GeViSoft SDK: GeViSoft SDK Index Page

GeViSoft SDK
  • Main Page
  • Modules
  • Namespaces
  • Classes
  • Files
GeViSoft SDK Index Page

Introduction

Welcome to Geutebrueck's GeViSoft SDK documentation.

You can either start your GeViSoft project by using the GeViAPIClient wrapper and its methods (recommended) or by using flat DLL function calls to GeViProcAPI.dll.

GeViAPIClient (recommended)

The best way to start is by inspecting the class GeViAPIClient and its methods.

GeViProcAPI functions

If you want to have a look at the flat GeViProcAPI.dll functions, it's best to start with database functions and then go on with the message functions and helper functions.

Generated on Mon Sep 26 2011 15:56:41 for GeViSoft SDK by doxygen 1.7.5.1


GeViSoft SDK: Modules

  • Namespaces
  • Classes
  • Files
Modules
Here is a list of all modules:
  • Database Functions
  • Message Functions
  • Helper Functions


GeViSoft SDK: Database Functions

Functions
Database Functions

These are the database functions provided by the GeViProcAPI Dll. More...

Functions

bool | GeViAPI_Database_SendPing (HGeViDatabase UserClient)
Sends a ping to the server for keep-alive checking.
bool | GeViAPI_Database_ActivateServerPing (HGeViDatabase UserClient, unsigned __int32 CheckPeriod)
Activates connection monitoring on server.
bool | GeViAPI_Database_Create (HGeViDatabase &Database, const char *Aliasname, const char *Address, const char *Username, const char *Password, const char *Username2, const char *Password2)
Creates a remote database object to access a GeViSoft database.
bool | GeViAPI_Database_Connect (HGeViDatabase Database, TConnectResult &ConnectResult, TGeViConnectProgress ACallback, void *AInstance)
Connects to a remote GeViSoft database object.
bool | GeViAPI_Database_Disconnect (HGeViDatabase Database)
Disconnects from a remote GeViSoft database object.
bool | GeViAPI_Database_SetCBNotification (HGeViDatabase Database, TGeViDatabaseNotification ACallback, void *AInstance)
Declares a callback function to receive notifications from the server.
bool | GeViAPI_Database_SendMessage (HGeViDatabase Database, const char *MessageBuffer, int BufferSize)
Sends a message to GeViSoft server.
bool | GeViAPI_Database_SendQuery (HGeViDatabase Database, const char *SendMessageBuffer, int SendBufferSize, char *&RecMessageBuffer, int &BytesRead, int TimeOut)
Sends a query to GeViSoft server.

Detailed Description

These are the database functions provided by the GeViProcAPI Dll.

Function Documentation

bool GeViAPI_Database_ActivateServerPing | ( | HGeViDatabase | UserClient,
 |  | unsigned __int32 | CheckPeriod
 | ) |  |

Activates connection monitoring on server.

This function activates a connection heart-beat check on the server. The server monitors the client and frees its listening port if the connection to the client is lost. Notice that this function does not implement heartbeat checking on the client side. To monitor the connection from the client side use GeViAPI_Database_SendPing().

Parameters:
UserClient handle to the database object inside the DLL.
CheckPeriod - time in milliseconds
  • 0 - deactivate;
  • else in range 100 - 60000
Returns:
true if the server ping could be activated
bool GeViAPI_Database_Connect | ( | HGeViDatabase | Database,
 |  | TConnectResult & | ConnectResult,
 |  | TGeViConnectProgress | ACallback,
 |  | void * | AInstance
 | ) |  |

Connects to a remote GeViSoft database object.

Parameters:
Database | handle to the database object inside the DLL.
ConnectResult | connectOK on success
ACallback | pointer to a callback function to show the connection progress. The callback is called from inside the DLL with updates of the status of the connection setup.
AInstance | pointer to the calling instance (normally "this").
Returns:
true if the command was sent to the server. Use ConnectResult for checking if the connection could be established!
bool GeViAPI_Database_Create | ( | HGeViDatabase & | Database,
 |  | const char * | Aliasname,
 |  | const char * | Address,
 |  | const char * | Username,
 |  | const char * | Password,
 |  | const char * | Username2,
 |  | const char * | Password2
 | ) |  |

Creates a remote database object to access a GeViSoft database.

Parameters:
Database | handle to the database object inside the DLL.
Aliasname | is an alias for the connection name. This can be left empty ("").
Address | is the IP address or hostname of the GeViServer to connect to.
Username | is the username to logon with.
Password | is the encrypted password for the GeViServer. You can get it from the plaintext password by calling the GeViAPI_EncodeString() method.
Username2 | is the second username to logon with. Can be left empty (""). It is only needed for systems that require multiple users to be logged in simultaneously for security reasons (dual control principle - two persons needed for authorization).
Password2 | is the second user's password. Can be left empty ("") if no dual control principle is enforced. It is only needed for systems that require multiple users to be logged in simultaneously for security reasons
Returns:
true if the command was sent to the server
See also:
GeViAPI_EncodeString()
bool GeViAPI_Database_Disconnect ( HGeViDatabase Database )

Disconnects from a remote GeViSoft database object.

Use this function to terminate your GeViSoft connection.

Parameters:
Database handle to the database object inside the DLL.
Returns:
true if the command was sent to the server
bool GeViAPI_Database_SendMessage | ( | HGeViDatabase | Database,
 |  | const char * | MessageBuffer,
 |  | int | BufferSize
 | ) |  |

Sends a message to GeViSoft server.

Parameters:
Database | handle to the database object inside the DLL.
MessageBuffer | char array that holds the message
BufferSize | length of MessageBuffer. Must not exceed GeViAPI_Namespace::GEVI_MAXACTIONLENGTH.
Returns:
true if the command was sent to the server.
bool GeViAPI_Database_SendPing ( HGeViDatabase UserClient )

Sends a ping to the server for keep-alive checking.

The function sends a ping packet to the server and waits for an answer. Best practice is to call this function regularly for a heartbeat check. If the return value is false, a new connection should be established.

Parameters:
UserClient handle to the database object inside the DLL.
Returns:
true if the connection is established and false if it is interrupted.
bool GeViAPI_Database_SendQuery | ( | HGeViDatabase | Database,
 |  | const char * | SendMessageBuffer,
 |  | int | SendBufferSize,
 |  | char *& | RecMessageBuffer,
 |  | int & | BytesRead,
 |  | int | TimeOut
 | ) |  |

Sends a query to GeViSoft server.

The query might either be a "state query" or a "database query"

Parameters:
Database | handle to the database object inside the DLL.
SendMessageBuffer | char array that holds the query to be sent
SendBufferSize | length of SendMessageBuffer. Must not exceed GeViAPI_Namespace::GEVI_MAXACTIONLENGTH.
RecMessageBuffer | char array to be filled with the server's answer. Should be freed with GeViAPI_FreeArray() after use.
BytesRead | length of the server answer
TimeOut | timeout for server answer in milliseconds.
Returns:
true if the command was sent to the server.
bool GeViAPI_Database_SetCBNotification | ( | HGeViDatabase | Database,
 |  | TGeViDatabaseNotification | ACallback,
 |  | void * | AInstance
 | ) |  |

Declares a callback function to receive notifications from the server.

Parameters:
Database | handle to the database object inside the DLL.
ACallback | is the callback function that should be called from the server on a new notification.
AInstance | is used as the Instance parameter during a call of the "ACallback" callback function
Returns:
true if the command was sent to the server.


GeViSoft SDK: Message Functions

Functions
Message Functions

These are the GeViSoft functions for CGeViMessage creation and conversion. More...

Functions

static CGeViMessage * | GeViAPI_Namespace::CGeViMessage::ReadBinMessage (const char *Buffer, int BufferLength, int &BytesRead)
Creates a new CGeViMessage from a binary buffer.
static CGeViMessage * | GeViAPI_Namespace::CGeViMessage::ReadASCIIMessage (const char *Buffer, int BufferLength, int &BytesRead)
Creates a new CGeViMessage from a text buffer.
bool | GeViAPI_Namespace::CGeViMessage::WriteBinMessage (char *Buffer, int BufferLength, int &BytesWrote)
Writes the contents of CGeViMessage into a binary buffer.
bool | GeViAPI_Namespace::CGeViMessage::WriteASCIIMessage (char *Buffer, int BufferLength, int &BytesWrote)
Writes the contents of CGeViMessage into a text buffer.

Detailed Description

These are the GeViSoft functions for CGeViMessage creation and conversion.

Function Documentation

static CGeViMessage* GeViAPI_Namespace::CGeViMessage::ReadASCIIMessage | ( | const char * | Buffer,
 |  | int | BufferLength,
 |  | int & | BytesRead
 | ) |  | [static]

Creates a new CGeViMessage from a text buffer.

This method creates a new CGeViMessage from a text buffer

Parameters:
Buffer | ASCII representation of the message
BufferLength | length of the Buffer. Must not exceed GeViAPI_Namespace::GEVI_MAXACTIONLENGTH.
BytesRead | length of the message found in the buffer in bytes.
Returns:
a new CGeViMessage on success or NULL if the message could not be created.
static CGeViMessage* GeViAPI_Namespace::CGeViMessage::ReadBinMessage | ( | const char * | Buffer,
 |  | int | BufferLength,
 |  | int & | BytesRead
 | ) |  | [static]

Creates a new CGeViMessage from a binary buffer.

This method creates a new CGeViMessage from a binary buffer

Parameters:
Buffer | binary representation of the message
BufferLength | length of the Buffer. Must not exceed GeViAPI_Namespace::GEVI_MAXACTIONLENGTH.
BytesRead | length of the message found in the buffer in bytes.
Returns:
a new CGeViMessage on success or NULL if the message could not be created.
bool GeViAPI_Namespace::CGeViMessage::WriteASCIIMessage | ( | char * | Buffer,
 |  | int | BufferLength,
 |  | int & | BytesWrote
 | ) |  |

Writes the contents of CGeViMessage into a text buffer.

This method fills a buffer with the ASCII representation of the calling message.

Parameters:
Buffer | ASCII representation of the message
BufferLength | length of the Buffer. Should be GeViAPI_Namespace::GEVI_MAXACTIONLENGTH.
BytesWrote | length of the message found in the buffer in bytes.
Returns:
true on success or false if the buffer could not be written.
bool GeViAPI_Namespace::CGeViMessage::WriteBinMessage | ( | char * | Buffer,
 |  | int | BufferLength,
 |  | int & | BytesWrote
 | ) |  |

Writes the contents of CGeViMessage into a binary buffer.

This method fills a buffer with the binary representation of the calling message.

Parameters:
Buffer | binary representation of the message
BufferLength | length of the Buffer. Should be GeViAPI_Namespace::GEVI_MAXACTIONLENGTH.
BytesWrote | length of the message found in the buffer in bytes.
Returns:
true on success or false if the buffer could not be written.


GeViSoft SDK: Helper Functions

Functions
Helper Functions

These are the helper functions provided by the GeViProcAPI Dll. More...

Functions

bool | GeViAPI_EncodeString (char *Dest, const char *Source, int DestSize)
Encodes the plain text password.
bool | GeViAPI_FreeArray (char *Pointer)
Frees memory allocated in the DLL.

Detailed Description

These are the helper functions provided by the GeViProcAPI Dll.

Function Documentation

bool GeViAPI_EncodeString | ( | char * | Dest,
 |  | const char * | Source,
 |  | int | DestSize
 | ) |  |

Encodes the plain text password.

This function encodes the plain text password into the encrypted one used by GeViSoft

Parameters:
Dest | - destination char* filled by the Dll method with the encrypted password. Should be of length 33 (char Dest[33]).
Source | - the plain text password string
DestSize | - length of the destination char array. Should be 33 - (sizeof(Dest))
bool GeViAPI_FreeArray ( char * Pointer )

Frees memory allocated in the DLL.

Execute this function to free buffers allocated in the DLL by your application.

Parameters:
Pointer Array to be freed
Returns:
true if the command was sent to the server


GeViSoft SDK: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
GeViAPI_Namespace::CAction |
GeViAPI_Namespace::CActivity |
GeViAPI_Namespace::CDataBaseAnswer |
GeViAPI_Namespace::CDataBaseFilter |
GeViAPI_Namespace::CDataBaseQuery |
GeViAPI_Namespace::CGeViMessage |
GeViAPI_Namespace::CReferenceObject |
GeViAPI_Namespace::CStateAnswer |
GeViAPI_Namespace::CStateQuery |
EGeVi | Base class that handles exceptions thrown by the DLL
EGeViCmdAborted |
EGeViCmdNotImplemented |
EGeViGeneric |
EGeViInvalidHandle |
EGeViIPConnection |
EGeViNoMessages |
EGeViSystem |
EGeViTimeout |
EGeViUnknown |
GeViAPIClient | Inside the GeViAPIClient class, the commmunication with GeViServer is handled
GeViHandleStruct | Structure to hold a handle to a GeViSoft Connection
GeViAPI_Namespace::TActionData |
GeViAPI_Namespace::TGeViDateTime |
TMessageEntry |
TMscGenericDateTime | Structure to hold the system time representation
TMscNativeDateTime | Structure to hold GeViSoft's internal time representation


GeViSoft SDK: GeViAPI_Namespace::CAction Class Reference

  • Class Members
  • GeViAPI_Namespace
  • CAction
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Friends
GeViAPI_Namespace::CAction Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CAction:
[legend]
Collaboration diagram for GeViAPI_Namespace::CAction:
[legend]

List of all members.

Public Member Functions

virtual const char * | GetActionName (void) const =0

Static Public Member Functions

static TActionCode | GetActionCodeByName (const char *Name)

Public Attributes

const TActionKind | m_ActionKind
const TActionCode | m_ActionCode

Protected Member Functions

CAction (TActionKind ActionKind, TActionCode ActionCode)

Static Protected Member Functions

static CAction * | ReadBuffer (CGeViTransferBuffer *Buffer)

Friends

class | CGeViMessage

Constructor & Destructor Documentation

GeViAPI_Namespace::CAction::CAction | ( | TActionKind | ActionKind,
 |  | TActionCode | ActionCode
 | ) |  | [protected]

Member Function Documentation

static TActionCode GeViAPI_Namespace::CAction::GetActionCodeByName ( const char * Name ) [static]
virtual const char* GeViAPI_Namespace::CAction::GetActionName ( void ) const [pure virtual]
static CAction* GeViAPI_Namespace::CAction::ReadBuffer ( CGeViTransferBuffer * Buffer ) [static, protected]

Friends And Related Function Documentation

friend class CGeViMessage [friend]

Member Data Documentation

const TActionCode GeViAPI_Namespace::CAction::m_ActionCode
const TActionKind GeViAPI_Namespace::CAction::m_ActionKind
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CActivity Class Reference

  • GeViAPI_Namespace
  • CActivity
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Friends
GeViAPI_Namespace::CActivity Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CActivity:
[legend]
Collaboration diagram for GeViAPI_Namespace::CActivity:
[legend]

List of all members.

Public Member Functions

virtual const char * | GetActivityName (void) const =0

Static Public Member Functions

static TActivityCode | GetActivityCodeByName (const char *Name)

Public Attributes

const TActivityKind | m_ActivityKind
const TActivityCode | m_ActivityCode

Protected Member Functions

CActivity (TActivityKind ActivityKind, TActivityCode ActivityCode)

Static Protected Member Functions

static CActivity * | ReadBuffer (CGeViTransferBuffer *Buffer)

Friends

class | CGeViMessage

Constructor & Destructor Documentation

GeViAPI_Namespace::CActivity::CActivity | ( | TActivityKind | ActivityKind,
 |  | TActivityCode | ActivityCode
 | ) |  | [protected]

Member Function Documentation

static TActivityCode GeViAPI_Namespace::CActivity::GetActivityCodeByName ( const char * Name ) [static]
virtual const char* GeViAPI_Namespace::CActivity::GetActivityName ( void ) const [pure virtual]
static CActivity* GeViAPI_Namespace::CActivity::ReadBuffer ( CGeViTransferBuffer * Buffer ) [static, protected]

Friends And Related Function Documentation

friend class CGeViMessage [friend]

Member Data Documentation

const TActivityCode GeViAPI_Namespace::CActivity::m_ActivityCode
const TActivityKind GeViAPI_Namespace::CActivity::m_ActivityKind
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CDataBaseAnswer Class Reference

  • GeViAPI_Namespace
  • CDataBaseAnswer
Public Member Functions | Static Public Member Functions | Public Attributes | Friends
GeViAPI_Namespace::CDataBaseAnswer Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CDataBaseAnswer:
[legend]
Collaboration diagram for GeViAPI_Namespace::CDataBaseAnswer:
[legend]

List of all members.

Public Member Functions

CDataBaseAnswer (TDBAnswerCode AnswerCode)
virtual const char * | GetDataBaseAnswerName (void) const =0

Static Public Member Functions

static CDataBaseAnswer * | ReadBuffer (CGeViTransferBuffer *Buffer)
static TDBAnswerCode | GetDataBaseAnswerCodeByName (const char *Name)

Public Attributes

const TDBAnswerCode | m_AnswerCode

Friends

class | CGeViMessage

Constructor & Destructor Documentation

GeViAPI_Namespace::CDataBaseAnswer::CDataBaseAnswer ( TDBAnswerCode AnswerCode )

Member Function Documentation

static TDBAnswerCode GeViAPI_Namespace::CDataBaseAnswer::GetDataBaseAnswerCodeByName ( const char * Name ) [static]
virtual const char* GeViAPI_Namespace::CDataBaseAnswer::GetDataBaseAnswerName ( void ) const [pure virtual]
static CDataBaseAnswer* GeViAPI_Namespace::CDataBaseAnswer::ReadBuffer ( CGeViTransferBuffer * Buffer ) [static]

Friends And Related Function Documentation

friend class CGeViMessage [friend]

Member Data Documentation

const TDBAnswerCode GeViAPI_Namespace::CDataBaseAnswer::m_AnswerCode
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CDataBaseFilter Class Reference

  • GeViAPI_Namespace
  • CDataBaseFilter
Protected Member Functions
GeViAPI_Namespace::CDataBaseFilter Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CDataBaseFilter:
[legend]
Collaboration diagram for GeViAPI_Namespace::CDataBaseFilter:
[legend]

List of all members.

Protected Member Functions

CDataBaseFilter (TDBQueryCode QueryCode, __int64 DBHandle)

Constructor & Destructor Documentation

GeViAPI_Namespace::CDataBaseFilter::CDataBaseFilter | ( | TDBQueryCode | QueryCode,
 |  | __int64 | DBHandle
 | ) |  | [protected]
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CDataBaseQuery Class Reference

  • GeViAPI_Namespace
  • CDataBaseQuery
Public Member Functions | Static Public Member Functions | Public Attributes | Friends
GeViAPI_Namespace::CDataBaseQuery Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CDataBaseQuery:
[legend]
Collaboration diagram for GeViAPI_Namespace::CDataBaseQuery:
[legend]

List of all members.

Public Member Functions

CDataBaseQuery (TDBQueryCode QueryCode, __int64 DBHandle=0, bool FilterQuery=false)
virtual const char * | GetDataBaseQueryName (void) const =0

Static Public Member Functions

static CDataBaseQuery * | ReadBuffer (CGeViTransferBuffer *Buffer)
static TDBQueryCode | GetDataBaseQueryCodeByName (const char *Name)

Public Attributes

__int64 | m_Handle
const TDBQueryCode | m_QueryCode
const bool | m_FilterQuery

Friends

class | CGeViMessage

Constructor & Destructor Documentation

GeViAPI_Namespace::CDataBaseQuery::CDataBaseQuery | ( | TDBQueryCode | QueryCode,
 |  | __int64 | DBHandle = 0,
 |  | bool | FilterQuery = false
 | ) |  |

Member Function Documentation

static TDBQueryCode GeViAPI_Namespace::CDataBaseQuery::GetDataBaseQueryCodeByName ( const char * Name ) [static]
virtual const char* GeViAPI_Namespace::CDataBaseQuery::GetDataBaseQueryName ( void ) const [pure virtual]
static CDataBaseQuery* GeViAPI_Namespace::CDataBaseQuery::ReadBuffer ( CGeViTransferBuffer * Buffer ) [static]

Friends And Related Function Documentation

friend class CGeViMessage [friend]

Member Data Documentation

const bool GeViAPI_Namespace::CDataBaseQuery::m_FilterQuery
__int64 GeViAPI_Namespace::CDataBaseQuery::m_Handle
const TDBQueryCode GeViAPI_Namespace::CDataBaseQuery::m_QueryCode
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CGeViMessage Class Reference

  • GeViAPI_Namespace
  • CGeViMessage
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions
GeViAPI_Namespace::CGeViMessage Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CGeViMessage:
[legend]
Collaboration diagram for GeViAPI_Namespace::CGeViMessage:
[legend]

List of all members.

Public Member Functions

bool | isAction () const
bool | isActivity () const
bool | isStateQuery () const
bool | isStateAnswer () const
bool | isDatabaseQuery () const
bool | isDatabaseAnswer () const
bool | WriteBinMessage (char *Buffer, int BufferLength, int &BytesWrote)
Writes the contents of CGeViMessage into a binary buffer.
bool | WriteASCIIMessage (char *Buffer, int BufferLength, int &BytesWrote)
Writes the contents of CGeViMessage into a text buffer.

Static Public Member Functions

static CGeViMessage * | ReadBinMessage (const char *Buffer, int BufferLength, int &BytesRead)
Creates a new CGeViMessage from a binary buffer.
static CGeViMessage * | ReadASCIIMessage (const char *Buffer, int BufferLength, int &BytesRead)
Creates a new CGeViMessage from a text buffer.

Public Attributes

TClientID m_SenderID
TClientID m_RecepientID
const TMessageKind | m_MessageKind

Protected Member Functions

CGeViMessage (TMessageKind MessageKind)
virtual bool | WriteBuffer (CGeViTransferBuffer *Buffer, int &BytesWrote) const =0

Static Protected Member Functions

static CGeViMessage * | ReadBuffer (CGeViTransferBuffer *Buffer, int &BytesRead)

Constructor & Destructor Documentation

GeViAPI_Namespace::CGeViMessage::CGeViMessage ( TMessageKind MessageKind ) [protected]

Member Function Documentation

bool GeViAPI_Namespace::CGeViMessage::isAction ( ) const [inline]
bool GeViAPI_Namespace::CGeViMessage::isActivity ( ) const [inline]
bool GeViAPI_Namespace::CGeViMessage::isDatabaseAnswer ( ) const [inline]
bool GeViAPI_Namespace::CGeViMessage::isDatabaseQuery ( ) const [inline]
bool GeViAPI_Namespace::CGeViMessage::isStateAnswer ( ) const [inline]
bool GeViAPI_Namespace::CGeViMessage::isStateQuery ( ) const [inline]
static CGeViMessage* GeViAPI_Namespace::CGeViMessage::ReadBuffer | ( | CGeViTransferBuffer * | Buffer,
 |  | int & | BytesRead
 | ) |  | [static, protected]
virtual bool GeViAPI_Namespace::CGeViMessage::WriteBuffer | ( | CGeViTransferBuffer * | Buffer,
 |  | int & | BytesWrote
 | ) |  | const [protected, pure virtual]

Member Data Documentation

const TMessageKind GeViAPI_Namespace::CGeViMessage::m_MessageKind
TClientID GeViAPI_Namespace::CGeViMessage::m_RecepientID
TClientID GeViAPI_Namespace::CGeViMessage::m_SenderID
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CReferenceObject Class Reference

  • GeViAPI_Namespace
  • CReferenceObject
Public Member Functions | Protected Member Functions
GeViAPI_Namespace::CReferenceObject Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CReferenceObject:
[legend]

List of all members.

Public Member Functions

CReferenceObject ()
void | IncRef ()
void | DecRef ()
void | DeleteObject ()
long | GetCounter ()

Protected Member Functions

virtual | ~CReferenceObject ()

Constructor & Destructor Documentation

virtual GeViAPI_Namespace::CReferenceObject::~CReferenceObject ( ) [protected, virtual]
GeViAPI_Namespace::CReferenceObject::CReferenceObject ( ) [inline]

Member Function Documentation

void GeViAPI_Namespace::CReferenceObject::DecRef ( )
void GeViAPI_Namespace::CReferenceObject::DeleteObject ( )
long GeViAPI_Namespace::CReferenceObject::GetCounter ( ) [inline]
void GeViAPI_Namespace::CReferenceObject::IncRef ( )
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CStateAnswer Class Reference

  • GeViAPI_Namespace
  • CStateAnswer
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Friends
GeViAPI_Namespace::CStateAnswer Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CStateAnswer:
[legend]
Collaboration diagram for GeViAPI_Namespace::CStateAnswer:
[legend]

List of all members.

Public Member Functions

virtual const char * | GetStateAnswerName (void) const =0

Static Public Member Functions

static TStateAnswerKind | GetStateAnswerCodeByName (const char *Name)

Public Attributes

const TStateAnswerKind | m_AnswerKind

Protected Member Functions

CStateAnswer (TStateAnswerKind AnswerKind)

Static Protected Member Functions

static CStateAnswer * | ReadBuffer (CGeViTransferBuffer *Buffer)

Friends

class | CGeViMessage

Constructor & Destructor Documentation

GeViAPI_Namespace::CStateAnswer::CStateAnswer ( TStateAnswerKind AnswerKind ) [protected]

Member Function Documentation

static TStateAnswerKind GeViAPI_Namespace::CStateAnswer::GetStateAnswerCodeByName ( const char * Name ) [static]
virtual const char* GeViAPI_Namespace::CStateAnswer::GetStateAnswerName ( void ) const [pure virtual]
static CStateAnswer* GeViAPI_Namespace::CStateAnswer::ReadBuffer ( CGeViTransferBuffer * Buffer ) [static, protected]

Friends And Related Function Documentation

friend class CGeViMessage [friend]

Member Data Documentation

const TStateAnswerKind GeViAPI_Namespace::CStateAnswer::m_AnswerKind
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: GeViAPI_Namespace::CStateQuery Class Reference

  • GeViAPI_Namespace
  • CStateQuery
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Friends
GeViAPI_Namespace::CStateQuery Class Reference

#include <MessageBase.h>

Inheritance diagram for GeViAPI_Namespace::CStateQuery:
[legend]
Collaboration diagram for GeViAPI_Namespace::CStateQuery:
[legend]

List of all members.

Public Member Functions

virtual const char * | GetStateQueryName (void) const =0

Static Public Member Functions

static TStateQueryKind | GetStateQueryCodeByName (const char *Name)

Public Attributes

const TStateQueryKind | m_QueryKind

Protected Member Functions

CStateQuery (TStateQueryKind QueryKind)

Static Protected Member Functions

static CStateQuery * | ReadBuffer (CGeViTransferBuffer *Buffer)

Friends

class | CGeViMessage

Constructor & Destructor Documentation

GeViAPI_Namespace::CStateQuery::CStateQuery ( TStateQueryKind QueryKind ) [protected]

Member Function Documentation

static TStateQueryKind GeViAPI_Namespace::CStateQuery::GetStateQueryCodeByName ( const char * Name ) [static]
virtual const char* GeViAPI_Namespace::CStateQuery::GetStateQueryName ( void ) const [pure virtual]
static CStateQuery* GeViAPI_Namespace::CStateQuery::ReadBuffer ( CGeViTransferBuffer * Buffer ) [static, protected]

Friends And Related Function Documentation

friend class CGeViMessage [friend]

Member Data Documentation

const TStateQueryKind GeViAPI_Namespace::CStateQuery::m_QueryKind
The documentation for this class was generated from the following file:
  • MessageBase.h


GeViSoft SDK: EGeVi Class Reference

Public Member Functions | Public Attributes
EGeVi Class Reference

Base class that handles exceptions thrown by the DLL. More...

#include <GeViAPIClient.h>

Inheritance diagram for EGeVi:
[legend]

List of all members.

Public Member Functions

EGeVi (const char *geViMessage)
EGeVi (const char *geViMessage, int geViError, int geViErrorClass)

Public Attributes

int | GeViError
int | GeViErrorClass

Detailed Description

Base class that handles exceptions thrown by the DLL.

Constructor & Destructor Documentation

EGeVi::EGeVi ( const char * geViMessage ) [inline]

Here is the caller graph for this function:

EGeVi::EGeVi | ( | const char * | geViMessage,
 |  | int | geViError,
 |  | int | geViErrorClass
 | ) |  | [inline]

Member Data Documentation

int EGeVi::GeViError
int EGeVi::GeViErrorClass
The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViCmdAborted Class Reference

Public Member Functions
EGeViCmdAborted Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViCmdAborted:
[legend]
Collaboration diagram for EGeViCmdAborted:
[legend]

List of all members.

Public Member Functions

EGeViCmdAborted (const char *Message)

Constructor & Destructor Documentation

EGeViCmdAborted::EGeViCmdAborted ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViCmdNotImplemented Class Reference

Public Member Functions
EGeViCmdNotImplemented Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViCmdNotImplemented:
[legend]
Collaboration diagram for EGeViCmdNotImplemented:
[legend]

List of all members.

Public Member Functions

EGeViCmdNotImplemented (const char *Message)

Constructor & Destructor Documentation

EGeViCmdNotImplemented::EGeViCmdNotImplemented ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViGeneric Class Reference

Public Member Functions
EGeViGeneric Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViGeneric:
[legend]
Collaboration diagram for EGeViGeneric:
[legend]

List of all members.

Public Member Functions

EGeViGeneric (const char *Message)

Constructor & Destructor Documentation

EGeViGeneric::EGeViGeneric ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViInvalidHandle Class Reference

Public Member Functions
EGeViInvalidHandle Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViInvalidHandle:
[legend]
Collaboration diagram for EGeViInvalidHandle:
[legend]

List of all members.

Public Member Functions

EGeViInvalidHandle (const char *Message)

Constructor & Destructor Documentation

EGeViInvalidHandle::EGeViInvalidHandle ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViIPConnection Class Reference

Public Member Functions
EGeViIPConnection Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViIPConnection:
[legend]
Collaboration diagram for EGeViIPConnection:
[legend]

List of all members.

Public Member Functions

EGeViIPConnection (const char *Message)

Constructor & Destructor Documentation

EGeViIPConnection::EGeViIPConnection ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViNoMessages Class Reference

Public Member Functions
EGeViNoMessages Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViNoMessages:
[legend]
Collaboration diagram for EGeViNoMessages:
[legend]

List of all members.

Public Member Functions

EGeViNoMessages (const char *Message)

Constructor & Destructor Documentation

EGeViNoMessages::EGeViNoMessages ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViSystem Class Reference

Public Member Functions
EGeViSystem Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViSystem:
[legend]
Collaboration diagram for EGeViSystem:
[legend]

List of all members.

Public Member Functions

EGeViSystem (const char *Message)

Constructor & Destructor Documentation

EGeViSystem::EGeViSystem ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViTimeout Class Reference

Public Member Functions
EGeViTimeout Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViTimeout:
[legend]
Collaboration diagram for EGeViTimeout:
[legend]

List of all members.

Public Member Functions

EGeViTimeout (const char *Message)

Constructor & Destructor Documentation

EGeViTimeout::EGeViTimeout ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: EGeViUnknown Class Reference

Public Member Functions
EGeViUnknown Class Reference

#include <GeViAPIClient.h>

Inheritance diagram for EGeViUnknown:
[legend]
Collaboration diagram for EGeViUnknown:
[legend]

List of all members.

Public Member Functions

EGeViUnknown (const char *Message)

Constructor & Destructor Documentation

EGeViUnknown::EGeViUnknown ( const char * Message ) [inline]

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: GeViAPIClient Class Reference

Public Member Functions | Static Public Member Functions
GeViAPIClient Class Reference

Inside the GeViAPIClient class, the commmunication with GeViServer is handled. More...

#include <GeViAPIClient.h>

List of all members.

Public Member Functions

GeViAPIClient (const char *Aliasname, const char *Address, const char *Username, const char *Password, const char *Username2, const char *Password2)
Constructor for a GeViAPIClient object.
~GeViAPIClient ()
Destructor for a GeViAPIClient object.
GeViAPI_Namespace::TConnectResult | Connect (const GeViAPI_Namespace::TGeViConnectProgress ACallback, void *AInstance)
Connects to the GeViSoft Server.
void | Disconnect ()
Disconnects from the GeViSoft Server.
void | SetCBNotification (const GeViAPI_Namespace::TGeViDatabaseNotification ACallback, void *AInstance)
Sets the callback for receiving notifications.
void | SendMessage (GeViAPI_Namespace::CGeViMessage *GeViMessage)
Send an action message.
GeViAPI_Namespace::CDataBaseAnswer * | SendDatabaseQuery (GeViAPI_Namespace::CDataBaseQuery *GeViMessage, const int timeout_ms)
Sends a database query.
GeViAPI_Namespace::CStateAnswer * | SendStateQuery (GeViAPI_Namespace::CStateQuery *GeViQuery, const int timeout_ms)
Sends a state query.
GeViAPI_Namespace::HGeViDatabase | GetDatabase (void)
Gets the database handle.
bool | SendPing ()
Sends a ping to the server for keep-alive checking.
bool | ActivateServerPing (unsigned __int32 CheckPeriod)

Static Public Member Functions

static void | EncodePassword (char *Dest, const char *Source, int DestSize)
Encodes a password string.

Detailed Description

Inside the GeViAPIClient class, the commmunication with GeViServer is handled.

The GeViAPIClient class wraps the flat functions provided by the GeViProcAPI.dll

Constructor & Destructor Documentation

GeViAPIClient::GeViAPIClient | ( | const char * | Aliasname,
 |  | const char * | Address,
 |  | const char * | Username,
 |  | const char * | Password,
 |  | const char * | Username2,
 |  | const char * | Password2
 | ) |  |

Constructor for a GeViAPIClient object.

Parameters:
Aliasname | is an alias for the connection name. This can be left empty ("").
Address | is the IP address or hostname of the GeViServer to connect to.
Username | is the username to logon with.
Password | is the encrypted password for the GeViServer. You can get it from the plaintext password by calling the EncodePassword() method.
Username2 | is the second username to logon with. Can be left empty (""). It is only needed for systems that require multiple users to be logged in simultaneously for security reasons (dual control principle - two persons needed for authorization).
Password2 | is the second user's password. Can be left empty ("") if no dual control principle is enforced. It is only needed for systems that require multiple users to be logged in simultaneously for security reasons
See also:
EncodePassword()
GeViAPIClient::~GeViAPIClient ( )

Destructor for a GeViAPIClient object.

Member Function Documentation

bool GeViAPIClient::ActivateServerPing ( unsigned __int32 CheckPeriod )
GeViAPI_Namespace::TConnectResult GeViAPIClient::Connect | ( | const GeViAPI_Namespace::TGeViConnectProgress | ACallback,
 |  | void * | AInstance
 | ) |  |

Connects to the GeViSoft Server.

This method wraps the call to the GeViAPU_Database_Connect function.

Parameters:
ACallback | - pointer to your callback function to show the connection progress. The callback is called from inside the DLL with updates of the status of the connection setup.
AInstance | - pointer to the calling instance (normally "this").
Returns:
the connection result. If the connection could be established, this is connectOK
void GeViAPIClient::Disconnect ( )

Disconnects from the GeViSoft Server.

static void GeViAPIClient::EncodePassword | ( | char * | Dest,
 |  | const char * | Source,
 |  | int | DestSize
 | ) |  | [static]

Encodes a password string.

This method encodes the plain password (source) into an encrypted password as used by GeViSoft (destination).

Parameters:
Dest | - destination char* filled by the Dll method with the encrypted password. Should be of length 33 (char Dest[33]).
Source | - the plain text password string
DestSize | - length of the destination char array. Should be 33 - (sizeof(Dest))
GeViAPI_Namespace::HGeViDatabase GeViAPIClient::GetDatabase ( void )

Gets the database handle.

This is a getter method for the database handle of the current GeViServer connection

Returns:
the database handle of the current GeViServer connection
GeViAPI_Namespace::CDataBaseAnswer* GeViAPIClient::SendDatabaseQuery | ( | GeViAPI_Namespace::CDataBaseQuery * | GeViMessage,
 |  | const int | timeout_ms
 | ) |  |

Sends a database query.

This method sends a database query to the server. The call is blocking and returns after a database answer has been received or the query has timed out.

Parameters:
GeViMessage | - the message to be sent.
timeout_ms | - milliseconds after which a connection attempt is aborted.
Returns:
a pointer to a CDataBaseAnswer object.
void GeViAPIClient::SendMessage ( GeViAPI_Namespace::CGeViMessage * GeViMessage )

Send an action message.

Parameters:
GeViMessage - the GeViMessage to be sent.
bool GeViAPIClient::SendPing ( )

Sends a ping to the server for keep-alive checking.

The function sends a ping packet to the server and waits for an answer. Best practice is to call this function regularly for a heartbeat check. If the return value is false, a new connection should be established.

Returns:
true if the connection is established and false if it is interrupted.
GeViAPI_Namespace::CStateAnswer* GeViAPIClient::SendStateQuery | ( | GeViAPI_Namespace::CStateQuery * | GeViQuery,
 |  | const int | timeout_ms
 | ) |  |

Sends a state query.

This method sends a state query to the server. The call is blocking and returns after a database answer has been received or the query has timed out.

Parameters:
GeViQuery | - the query to be sent.
timeout_ms | - milliseconds after which a connection attempt is aborted.
Returns:
a pointer to a CStateAnswer object.
void GeViAPIClient::SetCBNotification | ( | const GeViAPI_Namespace::TGeViDatabaseNotification | ACallback,
 |  | void * | AInstance
 | ) |  |

Sets the callback for receiving notifications.

The callback is called by the GeViProcAPI.dll every time a notification is received. In the callback, you can process the notifications.

Parameters:
ACallback | - pointer to your callback function to show the connection progress. The callback is called from inside the DLL with updates of the status of the connection setup.
AInstance | - pointer to the calling instance (normally "this").
The documentation for this class was generated from the following file:
  • GeViAPIClient.h


GeViSoft SDK: GeViHandleStruct Struct Reference

GeViHandleStruct Struct Reference

Structure to hold a handle to a GeViSoft Connection. More...

#include <GeViProcAPI.h>

Detailed Description

Structure to hold a handle to a GeViSoft Connection.

The documentation for this struct was generated from the following file:
  • GeViProcAPI.h


GeViSoft SDK: GeViAPI_Namespace::TActionData Class Reference

  • GeViAPI_Namespace
  • TActionData
Public Member Functions | Public Attributes
GeViAPI_Namespace::TActionData Class Reference

#include <GeViConst.h>

List of all members.

Public Member Functions

TActionData ()
~TActionData ()
TActionData (const TActionData &Other)
TActionData & | operator= (const TActionData &Other)
void | Clear ()

Public Attributes

char * | m_Buffer
int | m_BufferSize

Constructor & Destructor Documentation

GeViAPI_Namespace::TActionData::TActionData ( ) [inline]
GeViAPI_Namespace::TActionData::~TActionData ( ) [inline]

Here is the call graph for this function:

GeViAPI_Namespace::TActionData::TActionData ( const TActionData & Other ) [inline]

Member Function Documentation

void GeViAPI_Namespace::TActionData::Clear ( ) [inline]

Here is the caller graph for this function:

TActionData& GeViAPI_Namespace::TActionData::operator= ( const TActionData & Other ) [inline]

Here is the call graph for this function:

Member Data Documentation

char* GeViAPI_Namespace::TActionData::m_Buffer
int GeViAPI_Namespace::TActionData::m_BufferSize
The documentation for this class was generated from the following file:
  • GeViConst.h


GeViSoft SDK: GeViAPI_Namespace::TGeViDateTime Struct Reference

  • GeViAPI_Namespace
  • TGeViDateTime
Public Attributes
GeViAPI_Namespace::TGeViDateTime Struct Reference

#include <GeViConst.h>

List of all members.

Public Attributes

unsigned int | TimePart
unsigned int | DatePart

Member Data Documentation

unsigned int GeViAPI_Namespace::TGeViDateTime::DatePart
unsigned int GeViAPI_Namespace::TGeViDateTime::TimePart
The documentation for this struct was generated from the following file:
  • GeViConst.h


GeViSoft SDK: TMessageEntry Struct Reference

Public Attributes
TMessageEntry Struct Reference

#include <GeViProcAPI.h>

List of all members.

Public Attributes

char * | Buffer
__int32 | Length

Member Data Documentation

char* TMessageEntry::Buffer
__int32 TMessageEntry::Length
The documentation for this struct was generated from the following file:
  • GeViProcAPI.h


GeViSoft SDK: TMscGenericDateTime Struct Reference

Public Attributes
TMscGenericDateTime Struct Reference

Structure to hold the system time representation. More...

#include <GeViProcAPI.h>

List of all members.

Public Attributes

unsigned int | Year
unsigned int | Month
unsigned int | Day
unsigned int | DoW
Day of the Week.
unsigned int | Hour
unsigned int | Min
unsigned int | Sec
unsigned int | MSec

Detailed Description

Structure to hold the system time representation.

Member Data Documentation

unsigned int TMscGenericDateTime::Day
unsigned int TMscGenericDateTime::DoW

Day of the Week.

unsigned int TMscGenericDateTime::Hour
unsigned int TMscGenericDateTime::Min
unsigned int TMscGenericDateTime::Month
unsigned int TMscGenericDateTime::MSec
unsigned int TMscGenericDateTime::Sec
unsigned int TMscGenericDateTime::Year
The documentation for this struct was generated from the following file:
  • GeViProcAPI.h


GeViSoft SDK: TMscNativeDateTime Struct Reference

Public Attributes
TMscNativeDateTime Struct Reference

Structure to hold GeViSoft's internal time representation. More...

#include <GeViProcAPI.h>

List of all members.

Public Attributes

unsigned int | TimePart
Number of milliseconds since midnight.
unsigned int | DatePart
One plus number of days since 1/1/0001.

Detailed Description

Structure to hold GeViSoft's internal time representation.

Member Data Documentation

unsigned int TMscNativeDateTime::DatePart

One plus number of days since 1/1/0001.

unsigned int TMscNativeDateTime::TimePart

Number of milliseconds since midnight.

The documentation for this struct was generated from the following file:
  • GeViProcAPI.h


GeViSoft SDK: Class Index

Class Index
C | E | G | T
C
CGeViMessage (GeViAPI_Namespace) EGeViCmdAborted EGeViTimeout TGeViDateTime (GeViAPI_Namespace)
CReferenceObject (GeViAPI_Namespace) EGeViCmdNotImplemented EGeViUnknown TMessageEntry
CAction (GeViAPI_Namespace) CStateAnswer (GeViAPI_Namespace) EGeViGeneric
G
TMscGenericDateTime
CActivity (GeViAPI_Namespace) CStateQuery (GeViAPI_Namespace) EGeViInvalidHandle TMscNativeDateTime
CDataBaseAnswer (GeViAPI_Namespace)
E
EGeViIPConnection GeViAPIClient
CDataBaseFilter (GeViAPI_Namespace) EGeViNoMessages GeViHandleStruct
CDataBaseQuery (GeViAPI_Namespace) EGeVi EGeViSystem
T
TActionData (GeViAPI_Namespace)
C | E | G | T


GeViSoft SDK: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • GeViAPI_Namespace::CReferenceObject
    • GeViAPI_Namespace::CGeViMessage
      • GeViAPI_Namespace::CAction
      • GeViAPI_Namespace::CActivity
      • GeViAPI_Namespace::CDataBaseAnswer
      • GeViAPI_Namespace::CDataBaseQuery
        • GeViAPI_Namespace::CDataBaseFilter
      • GeViAPI_Namespace::CStateAnswer
      • GeViAPI_Namespace::CStateQuery
  • EGeVi
    • EGeViCmdAborted
    • EGeViCmdNotImplemented
    • EGeViGeneric
    • EGeViInvalidHandle
    • EGeViIPConnection
    • EGeViNoMessages
    • EGeViSystem
    • EGeViTimeout
    • EGeViUnknown
  • GeViAPIClient
  • GeViHandleStruct
  • GeViAPI_Namespace::TActionData
  • GeViAPI_Namespace::TGeViDateTime
  • TMessageEntry
  • TMscGenericDateTime
  • TMscNativeDateTime


GeViSoft SDK: Class Members

  • All
  • Functions
  • Variables
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • w
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivateServerPing() : GeViAPIClient

- b -

  • Buffer : TMessageEntry

- c -

  • CAction() : GeViAPI_Namespace::CAction
  • CActivity() : GeViAPI_Namespace::CActivity
  • CDataBaseAnswer() : GeViAPI_Namespace::CDataBaseAnswer
  • CDataBaseFilter() : GeViAPI_Namespace::CDataBaseFilter
  • CDataBaseQuery() : GeViAPI_Namespace::CDataBaseQuery
  • CGeViMessage
: GeViAPI_Namespace::CStateQuery
, GeViAPI_Namespace::CStateAnswer
, GeViAPI_Namespace::CDataBaseQuery
, GeViAPI_Namespace::CDataBaseAnswer
, GeViAPI_Namespace::CAction
, GeViAPI_Namespace::CGeViMessage
, GeViAPI_Namespace::CActivity
  • Clear() : GeViAPI_Namespace::TActionData
  • Connect() : GeViAPIClient
  • CReferenceObject() : GeViAPI_Namespace::CReferenceObject
  • CStateAnswer() : GeViAPI_Namespace::CStateAnswer
  • CStateQuery() : GeViAPI_Namespace::CStateQuery

- d -

  • DatePart : GeViAPI_Namespace::TGeViDateTime , TMscNativeDateTime
  • Day : TMscGenericDateTime
  • DecRef() : GeViAPI_Namespace::CReferenceObject
  • DeleteObject() : GeViAPI_Namespace::CReferenceObject
  • Disconnect() : GeViAPIClient
  • DoW : TMscGenericDateTime

- e -

  • EGeVi() : EGeVi
  • EGeViCmdAborted() : EGeViCmdAborted
  • EGeViCmdNotImplemented() : EGeViCmdNotImplemented
  • EGeViGeneric() : EGeViGeneric
  • EGeViInvalidHandle() : EGeViInvalidHandle
  • EGeViIPConnection() : EGeViIPConnection
  • EGeViNoMessages() : EGeViNoMessages
  • EGeViSystem() : EGeViSystem
  • EGeViTimeout() : EGeViTimeout
  • EGeViUnknown() : EGeViUnknown
  • EncodePassword() : GeViAPIClient

- g -

  • GetActionCodeByName() : GeViAPI_Namespace::CAction
  • GetActionName() : GeViAPI_Namespace::CAction
  • GetActivityCodeByName() : GeViAPI_Namespace::CActivity
  • GetActivityName() : GeViAPI_Namespace::CActivity
  • GetCounter() : GeViAPI_Namespace::CReferenceObject
  • GetDatabase() : GeViAPIClient
  • GetDataBaseAnswerCodeByName() : GeViAPI_Namespace::CDataBaseAnswer
  • GetDataBaseAnswerName() : GeViAPI_Namespace::CDataBaseAnswer
  • GetDataBaseQueryCodeByName() : GeViAPI_Namespace::CDataBaseQuery
  • GetDataBaseQueryName() : GeViAPI_Namespace::CDataBaseQuery
  • GetStateAnswerCodeByName() : GeViAPI_Namespace::CStateAnswer
  • GetStateAnswerName() : GeViAPI_Namespace::CStateAnswer
  • GetStateQueryCodeByName() : GeViAPI_Namespace::CStateQuery
  • GetStateQueryName() : GeViAPI_Namespace::CStateQuery
  • GeViAPIClient() : GeViAPIClient
  • GeViError : EGeVi
  • GeViErrorClass : EGeVi

- h -

  • Hour : TMscGenericDateTime

- i -

  • IncRef() : GeViAPI_Namespace::CReferenceObject
  • isAction() : GeViAPI_Namespace::CGeViMessage
  • isActivity() : GeViAPI_Namespace::CGeViMessage
  • isDatabaseAnswer() : GeViAPI_Namespace::CGeViMessage
  • isDatabaseQuery() : GeViAPI_Namespace::CGeViMessage
  • isStateAnswer() : GeViAPI_Namespace::CGeViMessage
  • isStateQuery() : GeViAPI_Namespace::CGeViMessage

- l -

  • Length : TMessageEntry

- m -

  • m_ActionCode : GeViAPI_Namespace::CAction
  • m_ActionKind : GeViAPI_Namespace::CAction
  • m_ActivityCode : GeViAPI_Namespace::CActivity
  • m_ActivityKind : GeViAPI_Namespace::CActivity
  • m_AnswerCode : GeViAPI_Namespace::CDataBaseAnswer
  • m_AnswerKind : GeViAPI_Namespace::CStateAnswer
  • m_Buffer : GeViAPI_Namespace::TActionData
  • m_BufferSize : GeViAPI_Namespace::TActionData
  • m_FilterQuery : GeViAPI_Namespace::CDataBaseQuery
  • m_Handle : GeViAPI_Namespace::CDataBaseQuery
  • m_MessageKind : GeViAPI_Namespace::CGeViMessage
  • m_QueryCode : GeViAPI_Namespace::CDataBaseQuery
  • m_QueryKind : GeViAPI_Namespace::CStateQuery
  • m_RecepientID : GeViAPI_Namespace::CGeViMessage
  • m_SenderID : GeViAPI_Namespace::CGeViMessage
  • Min : TMscGenericDateTime
  • Month : TMscGenericDateTime
  • MSec : TMscGenericDateTime

- o -

  • operator=() : GeViAPI_Namespace::TActionData

- r -

  • ReadASCIIMessage() : GeViAPI_Namespace::CGeViMessage
  • ReadBinMessage() : GeViAPI_Namespace::CGeViMessage
  • ReadBuffer()
: GeViAPI_Namespace::CDataBaseQuery
, GeViAPI_Namespace::CStateAnswer
, GeViAPI_Namespace::CStateQuery
, GeViAPI_Namespace::CActivity
, GeViAPI_Namespace::CAction
, GeViAPI_Namespace::CGeViMessage
, GeViAPI_Namespace::CDataBaseAnswer

- s -

  • Sec : TMscGenericDateTime
  • SendDatabaseQuery() : GeViAPIClient
  • SendMessage() : GeViAPIClient
  • SendPing() : GeViAPIClient
  • SendStateQuery() : GeViAPIClient
  • SetCBNotification() : GeViAPIClient

- t -

  • TActionData() : GeViAPI_Namespace::TActionData
  • TimePart : GeViAPI_Namespace::TGeViDateTime , TMscNativeDateTime

- w -

  • WriteASCIIMessage() : GeViAPI_Namespace::CGeViMessage
  • WriteBinMessage() : GeViAPI_Namespace::CGeViMessage
  • WriteBuffer() : GeViAPI_Namespace::CGeViMessage

- y -

  • Year : TMscGenericDateTime

- ~ -

  • ~CReferenceObject() : GeViAPI_Namespace::CReferenceObject
  • ~GeViAPIClient() : GeViAPIClient
  • ~TActionData() : GeViAPI_Namespace::TActionData


GeViSoft SDK: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
GeViAPI_Namespace


GeViSoft SDK: GeViAPI_Namespace Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions | Variables
GeViAPI_Namespace Namespace Reference

Classes

struct | TGeViDateTime
class | TActionData
class | CReferenceObject
class | CGeViMessage
class | CAction
class | CActivity
class | CStateQuery
class | CStateAnswer
class | CDataBaseQuery
class | CDataBaseFilter
class | CDataBaseAnswer

Typedefs

typedef __int64 | TClientID
typedef __int32 | TVideoInputID
typedef __int32 | TVideoOutputID
typedef __int32 | TInputContactID
typedef __int32 | TOutputContactID
typedef __int32 | TMGID
typedef __int32 | TMscEventTypeID
typedef __int32 | TEventTypeID
typedef __int32 | TAlarmTypeID
typedef __int64 | TMscEventID
typedef __int64 | TEventID
typedef __int64 | TAlarmID
typedef __int32 | int32
typedef int | TMessageInternal

Enumerations

enum TMessageKind {
mk_Action = 1, mk_Activity = 2, mk_DataBaseQuery = 3, mk_DataBaseAnswer = 4,
mk_CommandMessage = 5, mk_CommandAnswer = 6, mk_StateQuery = 7, mk_StateAnswer = 8
}
enum | TGeViPort { gp_UserPort = 0, gp_SetupPort = 1, gp_DevicePort = 2 }
enum TLoginFailure {
lf_Ok = 0, lf_UnknownUser = 1, lf_InvalidPassword = 2, lf_SecondUserRequired = 3,
lf_SecondUserUnknown = 4, lf_LicenseRestriction = 5, lf_ProtocolFailure = 6, lf_WrongInterfaceVersion = 7,
lf_PasswordCorrupt = 8, lf_AccessDenied = 9, lf_NoMultipleLogin = 10, lf_GeneralFailure = 20
}
enum TSwitchMode {
sm_Normal = 0x0, sm_KP = 0x1, sm_CP = 0x2, sm_VX3_CT = 0x3,
sm_MonitorCycle = 0xffffffff
}
enum | TDBCompare { dbc_LIKE = 0x0, dbc_LE = 0xFFFFFFFF, dbc_GE = 0x1 }
enum TGeViResourceType {
rt_DigitalInput = 0, rt_DigitalOutput = 1, rt_VideoInput = 2, rt_VideoOutput = 3,
rt_MonitorGroup = 4
}

Functions

bool | GetWriteResults (CGeViTransferBuffer *Buffer, int &BytesWrote)

Variables

const int | GEVI_MAXSTRINGLENGTH = 1024
const int | GEVI_MAXACTIONLENGTH = 2048
const int | GeViGscOffset = 0x1000
const TVideoInputID | csa_Last = 0
const TVideoInputID | csa_Previous = -2
const TVideoInputID | csa_Next = -1
const bool | ics_Open = false
const bool | ics_Closed = true
const bool | vss_Armed = true
const bool | vss_Disarmed = false
const bool | vsc_Ok = true
const bool | vsc_Failure = false
const bool | vsp_Live = true
const bool | vsp_Stored = false
const __int32 | pp_Unknown = -1
const __int32 | pp_BasePosition = -2
const __int32 | pd_Left = -1
const __int32 | pd_Right = 1
const __int32 | pd_None = 0
const __int32 | td_Up = -1
const __int32 | td_Down = 1
const __int32 | td_None = 0
const __int32 | ecs_Closed = -1
const __int32 | ecs_Open = 1
const __int32 | ecs_Unknown = 0
const __int32 | ecs_Sabotage = 3
const __int32 | ecs_Alternating = 2
const __int32 | ik_Special = 0
const __int32 | ik_Compax = 1
const __int32 | ik_GeViCom = 2
const __int32 | ik_GeViGST = 3
const __int32 | ik_GeViTel = 5
const __int32 | ik_Phoenix = 6
const __int32 | ik_RAWDevice = 7
const __int32 | ik_VicrosII = 8
const __int32 | ik_VicrosIII = 9
const __int32 | ik_VS40 = 10
const __int32 | ik_VSM = 11
const __int32 | uk_User = 1
const __int32 | uk_Interface = 2
const __int32 | uk_Client = 3
const __int32 | uk_SysAdmin = 4
const __int32 | vsa_ExternalAlarm = -1
const __int32 | ocd_Database = 0
const __int32 | ocd_EventLog = 1
const __int32 | ccs_NormalTemp = 0
const __int32 | dbar_None = 0
const __int32 | dbar_Start = 1
const __int32 | dbar_Reaction = 2
const __int32 | dbar_Ack = 3
const __int32 | dbar_Quit = 4
const __int32 | RightToAccessToUserPort = 0x1
const __int32 | RightToAccessToSetupPort = 0x2
const __int32 | RightToAccessToDevicePort = 0x4
const __int32 | SupervisorRight = 0x00000100
const __int32 | RightToMultiLogin = 0x00000200
const __int32 | AccessDatabaseRight = 0x00000400
const __int32 | ControlDatabaseRight = 0x00000800
const __int32 | Generic1Right = 0x00001000
const __int32 | Generic2Right = 0x00002000
const __int32 | Generic3Right = 0x00004000
const __int32 | Generic4Right = 0x00008000
const __int32 | Generic5Right = 0x00010000
const __int32 | DirectMessageRight = 0x00020000
const __int32 | SpecialActionRight = 0x00040000
const __int32 | AlarmActionRight = 0x00100000

Typedef Documentation

typedef __int32 GeViAPI_Namespace::int32
typedef __int64 GeViAPI_Namespace::TAlarmID
typedef __int32 GeViAPI_Namespace::TAlarmTypeID
typedef __int64 GeViAPI_Namespace::TClientID
typedef __int64 GeViAPI_Namespace::TEventID
typedef __int32 GeViAPI_Namespace::TEventTypeID
typedef __int32 GeViAPI_Namespace::TInputContactID
typedef int GeViAPI_Namespace::TMessageInternal
typedef __int32 GeViAPI_Namespace::TMGID
typedef __int64 GeViAPI_Namespace::TMscEventID
typedef __int32 GeViAPI_Namespace::TMscEventTypeID
typedef __int32 GeViAPI_Namespace::TOutputContactID
typedef __int32 GeViAPI_Namespace::TVideoInputID
typedef __int32 GeViAPI_Namespace::TVideoOutputID

Enumeration Type Documentation

enum GeViAPI_Namespace::TDBCompare
Enumerator:
dbc_LIKE
dbc_LE
dbc_GE
enum GeViAPI_Namespace::TGeViPort
Enumerator:
gp_UserPort
gp_SetupPort
gp_DevicePort
enum GeViAPI_Namespace::TGeViResourceType
Enumerator:
rt_DigitalInput
rt_DigitalOutput
rt_VideoInput
rt_VideoOutput
rt_MonitorGroup
enum GeViAPI_Namespace::TLoginFailure
Enumerator:
lf_Ok
lf_UnknownUser
lf_InvalidPassword
lf_SecondUserRequired
lf_SecondUserUnknown
lf_LicenseRestriction
lf_ProtocolFailure
lf_WrongInterfaceVersion
lf_PasswordCorrupt
lf_AccessDenied
lf_NoMultipleLogin
lf_GeneralFailure
enum GeViAPI_Namespace::TMessageKind
Enumerator:
mk_Action
mk_Activity
mk_DataBaseQuery
mk_DataBaseAnswer
mk_CommandMessage
mk_CommandAnswer
mk_StateQuery
mk_StateAnswer
enum GeViAPI_Namespace::TSwitchMode
Enumerator:
sm_Normal
sm_KP
sm_CP
sm_VX3_CT
sm_MonitorCycle

Function Documentation

bool GeViAPI_Namespace::GetWriteResults | ( | CGeViTransferBuffer * | Buffer,
 |  | int & | BytesWrote
 | ) |  |

Variable Documentation

const __int32 GeViAPI_Namespace::AccessDatabaseRight = 0x00000400
const __int32 GeViAPI_Namespace::AlarmActionRight = 0x00100000
const __int32 GeViAPI_Namespace::ccs_NormalTemp = 0
const __int32 GeViAPI_Namespace::ControlDatabaseRight = 0x00000800
const TVideoInputID GeViAPI_Namespace::csa_Last = 0
const TVideoInputID GeViAPI_Namespace::csa_Next = -1
const TVideoInputID GeViAPI_Namespace::csa_Previous = -2
const __int32 GeViAPI_Namespace::dbar_Ack = 3
const __int32 GeViAPI_Namespace::dbar_None = 0
const __int32 GeViAPI_Namespace::dbar_Quit = 4
const __int32 GeViAPI_Namespace::dbar_Reaction = 2
const __int32 GeViAPI_Namespace::dbar_Start = 1
const __int32 GeViAPI_Namespace::DirectMessageRight = 0x00020000
const __int32 GeViAPI_Namespace::ecs_Alternating = 2
const __int32 GeViAPI_Namespace::ecs_Closed = -1
const __int32 GeViAPI_Namespace::ecs_Open = 1
const __int32 GeViAPI_Namespace::ecs_Sabotage = 3
const __int32 GeViAPI_Namespace::ecs_Unknown = 0
const __int32 GeViAPI_Namespace::Generic1Right = 0x00001000
const __int32 GeViAPI_Namespace::Generic2Right = 0x00002000
const __int32 GeViAPI_Namespace::Generic3Right = 0x00004000
const __int32 GeViAPI_Namespace::Generic4Right = 0x00008000
const __int32 GeViAPI_Namespace::Generic5Right = 0x00010000
const int GeViAPI_Namespace::GEVI_MAXACTIONLENGTH = 2048
const int GeViAPI_Namespace::GEVI_MAXSTRINGLENGTH = 1024
const int GeViAPI_Namespace::GeViGscOffset = 0x1000
const bool GeViAPI_Namespace::ics_Closed = true
const bool GeViAPI_Namespace::ics_Open = false
const __int32 GeViAPI_Namespace::ik_Compax = 1
const __int32 GeViAPI_Namespace::ik_GeViCom = 2
const __int32 GeViAPI_Namespace::ik_GeViGST = 3
const __int32 GeViAPI_Namespace::ik_GeViTel = 5
const __int32 GeViAPI_Namespace::ik_Phoenix = 6
const __int32 GeViAPI_Namespace::ik_RAWDevice = 7
const __int32 GeViAPI_Namespace::ik_Special = 0
const __int32 GeViAPI_Namespace::ik_VicrosII = 8
const __int32 GeViAPI_Namespace::ik_VicrosIII = 9
const __int32 GeViAPI_Namespace::ik_VS40 = 10
const __int32 GeViAPI_Namespace::ik_VSM = 11
const __int32 GeViAPI_Namespace::ocd_Database = 0
const __int32 GeViAPI_Namespace::ocd_EventLog = 1
const __int32 GeViAPI_Namespace::pd_Left = -1
const __int32 GeViAPI_Namespace::pd_None = 0
const __int32 GeViAPI_Namespace::pd_Right = 1
const __int32 GeViAPI_Namespace::pp_BasePosition = -2
const __int32 GeViAPI_Namespace::pp_Unknown = -1
const __int32 GeViAPI_Namespace::RightToAccessToDevicePort = 0x4
const __int32 GeViAPI_Namespace::RightToAccessToSetupPort = 0x2
const __int32 GeViAPI_Namespace::RightToAccessToUserPort = 0x1
const __int32 GeViAPI_Namespace::RightToMultiLogin = 0x00000200
const __int32 GeViAPI_Namespace::SpecialActionRight = 0x00040000
const __int32 GeViAPI_Namespace::SupervisorRight = 0x00000100
const __int32 GeViAPI_Namespace::td_Down = 1
const __int32 GeViAPI_Namespace::td_None = 0
const __int32 GeViAPI_Namespace::td_Up = -1
const __int32 GeViAPI_Namespace::uk_Client = 3
const __int32 GeViAPI_Namespace::uk_Interface = 2
const __int32 GeViAPI_Namespace::uk_SysAdmin = 4
const __int32 GeViAPI_Namespace::uk_User = 1
const __int32 GeViAPI_Namespace::vsa_ExternalAlarm = -1
const bool GeViAPI_Namespace::vsc_Failure = false
const bool GeViAPI_Namespace::vsc_Ok = true
const bool GeViAPI_Namespace::vsp_Live = true
const bool GeViAPI_Namespace::vsp_Stored = false
const bool GeViAPI_Namespace::vss_Armed = true
const bool GeViAPI_Namespace::vss_Disarmed = false


GeViSoft SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AccessDatabaseRight : GeViAPI_Namespace
  • AlarmActionRight : GeViAPI_Namespace

- c -

  • ccs_NormalTemp : GeViAPI_Namespace
  • ControlDatabaseRight : GeViAPI_Namespace
  • csa_Last : GeViAPI_Namespace
  • csa_Next : GeViAPI_Namespace
  • csa_Previous : GeViAPI_Namespace

- d -

  • dbar_Ack : GeViAPI_Namespace
  • dbar_None : GeViAPI_Namespace
  • dbar_Quit : GeViAPI_Namespace
  • dbar_Reaction : GeViAPI_Namespace
  • dbar_Start : GeViAPI_Namespace
  • dbc_GE : GeViAPI_Namespace
  • dbc_LE : GeViAPI_Namespace
  • dbc_LIKE : GeViAPI_Namespace
  • DirectMessageRight : GeViAPI_Namespace

- e -

  • ecs_Alternating : GeViAPI_Namespace
  • ecs_Closed : GeViAPI_Namespace
  • ecs_Open : GeViAPI_Namespace
  • ecs_Sabotage : GeViAPI_Namespace
  • ecs_Unknown : GeViAPI_Namespace

- g -

  • Generic1Right : GeViAPI_Namespace
  • Generic2Right : GeViAPI_Namespace
  • Generic3Right : GeViAPI_Namespace
  • Generic4Right : GeViAPI_Namespace
  • Generic5Right : GeViAPI_Namespace
  • GetWriteResults() : GeViAPI_Namespace
  • GEVI_MAXACTIONLENGTH : GeViAPI_Namespace
  • GEVI_MAXSTRINGLENGTH : GeViAPI_Namespace
  • GeViGscOffset : GeViAPI_Namespace
  • gp_DevicePort : GeViAPI_Namespace
  • gp_SetupPort : GeViAPI_Namespace
  • gp_UserPort : GeViAPI_Namespace

- i -

  • ics_Closed : GeViAPI_Namespace
  • ics_Open : GeViAPI_Namespace
  • ik_Compax : GeViAPI_Namespace
  • ik_GeViCom : GeViAPI_Namespace
  • ik_GeViGST : GeViAPI_Namespace
  • ik_GeViTel : GeViAPI_Namespace
  • ik_Phoenix : GeViAPI_Namespace
  • ik_RAWDevice : GeViAPI_Namespace
  • ik_Special : GeViAPI_Namespace
  • ik_VicrosII : GeViAPI_Namespace
  • ik_VicrosIII : GeViAPI_Namespace
  • ik_VS40 : GeViAPI_Namespace
  • ik_VSM : GeViAPI_Namespace
  • int32 : GeViAPI_Namespace

- l -

  • lf_AccessDenied : GeViAPI_Namespace
  • lf_GeneralFailure : GeViAPI_Namespace
  • lf_InvalidPassword : GeViAPI_Namespace
  • lf_LicenseRestriction : GeViAPI_Namespace
  • lf_NoMultipleLogin : GeViAPI_Namespace
  • lf_Ok : GeViAPI_Namespace
  • lf_PasswordCorrupt : GeViAPI_Namespace
  • lf_ProtocolFailure : GeViAPI_Namespace
  • lf_SecondUserRequired : GeViAPI_Namespace
  • lf_SecondUserUnknown : GeViAPI_Namespace
  • lf_UnknownUser : GeViAPI_Namespace
  • lf_WrongInterfaceVersion : GeViAPI_Namespace

- m -

  • mk_Action : GeViAPI_Namespace
  • mk_Activity : GeViAPI_Namespace
  • mk_CommandAnswer : GeViAPI_Namespace
  • mk_CommandMessage : GeViAPI_Namespace
  • mk_DataBaseAnswer : GeViAPI_Namespace
  • mk_DataBaseQuery : GeViAPI_Namespace
  • mk_StateAnswer : GeViAPI_Namespace
  • mk_StateQuery : GeViAPI_Namespace

- o -

  • ocd_Database : GeViAPI_Namespace
  • ocd_EventLog : GeViAPI_Namespace

- p -

  • pd_Left : GeViAPI_Namespace
  • pd_None : GeViAPI_Namespace
  • pd_Right : GeViAPI_Namespace
  • pp_BasePosition : GeViAPI_Namespace
  • pp_Unknown : GeViAPI_Namespace

- r -

  • RightToAccessToDevicePort : GeViAPI_Namespace
  • RightToAccessToSetupPort : GeViAPI_Namespace
  • RightToAccessToUserPort : GeViAPI_Namespace
  • RightToMultiLogin : GeViAPI_Namespace
  • rt_DigitalInput : GeViAPI_Namespace
  • rt_DigitalOutput : GeViAPI_Namespace
  • rt_MonitorGroup : GeViAPI_Namespace
  • rt_VideoInput : GeViAPI_Namespace
  • rt_VideoOutput : GeViAPI_Namespace

- s -

  • sm_CP : GeViAPI_Namespace
  • sm_KP : GeViAPI_Namespace
  • sm_MonitorCycle : GeViAPI_Namespace
  • sm_Normal : GeViAPI_Namespace
  • sm_VX3_CT : GeViAPI_Namespace
  • SpecialActionRight : GeViAPI_Namespace
  • SupervisorRight : GeViAPI_Namespace

- t -

  • TAlarmID : GeViAPI_Namespace
  • TAlarmTypeID : GeViAPI_Namespace
  • TClientID : GeViAPI_Namespace
  • td_Down : GeViAPI_Namespace
  • td_None : GeViAPI_Namespace
  • td_Up : GeViAPI_Namespace
  • TDBCompare : GeViAPI_Namespace
  • TEventID : GeViAPI_Namespace
  • TEventTypeID : GeViAPI_Namespace
  • TGeViPort : GeViAPI_Namespace
  • TGeViResourceType : GeViAPI_Namespace
  • TInputContactID : GeViAPI_Namespace
  • TLoginFailure : GeViAPI_Namespace
  • TMessageInternal : GeViAPI_Namespace
  • TMessageKind : GeViAPI_Namespace
  • TMGID : GeViAPI_Namespace
  • TMscEventID : GeViAPI_Namespace
  • TMscEventTypeID : GeViAPI_Namespace
  • TOutputContactID : GeViAPI_Namespace
  • TSwitchMode : GeViAPI_Namespace
  • TVideoInputID : GeViAPI_Namespace
  • TVideoOutputID : GeViAPI_Namespace

- u -

  • uk_Client : GeViAPI_Namespace
  • uk_Interface : GeViAPI_Namespace
  • uk_SysAdmin : GeViAPI_Namespace
  • uk_User : GeViAPI_Namespace

- v -

  • vsa_ExternalAlarm : GeViAPI_Namespace
  • vsc_Failure : GeViAPI_Namespace
  • vsc_Ok : GeViAPI_Namespace
  • vsp_Live : GeViAPI_Namespace
  • vsp_Stored : GeViAPI_Namespace
  • vss_Armed : GeViAPI_Namespace
  • vss_Disarmed : GeViAPI_Namespace


GeViSoft SDK: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
GeViAPIClient.h [code]
GeViConst.h [code]
GeViProcAPI.h [code]
index.h [code]
MessageBase.h [code]


GeViSoft SDK: GeViAPIClient.h File Reference

  • File List
  • File Members
Classes
GeViAPIClient.h File Reference
#include <string>
#include <stdexcept>
#include "GeViProcAPI.h"
#include "MessageBase.h"
Include dependency graph for GeViAPIClient.h:

Go to the source code of this file.

Classes

class | EGeVi
Base class that handles exceptions thrown by the DLL. More...
class | EGeViCmdNotImplemented
class | EGeViCmdAborted
class | EGeViUnknown
class | EGeViGeneric
class | EGeViIPConnection
class | EGeViSystem
class | EGeViInvalidHandle
class | EGeViNoMessages
class | EGeViTimeout
class | GeViAPIClient
Inside the GeViAPIClient class, the commmunication with GeViServer is handled. More...


GeViSoft SDK: GeViConst.h File Reference

  • File List
  • File Members
Classes | Namespaces | Typedefs | Enumerations | Variables
GeViConst.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | GeViAPI_Namespace::TGeViDateTime
class | GeViAPI_Namespace::TActionData

Namespaces

namespace | GeViAPI_Namespace

Typedefs

typedef __int64 | GeViAPI_Namespace::TClientID
typedef __int32 | GeViAPI_Namespace::TVideoInputID
typedef __int32 | GeViAPI_Namespace::TVideoOutputID
typedef __int32 | GeViAPI_Namespace::TInputContactID
typedef __int32 | GeViAPI_Namespace::TOutputContactID
typedef __int32 | GeViAPI_Namespace::TMGID
typedef __int32 | GeViAPI_Namespace::TMscEventTypeID
typedef __int32 | GeViAPI_Namespace::TEventTypeID
typedef __int32 | GeViAPI_Namespace::TAlarmTypeID
typedef __int64 | GeViAPI_Namespace::TMscEventID
typedef __int64 | GeViAPI_Namespace::TEventID
typedef __int64 | GeViAPI_Namespace::TAlarmID
typedef __int32 | GeViAPI_Namespace::int32
typedef int | GeViAPI_Namespace::TMessageInternal

Enumerations

enum GeViAPI_Namespace::TMessageKind {
GeViAPI_Namespace::mk_Action = 1, GeViAPI_Namespace::mk_Activity = 2, GeViAPI_Namespace::mk_DataBaseQuery = 3, GeViAPI_Namespace::mk_DataBaseAnswer = 4,
GeViAPI_Namespace::mk_CommandMessage = 5, GeViAPI_Namespace::mk_CommandAnswer = 6, GeViAPI_Namespace::mk_StateQuery = 7, GeViAPI_Namespace::mk_StateAnswer = 8
}
enum | GeViAPI_Namespace::TGeViPort { GeViAPI_Namespace::gp_UserPort = 0, GeViAPI_Namespace::gp_SetupPort = 1, GeViAPI_Namespace::gp_DevicePort = 2 }
enum GeViAPI_Namespace::TLoginFailure {
GeViAPI_Namespace::lf_Ok = 0, GeViAPI_Namespace::lf_UnknownUser = 1, GeViAPI_Namespace::lf_InvalidPassword = 2, GeViAPI_Namespace::lf_SecondUserRequired = 3,
GeViAPI_Namespace::lf_SecondUserUnknown = 4, GeViAPI_Namespace::lf_LicenseRestriction = 5, GeViAPI_Namespace::lf_ProtocolFailure = 6, GeViAPI_Namespace::lf_WrongInterfaceVersion = 7,
GeViAPI_Namespace::lf_PasswordCorrupt = 8, GeViAPI_Namespace::lf_AccessDenied = 9, GeViAPI_Namespace::lf_NoMultipleLogin = 10, GeViAPI_Namespace::lf_GeneralFailure = 20
}
enum GeViAPI_Namespace::TSwitchMode {
GeViAPI_Namespace::sm_Normal = 0x0, GeViAPI_Namespace::sm_KP = 0x1, GeViAPI_Namespace::sm_CP = 0x2, GeViAPI_Namespace::sm_VX3_CT = 0x3,
GeViAPI_Namespace::sm_MonitorCycle = 0xffffffff
}
enum | GeViAPI_Namespace::TDBCompare { GeViAPI_Namespace::dbc_LIKE = 0x0, GeViAPI_Namespace::dbc_LE = 0xFFFFFFFF, GeViAPI_Namespace::dbc_GE = 0x1 }
enum GeViAPI_Namespace::TGeViResourceType {
GeViAPI_Namespace::rt_DigitalInput = 0, GeViAPI_Namespace::rt_DigitalOutput = 1, GeViAPI_Namespace::rt_VideoInput = 2, GeViAPI_Namespace::rt_VideoOutput = 3,
GeViAPI_Namespace::rt_MonitorGroup = 4
}

Variables

const int | GeViAPI_Namespace::GEVI_MAXSTRINGLENGTH = 1024
const int | GeViAPI_Namespace::GEVI_MAXACTIONLENGTH = 2048
const int | GeViAPI_Namespace::GeViGscOffset = 0x1000
const TVideoInputID | GeViAPI_Namespace::csa_Last = 0
const TVideoInputID | GeViAPI_Namespace::csa_Previous = -2
const TVideoInputID | GeViAPI_Namespace::csa_Next = -1
const bool | GeViAPI_Namespace::ics_Open = false
const bool | GeViAPI_Namespace::ics_Closed = true
const bool | GeViAPI_Namespace::vss_Armed = true
const bool | GeViAPI_Namespace::vss_Disarmed = false
const bool | GeViAPI_Namespace::vsc_Ok = true
const bool | GeViAPI_Namespace::vsc_Failure = false
const bool | GeViAPI_Namespace::vsp_Live = true
const bool | GeViAPI_Namespace::vsp_Stored = false
const __int32 | GeViAPI_Namespace::pp_Unknown = -1
const __int32 | GeViAPI_Namespace::pp_BasePosition = -2
const __int32 | GeViAPI_Namespace::pd_Left = -1
const __int32 | GeViAPI_Namespace::pd_Right = 1
const __int32 | GeViAPI_Namespace::pd_None = 0
const __int32 | GeViAPI_Namespace::td_Up = -1
const __int32 | GeViAPI_Namespace::td_Down = 1
const __int32 | GeViAPI_Namespace::td_None = 0
const __int32 | GeViAPI_Namespace::ecs_Closed = -1
const __int32 | GeViAPI_Namespace::ecs_Open = 1
const __int32 | GeViAPI_Namespace::ecs_Unknown = 0
const __int32 | GeViAPI_Namespace::ecs_Sabotage = 3
const __int32 | GeViAPI_Namespace::ecs_Alternating = 2
const __int32 | GeViAPI_Namespace::ik_Special = 0
const __int32 | GeViAPI_Namespace::ik_Compax = 1
const __int32 | GeViAPI_Namespace::ik_GeViCom = 2
const __int32 | GeViAPI_Namespace::ik_GeViGST = 3
const __int32 | GeViAPI_Namespace::ik_GeViTel = 5
const __int32 | GeViAPI_Namespace::ik_Phoenix = 6
const __int32 | GeViAPI_Namespace::ik_RAWDevice = 7
const __int32 | GeViAPI_Namespace::ik_VicrosII = 8
const __int32 | GeViAPI_Namespace::ik_VicrosIII = 9
const __int32 | GeViAPI_Namespace::ik_VS40 = 10
const __int32 | GeViAPI_Namespace::ik_VSM = 11
const __int32 | GeViAPI_Namespace::uk_User = 1
const __int32 | GeViAPI_Namespace::uk_Interface = 2
const __int32 | GeViAPI_Namespace::uk_Client = 3
const __int32 | GeViAPI_Namespace::uk_SysAdmin = 4
const __int32 | GeViAPI_Namespace::vsa_ExternalAlarm = -1
const __int32 | GeViAPI_Namespace::ocd_Database = 0
const __int32 | GeViAPI_Namespace::ocd_EventLog = 1
const __int32 | GeViAPI_Namespace::ccs_NormalTemp = 0
const __int32 | GeViAPI_Namespace::dbar_None = 0
const __int32 | GeViAPI_Namespace::dbar_Start = 1
const __int32 | GeViAPI_Namespace::dbar_Reaction = 2
const __int32 | GeViAPI_Namespace::dbar_Ack = 3
const __int32 | GeViAPI_Namespace::dbar_Quit = 4
const __int32 | GeViAPI_Namespace::RightToAccessToUserPort = 0x1
const __int32 | GeViAPI_Namespace::RightToAccessToSetupPort = 0x2
const __int32 | GeViAPI_Namespace::RightToAccessToDevicePort = 0x4
const __int32 | GeViAPI_Namespace::SupervisorRight = 0x00000100
const __int32 | GeViAPI_Namespace::RightToMultiLogin = 0x00000200
const __int32 | GeViAPI_Namespace::AccessDatabaseRight = 0x00000400
const __int32 | GeViAPI_Namespace::ControlDatabaseRight = 0x00000800
const __int32 | GeViAPI_Namespace::Generic1Right = 0x00001000
const __int32 | GeViAPI_Namespace::Generic2Right = 0x00002000
const __int32 | GeViAPI_Namespace::Generic3Right = 0x00004000
const __int32 | GeViAPI_Namespace::Generic4Right = 0x00008000
const __int32 | GeViAPI_Namespace::Generic5Right = 0x00010000
const __int32 | GeViAPI_Namespace::DirectMessageRight = 0x00020000
const __int32 | GeViAPI_Namespace::SpecialActionRight = 0x00040000
const __int32 | GeViAPI_Namespace::AlarmActionRight = 0x00100000


GeViSoft SDK: GeViProcAPI.h File Reference

  • File List
  • File Members
Classes | Typedefs | Enumerations | Functions | Variables
GeViProcAPI.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | TMessageEntry
struct | GeViHandleStruct
Structure to hold a handle to a GeViSoft Connection. More...
struct | TMscGenericDateTime
Structure to hold the system time representation. More...
struct | TMscNativeDateTime
Structure to hold GeViSoft's internal time representation. More...

Typedefs

typedef GeViHandleStruct * | HGeViSetupClient
typedef GeViHandleStruct * | HGeViDatabase
typedef GeViHandleStruct * | HGeViDeviceClient
typedef bool(__stdcall * | TGeViConnectProgress )(void *Instance, int Percentage, int Percent100)
Signature for the connect progress callback method.
typedef TServerNotification | Notification
typedef TGeViConnectProgress | TGeViAPIConnectProgress
typedef TGeViServerNotification | TGeViAPIServerNotification

Enumerations

enum TServerNotification {
NFServer_SetupModified = 0, NFServer_Disconnected = 10, NFServer_GoingShutdown = 11, NFServer_NewMessage = 12,
NFServer_DummyValue = 0x7FFFFFFF
}
enum TConnectResult {
connectOk = 0, connectWarningInvalidHeaders = 1, connectWarningMax = 99, connectAborted = 100,
connectGenericError = 101, connectFileEmpty = 200, connectFileAccessError = 201, connectFileInvalid = 202,
connectFileInvalidVersion = 203, connectFileCouldNotOpen = 204, connectTapeNotCompatible = 250, connectTapeNotReady = 251,
connectTapeInvalid = 252, connectTapeEmpty = 253, connectTapeInvalidVersion = 254, connectTapeCouldNotOpen = 255,
connectRemoteUnkownError = 300, connectRemoteTcpError = 301, connectRemoteUnknownUser = 302, connectRemoteConnectionLimitExceeded = 303,
connectRemoteClientInterfaceTooOld = 304, connectRemoteServerInterfaceTooOld = 305, connectRemoteSecondUserRequired = 306, connectRemotePortDisabled = 307,
connectDummyValue = 0x7FFFFFFF
}

Functions

typedef | void (__stdcall *TGeViDatabaseNotification)(void *Instance
Signature for the database notification callback method.
int | GeViAPI_InterfaceVersion ()
Returns the interface version number of the used GeViProcAPI.dll Should be checked against the "GeViProcAPIVersion".
bool | GeViAPI_GetLastError (int &AExceptionClass, int &ErrorNo, int &ErrorClass, char *&ErrorMessage)
Returns information about the last occured error in the current thread Should be called when any of the other API functions returns false.
bool | GeViAPI_EncodeString (char *Dest, const char *Source, int DestSize)
Encodes the plain text password.
bool | GeViAPI_CheckSocketVersion (bool &Sufficient, int &SocketVersionExpected, int &SocketVersionFound, bool &ProtocolsMissing)
Check if the version of the installed Socket-DLL is sufficient for the GeViProcAPI.DLL.
bool | GeViAPI_FreePointer (void *Pointer)
Free memory allocated in the DLL.
bool | GeViAPI_FreeArray (char *Pointer)
Frees memory allocated in the DLL.
bool | GeViAPI_SetupClient_SyncTime (HGeViSetupClient SetupClient, bool ForceSync)
bool | GeViAPI_SetupClient_GetDifferenceToServerTime (HGeViSetupClient SetupClient, __int64 &Milliseconds)
bool | GeViAPI_DeviceClient_SyncTime (HGeViDeviceClient DeviceClient, bool ForceSync)
bool | GeViAPI_DeviceClient_GetDifferenceToServerTime (HGeViDeviceClient DeviceClient, __int64 &Milliseconds)
bool | GeViAPI_Database_SyncTime (HGeViDatabase Database, bool ForceSync)
bool | GeViAPI_Database_GetDifferenceToServerTime (HGeViDatabase Database, __int64 &Milliseconds)
bool | GeViAPI_EncodeDateTime (GeViAPI_Namespace::TMscNativeDateTime &DT, unsigned short Year, unsigned short Month, unsigned short Day, unsigned short Hour, unsigned short Min, unsigned short Sec, unsigned short MSec)
Encodes date and time to TMscNativeDateTime.
bool | GeViAPI_DecodeDateTime (const GeViAPI_Namespace::TMscNativeDateTime DT, unsigned short &Year, unsigned short &Month, unsigned short &Day, unsigned short &Hour, unsigned short &Min, unsigned short &Sec, unsigned short &MSec)
Decodes date and time from TMscNativeDateTime.
bool | GeViAPI_SetupClient_SendPing (HGeViSetupClient SetupClient)
bool | GeViAPI_Database_SendPing (HGeViDatabase UserClient)
Sends a ping to the server for keep-alive checking.
bool | GeViAPI_DeviceClient_SendPing (HGeViDeviceClient DeviceClient)
bool | GeViAPI_SetupClient_ActivateServerPing (HGeViSetupClient SetupClient, unsigned __int32 CheckPeriod)
bool | GeViAPI_Database_ActivateServerPing (HGeViDatabase UserClient, unsigned __int32 CheckPeriod)
Activates connection monitoring on server.
bool | GeViAPI_DeviceClient_ActivateServerPing (HGeViDeviceClient DeviceClient, unsigned __int32 CheckPeriod)
bool | GeViAPI_Database_Create (HGeViDatabase &Database, const char *Aliasname, const char *Address, const char *Username, const char *Password, const char *Username2, const char *Password2)
Creates a remote database object to access a GeViSoft database.
bool | GeViAPI_Database_Destroy (HGeViDatabase Database)
bool | GeViAPI_Database_Connect (HGeViDatabase Database, TConnectResult &ConnectResult, TGeViConnectProgress ACallback, void *AInstance)
Connects to a remote GeViSoft database object.
bool | GeViAPI_Database_Connected (HGeViDatabase Database, bool &IsConnected)
bool | GeViAPI_Database_Disconnect (HGeViDatabase Database)
Disconnects from a remote GeViSoft database object.
bool | GeViAPI_Database_SetCBNotification (HGeViDatabase Database, TGeViDatabaseNotification ACallback, void *AInstance)
Declares a callback function to receive notifications from the server.
bool | GeViAPI_Database_GetAliasname (HGeViDatabase Database, char *&Aliasname)
bool | GeViAPI_Database_GetAddress (HGeViDatabase Database, char *&Address)
bool | GeViAPI_Database_GetUsername (HGeViDatabase Database, char *&Username, char *&Username2)
bool | GeViAPI_Database_GetPassword (HGeViDatabase Database, char *&Password, char *&Password2)
bool | GeViAPI_Database_GetDateTime (HGeViDatabase Database, TMscNativeDateTime &GMT, TMscNativeDateTime &LocalTime)
bool | GeViAPI_Database_SendMessage (HGeViDatabase Database, const char *MessageBuffer, int BufferSize)
Sends a message to GeViSoft server.
bool | GeViAPI_Database_SendToMessage (HGeViDatabase Database, const char *ClientName, const char *MessageBuffer, int BufferSize)
bool | GeViAPI_Database_SendQuery (HGeViDatabase Database, const char *SendMessageBuffer, int SendBufferSize, char *&RecMessageBuffer, int &BytesRead, int TimeOut)
Sends a query to GeViSoft server.
bool | GeViAPI_Database_AbortAllQueries (HGeViDatabase Database)
bool | GeViAPI_DeviceClient_Create (HGeViDeviceClient &DeviceClient, const char *Aliasname, const char *Address, const char *Username, const char *Password, const char *Username2, const char *Password2)
bool | GeViAPI_DeviceClient_Destroy (HGeViDeviceClient DeviceClient)
bool | GeViAPI_DeviceClient_Connect (HGeViDeviceClient DeviceClient, TConnectResult &ConnectResult, TGeViConnectProgress ACallback, void *AInstance)
bool | GeViAPI_DeviceClient_AutoConnect (HGeViDeviceClient DeviceClient, TConnectResult &ConnectResult)
bool | GeViAPI_DeviceClient_TerminateAutoConnect (HGeViDeviceClient DeviceClient)
bool | GeViAPI_DeviceClient_Connected (HGeViDeviceClient DeviceClient, bool &IsConnected)
bool | GeViAPI_DeviceClient_Disconnect (HGeViDeviceClient DeviceClient)
bool | GeViAPI_DeviceClient_SetCBNotification (HGeViDeviceClient DeviceClient, TGeViDatabaseNotification ACallback, void *AInstance)
bool | GeViAPI_DeviceClient_GetAliasname (HGeViDeviceClient DeviceClient, char *&Aliasname)
bool | GeViAPI_DeviceClient_GetAddress (HGeViDeviceClient DeviceClient, char *&Address)
bool | GeViAPI_DeviceClient_GetUsername (HGeViDeviceClient DeviceClient, char *&Username, char *&Username2)
bool | GeViAPI_DeviceClient_GetPassword (HGeViDeviceClient DeviceClient, char *&Password, char *&Password2)
bool | GeViAPI_DeviceClient_GetDateTime (HGeViDeviceClient DeviceClient, TMscNativeDateTime &GMT, TMscNativeDateTime &LocalTime)
bool | GeViAPI_DeviceClient_SendMessage (HGeViDeviceClient DeviceClient, const char *MessageBuffer, int BufferSize)
bool | GeViAPI_DeviceClient_SendToMessage (HGeViDeviceClient DeviceClient, const char *ClientName, const char *MessageBuffer, int BufferSize)
bool | GeViAPI_DeviceClient_SendQuery (HGeViDeviceClient DeviceClient, const char *SendMessageBuffer, int SendBufferSize, char *&RecMessageBuffer, int &BytesRead, int TimeOut)
bool | GeViAPI_DeviceClient_AbortAllQueries (HGeViDeviceClient DeviceClient)
bool | GeViAPI_DeviceClient_ReadSetup (HGeViDeviceClient DeviceClient, void *HFile)
bool | GeViAPI_SetupClient_Create (HGeViSetupClient &SetupClient, const char *Aliasname, const char *Address, const char *Username, const char *Password, const char *Username2, const char *Password2)
bool | GeViAPI_SetupClient_Destroy (HGeViSetupClient SetupClient)
bool | GeViAPI_SetupClient_Connect (HGeViSetupClient SetupClient, TConnectResult &ConnectResult, TGeViConnectProgress ACallback, void *AInstance)
bool | GeViAPI_SetupClient_Connected (HGeViSetupClient SetupClient, bool &IsConnected)
bool | GeViAPI_SetupClient_Disconnect (HGeViSetupClient SetupClient)
bool | GeViAPI_SetupClient_ReadSetup (HGeViSetupClient SetupClient, void *HFile)
bool | GeViAPI_SetupClient_WriteSetup (HGeViSetupClient SetupClient, void *HFile)
bool | GeViAPI_SetupClient_SetCBNotification (HGeViSetupClient SetupClient, TGeViDatabaseNotification ACallback, void *AInstance)
bool | GeViAPI_SetupClient_GetAliasname (HGeViSetupClient SetupClient, char *&Aliasname)
bool | GeViAPI_SetupClient_GetAddress (HGeViSetupClient SetupClient, char *&Address)
bool | GeViAPI_SetupClient_GetUsername (HGeViSetupClient SetupClient, char *&Username, char *&Username2)
bool | GeViAPI_SetupClient_GetPassword (HGeViSetupClient SetupClient, char *&Password, char *&Password2)
bool | GeViAPI_SetupClient_SendQuery (HGeViSetupClient SetupClient, const char *SendMessageBuffer, int SendBufferSize, char *&RecMessageBuffer, int &BytesRead, int TimeOut)
bool | GeViAPI_SetupClient_AbortAllQueries (HGeViSetupClient SetupClient)

Variables

const int | GeViProcAPIVersion = 0x00010001
const int | EClassCmdNotImplemented = -2
const int | EClassCmdAborted = -1
const int | EClassUnknown = 0
const int | EClassGeneric = 1
const int | EClassIPConnection = 2
const int | EClassSystem = 3
const int | EClassInvalidHandle = 4
const int | EClassNoMessages = 5
const int | EClassTimeout = 6

Typedef Documentation

typedef GeViHandleStruct* HGeViDatabase
typedef GeViHandleStruct* HGeViDeviceClient
typedef GeViHandleStruct* HGeViSetupClient
typedef TServerNotification Notification
typedef TGeViConnectProgress TGeViAPIConnectProgress
typedef TGeViServerNotification TGeViAPIServerNotification
typedef bool(__stdcall * TGeViConnectProgress)(void *Instance, int Percentage, int Percent100)

Signature for the connect progress callback method.

Enumeration Type Documentation

enum TConnectResult
Enumerator:
connectOk
connectWarningInvalidHeaders
connectWarningMax
connectAborted
connectGenericError
connectFileEmpty
connectFileAccessError
connectFileInvalid
connectFileInvalidVersion
connectFileCouldNotOpen
connectTapeNotCompatible
connectTapeNotReady
connectTapeInvalid
connectTapeEmpty
connectTapeInvalidVersion
connectTapeCouldNotOpen
connectRemoteUnkownError
connectRemoteTcpError
connectRemoteUnknownUser
connectRemoteConnectionLimitExceeded
connectRemoteClientInterfaceTooOld
connectRemoteServerInterfaceTooOld
connectRemoteSecondUserRequired
connectRemotePortDisabled
connectDummyValue
enum TServerNotification
Enumerator:
NFServer_SetupModified
NFServer_Disconnected
NFServer_GoingShutdown
NFServer_NewMessage
NFServer_DummyValue

Function Documentation

bool GeViAPI_CheckSocketVersion | ( | bool & | Sufficient,
 |  | int & | SocketVersionExpected,
 |  | int & | SocketVersionFound,
 |  | bool & | ProtocolsMissing
 | ) |  |

Check if the version of the installed Socket-DLL is sufficient for the GeViProcAPI.DLL.

bool GeViAPI_Database_AbortAllQueries ( HGeViDatabase Database )
bool GeViAPI_Database_Connected | ( | HGeViDatabase | Database,
 |  | bool & | IsConnected
 | ) |  |
Warning:
Do not use!

Use GeViAPI_Database_SendPing instead to check if a connection is established!

bool GeViAPI_Database_Destroy ( HGeViDatabase Database )
bool GeViAPI_Database_GetAddress | ( | HGeViDatabase | Database,
 |  | char *& | Address
 | ) |  |
bool GeViAPI_Database_GetAliasname | ( | HGeViDatabase | Database,
 |  | char *& | Aliasname
 | ) |  |
bool GeViAPI_Database_GetDateTime | ( | HGeViDatabase | Database,
 |  | TMscNativeDateTime & | GMT,
 |  | TMscNativeDateTime & | LocalTime
 | ) |  |
bool GeViAPI_Database_GetDifferenceToServerTime | ( | HGeViDatabase | Database,
 |  | __int64 & | Milliseconds
 | ) |  |
bool GeViAPI_Database_GetPassword | ( | HGeViDatabase | Database,
 |  | char *& | Password,
 |  | char *& | Password2
 | ) |  |
bool GeViAPI_Database_GetUsername | ( | HGeViDatabase | Database,
 |  | char *& | Username,
 |  | char *& | Username2
 | ) |  |
bool GeViAPI_Database_SendToMessage | ( | HGeViDatabase | Database,
 |  | const char * | ClientName,
 |  | const char * | MessageBuffer,
 |  | int | BufferSize
 | ) |  |
bool GeViAPI_Database_SyncTime | ( | HGeViDatabase | Database,
 |  | bool | ForceSync
 | ) |  |
bool GeViAPI_DecodeDateTime | ( | const GeViAPI_Namespace::TMscNativeDateTime | DT,
 |  | unsigned short & | Year,
 |  | unsigned short & | Month,
 |  | unsigned short & | Day,
 |  | unsigned short & | Hour,
 |  | unsigned short & | Min,
 |  | unsigned short & | Sec,
 |  | unsigned short & | MSec
 | ) |  |

Decodes date and time from TMscNativeDateTime.

bool GeViAPI_DeviceClient_AbortAllQueries ( HGeViDeviceClient DeviceClient )
bool GeViAPI_DeviceClient_ActivateServerPing | ( | HGeViDeviceClient | DeviceClient,
 |  | unsigned __int32 | CheckPeriod
 | ) |  |
bool GeViAPI_DeviceClient_AutoConnect | ( | HGeViDeviceClient | DeviceClient,
 |  | TConnectResult & | ConnectResult
 | ) |  |
bool GeViAPI_DeviceClient_Connect | ( | HGeViDeviceClient | DeviceClient,
 |  | TConnectResult & | ConnectResult,
 |  | TGeViConnectProgress | ACallback,
 |  | void * | AInstance
 | ) |  |
bool GeViAPI_DeviceClient_Connected | ( | HGeViDeviceClient | DeviceClient,
 |  | bool & | IsConnected
 | ) |  |
bool GeViAPI_DeviceClient_Create | ( | HGeViDeviceClient & | DeviceClient,
 |  | const char * | Aliasname,
 |  | const char * | Address,
 |  | const char * | Username,
 |  | const char * | Password,
 |  | const char * | Username2,
 |  | const char * | Password2
 | ) |  |
bool GeViAPI_DeviceClient_Destroy ( HGeViDeviceClient DeviceClient )
bool GeViAPI_DeviceClient_Disconnect ( HGeViDeviceClient DeviceClient )
bool GeViAPI_DeviceClient_GetAddress | ( | HGeViDeviceClient | DeviceClient,
 |  | char *& | Address
 | ) |  |
bool GeViAPI_DeviceClient_GetAliasname | ( | HGeViDeviceClient | DeviceClient,
 |  | char *& | Aliasname
 | ) |  |
bool GeViAPI_DeviceClient_GetDateTime | ( | HGeViDeviceClient | DeviceClient,
 |  | TMscNativeDateTime & | GMT,
 |  | TMscNativeDateTime & | LocalTime
 | ) |  |
bool GeViAPI_DeviceClient_GetDifferenceToServerTime | ( | HGeViDeviceClient | DeviceClient,
 |  | __int64 & | Milliseconds
 | ) |  |
bool GeViAPI_DeviceClient_GetPassword | ( | HGeViDeviceClient | DeviceClient,
 |  | char *& | Password,
 |  | char *& | Password2
 | ) |  |
bool GeViAPI_DeviceClient_GetUsername | ( | HGeViDeviceClient | DeviceClient,
 |  | char *& | Username,
 |  | char *& | Username2
 | ) |  |
bool GeViAPI_DeviceClient_ReadSetup | ( | HGeViDeviceClient | DeviceClient,
 |  | void * | HFile
 | ) |  |
bool GeViAPI_DeviceClient_SendMessage | ( | HGeViDeviceClient | DeviceClient,
 |  | const char * | MessageBuffer,
 |  | int | BufferSize
 | ) |  |
bool GeViAPI_DeviceClient_SendPing ( HGeViDeviceClient DeviceClient )
bool GeViAPI_DeviceClient_SendQuery | ( | HGeViDeviceClient | DeviceClient,
 |  | const char * | SendMessageBuffer,
 |  | int | SendBufferSize,
 |  | char *& | RecMessageBuffer,
 |  | int & | BytesRead,
 |  | int | TimeOut
 | ) |  |
bool GeViAPI_DeviceClient_SendToMessage | ( | HGeViDeviceClient | DeviceClient,
 |  | const char * | ClientName,
 |  | const char * | MessageBuffer,
 |  | int | BufferSize
 | ) |  |
bool GeViAPI_DeviceClient_SetCBNotification | ( | HGeViDeviceClient | DeviceClient,
 |  | TGeViDatabaseNotification | ACallback,
 |  | void * | AInstance
 | ) |  |
bool GeViAPI_DeviceClient_SyncTime | ( | HGeViDeviceClient | DeviceClient,
 |  | bool | ForceSync
 | ) |  |
bool GeViAPI_DeviceClient_TerminateAutoConnect ( HGeViDeviceClient DeviceClient )
bool GeViAPI_EncodeDateTime | ( | GeViAPI_Namespace::TMscNativeDateTime & | DT,
 |  | unsigned short | Year,
 |  | unsigned short | Month,
 |  | unsigned short | Day,
 |  | unsigned short | Hour,
 |  | unsigned short | Min,
 |  | unsigned short | Sec,
 |  | unsigned short | MSec
 | ) |  |

Encodes date and time to TMscNativeDateTime.

bool GeViAPI_FreePointer ( void * Pointer )

Free memory allocated in the DLL.

bool GeViAPI_GetLastError | ( | int & | AExceptionClass,
 |  | int & | ErrorNo,
 |  | int & | ErrorClass,
 |  | char *& | ErrorMessage
 | ) |  |

Returns information about the last occured error in the current thread Should be called when any of the other API functions returns false.

int GeViAPI_InterfaceVersion ( )

Returns the interface version number of the used GeViProcAPI.dll Should be checked against the "GeViProcAPIVersion".

bool GeViAPI_SetupClient_AbortAllQueries ( HGeViSetupClient SetupClient )
bool GeViAPI_SetupClient_ActivateServerPing | ( | HGeViSetupClient | SetupClient,
 |  | unsigned __int32 | CheckPeriod
 | ) |  |
bool GeViAPI_SetupClient_Connect | ( | HGeViSetupClient | SetupClient,
 |  | TConnectResult & | ConnectResult,
 |  | TGeViConnectProgress | ACallback,
 |  | void * | AInstance
 | ) |  |
bool GeViAPI_SetupClient_Connected | ( | HGeViSetupClient | SetupClient,
 |  | bool & | IsConnected
 | ) |  |
bool GeViAPI_SetupClient_Create | ( | HGeViSetupClient & | SetupClient,
 |  | const char * | Aliasname,
 |  | const char * | Address,
 |  | const char * | Username,
 |  | const char * | Password,
 |  | const char * | Username2,
 |  | const char * | Password2
 | ) |  |
bool GeViAPI_SetupClient_Destroy ( HGeViSetupClient SetupClient )
bool GeViAPI_SetupClient_Disconnect ( HGeViSetupClient SetupClient )
bool GeViAPI_SetupClient_GetAddress | ( | HGeViSetupClient | SetupClient,
 |  | char *& | Address
 | ) |  |
bool GeViAPI_SetupClient_GetAliasname | ( | HGeViSetupClient | SetupClient,
 |  | char *& | Aliasname
 | ) |  |
bool GeViAPI_SetupClient_GetDifferenceToServerTime | ( | HGeViSetupClient | SetupClient,
 |  | __int64 & | Milliseconds
 | ) |  |
bool GeViAPI_SetupClient_GetPassword | ( | HGeViSetupClient | SetupClient,
 |  | char *& | Password,
 |  | char *& | Password2
 | ) |  |
bool GeViAPI_SetupClient_GetUsername | ( | HGeViSetupClient | SetupClient,
 |  | char *& | Username,
 |  | char *& | Username2
 | ) |  |
bool GeViAPI_SetupClient_ReadSetup | ( | HGeViSetupClient | SetupClient,
 |  | void * | HFile
 | ) |  |
bool GeViAPI_SetupClient_SendPing ( HGeViSetupClient SetupClient )
bool GeViAPI_SetupClient_SendQuery | ( | HGeViSetupClient | SetupClient,
 |  | const char * | SendMessageBuffer,
 |  | int | SendBufferSize,
 |  | char *& | RecMessageBuffer,
 |  | int & | BytesRead,
 |  | int | TimeOut
 | ) |  |
bool GeViAPI_SetupClient_SetCBNotification | ( | HGeViSetupClient | SetupClient,
 |  | TGeViDatabaseNotification | ACallback,
 |  | void * | AInstance
 | ) |  |
bool GeViAPI_SetupClient_SyncTime | ( | HGeViSetupClient | SetupClient,
 |  | bool | ForceSync
 | ) |  |
bool GeViAPI_SetupClient_WriteSetup | ( | HGeViSetupClient | SetupClient,
 |  | void * | HFile
 | ) |  |
typedef void ( __stdcall * TGeViServerNotification )

Signature for the database notification callback method.

Signature for the server notification callback method.

This method is registered in the GeViAPIClient::SetCBNotification method if using GeViAPIClient or in ...

Variable Documentation

const int EClassCmdAborted = -1
const int EClassCmdNotImplemented = -2
const int EClassGeneric = 1
const int EClassInvalidHandle = 4
const int EClassIPConnection = 2
const int EClassNoMessages = 5
const int EClassSystem = 3
const int EClassTimeout = 6
const int EClassUnknown = 0
const int GeViProcAPIVersion = 0x00010001


GeViSoft SDK: index.h File Reference

  • File List
  • File Members
index.h File Reference

Go to the source code of this file.


GeViSoft SDK: MessageBase.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines | Functions
MessageBase.h File Reference
#include <string.h>
#include "ActionCode.h"
#include "StateQueryCode.h"
#include "DatabaseQueryCode.h"
#include "GeViConst.h"
#include "MessageBuffer.h"
Include dependency graph for MessageBase.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | GeViAPI_Namespace::CReferenceObject
class | GeViAPI_Namespace::CGeViMessage
class | GeViAPI_Namespace::CAction
class | GeViAPI_Namespace::CActivity
class | GeViAPI_Namespace::CStateQuery
class | GeViAPI_Namespace::CStateAnswer
class | GeViAPI_Namespace::CDataBaseQuery
class | GeViAPI_Namespace::CDataBaseFilter
class | GeViAPI_Namespace::CDataBaseAnswer

Namespaces

namespace | GeViAPI_Namespace

Defines

#define | REF &
#define | DEREF ->
#define | GEVI_STATIC_CAST(t, v) (static_cast<t>(v))
#define | GEVI_STATIC_CAST_REF(t, v) (static_cast<t &>(v))
#define | GEVI_REINTERPRET_CAST(t, v) (reinterpret_cast<t>(v))
#define | LESS(l, r) (l < r)
#define | GEVI_PTR_VECTOR(t, min, grow) CTPtrVector<t,min,grow>

Functions

bool | GeViAPI_Namespace::GetWriteResults (CGeViTransferBuffer *Buffer, int &BytesWrote)

Define Documentation

#define DEREF ->
#define GEVI_PTR_VECTOR | ( | t,
 |  | min,
 |  | grow
 | ) | CTPtrVector<t,min,grow>
#define GEVI_REINTERPRET_CAST | ( | t,
 |  | v
 | ) | (reinterpret_cast<t>(v))
#define GEVI_STATIC_CAST | ( | t,
 |  | v
 | ) | (static_cast<t>(v))
#define GEVI_STATIC_CAST_REF | ( | t,
 |  | v
 | ) | (static_cast<t &>(v))
#define LESS | ( | l,
 |  | r
 | ) | (l < r)
#define REF &


GeViSoft SDK: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • c
  • d
  • e
  • g
  • h
  • l
  • n
  • r
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- c -

  • connectAborted : GeViProcAPI.h
  • connectDummyValue : GeViProcAPI.h
  • connectFileAccessError : GeViProcAPI.h
  • connectFileCouldNotOpen : GeViProcAPI.h
  • connectFileEmpty : GeViProcAPI.h
  • connectFileInvalid : GeViProcAPI.h
  • connectFileInvalidVersion : GeViProcAPI.h
  • connectGenericError : GeViProcAPI.h
  • connectOk : GeViProcAPI.h
  • connectRemoteClientInterfaceTooOld : GeViProcAPI.h
  • connectRemoteConnectionLimitExceeded : GeViProcAPI.h
  • connectRemotePortDisabled : GeViProcAPI.h
  • connectRemoteSecondUserRequired : GeViProcAPI.h
  • connectRemoteServerInterfaceTooOld : GeViProcAPI.h
  • connectRemoteTcpError : GeViProcAPI.h
  • connectRemoteUnknownUser : GeViProcAPI.h
  • connectRemoteUnkownError : GeViProcAPI.h
  • connectTapeCouldNotOpen : GeViProcAPI.h
  • connectTapeEmpty : GeViProcAPI.h
  • connectTapeInvalid : GeViProcAPI.h
  • connectTapeInvalidVersion : GeViProcAPI.h
  • connectTapeNotCompatible : GeViProcAPI.h
  • connectTapeNotReady : GeViProcAPI.h
  • connectWarningInvalidHeaders : GeViProcAPI.h
  • connectWarningMax : GeViProcAPI.h

- d -

  • DEREF : MessageBase.h

- e -

  • EClassCmdAborted : GeViProcAPI.h
  • EClassCmdNotImplemented : GeViProcAPI.h
  • EClassGeneric : GeViProcAPI.h
  • EClassInvalidHandle : GeViProcAPI.h
  • EClassIPConnection : GeViProcAPI.h
  • EClassNoMessages : GeViProcAPI.h
  • EClassSystem : GeViProcAPI.h
  • EClassTimeout : GeViProcAPI.h
  • EClassUnknown : GeViProcAPI.h

- g -

  • GEVI_PTR_VECTOR : MessageBase.h
  • GEVI_REINTERPRET_CAST : MessageBase.h
  • GEVI_STATIC_CAST : MessageBase.h
  • GEVI_STATIC_CAST_REF : MessageBase.h
  • GeViAPI_CheckSocketVersion() : GeViProcAPI.h
  • GeViAPI_Database_AbortAllQueries() : GeViProcAPI.h
  • GeViAPI_Database_ActivateServerPing() : GeViProcAPI.h
  • GeViAPI_Database_Connect() : GeViProcAPI.h
  • GeViAPI_Database_Connected() : GeViProcAPI.h
  • GeViAPI_Database_Create() : GeViProcAPI.h
  • GeViAPI_Database_Destroy() : GeViProcAPI.h
  • GeViAPI_Database_Disconnect() : GeViProcAPI.h
  • GeViAPI_Database_GetAddress() : GeViProcAPI.h
  • GeViAPI_Database_GetAliasname() : GeViProcAPI.h
  • GeViAPI_Database_GetDateTime() : GeViProcAPI.h
  • GeViAPI_Database_GetDifferenceToServerTime() : GeViProcAPI.h
  • GeViAPI_Database_GetPassword() : GeViProcAPI.h
  • GeViAPI_Database_GetUsername() : GeViProcAPI.h
  • GeViAPI_Database_SendMessage() : GeViProcAPI.h
  • GeViAPI_Database_SendPing() : GeViProcAPI.h
  • GeViAPI_Database_SendQuery() : GeViProcAPI.h
  • GeViAPI_Database_SendToMessage() : GeViProcAPI.h
  • GeViAPI_Database_SetCBNotification() : GeViProcAPI.h
  • GeViAPI_Database_SyncTime() : GeViProcAPI.h
  • GeViAPI_DecodeDateTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_AbortAllQueries() : GeViProcAPI.h
  • GeViAPI_DeviceClient_ActivateServerPing() : GeViProcAPI.h
  • GeViAPI_DeviceClient_AutoConnect() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Connect() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Connected() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Create() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Destroy() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Disconnect() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetAddress() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetAliasname() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetDateTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetDifferenceToServerTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetPassword() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetUsername() : GeViProcAPI.h
  • GeViAPI_DeviceClient_ReadSetup() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendMessage() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendPing() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendQuery() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendToMessage() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SetCBNotification() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SyncTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_TerminateAutoConnect() : GeViProcAPI.h
  • GeViAPI_EncodeDateTime() : GeViProcAPI.h
  • GeViAPI_EncodeString() : GeViProcAPI.h
  • GeViAPI_FreeArray() : GeViProcAPI.h
  • GeViAPI_FreePointer() : GeViProcAPI.h
  • GeViAPI_GetLastError() : GeViProcAPI.h
  • GeViAPI_InterfaceVersion() : GeViProcAPI.h
  • GeViAPI_SetupClient_AbortAllQueries() : GeViProcAPI.h
  • GeViAPI_SetupClient_ActivateServerPing() : GeViProcAPI.h
  • GeViAPI_SetupClient_Connect() : GeViProcAPI.h
  • GeViAPI_SetupClient_Connected() : GeViProcAPI.h
  • GeViAPI_SetupClient_Create() : GeViProcAPI.h
  • GeViAPI_SetupClient_Destroy() : GeViProcAPI.h
  • GeViAPI_SetupClient_Disconnect() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetAddress() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetAliasname() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetDifferenceToServerTime() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetPassword() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetUsername() : GeViProcAPI.h
  • GeViAPI_SetupClient_ReadSetup() : GeViProcAPI.h
  • GeViAPI_SetupClient_SendPing() : GeViProcAPI.h
  • GeViAPI_SetupClient_SendQuery() : GeViProcAPI.h
  • GeViAPI_SetupClient_SetCBNotification() : GeViProcAPI.h
  • GeViAPI_SetupClient_SyncTime() : GeViProcAPI.h
  • GeViAPI_SetupClient_WriteSetup() : GeViProcAPI.h
  • GeViProcAPIVersion : GeViProcAPI.h

- h -

  • HGeViDatabase : GeViProcAPI.h
  • HGeViDeviceClient : GeViProcAPI.h
  • HGeViSetupClient : GeViProcAPI.h

- l -

  • LESS : MessageBase.h

- n -

  • NFServer_Disconnected : GeViProcAPI.h
  • NFServer_DummyValue : GeViProcAPI.h
  • NFServer_GoingShutdown : GeViProcAPI.h
  • NFServer_NewMessage : GeViProcAPI.h
  • NFServer_SetupModified : GeViProcAPI.h
  • Notification : GeViProcAPI.h

- r -

  • REF : MessageBase.h

- t -

  • TConnectResult : GeViProcAPI.h
  • TGeViAPIConnectProgress : GeViProcAPI.h
  • TGeViAPIServerNotification : GeViProcAPI.h
  • TGeViConnectProgress : GeViProcAPI.h
  • TServerNotification : GeViProcAPI.h

- v -

  • void() : GeViProcAPI.h


GeViSoft SDK: GeViAPIClient.h Source File

  • File List
  • File Members
GeViAPIClient.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 #ifndef GeViAPIClientH
00004 #define GeViAPIClientH
00005
00006 #include <string>
00007 #include <stdexcept>
00008 #include "GeViProcAPI.h"
00009 #include "MessageBase.h"
00010
00012 class EGeVi: public std::exception
00013 {
00014 public:
00015         int GeViError;
00016         int GeViErrorClass;
00017
00018         EGeVi(const char* geViMessage) :
00019                 std::exception(geViMessage), GeViError(0), GeViErrorClass(0)
00020         {
00021         }
00022
00023         EGeVi(const char* geViMessage, int geViError, int geViErrorClass) :
00024                 std::exception(geViMessage), GeViError(geViError), GeViErrorClass(geViErrorClass)
00025         {
00026         }
00027 };
00028
00029 class EGeViCmdNotImplemented : public EGeVi { public: EGeViCmdNotImplemented(const char* Message): EGeVi(Message) {} };
00030 class EGeViCmdAborted        : public EGeVi { public: EGeViCmdAborted(const char* Message): EGeVi(Message) {} };
00031 class EGeViUnknown           : public EGeVi { public: EGeViUnknown(const char* Message): EGeVi(Message) {} };
00032 class EGeViGeneric           : public EGeVi { public: EGeViGeneric(const char* Message): EGeVi(Message) {} };
00033 class EGeViIPConnection      : public EGeVi { public: EGeViIPConnection(const char* Message): EGeVi(Message) {} };
00034 class EGeViSystem            : public EGeVi { public: EGeViSystem(const char* Message): EGeVi(Message) {} };
00035 class EGeViInvalidHandle     : public EGeVi { public: EGeViInvalidHandle(const char* Message): EGeVi(Message) {} };
00036 class EGeViNoMessages        : public EGeVi { public: EGeViNoMessages(const char* Message): EGeVi(Message) {} };
00037 class EGeViTimeout           : public EGeVi { public: EGeViTimeout(const char* Message): EGeVi(Message) {} };
00038
00041 class GeViAPIClient
00042 {
00043 private:
00044         // Handle to the internal connection object of the DLL (connection to the GeViSoft Server)
00045         GeViAPI_Namespace::HGeViDatabase m_Database;
00046
00047         // Check error codes returned by DLL functions and transform them into exceptions
00048         static void GeViCheckError(bool GeViResult);
00049         static void GeViRaiseLastError();
00050
00051 public:
00053
00063         GeViAPIClient(const char* Aliasname, const char* Address,
00064                                   const char* Username, const char* Password,
00065                                   const char* Username2, const char* Password2);
00066
00067
00069         ~GeViAPIClient();
00070
00071
00074
00079         GeViAPI_Namespace::TConnectResult Connect(const GeViAPI_Namespace::TGeViConnectProgress ACallback, void* AInstance);
00080
00081
00083         void Disconnect();
00084
00085
00088
00092         void SetCBNotification(const GeViAPI_Namespace::TGeViDatabaseNotification ACallback,void* AInstance);
00093
00094
00096
00099         void SendMessage(GeViAPI_Namespace::CGeViMessage* GeViMessage);
00100
00101
00104
00109         GeViAPI_Namespace::CDataBaseAnswer* SendDatabaseQuery(GeViAPI_Namespace::CDataBaseQuery* GeViMessage, const int timeout_ms);
00110
00111
00114
00119     GeViAPI_Namespace::CStateAnswer* SendStateQuery(GeViAPI_Namespace::CStateQuery* GeViQuery, const int timeout_ms);
00120
00121
00124
00127         GeViAPI_Namespace::HGeViDatabase GetDatabase(void);
00128
00131
00136         static void EncodePassword(char* Dest, const char* Source, int DestSize);
00137
00141
00144         bool SendPing();
00145
00146         // Activate Server side ping/pong (only call this once after connection has been established); CheckPeriod is time in ms
00147         bool ActivateServerPing(unsigned __int32 CheckPeriod);
00148 };
00149
00150 #endif // GeViAPIClientH


GeViSoft SDK: GeViConst.h Source File

  • File List
  • File Members
GeViConst.h
Go to the documentation of this file.
00001
00002 #ifndef GeViConstH
00003 #define GeViConstH
00004
00005 namespace GeViAPI_Namespace {
00006
00007   const int GEVI_MAXSTRINGLENGTH = 1024;
00008   const int GEVI_MAXACTIONLENGTH = 2048;
00009   const int GeViGscOffset        = 0x1000;
00010
00011   enum TMessageKind {
00012      mk_Action          = 1,
00013      mk_Activity        = 2,
00014      mk_DataBaseQuery   = 3,
00015      mk_DataBaseAnswer  = 4,
00016      mk_CommandMessage  = 5,
00017      mk_CommandAnswer   = 6,
00018      mk_StateQuery      = 7,
00019      mk_StateAnswer     = 8
00020   };
00021
00022   typedef __int64 TClientID;
00023   typedef __int32 TVideoInputID;
00024   typedef __int32 TVideoOutputID;
00025   typedef __int32 TInputContactID;
00026   typedef __int32 TOutputContactID;
00027 //  typedef __int32 TRessourceID;
00028   typedef __int32 TMGID;
00029
00030   typedef __int32 TMscEventTypeID;
00031   typedef __int32 TEventTypeID;
00032   typedef __int32 TAlarmTypeID;
00033   typedef __int64 TMscEventID;
00034   typedef __int64 TEventID;
00035   typedef __int64 TAlarmID;
00036   typedef __int32 int32;
00037
00038 //  typedef char* TUserName;
00039
00040   // for internal purpose only
00041   typedef int TMessageInternal;
00042
00043   struct TGeViDateTime {
00044     unsigned int TimePart;   // Millisekunden seit Mitternacht
00045     unsigned int DatePart;   // Tage seit dem 1.1.0001 + 1
00046   };
00047 //  struct TMscNativeDateTime {
00048 //    unsigned int TimePart;   // Millisekunden seit Mitternacht
00049 //    unsigned int DatePart;   // Tage seit dem 1.1.0001 + 1
00050 //  };
00051
00052   class TActionData {
00053     public:
00054       char* m_Buffer;
00055       int   m_BufferSize;
00056
00057     public:
00058       TActionData()
00059       {
00060         m_Buffer = 0;
00061         m_BufferSize = 0;
00062       }
00063       ~TActionData()
00064       {
00065         Clear();
00066       }
00067       TActionData(const TActionData& Other)
00068       {
00069         if (Other.m_BufferSize) {
00070           m_Buffer = new char [Other.m_BufferSize];
00071           memcpy(m_Buffer, Other.m_Buffer, Other.m_BufferSize);
00072           m_BufferSize = Other.m_BufferSize;
00073         } else {
00074           m_Buffer = 0;
00075           m_BufferSize = 0;
00076         }
00077       }
00078       TActionData& operator= (const TActionData& Other)
00079       {
00080         if (this != &Other) {
00081           Clear();
00082
00083           if (Other.m_BufferSize) {
00084             m_Buffer = new char [Other.m_BufferSize];
00085             memcpy(m_Buffer, Other.m_Buffer, Other.m_BufferSize);
00086             m_BufferSize = Other.m_BufferSize;
00087           } else {
00088             m_Buffer = 0;
00089             m_BufferSize = 0;
00090           }
00091         }
00092         return *this;
00093       }
00094       void Clear()
00095       {
00096         if (m_Buffer) {
00097           delete [] m_Buffer;
00098         }
00099         m_Buffer = 0;
00100         m_BufferSize = 0;
00101       }
00102   };
00103
00104 /*
00105  GEVISERVER ports
00106  */
00107 enum TGeViPort {
00108   gp_UserPort = 0,
00109   gp_SetupPort = 1,
00110   gp_DevicePort = 2,
00111
00112 };
00113
00114 /*
00115  Reasons for the login failures
00116  */
00117 enum TLoginFailure {
00118   lf_Ok = 0,
00119   lf_UnknownUser = 1,
00120   lf_InvalidPassword = 2,
00121   lf_SecondUserRequired = 3,
00122   lf_SecondUserUnknown = 4,
00123   lf_LicenseRestriction = 5,
00124   lf_ProtocolFailure = 6,
00125   lf_WrongInterfaceVersion = 7,
00126   lf_PasswordCorrupt = 8,
00127   lf_AccessDenied = 9,
00128   lf_NoMultipleLogin = 10,
00129   lf_GeneralFailure = 20,
00130
00131 };
00132
00133 /*
00134  Switch mode for the CrossSwitch action
00135  */
00136 enum TSwitchMode {
00137   sm_Normal = 0x0,
00138   sm_KP = 0x1,
00139   sm_CP = 0x2,
00140   sm_VX3_CT = 0x3,
00141   sm_MonitorCycle = 0xffffffff,
00142
00143 };
00144
00145 /*
00146  Text compare operator for the database queries
00147  */
00148 enum TDBCompare {
00149   dbc_LIKE = 0x0,
00150   dbc_LE = 0xFFFFFFFF,
00151   dbc_GE = 0x1,
00152
00153 };
00154
00155 /*
00156  Resource type
00157  */
00158 enum TGeViResourceType {
00159   rt_DigitalInput = 0,
00160   rt_DigitalOutput = 1,
00161   rt_VideoInput = 2,
00162   rt_VideoOutput = 3,
00163   rt_MonitorGroup = 4,
00164
00165 };
00166
00167 /*
00168  Special values used in CrossSwitch action
00169  */
00170   const TVideoInputID
00171 csa_Last = 0;
00172   const TVideoInputID
00173 csa_Previous = -2;
00174   const TVideoInputID
00175 csa_Next = -1;
00176
00177 /*
00178  Special values used in InputContact action
00179  */
00180   const bool
00181 ics_Open = false;
00182   const bool
00183 ics_Closed = true;
00184
00185 /*
00186  Special values used in VSArmed action
00187  */
00188   const bool
00189 vss_Armed = true;
00190   const bool
00191 vss_Disarmed = false;
00192
00193 /*
00194  Special values used in VSPictureDetect action
00195  */
00196   const bool
00197 vsc_Ok = true;
00198   const bool
00199 vsc_Failure = false;
00200
00201 /*
00202  Special values used in VSPictureToOutput action
00203  */
00204   const bool
00205 vsp_Live = true;
00206   const bool
00207 vsp_Stored = false;
00208
00209 /*
00210  Preset positions, used in state queries
00211  */
00212   const __int32
00213 pp_Unknown = -1;
00214   const __int32
00215 pp_BasePosition = -2;
00216
00217 /*
00218  Pan direction, used in state queries
00219  */
00220   const __int32
00221 pd_Left = -1;
00222   const __int32
00223 pd_Right = 1;
00224   const __int32
00225 pd_None = 0;
00226
00227 /*
00228  Tilt direction, used in state queries
00229  */
00230   const __int32
00231 td_Up = -1;
00232   const __int32
00233 td_Down = 1;
00234   const __int32
00235 td_None = 0;
00236
00237 /*
00238  State of the digital contacts, used in state queries
00239  */
00240   const __int32
00241 ecs_Closed = -1;
00242   const __int32
00243 ecs_Open = 1;
00244   const __int32
00245 ecs_Unknown = 0;
00246   const __int32
00247 ecs_Sabotage = 3;
00248   const __int32
00249 ecs_Alternating = 2;
00250
00251 /*
00252  Interface kinds, used in state queries
00253  */
00254   const __int32
00255 ik_Special = 0;
00256   const __int32
00257 ik_Compax = 1;
00258   const __int32
00259 ik_GeViCom = 2;
00260   const __int32
00261 ik_GeViGST = 3;
00262   const __int32
00263 ik_GeViTel = 5;
00264   const __int32
00265 ik_Phoenix = 6;
00266   const __int32
00267 ik_RAWDevice = 7;
00268   const __int32
00269 ik_VicrosII = 8;
00270   const __int32
00271 ik_VicrosIII = 9;
00272   const __int32
00273 ik_VS40 = 10;
00274   const __int32
00275 ik_VSM = 11;
00276
00277 /*
00278  User kinds, used in state queries
00279  */
00280   const __int32
00281 uk_User = 1;
00282   const __int32
00283 uk_Interface = 2;
00284   const __int32
00285 uk_Client = 3;
00286   const __int32
00287 uk_SysAdmin = 4;
00288
00289 /*
00290  Alarm field by external alarms
00291  */
00292   const __int32
00293 vsa_ExternalAlarm = -1;
00294
00295 /*
00296  Console for the output operations like LogMessage
00297  */
00298   const __int32
00299 ocd_Database = 0;
00300   const __int32
00301 ocd_EventLog = 1;
00302
00303 /*
00304  Default speed for the PTZF operations
00305  */
00306   const __int32
00307 ccs_NormalTemp = 0;
00308
00309 /*
00310  Relation between actions and alarms
00311  */
00312   const __int32
00313 dbar_None = 0;
00314   const __int32
00315 dbar_Start = 1;
00316   const __int32
00317 dbar_Reaction = 2;
00318   const __int32
00319 dbar_Ack = 3;
00320   const __int32
00321 dbar_Quit = 4;
00322
00323 /*
00324  User's access right mask constants (OR connected)
00325  */
00326   const __int32
00327 RightToAccessToUserPort = 0x1;
00328   const __int32
00329 RightToAccessToSetupPort = 0x2;
00330   const __int32
00331 RightToAccessToDevicePort = 0x4;
00332   const __int32
00333 SupervisorRight = 0x00000100;
00334   const __int32
00335 RightToMultiLogin = 0x00000200;
00336   const __int32
00337 AccessDatabaseRight = 0x00000400;
00338   const __int32
00339 ControlDatabaseRight = 0x00000800;
00340   const __int32
00341 Generic1Right = 0x00001000;
00342   const __int32
00343 Generic2Right = 0x00002000;
00344   const __int32
00345 Generic3Right = 0x00004000;
00346   const __int32
00347 Generic4Right = 0x00008000;
00348   const __int32
00349 Generic5Right = 0x00010000;
00350   const __int32
00351 DirectMessageRight = 0x00020000;
00352   const __int32
00353 SpecialActionRight = 0x00040000;
00354   const __int32
00355 AlarmActionRight = 0x00100000;
00356
00357 }; // namespace
00358
00359 //------------------------
00360 //
00361 #endif
00362


GeViSoft SDK: GeViProcAPI.h Source File

  • File List
  • File Members
GeViProcAPI.h
Go to the documentation of this file.
00001 const int GeViProcAPIVersion = 0x00010001;
00002 const int EClassCmdNotImplemented  = -2;
00003 const int EClassCmdAborted         = -1;
00004 const int EClassUnknown            = 0;
00005 const int EClassGeneric            = 1;
00006 const int EClassIPConnection       = 2;
00007 const int EClassSystem             = 3;
00008 const int EClassInvalidHandle      = 4;
00009 const int EClassNoMessages         = 5;
00010 const int EClassTimeout            = 6;
00011
00012 enum TServerNotification {NFServer_SetupModified  = 0,
00013                           NFServer_Disconnected   = 10,
00014                           NFServer_GoingShutdown  = 11,
00015                           NFServer_NewMessage     = 12,
00016                           NFServer_DummyValue     = 0x7FFFFFFF}; // force 4 byte size
00017
00018 enum TConnectResult {connectOk                             = 0,
00019                      connectWarningInvalidHeaders          = 1,
00020                      connectWarningMax                     = 99,
00021                      connectAborted                        = 100,
00022                      connectGenericError                   = 101,
00023                      // Error values for local media
00024                      connectFileEmpty                      = 200,
00025                      connectFileAccessError                = 201,
00026                      connectFileInvalid                    = 202,
00027                      connectFileInvalidVersion             = 203,
00028                      connectFileCouldNotOpen               = 204,
00029
00030                      connectTapeNotCompatible              = 250,
00031                      connectTapeNotReady                   = 251,
00032                      connectTapeInvalid                    = 252,
00033                      connectTapeEmpty                      = 253,
00034                      connectTapeInvalidVersion             = 254,
00035                      connectTapeCouldNotOpen               = 255,
00036                      connectRemoteUnkownError              = 300,
00037                      connectRemoteTcpError                 = 301,
00038                      connectRemoteUnknownUser              = 302,
00039                      connectRemoteConnectionLimitExceeded  = 303,
00040                      connectRemoteClientInterfaceTooOld    = 304,
00041                      connectRemoteServerInterfaceTooOld    = 305,
00042                      connectRemoteSecondUserRequired       = 306,
00043                      connectRemotePortDisabled             = 307,
00044                      connectDummyValue                     = 0x7FFFFFFF};
00045 struct TMessageEntry {
00046   char*   Buffer;
00047   __int32 Length;
00048 };
00049
00051 struct GeViHandleStruct {};
00052
00053 typedef GeViHandleStruct* HGeViSetupClient;
00054 typedef GeViHandleStruct* HGeViDatabase;
00055 typedef GeViHandleStruct* HGeViDeviceClient;
00056
00058 typedef bool (__stdcall *TGeViConnectProgress)(void* Instance, int Percentage, int Percent100){};
00059
00062 typedef void (__stdcall *TGeViDatabaseNotification)(void* Instance, TServerNotification Notification, void* Params){};
00063
00066 typedef void (__stdcall *TGeViServerNotification)(void* Instance, TServerNotification Notification, void* Params){};
00067
00068 typedef TGeViConnectProgress TGeViAPIConnectProgress;
00069 typedef TGeViServerNotification TGeViAPIServerNotification;
00070
00071
00073 struct TMscGenericDateTime
00074 {
00075   unsigned int Year;
00076   unsigned int Month;
00077   unsigned int Day;
00079   unsigned int DoW;
00080   unsigned int Hour;
00081   unsigned int Min;
00082   unsigned int Sec;
00083   unsigned int MSec;
00084 };
00085
00086
00088 struct TMscNativeDateTime
00089 {
00091   unsigned int TimePart;
00093   unsigned int DatePart;
00094 };
00095
00096
00097
00100 int   GeViAPI_InterfaceVersion() {};
00101
00102
00105 bool  GeViAPI_GetLastError(int& AExceptionClass,
00106                     int& ErrorNo,
00107                     int& ErrorClass,
00108                     char*& ErrorMessage){};
00109
00110
00113
00119 bool  GeViAPI_EncodeString(
00120                     char* Dest,
00121                     const char* Source,
00122                     int DestSize){};
00123
00124
00125
00128 bool  GeViAPI_CheckSocketVersion(
00129                     bool& Sufficient,
00130                     int& SocketVersionExpected,
00131                     int& SocketVersionFound,
00132                     bool& ProtocolsMissing){};
00133
00134
00136 bool  GeViAPI_FreePointer(
00137                     void* Pointer){};
00138
00141
00146 bool  GeViAPI_FreeArray(
00147                     char* Pointer){};
00148
00149
00150 bool  GeViAPI_SetupClient_SyncTime(
00151                     HGeViSetupClient SetupClient,
00152                     bool ForceSync){};
00153
00154 bool  GeViAPI_SetupClient_GetDifferenceToServerTime(
00155                     HGeViSetupClient SetupClient,
00156                     __int64& Milliseconds){};
00157
00158
00159 bool  GeViAPI_DeviceClient_SyncTime(
00160                     HGeViDeviceClient DeviceClient,
00161                     bool ForceSync){};
00162 // sync time with the server
00163
00164 bool  GeViAPI_DeviceClient_GetDifferenceToServerTime(
00165                     HGeViDeviceClient DeviceClient,
00166                     __int64& Milliseconds){};
00167 // Get the difference to the server time in milliseconds
00168
00169 bool  GeViAPI_Database_SyncTime(
00170                     HGeViDatabase Database,
00171                     bool ForceSync){};
00172 // sync time with the server
00173
00174 bool  GeViAPI_Database_GetDifferenceToServerTime(
00175                     HGeViDatabase Database,
00176                     __int64& Milliseconds){};
00177
00179 bool  GeViAPI_EncodeDateTime(GeViAPI_Namespace::TMscNativeDateTime& DT,
00180   unsigned short Year, unsigned short Month, unsigned short Day,
00181   unsigned short Hour, unsigned short Min, unsigned short Sec, unsigned short MSec){};
00182
00184 bool  GeViAPI_DecodeDateTime(const GeViAPI_Namespace::TMscNativeDateTime DT,
00185   unsigned short &Year, unsigned short &Month, unsigned short &Day,
00186   unsigned short &Hour, unsigned short &Min, unsigned short &Sec, unsigned short &MSec){};
00187
00189 // Functions for check connection
00191
00192 bool  GeViAPI_SetupClient_SendPing(
00193                     HGeViSetupClient SetupClient){};
00194
00195
00196
00200
00205 bool  GeViAPI_Database_SendPing(
00206                     HGeViDatabase UserClient){};
00207
00208 bool  GeViAPI_DeviceClient_SendPing(
00209                     HGeViDeviceClient DeviceClient){};
00210 // send ping to the server
00211 // true if ok
00212 // false otherwise
00213
00214 bool  GeViAPI_SetupClient_ActivateServerPing(
00215                     HGeViSetupClient SetupClient,
00216                     unsigned __int32 CheckPeriod){};
00217
00222
00230 bool  GeViAPI_Database_ActivateServerPing(
00231                     HGeViDatabase UserClient,
00232                     unsigned __int32 CheckPeriod){};
00233 bool  GeViAPI_DeviceClient_ActivateServerPing(
00234                     HGeViDeviceClient DeviceClient,
00235                     unsigned __int32 CheckPeriod){};
00236 // activate/deactivate server-side ping
00237 // CheckPeriod - time in milliseconds
00238 //           0 - deactivate
00239 //           else in range 100 - 60000
00240
00242 // Database functions
00244
00246
00259 bool  GeViAPI_Database_Create(
00260                     HGeViDatabase& Database,
00261                     const char* Aliasname, const char* Address,
00262                     const char* Username , const char* Password,
00263                     const char* Username2, const char* Password2){};
00264 // Create a remote database object to access a GeViSoft database
00265 // The password must be encrypted with GeViAPI_EncodeString
00266 // If store the password in a file or in the registry, you should do this also encrypted
00267 // It is not possible to decrypt the password after encryption.
00268 // Username2 and Password2 are optional, they can be NULL if you login
00269 // as a single user
00270
00271 bool  GeViAPI_Database_Destroy(
00272                     HGeViDatabase Database){};
00273 // Destroy database object
00274
00277
00285 bool  GeViAPI_Database_Connect(
00286                     HGeViDatabase Database,
00287                     TConnectResult& ConnectResult,
00288                     TGeViConnectProgress ACallback,
00289                     void* AInstance){};
00290 // Connect to the database, ConnectResult = connectOk on success
00291
00292
00296 bool  GeViAPI_Database_Connected(
00297                     HGeViDatabase Database,
00298                     bool& IsConnected){};
00299
00302
00307 bool  GeViAPI_Database_Disconnect(
00308                     HGeViDatabase Database){};
00309
00312
00320 bool  GeViAPI_Database_SetCBNotification(
00321                     HGeViDatabase Database,
00322                     TGeViDatabaseNotification ACallback,
00323                     void* AInstance){};
00324
00325 bool  GeViAPI_Database_GetAliasname(
00326                     HGeViDatabase Database,
00327                     char*& Aliasname){};
00328 // retrieve the Aliasname that was specified by the creation of the database object
00329
00330 bool  GeViAPI_Database_GetAddress(
00331                     HGeViDatabase Database,
00332                     char*& Address){};
00333 // retrieve the address of the database server to which the connection was established
00334
00335 bool  GeViAPI_Database_GetUsername(
00336                     HGeViDatabase Database,
00337                     char*& Username,
00338                     char*& Username2){};
00339 // retrieve the Username(s){};  that have been used to establish the database connection
00340
00341 bool  GeViAPI_Database_GetPassword(
00342                     HGeViDatabase Database,
00343                     char*& Password,
00344                     char*& Password2){};
00345 // retrieve the Password(s){};  that have been used to establish the connection
00346
00347 bool  GeViAPI_Database_GetDateTime(
00348                     HGeViDatabase Database,
00349                     TMscNativeDateTime& GMT,
00350                     TMscNativeDateTime& LocalTime){};
00351 // Returns the current server time as GMT and LocalTime
00352
00353
00356
00363 bool  GeViAPI_Database_SendMessage(
00364                     HGeViDatabase Database,
00365                     const char* MessageBuffer, int BufferSize){};
00366 // Sends a message to the GeViServer
00367
00368 bool  GeViAPI_Database_SendToMessage(
00369                     HGeViDatabase Database,
00370                     const char* ClientName,
00371                     const char* MessageBuffer, int BufferSize){};
00372 // Sends a message to some specific client
00373
00376
00387 bool  GeViAPI_Database_SendQuery(
00388                     HGeViDatabase Database,
00389                     const char* SendMessageBuffer, int SendBufferSize,
00390                     char*& RecMessageBuffer, int& BytesRead, int TimeOut){};
00391 // Send Query and receive the answer from the GeViServer
00392 // The buffer "RecMessageBuffer" should be freed with FreeArray after use
00393
00394 bool  GeViAPI_Database_AbortAllQueries(
00395                     HGeViDatabase Database){};
00396 // Abort all queries
00397
00399 // DeviceClient functions
00401
00402 bool  GeViAPI_DeviceClient_Create(
00403                     HGeViDeviceClient& DeviceClient,
00404                     const char* Aliasname, const char* Address,
00405                     const char* Username , const char* Password,
00406                     const char* Username2, const char* Password2){};
00407 // Create a DeviceClient object to access a GeViSoft server
00408 // The password must be encrypted with GeViAPI_EncodeString
00409 // If store the password in a file or in the registry, you should do this also encrypted
00410 // It is not possible to decrypt the password after encryption.
00411 // Username2 and Password2 are optional, they can be NULL if you login
00412 // as a single user
00413
00414 bool  GeViAPI_DeviceClient_Destroy(
00415                     HGeViDeviceClient DeviceClient){};
00416 // Destroy DeviceClient object
00417
00418 bool  GeViAPI_DeviceClient_Connect(
00419                     HGeViDeviceClient DeviceClient,
00420                     TConnectResult& ConnectResult,
00421                     TGeViConnectProgress ACallback,
00422                     void* AInstance){};
00423 // Connect to the server, ConnectResult = connectOk on success
00424
00425 bool  GeViAPI_DeviceClient_AutoConnect(
00426                     HGeViDeviceClient DeviceClient,
00427                     TConnectResult& ConnectResult){};
00428 // AutoConnect to the server, ConnectResult = connectOk on success
00429 // !!! important: AutoConnect ignores the second user !!!
00430
00431 bool  GeViAPI_DeviceClient_TerminateAutoConnect(
00432                     HGeViDeviceClient DeviceClient){};
00433 // Terminiere gestarteten AutoConnect to the server
00434
00435 bool  GeViAPI_DeviceClient_Connected(
00436                     HGeViDeviceClient DeviceClient,
00437                     bool& IsConnected){};
00438 // Is the database connected ?
00439
00440 bool  GeViAPI_DeviceClient_Disconnect(
00441                     HGeViDeviceClient DeviceClient){};
00442 // Disconnect from the server
00443
00444
00445 // Declares a callback function to receive notifications from the server.
00446 //Instance is used as the Instance parameter during a call of the
00447 // TGeViDatabaseNotification callback function
00448 bool  GeViAPI_DeviceClient_SetCBNotification(
00449                     HGeViDeviceClient DeviceClient,
00450                     TGeViDatabaseNotification ACallback,
00451                     void* AInstance){};
00452 // Declare a callback function to receive notifications from the server,
00453 // Instance is used as the Instance parameter during a call of the
00454 // TGeViDatabaseNotification callback function
00455
00456 bool  GeViAPI_DeviceClient_GetAliasname(
00457                     HGeViDeviceClient DeviceClient,
00458                     char*& Aliasname){};
00459 // retrieve the Aliasname that was specified by the creation of the database object
00460
00461 bool  GeViAPI_DeviceClient_GetAddress(
00462                     HGeViDeviceClient DeviceClient,
00463                     char*& Address){};
00464 // retrieve the address of the database server to which the connection was established
00465
00466 bool  GeViAPI_DeviceClient_GetUsername(
00467                     HGeViDeviceClient DeviceClient,
00468                     char*& Username,
00469                     char*& Username2){};
00470 // retrieve the Username(s){};  that have been used to establish the database connection
00471
00472 bool  GeViAPI_DeviceClient_GetPassword(
00473                     HGeViDeviceClient DeviceClient,
00474                     char*& Password,
00475                     char*& Password2){};
00476 // retrieve the Password(s){};  that have been used to establish the connection
00477
00478 bool  GeViAPI_DeviceClient_GetDateTime(
00479                     HGeViDeviceClient DeviceClient,
00480                     TMscNativeDateTime& GMT,
00481                     TMscNativeDateTime& LocalTime){};
00482 // Returns the current server time as GMT and LocalTime
00483
00484 bool  GeViAPI_DeviceClient_SendMessage(
00485                     HGeViDeviceClient DeviceClient,
00486                     const char* MessageBuffer, int BufferSize){};
00487 // Sends a message to the GeViServer
00488
00489 bool  GeViAPI_DeviceClient_SendToMessage(
00490                     HGeViDeviceClient DeviceClient,
00491                     const char* ClientName,
00492                     const char* MessageBuffer, int BufferSize){};
00493 // Sends a message to some specific client
00494
00495 bool  GeViAPI_DeviceClient_SendQuery(
00496                     HGeViDeviceClient DeviceClient,
00497                     const char* SendMessageBuffer, int SendBufferSize,
00498                     char*& RecMessageBuffer, int& BytesRead, int TimeOut){};
00499 // Send Query and receive the answer from the GeViServer
00500 // The buffer "RecMessageBuffer" should be freed with FreeArray after use
00501
00502 bool  GeViAPI_DeviceClient_AbortAllQueries(
00503                     HGeViDeviceClient DeviceClient){};
00504 // Abort all started queries
00505
00506 bool  GeViAPI_DeviceClient_ReadSetup(
00507                     HGeViDeviceClient DeviceClient,
00508                     void* HFile){};
00509 // Read the setup registry from the server in the specfied file
00510
00512 // Setup functions
00514
00515 bool  GeViAPI_SetupClient_Create(
00516                     HGeViSetupClient& SetupClient,
00517                     const char* Aliasname, const char* Address,
00518                     const char* Username , const char* Password,
00519                     const char* Username2, const char* Password2){};
00520 // Create a setup client object to connect with the setup port of an GeViServer
00521 // The password must be encrypted with GeViAPI_EncodeString
00522 // If store the password in a file or in the registry, you should do this also encrypted
00523 // It is not possible to decrypt the password after encryption.
00524 // Username2 and Password2 are optional, they can be NULL if you login
00525 // as a single user
00526
00527 bool  GeViAPI_SetupClient_Destroy(
00528                     HGeViSetupClient SetupClient){};
00529 // Destroy the setup client object
00530
00531 bool  GeViAPI_SetupClient_Connect(
00532                     HGeViSetupClient SetupClient,
00533                     TConnectResult& ConnectResult,
00534                     TGeViConnectProgress ACallback, void* AInstance){};
00535 // Establish the connection to the setup port of the GeViServer
00536 // ?? ACallback
00537 // ?? AInstance
00538
00539 bool  GeViAPI_SetupClient_Connected(
00540                     HGeViSetupClient SetupClient,
00541                     bool& IsConnected){};
00542 // Is the connection established ?
00543
00544 bool  GeViAPI_SetupClient_Disconnect(
00545                     HGeViSetupClient SetupClient){};
00546 // Disconnect from the server
00547
00548 bool  GeViAPI_SetupClient_ReadSetup(
00549                     HGeViSetupClient SetupClient,
00550                     void* HFile){};
00551 // Read the setup registry from the server in the specfied file
00552 // ?? wie groß ist *HFile ??
00553
00554 bool  GeViAPI_SetupClient_WriteSetup(
00555                     HGeViSetupClient SetupClient,
00556                     void* HFile){};
00557 // Write the setup registry from the specfied file into the server
00558
00559 bool  GeViAPI_SetupClient_SetCBNotification(
00560                     HGeViSetupClient SetupClient,
00561                     TGeViDatabaseNotification ACallback,
00562                     void* AInstance){};
00563 // Declare a callback function to receive notifications from the database,
00564 // Instance is used as the Instance parameter during a call of the
00565 // TGeViDatabaseNotification callback function
00566
00567 bool  GeViAPI_SetupClient_GetAliasname(
00568                     HGeViSetupClient SetupClient,
00569                     char*& Aliasname){};
00570 // retrieve the Aliasname that was specified by the creation of the
00571 // SetupClient object
00572
00573 bool  GeViAPI_SetupClient_GetAddress(
00574                     HGeViSetupClient SetupClient,
00575                     char*& Address){};
00576 // retrieve the address of the database server to which the connection
00577 // was established
00578
00579 bool  GeViAPI_SetupClient_GetUsername(
00580                     HGeViSetupClient SetupClient,
00581                     char*& Username,
00582                     char*& Username2){};
00583 // retrieve the Username(s){};  that have been used to establish the connection
00584
00585 bool  GeViAPI_SetupClient_GetPassword(
00586                     HGeViSetupClient SetupClient,
00587                     char*& Password,
00588                     char*& Password2){};
00589 // retrieve the Password(s){};  that have been used to establish the connection
00590
00591 bool  GeViAPI_SetupClient_SendQuery(
00592                     HGeViSetupClient SetupClient,
00593                     const char* SendMessageBuffer, int SendBufferSize,
00594                     char*& RecMessageBuffer, int& BytesRead, int TimeOut){};
00595 // Send Query and receive the answer from the GeViServer
00596 // The buffer "RecMessageBuffer" should be freed with FreeArray after use
00597
00598 bool  GeViAPI_SetupClient_AbortAllQueries(
00599                     HGeViSetupClient SetupClient){};
00600 // Abort all started queries


GeViSoft SDK: MessageBase.h Source File

  • File List
  • File Members
MessageBase.h
Go to the documentation of this file.
00001 //---------------------------------------------------------------------------
00002
00003 #ifndef MessageBaseH
00004 #define MessageBaseH
00005
00006 #include <string.h>
00007 #include "ActionCode.h"
00008 #include "StateQueryCode.h"
00009 #include "DatabaseQueryCode.h"
00010 #include "GeViConst.h"
00011 #include "MessageBuffer.h"
00012
00013 #define REF &
00014 #define DEREF ->
00015
00016 #define GEVI_STATIC_CAST(t,v) (static_cast<t>(v))
00017 #define GEVI_STATIC_CAST_REF(t,v) (static_cast<t &>(v))
00018 #define GEVI_REINTERPRET_CAST(t,v) (reinterpret_cast<t>(v))
00019 #define LESS(l,r) (l < r)
00020 #define GEVI_PTR_VECTOR(t,min,grow) CTPtrVector<t,min,grow>
00021
00022 namespace GeViAPI_Namespace {
00023
00024 class CReferenceObject {
00025   private:
00026     long FRefCounter;
00027
00028   protected:
00029     virtual ~CReferenceObject();
00030
00031   public:
00032     CReferenceObject() { FRefCounter = 1; }
00033
00034     void IncRef();
00035     void DecRef();
00036     void DeleteObject();
00037
00038     long GetCounter() { return FRefCounter; }
00039 //    __property m_RefCounter: long read FRefCounter;
00040 };
00041
00042 class CGeViMessage: public CReferenceObject {
00043   protected:
00044     CGeViMessage(TMessageKind MessageKind);
00045
00046     static CGeViMessage* ReadBuffer(
00047              CGeViTransferBuffer* Buffer, // pointer to the buffer
00048              int& BytesRead               // bytes read
00049            );
00050     virtual bool WriteBuffer(
00051              CGeViTransferBuffer* Buffer, // pointer to the buffer
00052              int& BytesWrote              // bytes wrote
00053            ) const = 0;
00054
00055   public:
00056     TClientID          m_SenderID;        // sender's client id
00057     TClientID          m_RecepientID;     // recepient's client id
00058     const TMessageKind m_MessageKind;     // message kind
00059
00060   public:
00061     bool isAction() const { return m_MessageKind == mk_Action; }
00062     bool isActivity() const { return m_MessageKind == mk_Activity; }
00063     bool isStateQuery() const { return m_MessageKind == mk_StateQuery; }
00064     bool isStateAnswer() const { return m_MessageKind == mk_StateAnswer; }
00065     bool isDatabaseQuery() const { return m_MessageKind == mk_DataBaseQuery; }
00066     bool isDatabaseAnswer() const { return m_MessageKind == mk_DataBaseAnswer; }
00067
00068   public:
00069
00072
00079     static CGeViMessage* ReadBinMessage(
00080              const char* Buffer,          // pointer to the buffer
00081              int BufferLength,            // buffer length
00082              int& BytesRead               // bytes read
00083            );
00084
00085
00088
00095     static CGeViMessage* ReadASCIIMessage(
00096              const char* Buffer,          // pointer to the buffer
00097              int BufferLength,            // buffer length
00098              int& BytesRead               // bytes read
00099            );
00100
00103
00110     bool WriteBinMessage(
00111              char* Buffer,                // pointer to the buffer
00112              int BufferLength,            // buffer length
00113              int& BytesWrote              // bytes wrote
00114            );
00115
00118
00125     bool WriteASCIIMessage(
00126              char* Buffer,                // pointer to the buffer
00127              int BufferLength,            // buffer length
00128              int& BytesWrote              // bytes wrote
00129            );
00130 };
00131
00132 class CAction: public CGeViMessage {
00133   friend class CGeViMessage;
00134   protected:
00135     static CAction* ReadBuffer(CGeViTransferBuffer* Buffer); // pointer to the buffer
00136     CAction (TActionKind ActionKind, TActionCode ActionCode);
00137
00138   public:
00139     const TActionKind m_ActionKind;
00140     const TActionCode m_ActionCode;
00141
00142   public:
00143     virtual const char* GetActionName(void) const = 0;
00144     static TActionCode GetActionCodeByName(const char* Name);
00145 };
00146
00147 class CActivity: public CGeViMessage {
00148   friend class CGeViMessage;
00149   protected:
00150     static CActivity* ReadBuffer(CGeViTransferBuffer* Buffer); // pointer to the buffer
00151     CActivity (TActivityKind ActivityKind, TActivityCode ActivityCode);
00152
00153   public:
00154     const TActivityKind m_ActivityKind;
00155     const TActivityCode m_ActivityCode;
00156
00157   public:
00158     virtual const char* GetActivityName(void) const = 0;
00159     static TActivityCode GetActivityCodeByName(const char* Name);
00160 };
00161
00162 class CStateQuery: public CGeViMessage {
00163   friend class CGeViMessage;
00164   protected:
00165     static CStateQuery* ReadBuffer(CGeViTransferBuffer* Buffer); // pointer to the buffer
00166     CStateQuery(TStateQueryKind QueryKind);
00167
00168   public:
00169     const TStateQueryKind  m_QueryKind;
00170
00171   public:
00172     virtual const char* GetStateQueryName(void) const = 0;
00173     static TStateQueryKind GetStateQueryCodeByName(const char* Name);
00174 };
00175
00176 class CStateAnswer: public CGeViMessage {
00177   friend class CGeViMessage;
00178   protected:
00179     static CStateAnswer* ReadBuffer(CGeViTransferBuffer* Buffer); // pointer to the buffer
00180     CStateAnswer(TStateAnswerKind AnswerKind);
00181
00182   public:
00183     const TStateAnswerKind m_AnswerKind;
00184
00185   public:
00186     virtual const char* GetStateAnswerName(void) const = 0;
00187     static TStateAnswerKind GetStateAnswerCodeByName(const char* Name);
00188 };
00189
00190 class CDataBaseQuery: public CGeViMessage {
00191   friend class CGeViMessage;
00192   public:
00193     static CDataBaseQuery* ReadBuffer(CGeViTransferBuffer* Buffer); // pointer to the buffer
00194     CDataBaseQuery(TDBQueryCode QueryCode, __int64 DBHandle = 0, bool FilterQuery = false);
00195
00196   public:
00197     // For internal use in the database only
00198     __int64 m_Handle;
00199
00200   public:
00201     const TDBQueryCode m_QueryCode;
00202     const bool m_FilterQuery;
00203
00204   public:
00205     virtual const char* GetDataBaseQueryName(void) const = 0;
00206     static TDBQueryCode GetDataBaseQueryCodeByName(const char* Name);
00207 };
00208
00209 class CDataBaseFilter: public CDataBaseQuery {
00210   protected:
00211     CDataBaseFilter(TDBQueryCode QueryCode, __int64 DBHandle);
00212 };
00213
00214 class CDataBaseAnswer: public CGeViMessage {
00215   friend class CGeViMessage;
00216   public:
00217     static CDataBaseAnswer* ReadBuffer(CGeViTransferBuffer* Buffer); // pointer to the buffer
00218     CDataBaseAnswer(TDBAnswerCode AnswerCode);
00219
00220   public:
00221     const TDBAnswerCode m_AnswerCode;
00222
00223   public:
00224     virtual const char* GetDataBaseAnswerName(void) const = 0;
00225     static TDBAnswerCode GetDataBaseAnswerCodeByName(const char* Name);
00226 };
00227
00228 bool GetWriteResults(CGeViTransferBuffer* Buffer, int& BytesWrote);
00229 }; // namespace
00230 //---------------------------------------------------------------------------
00231 #endif


GeViSoft SDK: Member List

EGeVi Member List
This is the complete list of members for EGeVi, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViCmdAborted Member List
This is the complete list of members for EGeViCmdAborted, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViCmdAborted(const char *Message) | EGeViCmdAborted | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViCmdNotImplemented Member List
This is the complete list of members for EGeViCmdNotImplemented, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViCmdNotImplemented(const char *Message) | EGeViCmdNotImplemented | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViGeneric Member List
This is the complete list of members for EGeViGeneric, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViGeneric(const char *Message) | EGeViGeneric | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViIPConnection Member List
This is the complete list of members for EGeViIPConnection, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViIPConnection(const char *Message) | EGeViIPConnection | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViInvalidHandle Member List
This is the complete list of members for EGeViInvalidHandle, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViInvalidHandle(const char *Message) | EGeViInvalidHandle | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViNoMessages Member List
This is the complete list of members for EGeViNoMessages, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViNoMessages(const char *Message) | EGeViNoMessages | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViSystem Member List
This is the complete list of members for EGeViSystem, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViSystem(const char *Message) | EGeViSystem | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViTimeout Member List
This is the complete list of members for EGeViTimeout, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViTimeout(const char *Message) | EGeViTimeout | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

EGeViUnknown Member List
This is the complete list of members for EGeViUnknown, including all inherited members.
EGeVi(const char *geViMessage) | EGeVi | [inline]
EGeVi(const char *geViMessage, int geViError, int geViErrorClass) | EGeVi | [inline]
EGeViUnknown(const char *Message) | EGeViUnknown | [inline]
GeViError | EGeVi |
GeViErrorClass | EGeVi |


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CAction
GeViAPI_Namespace::CAction Member List
This is the complete list of members for GeViAPI_Namespace::CAction, including all inherited members.
CAction(TActionKind ActionKind, TActionCode ActionCode) | GeViAPI_Namespace::CAction | [protected]
CGeViMessage class | GeViAPI_Namespace::CAction | [friend]
GeViAPI_Namespace::CGeViMessage::CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetActionCodeByName(const char *Name) | GeViAPI_Namespace::CAction | [static]
GetActionName(void) const =0 | GeViAPI_Namespace::CAction | [pure virtual]
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_ActionCode | GeViAPI_Namespace::CAction |
m_ActionKind | GeViAPI_Namespace::CAction |
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer) | GeViAPI_Namespace::CAction | [protected, static]
GeViAPI_Namespace::CGeViMessage::ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CActivity
GeViAPI_Namespace::CActivity Member List
This is the complete list of members for GeViAPI_Namespace::CActivity, including all inherited members.
CActivity(TActivityKind ActivityKind, TActivityCode ActivityCode) | GeViAPI_Namespace::CActivity | [protected]
CGeViMessage class | GeViAPI_Namespace::CActivity | [friend]
GeViAPI_Namespace::CGeViMessage::CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetActivityCodeByName(const char *Name) | GeViAPI_Namespace::CActivity | [static]
GetActivityName(void) const =0 | GeViAPI_Namespace::CActivity | [pure virtual]
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_ActivityCode | GeViAPI_Namespace::CActivity |
m_ActivityKind | GeViAPI_Namespace::CActivity |
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer) | GeViAPI_Namespace::CActivity | [protected, static]
GeViAPI_Namespace::CGeViMessage::ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CDataBaseAnswer
GeViAPI_Namespace::CDataBaseAnswer Member List
This is the complete list of members for GeViAPI_Namespace::CDataBaseAnswer, including all inherited members.
CDataBaseAnswer(TDBAnswerCode AnswerCode) | GeViAPI_Namespace::CDataBaseAnswer |
CGeViMessage class | GeViAPI_Namespace::CDataBaseAnswer | [friend]
GeViAPI_Namespace::CGeViMessage::CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
GetDataBaseAnswerCodeByName(const char *Name) | GeViAPI_Namespace::CDataBaseAnswer | [static]
GetDataBaseAnswerName(void) const =0 | GeViAPI_Namespace::CDataBaseAnswer | [pure virtual]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_AnswerCode | GeViAPI_Namespace::CDataBaseAnswer |
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer) | GeViAPI_Namespace::CDataBaseAnswer | [static]
GeViAPI_Namespace::CGeViMessage::ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CDataBaseFilter
GeViAPI_Namespace::CDataBaseFilter Member List
This is the complete list of members for GeViAPI_Namespace::CDataBaseFilter, including all inherited members.
CDataBaseFilter(TDBQueryCode QueryCode, __int64 DBHandle) | GeViAPI_Namespace::CDataBaseFilter | [protected]
CDataBaseQuery(TDBQueryCode QueryCode, __int64 DBHandle=0, bool FilterQuery=false) | GeViAPI_Namespace::CDataBaseQuery |
GeViAPI_Namespace::CGeViMessage::CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
GetDataBaseQueryCodeByName(const char *Name) | GeViAPI_Namespace::CDataBaseQuery | [static]
GetDataBaseQueryName(void) const =0 | GeViAPI_Namespace::CDataBaseQuery | [pure virtual]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_FilterQuery | GeViAPI_Namespace::CDataBaseQuery |
m_Handle | GeViAPI_Namespace::CDataBaseQuery |
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_QueryCode | GeViAPI_Namespace::CDataBaseQuery |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer) | GeViAPI_Namespace::CDataBaseQuery | [static]
GeViAPI_Namespace::CGeViMessage::ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CDataBaseQuery
GeViAPI_Namespace::CDataBaseQuery Member List
This is the complete list of members for GeViAPI_Namespace::CDataBaseQuery, including all inherited members.
CDataBaseQuery(TDBQueryCode QueryCode, __int64 DBHandle=0, bool FilterQuery=false) | GeViAPI_Namespace::CDataBaseQuery |
CGeViMessage class | GeViAPI_Namespace::CDataBaseQuery | [friend]
GeViAPI_Namespace::CGeViMessage::CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
GetDataBaseQueryCodeByName(const char *Name) | GeViAPI_Namespace::CDataBaseQuery | [static]
GetDataBaseQueryName(void) const =0 | GeViAPI_Namespace::CDataBaseQuery | [pure virtual]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_FilterQuery | GeViAPI_Namespace::CDataBaseQuery |
m_Handle | GeViAPI_Namespace::CDataBaseQuery |
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_QueryCode | GeViAPI_Namespace::CDataBaseQuery |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer) | GeViAPI_Namespace::CDataBaseQuery | [static]
GeViAPI_Namespace::CGeViMessage::ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CGeViMessage
GeViAPI_Namespace::CGeViMessage Member List
This is the complete list of members for GeViAPI_Namespace::CGeViMessage, including all inherited members.
CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CReferenceObject
GeViAPI_Namespace::CReferenceObject Member List
This is the complete list of members for GeViAPI_Namespace::CReferenceObject, including all inherited members.
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
IncRef() | GeViAPI_Namespace::CReferenceObject |
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CStateAnswer
GeViAPI_Namespace::CStateAnswer Member List
This is the complete list of members for GeViAPI_Namespace::CStateAnswer, including all inherited members.
CGeViMessage class | GeViAPI_Namespace::CStateAnswer | [friend]
GeViAPI_Namespace::CGeViMessage::CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
CStateAnswer(TStateAnswerKind AnswerKind) | GeViAPI_Namespace::CStateAnswer | [protected]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
GetStateAnswerCodeByName(const char *Name) | GeViAPI_Namespace::CStateAnswer | [static]
GetStateAnswerName(void) const =0 | GeViAPI_Namespace::CStateAnswer | [pure virtual]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_AnswerKind | GeViAPI_Namespace::CStateAnswer |
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer) | GeViAPI_Namespace::CStateAnswer | [protected, static]
GeViAPI_Namespace::CGeViMessage::ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • CStateQuery
GeViAPI_Namespace::CStateQuery Member List
This is the complete list of members for GeViAPI_Namespace::CStateQuery, including all inherited members.
CGeViMessage class | GeViAPI_Namespace::CStateQuery | [friend]
GeViAPI_Namespace::CGeViMessage::CGeViMessage(TMessageKind MessageKind) | GeViAPI_Namespace::CGeViMessage | [protected]
CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [inline]
CStateQuery(TStateQueryKind QueryKind) | GeViAPI_Namespace::CStateQuery | [protected]
DecRef() | GeViAPI_Namespace::CReferenceObject |
DeleteObject() | GeViAPI_Namespace::CReferenceObject |
GetCounter() | GeViAPI_Namespace::CReferenceObject | [inline]
GetStateQueryCodeByName(const char *Name) | GeViAPI_Namespace::CStateQuery | [static]
GetStateQueryName(void) const =0 | GeViAPI_Namespace::CStateQuery | [pure virtual]
IncRef() | GeViAPI_Namespace::CReferenceObject |
isAction() const | GeViAPI_Namespace::CGeViMessage | [inline]
isActivity() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isDatabaseQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateAnswer() const | GeViAPI_Namespace::CGeViMessage | [inline]
isStateQuery() const | GeViAPI_Namespace::CGeViMessage | [inline]
m_MessageKind | GeViAPI_Namespace::CGeViMessage |
m_QueryKind | GeViAPI_Namespace::CStateQuery |
m_RecepientID | GeViAPI_Namespace::CGeViMessage |
m_SenderID | GeViAPI_Namespace::CGeViMessage |
ReadASCIIMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBinMessage(const char *Buffer, int BufferLength, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [static]
ReadBuffer(CGeViTransferBuffer *Buffer) | GeViAPI_Namespace::CStateQuery | [protected, static]
GeViAPI_Namespace::CGeViMessage::ReadBuffer(CGeViTransferBuffer *Buffer, int &BytesRead) | GeViAPI_Namespace::CGeViMessage | [protected, static]
WriteASCIIMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBinMessage(char *Buffer, int BufferLength, int &BytesWrote) | GeViAPI_Namespace::CGeViMessage |
WriteBuffer(CGeViTransferBuffer *Buffer, int &BytesWrote) const =0 | GeViAPI_Namespace::CGeViMessage | [protected, pure virtual]
~CReferenceObject() | GeViAPI_Namespace::CReferenceObject | [protected, virtual]


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • TActionData
GeViAPI_Namespace::TActionData Member List
This is the complete list of members for GeViAPI_Namespace::TActionData, including all inherited members.
Clear() | GeViAPI_Namespace::TActionData | [inline]
m_Buffer | GeViAPI_Namespace::TActionData |
m_BufferSize | GeViAPI_Namespace::TActionData |
operator=(const TActionData &Other) | GeViAPI_Namespace::TActionData | [inline]
TActionData() | GeViAPI_Namespace::TActionData | [inline]
TActionData(const TActionData &Other) | GeViAPI_Namespace::TActionData | [inline]
~TActionData() | GeViAPI_Namespace::TActionData | [inline]


GeViSoft SDK: Member List

GeViAPIClient Member List
This is the complete list of members for GeViAPIClient, including all inherited members.
ActivateServerPing(unsigned __int32 CheckPeriod) | GeViAPIClient |
Connect(const GeViAPI_Namespace::TGeViConnectProgress ACallback, void *AInstance) | GeViAPIClient |
Disconnect() | GeViAPIClient |
EncodePassword(char *Dest, const char *Source, int DestSize) | GeViAPIClient | [static]
GetDatabase(void) | GeViAPIClient |
GeViAPIClient(const char *Aliasname, const char *Address, const char *Username, const char *Password, const char *Username2, const char *Password2) | GeViAPIClient |
SendDatabaseQuery(GeViAPI_Namespace::CDataBaseQuery *GeViMessage, const int timeout_ms) | GeViAPIClient |
SendMessage(GeViAPI_Namespace::CGeViMessage *GeViMessage) | GeViAPIClient |
SendPing() | GeViAPIClient |
SendStateQuery(GeViAPI_Namespace::CStateQuery *GeViQuery, const int timeout_ms) | GeViAPIClient |
SetCBNotification(const GeViAPI_Namespace::TGeViDatabaseNotification ACallback, void *AInstance) | GeViAPIClient |
~GeViAPIClient() | GeViAPIClient |


GeViSoft SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Related Functions
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • r
  • s
  • t
  • w
  • ~

- a -

  • ActivateServerPing() : GeViAPIClient

- c -

  • CAction() : GeViAPI_Namespace::CAction
  • CActivity() : GeViAPI_Namespace::CActivity
  • CDataBaseAnswer() : GeViAPI_Namespace::CDataBaseAnswer
  • CDataBaseFilter() : GeViAPI_Namespace::CDataBaseFilter
  • CDataBaseQuery() : GeViAPI_Namespace::CDataBaseQuery
  • CGeViMessage() : GeViAPI_Namespace::CGeViMessage
  • Clear() : GeViAPI_Namespace::TActionData
  • Connect() : GeViAPIClient
  • CReferenceObject() : GeViAPI_Namespace::CReferenceObject
  • CStateAnswer() : GeViAPI_Namespace::CStateAnswer
  • CStateQuery() : GeViAPI_Namespace::CStateQuery

- d -

  • DecRef() : GeViAPI_Namespace::CReferenceObject
  • DeleteObject() : GeViAPI_Namespace::CReferenceObject
  • Disconnect() : GeViAPIClient

- e -

  • EGeVi() : EGeVi
  • EGeViCmdAborted() : EGeViCmdAborted
  • EGeViCmdNotImplemented() : EGeViCmdNotImplemented
  • EGeViGeneric() : EGeViGeneric
  • EGeViInvalidHandle() : EGeViInvalidHandle
  • EGeViIPConnection() : EGeViIPConnection
  • EGeViNoMessages() : EGeViNoMessages
  • EGeViSystem() : EGeViSystem
  • EGeViTimeout() : EGeViTimeout
  • EGeViUnknown() : EGeViUnknown
  • EncodePassword() : GeViAPIClient

- g -

  • GetActionCodeByName() : GeViAPI_Namespace::CAction
  • GetActionName() : GeViAPI_Namespace::CAction
  • GetActivityCodeByName() : GeViAPI_Namespace::CActivity
  • GetActivityName() : GeViAPI_Namespace::CActivity
  • GetCounter() : GeViAPI_Namespace::CReferenceObject
  • GetDatabase() : GeViAPIClient
  • GetDataBaseAnswerCodeByName() : GeViAPI_Namespace::CDataBaseAnswer
  • GetDataBaseAnswerName() : GeViAPI_Namespace::CDataBaseAnswer
  • GetDataBaseQueryCodeByName() : GeViAPI_Namespace::CDataBaseQuery
  • GetDataBaseQueryName() : GeViAPI_Namespace::CDataBaseQuery
  • GetStateAnswerCodeByName() : GeViAPI_Namespace::CStateAnswer
  • GetStateAnswerName() : GeViAPI_Namespace::CStateAnswer
  • GetStateQueryCodeByName() : GeViAPI_Namespace::CStateQuery
  • GetStateQueryName() : GeViAPI_Namespace::CStateQuery
  • GeViAPIClient() : GeViAPIClient

- i -

  • IncRef() : GeViAPI_Namespace::CReferenceObject
  • isAction() : GeViAPI_Namespace::CGeViMessage
  • isActivity() : GeViAPI_Namespace::CGeViMessage
  • isDatabaseAnswer() : GeViAPI_Namespace::CGeViMessage
  • isDatabaseQuery() : GeViAPI_Namespace::CGeViMessage
  • isStateAnswer() : GeViAPI_Namespace::CGeViMessage
  • isStateQuery() : GeViAPI_Namespace::CGeViMessage

- o -

  • operator=() : GeViAPI_Namespace::TActionData

- r -

  • ReadASCIIMessage() : GeViAPI_Namespace::CGeViMessage
  • ReadBinMessage() : GeViAPI_Namespace::CGeViMessage
  • ReadBuffer()
: GeViAPI_Namespace::CDataBaseQuery
, GeViAPI_Namespace::CStateAnswer
, GeViAPI_Namespace::CStateQuery
, GeViAPI_Namespace::CActivity
, GeViAPI_Namespace::CAction
, GeViAPI_Namespace::CGeViMessage
, GeViAPI_Namespace::CDataBaseAnswer

- s -

  • SendDatabaseQuery() : GeViAPIClient
  • SendMessage() : GeViAPIClient
  • SendPing() : GeViAPIClient
  • SendStateQuery() : GeViAPIClient
  • SetCBNotification() : GeViAPIClient

- t -

  • TActionData() : GeViAPI_Namespace::TActionData

- w -

  • WriteASCIIMessage() : GeViAPI_Namespace::CGeViMessage
  • WriteBinMessage() : GeViAPI_Namespace::CGeViMessage
  • WriteBuffer() : GeViAPI_Namespace::CGeViMessage

- ~ -

  • ~CReferenceObject() : GeViAPI_Namespace::CReferenceObject
  • ~GeViAPIClient() : GeViAPIClient
  • ~TActionData() : GeViAPI_Namespace::TActionData


GeViSoft SDK: Class Members - Related Functions

  • All
  • Functions
  • Variables
  • Related Functions
  • CGeViMessage
: GeViAPI_Namespace::CAction
, GeViAPI_Namespace::CDataBaseAnswer
, GeViAPI_Namespace::CDataBaseQuery
, GeViAPI_Namespace::CStateAnswer
, GeViAPI_Namespace::CStateQuery
, GeViAPI_Namespace::CActivity


GeViSoft SDK: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Functions
  • b
  • d
  • g
  • h
  • l
  • m
  • s
  • t
  • y

- b -

  • Buffer : TMessageEntry

- d -

  • DatePart : GeViAPI_Namespace::TGeViDateTime , TMscNativeDateTime
  • Day : TMscGenericDateTime
  • DoW : TMscGenericDateTime

- g -

  • GeViError : EGeVi
  • GeViErrorClass : EGeVi

- h -

  • Hour : TMscGenericDateTime

- l -

  • Length : TMessageEntry

- m -

  • m_ActionCode : GeViAPI_Namespace::CAction
  • m_ActionKind : GeViAPI_Namespace::CAction
  • m_ActivityCode : GeViAPI_Namespace::CActivity
  • m_ActivityKind : GeViAPI_Namespace::CActivity
  • m_AnswerCode : GeViAPI_Namespace::CDataBaseAnswer
  • m_AnswerKind : GeViAPI_Namespace::CStateAnswer
  • m_Buffer : GeViAPI_Namespace::TActionData
  • m_BufferSize : GeViAPI_Namespace::TActionData
  • m_FilterQuery : GeViAPI_Namespace::CDataBaseQuery
  • m_Handle : GeViAPI_Namespace::CDataBaseQuery
  • m_MessageKind : GeViAPI_Namespace::CGeViMessage
  • m_QueryCode : GeViAPI_Namespace::CDataBaseQuery
  • m_QueryKind : GeViAPI_Namespace::CStateQuery
  • m_RecepientID : GeViAPI_Namespace::CGeViMessage
  • m_SenderID : GeViAPI_Namespace::CGeViMessage
  • Min : TMscGenericDateTime
  • Month : TMscGenericDateTime
  • MSec : TMscGenericDateTime

- s -

  • Sec : TMscGenericDateTime

- t -

  • TimePart : GeViAPI_Namespace::TGeViDateTime , TMscNativeDateTime

- y -

  • Year : TMscGenericDateTime


GeViSoft SDK: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • DEREF : MessageBase.h
  • GEVI_PTR_VECTOR : MessageBase.h
  • GEVI_REINTERPRET_CAST : MessageBase.h
  • GEVI_STATIC_CAST : MessageBase.h
  • GEVI_STATIC_CAST_REF : MessageBase.h
  • LESS : MessageBase.h
  • REF : MessageBase.h


GeViSoft SDK: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • TConnectResult : GeViProcAPI.h
  • TServerNotification : GeViProcAPI.h


GeViSoft SDK: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • connectAborted : GeViProcAPI.h
  • connectDummyValue : GeViProcAPI.h
  • connectFileAccessError : GeViProcAPI.h
  • connectFileCouldNotOpen : GeViProcAPI.h
  • connectFileEmpty : GeViProcAPI.h
  • connectFileInvalid : GeViProcAPI.h
  • connectFileInvalidVersion : GeViProcAPI.h
  • connectGenericError : GeViProcAPI.h
  • connectOk : GeViProcAPI.h
  • connectRemoteClientInterfaceTooOld : GeViProcAPI.h
  • connectRemoteConnectionLimitExceeded : GeViProcAPI.h
  • connectRemotePortDisabled : GeViProcAPI.h
  • connectRemoteSecondUserRequired : GeViProcAPI.h
  • connectRemoteServerInterfaceTooOld : GeViProcAPI.h
  • connectRemoteTcpError : GeViProcAPI.h
  • connectRemoteUnknownUser : GeViProcAPI.h
  • connectRemoteUnkownError : GeViProcAPI.h
  • connectTapeCouldNotOpen : GeViProcAPI.h
  • connectTapeEmpty : GeViProcAPI.h
  • connectTapeInvalid : GeViProcAPI.h
  • connectTapeInvalidVersion : GeViProcAPI.h
  • connectTapeNotCompatible : GeViProcAPI.h
  • connectTapeNotReady : GeViProcAPI.h
  • connectWarningInvalidHeaders : GeViProcAPI.h
  • connectWarningMax : GeViProcAPI.h
  • NFServer_Disconnected : GeViProcAPI.h
  • NFServer_DummyValue : GeViProcAPI.h
  • NFServer_GoingShutdown : GeViProcAPI.h
  • NFServer_NewMessage : GeViProcAPI.h
  • NFServer_SetupModified : GeViProcAPI.h


GeViSoft SDK: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • g
  • v

- g -

  • GeViAPI_CheckSocketVersion() : GeViProcAPI.h
  • GeViAPI_Database_AbortAllQueries() : GeViProcAPI.h
  • GeViAPI_Database_ActivateServerPing() : GeViProcAPI.h
  • GeViAPI_Database_Connect() : GeViProcAPI.h
  • GeViAPI_Database_Connected() : GeViProcAPI.h
  • GeViAPI_Database_Create() : GeViProcAPI.h
  • GeViAPI_Database_Destroy() : GeViProcAPI.h
  • GeViAPI_Database_Disconnect() : GeViProcAPI.h
  • GeViAPI_Database_GetAddress() : GeViProcAPI.h
  • GeViAPI_Database_GetAliasname() : GeViProcAPI.h
  • GeViAPI_Database_GetDateTime() : GeViProcAPI.h
  • GeViAPI_Database_GetDifferenceToServerTime() : GeViProcAPI.h
  • GeViAPI_Database_GetPassword() : GeViProcAPI.h
  • GeViAPI_Database_GetUsername() : GeViProcAPI.h
  • GeViAPI_Database_SendMessage() : GeViProcAPI.h
  • GeViAPI_Database_SendPing() : GeViProcAPI.h
  • GeViAPI_Database_SendQuery() : GeViProcAPI.h
  • GeViAPI_Database_SendToMessage() : GeViProcAPI.h
  • GeViAPI_Database_SetCBNotification() : GeViProcAPI.h
  • GeViAPI_Database_SyncTime() : GeViProcAPI.h
  • GeViAPI_DecodeDateTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_AbortAllQueries() : GeViProcAPI.h
  • GeViAPI_DeviceClient_ActivateServerPing() : GeViProcAPI.h
  • GeViAPI_DeviceClient_AutoConnect() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Connect() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Connected() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Create() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Destroy() : GeViProcAPI.h
  • GeViAPI_DeviceClient_Disconnect() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetAddress() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetAliasname() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetDateTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetDifferenceToServerTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetPassword() : GeViProcAPI.h
  • GeViAPI_DeviceClient_GetUsername() : GeViProcAPI.h
  • GeViAPI_DeviceClient_ReadSetup() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendMessage() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendPing() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendQuery() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SendToMessage() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SetCBNotification() : GeViProcAPI.h
  • GeViAPI_DeviceClient_SyncTime() : GeViProcAPI.h
  • GeViAPI_DeviceClient_TerminateAutoConnect() : GeViProcAPI.h
  • GeViAPI_EncodeDateTime() : GeViProcAPI.h
  • GeViAPI_EncodeString() : GeViProcAPI.h
  • GeViAPI_FreeArray() : GeViProcAPI.h
  • GeViAPI_FreePointer() : GeViProcAPI.h
  • GeViAPI_GetLastError() : GeViProcAPI.h
  • GeViAPI_InterfaceVersion() : GeViProcAPI.h
  • GeViAPI_SetupClient_AbortAllQueries() : GeViProcAPI.h
  • GeViAPI_SetupClient_ActivateServerPing() : GeViProcAPI.h
  • GeViAPI_SetupClient_Connect() : GeViProcAPI.h
  • GeViAPI_SetupClient_Connected() : GeViProcAPI.h
  • GeViAPI_SetupClient_Create() : GeViProcAPI.h
  • GeViAPI_SetupClient_Destroy() : GeViProcAPI.h
  • GeViAPI_SetupClient_Disconnect() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetAddress() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetAliasname() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetDifferenceToServerTime() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetPassword() : GeViProcAPI.h
  • GeViAPI_SetupClient_GetUsername() : GeViProcAPI.h
  • GeViAPI_SetupClient_ReadSetup() : GeViProcAPI.h
  • GeViAPI_SetupClient_SendPing() : GeViProcAPI.h
  • GeViAPI_SetupClient_SendQuery() : GeViProcAPI.h
  • GeViAPI_SetupClient_SetCBNotification() : GeViProcAPI.h
  • GeViAPI_SetupClient_SyncTime() : GeViProcAPI.h
  • GeViAPI_SetupClient_WriteSetup() : GeViProcAPI.h

- v -

  • void() : GeViProcAPI.h


GeViSoft SDK: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • HGeViDatabase : GeViProcAPI.h
  • HGeViDeviceClient : GeViProcAPI.h
  • HGeViSetupClient : GeViProcAPI.h
  • Notification : GeViProcAPI.h
  • TGeViAPIConnectProgress : GeViProcAPI.h
  • TGeViAPIServerNotification : GeViProcAPI.h
  • TGeViConnectProgress : GeViProcAPI.h


GeViSoft SDK: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • EClassCmdAborted : GeViProcAPI.h
  • EClassCmdNotImplemented : GeViProcAPI.h
  • EClassGeneric : GeViProcAPI.h
  • EClassInvalidHandle : GeViProcAPI.h
  • EClassIPConnection : GeViProcAPI.h
  • EClassNoMessages : GeViProcAPI.h
  • EClassSystem : GeViProcAPI.h
  • EClassTimeout : GeViProcAPI.h
  • EClassUnknown : GeViProcAPI.h
  • GeViProcAPIVersion : GeViProcAPI.h


GeViSoft SDK: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


GeViSoft SDK: index.h Source File

  • File List
  • File Members
index.h
Go to the documentation of this file.
00001


GeViSoft SDK: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy


GeViSoft SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • TDBCompare : GeViAPI_Namespace
  • TGeViPort : GeViAPI_Namespace
  • TGeViResourceType : GeViAPI_Namespace
  • TLoginFailure : GeViAPI_Namespace
  • TMessageKind : GeViAPI_Namespace
  • TSwitchMode : GeViAPI_Namespace


GeViSoft SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • d
  • g
  • l
  • m
  • r
  • s

- d -

  • dbc_GE : GeViAPI_Namespace
  • dbc_LE : GeViAPI_Namespace
  • dbc_LIKE : GeViAPI_Namespace

- g -

  • gp_DevicePort : GeViAPI_Namespace
  • gp_SetupPort : GeViAPI_Namespace
  • gp_UserPort : GeViAPI_Namespace

- l -

  • lf_AccessDenied : GeViAPI_Namespace
  • lf_GeneralFailure : GeViAPI_Namespace
  • lf_InvalidPassword : GeViAPI_Namespace
  • lf_LicenseRestriction : GeViAPI_Namespace
  • lf_NoMultipleLogin : GeViAPI_Namespace
  • lf_Ok : GeViAPI_Namespace
  • lf_PasswordCorrupt : GeViAPI_Namespace
  • lf_ProtocolFailure : GeViAPI_Namespace
  • lf_SecondUserRequired : GeViAPI_Namespace
  • lf_SecondUserUnknown : GeViAPI_Namespace
  • lf_UnknownUser : GeViAPI_Namespace
  • lf_WrongInterfaceVersion : GeViAPI_Namespace

- m -

  • mk_Action : GeViAPI_Namespace
  • mk_Activity : GeViAPI_Namespace
  • mk_CommandAnswer : GeViAPI_Namespace
  • mk_CommandMessage : GeViAPI_Namespace
  • mk_DataBaseAnswer : GeViAPI_Namespace
  • mk_DataBaseQuery : GeViAPI_Namespace
  • mk_StateAnswer : GeViAPI_Namespace
  • mk_StateQuery : GeViAPI_Namespace

- r -

  • rt_DigitalInput : GeViAPI_Namespace
  • rt_DigitalOutput : GeViAPI_Namespace
  • rt_MonitorGroup : GeViAPI_Namespace
  • rt_VideoInput : GeViAPI_Namespace
  • rt_VideoOutput : GeViAPI_Namespace

- s -

  • sm_CP : GeViAPI_Namespace
  • sm_KP : GeViAPI_Namespace
  • sm_MonitorCycle : GeViAPI_Namespace
  • sm_Normal : GeViAPI_Namespace
  • sm_VX3_CT : GeViAPI_Namespace


GeViSoft SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • GetWriteResults() : GeViAPI_Namespace


GeViSoft SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • int32 : GeViAPI_Namespace
  • TAlarmID : GeViAPI_Namespace
  • TAlarmTypeID : GeViAPI_Namespace
  • TClientID : GeViAPI_Namespace
  • TEventID : GeViAPI_Namespace
  • TEventTypeID : GeViAPI_Namespace
  • TInputContactID : GeViAPI_Namespace
  • TMessageInternal : GeViAPI_Namespace
  • TMGID : GeViAPI_Namespace
  • TMscEventID : GeViAPI_Namespace
  • TMscEventTypeID : GeViAPI_Namespace
  • TOutputContactID : GeViAPI_Namespace
  • TVideoInputID : GeViAPI_Namespace
  • TVideoOutputID : GeViAPI_Namespace


GeViSoft SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- a -

  • AccessDatabaseRight : GeViAPI_Namespace
  • AlarmActionRight : GeViAPI_Namespace

- c -

  • ccs_NormalTemp : GeViAPI_Namespace
  • ControlDatabaseRight : GeViAPI_Namespace
  • csa_Last : GeViAPI_Namespace
  • csa_Next : GeViAPI_Namespace
  • csa_Previous : GeViAPI_Namespace

- d -

  • dbar_Ack : GeViAPI_Namespace
  • dbar_None : GeViAPI_Namespace
  • dbar_Quit : GeViAPI_Namespace
  • dbar_Reaction : GeViAPI_Namespace
  • dbar_Start : GeViAPI_Namespace
  • DirectMessageRight : GeViAPI_Namespace

- e -

  • ecs_Alternating : GeViAPI_Namespace
  • ecs_Closed : GeViAPI_Namespace
  • ecs_Open : GeViAPI_Namespace
  • ecs_Sabotage : GeViAPI_Namespace
  • ecs_Unknown : GeViAPI_Namespace

- g -

  • Generic1Right : GeViAPI_Namespace
  • Generic2Right : GeViAPI_Namespace
  • Generic3Right : GeViAPI_Namespace
  • Generic4Right : GeViAPI_Namespace
  • Generic5Right : GeViAPI_Namespace
  • GEVI_MAXACTIONLENGTH : GeViAPI_Namespace
  • GEVI_MAXSTRINGLENGTH : GeViAPI_Namespace
  • GeViGscOffset : GeViAPI_Namespace

- i -

  • ics_Closed : GeViAPI_Namespace
  • ics_Open : GeViAPI_Namespace
  • ik_Compax : GeViAPI_Namespace
  • ik_GeViCom : GeViAPI_Namespace
  • ik_GeViGST : GeViAPI_Namespace
  • ik_GeViTel : GeViAPI_Namespace
  • ik_Phoenix : GeViAPI_Namespace
  • ik_RAWDevice : GeViAPI_Namespace
  • ik_Special : GeViAPI_Namespace
  • ik_VicrosII : GeViAPI_Namespace
  • ik_VicrosIII : GeViAPI_Namespace
  • ik_VS40 : GeViAPI_Namespace
  • ik_VSM : GeViAPI_Namespace

- o -

  • ocd_Database : GeViAPI_Namespace
  • ocd_EventLog : GeViAPI_Namespace

- p -

  • pd_Left : GeViAPI_Namespace
  • pd_None : GeViAPI_Namespace
  • pd_Right : GeViAPI_Namespace
  • pp_BasePosition : GeViAPI_Namespace
  • pp_Unknown : GeViAPI_Namespace

- r -

  • RightToAccessToDevicePort : GeViAPI_Namespace
  • RightToAccessToSetupPort : GeViAPI_Namespace
  • RightToAccessToUserPort : GeViAPI_Namespace
  • RightToMultiLogin : GeViAPI_Namespace

- s -

  • SpecialActionRight : GeViAPI_Namespace
  • SupervisorRight : GeViAPI_Namespace

- t -

  • td_Down : GeViAPI_Namespace
  • td_None : GeViAPI_Namespace
  • td_Up : GeViAPI_Namespace

- u -

  • uk_Client : GeViAPI_Namespace
  • uk_Interface : GeViAPI_Namespace
  • uk_SysAdmin : GeViAPI_Namespace
  • uk_User : GeViAPI_Namespace

- v -

  • vsa_ExternalAlarm : GeViAPI_Namespace
  • vsc_Failure : GeViAPI_Namespace
  • vsc_Ok : GeViAPI_Namespace
  • vsp_Live : GeViAPI_Namespace
  • vsp_Stored : GeViAPI_Namespace
  • vss_Armed : GeViAPI_Namespace
  • vss_Disarmed : GeViAPI_Namespace


GeViSoft SDK: Member List

  • GeViAPI_Namespace
  • TGeViDateTime
GeViAPI_Namespace::TGeViDateTime Member List
This is the complete list of members for GeViAPI_Namespace::TGeViDateTime, including all inherited members.
DatePart | GeViAPI_Namespace::TGeViDateTime
TimePart | GeViAPI_Namespace::TGeViDateTime


GeViSoft SDK: Member List

TMessageEntry Member List
This is the complete list of members for TMessageEntry, including all inherited members.
Buffer | TMessageEntry
Length | TMessageEntry


GeViSoft SDK: Member List

TMscGenericDateTime Member List
This is the complete list of members for TMscGenericDateTime, including all inherited members.
Day | TMscGenericDateTime
DoW | TMscGenericDateTime
Hour | TMscGenericDateTime
Min | TMscGenericDateTime
Month | TMscGenericDateTime
MSec | TMscGenericDateTime
Sec | TMscGenericDateTime
Year | TMscGenericDateTime


GeViSoft SDK: Member List

TMscNativeDateTime Member List
This is the complete list of members for TMscNativeDateTime, including all inherited members.
DatePart | TMscNativeDateTime
TimePart | TMscNativeDateTime