Geutebrueck GeViSoftSDK .NET Wrapper: GeViSoft SDK Index Page

Geutebrueck GeViSoftSDK .NET Wrapper
  • Main Page
  • Modules
  • Classes
GeViSoft SDK Index Page

Introduction

Welcome to Geutebrueck's GeViSoft SDK .NET Wrapper documentation.

Please start by taking a look at the Database Functions.
Your connection to GeViSoft is handled by the public member functions of GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase.

Actions

For a list of the available GeViSoft actions and their constructors see Actions.
The respective Event Handlers and Event Arguments can be found in Event Handlers and Event Arguments.

State and Database Queries

Here you can find all State Queries and Answers and Database Queries and Answers.

Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Modules

  • Classes
Modules
Here is a list of all modules:
  • Database Functions
  • Actions
  • State Queries and Answers
  • Database Queries and Answers
  • Event Handlers and Event Arguments
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Database Functions

Classes | Functions
Database Functions

Classes

class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
struct | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
struct | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase

Functions

virtual void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::OnConnectProgress (GeViSoftConnectProgressEventArgs^ e)

Detailed Description

These are the database functions provided by the GeViSoft .NET SDK.

Function Documentation

void GeViDatabase::OnConnectProgress ( GeViSoftConnectProgressEventArgs^ e ) [protected, virtual]
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Actions

Classes
Actions

Classes

class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
Action 'Execution of a named action'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
Action 'The action data can not be found in the data base.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
Action 'Activate state profile'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
Action 'Change right profile of a user'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
Action 'Customized action'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
Action 'Explizit logoff of a user'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
Action 'Event relation was triggered'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
Action 'Start of event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
Action 'Stopp of event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
Action 'Historical alarm message.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
Action 'Historical contact message.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
Action 'Send a message to all users'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
Action 'Send a message to all users'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
Action 'Sending of a message to a user.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
Action 'Send a message to user'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
Action 'The input action of the current action mapping will be logged.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
Action 'Log message'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
Action 'Logging of a message'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
Action 'The input action of the first action mapping of this action mapping chain will be logged'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
Action 'Set new server as master'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
Action 'Connection master was changed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
Action 'Redirect resource.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
Action 'Master server was changed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
Action 'Redundant login failed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
Action 'Redundant login successful'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
Action 'Request to all users to perform a rescan'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
Action 'Request to a user to perform a rescan'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
Action 'Restore right profile of a user'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
Action 'Output the data to a RAW- or any other serial interface'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
Action 'Output the data to a RAW- or any other serial interface'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
Action 'Start of event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
Action 'Start timer'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
Action 'Stopp the event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
Action 'Stopp the event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
Action 'Stopp the timer'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
Action 'Request to all users to perform a time synchronization'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
Action 'Request to a user to perform a time synchronization'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
Action 'Explizit setting of date and time'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
Action 'Explizit setting of date and time'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
Action 'Explizit setting of date and time'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
Action 'System error'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
Action 'System settings changed.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
Action 'The system is starting.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
Action 'The system is stopping.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
Action 'System warning'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
Action 'User has logged in.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
Action 'Login failed.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
Action 'User has logged out.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
Action 'Database failure.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
Action 'Missing database'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
Action 'The database is ready.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
Action 'Turn off the auto focus of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
Action 'Turn on the auto focus of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
Action 'Delete text at the predefined position'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
Action 'Next camera in camera cycle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
Action 'Pause camera cycle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
Action 'Previous camera in camera cycle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
Action 'Resume camera cycle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
Action 'Start of the camera-cycle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
Action 'Stopp camera cycle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
Action 'Turn off camera light'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
Action 'Turn on camera light'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
Action 'Turn off the manual iris of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
Action 'Turn on the manual iris of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
Action 'Turn a camera off'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
Action 'Turn on a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
Action 'Turn of pump of a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
Action 'Turn on pump of a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
Action 'Output of a direct command to the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
Action 'Select character set.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
Action 'Set a camera text'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
Action 'Set text on a predefinied position'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
Action 'Turn off wiping a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
Action 'Turn on the wiping and washing of a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
Action 'Turn off special function 1'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
Action 'Turn on special function 1'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
Action 'Turn off special function U'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
Action 'Turn on special function U'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
Action 'Turn off special function V'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
Action 'Turn on special function V'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
Action 'Turn on displaying of firmware version'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
Action 'Turn off the camera text'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
Action 'Turn on the camera text'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
Action 'Next position in the camera tour'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
Action 'Pause the camera tour'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
Action 'Previous position in the camera tour'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
Action 'Resume the camera tour'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
Action 'Start of the camera tour'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
Action 'Stop the camera tour'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
Action 'Turn off displaying of the firmware version'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
Action 'Move camera to a base position'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
Action 'Clear base position of a camera.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
Action 'Save the base position of a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
Action 'Turn on the fast mode'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
Action 'Set camera focus farer'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
Action 'Set camera focus nearer'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
Action 'Stopp the focussing of a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
Action 'Close camera iris'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
Action 'Open the iris of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
Action 'Stopp closing the iris'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
Action 'Request of a MBeg initialization sequence'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
Action 'MBeg init sequence'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
Action 'Request the exclusive PTZ control'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
Action 'Release the exclusive PTZ control'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
Action 'Turn on normal mode'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
Action 'Automatic panning of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
Action 'Pan camera to the left'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
Action 'Pan camera to the right'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
Action 'Stopp panning of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
Action 'Move camera to a fix position'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
Action 'Clear fix position of a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
Action 'Save a fix position of a camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
Action 'Take over camera control'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
Action 'Incline the camera down'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
Action 'Stopp the inclinig of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
Action 'Incline camera up'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
Action 'Internal action requests the threshold value of an input'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
Action 'Internal action, return of the threshold value of an input'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
Action 'Zooming in the room'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
Action 'Zooming out of the room.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
Action 'Stop zooming of the camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
Action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
Action 'Clear the alarm flag of that video output'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
Action 'Clear that video output'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
Action 'Copy a video input from one video output to another one.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
Action 'Switch a video input on a video output'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
Action 'Switch a video input on a video output'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
Action 'Clears the free text'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
Action 'The image is disturbed.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
Action 'The contrast is OK again.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
Action 'The contrast is critical.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
Action 'Sync-signal failure.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
Action 'Sync-signal works correct again.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
Action 'Display free text on that video output.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
Action 'Reset the VX3-system'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
Action 'Flash contact'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
Action 'Close a contact'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
Action 'Input event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
Action 'Input event sabotage notification'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
Action 'Open contact'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
Action 'Cancel time range'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
Action 'Start of the time range'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
Action 'Acknowledgement of the alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
Action 'Acknowledge of the actual alarm on a moitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
Action 'Acknowledge the alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
Action 'Acknowledge of all alarms on a moitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
Action 'Alarm was acknowledged'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
Action 'An alarm was copied from one monitor group to an other'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
Action 'Trigger by the display of the alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
Action 'An alarm was moved from one monitor group to an other.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
Action 'Alarm was quitted'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
Action 'Alarm was restarted (retriggered)'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
Action 'Alarm was started'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
Action 'Copy actual alarm to an other monitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
Action 'Copy the alarm to an other monitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
Action 'AlarmAck-report at a MBeg'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
Action 'Report of the alarm quitting to a MBeg'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
Action 'Report of a alarm start at a MBeg'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
Action 'Disable monitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
Action 'Enable monitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
Action 'State of a monitor group has changed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
Action 'Move alarm to an other monitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
Action 'Move the alarm to an other monitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
Action 'Display alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
Action 'Send the actual alarm back in the queue and send the next to the monitors'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
Action 'Quitting a alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
Action 'Quit an actual alarm on a monitorgroup'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
Action 'Quitting an alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
Action 'Quit of all alarms on a moitor group'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
Action 'Start of a alarm of a special typ'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
Action 'Mode is 'Working' or 'Setup''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
Action 'Mode of the VMD'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
Action 'Alarm has finished.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
Action 'External alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
Action 'Alarm in a field'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
Action 'Test alarm for all VMD's of one client.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
Action 'Reset of the timers of all VMD of a client.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
Action 'VMD armed or disarmed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
Action 'Choose a saved picture.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
Action 'Picture OK respective picture failure'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
Action 'Set one picture to a common output'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
Action 'Set a picture to an output'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
Action 'Prealarm respective bring prealarm to end'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
Action 'The recorder was stopped'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
Action 'Reset of timer of the recorder of a VMD.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
Action 'All VMD's will be armed or disarmed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
Action 'Set the VMD armed or disarmed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
Action 'Set date and time of a CU.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
Action 'Reset timers of all VMD's of a VS-40 interface'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
Action 'Set mode of the sensor'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
Action 'Change output settings of the sensor'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
Action 'Sync signal and picture failure respective Sync signal OK'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
Action 'Test alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
Action 'Resez timer of aVMD.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
Action 'Mode is 'Working' or 'Setup''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
Action 'VMD Out of order'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
Action 'Start of the event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
Action 'Stopp of an event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
Action 'MULTISCOPE connected'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
Action 'Open MULTISCOPE connection failed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
Action 'Close MULTISCOPE connection'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
Action 'MULTISCOPE disconnected'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
Action 'MULTISCOPE Setup changed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
Action 'Start of MULTISCOPE event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
Action 'Stopp a MULTISCOPE event'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
Action 'GeviScope server connected'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
Action 'Open GeviScope connection failed'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
Action 'GeviScope disconnected'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
Action 'MIP alarm auxiliary input'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
Action 'MIP alarm cable'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
Action 'MIP alarm LU tamper'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
Action 'MIP alarm PM tamper'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
Action 'MIP alarm RM tamper'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
Action 'MIP auxiliary alarm state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
Action 'MIP auxiliary sensor status'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
Action 'MIP cable A failure state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
Action 'MIP cable B failure state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
Action 'MIP display segment alarm state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
Action 'MIP display segment status'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
Action 'MIP LU tamper alarm state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
Action 'MIP LU tamper status'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
Action 'MIP interface offnline'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
Action 'MIP interface online'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
Action 'MIP PM COM failure state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
Action 'MIP PM tamper alarm state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
Action 'MIP PM tamper status'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
Action 'MIP query interface'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
Action 'MIP RM COM failure state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
Action 'MIP RM tamper alarm state'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
Action 'MIP RM tamper status'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
Action 'MIP secure auxiliary sensor'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
Action 'MIP secure TP 1'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
Action 'MIP secure TP 2'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
Action 'MIP secure display segment'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
Action 'MIP secure LU'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
Action 'MIP secure PM'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
Action 'MIP secure RM'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
Action 'MIP turn a relay control'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
Action 'MIP turn relay on one zone'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
Action 'Output command to the connected camera'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
Action 'The current dim level of the illuminator'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
Action 'Get the dim level of the illuminator'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
Action 'Turn off the illuminator light'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
Action 'Turn on the illuminator light'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
Action 'Turn off the illuminator'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
Action 'Turn on the illuminator'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
Action 'Set the dim level of the illuminator'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
Action 'Turn off the special function U'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
Action 'Turn on the special function U'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
Action 'Turn off the special function V'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
Action 'Turn on the special function V'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
Action 'Turn off the special function X'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
Action 'Turn on the special function X'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
Action 'Turn off the special function Y'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
Action 'Turn on the special function Y'. More...

Detailed Description

These are the GeViSoft Actions.

Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: State Queries and Answers

Classes | Enumerations
State Queries and Answers

Classes

class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
StateAnswer 'Info zum Alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
StateAnswer 'AlarmOnMG info'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
StateAnswer 'Information zu dem Klient'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
StateAnswer 'Information zu dem Klient'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
StateAnswer 'Befehl fehlgeschlagen.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
StateAnswer 'Befehl ausgefuehrt.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
StateAnswer 'ContrastState Info'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
StateAnswer 'Datenbankzeit'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
StateAnswer 'Serverstartzeit'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
StateAnswer 'Info zu einem Eingangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
StateAnswer 'Interne Abfrage'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
StateAnswer 'Lizenzinformation'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
StateAnswer 'Interne Abfrage'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
StateAnswer 'Wert des bestimmten Eintrags'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
StateAnswer 'Info zu einer MG'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
StateAnswer 'Info zu einem Ausgangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
StateAnswer 'S/N Info'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
StateAnswer 'SyncState Info'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
StateAnswer 'Die Anfrage oder Befehl wurde terminiert.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
StateAnswer 'Gerade gemessener Schwellenwert'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
StateAnswer 'Befehl nicht verstanden.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
StateAnswer 'Die Rechte sind nicht ausreichend.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
StateAnswer 'Info zu einem VideoEingang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
StateAnswer 'Info zu einem Videoausgang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
StateAnswer 'VideoSensor Info'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
StateQuery 'Liefert die Information zum bestimmten Alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
StateQuery 'Liefert die Information zum bestimmten Alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
StateQuery 'Liefert die Information zum bestimmten Klient'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
StateQuery 'Liefert die Information zum bestimmten Klient'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
StateQuery 'Fragt die PictureState Info ab'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
StateQuery 'Liefert die Information zu dem ersten Alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
StateQuery 'Liefert die Information zu dem ersten Klient'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
StateQuery 'Liefert die Information zu dem ersten Klient dieses Typs'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
StateQuery 'Liefert die Information zu dem ersten Eingangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
StateQuery 'Liefert die Information zu dem ersten Eingangskontakt des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
StateQuery 'Liefert die Information zu der ersten MG'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
StateQuery 'Liefert die Information zu dem ersten VideoEingang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
StateQuery 'Liefert die Information zu dem ersten VideoEingang des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
StateQuery 'Liefert die Information zu dem ersten Videoausgang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
StateQuery 'Liefert die Information zu dem ersten Videoausgang des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
StateQuery 'Liefert die Datenbankzeit zurueck'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
StateQuery 'Liefert die Serverstartzeit zurueck'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
StateQuery 'Liefert die Lizenzinformation zurueck'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
StateQuery 'Liefert den Wert eines bestimmten Eintrags zurueck'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
StateQuery 'Login Information zu dem Klient'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
StateQuery 'Liefert die Information zur bestimmten MG'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
StateQuery 'Liefert die Information zur bestimmten MG'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
StateQuery 'Liefert die Information zu dem naechsten Alarm'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
StateQuery 'Liefert die Information zu dem naechsten Klient'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
StateQuery 'Liefert die Information zu dem naechsten Klient des angegeben Typs'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
StateQuery 'Liefert die Information zu der naechsten MG'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
StateQuery 'Liefert die Information zu dem naechsten VideoEingang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
StateQuery 'Liefert die Information zu dem neachsten VideoEingang des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
StateQuery 'Liefert die Information zu dem naechsten Videoausgang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
StateQuery 'Liefert die Information zu dem naechsten Videoausgang des Clients'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
StateQuery 'Fragt die S/N Info ab'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
StateQuery 'Fragt die SyncState Info ab'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
StateQuery 'Liefert die Information zu dem lokalen Videoeingangs eines VSM'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
StateQuery 'Liefert die Information zum bestimmten VideoEingang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
StateQuery 'Liefert die Information zum bestimmten VideoEingang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
StateQuery 'Liefert die Information zum bestimmten Videoausgang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
StateQuery 'Liefert die Information zum bestimmten Videoausgang'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
StateQuery 'Fragt die Info zum VideoSensor ab'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
StateQuery 'Interne Abfrage'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
StateQuery 'Interne Abfrage'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
StateQuery 'Interne Abfrage'. More...

Enumerations

enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQueryKind {
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetAlarmOnMGByIndex = 101, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetAlarmOnMGInfo = 100, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetAlarms = 98, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetAlarmsByName = 99,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetClient = 6, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetClientByName = 7, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetContrastState = 33, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstAlarm = 96,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstClient = 1, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstClientOfType = 4, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstInputContact = 61, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstInputContactOfClient = 62,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstMonitorGroup = 91, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstOutputContact = 71, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstOutputContactOfClient = 72, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstVideoInput = 11,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstVideoInputOfClient = 14, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstVideoOutput = 51, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetFirstVideoOutputOfClient = 52, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetInfoDatabaseCreationTime = 121,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetInfoServerStartTime = 120, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetInputContact = 65, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetInputContactByName = 66, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetLicenseInfo = 111,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetLicenseValue = 112, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetLoginInfo = 8, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetMonitorGroup = 93, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetMonitorGroupByName = 94,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextAlarm = 97, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextClient = 2, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextClientOfType = 5, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextInputContact = 63,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextInputContactOfClient = 64, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextMonitorGroup = 92, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextOutputContact = 73, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextOutputContactOfClient = 74,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextVideoInput = 12, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextVideoInputOfClient = 15, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextVideoOutput = 53, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetNextVideoOutputOfClient = 54,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetOutputContact = 75, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetOutputContactByName = 76, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetPTZHeadInfo = 21, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetSyncState = 31,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetThresholdValue = 80, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetVideoInput = 16, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetVideoInputByName = 17, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetVideoOutput = 55,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetVideoOutputByName = 56, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_GetVideoSensorInfo = 41, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_LicenseCall = 114, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_LicensePrepareCall = 113,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sqk_LicenseTransferData = 115
}
enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswerKind {
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_AlarmInfo = 92, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_AlarmOnMGInfo = 93, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_ClientInfo = 3, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_ClientLoginInfo = 4,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_CommandFailed = 105, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_CommandOk = 104, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_ContrastState = 34, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_InfoDatabaseCreationTime = 121,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_InfoServerStartTime = 120, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_InputContactInfo = 67, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_LicenseCall = 114, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_LicenseInfo = 111,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_LicenseTransferData = 115, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_LicenseValue = 112, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_MonitorGroupInfo = 91, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_Nothing = 0,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_OutputContactInfo = 77, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_PTZHeadInfo = 22, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_SyncState = 32, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_Terminated = 101,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_ThresholdInfo = 81, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_UnknownCommand = 103, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_UnsufficientRights = 102, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_VideoInputInfo = 13,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_VideoOutputInfo = 57, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::sak_VideoSensorInfo = 42
}

Detailed Description

These are the State Queries and Answers provided by the GeViSoft .NET SDK.

Enumeration Type Documentation

enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswerKind
Enumerator:
sak_AlarmInfo
sak_AlarmOnMGInfo
sak_ClientInfo
sak_ClientLoginInfo
sak_CommandFailed
sak_CommandOk
sak_ContrastState
sak_InfoDatabaseCreationTime
sak_InfoServerStartTime
sak_InputContactInfo
sak_LicenseCall
sak_LicenseInfo
sak_LicenseTransferData
sak_LicenseValue
sak_MonitorGroupInfo
sak_Nothing
sak_OutputContactInfo
sak_PTZHeadInfo
sak_SyncState
sak_Terminated
sak_ThresholdInfo
sak_UnknownCommand
sak_UnsufficientRights
sak_VideoInputInfo
sak_VideoOutputInfo
sak_VideoSensorInfo
enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQueryKind
Enumerator:
sqk_GetAlarmOnMGByIndex
sqk_GetAlarmOnMGInfo
sqk_GetAlarms
sqk_GetAlarmsByName
sqk_GetClient
sqk_GetClientByName
sqk_GetContrastState
sqk_GetFirstAlarm
sqk_GetFirstClient
sqk_GetFirstClientOfType
sqk_GetFirstInputContact
sqk_GetFirstInputContactOfClient
sqk_GetFirstMonitorGroup
sqk_GetFirstOutputContact
sqk_GetFirstOutputContactOfClient
sqk_GetFirstVideoInput
sqk_GetFirstVideoInputOfClient
sqk_GetFirstVideoOutput
sqk_GetFirstVideoOutputOfClient
sqk_GetInfoDatabaseCreationTime
sqk_GetInfoServerStartTime
sqk_GetInputContact
sqk_GetInputContactByName
sqk_GetLicenseInfo
sqk_GetLicenseValue
sqk_GetLoginInfo
sqk_GetMonitorGroup
sqk_GetMonitorGroupByName
sqk_GetNextAlarm
sqk_GetNextClient
sqk_GetNextClientOfType
sqk_GetNextInputContact
sqk_GetNextInputContactOfClient
sqk_GetNextMonitorGroup
sqk_GetNextOutputContact
sqk_GetNextOutputContactOfClient
sqk_GetNextVideoInput
sqk_GetNextVideoInputOfClient
sqk_GetNextVideoOutput
sqk_GetNextVideoOutputOfClient
sqk_GetOutputContact
sqk_GetOutputContactByName
sqk_GetPTZHeadInfo
sqk_GetSyncState
sqk_GetThresholdValue
sqk_GetVideoInput
sqk_GetVideoInputByName
sqk_GetVideoOutput
sqk_GetVideoOutputByName
sqk_GetVideoSensorInfo
sqk_LicenseCall
sqk_LicensePrepareCall
sqk_LicenseTransferData
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Database Queries and Answers

Classes | Enumerations
Database Queries and Answers

Classes

class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
StateAnswer 'Zugriff verweigert.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
StateAnswer 'Aktions Eintrag'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
StateAnswer 'Alarm Eintrag'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
StateAnswer 'Fehler'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
StateAnswer 'Befehl akzeptiert'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
StateAnswer 'Befehl abgebrochen'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
StateAnswer ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
StateAnswer 'Liefert der erzeugten Handle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
StateQuery ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
StateQuery 'ActionList'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
StateQuery 'GscSystem'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
StateQuery ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
StateQuery ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
StateQuery ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
StateQuery 'MG, wo Alarm praesentiert wurde'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
StateQuery ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
StateQuery 'MscSystem'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
StateQuery 'Primary Key groesser gleich'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
StateQuery 'Primary Key kleiner gleich'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
StateQuery 'Von welchem Klient kam die Aktion'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
StateQuery 'Von welchem Klient kam die Aktion'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
StateQuery 'Von welchem Klient kam die Aktion'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
StateQuery ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
StateQuery 'Die erste MG, wo Alarm praesentiert wurde'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
StateQuery ''. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
StateQuery 'Begleittext'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
StateQuery 'Beschreibung des Alarms'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
StateQuery 'AlarmTypeID bzw. ActionCode im Bereich'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
StateQuery 'Alarm- bzw. Aktionsname'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
StateQuery 'Mit/ohne Bestaetigung'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
StateQuery 'Mit/Ohne MscII Events'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
StateQuery 'Mit/ohne Quittierung'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
StateQuery 'Befehl abbrechen'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
StateQuery 'Schliesst den Handle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
StateQuery 'Startet eine Abfrage ueber die Aktionstabelle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
StateQuery 'Startet eine Abfrage ueber die Alarmtabelle'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Aktionstabelle vor.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Alarmtabelle vor.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
StateQuery 'Loescht alle passenden Eintraege in der Aktions- bzw. Alarmtabelle. Kann nur in Verbindung mit den entspraechenden CreateDelete...Handle verwendet werden.'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
StateQuery 'Liefert den Eintrag anhand von PK'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
StateQuery 'Liefert den ersten Eintrag'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
StateQuery 'Liefert den letzten Eintrag'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
StateQuery 'Liefert den naechsten Eintrag'. More...
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
StateQuery 'Liefert den vorgehenden Eintrag'. More...

Enumerations

enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQueryKind {
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_AbortQuery = 17, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_CloseQuery = 16, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_CreateActionQuery = 12, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_CreateAlarmQuery = 11,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_CreateDeleteActionsHandle = 13, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_CreateDeleteAlarmsHandle = 14, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_DeleteAll = 26, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_Get = 21,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_GetFirst = 22, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_GetLast = 23, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_GetNext = 24, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_GetPrev = 25,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_ActionKind = 58, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_ActionList = 70, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_GscSystem = 72, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_LocalTime_GrtEqu = 43,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_LocalTime_LowEqu = 44, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_MonitorGroupDesc = 63, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_MonitorGroupID = 47, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_MonitorGroupName = 62,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_MscSystem = 71, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_PK_GrtEqu = 42, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_PK_LowEqu = 41, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_SenderDesc = 61,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_SenderID = 59, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_SenderName = 60, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_StartMonitorGroupDesc = 55, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_StartMonitorGroupID = 46,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_StartMonitorGroupName = 54, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_Text = 51, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_TypeDesc = 53, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_TypeID = 45,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_TypeName = 52, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_WithAck = 49, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_WithMscIIRelation = 48, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbqc_WithQuit = 50
}
enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswerKind {
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_AccessDenied = 1, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_ActionEntry = 32, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_AlarmEntry = 31, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_DBError = 3,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_DBOk = 2, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_DBTerminated = 4, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_DeletedEntries = 33, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_Nothing = 5,
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::dbac_QueryHandle = 15
}

Detailed Description

These are the Database Queries and Answers provided by the GeViSoft .NET SDK.

Enumeration Type Documentation

enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswerKind
Enumerator:
dbac_AccessDenied
dbac_ActionEntry
dbac_AlarmEntry
dbac_DBError
dbac_DBOk
dbac_DBTerminated
dbac_DeletedEntries
dbac_Nothing
dbac_QueryHandle
enum GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQueryKind
Enumerator:
dbqc_AbortQuery
dbqc_CloseQuery
dbqc_CreateActionQuery
dbqc_CreateAlarmQuery
dbqc_CreateDeleteActionsHandle
dbqc_CreateDeleteAlarmsHandle
dbqc_DeleteAll
dbqc_Get
dbqc_GetFirst
dbqc_GetLast
dbqc_GetNext
dbqc_GetPrev
dbqc_ActionKind
dbqc_ActionList
dbqc_GscSystem
dbqc_LocalTime_GrtEqu
dbqc_LocalTime_LowEqu
dbqc_MonitorGroupDesc
dbqc_MonitorGroupID
dbqc_MonitorGroupName
dbqc_MscSystem
dbqc_PK_GrtEqu
dbqc_PK_LowEqu
dbqc_SenderDesc
dbqc_SenderID
dbqc_SenderName
dbqc_StartMonitorGroupDesc
dbqc_StartMonitorGroupID
dbqc_StartMonitorGroupName
dbqc_Text
dbqc_TypeDesc
dbqc_TypeID
dbqc_TypeName
dbqc_WithAck
dbqc_WithMscIIRelation
dbqc_WithQuit
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Event Handlers and Event Arguments

Classes | Functions | Events
Event Handlers and Event Arguments

Classes

class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
class | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs

Functions

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs::GeViAct_GscActionEventArgs (GscAction^ act)
Create the EventArgs to handle received GeViSCOPE Actions.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAlarmByInstanceEventHandler (Object^ sender, GeViAct_AckAlarmByInstanceEventArgs^ e)
Delegate for action 'Acknowledgement of the alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAlarmByMGEventHandler (Object^ sender, GeViAct_AckAlarmByMGEventArgs^ e)
Delegate for action 'Acknowledge of the actual alarm on a moitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAlarmByTypeEventHandler (Object^ sender, GeViAct_AckAlarmByTypeEventArgs^ e)
Delegate for action 'Acknowledge the alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAllAlarmsOnMGEventHandler (Object^ sender, GeViAct_AckAllAlarmsOnMGEventArgs^ e)
Delegate for action 'Acknowledge of all alarms on a moitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ActionByNameEventHandler (Object^ sender, GeViAct_ActionByNameEventArgs^ e)
Delegate for action 'Execution of a named action'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ActionDataCorruptEventHandler (Object^ sender, GeViAct_ActionDataCorruptEventArgs^ e)
Delegate for action 'The action data can not be found in the data base.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ActivateAssignmentProfileEventHandler (Object^ sender, GeViAct_ActivateAssignmentProfileEventArgs^ e)
Delegate for action 'Activate state profile'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmAckedEventHandler (Object^ sender, GeViAct_AlarmAckedEventArgs^ e)
Delegate for action 'Alarm was acknowledged'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmCopiedEventHandler (Object^ sender, GeViAct_AlarmCopiedEventArgs^ e)
Delegate for action 'An alarm was copied from one monitor group to an other'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmDisplayedEventHandler (Object^ sender, GeViAct_AlarmDisplayedEventArgs^ e)
Delegate for action 'Trigger by the display of the alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmMovedEventHandler (Object^ sender, GeViAct_AlarmMovedEventArgs^ e)
Delegate for action 'An alarm was moved from one monitor group to an other.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmQuittedEventHandler (Object^ sender, GeViAct_AlarmQuittedEventArgs^ e)
Delegate for action 'Alarm was quitted'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmRetriggeredEventHandler (Object^ sender, GeViAct_AlarmRetriggeredEventArgs^ e)
Delegate for action 'Alarm was restarted (retriggered)'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmStartedEventHandler (Object^ sender, GeViAct_AlarmStartedEventArgs^ e)
Delegate for action 'Alarm was started'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlternateContactEventHandler (Object^ sender, GeViAct_AlternateContactEventArgs^ e)
Delegate for action 'Flash contact'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraAutoFocusOffEventHandler (Object^ sender, GeViAct_CameraAutoFocusOffEventArgs^ e)
Delegate for action 'Turn off the auto focus of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraAutoFocusOnEventHandler (Object^ sender, GeViAct_CameraAutoFocusOnEventArgs^ e)
Delegate for action 'Turn on the auto focus of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraClearPrePosTextEventHandler (Object^ sender, GeViAct_CameraClearPrePosTextEventArgs^ e)
Delegate for action 'Delete text at the predefined position'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleNextEventHandler (Object^ sender, GeViAct_CameraCycleNextEventArgs^ e)
Delegate for action 'Next camera in camera cycle'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCyclePauseEventHandler (Object^ sender, GeViAct_CameraCyclePauseEventArgs^ e)
Delegate for action 'Pause camera cycle'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCyclePrevEventHandler (Object^ sender, GeViAct_CameraCyclePrevEventArgs^ e)
Delegate for action 'Previous camera in camera cycle'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleResumeEventHandler (Object^ sender, GeViAct_CameraCycleResumeEventArgs^ e)
Delegate for action 'Resume camera cycle'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleStartEventHandler (Object^ sender, GeViAct_CameraCycleStartEventArgs^ e)
Delegate for action 'Start of the camera-cycle'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleStopEventHandler (Object^ sender, GeViAct_CameraCycleStopEventArgs^ e)
Delegate for action 'Stopp camera cycle'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraLightOffEventHandler (Object^ sender, GeViAct_CameraLightOffEventArgs^ e)
Delegate for action 'Turn off camera light'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraLightOnEventHandler (Object^ sender, GeViAct_CameraLightOnEventArgs^ e)
Delegate for action 'Turn on camera light'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraManualIrisOffEventHandler (Object^ sender, GeViAct_CameraManualIrisOffEventArgs^ e)
Delegate for action 'Turn off the manual iris of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraManualIrisOnEventHandler (Object^ sender, GeViAct_CameraManualIrisOnEventArgs^ e)
Delegate for action 'Turn on the manual iris of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraOffEventHandler (Object^ sender, GeViAct_CameraOffEventArgs^ e)
Delegate for action 'Turn a camera off'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraOnEventHandler (Object^ sender, GeViAct_CameraOnEventArgs^ e)
Delegate for action 'Turn on a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraPumpOffEventHandler (Object^ sender, GeViAct_CameraPumpOffEventArgs^ e)
Delegate for action 'Turn of pump of a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraPumpOnEventHandler (Object^ sender, GeViAct_CameraPumpOnEventArgs^ e)
Delegate for action 'Turn on pump of a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraRAWOutputEventHandler (Object^ sender, GeViAct_CameraRAWOutputEventArgs^ e)
Delegate for action 'Output of a direct command to the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSelectCharModeEventHandler (Object^ sender, GeViAct_CameraSelectCharModeEventArgs^ e)
Delegate for action 'Select character set.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSetCameraTextEventHandler (Object^ sender, GeViAct_CameraSetCameraTextEventArgs^ e)
Delegate for action 'Set a camera text'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSetPrePosTextEventHandler (Object^ sender, GeViAct_CameraSetPrePosTextEventArgs^ e)
Delegate for action 'Set text on a predefinied position'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSmearAndWashOffEventHandler (Object^ sender, GeViAct_CameraSmearAndWashOffEventArgs^ e)
Delegate for action 'Turn off wiping a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSmearAndWashOnEventHandler (Object^ sender, GeViAct_CameraSmearAndWashOnEventArgs^ e)
Delegate for action 'Turn on the wiping and washing of a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpec1FuncOffEventHandler (Object^ sender, GeViAct_CameraSpec1FuncOffEventArgs^ e)
Delegate for action 'Turn off special function 1'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpec1FuncOnEventHandler (Object^ sender, GeViAct_CameraSpec1FuncOnEventArgs^ e)
Delegate for action 'Turn on special function 1'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecUFuncOffEventHandler (Object^ sender, GeViAct_CameraSpecUFuncOffEventArgs^ e)
Delegate for action 'Turn off special function U'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecUFuncOnEventHandler (Object^ sender, GeViAct_CameraSpecUFuncOnEventArgs^ e)
Delegate for action 'Turn on special function U'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecVFuncOffEventHandler (Object^ sender, GeViAct_CameraSpecVFuncOffEventArgs^ e)
Delegate for action 'Turn off special function V'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecVFuncOnEventHandler (Object^ sender, GeViAct_CameraSpecVFuncOnEventArgs^ e)
Delegate for action 'Turn on special function V'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraStopAllEventHandler (Object^ sender, GeViAct_CameraStopAllEventArgs^ e)
Delegate for action 'Turn on displaying of firmware version'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTextOffEventHandler (Object^ sender, GeViAct_CameraTextOffEventArgs^ e)
Delegate for action 'Turn off the camera text'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTextOnEventHandler (Object^ sender, GeViAct_CameraTextOnEventArgs^ e)
Delegate for action 'Turn on the camera text'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourNextEventHandler (Object^ sender, GeViAct_CameraTourNextEventArgs^ e)
Delegate for action 'Next position in the camera tour'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourPauseEventHandler (Object^ sender, GeViAct_CameraTourPauseEventArgs^ e)
Delegate for action 'Pause the camera tour'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourPrevEventHandler (Object^ sender, GeViAct_CameraTourPrevEventArgs^ e)
Delegate for action 'Previous position in the camera tour'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourResumeEventHandler (Object^ sender, GeViAct_CameraTourResumeEventArgs^ e)
Delegate for action 'Resume the camera tour'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourStartEventHandler (Object^ sender, GeViAct_CameraTourStartEventArgs^ e)
Delegate for action 'Start of the camera tour'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourStopEventHandler (Object^ sender, GeViAct_CameraTourStopEventArgs^ e)
Delegate for action 'Stop the camera tour'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraVerOffEventHandler (Object^ sender, GeViAct_CameraVerOffEventArgs^ e)
Delegate for action 'Turn off displaying of the firmware version'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ChangeRightProfileEventHandler (Object^ sender, GeViAct_ChangeRightProfileEventArgs^ e)
Delegate for action 'Change right profile of a user'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ClearAlarmFlagVideoInputEventHandler (Object^ sender, GeViAct_ClearAlarmFlagVideoInputEventArgs^ e)
Delegate for action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ClearAlarmFlagVideoOutputEventHandler (Object^ sender, GeViAct_ClearAlarmFlagVideoOutputEventArgs^ e)
Delegate for action 'Clear the alarm flag of that video output'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ClearVideoOutputEventHandler (Object^ sender, GeViAct_ClearVideoOutputEventArgs^ e)
Delegate for action 'Clear that video output'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CloseContactEventHandler (Object^ sender, GeViAct_CloseContactEventArgs^ e)
Delegate for action 'Close a contact'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CopyActualAlarmEventHandler (Object^ sender, GeViAct_CopyActualAlarmEventArgs^ e)
Delegate for action 'Copy actual alarm to an other monitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CopyAlarmByInstanceEventHandler (Object^ sender, GeViAct_CopyAlarmByInstanceEventArgs^ e)
Delegate for action 'Copy the alarm to an other monitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CopyCameraOnMonitorEventHandler (Object^ sender, GeViAct_CopyCameraOnMonitorEventArgs^ e)
Delegate for action 'Copy a video input from one video output to another one.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CrossSwitchEventHandler (Object^ sender, GeViAct_CrossSwitchEventArgs^ e)
Delegate for action 'Switch a video input on a video output'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CrossSwitchWithAlarmEventHandler (Object^ sender, GeViAct_CrossSwitchWithAlarmEventArgs^ e)
Delegate for action 'Switch a video input on a video output'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CustomActionEventHandler (Object^ sender, GeViAct_CustomActionEventArgs^ e)
Delegate for action 'Customized action'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DataBaseFailureEventHandler (Object^ sender, GeViAct_DataBaseFailureEventArgs^ e)
Delegate for action 'Database failure.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DataBaseMissingEventHandler (Object^ sender, GeViAct_DataBaseMissingEventArgs^ e)
Delegate for action 'Missing database'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DataBaseReadyEventHandler (Object^ sender, GeViAct_DataBaseReadyEventArgs^ e)
Delegate for action 'The database is ready.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DefaultPosCallUpEventHandler (Object^ sender, GeViAct_DefaultPosCallUpEventArgs^ e)
Delegate for action 'Move camera to a base position'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DefaultPosClearEventHandler (Object^ sender, GeViAct_DefaultPosClearEventArgs^ e)
Delegate for action 'Clear base position of a camera.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DefaultPosSaveEventHandler (Object^ sender, GeViAct_DefaultPosSaveEventArgs^ e)
Delegate for action 'Save the base position of a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DisconnectUserEventHandler (Object^ sender, GeViAct_DisconnectUserEventArgs^ e)
Delegate for action 'Explizit logoff of a user'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_EventRelationEventHandler (Object^ sender, GeViAct_EventRelationEventArgs^ e)
Delegate for action 'Event relation was triggered'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_EventStartedEventHandler (Object^ sender, GeViAct_EventStartedEventArgs^ e)
Delegate for action 'Start of event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_EventStoppedEventHandler (Object^ sender, GeViAct_EventStoppedEventArgs^ e)
Delegate for action 'Stopp of event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FastetModeOnEventHandler (Object^ sender, GeViAct_FastetModeOnEventArgs^ e)
Delegate for action 'Turn on the fast mode'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FocusFarEventHandler (Object^ sender, GeViAct_FocusFarEventArgs^ e)
Delegate for action 'Set camera focus farer'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FocusNearEventHandler (Object^ sender, GeViAct_FocusNearEventArgs^ e)
Delegate for action 'Set camera focus nearer'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FocusStopEventHandler (Object^ sender, GeViAct_FocusStopEventArgs^ e)
Delegate for action 'Stopp the focussing of a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_GeviScopeServerConnectedEventHandler (Object^ sender, GeViAct_GeviScopeServerConnectedEventArgs^ e)
Delegate for action 'GeviScope server connected'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_GeviScopeServerConnectionFailedEventHandler (Object^ sender, GeViAct_GeviScopeServerConnectionFailedEventArgs^ e)
Delegate for action 'Open GeviScope connection failed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_GeviScopeServerDisconnectedEventHandler (Object^ sender, GeViAct_GeviScopeServerDisconnectedEventArgs^ e)
Delegate for action 'GeviScope disconnected'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_HistoricalAlarmEventHandler (Object^ sender, GeViAct_HistoricalAlarmEventArgs^ e)
Delegate for action 'Historical alarm message.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_HistoricalInputEventHandler (Object^ sender, GeViAct_HistoricalInputEventArgs^ e)
Delegate for action 'Historical contact message.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorCameraOutputEventHandler (Object^ sender, GeViAct_IlluminatorCameraOutputEventArgs^ e)
Delegate for action 'Output command to the connected camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorDimLevelEventHandler (Object^ sender, GeViAct_IlluminatorDimLevelEventArgs^ e)
Delegate for action 'The current dim level of the illuminator'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorGetDimLevelEventHandler (Object^ sender, GeViAct_IlluminatorGetDimLevelEventArgs^ e)
Delegate for action 'Get the dim level of the illuminator'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorLightOffEventHandler (Object^ sender, GeViAct_IlluminatorLightOffEventArgs^ e)
Delegate for action 'Turn off the illuminator light'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorLightOnEventHandler (Object^ sender, GeViAct_IlluminatorLightOnEventArgs^ e)
Delegate for action 'Turn on the illuminator light'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorOffEventHandler (Object^ sender, GeViAct_IlluminatorOffEventArgs^ e)
Delegate for action 'Turn off the illuminator'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorOnEventHandler (Object^ sender, GeViAct_IlluminatorOnEventArgs^ e)
Delegate for action 'Turn on the illuminator'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSetDimLevelEventHandler (Object^ sender, GeViAct_IlluminatorSetDimLevelEventArgs^ e)
Delegate for action 'Set the dim level of the illuminator'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncUOffEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncUOffEventArgs^ e)
Delegate for action 'Turn off the special function U'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncUOnEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncUOnEventArgs^ e)
Delegate for action 'Turn on the special function U'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncVOffEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncVOffEventArgs^ e)
Delegate for action 'Turn off the special function V'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncVOnEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncVOnEventArgs^ e)
Delegate for action 'Turn on the special function V'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncXOffEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncXOffEventArgs^ e)
Delegate for action 'Turn off the special function X'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncXOnEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncXOnEventArgs^ e)
Delegate for action 'Turn on the special function X'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncYOffEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncYOffEventArgs^ e)
Delegate for action 'Turn off the special function Y'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncYOnEventHandler (Object^ sender, GeViAct_IlluminatorSpecFuncYOnEventArgs^ e)
Delegate for action 'Turn on the special function Y'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformAllUsersEventHandler (Object^ sender, GeViAct_InformAllUsersEventArgs^ e)
Delegate for action 'Send a message to all users'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformAllUsersMSGEventHandler (Object^ sender, GeViAct_InformAllUsersMSGEventArgs^ e)
Delegate for action 'Send a message to all users'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformUserEventHandler (Object^ sender, GeViAct_InformUserEventArgs^ e)
Delegate for action 'Sending of a message to a user.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformUserMSGEventHandler (Object^ sender, GeViAct_InformUserMSGEventArgs^ e)
Delegate for action 'Send a message to user'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InputContactEventHandler (Object^ sender, GeViAct_InputContactEventArgs^ e)
Delegate for action 'Input event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InputContactSabotageEventHandler (Object^ sender, GeViAct_InputContactSabotageEventArgs^ e)
Delegate for action 'Input event sabotage notification'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IrisCloseEventHandler (Object^ sender, GeViAct_IrisCloseEventArgs^ e)
Delegate for action 'Close camera iris'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IrisOpenEventHandler (Object^ sender, GeViAct_IrisOpenEventArgs^ e)
Delegate for action 'Open the iris of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IrisStopEventHandler (Object^ sender, GeViAct_IrisStopEventArgs^ e)
Delegate for action 'Stopp closing the iris'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogLastActionEventHandler (Object^ sender, GeViAct_LogLastActionEventArgs^ e)
Delegate for action 'The input action of the current action mapping will be logged.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogMessageEventHandler (Object^ sender, GeViAct_LogMessageEventArgs^ e)
Delegate for action 'Log message'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogMessageMSGEventHandler (Object^ sender, GeViAct_LogMessageMSGEventArgs^ e)
Delegate for action 'Logging of a message'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogSourceActionEventHandler (Object^ sender, GeViAct_LogSourceActionEventArgs^ e)
Delegate for action 'The input action of the first action mapping of this action mapping chain will be logged'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegAlarmAckEventHandler (Object^ sender, GeViAct_MBegAlarmAckEventArgs^ e)
Delegate for action 'AlarmAck-report at a MBeg'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegAlarmQuitEventHandler (Object^ sender, GeViAct_MBegAlarmQuitEventArgs^ e)
Delegate for action 'Report of the alarm quitting to a MBeg'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegAlarmStartEventHandler (Object^ sender, GeViAct_MBegAlarmStartEventArgs^ e)
Delegate for action 'Report of a alarm start at a MBeg'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegInitRequestEventHandler (Object^ sender, GeViAct_MBegInitRequestEventArgs^ e)
Delegate for action 'Request of a MBeg initialization sequence'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegInitSeqEventHandler (Object^ sender, GeViAct_MBegInitSeqEventArgs^ e)
Delegate for action 'MBeg init sequence'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegLockCameraEventHandler (Object^ sender, GeViAct_MBegLockCameraEventArgs^ e)
Delegate for action 'Request the exclusive PTZ control'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegUnlockCameraEventHandler (Object^ sender, GeViAct_MBegUnlockCameraEventArgs^ e)
Delegate for action 'Release the exclusive PTZ control'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmAuxiliaryInputEventHandler (Object^ sender, GeViAct_MIPAlarmAuxiliaryInputEventArgs^ e)
Delegate for action 'MIP alarm auxiliary input'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmCableEventHandler (Object^ sender, GeViAct_MIPAlarmCableEventArgs^ e)
Delegate for action 'MIP alarm cable'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmLUTamperEventHandler (Object^ sender, GeViAct_MIPAlarmLUTamperEventArgs^ e)
Delegate for action 'MIP alarm LU tamper'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmPMTamperEventHandler (Object^ sender, GeViAct_MIPAlarmPMTamperEventArgs^ e)
Delegate for action 'MIP alarm PM tamper'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmRMTamperEventHandler (Object^ sender, GeViAct_MIPAlarmRMTamperEventArgs^ e)
Delegate for action 'MIP alarm RM tamper'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAuxiliaryAlarmStateEventHandler (Object^ sender, GeViAct_MIPAuxiliaryAlarmStateEventArgs^ e)
Delegate for action 'MIP auxiliary alarm state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAuxiliarySensorStatusEventHandler (Object^ sender, GeViAct_MIPAuxiliarySensorStatusEventArgs^ e)
Delegate for action 'MIP auxiliary sensor status'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPCableAFaultStateEventHandler (Object^ sender, GeViAct_MIPCableAFaultStateEventArgs^ e)
Delegate for action 'MIP cable A failure state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPCableBFaultStateEventHandler (Object^ sender, GeViAct_MIPCableBFaultStateEventArgs^ e)
Delegate for action 'MIP cable B failure state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPDisplaySegmentAlarmStateEventHandler (Object^ sender, GeViAct_MIPDisplaySegmentAlarmStateEventArgs^ e)
Delegate for action 'MIP display segment alarm state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPDisplaySegmentStatusEventHandler (Object^ sender, GeViAct_MIPDisplaySegmentStatusEventArgs^ e)
Delegate for action 'MIP display segment status'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPLUTamperAlarmStateEventHandler (Object^ sender, GeViAct_MIPLUTamperAlarmStateEventArgs^ e)
Delegate for action 'MIP LU tamper alarm state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPLUTamperStatusEventHandler (Object^ sender, GeViAct_MIPLUTamperStatusEventArgs^ e)
Delegate for action 'MIP LU tamper status'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPOfflineEventHandler (Object^ sender, GeViAct_MIPOfflineEventArgs^ e)
Delegate for action 'MIP interface offnline'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPOnlineEventHandler (Object^ sender, GeViAct_MIPOnlineEventArgs^ e)
Delegate for action 'MIP interface online'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPPMComFailStateEventHandler (Object^ sender, GeViAct_MIPPMComFailStateEventArgs^ e)
Delegate for action 'MIP PM COM failure state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPPMTamperAlarmStateEventHandler (Object^ sender, GeViAct_MIPPMTamperAlarmStateEventArgs^ e)
Delegate for action 'MIP PM tamper alarm state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPPMTamperStatusEventHandler (Object^ sender, GeViAct_MIPPMTamperStatusEventArgs^ e)
Delegate for action 'MIP PM tamper status'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPQueryInterfaceEventHandler (Object^ sender, GeViAct_MIPQueryInterfaceEventArgs^ e)
Delegate for action 'MIP query interface'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPRMComFailStateEventHandler (Object^ sender, GeViAct_MIPRMComFailStateEventArgs^ e)
Delegate for action 'MIP RM COM failure state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPRMTamperAlarmStateEventHandler (Object^ sender, GeViAct_MIPRMTamperAlarmStateEventArgs^ e)
Delegate for action 'MIP RM tamper alarm state'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPRMTamperStatusEventHandler (Object^ sender, GeViAct_MIPRMTamperStatusEventArgs^ e)
Delegate for action 'MIP RM tamper status'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureAuxiliarySensorEventHandler (Object^ sender, GeViAct_MIPSecureAuxiliarySensorEventArgs^ e)
Delegate for action 'MIP secure auxiliary sensor'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureAuxiliaryTP1EventHandler (Object^ sender, GeViAct_MIPSecureAuxiliaryTP1EventArgs^ e)
Delegate for action 'MIP secure TP 1'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureAuxiliaryTP2EventHandler (Object^ sender, GeViAct_MIPSecureAuxiliaryTP2EventArgs^ e)
Delegate for action 'MIP secure TP 2'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureDisplaySegmentEventHandler (Object^ sender, GeViAct_MIPSecureDisplaySegmentEventArgs^ e)
Delegate for action 'MIP secure display segment'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureLUEventHandler (Object^ sender, GeViAct_MIPSecureLUEventArgs^ e)
Delegate for action 'MIP secure LU'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecurePMEventHandler (Object^ sender, GeViAct_MIPSecurePMEventArgs^ e)
Delegate for action 'MIP secure PM'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureRMEventHandler (Object^ sender, GeViAct_MIPSecureRMEventArgs^ e)
Delegate for action 'MIP secure RM'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPTurnARelayControlEventHandler (Object^ sender, GeViAct_MIPTurnARelayControlEventArgs^ e)
Delegate for action 'MIP turn a relay control'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPTurnRelaysOnOneZoneEventHandler (Object^ sender, GeViAct_MIPTurnRelaysOnOneZoneEventArgs^ e)
Delegate for action 'MIP turn relay on one zone'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MonitorGroupDisableEventHandler (Object^ sender, GeViAct_MonitorGroupDisableEventArgs^ e)
Delegate for action 'Disable monitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MonitorGroupEnableEventHandler (Object^ sender, GeViAct_MonitorGroupEnableEventArgs^ e)
Delegate for action 'Enable monitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MonitorGroupStatusChangedEventHandler (Object^ sender, GeViAct_MonitorGroupStatusChangedEventArgs^ e)
Delegate for action 'State of a monitor group has changed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MoveActualAlarmEventHandler (Object^ sender, GeViAct_MoveActualAlarmEventArgs^ e)
Delegate for action 'Move alarm to an other monitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MoveAlarmByInstanceEventHandler (Object^ sender, GeViAct_MoveAlarmByInstanceEventArgs^ e)
Delegate for action 'Move the alarm to an other monitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscEventStartedEventHandler (Object^ sender, GeViAct_MscEventStartedEventArgs^ e)
Delegate for action 'Start of the event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscEventStoppedEventHandler (Object^ sender, GeViAct_MscEventStoppedEventArgs^ e)
Delegate for action 'Stopp of an event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerConnectedEventHandler (Object^ sender, GeViAct_MscServerConnectedEventArgs^ e)
Delegate for action 'MULTISCOPE connected'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerConnectFailedEventHandler (Object^ sender, GeViAct_MscServerConnectFailedEventArgs^ e)
Delegate for action 'Open MULTISCOPE connection failed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerDisconnectEventHandler (Object^ sender, GeViAct_MscServerDisconnectEventArgs^ e)
Delegate for action 'Close MULTISCOPE connection'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerDisconnectedEventHandler (Object^ sender, GeViAct_MscServerDisconnectedEventArgs^ e)
Delegate for action 'MULTISCOPE disconnected'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscSetupModifiedEventHandler (Object^ sender, GeViAct_MscSetupModifiedEventArgs^ e)
Delegate for action 'MULTISCOPE Setup changed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_NormalModeOnEventHandler (Object^ sender, GeViAct_NormalModeOnEventArgs^ e)
Delegate for action 'Turn on normal mode'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_OpenContactEventHandler (Object^ sender, GeViAct_OpenContactEventArgs^ e)
Delegate for action 'Open contact'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanAutoEventHandler (Object^ sender, GeViAct_PanAutoEventArgs^ e)
Delegate for action 'Automatic panning of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanLeftEventHandler (Object^ sender, GeViAct_PanLeftEventArgs^ e)
Delegate for action 'Pan camera to the left'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanRightEventHandler (Object^ sender, GeViAct_PanRightEventArgs^ e)
Delegate for action 'Pan camera to the right'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanStopEventHandler (Object^ sender, GeViAct_PanStopEventArgs^ e)
Delegate for action 'Stopp panning of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PopUpAlarmEventHandler (Object^ sender, GeViAct_PopUpAlarmEventArgs^ e)
Delegate for action 'Display alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PopUpNextAlarmEventHandler (Object^ sender, GeViAct_PopUpNextAlarmEventArgs^ e)
Delegate for action 'Send the actual alarm back in the queue and send the next to the monitors'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PrePosCallUpEventHandler (Object^ sender, GeViAct_PrePosCallUpEventArgs^ e)
Delegate for action 'Move camera to a fix position'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PrePosClearEventHandler (Object^ sender, GeViAct_PrePosClearEventArgs^ e)
Delegate for action 'Clear fix position of a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PrePosSaveEventHandler (Object^ sender, GeViAct_PrePosSaveEventArgs^ e)
Delegate for action 'Save a fix position of a camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAlarmByInstanceEventHandler (Object^ sender, GeViAct_QuitAlarmByInstanceEventArgs^ e)
Delegate for action 'Quitting a alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAlarmByMGEventHandler (Object^ sender, GeViAct_QuitAlarmByMGEventArgs^ e)
Delegate for action 'Quit an actual alarm on a monitorgroup'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAlarmByTypeEventHandler (Object^ sender, GeViAct_QuitAlarmByTypeEventArgs^ e)
Delegate for action 'Quitting an alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAllAlarmsOnMGEventHandler (Object^ sender, GeViAct_QuitAllAlarmsOnMGEventArgs^ e)
Delegate for action 'Quit of all alarms on a moitor group'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedChangeMasterEventHandler (Object^ sender, GeViAct_RedChangeMasterEventArgs^ e)
Delegate for action 'Set new server as master'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedConnectionMasterChangedEventHandler (Object^ sender, GeViAct_RedConnectionMasterChangedEventArgs^ e)
Delegate for action 'Connection master was changed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedirectResourceEventHandler (Object^ sender, GeViAct_RedirectResourceEventArgs^ e)
Delegate for action 'Redirect resource.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedMasterServerChangedEventHandler (Object^ sender, GeViAct_RedMasterServerChangedEventArgs^ e)
Delegate for action 'Master server was changed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedRedundantLoginFailedEventHandler (Object^ sender, GeViAct_RedRedundantLoginFailedEventArgs^ e)
Delegate for action 'Redundant login failed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedRedundantUserLoginEventHandler (Object^ sender, GeViAct_RedRedundantUserLoginEventArgs^ e)
Delegate for action 'Redundant login successful'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RescannRequestEventHandler (Object^ sender, GeViAct_RescannRequestEventArgs^ e)
Delegate for action 'Request to all users to perform a rescan'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RescannRequestToClientEventHandler (Object^ sender, GeViAct_RescannRequestToClientEventArgs^ e)
Delegate for action 'Request to a user to perform a rescan'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RestoreRightProfileEventHandler (Object^ sender, GeViAct_RestoreRightProfileEventArgs^ e)
Delegate for action 'Restore right profile of a user'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SendRawDataEventHandler (Object^ sender, GeViAct_SendRawDataEventArgs^ e)
Delegate for action 'Output the data to a RAW- or any other serial interface'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SendRawDataMSGEventHandler (Object^ sender, GeViAct_SendRawDataMSGEventArgs^ e)
Delegate for action 'Output the data to a RAW- or any other serial interface'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartAlarmEventHandler (Object^ sender, GeViAct_StartAlarmEventArgs^ e)
Delegate for action 'Start of a alarm of a special typ'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartEventEventHandler (Object^ sender, GeViAct_StartEventEventArgs^ e)
Delegate for action 'Start of event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartMscEventEventHandler (Object^ sender, GeViAct_StartMscEventEventArgs^ e)
Delegate for action 'Start of MULTISCOPE event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartTimerEventHandler (Object^ sender, GeViAct_StartTimerEventArgs^ e)
Delegate for action 'Start timer'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopEventByInstanceEventHandler (Object^ sender, GeViAct_StopEventByInstanceEventArgs^ e)
Delegate for action 'Stopp the event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopEventByTypeEventHandler (Object^ sender, GeViAct_StopEventByTypeEventArgs^ e)
Delegate for action 'Stopp the event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopMscEventEventHandler (Object^ sender, GeViAct_StopMscEventEventArgs^ e)
Delegate for action 'Stopp a MULTISCOPE event'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopTimerEventHandler (Object^ sender, GeViAct_StopTimerEventArgs^ e)
Delegate for action 'Stopp the timer'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeRequestEventHandler (Object^ sender, GeViAct_SyncTimeRequestEventArgs^ e)
Delegate for action 'Request to all users to perform a time synchronization'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeRequestToClientEventHandler (Object^ sender, GeViAct_SyncTimeRequestToClientEventArgs^ e)
Delegate for action 'Request to a user to perform a time synchronization'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeSetTimeEventHandler (Object^ sender, GeViAct_SyncTimeSetTimeEventArgs^ e)
Delegate for action 'Explizit setting of date and time'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeSetTimeActualEventHandler (Object^ sender, GeViAct_SyncTimeSetTimeActualEventArgs^ e)
Delegate for action 'Explizit setting of date and time'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeSetTimeClientEventHandler (Object^ sender, GeViAct_SyncTimeSetTimeClientEventArgs^ e)
Delegate for action 'Explizit setting of date and time'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemErrorEventHandler (Object^ sender, GeViAct_SystemErrorEventArgs^ e)
Delegate for action 'System error'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemSettingsChangedEventHandler (Object^ sender, GeViAct_SystemSettingsChangedEventArgs^ e)
Delegate for action 'System settings changed.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemStartedEventHandler (Object^ sender, GeViAct_SystemStartedEventArgs^ e)
Delegate for action 'The system is starting.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemStoppedEventHandler (Object^ sender, GeViAct_SystemStoppedEventArgs^ e)
Delegate for action 'The system is stopping.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemWarningEventHandler (Object^ sender, GeViAct_SystemWarningEventArgs^ e)
Delegate for action 'System warning'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TakeCameraControlEventHandler (Object^ sender, GeViAct_TakeCameraControlEventArgs^ e)
Delegate for action 'Take over camera control'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TiltDownEventHandler (Object^ sender, GeViAct_TiltDownEventArgs^ e)
Delegate for action 'Incline the camera down'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TiltStopEventHandler (Object^ sender, GeViAct_TiltStopEventArgs^ e)
Delegate for action 'Stopp the inclinig of the camera'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TiltUpEventHandler (Object^ sender, GeViAct_TiltUpEventArgs^ e)
Delegate for action 'Incline camera up'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TimeRangeEndedEventHandler (Object^ sender, GeViAct_TimeRangeEndedEventArgs^ e)
Delegate for action 'Cancel time range'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TimeRangeStartedEventHandler (Object^ sender, GeViAct_TimeRangeStartedEventArgs^ e)
Delegate for action 'Start of the time range'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_UserLoginEventHandler (Object^ sender, GeViAct_UserLoginEventArgs^ e)
Delegate for action 'User has logged in.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_UserLoginFailedEventHandler (Object^ sender, GeViAct_UserLoginFailedEventArgs^ e)
Delegate for action 'Login failed.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_UserLogoutEventHandler (Object^ sender, GeViAct_UserLogoutEventArgs^ e)
Delegate for action 'User has logged out.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoClearTextOutEventHandler (Object^ sender, GeViAct_VideoClearTextOutEventArgs^ e)
Delegate for action 'Clears the free text'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoContrastAlarmEventHandler (Object^ sender, GeViAct_VideoContrastAlarmEventArgs^ e)
Delegate for action 'The image is disturbed.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoContrastOkEventHandler (Object^ sender, GeViAct_VideoContrastOkEventArgs^ e)
Delegate for action 'The contrast is OK again.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoContrastPreAlarmEventHandler (Object^ sender, GeViAct_VideoContrastPreAlarmEventArgs^ e)
Delegate for action 'The contrast is critical.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoSyncFailureEventHandler (Object^ sender, GeViAct_VideoSyncFailureEventArgs^ e)
Delegate for action 'Sync-signal failure.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoSyncOkEventHandler (Object^ sender, GeViAct_VideoSyncOkEventArgs^ e)
Delegate for action 'Sync-signal works correct again.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoTextOutEventHandler (Object^ sender, GeViAct_VideoTextOutEventArgs^ e)
Delegate for action 'Display free text on that video output.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoThresholdRequestEventHandler (Object^ sender, GeViAct_VideoThresholdRequestEventArgs^ e)
Delegate for action 'Internal action requests the threshold value of an input'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoThresholdValueEventHandler (Object^ sender, GeViAct_VideoThresholdValueEventArgs^ e)
Delegate for action 'Internal action, return of the threshold value of an input'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VS30PMModeEventHandler (Object^ sender, GeViAct_VS30PMModeEventArgs^ e)
Delegate for action 'Mode is 'Working' or 'Setup''.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VS30VMDModeEventHandler (Object^ sender, GeViAct_VS30VMDModeEventArgs^ e)
Delegate for action 'Mode of the VMD'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAlarmEndEventHandler (Object^ sender, GeViAct_VSAlarmEndEventArgs^ e)
Delegate for action 'Alarm has finished.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAlarmExternEventHandler (Object^ sender, GeViAct_VSAlarmExternEventArgs^ e)
Delegate for action 'External alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAlarmInFieldEventHandler (Object^ sender, GeViAct_VSAlarmInFieldEventArgs^ e)
Delegate for action 'Alarm in a field'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAllTestAlarmEventHandler (Object^ sender, GeViAct_VSAllTestAlarmEventArgs^ e)
Delegate for action 'Test alarm for all VMD's of one client.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAllTimerResetEventHandler (Object^ sender, GeViAct_VSAllTimerResetEventArgs^ e)
Delegate for action 'Reset of the timers of all VMD of a client.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSArmedEventHandler (Object^ sender, GeViAct_VSArmedEventArgs^ e)
Delegate for action 'VMD armed or disarmed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSChooseSavedPictureEventHandler (Object^ sender, GeViAct_VSChooseSavedPictureEventArgs^ e)
Delegate for action 'Choose a saved picture.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPictureDetectEventHandler (Object^ sender, GeViAct_VSPictureDetectEventArgs^ e)
Delegate for action 'Picture OK respective picture failure'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPictureToCommonOutEventHandler (Object^ sender, GeViAct_VSPictureToCommonOutEventArgs^ e)
Delegate for action 'Set one picture to a common output'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPictureToOutputEventHandler (Object^ sender, GeViAct_VSPictureToOutputEventArgs^ e)
Delegate for action 'Set a picture to an output'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPreAlarmEventHandler (Object^ sender, GeViAct_VSPreAlarmEventArgs^ e)
Delegate for action 'Prealarm respective bring prealarm to end'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSRecorderEndEventHandler (Object^ sender, GeViAct_VSRecorderEndEventArgs^ e)
Delegate for action 'The recorder was stopped'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSRecorderTimerResetEventHandler (Object^ sender, GeViAct_VSRecorderTimerResetEventArgs^ e)
Delegate for action 'Reset of timer of the recorder of a VMD.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetAllArmedEventHandler (Object^ sender, GeViAct_VSSetAllArmedEventArgs^ e)
Delegate for action 'All VMD's will be armed or disarmed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetArmedEventHandler (Object^ sender, GeViAct_VSSetArmedEventArgs^ e)
Delegate for action 'Set the VMD armed or disarmed'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetDateAndTimeEventHandler (Object^ sender, GeViAct_VSSetDateAndTimeEventArgs^ e)
Delegate for action 'Set date and time of a CU.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetModeEventHandler (Object^ sender, GeViAct_VSSetModeEventArgs^ e)
Delegate for action 'Reset timers of all VMD's of a VS-40 interface'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetSensorModeEventHandler (Object^ sender, GeViAct_VSSetSensorModeEventArgs^ e)
Delegate for action 'Set mode of the sensor'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetSensorOutputEventHandler (Object^ sender, GeViAct_VSSetSensorOutputEventArgs^ e)
Delegate for action 'Change output settings of the sensor'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSyncSignalDetectEventHandler (Object^ sender, GeViAct_VSSyncSignalDetectEventArgs^ e)
Delegate for action 'Sync signal and picture failure respective Sync signal OK'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSTestAlarmEventHandler (Object^ sender, GeViAct_VSTestAlarmEventArgs^ e)
Delegate for action 'Test alarm'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSTimerResetEventHandler (Object^ sender, GeViAct_VSTimerResetEventArgs^ e)
Delegate for action 'Resez timer of aVMD.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSVMDModeEventHandler (Object^ sender, GeViAct_VSVMDModeEventArgs^ e)
Delegate for action 'Mode is 'Working' or 'Setup''.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSVMDOutOfOrderEventHandler (Object^ sender, GeViAct_VSVMDOutOfOrderEventArgs^ e)
Delegate for action 'VMD Out of order'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VX3SystemResetEventHandler (Object^ sender, GeViAct_VX3SystemResetEventArgs^ e)
Delegate for action 'Reset the VX3-system'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ZoomInEventHandler (Object^ sender, GeViAct_ZoomInEventArgs^ e)
Delegate for action 'Zooming in the room'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ZoomOutEventHandler (Object^ sender, GeViAct_ZoomOutEventArgs^ e)
Delegate for action 'Zooming out of the room.'.
public delegate void | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ZoomStopEventHandler (Object^ sender, GeViAct_ZoomStopEventArgs^ e)
Delegate for action 'Stop zooming of the camera'.

Events

GeViAct_GscActionEventHandler^ | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedGscAction

Detailed Description

These are the Event Handlers of the GeViSoft .NET SDK.

Function Documentation

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAlarmByInstanceEventHandler | ( | Object^ | sender,
 |  | GeViAct_AckAlarmByInstanceEventArgs^ | e
 | ) |  |

Delegate for action 'Acknowledgement of the alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAlarmByMGEventHandler | ( | Object^ | sender,
 |  | GeViAct_AckAlarmByMGEventArgs^ | e
 | ) |  |

Delegate for action 'Acknowledge of the actual alarm on a moitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAlarmByTypeEventHandler | ( | Object^ | sender,
 |  | GeViAct_AckAlarmByTypeEventArgs^ | e
 | ) |  |

Delegate for action 'Acknowledge the alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AckAllAlarmsOnMGEventHandler | ( | Object^ | sender,
 |  | GeViAct_AckAllAlarmsOnMGEventArgs^ | e
 | ) |  |

Delegate for action 'Acknowledge of all alarms on a moitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ActionByNameEventHandler | ( | Object^ | sender,
 |  | GeViAct_ActionByNameEventArgs^ | e
 | ) |  |

Delegate for action 'Execution of a named action'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ActionDataCorruptEventHandler | ( | Object^ | sender,
 |  | GeViAct_ActionDataCorruptEventArgs^ | e
 | ) |  |

Delegate for action 'The action data can not be found in the data base.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ActivateAssignmentProfileEventHandler | ( | Object^ | sender,
 |  | GeViAct_ActivateAssignmentProfileEventArgs^ | e
 | ) |  |

Delegate for action 'Activate state profile'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmAckedEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlarmAckedEventArgs^ | e
 | ) |  |

Delegate for action 'Alarm was acknowledged'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmCopiedEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlarmCopiedEventArgs^ | e
 | ) |  |

Delegate for action 'An alarm was copied from one monitor group to an other'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmDisplayedEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlarmDisplayedEventArgs^ | e
 | ) |  |

Delegate for action 'Trigger by the display of the alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmMovedEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlarmMovedEventArgs^ | e
 | ) |  |

Delegate for action 'An alarm was moved from one monitor group to an other.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmQuittedEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlarmQuittedEventArgs^ | e
 | ) |  |

Delegate for action 'Alarm was quitted'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmRetriggeredEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlarmRetriggeredEventArgs^ | e
 | ) |  |

Delegate for action 'Alarm was restarted (retriggered)'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlarmStartedEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlarmStartedEventArgs^ | e
 | ) |  |

Delegate for action 'Alarm was started'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_AlternateContactEventHandler | ( | Object^ | sender,
 |  | GeViAct_AlternateContactEventArgs^ | e
 | ) |  |

Delegate for action 'Flash contact'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraAutoFocusOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraAutoFocusOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the auto focus of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraAutoFocusOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraAutoFocusOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the auto focus of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraClearPrePosTextEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraClearPrePosTextEventArgs^ | e
 | ) |  |

Delegate for action 'Delete text at the predefined position'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleNextEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraCycleNextEventArgs^ | e
 | ) |  |

Delegate for action 'Next camera in camera cycle'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCyclePauseEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraCyclePauseEventArgs^ | e
 | ) |  |

Delegate for action 'Pause camera cycle'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCyclePrevEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraCyclePrevEventArgs^ | e
 | ) |  |

Delegate for action 'Previous camera in camera cycle'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleResumeEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraCycleResumeEventArgs^ | e
 | ) |  |

Delegate for action 'Resume camera cycle'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleStartEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraCycleStartEventArgs^ | e
 | ) |  |

Delegate for action 'Start of the camera-cycle'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraCycleStopEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraCycleStopEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp camera cycle'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraLightOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraLightOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off camera light'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraLightOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraLightOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on camera light'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraManualIrisOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraManualIrisOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the manual iris of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraManualIrisOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraManualIrisOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the manual iris of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn a camera off'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraPumpOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraPumpOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn of pump of a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraPumpOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraPumpOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on pump of a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraRAWOutputEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraRAWOutputEventArgs^ | e
 | ) |  |

Delegate for action 'Output of a direct command to the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSelectCharModeEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSelectCharModeEventArgs^ | e
 | ) |  |

Delegate for action 'Select character set.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSetCameraTextEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSetCameraTextEventArgs^ | e
 | ) |  |

Delegate for action 'Set a camera text'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSetPrePosTextEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSetPrePosTextEventArgs^ | e
 | ) |  |

Delegate for action 'Set text on a predefinied position'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSmearAndWashOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSmearAndWashOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off wiping a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSmearAndWashOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSmearAndWashOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the wiping and washing of a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpec1FuncOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSpec1FuncOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off special function 1'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpec1FuncOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSpec1FuncOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on special function 1'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecUFuncOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSpecUFuncOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off special function U'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecUFuncOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSpecUFuncOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on special function U'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecVFuncOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSpecVFuncOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off special function V'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraSpecVFuncOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraSpecVFuncOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on special function V'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraStopAllEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraStopAllEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on displaying of firmware version'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTextOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTextOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the camera text'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTextOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTextOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the camera text'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourNextEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTourNextEventArgs^ | e
 | ) |  |

Delegate for action 'Next position in the camera tour'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourPauseEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTourPauseEventArgs^ | e
 | ) |  |

Delegate for action 'Pause the camera tour'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourPrevEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTourPrevEventArgs^ | e
 | ) |  |

Delegate for action 'Previous position in the camera tour'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourResumeEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTourResumeEventArgs^ | e
 | ) |  |

Delegate for action 'Resume the camera tour'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourStartEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTourStartEventArgs^ | e
 | ) |  |

Delegate for action 'Start of the camera tour'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraTourStopEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraTourStopEventArgs^ | e
 | ) |  |

Delegate for action 'Stop the camera tour'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CameraVerOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_CameraVerOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off displaying of the firmware version'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ChangeRightProfileEventHandler | ( | Object^ | sender,
 |  | GeViAct_ChangeRightProfileEventArgs^ | e
 | ) |  |

Delegate for action 'Change right profile of a user'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ClearAlarmFlagVideoInputEventHandler | ( | Object^ | sender,
 |  | GeViAct_ClearAlarmFlagVideoInputEventArgs^ | e
 | ) |  |

Delegate for action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ClearAlarmFlagVideoOutputEventHandler | ( | Object^ | sender,
 |  | GeViAct_ClearAlarmFlagVideoOutputEventArgs^ | e
 | ) |  |

Delegate for action 'Clear the alarm flag of that video output'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ClearVideoOutputEventHandler | ( | Object^ | sender,
 |  | GeViAct_ClearVideoOutputEventArgs^ | e
 | ) |  |

Delegate for action 'Clear that video output'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CloseContactEventHandler | ( | Object^ | sender,
 |  | GeViAct_CloseContactEventArgs^ | e
 | ) |  |

Delegate for action 'Close a contact'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CopyActualAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_CopyActualAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Copy actual alarm to an other monitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CopyAlarmByInstanceEventHandler | ( | Object^ | sender,
 |  | GeViAct_CopyAlarmByInstanceEventArgs^ | e
 | ) |  |

Delegate for action 'Copy the alarm to an other monitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CopyCameraOnMonitorEventHandler | ( | Object^ | sender,
 |  | GeViAct_CopyCameraOnMonitorEventArgs^ | e
 | ) |  |

Delegate for action 'Copy a video input from one video output to another one.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CrossSwitchEventHandler | ( | Object^ | sender,
 |  | GeViAct_CrossSwitchEventArgs^ | e
 | ) |  |

Delegate for action 'Switch a video input on a video output'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CrossSwitchWithAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_CrossSwitchWithAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Switch a video input on a video output'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_CustomActionEventHandler | ( | Object^ | sender,
 |  | GeViAct_CustomActionEventArgs^ | e
 | ) |  |

Delegate for action 'Customized action'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DataBaseFailureEventHandler | ( | Object^ | sender,
 |  | GeViAct_DataBaseFailureEventArgs^ | e
 | ) |  |

Delegate for action 'Database failure.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DataBaseMissingEventHandler | ( | Object^ | sender,
 |  | GeViAct_DataBaseMissingEventArgs^ | e
 | ) |  |

Delegate for action 'Missing database'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DataBaseReadyEventHandler | ( | Object^ | sender,
 |  | GeViAct_DataBaseReadyEventArgs^ | e
 | ) |  |

Delegate for action 'The database is ready.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DefaultPosCallUpEventHandler | ( | Object^ | sender,
 |  | GeViAct_DefaultPosCallUpEventArgs^ | e
 | ) |  |

Delegate for action 'Move camera to a base position'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DefaultPosClearEventHandler | ( | Object^ | sender,
 |  | GeViAct_DefaultPosClearEventArgs^ | e
 | ) |  |

Delegate for action 'Clear base position of a camera.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DefaultPosSaveEventHandler | ( | Object^ | sender,
 |  | GeViAct_DefaultPosSaveEventArgs^ | e
 | ) |  |

Delegate for action 'Save the base position of a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_DisconnectUserEventHandler | ( | Object^ | sender,
 |  | GeViAct_DisconnectUserEventArgs^ | e
 | ) |  |

Delegate for action 'Explizit logoff of a user'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_EventRelationEventHandler | ( | Object^ | sender,
 |  | GeViAct_EventRelationEventArgs^ | e
 | ) |  |

Delegate for action 'Event relation was triggered'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_EventStartedEventHandler | ( | Object^ | sender,
 |  | GeViAct_EventStartedEventArgs^ | e
 | ) |  |

Delegate for action 'Start of event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_EventStoppedEventHandler | ( | Object^ | sender,
 |  | GeViAct_EventStoppedEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp of event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FastetModeOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_FastetModeOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the fast mode'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FocusFarEventHandler | ( | Object^ | sender,
 |  | GeViAct_FocusFarEventArgs^ | e
 | ) |  |

Delegate for action 'Set camera focus farer'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FocusNearEventHandler | ( | Object^ | sender,
 |  | GeViAct_FocusNearEventArgs^ | e
 | ) |  |

Delegate for action 'Set camera focus nearer'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_FocusStopEventHandler | ( | Object^ | sender,
 |  | GeViAct_FocusStopEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp the focussing of a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_GeviScopeServerConnectedEventHandler | ( | Object^ | sender,
 |  | GeViAct_GeviScopeServerConnectedEventArgs^ | e
 | ) |  |

Delegate for action 'GeviScope server connected'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_GeviScopeServerConnectionFailedEventHandler | ( | Object^ | sender,
 |  | GeViAct_GeviScopeServerConnectionFailedEventArgs^ | e
 | ) |  |

Delegate for action 'Open GeviScope connection failed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_GeviScopeServerDisconnectedEventHandler | ( | Object^ | sender,
 |  | GeViAct_GeviScopeServerDisconnectedEventArgs^ | e
 | ) |  |

Delegate for action 'GeviScope disconnected'.

GeViAct_GscActionEventArgs::GeViAct_GscActionEventArgs ( GscAction^ act )

Create the EventArgs to handle received GeViSCOPE Actions.

Parameters:
m_GscAction This is the original GscAction'.
public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_HistoricalAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_HistoricalAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Historical alarm message.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_HistoricalInputEventHandler | ( | Object^ | sender,
 |  | GeViAct_HistoricalInputEventArgs^ | e
 | ) |  |

Delegate for action 'Historical contact message.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorCameraOutputEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorCameraOutputEventArgs^ | e
 | ) |  |

Delegate for action 'Output command to the connected camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorDimLevelEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorDimLevelEventArgs^ | e
 | ) |  |

Delegate for action 'The current dim level of the illuminator'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorGetDimLevelEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorGetDimLevelEventArgs^ | e
 | ) |  |

Delegate for action 'Get the dim level of the illuminator'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorLightOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorLightOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the illuminator light'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorLightOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorLightOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the illuminator light'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the illuminator'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the illuminator'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSetDimLevelEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSetDimLevelEventArgs^ | e
 | ) |  |

Delegate for action 'Set the dim level of the illuminator'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncUOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncUOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the special function U'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncUOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncUOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the special function U'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncVOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncVOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the special function V'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncVOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncVOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the special function V'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncXOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncXOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the special function X'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncXOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncXOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the special function X'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncYOffEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncYOffEventArgs^ | e
 | ) |  |

Delegate for action 'Turn off the special function Y'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IlluminatorSpecFuncYOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_IlluminatorSpecFuncYOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on the special function Y'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformAllUsersEventHandler | ( | Object^ | sender,
 |  | GeViAct_InformAllUsersEventArgs^ | e
 | ) |  |

Delegate for action 'Send a message to all users'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformAllUsersMSGEventHandler | ( | Object^ | sender,
 |  | GeViAct_InformAllUsersMSGEventArgs^ | e
 | ) |  |

Delegate for action 'Send a message to all users'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformUserEventHandler | ( | Object^ | sender,
 |  | GeViAct_InformUserEventArgs^ | e
 | ) |  |

Delegate for action 'Sending of a message to a user.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InformUserMSGEventHandler | ( | Object^ | sender,
 |  | GeViAct_InformUserMSGEventArgs^ | e
 | ) |  |

Delegate for action 'Send a message to user'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InputContactEventHandler | ( | Object^ | sender,
 |  | GeViAct_InputContactEventArgs^ | e
 | ) |  |

Delegate for action 'Input event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_InputContactSabotageEventHandler | ( | Object^ | sender,
 |  | GeViAct_InputContactSabotageEventArgs^ | e
 | ) |  |

Delegate for action 'Input event sabotage notification'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IrisCloseEventHandler | ( | Object^ | sender,
 |  | GeViAct_IrisCloseEventArgs^ | e
 | ) |  |

Delegate for action 'Close camera iris'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IrisOpenEventHandler | ( | Object^ | sender,
 |  | GeViAct_IrisOpenEventArgs^ | e
 | ) |  |

Delegate for action 'Open the iris of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_IrisStopEventHandler | ( | Object^ | sender,
 |  | GeViAct_IrisStopEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp closing the iris'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogLastActionEventHandler | ( | Object^ | sender,
 |  | GeViAct_LogLastActionEventArgs^ | e
 | ) |  |

Delegate for action 'The input action of the current action mapping will be logged.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogMessageEventHandler | ( | Object^ | sender,
 |  | GeViAct_LogMessageEventArgs^ | e
 | ) |  |

Delegate for action 'Log message'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogMessageMSGEventHandler | ( | Object^ | sender,
 |  | GeViAct_LogMessageMSGEventArgs^ | e
 | ) |  |

Delegate for action 'Logging of a message'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_LogSourceActionEventHandler | ( | Object^ | sender,
 |  | GeViAct_LogSourceActionEventArgs^ | e
 | ) |  |

Delegate for action 'The input action of the first action mapping of this action mapping chain will be logged'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegAlarmAckEventHandler | ( | Object^ | sender,
 |  | GeViAct_MBegAlarmAckEventArgs^ | e
 | ) |  |

Delegate for action 'AlarmAck-report at a MBeg'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegAlarmQuitEventHandler | ( | Object^ | sender,
 |  | GeViAct_MBegAlarmQuitEventArgs^ | e
 | ) |  |

Delegate for action 'Report of the alarm quitting to a MBeg'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegAlarmStartEventHandler | ( | Object^ | sender,
 |  | GeViAct_MBegAlarmStartEventArgs^ | e
 | ) |  |

Delegate for action 'Report of a alarm start at a MBeg'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegInitRequestEventHandler | ( | Object^ | sender,
 |  | GeViAct_MBegInitRequestEventArgs^ | e
 | ) |  |

Delegate for action 'Request of a MBeg initialization sequence'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegInitSeqEventHandler | ( | Object^ | sender,
 |  | GeViAct_MBegInitSeqEventArgs^ | e
 | ) |  |

Delegate for action 'MBeg init sequence'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegLockCameraEventHandler | ( | Object^ | sender,
 |  | GeViAct_MBegLockCameraEventArgs^ | e
 | ) |  |

Delegate for action 'Request the exclusive PTZ control'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MBegUnlockCameraEventHandler | ( | Object^ | sender,
 |  | GeViAct_MBegUnlockCameraEventArgs^ | e
 | ) |  |

Delegate for action 'Release the exclusive PTZ control'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmAuxiliaryInputEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPAlarmAuxiliaryInputEventArgs^ | e
 | ) |  |

Delegate for action 'MIP alarm auxiliary input'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmCableEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPAlarmCableEventArgs^ | e
 | ) |  |

Delegate for action 'MIP alarm cable'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmLUTamperEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPAlarmLUTamperEventArgs^ | e
 | ) |  |

Delegate for action 'MIP alarm LU tamper'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmPMTamperEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPAlarmPMTamperEventArgs^ | e
 | ) |  |

Delegate for action 'MIP alarm PM tamper'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAlarmRMTamperEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPAlarmRMTamperEventArgs^ | e
 | ) |  |

Delegate for action 'MIP alarm RM tamper'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAuxiliaryAlarmStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPAuxiliaryAlarmStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP auxiliary alarm state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPAuxiliarySensorStatusEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPAuxiliarySensorStatusEventArgs^ | e
 | ) |  |

Delegate for action 'MIP auxiliary sensor status'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPCableAFaultStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPCableAFaultStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP cable A failure state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPCableBFaultStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPCableBFaultStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP cable B failure state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPDisplaySegmentAlarmStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPDisplaySegmentAlarmStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP display segment alarm state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPDisplaySegmentStatusEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPDisplaySegmentStatusEventArgs^ | e
 | ) |  |

Delegate for action 'MIP display segment status'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPLUTamperAlarmStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPLUTamperAlarmStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP LU tamper alarm state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPLUTamperStatusEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPLUTamperStatusEventArgs^ | e
 | ) |  |

Delegate for action 'MIP LU tamper status'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPOfflineEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPOfflineEventArgs^ | e
 | ) |  |

Delegate for action 'MIP interface offnline'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPOnlineEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPOnlineEventArgs^ | e
 | ) |  |

Delegate for action 'MIP interface online'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPPMComFailStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPPMComFailStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP PM COM failure state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPPMTamperAlarmStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPPMTamperAlarmStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP PM tamper alarm state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPPMTamperStatusEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPPMTamperStatusEventArgs^ | e
 | ) |  |

Delegate for action 'MIP PM tamper status'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPQueryInterfaceEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPQueryInterfaceEventArgs^ | e
 | ) |  |

Delegate for action 'MIP query interface'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPRMComFailStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPRMComFailStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP RM COM failure state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPRMTamperAlarmStateEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPRMTamperAlarmStateEventArgs^ | e
 | ) |  |

Delegate for action 'MIP RM tamper alarm state'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPRMTamperStatusEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPRMTamperStatusEventArgs^ | e
 | ) |  |

Delegate for action 'MIP RM tamper status'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureAuxiliarySensorEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPSecureAuxiliarySensorEventArgs^ | e
 | ) |  |

Delegate for action 'MIP secure auxiliary sensor'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureAuxiliaryTP1EventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPSecureAuxiliaryTP1EventArgs^ | e
 | ) |  |

Delegate for action 'MIP secure TP 1'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureAuxiliaryTP2EventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPSecureAuxiliaryTP2EventArgs^ | e
 | ) |  |

Delegate for action 'MIP secure TP 2'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureDisplaySegmentEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPSecureDisplaySegmentEventArgs^ | e
 | ) |  |

Delegate for action 'MIP secure display segment'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureLUEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPSecureLUEventArgs^ | e
 | ) |  |

Delegate for action 'MIP secure LU'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecurePMEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPSecurePMEventArgs^ | e
 | ) |  |

Delegate for action 'MIP secure PM'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPSecureRMEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPSecureRMEventArgs^ | e
 | ) |  |

Delegate for action 'MIP secure RM'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPTurnARelayControlEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPTurnARelayControlEventArgs^ | e
 | ) |  |

Delegate for action 'MIP turn a relay control'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MIPTurnRelaysOnOneZoneEventHandler | ( | Object^ | sender,
 |  | GeViAct_MIPTurnRelaysOnOneZoneEventArgs^ | e
 | ) |  |

Delegate for action 'MIP turn relay on one zone'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MonitorGroupDisableEventHandler | ( | Object^ | sender,
 |  | GeViAct_MonitorGroupDisableEventArgs^ | e
 | ) |  |

Delegate for action 'Disable monitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MonitorGroupEnableEventHandler | ( | Object^ | sender,
 |  | GeViAct_MonitorGroupEnableEventArgs^ | e
 | ) |  |

Delegate for action 'Enable monitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MonitorGroupStatusChangedEventHandler | ( | Object^ | sender,
 |  | GeViAct_MonitorGroupStatusChangedEventArgs^ | e
 | ) |  |

Delegate for action 'State of a monitor group has changed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MoveActualAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_MoveActualAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Move alarm to an other monitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MoveAlarmByInstanceEventHandler | ( | Object^ | sender,
 |  | GeViAct_MoveAlarmByInstanceEventArgs^ | e
 | ) |  |

Delegate for action 'Move the alarm to an other monitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscEventStartedEventHandler | ( | Object^ | sender,
 |  | GeViAct_MscEventStartedEventArgs^ | e
 | ) |  |

Delegate for action 'Start of the event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscEventStoppedEventHandler | ( | Object^ | sender,
 |  | GeViAct_MscEventStoppedEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp of an event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerConnectedEventHandler | ( | Object^ | sender,
 |  | GeViAct_MscServerConnectedEventArgs^ | e
 | ) |  |

Delegate for action 'MULTISCOPE connected'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerConnectFailedEventHandler | ( | Object^ | sender,
 |  | GeViAct_MscServerConnectFailedEventArgs^ | e
 | ) |  |

Delegate for action 'Open MULTISCOPE connection failed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerDisconnectedEventHandler | ( | Object^ | sender,
 |  | GeViAct_MscServerDisconnectedEventArgs^ | e
 | ) |  |

Delegate for action 'MULTISCOPE disconnected'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscServerDisconnectEventHandler | ( | Object^ | sender,
 |  | GeViAct_MscServerDisconnectEventArgs^ | e
 | ) |  |

Delegate for action 'Close MULTISCOPE connection'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_MscSetupModifiedEventHandler | ( | Object^ | sender,
 |  | GeViAct_MscSetupModifiedEventArgs^ | e
 | ) |  |

Delegate for action 'MULTISCOPE Setup changed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_NormalModeOnEventHandler | ( | Object^ | sender,
 |  | GeViAct_NormalModeOnEventArgs^ | e
 | ) |  |

Delegate for action 'Turn on normal mode'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_OpenContactEventHandler | ( | Object^ | sender,
 |  | GeViAct_OpenContactEventArgs^ | e
 | ) |  |

Delegate for action 'Open contact'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanAutoEventHandler | ( | Object^ | sender,
 |  | GeViAct_PanAutoEventArgs^ | e
 | ) |  |

Delegate for action 'Automatic panning of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanLeftEventHandler | ( | Object^ | sender,
 |  | GeViAct_PanLeftEventArgs^ | e
 | ) |  |

Delegate for action 'Pan camera to the left'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanRightEventHandler | ( | Object^ | sender,
 |  | GeViAct_PanRightEventArgs^ | e
 | ) |  |

Delegate for action 'Pan camera to the right'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PanStopEventHandler | ( | Object^ | sender,
 |  | GeViAct_PanStopEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp panning of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PopUpAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_PopUpAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Display alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PopUpNextAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_PopUpNextAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Send the actual alarm back in the queue and send the next to the monitors'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PrePosCallUpEventHandler | ( | Object^ | sender,
 |  | GeViAct_PrePosCallUpEventArgs^ | e
 | ) |  |

Delegate for action 'Move camera to a fix position'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PrePosClearEventHandler | ( | Object^ | sender,
 |  | GeViAct_PrePosClearEventArgs^ | e
 | ) |  |

Delegate for action 'Clear fix position of a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_PrePosSaveEventHandler | ( | Object^ | sender,
 |  | GeViAct_PrePosSaveEventArgs^ | e
 | ) |  |

Delegate for action 'Save a fix position of a camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAlarmByInstanceEventHandler | ( | Object^ | sender,
 |  | GeViAct_QuitAlarmByInstanceEventArgs^ | e
 | ) |  |

Delegate for action 'Quitting a alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAlarmByMGEventHandler | ( | Object^ | sender,
 |  | GeViAct_QuitAlarmByMGEventArgs^ | e
 | ) |  |

Delegate for action 'Quit an actual alarm on a monitorgroup'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAlarmByTypeEventHandler | ( | Object^ | sender,
 |  | GeViAct_QuitAlarmByTypeEventArgs^ | e
 | ) |  |

Delegate for action 'Quitting an alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_QuitAllAlarmsOnMGEventHandler | ( | Object^ | sender,
 |  | GeViAct_QuitAllAlarmsOnMGEventArgs^ | e
 | ) |  |

Delegate for action 'Quit of all alarms on a moitor group'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedChangeMasterEventHandler | ( | Object^ | sender,
 |  | GeViAct_RedChangeMasterEventArgs^ | e
 | ) |  |

Delegate for action 'Set new server as master'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedConnectionMasterChangedEventHandler | ( | Object^ | sender,
 |  | GeViAct_RedConnectionMasterChangedEventArgs^ | e
 | ) |  |

Delegate for action 'Connection master was changed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedirectResourceEventHandler | ( | Object^ | sender,
 |  | GeViAct_RedirectResourceEventArgs^ | e
 | ) |  |

Delegate for action 'Redirect resource.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedMasterServerChangedEventHandler | ( | Object^ | sender,
 |  | GeViAct_RedMasterServerChangedEventArgs^ | e
 | ) |  |

Delegate for action 'Master server was changed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedRedundantLoginFailedEventHandler | ( | Object^ | sender,
 |  | GeViAct_RedRedundantLoginFailedEventArgs^ | e
 | ) |  |

Delegate for action 'Redundant login failed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RedRedundantUserLoginEventHandler | ( | Object^ | sender,
 |  | GeViAct_RedRedundantUserLoginEventArgs^ | e
 | ) |  |

Delegate for action 'Redundant login successful'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RescannRequestEventHandler | ( | Object^ | sender,
 |  | GeViAct_RescannRequestEventArgs^ | e
 | ) |  |

Delegate for action 'Request to all users to perform a rescan'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RescannRequestToClientEventHandler | ( | Object^ | sender,
 |  | GeViAct_RescannRequestToClientEventArgs^ | e
 | ) |  |

Delegate for action 'Request to a user to perform a rescan'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_RestoreRightProfileEventHandler | ( | Object^ | sender,
 |  | GeViAct_RestoreRightProfileEventArgs^ | e
 | ) |  |

Delegate for action 'Restore right profile of a user'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SendRawDataEventHandler | ( | Object^ | sender,
 |  | GeViAct_SendRawDataEventArgs^ | e
 | ) |  |

Delegate for action 'Output the data to a RAW- or any other serial interface'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SendRawDataMSGEventHandler | ( | Object^ | sender,
 |  | GeViAct_SendRawDataMSGEventArgs^ | e
 | ) |  |

Delegate for action 'Output the data to a RAW- or any other serial interface'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_StartAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Start of a alarm of a special typ'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartEventEventHandler | ( | Object^ | sender,
 |  | GeViAct_StartEventEventArgs^ | e
 | ) |  |

Delegate for action 'Start of event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartMscEventEventHandler | ( | Object^ | sender,
 |  | GeViAct_StartMscEventEventArgs^ | e
 | ) |  |

Delegate for action 'Start of MULTISCOPE event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StartTimerEventHandler | ( | Object^ | sender,
 |  | GeViAct_StartTimerEventArgs^ | e
 | ) |  |

Delegate for action 'Start timer'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopEventByInstanceEventHandler | ( | Object^ | sender,
 |  | GeViAct_StopEventByInstanceEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp the event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopEventByTypeEventHandler | ( | Object^ | sender,
 |  | GeViAct_StopEventByTypeEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp the event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopMscEventEventHandler | ( | Object^ | sender,
 |  | GeViAct_StopMscEventEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp a MULTISCOPE event'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_StopTimerEventHandler | ( | Object^ | sender,
 |  | GeViAct_StopTimerEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp the timer'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeRequestEventHandler | ( | Object^ | sender,
 |  | GeViAct_SyncTimeRequestEventArgs^ | e
 | ) |  |

Delegate for action 'Request to all users to perform a time synchronization'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeRequestToClientEventHandler | ( | Object^ | sender,
 |  | GeViAct_SyncTimeRequestToClientEventArgs^ | e
 | ) |  |

Delegate for action 'Request to a user to perform a time synchronization'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeSetTimeActualEventHandler | ( | Object^ | sender,
 |  | GeViAct_SyncTimeSetTimeActualEventArgs^ | e
 | ) |  |

Delegate for action 'Explizit setting of date and time'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeSetTimeClientEventHandler | ( | Object^ | sender,
 |  | GeViAct_SyncTimeSetTimeClientEventArgs^ | e
 | ) |  |

Delegate for action 'Explizit setting of date and time'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SyncTimeSetTimeEventHandler | ( | Object^ | sender,
 |  | GeViAct_SyncTimeSetTimeEventArgs^ | e
 | ) |  |

Delegate for action 'Explizit setting of date and time'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemErrorEventHandler | ( | Object^ | sender,
 |  | GeViAct_SystemErrorEventArgs^ | e
 | ) |  |

Delegate for action 'System error'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemSettingsChangedEventHandler | ( | Object^ | sender,
 |  | GeViAct_SystemSettingsChangedEventArgs^ | e
 | ) |  |

Delegate for action 'System settings changed.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemStartedEventHandler | ( | Object^ | sender,
 |  | GeViAct_SystemStartedEventArgs^ | e
 | ) |  |

Delegate for action 'The system is starting.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemStoppedEventHandler | ( | Object^ | sender,
 |  | GeViAct_SystemStoppedEventArgs^ | e
 | ) |  |

Delegate for action 'The system is stopping.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_SystemWarningEventHandler | ( | Object^ | sender,
 |  | GeViAct_SystemWarningEventArgs^ | e
 | ) |  |

Delegate for action 'System warning'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TakeCameraControlEventHandler | ( | Object^ | sender,
 |  | GeViAct_TakeCameraControlEventArgs^ | e
 | ) |  |

Delegate for action 'Take over camera control'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TiltDownEventHandler | ( | Object^ | sender,
 |  | GeViAct_TiltDownEventArgs^ | e
 | ) |  |

Delegate for action 'Incline the camera down'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TiltStopEventHandler | ( | Object^ | sender,
 |  | GeViAct_TiltStopEventArgs^ | e
 | ) |  |

Delegate for action 'Stopp the inclinig of the camera'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TiltUpEventHandler | ( | Object^ | sender,
 |  | GeViAct_TiltUpEventArgs^ | e
 | ) |  |

Delegate for action 'Incline camera up'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TimeRangeEndedEventHandler | ( | Object^ | sender,
 |  | GeViAct_TimeRangeEndedEventArgs^ | e
 | ) |  |

Delegate for action 'Cancel time range'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_TimeRangeStartedEventHandler | ( | Object^ | sender,
 |  | GeViAct_TimeRangeStartedEventArgs^ | e
 | ) |  |

Delegate for action 'Start of the time range'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_UserLoginEventHandler | ( | Object^ | sender,
 |  | GeViAct_UserLoginEventArgs^ | e
 | ) |  |

Delegate for action 'User has logged in.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_UserLoginFailedEventHandler | ( | Object^ | sender,
 |  | GeViAct_UserLoginFailedEventArgs^ | e
 | ) |  |

Delegate for action 'Login failed.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_UserLogoutEventHandler | ( | Object^ | sender,
 |  | GeViAct_UserLogoutEventArgs^ | e
 | ) |  |

Delegate for action 'User has logged out.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoClearTextOutEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoClearTextOutEventArgs^ | e
 | ) |  |

Delegate for action 'Clears the free text'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoContrastAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoContrastAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'The image is disturbed.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoContrastOkEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoContrastOkEventArgs^ | e
 | ) |  |

Delegate for action 'The contrast is OK again.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoContrastPreAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoContrastPreAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'The contrast is critical.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoSyncFailureEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoSyncFailureEventArgs^ | e
 | ) |  |

Delegate for action 'Sync-signal failure.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoSyncOkEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoSyncOkEventArgs^ | e
 | ) |  |

Delegate for action 'Sync-signal works correct again.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoTextOutEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoTextOutEventArgs^ | e
 | ) |  |

Delegate for action 'Display free text on that video output.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoThresholdRequestEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoThresholdRequestEventArgs^ | e
 | ) |  |

Delegate for action 'Internal action requests the threshold value of an input'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VideoThresholdValueEventHandler | ( | Object^ | sender,
 |  | GeViAct_VideoThresholdValueEventArgs^ | e
 | ) |  |

Delegate for action 'Internal action, return of the threshold value of an input'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VS30PMModeEventHandler | ( | Object^ | sender,
 |  | GeViAct_VS30PMModeEventArgs^ | e
 | ) |  |

Delegate for action 'Mode is 'Working' or 'Setup''.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VS30VMDModeEventHandler | ( | Object^ | sender,
 |  | GeViAct_VS30VMDModeEventArgs^ | e
 | ) |  |

Delegate for action 'Mode of the VMD'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAlarmEndEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSAlarmEndEventArgs^ | e
 | ) |  |

Delegate for action 'Alarm has finished.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAlarmExternEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSAlarmExternEventArgs^ | e
 | ) |  |

Delegate for action 'External alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAlarmInFieldEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSAlarmInFieldEventArgs^ | e
 | ) |  |

Delegate for action 'Alarm in a field'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAllTestAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSAllTestAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Test alarm for all VMD's of one client.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSAllTimerResetEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSAllTimerResetEventArgs^ | e
 | ) |  |

Delegate for action 'Reset of the timers of all VMD of a client.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSArmedEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSArmedEventArgs^ | e
 | ) |  |

Delegate for action 'VMD armed or disarmed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSChooseSavedPictureEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSChooseSavedPictureEventArgs^ | e
 | ) |  |

Delegate for action 'Choose a saved picture.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPictureDetectEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSPictureDetectEventArgs^ | e
 | ) |  |

Delegate for action 'Picture OK respective picture failure'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPictureToCommonOutEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSPictureToCommonOutEventArgs^ | e
 | ) |  |

Delegate for action 'Set one picture to a common output'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPictureToOutputEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSPictureToOutputEventArgs^ | e
 | ) |  |

Delegate for action 'Set a picture to an output'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSPreAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSPreAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Prealarm respective bring prealarm to end'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSRecorderEndEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSRecorderEndEventArgs^ | e
 | ) |  |

Delegate for action 'The recorder was stopped'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSRecorderTimerResetEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSRecorderTimerResetEventArgs^ | e
 | ) |  |

Delegate for action 'Reset of timer of the recorder of a VMD.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetAllArmedEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSSetAllArmedEventArgs^ | e
 | ) |  |

Delegate for action 'All VMD's will be armed or disarmed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetArmedEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSSetArmedEventArgs^ | e
 | ) |  |

Delegate for action 'Set the VMD armed or disarmed'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetDateAndTimeEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSSetDateAndTimeEventArgs^ | e
 | ) |  |

Delegate for action 'Set date and time of a CU.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetModeEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSSetModeEventArgs^ | e
 | ) |  |

Delegate for action 'Reset timers of all VMD's of a VS-40 interface'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetSensorModeEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSSetSensorModeEventArgs^ | e
 | ) |  |

Delegate for action 'Set mode of the sensor'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSetSensorOutputEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSSetSensorOutputEventArgs^ | e
 | ) |  |

Delegate for action 'Change output settings of the sensor'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSSyncSignalDetectEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSSyncSignalDetectEventArgs^ | e
 | ) |  |

Delegate for action 'Sync signal and picture failure respective Sync signal OK'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSTestAlarmEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSTestAlarmEventArgs^ | e
 | ) |  |

Delegate for action 'Test alarm'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSTimerResetEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSTimerResetEventArgs^ | e
 | ) |  |

Delegate for action 'Resez timer of aVMD.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSVMDModeEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSVMDModeEventArgs^ | e
 | ) |  |

Delegate for action 'Mode is 'Working' or 'Setup''.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VSVMDOutOfOrderEventHandler | ( | Object^ | sender,
 |  | GeViAct_VSVMDOutOfOrderEventArgs^ | e
 | ) |  |

Delegate for action 'VMD Out of order'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_VX3SystemResetEventHandler | ( | Object^ | sender,
 |  | GeViAct_VX3SystemResetEventArgs^ | e
 | ) |  |

Delegate for action 'Reset the VX3-system'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ZoomInEventHandler | ( | Object^ | sender,
 |  | GeViAct_ZoomInEventArgs^ | e
 | ) |  |

Delegate for action 'Zooming in the room'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ZoomOutEventHandler | ( | Object^ | sender,
 |  | GeViAct_ZoomOutEventArgs^ | e
 | ) |  |

Delegate for action 'Zooming out of the room.'.

public delegate void GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAct_ZoomStopEventHandler | ( | Object^ | sender,
 |  | GeViAct_ZoomStopEventArgs^ | e
 | ) |  |

Delegate for action 'Stop zooming of the camera'.

Events

GeViAct_GscActionEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedGscAction
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance | Action 'Acknowledgement of the alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG | Action 'Acknowledge of the actual alarm on a moitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType | Action 'Acknowledge the alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG | Action 'Acknowledge of all alarms on a moitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName | Action 'Execution of a named action'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt | Action 'The action data can not be found in the data base.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile | Action 'Activate state profile'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked | Action 'Alarm was acknowledged'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied | Action 'An alarm was copied from one monitor group to an other'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed | Action 'Trigger by the display of the alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved | Action 'An alarm was moved from one monitor group to an other.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted | Action 'Alarm was quitted'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered | Action 'Alarm was restarted (retriggered)'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted | Action 'Alarm was started'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact | Action 'Flash contact'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff | Action 'Turn off the auto focus of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn | Action 'Turn on the auto focus of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText | Action 'Delete text at the predefined position'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext | Action 'Next camera in camera cycle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause | Action 'Pause camera cycle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev | Action 'Previous camera in camera cycle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume | Action 'Resume camera cycle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart | Action 'Start of the camera-cycle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop | Action 'Stopp camera cycle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff | Action 'Turn off camera light'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn | Action 'Turn on camera light'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff | Action 'Turn off the manual iris of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn | Action 'Turn on the manual iris of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff | Action 'Turn a camera off'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn | Action 'Turn on a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff | Action 'Turn of pump of a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn | Action 'Turn on pump of a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput | Action 'Output of a direct command to the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode | Action 'Select character set.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText | Action 'Set a camera text'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText | Action 'Set text on a predefinied position'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff | Action 'Turn off wiping a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn | Action 'Turn on the wiping and washing of a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff | Action 'Turn off special function 1'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn | Action 'Turn on special function 1'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff | Action 'Turn off special function U'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn | Action 'Turn on special function U'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff | Action 'Turn off special function V'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn | Action 'Turn on special function V'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll | Action 'Turn on displaying of firmware version'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff | Action 'Turn off the camera text'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn | Action 'Turn on the camera text'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext | Action 'Next position in the camera tour'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause | Action 'Pause the camera tour'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev | Action 'Previous position in the camera tour'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume | Action 'Resume the camera tour'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart | Action 'Start of the camera tour'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop | Action 'Stop the camera tour'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff | Action 'Turn off displaying of the firmware version'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile | Action 'Change right profile of a user'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput | Action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput | Action 'Clear the alarm flag of that video output'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput | Action 'Clear that video output'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact | Action 'Close a contact'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm | Action 'Copy actual alarm to an other monitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance | Action 'Copy the alarm to an other monitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor | Action 'Copy a video input from one video output to another one.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch | Action 'Switch a video input on a video output'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm | Action 'Switch a video input on a video output'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction | Action 'Customized action'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure | Action 'Database failure.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing | Action 'Missing database'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady | Action 'The database is ready.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp | Action 'Move camera to a base position'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear | Action 'Clear base position of a camera.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave | Action 'Save the base position of a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser | Action 'Explizit logoff of a user'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation | Action 'Event relation was triggered'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted | Action 'Start of event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped | Action 'Stopp of event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn | Action 'Turn on the fast mode'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar | Action 'Set camera focus farer'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear | Action 'Set camera focus nearer'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop | Action 'Stopp the focussing of a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected | Action 'GeviScope server connected'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed | Action 'Open GeviScope connection failed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected | Action 'GeviScope disconnected'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm | Action 'Historical alarm message.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput | Action 'Historical contact message.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput | Action 'Output command to the connected camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel | Action 'The current dim level of the illuminator'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel | Action 'Get the dim level of the illuminator'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff | Action 'Turn off the illuminator light'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn | Action 'Turn on the illuminator light'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff | Action 'Turn off the illuminator'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn | Action 'Turn on the illuminator'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel | Action 'Set the dim level of the illuminator'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff | Action 'Turn off the special function U'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn | Action 'Turn on the special function U'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff | Action 'Turn off the special function V'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn | Action 'Turn on the special function V'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff | Action 'Turn off the special function X'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn | Action 'Turn on the special function X'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff | Action 'Turn off the special function Y'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn | Action 'Turn on the special function Y'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers | Action 'Send a message to all users'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG | Action 'Send a message to all users'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser | Action 'Sending of a message to a user.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG | Action 'Send a message to user'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact | Action 'Input event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage | Action 'Input event sabotage notification'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose | Action 'Close camera iris'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen | Action 'Open the iris of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop | Action 'Stopp closing the iris'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction | Action 'The input action of the current action mapping will be logged.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage | Action 'Log message'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG | Action 'Logging of a message'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction | Action 'The input action of the first action mapping of this action mapping chain will be logged'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck | Action 'AlarmAck-report at a MBeg'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit | Action 'Report of the alarm quitting to a MBeg'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart | Action 'Report of a alarm start at a MBeg'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest | Action 'Request of a MBeg initialization sequence'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq | Action 'MBeg init sequence'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera | Action 'Request the exclusive PTZ control'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera | Action 'Release the exclusive PTZ control'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput | Action 'MIP alarm auxiliary input'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable | Action 'MIP alarm cable'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper | Action 'MIP alarm LU tamper'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper | Action 'MIP alarm PM tamper'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper | Action 'MIP alarm RM tamper'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState | Action 'MIP auxiliary alarm state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus | Action 'MIP auxiliary sensor status'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState | Action 'MIP cable A failure state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState | Action 'MIP cable B failure state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState | Action 'MIP display segment alarm state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus | Action 'MIP display segment status'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState | Action 'MIP LU tamper alarm state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus | Action 'MIP LU tamper status'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline | Action 'MIP interface offnline'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline | Action 'MIP interface online'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState | Action 'MIP PM COM failure state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState | Action 'MIP PM tamper alarm state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus | Action 'MIP PM tamper status'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface | Action 'MIP query interface'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState | Action 'MIP RM COM failure state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState | Action 'MIP RM tamper alarm state'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus | Action 'MIP RM tamper status'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor | Action 'MIP secure auxiliary sensor'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 | Action 'MIP secure TP 1'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 | Action 'MIP secure TP 2'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment | Action 'MIP secure display segment'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU | Action 'MIP secure LU'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM | Action 'MIP secure PM'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM | Action 'MIP secure RM'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl | Action 'MIP turn a relay control'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone | Action 'MIP turn relay on one zone'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable | Action 'Disable monitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable | Action 'Enable monitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged | Action 'State of a monitor group has changed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm | Action 'Move alarm to an other monitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance | Action 'Move the alarm to an other monitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted | Action 'Start of the event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped | Action 'Stopp of an event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected | Action 'MULTISCOPE connected'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed | Action 'Open MULTISCOPE connection failed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect | Action 'Close MULTISCOPE connection'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected | Action 'MULTISCOPE disconnected'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified | Action 'MULTISCOPE Setup changed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn | Action 'Turn on normal mode'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact | Action 'Open contact'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto | Action 'Automatic panning of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft | Action 'Pan camera to the left'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight | Action 'Pan camera to the right'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop | Action 'Stopp panning of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm | Action 'Display alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm | Action 'Send the actual alarm back in the queue and send the next to the monitors'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp | Action 'Move camera to a fix position'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear | Action 'Clear fix position of a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave | Action 'Save a fix position of a camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance | Action 'Quitting a alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG | Action 'Quit an actual alarm on a monitorgroup'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType | Action 'Quitting an alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG | Action 'Quit of all alarms on a moitor group'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster | Action 'Set new server as master'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged | Action 'Connection master was changed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource | Action 'Redirect resource.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged | Action 'Master server was changed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed | Action 'Redundant login failed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin | Action 'Redundant login successful'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest | Action 'Request to all users to perform a rescan'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient | Action 'Request to a user to perform a rescan'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile | Action 'Restore right profile of a user'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData | Action 'Output the data to a RAW- or any other serial interface'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG | Action 'Output the data to a RAW- or any other serial interface'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm | Action 'Start of a alarm of a special typ'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent | Action 'Start of event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent | Action 'Start of MULTISCOPE event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer | Action 'Start timer'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance | Action 'Stopp the event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType | Action 'Stopp the event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent | Action 'Stopp a MULTISCOPE event'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer | Action 'Stopp the timer'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest | Action 'Request to all users to perform a time synchronization'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient | Action 'Request to a user to perform a time synchronization'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime | Action 'Explizit setting of date and time'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual | Action 'Explizit setting of date and time'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient | Action 'Explizit setting of date and time'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError | Action 'System error'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged | Action 'System settings changed.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted | Action 'The system is starting.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped | Action 'The system is stopping.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning | Action 'System warning'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl | Action 'Take over camera control'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown | Action 'Incline the camera down'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop | Action 'Stopp the inclinig of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp | Action 'Incline camera up'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded | Action 'Cancel time range'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted | Action 'Start of the time range'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin | Action 'User has logged in.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed | Action 'Login failed.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout | Action 'User has logged out.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut | Action 'Clears the free text'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm | Action 'The image is disturbed.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk | Action 'The contrast is OK again.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm | Action 'The contrast is critical.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure | Action 'Sync-signal failure.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk | Action 'Sync-signal works correct again.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut | Action 'Display free text on that video output.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest | Action 'Internal action requests the threshold value of an input'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue | Action 'Internal action, return of the threshold value of an input'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode | Action 'Mode is 'Working' or 'Setup''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode | Action 'Mode of the VMD'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd | Action 'Alarm has finished.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern | Action 'External alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField | Action 'Alarm in a field'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm | Action 'Test alarm for all VMD's of one client.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset | Action 'Reset of the timers of all VMD of a client.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed | Action 'VMD armed or disarmed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture | Action 'Choose a saved picture.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect | Action 'Picture OK respective picture failure'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut | Action 'Set one picture to a common output'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput | Action 'Set a picture to an output'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm | Action 'Prealarm respective bring prealarm to end'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd | Action 'The recorder was stopped'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset | Action 'Reset of timer of the recorder of a VMD.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed | Action 'All VMD's will be armed or disarmed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed | Action 'Set the VMD armed or disarmed'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime | Action 'Set date and time of a CU.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode | Action 'Reset timers of all VMD's of a VS-40 interface'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode | Action 'Set mode of the sensor'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput | Action 'Change output settings of the sensor'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect | Action 'Sync signal and picture failure respective Sync signal OK'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm | Action 'Test alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset | Action 'Resez timer of aVMD.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode | Action 'Mode is 'Working' or 'Setup''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder | Action 'VMD Out of order'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset | Action 'Reset the VX3-system'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn | Action 'Zooming in the room'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut | Action 'Zooming out of the room.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop | Action 'Stop zooming of the camera'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData | GeViSoft Action Data
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied | StateAnswer 'Zugriff verweigert.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry | StateAnswer 'Aktions Eintrag'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry | StateAnswer 'Alarm Eintrag'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError | StateAnswer 'Fehler'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk | StateAnswer 'Befehl akzeptiert'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated | StateAnswer 'Befehl abgebrochen'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries | StateAnswer ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing | StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle | StateAnswer 'Liefert der erzeugten Handle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind | StateQuery ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList | StateQuery 'ActionList'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem | StateQuery 'GscSystem'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu | StateQuery ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu | StateQuery ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc | StateQuery ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID | StateQuery 'MG, wo Alarm praesentiert wurde'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName | StateQuery ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem | StateQuery 'MscSystem'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu | StateQuery 'Primary Key groesser gleich'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu | StateQuery 'Primary Key kleiner gleich'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc | StateQuery 'Von welchem Klient kam die Aktion'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID | StateQuery 'Von welchem Klient kam die Aktion'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName | StateQuery 'Von welchem Klient kam die Aktion'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc | StateQuery ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID | StateQuery 'Die erste MG, wo Alarm praesentiert wurde'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName | StateQuery ''
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text | StateQuery 'Begleittext'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc | StateQuery 'Beschreibung des Alarms'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID | StateQuery 'AlarmTypeID bzw. ActionCode im Bereich'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName | StateQuery 'Alarm- bzw. Aktionsname'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck | StateQuery 'Mit/ohne Bestaetigung'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation | StateQuery 'Mit/Ohne MscII Events'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit | StateQuery 'Mit/ohne Quittierung'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery | StateQuery 'Befehl abbrechen'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery | StateQuery 'Schliesst den Handle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery | StateQuery 'Startet eine Abfrage ueber die Aktionstabelle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery | StateQuery 'Startet eine Abfrage ueber die Alarmtabelle'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle | StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Aktionstabelle vor.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle | StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Alarmtabelle vor.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll | StateQuery 'Loescht alle passenden Eintraege in der Aktions- bzw. Alarmtabelle. Kann nur in Verbindung mit den entspraechenden CreateDelete...Handle verwendet werden.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get | StateQuery 'Liefert den Eintrag anhand von PK'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst | StateQuery 'Liefert den ersten Eintrag'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast | StateQuery 'Liefert den letzten Eintrag'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext | StateQuery 'Liefert den naechsten Eintrag'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev | StateQuery 'Liefert den vorgehenden Eintrag'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo | StateAnswer 'Info zum Alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo | StateAnswer 'AlarmOnMG info'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo | StateAnswer 'Information zu dem Klient'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo | StateAnswer 'Information zu dem Klient'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed | StateAnswer 'Befehl fehlgeschlagen.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk | StateAnswer 'Befehl ausgefuehrt.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState | StateAnswer 'ContrastState Info'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime | StateAnswer 'Datenbankzeit'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime | StateAnswer 'Serverstartzeit'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo | StateAnswer 'Info zu einem Eingangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall | StateAnswer 'Interne Abfrage'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo | StateAnswer 'Lizenzinformation'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData | StateAnswer 'Interne Abfrage'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue | StateAnswer 'Wert des bestimmten Eintrags'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo | StateAnswer 'Info zu einer MG'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing | StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo | StateAnswer 'Info zu einem Ausgangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo | StateAnswer 'S/N Info'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState | StateAnswer 'SyncState Info'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated | StateAnswer 'Die Anfrage oder Befehl wurde terminiert.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo | StateAnswer 'Gerade gemessener Schwellenwert'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand | StateAnswer 'Befehl nicht verstanden.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights | StateAnswer 'Die Rechte sind nicht ausreichend.'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo | StateAnswer 'Info zu einem VideoEingang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo | StateAnswer 'Info zu einem Videoausgang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo | StateAnswer 'VideoSensor Info'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex | StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo | StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms | StateQuery 'Liefert die Information zum bestimmten Alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName | StateQuery 'Liefert die Information zum bestimmten Alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient | StateQuery 'Liefert die Information zum bestimmten Klient'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName | StateQuery 'Liefert die Information zum bestimmten Klient'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState | StateQuery 'Fragt die PictureState Info ab'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm | StateQuery 'Liefert die Information zu dem ersten Alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient | StateQuery 'Liefert die Information zu dem ersten Klient'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType | StateQuery 'Liefert die Information zu dem ersten Klient dieses Typs'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact | StateQuery 'Liefert die Information zu dem ersten Eingangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient | StateQuery 'Liefert die Information zu dem ersten Eingangskontakt des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup | StateQuery 'Liefert die Information zu der ersten MG'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact | StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient | StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput | StateQuery 'Liefert die Information zu dem ersten VideoEingang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient | StateQuery 'Liefert die Information zu dem ersten VideoEingang des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput | StateQuery 'Liefert die Information zu dem ersten Videoausgang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient | StateQuery 'Liefert die Information zu dem ersten Videoausgang des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime | StateQuery 'Liefert die Datenbankzeit zurueck'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime | StateQuery 'Liefert die Serverstartzeit zurueck'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact | StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName | StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo | StateQuery 'Liefert die Lizenzinformation zurueck'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue | StateQuery 'Liefert den Wert eines bestimmten Eintrags zurueck'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo | StateQuery 'Login Information zu dem Klient'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup | StateQuery 'Liefert die Information zur bestimmten MG'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName | StateQuery 'Liefert die Information zur bestimmten MG'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm | StateQuery 'Liefert die Information zu dem naechsten Alarm'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient | StateQuery 'Liefert die Information zu dem naechsten Klient'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType | StateQuery 'Liefert die Information zu dem naechsten Klient des angegeben Typs'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact | StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient | StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup | StateQuery 'Liefert die Information zu der naechsten MG'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact | StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient | StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput | StateQuery 'Liefert die Information zu dem naechsten VideoEingang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient | StateQuery 'Liefert die Information zu dem neachsten VideoEingang des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput | StateQuery 'Liefert die Information zu dem naechsten Videoausgang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient | StateQuery 'Liefert die Information zu dem naechsten Videoausgang des Clients'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact | StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName | StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo | StateQuery 'Fragt die S/N Info ab'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState | StateQuery 'Fragt die SyncState Info ab'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue | StateQuery 'Liefert die Information zu dem lokalen Videoeingangs eines VSM'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput | StateQuery 'Liefert die Information zum bestimmten VideoEingang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName | StateQuery 'Liefert die Information zum bestimmten VideoEingang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput | StateQuery 'Liefert die Information zum bestimmten Videoausgang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName | StateQuery 'Liefert die Information zum bestimmten Videoausgang'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo | StateQuery 'Fragt die Info zum VideoSensor ab'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall | StateQuery 'Interne Abfrage'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall | StateQuery 'Interne Abfrage'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData | StateQuery 'Interne Abfrage'
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime |
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions Class Reference

  • Class Hierarchy
  • Class Members
  • GEUTEBRUECK
  • GeViSoftSDKNET
  • ActionsWrapper
  • DBIHelperFunctions
Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions Class Reference
Database Functions

List of all members.

Static Public Member Functions

static String^ EncodePassword (String^ passwordStr)
Encodes the plain text password.

Member Function Documentation

String DBIHelperFunctions::EncodePassword ( String^ passwordStr ) [static]

Encodes the plain text password.

Parameters:
passwordStr Plaintext password string.
Returns:
the encoded password string.
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance Class Reference

  • GeViSoftSDKNET
  • ActionsWrapper
  • AlarmControlActions
  • GeViAct_AckAlarmByInstance
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance Class Reference
Actions

Action 'Acknowledgement of the alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance:
[legend]

List of all members.

Public Member Functions

GeViAct_AckAlarmByInstance (GeViClientID initClientID, GeViAlarmID initAlarmID, String^ initAlarmText)
Create the action 'Acknowledgement of the alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AckAlarmByInstance^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description text.

Detailed Description

Action 'Acknowledgement of the alarm'.

Constructor & Destructor Documentation

GeViAct_AckAlarmByInstance::GeViAct_AckAlarmByInstance | ( | GeViClientID | initClientID,
 |  | GeViAlarmID | initAlarmID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Acknowledgement of the alarm'.

Parameters:
initClientID | Automatic insert of the acknowledging user
initAlarmID | Instance ID of the alarm
initAlarmText | Description text

Member Function Documentation

GeViAct_AckAlarmByInstance GeViAct_AckAlarmByInstance::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AckAlarmByInstance::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance::aAlarmText

Description text.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance::aClientID

Automatic insert of the acknowledging user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AckAlarmByInstanceEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AckAlarmByInstanceEventArgs (GeViAct_AckAlarmByInstance^ initAction)
Create the EventArgs for handler of action 'Acknowledgement of the alarm'.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description text.

Private Member Functions

GeViAct_AckAlarmByInstanceEventArgs ()

Detailed Description

EventArgs for handler of action 'Acknowledgement of the alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs::GeViAct_AckAlarmByInstanceEventArgs ( ) [private]
GeViAct_AckAlarmByInstanceEventArgs::GeViAct_AckAlarmByInstanceEventArgs ( GeViAct_AckAlarmByInstance^ initAction )

Create the EventArgs for handler of action 'Acknowledgement of the alarm'.

Parameters:
initAction Managed action 'Acknowledgement of the alarm'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs::aAlarmText

Description text.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs::aClientID

Automatic insert of the acknowledging user.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG Class Reference

  • AlarmControlActions
  • GeViAct_AckAlarmByMG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG Class Reference
Actions

Action 'Acknowledge of the actual alarm on a moitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG:
[legend]

List of all members.

Public Member Functions

GeViAct_AckAlarmByMG (GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText)
Create the action 'Acknowledge of the actual alarm on a moitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AckAlarmByMG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Detailed Description

Action 'Acknowledge of the actual alarm on a moitor group'.

Constructor & Destructor Documentation

GeViAct_AckAlarmByMG::GeViAct_AckAlarmByMG | ( | GeViClientID | initClientID,
 |  | GeViMGID | initMGID,
 |  | String^ | initMGName,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Acknowledge of the actual alarm on a moitor group'.

Parameters:
initClientID | Automatic insert of the acknowledging user
initMGID | ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
initMGName | Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
initAlarmText | Description

Member Function Documentation

GeViAct_AckAlarmByMG GeViAct_AckAlarmByMG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AckAlarmByMG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG::aClientID

Automatic insert of the acknowledging user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AckAlarmByMGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AckAlarmByMGEventArgs (GeViAct_AckAlarmByMG^ initAction)
Create the EventArgs for handler of action 'Acknowledge of the actual alarm on a moitor group'.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_AckAlarmByMGEventArgs ()

Detailed Description

EventArgs for handler of action 'Acknowledge of the actual alarm on a moitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs::GeViAct_AckAlarmByMGEventArgs ( ) [private]
GeViAct_AckAlarmByMGEventArgs::GeViAct_AckAlarmByMGEventArgs ( GeViAct_AckAlarmByMG^ initAction )

Create the EventArgs for handler of action 'Acknowledge of the actual alarm on a moitor group'.

Parameters:
initAction Managed action 'Acknowledge of the actual alarm on a moitor group'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs::aClientID

Automatic insert of the acknowledging user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType Class Reference

  • AlarmControlActions
  • GeViAct_AckAlarmByType
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType Class Reference
Actions

Action 'Acknowledge the alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType:
[legend]

List of all members.

Public Member Functions

GeViAct_AckAlarmByType (GeViClientID initClientID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, String^ initAlarmText)
Create the action 'Acknowledge the alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AckAlarmByType^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type, it is only used for the search, if name is empty.
String^ | aAlarmType
Name of alarm type (mean criterion)
String^ | aAlarmText
Description text.

Detailed Description

Action 'Acknowledge the alarm'.

Constructor & Destructor Documentation

GeViAct_AckAlarmByType::GeViAct_AckAlarmByType | ( | GeViClientID | initClientID,
 |  | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Acknowledge the alarm'.

Parameters:
initClientID | Automatic insert of the acknowledging user
initAlarmTypeID | ID of the alarm type, it is only used for the search, if name is empty
initAlarmType | Name of alarm type (mean criterion)
initAlarmText | Description text

Member Function Documentation

GeViAct_AckAlarmByType GeViAct_AckAlarmByType::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AckAlarmByType::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType::aAlarmText

Description text.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType::aAlarmType

Name of alarm type (mean criterion)

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType::aAlarmTypeID

ID of the alarm type, it is only used for the search, if name is empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType::aClientID

Automatic insert of the acknowledging user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AckAlarmByTypeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AckAlarmByTypeEventArgs (GeViAct_AckAlarmByType^ initAction)
Create the EventArgs for handler of action 'Acknowledge the alarm'.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type, it is only used for the search, if name is empty.
String^ | aAlarmType
Name of alarm type (mean criterion)
String^ | aAlarmText
Description text.

Private Member Functions

GeViAct_AckAlarmByTypeEventArgs ()

Detailed Description

EventArgs for handler of action 'Acknowledge the alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs::GeViAct_AckAlarmByTypeEventArgs ( ) [private]
GeViAct_AckAlarmByTypeEventArgs::GeViAct_AckAlarmByTypeEventArgs ( GeViAct_AckAlarmByType^ initAction )

Create the EventArgs for handler of action 'Acknowledge the alarm'.

Parameters:
initAction Managed action 'Acknowledge the alarm'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs::aAlarmText

Description text.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs::aAlarmType

Name of alarm type (mean criterion)

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs::aAlarmTypeID

ID of the alarm type, it is only used for the search, if name is empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs::aClientID

Automatic insert of the acknowledging user.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG Class Reference

  • AlarmControlActions
  • GeViAct_AckAllAlarmsOnMG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG Class Reference
Actions

Action 'Acknowledge of all alarms on a moitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG:
[legend]

List of all members.

Public Member Functions

GeViAct_AckAllAlarmsOnMG (GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText)
Create the action 'Acknowledge of all alarms on a moitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AckAllAlarmsOnMG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Detailed Description

Action 'Acknowledge of all alarms on a moitor group'.

Constructor & Destructor Documentation

GeViAct_AckAllAlarmsOnMG::GeViAct_AckAllAlarmsOnMG | ( | GeViClientID | initClientID,
 |  | GeViMGID | initMGID,
 |  | String^ | initMGName,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Acknowledge of all alarms on a moitor group'.

Parameters:
initClientID | Automatic insert of the acknowledging user
initMGID | ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
initMGName | Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
initAlarmText | Description

Member Function Documentation

GeViAct_AckAllAlarmsOnMG GeViAct_AckAllAlarmsOnMG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AckAllAlarmsOnMG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG::aClientID

Automatic insert of the acknowledging user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AckAllAlarmsOnMGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AckAllAlarmsOnMGEventArgs (GeViAct_AckAllAlarmsOnMG^ initAction)
Create the EventArgs for handler of action 'Acknowledge of all alarms on a moitor group'.

Properties

GeViClientID | aClientID
Automatic insert of the acknowledging user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_AckAllAlarmsOnMGEventArgs ()

Detailed Description

EventArgs for handler of action 'Acknowledge of all alarms on a moitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs::GeViAct_AckAllAlarmsOnMGEventArgs ( ) [private]
GeViAct_AckAllAlarmsOnMGEventArgs::GeViAct_AckAllAlarmsOnMGEventArgs ( GeViAct_AckAllAlarmsOnMG^ initAction )

Create the EventArgs for handler of action 'Acknowledge of all alarms on a moitor group'.

Parameters:
initAction Managed action 'Acknowledge of all alarms on a moitor group'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs::aClientID

Automatic insert of the acknowledging user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName Class Reference

  • SystemActions
  • GeViAct_ActionByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName Class Reference
Actions

Action 'Execution of a named action'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName:
[legend]

List of all members.

Public Member Functions

GeViAct_ActionByName (String^ initActionName)
Create the action 'Execution of a named action'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_ActionByName^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aActionName
Name of the action.

Detailed Description

Action 'Execution of a named action'.

Constructor & Destructor Documentation

GeViAct_ActionByName::GeViAct_ActionByName ( String^ initActionName )

Create the action 'Execution of a named action'.

Parameters:
initActionName Name of the action

Member Function Documentation

GeViAct_ActionByName GeViAct_ActionByName::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ActionByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName::aActionName

Name of the action.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ActionByNameEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ActionByNameEventArgs (GeViAct_ActionByName^ initAction)
Create the EventArgs for handler of action 'Execution of a named action'.

Properties

String^ aActionName
Name of the action.

Private Member Functions

GeViAct_ActionByNameEventArgs ()

Detailed Description

EventArgs for handler of action 'Execution of a named action'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs::GeViAct_ActionByNameEventArgs ( ) [private]
GeViAct_ActionByNameEventArgs::GeViAct_ActionByNameEventArgs ( GeViAct_ActionByName^ initAction )

Create the EventArgs for handler of action 'Execution of a named action'.

Parameters:
initAction Managed action 'Execution of a named action'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs::aActionName

Name of the action.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt Class Reference

  • SystemActions
  • GeViAct_ActionDataCorrupt
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt Class Reference
Actions

Action 'The action data can not be found in the data base.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt:
[legend]

List of all members.

Public Member Functions

GeViAct_ActionDataCorrupt ()
Create the action 'The action data can not be found in the data base.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_ActionDataCorrupt^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Detailed Description

Action 'The action data can not be found in the data base.'.

Constructor & Destructor Documentation

GeViAct_ActionDataCorrupt::GeViAct_ActionDataCorrupt ( )

Create the action 'The action data can not be found in the data base.'.

Member Function Documentation

GeViAct_ActionDataCorrupt GeViAct_ActionDataCorrupt::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ActionDataCorrupt::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ActionDataCorruptEventArgs
Public Member Functions | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ActionDataCorruptEventArgs (GeViAct_ActionDataCorrupt^ initAction)
Create the EventArgs for handler of action 'The action data can not be found in the data base.'.

Private Member Functions

GeViAct_ActionDataCorruptEventArgs ()

Detailed Description

EventArgs for handler of action 'The action data can not be found in the data base.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs::GeViAct_ActionDataCorruptEventArgs ( ) [private]
GeViAct_ActionDataCorruptEventArgs::GeViAct_ActionDataCorruptEventArgs ( GeViAct_ActionDataCorrupt^ initAction )

Create the EventArgs for handler of action 'The action data can not be found in the data base.'.

Parameters:
initAction Managed action 'The action data can not be found in the data base.'.
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile Class Reference

  • SystemActions
  • GeViAct_ActivateAssignmentProfile
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile Class Reference
Actions

Action 'Activate state profile'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile:
[legend]

List of all members.

Public Member Functions

GeViAct_ActivateAssignmentProfile (Int32 initProfileID, String^ initProfileName)
Create the action 'Activate state profile'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_ActivateAssignmentProfile^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aProfileID
ID of the profile, if there is no name for it.
String^ | aProfileName
Name of the profile or empty.

Detailed Description

Action 'Activate state profile'.

Constructor & Destructor Documentation

GeViAct_ActivateAssignmentProfile::GeViAct_ActivateAssignmentProfile | ( | Int32 | initProfileID,
 |  | String^ | initProfileName
 | ) |  |

Create the action 'Activate state profile'.

Parameters:
initProfileID | ID of the profile, if there is no name for it
initProfileName | Name of the profile or empty

Member Function Documentation

GeViAct_ActivateAssignmentProfile GeViAct_ActivateAssignmentProfile::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ActivateAssignmentProfile::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile::aProfileID

ID of the profile, if there is no name for it.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile::aProfileName

Name of the profile or empty.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ActivateAssignmentProfileEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ActivateAssignmentProfileEventArgs (GeViAct_ActivateAssignmentProfile^ initAction)
Create the EventArgs for handler of action 'Activate state profile'.

Properties

Int32 | aProfileID
ID of the profile, if there is no name for it.
String^ | aProfileName
Name of the profile or empty.

Private Member Functions

GeViAct_ActivateAssignmentProfileEventArgs ()

Detailed Description

EventArgs for handler of action 'Activate state profile'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs::GeViAct_ActivateAssignmentProfileEventArgs ( ) [private]
GeViAct_ActivateAssignmentProfileEventArgs::GeViAct_ActivateAssignmentProfileEventArgs ( GeViAct_ActivateAssignmentProfile^ initAction )

Create the EventArgs for handler of action 'Activate state profile'.

Parameters:
initAction Managed action 'Activate state profile'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs::aProfileID

ID of the profile, if there is no name for it.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs::aProfileName

Name of the profile or empty.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked Class Reference

  • AlarmControlActions
  • GeViAct_AlarmAcked
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked Class Reference
Actions

Action 'Alarm was acknowledged'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked:
[legend]

List of all members.

Public Member Functions

GeViAct_AlarmAcked (GeViClientID initClientID, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViMGID initMGID, String^ initAlarmText)
Create the action 'Alarm was acknowledged'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlarmAcked^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of acknowledging user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
GeViMGID | aMGID
ID of the monitor group, on which the alarm shall be displayed. (possibly only the first MG)
String^ | aAlarmText
Description text for acknowledgement.

Detailed Description

Action 'Alarm was acknowledged'.

Constructor & Destructor Documentation

GeViAct_AlarmAcked::GeViAct_AlarmAcked | ( | GeViClientID | initClientID,
 |  | GeViAlarmID | initAlarmID,
 |  | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | GeViMGID | initMGID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Alarm was acknowledged'.

Parameters:
initClientID | ID of acknowledging user
initAlarmID | Instance ID of the alarm
initAlarmTypeID | ID of the alarm type
initAlarmType | Name of the alarm type
initMGID | ID of the monitor group, on which the alarm shall be displayed. (possibly only the first MG)
initAlarmText | Description text for acknowledgement

Member Function Documentation

GeViAct_AlarmAcked GeViAct_AlarmAcked::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlarmAcked::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked::aAlarmText

Description text for acknowledgement.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked::aAlarmTypeID

ID of the alarm type.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked::aClientID

ID of acknowledging user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked::aMGID

ID of the monitor group, on which the alarm shall be displayed. (possibly only the first MG)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlarmAckedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlarmAckedEventArgs (GeViAct_AlarmAcked^ initAction)
Create the EventArgs for handler of action 'Alarm was acknowledged'.

Properties

GeViClientID | aClientID
ID of acknowledging user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
GeViMGID | aMGID
ID of the monitor group, on which the alarm shall be displayed. (possibly only the first MG)
String^ | aAlarmText
Description text for acknowledgement.

Private Member Functions

GeViAct_AlarmAckedEventArgs ()

Detailed Description

EventArgs for handler of action 'Alarm was acknowledged'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs::GeViAct_AlarmAckedEventArgs ( ) [private]
GeViAct_AlarmAckedEventArgs::GeViAct_AlarmAckedEventArgs ( GeViAct_AlarmAcked^ initAction )

Create the EventArgs for handler of action 'Alarm was acknowledged'.

Parameters:
initAction Managed action 'Alarm was acknowledged'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs::aAlarmText

Description text for acknowledgement.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs::aAlarmTypeID

ID of the alarm type.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs::aClientID

ID of acknowledging user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs::aMGID

ID of the monitor group, on which the alarm shall be displayed. (possibly only the first MG)

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied Class Reference

  • AlarmControlActions
  • GeViAct_AlarmCopied
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied Class Reference
Actions

Action 'An alarm was copied from one monitor group to an other'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied:
[legend]

List of all members.

Public Member Functions

GeViAct_AlarmCopied (GeViAlarmID initAlarmID, GeViMGID initMGFrom, GeViMGID initMGTo)
Create the action 'An alarm was copied from one monitor group to an other'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlarmCopied^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViMGID | aMGFrom
From which monitor group (ID)
GeViMGID | aMGTo
To which monitor group (ID)

Detailed Description

Action 'An alarm was copied from one monitor group to an other'.

Constructor & Destructor Documentation

GeViAct_AlarmCopied::GeViAct_AlarmCopied | ( | GeViAlarmID | initAlarmID,
 |  | GeViMGID | initMGFrom,
 |  | GeViMGID | initMGTo
 | ) |  |

Create the action 'An alarm was copied from one monitor group to an other'.

Parameters:
initAlarmID | Instance ID of the alarm
initMGFrom | From which monitor group (ID)
initMGTo | To which monitor group (ID)

Member Function Documentation

GeViAct_AlarmCopied GeViAct_AlarmCopied::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlarmCopied::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied::aAlarmID

Instance ID of the alarm.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied::aMGFrom

From which monitor group (ID)

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied::aMGTo

To which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlarmCopiedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlarmCopiedEventArgs (GeViAct_AlarmCopied^ initAction)
Create the EventArgs for handler of action 'An alarm was copied from one monitor group to an other'.

Properties

GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViMGID | aMGFrom
From which monitor group (ID)
GeViMGID | aMGTo
To which monitor group (ID)

Private Member Functions

GeViAct_AlarmCopiedEventArgs ()

Detailed Description

EventArgs for handler of action 'An alarm was copied from one monitor group to an other'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs::GeViAct_AlarmCopiedEventArgs ( ) [private]
GeViAct_AlarmCopiedEventArgs::GeViAct_AlarmCopiedEventArgs ( GeViAct_AlarmCopied^ initAction )

Create the EventArgs for handler of action 'An alarm was copied from one monitor group to an other'.

Parameters:
initAction Managed action 'An alarm was copied from one monitor group to an other'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs::aAlarmID

Instance ID of the alarm.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs::aMGFrom

From which monitor group (ID)

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs::aMGTo

To which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed Class Reference

  • AlarmControlActions
  • GeViAct_AlarmDisplayed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed Class Reference
Actions

Action 'Trigger by the display of the alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed:
[legend]

List of all members.

Public Member Functions

GeViAct_AlarmDisplayed (GeViMGID initMonitorGroup, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, Boolean initFirstTime, Boolean initOtherCleared)
Create the action 'Trigger by the display of the alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlarmDisplayed^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aMonitorGroup
To which monitor group.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
Boolean | aFirstTime
true = The first time on this MG?; false = repeated
Boolean | aOtherCleared
true = The other alarms on that MG have been cleared (no filling mode)

Detailed Description

Action 'Trigger by the display of the alarm'.

Constructor & Destructor Documentation

GeViAct_AlarmDisplayed::GeViAct_AlarmDisplayed | ( | GeViMGID | initMonitorGroup,
 |  | GeViAlarmID | initAlarmID,
 |  | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | Boolean | initFirstTime,
 |  | Boolean | initOtherCleared
 | ) |  |

Create the action 'Trigger by the display of the alarm'.

Parameters:
initMonitorGroup | To which monitor group
initAlarmID | Instance ID of the alarm
initAlarmTypeID | ID of the alarm type
initAlarmType | Name of the alarm type
initFirstTime | true = The first time on this MG?; false = repeated
initOtherCleared | true = The other alarms on that MG have been cleared (no filling mode)

Member Function Documentation

GeViAct_AlarmDisplayed GeViAct_AlarmDisplayed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlarmDisplayed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed::aAlarmTypeID

ID of the alarm type.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed::aFirstTime

true = The first time on this MG?; false = repeated

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed::aMonitorGroup

To which monitor group.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed::aOtherCleared

true = The other alarms on that MG have been cleared (no filling mode)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlarmDisplayedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlarmDisplayedEventArgs (GeViAct_AlarmDisplayed^ initAction)
Create the EventArgs for handler of action 'Trigger by the display of the alarm'.

Properties

GeViMGID | aMonitorGroup
To which monitor group.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
Boolean | aFirstTime
true = The first time on this MG?; false = repeated
Boolean | aOtherCleared
true = The other alarms on that MG have been cleared (no filling mode)

Private Member Functions

GeViAct_AlarmDisplayedEventArgs ()

Detailed Description

EventArgs for handler of action 'Trigger by the display of the alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs::GeViAct_AlarmDisplayedEventArgs ( ) [private]
GeViAct_AlarmDisplayedEventArgs::GeViAct_AlarmDisplayedEventArgs ( GeViAct_AlarmDisplayed^ initAction )

Create the EventArgs for handler of action 'Trigger by the display of the alarm'.

Parameters:
initAction Managed action 'Trigger by the display of the alarm'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs::aAlarmTypeID

ID of the alarm type.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs::aFirstTime

true = The first time on this MG?; false = repeated

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs::aMonitorGroup

To which monitor group.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs::aOtherCleared

true = The other alarms on that MG have been cleared (no filling mode)

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved Class Reference

  • AlarmControlActions
  • GeViAct_AlarmMoved
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved Class Reference
Actions

Action 'An alarm was moved from one monitor group to an other.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved:
[legend]

List of all members.

Public Member Functions

GeViAct_AlarmMoved (GeViAlarmID initAlarmID, GeViMGID initMGFrom, GeViMGID initMGTo)
Create the action 'An alarm was moved from one monitor group to an other.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlarmMoved^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViMGID | aMGFrom
From which monitor group (ID)
GeViMGID | aMGTo
To which monitor group (ID)

Detailed Description

Action 'An alarm was moved from one monitor group to an other.'.

Constructor & Destructor Documentation

GeViAct_AlarmMoved::GeViAct_AlarmMoved | ( | GeViAlarmID | initAlarmID,
 |  | GeViMGID | initMGFrom,
 |  | GeViMGID | initMGTo
 | ) |  |

Create the action 'An alarm was moved from one monitor group to an other.'.

Parameters:
initAlarmID | Instance ID of the alarm
initMGFrom | From which monitor group (ID)
initMGTo | To which monitor group (ID)

Member Function Documentation

GeViAct_AlarmMoved GeViAct_AlarmMoved::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlarmMoved::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved::aAlarmID

Instance ID of the alarm.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved::aMGFrom

From which monitor group (ID)

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved::aMGTo

To which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlarmMovedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlarmMovedEventArgs (GeViAct_AlarmMoved^ initAction)
Create the EventArgs for handler of action 'An alarm was moved from one monitor group to an other.'.

Properties

GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViMGID | aMGFrom
From which monitor group (ID)
GeViMGID | aMGTo
To which monitor group (ID)

Private Member Functions

GeViAct_AlarmMovedEventArgs ()

Detailed Description

EventArgs for handler of action 'An alarm was moved from one monitor group to an other.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs::GeViAct_AlarmMovedEventArgs ( ) [private]
GeViAct_AlarmMovedEventArgs::GeViAct_AlarmMovedEventArgs ( GeViAct_AlarmMoved^ initAction )

Create the EventArgs for handler of action 'An alarm was moved from one monitor group to an other.'.

Parameters:
initAction Managed action 'An alarm was moved from one monitor group to an other.'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs::aAlarmID

Instance ID of the alarm.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs::aMGFrom

From which monitor group (ID)

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs::aMGTo

To which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted Class Reference

  • AlarmControlActions
  • GeViAct_AlarmQuitted
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted Class Reference
Actions

Action 'Alarm was quitted'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted:
[legend]

List of all members.

Public Member Functions

GeViAct_AlarmQuitted (GeViClientID initClientID, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViMGID initMGID, String^ initAlarmText)
Create the action 'Alarm was quitted'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlarmQuitted^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of the quitting user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
GeViMGID | aMGID
ID of the monitor group, on which the alarm shall be displayed.
String^ | aAlarmText
Description text for quiting.

Detailed Description

Action 'Alarm was quitted'.

Constructor & Destructor Documentation

GeViAct_AlarmQuitted::GeViAct_AlarmQuitted | ( | GeViClientID | initClientID,
 |  | GeViAlarmID | initAlarmID,
 |  | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | GeViMGID | initMGID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Alarm was quitted'.

Parameters:
initClientID | ID of the quitting user
initAlarmID | Instance ID of the alarm
initAlarmTypeID | ID of the alarm type
initAlarmType | Name of the alarm type
initMGID | ID of the monitor group, on which the alarm shall be displayed.
initAlarmText | Description text for quiting

Member Function Documentation

GeViAct_AlarmQuitted GeViAct_AlarmQuitted::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlarmQuitted::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted::aAlarmText

Description text for quiting.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted::aAlarmTypeID

ID of the alarm type.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted::aClientID

ID of the quitting user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted::aMGID

ID of the monitor group, on which the alarm shall be displayed.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlarmQuittedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlarmQuittedEventArgs (GeViAct_AlarmQuitted^ initAction)
Create the EventArgs for handler of action 'Alarm was quitted'.

Properties

GeViClientID | aClientID
ID of the quitting user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
GeViMGID | aMGID
ID of the monitor group, on which the alarm shall be displayed.
String^ | aAlarmText
Description text for quiting.

Private Member Functions

GeViAct_AlarmQuittedEventArgs ()

Detailed Description

EventArgs for handler of action 'Alarm was quitted'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs::GeViAct_AlarmQuittedEventArgs ( ) [private]
GeViAct_AlarmQuittedEventArgs::GeViAct_AlarmQuittedEventArgs ( GeViAct_AlarmQuitted^ initAction )

Create the EventArgs for handler of action 'Alarm was quitted'.

Parameters:
initAction Managed action 'Alarm was quitted'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs::aAlarmText

Description text for quiting.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs::aAlarmTypeID

ID of the alarm type.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs::aClientID

ID of the quitting user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs::aMGID

ID of the monitor group, on which the alarm shall be displayed.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered Class Reference

  • AlarmControlActions
  • GeViAct_AlarmRetriggered
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered Class Reference
Actions

Action 'Alarm was restarted (retriggered)'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered:
[legend]

List of all members.

Public Member Functions

GeViAct_AlarmRetriggered (GeViAlarmID initAlarmID, Boolean initAckCleared)
Create the action 'Alarm was restarted (retriggered)'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlarmRetriggered^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViAlarmID | aAlarmID
Instance ID of the alarm.
Boolean | aAckCleared
true = An acknowledgement was revoked

Detailed Description

Action 'Alarm was restarted (retriggered)'.

Constructor & Destructor Documentation

GeViAct_AlarmRetriggered::GeViAct_AlarmRetriggered | ( | GeViAlarmID | initAlarmID,
 |  | Boolean | initAckCleared
 | ) |  |

Create the action 'Alarm was restarted (retriggered)'.

Parameters:
initAlarmID | Instance ID of the alarm
initAckCleared | true = An acknowledgement was revoked

Member Function Documentation

GeViAct_AlarmRetriggered GeViAct_AlarmRetriggered::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlarmRetriggered::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered::aAckCleared

true = An acknowledgement was revoked

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered::aAlarmID

Instance ID of the alarm.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlarmRetriggeredEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlarmRetriggeredEventArgs (GeViAct_AlarmRetriggered^ initAction)
Create the EventArgs for handler of action 'Alarm was restarted (retriggered)'.

Properties

GeViAlarmID | aAlarmID
Instance ID of the alarm.
Boolean | aAckCleared
true = An acknowledgement was revoked

Private Member Functions

GeViAct_AlarmRetriggeredEventArgs ()

Detailed Description

EventArgs for handler of action 'Alarm was restarted (retriggered)'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs::GeViAct_AlarmRetriggeredEventArgs ( ) [private]
GeViAct_AlarmRetriggeredEventArgs::GeViAct_AlarmRetriggeredEventArgs ( GeViAct_AlarmRetriggered^ initAction )

Create the EventArgs for handler of action 'Alarm was restarted (retriggered)'.

Parameters:
initAction Managed action 'Alarm was restarted (retriggered)'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs::aAckCleared

true = An acknowledgement was revoked

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs::aAlarmID

Instance ID of the alarm.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted Class Reference

  • AlarmControlActions
  • GeViAct_AlarmStarted
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted Class Reference
Actions

Action 'Alarm was started'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted:
[legend]

List of all members.

Public Member Functions

GeViAct_AlarmStarted (GeViClientID initClientID, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViMGID initMGID, String^ initAlarmText)
Create the action 'Alarm was started'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlarmStarted^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of the sender.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
GeViMGID | aMGID
ID of the monitor group, on which the alarm shall be displayed.
String^ | aAlarmText
Description.

Detailed Description

Action 'Alarm was started'.

Constructor & Destructor Documentation

GeViAct_AlarmStarted::GeViAct_AlarmStarted | ( | GeViClientID | initClientID,
 |  | GeViAlarmID | initAlarmID,
 |  | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | GeViMGID | initMGID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Alarm was started'.

Parameters:
initClientID | ID of the sender
initAlarmID | Instance ID of the alarm
initAlarmTypeID | ID of the alarm type
initAlarmType | Name of the alarm type
initMGID | ID of the monitor group, on which the alarm shall be displayed.
initAlarmText | Description

Member Function Documentation

GeViAct_AlarmStarted GeViAct_AlarmStarted::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlarmStarted::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted::aAlarmText

Description.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted::aAlarmTypeID

ID of the alarm type.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted::aClientID

ID of the sender.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted::aMGID

ID of the monitor group, on which the alarm shall be displayed.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlarmStartedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlarmStartedEventArgs (GeViAct_AlarmStarted^ initAction)
Create the EventArgs for handler of action 'Alarm was started'.

Properties

GeViClientID | aClientID
ID of the sender.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of the alarm type.
GeViMGID | aMGID
ID of the monitor group, on which the alarm shall be displayed.
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_AlarmStartedEventArgs ()

Detailed Description

EventArgs for handler of action 'Alarm was started'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs::GeViAct_AlarmStartedEventArgs ( ) [private]
GeViAct_AlarmStartedEventArgs::GeViAct_AlarmStartedEventArgs ( GeViAct_AlarmStarted^ initAction )

Create the EventArgs for handler of action 'Alarm was started'.

Parameters:
initAction Managed action 'Alarm was started'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs::aAlarmText

Description.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs::aAlarmTypeID

ID of the alarm type.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs::aClientID

ID of the sender.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs::aMGID

ID of the monitor group, on which the alarm shall be displayed.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact Class Reference

  • ContactBusActions
  • GeViAct_AlternateContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact Class Reference
Actions

Action 'Flash contact'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact:
[legend]

List of all members.

Public Member Functions

GeViAct_AlternateContact (Int32 initGlobalContactID, Int32 initBlinkPeriod, Int32 initBlinkOnTime)
Create the action 'Flash contact'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_AlternateContact^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aGlobalContactID
Global ID of the contact.
Int32 | aBlinkPeriod
Flashing period in milliseconds.
Int32 | aBlinkOnTime
Duration of the flash in milliseconds.

Detailed Description

Action 'Flash contact'.

Constructor & Destructor Documentation

GeViAct_AlternateContact::GeViAct_AlternateContact | ( | Int32 | initGlobalContactID,
 |  | Int32 | initBlinkPeriod,
 |  | Int32 | initBlinkOnTime
 | ) |  |

Create the action 'Flash contact'.

Parameters:
initGlobalContactID | Global ID of the contact
initBlinkPeriod | Flashing period in milliseconds
initBlinkOnTime | Duration of the flash in milliseconds

Member Function Documentation

GeViAct_AlternateContact GeViAct_AlternateContact::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_AlternateContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact::aBlinkOnTime

Duration of the flash in milliseconds.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact::aBlinkPeriod

Flashing period in milliseconds.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact::aGlobalContactID

Global ID of the contact.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_AlternateContactEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_AlternateContactEventArgs (GeViAct_AlternateContact^ initAction)
Create the EventArgs for handler of action 'Flash contact'.

Properties

Int32 | aGlobalContactID
Global ID of the contact.
Int32 | aBlinkPeriod
Flashing period in milliseconds.
Int32 | aBlinkOnTime
Duration of the flash in milliseconds.

Private Member Functions

GeViAct_AlternateContactEventArgs ()

Detailed Description

EventArgs for handler of action 'Flash contact'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs::GeViAct_AlternateContactEventArgs ( ) [private]
GeViAct_AlternateContactEventArgs::GeViAct_AlternateContactEventArgs ( GeViAct_AlternateContact^ initAction )

Create the EventArgs for handler of action 'Flash contact'.

Parameters:
initAction Managed action 'Flash contact'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs::aBlinkOnTime

Duration of the flash in milliseconds.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs::aBlinkPeriod

Flashing period in milliseconds.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs::aGlobalContactID

Global ID of the contact.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff Class Reference

  • CameraControlActions
  • GeViAct_CameraAutoFocusOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff Class Reference
Actions

Action 'Turn off the auto focus of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraAutoFocusOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off the auto focus of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraAutoFocusOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.

Detailed Description

Action 'Turn off the auto focus of the camera'.

Constructor & Destructor Documentation

GeViAct_CameraAutoFocusOff::GeViAct_CameraAutoFocusOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off the auto focus of the camera'.

Parameters:
initVideoInput ID of the camera

Member Function Documentation

GeViAct_CameraAutoFocusOff GeViAct_CameraAutoFocusOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraAutoFocusOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraAutoFocusOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraAutoFocusOffEventArgs (GeViAct_CameraAutoFocusOff^ initAction)
Create the EventArgs for handler of action 'Turn off the auto focus of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera.

Private Member Functions

GeViAct_CameraAutoFocusOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the auto focus of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs::GeViAct_CameraAutoFocusOffEventArgs ( ) [private]
GeViAct_CameraAutoFocusOffEventArgs::GeViAct_CameraAutoFocusOffEventArgs ( GeViAct_CameraAutoFocusOff^ initAction )

Create the EventArgs for handler of action 'Turn off the auto focus of the camera'.

Parameters:
initAction Managed action 'Turn off the auto focus of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn Class Reference

  • CameraControlActions
  • GeViAct_CameraAutoFocusOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn Class Reference
Actions

Action 'Turn on the auto focus of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraAutoFocusOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on the auto focus of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraAutoFocusOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.

Detailed Description

Action 'Turn on the auto focus of the camera'.

Constructor & Destructor Documentation

GeViAct_CameraAutoFocusOn::GeViAct_CameraAutoFocusOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on the auto focus of the camera'.

Parameters:
initVideoInput ID of the camera

Member Function Documentation

GeViAct_CameraAutoFocusOn GeViAct_CameraAutoFocusOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraAutoFocusOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraAutoFocusOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraAutoFocusOnEventArgs (GeViAct_CameraAutoFocusOn^ initAction)
Create the EventArgs for handler of action 'Turn on the auto focus of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera.

Private Member Functions

GeViAct_CameraAutoFocusOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the auto focus of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs::GeViAct_CameraAutoFocusOnEventArgs ( ) [private]
GeViAct_CameraAutoFocusOnEventArgs::GeViAct_CameraAutoFocusOnEventArgs ( GeViAct_CameraAutoFocusOn^ initAction )

Create the EventArgs for handler of action 'Turn on the auto focus of the camera'.

Parameters:
initAction Managed action 'Turn on the auto focus of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText Class Reference

  • CameraControlActions
  • GeViAct_CameraClearPrePosText
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText Class Reference
Actions

Action 'Delete text at the predefined position'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraClearPrePosText (GeViVideoInputID initVideoInput, Int32 initPosition)
Create the action 'Delete text at the predefined position'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_CameraClearPrePosText^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which text shall be cleared.
Int32 | aPosition
ID of the fix position, which text shall be cleared (special value 63 clears the text of all positions)

Detailed Description

Action 'Delete text at the predefined position'.

Constructor & Destructor Documentation

GeViAct_CameraClearPrePosText::GeViAct_CameraClearPrePosText | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initPosition
 | ) |  |

Create the action 'Delete text at the predefined position'.

Parameters:
initVideoInput | ID of the camera, which text shall be cleared
initPosition | ID of the fix position, which text shall be cleared (special value 63 clears the text of all positions)

Member Function Documentation

GeViAct_CameraClearPrePosText GeViAct_CameraClearPrePosText::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraClearPrePosText::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText::aPosition

ID of the fix position, which text shall be cleared (special value 63 clears the text of all positions)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText::aVideoInput

ID of the camera, which text shall be cleared.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraClearPrePosTextEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraClearPrePosTextEventArgs (GeViAct_CameraClearPrePosText^ initAction)
Create the EventArgs for handler of action 'Delete text at the predefined position'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which text shall be cleared.
Int32 | aPosition
ID of the fix position, which text shall be cleared (special value 63 clears the text of all positions)

Private Member Functions

GeViAct_CameraClearPrePosTextEventArgs ()

Detailed Description

EventArgs for handler of action 'Delete text at the predefined position'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs::GeViAct_CameraClearPrePosTextEventArgs ( ) [private]
GeViAct_CameraClearPrePosTextEventArgs::GeViAct_CameraClearPrePosTextEventArgs ( GeViAct_CameraClearPrePosText^ initAction )

Create the EventArgs for handler of action 'Delete text at the predefined position'.

Parameters:
initAction Managed action 'Delete text at the predefined position'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs::aPosition

ID of the fix position, which text shall be cleared (special value 63 clears the text of all positions)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs::aVideoInput

ID of the camera, which text shall be cleared.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext Class Reference

  • CameraControlActions
  • GeViAct_CameraCycleNext
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext Class Reference
Actions

Action 'Next camera in camera cycle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraCycleNext (GeViVideoOutputID initMonitorID)
Create the action 'Next camera in camera cycle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraCycleNext^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aMonitorID
ID of the monitor.

Detailed Description

Action 'Next camera in camera cycle'.

Constructor & Destructor Documentation

GeViAct_CameraCycleNext::GeViAct_CameraCycleNext ( GeViVideoOutputID initMonitorID )

Create the action 'Next camera in camera cycle'.

Parameters:
initMonitorID ID of the monitor

Member Function Documentation

GeViAct_CameraCycleNext GeViAct_CameraCycleNext::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraCycleNext::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraCycleNextEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraCycleNextEventArgs (GeViAct_CameraCycleNext^ initAction)
Create the EventArgs for handler of action 'Next camera in camera cycle'.

Properties

GeViVideoOutputID aMonitorID
ID of the monitor.

Private Member Functions

GeViAct_CameraCycleNextEventArgs ()

Detailed Description

EventArgs for handler of action 'Next camera in camera cycle'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs::GeViAct_CameraCycleNextEventArgs ( ) [private]
GeViAct_CameraCycleNextEventArgs::GeViAct_CameraCycleNextEventArgs ( GeViAct_CameraCycleNext^ initAction )

Create the EventArgs for handler of action 'Next camera in camera cycle'.

Parameters:
initAction Managed action 'Next camera in camera cycle'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause Class Reference

  • CameraControlActions
  • GeViAct_CameraCyclePause
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause Class Reference
Actions

Action 'Pause camera cycle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraCyclePause (GeViVideoOutputID initMonitorID)
Create the action 'Pause camera cycle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraCyclePause^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aMonitorID
ID of the monitor.

Detailed Description

Action 'Pause camera cycle'.

Constructor & Destructor Documentation

GeViAct_CameraCyclePause::GeViAct_CameraCyclePause ( GeViVideoOutputID initMonitorID )

Create the action 'Pause camera cycle'.

Parameters:
initMonitorID ID of the monitor

Member Function Documentation

GeViAct_CameraCyclePause GeViAct_CameraCyclePause::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraCyclePause::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraCyclePauseEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraCyclePauseEventArgs (GeViAct_CameraCyclePause^ initAction)
Create the EventArgs for handler of action 'Pause camera cycle'.

Properties

GeViVideoOutputID aMonitorID
ID of the monitor.

Private Member Functions

GeViAct_CameraCyclePauseEventArgs ()

Detailed Description

EventArgs for handler of action 'Pause camera cycle'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs::GeViAct_CameraCyclePauseEventArgs ( ) [private]
GeViAct_CameraCyclePauseEventArgs::GeViAct_CameraCyclePauseEventArgs ( GeViAct_CameraCyclePause^ initAction )

Create the EventArgs for handler of action 'Pause camera cycle'.

Parameters:
initAction Managed action 'Pause camera cycle'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev Class Reference

  • CameraControlActions
  • GeViAct_CameraCyclePrev
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev Class Reference
Actions

Action 'Previous camera in camera cycle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraCyclePrev (GeViVideoOutputID initMonitorID)
Create the action 'Previous camera in camera cycle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraCyclePrev^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aMonitorID
ID of the monitor.

Detailed Description

Action 'Previous camera in camera cycle'.

Constructor & Destructor Documentation

GeViAct_CameraCyclePrev::GeViAct_CameraCyclePrev ( GeViVideoOutputID initMonitorID )

Create the action 'Previous camera in camera cycle'.

Parameters:
initMonitorID ID of the monitor

Member Function Documentation

GeViAct_CameraCyclePrev GeViAct_CameraCyclePrev::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraCyclePrev::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraCyclePrevEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraCyclePrevEventArgs (GeViAct_CameraCyclePrev^ initAction)
Create the EventArgs for handler of action 'Previous camera in camera cycle'.

Properties

GeViVideoOutputID aMonitorID
ID of the monitor.

Private Member Functions

GeViAct_CameraCyclePrevEventArgs ()

Detailed Description

EventArgs for handler of action 'Previous camera in camera cycle'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs::GeViAct_CameraCyclePrevEventArgs ( ) [private]
GeViAct_CameraCyclePrevEventArgs::GeViAct_CameraCyclePrevEventArgs ( GeViAct_CameraCyclePrev^ initAction )

Create the EventArgs for handler of action 'Previous camera in camera cycle'.

Parameters:
initAction Managed action 'Previous camera in camera cycle'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume Class Reference

  • CameraControlActions
  • GeViAct_CameraCycleResume
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume Class Reference
Actions

Action 'Resume camera cycle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraCycleResume (GeViVideoOutputID initMonitorID)
Create the action 'Resume camera cycle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraCycleResume^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aMonitorID
ID of the monitor.

Detailed Description

Action 'Resume camera cycle'.

Constructor & Destructor Documentation

GeViAct_CameraCycleResume::GeViAct_CameraCycleResume ( GeViVideoOutputID initMonitorID )

Create the action 'Resume camera cycle'.

Parameters:
initMonitorID ID of the monitor

Member Function Documentation

GeViAct_CameraCycleResume GeViAct_CameraCycleResume::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraCycleResume::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraCycleResumeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraCycleResumeEventArgs (GeViAct_CameraCycleResume^ initAction)
Create the EventArgs for handler of action 'Resume camera cycle'.

Properties

GeViVideoOutputID aMonitorID
ID of the monitor.

Private Member Functions

GeViAct_CameraCycleResumeEventArgs ()

Detailed Description

EventArgs for handler of action 'Resume camera cycle'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs::GeViAct_CameraCycleResumeEventArgs ( ) [private]
GeViAct_CameraCycleResumeEventArgs::GeViAct_CameraCycleResumeEventArgs ( GeViAct_CameraCycleResume^ initAction )

Create the EventArgs for handler of action 'Resume camera cycle'.

Parameters:
initAction Managed action 'Resume camera cycle'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs::aMonitorID

ID of the monitor.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart Class Reference

  • CameraControlActions
  • GeViAct_CameraCycleStart
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart Class Reference
Actions

Action 'Start of the camera-cycle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraCycleStart (GeViVideoOutputID initMonitorID, Int32 initCycleID, String^ initCycleName)
Create the action 'Start of the camera-cycle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraCycleStart^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aMonitorID
ID of the monitor, on which the cycle shall be realized.
Int32 | aCycleID
ID of the cycle template. In the case of (0 and empty CycleName) the default cycle of the monitor will be startet.
String^ | aCycleName
Name of the cycle template or empty (e.g. for default cycle)

Detailed Description

Action 'Start of the camera-cycle'.

Constructor & Destructor Documentation

GeViAct_CameraCycleStart::GeViAct_CameraCycleStart | ( | GeViVideoOutputID | initMonitorID,
 |  | Int32 | initCycleID,
 |  | String^ | initCycleName
 | ) |  |

Create the action 'Start of the camera-cycle'.

Parameters:
initMonitorID | ID of the monitor, on which the cycle shall be realized
initCycleID | ID of the cycle template. In the case of (0 and empty CycleName) the default cycle of the monitor will be startet.
initCycleName | Name of the cycle template or empty (e.g. for default cycle)

Member Function Documentation

GeViAct_CameraCycleStart GeViAct_CameraCycleStart::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraCycleStart::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart::aCycleID

ID of the cycle template. In the case of (0 and empty CycleName) the default cycle of the monitor will be startet.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart::aCycleName

Name of the cycle template or empty (e.g. for default cycle)

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart::aMonitorID

ID of the monitor, on which the cycle shall be realized.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraCycleStartEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraCycleStartEventArgs (GeViAct_CameraCycleStart^ initAction)
Create the EventArgs for handler of action 'Start of the camera-cycle'.

Properties

GeViVideoOutputID | aMonitorID
ID of the monitor, on which the cycle shall be realized.
Int32 | aCycleID
ID of the cycle template. In the case of (0 and empty CycleName) the default cycle of the monitor will be startet.
String^ | aCycleName
Name of the cycle template or empty (e.g. for default cycle)

Private Member Functions

GeViAct_CameraCycleStartEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of the camera-cycle'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs::GeViAct_CameraCycleStartEventArgs ( ) [private]
GeViAct_CameraCycleStartEventArgs::GeViAct_CameraCycleStartEventArgs ( GeViAct_CameraCycleStart^ initAction )

Create the EventArgs for handler of action 'Start of the camera-cycle'.

Parameters:
initAction Managed action 'Start of the camera-cycle'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs::aCycleID

ID of the cycle template. In the case of (0 and empty CycleName) the default cycle of the monitor will be startet.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs::aCycleName

Name of the cycle template or empty (e.g. for default cycle)

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs::aMonitorID

ID of the monitor, on which the cycle shall be realized.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop Class Reference

  • CameraControlActions
  • GeViAct_CameraCycleStop
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop Class Reference
Actions

Action 'Stopp camera cycle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraCycleStop (GeViVideoOutputID initMonitorID)
Create the action 'Stopp camera cycle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraCycleStop^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aMonitorID
ID of the monitor, on which the cycle is running.

Detailed Description

Action 'Stopp camera cycle'.

Constructor & Destructor Documentation

GeViAct_CameraCycleStop::GeViAct_CameraCycleStop ( GeViVideoOutputID initMonitorID )

Create the action 'Stopp camera cycle'.

Parameters:
initMonitorID ID of the monitor, on which the cycle is running

Member Function Documentation

GeViAct_CameraCycleStop GeViAct_CameraCycleStop::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraCycleStop::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop::aMonitorID

ID of the monitor, on which the cycle is running.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraCycleStopEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraCycleStopEventArgs (GeViAct_CameraCycleStop^ initAction)
Create the EventArgs for handler of action 'Stopp camera cycle'.

Properties

GeViVideoOutputID aMonitorID
ID of the monitor, on which the cycle is running.

Private Member Functions

GeViAct_CameraCycleStopEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp camera cycle'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs::GeViAct_CameraCycleStopEventArgs ( ) [private]
GeViAct_CameraCycleStopEventArgs::GeViAct_CameraCycleStopEventArgs ( GeViAct_CameraCycleStop^ initAction )

Create the EventArgs for handler of action 'Stopp camera cycle'.

Parameters:
initAction Managed action 'Stopp camera cycle'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs::aMonitorID

ID of the monitor, on which the cycle is running.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff Class Reference

  • CameraControlActions
  • GeViAct_CameraLightOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff Class Reference
Actions

Action 'Turn off camera light'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraLightOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off camera light'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraLightOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which light shall be turned off.

Detailed Description

Action 'Turn off camera light'.

Constructor & Destructor Documentation

GeViAct_CameraLightOff::GeViAct_CameraLightOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off camera light'.

Parameters:
initVideoInput ID of the camera, which light shall be turned off.

Member Function Documentation

GeViAct_CameraLightOff GeViAct_CameraLightOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraLightOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff::aVideoInput

ID of the camera, which light shall be turned off.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraLightOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraLightOffEventArgs (GeViAct_CameraLightOff^ initAction)
Create the EventArgs for handler of action 'Turn off camera light'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which light shall be turned off.

Private Member Functions

GeViAct_CameraLightOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off camera light'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs::GeViAct_CameraLightOffEventArgs ( ) [private]
GeViAct_CameraLightOffEventArgs::GeViAct_CameraLightOffEventArgs ( GeViAct_CameraLightOff^ initAction )

Create the EventArgs for handler of action 'Turn off camera light'.

Parameters:
initAction Managed action 'Turn off camera light'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs::aVideoInput

ID of the camera, which light shall be turned off.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn Class Reference

  • CameraControlActions
  • GeViAct_CameraLightOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn Class Reference
Actions

Action 'Turn on camera light'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraLightOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on camera light'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraLightOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which light shall be turn on.

Detailed Description

Action 'Turn on camera light'.

Constructor & Destructor Documentation

GeViAct_CameraLightOn::GeViAct_CameraLightOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on camera light'.

Parameters:
initVideoInput ID of the camera, which light shall be turn on

Member Function Documentation

GeViAct_CameraLightOn GeViAct_CameraLightOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraLightOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn::aVideoInput

ID of the camera, which light shall be turn on.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraLightOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraLightOnEventArgs (GeViAct_CameraLightOn^ initAction)
Create the EventArgs for handler of action 'Turn on camera light'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which light shall be turn on.

Private Member Functions

GeViAct_CameraLightOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on camera light'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs::GeViAct_CameraLightOnEventArgs ( ) [private]
GeViAct_CameraLightOnEventArgs::GeViAct_CameraLightOnEventArgs ( GeViAct_CameraLightOn^ initAction )

Create the EventArgs for handler of action 'Turn on camera light'.

Parameters:
initAction Managed action 'Turn on camera light'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs::aVideoInput

ID of the camera, which light shall be turn on.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff Class Reference

  • CameraControlActions
  • GeViAct_CameraManualIrisOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff Class Reference
Actions

Action 'Turn off the manual iris of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraManualIrisOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off the manual iris of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraManualIrisOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.

Detailed Description

Action 'Turn off the manual iris of the camera'.

Constructor & Destructor Documentation

GeViAct_CameraManualIrisOff::GeViAct_CameraManualIrisOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off the manual iris of the camera'.

Parameters:
initVideoInput ID of the camera

Member Function Documentation

GeViAct_CameraManualIrisOff GeViAct_CameraManualIrisOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraManualIrisOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraManualIrisOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraManualIrisOffEventArgs (GeViAct_CameraManualIrisOff^ initAction)
Create the EventArgs for handler of action 'Turn off the manual iris of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera.

Private Member Functions

GeViAct_CameraManualIrisOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the manual iris of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs::GeViAct_CameraManualIrisOffEventArgs ( ) [private]
GeViAct_CameraManualIrisOffEventArgs::GeViAct_CameraManualIrisOffEventArgs ( GeViAct_CameraManualIrisOff^ initAction )

Create the EventArgs for handler of action 'Turn off the manual iris of the camera'.

Parameters:
initAction Managed action 'Turn off the manual iris of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn Class Reference

  • CameraControlActions
  • GeViAct_CameraManualIrisOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn Class Reference
Actions

Action 'Turn on the manual iris of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraManualIrisOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on the manual iris of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraManualIrisOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.

Detailed Description

Action 'Turn on the manual iris of the camera'.

Constructor & Destructor Documentation

GeViAct_CameraManualIrisOn::GeViAct_CameraManualIrisOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on the manual iris of the camera'.

Parameters:
initVideoInput ID of the camera

Member Function Documentation

GeViAct_CameraManualIrisOn GeViAct_CameraManualIrisOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraManualIrisOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraManualIrisOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraManualIrisOnEventArgs (GeViAct_CameraManualIrisOn^ initAction)
Create the EventArgs for handler of action 'Turn on the manual iris of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera.

Private Member Functions

GeViAct_CameraManualIrisOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the manual iris of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs::GeViAct_CameraManualIrisOnEventArgs ( ) [private]
GeViAct_CameraManualIrisOnEventArgs::GeViAct_CameraManualIrisOnEventArgs ( GeViAct_CameraManualIrisOn^ initAction )

Create the EventArgs for handler of action 'Turn on the manual iris of the camera'.

Parameters:
initAction Managed action 'Turn on the manual iris of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff Class Reference

  • CameraControlActions
  • GeViAct_CameraOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff Class Reference
Actions

Action 'Turn a camera off'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraOff (GeViVideoInputID initVideoInput)
Create the action 'Turn a camera off'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera to turn off.

Detailed Description

Action 'Turn a camera off'.

Constructor & Destructor Documentation

GeViAct_CameraOff::GeViAct_CameraOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn a camera off'.

Parameters:
initVideoInput ID of the camera to turn off

Member Function Documentation

GeViAct_CameraOff GeViAct_CameraOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff::aVideoInput

ID of the camera to turn off.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraOffEventArgs (GeViAct_CameraOff^ initAction)
Create the EventArgs for handler of action 'Turn a camera off'.

Properties

GeViVideoInputID aVideoInput
ID of the camera to turn off.

Private Member Functions

GeViAct_CameraOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn a camera off'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs::GeViAct_CameraOffEventArgs ( ) [private]
GeViAct_CameraOffEventArgs::GeViAct_CameraOffEventArgs ( GeViAct_CameraOff^ initAction )

Create the EventArgs for handler of action 'Turn a camera off'.

Parameters:
initAction Managed action 'Turn a camera off'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs::aVideoInput

ID of the camera to turn off.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn Class Reference

  • CameraControlActions
  • GeViAct_CameraOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn Class Reference
Actions

Action 'Turn on a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera to turn on.

Detailed Description

Action 'Turn on a camera'.

Constructor & Destructor Documentation

GeViAct_CameraOn::GeViAct_CameraOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on a camera'.

Parameters:
initVideoInput ID of the camera to turn on

Member Function Documentation

GeViAct_CameraOn GeViAct_CameraOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn::aVideoInput

ID of the camera to turn on.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraOnEventArgs (GeViAct_CameraOn^ initAction)
Create the EventArgs for handler of action 'Turn on a camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera to turn on.

Private Member Functions

GeViAct_CameraOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs::GeViAct_CameraOnEventArgs ( ) [private]
GeViAct_CameraOnEventArgs::GeViAct_CameraOnEventArgs ( GeViAct_CameraOn^ initAction )

Create the EventArgs for handler of action 'Turn on a camera'.

Parameters:
initAction Managed action 'Turn on a camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs::aVideoInput

ID of the camera to turn on.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff Class Reference

  • CameraControlActions
  • GeViAct_CameraPumpOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff Class Reference
Actions

Action 'Turn of pump of a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraPumpOff (GeViVideoInputID initVideoInput)
Create the action 'Turn of pump of a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraPumpOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which pump shall be turned off.

Detailed Description

Action 'Turn of pump of a camera'.

Constructor & Destructor Documentation

GeViAct_CameraPumpOff::GeViAct_CameraPumpOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn of pump of a camera'.

Parameters:
initVideoInput ID of the camera, which pump shall be turned off

Member Function Documentation

GeViAct_CameraPumpOff GeViAct_CameraPumpOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraPumpOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff::aVideoInput

ID of the camera, which pump shall be turned off.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraPumpOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraPumpOffEventArgs (GeViAct_CameraPumpOff^ initAction)
Create the EventArgs for handler of action 'Turn of pump of a camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which pump shall be turned off.

Private Member Functions

GeViAct_CameraPumpOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn of pump of a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs::GeViAct_CameraPumpOffEventArgs ( ) [private]
GeViAct_CameraPumpOffEventArgs::GeViAct_CameraPumpOffEventArgs ( GeViAct_CameraPumpOff^ initAction )

Create the EventArgs for handler of action 'Turn of pump of a camera'.

Parameters:
initAction Managed action 'Turn of pump of a camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs::aVideoInput

ID of the camera, which pump shall be turned off.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn Class Reference

  • CameraControlActions
  • GeViAct_CameraPumpOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn Class Reference
Actions

Action 'Turn on pump of a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraPumpOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on pump of a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraPumpOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which pump shall be turned on.

Detailed Description

Action 'Turn on pump of a camera'.

Constructor & Destructor Documentation

GeViAct_CameraPumpOn::GeViAct_CameraPumpOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on pump of a camera'.

Parameters:
initVideoInput ID of the camera, which pump shall be turned on

Member Function Documentation

GeViAct_CameraPumpOn GeViAct_CameraPumpOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraPumpOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn::aVideoInput

ID of the camera, which pump shall be turned on.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraPumpOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraPumpOnEventArgs (GeViAct_CameraPumpOn^ initAction)
Create the EventArgs for handler of action 'Turn on pump of a camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which pump shall be turned on.

Private Member Functions

GeViAct_CameraPumpOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on pump of a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs::GeViAct_CameraPumpOnEventArgs ( ) [private]
GeViAct_CameraPumpOnEventArgs::GeViAct_CameraPumpOnEventArgs ( GeViAct_CameraPumpOn^ initAction )

Create the EventArgs for handler of action 'Turn on pump of a camera'.

Parameters:
initAction Managed action 'Turn on pump of a camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs::aVideoInput

ID of the camera, which pump shall be turned on.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput Class Reference

  • CameraControlActions
  • GeViAct_CameraRAWOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput Class Reference
Actions

Action 'Output of a direct command to the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraRAWOutput (GeViVideoInputID initVideoInput, String^ initRAWData)
Create the action 'Output of a direct command to the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraRAWOutput^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.
String^ | aRAWData
Raw data, which are put out direct to the camera after.

Detailed Description

Action 'Output of a direct command to the camera'.

Constructor & Destructor Documentation

GeViAct_CameraRAWOutput::GeViAct_CameraRAWOutput | ( | GeViVideoInputID | initVideoInput,
 |  | String^ | initRAWData
 | ) |  |

Create the action 'Output of a direct command to the camera'.

Parameters:
initVideoInput | ID of the camera
initRAWData | Raw data, which are put out direct to the camera after

Member Function Documentation

GeViAct_CameraRAWOutput GeViAct_CameraRAWOutput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraRAWOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput::aRAWData

Raw data, which are put out direct to the camera after.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraRAWOutputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraRAWOutputEventArgs (GeViAct_CameraRAWOutput^ initAction)
Create the EventArgs for handler of action 'Output of a direct command to the camera'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.
String^ | aRAWData
Raw data, which are put out direct to the camera after.

Private Member Functions

GeViAct_CameraRAWOutputEventArgs ()

Detailed Description

EventArgs for handler of action 'Output of a direct command to the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs::GeViAct_CameraRAWOutputEventArgs ( ) [private]
GeViAct_CameraRAWOutputEventArgs::GeViAct_CameraRAWOutputEventArgs ( GeViAct_CameraRAWOutput^ initAction )

Create the EventArgs for handler of action 'Output of a direct command to the camera'.

Parameters:
initAction Managed action 'Output of a direct command to the camera'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs::aRAWData

Raw data, which are put out direct to the camera after.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode Class Reference

  • CameraControlActions
  • GeViAct_CameraSelectCharMode
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode Class Reference
Actions

Action 'Select character set.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSelectCharMode (GeViVideoInputID initVideoInput, Int32 initMode)
Create the action 'Select character set.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_CameraSelectCharMode^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which character set shall be changed.
Int32 | aMode
Character set (0 or 1)

Detailed Description

Action 'Select character set.'.

Constructor & Destructor Documentation

GeViAct_CameraSelectCharMode::GeViAct_CameraSelectCharMode | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initMode
 | ) |  |

Create the action 'Select character set.'.

Parameters:
initVideoInput | ID of the camera, which character set shall be changed
initMode | Character set (0 or 1)

Member Function Documentation

GeViAct_CameraSelectCharMode GeViAct_CameraSelectCharMode::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSelectCharMode::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode::aMode

Character set (0 or 1)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode::aVideoInput

ID of the camera, which character set shall be changed.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSelectCharModeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSelectCharModeEventArgs (GeViAct_CameraSelectCharMode^ initAction)
Create the EventArgs for handler of action 'Select character set.'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which character set shall be changed.
Int32 | aMode
Character set (0 or 1)

Private Member Functions

GeViAct_CameraSelectCharModeEventArgs ()

Detailed Description

EventArgs for handler of action 'Select character set.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs::GeViAct_CameraSelectCharModeEventArgs ( ) [private]
GeViAct_CameraSelectCharModeEventArgs::GeViAct_CameraSelectCharModeEventArgs ( GeViAct_CameraSelectCharMode^ initAction )

Create the EventArgs for handler of action 'Select character set.'.

Parameters:
initAction Managed action 'Select character set.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs::aMode

Character set (0 or 1)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs::aVideoInput

ID of the camera, which character set shall be changed.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText Class Reference

  • CameraControlActions
  • GeViAct_CameraSetCameraText
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText Class Reference
Actions

Action 'Set a camera text'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSetCameraText (GeViVideoInputID initVideoInput, String^ initText)
Create the action 'Set a camera text'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSetCameraText^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which Text shall be set.
String^ | aText
Text, maximal 16 characters.

Detailed Description

Action 'Set a camera text'.

Constructor & Destructor Documentation

GeViAct_CameraSetCameraText::GeViAct_CameraSetCameraText | ( | GeViVideoInputID | initVideoInput,
 |  | String^ | initText
 | ) |  |

Create the action 'Set a camera text'.

Parameters:
initVideoInput | ID of the camera, which Text shall be set
initText | Text, maximal 16 characters

Member Function Documentation

GeViAct_CameraSetCameraText GeViAct_CameraSetCameraText::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSetCameraText::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText::aText

Text, maximal 16 characters.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText::aVideoInput

ID of the camera, which Text shall be set.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSetCameraTextEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSetCameraTextEventArgs (GeViAct_CameraSetCameraText^ initAction)
Create the EventArgs for handler of action 'Set a camera text'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which Text shall be set.
String^ | aText
Text, maximal 16 characters.

Private Member Functions

GeViAct_CameraSetCameraTextEventArgs ()

Detailed Description

EventArgs for handler of action 'Set a camera text'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs::GeViAct_CameraSetCameraTextEventArgs ( ) [private]
GeViAct_CameraSetCameraTextEventArgs::GeViAct_CameraSetCameraTextEventArgs ( GeViAct_CameraSetCameraText^ initAction )

Create the EventArgs for handler of action 'Set a camera text'.

Parameters:
initAction Managed action 'Set a camera text'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs::aText

Text, maximal 16 characters.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs::aVideoInput

ID of the camera, which Text shall be set.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText Class Reference

  • CameraControlActions
  • GeViAct_CameraSetPrePosText
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText Class Reference
Actions

Action 'Set text on a predefinied position'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSetPrePosText (GeViVideoInputID initVideoInput, String^ initText)
Create the action 'Set text on a predefinied position'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSetPrePosText^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, where the text shall be set.
String^ | aText
Text, maximal 16 characters.

Detailed Description

Action 'Set text on a predefinied position'.

Constructor & Destructor Documentation

GeViAct_CameraSetPrePosText::GeViAct_CameraSetPrePosText | ( | GeViVideoInputID | initVideoInput,
 |  | String^ | initText
 | ) |  |

Create the action 'Set text on a predefinied position'.

Parameters:
initVideoInput | ID of the camera, where the text shall be set
initText | Text, maximal 16 characters

Member Function Documentation

GeViAct_CameraSetPrePosText GeViAct_CameraSetPrePosText::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSetPrePosText::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText::aText

Text, maximal 16 characters.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText::aVideoInput

ID of the camera, where the text shall be set.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSetPrePosTextEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSetPrePosTextEventArgs (GeViAct_CameraSetPrePosText^ initAction)
Create the EventArgs for handler of action 'Set text on a predefinied position'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, where the text shall be set.
String^ | aText
Text, maximal 16 characters.

Private Member Functions

GeViAct_CameraSetPrePosTextEventArgs ()

Detailed Description

EventArgs for handler of action 'Set text on a predefinied position'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs::GeViAct_CameraSetPrePosTextEventArgs ( ) [private]
GeViAct_CameraSetPrePosTextEventArgs::GeViAct_CameraSetPrePosTextEventArgs ( GeViAct_CameraSetPrePosText^ initAction )

Create the EventArgs for handler of action 'Set text on a predefinied position'.

Parameters:
initAction Managed action 'Set text on a predefinied position'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs::aText

Text, maximal 16 characters.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs::aVideoInput

ID of the camera, where the text shall be set.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff Class Reference

  • CameraControlActions
  • GeViAct_CameraSmearAndWashOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff Class Reference
Actions

Action 'Turn off wiping a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSmearAndWashOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off wiping a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_CameraSmearAndWashOff^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, where the wiping and washing shall be turned off.

Detailed Description

Action 'Turn off wiping a camera'.

Constructor & Destructor Documentation

GeViAct_CameraSmearAndWashOff::GeViAct_CameraSmearAndWashOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off wiping a camera'.

Parameters:
initVideoInput ID of the camera, where the wiping and washing shall be turned off

Member Function Documentation

GeViAct_CameraSmearAndWashOff GeViAct_CameraSmearAndWashOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSmearAndWashOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff::aVideoInput

ID of the camera, where the wiping and washing shall be turned off.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSmearAndWashOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSmearAndWashOffEventArgs (GeViAct_CameraSmearAndWashOff^ initAction)
Create the EventArgs for handler of action 'Turn off wiping a camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, where the wiping and washing shall be turned off.

Private Member Functions

GeViAct_CameraSmearAndWashOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off wiping a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs::GeViAct_CameraSmearAndWashOffEventArgs ( ) [private]
GeViAct_CameraSmearAndWashOffEventArgs::GeViAct_CameraSmearAndWashOffEventArgs ( GeViAct_CameraSmearAndWashOff^ initAction )

Create the EventArgs for handler of action 'Turn off wiping a camera'.

Parameters:
initAction Managed action 'Turn off wiping a camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs::aVideoInput

ID of the camera, where the wiping and washing shall be turned off.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn Class Reference

  • CameraControlActions
  • GeViAct_CameraSmearAndWashOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn Class Reference
Actions

Action 'Turn on the wiping and washing of a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSmearAndWashOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on the wiping and washing of a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_CameraSmearAndWashOn^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, where the wiping shall be activated.

Detailed Description

Action 'Turn on the wiping and washing of a camera'.

Constructor & Destructor Documentation

GeViAct_CameraSmearAndWashOn::GeViAct_CameraSmearAndWashOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on the wiping and washing of a camera'.

Parameters:
initVideoInput ID of the camera, where the wiping shall be activated

Member Function Documentation

GeViAct_CameraSmearAndWashOn GeViAct_CameraSmearAndWashOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSmearAndWashOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn::aVideoInput

ID of the camera, where the wiping shall be activated.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSmearAndWashOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSmearAndWashOnEventArgs (GeViAct_CameraSmearAndWashOn^ initAction)
Create the EventArgs for handler of action 'Turn on the wiping and washing of a camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, where the wiping shall be activated.

Private Member Functions

GeViAct_CameraSmearAndWashOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the wiping and washing of a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs::GeViAct_CameraSmearAndWashOnEventArgs ( ) [private]
GeViAct_CameraSmearAndWashOnEventArgs::GeViAct_CameraSmearAndWashOnEventArgs ( GeViAct_CameraSmearAndWashOn^ initAction )

Create the EventArgs for handler of action 'Turn on the wiping and washing of a camera'.

Parameters:
initAction Managed action 'Turn on the wiping and washing of a camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs::aVideoInput

ID of the camera, where the wiping shall be activated.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff Class Reference

  • CameraControlActions
  • GeViAct_CameraSpec1FuncOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff Class Reference
Actions

Action 'Turn off special function 1'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSpec1FuncOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off special function 1'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSpec1FuncOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall turn off special function 1.

Detailed Description

Action 'Turn off special function 1'.

Constructor & Destructor Documentation

GeViAct_CameraSpec1FuncOff::GeViAct_CameraSpec1FuncOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off special function 1'.

Parameters:
initVideoInput ID of the camera, which shall turn off special function 1

Member Function Documentation

GeViAct_CameraSpec1FuncOff GeViAct_CameraSpec1FuncOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSpec1FuncOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff::aVideoInput

ID of the camera, which shall turn off special function 1.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSpec1FuncOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSpec1FuncOffEventArgs (GeViAct_CameraSpec1FuncOff^ initAction)
Create the EventArgs for handler of action 'Turn off special function 1'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall turn off special function 1.

Private Member Functions

GeViAct_CameraSpec1FuncOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off special function 1'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs::GeViAct_CameraSpec1FuncOffEventArgs ( ) [private]
GeViAct_CameraSpec1FuncOffEventArgs::GeViAct_CameraSpec1FuncOffEventArgs ( GeViAct_CameraSpec1FuncOff^ initAction )

Create the EventArgs for handler of action 'Turn off special function 1'.

Parameters:
initAction Managed action 'Turn off special function 1'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs::aVideoInput

ID of the camera, which shall turn off special function 1.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn Class Reference

  • CameraControlActions
  • GeViAct_CameraSpec1FuncOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn Class Reference
Actions

Action 'Turn on special function 1'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSpec1FuncOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on special function 1'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSpec1FuncOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall activate special function 1.

Detailed Description

Action 'Turn on special function 1'.

Constructor & Destructor Documentation

GeViAct_CameraSpec1FuncOn::GeViAct_CameraSpec1FuncOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on special function 1'.

Parameters:
initVideoInput ID of the camera, which shall activate special function 1

Member Function Documentation

GeViAct_CameraSpec1FuncOn GeViAct_CameraSpec1FuncOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSpec1FuncOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn::aVideoInput

ID of the camera, which shall activate special function 1.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSpec1FuncOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSpec1FuncOnEventArgs (GeViAct_CameraSpec1FuncOn^ initAction)
Create the EventArgs for handler of action 'Turn on special function 1'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall activate special function 1.

Private Member Functions

GeViAct_CameraSpec1FuncOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on special function 1'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs::GeViAct_CameraSpec1FuncOnEventArgs ( ) [private]
GeViAct_CameraSpec1FuncOnEventArgs::GeViAct_CameraSpec1FuncOnEventArgs ( GeViAct_CameraSpec1FuncOn^ initAction )

Create the EventArgs for handler of action 'Turn on special function 1'.

Parameters:
initAction Managed action 'Turn on special function 1'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs::aVideoInput

ID of the camera, which shall activate special function 1.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff Class Reference

  • CameraControlActions
  • GeViAct_CameraSpecUFuncOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff Class Reference
Actions

Action 'Turn off special function U'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSpecUFuncOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off special function U'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSpecUFuncOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall turn off special function U.

Detailed Description

Action 'Turn off special function U'.

Constructor & Destructor Documentation

GeViAct_CameraSpecUFuncOff::GeViAct_CameraSpecUFuncOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off special function U'.

Parameters:
initVideoInput ID of the camera, which shall turn off special function U

Member Function Documentation

GeViAct_CameraSpecUFuncOff GeViAct_CameraSpecUFuncOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSpecUFuncOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff::aVideoInput

ID of the camera, which shall turn off special function U.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSpecUFuncOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSpecUFuncOffEventArgs (GeViAct_CameraSpecUFuncOff^ initAction)
Create the EventArgs for handler of action 'Turn off special function U'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall turn off special function U.

Private Member Functions

GeViAct_CameraSpecUFuncOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off special function U'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs::GeViAct_CameraSpecUFuncOffEventArgs ( ) [private]
GeViAct_CameraSpecUFuncOffEventArgs::GeViAct_CameraSpecUFuncOffEventArgs ( GeViAct_CameraSpecUFuncOff^ initAction )

Create the EventArgs for handler of action 'Turn off special function U'.

Parameters:
initAction Managed action 'Turn off special function U'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs::aVideoInput

ID of the camera, which shall turn off special function U.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn Class Reference

  • CameraControlActions
  • GeViAct_CameraSpecUFuncOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn Class Reference
Actions

Action 'Turn on special function U'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSpecUFuncOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on special function U'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSpecUFuncOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall turn on special function U.

Detailed Description

Action 'Turn on special function U'.

Constructor & Destructor Documentation

GeViAct_CameraSpecUFuncOn::GeViAct_CameraSpecUFuncOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on special function U'.

Parameters:
initVideoInput ID of the camera, which shall turn on special function U

Member Function Documentation

GeViAct_CameraSpecUFuncOn GeViAct_CameraSpecUFuncOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSpecUFuncOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn::aVideoInput

ID of the camera, which shall turn on special function U.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSpecUFuncOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSpecUFuncOnEventArgs (GeViAct_CameraSpecUFuncOn^ initAction)
Create the EventArgs for handler of action 'Turn on special function U'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall turn on special function U.

Private Member Functions

GeViAct_CameraSpecUFuncOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on special function U'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs::GeViAct_CameraSpecUFuncOnEventArgs ( ) [private]
GeViAct_CameraSpecUFuncOnEventArgs::GeViAct_CameraSpecUFuncOnEventArgs ( GeViAct_CameraSpecUFuncOn^ initAction )

Create the EventArgs for handler of action 'Turn on special function U'.

Parameters:
initAction Managed action 'Turn on special function U'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs::aVideoInput

ID of the camera, which shall turn on special function U.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff Class Reference

  • CameraControlActions
  • GeViAct_CameraSpecVFuncOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff Class Reference
Actions

Action 'Turn off special function V'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSpecVFuncOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off special function V'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSpecVFuncOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall turn off special function V.

Detailed Description

Action 'Turn off special function V'.

Constructor & Destructor Documentation

GeViAct_CameraSpecVFuncOff::GeViAct_CameraSpecVFuncOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off special function V'.

Parameters:
initVideoInput ID of the camera, which shall turn off special function V

Member Function Documentation

GeViAct_CameraSpecVFuncOff GeViAct_CameraSpecVFuncOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSpecVFuncOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff::aVideoInput

ID of the camera, which shall turn off special function V.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSpecVFuncOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSpecVFuncOffEventArgs (GeViAct_CameraSpecVFuncOff^ initAction)
Create the EventArgs for handler of action 'Turn off special function V'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall turn off special function V.

Private Member Functions

GeViAct_CameraSpecVFuncOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off special function V'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs::GeViAct_CameraSpecVFuncOffEventArgs ( ) [private]
GeViAct_CameraSpecVFuncOffEventArgs::GeViAct_CameraSpecVFuncOffEventArgs ( GeViAct_CameraSpecVFuncOff^ initAction )

Create the EventArgs for handler of action 'Turn off special function V'.

Parameters:
initAction Managed action 'Turn off special function V'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs::aVideoInput

ID of the camera, which shall turn off special function V.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn Class Reference

  • CameraControlActions
  • GeViAct_CameraSpecVFuncOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn Class Reference
Actions

Action 'Turn on special function V'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraSpecVFuncOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on special function V'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraSpecVFuncOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall activate special function V.

Detailed Description

Action 'Turn on special function V'.

Constructor & Destructor Documentation

GeViAct_CameraSpecVFuncOn::GeViAct_CameraSpecVFuncOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on special function V'.

Parameters:
initVideoInput ID of the camera, which shall activate special function V

Member Function Documentation

GeViAct_CameraSpecVFuncOn GeViAct_CameraSpecVFuncOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraSpecVFuncOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn::aVideoInput

ID of the camera, which shall activate special function V.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraSpecVFuncOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraSpecVFuncOnEventArgs (GeViAct_CameraSpecVFuncOn^ initAction)
Create the EventArgs for handler of action 'Turn on special function V'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall activate special function V.

Private Member Functions

GeViAct_CameraSpecVFuncOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on special function V'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs::GeViAct_CameraSpecVFuncOnEventArgs ( ) [private]
GeViAct_CameraSpecVFuncOnEventArgs::GeViAct_CameraSpecVFuncOnEventArgs ( GeViAct_CameraSpecVFuncOn^ initAction )

Create the EventArgs for handler of action 'Turn on special function V'.

Parameters:
initAction Managed action 'Turn on special function V'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs::aVideoInput

ID of the camera, which shall activate special function V.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll Class Reference

  • CameraControlActions
  • GeViAct_CameraStopAll
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll Class Reference
Actions

Action 'Turn on displaying of firmware version'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraStopAll (GeViVideoInputID initVideoInput)
Create the action 'Turn on displaying of firmware version'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraStopAll^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.

Detailed Description

Action 'Turn on displaying of firmware version'.

Constructor & Destructor Documentation

GeViAct_CameraStopAll::GeViAct_CameraStopAll ( GeViVideoInputID initVideoInput )

Create the action 'Turn on displaying of firmware version'.

Parameters:
initVideoInput ID of the camera

Member Function Documentation

GeViAct_CameraStopAll GeViAct_CameraStopAll::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraStopAll::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraStopAllEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraStopAllEventArgs (GeViAct_CameraStopAll^ initAction)
Create the EventArgs for handler of action 'Turn on displaying of firmware version'.

Properties

GeViVideoInputID aVideoInput
ID of the camera.

Private Member Functions

GeViAct_CameraStopAllEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on displaying of firmware version'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs::GeViAct_CameraStopAllEventArgs ( ) [private]
GeViAct_CameraStopAllEventArgs::GeViAct_CameraStopAllEventArgs ( GeViAct_CameraStopAll^ initAction )

Create the EventArgs for handler of action 'Turn on displaying of firmware version'.

Parameters:
initAction Managed action 'Turn on displaying of firmware version'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff Class Reference

  • CameraControlActions
  • GeViAct_CameraTextOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff Class Reference
Actions

Action 'Turn off the camera text'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTextOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off the camera text'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTextOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.

Detailed Description

Action 'Turn off the camera text'.

Constructor & Destructor Documentation

GeViAct_CameraTextOff::GeViAct_CameraTextOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off the camera text'.

Parameters:
initVideoInput ID of the camera

Member Function Documentation

GeViAct_CameraTextOff GeViAct_CameraTextOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTextOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTextOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTextOffEventArgs (GeViAct_CameraTextOff^ initAction)
Create the EventArgs for handler of action 'Turn off the camera text'.

Properties

GeViVideoInputID aVideoInput
ID of the camera.

Private Member Functions

GeViAct_CameraTextOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the camera text'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs::GeViAct_CameraTextOffEventArgs ( ) [private]
GeViAct_CameraTextOffEventArgs::GeViAct_CameraTextOffEventArgs ( GeViAct_CameraTextOff^ initAction )

Create the EventArgs for handler of action 'Turn off the camera text'.

Parameters:
initAction Managed action 'Turn off the camera text'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn Class Reference

  • CameraControlActions
  • GeViAct_CameraTextOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn Class Reference
Actions

Action 'Turn on the camera text'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTextOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on the camera text'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTextOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.

Detailed Description

Action 'Turn on the camera text'.

Constructor & Destructor Documentation

GeViAct_CameraTextOn::GeViAct_CameraTextOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on the camera text'.

Parameters:
initVideoInput ID of the camera

Member Function Documentation

GeViAct_CameraTextOn GeViAct_CameraTextOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTextOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTextOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTextOnEventArgs (GeViAct_CameraTextOn^ initAction)
Create the EventArgs for handler of action 'Turn on the camera text'.

Properties

GeViVideoInputID aVideoInput
ID of the camera.

Private Member Functions

GeViAct_CameraTextOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the camera text'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs::GeViAct_CameraTextOnEventArgs ( ) [private]
GeViAct_CameraTextOnEventArgs::GeViAct_CameraTextOnEventArgs ( GeViAct_CameraTextOn^ initAction )

Create the EventArgs for handler of action 'Turn on the camera text'.

Parameters:
initAction Managed action 'Turn on the camera text'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext Class Reference

  • CameraControlActions
  • GeViAct_CameraTourNext
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext Class Reference
Actions

Action 'Next position in the camera tour'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTourNext (GeViVideoInputID initCameraID)
Create the action 'Next position in the camera tour'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTourNext^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aCameraID
ID of the camera.

Detailed Description

Action 'Next position in the camera tour'.

Constructor & Destructor Documentation

GeViAct_CameraTourNext::GeViAct_CameraTourNext ( GeViVideoInputID initCameraID )

Create the action 'Next position in the camera tour'.

Parameters:
initCameraID ID of the camera

Member Function Documentation

GeViAct_CameraTourNext GeViAct_CameraTourNext::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTourNext::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTourNextEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTourNextEventArgs (GeViAct_CameraTourNext^ initAction)
Create the EventArgs for handler of action 'Next position in the camera tour'.

Properties

GeViVideoInputID aCameraID
ID of the camera.

Private Member Functions

GeViAct_CameraTourNextEventArgs ()

Detailed Description

EventArgs for handler of action 'Next position in the camera tour'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs::GeViAct_CameraTourNextEventArgs ( ) [private]
GeViAct_CameraTourNextEventArgs::GeViAct_CameraTourNextEventArgs ( GeViAct_CameraTourNext^ initAction )

Create the EventArgs for handler of action 'Next position in the camera tour'.

Parameters:
initAction Managed action 'Next position in the camera tour'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause Class Reference

  • CameraControlActions
  • GeViAct_CameraTourPause
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause Class Reference
Actions

Action 'Pause the camera tour'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTourPause (GeViVideoInputID initCameraID)
Create the action 'Pause the camera tour'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTourPause^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aCameraID
ID of the camera.

Detailed Description

Action 'Pause the camera tour'.

Constructor & Destructor Documentation

GeViAct_CameraTourPause::GeViAct_CameraTourPause ( GeViVideoInputID initCameraID )

Create the action 'Pause the camera tour'.

Parameters:
initCameraID ID of the camera

Member Function Documentation

GeViAct_CameraTourPause GeViAct_CameraTourPause::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTourPause::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTourPauseEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTourPauseEventArgs (GeViAct_CameraTourPause^ initAction)
Create the EventArgs for handler of action 'Pause the camera tour'.

Properties

GeViVideoInputID aCameraID
ID of the camera.

Private Member Functions

GeViAct_CameraTourPauseEventArgs ()

Detailed Description

EventArgs for handler of action 'Pause the camera tour'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs::GeViAct_CameraTourPauseEventArgs ( ) [private]
GeViAct_CameraTourPauseEventArgs::GeViAct_CameraTourPauseEventArgs ( GeViAct_CameraTourPause^ initAction )

Create the EventArgs for handler of action 'Pause the camera tour'.

Parameters:
initAction Managed action 'Pause the camera tour'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev Class Reference

  • CameraControlActions
  • GeViAct_CameraTourPrev
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev Class Reference
Actions

Action 'Previous position in the camera tour'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTourPrev (GeViVideoInputID initCameraID)
Create the action 'Previous position in the camera tour'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTourPrev^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aCameraID
ID of the camera.

Detailed Description

Action 'Previous position in the camera tour'.

Constructor & Destructor Documentation

GeViAct_CameraTourPrev::GeViAct_CameraTourPrev ( GeViVideoInputID initCameraID )

Create the action 'Previous position in the camera tour'.

Parameters:
initCameraID ID of the camera

Member Function Documentation

GeViAct_CameraTourPrev GeViAct_CameraTourPrev::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTourPrev::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTourPrevEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTourPrevEventArgs (GeViAct_CameraTourPrev^ initAction)
Create the EventArgs for handler of action 'Previous position in the camera tour'.

Properties

GeViVideoInputID aCameraID
ID of the camera.

Private Member Functions

GeViAct_CameraTourPrevEventArgs ()

Detailed Description

EventArgs for handler of action 'Previous position in the camera tour'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs::GeViAct_CameraTourPrevEventArgs ( ) [private]
GeViAct_CameraTourPrevEventArgs::GeViAct_CameraTourPrevEventArgs ( GeViAct_CameraTourPrev^ initAction )

Create the EventArgs for handler of action 'Previous position in the camera tour'.

Parameters:
initAction Managed action 'Previous position in the camera tour'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume Class Reference

  • CameraControlActions
  • GeViAct_CameraTourResume
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume Class Reference
Actions

Action 'Resume the camera tour'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTourResume (GeViVideoInputID initCameraID)
Create the action 'Resume the camera tour'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTourResume^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aCameraID
ID of the camera.

Detailed Description

Action 'Resume the camera tour'.

Constructor & Destructor Documentation

GeViAct_CameraTourResume::GeViAct_CameraTourResume ( GeViVideoInputID initCameraID )

Create the action 'Resume the camera tour'.

Parameters:
initCameraID ID of the camera

Member Function Documentation

GeViAct_CameraTourResume GeViAct_CameraTourResume::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTourResume::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTourResumeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTourResumeEventArgs (GeViAct_CameraTourResume^ initAction)
Create the EventArgs for handler of action 'Resume the camera tour'.

Properties

GeViVideoInputID aCameraID
ID of the camera.

Private Member Functions

GeViAct_CameraTourResumeEventArgs ()

Detailed Description

EventArgs for handler of action 'Resume the camera tour'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs::GeViAct_CameraTourResumeEventArgs ( ) [private]
GeViAct_CameraTourResumeEventArgs::GeViAct_CameraTourResumeEventArgs ( GeViAct_CameraTourResume^ initAction )

Create the EventArgs for handler of action 'Resume the camera tour'.

Parameters:
initAction Managed action 'Resume the camera tour'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart Class Reference

  • CameraControlActions
  • GeViAct_CameraTourStart
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart Class Reference
Actions

Action 'Start of the camera tour'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTourStart (GeViVideoInputID initCameraID, Int32 initTourID, String^ initTourName)
Create the action 'Start of the camera tour'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTourStart^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aCameraID
ID of the camera of this tour.
Int32 | aTourID
ID of the tour template. In the case of (0 and empty Tourname) the default tour of the camera will be started.
String^ | aTourName
Name of the tour template or empty for default tour.

Detailed Description

Action 'Start of the camera tour'.

Constructor & Destructor Documentation

GeViAct_CameraTourStart::GeViAct_CameraTourStart | ( | GeViVideoInputID | initCameraID,
 |  | Int32 | initTourID,
 |  | String^ | initTourName
 | ) |  |

Create the action 'Start of the camera tour'.

Parameters:
initCameraID | ID of the camera of this tour
initTourID | ID of the tour template. In the case of (0 and empty Tourname) the default tour of the camera will be started.
initTourName | Name of the tour template or empty for default tour

Member Function Documentation

GeViAct_CameraTourStart GeViAct_CameraTourStart::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTourStart::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart::aCameraID

ID of the camera of this tour.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart::aTourID

ID of the tour template. In the case of (0 and empty Tourname) the default tour of the camera will be started.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart::aTourName

Name of the tour template or empty for default tour.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTourStartEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTourStartEventArgs (GeViAct_CameraTourStart^ initAction)
Create the EventArgs for handler of action 'Start of the camera tour'.

Properties

GeViVideoInputID | aCameraID
ID of the camera of this tour.
Int32 | aTourID
ID of the tour template. In the case of (0 and empty Tourname) the default tour of the camera will be started.
String^ | aTourName
Name of the tour template or empty for default tour.

Private Member Functions

GeViAct_CameraTourStartEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of the camera tour'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs::GeViAct_CameraTourStartEventArgs ( ) [private]
GeViAct_CameraTourStartEventArgs::GeViAct_CameraTourStartEventArgs ( GeViAct_CameraTourStart^ initAction )

Create the EventArgs for handler of action 'Start of the camera tour'.

Parameters:
initAction Managed action 'Start of the camera tour'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs::aCameraID

ID of the camera of this tour.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs::aTourID

ID of the tour template. In the case of (0 and empty Tourname) the default tour of the camera will be started.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs::aTourName

Name of the tour template or empty for default tour.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop Class Reference

  • CameraControlActions
  • GeViAct_CameraTourStop
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop Class Reference
Actions

Action 'Stop the camera tour'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraTourStop (GeViVideoInputID initCameraID)
Create the action 'Stop the camera tour'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraTourStop^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aCameraID
ID of the camera.

Detailed Description

Action 'Stop the camera tour'.

Constructor & Destructor Documentation

GeViAct_CameraTourStop::GeViAct_CameraTourStop ( GeViVideoInputID initCameraID )

Create the action 'Stop the camera tour'.

Parameters:
initCameraID ID of the camera

Member Function Documentation

GeViAct_CameraTourStop GeViAct_CameraTourStop::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraTourStop::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraTourStopEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraTourStopEventArgs (GeViAct_CameraTourStop^ initAction)
Create the EventArgs for handler of action 'Stop the camera tour'.

Properties

GeViVideoInputID aCameraID
ID of the camera.

Private Member Functions

GeViAct_CameraTourStopEventArgs ()

Detailed Description

EventArgs for handler of action 'Stop the camera tour'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs::GeViAct_CameraTourStopEventArgs ( ) [private]
GeViAct_CameraTourStopEventArgs::GeViAct_CameraTourStopEventArgs ( GeViAct_CameraTourStop^ initAction )

Create the EventArgs for handler of action 'Stop the camera tour'.

Parameters:
initAction Managed action 'Stop the camera tour'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs::aCameraID

ID of the camera.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff Class Reference

  • CameraControlActions
  • GeViAct_CameraVerOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff Class Reference
Actions

Action 'Turn off displaying of the firmware version'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff:
[legend]

List of all members.

Public Member Functions

GeViAct_CameraVerOff (GeViVideoInputID initVideoInput)
Create the action 'Turn off displaying of the firmware version'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CameraVerOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall turn off displaying of firmware version.

Detailed Description

Action 'Turn off displaying of the firmware version'.

Constructor & Destructor Documentation

GeViAct_CameraVerOff::GeViAct_CameraVerOff ( GeViVideoInputID initVideoInput )

Create the action 'Turn off displaying of the firmware version'.

Parameters:
initVideoInput ID of the camera, which shall turn off displaying of firmware version

Member Function Documentation

GeViAct_CameraVerOff GeViAct_CameraVerOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CameraVerOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff::aVideoInput

ID of the camera, which shall turn off displaying of firmware version.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CameraVerOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CameraVerOffEventArgs (GeViAct_CameraVerOff^ initAction)
Create the EventArgs for handler of action 'Turn off displaying of the firmware version'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall turn off displaying of firmware version.

Private Member Functions

GeViAct_CameraVerOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off displaying of the firmware version'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs::GeViAct_CameraVerOffEventArgs ( ) [private]
GeViAct_CameraVerOffEventArgs::GeViAct_CameraVerOffEventArgs ( GeViAct_CameraVerOff^ initAction )

Create the EventArgs for handler of action 'Turn off displaying of the firmware version'.

Parameters:
initAction Managed action 'Turn off displaying of the firmware version'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs::aVideoInput

ID of the camera, which shall turn off displaying of firmware version.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile Class Reference

  • SystemActions
  • GeViAct_ChangeRightProfile
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile Class Reference
Actions

Action 'Change right profile of a user'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile:
[legend]

List of all members.

Public Member Functions

GeViAct_ChangeRightProfile (GeViClientID initUserID, String^ initUserName, Int32 initProfileID, String^ initProfileName)
Create the action 'Change right profile of a user'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_ChangeRightProfile^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aUserID
ID of the user, only if name is empty.
String^ | aUserName
Name of the user or empty.
Int32 | aProfileID
ID of the profile, if there is no name for it.
String^ | aProfileName
Name of the profile or empty.

Detailed Description

Action 'Change right profile of a user'.

Constructor & Destructor Documentation

GeViAct_ChangeRightProfile::GeViAct_ChangeRightProfile | ( | GeViClientID | initUserID,
 |  | String^ | initUserName,
 |  | Int32 | initProfileID,
 |  | String^ | initProfileName
 | ) |  |

Create the action 'Change right profile of a user'.

Parameters:
initUserID | ID of the user, only if name is empty.
initUserName | Name of the user or empty
initProfileID | ID of the profile, if there is no name for it
initProfileName | Name of the profile or empty

Member Function Documentation

GeViAct_ChangeRightProfile GeViAct_ChangeRightProfile::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ChangeRightProfile::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile::aProfileID

ID of the profile, if there is no name for it.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile::aProfileName

Name of the profile or empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile::aUserID

ID of the user, only if name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile::aUserName

Name of the user or empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ChangeRightProfileEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ChangeRightProfileEventArgs (GeViAct_ChangeRightProfile^ initAction)
Create the EventArgs for handler of action 'Change right profile of a user'.

Properties

GeViClientID | aUserID
ID of the user, only if name is empty.
String^ | aUserName
Name of the user or empty.
Int32 | aProfileID
ID of the profile, if there is no name for it.
String^ | aProfileName
Name of the profile or empty.

Private Member Functions

GeViAct_ChangeRightProfileEventArgs ()

Detailed Description

EventArgs for handler of action 'Change right profile of a user'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs::GeViAct_ChangeRightProfileEventArgs ( ) [private]
GeViAct_ChangeRightProfileEventArgs::GeViAct_ChangeRightProfileEventArgs ( GeViAct_ChangeRightProfile^ initAction )

Create the EventArgs for handler of action 'Change right profile of a user'.

Parameters:
initAction Managed action 'Change right profile of a user'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs::aProfileID

ID of the profile, if there is no name for it.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs::aProfileName

Name of the profile or empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs::aUserID

ID of the user, only if name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs::aUserName

Name of the user or empty.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput Class Reference

  • SwitchControlActions
  • GeViAct_ClearAlarmFlagVideoInput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput Class Reference
Actions

Action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput:
[legend]

List of all members.

Public Member Functions

GeViAct_ClearAlarmFlagVideoInput (GeViVideoInputID initVideoInput)
Create the action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_ClearAlarmFlagVideoInput^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input.

Detailed Description

Action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

Constructor & Destructor Documentation

GeViAct_ClearAlarmFlagVideoInput::GeViAct_ClearAlarmFlagVideoInput ( GeViVideoInputID initVideoInput )

Create the action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

Parameters:
initVideoInput ID of video input

Member Function Documentation

GeViAct_ClearAlarmFlagVideoInput GeViAct_ClearAlarmFlagVideoInput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ClearAlarmFlagVideoInput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ClearAlarmFlagVideoInputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ClearAlarmFlagVideoInputEventArgs (GeViAct_ClearAlarmFlagVideoInput^ initAction)
Create the EventArgs for handler of action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

Properties

GeViVideoInputID aVideoInput
ID of video input.

Private Member Functions

GeViAct_ClearAlarmFlagVideoInputEventArgs ()

Detailed Description

EventArgs for handler of action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs::GeViAct_ClearAlarmFlagVideoInputEventArgs ( ) [private]
GeViAct_ClearAlarmFlagVideoInputEventArgs::GeViAct_ClearAlarmFlagVideoInputEventArgs ( GeViAct_ClearAlarmFlagVideoInput^ initAction )

Create the EventArgs for handler of action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

Parameters:
initAction Managed action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput Class Reference

  • SwitchControlActions
  • GeViAct_ClearAlarmFlagVideoOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput Class Reference
Actions

Action 'Clear the alarm flag of that video output'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput:
[legend]

List of all members.

Public Member Functions

GeViAct_ClearAlarmFlagVideoOutput (GeViVideoOutputID initVideoOutput)
Create the action 'Clear the alarm flag of that video output'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_ClearAlarmFlagVideoOutput^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aVideoOutput
Video output.

Detailed Description

Action 'Clear the alarm flag of that video output'.

Constructor & Destructor Documentation

GeViAct_ClearAlarmFlagVideoOutput::GeViAct_ClearAlarmFlagVideoOutput ( GeViVideoOutputID initVideoOutput )

Create the action 'Clear the alarm flag of that video output'.

Parameters:
initVideoOutput Video output

Member Function Documentation

GeViAct_ClearAlarmFlagVideoOutput GeViAct_ClearAlarmFlagVideoOutput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ClearAlarmFlagVideoOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput::aVideoOutput

Video output.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ClearAlarmFlagVideoOutputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ClearAlarmFlagVideoOutputEventArgs (GeViAct_ClearAlarmFlagVideoOutput^ initAction)
Create the EventArgs for handler of action 'Clear the alarm flag of that video output'.

Properties

GeViVideoOutputID aVideoOutput
Video output.

Private Member Functions

GeViAct_ClearAlarmFlagVideoOutputEventArgs ()

Detailed Description

EventArgs for handler of action 'Clear the alarm flag of that video output'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs::GeViAct_ClearAlarmFlagVideoOutputEventArgs ( ) [private]
GeViAct_ClearAlarmFlagVideoOutputEventArgs::GeViAct_ClearAlarmFlagVideoOutputEventArgs ( GeViAct_ClearAlarmFlagVideoOutput^ initAction )

Create the EventArgs for handler of action 'Clear the alarm flag of that video output'.

Parameters:
initAction Managed action 'Clear the alarm flag of that video output'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs::aVideoOutput

Video output.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput Class Reference

  • SwitchControlActions
  • GeViAct_ClearVideoOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput Class Reference
Actions

Action 'Clear that video output'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput:
[legend]

List of all members.

Public Member Functions

GeViAct_ClearVideoOutput (GeViVideoOutputID initVideoOutput)
Create the action 'Clear that video output'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_ClearVideoOutput^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aVideoOutput
Video output to switch.

Detailed Description

Action 'Clear that video output'.

Constructor & Destructor Documentation

GeViAct_ClearVideoOutput::GeViAct_ClearVideoOutput ( GeViVideoOutputID initVideoOutput )

Create the action 'Clear that video output'.

Parameters:
initVideoOutput Video output to switch

Member Function Documentation

GeViAct_ClearVideoOutput GeViAct_ClearVideoOutput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ClearVideoOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput::aVideoOutput

Video output to switch.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ClearVideoOutputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ClearVideoOutputEventArgs (GeViAct_ClearVideoOutput^ initAction)
Create the EventArgs for handler of action 'Clear that video output'.

Properties

GeViVideoOutputID aVideoOutput
Video output to switch.

Private Member Functions

GeViAct_ClearVideoOutputEventArgs ()

Detailed Description

EventArgs for handler of action 'Clear that video output'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs::GeViAct_ClearVideoOutputEventArgs ( ) [private]
GeViAct_ClearVideoOutputEventArgs::GeViAct_ClearVideoOutputEventArgs ( GeViAct_ClearVideoOutput^ initAction )

Create the EventArgs for handler of action 'Clear that video output'.

Parameters:
initAction Managed action 'Clear that video output'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs::aVideoOutput

Video output to switch.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact Class Reference

  • ContactBusActions
  • GeViAct_CloseContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact Class Reference
Actions

Action 'Close a contact'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact:
[legend]

List of all members.

Public Member Functions

GeViAct_CloseContact (Int32 initGlobalContactID)
Create the action 'Close a contact'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CloseContact^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aGlobalContactID
Global ID of that contact.

Detailed Description

Action 'Close a contact'.

Constructor & Destructor Documentation

GeViAct_CloseContact::GeViAct_CloseContact ( Int32 initGlobalContactID )

Create the action 'Close a contact'.

Parameters:
initGlobalContactID Global ID of that contact

Member Function Documentation

GeViAct_CloseContact GeViAct_CloseContact::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CloseContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact::aGlobalContactID

Global ID of that contact.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CloseContactEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CloseContactEventArgs (GeViAct_CloseContact^ initAction)
Create the EventArgs for handler of action 'Close a contact'.

Properties

Int32 aGlobalContactID
Global ID of that contact.

Private Member Functions

GeViAct_CloseContactEventArgs ()

Detailed Description

EventArgs for handler of action 'Close a contact'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs::GeViAct_CloseContactEventArgs ( ) [private]
GeViAct_CloseContactEventArgs::GeViAct_CloseContactEventArgs ( GeViAct_CloseContact^ initAction )

Create the EventArgs for handler of action 'Close a contact'.

Parameters:
initAction Managed action 'Close a contact'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs::aGlobalContactID

Global ID of that contact.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm Class Reference

  • AlarmControlActions
  • GeViAct_CopyActualAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm Class Reference
Actions

Action 'Copy actual alarm to an other monitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_CopyActualAlarm (GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText)
Create the action 'Copy actual alarm to an other monitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CopyActualAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aFrom
From which monitor group.
GeViMGID | aTo
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Automatic adaption of the instance ID of the alarm.
String^ | aAlarmText
Description.

Detailed Description

Action 'Copy actual alarm to an other monitor group'.

Constructor & Destructor Documentation

GeViAct_CopyActualAlarm::GeViAct_CopyActualAlarm | ( | GeViMGID | initFrom,
 |  | GeViMGID | initTo,
 |  | GeViClientID | initUserID,
 |  | GeViAlarmID | initAlarmID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Copy actual alarm to an other monitor group'.

Parameters:
initFrom | From which monitor group
initTo | To which monitor group
initUserID | Automatic adaption of the user, which has caused the move
initAlarmID | Automatic adaption of the instance ID of the alarm
initAlarmText | Description

Member Function Documentation

GeViAct_CopyActualAlarm GeViAct_CopyActualAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CopyActualAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm::aAlarmID

Automatic adaption of the instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm::aFrom

From which monitor group.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm::aTo

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CopyActualAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CopyActualAlarmEventArgs (GeViAct_CopyActualAlarm^ initAction)
Create the EventArgs for handler of action 'Copy actual alarm to an other monitor group'.

Properties

GeViMGID | aFrom
From which monitor group.
GeViMGID | aTo
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Automatic adaption of the instance ID of the alarm.
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_CopyActualAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Copy actual alarm to an other monitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs::GeViAct_CopyActualAlarmEventArgs ( ) [private]
GeViAct_CopyActualAlarmEventArgs::GeViAct_CopyActualAlarmEventArgs ( GeViAct_CopyActualAlarm^ initAction )

Create the EventArgs for handler of action 'Copy actual alarm to an other monitor group'.

Parameters:
initAction Managed action 'Copy actual alarm to an other monitor group'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs::aAlarmID

Automatic adaption of the instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs::aFrom

From which monitor group.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs::aTo

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance Class Reference

  • AlarmControlActions
  • GeViAct_CopyAlarmByInstance
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance Class Reference
Actions

Action 'Copy the alarm to an other monitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance:
[legend]

List of all members.

Public Member Functions

GeViAct_CopyAlarmByInstance (GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText)
Create the action 'Copy the alarm to an other monitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CopyAlarmByInstance^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aFrom
From which monitor group.
GeViMGID | aTo
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description.

Detailed Description

Action 'Copy the alarm to an other monitor group'.

Constructor & Destructor Documentation

GeViAct_CopyAlarmByInstance::GeViAct_CopyAlarmByInstance | ( | GeViMGID | initFrom,
 |  | GeViMGID | initTo,
 |  | GeViClientID | initUserID,
 |  | GeViAlarmID | initAlarmID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Copy the alarm to an other monitor group'.

Parameters:
initFrom | From which monitor group
initTo | To which monitor group
initUserID | Automatic adaption of the user, which has caused the move
initAlarmID | Instance ID of the alarm
initAlarmText | Description

Member Function Documentation

GeViAct_CopyAlarmByInstance GeViAct_CopyAlarmByInstance::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CopyAlarmByInstance::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance::aFrom

From which monitor group.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance::aTo

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CopyAlarmByInstanceEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CopyAlarmByInstanceEventArgs (GeViAct_CopyAlarmByInstance^ initAction)
Create the EventArgs for handler of action 'Copy the alarm to an other monitor group'.

Properties

GeViMGID | aFrom
From which monitor group.
GeViMGID | aTo
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_CopyAlarmByInstanceEventArgs ()

Detailed Description

EventArgs for handler of action 'Copy the alarm to an other monitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs::GeViAct_CopyAlarmByInstanceEventArgs ( ) [private]
GeViAct_CopyAlarmByInstanceEventArgs::GeViAct_CopyAlarmByInstanceEventArgs ( GeViAct_CopyAlarmByInstance^ initAction )

Create the EventArgs for handler of action 'Copy the alarm to an other monitor group'.

Parameters:
initAction Managed action 'Copy the alarm to an other monitor group'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs::aFrom

From which monitor group.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs::aTo

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor Class Reference

  • SwitchControlActions
  • GeViAct_CopyCameraOnMonitor
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor Class Reference
Actions

Action 'Copy a video input from one video output to another one.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor:
[legend]

List of all members.

Public Member Functions

GeViAct_CopyCameraOnMonitor (GeViVideoOutputID initVideoOutputFrom, GeViVideoOutputID initVideoOutputTo)
Create the action 'Copy a video input from one video output to another one.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CopyCameraOnMonitor^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aVideoOutputFrom
Video output to copy from.
GeViVideoOutputID | aVideoOutputTo
Video output to copy to.

Detailed Description

Action 'Copy a video input from one video output to another one.'.

Constructor & Destructor Documentation

GeViAct_CopyCameraOnMonitor::GeViAct_CopyCameraOnMonitor | ( | GeViVideoOutputID | initVideoOutputFrom,
 |  | GeViVideoOutputID | initVideoOutputTo
 | ) |  |

Create the action 'Copy a video input from one video output to another one.'.

Parameters:
initVideoOutputFrom | Video output to copy from
initVideoOutputTo | Video output to copy to

Member Function Documentation

GeViAct_CopyCameraOnMonitor GeViAct_CopyCameraOnMonitor::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CopyCameraOnMonitor::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor::aVideoOutputFrom

Video output to copy from.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor::aVideoOutputTo

Video output to copy to.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CopyCameraOnMonitorEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CopyCameraOnMonitorEventArgs (GeViAct_CopyCameraOnMonitor^ initAction)
Create the EventArgs for handler of action 'Copy a video input from one video output to another one.'.

Properties

GeViVideoOutputID | aVideoOutputFrom
Video output to copy from.
GeViVideoOutputID | aVideoOutputTo
Video output to copy to.

Private Member Functions

GeViAct_CopyCameraOnMonitorEventArgs ()

Detailed Description

EventArgs for handler of action 'Copy a video input from one video output to another one.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs::GeViAct_CopyCameraOnMonitorEventArgs ( ) [private]
GeViAct_CopyCameraOnMonitorEventArgs::GeViAct_CopyCameraOnMonitorEventArgs ( GeViAct_CopyCameraOnMonitor^ initAction )

Create the EventArgs for handler of action 'Copy a video input from one video output to another one.'.

Parameters:
initAction Managed action 'Copy a video input from one video output to another one.'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs::aVideoOutputFrom

Video output to copy from.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs::aVideoOutputTo

Video output to copy to.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch Class Reference

  • SwitchControlActions
  • GeViAct_CrossSwitch
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch Class Reference
Actions

Action 'Switch a video input on a video output'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch:
[legend]

List of all members.

Public Member Functions

GeViAct_CrossSwitch (GeViVideoInputID initVideoInput, GeViVideoOutputID initVideoOutput, GeViTSwitchMode initSwitchMode)
Create the action 'Switch a video input on a video output'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CrossSwitch^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input to switch (special values: 0 = last; -1/-2 = next/prev. relative to the actual video input.
GeViVideoOutputID | aVideoOutput
ID of video output to switch.
GeViTSwitchMode | aSwitchMode
switch mode: 0,2 = normal (command CP), 1 = (command KP); 3 = (command CT, disable teletext)

Detailed Description

Action 'Switch a video input on a video output'.

Constructor & Destructor Documentation

GeViAct_CrossSwitch::GeViAct_CrossSwitch | ( | GeViVideoInputID | initVideoInput,
 |  | GeViVideoOutputID | initVideoOutput,
 |  | GeViTSwitchMode | initSwitchMode
 | ) |  |

Create the action 'Switch a video input on a video output'.

Parameters:
initVideoInput | ID of video input to switch (special values: 0 = last; -1/-2 = next/prev. relative to the actual video input
initVideoOutput | ID of video output to switch
initSwitchMode | switch mode: 0,2 = normal (command CP), 1 = (command KP); 3 = (command CT, disable teletext)

Member Function Documentation

GeViAct_CrossSwitch GeViAct_CrossSwitch::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CrossSwitch::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViTSwitchMode GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch::aSwitchMode

switch mode: 0,2 = normal (command CP), 1 = (command KP); 3 = (command CT, disable teletext)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch::aVideoInput

ID of video input to switch (special values: 0 = last; -1/-2 = next/prev. relative to the actual video input.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch::aVideoOutput

ID of video output to switch.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CrossSwitchEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CrossSwitchEventArgs (GeViAct_CrossSwitch^ initAction)
Create the EventArgs for handler of action 'Switch a video input on a video output'.

Properties

GeViVideoInputID | aVideoInput
ID of video input to switch (special values: 0 = last; -1/-2 = next/prev. relative to the actual video input.
GeViVideoOutputID | aVideoOutput
ID of video output to switch.
GeViTSwitchMode | aSwitchMode
switch mode: 0,2 = normal (command CP), 1 = (command KP); 3 = (command CT, disable teletext)

Private Member Functions

GeViAct_CrossSwitchEventArgs ()

Detailed Description

EventArgs for handler of action 'Switch a video input on a video output'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs::GeViAct_CrossSwitchEventArgs ( ) [private]
GeViAct_CrossSwitchEventArgs::GeViAct_CrossSwitchEventArgs ( GeViAct_CrossSwitch^ initAction )

Create the EventArgs for handler of action 'Switch a video input on a video output'.

Parameters:
initAction Managed action 'Switch a video input on a video output'.

Property Documentation

GeViTSwitchMode GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs::aSwitchMode

switch mode: 0,2 = normal (command CP), 1 = (command KP); 3 = (command CT, disable teletext)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs::aVideoInput

ID of video input to switch (special values: 0 = last; -1/-2 = next/prev. relative to the actual video input.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs::aVideoOutput

ID of video output to switch.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm Class Reference

  • SwitchControlActions
  • GeViAct_CrossSwitchWithAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm Class Reference
Actions

Action 'Switch a video input on a video output'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_CrossSwitchWithAlarm (GeViVideoInputID initVideoInput, GeViVideoOutputID initVideoOutput)
Create the action 'Switch a video input on a video output'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_CrossSwitchWithAlarm^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input to switch.
GeViVideoOutputID | aVideoOutput
ID of video output to switch.

Detailed Description

Action 'Switch a video input on a video output'.

Constructor & Destructor Documentation

GeViAct_CrossSwitchWithAlarm::GeViAct_CrossSwitchWithAlarm | ( | GeViVideoInputID | initVideoInput,
 |  | GeViVideoOutputID | initVideoOutput
 | ) |  |

Create the action 'Switch a video input on a video output'.

Parameters:
initVideoInput | ID of video input to switch
initVideoOutput | ID of video output to switch

Member Function Documentation

GeViAct_CrossSwitchWithAlarm GeViAct_CrossSwitchWithAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CrossSwitchWithAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm::aVideoInput

ID of video input to switch.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm::aVideoOutput

ID of video output to switch.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CrossSwitchWithAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CrossSwitchWithAlarmEventArgs (GeViAct_CrossSwitchWithAlarm^ initAction)
Create the EventArgs for handler of action 'Switch a video input on a video output'.

Properties

GeViVideoInputID | aVideoInput
ID of video input to switch.
GeViVideoOutputID | aVideoOutput
ID of video output to switch.

Private Member Functions

GeViAct_CrossSwitchWithAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Switch a video input on a video output'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs::GeViAct_CrossSwitchWithAlarmEventArgs ( ) [private]
GeViAct_CrossSwitchWithAlarmEventArgs::GeViAct_CrossSwitchWithAlarmEventArgs ( GeViAct_CrossSwitchWithAlarm^ initAction )

Create the EventArgs for handler of action 'Switch a video input on a video output'.

Parameters:
initAction Managed action 'Switch a video input on a video output'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs::aVideoInput

ID of video input to switch.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs::aVideoOutput

ID of video output to switch.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction Class Reference

  • SystemActions
  • GeViAct_CustomAction
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction Class Reference
Actions

Action 'Customized action'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction:
[legend]

List of all members.

Public Member Functions

GeViAct_CustomAction (Int32 initCustomInt, String^ initCustomText)
Create the action 'Customized action'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_CustomAction^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aCustomInt
INT 32.
String^ | aCustomText
Text.

Detailed Description

Action 'Customized action'.

Constructor & Destructor Documentation

GeViAct_CustomAction::GeViAct_CustomAction | ( | Int32 | initCustomInt,
 |  | String^ | initCustomText
 | ) |  |

Create the action 'Customized action'.

Parameters:
initCustomInt | INT 32
initCustomText | Text

Member Function Documentation

GeViAct_CustomAction GeViAct_CustomAction::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_CustomAction::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction::aCustomInt

INT 32.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction::aCustomText

Text.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_CustomActionEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_CustomActionEventArgs (GeViAct_CustomAction^ initAction)
Create the EventArgs for handler of action 'Customized action'.

Properties

Int32 | aCustomInt
INT 32.
String^ | aCustomText
Text.

Private Member Functions

GeViAct_CustomActionEventArgs ()

Detailed Description

EventArgs for handler of action 'Customized action'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs::GeViAct_CustomActionEventArgs ( ) [private]
GeViAct_CustomActionEventArgs::GeViAct_CustomActionEventArgs ( GeViAct_CustomAction^ initAction )

Create the EventArgs for handler of action 'Customized action'.

Parameters:
initAction Managed action 'Customized action'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs::aCustomInt

INT 32.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs::aCustomText

Text.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure Class Reference

  • DataBaseActions
  • GeViAct_DataBaseFailure
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure Class Reference
Actions

Action 'Database failure.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure:
[legend]

List of all members.

Public Member Functions

GeViAct_DataBaseFailure ()
Create the action 'Database failure.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_DataBaseFailure^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Detailed Description

Action 'Database failure.'.

Constructor & Destructor Documentation

GeViAct_DataBaseFailure::GeViAct_DataBaseFailure ( )

Create the action 'Database failure.'.

Member Function Documentation

GeViAct_DataBaseFailure GeViAct_DataBaseFailure::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_DataBaseFailure::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_DataBaseFailureEventArgs
Public Member Functions | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_DataBaseFailureEventArgs (GeViAct_DataBaseFailure^ initAction)
Create the EventArgs for handler of action 'Database failure.'.

Private Member Functions

GeViAct_DataBaseFailureEventArgs ()

Detailed Description

EventArgs for handler of action 'Database failure.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs::GeViAct_DataBaseFailureEventArgs ( ) [private]
GeViAct_DataBaseFailureEventArgs::GeViAct_DataBaseFailureEventArgs ( GeViAct_DataBaseFailure^ initAction )

Create the EventArgs for handler of action 'Database failure.'.

Parameters:
initAction Managed action 'Database failure.'.
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing Class Reference

  • DataBaseActions
  • GeViAct_DataBaseMissing
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing Class Reference
Actions

Action 'Missing database'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing:
[legend]

List of all members.

Public Member Functions

GeViAct_DataBaseMissing ()
Create the action 'Missing database'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_DataBaseMissing^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Detailed Description

Action 'Missing database'.

Constructor & Destructor Documentation

GeViAct_DataBaseMissing::GeViAct_DataBaseMissing ( )

Create the action 'Missing database'.

Member Function Documentation

GeViAct_DataBaseMissing GeViAct_DataBaseMissing::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_DataBaseMissing::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_DataBaseMissingEventArgs
Public Member Functions | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_DataBaseMissingEventArgs (GeViAct_DataBaseMissing^ initAction)
Create the EventArgs for handler of action 'Missing database'.

Private Member Functions

GeViAct_DataBaseMissingEventArgs ()

Detailed Description

EventArgs for handler of action 'Missing database'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs::GeViAct_DataBaseMissingEventArgs ( ) [private]
GeViAct_DataBaseMissingEventArgs::GeViAct_DataBaseMissingEventArgs ( GeViAct_DataBaseMissing^ initAction )

Create the EventArgs for handler of action 'Missing database'.

Parameters:
initAction Managed action 'Missing database'.
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady Class Reference

  • DataBaseActions
  • GeViAct_DataBaseReady
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady Class Reference
Actions

Action 'The database is ready.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady:
[legend]

List of all members.

Public Member Functions

GeViAct_DataBaseReady ()
Create the action 'The database is ready.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_DataBaseReady^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Detailed Description

Action 'The database is ready.'.

Constructor & Destructor Documentation

GeViAct_DataBaseReady::GeViAct_DataBaseReady ( )

Create the action 'The database is ready.'.

Member Function Documentation

GeViAct_DataBaseReady GeViAct_DataBaseReady::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_DataBaseReady::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_DataBaseReadyEventArgs
Public Member Functions | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_DataBaseReadyEventArgs (GeViAct_DataBaseReady^ initAction)
Create the EventArgs for handler of action 'The database is ready.'.

Private Member Functions

GeViAct_DataBaseReadyEventArgs ()

Detailed Description

EventArgs for handler of action 'The database is ready.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs::GeViAct_DataBaseReadyEventArgs ( ) [private]
GeViAct_DataBaseReadyEventArgs::GeViAct_DataBaseReadyEventArgs ( GeViAct_DataBaseReady^ initAction )

Create the EventArgs for handler of action 'The database is ready.'.

Parameters:
initAction Managed action 'The database is ready.'.
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp Class Reference

  • CameraControlActions
  • GeViAct_DefaultPosCallUp
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp Class Reference
Actions

Action 'Move camera to a base position'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp:
[legend]

List of all members.

Public Member Functions

GeViAct_DefaultPosCallUp (GeViVideoInputID initVideoInput)
Create the action 'Move camera to a base position'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_DefaultPosCallUp^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall move to the base position.

Detailed Description

Action 'Move camera to a base position'.

Constructor & Destructor Documentation

GeViAct_DefaultPosCallUp::GeViAct_DefaultPosCallUp ( GeViVideoInputID initVideoInput )

Create the action 'Move camera to a base position'.

Parameters:
initVideoInput ID of the camera, which shall move to the base position

Member Function Documentation

GeViAct_DefaultPosCallUp GeViAct_DefaultPosCallUp::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_DefaultPosCallUp::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp::aVideoInput

ID of the camera, which shall move to the base position.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_DefaultPosCallUpEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_DefaultPosCallUpEventArgs (GeViAct_DefaultPosCallUp^ initAction)
Create the EventArgs for handler of action 'Move camera to a base position'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which shall move to the base position.

Private Member Functions

GeViAct_DefaultPosCallUpEventArgs ()

Detailed Description

EventArgs for handler of action 'Move camera to a base position'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs::GeViAct_DefaultPosCallUpEventArgs ( ) [private]
GeViAct_DefaultPosCallUpEventArgs::GeViAct_DefaultPosCallUpEventArgs ( GeViAct_DefaultPosCallUp^ initAction )

Create the EventArgs for handler of action 'Move camera to a base position'.

Parameters:
initAction Managed action 'Move camera to a base position'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs::aVideoInput

ID of the camera, which shall move to the base position.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear Class Reference

  • CameraControlActions
  • GeViAct_DefaultPosClear
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear Class Reference
Actions

Action 'Clear base position of a camera.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear:
[legend]

List of all members.

Public Member Functions

GeViAct_DefaultPosClear (GeViVideoInputID initVideoInput)
Create the action 'Clear base position of a camera.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_DefaultPosClear^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which base position shall be deleted.

Detailed Description

Action 'Clear base position of a camera.'.

Constructor & Destructor Documentation

GeViAct_DefaultPosClear::GeViAct_DefaultPosClear ( GeViVideoInputID initVideoInput )

Create the action 'Clear base position of a camera.'.

Parameters:
initVideoInput ID of the camera, which base position shall be deleted

Member Function Documentation

GeViAct_DefaultPosClear GeViAct_DefaultPosClear::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_DefaultPosClear::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear::aVideoInput

ID of the camera, which base position shall be deleted.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_DefaultPosClearEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_DefaultPosClearEventArgs (GeViAct_DefaultPosClear^ initAction)
Create the EventArgs for handler of action 'Clear base position of a camera.'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which base position shall be deleted.

Private Member Functions

GeViAct_DefaultPosClearEventArgs ()

Detailed Description

EventArgs for handler of action 'Clear base position of a camera.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs::GeViAct_DefaultPosClearEventArgs ( ) [private]
GeViAct_DefaultPosClearEventArgs::GeViAct_DefaultPosClearEventArgs ( GeViAct_DefaultPosClear^ initAction )

Create the EventArgs for handler of action 'Clear base position of a camera.'.

Parameters:
initAction Managed action 'Clear base position of a camera.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs::aVideoInput

ID of the camera, which base position shall be deleted.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave Class Reference

  • CameraControlActions
  • GeViAct_DefaultPosSave
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave Class Reference
Actions

Action 'Save the base position of a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave:
[legend]

List of all members.

Public Member Functions

GeViAct_DefaultPosSave (GeViVideoInputID initVideoInput)
Create the action 'Save the base position of a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_DefaultPosSave^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which position shall be saved.

Detailed Description

Action 'Save the base position of a camera'.

Constructor & Destructor Documentation

GeViAct_DefaultPosSave::GeViAct_DefaultPosSave ( GeViVideoInputID initVideoInput )

Create the action 'Save the base position of a camera'.

Parameters:
initVideoInput ID of the camera, which position shall be saved

Member Function Documentation

GeViAct_DefaultPosSave GeViAct_DefaultPosSave::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_DefaultPosSave::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave::aVideoInput

ID of the camera, which position shall be saved.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_DefaultPosSaveEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_DefaultPosSaveEventArgs (GeViAct_DefaultPosSave^ initAction)
Create the EventArgs for handler of action 'Save the base position of a camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which position shall be saved.

Private Member Functions

GeViAct_DefaultPosSaveEventArgs ()

Detailed Description

EventArgs for handler of action 'Save the base position of a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs::GeViAct_DefaultPosSaveEventArgs ( ) [private]
GeViAct_DefaultPosSaveEventArgs::GeViAct_DefaultPosSaveEventArgs ( GeViAct_DefaultPosSave^ initAction )

Create the EventArgs for handler of action 'Save the base position of a camera'.

Parameters:
initAction Managed action 'Save the base position of a camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs::aVideoInput

ID of the camera, which position shall be saved.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser Class Reference

  • SystemActions
  • GeViAct_DisconnectUser
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser Class Reference
Actions

Action 'Explizit logoff of a user'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser:
[legend]

List of all members.

Public Member Functions

GeViAct_DisconnectUser (GeViClientID initUserID, String^ initUserName, GeViClientID initAdminID, String^ initReason)
Create the action 'Explizit logoff of a user'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_DisconnectUser^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aUserID
ID of the user, only if name is empty.
String^ | aUserName
Name of the user or empty.
GeViClientID | aAdminID
Automatic adaption of ID of the administrator, who is logging of the user.
String^ | aReason
Reason for logoff.

Detailed Description

Action 'Explizit logoff of a user'.

Constructor & Destructor Documentation

GeViAct_DisconnectUser::GeViAct_DisconnectUser | ( | GeViClientID | initUserID,
 |  | String^ | initUserName,
 |  | GeViClientID | initAdminID,
 |  | String^ | initReason
 | ) |  |

Create the action 'Explizit logoff of a user'.

Parameters:
initUserID | ID of the user, only if name is empty.
initUserName | Name of the user or empty
initAdminID | Automatic adaption of ID of the administrator, who is logging of the user
initReason | Reason for logoff

Member Function Documentation

GeViAct_DisconnectUser GeViAct_DisconnectUser::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_DisconnectUser::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser::aAdminID

Automatic adaption of ID of the administrator, who is logging of the user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser::aReason

Reason for logoff.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser::aUserID

ID of the user, only if name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser::aUserName

Name of the user or empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_DisconnectUserEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_DisconnectUserEventArgs (GeViAct_DisconnectUser^ initAction)
Create the EventArgs for handler of action 'Explizit logoff of a user'.

Properties

GeViClientID | aUserID
ID of the user, only if name is empty.
String^ | aUserName
Name of the user or empty.
GeViClientID | aAdminID
Automatic adaption of ID of the administrator, who is logging of the user.
String^ | aReason
Reason for logoff.

Private Member Functions

GeViAct_DisconnectUserEventArgs ()

Detailed Description

EventArgs for handler of action 'Explizit logoff of a user'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs::GeViAct_DisconnectUserEventArgs ( ) [private]
GeViAct_DisconnectUserEventArgs::GeViAct_DisconnectUserEventArgs ( GeViAct_DisconnectUser^ initAction )

Create the EventArgs for handler of action 'Explizit logoff of a user'.

Parameters:
initAction Managed action 'Explizit logoff of a user'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs::aAdminID

Automatic adaption of ID of the administrator, who is logging of the user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs::aReason

Reason for logoff.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs::aUserID

ID of the user, only if name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs::aUserName

Name of the user or empty.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation Class Reference

  • SystemActions
  • GeViAct_EventRelation
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation Class Reference
Actions

Action 'Event relation was triggered'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation:
[legend]

List of all members.

Public Member Functions

GeViAct_EventRelation (Int32 initEventRelationTypeID, String^ initEventRelationName)
Create the action 'Event relation was triggered'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_EventRelation^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aEventRelationTypeID
ID of relation typ; Necessary, if the name is empty, otherwise it will be adapted.
String^ | aEventRelationName
Name of the event respective empty.

Detailed Description

Action 'Event relation was triggered'.

Constructor & Destructor Documentation

GeViAct_EventRelation::GeViAct_EventRelation | ( | Int32 | initEventRelationTypeID,
 |  | String^ | initEventRelationName
 | ) |  |

Create the action 'Event relation was triggered'.

Parameters:
initEventRelationTypeID | ID of relation typ; Necessary, if the name is empty, otherwise it will be adapted.
initEventRelationName | Name of the event respective empty

Member Function Documentation

GeViAct_EventRelation GeViAct_EventRelation::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_EventRelation::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation::aEventRelationName

Name of the event respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation::aEventRelationTypeID

ID of relation typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_EventRelationEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_EventRelationEventArgs (GeViAct_EventRelation^ initAction)
Create the EventArgs for handler of action 'Event relation was triggered'.

Properties

Int32 | aEventRelationTypeID
ID of relation typ; Necessary, if the name is empty, otherwise it will be adapted.
String^ | aEventRelationName
Name of the event respective empty.

Private Member Functions

GeViAct_EventRelationEventArgs ()

Detailed Description

EventArgs for handler of action 'Event relation was triggered'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs::GeViAct_EventRelationEventArgs ( ) [private]
GeViAct_EventRelationEventArgs::GeViAct_EventRelationEventArgs ( GeViAct_EventRelation^ initAction )

Create the EventArgs for handler of action 'Event relation was triggered'.

Parameters:
initAction Managed action 'Event relation was triggered'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs::aEventRelationName

Name of the event respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs::aEventRelationTypeID

ID of relation typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted Class Reference

  • SystemActions
  • GeViAct_EventStarted
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted Class Reference
Actions

Action 'Start of event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted:
[legend]

List of all members.

Public Member Functions

GeViAct_EventStarted (GeViEventTypeID initEventTypeID, GeViEventID initEventID, String^ initEventName)
Create the action 'Start of event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_EventStarted^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViEventTypeID | aEventTypeID
ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
GeViEventID | aEventID
Instance Id of the event.
String^ | aEventName
Name of event.

Detailed Description

Action 'Start of event'.

Constructor & Destructor Documentation

GeViAct_EventStarted::GeViAct_EventStarted | ( | GeViEventTypeID | initEventTypeID,
 |  | GeViEventID | initEventID,
 |  | String^ | initEventName
 | ) |  |

Create the action 'Start of event'.

Parameters:
initEventTypeID | ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
initEventID | Instance Id of the event
initEventName | Name of event

Member Function Documentation

GeViAct_EventStarted GeViAct_EventStarted::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_EventStarted::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted::aEventID

Instance Id of the event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted::aEventName

Name of event.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted::aEventTypeID

ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_EventStartedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_EventStartedEventArgs (GeViAct_EventStarted^ initAction)
Create the EventArgs for handler of action 'Start of event'.

Properties

GeViEventTypeID | aEventTypeID
ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
GeViEventID | aEventID
Instance Id of the event.
String^ | aEventName
Name of event.

Private Member Functions

GeViAct_EventStartedEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs::GeViAct_EventStartedEventArgs ( ) [private]
GeViAct_EventStartedEventArgs::GeViAct_EventStartedEventArgs ( GeViAct_EventStarted^ initAction )

Create the EventArgs for handler of action 'Start of event'.

Parameters:
initAction Managed action 'Start of event'.

Property Documentation

GeViEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs::aEventID

Instance Id of the event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs::aEventName

Name of event.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs::aEventTypeID

ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped Class Reference

  • SystemActions
  • GeViAct_EventStopped
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped Class Reference
Actions

Action 'Stopp of event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped:
[legend]

List of all members.

Public Member Functions

GeViAct_EventStopped (GeViEventTypeID initEventTypeID, GeViEventID initEventID, String^ initEventName)
Create the action 'Stopp of event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_EventStopped^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViEventTypeID | aEventTypeID
ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
GeViEventID | aEventID
Instance ID of the event.
String^ | aEventName
Name of the event respective empty.

Detailed Description

Action 'Stopp of event'.

Constructor & Destructor Documentation

GeViAct_EventStopped::GeViAct_EventStopped | ( | GeViEventTypeID | initEventTypeID,
 |  | GeViEventID | initEventID,
 |  | String^ | initEventName
 | ) |  |

Create the action 'Stopp of event'.

Parameters:
initEventTypeID | ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
initEventID | Instance ID of the event
initEventName | Name of the event respective empty

Member Function Documentation

GeViAct_EventStopped GeViAct_EventStopped::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_EventStopped::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped::aEventID

Instance ID of the event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped::aEventName

Name of the event respective empty.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped::aEventTypeID

ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_EventStoppedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_EventStoppedEventArgs (GeViAct_EventStopped^ initAction)
Create the EventArgs for handler of action 'Stopp of event'.

Properties

GeViEventTypeID | aEventTypeID
ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
GeViEventID | aEventID
Instance ID of the event.
String^ | aEventName
Name of the event respective empty.

Private Member Functions

GeViAct_EventStoppedEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp of event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs::GeViAct_EventStoppedEventArgs ( ) [private]
GeViAct_EventStoppedEventArgs::GeViAct_EventStoppedEventArgs ( GeViAct_EventStopped^ initAction )

Create the EventArgs for handler of action 'Stopp of event'.

Parameters:
initAction Managed action 'Stopp of event'.

Property Documentation

GeViEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs::aEventID

Instance ID of the event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs::aEventName

Name of the event respective empty.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs::aEventTypeID

ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn Class Reference

  • CameraControlActions
  • GeViAct_FastetModeOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn Class Reference
Actions

Action 'Turn on the fast mode'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn:
[legend]

List of all members.

Public Member Functions

GeViAct_FastetModeOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on the fast mode'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_FastetModeOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of input, where the fast mode shall be activated.

Detailed Description

Action 'Turn on the fast mode'.

Constructor & Destructor Documentation

GeViAct_FastetModeOn::GeViAct_FastetModeOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on the fast mode'.

Parameters:
initVideoInput ID of input, where the fast mode shall be activated

Member Function Documentation

GeViAct_FastetModeOn GeViAct_FastetModeOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_FastetModeOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn::aVideoInput

ID of input, where the fast mode shall be activated.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_FastetModeOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_FastetModeOnEventArgs (GeViAct_FastetModeOn^ initAction)
Create the EventArgs for handler of action 'Turn on the fast mode'.

Properties

GeViVideoInputID aVideoInput
ID of input, where the fast mode shall be activated.

Private Member Functions

GeViAct_FastetModeOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the fast mode'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs::GeViAct_FastetModeOnEventArgs ( ) [private]
GeViAct_FastetModeOnEventArgs::GeViAct_FastetModeOnEventArgs ( GeViAct_FastetModeOn^ initAction )

Create the EventArgs for handler of action 'Turn on the fast mode'.

Parameters:
initAction Managed action 'Turn on the fast mode'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs::aVideoInput

ID of input, where the fast mode shall be activated.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar Class Reference

  • CameraControlActions
  • GeViAct_FocusFar
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar Class Reference
Actions

Action 'Set camera focus farer'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar:
[legend]

List of all members.

Public Member Functions

GeViAct_FocusFar (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Set camera focus farer'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_FocusFar^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input to set farer.
Int32 | aTemp
Speed of focus change (0 = standard)

Detailed Description

Action 'Set camera focus farer'.

Constructor & Destructor Documentation

GeViAct_FocusFar::GeViAct_FocusFar | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Set camera focus farer'.

Parameters:
initVideoInput | ID of video input to set farer
initTemp | Speed of focus change (0 = standard)

Member Function Documentation

GeViAct_FocusFar GeViAct_FocusFar::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_FocusFar::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar::aTemp

Speed of focus change (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar::aVideoInput

ID of video input to set farer.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_FocusFarEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_FocusFarEventArgs (GeViAct_FocusFar^ initAction)
Create the EventArgs for handler of action 'Set camera focus farer'.

Properties

GeViVideoInputID | aVideoInput
ID of video input to set farer.
Int32 | aTemp
Speed of focus change (0 = standard)

Private Member Functions

GeViAct_FocusFarEventArgs ()

Detailed Description

EventArgs for handler of action 'Set camera focus farer'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs::GeViAct_FocusFarEventArgs ( ) [private]
GeViAct_FocusFarEventArgs::GeViAct_FocusFarEventArgs ( GeViAct_FocusFar^ initAction )

Create the EventArgs for handler of action 'Set camera focus farer'.

Parameters:
initAction Managed action 'Set camera focus farer'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs::aTemp

Speed of focus change (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs::aVideoInput

ID of video input to set farer.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear Class Reference

  • CameraControlActions
  • GeViAct_FocusNear
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear Class Reference
Actions

Action 'Set camera focus nearer'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear:
[legend]

List of all members.

Public Member Functions

GeViAct_FocusNear (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Set camera focus nearer'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_FocusNear^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input to set nearer.
Int32 | aTemp
Speed of focus change (0 = standard)

Detailed Description

Action 'Set camera focus nearer'.

Constructor & Destructor Documentation

GeViAct_FocusNear::GeViAct_FocusNear | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Set camera focus nearer'.

Parameters:
initVideoInput | ID of video input to set nearer
initTemp | Speed of focus change (0 = standard)

Member Function Documentation

GeViAct_FocusNear GeViAct_FocusNear::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_FocusNear::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear::aTemp

Speed of focus change (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear::aVideoInput

ID of video input to set nearer.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_FocusNearEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_FocusNearEventArgs (GeViAct_FocusNear^ initAction)
Create the EventArgs for handler of action 'Set camera focus nearer'.

Properties

GeViVideoInputID | aVideoInput
ID of video input to set nearer.
Int32 | aTemp
Speed of focus change (0 = standard)

Private Member Functions

GeViAct_FocusNearEventArgs ()

Detailed Description

EventArgs for handler of action 'Set camera focus nearer'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs::GeViAct_FocusNearEventArgs ( ) [private]
GeViAct_FocusNearEventArgs::GeViAct_FocusNearEventArgs ( GeViAct_FocusNear^ initAction )

Create the EventArgs for handler of action 'Set camera focus nearer'.

Parameters:
initAction Managed action 'Set camera focus nearer'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs::aTemp

Speed of focus change (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs::aVideoInput

ID of video input to set nearer.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop Class Reference

  • CameraControlActions
  • GeViAct_FocusStop
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop Class Reference
Actions

Action 'Stopp the focussing of a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop:
[legend]

List of all members.

Public Member Functions

GeViAct_FocusStop (GeViVideoInputID initVideoInput)
Create the action 'Stopp the focussing of a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_FocusStop^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input which focussing shall be stopped.

Detailed Description

Action 'Stopp the focussing of a camera'.

Constructor & Destructor Documentation

GeViAct_FocusStop::GeViAct_FocusStop ( GeViVideoInputID initVideoInput )

Create the action 'Stopp the focussing of a camera'.

Parameters:
initVideoInput ID of video input which focussing shall be stopped

Member Function Documentation

GeViAct_FocusStop GeViAct_FocusStop::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_FocusStop::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop::aVideoInput

ID of video input which focussing shall be stopped.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_FocusStopEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_FocusStopEventArgs (GeViAct_FocusStop^ initAction)
Create the EventArgs for handler of action 'Stopp the focussing of a camera'.

Properties

GeViVideoInputID aVideoInput
ID of video input which focussing shall be stopped.

Private Member Functions

GeViAct_FocusStopEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp the focussing of a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs::GeViAct_FocusStopEventArgs ( ) [private]
GeViAct_FocusStopEventArgs::GeViAct_FocusStopEventArgs ( GeViAct_FocusStop^ initAction )

Create the EventArgs for handler of action 'Stopp the focussing of a camera'.

Parameters:
initAction Managed action 'Stopp the focussing of a camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs::aVideoInput

ID of video input which focussing shall be stopped.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected Class Reference

  • GeviScopeActions
  • GeViAct_GeviScopeServerConnected
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected Class Reference
Actions

Action 'GeviScope server connected'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected:
[legend]

List of all members.

Public Member Functions

GeViAct_GeviScopeServerConnected (String^ initGscServerName)
Create the action 'GeviScope server connected'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_GeviScopeServerConnected^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aGscServerName
Name of the GeviScope server.

Detailed Description

Action 'GeviScope server connected'.

Constructor & Destructor Documentation

GeViAct_GeviScopeServerConnected::GeViAct_GeviScopeServerConnected ( String^ initGscServerName )

Create the action 'GeviScope server connected'.

Parameters:
initGscServerName Name of the GeviScope server

Member Function Documentation

GeViAct_GeviScopeServerConnected GeViAct_GeviScopeServerConnected::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_GeviScopeServerConnected::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected::aGscServerName

Name of the GeviScope server.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_GeviScopeServerConnectedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_GeviScopeServerConnectedEventArgs (GeViAct_GeviScopeServerConnected^ initAction)
Create the EventArgs for handler of action 'GeviScope server connected'.

Properties

String^ aGscServerName
Name of the GeviScope server.

Private Member Functions

GeViAct_GeviScopeServerConnectedEventArgs ()

Detailed Description

EventArgs for handler of action 'GeviScope server connected'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs::GeViAct_GeviScopeServerConnectedEventArgs ( ) [private]
GeViAct_GeviScopeServerConnectedEventArgs::GeViAct_GeviScopeServerConnectedEventArgs ( GeViAct_GeviScopeServerConnected^ initAction )

Create the EventArgs for handler of action 'GeviScope server connected'.

Parameters:
initAction Managed action 'GeviScope server connected'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs::aGscServerName

Name of the GeviScope server.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed Class Reference

  • GeviScopeActions
  • GeViAct_GeviScopeServerConnectionFailed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed Class Reference
Actions

Action 'Open GeviScope connection failed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed:
[legend]

List of all members.

Public Member Functions

GeViAct_GeviScopeServerConnectionFailed (String^ initGscServerName)
Create the action 'Open GeviScope connection failed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_GeviScopeServerConnectionFailed^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aGscServerName
Name of the GeviScope server.

Detailed Description

Action 'Open GeviScope connection failed'.

Constructor & Destructor Documentation

GeViAct_GeviScopeServerConnectionFailed::GeViAct_GeviScopeServerConnectionFailed ( String^ initGscServerName )

Create the action 'Open GeviScope connection failed'.

Parameters:
initGscServerName Name of the GeviScope server

Member Function Documentation

GeViAct_GeviScopeServerConnectionFailed GeViAct_GeviScopeServerConnectionFailed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_GeviScopeServerConnectionFailed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed::aGscServerName

Name of the GeviScope server.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_GeviScopeServerConnectionFailedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_GeviScopeServerConnectionFailedEventArgs (GeViAct_GeviScopeServerConnectionFailed^ initAction)
Create the EventArgs for handler of action 'Open GeviScope connection failed'.

Properties

String^ aGscServerName
Name of the GeviScope server.

Private Member Functions

GeViAct_GeviScopeServerConnectionFailedEventArgs ()

Detailed Description

EventArgs for handler of action 'Open GeviScope connection failed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs::GeViAct_GeviScopeServerConnectionFailedEventArgs ( ) [private]
GeViAct_GeviScopeServerConnectionFailedEventArgs::GeViAct_GeviScopeServerConnectionFailedEventArgs ( GeViAct_GeviScopeServerConnectionFailed^ initAction )

Create the EventArgs for handler of action 'Open GeviScope connection failed'.

Parameters:
initAction Managed action 'Open GeviScope connection failed'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs::aGscServerName

Name of the GeviScope server.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected Class Reference

  • GeviScopeActions
  • GeViAct_GeviScopeServerDisconnected
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected Class Reference
Actions

Action 'GeviScope disconnected'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected:
[legend]

List of all members.

Public Member Functions

GeViAct_GeviScopeServerDisconnected (String^ initGscServerName)
Create the action 'GeviScope disconnected'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_GeviScopeServerDisconnected^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aGscServerName
Name of the GeviScope server.

Detailed Description

Action 'GeviScope disconnected'.

Constructor & Destructor Documentation

GeViAct_GeviScopeServerDisconnected::GeViAct_GeviScopeServerDisconnected ( String^ initGscServerName )

Create the action 'GeviScope disconnected'.

Parameters:
initGscServerName Name of the GeviScope server

Member Function Documentation

GeViAct_GeviScopeServerDisconnected GeViAct_GeviScopeServerDisconnected::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_GeviScopeServerDisconnected::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected::aGscServerName

Name of the GeviScope server.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_GeviScopeServerDisconnectedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_GeviScopeServerDisconnectedEventArgs (GeViAct_GeviScopeServerDisconnected^ initAction)
Create the EventArgs for handler of action 'GeviScope disconnected'.

Properties

String^ aGscServerName
Name of the GeviScope server.

Private Member Functions

GeViAct_GeviScopeServerDisconnectedEventArgs ()

Detailed Description

EventArgs for handler of action 'GeviScope disconnected'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs::GeViAct_GeviScopeServerDisconnectedEventArgs ( ) [private]
GeViAct_GeviScopeServerDisconnectedEventArgs::GeViAct_GeviScopeServerDisconnectedEventArgs ( GeViAct_GeviScopeServerDisconnected^ initAction )

Create the EventArgs for handler of action 'GeviScope disconnected'.

Parameters:
initAction Managed action 'GeviScope disconnected'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs::aGscServerName

Name of the GeviScope server.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_GscActionEventArgs
Public Member Functions | Public Attributes | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs Class Reference

List of all members.

Public Member Functions

GeViAct_GscActionEventArgs (GscAction^ act)
Create the EventArgs to handle received GeViSCOPE Actions.

Public Attributes

GscAction^ m_GscAction

Private Member Functions

GeViAct_GscActionEventArgs ()

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs::GeViAct_GscActionEventArgs ( ) [private]

Member Data Documentation

GscAction ^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs::m_GscAction
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm Class Reference

  • SystemActions
  • GeViAct_HistoricalAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm Class Reference
Actions

Action 'Historical alarm message.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_HistoricalAlarm (GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViTGeViDateTime initTimeStamp)
Create the action 'Historical alarm message.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_HistoricalAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of alarm type.
GeViTGeViDateTime aTimeStamp
Time stamp.

Detailed Description

Action 'Historical alarm message.'.

Constructor & Destructor Documentation

GeViAct_HistoricalAlarm::GeViAct_HistoricalAlarm | ( | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | GeViTGeViDateTime | initTimeStamp
 | ) |  |

Create the action 'Historical alarm message.'.

Parameters:
initAlarmTypeID | ID of the alarm type.
initAlarmType | Name of alarm type
initTimeStamp | Time stamp

Member Function Documentation

GeViAct_HistoricalAlarm GeViAct_HistoricalAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_HistoricalAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm::aAlarmType

Name of alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm::aAlarmTypeID

ID of the alarm type.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm::aTimeStamp

Time stamp.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_HistoricalAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_HistoricalAlarmEventArgs (GeViAct_HistoricalAlarm^ initAction)
Create the EventArgs for handler of action 'Historical alarm message.'.

Properties

GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type.
String^ | aAlarmType
Name of alarm type.
GeViTGeViDateTime aTimeStamp
Time stamp.

Private Member Functions

GeViAct_HistoricalAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Historical alarm message.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs::GeViAct_HistoricalAlarmEventArgs ( ) [private]
GeViAct_HistoricalAlarmEventArgs::GeViAct_HistoricalAlarmEventArgs ( GeViAct_HistoricalAlarm^ initAction )

Create the EventArgs for handler of action 'Historical alarm message.'.

Parameters:
initAction Managed action 'Historical alarm message.'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs::aAlarmType

Name of alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs::aAlarmTypeID

ID of the alarm type.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs::aTimeStamp

Time stamp.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput Class Reference

  • SystemActions
  • GeViAct_HistoricalInput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput Class Reference
Actions

Action 'Historical contact message.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput:
[legend]

List of all members.

Public Member Functions

GeViAct_HistoricalInput (Int32 initContactID, Int32 initLevel, GeViTGeViDateTime initTimeStamp)
Create the action 'Historical contact message.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_HistoricalInput^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aContactID
Global id of that contact.
Int32 | aLevel
State of that contact.
GeViTGeViDateTime aTimeStamp
Time stamp.

Detailed Description

Action 'Historical contact message.'.

Constructor & Destructor Documentation

GeViAct_HistoricalInput::GeViAct_HistoricalInput | ( | Int32 | initContactID,
 |  | Int32 | initLevel,
 |  | GeViTGeViDateTime | initTimeStamp
 | ) |  |

Create the action 'Historical contact message.'.

Parameters:
initContactID | Global id of that contact
initLevel | State of that contact
initTimeStamp | Time stamp

Member Function Documentation

GeViAct_HistoricalInput GeViAct_HistoricalInput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_HistoricalInput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput::aContactID

Global id of that contact.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput::aLevel

State of that contact.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput::aTimeStamp

Time stamp.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_HistoricalInputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_HistoricalInputEventArgs (GeViAct_HistoricalInput^ initAction)
Create the EventArgs for handler of action 'Historical contact message.'.

Properties

Int32 | aContactID
Global id of that contact.
Int32 | aLevel
State of that contact.
GeViTGeViDateTime aTimeStamp
Time stamp.

Private Member Functions

GeViAct_HistoricalInputEventArgs ()

Detailed Description

EventArgs for handler of action 'Historical contact message.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs::GeViAct_HistoricalInputEventArgs ( ) [private]
GeViAct_HistoricalInputEventArgs::GeViAct_HistoricalInputEventArgs ( GeViAct_HistoricalInput^ initAction )

Create the EventArgs for handler of action 'Historical contact message.'.

Parameters:
initAction Managed action 'Historical contact message.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs::aContactID

Global id of that contact.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs::aLevel

State of that contact.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs::aTimeStamp

Time stamp.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorCameraOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput Class Reference
Actions

Action 'Output command to the connected camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorCameraOutput (GeViVideoInputID initIlluminator, String^ initCommand)
Create the action 'Output command to the connected camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorCameraOutput^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.
String^ | aCommand
Camera commend.

Detailed Description

Action 'Output command to the connected camera'.

Constructor & Destructor Documentation

GeViAct_IlluminatorCameraOutput::GeViAct_IlluminatorCameraOutput | ( | GeViVideoInputID | initIlluminator,
 |  | String^ | initCommand
 | ) |  |

Create the action 'Output command to the connected camera'.

Parameters:
initIlluminator | ID of the used illuminator
initCommand | Camera commend

Member Function Documentation

GeViAct_IlluminatorCameraOutput GeViAct_IlluminatorCameraOutput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorCameraOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput::aCommand

Camera commend.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorCameraOutputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorCameraOutputEventArgs (GeViAct_IlluminatorCameraOutput^ initAction)
Create the EventArgs for handler of action 'Output command to the connected camera'.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.
String^ | aCommand
Camera commend.

Private Member Functions

GeViAct_IlluminatorCameraOutputEventArgs ()

Detailed Description

EventArgs for handler of action 'Output command to the connected camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs::GeViAct_IlluminatorCameraOutputEventArgs ( ) [private]
GeViAct_IlluminatorCameraOutputEventArgs::GeViAct_IlluminatorCameraOutputEventArgs ( GeViAct_IlluminatorCameraOutput^ initAction )

Create the EventArgs for handler of action 'Output command to the connected camera'.

Parameters:
initAction Managed action 'Output command to the connected camera'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs::aCommand

Camera commend.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorDimLevel
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel Class Reference
Actions

Action 'The current dim level of the illuminator'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorDimLevel (GeViVideoInputID initIlluminator, Int32 initLevel)
Create the action 'The current dim level of the illuminator'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IlluminatorDimLevel^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.
Int32 | aLevel
Dim level.

Detailed Description

Action 'The current dim level of the illuminator'.

Constructor & Destructor Documentation

GeViAct_IlluminatorDimLevel::GeViAct_IlluminatorDimLevel | ( | GeViVideoInputID | initIlluminator,
 |  | Int32 | initLevel
 | ) |  |

Create the action 'The current dim level of the illuminator'.

Parameters:
initIlluminator | ID of the used illuminator
initLevel | Dim level

Member Function Documentation

GeViAct_IlluminatorDimLevel GeViAct_IlluminatorDimLevel::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorDimLevel::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel::aIlluminator

ID of the used illuminator.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel::aLevel

Dim level.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorDimLevelEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorDimLevelEventArgs (GeViAct_IlluminatorDimLevel^ initAction)
Create the EventArgs for handler of action 'The current dim level of the illuminator'.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.
Int32 | aLevel
Dim level.

Private Member Functions

GeViAct_IlluminatorDimLevelEventArgs ()

Detailed Description

EventArgs for handler of action 'The current dim level of the illuminator'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs::GeViAct_IlluminatorDimLevelEventArgs ( ) [private]
GeViAct_IlluminatorDimLevelEventArgs::GeViAct_IlluminatorDimLevelEventArgs ( GeViAct_IlluminatorDimLevel^ initAction )

Create the EventArgs for handler of action 'The current dim level of the illuminator'.

Parameters:
initAction Managed action 'The current dim level of the illuminator'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs::aIlluminator

ID of the used illuminator.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs::aLevel

Dim level.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorGetDimLevel
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel Class Reference
Actions

Action 'Get the dim level of the illuminator'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorGetDimLevel (GeViVideoInputID initIlluminator)
Create the action 'Get the dim level of the illuminator'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorGetDimLevel^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Get the dim level of the illuminator'.

Constructor & Destructor Documentation

GeViAct_IlluminatorGetDimLevel::GeViAct_IlluminatorGetDimLevel ( GeViVideoInputID initIlluminator )

Create the action 'Get the dim level of the illuminator'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorGetDimLevel GeViAct_IlluminatorGetDimLevel::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorGetDimLevel::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorGetDimLevelEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorGetDimLevelEventArgs (GeViAct_IlluminatorGetDimLevel^ initAction)
Create the EventArgs for handler of action 'Get the dim level of the illuminator'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorGetDimLevelEventArgs ()

Detailed Description

EventArgs for handler of action 'Get the dim level of the illuminator'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs::GeViAct_IlluminatorGetDimLevelEventArgs ( ) [private]
GeViAct_IlluminatorGetDimLevelEventArgs::GeViAct_IlluminatorGetDimLevelEventArgs ( GeViAct_IlluminatorGetDimLevel^ initAction )

Create the EventArgs for handler of action 'Get the dim level of the illuminator'.

Parameters:
initAction Managed action 'Get the dim level of the illuminator'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorLightOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff Class Reference
Actions

Action 'Turn off the illuminator light'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorLightOff (GeViVideoInputID initIlluminator)
Create the action 'Turn off the illuminator light'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IlluminatorLightOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the illuminator, which light shall be turned off.

Detailed Description

Action 'Turn off the illuminator light'.

Constructor & Destructor Documentation

GeViAct_IlluminatorLightOff::GeViAct_IlluminatorLightOff ( GeViVideoInputID initIlluminator )

Create the action 'Turn off the illuminator light'.

Parameters:
initIlluminator ID of the illuminator, which light shall be turned off.

Member Function Documentation

GeViAct_IlluminatorLightOff GeViAct_IlluminatorLightOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorLightOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff::aIlluminator

ID of the illuminator, which light shall be turned off.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorLightOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorLightOffEventArgs (GeViAct_IlluminatorLightOff^ initAction)
Create the EventArgs for handler of action 'Turn off the illuminator light'.

Properties

GeViVideoInputID aIlluminator
ID of the illuminator, which light shall be turned off.

Private Member Functions

GeViAct_IlluminatorLightOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the illuminator light'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs::GeViAct_IlluminatorLightOffEventArgs ( ) [private]
GeViAct_IlluminatorLightOffEventArgs::GeViAct_IlluminatorLightOffEventArgs ( GeViAct_IlluminatorLightOff^ initAction )

Create the EventArgs for handler of action 'Turn off the illuminator light'.

Parameters:
initAction Managed action 'Turn off the illuminator light'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs::aIlluminator

ID of the illuminator, which light shall be turned off.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorLightOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn Class Reference
Actions

Action 'Turn on the illuminator light'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorLightOn (GeViVideoInputID initIlluminator)
Create the action 'Turn on the illuminator light'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IlluminatorLightOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the illuminator, which light shall be turn on.

Detailed Description

Action 'Turn on the illuminator light'.

Constructor & Destructor Documentation

GeViAct_IlluminatorLightOn::GeViAct_IlluminatorLightOn ( GeViVideoInputID initIlluminator )

Create the action 'Turn on the illuminator light'.

Parameters:
initIlluminator ID of the illuminator, which light shall be turn on

Member Function Documentation

GeViAct_IlluminatorLightOn GeViAct_IlluminatorLightOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorLightOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn::aIlluminator

ID of the illuminator, which light shall be turn on.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorLightOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorLightOnEventArgs (GeViAct_IlluminatorLightOn^ initAction)
Create the EventArgs for handler of action 'Turn on the illuminator light'.

Properties

GeViVideoInputID aIlluminator
ID of the illuminator, which light shall be turn on.

Private Member Functions

GeViAct_IlluminatorLightOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the illuminator light'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs::GeViAct_IlluminatorLightOnEventArgs ( ) [private]
GeViAct_IlluminatorLightOnEventArgs::GeViAct_IlluminatorLightOnEventArgs ( GeViAct_IlluminatorLightOn^ initAction )

Create the EventArgs for handler of action 'Turn on the illuminator light'.

Parameters:
initAction Managed action 'Turn on the illuminator light'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs::aIlluminator

ID of the illuminator, which light shall be turn on.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff Class Reference
Actions

Action 'Turn off the illuminator'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorOff (GeViVideoInputID initIlluminator)
Create the action 'Turn off the illuminator'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IlluminatorOff^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the illuminator to turn off.

Detailed Description

Action 'Turn off the illuminator'.

Constructor & Destructor Documentation

GeViAct_IlluminatorOff::GeViAct_IlluminatorOff ( GeViVideoInputID initIlluminator )

Create the action 'Turn off the illuminator'.

Parameters:
initIlluminator ID of the illuminator to turn off

Member Function Documentation

GeViAct_IlluminatorOff GeViAct_IlluminatorOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff::aIlluminator

ID of the illuminator to turn off.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorOffEventArgs (GeViAct_IlluminatorOff^ initAction)
Create the EventArgs for handler of action 'Turn off the illuminator'.

Properties

GeViVideoInputID aIlluminator
ID of the illuminator to turn off.

Private Member Functions

GeViAct_IlluminatorOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the illuminator'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs::GeViAct_IlluminatorOffEventArgs ( ) [private]
GeViAct_IlluminatorOffEventArgs::GeViAct_IlluminatorOffEventArgs ( GeViAct_IlluminatorOff^ initAction )

Create the EventArgs for handler of action 'Turn off the illuminator'.

Parameters:
initAction Managed action 'Turn off the illuminator'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs::aIlluminator

ID of the illuminator to turn off.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn Class Reference
Actions

Action 'Turn on the illuminator'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorOn (GeViVideoInputID initIlluminator)
Create the action 'Turn on the illuminator'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IlluminatorOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the illuminator to turn on.

Detailed Description

Action 'Turn on the illuminator'.

Constructor & Destructor Documentation

GeViAct_IlluminatorOn::GeViAct_IlluminatorOn ( GeViVideoInputID initIlluminator )

Create the action 'Turn on the illuminator'.

Parameters:
initIlluminator ID of the illuminator to turn on

Member Function Documentation

GeViAct_IlluminatorOn GeViAct_IlluminatorOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn::aIlluminator

ID of the illuminator to turn on.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorOnEventArgs (GeViAct_IlluminatorOn^ initAction)
Create the EventArgs for handler of action 'Turn on the illuminator'.

Properties

GeViVideoInputID aIlluminator
ID of the illuminator to turn on.

Private Member Functions

GeViAct_IlluminatorOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the illuminator'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs::GeViAct_IlluminatorOnEventArgs ( ) [private]
GeViAct_IlluminatorOnEventArgs::GeViAct_IlluminatorOnEventArgs ( GeViAct_IlluminatorOn^ initAction )

Create the EventArgs for handler of action 'Turn on the illuminator'.

Parameters:
initAction Managed action 'Turn on the illuminator'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs::aIlluminator

ID of the illuminator to turn on.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSetDimLevel
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel Class Reference
Actions

Action 'Set the dim level of the illuminator'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSetDimLevel (GeViVideoInputID initIlluminator, Int32 initLevel)
Create the action 'Set the dim level of the illuminator'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSetDimLevel^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.
Int32 | aLevel
Dim level.

Detailed Description

Action 'Set the dim level of the illuminator'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSetDimLevel::GeViAct_IlluminatorSetDimLevel | ( | GeViVideoInputID | initIlluminator,
 |  | Int32 | initLevel
 | ) |  |

Create the action 'Set the dim level of the illuminator'.

Parameters:
initIlluminator | ID of the used illuminator
initLevel | Dim level

Member Function Documentation

GeViAct_IlluminatorSetDimLevel GeViAct_IlluminatorSetDimLevel::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSetDimLevel::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel::aIlluminator

ID of the used illuminator.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel::aLevel

Dim level.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSetDimLevelEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSetDimLevelEventArgs (GeViAct_IlluminatorSetDimLevel^ initAction)
Create the EventArgs for handler of action 'Set the dim level of the illuminator'.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.
Int32 | aLevel
Dim level.

Private Member Functions

GeViAct_IlluminatorSetDimLevelEventArgs ()

Detailed Description

EventArgs for handler of action 'Set the dim level of the illuminator'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs::GeViAct_IlluminatorSetDimLevelEventArgs ( ) [private]
GeViAct_IlluminatorSetDimLevelEventArgs::GeViAct_IlluminatorSetDimLevelEventArgs ( GeViAct_IlluminatorSetDimLevel^ initAction )

Create the EventArgs for handler of action 'Set the dim level of the illuminator'.

Parameters:
initAction Managed action 'Set the dim level of the illuminator'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs::aIlluminator

ID of the used illuminator.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs::aLevel

Dim level.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncUOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff Class Reference
Actions

Action 'Turn off the special function U'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncUOff (GeViVideoInputID initIlluminator)
Create the action 'Turn off the special function U'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncUOff^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn off the special function U'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncUOff::GeViAct_IlluminatorSpecFuncUOff ( GeViVideoInputID initIlluminator )

Create the action 'Turn off the special function U'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncUOff GeViAct_IlluminatorSpecFuncUOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncUOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncUOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncUOffEventArgs (GeViAct_IlluminatorSpecFuncUOff^ initAction)
Create the EventArgs for handler of action 'Turn off the special function U'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncUOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the special function U'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs::GeViAct_IlluminatorSpecFuncUOffEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncUOffEventArgs::GeViAct_IlluminatorSpecFuncUOffEventArgs ( GeViAct_IlluminatorSpecFuncUOff^ initAction )

Create the EventArgs for handler of action 'Turn off the special function U'.

Parameters:
initAction Managed action 'Turn off the special function U'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncUOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn Class Reference
Actions

Action 'Turn on the special function U'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncUOn (GeViVideoInputID initIlluminator)
Create the action 'Turn on the special function U'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncUOn^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn on the special function U'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncUOn::GeViAct_IlluminatorSpecFuncUOn ( GeViVideoInputID initIlluminator )

Create the action 'Turn on the special function U'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncUOn GeViAct_IlluminatorSpecFuncUOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncUOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncUOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncUOnEventArgs (GeViAct_IlluminatorSpecFuncUOn^ initAction)
Create the EventArgs for handler of action 'Turn on the special function U'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncUOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the special function U'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs::GeViAct_IlluminatorSpecFuncUOnEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncUOnEventArgs::GeViAct_IlluminatorSpecFuncUOnEventArgs ( GeViAct_IlluminatorSpecFuncUOn^ initAction )

Create the EventArgs for handler of action 'Turn on the special function U'.

Parameters:
initAction Managed action 'Turn on the special function U'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncVOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff Class Reference
Actions

Action 'Turn off the special function V'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncVOff (GeViVideoInputID initIlluminator)
Create the action 'Turn off the special function V'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncVOff^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn off the special function V'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncVOff::GeViAct_IlluminatorSpecFuncVOff ( GeViVideoInputID initIlluminator )

Create the action 'Turn off the special function V'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncVOff GeViAct_IlluminatorSpecFuncVOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncVOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncVOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncVOffEventArgs (GeViAct_IlluminatorSpecFuncVOff^ initAction)
Create the EventArgs for handler of action 'Turn off the special function V'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncVOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the special function V'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs::GeViAct_IlluminatorSpecFuncVOffEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncVOffEventArgs::GeViAct_IlluminatorSpecFuncVOffEventArgs ( GeViAct_IlluminatorSpecFuncVOff^ initAction )

Create the EventArgs for handler of action 'Turn off the special function V'.

Parameters:
initAction Managed action 'Turn off the special function V'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncVOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn Class Reference
Actions

Action 'Turn on the special function V'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncVOn (GeViVideoInputID initIlluminator)
Create the action 'Turn on the special function V'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncVOn^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn on the special function V'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncVOn::GeViAct_IlluminatorSpecFuncVOn ( GeViVideoInputID initIlluminator )

Create the action 'Turn on the special function V'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncVOn GeViAct_IlluminatorSpecFuncVOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncVOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncVOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncVOnEventArgs (GeViAct_IlluminatorSpecFuncVOn^ initAction)
Create the EventArgs for handler of action 'Turn on the special function V'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncVOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the special function V'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs::GeViAct_IlluminatorSpecFuncVOnEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncVOnEventArgs::GeViAct_IlluminatorSpecFuncVOnEventArgs ( GeViAct_IlluminatorSpecFuncVOn^ initAction )

Create the EventArgs for handler of action 'Turn on the special function V'.

Parameters:
initAction Managed action 'Turn on the special function V'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncXOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff Class Reference
Actions

Action 'Turn off the special function X'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncXOff (GeViVideoInputID initIlluminator)
Create the action 'Turn off the special function X'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncXOff^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn off the special function X'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncXOff::GeViAct_IlluminatorSpecFuncXOff ( GeViVideoInputID initIlluminator )

Create the action 'Turn off the special function X'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncXOff GeViAct_IlluminatorSpecFuncXOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncXOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncXOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncXOffEventArgs (GeViAct_IlluminatorSpecFuncXOff^ initAction)
Create the EventArgs for handler of action 'Turn off the special function X'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncXOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the special function X'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs::GeViAct_IlluminatorSpecFuncXOffEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncXOffEventArgs::GeViAct_IlluminatorSpecFuncXOffEventArgs ( GeViAct_IlluminatorSpecFuncXOff^ initAction )

Create the EventArgs for handler of action 'Turn off the special function X'.

Parameters:
initAction Managed action 'Turn off the special function X'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncXOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn Class Reference
Actions

Action 'Turn on the special function X'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncXOn (GeViVideoInputID initIlluminator)
Create the action 'Turn on the special function X'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncXOn^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn on the special function X'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncXOn::GeViAct_IlluminatorSpecFuncXOn ( GeViVideoInputID initIlluminator )

Create the action 'Turn on the special function X'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncXOn GeViAct_IlluminatorSpecFuncXOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncXOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncXOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncXOnEventArgs (GeViAct_IlluminatorSpecFuncXOn^ initAction)
Create the EventArgs for handler of action 'Turn on the special function X'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncXOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the special function X'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs::GeViAct_IlluminatorSpecFuncXOnEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncXOnEventArgs::GeViAct_IlluminatorSpecFuncXOnEventArgs ( GeViAct_IlluminatorSpecFuncXOn^ initAction )

Create the EventArgs for handler of action 'Turn on the special function X'.

Parameters:
initAction Managed action 'Turn on the special function X'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncYOff
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff Class Reference
Actions

Action 'Turn off the special function Y'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncYOff (GeViVideoInputID initIlluminator)
Create the action 'Turn off the special function Y'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncYOff^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn off the special function Y'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncYOff::GeViAct_IlluminatorSpecFuncYOff ( GeViVideoInputID initIlluminator )

Create the action 'Turn off the special function Y'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncYOff GeViAct_IlluminatorSpecFuncYOff::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncYOff::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncYOffEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncYOffEventArgs (GeViAct_IlluminatorSpecFuncYOff^ initAction)
Create the EventArgs for handler of action 'Turn off the special function Y'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncYOffEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn off the special function Y'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs::GeViAct_IlluminatorSpecFuncYOffEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncYOffEventArgs::GeViAct_IlluminatorSpecFuncYOffEventArgs ( GeViAct_IlluminatorSpecFuncYOff^ initAction )

Create the EventArgs for handler of action 'Turn off the special function Y'.

Parameters:
initAction Managed action 'Turn off the special function Y'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn Class Reference

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncYOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn Class Reference
Actions

Action 'Turn on the special function Y'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn:
[legend]

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncYOn (GeViVideoInputID initIlluminator)
Create the action 'Turn on the special function Y'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_IlluminatorSpecFuncYOn^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aIlluminator
ID of the used illuminator.

Detailed Description

Action 'Turn on the special function Y'.

Constructor & Destructor Documentation

GeViAct_IlluminatorSpecFuncYOn::GeViAct_IlluminatorSpecFuncYOn ( GeViVideoInputID initIlluminator )

Create the action 'Turn on the special function Y'.

Parameters:
initIlluminator ID of the used illuminator

Member Function Documentation

GeViAct_IlluminatorSpecFuncYOn GeViAct_IlluminatorSpecFuncYOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IlluminatorSpecFuncYOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncYOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IlluminatorSpecFuncYOnEventArgs (GeViAct_IlluminatorSpecFuncYOn^ initAction)
Create the EventArgs for handler of action 'Turn on the special function Y'.

Properties

GeViVideoInputID aIlluminator
ID of the used illuminator.

Private Member Functions

GeViAct_IlluminatorSpecFuncYOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on the special function Y'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs::GeViAct_IlluminatorSpecFuncYOnEventArgs ( ) [private]
GeViAct_IlluminatorSpecFuncYOnEventArgs::GeViAct_IlluminatorSpecFuncYOnEventArgs ( GeViAct_IlluminatorSpecFuncYOn^ initAction )

Create the EventArgs for handler of action 'Turn on the special function Y'.

Parameters:
initAction Managed action 'Turn on the special function Y'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs::aIlluminator

ID of the used illuminator.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers Class Reference

  • SystemActions
  • GeViAct_InformAllUsers
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers Class Reference
Actions

Action 'Send a message to all users'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers:
[legend]

List of all members.

Public Member Functions

GeViAct_InformAllUsers (GeViClientID initFrom, String^ initFromName, String^ initInfoMessage)
Create the action 'Send a message to all users'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_InformAllUsers^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aFrom
Automatic adaption of the ID of the user, whose is sending the message.
String^ | aFromName
Automatic adaption if the name, who was sending this message.
String^ | aInfoMessage
Message.

Detailed Description

Action 'Send a message to all users'.

Constructor & Destructor Documentation

GeViAct_InformAllUsers::GeViAct_InformAllUsers | ( | GeViClientID | initFrom,
 |  | String^ | initFromName,
 |  | String^ | initInfoMessage
 | ) |  |

Create the action 'Send a message to all users'.

Parameters:
initFrom | Automatic adaption of the ID of the user, whose is sending the message
initFromName | Automatic adaption if the name, who was sending this message
initInfoMessage | Message

Member Function Documentation

GeViAct_InformAllUsers GeViAct_InformAllUsers::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_InformAllUsers::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers::aFrom

Automatic adaption of the ID of the user, whose is sending the message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers::aFromName

Automatic adaption if the name, who was sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers::aInfoMessage

Message.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_InformAllUsersEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_InformAllUsersEventArgs (GeViAct_InformAllUsers^ initAction)
Create the EventArgs for handler of action 'Send a message to all users'.

Properties

GeViClientID | aFrom
Automatic adaption of the ID of the user, whose is sending the message.
String^ | aFromName
Automatic adaption if the name, who was sending this message.
String^ | aInfoMessage
Message.

Private Member Functions

GeViAct_InformAllUsersEventArgs ()

Detailed Description

EventArgs for handler of action 'Send a message to all users'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs::GeViAct_InformAllUsersEventArgs ( ) [private]
GeViAct_InformAllUsersEventArgs::GeViAct_InformAllUsersEventArgs ( GeViAct_InformAllUsers^ initAction )

Create the EventArgs for handler of action 'Send a message to all users'.

Parameters:
initAction Managed action 'Send a message to all users'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs::aFrom

Automatic adaption of the ID of the user, whose is sending the message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs::aFromName

Automatic adaption if the name, who was sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs::aInfoMessage

Message.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG Class Reference

  • SystemActions
  • GeViAct_InformAllUsersMSG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG Class Reference
Actions

Action 'Send a message to all users'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG:
[legend]

List of all members.

Public Member Functions

GeViAct_InformAllUsersMSG (GeViClientID initFrom, String^ initFromName, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal)
Create the action 'Send a message to all users'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_InformAllUsersMSG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aFrom
Automatic adaption of the user ID, who sends this message.
String^ | aFromName
Automatic adaption of the user name, who sends this message.
Int32 | aMessageID
ID of the message, if name is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.

Detailed Description

Action 'Send a message to all users'.

Constructor & Destructor Documentation

GeViAct_InformAllUsersMSG::GeViAct_InformAllUsersMSG | ( | GeViClientID | initFrom,
 |  | String^ | initFromName,
 |  | Int32 | initMessageID,
 |  | String^ | initMessageName,
 |  | GeViMessageInternal | initMessageInternal
 | ) |  |

Create the action 'Send a message to all users'.

Parameters:
initFrom | Automatic adaption of the user ID, who sends this message
initFromName | Automatic adaption of the user name, who sends this message
initMessageID | ID of the message, if name is empty
initMessageName | Name of the message respective empty
initMessageInternal | An internal structur, what is not to pass on outwards.

Member Function Documentation

GeViAct_InformAllUsersMSG GeViAct_InformAllUsersMSG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_InformAllUsersMSG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG::aFrom

Automatic adaption of the user ID, who sends this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG::aFromName

Automatic adaption of the user name, who sends this message.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG::aMessageID

ID of the message, if name is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG::aMessageName

Name of the message respective empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_InformAllUsersMSGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_InformAllUsersMSGEventArgs (GeViAct_InformAllUsersMSG^ initAction)
Create the EventArgs for handler of action 'Send a message to all users'.

Properties

GeViClientID | aFrom
Automatic adaption of the user ID, who sends this message.
String^ | aFromName
Automatic adaption of the user name, who sends this message.
Int32 | aMessageID
ID of the message, if name is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.

Private Member Functions

GeViAct_InformAllUsersMSGEventArgs ()

Detailed Description

EventArgs for handler of action 'Send a message to all users'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs::GeViAct_InformAllUsersMSGEventArgs ( ) [private]
GeViAct_InformAllUsersMSGEventArgs::GeViAct_InformAllUsersMSGEventArgs ( GeViAct_InformAllUsersMSG^ initAction )

Create the EventArgs for handler of action 'Send a message to all users'.

Parameters:
initAction Managed action 'Send a message to all users'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs::aFrom

Automatic adaption of the user ID, who sends this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs::aFromName

Automatic adaption of the user name, who sends this message.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs::aMessageID

ID of the message, if name is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs::aMessageName

Name of the message respective empty.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser Class Reference

  • SystemActions
  • GeViAct_InformUser
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser Class Reference
Actions

Action 'Sending of a message to a user.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser:
[legend]

List of all members.

Public Member Functions

GeViAct_InformUser (GeViClientID initFrom, String^ initFromName, GeViClientID initTo, String^ initToName, String^ initInfoMessage)
Create the action 'Sending of a message to a user.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_InformUser^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aFrom
Automatic adaption if the user ID, who was sending this message.
String^ | aFromName
Automatic adaption of the name, who was sending this message.
GeViClientID | aTo
ID of the user, to whom the message was directed; Only used, when the ToName is empty!
String^ | aToName
Name of the user, to whom the message were directed.
String^ | aInfoMessage
Message.

Detailed Description

Action 'Sending of a message to a user.'.

Constructor & Destructor Documentation

GeViAct_InformUser::GeViAct_InformUser | ( | GeViClientID | initFrom,
 |  | String^ | initFromName,
 |  | GeViClientID | initTo,
 |  | String^ | initToName,
 |  | String^ | initInfoMessage
 | ) |  |

Create the action 'Sending of a message to a user.'.

Parameters:
initFrom | Automatic adaption if the user ID, who was sending this message
initFromName | Automatic adaption of the name, who was sending this message
initTo | ID of the user, to whom the message was directed; Only used, when the ToName is empty!
initToName | Name of the user, to whom the message were directed
initInfoMessage | Message

Member Function Documentation

GeViAct_InformUser GeViAct_InformUser::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_InformUser::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser::aFrom

Automatic adaption if the user ID, who was sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser::aFromName

Automatic adaption of the name, who was sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser::aInfoMessage

Message.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser::aTo

ID of the user, to whom the message was directed; Only used, when the ToName is empty!

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser::aToName

Name of the user, to whom the message were directed.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_InformUserEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_InformUserEventArgs (GeViAct_InformUser^ initAction)
Create the EventArgs for handler of action 'Sending of a message to a user.'.

Properties

GeViClientID | aFrom
Automatic adaption if the user ID, who was sending this message.
String^ | aFromName
Automatic adaption of the name, who was sending this message.
GeViClientID | aTo
ID of the user, to whom the message was directed; Only used, when the ToName is empty!
String^ | aToName
Name of the user, to whom the message were directed.
String^ | aInfoMessage
Message.

Private Member Functions

GeViAct_InformUserEventArgs ()

Detailed Description

EventArgs for handler of action 'Sending of a message to a user.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs::GeViAct_InformUserEventArgs ( ) [private]
GeViAct_InformUserEventArgs::GeViAct_InformUserEventArgs ( GeViAct_InformUser^ initAction )

Create the EventArgs for handler of action 'Sending of a message to a user.'.

Parameters:
initAction Managed action 'Sending of a message to a user.'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs::aFrom

Automatic adaption if the user ID, who was sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs::aFromName

Automatic adaption of the name, who was sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs::aInfoMessage

Message.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs::aTo

ID of the user, to whom the message was directed; Only used, when the ToName is empty!

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs::aToName

Name of the user, to whom the message were directed.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG Class Reference

  • SystemActions
  • GeViAct_InformUserMSG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG Class Reference
Actions

Action 'Send a message to user'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG:
[legend]

List of all members.

Public Member Functions

GeViAct_InformUserMSG (GeViClientID initFrom, String^ initFromName, GeViClientID initTo, String^ initToName, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal)
Create the action 'Send a message to user'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_InformUserMSG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aFrom
Automatic adaption of user ID, who is sending this message.
String^ | aFromName
Automatic adaption of user name, who is sending this message.
GeViClientID | aTo
ID of the user, to which this message is directed. It will only be used, if the ToName is empty. (0 may also not appear there!)
String^ | aToName
Name of the user, to which the message is directed.
Int32 | aMessageID
ID of the message, if the name is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.

Detailed Description

Action 'Send a message to user'.

Constructor & Destructor Documentation

GeViAct_InformUserMSG::GeViAct_InformUserMSG | ( | GeViClientID | initFrom,
 |  | String^ | initFromName,
 |  | GeViClientID | initTo,
 |  | String^ | initToName,
 |  | Int32 | initMessageID,
 |  | String^ | initMessageName,
 |  | GeViMessageInternal | initMessageInternal
 | ) |  |

Create the action 'Send a message to user'.

Parameters:
initFrom | Automatic adaption of user ID, who is sending this message
initFromName | Automatic adaption of user name, who is sending this message
initTo | ID of the user, to which this message is directed. It will only be used, if the ToName is empty. (0 may also not appear there!)
initToName | Name of the user, to which the message is directed.
initMessageID | ID of the message, if the name is empty
initMessageName | Name of the message respective empty
initMessageInternal | An internal structur, what is not to pass on outwards.

Member Function Documentation

GeViAct_InformUserMSG GeViAct_InformUserMSG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_InformUserMSG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG::aFrom

Automatic adaption of user ID, who is sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG::aFromName

Automatic adaption of user name, who is sending this message.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG::aMessageID

ID of the message, if the name is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG::aMessageName

Name of the message respective empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG::aTo

ID of the user, to which this message is directed. It will only be used, if the ToName is empty. (0 may also not appear there!)

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG::aToName

Name of the user, to which the message is directed.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_InformUserMSGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_InformUserMSGEventArgs (GeViAct_InformUserMSG^ initAction)
Create the EventArgs for handler of action 'Send a message to user'.

Properties

GeViClientID | aFrom
Automatic adaption of user ID, who is sending this message.
String^ | aFromName
Automatic adaption of user name, who is sending this message.
GeViClientID | aTo
ID of the user, to which this message is directed. It will only be used, if the ToName is empty. (0 may also not appear there!)
String^ | aToName
Name of the user, to which the message is directed.
Int32 | aMessageID
ID of the message, if the name is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.

Private Member Functions

GeViAct_InformUserMSGEventArgs ()

Detailed Description

EventArgs for handler of action 'Send a message to user'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::GeViAct_InformUserMSGEventArgs ( ) [private]
GeViAct_InformUserMSGEventArgs::GeViAct_InformUserMSGEventArgs ( GeViAct_InformUserMSG^ initAction )

Create the EventArgs for handler of action 'Send a message to user'.

Parameters:
initAction Managed action 'Send a message to user'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::aFrom

Automatic adaption of user ID, who is sending this message.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::aFromName

Automatic adaption of user name, who is sending this message.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::aMessageID

ID of the message, if the name is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::aMessageName

Name of the message respective empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::aTo

ID of the user, to which this message is directed. It will only be used, if the ToName is empty. (0 may also not appear there!)

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs::aToName

Name of the user, to which the message is directed.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact Class Reference

  • ContactBusActions
  • GeViAct_InputContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact Class Reference
Actions

Action 'Input event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact:
[legend]

List of all members.

Public Member Functions

GeViAct_InputContact (Int32 initGlobalContactID, Boolean initChangedTo)
Create the action 'Input event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_InputContact^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aGlobalContactID
Global ID of that contact.
Boolean | aChangedTo
New state of the input (true = closed, false = open)

Detailed Description

Action 'Input event'.

Constructor & Destructor Documentation

GeViAct_InputContact::GeViAct_InputContact | ( | Int32 | initGlobalContactID,
 |  | Boolean | initChangedTo
 | ) |  |

Create the action 'Input event'.

Parameters:
initGlobalContactID | Global ID of that contact
initChangedTo | New state of the input (true = closed, false = open)

Member Function Documentation

GeViAct_InputContact GeViAct_InputContact::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_InputContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact::aChangedTo

New state of the input (true = closed, false = open)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact::aGlobalContactID

Global ID of that contact.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_InputContactEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_InputContactEventArgs (GeViAct_InputContact^ initAction)
Create the EventArgs for handler of action 'Input event'.

Properties

Int32 | aGlobalContactID
Global ID of that contact.
Boolean | aChangedTo
New state of the input (true = closed, false = open)

Private Member Functions

GeViAct_InputContactEventArgs ()

Detailed Description

EventArgs for handler of action 'Input event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs::GeViAct_InputContactEventArgs ( ) [private]
GeViAct_InputContactEventArgs::GeViAct_InputContactEventArgs ( GeViAct_InputContact^ initAction )

Create the EventArgs for handler of action 'Input event'.

Parameters:
initAction Managed action 'Input event'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs::aChangedTo

New state of the input (true = closed, false = open)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs::aGlobalContactID

Global ID of that contact.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage Class Reference

  • ContactBusActions
  • GeViAct_InputContactSabotage
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage Class Reference
Actions

Action 'Input event sabotage notification'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage:
[legend]

List of all members.

Public Member Functions

GeViAct_InputContactSabotage (Int32 initGlobalContactID)
Create the action 'Input event sabotage notification'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_InputContactSabotage^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aGlobalContactID
Global ID of that contact.

Detailed Description

Action 'Input event sabotage notification'.

Constructor & Destructor Documentation

GeViAct_InputContactSabotage::GeViAct_InputContactSabotage ( Int32 initGlobalContactID )

Create the action 'Input event sabotage notification'.

Parameters:
initGlobalContactID Global ID of that contact

Member Function Documentation

GeViAct_InputContactSabotage GeViAct_InputContactSabotage::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_InputContactSabotage::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage::aGlobalContactID

Global ID of that contact.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_InputContactSabotageEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_InputContactSabotageEventArgs (GeViAct_InputContactSabotage^ initAction)
Create the EventArgs for handler of action 'Input event sabotage notification'.

Properties

Int32 aGlobalContactID
Global ID of that contact.

Private Member Functions

GeViAct_InputContactSabotageEventArgs ()

Detailed Description

EventArgs for handler of action 'Input event sabotage notification'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs::GeViAct_InputContactSabotageEventArgs ( ) [private]
GeViAct_InputContactSabotageEventArgs::GeViAct_InputContactSabotageEventArgs ( GeViAct_InputContactSabotage^ initAction )

Create the EventArgs for handler of action 'Input event sabotage notification'.

Parameters:
initAction Managed action 'Input event sabotage notification'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs::aGlobalContactID

Global ID of that contact.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose Class Reference

  • CameraControlActions
  • GeViAct_IrisClose
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose Class Reference
Actions

Action 'Close camera iris'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose:
[legend]

List of all members.

Public Member Functions

GeViAct_IrisClose (GeViVideoInputID initVideoInput)
Create the action 'Close camera iris'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IrisClose^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, of the iris shall be closed.

Detailed Description

Action 'Close camera iris'.

Constructor & Destructor Documentation

GeViAct_IrisClose::GeViAct_IrisClose ( GeViVideoInputID initVideoInput )

Create the action 'Close camera iris'.

Parameters:
initVideoInput ID of the camera, of the iris shall be closed

Member Function Documentation

GeViAct_IrisClose GeViAct_IrisClose::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IrisClose::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose::aVideoInput

ID of the camera, of the iris shall be closed.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IrisCloseEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IrisCloseEventArgs (GeViAct_IrisClose^ initAction)
Create the EventArgs for handler of action 'Close camera iris'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, of the iris shall be closed.

Private Member Functions

GeViAct_IrisCloseEventArgs ()

Detailed Description

EventArgs for handler of action 'Close camera iris'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs::GeViAct_IrisCloseEventArgs ( ) [private]
GeViAct_IrisCloseEventArgs::GeViAct_IrisCloseEventArgs ( GeViAct_IrisClose^ initAction )

Create the EventArgs for handler of action 'Close camera iris'.

Parameters:
initAction Managed action 'Close camera iris'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs::aVideoInput

ID of the camera, of the iris shall be closed.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen Class Reference

  • CameraControlActions
  • GeViAct_IrisOpen
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen Class Reference
Actions

Action 'Open the iris of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen:
[legend]

List of all members.

Public Member Functions

GeViAct_IrisOpen (GeViVideoInputID initVideoInput)
Create the action 'Open the iris of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IrisOpen^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, of which the iris shall be opened.

Detailed Description

Action 'Open the iris of the camera'.

Constructor & Destructor Documentation

GeViAct_IrisOpen::GeViAct_IrisOpen ( GeViVideoInputID initVideoInput )

Create the action 'Open the iris of the camera'.

Parameters:
initVideoInput ID of the camera, of which the iris shall be opened

Member Function Documentation

GeViAct_IrisOpen GeViAct_IrisOpen::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IrisOpen::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen::aVideoInput

ID of the camera, of which the iris shall be opened.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IrisOpenEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IrisOpenEventArgs (GeViAct_IrisOpen^ initAction)
Create the EventArgs for handler of action 'Open the iris of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, of which the iris shall be opened.

Private Member Functions

GeViAct_IrisOpenEventArgs ()

Detailed Description

EventArgs for handler of action 'Open the iris of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs::GeViAct_IrisOpenEventArgs ( ) [private]
GeViAct_IrisOpenEventArgs::GeViAct_IrisOpenEventArgs ( GeViAct_IrisOpen^ initAction )

Create the EventArgs for handler of action 'Open the iris of the camera'.

Parameters:
initAction Managed action 'Open the iris of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs::aVideoInput

ID of the camera, of which the iris shall be opened.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop Class Reference

  • CameraControlActions
  • GeViAct_IrisStop
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop Class Reference
Actions

Action 'Stopp closing the iris'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop:
[legend]

List of all members.

Public Member Functions

GeViAct_IrisStop (GeViVideoInputID initVideoInput)
Create the action 'Stopp closing the iris'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_IrisStop^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which iris change shall be stopped.

Detailed Description

Action 'Stopp closing the iris'.

Constructor & Destructor Documentation

GeViAct_IrisStop::GeViAct_IrisStop ( GeViVideoInputID initVideoInput )

Create the action 'Stopp closing the iris'.

Parameters:
initVideoInput ID of the camera, which iris change shall be stopped

Member Function Documentation

GeViAct_IrisStop GeViAct_IrisStop::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_IrisStop::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop::aVideoInput

ID of the camera, which iris change shall be stopped.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_IrisStopEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_IrisStopEventArgs (GeViAct_IrisStop^ initAction)
Create the EventArgs for handler of action 'Stopp closing the iris'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which iris change shall be stopped.

Private Member Functions

GeViAct_IrisStopEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp closing the iris'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs::GeViAct_IrisStopEventArgs ( ) [private]
GeViAct_IrisStopEventArgs::GeViAct_IrisStopEventArgs ( GeViAct_IrisStop^ initAction )

Create the EventArgs for handler of action 'Stopp closing the iris'.

Parameters:
initAction Managed action 'Stopp closing the iris'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs::aVideoInput

ID of the camera, which iris change shall be stopped.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction Class Reference

  • SystemActions
  • GeViAct_LogLastAction
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction Class Reference
Actions

Action 'The input action of the current action mapping will be logged.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction:
[legend]

List of all members.

Public Member Functions

GeViAct_LogLastAction (Int32 initConsole)
Create the action 'The input action of the current action mapping will be logged.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_LogLastAction^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aConsole
0 = data base; 1 = SystemEventLog

Detailed Description

Action 'The input action of the current action mapping will be logged.'.

Constructor & Destructor Documentation

GeViAct_LogLastAction::GeViAct_LogLastAction ( Int32 initConsole )

Create the action 'The input action of the current action mapping will be logged.'.

Parameters:
initConsole 0 = data base; 1 = SystemEventLog

Member Function Documentation

GeViAct_LogLastAction GeViAct_LogLastAction::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_LogLastAction::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction::aConsole

0 = data base; 1 = SystemEventLog

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_LogLastActionEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_LogLastActionEventArgs (GeViAct_LogLastAction^ initAction)
Create the EventArgs for handler of action 'The input action of the current action mapping will be logged.'.

Properties

Int32 aConsole
0 = data base; 1 = SystemEventLog

Private Member Functions

GeViAct_LogLastActionEventArgs ()

Detailed Description

EventArgs for handler of action 'The input action of the current action mapping will be logged.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs::GeViAct_LogLastActionEventArgs ( ) [private]
GeViAct_LogLastActionEventArgs::GeViAct_LogLastActionEventArgs ( GeViAct_LogLastAction^ initAction )

Create the EventArgs for handler of action 'The input action of the current action mapping will be logged.'.

Parameters:
initAction Managed action 'The input action of the current action mapping will be logged.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs::aConsole

0 = data base; 1 = SystemEventLog

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage Class Reference

  • SystemActions
  • GeViAct_LogMessage
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage Class Reference
Actions

Action 'Log message'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage:
[legend]

List of all members.

Public Member Functions

GeViAct_LogMessage (GeViClientID initClientID, Int32 initConsole, String^ initLogText, GeViAlarmID initAlarmID)
Create the action 'Log message'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_LogMessage^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic adaption, what has trigger the error.
Int32 | aConsole
0 = data base; 1 = SystemEventLog
String^ | aLogText
Message to log.
GeViAlarmID | aAlarmID
Instance Id of the alarm; If 0 no reference to the alarm will be made!

Detailed Description

Action 'Log message'.

Constructor & Destructor Documentation

GeViAct_LogMessage::GeViAct_LogMessage | ( | GeViClientID | initClientID,
 |  | Int32 | initConsole,
 |  | String^ | initLogText,
 |  | GeViAlarmID | initAlarmID
 | ) |  |

Create the action 'Log message'.

Parameters:
initClientID | Automatic adaption, what has trigger the error
initConsole | 0 = data base; 1 = SystemEventLog
initLogText | Message to log
initAlarmID | Instance Id of the alarm; If 0 no reference to the alarm will be made!

Member Function Documentation

GeViAct_LogMessage GeViAct_LogMessage::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_LogMessage::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage::aAlarmID

Instance Id of the alarm; If 0 no reference to the alarm will be made!

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage::aClientID

Automatic adaption, what has trigger the error.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage::aConsole

0 = data base; 1 = SystemEventLog

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage::aLogText

Message to log.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_LogMessageEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_LogMessageEventArgs (GeViAct_LogMessage^ initAction)
Create the EventArgs for handler of action 'Log message'.

Properties

GeViClientID | aClientID
Automatic adaption, what has trigger the error.
Int32 | aConsole
0 = data base; 1 = SystemEventLog
String^ | aLogText
Message to log.
GeViAlarmID | aAlarmID
Instance Id of the alarm; If 0 no reference to the alarm will be made!

Private Member Functions

GeViAct_LogMessageEventArgs ()

Detailed Description

EventArgs for handler of action 'Log message'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs::GeViAct_LogMessageEventArgs ( ) [private]
GeViAct_LogMessageEventArgs::GeViAct_LogMessageEventArgs ( GeViAct_LogMessage^ initAction )

Create the EventArgs for handler of action 'Log message'.

Parameters:
initAction Managed action 'Log message'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs::aAlarmID

Instance Id of the alarm; If 0 no reference to the alarm will be made!

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs::aClientID

Automatic adaption, what has trigger the error.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs::aConsole

0 = data base; 1 = SystemEventLog

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs::aLogText

Message to log.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG Class Reference

  • SystemActions
  • GeViAct_LogMessageMSG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG Class Reference
Actions

Action 'Logging of a message'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG:
[legend]

List of all members.

Public Member Functions

GeViAct_LogMessageMSG (GeViClientID initClientID, Int32 initConsole, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal, GeViAlarmID initAlarmID)
Create the action 'Logging of a message'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_LogMessageMSG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic adaption, who or what was creating the message.
Int32 | aConsole
0 = data base; 1 = SystemEventLog
Int32 | aMessageID
ID of the message; Only needed, if name is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.
GeViAlarmID | aAlarmID
Instance ID of the alarm; If 0 no refernece to the alarm will be created!

Detailed Description

Action 'Logging of a message'.

Constructor & Destructor Documentation

GeViAct_LogMessageMSG::GeViAct_LogMessageMSG | ( | GeViClientID | initClientID,
 |  | Int32 | initConsole,
 |  | Int32 | initMessageID,
 |  | String^ | initMessageName,
 |  | GeViMessageInternal | initMessageInternal,
 |  | GeViAlarmID | initAlarmID
 | ) |  |

Create the action 'Logging of a message'.

Parameters:
initClientID | Automatic adaption, who or what was creating the message
initConsole | 0 = data base; 1 = SystemEventLog
initMessageID | ID of the message; Only needed, if name is empty
initMessageName | Name of the message respective empty
initMessageInternal | An internal structur, what is not to pass on outwards.
initAlarmID | Instance ID of the alarm; If 0 no refernece to the alarm will be created!

Member Function Documentation

GeViAct_LogMessageMSG GeViAct_LogMessageMSG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_LogMessageMSG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG::aAlarmID

Instance ID of the alarm; If 0 no refernece to the alarm will be created!

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG::aClientID

Automatic adaption, who or what was creating the message.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG::aConsole

0 = data base; 1 = SystemEventLog

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG::aMessageID

ID of the message; Only needed, if name is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG::aMessageName

Name of the message respective empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_LogMessageMSGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_LogMessageMSGEventArgs (GeViAct_LogMessageMSG^ initAction)
Create the EventArgs for handler of action 'Logging of a message'.

Properties

GeViClientID | aClientID
Automatic adaption, who or what was creating the message.
Int32 | aConsole
0 = data base; 1 = SystemEventLog
Int32 | aMessageID
ID of the message; Only needed, if name is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.
GeViAlarmID | aAlarmID
Instance ID of the alarm; If 0 no refernece to the alarm will be created!

Private Member Functions

GeViAct_LogMessageMSGEventArgs ()

Detailed Description

EventArgs for handler of action 'Logging of a message'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs::GeViAct_LogMessageMSGEventArgs ( ) [private]
GeViAct_LogMessageMSGEventArgs::GeViAct_LogMessageMSGEventArgs ( GeViAct_LogMessageMSG^ initAction )

Create the EventArgs for handler of action 'Logging of a message'.

Parameters:
initAction Managed action 'Logging of a message'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs::aAlarmID

Instance ID of the alarm; If 0 no refernece to the alarm will be created!

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs::aClientID

Automatic adaption, who or what was creating the message.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs::aConsole

0 = data base; 1 = SystemEventLog

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs::aMessageID

ID of the message; Only needed, if name is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs::aMessageName

Name of the message respective empty.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction Class Reference

  • SystemActions
  • GeViAct_LogSourceAction
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction Class Reference
Actions

Action 'The input action of the first action mapping of this action mapping chain will be logged'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction:
[legend]

List of all members.

Public Member Functions

GeViAct_LogSourceAction (Int32 initConsole)
Create the action 'The input action of the first action mapping of this action mapping chain will be logged'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_LogSourceAction^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aConsole
0 = data base; 1 = SystemEventLog

Detailed Description

Action 'The input action of the first action mapping of this action mapping chain will be logged'.

Constructor & Destructor Documentation

GeViAct_LogSourceAction::GeViAct_LogSourceAction ( Int32 initConsole )

Create the action 'The input action of the first action mapping of this action mapping chain will be logged'.

Parameters:
initConsole 0 = data base; 1 = SystemEventLog

Member Function Documentation

GeViAct_LogSourceAction GeViAct_LogSourceAction::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_LogSourceAction::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction::aConsole

0 = data base; 1 = SystemEventLog

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_LogSourceActionEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_LogSourceActionEventArgs (GeViAct_LogSourceAction^ initAction)
Create the EventArgs for handler of action 'The input action of the first action mapping of this action mapping chain will be logged'.

Properties

Int32 aConsole
0 = data base; 1 = SystemEventLog

Private Member Functions

GeViAct_LogSourceActionEventArgs ()

Detailed Description

EventArgs for handler of action 'The input action of the first action mapping of this action mapping chain will be logged'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs::GeViAct_LogSourceActionEventArgs ( ) [private]
GeViAct_LogSourceActionEventArgs::GeViAct_LogSourceActionEventArgs ( GeViAct_LogSourceAction^ initAction )

Create the EventArgs for handler of action 'The input action of the first action mapping of this action mapping chain will be logged'.

Parameters:
initAction Managed action 'The input action of the first action mapping of this action mapping chain will be logged'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs::aConsole

0 = data base; 1 = SystemEventLog

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck Class Reference

  • AlarmControlActions
  • GeViAct_MBegAlarmAck
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck Class Reference
Actions

Action 'AlarmAck-report at a MBeg'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck:
[legend]

List of all members.

Public Member Functions

GeViAct_MBegAlarmAck (Int32 initUp, Int32 initTo)
Create the action 'AlarmAck-report at a MBeg'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MBegAlarmAck^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aUp
Details to the monitor group: from.
Int32 | aTo
to

Detailed Description

Action 'AlarmAck-report at a MBeg'.

Constructor & Destructor Documentation

GeViAct_MBegAlarmAck::GeViAct_MBegAlarmAck | ( | Int32 | initUp,
 |  | Int32 | initTo
 | ) |  |

Create the action 'AlarmAck-report at a MBeg'.

Parameters:
initUp | Details to the monitor group: from
initTo | to

Member Function Documentation

GeViAct_MBegAlarmAck GeViAct_MBegAlarmAck::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MBegAlarmAck::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck::aTo

to

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck::aUp

Details to the monitor group: from.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MBegAlarmAckEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MBegAlarmAckEventArgs (GeViAct_MBegAlarmAck^ initAction)
Create the EventArgs for handler of action 'AlarmAck-report at a MBeg'.

Properties

Int32 | aUp
Details to the monitor group: from.
Int32 | aTo
to

Private Member Functions

GeViAct_MBegAlarmAckEventArgs ()

Detailed Description

EventArgs for handler of action 'AlarmAck-report at a MBeg'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs::GeViAct_MBegAlarmAckEventArgs ( ) [private]
GeViAct_MBegAlarmAckEventArgs::GeViAct_MBegAlarmAckEventArgs ( GeViAct_MBegAlarmAck^ initAction )

Create the EventArgs for handler of action 'AlarmAck-report at a MBeg'.

Parameters:
initAction Managed action 'AlarmAck-report at a MBeg'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs::aTo

to

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs::aUp

Details to the monitor group: from.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit Class Reference

  • AlarmControlActions
  • GeViAct_MBegAlarmQuit
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit Class Reference
Actions

Action 'Report of the alarm quitting to a MBeg'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit:
[legend]

List of all members.

Public Member Functions

GeViAct_MBegAlarmQuit (Int32 initUp, Int32 initTo)
Create the action 'Report of the alarm quitting to a MBeg'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MBegAlarmQuit^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aUp
Details to the monitor group: from.
Int32 | aTo
to

Detailed Description

Action 'Report of the alarm quitting to a MBeg'.

Constructor & Destructor Documentation

GeViAct_MBegAlarmQuit::GeViAct_MBegAlarmQuit | ( | Int32 | initUp,
 |  | Int32 | initTo
 | ) |  |

Create the action 'Report of the alarm quitting to a MBeg'.

Parameters:
initUp | Details to the monitor group: from
initTo | to

Member Function Documentation

GeViAct_MBegAlarmQuit GeViAct_MBegAlarmQuit::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MBegAlarmQuit::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit::aTo

to

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit::aUp

Details to the monitor group: from.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MBegAlarmQuitEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MBegAlarmQuitEventArgs (GeViAct_MBegAlarmQuit^ initAction)
Create the EventArgs for handler of action 'Report of the alarm quitting to a MBeg'.

Properties

Int32 | aUp
Details to the monitor group: from.
Int32 | aTo
to

Private Member Functions

GeViAct_MBegAlarmQuitEventArgs ()

Detailed Description

EventArgs for handler of action 'Report of the alarm quitting to a MBeg'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs::GeViAct_MBegAlarmQuitEventArgs ( ) [private]
GeViAct_MBegAlarmQuitEventArgs::GeViAct_MBegAlarmQuitEventArgs ( GeViAct_MBegAlarmQuit^ initAction )

Create the EventArgs for handler of action 'Report of the alarm quitting to a MBeg'.

Parameters:
initAction Managed action 'Report of the alarm quitting to a MBeg'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs::aTo

to

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs::aUp

Details to the monitor group: from.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart Class Reference

  • AlarmControlActions
  • GeViAct_MBegAlarmStart
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart Class Reference
Actions

Action 'Report of a alarm start at a MBeg'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart:
[legend]

List of all members.

Public Member Functions

GeViAct_MBegAlarmStart (Int32 initUp, Int32 initTo)
Create the action 'Report of a alarm start at a MBeg'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MBegAlarmStart^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aUp
Details to the monitor group: from.
Int32 | aTo
to

Detailed Description

Action 'Report of a alarm start at a MBeg'.

Constructor & Destructor Documentation

GeViAct_MBegAlarmStart::GeViAct_MBegAlarmStart | ( | Int32 | initUp,
 |  | Int32 | initTo
 | ) |  |

Create the action 'Report of a alarm start at a MBeg'.

Parameters:
initUp | Details to the monitor group: from
initTo | to

Member Function Documentation

GeViAct_MBegAlarmStart GeViAct_MBegAlarmStart::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MBegAlarmStart::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart::aTo

to

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart::aUp

Details to the monitor group: from.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MBegAlarmStartEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MBegAlarmStartEventArgs (GeViAct_MBegAlarmStart^ initAction)
Create the EventArgs for handler of action 'Report of a alarm start at a MBeg'.

Properties

Int32 | aUp
Details to the monitor group: from.
Int32 | aTo
to

Private Member Functions

GeViAct_MBegAlarmStartEventArgs ()

Detailed Description

EventArgs for handler of action 'Report of a alarm start at a MBeg'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs::GeViAct_MBegAlarmStartEventArgs ( ) [private]
GeViAct_MBegAlarmStartEventArgs::GeViAct_MBegAlarmStartEventArgs ( GeViAct_MBegAlarmStart^ initAction )

Create the EventArgs for handler of action 'Report of a alarm start at a MBeg'.

Parameters:
initAction Managed action 'Report of a alarm start at a MBeg'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs::aTo

to

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs::aUp

Details to the monitor group: from.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest Class Reference

  • CameraControlActions
  • GeViAct_MBegInitRequest
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest Class Reference
Actions

Action 'Request of a MBeg initialization sequence'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest:
[legend]

List of all members.

Public Member Functions

GeViAct_MBegInitRequest (GeViClientID initClient)
Create the action 'Request of a MBeg initialization sequence'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MBegInitRequest^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClient
Interface ID of GeViTel.

Detailed Description

Action 'Request of a MBeg initialization sequence'.

Constructor & Destructor Documentation

GeViAct_MBegInitRequest::GeViAct_MBegInitRequest ( GeViClientID initClient )

Create the action 'Request of a MBeg initialization sequence'.

Parameters:
initClient Interface ID of GeViTel

Member Function Documentation

GeViAct_MBegInitRequest GeViAct_MBegInitRequest::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MBegInitRequest::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest::aClient

Interface ID of GeViTel.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MBegInitRequestEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MBegInitRequestEventArgs (GeViAct_MBegInitRequest^ initAction)
Create the EventArgs for handler of action 'Request of a MBeg initialization sequence'.

Properties

GeViClientID aClient
Interface ID of GeViTel.

Private Member Functions

GeViAct_MBegInitRequestEventArgs ()

Detailed Description

EventArgs for handler of action 'Request of a MBeg initialization sequence'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs::GeViAct_MBegInitRequestEventArgs ( ) [private]
GeViAct_MBegInitRequestEventArgs::GeViAct_MBegInitRequestEventArgs ( GeViAct_MBegInitRequest^ initAction )

Create the EventArgs for handler of action 'Request of a MBeg initialization sequence'.

Parameters:
initAction Managed action 'Request of a MBeg initialization sequence'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs::aClient

Interface ID of GeViTel.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq Class Reference

  • CameraControlActions
  • GeViAct_MBegInitSeq
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq Class Reference
Actions

Action 'MBeg init sequence'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq:
[legend]

List of all members.

Public Member Functions

GeViAct_MBegInitSeq (GeViClientID initClient, String^ initSeq)
Create the action 'MBeg init sequence'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MBegInitSeq^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClient
Interface ID of GeViTel.
String^ | aSeq
Init sequence, a sequence of mmccc (mm - Monitor, ccc - camera)

Detailed Description

Action 'MBeg init sequence'.

Constructor & Destructor Documentation

GeViAct_MBegInitSeq::GeViAct_MBegInitSeq | ( | GeViClientID | initClient,
 |  | String^ | initSeq
 | ) |  |

Create the action 'MBeg init sequence'.

Parameters:
initClient | Interface ID of GeViTel
initSeq | Init sequence, a sequence of mmccc (mm - Monitor, ccc - camera)

Member Function Documentation

GeViAct_MBegInitSeq GeViAct_MBegInitSeq::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MBegInitSeq::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq::aClient

Interface ID of GeViTel.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq::aSeq

Init sequence, a sequence of mmccc (mm - Monitor, ccc - camera)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MBegInitSeqEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MBegInitSeqEventArgs (GeViAct_MBegInitSeq^ initAction)
Create the EventArgs for handler of action 'MBeg init sequence'.

Properties

GeViClientID | aClient
Interface ID of GeViTel.
String^ | aSeq
Init sequence, a sequence of mmccc (mm - Monitor, ccc - camera)

Private Member Functions

GeViAct_MBegInitSeqEventArgs ()

Detailed Description

EventArgs for handler of action 'MBeg init sequence'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs::GeViAct_MBegInitSeqEventArgs ( ) [private]
GeViAct_MBegInitSeqEventArgs::GeViAct_MBegInitSeqEventArgs ( GeViAct_MBegInitSeq^ initAction )

Create the EventArgs for handler of action 'MBeg init sequence'.

Parameters:
initAction Managed action 'MBeg init sequence'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs::aClient

Interface ID of GeViTel.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs::aSeq

Init sequence, a sequence of mmccc (mm - Monitor, ccc - camera)

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera Class Reference

  • CameraControlActions
  • GeViAct_MBegLockCamera
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera Class Reference
Actions

Action 'Request the exclusive PTZ control'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera:
[legend]

List of all members.

Public Member Functions

GeViAct_MBegLockCamera (GeViClientID initClient, GeViVideoInputID initVideoInput)
Create the action 'Request the exclusive PTZ control'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MBegLockCamera^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClient
Interface ID of GeViTel.
GeViVideoInputID | aVideoInput
ID of video input to switch.

Detailed Description

Action 'Request the exclusive PTZ control'.

Constructor & Destructor Documentation

GeViAct_MBegLockCamera::GeViAct_MBegLockCamera | ( | GeViClientID | initClient,
 |  | GeViVideoInputID | initVideoInput
 | ) |  |

Create the action 'Request the exclusive PTZ control'.

Parameters:
initClient | Interface ID of GeViTel
initVideoInput | ID of video input to switch

Member Function Documentation

GeViAct_MBegLockCamera GeViAct_MBegLockCamera::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MBegLockCamera::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera::aClient

Interface ID of GeViTel.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera::aVideoInput

ID of video input to switch.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MBegLockCameraEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MBegLockCameraEventArgs (GeViAct_MBegLockCamera^ initAction)
Create the EventArgs for handler of action 'Request the exclusive PTZ control'.

Properties

GeViClientID | aClient
Interface ID of GeViTel.
GeViVideoInputID | aVideoInput
ID of video input to switch.

Private Member Functions

GeViAct_MBegLockCameraEventArgs ()

Detailed Description

EventArgs for handler of action 'Request the exclusive PTZ control'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs::GeViAct_MBegLockCameraEventArgs ( ) [private]
GeViAct_MBegLockCameraEventArgs::GeViAct_MBegLockCameraEventArgs ( GeViAct_MBegLockCamera^ initAction )

Create the EventArgs for handler of action 'Request the exclusive PTZ control'.

Parameters:
initAction Managed action 'Request the exclusive PTZ control'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs::aClient

Interface ID of GeViTel.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs::aVideoInput

ID of video input to switch.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera Class Reference

  • CameraControlActions
  • GeViAct_MBegUnlockCamera
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera Class Reference
Actions

Action 'Release the exclusive PTZ control'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera:
[legend]

List of all members.

Public Member Functions

GeViAct_MBegUnlockCamera (GeViClientID initClient)
Create the action 'Release the exclusive PTZ control'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MBegUnlockCamera^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClient
Interface ID of GeViTel.

Detailed Description

Action 'Release the exclusive PTZ control'.

Constructor & Destructor Documentation

GeViAct_MBegUnlockCamera::GeViAct_MBegUnlockCamera ( GeViClientID initClient )

Create the action 'Release the exclusive PTZ control'.

Parameters:
initClient Interface ID of GeViTel

Member Function Documentation

GeViAct_MBegUnlockCamera GeViAct_MBegUnlockCamera::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MBegUnlockCamera::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera::aClient

Interface ID of GeViTel.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MBegUnlockCameraEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MBegUnlockCameraEventArgs (GeViAct_MBegUnlockCamera^ initAction)
Create the EventArgs for handler of action 'Release the exclusive PTZ control'.

Properties

GeViClientID aClient
Interface ID of GeViTel.

Private Member Functions

GeViAct_MBegUnlockCameraEventArgs ()

Detailed Description

EventArgs for handler of action 'Release the exclusive PTZ control'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs::GeViAct_MBegUnlockCameraEventArgs ( ) [private]
GeViAct_MBegUnlockCameraEventArgs::GeViAct_MBegUnlockCameraEventArgs ( GeViAct_MBegUnlockCamera^ initAction )

Create the EventArgs for handler of action 'Release the exclusive PTZ control'.

Parameters:
initAction Managed action 'Release the exclusive PTZ control'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs::aClient

Interface ID of GeViTel.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput Class Reference

  • MIPActions
  • GeViAct_MIPAlarmAuxiliaryInput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput Class Reference
Actions

Action 'MIP alarm auxiliary input'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPAlarmAuxiliaryInput (Int32 initInterfaceID, Int32 initUnit, Int32 initUnitType, Int32 initLocation)
Create the action 'MIP alarm auxiliary input'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPAlarmAuxiliaryInput^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aUnitType
Unit type: 1 - PM, 2 - LU, 3 - RM.
Int32 | aLocation
Alarm location: 0 - tamper 1, 1 - tamper 2, 2 - sensor.

Detailed Description

Action 'MIP alarm auxiliary input'.

Constructor & Destructor Documentation

GeViAct_MIPAlarmAuxiliaryInput::GeViAct_MIPAlarmAuxiliaryInput | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initUnitType,
 |  | Int32 | initLocation
 | ) |  |

Create the action 'MIP alarm auxiliary input'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initUnitType | Unit type: 1 - PM, 2 - LU, 3 - RM.
initLocation | Alarm location: 0 - tamper 1, 1 - tamper 2, 2 - sensor.

Member Function Documentation

GeViAct_MIPAlarmAuxiliaryInput GeViAct_MIPAlarmAuxiliaryInput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPAlarmAuxiliaryInput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput::aLocation

Alarm location: 0 - tamper 1, 1 - tamper 2, 2 - sensor.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput::aUnit

Unit no.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput::aUnitType

Unit type: 1 - PM, 2 - LU, 3 - RM.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPAlarmAuxiliaryInputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPAlarmAuxiliaryInputEventArgs (GeViAct_MIPAlarmAuxiliaryInput^ initAction)
Create the EventArgs for handler of action 'MIP alarm auxiliary input'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aUnitType
Unit type: 1 - PM, 2 - LU, 3 - RM.
Int32 | aLocation
Alarm location: 0 - tamper 1, 1 - tamper 2, 2 - sensor.

Private Member Functions

GeViAct_MIPAlarmAuxiliaryInputEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP alarm auxiliary input'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs::GeViAct_MIPAlarmAuxiliaryInputEventArgs ( ) [private]
GeViAct_MIPAlarmAuxiliaryInputEventArgs::GeViAct_MIPAlarmAuxiliaryInputEventArgs ( GeViAct_MIPAlarmAuxiliaryInput^ initAction )

Create the EventArgs for handler of action 'MIP alarm auxiliary input'.

Parameters:
initAction Managed action 'MIP alarm auxiliary input'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs::aLocation

Alarm location: 0 - tamper 1, 1 - tamper 2, 2 - sensor.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs::aUnit

Unit no.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs::aUnitType

Unit type: 1 - PM, 2 - LU, 3 - RM.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable Class Reference

  • MIPActions
  • GeViAct_MIPAlarmCable
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable Class Reference
Actions

Action 'MIP alarm cable'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPAlarmCable (Int32 initInterfaceID, Int32 initUnit, Int32 initCable, Int32 initLocation)
Create the action 'MIP alarm cable'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPAlarmCable^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aCable
Cable: 0 - cable A, 1 - cable B.
Int32 | aLocation
Alarm location.

Detailed Description

Action 'MIP alarm cable'.

Constructor & Destructor Documentation

GeViAct_MIPAlarmCable::GeViAct_MIPAlarmCable | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initCable,
 |  | Int32 | initLocation
 | ) |  |

Create the action 'MIP alarm cable'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initCable | Cable: 0 - cable A, 1 - cable B.
initLocation | Alarm location.

Member Function Documentation

GeViAct_MIPAlarmCable GeViAct_MIPAlarmCable::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPAlarmCable::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable::aCable

Cable: 0 - cable A, 1 - cable B.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable::aLocation

Alarm location.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPAlarmCableEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPAlarmCableEventArgs (GeViAct_MIPAlarmCable^ initAction)
Create the EventArgs for handler of action 'MIP alarm cable'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aCable
Cable: 0 - cable A, 1 - cable B.
Int32 | aLocation
Alarm location.

Private Member Functions

GeViAct_MIPAlarmCableEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP alarm cable'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs::GeViAct_MIPAlarmCableEventArgs ( ) [private]
GeViAct_MIPAlarmCableEventArgs::GeViAct_MIPAlarmCableEventArgs ( GeViAct_MIPAlarmCable^ initAction )

Create the EventArgs for handler of action 'MIP alarm cable'.

Parameters:
initAction Managed action 'MIP alarm cable'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs::aCable

Cable: 0 - cable A, 1 - cable B.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs::aLocation

Alarm location.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper Class Reference

  • MIPActions
  • GeViAct_MIPAlarmLUTamper
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper Class Reference
Actions

Action 'MIP alarm LU tamper'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPAlarmLUTamper (Int32 initInterfaceID, Int32 initUnit)
Create the action 'MIP alarm LU tamper'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPAlarmLUTamper^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.

Detailed Description

Action 'MIP alarm LU tamper'.

Constructor & Destructor Documentation

GeViAct_MIPAlarmLUTamper::GeViAct_MIPAlarmLUTamper | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit
 | ) |  |

Create the action 'MIP alarm LU tamper'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.

Member Function Documentation

GeViAct_MIPAlarmLUTamper GeViAct_MIPAlarmLUTamper::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPAlarmLUTamper::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPAlarmLUTamperEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPAlarmLUTamperEventArgs (GeViAct_MIPAlarmLUTamper^ initAction)
Create the EventArgs for handler of action 'MIP alarm LU tamper'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.

Private Member Functions

GeViAct_MIPAlarmLUTamperEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP alarm LU tamper'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs::GeViAct_MIPAlarmLUTamperEventArgs ( ) [private]
GeViAct_MIPAlarmLUTamperEventArgs::GeViAct_MIPAlarmLUTamperEventArgs ( GeViAct_MIPAlarmLUTamper^ initAction )

Create the EventArgs for handler of action 'MIP alarm LU tamper'.

Parameters:
initAction Managed action 'MIP alarm LU tamper'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper Class Reference

  • MIPActions
  • GeViAct_MIPAlarmPMTamper
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper Class Reference
Actions

Action 'MIP alarm PM tamper'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPAlarmPMTamper (Int32 initInterfaceID, Int32 initUnit)
Create the action 'MIP alarm PM tamper'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPAlarmPMTamper^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.

Detailed Description

Action 'MIP alarm PM tamper'.

Constructor & Destructor Documentation

GeViAct_MIPAlarmPMTamper::GeViAct_MIPAlarmPMTamper | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit
 | ) |  |

Create the action 'MIP alarm PM tamper'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.

Member Function Documentation

GeViAct_MIPAlarmPMTamper GeViAct_MIPAlarmPMTamper::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPAlarmPMTamper::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPAlarmPMTamperEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPAlarmPMTamperEventArgs (GeViAct_MIPAlarmPMTamper^ initAction)
Create the EventArgs for handler of action 'MIP alarm PM tamper'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.

Private Member Functions

GeViAct_MIPAlarmPMTamperEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP alarm PM tamper'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs::GeViAct_MIPAlarmPMTamperEventArgs ( ) [private]
GeViAct_MIPAlarmPMTamperEventArgs::GeViAct_MIPAlarmPMTamperEventArgs ( GeViAct_MIPAlarmPMTamper^ initAction )

Create the EventArgs for handler of action 'MIP alarm PM tamper'.

Parameters:
initAction Managed action 'MIP alarm PM tamper'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper Class Reference

  • MIPActions
  • GeViAct_MIPAlarmRMTamper
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper Class Reference
Actions

Action 'MIP alarm RM tamper'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPAlarmRMTamper (Int32 initInterfaceID, Int32 initUnit)
Create the action 'MIP alarm RM tamper'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPAlarmRMTamper^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.

Detailed Description

Action 'MIP alarm RM tamper'.

Constructor & Destructor Documentation

GeViAct_MIPAlarmRMTamper::GeViAct_MIPAlarmRMTamper | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit
 | ) |  |

Create the action 'MIP alarm RM tamper'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.

Member Function Documentation

GeViAct_MIPAlarmRMTamper GeViAct_MIPAlarmRMTamper::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPAlarmRMTamper::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPAlarmRMTamperEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPAlarmRMTamperEventArgs (GeViAct_MIPAlarmRMTamper^ initAction)
Create the EventArgs for handler of action 'MIP alarm RM tamper'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.

Private Member Functions

GeViAct_MIPAlarmRMTamperEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP alarm RM tamper'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs::GeViAct_MIPAlarmRMTamperEventArgs ( ) [private]
GeViAct_MIPAlarmRMTamperEventArgs::GeViAct_MIPAlarmRMTamperEventArgs ( GeViAct_MIPAlarmRMTamper^ initAction )

Create the EventArgs for handler of action 'MIP alarm RM tamper'.

Parameters:
initAction Managed action 'MIP alarm RM tamper'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState Class Reference

  • MIPActions
  • GeViAct_MIPAuxiliaryAlarmState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState Class Reference
Actions

Action 'MIP auxiliary alarm state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPAuxiliaryAlarmState (Int32 initInterfaceID, Int32 initUnit, Int32 initUnitType, Int32 initAlarmState)
Create the action 'MIP auxiliary alarm state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPAuxiliaryAlarmState^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aUnitType
Unit type: 1 - PM, 2 - LU, 3 - RM.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Detailed Description

Action 'MIP auxiliary alarm state'.

Constructor & Destructor Documentation

GeViAct_MIPAuxiliaryAlarmState::GeViAct_MIPAuxiliaryAlarmState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initUnitType,
 |  | Int32 | initAlarmState
 | ) |  |

Create the action 'MIP auxiliary alarm state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initUnitType | Unit type: 1 - PM, 2 - LU, 3 - RM.
initAlarmState | Current alarm state: 0 - normal, 1 - alarm.

Member Function Documentation

GeViAct_MIPAuxiliaryAlarmState GeViAct_MIPAuxiliaryAlarmState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPAuxiliaryAlarmState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState::aUnit

Unit no.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState::aUnitType

Unit type: 1 - PM, 2 - LU, 3 - RM.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPAuxiliaryAlarmStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPAuxiliaryAlarmStateEventArgs (GeViAct_MIPAuxiliaryAlarmState^ initAction)
Create the EventArgs for handler of action 'MIP auxiliary alarm state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aUnitType
Unit type: 1 - PM, 2 - LU, 3 - RM.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Private Member Functions

GeViAct_MIPAuxiliaryAlarmStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP auxiliary alarm state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs::GeViAct_MIPAuxiliaryAlarmStateEventArgs ( ) [private]
GeViAct_MIPAuxiliaryAlarmStateEventArgs::GeViAct_MIPAuxiliaryAlarmStateEventArgs ( GeViAct_MIPAuxiliaryAlarmState^ initAction )

Create the EventArgs for handler of action 'MIP auxiliary alarm state'.

Parameters:
initAction Managed action 'MIP auxiliary alarm state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs::aUnit

Unit no.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs::aUnitType

Unit type: 1 - PM, 2 - LU, 3 - RM.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus Class Reference

  • MIPActions
  • GeViAct_MIPAuxiliarySensorStatus
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus Class Reference
Actions

Action 'MIP auxiliary sensor status'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPAuxiliarySensorStatus (Int32 initInterfaceID, Int32 initUnit, Int32 initUnitType, Int32 initStatus)
Create the action 'MIP auxiliary sensor status'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPAuxiliarySensorStatus^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aUnitType
Unit type: 1 - PM, 2 - LU, 3 - RM.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Detailed Description

Action 'MIP auxiliary sensor status'.

Constructor & Destructor Documentation

GeViAct_MIPAuxiliarySensorStatus::GeViAct_MIPAuxiliarySensorStatus | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initUnitType,
 |  | Int32 | initStatus
 | ) |  |

Create the action 'MIP auxiliary sensor status'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initUnitType | Unit type: 1 - PM, 2 - LU, 3 - RM.
initStatus | Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Member Function Documentation

GeViAct_MIPAuxiliarySensorStatus GeViAct_MIPAuxiliarySensorStatus::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPAuxiliarySensorStatus::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus::aUnit

Unit no.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus::aUnitType

Unit type: 1 - PM, 2 - LU, 3 - RM.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPAuxiliarySensorStatusEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPAuxiliarySensorStatusEventArgs (GeViAct_MIPAuxiliarySensorStatus^ initAction)
Create the EventArgs for handler of action 'MIP auxiliary sensor status'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aUnitType
Unit type: 1 - PM, 2 - LU, 3 - RM.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Private Member Functions

GeViAct_MIPAuxiliarySensorStatusEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP auxiliary sensor status'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs::GeViAct_MIPAuxiliarySensorStatusEventArgs ( ) [private]
GeViAct_MIPAuxiliarySensorStatusEventArgs::GeViAct_MIPAuxiliarySensorStatusEventArgs ( GeViAct_MIPAuxiliarySensorStatus^ initAction )

Create the EventArgs for handler of action 'MIP auxiliary sensor status'.

Parameters:
initAction Managed action 'MIP auxiliary sensor status'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs::aUnit

Unit no.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs::aUnitType

Unit type: 1 - PM, 2 - LU, 3 - RM.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState Class Reference

  • MIPActions
  • GeViAct_MIPCableAFaultState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState Class Reference
Actions

Action 'MIP cable A failure state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPCableAFaultState (Int32 initInterfaceID, Int32 initUnit, Int32 initState)
Create the action 'MIP cable A failure state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPCableAFaultState^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Detailed Description

Action 'MIP cable A failure state'.

Constructor & Destructor Documentation

GeViAct_MIPCableAFaultState::GeViAct_MIPCableAFaultState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initState
 | ) |  |

Create the action 'MIP cable A failure state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initState | Current failure state: 0 - normal, 1 - failure.

Member Function Documentation

GeViAct_MIPCableAFaultState GeViAct_MIPCableAFaultState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPCableAFaultState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPCableAFaultStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPCableAFaultStateEventArgs (GeViAct_MIPCableAFaultState^ initAction)
Create the EventArgs for handler of action 'MIP cable A failure state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Private Member Functions

GeViAct_MIPCableAFaultStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP cable A failure state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs::GeViAct_MIPCableAFaultStateEventArgs ( ) [private]
GeViAct_MIPCableAFaultStateEventArgs::GeViAct_MIPCableAFaultStateEventArgs ( GeViAct_MIPCableAFaultState^ initAction )

Create the EventArgs for handler of action 'MIP cable A failure state'.

Parameters:
initAction Managed action 'MIP cable A failure state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState Class Reference

  • MIPActions
  • GeViAct_MIPCableBFaultState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState Class Reference
Actions

Action 'MIP cable B failure state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPCableBFaultState (Int32 initInterfaceID, Int32 initUnit, Int32 initState)
Create the action 'MIP cable B failure state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPCableBFaultState^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Detailed Description

Action 'MIP cable B failure state'.

Constructor & Destructor Documentation

GeViAct_MIPCableBFaultState::GeViAct_MIPCableBFaultState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initState
 | ) |  |

Create the action 'MIP cable B failure state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initState | Current failure state: 0 - normal, 1 - failure.

Member Function Documentation

GeViAct_MIPCableBFaultState GeViAct_MIPCableBFaultState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPCableBFaultState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPCableBFaultStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPCableBFaultStateEventArgs (GeViAct_MIPCableBFaultState^ initAction)
Create the EventArgs for handler of action 'MIP cable B failure state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Private Member Functions

GeViAct_MIPCableBFaultStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP cable B failure state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs::GeViAct_MIPCableBFaultStateEventArgs ( ) [private]
GeViAct_MIPCableBFaultStateEventArgs::GeViAct_MIPCableBFaultStateEventArgs ( GeViAct_MIPCableBFaultState^ initAction )

Create the EventArgs for handler of action 'MIP cable B failure state'.

Parameters:
initAction Managed action 'MIP cable B failure state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState Class Reference

  • MIPActions
  • GeViAct_MIPDisplaySegmentAlarmState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState Class Reference
Actions

Action 'MIP display segment alarm state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPDisplaySegmentAlarmState (Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState)
Create the action 'MIP display segment alarm state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPDisplaySegmentAlarmState^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Detailed Description

Action 'MIP display segment alarm state'.

Constructor & Destructor Documentation

GeViAct_MIPDisplaySegmentAlarmState::GeViAct_MIPDisplaySegmentAlarmState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initAlarmState
 | ) |  |

Create the action 'MIP display segment alarm state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initAlarmState | Current alarm state: 0 - normal, 1 - alarm.

Member Function Documentation

GeViAct_MIPDisplaySegmentAlarmState GeViAct_MIPDisplaySegmentAlarmState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPDisplaySegmentAlarmState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPDisplaySegmentAlarmStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPDisplaySegmentAlarmStateEventArgs (GeViAct_MIPDisplaySegmentAlarmState^ initAction)
Create the EventArgs for handler of action 'MIP display segment alarm state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Private Member Functions

GeViAct_MIPDisplaySegmentAlarmStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP display segment alarm state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs::GeViAct_MIPDisplaySegmentAlarmStateEventArgs ( ) [private]
GeViAct_MIPDisplaySegmentAlarmStateEventArgs::GeViAct_MIPDisplaySegmentAlarmStateEventArgs ( GeViAct_MIPDisplaySegmentAlarmState^ initAction )

Create the EventArgs for handler of action 'MIP display segment alarm state'.

Parameters:
initAction Managed action 'MIP display segment alarm state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus Class Reference

  • MIPActions
  • GeViAct_MIPDisplaySegmentStatus
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus Class Reference
Actions

Action 'MIP display segment status'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPDisplaySegmentStatus (Int32 initInterfaceID, Int32 initUnit, Int32 initStatus)
Create the action 'MIP display segment status'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPDisplaySegmentStatus^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Detailed Description

Action 'MIP display segment status'.

Constructor & Destructor Documentation

GeViAct_MIPDisplaySegmentStatus::GeViAct_MIPDisplaySegmentStatus | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initStatus
 | ) |  |

Create the action 'MIP display segment status'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Member Function Documentation

GeViAct_MIPDisplaySegmentStatus GeViAct_MIPDisplaySegmentStatus::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPDisplaySegmentStatus::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPDisplaySegmentStatusEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPDisplaySegmentStatusEventArgs (GeViAct_MIPDisplaySegmentStatus^ initAction)
Create the EventArgs for handler of action 'MIP display segment status'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Private Member Functions

GeViAct_MIPDisplaySegmentStatusEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP display segment status'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs::GeViAct_MIPDisplaySegmentStatusEventArgs ( ) [private]
GeViAct_MIPDisplaySegmentStatusEventArgs::GeViAct_MIPDisplaySegmentStatusEventArgs ( GeViAct_MIPDisplaySegmentStatus^ initAction )

Create the EventArgs for handler of action 'MIP display segment status'.

Parameters:
initAction Managed action 'MIP display segment status'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState Class Reference

  • MIPActions
  • GeViAct_MIPLUTamperAlarmState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState Class Reference
Actions

Action 'MIP LU tamper alarm state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPLUTamperAlarmState (Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState)
Create the action 'MIP LU tamper alarm state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPLUTamperAlarmState^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Detailed Description

Action 'MIP LU tamper alarm state'.

Constructor & Destructor Documentation

GeViAct_MIPLUTamperAlarmState::GeViAct_MIPLUTamperAlarmState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initAlarmState
 | ) |  |

Create the action 'MIP LU tamper alarm state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initAlarmState | Current alarm state: 0 - normal, 1 - alarm.

Member Function Documentation

GeViAct_MIPLUTamperAlarmState GeViAct_MIPLUTamperAlarmState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPLUTamperAlarmState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPLUTamperAlarmStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPLUTamperAlarmStateEventArgs (GeViAct_MIPLUTamperAlarmState^ initAction)
Create the EventArgs for handler of action 'MIP LU tamper alarm state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Private Member Functions

GeViAct_MIPLUTamperAlarmStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP LU tamper alarm state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs::GeViAct_MIPLUTamperAlarmStateEventArgs ( ) [private]
GeViAct_MIPLUTamperAlarmStateEventArgs::GeViAct_MIPLUTamperAlarmStateEventArgs ( GeViAct_MIPLUTamperAlarmState^ initAction )

Create the EventArgs for handler of action 'MIP LU tamper alarm state'.

Parameters:
initAction Managed action 'MIP LU tamper alarm state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus Class Reference

  • MIPActions
  • GeViAct_MIPLUTamperStatus
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus Class Reference
Actions

Action 'MIP LU tamper status'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPLUTamperStatus (Int32 initInterfaceID, Int32 initUnit, Int32 initStatus)
Create the action 'MIP LU tamper status'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPLUTamperStatus^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Detailed Description

Action 'MIP LU tamper status'.

Constructor & Destructor Documentation

GeViAct_MIPLUTamperStatus::GeViAct_MIPLUTamperStatus | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initStatus
 | ) |  |

Create the action 'MIP LU tamper status'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Member Function Documentation

GeViAct_MIPLUTamperStatus GeViAct_MIPLUTamperStatus::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPLUTamperStatus::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPLUTamperStatusEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPLUTamperStatusEventArgs (GeViAct_MIPLUTamperStatus^ initAction)
Create the EventArgs for handler of action 'MIP LU tamper status'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Private Member Functions

GeViAct_MIPLUTamperStatusEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP LU tamper status'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs::GeViAct_MIPLUTamperStatusEventArgs ( ) [private]
GeViAct_MIPLUTamperStatusEventArgs::GeViAct_MIPLUTamperStatusEventArgs ( GeViAct_MIPLUTamperStatus^ initAction )

Create the EventArgs for handler of action 'MIP LU tamper status'.

Parameters:
initAction Managed action 'MIP LU tamper status'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline Class Reference

  • MIPActions
  • GeViAct_MIPOffline
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline Class Reference
Actions

Action 'MIP interface offnline'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPOffline (Int32 initInterfaceID)
Create the action 'MIP interface offnline'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPOffline^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.

Detailed Description

Action 'MIP interface offnline'.

Constructor & Destructor Documentation

GeViAct_MIPOffline::GeViAct_MIPOffline ( Int32 initInterfaceID )

Create the action 'MIP interface offnline'.

Parameters:
initInterfaceID Interface ID of the corresponding GeMIP.

Member Function Documentation

GeViAct_MIPOffline GeViAct_MIPOffline::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPOffline::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline::aInterfaceID

Interface ID of the corresponding GeMIP.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPOfflineEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPOfflineEventArgs (GeViAct_MIPOffline^ initAction)
Create the EventArgs for handler of action 'MIP interface offnline'.

Properties

Int32 aInterfaceID
Interface ID of the corresponding GeMIP.

Private Member Functions

GeViAct_MIPOfflineEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP interface offnline'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs::GeViAct_MIPOfflineEventArgs ( ) [private]
GeViAct_MIPOfflineEventArgs::GeViAct_MIPOfflineEventArgs ( GeViAct_MIPOffline^ initAction )

Create the EventArgs for handler of action 'MIP interface offnline'.

Parameters:
initAction Managed action 'MIP interface offnline'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline Class Reference

  • MIPActions
  • GeViAct_MIPOnline
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline Class Reference
Actions

Action 'MIP interface online'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPOnline (Int32 initInterfaceID)
Create the action 'MIP interface online'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPOnline^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.

Detailed Description

Action 'MIP interface online'.

Constructor & Destructor Documentation

GeViAct_MIPOnline::GeViAct_MIPOnline ( Int32 initInterfaceID )

Create the action 'MIP interface online'.

Parameters:
initInterfaceID Interface ID of the corresponding GeMIP.

Member Function Documentation

GeViAct_MIPOnline GeViAct_MIPOnline::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPOnline::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline::aInterfaceID

Interface ID of the corresponding GeMIP.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPOnlineEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPOnlineEventArgs (GeViAct_MIPOnline^ initAction)
Create the EventArgs for handler of action 'MIP interface online'.

Properties

Int32 aInterfaceID
Interface ID of the corresponding GeMIP.

Private Member Functions

GeViAct_MIPOnlineEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP interface online'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs::GeViAct_MIPOnlineEventArgs ( ) [private]
GeViAct_MIPOnlineEventArgs::GeViAct_MIPOnlineEventArgs ( GeViAct_MIPOnline^ initAction )

Create the EventArgs for handler of action 'MIP interface online'.

Parameters:
initAction Managed action 'MIP interface online'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState Class Reference

  • MIPActions
  • GeViAct_MIPPMComFailState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState Class Reference
Actions

Action 'MIP PM COM failure state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPPMComFailState (Int32 initInterfaceID, Int32 initUnit, Int32 initState)
Create the action 'MIP PM COM failure state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPPMComFailState^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Detailed Description

Action 'MIP PM COM failure state'.

Constructor & Destructor Documentation

GeViAct_MIPPMComFailState::GeViAct_MIPPMComFailState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initState
 | ) |  |

Create the action 'MIP PM COM failure state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initState | Current failure state: 0 - normal, 1 - failure.

Member Function Documentation

GeViAct_MIPPMComFailState GeViAct_MIPPMComFailState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPPMComFailState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPPMComFailStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPPMComFailStateEventArgs (GeViAct_MIPPMComFailState^ initAction)
Create the EventArgs for handler of action 'MIP PM COM failure state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Private Member Functions

GeViAct_MIPPMComFailStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP PM COM failure state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs::GeViAct_MIPPMComFailStateEventArgs ( ) [private]
GeViAct_MIPPMComFailStateEventArgs::GeViAct_MIPPMComFailStateEventArgs ( GeViAct_MIPPMComFailState^ initAction )

Create the EventArgs for handler of action 'MIP PM COM failure state'.

Parameters:
initAction Managed action 'MIP PM COM failure state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState Class Reference

  • MIPActions
  • GeViAct_MIPPMTamperAlarmState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState Class Reference
Actions

Action 'MIP PM tamper alarm state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPPMTamperAlarmState (Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState)
Create the action 'MIP PM tamper alarm state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPPMTamperAlarmState^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Detailed Description

Action 'MIP PM tamper alarm state'.

Constructor & Destructor Documentation

GeViAct_MIPPMTamperAlarmState::GeViAct_MIPPMTamperAlarmState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initAlarmState
 | ) |  |

Create the action 'MIP PM tamper alarm state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initAlarmState | Current alarm state: 0 - normal, 1 - alarm.

Member Function Documentation

GeViAct_MIPPMTamperAlarmState GeViAct_MIPPMTamperAlarmState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPPMTamperAlarmState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPPMTamperAlarmStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPPMTamperAlarmStateEventArgs (GeViAct_MIPPMTamperAlarmState^ initAction)
Create the EventArgs for handler of action 'MIP PM tamper alarm state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Private Member Functions

GeViAct_MIPPMTamperAlarmStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP PM tamper alarm state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs::GeViAct_MIPPMTamperAlarmStateEventArgs ( ) [private]
GeViAct_MIPPMTamperAlarmStateEventArgs::GeViAct_MIPPMTamperAlarmStateEventArgs ( GeViAct_MIPPMTamperAlarmState^ initAction )

Create the EventArgs for handler of action 'MIP PM tamper alarm state'.

Parameters:
initAction Managed action 'MIP PM tamper alarm state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus Class Reference

  • MIPActions
  • GeViAct_MIPPMTamperStatus
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus Class Reference
Actions

Action 'MIP PM tamper status'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPPMTamperStatus (Int32 initInterfaceID, Int32 initUnit, Int32 initStatus)
Create the action 'MIP PM tamper status'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPPMTamperStatus^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Detailed Description

Action 'MIP PM tamper status'.

Constructor & Destructor Documentation

GeViAct_MIPPMTamperStatus::GeViAct_MIPPMTamperStatus | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initStatus
 | ) |  |

Create the action 'MIP PM tamper status'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Member Function Documentation

GeViAct_MIPPMTamperStatus GeViAct_MIPPMTamperStatus::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPPMTamperStatus::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPPMTamperStatusEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPPMTamperStatusEventArgs (GeViAct_MIPPMTamperStatus^ initAction)
Create the EventArgs for handler of action 'MIP PM tamper status'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Private Member Functions

GeViAct_MIPPMTamperStatusEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP PM tamper status'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs::GeViAct_MIPPMTamperStatusEventArgs ( ) [private]
GeViAct_MIPPMTamperStatusEventArgs::GeViAct_MIPPMTamperStatusEventArgs ( GeViAct_MIPPMTamperStatus^ initAction )

Create the EventArgs for handler of action 'MIP PM tamper status'.

Parameters:
initAction Managed action 'MIP PM tamper status'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface Class Reference

  • MIPActions
  • GeViAct_MIPQueryInterface
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface Class Reference
Actions

Action 'MIP query interface'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPQueryInterface (Int32 initInterfaceID)
Create the action 'MIP query interface'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPQueryInterface^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.

Detailed Description

Action 'MIP query interface'.

Constructor & Destructor Documentation

GeViAct_MIPQueryInterface::GeViAct_MIPQueryInterface ( Int32 initInterfaceID )

Create the action 'MIP query interface'.

Parameters:
initInterfaceID Interface ID of the corresponding GeMIP.

Member Function Documentation

GeViAct_MIPQueryInterface GeViAct_MIPQueryInterface::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPQueryInterface::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface::aInterfaceID

Interface ID of the corresponding GeMIP.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPQueryInterfaceEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPQueryInterfaceEventArgs (GeViAct_MIPQueryInterface^ initAction)
Create the EventArgs for handler of action 'MIP query interface'.

Properties

Int32 aInterfaceID
Interface ID of the corresponding GeMIP.

Private Member Functions

GeViAct_MIPQueryInterfaceEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP query interface'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs::GeViAct_MIPQueryInterfaceEventArgs ( ) [private]
GeViAct_MIPQueryInterfaceEventArgs::GeViAct_MIPQueryInterfaceEventArgs ( GeViAct_MIPQueryInterface^ initAction )

Create the EventArgs for handler of action 'MIP query interface'.

Parameters:
initAction Managed action 'MIP query interface'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState Class Reference

  • MIPActions
  • GeViAct_MIPRMComFailState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState Class Reference
Actions

Action 'MIP RM COM failure state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPRMComFailState (Int32 initInterfaceID, Int32 initUnit, Int32 initState)
Create the action 'MIP RM COM failure state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPRMComFailState^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Detailed Description

Action 'MIP RM COM failure state'.

Constructor & Destructor Documentation

GeViAct_MIPRMComFailState::GeViAct_MIPRMComFailState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initState
 | ) |  |

Create the action 'MIP RM COM failure state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initState | Current failure state: 0 - normal, 1 - failure.

Member Function Documentation

GeViAct_MIPRMComFailState GeViAct_MIPRMComFailState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPRMComFailState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPRMComFailStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPRMComFailStateEventArgs (GeViAct_MIPRMComFailState^ initAction)
Create the EventArgs for handler of action 'MIP RM COM failure state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aState
Current failure state: 0 - normal, 1 - failure.

Private Member Functions

GeViAct_MIPRMComFailStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP RM COM failure state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs::GeViAct_MIPRMComFailStateEventArgs ( ) [private]
GeViAct_MIPRMComFailStateEventArgs::GeViAct_MIPRMComFailStateEventArgs ( GeViAct_MIPRMComFailState^ initAction )

Create the EventArgs for handler of action 'MIP RM COM failure state'.

Parameters:
initAction Managed action 'MIP RM COM failure state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs::aState

Current failure state: 0 - normal, 1 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState Class Reference

  • MIPActions
  • GeViAct_MIPRMTamperAlarmState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState Class Reference
Actions

Action 'MIP RM tamper alarm state'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPRMTamperAlarmState (Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState)
Create the action 'MIP RM tamper alarm state'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPRMTamperAlarmState^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Detailed Description

Action 'MIP RM tamper alarm state'.

Constructor & Destructor Documentation

GeViAct_MIPRMTamperAlarmState::GeViAct_MIPRMTamperAlarmState | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initAlarmState
 | ) |  |

Create the action 'MIP RM tamper alarm state'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initAlarmState | Current alarm state: 0 - normal, 1 - alarm.

Member Function Documentation

GeViAct_MIPRMTamperAlarmState GeViAct_MIPRMTamperAlarmState::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPRMTamperAlarmState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPRMTamperAlarmStateEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPRMTamperAlarmStateEventArgs (GeViAct_MIPRMTamperAlarmState^ initAction)
Create the EventArgs for handler of action 'MIP RM tamper alarm state'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aAlarmState
Current alarm state: 0 - normal, 1 - alarm.

Private Member Functions

GeViAct_MIPRMTamperAlarmStateEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP RM tamper alarm state'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs::GeViAct_MIPRMTamperAlarmStateEventArgs ( ) [private]
GeViAct_MIPRMTamperAlarmStateEventArgs::GeViAct_MIPRMTamperAlarmStateEventArgs ( GeViAct_MIPRMTamperAlarmState^ initAction )

Create the EventArgs for handler of action 'MIP RM tamper alarm state'.

Parameters:
initAction Managed action 'MIP RM tamper alarm state'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs::aAlarmState

Current alarm state: 0 - normal, 1 - alarm.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus Class Reference

  • MIPActions
  • GeViAct_MIPRMTamperStatus
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus Class Reference
Actions

Action 'MIP RM tamper status'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPRMTamperStatus (Int32 initInterfaceID, Int32 initUnit, Int32 initStatus)
Create the action 'MIP RM tamper status'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPRMTamperStatus^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Detailed Description

Action 'MIP RM tamper status'.

Constructor & Destructor Documentation

GeViAct_MIPRMTamperStatus::GeViAct_MIPRMTamperStatus | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Int32 | initStatus
 | ) |  |

Create the action 'MIP RM tamper status'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Member Function Documentation

GeViAct_MIPRMTamperStatus GeViAct_MIPRMTamperStatus::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPRMTamperStatus::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPRMTamperStatusEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPRMTamperStatusEventArgs (GeViAct_MIPRMTamperStatus^ initAction)
Create the EventArgs for handler of action 'MIP RM tamper status'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Int32 | aStatus
Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Private Member Functions

GeViAct_MIPRMTamperStatusEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP RM tamper status'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs::GeViAct_MIPRMTamperStatusEventArgs ( ) [private]
GeViAct_MIPRMTamperStatusEventArgs::GeViAct_MIPRMTamperStatusEventArgs ( GeViAct_MIPRMTamperStatus^ initAction )

Create the EventArgs for handler of action 'MIP RM tamper status'.

Parameters:
initAction Managed action 'MIP RM tamper status'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs::aStatus

Current unit status: 0 - inactive, 1 - access, 2 - secure, 3 - failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor Class Reference

  • MIPActions
  • GeViAct_MIPSecureAuxiliarySensor
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor Class Reference
Actions

Action 'MIP secure auxiliary sensor'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPSecureAuxiliarySensor (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP secure auxiliary sensor'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPSecureAuxiliarySensor^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Detailed Description

Action 'MIP secure auxiliary sensor'.

Constructor & Destructor Documentation

GeViAct_MIPSecureAuxiliarySensor::GeViAct_MIPSecureAuxiliarySensor | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP secure auxiliary sensor'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Secure unit if true, grant access otherwise.

Member Function Documentation

GeViAct_MIPSecureAuxiliarySensor GeViAct_MIPSecureAuxiliarySensor::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPSecureAuxiliarySensor::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPSecureAuxiliarySensorEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPSecureAuxiliarySensorEventArgs (GeViAct_MIPSecureAuxiliarySensor^ initAction)
Create the EventArgs for handler of action 'MIP secure auxiliary sensor'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Private Member Functions

GeViAct_MIPSecureAuxiliarySensorEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP secure auxiliary sensor'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs::GeViAct_MIPSecureAuxiliarySensorEventArgs ( ) [private]
GeViAct_MIPSecureAuxiliarySensorEventArgs::GeViAct_MIPSecureAuxiliarySensorEventArgs ( GeViAct_MIPSecureAuxiliarySensor^ initAction )

Create the EventArgs for handler of action 'MIP secure auxiliary sensor'.

Parameters:
initAction Managed action 'MIP secure auxiliary sensor'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 Class Reference

  • MIPActions
  • GeViAct_MIPSecureAuxiliaryTP1
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 Class Reference
Actions

Action 'MIP secure TP 1'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPSecureAuxiliaryTP1 (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP secure TP 1'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPSecureAuxiliaryTP1^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Detailed Description

Action 'MIP secure TP 1'.

Constructor & Destructor Documentation

GeViAct_MIPSecureAuxiliaryTP1::GeViAct_MIPSecureAuxiliaryTP1 | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP secure TP 1'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Secure unit if true, grant access otherwise.

Member Function Documentation

GeViAct_MIPSecureAuxiliaryTP1 GeViAct_MIPSecureAuxiliaryTP1::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPSecureAuxiliaryTP1::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPSecureAuxiliaryTP1EventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPSecureAuxiliaryTP1EventArgs (GeViAct_MIPSecureAuxiliaryTP1^ initAction)
Create the EventArgs for handler of action 'MIP secure TP 1'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Private Member Functions

GeViAct_MIPSecureAuxiliaryTP1EventArgs ()

Detailed Description

EventArgs for handler of action 'MIP secure TP 1'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs::GeViAct_MIPSecureAuxiliaryTP1EventArgs ( ) [private]
GeViAct_MIPSecureAuxiliaryTP1EventArgs::GeViAct_MIPSecureAuxiliaryTP1EventArgs ( GeViAct_MIPSecureAuxiliaryTP1^ initAction )

Create the EventArgs for handler of action 'MIP secure TP 1'.

Parameters:
initAction Managed action 'MIP secure TP 1'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 Class Reference

  • MIPActions
  • GeViAct_MIPSecureAuxiliaryTP2
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 Class Reference
Actions

Action 'MIP secure TP 2'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPSecureAuxiliaryTP2 (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP secure TP 2'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPSecureAuxiliaryTP2^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Detailed Description

Action 'MIP secure TP 2'.

Constructor & Destructor Documentation

GeViAct_MIPSecureAuxiliaryTP2::GeViAct_MIPSecureAuxiliaryTP2 | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP secure TP 2'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Secure unit if true, grant access otherwise.

Member Function Documentation

GeViAct_MIPSecureAuxiliaryTP2 GeViAct_MIPSecureAuxiliaryTP2::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPSecureAuxiliaryTP2::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPSecureAuxiliaryTP2EventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPSecureAuxiliaryTP2EventArgs (GeViAct_MIPSecureAuxiliaryTP2^ initAction)
Create the EventArgs for handler of action 'MIP secure TP 2'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Private Member Functions

GeViAct_MIPSecureAuxiliaryTP2EventArgs ()

Detailed Description

EventArgs for handler of action 'MIP secure TP 2'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs::GeViAct_MIPSecureAuxiliaryTP2EventArgs ( ) [private]
GeViAct_MIPSecureAuxiliaryTP2EventArgs::GeViAct_MIPSecureAuxiliaryTP2EventArgs ( GeViAct_MIPSecureAuxiliaryTP2^ initAction )

Create the EventArgs for handler of action 'MIP secure TP 2'.

Parameters:
initAction Managed action 'MIP secure TP 2'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment Class Reference

  • MIPActions
  • GeViAct_MIPSecureDisplaySegment
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment Class Reference
Actions

Action 'MIP secure display segment'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPSecureDisplaySegment (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP secure display segment'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPSecureDisplaySegment^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Detailed Description

Action 'MIP secure display segment'.

Constructor & Destructor Documentation

GeViAct_MIPSecureDisplaySegment::GeViAct_MIPSecureDisplaySegment | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP secure display segment'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Secure unit if true, grant access otherwise.

Member Function Documentation

GeViAct_MIPSecureDisplaySegment GeViAct_MIPSecureDisplaySegment::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPSecureDisplaySegment::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPSecureDisplaySegmentEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPSecureDisplaySegmentEventArgs (GeViAct_MIPSecureDisplaySegment^ initAction)
Create the EventArgs for handler of action 'MIP secure display segment'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Private Member Functions

GeViAct_MIPSecureDisplaySegmentEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP secure display segment'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs::GeViAct_MIPSecureDisplaySegmentEventArgs ( ) [private]
GeViAct_MIPSecureDisplaySegmentEventArgs::GeViAct_MIPSecureDisplaySegmentEventArgs ( GeViAct_MIPSecureDisplaySegment^ initAction )

Create the EventArgs for handler of action 'MIP secure display segment'.

Parameters:
initAction Managed action 'MIP secure display segment'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU Class Reference

  • MIPActions
  • GeViAct_MIPSecureLU
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU Class Reference
Actions

Action 'MIP secure LU'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPSecureLU (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP secure LU'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPSecureLU^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Detailed Description

Action 'MIP secure LU'.

Constructor & Destructor Documentation

GeViAct_MIPSecureLU::GeViAct_MIPSecureLU | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP secure LU'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Secure unit if true, grant access otherwise.

Member Function Documentation

GeViAct_MIPSecureLU GeViAct_MIPSecureLU::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPSecureLU::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPSecureLUEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPSecureLUEventArgs (GeViAct_MIPSecureLU^ initAction)
Create the EventArgs for handler of action 'MIP secure LU'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Private Member Functions

GeViAct_MIPSecureLUEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP secure LU'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs::GeViAct_MIPSecureLUEventArgs ( ) [private]
GeViAct_MIPSecureLUEventArgs::GeViAct_MIPSecureLUEventArgs ( GeViAct_MIPSecureLU^ initAction )

Create the EventArgs for handler of action 'MIP secure LU'.

Parameters:
initAction Managed action 'MIP secure LU'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM Class Reference

  • MIPActions
  • GeViAct_MIPSecurePM
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM Class Reference
Actions

Action 'MIP secure PM'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPSecurePM (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP secure PM'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPSecurePM^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Detailed Description

Action 'MIP secure PM'.

Constructor & Destructor Documentation

GeViAct_MIPSecurePM::GeViAct_MIPSecurePM | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP secure PM'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Secure unit if true, grant access otherwise.

Member Function Documentation

GeViAct_MIPSecurePM GeViAct_MIPSecurePM::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPSecurePM::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPSecurePMEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPSecurePMEventArgs (GeViAct_MIPSecurePM^ initAction)
Create the EventArgs for handler of action 'MIP secure PM'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Private Member Functions

GeViAct_MIPSecurePMEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP secure PM'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs::GeViAct_MIPSecurePMEventArgs ( ) [private]
GeViAct_MIPSecurePMEventArgs::GeViAct_MIPSecurePMEventArgs ( GeViAct_MIPSecurePM^ initAction )

Create the EventArgs for handler of action 'MIP secure PM'.

Parameters:
initAction Managed action 'MIP secure PM'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM Class Reference

  • MIPActions
  • GeViAct_MIPSecureRM
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM Class Reference
Actions

Action 'MIP secure RM'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPSecureRM (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP secure RM'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MIPSecureRM^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Detailed Description

Action 'MIP secure RM'.

Constructor & Destructor Documentation

GeViAct_MIPSecureRM::GeViAct_MIPSecureRM | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP secure RM'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Secure unit if true, grant access otherwise.

Member Function Documentation

GeViAct_MIPSecureRM GeViAct_MIPSecureRM::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPSecureRM::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPSecureRMEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPSecureRMEventArgs (GeViAct_MIPSecureRM^ initAction)
Create the EventArgs for handler of action 'MIP secure RM'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Secure unit if true, grant access otherwise.

Private Member Functions

GeViAct_MIPSecureRMEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP secure RM'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs::GeViAct_MIPSecureRMEventArgs ( ) [private]
GeViAct_MIPSecureRMEventArgs::GeViAct_MIPSecureRMEventArgs ( GeViAct_MIPSecureRM^ initAction )

Create the EventArgs for handler of action 'MIP secure RM'.

Parameters:
initAction Managed action 'MIP secure RM'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs::aStatus

Secure unit if true, grant access otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl Class Reference

  • MIPActions
  • GeViAct_MIPTurnARelayControl
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl Class Reference
Actions

Action 'MIP turn a relay control'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPTurnARelayControl (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP turn a relay control'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPTurnARelayControl^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Turn on if true, turn off otherwise.

Detailed Description

Action 'MIP turn a relay control'.

Constructor & Destructor Documentation

GeViAct_MIPTurnARelayControl::GeViAct_MIPTurnARelayControl | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP turn a relay control'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Turn on if true, turn off otherwise.

Member Function Documentation

GeViAct_MIPTurnARelayControl GeViAct_MIPTurnARelayControl::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPTurnARelayControl::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl::aStatus

Turn on if true, turn off otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPTurnARelayControlEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPTurnARelayControlEventArgs (GeViAct_MIPTurnARelayControl^ initAction)
Create the EventArgs for handler of action 'MIP turn a relay control'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Turn on if true, turn off otherwise.

Private Member Functions

GeViAct_MIPTurnARelayControlEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP turn a relay control'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs::GeViAct_MIPTurnARelayControlEventArgs ( ) [private]
GeViAct_MIPTurnARelayControlEventArgs::GeViAct_MIPTurnARelayControlEventArgs ( GeViAct_MIPTurnARelayControl^ initAction )

Create the EventArgs for handler of action 'MIP turn a relay control'.

Parameters:
initAction Managed action 'MIP turn a relay control'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs::aStatus

Turn on if true, turn off otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone Class Reference

  • MIPActions
  • GeViAct_MIPTurnRelaysOnOneZone
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone Class Reference
Actions

Action 'MIP turn relay on one zone'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone:
[legend]

List of all members.

Public Member Functions

GeViAct_MIPTurnRelaysOnOneZone (Int32 initInterfaceID, Int32 initUnit, Boolean initStatus)
Create the action 'MIP turn relay on one zone'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MIPTurnRelaysOnOneZone^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Turn on if true, turn off otherwise.

Detailed Description

Action 'MIP turn relay on one zone'.

Constructor & Destructor Documentation

GeViAct_MIPTurnRelaysOnOneZone::GeViAct_MIPTurnRelaysOnOneZone | ( | Int32 | initInterfaceID,
 |  | Int32 | initUnit,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'MIP turn relay on one zone'.

Parameters:
initInterfaceID | Interface ID of the corresponding GeMIP.
initUnit | Unit no.
initStatus | Turn on if true, turn off otherwise.

Member Function Documentation

GeViAct_MIPTurnRelaysOnOneZone GeViAct_MIPTurnRelaysOnOneZone::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MIPTurnRelaysOnOneZone::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone::aStatus

Turn on if true, turn off otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MIPTurnRelaysOnOneZoneEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MIPTurnRelaysOnOneZoneEventArgs (GeViAct_MIPTurnRelaysOnOneZone^ initAction)
Create the EventArgs for handler of action 'MIP turn relay on one zone'.

Properties

Int32 | aInterfaceID
Interface ID of the corresponding GeMIP.
Int32 | aUnit
Unit no.
Boolean | aStatus
Turn on if true, turn off otherwise.

Private Member Functions

GeViAct_MIPTurnRelaysOnOneZoneEventArgs ()

Detailed Description

EventArgs for handler of action 'MIP turn relay on one zone'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs::GeViAct_MIPTurnRelaysOnOneZoneEventArgs ( ) [private]
GeViAct_MIPTurnRelaysOnOneZoneEventArgs::GeViAct_MIPTurnRelaysOnOneZoneEventArgs ( GeViAct_MIPTurnRelaysOnOneZone^ initAction )

Create the EventArgs for handler of action 'MIP turn relay on one zone'.

Parameters:
initAction Managed action 'MIP turn relay on one zone'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs::aInterfaceID

Interface ID of the corresponding GeMIP.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs::aStatus

Turn on if true, turn off otherwise.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs::aUnit

Unit no.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable Class Reference

  • AlarmControlActions
  • GeViAct_MonitorGroupDisable
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable Class Reference
Actions

Action 'Disable monitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable:
[legend]

List of all members.

Public Member Functions

GeViAct_MonitorGroupDisable (GeViMGID initMonitorGroup)
Create the action 'Disable monitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MonitorGroupDisable^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aMonitorGroup
Which monitor group (ID)

Detailed Description

Action 'Disable monitor group'.

Constructor & Destructor Documentation

GeViAct_MonitorGroupDisable::GeViAct_MonitorGroupDisable ( GeViMGID initMonitorGroup )

Create the action 'Disable monitor group'.

Parameters:
initMonitorGroup Which monitor group (ID)

Member Function Documentation

GeViAct_MonitorGroupDisable GeViAct_MonitorGroupDisable::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MonitorGroupDisable::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable::aMonitorGroup

Which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MonitorGroupDisableEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MonitorGroupDisableEventArgs (GeViAct_MonitorGroupDisable^ initAction)
Create the EventArgs for handler of action 'Disable monitor group'.

Properties

GeViMGID aMonitorGroup
Which monitor group (ID)

Private Member Functions

GeViAct_MonitorGroupDisableEventArgs ()

Detailed Description

EventArgs for handler of action 'Disable monitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs::GeViAct_MonitorGroupDisableEventArgs ( ) [private]
GeViAct_MonitorGroupDisableEventArgs::GeViAct_MonitorGroupDisableEventArgs ( GeViAct_MonitorGroupDisable^ initAction )

Create the EventArgs for handler of action 'Disable monitor group'.

Parameters:
initAction Managed action 'Disable monitor group'.

Property Documentation

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs::aMonitorGroup

Which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable Class Reference

  • AlarmControlActions
  • GeViAct_MonitorGroupEnable
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable Class Reference
Actions

Action 'Enable monitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable:
[legend]

List of all members.

Public Member Functions

GeViAct_MonitorGroupEnable (GeViMGID initMonitorGroup)
Create the action 'Enable monitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MonitorGroupEnable^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aMonitorGroup
Which monitor group (ID)

Detailed Description

Action 'Enable monitor group'.

Constructor & Destructor Documentation

GeViAct_MonitorGroupEnable::GeViAct_MonitorGroupEnable ( GeViMGID initMonitorGroup )

Create the action 'Enable monitor group'.

Parameters:
initMonitorGroup Which monitor group (ID)

Member Function Documentation

GeViAct_MonitorGroupEnable GeViAct_MonitorGroupEnable::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MonitorGroupEnable::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable::aMonitorGroup

Which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MonitorGroupEnableEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MonitorGroupEnableEventArgs (GeViAct_MonitorGroupEnable^ initAction)
Create the EventArgs for handler of action 'Enable monitor group'.

Properties

GeViMGID aMonitorGroup
Which monitor group (ID)

Private Member Functions

GeViAct_MonitorGroupEnableEventArgs ()

Detailed Description

EventArgs for handler of action 'Enable monitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs::GeViAct_MonitorGroupEnableEventArgs ( ) [private]
GeViAct_MonitorGroupEnableEventArgs::GeViAct_MonitorGroupEnableEventArgs ( GeViAct_MonitorGroupEnable^ initAction )

Create the EventArgs for handler of action 'Enable monitor group'.

Parameters:
initAction Managed action 'Enable monitor group'.

Property Documentation

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs::aMonitorGroup

Which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged Class Reference

  • AlarmControlActions
  • GeViAct_MonitorGroupStatusChanged
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged Class Reference
Actions

Action 'State of a monitor group has changed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged:
[legend]

List of all members.

Public Member Functions

GeViAct_MonitorGroupStatusChanged (GeViMGID initMonitorGroup, Boolean initEnabled)
Create the action 'State of a monitor group has changed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MonitorGroupStatusChanged^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aMonitorGroup
Which monitor group (ID)
Boolean | aEnabled
true/false = New state is activ/not avtiv

Detailed Description

Action 'State of a monitor group has changed'.

Constructor & Destructor Documentation

GeViAct_MonitorGroupStatusChanged::GeViAct_MonitorGroupStatusChanged | ( | GeViMGID | initMonitorGroup,
 |  | Boolean | initEnabled
 | ) |  |

Create the action 'State of a monitor group has changed'.

Parameters:
initMonitorGroup | Which monitor group (ID)
initEnabled | true/false = New state is activ/not avtiv

Member Function Documentation

GeViAct_MonitorGroupStatusChanged GeViAct_MonitorGroupStatusChanged::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MonitorGroupStatusChanged::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged::aEnabled

true/false = New state is activ/not avtiv

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged::aMonitorGroup

Which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MonitorGroupStatusChangedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MonitorGroupStatusChangedEventArgs (GeViAct_MonitorGroupStatusChanged^ initAction)
Create the EventArgs for handler of action 'State of a monitor group has changed'.

Properties

GeViMGID | aMonitorGroup
Which monitor group (ID)
Boolean | aEnabled
true/false = New state is activ/not avtiv

Private Member Functions

GeViAct_MonitorGroupStatusChangedEventArgs ()

Detailed Description

EventArgs for handler of action 'State of a monitor group has changed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs::GeViAct_MonitorGroupStatusChangedEventArgs ( ) [private]
GeViAct_MonitorGroupStatusChangedEventArgs::GeViAct_MonitorGroupStatusChangedEventArgs ( GeViAct_MonitorGroupStatusChanged^ initAction )

Create the EventArgs for handler of action 'State of a monitor group has changed'.

Parameters:
initAction Managed action 'State of a monitor group has changed'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs::aEnabled

true/false = New state is activ/not avtiv

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs::aMonitorGroup

Which monitor group (ID)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm Class Reference

  • AlarmControlActions
  • GeViAct_MoveActualAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm Class Reference
Actions

Action 'Move alarm to an other monitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_MoveActualAlarm (GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText)
Create the action 'Move alarm to an other monitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MoveActualAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aFrom
From which monitor group (ID)
GeViMGID | aTo
To which monitor group (ID)
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Automatic adaption of the instance ID of the alarm.
String^ | aAlarmText
Description.

Detailed Description

Action 'Move alarm to an other monitor group'.

Constructor & Destructor Documentation

GeViAct_MoveActualAlarm::GeViAct_MoveActualAlarm | ( | GeViMGID | initFrom,
 |  | GeViMGID | initTo,
 |  | GeViClientID | initUserID,
 |  | GeViAlarmID | initAlarmID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Move alarm to an other monitor group'.

Parameters:
initFrom | From which monitor group (ID)
initTo | To which monitor group (ID)
initUserID | Automatic adaption of the user, which has caused the move
initAlarmID | Automatic adaption of the instance ID of the alarm
initAlarmText | Description

Member Function Documentation

GeViAct_MoveActualAlarm GeViAct_MoveActualAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MoveActualAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm::aAlarmID

Automatic adaption of the instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm::aFrom

From which monitor group (ID)

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm::aTo

To which monitor group (ID)

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MoveActualAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MoveActualAlarmEventArgs (GeViAct_MoveActualAlarm^ initAction)
Create the EventArgs for handler of action 'Move alarm to an other monitor group'.

Properties

GeViMGID | aFrom
From which monitor group (ID)
GeViMGID | aTo
To which monitor group (ID)
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Automatic adaption of the instance ID of the alarm.
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_MoveActualAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Move alarm to an other monitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs::GeViAct_MoveActualAlarmEventArgs ( ) [private]
GeViAct_MoveActualAlarmEventArgs::GeViAct_MoveActualAlarmEventArgs ( GeViAct_MoveActualAlarm^ initAction )

Create the EventArgs for handler of action 'Move alarm to an other monitor group'.

Parameters:
initAction Managed action 'Move alarm to an other monitor group'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs::aAlarmID

Automatic adaption of the instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs::aFrom

From which monitor group (ID)

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs::aTo

To which monitor group (ID)

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance Class Reference

  • AlarmControlActions
  • GeViAct_MoveAlarmByInstance
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance Class Reference
Actions

Action 'Move the alarm to an other monitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance:
[legend]

List of all members.

Public Member Functions

GeViAct_MoveAlarmByInstance (GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText)
Create the action 'Move the alarm to an other monitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MoveAlarmByInstance^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aFrom
From which monitor group.
GeViMGID | aTo
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description.

Detailed Description

Action 'Move the alarm to an other monitor group'.

Constructor & Destructor Documentation

GeViAct_MoveAlarmByInstance::GeViAct_MoveAlarmByInstance | ( | GeViMGID | initFrom,
 |  | GeViMGID | initTo,
 |  | GeViClientID | initUserID,
 |  | GeViAlarmID | initAlarmID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Move the alarm to an other monitor group'.

Parameters:
initFrom | From which monitor group
initTo | To which monitor group
initUserID | Automatic adaption of the user, which has caused the move
initAlarmID | Instance ID of the alarm
initAlarmText | Description

Member Function Documentation

GeViAct_MoveAlarmByInstance GeViAct_MoveAlarmByInstance::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MoveAlarmByInstance::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance::aFrom

From which monitor group.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance::aTo

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MoveAlarmByInstanceEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MoveAlarmByInstanceEventArgs (GeViAct_MoveAlarmByInstance^ initAction)
Create the EventArgs for handler of action 'Move the alarm to an other monitor group'.

Properties

GeViMGID | aFrom
From which monitor group.
GeViMGID | aTo
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_MoveAlarmByInstanceEventArgs ()

Detailed Description

EventArgs for handler of action 'Move the alarm to an other monitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs::GeViAct_MoveAlarmByInstanceEventArgs ( ) [private]
GeViAct_MoveAlarmByInstanceEventArgs::GeViAct_MoveAlarmByInstanceEventArgs ( GeViAct_MoveAlarmByInstance^ initAction )

Create the EventArgs for handler of action 'Move the alarm to an other monitor group'.

Parameters:
initAction Managed action 'Move the alarm to an other monitor group'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs::aAlarmText

Description.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs::aFrom

From which monitor group.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs::aTo

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted Class Reference

  • MscIIActions
  • GeViAct_MscEventStarted
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted Class Reference
Actions

Action 'Start of the event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted:
[legend]

List of all members.

Public Member Functions

GeViAct_MscEventStarted (Int32 initMscServerID, String^ initMscServerName, GeViGUID initMscDBGUID, GeViMscEventID initMscEventID, GeViMscEventTypeID initMscEventTypeID, Int32 initMscEventRef, String^ initMscEventName, Int32 initMscMessageKind)
Create the action 'Start of the event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MscEventStarted^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
GeViMscEventID | aMscEventID
Instance ID of the MULTISCOPE event.
GeViMscEventTypeID | aMscEventTypeID
Type ID of the MULTISCOPE event type.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type.
String^ | aMscEventName
Name of the event.
Int32 | aMscMessageKind
Message kind (this time only 0 = normal)

Detailed Description

Action 'Start of the event'.

Constructor & Destructor Documentation

GeViAct_MscEventStarted::GeViAct_MscEventStarted | ( | Int32 | initMscServerID,
 |  | String^ | initMscServerName,
 |  | GeViGUID | initMscDBGUID,
 |  | GeViMscEventID | initMscEventID,
 |  | GeViMscEventTypeID | initMscEventTypeID,
 |  | Int32 | initMscEventRef,
 |  | String^ | initMscEventName,
 |  | Int32 | initMscMessageKind
 | ) |  |

Create the action 'Start of the event'.

Parameters:
initMscServerID | GeVi-internal ID of the MULTISCOPE server.
initMscServerName | Name (host name) of the MULTISCOPE server
initMscDBGUID | GUID of the MULTISCOPE data base
initMscEventID | Instance ID of the MULTISCOPE event
initMscEventTypeID | Type ID of the MULTISCOPE event type
initMscEventRef | GeVi-internal ID (Reference) of the MULTISCOPE event type
initMscEventName | Name of the event
initMscMessageKind | Message kind (this time only 0 = normal)

Member Function Documentation

GeViAct_MscEventStarted GeViAct_MscEventStarted::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MscEventStarted::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscDBGUID

GUID of the MULTISCOPE data base.

GeViMscEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscEventID

Instance ID of the MULTISCOPE event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscEventName

Name of the event.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type.

GeViMscEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscEventTypeID

Type ID of the MULTISCOPE event type.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscMessageKind

Message kind (this time only 0 = normal)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MscEventStartedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MscEventStartedEventArgs (GeViAct_MscEventStarted^ initAction)
Create the EventArgs for handler of action 'Start of the event'.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
GeViMscEventID | aMscEventID
Instance ID of the MULTISCOPE event.
GeViMscEventTypeID | aMscEventTypeID
Type ID of the MULTISCOPE event type.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type.
String^ | aMscEventName
Name of the event.
Int32 | aMscMessageKind
Message kind (this time only 0 = normal)

Private Member Functions

GeViAct_MscEventStartedEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of the event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::GeViAct_MscEventStartedEventArgs ( ) [private]
GeViAct_MscEventStartedEventArgs::GeViAct_MscEventStartedEventArgs ( GeViAct_MscEventStarted^ initAction )

Create the EventArgs for handler of action 'Start of the event'.

Parameters:
initAction Managed action 'Start of the event'.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscDBGUID

GUID of the MULTISCOPE data base.

GeViMscEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscEventID

Instance ID of the MULTISCOPE event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscEventName

Name of the event.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type.

GeViMscEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscEventTypeID

Type ID of the MULTISCOPE event type.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscMessageKind

Message kind (this time only 0 = normal)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped Class Reference

  • MscIIActions
  • GeViAct_MscEventStopped
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped Class Reference
Actions

Action 'Stopp of an event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped:
[legend]

List of all members.

Public Member Functions

GeViAct_MscEventStopped (Int32 initMscServerID, String^ initMscServerName, GeViGUID initMscDBGUID, GeViMscEventID initMscEventID, GeViMscEventTypeID initMscEventTypeID, Int32 initMscEventRef, String^ initMscEventName, Int32 initMscMessageKind)
Create the action 'Stopp of an event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MscEventStopped^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
GeViMscEventID | aMscEventID
Instance ID of the MULTISCOPE event.
GeViMscEventTypeID | aMscEventTypeID
MULTISCOPE type ID of the MULTISCOPE event type.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type.
String^ | aMscEventName
Name of the event.
Int32 | aMscMessageKind
Message kind (this time only 0 = normal)

Detailed Description

Action 'Stopp of an event'.

Constructor & Destructor Documentation

GeViAct_MscEventStopped::GeViAct_MscEventStopped | ( | Int32 | initMscServerID,
 |  | String^ | initMscServerName,
 |  | GeViGUID | initMscDBGUID,
 |  | GeViMscEventID | initMscEventID,
 |  | GeViMscEventTypeID | initMscEventTypeID,
 |  | Int32 | initMscEventRef,
 |  | String^ | initMscEventName,
 |  | Int32 | initMscMessageKind
 | ) |  |

Create the action 'Stopp of an event'.

Parameters:
initMscServerID | GeVi-internal ID of the MULTISCOPE server.
initMscServerName | Name (host name) of the MULTISCOPE server
initMscDBGUID | GUID of the MULTISCOPE data base
initMscEventID | Instance ID of the MULTISCOPE event
initMscEventTypeID | MULTISCOPE type ID of the MULTISCOPE event type
initMscEventRef | GeVi-internal ID (Reference) of the MULTISCOPE event type
initMscEventName | Name of the event
initMscMessageKind | Message kind (this time only 0 = normal)

Member Function Documentation

GeViAct_MscEventStopped GeViAct_MscEventStopped::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MscEventStopped::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscDBGUID

GUID of the MULTISCOPE data base.

GeViMscEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscEventID

Instance ID of the MULTISCOPE event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscEventName

Name of the event.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type.

GeViMscEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscEventTypeID

MULTISCOPE type ID of the MULTISCOPE event type.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscMessageKind

Message kind (this time only 0 = normal)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MscEventStoppedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MscEventStoppedEventArgs (GeViAct_MscEventStopped^ initAction)
Create the EventArgs for handler of action 'Stopp of an event'.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
GeViMscEventID | aMscEventID
Instance ID of the MULTISCOPE event.
GeViMscEventTypeID | aMscEventTypeID
MULTISCOPE type ID of the MULTISCOPE event type.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type.
String^ | aMscEventName
Name of the event.
Int32 | aMscMessageKind
Message kind (this time only 0 = normal)

Private Member Functions

GeViAct_MscEventStoppedEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp of an event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::GeViAct_MscEventStoppedEventArgs ( ) [private]
GeViAct_MscEventStoppedEventArgs::GeViAct_MscEventStoppedEventArgs ( GeViAct_MscEventStopped^ initAction )

Create the EventArgs for handler of action 'Stopp of an event'.

Parameters:
initAction Managed action 'Stopp of an event'.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscDBGUID

GUID of the MULTISCOPE data base.

GeViMscEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscEventID

Instance ID of the MULTISCOPE event.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscEventName

Name of the event.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type.

GeViMscEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscEventTypeID

MULTISCOPE type ID of the MULTISCOPE event type.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscMessageKind

Message kind (this time only 0 = normal)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected Class Reference

  • MscIIActions
  • GeViAct_MscServerConnected
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected Class Reference
Actions

Action 'MULTISCOPE connected'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected:
[legend]

List of all members.

Public Member Functions

GeViAct_MscServerConnected (Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName)
Create the action 'MULTISCOPE connected'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MscServerConnected^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Detailed Description

Action 'MULTISCOPE connected'.

Constructor & Destructor Documentation

GeViAct_MscServerConnected::GeViAct_MscServerConnected | ( | Int32 | initMscServerID,
 |  | GeViGUID | initMscDBGUID,
 |  | String^ | initMscServerName
 | ) |  |

Create the action 'MULTISCOPE connected'.

Parameters:
initMscServerID | GeVi-internal ID of MULTISCOPE server
initMscDBGUID | GUID of the MULTISCOPE data base
initMscServerName | Name (host name) of the MULTISCOPE server

Member Function Documentation

GeViAct_MscServerConnected GeViAct_MscServerConnected::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MscServerConnected::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected::aMscServerID

GeVi-internal ID of MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MscServerConnectedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MscServerConnectedEventArgs (GeViAct_MscServerConnected^ initAction)
Create the EventArgs for handler of action 'MULTISCOPE connected'.

Properties

Int32 | aMscServerID
GeVi-internal ID of MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Private Member Functions

GeViAct_MscServerConnectedEventArgs ()

Detailed Description

EventArgs for handler of action 'MULTISCOPE connected'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs::GeViAct_MscServerConnectedEventArgs ( ) [private]
GeViAct_MscServerConnectedEventArgs::GeViAct_MscServerConnectedEventArgs ( GeViAct_MscServerConnected^ initAction )

Create the EventArgs for handler of action 'MULTISCOPE connected'.

Parameters:
initAction Managed action 'MULTISCOPE connected'.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs::aMscServerID

GeVi-internal ID of MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed Class Reference

  • MscIIActions
  • GeViAct_MscServerConnectFailed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed Class Reference
Actions

Action 'Open MULTISCOPE connection failed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed:
[legend]

List of all members.

Public Member Functions

GeViAct_MscServerConnectFailed (Int32 initMscServerID, String^ initMscServerName)
Create the action 'Open MULTISCOPE connection failed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MscServerConnectFailed^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Detailed Description

Action 'Open MULTISCOPE connection failed'.

Constructor & Destructor Documentation

GeViAct_MscServerConnectFailed::GeViAct_MscServerConnectFailed | ( | Int32 | initMscServerID,
 |  | String^ | initMscServerName
 | ) |  |

Create the action 'Open MULTISCOPE connection failed'.

Parameters:
initMscServerID | GeVi-internal ID of the MULTISCOPE server
initMscServerName | Name (host name) of the MULTISCOPE server

Member Function Documentation

GeViAct_MscServerConnectFailed GeViAct_MscServerConnectFailed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MscServerConnectFailed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MscServerConnectFailedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MscServerConnectFailedEventArgs (GeViAct_MscServerConnectFailed^ initAction)
Create the EventArgs for handler of action 'Open MULTISCOPE connection failed'.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Private Member Functions

GeViAct_MscServerConnectFailedEventArgs ()

Detailed Description

EventArgs for handler of action 'Open MULTISCOPE connection failed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs::GeViAct_MscServerConnectFailedEventArgs ( ) [private]
GeViAct_MscServerConnectFailedEventArgs::GeViAct_MscServerConnectFailedEventArgs ( GeViAct_MscServerConnectFailed^ initAction )

Create the EventArgs for handler of action 'Open MULTISCOPE connection failed'.

Parameters:
initAction Managed action 'Open MULTISCOPE connection failed'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect Class Reference

  • MscIIActions
  • GeViAct_MscServerDisconnect
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect Class Reference
Actions

Action 'Close MULTISCOPE connection'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect:
[legend]

List of all members.

Public Member Functions

GeViAct_MscServerDisconnect (Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName)
Create the action 'Close MULTISCOPE connection'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MscServerDisconnect^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Detailed Description

Action 'Close MULTISCOPE connection'.

Constructor & Destructor Documentation

GeViAct_MscServerDisconnect::GeViAct_MscServerDisconnect | ( | Int32 | initMscServerID,
 |  | GeViGUID | initMscDBGUID,
 |  | String^ | initMscServerName
 | ) |  |

Create the action 'Close MULTISCOPE connection'.

Parameters:
initMscServerID | GeVi-internal ID of the MULTISCOPE server.
initMscDBGUID | GUID of the MULTISCOPE data base
initMscServerName | Name (host name) of the MULTISCOPE server

Member Function Documentation

GeViAct_MscServerDisconnect GeViAct_MscServerDisconnect::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MscServerDisconnect::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected Class Reference

  • MscIIActions
  • GeViAct_MscServerDisconnected
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected Class Reference
Actions

Action 'MULTISCOPE disconnected'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected:
[legend]

List of all members.

Public Member Functions

GeViAct_MscServerDisconnected (Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName)
Create the action 'MULTISCOPE disconnected'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_MscServerDisconnected^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Detailed Description

Action 'MULTISCOPE disconnected'.

Constructor & Destructor Documentation

GeViAct_MscServerDisconnected::GeViAct_MscServerDisconnected | ( | Int32 | initMscServerID,
 |  | GeViGUID | initMscDBGUID,
 |  | String^ | initMscServerName
 | ) |  |

Create the action 'MULTISCOPE disconnected'.

Parameters:
initMscServerID | GeVi-internal ID of the MULTISCOPE server
initMscDBGUID | GUID of the MULTISCOPE data base
initMscServerName | Name (host name) of the MULTISCOPE server

Member Function Documentation

GeViAct_MscServerDisconnected GeViAct_MscServerDisconnected::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MscServerDisconnected::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MscServerDisconnectedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MscServerDisconnectedEventArgs (GeViAct_MscServerDisconnected^ initAction)
Create the EventArgs for handler of action 'MULTISCOPE disconnected'.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Private Member Functions

GeViAct_MscServerDisconnectedEventArgs ()

Detailed Description

EventArgs for handler of action 'MULTISCOPE disconnected'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs::GeViAct_MscServerDisconnectedEventArgs ( ) [private]
GeViAct_MscServerDisconnectedEventArgs::GeViAct_MscServerDisconnectedEventArgs ( GeViAct_MscServerDisconnected^ initAction )

Create the EventArgs for handler of action 'MULTISCOPE disconnected'.

Parameters:
initAction Managed action 'MULTISCOPE disconnected'.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MscServerDisconnectEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MscServerDisconnectEventArgs (GeViAct_MscServerDisconnect^ initAction)
Create the EventArgs for handler of action 'Close MULTISCOPE connection'.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Private Member Functions

GeViAct_MscServerDisconnectEventArgs ()

Detailed Description

EventArgs for handler of action 'Close MULTISCOPE connection'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs::GeViAct_MscServerDisconnectEventArgs ( ) [private]
GeViAct_MscServerDisconnectEventArgs::GeViAct_MscServerDisconnectEventArgs ( GeViAct_MscServerDisconnect^ initAction )

Create the EventArgs for handler of action 'Close MULTISCOPE connection'.

Parameters:
initAction Managed action 'Close MULTISCOPE connection'.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified Class Reference

  • MscIIActions
  • GeViAct_MscSetupModified
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified Class Reference
Actions

Action 'MULTISCOPE Setup changed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified:
[legend]

List of all members.

Public Member Functions

GeViAct_MscSetupModified (Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName)
Create the action 'MULTISCOPE Setup changed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_MscSetupModified^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Detailed Description

Action 'MULTISCOPE Setup changed'.

Constructor & Destructor Documentation

GeViAct_MscSetupModified::GeViAct_MscSetupModified | ( | Int32 | initMscServerID,
 |  | GeViGUID | initMscDBGUID,
 |  | String^ | initMscServerName
 | ) |  |

Create the action 'MULTISCOPE Setup changed'.

Parameters:
initMscServerID | GeVi-internal ID of the MULTISCOPE server
initMscDBGUID | GUID of the MULTISCOPE data base
initMscServerName | Name (host name) of the MULTISCOPE server

Member Function Documentation

GeViAct_MscSetupModified GeViAct_MscSetupModified::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_MscSetupModified::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_MscSetupModifiedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_MscSetupModifiedEventArgs (GeViAct_MscSetupModified^ initAction)
Create the EventArgs for handler of action 'MULTISCOPE Setup changed'.

Properties

Int32 | aMscServerID
GeVi-internal ID of the MULTISCOPE server.
GeViGUID aMscDBGUID
GUID of the MULTISCOPE data base.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server.

Private Member Functions

GeViAct_MscSetupModifiedEventArgs ()

Detailed Description

EventArgs for handler of action 'MULTISCOPE Setup changed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs::GeViAct_MscSetupModifiedEventArgs ( ) [private]
GeViAct_MscSetupModifiedEventArgs::GeViAct_MscSetupModifiedEventArgs ( GeViAct_MscSetupModified^ initAction )

Create the EventArgs for handler of action 'MULTISCOPE Setup changed'.

Parameters:
initAction Managed action 'MULTISCOPE Setup changed'.

Property Documentation

GeViGUID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs::aMscDBGUID

GUID of the MULTISCOPE data base.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs::aMscServerID

GeVi-internal ID of the MULTISCOPE server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn Class Reference

  • CameraControlActions
  • GeViAct_NormalModeOn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn Class Reference
Actions

Action 'Turn on normal mode'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn:
[legend]

List of all members.

Public Member Functions

GeViAct_NormalModeOn (GeViVideoInputID initVideoInput)
Create the action 'Turn on normal mode'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_NormalModeOn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of input, where the normal mode shall be activated.

Detailed Description

Action 'Turn on normal mode'.

Constructor & Destructor Documentation

GeViAct_NormalModeOn::GeViAct_NormalModeOn ( GeViVideoInputID initVideoInput )

Create the action 'Turn on normal mode'.

Parameters:
initVideoInput ID of input, where the normal mode shall be activated

Member Function Documentation

GeViAct_NormalModeOn GeViAct_NormalModeOn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_NormalModeOn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn::aVideoInput

ID of input, where the normal mode shall be activated.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_NormalModeOnEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_NormalModeOnEventArgs (GeViAct_NormalModeOn^ initAction)
Create the EventArgs for handler of action 'Turn on normal mode'.

Properties

GeViVideoInputID aVideoInput
ID of input, where the normal mode shall be activated.

Private Member Functions

GeViAct_NormalModeOnEventArgs ()

Detailed Description

EventArgs for handler of action 'Turn on normal mode'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs::GeViAct_NormalModeOnEventArgs ( ) [private]
GeViAct_NormalModeOnEventArgs::GeViAct_NormalModeOnEventArgs ( GeViAct_NormalModeOn^ initAction )

Create the EventArgs for handler of action 'Turn on normal mode'.

Parameters:
initAction Managed action 'Turn on normal mode'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs::aVideoInput

ID of input, where the normal mode shall be activated.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact Class Reference

  • ContactBusActions
  • GeViAct_OpenContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact Class Reference
Actions

Action 'Open contact'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact:
[legend]

List of all members.

Public Member Functions

GeViAct_OpenContact (Int32 initGlobalContactID)
Create the action 'Open contact'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_OpenContact^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aGlobalContactID
Global id of that contact.

Detailed Description

Action 'Open contact'.

Constructor & Destructor Documentation

GeViAct_OpenContact::GeViAct_OpenContact ( Int32 initGlobalContactID )

Create the action 'Open contact'.

Parameters:
initGlobalContactID Global id of that contact

Member Function Documentation

GeViAct_OpenContact GeViAct_OpenContact::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_OpenContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact::aGlobalContactID

Global id of that contact.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_OpenContactEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_OpenContactEventArgs (GeViAct_OpenContact^ initAction)
Create the EventArgs for handler of action 'Open contact'.

Properties

Int32 aGlobalContactID
Global id of that contact.

Private Member Functions

GeViAct_OpenContactEventArgs ()

Detailed Description

EventArgs for handler of action 'Open contact'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs::GeViAct_OpenContactEventArgs ( ) [private]
GeViAct_OpenContactEventArgs::GeViAct_OpenContactEventArgs ( GeViAct_OpenContact^ initAction )

Create the EventArgs for handler of action 'Open contact'.

Parameters:
initAction Managed action 'Open contact'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs::aGlobalContactID

Global id of that contact.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto Class Reference

  • CameraControlActions
  • GeViAct_PanAuto
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto Class Reference
Actions

Action 'Automatic panning of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto:
[legend]

List of all members.

Public Member Functions

GeViAct_PanAuto (GeViVideoInputID initVideoInput, Int32 initModus)
Create the action 'Automatic panning of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PanAuto^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, for which the automatic pan-mode shall be activated.
Int32 | aModus
Typ of automatic pan mode, device dependend, don't use directly.

Detailed Description

Action 'Automatic panning of the camera'.

Constructor & Destructor Documentation

GeViAct_PanAuto::GeViAct_PanAuto | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initModus
 | ) |  |

Create the action 'Automatic panning of the camera'.

Parameters:
initVideoInput | ID of the camera, for which the automatic pan-mode shall be activated.
initModus | Typ of automatic pan mode, device dependend, don't use directly

Member Function Documentation

GeViAct_PanAuto GeViAct_PanAuto::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PanAuto::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto::aModus

Typ of automatic pan mode, device dependend, don't use directly.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto::aVideoInput

ID of the camera, for which the automatic pan-mode shall be activated.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PanAutoEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PanAutoEventArgs (GeViAct_PanAuto^ initAction)
Create the EventArgs for handler of action 'Automatic panning of the camera'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, for which the automatic pan-mode shall be activated.
Int32 | aModus
Typ of automatic pan mode, device dependend, don't use directly.

Private Member Functions

GeViAct_PanAutoEventArgs ()

Detailed Description

EventArgs for handler of action 'Automatic panning of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs::GeViAct_PanAutoEventArgs ( ) [private]
GeViAct_PanAutoEventArgs::GeViAct_PanAutoEventArgs ( GeViAct_PanAuto^ initAction )

Create the EventArgs for handler of action 'Automatic panning of the camera'.

Parameters:
initAction Managed action 'Automatic panning of the camera'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs::aModus

Typ of automatic pan mode, device dependend, don't use directly.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs::aVideoInput

ID of the camera, for which the automatic pan-mode shall be activated.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft Class Reference

  • CameraControlActions
  • GeViAct_PanLeft
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft Class Reference
Actions

Action 'Pan camera to the left'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft:
[legend]

List of all members.

Public Member Functions

GeViAct_PanLeft (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Pan camera to the left'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PanLeft^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall panned to the left.
Int32 | aTemp
Speed of panning (0 = standard)

Detailed Description

Action 'Pan camera to the left'.

Constructor & Destructor Documentation

GeViAct_PanLeft::GeViAct_PanLeft | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Pan camera to the left'.

Parameters:
initVideoInput | ID of the camera, which shall panned to the left
initTemp | Speed of panning (0 = standard)

Member Function Documentation

GeViAct_PanLeft GeViAct_PanLeft::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PanLeft::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft::aTemp

Speed of panning (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft::aVideoInput

ID of the camera, which shall panned to the left.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PanLeftEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PanLeftEventArgs (GeViAct_PanLeft^ initAction)
Create the EventArgs for handler of action 'Pan camera to the left'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall panned to the left.
Int32 | aTemp
Speed of panning (0 = standard)

Private Member Functions

GeViAct_PanLeftEventArgs ()

Detailed Description

EventArgs for handler of action 'Pan camera to the left'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs::GeViAct_PanLeftEventArgs ( ) [private]
GeViAct_PanLeftEventArgs::GeViAct_PanLeftEventArgs ( GeViAct_PanLeft^ initAction )

Create the EventArgs for handler of action 'Pan camera to the left'.

Parameters:
initAction Managed action 'Pan camera to the left'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs::aTemp

Speed of panning (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs::aVideoInput

ID of the camera, which shall panned to the left.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight Class Reference

  • CameraControlActions
  • GeViAct_PanRight
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight Class Reference
Actions

Action 'Pan camera to the right'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight:
[legend]

List of all members.

Public Member Functions

GeViAct_PanRight (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Pan camera to the right'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PanRight^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of Camera, which shall panned to the right.
Int32 | aTemp
Speed of panning (0 = standard)

Detailed Description

Action 'Pan camera to the right'.

Constructor & Destructor Documentation

GeViAct_PanRight::GeViAct_PanRight | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Pan camera to the right'.

Parameters:
initVideoInput | ID of Camera, which shall panned to the right
initTemp | Speed of panning (0 = standard)

Member Function Documentation

GeViAct_PanRight GeViAct_PanRight::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PanRight::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight::aTemp

Speed of panning (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight::aVideoInput

ID of Camera, which shall panned to the right.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PanRightEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PanRightEventArgs (GeViAct_PanRight^ initAction)
Create the EventArgs for handler of action 'Pan camera to the right'.

Properties

GeViVideoInputID | aVideoInput
ID of Camera, which shall panned to the right.
Int32 | aTemp
Speed of panning (0 = standard)

Private Member Functions

GeViAct_PanRightEventArgs ()

Detailed Description

EventArgs for handler of action 'Pan camera to the right'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs::GeViAct_PanRightEventArgs ( ) [private]
GeViAct_PanRightEventArgs::GeViAct_PanRightEventArgs ( GeViAct_PanRight^ initAction )

Create the EventArgs for handler of action 'Pan camera to the right'.

Parameters:
initAction Managed action 'Pan camera to the right'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs::aTemp

Speed of panning (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs::aVideoInput

ID of Camera, which shall panned to the right.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop Class Reference

  • CameraControlActions
  • GeViAct_PanStop
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop Class Reference
Actions

Action 'Stopp panning of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop:
[legend]

List of all members.

Public Member Functions

GeViAct_PanStop (GeViVideoInputID initVideoInput)
Create the action 'Stopp panning of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PanStop^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which panning shall be stopped.

Detailed Description

Action 'Stopp panning of the camera'.

Constructor & Destructor Documentation

GeViAct_PanStop::GeViAct_PanStop ( GeViVideoInputID initVideoInput )

Create the action 'Stopp panning of the camera'.

Parameters:
initVideoInput ID of the camera, which panning shall be stopped.

Member Function Documentation

GeViAct_PanStop GeViAct_PanStop::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PanStop::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop::aVideoInput

ID of the camera, which panning shall be stopped.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PanStopEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PanStopEventArgs (GeViAct_PanStop^ initAction)
Create the EventArgs for handler of action 'Stopp panning of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which panning shall be stopped.

Private Member Functions

GeViAct_PanStopEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp panning of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs::GeViAct_PanStopEventArgs ( ) [private]
GeViAct_PanStopEventArgs::GeViAct_PanStopEventArgs ( GeViAct_PanStop^ initAction )

Create the EventArgs for handler of action 'Stopp panning of the camera'.

Parameters:
initAction Managed action 'Stopp panning of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs::aVideoInput

ID of the camera, which panning shall be stopped.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm Class Reference

  • AlarmControlActions
  • GeViAct_PopUpAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm Class Reference
Actions

Action 'Display alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_PopUpAlarm (GeViMGID initMonitorGroup, GeViClientID initUserID, GeViAlarmID initAlarmID)
Create the action 'Display alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PopUpAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aMonitorGroup
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Instance ID of the alarm.

Detailed Description

Action 'Display alarm'.

Constructor & Destructor Documentation

GeViAct_PopUpAlarm::GeViAct_PopUpAlarm | ( | GeViMGID | initMonitorGroup,
 |  | GeViClientID | initUserID,
 |  | GeViAlarmID | initAlarmID
 | ) |  |

Create the action 'Display alarm'.

Parameters:
initMonitorGroup | To which monitor group
initUserID | Automatic adaption of the user, which has caused the move
initAlarmID | Instance ID of the alarm

Member Function Documentation

GeViAct_PopUpAlarm GeViAct_PopUpAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PopUpAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm::aAlarmID

Instance ID of the alarm.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm::aMonitorGroup

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PopUpAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PopUpAlarmEventArgs (GeViAct_PopUpAlarm^ initAction)
Create the EventArgs for handler of action 'Display alarm'.

Properties

GeViMGID | aMonitorGroup
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user, which has caused the move.
GeViAlarmID | aAlarmID
Instance ID of the alarm.

Private Member Functions

GeViAct_PopUpAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Display alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs::GeViAct_PopUpAlarmEventArgs ( ) [private]
GeViAct_PopUpAlarmEventArgs::GeViAct_PopUpAlarmEventArgs ( GeViAct_PopUpAlarm^ initAction )

Create the EventArgs for handler of action 'Display alarm'.

Parameters:
initAction Managed action 'Display alarm'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs::aAlarmID

Instance ID of the alarm.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs::aMonitorGroup

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs::aUserID

Automatic adaption of the user, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm Class Reference

  • AlarmControlActions
  • GeViAct_PopUpNextAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm Class Reference
Actions

Action 'Send the actual alarm back in the queue and send the next to the monitors'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_PopUpNextAlarm (GeViMGID initMonitorGroup, GeViClientID initUserID)
Create the action 'Send the actual alarm back in the queue and send the next to the monitors'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PopUpNextAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViMGID | aMonitorGroup
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user ID, which has caused the move.

Detailed Description

Action 'Send the actual alarm back in the queue and send the next to the monitors'.

Constructor & Destructor Documentation

GeViAct_PopUpNextAlarm::GeViAct_PopUpNextAlarm | ( | GeViMGID | initMonitorGroup,
 |  | GeViClientID | initUserID
 | ) |  |

Create the action 'Send the actual alarm back in the queue and send the next to the monitors'.

Parameters:
initMonitorGroup | To which monitor group
initUserID | Automatic adaption of the user ID, which has caused the move

Member Function Documentation

GeViAct_PopUpNextAlarm GeViAct_PopUpNextAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PopUpNextAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm::aMonitorGroup

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm::aUserID

Automatic adaption of the user ID, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PopUpNextAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PopUpNextAlarmEventArgs (GeViAct_PopUpNextAlarm^ initAction)
Create the EventArgs for handler of action 'Send the actual alarm back in the queue and send the next to the monitors'.

Properties

GeViMGID | aMonitorGroup
To which monitor group.
GeViClientID | aUserID
Automatic adaption of the user ID, which has caused the move.

Private Member Functions

GeViAct_PopUpNextAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Send the actual alarm back in the queue and send the next to the monitors'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs::GeViAct_PopUpNextAlarmEventArgs ( ) [private]
GeViAct_PopUpNextAlarmEventArgs::GeViAct_PopUpNextAlarmEventArgs ( GeViAct_PopUpNextAlarm^ initAction )

Create the EventArgs for handler of action 'Send the actual alarm back in the queue and send the next to the monitors'.

Parameters:
initAction Managed action 'Send the actual alarm back in the queue and send the next to the monitors'.

Property Documentation

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs::aMonitorGroup

To which monitor group.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs::aUserID

Automatic adaption of the user ID, which has caused the move.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp Class Reference

  • CameraControlActions
  • GeViAct_PrePosCallUp
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp Class Reference
Actions

Action 'Move camera to a fix position'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp:
[legend]

List of all members.

Public Member Functions

GeViAct_PrePosCallUp (GeViVideoInputID initVideoInput, Int32 initPosition)
Create the action 'Move camera to a fix position'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PrePosCallUp^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall move to a fix position.
Int32 | aPosition
ID of the fix position.

Detailed Description

Action 'Move camera to a fix position'.

Constructor & Destructor Documentation

GeViAct_PrePosCallUp::GeViAct_PrePosCallUp | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initPosition
 | ) |  |

Create the action 'Move camera to a fix position'.

Parameters:
initVideoInput | ID of the camera, which shall move to a fix position
initPosition | ID of the fix position

Member Function Documentation

GeViAct_PrePosCallUp GeViAct_PrePosCallUp::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PrePosCallUp::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp::aPosition

ID of the fix position.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp::aVideoInput

ID of the camera, which shall move to a fix position.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PrePosCallUpEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PrePosCallUpEventArgs (GeViAct_PrePosCallUp^ initAction)
Create the EventArgs for handler of action 'Move camera to a fix position'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall move to a fix position.
Int32 | aPosition
ID of the fix position.

Private Member Functions

GeViAct_PrePosCallUpEventArgs ()

Detailed Description

EventArgs for handler of action 'Move camera to a fix position'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs::GeViAct_PrePosCallUpEventArgs ( ) [private]
GeViAct_PrePosCallUpEventArgs::GeViAct_PrePosCallUpEventArgs ( GeViAct_PrePosCallUp^ initAction )

Create the EventArgs for handler of action 'Move camera to a fix position'.

Parameters:
initAction Managed action 'Move camera to a fix position'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs::aPosition

ID of the fix position.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs::aVideoInput

ID of the camera, which shall move to a fix position.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear Class Reference

  • CameraControlActions
  • GeViAct_PrePosClear
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear Class Reference
Actions

Action 'Clear fix position of a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear:
[legend]

List of all members.

Public Member Functions

GeViAct_PrePosClear (GeViVideoInputID initVideoInput, Int32 initPosition)
Create the action 'Clear fix position of a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PrePosClear^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which position shall be deleted.
Int32 | aPosition
ID of the fix position.

Detailed Description

Action 'Clear fix position of a camera'.

Constructor & Destructor Documentation

GeViAct_PrePosClear::GeViAct_PrePosClear | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initPosition
 | ) |  |

Create the action 'Clear fix position of a camera'.

Parameters:
initVideoInput | ID of the camera, which position shall be deleted
initPosition | ID of the fix position

Member Function Documentation

GeViAct_PrePosClear GeViAct_PrePosClear::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PrePosClear::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear::aPosition

ID of the fix position.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear::aVideoInput

ID of the camera, which position shall be deleted.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PrePosClearEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PrePosClearEventArgs (GeViAct_PrePosClear^ initAction)
Create the EventArgs for handler of action 'Clear fix position of a camera'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which position shall be deleted.
Int32 | aPosition
ID of the fix position.

Private Member Functions

GeViAct_PrePosClearEventArgs ()

Detailed Description

EventArgs for handler of action 'Clear fix position of a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs::GeViAct_PrePosClearEventArgs ( ) [private]
GeViAct_PrePosClearEventArgs::GeViAct_PrePosClearEventArgs ( GeViAct_PrePosClear^ initAction )

Create the EventArgs for handler of action 'Clear fix position of a camera'.

Parameters:
initAction Managed action 'Clear fix position of a camera'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs::aPosition

ID of the fix position.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs::aVideoInput

ID of the camera, which position shall be deleted.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave Class Reference

  • CameraControlActions
  • GeViAct_PrePosSave
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave Class Reference
Actions

Action 'Save a fix position of a camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave:
[legend]

List of all members.

Public Member Functions

GeViAct_PrePosSave (GeViVideoInputID initVideoInput, Int32 initPosition)
Create the action 'Save a fix position of a camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_PrePosSave^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which position shall be saved.
Int32 | aPosition
ID of the fix position.

Detailed Description

Action 'Save a fix position of a camera'.

Constructor & Destructor Documentation

GeViAct_PrePosSave::GeViAct_PrePosSave | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initPosition
 | ) |  |

Create the action 'Save a fix position of a camera'.

Parameters:
initVideoInput | ID of the camera, which position shall be saved
initPosition | ID of the fix position

Member Function Documentation

GeViAct_PrePosSave GeViAct_PrePosSave::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_PrePosSave::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave::aPosition

ID of the fix position.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave::aVideoInput

ID of the camera, which position shall be saved.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_PrePosSaveEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_PrePosSaveEventArgs (GeViAct_PrePosSave^ initAction)
Create the EventArgs for handler of action 'Save a fix position of a camera'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which position shall be saved.
Int32 | aPosition
ID of the fix position.

Private Member Functions

GeViAct_PrePosSaveEventArgs ()

Detailed Description

EventArgs for handler of action 'Save a fix position of a camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs::GeViAct_PrePosSaveEventArgs ( ) [private]
GeViAct_PrePosSaveEventArgs::GeViAct_PrePosSaveEventArgs ( GeViAct_PrePosSave^ initAction )

Create the EventArgs for handler of action 'Save a fix position of a camera'.

Parameters:
initAction Managed action 'Save a fix position of a camera'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs::aPosition

ID of the fix position.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs::aVideoInput

ID of the camera, which position shall be saved.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance Class Reference

  • AlarmControlActions
  • GeViAct_QuitAlarmByInstance
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance Class Reference
Actions

Action 'Quitting a alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance:
[legend]

List of all members.

Public Member Functions

GeViAct_QuitAlarmByInstance (GeViClientID initClientID, GeViAlarmID initAlarmID, String^ initAlarmText)
Create the action 'Quitting a alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_QuitAlarmByInstance^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description.

Detailed Description

Action 'Quitting a alarm'.

Constructor & Destructor Documentation

GeViAct_QuitAlarmByInstance::GeViAct_QuitAlarmByInstance | ( | GeViClientID | initClientID,
 |  | GeViAlarmID | initAlarmID,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Quitting a alarm'.

Parameters:
initClientID | Automatic insert of the quitting user
initAlarmID | Instance ID of the alarm
initAlarmText | Description

Member Function Documentation

GeViAct_QuitAlarmByInstance GeViAct_QuitAlarmByInstance::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_QuitAlarmByInstance::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance::aClientID

Automatic insert of the quitting user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_QuitAlarmByInstanceEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_QuitAlarmByInstanceEventArgs (GeViAct_QuitAlarmByInstance^ initAction)
Create the EventArgs for handler of action 'Quitting a alarm'.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViAlarmID | aAlarmID
Instance ID of the alarm.
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_QuitAlarmByInstanceEventArgs ()

Detailed Description

EventArgs for handler of action 'Quitting a alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs::GeViAct_QuitAlarmByInstanceEventArgs ( ) [private]
GeViAct_QuitAlarmByInstanceEventArgs::GeViAct_QuitAlarmByInstanceEventArgs ( GeViAct_QuitAlarmByInstance^ initAction )

Create the EventArgs for handler of action 'Quitting a alarm'.

Parameters:
initAction Managed action 'Quitting a alarm'.

Property Documentation

GeViAlarmID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs::aAlarmID

Instance ID of the alarm.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs::aClientID

Automatic insert of the quitting user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG Class Reference

  • AlarmControlActions
  • GeViAct_QuitAlarmByMG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG Class Reference
Actions

Action 'Quit an actual alarm on a monitorgroup'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG:
[legend]

List of all members.

Public Member Functions

GeViAct_QuitAlarmByMG (GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText)
Create the action 'Quit an actual alarm on a monitorgroup'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_QuitAlarmByMG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Detailed Description

Action 'Quit an actual alarm on a monitorgroup'.

Constructor & Destructor Documentation

GeViAct_QuitAlarmByMG::GeViAct_QuitAlarmByMG | ( | GeViClientID | initClientID,
 |  | GeViMGID | initMGID,
 |  | String^ | initMGName,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Quit an actual alarm on a monitorgroup'.

Parameters:
initClientID | Automatic insert of the quitting user
initMGID | ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
initMGName | Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
initAlarmText | Description

Member Function Documentation

GeViAct_QuitAlarmByMG GeViAct_QuitAlarmByMG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_QuitAlarmByMG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG::aClientID

Automatic insert of the quitting user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_QuitAlarmByMGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_QuitAlarmByMGEventArgs (GeViAct_QuitAlarmByMG^ initAction)
Create the EventArgs for handler of action 'Quit an actual alarm on a monitorgroup'.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_QuitAlarmByMGEventArgs ()

Detailed Description

EventArgs for handler of action 'Quit an actual alarm on a monitorgroup'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs::GeViAct_QuitAlarmByMGEventArgs ( ) [private]
GeViAct_QuitAlarmByMGEventArgs::GeViAct_QuitAlarmByMGEventArgs ( GeViAct_QuitAlarmByMG^ initAction )

Create the EventArgs for handler of action 'Quit an actual alarm on a monitorgroup'.

Parameters:
initAction Managed action 'Quit an actual alarm on a monitorgroup'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs::aClientID

Automatic insert of the quitting user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType Class Reference

  • AlarmControlActions
  • GeViAct_QuitAlarmByType
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType Class Reference
Actions

Action 'Quitting an alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType:
[legend]

List of all members.

Public Member Functions

GeViAct_QuitAlarmByType (GeViClientID initClientID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, String^ initAlarmText)
Create the action 'Quitting an alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_QuitAlarmByType^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type; only used in the case of empty AlarmType.
String^ | aAlarmType
Name of the alarm type.
String^ | aAlarmText
Description.

Detailed Description

Action 'Quitting an alarm'.

Constructor & Destructor Documentation

GeViAct_QuitAlarmByType::GeViAct_QuitAlarmByType | ( | GeViClientID | initClientID,
 |  | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Quitting an alarm'.

Parameters:
initClientID | Automatic insert of the quitting user
initAlarmTypeID | ID of the alarm type; only used in the case of empty AlarmType
initAlarmType | Name of the alarm type
initAlarmText | Description

Member Function Documentation

GeViAct_QuitAlarmByType GeViAct_QuitAlarmByType::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_QuitAlarmByType::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType::aAlarmText

Description.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType::aAlarmTypeID

ID of the alarm type; only used in the case of empty AlarmType.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType::aClientID

Automatic insert of the quitting user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_QuitAlarmByTypeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_QuitAlarmByTypeEventArgs (GeViAct_QuitAlarmByType^ initAction)
Create the EventArgs for handler of action 'Quitting an alarm'.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type; only used in the case of empty AlarmType.
String^ | aAlarmType
Name of the alarm type.
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_QuitAlarmByTypeEventArgs ()

Detailed Description

EventArgs for handler of action 'Quitting an alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs::GeViAct_QuitAlarmByTypeEventArgs ( ) [private]
GeViAct_QuitAlarmByTypeEventArgs::GeViAct_QuitAlarmByTypeEventArgs ( GeViAct_QuitAlarmByType^ initAction )

Create the EventArgs for handler of action 'Quitting an alarm'.

Parameters:
initAction Managed action 'Quitting an alarm'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs::aAlarmText

Description.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs::aAlarmType

Name of the alarm type.

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs::aAlarmTypeID

ID of the alarm type; only used in the case of empty AlarmType.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs::aClientID

Automatic insert of the quitting user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG Class Reference

  • AlarmControlActions
  • GeViAct_QuitAllAlarmsOnMG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG Class Reference
Actions

Action 'Quit of all alarms on a moitor group'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG:
[legend]

List of all members.

Public Member Functions

GeViAct_QuitAllAlarmsOnMG (GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText)
Create the action 'Quit of all alarms on a moitor group'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_QuitAllAlarmsOnMG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Detailed Description

Action 'Quit of all alarms on a moitor group'.

Constructor & Destructor Documentation

GeViAct_QuitAllAlarmsOnMG::GeViAct_QuitAllAlarmsOnMG | ( | GeViClientID | initClientID,
 |  | GeViMGID | initMGID,
 |  | String^ | initMGName,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Quit of all alarms on a moitor group'.

Parameters:
initClientID | Automatic insert of the quitting user
initMGID | ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
initMGName | Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
initAlarmText | Description

Member Function Documentation

GeViAct_QuitAllAlarmsOnMG GeViAct_QuitAllAlarmsOnMG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_QuitAllAlarmsOnMG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG::aClientID

Automatic insert of the quitting user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_QuitAllAlarmsOnMGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_QuitAllAlarmsOnMGEventArgs (GeViAct_QuitAllAlarmsOnMG^ initAction)
Create the EventArgs for handler of action 'Quit of all alarms on a moitor group'.

Properties

GeViClientID | aClientID
Automatic insert of the quitting user.
GeViMGID | aMGID
ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.
String^ | aMGName
Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_QuitAllAlarmsOnMGEventArgs ()

Detailed Description

EventArgs for handler of action 'Quit of all alarms on a moitor group'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs::GeViAct_QuitAllAlarmsOnMGEventArgs ( ) [private]
GeViAct_QuitAllAlarmsOnMGEventArgs::GeViAct_QuitAllAlarmsOnMGEventArgs ( GeViAct_QuitAllAlarmsOnMG^ initAction )

Create the EventArgs for handler of action 'Quit of all alarms on a moitor group'.

Parameters:
initAction Managed action 'Quit of all alarms on a moitor group'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs::aAlarmText

Description.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs::aClientID

Automatic insert of the quitting user.

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs::aMGID

ID of the monitor group, on which the alarm is displayed; used only by empty MGName field.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs::aMGName

Name of the monitor group, on which the alarm is displayed or empty (mean search criterion).

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster Class Reference

  • SystemActions
  • GeViAct_RedChangeMaster
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster Class Reference
Actions

Action 'Set new server as master'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster:
[legend]

List of all members.

Public Member Functions

GeViAct_RedChangeMaster (String^ initNewMaster, Boolean initDisconnectIOClients)
Create the action 'Set new server as master'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_RedChangeMaster^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aNewMaster
Name of the new master server.
Boolean | aDisconnectIOClients
If true, all GeViIO clients will be disconnected.

Detailed Description

Action 'Set new server as master'.

Constructor & Destructor Documentation

GeViAct_RedChangeMaster::GeViAct_RedChangeMaster | ( | String^ | initNewMaster,
 |  | Boolean | initDisconnectIOClients
 | ) |  |

Create the action 'Set new server as master'.

Parameters:
initNewMaster | Name of the new master server
initDisconnectIOClients | If true, all GeViIO clients will be disconnected.

Member Function Documentation

GeViAct_RedChangeMaster GeViAct_RedChangeMaster::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RedChangeMaster::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster::aDisconnectIOClients

If true, all GeViIO clients will be disconnected.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster::aNewMaster

Name of the new master server.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RedChangeMasterEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RedChangeMasterEventArgs (GeViAct_RedChangeMaster^ initAction)
Create the EventArgs for handler of action 'Set new server as master'.

Properties

String^ | aNewMaster
Name of the new master server.
Boolean | aDisconnectIOClients
If true, all GeViIO clients will be disconnected.

Private Member Functions

GeViAct_RedChangeMasterEventArgs ()

Detailed Description

EventArgs for handler of action 'Set new server as master'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs::GeViAct_RedChangeMasterEventArgs ( ) [private]
GeViAct_RedChangeMasterEventArgs::GeViAct_RedChangeMasterEventArgs ( GeViAct_RedChangeMaster^ initAction )

Create the EventArgs for handler of action 'Set new server as master'.

Parameters:
initAction Managed action 'Set new server as master'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs::aDisconnectIOClients

If true, all GeViIO clients will be disconnected.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs::aNewMaster

Name of the new master server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged Class Reference

  • SystemActions
  • GeViAct_RedConnectionMasterChanged
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged Class Reference
Actions

Action 'Connection master was changed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged:
[legend]

List of all members.

Public Member Functions

GeViAct_RedConnectionMasterChanged (String^ initNewMaster, String^ initOldMaster, String^ initUser, String^ initHost)
Create the action 'Connection master was changed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_RedConnectionMasterChanged^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aNewMaster
Name of the new master server.
String^ | aOldMaster
Name of the old master server.
String^ | aUser
Name of the connected user.
String^ | aHost
Hostname or addresse.

Detailed Description

Action 'Connection master was changed'.

Constructor & Destructor Documentation

GeViAct_RedConnectionMasterChanged::GeViAct_RedConnectionMasterChanged | ( | String^ | initNewMaster,
 |  | String^ | initOldMaster,
 |  | String^ | initUser,
 |  | String^ | initHost
 | ) |  |

Create the action 'Connection master was changed'.

Parameters:
initNewMaster | Name of the new master server
initOldMaster | Name of the old master server
initUser | Name of the connected user
initHost | Hostname or addresse

Member Function Documentation

GeViAct_RedConnectionMasterChanged GeViAct_RedConnectionMasterChanged::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RedConnectionMasterChanged::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged::aHost

Hostname or addresse.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged::aNewMaster

Name of the new master server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged::aOldMaster

Name of the old master server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged::aUser

Name of the connected user.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RedConnectionMasterChangedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RedConnectionMasterChangedEventArgs (GeViAct_RedConnectionMasterChanged^ initAction)
Create the EventArgs for handler of action 'Connection master was changed'.

Properties

String^ | aNewMaster
Name of the new master server.
String^ | aOldMaster
Name of the old master server.
String^ | aUser
Name of the connected user.
String^ | aHost
Hostname or addresse.

Private Member Functions

GeViAct_RedConnectionMasterChangedEventArgs ()

Detailed Description

EventArgs for handler of action 'Connection master was changed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs::GeViAct_RedConnectionMasterChangedEventArgs ( ) [private]
GeViAct_RedConnectionMasterChangedEventArgs::GeViAct_RedConnectionMasterChangedEventArgs ( GeViAct_RedConnectionMasterChanged^ initAction )

Create the EventArgs for handler of action 'Connection master was changed'.

Parameters:
initAction Managed action 'Connection master was changed'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs::aHost

Hostname or addresse.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs::aNewMaster

Name of the new master server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs::aOldMaster

Name of the old master server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs::aUser

Name of the connected user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource Class Reference

  • SystemActions
  • GeViAct_RedirectResource
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource Class Reference
Actions

Action 'Redirect resource.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource:
[legend]

List of all members.

Public Member Functions

GeViAct_RedirectResource (GeViTGeViResourceType initResourceType, Int32 initOldNumber, Int32 initNewNumber)
Create the action 'Redirect resource.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_RedirectResource^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViTGeViResourceType | aResourceType
Type of the resource.
Int32 | aOldNumber
Old resource ID.
Int32 | aNewNumber
New resource ID.

Detailed Description

Action 'Redirect resource.'.

Constructor & Destructor Documentation

GeViAct_RedirectResource::GeViAct_RedirectResource | ( | GeViTGeViResourceType | initResourceType,
 |  | Int32 | initOldNumber,
 |  | Int32 | initNewNumber
 | ) |  |

Create the action 'Redirect resource.'.

Parameters:
initResourceType | Type of the resource
initOldNumber | Old resource ID.
initNewNumber | New resource ID.

Member Function Documentation

GeViAct_RedirectResource GeViAct_RedirectResource::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RedirectResource::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource::aNewNumber

New resource ID.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource::aOldNumber

Old resource ID.

GeViTGeViResourceType GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource::aResourceType

Type of the resource.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RedirectResourceEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RedirectResourceEventArgs (GeViAct_RedirectResource^ initAction)
Create the EventArgs for handler of action 'Redirect resource.'.

Properties

GeViTGeViResourceType | aResourceType
Type of the resource.
Int32 | aOldNumber
Old resource ID.
Int32 | aNewNumber
New resource ID.

Private Member Functions

GeViAct_RedirectResourceEventArgs ()

Detailed Description

EventArgs for handler of action 'Redirect resource.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs::GeViAct_RedirectResourceEventArgs ( ) [private]
GeViAct_RedirectResourceEventArgs::GeViAct_RedirectResourceEventArgs ( GeViAct_RedirectResource^ initAction )

Create the EventArgs for handler of action 'Redirect resource.'.

Parameters:
initAction Managed action 'Redirect resource.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs::aNewNumber

New resource ID.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs::aOldNumber

Old resource ID.

GeViTGeViResourceType GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs::aResourceType

Type of the resource.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged Class Reference

  • SystemActions
  • GeViAct_RedMasterServerChanged
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged Class Reference
Actions

Action 'Master server was changed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged:
[legend]

List of all members.

Public Member Functions

GeViAct_RedMasterServerChanged (String^ initNewMaster, String^ initOldMaster)
Create the action 'Master server was changed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_RedMasterServerChanged^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aNewMaster
Name of the new master server.
String^ | aOldMaster
Name of the old master server.

Detailed Description

Action 'Master server was changed'.

Constructor & Destructor Documentation

GeViAct_RedMasterServerChanged::GeViAct_RedMasterServerChanged | ( | String^ | initNewMaster,
 |  | String^ | initOldMaster
 | ) |  |

Create the action 'Master server was changed'.

Parameters:
initNewMaster | Name of the new master server
initOldMaster | Name of the old master server

Member Function Documentation

GeViAct_RedMasterServerChanged GeViAct_RedMasterServerChanged::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RedMasterServerChanged::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged::aNewMaster

Name of the new master server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged::aOldMaster

Name of the old master server.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RedMasterServerChangedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RedMasterServerChangedEventArgs (GeViAct_RedMasterServerChanged^ initAction)
Create the EventArgs for handler of action 'Master server was changed'.

Properties

String^ | aNewMaster
Name of the new master server.
String^ | aOldMaster
Name of the old master server.

Private Member Functions

GeViAct_RedMasterServerChangedEventArgs ()

Detailed Description

EventArgs for handler of action 'Master server was changed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs::GeViAct_RedMasterServerChangedEventArgs ( ) [private]
GeViAct_RedMasterServerChangedEventArgs::GeViAct_RedMasterServerChangedEventArgs ( GeViAct_RedMasterServerChanged^ initAction )

Create the EventArgs for handler of action 'Master server was changed'.

Parameters:
initAction Managed action 'Master server was changed'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs::aNewMaster

Name of the new master server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs::aOldMaster

Name of the old master server.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed Class Reference

  • SystemActions
  • GeViAct_RedRedundantLoginFailed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed Class Reference
Actions

Action 'Redundant login failed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed:
[legend]

List of all members.

Public Member Functions

GeViAct_RedRedundantLoginFailed (String^ initUser, String^ initHost, String^ initServerHost)
Create the action 'Redundant login failed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_RedRedundantLoginFailed^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aUser
Name of the connected user.
String^ | aHost
Hostname or address of the user.
String^ | aServerHost
Hostname or address of the server.

Detailed Description

Action 'Redundant login failed'.

Constructor & Destructor Documentation

GeViAct_RedRedundantLoginFailed::GeViAct_RedRedundantLoginFailed | ( | String^ | initUser,
 |  | String^ | initHost,
 |  | String^ | initServerHost
 | ) |  |

Create the action 'Redundant login failed'.

Parameters:
initUser | Name of the connected user
initHost | Hostname or address of the user
initServerHost | Hostname or address of the server

Member Function Documentation

GeViAct_RedRedundantLoginFailed GeViAct_RedRedundantLoginFailed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RedRedundantLoginFailed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed::aHost

Hostname or address of the user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed::aServerHost

Hostname or address of the server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed::aUser

Name of the connected user.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RedRedundantLoginFailedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RedRedundantLoginFailedEventArgs (GeViAct_RedRedundantLoginFailed^ initAction)
Create the EventArgs for handler of action 'Redundant login failed'.

Properties

String^ | aUser
Name of the connected user.
String^ | aHost
Hostname or address of the user.
String^ | aServerHost
Hostname or address of the server.

Private Member Functions

GeViAct_RedRedundantLoginFailedEventArgs ()

Detailed Description

EventArgs for handler of action 'Redundant login failed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs::GeViAct_RedRedundantLoginFailedEventArgs ( ) [private]
GeViAct_RedRedundantLoginFailedEventArgs::GeViAct_RedRedundantLoginFailedEventArgs ( GeViAct_RedRedundantLoginFailed^ initAction )

Create the EventArgs for handler of action 'Redundant login failed'.

Parameters:
initAction Managed action 'Redundant login failed'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs::aHost

Hostname or address of the user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs::aServerHost

Hostname or address of the server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs::aUser

Name of the connected user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin Class Reference

  • SystemActions
  • GeViAct_RedRedundantUserLogin
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin Class Reference
Actions

Action 'Redundant login successful'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin:
[legend]

List of all members.

Public Member Functions

GeViAct_RedRedundantUserLogin (String^ initUser, String^ initHost, String^ initServerHost)
Create the action 'Redundant login successful'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_RedRedundantUserLogin^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aUser
Name of the connected user.
String^ | aHost
Hostname or address of the user.
String^ | aServerHost
Hostname or address of the server.

Detailed Description

Action 'Redundant login successful'.

Constructor & Destructor Documentation

GeViAct_RedRedundantUserLogin::GeViAct_RedRedundantUserLogin | ( | String^ | initUser,
 |  | String^ | initHost,
 |  | String^ | initServerHost
 | ) |  |

Create the action 'Redundant login successful'.

Parameters:
initUser | Name of the connected user
initHost | Hostname or address of the user
initServerHost | Hostname or address of the server

Member Function Documentation

GeViAct_RedRedundantUserLogin GeViAct_RedRedundantUserLogin::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RedRedundantUserLogin::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin::aHost

Hostname or address of the user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin::aServerHost

Hostname or address of the server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin::aUser

Name of the connected user.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RedRedundantUserLoginEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RedRedundantUserLoginEventArgs (GeViAct_RedRedundantUserLogin^ initAction)
Create the EventArgs for handler of action 'Redundant login successful'.

Properties

String^ | aUser
Name of the connected user.
String^ | aHost
Hostname or address of the user.
String^ | aServerHost
Hostname or address of the server.

Private Member Functions

GeViAct_RedRedundantUserLoginEventArgs ()

Detailed Description

EventArgs for handler of action 'Redundant login successful'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs::GeViAct_RedRedundantUserLoginEventArgs ( ) [private]
GeViAct_RedRedundantUserLoginEventArgs::GeViAct_RedRedundantUserLoginEventArgs ( GeViAct_RedRedundantUserLogin^ initAction )

Create the EventArgs for handler of action 'Redundant login successful'.

Parameters:
initAction Managed action 'Redundant login successful'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs::aHost

Hostname or address of the user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs::aServerHost

Hostname or address of the server.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs::aUser

Name of the connected user.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest Class Reference

  • SystemActions
  • GeViAct_RescannRequest
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest Class Reference
Actions

Action 'Request to all users to perform a rescan'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest:
[legend]

List of all members.

Public Member Functions

GeViAct_RescannRequest (Boolean initInformDevices)
Create the action 'Request to all users to perform a rescan'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_RescannRequest^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Boolean | aInformDevices
true = Scan connected devices

Detailed Description

Action 'Request to all users to perform a rescan'.

Constructor & Destructor Documentation

GeViAct_RescannRequest::GeViAct_RescannRequest ( Boolean initInformDevices )

Create the action 'Request to all users to perform a rescan'.

Parameters:
initInformDevices true = Scan connected devices

Member Function Documentation

GeViAct_RescannRequest GeViAct_RescannRequest::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RescannRequest::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest::aInformDevices

true = Scan connected devices

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RescannRequestEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RescannRequestEventArgs (GeViAct_RescannRequest^ initAction)
Create the EventArgs for handler of action 'Request to all users to perform a rescan'.

Properties

Boolean aInformDevices
true = Scan connected devices

Private Member Functions

GeViAct_RescannRequestEventArgs ()

Detailed Description

EventArgs for handler of action 'Request to all users to perform a rescan'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs::GeViAct_RescannRequestEventArgs ( ) [private]
GeViAct_RescannRequestEventArgs::GeViAct_RescannRequestEventArgs ( GeViAct_RescannRequest^ initAction )

Create the EventArgs for handler of action 'Request to all users to perform a rescan'.

Parameters:
initAction Managed action 'Request to all users to perform a rescan'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs::aInformDevices

true = Scan connected devices

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient Class Reference

  • SystemActions
  • GeViAct_RescannRequestToClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient Class Reference
Actions

Action 'Request to a user to perform a rescan'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient:
[legend]

List of all members.

Public Member Functions

GeViAct_RescannRequestToClient (GeViClientID initClientID, String^ initClientName, Boolean initInformDevices)
Create the action 'Request to a user to perform a rescan'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_RescannRequestToClient^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of the recipient of the message, it is only needed if the ClientName is empty.
String^ | aClientName
Name of the recipient of the message respective empty.
Boolean | aInformDevices
true = Scan connected devices

Detailed Description

Action 'Request to a user to perform a rescan'.

Constructor & Destructor Documentation

GeViAct_RescannRequestToClient::GeViAct_RescannRequestToClient | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | Boolean | initInformDevices
 | ) |  |

Create the action 'Request to a user to perform a rescan'.

Parameters:
initClientID | ID of the recipient of the message, it is only needed if the ClientName is empty
initClientName | Name of the recipient of the message respective empty
initInformDevices | true = Scan connected devices

Member Function Documentation

GeViAct_RescannRequestToClient GeViAct_RescannRequestToClient::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RescannRequestToClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient::aClientID

ID of the recipient of the message, it is only needed if the ClientName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient::aClientName

Name of the recipient of the message respective empty.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient::aInformDevices

true = Scan connected devices

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RescannRequestToClientEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RescannRequestToClientEventArgs (GeViAct_RescannRequestToClient^ initAction)
Create the EventArgs for handler of action 'Request to a user to perform a rescan'.

Properties

GeViClientID | aClientID
ID of the recipient of the message, it is only needed if the ClientName is empty.
String^ | aClientName
Name of the recipient of the message respective empty.
Boolean | aInformDevices
true = Scan connected devices

Private Member Functions

GeViAct_RescannRequestToClientEventArgs ()

Detailed Description

EventArgs for handler of action 'Request to a user to perform a rescan'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs::GeViAct_RescannRequestToClientEventArgs ( ) [private]
GeViAct_RescannRequestToClientEventArgs::GeViAct_RescannRequestToClientEventArgs ( GeViAct_RescannRequestToClient^ initAction )

Create the EventArgs for handler of action 'Request to a user to perform a rescan'.

Parameters:
initAction Managed action 'Request to a user to perform a rescan'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs::aClientID

ID of the recipient of the message, it is only needed if the ClientName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs::aClientName

Name of the recipient of the message respective empty.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs::aInformDevices

true = Scan connected devices

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile Class Reference

  • SystemActions
  • GeViAct_RestoreRightProfile
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile Class Reference
Actions

Action 'Restore right profile of a user'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile:
[legend]

List of all members.

Public Member Functions

GeViAct_RestoreRightProfile (GeViClientID initUserID, String^ initUserName)
Create the action 'Restore right profile of a user'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_RestoreRightProfile^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aUserID
ID of the user, only if name is empty.
String^ | aUserName
Name of the user or empty.

Detailed Description

Action 'Restore right profile of a user'.

Constructor & Destructor Documentation

GeViAct_RestoreRightProfile::GeViAct_RestoreRightProfile | ( | GeViClientID | initUserID,
 |  | String^ | initUserName
 | ) |  |

Create the action 'Restore right profile of a user'.

Parameters:
initUserID | ID of the user, only if name is empty.
initUserName | Name of the user or empty

Member Function Documentation

GeViAct_RestoreRightProfile GeViAct_RestoreRightProfile::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_RestoreRightProfile::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile::aUserID

ID of the user, only if name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile::aUserName

Name of the user or empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_RestoreRightProfileEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_RestoreRightProfileEventArgs (GeViAct_RestoreRightProfile^ initAction)
Create the EventArgs for handler of action 'Restore right profile of a user'.

Properties

GeViClientID | aUserID
ID of the user, only if name is empty.
String^ | aUserName
Name of the user or empty.

Private Member Functions

GeViAct_RestoreRightProfileEventArgs ()

Detailed Description

EventArgs for handler of action 'Restore right profile of a user'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs::GeViAct_RestoreRightProfileEventArgs ( ) [private]
GeViAct_RestoreRightProfileEventArgs::GeViAct_RestoreRightProfileEventArgs ( GeViAct_RestoreRightProfile^ initAction )

Create the EventArgs for handler of action 'Restore right profile of a user'.

Parameters:
initAction Managed action 'Restore right profile of a user'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs::aUserID

ID of the user, only if name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs::aUserName

Name of the user or empty.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData Class Reference

  • SystemActions
  • GeViAct_SendRawData
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData Class Reference
Actions

Action 'Output the data to a RAW- or any other serial interface'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData:
[legend]

List of all members.

Public Member Functions

GeViAct_SendRawData (GeViClientID initClientID, String^ initClientName, String^ initRawData)
Create the action 'Output the data to a RAW- or any other serial interface'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SendRawData^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of the recipient of the message, it is only needed if the ClientName is empty.
String^ | aClientName
Name of the recipient of the message respective empty.
String^ | aRawData
Data.

Detailed Description

Action 'Output the data to a RAW- or any other serial interface'.

Constructor & Destructor Documentation

GeViAct_SendRawData::GeViAct_SendRawData | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | String^ | initRawData
 | ) |  |

Create the action 'Output the data to a RAW- or any other serial interface'.

Parameters:
initClientID | ID of the recipient of the message, it is only needed if the ClientName is empty
initClientName | Name of the recipient of the message respective empty
initRawData | Data

Member Function Documentation

GeViAct_SendRawData GeViAct_SendRawData::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SendRawData::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData::aClientID

ID of the recipient of the message, it is only needed if the ClientName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData::aClientName

Name of the recipient of the message respective empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData::aRawData

Data.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SendRawDataEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SendRawDataEventArgs (GeViAct_SendRawData^ initAction)
Create the EventArgs for handler of action 'Output the data to a RAW- or any other serial interface'.

Properties

GeViClientID | aClientID
ID of the recipient of the message, it is only needed if the ClientName is empty.
String^ | aClientName
Name of the recipient of the message respective empty.
String^ | aRawData
Data.

Private Member Functions

GeViAct_SendRawDataEventArgs ()

Detailed Description

EventArgs for handler of action 'Output the data to a RAW- or any other serial interface'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs::GeViAct_SendRawDataEventArgs ( ) [private]
GeViAct_SendRawDataEventArgs::GeViAct_SendRawDataEventArgs ( GeViAct_SendRawData^ initAction )

Create the EventArgs for handler of action 'Output the data to a RAW- or any other serial interface'.

Parameters:
initAction Managed action 'Output the data to a RAW- or any other serial interface'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs::aClientID

ID of the recipient of the message, it is only needed if the ClientName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs::aClientName

Name of the recipient of the message respective empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs::aRawData

Data.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG Class Reference

  • SystemActions
  • GeViAct_SendRawDataMSG
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG Class Reference
Actions

Action 'Output the data to a RAW- or any other serial interface'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG:
[legend]

List of all members.

Public Member Functions

GeViAct_SendRawDataMSG (GeViClientID initClientID, String^ initClientName, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal)
Create the action 'Output the data to a RAW- or any other serial interface'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SendRawDataMSG^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of the recipient of the message, it is only needed if the ClientName is empty.
String^ | aClientName
Name of the recipient of the message respective empty.
Int32 | aMessageID
ID of the message. It is only needed, if the MessageName is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.

Detailed Description

Action 'Output the data to a RAW- or any other serial interface'.

Constructor & Destructor Documentation

GeViAct_SendRawDataMSG::GeViAct_SendRawDataMSG | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | Int32 | initMessageID,
 |  | String^ | initMessageName,
 |  | GeViMessageInternal | initMessageInternal
 | ) |  |

Create the action 'Output the data to a RAW- or any other serial interface'.

Parameters:
initClientID | ID of the recipient of the message, it is only needed if the ClientName is empty
initClientName | Name of the recipient of the message respective empty
initMessageID | ID of the message. It is only needed, if the MessageName is empty.
initMessageName | Name of the message respective empty
initMessageInternal | An internal structur, what is not to pass on outwards.

Member Function Documentation

GeViAct_SendRawDataMSG GeViAct_SendRawDataMSG::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SendRawDataMSG::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG::aClientID

ID of the recipient of the message, it is only needed if the ClientName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG::aClientName

Name of the recipient of the message respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG::aMessageID

ID of the message. It is only needed, if the MessageName is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG::aMessageName

Name of the message respective empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SendRawDataMSGEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SendRawDataMSGEventArgs (GeViAct_SendRawDataMSG^ initAction)
Create the EventArgs for handler of action 'Output the data to a RAW- or any other serial interface'.

Properties

GeViClientID | aClientID
ID of the recipient of the message, it is only needed if the ClientName is empty.
String^ | aClientName
Name of the recipient of the message respective empty.
Int32 | aMessageID
ID of the message. It is only needed, if the MessageName is empty.
String^ | aMessageName
Name of the message respective empty.
GeViMessageInternal | aMessageInternal
An internal structur, what is not to pass on outwards.

Private Member Functions

GeViAct_SendRawDataMSGEventArgs ()

Detailed Description

EventArgs for handler of action 'Output the data to a RAW- or any other serial interface'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs::GeViAct_SendRawDataMSGEventArgs ( ) [private]
GeViAct_SendRawDataMSGEventArgs::GeViAct_SendRawDataMSGEventArgs ( GeViAct_SendRawDataMSG^ initAction )

Create the EventArgs for handler of action 'Output the data to a RAW- or any other serial interface'.

Parameters:
initAction Managed action 'Output the data to a RAW- or any other serial interface'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs::aClientID

ID of the recipient of the message, it is only needed if the ClientName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs::aClientName

Name of the recipient of the message respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs::aMessageID

ID of the message. It is only needed, if the MessageName is empty.

GeViMessageInternal GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs::aMessageInternal

An internal structur, what is not to pass on outwards.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs::aMessageName

Name of the message respective empty.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm Class Reference

  • AlarmControlActions
  • GeViAct_StartAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm Class Reference
Actions

Action 'Start of a alarm of a special typ'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_StartAlarm (GeViClientID initClientID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, String^ initAlarmText)
Create the action 'Start of a alarm of a special typ'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StartAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic insert of the sender.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type, it is only used for the search, if name is empty.
String^ | aAlarmType
Name of alarm type (mean criterion)
String^ | aAlarmText
Description.

Detailed Description

Action 'Start of a alarm of a special typ'.

Constructor & Destructor Documentation

GeViAct_StartAlarm::GeViAct_StartAlarm | ( | GeViClientID | initClientID,
 |  | GeViAlarmTypeID | initAlarmTypeID,
 |  | String^ | initAlarmType,
 |  | String^ | initAlarmText
 | ) |  |

Create the action 'Start of a alarm of a special typ'.

Parameters:
initClientID | Automatic insert of the sender
initAlarmTypeID | ID of the alarm type, it is only used for the search, if name is empty
initAlarmType | Name of alarm type (mean criterion)
initAlarmText | Description

Member Function Documentation

GeViAct_StartAlarm GeViAct_StartAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StartAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm::aAlarmText

Description.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm::aAlarmType

Name of alarm type (mean criterion)

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm::aAlarmTypeID

ID of the alarm type, it is only used for the search, if name is empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm::aClientID

Automatic insert of the sender.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StartAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StartAlarmEventArgs (GeViAct_StartAlarm^ initAction)
Create the EventArgs for handler of action 'Start of a alarm of a special typ'.

Properties

GeViClientID | aClientID
Automatic insert of the sender.
GeViAlarmTypeID | aAlarmTypeID
ID of the alarm type, it is only used for the search, if name is empty.
String^ | aAlarmType
Name of alarm type (mean criterion)
String^ | aAlarmText
Description.

Private Member Functions

GeViAct_StartAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of a alarm of a special typ'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs::GeViAct_StartAlarmEventArgs ( ) [private]
GeViAct_StartAlarmEventArgs::GeViAct_StartAlarmEventArgs ( GeViAct_StartAlarm^ initAction )

Create the EventArgs for handler of action 'Start of a alarm of a special typ'.

Parameters:
initAction Managed action 'Start of a alarm of a special typ'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs::aAlarmText

Description.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs::aAlarmType

Name of alarm type (mean criterion)

GeViAlarmTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs::aAlarmTypeID

ID of the alarm type, it is only used for the search, if name is empty.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs::aClientID

Automatic insert of the sender.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent Class Reference

  • SystemActions
  • GeViAct_StartEvent
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent Class Reference
Actions

Action 'Start of event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent:
[legend]

List of all members.

Public Member Functions

GeViAct_StartEvent (GeViEventTypeID initEventTypeID, String^ initEventName)
Create the action 'Start of event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StartEvent^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViEventTypeID | aEventTypeID
ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
String^ | aEventName
Name of the event respective empty.

Detailed Description

Action 'Start of event'.

Constructor & Destructor Documentation

GeViAct_StartEvent::GeViAct_StartEvent | ( | GeViEventTypeID | initEventTypeID,
 |  | String^ | initEventName
 | ) |  |

Create the action 'Start of event'.

Parameters:
initEventTypeID | ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
initEventName | Name of the event respective empty

Member Function Documentation

GeViAct_StartEvent GeViAct_StartEvent::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StartEvent::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent::aEventName

Name of the event respective empty.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent::aEventTypeID

ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StartEventEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StartEventEventArgs (GeViAct_StartEvent^ initAction)
Create the EventArgs for handler of action 'Start of event'.

Properties

GeViEventTypeID | aEventTypeID
ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.
String^ | aEventName
Name of the event respective empty.

Private Member Functions

GeViAct_StartEventEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs::GeViAct_StartEventEventArgs ( ) [private]
GeViAct_StartEventEventArgs::GeViAct_StartEventEventArgs ( GeViAct_StartEvent^ initAction )

Create the EventArgs for handler of action 'Start of event'.

Parameters:
initAction Managed action 'Start of event'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs::aEventName

Name of the event respective empty.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs::aEventTypeID

ID of event typ; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent Class Reference

  • MscIIActions
  • GeViAct_StartMscEvent
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent Class Reference
Actions

Action 'Start of MULTISCOPE event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent:
[legend]

List of all members.

Public Member Functions

GeViAct_StartMscEvent (Int32 initMscServerID, String^ initMscServerName, Int32 initMscEventRef, String^ initMscEventName, Int32 initMscStartKind, Int64 initMscInt1, Int64 initMscInt2, String^ initMscBlob)
Create the action 'Start of MULTISCOPE event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StartMscEvent^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of MULTISCOPE server; It will only needed, if the server name is empty.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server respective empty.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.
String^ | aMscEventName
Name of the MULTISCOPE event type respective empty.
Int32 | aMscStartKind
Start kind (currently only 0 = normal)
Int64 | aMscInt1
EventParam1 of MULTISCOPE Event record.
Int64 | aMscInt2
EventParam2 of MULTISCOPE Event record.
String^ | aMscBlob
Information stored in blob field of the MULTISCOPE Event record respective empty.

Detailed Description

Action 'Start of MULTISCOPE event'.

Constructor & Destructor Documentation

GeViAct_StartMscEvent::GeViAct_StartMscEvent | ( | Int32 | initMscServerID,
 |  | String^ | initMscServerName,
 |  | Int32 | initMscEventRef,
 |  | String^ | initMscEventName,
 |  | Int32 | initMscStartKind,
 |  | Int64 | initMscInt1,
 |  | Int64 | initMscInt2,
 |  | String^ | initMscBlob
 | ) |  |

Create the action 'Start of MULTISCOPE event'.

Parameters:
initMscServerID | GeVi-internal ID of MULTISCOPE server; It will only needed, if the server name is empty.
initMscServerName | Name (host name) of the MULTISCOPE server respective empty
initMscEventRef | GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.
initMscEventName | Name of the MULTISCOPE event type respective empty
initMscStartKind | Start kind (currently only 0 = normal)
initMscInt1 | EventParam1 of MULTISCOPE Event record
initMscInt2 | EventParam2 of MULTISCOPE Event record
initMscBlob | Information stored in blob field of the MULTISCOPE Event record respective empty

Member Function Documentation

GeViAct_StartMscEvent GeViAct_StartMscEvent::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StartMscEvent::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscBlob

Information stored in blob field of the MULTISCOPE Event record respective empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscEventName

Name of the MULTISCOPE event type respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscInt1

EventParam1 of MULTISCOPE Event record.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscInt2

EventParam2 of MULTISCOPE Event record.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscServerID

GeVi-internal ID of MULTISCOPE server; It will only needed, if the server name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscServerName

Name (host name) of the MULTISCOPE server respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent::aMscStartKind

Start kind (currently only 0 = normal)

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StartMscEventEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StartMscEventEventArgs (GeViAct_StartMscEvent^ initAction)
Create the EventArgs for handler of action 'Start of MULTISCOPE event'.

Properties

Int32 | aMscServerID
GeVi-internal ID of MULTISCOPE server; It will only needed, if the server name is empty.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server respective empty.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.
String^ | aMscEventName
Name of the MULTISCOPE event type respective empty.
Int32 | aMscStartKind
Start kind (currently only 0 = normal)
Int64 | aMscInt1
EventParam1 of MULTISCOPE Event record.
Int64 | aMscInt2
EventParam2 of MULTISCOPE Event record.
String^ | aMscBlob
Information stored in blob field of the MULTISCOPE Event record respective empty.

Private Member Functions

GeViAct_StartMscEventEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of MULTISCOPE event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::GeViAct_StartMscEventEventArgs ( ) [private]
GeViAct_StartMscEventEventArgs::GeViAct_StartMscEventEventArgs ( GeViAct_StartMscEvent^ initAction )

Create the EventArgs for handler of action 'Start of MULTISCOPE event'.

Parameters:
initAction Managed action 'Start of MULTISCOPE event'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscBlob

Information stored in blob field of the MULTISCOPE Event record respective empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscEventName

Name of the MULTISCOPE event type respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscInt1

EventParam1 of MULTISCOPE Event record.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscInt2

EventParam2 of MULTISCOPE Event record.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscServerID

GeVi-internal ID of MULTISCOPE server; It will only needed, if the server name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs::aMscStartKind

Start kind (currently only 0 = normal)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer Class Reference

  • SystemActions
  • GeViAct_StartTimer
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer Class Reference
Actions

Action 'Start timer'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer:
[legend]

List of all members.

Public Member Functions

GeViAct_StartTimer (Int32 initTimerID, String^ initTimerName)
Create the action 'Start timer'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StartTimer^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aTimerID
ID of the timer, it is only needed if the TimerName is empty.
String^ | aTimerName
Name of the timer.

Detailed Description

Action 'Start timer'.

Constructor & Destructor Documentation

GeViAct_StartTimer::GeViAct_StartTimer | ( | Int32 | initTimerID,
 |  | String^ | initTimerName
 | ) |  |

Create the action 'Start timer'.

Parameters:
initTimerID | ID of the timer, it is only needed if the TimerName is empty
initTimerName | Name of the timer

Member Function Documentation

GeViAct_StartTimer GeViAct_StartTimer::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StartTimer::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer::aTimerID

ID of the timer, it is only needed if the TimerName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer::aTimerName

Name of the timer.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StartTimerEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StartTimerEventArgs (GeViAct_StartTimer^ initAction)
Create the EventArgs for handler of action 'Start timer'.

Properties

Int32 | aTimerID
ID of the timer, it is only needed if the TimerName is empty.
String^ | aTimerName
Name of the timer.

Private Member Functions

GeViAct_StartTimerEventArgs ()

Detailed Description

EventArgs for handler of action 'Start timer'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs::GeViAct_StartTimerEventArgs ( ) [private]
GeViAct_StartTimerEventArgs::GeViAct_StartTimerEventArgs ( GeViAct_StartTimer^ initAction )

Create the EventArgs for handler of action 'Start timer'.

Parameters:
initAction Managed action 'Start timer'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs::aTimerID

ID of the timer, it is only needed if the TimerName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs::aTimerName

Name of the timer.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance Class Reference

  • SystemActions
  • GeViAct_StopEventByInstance
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance Class Reference
Actions

Action 'Stopp the event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance:
[legend]

List of all members.

Public Member Functions

GeViAct_StopEventByInstance (GeViEventID initEventID)
Create the action 'Stopp the event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StopEventByInstance^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViEventID | aEventID
Instance ID of the event.

Detailed Description

Action 'Stopp the event'.

Constructor & Destructor Documentation

GeViAct_StopEventByInstance::GeViAct_StopEventByInstance ( GeViEventID initEventID )

Create the action 'Stopp the event'.

Parameters:
initEventID Instance ID of the event

Member Function Documentation

GeViAct_StopEventByInstance GeViAct_StopEventByInstance::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StopEventByInstance::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance::aEventID

Instance ID of the event.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StopEventByInstanceEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StopEventByInstanceEventArgs (GeViAct_StopEventByInstance^ initAction)
Create the EventArgs for handler of action 'Stopp the event'.

Properties

GeViEventID aEventID
Instance ID of the event.

Private Member Functions

GeViAct_StopEventByInstanceEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp the event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs::GeViAct_StopEventByInstanceEventArgs ( ) [private]
GeViAct_StopEventByInstanceEventArgs::GeViAct_StopEventByInstanceEventArgs ( GeViAct_StopEventByInstance^ initAction )

Create the EventArgs for handler of action 'Stopp the event'.

Parameters:
initAction Managed action 'Stopp the event'.

Property Documentation

GeViEventID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs::aEventID

Instance ID of the event.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType Class Reference

  • SystemActions
  • GeViAct_StopEventByType
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType Class Reference
Actions

Action 'Stopp the event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType:
[legend]

List of all members.

Public Member Functions

GeViAct_StopEventByType (GeViEventTypeID initEventTypeID, String^ initEventName)
Create the action 'Stopp the event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StopEventByType^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViEventTypeID | aEventTypeID
ID of event type; Necessary, if the name is empty, otherwise it will be adapted.
String^ | aEventName
Name of the event respective empty.

Detailed Description

Action 'Stopp the event'.

Constructor & Destructor Documentation

GeViAct_StopEventByType::GeViAct_StopEventByType | ( | GeViEventTypeID | initEventTypeID,
 |  | String^ | initEventName
 | ) |  |

Create the action 'Stopp the event'.

Parameters:
initEventTypeID | ID of event type; Necessary, if the name is empty, otherwise it will be adapted.
initEventName | Name of the event respective empty

Member Function Documentation

GeViAct_StopEventByType GeViAct_StopEventByType::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StopEventByType::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType::aEventName

Name of the event respective empty.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType::aEventTypeID

ID of event type; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StopEventByTypeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StopEventByTypeEventArgs (GeViAct_StopEventByType^ initAction)
Create the EventArgs for handler of action 'Stopp the event'.

Properties

GeViEventTypeID | aEventTypeID
ID of event type; Necessary, if the name is empty, otherwise it will be adapted.
String^ | aEventName
Name of the event respective empty.

Private Member Functions

GeViAct_StopEventByTypeEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp the event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs::GeViAct_StopEventByTypeEventArgs ( ) [private]
GeViAct_StopEventByTypeEventArgs::GeViAct_StopEventByTypeEventArgs ( GeViAct_StopEventByType^ initAction )

Create the EventArgs for handler of action 'Stopp the event'.

Parameters:
initAction Managed action 'Stopp the event'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs::aEventName

Name of the event respective empty.

GeViEventTypeID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs::aEventTypeID

ID of event type; Necessary, if the name is empty, otherwise it will be adapted.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent Class Reference

  • MscIIActions
  • GeViAct_StopMscEvent
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent Class Reference
Actions

Action 'Stopp a MULTISCOPE event'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent:
[legend]

List of all members.

Public Member Functions

GeViAct_StopMscEvent (Int32 initMscServerID, String^ initMscServerName, Int32 initMscEventRef, String^ initMscEventName, Boolean initIgnoreRefs)
Create the action 'Stopp a MULTISCOPE event'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StopMscEvent^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aMscServerID
GeVi-internal ID of MULTISCOPE server; It will only be needed, if the MSCServerName is empty.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server respective empty.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.
String^ | aMscEventName
Name of the MULTISCOPE event type respective empty.
Boolean | aIgnoreRefs
true = Ignore the reference counting

Detailed Description

Action 'Stopp a MULTISCOPE event'.

Constructor & Destructor Documentation

GeViAct_StopMscEvent::GeViAct_StopMscEvent | ( | Int32 | initMscServerID,
 |  | String^ | initMscServerName,
 |  | Int32 | initMscEventRef,
 |  | String^ | initMscEventName,
 |  | Boolean | initIgnoreRefs
 | ) |  |

Create the action 'Stopp a MULTISCOPE event'.

Parameters:
initMscServerID | GeVi-internal ID of MULTISCOPE server; It will only be needed, if the MSCServerName is empty.
initMscServerName | Name (host name) of the MULTISCOPE server respective empty
initMscEventRef | GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.
initMscEventName | Name of the MULTISCOPE event type respective empty
initIgnoreRefs | true = Ignore the reference counting

Member Function Documentation

GeViAct_StopMscEvent GeViAct_StopMscEvent::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StopMscEvent::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent::aIgnoreRefs

true = Ignore the reference counting

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent::aMscEventName

Name of the MULTISCOPE event type respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent::aMscServerID

GeVi-internal ID of MULTISCOPE server; It will only be needed, if the MSCServerName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent::aMscServerName

Name (host name) of the MULTISCOPE server respective empty.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StopMscEventEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StopMscEventEventArgs (GeViAct_StopMscEvent^ initAction)
Create the EventArgs for handler of action 'Stopp a MULTISCOPE event'.

Properties

Int32 | aMscServerID
GeVi-internal ID of MULTISCOPE server; It will only be needed, if the MSCServerName is empty.
String^ | aMscServerName
Name (host name) of the MULTISCOPE server respective empty.
Int32 | aMscEventRef
GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.
String^ | aMscEventName
Name of the MULTISCOPE event type respective empty.
Boolean | aIgnoreRefs
true = Ignore the reference counting

Private Member Functions

GeViAct_StopMscEventEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp a MULTISCOPE event'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs::GeViAct_StopMscEventEventArgs ( ) [private]
GeViAct_StopMscEventEventArgs::GeViAct_StopMscEventEventArgs ( GeViAct_StopMscEvent^ initAction )

Create the EventArgs for handler of action 'Stopp a MULTISCOPE event'.

Parameters:
initAction Managed action 'Stopp a MULTISCOPE event'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs::aIgnoreRefs

true = Ignore the reference counting

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs::aMscEventName

Name of the MULTISCOPE event type respective empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs::aMscEventRef

GeVi-internal ID (Reference) of the MULTISCOPE event type; It will only be needed, if the MscEventName is empty.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs::aMscServerID

GeVi-internal ID of MULTISCOPE server; It will only be needed, if the MSCServerName is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs::aMscServerName

Name (host name) of the MULTISCOPE server respective empty.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer Class Reference

  • SystemActions
  • GeViAct_StopTimer
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer Class Reference
Actions

Action 'Stopp the timer'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer:
[legend]

List of all members.

Public Member Functions

GeViAct_StopTimer (Int32 initTimerID, String^ initTimerName)
Create the action 'Stopp the timer'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_StopTimer^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int32 | aTimerID
ID of the timer, it is only needed, if the name is empty.
String^ | aTimerName
Name of the timer.

Detailed Description

Action 'Stopp the timer'.

Constructor & Destructor Documentation

GeViAct_StopTimer::GeViAct_StopTimer | ( | Int32 | initTimerID,
 |  | String^ | initTimerName
 | ) |  |

Create the action 'Stopp the timer'.

Parameters:
initTimerID | ID of the timer, it is only needed, if the name is empty
initTimerName | Name of the timer

Member Function Documentation

GeViAct_StopTimer GeViAct_StopTimer::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_StopTimer::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer::aTimerID

ID of the timer, it is only needed, if the name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer::aTimerName

Name of the timer.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_StopTimerEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_StopTimerEventArgs (GeViAct_StopTimer^ initAction)
Create the EventArgs for handler of action 'Stopp the timer'.

Properties

Int32 | aTimerID
ID of the timer, it is only needed, if the name is empty.
String^ | aTimerName
Name of the timer.

Private Member Functions

GeViAct_StopTimerEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp the timer'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs::GeViAct_StopTimerEventArgs ( ) [private]
GeViAct_StopTimerEventArgs::GeViAct_StopTimerEventArgs ( GeViAct_StopTimer^ initAction )

Create the EventArgs for handler of action 'Stopp the timer'.

Parameters:
initAction Managed action 'Stopp the timer'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs::aTimerID

ID of the timer, it is only needed, if the name is empty.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs::aTimerName

Name of the timer.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest Class Reference

  • SystemActions
  • GeViAct_SyncTimeRequest
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest Class Reference
Actions

Action 'Request to all users to perform a time synchronization'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest:
[legend]

List of all members.

Public Member Functions

GeViAct_SyncTimeRequest (Boolean initInformDevices)
Create the action 'Request to all users to perform a time synchronization'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SyncTimeRequest^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Boolean | aInformDevices
true = Synchronize connected devices, false = do not synchronize

Detailed Description

Action 'Request to all users to perform a time synchronization'.

Constructor & Destructor Documentation

GeViAct_SyncTimeRequest::GeViAct_SyncTimeRequest ( Boolean initInformDevices )

Create the action 'Request to all users to perform a time synchronization'.

Parameters:
initInformDevices true = Synchronize connected devices, false = do not synchronize

Member Function Documentation

GeViAct_SyncTimeRequest GeViAct_SyncTimeRequest::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SyncTimeRequest::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SyncTimeRequestEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SyncTimeRequestEventArgs (GeViAct_SyncTimeRequest^ initAction)
Create the EventArgs for handler of action 'Request to all users to perform a time synchronization'.

Properties

Boolean aInformDevices
true = Synchronize connected devices, false = do not synchronize

Private Member Functions

GeViAct_SyncTimeRequestEventArgs ()

Detailed Description

EventArgs for handler of action 'Request to all users to perform a time synchronization'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs::GeViAct_SyncTimeRequestEventArgs ( ) [private]
GeViAct_SyncTimeRequestEventArgs::GeViAct_SyncTimeRequestEventArgs ( GeViAct_SyncTimeRequest^ initAction )

Create the EventArgs for handler of action 'Request to all users to perform a time synchronization'.

Parameters:
initAction Managed action 'Request to all users to perform a time synchronization'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient Class Reference

  • SystemActions
  • GeViAct_SyncTimeRequestToClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient Class Reference
Actions

Action 'Request to a user to perform a time synchronization'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient:
[legend]

List of all members.

Public Member Functions

GeViAct_SyncTimeRequestToClient (GeViClientID initClientID, String^ initClientName, Boolean initInformDevices)
Create the action 'Request to a user to perform a time synchronization'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_SyncTimeRequestToClient^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of the recipient of the message; only used in the case of an empty Clientname.
String^ | aClientName
Name of the recipient of the message respective empty.
Boolean | aInformDevices
true = Synchronize connected devices, false = do not synchronize

Detailed Description

Action 'Request to a user to perform a time synchronization'.

Constructor & Destructor Documentation

GeViAct_SyncTimeRequestToClient::GeViAct_SyncTimeRequestToClient | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | Boolean | initInformDevices
 | ) |  |

Create the action 'Request to a user to perform a time synchronization'.

Parameters:
initClientID | ID of the recipient of the message; only used in the case of an empty Clientname
initClientName | Name of the recipient of the message respective empty
initInformDevices | true = Synchronize connected devices, false = do not synchronize

Member Function Documentation

GeViAct_SyncTimeRequestToClient GeViAct_SyncTimeRequestToClient::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SyncTimeRequestToClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient::aClientID

ID of the recipient of the message; only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient::aClientName

Name of the recipient of the message respective empty.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SyncTimeRequestToClientEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SyncTimeRequestToClientEventArgs (GeViAct_SyncTimeRequestToClient^ initAction)
Create the EventArgs for handler of action 'Request to a user to perform a time synchronization'.

Properties

GeViClientID | aClientID
ID of the recipient of the message; only used in the case of an empty Clientname.
String^ | aClientName
Name of the recipient of the message respective empty.
Boolean | aInformDevices
true = Synchronize connected devices, false = do not synchronize

Private Member Functions

GeViAct_SyncTimeRequestToClientEventArgs ()

Detailed Description

EventArgs for handler of action 'Request to a user to perform a time synchronization'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs::GeViAct_SyncTimeRequestToClientEventArgs ( ) [private]
GeViAct_SyncTimeRequestToClientEventArgs::GeViAct_SyncTimeRequestToClientEventArgs ( GeViAct_SyncTimeRequestToClient^ initAction )

Create the EventArgs for handler of action 'Request to a user to perform a time synchronization'.

Parameters:
initAction Managed action 'Request to a user to perform a time synchronization'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs::aClientID

ID of the recipient of the message; only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs::aClientName

Name of the recipient of the message respective empty.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime Class Reference

  • SystemActions
  • GeViAct_SyncTimeSetTime
Public Member Functions | Static Public Member Functions | Public Attributes | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime Class Reference
Actions

Action 'Explizit setting of date and time'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime:
[legend]

List of all members.

Public Member Functions

GeViAct_SyncTimeSetTime (GeViTGeViDateTime initDateAndTime, Boolean initInformDevices)
Create the action 'Explizit setting of date and time'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SyncTimeSetTime^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Public Attributes

GeViTGeViDateTime aDateAndTime
Actual date and time.

Properties

Boolean | aInformDevices
true = Synchronize connected devices, false = do not synchronize

Detailed Description

Action 'Explizit setting of date and time'.

Constructor & Destructor Documentation

GeViAct_SyncTimeSetTime::GeViAct_SyncTimeSetTime | ( | GeViTGeViDateTime | initDateAndTime,
 |  | Boolean | initInformDevices
 | ) |  |

Create the action 'Explizit setting of date and time'.

Parameters:
initDateAndTime | Actual date and time
initInformDevices | true = Synchronize connected devices, false = do not synchronize

Member Function Documentation

GeViAct_SyncTimeSetTime GeViAct_SyncTimeSetTime::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SyncTimeSetTime::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Member Data Documentation

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime::aDateAndTime

Actual date and time.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual Class Reference

  • SystemActions
  • GeViAct_SyncTimeSetTimeActual
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual Class Reference
Actions

Action 'Explizit setting of date and time'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual:
[legend]

List of all members.

Public Member Functions

GeViAct_SyncTimeSetTimeActual (Boolean initInformDevices)
Create the action 'Explizit setting of date and time'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_SyncTimeSetTimeActual^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Boolean | aInformDevices
true = Synchronize connected devices, false = do not synchronize

Detailed Description

Action 'Explizit setting of date and time'.

Constructor & Destructor Documentation

GeViAct_SyncTimeSetTimeActual::GeViAct_SyncTimeSetTimeActual ( Boolean initInformDevices )

Create the action 'Explizit setting of date and time'.

Parameters:
initInformDevices true = Synchronize connected devices, false = do not synchronize

Member Function Documentation

GeViAct_SyncTimeSetTimeActual GeViAct_SyncTimeSetTimeActual::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SyncTimeSetTimeActual::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SyncTimeSetTimeActualEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SyncTimeSetTimeActualEventArgs (GeViAct_SyncTimeSetTimeActual^ initAction)
Create the EventArgs for handler of action 'Explizit setting of date and time'.

Properties

Boolean aInformDevices
true = Synchronize connected devices, false = do not synchronize

Private Member Functions

GeViAct_SyncTimeSetTimeActualEventArgs ()

Detailed Description

EventArgs for handler of action 'Explizit setting of date and time'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs::GeViAct_SyncTimeSetTimeActualEventArgs ( ) [private]
GeViAct_SyncTimeSetTimeActualEventArgs::GeViAct_SyncTimeSetTimeActualEventArgs ( GeViAct_SyncTimeSetTimeActual^ initAction )

Create the EventArgs for handler of action 'Explizit setting of date and time'.

Parameters:
initAction Managed action 'Explizit setting of date and time'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient Class Reference

  • SystemActions
  • GeViAct_SyncTimeSetTimeClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient Class Reference
Actions

Action 'Explizit setting of date and time'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient:
[legend]

List of all members.

Public Member Functions

GeViAct_SyncTimeSetTimeClient (GeViClientID initClientID, String^ initClientName, Boolean initInformDevices, GeViTGeViDateTime initDateAndTime)
Create the action 'Explizit setting of date and time'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_SyncTimeSetTimeClient^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of the recipient of the message; only used in the case of an empty Clientname.
String^ | aClientName
Name of the recipient of the message respective empty.
Boolean | aInformDevices
true = Synchronize connected devices (only interesting for GeViIO)
GeViTGeViDateTime aDateAndTime
Actual date and time.

Detailed Description

Action 'Explizit setting of date and time'.

Constructor & Destructor Documentation

GeViAct_SyncTimeSetTimeClient::GeViAct_SyncTimeSetTimeClient | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | Boolean | initInformDevices,
 |  | GeViTGeViDateTime | initDateAndTime
 | ) |  |

Create the action 'Explizit setting of date and time'.

Parameters:
initClientID | ID of the recipient of the message; only used in the case of an empty Clientname
initClientName | Name of the recipient of the message respective empty
initInformDevices | true = Synchronize connected devices (only interesting for GeViIO)
initDateAndTime | Actual date and time

Member Function Documentation

GeViAct_SyncTimeSetTimeClient GeViAct_SyncTimeSetTimeClient::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SyncTimeSetTimeClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient::aClientID

ID of the recipient of the message; only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient::aClientName

Name of the recipient of the message respective empty.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient::aDateAndTime

Actual date and time.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient::aInformDevices

true = Synchronize connected devices (only interesting for GeViIO)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SyncTimeSetTimeClientEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SyncTimeSetTimeClientEventArgs (GeViAct_SyncTimeSetTimeClient^ initAction)
Create the EventArgs for handler of action 'Explizit setting of date and time'.

Properties

GeViClientID | aClientID
ID of the recipient of the message; only used in the case of an empty Clientname.
String^ | aClientName
Name of the recipient of the message respective empty.
Boolean | aInformDevices
true = Synchronize connected devices (only interesting for GeViIO)
GeViTGeViDateTime aDateAndTime
Actual date and time.

Private Member Functions

GeViAct_SyncTimeSetTimeClientEventArgs ()

Detailed Description

EventArgs for handler of action 'Explizit setting of date and time'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs::GeViAct_SyncTimeSetTimeClientEventArgs ( ) [private]
GeViAct_SyncTimeSetTimeClientEventArgs::GeViAct_SyncTimeSetTimeClientEventArgs ( GeViAct_SyncTimeSetTimeClient^ initAction )

Create the EventArgs for handler of action 'Explizit setting of date and time'.

Parameters:
initAction Managed action 'Explizit setting of date and time'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs::aClientID

ID of the recipient of the message; only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs::aClientName

Name of the recipient of the message respective empty.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs::aDateAndTime

Actual date and time.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs::aInformDevices

true = Synchronize connected devices (only interesting for GeViIO)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SyncTimeSetTimeEventArgs
Public Member Functions | Public Attributes | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs Class Reference
Event Handlers and Event Arguments
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs:
[legend]

List of all members.

Public Member Functions

GeViAct_SyncTimeSetTimeEventArgs (GeViAct_SyncTimeSetTime^ initAction)
Create the EventArgs for handler of action 'Explizit setting of date and time'.

Public Attributes

GeViTGeViDateTime aDateAndTime
Actual date and time.

Properties

Boolean aInformDevices
true = Synchronize connected devices, false = do not synchronize

Private Member Functions

GeViAct_SyncTimeSetTimeEventArgs ()

Detailed Description

EventArgs for handler of action 'Explizit setting of date and time'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs::GeViAct_SyncTimeSetTimeEventArgs ( ) [private]
GeViAct_SyncTimeSetTimeEventArgs::GeViAct_SyncTimeSetTimeEventArgs ( GeViAct_SyncTimeSetTime^ initAction )

Create the EventArgs for handler of action 'Explizit setting of date and time'.

Parameters:
initAction Managed action 'Explizit setting of date and time'.

Member Data Documentation

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs::aDateAndTime

Actual date and time.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs::aInformDevices

true = Synchronize connected devices, false = do not synchronize

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError Class Reference

  • SystemActions
  • GeViAct_SystemError
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError Class Reference
Actions

Action 'System error'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError:
[legend]

List of all members.

Public Member Functions

GeViAct_SystemError (GeViClientID initClientID, Int32 initErrorCode, Int32 initErrorSubCode, String^ initErrorText)
Create the action 'System error'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SystemError^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic adaption, what has triggered the error.
Int32 | aErrorCode
Error code.
Int32 | aErrorSubCode
Error subcode.
String^ | aErrorText
Error description.

Detailed Description

Action 'System error'.

Constructor & Destructor Documentation

GeViAct_SystemError::GeViAct_SystemError | ( | GeViClientID | initClientID,
 |  | Int32 | initErrorCode,
 |  | Int32 | initErrorSubCode,
 |  | String^ | initErrorText
 | ) |  |

Create the action 'System error'.

Parameters:
initClientID | Automatic adaption, what has triggered the error
initErrorCode | Error code
initErrorSubCode | Error subcode
initErrorText | Error description

Member Function Documentation

GeViAct_SystemError GeViAct_SystemError::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SystemError::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError::aClientID

Automatic adaption, what has triggered the error.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError::aErrorCode

Error code.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError::aErrorSubCode

Error subcode.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError::aErrorText

Error description.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SystemErrorEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SystemErrorEventArgs (GeViAct_SystemError^ initAction)
Create the EventArgs for handler of action 'System error'.

Properties

GeViClientID | aClientID
Automatic adaption, what has triggered the error.
Int32 | aErrorCode
Error code.
Int32 | aErrorSubCode
Error subcode.
String^ | aErrorText
Error description.

Private Member Functions

GeViAct_SystemErrorEventArgs ()

Detailed Description

EventArgs for handler of action 'System error'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs::GeViAct_SystemErrorEventArgs ( ) [private]
GeViAct_SystemErrorEventArgs::GeViAct_SystemErrorEventArgs ( GeViAct_SystemError^ initAction )

Create the EventArgs for handler of action 'System error'.

Parameters:
initAction Managed action 'System error'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs::aClientID

Automatic adaption, what has triggered the error.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs::aErrorCode

Error code.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs::aErrorSubCode

Error subcode.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs::aErrorText

Error description.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged Class Reference

  • SystemActions
  • GeViAct_SystemSettingsChanged
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged Class Reference
Actions

Action 'System settings changed.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged:
[legend]

List of all members.

Public Member Functions

GeViAct_SystemSettingsChanged (String^ initUser1, String^ initUser2, String^ initHost)
Create the action 'System settings changed.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_SystemSettingsChanged^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if he do not exist.
String^ | aHost
Host name or address.

Detailed Description

Action 'System settings changed.'.

Constructor & Destructor Documentation

GeViAct_SystemSettingsChanged::GeViAct_SystemSettingsChanged | ( | String^ | initUser1,
 |  | String^ | initUser2,
 |  | String^ | initHost
 | ) |  |

Create the action 'System settings changed.'.

Parameters:
initUser1 | Name of the first user
initUser2 | Name of the second user or empty, if he do not exist.
initHost | Host name or address

Member Function Documentation

GeViAct_SystemSettingsChanged GeViAct_SystemSettingsChanged::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SystemSettingsChanged::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged::aHost

Host name or address.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged::aUser2

Name of the second user or empty, if he do not exist.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SystemSettingsChangedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SystemSettingsChangedEventArgs (GeViAct_SystemSettingsChanged^ initAction)
Create the EventArgs for handler of action 'System settings changed.'.

Properties

String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if he do not exist.
String^ | aHost
Host name or address.

Private Member Functions

GeViAct_SystemSettingsChangedEventArgs ()

Detailed Description

EventArgs for handler of action 'System settings changed.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs::GeViAct_SystemSettingsChangedEventArgs ( ) [private]
GeViAct_SystemSettingsChangedEventArgs::GeViAct_SystemSettingsChangedEventArgs ( GeViAct_SystemSettingsChanged^ initAction )

Create the EventArgs for handler of action 'System settings changed.'.

Parameters:
initAction Managed action 'System settings changed.'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs::aHost

Host name or address.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs::aUser2

Name of the second user or empty, if he do not exist.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted Class Reference

  • SystemActions
  • GeViAct_SystemStarted
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted Class Reference
Actions

Action 'The system is starting.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted:
[legend]

List of all members.

Public Member Functions

GeViAct_SystemStarted ()
Create the action 'The system is starting.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SystemStarted^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Detailed Description

Action 'The system is starting.'.

Constructor & Destructor Documentation

GeViAct_SystemStarted::GeViAct_SystemStarted ( )

Create the action 'The system is starting.'.

Member Function Documentation

GeViAct_SystemStarted GeViAct_SystemStarted::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SystemStarted::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SystemStartedEventArgs
Public Member Functions | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SystemStartedEventArgs (GeViAct_SystemStarted^ initAction)
Create the EventArgs for handler of action 'The system is starting.'.

Private Member Functions

GeViAct_SystemStartedEventArgs ()

Detailed Description

EventArgs for handler of action 'The system is starting.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs::GeViAct_SystemStartedEventArgs ( ) [private]
GeViAct_SystemStartedEventArgs::GeViAct_SystemStartedEventArgs ( GeViAct_SystemStarted^ initAction )

Create the EventArgs for handler of action 'The system is starting.'.

Parameters:
initAction Managed action 'The system is starting.'.
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped Class Reference

  • SystemActions
  • GeViAct_SystemStopped
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped Class Reference
Actions

Action 'The system is stopping.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped:
[legend]

List of all members.

Public Member Functions

GeViAct_SystemStopped ()
Create the action 'The system is stopping.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SystemStopped^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Detailed Description

Action 'The system is stopping.'.

Constructor & Destructor Documentation

GeViAct_SystemStopped::GeViAct_SystemStopped ( )

Create the action 'The system is stopping.'.

Member Function Documentation

GeViAct_SystemStopped GeViAct_SystemStopped::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SystemStopped::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SystemStoppedEventArgs
Public Member Functions | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SystemStoppedEventArgs (GeViAct_SystemStopped^ initAction)
Create the EventArgs for handler of action 'The system is stopping.'.

Private Member Functions

GeViAct_SystemStoppedEventArgs ()

Detailed Description

EventArgs for handler of action 'The system is stopping.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs::GeViAct_SystemStoppedEventArgs ( ) [private]
GeViAct_SystemStoppedEventArgs::GeViAct_SystemStoppedEventArgs ( GeViAct_SystemStopped^ initAction )

Create the EventArgs for handler of action 'The system is stopping.'.

Parameters:
initAction Managed action 'The system is stopping.'.
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning Class Reference

  • SystemActions
  • GeViAct_SystemWarning
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning Class Reference
Actions

Action 'System warning'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning:
[legend]

List of all members.

Public Member Functions

GeViAct_SystemWarning (GeViClientID initClientID, Int32 initWarningCode, Int32 initWarningSubCode, String^ initWarningText)
Create the action 'System warning'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_SystemWarning^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
Automatic adaption, what has triggered the warning.
Int32 | aWarningCode
Warning code.
Int32 | aWarningSubCode
Warning subcode.
String^ | aWarningText
Warning description.

Detailed Description

Action 'System warning'.

Constructor & Destructor Documentation

GeViAct_SystemWarning::GeViAct_SystemWarning | ( | GeViClientID | initClientID,
 |  | Int32 | initWarningCode,
 |  | Int32 | initWarningSubCode,
 |  | String^ | initWarningText
 | ) |  |

Create the action 'System warning'.

Parameters:
initClientID | Automatic adaption, what has triggered the warning
initWarningCode | Warning code
initWarningSubCode | Warning subcode
initWarningText | Warning description

Member Function Documentation

GeViAct_SystemWarning GeViAct_SystemWarning::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_SystemWarning::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning::aClientID

Automatic adaption, what has triggered the warning.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning::aWarningCode

Warning code.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning::aWarningSubCode

Warning subcode.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning::aWarningText

Warning description.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_SystemWarningEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_SystemWarningEventArgs (GeViAct_SystemWarning^ initAction)
Create the EventArgs for handler of action 'System warning'.

Properties

GeViClientID | aClientID
Automatic adaption, what has triggered the warning.
Int32 | aWarningCode
Warning code.
Int32 | aWarningSubCode
Warning subcode.
String^ | aWarningText
Warning description.

Private Member Functions

GeViAct_SystemWarningEventArgs ()

Detailed Description

EventArgs for handler of action 'System warning'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs::GeViAct_SystemWarningEventArgs ( ) [private]
GeViAct_SystemWarningEventArgs::GeViAct_SystemWarningEventArgs ( GeViAct_SystemWarning^ initAction )

Create the EventArgs for handler of action 'System warning'.

Parameters:
initAction Managed action 'System warning'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs::aClientID

Automatic adaption, what has triggered the warning.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs::aWarningCode

Warning code.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs::aWarningSubCode

Warning subcode.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs::aWarningText

Warning description.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl Class Reference

  • CameraControlActions
  • GeViAct_TakeCameraControl
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl Class Reference
Actions

Action 'Take over camera control'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl:
[legend]

List of all members.

Public Member Functions

GeViAct_TakeCameraControl (GeViVideoInputID initVideoInput, Int32 initPeriod, GeViClientID initUserID)
Create the action 'Take over camera control'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_TakeCameraControl^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.
Int32 | aPeriod
Period for takeover of the control in seconds (!!!)
GeViClientID | aUserID
Automatic adaption of the user ID, which has caused the move.

Detailed Description

Action 'Take over camera control'.

Constructor & Destructor Documentation

GeViAct_TakeCameraControl::GeViAct_TakeCameraControl | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initPeriod,
 |  | GeViClientID | initUserID
 | ) |  |

Create the action 'Take over camera control'.

Parameters:
initVideoInput | ID of the camera
initPeriod | Period for takeover of the control in seconds (!!!)
initUserID | Automatic adaption of the user ID, which has caused the move

Member Function Documentation

GeViAct_TakeCameraControl GeViAct_TakeCameraControl::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_TakeCameraControl::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl::aPeriod

Period for takeover of the control in seconds (!!!)

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl::aUserID

Automatic adaption of the user ID, which has caused the move.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_TakeCameraControlEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_TakeCameraControlEventArgs (GeViAct_TakeCameraControl^ initAction)
Create the EventArgs for handler of action 'Take over camera control'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera.
Int32 | aPeriod
Period for takeover of the control in seconds (!!!)
GeViClientID | aUserID
Automatic adaption of the user ID, which has caused the move.

Private Member Functions

GeViAct_TakeCameraControlEventArgs ()

Detailed Description

EventArgs for handler of action 'Take over camera control'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs::GeViAct_TakeCameraControlEventArgs ( ) [private]
GeViAct_TakeCameraControlEventArgs::GeViAct_TakeCameraControlEventArgs ( GeViAct_TakeCameraControl^ initAction )

Create the EventArgs for handler of action 'Take over camera control'.

Parameters:
initAction Managed action 'Take over camera control'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs::aPeriod

Period for takeover of the control in seconds (!!!)

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs::aUserID

Automatic adaption of the user ID, which has caused the move.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs::aVideoInput

ID of the camera.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown Class Reference

  • CameraControlActions
  • GeViAct_TiltDown
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown Class Reference
Actions

Action 'Incline the camera down'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown:
[legend]

List of all members.

Public Member Functions

GeViAct_TiltDown (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Incline the camera down'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_TiltDown^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall incline down.
Int32 | aTemp
Speed of inclining (0 = standard)

Detailed Description

Action 'Incline the camera down'.

Constructor & Destructor Documentation

GeViAct_TiltDown::GeViAct_TiltDown | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Incline the camera down'.

Parameters:
initVideoInput | ID of the camera, which shall incline down
initTemp | Speed of inclining (0 = standard)

Member Function Documentation

GeViAct_TiltDown GeViAct_TiltDown::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_TiltDown::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown::aTemp

Speed of inclining (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown::aVideoInput

ID of the camera, which shall incline down.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_TiltDownEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_TiltDownEventArgs (GeViAct_TiltDown^ initAction)
Create the EventArgs for handler of action 'Incline the camera down'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall incline down.
Int32 | aTemp
Speed of inclining (0 = standard)

Private Member Functions

GeViAct_TiltDownEventArgs ()

Detailed Description

EventArgs for handler of action 'Incline the camera down'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs::GeViAct_TiltDownEventArgs ( ) [private]
GeViAct_TiltDownEventArgs::GeViAct_TiltDownEventArgs ( GeViAct_TiltDown^ initAction )

Create the EventArgs for handler of action 'Incline the camera down'.

Parameters:
initAction Managed action 'Incline the camera down'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs::aTemp

Speed of inclining (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs::aVideoInput

ID of the camera, which shall incline down.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop Class Reference

  • CameraControlActions
  • GeViAct_TiltStop
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop Class Reference
Actions

Action 'Stopp the inclinig of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop:
[legend]

List of all members.

Public Member Functions

GeViAct_TiltStop (GeViVideoInputID initVideoInput)
Create the action 'Stopp the inclinig of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_TiltStop^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which inclining shall be stopped.

Detailed Description

Action 'Stopp the inclinig of the camera'.

Constructor & Destructor Documentation

GeViAct_TiltStop::GeViAct_TiltStop ( GeViVideoInputID initVideoInput )

Create the action 'Stopp the inclinig of the camera'.

Parameters:
initVideoInput ID of the camera, which inclining shall be stopped

Member Function Documentation

GeViAct_TiltStop GeViAct_TiltStop::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_TiltStop::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop::aVideoInput

ID of the camera, which inclining shall be stopped.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_TiltStopEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_TiltStopEventArgs (GeViAct_TiltStop^ initAction)
Create the EventArgs for handler of action 'Stopp the inclinig of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of the camera, which inclining shall be stopped.

Private Member Functions

GeViAct_TiltStopEventArgs ()

Detailed Description

EventArgs for handler of action 'Stopp the inclinig of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs::GeViAct_TiltStopEventArgs ( ) [private]
GeViAct_TiltStopEventArgs::GeViAct_TiltStopEventArgs ( GeViAct_TiltStop^ initAction )

Create the EventArgs for handler of action 'Stopp the inclinig of the camera'.

Parameters:
initAction Managed action 'Stopp the inclinig of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs::aVideoInput

ID of the camera, which inclining shall be stopped.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp Class Reference

  • CameraControlActions
  • GeViAct_TiltUp
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp Class Reference
Actions

Action 'Incline camera up'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp:
[legend]

List of all members.

Public Member Functions

GeViAct_TiltUp (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Incline camera up'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_TiltUp^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall inclined up.
Int32 | aTemp
Speed of inclining (0 = standard)

Detailed Description

Action 'Incline camera up'.

Constructor & Destructor Documentation

GeViAct_TiltUp::GeViAct_TiltUp | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Incline camera up'.

Parameters:
initVideoInput | ID of the camera, which shall inclined up.
initTemp | Speed of inclining (0 = standard)

Member Function Documentation

GeViAct_TiltUp GeViAct_TiltUp::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_TiltUp::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp::aTemp

Speed of inclining (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp::aVideoInput

ID of the camera, which shall inclined up.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_TiltUpEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_TiltUpEventArgs (GeViAct_TiltUp^ initAction)
Create the EventArgs for handler of action 'Incline camera up'.

Properties

GeViVideoInputID | aVideoInput
ID of the camera, which shall inclined up.
Int32 | aTemp
Speed of inclining (0 = standard)

Private Member Functions

GeViAct_TiltUpEventArgs ()

Detailed Description

EventArgs for handler of action 'Incline camera up'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs::GeViAct_TiltUpEventArgs ( ) [private]
GeViAct_TiltUpEventArgs::GeViAct_TiltUpEventArgs ( GeViAct_TiltUp^ initAction )

Create the EventArgs for handler of action 'Incline camera up'.

Parameters:
initAction Managed action 'Incline camera up'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs::aTemp

Speed of inclining (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs::aVideoInput

ID of the camera, which shall inclined up.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded Class Reference

  • TimeRangesActions
  • GeViAct_TimeRangeEnded
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded Class Reference
Actions

Action 'Cancel time range'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded:
[legend]

List of all members.

Public Member Functions

GeViAct_TimeRangeEnded (Int64 initID, String^ initTimeRangeName)
Create the action 'Cancel time range'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_TimeRangeEnded^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int64 | aID
ID of the time range, only used in the case of an empty TimeRangeName.
String^ | aTimeRangeName
Name of the time range or empty.

Detailed Description

Action 'Cancel time range'.

Constructor & Destructor Documentation

GeViAct_TimeRangeEnded::GeViAct_TimeRangeEnded | ( | Int64 | initID,
 |  | String^ | initTimeRangeName
 | ) |  |

Create the action 'Cancel time range'.

Parameters:
initID | ID of the time range, only used in the case of an empty TimeRangeName
initTimeRangeName | Name of the time range or empty

Member Function Documentation

GeViAct_TimeRangeEnded GeViAct_TimeRangeEnded::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_TimeRangeEnded::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded::aID

ID of the time range, only used in the case of an empty TimeRangeName.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded::aTimeRangeName

Name of the time range or empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_TimeRangeEndedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_TimeRangeEndedEventArgs (GeViAct_TimeRangeEnded^ initAction)
Create the EventArgs for handler of action 'Cancel time range'.

Properties

Int64 | aID
ID of the time range, only used in the case of an empty TimeRangeName.
String^ | aTimeRangeName
Name of the time range or empty.

Private Member Functions

GeViAct_TimeRangeEndedEventArgs ()

Detailed Description

EventArgs for handler of action 'Cancel time range'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs::GeViAct_TimeRangeEndedEventArgs ( ) [private]
GeViAct_TimeRangeEndedEventArgs::GeViAct_TimeRangeEndedEventArgs ( GeViAct_TimeRangeEnded^ initAction )

Create the EventArgs for handler of action 'Cancel time range'.

Parameters:
initAction Managed action 'Cancel time range'.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs::aID

ID of the time range, only used in the case of an empty TimeRangeName.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs::aTimeRangeName

Name of the time range or empty.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted Class Reference

  • TimeRangesActions
  • GeViAct_TimeRangeStarted
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted Class Reference
Actions

Action 'Start of the time range'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted:
[legend]

List of all members.

Public Member Functions

GeViAct_TimeRangeStarted (Int64 initID, String^ initTimeRangeName)
Create the action 'Start of the time range'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_TimeRangeStarted^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

Int64 | aID
ID of the time range, only used in the case of an empty TimeRangeName.
String^ | aTimeRangeName
Name of the time range or empty.

Detailed Description

Action 'Start of the time range'.

Constructor & Destructor Documentation

GeViAct_TimeRangeStarted::GeViAct_TimeRangeStarted | ( | Int64 | initID,
 |  | String^ | initTimeRangeName
 | ) |  |

Create the action 'Start of the time range'.

Parameters:
initID | ID of the time range, only used in the case of an empty TimeRangeName
initTimeRangeName | Name of the time range or empty

Member Function Documentation

GeViAct_TimeRangeStarted GeViAct_TimeRangeStarted::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_TimeRangeStarted::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted::aID

ID of the time range, only used in the case of an empty TimeRangeName.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted::aTimeRangeName

Name of the time range or empty.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_TimeRangeStartedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_TimeRangeStartedEventArgs (GeViAct_TimeRangeStarted^ initAction)
Create the EventArgs for handler of action 'Start of the time range'.

Properties

Int64 | aID
ID of the time range, only used in the case of an empty TimeRangeName.
String^ | aTimeRangeName
Name of the time range or empty.

Private Member Functions

GeViAct_TimeRangeStartedEventArgs ()

Detailed Description

EventArgs for handler of action 'Start of the time range'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs::GeViAct_TimeRangeStartedEventArgs ( ) [private]
GeViAct_TimeRangeStartedEventArgs::GeViAct_TimeRangeStartedEventArgs ( GeViAct_TimeRangeStarted^ initAction )

Create the EventArgs for handler of action 'Start of the time range'.

Parameters:
initAction Managed action 'Start of the time range'.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs::aID

ID of the time range, only used in the case of an empty TimeRangeName.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs::aTimeRangeName

Name of the time range or empty.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin Class Reference

  • SystemActions
  • GeViAct_UserLogin
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin Class Reference
Actions

Action 'User has logged in.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin:
[legend]

List of all members.

Public Member Functions

GeViAct_UserLogin (GeViTGeViPort initPort, String^ initUser1, String^ initUser2, String^ initHost)
Create the action 'User has logged in.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_UserLogin^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViTGeViPort | aPort
Port, where the login was realized.
String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if not he do not exist.
String^ | aHost
Hostname or address.

Detailed Description

Action 'User has logged in.'.

Constructor & Destructor Documentation

GeViAct_UserLogin::GeViAct_UserLogin | ( | GeViTGeViPort | initPort,
 |  | String^ | initUser1,
 |  | String^ | initUser2,
 |  | String^ | initHost
 | ) |  |

Create the action 'User has logged in.'.

Parameters:
initPort | Port, where the login was realized
initUser1 | Name of the first user
initUser2 | Name of the second user or empty, if not he do not exist.
initHost | Hostname or address

Member Function Documentation

GeViAct_UserLogin GeViAct_UserLogin::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_UserLogin::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin::aHost

Hostname or address.

GeViTGeViPort GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin::aPort

Port, where the login was realized.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin::aUser2

Name of the second user or empty, if not he do not exist.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_UserLoginEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_UserLoginEventArgs (GeViAct_UserLogin^ initAction)
Create the EventArgs for handler of action 'User has logged in.'.

Properties

GeViTGeViPort | aPort
Port, where the login was realized.
String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if not he do not exist.
String^ | aHost
Hostname or address.

Private Member Functions

GeViAct_UserLoginEventArgs ()

Detailed Description

EventArgs for handler of action 'User has logged in.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs::GeViAct_UserLoginEventArgs ( ) [private]
GeViAct_UserLoginEventArgs::GeViAct_UserLoginEventArgs ( GeViAct_UserLogin^ initAction )

Create the EventArgs for handler of action 'User has logged in.'.

Parameters:
initAction Managed action 'User has logged in.'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs::aHost

Hostname or address.

GeViTGeViPort GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs::aPort

Port, where the login was realized.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs::aUser2

Name of the second user or empty, if not he do not exist.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed Class Reference

  • SystemActions
  • GeViAct_UserLoginFailed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed Class Reference
Actions

Action 'Login failed.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed:
[legend]

List of all members.

Public Member Functions

GeViAct_UserLoginFailed (GeViTGeViPort initPort, String^ initUser1, String^ initUser2, String^ initHost, GeViTLoginFailure initReason)
Create the action 'Login failed.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_UserLoginFailed^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViTGeViPort | aPort
Port, where the login was tried.
String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if he do not exist.
String^ | aHost
Hostname or addresse.
GeViTLoginFailure | aReason
Reason of the fail.

Detailed Description

Action 'Login failed.'.

Constructor & Destructor Documentation

GeViAct_UserLoginFailed::GeViAct_UserLoginFailed | ( | GeViTGeViPort | initPort,
 |  | String^ | initUser1,
 |  | String^ | initUser2,
 |  | String^ | initHost,
 |  | GeViTLoginFailure | initReason
 | ) |  |

Create the action 'Login failed.'.

Parameters:
initPort | Port, where the login was tried
initUser1 | Name of the first user
initUser2 | Name of the second user or empty, if he do not exist.
initHost | Hostname or addresse
initReason | Reason of the fail

Member Function Documentation

GeViAct_UserLoginFailed GeViAct_UserLoginFailed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_UserLoginFailed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed::aHost

Hostname or addresse.

GeViTGeViPort GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed::aPort

Port, where the login was tried.

GeViTLoginFailure GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed::aReason

Reason of the fail.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed::aUser2

Name of the second user or empty, if he do not exist.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_UserLoginFailedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_UserLoginFailedEventArgs (GeViAct_UserLoginFailed^ initAction)
Create the EventArgs for handler of action 'Login failed.'.

Properties

GeViTGeViPort | aPort
Port, where the login was tried.
String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if he do not exist.
String^ | aHost
Hostname or addresse.
GeViTLoginFailure | aReason
Reason of the fail.

Private Member Functions

GeViAct_UserLoginFailedEventArgs ()

Detailed Description

EventArgs for handler of action 'Login failed.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs::GeViAct_UserLoginFailedEventArgs ( ) [private]
GeViAct_UserLoginFailedEventArgs::GeViAct_UserLoginFailedEventArgs ( GeViAct_UserLoginFailed^ initAction )

Create the EventArgs for handler of action 'Login failed.'.

Parameters:
initAction Managed action 'Login failed.'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs::aHost

Hostname or addresse.

GeViTGeViPort GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs::aPort

Port, where the login was tried.

GeViTLoginFailure GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs::aReason

Reason of the fail.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs::aUser2

Name of the second user or empty, if he do not exist.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout Class Reference

  • SystemActions
  • GeViAct_UserLogout
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout Class Reference
Actions

Action 'User has logged out.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout:
[legend]

List of all members.

Public Member Functions

GeViAct_UserLogout (GeViTGeViPort initPort, String^ initUser1, String^ initUser2, String^ initHost)
Create the action 'User has logged out.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_UserLogout^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViTGeViPort | aPort
Port, where the logout was realized.
String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if not he do not exist.
String^ | aHost
Hostname or address.

Detailed Description

Action 'User has logged out.'.

Constructor & Destructor Documentation

GeViAct_UserLogout::GeViAct_UserLogout | ( | GeViTGeViPort | initPort,
 |  | String^ | initUser1,
 |  | String^ | initUser2,
 |  | String^ | initHost
 | ) |  |

Create the action 'User has logged out.'.

Parameters:
initPort | Port, where the logout was realized
initUser1 | Name of the first user
initUser2 | Name of the second user or empty, if not he do not exist.
initHost | Hostname or address

Member Function Documentation

GeViAct_UserLogout GeViAct_UserLogout::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_UserLogout::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout::aHost

Hostname or address.

GeViTGeViPort GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout::aPort

Port, where the logout was realized.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout::aUser2

Name of the second user or empty, if not he do not exist.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_UserLogoutEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_UserLogoutEventArgs (GeViAct_UserLogout^ initAction)
Create the EventArgs for handler of action 'User has logged out.'.

Properties

GeViTGeViPort | aPort
Port, where the logout was realized.
String^ | aUser1
Name of the first user.
String^ | aUser2
Name of the second user or empty, if not he do not exist.
String^ | aHost
Hostname or address.

Private Member Functions

GeViAct_UserLogoutEventArgs ()

Detailed Description

EventArgs for handler of action 'User has logged out.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs::GeViAct_UserLogoutEventArgs ( ) [private]
GeViAct_UserLogoutEventArgs::GeViAct_UserLogoutEventArgs ( GeViAct_UserLogout^ initAction )

Create the EventArgs for handler of action 'User has logged out.'.

Parameters:
initAction Managed action 'User has logged out.'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs::aHost

Hostname or address.

GeViTGeViPort GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs::aPort

Port, where the logout was realized.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs::aUser1

Name of the first user.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs::aUser2

Name of the second user or empty, if not he do not exist.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut Class Reference

  • SwitchControlActions
  • GeViAct_VideoClearTextOut
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut Class Reference
Actions

Action 'Clears the free text'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoClearTextOut (GeViVideoOutputID initVideoOutput)
Create the action 'Clears the free text'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VideoClearTextOut^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aVideoOutput
Video output for deleting that text.

Detailed Description

Action 'Clears the free text'.

Constructor & Destructor Documentation

GeViAct_VideoClearTextOut::GeViAct_VideoClearTextOut ( GeViVideoOutputID initVideoOutput )

Create the action 'Clears the free text'.

Parameters:
initVideoOutput Video output for deleting that text.

Member Function Documentation

GeViAct_VideoClearTextOut GeViAct_VideoClearTextOut::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoClearTextOut::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut::aVideoOutput

Video output for deleting that text.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoClearTextOutEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoClearTextOutEventArgs (GeViAct_VideoClearTextOut^ initAction)
Create the EventArgs for handler of action 'Clears the free text'.

Properties

GeViVideoOutputID aVideoOutput
Video output for deleting that text.

Private Member Functions

GeViAct_VideoClearTextOutEventArgs ()

Detailed Description

EventArgs for handler of action 'Clears the free text'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs::GeViAct_VideoClearTextOutEventArgs ( ) [private]
GeViAct_VideoClearTextOutEventArgs::GeViAct_VideoClearTextOutEventArgs ( GeViAct_VideoClearTextOut^ initAction )

Create the EventArgs for handler of action 'Clears the free text'.

Parameters:
initAction Managed action 'Clears the free text'.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs::aVideoOutput

Video output for deleting that text.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm Class Reference

  • SwitchControlActions
  • GeViAct_VideoContrastAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm Class Reference
Actions

Action 'The image is disturbed.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoContrastAlarm (GeViVideoInputID initVideoInput, Int32 initThreshold)
Create the action 'The image is disturbed.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VideoContrastAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input with the contrast failure.
Int32 | aThreshold
Contrast value.

Detailed Description

Action 'The image is disturbed.'.

Constructor & Destructor Documentation

GeViAct_VideoContrastAlarm::GeViAct_VideoContrastAlarm | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initThreshold
 | ) |  |

Create the action 'The image is disturbed.'.

Parameters:
initVideoInput | ID of video input with the contrast failure.
initThreshold | Contrast value

Member Function Documentation

GeViAct_VideoContrastAlarm GeViAct_VideoContrastAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoContrastAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm::aThreshold

Contrast value.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm::aVideoInput

ID of video input with the contrast failure.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoContrastAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoContrastAlarmEventArgs (GeViAct_VideoContrastAlarm^ initAction)
Create the EventArgs for handler of action 'The image is disturbed.'.

Properties

GeViVideoInputID | aVideoInput
ID of video input with the contrast failure.
Int32 | aThreshold
Contrast value.

Private Member Functions

GeViAct_VideoContrastAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'The image is disturbed.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs::GeViAct_VideoContrastAlarmEventArgs ( ) [private]
GeViAct_VideoContrastAlarmEventArgs::GeViAct_VideoContrastAlarmEventArgs ( GeViAct_VideoContrastAlarm^ initAction )

Create the EventArgs for handler of action 'The image is disturbed.'.

Parameters:
initAction Managed action 'The image is disturbed.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs::aThreshold

Contrast value.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs::aVideoInput

ID of video input with the contrast failure.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk Class Reference

  • SwitchControlActions
  • GeViAct_VideoContrastOk
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk Class Reference
Actions

Action 'The contrast is OK again.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoContrastOk (GeViVideoInputID initVideoInput)
Create the action 'The contrast is OK again.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VideoContrastOk^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input were the contrast is OK again.

Detailed Description

Action 'The contrast is OK again.'.

Constructor & Destructor Documentation

GeViAct_VideoContrastOk::GeViAct_VideoContrastOk ( GeViVideoInputID initVideoInput )

Create the action 'The contrast is OK again.'.

Parameters:
initVideoInput ID of video input were the contrast is OK again.

Member Function Documentation

GeViAct_VideoContrastOk GeViAct_VideoContrastOk::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoContrastOk::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk::aVideoInput

ID of video input were the contrast is OK again.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoContrastOkEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoContrastOkEventArgs (GeViAct_VideoContrastOk^ initAction)
Create the EventArgs for handler of action 'The contrast is OK again.'.

Properties

GeViVideoInputID aVideoInput
ID of video input were the contrast is OK again.

Private Member Functions

GeViAct_VideoContrastOkEventArgs ()

Detailed Description

EventArgs for handler of action 'The contrast is OK again.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs::GeViAct_VideoContrastOkEventArgs ( ) [private]
GeViAct_VideoContrastOkEventArgs::GeViAct_VideoContrastOkEventArgs ( GeViAct_VideoContrastOk^ initAction )

Create the EventArgs for handler of action 'The contrast is OK again.'.

Parameters:
initAction Managed action 'The contrast is OK again.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs::aVideoInput

ID of video input were the contrast is OK again.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm Class Reference

  • SwitchControlActions
  • GeViAct_VideoContrastPreAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm Class Reference
Actions

Action 'The contrast is critical.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoContrastPreAlarm (GeViVideoInputID initVideoInput, Int32 initThreshold)
Create the action 'The contrast is critical.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_VideoContrastPreAlarm^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input with critical contrast.
Int32 | aThreshold
Contrast value.

Detailed Description

Action 'The contrast is critical.'.

Constructor & Destructor Documentation

GeViAct_VideoContrastPreAlarm::GeViAct_VideoContrastPreAlarm | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initThreshold
 | ) |  |

Create the action 'The contrast is critical.'.

Parameters:
initVideoInput | ID of video input with critical contrast.
initThreshold | Contrast value

Member Function Documentation

GeViAct_VideoContrastPreAlarm GeViAct_VideoContrastPreAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoContrastPreAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm::aThreshold

Contrast value.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm::aVideoInput

ID of video input with critical contrast.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoContrastPreAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoContrastPreAlarmEventArgs (GeViAct_VideoContrastPreAlarm^ initAction)
Create the EventArgs for handler of action 'The contrast is critical.'.

Properties

GeViVideoInputID | aVideoInput
ID of video input with critical contrast.
Int32 | aThreshold
Contrast value.

Private Member Functions

GeViAct_VideoContrastPreAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'The contrast is critical.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs::GeViAct_VideoContrastPreAlarmEventArgs ( ) [private]
GeViAct_VideoContrastPreAlarmEventArgs::GeViAct_VideoContrastPreAlarmEventArgs ( GeViAct_VideoContrastPreAlarm^ initAction )

Create the EventArgs for handler of action 'The contrast is critical.'.

Parameters:
initAction Managed action 'The contrast is critical.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs::aThreshold

Contrast value.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs::aVideoInput

ID of video input with critical contrast.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure Class Reference

  • SwitchControlActions
  • GeViAct_VideoSyncFailure
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure Class Reference
Actions

Action 'Sync-signal failure.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoSyncFailure (GeViVideoInputID initVideoInput)
Create the action 'Sync-signal failure.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VideoSyncFailure^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video output with appearence of that sync-failures.

Detailed Description

Action 'Sync-signal failure.'.

Constructor & Destructor Documentation

GeViAct_VideoSyncFailure::GeViAct_VideoSyncFailure ( GeViVideoInputID initVideoInput )

Create the action 'Sync-signal failure.'.

Parameters:
initVideoInput ID of video output with appearence of that sync-failures.

Member Function Documentation

GeViAct_VideoSyncFailure GeViAct_VideoSyncFailure::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoSyncFailure::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure::aVideoInput

ID of video output with appearence of that sync-failures.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoSyncFailureEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoSyncFailureEventArgs (GeViAct_VideoSyncFailure^ initAction)
Create the EventArgs for handler of action 'Sync-signal failure.'.

Properties

GeViVideoInputID aVideoInput
ID of video output with appearence of that sync-failures.

Private Member Functions

GeViAct_VideoSyncFailureEventArgs ()

Detailed Description

EventArgs for handler of action 'Sync-signal failure.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs::GeViAct_VideoSyncFailureEventArgs ( ) [private]
GeViAct_VideoSyncFailureEventArgs::GeViAct_VideoSyncFailureEventArgs ( GeViAct_VideoSyncFailure^ initAction )

Create the EventArgs for handler of action 'Sync-signal failure.'.

Parameters:
initAction Managed action 'Sync-signal failure.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs::aVideoInput

ID of video output with appearence of that sync-failures.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk Class Reference

  • SwitchControlActions
  • GeViAct_VideoSyncOk
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk Class Reference
Actions

Action 'Sync-signal works correct again.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoSyncOk (GeViVideoInputID initVideoInput)
Create the action 'Sync-signal works correct again.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VideoSyncOk^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input detecting that Sync-signal again .

Detailed Description

Action 'Sync-signal works correct again.'.

Constructor & Destructor Documentation

GeViAct_VideoSyncOk::GeViAct_VideoSyncOk ( GeViVideoInputID initVideoInput )

Create the action 'Sync-signal works correct again.'.

Parameters:
initVideoInput ID of video input detecting that Sync-signal again .

Member Function Documentation

GeViAct_VideoSyncOk GeViAct_VideoSyncOk::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoSyncOk::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk::aVideoInput

ID of video input detecting that Sync-signal again .

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoSyncOkEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoSyncOkEventArgs (GeViAct_VideoSyncOk^ initAction)
Create the EventArgs for handler of action 'Sync-signal works correct again.'.

Properties

GeViVideoInputID aVideoInput
ID of video input detecting that Sync-signal again .

Private Member Functions

GeViAct_VideoSyncOkEventArgs ()

Detailed Description

EventArgs for handler of action 'Sync-signal works correct again.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs::GeViAct_VideoSyncOkEventArgs ( ) [private]
GeViAct_VideoSyncOkEventArgs::GeViAct_VideoSyncOkEventArgs ( GeViAct_VideoSyncOk^ initAction )

Create the EventArgs for handler of action 'Sync-signal works correct again.'.

Parameters:
initAction Managed action 'Sync-signal works correct again.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs::aVideoInput

ID of video input detecting that Sync-signal again .

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut Class Reference

  • SwitchControlActions
  • GeViAct_VideoTextOut
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut Class Reference
Actions

Action 'Display free text on that video output.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoTextOut (GeViVideoOutputID initVideoOutput, String^ initText)
Create the action 'Display free text on that video output.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VideoTextOut^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoOutputID | aVideoOutput
Video output for displaying that text.
String^ | aText
Text to display.

Detailed Description

Action 'Display free text on that video output.'.

Constructor & Destructor Documentation

GeViAct_VideoTextOut::GeViAct_VideoTextOut | ( | GeViVideoOutputID | initVideoOutput,
 |  | String^ | initText
 | ) |  |

Create the action 'Display free text on that video output.'.

Parameters:
initVideoOutput | Video output for displaying that text.
initText | Text to display

Member Function Documentation

GeViAct_VideoTextOut GeViAct_VideoTextOut::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoTextOut::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut::aText

Text to display.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut::aVideoOutput

Video output for displaying that text.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoTextOutEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoTextOutEventArgs (GeViAct_VideoTextOut^ initAction)
Create the EventArgs for handler of action 'Display free text on that video output.'.

Properties

GeViVideoOutputID | aVideoOutput
Video output for displaying that text.
String^ | aText
Text to display.

Private Member Functions

GeViAct_VideoTextOutEventArgs ()

Detailed Description

EventArgs for handler of action 'Display free text on that video output.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs::GeViAct_VideoTextOutEventArgs ( ) [private]
GeViAct_VideoTextOutEventArgs::GeViAct_VideoTextOutEventArgs ( GeViAct_VideoTextOut^ initAction )

Create the EventArgs for handler of action 'Display free text on that video output.'.

Parameters:
initAction Managed action 'Display free text on that video output.'.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs::aText

Text to display.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs::aVideoOutput

Video output for displaying that text.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest Class Reference

  • CameraControlActions
  • GeViAct_VideoThresholdRequest
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest Class Reference
Actions

Action 'Internal action requests the threshold value of an input'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoThresholdRequest (GeViClientID initClient, Int32 initInternal1, Int64 initInternal2, Int32 initVideoInput)
Create the action 'Internal action requests the threshold value of an input'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_VideoThresholdRequest^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClient
Interface ID of the VSM.
Int32 | aInternal1
Internal parameter.
Int64 | aInternal2
Internal parameter.
Int32 | aVideoInput
Local video input on VSM.

Detailed Description

Action 'Internal action requests the threshold value of an input'.

Constructor & Destructor Documentation

GeViAct_VideoThresholdRequest::GeViAct_VideoThresholdRequest | ( | GeViClientID | initClient,
 |  | Int32 | initInternal1,
 |  | Int64 | initInternal2,
 |  | Int32 | initVideoInput
 | ) |  |

Create the action 'Internal action requests the threshold value of an input'.

Parameters:
initClient | Interface ID of the VSM
initInternal1 | Internal parameter
initInternal2 | Internal parameter
initVideoInput | Local video input on VSM

Member Function Documentation

GeViAct_VideoThresholdRequest GeViAct_VideoThresholdRequest::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoThresholdRequest::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest::aClient

Interface ID of the VSM.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest::aInternal1

Internal parameter.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest::aInternal2

Internal parameter.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest::aVideoInput

Local video input on VSM.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoThresholdRequestEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoThresholdRequestEventArgs (GeViAct_VideoThresholdRequest^ initAction)
Create the EventArgs for handler of action 'Internal action requests the threshold value of an input'.

Properties

GeViClientID | aClient
Interface ID of the VSM.
Int32 | aInternal1
Internal parameter.
Int64 | aInternal2
Internal parameter.
Int32 | aVideoInput
Local video input on VSM.

Private Member Functions

GeViAct_VideoThresholdRequestEventArgs ()

Detailed Description

EventArgs for handler of action 'Internal action requests the threshold value of an input'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs::GeViAct_VideoThresholdRequestEventArgs ( ) [private]
GeViAct_VideoThresholdRequestEventArgs::GeViAct_VideoThresholdRequestEventArgs ( GeViAct_VideoThresholdRequest^ initAction )

Create the EventArgs for handler of action 'Internal action requests the threshold value of an input'.

Parameters:
initAction Managed action 'Internal action requests the threshold value of an input'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs::aClient

Interface ID of the VSM.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs::aInternal1

Internal parameter.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs::aInternal2

Internal parameter.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs::aVideoInput

Local video input on VSM.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue Class Reference

  • CameraControlActions
  • GeViAct_VideoThresholdValue
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue Class Reference
Actions

Action 'Internal action, return of the threshold value of an input'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue:
[legend]

List of all members.

Public Member Functions

GeViAct_VideoThresholdValue (GeViClientID initClient, Int32 initInternal1, Int64 initInternal2, Int32 initThreshold, Int32 initMinThreshold, Int32 initAVGThreshold, Int32 initSecondsSinceStart, Int32 initNumberOfMeasures)
Create the action 'Internal action, return of the threshold value of an input'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VideoThresholdValue^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClient
Interface ID of the VSM.
Int32 | aInternal1
Internal parameter.
Int64 | aInternal2
Internal parameter.
Int32 | aThreshold
Current threshold value.
Int32 | aMinThreshold
Minimal threshold value.
Int32 | aAVGThreshold
Average threshold value.
Int32 | aSecondsSinceStart
Period of measurement in seconds.
Int32 | aNumberOfMeasures
Number of measures.

Detailed Description

Action 'Internal action, return of the threshold value of an input'.

Constructor & Destructor Documentation

GeViAct_VideoThresholdValue::GeViAct_VideoThresholdValue | ( | GeViClientID | initClient,
 |  | Int32 | initInternal1,
 |  | Int64 | initInternal2,
 |  | Int32 | initThreshold,
 |  | Int32 | initMinThreshold,
 |  | Int32 | initAVGThreshold,
 |  | Int32 | initSecondsSinceStart,
 |  | Int32 | initNumberOfMeasures
 | ) |  |

Create the action 'Internal action, return of the threshold value of an input'.

Parameters:
initClient | Interface ID of the VSM
initInternal1 | Internal parameter
initInternal2 | Internal parameter
initThreshold | Current threshold value
initMinThreshold | Minimal threshold value
initAVGThreshold | Average threshold value
initSecondsSinceStart | Period of measurement in seconds
initNumberOfMeasures | Number of measures

Member Function Documentation

GeViAct_VideoThresholdValue GeViAct_VideoThresholdValue::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VideoThresholdValue::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aAVGThreshold

Average threshold value.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aClient

Interface ID of the VSM.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aInternal1

Internal parameter.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aInternal2

Internal parameter.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aMinThreshold

Minimal threshold value.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aNumberOfMeasures

Number of measures.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aSecondsSinceStart

Period of measurement in seconds.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue::aThreshold

Current threshold value.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VideoThresholdValueEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VideoThresholdValueEventArgs (GeViAct_VideoThresholdValue^ initAction)
Create the EventArgs for handler of action 'Internal action, return of the threshold value of an input'.

Properties

GeViClientID | aClient
Interface ID of the VSM.
Int32 | aInternal1
Internal parameter.
Int64 | aInternal2
Internal parameter.
Int32 | aThreshold
Current threshold value.
Int32 | aMinThreshold
Minimal threshold value.
Int32 | aAVGThreshold
Average threshold value.
Int32 | aSecondsSinceStart
Period of measurement in seconds.
Int32 | aNumberOfMeasures
Number of measures.

Private Member Functions

GeViAct_VideoThresholdValueEventArgs ()

Detailed Description

EventArgs for handler of action 'Internal action, return of the threshold value of an input'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::GeViAct_VideoThresholdValueEventArgs ( ) [private]
GeViAct_VideoThresholdValueEventArgs::GeViAct_VideoThresholdValueEventArgs ( GeViAct_VideoThresholdValue^ initAction )

Create the EventArgs for handler of action 'Internal action, return of the threshold value of an input'.

Parameters:
initAction Managed action 'Internal action, return of the threshold value of an input'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aAVGThreshold

Average threshold value.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aClient

Interface ID of the VSM.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aInternal1

Internal parameter.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aInternal2

Internal parameter.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aMinThreshold

Minimal threshold value.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aNumberOfMeasures

Number of measures.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aSecondsSinceStart

Period of measurement in seconds.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs::aThreshold

Current threshold value.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode Class Reference

  • VideoSensorActions
  • GeViAct_VS30PMMode
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode Class Reference
Actions

Action 'Mode is 'Working' or 'Setup''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode:
[legend]

List of all members.

Public Member Functions

GeViAct_VS30PMMode (GeViClientID initClientID, String^ initClientName, Boolean initStatus)
Create the action 'Mode is 'Working' or 'Setup''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VS30PMMode^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
Boolean | aStatus
true = Setup-mode; false = Work-mode

Detailed Description

Action 'Mode is 'Working' or 'Setup''.

Constructor & Destructor Documentation

GeViAct_VS30PMMode::GeViAct_VS30PMMode | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'Mode is 'Working' or 'Setup''.

Parameters:
initClientID | ID of VS-40 interface, only used in the case of an empty Clientname
initClientName | Name of VS-40 interface
initStatus | true = Setup-mode; false = Work-mode

Member Function Documentation

GeViAct_VS30PMMode GeViAct_VS30PMMode::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VS30PMMode::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode::aClientName

Name of VS-40 interface.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode::aStatus

true = Setup-mode; false = Work-mode

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VS30PMModeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VS30PMModeEventArgs (GeViAct_VS30PMMode^ initAction)
Create the EventArgs for handler of action 'Mode is 'Working' or 'Setup''.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
Boolean | aStatus
true = Setup-mode; false = Work-mode

Private Member Functions

GeViAct_VS30PMModeEventArgs ()

Detailed Description

EventArgs for handler of action 'Mode is 'Working' or 'Setup''.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs::GeViAct_VS30PMModeEventArgs ( ) [private]
GeViAct_VS30PMModeEventArgs::GeViAct_VS30PMModeEventArgs ( GeViAct_VS30PMMode^ initAction )

Create the EventArgs for handler of action 'Mode is 'Working' or 'Setup''.

Parameters:
initAction Managed action 'Mode is 'Working' or 'Setup''.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs::aClientName

Name of VS-40 interface.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs::aStatus

true = Setup-mode; false = Work-mode

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode Class Reference

  • VideoSensorActions
  • GeViAct_VS30VMDMode
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode Class Reference
Actions

Action 'Mode of the VMD'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode:
[legend]

List of all members.

Public Member Functions

GeViAct_VS30VMDMode (GeViVideoInputID initVideoInput, Int32 initStatus)
Create the action 'Mode of the VMD'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VS30VMDMode^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input.
Int32 | aStatus
Working mode.

Detailed Description

Action 'Mode of the VMD'.

Constructor & Destructor Documentation

GeViAct_VS30VMDMode::GeViAct_VS30VMDMode | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initStatus
 | ) |  |

Create the action 'Mode of the VMD'.

Parameters:
initVideoInput | ID of video input
initStatus | Working mode

Member Function Documentation

GeViAct_VS30VMDMode GeViAct_VS30VMDMode::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VS30VMDMode::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode::aStatus

Working mode.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VS30VMDModeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VS30VMDModeEventArgs (GeViAct_VS30VMDMode^ initAction)
Create the EventArgs for handler of action 'Mode of the VMD'.

Properties

GeViVideoInputID | aVideoInput
ID of video input.
Int32 | aStatus
Working mode.

Private Member Functions

GeViAct_VS30VMDModeEventArgs ()

Detailed Description

EventArgs for handler of action 'Mode of the VMD'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs::GeViAct_VS30VMDModeEventArgs ( ) [private]
GeViAct_VS30VMDModeEventArgs::GeViAct_VS30VMDModeEventArgs ( GeViAct_VS30VMDMode^ initAction )

Create the EventArgs for handler of action 'Mode of the VMD'.

Parameters:
initAction Managed action 'Mode of the VMD'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs::aStatus

Working mode.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd Class Reference

  • VideoSensorActions
  • GeViAct_VSAlarmEnd
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd Class Reference
Actions

Action 'Alarm has finished.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd:
[legend]

List of all members.

Public Member Functions

GeViAct_VSAlarmEnd (GeViVideoInputID initVideoInput)
Create the action 'Alarm has finished.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSAlarmEnd^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)

Detailed Description

Action 'Alarm has finished.'.

Constructor & Destructor Documentation

GeViAct_VSAlarmEnd::GeViAct_VSAlarmEnd ( GeViVideoInputID initVideoInput )

Create the action 'Alarm has finished.'.

Parameters:
initVideoInput ID of video input (VMD/Input)

Member Function Documentation

GeViAct_VSAlarmEnd GeViAct_VSAlarmEnd::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSAlarmEnd::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSAlarmEndEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSAlarmEndEventArgs (GeViAct_VSAlarmEnd^ initAction)
Create the EventArgs for handler of action 'Alarm has finished.'.

Properties

GeViVideoInputID aVideoInput
ID of video input (VMD/Input)

Private Member Functions

GeViAct_VSAlarmEndEventArgs ()

Detailed Description

EventArgs for handler of action 'Alarm has finished.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs::GeViAct_VSAlarmEndEventArgs ( ) [private]
GeViAct_VSAlarmEndEventArgs::GeViAct_VSAlarmEndEventArgs ( GeViAct_VSAlarmEnd^ initAction )

Create the EventArgs for handler of action 'Alarm has finished.'.

Parameters:
initAction Managed action 'Alarm has finished.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern Class Reference

  • VideoSensorActions
  • GeViAct_VSAlarmExtern
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern Class Reference
Actions

Action 'External alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern:
[legend]

List of all members.

Public Member Functions

GeViAct_VSAlarmExtern (GeViVideoInputID initVideoInput)
Create the action 'External alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSAlarmExtern^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)

Detailed Description

Action 'External alarm'.

Constructor & Destructor Documentation

GeViAct_VSAlarmExtern::GeViAct_VSAlarmExtern ( GeViVideoInputID initVideoInput )

Create the action 'External alarm'.

Parameters:
initVideoInput ID of video input (VMD/Input)

Member Function Documentation

GeViAct_VSAlarmExtern GeViAct_VSAlarmExtern::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSAlarmExtern::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSAlarmExternEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSAlarmExternEventArgs (GeViAct_VSAlarmExtern^ initAction)
Create the EventArgs for handler of action 'External alarm'.

Properties

GeViVideoInputID aVideoInput
ID of video input (VMD/Input)

Private Member Functions

GeViAct_VSAlarmExternEventArgs ()

Detailed Description

EventArgs for handler of action 'External alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs::GeViAct_VSAlarmExternEventArgs ( ) [private]
GeViAct_VSAlarmExternEventArgs::GeViAct_VSAlarmExternEventArgs ( GeViAct_VSAlarmExtern^ initAction )

Create the EventArgs for handler of action 'External alarm'.

Parameters:
initAction Managed action 'External alarm'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField Class Reference

  • VideoSensorActions
  • GeViAct_VSAlarmInField
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField Class Reference
Actions

Action 'Alarm in a field'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField:
[legend]

List of all members.

Public Member Functions

GeViAct_VSAlarmInField (GeViVideoInputID initVideoInput, Int32 initField, Byte initMeasureTime)
Create the action 'Alarm in a field'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSAlarmInField^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Int32 | aField
field number (1-64)
Byte | aMeasureTime
Measure time (A-E)

Detailed Description

Action 'Alarm in a field'.

Constructor & Destructor Documentation

GeViAct_VSAlarmInField::GeViAct_VSAlarmInField | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initField,
 |  | Byte | initMeasureTime
 | ) |  |

Create the action 'Alarm in a field'.

Parameters:
initVideoInput | ID of video input (VMD/Input)
initField | field number (1-64)
initMeasureTime | Measure time (A-E)

Member Function Documentation

GeViAct_VSAlarmInField GeViAct_VSAlarmInField::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSAlarmInField::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField::aField

field number (1-64)

Byte GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField::aMeasureTime

Measure time (A-E)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSAlarmInFieldEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSAlarmInFieldEventArgs (GeViAct_VSAlarmInField^ initAction)
Create the EventArgs for handler of action 'Alarm in a field'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Int32 | aField
field number (1-64)
Byte | aMeasureTime
Measure time (A-E)

Private Member Functions

GeViAct_VSAlarmInFieldEventArgs ()

Detailed Description

EventArgs for handler of action 'Alarm in a field'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs::GeViAct_VSAlarmInFieldEventArgs ( ) [private]
GeViAct_VSAlarmInFieldEventArgs::GeViAct_VSAlarmInFieldEventArgs ( GeViAct_VSAlarmInField^ initAction )

Create the EventArgs for handler of action 'Alarm in a field'.

Parameters:
initAction Managed action 'Alarm in a field'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs::aField

field number (1-64)

Byte GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs::aMeasureTime

Measure time (A-E)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm Class Reference

  • VideoSensorActions
  • GeViAct_VSAllTestAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm Class Reference
Actions

Action 'Test alarm for all VMD's of one client.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_VSAllTestAlarm (GeViClientID initClientID, String^ initClientName)
Create the action 'Test alarm for all VMD's of one client.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSAllTestAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.

Detailed Description

Action 'Test alarm for all VMD's of one client.'.

Constructor & Destructor Documentation

GeViAct_VSAllTestAlarm::GeViAct_VSAllTestAlarm | ( | GeViClientID | initClientID,
 |  | String^ | initClientName
 | ) |  |

Create the action 'Test alarm for all VMD's of one client.'.

Parameters:
initClientID | ID of VS-40 interface, only used in the case of an empty Clientname
initClientName | Name of VS-40 interface

Member Function Documentation

GeViAct_VSAllTestAlarm GeViAct_VSAllTestAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSAllTestAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm::aClientName

Name of VS-40 interface.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSAllTestAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSAllTestAlarmEventArgs (GeViAct_VSAllTestAlarm^ initAction)
Create the EventArgs for handler of action 'Test alarm for all VMD's of one client.'.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.

Private Member Functions

GeViAct_VSAllTestAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Test alarm for all VMD's of one client.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs::GeViAct_VSAllTestAlarmEventArgs ( ) [private]
GeViAct_VSAllTestAlarmEventArgs::GeViAct_VSAllTestAlarmEventArgs ( GeViAct_VSAllTestAlarm^ initAction )

Create the EventArgs for handler of action 'Test alarm for all VMD's of one client.'.

Parameters:
initAction Managed action 'Test alarm for all VMD's of one client.'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs::aClientName

Name of VS-40 interface.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset Class Reference

  • VideoSensorActions
  • GeViAct_VSAllTimerReset
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset Class Reference
Actions

Action 'Reset of the timers of all VMD of a client.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset:
[legend]

List of all members.

Public Member Functions

GeViAct_VSAllTimerReset (GeViClientID initClientID, String^ initClientName)
Create the action 'Reset of the timers of all VMD of a client.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSAllTimerReset^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.

Detailed Description

Action 'Reset of the timers of all VMD of a client.'.

Constructor & Destructor Documentation

GeViAct_VSAllTimerReset::GeViAct_VSAllTimerReset | ( | GeViClientID | initClientID,
 |  | String^ | initClientName
 | ) |  |

Create the action 'Reset of the timers of all VMD of a client.'.

Parameters:
initClientID | ID of VS-40 interface, only used in the case of an empty Clientname
initClientName | Name of VS-40 interface

Member Function Documentation

GeViAct_VSAllTimerReset GeViAct_VSAllTimerReset::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSAllTimerReset::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset::aClientName

Name of VS-40 interface.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSAllTimerResetEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSAllTimerResetEventArgs (GeViAct_VSAllTimerReset^ initAction)
Create the EventArgs for handler of action 'Reset of the timers of all VMD of a client.'.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.

Private Member Functions

GeViAct_VSAllTimerResetEventArgs ()

Detailed Description

EventArgs for handler of action 'Reset of the timers of all VMD of a client.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs::GeViAct_VSAllTimerResetEventArgs ( ) [private]
GeViAct_VSAllTimerResetEventArgs::GeViAct_VSAllTimerResetEventArgs ( GeViAct_VSAllTimerReset^ initAction )

Create the EventArgs for handler of action 'Reset of the timers of all VMD of a client.'.

Parameters:
initAction Managed action 'Reset of the timers of all VMD of a client.'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs::aClientName

Name of VS-40 interface.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed Class Reference

  • VideoSensorActions
  • GeViAct_VSArmed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed Class Reference
Actions

Action 'VMD armed or disarmed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed:
[legend]

List of all members.

Public Member Functions

GeViAct_VSArmed (GeViVideoInputID initVideoInput, Boolean initStatus)
Create the action 'VMD armed or disarmed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSArmed^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = armed; false = disarmed

Detailed Description

Action 'VMD armed or disarmed'.

Constructor & Destructor Documentation

GeViAct_VSArmed::GeViAct_VSArmed | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'VMD armed or disarmed'.

Parameters:
initVideoInput | ID of video input (VMD/Input)
initStatus | true = armed; false = disarmed

Member Function Documentation

GeViAct_VSArmed GeViAct_VSArmed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSArmed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed::aStatus

true = armed; false = disarmed

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSArmedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSArmedEventArgs (GeViAct_VSArmed^ initAction)
Create the EventArgs for handler of action 'VMD armed or disarmed'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = armed; false = disarmed

Private Member Functions

GeViAct_VSArmedEventArgs ()

Detailed Description

EventArgs for handler of action 'VMD armed or disarmed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs::GeViAct_VSArmedEventArgs ( ) [private]
GeViAct_VSArmedEventArgs::GeViAct_VSArmedEventArgs ( GeViAct_VSArmed^ initAction )

Create the EventArgs for handler of action 'VMD armed or disarmed'.

Parameters:
initAction Managed action 'VMD armed or disarmed'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs::aStatus

true = armed; false = disarmed

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture Class Reference

  • VideoSensorActions
  • GeViAct_VSChooseSavedPicture
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture Class Reference
Actions

Action 'Choose a saved picture.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture:
[legend]

List of all members.

Public Member Functions

GeViAct_VSChooseSavedPicture (GeViVideoInputID initVideoInput, Int32 initSavedPicture)
Create the action 'Choose a saved picture.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_VSChooseSavedPicture^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Int32 | aSavedPicture
Can be 1, 2, 3 or 4. (0 mean stand for 'normal state (respectively sequence)'.

Detailed Description

Action 'Choose a saved picture.'.

Constructor & Destructor Documentation

GeViAct_VSChooseSavedPicture::GeViAct_VSChooseSavedPicture | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initSavedPicture
 | ) |  |

Create the action 'Choose a saved picture.'.

Parameters:
initVideoInput | ID of video input (VMD/1)
initSavedPicture | Can be 1, 2, 3 or 4. (0 mean stand for 'normal state (respectively sequence)'

Member Function Documentation

GeViAct_VSChooseSavedPicture GeViAct_VSChooseSavedPicture::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSChooseSavedPicture::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture::aSavedPicture

Can be 1, 2, 3 or 4. (0 mean stand for 'normal state (respectively sequence)'.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSChooseSavedPictureEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSChooseSavedPictureEventArgs (GeViAct_VSChooseSavedPicture^ initAction)
Create the EventArgs for handler of action 'Choose a saved picture.'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Int32 | aSavedPicture
Can be 1, 2, 3 or 4. (0 mean stand for 'normal state (respectively sequence)'.

Private Member Functions

GeViAct_VSChooseSavedPictureEventArgs ()

Detailed Description

EventArgs for handler of action 'Choose a saved picture.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs::GeViAct_VSChooseSavedPictureEventArgs ( ) [private]
GeViAct_VSChooseSavedPictureEventArgs::GeViAct_VSChooseSavedPictureEventArgs ( GeViAct_VSChooseSavedPicture^ initAction )

Create the EventArgs for handler of action 'Choose a saved picture.'.

Parameters:
initAction Managed action 'Choose a saved picture.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs::aSavedPicture

Can be 1, 2, 3 or 4. (0 mean stand for 'normal state (respectively sequence)'.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect Class Reference

  • VideoSensorActions
  • GeViAct_VSPictureDetect
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect Class Reference
Actions

Action 'Picture OK respective picture failure'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect:
[legend]

List of all members.

Public Member Functions

GeViAct_VSPictureDetect (GeViVideoInputID initVideoInput, Boolean initStatus)
Create the action 'Picture OK respective picture failure'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSPictureDetect^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = picture OK; false = picture failure

Detailed Description

Action 'Picture OK respective picture failure'.

Constructor & Destructor Documentation

GeViAct_VSPictureDetect::GeViAct_VSPictureDetect | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'Picture OK respective picture failure'.

Parameters:
initVideoInput | ID of video input (VMD/Input)
initStatus | true = picture OK; false = picture failure

Member Function Documentation

GeViAct_VSPictureDetect GeViAct_VSPictureDetect::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSPictureDetect::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect::aStatus

true = picture OK; false = picture failure

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSPictureDetectEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSPictureDetectEventArgs (GeViAct_VSPictureDetect^ initAction)
Create the EventArgs for handler of action 'Picture OK respective picture failure'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = picture OK; false = picture failure

Private Member Functions

GeViAct_VSPictureDetectEventArgs ()

Detailed Description

EventArgs for handler of action 'Picture OK respective picture failure'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs::GeViAct_VSPictureDetectEventArgs ( ) [private]
GeViAct_VSPictureDetectEventArgs::GeViAct_VSPictureDetectEventArgs ( GeViAct_VSPictureDetect^ initAction )

Create the EventArgs for handler of action 'Picture OK respective picture failure'.

Parameters:
initAction Managed action 'Picture OK respective picture failure'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs::aStatus

true = picture OK; false = picture failure

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut Class Reference

  • VideoSensorActions
  • GeViAct_VSPictureToCommonOut
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut Class Reference
Actions

Action 'Set one picture to a common output'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut:
[legend]

List of all members.

Public Member Functions

GeViAct_VSPictureToCommonOut (GeViVideoInputID initVideoInput, Int32 initOutput)
Create the action 'Set one picture to a common output'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_VSPictureToCommonOut^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Int32 | aOutput
ID of common output, to which the picture shall be set.

Detailed Description

Action 'Set one picture to a common output'.

Constructor & Destructor Documentation

GeViAct_VSPictureToCommonOut::GeViAct_VSPictureToCommonOut | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initOutput
 | ) |  |

Create the action 'Set one picture to a common output'.

Parameters:
initVideoInput | ID of video input (VMD/1)
initOutput | ID of common output, to which the picture shall be set

Member Function Documentation

GeViAct_VSPictureToCommonOut GeViAct_VSPictureToCommonOut::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSPictureToCommonOut::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut::aOutput

ID of common output, to which the picture shall be set.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSPictureToCommonOutEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSPictureToCommonOutEventArgs (GeViAct_VSPictureToCommonOut^ initAction)
Create the EventArgs for handler of action 'Set one picture to a common output'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Int32 | aOutput
ID of common output, to which the picture shall be set.

Private Member Functions

GeViAct_VSPictureToCommonOutEventArgs ()

Detailed Description

EventArgs for handler of action 'Set one picture to a common output'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs::GeViAct_VSPictureToCommonOutEventArgs ( ) [private]
GeViAct_VSPictureToCommonOutEventArgs::GeViAct_VSPictureToCommonOutEventArgs ( GeViAct_VSPictureToCommonOut^ initAction )

Create the EventArgs for handler of action 'Set one picture to a common output'.

Parameters:
initAction Managed action 'Set one picture to a common output'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs::aOutput

ID of common output, to which the picture shall be set.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput Class Reference

  • VideoSensorActions
  • GeViAct_VSPictureToOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput Class Reference
Actions

Action 'Set a picture to an output'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput:
[legend]

List of all members.

Public Member Functions

GeViAct_VSPictureToOutput (GeViVideoInputID initVideoInput, Boolean initWhichPicture)
Create the action 'Set a picture to an output'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSPictureToOutput^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Boolean | aWhichPicture
true = live picture, false = picture from video memory

Detailed Description

Action 'Set a picture to an output'.

Constructor & Destructor Documentation

GeViAct_VSPictureToOutput::GeViAct_VSPictureToOutput | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initWhichPicture
 | ) |  |

Create the action 'Set a picture to an output'.

Parameters:
initVideoInput | ID of video input (VMD/1)
initWhichPicture | true = live picture, false = picture from video memory

Member Function Documentation

GeViAct_VSPictureToOutput GeViAct_VSPictureToOutput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSPictureToOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput::aVideoInput

ID of video input (VMD/1)

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput::aWhichPicture

true = live picture, false = picture from video memory

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSPictureToOutputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSPictureToOutputEventArgs (GeViAct_VSPictureToOutput^ initAction)
Create the EventArgs for handler of action 'Set a picture to an output'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Boolean | aWhichPicture
true = live picture, false = picture from video memory

Private Member Functions

GeViAct_VSPictureToOutputEventArgs ()

Detailed Description

EventArgs for handler of action 'Set a picture to an output'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs::GeViAct_VSPictureToOutputEventArgs ( ) [private]
GeViAct_VSPictureToOutputEventArgs::GeViAct_VSPictureToOutputEventArgs ( GeViAct_VSPictureToOutput^ initAction )

Create the EventArgs for handler of action 'Set a picture to an output'.

Parameters:
initAction Managed action 'Set a picture to an output'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs::aVideoInput

ID of video input (VMD/1)

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs::aWhichPicture

true = live picture, false = picture from video memory

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm Class Reference

  • VideoSensorActions
  • GeViAct_VSPreAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm Class Reference
Actions

Action 'Prealarm respective bring prealarm to end'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_VSPreAlarm (GeViVideoInputID initVideoInput, Boolean initStatus)
Create the action 'Prealarm respective bring prealarm to end'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSPreAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = prealarm; false = prealarm finished

Detailed Description

Action 'Prealarm respective bring prealarm to end'.

Constructor & Destructor Documentation

GeViAct_VSPreAlarm::GeViAct_VSPreAlarm | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'Prealarm respective bring prealarm to end'.

Parameters:
initVideoInput | ID of video input (VMD/Input)
initStatus | true = prealarm; false = prealarm finished

Member Function Documentation

GeViAct_VSPreAlarm GeViAct_VSPreAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSPreAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm::aStatus

true = prealarm; false = prealarm finished

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSPreAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSPreAlarmEventArgs (GeViAct_VSPreAlarm^ initAction)
Create the EventArgs for handler of action 'Prealarm respective bring prealarm to end'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = prealarm; false = prealarm finished

Private Member Functions

GeViAct_VSPreAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Prealarm respective bring prealarm to end'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs::GeViAct_VSPreAlarmEventArgs ( ) [private]
GeViAct_VSPreAlarmEventArgs::GeViAct_VSPreAlarmEventArgs ( GeViAct_VSPreAlarm^ initAction )

Create the EventArgs for handler of action 'Prealarm respective bring prealarm to end'.

Parameters:
initAction Managed action 'Prealarm respective bring prealarm to end'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs::aStatus

true = prealarm; false = prealarm finished

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd Class Reference

  • VideoSensorActions
  • GeViAct_VSRecorderEnd
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd Class Reference
Actions

Action 'The recorder was stopped'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd:
[legend]

List of all members.

Public Member Functions

GeViAct_VSRecorderEnd (GeViVideoInputID initVideoInput)
Create the action 'The recorder was stopped'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSRecorderEnd^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)

Detailed Description

Action 'The recorder was stopped'.

Constructor & Destructor Documentation

GeViAct_VSRecorderEnd::GeViAct_VSRecorderEnd ( GeViVideoInputID initVideoInput )

Create the action 'The recorder was stopped'.

Parameters:
initVideoInput ID of video input (VMD/Input)

Member Function Documentation

GeViAct_VSRecorderEnd GeViAct_VSRecorderEnd::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSRecorderEnd::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSRecorderEndEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSRecorderEndEventArgs (GeViAct_VSRecorderEnd^ initAction)
Create the EventArgs for handler of action 'The recorder was stopped'.

Properties

GeViVideoInputID aVideoInput
ID of video input (VMD/Input)

Private Member Functions

GeViAct_VSRecorderEndEventArgs ()

Detailed Description

EventArgs for handler of action 'The recorder was stopped'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs::GeViAct_VSRecorderEndEventArgs ( ) [private]
GeViAct_VSRecorderEndEventArgs::GeViAct_VSRecorderEndEventArgs ( GeViAct_VSRecorderEnd^ initAction )

Create the EventArgs for handler of action 'The recorder was stopped'.

Parameters:
initAction Managed action 'The recorder was stopped'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset Class Reference

  • VideoSensorActions
  • GeViAct_VSRecorderTimerReset
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset Class Reference
Actions

Action 'Reset of timer of the recorder of a VMD.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset:
[legend]

List of all members.

Public Member Functions

GeViAct_VSRecorderTimerReset (GeViVideoInputID initVideoInput)
Create the action 'Reset of timer of the recorder of a VMD.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static
GeViAct_VSRecorderTimerReset^ 		FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)

Detailed Description

Action 'Reset of timer of the recorder of a VMD.'.

Constructor & Destructor Documentation

GeViAct_VSRecorderTimerReset::GeViAct_VSRecorderTimerReset ( GeViVideoInputID initVideoInput )

Create the action 'Reset of timer of the recorder of a VMD.'.

Parameters:
initVideoInput ID of video input (VMD/1)

Member Function Documentation

GeViAct_VSRecorderTimerReset GeViAct_VSRecorderTimerReset::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSRecorderTimerReset::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSRecorderTimerResetEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSRecorderTimerResetEventArgs (GeViAct_VSRecorderTimerReset^ initAction)
Create the EventArgs for handler of action 'Reset of timer of the recorder of a VMD.'.

Properties

GeViVideoInputID aVideoInput
ID of video input (VMD/1)

Private Member Functions

GeViAct_VSRecorderTimerResetEventArgs ()

Detailed Description

EventArgs for handler of action 'Reset of timer of the recorder of a VMD.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs::GeViAct_VSRecorderTimerResetEventArgs ( ) [private]
GeViAct_VSRecorderTimerResetEventArgs::GeViAct_VSRecorderTimerResetEventArgs ( GeViAct_VSRecorderTimerReset^ initAction )

Create the EventArgs for handler of action 'Reset of timer of the recorder of a VMD.'.

Parameters:
initAction Managed action 'Reset of timer of the recorder of a VMD.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed Class Reference

  • VideoSensorActions
  • GeViAct_VSSetAllArmed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed Class Reference
Actions

Action 'All VMD's will be armed or disarmed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed:
[legend]

List of all members.

Public Member Functions

GeViAct_VSSetAllArmed (GeViClientID initClientID, String^ initClientName, Boolean initArmed)
Create the action 'All VMD's will be armed or disarmed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSSetAllArmed^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
Boolean | aArmed
true = armed, false = disarmed

Detailed Description

Action 'All VMD's will be armed or disarmed'.

Constructor & Destructor Documentation

GeViAct_VSSetAllArmed::GeViAct_VSSetAllArmed | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | Boolean | initArmed
 | ) |  |

Create the action 'All VMD's will be armed or disarmed'.

Parameters:
initClientID | ID of VS-40 interface, only used in the case of an empty Clientname
initClientName | Name of VS-40 interface
initArmed | true = armed, false = disarmed

Member Function Documentation

GeViAct_VSSetAllArmed GeViAct_VSSetAllArmed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSSetAllArmed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed::aArmed

true = armed, false = disarmed

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed::aClientName

Name of VS-40 interface.

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSSetAllArmedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSSetAllArmedEventArgs (GeViAct_VSSetAllArmed^ initAction)
Create the EventArgs for handler of action 'All VMD's will be armed or disarmed'.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
Boolean | aArmed
true = armed, false = disarmed

Private Member Functions

GeViAct_VSSetAllArmedEventArgs ()

Detailed Description

EventArgs for handler of action 'All VMD's will be armed or disarmed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs::GeViAct_VSSetAllArmedEventArgs ( ) [private]
GeViAct_VSSetAllArmedEventArgs::GeViAct_VSSetAllArmedEventArgs ( GeViAct_VSSetAllArmed^ initAction )

Create the EventArgs for handler of action 'All VMD's will be armed or disarmed'.

Parameters:
initAction Managed action 'All VMD's will be armed or disarmed'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs::aArmed

true = armed, false = disarmed

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs::aClientName

Name of VS-40 interface.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed Class Reference

  • VideoSensorActions
  • GeViAct_VSSetArmed
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed Class Reference
Actions

Action 'Set the VMD armed or disarmed'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed:
[legend]

List of all members.

Public Member Functions

GeViAct_VSSetArmed (GeViVideoInputID initVideoInput, Boolean initArmed)
Create the action 'Set the VMD armed or disarmed'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSSetArmed^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Boolean | aArmed
true = armed, false = disarmed

Detailed Description

Action 'Set the VMD armed or disarmed'.

Constructor & Destructor Documentation

GeViAct_VSSetArmed::GeViAct_VSSetArmed | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initArmed
 | ) |  |

Create the action 'Set the VMD armed or disarmed'.

Parameters:
initVideoInput | ID of video input (VMD/1)
initArmed | true = armed, false = disarmed

Member Function Documentation

GeViAct_VSSetArmed GeViAct_VSSetArmed::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSSetArmed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed::aArmed

true = armed, false = disarmed

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSSetArmedEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSSetArmedEventArgs (GeViAct_VSSetArmed^ initAction)
Create the EventArgs for handler of action 'Set the VMD armed or disarmed'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)
Boolean | aArmed
true = armed, false = disarmed

Private Member Functions

GeViAct_VSSetArmedEventArgs ()

Detailed Description

EventArgs for handler of action 'Set the VMD armed or disarmed'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs::GeViAct_VSSetArmedEventArgs ( ) [private]
GeViAct_VSSetArmedEventArgs::GeViAct_VSSetArmedEventArgs ( GeViAct_VSSetArmed^ initAction )

Create the EventArgs for handler of action 'Set the VMD armed or disarmed'.

Parameters:
initAction Managed action 'Set the VMD armed or disarmed'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs::aArmed

true = armed, false = disarmed

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime Class Reference

  • VideoSensorActions
  • GeViAct_VSSetDateAndTime
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime Class Reference
Actions

Action 'Set date and time of a CU.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime:
[legend]

List of all members.

Public Member Functions

GeViAct_VSSetDateAndTime (GeViClientID initClientID, String^ initClientName, GeViTGeViDateTime initDateAndTime)
Create the action 'Set date and time of a CU.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSSetDateAndTime^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
GeViTGeViDateTime aDateAndTime
Date and time to set.

Detailed Description

Action 'Set date and time of a CU.'.

Constructor & Destructor Documentation

GeViAct_VSSetDateAndTime::GeViAct_VSSetDateAndTime | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | GeViTGeViDateTime | initDateAndTime
 | ) |  |

Create the action 'Set date and time of a CU.'.

Parameters:
initClientID | ID of VS-40 interface, only used in the case of an empty Clientname
initClientName | Name of VS-40 interface
initDateAndTime | Date and time to set

Member Function Documentation

GeViAct_VSSetDateAndTime GeViAct_VSSetDateAndTime::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSSetDateAndTime::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime::aClientName

Name of VS-40 interface.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime::aDateAndTime

Date and time to set.

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSSetDateAndTimeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSSetDateAndTimeEventArgs (GeViAct_VSSetDateAndTime^ initAction)
Create the EventArgs for handler of action 'Set date and time of a CU.'.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
GeViTGeViDateTime aDateAndTime
Date and time to set.

Private Member Functions

GeViAct_VSSetDateAndTimeEventArgs ()

Detailed Description

EventArgs for handler of action 'Set date and time of a CU.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs::GeViAct_VSSetDateAndTimeEventArgs ( ) [private]
GeViAct_VSSetDateAndTimeEventArgs::GeViAct_VSSetDateAndTimeEventArgs ( GeViAct_VSSetDateAndTime^ initAction )

Create the EventArgs for handler of action 'Set date and time of a CU.'.

Parameters:
initAction Managed action 'Set date and time of a CU.'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs::aClientName

Name of VS-40 interface.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs::aDateAndTime

Date and time to set.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode Class Reference

  • VideoSensorActions
  • GeViAct_VSSetMode
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode Class Reference
Actions

Action 'Reset timers of all VMD's of a VS-40 interface'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode:
[legend]

List of all members.

Public Member Functions

GeViAct_VSSetMode (GeViClientID initClientID, String^ initClientName, Int32 initMode)
Create the action 'Reset timers of all VMD's of a VS-40 interface'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSSetMode^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
Int32 | aMode
Can be 1, 2, 3, or 4.

Detailed Description

Action 'Reset timers of all VMD's of a VS-40 interface'.

Constructor & Destructor Documentation

GeViAct_VSSetMode::GeViAct_VSSetMode | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | Int32 | initMode
 | ) |  |

Create the action 'Reset timers of all VMD's of a VS-40 interface'.

Parameters:
initClientID | ID of VS-40 interface, only used in the case of an empty Clientname
initClientName | Name of VS-40 interface
initMode | Can be 1, 2, 3, or 4

Member Function Documentation

GeViAct_VSSetMode GeViAct_VSSetMode::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSSetMode::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode::aClientName

Name of VS-40 interface.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode::aMode

Can be 1, 2, 3, or 4.

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSSetModeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSSetModeEventArgs (GeViAct_VSSetMode^ initAction)
Create the EventArgs for handler of action 'Reset timers of all VMD's of a VS-40 interface'.

Properties

GeViClientID | aClientID
ID of VS-40 interface, only used in the case of an empty Clientname.
String^ | aClientName
Name of VS-40 interface.
Int32 | aMode
Can be 1, 2, 3, or 4.

Private Member Functions

GeViAct_VSSetModeEventArgs ()

Detailed Description

EventArgs for handler of action 'Reset timers of all VMD's of a VS-40 interface'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs::GeViAct_VSSetModeEventArgs ( ) [private]
GeViAct_VSSetModeEventArgs::GeViAct_VSSetModeEventArgs ( GeViAct_VSSetMode^ initAction )

Create the EventArgs for handler of action 'Reset timers of all VMD's of a VS-40 interface'.

Parameters:
initAction Managed action 'Reset timers of all VMD's of a VS-40 interface'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs::aClientID

ID of VS-40 interface, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs::aClientName

Name of VS-40 interface.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs::aMode

Can be 1, 2, 3, or 4.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode Class Reference

  • VideoSensorActions
  • GeViAct_VSSetSensorMode
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode Class Reference
Actions

Action 'Set mode of the sensor'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode:
[legend]

List of all members.

Public Member Functions

GeViAct_VSSetSensorMode (GeViVideoInputID initVideoInput, Int32 initMode)
Create the action 'Set mode of the sensor'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSSetSensorMode^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input.
Int32 | aMode
Can be 1, 2, 3, or 4.

Detailed Description

Action 'Set mode of the sensor'.

Constructor & Destructor Documentation

GeViAct_VSSetSensorMode::GeViAct_VSSetSensorMode | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initMode
 | ) |  |

Create the action 'Set mode of the sensor'.

Parameters:
initVideoInput | ID of video input
initMode | Can be 1, 2, 3, or 4

Member Function Documentation

GeViAct_VSSetSensorMode GeViAct_VSSetSensorMode::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSSetSensorMode::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode::aMode

Can be 1, 2, 3, or 4.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSSetSensorModeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSSetSensorModeEventArgs (GeViAct_VSSetSensorMode^ initAction)
Create the EventArgs for handler of action 'Set mode of the sensor'.

Properties

GeViVideoInputID | aVideoInput
ID of video input.
Int32 | aMode
Can be 1, 2, 3, or 4.

Private Member Functions

GeViAct_VSSetSensorModeEventArgs ()

Detailed Description

EventArgs for handler of action 'Set mode of the sensor'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs::GeViAct_VSSetSensorModeEventArgs ( ) [private]
GeViAct_VSSetSensorModeEventArgs::GeViAct_VSSetSensorModeEventArgs ( GeViAct_VSSetSensorMode^ initAction )

Create the EventArgs for handler of action 'Set mode of the sensor'.

Parameters:
initAction Managed action 'Set mode of the sensor'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs::aMode

Can be 1, 2, 3, or 4.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput Class Reference

  • VideoSensorActions
  • GeViAct_VSSetSensorOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput Class Reference
Actions

Action 'Change output settings of the sensor'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput:
[legend]

List of all members.

Public Member Functions

GeViAct_VSSetSensorOutput (GeViVideoInputID initVideoInput, Boolean initOutput, Boolean initMode)
Create the action 'Change output settings of the sensor'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSSetSensorOutput^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input.
Boolean | aOutput
true - common output, false - single output
Boolean | aMode
true - EXTERN, false - ALWAYS

Detailed Description

Action 'Change output settings of the sensor'.

Constructor & Destructor Documentation

GeViAct_VSSetSensorOutput::GeViAct_VSSetSensorOutput | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initOutput,
 |  | Boolean | initMode
 | ) |  |

Create the action 'Change output settings of the sensor'.

Parameters:
initVideoInput | ID of video input
initOutput | true - common output, false - single output
initMode | true - EXTERN, false - ALWAYS

Member Function Documentation

GeViAct_VSSetSensorOutput GeViAct_VSSetSensorOutput::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSSetSensorOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput::aMode

true - EXTERN, false - ALWAYS

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput::aOutput

true - common output, false - single output

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSSetSensorOutputEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSSetSensorOutputEventArgs (GeViAct_VSSetSensorOutput^ initAction)
Create the EventArgs for handler of action 'Change output settings of the sensor'.

Properties

GeViVideoInputID | aVideoInput
ID of video input.
Boolean | aOutput
true - common output, false - single output
Boolean | aMode
true - EXTERN, false - ALWAYS

Private Member Functions

GeViAct_VSSetSensorOutputEventArgs ()

Detailed Description

EventArgs for handler of action 'Change output settings of the sensor'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs::GeViAct_VSSetSensorOutputEventArgs ( ) [private]
GeViAct_VSSetSensorOutputEventArgs::GeViAct_VSSetSensorOutputEventArgs ( GeViAct_VSSetSensorOutput^ initAction )

Create the EventArgs for handler of action 'Change output settings of the sensor'.

Parameters:
initAction Managed action 'Change output settings of the sensor'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs::aMode

true - EXTERN, false - ALWAYS

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs::aOutput

true - common output, false - single output

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs::aVideoInput

ID of video input.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect Class Reference

  • VideoSensorActions
  • GeViAct_VSSyncSignalDetect
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect Class Reference
Actions

Action 'Sync signal and picture failure respective Sync signal OK'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect:
[legend]

List of all members.

Public Member Functions

GeViAct_VSSyncSignalDetect (GeViVideoInputID initVideoInput, Boolean initStatus)
Create the action 'Sync signal and picture failure respective Sync signal OK'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSSyncSignalDetect^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = Sync OK; false = Sync-failure

Detailed Description

Action 'Sync signal and picture failure respective Sync signal OK'.

Constructor & Destructor Documentation

GeViAct_VSSyncSignalDetect::GeViAct_VSSyncSignalDetect | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'Sync signal and picture failure respective Sync signal OK'.

Parameters:
initVideoInput | ID of video input (VMD/Input)
initStatus | true = Sync OK; false = Sync-failure

Member Function Documentation

GeViAct_VSSyncSignalDetect GeViAct_VSSyncSignalDetect::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSSyncSignalDetect::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect::aStatus

true = Sync OK; false = Sync-failure

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSSyncSignalDetectEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSSyncSignalDetectEventArgs (GeViAct_VSSyncSignalDetect^ initAction)
Create the EventArgs for handler of action 'Sync signal and picture failure respective Sync signal OK'.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = Sync OK; false = Sync-failure

Private Member Functions

GeViAct_VSSyncSignalDetectEventArgs ()

Detailed Description

EventArgs for handler of action 'Sync signal and picture failure respective Sync signal OK'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs::GeViAct_VSSyncSignalDetectEventArgs ( ) [private]
GeViAct_VSSyncSignalDetectEventArgs::GeViAct_VSSyncSignalDetectEventArgs ( GeViAct_VSSyncSignalDetect^ initAction )

Create the EventArgs for handler of action 'Sync signal and picture failure respective Sync signal OK'.

Parameters:
initAction Managed action 'Sync signal and picture failure respective Sync signal OK'.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs::aStatus

true = Sync OK; false = Sync-failure

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm Class Reference

  • VideoSensorActions
  • GeViAct_VSTestAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm Class Reference
Actions

Action 'Test alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm:
[legend]

List of all members.

Public Member Functions

GeViAct_VSTestAlarm (GeViVideoInputID initVideoInput)
Create the action 'Test alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSTestAlarm^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)

Detailed Description

Action 'Test alarm'.

Constructor & Destructor Documentation

GeViAct_VSTestAlarm::GeViAct_VSTestAlarm ( GeViVideoInputID initVideoInput )

Create the action 'Test alarm'.

Parameters:
initVideoInput ID of video input (VMD/1)

Member Function Documentation

GeViAct_VSTestAlarm GeViAct_VSTestAlarm::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSTestAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSTestAlarmEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSTestAlarmEventArgs (GeViAct_VSTestAlarm^ initAction)
Create the EventArgs for handler of action 'Test alarm'.

Properties

GeViVideoInputID aVideoInput
ID of video input (VMD/1)

Private Member Functions

GeViAct_VSTestAlarmEventArgs ()

Detailed Description

EventArgs for handler of action 'Test alarm'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs::GeViAct_VSTestAlarmEventArgs ( ) [private]
GeViAct_VSTestAlarmEventArgs::GeViAct_VSTestAlarmEventArgs ( GeViAct_VSTestAlarm^ initAction )

Create the EventArgs for handler of action 'Test alarm'.

Parameters:
initAction Managed action 'Test alarm'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset Class Reference

  • VideoSensorActions
  • GeViAct_VSTimerReset
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset Class Reference
Actions

Action 'Resez timer of aVMD.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset:
[legend]

List of all members.

Public Member Functions

GeViAct_VSTimerReset (GeViVideoInputID initVideoInput)
Create the action 'Resez timer of aVMD.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSTimerReset^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/1)

Detailed Description

Action 'Resez timer of aVMD.'.

Constructor & Destructor Documentation

GeViAct_VSTimerReset::GeViAct_VSTimerReset ( GeViVideoInputID initVideoInput )

Create the action 'Resez timer of aVMD.'.

Parameters:
initVideoInput ID of video input (VMD/1)

Member Function Documentation

GeViAct_VSTimerReset GeViAct_VSTimerReset::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSTimerReset::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSTimerResetEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSTimerResetEventArgs (GeViAct_VSTimerReset^ initAction)
Create the EventArgs for handler of action 'Resez timer of aVMD.'.

Properties

GeViVideoInputID aVideoInput
ID of video input (VMD/1)

Private Member Functions

GeViAct_VSTimerResetEventArgs ()

Detailed Description

EventArgs for handler of action 'Resez timer of aVMD.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs::GeViAct_VSTimerResetEventArgs ( ) [private]
GeViAct_VSTimerResetEventArgs::GeViAct_VSTimerResetEventArgs ( GeViAct_VSTimerReset^ initAction )

Create the EventArgs for handler of action 'Resez timer of aVMD.'.

Parameters:
initAction Managed action 'Resez timer of aVMD.'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs::aVideoInput

ID of video input (VMD/1)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode Class Reference

  • VideoSensorActions
  • GeViAct_VSVMDMode
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode Class Reference
Actions

Action 'Mode is 'Working' or 'Setup''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode:
[legend]

List of all members.

Public Member Functions

GeViAct_VSVMDMode (GeViVideoInputID initVideoInput, Boolean initStatus)
Create the action 'Mode is 'Working' or 'Setup''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSVMDMode^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = Setup-mode; false = Work-mode

Detailed Description

Action 'Mode is 'Working' or 'Setup''.

Constructor & Destructor Documentation

GeViAct_VSVMDMode::GeViAct_VSVMDMode | ( | GeViVideoInputID | initVideoInput,
 |  | Boolean | initStatus
 | ) |  |

Create the action 'Mode is 'Working' or 'Setup''.

Parameters:
initVideoInput | ID of video input (VMD/Input)
initStatus | true = Setup-mode; false = Work-mode

Member Function Documentation

GeViAct_VSVMDMode GeViAct_VSVMDMode::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSVMDMode::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode::aStatus

true = Setup-mode; false = Work-mode

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSVMDModeEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSVMDModeEventArgs (GeViAct_VSVMDMode^ initAction)
Create the EventArgs for handler of action 'Mode is 'Working' or 'Setup''.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)
Boolean | aStatus
true = Setup-mode; false = Work-mode

Private Member Functions

GeViAct_VSVMDModeEventArgs ()

Detailed Description

EventArgs for handler of action 'Mode is 'Working' or 'Setup''.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs::GeViAct_VSVMDModeEventArgs ( ) [private]
GeViAct_VSVMDModeEventArgs::GeViAct_VSVMDModeEventArgs ( GeViAct_VSVMDMode^ initAction )

Create the EventArgs for handler of action 'Mode is 'Working' or 'Setup''.

Parameters:
initAction Managed action 'Mode is 'Working' or 'Setup''.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs::aStatus

true = Setup-mode; false = Work-mode

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder Class Reference

  • VideoSensorActions
  • GeViAct_VSVMDOutOfOrder
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder Class Reference
Actions

Action 'VMD Out of order'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder:
[legend]

List of all members.

Public Member Functions

GeViAct_VSVMDOutOfOrder (GeViVideoInputID initVideoInput)
Create the action 'VMD Out of order'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VSVMDOutOfOrder^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input (VMD/Input)

Detailed Description

Action 'VMD Out of order'.

Constructor & Destructor Documentation

GeViAct_VSVMDOutOfOrder::GeViAct_VSVMDOutOfOrder ( GeViVideoInputID initVideoInput )

Create the action 'VMD Out of order'.

Parameters:
initVideoInput ID of video input (VMD/Input)

Member Function Documentation

GeViAct_VSVMDOutOfOrder GeViAct_VSVMDOutOfOrder::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VSVMDOutOfOrder::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VSVMDOutOfOrderEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VSVMDOutOfOrderEventArgs (GeViAct_VSVMDOutOfOrder^ initAction)
Create the EventArgs for handler of action 'VMD Out of order'.

Properties

GeViVideoInputID aVideoInput
ID of video input (VMD/Input)

Private Member Functions

GeViAct_VSVMDOutOfOrderEventArgs ()

Detailed Description

EventArgs for handler of action 'VMD Out of order'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs::GeViAct_VSVMDOutOfOrderEventArgs ( ) [private]
GeViAct_VSVMDOutOfOrderEventArgs::GeViAct_VSVMDOutOfOrderEventArgs ( GeViAct_VSVMDOutOfOrder^ initAction )

Create the EventArgs for handler of action 'VMD Out of order'.

Parameters:
initAction Managed action 'VMD Out of order'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs::aVideoInput

ID of video input (VMD/Input)

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset Class Reference

  • SwitchControlActions
  • GeViAct_VX3SystemReset
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset Class Reference
Actions

Action 'Reset the VX3-system'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset:
[legend]

List of all members.

Public Member Functions

GeViAct_VX3SystemReset (GeViClientID initClientID, String^ initClientName)
Create the action 'Reset the VX3-system'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_VX3SystemReset^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViClientID | aClientID
User ID of the VX3-system, only used in the case of an empty Clientname.
String^ | aClientName
Name of the VX3-system.

Detailed Description

Action 'Reset the VX3-system'.

Constructor & Destructor Documentation

GeViAct_VX3SystemReset::GeViAct_VX3SystemReset | ( | GeViClientID | initClientID,
 |  | String^ | initClientName
 | ) |  |

Create the action 'Reset the VX3-system'.

Parameters:
initClientID | User ID of the VX3-system, only used in the case of an empty Clientname
initClientName | Name of the VX3-system

Member Function Documentation

GeViAct_VX3SystemReset GeViAct_VX3SystemReset::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_VX3SystemReset::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset::aClientID

User ID of the VX3-system, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset::aClientName

Name of the VX3-system.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_VX3SystemResetEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_VX3SystemResetEventArgs (GeViAct_VX3SystemReset^ initAction)
Create the EventArgs for handler of action 'Reset the VX3-system'.

Properties

GeViClientID | aClientID
User ID of the VX3-system, only used in the case of an empty Clientname.
String^ | aClientName
Name of the VX3-system.

Private Member Functions

GeViAct_VX3SystemResetEventArgs ()

Detailed Description

EventArgs for handler of action 'Reset the VX3-system'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs::GeViAct_VX3SystemResetEventArgs ( ) [private]
GeViAct_VX3SystemResetEventArgs::GeViAct_VX3SystemResetEventArgs ( GeViAct_VX3SystemReset^ initAction )

Create the EventArgs for handler of action 'Reset the VX3-system'.

Parameters:
initAction Managed action 'Reset the VX3-system'.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs::aClientID

User ID of the VX3-system, only used in the case of an empty Clientname.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs::aClientName

Name of the VX3-system.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn Class Reference

  • CameraControlActions
  • GeViAct_ZoomIn
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn Class Reference
Actions

Action 'Zooming in the room'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn:
[legend]

List of all members.

Public Member Functions

GeViAct_ZoomIn (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Zooming in the room'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_ZoomIn^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input, which window shall be zoomed in.
Int32 | aTemp
Speed of the zoom (0 = standard)

Detailed Description

Action 'Zooming in the room'.

Constructor & Destructor Documentation

GeViAct_ZoomIn::GeViAct_ZoomIn | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Zooming in the room'.

Parameters:
initVideoInput | ID of video input, which window shall be zoomed in
initTemp | Speed of the zoom (0 = standard)

Member Function Documentation

GeViAct_ZoomIn GeViAct_ZoomIn::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ZoomIn::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn::aTemp

Speed of the zoom (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn::aVideoInput

ID of video input, which window shall be zoomed in.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ZoomInEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ZoomInEventArgs (GeViAct_ZoomIn^ initAction)
Create the EventArgs for handler of action 'Zooming in the room'.

Properties

GeViVideoInputID | aVideoInput
ID of video input, which window shall be zoomed in.
Int32 | aTemp
Speed of the zoom (0 = standard)

Private Member Functions

GeViAct_ZoomInEventArgs ()

Detailed Description

EventArgs for handler of action 'Zooming in the room'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs::GeViAct_ZoomInEventArgs ( ) [private]
GeViAct_ZoomInEventArgs::GeViAct_ZoomInEventArgs ( GeViAct_ZoomIn^ initAction )

Create the EventArgs for handler of action 'Zooming in the room'.

Parameters:
initAction Managed action 'Zooming in the room'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs::aTemp

Speed of the zoom (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs::aVideoInput

ID of video input, which window shall be zoomed in.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut Class Reference

  • CameraControlActions
  • GeViAct_ZoomOut
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut Class Reference
Actions

Action 'Zooming out of the room.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut:
[legend]

List of all members.

Public Member Functions

GeViAct_ZoomOut (GeViVideoInputID initVideoInput, Int32 initTemp)
Create the action 'Zooming out of the room.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_ZoomOut^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input, which window shall be zoomed out.
Int32 | aTemp
Speed of the zoom (0 = standard)

Detailed Description

Action 'Zooming out of the room.'.

Constructor & Destructor Documentation

GeViAct_ZoomOut::GeViAct_ZoomOut | ( | GeViVideoInputID | initVideoInput,
 |  | Int32 | initTemp
 | ) |  |

Create the action 'Zooming out of the room.'.

Parameters:
initVideoInput | ID of video input, which window shall be zoomed out
initTemp | Speed of the zoom (0 = standard)

Member Function Documentation

GeViAct_ZoomOut GeViAct_ZoomOut::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ZoomOut::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut::aTemp

Speed of the zoom (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut::aVideoInput

ID of video input, which window shall be zoomed out.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ZoomOutEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ZoomOutEventArgs (GeViAct_ZoomOut^ initAction)
Create the EventArgs for handler of action 'Zooming out of the room.'.

Properties

GeViVideoInputID | aVideoInput
ID of video input, which window shall be zoomed out.
Int32 | aTemp
Speed of the zoom (0 = standard)

Private Member Functions

GeViAct_ZoomOutEventArgs ()

Detailed Description

EventArgs for handler of action 'Zooming out of the room.'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs::GeViAct_ZoomOutEventArgs ( ) [private]
GeViAct_ZoomOutEventArgs::GeViAct_ZoomOutEventArgs ( GeViAct_ZoomOut^ initAction )

Create the EventArgs for handler of action 'Zooming out of the room.'.

Parameters:
initAction Managed action 'Zooming out of the room.'.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs::aTemp

Speed of the zoom (0 = standard)

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs::aVideoInput

ID of video input, which window shall be zoomed out.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop Class Reference

  • CameraControlActions
  • GeViAct_ZoomStop
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop Class Reference
Actions

Action 'Stop zooming of the camera'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop:
[legend]

List of all members.

Public Member Functions

GeViAct_ZoomStop (GeViVideoInputID initVideoInput)
Create the action 'Stop zooming of the camera'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this action.

Static Public Member Functions

static GeViAct_ZoomStop^ | FromNativeAction (CGeViMessage *nativeAction)
Create a managed instance of this action by using a native C++ instance.

Properties

GeViVideoInputID | aVideoInput
ID of video input where the zooming shall be stopped.

Detailed Description

Action 'Stop zooming of the camera'.

Constructor & Destructor Documentation

GeViAct_ZoomStop::GeViAct_ZoomStop ( GeViVideoInputID initVideoInput )

Create the action 'Stop zooming of the camera'.

Parameters:
initVideoInput ID of video input where the zooming shall be stopped

Member Function Documentation

GeViAct_ZoomStop GeViAct_ZoomStop::FromNativeAction ( CGeViMessage * nativeAction ) [static]

Create a managed instance of this action by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the action.
CGeViMessage * GeViAct_ZoomStop::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this action.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop::aVideoInput

ID of video input where the zooming shall be stopped.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs Class Reference

  • ActionDispatcher
  • GeViAct_ZoomStopEventArgs
Public Member Functions | Properties | Private Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs Class Reference
Event Handlers and Event Arguments

List of all members.

Public Member Functions

GeViAct_ZoomStopEventArgs (GeViAct_ZoomStop^ initAction)
Create the EventArgs for handler of action 'Stop zooming of the camera'.

Properties

GeViVideoInputID aVideoInput
ID of video input where the zooming shall be stopped.

Private Member Functions

GeViAct_ZoomStopEventArgs ()

Detailed Description

EventArgs for handler of action 'Stop zooming of the camera'.

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs::GeViAct_ZoomStopEventArgs ( ) [private]
GeViAct_ZoomStopEventArgs::GeViAct_ZoomStopEventArgs ( GeViAct_ZoomStop^ initAction )

Create the EventArgs for handler of action 'Stop zooming of the camera'.

Parameters:
initAction Managed action 'Stop zooming of the camera'.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs::aVideoInput

ID of video input where the zooming shall be stopped.

Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction Class Reference

  • GeViAction
Public Member Functions | Public Attributes | Protected Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction Class Reference

Inherits GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Inherited by GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode, and GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder.

Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction:
[legend]

List of all members.

Public Member Functions

GeViAction^ | InternalFromNativeAction (CGeViMessage *nativeAction)

Public Attributes

const GeViActionKind | _ActionKind
const GeViActionCode | _ActionCode

Protected Member Functions

GeViAction (GeViActionKind actionKind, GeViActionCode actionCode)

Constructor & Destructor Documentation

GeViAction::GeViAction | ( | GeViActionKind | actionKind,
 |  | GeViActionCode | actionCode
 | ) |  | [protected]

Member Function Documentation

GeViAction GeViAction::InternalFromNativeAction ( CGeViMessage * nativeAction )

Member Data Documentation

const GeViActionCode GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction::_ActionCode
const GeViActionKind GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction::_ActionKind
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData Struct Reference

  • GeViActionData
Public Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData Struct Reference

GeViSoft Action Data. More...

List of all members.

Public Attributes

System::String^ _ActionData

Detailed Description

GeViSoft Action Data.

Member Data Documentation

System::String ^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData::_ActionData
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase Class Reference

  • GeViDatabase
Public Member Functions | Protected Member Functions | Events | Private Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase Class Reference
Database Functions
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase:
[legend]

List of all members.

Public Member Functions

GeViDatabase ()
~GeViDatabase ()
!GeViDatabase ()
void | Create (String^ address, String^ username, String^ plainTextPassword)
Initalizes the connection to the GeViSoft Server.
void | Create (String^ address, String^ username, String^ plainTextPassword, String^ username2, String^ plainTextPassword2)
Initalizes the connection to the GeViSoft Server.
GeViConnectResult | Connect ()
Starts the connection to the GeViSoft Server.
bool | Disconnect ()
Disconnects from a remote GeViSoft database object. Use this function to terminate your GeViSoft connection.
bool | SendPing ()
Sends a ping to the server for keep-alive checking. The function sends a ping packet to the server and waits for an answer. Best practice is to call this function regularly for a heartbeat check. If the return value is false, a new connection should be established.
bool | SendMessage (String^ message)
Sends a GeViMessage to the Server.
bool | SendMessage (GeViMessage^ message)
Sends a GeViMessage to the Server.
bool | SendMessage (String^ gscServerName, GscAction^ gscAct)
Sends a GeViScope Action to the Server.
bool | SendQuery (GeViMessage^ message,[Out] GeViMessage^ %answer)
Sends a GeViScope State or Database Query to the Server. Please note that the call to SendQuery is blocking until the server sends an answer or the timeout is reached.
bool | RegisterCallback ()
Registers the Database notification callback.
void | SetQueryTimeoutInMs (int timeout)
Sets the SendQuery timeout period.
Default is 3000ms.

Protected Member Functions

virtual void | OnConnectProgress (GeViSoftConnectProgressEventArgs^ e)
virtual void | OnDatabaseNotification (GeViSoftDatabaseNotificationEventArgs^ e)
virtual void | OnGscAction (GeViAct_GscActionEventArgs^ e)
virtual void | OnNewAckAlarmByInstance (GeViAct_AckAlarmByInstanceEventArgs^ e)
virtual void | OnNewAckAlarmByMG (GeViAct_AckAlarmByMGEventArgs^ e)
virtual void | OnNewAckAlarmByType (GeViAct_AckAlarmByTypeEventArgs^ e)
virtual void | OnNewAckAllAlarmsOnMG (GeViAct_AckAllAlarmsOnMGEventArgs^ e)
virtual void | OnNewActionByName (GeViAct_ActionByNameEventArgs^ e)
virtual void | OnNewActionDataCorrupt (GeViAct_ActionDataCorruptEventArgs^ e)
virtual void | OnNewActivateAssignmentProfile (GeViAct_ActivateAssignmentProfileEventArgs^ e)
virtual void | OnNewAlarmAcked (GeViAct_AlarmAckedEventArgs^ e)
virtual void | OnNewAlarmCopied (GeViAct_AlarmCopiedEventArgs^ e)
virtual void | OnNewAlarmDisplayed (GeViAct_AlarmDisplayedEventArgs^ e)
virtual void | OnNewAlarmMoved (GeViAct_AlarmMovedEventArgs^ e)
virtual void | OnNewAlarmQuitted (GeViAct_AlarmQuittedEventArgs^ e)
virtual void | OnNewAlarmRetriggered (GeViAct_AlarmRetriggeredEventArgs^ e)
virtual void | OnNewAlarmStarted (GeViAct_AlarmStartedEventArgs^ e)
virtual void | OnNewAlternateContact (GeViAct_AlternateContactEventArgs^ e)
virtual void | OnNewCameraAutoFocusOff (GeViAct_CameraAutoFocusOffEventArgs^ e)
virtual void | OnNewCameraAutoFocusOn (GeViAct_CameraAutoFocusOnEventArgs^ e)
virtual void | OnNewCameraClearPrePosText (GeViAct_CameraClearPrePosTextEventArgs^ e)
virtual void | OnNewCameraCycleNext (GeViAct_CameraCycleNextEventArgs^ e)
virtual void | OnNewCameraCyclePause (GeViAct_CameraCyclePauseEventArgs^ e)
virtual void | OnNewCameraCyclePrev (GeViAct_CameraCyclePrevEventArgs^ e)
virtual void | OnNewCameraCycleResume (GeViAct_CameraCycleResumeEventArgs^ e)
virtual void | OnNewCameraCycleStart (GeViAct_CameraCycleStartEventArgs^ e)
virtual void | OnNewCameraCycleStop (GeViAct_CameraCycleStopEventArgs^ e)
virtual void | OnNewCameraLightOff (GeViAct_CameraLightOffEventArgs^ e)
virtual void | OnNewCameraLightOn (GeViAct_CameraLightOnEventArgs^ e)
virtual void | OnNewCameraManualIrisOff (GeViAct_CameraManualIrisOffEventArgs^ e)
virtual void | OnNewCameraManualIrisOn (GeViAct_CameraManualIrisOnEventArgs^ e)
virtual void | OnNewCameraOff (GeViAct_CameraOffEventArgs^ e)
virtual void | OnNewCameraOn (GeViAct_CameraOnEventArgs^ e)
virtual void | OnNewCameraPumpOff (GeViAct_CameraPumpOffEventArgs^ e)
virtual void | OnNewCameraPumpOn (GeViAct_CameraPumpOnEventArgs^ e)
virtual void | OnNewCameraRAWOutput (GeViAct_CameraRAWOutputEventArgs^ e)
virtual void | OnNewCameraSelectCharMode (GeViAct_CameraSelectCharModeEventArgs^ e)
virtual void | OnNewCameraSetCameraText (GeViAct_CameraSetCameraTextEventArgs^ e)
virtual void | OnNewCameraSetPrePosText (GeViAct_CameraSetPrePosTextEventArgs^ e)
virtual void | OnNewCameraSmearAndWashOff (GeViAct_CameraSmearAndWashOffEventArgs^ e)
virtual void | OnNewCameraSmearAndWashOn (GeViAct_CameraSmearAndWashOnEventArgs^ e)
virtual void | OnNewCameraSpec1FuncOff (GeViAct_CameraSpec1FuncOffEventArgs^ e)
virtual void | OnNewCameraSpec1FuncOn (GeViAct_CameraSpec1FuncOnEventArgs^ e)
virtual void | OnNewCameraSpecUFuncOff (GeViAct_CameraSpecUFuncOffEventArgs^ e)
virtual void | OnNewCameraSpecUFuncOn (GeViAct_CameraSpecUFuncOnEventArgs^ e)
virtual void | OnNewCameraSpecVFuncOff (GeViAct_CameraSpecVFuncOffEventArgs^ e)
virtual void | OnNewCameraSpecVFuncOn (GeViAct_CameraSpecVFuncOnEventArgs^ e)
virtual void | OnNewCameraStopAll (GeViAct_CameraStopAllEventArgs^ e)
virtual void | OnNewCameraTextOff (GeViAct_CameraTextOffEventArgs^ e)
virtual void | OnNewCameraTextOn (GeViAct_CameraTextOnEventArgs^ e)
virtual void | OnNewCameraTourNext (GeViAct_CameraTourNextEventArgs^ e)
virtual void | OnNewCameraTourPause (GeViAct_CameraTourPauseEventArgs^ e)
virtual void | OnNewCameraTourPrev (GeViAct_CameraTourPrevEventArgs^ e)
virtual void | OnNewCameraTourResume (GeViAct_CameraTourResumeEventArgs^ e)
virtual void | OnNewCameraTourStart (GeViAct_CameraTourStartEventArgs^ e)
virtual void | OnNewCameraTourStop (GeViAct_CameraTourStopEventArgs^ e)
virtual void | OnNewCameraVerOff (GeViAct_CameraVerOffEventArgs^ e)
virtual void | OnNewChangeRightProfile (GeViAct_ChangeRightProfileEventArgs^ e)
virtual void | OnNewClearAlarmFlagVideoInput (GeViAct_ClearAlarmFlagVideoInputEventArgs^ e)
virtual void | OnNewClearAlarmFlagVideoOutput (GeViAct_ClearAlarmFlagVideoOutputEventArgs^ e)
virtual void | OnNewClearVideoOutput (GeViAct_ClearVideoOutputEventArgs^ e)
virtual void | OnNewCloseContact (GeViAct_CloseContactEventArgs^ e)
virtual void | OnNewCopyActualAlarm (GeViAct_CopyActualAlarmEventArgs^ e)
virtual void | OnNewCopyAlarmByInstance (GeViAct_CopyAlarmByInstanceEventArgs^ e)
virtual void | OnNewCopyCameraOnMonitor (GeViAct_CopyCameraOnMonitorEventArgs^ e)
virtual void | OnNewCrossSwitch (GeViAct_CrossSwitchEventArgs^ e)
virtual void | OnNewCrossSwitchWithAlarm (GeViAct_CrossSwitchWithAlarmEventArgs^ e)
virtual void | OnNewCustomAction (GeViAct_CustomActionEventArgs^ e)
virtual void | OnNewDataBaseFailure (GeViAct_DataBaseFailureEventArgs^ e)
virtual void | OnNewDataBaseMissing (GeViAct_DataBaseMissingEventArgs^ e)
virtual void | OnNewDataBaseReady (GeViAct_DataBaseReadyEventArgs^ e)
virtual void | OnNewDefaultPosCallUp (GeViAct_DefaultPosCallUpEventArgs^ e)
virtual void | OnNewDefaultPosClear (GeViAct_DefaultPosClearEventArgs^ e)
virtual void | OnNewDefaultPosSave (GeViAct_DefaultPosSaveEventArgs^ e)
virtual void | OnNewDisconnectUser (GeViAct_DisconnectUserEventArgs^ e)
virtual void | OnNewEventRelation (GeViAct_EventRelationEventArgs^ e)
virtual void | OnNewEventStarted (GeViAct_EventStartedEventArgs^ e)
virtual void | OnNewEventStopped (GeViAct_EventStoppedEventArgs^ e)
virtual void | OnNewFastetModeOn (GeViAct_FastetModeOnEventArgs^ e)
virtual void | OnNewFocusFar (GeViAct_FocusFarEventArgs^ e)
virtual void | OnNewFocusNear (GeViAct_FocusNearEventArgs^ e)
virtual void | OnNewFocusStop (GeViAct_FocusStopEventArgs^ e)
virtual void | OnNewGeviScopeServerConnected (GeViAct_GeviScopeServerConnectedEventArgs^ e)
virtual void | OnNewGeviScopeServerConnectionFailed (GeViAct_GeviScopeServerConnectionFailedEventArgs^ e)
virtual void | OnNewGeviScopeServerDisconnected (GeViAct_GeviScopeServerDisconnectedEventArgs^ e)
virtual void | OnNewHistoricalAlarm (GeViAct_HistoricalAlarmEventArgs^ e)
virtual void | OnNewHistoricalInput (GeViAct_HistoricalInputEventArgs^ e)
virtual void | OnNewIlluminatorCameraOutput (GeViAct_IlluminatorCameraOutputEventArgs^ e)
virtual void | OnNewIlluminatorDimLevel (GeViAct_IlluminatorDimLevelEventArgs^ e)
virtual void | OnNewIlluminatorGetDimLevel (GeViAct_IlluminatorGetDimLevelEventArgs^ e)
virtual void | OnNewIlluminatorLightOff (GeViAct_IlluminatorLightOffEventArgs^ e)
virtual void | OnNewIlluminatorLightOn (GeViAct_IlluminatorLightOnEventArgs^ e)
virtual void | OnNewIlluminatorOff (GeViAct_IlluminatorOffEventArgs^ e)
virtual void | OnNewIlluminatorOn (GeViAct_IlluminatorOnEventArgs^ e)
virtual void | OnNewIlluminatorSetDimLevel (GeViAct_IlluminatorSetDimLevelEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncUOff (GeViAct_IlluminatorSpecFuncUOffEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncUOn (GeViAct_IlluminatorSpecFuncUOnEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncVOff (GeViAct_IlluminatorSpecFuncVOffEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncVOn (GeViAct_IlluminatorSpecFuncVOnEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncXOff (GeViAct_IlluminatorSpecFuncXOffEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncXOn (GeViAct_IlluminatorSpecFuncXOnEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncYOff (GeViAct_IlluminatorSpecFuncYOffEventArgs^ e)
virtual void | OnNewIlluminatorSpecFuncYOn (GeViAct_IlluminatorSpecFuncYOnEventArgs^ e)
virtual void | OnNewInformAllUsers (GeViAct_InformAllUsersEventArgs^ e)
virtual void | OnNewInformAllUsersMSG (GeViAct_InformAllUsersMSGEventArgs^ e)
virtual void | OnNewInformUser (GeViAct_InformUserEventArgs^ e)
virtual void | OnNewInformUserMSG (GeViAct_InformUserMSGEventArgs^ e)
virtual void | OnNewInputContact (GeViAct_InputContactEventArgs^ e)
virtual void | OnNewInputContactSabotage (GeViAct_InputContactSabotageEventArgs^ e)
virtual void | OnNewIrisClose (GeViAct_IrisCloseEventArgs^ e)
virtual void | OnNewIrisOpen (GeViAct_IrisOpenEventArgs^ e)
virtual void | OnNewIrisStop (GeViAct_IrisStopEventArgs^ e)
virtual void | OnNewLogLastAction (GeViAct_LogLastActionEventArgs^ e)
virtual void | OnNewLogMessage (GeViAct_LogMessageEventArgs^ e)
virtual void | OnNewLogMessageMSG (GeViAct_LogMessageMSGEventArgs^ e)
virtual void | OnNewLogSourceAction (GeViAct_LogSourceActionEventArgs^ e)
virtual void | OnNewMBegAlarmAck (GeViAct_MBegAlarmAckEventArgs^ e)
virtual void | OnNewMBegAlarmQuit (GeViAct_MBegAlarmQuitEventArgs^ e)
virtual void | OnNewMBegAlarmStart (GeViAct_MBegAlarmStartEventArgs^ e)
virtual void | OnNewMBegInitRequest (GeViAct_MBegInitRequestEventArgs^ e)
virtual void | OnNewMBegInitSeq (GeViAct_MBegInitSeqEventArgs^ e)
virtual void | OnNewMBegLockCamera (GeViAct_MBegLockCameraEventArgs^ e)
virtual void | OnNewMBegUnlockCamera (GeViAct_MBegUnlockCameraEventArgs^ e)
virtual void | OnNewMIPAlarmAuxiliaryInput (GeViAct_MIPAlarmAuxiliaryInputEventArgs^ e)
virtual void | OnNewMIPAlarmCable (GeViAct_MIPAlarmCableEventArgs^ e)
virtual void | OnNewMIPAlarmLUTamper (GeViAct_MIPAlarmLUTamperEventArgs^ e)
virtual void | OnNewMIPAlarmPMTamper (GeViAct_MIPAlarmPMTamperEventArgs^ e)
virtual void | OnNewMIPAlarmRMTamper (GeViAct_MIPAlarmRMTamperEventArgs^ e)
virtual void | OnNewMIPAuxiliaryAlarmState (GeViAct_MIPAuxiliaryAlarmStateEventArgs^ e)
virtual void | OnNewMIPAuxiliarySensorStatus (GeViAct_MIPAuxiliarySensorStatusEventArgs^ e)
virtual void | OnNewMIPCableAFaultState (GeViAct_MIPCableAFaultStateEventArgs^ e)
virtual void | OnNewMIPCableBFaultState (GeViAct_MIPCableBFaultStateEventArgs^ e)
virtual void | OnNewMIPDisplaySegmentAlarmState (GeViAct_MIPDisplaySegmentAlarmStateEventArgs^ e)
virtual void | OnNewMIPDisplaySegmentStatus (GeViAct_MIPDisplaySegmentStatusEventArgs^ e)
virtual void | OnNewMIPLUTamperAlarmState (GeViAct_MIPLUTamperAlarmStateEventArgs^ e)
virtual void | OnNewMIPLUTamperStatus (GeViAct_MIPLUTamperStatusEventArgs^ e)
virtual void | OnNewMIPOffline (GeViAct_MIPOfflineEventArgs^ e)
virtual void | OnNewMIPOnline (GeViAct_MIPOnlineEventArgs^ e)
virtual void | OnNewMIPPMComFailState (GeViAct_MIPPMComFailStateEventArgs^ e)
virtual void | OnNewMIPPMTamperAlarmState (GeViAct_MIPPMTamperAlarmStateEventArgs^ e)
virtual void | OnNewMIPPMTamperStatus (GeViAct_MIPPMTamperStatusEventArgs^ e)
virtual void | OnNewMIPQueryInterface (GeViAct_MIPQueryInterfaceEventArgs^ e)
virtual void | OnNewMIPRMComFailState (GeViAct_MIPRMComFailStateEventArgs^ e)
virtual void | OnNewMIPRMTamperAlarmState (GeViAct_MIPRMTamperAlarmStateEventArgs^ e)
virtual void | OnNewMIPRMTamperStatus (GeViAct_MIPRMTamperStatusEventArgs^ e)
virtual void | OnNewMIPSecureAuxiliarySensor (GeViAct_MIPSecureAuxiliarySensorEventArgs^ e)
virtual void | OnNewMIPSecureAuxiliaryTP1 (GeViAct_MIPSecureAuxiliaryTP1EventArgs^ e)
virtual void | OnNewMIPSecureAuxiliaryTP2 (GeViAct_MIPSecureAuxiliaryTP2EventArgs^ e)
virtual void | OnNewMIPSecureDisplaySegment (GeViAct_MIPSecureDisplaySegmentEventArgs^ e)
virtual void | OnNewMIPSecureLU (GeViAct_MIPSecureLUEventArgs^ e)
virtual void | OnNewMIPSecurePM (GeViAct_MIPSecurePMEventArgs^ e)
virtual void | OnNewMIPSecureRM (GeViAct_MIPSecureRMEventArgs^ e)
virtual void | OnNewMIPTurnARelayControl (GeViAct_MIPTurnARelayControlEventArgs^ e)
virtual void | OnNewMIPTurnRelaysOnOneZone (GeViAct_MIPTurnRelaysOnOneZoneEventArgs^ e)
virtual void | OnNewMonitorGroupDisable (GeViAct_MonitorGroupDisableEventArgs^ e)
virtual void | OnNewMonitorGroupEnable (GeViAct_MonitorGroupEnableEventArgs^ e)
virtual void | OnNewMonitorGroupStatusChanged (GeViAct_MonitorGroupStatusChangedEventArgs^ e)
virtual void | OnNewMoveActualAlarm (GeViAct_MoveActualAlarmEventArgs^ e)
virtual void | OnNewMoveAlarmByInstance (GeViAct_MoveAlarmByInstanceEventArgs^ e)
virtual void | OnNewMscEventStarted (GeViAct_MscEventStartedEventArgs^ e)
virtual void | OnNewMscEventStopped (GeViAct_MscEventStoppedEventArgs^ e)
virtual void | OnNewMscServerConnected (GeViAct_MscServerConnectedEventArgs^ e)
virtual void | OnNewMscServerConnectFailed (GeViAct_MscServerConnectFailedEventArgs^ e)
virtual void | OnNewMscServerDisconnect (GeViAct_MscServerDisconnectEventArgs^ e)
virtual void | OnNewMscServerDisconnected (GeViAct_MscServerDisconnectedEventArgs^ e)
virtual void | OnNewMscSetupModified (GeViAct_MscSetupModifiedEventArgs^ e)
virtual void | OnNewNormalModeOn (GeViAct_NormalModeOnEventArgs^ e)
virtual void | OnNewOpenContact (GeViAct_OpenContactEventArgs^ e)
virtual void | OnNewPanAuto (GeViAct_PanAutoEventArgs^ e)
virtual void | OnNewPanLeft (GeViAct_PanLeftEventArgs^ e)
virtual void | OnNewPanRight (GeViAct_PanRightEventArgs^ e)
virtual void | OnNewPanStop (GeViAct_PanStopEventArgs^ e)
virtual void | OnNewPopUpAlarm (GeViAct_PopUpAlarmEventArgs^ e)
virtual void | OnNewPopUpNextAlarm (GeViAct_PopUpNextAlarmEventArgs^ e)
virtual void | OnNewPrePosCallUp (GeViAct_PrePosCallUpEventArgs^ e)
virtual void | OnNewPrePosClear (GeViAct_PrePosClearEventArgs^ e)
virtual void | OnNewPrePosSave (GeViAct_PrePosSaveEventArgs^ e)
virtual void | OnNewQuitAlarmByInstance (GeViAct_QuitAlarmByInstanceEventArgs^ e)
virtual void | OnNewQuitAlarmByMG (GeViAct_QuitAlarmByMGEventArgs^ e)
virtual void | OnNewQuitAlarmByType (GeViAct_QuitAlarmByTypeEventArgs^ e)
virtual void | OnNewQuitAllAlarmsOnMG (GeViAct_QuitAllAlarmsOnMGEventArgs^ e)
virtual void | OnNewRedChangeMaster (GeViAct_RedChangeMasterEventArgs^ e)
virtual void | OnNewRedConnectionMasterChanged (GeViAct_RedConnectionMasterChangedEventArgs^ e)
virtual void | OnNewRedirectResource (GeViAct_RedirectResourceEventArgs^ e)
virtual void | OnNewRedMasterServerChanged (GeViAct_RedMasterServerChangedEventArgs^ e)
virtual void | OnNewRedRedundantLoginFailed (GeViAct_RedRedundantLoginFailedEventArgs^ e)
virtual void | OnNewRedRedundantUserLogin (GeViAct_RedRedundantUserLoginEventArgs^ e)
virtual void | OnNewRescannRequest (GeViAct_RescannRequestEventArgs^ e)
virtual void | OnNewRescannRequestToClient (GeViAct_RescannRequestToClientEventArgs^ e)
virtual void | OnNewRestoreRightProfile (GeViAct_RestoreRightProfileEventArgs^ e)
virtual void | OnNewSendRawData (GeViAct_SendRawDataEventArgs^ e)
virtual void | OnNewSendRawDataMSG (GeViAct_SendRawDataMSGEventArgs^ e)
virtual void | OnNewStartAlarm (GeViAct_StartAlarmEventArgs^ e)
virtual void | OnNewStartEvent (GeViAct_StartEventEventArgs^ e)
virtual void | OnNewStartMscEvent (GeViAct_StartMscEventEventArgs^ e)
virtual void | OnNewStartTimer (GeViAct_StartTimerEventArgs^ e)
virtual void | OnNewStopEventByInstance (GeViAct_StopEventByInstanceEventArgs^ e)
virtual void | OnNewStopEventByType (GeViAct_StopEventByTypeEventArgs^ e)
virtual void | OnNewStopMscEvent (GeViAct_StopMscEventEventArgs^ e)
virtual void | OnNewStopTimer (GeViAct_StopTimerEventArgs^ e)
virtual void | OnNewSyncTimeRequest (GeViAct_SyncTimeRequestEventArgs^ e)
virtual void | OnNewSyncTimeRequestToClient (GeViAct_SyncTimeRequestToClientEventArgs^ e)
virtual void | OnNewSyncTimeSetTime (GeViAct_SyncTimeSetTimeEventArgs^ e)
virtual void | OnNewSyncTimeSetTimeActual (GeViAct_SyncTimeSetTimeActualEventArgs^ e)
virtual void | OnNewSyncTimeSetTimeClient (GeViAct_SyncTimeSetTimeClientEventArgs^ e)
virtual void | OnNewSystemError (GeViAct_SystemErrorEventArgs^ e)
virtual void | OnNewSystemSettingsChanged (GeViAct_SystemSettingsChangedEventArgs^ e)
virtual void | OnNewSystemStarted (GeViAct_SystemStartedEventArgs^ e)
virtual void | OnNewSystemStopped (GeViAct_SystemStoppedEventArgs^ e)
virtual void | OnNewSystemWarning (GeViAct_SystemWarningEventArgs^ e)
virtual void | OnNewTakeCameraControl (GeViAct_TakeCameraControlEventArgs^ e)
virtual void | OnNewTiltDown (GeViAct_TiltDownEventArgs^ e)
virtual void | OnNewTiltStop (GeViAct_TiltStopEventArgs^ e)
virtual void | OnNewTiltUp (GeViAct_TiltUpEventArgs^ e)
virtual void | OnNewTimeRangeEnded (GeViAct_TimeRangeEndedEventArgs^ e)
virtual void | OnNewTimeRangeStarted (GeViAct_TimeRangeStartedEventArgs^ e)
virtual void | OnNewUserLogin (GeViAct_UserLoginEventArgs^ e)
virtual void | OnNewUserLoginFailed (GeViAct_UserLoginFailedEventArgs^ e)
virtual void | OnNewUserLogout (GeViAct_UserLogoutEventArgs^ e)
virtual void | OnNewVideoClearTextOut (GeViAct_VideoClearTextOutEventArgs^ e)
virtual void | OnNewVideoContrastAlarm (GeViAct_VideoContrastAlarmEventArgs^ e)
virtual void | OnNewVideoContrastOk (GeViAct_VideoContrastOkEventArgs^ e)
virtual void | OnNewVideoContrastPreAlarm (GeViAct_VideoContrastPreAlarmEventArgs^ e)
virtual void | OnNewVideoSyncFailure (GeViAct_VideoSyncFailureEventArgs^ e)
virtual void | OnNewVideoSyncOk (GeViAct_VideoSyncOkEventArgs^ e)
virtual void | OnNewVideoTextOut (GeViAct_VideoTextOutEventArgs^ e)
virtual void | OnNewVideoThresholdRequest (GeViAct_VideoThresholdRequestEventArgs^ e)
virtual void | OnNewVideoThresholdValue (GeViAct_VideoThresholdValueEventArgs^ e)
virtual void | OnNewVS30PMMode (GeViAct_VS30PMModeEventArgs^ e)
virtual void | OnNewVS30VMDMode (GeViAct_VS30VMDModeEventArgs^ e)
virtual void | OnNewVSAlarmEnd (GeViAct_VSAlarmEndEventArgs^ e)
virtual void | OnNewVSAlarmExtern (GeViAct_VSAlarmExternEventArgs^ e)
virtual void | OnNewVSAlarmInField (GeViAct_VSAlarmInFieldEventArgs^ e)
virtual void | OnNewVSAllTestAlarm (GeViAct_VSAllTestAlarmEventArgs^ e)
virtual void | OnNewVSAllTimerReset (GeViAct_VSAllTimerResetEventArgs^ e)
virtual void | OnNewVSArmed (GeViAct_VSArmedEventArgs^ e)
virtual void | OnNewVSChooseSavedPicture (GeViAct_VSChooseSavedPictureEventArgs^ e)
virtual void | OnNewVSPictureDetect (GeViAct_VSPictureDetectEventArgs^ e)
virtual void | OnNewVSPictureToCommonOut (GeViAct_VSPictureToCommonOutEventArgs^ e)
virtual void | OnNewVSPictureToOutput (GeViAct_VSPictureToOutputEventArgs^ e)
virtual void | OnNewVSPreAlarm (GeViAct_VSPreAlarmEventArgs^ e)
virtual void | OnNewVSRecorderEnd (GeViAct_VSRecorderEndEventArgs^ e)
virtual void | OnNewVSRecorderTimerReset (GeViAct_VSRecorderTimerResetEventArgs^ e)
virtual void | OnNewVSSetAllArmed (GeViAct_VSSetAllArmedEventArgs^ e)
virtual void | OnNewVSSetArmed (GeViAct_VSSetArmedEventArgs^ e)
virtual void | OnNewVSSetDateAndTime (GeViAct_VSSetDateAndTimeEventArgs^ e)
virtual void | OnNewVSSetMode (GeViAct_VSSetModeEventArgs^ e)
virtual void | OnNewVSSetSensorMode (GeViAct_VSSetSensorModeEventArgs^ e)
virtual void | OnNewVSSetSensorOutput (GeViAct_VSSetSensorOutputEventArgs^ e)
virtual void | OnNewVSSyncSignalDetect (GeViAct_VSSyncSignalDetectEventArgs^ e)
virtual void | OnNewVSTestAlarm (GeViAct_VSTestAlarmEventArgs^ e)
virtual void | OnNewVSTimerReset (GeViAct_VSTimerResetEventArgs^ e)
virtual void | OnNewVSVMDMode (GeViAct_VSVMDModeEventArgs^ e)
virtual void | OnNewVSVMDOutOfOrder (GeViAct_VSVMDOutOfOrderEventArgs^ e)
virtual void | OnNewVX3SystemReset (GeViAct_VX3SystemResetEventArgs^ e)
virtual void | OnNewZoomIn (GeViAct_ZoomInEventArgs^ e)
virtual void | OnNewZoomOut (GeViAct_ZoomOutEventArgs^ e)
virtual void | OnNewZoomStop (GeViAct_ZoomStopEventArgs^ e)

Events

GeViSoftConnectProgressEventHandler^ | ConnectProgress
GeViSoftDatabaseNotificationEventHandler^ | DatabaseNotification
GeViAct_GscActionEventHandler^ | ReceivedGscAction
GeViAct_AckAlarmByInstanceEventHandler^ | ReceivedAckAlarmByInstance
Event for action 'Acknowledgement of the alarm'.
GeViAct_AckAlarmByMGEventHandler^ | ReceivedAckAlarmByMG
Event for action 'Acknowledge of the actual alarm on a moitor group'.
GeViAct_AckAlarmByTypeEventHandler^ | ReceivedAckAlarmByType
Event for action 'Acknowledge the alarm'.
GeViAct_AckAllAlarmsOnMGEventHandler^ | ReceivedAckAllAlarmsOnMG
Event for action 'Acknowledge of all alarms on a moitor group'.
GeViAct_ActionByNameEventHandler^ | ReceivedActionByName
Event for action 'Execution of a named action'.
GeViAct_ActionDataCorruptEventHandler^ | ReceivedActionDataCorrupt
Event for action 'The action data can not be found in the data base.'.
GeViAct_ActivateAssignmentProfileEventHandler^ | ReceivedActivateAssignmentProfile
Event for action 'Activate state profile'.
GeViAct_AlarmAckedEventHandler^ | ReceivedAlarmAcked
Event for action 'Alarm was acknowledged'.
GeViAct_AlarmCopiedEventHandler^ | ReceivedAlarmCopied
Event for action 'An alarm was copied from one monitor group to an other'.
GeViAct_AlarmDisplayedEventHandler^ | ReceivedAlarmDisplayed
Event for action 'Trigger by the display of the alarm'.
GeViAct_AlarmMovedEventHandler^ | ReceivedAlarmMoved
Event for action 'An alarm was moved from one monitor group to an other.'.
GeViAct_AlarmQuittedEventHandler^ | ReceivedAlarmQuitted
Event for action 'Alarm was quitted'.
GeViAct_AlarmRetriggeredEventHandler^ | ReceivedAlarmRetriggered
Event for action 'Alarm was restarted (retriggered)'.
GeViAct_AlarmStartedEventHandler^ | ReceivedAlarmStarted
Event for action 'Alarm was started'.
GeViAct_AlternateContactEventHandler^ | ReceivedAlternateContact
Event for action 'Flash contact'.
GeViAct_CameraAutoFocusOffEventHandler^ | ReceivedCameraAutoFocusOff
Event for action 'Turn off the auto focus of the camera'.
GeViAct_CameraAutoFocusOnEventHandler^ | ReceivedCameraAutoFocusOn
Event for action 'Turn on the auto focus of the camera'.
GeViAct_CameraClearPrePosTextEventHandler^ | ReceivedCameraClearPrePosText
Event for action 'Delete text at the predefined position'.
GeViAct_CameraCycleNextEventHandler^ | ReceivedCameraCycleNext
Event for action 'Next camera in camera cycle'.
GeViAct_CameraCyclePauseEventHandler^ | ReceivedCameraCyclePause
Event for action 'Pause camera cycle'.
GeViAct_CameraCyclePrevEventHandler^ | ReceivedCameraCyclePrev
Event for action 'Previous camera in camera cycle'.
GeViAct_CameraCycleResumeEventHandler^ | ReceivedCameraCycleResume
Event for action 'Resume camera cycle'.
GeViAct_CameraCycleStartEventHandler^ | ReceivedCameraCycleStart
Event for action 'Start of the camera-cycle'.
GeViAct_CameraCycleStopEventHandler^ | ReceivedCameraCycleStop
Event for action 'Stopp camera cycle'.
GeViAct_CameraLightOffEventHandler^ | ReceivedCameraLightOff
Event for action 'Turn off camera light'.
GeViAct_CameraLightOnEventHandler^ | ReceivedCameraLightOn
Event for action 'Turn on camera light'.
GeViAct_CameraManualIrisOffEventHandler^ | ReceivedCameraManualIrisOff
Event for action 'Turn off the manual iris of the camera'.
GeViAct_CameraManualIrisOnEventHandler^ | ReceivedCameraManualIrisOn
Event for action 'Turn on the manual iris of the camera'.
GeViAct_CameraOffEventHandler^ | ReceivedCameraOff
Event for action 'Turn a camera off'.
GeViAct_CameraOnEventHandler^ | ReceivedCameraOn
Event for action 'Turn on a camera'.
GeViAct_CameraPumpOffEventHandler^ | ReceivedCameraPumpOff
Event for action 'Turn of pump of a camera'.
GeViAct_CameraPumpOnEventHandler^ | ReceivedCameraPumpOn
Event for action 'Turn on pump of a camera'.
GeViAct_CameraRAWOutputEventHandler^ | ReceivedCameraRAWOutput
Event for action 'Output of a direct command to the camera'.
GeViAct_CameraSelectCharModeEventHandler^ | ReceivedCameraSelectCharMode
Event for action 'Select character set.'.
GeViAct_CameraSetCameraTextEventHandler^ | ReceivedCameraSetCameraText
Event for action 'Set a camera text'.
GeViAct_CameraSetPrePosTextEventHandler^ | ReceivedCameraSetPrePosText
Event for action 'Set text on a predefinied position'.
GeViAct_CameraSmearAndWashOffEventHandler^ | ReceivedCameraSmearAndWashOff
Event for action 'Turn off wiping a camera'.
GeViAct_CameraSmearAndWashOnEventHandler^ | ReceivedCameraSmearAndWashOn
Event for action 'Turn on the wiping and washing of a camera'.
GeViAct_CameraSpec1FuncOffEventHandler^ | ReceivedCameraSpec1FuncOff
Event for action 'Turn off special function 1'.
GeViAct_CameraSpec1FuncOnEventHandler^ | ReceivedCameraSpec1FuncOn
Event for action 'Turn on special function 1'.
GeViAct_CameraSpecUFuncOffEventHandler^ | ReceivedCameraSpecUFuncOff
Event for action 'Turn off special function U'.
GeViAct_CameraSpecUFuncOnEventHandler^ | ReceivedCameraSpecUFuncOn
Event for action 'Turn on special function U'.
GeViAct_CameraSpecVFuncOffEventHandler^ | ReceivedCameraSpecVFuncOff
Event for action 'Turn off special function V'.
GeViAct_CameraSpecVFuncOnEventHandler^ | ReceivedCameraSpecVFuncOn
Event for action 'Turn on special function V'.
GeViAct_CameraStopAllEventHandler^ | ReceivedCameraStopAll
Event for action 'Turn on displaying of firmware version'.
GeViAct_CameraTextOffEventHandler^ | ReceivedCameraTextOff
Event for action 'Turn off the camera text'.
GeViAct_CameraTextOnEventHandler^ | ReceivedCameraTextOn
Event for action 'Turn on the camera text'.
GeViAct_CameraTourNextEventHandler^ | ReceivedCameraTourNext
Event for action 'Next position in the camera tour'.
GeViAct_CameraTourPauseEventHandler^ | ReceivedCameraTourPause
Event for action 'Pause the camera tour'.
GeViAct_CameraTourPrevEventHandler^ | ReceivedCameraTourPrev
Event for action 'Previous position in the camera tour'.
GeViAct_CameraTourResumeEventHandler^ | ReceivedCameraTourResume
Event for action 'Resume the camera tour'.
GeViAct_CameraTourStartEventHandler^ | ReceivedCameraTourStart
Event for action 'Start of the camera tour'.
GeViAct_CameraTourStopEventHandler^ | ReceivedCameraTourStop
Event for action 'Stop the camera tour'.
GeViAct_CameraVerOffEventHandler^ | ReceivedCameraVerOff
Event for action 'Turn off displaying of the firmware version'.
GeViAct_ChangeRightProfileEventHandler^ | ReceivedChangeRightProfile
Event for action 'Change right profile of a user'.
GeViAct_ClearAlarmFlagVideoInputEventHandler^ | ReceivedClearAlarmFlagVideoInput
Event for action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.
GeViAct_ClearAlarmFlagVideoOutputEventHandler^ | ReceivedClearAlarmFlagVideoOutput
Event for action 'Clear the alarm flag of that video output'.
GeViAct_ClearVideoOutputEventHandler^ | ReceivedClearVideoOutput
Event for action 'Clear that video output'.
GeViAct_CloseContactEventHandler^ | ReceivedCloseContact
Event for action 'Close a contact'.
GeViAct_CopyActualAlarmEventHandler^ | ReceivedCopyActualAlarm
Event for action 'Copy actual alarm to an other monitor group'.
GeViAct_CopyAlarmByInstanceEventHandler^ | ReceivedCopyAlarmByInstance
Event for action 'Copy the alarm to an other monitor group'.
GeViAct_CopyCameraOnMonitorEventHandler^ | ReceivedCopyCameraOnMonitor
Event for action 'Copy a video input from one video output to another one.'.
GeViAct_CrossSwitchEventHandler^ | ReceivedCrossSwitch
Event for action 'Switch a video input on a video output'.
GeViAct_CrossSwitchWithAlarmEventHandler^ | ReceivedCrossSwitchWithAlarm
Event for action 'Switch a video input on a video output'.
GeViAct_CustomActionEventHandler^ | ReceivedCustomAction
Event for action 'Customized action'.
GeViAct_DataBaseFailureEventHandler^ | ReceivedDataBaseFailure
Event for action 'Database failure.'.
GeViAct_DataBaseMissingEventHandler^ | ReceivedDataBaseMissing
Event for action 'Missing database'.
GeViAct_DataBaseReadyEventHandler^ | ReceivedDataBaseReady
Event for action 'The database is ready.'.
GeViAct_DefaultPosCallUpEventHandler^ | ReceivedDefaultPosCallUp
Event for action 'Move camera to a base position'.
GeViAct_DefaultPosClearEventHandler^ | ReceivedDefaultPosClear
Event for action 'Clear base position of a camera.'.
GeViAct_DefaultPosSaveEventHandler^ | ReceivedDefaultPosSave
Event for action 'Save the base position of a camera'.
GeViAct_DisconnectUserEventHandler^ | ReceivedDisconnectUser
Event for action 'Explizit logoff of a user'.
GeViAct_EventRelationEventHandler^ | ReceivedEventRelation
Event for action 'Event relation was triggered'.
GeViAct_EventStartedEventHandler^ | ReceivedEventStarted
Event for action 'Start of event'.
GeViAct_EventStoppedEventHandler^ | ReceivedEventStopped
Event for action 'Stopp of event'.
GeViAct_FastetModeOnEventHandler^ | ReceivedFastetModeOn
Event for action 'Turn on the fast mode'.
GeViAct_FocusFarEventHandler^ | ReceivedFocusFar
Event for action 'Set camera focus farer'.
GeViAct_FocusNearEventHandler^ | ReceivedFocusNear
Event for action 'Set camera focus nearer'.
GeViAct_FocusStopEventHandler^ | ReceivedFocusStop
Event for action 'Stopp the focussing of a camera'.
GeViAct_GeviScopeServerConnectedEventHandler^ | ReceivedGeviScopeServerConnected
Event for action 'GeviScope server connected'.
GeViAct_GeviScopeServerConnectionFailedEventHandler^ | ReceivedGeviScopeServerConnectionFailed
Event for action 'Open GeviScope connection failed'.
GeViAct_GeviScopeServerDisconnectedEventHandler^ | ReceivedGeviScopeServerDisconnected
Event for action 'GeviScope disconnected'.
GeViAct_HistoricalAlarmEventHandler^ | ReceivedHistoricalAlarm
Event for action 'Historical alarm message.'.
GeViAct_HistoricalInputEventHandler^ | ReceivedHistoricalInput
Event for action 'Historical contact message.'.
GeViAct_IlluminatorCameraOutputEventHandler^ | ReceivedIlluminatorCameraOutput
Event for action 'Output command to the connected camera'.
GeViAct_IlluminatorDimLevelEventHandler^ | ReceivedIlluminatorDimLevel
Event for action 'The current dim level of the illuminator'.
GeViAct_IlluminatorGetDimLevelEventHandler^ | ReceivedIlluminatorGetDimLevel
Event for action 'Get the dim level of the illuminator'.
GeViAct_IlluminatorLightOffEventHandler^ | ReceivedIlluminatorLightOff
Event for action 'Turn off the illuminator light'.
GeViAct_IlluminatorLightOnEventHandler^ | ReceivedIlluminatorLightOn
Event for action 'Turn on the illuminator light'.
GeViAct_IlluminatorOffEventHandler^ | ReceivedIlluminatorOff
Event for action 'Turn off the illuminator'.
GeViAct_IlluminatorOnEventHandler^ | ReceivedIlluminatorOn
Event for action 'Turn on the illuminator'.
GeViAct_IlluminatorSetDimLevelEventHandler^ | ReceivedIlluminatorSetDimLevel
Event for action 'Set the dim level of the illuminator'.
GeViAct_IlluminatorSpecFuncUOffEventHandler^ | ReceivedIlluminatorSpecFuncUOff
Event for action 'Turn off the special function U'.
GeViAct_IlluminatorSpecFuncUOnEventHandler^ | ReceivedIlluminatorSpecFuncUOn
Event for action 'Turn on the special function U'.
GeViAct_IlluminatorSpecFuncVOffEventHandler^ | ReceivedIlluminatorSpecFuncVOff
Event for action 'Turn off the special function V'.
GeViAct_IlluminatorSpecFuncVOnEventHandler^ | ReceivedIlluminatorSpecFuncVOn
Event for action 'Turn on the special function V'.
GeViAct_IlluminatorSpecFuncXOffEventHandler^ | ReceivedIlluminatorSpecFuncXOff
Event for action 'Turn off the special function X'.
GeViAct_IlluminatorSpecFuncXOnEventHandler^ | ReceivedIlluminatorSpecFuncXOn
Event for action 'Turn on the special function X'.
GeViAct_IlluminatorSpecFuncYOffEventHandler^ | ReceivedIlluminatorSpecFuncYOff
Event for action 'Turn off the special function Y'.
GeViAct_IlluminatorSpecFuncYOnEventHandler^ | ReceivedIlluminatorSpecFuncYOn
Event for action 'Turn on the special function Y'.
GeViAct_InformAllUsersEventHandler^ | ReceivedInformAllUsers
Event for action 'Send a message to all users'.
GeViAct_InformAllUsersMSGEventHandler^ | ReceivedInformAllUsersMSG
Event for action 'Send a message to all users'.
GeViAct_InformUserEventHandler^ | ReceivedInformUser
Event for action 'Sending of a message to a user.'.
GeViAct_InformUserMSGEventHandler^ | ReceivedInformUserMSG
Event for action 'Send a message to user'.
GeViAct_InputContactEventHandler^ | ReceivedInputContact
Event for action 'Input event'.
GeViAct_InputContactSabotageEventHandler^ | ReceivedInputContactSabotage
Event for action 'Input event sabotage notification'.
GeViAct_IrisCloseEventHandler^ | ReceivedIrisClose
Event for action 'Close camera iris'.
GeViAct_IrisOpenEventHandler^ | ReceivedIrisOpen
Event for action 'Open the iris of the camera'.
GeViAct_IrisStopEventHandler^ | ReceivedIrisStop
Event for action 'Stopp closing the iris'.
GeViAct_LogLastActionEventHandler^ | ReceivedLogLastAction
Event for action 'The input action of the current action mapping will be logged.'.
GeViAct_LogMessageEventHandler^ | ReceivedLogMessage
Event for action 'Log message'.
GeViAct_LogMessageMSGEventHandler^ | ReceivedLogMessageMSG
Event for action 'Logging of a message'.
GeViAct_LogSourceActionEventHandler^ | ReceivedLogSourceAction
Event for action 'The input action of the first action mapping of this action mapping chain will be logged'.
GeViAct_MBegAlarmAckEventHandler^ | ReceivedMBegAlarmAck
Event for action 'AlarmAck-report at a MBeg'.
GeViAct_MBegAlarmQuitEventHandler^ | ReceivedMBegAlarmQuit
Event for action 'Report of the alarm quitting to a MBeg'.
GeViAct_MBegAlarmStartEventHandler^ | ReceivedMBegAlarmStart
Event for action 'Report of a alarm start at a MBeg'.
GeViAct_MBegInitRequestEventHandler^ | ReceivedMBegInitRequest
Event for action 'Request of a MBeg initialization sequence'.
GeViAct_MBegInitSeqEventHandler^ | ReceivedMBegInitSeq
Event for action 'MBeg init sequence'.
GeViAct_MBegLockCameraEventHandler^ | ReceivedMBegLockCamera
Event for action 'Request the exclusive PTZ control'.
GeViAct_MBegUnlockCameraEventHandler^ | ReceivedMBegUnlockCamera
Event for action 'Release the exclusive PTZ control'.
GeViAct_MIPAlarmAuxiliaryInputEventHandler^ | ReceivedMIPAlarmAuxiliaryInput
Event for action 'MIP alarm auxiliary input'.
GeViAct_MIPAlarmCableEventHandler^ | ReceivedMIPAlarmCable
Event for action 'MIP alarm cable'.
GeViAct_MIPAlarmLUTamperEventHandler^ | ReceivedMIPAlarmLUTamper
Event for action 'MIP alarm LU tamper'.
GeViAct_MIPAlarmPMTamperEventHandler^ | ReceivedMIPAlarmPMTamper
Event for action 'MIP alarm PM tamper'.
GeViAct_MIPAlarmRMTamperEventHandler^ | ReceivedMIPAlarmRMTamper
Event for action 'MIP alarm RM tamper'.
GeViAct_MIPAuxiliaryAlarmStateEventHandler^ | ReceivedMIPAuxiliaryAlarmState
Event for action 'MIP auxiliary alarm state'.
GeViAct_MIPAuxiliarySensorStatusEventHandler^ | ReceivedMIPAuxiliarySensorStatus
Event for action 'MIP auxiliary sensor status'.
GeViAct_MIPCableAFaultStateEventHandler^ | ReceivedMIPCableAFaultState
Event for action 'MIP cable A failure state'.
GeViAct_MIPCableBFaultStateEventHandler^ | ReceivedMIPCableBFaultState
Event for action 'MIP cable B failure state'.
GeViAct_MIPDisplaySegmentAlarmStateEventHandler^ | ReceivedMIPDisplaySegmentAlarmState
Event for action 'MIP display segment alarm state'.
GeViAct_MIPDisplaySegmentStatusEventHandler^ | ReceivedMIPDisplaySegmentStatus
Event for action 'MIP display segment status'.
GeViAct_MIPLUTamperAlarmStateEventHandler^ | ReceivedMIPLUTamperAlarmState
Event for action 'MIP LU tamper alarm state'.
GeViAct_MIPLUTamperStatusEventHandler^ | ReceivedMIPLUTamperStatus
Event for action 'MIP LU tamper status'.
GeViAct_MIPOfflineEventHandler^ | ReceivedMIPOffline
Event for action 'MIP interface offnline'.
GeViAct_MIPOnlineEventHandler^ | ReceivedMIPOnline
Event for action 'MIP interface online'.
GeViAct_MIPPMComFailStateEventHandler^ | ReceivedMIPPMComFailState
Event for action 'MIP PM COM failure state'.
GeViAct_MIPPMTamperAlarmStateEventHandler^ | ReceivedMIPPMTamperAlarmState
Event for action 'MIP PM tamper alarm state'.
GeViAct_MIPPMTamperStatusEventHandler^ | ReceivedMIPPMTamperStatus
Event for action 'MIP PM tamper status'.
GeViAct_MIPQueryInterfaceEventHandler^ | ReceivedMIPQueryInterface
Event for action 'MIP query interface'.
GeViAct_MIPRMComFailStateEventHandler^ | ReceivedMIPRMComFailState
Event for action 'MIP RM COM failure state'.
GeViAct_MIPRMTamperAlarmStateEventHandler^ | ReceivedMIPRMTamperAlarmState
Event for action 'MIP RM tamper alarm state'.
GeViAct_MIPRMTamperStatusEventHandler^ | ReceivedMIPRMTamperStatus
Event for action 'MIP RM tamper status'.
GeViAct_MIPSecureAuxiliarySensorEventHandler^ | ReceivedMIPSecureAuxiliarySensor
Event for action 'MIP secure auxiliary sensor'.
GeViAct_MIPSecureAuxiliaryTP1EventHandler^ | ReceivedMIPSecureAuxiliaryTP1
Event for action 'MIP secure TP 1'.
GeViAct_MIPSecureAuxiliaryTP2EventHandler^ | ReceivedMIPSecureAuxiliaryTP2
Event for action 'MIP secure TP 2'.
GeViAct_MIPSecureDisplaySegmentEventHandler^ | ReceivedMIPSecureDisplaySegment
Event for action 'MIP secure display segment'.
GeViAct_MIPSecureLUEventHandler^ | ReceivedMIPSecureLU
Event for action 'MIP secure LU'.
GeViAct_MIPSecurePMEventHandler^ | ReceivedMIPSecurePM
Event for action 'MIP secure PM'.
GeViAct_MIPSecureRMEventHandler^ | ReceivedMIPSecureRM
Event for action 'MIP secure RM'.
GeViAct_MIPTurnARelayControlEventHandler^ | ReceivedMIPTurnARelayControl
Event for action 'MIP turn a relay control'.
GeViAct_MIPTurnRelaysOnOneZoneEventHandler^ | ReceivedMIPTurnRelaysOnOneZone
Event for action 'MIP turn relay on one zone'.
GeViAct_MonitorGroupDisableEventHandler^ | ReceivedMonitorGroupDisable
Event for action 'Disable monitor group'.
GeViAct_MonitorGroupEnableEventHandler^ | ReceivedMonitorGroupEnable
Event for action 'Enable monitor group'.
GeViAct_MonitorGroupStatusChangedEventHandler^ | ReceivedMonitorGroupStatusChanged
Event for action 'State of a monitor group has changed'.
GeViAct_MoveActualAlarmEventHandler^ | ReceivedMoveActualAlarm
Event for action 'Move alarm to an other monitor group'.
GeViAct_MoveAlarmByInstanceEventHandler^ | ReceivedMoveAlarmByInstance
Event for action 'Move the alarm to an other monitor group'.
GeViAct_MscEventStartedEventHandler^ | ReceivedMscEventStarted
Event for action 'Start of the event'.
GeViAct_MscEventStoppedEventHandler^ | ReceivedMscEventStopped
Event for action 'Stopp of an event'.
GeViAct_MscServerConnectedEventHandler^ | ReceivedMscServerConnected
Event for action 'MULTISCOPE connected'.
GeViAct_MscServerConnectFailedEventHandler^ | ReceivedMscServerConnectFailed
Event for action 'Open MULTISCOPE connection failed'.
GeViAct_MscServerDisconnectEventHandler^ | ReceivedMscServerDisconnect
Event for action 'Close MULTISCOPE connection'.
GeViAct_MscServerDisconnectedEventHandler^ | ReceivedMscServerDisconnected
Event for action 'MULTISCOPE disconnected'.
GeViAct_MscSetupModifiedEventHandler^ | ReceivedMscSetupModified
Event for action 'MULTISCOPE Setup changed'.
GeViAct_NormalModeOnEventHandler^ | ReceivedNormalModeOn
Event for action 'Turn on normal mode'.
GeViAct_OpenContactEventHandler^ | ReceivedOpenContact
Event for action 'Open contact'.
GeViAct_PanAutoEventHandler^ | ReceivedPanAuto
Event for action 'Automatic panning of the camera'.
GeViAct_PanLeftEventHandler^ | ReceivedPanLeft
Event for action 'Pan camera to the left'.
GeViAct_PanRightEventHandler^ | ReceivedPanRight
Event for action 'Pan camera to the right'.
GeViAct_PanStopEventHandler^ | ReceivedPanStop
Event for action 'Stopp panning of the camera'.
GeViAct_PopUpAlarmEventHandler^ | ReceivedPopUpAlarm
Event for action 'Display alarm'.
GeViAct_PopUpNextAlarmEventHandler^ | ReceivedPopUpNextAlarm
Event for action 'Send the actual alarm back in the queue and send the next to the monitors'.
GeViAct_PrePosCallUpEventHandler^ | ReceivedPrePosCallUp
Event for action 'Move camera to a fix position'.
GeViAct_PrePosClearEventHandler^ | ReceivedPrePosClear
Event for action 'Clear fix position of a camera'.
GeViAct_PrePosSaveEventHandler^ | ReceivedPrePosSave
Event for action 'Save a fix position of a camera'.
GeViAct_QuitAlarmByInstanceEventHandler^ | ReceivedQuitAlarmByInstance
Event for action 'Quitting a alarm'.
GeViAct_QuitAlarmByMGEventHandler^ | ReceivedQuitAlarmByMG
Event for action 'Quit an actual alarm on a monitorgroup'.
GeViAct_QuitAlarmByTypeEventHandler^ | ReceivedQuitAlarmByType
Event for action 'Quitting an alarm'.
GeViAct_QuitAllAlarmsOnMGEventHandler^ | ReceivedQuitAllAlarmsOnMG
Event for action 'Quit of all alarms on a moitor group'.
GeViAct_RedChangeMasterEventHandler^ | ReceivedRedChangeMaster
Event for action 'Set new server as master'.
GeViAct_RedConnectionMasterChangedEventHandler^ | ReceivedRedConnectionMasterChanged
Event for action 'Connection master was changed'.
GeViAct_RedirectResourceEventHandler^ | ReceivedRedirectResource
Event for action 'Redirect resource.'.
GeViAct_RedMasterServerChangedEventHandler^ | ReceivedRedMasterServerChanged
Event for action 'Master server was changed'.
GeViAct_RedRedundantLoginFailedEventHandler^ | ReceivedRedRedundantLoginFailed
Event for action 'Redundant login failed'.
GeViAct_RedRedundantUserLoginEventHandler^ | ReceivedRedRedundantUserLogin
Event for action 'Redundant login successful'.
GeViAct_RescannRequestEventHandler^ | ReceivedRescannRequest
Event for action 'Request to all users to perform a rescan'.
GeViAct_RescannRequestToClientEventHandler^ | ReceivedRescannRequestToClient
Event for action 'Request to a user to perform a rescan'.
GeViAct_RestoreRightProfileEventHandler^ | ReceivedRestoreRightProfile
Event for action 'Restore right profile of a user'.
GeViAct_SendRawDataEventHandler^ | ReceivedSendRawData
Event for action 'Output the data to a RAW- or any other serial interface'.
GeViAct_SendRawDataMSGEventHandler^ | ReceivedSendRawDataMSG
Event for action 'Output the data to a RAW- or any other serial interface'.
GeViAct_StartAlarmEventHandler^ | ReceivedStartAlarm
Event for action 'Start of a alarm of a special typ'.
GeViAct_StartEventEventHandler^ | ReceivedStartEvent
Event for action 'Start of event'.
GeViAct_StartMscEventEventHandler^ | ReceivedStartMscEvent
Event for action 'Start of MULTISCOPE event'.
GeViAct_StartTimerEventHandler^ | ReceivedStartTimer
Event for action 'Start timer'.
GeViAct_StopEventByInstanceEventHandler^ | ReceivedStopEventByInstance
Event for action 'Stopp the event'.
GeViAct_StopEventByTypeEventHandler^ | ReceivedStopEventByType
Event for action 'Stopp the event'.
GeViAct_StopMscEventEventHandler^ | ReceivedStopMscEvent
Event for action 'Stopp a MULTISCOPE event'.
GeViAct_StopTimerEventHandler^ | ReceivedStopTimer
Event for action 'Stopp the timer'.
GeViAct_SyncTimeRequestEventHandler^ | ReceivedSyncTimeRequest
Event for action 'Request to all users to perform a time synchronization'.
GeViAct_SyncTimeRequestToClientEventHandler^ | ReceivedSyncTimeRequestToClient
Event for action 'Request to a user to perform a time synchronization'.
GeViAct_SyncTimeSetTimeEventHandler^ | ReceivedSyncTimeSetTime
Event for action 'Explizit setting of date and time'.
GeViAct_SyncTimeSetTimeActualEventHandler^ | ReceivedSyncTimeSetTimeActual
Event for action 'Explizit setting of date and time'.
GeViAct_SyncTimeSetTimeClientEventHandler^ | ReceivedSyncTimeSetTimeClient
Event for action 'Explizit setting of date and time'.
GeViAct_SystemErrorEventHandler^ | ReceivedSystemError
Event for action 'System error'.
GeViAct_SystemSettingsChangedEventHandler^ | ReceivedSystemSettingsChanged
Event for action 'System settings changed.'.
GeViAct_SystemStartedEventHandler^ | ReceivedSystemStarted
Event for action 'The system is starting.'.
GeViAct_SystemStoppedEventHandler^ | ReceivedSystemStopped
Event for action 'The system is stopping.'.
GeViAct_SystemWarningEventHandler^ | ReceivedSystemWarning
Event for action 'System warning'.
GeViAct_TakeCameraControlEventHandler^ | ReceivedTakeCameraControl
Event for action 'Take over camera control'.
GeViAct_TiltDownEventHandler^ | ReceivedTiltDown
Event for action 'Incline the camera down'.
GeViAct_TiltStopEventHandler^ | ReceivedTiltStop
Event for action 'Stopp the inclinig of the camera'.
GeViAct_TiltUpEventHandler^ | ReceivedTiltUp
Event for action 'Incline camera up'.
GeViAct_TimeRangeEndedEventHandler^ | ReceivedTimeRangeEnded
Event for action 'Cancel time range'.
GeViAct_TimeRangeStartedEventHandler^ | ReceivedTimeRangeStarted
Event for action 'Start of the time range'.
GeViAct_UserLoginEventHandler^ | ReceivedUserLogin
Event for action 'User has logged in.'.
GeViAct_UserLoginFailedEventHandler^ | ReceivedUserLoginFailed
Event for action 'Login failed.'.
GeViAct_UserLogoutEventHandler^ | ReceivedUserLogout
Event for action 'User has logged out.'.
GeViAct_VideoClearTextOutEventHandler^ | ReceivedVideoClearTextOut
Event for action 'Clears the free text'.
GeViAct_VideoContrastAlarmEventHandler^ | ReceivedVideoContrastAlarm
Event for action 'The image is disturbed.'.
GeViAct_VideoContrastOkEventHandler^ | ReceivedVideoContrastOk
Event for action 'The contrast is OK again.'.
GeViAct_VideoContrastPreAlarmEventHandler^ | ReceivedVideoContrastPreAlarm
Event for action 'The contrast is critical.'.
GeViAct_VideoSyncFailureEventHandler^ | ReceivedVideoSyncFailure
Event for action 'Sync-signal failure.'.
GeViAct_VideoSyncOkEventHandler^ | ReceivedVideoSyncOk
Event for action 'Sync-signal works correct again.'.
GeViAct_VideoTextOutEventHandler^ | ReceivedVideoTextOut
Event for action 'Display free text on that video output.'.
GeViAct_VideoThresholdRequestEventHandler^ | ReceivedVideoThresholdRequest
Event for action 'Internal action requests the threshold value of an input'.
GeViAct_VideoThresholdValueEventHandler^ | ReceivedVideoThresholdValue
Event for action 'Internal action, return of the threshold value of an input'.
GeViAct_VS30PMModeEventHandler^ | ReceivedVS30PMMode
Event for action 'Mode is 'Working' or 'Setup''.
GeViAct_VS30VMDModeEventHandler^ | ReceivedVS30VMDMode
Event for action 'Mode of the VMD'.
GeViAct_VSAlarmEndEventHandler^ | ReceivedVSAlarmEnd
Event for action 'Alarm has finished.'.
GeViAct_VSAlarmExternEventHandler^ | ReceivedVSAlarmExtern
Event for action 'External alarm'.
GeViAct_VSAlarmInFieldEventHandler^ | ReceivedVSAlarmInField
Event for action 'Alarm in a field'.
GeViAct_VSAllTestAlarmEventHandler^ | ReceivedVSAllTestAlarm
Event for action 'Test alarm for all VMD's of one client.'.
GeViAct_VSAllTimerResetEventHandler^ | ReceivedVSAllTimerReset
Event for action 'Reset of the timers of all VMD of a client.'.
GeViAct_VSArmedEventHandler^ | ReceivedVSArmed
Event for action 'VMD armed or disarmed'.
GeViAct_VSChooseSavedPictureEventHandler^ | ReceivedVSChooseSavedPicture
Event for action 'Choose a saved picture.'.
GeViAct_VSPictureDetectEventHandler^ | ReceivedVSPictureDetect
Event for action 'Picture OK respective picture failure'.
GeViAct_VSPictureToCommonOutEventHandler^ | ReceivedVSPictureToCommonOut
Event for action 'Set one picture to a common output'.
GeViAct_VSPictureToOutputEventHandler^ | ReceivedVSPictureToOutput
Event for action 'Set a picture to an output'.
GeViAct_VSPreAlarmEventHandler^ | ReceivedVSPreAlarm
Event for action 'Prealarm respective bring prealarm to end'.
GeViAct_VSRecorderEndEventHandler^ | ReceivedVSRecorderEnd
Event for action 'The recorder was stopped'.
GeViAct_VSRecorderTimerResetEventHandler^ | ReceivedVSRecorderTimerReset
Event for action 'Reset of timer of the recorder of a VMD.'.
GeViAct_VSSetAllArmedEventHandler^ | ReceivedVSSetAllArmed
Event for action 'All VMD's will be armed or disarmed'.
GeViAct_VSSetArmedEventHandler^ | ReceivedVSSetArmed
Event for action 'Set the VMD armed or disarmed'.
GeViAct_VSSetDateAndTimeEventHandler^ | ReceivedVSSetDateAndTime
Event for action 'Set date and time of a CU.'.
GeViAct_VSSetModeEventHandler^ | ReceivedVSSetMode
Event for action 'Reset timers of all VMD's of a VS-40 interface'.
GeViAct_VSSetSensorModeEventHandler^ | ReceivedVSSetSensorMode
Event for action 'Set mode of the sensor'.
GeViAct_VSSetSensorOutputEventHandler^ | ReceivedVSSetSensorOutput
Event for action 'Change output settings of the sensor'.
GeViAct_VSSyncSignalDetectEventHandler^ | ReceivedVSSyncSignalDetect
Event for action 'Sync signal and picture failure respective Sync signal OK'.
GeViAct_VSTestAlarmEventHandler^ | ReceivedVSTestAlarm
Event for action 'Test alarm'.
GeViAct_VSTimerResetEventHandler^ | ReceivedVSTimerReset
Event for action 'Resez timer of aVMD.'.
GeViAct_VSVMDModeEventHandler^ | ReceivedVSVMDMode
Event for action 'Mode is 'Working' or 'Setup''.
GeViAct_VSVMDOutOfOrderEventHandler^ | ReceivedVSVMDOutOfOrder
Event for action 'VMD Out of order'.
GeViAct_VX3SystemResetEventHandler^ | ReceivedVX3SystemReset
Event for action 'Reset the VX3-system'.
GeViAct_ZoomInEventHandler^ | ReceivedZoomIn
Event for action 'Zooming in the room'.
GeViAct_ZoomOutEventHandler^ | ReceivedZoomOut
Event for action 'Zooming out of the room.'.
GeViAct_ZoomStopEventHandler^ | ReceivedZoomStop
Event for action 'Stop zooming of the camera'.

Private Attributes

HGeViDatabase | m_NativeDatabaseHandle
bool | dipsosed
GeViSoftDatabaseNotificationCallbackWrapper * m_DBNotificationCallbackWrapper
int | m_sendQueryTimeout

Constructor & Destructor Documentation

GeViDatabase::GeViDatabase ( )
GeViDatabase::~GeViDatabase ( )
GeViDatabase::!GeViDatabase ( )

Member Function Documentation

GeViConnectResult GeViDatabase::Connect ( )

Starts the connection to the GeViSoft Server.

Remarks:
Initialize the connection first with Create().
Returns:
Returns the result of the connection attempt.
void GeViDatabase::Create | ( | String^ | address,
 |  | String^ | username,
 |  | String^ | plainTextPassword
 | ) |  |

Initalizes the connection to the GeViSoft Server.

Parameters:
address | Hostname or IP address of the GeViSoft Server.
username | Name of the GeViSoft user account.
plainTextPassword | Password of the GeViSoft user to login.
void GeViDatabase::Create | ( | String^ | address,
 |  | String^ | username,
 |  | String^ | plainTextPassword,
 |  | String^ | username2,
 |  | String^ | plainTextPassword2
 | ) |  |

Initalizes the connection to the GeViSoft Server.

Parameters:
address | Hostname or IP address of the GeViSoft Server.
username | Name of the GeViSoft user account.
plainTextPassword | Password of the GeViSoft user to login.
username2 | Name of the GeViSoft user account. It is only needed for systems that require multiple users to be logged in simultaneously for security reasons (dual control principle - two persons needed for authorization).
plainTextPassword2 | Password of the second GeViSoft user if applicable.
bool GeViDatabase::Disconnect ( )

Disconnects from a remote GeViSoft database object. Use this function to terminate your GeViSoft connection.

Returns:
Returns true if the command was sent to the server.
void GeViDatabase::OnDatabaseNotification ( GeViSoftDatabaseNotificationEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnGscAction ( GeViAct_GscActionEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAckAlarmByInstance ( GeViAct_AckAlarmByInstanceEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAckAlarmByMG ( GeViAct_AckAlarmByMGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAckAlarmByType ( GeViAct_AckAlarmByTypeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAckAllAlarmsOnMG ( GeViAct_AckAllAlarmsOnMGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewActionByName ( GeViAct_ActionByNameEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewActionDataCorrupt ( GeViAct_ActionDataCorruptEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewActivateAssignmentProfile ( GeViAct_ActivateAssignmentProfileEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlarmAcked ( GeViAct_AlarmAckedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlarmCopied ( GeViAct_AlarmCopiedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlarmDisplayed ( GeViAct_AlarmDisplayedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlarmMoved ( GeViAct_AlarmMovedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlarmQuitted ( GeViAct_AlarmQuittedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlarmRetriggered ( GeViAct_AlarmRetriggeredEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlarmStarted ( GeViAct_AlarmStartedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewAlternateContact ( GeViAct_AlternateContactEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraAutoFocusOff ( GeViAct_CameraAutoFocusOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraAutoFocusOn ( GeViAct_CameraAutoFocusOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraClearPrePosText ( GeViAct_CameraClearPrePosTextEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraCycleNext ( GeViAct_CameraCycleNextEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraCyclePause ( GeViAct_CameraCyclePauseEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraCyclePrev ( GeViAct_CameraCyclePrevEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraCycleResume ( GeViAct_CameraCycleResumeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraCycleStart ( GeViAct_CameraCycleStartEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraCycleStop ( GeViAct_CameraCycleStopEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraLightOff ( GeViAct_CameraLightOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraLightOn ( GeViAct_CameraLightOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraManualIrisOff ( GeViAct_CameraManualIrisOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraManualIrisOn ( GeViAct_CameraManualIrisOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraOff ( GeViAct_CameraOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraOn ( GeViAct_CameraOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraPumpOff ( GeViAct_CameraPumpOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraPumpOn ( GeViAct_CameraPumpOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraRAWOutput ( GeViAct_CameraRAWOutputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSelectCharMode ( GeViAct_CameraSelectCharModeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSetCameraText ( GeViAct_CameraSetCameraTextEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSetPrePosText ( GeViAct_CameraSetPrePosTextEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSmearAndWashOff ( GeViAct_CameraSmearAndWashOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSmearAndWashOn ( GeViAct_CameraSmearAndWashOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSpec1FuncOff ( GeViAct_CameraSpec1FuncOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSpec1FuncOn ( GeViAct_CameraSpec1FuncOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSpecUFuncOff ( GeViAct_CameraSpecUFuncOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSpecUFuncOn ( GeViAct_CameraSpecUFuncOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSpecVFuncOff ( GeViAct_CameraSpecVFuncOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraSpecVFuncOn ( GeViAct_CameraSpecVFuncOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraStopAll ( GeViAct_CameraStopAllEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTextOff ( GeViAct_CameraTextOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTextOn ( GeViAct_CameraTextOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTourNext ( GeViAct_CameraTourNextEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTourPause ( GeViAct_CameraTourPauseEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTourPrev ( GeViAct_CameraTourPrevEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTourResume ( GeViAct_CameraTourResumeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTourStart ( GeViAct_CameraTourStartEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraTourStop ( GeViAct_CameraTourStopEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCameraVerOff ( GeViAct_CameraVerOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewChangeRightProfile ( GeViAct_ChangeRightProfileEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewClearAlarmFlagVideoInput ( GeViAct_ClearAlarmFlagVideoInputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewClearAlarmFlagVideoOutput ( GeViAct_ClearAlarmFlagVideoOutputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewClearVideoOutput ( GeViAct_ClearVideoOutputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCloseContact ( GeViAct_CloseContactEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCopyActualAlarm ( GeViAct_CopyActualAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCopyAlarmByInstance ( GeViAct_CopyAlarmByInstanceEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCopyCameraOnMonitor ( GeViAct_CopyCameraOnMonitorEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCrossSwitch ( GeViAct_CrossSwitchEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCrossSwitchWithAlarm ( GeViAct_CrossSwitchWithAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewCustomAction ( GeViAct_CustomActionEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewDataBaseFailure ( GeViAct_DataBaseFailureEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewDataBaseMissing ( GeViAct_DataBaseMissingEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewDataBaseReady ( GeViAct_DataBaseReadyEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewDefaultPosCallUp ( GeViAct_DefaultPosCallUpEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewDefaultPosClear ( GeViAct_DefaultPosClearEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewDefaultPosSave ( GeViAct_DefaultPosSaveEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewDisconnectUser ( GeViAct_DisconnectUserEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewEventRelation ( GeViAct_EventRelationEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewEventStarted ( GeViAct_EventStartedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewEventStopped ( GeViAct_EventStoppedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewFastetModeOn ( GeViAct_FastetModeOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewFocusFar ( GeViAct_FocusFarEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewFocusNear ( GeViAct_FocusNearEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewFocusStop ( GeViAct_FocusStopEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewGeviScopeServerConnected ( GeViAct_GeviScopeServerConnectedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewGeviScopeServerConnectionFailed ( GeViAct_GeviScopeServerConnectionFailedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewGeviScopeServerDisconnected ( GeViAct_GeviScopeServerDisconnectedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewHistoricalAlarm ( GeViAct_HistoricalAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewHistoricalInput ( GeViAct_HistoricalInputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorCameraOutput ( GeViAct_IlluminatorCameraOutputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorDimLevel ( GeViAct_IlluminatorDimLevelEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorGetDimLevel ( GeViAct_IlluminatorGetDimLevelEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorLightOff ( GeViAct_IlluminatorLightOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorLightOn ( GeViAct_IlluminatorLightOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorOff ( GeViAct_IlluminatorOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorOn ( GeViAct_IlluminatorOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSetDimLevel ( GeViAct_IlluminatorSetDimLevelEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncUOff ( GeViAct_IlluminatorSpecFuncUOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncUOn ( GeViAct_IlluminatorSpecFuncUOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncVOff ( GeViAct_IlluminatorSpecFuncVOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncVOn ( GeViAct_IlluminatorSpecFuncVOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncXOff ( GeViAct_IlluminatorSpecFuncXOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncXOn ( GeViAct_IlluminatorSpecFuncXOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncYOff ( GeViAct_IlluminatorSpecFuncYOffEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIlluminatorSpecFuncYOn ( GeViAct_IlluminatorSpecFuncYOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewInformAllUsers ( GeViAct_InformAllUsersEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewInformAllUsersMSG ( GeViAct_InformAllUsersMSGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewInformUser ( GeViAct_InformUserEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewInformUserMSG ( GeViAct_InformUserMSGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewInputContact ( GeViAct_InputContactEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewInputContactSabotage ( GeViAct_InputContactSabotageEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIrisClose ( GeViAct_IrisCloseEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIrisOpen ( GeViAct_IrisOpenEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewIrisStop ( GeViAct_IrisStopEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewLogLastAction ( GeViAct_LogLastActionEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewLogMessage ( GeViAct_LogMessageEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewLogMessageMSG ( GeViAct_LogMessageMSGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewLogSourceAction ( GeViAct_LogSourceActionEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMBegAlarmAck ( GeViAct_MBegAlarmAckEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMBegAlarmQuit ( GeViAct_MBegAlarmQuitEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMBegAlarmStart ( GeViAct_MBegAlarmStartEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMBegInitRequest ( GeViAct_MBegInitRequestEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMBegInitSeq ( GeViAct_MBegInitSeqEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMBegLockCamera ( GeViAct_MBegLockCameraEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMBegUnlockCamera ( GeViAct_MBegUnlockCameraEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPAlarmAuxiliaryInput ( GeViAct_MIPAlarmAuxiliaryInputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPAlarmCable ( GeViAct_MIPAlarmCableEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPAlarmLUTamper ( GeViAct_MIPAlarmLUTamperEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPAlarmPMTamper ( GeViAct_MIPAlarmPMTamperEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPAlarmRMTamper ( GeViAct_MIPAlarmRMTamperEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPAuxiliaryAlarmState ( GeViAct_MIPAuxiliaryAlarmStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPAuxiliarySensorStatus ( GeViAct_MIPAuxiliarySensorStatusEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPCableAFaultState ( GeViAct_MIPCableAFaultStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPCableBFaultState ( GeViAct_MIPCableBFaultStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPDisplaySegmentAlarmState ( GeViAct_MIPDisplaySegmentAlarmStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPDisplaySegmentStatus ( GeViAct_MIPDisplaySegmentStatusEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPLUTamperAlarmState ( GeViAct_MIPLUTamperAlarmStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPLUTamperStatus ( GeViAct_MIPLUTamperStatusEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPOffline ( GeViAct_MIPOfflineEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPOnline ( GeViAct_MIPOnlineEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPPMComFailState ( GeViAct_MIPPMComFailStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPPMTamperAlarmState ( GeViAct_MIPPMTamperAlarmStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPPMTamperStatus ( GeViAct_MIPPMTamperStatusEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPQueryInterface ( GeViAct_MIPQueryInterfaceEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPRMComFailState ( GeViAct_MIPRMComFailStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPRMTamperAlarmState ( GeViAct_MIPRMTamperAlarmStateEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPRMTamperStatus ( GeViAct_MIPRMTamperStatusEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPSecureAuxiliarySensor ( GeViAct_MIPSecureAuxiliarySensorEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPSecureAuxiliaryTP1 ( GeViAct_MIPSecureAuxiliaryTP1EventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPSecureAuxiliaryTP2 ( GeViAct_MIPSecureAuxiliaryTP2EventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPSecureDisplaySegment ( GeViAct_MIPSecureDisplaySegmentEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPSecureLU ( GeViAct_MIPSecureLUEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPSecurePM ( GeViAct_MIPSecurePMEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPSecureRM ( GeViAct_MIPSecureRMEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPTurnARelayControl ( GeViAct_MIPTurnARelayControlEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMIPTurnRelaysOnOneZone ( GeViAct_MIPTurnRelaysOnOneZoneEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMonitorGroupDisable ( GeViAct_MonitorGroupDisableEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMonitorGroupEnable ( GeViAct_MonitorGroupEnableEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMonitorGroupStatusChanged ( GeViAct_MonitorGroupStatusChangedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMoveActualAlarm ( GeViAct_MoveActualAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMoveAlarmByInstance ( GeViAct_MoveAlarmByInstanceEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMscEventStarted ( GeViAct_MscEventStartedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMscEventStopped ( GeViAct_MscEventStoppedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMscServerConnected ( GeViAct_MscServerConnectedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMscServerConnectFailed ( GeViAct_MscServerConnectFailedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMscServerDisconnect ( GeViAct_MscServerDisconnectEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMscServerDisconnected ( GeViAct_MscServerDisconnectedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewMscSetupModified ( GeViAct_MscSetupModifiedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewNormalModeOn ( GeViAct_NormalModeOnEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewOpenContact ( GeViAct_OpenContactEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPanAuto ( GeViAct_PanAutoEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPanLeft ( GeViAct_PanLeftEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPanRight ( GeViAct_PanRightEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPanStop ( GeViAct_PanStopEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPopUpAlarm ( GeViAct_PopUpAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPopUpNextAlarm ( GeViAct_PopUpNextAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPrePosCallUp ( GeViAct_PrePosCallUpEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPrePosClear ( GeViAct_PrePosClearEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewPrePosSave ( GeViAct_PrePosSaveEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewQuitAlarmByInstance ( GeViAct_QuitAlarmByInstanceEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewQuitAlarmByMG ( GeViAct_QuitAlarmByMGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewQuitAlarmByType ( GeViAct_QuitAlarmByTypeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewQuitAllAlarmsOnMG ( GeViAct_QuitAllAlarmsOnMGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRedChangeMaster ( GeViAct_RedChangeMasterEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRedConnectionMasterChanged ( GeViAct_RedConnectionMasterChangedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRedirectResource ( GeViAct_RedirectResourceEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRedMasterServerChanged ( GeViAct_RedMasterServerChangedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRedRedundantLoginFailed ( GeViAct_RedRedundantLoginFailedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRedRedundantUserLogin ( GeViAct_RedRedundantUserLoginEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRescannRequest ( GeViAct_RescannRequestEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRescannRequestToClient ( GeViAct_RescannRequestToClientEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewRestoreRightProfile ( GeViAct_RestoreRightProfileEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSendRawData ( GeViAct_SendRawDataEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSendRawDataMSG ( GeViAct_SendRawDataMSGEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStartAlarm ( GeViAct_StartAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStartEvent ( GeViAct_StartEventEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStartMscEvent ( GeViAct_StartMscEventEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStartTimer ( GeViAct_StartTimerEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStopEventByInstance ( GeViAct_StopEventByInstanceEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStopEventByType ( GeViAct_StopEventByTypeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStopMscEvent ( GeViAct_StopMscEventEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewStopTimer ( GeViAct_StopTimerEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSyncTimeRequest ( GeViAct_SyncTimeRequestEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSyncTimeRequestToClient ( GeViAct_SyncTimeRequestToClientEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSyncTimeSetTime ( GeViAct_SyncTimeSetTimeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSyncTimeSetTimeActual ( GeViAct_SyncTimeSetTimeActualEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSyncTimeSetTimeClient ( GeViAct_SyncTimeSetTimeClientEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSystemError ( GeViAct_SystemErrorEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSystemSettingsChanged ( GeViAct_SystemSettingsChangedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSystemStarted ( GeViAct_SystemStartedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSystemStopped ( GeViAct_SystemStoppedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewSystemWarning ( GeViAct_SystemWarningEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewTakeCameraControl ( GeViAct_TakeCameraControlEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewTiltDown ( GeViAct_TiltDownEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewTiltStop ( GeViAct_TiltStopEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewTiltUp ( GeViAct_TiltUpEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewTimeRangeEnded ( GeViAct_TimeRangeEndedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewTimeRangeStarted ( GeViAct_TimeRangeStartedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewUserLogin ( GeViAct_UserLoginEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewUserLoginFailed ( GeViAct_UserLoginFailedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewUserLogout ( GeViAct_UserLogoutEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoClearTextOut ( GeViAct_VideoClearTextOutEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoContrastAlarm ( GeViAct_VideoContrastAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoContrastOk ( GeViAct_VideoContrastOkEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoContrastPreAlarm ( GeViAct_VideoContrastPreAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoSyncFailure ( GeViAct_VideoSyncFailureEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoSyncOk ( GeViAct_VideoSyncOkEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoTextOut ( GeViAct_VideoTextOutEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoThresholdRequest ( GeViAct_VideoThresholdRequestEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVideoThresholdValue ( GeViAct_VideoThresholdValueEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVS30PMMode ( GeViAct_VS30PMModeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVS30VMDMode ( GeViAct_VS30VMDModeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSAlarmEnd ( GeViAct_VSAlarmEndEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSAlarmExtern ( GeViAct_VSAlarmExternEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSAlarmInField ( GeViAct_VSAlarmInFieldEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSAllTestAlarm ( GeViAct_VSAllTestAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSAllTimerReset ( GeViAct_VSAllTimerResetEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSArmed ( GeViAct_VSArmedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSChooseSavedPicture ( GeViAct_VSChooseSavedPictureEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSPictureDetect ( GeViAct_VSPictureDetectEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSPictureToCommonOut ( GeViAct_VSPictureToCommonOutEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSPictureToOutput ( GeViAct_VSPictureToOutputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSPreAlarm ( GeViAct_VSPreAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSRecorderEnd ( GeViAct_VSRecorderEndEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSRecorderTimerReset ( GeViAct_VSRecorderTimerResetEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSSetAllArmed ( GeViAct_VSSetAllArmedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSSetArmed ( GeViAct_VSSetArmedEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSSetDateAndTime ( GeViAct_VSSetDateAndTimeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSSetMode ( GeViAct_VSSetModeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSSetSensorMode ( GeViAct_VSSetSensorModeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSSetSensorOutput ( GeViAct_VSSetSensorOutputEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSSyncSignalDetect ( GeViAct_VSSyncSignalDetectEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSTestAlarm ( GeViAct_VSTestAlarmEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSTimerReset ( GeViAct_VSTimerResetEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSVMDMode ( GeViAct_VSVMDModeEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVSVMDOutOfOrder ( GeViAct_VSVMDOutOfOrderEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewVX3SystemReset ( GeViAct_VX3SystemResetEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewZoomIn ( GeViAct_ZoomInEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewZoomOut ( GeViAct_ZoomOutEventArgs^ e ) [protected, virtual]
void GeViDatabase::OnNewZoomStop ( GeViAct_ZoomStopEventArgs^ e ) [protected, virtual]
bool GeViDatabase::RegisterCallback ( )

Registers the Database notification callback.

Returns:
Returns true if the command was sent to the server.
bool GeViDatabase::SendMessage ( String^ message )

Sends a GeViMessage to the Server.

Parameters:
message Message to send as a String (e.g. CustomAction(1, "Hello") )
Returns:
Returns true if the command was sent to the server.
bool GeViDatabase::SendMessage ( GeViMessage^ message )

Sends a GeViMessage to the Server.

Parameters:
message Message to send as a GeViMessage instance.
Returns:
Returns true if the command was sent to the server.
bool GeViDatabase::SendMessage | ( | String^ | gscServerName,
 |  | GscAction^ | gscAct
 | ) |  |

Sends a GeViScope Action to the Server.

Parameters:
gscServerName | Alias name of the GeViScope Server the message shall be sent to.
gscAct | Instance of the GeViScope Action that shall be sent.
Returns:
Returns true if the command was sent to the server.
bool GeViDatabase::SendPing ( )

Sends a ping to the server for keep-alive checking. The function sends a ping packet to the server and waits for an answer. Best practice is to call this function regularly for a heartbeat check. If the return value is false, a new connection should be established.

Returns:
true if the connection is established and false if it is interrupted. .
bool GeViDatabase::SendQuery | ( | GeViMessage^ | message,
 |  | [Out] GeViMessage^ % | answer
 | ) |  |

Sends a GeViScope State or Database Query to the Server. Please note that the call to SendQuery is blocking until the server sends an answer or the timeout is reached.

See also:
SetQueryTimeoutInMs for changing the timeout period
Parameters:
message | GeViDBQuery or GeViStateQuery.
answer | Answer of the GeViSoft Server.
Returns:
Returns true if the command was sent to the server.
void GeViDatabase::SetQueryTimeoutInMs ( int timeout )

Sets the SendQuery timeout period.
Default is 3000ms.

Parameters:
timeout Timeout period in ms.

Member Data Documentation

bool GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::dipsosed [private]
GeViSoftDatabaseNotificationCallbackWrapper* GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::m_DBNotificationCallbackWrapper [private]
HGeViDatabase GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::m_NativeDatabaseHandle [private]
int GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::m_sendQueryTimeout [private]

Event Documentation

GeViSoftConnectProgressEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ConnectProgress
GeViSoftDatabaseNotificationEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::DatabaseNotification
GeViAct_AckAlarmByInstanceEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAckAlarmByInstance

Event for action 'Acknowledgement of the alarm'.

GeViAct_AckAlarmByMGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAckAlarmByMG

Event for action 'Acknowledge of the actual alarm on a moitor group'.

GeViAct_AckAlarmByTypeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAckAlarmByType

Event for action 'Acknowledge the alarm'.

GeViAct_AckAllAlarmsOnMGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAckAllAlarmsOnMG

Event for action 'Acknowledge of all alarms on a moitor group'.

GeViAct_ActionByNameEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedActionByName

Event for action 'Execution of a named action'.

GeViAct_ActionDataCorruptEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedActionDataCorrupt

Event for action 'The action data can not be found in the data base.'.

GeViAct_ActivateAssignmentProfileEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedActivateAssignmentProfile

Event for action 'Activate state profile'.

GeViAct_AlarmAckedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlarmAcked

Event for action 'Alarm was acknowledged'.

GeViAct_AlarmCopiedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlarmCopied

Event for action 'An alarm was copied from one monitor group to an other'.

GeViAct_AlarmDisplayedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlarmDisplayed

Event for action 'Trigger by the display of the alarm'.

GeViAct_AlarmMovedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlarmMoved

Event for action 'An alarm was moved from one monitor group to an other.'.

GeViAct_AlarmQuittedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlarmQuitted

Event for action 'Alarm was quitted'.

GeViAct_AlarmRetriggeredEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlarmRetriggered

Event for action 'Alarm was restarted (retriggered)'.

GeViAct_AlarmStartedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlarmStarted

Event for action 'Alarm was started'.

GeViAct_AlternateContactEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedAlternateContact

Event for action 'Flash contact'.

GeViAct_CameraAutoFocusOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraAutoFocusOff

Event for action 'Turn off the auto focus of the camera'.

GeViAct_CameraAutoFocusOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraAutoFocusOn

Event for action 'Turn on the auto focus of the camera'.

GeViAct_CameraClearPrePosTextEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraClearPrePosText

Event for action 'Delete text at the predefined position'.

GeViAct_CameraCycleNextEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraCycleNext

Event for action 'Next camera in camera cycle'.

GeViAct_CameraCyclePauseEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraCyclePause

Event for action 'Pause camera cycle'.

GeViAct_CameraCyclePrevEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraCyclePrev

Event for action 'Previous camera in camera cycle'.

GeViAct_CameraCycleResumeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraCycleResume

Event for action 'Resume camera cycle'.

GeViAct_CameraCycleStartEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraCycleStart

Event for action 'Start of the camera-cycle'.

GeViAct_CameraCycleStopEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraCycleStop

Event for action 'Stopp camera cycle'.

GeViAct_CameraLightOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraLightOff

Event for action 'Turn off camera light'.

GeViAct_CameraLightOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraLightOn

Event for action 'Turn on camera light'.

GeViAct_CameraManualIrisOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraManualIrisOff

Event for action 'Turn off the manual iris of the camera'.

GeViAct_CameraManualIrisOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraManualIrisOn

Event for action 'Turn on the manual iris of the camera'.

GeViAct_CameraOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraOff

Event for action 'Turn a camera off'.

GeViAct_CameraOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraOn

Event for action 'Turn on a camera'.

GeViAct_CameraPumpOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraPumpOff

Event for action 'Turn of pump of a camera'.

GeViAct_CameraPumpOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraPumpOn

Event for action 'Turn on pump of a camera'.

GeViAct_CameraRAWOutputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraRAWOutput

Event for action 'Output of a direct command to the camera'.

GeViAct_CameraSelectCharModeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSelectCharMode

Event for action 'Select character set.'.

GeViAct_CameraSetCameraTextEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSetCameraText

Event for action 'Set a camera text'.

GeViAct_CameraSetPrePosTextEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSetPrePosText

Event for action 'Set text on a predefinied position'.

GeViAct_CameraSmearAndWashOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSmearAndWashOff

Event for action 'Turn off wiping a camera'.

GeViAct_CameraSmearAndWashOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSmearAndWashOn

Event for action 'Turn on the wiping and washing of a camera'.

GeViAct_CameraSpec1FuncOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSpec1FuncOff

Event for action 'Turn off special function 1'.

GeViAct_CameraSpec1FuncOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSpec1FuncOn

Event for action 'Turn on special function 1'.

GeViAct_CameraSpecUFuncOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSpecUFuncOff

Event for action 'Turn off special function U'.

GeViAct_CameraSpecUFuncOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSpecUFuncOn

Event for action 'Turn on special function U'.

GeViAct_CameraSpecVFuncOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSpecVFuncOff

Event for action 'Turn off special function V'.

GeViAct_CameraSpecVFuncOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraSpecVFuncOn

Event for action 'Turn on special function V'.

GeViAct_CameraStopAllEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraStopAll

Event for action 'Turn on displaying of firmware version'.

GeViAct_CameraTextOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTextOff

Event for action 'Turn off the camera text'.

GeViAct_CameraTextOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTextOn

Event for action 'Turn on the camera text'.

GeViAct_CameraTourNextEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTourNext

Event for action 'Next position in the camera tour'.

GeViAct_CameraTourPauseEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTourPause

Event for action 'Pause the camera tour'.

GeViAct_CameraTourPrevEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTourPrev

Event for action 'Previous position in the camera tour'.

GeViAct_CameraTourResumeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTourResume

Event for action 'Resume the camera tour'.

GeViAct_CameraTourStartEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTourStart

Event for action 'Start of the camera tour'.

GeViAct_CameraTourStopEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraTourStop

Event for action 'Stop the camera tour'.

GeViAct_CameraVerOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCameraVerOff

Event for action 'Turn off displaying of the firmware version'.

GeViAct_ChangeRightProfileEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedChangeRightProfile

Event for action 'Change right profile of a user'.

GeViAct_ClearAlarmFlagVideoInputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedClearAlarmFlagVideoInput

Event for action 'Clear the alam flag of a video input. - Attention - the video input will not cleared.'.

GeViAct_ClearAlarmFlagVideoOutputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedClearAlarmFlagVideoOutput

Event for action 'Clear the alarm flag of that video output'.

GeViAct_ClearVideoOutputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedClearVideoOutput

Event for action 'Clear that video output'.

GeViAct_CloseContactEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCloseContact

Event for action 'Close a contact'.

GeViAct_CopyActualAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCopyActualAlarm

Event for action 'Copy actual alarm to an other monitor group'.

GeViAct_CopyAlarmByInstanceEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCopyAlarmByInstance

Event for action 'Copy the alarm to an other monitor group'.

GeViAct_CopyCameraOnMonitorEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCopyCameraOnMonitor

Event for action 'Copy a video input from one video output to another one.'.

GeViAct_CrossSwitchEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCrossSwitch

Event for action 'Switch a video input on a video output'.

GeViAct_CrossSwitchWithAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCrossSwitchWithAlarm

Event for action 'Switch a video input on a video output'.

GeViAct_CustomActionEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedCustomAction

Event for action 'Customized action'.

GeViAct_DataBaseFailureEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedDataBaseFailure

Event for action 'Database failure.'.

GeViAct_DataBaseMissingEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedDataBaseMissing

Event for action 'Missing database'.

GeViAct_DataBaseReadyEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedDataBaseReady

Event for action 'The database is ready.'.

GeViAct_DefaultPosCallUpEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedDefaultPosCallUp

Event for action 'Move camera to a base position'.

GeViAct_DefaultPosClearEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedDefaultPosClear

Event for action 'Clear base position of a camera.'.

GeViAct_DefaultPosSaveEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedDefaultPosSave

Event for action 'Save the base position of a camera'.

GeViAct_DisconnectUserEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedDisconnectUser

Event for action 'Explizit logoff of a user'.

GeViAct_EventRelationEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedEventRelation

Event for action 'Event relation was triggered'.

GeViAct_EventStartedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedEventStarted

Event for action 'Start of event'.

GeViAct_EventStoppedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedEventStopped

Event for action 'Stopp of event'.

GeViAct_FastetModeOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedFastetModeOn

Event for action 'Turn on the fast mode'.

GeViAct_FocusFarEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedFocusFar

Event for action 'Set camera focus farer'.

GeViAct_FocusNearEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedFocusNear

Event for action 'Set camera focus nearer'.

GeViAct_FocusStopEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedFocusStop

Event for action 'Stopp the focussing of a camera'.

GeViAct_GeviScopeServerConnectedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedGeviScopeServerConnected

Event for action 'GeviScope server connected'.

GeViAct_GeviScopeServerConnectionFailedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedGeviScopeServerConnectionFailed

Event for action 'Open GeviScope connection failed'.

GeViAct_GeviScopeServerDisconnectedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedGeviScopeServerDisconnected

Event for action 'GeviScope disconnected'.

GeViAct_HistoricalAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedHistoricalAlarm

Event for action 'Historical alarm message.'.

GeViAct_HistoricalInputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedHistoricalInput

Event for action 'Historical contact message.'.

GeViAct_IlluminatorCameraOutputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorCameraOutput

Event for action 'Output command to the connected camera'.

GeViAct_IlluminatorDimLevelEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorDimLevel

Event for action 'The current dim level of the illuminator'.

GeViAct_IlluminatorGetDimLevelEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorGetDimLevel

Event for action 'Get the dim level of the illuminator'.

GeViAct_IlluminatorLightOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorLightOff

Event for action 'Turn off the illuminator light'.

GeViAct_IlluminatorLightOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorLightOn

Event for action 'Turn on the illuminator light'.

GeViAct_IlluminatorOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorOff

Event for action 'Turn off the illuminator'.

GeViAct_IlluminatorOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorOn

Event for action 'Turn on the illuminator'.

GeViAct_IlluminatorSetDimLevelEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSetDimLevel

Event for action 'Set the dim level of the illuminator'.

GeViAct_IlluminatorSpecFuncUOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncUOff

Event for action 'Turn off the special function U'.

GeViAct_IlluminatorSpecFuncUOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncUOn

Event for action 'Turn on the special function U'.

GeViAct_IlluminatorSpecFuncVOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncVOff

Event for action 'Turn off the special function V'.

GeViAct_IlluminatorSpecFuncVOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncVOn

Event for action 'Turn on the special function V'.

GeViAct_IlluminatorSpecFuncXOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncXOff

Event for action 'Turn off the special function X'.

GeViAct_IlluminatorSpecFuncXOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncXOn

Event for action 'Turn on the special function X'.

GeViAct_IlluminatorSpecFuncYOffEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncYOff

Event for action 'Turn off the special function Y'.

GeViAct_IlluminatorSpecFuncYOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIlluminatorSpecFuncYOn

Event for action 'Turn on the special function Y'.

GeViAct_InformAllUsersEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedInformAllUsers

Event for action 'Send a message to all users'.

GeViAct_InformAllUsersMSGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedInformAllUsersMSG

Event for action 'Send a message to all users'.

GeViAct_InformUserEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedInformUser

Event for action 'Sending of a message to a user.'.

GeViAct_InformUserMSGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedInformUserMSG

Event for action 'Send a message to user'.

GeViAct_InputContactEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedInputContact

Event for action 'Input event'.

GeViAct_InputContactSabotageEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedInputContactSabotage

Event for action 'Input event sabotage notification'.

GeViAct_IrisCloseEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIrisClose

Event for action 'Close camera iris'.

GeViAct_IrisOpenEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIrisOpen

Event for action 'Open the iris of the camera'.

GeViAct_IrisStopEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedIrisStop

Event for action 'Stopp closing the iris'.

GeViAct_LogLastActionEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedLogLastAction

Event for action 'The input action of the current action mapping will be logged.'.

GeViAct_LogMessageEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedLogMessage

Event for action 'Log message'.

GeViAct_LogMessageMSGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedLogMessageMSG

Event for action 'Logging of a message'.

GeViAct_LogSourceActionEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedLogSourceAction

Event for action 'The input action of the first action mapping of this action mapping chain will be logged'.

GeViAct_MBegAlarmAckEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMBegAlarmAck

Event for action 'AlarmAck-report at a MBeg'.

GeViAct_MBegAlarmQuitEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMBegAlarmQuit

Event for action 'Report of the alarm quitting to a MBeg'.

GeViAct_MBegAlarmStartEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMBegAlarmStart

Event for action 'Report of a alarm start at a MBeg'.

GeViAct_MBegInitRequestEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMBegInitRequest

Event for action 'Request of a MBeg initialization sequence'.

GeViAct_MBegInitSeqEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMBegInitSeq

Event for action 'MBeg init sequence'.

GeViAct_MBegLockCameraEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMBegLockCamera

Event for action 'Request the exclusive PTZ control'.

GeViAct_MBegUnlockCameraEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMBegUnlockCamera

Event for action 'Release the exclusive PTZ control'.

GeViAct_MIPAlarmAuxiliaryInputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPAlarmAuxiliaryInput

Event for action 'MIP alarm auxiliary input'.

GeViAct_MIPAlarmCableEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPAlarmCable

Event for action 'MIP alarm cable'.

GeViAct_MIPAlarmLUTamperEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPAlarmLUTamper

Event for action 'MIP alarm LU tamper'.

GeViAct_MIPAlarmPMTamperEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPAlarmPMTamper

Event for action 'MIP alarm PM tamper'.

GeViAct_MIPAlarmRMTamperEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPAlarmRMTamper

Event for action 'MIP alarm RM tamper'.

GeViAct_MIPAuxiliaryAlarmStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPAuxiliaryAlarmState

Event for action 'MIP auxiliary alarm state'.

GeViAct_MIPAuxiliarySensorStatusEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPAuxiliarySensorStatus

Event for action 'MIP auxiliary sensor status'.

GeViAct_MIPCableAFaultStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPCableAFaultState

Event for action 'MIP cable A failure state'.

GeViAct_MIPCableBFaultStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPCableBFaultState

Event for action 'MIP cable B failure state'.

GeViAct_MIPDisplaySegmentAlarmStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPDisplaySegmentAlarmState

Event for action 'MIP display segment alarm state'.

GeViAct_MIPDisplaySegmentStatusEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPDisplaySegmentStatus

Event for action 'MIP display segment status'.

GeViAct_MIPLUTamperAlarmStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPLUTamperAlarmState

Event for action 'MIP LU tamper alarm state'.

GeViAct_MIPLUTamperStatusEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPLUTamperStatus

Event for action 'MIP LU tamper status'.

GeViAct_MIPOfflineEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPOffline

Event for action 'MIP interface offnline'.

GeViAct_MIPOnlineEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPOnline

Event for action 'MIP interface online'.

GeViAct_MIPPMComFailStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPPMComFailState

Event for action 'MIP PM COM failure state'.

GeViAct_MIPPMTamperAlarmStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPPMTamperAlarmState

Event for action 'MIP PM tamper alarm state'.

GeViAct_MIPPMTamperStatusEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPPMTamperStatus

Event for action 'MIP PM tamper status'.

GeViAct_MIPQueryInterfaceEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPQueryInterface

Event for action 'MIP query interface'.

GeViAct_MIPRMComFailStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPRMComFailState

Event for action 'MIP RM COM failure state'.

GeViAct_MIPRMTamperAlarmStateEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPRMTamperAlarmState

Event for action 'MIP RM tamper alarm state'.

GeViAct_MIPRMTamperStatusEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPRMTamperStatus

Event for action 'MIP RM tamper status'.

GeViAct_MIPSecureAuxiliarySensorEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPSecureAuxiliarySensor

Event for action 'MIP secure auxiliary sensor'.

GeViAct_MIPSecureAuxiliaryTP1EventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPSecureAuxiliaryTP1

Event for action 'MIP secure TP 1'.

GeViAct_MIPSecureAuxiliaryTP2EventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPSecureAuxiliaryTP2

Event for action 'MIP secure TP 2'.

GeViAct_MIPSecureDisplaySegmentEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPSecureDisplaySegment

Event for action 'MIP secure display segment'.

GeViAct_MIPSecureLUEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPSecureLU

Event for action 'MIP secure LU'.

GeViAct_MIPSecurePMEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPSecurePM

Event for action 'MIP secure PM'.

GeViAct_MIPSecureRMEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPSecureRM

Event for action 'MIP secure RM'.

GeViAct_MIPTurnARelayControlEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPTurnARelayControl

Event for action 'MIP turn a relay control'.

GeViAct_MIPTurnRelaysOnOneZoneEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMIPTurnRelaysOnOneZone

Event for action 'MIP turn relay on one zone'.

GeViAct_MonitorGroupDisableEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMonitorGroupDisable

Event for action 'Disable monitor group'.

GeViAct_MonitorGroupEnableEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMonitorGroupEnable

Event for action 'Enable monitor group'.

GeViAct_MonitorGroupStatusChangedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMonitorGroupStatusChanged

Event for action 'State of a monitor group has changed'.

GeViAct_MoveActualAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMoveActualAlarm

Event for action 'Move alarm to an other monitor group'.

GeViAct_MoveAlarmByInstanceEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMoveAlarmByInstance

Event for action 'Move the alarm to an other monitor group'.

GeViAct_MscEventStartedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMscEventStarted

Event for action 'Start of the event'.

GeViAct_MscEventStoppedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMscEventStopped

Event for action 'Stopp of an event'.

GeViAct_MscServerConnectedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMscServerConnected

Event for action 'MULTISCOPE connected'.

GeViAct_MscServerConnectFailedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMscServerConnectFailed

Event for action 'Open MULTISCOPE connection failed'.

GeViAct_MscServerDisconnectEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMscServerDisconnect

Event for action 'Close MULTISCOPE connection'.

GeViAct_MscServerDisconnectedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMscServerDisconnected

Event for action 'MULTISCOPE disconnected'.

GeViAct_MscSetupModifiedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedMscSetupModified

Event for action 'MULTISCOPE Setup changed'.

GeViAct_NormalModeOnEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedNormalModeOn

Event for action 'Turn on normal mode'.

GeViAct_OpenContactEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedOpenContact

Event for action 'Open contact'.

GeViAct_PanAutoEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPanAuto

Event for action 'Automatic panning of the camera'.

GeViAct_PanLeftEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPanLeft

Event for action 'Pan camera to the left'.

GeViAct_PanRightEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPanRight

Event for action 'Pan camera to the right'.

GeViAct_PanStopEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPanStop

Event for action 'Stopp panning of the camera'.

GeViAct_PopUpAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPopUpAlarm

Event for action 'Display alarm'.

GeViAct_PopUpNextAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPopUpNextAlarm

Event for action 'Send the actual alarm back in the queue and send the next to the monitors'.

GeViAct_PrePosCallUpEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPrePosCallUp

Event for action 'Move camera to a fix position'.

GeViAct_PrePosClearEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPrePosClear

Event for action 'Clear fix position of a camera'.

GeViAct_PrePosSaveEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedPrePosSave

Event for action 'Save a fix position of a camera'.

GeViAct_QuitAlarmByInstanceEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedQuitAlarmByInstance

Event for action 'Quitting a alarm'.

GeViAct_QuitAlarmByMGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedQuitAlarmByMG

Event for action 'Quit an actual alarm on a monitorgroup'.

GeViAct_QuitAlarmByTypeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedQuitAlarmByType

Event for action 'Quitting an alarm'.

GeViAct_QuitAllAlarmsOnMGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedQuitAllAlarmsOnMG

Event for action 'Quit of all alarms on a moitor group'.

GeViAct_RedChangeMasterEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRedChangeMaster

Event for action 'Set new server as master'.

GeViAct_RedConnectionMasterChangedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRedConnectionMasterChanged

Event for action 'Connection master was changed'.

GeViAct_RedirectResourceEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRedirectResource

Event for action 'Redirect resource.'.

GeViAct_RedMasterServerChangedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRedMasterServerChanged

Event for action 'Master server was changed'.

GeViAct_RedRedundantLoginFailedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRedRedundantLoginFailed

Event for action 'Redundant login failed'.

GeViAct_RedRedundantUserLoginEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRedRedundantUserLogin

Event for action 'Redundant login successful'.

GeViAct_RescannRequestEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRescannRequest

Event for action 'Request to all users to perform a rescan'.

GeViAct_RescannRequestToClientEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRescannRequestToClient

Event for action 'Request to a user to perform a rescan'.

GeViAct_RestoreRightProfileEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedRestoreRightProfile

Event for action 'Restore right profile of a user'.

GeViAct_SendRawDataEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSendRawData

Event for action 'Output the data to a RAW- or any other serial interface'.

GeViAct_SendRawDataMSGEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSendRawDataMSG

Event for action 'Output the data to a RAW- or any other serial interface'.

GeViAct_StartAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStartAlarm

Event for action 'Start of a alarm of a special typ'.

GeViAct_StartEventEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStartEvent

Event for action 'Start of event'.

GeViAct_StartMscEventEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStartMscEvent

Event for action 'Start of MULTISCOPE event'.

GeViAct_StartTimerEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStartTimer

Event for action 'Start timer'.

GeViAct_StopEventByInstanceEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStopEventByInstance

Event for action 'Stopp the event'.

GeViAct_StopEventByTypeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStopEventByType

Event for action 'Stopp the event'.

GeViAct_StopMscEventEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStopMscEvent

Event for action 'Stopp a MULTISCOPE event'.

GeViAct_StopTimerEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedStopTimer

Event for action 'Stopp the timer'.

GeViAct_SyncTimeRequestEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSyncTimeRequest

Event for action 'Request to all users to perform a time synchronization'.

GeViAct_SyncTimeRequestToClientEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSyncTimeRequestToClient

Event for action 'Request to a user to perform a time synchronization'.

GeViAct_SyncTimeSetTimeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSyncTimeSetTime

Event for action 'Explizit setting of date and time'.

GeViAct_SyncTimeSetTimeActualEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSyncTimeSetTimeActual

Event for action 'Explizit setting of date and time'.

GeViAct_SyncTimeSetTimeClientEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSyncTimeSetTimeClient

Event for action 'Explizit setting of date and time'.

GeViAct_SystemErrorEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSystemError

Event for action 'System error'.

GeViAct_SystemSettingsChangedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSystemSettingsChanged

Event for action 'System settings changed.'.

GeViAct_SystemStartedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSystemStarted

Event for action 'The system is starting.'.

GeViAct_SystemStoppedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSystemStopped

Event for action 'The system is stopping.'.

GeViAct_SystemWarningEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedSystemWarning

Event for action 'System warning'.

GeViAct_TakeCameraControlEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedTakeCameraControl

Event for action 'Take over camera control'.

GeViAct_TiltDownEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedTiltDown

Event for action 'Incline the camera down'.

GeViAct_TiltStopEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedTiltStop

Event for action 'Stopp the inclinig of the camera'.

GeViAct_TiltUpEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedTiltUp

Event for action 'Incline camera up'.

GeViAct_TimeRangeEndedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedTimeRangeEnded

Event for action 'Cancel time range'.

GeViAct_TimeRangeStartedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedTimeRangeStarted

Event for action 'Start of the time range'.

GeViAct_UserLoginEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedUserLogin

Event for action 'User has logged in.'.

GeViAct_UserLoginFailedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedUserLoginFailed

Event for action 'Login failed.'.

GeViAct_UserLogoutEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedUserLogout

Event for action 'User has logged out.'.

GeViAct_VideoClearTextOutEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoClearTextOut

Event for action 'Clears the free text'.

GeViAct_VideoContrastAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoContrastAlarm

Event for action 'The image is disturbed.'.

GeViAct_VideoContrastOkEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoContrastOk

Event for action 'The contrast is OK again.'.

GeViAct_VideoContrastPreAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoContrastPreAlarm

Event for action 'The contrast is critical.'.

GeViAct_VideoSyncFailureEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoSyncFailure

Event for action 'Sync-signal failure.'.

GeViAct_VideoSyncOkEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoSyncOk

Event for action 'Sync-signal works correct again.'.

GeViAct_VideoTextOutEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoTextOut

Event for action 'Display free text on that video output.'.

GeViAct_VideoThresholdRequestEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoThresholdRequest

Event for action 'Internal action requests the threshold value of an input'.

GeViAct_VideoThresholdValueEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVideoThresholdValue

Event for action 'Internal action, return of the threshold value of an input'.

GeViAct_VS30PMModeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVS30PMMode

Event for action 'Mode is 'Working' or 'Setup''.

GeViAct_VS30VMDModeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVS30VMDMode

Event for action 'Mode of the VMD'.

GeViAct_VSAlarmEndEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSAlarmEnd

Event for action 'Alarm has finished.'.

GeViAct_VSAlarmExternEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSAlarmExtern

Event for action 'External alarm'.

GeViAct_VSAlarmInFieldEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSAlarmInField

Event for action 'Alarm in a field'.

GeViAct_VSAllTestAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSAllTestAlarm

Event for action 'Test alarm for all VMD's of one client.'.

GeViAct_VSAllTimerResetEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSAllTimerReset

Event for action 'Reset of the timers of all VMD of a client.'.

GeViAct_VSArmedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSArmed

Event for action 'VMD armed or disarmed'.

GeViAct_VSChooseSavedPictureEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSChooseSavedPicture

Event for action 'Choose a saved picture.'.

GeViAct_VSPictureDetectEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSPictureDetect

Event for action 'Picture OK respective picture failure'.

GeViAct_VSPictureToCommonOutEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSPictureToCommonOut

Event for action 'Set one picture to a common output'.

GeViAct_VSPictureToOutputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSPictureToOutput

Event for action 'Set a picture to an output'.

GeViAct_VSPreAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSPreAlarm

Event for action 'Prealarm respective bring prealarm to end'.

GeViAct_VSRecorderEndEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSRecorderEnd

Event for action 'The recorder was stopped'.

GeViAct_VSRecorderTimerResetEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSRecorderTimerReset

Event for action 'Reset of timer of the recorder of a VMD.'.

GeViAct_VSSetAllArmedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSSetAllArmed

Event for action 'All VMD's will be armed or disarmed'.

GeViAct_VSSetArmedEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSSetArmed

Event for action 'Set the VMD armed or disarmed'.

GeViAct_VSSetDateAndTimeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSSetDateAndTime

Event for action 'Set date and time of a CU.'.

GeViAct_VSSetModeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSSetMode

Event for action 'Reset timers of all VMD's of a VS-40 interface'.

GeViAct_VSSetSensorModeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSSetSensorMode

Event for action 'Set mode of the sensor'.

GeViAct_VSSetSensorOutputEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSSetSensorOutput

Event for action 'Change output settings of the sensor'.

GeViAct_VSSyncSignalDetectEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSSyncSignalDetect

Event for action 'Sync signal and picture failure respective Sync signal OK'.

GeViAct_VSTestAlarmEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSTestAlarm

Event for action 'Test alarm'.

GeViAct_VSTimerResetEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSTimerReset

Event for action 'Resez timer of aVMD.'.

GeViAct_VSVMDModeEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSVMDMode

Event for action 'Mode is 'Working' or 'Setup''.

GeViAct_VSVMDOutOfOrderEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVSVMDOutOfOrder

Event for action 'VMD Out of order'.

GeViAct_VX3SystemResetEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedVX3SystemReset

Event for action 'Reset the VX3-system'.

GeViAct_ZoomInEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedZoomIn

Event for action 'Zooming in the room'.

GeViAct_ZoomOutEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedZoomOut

Event for action 'Zooming out of the room.'.

GeViAct_ZoomStopEventHandler^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase::ReceivedZoomStop

Event for action 'Stop zooming of the camera'.

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied Class Reference

  • DataBaseAnswers
  • GeViDBA_AccessDenied
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied Class Reference
Database Queries and Answers

StateAnswer 'Zugriff verweigert.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied:
[legend]

List of all members.

Public Member Functions

GeViDBA_AccessDenied ()
Create the stateanswer 'Zugriff verweigert.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_AccessDenied^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Zugriff verweigert.'.

Constructor & Destructor Documentation

GeViDBA_AccessDenied::GeViDBA_AccessDenied ( )

Create the stateanswer 'Zugriff verweigert.'.

Member Function Documentation

GeViDBA_AccessDenied GeViDBA_AccessDenied::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_AccessDenied::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry Class Reference

  • DataBaseAnswers
  • GeViDBA_ActionEntry
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry Class Reference
Database Queries and Answers

StateAnswer 'Aktions Eintrag'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry:
[legend]

List of all members.

Public Member Functions

GeViDBA_ActionEntry (Int64 initPK, GeViTGeViDateTime initLocalTime, GeViTGeViDateTime initGMTTime, GeViActionData initActionData, String^ initClientName, String^ initClientDesc, String^ initActionText, Int32 initAlarmRelation, Int64 initAlarmReference)
Create the stateanswer 'Aktions Eintrag'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_ActionEntry^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int64 | sPK
PK der Aktion.
GeViTGeViDateTime sLocalTime
Lokale Zeit.
GeViTGeViDateTime sGMTTime
GMT Zeit.
GeViActionData sActionData
BIN-Buffer mit der Aktionsdaten, enthaelt u.a. die ID des Sender.
String^ | sClientName
Name derjenigen, der diese Aktion ausgeloest hat bzw. leer, falls vom Server.
String^ | sClientDesc
Beschreibung des Ausloesers.
String^ | sActionText
U.u. der Begleittext.
Int32 | sAlarmRelation
Beziehung zu dem Alarm (0 - keine, 1 - Startaktion, 2 - Folgektion, 3 - Bestatetiguns- und 4 - Quittierungsaktion)
Int64 | sAlarmReference
FK des Alarms.

Detailed Description

StateAnswer 'Aktions Eintrag'.

Constructor & Destructor Documentation

GeViDBA_ActionEntry::GeViDBA_ActionEntry | ( | Int64 | initPK,
 |  | GeViTGeViDateTime | initLocalTime,
 |  | GeViTGeViDateTime | initGMTTime,
 |  | GeViActionData | initActionData,
 |  | String^ | initClientName,
 |  | String^ | initClientDesc,
 |  | String^ | initActionText,
 |  | Int32 | initAlarmRelation,
 |  | Int64 | initAlarmReference
 | ) |  |

Create the stateanswer 'Aktions Eintrag'.

Member Function Documentation

GeViDBA_ActionEntry GeViDBA_ActionEntry::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_ActionEntry::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViActionData GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sActionData

BIN-Buffer mit der Aktionsdaten, enthaelt u.a. die ID des Sender.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sActionText

U.u. der Begleittext.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sAlarmReference

FK des Alarms.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sAlarmRelation

Beziehung zu dem Alarm (0 - keine, 1 - Startaktion, 2 - Folgektion, 3 - Bestatetiguns- und 4 - Quittierungsaktion)

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sClientDesc

Beschreibung des Ausloesers.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sClientName

Name derjenigen, der diese Aktion ausgeloest hat bzw. leer, falls vom Server.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sGMTTime

GMT Zeit.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sLocalTime

Lokale Zeit.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry::sPK

PK der Aktion.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry Class Reference

  • DataBaseAnswers
  • GeViDBA_AlarmEntry
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry Class Reference
Database Queries and Answers

StateAnswer 'Alarm Eintrag'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry:
[legend]

List of all members.

Public Member Functions

GeViDBA_AlarmEntry (Int64 initPK, GeViTGeViDateTime initLocalTime, GeViTGeViDateTime initGMTTime, Int32 initAlarmType, Int32 initStartMonitorGroup, Boolean initMonitorGroupChanged, Boolean initSomeMscIIEvents, Boolean initAcknowledged, Boolean initQuitted, String^ initAlarmText, String^ initAlarmTypeName, String^ initAlarmTypeDesc, String^ initStartMonitorGroupName, String^ initStartMonitorGroupDesc)
Create the stateanswer 'Alarm Eintrag'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_AlarmEntry^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int64 | sPK
PK des Eintrages.
GeViTGeViDateTime sLocalTime
Lokale Zeit.
GeViTGeViDateTime sGMTTime
GMT Zeit.
Int32 | sAlarmType
TypeID des Alarmes.
Int32 | sStartMonitorGroup
ID der Monitorgruppe, an der Alarm zum ersten Mal angezeigt wurde.
Boolean | sMonitorGroupChanged
Alarm wurde auf mehreren Monitorgruppen dargestellt.
Boolean | sSomeMscIIEvents
Zu diesem Alarm wurde MscII Events abgespeichert.
Boolean | sAcknowledged
Wurde bestaetigt.
Boolean | sQuitted
Wurde quittiert.
String^ | sAlarmText
Begleittext beim Start des Alarmes.
String^ | sAlarmTypeName
Name des Alarmes.
String^ | sAlarmTypeDesc
Die Beschreibung.
String^ | sStartMonitorGroupName
Name der erste MG.
String^ | sStartMonitorGroupDesc
Beschreibung der ersten MG.

Detailed Description

StateAnswer 'Alarm Eintrag'.

Constructor & Destructor Documentation

GeViDBA_AlarmEntry::GeViDBA_AlarmEntry | ( | Int64 | initPK,
 |  | GeViTGeViDateTime | initLocalTime,
 |  | GeViTGeViDateTime | initGMTTime,
 |  | Int32 | initAlarmType,
 |  | Int32 | initStartMonitorGroup,
 |  | Boolean | initMonitorGroupChanged,
 |  | Boolean | initSomeMscIIEvents,
 |  | Boolean | initAcknowledged,
 |  | Boolean | initQuitted,
 |  | String^ | initAlarmText,
 |  | String^ | initAlarmTypeName,
 |  | String^ | initAlarmTypeDesc,
 |  | String^ | initStartMonitorGroupName,
 |  | String^ | initStartMonitorGroupDesc
 | ) |  |

Create the stateanswer 'Alarm Eintrag'.

Member Function Documentation

GeViDBA_AlarmEntry GeViDBA_AlarmEntry::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_AlarmEntry::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sAcknowledged

Wurde bestaetigt.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sAlarmText

Begleittext beim Start des Alarmes.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sAlarmType

TypeID des Alarmes.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sAlarmTypeDesc

Die Beschreibung.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sAlarmTypeName

Name des Alarmes.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sGMTTime

GMT Zeit.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sLocalTime

Lokale Zeit.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sMonitorGroupChanged

Alarm wurde auf mehreren Monitorgruppen dargestellt.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sPK

PK des Eintrages.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sQuitted

Wurde quittiert.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sSomeMscIIEvents

Zu diesem Alarm wurde MscII Events abgespeichert.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sStartMonitorGroup

ID der Monitorgruppe, an der Alarm zum ersten Mal angezeigt wurde.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sStartMonitorGroupDesc

Beschreibung der ersten MG.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry::sStartMonitorGroupName

Name der erste MG.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError Class Reference

  • DataBaseAnswers
  • GeViDBA_DBError
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError Class Reference
Database Queries and Answers

StateAnswer 'Fehler'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError:
[legend]

List of all members.

Public Member Functions

GeViDBA_DBError (Int32 initErrorCode, String^ initErrorText)
Create the stateanswer 'Fehler'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_DBError^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sErrorCode
Fehlercode.
String^ | sErrorText
Fehlerbeschreibung.

Detailed Description

StateAnswer 'Fehler'.

Constructor & Destructor Documentation

GeViDBA_DBError::GeViDBA_DBError | ( | Int32 | initErrorCode,
 |  | String^ | initErrorText
 | ) |  |

Create the stateanswer 'Fehler'.

Member Function Documentation

GeViDBA_DBError GeViDBA_DBError::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_DBError::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError::sErrorCode

Fehlercode.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError::sErrorText

Fehlerbeschreibung.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk Class Reference

  • DataBaseAnswers
  • GeViDBA_DBOk
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk Class Reference
Database Queries and Answers

StateAnswer 'Befehl akzeptiert'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk:
[legend]

List of all members.

Public Member Functions

GeViDBA_DBOk ()
Create the stateanswer 'Befehl akzeptiert'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_DBOk^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Befehl akzeptiert'.

Constructor & Destructor Documentation

GeViDBA_DBOk::GeViDBA_DBOk ( )

Create the stateanswer 'Befehl akzeptiert'.

Member Function Documentation

GeViDBA_DBOk GeViDBA_DBOk::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_DBOk::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated Class Reference

  • DataBaseAnswers
  • GeViDBA_DBTerminated
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated Class Reference
Database Queries and Answers

StateAnswer 'Befehl abgebrochen'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated:
[legend]

List of all members.

Public Member Functions

GeViDBA_DBTerminated ()
Create the stateanswer 'Befehl abgebrochen'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_DBTerminated^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Befehl abgebrochen'.

Constructor & Destructor Documentation

GeViDBA_DBTerminated::GeViDBA_DBTerminated ( )

Create the stateanswer 'Befehl abgebrochen'.

Member Function Documentation

GeViDBA_DBTerminated GeViDBA_DBTerminated::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_DBTerminated::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries Class Reference

  • DataBaseAnswers
  • GeViDBA_DeletedEntries
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries Class Reference
Database Queries and Answers

StateAnswer ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries:
[legend]

List of all members.

Public Member Functions

GeViDBA_DeletedEntries (Int32 initDeletedActions, Int32 initDeletedAlarms)
Create the stateanswer ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_DeletedEntries^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sDeletedActions
Anzahl der geloeschten Aktionen.
Int32 | sDeletedAlarms
Anzahl der geloeschten Alarme.

Detailed Description

StateAnswer ''.

Constructor & Destructor Documentation

GeViDBA_DeletedEntries::GeViDBA_DeletedEntries | ( | Int32 | initDeletedActions,
 |  | Int32 | initDeletedAlarms
 | ) |  |

Create the stateanswer ''.

Member Function Documentation

GeViDBA_DeletedEntries GeViDBA_DeletedEntries::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_DeletedEntries::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries::sDeletedActions

Anzahl der geloeschten Aktionen.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries::sDeletedAlarms

Anzahl der geloeschten Alarme.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing Class Reference

  • DataBaseAnswers
  • GeViDBA_Nothing
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing Class Reference
Database Queries and Answers

StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing:
[legend]

List of all members.

Public Member Functions

GeViDBA_Nothing ()
Create the stateanswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_Nothing^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'.

Constructor & Destructor Documentation

GeViDBA_Nothing::GeViDBA_Nothing ( )

Create the stateanswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'.

Member Function Documentation

GeViDBA_Nothing GeViDBA_Nothing::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_Nothing::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle Class Reference

  • DataBaseAnswers
  • GeViDBA_QueryHandle
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle Class Reference
Database Queries and Answers

StateAnswer 'Liefert der erzeugten Handle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle:
[legend]

List of all members.

Public Member Functions

GeViDBA_QueryHandle (Int64 initHandle)
Create the stateanswer 'Liefert der erzeugten Handle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViDBA_QueryHandle^ | FromNativeDBAnswer (CDataBaseAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int64 | sHandle
Handle zu dieser Anfrage.

Detailed Description

StateAnswer 'Liefert der erzeugten Handle'.

Constructor & Destructor Documentation

GeViDBA_QueryHandle::GeViDBA_QueryHandle ( Int64 initHandle )

Create the stateanswer 'Liefert der erzeugten Handle'.

Member Function Documentation

GeViDBA_QueryHandle GeViDBA_QueryHandle::FromNativeDBAnswer ( CDataBaseAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViDBA_QueryHandle::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle::sHandle

Handle zu dieser Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer Class Reference

  • GeViDBAnswer
Static Public Member Functions | Public Attributes | Protected Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer Class Reference
Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer:
[legend]

List of all members.

Static Public Member Functions

static GeViDBAnswer^ | InternalFromNativeQuery (CDataBaseAnswer *nativeAnswer)

Public Attributes

const GeViDBAnswerKind | _DBAnswerKind

Protected Member Functions

GeViDBAnswer (GeViDBAnswerKind answerKind)

Constructor & Destructor Documentation

GeViDBAnswer::GeViDBAnswer ( GeViDBAnswerKind answerKind ) [protected]

Member Function Documentation

GeViDBAnswer GeViDBAnswer::InternalFromNativeQuery ( CDataBaseAnswer * nativeAnswer ) [static]

Member Data Documentation

const GeViDBAnswerKind GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer::_DBAnswerKind
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind Class Reference

  • DataBaseQueries
  • GeViDBF_ActionKind
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind Class Reference
Database Queries and Answers

StateQuery ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind:
[legend]

List of all members.

Public Member Functions

GeViDBF_ActionKind (Int64 initHandle, Int32 initUp, Int32 initTo)
Create the query ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Int32 | sUp
Von (0 - ohne Einschraenkung)
Int32 | sTo
Bis (0 - ohne Einschraenkung)

Detailed Description

StateQuery ''.

Constructor & Destructor Documentation

GeViDBF_ActionKind::GeViDBF_ActionKind | ( | Int64 | initHandle,
 |  | Int32 | initUp,
 |  | Int32 | initTo
 | ) |  |

Create the query ''.

Member Function Documentation

CGeViMessage * GeViDBF_ActionKind::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind::sHandle

Handle der Anfrage.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind::sTo

Bis (0 - ohne Einschraenkung)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind::sUp

Von (0 - ohne Einschraenkung)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList Class Reference

  • DataBaseQueries
  • GeViDBF_ActionList
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList Class Reference
Database Queries and Answers

StateQuery 'ActionList'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList:
[legend]

List of all members.

Public Member Functions

GeViDBF_ActionList (Int64 initHandle, String^ initActionList)
Create the query 'ActionList'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sActionList
ActionList.

Detailed Description

StateQuery 'ActionList'.

Constructor & Destructor Documentation

GeViDBF_ActionList::GeViDBF_ActionList | ( | Int64 | initHandle,
 |  | String^ | initActionList
 | ) |  |

Create the query 'ActionList'.

Member Function Documentation

CGeViMessage * GeViDBF_ActionList::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList::sActionList

ActionList.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem Class Reference

  • DataBaseQueries
  • GeViDBF_GscSystem
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem Class Reference
Database Queries and Answers

StateQuery 'GscSystem'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem:
[legend]

List of all members.

Public Member Functions

GeViDBF_GscSystem (Int64 initHandle, String^ initGscName)
Create the query 'GscSystem'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sGscName
GscName.

Detailed Description

StateQuery 'GscSystem'.

Constructor & Destructor Documentation

GeViDBF_GscSystem::GeViDBF_GscSystem | ( | Int64 | initHandle,
 |  | String^ | initGscName
 | ) |  |

Create the query 'GscSystem'.

Member Function Documentation

CGeViMessage * GeViDBF_GscSystem::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem::sGscName

GscName.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu Class Reference

  • DataBaseQueries
  • GeViDBF_LocalTime_GrtEqu
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu Class Reference
Database Queries and Answers

StateQuery ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu:
[legend]

List of all members.

Public Member Functions

GeViDBF_LocalTime_GrtEqu (Int64 initHandle, GeViTGeViDateTime initLocalTime)
Create the query ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
GeViTGeViDateTime sLocalTime
Die untere Schranke.

Detailed Description

StateQuery ''.

Constructor & Destructor Documentation

GeViDBF_LocalTime_GrtEqu::GeViDBF_LocalTime_GrtEqu | ( | Int64 | initHandle,
 |  | GeViTGeViDateTime | initLocalTime
 | ) |  |

Create the query ''.

Member Function Documentation

CGeViMessage * GeViDBF_LocalTime_GrtEqu::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu::sHandle

Handle der Anfrage.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu::sLocalTime

Die untere Schranke.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu Class Reference

  • DataBaseQueries
  • GeViDBF_LocalTime_LowEqu
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu Class Reference
Database Queries and Answers

StateQuery ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu:
[legend]

List of all members.

Public Member Functions

GeViDBF_LocalTime_LowEqu (Int64 initHandle, GeViTGeViDateTime initLocalTime)
Create the query ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
GeViTGeViDateTime sLocalTime
Die obere Schranke.

Detailed Description

StateQuery ''.

Constructor & Destructor Documentation

GeViDBF_LocalTime_LowEqu::GeViDBF_LocalTime_LowEqu | ( | Int64 | initHandle,
 |  | GeViTGeViDateTime | initLocalTime
 | ) |  |

Create the query ''.

Member Function Documentation

CGeViMessage * GeViDBF_LocalTime_LowEqu::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu::sHandle

Handle der Anfrage.

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu::sLocalTime

Die obere Schranke.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc Class Reference

  • DataBaseQueries
  • GeViDBF_MonitorGroupDesc
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc Class Reference
Database Queries and Answers

StateQuery ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc:
[legend]

List of all members.

Public Member Functions

GeViDBF_MonitorGroupDesc (Int64 initHandle, String^ initMGDesc, GeViDBCompare initCompare)
Create the query ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sMGDesc
Beschreibung der MG.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery ''.

Constructor & Destructor Documentation

GeViDBF_MonitorGroupDesc::GeViDBF_MonitorGroupDesc | ( | Int64 | initHandle,
 |  | String^ | initMGDesc,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query ''.

Member Function Documentation

CGeViMessage * GeViDBF_MonitorGroupDesc::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc::sMGDesc

Beschreibung der MG.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID Class Reference

  • DataBaseQueries
  • GeViDBF_MonitorGroupID
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID Class Reference
Database Queries and Answers

StateQuery 'MG, wo Alarm praesentiert wurde'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID:
[legend]

List of all members.

Public Member Functions

GeViDBF_MonitorGroupID (Int64 initHandle, Int32 initUp, Int32 initTo)
Create the query 'MG, wo Alarm praesentiert wurde'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Int32 | sUp
Von (0 - ohne Einschraenkung)
Int32 | sTo
Bis (0 - ohne Einschraenkung)

Detailed Description

StateQuery 'MG, wo Alarm praesentiert wurde'.

Constructor & Destructor Documentation

GeViDBF_MonitorGroupID::GeViDBF_MonitorGroupID | ( | Int64 | initHandle,
 |  | Int32 | initUp,
 |  | Int32 | initTo
 | ) |  |

Create the query 'MG, wo Alarm praesentiert wurde'.

Member Function Documentation

CGeViMessage * GeViDBF_MonitorGroupID::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID::sHandle

Handle der Anfrage.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID::sTo

Bis (0 - ohne Einschraenkung)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID::sUp

Von (0 - ohne Einschraenkung)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName Class Reference

  • DataBaseQueries
  • GeViDBF_MonitorGroupName
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName Class Reference
Database Queries and Answers

StateQuery ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName:
[legend]

List of all members.

Public Member Functions

GeViDBF_MonitorGroupName (Int64 initHandle, String^ initMGName, GeViDBCompare initCompare)
Create the query ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sMGName
Name der MG.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery ''.

Constructor & Destructor Documentation

GeViDBF_MonitorGroupName::GeViDBF_MonitorGroupName | ( | Int64 | initHandle,
 |  | String^ | initMGName,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query ''.

Member Function Documentation

CGeViMessage * GeViDBF_MonitorGroupName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName::sMGName

Name der MG.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem Class Reference

  • DataBaseQueries
  • GeViDBF_MscSystem
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem Class Reference
Database Queries and Answers

StateQuery 'MscSystem'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem:
[legend]

List of all members.

Public Member Functions

GeViDBF_MscSystem (Int64 initHandle, String^ initMscName)
Create the query 'MscSystem'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sMscName
MscName.

Detailed Description

StateQuery 'MscSystem'.

Constructor & Destructor Documentation

GeViDBF_MscSystem::GeViDBF_MscSystem | ( | Int64 | initHandle,
 |  | String^ | initMscName
 | ) |  |

Create the query 'MscSystem'.

Member Function Documentation

CGeViMessage * GeViDBF_MscSystem::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem::sMscName

MscName.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu Class Reference

  • DataBaseQueries
  • GeViDBF_PK_GrtEqu
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu Class Reference
Database Queries and Answers

StateQuery 'Primary Key groesser gleich'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu:
[legend]

List of all members.

Public Member Functions

GeViDBF_PK_GrtEqu (Int64 initHandle, Int64 initPK)
Create the query 'Primary Key groesser gleich'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Int64 | sPK
PK Untershranke.

Detailed Description

StateQuery 'Primary Key groesser gleich'.

Constructor & Destructor Documentation

GeViDBF_PK_GrtEqu::GeViDBF_PK_GrtEqu | ( | Int64 | initHandle,
 |  | Int64 | initPK
 | ) |  |

Create the query 'Primary Key groesser gleich'.

Member Function Documentation

CGeViMessage * GeViDBF_PK_GrtEqu::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu::sHandle

Handle der Anfrage.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu::sPK

PK Untershranke.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu Class Reference

  • DataBaseQueries
  • GeViDBF_PK_LowEqu
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu Class Reference
Database Queries and Answers

StateQuery 'Primary Key kleiner gleich'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu:
[legend]

List of all members.

Public Member Functions

GeViDBF_PK_LowEqu (Int64 initHandle, Int64 initPK)
Create the query 'Primary Key kleiner gleich'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Int64 | sPK
PK Oberschranke.

Detailed Description

StateQuery 'Primary Key kleiner gleich'.

Constructor & Destructor Documentation

GeViDBF_PK_LowEqu::GeViDBF_PK_LowEqu | ( | Int64 | initHandle,
 |  | Int64 | initPK
 | ) |  |

Create the query 'Primary Key kleiner gleich'.

Member Function Documentation

CGeViMessage * GeViDBF_PK_LowEqu::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu::sHandle

Handle der Anfrage.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu::sPK

PK Oberschranke.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc Class Reference

  • DataBaseQueries
  • GeViDBF_SenderDesc
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc Class Reference
Database Queries and Answers

StateQuery 'Von welchem Klient kam die Aktion'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc:
[legend]

List of all members.

Public Member Functions

GeViDBF_SenderDesc (Int64 initHandle, String^ initClientDesc, GeViDBCompare initCompare)
Create the query 'Von welchem Klient kam die Aktion'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sClientDesc
Beschreibung des Klienten.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery 'Von welchem Klient kam die Aktion'.

Constructor & Destructor Documentation

GeViDBF_SenderDesc::GeViDBF_SenderDesc | ( | Int64 | initHandle,
 |  | String^ | initClientDesc,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query 'Von welchem Klient kam die Aktion'.

Member Function Documentation

CGeViMessage * GeViDBF_SenderDesc::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc::sClientDesc

Beschreibung des Klienten.

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID Class Reference

  • DataBaseQueries
  • GeViDBF_SenderID
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID Class Reference
Database Queries and Answers

StateQuery 'Von welchem Klient kam die Aktion'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID:
[legend]

List of all members.

Public Member Functions

GeViDBF_SenderID (Int64 initHandle, Int64 initUp, Int64 initTo)
Create the query 'Von welchem Klient kam die Aktion'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Int64 | sUp
Von (0 - ohne Einschraenkung)
Int64 | sTo
Bis (0 - ohne Einschraenkung)

Detailed Description

StateQuery 'Von welchem Klient kam die Aktion'.

Constructor & Destructor Documentation

GeViDBF_SenderID::GeViDBF_SenderID | ( | Int64 | initHandle,
 |  | Int64 | initUp,
 |  | Int64 | initTo
 | ) |  |

Create the query 'Von welchem Klient kam die Aktion'.

Member Function Documentation

CGeViMessage * GeViDBF_SenderID::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID::sHandle

Handle der Anfrage.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID::sTo

Bis (0 - ohne Einschraenkung)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID::sUp

Von (0 - ohne Einschraenkung)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName Class Reference

  • DataBaseQueries
  • GeViDBF_SenderName
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName Class Reference
Database Queries and Answers

StateQuery 'Von welchem Klient kam die Aktion'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName:
[legend]

List of all members.

Public Member Functions

GeViDBF_SenderName (Int64 initHandle, String^ initClientName, GeViDBCompare initCompare)
Create the query 'Von welchem Klient kam die Aktion'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sClientName
Name des Klienten.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery 'Von welchem Klient kam die Aktion'.

Constructor & Destructor Documentation

GeViDBF_SenderName::GeViDBF_SenderName | ( | Int64 | initHandle,
 |  | String^ | initClientName,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query 'Von welchem Klient kam die Aktion'.

Member Function Documentation

CGeViMessage * GeViDBF_SenderName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName::sClientName

Name des Klienten.

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc Class Reference

  • DataBaseQueries
  • GeViDBF_StartMonitorGroupDesc
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc Class Reference
Database Queries and Answers

StateQuery ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc:
[legend]

List of all members.

Public Member Functions

GeViDBF_StartMonitorGroupDesc (Int64 initHandle, String^ initMGDesc, GeViDBCompare initCompare)
Create the query ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sMGDesc
Beschreibung der ersten MG.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery ''.

Constructor & Destructor Documentation

GeViDBF_StartMonitorGroupDesc::GeViDBF_StartMonitorGroupDesc | ( | Int64 | initHandle,
 |  | String^ | initMGDesc,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query ''.

Member Function Documentation

CGeViMessage * GeViDBF_StartMonitorGroupDesc::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc::sMGDesc

Beschreibung der ersten MG.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID Class Reference

  • DataBaseQueries
  • GeViDBF_StartMonitorGroupID
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID Class Reference
Database Queries and Answers

StateQuery 'Die erste MG, wo Alarm praesentiert wurde'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID:
[legend]

List of all members.

Public Member Functions

GeViDBF_StartMonitorGroupID (Int64 initHandle, Int32 initUp, Int32 initTo)
Create the query 'Die erste MG, wo Alarm praesentiert wurde'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Int32 | sUp
Von (0 - ohne Einschraenkung)
Int32 | sTo
Bis (0 - ohne Einschraenkung)

Detailed Description

StateQuery 'Die erste MG, wo Alarm praesentiert wurde'.

Constructor & Destructor Documentation

GeViDBF_StartMonitorGroupID::GeViDBF_StartMonitorGroupID | ( | Int64 | initHandle,
 |  | Int32 | initUp,
 |  | Int32 | initTo
 | ) |  |

Create the query 'Die erste MG, wo Alarm praesentiert wurde'.

Member Function Documentation

CGeViMessage * GeViDBF_StartMonitorGroupID::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID::sHandle

Handle der Anfrage.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID::sTo

Bis (0 - ohne Einschraenkung)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID::sUp

Von (0 - ohne Einschraenkung)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName Class Reference

  • DataBaseQueries
  • GeViDBF_StartMonitorGroupName
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName Class Reference
Database Queries and Answers

StateQuery ''. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName:
[legend]

List of all members.

Public Member Functions

GeViDBF_StartMonitorGroupName (Int64 initHandle, String^ initMGName, GeViDBCompare initCompare)
Create the query ''.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sMGName
Name der ersten MG.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery ''.

Constructor & Destructor Documentation

GeViDBF_StartMonitorGroupName::GeViDBF_StartMonitorGroupName | ( | Int64 | initHandle,
 |  | String^ | initMGName,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query ''.

Member Function Documentation

CGeViMessage * GeViDBF_StartMonitorGroupName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName::sMGName

Name der ersten MG.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text Class Reference

  • DataBaseQueries
  • GeViDBF_Text
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text Class Reference
Database Queries and Answers

StateQuery 'Begleittext'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text:
[legend]

List of all members.

Public Member Functions

GeViDBF_Text (Int64 initHandle, String^ initText, GeViDBCompare initCompare)
Create the query 'Begleittext'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sText
Begleittext.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery 'Begleittext'.

Constructor & Destructor Documentation

GeViDBF_Text::GeViDBF_Text | ( | Int64 | initHandle,
 |  | String^ | initText,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query 'Begleittext'.

Member Function Documentation

CGeViMessage * GeViDBF_Text::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text::sText

Begleittext.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc Class Reference

  • DataBaseQueries
  • GeViDBF_TypeDesc
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc Class Reference
Database Queries and Answers

StateQuery 'Beschreibung des Alarms'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc:
[legend]

List of all members.

Public Member Functions

GeViDBF_TypeDesc (Int64 initHandle, String^ initTypeDesc, GeViDBCompare initCompare)
Create the query 'Beschreibung des Alarms'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sTypeDesc
Beschreibung des Alarms.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery 'Beschreibung des Alarms'.

Constructor & Destructor Documentation

GeViDBF_TypeDesc::GeViDBF_TypeDesc | ( | Int64 | initHandle,
 |  | String^ | initTypeDesc,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query 'Beschreibung des Alarms'.

Member Function Documentation

CGeViMessage * GeViDBF_TypeDesc::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc::sTypeDesc

Beschreibung des Alarms.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID Class Reference

  • DataBaseQueries
  • GeViDBF_TypeID
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID Class Reference
Database Queries and Answers

StateQuery 'AlarmTypeID bzw. ActionCode im Bereich'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID:
[legend]

List of all members.

Public Member Functions

GeViDBF_TypeID (Int64 initHandle, Int32 initUp, Int32 initTo)
Create the query 'AlarmTypeID bzw. ActionCode im Bereich'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Int32 | sUp
Von (0 - ohne Einschraenkung)
Int32 | sTo
Bis (0 - ohne Einschraenkung)

Detailed Description

StateQuery 'AlarmTypeID bzw. ActionCode im Bereich'.

Constructor & Destructor Documentation

GeViDBF_TypeID::GeViDBF_TypeID | ( | Int64 | initHandle,
 |  | Int32 | initUp,
 |  | Int32 | initTo
 | ) |  |

Create the query 'AlarmTypeID bzw. ActionCode im Bereich'.

Member Function Documentation

CGeViMessage * GeViDBF_TypeID::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID::sHandle

Handle der Anfrage.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID::sTo

Bis (0 - ohne Einschraenkung)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID::sUp

Von (0 - ohne Einschraenkung)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName Class Reference

  • DataBaseQueries
  • GeViDBF_TypeName
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName Class Reference
Database Queries and Answers

StateQuery 'Alarm- bzw. Aktionsname'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName:
[legend]

List of all members.

Public Member Functions

GeViDBF_TypeName (Int64 initHandle, String^ initTypeName, GeViDBCompare initCompare)
Create the query 'Alarm- bzw. Aktionsname'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
String^ | sTypeName
Name des Alarms bzw. der Aktion.
GeViDBCompare | sCompare
Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Detailed Description

StateQuery 'Alarm- bzw. Aktionsname'.

Constructor & Destructor Documentation

GeViDBF_TypeName::GeViDBF_TypeName | ( | Int64 | initHandle,
 |  | String^ | initTypeName,
 |  | GeViDBCompare | initCompare
 | ) |  |

Create the query 'Alarm- bzw. Aktionsname'.

Member Function Documentation

CGeViMessage * GeViDBF_TypeName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViDBCompare GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName::sCompare

Vergleichsart (LIKE, kleiner-gleich, groesser-gleich)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName::sHandle

Handle der Anfrage.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName::sTypeName

Name des Alarms bzw. der Aktion.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck Class Reference

  • DataBaseQueries
  • GeViDBF_WithAck
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck Class Reference
Database Queries and Answers

StateQuery 'Mit/ohne Bestaetigung'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck:
[legend]

List of all members.

Public Member Functions

GeViDBF_WithAck (Int64 initHandle, Boolean initWith)
Create the query 'Mit/ohne Bestaetigung'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Boolean | sWith
Only with or only without Acknowledge (seen)

Detailed Description

StateQuery 'Mit/ohne Bestaetigung'.

Constructor & Destructor Documentation

GeViDBF_WithAck::GeViDBF_WithAck | ( | Int64 | initHandle,
 |  | Boolean | initWith
 | ) |  |

Create the query 'Mit/ohne Bestaetigung'.

Member Function Documentation

CGeViMessage * GeViDBF_WithAck::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck::sHandle

Handle der Anfrage.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck::sWith

Only with or only without Acknowledge (seen)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation Class Reference

  • DataBaseQueries
  • GeViDBF_WithMscIIRelation
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation Class Reference
Database Queries and Answers

StateQuery 'Mit/Ohne MscII Events'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation:
[legend]

List of all members.

Public Member Functions

GeViDBF_WithMscIIRelation (Int64 initHandle, Boolean initWith)
Create the query 'Mit/Ohne MscII Events'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Boolean | sWith
Only with or only without Msc II Events.

Detailed Description

StateQuery 'Mit/Ohne MscII Events'.

Constructor & Destructor Documentation

GeViDBF_WithMscIIRelation::GeViDBF_WithMscIIRelation | ( | Int64 | initHandle,
 |  | Boolean | initWith
 | ) |  |

Create the query 'Mit/Ohne MscII Events'.

Member Function Documentation

CGeViMessage * GeViDBF_WithMscIIRelation::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation::sHandle

Handle der Anfrage.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation::sWith

Only with or only without Msc II Events.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit Class Reference

  • DataBaseQueries
  • GeViDBF_WithQuit
Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit Class Reference
Database Queries and Answers

StateQuery 'Mit/ohne Quittierung'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit:
[legend]

List of all members.

Public Member Functions

GeViDBF_WithQuit (Int64 initHandle, Boolean initWith)
Create the query 'Mit/ohne Quittierung'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Properties

Int64 | sHandle
Handle der Anfrage.
Boolean | sWith
Only with or only without Quit (done)

Detailed Description

StateQuery 'Mit/ohne Quittierung'.

Constructor & Destructor Documentation

GeViDBF_WithQuit::GeViDBF_WithQuit | ( | Int64 | initHandle,
 |  | Boolean | initWith
 | ) |  |

Create the query 'Mit/ohne Quittierung'.

Member Function Documentation

CGeViMessage * GeViDBF_WithQuit::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit::sHandle

Handle der Anfrage.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit::sWith

Only with or only without Quit (done)

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter Class Reference

  • GeViDBFilter
Public Attributes | Protected Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter Class Reference
Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter:
[legend]

List of all members.

Public Attributes

const GeViDBQueryKind _DBQueryKind

Protected Member Functions

GeViDBFilter (GeViDBQueryKind queryKind)

Constructor & Destructor Documentation

GeViDBFilter::GeViDBFilter ( GeViDBQueryKind queryKind ) [protected]

Member Data Documentation

const GeViDBQueryKind GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter::_DBQueryKind
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery Class Reference

  • DataBaseQueries
  • GeViDBQ_AbortQuery
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery Class Reference
Database Queries and Answers

StateQuery 'Befehl abbrechen'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery:
[legend]

List of all members.

Public Member Functions

GeViDBQ_AbortQuery (Int64 initHandle)
Create the query 'Befehl abbrechen'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_AbortQuery^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.

Detailed Description

StateQuery 'Befehl abbrechen'.

Constructor & Destructor Documentation

GeViDBQ_AbortQuery::GeViDBQ_AbortQuery ( Int64 initHandle )

Create the query 'Befehl abbrechen'.

Member Function Documentation

GeViDBQ_AbortQuery GeViDBQ_AbortQuery::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_AbortQuery::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery Class Reference

  • DataBaseQueries
  • GeViDBQ_CloseQuery
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery Class Reference
Database Queries and Answers

StateQuery 'Schliesst den Handle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery:
[legend]

List of all members.

Public Member Functions

GeViDBQ_CloseQuery (Int64 initHandle)
Create the query 'Schliesst den Handle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_CloseQuery^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.

Detailed Description

StateQuery 'Schliesst den Handle'.

Constructor & Destructor Documentation

GeViDBQ_CloseQuery::GeViDBQ_CloseQuery ( Int64 initHandle )

Create the query 'Schliesst den Handle'.

Member Function Documentation

GeViDBQ_CloseQuery GeViDBQ_CloseQuery::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_CloseQuery::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery Class Reference

  • DataBaseQueries
  • GeViDBQ_CreateActionQuery
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery Class Reference
Database Queries and Answers

StateQuery 'Startet eine Abfrage ueber die Aktionstabelle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery:
[legend]

List of all members.

Public Member Functions

GeViDBQ_CreateActionQuery (Int64 initPKAlarm)
Create the query 'Startet eine Abfrage ueber die Aktionstabelle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_CreateActionQuery^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sPKAlarm
PK des Alarms, bzw. 0 wenn die Aktionen ohne Alarmbezug gesucht werden.

Detailed Description

StateQuery 'Startet eine Abfrage ueber die Aktionstabelle'.

Constructor & Destructor Documentation

GeViDBQ_CreateActionQuery::GeViDBQ_CreateActionQuery ( Int64 initPKAlarm )

Create the query 'Startet eine Abfrage ueber die Aktionstabelle'.

Member Function Documentation

GeViDBQ_CreateActionQuery GeViDBQ_CreateActionQuery::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_CreateActionQuery::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery::sPKAlarm

PK des Alarms, bzw. 0 wenn die Aktionen ohne Alarmbezug gesucht werden.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery Class Reference

  • DataBaseQueries
  • GeViDBQ_CreateAlarmQuery
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery Class Reference
Database Queries and Answers

StateQuery 'Startet eine Abfrage ueber die Alarmtabelle'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery:
[legend]

List of all members.

Public Member Functions

GeViDBQ_CreateAlarmQuery ()
Create the query 'Startet eine Abfrage ueber die Alarmtabelle'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_CreateAlarmQuery^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Detailed Description

StateQuery 'Startet eine Abfrage ueber die Alarmtabelle'.

Constructor & Destructor Documentation

GeViDBQ_CreateAlarmQuery::GeViDBQ_CreateAlarmQuery ( )

Create the query 'Startet eine Abfrage ueber die Alarmtabelle'.

Member Function Documentation

GeViDBQ_CreateAlarmQuery GeViDBQ_CreateAlarmQuery::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_CreateAlarmQuery::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle Class Reference

  • DataBaseQueries
  • GeViDBQ_CreateDeleteActionsHandle
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle Class Reference
Database Queries and Answers

StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Aktionstabelle vor.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle:
[legend]

List of all members.

Public Member Functions

GeViDBQ_CreateDeleteActionsHandle ()
Create the query 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Aktionstabelle vor.'.
virtual CGeViMessage * ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViDBQ_CreateDeleteActionsHandle^ 		FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Detailed Description

StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Aktionstabelle vor.'.

Constructor & Destructor Documentation

GeViDBQ_CreateDeleteActionsHandle::GeViDBQ_CreateDeleteActionsHandle ( )

Create the query 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Aktionstabelle vor.'.

Member Function Documentation

GeViDBQ_CreateDeleteActionsHandle GeViDBQ_CreateDeleteActionsHandle::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_CreateDeleteActionsHandle::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle Class Reference

  • DataBaseQueries
  • GeViDBQ_CreateDeleteAlarmsHandle
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle Class Reference
Database Queries and Answers

StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Alarmtabelle vor.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle:
[legend]

List of all members.

Public Member Functions

GeViDBQ_CreateDeleteAlarmsHandle ()
Create the query 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Alarmtabelle vor.'.
virtual CGeViMessage * ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViDBQ_CreateDeleteAlarmsHandle^ 		FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Detailed Description

StateQuery 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Alarmtabelle vor.'.

Constructor & Destructor Documentation

GeViDBQ_CreateDeleteAlarmsHandle::GeViDBQ_CreateDeleteAlarmsHandle ( )

Create the query 'Bereitet ein Objekt fuer das selektive Loeschen von Eintraegen in der Alarmtabelle vor.'.

Member Function Documentation

GeViDBQ_CreateDeleteAlarmsHandle GeViDBQ_CreateDeleteAlarmsHandle::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_CreateDeleteAlarmsHandle::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll Class Reference

  • DataBaseQueries
  • GeViDBQ_DeleteAll
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll Class Reference
Database Queries and Answers

StateQuery 'Loescht alle passenden Eintraege in der Aktions- bzw. Alarmtabelle. Kann nur in Verbindung mit den entspraechenden CreateDelete...Handle verwendet werden.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll:
[legend]

List of all members.

Public Member Functions

GeViDBQ_DeleteAll (Int64 initHandle)
Create the query 'Loescht alle passenden Eintraege in der Aktions- bzw. Alarmtabelle. Kann nur in Verbindung mit den entspraechenden CreateDelete...Handle verwendet werden.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_DeleteAll^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.

Detailed Description

StateQuery 'Loescht alle passenden Eintraege in der Aktions- bzw. Alarmtabelle. Kann nur in Verbindung mit den entspraechenden CreateDelete...Handle verwendet werden.'.

Constructor & Destructor Documentation

GeViDBQ_DeleteAll::GeViDBQ_DeleteAll ( Int64 initHandle )

Create the query 'Loescht alle passenden Eintraege in der Aktions- bzw. Alarmtabelle. Kann nur in Verbindung mit den entspraechenden CreateDelete...Handle verwendet werden.'.

Member Function Documentation

GeViDBQ_DeleteAll GeViDBQ_DeleteAll::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_DeleteAll::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get Class Reference

  • DataBaseQueries
  • GeViDBQ_Get
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get Class Reference
Database Queries and Answers

StateQuery 'Liefert den Eintrag anhand von PK'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get:
[legend]

List of all members.

Public Member Functions

GeViDBQ_Get (Int64 initHandle, Int64 initPK)
Create the query 'Liefert den Eintrag anhand von PK'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_Get^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.
Int64 | sPK
PK des Satzes.

Detailed Description

StateQuery 'Liefert den Eintrag anhand von PK'.

Constructor & Destructor Documentation

GeViDBQ_Get::GeViDBQ_Get | ( | Int64 | initHandle,
 |  | Int64 | initPK
 | ) |  |

Create the query 'Liefert den Eintrag anhand von PK'.

Member Function Documentation

GeViDBQ_Get GeViDBQ_Get::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_Get::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get::sHandle

Handle der Anfrage.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get::sPK

PK des Satzes.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst Class Reference

  • DataBaseQueries
  • GeViDBQ_GetFirst
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst Class Reference
Database Queries and Answers

StateQuery 'Liefert den ersten Eintrag'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst:
[legend]

List of all members.

Public Member Functions

GeViDBQ_GetFirst (Int64 initHandle)
Create the query 'Liefert den ersten Eintrag'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_GetFirst^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.

Detailed Description

StateQuery 'Liefert den ersten Eintrag'.

Constructor & Destructor Documentation

GeViDBQ_GetFirst::GeViDBQ_GetFirst ( Int64 initHandle )

Create the query 'Liefert den ersten Eintrag'.

Member Function Documentation

GeViDBQ_GetFirst GeViDBQ_GetFirst::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_GetFirst::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast Class Reference

  • DataBaseQueries
  • GeViDBQ_GetLast
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast Class Reference
Database Queries and Answers

StateQuery 'Liefert den letzten Eintrag'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast:
[legend]

List of all members.

Public Member Functions

GeViDBQ_GetLast (Int64 initHandle)
Create the query 'Liefert den letzten Eintrag'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_GetLast^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.

Detailed Description

StateQuery 'Liefert den letzten Eintrag'.

Constructor & Destructor Documentation

GeViDBQ_GetLast::GeViDBQ_GetLast ( Int64 initHandle )

Create the query 'Liefert den letzten Eintrag'.

Member Function Documentation

GeViDBQ_GetLast GeViDBQ_GetLast::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_GetLast::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext Class Reference

  • DataBaseQueries
  • GeViDBQ_GetNext
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext Class Reference
Database Queries and Answers

StateQuery 'Liefert den naechsten Eintrag'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext:
[legend]

List of all members.

Public Member Functions

GeViDBQ_GetNext (Int64 initHandle, Int64 initBasePK)
Create the query 'Liefert den naechsten Eintrag'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_GetNext^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.
Int64 | sBasePK
PK des zuletzt abgefragten Satzes (bzw. 0 - benutze die Marke von GeViDB)

Detailed Description

StateQuery 'Liefert den naechsten Eintrag'.

Constructor & Destructor Documentation

GeViDBQ_GetNext::GeViDBQ_GetNext | ( | Int64 | initHandle,
 |  | Int64 | initBasePK
 | ) |  |

Create the query 'Liefert den naechsten Eintrag'.

Member Function Documentation

GeViDBQ_GetNext GeViDBQ_GetNext::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_GetNext::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext::sBasePK

PK des zuletzt abgefragten Satzes (bzw. 0 - benutze die Marke von GeViDB)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev Class Reference

  • DataBaseQueries
  • GeViDBQ_GetPrev
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev Class Reference
Database Queries and Answers

StateQuery 'Liefert den vorgehenden Eintrag'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev:
[legend]

List of all members.

Public Member Functions

GeViDBQ_GetPrev (Int64 initHandle, Int64 initBasePK)
Create the query 'Liefert den vorgehenden Eintrag'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViDBQ_GetPrev^ | FromNativeQuery (CDataBaseQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int64 | sHandle
Handle der Anfrage.
Int64 | sBasePK
PK des zuletzt abgefragten Satzes (bzw. 0 - benutze die Marke von GeViDB)

Detailed Description

StateQuery 'Liefert den vorgehenden Eintrag'.

Constructor & Destructor Documentation

GeViDBQ_GetPrev::GeViDBQ_GetPrev | ( | Int64 | initHandle,
 |  | Int64 | initBasePK
 | ) |  |

Create the query 'Liefert den vorgehenden Eintrag'.

Member Function Documentation

GeViDBQ_GetPrev GeViDBQ_GetPrev::FromNativeQuery ( CDataBaseQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViDBQ_GetPrev::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev::sBasePK

PK des zuletzt abgefragten Satzes (bzw. 0 - benutze die Marke von GeViDB)

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev::sHandle

Handle der Anfrage.

Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery Class Reference

  • GeViDBQuery
Public Attributes | Protected Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery Class Reference
Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery:
[legend]

List of all members.

Public Attributes

const GeViDBQueryKind _DBQueryKind

Protected Member Functions

GeViDBQuery (GeViDBQueryKind queryKind)

Constructor & Destructor Documentation

GeViDBQuery::GeViDBQuery ( GeViDBQueryKind queryKind ) [protected]

Member Data Documentation

const GeViDBQueryKind GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery::_DBQueryKind
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID Struct Reference

  • GeViGUID
Public Attributes | Static Public Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID Struct Reference

List of all members.

Public Attributes

System::UInt32 | Data1
System::UInt16 | Data2
System::UInt16 | Data3

Static Public Attributes

static array< System::Byte >^ | Data4 = gcnew array<System::Byte>(8){0, 0, 0, 0, 0, 0, 0, 0}

Member Data Documentation

System::UInt32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID::Data1
System::UInt16 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID::Data2
System::UInt16 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID::Data3
array<System::Byte> ^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID::Data4 = gcnew array<System::Byte>(8){0, 0, 0, 0, 0, 0, 0, 0} [static]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage Class Reference

  • GeViMessage
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage Class Reference
Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage:
[legend]

List of all members.

Public Member Functions

virtual CGeViMessage * | ToNativeAction ()=0

Public Attributes

GeViMessageKind | _MessageKind
GeViClientID | _SenderId
GeViClientID | _RecipientId

Protected Member Functions

GeViMessage (GeViMessageKind messageKind)

Protected Attributes

GeViAPI_Namespace::CGeViMessage * | m_NativeMessage

Constructor & Destructor Documentation

GeViMessage::GeViMessage ( GeViMessageKind messageKind ) [protected]

Member Function Documentation

virtual CGeViMessage* GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage::ToNativeAction ( ) [pure virtual]

Implemented in GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo, and GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex.

Member Data Documentation

GeViMessageKind GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage::_MessageKind
GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage::_RecipientId
GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage::_SenderId
GeViAPI_Namespace::CGeViMessage* GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage::m_NativeMessage [protected]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo Class Reference

  • StateAnswers
  • GeViSA_AlarmInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo Class Reference
State Queries and Answers

StateAnswer 'Info zum Alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_AlarmInfo (Int32 initGlobalID, String^ initName, String^ initDescription, Int64 initInstanceID, Boolean initStarted, Boolean initAcked, Int32 initPresentedOnCount, Int32 initFirstMG, Boolean initDisplayedOnFirstMG)
Create the stateanswer 'Info zum Alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_AlarmInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sGlobalID
GlobalID des Alarms.
String^ | sName
Name des Alarms.
String^ | sDescription
Beschreibung des Alarms.
Int64 | sInstanceID
InstanceID des Alarms (0 falls nicht gestartet)
Boolean | sStarted
true - Alarm ist aktiv, false - nein
Boolean | sAcked
Wurde bestaetigt.
Int32 | sPresentedOnCount
Anzahl der MG, an denen Alarm dargestellt wird.
Int32 | sFirstMG
GlobalID der ersten MG in der Liste (0 - falls nicht aktiv)
Boolean | sDisplayedOnFirstMG
Ist dieser Alarm an der o.g. MG sichtbar.

Detailed Description

StateAnswer 'Info zum Alarm'.

Constructor & Destructor Documentation

GeViSA_AlarmInfo::GeViSA_AlarmInfo | ( | Int32 | initGlobalID,
 |  | String^ | initName,
 |  | String^ | initDescription,
 |  | Int64 | initInstanceID,
 |  | Boolean | initStarted,
 |  | Boolean | initAcked,
 |  | Int32 | initPresentedOnCount,
 |  | Int32 | initFirstMG,
 |  | Boolean | initDisplayedOnFirstMG
 | ) |  |

Create the stateanswer 'Info zum Alarm'.

Member Function Documentation

GeViSA_AlarmInfo GeViSA_AlarmInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_AlarmInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sAcked

Wurde bestaetigt.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sDescription

Beschreibung des Alarms.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sDisplayedOnFirstMG

Ist dieser Alarm an der o.g. MG sichtbar.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sFirstMG

GlobalID der ersten MG in der Liste (0 - falls nicht aktiv)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sGlobalID

GlobalID des Alarms.

Int64 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sInstanceID

InstanceID des Alarms (0 falls nicht gestartet)

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sName

Name des Alarms.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sPresentedOnCount

Anzahl der MG, an denen Alarm dargestellt wird.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo::sStarted

true - Alarm ist aktiv, false - nein

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo Class Reference

  • StateAnswers
  • GeViSA_AlarmOnMGInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo Class Reference
State Queries and Answers

StateAnswer 'AlarmOnMG info'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_AlarmOnMGInfo (GeViMGID initMGID, Boolean initContained, Boolean initVisible)
Create the stateanswer 'AlarmOnMG info'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_AlarmOnMGInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViMGID | sMGID
GlobalID der MG.
Boolean | sContained
Alarm auf der MG enthalten (immer true, sonst wird Nothing gesendet!)
Boolean | sVisible
Alarm ist sichtbar auf der MG.

Detailed Description

StateAnswer 'AlarmOnMG info'.

Constructor & Destructor Documentation

GeViSA_AlarmOnMGInfo::GeViSA_AlarmOnMGInfo | ( | GeViMGID | initMGID,
 |  | Boolean | initContained,
 |  | Boolean | initVisible
 | ) |  |

Create the stateanswer 'AlarmOnMG info'.

Member Function Documentation

GeViSA_AlarmOnMGInfo GeViSA_AlarmOnMGInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_AlarmOnMGInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo::sContained

Alarm auf der MG enthalten (immer true, sonst wird Nothing gesendet!)

GeViMGID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo::sMGID

GlobalID der MG.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo::sVisible

Alarm ist sichtbar auf der MG.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo Class Reference

  • StateAnswers
  • GeViSA_ClientInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo Class Reference
State Queries and Answers

StateAnswer 'Information zu dem Klient'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_ClientInfo (GeViClientID initClientID, String^ initClientName, String^ initClientFullName, String^ initClientDescription, Int32 initClientType, Int32 initInterfaceType, Boolean initCorrupt, Int32 initLoginCount, Int32 initAccessRights)
Create the stateanswer 'Information zu dem Klient'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_ClientInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViClientID | sClientID
ClientID des Klienten.
String^ | sClientName
Login Name des Klienten.
String^ | sClientFullName
Klartext Name des Klienten.
String^ | sClientDescription
Beschreibung des Klienten.
Int32 | sClientType
GeViIO, User, SysAdmin, Interface.
Int32 | sInterfaceType
Phoenix, GeViTel,...Nur wenn ClientType == Interface.
Boolean | sCorrupt
Passwort korrupt?
Int32 | sLoginCount
Anzahl der Logins.
Int32 | sAccessRights
Zugriffsrechte.

Detailed Description

StateAnswer 'Information zu dem Klient'.

Constructor & Destructor Documentation

GeViSA_ClientInfo::GeViSA_ClientInfo | ( | GeViClientID | initClientID,
 |  | String^ | initClientName,
 |  | String^ | initClientFullName,
 |  | String^ | initClientDescription,
 |  | Int32 | initClientType,
 |  | Int32 | initInterfaceType,
 |  | Boolean | initCorrupt,
 |  | Int32 | initLoginCount,
 |  | Int32 | initAccessRights
 | ) |  |

Create the stateanswer 'Information zu dem Klient'.

Member Function Documentation

GeViSA_ClientInfo GeViSA_ClientInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_ClientInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sAccessRights

Zugriffsrechte.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sClientDescription

Beschreibung des Klienten.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sClientFullName

Klartext Name des Klienten.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sClientID

ClientID des Klienten.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sClientName

Login Name des Klienten.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sClientType

GeViIO, User, SysAdmin, Interface.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sCorrupt

Passwort korrupt?

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sInterfaceType

Phoenix, GeViTel,...Nur wenn ClientType == Interface.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo::sLoginCount

Anzahl der Logins.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo Class Reference

  • StateAnswers
  • GeViSA_ClientLoginInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo Class Reference
State Queries and Answers

StateAnswer 'Information zu dem Klient'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_ClientLoginInfo (GeViTGeViPort initPort, String^ initIP, String^ initSecondUser)
Create the stateanswer 'Information zu dem Klient'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_ClientLoginInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViTGeViPort | sPort
Port.
String^ | sIP
IP Adresse.
String^ | sSecondUser
evtl. Name des Zweitnutzer

Detailed Description

StateAnswer 'Information zu dem Klient'.

Constructor & Destructor Documentation

GeViSA_ClientLoginInfo::GeViSA_ClientLoginInfo | ( | GeViTGeViPort | initPort,
 |  | String^ | initIP,
 |  | String^ | initSecondUser
 | ) |  |

Create the stateanswer 'Information zu dem Klient'.

Member Function Documentation

GeViSA_ClientLoginInfo GeViSA_ClientLoginInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_ClientLoginInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo::sIP

IP Adresse.

GeViTGeViPort GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo::sPort

Port.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo::sSecondUser

evtl. Name des Zweitnutzer

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed Class Reference

  • StateAnswers
  • GeViSA_CommandFailed
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed Class Reference
State Queries and Answers

StateAnswer 'Befehl fehlgeschlagen.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed:
[legend]

List of all members.

Public Member Functions

GeViSA_CommandFailed ()
Create the stateanswer 'Befehl fehlgeschlagen.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_CommandFailed^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Befehl fehlgeschlagen.'.

Constructor & Destructor Documentation

GeViSA_CommandFailed::GeViSA_CommandFailed ( )

Create the stateanswer 'Befehl fehlgeschlagen.'.

Member Function Documentation

GeViSA_CommandFailed GeViSA_CommandFailed::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_CommandFailed::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk Class Reference

  • StateAnswers
  • GeViSA_CommandOk
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk Class Reference
State Queries and Answers

StateAnswer 'Befehl ausgefuehrt.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk:
[legend]

List of all members.

Public Member Functions

GeViSA_CommandOk ()
Create the stateanswer 'Befehl ausgefuehrt.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_CommandOk^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Befehl ausgefuehrt.'.

Constructor & Destructor Documentation

GeViSA_CommandOk::GeViSA_CommandOk ( )

Create the stateanswer 'Befehl ausgefuehrt.'.

Member Function Documentation

GeViSA_CommandOk GeViSA_CommandOk::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_CommandOk::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState Class Reference

  • StateAnswers
  • GeViSA_ContrastState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState Class Reference
State Queries and Answers

StateAnswer 'ContrastState Info'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState:
[legend]

List of all members.

Public Member Functions

GeViSA_ContrastState (Boolean initContrastAlarm, Boolean initContrastPreAlarm, Int32 initAlarmThreshold, Int32 initPreAlarmThreshold, Int32 initLastThreshold)
Create the stateanswer 'ContrastState Info'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_ContrastState^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Boolean | sContrastAlarm
Alarm gemessen.
Boolean | sContrastPreAlarm
Voralarm gemessen.
Int32 | sAlarmThreshold
Schwellenwert fuer Alarm.
Int32 | sPreAlarmThreshold
Schwellenwert fue Voralarm.
Int32 | sLastThreshold
Zuletzt gemessener (Vor-)Alarm-Schwellenwert (0 - Ok, -1 - Syncausfall, -2 - Kommunikationsausfall)

Detailed Description

StateAnswer 'ContrastState Info'.

Constructor & Destructor Documentation

GeViSA_ContrastState::GeViSA_ContrastState | ( | Boolean | initContrastAlarm,
 |  | Boolean | initContrastPreAlarm,
 |  | Int32 | initAlarmThreshold,
 |  | Int32 | initPreAlarmThreshold,
 |  | Int32 | initLastThreshold
 | ) |  |

Create the stateanswer 'ContrastState Info'.

Member Function Documentation

GeViSA_ContrastState GeViSA_ContrastState::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_ContrastState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState::sAlarmThreshold

Schwellenwert fuer Alarm.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState::sContrastAlarm

Alarm gemessen.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState::sContrastPreAlarm

Voralarm gemessen.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState::sLastThreshold

Zuletzt gemessener (Vor-)Alarm-Schwellenwert (0 - Ok, -1 - Syncausfall, -2 - Kommunikationsausfall)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState::sPreAlarmThreshold

Schwellenwert fue Voralarm.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime Class Reference

  • StateAnswers
  • GeViSA_InfoDatabaseCreationTime
Public Member Functions | Static Public Member Functions | Public Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime Class Reference
State Queries and Answers

StateAnswer 'Datenbankzeit'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime:
[legend]

List of all members.

Public Member Functions

GeViSA_InfoDatabaseCreationTime (GeViTGeViDateTime initStartTime)
Create the stateanswer 'Datenbankzeit'.
virtual CGeViMessage * ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static
GeViSA_InfoDatabaseCreationTime^ 		FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Public Attributes

GeViTGeViDateTime sStartTime
Wann wurde die Datenbank erzeugt.

Detailed Description

StateAnswer 'Datenbankzeit'.

Constructor & Destructor Documentation

GeViSA_InfoDatabaseCreationTime::GeViSA_InfoDatabaseCreationTime ( GeViTGeViDateTime initStartTime )

Create the stateanswer 'Datenbankzeit'.

Member Function Documentation

GeViSA_InfoDatabaseCreationTime GeViSA_InfoDatabaseCreationTime::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_InfoDatabaseCreationTime::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Member Data Documentation

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime::sStartTime

Wann wurde die Datenbank erzeugt.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime Class Reference

  • StateAnswers
  • GeViSA_InfoServerStartTime
Public Member Functions | Static Public Member Functions | Public Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime Class Reference
State Queries and Answers

StateAnswer 'Serverstartzeit'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime:
[legend]

List of all members.

Public Member Functions

GeViSA_InfoServerStartTime (GeViTGeViDateTime initStartTime)
Create the stateanswer 'Serverstartzeit'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_InfoServerStartTime^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Public Attributes

GeViTGeViDateTime sStartTime
Wann wurde der Server gestartet.

Detailed Description

StateAnswer 'Serverstartzeit'.

Constructor & Destructor Documentation

GeViSA_InfoServerStartTime::GeViSA_InfoServerStartTime ( GeViTGeViDateTime initStartTime )

Create the stateanswer 'Serverstartzeit'.

Member Function Documentation

GeViSA_InfoServerStartTime GeViSA_InfoServerStartTime::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_InfoServerStartTime::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Member Data Documentation

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime::sStartTime

Wann wurde der Server gestartet.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo Class Reference

  • StateAnswers
  • GeViSA_InputContactInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo Class Reference
State Queries and Answers

StateAnswer 'Info zu einem Eingangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_InputContactInfo (GeViInputContactID initGlobalID, Int32 initSegment, GeViInputContactID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Int32 initState, GeViTGeViDateTime initTriggerTime)
Create the stateanswer 'Info zu einem Eingangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_InputContactInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViInputContactID | sGlobalID
GlobalID des Eingangskontaktes.
Int32 | sSegment
Segment am Klient (meist 1)
GeViInputContactID | sLocalID
LocalID des Eingangskontaktes.
GeViClientID | sClientID
ClientID des Klients, der diesen Eingangskontakt verwaltet.
String^ | sName
Name des Eingangskontaktes.
String^ | sDescription
Beschreibung des Eingangskontaktes.
Boolean | sActive
true - Klient ist bereits eingeloggt, false - nein
Boolean | sEnabled
Eingeschaltet oder zeitweise deaktiviert.
Int32 | sState
offen, geschlossen, unbekannt
GeViTGeViDateTime sTriggerTime
Wann wurde zuletzt gemeldet.

Detailed Description

StateAnswer 'Info zu einem Eingangskontakt'.

Constructor & Destructor Documentation

GeViSA_InputContactInfo::GeViSA_InputContactInfo | ( | GeViInputContactID | initGlobalID,
 |  | Int32 | initSegment,
 |  | GeViInputContactID | initLocalID,
 |  | GeViClientID | initClientID,
 |  | String^ | initName,
 |  | String^ | initDescription,
 |  | Boolean | initActive,
 |  | Boolean | initEnabled,
 |  | Int32 | initState,
 |  | GeViTGeViDateTime | initTriggerTime
 | ) |  |

Create the stateanswer 'Info zu einem Eingangskontakt'.

Member Function Documentation

GeViSA_InputContactInfo GeViSA_InputContactInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_InputContactInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sActive

true - Klient ist bereits eingeloggt, false - nein

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sClientID

ClientID des Klients, der diesen Eingangskontakt verwaltet.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sDescription

Beschreibung des Eingangskontaktes.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sEnabled

Eingeschaltet oder zeitweise deaktiviert.

GeViInputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sGlobalID

GlobalID des Eingangskontaktes.

GeViInputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sLocalID

LocalID des Eingangskontaktes.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sName

Name des Eingangskontaktes.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sSegment

Segment am Klient (meist 1)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sState

offen, geschlossen, unbekannt

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo::sTriggerTime

Wann wurde zuletzt gemeldet.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall Class Reference

  • StateAnswers
  • GeViSA_LicenseCall
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall Class Reference
State Queries and Answers

StateAnswer 'Interne Abfrage'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall:
[legend]

List of all members.

Public Member Functions

GeViSA_LicenseCall (Int32 initVal1, Int32 initVal2, Int32 initVal3, Int32 initVal4)
Create the stateanswer 'Interne Abfrage'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_LicenseCall^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sVal1
Wert 1.
Int32 | sVal2
Wert 2.
Int32 | sVal3
Wert 3.
Int32 | sVal4
Wert 4.

Detailed Description

StateAnswer 'Interne Abfrage'.

Constructor & Destructor Documentation

GeViSA_LicenseCall::GeViSA_LicenseCall | ( | Int32 | initVal1,
 |  | Int32 | initVal2,
 |  | Int32 | initVal3,
 |  | Int32 | initVal4
 | ) |  |

Create the stateanswer 'Interne Abfrage'.

Member Function Documentation

GeViSA_LicenseCall GeViSA_LicenseCall::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_LicenseCall::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall::sVal1

Wert 1.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall::sVal2

Wert 2.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall::sVal3

Wert 3.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall::sVal4

Wert 4.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo Class Reference

  • StateAnswers
  • GeViSA_LicenseInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo Class Reference
State Queries and Answers

StateAnswer 'Lizenzinformation'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_LicenseInfo (Int32 initLicVersion, Boolean initDongleDllFound, Boolean initDongleKeyFound, String^ initLicString)
Create the stateanswer 'Lizenzinformation'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_LicenseInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sLicVersion
Version der Lizenzzeichenkette.
Boolean | sDongleDllFound
Zeigt ob die Dongle-DLLs gefunden wurden.
Boolean | sDongleKeyFound
Zeigt ob der Dongle gefunden wurde.
String^ | sLicString
Lizenzzeichenkette.

Detailed Description

StateAnswer 'Lizenzinformation'.

Constructor & Destructor Documentation

GeViSA_LicenseInfo::GeViSA_LicenseInfo | ( | Int32 | initLicVersion,
 |  | Boolean | initDongleDllFound,
 |  | Boolean | initDongleKeyFound,
 |  | String^ | initLicString
 | ) |  |

Create the stateanswer 'Lizenzinformation'.

Member Function Documentation

GeViSA_LicenseInfo GeViSA_LicenseInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_LicenseInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo::sDongleDllFound

Zeigt ob die Dongle-DLLs gefunden wurden.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo::sDongleKeyFound

Zeigt ob der Dongle gefunden wurde.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo::sLicString

Lizenzzeichenkette.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo::sLicVersion

Version der Lizenzzeichenkette.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData Class Reference

  • StateAnswers
  • GeViSA_LicenseTransferData
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData Class Reference
State Queries and Answers

StateAnswer 'Interne Abfrage'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData:
[legend]

List of all members.

Public Member Functions

GeViSA_LicenseTransferData (Int32 initVal1, Int32 initVal2, String^ initVal3)
Create the stateanswer 'Interne Abfrage'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_LicenseTransferData^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sVal1
Wert 1.
Int32 | sVal2
Wert 2.
String^ | sVal3
Wert 3.

Detailed Description

StateAnswer 'Interne Abfrage'.

Constructor & Destructor Documentation

GeViSA_LicenseTransferData::GeViSA_LicenseTransferData | ( | Int32 | initVal1,
 |  | Int32 | initVal2,
 |  | String^ | initVal3
 | ) |  |

Create the stateanswer 'Interne Abfrage'.

Member Function Documentation

GeViSA_LicenseTransferData GeViSA_LicenseTransferData::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_LicenseTransferData::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData::sVal1

Wert 1.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData::sVal2

Wert 2.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData::sVal3

Wert 3.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue Class Reference

  • StateAnswers
  • GeViSA_LicenseValue
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue Class Reference
State Queries and Answers

StateAnswer 'Wert des bestimmten Eintrags'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue:
[legend]

List of all members.

Public Member Functions

GeViSA_LicenseValue (String^ initLicName, Int32 initLicValue)
Create the stateanswer 'Wert des bestimmten Eintrags'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_LicenseValue^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

String^ | sLicName
Name des Eintrags.
Int32 | sLicValue
Wert des Eintrags.

Detailed Description

StateAnswer 'Wert des bestimmten Eintrags'.

Constructor & Destructor Documentation

GeViSA_LicenseValue::GeViSA_LicenseValue | ( | String^ | initLicName,
 |  | Int32 | initLicValue
 | ) |  |

Create the stateanswer 'Wert des bestimmten Eintrags'.

Member Function Documentation

GeViSA_LicenseValue GeViSA_LicenseValue::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_LicenseValue::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue::sLicName

Name des Eintrags.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue::sLicValue

Wert des Eintrags.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo Class Reference

  • StateAnswers
  • GeViSA_MonitorGroupInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo Class Reference
State Queries and Answers

StateAnswer 'Info zu einer MG'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_MonitorGroupInfo (Int32 initGlobalID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Int32 initPresentedAlarms, Int32 initAllAlarms)
Create the stateanswer 'Info zu einer MG'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_MonitorGroupInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sGlobalID
GlobalID der MG.
String^ | sName
Name der MG.
String^ | sDescription
Beschreibung der MG.
Boolean | sActive
true - die MG ist aktiv, false - nein
Boolean | sEnabled
klar
Int32 | sPresentedAlarms
Anzahl der dargestellten Alarme.
Int32 | sAllAlarms
Gesamtzahl der Alarme.

Detailed Description

StateAnswer 'Info zu einer MG'.

Constructor & Destructor Documentation

GeViSA_MonitorGroupInfo::GeViSA_MonitorGroupInfo | ( | Int32 | initGlobalID,
 |  | String^ | initName,
 |  | String^ | initDescription,
 |  | Boolean | initActive,
 |  | Boolean | initEnabled,
 |  | Int32 | initPresentedAlarms,
 |  | Int32 | initAllAlarms
 | ) |  |

Create the stateanswer 'Info zu einer MG'.

Member Function Documentation

GeViSA_MonitorGroupInfo GeViSA_MonitorGroupInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_MonitorGroupInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo::sActive

true - die MG ist aktiv, false - nein

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo::sAllAlarms

Gesamtzahl der Alarme.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo::sDescription

Beschreibung der MG.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo::sEnabled

klar

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo::sGlobalID

GlobalID der MG.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo::sName

Name der MG.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo::sPresentedAlarms

Anzahl der dargestellten Alarme.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing Class Reference

  • StateAnswers
  • GeViSA_Nothing
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing Class Reference
State Queries and Answers

StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing:
[legend]

List of all members.

Public Member Functions

GeViSA_Nothing ()
Create the stateanswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_Nothing^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'.

Constructor & Destructor Documentation

GeViSA_Nothing::GeViSA_Nothing ( )

Create the stateanswer 'Die Antwort wird gesendet wenn keine Eintraege mehr vorhanden sind bzw. es wurde gar keine Antwort fuer die Anfrage gefunden.'.

Member Function Documentation

GeViSA_Nothing GeViSA_Nothing::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_Nothing::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo Class Reference

  • StateAnswers
  • GeViSA_OutputContactInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo Class Reference
State Queries and Answers

StateAnswer 'Info zu einem Ausgangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_OutputContactInfo (GeViOutputContactID initGlobalID, Int32 initSegment, GeViOutputContactID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Boolean initAccessible, Int32 initState, Int32 initPeriod, GeViTGeViDateTime initTriggerTime)
Create the stateanswer 'Info zu einem Ausgangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_OutputContactInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViOutputContactID | sGlobalID
GlobalID des Ausgangskontaktes.
Int32 | sSegment
Segment am Klient (meist 1)
GeViOutputContactID | sLocalID
LocalID des Ausgangskontaktes.
GeViClientID | sClientID
ClientID des Klients, der diesen Ausgangskontakt verwaltet.
String^ | sName
Name des Ausgangskontaktes.
String^ | sDescription
Beschreibung des Ausgangskontaktes.
Boolean | sActive
true - Klient ist bereits eingeloggt, false - nein
Boolean | sEnabled
Eingeschaltet oder zeitweise deaktiviert.
Boolean | sAccessible
Mit aktuellen Rechten zugreifbar oder nicht.
Int32 | sState
offen, geschlossen, unbekannt, alternierend
Int32 | sPeriod
Schaltzeit.
GeViTGeViDateTime sTriggerTime
Wann wurde zuletzt gemeldet.

Detailed Description

StateAnswer 'Info zu einem Ausgangskontakt'.

Constructor & Destructor Documentation

GeViSA_OutputContactInfo::GeViSA_OutputContactInfo | ( | GeViOutputContactID | initGlobalID,
 |  | Int32 | initSegment,
 |  | GeViOutputContactID | initLocalID,
 |  | GeViClientID | initClientID,
 |  | String^ | initName,
 |  | String^ | initDescription,
 |  | Boolean | initActive,
 |  | Boolean | initEnabled,
 |  | Boolean | initAccessible,
 |  | Int32 | initState,
 |  | Int32 | initPeriod,
 |  | GeViTGeViDateTime | initTriggerTime
 | ) |  |

Create the stateanswer 'Info zu einem Ausgangskontakt'.

Member Function Documentation

GeViSA_OutputContactInfo GeViSA_OutputContactInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_OutputContactInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sAccessible

Mit aktuellen Rechten zugreifbar oder nicht.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sActive

true - Klient ist bereits eingeloggt, false - nein

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sClientID

ClientID des Klients, der diesen Ausgangskontakt verwaltet.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sDescription

Beschreibung des Ausgangskontaktes.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sEnabled

Eingeschaltet oder zeitweise deaktiviert.

GeViOutputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sGlobalID

GlobalID des Ausgangskontaktes.

GeViOutputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sLocalID

LocalID des Ausgangskontaktes.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sName

Name des Ausgangskontaktes.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sPeriod

Schaltzeit.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sSegment

Segment am Klient (meist 1)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sState

offen, geschlossen, unbekannt, alternierend

GeViTGeViDateTime GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo::sTriggerTime

Wann wurde zuletzt gemeldet.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo Class Reference

  • StateAnswers
  • GeViSA_PTZHeadInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo Class Reference
State Queries and Answers

StateAnswer 'S/N Info'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_PTZHeadInfo (GeViClientID initClientID, Int32 initLocalID, Boolean initActive, Int32 initActualPosition, Int32 initActualTour, Int32 initDefaultTour, Int32 initPan, Int32 initTilt, Boolean initAutoPan, Boolean initAccessible)
Create the stateanswer 'S/N Info'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_PTZHeadInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViClientID | sClientID
ClientID des Klients, der diesen S/N Kopf verwaltet.
Int32 | sLocalID
LocalID des Kopfes.
Boolean | sActive
true - Klient ist bereits eingeloggt, false - nein
Int32 | sActualPosition
Gerade angefahrene Festposition (-1 unknown, -2 base)
Int32 | sActualTour
Gerade verwendete Kameratour (-1 unknown)
Int32 | sDefaultTour
Voreingestellte Kameratour (-1 unknown)
Int32 | sPan
Schwenkrichtung.
Int32 | sTilt
Neigerichtung.
Boolean | sAutoPan
AutoPan aktiv.
Boolean | sAccessible
PTZ Kopf mit aktuellen Rechten zugreifbar oder nicht.

Detailed Description

StateAnswer 'S/N Info'.

Constructor & Destructor Documentation

GeViSA_PTZHeadInfo::GeViSA_PTZHeadInfo | ( | GeViClientID | initClientID,
 |  | Int32 | initLocalID,
 |  | Boolean | initActive,
 |  | Int32 | initActualPosition,
 |  | Int32 | initActualTour,
 |  | Int32 | initDefaultTour,
 |  | Int32 | initPan,
 |  | Int32 | initTilt,
 |  | Boolean | initAutoPan,
 |  | Boolean | initAccessible
 | ) |  |

Create the stateanswer 'S/N Info'.

Member Function Documentation

GeViSA_PTZHeadInfo GeViSA_PTZHeadInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_PTZHeadInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sAccessible

PTZ Kopf mit aktuellen Rechten zugreifbar oder nicht.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sActive

true - Klient ist bereits eingeloggt, false - nein

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sActualPosition

Gerade angefahrene Festposition (-1 unknown, -2 base)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sActualTour

Gerade verwendete Kameratour (-1 unknown)

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sAutoPan

AutoPan aktiv.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sClientID

ClientID des Klients, der diesen S/N Kopf verwaltet.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sDefaultTour

Voreingestellte Kameratour (-1 unknown)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sLocalID

LocalID des Kopfes.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sPan

Schwenkrichtung.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo::sTilt

Neigerichtung.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState Class Reference

  • StateAnswers
  • GeViSA_SyncState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState Class Reference
State Queries and Answers

StateAnswer 'SyncState Info'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState:
[legend]

List of all members.

Public Member Functions

GeViSA_SyncState (Boolean initSyncOK)
Create the stateanswer 'SyncState Info'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_SyncState^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Boolean | sSyncOK
klar

Detailed Description

StateAnswer 'SyncState Info'.

Constructor & Destructor Documentation

GeViSA_SyncState::GeViSA_SyncState ( Boolean initSyncOK )

Create the stateanswer 'SyncState Info'.

Member Function Documentation

GeViSA_SyncState GeViSA_SyncState::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_SyncState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState::sSyncOK

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated Class Reference

  • StateAnswers
  • GeViSA_Terminated
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated Class Reference
State Queries and Answers

StateAnswer 'Die Anfrage oder Befehl wurde terminiert.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated:
[legend]

List of all members.

Public Member Functions

GeViSA_Terminated ()
Create the stateanswer 'Die Anfrage oder Befehl wurde terminiert.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_Terminated^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Die Anfrage oder Befehl wurde terminiert.'.

Constructor & Destructor Documentation

GeViSA_Terminated::GeViSA_Terminated ( )

Create the stateanswer 'Die Anfrage oder Befehl wurde terminiert.'.

Member Function Documentation

GeViSA_Terminated GeViSA_Terminated::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_Terminated::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo Class Reference

  • StateAnswers
  • GeViSA_ThresholdInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo Class Reference
State Queries and Answers

StateAnswer 'Gerade gemessener Schwellenwert'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_ThresholdInfo (Int32 initVideoInput, Int32 initThreshold, Int32 initMinThreshold, Int32 initAVGThreshold, Int32 initSecondsSinceStart, Int32 initNumberOfMeasures)
Create the stateanswer 'Gerade gemessener Schwellenwert'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_ThresholdInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

Int32 | sVideoInput
Lokaler Videoeingang des VSM (eigentlich der zugehoerigen Kreuzschiene)
Int32 | sThreshold
Threshold value, -1 sync failure, -2 failure.
Int32 | sMinThreshold
Minimaler Schwellenwert.
Int32 | sAVGThreshold
Durchschnittlicher Schwellenwert.
Int32 | sSecondsSinceStart
Dauer der Messreihe in Sekunden.
Int32 | sNumberOfMeasures
Anzahl der Einzelmesswerte.

Detailed Description

StateAnswer 'Gerade gemessener Schwellenwert'.

Constructor & Destructor Documentation

GeViSA_ThresholdInfo::GeViSA_ThresholdInfo | ( | Int32 | initVideoInput,
 |  | Int32 | initThreshold,
 |  | Int32 | initMinThreshold,
 |  | Int32 | initAVGThreshold,
 |  | Int32 | initSecondsSinceStart,
 |  | Int32 | initNumberOfMeasures
 | ) |  |

Create the stateanswer 'Gerade gemessener Schwellenwert'.

Member Function Documentation

GeViSA_ThresholdInfo GeViSA_ThresholdInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_ThresholdInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo::sAVGThreshold

Durchschnittlicher Schwellenwert.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo::sMinThreshold

Minimaler Schwellenwert.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo::sNumberOfMeasures

Anzahl der Einzelmesswerte.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo::sSecondsSinceStart

Dauer der Messreihe in Sekunden.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo::sThreshold

Threshold value, -1 sync failure, -2 failure.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo::sVideoInput

Lokaler Videoeingang des VSM (eigentlich der zugehoerigen Kreuzschiene)

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand Class Reference

  • StateAnswers
  • GeViSA_UnknownCommand
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand Class Reference
State Queries and Answers

StateAnswer 'Befehl nicht verstanden.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand:
[legend]

List of all members.

Public Member Functions

GeViSA_UnknownCommand ()
Create the stateanswer 'Befehl nicht verstanden.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_UnknownCommand^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Befehl nicht verstanden.'.

Constructor & Destructor Documentation

GeViSA_UnknownCommand::GeViSA_UnknownCommand ( )

Create the stateanswer 'Befehl nicht verstanden.'.

Member Function Documentation

GeViSA_UnknownCommand GeViSA_UnknownCommand::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_UnknownCommand::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights Class Reference

  • StateAnswers
  • GeViSA_UnsufficientRights
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights Class Reference
State Queries and Answers

StateAnswer 'Die Rechte sind nicht ausreichend.'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights:
[legend]

List of all members.

Public Member Functions

GeViSA_UnsufficientRights ()
Create the stateanswer 'Die Rechte sind nicht ausreichend.'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_UnsufficientRights^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Detailed Description

StateAnswer 'Die Rechte sind nicht ausreichend.'.

Constructor & Destructor Documentation

GeViSA_UnsufficientRights::GeViSA_UnsufficientRights ( )

Create the stateanswer 'Die Rechte sind nicht ausreichend.'.

Member Function Documentation

GeViSA_UnsufficientRights GeViSA_UnsufficientRights::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_UnsufficientRights::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo Class Reference

  • StateAnswers
  • GeViSA_VideoInputInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo Class Reference
State Queries and Answers

StateAnswer 'Info zu einem VideoEingang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_VideoInputInfo (GeViVideoInputID initGlobalID, GeViVideoInputID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Boolean initAccessible, Boolean initHasPTZHead, Boolean initHasVideoSensor, Boolean initHasContrastDetection, Boolean initHasSyncDetection, Int32 initAlarmCounter)
Create the stateanswer 'Info zu einem VideoEingang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_VideoInputInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViVideoInputID | sGlobalID
GlobalID des VideoEinganges.
GeViVideoInputID | sLocalID
LocalID des VideoEinganges.
GeViClientID | sClientID
ClientID des Klients, der diesen VideoEingang verwaltet.
String^ | sName
Name des Videoeingangs.
String^ | sDescription
Beschreibung des Videoeingangs.
Boolean | sActive
true - Klient ist bereits eingeloggt, false - nein
Boolean | sEnabled
Eingeschaltet oder zeitweise deaktiviert.
Boolean | sAccessible
Mit aktuellen Rechten zugreifbar oder nicht.
Boolean | sHasPTZHead
klar
Boolean | sHasVideoSensor
klar
Boolean | sHasContrastDetection
klar
Boolean | sHasSyncDetection
klar
Int32 | sAlarmCounter
Anzahl der vorgenommenen Alarm-Schaltungen.

Detailed Description

StateAnswer 'Info zu einem VideoEingang'.

Constructor & Destructor Documentation

GeViSA_VideoInputInfo::GeViSA_VideoInputInfo | ( | GeViVideoInputID | initGlobalID,
 |  | GeViVideoInputID | initLocalID,
 |  | GeViClientID | initClientID,
 |  | String^ | initName,
 |  | String^ | initDescription,
 |  | Boolean | initActive,
 |  | Boolean | initEnabled,
 |  | Boolean | initAccessible,
 |  | Boolean | initHasPTZHead,
 |  | Boolean | initHasVideoSensor,
 |  | Boolean | initHasContrastDetection,
 |  | Boolean | initHasSyncDetection,
 |  | Int32 | initAlarmCounter
 | ) |  |

Create the stateanswer 'Info zu einem VideoEingang'.

Member Function Documentation

GeViSA_VideoInputInfo GeViSA_VideoInputInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_VideoInputInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sAccessible

Mit aktuellen Rechten zugreifbar oder nicht.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sActive

true - Klient ist bereits eingeloggt, false - nein

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sAlarmCounter

Anzahl der vorgenommenen Alarm-Schaltungen.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sClientID

ClientID des Klients, der diesen VideoEingang verwaltet.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sDescription

Beschreibung des Videoeingangs.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sEnabled

Eingeschaltet oder zeitweise deaktiviert.

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sGlobalID

GlobalID des VideoEinganges.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sHasContrastDetection

klar

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sHasPTZHead

klar

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sHasSyncDetection

klar

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sHasVideoSensor

klar

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sLocalID

LocalID des VideoEinganges.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo::sName

Name des Videoeingangs.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo Class Reference

  • StateAnswers
  • GeViSA_VideoOutputInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo Class Reference
State Queries and Answers

StateAnswer 'Info zu einem Videoausgang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_VideoOutputInfo (GeViVideoOutputID initGlobalID, GeViVideoOutputID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Boolean initAccessible, GeViVideoInputID initActualCamera, Int32 initActualCycle, Boolean initHasAlarm)
Create the stateanswer 'Info zu einem Videoausgang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_VideoOutputInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViVideoOutputID | sGlobalID
GlobalID des Videoausganges.
GeViVideoOutputID | sLocalID
LocalID des Videoausganges.
GeViClientID | sClientID
ClientID des Klients, der diesen Videoausgang verwaltet.
String^ | sName
Name des Videoausgangs.
String^ | sDescription
Beschreibung des Videoausgangs.
Boolean | sActive
true - Klient ist bereits eingeloggt, false - nein
Boolean | sEnabled
Eingeschaltet oder zeitweise deaktiviert.
Boolean | sAccessible
Mit aktuellen Rechten zugreifbar oder nicht.
GeViVideoInputID | sActualCamera
Gerade geschaltete Kamera.
Int32 | sActualCycle
Gerade laufender Camerazyklus.
Boolean | sHasAlarm
Eine Alarmaufschaltung?

Detailed Description

StateAnswer 'Info zu einem Videoausgang'.

Constructor & Destructor Documentation

GeViSA_VideoOutputInfo::GeViSA_VideoOutputInfo | ( | GeViVideoOutputID | initGlobalID,
 |  | GeViVideoOutputID | initLocalID,
 |  | GeViClientID | initClientID,
 |  | String^ | initName,
 |  | String^ | initDescription,
 |  | Boolean | initActive,
 |  | Boolean | initEnabled,
 |  | Boolean | initAccessible,
 |  | GeViVideoInputID | initActualCamera,
 |  | Int32 | initActualCycle,
 |  | Boolean | initHasAlarm
 | ) |  |

Create the stateanswer 'Info zu einem Videoausgang'.

Member Function Documentation

GeViSA_VideoOutputInfo GeViSA_VideoOutputInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_VideoOutputInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sAccessible

Mit aktuellen Rechten zugreifbar oder nicht.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sActive

true - Klient ist bereits eingeloggt, false - nein

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sActualCamera

Gerade geschaltete Kamera.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sActualCycle

Gerade laufender Camerazyklus.

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sClientID

ClientID des Klients, der diesen Videoausgang verwaltet.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sDescription

Beschreibung des Videoausgangs.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sEnabled

Eingeschaltet oder zeitweise deaktiviert.

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sGlobalID

GlobalID des Videoausganges.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sHasAlarm

Eine Alarmaufschaltung?

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sLocalID

LocalID des Videoausganges.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo::sName

Name des Videoausgangs.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo Class Reference

  • StateAnswers
  • GeViSA_VideoSensorInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo Class Reference
State Queries and Answers

StateAnswer 'VideoSensor Info'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo:
[legend]

List of all members.

Public Member Functions

GeViSA_VideoSensorInfo (GeViClientID initClientID, Int32 initLocalID, Boolean initActive, Boolean initArmed, Boolean initHasAlarm, Boolean initHasPreAlarm, Int32 initAlarmField, Byte initAlarmTime, Boolean initSyncOK, Boolean initContrastOK, Boolean initAccessible)
Create the stateanswer 'VideoSensor Info'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this stateanswer.

Static Public Member Functions

static GeViSA_VideoSensorInfo^ | FromNativeStateAnswer (CStateAnswer *nativeStateAnswer)
Create a managed instance of this stateanswer by using a native C++ instance.

Properties

GeViClientID | sClientID
ClientID des Klients, der diesen VideoSensor verwaltet.
Int32 | sLocalID
VMD * 10 + Eingang des VideoSensors.
Boolean | sActive
true - Klient ist bereits eingeloggt, false - nein
Boolean | sArmed
Scharf?
Boolean | sHasAlarm
klar
Boolean | sHasPreAlarm
klar
Int32 | sAlarmField
klar, "-1" - externer Alarm
Byte | sAlarmTime
klar
Boolean | sSyncOK
klar
Boolean | sContrastOK
klar
Boolean | sAccessible
VS mit aktuellen Rechten zugreifbar oder nicht.

Detailed Description

StateAnswer 'VideoSensor Info'.

Constructor & Destructor Documentation

GeViSA_VideoSensorInfo::GeViSA_VideoSensorInfo | ( | GeViClientID | initClientID,
 |  | Int32 | initLocalID,
 |  | Boolean | initActive,
 |  | Boolean | initArmed,
 |  | Boolean | initHasAlarm,
 |  | Boolean | initHasPreAlarm,
 |  | Int32 | initAlarmField,
 |  | Byte | initAlarmTime,
 |  | Boolean | initSyncOK,
 |  | Boolean | initContrastOK,
 |  | Boolean | initAccessible
 | ) |  |

Create the stateanswer 'VideoSensor Info'.

Member Function Documentation

GeViSA_VideoSensorInfo GeViSA_VideoSensorInfo::FromNativeStateAnswer ( CStateAnswer * nativeStateAnswer ) [static]

Create a managed instance of this stateanswer by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the stateanswer.
CGeViMessage * GeViSA_VideoSensorInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this stateanswer.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sAccessible

VS mit aktuellen Rechten zugreifbar oder nicht.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sActive

true - Klient ist bereits eingeloggt, false - nein

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sAlarmField

klar, "-1" - externer Alarm

Byte GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sAlarmTime

klar

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sArmed

Scharf?

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sClientID

ClientID des Klients, der diesen VideoSensor verwaltet.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sContrastOK

klar

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sHasAlarm

klar

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sHasPreAlarm

klar

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sLocalID

VMD * 10 + Eingang des VideoSensors.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo::sSyncOK

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper Struct Reference

  • GeViSoftConnectProgressCallbackWrapper
Public Member Functions | Private Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper Struct Reference
Database Functions

List of all members.

Public Member Functions

GeViSoftConnectProgressCallbackWrapper (GeViSoftConnectProgressDelegate^ instance, TGeViConnectProgress callback)
~GeViSoftConnectProgressCallbackWrapper ()
TGeViConnectProgress | GetNativeCallback ()
void * | GetNativeInstance ()
GeViSoftConnectProgressDelegate^ | Invoke ()

Private Attributes

void * | _NativeInstance
TGeViConnectProgress | _NativeCallback
gcroot
< GeViSoftConnectProgressDelegate^ > 		_DelegateInstance

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::GeViSoftConnectProgressCallbackWrapper | ( | GeViSoftConnectProgressDelegate^ | instance,
 |  | TGeViConnectProgress | callback
 | ) |  |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::~GeViSoftConnectProgressCallbackWrapper ( )

Member Function Documentation

TGeViConnectProgress GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::GetNativeCallback ( )
void* GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::GetNativeInstance ( )
GeViSoftConnectProgressDelegate ^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::Invoke ( )

Member Data Documentation

gcroot<GeViSoftConnectProgressDelegate^> GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::_DelegateInstance [private]
TGeViConnectProgress GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::_NativeCallback [private]
void* GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper::_NativeInstance [private]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs Class Reference

  • GeViSoftConnectProgressEventArgs
Public Member Functions | Properties | Private Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs Class Reference
Database Functions

List of all members.

Public Member Functions

GeViSoftConnectProgressEventArgs (Int32 progress, Int32 effort)

Properties

Int32 | Progress [get]
Int32 | Effort [get]

Private Attributes

Int32 | m_Progress
Int32 | m_Effort

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs::GeViSoftConnectProgressEventArgs | ( | Int32 | progress,
 |  | Int32 | effort
 | ) |  |

Member Data Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs::m_Effort [private]
Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs::m_Progress [private]

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs::Effort [get]
Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs::Progress [get]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper Struct Reference

  • GeViSoftDatabaseNotificationCallbackWrapper
Public Member Functions | Private Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper Struct Reference
Database Functions

List of all members.

Public Member Functions

GeViSoftDatabaseNotificationCallbackWrapper (GeViSoftDatabaseNotificationDelegate^ instance, TGeViDatabaseNotification callback)
~GeViSoftDatabaseNotificationCallbackWrapper ()
TGeViDatabaseNotification | GetNativeCallback ()
void * | GetNativeInstance ()
GeViSoftDatabaseNotificationDelegate^ | Invoke ()

Private Attributes

void * | _NativeInstance
TGeViDatabaseNotification | _NativeCallback
gcroot
< GeViSoftDatabaseNotificationDelegate^ > 		_DelegateInstance

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::GeViSoftDatabaseNotificationCallbackWrapper | ( | GeViSoftDatabaseNotificationDelegate^ | instance,
 |  | TGeViDatabaseNotification | callback
 | ) |  |
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::~GeViSoftDatabaseNotificationCallbackWrapper ( )

Member Function Documentation

TGeViDatabaseNotification GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::GetNativeCallback ( )
void* GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::GetNativeInstance ( )
GeViSoftDatabaseNotificationDelegate ^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::Invoke ( )

Member Data Documentation

gcroot<GeViSoftDatabaseNotificationDelegate^> GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::_DelegateInstance [private]
TGeViDatabaseNotification GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::_NativeCallback [private]
void* GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper::_NativeInstance [private]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs Class Reference

  • GeViSoftDatabaseNotificationEventArgs
Public Member Functions | Properties | Private Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs Class Reference
Database Functions

List of all members.

Public Member Functions

GeViSoftDatabaseNotificationEventArgs (GeViServerNotification notification, IntPtr params)

Properties

GeViServerNotification | ServerNotificationType [get]
IntPtr | Params [get]

Private Attributes

GeViServerNotification | m_ServerNotification
IntPtr | m_params

Constructor & Destructor Documentation

GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs::GeViSoftDatabaseNotificationEventArgs | ( | GeViServerNotification | notification,
 |  | IntPtr | params
 | ) |  |

Member Data Documentation

IntPtr GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs::m_params [private]
GeViServerNotification GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs::m_ServerNotification [private]

Property Documentation

IntPtr GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs::Params [get]
GeViServerNotification GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs::ServerNotificationType [get]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex Class Reference

  • StateQueries
  • GeViSQ_GetAlarmOnMGByIndex
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex Class Reference
State Queries and Answers

StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetAlarmOnMGByIndex (Int32 initResID, Int32 initIndex)
Create the query 'Fragt die Sichtbarkeit des Alarm auf der MG'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetAlarmOnMGByIndex^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int32 | sResID
GlobalID des Alarms.
Int32 | sIndex
Index (von 0 bis PresentedOnCount)

Detailed Description

StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'.

Constructor & Destructor Documentation

GeViSQ_GetAlarmOnMGByIndex::GeViSQ_GetAlarmOnMGByIndex | ( | Int32 | initResID,
 |  | Int32 | initIndex
 | ) |  |

Create the query 'Fragt die Sichtbarkeit des Alarm auf der MG'.

Member Function Documentation

GeViSQ_GetAlarmOnMGByIndex GeViSQ_GetAlarmOnMGByIndex::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetAlarmOnMGByIndex::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex::sIndex

Index (von 0 bis PresentedOnCount)

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex::sResID

GlobalID des Alarms.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo Class Reference

  • StateQueries
  • GeViSQ_GetAlarmOnMGInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo Class Reference
State Queries and Answers

StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetAlarmOnMGInfo (Int32 initResID, Int32 initMGID)
Create the query 'Fragt die Sichtbarkeit des Alarm auf der MG'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetAlarmOnMGInfo^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int32 | sResID
GlobalID des Alarms.
Int32 | sMGID
GlobalID der MG.

Detailed Description

StateQuery 'Fragt die Sichtbarkeit des Alarm auf der MG'.

Constructor & Destructor Documentation

GeViSQ_GetAlarmOnMGInfo::GeViSQ_GetAlarmOnMGInfo | ( | Int32 | initResID,
 |  | Int32 | initMGID
 | ) |  |

Create the query 'Fragt die Sichtbarkeit des Alarm auf der MG'.

Member Function Documentation

GeViSQ_GetAlarmOnMGInfo GeViSQ_GetAlarmOnMGInfo::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetAlarmOnMGInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo::sMGID

GlobalID der MG.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo::sResID

GlobalID des Alarms.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms Class Reference

  • StateQueries
  • GeViSQ_GetAlarms
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetAlarms (Int32 initResID)
Create the query 'Liefert die Information zum bestimmten Alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetAlarms^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int32 | sResID
GlobalID des Alarms (Alarmtyps)

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Alarm'.

Constructor & Destructor Documentation

GeViSQ_GetAlarms::GeViSQ_GetAlarms ( Int32 initResID )

Create the query 'Liefert die Information zum bestimmten Alarm'.

Member Function Documentation

GeViSQ_GetAlarms GeViSQ_GetAlarms::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetAlarms::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms::sResID

GlobalID des Alarms (Alarmtyps)

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName Class Reference

  • StateQueries
  • GeViSQ_GetAlarmsByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetAlarmsByName (String^ initName)
Create the query 'Liefert die Information zum bestimmten Alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetAlarmsByName^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sName
Name des Alarms.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Alarm'.

Constructor & Destructor Documentation

GeViSQ_GetAlarmsByName::GeViSQ_GetAlarmsByName ( String^ initName )

Create the query 'Liefert die Information zum bestimmten Alarm'.

Member Function Documentation

GeViSQ_GetAlarmsByName GeViSQ_GetAlarmsByName::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetAlarmsByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName::sName

Name des Alarms.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient Class Reference

  • StateQueries
  • GeViSQ_GetClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Klient'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetClient (GeViClientID initClientID)
Create the query 'Liefert die Information zum bestimmten Klient'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetClient^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViClientID | sClientID
ClientID des abzufragenden Klienten.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Klient'.

Constructor & Destructor Documentation

GeViSQ_GetClient::GeViSQ_GetClient ( GeViClientID initClientID )

Create the query 'Liefert die Information zum bestimmten Klient'.

Member Function Documentation

GeViSQ_GetClient GeViSQ_GetClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient::sClientID

ClientID des abzufragenden Klienten.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName Class Reference

  • StateQueries
  • GeViSQ_GetClientByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Klient'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetClientByName (String^ initName)
Create the query 'Liefert die Information zum bestimmten Klient'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetClientByName^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sName
Name des abzufragenden Klienten.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Klient'.

Constructor & Destructor Documentation

GeViSQ_GetClientByName::GeViSQ_GetClientByName ( String^ initName )

Create the query 'Liefert die Information zum bestimmten Klient'.

Member Function Documentation

GeViSQ_GetClientByName GeViSQ_GetClientByName::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetClientByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName::sName

Name des abzufragenden Klienten.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState Class Reference

  • StateQueries
  • GeViSQ_GetContrastState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState Class Reference
State Queries and Answers

StateQuery 'Fragt die PictureState Info ab'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetContrastState (GeViVideoInputID initResID)
Create the query 'Fragt die PictureState Info ab'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetContrastState^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViVideoInputID | sResID
GlobalID des VideoEinganges.

Detailed Description

StateQuery 'Fragt die PictureState Info ab'.

Constructor & Destructor Documentation

GeViSQ_GetContrastState::GeViSQ_GetContrastState ( GeViVideoInputID initResID )

Create the query 'Fragt die PictureState Info ab'.

Member Function Documentation

GeViSQ_GetContrastState GeViSQ_GetContrastState::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetContrastState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState::sResID

GlobalID des VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm Class Reference

  • StateQueries
  • GeViSQ_GetFirstAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstAlarm (Boolean initActiveOnly, Boolean initEnabledOnly)
Create the query 'Liefert die Information zu dem ersten Alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetFirstAlarm^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die aktiven Alarms, false - alle
Boolean | sEnabledOnly
klar

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Alarm'.

Constructor & Destructor Documentation

GeViSQ_GetFirstAlarm::GeViSQ_GetFirstAlarm | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Alarm'.

Member Function Documentation

GeViSQ_GetFirstAlarm GeViSQ_GetFirstAlarm::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm::sActiveOnly

true - nur die aktiven Alarms, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient Class Reference

  • StateQueries
  • GeViSQ_GetFirstClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Klient'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstClient (Boolean initActiveOnly)
Create the query 'Liefert die Information zu dem ersten Klient'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetFirstClient^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur eingeloggte Klienten

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Klient'.

Constructor & Destructor Documentation

GeViSQ_GetFirstClient::GeViSQ_GetFirstClient ( Boolean initActiveOnly )

Create the query 'Liefert die Information zu dem ersten Klient'.

Member Function Documentation

GeViSQ_GetFirstClient GeViSQ_GetFirstClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient::sActiveOnly

true - nur eingeloggte Klienten

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType Class Reference

  • StateQueries
  • GeViSQ_GetFirstClientOfType
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Klient dieses Typs'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstClientOfType (Boolean initActiveOnly, Int32 initSQClientType)
Create the query 'Liefert die Information zu dem ersten Klient dieses Typs'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetFirstClientOfType^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur eingeloggte Klienten
Int32 | sSQClientType
enum

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Klient dieses Typs'.

Constructor & Destructor Documentation

GeViSQ_GetFirstClientOfType::GeViSQ_GetFirstClientOfType | ( | Boolean | initActiveOnly,
 |  | Int32 | initSQClientType
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Klient dieses Typs'.

Member Function Documentation

GeViSQ_GetFirstClientOfType GeViSQ_GetFirstClientOfType::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstClientOfType::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType::sActiveOnly

true - nur eingeloggte Klienten

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType::sSQClientType

enum

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact Class Reference

  • StateQueries
  • GeViSQ_GetFirstInputContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Eingangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstInputContact (Boolean initActiveOnly, Boolean initEnabledOnly)
Create the query 'Liefert die Information zu dem ersten Eingangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetFirstInputContact^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Eingangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetFirstInputContact::GeViSQ_GetFirstInputContact | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Eingangskontakt'.

Member Function Documentation

GeViSQ_GetFirstInputContact GeViSQ_GetFirstInputContact::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstInputContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact::sActiveOnly

true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient Class Reference

  • StateQueries
  • GeViSQ_GetFirstInputContactOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Eingangskontakt des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstInputContactOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem ersten Eingangskontakt des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetFirstInputContactOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Eingangskontakt des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetFirstInputContactOfClient::GeViSQ_GetFirstInputContactOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Eingangskontakt des Clients'.

Member Function Documentation

GeViSQ_GetFirstInputContactOfClient GeViSQ_GetFirstInputContactOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstInputContactOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient::sActiveOnly

true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup Class Reference

  • StateQueries
  • GeViSQ_GetFirstMonitorGroup
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu der ersten MG'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstMonitorGroup (Boolean initActiveOnly, Boolean initEnabledOnly)
Create the query 'Liefert die Information zu der ersten MG'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetFirstMonitorGroup^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Monitorgruppen, die aktiv sind, false - alle
Boolean | sEnabledOnly
klar

Detailed Description

StateQuery 'Liefert die Information zu der ersten MG'.

Constructor & Destructor Documentation

GeViSQ_GetFirstMonitorGroup::GeViSQ_GetFirstMonitorGroup | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly
 | ) |  |

Create the query 'Liefert die Information zu der ersten MG'.

Member Function Documentation

GeViSQ_GetFirstMonitorGroup GeViSQ_GetFirstMonitorGroup::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstMonitorGroup::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup::sActiveOnly

true - nur die Monitorgruppen, die aktiv sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact Class Reference

  • StateQueries
  • GeViSQ_GetFirstOutputContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstOutputContact (Boolean initActiveOnly, Boolean initEnabledOnly)
Create the query 'Liefert die Information zu dem ersten Ausgangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetFirstOutputContact^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetFirstOutputContact::GeViSQ_GetFirstOutputContact | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Ausgangskontakt'.

Member Function Documentation

GeViSQ_GetFirstOutputContact GeViSQ_GetFirstOutputContact::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstOutputContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact::sActiveOnly

true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient Class Reference

  • StateQueries
  • GeViSQ_GetFirstOutputContactOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstOutputContactOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem ersten Ausgangskontakt des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetFirstOutputContactOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Ausgangskontakt des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetFirstOutputContactOfClient::GeViSQ_GetFirstOutputContactOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Ausgangskontakt des Clients'.

Member Function Documentation

GeViSQ_GetFirstOutputContactOfClient GeViSQ_GetFirstOutputContactOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstOutputContactOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient::sActiveOnly

true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput Class Reference

  • StateQueries
  • GeViSQ_GetFirstVideoInput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten VideoEingang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstVideoInput (Boolean initActiveOnly, Boolean initEnabledOnly)
Create the query 'Liefert die Information zu dem ersten VideoEingang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetFirstVideoInput^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar

Detailed Description

StateQuery 'Liefert die Information zu dem ersten VideoEingang'.

Constructor & Destructor Documentation

GeViSQ_GetFirstVideoInput::GeViSQ_GetFirstVideoInput | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly
 | ) |  |

Create the query 'Liefert die Information zu dem ersten VideoEingang'.

Member Function Documentation

GeViSQ_GetFirstVideoInput GeViSQ_GetFirstVideoInput::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstVideoInput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput::sActiveOnly

true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient Class Reference

  • StateQueries
  • GeViSQ_GetFirstVideoInputOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten VideoEingang des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstVideoInputOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem ersten VideoEingang des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetFirstVideoInputOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem ersten VideoEingang des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetFirstVideoInputOfClient::GeViSQ_GetFirstVideoInputOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem ersten VideoEingang des Clients'.

Member Function Documentation

GeViSQ_GetFirstVideoInputOfClient GeViSQ_GetFirstVideoInputOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstVideoInputOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient::sActiveOnly

true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput Class Reference

  • StateQueries
  • GeViSQ_GetFirstVideoOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Videoausgang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstVideoOutput (Boolean initActiveOnly, Boolean initEnabledOnly)
Create the query 'Liefert die Information zu dem ersten Videoausgang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetFirstVideoOutput^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Videoausgaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Videoausgang'.

Constructor & Destructor Documentation

GeViSQ_GetFirstVideoOutput::GeViSQ_GetFirstVideoOutput | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Videoausgang'.

Member Function Documentation

GeViSQ_GetFirstVideoOutput GeViSQ_GetFirstVideoOutput::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstVideoOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput::sActiveOnly

true - nur die Videoausgaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient Class Reference

  • StateQueries
  • GeViSQ_GetFirstVideoOutputOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem ersten Videoausgang des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetFirstVideoOutputOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem ersten Videoausgang des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetFirstVideoOutputOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Videoausgaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem ersten Videoausgang des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetFirstVideoOutputOfClient::GeViSQ_GetFirstVideoOutputOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem ersten Videoausgang des Clients'.

Member Function Documentation

GeViSQ_GetFirstVideoOutputOfClient GeViSQ_GetFirstVideoOutputOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetFirstVideoOutputOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient::sActiveOnly

true - nur die Videoausgaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient::sEnabledOnly

klar

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime Class Reference

  • StateQueries
  • GeViSQ_GetInfoDatabaseCreationTime
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime Class Reference
State Queries and Answers

StateQuery 'Liefert die Datenbankzeit zurueck'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetInfoDatabaseCreationTime ()
Create the query 'Liefert die Datenbankzeit zurueck'.
virtual CGeViMessage * ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetInfoDatabaseCreationTime^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Detailed Description

StateQuery 'Liefert die Datenbankzeit zurueck'.

Constructor & Destructor Documentation

GeViSQ_GetInfoDatabaseCreationTime::GeViSQ_GetInfoDatabaseCreationTime ( )

Create the query 'Liefert die Datenbankzeit zurueck'.

Member Function Documentation

GeViSQ_GetInfoDatabaseCreationTime GeViSQ_GetInfoDatabaseCreationTime::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetInfoDatabaseCreationTime::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime Class Reference

  • StateQueries
  • GeViSQ_GetInfoServerStartTime
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime Class Reference
State Queries and Answers

StateQuery 'Liefert die Serverstartzeit zurueck'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetInfoServerStartTime ()
Create the query 'Liefert die Serverstartzeit zurueck'.
virtual CGeViMessage * ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetInfoServerStartTime^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Detailed Description

StateQuery 'Liefert die Serverstartzeit zurueck'.

Constructor & Destructor Documentation

GeViSQ_GetInfoServerStartTime::GeViSQ_GetInfoServerStartTime ( )

Create the query 'Liefert die Serverstartzeit zurueck'.

Member Function Documentation

GeViSQ_GetInfoServerStartTime GeViSQ_GetInfoServerStartTime::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetInfoServerStartTime::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact Class Reference

  • StateQueries
  • GeViSQ_GetInputContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetInputContact (GeViInputContactID initResID)
Create the query 'Liefert die Information zum bestimmten Eingangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetInputContact^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViInputContactID | sResID
InputContactID des Eingangskontaktes.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetInputContact::GeViSQ_GetInputContact ( GeViInputContactID initResID )

Create the query 'Liefert die Information zum bestimmten Eingangskontakt'.

Member Function Documentation

GeViSQ_GetInputContact GeViSQ_GetInputContact::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetInputContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViInputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact::sResID

InputContactID des Eingangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName Class Reference

  • StateQueries
  • GeViSQ_GetInputContactByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetInputContactByName (String^ initName)
Create the query 'Liefert die Information zum bestimmten Eingangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetInputContactByName^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sName
Name des Eingangskontaktes.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Eingangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetInputContactByName::GeViSQ_GetInputContactByName ( String^ initName )

Create the query 'Liefert die Information zum bestimmten Eingangskontakt'.

Member Function Documentation

GeViSQ_GetInputContactByName GeViSQ_GetInputContactByName::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetInputContactByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName::sName

Name des Eingangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo Class Reference

  • StateQueries
  • GeViSQ_GetLicenseInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo Class Reference
State Queries and Answers

StateQuery 'Liefert die Lizenzinformation zurueck'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetLicenseInfo (Int32 initLicVersion)
Create the query 'Liefert die Lizenzinformation zurueck'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetLicenseInfo^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int32 | sLicVersion
Version der Lizenzzeichenkette (0 - default)

Detailed Description

StateQuery 'Liefert die Lizenzinformation zurueck'.

Constructor & Destructor Documentation

GeViSQ_GetLicenseInfo::GeViSQ_GetLicenseInfo ( Int32 initLicVersion )

Create the query 'Liefert die Lizenzinformation zurueck'.

Member Function Documentation

GeViSQ_GetLicenseInfo GeViSQ_GetLicenseInfo::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetLicenseInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo::sLicVersion

Version der Lizenzzeichenkette (0 - default)

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue Class Reference

  • StateQueries
  • GeViSQ_GetLicenseValue
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue Class Reference
State Queries and Answers

StateQuery 'Liefert den Wert eines bestimmten Eintrags zurueck'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetLicenseValue (String^ initLicName)
Create the query 'Liefert den Wert eines bestimmten Eintrags zurueck'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetLicenseValue^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sLicName
Name des Eintrags.

Detailed Description

StateQuery 'Liefert den Wert eines bestimmten Eintrags zurueck'.

Constructor & Destructor Documentation

GeViSQ_GetLicenseValue::GeViSQ_GetLicenseValue ( String^ initLicName )

Create the query 'Liefert den Wert eines bestimmten Eintrags zurueck'.

Member Function Documentation

GeViSQ_GetLicenseValue GeViSQ_GetLicenseValue::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetLicenseValue::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue::sLicName

Name des Eintrags.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo Class Reference

  • StateQueries
  • GeViSQ_GetLoginInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo Class Reference
State Queries and Answers

StateQuery 'Login Information zu dem Klient'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetLoginInfo (GeViClientID initClientID, Int32 initEntryNumber)
Create the query 'Login Information zu dem Klient'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetLoginInfo^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViClientID | sClientID
ClientID des Klienten.
Int32 | sEntryNumber
Nummer des Eintrages (0 .. LoginCount(vom vorhergehenden Antwort))

Detailed Description

StateQuery 'Login Information zu dem Klient'.

Constructor & Destructor Documentation

GeViSQ_GetLoginInfo::GeViSQ_GetLoginInfo | ( | GeViClientID | initClientID,
 |  | Int32 | initEntryNumber
 | ) |  |

Create the query 'Login Information zu dem Klient'.

Member Function Documentation

GeViSQ_GetLoginInfo GeViSQ_GetLoginInfo::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetLoginInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo::sClientID

ClientID des Klienten.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo::sEntryNumber

Nummer des Eintrages (0 .. LoginCount(vom vorhergehenden Antwort))

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup Class Reference

  • StateQueries
  • GeViSQ_GetMonitorGroup
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zur bestimmten MG'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetMonitorGroup (Int32 initResID)
Create the query 'Liefert die Information zur bestimmten MG'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetMonitorGroup^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int32 | sResID
GlobalID der MG.

Detailed Description

StateQuery 'Liefert die Information zur bestimmten MG'.

Constructor & Destructor Documentation

GeViSQ_GetMonitorGroup::GeViSQ_GetMonitorGroup ( Int32 initResID )

Create the query 'Liefert die Information zur bestimmten MG'.

Member Function Documentation

GeViSQ_GetMonitorGroup GeViSQ_GetMonitorGroup::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetMonitorGroup::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup::sResID

GlobalID der MG.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName Class Reference

  • StateQueries
  • GeViSQ_GetMonitorGroupByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zur bestimmten MG'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetMonitorGroupByName (String^ initName)
Create the query 'Liefert die Information zur bestimmten MG'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetMonitorGroupByName^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sName
Name der MG.

Detailed Description

StateQuery 'Liefert die Information zur bestimmten MG'.

Constructor & Destructor Documentation

GeViSQ_GetMonitorGroupByName::GeViSQ_GetMonitorGroupByName ( String^ initName )

Create the query 'Liefert die Information zur bestimmten MG'.

Member Function Documentation

GeViSQ_GetMonitorGroupByName GeViSQ_GetMonitorGroupByName::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetMonitorGroupByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName::sName

Name der MG.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm Class Reference

  • StateQueries
  • GeViSQ_GetNextAlarm
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Alarm'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextAlarm (Boolean initActiveOnly, Boolean initEnabledOnly, Int32 initPrevID)
Create the query 'Liefert die Information zu dem naechsten Alarm'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextAlarm^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die aktiven Alarms, die aktiv sind, false - alle
Boolean | sEnabledOnly
klar
Int32 | sPrevID
GlobalID des vorher abgefragten Alarms.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Alarm'.

Constructor & Destructor Documentation

GeViSQ_GetNextAlarm::GeViSQ_GetNextAlarm | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | Int32 | initPrevID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Alarm'.

Member Function Documentation

GeViSQ_GetNextAlarm GeViSQ_GetNextAlarm::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextAlarm::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm::sActiveOnly

true - nur die aktiven Alarms, die aktiv sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm::sEnabledOnly

klar

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm::sPrevID

GlobalID des vorher abgefragten Alarms.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient Class Reference

  • StateQueries
  • GeViSQ_GetNextClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Klient'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextClient (Boolean initActiveOnly, GeViClientID initPrevID)
Create the query 'Liefert die Information zu dem naechsten Klient'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextClient^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur eingeloggte Klienten
GeViClientID | sPrevID
ClientID des vorher abgefragten Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Klient'.

Constructor & Destructor Documentation

GeViSQ_GetNextClient::GeViSQ_GetNextClient | ( | Boolean | initActiveOnly,
 |  | GeViClientID | initPrevID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Klient'.

Member Function Documentation

GeViSQ_GetNextClient GeViSQ_GetNextClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient::sActiveOnly

true - nur eingeloggte Klienten

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient::sPrevID

ClientID des vorher abgefragten Klienten.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType Class Reference

  • StateQueries
  • GeViSQ_GetNextClientOfType
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Klient des angegeben Typs'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextClientOfType (Boolean initActiveOnly, GeViClientID initPrevID, Int32 initSQClientType)
Create the query 'Liefert die Information zu dem naechsten Klient des angegeben Typs'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextClientOfType^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur eingeloggte Klienten
GeViClientID | sPrevID
ClientID des vorher abgefragten Klienten.
Int32 | sSQClientType
enum

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Klient des angegeben Typs'.

Constructor & Destructor Documentation

GeViSQ_GetNextClientOfType::GeViSQ_GetNextClientOfType | ( | Boolean | initActiveOnly,
 |  | GeViClientID | initPrevID,
 |  | Int32 | initSQClientType
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Klient des angegeben Typs'.

Member Function Documentation

GeViSQ_GetNextClientOfType GeViSQ_GetNextClientOfType::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextClientOfType::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType::sActiveOnly

true - nur eingeloggte Klienten

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType::sPrevID

ClientID des vorher abgefragten Klienten.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType::sSQClientType

enum

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact Class Reference

  • StateQueries
  • GeViSQ_GetNextInputContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextInputContact (Boolean initActiveOnly, Boolean initEnabledOnly, GeViInputContactID initPrevID)
Create the query 'Liefert die Information zu dem naechsten Eingangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextInputContact^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViInputContactID | sPrevID
InputContactID des vorher abgefragten Eingangskontaktes.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetNextInputContact::GeViSQ_GetNextInputContact | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViInputContactID | initPrevID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Eingangskontakt'.

Member Function Documentation

GeViSQ_GetNextInputContact GeViSQ_GetNextInputContact::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextInputContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact::sActiveOnly

true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact::sEnabledOnly

klar

GeViInputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact::sPrevID

InputContactID des vorher abgefragten Eingangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient Class Reference

  • StateQueries
  • GeViSQ_GetNextInputContactOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextInputContactOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViInputContactID initPrevID, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem naechsten Eingangskontakt des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetNextInputContactOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViInputContactID | sPrevID
InputContactID des vorher abgefragten Eingangskontaktes.
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Eingangskontakt des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetNextInputContactOfClient::GeViSQ_GetNextInputContactOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViInputContactID | initPrevID,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Eingangskontakt des Clients'.

Member Function Documentation

GeViSQ_GetNextInputContactOfClient GeViSQ_GetNextInputContactOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextInputContactOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient::sActiveOnly

true - nur die Eingangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient::sEnabledOnly

klar

GeViInputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient::sPrevID

InputContactID des vorher abgefragten Eingangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup Class Reference

  • StateQueries
  • GeViSQ_GetNextMonitorGroup
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu der naechsten MG'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextMonitorGroup (Boolean initActiveOnly, Boolean initEnabledOnly, Int32 initPrevID)
Create the query 'Liefert die Information zu der naechsten MG'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextMonitorGroup^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Monitorgruppen, die aktiv sind, false - alle
Boolean | sEnabledOnly
klar
Int32 | sPrevID
GlobalID der vorher abgefragten MG.

Detailed Description

StateQuery 'Liefert die Information zu der naechsten MG'.

Constructor & Destructor Documentation

GeViSQ_GetNextMonitorGroup::GeViSQ_GetNextMonitorGroup | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | Int32 | initPrevID
 | ) |  |

Create the query 'Liefert die Information zu der naechsten MG'.

Member Function Documentation

GeViSQ_GetNextMonitorGroup GeViSQ_GetNextMonitorGroup::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextMonitorGroup::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup::sActiveOnly

true - nur die Monitorgruppen, die aktiv sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup::sEnabledOnly

klar

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup::sPrevID

GlobalID der vorher abgefragten MG.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact Class Reference

  • StateQueries
  • GeViSQ_GetNextOutputContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextOutputContact (Boolean initActiveOnly, Boolean initEnabledOnly, GeViOutputContactID initPrevID)
Create the query 'Liefert die Information zu dem naechsten Ausgangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextOutputContact^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViOutputContactID | sPrevID
OutputContactID des vorher abgefragten Ausgangskontaktes.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetNextOutputContact::GeViSQ_GetNextOutputContact | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViOutputContactID | initPrevID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Ausgangskontakt'.

Member Function Documentation

GeViSQ_GetNextOutputContact GeViSQ_GetNextOutputContact::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextOutputContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact::sActiveOnly

true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact::sEnabledOnly

klar

GeViOutputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact::sPrevID

OutputContactID des vorher abgefragten Ausgangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient Class Reference

  • StateQueries
  • GeViSQ_GetNextOutputContactOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextOutputContactOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViOutputContactID initPrevID, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem naechsten Ausgangskontakt des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetNextOutputContactOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViOutputContactID | sPrevID
OutputContactID des vorher abgefragten Ausgangskontaktes.
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Ausgangskontakt des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetNextOutputContactOfClient::GeViSQ_GetNextOutputContactOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViOutputContactID | initPrevID,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Ausgangskontakt des Clients'.

Member Function Documentation

GeViSQ_GetNextOutputContactOfClient GeViSQ_GetNextOutputContactOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextOutputContactOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient::sActiveOnly

true - nur die Ausgangskontakte, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient::sEnabledOnly

klar

GeViOutputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient::sPrevID

OutputContactID des vorher abgefragten Ausgangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput Class Reference

  • StateQueries
  • GeViSQ_GetNextVideoInput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten VideoEingang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextVideoInput (Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoInputID initPrevID)
Create the query 'Liefert die Information zu dem naechsten VideoEingang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextVideoInput^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViVideoInputID | sPrevID
VideoInputID des vorher abgefragten VideoEinganges.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten VideoEingang'.

Constructor & Destructor Documentation

GeViSQ_GetNextVideoInput::GeViSQ_GetNextVideoInput | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViVideoInputID | initPrevID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten VideoEingang'.

Member Function Documentation

GeViSQ_GetNextVideoInput GeViSQ_GetNextVideoInput::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextVideoInput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput::sActiveOnly

true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput::sEnabledOnly

klar

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput::sPrevID

VideoInputID des vorher abgefragten VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient Class Reference

  • StateQueries
  • GeViSQ_GetNextVideoInputOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem neachsten VideoEingang des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextVideoInputOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoInputID initPrevID, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem neachsten VideoEingang des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetNextVideoInputOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViVideoInputID | sPrevID
VideoInputID des vorher abgefragten VideoEinganges.
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem neachsten VideoEingang des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetNextVideoInputOfClient::GeViSQ_GetNextVideoInputOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViVideoInputID | initPrevID,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem neachsten VideoEingang des Clients'.

Member Function Documentation

GeViSQ_GetNextVideoInputOfClient GeViSQ_GetNextVideoInputOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextVideoInputOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient::sActiveOnly

true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient::sEnabledOnly

klar

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient::sPrevID

VideoInputID des vorher abgefragten VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput Class Reference

  • StateQueries
  • GeViSQ_GetNextVideoOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Videoausgang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextVideoOutput (Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoOutputID initPrevID)
Create the query 'Liefert die Information zu dem naechsten Videoausgang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetNextVideoOutput^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die Videoausgaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViVideoOutputID | sPrevID
VideoOutputID des vorher abgefragten Videoausganges.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Videoausgang'.

Constructor & Destructor Documentation

GeViSQ_GetNextVideoOutput::GeViSQ_GetNextVideoOutput | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViVideoOutputID | initPrevID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Videoausgang'.

Member Function Documentation

GeViSQ_GetNextVideoOutput GeViSQ_GetNextVideoOutput::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextVideoOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput::sActiveOnly

true - nur die Videoausgaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput::sEnabledOnly

klar

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput::sPrevID

VideoOutputID des vorher abgefragten Videoausganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient Class Reference

  • StateQueries
  • GeViSQ_GetNextVideoOutputOfClient
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem naechsten Videoausgang des Clients'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetNextVideoOutputOfClient (Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoOutputID initPrevID, GeViClientID initClientID)
Create the query 'Liefert die Information zu dem naechsten Videoausgang des Clients'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetNextVideoOutputOfClient^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Boolean | sActiveOnly
true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle
Boolean | sEnabledOnly
klar
GeViVideoOutputID | sPrevID
VideoOutputID des vorher abgefragten Videoausganges.
GeViClientID | sClientID
ClientID des Klienten.

Detailed Description

StateQuery 'Liefert die Information zu dem naechsten Videoausgang des Clients'.

Constructor & Destructor Documentation

GeViSQ_GetNextVideoOutputOfClient::GeViSQ_GetNextVideoOutputOfClient | ( | Boolean | initActiveOnly,
 |  | Boolean | initEnabledOnly,
 |  | GeViVideoOutputID | initPrevID,
 |  | GeViClientID | initClientID
 | ) |  |

Create the query 'Liefert die Information zu dem naechsten Videoausgang des Clients'.

Member Function Documentation

GeViSQ_GetNextVideoOutputOfClient GeViSQ_GetNextVideoOutputOfClient::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetNextVideoOutputOfClient::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient::sActiveOnly

true - nur die VideoEingaenge, deren verwaltende Klients bereits eingeloggt sind, false - alle

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient::sClientID

ClientID des Klienten.

Boolean GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient::sEnabledOnly

klar

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient::sPrevID

VideoOutputID des vorher abgefragten Videoausganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact Class Reference

  • StateQueries
  • GeViSQ_GetOutputContact
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetOutputContact (GeViOutputContactID initResID)
Create the query 'Liefert die Information zum bestimmten Ausgangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetOutputContact^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViOutputContactID | sResID
OutputContactID des Ausgangskontaktes.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetOutputContact::GeViSQ_GetOutputContact ( GeViOutputContactID initResID )

Create the query 'Liefert die Information zum bestimmten Ausgangskontakt'.

Member Function Documentation

GeViSQ_GetOutputContact GeViSQ_GetOutputContact::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetOutputContact::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViOutputContactID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact::sResID

OutputContactID des Ausgangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName Class Reference

  • StateQueries
  • GeViSQ_GetOutputContactByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetOutputContactByName (String^ initName)
Create the query 'Liefert die Information zum bestimmten Ausgangskontakt'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static
GeViSQ_GetOutputContactByName^ 		FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sName
Name des Ausgangskontaktes.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Ausgangskontakt'.

Constructor & Destructor Documentation

GeViSQ_GetOutputContactByName::GeViSQ_GetOutputContactByName ( String^ initName )

Create the query 'Liefert die Information zum bestimmten Ausgangskontakt'.

Member Function Documentation

GeViSQ_GetOutputContactByName GeViSQ_GetOutputContactByName::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetOutputContactByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName::sName

Name des Ausgangskontaktes.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo Class Reference

  • StateQueries
  • GeViSQ_GetPTZHeadInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo Class Reference
State Queries and Answers

StateQuery 'Fragt die S/N Info ab'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetPTZHeadInfo (GeViVideoInputID initResID)
Create the query 'Fragt die S/N Info ab'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetPTZHeadInfo^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViVideoInputID | sResID
GlobalID des VideoEinganges.

Detailed Description

StateQuery 'Fragt die S/N Info ab'.

Constructor & Destructor Documentation

GeViSQ_GetPTZHeadInfo::GeViSQ_GetPTZHeadInfo ( GeViVideoInputID initResID )

Create the query 'Fragt die S/N Info ab'.

Member Function Documentation

GeViSQ_GetPTZHeadInfo GeViSQ_GetPTZHeadInfo::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetPTZHeadInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo::sResID

GlobalID des VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState Class Reference

  • StateQueries
  • GeViSQ_GetSyncState
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState Class Reference
State Queries and Answers

StateQuery 'Fragt die SyncState Info ab'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetSyncState (GeViVideoInputID initResID)
Create the query 'Fragt die SyncState Info ab'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetSyncState^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViVideoInputID | sResID
GlobalID des VideoEinganges.

Detailed Description

StateQuery 'Fragt die SyncState Info ab'.

Constructor & Destructor Documentation

GeViSQ_GetSyncState::GeViSQ_GetSyncState ( GeViVideoInputID initResID )

Create the query 'Fragt die SyncState Info ab'.

Member Function Documentation

GeViSQ_GetSyncState GeViSQ_GetSyncState::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetSyncState::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState::sResID

GlobalID des VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue Class Reference

  • StateQueries
  • GeViSQ_GetThresholdValue
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zu dem lokalen Videoeingangs eines VSM'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetThresholdValue (GeViClientID initClient, Int32 initVideoInput)
Create the query 'Liefert die Information zu dem lokalen Videoeingangs eines VSM'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetThresholdValue^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViClientID | sClient
Interface-ID des VSM.
Int32 | sVideoInput
Lokaler Videoeingang des VSM (eigentlich der zugehoerigen Kreuzschiene)

Detailed Description

StateQuery 'Liefert die Information zu dem lokalen Videoeingangs eines VSM'.

Constructor & Destructor Documentation

GeViSQ_GetThresholdValue::GeViSQ_GetThresholdValue | ( | GeViClientID | initClient,
 |  | Int32 | initVideoInput
 | ) |  |

Create the query 'Liefert die Information zu dem lokalen Videoeingangs eines VSM'.

Member Function Documentation

GeViSQ_GetThresholdValue GeViSQ_GetThresholdValue::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetThresholdValue::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViClientID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue::sClient

Interface-ID des VSM.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue::sVideoInput

Lokaler Videoeingang des VSM (eigentlich der zugehoerigen Kreuzschiene)

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput Class Reference

  • StateQueries
  • GeViSQ_GetVideoInput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten VideoEingang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetVideoInput (GeViVideoInputID initResID)
Create the query 'Liefert die Information zum bestimmten VideoEingang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetVideoInput^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViVideoInputID | sResID
VideoInputID des VideoEinganges.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten VideoEingang'.

Constructor & Destructor Documentation

GeViSQ_GetVideoInput::GeViSQ_GetVideoInput ( GeViVideoInputID initResID )

Create the query 'Liefert die Information zum bestimmten VideoEingang'.

Member Function Documentation

GeViSQ_GetVideoInput GeViSQ_GetVideoInput::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetVideoInput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput::sResID

VideoInputID des VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName Class Reference

  • StateQueries
  • GeViSQ_GetVideoInputByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten VideoEingang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetVideoInputByName (String^ initName)
Create the query 'Liefert die Information zum bestimmten VideoEingang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetVideoInputByName^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sName
Name des VideoEinganges.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten VideoEingang'.

Constructor & Destructor Documentation

GeViSQ_GetVideoInputByName::GeViSQ_GetVideoInputByName ( String^ initName )

Create the query 'Liefert die Information zum bestimmten VideoEingang'.

Member Function Documentation

GeViSQ_GetVideoInputByName GeViSQ_GetVideoInputByName::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetVideoInputByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName::sName

Name des VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput Class Reference

  • StateQueries
  • GeViSQ_GetVideoOutput
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Videoausgang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetVideoOutput (GeViVideoOutputID initResID)
Create the query 'Liefert die Information zum bestimmten Videoausgang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetVideoOutput^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViVideoOutputID | sResID
VideoOutputID des Videoausganges.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Videoausgang'.

Constructor & Destructor Documentation

GeViSQ_GetVideoOutput::GeViSQ_GetVideoOutput ( GeViVideoOutputID initResID )

Create the query 'Liefert die Information zum bestimmten Videoausgang'.

Member Function Documentation

GeViSQ_GetVideoOutput GeViSQ_GetVideoOutput::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetVideoOutput::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoOutputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput::sResID

VideoOutputID des Videoausganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName Class Reference

  • StateQueries
  • GeViSQ_GetVideoOutputByName
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName Class Reference
State Queries and Answers

StateQuery 'Liefert die Information zum bestimmten Videoausgang'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetVideoOutputByName (String^ initName)
Create the query 'Liefert die Information zum bestimmten Videoausgang'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetVideoOutputByName^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

String^ | sName
Name des Videoausganges.

Detailed Description

StateQuery 'Liefert die Information zum bestimmten Videoausgang'.

Constructor & Destructor Documentation

GeViSQ_GetVideoOutputByName::GeViSQ_GetVideoOutputByName ( String^ initName )

Create the query 'Liefert die Information zum bestimmten Videoausgang'.

Member Function Documentation

GeViSQ_GetVideoOutputByName GeViSQ_GetVideoOutputByName::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetVideoOutputByName::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName::sName

Name des Videoausganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo Class Reference

  • StateQueries
  • GeViSQ_GetVideoSensorInfo
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo Class Reference
State Queries and Answers

StateQuery 'Fragt die Info zum VideoSensor ab'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo:
[legend]

List of all members.

Public Member Functions

GeViSQ_GetVideoSensorInfo (GeViVideoInputID initResID)
Create the query 'Fragt die Info zum VideoSensor ab'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_GetVideoSensorInfo^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

GeViVideoInputID | sResID
GlobalID des VideoEinganges.

Detailed Description

StateQuery 'Fragt die Info zum VideoSensor ab'.

Constructor & Destructor Documentation

GeViSQ_GetVideoSensorInfo::GeViSQ_GetVideoSensorInfo ( GeViVideoInputID initResID )

Create the query 'Fragt die Info zum VideoSensor ab'.

Member Function Documentation

GeViSQ_GetVideoSensorInfo GeViSQ_GetVideoSensorInfo::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_GetVideoSensorInfo::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

GeViVideoInputID GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo::sResID

GlobalID des VideoEinganges.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall Class Reference

  • StateQueries
  • GeViSQ_LicenseCall
Public Member Functions | Static Public Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall Class Reference
State Queries and Answers

StateQuery 'Interne Abfrage'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall:
[legend]

List of all members.

Public Member Functions

GeViSQ_LicenseCall ()
Create the query 'Interne Abfrage'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_LicenseCall^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Detailed Description

StateQuery 'Interne Abfrage'.

Constructor & Destructor Documentation

GeViSQ_LicenseCall::GeViSQ_LicenseCall ( )

Create the query 'Interne Abfrage'.

Member Function Documentation

GeViSQ_LicenseCall GeViSQ_LicenseCall::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_LicenseCall::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall Class Reference

  • StateQueries
  • GeViSQ_LicensePrepareCall
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall Class Reference
State Queries and Answers

StateQuery 'Interne Abfrage'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall:
[legend]

List of all members.

Public Member Functions

GeViSQ_LicensePrepareCall (Int32 initVal1, Int32 initVal2, Int32 initVal3, Int32 initVal4)
Create the query 'Interne Abfrage'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_LicensePrepareCall^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int32 | sVal1
Wert 1.
Int32 | sVal2
Wert 2.
Int32 | sVal3
Wert 3.
Int32 | sVal4
Wert 4.

Detailed Description

StateQuery 'Interne Abfrage'.

Constructor & Destructor Documentation

GeViSQ_LicensePrepareCall::GeViSQ_LicensePrepareCall | ( | Int32 | initVal1,
 |  | Int32 | initVal2,
 |  | Int32 | initVal3,
 |  | Int32 | initVal4
 | ) |  |

Create the query 'Interne Abfrage'.

Member Function Documentation

GeViSQ_LicensePrepareCall GeViSQ_LicensePrepareCall::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_LicensePrepareCall::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall::sVal1

Wert 1.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall::sVal2

Wert 2.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall::sVal3

Wert 3.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall::sVal4

Wert 4.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData Class Reference

  • StateQueries
  • GeViSQ_LicenseTransferData
Public Member Functions | Static Public Member Functions | Properties
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData Class Reference
State Queries and Answers

StateQuery 'Interne Abfrage'. More...

Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData:
[legend]

List of all members.

Public Member Functions

GeViSQ_LicenseTransferData (Int32 initVal1, Int32 initVal2, String^ initVal3)
Create the query 'Interne Abfrage'.
virtual CGeViMessage * | ToNativeAction () override
Create a native C++ instance of this query.

Static Public Member Functions

static GeViSQ_LicenseTransferData^ | FromNativeQuery (CStateQuery *nativeQuery)
Create a managed instance of this query by using a native C++ instance.

Properties

Int32 | sVal1
Wert 1.
Int32 | sVal2
Wert 2.
String^ | sVal3
Wert 3.

Detailed Description

StateQuery 'Interne Abfrage'.

Constructor & Destructor Documentation

GeViSQ_LicenseTransferData::GeViSQ_LicenseTransferData | ( | Int32 | initVal1,
 |  | Int32 | initVal2,
 |  | String^ | initVal3
 | ) |  |

Create the query 'Interne Abfrage'.

Member Function Documentation

GeViSQ_LicenseTransferData GeViSQ_LicenseTransferData::FromNativeQuery ( CStateQuery * nativeQuery ) [static]

Create a managed instance of this query by using a native C++ instance.

Returns:
Returns the managed instance.
Parameters:
nativeAction Native C++ instance of the query.
CGeViMessage * GeViSQ_LicenseTransferData::ToNativeAction ( ) [override, virtual]

Create a native C++ instance of this query.

Returns:
Returns the native C++ instance.

Implements GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Property Documentation

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData::sVal1

Wert 1.

Int32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData::sVal2

Wert 2.

String^ GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData::sVal3

Wert 3.

Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer Class Reference

  • GeViStateAnswer
Static Public Member Functions | Public Attributes | Protected Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer Class Reference
Inheritance diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer:
[legend]
Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer:
[legend]

List of all members.

Static Public Member Functions

static GeViStateAnswer^ | InternalFromNativeQuery (CStateAnswer *nativeAnswer)

Public Attributes

const GeViStateAnswerKind | _StateAnswerKind

Protected Member Functions

GeViStateAnswer (GeViStateAnswerKind answerKind)

Constructor & Destructor Documentation

GeViStateAnswer::GeViStateAnswer ( GeViStateAnswerKind answerKind ) [protected]

Member Function Documentation

GeViStateAnswer GeViStateAnswer::InternalFromNativeQuery ( CStateAnswer * nativeAnswer ) [static]

Member Data Documentation

const GeViStateAnswerKind GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer::_StateAnswerKind
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery Class Reference

  • GeViStateQuery
Public Attributes | Protected Member Functions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery Class Reference

Inherits GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage.

Inherited by GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall, and GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData.

Collaboration diagram for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery:
[legend]

List of all members.

Public Attributes

const GeViStateQueryKind _StateQueryKind

Protected Member Functions

GeViStateQuery (GeViStateQueryKind queryKind)

Constructor & Destructor Documentation

GeViStateQuery::GeViStateQuery ( GeViStateQueryKind queryKind ) [protected]

Member Data Documentation

const GeViStateQueryKind GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery::_StateQueryKind
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime Struct Reference

  • GeViTGeViDateTime
Public Attributes
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime Struct Reference

List of all members.

Public Attributes

System::UInt32 | TimePart
System::UInt32 | DatePart

Member Data Documentation

System::UInt32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime::DatePart
System::UInt32 GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime::TimePart
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Index

Class Index
D | G
D
GeViAct_CrossSwitchWithAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) GeViAct_MIPCableBFaultState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) GeViAct_StopEventByInstanceEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) GeViDBA_DBTerminated (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers)
GeViAct_CrossSwitchWithAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPCableBFaultStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_StopEventByType (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBA_DeletedEntries (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers)
DBIHelperFunctions (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper) | GeViAct_CustomAction (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MIPDisplaySegmentAlarmState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_StopEventByTypeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBA_Nothing (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers)
G
GeViAct_CustomActionEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) GeViAct_MIPDisplaySegmentAlarmStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) GeViAct_StopMscEvent (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) GeViDBA_QueryHandle (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers)
GeViAct_DataBaseFailure (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions) | GeViAct_MIPDisplaySegmentStatus (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_StopMscEventEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBAnswer (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_AckAlarmByInstance (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_DataBaseFailureEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPDisplaySegmentStatusEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_StopTimer (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_ActionKind (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AckAlarmByInstanceEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_DataBaseMissing (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions) | GeViAct_MIPLUTamperAlarmState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_StopTimerEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_ActionList (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AckAlarmByMG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_DataBaseMissingEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPLUTamperAlarmStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SyncTimeRequest (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_GscSystem (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AckAlarmByMGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_DataBaseReady (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions) | GeViAct_MIPLUTamperStatus (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SyncTimeRequestEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_LocalTime_GrtEqu (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AckAlarmByType (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_DataBaseReadyEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPLUTamperStatusEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SyncTimeRequestToClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_LocalTime_LowEqu (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AckAlarmByTypeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_DefaultPosCallUp (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MIPOffline (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SyncTimeRequestToClientEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_MonitorGroupDesc (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AckAllAlarmsOnMG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_DefaultPosCallUpEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPOfflineEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SyncTimeSetTime (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_MonitorGroupID (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AckAllAlarmsOnMGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_DefaultPosClear (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MIPOnline (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SyncTimeSetTimeActual (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_MonitorGroupName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_ActionByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_DefaultPosClearEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPOnlineEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SyncTimeSetTimeActualEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_MscSystem (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_ActionByNameEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_DefaultPosSave (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MIPPMComFailState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SyncTimeSetTimeClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_PK_GrtEqu (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_ActionDataCorrupt (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_DefaultPosSaveEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPPMComFailStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SyncTimeSetTimeClientEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_PK_LowEqu (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_ActionDataCorruptEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_DisconnectUser (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MIPPMTamperAlarmState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SyncTimeSetTimeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_SenderDesc (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_ActivateAssignmentProfile (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_DisconnectUserEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPPMTamperAlarmStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SystemError (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_SenderID (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_ActivateAssignmentProfileEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_EventRelation (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MIPPMTamperStatus (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SystemErrorEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_SenderName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmAcked (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_EventRelationEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPPMTamperStatusEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SystemSettingsChanged (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_StartMonitorGroupDesc (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmAckedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_EventStarted (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MIPQueryInterface (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SystemSettingsChangedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_StartMonitorGroupID (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmCopied (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_EventStartedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPQueryInterfaceEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SystemStarted (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_StartMonitorGroupName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmCopiedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_EventStopped (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MIPRMComFailState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SystemStartedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_Text (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmDisplayed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_EventStoppedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPRMComFailStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SystemStopped (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_TypeDesc (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmDisplayedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_FastetModeOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MIPRMTamperAlarmState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SystemStoppedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_TypeID (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmMoved (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_FastetModeOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPRMTamperAlarmStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SystemWarning (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBF_TypeName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmMovedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_FocusFar (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MIPRMTamperStatus (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SystemWarningEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_WithAck (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmQuitted (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_FocusFarEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPRMTamperStatusEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_TakeCameraControl (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViDBF_WithMscIIRelation (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmQuittedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_FocusNear (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MIPSecureAuxiliarySensor (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_TakeCameraControlEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBF_WithQuit (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmRetriggered (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_FocusNearEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPSecureAuxiliarySensorEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_TiltDown (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViDBFilter (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_AlarmRetriggeredEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_FocusStop (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MIPSecureAuxiliaryTP1 (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_TiltDownEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBQ_AbortQuery (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmStarted (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_FocusStopEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPSecureAuxiliaryTP1EventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_TiltStop (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViDBQ_CloseQuery (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlarmStartedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_GeviScopeServerConnected (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions) | GeViAct_MIPSecureAuxiliaryTP2 (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_TiltStopEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBQ_CreateActionQuery (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlternateContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions) | GeViAct_GeviScopeServerConnectedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPSecureAuxiliaryTP2EventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_TiltUp (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViDBQ_CreateAlarmQuery (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_AlternateContactEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_GeviScopeServerConnectionFailed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions) | GeViAct_MIPSecureDisplaySegment (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_TiltUpEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBQ_CreateDeleteActionsHandle (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraAutoFocusOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_GeviScopeServerConnectionFailedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPSecureDisplaySegmentEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_TimeRangeEnded (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions) | GeViDBQ_CreateDeleteAlarmsHandle (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraAutoFocusOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_GeviScopeServerDisconnected (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions) | GeViAct_MIPSecureLU (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_TimeRangeEndedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBQ_DeleteAll (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraAutoFocusOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_GeviScopeServerDisconnectedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPSecureLUEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_TimeRangeStarted (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions) | GeViDBQ_Get (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraAutoFocusOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_GscActionEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPSecurePM (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_TimeRangeStartedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBQ_GetFirst (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraClearPrePosText (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_HistoricalAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MIPSecurePMEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_UserLogin (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBQ_GetLast (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraClearPrePosTextEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_HistoricalAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPSecureRM (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_UserLoginEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBQ_GetNext (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraCycleNext (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_HistoricalInput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MIPSecureRMEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_UserLoginFailed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBQ_GetPrev (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries)
GeViAct_CameraCycleNextEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_HistoricalInputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPTurnARelayControl (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_UserLoginFailedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBQuery (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CameraCyclePause (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorCameraOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MIPTurnARelayControlEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_UserLogout (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViGUID (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CameraCyclePauseEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorCameraOutputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPTurnRelaysOnOneZone (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_UserLogoutEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViMessage (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CameraCyclePrev (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorDimLevel (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MIPTurnRelaysOnOneZoneEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoClearTextOut (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSA_AlarmInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraCyclePrevEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorDimLevelEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MonitorGroupDisable (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VideoClearTextOutEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_AlarmOnMGInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraCycleResume (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorGetDimLevel (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MonitorGroupDisableEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoContrastAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSA_ClientInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraCycleResumeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorGetDimLevelEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MonitorGroupEnable (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VideoContrastAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_ClientLoginInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraCycleStart (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorLightOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MonitorGroupEnableEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoContrastOk (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSA_CommandFailed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraCycleStartEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorLightOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MonitorGroupStatusChanged (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VideoContrastOkEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_CommandOk (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraCycleStop (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorLightOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MonitorGroupStatusChangedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoContrastPreAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSA_ContrastState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraCycleStopEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorLightOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MoveActualAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VideoContrastPreAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_InfoDatabaseCreationTime (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraLightOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MoveActualAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoSyncFailure (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSA_InfoServerStartTime (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraLightOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MoveAlarmByInstance (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VideoSyncFailureEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_InputContactInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraLightOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MoveAlarmByInstanceEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoSyncOk (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSA_LicenseCall (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraLightOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MscEventStarted (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViAct_VideoSyncOkEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_LicenseInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraManualIrisOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSetDimLevel (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MscEventStartedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoTextOut (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSA_LicenseTransferData (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraManualIrisOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSetDimLevelEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MscEventStopped (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViAct_VideoTextOutEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_LicenseValue (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraManualIrisOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncUOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MscEventStoppedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoThresholdRequest (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViSA_MonitorGroupInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraManualIrisOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncUOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MscServerConnected (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViAct_VideoThresholdRequestEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_Nothing (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncUOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MscServerConnectedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VideoThresholdValue (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViSA_OutputContactInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncUOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MscServerConnectFailed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViAct_VideoThresholdValueEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_PTZHeadInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncVOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MscServerConnectFailedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VS30PMMode (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSA_SyncState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncVOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MscServerDisconnect (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViAct_VS30PMModeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_Terminated (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraPumpOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncVOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MscServerDisconnected (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViAct_VS30VMDMode (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSA_ThresholdInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraPumpOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncVOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MscServerDisconnectedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VS30VMDModeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_UnknownCommand (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraPumpOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncXOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MscServerDisconnectEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSAlarmEnd (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSA_UnsufficientRights (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraPumpOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncXOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MscSetupModified (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViAct_VSAlarmEndEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_VideoInputInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraRAWOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncXOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_MscSetupModifiedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSAlarmExtern (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSA_VideoOutputInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraRAWOutputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncXOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_NormalModeOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSAlarmExternEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSA_VideoSensorInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers)
GeViAct_CameraSelectCharMode (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncYOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_NormalModeOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSAlarmInField (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSoftConnectProgressCallbackWrapper (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CameraSelectCharModeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncYOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_OpenContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions) | GeViAct_VSAlarmInFieldEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSoftConnectProgressEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CameraSetCameraText (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IlluminatorSpecFuncYOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions) | GeViAct_OpenContactEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSAllTestAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSoftDatabaseNotificationCallbackWrapper (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CameraSetCameraTextEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IlluminatorSpecFuncYOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PanAuto (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSAllTestAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSoftDatabaseNotificationEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CameraSetPrePosText (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_InformAllUsers (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_PanAutoEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSAllTimerReset (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetAlarmOnMGByIndex (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSetPrePosTextEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_InformAllUsersEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PanLeft (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSAllTimerResetEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetAlarmOnMGInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSmearAndWashOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_InformAllUsersMSG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_PanLeftEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSArmed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetAlarms (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSmearAndWashOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_InformAllUsersMSGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PanRight (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSArmedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetAlarmsByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSmearAndWashOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_InformUser (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_PanRightEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSChooseSavedPicture (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSmearAndWashOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_InformUserEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PanStop (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSChooseSavedPictureEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetClientByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpec1FuncOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_InformUserMSG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_PanStopEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSPictureDetect (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetContrastState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpec1FuncOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_InformUserMSGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PopUpAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VSPictureDetectEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetFirstAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpec1FuncOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_InputContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions) | GeViAct_PopUpAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSPictureToCommonOut (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetFirstClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpec1FuncOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_InputContactEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PopUpNextAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VSPictureToCommonOutEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetFirstClientOfType (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecUFuncOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_InputContactSabotage (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions) | GeViAct_PopUpNextAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSPictureToOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetFirstInputContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecUFuncOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_InputContactSabotageEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PrePosCallUp (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSPictureToOutputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetFirstInputContactOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecUFuncOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IrisClose (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_PrePosCallUpEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSPreAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetFirstMonitorGroup (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecUFuncOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IrisCloseEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PrePosClear (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSPreAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetFirstOutputContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecVFuncOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IrisOpen (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_PrePosClearEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSRecorderEnd (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetFirstOutputContactOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecVFuncOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IrisOpenEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_PrePosSave (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_VSRecorderEndEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetFirstVideoInput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecVFuncOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_IrisStop (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_PrePosSaveEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSRecorderTimerReset (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetFirstVideoInputOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraSpecVFuncOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_IrisStopEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_QuitAlarmByInstance (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VSRecorderTimerResetEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetFirstVideoOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraStopAll (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_LogLastAction (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_QuitAlarmByInstanceEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSSetAllArmed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetFirstVideoOutputOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraStopAllEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_LogLastActionEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_QuitAlarmByMG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VSSetAllArmedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetInfoDatabaseCreationTime (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTextOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_LogMessage (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_QuitAlarmByMGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSSetArmed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetInfoServerStartTime (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTextOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_LogMessageEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_QuitAlarmByType (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VSSetArmedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetInputContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTextOn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_LogMessageMSG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_QuitAlarmByTypeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSSetDateAndTime (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetInputContactByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTextOnEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_LogMessageMSGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_QuitAllAlarmsOnMG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_VSSetDateAndTimeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetLicenseInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourNext (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_LogSourceAction (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_QuitAllAlarmsOnMGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSSetMode (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetLicenseValue (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourNextEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_LogSourceActionEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RedChangeMaster (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSSetModeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetLoginInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourPause (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MBegAlarmAck (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_RedChangeMasterEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSSetSensorMode (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetMonitorGroup (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourPauseEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MBegAlarmAckEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RedConnectionMasterChanged (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSSetSensorModeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetMonitorGroupByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourPrev (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MBegAlarmQuit (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_RedConnectionMasterChangedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSSetSensorOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetNextAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourPrevEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MBegAlarmQuitEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RedirectResource (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSSetSensorOutputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetNextClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourResume (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MBegAlarmStart (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_RedirectResourceEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSSyncSignalDetect (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetNextClientOfType (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourResumeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MBegAlarmStartEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RedMasterServerChanged (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSSyncSignalDetectEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetNextInputContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourStart (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MBegInitRequest (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_RedMasterServerChangedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSTestAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetNextInputContactOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourStartEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MBegInitRequestEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RedRedundantLoginFailed (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSTestAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetNextMonitorGroup (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourStop (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MBegInitSeq (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_RedRedundantLoginFailedEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSTimerReset (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetNextOutputContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraTourStopEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MBegInitSeqEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RedRedundantUserLogin (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSTimerResetEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetNextOutputContactOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraVerOff (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_MBegLockCamera (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_RedRedundantUserLoginEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSVMDMode (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetNextVideoInput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CameraVerOffEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MBegLockCameraEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RescannRequest (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSVMDModeEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetNextVideoInputOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ChangeRightProfile (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_MBegUnlockCamera (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViAct_RescannRequestEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VSVMDOutOfOrder (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions) | GeViSQ_GetNextVideoOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ChangeRightProfileEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MBegUnlockCameraEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RescannRequestToClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VSVMDOutOfOrderEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetNextVideoOutputOfClient (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ClearAlarmFlagVideoInput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViAct_MIPAlarmAuxiliaryInput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_RescannRequestToClientEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_VX3SystemReset (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViSQ_GetOutputContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ClearAlarmFlagVideoInputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPAlarmAuxiliaryInputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_RestoreRightProfile (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_VX3SystemResetEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetOutputContactByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ClearAlarmFlagVideoOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViAct_MIPAlarmCable (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_RestoreRightProfileEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_ZoomIn (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViSQ_GetPTZHeadInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ClearAlarmFlagVideoOutputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPAlarmCableEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SendRawData (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_ZoomInEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetSyncState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ClearVideoOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViAct_MIPAlarmLUTamper (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SendRawDataEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_ZoomOut (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViSQ_GetThresholdValue (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_ClearVideoOutputEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPAlarmLUTamperEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_SendRawDataMSG (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViAct_ZoomOutEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetVideoInput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CloseContact (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions) | GeViAct_MIPAlarmPMTamper (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_SendRawDataMSGEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_ZoomStop (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions) | GeViSQ_GetVideoInputByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CloseContactEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPAlarmPMTamperEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_StartAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_ZoomStopEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViSQ_GetVideoOutput (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CopyActualAlarm (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_MIPAlarmRMTamper (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_StartAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAction (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper) | GeViSQ_GetVideoOutputByName (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CopyActualAlarmEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPAlarmRMTamperEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_StartEvent (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViActionData (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper) | GeViSQ_GetVideoSensorInfo (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CopyAlarmByInstance (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions) | GeViAct_MIPAuxiliaryAlarmState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_StartEventEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDatabase (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper) | GeViSQ_LicenseCall (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CopyAlarmByInstanceEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPAuxiliaryAlarmStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_StartMscEvent (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions) | GeViDBA_AccessDenied (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers) | GeViSQ_LicensePrepareCall (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CopyCameraOnMonitor (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViAct_MIPAuxiliarySensorStatus (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_StartMscEventEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBA_ActionEntry (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers) | GeViSQ_LicenseTransferData (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries)
GeViAct_CopyCameraOnMonitorEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPAuxiliarySensorStatusEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_StartTimer (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBA_AlarmEntry (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers) | GeViStateAnswer (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CrossSwitch (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions) | GeViAct_MIPCableAFaultState (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions) | GeViAct_StartTimerEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViDBA_DBError (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers) | GeViStateQuery (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
GeViAct_CrossSwitchEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_MIPCableAFaultStateEventArgs (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher) | GeViAct_StopEventByInstance (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions) | GeViDBA_DBOk (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers) | GeViTGeViDateTime (GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper)
D | G
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
    • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
    • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
    • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
    • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
    • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
    • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
      • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- ! -

  • !GeViDatabase() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTourResumeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs, including all inherited members.
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs |
GeViAct_CameraTourResumeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs | [private]
GeViAct_CameraTourResumeEventArgs(GeViAct_CameraTourResume^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlarmStartedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
GeViAct_AlarmStartedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs | [private]
GeViAct_AlarmStartedEventArgs(GeViAct_AlarmStarted^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_UserLoginEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs, including all inherited members.
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs |
aPort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs |
GeViAct_UserLoginEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs | [private]
GeViAct_UserLoginEventArgs(GeViAct_UserLogin^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SystemStartedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs, including all inherited members.
GeViAct_SystemStartedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs | [private]
GeViAct_SystemStartedEventArgs(GeViAct_SystemStarted^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PopUpNextAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs, including all inherited members.
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs |
GeViAct_PopUpNextAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs | [private]
GeViAct_PopUpNextAlarmEventArgs(GeViAct_PopUpNextAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPRMTamperStatusEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs |
GeViAct_MIPRMTamperStatusEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs | [private]
GeViAct_MIPRMTamperStatusEventArgs(GeViAct_MIPRMTamperStatus^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_DataBaseFailureEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs, including all inherited members.
GeViAct_DataBaseFailureEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs | [private]
GeViAct_DataBaseFailureEventArgs(GeViAct_DataBaseFailure^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MBegAlarmQuitEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs, including all inherited members.
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs |
aUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs |
GeViAct_MBegAlarmQuitEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs | [private]
GeViAct_MBegAlarmQuitEventArgs(GeViAct_MBegAlarmQuit^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPAuxiliaryAlarmStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs, including all inherited members.
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs |
aUnitType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs |
GeViAct_MIPAuxiliaryAlarmStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs | [private]
GeViAct_MIPAuxiliaryAlarmStateEventArgs(GeViAct_MIPAuxiliaryAlarmState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MBegLockCameraEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs, including all inherited members.
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs |
GeViAct_MBegLockCameraEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs | [private]
GeViAct_MBegLockCameraEventArgs(GeViAct_MBegLockCamera^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoThresholdRequestEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs, including all inherited members.
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs |
aInternal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs |
aInternal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs |
GeViAct_VideoThresholdRequestEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs | [private]
GeViAct_VideoThresholdRequestEventArgs(GeViAct_VideoThresholdRequest^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraStopAllEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs |
GeViAct_CameraStopAllEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs | [private]
GeViAct_CameraStopAllEventArgs(GeViAct_CameraStopAll^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSetCameraTextEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs, including all inherited members.
aText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs |
GeViAct_CameraSetCameraTextEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs | [private]
GeViAct_CameraSetCameraTextEventArgs(GeViAct_CameraSetCameraText^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSelectCharModeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs, including all inherited members.
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs |
GeViAct_CameraSelectCharModeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs | [private]
GeViAct_CameraSelectCharModeEventArgs(GeViAct_CameraSelectCharMode^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_DefaultPosCallUpEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs |
GeViAct_DefaultPosCallUpEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs | [private]
GeViAct_DefaultPosCallUpEventArgs(GeViAct_DefaultPosCallUp^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSChooseSavedPictureEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs, including all inherited members.
aSavedPicture | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs |
GeViAct_VSChooseSavedPictureEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs | [private]
GeViAct_VSChooseSavedPictureEventArgs(GeViAct_VSChooseSavedPicture^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_TimeRangeStartedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs, including all inherited members.
aID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs |
aTimeRangeName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs |
GeViAct_TimeRangeStartedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs | [private]
GeViAct_TimeRangeStartedEventArgs(GeViAct_TimeRangeStarted^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_InformUserEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs, including all inherited members.
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs |
aInfoMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs |
aToName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs |
GeViAct_InformUserEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs | [private]
GeViAct_InformUserEventArgs(GeViAct_InformUser^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraVerOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs |
GeViAct_CameraVerOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs | [private]
GeViAct_CameraVerOffEventArgs(GeViAct_CameraVerOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_DataBaseReadyEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs, including all inherited members.
GeViAct_DataBaseReadyEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs | [private]
GeViAct_DataBaseReadyEventArgs(GeViAct_DataBaseReady^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RedRedundantLoginFailedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs, including all inherited members.
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs |
aServerHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs |
aUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs |
GeViAct_RedRedundantLoginFailedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs | [private]
GeViAct_RedRedundantLoginFailedEventArgs(GeViAct_RedRedundantLoginFailed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_TimeRangeEndedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs, including all inherited members.
aID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs |
aTimeRangeName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs |
GeViAct_TimeRangeEndedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs | [private]
GeViAct_TimeRangeEndedEventArgs(GeViAct_TimeRangeEnded^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoContrastAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs, including all inherited members.
aThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs |
GeViAct_VideoContrastAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs | [private]
GeViAct_VideoContrastAlarmEventArgs(GeViAct_VideoContrastAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AckAllAlarmsOnMGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs, including all inherited members.
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs |
GeViAct_AckAllAlarmsOnMGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs | [private]
GeViAct_AckAllAlarmsOnMGEventArgs(GeViAct_AckAllAlarmsOnMG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPOnlineEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs |
GeViAct_MIPOnlineEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs | [private]
GeViAct_MIPOnlineEventArgs(GeViAct_MIPOnline^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSSetArmedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs, including all inherited members.
aArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs |
GeViAct_VSSetArmedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs | [private]
GeViAct_VSSetArmedEventArgs(GeViAct_VSSetArmed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_LogSourceActionEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs, including all inherited members.
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs |
GeViAct_LogSourceActionEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs | [private]
GeViAct_LogSourceActionEventArgs(GeViAct_LogSourceAction^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPCableBFaultStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs |
GeViAct_MIPCableBFaultStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs | [private]
GeViAct_MIPCableBFaultStateEventArgs(GeViAct_MIPCableBFaultState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraRAWOutputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs, including all inherited members.
aRAWData | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs |
GeViAct_CameraRAWOutputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs | [private]
GeViAct_CameraRAWOutputEventArgs(GeViAct_CameraRAWOutput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AckAlarmByTypeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs, including all inherited members.
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs |
GeViAct_AckAlarmByTypeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs | [private]
GeViAct_AckAlarmByTypeEventArgs(GeViAct_AckAlarmByType^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSArmedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs, including all inherited members.
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs |
GeViAct_VSArmedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs | [private]
GeViAct_VSArmedEventArgs(GeViAct_VSArmed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraCycleResumeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs, including all inherited members.
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs |
GeViAct_CameraCycleResumeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs | [private]
GeViAct_CameraCycleResumeEventArgs(GeViAct_CameraCycleResume^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlarmCopiedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs |
aMGFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs |
aMGTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs |
GeViAct_AlarmCopiedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs | [private]
GeViAct_AlarmCopiedEventArgs(GeViAct_AlarmCopied^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_LogLastActionEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs, including all inherited members.
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs |
GeViAct_LogLastActionEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs | [private]
GeViAct_LogLastActionEventArgs(GeViAct_LogLastAction^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraCyclePauseEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs, including all inherited members.
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs |
GeViAct_CameraCyclePauseEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs | [private]
GeViAct_CameraCyclePauseEventArgs(GeViAct_CameraCyclePause^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlarmMovedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs |
aMGFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs |
aMGTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs |
GeViAct_AlarmMovedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs | [private]
GeViAct_AlarmMovedEventArgs(GeViAct_AlarmMoved^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ActivateAssignmentProfileEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs, including all inherited members.
aProfileID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs |
aProfileName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs |
GeViAct_ActivateAssignmentProfileEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs | [private]
GeViAct_ActivateAssignmentProfileEventArgs(GeViAct_ActivateAssignmentProfile^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SystemSettingsChangedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs, including all inherited members.
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs |
GeViAct_SystemSettingsChangedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs | [private]
GeViAct_SystemSettingsChangedEventArgs(GeViAct_SystemSettingsChanged^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPLUTamperStatusEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs |
GeViAct_MIPLUTamperStatusEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs | [private]
GeViAct_MIPLUTamperStatusEventArgs(GeViAct_MIPLUTamperStatus^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlternateContactEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs, including all inherited members.
aBlinkOnTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs |
aBlinkPeriod | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs |
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs |
GeViAct_AlternateContactEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs | [private]
GeViAct_AlternateContactEventArgs(GeViAct_AlternateContact^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StartAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs, including all inherited members.
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs |
GeViAct_StartAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs | [private]
GeViAct_StartAlarmEventArgs(GeViAct_StartAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTourStopEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs, including all inherited members.
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs |
GeViAct_CameraTourStopEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs | [private]
GeViAct_CameraTourStopEventArgs(GeViAct_CameraTourStop^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPOfflineEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs |
GeViAct_MIPOfflineEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs | [private]
GeViAct_MIPOfflineEventArgs(GeViAct_MIPOffline^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VS30VMDModeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs, including all inherited members.
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs |
GeViAct_VS30VMDModeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs | [private]
GeViAct_VS30VMDModeEventArgs(GeViAct_VS30VMDMode^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSAlarmEndEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs |
GeViAct_VSAlarmEndEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs | [private]
GeViAct_VSAlarmEndEventArgs(GeViAct_VSAlarmEnd^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSSetDateAndTimeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs |
aDateAndTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs |
GeViAct_VSSetDateAndTimeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs | [private]
GeViAct_VSSetDateAndTimeEventArgs(GeViAct_VSSetDateAndTime^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_InformAllUsersEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs, including all inherited members.
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs |
aInfoMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs |
GeViAct_InformAllUsersEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs | [private]
GeViAct_InformAllUsersEventArgs(GeViAct_InformAllUsers^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_TiltStopEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs |
GeViAct_TiltStopEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs | [private]
GeViAct_TiltStopEventArgs(GeViAct_TiltStop^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StartMscEventEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs, including all inherited members.
aMscBlob | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
aMscInt1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
aMscInt2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
aMscStartKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
GeViAct_StartMscEventEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs | [private]
GeViAct_StartMscEventEventArgs(GeViAct_StartMscEvent^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SendRawDataMSGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs |
GeViAct_SendRawDataMSGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs | [private]
GeViAct_SendRawDataMSGEventArgs(GeViAct_SendRawDataMSG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSSetSensorOutputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs, including all inherited members.
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs |
aOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs |
GeViAct_VSSetSensorOutputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs | [private]
GeViAct_VSSetSensorOutputEventArgs(GeViAct_VSSetSensorOutput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CrossSwitchWithAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs |
GeViAct_CrossSwitchWithAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs | [private]
GeViAct_CrossSwitchWithAlarmEventArgs(GeViAct_CrossSwitchWithAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PanRightEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs |
GeViAct_PanRightEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs | [private]
GeViAct_PanRightEventArgs(GeViAct_PanRight^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraLightOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs |
GeViAct_CameraLightOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs | [private]
GeViAct_CameraLightOnEventArgs(GeViAct_CameraLightOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RedMasterServerChangedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs, including all inherited members.
aNewMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs |
aOldMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs |
GeViAct_RedMasterServerChangedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs | [private]
GeViAct_RedMasterServerChangedEventArgs(GeViAct_RedMasterServerChanged^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MscServerConnectedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs, including all inherited members.
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs |
GeViAct_MscServerConnectedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs | [private]
GeViAct_MscServerConnectedEventArgs(GeViAct_MscServerConnected^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPTurnRelaysOnOneZoneEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs |
GeViAct_MIPTurnRelaysOnOneZoneEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs | [private]
GeViAct_MIPTurnRelaysOnOneZoneEventArgs(GeViAct_MIPTurnRelaysOnOneZone^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ChangeRightProfileEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs, including all inherited members.
aProfileID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs |
aProfileName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs |
aUserName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs |
GeViAct_ChangeRightProfileEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs | [private]
GeViAct_ChangeRightProfileEventArgs(GeViAct_ChangeRightProfile^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_GeviScopeServerDisconnectedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs, including all inherited members.
aGscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs |
GeViAct_GeviScopeServerDisconnectedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs | [private]
GeViAct_GeviScopeServerDisconnectedEventArgs(GeViAct_GeviScopeServerDisconnected^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraManualIrisOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs |
GeViAct_CameraManualIrisOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs | [private]
GeViAct_CameraManualIrisOffEventArgs(GeViAct_CameraManualIrisOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_InputContactSabotageEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs, including all inherited members.
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs |
GeViAct_InputContactSabotageEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs | [private]
GeViAct_InputContactSabotageEventArgs(GeViAct_InputContactSabotage^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SystemStoppedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs, including all inherited members.
GeViAct_SystemStoppedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs | [private]
GeViAct_SystemStoppedEventArgs(GeViAct_SystemStopped^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ActionDataCorruptEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs, including all inherited members.
GeViAct_ActionDataCorruptEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs | [private]
GeViAct_ActionDataCorruptEventArgs(GeViAct_ActionDataCorrupt^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs |
GeViAct_IlluminatorOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs | [private]
GeViAct_IlluminatorOffEventArgs(GeViAct_IlluminatorOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CustomActionEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs, including all inherited members.
aCustomInt | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs |
aCustomText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs |
GeViAct_CustomActionEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs | [private]
GeViAct_CustomActionEventArgs(GeViAct_CustomAction^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PrePosCallUpEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs, including all inherited members.
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs |
GeViAct_PrePosCallUpEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs | [private]
GeViAct_PrePosCallUpEventArgs(GeViAct_PrePosCallUp^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SyncTimeRequestToClientEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs |
GeViAct_SyncTimeRequestToClientEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs | [private]
GeViAct_SyncTimeRequestToClientEventArgs(GeViAct_SyncTimeRequestToClient^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ZoomOutEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs |
GeViAct_ZoomOutEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs | [private]
GeViAct_ZoomOutEventArgs(GeViAct_ZoomOut^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PanStopEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs |
GeViAct_PanStopEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs | [private]
GeViAct_PanStopEventArgs(GeViAct_PanStop^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSetDimLevelEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs |
aLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs |
GeViAct_IlluminatorSetDimLevelEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs | [private]
GeViAct_IlluminatorSetDimLevelEventArgs(GeViAct_IlluminatorSetDimLevel^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorLightOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs |
GeViAct_IlluminatorLightOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs | [private]
GeViAct_IlluminatorLightOffEventArgs(GeViAct_IlluminatorLightOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncVOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs |
GeViAct_IlluminatorSpecFuncVOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs | [private]
GeViAct_IlluminatorSpecFuncVOnEventArgs(GeViAct_IlluminatorSpecFuncVOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_QuitAllAlarmsOnMGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs, including all inherited members.
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs |
GeViAct_QuitAllAlarmsOnMGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs | [private]
GeViAct_QuitAllAlarmsOnMGEventArgs(GeViAct_QuitAllAlarmsOnMG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraCycleStartEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs, including all inherited members.
aCycleID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs |
aCycleName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs |
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs |
GeViAct_CameraCycleStartEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs | [private]
GeViAct_CameraCycleStartEventArgs(GeViAct_CameraCycleStart^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSpec1FuncOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs |
GeViAct_CameraSpec1FuncOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs | [private]
GeViAct_CameraSpec1FuncOnEventArgs(GeViAct_CameraSpec1FuncOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSAlarmInFieldEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs, including all inherited members.
aField | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs |
aMeasureTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs |
GeViAct_VSAlarmInFieldEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs | [private]
GeViAct_VSAlarmInFieldEventArgs(GeViAct_VSAlarmInField^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlarmRetriggeredEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs, including all inherited members.
aAckCleared | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs |
GeViAct_AlarmRetriggeredEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs | [private]
GeViAct_AlarmRetriggeredEventArgs(GeViAct_AlarmRetriggered^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_FocusNearEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs |
GeViAct_FocusNearEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs | [private]
GeViAct_FocusNearEventArgs(GeViAct_FocusNear^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPSecureLUEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs |
GeViAct_MIPSecureLUEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs | [private]
GeViAct_MIPSecureLUEventArgs(GeViAct_MIPSecureLU^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_HistoricalInputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs, including all inherited members.
aContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs |
aLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs |
aTimeStamp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs |
GeViAct_HistoricalInputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs | [private]
GeViAct_HistoricalInputEventArgs(GeViAct_HistoricalInput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_EventRelationEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs, including all inherited members.
aEventRelationName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs |
aEventRelationTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs |
GeViAct_EventRelationEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs | [private]
GeViAct_EventRelationEventArgs(GeViAct_EventRelation^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RedRedundantUserLoginEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs, including all inherited members.
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs |
aServerHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs |
aUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs |
GeViAct_RedRedundantUserLoginEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs | [private]
GeViAct_RedRedundantUserLoginEventArgs(GeViAct_RedRedundantUserLogin^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs |
GeViAct_CameraOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs | [private]
GeViAct_CameraOffEventArgs(GeViAct_CameraOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_DefaultPosSaveEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs |
GeViAct_DefaultPosSaveEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs | [private]
GeViAct_DefaultPosSaveEventArgs(GeViAct_DefaultPosSave^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AckAlarmByMGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs, including all inherited members.
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs |
GeViAct_AckAlarmByMGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs | [private]
GeViAct_AckAlarmByMGEventArgs(GeViAct_AckAlarmByMG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSPictureToOutputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs |
aWhichPicture | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs |
GeViAct_VSPictureToOutputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs | [private]
GeViAct_VSPictureToOutputEventArgs(GeViAct_VSPictureToOutput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncXOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs |
GeViAct_IlluminatorSpecFuncXOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs | [private]
GeViAct_IlluminatorSpecFuncXOnEventArgs(GeViAct_IlluminatorSpecFuncXOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPAlarmLUTamperEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs |
GeViAct_MIPAlarmLUTamperEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs | [private]
GeViAct_MIPAlarmLUTamperEventArgs(GeViAct_MIPAlarmLUTamper^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraAutoFocusOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs |
GeViAct_CameraAutoFocusOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs | [private]
GeViAct_CameraAutoFocusOffEventArgs(GeViAct_CameraAutoFocusOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SyncTimeRequestEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs, including all inherited members.
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs |
GeViAct_SyncTimeRequestEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs | [private]
GeViAct_SyncTimeRequestEventArgs(GeViAct_SyncTimeRequest^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_EventStartedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs, including all inherited members.
aEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs |
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs |
GeViAct_EventStartedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs | [private]
GeViAct_EventStartedEventArgs(GeViAct_EventStarted^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraCyclePrevEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs, including all inherited members.
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs |
GeViAct_CameraCyclePrevEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs | [private]
GeViAct_CameraCyclePrevEventArgs(GeViAct_CameraCyclePrev^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoContrastPreAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs, including all inherited members.
aThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs |
GeViAct_VideoContrastPreAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs | [private]
GeViAct_VideoContrastPreAlarmEventArgs(GeViAct_VideoContrastPreAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_GscActionEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs, including all inherited members.
GeViAct_GscActionEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs | [private]
GeViAct_GscActionEventArgs(GscAction^ act) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs |
m_GscAction | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CopyAlarmByInstanceEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs |
GeViAct_CopyAlarmByInstanceEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs | [private]
GeViAct_CopyAlarmByInstanceEventArgs(GeViAct_CopyAlarmByInstance^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSSetSensorModeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs, including all inherited members.
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs |
GeViAct_VSSetSensorModeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs | [private]
GeViAct_VSSetSensorModeEventArgs(GeViAct_VSSetSensorMode^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTourPrevEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs, including all inherited members.
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs |
GeViAct_CameraTourPrevEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs | [private]
GeViAct_CameraTourPrevEventArgs(GeViAct_CameraTourPrev^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IrisOpenEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs |
GeViAct_IrisOpenEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs | [private]
GeViAct_IrisOpenEventArgs(GeViAct_IrisOpen^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSAllTestAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs |
GeViAct_VSAllTestAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs | [private]
GeViAct_VSAllTestAlarmEventArgs(GeViAct_VSAllTestAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MonitorGroupStatusChangedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs, including all inherited members.
aEnabled | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs |
GeViAct_MonitorGroupStatusChangedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs | [private]
GeViAct_MonitorGroupStatusChangedEventArgs(GeViAct_MonitorGroupStatusChanged^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RedConnectionMasterChangedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs, including all inherited members.
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs |
aNewMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs |
aOldMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs |
aUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs |
GeViAct_RedConnectionMasterChangedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs | [private]
GeViAct_RedConnectionMasterChangedEventArgs(GeViAct_RedConnectionMasterChanged^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IrisStopEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs |
GeViAct_IrisStopEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs | [private]
GeViAct_IrisStopEventArgs(GeViAct_IrisStop^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraAutoFocusOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs |
GeViAct_CameraAutoFocusOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs | [private]
GeViAct_CameraAutoFocusOnEventArgs(GeViAct_CameraAutoFocusOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPAuxiliarySensorStatusEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs |
aUnitType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs |
GeViAct_MIPAuxiliarySensorStatusEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs | [private]
GeViAct_MIPAuxiliarySensorStatusEventArgs(GeViAct_MIPAuxiliarySensorStatus^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PrePosSaveEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs, including all inherited members.
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs |
GeViAct_PrePosSaveEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs | [private]
GeViAct_PrePosSaveEventArgs(GeViAct_PrePosSave^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PanLeftEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs |
GeViAct_PanLeftEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs | [private]
GeViAct_PanLeftEventArgs(GeViAct_PanLeft^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPTurnARelayControlEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs |
GeViAct_MIPTurnARelayControlEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs | [private]
GeViAct_MIPTurnARelayControlEventArgs(GeViAct_MIPTurnARelayControl^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StopTimerEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs, including all inherited members.
aTimerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs |
aTimerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs |
GeViAct_StopTimerEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs | [private]
GeViAct_StopTimerEventArgs(GeViAct_StopTimer^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CrossSwitchEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs, including all inherited members.
aSwitchMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs |
GeViAct_CrossSwitchEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs | [private]
GeViAct_CrossSwitchEventArgs(GeViAct_CrossSwitch^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_OpenContactEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs, including all inherited members.
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs |
GeViAct_OpenContactEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs | [private]
GeViAct_OpenContactEventArgs(GeViAct_OpenContact^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_NormalModeOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs |
GeViAct_NormalModeOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs | [private]
GeViAct_NormalModeOnEventArgs(GeViAct_NormalModeOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ActionByNameEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs, including all inherited members.
aActionName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs |
GeViAct_ActionByNameEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs | [private]
GeViAct_ActionByNameEventArgs(GeViAct_ActionByName^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ClearAlarmFlagVideoInputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs |
GeViAct_ClearAlarmFlagVideoInputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs | [private]
GeViAct_ClearAlarmFlagVideoInputEventArgs(GeViAct_ClearAlarmFlagVideoInput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSRecorderEndEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs |
GeViAct_VSRecorderEndEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs | [private]
GeViAct_VSRecorderEndEventArgs(GeViAct_VSRecorderEnd^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTextOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs |
GeViAct_CameraTextOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs | [private]
GeViAct_CameraTextOnEventArgs(GeViAct_CameraTextOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPSecureDisplaySegmentEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs |
GeViAct_MIPSecureDisplaySegmentEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs | [private]
GeViAct_MIPSecureDisplaySegmentEventArgs(GeViAct_MIPSecureDisplaySegment^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPRMTamperAlarmStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs, including all inherited members.
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs |
GeViAct_MIPRMTamperAlarmStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs | [private]
GeViAct_MIPRMTamperAlarmStateEventArgs(GeViAct_MIPRMTamperAlarmState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSmearAndWashOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs |
GeViAct_CameraSmearAndWashOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs | [private]
GeViAct_CameraSmearAndWashOnEventArgs(GeViAct_CameraSmearAndWashOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSpecUFuncOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs |
GeViAct_CameraSpecUFuncOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs | [private]
GeViAct_CameraSpecUFuncOffEventArgs(GeViAct_CameraSpecUFuncOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_DataBaseMissingEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs, including all inherited members.
GeViAct_DataBaseMissingEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs | [private]
GeViAct_DataBaseMissingEventArgs(GeViAct_DataBaseMissing^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RedChangeMasterEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs, including all inherited members.
aDisconnectIOClients | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs |
aNewMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs |
GeViAct_RedChangeMasterEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs | [private]
GeViAct_RedChangeMasterEventArgs(GeViAct_RedChangeMaster^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MonitorGroupEnableEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs, including all inherited members.
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs |
GeViAct_MonitorGroupEnableEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs | [private]
GeViAct_MonitorGroupEnableEventArgs(GeViAct_MonitorGroupEnable^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPPMComFailStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs |
GeViAct_MIPPMComFailStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs | [private]
GeViAct_MIPPMComFailStateEventArgs(GeViAct_MIPPMComFailState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MscEventStartedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs, including all inherited members.
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
aMscEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
aMscEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
aMscMessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
GeViAct_MscEventStartedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs | [private]
GeViAct_MscEventStartedEventArgs(GeViAct_MscEventStarted^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSSetModeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs |
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs |
GeViAct_VSSetModeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs | [private]
GeViAct_VSSetModeEventArgs(GeViAct_VSSetMode^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncXOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs |
GeViAct_IlluminatorSpecFuncXOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs | [private]
GeViAct_IlluminatorSpecFuncXOffEventArgs(GeViAct_IlluminatorSpecFuncXOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs |
GeViAct_CameraOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs | [private]
GeViAct_CameraOnEventArgs(GeViAct_CameraOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CloseContactEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs, including all inherited members.
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs |
GeViAct_CloseContactEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs | [private]
GeViAct_CloseContactEventArgs(GeViAct_CloseContact^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPPMTamperStatusEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs |
GeViAct_MIPPMTamperStatusEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs | [private]
GeViAct_MIPPMTamperStatusEventArgs(GeViAct_MIPPMTamperStatus^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSVMDModeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs, including all inherited members.
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs |
GeViAct_VSVMDModeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs | [private]
GeViAct_VSVMDModeEventArgs(GeViAct_VSVMDMode^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraCycleStopEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs, including all inherited members.
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs |
GeViAct_CameraCycleStopEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs | [private]
GeViAct_CameraCycleStopEventArgs(GeViAct_CameraCycleStop^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PrePosClearEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs, including all inherited members.
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs |
GeViAct_PrePosClearEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs | [private]
GeViAct_PrePosClearEventArgs(GeViAct_PrePosClear^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_HistoricalAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs, including all inherited members.
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs |
aTimeStamp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs |
GeViAct_HistoricalAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs | [private]
GeViAct_HistoricalAlarmEventArgs(GeViAct_HistoricalAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RestoreRightProfileEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs, including all inherited members.
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs |
aUserName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs |
GeViAct_RestoreRightProfileEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs | [private]
GeViAct_RestoreRightProfileEventArgs(GeViAct_RestoreRightProfile^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSPreAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs, including all inherited members.
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs |
GeViAct_VSPreAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs | [private]
GeViAct_VSPreAlarmEventArgs(GeViAct_VSPreAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncVOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs |
GeViAct_IlluminatorSpecFuncVOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs | [private]
GeViAct_IlluminatorSpecFuncVOffEventArgs(GeViAct_IlluminatorSpecFuncVOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IrisCloseEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs |
GeViAct_IrisCloseEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs | [private]
GeViAct_IrisCloseEventArgs(GeViAct_IrisClose^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_DisconnectUserEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs, including all inherited members.
aAdminID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs |
aReason | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs |
aUserName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs |
GeViAct_DisconnectUserEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs | [private]
GeViAct_DisconnectUserEventArgs(GeViAct_DisconnectUser^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MoveActualAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs |
GeViAct_MoveActualAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs | [private]
GeViAct_MoveActualAlarmEventArgs(GeViAct_MoveActualAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSVMDOutOfOrderEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs |
GeViAct_VSVMDOutOfOrderEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs | [private]
GeViAct_VSVMDOutOfOrderEventArgs(GeViAct_VSVMDOutOfOrder^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPDisplaySegmentStatusEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs |
GeViAct_MIPDisplaySegmentStatusEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs | [private]
GeViAct_MIPDisplaySegmentStatusEventArgs(GeViAct_MIPDisplaySegmentStatus^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPSecureAuxiliaryTP1EventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs |
GeViAct_MIPSecureAuxiliaryTP1EventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs | [private]
GeViAct_MIPSecureAuxiliaryTP1EventArgs(GeViAct_MIPSecureAuxiliaryTP1^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraClearPrePosTextEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs, including all inherited members.
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs |
GeViAct_CameraClearPrePosTextEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs | [private]
GeViAct_CameraClearPrePosTextEventArgs(GeViAct_CameraClearPrePosText^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_QuitAlarmByInstanceEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs |
GeViAct_QuitAlarmByInstanceEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs | [private]
GeViAct_QuitAlarmByInstanceEventArgs(GeViAct_QuitAlarmByInstance^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPSecureAuxiliarySensorEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs |
GeViAct_MIPSecureAuxiliarySensorEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs | [private]
GeViAct_MIPSecureAuxiliarySensorEventArgs(GeViAct_MIPSecureAuxiliarySensor^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncUOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs |
GeViAct_IlluminatorSpecFuncUOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs | [private]
GeViAct_IlluminatorSpecFuncUOffEventArgs(GeViAct_IlluminatorSpecFuncUOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_UserLogoutEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs, including all inherited members.
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs |
aPort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs |
GeViAct_UserLogoutEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs | [private]
GeViAct_UserLogoutEventArgs(GeViAct_UserLogout^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RescannRequestEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs, including all inherited members.
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs |
GeViAct_RescannRequestEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs | [private]
GeViAct_RescannRequestEventArgs(GeViAct_RescannRequest^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MoveAlarmByInstanceEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs |
GeViAct_MoveAlarmByInstanceEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs | [private]
GeViAct_MoveAlarmByInstanceEventArgs(GeViAct_MoveAlarmByInstance^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTextOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs |
GeViAct_CameraTextOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs | [private]
GeViAct_CameraTextOffEventArgs(GeViAct_CameraTextOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSpecVFuncOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs |
GeViAct_CameraSpecVFuncOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs | [private]
GeViAct_CameraSpecVFuncOffEventArgs(GeViAct_CameraSpecVFuncOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSpec1FuncOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs |
GeViAct_CameraSpec1FuncOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs | [private]
GeViAct_CameraSpec1FuncOffEventArgs(GeViAct_CameraSpec1FuncOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraLightOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs |
GeViAct_CameraLightOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs | [private]
GeViAct_CameraLightOffEventArgs(GeViAct_CameraLightOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncYOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs |
GeViAct_IlluminatorSpecFuncYOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs | [private]
GeViAct_IlluminatorSpecFuncYOffEventArgs(GeViAct_IlluminatorSpecFuncYOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlarmDisplayedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
aFirstTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
aOtherCleared | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
GeViAct_AlarmDisplayedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs | [private]
GeViAct_AlarmDisplayedEventArgs(GeViAct_AlarmDisplayed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSmearAndWashOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs |
GeViAct_CameraSmearAndWashOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs | [private]
GeViAct_CameraSmearAndWashOffEventArgs(GeViAct_CameraSmearAndWashOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_UserLoginFailedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs, including all inherited members.
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs |
aPort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs |
aReason | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs |
GeViAct_UserLoginFailedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs | [private]
GeViAct_UserLoginFailedEventArgs(GeViAct_UserLoginFailed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VX3SystemResetEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs |
GeViAct_VX3SystemResetEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs | [private]
GeViAct_VX3SystemResetEventArgs(GeViAct_VX3SystemReset^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_TiltDownEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs |
GeViAct_TiltDownEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs | [private]
GeViAct_TiltDownEventArgs(GeViAct_TiltDown^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ClearVideoOutputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs, including all inherited members.
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs |
GeViAct_ClearVideoOutputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs | [private]
GeViAct_ClearVideoOutputEventArgs(GeViAct_ClearVideoOutput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPAlarmPMTamperEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs |
GeViAct_MIPAlarmPMTamperEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs | [private]
GeViAct_MIPAlarmPMTamperEventArgs(GeViAct_MIPAlarmPMTamper^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MonitorGroupDisableEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs, including all inherited members.
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs |
GeViAct_MonitorGroupDisableEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs | [private]
GeViAct_MonitorGroupDisableEventArgs(GeViAct_MonitorGroupDisable^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_InputContactEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs, including all inherited members.
aChangedTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs |
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs |
GeViAct_InputContactEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs | [private]
GeViAct_InputContactEventArgs(GeViAct_InputContact^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PopUpAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs |
GeViAct_PopUpAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs | [private]
GeViAct_PopUpAlarmEventArgs(GeViAct_PopUpAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SyncTimeSetTimeClientEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs |
aDateAndTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs |
GeViAct_SyncTimeSetTimeClientEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs | [private]
GeViAct_SyncTimeSetTimeClientEventArgs(GeViAct_SyncTimeSetTimeClient^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SyncTimeSetTimeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs, including all inherited members.
aDateAndTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs |
GeViAct_SyncTimeSetTimeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs | [private]
GeViAct_SyncTimeSetTimeEventArgs(GeViAct_SyncTimeSetTime^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AckAlarmByInstanceEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs |
GeViAct_AckAlarmByInstanceEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs | [private]
GeViAct_AckAlarmByInstanceEventArgs(GeViAct_AckAlarmByInstance^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTourNextEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs, including all inherited members.
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs |
GeViAct_CameraTourNextEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs | [private]
GeViAct_CameraTourNextEventArgs(GeViAct_CameraTourNext^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSPictureToCommonOutEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs, including all inherited members.
aOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs |
GeViAct_VSPictureToCommonOutEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs | [private]
GeViAct_VSPictureToCommonOutEventArgs(GeViAct_VSPictureToCommonOut^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSetPrePosTextEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs, including all inherited members.
aText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs |
GeViAct_CameraSetPrePosTextEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs | [private]
GeViAct_CameraSetPrePosTextEventArgs(GeViAct_CameraSetPrePosText^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_QuitAlarmByTypeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs, including all inherited members.
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs |
GeViAct_QuitAlarmByTypeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs | [private]
GeViAct_QuitAlarmByTypeEventArgs(GeViAct_QuitAlarmByType^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SystemErrorEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs |
aErrorCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs |
aErrorSubCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs |
aErrorText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs |
GeViAct_SystemErrorEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs | [private]
GeViAct_SystemErrorEventArgs(GeViAct_SystemError^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPSecureRMEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs |
GeViAct_MIPSecureRMEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs | [private]
GeViAct_MIPSecureRMEventArgs(GeViAct_MIPSecureRM^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSpecVFuncOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs |
GeViAct_CameraSpecVFuncOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs | [private]
GeViAct_CameraSpecVFuncOnEventArgs(GeViAct_CameraSpecVFuncOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorCameraOutputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs, including all inherited members.
aCommand | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs |
GeViAct_IlluminatorCameraOutputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs | [private]
GeViAct_IlluminatorCameraOutputEventArgs(GeViAct_IlluminatorCameraOutput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSTimerResetEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs |
GeViAct_VSTimerResetEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs | [private]
GeViAct_VSTimerResetEventArgs(GeViAct_VSTimerReset^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_TiltUpEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs |
GeViAct_TiltUpEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs | [private]
GeViAct_TiltUpEventArgs(GeViAct_TiltUp^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlarmQuittedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
GeViAct_AlarmQuittedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs | [private]
GeViAct_AlarmQuittedEventArgs(GeViAct_AlarmQuitted^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraManualIrisOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs |
GeViAct_CameraManualIrisOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs | [private]
GeViAct_CameraManualIrisOnEventArgs(GeViAct_CameraManualIrisOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoSyncFailureEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs |
GeViAct_VideoSyncFailureEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs | [private]
GeViAct_VideoSyncFailureEventArgs(GeViAct_VideoSyncFailure^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPAlarmCableEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs, including all inherited members.
aCable | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs |
aLocation | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs |
GeViAct_MIPAlarmCableEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs | [private]
GeViAct_MIPAlarmCableEventArgs(GeViAct_MIPAlarmCable^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VS30PMModeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs |
GeViAct_VS30PMModeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs | [private]
GeViAct_VS30PMModeEventArgs(GeViAct_VS30PMMode^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPAlarmRMTamperEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs |
GeViAct_MIPAlarmRMTamperEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs | [private]
GeViAct_MIPAlarmRMTamperEventArgs(GeViAct_MIPAlarmRMTamper^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoTextOutEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs, including all inherited members.
aText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs |
GeViAct_VideoTextOutEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs | [private]
GeViAct_VideoTextOutEventArgs(GeViAct_VideoTextOut^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_InformAllUsersMSGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs, including all inherited members.
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs |
GeViAct_InformAllUsersMSGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs | [private]
GeViAct_InformAllUsersMSGEventArgs(GeViAct_InformAllUsersMSG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SyncTimeSetTimeActualEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs, including all inherited members.
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs |
GeViAct_SyncTimeSetTimeActualEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs | [private]
GeViAct_SyncTimeSetTimeActualEventArgs(GeViAct_SyncTimeSetTimeActual^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPSecurePMEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs |
GeViAct_MIPSecurePMEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs | [private]
GeViAct_MIPSecurePMEventArgs(GeViAct_MIPSecurePM^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_EventStoppedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs, including all inherited members.
aEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs |
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs |
GeViAct_EventStoppedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs | [private]
GeViAct_EventStoppedEventArgs(GeViAct_EventStopped^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CopyCameraOnMonitorEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs, including all inherited members.
aVideoOutputFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs |
aVideoOutputTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs |
GeViAct_CopyCameraOnMonitorEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs | [private]
GeViAct_CopyCameraOnMonitorEventArgs(GeViAct_CopyCameraOnMonitor^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSRecorderTimerResetEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs |
GeViAct_VSRecorderTimerResetEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs | [private]
GeViAct_VSRecorderTimerResetEventArgs(GeViAct_VSRecorderTimerReset^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RescannRequestToClientEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs |
GeViAct_RescannRequestToClientEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs | [private]
GeViAct_RescannRequestToClientEventArgs(GeViAct_RescannRequestToClient^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StartTimerEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs, including all inherited members.
aTimerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs |
aTimerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs |
GeViAct_StartTimerEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs | [private]
GeViAct_StartTimerEventArgs(GeViAct_StartTimer^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTourPauseEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs, including all inherited members.
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs |
GeViAct_CameraTourPauseEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs | [private]
GeViAct_CameraTourPauseEventArgs(GeViAct_CameraTourPause^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StopEventByTypeEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs, including all inherited members.
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs |
GeViAct_StopEventByTypeEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs | [private]
GeViAct_StopEventByTypeEventArgs(GeViAct_StopEventByType^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MBegAlarmStartEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs, including all inherited members.
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs |
aUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs |
GeViAct_MBegAlarmStartEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs | [private]
GeViAct_MBegAlarmStartEventArgs(GeViAct_MBegAlarmStart^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs |
GeViAct_IlluminatorOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs | [private]
GeViAct_IlluminatorOnEventArgs(GeViAct_IlluminatorOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraTourStartEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs, including all inherited members.
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs |
aTourID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs |
aTourName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs |
GeViAct_CameraTourStartEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs | [private]
GeViAct_CameraTourStartEventArgs(GeViAct_CameraTourStart^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MscServerConnectFailedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs, including all inherited members.
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs |
GeViAct_MscServerConnectFailedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs | [private]
GeViAct_MscServerConnectFailedEventArgs(GeViAct_MscServerConnectFailed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_AlarmAckedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
GeViAct_AlarmAckedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs | [private]
GeViAct_AlarmAckedEventArgs(GeViAct_AlarmAcked^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_RedirectResourceEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs, including all inherited members.
aNewNumber | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs |
aOldNumber | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs |
aResourceType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs |
GeViAct_RedirectResourceEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs | [private]
GeViAct_RedirectResourceEventArgs(GeViAct_RedirectResource^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ZoomInEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs |
GeViAct_ZoomInEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs | [private]
GeViAct_ZoomInEventArgs(GeViAct_ZoomIn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoSyncOkEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs |
GeViAct_VideoSyncOkEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs | [private]
GeViAct_VideoSyncOkEventArgs(GeViAct_VideoSyncOk^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ClearAlarmFlagVideoOutputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs, including all inherited members.
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs |
GeViAct_ClearAlarmFlagVideoOutputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs | [private]
GeViAct_ClearAlarmFlagVideoOutputEventArgs(GeViAct_ClearAlarmFlagVideoOutput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorGetDimLevelEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs |
GeViAct_IlluminatorGetDimLevelEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs | [private]
GeViAct_IlluminatorGetDimLevelEventArgs(GeViAct_IlluminatorGetDimLevel^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSTestAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs |
GeViAct_VSTestAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs | [private]
GeViAct_VSTestAlarmEventArgs(GeViAct_VSTestAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPRMComFailStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs |
GeViAct_MIPRMComFailStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs | [private]
GeViAct_MIPRMComFailStateEventArgs(GeViAct_MIPRMComFailState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MBegInitSeqEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs, including all inherited members.
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs |
aSeq | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs |
GeViAct_MBegInitSeqEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs | [private]
GeViAct_MBegInitSeqEventArgs(GeViAct_MBegInitSeq^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_GeviScopeServerConnectedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs, including all inherited members.
aGscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs |
GeViAct_GeviScopeServerConnectedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs | [private]
GeViAct_GeviScopeServerConnectedEventArgs(GeViAct_GeviScopeServerConnected^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MscServerDisconnectedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs, including all inherited members.
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs |
GeViAct_MscServerDisconnectedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs | [private]
GeViAct_MscServerDisconnectedEventArgs(GeViAct_MscServerDisconnected^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPQueryInterfaceEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs |
GeViAct_MIPQueryInterfaceEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs | [private]
GeViAct_MIPQueryInterfaceEventArgs(GeViAct_MIPQueryInterface^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraPumpOffEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs |
GeViAct_CameraPumpOffEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs | [private]
GeViAct_CameraPumpOffEventArgs(GeViAct_CameraPumpOff^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_DefaultPosClearEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs |
GeViAct_DefaultPosClearEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs | [private]
GeViAct_DefaultPosClearEventArgs(GeViAct_DefaultPosClear^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CopyActualAlarmEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs |
GeViAct_CopyActualAlarmEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs | [private]
GeViAct_CopyActualAlarmEventArgs(GeViAct_CopyActualAlarm^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPSecureAuxiliaryTP2EventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs |
GeViAct_MIPSecureAuxiliaryTP2EventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs | [private]
GeViAct_MIPSecureAuxiliaryTP2EventArgs(GeViAct_MIPSecureAuxiliaryTP2^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncUOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs |
GeViAct_IlluminatorSpecFuncUOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs | [private]
GeViAct_IlluminatorSpecFuncUOnEventArgs(GeViAct_IlluminatorSpecFuncUOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MscEventStoppedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs, including all inherited members.
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
aMscEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
aMscEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
aMscMessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
GeViAct_MscEventStoppedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs | [private]
GeViAct_MscEventStoppedEventArgs(GeViAct_MscEventStopped^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPCableAFaultStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs |
GeViAct_MIPCableAFaultStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs | [private]
GeViAct_MIPCableAFaultStateEventArgs(GeViAct_MIPCableAFaultState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPDisplaySegmentAlarmStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs, including all inherited members.
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs |
GeViAct_MIPDisplaySegmentAlarmStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs | [private]
GeViAct_MIPDisplaySegmentAlarmStateEventArgs(GeViAct_MIPDisplaySegmentAlarmState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorDimLevelEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs |
aLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs |
GeViAct_IlluminatorDimLevelEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs | [private]
GeViAct_IlluminatorDimLevelEventArgs(GeViAct_IlluminatorDimLevel^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSPictureDetectEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs, including all inherited members.
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs |
GeViAct_VSPictureDetectEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs | [private]
GeViAct_VSPictureDetectEventArgs(GeViAct_VSPictureDetect^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_FocusFarEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs, including all inherited members.
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs |
GeViAct_FocusFarEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs | [private]
GeViAct_FocusFarEventArgs(GeViAct_FocusFar^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_LogMessageMSGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
GeViAct_LogMessageMSGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs | [private]
GeViAct_LogMessageMSGEventArgs(GeViAct_LogMessageMSG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_GeviScopeServerConnectionFailedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs, including all inherited members.
aGscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs |
GeViAct_GeviScopeServerConnectionFailedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs | [private]
GeViAct_GeviScopeServerConnectionFailedEventArgs(GeViAct_GeviScopeServerConnectionFailed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_ZoomStopEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs |
GeViAct_ZoomStopEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs | [private]
GeViAct_ZoomStopEventArgs(GeViAct_ZoomStop^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MscSetupModifiedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs, including all inherited members.
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs |
GeViAct_MscSetupModifiedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs | [private]
GeViAct_MscSetupModifiedEventArgs(GeViAct_MscSetupModified^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoThresholdValueEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs, including all inherited members.
aAVGThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
aInternal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
aInternal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
aMinThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
aNumberOfMeasures | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
aSecondsSinceStart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
aThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
GeViAct_VideoThresholdValueEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs | [private]
GeViAct_VideoThresholdValueEventArgs(GeViAct_VideoThresholdValue^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPAlarmAuxiliaryInputEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs, including all inherited members.
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs |
aLocation | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs |
aUnitType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs |
GeViAct_MIPAlarmAuxiliaryInputEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs | [private]
GeViAct_MIPAlarmAuxiliaryInputEventArgs(GeViAct_MIPAlarmAuxiliaryInput^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_FocusStopEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs |
GeViAct_FocusStopEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs | [private]
GeViAct_FocusStopEventArgs(GeViAct_FocusStop^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StopMscEventEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs, including all inherited members.
aIgnoreRefs | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs |
GeViAct_StopMscEventEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs | [private]
GeViAct_StopMscEventEventArgs(GeViAct_StopMscEvent^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_QuitAlarmByMGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs, including all inherited members.
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs |
GeViAct_QuitAlarmByMGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs | [private]
GeViAct_QuitAlarmByMGEventArgs(GeViAct_QuitAlarmByMG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPLUTamperAlarmStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs, including all inherited members.
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs |
GeViAct_MIPLUTamperAlarmStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs | [private]
GeViAct_MIPLUTamperAlarmStateEventArgs(GeViAct_MIPLUTamperAlarmState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorLightOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs |
GeViAct_IlluminatorLightOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs | [private]
GeViAct_IlluminatorLightOnEventArgs(GeViAct_IlluminatorLightOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MBegInitRequestEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs, including all inherited members.
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs |
GeViAct_MBegInitRequestEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs | [private]
GeViAct_MBegInitRequestEventArgs(GeViAct_MBegInitRequest^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoClearTextOutEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs, including all inherited members.
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs |
GeViAct_VideoClearTextOutEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs | [private]
GeViAct_VideoClearTextOutEventArgs(GeViAct_VideoClearTextOut^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSSetAllArmedEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs, including all inherited members.
aArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs |
GeViAct_VSSetAllArmedEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs | [private]
GeViAct_VSSetAllArmedEventArgs(GeViAct_VSSetAllArmed^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_IlluminatorSpecFuncYOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs, including all inherited members.
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs |
GeViAct_IlluminatorSpecFuncYOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs | [private]
GeViAct_IlluminatorSpecFuncYOnEventArgs(GeViAct_IlluminatorSpecFuncYOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MscServerDisconnectEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs, including all inherited members.
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs |
GeViAct_MscServerDisconnectEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs | [private]
GeViAct_MscServerDisconnectEventArgs(GeViAct_MscServerDisconnect^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_InformUserMSGEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs, including all inherited members.
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
aToName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
GeViAct_InformUserMSGEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs | [private]
GeViAct_InformUserMSGEventArgs(GeViAct_InformUserMSG^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MBegAlarmAckEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs, including all inherited members.
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs |
aUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs |
GeViAct_MBegAlarmAckEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs | [private]
GeViAct_MBegAlarmAckEventArgs(GeViAct_MBegAlarmAck^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSAlarmExternEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs |
GeViAct_VSAlarmExternEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs | [private]
GeViAct_VSAlarmExternEventArgs(GeViAct_VSAlarmExtern^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MBegUnlockCameraEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs, including all inherited members.
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs |
GeViAct_MBegUnlockCameraEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs | [private]
GeViAct_MBegUnlockCameraEventArgs(GeViAct_MBegUnlockCamera^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraSpecUFuncOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs |
GeViAct_CameraSpecUFuncOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs | [private]
GeViAct_CameraSpecUFuncOnEventArgs(GeViAct_CameraSpecUFuncOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_MIPPMTamperAlarmStateEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs, including all inherited members.
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs |
GeViAct_MIPPMTamperAlarmStateEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs | [private]
GeViAct_MIPPMTamperAlarmStateEventArgs(GeViAct_MIPPMTamperAlarmState^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSAllTimerResetEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs |
GeViAct_VSAllTimerResetEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs | [private]
GeViAct_VSAllTimerResetEventArgs(GeViAct_VSAllTimerReset^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VSSyncSignalDetectEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs, including all inherited members.
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs |
GeViAct_VSSyncSignalDetectEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs | [private]
GeViAct_VSSyncSignalDetectEventArgs(GeViAct_VSSyncSignalDetect^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StartEventEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs, including all inherited members.
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs |
GeViAct_StartEventEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs | [private]
GeViAct_StartEventEventArgs(GeViAct_StartEvent^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraPumpOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs |
GeViAct_CameraPumpOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs | [private]
GeViAct_CameraPumpOnEventArgs(GeViAct_CameraPumpOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_VideoContrastOkEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs |
GeViAct_VideoContrastOkEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs | [private]
GeViAct_VideoContrastOkEventArgs(GeViAct_VideoContrastOk^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_PanAutoEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs, including all inherited members.
aModus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs |
GeViAct_PanAutoEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs | [private]
GeViAct_PanAutoEventArgs(GeViAct_PanAuto^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_TakeCameraControlEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs, including all inherited members.
aPeriod | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs |
GeViAct_TakeCameraControlEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs | [private]
GeViAct_TakeCameraControlEventArgs(GeViAct_TakeCameraControl^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_FastetModeOnEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs, including all inherited members.
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs |
GeViAct_FastetModeOnEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs | [private]
GeViAct_FastetModeOnEventArgs(GeViAct_FastetModeOn^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SendRawDataEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs |
aRawData | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs |
GeViAct_SendRawDataEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs | [private]
GeViAct_SendRawDataEventArgs(GeViAct_SendRawData^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_LogMessageEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs, including all inherited members.
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs |
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs |
aLogText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs |
GeViAct_LogMessageEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs | [private]
GeViAct_LogMessageEventArgs(GeViAct_LogMessage^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_CameraCycleNextEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs, including all inherited members.
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs |
GeViAct_CameraCycleNextEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs | [private]
GeViAct_CameraCycleNextEventArgs(GeViAct_CameraCycleNext^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_SystemWarningEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs, including all inherited members.
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs |
aWarningCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs |
aWarningSubCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs |
aWarningText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs |
GeViAct_SystemWarningEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs | [private]
GeViAct_SystemWarningEventArgs(GeViAct_SystemWarning^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ActionDispatcher
  • GeViAct_StopEventByInstanceEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs, including all inherited members.
aEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs |
GeViAct_StopEventByInstanceEventArgs() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs | [private]
GeViAct_StopEventByInstanceEventArgs(GeViAct_StopEventByInstance^ initAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs |
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AlarmRetriggered
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAckCleared | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered | [static]
GeViAct_AlarmRetriggered(GeViAlarmID initAlarmID, Boolean initAckCleared) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MBegAlarmQuit
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit |
aUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit | [static]
GeViAct_MBegAlarmQuit(Int32 initUp, Int32 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AckAlarmByMG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG | [static]
GeViAct_AckAlarmByMG(GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MoveActualAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm | [static]
GeViAct_MoveActualAlarm(GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_CopyAlarmByInstance
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance | [static]
GeViAct_CopyAlarmByInstance(GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_QuitAlarmByType
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType | [static]
GeViAct_QuitAlarmByType(GeViClientID initClientID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AlarmCopied
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied |
aMGFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied |
aMGTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied | [static]
GeViAct_AlarmCopied(GeViAlarmID initAlarmID, GeViMGID initMGFrom, GeViMGID initMGTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MBegAlarmAck
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck |
aUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck | [static]
GeViAct_MBegAlarmAck(Int32 initUp, Int32 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AlarmDisplayed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed |
aFirstTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed |
aOtherCleared | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed | [static]
GeViAct_AlarmDisplayed(GeViMGID initMonitorGroup, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, Boolean initFirstTime, Boolean initOtherCleared) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AckAllAlarmsOnMG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG | [static]
GeViAct_AckAllAlarmsOnMG(GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AlarmQuitted
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted | [static]
GeViAct_AlarmQuitted(GeViClientID initClientID, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViMGID initMGID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MonitorGroupEnable
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable | [static]
GeViAct_MonitorGroupEnable(GeViMGID initMonitorGroup) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_StartAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm | [static]
GeViAct_StartAlarm(GeViClientID initClientID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AlarmMoved
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved |
aMGFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved |
aMGTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved | [static]
GeViAct_AlarmMoved(GeViAlarmID initAlarmID, GeViMGID initMGFrom, GeViMGID initMGTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_QuitAllAlarmsOnMG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG | [static]
GeViAct_QuitAllAlarmsOnMG(GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_QuitAlarmByMG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG |
aMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG | [static]
GeViAct_QuitAlarmByMG(GeViClientID initClientID, GeViMGID initMGID, String^ initMGName, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MBegAlarmStart
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart |
aUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart | [static]
GeViAct_MBegAlarmStart(Int32 initUp, Int32 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MonitorGroupStatusChanged
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aEnabled | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged | [static]
GeViAct_MonitorGroupStatusChanged(GeViMGID initMonitorGroup, Boolean initEnabled) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MoveAlarmByInstance
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance | [static]
GeViAct_MoveAlarmByInstance(GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_PopUpNextAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm | [static]
GeViAct_PopUpNextAlarm(GeViMGID initMonitorGroup, GeViClientID initUserID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_PopUpAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm | [static]
GeViAct_PopUpAlarm(GeViMGID initMonitorGroup, GeViClientID initUserID, GeViAlarmID initAlarmID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AlarmAcked
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked | [static]
GeViAct_AlarmAcked(GeViClientID initClientID, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViMGID initMGID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AlarmStarted
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted |
aMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted | [static]
GeViAct_AlarmStarted(GeViClientID initClientID, GeViAlarmID initAlarmID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViMGID initMGID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_CopyActualAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm | [static]
GeViAct_CopyActualAlarm(GeViMGID initFrom, GeViMGID initTo, GeViClientID initUserID, GeViAlarmID initAlarmID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_MonitorGroupDisable
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable | [static]
GeViAct_MonitorGroupDisable(GeViMGID initMonitorGroup) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_QuitAlarmByInstance
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance | [static]
GeViAct_QuitAlarmByInstance(GeViClientID initClientID, GeViAlarmID initAlarmID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AckAlarmByType
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType | [static]
GeViAct_AckAlarmByType(GeViClientID initClientID, GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • AlarmControlActions
  • GeViAct_AckAlarmByInstance
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance |
aAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance | [static]
GeViAct_AckAlarmByInstance(GeViClientID initClientID, GeViAlarmID initAlarmID, String^ initAlarmText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTourStart
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart |
aTourID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart |
aTourName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart | [static]
GeViAct_CameraTourStart(GeViVideoInputID initCameraID, Int32 initTourID, String^ initTourName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSmearAndWashOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff | [static]
GeViAct_CameraSmearAndWashOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_DefaultPosCallUp
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp | [static]
GeViAct_DefaultPosCallUp(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_FocusStop
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop | [static]
GeViAct_FocusStop(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_MBegInitRequest
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest | [static]
GeViAct_MBegInitRequest(GeViClientID initClient) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_FocusNear
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear | [static]
GeViAct_FocusNear(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_PanRight
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight | [static]
GeViAct_PanRight(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTourResume
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume | [static]
GeViAct_CameraTourResume(GeViVideoInputID initCameraID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff | [static]
GeViAct_CameraOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_TakeCameraControl
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aPeriod | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl | [static]
GeViAct_TakeCameraControl(GeViVideoInputID initVideoInput, Int32 initPeriod, GeViClientID initUserID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraCyclePause
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause | [static]
GeViAct_CameraCyclePause(GeViVideoOutputID initMonitorID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_TiltUp
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp | [static]
GeViAct_TiltUp(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraCycleNext
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext | [static]
GeViAct_CameraCycleNext(GeViVideoOutputID initMonitorID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraAutoFocusOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff | [static]
GeViAct_CameraAutoFocusOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraAutoFocusOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn | [static]
GeViAct_CameraAutoFocusOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_ZoomStop
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop | [static]
GeViAct_ZoomStop(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_TiltStop
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop | [static]
GeViAct_TiltStop(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSpecUFuncOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn | [static]
GeViAct_CameraSpecUFuncOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSpec1FuncOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff | [static]
GeViAct_CameraSpec1FuncOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_PanAuto
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aModus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto | [static]
GeViAct_PanAuto(GeViVideoInputID initVideoInput, Int32 initModus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraCycleStart
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCycleID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart |
aCycleName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart |
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart | [static]
GeViAct_CameraCycleStart(GeViVideoOutputID initMonitorID, Int32 initCycleID, String^ initCycleName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_VideoThresholdValue
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAVGThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
aInternal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
aInternal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
aMinThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
aNumberOfMeasures | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
aSecondsSinceStart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
aThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue | [static]
GeViAct_VideoThresholdValue(GeViClientID initClient, Int32 initInternal1, Int64 initInternal2, Int32 initThreshold, Int32 initMinThreshold, Int32 initAVGThreshold, Int32 initSecondsSinceStart, Int32 initNumberOfMeasures) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_MBegInitSeq
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq |
aSeq | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq | [static]
GeViAct_MBegInitSeq(GeViClientID initClient, String^ initSeq) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_DefaultPosClear
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear | [static]
GeViAct_DefaultPosClear(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraManualIrisOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn | [static]
GeViAct_CameraManualIrisOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraCycleResume
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume | [static]
GeViAct_CameraCycleResume(GeViVideoOutputID initMonitorID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSpecUFuncOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff | [static]
GeViAct_CameraSpecUFuncOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraPumpOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn | [static]
GeViAct_CameraPumpOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSetCameraText
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText | [static]
GeViAct_CameraSetCameraText(GeViVideoInputID initVideoInput, String^ initText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_TiltDown
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown | [static]
GeViAct_TiltDown(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraClearPrePosText
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText | [static]
GeViAct_CameraClearPrePosText(GeViVideoInputID initVideoInput, Int32 initPosition) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_PrePosCallUp
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp | [static]
GeViAct_PrePosCallUp(GeViVideoInputID initVideoInput, Int32 initPosition) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_DefaultPosSave
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave | [static]
GeViAct_DefaultPosSave(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_PrePosSave
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave | [static]
GeViAct_PrePosSave(GeViVideoInputID initVideoInput, Int32 initPosition) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_MBegUnlockCamera
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera | [static]
GeViAct_MBegUnlockCamera(GeViClientID initClient) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_PanStop
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop | [static]
GeViAct_PanStop(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTourPause
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause | [static]
GeViAct_CameraTourPause(GeViVideoInputID initCameraID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_FocusFar
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar | [static]
GeViAct_FocusFar(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraStopAll
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll | [static]
GeViAct_CameraStopAll(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraCyclePrev
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev | [static]
GeViAct_CameraCyclePrev(GeViVideoOutputID initMonitorID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_ZoomOut
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut | [static]
GeViAct_ZoomOut(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSelectCharMode
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode | [static]
GeViAct_CameraSelectCharMode(GeViVideoInputID initVideoInput, Int32 initMode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_IrisStop
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop | [static]
GeViAct_IrisStop(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_VideoThresholdRequest
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest |
aInternal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest |
aInternal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest | [static]
GeViAct_VideoThresholdRequest(GeViClientID initClient, Int32 initInternal1, Int64 initInternal2, Int32 initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSpecVFuncOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff | [static]
GeViAct_CameraSpecVFuncOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTourStop
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop | [static]
GeViAct_CameraTourStop(GeViVideoInputID initCameraID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTextOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff | [static]
GeViAct_CameraTextOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_IrisOpen
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen | [static]
GeViAct_IrisOpen(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_PanLeft
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft | [static]
GeViAct_PanLeft(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSmearAndWashOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn | [static]
GeViAct_CameraSmearAndWashOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_FastetModeOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn | [static]
GeViAct_FastetModeOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_PrePosClear
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear | [static]
GeViAct_PrePosClear(GeViVideoInputID initVideoInput, Int32 initPosition) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_IrisClose
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose | [static]
GeViAct_IrisClose(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSpec1FuncOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn | [static]
GeViAct_CameraSpec1FuncOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraManualIrisOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff | [static]
GeViAct_CameraManualIrisOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_MBegLockCamera
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera | [static]
GeViAct_MBegLockCamera(GeViClientID initClient, GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTourNext
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext | [static]
GeViAct_CameraTourNext(GeViVideoInputID initCameraID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraPumpOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff | [static]
GeViAct_CameraPumpOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTourPrev
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCameraID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev | [static]
GeViAct_CameraTourPrev(GeViVideoInputID initCameraID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraRAWOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aRAWData | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput | [static]
GeViAct_CameraRAWOutput(GeViVideoInputID initVideoInput, String^ initRAWData) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn | [static]
GeViAct_CameraOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_NormalModeOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn | [static]
GeViAct_NormalModeOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_ZoomIn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTemp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn | [static]
GeViAct_ZoomIn(GeViVideoInputID initVideoInput, Int32 initTemp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSetPrePosText
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText | [static]
GeViAct_CameraSetPrePosText(GeViVideoInputID initVideoInput, String^ initText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraCycleStop
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMonitorID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop | [static]
GeViAct_CameraCycleStop(GeViVideoOutputID initMonitorID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraVerOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff | [static]
GeViAct_CameraVerOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraLightOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn | [static]
GeViAct_CameraLightOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraSpecVFuncOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn | [static]
GeViAct_CameraSpecVFuncOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraLightOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff | [static]
GeViAct_CameraLightOff(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff | [virtual]
Generated on Fri Dec 9 2011 11:16:01 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • CameraControlActions
  • GeViAct_CameraTextOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn | [static]
GeViAct_CameraTextOn(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ContactBusActions
  • GeViAct_InputContactSabotage
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage | [static]
GeViAct_InputContactSabotage(Int32 initGlobalContactID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ContactBusActions
  • GeViAct_InputContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aChangedTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact |
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact | [static]
GeViAct_InputContact(Int32 initGlobalContactID, Boolean initChangedTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ContactBusActions
  • GeViAct_CloseContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact | [static]
GeViAct_CloseContact(Int32 initGlobalContactID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ContactBusActions
  • GeViAct_AlternateContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aBlinkOnTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact |
aBlinkPeriod | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact |
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact | [static]
GeViAct_AlternateContact(Int32 initGlobalContactID, Int32 initBlinkPeriod, Int32 initBlinkOnTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • ContactBusActions
  • GeViAct_OpenContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aGlobalContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact | [static]
GeViAct_OpenContact(Int32 initGlobalContactID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DBIHelperFunctions
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions, including all inherited members.
EncodePassword(String^ passwordStr) GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions [static]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseActions
  • GeViAct_DataBaseReady
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady | [static]
GeViAct_DataBaseReady() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseActions
  • GeViAct_DataBaseMissing
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing | [static]
GeViAct_DataBaseMissing() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseActions
  • GeViAct_DataBaseFailure
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure | [static]
GeViAct_DataBaseFailure() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_ActionEntry
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry | [static]
GeViDBA_ActionEntry(Int64 initPK, GeViTGeViDateTime initLocalTime, GeViTGeViDateTime initGMTTime, GeViActionData initActionData, String^ initClientName, String^ initClientDesc, String^ initActionText, Int32 initAlarmRelation, Int64 initAlarmReference) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActionData | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sActionText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sAlarmReference | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sAlarmRelation | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sClientDesc | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sGMTTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sLocalTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
sPK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_Nothing
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing | [static]
GeViDBA_Nothing() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_DBOk
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk | [static]
GeViDBA_DBOk() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_DBTerminated
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated | [static]
GeViDBA_DBTerminated() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_AccessDenied
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied | [static]
GeViDBA_AccessDenied() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_DeletedEntries
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries | [static]
GeViDBA_DeletedEntries(Int32 initDeletedActions, Int32 initDeletedAlarms) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sDeletedActions | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries |
sDeletedAlarms | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_AlarmEntry
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry | [static]
GeViDBA_AlarmEntry(Int64 initPK, GeViTGeViDateTime initLocalTime, GeViTGeViDateTime initGMTTime, Int32 initAlarmType, Int32 initStartMonitorGroup, Boolean initMonitorGroupChanged, Boolean initSomeMscIIEvents, Boolean initAcknowledged, Boolean initQuitted, String^ initAlarmText, String^ initAlarmTypeName, String^ initAlarmTypeDesc, String^ initStartMonitorGroupName, String^ initStartMonitorGroupDesc) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAcknowledged | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sAlarmText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sAlarmTypeDesc | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sAlarmTypeName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sGMTTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sLocalTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sMonitorGroupChanged | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sPK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sQuitted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sSomeMscIIEvents | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sStartMonitorGroup | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sStartMonitorGroupDesc | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
sStartMonitorGroupName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_QueryHandle
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle | [static]
GeViDBA_QueryHandle(Int64 initHandle) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseAnswers
  • GeViDBA_DBError
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeDBAnswer(CDataBaseAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError | [static]
GeViDBA_DBError(Int32 initErrorCode, String^ initErrorText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sErrorCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError |
sErrorText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_TypeID
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_TypeID(Int64 initHandle, Int32 initUp, Int32 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID |
sTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID |
sUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_StartMonitorGroupDesc
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_StartMonitorGroupDesc(Int64 initHandle, String^ initMGDesc, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc |
sMGDesc | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_CreateDeleteAlarmsHandle
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle | [static]
GeViDBQ_CreateDeleteAlarmsHandle() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_DeleteAll
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll | [static]
GeViDBQ_DeleteAll(Int64 initHandle) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_ActionKind
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_ActionKind(Int64 initHandle, Int32 initUp, Int32 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind |
sTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind |
sUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_SenderName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_SenderName(Int64 initHandle, String^ initClientName, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName |
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_GetNext
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext | [static]
GeViDBQ_GetNext(Int64 initHandle, Int64 initBasePK) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sBasePK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_MonitorGroupID
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_MonitorGroupID(Int64 initHandle, Int32 initUp, Int32 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID |
sTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID |
sUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_GscSystem
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_GscSystem(Int64 initHandle, String^ initGscName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sGscName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_AbortQuery
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery | [static]
GeViDBQ_AbortQuery(Int64 initHandle) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_CreateActionQuery
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery | [static]
GeViDBQ_CreateActionQuery(Int64 initPKAlarm) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sPKAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_TypeDesc
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_TypeDesc(Int64 initHandle, String^ initTypeDesc, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc |
sTypeDesc | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_LocalTime_GrtEqu
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_LocalTime_GrtEqu(Int64 initHandle, GeViTGeViDateTime initLocalTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu |
sLocalTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_PK_GrtEqu
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_PK_GrtEqu(Int64 initHandle, Int64 initPK) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu |
sPK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_TypeName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_TypeName(Int64 initHandle, String^ initTypeName, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName |
sTypeName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_WithQuit
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_WithQuit(Int64 initHandle, Boolean initWith) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit |
sWith | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_MonitorGroupName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_MonitorGroupName(Int64 initHandle, String^ initMGName, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName |
sMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_StartMonitorGroupName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_StartMonitorGroupName(Int64 initHandle, String^ initMGName, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName |
sMGName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_Text
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_Text(Int64 initHandle, String^ initText, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text |
sText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_Get
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get | [static]
GeViDBQ_Get(Int64 initHandle, Int64 initPK) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get |
sPK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_MonitorGroupDesc
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_MonitorGroupDesc(Int64 initHandle, String^ initMGDesc, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc |
sMGDesc | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_CloseQuery
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery | [static]
GeViDBQ_CloseQuery(Int64 initHandle) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_GetLast
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast | [static]
GeViDBQ_GetLast(Int64 initHandle) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_WithAck
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_WithAck(Int64 initHandle, Boolean initWith) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck |
sWith | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_GetPrev
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev | [static]
GeViDBQ_GetPrev(Int64 initHandle, Int64 initBasePK) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sBasePK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_SenderDesc
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_SenderDesc(Int64 initHandle, String^ initClientDesc, GeViDBCompare initCompare) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sClientDesc | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc |
sCompare | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_CreateDeleteActionsHandle
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle | [static]
GeViDBQ_CreateDeleteActionsHandle() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_LocalTime_LowEqu
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_LocalTime_LowEqu(Int64 initHandle, GeViTGeViDateTime initLocalTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu |
sLocalTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_WithMscIIRelation
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_WithMscIIRelation(Int64 initHandle, Boolean initWith) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation |
sWith | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_MscSystem
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_MscSystem(Int64 initHandle, String^ initMscName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem |
sMscName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_StartMonitorGroupID
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_StartMonitorGroupID(Int64 initHandle, Int32 initUp, Int32 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID |
sTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID |
sUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_ActionList
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_ActionList(Int64 initHandle, String^ initActionList) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActionList | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList |
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_SenderID
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_SenderID(Int64 initHandle, Int64 initUp, Int64 initTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID |
sTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID |
sUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_CreateAlarmQuery
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery | [static]
GeViDBQ_CreateAlarmQuery() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBQ_GetFirst
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeQuery(CDataBaseQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst | [static]
GeViDBQ_GetFirst(Int64 initHandle) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • DataBaseQueries
  • GeViDBF_PK_LowEqu
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBF_PK_LowEqu(Int64 initHandle, Int64 initPK) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu |
sPK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViAction
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction()=0 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [pure virtual]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViDBAnswer
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer, including all inherited members.
_DBAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBAnswer(GeViDBAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeQuery(CDataBaseAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction()=0 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [pure virtual]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViDBFilter
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBFilter(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction()=0 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [pure virtual]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViDBQuery
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery, including all inherited members.
_DBQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViDBQuery(GeViDBQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction()=0 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [pure virtual]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViDatabase
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase, including all inherited members.
!GeViDatabase() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
Connect() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ConnectProgress | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
Create(String^ address, String^ username, String^ plainTextPassword) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
Create(String^ address, String^ username, String^ plainTextPassword, String^ username2, String^ plainTextPassword2) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
DatabaseNotification | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
dipsosed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [private]
Disconnect() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
GeViDatabase() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
m_DBNotificationCallbackWrapper | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [private]
m_NativeDatabaseHandle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [private]
m_sendQueryTimeout | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [private]
OnConnectProgress(GeViSoftConnectProgressEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnDatabaseNotification(GeViSoftDatabaseNotificationEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnGscAction(GeViAct_GscActionEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAckAlarmByInstance(GeViAct_AckAlarmByInstanceEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAckAlarmByMG(GeViAct_AckAlarmByMGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAckAlarmByType(GeViAct_AckAlarmByTypeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAckAllAlarmsOnMG(GeViAct_AckAllAlarmsOnMGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewActionByName(GeViAct_ActionByNameEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewActionDataCorrupt(GeViAct_ActionDataCorruptEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewActivateAssignmentProfile(GeViAct_ActivateAssignmentProfileEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlarmAcked(GeViAct_AlarmAckedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlarmCopied(GeViAct_AlarmCopiedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlarmDisplayed(GeViAct_AlarmDisplayedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlarmMoved(GeViAct_AlarmMovedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlarmQuitted(GeViAct_AlarmQuittedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlarmRetriggered(GeViAct_AlarmRetriggeredEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlarmStarted(GeViAct_AlarmStartedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewAlternateContact(GeViAct_AlternateContactEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraAutoFocusOff(GeViAct_CameraAutoFocusOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraAutoFocusOn(GeViAct_CameraAutoFocusOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraClearPrePosText(GeViAct_CameraClearPrePosTextEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraCycleNext(GeViAct_CameraCycleNextEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraCyclePause(GeViAct_CameraCyclePauseEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraCyclePrev(GeViAct_CameraCyclePrevEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraCycleResume(GeViAct_CameraCycleResumeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraCycleStart(GeViAct_CameraCycleStartEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraCycleStop(GeViAct_CameraCycleStopEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraLightOff(GeViAct_CameraLightOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraLightOn(GeViAct_CameraLightOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraManualIrisOff(GeViAct_CameraManualIrisOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraManualIrisOn(GeViAct_CameraManualIrisOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraOff(GeViAct_CameraOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraOn(GeViAct_CameraOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraPumpOff(GeViAct_CameraPumpOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraPumpOn(GeViAct_CameraPumpOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraRAWOutput(GeViAct_CameraRAWOutputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSelectCharMode(GeViAct_CameraSelectCharModeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSetCameraText(GeViAct_CameraSetCameraTextEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSetPrePosText(GeViAct_CameraSetPrePosTextEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSmearAndWashOff(GeViAct_CameraSmearAndWashOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSmearAndWashOn(GeViAct_CameraSmearAndWashOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSpec1FuncOff(GeViAct_CameraSpec1FuncOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSpec1FuncOn(GeViAct_CameraSpec1FuncOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSpecUFuncOff(GeViAct_CameraSpecUFuncOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSpecUFuncOn(GeViAct_CameraSpecUFuncOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSpecVFuncOff(GeViAct_CameraSpecVFuncOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraSpecVFuncOn(GeViAct_CameraSpecVFuncOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraStopAll(GeViAct_CameraStopAllEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTextOff(GeViAct_CameraTextOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTextOn(GeViAct_CameraTextOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTourNext(GeViAct_CameraTourNextEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTourPause(GeViAct_CameraTourPauseEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTourPrev(GeViAct_CameraTourPrevEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTourResume(GeViAct_CameraTourResumeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTourStart(GeViAct_CameraTourStartEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraTourStop(GeViAct_CameraTourStopEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCameraVerOff(GeViAct_CameraVerOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewChangeRightProfile(GeViAct_ChangeRightProfileEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewClearAlarmFlagVideoInput(GeViAct_ClearAlarmFlagVideoInputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewClearAlarmFlagVideoOutput(GeViAct_ClearAlarmFlagVideoOutputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewClearVideoOutput(GeViAct_ClearVideoOutputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCloseContact(GeViAct_CloseContactEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCopyActualAlarm(GeViAct_CopyActualAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCopyAlarmByInstance(GeViAct_CopyAlarmByInstanceEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCopyCameraOnMonitor(GeViAct_CopyCameraOnMonitorEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCrossSwitch(GeViAct_CrossSwitchEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCrossSwitchWithAlarm(GeViAct_CrossSwitchWithAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewCustomAction(GeViAct_CustomActionEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewDataBaseFailure(GeViAct_DataBaseFailureEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewDataBaseMissing(GeViAct_DataBaseMissingEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewDataBaseReady(GeViAct_DataBaseReadyEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewDefaultPosCallUp(GeViAct_DefaultPosCallUpEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewDefaultPosClear(GeViAct_DefaultPosClearEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewDefaultPosSave(GeViAct_DefaultPosSaveEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewDisconnectUser(GeViAct_DisconnectUserEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewEventRelation(GeViAct_EventRelationEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewEventStarted(GeViAct_EventStartedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewEventStopped(GeViAct_EventStoppedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewFastetModeOn(GeViAct_FastetModeOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewFocusFar(GeViAct_FocusFarEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewFocusNear(GeViAct_FocusNearEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewFocusStop(GeViAct_FocusStopEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewGeviScopeServerConnected(GeViAct_GeviScopeServerConnectedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewGeviScopeServerConnectionFailed(GeViAct_GeviScopeServerConnectionFailedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewGeviScopeServerDisconnected(GeViAct_GeviScopeServerDisconnectedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewHistoricalAlarm(GeViAct_HistoricalAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewHistoricalInput(GeViAct_HistoricalInputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorCameraOutput(GeViAct_IlluminatorCameraOutputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorDimLevel(GeViAct_IlluminatorDimLevelEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorGetDimLevel(GeViAct_IlluminatorGetDimLevelEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorLightOff(GeViAct_IlluminatorLightOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorLightOn(GeViAct_IlluminatorLightOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorOff(GeViAct_IlluminatorOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorOn(GeViAct_IlluminatorOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSetDimLevel(GeViAct_IlluminatorSetDimLevelEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncUOff(GeViAct_IlluminatorSpecFuncUOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncUOn(GeViAct_IlluminatorSpecFuncUOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncVOff(GeViAct_IlluminatorSpecFuncVOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncVOn(GeViAct_IlluminatorSpecFuncVOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncXOff(GeViAct_IlluminatorSpecFuncXOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncXOn(GeViAct_IlluminatorSpecFuncXOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncYOff(GeViAct_IlluminatorSpecFuncYOffEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIlluminatorSpecFuncYOn(GeViAct_IlluminatorSpecFuncYOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewInformAllUsers(GeViAct_InformAllUsersEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewInformAllUsersMSG(GeViAct_InformAllUsersMSGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewInformUser(GeViAct_InformUserEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewInformUserMSG(GeViAct_InformUserMSGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewInputContact(GeViAct_InputContactEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewInputContactSabotage(GeViAct_InputContactSabotageEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIrisClose(GeViAct_IrisCloseEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIrisOpen(GeViAct_IrisOpenEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewIrisStop(GeViAct_IrisStopEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewLogLastAction(GeViAct_LogLastActionEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewLogMessage(GeViAct_LogMessageEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewLogMessageMSG(GeViAct_LogMessageMSGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewLogSourceAction(GeViAct_LogSourceActionEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMBegAlarmAck(GeViAct_MBegAlarmAckEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMBegAlarmQuit(GeViAct_MBegAlarmQuitEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMBegAlarmStart(GeViAct_MBegAlarmStartEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMBegInitRequest(GeViAct_MBegInitRequestEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMBegInitSeq(GeViAct_MBegInitSeqEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMBegLockCamera(GeViAct_MBegLockCameraEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMBegUnlockCamera(GeViAct_MBegUnlockCameraEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPAlarmAuxiliaryInput(GeViAct_MIPAlarmAuxiliaryInputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPAlarmCable(GeViAct_MIPAlarmCableEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPAlarmLUTamper(GeViAct_MIPAlarmLUTamperEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPAlarmPMTamper(GeViAct_MIPAlarmPMTamperEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPAlarmRMTamper(GeViAct_MIPAlarmRMTamperEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPAuxiliaryAlarmState(GeViAct_MIPAuxiliaryAlarmStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPAuxiliarySensorStatus(GeViAct_MIPAuxiliarySensorStatusEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPCableAFaultState(GeViAct_MIPCableAFaultStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPCableBFaultState(GeViAct_MIPCableBFaultStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPDisplaySegmentAlarmState(GeViAct_MIPDisplaySegmentAlarmStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPDisplaySegmentStatus(GeViAct_MIPDisplaySegmentStatusEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPLUTamperAlarmState(GeViAct_MIPLUTamperAlarmStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPLUTamperStatus(GeViAct_MIPLUTamperStatusEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPOffline(GeViAct_MIPOfflineEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPOnline(GeViAct_MIPOnlineEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPPMComFailState(GeViAct_MIPPMComFailStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPPMTamperAlarmState(GeViAct_MIPPMTamperAlarmStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPPMTamperStatus(GeViAct_MIPPMTamperStatusEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPQueryInterface(GeViAct_MIPQueryInterfaceEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPRMComFailState(GeViAct_MIPRMComFailStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPRMTamperAlarmState(GeViAct_MIPRMTamperAlarmStateEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPRMTamperStatus(GeViAct_MIPRMTamperStatusEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPSecureAuxiliarySensor(GeViAct_MIPSecureAuxiliarySensorEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPSecureAuxiliaryTP1(GeViAct_MIPSecureAuxiliaryTP1EventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPSecureAuxiliaryTP2(GeViAct_MIPSecureAuxiliaryTP2EventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPSecureDisplaySegment(GeViAct_MIPSecureDisplaySegmentEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPSecureLU(GeViAct_MIPSecureLUEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPSecurePM(GeViAct_MIPSecurePMEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPSecureRM(GeViAct_MIPSecureRMEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPTurnARelayControl(GeViAct_MIPTurnARelayControlEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMIPTurnRelaysOnOneZone(GeViAct_MIPTurnRelaysOnOneZoneEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMonitorGroupDisable(GeViAct_MonitorGroupDisableEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMonitorGroupEnable(GeViAct_MonitorGroupEnableEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMonitorGroupStatusChanged(GeViAct_MonitorGroupStatusChangedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMoveActualAlarm(GeViAct_MoveActualAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMoveAlarmByInstance(GeViAct_MoveAlarmByInstanceEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMscEventStarted(GeViAct_MscEventStartedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMscEventStopped(GeViAct_MscEventStoppedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMscServerConnected(GeViAct_MscServerConnectedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMscServerConnectFailed(GeViAct_MscServerConnectFailedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMscServerDisconnect(GeViAct_MscServerDisconnectEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMscServerDisconnected(GeViAct_MscServerDisconnectedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewMscSetupModified(GeViAct_MscSetupModifiedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewNormalModeOn(GeViAct_NormalModeOnEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewOpenContact(GeViAct_OpenContactEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPanAuto(GeViAct_PanAutoEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPanLeft(GeViAct_PanLeftEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPanRight(GeViAct_PanRightEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPanStop(GeViAct_PanStopEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPopUpAlarm(GeViAct_PopUpAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPopUpNextAlarm(GeViAct_PopUpNextAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPrePosCallUp(GeViAct_PrePosCallUpEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPrePosClear(GeViAct_PrePosClearEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewPrePosSave(GeViAct_PrePosSaveEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewQuitAlarmByInstance(GeViAct_QuitAlarmByInstanceEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewQuitAlarmByMG(GeViAct_QuitAlarmByMGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewQuitAlarmByType(GeViAct_QuitAlarmByTypeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewQuitAllAlarmsOnMG(GeViAct_QuitAllAlarmsOnMGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRedChangeMaster(GeViAct_RedChangeMasterEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRedConnectionMasterChanged(GeViAct_RedConnectionMasterChangedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRedirectResource(GeViAct_RedirectResourceEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRedMasterServerChanged(GeViAct_RedMasterServerChangedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRedRedundantLoginFailed(GeViAct_RedRedundantLoginFailedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRedRedundantUserLogin(GeViAct_RedRedundantUserLoginEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRescannRequest(GeViAct_RescannRequestEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRescannRequestToClient(GeViAct_RescannRequestToClientEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewRestoreRightProfile(GeViAct_RestoreRightProfileEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSendRawData(GeViAct_SendRawDataEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSendRawDataMSG(GeViAct_SendRawDataMSGEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStartAlarm(GeViAct_StartAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStartEvent(GeViAct_StartEventEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStartMscEvent(GeViAct_StartMscEventEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStartTimer(GeViAct_StartTimerEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStopEventByInstance(GeViAct_StopEventByInstanceEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStopEventByType(GeViAct_StopEventByTypeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStopMscEvent(GeViAct_StopMscEventEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewStopTimer(GeViAct_StopTimerEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSyncTimeRequest(GeViAct_SyncTimeRequestEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSyncTimeRequestToClient(GeViAct_SyncTimeRequestToClientEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSyncTimeSetTime(GeViAct_SyncTimeSetTimeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSyncTimeSetTimeActual(GeViAct_SyncTimeSetTimeActualEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSyncTimeSetTimeClient(GeViAct_SyncTimeSetTimeClientEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSystemError(GeViAct_SystemErrorEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSystemSettingsChanged(GeViAct_SystemSettingsChangedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSystemStarted(GeViAct_SystemStartedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSystemStopped(GeViAct_SystemStoppedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewSystemWarning(GeViAct_SystemWarningEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewTakeCameraControl(GeViAct_TakeCameraControlEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewTiltDown(GeViAct_TiltDownEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewTiltStop(GeViAct_TiltStopEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewTiltUp(GeViAct_TiltUpEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewTimeRangeEnded(GeViAct_TimeRangeEndedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewTimeRangeStarted(GeViAct_TimeRangeStartedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewUserLogin(GeViAct_UserLoginEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewUserLoginFailed(GeViAct_UserLoginFailedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewUserLogout(GeViAct_UserLogoutEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoClearTextOut(GeViAct_VideoClearTextOutEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoContrastAlarm(GeViAct_VideoContrastAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoContrastOk(GeViAct_VideoContrastOkEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoContrastPreAlarm(GeViAct_VideoContrastPreAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoSyncFailure(GeViAct_VideoSyncFailureEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoSyncOk(GeViAct_VideoSyncOkEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoTextOut(GeViAct_VideoTextOutEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoThresholdRequest(GeViAct_VideoThresholdRequestEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVideoThresholdValue(GeViAct_VideoThresholdValueEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVS30PMMode(GeViAct_VS30PMModeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVS30VMDMode(GeViAct_VS30VMDModeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSAlarmEnd(GeViAct_VSAlarmEndEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSAlarmExtern(GeViAct_VSAlarmExternEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSAlarmInField(GeViAct_VSAlarmInFieldEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSAllTestAlarm(GeViAct_VSAllTestAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSAllTimerReset(GeViAct_VSAllTimerResetEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSArmed(GeViAct_VSArmedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSChooseSavedPicture(GeViAct_VSChooseSavedPictureEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSPictureDetect(GeViAct_VSPictureDetectEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSPictureToCommonOut(GeViAct_VSPictureToCommonOutEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSPictureToOutput(GeViAct_VSPictureToOutputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSPreAlarm(GeViAct_VSPreAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSRecorderEnd(GeViAct_VSRecorderEndEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSRecorderTimerReset(GeViAct_VSRecorderTimerResetEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSSetAllArmed(GeViAct_VSSetAllArmedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSSetArmed(GeViAct_VSSetArmedEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSSetDateAndTime(GeViAct_VSSetDateAndTimeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSSetMode(GeViAct_VSSetModeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSSetSensorMode(GeViAct_VSSetSensorModeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSSetSensorOutput(GeViAct_VSSetSensorOutputEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSSyncSignalDetect(GeViAct_VSSyncSignalDetectEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSTestAlarm(GeViAct_VSTestAlarmEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSTimerReset(GeViAct_VSTimerResetEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSVMDMode(GeViAct_VSVMDModeEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVSVMDOutOfOrder(GeViAct_VSVMDOutOfOrderEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewVX3SystemReset(GeViAct_VX3SystemResetEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewZoomIn(GeViAct_ZoomInEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewZoomOut(GeViAct_ZoomOutEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
OnNewZoomStop(GeViAct_ZoomStopEventArgs^ e) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase | [protected, virtual]
ReceivedAckAlarmByInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAckAlarmByMG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAckAlarmByType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAckAllAlarmsOnMG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedActionByName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedActionDataCorrupt | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedActivateAssignmentProfile | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlarmAcked | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlarmCopied | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlarmDisplayed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlarmMoved | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlarmQuitted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlarmRetriggered | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlarmStarted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedAlternateContact | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraAutoFocusOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraAutoFocusOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraClearPrePosText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraCycleNext | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraCyclePause | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraCyclePrev | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraCycleResume | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraCycleStart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraCycleStop | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraLightOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraLightOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraManualIrisOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraManualIrisOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraPumpOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraPumpOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraRAWOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSelectCharMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSetCameraText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSetPrePosText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSmearAndWashOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSmearAndWashOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSpec1FuncOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSpec1FuncOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSpecUFuncOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSpecUFuncOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSpecVFuncOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraSpecVFuncOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraStopAll | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTextOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTextOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTourNext | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTourPause | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTourPrev | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTourResume | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTourStart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraTourStop | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCameraVerOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedChangeRightProfile | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedClearAlarmFlagVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedClearAlarmFlagVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedClearVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCloseContact | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCopyActualAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCopyAlarmByInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCopyCameraOnMonitor | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCrossSwitch | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCrossSwitchWithAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedCustomAction | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedDataBaseFailure | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedDataBaseMissing | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedDataBaseReady | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedDefaultPosCallUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedDefaultPosClear | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedDefaultPosSave | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedDisconnectUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedEventRelation | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedEventStarted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedEventStopped | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedFastetModeOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedFocusFar | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedFocusNear | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedFocusStop | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedGeviScopeServerConnected | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedGeviScopeServerConnectionFailed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedGeviScopeServerDisconnected | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedGscAction | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedHistoricalAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedHistoricalInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorCameraOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorDimLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorGetDimLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorLightOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorLightOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSetDimLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncUOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncUOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncVOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncVOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncXOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncXOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncYOff | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIlluminatorSpecFuncYOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedInformAllUsers | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedInformAllUsersMSG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedInformUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedInformUserMSG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedInputContact | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedInputContactSabotage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIrisClose | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIrisOpen | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedIrisStop | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedLogLastAction | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedLogMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedLogMessageMSG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedLogSourceAction | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMBegAlarmAck | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMBegAlarmQuit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMBegAlarmStart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMBegInitRequest | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMBegInitSeq | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMBegLockCamera | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMBegUnlockCamera | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPAlarmAuxiliaryInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPAlarmCable | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPAlarmLUTamper | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPAlarmPMTamper | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPAlarmRMTamper | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPAuxiliaryAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPAuxiliarySensorStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPCableAFaultState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPCableBFaultState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPDisplaySegmentAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPDisplaySegmentStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPLUTamperAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPLUTamperStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPOffline | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPOnline | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPPMComFailState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPPMTamperAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPPMTamperStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPQueryInterface | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPRMComFailState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPRMTamperAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPRMTamperStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPSecureAuxiliarySensor | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPSecureAuxiliaryTP1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPSecureAuxiliaryTP2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPSecureDisplaySegment | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPSecureLU | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPSecurePM | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPSecureRM | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPTurnARelayControl | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMIPTurnRelaysOnOneZone | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMonitorGroupDisable | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMonitorGroupEnable | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMonitorGroupStatusChanged | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMoveActualAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMoveAlarmByInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMscEventStarted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMscEventStopped | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMscServerConnected | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMscServerConnectFailed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMscServerDisconnect | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMscServerDisconnected | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedMscSetupModified | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedNormalModeOn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedOpenContact | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPanAuto | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPanLeft | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPanRight | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPanStop | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPopUpAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPopUpNextAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPrePosCallUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPrePosClear | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedPrePosSave | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedQuitAlarmByInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedQuitAlarmByMG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedQuitAlarmByType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedQuitAllAlarmsOnMG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRedChangeMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRedConnectionMasterChanged | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRedirectResource | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRedMasterServerChanged | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRedRedundantLoginFailed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRedRedundantUserLogin | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRescannRequest | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRescannRequestToClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedRestoreRightProfile | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSendRawData | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSendRawDataMSG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStartAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStartEvent | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStartMscEvent | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStartTimer | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStopEventByInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStopEventByType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStopMscEvent | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedStopTimer | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSyncTimeRequest | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSyncTimeRequestToClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSyncTimeSetTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSyncTimeSetTimeActual | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSyncTimeSetTimeClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSystemError | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSystemSettingsChanged | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSystemStarted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSystemStopped | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedSystemWarning | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedTakeCameraControl | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedTiltDown | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedTiltStop | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedTiltUp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedTimeRangeEnded | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedTimeRangeStarted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedUserLogin | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedUserLoginFailed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedUserLogout | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoClearTextOut | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoContrastAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoContrastOk | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoContrastPreAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoSyncFailure | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoSyncOk | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoTextOut | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoThresholdRequest | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVideoThresholdValue | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVS30PMMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVS30VMDMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSAlarmEnd | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSAlarmExtern | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSAlarmInField | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSAllTestAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSAllTimerReset | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSChooseSavedPicture | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSPictureDetect | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSPictureToCommonOut | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSPictureToOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSPreAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSRecorderEnd | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSRecorderTimerReset | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSSetAllArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSSetArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSSetDateAndTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSSetMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSSetSensorMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSSetSensorOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSSyncSignalDetect | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSTestAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSTimerReset | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSVMDMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVSVMDOutOfOrder | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedVX3SystemReset | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedZoomIn | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedZoomOut | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
ReceivedZoomStop | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
RegisterCallback() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
SendMessage(String^ message) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
SendMessage(GeViMessage^ message) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
SendMessage(String^ gscServerName, GscAction^ gscAct) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
SendPing() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
SendQuery(GeViMessage^ message,[Out] GeViMessage^ %answer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
SetQueryTimeoutInMs(int timeout) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
~GeViDatabase() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViMessage
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction()=0 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [pure virtual]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViSoftConnectProgressEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs, including all inherited members.
Effort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs |
GeViSoftConnectProgressEventArgs(Int32 progress, Int32 effort) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs |
m_Effort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs | [private]
m_Progress | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs | [private]
Progress | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViSoftDatabaseNotificationEventArgs
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs, including all inherited members.
GeViSoftDatabaseNotificationEventArgs(GeViServerNotification notification, IntPtr params) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs |
m_params | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs | [private]
m_ServerNotification | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs | [private]
Params | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs |
ServerNotificationType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViStateAnswer
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction()=0 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [pure virtual]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViStateQuery
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction()=0 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [pure virtual]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeviScopeActions
  • GeViAct_GeviScopeServerConnected
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aGscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected | [static]
GeViAct_GeviScopeServerConnected(String^ initGscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeviScopeActions
  • GeViAct_GeviScopeServerDisconnected
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aGscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected | [static]
GeViAct_GeviScopeServerDisconnected(String^ initGscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeviScopeActions
  • GeViAct_GeviScopeServerConnectionFailed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aGscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed | [static]
GeViAct_GeviScopeServerConnectionFailed(String^ initGscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncUOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff | [static]
GeViAct_IlluminatorSpecFuncUOff(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff | [static]
GeViAct_IlluminatorOff(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorLightOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn | [static]
GeViAct_IlluminatorLightOn(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncVOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn | [static]
GeViAct_IlluminatorSpecFuncVOn(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncXOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn | [static]
GeViAct_IlluminatorSpecFuncXOn(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncYOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff | [static]
GeViAct_IlluminatorSpecFuncYOff(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncUOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn | [static]
GeViAct_IlluminatorSpecFuncUOn(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSetDimLevel
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel |
aLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel | [static]
GeViAct_IlluminatorSetDimLevel(GeViVideoInputID initIlluminator, Int32 initLevel) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorGetDimLevel
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel | [static]
GeViAct_IlluminatorGetDimLevel(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn | [static]
GeViAct_IlluminatorOn(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorCameraOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCommand | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput | [static]
GeViAct_IlluminatorCameraOutput(GeViVideoInputID initIlluminator, String^ initCommand) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorLightOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff | [static]
GeViAct_IlluminatorLightOff(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncXOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff | [static]
GeViAct_IlluminatorSpecFuncXOff(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncYOn
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn | [static]
GeViAct_IlluminatorSpecFuncYOn(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorSpecFuncVOff
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff | [static]
GeViAct_IlluminatorSpecFuncVOff(GeViVideoInputID initIlluminator) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • IlluminatorActions
  • GeViAct_IlluminatorDimLevel
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIlluminator | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel |
aLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel | [static]
GeViAct_IlluminatorDimLevel(GeViVideoInputID initIlluminator, Int32 initLevel) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPAlarmLUTamper
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper | [static]
GeViAct_MIPAlarmLUTamper(Int32 initInterfaceID, Int32 initUnit) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPSecureLU
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU | [static]
GeViAct_MIPSecureLU(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPAlarmCable
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCable | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable |
aLocation | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable | [static]
GeViAct_MIPAlarmCable(Int32 initInterfaceID, Int32 initUnit, Int32 initCable, Int32 initLocation) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPDisplaySegmentStatus
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus | [static]
GeViAct_MIPDisplaySegmentStatus(Int32 initInterfaceID, Int32 initUnit, Int32 initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPSecureDisplaySegment
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment | [static]
GeViAct_MIPSecureDisplaySegment(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPAlarmPMTamper
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper | [static]
GeViAct_MIPAlarmPMTamper(Int32 initInterfaceID, Int32 initUnit) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPSecurePM
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM | [static]
GeViAct_MIPSecurePM(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPPMTamperStatus
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus | [static]
GeViAct_MIPPMTamperStatus(Int32 initInterfaceID, Int32 initUnit, Int32 initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPLUTamperAlarmState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState | [static]
GeViAct_MIPLUTamperAlarmState(Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPRMTamperAlarmState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState | [static]
GeViAct_MIPRMTamperAlarmState(Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPTurnRelaysOnOneZone
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone | [static]
GeViAct_MIPTurnRelaysOnOneZone(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPSecureAuxiliaryTP1
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 | [static]
GeViAct_MIPSecureAuxiliaryTP1(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1 | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPDisplaySegmentAlarmState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState | [static]
GeViAct_MIPDisplaySegmentAlarmState(Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPAuxiliaryAlarmState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState |
aUnitType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState | [static]
GeViAct_MIPAuxiliaryAlarmState(Int32 initInterfaceID, Int32 initUnit, Int32 initUnitType, Int32 initAlarmState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPAuxiliarySensorStatus
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus |
aUnitType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus | [static]
GeViAct_MIPAuxiliarySensorStatus(Int32 initInterfaceID, Int32 initUnit, Int32 initUnitType, Int32 initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPSecureAuxiliarySensor
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor | [static]
GeViAct_MIPSecureAuxiliarySensor(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPAlarmAuxiliaryInput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput |
aLocation | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput |
aUnitType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput | [static]
GeViAct_MIPAlarmAuxiliaryInput(Int32 initInterfaceID, Int32 initUnit, Int32 initUnitType, Int32 initLocation) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPPMTamperAlarmState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState | [static]
GeViAct_MIPPMTamperAlarmState(Int32 initInterfaceID, Int32 initUnit, Int32 initAlarmState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPLUTamperStatus
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus | [static]
GeViAct_MIPLUTamperStatus(Int32 initInterfaceID, Int32 initUnit, Int32 initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPPMComFailState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState | [static]
GeViAct_MIPPMComFailState(Int32 initInterfaceID, Int32 initUnit, Int32 initState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPCableAFaultState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState | [static]
GeViAct_MIPCableAFaultState(Int32 initInterfaceID, Int32 initUnit, Int32 initState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPRMComFailState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState | [static]
GeViAct_MIPRMComFailState(Int32 initInterfaceID, Int32 initUnit, Int32 initState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPOnline
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline | [static]
GeViAct_MIPOnline(Int32 initInterfaceID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPTurnARelayControl
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl | [static]
GeViAct_MIPTurnARelayControl(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPSecureRM
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM | [static]
GeViAct_MIPSecureRM(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPQueryInterface
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface | [static]
GeViAct_MIPQueryInterface(Int32 initInterfaceID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPSecureAuxiliaryTP2
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 | [static]
GeViAct_MIPSecureAuxiliaryTP2(Int32 initInterfaceID, Int32 initUnit, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2 | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPAlarmRMTamper
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper | [static]
GeViAct_MIPAlarmRMTamper(Int32 initInterfaceID, Int32 initUnit) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPCableBFaultState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState |
aState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState | [static]
GeViAct_MIPCableBFaultState(Int32 initInterfaceID, Int32 initUnit, Int32 initState) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPRMTamperStatus
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus |
aUnit | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus | [static]
GeViAct_MIPRMTamperStatus(Int32 initInterfaceID, Int32 initUnit, Int32 initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MIPActions
  • GeViAct_MIPOffline
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInterfaceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline | [static]
GeViAct_MIPOffline(Int32 initInterfaceID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline | [virtual]
Generated on Fri Dec 9 2011 11:16:02 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_MscServerConnectFailed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed | [static]
GeViAct_MscServerConnectFailed(Int32 initMscServerID, String^ initMscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_MscEventStopped
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
aMscEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
aMscEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
aMscMessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped | [static]
GeViAct_MscEventStopped(Int32 initMscServerID, String^ initMscServerName, GeViGUID initMscDBGUID, GeViMscEventID initMscEventID, GeViMscEventTypeID initMscEventTypeID, Int32 initMscEventRef, String^ initMscEventName, Int32 initMscMessageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_StopMscEvent
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aIgnoreRefs | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent | [static]
GeViAct_StopMscEvent(Int32 initMscServerID, String^ initMscServerName, Int32 initMscEventRef, String^ initMscEventName, Boolean initIgnoreRefs) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_MscServerDisconnect
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect | [static]
GeViAct_MscServerDisconnect(Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_MscServerDisconnected
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected | [static]
GeViAct_MscServerDisconnected(Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_MscServerConnected
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected | [static]
GeViAct_MscServerConnected(Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_StartMscEvent
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscBlob | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
aMscInt1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
aMscInt2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
aMscStartKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent | [static]
GeViAct_StartMscEvent(Int32 initMscServerID, String^ initMscServerName, Int32 initMscEventRef, String^ initMscEventName, Int32 initMscStartKind, Int64 initMscInt1, Int64 initMscInt2, String^ initMscBlob) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_MscEventStarted
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
aMscEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
aMscEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
aMscEventRef | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
aMscEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
aMscMessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted | [static]
GeViAct_MscEventStarted(Int32 initMscServerID, String^ initMscServerName, GeViGUID initMscDBGUID, GeViMscEventID initMscEventID, GeViMscEventTypeID initMscEventTypeID, Int32 initMscEventRef, String^ initMscEventName, Int32 initMscMessageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • MscIIActions
  • GeViAct_MscSetupModified
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMscDBGUID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified |
aMscServerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified |
aMscServerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified | [static]
GeViAct_MscSetupModified(Int32 initMscServerID, GeViGUID initMscDBGUID, String^ initMscServerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_AlarmInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_AlarmInfo(Int32 initGlobalID, String^ initName, String^ initDescription, Int64 initInstanceID, Boolean initStarted, Boolean initAcked, Int32 initPresentedOnCount, Int32 initFirstMG, Boolean initDisplayedOnFirstMG) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAcked | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sDescription | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sDisplayedOnFirstMG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sFirstMG | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sGlobalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sInstanceID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sPresentedOnCount | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
sStarted | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_CommandOk
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_CommandOk() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_Nothing
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_Nothing() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_SyncState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_SyncState(Boolean initSyncOK) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sSyncOK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_Terminated
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_Terminated() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_LicenseValue
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_LicenseValue(String^ initLicName, Int32 initLicValue) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sLicName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue |
sLicValue | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_LicenseTransferData
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_LicenseTransferData(Int32 initVal1, Int32 initVal2, String^ initVal3) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sVal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData |
sVal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData |
sVal3 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_ThresholdInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_ThresholdInfo(Int32 initVideoInput, Int32 initThreshold, Int32 initMinThreshold, Int32 initAVGThreshold, Int32 initSecondsSinceStart, Int32 initNumberOfMeasures) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAVGThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo |
sMinThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo |
sNumberOfMeasures | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo |
sSecondsSinceStart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo |
sThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo |
sVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_OutputContactInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_OutputContactInfo(GeViOutputContactID initGlobalID, Int32 initSegment, GeViOutputContactID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Boolean initAccessible, Int32 initState, Int32 initPeriod, GeViTGeViDateTime initTriggerTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAccessible | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sActive | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sDescription | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sEnabled | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sGlobalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sLocalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sPeriod | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sSegment | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
sTriggerTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_ClientInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_ClientInfo(GeViClientID initClientID, String^ initClientName, String^ initClientFullName, String^ initClientDescription, Int32 initClientType, Int32 initInterfaceType, Boolean initCorrupt, Int32 initLoginCount, Int32 initAccessRights) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAccessRights | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sClientDescription | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sClientFullName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sClientType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sCorrupt | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sInterfaceType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
sLoginCount | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_UnknownCommand
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_UnknownCommand() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_PTZHeadInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_PTZHeadInfo(GeViClientID initClientID, Int32 initLocalID, Boolean initActive, Int32 initActualPosition, Int32 initActualTour, Int32 initDefaultTour, Int32 initPan, Int32 initTilt, Boolean initAutoPan, Boolean initAccessible) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAccessible | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sActive | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sActualPosition | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sActualTour | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sAutoPan | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sDefaultTour | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sLocalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sPan | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
sTilt | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_MonitorGroupInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_MonitorGroupInfo(Int32 initGlobalID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Int32 initPresentedAlarms, Int32 initAllAlarms) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActive | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
sAllAlarms | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
sDescription | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
sEnabled | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
sGlobalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
sPresentedAlarms | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_VideoSensorInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_VideoSensorInfo(GeViClientID initClientID, Int32 initLocalID, Boolean initActive, Boolean initArmed, Boolean initHasAlarm, Boolean initHasPreAlarm, Int32 initAlarmField, Byte initAlarmTime, Boolean initSyncOK, Boolean initContrastOK, Boolean initAccessible) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAccessible | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sActive | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sAlarmField | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sAlarmTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sContrastOK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sHasAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sHasPreAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sLocalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
sSyncOK | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_CommandFailed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_CommandFailed() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_InfoServerStartTime
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_InfoServerStartTime(GeViTGeViDateTime initStartTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sStartTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_VideoInputInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_VideoInputInfo(GeViVideoInputID initGlobalID, GeViVideoInputID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Boolean initAccessible, Boolean initHasPTZHead, Boolean initHasVideoSensor, Boolean initHasContrastDetection, Boolean initHasSyncDetection, Int32 initAlarmCounter) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAccessible | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sActive | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sAlarmCounter | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sDescription | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sEnabled | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sGlobalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sHasContrastDetection | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sHasPTZHead | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sHasSyncDetection | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sHasVideoSensor | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sLocalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_ContrastState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_ContrastState(Boolean initContrastAlarm, Boolean initContrastPreAlarm, Int32 initAlarmThreshold, Int32 initPreAlarmThreshold, Int32 initLastThreshold) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAlarmThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState |
sContrastAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState |
sContrastPreAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState |
sLastThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState |
sPreAlarmThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_InputContactInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_InputContactInfo(GeViInputContactID initGlobalID, Int32 initSegment, GeViInputContactID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Int32 initState, GeViTGeViDateTime initTriggerTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActive | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sDescription | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sEnabled | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sGlobalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sLocalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sSegment | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sState | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
sTriggerTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_LicenseInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_LicenseInfo(Int32 initLicVersion, Boolean initDongleDllFound, Boolean initDongleKeyFound, String^ initLicString) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sDongleDllFound | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo |
sDongleKeyFound | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo |
sLicString | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo |
sLicVersion | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_VideoOutputInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_VideoOutputInfo(GeViVideoOutputID initGlobalID, GeViVideoOutputID initLocalID, GeViClientID initClientID, String^ initName, String^ initDescription, Boolean initActive, Boolean initEnabled, Boolean initAccessible, GeViVideoInputID initActualCamera, Int32 initActualCycle, Boolean initHasAlarm) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sAccessible | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sActive | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sActualCamera | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sActualCycle | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sDescription | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sEnabled | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sGlobalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sHasAlarm | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sLocalID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_UnsufficientRights
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_UnsufficientRights() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_AlarmOnMGInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_AlarmOnMGInfo(GeViMGID initMGID, Boolean initContained, Boolean initVisible) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sContained | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo |
sMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo |
sVisible | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_InfoDatabaseCreationTime
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_InfoDatabaseCreationTime(GeViTGeViDateTime initStartTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sStartTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_LicenseCall
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_LicenseCall(Int32 initVal1, Int32 initVal2, Int32 initVal3, Int32 initVal4) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sVal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall |
sVal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall |
sVal3 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall |
sVal4 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateAnswers
  • GeViSA_ClientLoginInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateAnswerKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer |
FromNativeStateAnswer(CStateAnswer *nativeStateAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSA_ClientLoginInfo(GeViTGeViPort initPort, String^ initIP, String^ initSecondUser) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo |
GeViStateAnswer(GeViStateAnswerKind answerKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [protected]
InternalFromNativeQuery(CStateAnswer *nativeAnswer) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer | [static]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sIP | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo |
sPort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo |
sSecondUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetAlarms
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetAlarms(Int32 initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetClient(GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetInputContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetInputContact(GeViInputContactID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstOutputContactOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstOutputContactOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_LicensePrepareCall
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_LicensePrepareCall(Int32 initVal1, Int32 initVal2, Int32 initVal3, Int32 initVal4) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sVal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall |
sVal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall |
sVal3 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall |
sVal4 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextInputContactOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextInputContactOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViInputContactID initPrevID, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetOutputContactByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetOutputContactByName(String^ initName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstInputContactOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstInputContactOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetAlarmOnMGInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetAlarmOnMGInfo(Int32 initResID, Int32 initMGID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sMGID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo |
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetContrastState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetContrastState(GeViVideoInputID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetInfoServerStartTime
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetInfoServerStartTime() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextVideoOutputOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextVideoOutputOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoOutputID initPrevID, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetThresholdValue
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetThresholdValue(GeViClientID initClient, Int32 initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sClient | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue |
sVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextOutputContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextOutputContact(Boolean initActiveOnly, Boolean initEnabledOnly, GeViOutputContactID initPrevID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetLicenseInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetLicenseInfo(Int32 initLicVersion) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sLicVersion | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextVideoInput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextVideoInput(Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoInputID initPrevID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetVideoInputByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetVideoInputByName(String^ initName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextInputContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextInputContact(Boolean initActiveOnly, Boolean initEnabledOnly, GeViInputContactID initPrevID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetClientByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetClientByName(String^ initName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetLicenseValue
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetLicenseValue(String^ initLicName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sLicName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstAlarm(Boolean initActiveOnly, Boolean initEnabledOnly) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextOutputContactOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextOutputContactOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViOutputContactID initPrevID, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstVideoInput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstVideoInput(Boolean initActiveOnly, Boolean initEnabledOnly) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_LicenseCall
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_LicenseCall() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextClient(Boolean initActiveOnly, GeViClientID initPrevID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextAlarm(Boolean initActiveOnly, Boolean initEnabledOnly, Int32 initPrevID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstClientOfType
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstClientOfType(Boolean initActiveOnly, Int32 initSQClientType) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType |
sSQClientType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetInputContactByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetInputContactByName(String^ initName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetOutputContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetOutputContact(GeViOutputContactID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetVideoOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetVideoOutput(GeViVideoOutputID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetVideoSensorInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetVideoSensorInfo(GeViVideoInputID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstClient(Boolean initActiveOnly) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetPTZHeadInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetPTZHeadInfo(GeViVideoInputID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextVideoOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextVideoOutput(Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoOutputID initPrevID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstInputContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstInputContact(Boolean initActiveOnly, Boolean initEnabledOnly) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetInfoDatabaseCreationTime
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetInfoDatabaseCreationTime() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetSyncState
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetSyncState(GeViVideoInputID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstVideoInputOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstVideoInputOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextMonitorGroup
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextMonitorGroup(Boolean initActiveOnly, Boolean initEnabledOnly, Int32 initPrevID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextClientOfType
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextClientOfType(Boolean initActiveOnly, GeViClientID initPrevID, Int32 initSQClientType) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType |
sSQClientType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstOutputContact
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstOutputContact(Boolean initActiveOnly, Boolean initEnabledOnly) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstMonitorGroup
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstMonitorGroup(Boolean initActiveOnly, Boolean initEnabledOnly) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetVideoOutputByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetVideoOutputByName(String^ initName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetLoginInfo
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetLoginInfo(GeViClientID initClientID, Int32 initEntryNumber) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo |
sEntryNumber | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetAlarmsByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetAlarmsByName(String^ initName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstVideoOutputOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstVideoOutputOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetMonitorGroupByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetMonitorGroupByName(String^ initName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetVideoInput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetVideoInput(GeViVideoInputID initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetAlarmOnMGByIndex
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetAlarmOnMGByIndex(Int32 initResID, Int32 initIndex) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sIndex | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex |
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetMonitorGroup
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetMonitorGroup(Int32 initResID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sResID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetFirstVideoOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetFirstVideoOutput(Boolean initActiveOnly, Boolean initEnabledOnly) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_LicenseTransferData
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_LicenseTransferData(Int32 initVal1, Int32 initVal2, String^ initVal3) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sVal1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData |
sVal2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData |
sVal3 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • StateQueries
  • GeViSQ_GetNextVideoInputOfClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient, including all inherited members.
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_StateQueryKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery |
FromNativeQuery(CStateQuery *nativeQuery) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient | [static]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
GeViSQ_GetNextVideoInputOfClient(Boolean initActiveOnly, Boolean initEnabledOnly, GeViVideoInputID initPrevID, GeViClientID initClientID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient |
GeViStateQuery(GeViStateQueryKind queryKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery | [protected]
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
sActiveOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient |
sClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient |
sEnabledOnly | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient |
sPrevID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient |
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_CrossSwitchWithAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm | [static]
GeViAct_CrossSwitchWithAlarm(GeViVideoInputID initVideoInput, GeViVideoOutputID initVideoOutput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_CopyCameraOnMonitor
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoOutputFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor |
aVideoOutputTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor | [static]
GeViAct_CopyCameraOnMonitor(GeViVideoOutputID initVideoOutputFrom, GeViVideoOutputID initVideoOutputTo) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_ClearAlarmFlagVideoOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput | [static]
GeViAct_ClearAlarmFlagVideoOutput(GeViVideoOutputID initVideoOutput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VX3SystemReset
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset | [static]
GeViAct_VX3SystemReset(GeViClientID initClientID, String^ initClientName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_ClearAlarmFlagVideoInput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput | [static]
GeViAct_ClearAlarmFlagVideoInput(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VideoContrastOk
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk | [static]
GeViAct_VideoContrastOk(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VideoClearTextOut
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut | [static]
GeViAct_VideoClearTextOut(GeViVideoOutputID initVideoOutput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VideoSyncFailure
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure | [static]
GeViAct_VideoSyncFailure(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VideoContrastAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm | [static]
GeViAct_VideoContrastAlarm(GeViVideoInputID initVideoInput, Int32 initThreshold) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_ClearVideoOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput | [static]
GeViAct_ClearVideoOutput(GeViVideoOutputID initVideoOutput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VideoTextOut
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut | [static]
GeViAct_VideoTextOut(GeViVideoOutputID initVideoOutput, String^ initText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VideoContrastPreAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aThreshold | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm | [static]
GeViAct_VideoContrastPreAlarm(GeViVideoInputID initVideoInput, Int32 initThreshold) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_VideoSyncOk
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk | [static]
GeViAct_VideoSyncOk(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SwitchControlActions
  • GeViAct_CrossSwitch
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aSwitchMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch |
aVideoOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch | [static]
GeViAct_CrossSwitch(GeViVideoInputID initVideoInput, GeViVideoOutputID initVideoOutput, GeViTSwitchMode initSwitchMode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_HistoricalAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm |
aAlarmTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm |
aTimeStamp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm | [static]
GeViAct_HistoricalAlarm(GeViAlarmTypeID initAlarmTypeID, String^ initAlarmType, GeViTGeViDateTime initTimeStamp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_ActivateAssignmentProfile
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aProfileID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile |
aProfileName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile | [static]
GeViAct_ActivateAssignmentProfile(Int32 initProfileID, String^ initProfileName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_StopTimer
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTimerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer |
aTimerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer | [static]
GeViAct_StopTimer(Int32 initTimerID, String^ initTimerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RedMasterServerChanged
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aNewMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged |
aOldMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged | [static]
GeViAct_RedMasterServerChanged(String^ initNewMaster, String^ initOldMaster) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_LogMessage
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage |
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage |
aLogText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage | [static]
GeViAct_LogMessage(GeViClientID initClientID, Int32 initConsole, String^ initLogText, GeViAlarmID initAlarmID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_ChangeRightProfile
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aProfileID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile |
aProfileName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile |
aUserName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile | [static]
GeViAct_ChangeRightProfile(GeViClientID initUserID, String^ initUserName, Int32 initProfileID, String^ initProfileName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_CustomAction
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aCustomInt | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction |
aCustomText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction | [static]
GeViAct_CustomAction(Int32 initCustomInt, String^ initCustomText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_StartTimer
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aTimerID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer |
aTimerName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer | [static]
GeViAct_StartTimer(Int32 initTimerID, String^ initTimerName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_LogMessageMSG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAlarmID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG |
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG | [static]
GeViAct_LogMessageMSG(GeViClientID initClientID, Int32 initConsole, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal, GeViAlarmID initAlarmID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_ActionDataCorrupt
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt | [static]
GeViAct_ActionDataCorrupt() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_ActionByName
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aActionName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName | [static]
GeViAct_ActionByName(String^ initActionName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName | [virtual]
Generated on Fri Dec 9 2011 11:16:03 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RedChangeMaster
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aDisconnectIOClients | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster |
aNewMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster | [static]
GeViAct_RedChangeMaster(String^ initNewMaster, Boolean initDisconnectIOClients) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RescannRequest
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest | [static]
GeViAct_RescannRequest(Boolean initInformDevices) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SendRawData
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData |
aRawData | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData | [static]
GeViAct_SendRawData(GeViClientID initClientID, String^ initClientName, String^ initRawData) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_StartEvent
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent | [static]
GeViAct_StartEvent(GeViEventTypeID initEventTypeID, String^ initEventName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SystemStopped
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped | [static]
GeViAct_SystemStopped() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_InformAllUsersMSG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG | [static]
GeViAct_InformAllUsersMSG(GeViClientID initFrom, String^ initFromName, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SendRawDataMSG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG | [static]
GeViAct_SendRawDataMSG(GeViClientID initClientID, String^ initClientName, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_HistoricalInput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aContactID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput |
aLevel | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput |
aTimeStamp | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput | [static]
GeViAct_HistoricalInput(Int32 initContactID, Int32 initLevel, GeViTGeViDateTime initTimeStamp) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SyncTimeRequestToClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient | [static]
GeViAct_SyncTimeRequestToClient(GeViClientID initClientID, String^ initClientName, Boolean initInformDevices) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RedRedundantLoginFailed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed |
aServerHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed |
aUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed | [static]
GeViAct_RedRedundantLoginFailed(String^ initUser, String^ initHost, String^ initServerHost) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SystemStarted
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted | [static]
GeViAct_SystemStarted() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_StopEventByInstance
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance | [static]
GeViAct_StopEventByInstance(GeViEventID initEventID) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_EventStarted
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted |
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted | [static]
GeViAct_EventStarted(GeViEventTypeID initEventTypeID, GeViEventID initEventID, String^ initEventName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RescannRequestToClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient | [static]
GeViAct_RescannRequestToClient(GeViClientID initClientID, String^ initClientName, Boolean initInformDevices) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RedConnectionMasterChanged
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged |
aNewMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged |
aOldMaster | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged |
aUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged | [static]
GeViAct_RedConnectionMasterChanged(String^ initNewMaster, String^ initOldMaster, String^ initUser, String^ initHost) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_UserLoginFailed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed |
aPort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed |
aReason | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed | [static]
GeViAct_UserLoginFailed(GeViTGeViPort initPort, String^ initUser1, String^ initUser2, String^ initHost, GeViTLoginFailure initReason) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_LogSourceAction
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction | [static]
GeViAct_LogSourceAction(Int32 initConsole) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_InformUser
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser |
aInfoMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser |
aToName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser | [static]
GeViAct_InformUser(GeViClientID initFrom, String^ initFromName, GeViClientID initTo, String^ initToName, String^ initInfoMessage) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_LogLastAction
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aConsole | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction | [static]
GeViAct_LogLastAction(Int32 initConsole) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_DisconnectUser
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aAdminID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser |
aReason | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser |
aUserName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser | [static]
GeViAct_DisconnectUser(GeViClientID initUserID, String^ initUserName, GeViClientID initAdminID, String^ initReason) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_EventRelation
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aEventRelationName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation |
aEventRelationTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation | [static]
GeViAct_EventRelation(Int32 initEventRelationTypeID, String^ initEventRelationName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SystemError
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError |
aErrorCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError |
aErrorSubCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError |
aErrorText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError | [static]
GeViAct_SystemError(GeViClientID initClientID, Int32 initErrorCode, Int32 initErrorSubCode, String^ initErrorText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_StopEventByType
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType | [static]
GeViAct_StopEventByType(GeViEventTypeID initEventTypeID, String^ initEventName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_EventStopped
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aEventID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped |
aEventName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped |
aEventTypeID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped | [static]
GeViAct_EventStopped(GeViEventTypeID initEventTypeID, GeViEventID initEventID, String^ initEventName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SystemWarning
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning |
aWarningCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning |
aWarningSubCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning |
aWarningText | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning | [static]
GeViAct_SystemWarning(GeViClientID initClientID, Int32 initWarningCode, Int32 initWarningSubCode, String^ initWarningText) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SystemSettingsChanged
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged | [static]
GeViAct_SystemSettingsChanged(String^ initUser1, String^ initUser2, String^ initHost) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RestoreRightProfile
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aUserID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile |
aUserName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile | [static]
GeViAct_RestoreRightProfile(GeViClientID initUserID, String^ initUserName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SyncTimeSetTimeClient
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient |
aDateAndTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient | [static]
GeViAct_SyncTimeSetTimeClient(GeViClientID initClientID, String^ initClientName, Boolean initInformDevices, GeViTGeViDateTime initDateAndTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SyncTimeSetTime
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aDateAndTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime | [static]
GeViAct_SyncTimeSetTime(GeViTGeViDateTime initDateAndTime, Boolean initInformDevices) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SyncTimeRequest
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest | [static]
GeViAct_SyncTimeRequest(Boolean initInformDevices) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RedRedundantUserLogin
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin |
aServerHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin |
aUser | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin | [static]
GeViAct_RedRedundantUserLogin(String^ initUser, String^ initHost, String^ initServerHost) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_SyncTimeSetTimeActual
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aInformDevices | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual | [static]
GeViAct_SyncTimeSetTimeActual(Boolean initInformDevices) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_UserLogin
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin |
aPort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin | [static]
GeViAct_UserLogin(GeViTGeViPort initPort, String^ initUser1, String^ initUser2, String^ initHost) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_InformAllUsers
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers |
aInfoMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers | [static]
GeViAct_InformAllUsers(GeViClientID initFrom, String^ initFromName, String^ initInfoMessage) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_RedirectResource
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aNewNumber | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource |
aOldNumber | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource |
aResourceType | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource | [static]
GeViAct_RedirectResource(GeViTGeViResourceType initResourceType, Int32 initOldNumber, Int32 initNewNumber) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_UserLogout
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aHost | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout |
aPort | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout |
aUser1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout |
aUser2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout | [static]
GeViAct_UserLogout(GeViTGeViPort initPort, String^ initUser1, String^ initUser2, String^ initHost) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • SystemActions
  • GeViAct_InformUserMSG
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aFrom | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
aFromName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
aMessageID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
aMessageInternal | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
aMessageName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
aTo | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
aToName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG | [static]
GeViAct_InformUserMSG(GeViClientID initFrom, String^ initFromName, GeViClientID initTo, String^ initToName, Int32 initMessageID, String^ initMessageName, GeViMessageInternal initMessageInternal) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • TimeRangesActions
  • GeViAct_TimeRangeStarted
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted |
aTimeRangeName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted | [static]
GeViAct_TimeRangeStarted(Int64 initID, String^ initTimeRangeName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • TimeRangesActions
  • GeViAct_TimeRangeEnded
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded |
aTimeRangeName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded | [static]
GeViAct_TimeRangeEnded(Int64 initID, String^ initTimeRangeName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSAllTimerReset
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset | [static]
GeViAct_VSAllTimerReset(GeViClientID initClientID, String^ initClientName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VS30PMMode
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode | [static]
GeViAct_VS30PMMode(GeViClientID initClientID, String^ initClientName, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSRecorderTimerReset
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset | [static]
GeViAct_VSRecorderTimerReset(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSSetMode
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode |
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode | [static]
GeViAct_VSSetMode(GeViClientID initClientID, String^ initClientName, Int32 initMode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSSetAllArmed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed | [static]
GeViAct_VSSetAllArmed(GeViClientID initClientID, String^ initClientName, Boolean initArmed) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSPreAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm | [static]
GeViAct_VSPreAlarm(GeViVideoInputID initVideoInput, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSChooseSavedPicture
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aSavedPicture | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture | [static]
GeViAct_VSChooseSavedPicture(GeViVideoInputID initVideoInput, Int32 initSavedPicture) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSPictureToOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput |
aWhichPicture | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput | [static]
GeViAct_VSPictureToOutput(GeViVideoInputID initVideoInput, Boolean initWhichPicture) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VS30VMDMode
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode | [static]
GeViAct_VS30VMDMode(GeViVideoInputID initVideoInput, Int32 initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSArmed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed | [static]
GeViAct_VSArmed(GeViVideoInputID initVideoInput, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSSyncSignalDetect
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect | [static]
GeViAct_VSSyncSignalDetect(GeViVideoInputID initVideoInput, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSRecorderEnd
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd | [static]
GeViAct_VSRecorderEnd(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSPictureToCommonOut
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut | [static]
GeViAct_VSPictureToCommonOut(GeViVideoInputID initVideoInput, Int32 initOutput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSTestAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm | [static]
GeViAct_VSTestAlarm(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSSetSensorMode
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode | [static]
GeViAct_VSSetSensorMode(GeViVideoInputID initVideoInput, Int32 initMode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSAlarmExtern
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern | [static]
GeViAct_VSAlarmExtern(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSVMDMode
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode | [static]
GeViAct_VSVMDMode(GeViVideoInputID initVideoInput, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSSetArmed
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aArmed | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed | [static]
GeViAct_VSSetArmed(GeViVideoInputID initVideoInput, Boolean initArmed) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSAllTestAlarm
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm | [static]
GeViAct_VSAllTestAlarm(GeViClientID initClientID, String^ initClientName) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSPictureDetect
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aStatus | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect | [static]
GeViAct_VSPictureDetect(GeViVideoInputID initVideoInput, Boolean initStatus) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSAlarmEnd
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd | [static]
GeViAct_VSAlarmEnd(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSTimerReset
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset | [static]
GeViAct_VSTimerReset(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSVMDOutOfOrder
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder | [static]
GeViAct_VSVMDOutOfOrder(GeViVideoInputID initVideoInput) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSSetDateAndTime
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aClientID | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime |
aClientName | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime |
aDateAndTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime | [static]
GeViAct_VSSetDateAndTime(GeViClientID initClientID, String^ initClientName, GeViTGeViDateTime initDateAndTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSAlarmInField
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aField | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField |
aMeasureTime | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField | [static]
GeViAct_VSAlarmInField(GeViVideoInputID initVideoInput, Int32 initField, Byte initMeasureTime) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField | [virtual]
Generated on Fri Dec 9 2011 11:16:04 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • VideoSensorActions
  • GeViAct_VSSetSensorOutput
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput, including all inherited members.
_ActionCode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_ActionKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
_MessageKind | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_RecipientId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
_SenderId | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage |
aMode | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput |
aOutput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput |
aVideoInput | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput |
FromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput | [static]
GeViAct_VSSetSensorOutput(GeViVideoInputID initVideoInput, Boolean initOutput, Boolean initMode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput |
GeViAction(GeViActionKind actionKind, GeViActionCode actionCode) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction | [protected]
GeViMessage(GeViMessageKind messageKind) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
InternalFromNativeAction(CGeViMessage *nativeAction) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction |
m_NativeMessage | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage | [protected]
ToNativeAction() override | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput | [virtual]
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _ActionCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • _ActionData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData
  • _ActionKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • _DBAnswerKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer
  • _DBQueryKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter
  • _DelegateInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • _MessageKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • _NativeCallback : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
  • _NativeInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • _RecipientId : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • _SenderId : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • _StateAnswerKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer
  • _StateQueryKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • m_DBNotificationCallbackWrapper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • m_Effort : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • m_GscAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs
  • m_NativeDatabaseHandle : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • m_NativeMessage : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • m_params : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • m_Progress : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • m_sendQueryTimeout : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • m_ServerNotification : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • OnConnectProgress() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnDatabaseNotification() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnGscAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewActionByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewActionDataCorrupt() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewActivateAssignmentProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmAcked() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmCopied() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmDisplayed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmMoved() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmQuitted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmRetriggered() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlternateContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraAutoFocusOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraAutoFocusOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraClearPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCyclePause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCyclePrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraManualIrisOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraManualIrisOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraPumpOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraPumpOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraRAWOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSelectCharMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSetCameraText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSetPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSmearAndWashOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSmearAndWashOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpec1FuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpec1FuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecUFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecUFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecVFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecVFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraStopAll() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTextOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTextOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourPause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourPrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraVerOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewChangeRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewClearAlarmFlagVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewClearAlarmFlagVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewClearVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCloseContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCopyActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCopyAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCopyCameraOnMonitor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCrossSwitch() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCrossSwitchWithAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCustomAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDataBaseFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDataBaseMissing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDataBaseReady() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDefaultPosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDefaultPosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDefaultPosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDisconnectUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewEventRelation() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewEventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewEventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFastetModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFocusFar() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFocusNear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFocusStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewGeviScopeServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewGeviScopeServerConnectionFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewGeviScopeServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewHistoricalAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewHistoricalInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorCameraOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorGetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncUOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncUOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncVOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncVOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncXOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncXOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncYOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncYOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformAllUsers() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformAllUsersMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformUserMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInputContactSabotage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIrisClose() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIrisOpen() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIrisStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogLastAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogMessageMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogSourceAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegAlarmAck() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegAlarmQuit() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegAlarmStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegInitRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegInitSeq() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegLockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegUnlockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmAuxiliaryInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmCable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmLUTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmPMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmRMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAuxiliaryAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAuxiliarySensorStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPCableAFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPCableBFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPDisplaySegmentAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPDisplaySegmentStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPLUTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPLUTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPOffline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPOnline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPPMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPPMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPPMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPQueryInterface() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPRMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPRMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPRMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureAuxiliarySensor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureAuxiliaryTP1() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureAuxiliaryTP2() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureDisplaySegment() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureLU() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecurePM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureRM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPTurnARelayControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPTurnRelaysOnOneZone() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMonitorGroupDisable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMonitorGroupEnable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMonitorGroupStatusChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMoveActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMoveAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscEventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscEventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerConnectFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerDisconnect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscSetupModified() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewNormalModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewOpenContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanAuto() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanLeft() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanRight() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPopUpAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPopUpNextAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPrePosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPrePosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPrePosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedChangeMaster() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedConnectionMasterChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedirectResource() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedMasterServerChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedRedundantLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedRedundantUserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRescannRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRescannRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRestoreRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSendRawData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSendRawDataMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopEventByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopEventByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeSetTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeSetTimeActual() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeSetTimeClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemError() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemSettingsChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemWarning() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTakeCameraControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTiltDown() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTiltStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTiltUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTimeRangeEnded() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTimeRangeStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewUserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewUserLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewUserLogout() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoClearTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoContrastAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoContrastOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoContrastPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoSyncFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoSyncOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoThresholdRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoThresholdValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVS30PMMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVS30VMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAlarmEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAlarmExtern() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAlarmInField() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAllTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAllTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSChooseSavedPicture() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPictureDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPictureToCommonOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPictureToOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSRecorderEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSRecorderTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetAllArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetDateAndTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetSensorMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetSensorOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSyncSignalDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSVMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSVMDOutOfOrder() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVX3SystemReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewZoomIn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewZoomOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewZoomStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~GeViDatabase() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ~GeViSoftConnectProgressCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • ~GeViSoftDatabaseNotificationCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • aAckCleared : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
  • aActionName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
  • aAdminID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
  • aAlarmID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
  • aAlarmState
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
  • aAlarmText
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
  • aAlarmType
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
  • aAlarmTypeID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
  • aArmed
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
  • aAVGThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aBlinkOnTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
  • aBlinkPeriod : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
  • aCable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
  • aCameraID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
  • aChangedTo : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
  • aClient
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aClientID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
  • aClientName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
  • aCommand : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
  • aConsole
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs
  • aContactID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
  • aCustomInt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
  • aCustomText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
  • aCycleID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
  • aCycleName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
  • aDateAndTime
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
  • aDisconnectIOClients : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs
  • aEnabled : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
  • aErrorCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • aErrorSubCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • aErrorText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • aEventID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs
  • aEventName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
  • aEventRelationName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
  • aEventRelationTypeID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
  • aEventTypeID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
  • aField : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
  • aFirstTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
  • aFrom
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
  • aFromName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
  • aGlobalContactID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs
  • aGscServerName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs
  • aHost
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
  • aID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
  • aIgnoreRefs : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aIlluminator
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs
  • aInfoMessage
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
  • aInformDevices
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
  • aInterfaceID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
  • aInternal1
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aInternal2
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aLevel
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
  • aLocation
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
  • aLogText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
  • aMeasureTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
  • aMessageID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
  • aMessageInternal
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
  • aMessageName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
  • aMGFrom
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
  • aMGID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
  • aMGName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
  • aMGTo
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
  • aMinThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aMode
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
  • aModus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
  • aMonitorGroup
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
  • aMonitorID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs
  • aMscBlob : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • aMscDBGUID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
  • aMscEventID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • aMscEventName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aMscEventRef
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aMscEventTypeID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • aMscInt1 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • aMscInt2 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • aMscMessageKind
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • aMscServerID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aMscServerName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • aMscStartKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
  • aNewMaster
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
  • aNewNumber : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
  • aNumberOfMeasures : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aOldMaster
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
  • aOldNumber : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
  • aOtherCleared : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
  • aOutput
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
  • aPeriod : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
  • aPort
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
  • aPosition
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
  • aProfileID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
  • aProfileName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
  • aRawData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
  • aRAWData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs
  • aRawData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
  • aReason
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
  • aResourceType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
  • aSavedPicture : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs
  • aSecondsSinceStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aSeq : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
  • aServerHost
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
  • aState
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
  • aStatus
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
  • aSwitchMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
  • aTemp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
  • aText
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
  • aThreshold
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
  • aTimeRangeName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
  • aTimerID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
  • aTimerName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
  • aTimeStamp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
  • aTo
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
  • aToName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
  • aTourID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
  • aTourName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
  • aUnit
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
  • aUnitType
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
  • aUp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
  • aUser
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
  • aUser1
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
  • aUser2
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
  • aUserID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
  • aUserName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
  • aVideoInput
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs
  • aVideoOutput
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
  • aVideoOutputFrom : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
  • aVideoOutputTo : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs
  • aWarningCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
  • aWarningSubCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
  • aWarningText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
  • aWhichPicture : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • Connect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ConnectProgress : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • Create() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Data1 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • Data2 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • Data3 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • Data4 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • DatabaseNotification : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • DatePart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime
  • dipsosed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • Disconnect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Effort : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • EncodePassword() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • FromNativeAction()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
  • FromNativeDBAnswer()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • FromNativeQuery()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
  • FromNativeStateAnswer()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetNativeCallback()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
  • GetNativeInstance()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • GeViAct_AckAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
  • GeViAct_AckAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
  • GeViAct_AckAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
  • GeViAct_AckAlarmByMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
  • GeViAct_AckAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
  • GeViAct_AckAlarmByTypeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
  • GeViAct_AckAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
  • GeViAct_AckAllAlarmsOnMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
  • GeViAct_ActionByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
  • GeViAct_ActionByNameEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs
  • GeViAct_ActionDataCorrupt() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
  • GeViAct_ActionDataCorruptEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs
  • GeViAct_ActivateAssignmentProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
  • GeViAct_ActivateAssignmentProfileEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
  • GeViAct_AlarmAcked() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
  • GeViAct_AlarmAckedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
  • GeViAct_AlarmCopied() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
  • GeViAct_AlarmCopiedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
  • GeViAct_AlarmDisplayed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
  • GeViAct_AlarmDisplayedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
  • GeViAct_AlarmMoved() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
  • GeViAct_AlarmMovedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
  • GeViAct_AlarmQuitted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
  • GeViAct_AlarmQuittedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
  • GeViAct_AlarmRetriggered() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
  • GeViAct_AlarmRetriggeredEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
  • GeViAct_AlarmStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
  • GeViAct_AlarmStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
  • GeViAct_AlternateContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
  • GeViAct_AlternateContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
  • GeViAct_CameraAutoFocusOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
  • GeViAct_CameraAutoFocusOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs
  • GeViAct_CameraAutoFocusOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
  • GeViAct_CameraAutoFocusOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs
  • GeViAct_CameraClearPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
  • GeViAct_CameraClearPrePosTextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
  • GeViAct_CameraCycleNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
  • GeViAct_CameraCycleNextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs
  • GeViAct_CameraCyclePause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
  • GeViAct_CameraCyclePauseEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs
  • GeViAct_CameraCyclePrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
  • GeViAct_CameraCyclePrevEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs
  • GeViAct_CameraCycleResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
  • GeViAct_CameraCycleResumeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs
  • GeViAct_CameraCycleStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
  • GeViAct_CameraCycleStartEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
  • GeViAct_CameraCycleStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
  • GeViAct_CameraCycleStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs
  • GeViAct_CameraLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
  • GeViAct_CameraLightOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs
  • GeViAct_CameraLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
  • GeViAct_CameraLightOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs
  • GeViAct_CameraManualIrisOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
  • GeViAct_CameraManualIrisOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs
  • GeViAct_CameraManualIrisOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
  • GeViAct_CameraManualIrisOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs
  • GeViAct_CameraOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
  • GeViAct_CameraOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs
  • GeViAct_CameraOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
  • GeViAct_CameraOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs
  • GeViAct_CameraPumpOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
  • GeViAct_CameraPumpOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs
  • GeViAct_CameraPumpOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
  • GeViAct_CameraPumpOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs
  • GeViAct_CameraRAWOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
  • GeViAct_CameraRAWOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs
  • GeViAct_CameraSelectCharMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
  • GeViAct_CameraSelectCharModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
  • GeViAct_CameraSetCameraText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
  • GeViAct_CameraSetCameraTextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
  • GeViAct_CameraSetPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
  • GeViAct_CameraSetPrePosTextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
  • GeViAct_CameraSmearAndWashOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
  • GeViAct_CameraSmearAndWashOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs
  • GeViAct_CameraSmearAndWashOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
  • GeViAct_CameraSmearAndWashOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs
  • GeViAct_CameraSpec1FuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
  • GeViAct_CameraSpec1FuncOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs
  • GeViAct_CameraSpec1FuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
  • GeViAct_CameraSpec1FuncOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs
  • GeViAct_CameraSpecUFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
  • GeViAct_CameraSpecUFuncOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs
  • GeViAct_CameraSpecUFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
  • GeViAct_CameraSpecUFuncOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs
  • GeViAct_CameraSpecVFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
  • GeViAct_CameraSpecVFuncOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs
  • GeViAct_CameraSpecVFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
  • GeViAct_CameraSpecVFuncOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs
  • GeViAct_CameraStopAll() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
  • GeViAct_CameraStopAllEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs
  • GeViAct_CameraTextOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
  • GeViAct_CameraTextOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs
  • GeViAct_CameraTextOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
  • GeViAct_CameraTextOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs
  • GeViAct_CameraTourNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
  • GeViAct_CameraTourNextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs
  • GeViAct_CameraTourPause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
  • GeViAct_CameraTourPauseEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs
  • GeViAct_CameraTourPrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
  • GeViAct_CameraTourPrevEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs
  • GeViAct_CameraTourResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
  • GeViAct_CameraTourResumeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs
  • GeViAct_CameraTourStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
  • GeViAct_CameraTourStartEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
  • GeViAct_CameraTourStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
  • GeViAct_CameraTourStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs
  • GeViAct_CameraVerOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
  • GeViAct_CameraVerOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs
  • GeViAct_ChangeRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
  • GeViAct_ChangeRightProfileEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
  • GeViAct_ClearAlarmFlagVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
  • GeViAct_ClearAlarmFlagVideoInputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs
  • GeViAct_ClearAlarmFlagVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
  • GeViAct_ClearAlarmFlagVideoOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs
  • GeViAct_ClearVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
  • GeViAct_ClearVideoOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs
  • GeViAct_CloseContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
  • GeViAct_CloseContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs
  • GeViAct_CopyActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
  • GeViAct_CopyActualAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
  • GeViAct_CopyAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
  • GeViAct_CopyAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
  • GeViAct_CopyCameraOnMonitor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
  • GeViAct_CopyCameraOnMonitorEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs
  • GeViAct_CrossSwitch() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
  • GeViAct_CrossSwitchEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
  • GeViAct_CrossSwitchWithAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
  • GeViAct_CrossSwitchWithAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
  • GeViAct_CustomAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
  • GeViAct_CustomActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
  • GeViAct_DataBaseFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
  • GeViAct_DataBaseFailureEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs
  • GeViAct_DataBaseMissing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
  • GeViAct_DataBaseMissingEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs
  • GeViAct_DataBaseReady() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
  • GeViAct_DataBaseReadyEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs
  • GeViAct_DefaultPosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
  • GeViAct_DefaultPosCallUpEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs
  • GeViAct_DefaultPosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
  • GeViAct_DefaultPosClearEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs
  • GeViAct_DefaultPosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
  • GeViAct_DefaultPosSaveEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs
  • GeViAct_DisconnectUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
  • GeViAct_DisconnectUserEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
  • GeViAct_EventRelation() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
  • GeViAct_EventRelationEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
  • GeViAct_EventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
  • GeViAct_EventStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
  • GeViAct_EventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
  • GeViAct_EventStoppedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
  • GeViAct_FastetModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
  • GeViAct_FastetModeOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs
  • GeViAct_FocusFar() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
  • GeViAct_FocusFarEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
  • GeViAct_FocusNear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
  • GeViAct_FocusNearEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
  • GeViAct_FocusStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
  • GeViAct_FocusStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs
  • GeViAct_GeviScopeServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
  • GeViAct_GeviScopeServerConnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs
  • GeViAct_GeviScopeServerConnectionFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
  • GeViAct_GeviScopeServerConnectionFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs
  • GeViAct_GeviScopeServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
  • GeViAct_GeviScopeServerDisconnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs
  • GeViAct_GscActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs
  • GeViAct_HistoricalAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
  • GeViAct_HistoricalAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
  • GeViAct_HistoricalInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
  • GeViAct_HistoricalInputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
  • GeViAct_IlluminatorCameraOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
  • GeViAct_IlluminatorCameraOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
  • GeViAct_IlluminatorDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
  • GeViAct_IlluminatorDimLevelEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
  • GeViAct_IlluminatorGetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
  • GeViAct_IlluminatorGetDimLevelEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs
  • GeViAct_IlluminatorLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
  • GeViAct_IlluminatorLightOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs
  • GeViAct_IlluminatorLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
  • GeViAct_IlluminatorLightOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs
  • GeViAct_IlluminatorOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
  • GeViAct_IlluminatorOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs
  • GeViAct_IlluminatorOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
  • GeViAct_IlluminatorOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs
  • GeViAct_IlluminatorSetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
  • GeViAct_IlluminatorSetDimLevelEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
  • GeViAct_IlluminatorSpecFuncUOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
  • GeViAct_IlluminatorSpecFuncUOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs
  • GeViAct_IlluminatorSpecFuncUOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
  • GeViAct_IlluminatorSpecFuncUOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs
  • GeViAct_IlluminatorSpecFuncVOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
  • GeViAct_IlluminatorSpecFuncVOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs
  • GeViAct_IlluminatorSpecFuncVOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
  • GeViAct_IlluminatorSpecFuncVOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs
  • GeViAct_IlluminatorSpecFuncXOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
  • GeViAct_IlluminatorSpecFuncXOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs
  • GeViAct_IlluminatorSpecFuncXOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
  • GeViAct_IlluminatorSpecFuncXOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs
  • GeViAct_IlluminatorSpecFuncYOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
  • GeViAct_IlluminatorSpecFuncYOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs
  • GeViAct_IlluminatorSpecFuncYOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
  • GeViAct_IlluminatorSpecFuncYOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs
  • GeViAct_InformAllUsers() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
  • GeViAct_InformAllUsersEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
  • GeViAct_InformAllUsersMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
  • GeViAct_InformAllUsersMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
  • GeViAct_InformUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
  • GeViAct_InformUserEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
  • GeViAct_InformUserMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
  • GeViAct_InformUserMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
  • GeViAct_InputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
  • GeViAct_InputContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
  • GeViAct_InputContactSabotage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
  • GeViAct_InputContactSabotageEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs
  • GeViAct_IrisClose() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
  • GeViAct_IrisCloseEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs
  • GeViAct_IrisOpen() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
  • GeViAct_IrisOpenEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs
  • GeViAct_IrisStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
  • GeViAct_IrisStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs
  • GeViAct_LogLastAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
  • GeViAct_LogLastActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs
  • GeViAct_LogMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
  • GeViAct_LogMessageEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
  • GeViAct_LogMessageMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
  • GeViAct_LogMessageMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
  • GeViAct_LogSourceAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
  • GeViAct_LogSourceActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs
  • GeViAct_MBegAlarmAck() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
  • GeViAct_MBegAlarmAckEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
  • GeViAct_MBegAlarmQuit() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
  • GeViAct_MBegAlarmQuitEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
  • GeViAct_MBegAlarmStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
  • GeViAct_MBegAlarmStartEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
  • GeViAct_MBegInitRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
  • GeViAct_MBegInitRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs
  • GeViAct_MBegInitSeq() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
  • GeViAct_MBegInitSeqEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
  • GeViAct_MBegLockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
  • GeViAct_MBegLockCameraEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
  • GeViAct_MBegUnlockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
  • GeViAct_MBegUnlockCameraEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs
  • GeViAct_MIPAlarmAuxiliaryInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
  • GeViAct_MIPAlarmAuxiliaryInputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
  • GeViAct_MIPAlarmCable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
  • GeViAct_MIPAlarmCableEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
  • GeViAct_MIPAlarmLUTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
  • GeViAct_MIPAlarmLUTamperEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
  • GeViAct_MIPAlarmPMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
  • GeViAct_MIPAlarmPMTamperEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
  • GeViAct_MIPAlarmRMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
  • GeViAct_MIPAlarmRMTamperEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
  • GeViAct_MIPAuxiliaryAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
  • GeViAct_MIPAuxiliaryAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
  • GeViAct_MIPAuxiliarySensorStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
  • GeViAct_MIPAuxiliarySensorStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
  • GeViAct_MIPCableAFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
  • GeViAct_MIPCableAFaultStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
  • GeViAct_MIPCableBFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
  • GeViAct_MIPCableBFaultStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
  • GeViAct_MIPDisplaySegmentAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
  • GeViAct_MIPDisplaySegmentAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
  • GeViAct_MIPDisplaySegmentStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
  • GeViAct_MIPDisplaySegmentStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
  • GeViAct_MIPLUTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
  • GeViAct_MIPLUTamperAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
  • GeViAct_MIPLUTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
  • GeViAct_MIPLUTamperStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
  • GeViAct_MIPOffline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
  • GeViAct_MIPOfflineEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs
  • GeViAct_MIPOnline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
  • GeViAct_MIPOnlineEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs
  • GeViAct_MIPPMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
  • GeViAct_MIPPMComFailStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
  • GeViAct_MIPPMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
  • GeViAct_MIPPMTamperAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
  • GeViAct_MIPPMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
  • GeViAct_MIPPMTamperStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
  • GeViAct_MIPQueryInterface() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
  • GeViAct_MIPQueryInterfaceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs
  • GeViAct_MIPRMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
  • GeViAct_MIPRMComFailStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
  • GeViAct_MIPRMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
  • GeViAct_MIPRMTamperAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
  • GeViAct_MIPRMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
  • GeViAct_MIPRMTamperStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
  • GeViAct_MIPSecureAuxiliarySensor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
  • GeViAct_MIPSecureAuxiliarySensorEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
  • GeViAct_MIPSecureAuxiliaryTP1() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
  • GeViAct_MIPSecureAuxiliaryTP1EventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
  • GeViAct_MIPSecureAuxiliaryTP2() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
  • GeViAct_MIPSecureAuxiliaryTP2EventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
  • GeViAct_MIPSecureDisplaySegment() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
  • GeViAct_MIPSecureDisplaySegmentEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
  • GeViAct_MIPSecureLU() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
  • GeViAct_MIPSecureLUEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
  • GeViAct_MIPSecurePM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
  • GeViAct_MIPSecurePMEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
  • GeViAct_MIPSecureRM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
  • GeViAct_MIPSecureRMEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
  • GeViAct_MIPTurnARelayControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
  • GeViAct_MIPTurnARelayControlEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
  • GeViAct_MIPTurnRelaysOnOneZone() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
  • GeViAct_MIPTurnRelaysOnOneZoneEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
  • GeViAct_MonitorGroupDisable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
  • GeViAct_MonitorGroupDisableEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs
  • GeViAct_MonitorGroupEnable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
  • GeViAct_MonitorGroupEnableEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs
  • GeViAct_MonitorGroupStatusChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
  • GeViAct_MonitorGroupStatusChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
  • GeViAct_MoveActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
  • GeViAct_MoveActualAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
  • GeViAct_MoveAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
  • GeViAct_MoveAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
  • GeViAct_MscEventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
  • GeViAct_MscEventStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
  • GeViAct_MscEventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
  • GeViAct_MscEventStoppedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • GeViAct_MscServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
  • GeViAct_MscServerConnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
  • GeViAct_MscServerConnectFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
  • GeViAct_MscServerConnectFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
  • GeViAct_MscServerDisconnect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
  • GeViAct_MscServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
  • GeViAct_MscServerDisconnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
  • GeViAct_MscServerDisconnectEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
  • GeViAct_MscSetupModified() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
  • GeViAct_MscSetupModifiedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
  • GeViAct_NormalModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
  • GeViAct_NormalModeOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs
  • GeViAct_OpenContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
  • GeViAct_OpenContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs
  • GeViAct_PanAuto() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
  • GeViAct_PanAutoEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
  • GeViAct_PanLeft() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
  • GeViAct_PanLeftEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
  • GeViAct_PanRight() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
  • GeViAct_PanRightEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
  • GeViAct_PanStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
  • GeViAct_PanStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs
  • GeViAct_PopUpAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
  • GeViAct_PopUpAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
  • GeViAct_PopUpNextAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
  • GeViAct_PopUpNextAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
  • GeViAct_PrePosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
  • GeViAct_PrePosCallUpEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
  • GeViAct_PrePosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
  • GeViAct_PrePosClearEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
  • GeViAct_PrePosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
  • GeViAct_PrePosSaveEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
  • GeViAct_QuitAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
  • GeViAct_QuitAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
  • GeViAct_QuitAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
  • GeViAct_QuitAlarmByMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
  • GeViAct_QuitAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
  • GeViAct_QuitAlarmByTypeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
  • GeViAct_QuitAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
  • GeViAct_QuitAllAlarmsOnMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
  • GeViAct_RedChangeMaster() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
  • GeViAct_RedChangeMasterEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs
  • GeViAct_RedConnectionMasterChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
  • GeViAct_RedConnectionMasterChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
  • GeViAct_RedirectResource() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
  • GeViAct_RedirectResourceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs
  • GeViAct_RedMasterServerChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
  • GeViAct_RedMasterServerChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
  • GeViAct_RedRedundantLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
  • GeViAct_RedRedundantLoginFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
  • GeViAct_RedRedundantUserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
  • GeViAct_RedRedundantUserLoginEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
  • GeViAct_RescannRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
  • GeViAct_RescannRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs
  • GeViAct_RescannRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
  • GeViAct_RescannRequestToClientEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
  • GeViAct_RestoreRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
  • GeViAct_RestoreRightProfileEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
  • GeViAct_SendRawData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
  • GeViAct_SendRawDataEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
  • GeViAct_SendRawDataMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
  • GeViAct_SendRawDataMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
  • GeViAct_StartAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
  • GeViAct_StartAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
  • GeViAct_StartEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
  • GeViAct_StartEventEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
  • GeViAct_StartMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
  • GeViAct_StartMscEventEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • GeViAct_StartTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
  • GeViAct_StartTimerEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
  • GeViAct_StopEventByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
  • GeViAct_StopEventByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs
  • GeViAct_StopEventByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
  • GeViAct_StopEventByTypeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
  • GeViAct_StopMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
  • GeViAct_StopMscEventEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • GeViAct_StopTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
  • GeViAct_StopTimerEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
  • GeViAct_SyncTimeRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
  • GeViAct_SyncTimeRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs
  • GeViAct_SyncTimeRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
  • GeViAct_SyncTimeRequestToClientEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
  • GeViAct_SyncTimeSetTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
  • GeViAct_SyncTimeSetTimeActual() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
  • GeViAct_SyncTimeSetTimeActualEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs
  • GeViAct_SyncTimeSetTimeClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
  • GeViAct_SyncTimeSetTimeClientEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
  • GeViAct_SyncTimeSetTimeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs
  • GeViAct_SystemError() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
  • GeViAct_SystemErrorEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • GeViAct_SystemSettingsChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
  • GeViAct_SystemSettingsChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
  • GeViAct_SystemStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
  • GeViAct_SystemStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs
  • GeViAct_SystemStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
  • GeViAct_SystemStoppedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs
  • GeViAct_SystemWarning() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
  • GeViAct_SystemWarningEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
  • GeViAct_TakeCameraControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
  • GeViAct_TakeCameraControlEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
  • GeViAct_TiltDown() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
  • GeViAct_TiltDownEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
  • GeViAct_TiltStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
  • GeViAct_TiltStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs
  • GeViAct_TiltUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
  • GeViAct_TiltUpEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
  • GeViAct_TimeRangeEnded() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
  • GeViAct_TimeRangeEndedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
  • GeViAct_TimeRangeStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
  • GeViAct_TimeRangeStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
  • GeViAct_UserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
  • GeViAct_UserLoginEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
  • GeViAct_UserLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
  • GeViAct_UserLoginFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
  • GeViAct_UserLogout() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
  • GeViAct_UserLogoutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
  • GeViAct_VideoClearTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
  • GeViAct_VideoClearTextOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs
  • GeViAct_VideoContrastAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
  • GeViAct_VideoContrastAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
  • GeViAct_VideoContrastOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
  • GeViAct_VideoContrastOkEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs
  • GeViAct_VideoContrastPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
  • GeViAct_VideoContrastPreAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
  • GeViAct_VideoSyncFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
  • GeViAct_VideoSyncFailureEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs
  • GeViAct_VideoSyncOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
  • GeViAct_VideoSyncOkEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs
  • GeViAct_VideoTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
  • GeViAct_VideoTextOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
  • GeViAct_VideoThresholdRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
  • GeViAct_VideoThresholdRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
  • GeViAct_VideoThresholdValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
  • GeViAct_VideoThresholdValueEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • GeViAct_VS30PMMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
  • GeViAct_VS30PMModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
  • GeViAct_VS30VMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
  • GeViAct_VS30VMDModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
  • GeViAct_VSAlarmEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
  • GeViAct_VSAlarmEndEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs
  • GeViAct_VSAlarmExtern() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
  • GeViAct_VSAlarmExternEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs
  • GeViAct_VSAlarmInField() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
  • GeViAct_VSAlarmInFieldEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
  • GeViAct_VSAllTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
  • GeViAct_VSAllTestAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
  • GeViAct_VSAllTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
  • GeViAct_VSAllTimerResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
  • GeViAct_VSArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
  • GeViAct_VSArmedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
  • GeViAct_VSChooseSavedPicture() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
  • GeViAct_VSChooseSavedPictureEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs
  • GeViAct_VSPictureDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
  • GeViAct_VSPictureDetectEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
  • GeViAct_VSPictureToCommonOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
  • GeViAct_VSPictureToCommonOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
  • GeViAct_VSPictureToOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
  • GeViAct_VSPictureToOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs
  • GeViAct_VSPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
  • GeViAct_VSPreAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
  • GeViAct_VSRecorderEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
  • GeViAct_VSRecorderEndEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs
  • GeViAct_VSRecorderTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
  • GeViAct_VSRecorderTimerResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs
  • GeViAct_VSSetAllArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
  • GeViAct_VSSetAllArmedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
  • GeViAct_VSSetArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
  • GeViAct_VSSetArmedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
  • GeViAct_VSSetDateAndTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
  • GeViAct_VSSetDateAndTimeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
  • GeViAct_VSSetMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
  • GeViAct_VSSetModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
  • GeViAct_VSSetSensorMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
  • GeViAct_VSSetSensorModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
  • GeViAct_VSSetSensorOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
  • GeViAct_VSSetSensorOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
  • GeViAct_VSSyncSignalDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
  • GeViAct_VSSyncSignalDetectEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
  • GeViAct_VSTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
  • GeViAct_VSTestAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs
  • GeViAct_VSTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
  • GeViAct_VSTimerResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs
  • GeViAct_VSVMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
  • GeViAct_VSVMDModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
  • GeViAct_VSVMDOutOfOrder() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
  • GeViAct_VSVMDOutOfOrderEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs
  • GeViAct_VX3SystemReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
  • GeViAct_VX3SystemResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
  • GeViAct_ZoomIn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
  • GeViAct_ZoomInEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
  • GeViAct_ZoomOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
  • GeViAct_ZoomOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
  • GeViAct_ZoomStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
  • GeViAct_ZoomStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs
  • GeViAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • GeViDatabase() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • GeViDBA_AccessDenied() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
  • GeViDBA_ActionEntry() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • GeViDBA_AlarmEntry() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • GeViDBA_DBError() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
  • GeViDBA_DBOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
  • GeViDBA_DBTerminated() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
  • GeViDBA_DeletedEntries() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • GeViDBA_Nothing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
  • GeViDBA_QueryHandle() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
  • GeViDBAnswer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer
  • GeViDBF_ActionKind() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
  • GeViDBF_ActionList() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
  • GeViDBF_GscSystem() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
  • GeViDBF_LocalTime_GrtEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
  • GeViDBF_LocalTime_LowEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
  • GeViDBF_MonitorGroupDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
  • GeViDBF_MonitorGroupID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
  • GeViDBF_MonitorGroupName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
  • GeViDBF_MscSystem() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
  • GeViDBF_PK_GrtEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
  • GeViDBF_PK_LowEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
  • GeViDBF_SenderDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
  • GeViDBF_SenderID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
  • GeViDBF_SenderName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
  • GeViDBF_StartMonitorGroupDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
  • GeViDBF_StartMonitorGroupID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
  • GeViDBF_StartMonitorGroupName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
  • GeViDBF_Text() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
  • GeViDBF_TypeDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
  • GeViDBF_TypeID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
  • GeViDBF_TypeName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
  • GeViDBF_WithAck() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
  • GeViDBF_WithMscIIRelation() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
  • GeViDBF_WithQuit() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
  • GeViDBFilter() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter
  • GeViDBQ_AbortQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
  • GeViDBQ_CloseQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
  • GeViDBQ_CreateActionQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
  • GeViDBQ_CreateAlarmQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
  • GeViDBQ_CreateDeleteActionsHandle() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
  • GeViDBQ_CreateDeleteAlarmsHandle() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
  • GeViDBQ_DeleteAll() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
  • GeViDBQ_Get() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
  • GeViDBQ_GetFirst() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
  • GeViDBQ_GetLast() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
  • GeViDBQ_GetNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
  • GeViDBQ_GetPrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
  • GeViDBQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery
  • GeViMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • GeViSA_AlarmInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • GeViSA_AlarmOnMGInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
  • GeViSA_ClientInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • GeViSA_ClientLoginInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • GeViSA_CommandFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
  • GeViSA_CommandOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
  • GeViSA_ContrastState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • GeViSA_InfoDatabaseCreationTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
  • GeViSA_InfoServerStartTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
  • GeViSA_InputContactInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
  • GeViSA_LicenseCall() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
  • GeViSA_LicenseInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • GeViSA_LicenseTransferData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
  • GeViSA_LicenseValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
  • GeViSA_MonitorGroupInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
  • GeViSA_Nothing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
  • GeViSA_OutputContactInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
  • GeViSA_PTZHeadInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • GeViSA_SyncState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
  • GeViSA_Terminated() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
  • GeViSA_ThresholdInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • GeViSA_UnknownCommand() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
  • GeViSA_UnsufficientRights() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
  • GeViSA_VideoInputInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • GeViSA_VideoOutputInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • GeViSA_VideoSensorInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • GeViSoftConnectProgressCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • GeViSoftConnectProgressEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • GeViSoftDatabaseNotificationCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
  • GeViSoftDatabaseNotificationEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • GeViSQ_GetAlarmOnMGByIndex() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
  • GeViSQ_GetAlarmOnMGInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
  • GeViSQ_GetAlarms() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
  • GeViSQ_GetAlarmsByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
  • GeViSQ_GetClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
  • GeViSQ_GetClientByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
  • GeViSQ_GetContrastState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
  • GeViSQ_GetFirstAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
  • GeViSQ_GetFirstClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
  • GeViSQ_GetFirstClientOfType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
  • GeViSQ_GetFirstInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
  • GeViSQ_GetFirstInputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
  • GeViSQ_GetFirstMonitorGroup() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
  • GeViSQ_GetFirstOutputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
  • GeViSQ_GetFirstOutputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
  • GeViSQ_GetFirstVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
  • GeViSQ_GetFirstVideoInputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
  • GeViSQ_GetFirstVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
  • GeViSQ_GetFirstVideoOutputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
  • GeViSQ_GetInfoDatabaseCreationTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
  • GeViSQ_GetInfoServerStartTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
  • GeViSQ_GetInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
  • GeViSQ_GetInputContactByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
  • GeViSQ_GetLicenseInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
  • GeViSQ_GetLicenseValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
  • GeViSQ_GetLoginInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
  • GeViSQ_GetMonitorGroup() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
  • GeViSQ_GetMonitorGroupByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
  • GeViSQ_GetNextAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
  • GeViSQ_GetNextClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
  • GeViSQ_GetNextClientOfType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
  • GeViSQ_GetNextInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
  • GeViSQ_GetNextInputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
  • GeViSQ_GetNextMonitorGroup() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
  • GeViSQ_GetNextOutputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
  • GeViSQ_GetNextOutputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
  • GeViSQ_GetNextVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
  • GeViSQ_GetNextVideoInputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
  • GeViSQ_GetNextVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
  • GeViSQ_GetNextVideoOutputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
  • GeViSQ_GetOutputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
  • GeViSQ_GetOutputContactByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
  • GeViSQ_GetPTZHeadInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
  • GeViSQ_GetSyncState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
  • GeViSQ_GetThresholdValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
  • GeViSQ_GetVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
  • GeViSQ_GetVideoInputByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
  • GeViSQ_GetVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
  • GeViSQ_GetVideoOutputByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
  • GeViSQ_GetVideoSensorInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
  • GeViSQ_LicenseCall() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
  • GeViSQ_LicensePrepareCall() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
  • GeViSQ_LicenseTransferData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
  • GeViStateAnswer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer
  • GeViStateQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • InternalFromNativeAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • InternalFromNativeQuery()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer
  • Invoke()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Params : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • Progress : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • ReceivedAckAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAckAlarmByMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAckAlarmByType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAckAllAlarmsOnMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedActionByName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedActionDataCorrupt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedActivateAssignmentProfile : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmAcked : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmCopied : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmDisplayed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmMoved : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmQuitted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmRetriggered : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlternateContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraAutoFocusOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraAutoFocusOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraClearPrePosText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleNext : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCyclePause : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCyclePrev : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleResume : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraLightOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraLightOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraManualIrisOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraManualIrisOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraPumpOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraPumpOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraRAWOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSelectCharMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSetCameraText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSetPrePosText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSmearAndWashOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSmearAndWashOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpec1FuncOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpec1FuncOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecUFuncOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecUFuncOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecVFuncOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecVFuncOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraStopAll : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTextOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTextOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourNext : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourPause : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourPrev : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourResume : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraVerOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedChangeRightProfile : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedClearAlarmFlagVideoInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedClearAlarmFlagVideoOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedClearVideoOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCloseContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCopyActualAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCopyAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCopyCameraOnMonitor : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCrossSwitch : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCrossSwitchWithAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCustomAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDataBaseFailure : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDataBaseMissing : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDataBaseReady : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDefaultPosCallUp : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDefaultPosClear : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDefaultPosSave : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDisconnectUser : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedEventRelation : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedEventStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedEventStopped : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFastetModeOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFocusFar : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFocusNear : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFocusStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGeviScopeServerConnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGeviScopeServerConnectionFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGeviScopeServerDisconnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGscAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedHistoricalAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedHistoricalInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorCameraOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorDimLevel : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorGetDimLevel : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorLightOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorLightOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSetDimLevel : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncUOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncUOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncVOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncVOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncXOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncXOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncYOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncYOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformAllUsers : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformAllUsersMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformUser : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformUserMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInputContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInputContactSabotage : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIrisClose : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIrisOpen : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIrisStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogLastAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogMessage : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogMessageMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogSourceAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegAlarmAck : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegAlarmQuit : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegAlarmStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegInitRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegInitSeq : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegLockCamera : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegUnlockCamera : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmAuxiliaryInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmCable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmLUTamper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmPMTamper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmRMTamper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAuxiliaryAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAuxiliarySensorStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPCableAFaultState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPCableBFaultState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPDisplaySegmentAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPDisplaySegmentStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPLUTamperAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPLUTamperStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPOffline : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPOnline : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPPMComFailState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPPMTamperAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPPMTamperStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPQueryInterface : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPRMComFailState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPRMTamperAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPRMTamperStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureAuxiliarySensor : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureAuxiliaryTP1 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureAuxiliaryTP2 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureDisplaySegment : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureLU : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecurePM : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureRM : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPTurnARelayControl : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPTurnRelaysOnOneZone : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMonitorGroupDisable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMonitorGroupEnable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMonitorGroupStatusChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMoveActualAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMoveAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscEventStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscEventStopped : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerConnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerConnectFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerDisconnect : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerDisconnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscSetupModified : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedNormalModeOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedOpenContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanAuto : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanLeft : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanRight : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPopUpAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPopUpNextAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPrePosCallUp : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPrePosClear : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPrePosSave : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAlarmByMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAlarmByType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAllAlarmsOnMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedChangeMaster : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedConnectionMasterChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedirectResource : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedMasterServerChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedRedundantLoginFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedRedundantUserLogin : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRescannRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRescannRequestToClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRestoreRightProfile : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSendRawData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSendRawDataMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartEvent : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartMscEvent : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartTimer : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopEventByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopEventByType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopMscEvent : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopTimer : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeRequestToClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeSetTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeSetTimeActual : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeSetTimeClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemError : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemSettingsChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemStopped : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemWarning : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTakeCameraControl : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTiltDown : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTiltStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTiltUp : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTimeRangeEnded : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTimeRangeStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedUserLogin : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedUserLoginFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedUserLogout : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoClearTextOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoContrastAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoContrastOk : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoContrastPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoSyncFailure : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoSyncOk : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoTextOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoThresholdRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoThresholdValue : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVS30PMMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVS30VMDMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAlarmEnd : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAlarmExtern : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAlarmInField : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAllTestAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAllTimerReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSChooseSavedPicture : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPictureDetect : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPictureToCommonOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPictureToOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSRecorderEnd : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSRecorderTimerReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetAllArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetDateAndTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetSensorMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetSensorOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSyncSignalDetect : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSTestAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSTimerReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSVMDMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSVMDOutOfOrder : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVX3SystemReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedZoomIn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedZoomOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedZoomStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • RegisterCallback() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • sAccessible
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sAccessRights : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sAcked : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sAcknowledged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sActionData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sActionList : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
  • sActionText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sActive
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sActiveOnly
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
  • sActualCamera : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sActualCycle : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sActualPosition : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sActualTour : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sAlarmCounter : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sAlarmField : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sAlarmReference : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sAlarmRelation : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sAlarmText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAlarmThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sAlarmTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sAlarmType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAlarmTypeDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAlarmTypeName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAllAlarms : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
  • sArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sAutoPan : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sAVGThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sBasePK : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
  • sClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
  • sClientDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
  • sClientDescription : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sClientFullName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sClientID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
  • sClientName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sClientType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sCompare
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
  • sContained : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
  • sContrastAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sContrastOK : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sContrastPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sCorrupt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sDefaultTour : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sDeletedActions : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • sDeletedAlarms : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • sDescription
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sDisplayedOnFirstMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sDongleDllFound : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • sDongleKeyFound : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • sEnabled
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sEnabledOnly
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
  • SendMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • SendPing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • SendQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • sEntryNumber : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
  • sErrorCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
  • sErrorText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
  • ServerNotificationType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • SetQueryTimeoutInMs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • sFirstMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sGlobalID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sGMTTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sGscName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
  • sHandle
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
  • sHasAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sHasContrastDetection : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sHasPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sHasPTZHead : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sHasSyncDetection : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sHasVideoSensor : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sIndex : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
  • sInstanceID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sInterfaceType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sIP : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • sLastThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sLicName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
  • sLicString : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • sLicValue : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
  • sLicVersion : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
  • sLocalID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sLocalTime
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
  • sLoginCount : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sMGDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
  • sMGID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
  • sMGName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
  • sMinThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sMonitorGroupChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sMscName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
  • sName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
  • sNumberOfMeasures : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sPan : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sPeriod : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
  • sPK
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
  • sPKAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
  • sPort : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • sPreAlarmThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sPresentedAlarms : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
  • sPresentedOnCount : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sPrevID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
  • sQuitted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sResID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
  • sSecondsSinceStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sSecondUser : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • sSegment : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
  • sSomeMscIIEvents : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sSQClientType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
  • sStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sStartMonitorGroup : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sStartMonitorGroupDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sStartMonitorGroupName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sStartTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
  • sState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
  • sSyncOK : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
  • sText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
  • sThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sTilt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sTo
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
  • sTriggerTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
  • sTypeDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
  • sTypeName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
  • sUp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
  • sVal1
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
  • sVal2
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
  • sVal3
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
  • sVal4 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
  • sVideoInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sVisible : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
  • sWith
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • TimePart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime
  • ToNativeAction()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Events

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • c
  • d
  • r

- c -

  • ConnectProgress : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Events

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • c
  • d
  • r

- d -

  • DatabaseNotification : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Events

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • c
  • d
  • r

- r -

  • ReceivedAckAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAckAlarmByMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAckAlarmByType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAckAllAlarmsOnMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedActionByName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedActionDataCorrupt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedActivateAssignmentProfile : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmAcked : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmCopied : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmDisplayed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmMoved : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmQuitted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmRetriggered : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlarmStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedAlternateContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraAutoFocusOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraAutoFocusOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraClearPrePosText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleNext : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCyclePause : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCyclePrev : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleResume : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraCycleStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraLightOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraLightOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraManualIrisOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraManualIrisOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraPumpOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraPumpOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraRAWOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSelectCharMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSetCameraText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSetPrePosText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSmearAndWashOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSmearAndWashOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpec1FuncOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpec1FuncOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecUFuncOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecUFuncOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecVFuncOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraSpecVFuncOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraStopAll : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTextOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTextOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourNext : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourPause : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourPrev : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourResume : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraTourStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCameraVerOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedChangeRightProfile : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedClearAlarmFlagVideoInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedClearAlarmFlagVideoOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedClearVideoOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCloseContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCopyActualAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCopyAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCopyCameraOnMonitor : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCrossSwitch : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCrossSwitchWithAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedCustomAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDataBaseFailure : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDataBaseMissing : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDataBaseReady : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDefaultPosCallUp : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDefaultPosClear : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDefaultPosSave : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedDisconnectUser : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedEventRelation : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedEventStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedEventStopped : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFastetModeOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFocusFar : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFocusNear : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedFocusStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGeviScopeServerConnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGeviScopeServerConnectionFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGeviScopeServerDisconnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedGscAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedHistoricalAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedHistoricalInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorCameraOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorDimLevel : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorGetDimLevel : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorLightOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorLightOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSetDimLevel : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncUOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncUOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncVOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncVOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncXOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncXOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncYOff : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIlluminatorSpecFuncYOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformAllUsers : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformAllUsersMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformUser : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInformUserMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInputContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedInputContactSabotage : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIrisClose : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIrisOpen : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedIrisStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogLastAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogMessage : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogMessageMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedLogSourceAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegAlarmAck : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegAlarmQuit : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegAlarmStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegInitRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegInitSeq : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegLockCamera : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMBegUnlockCamera : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmAuxiliaryInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmCable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmLUTamper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmPMTamper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAlarmRMTamper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAuxiliaryAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPAuxiliarySensorStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPCableAFaultState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPCableBFaultState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPDisplaySegmentAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPDisplaySegmentStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPLUTamperAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPLUTamperStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPOffline : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPOnline : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPPMComFailState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPPMTamperAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPPMTamperStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPQueryInterface : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPRMComFailState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPRMTamperAlarmState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPRMTamperStatus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureAuxiliarySensor : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureAuxiliaryTP1 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureAuxiliaryTP2 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureDisplaySegment : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureLU : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecurePM : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPSecureRM : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPTurnARelayControl : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMIPTurnRelaysOnOneZone : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMonitorGroupDisable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMonitorGroupEnable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMonitorGroupStatusChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMoveActualAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMoveAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscEventStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscEventStopped : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerConnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerConnectFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerDisconnect : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscServerDisconnected : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedMscSetupModified : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedNormalModeOn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedOpenContact : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanAuto : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanLeft : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanRight : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPanStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPopUpAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPopUpNextAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPrePosCallUp : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPrePosClear : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedPrePosSave : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAlarmByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAlarmByMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAlarmByType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedQuitAllAlarmsOnMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedChangeMaster : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedConnectionMasterChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedirectResource : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedMasterServerChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedRedundantLoginFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRedRedundantUserLogin : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRescannRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRescannRequestToClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedRestoreRightProfile : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSendRawData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSendRawDataMSG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartEvent : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartMscEvent : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStartTimer : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopEventByInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopEventByType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopMscEvent : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedStopTimer : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeRequestToClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeSetTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeSetTimeActual : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSyncTimeSetTimeClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemError : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemSettingsChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemStopped : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedSystemWarning : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTakeCameraControl : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTiltDown : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTiltStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTiltUp : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTimeRangeEnded : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedTimeRangeStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedUserLogin : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedUserLoginFailed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedUserLogout : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoClearTextOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoContrastAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoContrastOk : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoContrastPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoSyncFailure : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoSyncOk : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoTextOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoThresholdRequest : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVideoThresholdValue : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVS30PMMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVS30VMDMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAlarmEnd : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAlarmExtern : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAlarmInField : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAllTestAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSAllTimerReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSChooseSavedPicture : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPictureDetect : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPictureToCommonOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPictureToOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSRecorderEnd : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSRecorderTimerReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetAllArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetDateAndTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetSensorMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSetSensorOutput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSSyncSignalDetect : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSTestAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSTimerReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSVMDMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVSVMDOutOfOrder : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedVX3SystemReset : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedZoomIn : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedZoomOut : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ReceivedZoomStop : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- ! -

  • !GeViDatabase() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- o -

  • OnConnectProgress() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnDatabaseNotification() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnGscAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAckAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewActionByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewActionDataCorrupt() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewActivateAssignmentProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmAcked() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmCopied() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmDisplayed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmMoved() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmQuitted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmRetriggered() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlarmStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewAlternateContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraAutoFocusOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraAutoFocusOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraClearPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCyclePause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCyclePrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraCycleStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraManualIrisOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraManualIrisOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraPumpOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraPumpOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraRAWOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSelectCharMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSetCameraText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSetPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSmearAndWashOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSmearAndWashOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpec1FuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpec1FuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecUFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecUFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecVFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraSpecVFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraStopAll() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTextOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTextOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourPause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourPrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraTourStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCameraVerOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewChangeRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewClearAlarmFlagVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewClearAlarmFlagVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewClearVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCloseContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCopyActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCopyAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCopyCameraOnMonitor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCrossSwitch() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCrossSwitchWithAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewCustomAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDataBaseFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDataBaseMissing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDataBaseReady() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDefaultPosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDefaultPosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDefaultPosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewDisconnectUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewEventRelation() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewEventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewEventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFastetModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFocusFar() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFocusNear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewFocusStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewGeviScopeServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewGeviScopeServerConnectionFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewGeviScopeServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewHistoricalAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewHistoricalInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorCameraOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorGetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncUOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncUOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncVOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncVOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncXOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncXOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncYOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIlluminatorSpecFuncYOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformAllUsers() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformAllUsersMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInformUserMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewInputContactSabotage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIrisClose() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIrisOpen() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewIrisStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogLastAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogMessageMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewLogSourceAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegAlarmAck() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegAlarmQuit() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegAlarmStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegInitRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegInitSeq() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegLockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMBegUnlockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmAuxiliaryInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmCable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmLUTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmPMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAlarmRMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAuxiliaryAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPAuxiliarySensorStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPCableAFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPCableBFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPDisplaySegmentAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPDisplaySegmentStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPLUTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPLUTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPOffline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPOnline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPPMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPPMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPPMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPQueryInterface() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPRMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPRMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPRMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureAuxiliarySensor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureAuxiliaryTP1() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureAuxiliaryTP2() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureDisplaySegment() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureLU() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecurePM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPSecureRM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPTurnARelayControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMIPTurnRelaysOnOneZone() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMonitorGroupDisable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMonitorGroupEnable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMonitorGroupStatusChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMoveActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMoveAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscEventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscEventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerConnectFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerDisconnect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewMscSetupModified() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewNormalModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewOpenContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanAuto() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanLeft() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanRight() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPanStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPopUpAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPopUpNextAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPrePosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPrePosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewPrePosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewQuitAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedChangeMaster() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedConnectionMasterChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedirectResource() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedMasterServerChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedRedundantLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRedRedundantUserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRescannRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRescannRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewRestoreRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSendRawData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSendRawDataMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStartTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopEventByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopEventByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewStopTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeSetTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeSetTimeActual() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSyncTimeSetTimeClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemError() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemSettingsChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewSystemWarning() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTakeCameraControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTiltDown() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTiltStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTiltUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTimeRangeEnded() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewTimeRangeStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewUserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewUserLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewUserLogout() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoClearTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoContrastAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoContrastOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoContrastPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoSyncFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoSyncOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoThresholdRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVideoThresholdValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVS30PMMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVS30VMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAlarmEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAlarmExtern() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAlarmInField() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAllTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSAllTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSChooseSavedPicture() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPictureDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPictureToCommonOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPictureToOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSRecorderEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSRecorderTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetAllArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetDateAndTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetSensorMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSetSensorOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSSyncSignalDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSVMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVSVMDOutOfOrder() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewVX3SystemReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewZoomIn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewZoomOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • OnNewZoomStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- ~ -

  • ~GeViDatabase() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • ~GeViSoftConnectProgressCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • ~GeViSoftDatabaseNotificationCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- c -

  • Connect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • Create() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- d -

  • Disconnect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- e -

  • EncodePassword() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DBIHelperFunctions
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- f -

  • FromNativeAction()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
  • FromNativeDBAnswer()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • FromNativeQuery()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
  • FromNativeStateAnswer()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- g -

  • GetNativeCallback()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
  • GetNativeInstance()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • GeViAct_AckAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
  • GeViAct_AckAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
  • GeViAct_AckAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
  • GeViAct_AckAlarmByMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
  • GeViAct_AckAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
  • GeViAct_AckAlarmByTypeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
  • GeViAct_AckAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
  • GeViAct_AckAllAlarmsOnMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
  • GeViAct_ActionByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
  • GeViAct_ActionByNameEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs
  • GeViAct_ActionDataCorrupt() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
  • GeViAct_ActionDataCorruptEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionDataCorruptEventArgs
  • GeViAct_ActivateAssignmentProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
  • GeViAct_ActivateAssignmentProfileEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
  • GeViAct_AlarmAcked() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
  • GeViAct_AlarmAckedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
  • GeViAct_AlarmCopied() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
  • GeViAct_AlarmCopiedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
  • GeViAct_AlarmDisplayed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
  • GeViAct_AlarmDisplayedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
  • GeViAct_AlarmMoved() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
  • GeViAct_AlarmMovedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
  • GeViAct_AlarmQuitted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
  • GeViAct_AlarmQuittedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
  • GeViAct_AlarmRetriggered() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
  • GeViAct_AlarmRetriggeredEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
  • GeViAct_AlarmStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
  • GeViAct_AlarmStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
  • GeViAct_AlternateContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
  • GeViAct_AlternateContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
  • GeViAct_CameraAutoFocusOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
  • GeViAct_CameraAutoFocusOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs
  • GeViAct_CameraAutoFocusOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
  • GeViAct_CameraAutoFocusOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs
  • GeViAct_CameraClearPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
  • GeViAct_CameraClearPrePosTextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
  • GeViAct_CameraCycleNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
  • GeViAct_CameraCycleNextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs
  • GeViAct_CameraCyclePause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
  • GeViAct_CameraCyclePauseEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs
  • GeViAct_CameraCyclePrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
  • GeViAct_CameraCyclePrevEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs
  • GeViAct_CameraCycleResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
  • GeViAct_CameraCycleResumeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs
  • GeViAct_CameraCycleStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
  • GeViAct_CameraCycleStartEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
  • GeViAct_CameraCycleStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
  • GeViAct_CameraCycleStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs
  • GeViAct_CameraLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
  • GeViAct_CameraLightOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs
  • GeViAct_CameraLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
  • GeViAct_CameraLightOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs
  • GeViAct_CameraManualIrisOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
  • GeViAct_CameraManualIrisOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs
  • GeViAct_CameraManualIrisOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
  • GeViAct_CameraManualIrisOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs
  • GeViAct_CameraOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
  • GeViAct_CameraOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs
  • GeViAct_CameraOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
  • GeViAct_CameraOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs
  • GeViAct_CameraPumpOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
  • GeViAct_CameraPumpOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs
  • GeViAct_CameraPumpOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
  • GeViAct_CameraPumpOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs
  • GeViAct_CameraRAWOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
  • GeViAct_CameraRAWOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs
  • GeViAct_CameraSelectCharMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
  • GeViAct_CameraSelectCharModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
  • GeViAct_CameraSetCameraText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
  • GeViAct_CameraSetCameraTextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
  • GeViAct_CameraSetPrePosText() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
  • GeViAct_CameraSetPrePosTextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
  • GeViAct_CameraSmearAndWashOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
  • GeViAct_CameraSmearAndWashOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs
  • GeViAct_CameraSmearAndWashOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
  • GeViAct_CameraSmearAndWashOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs
  • GeViAct_CameraSpec1FuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
  • GeViAct_CameraSpec1FuncOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs
  • GeViAct_CameraSpec1FuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
  • GeViAct_CameraSpec1FuncOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs
  • GeViAct_CameraSpecUFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
  • GeViAct_CameraSpecUFuncOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs
  • GeViAct_CameraSpecUFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
  • GeViAct_CameraSpecUFuncOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs
  • GeViAct_CameraSpecVFuncOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
  • GeViAct_CameraSpecVFuncOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs
  • GeViAct_CameraSpecVFuncOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
  • GeViAct_CameraSpecVFuncOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs
  • GeViAct_CameraStopAll() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
  • GeViAct_CameraStopAllEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs
  • GeViAct_CameraTextOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
  • GeViAct_CameraTextOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs
  • GeViAct_CameraTextOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
  • GeViAct_CameraTextOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs
  • GeViAct_CameraTourNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
  • GeViAct_CameraTourNextEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs
  • GeViAct_CameraTourPause() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
  • GeViAct_CameraTourPauseEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs
  • GeViAct_CameraTourPrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
  • GeViAct_CameraTourPrevEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs
  • GeViAct_CameraTourResume() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
  • GeViAct_CameraTourResumeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs
  • GeViAct_CameraTourStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
  • GeViAct_CameraTourStartEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
  • GeViAct_CameraTourStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
  • GeViAct_CameraTourStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs
  • GeViAct_CameraVerOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
  • GeViAct_CameraVerOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs
  • GeViAct_ChangeRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
  • GeViAct_ChangeRightProfileEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
  • GeViAct_ClearAlarmFlagVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
  • GeViAct_ClearAlarmFlagVideoInputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs
  • GeViAct_ClearAlarmFlagVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
  • GeViAct_ClearAlarmFlagVideoOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs
  • GeViAct_ClearVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
  • GeViAct_ClearVideoOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs
  • GeViAct_CloseContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
  • GeViAct_CloseContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs
  • GeViAct_CopyActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
  • GeViAct_CopyActualAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
  • GeViAct_CopyAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
  • GeViAct_CopyAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
  • GeViAct_CopyCameraOnMonitor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
  • GeViAct_CopyCameraOnMonitorEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs
  • GeViAct_CrossSwitch() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
  • GeViAct_CrossSwitchEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
  • GeViAct_CrossSwitchWithAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
  • GeViAct_CrossSwitchWithAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
  • GeViAct_CustomAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
  • GeViAct_CustomActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
  • GeViAct_DataBaseFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
  • GeViAct_DataBaseFailureEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseFailureEventArgs
  • GeViAct_DataBaseMissing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
  • GeViAct_DataBaseMissingEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseMissingEventArgs
  • GeViAct_DataBaseReady() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
  • GeViAct_DataBaseReadyEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DataBaseReadyEventArgs
  • GeViAct_DefaultPosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
  • GeViAct_DefaultPosCallUpEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs
  • GeViAct_DefaultPosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
  • GeViAct_DefaultPosClearEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs
  • GeViAct_DefaultPosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
  • GeViAct_DefaultPosSaveEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs
  • GeViAct_DisconnectUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
  • GeViAct_DisconnectUserEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
  • GeViAct_EventRelation() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
  • GeViAct_EventRelationEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
  • GeViAct_EventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
  • GeViAct_EventStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
  • GeViAct_EventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
  • GeViAct_EventStoppedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
  • GeViAct_FastetModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
  • GeViAct_FastetModeOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs
  • GeViAct_FocusFar() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
  • GeViAct_FocusFarEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
  • GeViAct_FocusNear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
  • GeViAct_FocusNearEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
  • GeViAct_FocusStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
  • GeViAct_FocusStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs
  • GeViAct_GeviScopeServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
  • GeViAct_GeviScopeServerConnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs
  • GeViAct_GeviScopeServerConnectionFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
  • GeViAct_GeviScopeServerConnectionFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs
  • GeViAct_GeviScopeServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
  • GeViAct_GeviScopeServerDisconnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs
  • GeViAct_GscActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs
  • GeViAct_HistoricalAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
  • GeViAct_HistoricalAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
  • GeViAct_HistoricalInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
  • GeViAct_HistoricalInputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
  • GeViAct_IlluminatorCameraOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
  • GeViAct_IlluminatorCameraOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
  • GeViAct_IlluminatorDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
  • GeViAct_IlluminatorDimLevelEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
  • GeViAct_IlluminatorGetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
  • GeViAct_IlluminatorGetDimLevelEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs
  • GeViAct_IlluminatorLightOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
  • GeViAct_IlluminatorLightOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs
  • GeViAct_IlluminatorLightOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
  • GeViAct_IlluminatorLightOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs
  • GeViAct_IlluminatorOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
  • GeViAct_IlluminatorOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs
  • GeViAct_IlluminatorOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
  • GeViAct_IlluminatorOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs
  • GeViAct_IlluminatorSetDimLevel() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
  • GeViAct_IlluminatorSetDimLevelEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
  • GeViAct_IlluminatorSpecFuncUOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
  • GeViAct_IlluminatorSpecFuncUOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs
  • GeViAct_IlluminatorSpecFuncUOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
  • GeViAct_IlluminatorSpecFuncUOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs
  • GeViAct_IlluminatorSpecFuncVOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
  • GeViAct_IlluminatorSpecFuncVOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs
  • GeViAct_IlluminatorSpecFuncVOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
  • GeViAct_IlluminatorSpecFuncVOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs
  • GeViAct_IlluminatorSpecFuncXOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
  • GeViAct_IlluminatorSpecFuncXOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs
  • GeViAct_IlluminatorSpecFuncXOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
  • GeViAct_IlluminatorSpecFuncXOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs
  • GeViAct_IlluminatorSpecFuncYOff() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
  • GeViAct_IlluminatorSpecFuncYOffEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs
  • GeViAct_IlluminatorSpecFuncYOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
  • GeViAct_IlluminatorSpecFuncYOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs
  • GeViAct_InformAllUsers() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
  • GeViAct_InformAllUsersEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
  • GeViAct_InformAllUsersMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
  • GeViAct_InformAllUsersMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
  • GeViAct_InformUser() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
  • GeViAct_InformUserEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
  • GeViAct_InformUserMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
  • GeViAct_InformUserMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
  • GeViAct_InputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
  • GeViAct_InputContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
  • GeViAct_InputContactSabotage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
  • GeViAct_InputContactSabotageEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs
  • GeViAct_IrisClose() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
  • GeViAct_IrisCloseEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs
  • GeViAct_IrisOpen() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
  • GeViAct_IrisOpenEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs
  • GeViAct_IrisStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
  • GeViAct_IrisStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs
  • GeViAct_LogLastAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
  • GeViAct_LogLastActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs
  • GeViAct_LogMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
  • GeViAct_LogMessageEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
  • GeViAct_LogMessageMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
  • GeViAct_LogMessageMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
  • GeViAct_LogSourceAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
  • GeViAct_LogSourceActionEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs
  • GeViAct_MBegAlarmAck() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
  • GeViAct_MBegAlarmAckEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
  • GeViAct_MBegAlarmQuit() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
  • GeViAct_MBegAlarmQuitEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
  • GeViAct_MBegAlarmStart() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
  • GeViAct_MBegAlarmStartEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
  • GeViAct_MBegInitRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
  • GeViAct_MBegInitRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs
  • GeViAct_MBegInitSeq() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
  • GeViAct_MBegInitSeqEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
  • GeViAct_MBegLockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
  • GeViAct_MBegLockCameraEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
  • GeViAct_MBegUnlockCamera() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
  • GeViAct_MBegUnlockCameraEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs
  • GeViAct_MIPAlarmAuxiliaryInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
  • GeViAct_MIPAlarmAuxiliaryInputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
  • GeViAct_MIPAlarmCable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
  • GeViAct_MIPAlarmCableEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
  • GeViAct_MIPAlarmLUTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
  • GeViAct_MIPAlarmLUTamperEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
  • GeViAct_MIPAlarmPMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
  • GeViAct_MIPAlarmPMTamperEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
  • GeViAct_MIPAlarmRMTamper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
  • GeViAct_MIPAlarmRMTamperEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
  • GeViAct_MIPAuxiliaryAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
  • GeViAct_MIPAuxiliaryAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
  • GeViAct_MIPAuxiliarySensorStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
  • GeViAct_MIPAuxiliarySensorStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
  • GeViAct_MIPCableAFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
  • GeViAct_MIPCableAFaultStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
  • GeViAct_MIPCableBFaultState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
  • GeViAct_MIPCableBFaultStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
  • GeViAct_MIPDisplaySegmentAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
  • GeViAct_MIPDisplaySegmentAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
  • GeViAct_MIPDisplaySegmentStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
  • GeViAct_MIPDisplaySegmentStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
  • GeViAct_MIPLUTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
  • GeViAct_MIPLUTamperAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
  • GeViAct_MIPLUTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
  • GeViAct_MIPLUTamperStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
  • GeViAct_MIPOffline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
  • GeViAct_MIPOfflineEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs
  • GeViAct_MIPOnline() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
  • GeViAct_MIPOnlineEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs
  • GeViAct_MIPPMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
  • GeViAct_MIPPMComFailStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
  • GeViAct_MIPPMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
  • GeViAct_MIPPMTamperAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
  • GeViAct_MIPPMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
  • GeViAct_MIPPMTamperStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
  • GeViAct_MIPQueryInterface() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
  • GeViAct_MIPQueryInterfaceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs
  • GeViAct_MIPRMComFailState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
  • GeViAct_MIPRMComFailStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
  • GeViAct_MIPRMTamperAlarmState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
  • GeViAct_MIPRMTamperAlarmStateEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
  • GeViAct_MIPRMTamperStatus() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
  • GeViAct_MIPRMTamperStatusEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
  • GeViAct_MIPSecureAuxiliarySensor() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
  • GeViAct_MIPSecureAuxiliarySensorEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
  • GeViAct_MIPSecureAuxiliaryTP1() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
  • GeViAct_MIPSecureAuxiliaryTP1EventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
  • GeViAct_MIPSecureAuxiliaryTP2() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
  • GeViAct_MIPSecureAuxiliaryTP2EventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
  • GeViAct_MIPSecureDisplaySegment() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
  • GeViAct_MIPSecureDisplaySegmentEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
  • GeViAct_MIPSecureLU() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
  • GeViAct_MIPSecureLUEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
  • GeViAct_MIPSecurePM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
  • GeViAct_MIPSecurePMEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
  • GeViAct_MIPSecureRM() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
  • GeViAct_MIPSecureRMEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
  • GeViAct_MIPTurnARelayControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
  • GeViAct_MIPTurnARelayControlEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
  • GeViAct_MIPTurnRelaysOnOneZone() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
  • GeViAct_MIPTurnRelaysOnOneZoneEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
  • GeViAct_MonitorGroupDisable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
  • GeViAct_MonitorGroupDisableEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs
  • GeViAct_MonitorGroupEnable() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
  • GeViAct_MonitorGroupEnableEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs
  • GeViAct_MonitorGroupStatusChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
  • GeViAct_MonitorGroupStatusChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
  • GeViAct_MoveActualAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
  • GeViAct_MoveActualAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
  • GeViAct_MoveAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
  • GeViAct_MoveAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
  • GeViAct_MscEventStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
  • GeViAct_MscEventStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
  • GeViAct_MscEventStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
  • GeViAct_MscEventStoppedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • GeViAct_MscServerConnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
  • GeViAct_MscServerConnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
  • GeViAct_MscServerConnectFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
  • GeViAct_MscServerConnectFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
  • GeViAct_MscServerDisconnect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
  • GeViAct_MscServerDisconnected() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
  • GeViAct_MscServerDisconnectedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
  • GeViAct_MscServerDisconnectEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
  • GeViAct_MscSetupModified() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
  • GeViAct_MscSetupModifiedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
  • GeViAct_NormalModeOn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
  • GeViAct_NormalModeOnEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs
  • GeViAct_OpenContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
  • GeViAct_OpenContactEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs
  • GeViAct_PanAuto() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
  • GeViAct_PanAutoEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
  • GeViAct_PanLeft() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
  • GeViAct_PanLeftEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
  • GeViAct_PanRight() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
  • GeViAct_PanRightEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
  • GeViAct_PanStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
  • GeViAct_PanStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs
  • GeViAct_PopUpAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
  • GeViAct_PopUpAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
  • GeViAct_PopUpNextAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
  • GeViAct_PopUpNextAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
  • GeViAct_PrePosCallUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
  • GeViAct_PrePosCallUpEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
  • GeViAct_PrePosClear() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
  • GeViAct_PrePosClearEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
  • GeViAct_PrePosSave() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
  • GeViAct_PrePosSaveEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
  • GeViAct_QuitAlarmByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
  • GeViAct_QuitAlarmByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
  • GeViAct_QuitAlarmByMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
  • GeViAct_QuitAlarmByMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
  • GeViAct_QuitAlarmByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
  • GeViAct_QuitAlarmByTypeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
  • GeViAct_QuitAllAlarmsOnMG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
  • GeViAct_QuitAllAlarmsOnMGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
  • GeViAct_RedChangeMaster() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
  • GeViAct_RedChangeMasterEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs
  • GeViAct_RedConnectionMasterChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
  • GeViAct_RedConnectionMasterChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
  • GeViAct_RedirectResource() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
  • GeViAct_RedirectResourceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs
  • GeViAct_RedMasterServerChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
  • GeViAct_RedMasterServerChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
  • GeViAct_RedRedundantLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
  • GeViAct_RedRedundantLoginFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
  • GeViAct_RedRedundantUserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
  • GeViAct_RedRedundantUserLoginEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
  • GeViAct_RescannRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
  • GeViAct_RescannRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs
  • GeViAct_RescannRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
  • GeViAct_RescannRequestToClientEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
  • GeViAct_RestoreRightProfile() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
  • GeViAct_RestoreRightProfileEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
  • GeViAct_SendRawData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
  • GeViAct_SendRawDataEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
  • GeViAct_SendRawDataMSG() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
  • GeViAct_SendRawDataMSGEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
  • GeViAct_StartAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
  • GeViAct_StartAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
  • GeViAct_StartEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
  • GeViAct_StartEventEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
  • GeViAct_StartMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
  • GeViAct_StartMscEventEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • GeViAct_StartTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
  • GeViAct_StartTimerEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
  • GeViAct_StopEventByInstance() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
  • GeViAct_StopEventByInstanceEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs
  • GeViAct_StopEventByType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
  • GeViAct_StopEventByTypeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
  • GeViAct_StopMscEvent() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
  • GeViAct_StopMscEventEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • GeViAct_StopTimer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
  • GeViAct_StopTimerEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
  • GeViAct_SyncTimeRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
  • GeViAct_SyncTimeRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs
  • GeViAct_SyncTimeRequestToClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
  • GeViAct_SyncTimeRequestToClientEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
  • GeViAct_SyncTimeSetTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
  • GeViAct_SyncTimeSetTimeActual() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
  • GeViAct_SyncTimeSetTimeActualEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs
  • GeViAct_SyncTimeSetTimeClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
  • GeViAct_SyncTimeSetTimeClientEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
  • GeViAct_SyncTimeSetTimeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs
  • GeViAct_SystemError() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
  • GeViAct_SystemErrorEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • GeViAct_SystemSettingsChanged() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
  • GeViAct_SystemSettingsChangedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
  • GeViAct_SystemStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
  • GeViAct_SystemStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStartedEventArgs
  • GeViAct_SystemStopped() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
  • GeViAct_SystemStoppedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemStoppedEventArgs
  • GeViAct_SystemWarning() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
  • GeViAct_SystemWarningEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
  • GeViAct_TakeCameraControl() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
  • GeViAct_TakeCameraControlEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
  • GeViAct_TiltDown() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
  • GeViAct_TiltDownEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
  • GeViAct_TiltStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
  • GeViAct_TiltStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs
  • GeViAct_TiltUp() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
  • GeViAct_TiltUpEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
  • GeViAct_TimeRangeEnded() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
  • GeViAct_TimeRangeEndedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
  • GeViAct_TimeRangeStarted() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
  • GeViAct_TimeRangeStartedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
  • GeViAct_UserLogin() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
  • GeViAct_UserLoginEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
  • GeViAct_UserLoginFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
  • GeViAct_UserLoginFailedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
  • GeViAct_UserLogout() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
  • GeViAct_UserLogoutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
  • GeViAct_VideoClearTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
  • GeViAct_VideoClearTextOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs
  • GeViAct_VideoContrastAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
  • GeViAct_VideoContrastAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
  • GeViAct_VideoContrastOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
  • GeViAct_VideoContrastOkEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs
  • GeViAct_VideoContrastPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
  • GeViAct_VideoContrastPreAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
  • GeViAct_VideoSyncFailure() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
  • GeViAct_VideoSyncFailureEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs
  • GeViAct_VideoSyncOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
  • GeViAct_VideoSyncOkEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs
  • GeViAct_VideoTextOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
  • GeViAct_VideoTextOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
  • GeViAct_VideoThresholdRequest() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
  • GeViAct_VideoThresholdRequestEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
  • GeViAct_VideoThresholdValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
  • GeViAct_VideoThresholdValueEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • GeViAct_VS30PMMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
  • GeViAct_VS30PMModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
  • GeViAct_VS30VMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
  • GeViAct_VS30VMDModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
  • GeViAct_VSAlarmEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
  • GeViAct_VSAlarmEndEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs
  • GeViAct_VSAlarmExtern() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
  • GeViAct_VSAlarmExternEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs
  • GeViAct_VSAlarmInField() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
  • GeViAct_VSAlarmInFieldEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
  • GeViAct_VSAllTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
  • GeViAct_VSAllTestAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
  • GeViAct_VSAllTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
  • GeViAct_VSAllTimerResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
  • GeViAct_VSArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
  • GeViAct_VSArmedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
  • GeViAct_VSChooseSavedPicture() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
  • GeViAct_VSChooseSavedPictureEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs
  • GeViAct_VSPictureDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
  • GeViAct_VSPictureDetectEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
  • GeViAct_VSPictureToCommonOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
  • GeViAct_VSPictureToCommonOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
  • GeViAct_VSPictureToOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
  • GeViAct_VSPictureToOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs
  • GeViAct_VSPreAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
  • GeViAct_VSPreAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
  • GeViAct_VSRecorderEnd() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
  • GeViAct_VSRecorderEndEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs
  • GeViAct_VSRecorderTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
  • GeViAct_VSRecorderTimerResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs
  • GeViAct_VSSetAllArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
  • GeViAct_VSSetAllArmedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
  • GeViAct_VSSetArmed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
  • GeViAct_VSSetArmedEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
  • GeViAct_VSSetDateAndTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
  • GeViAct_VSSetDateAndTimeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
  • GeViAct_VSSetMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
  • GeViAct_VSSetModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
  • GeViAct_VSSetSensorMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
  • GeViAct_VSSetSensorModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
  • GeViAct_VSSetSensorOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
  • GeViAct_VSSetSensorOutputEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
  • GeViAct_VSSyncSignalDetect() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
  • GeViAct_VSSyncSignalDetectEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
  • GeViAct_VSTestAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
  • GeViAct_VSTestAlarmEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs
  • GeViAct_VSTimerReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
  • GeViAct_VSTimerResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs
  • GeViAct_VSVMDMode() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
  • GeViAct_VSVMDModeEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
  • GeViAct_VSVMDOutOfOrder() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
  • GeViAct_VSVMDOutOfOrderEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs
  • GeViAct_VX3SystemReset() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
  • GeViAct_VX3SystemResetEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
  • GeViAct_ZoomIn() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
  • GeViAct_ZoomInEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
  • GeViAct_ZoomOut() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
  • GeViAct_ZoomOutEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
  • GeViAct_ZoomStop() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
  • GeViAct_ZoomStopEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs
  • GeViAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • GeViDatabase() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • GeViDBA_AccessDenied() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
  • GeViDBA_ActionEntry() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • GeViDBA_AlarmEntry() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • GeViDBA_DBError() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
  • GeViDBA_DBOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
  • GeViDBA_DBTerminated() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
  • GeViDBA_DeletedEntries() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • GeViDBA_Nothing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
  • GeViDBA_QueryHandle() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
  • GeViDBAnswer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer
  • GeViDBF_ActionKind() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
  • GeViDBF_ActionList() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
  • GeViDBF_GscSystem() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
  • GeViDBF_LocalTime_GrtEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
  • GeViDBF_LocalTime_LowEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
  • GeViDBF_MonitorGroupDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
  • GeViDBF_MonitorGroupID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
  • GeViDBF_MonitorGroupName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
  • GeViDBF_MscSystem() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
  • GeViDBF_PK_GrtEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
  • GeViDBF_PK_LowEqu() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
  • GeViDBF_SenderDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
  • GeViDBF_SenderID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
  • GeViDBF_SenderName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
  • GeViDBF_StartMonitorGroupDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
  • GeViDBF_StartMonitorGroupID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
  • GeViDBF_StartMonitorGroupName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
  • GeViDBF_Text() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
  • GeViDBF_TypeDesc() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
  • GeViDBF_TypeID() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
  • GeViDBF_TypeName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
  • GeViDBF_WithAck() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
  • GeViDBF_WithMscIIRelation() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
  • GeViDBF_WithQuit() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
  • GeViDBFilter() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter
  • GeViDBQ_AbortQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
  • GeViDBQ_CloseQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
  • GeViDBQ_CreateActionQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
  • GeViDBQ_CreateAlarmQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
  • GeViDBQ_CreateDeleteActionsHandle() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
  • GeViDBQ_CreateDeleteAlarmsHandle() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
  • GeViDBQ_DeleteAll() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
  • GeViDBQ_Get() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
  • GeViDBQ_GetFirst() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
  • GeViDBQ_GetLast() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
  • GeViDBQ_GetNext() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
  • GeViDBQ_GetPrev() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
  • GeViDBQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery
  • GeViMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • GeViSA_AlarmInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • GeViSA_AlarmOnMGInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
  • GeViSA_ClientInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • GeViSA_ClientLoginInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • GeViSA_CommandFailed() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
  • GeViSA_CommandOk() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
  • GeViSA_ContrastState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • GeViSA_InfoDatabaseCreationTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
  • GeViSA_InfoServerStartTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
  • GeViSA_InputContactInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
  • GeViSA_LicenseCall() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
  • GeViSA_LicenseInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • GeViSA_LicenseTransferData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
  • GeViSA_LicenseValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
  • GeViSA_MonitorGroupInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
  • GeViSA_Nothing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
  • GeViSA_OutputContactInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
  • GeViSA_PTZHeadInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • GeViSA_SyncState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
  • GeViSA_Terminated() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
  • GeViSA_ThresholdInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • GeViSA_UnknownCommand() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
  • GeViSA_UnsufficientRights() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
  • GeViSA_VideoInputInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • GeViSA_VideoOutputInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • GeViSA_VideoSensorInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • GeViSoftConnectProgressCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • GeViSoftConnectProgressEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • GeViSoftDatabaseNotificationCallbackWrapper() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
  • GeViSoftDatabaseNotificationEventArgs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • GeViSQ_GetAlarmOnMGByIndex() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
  • GeViSQ_GetAlarmOnMGInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
  • GeViSQ_GetAlarms() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
  • GeViSQ_GetAlarmsByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
  • GeViSQ_GetClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
  • GeViSQ_GetClientByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
  • GeViSQ_GetContrastState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
  • GeViSQ_GetFirstAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
  • GeViSQ_GetFirstClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
  • GeViSQ_GetFirstClientOfType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
  • GeViSQ_GetFirstInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
  • GeViSQ_GetFirstInputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
  • GeViSQ_GetFirstMonitorGroup() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
  • GeViSQ_GetFirstOutputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
  • GeViSQ_GetFirstOutputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
  • GeViSQ_GetFirstVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
  • GeViSQ_GetFirstVideoInputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
  • GeViSQ_GetFirstVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
  • GeViSQ_GetFirstVideoOutputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
  • GeViSQ_GetInfoDatabaseCreationTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
  • GeViSQ_GetInfoServerStartTime() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
  • GeViSQ_GetInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
  • GeViSQ_GetInputContactByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
  • GeViSQ_GetLicenseInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
  • GeViSQ_GetLicenseValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
  • GeViSQ_GetLoginInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
  • GeViSQ_GetMonitorGroup() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
  • GeViSQ_GetMonitorGroupByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
  • GeViSQ_GetNextAlarm() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
  • GeViSQ_GetNextClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
  • GeViSQ_GetNextClientOfType() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
  • GeViSQ_GetNextInputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
  • GeViSQ_GetNextInputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
  • GeViSQ_GetNextMonitorGroup() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
  • GeViSQ_GetNextOutputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
  • GeViSQ_GetNextOutputContactOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
  • GeViSQ_GetNextVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
  • GeViSQ_GetNextVideoInputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
  • GeViSQ_GetNextVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
  • GeViSQ_GetNextVideoOutputOfClient() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
  • GeViSQ_GetOutputContact() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
  • GeViSQ_GetOutputContactByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
  • GeViSQ_GetPTZHeadInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
  • GeViSQ_GetSyncState() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
  • GeViSQ_GetThresholdValue() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
  • GeViSQ_GetVideoInput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
  • GeViSQ_GetVideoInputByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
  • GeViSQ_GetVideoOutput() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
  • GeViSQ_GetVideoOutputByName() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
  • GeViSQ_GetVideoSensorInfo() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
  • GeViSQ_LicenseCall() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
  • GeViSQ_LicensePrepareCall() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
  • GeViSQ_LicenseTransferData() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
  • GeViStateAnswer() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer
  • GeViStateQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- i -

  • InternalFromNativeAction() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • InternalFromNativeQuery()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer
  • Invoke()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- r -

  • RegisterCallback() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- s -

  • SendMessage() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • SendPing() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • SendQuery() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • SetQueryTimeoutInMs() : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • !
  • c
  • d
  • e
  • f
  • g
  • i
  • o
  • r
  • s
  • t
  • ~

- t -

  • ToNativeAction()
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInfoDatabaseCreationTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnsufficientRights
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_UnknownCommand
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Terminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_CommandFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteAlarmsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateDeleteActionsHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateAlarmQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_Nothing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBTerminated
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AccessDenied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseReady
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseMissing
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseActions::GeViAct_DataBaseFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionDataCorrupt
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • e
  • p
  • s

- a -

  • aAckCleared : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
  • aActionName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActionByNameEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActionByName
  • aAdminID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
  • aAlarmID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmRetriggeredEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmRetriggered
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
  • aAlarmState
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
  • aAlarmText
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
  • aAlarmType
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
  • aAlarmTypeID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
  • aArmed
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
  • aAVGThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aBlinkOnTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
  • aBlinkPeriod : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
  • aCable : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
  • aCameraID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourNextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPauseEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourPrevEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourResumeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourPrev
  • aChangedTo : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
  • aClient
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegUnlockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegUnlockCameraEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aClientID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_StartAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByTypeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
  • aClientName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VX3SystemReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAllTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetAllArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTestAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAllTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetAllArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VX3SystemResetEventArgs
  • aCommand : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
  • aConsole
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogLastAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogSourceAction
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogLastActionEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogSourceActionEventArgs
  • aContactID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
  • aCustomInt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
  • aCustomText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_CustomAction , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CustomActionEventArgs
  • aCycleID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
  • aCycleName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
  • aDateAndTime
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetDateAndTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetDateAndTimeEventArgs
  • aDisconnectIOClients : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
  • aEnabled : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
  • aErrorCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • aErrorSubCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • aErrorText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemError , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemErrorEventArgs
  • aEventID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByInstanceEventArgs
  • aEventName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
  • aEventRelationName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
  • aEventRelationTypeID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventRelation , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventRelationEventArgs
  • aEventTypeID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_EventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopEventByType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_EventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopEventByTypeEventArgs
  • aField : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
  • aFirstTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
  • aFrom
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
  • aFromName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
  • aGlobalContactID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_AlternateContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_CloseContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_InputContactSabotage
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ContactBusActions::GeViAct_OpenContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlternateContactEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CloseContactEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InputContactSabotageEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_OpenContactEventArgs
  • aGscServerName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerConnectionFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeviScopeActions::GeViAct_GeviScopeServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerConnectionFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GeviScopeServerDisconnectedEventArgs
  • aHost
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
  • aID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
  • aIgnoreRefs : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aIlluminator
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorCameraOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorGetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncUOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncVOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncXOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSpecFuncYOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorCameraOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorGetDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorLightOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncUOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncVOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncXOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSpecFuncYOnEventArgs
  • aInfoMessage
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsers
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
  • aInformDevices
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RescannRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeRequestToClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeActual
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTimeClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RescannRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeRequestToClientEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeActualEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeClientEventArgs
  • aInterfaceID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOffline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPOnline
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPQueryInterface
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOfflineEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPOnlineEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPQueryInterfaceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
  • aInternal1
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aInternal2
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aLevel
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::IlluminatorActions::GeViAct_IlluminatorSetDimLevel
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorDimLevelEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IlluminatorSetDimLevelEventArgs
  • aLocation
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
  • aLogText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessage , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageEventArgs
  • aMeasureTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
  • aMessageID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
  • aMessageInternal
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
  • aMessageName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformAllUsersMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_LogMessageMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawDataMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformAllUsersMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_LogMessageMSGEventArgs
  • aMGFrom
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
  • aMGID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmAcked
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmQuitted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmAckedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmQuittedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
  • aMGName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AckAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAlarmByMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_QuitAllAlarmsOnMG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AckAllAlarmsOnMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAlarmByMGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_QuitAllAlarmsOnMGEventArgs
  • aMGTo
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmCopied
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmMoved
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmCopiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmMovedEventArgs
  • aMinThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aMode
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
  • aModus : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
  • aMonitorGroup
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupDisable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupEnable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MonitorGroupStatusChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupDisableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupEnableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MonitorGroupStatusChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
  • aMonitorID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePause
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCyclePrev
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleResume
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraCycleStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleNextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePauseEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCyclePrevEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleResumeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraCycleStopEventArgs
  • aMscBlob : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • aMscDBGUID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
  • aMscEventID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • aMscEventName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aMscEventRef
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aMscEventTypeID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • aMscInt1 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • aMscInt2 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • aMscMessageKind
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
  • aMscServerID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
  • aMscServerName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StopMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscEventStopped
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerConnectFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnected
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscSetupModified
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscEventStoppedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerDisconnectedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscSetupModifiedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopMscEventEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_MscServerDisconnect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MscServerConnectFailedEventArgs
  • aMscStartKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MscIIActions::GeViAct_StartMscEvent , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartMscEventEventArgs
  • aNewMaster
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedChangeMasterEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedChangeMaster
  • aNewNumber : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs
  • aNumberOfMeasures : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
  • aOldMaster
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedMasterServerChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedMasterServerChangedEventArgs
  • aOldNumber : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs
  • aOtherCleared : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_AlarmDisplayedEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_AlarmDisplayed
  • aOutput
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
  • aPeriod : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
  • aPort
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
  • aPosition
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
  • aProfileID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
  • aProfileName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ActivateAssignmentProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ActivateAssignmentProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
  • aRawData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SendRawData , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SendRawDataEventArgs
  • aRAWData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
  • aReason
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
  • aResourceType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedirectResource , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedirectResourceEventArgs
  • aSavedPicture : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
  • aSecondsSinceStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
  • aSeq : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegInitSeq , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegInitSeqEventArgs
  • aServerHost
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
  • aState
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
  • aStatus
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30PMMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30PMModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
  • aSwitchMode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
  • aTemp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
  • aText
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
  • aThreshold
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdValueEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdValue
  • aTimeRangeName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeStarted
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeStartedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TimeRangeEndedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::TimeRangesActions::GeViAct_TimeRangeEnded
  • aTimerID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
  • aTimerName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StopTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_StartTimer
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StopTimerEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_StartTimerEventArgs
  • aTimeStamp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_HistoricalAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_HistoricalAlarmEventArgs
  • aTo
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
  • aToName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserMSGEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_InformUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_InformUserMSG
  • aTourID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
  • aTourName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTourStart , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTourStartEventArgs
  • aUnit
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP1
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP1EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableAFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPCableBFaultStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmRMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmRMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableBFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnRelaysOnOneZone
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureDisplaySegment
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPTurnARelayControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecurePM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPLUTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmPMTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmLUTamper
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureLUEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureDisplaySegmentEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliarySensor
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmPMTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmCable
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPCableAFaultState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPDisplaySegmentAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMComFailState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPPMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPRMTamperAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureAuxiliaryTP2
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureLU
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPSecureRM
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmCableEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmLUTamperEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPDisplaySegmentAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPLUTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPPMComFailStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPRMTamperStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliarySensorEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureAuxiliaryTP2EventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecureRMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnRelaysOnOneZoneEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPSecurePMEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPTurnARelayControlEventArgs
  • aUnitType
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliaryAlarmState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliarySensorStatusEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAuxiliarySensorStatus
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAlarmAuxiliaryInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MIPAuxiliaryAlarmStateEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::MIPActions::GeViAct_MIPAlarmAuxiliaryInput
  • aUp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmAckEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmQuitEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegAlarmStartEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MBegAlarmStart
  • aUser
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedConnectionMasterChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedConnectionMasterChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantUserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RedRedundantUserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RedRedundantLoginFailedEventArgs
  • aUser1
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
  • aUser2
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemSettingsChangedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLogoutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_UserLoginFailedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLoginFailed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogin
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemSettingsChanged
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_UserLogout
  • aUserID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_CopyActualAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_MoveAlarmByInstance
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::AlarmControlActions::GeViAct_PopUpAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpNextAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PopUpAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveActualAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MoveAlarmByInstanceEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
  • aUserName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DisconnectUserEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_RestoreRightProfileEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_DisconnectUser
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_RestoreRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_ChangeRightProfile
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ChangeRightProfileEventArgs
  • aVideoInput
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FastetModeOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraRAWOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncFailure
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisOpen
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosSaveEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraStopAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosClearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraVerOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastOkEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSmearAndWashOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoThresholdRequestEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_MBegLockCamera
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FastetModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmEndEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoSyncOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSelectCharModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomInEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanAuto
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDOutOfOrder
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraManualIrisOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltDownEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PrePosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncOkEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanLeft
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosCallUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_VideoThresholdRequest
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_MBegLockCameraEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmExternEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusNear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusFarEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PrePosSaveEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSVMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosClearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTestAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltDown
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSyncSignalDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisCloseEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraTextOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VS30VMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosCallUp
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusFar
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_PanRight
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanLeftEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDOutOfOrderEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VS30VMDMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetCameraText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_FocusStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoSyncFailureEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TiltStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomIn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecVFuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderEndEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraPumpOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoInputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraAutoFocusOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosClear
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSArmed
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToCommonOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraPumpOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoContrastOk
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecUFuncOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraClearPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomStopEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSetSensorMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPreAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_DefaultPosSave
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSChooseSavedPicture
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TiltUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSSyncSignalDetect
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_NormalModeOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_TakeCameraControl
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_TakeCameraControlEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraClearPrePosTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_DefaultPosCallUpEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_NormalModeOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetArmedEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSTestAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmInField
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPreAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSelectCharMode
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpecUFuncOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraVerOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ZoomOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_FocusNearEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_ZoomStop
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSpec1FuncOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraLightOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraAutoFocusOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraTextOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_IrisClose
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraStopAllEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoContrastAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSSetSensorOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOff
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSChooseSavedPictureEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSmearAndWashOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpec1FuncOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSRecorderEnd
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSTimerReset
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSetCameraTextEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSVMDModeEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraRAWOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSAlarmExtern
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanAutoEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraSpecVFuncOffEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSAlarmInFieldEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSRecorderTimerResetEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureDetectEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_PanRightEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraLightOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToCommonOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraManualIrisOn
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_IrisOpenEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CameraOnEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::CameraControlActions::GeViAct_CameraSetPrePosText
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
  • aVideoOutput
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoClearTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitch
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearVideoOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CrossSwitchWithAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_ClearAlarmFlagVideoOutputEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_VideoTextOut
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearAlarmFlagVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoTextOutEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_ClearVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CrossSwitchWithAlarmEventArgs
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VideoClearTextOutEventArgs
  • aVideoOutputFrom : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor
  • aVideoOutputTo : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SwitchControlActions::GeViAct_CopyCameraOnMonitor , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_CopyCameraOnMonitorEventArgs
  • aWarningCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
  • aWarningSubCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning
  • aWarningText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SystemWarning , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SystemWarningEventArgs
  • aWhichPicture : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_VSPictureToOutputEventArgs , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::VideoSensorActions::GeViAct_VSPictureToOutput
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • e
  • p
  • s

- e -

  • Effort : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • e
  • p
  • s

- p -

  • Params : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • Progress : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • a
  • e
  • p
  • s

- s -

  • sAccessible
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sAccessRights : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sAcked : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sAcknowledged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sActionData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sActionList : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
  • sActionText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sActive
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sActiveOnly
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
  • sActualCamera : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sActualCycle : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sActualPosition : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sActualTour : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sAlarmCounter : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sAlarmField : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sAlarmReference : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sAlarmRelation : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
  • sAlarmText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAlarmThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sAlarmTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sAlarmType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAlarmTypeDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAlarmTypeName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sAllAlarms : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
  • sArmed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sAutoPan : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sAVGThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sBasePK : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
  • sClient : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue
  • sClientDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
  • sClientDescription : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sClientFullName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sClientID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
  • sClientName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sClientType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sCompare
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
  • sContained : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
  • sContrastAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sContrastOK : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sContrastPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sCorrupt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sDefaultTour : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sDeletedActions : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • sDeletedAlarms : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DeletedEntries
  • sDescription
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sDisplayedOnFirstMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sDongleDllFound : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • sDongleKeyFound : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • sEnabled
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sEnabledOnly
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstVideoInputOfClient
  • sEntryNumber : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLoginInfo
  • sErrorCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
  • sErrorText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_DBError
  • ServerNotificationType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • sFirstMG : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sGlobalID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
  • sGMTTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sGscName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
  • sHandle
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetFirst
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_QueryHandle
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionList
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_GscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_AbortQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CloseQuery
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_DeleteAll
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetLast
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetNext
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_GetPrev
  • sHasAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sHasContrastDetection : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sHasPreAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sHasPTZHead : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sHasSyncDetection : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sHasVideoSensor : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
  • sIndex : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
  • sInstanceID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sInterfaceType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sIP : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • sLastThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sLicName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseValue
  • sLicString : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo
  • sLicValue : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseValue
  • sLicVersion : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetLicenseInfo
  • sLocalID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sLocalTime
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_LocalTime_LowEqu
  • sLoginCount : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientInfo
  • sMGDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupDesc , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupDesc
  • sMGID : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
  • sMGName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupName , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupName
  • sMinThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sMonitorGroupChanged : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sMscName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MscSystem
  • sName
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmsByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutputByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContactByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoInputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoOutputInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetClientByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroupByName
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInputByName
  • sNumberOfMeasures : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sPan : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sPeriod : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo
  • sPK
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_GrtEqu
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_Get
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_ActionEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_PK_LowEqu
  • sPKAlarm : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBQ_CreateActionQuery
  • sPort : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • sPreAlarmThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ContrastState
  • sPresentedAlarms : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_MonitorGroupInfo
  • sPresentedOnCount : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sPrevID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextAlarm
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoOutputOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextVideoInput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextInputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextOutputContactOfClient
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClient
  • sQuitted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sResID
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGByIndex
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarms
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetContrastState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetSyncState
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetAlarmOnMGInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetOutputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetPTZHeadInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoOutput
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetMonitorGroup
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoSensorInfo
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetInputContact
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetVideoInput
  • sSecondsSinceStart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sSecondUser : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ClientLoginInfo
  • sSegment : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
  • sSomeMscIIEvents : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sSQClientType : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetFirstClientOfType , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetNextClientOfType
  • sStarted : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmInfo
  • sStartMonitorGroup : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sStartMonitorGroupDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sStartMonitorGroupName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseAnswers::GeViDBA_AlarmEntry
  • sState : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
  • sSyncOK : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_SyncState , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_VideoSensorInfo
  • sText : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_Text
  • sThreshold : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sTilt : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_PTZHeadInfo
  • sTo
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
  • sTriggerTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_OutputContactInfo , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InputContactInfo
  • sTypeDesc : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeDesc
  • sTypeName : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeName
  • sUp
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_ActionKind
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_SenderID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_StartMonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_MonitorGroupID
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_TypeID
  • sVal1
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
  • sVal2
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
  • sVal3
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseTransferData
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicenseTransferData
  • sVal4 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_LicenseCall , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_LicensePrepareCall
  • sVideoInput : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateQueries::GeViSQ_GetThresholdValue , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_ThresholdInfo
  • sVisible : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_AlarmOnMGInfo
  • sWith
: GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithAck
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithQuit
, GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::DataBaseQueries::GeViDBF_WithMscIIRelation
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
  • Events
  • _
  • a
  • d
  • m
  • s
  • t

- _ -

  • _ActionCode : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • _ActionData : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData
  • _ActionKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViAction
  • _DBAnswerKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBAnswer
  • _DBQueryKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBQuery , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDBFilter
  • _DelegateInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • _MessageKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • _NativeCallback : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper
  • _NativeInstance : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper
  • _RecipientId : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • _SenderId : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • _StateAnswerKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateAnswer
  • _StateQueryKind : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViStateQuery

- a -

  • aDateAndTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::SystemActions::GeViAct_SyncTimeSetTime , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_SyncTimeSetTimeEventArgs

- d -

  • Data1 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • Data2 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • Data3 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • Data4 : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID
  • DatePart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime
  • dipsosed : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase

- m -

  • m_DBNotificationCallbackWrapper : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • m_Effort : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • m_GscAction : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::ActionDispatcher::GeViAct_GscActionEventArgs
  • m_NativeDatabaseHandle : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • m_NativeMessage : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViMessage
  • m_params : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs
  • m_Progress : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressEventArgs
  • m_sendQueryTimeout : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViDatabase
  • m_ServerNotification : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationEventArgs

- s -

  • sStartTime : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoDatabaseCreationTime , GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::StateAnswers::GeViSA_InfoServerStartTime

- t -

  • TimePart : GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime
Generated on Fri Dec 9 2011 11:15:59 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Fri Dec 9 2011 11:16:05 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy

Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViActionData
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData, including all inherited members.
_ActionData GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViActionData
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViGUID
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID, including all inherited members.
Data1 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID |
Data2 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID |
Data3 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID |
Data4 | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViGUID | [static]
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViSoftConnectProgressCallbackWrapper
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper, including all inherited members.
_DelegateInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper | [private]
_NativeCallback | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper | [private]
_NativeInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper | [private]
GetNativeCallback() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper |
GetNativeInstance() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper |
GeViSoftConnectProgressCallbackWrapper(GeViSoftConnectProgressDelegate^ instance, TGeViConnectProgress callback) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper |
Invoke() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper |
~GeViSoftConnectProgressCallbackWrapper() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftConnectProgressCallbackWrapper |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViSoftDatabaseNotificationCallbackWrapper
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper, including all inherited members.
_DelegateInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper | [private]
_NativeCallback | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper | [private]
_NativeInstance | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper | [private]
GetNativeCallback() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper |
GetNativeInstance() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper |
GeViSoftDatabaseNotificationCallbackWrapper(GeViSoftDatabaseNotificationDelegate^ instance, TGeViDatabaseNotification callback) | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper |
Invoke() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper |
~GeViSoftDatabaseNotificationCallbackWrapper() | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViSoftDatabaseNotificationCallbackWrapper |
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1


Geutebrueck GeViSoftSDK .NET Wrapper: Member List

  • GeViTGeViDateTime
GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime Member List
This is the complete list of members for GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime, including all inherited members.
DatePart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime
TimePart | GEUTEBRUECK::GeViSoftSDKNET::ActionsWrapper::GeViTGeViDateTime
Generated on Fri Dec 9 2011 11:16:00 for Geutebrueck GeViSoftSDK .NET Wrapper by doxygen 1.7.5.1