GSC actions: GSC actions

  • Main Page
  • Modules
  • Namespaces
  • Classes
  • Files

GSC actions

C++ interface version 2.95 from 05.09.2013

Introduction

This manual describes the action interface of the GeViScope system. We assume that you are already familiar with GscDBI which provides transport layer between PLC server and the client. Messages passing over GscDBI should be encoded to or decoded from its transport representation.

GscActions.dll provides interface for this purpose. GscActionsDlgs.dll provides additional interface for GUI clients.

Use Modules section to walk through this documentation.

GscActions.dll

This section collects general types and functions and explains the error handling.

Messages / actions

This section describes what messages are and how to use them.

Create / decode functions

Here you find the answer how to create or decode some particular action.

Enumeration

Types and functions used to enumerate action's info.

Dispatcher

Collection of dispatcher classes to simplify notification of the action.

GscActionsDlgs.dll

Additional means provided by this DLL.

Copyright (c) 2004 – 2010 Geutebrück GmbH. All rights reserved. This file was generated by Doxygen


GSC actions: Module Index

  • Classes
  • Files

Modules

Here is a list of all modules:
  • GscActions.dll
    • Basic types
    • General definitions
    • Error handling
    • Actions
      • ATM/ACS
        • ACS access denied
        • ACS access granted
        • ACS raw answer
        • ACS raw data
        • ATM raw answer
        • ATM raw data
        • ATM transaction
      • Audio control
        • ABC connect
        • ABC disconnect
        • ABC play file
        • Sensor audio alarm
      • Backup actions
        • Abort all auto backups
        • Abort auto backup
        • Auto backup capacity file auto deleted
        • Auto backup capacity out of disk space
        • Auto backup capacity warning
        • Auto backup file done
        • Auto backup file progress
        • Auto backup file started
        • Auto backup operation done
        • Auto backup operation started
        • Auto backup schedule done
        • Auto backup schedule started
        • Backup event
        • Event backup done
        • Event backup file done
        • Event backup file progress
        • Event backup file started
        • Event backup started
        • Start auto backup
      • Camera control
        • Auto focus off
        • Auto focus on
        • Camera RAW output
        • Camera apply profile
        • Camera backlight compensation mode
        • Camera clear preset text
        • Camera day/night mode
        • Camera light off
        • Camera light on
        • Camera manual iris off
        • Camera manual iris on
        • Camera off
        • Camera on
        • Camera pump off
        • Camera pump on
        • Camera select char mode
        • Camera set preset text
        • Camera spec func U off
        • Camera spec func U on
        • Camera spec func V off
        • Camera spec func V on
        • Camera spec func X off
        • Camera spec func X on
        • Camera spec func Y off
        • Camera spec func Y on
        • Camera stop all
        • Camera text off
        • Camera text on
        • Camera tour start
        • Camera tour stop
        • Camera version off
        • Camera version on
        • Camera wash-wipe off
        • Camera wash-wipe on
        • Clear default position
        • Clear preset position
        • Fast speed off
        • Fast speed on
        • Focus far
        • Focus near
        • Focus stop
        • Iris close
        • Iris open
        • Iris stop
        • Move by speed
        • Move to absolute position
        • Move to default position
        • Move to preset position
        • Move to relative position
        • Pan auto
        • Pan left
        • Pan right
        • Pan stop
        • Save default position
        • Save preset position
        • Set camera text
        • Tilt down
        • Tilt stop
        • Tilt up
        • Zoom in
        • Zoom out
        • Zoom stop
      • Cash management actions
        • Safebag close
        • Safebag data
        • Safebag open
        • Safebag passing of risk data
        • Safebag passing of risk start
        • Safebag passing of risk stop
      • Device information
        • Device found
        • Device plugin error
        • Device plugin state
        • Device reattached
        • Device removed
        • New firmware received
      • Digital contacts
        • Case has been closed
        • Case has been opened
        • Digital input
        • IOI43 reset mainboard
        • IOI43 temperature notification
        • IOI43 watchdog activate
        • IOI43 watchdog deactivate
        • IOI43 watchdog trigger
        • Key pressed
        • Key released
        • Reset mainboard
        • Set digital output
        • Set system LED
        • Set system LED to blink
        • Temperature notification
        • Watchdog activate
        • Watchdog deactivate
        • Watchdog trigger
      • Imex
        • Imex capacity file auto deleted
        • Imex capacity out of disk space.
        • Imex capacity warning
        • Imex export event image
        • Imex export image from DB
        • Imex export image from live stream
      • LPS
        • LPS position data
        • LPS query position
      • Lenel
        • Lenel access event
        • Lenel fire event
        • Lenel intercom event
        • Lenel raw data
        • Lenel refresh names
        • Lenel security event
        • Lenel video event
      • POS
        • Barcode data
        • Filling pump status
        • Interface raw answer
        • Interface raw data
        • POS data
        • POS status
        • Terminal article data
        • Terminal payment data
      • Perimeter protection
        • PP device alarm
        • PP device input
        • PP device offline
        • PP device online
        • PP interface offline
        • PP interface online
        • PP query interface
        • PP set device output
        • PP subcell alarm
        • PP zone alarm
      • Remote export
        • Cancel export
        • Export finished
        • Export progress
        • Initialize remote export
        • Set export marker
        • Start remote export
        • Start scene store
      • SKIDATA
        • SKIDATA control
        • SKIDATA device event
        • SKIDATA entry
        • SKIDATA exit
        • SKIDATA transaction
      • Supply chain security
        • GSCS vehicle access denied
        • GSCS vehicle access expired
        • GSCS vehicle access granted
        • GSCS vehicle access pending
        • Log NPR recognition
        • Log barcode data
        • Log barcode data LPS
      • System actions
        • Blocking filter activate
        • Blocking filter deactivate
        • Custom action
        • Database recording info per ring
        • Database recording info total
        • Database started
        • Event recording changed
        • Event started
        • Event stopped
        • FRC notification
        • GEMOS alarm
        • IP switch operation
        • Kill all events
        • Kill event
        • Kill event by instance
        • Live check
        • Redundant power failure
        • Redundant power ok
        • SMRP viewer cleared
        • SMRP viewer connected
        • SMTP mail
        • Set clock
        • Set watchdog
        • Setup changed
        • Setup upload progress
        • Start event
        • Stop all events
        • Stop event
        • Stop event by instance
        • System error
        • System info
        • System settings changed
        • System started
        • System terminating
        • System warning
        • Transfer binary buffer
        • Transfer binary channel buffer
        • User login
        • User login failed
        • User logout
      • Video control
        • Activate external process
        • CPA measurement
        • Change AD parameter set
        • Change CPA parameter set
        • Change GTectVMX parameter set
        • Change OBTRACK parameter set
        • Change VMD parameter set
        • Change camera profile
        • Channel error
        • Channel info
        • Channel live check
        • Channel warning
        • Enable client VCA
        • G-Tect analytics live check
        • G-Tect scene alarm
        • G-Tect scene alarm finished
        • G-Tect/Dual sensor alarm
        • G-Tect/Dual sensor alarm finished
        • G-Tect/VMX alarm
        • G-Tect/VMX alarm finished
        • IAS settings changed
        • IP camera failover notification
        • IP camera failover restore
        • IP camera raw command
        • Make CPA reference image
        • Media channel setup
        • NPR raw data
        • NPR recognition
        • OBTRACK channel counter
        • OBTRACK channel counter threshold
        • OBTRACK channel set counter
        • OBTRACK frame raw data
        • OBTRACK group counter
        • OBTRACK group counter threshold
        • OBTRACK group set counter
        • OBTRACK object raw data
        • OBTRACK tunnel alarm
        • Sensor alarm finished
        • Sensor inhibit alarm finished
        • Sensor inhibit video alarm
        • Sensor video alarm
        • Set system time
        • Set test picture mode
        • VCA set armed
        • VCA status answer
        • VCA status request
        • Video contrast detected
        • Video contrast failed
        • Video set image brightness
        • Video set image contrast
        • Video set image saturation
        • Video source has changed
        • Video sync detected
        • Video sync failed
      • Viewer actions
        • VC alarm queue confirm
        • VC alarm queue confirm by instance
        • VC alarm queue confirm by type
        • VC alarm queue remove
        • VC alarm queue remove by instance
        • VC alarm queue remove by type
        • VC alarm queue select
        • VC alarm queue select by instance
        • VC alarm queue select by type
        • VC change scene by name
        • VC clear scene by name
        • VC full mode
        • VC set audio level
        • VC show viewer text
        • VC stretch mode
        • Viewer change scene
        • Viewer change sync audio/video
        • Viewer clear
        • Viewer clear scene
        • Viewer clear text output
        • Viewer connect
        • Viewer connect live
        • Viewer export picture
        • Viewer jump by time
        • Viewer maximize
        • Viewer play from time
        • Viewer print picture
        • Viewer select
        • Viewer set play mode
        • Viewer show alarm by instance
        • Viewer show alarm by key
        • Viewer show alarm by type
        • Viewer text output
      • Viewer notifications
        • Image export notification
        • Scene store modification
        • VC alarm queue notification
        • VC scene changed
        • Viewer cleared
        • Viewer connected
        • Viewer play mode changed
        • Viewer selection changed
  • Messages / actions
    • Message classes
    • Message functions
    • Action functions
    • Match action functions
    • Output operators
  • Create / decode functions
    • Functions to create GSC actions
    • Functions to decode GSC actions
  • Enumeration
    • Basic enumeration
    • Enumerate action classes
    • Enumerate actions
    • Enumerate action parameters
    • Enumerate enum values
    • Access by name
  • Dispatcher
    • Using virtual functions
  • GscActionsDlgs.dll
    • General definitions
    • Working with buffers
    • Conversion functions
    • Dialog functions
    • Enumeration classes
    • Sources of built-in dialog
      • GscActionsDialog.dfm
      • GscActionsDialog.h
      • GscActionsDialog.cpp
  • GscPlcEvents


GSC actions: GscActions.dll

Modules

GscActions.dll

Collaboration diagram for GscActions.dll:

Detailed Description

This section collects information on basic types of GscActions.dll like GscMessageClass or GscActionClass.

GscActionCode contains a list of all available actions in GeViScope system.

Here one can find also the general information about interface: its version and release date as well as functions to query this information. Last but one module explains the error handling.

At the last you will find here the list of all actions.

Modules

Basic types

Basic types for GscActions and GscActionsDlgs DLLs.

General definitions

General definitions for GscActions.DLL.

Error handling

Error handling for GscActions.DLL.

Actions

List of all actions.


GSC actions: Basic types

Classes | Typedefs | Enumerations | Variables

Basic types
[GscActions.dll]

Collaboration diagram for Basic types:

Detailed Description

Basic types for GscActions and GscActionsDlgs DLLs.

Basic types and definitions.

   #include "GscActionsTypes.h"
   using namespace GscPLC;

Important types

Message class | GscMessageClass
This data type is used to classify GeViScope messages. Depending on the class of the message one has access to additional information. GeViScope uses following message classes: actions used to transfer information between client and server, match actions represent test conditions which are used to trigger some reactions.
Use GscAct_GetMessageClass or CGscMessage::GetMessageClass to access this information
Action class | GscActionClass
This data type is used to group similar actions, like system actions, video control, etc.
Use GscAct_GetActionClass or CGscAction::GetActionClass to access this information
Action code | GscActionCode
Represents type of the action, like user login.
Use GscAct_GetActionCode or CGscAction::GetActionCode to access this information
Parameter type | GscParameterType
This enumeration type is used to denote type of the action's parameters, e.g. in TGscParameterInfo. This information is useful to build dialogs where the user can fill action parameters in a form.
Parameter view | GscParameterType
This enumeration type is used to denote the role of the action's parameters, like "this string represents a \ref pv_UserName "user name"". This information can be used together with parameter type to prepare lists of available values in dialog windows.

Classes

struct | TPlcMediaChannelID
Media channel. More...
struct | TPlcEventTypeID
Event type. More...
struct | TPlcResourceID
Resource ID. More...
struct | TPlcRect
PLC rect. More...
struct | TPlcUpdateActionInfoCallback
update callback definition More...

Typedefs

typedef enum TPlcDigitalInputState | DigitalInputState
State of the digital input contact.
typedef enum TPlcDigitalOutputState | DigitalOutputState
State of the digital output contact.
typedef enum TPlcVideoSignalNorm | VideoSignalNorm
Norm of the video input signal.
typedef enum TPlcVideoSignalType | VideoSignalType
Type of the video input signal.
typedef enum TPlcVideoInterlaceType | VideoInterlaceType
Interlace kind of the video input signal.
typedef enum TPlcADArea | ADArea
Activity detection area.
typedef enum TPlcVMDGroup | VMDGroup
VMD group.
typedef enum TPlcSystemLED | SystemLED
System LED.
typedef enum TPlcVideoSensorKind | VideoSensorKind
Video sensor type.
typedef enum
TPlcUserLoginFailureCode 		UserLoginFailureCode
User login failure code.
typedef enum TPlcPlcMessageSource | PlcMessageSource
Source of the message.
typedef enum TPlcPlcMessageCode | PlcMessageCode
Code of the message.
typedef enum
TPlcPlcViewerAlarmQueueSelection 		PlcViewerAlarmQueueSelection
Viewer alarm queue selection mode.
typedef enum TPlcABCapacityWarning | ABCapacityWarning
Auto backup capacity monitoring warning.
typedef enum
TPlcPlcObtrackObjectStatus 		PlcObtrackObjectStatus
OBTRACK object status.
typedef enum
TPlcPlcObtrackObjectClass 		PlcObtrackObjectClass
OBTRACK object class.
typedef enum TPlcPlcDatabaseStatus | PlcDatabaseStatus
Database status.
typedef enum
TPlcPlcObtrackProcessSize 		PlcObtrackProcessSize
OBTRACK process size.
typedef enum TPlcSystemKey | SystemKey
GEVISCOPE system key.
typedef enum TPlcVMDCycle | VMDCycle
VMD measure cycle.
typedef enum TPlcSafebagStep | SafebagStep
Safebag step.
typedef enum
TPlcPlcObtrackCounterType 		PlcObtrackCounterType
OBTRACK counter type.
typedef enum
TPlcPlcObtrackExceedingDirection 		PlcObtrackExceedingDirection
OBTRACK exceeding direction.
typedef enum
TPlcPlcTunnelAlarmReason 		PlcTunnelAlarmReason
Tunnel alarm reason.
typedef enum TPlcPlcViewerPlayMode | PlcViewerPlayMode
Viewer play mode.
typedef enum
TPlcPlcViewerAlarmPlayMode 		PlcViewerAlarmPlayMode
Viewer alarm play mode.
typedef enum
TPlcPlcViewerAlarmState 		PlcViewerAlarmState
Viewer alarm state notification.
typedef enum TPlcPlcImageExportType | PlcImageExportType
Image export type.
typedef enum TPlcPlcDatabaseRing | PlcDatabaseRing
Database ring.
typedef enum TPlcPlcPluginError | PlcPluginError
Plugin error code.
typedef enum TPlcPlcClientType | PlcClientType
Client type.
typedef enum TPlcPlcFRCNotification | PlcFRCNotification
FRC notification.
typedef enum TPlcPlcResourceKind | PlcResourceKind
PLC resource kind.
typedef enum
TPlcPlcResourceChangeKind 		PlcResourceChangeKind
PLC resource change kind.
typedef enum TPlcPlcPOSStatus | PlcPOSStatus
PLC POS status.
typedef enum TPlcPlcNPRRestriction | PlcNPRRestriction
PLC POS status.
typedef enum
TPlcPlcSpecialConstants 		PlcSpecialConstants
Special constants.
typedef enum TPlcPlcPluginState | PlcPluginState
Plugin state.
typedef enum TPlcPlcPumpStatus | PlcPumpStatus
PLC pump status.
typedef enum TPlcPlcDayNightMode | PlcDayNightMode
Day/night mode.
typedef enum TPlcPlcBacklightMode | PlcBacklightMode
Backlight compensation mode.
typedef enum TPlcPlcSkidataControl | PlcSkidataControl
SKIDATA control message.
typedef enum
TPlcPlcSkidataMsgCodeEntry 		PlcSkidataMsgCodeEntry
SKIDATA message entry.
typedef enum
TPlcPlcSkidataMsgCodeExit 		PlcSkidataMsgCodeExit
SKIDATA message exit.
typedef enum
TPlcPlcSkidataMsgCodeTransaction 		PlcSkidataMsgCodeTransaction
SKIDATA message transaction.
typedef enum TPlcPlcExportMarker | PlcExportMarker
Export marker.
typedef enum TPlcPlcBackupFormat | PlcBackupFormat
Backup format.
typedef enum TPlcPlcExportSuccess | PlcExportSuccess
Export success state.
typedef enum TPlcPlcExportAbort | PlcExportAbort
Export abort flag.
typedef enum TPlcPlcLpsStatus | PlcLpsStatus
Position query status.
typedef enum
TPlcPlcSceneStoreModificationType 		PlcSceneStoreModificationType
Scene store modification type.
typedef enum
TPlcGTectSceneAlarmReason 		GTectSceneAlarmReason
G-Tect alarm reason.
typedef enum TPlcGTectClientVCAType | GTectClientVCAType
G-Tect client VCA type.
typedef enum TPlcLenelAccessResult | LenelAccessResult
Lenel access result.
typedef enum TPlcLenelEventType | LenelEventType
Lenel event type.
typedef enum TPlcLenelEventID | LenelEventID
Lenel event ID.
typedef enum TPlcIODeviceType | IODeviceType
Specifies the type of the io device.
typedef enum TPlcTrafficDirection | TrafficDirection
Traffic direction.
typedef enum TPlcPPAlarmState | PPAlarmState
PP alarm state.
typedef enum TPlcPPCableKind | PPCableKind
PP cable kind.
typedef enum TPlcPPSensorKind | PPSensorKind
PP sensor kind.
typedef enum TPlcIPSwitchOps | IPSwitchOps
IP switch operation.
typedef TPlcResourceID | TPlcTimeRangeID
compatibility definitions
typedef bool(__stdcall * | TUpdateMediaChannelID )(void *Object, TPlcMediaChannelID &Info)
update media channel callback
typedef bool(__stdcall * | TUpdateEventTypeID )(void *Object, TPlcEventTypeID &Info)
update event type callback
typedef bool(__stdcall * | TUpdateResourceID )(void *Object, GscParameterView ParameterView, TPlcResourceID &Info)
update resource ID callback
typedef bool(__stdcall * | TUpdateResChannelID )(void *Object, GscParameterView ParameterView, TPlcResourceID &Info, __int64 &Channel)
update resource ID and channel callback

Enumerations

enum | GscMessageClass { mk_Action = 1, mk_MatchAction = 2, mk_Unknown = 0x7fffffff }

Available message classes.

More...
enum GscActionClass {
ak_System = 0, ak_Video = 1, ak_Audio = 2, ak_CameraControl = 3,
ak_DigitalContacts = 4, ak_Device = 5, ak_ATM = 6, ak_Backup = 7,
ak_CashManagement = 8, ak_Viewer = 9, ak_ViewerNotification = 10, ak_POS = 11,
ak_RemoteExport = 12, ak_SkiData = 13, ak_LPS = 14, ak_Logistic = 15,
ak_Lenel = 16, ak_Imex = 17, ak_PP = 18, ak_Unknown = 0x7fffffff
}

Available action classes.

More...
enum GscActionCode {
ac_SystemStarted = 1, ac_SystemTerminating = 2, ac_UserLogin = 3, ac_UserLoginFailed = 4,
ac_UserLogout = 5, ac_SystemSettingsChanged = 6, ac_LiveCheck = 7, ac_CustomAction = 8,
ac_DatabaseStarted = 9, ac_DeviceFound = 10, ac_DeviceRemoved = 11, ac_DeviceNewFirmware = 12,
ac_DeviceReattached = 13, ac_DevicePluginError = 14, ac_DevicePluginState = 15, ac_SetupUploadProgress = 16,
ac_SetupChanged = 17, ac_FRCNotification = 19, ac_SensorAudioAlarm = 20, ac_ABCConnect = 21,
ac_ABCDisconnect = 22, ac_ABCPlayFile = 23, ac_SetClock = 25, ac_DigitalInput = 30,
ac_SetDigitalOutput = 31, ac_SetLED = 32, ac_SetLEDBlink = 33, ac_KeyPressed = 35,
ac_KeyReleased = 36, ac_RedundantPowerFailure = 37, ac_RedundantPowerOk = 38, ac_VideoSyncDetected = 40,
ac_VideoSyncFailed = 41, ac_ChangeADParameterSet = 42, ac_ChangeVMDParameterSet = 43, ac_ChangeCPAParameterSet = 44,
ac_VideoSourceChanged = 45, ac_VideoContrastDetected = 46, ac_VideoContrastFailed = 47, ac_MakeCPAReferenceImage = 48,
ac_IASSettingsChanged = 49, ac_SystemInfo = 50, ac_SystemWarning = 51, ac_SystemError = 52,
ac_SetWatchdog = 53, ac_StartEvent = 54, ac_StopEvent = 55, ac_StopEventByID = 56,
ac_EventStarted = 59, ac_EventStopped = 60, ac_EventRecordingChanged = 61, ac_StopAllEvents = 62,
ac_KillEvent = 63, ac_KillEventByID = 64, ac_KillAllEvents = 65, ac_BlockingFilterActivate = 68,
ac_BlockingFilterDeactivate = 69, ac_CPAMeasurement = 70, ac_SetTestPictureMode = 72, ac_ChannelLiveCheck = 74,
ac_IPCameraRawCommand = 75, ac_SensorVideoAlarm = 80, ac_SensorInhibitVideoAlarm = 81, ac_SensorAlarmFinished = 84,
ac_SensorInhibitAlarmFinished = 85, ac_ChangeObtrackParameterSet = 90, ac_ObtrackFrameRawData = 91, ac_ObtrackObjectRawData = 92,
ac_ObtrackChannelCounter = 94, ac_ObtrackGroupCounter = 95, ac_ObtrackChannelCounterThreshold = 96, ac_ObtrackGroupCounterThreshold = 97,
ac_ObtrackChannelSetCounter = 98, ac_ObtrackGroupSetCounter = 99, ac_PanRight = 101, ac_PanLeft = 102,
ac_PanStop = 103, ac_TiltUp = 104, ac_TiltDown = 105, ac_TiltStop = 106,
ac_ZoomIn = 107, ac_ZoomOut = 108, ac_ZoomStop = 109, ac_FocusNear = 110,
ac_FocusFar = 111, ac_FocusStop = 112, ac_IrisOpen = 113, ac_IrisClose = 114,
ac_IrisStop = 115, ac_PrePosCallUp = 116, ac_DefaultPosCallUp = 117, ac_CameraTourStart = 118,
ac_CameraTourStop = 119, ac_CameraLightOn = 120, ac_CameraLightOff = 121, ac_CameraOn = 122,
ac_CameraOff = 123, ac_CameraPumpOn = 124, ac_CameraPumpOff = 125, ac_FastSpeedOn = 126,
ac_FastSpeedOff = 127, ac_CameraWashOn = 128, ac_CameraWashOff = 129, ac_CameraSpecFuncUOn = 130,
ac_CameraSpecFuncUOff = 131, ac_CameraSpecFuncVOn = 132, ac_CameraSpecFuncVOff = 133, ac_CameraSpecFuncXOn = 134,
ac_CameraSpecFuncXOff = 135, ac_CameraSpecFuncYOn = 136, ac_CameraSpecFuncYOff = 137, ac_CameraStopAll = 138,
ac_PrePosSave = 139, ac_DefaultPosSave = 140, ac_PrePosClear = 141, ac_DefaultPosClear = 142,
ac_SetCameraText = 143, ac_CameraSelectCharMode = 144, ac_CameraClearPrePosText = 145, ac_CameraSetPrePosText = 146,
ac_CameraRAWOutput = 147, ac_CameraVersionOn = 148, ac_CameraVersionOff = 149, ac_PanAuto = 150,
ac_AutoFocusOn = 151, ac_AutoFocusOff = 152, ac_CameraManualIrisOn = 153, ac_CameraManualIrisOff = 154,
ac_CameraTextOn = 155, ac_CameraTextOff = 156, ac_CameraDayNightMode = 157, ac_CameraBacklightCompensationMode = 158,
ac_CameraApplyProfile = 159, ac_MoveToAbsolutePosition = 160, ac_MoveToRelativePosition = 161, ac_MoveToBySpeed = 162,
ac_ChannelInfo = 180, ac_ChannelWarning = 181, ac_ChannelError = 182, ac_IPSwitchOperation = 190,
ac_ViewerConnectLive = 200, ac_ViewerConnect = 201, ac_ViewerClear = 202, ac_ViewerConnected = 203,
ac_ViewerCleared = 204, ac_ViewerPlayModeChanged = 205, ac_ViewerChangeScene = 206, ac_VCChangeSceneByName = 207,
ac_ViewerClearScene = 208, ac_VCClearSceneByName = 209, ac_ViewerShowAlarmByInstance = 210, ac_ViewerShowAlarmByKey = 211,
ac_ViewerShowAlarmByType = 212, ac_VCSceneChanged = 213, ac_ViewerJumpByTime = 215, ac_ViewerPlayFromTime = 216,
ac_ViewerSetPlayMode = 217, ac_ViewerSyncAudioAndVideo = 220, ac_VCSetAudioLevel = 221, ac_ViewerMaximize = 222,
ac_ViewerExportPicture = 223, ac_ViewerPrintPicture = 224, ac_ImageExportNotification = 225, ac_ViewerSelect = 230,
ac_VCShowViewerText = 231, ac_VCFullMode = 232, ac_VCStretchMode = 233, ac_ViewerTextOutput = 240,
ac_ViewerClearTextOutput = 241, ac_ViewerSelectionChanged = 242, ac_SceneStoreModification = 243, ac_VCAlarmQueueSelect = 250,
ac_VCAlarmQueueSelectByType = 251, ac_VCAlarmQueueConfirm = 252, ac_VCAlarmQueueConfirmByType = 253, ac_VCAlarmQueueRemove = 254,
ac_VCAlarmQueueRemoveByType = 255, ac_VCAlarmQueueSelectByInstance = 256, ac_VCAlarmQueueConfirmByInstance = 257, ac_VCAlarmQueueRemoveByInstance = 258,
ac_VCAlarmQueueNotification = 259, ac_DatabaseRecordingInfoTotal = 260, ac_DatabaseRecordingInfoRing = 263, ac_AutoBackupCapacityMonitoringOutOfDiskSpace = 270,
ac_AutoBackupCapacityMonitoringCapacityWarning = 272, ac_AutoBackupCapacityMonitoringFileAutoDeleted = 274, ac_StartAutoBackup = 280, ac_BackupEvent = 281,
ac_AutoBackupScheduleStarted = 282, ac_AutoBackupScheduleDone = 284, ac_AutoBackupOperationStarted = 286, ac_AutoBackupOperationDone = 288,
ac_AutoBackupFileStarted = 290, ac_AutoBackupFileProgress = 292, ac_AutoBackupFileDone = 294, ac_AbortAutoBackup = 298,
ac_AbortAllAutoBackups = 299, ac_GEMOSalarm = 300, ac_ObtrackTunnelAlarm = 301, ac_SMTPMailSend = 303,
ac_EventBackupStarted = 310, ac_EventBackupDone = 312, ac_EventBackupFileStarted = 314, ac_EventBackupFileProgress = 316,
ac_EventBackupFileDone = 318, ac_ChangeCameraProfile = 330, ac_SMRPViewerConnected = 340, ac_SMRPViewerCleared = 341,
ac_ATMRawData = 350, ac_ATMRawAnswer = 351, ac_ATMTransaction = 352, ac_ACSRawData = 354,
ac_ACSRawAnswer = 355, ac_ACSAccessGranted = 356, ac_ACSAccessDenied = 357, ac_InterfaceRawData = 358,
ac_InterfaceRawAnswer = 359, ac_POSStatus = 360, ac_POSData = 361, ac_TerminalArticleData = 363,
ac_TerminalPaymentData = 364, ac_BarcodeData = 365, ac_FillingPumpStatus = 366, ac_ActivateExternalProcess = 370,
ac_NPRRawData = 371, ac_NPRRecognition = 375, ac_TransferBinaryBuffer = 380, ac_TransferBinaryChannelBuffer = 381,
ac_SetSystemTime = 385, ac_VideoSetImageContrast = 390, ac_VideoSetImageBrightness = 391, ac_VideoSetImageSaturation = 392,
ac_MediaChannelSetupInfo = 395, ac_SafebagOpen = 400, ac_SafebagData = 402, ac_SafebagClose = 405,
ac_SafebagPassingOfRiskStart = 407, ac_SafebagPassingOfRiskData = 410, ac_SafebagPassingOfRiskStop = 413, ac_IOI43WDActivate = 420,
ac_IOI43WDDeactivate = 421, ac_IOI43WDTrigger = 422, ac_IOI43ResetMainboard = 423, ac_IOI43Temperature = 424,
ac_SkidataControl = 430, ac_SkidataEntry = 431, ac_SkidataExit = 432, ac_SkidataTransaction = 433,
ac_SkidataDeviceEvent = 434, ac_WatchdogActivate = 440, ac_WatchdogDeactivate = 441, ac_WatchdogTrigger = 442,
ac_Temperature = 443, ac_ResetMainboard = 444, ac_CaseOpened = 445, ac_CaseClosed = 446,
ac_SetExportMarker = 450, ac_InitializeRemoteExport = 451, ac_StartRemoteExport = 452, ac_ExportProgress = 454,
ac_ExportFinished = 455, ac_CancelExport = 456, ac_StartSceneStore = 457, ac_LPSPositionData = 460,
ac_LPSQueryPosition = 463, ac_LogBarcodeData = 465, ac_LogBarcodeDataLPS = 467, ac_LogNPRRecognition = 469,
ac_GSCSVehicleAccessDenied = 480, ac_GSCSVehicleAccessGranted = 482, ac_GSCSVehicleAccessExpired = 484, ac_GSCSVehicleAccessPending = 486,
ac_LenelSecurityEvent = 500, ac_LenelAccessEvent = 502, ac_LenelIntercomEvent = 506, ac_LenelVideoEvent = 508,
ac_LenelFireEvent = 510, ac_LenelRawData = 512, ac_LenelRefreshNames = 514, ac_GTectVMXAlarm = 520,
ac_GTectVMXAlarmFinished = 522, ac_GTectDualSensorAlarm = 524, ac_GTectDualSensorAlarmFinished = 526, ac_GTectSceneAlarm = 528,
ac_GTectSceneAlarmFinished = 530, ac_GTectAnalyticsLiveCheck = 532, ac_ChangeGTectParameterSet = 534, ac_SetClientVCA = 536,
ac_VCASetArmed = 537, ac_VCAStatusRequest = 538, ac_VCAStatusAnswer = 539, ac_IPCamFailoverNotification = 540,
ac_IPCamFailoverRestore = 541, ac_ImexCapacityWarning = 550, ac_ImexCapacityOutOfDiskSpace = 552, ac_ImexCapacityFileAutoDeleted = 554,
ac_ImexExportImageFromDB = 560, ac_ImexExportEventImage = 562, ac_ImexExportImageFromLiveStream = 564, ac_PPSubcellAlarm = 580,
ac_PPDeviceAlarm = 581, ac_PPZoneAlarm = 582, ac_PPDeviceInput = 583, ac_PPSetDeviceOutput = 584,
ac_PPQueryInterface = 585, ac_PPInterfaceOnline = 586, ac_PPInterfaceOffline = 587, ac_PPDeviceOnline = 588,
ac_PPDeviceOffline = 589, ac_Unknown = 0x7fffffff
}

Available action codes.

More...
enum | TPlcDigitalInputState { disLow = 0, disMiddle = 1, disHigh = 2, disUnknown = 0x7fffffff }

State of the digital input contact.

More...
enum | TPlcDigitalOutputState { dosOpen = 0, dosClose = 1, dosToggle = 2, dosUnknown = 0x7fffffff }

State of the digital output contact.

More...
enum | TPlcVideoSignalNorm { vsnEIA = 0, vsnCCIR = 1, vsnUnknown = 0x7fffffff }

Norm of the video input signal.

More...
enum | TPlcVideoSignalType { vstBAS = 0, vstFBAS = 1, vstUnknown = 0x7fffffff }

Type of the video input signal.

More...
enum | TPlcVideoInterlaceType { vsdInterlaced = 0, vsdNonInterlaced = 1, vsdUnknown = 0x7fffffff }

Interlace kind of the video input signal.

More...
enum TPlcADArea {
adgArea1 = 0, adgArea2 = 1, adgArea3 = 2, adgArea4 = 3,
adgUnknown = 0x7fffffff
}

Activity detection area.

More...
enum TPlcVMDGroup {
vmgGroup1 = 0, vmgGroup2 = 1, vmgGroup3 = 2, vmgGroup4 = 3,
vmgUnknown = 0x7fffffff
}

VMD group.

More...
enum TPlcSystemLED {
ledError = 0, ledRecord = 1, ledGreen = 2, ledYellow = 3,
ledIOI43a1 = 9, ledIOI43a2 = 10, ledIOI43a3 = 11, ledIOI43a4 = 12,
ledUnknown = 0x7fffffff
}

System LED.

More...
enum TPlcVideoSensorKind {
vskAD = 0, vskVMD = 1, vskCPA = 2, vskIPAD = 3,
vskOBTRACK = 4, vskDUAL = 5, vskNPR = 6, vskFR = 7,
vskVAMissing = 8, vskCPAExt = 9, vskGTectVMX = 10, vskUnknown = 0x7fffffff
}

Video sensor type.

More...
enum TPlcUserLoginFailureCode {
ulfUser1NotFound = 1, ulfUser1InvalPwd = 2, ulfUser2NotFound = 3, ulfUser2InvalPwd = 4,
ulfMissingSecondUser = 5, ulfUser2NotAdmitted = 6, ulfNoLicense = 7, ulfTooManyClients = 8,
ulfUnknown = 0x7fffffff
}

User login failure code.

More...
enum TPlcPlcMessageSource {
pmsServer = 0, pmsSetup = 1, pmsDBE = 2, pmsMediaAPI = 3,
pmsMediaPlugin = 4, pmsPLC = 5, pmsAutoBackup = 6, pmsDongle = 7,
pmsFRC = 8, pmsATM = 9, pmsSensor = 10, pmsPOS = 11,
pmsACS = 12, pmsIOI43 = 13, pmsInterface = 14, pmsTranscoder = 15,
pmsLenel = 16, pmsLogistic = 17, pmsLPS = 18, pmsSCS = 19,
pmsVAM = 20, pmsMIO = 21, pmsPP = 22, pmsUnknown = 0x7fffffff
}

Source of the message.

More...
enum TPlcPlcMessageCode {
pmcInternalError = 0, pmcOutOfResources = 1, pmcUnlicensed = 2, pmcConnectionLost = 3,
pmcUnknownError = 4, pmcDemoModeExpired = 5, pmcDatabaseFileMissing = 10, pmcFileAccessError = 11,
pmcFLTMInefficient = 12, pmcDBECouldNotFreeAnyPage = 13, pmcDongleFound = 20, pmcDongleMissing = 21,
pmcDongleWrong = 22, pmcDongleInsufficient = 23, pmcFirmwareUploadFailed = 30, pmcWatchdogReset = 31,
pmcHttpError = 35, pmcHostRestrictions = 36, pmcInsufficientFrameRate = 40, pmcTranscoderOverload = 41,
pmcNoControlForLongTime = 50, pmcBehaviouralRuleTooDeep = 51, pmcCannotOpenPort = 61, pmcCannotEnumeratePorts = 62,
pmcCannotSetFilter = 63, pmcDataOverflow = 64, pmcInsufficientData = 65, pmcIODeviceFound = 70,
pmcIODeviceLost = 71, pmcIODeviceNotFound = 72, pmcIOTemperatureBelow = 73, pmcIOTemperatureAbove = 74,
pmcIODriverNotInstalled = 75, pmcIOCannotEnumerate = 76, pmcIOCannotOpen = 77, pmcIODuplcatedAddress = 78,
pmcIOUnusedDevice = 79, pmcUnknown = 0x7fffffff
}

Code of the message.

More...
enum TPlcPlcViewerAlarmQueueSelection {
aqsFirst = 0, aqsLast = 1, aqsNext = 2, aqsPrevious = 3,
aqsUnknown = 0x7fffffff
}

Viewer alarm queue selection mode.

More...
enum TPlcABCapacityWarning {
abwOk = 0, abwFreeCapacityBelowLimit = 1, abwAllocatedCapacityAboveLimit = 2, abwBoth = 3,
abwUnknown = 0x7fffffff
}

Auto backup capacity monitoring warning.

More...
enum TPlcPlcObtrackObjectStatus {
oosStarting = 0, oosStationary = 1, oosLeaving = 2, oosUndefined = 3,
oosDeleted = 4, oosUnknown = 0x7fffffff
}

OBTRACK object status.

More...
enum | TPlcPlcObtrackObjectClass { oocPerson = 0, oocCar = 1, oocUndefined = 2, oocUnknown = 0x7fffffff }

OBTRACK object class.

More...
enum | TPlcPlcDatabaseStatus { dbsEmpty = 0, dbsReady = 1, dbsFileAdded = 2, dbsUnknown = 0x7fffffff }

Database status.

More...
enum | TPlcPlcObtrackProcessSize { opsCIF = 0, opsFourCIF = 1, opsTakeWhatYouGet = 2, opsUnknown = 0x7fffffff }

OBTRACK process size.

More...
enum TPlcSystemKey {
keyDisplay1 = 0, keyDisplay2 = 1, keyDisplay3 = 2, keyDisplay4 = 3,
keyReporter1 = 256, keyUnknown = 0x7fffffff
}

GEVISCOPE system key.

More...
enum TPlcVMDCycle {
vmc40ms = 0, vmc160ms = 1, vmc640ms = 2, vmc2_5s = 3,
vmc10s = 4, vmcUnknown = 0x7fffffff
}

VMD measure cycle.

More...
enum | TPlcSafebagStep { sbsOpen = 0, sbsUnknown = 0x7fffffff }

Safebag step.

More...
enum | TPlcPlcObtrackCounterType { octIncoming = 0, octOutcoming = 1, octCommon = 2, octUnknown = 0x7fffffff }

OBTRACK counter type.

More...
enum | TPlcPlcObtrackExceedingDirection { oedExceed = 0, oedFallBelow = 1, oedUnknown = 0x7fffffff }

OBTRACK exceeding direction.

More...
enum | TPlcPlcTunnelAlarmReason { tarPerson = 0, tarPark = 1, tarWrongDirection = 2, tarUnknown = 0x7fffffff }

Tunnel alarm reason.

More...
enum TPlcPlcViewerPlayMode {
vpmUnknownMode = 0, vpmPlayStop = 1, vpmPlayForward = 2, vpmPlayBackward = 3,
vpmPlayFastForward = 4, vpmPlayFastBackward = 5, vpmPlayStepForward = 6, vpmPlayStepBackward = 7,
vpmPlayBOD = 8, vpmPlayEOD = 9, vpmPlayQuasiLive = 10, vpmPlayStream = 11,
vpmPlayNextEvent = 12, vpmPlayPrevEvent = 13, vpmPeekLivePicture = 14, vpmPlayNextMOS = 17,
vpmPlayPrevMOS = 18, vpmUnknown = 0x7fffffff
}

Viewer play mode.

More...
enum TPlcPlcViewerAlarmPlayMode {
apmDefault = 0, apmLiveReplay = 1, apmReplayEventPictures = 2, apmContinuousEventReplayInALoop = 3,
apmShowFirstAlarmPictureOnly = 4, apmUnknown = 0x7fffffff
}

Viewer alarm play mode.

More...
enum TPlcPlcViewerAlarmState {
vasNewAlarm = 0, vasPresented = 1, vasStacked = 2, vasConfirmed = 3,
vasRemoved = 4, vasLastConfirmed = 5, vasLastRemoved = 6, vasListConfirmed = 7,
vasListEmpty = 8, vasUnknown = 0x7fffffff
}

Viewer alarm state notification.

More...
enum TPlcPlcImageExportType {
ietSingleImage = 0, ietBackupFile = 1, ietVideoFile = 2, ietClipboard = 3,
ietPrinter = 4, ietUnknown = 0x7fffffff
}

Image export type.

More...
enum TPlcPlcDatabaseRing {
dbrRing1 = 0, dbrRing2 = 1, dbrRing3 = 2, dbrRing4 = 3,
dbrRing5 = 4, dbrRing6 = 5, dbrRing7 = 6, dbrRing8 = 7,
dbrUnknown = 0x7fffffff
}

Database ring.

More...
enum TPlcPlcPluginError {
ppeInternalError = 1, ppeOutOfResources = 2, ppeUnlicensed = 3, ppeConnectionLost = 4,
ppeUnknownError = 5, ppeUnknown = 0x7fffffff
}

Plugin error code.

More...
enum TPlcPlcClientType {
pctInvalid = 0, pctGscView = 1, pctGscSetup = 2, pctGscRegEdit = 3,
pctGscWeb = 4, pctDefault = 5, pctGscSupplyChain = 6, pctUnknown = 0x7fffffff
}

Client type.

More...
enum TPlcPlcFRCNotification {
frnDataOverwritten = 0, frnBufferActivated = 1, frnReconcileStarted = 2, frnReconcileProgress = 3,
frnReconcileAborted = 4, frnReconcileFinished = 5, frnUnknown = 0x7fffffff
}

FRC notification.

More...
enum TPlcPlcResourceKind {
prkNotSpecified = 0, prkVideoInput = 1, prkPTZHead = 2, prkDigitalInput = 3,
prkDigitalOutput = 4, prkUser = 5, prkTimeRange = 6, prkVCUserOptions = 7,
prkVCAllProfiles = 8, prkUnknown = 0x7fffffff
}

PLC resource kind.

More...
enum | TPlcPlcResourceChangeKind { rckAdded = 0, rckRemoved = 1, rckModified = 2, rckUnknown = 0x7fffffff }

PLC resource change kind.

More...
enum | TPlcPlcPOSStatus { posStarted = 0, posCleared = 1, posStopped = 2, posUnknown = 0x7fffffff }

PLC POS status.

More...
enum | TPlcPlcNPRRestriction { nrrUnspecified = 0, nrrBlackListed = 1, nrrWhiteListed = 2, nrrUnknown = 0x7fffffff }

PLC POS status.

More...
enum | TPlcPlcSpecialConstants { pscRestOfTime = 0, pscUnknown = 0x7fffffff }

Special constants.

More...
enum | TPlcPlcPluginState { ppsInternalState = 0, ppsConnected = 1, ppsDisconnected = 2, ppsUnknown = 0x7fffffff }

Plugin state.

More...
enum TPlcPlcPumpStatus {
pumStarted = 0, pumStopped = 1, pumCleared = 2, pumAmount = 3,
pumUnknown = 0x7fffffff
}

PLC pump status.

More...
enum | TPlcPlcDayNightMode { pdnDay = 0, pdnNight = 1, pdnAuto = 2, pdnUnknown = 0x7fffffff }

Day/night mode.

More...
enum | TPlcPlcBacklightMode { pbmOff = 0, pbmOn = 1, pbmUnknown = 0x7fffffff }

Backlight compensation mode.

More...
enum TPlcPlcSkidataControl {
sdcConnectionOk = 1, sdcConnectionFailed = 2, sdcDisconnected = 3, sdcConnectionLost = 4,
sdcUnknown = 0x7fffffff
}

SKIDATA control message.

More...
enum TPlcPlcSkidataMsgCodeEntry {
sdenTicket = 1, sdenCreditCard = 2, sdenElectronicPurse = 3, sdenExternalCard = 4,
sdenUnknown = 0x7fffffff
}

SKIDATA message entry.

More...
enum TPlcPlcSkidataMsgCodeExit {
sdexTicket = 1, sdexCreditCard = 2, sdexElectronicPurse = 3, sdexExternalCard = 4,
sdexUnknown = 0x7fffffff
}

SKIDATA message exit.

More...
enum TPlcPlcSkidataMsgCodeTransaction {
sdtrParking = 1, sdtrSale = 2, sdtrOther = 3, sdtrCash = 4,
sdtrCheck = 5, sdtrCreditCard = 6, sdtrInvoice = 7, sdtrValueCard = 8,
sdtrValidation = 9, sdtrToken = 10, sdtrElectronicPurse = 11, sdtrIsoDiscount = 12,
sdtrUnknown = 0x7fffffff
}

SKIDATA message transaction.

More...
enum | TPlcPlcExportMarker { exmSelectionBegin = 0, exmSelectionEnd = 1, exmUnknown = 0x7fffffff }

Export marker.

More...
enum | TPlcPlcBackupFormat { ebfDefault = 0, ebfGBF = 1, ebfMPEG2 = 2, ebfUnknown = 0x7fffffff }

Backup format.

More...
enum TPlcPlcExportSuccess {
exsSuccess = 0, exsFailed = 1, exsAborted = 2, exsLowDiscSpace = 3,
exsNoUserRights = 4, exsQueueSizeReached = 5, exsConnectionError = 6, exsUnknown = 0x7fffffff
}

Export success state.

More...
enum TPlcPlcExportAbort {
exaUserAbort = 0, exaLowDiscSpace = 1, exaNoUserRights = 2, exaError = 3,
exaUnknown = 0x7fffffff
}

Export abort flag.

More...
enum TPlcPlcLpsStatus {
lstPositionOK = 0, lstUnknownArea = 1, lstLastPosition = 2, lstInvalidID = 3,
lstError = 4, lstUnknown = 0x7fffffff
}

Position query status.

More...
enum TPlcPlcSceneStoreModificationType {
smtCreate = 0, smtOpen = 1, smtDisplay = 2, smtClose = 3,
smtDelete = 4, smtUnknown = 0x7fffffff
}

Scene store modification type.

More...
enum | TPlcGTectSceneAlarmReason { garViewFieldObservation = 0, garContrast = 1, garUnknown = 0x7fffffff }

G-Tect alarm reason.

More...
enum | TPlcGTectClientVCAType { gvtClientPrivacyMasking = 0, gvtMotionPrivacy = 1, gvtUnknown = 0x7fffffff }

G-Tect client VCA type.

More...
enum TPlcLenelAccessResult {
larOther = 0, larlUnknown = 1, larGranted = 2, larDenied = 3,
larNotApplicable = 4, larUnknown = 0x7fffffff
}

Lenel access result.

More...
enum TPlcLenelEventType {
letAccessGranted = 0, letAccessDenied = 1, letDuress = 2, letAreaAPB = 3,
letSystem = 4, letAsset = 5, letHostMessages = 6, letFireSeven = 7,
letFireEight = 8, letFireNine = 9, letIntercom = 10, letVideo = 11,
letTransmitter = 12, letBiometric = 18, letTrouble = 19, letDigitize = 20,
letBurglary = 21, letTemperature = 22, letGas = 23, letRelaySounder = 24,
letMedical = 25, letWater = 26, letC900 = 27, letOpenClose = 28,
letMuster = 29, letGeneric = 30, letPointofSale = 31, letPortableProgrammer = 32,
letUnknown = 0x7fffffff
}

Lenel event type.

More...
enum TPlcLenelEventID {
leiAccessGranted = 1, leiAccessGrantedonFacilityCode = 2, leiAccessGrantedNoEntryMade = 3, leiAccessGrantedonFacilityCodeNoEntryMade = 4,
leiInvalidCardFormat = 6, leiDeniedCountExceeded = 7, leiDeniedPINOnlyRequest = 8, leiInvalidFacilityCode = 9,
leiInvalidBadge = 10, leiInvalidIssueCode = 11, leiInvalidPINNumber = 12, leiInvalidAccessLevel = 13,
leiInactiveBadge = 14, leiDeniedReaderExcluded = 15, leiDeniedNoCommandAuthority = 16, leiDeniedUnMaskActiveZonesinGroup = 17,
leiUseLimitExceeded = 18, leiAccessGrantedUnderDuress = 20, leiAccessDeniedUnderDuress = 21, leiAccessGrantedUnderDuressNoEntryMade = 22,
leiAntiPassbackViolation = 23, leiAreaLimitExceeded = 24, leiTimeoutExceededNoSecondCard = 25, leiAreaClosed = 26,
leiAccessGrantedAntiPassbackUsed = 27, leiAccessGrantedAntiPassbackNotUsed = 28, leiAntiPassbackInvalidExitReader = 29, leiAntiPassbackInvalidEntryReader = 30,
leiNotConfigured = 33, leiAlarmCanceled = 34, leiAlarmActive = 35, leiDoorForcedOpen = 41,
leiDoorForcedOpenCanceled = 42, leiDoorHeldOpen = 43, leiDoorHeldOpenCanceled = 44, leiReaderInputTamper = 47,
leiReaderInputTamperCanceled = 48, leiDoorContactTamper = 49, leiDoorContactTamperCanceled = 50, leiCabinetTamper = 51,
leiCanceledCabinetTamper = 52, leiPowerFailure = 53, leiCanceledPowerFailure = 54, leiRelayContactActivated = 86,
leiRelayContactDeactivated = 87, leiCommunicationsLost = 109, leiCommunicationsRestored = 110, leiLocalIOExecutedFunctionList = 111,
leiFireAlarmIn = 220, leiFireAlarmOut = 221, leiFireAlarmAcknowledge = 222, leiFireAlarmBlockAcknowledge = 223,
leiCalltoaBusySubscriber = 760, leiCalltoaPrivateSubscriber = 761, leiCalltoanOpenSubscriber = 762, leiCallDisconnected = 763,
leiIntercomFunction = 764, leiTroubleIn = 765, leiTroubleOut = 766, leiTroubleAcknowledge = 767,
leiDeniedLowBattery = 801, leiReaderModeFacilityCode = 802, leiReaderModeCardOnly = 803, leiReaderModeFirstCardUnlock = 804,
leiReaderModeUnlocked = 805, leiReaderModeLocked = 806, leiBiometricMismatch = 812, leiInputMasked = 831,
leiInputUnmasked = 832, leiDoorForcedOpenMasked = 833, leiDoorForcedOpenUnmasked = 834, leiDoorHeldOpenMasked = 835,
leiDoorHeldOpenUnmasked = 836, leiReaderModePinorCard = 837, leiReaderModeCardandPin = 838, leiAcceptedBiometricScore = 839,
leiRejectedBiometricScore = 840, leiNoBiometricTemplateData = 841, leiPanelOptionsMismatch = 842, leiAccessGrantedReaderUnlocked = 843,
leiAccessDeniedReaderLocked = 844, leiMaxCardholdersReached = 845, leiMaxAssetsReached = 846, leiAccessGrantedGenral = 847,
leiAccessDeniedGeneral = 848, leiAccessDeniedDoorSecured = 849, leiAccessDeniedInterlock = 850, leiAccessDeniedPassback = 851,
leiAccessDeniedUnauthorizedArmingState = 852, leiAccessDeniedUnauthorizedEntryLevel = 853, leiAccessDeniedUnauthorizedTime = 854, leiSchedulerActionFailed = 1502,
leiSchedulerActionExecuted = 1503, leiGuardTourActionFailed = 1504, leiGuardTourActionExecuted = 1505, leiGlobalLinkageActionFailed = 1506,
leiGlobalLinkageActionExecuted = 1507, leiDeniedNoHostApproval = 1508, leiDeniedUnauthorizedAssets = 1509, leiFirstCardUnlockModeEnabled = 1542,
leiFirstCardUnlockModeDisabled = 1543, leiExtendedHeldOpenModeEnabled = 1544, leiExtendedHeldOpenModeDisabled = 1545, leiCipherModeEnabled = 1546,
leiCipherModeDisabled = 1547, leiBiometricVerifyModeEnabled = 1548, leiBiometricVerifyModeDisabled = 1549, leiAccessDeniedNoBiometricTemplate = 1550,
leiAccessDeniedBiometricReaderOffline = 1551, leiExtendedHeldCommandDenied = 1552, leiExtendedHeldCommandSetFromReader = 1553, leiIncomingCall = 1554,
leiTroubleReport = 1555, leiTestReport = 1556, leiAcknowledgmentActionExecuted = 1785, leiAcknowledgmentActionFailed = 1786,
leiAlarmMonitoringActionGroupExecuted = 1787, leiAlarmMonitoringActionGroupFailed = 1788, leiSmartCardAuthenticationFailed = 1789, leiRinging = 1794,
leiCallFailed = 1795, leiHold = 1796, leiRetrieved = 1797, leiInitiated = 1798,
leiGenericEvent = 1799, leiInputAlarmed = 1808, leiInputNormal = 1809, leiInputLowLow = 1810,
leiInputLow = 1811, leiInputHigh = 1812, leiInputHighHigh = 1813, leiDoorOpen = 1887,
leiDoorClose = 1888, leiCommunicationsWithHostLost = 1889, leiCommunicationsWithHostRestored = 1890, leiCallEnded = 1891,
leiCallEstablished = 1892, leiUnansweredCall = 1893, leiCallTransferred = 1894, leiCallConferenced = 1895,
leiAccessDeniedEscortTimeoutExpired = 1896, leiCallQueued = 1910, leiAccessDeniedAreaOccupied = 1911, leiAccessDeniedNoOccupantApproval = 1912,
leiDeniedBadgeNotinPanel = 1914, leiIntercomExchangeFailure = 1915, leiIntrusionCommandDenied = 1920, leiIntrusionCommandAccepted = 1921,
leiAlarmMaskGroupArmed = 1922, leiAlarmMaskGroupDisarmed = 1923, leiAlarmMaskGroupForceArmed = 1924, leiAlarmMaskGroupMaskCountIncremented = 1925,
leiAlarmMaskGroupMaskCountDecremented = 1926, leiAlarmMaskGroupArmingFailureActivePoints = 1927, leiAccessDeniedAreaEmpty = 1928, leiElevatorTerminalModeDefaultFloororUserEntryofDestinationFloor = 1936,
leiUnknownElevatorTerminal = 1937, leiOpenDoorCommandIssuedDoorUsed = 1938, leiOpenDoorCommandIssuedDoorNotUsed = 1939, leiRequesttoExitDoorUsed = 1940,
leiRequesttoExitDoorNotUsed = 1941, leiElevatorTerminalModeDefaultFloor = 1943, leiElevatorTerminalModeAccesstoAuthorizedFloors = 1944, leiElevatorTerminalModeUserEntryofDestinationFloor = 1945,
leiReaderOffline = 1968, leiReaderOfflineRestored = 1969, leiUnknownUserCommand = 1978, leiAccessDeniedAssetRequired = 1984,
leiAccessDeniedSpecial = 2289, leiUnknown = 0x7fffffff
}

Lenel event ID.

More...
enum | TPlcIODeviceType { dioDeviceTypeMIO = 0, dioDeviceTypeIOI43 = 1, dioUnknown = 0x7fffffff }

Specifies the type of the io device.

More...
enum | TPlcTrafficDirection { tfdIn = 0, tfdOut = 1, tfdUnspecified = 2, tfdUnknown = 0x7fffffff }

Traffic direction.

More...
enum | TPlcPPAlarmState { pasNormal = 0, pasAlarm = 1, pasUnknown = 0x7fffffff }

PP alarm state.

More...
enum | TPlcPPCableKind { pckCableA = 0, pckCableB = 1, pckUnknown = 0x7fffffff }

PP cable kind.

More...
enum TPlcPPSensorKind {
pskCableAFault = 0, pskCableBFault = 1, pskTamper = 2, pskTrap = 3,
pskSensor = 4, pskPath = 5, pskAux = 6, pskService = 7,
pskUnknown = 0x7fffffff
}

PP sensor kind.

More...
enum TPlcIPSwitchOps {
ipoPOEOn = 0, ipoPOEOff = 1, ipoPOEReset = 2, ipoPOEDelayedReset = 3,
ipoUnknown = 0x7fffffff
}

IP switch operation.

More...
enum GscParameterType {
pt___int32 = 0, pt___int64 = 1, pt_TGLibDateTime = 2, pt_string = 3,
pt_widestring = 4, pt_bool = 5, pt_GUID = 6, pt_TEventTypeID = 7,
pt_TMediaChannelID = 8, pt_TResourceID = 9, pt_DigitalInputState = 10, pt_DigitalOutputState = 11,
pt_VideoSignalNorm = 12, pt_VideoSignalType = 13, pt_VideoInterlaceType = 14, pt_ADArea = 15,
pt_VMDGroup = 16, pt_SystemLED = 17, pt_VideoSensorKind = 18, pt_UserLoginFailureCode = 20,
pt_PlcMessageSource = 21, pt_PlcMessageCode = 24, pt_PlcViewerAlarmQueueSelection = 28, pt_ABCapacityWarning = 29,
pt_PlcObtrackObjectStatus = 30, pt_PlcObtrackObjectClass = 31, pt_PlcDatabaseStatus = 32, pt_PlcObtrackProcessSize = 33,
pt_SystemKey = 34, pt_VMDCycle = 35, pt_SafebagStep = 36, pt_PlcObtrackCounterType = 37,
pt_PlcObtrackExceedingDirection = 38, pt_PlcTunnelAlarmReason = 39, pt_PlcViewerPlayMode = 40, pt_PlcViewerAlarmPlayMode = 43,
pt_PlcViewerAlarmState = 45, pt_PlcImageExportType = 47, pt_PlcDatabaseRing = 48, pt_PlcPluginError = 49,
pt_PlcClientType = 50, pt_PlcFRCNotification = 52, pt_PlcResourceKind = 54, pt_PlcResourceChangeKind = 56,
pt_PlcPOSStatus = 58, pt_PlcNPRRestriction = 59, pt_PlcSpecialConstants = 60, pt_PlcPluginState = 61,
pt_PlcPumpStatus = 62, pt_PlcDayNightMode = 63, pt_PlcBacklightMode = 64, pt_PlcSkidataControl = 65,
pt_PlcSkidataMsgCodeEntry = 66, pt_PlcSkidataMsgCodeExit = 68, pt_PlcSkidataMsgCodeTransaction = 70, pt_PlcExportMarker = 72,
pt_PlcBackupFormat = 73, pt_PlcExportSuccess = 74, pt_PlcExportAbort = 75, pt_PlcLpsStatus = 77,
pt_PlcSceneStoreModificationType = 78, pt_GTectSceneAlarmReason = 79, pt_GTectClientVCAType = 80, pt_LenelAccessResult = 95,
pt_LenelEventType = 96, pt_LenelEventID = 99, pt_IODeviceType = 90, pt_TrafficDirection = 81,
pt_PPAlarmState = 82, pt_PPCableKind = 83, pt_PPSensorKind = 84, pt_IPSwitchOps = 85,
pt_double = 100, pt_TPlcRect = 101, pt_Unknown = 0x7fffffff
}

Available parameter types.

More...
enum GscParameterView {
pv_Default = 0, pv_UserName = 1, pv_DeviceType = 2, pv_DeviceName = 3,
pv_VideoInput = 4, pv_VideoOutput = 5, pv_InputContact = 6, pv_OutputContact = 7,
pv_PTZHead = 8, pv_TimeRange = 9, pv_Event = 10, pv_AudioInput = 11,
pv_AudioOutput = 12, pv_ADParameterSet = 13, pv_VMDParameterSet = 14, pv_WindowsError = 15,
pv_DeviceSubType = 16, pv_ForeignKey = 17, pv_CPAParameterSet = 18, pv_ObtrackParameterSet = 19,
pv_ABDestination = 20, pv_ABSchedule = 21, pv_HardwareModule = 22, pv_CameraProfile = 23,
pv_GTectParameterSet = 24, pv_ImexDestination = 25, pv_Unknown = 0x7FFFFFFF
}

Available parameter views.

More...

Variables

const unsigned __int32 | FlagDisableResourceUpdate = 0x00000001
Disable resource update callback.
const unsigned __int32 | FlagDisableInternalInEventData = 0x00000002
Disable storing internal data in event data struct.
const unsigned __int32 | TPlcUpdateActionInfoCallbackVersion = 1
update callback definition version

Typedef Documentation

typedef enum TPlcDigitalInputState DigitalInputState

State of the digital input contact.

typedef enum TPlcDigitalOutputState DigitalOutputState

State of the digital output contact.

typedef enum TPlcVideoSignalNorm VideoSignalNorm

Norm of the video input signal.

typedef enum TPlcVideoSignalType VideoSignalType

Type of the video input signal.

typedef enum TPlcVideoInterlaceType VideoInterlaceType

Interlace kind of the video input signal.

typedef enum TPlcADArea ADArea

Activity detection area.

typedef enum TPlcVMDGroup VMDGroup

VMD group.

typedef enum TPlcSystemLED SystemLED

System LED.

typedef enum TPlcVideoSensorKind VideoSensorKind

Video sensor type.

typedef enum TPlcUserLoginFailureCode UserLoginFailureCode

User login failure code.

typedef enum TPlcPlcMessageSource PlcMessageSource

Source of the message.

typedef enum TPlcPlcMessageCode PlcMessageCode

Code of the message.

typedef enum TPlcPlcViewerAlarmQueueSelection PlcViewerAlarmQueueSelection

Viewer alarm queue selection mode.

typedef enum TPlcABCapacityWarning ABCapacityWarning

Auto backup capacity monitoring warning.

typedef enum TPlcPlcObtrackObjectStatus PlcObtrackObjectStatus

OBTRACK object status.

typedef enum TPlcPlcObtrackObjectClass PlcObtrackObjectClass

OBTRACK object class.

typedef enum TPlcPlcDatabaseStatus PlcDatabaseStatus

Database status.

typedef enum TPlcPlcObtrackProcessSize PlcObtrackProcessSize

OBTRACK process size.

typedef enum TPlcSystemKey SystemKey

GEVISCOPE system key.

typedef enum TPlcVMDCycle VMDCycle

VMD measure cycle.

typedef enum TPlcSafebagStep SafebagStep

Safebag step.

typedef enum TPlcPlcObtrackCounterType PlcObtrackCounterType

OBTRACK counter type.

typedef enum TPlcPlcObtrackExceedingDirection PlcObtrackExceedingDirection

OBTRACK exceeding direction.

typedef enum TPlcPlcTunnelAlarmReason PlcTunnelAlarmReason

Tunnel alarm reason.

typedef enum TPlcPlcViewerPlayMode PlcViewerPlayMode

Viewer play mode.

typedef enum TPlcPlcViewerAlarmPlayMode PlcViewerAlarmPlayMode

Viewer alarm play mode.

typedef enum TPlcPlcViewerAlarmState PlcViewerAlarmState

Viewer alarm state notification.

typedef enum TPlcPlcImageExportType PlcImageExportType

Image export type.

typedef enum TPlcPlcDatabaseRing PlcDatabaseRing

Database ring.

typedef enum TPlcPlcPluginError PlcPluginError

Plugin error code.

typedef enum TPlcPlcClientType PlcClientType

Client type.

typedef enum TPlcPlcFRCNotification PlcFRCNotification

FRC notification.

typedef enum TPlcPlcResourceKind PlcResourceKind

PLC resource kind.

typedef enum TPlcPlcResourceChangeKind PlcResourceChangeKind

PLC resource change kind.

typedef enum TPlcPlcPOSStatus PlcPOSStatus

PLC POS status.

typedef enum TPlcPlcNPRRestriction PlcNPRRestriction

PLC POS status.

typedef enum TPlcPlcSpecialConstants PlcSpecialConstants

Special constants.

typedef enum TPlcPlcPluginState PlcPluginState

Plugin state.

typedef enum TPlcPlcPumpStatus PlcPumpStatus

PLC pump status.

typedef enum TPlcPlcDayNightMode PlcDayNightMode

Day/night mode.

typedef enum TPlcPlcBacklightMode PlcBacklightMode

Backlight compensation mode.

typedef enum TPlcPlcSkidataControl PlcSkidataControl

SKIDATA control message.

typedef enum TPlcPlcSkidataMsgCodeEntry PlcSkidataMsgCodeEntry

SKIDATA message entry.

typedef enum TPlcPlcSkidataMsgCodeExit PlcSkidataMsgCodeExit

SKIDATA message exit.

typedef enum TPlcPlcSkidataMsgCodeTransaction PlcSkidataMsgCodeTransaction

SKIDATA message transaction.

typedef enum TPlcPlcExportMarker PlcExportMarker

Export marker.

typedef enum TPlcPlcBackupFormat PlcBackupFormat

Backup format.

typedef enum TPlcPlcExportSuccess PlcExportSuccess

Export success state.

typedef enum TPlcPlcExportAbort PlcExportAbort

Export abort flag.

typedef enum TPlcPlcLpsStatus PlcLpsStatus

Position query status.

typedef enum TPlcPlcSceneStoreModificationType PlcSceneStoreModificationType

Scene store modification type.

typedef enum TPlcGTectSceneAlarmReason GTectSceneAlarmReason

G-Tect alarm reason.

typedef enum TPlcGTectClientVCAType GTectClientVCAType

G-Tect client VCA type.

typedef enum TPlcLenelAccessResult LenelAccessResult

Lenel access result.

typedef enum TPlcLenelEventType LenelEventType

Lenel event type.

typedef enum TPlcLenelEventID LenelEventID

Lenel event ID.

typedef enum TPlcIODeviceType IODeviceType

Specifies the type of the io device.

typedef enum TPlcTrafficDirection TrafficDirection

Traffic direction.

typedef enum TPlcPPAlarmState PPAlarmState

PP alarm state.

typedef enum TPlcPPCableKind PPCableKind

PP cable kind.

typedef enum TPlcPPSensorKind PPSensorKind

PP sensor kind.

typedef enum TPlcIPSwitchOps IPSwitchOps

IP switch operation.

typedef TPlcResourceID TPlcTimeRangeID

compatibility definitions

Definition at line 1633 of file GscActionsTypes.h.

typedef bool(__stdcall * TUpdateMediaChannelID)(void *Object, TPlcMediaChannelID &Info)

update media channel callback

Definition at line 1636 of file GscActionsTypes.h.

typedef bool(__stdcall * TUpdateEventTypeID)(void *Object, TPlcEventTypeID &Info)

update event type callback

Definition at line 1638 of file GscActionsTypes.h.

typedef bool(__stdcall * TUpdateResourceID)(void *Object, GscParameterView ParameterView, TPlcResourceID &Info)

update resource ID callback

Definition at line 1640 of file GscActionsTypes.h.

typedef bool(__stdcall * TUpdateResChannelID)(void *Object, GscParameterView ParameterView, TPlcResourceID &Info, __int64 &Channel)

update resource ID and channel callback

Definition at line 1642 of file GscActionsTypes.h.

Enumeration Type Documentation

enum GscMessageClass

Available message classes.

Enumerator:
mk_Action

action

mk_MatchAction

match action

mk_Unknown

Definition at line 41 of file GscActionsTypes.h.

enum GscActionClass

Available action classes.

Enumerator:
ak_System

System actions.

ak_Video

Video control.

ak_Audio

Audio control.

ak_CameraControl

Camera control.

ak_DigitalContacts

Digital contacts.

ak_Device

Device information.

ak_ATM

ATM/ACS.

ak_Backup

Backup actions.

ak_CashManagement

Cash management actions.

ak_Viewer

Viewer actions.

ak_ViewerNotification

Viewer notifications.

ak_POS

POS.

ak_RemoteExport

Remote export.

ak_SkiData

SKIDATA.

ak_LPS

LPS.

ak_Logistic

Supply chain security.

ak_Lenel

Lenel.

ak_Imex

Imex.

ak_PP

Perimeter protection.

ak_Unknown

Definition at line 51 of file GscActionsTypes.h.

enum GscActionCode

Available action codes.

Enumerator:
ac_SystemStarted

System started.

ac_SystemTerminating

System terminating.

ac_UserLogin

User login.

ac_UserLoginFailed

User login failed.

ac_UserLogout

User logout.

ac_SystemSettingsChanged

System settings changed.

ac_LiveCheck

Live check.

ac_CustomAction

Custom action.

ac_DatabaseStarted

Database started.

ac_DeviceFound

Device found.

ac_DeviceRemoved

Device removed.

ac_DeviceNewFirmware

New firmware received.

ac_DeviceReattached

Device reattached.

ac_DevicePluginError

Device plugin error.

ac_DevicePluginState

Device plugin state.

ac_SetupUploadProgress

Setup upload progress.

ac_SetupChanged

Setup changed.

ac_FRCNotification

FRC notification.

ac_SensorAudioAlarm

Sensor audio alarm.

ac_ABCConnect

ABC connect.

ac_ABCDisconnect

ABC disconnect.

ac_ABCPlayFile

ABC play file.

ac_SetClock

Set clock.

ac_DigitalInput

Digital input.

ac_SetDigitalOutput

Set digital output.

ac_SetLED

Set system LED.

ac_SetLEDBlink

Set system LED to blink.

ac_KeyPressed

Key pressed.

ac_KeyReleased

Key released.

ac_RedundantPowerFailure

Redundant power failure.

ac_RedundantPowerOk

Redundant power ok.

ac_VideoSyncDetected

Video sync detected.

ac_VideoSyncFailed

Video sync failed.

ac_ChangeADParameterSet

Change AD parameter set.

ac_ChangeVMDParameterSet

Change VMD parameter set.

ac_ChangeCPAParameterSet

Change CPA parameter set.

ac_VideoSourceChanged

Video source has changed.

ac_VideoContrastDetected

Video contrast detected.

ac_VideoContrastFailed

Video contrast failed.

ac_MakeCPAReferenceImage

Make CPA reference image.

ac_IASSettingsChanged

IAS settings changed.

ac_SystemInfo

System info.

ac_SystemWarning

System warning.

ac_SystemError

System error.

ac_SetWatchdog

Set watchdog.

ac_StartEvent

Start event.

ac_StopEvent

Stop event.

ac_StopEventByID

Stop event by instance.

ac_EventStarted

Event started.

ac_EventStopped

Event stopped.

ac_EventRecordingChanged

Event recording changed.

ac_StopAllEvents

Stop all events.

ac_KillEvent

Kill event.

ac_KillEventByID

Kill event by instance.

ac_KillAllEvents

Kill all events.

ac_BlockingFilterActivate

Blocking filter activate.

ac_BlockingFilterDeactivate

Blocking filter deactivate.

ac_CPAMeasurement

CPA measurement.

ac_SetTestPictureMode

Set test picture mode.

ac_ChannelLiveCheck

Channel live check.

ac_IPCameraRawCommand

IP camera raw command.

ac_SensorVideoAlarm

Sensor video alarm.

ac_SensorInhibitVideoAlarm

Sensor inhibit video alarm.

ac_SensorAlarmFinished

Sensor alarm finished.

ac_SensorInhibitAlarmFinished

Sensor inhibit alarm finished.

ac_ChangeObtrackParameterSet

Change OBTRACK parameter set.

ac_ObtrackFrameRawData

OBTRACK frame raw data.

ac_ObtrackObjectRawData

OBTRACK object raw data.

ac_ObtrackChannelCounter

OBTRACK channel counter.

ac_ObtrackGroupCounter

OBTRACK group counter.

ac_ObtrackChannelCounterThreshold

OBTRACK channel counter threshold.

ac_ObtrackGroupCounterThreshold

OBTRACK group counter threshold.

ac_ObtrackChannelSetCounter

OBTRACK channel set counter.

ac_ObtrackGroupSetCounter

OBTRACK group set counter.

ac_PanRight

Pan right.

ac_PanLeft

Pan left.

ac_PanStop

Pan stop.

ac_TiltUp

Tilt up.

ac_TiltDown

Tilt down.

ac_TiltStop

Tilt stop.

ac_ZoomIn

Zoom in.

ac_ZoomOut

Zoom out.

ac_ZoomStop

Zoom stop.

ac_FocusNear

Focus near.

ac_FocusFar

Focus far.

ac_FocusStop

Focus stop.

ac_IrisOpen

Iris open.

ac_IrisClose

Iris close.

ac_IrisStop

Iris stop.

ac_PrePosCallUp

Move to preset position.

ac_DefaultPosCallUp

Move to default position.

ac_CameraTourStart

Camera tour start.

ac_CameraTourStop

Camera tour stop.

ac_CameraLightOn

Camera light on.

ac_CameraLightOff

Camera light off.

ac_CameraOn

Camera on.

ac_CameraOff

Camera off.

ac_CameraPumpOn

Camera pump on.

ac_CameraPumpOff

Camera pump off.

ac_FastSpeedOn

Fast speed on.

ac_FastSpeedOff

Fast speed off.

ac_CameraWashOn

Camera wash-wipe on.

ac_CameraWashOff

Camera wash-wipe off.

ac_CameraSpecFuncUOn

Camera spec func U on.

ac_CameraSpecFuncUOff

Camera spec func U off.

ac_CameraSpecFuncVOn

Camera spec func V on.

ac_CameraSpecFuncVOff

Camera spec func V off.

ac_CameraSpecFuncXOn

Camera spec func X on.

ac_CameraSpecFuncXOff

Camera spec func X off.

ac_CameraSpecFuncYOn

Camera spec func Y on.

ac_CameraSpecFuncYOff

Camera spec func Y off.

ac_CameraStopAll

Camera stop all.

ac_PrePosSave

Save preset position.

ac_DefaultPosSave

Save default position.

ac_PrePosClear

Clear preset position.

ac_DefaultPosClear

Clear default position.

ac_SetCameraText

Set camera text.

ac_CameraSelectCharMode

Camera select char mode.

ac_CameraClearPrePosText

Camera clear preset text.

ac_CameraSetPrePosText

Camera set preset text.

ac_CameraRAWOutput

Camera RAW output.

ac_CameraVersionOn

Camera version on.

ac_CameraVersionOff

Camera version off.

ac_PanAuto

Pan auto.

ac_AutoFocusOn

Auto focus on.

ac_AutoFocusOff

Auto focus off.

ac_CameraManualIrisOn

Camera manual iris on.

ac_CameraManualIrisOff

Camera manual iris off.

ac_CameraTextOn

Camera text on.

ac_CameraTextOff

Camera text off.

ac_CameraDayNightMode

Camera day/night mode.

ac_CameraBacklightCompensationMode

Camera backlight compensation mode.

ac_CameraApplyProfile

Camera apply profile.

ac_MoveToAbsolutePosition

Move to absolute position.

ac_MoveToRelativePosition

Move to relative position.

ac_MoveToBySpeed

Move by speed.

ac_ChannelInfo

Channel info.

ac_ChannelWarning

Channel warning.

ac_ChannelError

Channel error.

ac_IPSwitchOperation

IP switch operation.

ac_ViewerConnectLive

Viewer connect live.

ac_ViewerConnect

Viewer connect.

ac_ViewerClear

Viewer clear.

ac_ViewerConnected

Viewer connected.

ac_ViewerCleared

Viewer cleared.

ac_ViewerPlayModeChanged

Viewer play mode changed.

ac_ViewerChangeScene

Viewer change scene.

ac_VCChangeSceneByName

VC change scene by name.

ac_ViewerClearScene

Viewer clear scene.

ac_VCClearSceneByName

VC clear scene by name.

ac_ViewerShowAlarmByInstance

Viewer show alarm by instance.

ac_ViewerShowAlarmByKey

Viewer show alarm by key.

ac_ViewerShowAlarmByType

Viewer show alarm by type.

ac_VCSceneChanged

VC scene changed.

ac_ViewerJumpByTime

Viewer jump by time.

ac_ViewerPlayFromTime

Viewer play from time.

ac_ViewerSetPlayMode

Viewer set play mode.

ac_ViewerSyncAudioAndVideo

Viewer change sync audio/video.

ac_VCSetAudioLevel

VC set audio level.

ac_ViewerMaximize

Viewer maximize.

ac_ViewerExportPicture

Viewer export picture.

ac_ViewerPrintPicture

Viewer print picture.

ac_ImageExportNotification

Image export notification.

ac_ViewerSelect

Viewer select.

ac_VCShowViewerText

VC show viewer text.

ac_VCFullMode

VC full mode.

ac_VCStretchMode

VC stretch mode.

ac_ViewerTextOutput

Viewer text output.

ac_ViewerClearTextOutput

Viewer clear text output.

ac_ViewerSelectionChanged

Viewer selection changed.

ac_SceneStoreModification

Scene store modification.

ac_VCAlarmQueueSelect

VC alarm queue select.

ac_VCAlarmQueueSelectByType

VC alarm queue select by type.

ac_VCAlarmQueueConfirm

VC alarm queue confirm.

ac_VCAlarmQueueConfirmByType

VC alarm queue confirm by type.

ac_VCAlarmQueueRemove

VC alarm queue remove.

ac_VCAlarmQueueRemoveByType

VC alarm queue remove by type.

ac_VCAlarmQueueSelectByInstance

VC alarm queue select by instance.

ac_VCAlarmQueueConfirmByInstance

VC alarm queue confirm by instance.

ac_VCAlarmQueueRemoveByInstance

VC alarm queue remove by instance.

ac_VCAlarmQueueNotification

VC alarm queue notification.

ac_DatabaseRecordingInfoTotal

Database recording info total.

ac_DatabaseRecordingInfoRing

Database recording info per ring.

ac_AutoBackupCapacityMonitoringOutOfDiskSpace

Auto backup capacity out of disk space.

ac_AutoBackupCapacityMonitoringCapacityWarning

Auto backup capacity warning.

ac_AutoBackupCapacityMonitoringFileAutoDeleted

Auto backup capacity file auto deleted.

ac_StartAutoBackup

Start auto backup.

ac_BackupEvent

Backup event.

ac_AutoBackupScheduleStarted

Auto backup schedule started.

ac_AutoBackupScheduleDone

Auto backup schedule done.

ac_AutoBackupOperationStarted

Auto backup operation started.

ac_AutoBackupOperationDone

Auto backup operation done.

ac_AutoBackupFileStarted

Auto backup file started.

ac_AutoBackupFileProgress

Auto backup file progress.

ac_AutoBackupFileDone

Auto backup file done.

ac_AbortAutoBackup

Abort auto backup.

ac_AbortAllAutoBackups

Abort all auto backups.

ac_GEMOSalarm

GEMOS alarm.

ac_ObtrackTunnelAlarm

OBTRACK tunnel alarm.

ac_SMTPMailSend

SMTP mail.

ac_EventBackupStarted

Event backup started.

ac_EventBackupDone

Event backup done.

ac_EventBackupFileStarted

Event backup file started.

ac_EventBackupFileProgress

Event backup file progress.

ac_EventBackupFileDone

Event backup file done.

ac_ChangeCameraProfile

Change camera profile.

ac_SMRPViewerConnected

SMRP viewer connected.

ac_SMRPViewerCleared

SMRP viewer cleared.

ac_ATMRawData

ATM raw data.

ac_ATMRawAnswer

ATM raw answer.

ac_ATMTransaction

ATM transaction.

ac_ACSRawData

ACS raw data.

ac_ACSRawAnswer

ACS raw answer.

ac_ACSAccessGranted

ACS access granted.

ac_ACSAccessDenied

ACS access denied.

ac_InterfaceRawData

Interface raw data.

ac_InterfaceRawAnswer

Interface raw answer.

ac_POSStatus

POS status.

ac_POSData

POS data.

ac_TerminalArticleData

Terminal article data.

ac_TerminalPaymentData

Terminal payment data.

ac_BarcodeData

Barcode data.

ac_FillingPumpStatus

Filling pump status.

ac_ActivateExternalProcess

Activate external process.

ac_NPRRawData

NPR raw data.

ac_NPRRecognition

NPR recognition.

ac_TransferBinaryBuffer

Transfer binary buffer.

ac_TransferBinaryChannelBuffer

Transfer binary channel buffer.

ac_SetSystemTime

Set system time.

ac_VideoSetImageContrast

Video set image contrast.

ac_VideoSetImageBrightness

Video set image brightness.

ac_VideoSetImageSaturation

Video set image saturation.

ac_MediaChannelSetupInfo

Media channel setup.

ac_SafebagOpen

Safebag open.

ac_SafebagData

Safebag data.

ac_SafebagClose

Safebag close.

ac_SafebagPassingOfRiskStart

Safebag passing of risk start.

ac_SafebagPassingOfRiskData

Safebag passing of risk data.

ac_SafebagPassingOfRiskStop

Safebag passing of risk stop.

ac_IOI43WDActivate

IOI43 watchdog activate.

ac_IOI43WDDeactivate

IOI43 watchdog deactivate.

ac_IOI43WDTrigger

IOI43 watchdog trigger.

ac_IOI43ResetMainboard

IOI43 reset mainboard.

ac_IOI43Temperature

IOI43 temperature notification.

ac_SkidataControl

SKIDATA control.

ac_SkidataEntry

SKIDATA entry.

ac_SkidataExit

SKIDATA exit.

ac_SkidataTransaction

SKIDATA transaction.

ac_SkidataDeviceEvent

SKIDATA device event.

ac_WatchdogActivate

Watchdog activate.

ac_WatchdogDeactivate

Watchdog deactivate.

ac_WatchdogTrigger

Watchdog trigger.

ac_Temperature

Temperature notification.

ac_ResetMainboard

Reset mainboard.

ac_CaseOpened

Case has been opened.

ac_CaseClosed

Case has been closed.

ac_SetExportMarker

Set export marker.

ac_InitializeRemoteExport

Initialize remote export.

ac_StartRemoteExport

Start remote export.

ac_ExportProgress

Export progress.

ac_ExportFinished

Export finished.

ac_CancelExport

Cancel export.

ac_StartSceneStore

Start scene store.

ac_LPSPositionData

LPS position data.

ac_LPSQueryPosition

LPS query position.

ac_LogBarcodeData

Log barcode data.

ac_LogBarcodeDataLPS

Log barcode data LPS.

ac_LogNPRRecognition

Log NPR recognition.

ac_GSCSVehicleAccessDenied

GSCS vehicle access denied.

ac_GSCSVehicleAccessGranted

GSCS vehicle access granted.

ac_GSCSVehicleAccessExpired

GSCS vehicle access expired.

ac_GSCSVehicleAccessPending

GSCS vehicle access pending.

ac_LenelSecurityEvent

Lenel security event.

ac_LenelAccessEvent

Lenel access event.

ac_LenelIntercomEvent

Lenel intercom event.

ac_LenelVideoEvent

Lenel video event.

ac_LenelFireEvent

Lenel fire event.

ac_LenelRawData

Lenel raw data.

ac_LenelRefreshNames

Lenel refresh names.

ac_GTectVMXAlarm

G-Tect/VMX alarm.

ac_GTectVMXAlarmFinished

G-Tect/VMX alarm finished.

ac_GTectDualSensorAlarm

G-Tect/Dual sensor alarm.

ac_GTectDualSensorAlarmFinished

G-Tect/Dual sensor alarm finished.

ac_GTectSceneAlarm

G-Tect scene alarm.

ac_GTectSceneAlarmFinished

G-Tect scene alarm finished.

ac_GTectAnalyticsLiveCheck

G-Tect analytics live check.

ac_ChangeGTectParameterSet

Change GTectVMX parameter set.

ac_SetClientVCA

Enable client VCA.

ac_VCASetArmed

VCA set armed.

ac_VCAStatusRequest

VCA status request.

ac_VCAStatusAnswer

VCA status answer.

ac_IPCamFailoverNotification

IP camera failover notification.

ac_IPCamFailoverRestore

IP camera failover restore.

ac_ImexCapacityWarning

Imex capacity warning.

ac_ImexCapacityOutOfDiskSpace

Imex capacity out of disk space.

ac_ImexCapacityFileAutoDeleted

Imex capacity file auto deleted.

ac_ImexExportImageFromDB

Imex export image from DB.

ac_ImexExportEventImage

Imex export event image.

ac_ImexExportImageFromLiveStream

Imex export image from live stream.

ac_PPSubcellAlarm

PP subcell alarm.

ac_PPDeviceAlarm

PP device alarm.

ac_PPZoneAlarm

PP zone alarm.

ac_PPDeviceInput

PP device input.

ac_PPSetDeviceOutput

PP set device output.

ac_PPQueryInterface

PP query interface.

ac_PPInterfaceOnline

PP interface online.

ac_PPInterfaceOffline

PP interface offline.

ac_PPDeviceOnline

PP device online.

ac_PPDeviceOffline

PP device offline.

ac_Unknown

Definition at line 78 of file GscActionsTypes.h.

enum TPlcDigitalInputState

State of the digital input contact.

Enumerator:
disLow

low

disMiddle

terminated

disHigh

high

disUnknown

Definition at line 396 of file GscActionsTypes.h.

enum TPlcDigitalOutputState

State of the digital output contact.

Enumerator:
dosOpen

open

dosClose

close

dosToggle

toggle

dosUnknown

Definition at line 407 of file GscActionsTypes.h.

enum TPlcVideoSignalNorm

Norm of the video input signal.

Enumerator:
vsnEIA

EIA.

vsnCCIR

CCIR.

vsnUnknown

Definition at line 418 of file GscActionsTypes.h.

enum TPlcVideoSignalType

Type of the video input signal.

Enumerator:
vstBAS

BAS.

vstFBAS

FBAS.

vstUnknown

Definition at line 428 of file GscActionsTypes.h.

enum TPlcVideoInterlaceType

Interlace kind of the video input signal.

Enumerator:
vsdInterlaced

interlaced

vsdNonInterlaced

non-interlaced

vsdUnknown

Definition at line 438 of file GscActionsTypes.h.

enum TPlcADArea

Activity detection area.

Enumerator:
adgArea1

area 1

adgArea2

area 2

adgArea3

area 3

adgArea4

area 4

adgUnknown

Definition at line 448 of file GscActionsTypes.h.

enum TPlcVMDGroup

VMD group.

Enumerator:
vmgGroup1

group 1

vmgGroup2

group 2

vmgGroup3

group 3

vmgGroup4

group 4

vmgUnknown

Definition at line 460 of file GscActionsTypes.h.

enum TPlcSystemLED

System LED.

Enumerator:
ledError

error LED

ledRecord

record LED

ledGreen

green LED

ledYellow

yellow LED

ledIOI43a1

IOI43a LED 1.

ledIOI43a2

IOI43a LED 2.

ledIOI43a3

IOI43a LED 3.

ledIOI43a4

IOI43a LED 4.

ledUnknown

Definition at line 472 of file GscActionsTypes.h.

enum TPlcVideoSensorKind

Video sensor type.

Enumerator:
vskAD

AD.

vskVMD

VMD.

vskCPA

CPA.

vskIPAD

IP-AD.

vskOBTRACK

OBTRACK.

vskDUAL

DUAL.

vskNPR

NPR.

vskFR

FR.

vskVAMissing

VA-Missing.

vskCPAExt

CPA extern.

vskGTectVMX

G-Tect/VMX.

vskUnknown

Definition at line 488 of file GscActionsTypes.h.

enum TPlcUserLoginFailureCode

User login failure code.

Enumerator:
ulfUser1NotFound

unknown first user

ulfUser1InvalPwd

invalid first user

ulfUser2NotFound

unknown second user

ulfUser2InvalPwd

invalid second user

ulfMissingSecondUser

second user required

ulfUser2NotAdmitted

second user is not admitted

ulfNoLicense

no licence available

ulfTooManyClients

licence limits reached

ulfUnknown

Definition at line 507 of file GscActionsTypes.h.

enum TPlcPlcMessageSource

Source of the message.

Enumerator:
pmsServer

server

pmsSetup

setup

pmsDBE

DBE.

pmsMediaAPI

media API

pmsMediaPlugin

media plugin

pmsPLC

PLC.

pmsAutoBackup

auto backup

pmsDongle

dongle

pmsFRC

FRC.

pmsATM

ATM.

pmsSensor

sensor

pmsPOS

POS.

pmsACS

ACS.

pmsIOI43

IOI43.

pmsInterface

interface

pmsTranscoder

transcoder

pmsLenel

LENEL.

pmsLogistic

logistic

pmsLPS

LPS.

pmsSCS

Supply Chain Security.

pmsVAM

Vehicle Access Manager.

pmsMIO

MIO.

pmsPP

perimeter protection

pmsUnknown

Definition at line 523 of file GscActionsTypes.h.

enum TPlcPlcMessageCode

Code of the message.

Enumerator:
pmcInternalError

internal error

pmcOutOfResources

out of resources

pmcUnlicensed

unlicensed

pmcConnectionLost

connection lost

pmcUnknownError

unknown error

pmcDemoModeExpired

demo mode expired

pmcDatabaseFileMissing

database file missing

pmcFileAccessError

file access error

pmcFLTMInefficient

FLTM inefficient.

pmcDBECouldNotFreeAnyPage

DBE could not free any page.

pmcDongleFound

dongle found

pmcDongleMissing

dongle missing

pmcDongleWrong

wrong dongle connected

pmcDongleInsufficient

insufficient licences

pmcFirmwareUploadFailed

firmware upload failed

pmcWatchdogReset

watchdog reset detected

pmcHttpError

HTTP error.

pmcHostRestrictions

not a white-listed host

pmcInsufficientFrameRate

not enough images for analysis

pmcTranscoderOverload

transcoder is overloaded

pmcNoControlForLongTime

had no control for long time

pmcBehaviouralRuleTooDeep

behavioural rule iteration too deep

pmcCannotOpenPort

cannot open port

pmcCannotEnumeratePorts

cannot enumerate ports

pmcCannotSetFilter

cannot set filter

pmcDataOverflow

data overflow

pmcInsufficientData

insufficient data

pmcIODeviceFound

device found

pmcIODeviceLost

device lost

pmcIODeviceNotFound

device not found

pmcIOTemperatureBelow

temperature below threshold

pmcIOTemperatureAbove

temperature above threshold

pmcIODriverNotInstalled

driver is not installed

pmcIOCannotEnumerate

cannot enumerate hardware

pmcIOCannotOpen

cannot open device

pmcIODuplcatedAddress

device with duplicated address switch

pmcIOUnusedDevice

unused device

pmcUnknown

Definition at line 554 of file GscActionsTypes.h.

enum TPlcPlcViewerAlarmQueueSelection

Viewer alarm queue selection mode.

Enumerator:
aqsFirst

first

aqsLast

last

aqsNext

next

aqsPrevious

previous

aqsUnknown

Definition at line 599 of file GscActionsTypes.h.

enum TPlcABCapacityWarning

Auto backup capacity monitoring warning.

Enumerator:
abwOk

no warnings

abwFreeCapacityBelowLimit

free capacity below limit

abwAllocatedCapacityAboveLimit

allocated capacity above limit

abwBoth

free capacity below and allocated capacity above limit

abwUnknown

Definition at line 611 of file GscActionsTypes.h.

enum TPlcPlcObtrackObjectStatus

OBTRACK object status.

Enumerator:
oosStarting

starting

oosStationary

stationary

oosLeaving

leaving

oosUndefined

undefined

oosDeleted

deleted

oosUnknown

Definition at line 623 of file GscActionsTypes.h.

enum TPlcPlcObtrackObjectClass

OBTRACK object class.

Enumerator:
oocPerson

person

oocCar

car

oocUndefined

unknown object

oocUnknown

Definition at line 636 of file GscActionsTypes.h.

enum TPlcPlcDatabaseStatus

Database status.

Enumerator:
dbsEmpty

empty

dbsReady

ready

dbsFileAdded

file added

dbsUnknown

Definition at line 647 of file GscActionsTypes.h.

enum TPlcPlcObtrackProcessSize

OBTRACK process size.

Enumerator:
opsCIF

CIF.

opsFourCIF

4CIF

opsTakeWhatYouGet

ANY.

opsUnknown

Definition at line 658 of file GscActionsTypes.h.

enum TPlcSystemKey

GEVISCOPE system key.

Enumerator:
keyDisplay1

GSC display 1.

keyDisplay2

GSC display 2.

keyDisplay3

GSC display 3.

keyDisplay4

GSC display 4.

keyReporter1

reporter 1

keyUnknown

Definition at line 669 of file GscActionsTypes.h.

enum TPlcVMDCycle

VMD measure cycle.

Enumerator:
vmc40ms

40 ms

vmc160ms

160 ms

vmc640ms

640 ms

vmc2_5s

2.5 s

vmc10s

10 s

vmcUnknown

Definition at line 682 of file GscActionsTypes.h.

enum TPlcSafebagStep

Safebag step.

Enumerator:
sbsOpen

open

sbsUnknown

Definition at line 695 of file GscActionsTypes.h.

enum TPlcPlcObtrackCounterType

OBTRACK counter type.

Enumerator:
octIncoming

incoming

octOutcoming

outcoming

octCommon

common

octUnknown

Definition at line 704 of file GscActionsTypes.h.

enum TPlcPlcObtrackExceedingDirection

OBTRACK exceeding direction.

Enumerator:
oedExceed

exceed

oedFallBelow

fall below

oedUnknown

Definition at line 715 of file GscActionsTypes.h.

enum TPlcPlcTunnelAlarmReason

Tunnel alarm reason.

Enumerator:
tarPerson

person

tarPark

park

tarWrongDirection

wrong direction

tarUnknown

Definition at line 725 of file GscActionsTypes.h.

enum TPlcPlcViewerPlayMode

Viewer play mode.

Enumerator:
vpmUnknownMode

unknown

vpmPlayStop

play stop

vpmPlayForward

play forward

vpmPlayBackward

play backward

vpmPlayFastForward

fast forward

vpmPlayFastBackward

fast backward

vpmPlayStepForward

step forward

vpmPlayStepBackward

step backward

vpmPlayBOD

play BOD

vpmPlayEOD

play EOD

vpmPlayQuasiLive

quasi live

vpmPlayStream

live

vpmPlayNextEvent

next event

vpmPlayPrevEvent

prev event

vpmPeekLivePicture

peek live picture

vpmPlayNextMOS

next detected motion

vpmPlayPrevMOS

prev detected motion

vpmUnknown

Definition at line 736 of file GscActionsTypes.h.

enum TPlcPlcViewerAlarmPlayMode

Viewer alarm play mode.

Enumerator:
apmDefault

show alarm using default settings

apmLiveReplay

live replay

apmReplayEventPictures

replay event pictures

apmContinuousEventReplayInALoop

continuous event replay

apmShowFirstAlarmPictureOnly

show first alarm picture only

apmUnknown

Definition at line 761 of file GscActionsTypes.h.

enum TPlcPlcViewerAlarmState

Viewer alarm state notification.

Enumerator:
vasNewAlarm

new alarm

vasPresented

presented

vasStacked

stacked

vasConfirmed

confirmed

vasRemoved

removed

vasLastConfirmed

last confirmed

vasLastRemoved

last removed

vasListConfirmed

list confirmed

vasListEmpty

list empty

vasUnknown

Definition at line 774 of file GscActionsTypes.h.

enum TPlcPlcImageExportType

Image export type.

Enumerator:
ietSingleImage

single image

ietBackupFile

backup file

ietVideoFile

video file

ietClipboard

clipboard

ietPrinter

printer

ietUnknown

Definition at line 791 of file GscActionsTypes.h.

enum TPlcPlcDatabaseRing

Database ring.

Enumerator:
dbrRing1

ring 1

dbrRing2

ring 2

dbrRing3

ring 3

dbrRing4

ring 4

dbrRing5

ring 5

dbrRing6

ring 6

dbrRing7

ring 7

dbrRing8

ring 8

dbrUnknown

Definition at line 804 of file GscActionsTypes.h.

enum TPlcPlcPluginError

Plugin error code.

Enumerator:
ppeInternalError

internal error

ppeOutOfResources

out of resources

ppeUnlicensed

unlicensed

ppeConnectionLost

connection lost

ppeUnknownError

unknown error

ppeUnknown

Definition at line 820 of file GscActionsTypes.h.

enum TPlcPlcClientType

Client type.

Enumerator:
pctInvalid

invalid

pctGscView

GSCView.

pctGscSetup

GSCSetup.

pctGscRegEdit

GSCRegEdit.

pctGscWeb

GSCWeb.

pctDefault

default

pctGscSupplyChain

GSCSupplyChain.

pctUnknown

Definition at line 833 of file GscActionsTypes.h.

enum TPlcPlcFRCNotification

FRC notification.

Enumerator:
frnDataOverwritten

data overwritten

frnBufferActivated

buffer recording activated

frnReconcileStarted

reconcile operation started

frnReconcileProgress

reconcile progress

frnReconcileAborted

reconcile aborted

frnReconcileFinished

reconcile finished

frnUnknown

Definition at line 848 of file GscActionsTypes.h.

enum TPlcPlcResourceKind

PLC resource kind.

Enumerator:
prkNotSpecified

unknown

prkVideoInput

video input

prkPTZHead

PTZ head.

prkDigitalInput

digital input

prkDigitalOutput

digital output

prkUser

user

prkTimeRange

time range

prkVCUserOptions

VC user options.

prkVCAllProfiles

VC all profiles.

prkUnknown

Definition at line 862 of file GscActionsTypes.h.

enum TPlcPlcResourceChangeKind

PLC resource change kind.

Enumerator:
rckAdded

added

rckRemoved

removed

rckModified

modified

rckUnknown

Definition at line 879 of file GscActionsTypes.h.

enum TPlcPlcPOSStatus

PLC POS status.

Enumerator:
posStarted

started

posCleared

cleared

posStopped

stopped

posUnknown

Definition at line 890 of file GscActionsTypes.h.

enum TPlcPlcNPRRestriction

PLC POS status.

Enumerator:
nrrUnspecified

unspecified

nrrBlackListed

black-listed

nrrWhiteListed

white-listed

nrrUnknown

Definition at line 901 of file GscActionsTypes.h.

enum TPlcPlcSpecialConstants

Special constants.

Enumerator:
pscRestOfTime

rest of time

pscUnknown

Definition at line 912 of file GscActionsTypes.h.

enum TPlcPlcPluginState

Plugin state.

Enumerator:
ppsInternalState

internal state

ppsConnected

connected

ppsDisconnected

disconnected

ppsUnknown

Definition at line 921 of file GscActionsTypes.h.

enum TPlcPlcPumpStatus

PLC pump status.

Enumerator:
pumStarted

filling started

pumStopped

filling stopped

pumCleared

pump released

pumAmount

amount message

pumUnknown

Definition at line 932 of file GscActionsTypes.h.

enum TPlcPlcDayNightMode

Day/night mode.

Enumerator:
pdnDay

day

pdnNight

night

pdnAuto

auto

pdnUnknown

Definition at line 944 of file GscActionsTypes.h.

enum TPlcPlcBacklightMode

Backlight compensation mode.

Enumerator:
pbmOff

off

pbmOn

on

pbmUnknown

Definition at line 955 of file GscActionsTypes.h.

enum TPlcPlcSkidataControl

SKIDATA control message.

Enumerator:
sdcConnectionOk

connection ok

sdcConnectionFailed

connection attempt failed

sdcDisconnected

disconnected

sdcConnectionLost

connection lost

sdcUnknown

Definition at line 965 of file GscActionsTypes.h.

enum TPlcPlcSkidataMsgCodeEntry

SKIDATA message entry.

Enumerator:
sdenTicket

SKIDATA ticket.

sdenCreditCard

credit card

sdenElectronicPurse

el. purse card

sdenExternalCard

external card

sdenUnknown

Definition at line 977 of file GscActionsTypes.h.

enum TPlcPlcSkidataMsgCodeExit

SKIDATA message exit.

Enumerator:
sdexTicket

SKIDATA ticket.

sdexCreditCard

credit card

sdexElectronicPurse

el. purse card

sdexExternalCard

external card

sdexUnknown

Definition at line 989 of file GscActionsTypes.h.

enum TPlcPlcSkidataMsgCodeTransaction

SKIDATA message transaction.

Enumerator:
sdtrParking

parking payment

sdtrSale

sale payment

sdtrOther

other payment

sdtrCash

cash payment

sdtrCheck

cheque payment

sdtrCreditCard

credit card payment

sdtrInvoice

invoice payment

sdtrValueCard

value card payment

sdtrValidation

validation payment

sdtrToken

token payment

sdtrElectronicPurse

electronic purse payment

sdtrIsoDiscount

ISO discount payment.

sdtrUnknown

Definition at line 1001 of file GscActionsTypes.h.

enum TPlcPlcExportMarker

Export marker.

Enumerator:
exmSelectionBegin

selection begin

exmSelectionEnd

selection end

exmUnknown

Definition at line 1021 of file GscActionsTypes.h.

enum TPlcPlcBackupFormat

Backup format.

Enumerator:
ebfDefault

default

ebfGBF

GBF.

ebfMPEG2

MPEG2.

ebfUnknown

Definition at line 1031 of file GscActionsTypes.h.

enum TPlcPlcExportSuccess

Export success state.

Enumerator:
exsSuccess

success

exsFailed

failed

exsAborted

aborted

exsLowDiscSpace

low disc space

exsNoUserRights

no user rights

exsQueueSizeReached

queue size reached

exsConnectionError

connection error

exsUnknown

Definition at line 1042 of file GscActionsTypes.h.

enum TPlcPlcExportAbort

Export abort flag.

Enumerator:
exaUserAbort

user abort

exaLowDiscSpace

low disc space

exaNoUserRights

no user rights

exaError

error

exaUnknown

Definition at line 1057 of file GscActionsTypes.h.

enum TPlcPlcLpsStatus

Position query status.

Enumerator:
lstPositionOK

tag and position is valid

lstUnknownArea

tag is valid but position is not known

lstLastPosition

tag is valid but position is last known position

lstInvalidID

tag is invalid

lstError

system error or server not connected

lstUnknown

Definition at line 1069 of file GscActionsTypes.h.

enum TPlcPlcSceneStoreModificationType

Scene store modification type.

Enumerator:
smtCreate

create

smtOpen

open

smtDisplay

display

smtClose

close

smtDelete

delete

smtUnknown

Definition at line 1082 of file GscActionsTypes.h.

enum TPlcGTectSceneAlarmReason

G-Tect alarm reason.

Enumerator:
garViewFieldObservation

view field observation

garContrast

contrast

garUnknown

Definition at line 1095 of file GscActionsTypes.h.

enum TPlcGTectClientVCAType

G-Tect client VCA type.

Enumerator:
gvtClientPrivacyMasking

client privacy masking

gvtMotionPrivacy

motion privacy

gvtUnknown

Definition at line 1105 of file GscActionsTypes.h.

enum TPlcLenelAccessResult

Lenel access result.

Enumerator:
larOther

access other

larlUnknown

access unknown

larGranted

access granted

larDenied

access denied

larNotApplicable

not applicable

larUnknown

Definition at line 1115 of file GscActionsTypes.h.

enum TPlcLenelEventType

Lenel event type.

Enumerator:
letAccessGranted

access granted

letAccessDenied

access denied

letDuress

duress

letAreaAPB

area APB

letSystem

system

letAsset

asset

letHostMessages

host messages

letFireSeven

Fire.

letFireEight

Fire.

letFireNine

Fire.

letIntercom

intercom

letVideo

video

letTransmitter

transmitter

letBiometric

biometric

letTrouble

trouble

letDigitize

digitize

letBurglary

burglary

letTemperature

temperature

letGas

gas

letRelaySounder

relay/sounder

letMedical

medical

letWater

water

letC900

C900.

letOpenClose

open/close

letMuster

muster

letGeneric

generic

letPointofSale

point of sale

letPortableProgrammer

portable programmer

letUnknown

Definition at line 1128 of file GscActionsTypes.h.

enum TPlcLenelEventID

Lenel event ID.

Enumerator:
leiAccessGranted

access granted

leiAccessGrantedonFacilityCode

access granted on facility code

leiAccessGrantedNoEntryMade

access granted no entry made

leiAccessGrantedonFacilityCodeNoEntryMade

access granted on facility code, no entry made

leiInvalidCardFormat

invalid card format

leiDeniedCountExceeded

denied count exceeded

leiDeniedPINOnlyRequest

denied, pin only request

leiInvalidFacilityCode

invalid facility code

leiInvalidBadge

invalid badge

leiInvalidIssueCode

invalid issue code

leiInvalidPINNumber

invalid pin number

leiInvalidAccessLevel

invalid access level

leiInactiveBadge

inactive badge

leiDeniedReaderExcluded

denied, reader excluded

leiDeniedNoCommandAuthority

denied, no command authority

leiDeniedUnMaskActiveZonesinGroup

denied unmask - active zones in group

leiUseLimitExceeded

use limit exceeded

leiAccessGrantedUnderDuress

access granted under duress

leiAccessDeniedUnderDuress

access denied under duress

leiAccessGrantedUnderDuressNoEntryMade

access granted under duress - no entry made

leiAntiPassbackViolation

anti-passback violation

leiAreaLimitExceeded

area limit exceeded

leiTimeoutExceededNoSecondCard

timeout exceeded - no second card

leiAreaClosed

area closed

leiAccessGrantedAntiPassbackUsed

access granted - anti-passback used

leiAccessGrantedAntiPassbackNotUsed

access granted - anti-passback not used

leiAntiPassbackInvalidExitReader

anti-passback invalid exit reader

leiAntiPassbackInvalidEntryReader

anti-passback invalid entry reader

leiNotConfigured

not configured

leiAlarmCanceled

alarm canceled

leiAlarmActive

alarm active

leiDoorForcedOpen

door forced open

leiDoorForcedOpenCanceled

door forced open canceled

leiDoorHeldOpen

door held open

leiDoorHeldOpenCanceled

door held open canceled

leiReaderInputTamper

reader input tamper

leiReaderInputTamperCanceled

reader input tamper canceled

leiDoorContactTamper

door contact tamper

leiDoorContactTamperCanceled

door contact tamper canceled

leiCabinetTamper

cabinet tamper

leiCanceledCabinetTamper

canceled cabinet tamper

leiPowerFailure

power failure

leiCanceledPowerFailure

canceled power failure

leiRelayContactActivated

relay contact activated

leiRelayContactDeactivated

relay contact deactivated

leiCommunicationsLost

communications lost

leiCommunicationsRestored

communications restored

leiLocalIOExecutedFunctionList

local i/o executed function list

leiFireAlarmIn

fire alarm in

leiFireAlarmOut

fire alarm out

leiFireAlarmAcknowledge

fire alarm acknowledge

leiFireAlarmBlockAcknowledge

fire alarm block acknowledge

leiCalltoaBusySubscriber

call to a busy subscriber

leiCalltoaPrivateSubscriber

call to a private subscriber

leiCalltoanOpenSubscriber

call to an open subscriber

leiCallDisconnected

call disconnected

leiIntercomFunction

intercom function

leiTroubleIn

trouble in

leiTroubleOut

trouble out

leiTroubleAcknowledge

trouble acknowledge

leiDeniedLowBattery

denied low battery

leiReaderModeFacilityCode

reader mode facility code

leiReaderModeCardOnly

reader mode card only

leiReaderModeFirstCardUnlock

reader mode first card unlock

leiReaderModeUnlocked

reader mode unlocked

leiReaderModeLocked

reader mode locked

leiBiometricMismatch

biometric mismatch

leiInputMasked

input masked

leiInputUnmasked

input unmasked

leiDoorForcedOpenMasked

door forced open masked

leiDoorForcedOpenUnmasked

door forced open unmasked

leiDoorHeldOpenMasked

door held open masked

leiDoorHeldOpenUnmasked

door held open unmasked

leiReaderModePinorCard

reader mode pin or card

leiReaderModeCardandPin

reader mode card and pin

leiAcceptedBiometricScore

accepted biometric score

leiRejectedBiometricScore

rejected biometric score

leiNoBiometricTemplateData

no biometric template data

leiPanelOptionsMismatch

panel options mismatch

leiAccessGrantedReaderUnlocked

access granted: reader unlocked

leiAccessDeniedReaderLocked

access denied: reader locked

leiMaxCardholdersReached

max cardholders reached

leiMaxAssetsReached

max assets reached

leiAccessGrantedGenral

access granted

leiAccessDeniedGeneral

access denied

leiAccessDeniedDoorSecured

access denied door secured

leiAccessDeniedInterlock

access denied interlock

leiAccessDeniedPassback

access denied passback

leiAccessDeniedUnauthorizedArmingState

access denied unauthorized arming state

leiAccessDeniedUnauthorizedEntryLevel

access denied unauthorized entry level

leiAccessDeniedUnauthorizedTime

access denied unauthorized time

leiSchedulerActionFailed

scheduler action failed

leiSchedulerActionExecuted

scheduler action executed

leiGuardTourActionFailed

guard tour action failed

leiGuardTourActionExecuted

guard tour action executed

leiGlobalLinkageActionFailed

global linkage action failed

leiGlobalLinkageActionExecuted

global linkage action executed

leiDeniedNoHostApproval

denied - no host approval

leiDeniedUnauthorizedAssets

denied - unauthorized assets

leiFirstCardUnlockModeEnabled

first card unlock mode enabled

leiFirstCardUnlockModeDisabled

first card unlock mode disabled

leiExtendedHeldOpenModeEnabled

extended held open mode enabled

leiExtendedHeldOpenModeDisabled

extended held open mode disabled

leiCipherModeEnabled

cipher mode enabled

leiCipherModeDisabled

cipher mode disabled

leiBiometricVerifyModeEnabled

biometric verify mode enabled

leiBiometricVerifyModeDisabled

biometric verify mode disabled

leiAccessDeniedNoBiometricTemplate

access denied: no biometric template

leiAccessDeniedBiometricReaderOffline

access denied: biometric reader offline

leiExtendedHeldCommandDenied

extended held command denied

leiExtendedHeldCommandSetFromReader

extended held command set from reader

leiIncomingCall

incoming call

leiTroubleReport

trouble report

leiTestReport

test report

leiAcknowledgmentActionExecuted

acknowledgment action executed

leiAcknowledgmentActionFailed

acknowledgment action failed

leiAlarmMonitoringActionGroupExecuted

alarm monitoring action group executed

leiAlarmMonitoringActionGroupFailed

alarm monitoring action group failed

leiSmartCardAuthenticationFailed

smart card authentication failed

leiRinging

ringing

leiCallFailed

call failed

leiHold

hold

leiRetrieved

retrieved

leiInitiated

initiated

leiGenericEvent

generic event

leiInputAlarmed

input alarmed

leiInputNormal

input normal

leiInputLowLow

input low low

leiInputLow

input low

leiInputHigh

input high

leiInputHighHigh

input high high

leiDoorOpen

door open

leiDoorClose

door close

leiCommunicationsWithHostLost

communications with host lost

leiCommunicationsWithHostRestored

communications with host restored

leiCallEnded

call ended

leiCallEstablished

call established

leiUnansweredCall

unanswered call

leiCallTransferred

call transferred

leiCallConferenced

call conferenced

leiAccessDeniedEscortTimeoutExpired

access denied: escort timeout expired

leiCallQueued

call queued

leiAccessDeniedAreaOccupied

access denied: area occupied

leiAccessDeniedNoOccupantApproval

access denied: no occupant approval

leiDeniedBadgeNotinPanel

denied, badge not in panel

leiIntercomExchangeFailure

intercom exchange failure

leiIntrusionCommandDenied

intrusion command denied

leiIntrusionCommandAccepted

intrusion command accepted

leiAlarmMaskGroupArmed

alarm mask group armed

leiAlarmMaskGroupDisarmed

alarm mask group disarmed

leiAlarmMaskGroupForceArmed

alarm mask group force armed

leiAlarmMaskGroupMaskCountIncremented

alarm mask group mask count incremented

leiAlarmMaskGroupMaskCountDecremented

alarm mask group mask count decremented

leiAlarmMaskGroupArmingFailureActivePoints

alarm mask group arming failure, active points

leiAccessDeniedAreaEmpty

access denied: area empty

leiElevatorTerminalModeDefaultFloororUserEntryofDestinationFloor

elevator terminal mode default floor or user entry of destination floor

leiUnknownElevatorTerminal

unknown elevator terminal

leiOpenDoorCommandIssuedDoorUsed

open door command issued - door used

leiOpenDoorCommandIssuedDoorNotUsed

open door command issued - door not used

leiRequesttoExitDoorUsed

request to exit - door used

leiRequesttoExitDoorNotUsed

request to exit - door not used

leiElevatorTerminalModeDefaultFloor

elevator terminal mode default floor

leiElevatorTerminalModeAccesstoAuthorizedFloors

elevator terminal mode access to authorized floors

leiElevatorTerminalModeUserEntryofDestinationFloor

elevator terminal mode user entry of destination floor

leiReaderOffline

reader offline

leiReaderOfflineRestored

reader offline restored

leiUnknownUserCommand

unknown user command

leiAccessDeniedAssetRequired

access denied: asset required

leiAccessDeniedSpecial

access denied

leiUnknown

Definition at line 1164 of file GscActionsTypes.h.

enum TPlcIODeviceType

Specifies the type of the io device.

Enumerator:
dioDeviceTypeMIO

MIO84.

dioDeviceTypeIOI43

IOI43.

dioUnknown

Definition at line 1341 of file GscActionsTypes.h.

enum TPlcTrafficDirection

Traffic direction.

Enumerator:
tfdIn

in

tfdOut

out

tfdUnspecified

unknown

tfdUnknown

Definition at line 1351 of file GscActionsTypes.h.

enum TPlcPPAlarmState

PP alarm state.

Enumerator:
pasNormal

normal

pasAlarm

alarm

pasUnknown

Definition at line 1362 of file GscActionsTypes.h.

enum TPlcPPCableKind

PP cable kind.

Enumerator:
pckCableA

cable A

pckCableB

cable B

pckUnknown

Definition at line 1372 of file GscActionsTypes.h.

enum TPlcPPSensorKind

PP sensor kind.

Enumerator:
pskCableAFault

cable A fault

pskCableBFault

cable B fault

pskTamper

tamper

pskTrap

trap

pskSensor

sensor

pskPath

path

pskAux

aux

pskService

service

pskUnknown

Definition at line 1382 of file GscActionsTypes.h.

enum TPlcIPSwitchOps

IP switch operation.

Enumerator:
ipoPOEOn

PoE on.

ipoPOEOff

PoE off.

ipoPOEReset

PoE reset.

ipoPOEDelayedReset

PoE delayed reset.

ipoUnknown

Definition at line 1398 of file GscActionsTypes.h.

enum GscParameterType

Available parameter types.

Enumerator:
pt___int32

32 bit integer values

pt___int64

64 bit integer values

pt_TGLibDateTime

date / time values

pt_string

ANSI strings (0-terminated).

pt_widestring

UNICODE strings (0-terminated).

pt_bool

boolean values

pt_GUID

GUID values.

pt_TEventTypeID

event type struct

pt_TMediaChannelID

media channel struct

pt_TResourceID

resource ID struct

pt_DigitalInputState

State of the digital input contact.

pt_DigitalOutputState

State of the digital output contact.

pt_VideoSignalNorm

Norm of the video input signal.

pt_VideoSignalType

Type of the video input signal.

pt_VideoInterlaceType

Interlace kind of the video input signal.

pt_ADArea

Activity detection area.

pt_VMDGroup

VMD group.

pt_SystemLED

System LED.

pt_VideoSensorKind

Video sensor type.

pt_UserLoginFailureCode

User login failure code.

pt_PlcMessageSource

Source of the message.

pt_PlcMessageCode

Code of the message.

pt_PlcViewerAlarmQueueSelection

Viewer alarm queue selection mode.

pt_ABCapacityWarning

Auto backup capacity monitoring warning.

pt_PlcObtrackObjectStatus

OBTRACK object status.

pt_PlcObtrackObjectClass

OBTRACK object class.

pt_PlcDatabaseStatus

Database status.

pt_PlcObtrackProcessSize

OBTRACK process size.

pt_SystemKey

GEVISCOPE system key.

pt_VMDCycle

VMD measure cycle.

pt_SafebagStep

Safebag step.

pt_PlcObtrackCounterType

OBTRACK counter type.

pt_PlcObtrackExceedingDirection

OBTRACK exceeding direction.

pt_PlcTunnelAlarmReason

Tunnel alarm reason.

pt_PlcViewerPlayMode

Viewer play mode.

pt_PlcViewerAlarmPlayMode

Viewer alarm play mode.

pt_PlcViewerAlarmState

Viewer alarm state notification.

pt_PlcImageExportType

Image export type.

pt_PlcDatabaseRing

Database ring.

pt_PlcPluginError

Plugin error code.

pt_PlcClientType

Client type.

pt_PlcFRCNotification

FRC notification.

pt_PlcResourceKind

PLC resource kind.

pt_PlcResourceChangeKind

PLC resource change kind.

pt_PlcPOSStatus

PLC POS status.

pt_PlcNPRRestriction

PLC POS status.

pt_PlcSpecialConstants

Special constants.

pt_PlcPluginState

Plugin state.

pt_PlcPumpStatus

PLC pump status.

pt_PlcDayNightMode

Day/night mode.

pt_PlcBacklightMode

Backlight compensation mode.

pt_PlcSkidataControl

SKIDATA control message.

pt_PlcSkidataMsgCodeEntry

SKIDATA message entry.

pt_PlcSkidataMsgCodeExit

SKIDATA message exit.

pt_PlcSkidataMsgCodeTransaction

SKIDATA message transaction.

pt_PlcExportMarker

Export marker.

pt_PlcBackupFormat

Backup format.

pt_PlcExportSuccess

Export success state.

pt_PlcExportAbort

Export abort flag.

pt_PlcLpsStatus

Position query status.

pt_PlcSceneStoreModificationType

Scene store modification type.

pt_GTectSceneAlarmReason

G-Tect alarm reason.

pt_GTectClientVCAType

G-Tect client VCA type.

pt_LenelAccessResult

Lenel access result.

pt_LenelEventType

Lenel event type.

pt_LenelEventID

Lenel event ID.

pt_IODeviceType

Specifies the type of the io device.

pt_TrafficDirection

Traffic direction.

pt_PPAlarmState

PP alarm state.

pt_PPCableKind

PP cable kind.

pt_PPSensorKind

PP sensor kind.

pt_IPSwitchOps

IP switch operation.

pt_double

double value

pt_TPlcRect

PLC rect value.

pt_Unknown

Definition at line 1411 of file GscActionsTypes.h.

enum GscParameterView

Available parameter views.

Enumerator:
pv_Default

default view

pv_UserName

parameter represents user name

pv_DeviceType

parameter represents device type

pv_DeviceName

parameter represents device name

pv_VideoInput

parameter represents video input channel

pv_VideoOutput

parameter represents video output channel

pv_InputContact

parameter represents input contact

pv_OutputContact

parameter represents output contact

pv_PTZHead

parameter represents PTZ head

pv_TimeRange

parameter represents time range

pv_Event

parameter represents event type

pv_AudioInput

parameter represents audio input channel

pv_AudioOutput

parameter represents audio output channel

pv_ADParameterSet

parameter represents AD parameter set

pv_VMDParameterSet

parameter represents VMD parameter set

pv_WindowsError

parameter represents Windows error code

pv_DeviceSubType

parameter represents device sub type

pv_ForeignKey

parameter represents foreign key

pv_CPAParameterSet

parameter represents CPA parameter set

pv_ObtrackParameterSet

parameter represents OBTRACK parameter set

pv_ABDestination

parameter represents auto backup destination

pv_ABSchedule

parameter represents auto backup schedule

pv_HardwareModule

parameter represents hardware module

pv_CameraProfile

parameter represents camera profile

pv_GTectParameterSet

parameter represents G-Tect parameter set

pv_ImexDestination

parameter represents image export destination

pv_Unknown

Definition at line 1493 of file GscActionsTypes.h.

Variable Documentation

const unsigned __int32 FlagDisableResourceUpdate = 0x00000001

Disable resource update callback.

Definition at line 33 of file GscActionsTypes.h.

const unsigned __int32 FlagDisableInternalInEventData = 0x00000002

Disable storing internal data in event data struct.

Definition at line 36 of file GscActionsTypes.h.

const unsigned __int32 TPlcUpdateActionInfoCallbackVersion = 1

update callback definition version

Definition at line 1646 of file GscActionsTypes.h.


GSC actions: General definitions

Functions | Variables

General definitions
[GscActions.dll]

Collaboration diagram for General definitions:

Detailed Description

General definitions for GscActions.DLL.

imported functions

Important constants.

   #include "GscActions.h"
   using namespace GscPLC;

General functions

Functions

GSCACTDLLCALL int __stdcall | GscAct_InterfaceVersion ()
Get the interface version number of the used GscActions.dll.
GSCACTDLLCALL const char *__stdcall | GscAct_InterfaceDate ()
Get the interface release date of the used GscActions.dll.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfOpenHandles ()
Get the number of open action/message handles.

Variables

const char | GscActionsDll [] = "GscActions.DLL"
DLL name.
const int | GscActionAPIVersion = 95
API version.
const char | GscActionAPIDate [] = "05.09.2013"
API release date.

Function Documentation

GSCACTDLLCALL int __stdcall GscAct_InterfaceVersion ( )

Get the interface version number of the used GscActions.dll.

Should be checked against the GscActionAPIVersion to ensure one works with a compatible DLL.

Returns:
interface version number
GSCACTDLLCALL const char* __stdcall GscAct_InterfaceDate ( )

Get the interface release date of the used GscActions.dll.

Returns:
interface release date
GSCACTDLLCALL unsigned int __stdcall GscAct_GetNumberOfOpenHandles ( )

Get the number of open action/message handles.

Use this function to detect memory leaks.

Returns:
number of open action/message handles.

Variable Documentation

const char GscActionsDll[] = "GscActions.DLL"

DLL name.

Definition at line 45 of file GscActions.h.

const int GscActionAPIVersion = 95

API version.

Definition at line 47 of file GscActions.h.

const char GscActionAPIDate[] = "05.09.2013"

API release date.

Definition at line 49 of file GscActions.h.


GSC actions: Error handling

Classes | Functions

Error handling
[GscActions.dll]

Collaboration diagram for Error handling:

Detailed Description

Error handling for GscActions.DLL.

Error handling.

Interface functions do not throw any exceptions. Functions, which can fail, return a boolean value. true indicates success, false - the failure. To get extended information in failure case use GscAct_GetLastError. Call this function also when functions returning handles return NULL.

Classes

struct | TPlcLastError
Structure which holds last error info. More...

Functions

GSCACTDLLCALL bool __stdcall | GscAct_GetLastError (TPlcLastError &LastError)
Get information about the last occured error in the current thread.

Function Documentation

GSCACTDLLCALL bool __stdcall GscAct_GetLastError ( TPlcLastError & LastError )

Get information about the last occured error in the current thread.

Should be called when any of the other API functions returns false.

Parameters:
[out] LastError Reference to structure where to store the information.
Returns:
true if last error info is available and false otherwise.


GSC actions: Actions

Modules

Actions
[GscActions.dll]

Collaboration diagram for Actions:

Detailed Description

List of all actions.

Modules

ATM/ACS

ATM and ACS actions.

Audio control

All actions to control the audio streams, also all notifications about the state change of the audio streams.

Backup actions

All actions for backup.

Camera control

All actions to remote control the PTZ heads or camera adjustments.

Cash management actions

All actions for cash management.

Device information

All actions for low-level notification of the device or media channels changes.

Digital contacts

All actions for handling digital inputs and outputs.

Imex

Image export.

LPS

LPS messages.

Lenel

Lenel.

POS

POS (point of sale).

Perimeter protection

Perimeter protection.

Remote export

Remote export.

SKIDATA

SKIDATA messages.

Supply chain security

Supply chain security.

System actions

All actions describing system behaviour.

Video control

All actions to control the video streams, also all notifications about the state change of the video streams.

Viewer actions

All actions for viewer customizing.

Viewer notifications

All viewer notifications.


GSC actions: ATM/ACS

Modules

ATM/ACS
[Actions]

Collaboration diagram for ATM/ACS:

Detailed Description

ATM and ACS actions.

Modules

ACS access denied

ACS access denied.

ACS access granted

ACS access granted.

ACS raw answer

ACS raw answer.

ACS raw data

ACS raw data.

ATM raw answer

ATM raw answer.

ATM raw data

ATM raw data.

ATM transaction

ATM transaction.


GSC actions: ACS access denied

ACS access denied
[ATM/ACS]

Collaboration diagram for ACS access denied:

ACS access denied.

ACS access denied.

Parameters

Name | Type | Description
ACSName | widestring | ACS
ACS name.
ACSNo | __int32 | ACS no
optional | ACS no.
Account | __int64 | account
optional | Account no.
BancCode | __int64 | bank code
optional | Bank code.
CardNo | widestring | card no
optional | Card no.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
Reason | __int32 | reason
optional | Reason.

Example how to create this action:

   const wchar_t*  ACSName         = L"ACS";

   HGscAction anAction;
   anAction = GscAct_CreateACSAccessDenied(ACSName, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ACSName;
   const __int32*  ACSNo;
   const __int64*  Account;
   const __int64*  BancCode;
   const wchar_t*  CardNo;
   const TGLibDateTime* TimeStamp;
   const __int32*  Reason;

   if (! GscAct_DecodeACSAccessDenied(anAction, ACSName, ACSNo, Account, BancCode, CardNo, TimeStamp, Reason))
   {
     // error handling
   }


GSC actions: ACS access granted

ACS access granted
[ATM/ACS]

Collaboration diagram for ACS access granted:

ACS access granted.

ACS access granted.

Parameters

Name | Type | Description
ACSName | widestring | ACS
ACS name.
ACSNo | __int32 | ACS no
optional | ACS no.
Account | __int64 | account
optional | Account no.
BancCode | __int64 | bank code
optional | Bank code.
CardNo | widestring | card no
optional | Card no.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.

Example how to create this action:

   const wchar_t*  ACSName         = L"ACS";

   HGscAction anAction;
   anAction = GscAct_CreateACSAccessGranted(ACSName, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ACSName;
   const __int32*  ACSNo;
   const __int64*  Account;
   const __int64*  BancCode;
   const wchar_t*  CardNo;
   const TGLibDateTime* TimeStamp;

   if (! GscAct_DecodeACSAccessGranted(anAction, ACSName, ACSNo, Account, BancCode, CardNo, TimeStamp))
   {
     // error handling
   }


GSC actions: ACS raw answer

ACS raw answer
[ATM/ACS]

Collaboration diagram for ACS raw answer:

ACS raw answer.

ACS raw answer.

Parameters

Name | Type | Description
ACSName | widestring | ACS
ACS name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ACSData | widestring | answer
ACS answer.

Example how to create this action:

   const wchar_t*  ACSName         = L"ACS";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  ACSData         = L"answer";

   HGscAction anAction;
   anAction = GscAct_CreateACSRawAnswer(ACSName, TimeStamp, ACSData);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ACSName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  ACSData;

   if (! GscAct_DecodeACSRawAnswer(anAction, ACSName, TimeStamp, ACSData))
   {
     // error handling
   }


GSC actions: ACS raw data

ACS raw data
[ATM/ACS]

Collaboration diagram for ACS raw data:

ACS raw data.

ACS raw data.

Parameters

Name | Type | Description
ACSName | widestring | ACS
ACS name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ACSData | widestring | data
ACS data.

Example how to create this action:

   const wchar_t*  ACSName         = L"ACS";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  ACSData         = L"data";

   HGscAction anAction;
   anAction = GscAct_CreateACSRawData(ACSName, TimeStamp, ACSData);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ACSName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  ACSData;

   if (! GscAct_DecodeACSRawData(anAction, ACSName, TimeStamp, ACSData))
   {
     // error handling
   }


GSC actions: ATM raw answer

ATM raw answer
[ATM/ACS]

Collaboration diagram for ATM raw answer:

ATM raw answer.

ATM raw answer.

Parameters

Name | Type | Description
ATMName | widestring | ATM
ATM name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ATMData | widestring | answer
ATM answer.

Example how to create this action:

   const wchar_t*  ATMName         = L"ATM";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  ATMData         = L"answer";

   HGscAction anAction;
   anAction = GscAct_CreateATMRawAnswer(ATMName, TimeStamp, ATMData);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ATMName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  ATMData;

   if (! GscAct_DecodeATMRawAnswer(anAction, ATMName, TimeStamp, ATMData))
   {
     // error handling
   }


GSC actions: ATM raw data

ATM raw data
[ATM/ACS]

Collaboration diagram for ATM raw data:

ATM raw data.

ATM raw data.

Parameters

Name | Type | Description
ATMName | widestring | ATM
ATM name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ATMData | widestring | data
ATM data.

Example how to create this action:

   const wchar_t*  ATMName         = L"ATM";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  ATMData         = L"data";

   HGscAction anAction;
   anAction = GscAct_CreateATMRawData(ATMName, TimeStamp, ATMData);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ATMName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  ATMData;

   if (! GscAct_DecodeATMRawData(anAction, ATMName, TimeStamp, ATMData))
   {
     // error handling
   }


GSC actions: ATM transaction

ATM transaction
[ATM/ACS]

Collaboration diagram for ATM transaction:

ATM transaction.

ATM transaction.

Parameters

Name | Type | Description
ATMName | widestring | ATM
ATM name.
NewTransaction | bool | new transaction
New transaction.
Photostep | __int32 | photostep
Photostep.
ATMNo | __int32 | ATM no
optional | ATM no.
Account | __int64 | account
optional | Account no.
BancCode | __int64 | bank code
optional | Bank code.
CardNo | widestring | card no
optional | Card no.
TAN1 | __int64 | tan 1
optional | TAN 1.
TAN2 | __int64 | tan 2
optional | TAN 2.
TimeStamp1 | TGLibDateTime | time stamp 1
optional | Time stamp 1.
TimeStamp2 | TGLibDateTime | time stamp 2
optional | Time stamp 2.
Amount | double | amount
optional | Amount.
Currency | widestring | currency
optional | Currency.

Example how to create this action:

   const wchar_t*  ATMName         = L"ATM";
   bool            NewTransaction  = false;
   __int32         Photostep       = 1;

   HGscAction anAction;
   anAction = GscAct_CreateATMTransaction(ATMName, NewTransaction, Photostep, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ATMName;
   bool            NewTransaction;
   __int32         Photostep;
   const __int32*  ATMNo;
   const __int64*  Account;
   const __int64*  BancCode;
   const wchar_t*  CardNo;
   const __int64*  TAN1;
   const __int64*  TAN2;
   const TGLibDateTime* TimeStamp1;
   const TGLibDateTime* TimeStamp2;
   const double*   Amount;
   const wchar_t*  Currency;

   if (! GscAct_DecodeATMTransaction(anAction, ATMName, NewTransaction, Photostep, ATMNo, Account, BancCode, CardNo, TAN1, TAN2, TimeStamp1, TimeStamp2, Amount, Currency))
   {
     // error handling
   }


GSC actions: Audio control

Modules

Audio control
[Actions]

Collaboration diagram for Audio control:

Detailed Description

All actions to control the audio streams, also all notifications about the state change of the audio streams.

Modules

ABC connect

Connect audio back channel.

ABC disconnect

Disconnect audio back channel.

ABC play file

Play file on audio back channel.

Sensor audio alarm

Audio alarm detected.


GSC actions: ABC connect

ABC connect
[Audio control]

Collaboration diagram for ABC connect:

Connect audio back channel.

Connect audio back channel.

Parameters

Name | Type | Description
Address | widestring | address
Address of the remote server.

Example how to create this action:

   const wchar_t*  Address         = L"address";

   HGscAction anAction;
   anAction = GscAct_CreateABCConnect(Address);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  Address;

   if (! GscAct_DecodeABCConnect(anAction, Address))
   {
     // error handling
   }


GSC actions: ABC disconnect

ABC disconnect
[Audio control]

Collaboration diagram for ABC disconnect:

Disconnect audio back channel.

Disconnect audio back channel.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateABCDisconnect();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeABCDisconnect(anAction))
   {
     // error handling
   }


GSC actions: ABC play file

ABC play file
[Audio control]

Collaboration diagram for ABC play file:

Play file on audio back channel.

Play file on audio back channel.

Parameters

Name | Type | Description
FileID | __int64 | file ID
File ID.
FileName | widestring | file name
Name of the file.
AutoRepeat | bool | repeat
Repeat file automatically

Example how to create this action:

   __int64         FileID          = 1;
   const wchar_t*  FileName        = L"file name";
   bool            AutoRepeat      = false;

   HGscAction anAction;
   anAction = GscAct_CreateABCPlayFile(FileID, FileName, AutoRepeat);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         FileID;
   const wchar_t*  FileName;
   bool            AutoRepeat;

   if (! GscAct_DecodeABCPlayFile(anAction, FileID, FileName, AutoRepeat))
   {
     // error handling
   }


GSC actions: Sensor audio alarm

Sensor audio alarm
[Audio control]

Collaboration diagram for Sensor audio alarm:

Audio alarm detected.

Audio alarm detected.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateSensorAudioAlarm(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeSensorAudioAlarm(anAction, Channel))
   {
     // error handling
   }


GSC actions: Backup actions

Modules

Backup actions
[Actions]

Collaboration diagram for Backup actions:

Detailed Description

All actions for backup.

Modules

Abort all auto backups

Abort all auto backups.

Abort auto backup

Abort auto backup.

Auto backup capacity file auto deleted

Auto backup capacity monitoring: file auto deleted.

Auto backup capacity out of disk space

Auto backup capacity monitoring: out of disk space.

Auto backup capacity warning

Auto backup capacity monitoring: capacity warning.

Auto backup file done

Auto backup progress notification: file done.

Auto backup file progress

Auto backup progress notification: file progress.

Auto backup file started

Auto backup progress notification: file started.

Auto backup operation done

Auto backup progress notification: operation done.

Auto backup operation started

Auto backup progress notification: operation started.

Auto backup schedule done

Auto backup progress notification: schedule done.

Auto backup schedule started

Auto backup progress notification: schedule started.

Backup event

Backup event.

Event backup done

Event backup progress notification: backup done.

Event backup file done

Event backup progress notification: file done.

Event backup file progress

Event backup progress notification: file progress.

Event backup file started

Event backup progress notification: file started.

Event backup started

Event backup progress notification: backup started.

Start auto backup

Start auto backup.


GSC actions: Abort all auto backups

Abort all auto backups
[Backup actions]

Collaboration diagram for Abort all auto backups:

Abort all auto backups.

Abort all auto backups.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateAbortAllAutoBackups();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeAbortAllAutoBackups(anAction))
   {
     // error handling
   }


GSC actions: Abort auto backup

Abort auto backup
[Backup actions]

Collaboration diagram for Abort auto backup:

Abort auto backup.

Abort auto backup.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateAbortAutoBackup(Schedule);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;

   if (! GscAct_DecodeAbortAutoBackup(anAction, Schedule))
   {
     // error handling
   }


GSC actions: Auto backup capacity file auto deleted

Auto backup capacity file auto deleted
[Backup actions]

Collaboration diagram for Auto backup capacity file auto deleted:

Auto backup capacity monitoring: file auto deleted.

Auto backup capacity monitoring: file auto deleted.

Parameters

Name | Type | Description
Warning | ABCapacityWarning | warning
Warning.
Destination | TResourceID | destination
Destination.
TotalCapacity | __int64 | total capacity
Total capacity.
FreeCapacity | __int64 | free capacity
Free capacity.
AllocatedByGbf | __int64 | allocated by GBF
Allocated by GBF.
PercentFree | __int32 | percent free
Percent free.
PercentAllocated | __int32 | percent allocated
Percent allocated.
PercentAllocatedByGbf | __int32 | percent allocated by GBF
Percent allocated by GBF.
FileSize | __int64 | file size
File size.
FileName | widestring | file name
File name.

Example how to create this action:

   ABCapacityWarning Warning         = abwOk;
   TResourceID     Destination     = {0, L"", 0};
   __int64         TotalCapacity   = 1;
   __int64         FreeCapacity    = 1;
   __int64         AllocatedByGbf  = 1;
   __int32         PercentFree     = 1;
   __int32         PercentAllocated = 1;
   __int32         PercentAllocatedByGbf = 1;
   __int64         FileSize        = 1;
   const wchar_t*  FileName        = L"file name";

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupCapacityMonitoringFileAutoDeleted(Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByGbf, PercentFree, PercentAllocated, PercentAllocatedByGbf, FileSize, FileName);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   ABCapacityWarning Warning;
   TResourceID     Destination;
   __int64         TotalCapacity;
   __int64         FreeCapacity;
   __int64         AllocatedByGbf;
   __int32         PercentFree;
   __int32         PercentAllocated;
   __int32         PercentAllocatedByGbf;
   __int64         FileSize;
   const wchar_t*  FileName;

   if (! GscAct_DecodeAutoBackupCapacityMonitoringFileAutoDeleted(anAction, Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByGbf, PercentFree, PercentAllocated, PercentAllocatedByGbf, FileSize, FileName))
   {
     // error handling
   }


GSC actions: Auto backup capacity out of disk space

Auto backup capacity out of disk space
[Backup actions]

Collaboration diagram for Auto backup capacity out of disk space:

Auto backup capacity monitoring: out of disk space.

Auto backup capacity monitoring: out of disk space.

Parameters

Name | Type | Description
Warning | ABCapacityWarning | warning
Warning.
Destination | TResourceID | destination
Destination.
TotalCapacity | __int64 | total capacity
Total capacity.
FreeCapacity | __int64 | free capacity
Free capacity.
AllocatedByGbf | __int64 | allocated by GBF
Allocated by GBF.
PercentFree | __int32 | percent free
Percent free.
PercentAllocated | __int32 | percent allocated
Percent allocated.
PercentAllocatedByGbf | __int32 | percent allocated by GBF
Percent allocated by GBF.

Example how to create this action:

   ABCapacityWarning Warning         = abwOk;
   TResourceID     Destination     = {0, L"", 0};
   __int64         TotalCapacity   = 1;
   __int64         FreeCapacity    = 1;
   __int64         AllocatedByGbf  = 1;
   __int32         PercentFree     = 1;
   __int32         PercentAllocated = 1;
   __int32         PercentAllocatedByGbf = 1;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupCapacityMonitoringOutOfDiskSpace(Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByGbf, PercentFree, PercentAllocated, PercentAllocatedByGbf);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   ABCapacityWarning Warning;
   TResourceID     Destination;
   __int64         TotalCapacity;
   __int64         FreeCapacity;
   __int64         AllocatedByGbf;
   __int32         PercentFree;
   __int32         PercentAllocated;
   __int32         PercentAllocatedByGbf;

   if (! GscAct_DecodeAutoBackupCapacityMonitoringOutOfDiskSpace(anAction, Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByGbf, PercentFree, PercentAllocated, PercentAllocatedByGbf))
   {
     // error handling
   }


GSC actions: Auto backup capacity warning

Auto backup capacity warning
[Backup actions]

Collaboration diagram for Auto backup capacity warning:

Auto backup capacity monitoring: capacity warning.

Auto backup capacity monitoring: capacity warning.

Parameters

Name | Type | Description
Warning | ABCapacityWarning | warning
Warning.
Destination | TResourceID | destination
Destination.
TotalCapacity | __int64 | total capacity
Total capacity.
FreeCapacity | __int64 | free capacity
Free capacity.
AllocatedByGbf | __int64 | allocated by GBF
Allocated by GBF.
PercentFree | __int32 | percent free
Percent free.
PercentAllocated | __int32 | percent allocated
Percent allocated.
PercentAllocatedByGbf | __int32 | percent allocated by GBF
Percent allocated by GBF.

Example how to create this action:

   ABCapacityWarning Warning         = abwOk;
   TResourceID     Destination     = {0, L"", 0};
   __int64         TotalCapacity   = 1;
   __int64         FreeCapacity    = 1;
   __int64         AllocatedByGbf  = 1;
   __int32         PercentFree     = 1;
   __int32         PercentAllocated = 1;
   __int32         PercentAllocatedByGbf = 1;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupCapacityMonitoringCapacityWarning(Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByGbf, PercentFree, PercentAllocated, PercentAllocatedByGbf);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   ABCapacityWarning Warning;
   TResourceID     Destination;
   __int64         TotalCapacity;
   __int64         FreeCapacity;
   __int64         AllocatedByGbf;
   __int32         PercentFree;
   __int32         PercentAllocated;
   __int32         PercentAllocatedByGbf;

   if (! GscAct_DecodeAutoBackupCapacityMonitoringCapacityWarning(anAction, Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByGbf, PercentFree, PercentAllocated, PercentAllocatedByGbf))
   {
     // error handling
   }


GSC actions: Auto backup file done

Auto backup file done
[Backup actions]

Collaboration diagram for Auto backup file done:

Auto backup progress notification: file done.

Auto backup progress notification: file done.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.
StartTime | TGLibDateTime | start time
optional | Start time, empty during event backup.
EffectiveStartTime | TGLibDateTime | effective start time
Effective schedule start time.
OperationCount | __int32 | operation count
Operation count.
TimerStart | bool | timer start
Timer start.
OperationIndex | __int32 | operation index
Operation index.
OperationStartTime | TGLibDateTime | operation start time
Operation start time.
Source | TResourceID | source
Source.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
FileIndex | __int32 | file index
File index.
FileName | widestring | file name
File name.
FileSize | __int64 | file size
File size.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};
   TGLibDateTime   EffectiveStartTime = TGLibDateTime::Now();
   __int32         OperationCount  = 1;
   bool            TimerStart      = false;
   __int32         OperationIndex  = 1;
   TGLibDateTime   OperationStartTime = TGLibDateTime::Now();
   TResourceID     Source          = {0, L"", 0};
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   __int32         FileIndex       = 1;
   const wchar_t*  FileName        = L"file name";
   __int64         FileSize        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupFileDone(Schedule, NULL, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit, FileIndex, FileName, FileSize);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;
   const TGLibDateTime* StartTime;
   TGLibDateTime   EffectiveStartTime;
   __int32         OperationCount;
   bool            TimerStart;
   __int32         OperationIndex;
   TGLibDateTime   OperationStartTime;
   TResourceID     Source;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   __int32         FileIndex;
   const wchar_t*  FileName;
   __int64         FileSize;

   if (! GscAct_DecodeAutoBackupFileDone(anAction, Schedule, StartTime, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit, FileIndex, FileName, FileSize))
   {
     // error handling
   }


GSC actions: Auto backup file progress

Auto backup file progress
[Backup actions]

Collaboration diagram for Auto backup file progress:

Auto backup progress notification: file progress.

Auto backup progress notification: file progress.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.
StartTime | TGLibDateTime | start time
optional | Start time, empty during event backup.
EffectiveStartTime | TGLibDateTime | effective start time
Effective schedule start time.
OperationCount | __int32 | operation count
Operation count.
TimerStart | bool | timer start
Timer start.
OperationIndex | __int32 | operation index
Operation index.
OperationStartTime | TGLibDateTime | operation start time
Operation start time.
Source | TResourceID | source
Source.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
FileIndex | __int32 | file index
File index.
FileName | widestring | file name
File name.
FileSize | __int64 | file size
File size.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};
   TGLibDateTime   EffectiveStartTime = TGLibDateTime::Now();
   __int32         OperationCount  = 1;
   bool            TimerStart      = false;
   __int32         OperationIndex  = 1;
   TGLibDateTime   OperationStartTime = TGLibDateTime::Now();
   TResourceID     Source          = {0, L"", 0};
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   __int32         FileIndex       = 1;
   const wchar_t*  FileName        = L"file name";
   __int64         FileSize        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupFileProgress(Schedule, NULL, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit, FileIndex, FileName, FileSize);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;
   const TGLibDateTime* StartTime;
   TGLibDateTime   EffectiveStartTime;
   __int32         OperationCount;
   bool            TimerStart;
   __int32         OperationIndex;
   TGLibDateTime   OperationStartTime;
   TResourceID     Source;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   __int32         FileIndex;
   const wchar_t*  FileName;
   __int64         FileSize;

   if (! GscAct_DecodeAutoBackupFileProgress(anAction, Schedule, StartTime, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit, FileIndex, FileName, FileSize))
   {
     // error handling
   }


GSC actions: Auto backup file started

Auto backup file started
[Backup actions]

Collaboration diagram for Auto backup file started:

Auto backup progress notification: file started.

Auto backup progress notification: file started.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.
StartTime | TGLibDateTime | start time
optional | Start time, empty during event backup.
EffectiveStartTime | TGLibDateTime | effective start time
Effective schedule start time.
OperationCount | __int32 | operation count
Operation count.
TimerStart | bool | timer start
Timer start.
OperationIndex | __int32 | operation index
Operation index.
OperationStartTime | TGLibDateTime | operation start time
Operation start time.
Source | TResourceID | source
Source.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
FileIndex | __int32 | file index
File index.
FileName | widestring | file name
File name.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};
   TGLibDateTime   EffectiveStartTime = TGLibDateTime::Now();
   __int32         OperationCount  = 1;
   bool            TimerStart      = false;
   __int32         OperationIndex  = 1;
   TGLibDateTime   OperationStartTime = TGLibDateTime::Now();
   TResourceID     Source          = {0, L"", 0};
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   __int32         FileIndex       = 1;
   const wchar_t*  FileName        = L"file name";

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupFileStarted(Schedule, NULL, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit, FileIndex, FileName);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;
   const TGLibDateTime* StartTime;
   TGLibDateTime   EffectiveStartTime;
   __int32         OperationCount;
   bool            TimerStart;
   __int32         OperationIndex;
   TGLibDateTime   OperationStartTime;
   TResourceID     Source;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   __int32         FileIndex;
   const wchar_t*  FileName;

   if (! GscAct_DecodeAutoBackupFileStarted(anAction, Schedule, StartTime, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit, FileIndex, FileName))
   {
     // error handling
   }


GSC actions: Auto backup operation done

Auto backup operation done
[Backup actions]

Collaboration diagram for Auto backup operation done:

Auto backup progress notification: operation done.

Auto backup progress notification: operation done.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.
StartTime | TGLibDateTime | start time
optional | Start time, empty during event backup.
EffectiveStartTime | TGLibDateTime | effective start time
Effective schedule start time.
OperationCount | __int32 | operation count
Operation count.
TimerStart | bool | timer start
Timer start.
OperationIndex | __int32 | operation index
Operation index.
OperationStartTime | TGLibDateTime | operation start time
Operation start time.
OperationStopTime | TGLibDateTime | operation stop time
Operation stop time.
Source | TResourceID | source
Source.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
OperationErrorCode | __int32 | error code
optional | Operation error code.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};
   TGLibDateTime   EffectiveStartTime = TGLibDateTime::Now();
   __int32         OperationCount  = 1;
   bool            TimerStart      = false;
   __int32         OperationIndex  = 1;
   TGLibDateTime   OperationStartTime = TGLibDateTime::Now();
   TGLibDateTime   OperationStopTime = TGLibDateTime::Now();
   TResourceID     Source          = {0, L"", 0};
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupOperationDone(Schedule, NULL, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, OperationStopTime, Source, Destination, FileSizeLimit, BandWidthLimit, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;
   const TGLibDateTime* StartTime;
   TGLibDateTime   EffectiveStartTime;
   __int32         OperationCount;
   bool            TimerStart;
   __int32         OperationIndex;
   TGLibDateTime   OperationStartTime;
   TGLibDateTime   OperationStopTime;
   TResourceID     Source;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   const __int32*  OperationErrorCode;

   if (! GscAct_DecodeAutoBackupOperationDone(anAction, Schedule, StartTime, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, OperationStopTime, Source, Destination, FileSizeLimit, BandWidthLimit, OperationErrorCode))
   {
     // error handling
   }


GSC actions: Auto backup operation started

Auto backup operation started
[Backup actions]

Collaboration diagram for Auto backup operation started:

Auto backup progress notification: operation started.

Auto backup progress notification: operation started.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.
StartTime | TGLibDateTime | start time
optional | Start time, empty during event backup.
EffectiveStartTime | TGLibDateTime | effective start time
Effective schedule start time.
OperationCount | __int32 | operation count
Operation count.
TimerStart | bool | timer start
Timer start.
OperationIndex | __int32 | operation index
Operation index.
OperationStartTime | TGLibDateTime | operation start time
Operation start time.
Source | TResourceID | source
Source.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};
   TGLibDateTime   EffectiveStartTime = TGLibDateTime::Now();
   __int32         OperationCount  = 1;
   bool            TimerStart      = false;
   __int32         OperationIndex  = 1;
   TGLibDateTime   OperationStartTime = TGLibDateTime::Now();
   TResourceID     Source          = {0, L"", 0};
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupOperationStarted(Schedule, NULL, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;
   const TGLibDateTime* StartTime;
   TGLibDateTime   EffectiveStartTime;
   __int32         OperationCount;
   bool            TimerStart;
   __int32         OperationIndex;
   TGLibDateTime   OperationStartTime;
   TResourceID     Source;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;

   if (! GscAct_DecodeAutoBackupOperationStarted(anAction, Schedule, StartTime, EffectiveStartTime, OperationCount, TimerStart, OperationIndex, OperationStartTime, Source, Destination, FileSizeLimit, BandWidthLimit))
   {
     // error handling
   }


GSC actions: Auto backup schedule done

Auto backup schedule done
[Backup actions]

Collaboration diagram for Auto backup schedule done:

Auto backup progress notification: schedule done.

Auto backup progress notification: schedule done.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.
StartTime | TGLibDateTime | start time
optional | Start time, empty during event backup.
EffectiveStartTime | TGLibDateTime | effective start time
Effective schedule start time.
StopTime | TGLibDateTime | stop time
Schedule stop time.
OperationCount | __int32 | operation count
Operation count.
TimerStart | bool | timer start
Timer start.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};
   TGLibDateTime   EffectiveStartTime = TGLibDateTime::Now();
   TGLibDateTime   StopTime        = TGLibDateTime::Now();
   __int32         OperationCount  = 1;
   bool            TimerStart      = false;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupScheduleDone(Schedule, NULL, EffectiveStartTime, StopTime, OperationCount, TimerStart);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;
   const TGLibDateTime* StartTime;
   TGLibDateTime   EffectiveStartTime;
   TGLibDateTime   StopTime;
   __int32         OperationCount;
   bool            TimerStart;

   if (! GscAct_DecodeAutoBackupScheduleDone(anAction, Schedule, StartTime, EffectiveStartTime, StopTime, OperationCount, TimerStart))
   {
     // error handling
   }


GSC actions: Auto backup schedule started

Auto backup schedule started
[Backup actions]

Collaboration diagram for Auto backup schedule started:

Auto backup progress notification: schedule started.

Auto backup progress notification: schedule started.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.
StartTime | TGLibDateTime | start time
optional | Start time, empty during event backup.
EffectiveStartTime | TGLibDateTime | effective start time
Effective schedule start time.
OperationCount | __int32 | operation count
Operation count.
TimerStart | bool | timer start
Timer start.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};
   TGLibDateTime   EffectiveStartTime = TGLibDateTime::Now();
   __int32         OperationCount  = 1;
   bool            TimerStart      = false;

   HGscAction anAction;
   anAction = GscAct_CreateAutoBackupScheduleStarted(Schedule, NULL, EffectiveStartTime, OperationCount, TimerStart);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;
   const TGLibDateTime* StartTime;
   TGLibDateTime   EffectiveStartTime;
   __int32         OperationCount;
   bool            TimerStart;

   if (! GscAct_DecodeAutoBackupScheduleStarted(anAction, Schedule, StartTime, EffectiveStartTime, OperationCount, TimerStart))
   {
     // error handling
   }


GSC actions: Backup event

Backup event
[Backup actions]

Collaboration diagram for Backup event:

Backup event.

Backup event.

Parameters

Name | Type | Description
EventID | __int64 | instance ID
Instance ID of the event.
TypeID | TEventTypeID | event type
Type of the event.
Destination | TResourceID | destination
Destination.
StartHintID | __int64 | start hint ID
optional | Optional start hint ID.
StopHintID | __int64 | stop hint ID
optional | Optional stop hint ID.
Subfolder | widestring | sub folder
optional | Sub folder to backup event.

Example how to create this action:

   __int64         EventID         = 1;
   TEventTypeID    TypeID          = {0, L"", 0};
   TResourceID     Destination     = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateBackupEvent(EventID, TypeID, Destination, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         EventID;
   TEventTypeID    TypeID;
   TResourceID     Destination;
   const __int64*  StartHintID;
   const __int64*  StopHintID;
   const wchar_t*  Subfolder;

   if (! GscAct_DecodeBackupEvent(anAction, EventID, TypeID, Destination, StartHintID, StopHintID, Subfolder))
   {
     // error handling
   }


GSC actions: Event backup done

Event backup done
[Backup actions]

Collaboration diagram for Event backup done:

Event backup progress notification: backup done.

Event backup progress notification: backup done.

Parameters

Name | Type | Description
JobID | GUID | job ID
Backup job ID.
EventTypeID | TEventTypeID | event type
Type of the event.
EventID | __int64 | instance ID
Instance ID of the event.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
StartTime | TGLibDateTime | start time
Backup start time.
StopTime | TGLibDateTime | stop time
Backup stop time.
OperationErrorCode | __int32 | error code
optional | Operation error code.

Example how to create this action:

   GUID            JobID           = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   TEventTypeID    EventTypeID     = {0, L"", 0};
   __int64         EventID         = 1;
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   TGLibDateTime   StopTime        = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateEventBackupDone(JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, StopTime, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            JobID;
   TEventTypeID    EventTypeID;
   __int64         EventID;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   TGLibDateTime   StartTime;
   TGLibDateTime   StopTime;
   const __int32*  OperationErrorCode;

   if (! GscAct_DecodeEventBackupDone(anAction, JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, StopTime, OperationErrorCode))
   {
     // error handling
   }


GSC actions: Event backup file done

Event backup file done
[Backup actions]

Collaboration diagram for Event backup file done:

Event backup progress notification: file done.

Event backup progress notification: file done.

Parameters

Name | Type | Description
JobID | GUID | job ID
Backup job ID.
EventTypeID | TEventTypeID | event type
Type of the event.
EventID | __int64 | instance ID
Instance ID of the event.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
StartTime | TGLibDateTime | start time
Effective backup start time.
FileIndex | __int32 | file index
File index.
FileName | widestring | file name
File name.
FileSize | __int64 | file size
File size.

Example how to create this action:

   GUID            JobID           = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   TEventTypeID    EventTypeID     = {0, L"", 0};
   __int64         EventID         = 1;
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   __int32         FileIndex       = 1;
   const wchar_t*  FileName        = L"file name";
   __int64         FileSize        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateEventBackupFileDone(JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, FileIndex, FileName, FileSize);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            JobID;
   TEventTypeID    EventTypeID;
   __int64         EventID;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   TGLibDateTime   StartTime;
   __int32         FileIndex;
   const wchar_t*  FileName;
   __int64         FileSize;

   if (! GscAct_DecodeEventBackupFileDone(anAction, JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, FileIndex, FileName, FileSize))
   {
     // error handling
   }


GSC actions: Event backup file progress

Event backup file progress
[Backup actions]

Collaboration diagram for Event backup file progress:

Event backup progress notification: file progress.

Event backup progress notification: file progress.

Parameters

Name | Type | Description
JobID | GUID | job ID
Backup job ID.
EventTypeID | TEventTypeID | event type
Type of the event.
EventID | __int64 | instance ID
Instance ID of the event.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
StartTime | TGLibDateTime | start time
Effective backup start time.
FileIndex | __int32 | file index
File index.
FileName | widestring | file name
File name.
FileSize | __int64 | file size
File size.

Example how to create this action:

   GUID            JobID           = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   TEventTypeID    EventTypeID     = {0, L"", 0};
   __int64         EventID         = 1;
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   __int32         FileIndex       = 1;
   const wchar_t*  FileName        = L"file name";
   __int64         FileSize        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateEventBackupFileProgress(JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, FileIndex, FileName, FileSize);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            JobID;
   TEventTypeID    EventTypeID;
   __int64         EventID;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   TGLibDateTime   StartTime;
   __int32         FileIndex;
   const wchar_t*  FileName;
   __int64         FileSize;

   if (! GscAct_DecodeEventBackupFileProgress(anAction, JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, FileIndex, FileName, FileSize))
   {
     // error handling
   }


GSC actions: Event backup file started

Event backup file started
[Backup actions]

Collaboration diagram for Event backup file started:

Event backup progress notification: file started.

Event backup progress notification: file started.

Parameters

Name | Type | Description
JobID | GUID | job ID
Backup job ID.
EventTypeID | TEventTypeID | event type
Type of the event.
EventID | __int64 | instance ID
Instance ID of the event.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
StartTime | TGLibDateTime | start time
Effective backup start time.
FileIndex | __int32 | file index
File index.
FileName | widestring | file name
File name.

Example how to create this action:

   GUID            JobID           = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   TEventTypeID    EventTypeID     = {0, L"", 0};
   __int64         EventID         = 1;
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   __int32         FileIndex       = 1;
   const wchar_t*  FileName        = L"file name";

   HGscAction anAction;
   anAction = GscAct_CreateEventBackupFileStarted(JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, FileIndex, FileName);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            JobID;
   TEventTypeID    EventTypeID;
   __int64         EventID;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   TGLibDateTime   StartTime;
   __int32         FileIndex;
   const wchar_t*  FileName;

   if (! GscAct_DecodeEventBackupFileStarted(anAction, JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime, FileIndex, FileName))
   {
     // error handling
   }


GSC actions: Event backup started

Event backup started
[Backup actions]

Collaboration diagram for Event backup started:

Event backup progress notification: backup started.

Event backup progress notification: backup started.

Parameters

Name | Type | Description
JobID | GUID | job ID
Backup job ID.
EventTypeID | TEventTypeID | event type
Type of the event.
EventID | __int64 | instance ID
Instance ID of the event.
Destination | TResourceID | destination
Destination.
FileSizeLimit | __int64 | file size limit
File size limit.
BandWidthLimit | __int64 | band width limit
Band width limit.
StartTime | TGLibDateTime | start time
Backup start time.

Example how to create this action:

   GUID            JobID           = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   TEventTypeID    EventTypeID     = {0, L"", 0};
   __int64         EventID         = 1;
   TResourceID     Destination     = {0, L"", 0};
   __int64         FileSizeLimit   = 1;
   __int64         BandWidthLimit  = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateEventBackupStarted(JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            JobID;
   TEventTypeID    EventTypeID;
   __int64         EventID;
   TResourceID     Destination;
   __int64         FileSizeLimit;
   __int64         BandWidthLimit;
   TGLibDateTime   StartTime;

   if (! GscAct_DecodeEventBackupStarted(anAction, JobID, EventTypeID, EventID, Destination, FileSizeLimit, BandWidthLimit, StartTime))
   {
     // error handling
   }


GSC actions: Start auto backup

Start auto backup
[Backup actions]

Collaboration diagram for Start auto backup:

Start auto backup.

Start auto backup.

Parameters

Name | Type | Description
Schedule | TResourceID | schedule
Schedule.

Example how to create this action:

   TResourceID     Schedule        = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateStartAutoBackup(Schedule);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     Schedule;

   if (! GscAct_DecodeStartAutoBackup(anAction, Schedule))
   {
     // error handling
   }


GSC actions: Camera control

Modules

Camera control
[Actions]

Collaboration diagram for Camera control:

Detailed Description

All actions to remote control the PTZ heads or camera adjustments.

Modules

Auto focus off

Disable auto focus of the camera.

Auto focus on

Enable auto focus of the camera.

Camera RAW output

Output unformatted command to the camera.

Camera apply profile

Apply a predefined profile settings to the camera.

Camera backlight compensation mode

Change backlight compensation mode of the camera.

Camera clear preset text

Clear camera text for preset position.

Camera day/night mode

Change day/night mode of the camera.

Camera light off

Turn camera light off.

Camera light on

Turn camera light on.

Camera manual iris off

Disable manual iris of the camera.

Camera manual iris on

Enable manual iris of the camera.

Camera off

Turn camera off.

Camera on

Turn camera on.

Camera pump off

Turn camera pump off.

Camera pump on

Turn camera pump on.

Camera select char mode

Select camera character mode.

Camera set preset text

Set camera text for preset position.

Camera spec func U off

Turn camera special function U off.

Camera spec func U on

Turn camera special function U on.

Camera spec func V off

Turn camera special function V off.

Camera spec func V on

Turn camera special function V on.

Camera spec func X off

Turn camera special function X off.

Camera spec func X on

Turn camera special function X on.

Camera spec func Y off

Turn camera special function Y off.

Camera spec func Y on

Turn camera special function Y on.

Camera stop all

Camera stop all.

Camera text off

Disable camera text.

Camera text on

Enable camera text.

Camera tour start

Start camera tour.

Camera tour stop

Stop camera tour.

Camera version off

Hide camera version string.

Camera version on

Show camera version string.

Camera wash-wipe off

Turn camera wash-wipe off.

Camera wash-wipe on

Turn camera wash-wipe on.

Clear default position

Clear camera default position.

Clear preset position

Clear camera preset position.

Fast speed off

Turn camera fast speed off.

Fast speed on

Turn camera fast speed on.

Focus far

Focus camera far.

Focus near

Focus camera near.

Focus stop

Stop camera focus.

Iris close

Close camera iris.

Iris open

Open camera iris.

Iris stop

Stop camera iris.

Move by speed

Move camera by speed.

Move to absolute position

Move camera to absolute position.

Move to default position

Move camera to default position.

Move to preset position

Move camera to preset position.

Move to relative position

Move camera to relative position.

Pan auto

Turn auto pan of the camera.

Pan left

Pan camera to the left.

Pan right

Pan camera to the right.

Pan stop

Stop pan movement.

Save default position

Save current camera position as default position.

Save preset position

Save current camera position as preset position.

Set camera text

Set camera text.

Tilt down

Tilt camera down.

Tilt stop

Stop tilt movement.

Tilt up

Tilt camera up.

Zoom in

Zoom camera in.

Zoom out

Zoom camera out.

Zoom stop

Stop camera zoom.


GSC actions: Auto focus off

Auto focus off
[Camera control]

Collaboration diagram for Auto focus off:

Disable auto focus of the camera.

Disable auto focus of the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateAutoFocusOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeAutoFocusOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Auto focus on

Auto focus on
[Camera control]

Collaboration diagram for Auto focus on:

Enable auto focus of the camera.

Enable auto focus of the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateAutoFocusOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeAutoFocusOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera RAW output

Camera RAW output
[Camera control]

Collaboration diagram for Camera RAW output:

Output unformatted command to the camera.

Output unformatted command to the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Output | string | output
RAW command to output.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   const char*     Output          = "output";

   HGscAction anAction;
   anAction = GscAct_CreateCameraRAWOutput(Camera, Output);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   const char*     Output;

   if (! GscAct_DecodeCameraRAWOutput(anAction, Camera, Output))
   {
     // error handling
   }


GSC actions: Camera apply profile

Camera apply profile
[Camera control]

Collaboration diagram for Camera apply profile:

Apply a predefined profile settings to the camera.

Apply a predefined profile settings to the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Profile | widestring | profile
Profile name.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   const wchar_t*  Profile         = L"profile";

   HGscAction anAction;
   anAction = GscAct_CreateCameraApplyProfile(Camera, Profile);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   const wchar_t*  Profile;

   if (! GscAct_DecodeCameraApplyProfile(anAction, Camera, Profile))
   {
     // error handling
   }


GSC actions: Camera backlight compensation mode

Camera backlight compensation mode
[Camera control]

Collaboration diagram for Camera backlight compensation mode:

Change backlight compensation mode of the camera.

Change backlight compensation mode of the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Mode | PlcBacklightMode | mode
Backlight compensation mode.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   PlcBacklightMode Mode            = pbmOff;

   HGscAction anAction;
   anAction = GscAct_CreateCameraBacklightCompensationMode(Camera, Mode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   PlcBacklightMode Mode;

   if (! GscAct_DecodeCameraBacklightCompensationMode(anAction, Camera, Mode))
   {
     // error handling
   }


GSC actions: Camera clear preset text

Camera clear preset text
[Camera control]

Collaboration diagram for Camera clear preset text:

Clear camera text for preset position.

Clear camera text for preset position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Position | __int32 | position
Preset position.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Position        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateCameraClearPrePosText(Camera, Position);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Position;

   if (! GscAct_DecodeCameraClearPrePosText(anAction, Camera, Position))
   {
     // error handling
   }


GSC actions: Camera day/night mode

Camera day/night mode
[Camera control]

Collaboration diagram for Camera day/night mode:

Change day/night mode of the camera.

Change day/night mode of the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Mode | PlcDayNightMode | mode
Day/night mode.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   PlcDayNightMode Mode            = pdnDay;

   HGscAction anAction;
   anAction = GscAct_CreateCameraDayNightMode(Camera, Mode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   PlcDayNightMode Mode;

   if (! GscAct_DecodeCameraDayNightMode(anAction, Camera, Mode))
   {
     // error handling
   }


GSC actions: Camera light off

Camera light off
[Camera control]

Collaboration diagram for Camera light off:

Turn camera light off.

Turn camera light off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraLightOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraLightOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera light on

Camera light on
[Camera control]

Collaboration diagram for Camera light on:

Turn camera light on.

Turn camera light on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraLightOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraLightOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera manual iris off

Camera manual iris off
[Camera control]

Collaboration diagram for Camera manual iris off:

Disable manual iris of the camera.

Disable manual iris of the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraManualIrisOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraManualIrisOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera manual iris on

Camera manual iris on
[Camera control]

Collaboration diagram for Camera manual iris on:

Enable manual iris of the camera.

Enable manual iris of the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraManualIrisOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraManualIrisOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera off

Camera off
[Camera control]

Collaboration diagram for Camera off:

Turn camera off.

Turn camera off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera on

Camera on
[Camera control]

Collaboration diagram for Camera on:

Turn camera on.

Turn camera on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera pump off

Camera pump off
[Camera control]

Collaboration diagram for Camera pump off:

Turn camera pump off.

Turn camera pump off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraPumpOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraPumpOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera pump on

Camera pump on
[Camera control]

Collaboration diagram for Camera pump on:

Turn camera pump on.

Turn camera pump on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraPumpOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraPumpOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera select char mode

Camera select char mode
[Camera control]

Collaboration diagram for Camera select char mode:

Select camera character mode.

Select camera character mode.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Mode | __int32 | mode
Character mode.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Mode            = 1;

   HGscAction anAction;
   anAction = GscAct_CreateCameraSelectCharMode(Camera, Mode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Mode;

   if (! GscAct_DecodeCameraSelectCharMode(anAction, Camera, Mode))
   {
     // error handling
   }


GSC actions: Camera set preset text

Camera set preset text
[Camera control]

Collaboration diagram for Camera set preset text:

Set camera text for preset position.

Set camera text for preset position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Position | __int32 | position
Preset position.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Position        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateCameraSetPrePosText(Camera, Position);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Position;

   if (! GscAct_DecodeCameraSetPrePosText(anAction, Camera, Position))
   {
     // error handling
   }


GSC actions: Camera spec func U off

Camera spec func U off
[Camera control]

Collaboration diagram for Camera spec func U off:

Turn camera special function U off.

Turn camera special function U off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncUOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncUOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera spec func U on

Camera spec func U on
[Camera control]

Collaboration diagram for Camera spec func U on:

Turn camera special function U on.

Turn camera special function U on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncUOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncUOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera spec func V off

Camera spec func V off
[Camera control]

Collaboration diagram for Camera spec func V off:

Turn camera special function V off.

Turn camera special function V off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncVOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncVOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera spec func V on

Camera spec func V on
[Camera control]

Collaboration diagram for Camera spec func V on:

Turn camera special function V on.

Turn camera special function V on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncVOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncVOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera spec func X off

Camera spec func X off
[Camera control]

Collaboration diagram for Camera spec func X off:

Turn camera special function X off.

Turn camera special function X off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncXOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncXOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera spec func X on

Camera spec func X on
[Camera control]

Collaboration diagram for Camera spec func X on:

Turn camera special function X on.

Turn camera special function X on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncXOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncXOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera spec func Y off

Camera spec func Y off
[Camera control]

Collaboration diagram for Camera spec func Y off:

Turn camera special function Y off.

Turn camera special function Y off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncYOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncYOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera spec func Y on

Camera spec func Y on
[Camera control]

Collaboration diagram for Camera spec func Y on:

Turn camera special function Y on.

Turn camera special function Y on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraSpecFuncYOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraSpecFuncYOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera stop all

Camera stop all
[Camera control]

Collaboration diagram for Camera stop all:

Camera stop all.

Camera stop all.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraStopAll(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraStopAll(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera text off

Camera text off
[Camera control]

Collaboration diagram for Camera text off:

Disable camera text.

Disable camera text.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraTextOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraTextOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera text on

Camera text on
[Camera control]

Collaboration diagram for Camera text on:

Enable camera text.

Enable camera text.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraTextOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraTextOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera tour start

Camera tour start
[Camera control]

Collaboration diagram for Camera tour start:

Start camera tour.

Start camera tour.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
TourID | __int32 | tour ID
Tour ID.
TourName | string | tour name
Tour name.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         TourID          = 1;
   const char*     TourName        = "tour name";

   HGscAction anAction;
   anAction = GscAct_CreateCameraTourStart(Camera, TourID, TourName);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         TourID;
   const char*     TourName;

   if (! GscAct_DecodeCameraTourStart(anAction, Camera, TourID, TourName))
   {
     // error handling
   }


GSC actions: Camera tour stop

Camera tour stop
[Camera control]

Collaboration diagram for Camera tour stop:

Stop camera tour.

Stop camera tour.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraTourStop(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraTourStop(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera version off

Camera version off
[Camera control]

Collaboration diagram for Camera version off:

Hide camera version string.

Hide camera version string.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraVersionOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraVersionOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera version on

Camera version on
[Camera control]

Collaboration diagram for Camera version on:

Show camera version string.

Show camera version string.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraVersionOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraVersionOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera wash-wipe off

Camera wash-wipe off
[Camera control]

Collaboration diagram for Camera wash-wipe off:

Turn camera wash-wipe off.

Turn camera wash-wipe off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraWashOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraWashOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Camera wash-wipe on

Camera wash-wipe on
[Camera control]

Collaboration diagram for Camera wash-wipe on:

Turn camera wash-wipe on.

Turn camera wash-wipe on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateCameraWashOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeCameraWashOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Clear default position

Clear default position
[Camera control]

Collaboration diagram for Clear default position:

Clear camera default position.

Clear camera default position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateDefaultPosClear(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeDefaultPosClear(anAction, Camera))
   {
     // error handling
   }


GSC actions: Clear preset position

Clear preset position
[Camera control]

Collaboration diagram for Clear preset position:

Clear camera preset position.

Clear camera preset position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Position | __int32 | position
Preset position.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Position        = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePrePosClear(Camera, Position);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Position;

   if (! GscAct_DecodePrePosClear(anAction, Camera, Position))
   {
     // error handling
   }


GSC actions: Fast speed off

Fast speed off
[Camera control]

Collaboration diagram for Fast speed off:

Turn camera fast speed off.

Turn camera fast speed off.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateFastSpeedOff(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeFastSpeedOff(anAction, Camera))
   {
     // error handling
   }


GSC actions: Fast speed on

Fast speed on
[Camera control]

Collaboration diagram for Fast speed on:

Turn camera fast speed on.

Turn camera fast speed on.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateFastSpeedOn(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeFastSpeedOn(anAction, Camera))
   {
     // error handling
   }


GSC actions: Focus far

Focus far
[Camera control]

Collaboration diagram for Focus far:

Focus camera far.

Focus camera far.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Focus speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreateFocusFar(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodeFocusFar(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Focus near

Focus near
[Camera control]

Collaboration diagram for Focus near:

Focus camera near.

Focus camera near.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Focus speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreateFocusNear(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodeFocusNear(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Focus stop

Focus stop
[Camera control]

Collaboration diagram for Focus stop:

Stop camera focus.

Stop camera focus.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateFocusStop(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeFocusStop(anAction, Camera))
   {
     // error handling
   }


GSC actions: Iris close

Iris close
[Camera control]

Collaboration diagram for Iris close:

Close camera iris.

Close camera iris.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateIrisClose(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeIrisClose(anAction, Camera))
   {
     // error handling
   }


GSC actions: Iris open

Iris open
[Camera control]

Collaboration diagram for Iris open:

Open camera iris.

Open camera iris.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateIrisOpen(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeIrisOpen(anAction, Camera))
   {
     // error handling
   }


GSC actions: Iris stop

Iris stop
[Camera control]

Collaboration diagram for Iris stop:

Stop camera iris.

Stop camera iris.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateIrisStop(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeIrisStop(anAction, Camera))
   {
     // error handling
   }


GSC actions: Move by speed

Move by speed
[Camera control]

Collaboration diagram for Move by speed:

Move camera by speed.

Move camera by speed.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
SpeedAlpha | double | alpha speed
Speed in alpha (pan) direction (0/100 %).
SpeedBeta | double | beta speed
Speed in beta (tilt) direction (0/100 %).

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   double          SpeedAlpha      = 0.0;
   double          SpeedBeta       = 0.0;

   HGscAction anAction;
   anAction = GscAct_CreateMoveToBySpeed(Camera, SpeedAlpha, SpeedBeta);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   double          SpeedAlpha;
   double          SpeedBeta;

   if (! GscAct_DecodeMoveToBySpeed(anAction, Camera, SpeedAlpha, SpeedBeta))
   {
     // error handling
   }


GSC actions: Move to absolute position

Move to absolute position
[Camera control]

Collaboration diagram for Move to absolute position:

Move camera to absolute position.

Move camera to absolute position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Alpha | double | alpha
Alpha angle (-180°/+180°).
Beta | double | beta
Beta angle (-90°/+90°).
SpeedAlpha | double | alpha speed
Speed in alpha direction (0/100 %).
SpeedBeta | double | beta speed
Speed in beta direction (0/100 %).

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   double          Alpha           = 0.0;
   double          Beta            = 0.0;
   double          SpeedAlpha      = 0.0;
   double          SpeedBeta       = 0.0;

   HGscAction anAction;
   anAction = GscAct_CreateMoveToAbsolutePosition(Camera, Alpha, Beta, SpeedAlpha, SpeedBeta);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   double          Alpha;
   double          Beta;
   double          SpeedAlpha;
   double          SpeedBeta;

   if (! GscAct_DecodeMoveToAbsolutePosition(anAction, Camera, Alpha, Beta, SpeedAlpha, SpeedBeta))
   {
     // error handling
   }


GSC actions: Move to default position

Move to default position
[Camera control]

Collaboration diagram for Move to default position:

Move camera to default position.

Move camera to default position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateDefaultPosCallUp(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeDefaultPosCallUp(anAction, Camera))
   {
     // error handling
   }


GSC actions: Move to preset position

Move to preset position
[Camera control]

Collaboration diagram for Move to preset position:

Move camera to preset position.

Move camera to preset position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Position | __int32 | position
Preset position.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Position        = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePrePosCallUp(Camera, Position);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Position;

   if (! GscAct_DecodePrePosCallUp(anAction, Camera, Position))
   {
     // error handling
   }


GSC actions: Move to relative position

Move to relative position
[Camera control]

Collaboration diagram for Move to relative position:

Move camera to relative position.

Move camera to relative position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Alpha | double | alpha
Alpha angle (-180°/+180°).
Beta | double | beta
Beta angle (-90°/+90°).
SpeedAlpha | double | alpha speed
Speed in alpha direction (0/100 %).
SpeedBeta | double | beta speed
Speed in beta direction (0/100 %).

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   double          Alpha           = 0.0;
   double          Beta            = 0.0;
   double          SpeedAlpha      = 0.0;
   double          SpeedBeta       = 0.0;

   HGscAction anAction;
   anAction = GscAct_CreateMoveToRelativePosition(Camera, Alpha, Beta, SpeedAlpha, SpeedBeta);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   double          Alpha;
   double          Beta;
   double          SpeedAlpha;
   double          SpeedBeta;

   if (! GscAct_DecodeMoveToRelativePosition(anAction, Camera, Alpha, Beta, SpeedAlpha, SpeedBeta))
   {
     // error handling
   }


GSC actions: Pan auto

Pan auto
[Camera control]

Collaboration diagram for Pan auto:

Turn auto pan of the camera.

Turn auto pan of the camera.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Modus | __int32 | modus
Pan modus.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Modus           = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePanAuto(Camera, Modus);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Modus;

   if (! GscAct_DecodePanAuto(anAction, Camera, Modus))
   {
     // error handling
   }


GSC actions: Pan left

Pan left
[Camera control]

Collaboration diagram for Pan left:

Pan camera to the left.

Pan camera to the left.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Pan speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePanLeft(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodePanLeft(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Pan right

Pan right
[Camera control]

Collaboration diagram for Pan right:

Pan camera to the right.

Pan camera to the right.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Pan speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePanRight(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodePanRight(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Pan stop

Pan stop
[Camera control]

Collaboration diagram for Pan stop:

Stop pan movement.

Stop pan movement.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreatePanStop(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodePanStop(anAction, Camera))
   {
     // error handling
   }


GSC actions: Save default position

Save default position
[Camera control]

Collaboration diagram for Save default position:

Save current camera position as default position.

Save current camera position as default position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateDefaultPosSave(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeDefaultPosSave(anAction, Camera))
   {
     // error handling
   }


GSC actions: Save preset position

Save preset position
[Camera control]

Collaboration diagram for Save preset position:

Save current camera position as preset position.

Save current camera position as preset position.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Position | __int32 | position
Preset position.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Position        = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePrePosSave(Camera, Position);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Position;

   if (! GscAct_DecodePrePosSave(anAction, Camera, Position))
   {
     // error handling
   }


GSC actions: Set camera text

Set camera text
[Camera control]

Collaboration diagram for Set camera text:

Set camera text.

Set camera text.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Text | string | text
Text to superimpose.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   const char*     Text            = "text";

   HGscAction anAction;
   anAction = GscAct_CreateSetCameraText(Camera, Text);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   const char*     Text;

   if (! GscAct_DecodeSetCameraText(anAction, Camera, Text))
   {
     // error handling
   }


GSC actions: Tilt down

Tilt down
[Camera control]

Collaboration diagram for Tilt down:

Tilt camera down.

Tilt camera down.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Tilt speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreateTiltDown(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodeTiltDown(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Tilt stop

Tilt stop
[Camera control]

Collaboration diagram for Tilt stop:

Stop tilt movement.

Stop tilt movement.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateTiltStop(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeTiltStop(anAction, Camera))
   {
     // error handling
   }


GSC actions: Tilt up

Tilt up
[Camera control]

Collaboration diagram for Tilt up:

Tilt camera up.

Tilt camera up.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Tilt speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreateTiltUp(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodeTiltUp(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Zoom in

Zoom in
[Camera control]

Collaboration diagram for Zoom in:

Zoom camera in.

Zoom camera in.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Zoom speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreateZoomIn(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodeZoomIn(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Zoom out

Zoom out
[Camera control]

Collaboration diagram for Zoom out:

Zoom camera out.

Zoom camera out.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.
Speed | __int32 | speed
Zoom speed.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};
   __int32         Speed           = 1;

   HGscAction anAction;
   anAction = GscAct_CreateZoomOut(Camera, Speed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;
   __int32         Speed;

   if (! GscAct_DecodeZoomOut(anAction, Camera, Speed))
   {
     // error handling
   }


GSC actions: Zoom stop

Zoom stop
[Camera control]

Collaboration diagram for Zoom stop:

Stop camera zoom.

Stop camera zoom.

Parameters

Name | Type | Description
Camera | TMediaChannelID | PTZ head
PTZ head.

Example how to create this action:

   TMediaChannelID Camera          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateZoomStop(Camera);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Camera;

   if (! GscAct_DecodeZoomStop(anAction, Camera))
   {
     // error handling
   }


GSC actions: Cash management actions

Modules

Cash management actions
[Actions]

Collaboration diagram for Cash management actions:

Detailed Description

All actions for cash management.

Modules

Safebag close

Safebag close.

Safebag data

Safebag data.

Safebag open

Safebag open.

Safebag passing of risk data

Safebag passing of risk data.

Safebag passing of risk start

Safebag passing of risk start.

Safebag passing of risk stop

Safebag passing of risk stop.


GSC actions: Safebag close

Safebag close
[Cash management actions]

Collaboration diagram for Safebag close:

Safebag close.

Safebag close.

Parameters

Name | Type | Description
WorkingPlace | __int32 | working place
Working place no.
StartTime | TGLibDateTime | start time
Start time stamp.
StopTime | TGLibDateTime | stop time
Stop time stamp.
SafebagNo | widestring | safebag no.
Safebag no.
SafebagInfo | widestring | safebag info
Additional info about safebag.
StepID | SafebagStep | step ID
Processing step ID.
Debit | double | debit
optional | Debit.
Total | double | total
optional | Total.
Difference | double | difference
optional | Difference between debit and total.
HasDifference | bool | has difference
optional | Difference between debit and total is not zero.
Notes | widestring | notes
optional | Notes.
Coins | widestring | coins
optional | Coins.
Cheques | widestring | cheques
optional | Cheques.

Example how to create this action:

   __int32         WorkingPlace    = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   TGLibDateTime   StopTime        = TGLibDateTime::Now();
   const wchar_t*  SafebagNo       = L"safebag no.";
   const wchar_t*  SafebagInfo     = L"safebag info";
   SafebagStep     StepID          = sbsOpen;

   HGscAction anAction;
   anAction = GscAct_CreateSafebagClose(WorkingPlace, StartTime, StopTime, SafebagNo, SafebagInfo, StepID, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         WorkingPlace;
   TGLibDateTime   StartTime;
   TGLibDateTime   StopTime;
   const wchar_t*  SafebagNo;
   const wchar_t*  SafebagInfo;
   SafebagStep     StepID;
   const double*   Debit;
   const double*   Total;
   const double*   Difference;
   const bool*     HasDifference;
   const wchar_t*  Notes;
   const wchar_t*  Coins;
   const wchar_t*  Cheques;

   if (! GscAct_DecodeSafebagClose(anAction, WorkingPlace, StartTime, StopTime, SafebagNo, SafebagInfo, StepID, Debit, Total, Difference, HasDifference, Notes, Coins, Cheques))
   {
     // error handling
   }


GSC actions: Safebag data

Safebag data
[Cash management actions]

Collaboration diagram for Safebag data:

Safebag data.

Safebag data.

Parameters

Name | Type | Description
WorkingPlace | __int32 | working place
Working place no.
StartTime | TGLibDateTime | start time
Start time stamp.
SafebagNo | widestring | safebag no.
Safebag no.
SafebagInfo | widestring | safebag info
Additional info about safebag.
StepID | SafebagStep | step ID
Processing step ID.
Debit | double | debit
optional | Debit.
Total | double | total
optional | Total.
Difference | double | difference
optional | Difference between debit and total.
HasDifference | bool | has difference
optional | Difference between debit and total is not zero.
Notes | widestring | notes
optional | Notes.
Coins | widestring | coins
optional | Coins.
Cheques | widestring | cheques
optional | Cheques.

Example how to create this action:

   __int32         WorkingPlace    = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   const wchar_t*  SafebagNo       = L"safebag no.";
   const wchar_t*  SafebagInfo     = L"safebag info";
   SafebagStep     StepID          = sbsOpen;

   HGscAction anAction;
   anAction = GscAct_CreateSafebagData(WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         WorkingPlace;
   TGLibDateTime   StartTime;
   const wchar_t*  SafebagNo;
   const wchar_t*  SafebagInfo;
   SafebagStep     StepID;
   const double*   Debit;
   const double*   Total;
   const double*   Difference;
   const bool*     HasDifference;
   const wchar_t*  Notes;
   const wchar_t*  Coins;
   const wchar_t*  Cheques;

   if (! GscAct_DecodeSafebagData(anAction, WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID, Debit, Total, Difference, HasDifference, Notes, Coins, Cheques))
   {
     // error handling
   }


GSC actions: Safebag open

Safebag open
[Cash management actions]

Collaboration diagram for Safebag open:

Safebag open.

Safebag open.

Parameters

Name | Type | Description
WorkingPlace | __int32 | working place
Working place no.
StartTime | TGLibDateTime | start time
Start time stamp.
SafebagNo | widestring | safebag no.
Safebag no.
SafebagInfo | widestring | safebag info
Additional info about safebag.
StepID | SafebagStep | step ID
Processing step ID.

Example how to create this action:

   __int32         WorkingPlace    = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   const wchar_t*  SafebagNo       = L"safebag no.";
   const wchar_t*  SafebagInfo     = L"safebag info";
   SafebagStep     StepID          = sbsOpen;

   HGscAction anAction;
   anAction = GscAct_CreateSafebagOpen(WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         WorkingPlace;
   TGLibDateTime   StartTime;
   const wchar_t*  SafebagNo;
   const wchar_t*  SafebagInfo;
   SafebagStep     StepID;

   if (! GscAct_DecodeSafebagOpen(anAction, WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID))
   {
     // error handling
   }


GSC actions: Safebag passing of risk data

Safebag passing of risk data
[Cash management actions]

Collaboration diagram for Safebag passing of risk data:

Safebag passing of risk data.

Safebag passing of risk data.

Parameters

Name | Type | Description
WorkingPlace | __int32 | working place
Working place no.
StartTime | TGLibDateTime | start time
Start time stamp.
SafebagNo | widestring | safebag no.
Safebag no.
SafebagInfo | widestring | safebag info
Additional info about safebag.
StepID | SafebagStep | step ID
Processing step ID.
UserID1 | __int32 | user 1
User who gives the safebag.
UserID2 | __int32 | user 2
User who takes the safebag.
TourNumber | __int32 | tour no
optional | Optional tour no.
TargetWorkingPlace | widestring | target working place
optional | Target working place.
PassingOfRiskType | widestring | passing of risk type
optional | Passing of risk type.

Example how to create this action:

   __int32         WorkingPlace    = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   const wchar_t*  SafebagNo       = L"safebag no.";
   const wchar_t*  SafebagInfo     = L"safebag info";
   SafebagStep     StepID          = sbsOpen;
   __int32         UserID1         = 1;
   __int32         UserID2         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSafebagPassingOfRiskData(WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID, UserID1, UserID2, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         WorkingPlace;
   TGLibDateTime   StartTime;
   const wchar_t*  SafebagNo;
   const wchar_t*  SafebagInfo;
   SafebagStep     StepID;
   __int32         UserID1;
   __int32         UserID2;
   const __int32*  TourNumber;
   const wchar_t*  TargetWorkingPlace;
   const wchar_t*  PassingOfRiskType;

   if (! GscAct_DecodeSafebagPassingOfRiskData(anAction, WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID, UserID1, UserID2, TourNumber, TargetWorkingPlace, PassingOfRiskType))
   {
     // error handling
   }


GSC actions: Safebag passing of risk start

Safebag passing of risk start
[Cash management actions]

Collaboration diagram for Safebag passing of risk start:

Safebag passing of risk start.

Safebag passing of risk start.

Parameters

Name | Type | Description
WorkingPlace | __int32 | working place
Working place no.
StartTime | TGLibDateTime | start time
Start time stamp.
SafebagNo | widestring | safebag no.
Safebag no.
SafebagInfo | widestring | safebag info
Additional info about safebag.
StepID | SafebagStep | step ID
Processing step ID.
UserID1 | __int32 | user 1
User who gives the safebag.
UserID2 | __int32 | user 2
User who takes the safebag.
TourNumber | __int32 | tour no
optional | Optional tour no.
TargetWorkingPlace | widestring | target working place
optional | Target working place.
PassingOfRiskType | widestring | passing of risk type
optional | Passing of risk type.

Example how to create this action:

   __int32         WorkingPlace    = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   const wchar_t*  SafebagNo       = L"safebag no.";
   const wchar_t*  SafebagInfo     = L"safebag info";
   SafebagStep     StepID          = sbsOpen;
   __int32         UserID1         = 1;
   __int32         UserID2         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSafebagPassingOfRiskStart(WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID, UserID1, UserID2, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         WorkingPlace;
   TGLibDateTime   StartTime;
   const wchar_t*  SafebagNo;
   const wchar_t*  SafebagInfo;
   SafebagStep     StepID;
   __int32         UserID1;
   __int32         UserID2;
   const __int32*  TourNumber;
   const wchar_t*  TargetWorkingPlace;
   const wchar_t*  PassingOfRiskType;

   if (! GscAct_DecodeSafebagPassingOfRiskStart(anAction, WorkingPlace, StartTime, SafebagNo, SafebagInfo, StepID, UserID1, UserID2, TourNumber, TargetWorkingPlace, PassingOfRiskType))
   {
     // error handling
   }


GSC actions: Safebag passing of risk stop

Safebag passing of risk stop
[Cash management actions]

Collaboration diagram for Safebag passing of risk stop:

Safebag passing of risk stop.

Safebag passing of risk stop.

Parameters

Name | Type | Description
WorkingPlace | __int32 | working place
Working place no.
StartTime | TGLibDateTime | start time
Start time stamp.
StopTime | TGLibDateTime | stop time
Stop time stamp.
SafebagNo | widestring | safebag no.
Safebag no.
SafebagInfo | widestring | safebag info
Additional info about safebag.
StepID | SafebagStep | step ID
Processing step ID.
UserID1 | __int32 | user 1
User who gives the safebag.
UserID2 | __int32 | user 2
User who takes the safebag.
TourNumber | __int32 | tour no
optional | Optional tour no.
TargetWorkingPlace | widestring | target working place
optional | Target working place.
PassingOfRiskType | widestring | passing of risk type
optional | Passing of risk type.

Example how to create this action:

   __int32         WorkingPlace    = 1;
   TGLibDateTime   StartTime       = TGLibDateTime::Now();
   TGLibDateTime   StopTime        = TGLibDateTime::Now();
   const wchar_t*  SafebagNo       = L"safebag no.";
   const wchar_t*  SafebagInfo     = L"safebag info";
   SafebagStep     StepID          = sbsOpen;
   __int32         UserID1         = 1;
   __int32         UserID2         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSafebagPassingOfRiskStop(WorkingPlace, StartTime, StopTime, SafebagNo, SafebagInfo, StepID, UserID1, UserID2, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         WorkingPlace;
   TGLibDateTime   StartTime;
   TGLibDateTime   StopTime;
   const wchar_t*  SafebagNo;
   const wchar_t*  SafebagInfo;
   SafebagStep     StepID;
   __int32         UserID1;
   __int32         UserID2;
   const __int32*  TourNumber;
   const wchar_t*  TargetWorkingPlace;
   const wchar_t*  PassingOfRiskType;

   if (! GscAct_DecodeSafebagPassingOfRiskStop(anAction, WorkingPlace, StartTime, StopTime, SafebagNo, SafebagInfo, StepID, UserID1, UserID2, TourNumber, TargetWorkingPlace, PassingOfRiskType))
   {
     // error handling
   }


GSC actions: Device information

Modules

Device information
[Actions]

Collaboration diagram for Device information:

Detailed Description

All actions for low-level notification of the device or media channels changes.

Modules

Device found

This action will be fired when the USB or NET device is connected to the system.

Device plugin error

This action notifies device plugin error.

Device plugin state

This action notifies device plugin state.

Device reattached

This action will be fired when the USB or NET device is reattached to the system.

Device removed

This action will be fired when the USB or NET device is disconnected from the system.

New firmware received

This action will be fired when the USB or NET device has got the new firmware.


GSC actions: Device found

Device found
[Device information]

Collaboration diagram for Device found:

This action will be fired when the USB or NET device is connected to the system.

It is also fired at start-up for all detected devices.

This action will be fired when the USB or NET device is connected to the system. It is also fired at start-up for all detected devices.

Parameters

Name | Type | Description
Type | string | device type
Type of the device.
Name | string | device name
Device name if assigned in setup, empty otherwise.
Serial | string | serial ID
Serial ID of the device.

Example how to create this action:

   const char*     Type            = "device type";
   const char*     Name            = "device name";
   const char*     Serial          = "serial ID";

   HGscAction anAction;
   anAction = GscAct_CreateDeviceFound(Type, Name, Serial);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const char*     Type;
   const char*     Name;
   const char*     Serial;

   if (! GscAct_DecodeDeviceFound(anAction, Type, Name, Serial))
   {
     // error handling
   }


GSC actions: Device plugin error

Device plugin error
[Device information]

Collaboration diagram for Device plugin error:

This action notifies device plugin error.

This action notifies device plugin error.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
Type | string | device type
Type of the device.
SubType | string | device subtype
optional | Subtype of the device.
Name | string | device name
Device name.
Serial | string | serial ID
Serial ID of the device.
ErrorClass | PlcPluginError | error class
Error class of the error occured.
ErrorCode | __int32 | error code
optional | Plugin type specific error code.
Description | string | description
optional | Error description.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   const char*     Type            = "device type";
   const char*     Name            = "device name";
   const char*     Serial          = "serial ID";
   PlcPluginError  ErrorClass      = ppeInternalError;

   HGscAction anAction;
   anAction = GscAct_CreateDevicePluginError(Channel, Type, NULL, Name, Serial, ErrorClass, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const char*     Type;
   const char*     SubType;
   const char*     Name;
   const char*     Serial;
   PlcPluginError  ErrorClass;
   const __int32*  ErrorCode;
   const char*     Description;

   if (! GscAct_DecodeDevicePluginError(anAction, Channel, Type, SubType, Name, Serial, ErrorClass, ErrorCode, Description))
   {
     // error handling
   }


GSC actions: Device plugin state

Device plugin state
[Device information]

Collaboration diagram for Device plugin state:

This action notifies device plugin state.

This action notifies device plugin state.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
Type | string | device type
Type of the device.
SubType | string | device subtype
optional | Subtype of the device.
Name | string | device name
Device name.
Serial | string | serial ID
Serial ID of the device.
State | PlcPluginState | plugin state
New plugin device state.
InternalState | __int32 | internal state
optional | Plugin device specific state.
Description | string | description
optional | State description.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   const char*     Type            = "device type";
   const char*     Name            = "device name";
   const char*     Serial          = "serial ID";
   PlcPluginState  State           = ppsInternalState;

   HGscAction anAction;
   anAction = GscAct_CreateDevicePluginState(Channel, Type, NULL, Name, Serial, State, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const char*     Type;
   const char*     SubType;
   const char*     Name;
   const char*     Serial;
   PlcPluginState  State;
   const __int32*  InternalState;
   const char*     Description;

   if (! GscAct_DecodeDevicePluginState(anAction, Channel, Type, SubType, Name, Serial, State, InternalState, Description))
   {
     // error handling
   }


GSC actions: Device reattached

Device reattached
[Device information]

Collaboration diagram for Device reattached:

This action will be fired when the USB or NET device is reattached to the system.

This action will be fired when the USB or NET device is reattached to the system.

Parameters

Name | Type | Description
Type | string | device type
Type of the device.
Name | string | device name
Device name if assigned in setup, empty otherwise.
Serial | string | serial ID
Serial ID of the device.

Example how to create this action:

   const char*     Type            = "device type";
   const char*     Name            = "device name";
   const char*     Serial          = "serial ID";

   HGscAction anAction;
   anAction = GscAct_CreateDeviceReattached(Type, Name, Serial);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const char*     Type;
   const char*     Name;
   const char*     Serial;

   if (! GscAct_DecodeDeviceReattached(anAction, Type, Name, Serial))
   {
     // error handling
   }


GSC actions: Device removed

Device removed
[Device information]

Collaboration diagram for Device removed:

This action will be fired when the USB or NET device is disconnected from the system.

It is also fired at the start-up for all parameterized but not present devices.

This action will be fired when the USB or NET device is disconnected from the system. It is also fired at the start-up for all parameterized but not present devices.

Parameters

Name | Type | Description
Type | string | device type
Type of the device.
Name | string | device name
Device name if assigned in setup, empty otherwise.
Serial | string | serial ID
Serial ID of the device.

Example how to create this action:

   const char*     Type            = "device type";
   const char*     Name            = "device name";
   const char*     Serial          = "serial ID";

   HGscAction anAction;
   anAction = GscAct_CreateDeviceRemoved(Type, Name, Serial);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const char*     Type;
   const char*     Name;
   const char*     Serial;

   if (! GscAct_DecodeDeviceRemoved(anAction, Type, Name, Serial))
   {
     // error handling
   }


GSC actions: New firmware received

New firmware received
[Device information]

Collaboration diagram for New firmware received:

This action will be fired when the USB or NET device has got the new firmware.

This action will be fired when the USB or NET device has got the new firmware.

Parameters

Name | Type | Description
Type | string | device type
Type of the device.
Name | string | device name
Device name if assigned in setup, empty otherwise.
Serial | string | serial ID
Serial ID of the device.
Firmware | string | firmware serial
Serial ID of the firmware.

Example how to create this action:

   const char*     Type            = "device type";
   const char*     Name            = "device name";
   const char*     Serial          = "serial ID";
   const char*     Firmware        = "firmware serial";

   HGscAction anAction;
   anAction = GscAct_CreateDeviceNewFirmware(Type, Name, Serial, Firmware);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const char*     Type;
   const char*     Name;
   const char*     Serial;
   const char*     Firmware;

   if (! GscAct_DecodeDeviceNewFirmware(anAction, Type, Name, Serial, Firmware))
   {
     // error handling
   }


GSC actions: Digital contacts

Modules

Digital contacts
[Actions]

Collaboration diagram for Digital contacts:

Detailed Description

All actions for handling digital inputs and outputs.

Modules

Case has been closed

Case has been closed.

Case has been opened

Case has been opened.

Digital input

This action will be fired when the state of the digital input has changed.

IOI43 reset mainboard

Reset mainboard using IOI43a/ab USB Alarm-I/O.

IOI43 temperature notification

Temperature notification from IOI43a/ab USB Alarm-I/O.

IOI43 watchdog activate

Activate watchdog on IOI43a/ab USB Alarm-I/O.

IOI43 watchdog deactivate

Deactivate watchdog on IOI43a/ab USB Alarm-I/O.

IOI43 watchdog trigger

Trigger watchdog on IOI43a/ab USB Alarm-I/O.

Key pressed

This action is notified if one of the GEVISCOPE system keys is pressed.

Key released

This action is notified if one of the GEVISCOPE system keys is released.

Reset mainboard

Reset mainboard using IO device.

Set digital output

This action is used to modify the state of the digital output and to notify this change.

Set system LED

This action is used to turn the system LEDs on or off.

Set system LED to blink

This action is used to blink the system LEDs.

Temperature notification

Temperature notification from a/ab USB Alarm-I/O.

Watchdog activate

Activate watchdog.

Watchdog deactivate

Deactivate watchdog.

Watchdog trigger

Trigger watchdog.


GSC actions: Case has been closed

Case has been closed
[Digital contacts]

Collaboration diagram for Case has been closed:

Case has been closed.

Case has been closed.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateCaseClosed();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeCaseClosed(anAction))
   {
     // error handling
   }


GSC actions: Case has been opened

Case has been opened
[Digital contacts]

Collaboration diagram for Case has been opened:

Case has been opened.

Case has been opened.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateCaseOpened();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeCaseOpened(anAction))
   {
     // error handling
   }


GSC actions: Digital input

Digital input
[Digital contacts]

Collaboration diagram for Digital input:

This action will be fired when the state of the digital input has changed.

This action will be fired when the state of the digital input has changed.

Parameters

Name | Type | Description
Contact | TMediaChannelID | contact
Contact.
State | DigitalInputState | state
New state.

Example how to create this action:

   TMediaChannelID Contact         = {0, L"", 0};
   DigitalInputState State           = disLow;

   HGscAction anAction;
   anAction = GscAct_CreateDigitalInput(Contact, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Contact;
   DigitalInputState State;

   if (! GscAct_DecodeDigitalInput(anAction, Contact, State))
   {
     // error handling
   }


GSC actions: IOI43 reset mainboard

IOI43 reset mainboard
[Digital contacts]

Collaboration diagram for IOI43 reset mainboard:

Reset mainboard using IOI43a/ab USB Alarm-I/O.

Reset mainboard using IOI43a/ab USB Alarm-I/O.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateIOI43ResetMainboard();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeIOI43ResetMainboard(anAction))
   {
     // error handling
   }


GSC actions: IOI43 temperature notification

IOI43 temperature notification
[Digital contacts]

Collaboration diagram for IOI43 temperature notification:

Temperature notification from IOI43a/ab USB Alarm-I/O.

Temperature notification from IOI43a/ab USB Alarm-I/O.

Parameters

Name | Type | Description
ID | widestring | ID
ID of the IOI43 module (like IOI43-00).
Temperature | __int32 | temperature
Temperature.

Example how to create this action:

   const wchar_t*  ID              = L"ID";
   __int32         Temperature     = 1;

   HGscAction anAction;
   anAction = GscAct_CreateIOI43Temperature(ID, Temperature);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ID;
   __int32         Temperature;

   if (! GscAct_DecodeIOI43Temperature(anAction, ID, Temperature))
   {
     // error handling
   }


GSC actions: IOI43 watchdog activate

IOI43 watchdog activate
[Digital contacts]

Collaboration diagram for IOI43 watchdog activate:

Activate watchdog on IOI43a/ab USB Alarm-I/O.

Activate watchdog on IOI43a/ab USB Alarm-I/O.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateIOI43WDActivate();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeIOI43WDActivate(anAction))
   {
     // error handling
   }


GSC actions: IOI43 watchdog deactivate

IOI43 watchdog deactivate
[Digital contacts]

Collaboration diagram for IOI43 watchdog deactivate:

Deactivate watchdog on IOI43a/ab USB Alarm-I/O.

Deactivate watchdog on IOI43a/ab USB Alarm-I/O.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateIOI43WDDeactivate();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeIOI43WDDeactivate(anAction))
   {
     // error handling
   }


GSC actions: IOI43 watchdog trigger

IOI43 watchdog trigger
[Digital contacts]

Collaboration diagram for IOI43 watchdog trigger:

Trigger watchdog on IOI43a/ab USB Alarm-I/O.

Trigger watchdog on IOI43a/ab USB Alarm-I/O.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateIOI43WDTrigger();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeIOI43WDTrigger(anAction))
   {
     // error handling
   }


GSC actions: Key pressed

Key pressed
[Digital contacts]

Collaboration diagram for Key pressed:

This action is notified if one of the GEVISCOPE system keys is pressed.

This action is notified if one of the GEVISCOPE system keys is pressed.

Parameters

Name | Type | Description
Key | SystemKey | key
System key.

Example how to create this action:

   SystemKey       Key             = keyDisplay1;

   HGscAction anAction;
   anAction = GscAct_CreateKeyPressed(Key);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   SystemKey       Key;

   if (! GscAct_DecodeKeyPressed(anAction, Key))
   {
     // error handling
   }


GSC actions: Key released

Key released
[Digital contacts]

Collaboration diagram for Key released:

This action is notified if one of the GEVISCOPE system keys is released.

This action is notified if one of the GEVISCOPE system keys is released.

Parameters

Name | Type | Description
Key | SystemKey | key
System key.

Example how to create this action:

   SystemKey       Key             = keyDisplay1;

   HGscAction anAction;
   anAction = GscAct_CreateKeyReleased(Key);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   SystemKey       Key;

   if (! GscAct_DecodeKeyReleased(anAction, Key))
   {
     // error handling
   }


GSC actions: Reset mainboard

Reset mainboard
[Digital contacts]

Collaboration diagram for Reset mainboard:

Reset mainboard using IO device.

Reset mainboard using IO device.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateResetMainboard();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeResetMainboard(anAction))
   {
     // error handling
   }


GSC actions: Set digital output

Set digital output
[Digital contacts]

Collaboration diagram for Set digital output:

This action is used to modify the state of the digital output and to notify this change.

This action is used to modify the state of the digital output and to notify this change.

Parameters

Name | Type | Description
Contact | TMediaChannelID | contact
Contact.
State | DigitalOutputState | state
New state.

Example how to create this action:

   TMediaChannelID Contact         = {0, L"", 0};
   DigitalOutputState State           = dosOpen;

   HGscAction anAction;
   anAction = GscAct_CreateSetDigitalOutput(Contact, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Contact;
   DigitalOutputState State;

   if (! GscAct_DecodeSetDigitalOutput(anAction, Contact, State))
   {
     // error handling
   }


GSC actions: Set system LED

Set system LED
[Digital contacts]

Collaboration diagram for Set system LED:

This action is used to turn the system LEDs on or off.

This action is used to turn the system LEDs on or off.

Parameters

Name | Type | Description
LED | SystemLED | LED
System LED.
State | DigitalOutputState | state
New state.

Example how to create this action:

   SystemLED       LED             = ledError;
   DigitalOutputState State           = dosOpen;

   HGscAction anAction;
   anAction = GscAct_CreateSetLED(LED, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   SystemLED       LED;
   DigitalOutputState State;

   if (! GscAct_DecodeSetLED(anAction, LED, State))
   {
     // error handling
   }


GSC actions: Set system LED to blink

Set system LED to blink
[Digital contacts]

Collaboration diagram for Set system LED to blink:

This action is used to blink the system LEDs.

This action is used to blink the system LEDs.

Parameters

Name | Type | Description
LED | SystemLED | LED
System LED.
LedTimeOnMs | __int32 | LED time ON
Time in milliseconds when the LED will be switched on.
LedTimeOffMs | __int32 | LED time OFF
Time in milliseconds when the LED will be switched off.

Example how to create this action:

   SystemLED       LED             = ledError;
   __int32         LedTimeOnMs     = 1;
   __int32         LedTimeOffMs    = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSetLEDBlink(LED, LedTimeOnMs, LedTimeOffMs);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   SystemLED       LED;
   __int32         LedTimeOnMs;
   __int32         LedTimeOffMs;

   if (! GscAct_DecodeSetLEDBlink(anAction, LED, LedTimeOnMs, LedTimeOffMs))
   {
     // error handling
   }


GSC actions: Temperature notification

Temperature notification
[Digital contacts]

Collaboration diagram for Temperature notification:

Temperature notification from a/ab USB Alarm-I/O.

Temperature notification from a/ab USB Alarm-I/O.

Parameters

Name | Type | Description
SourceType | IODeviceType | IO device type
Type of the device, which has fired the action.
ID | widestring | ID
ID of the IO module (like IOI43-00/MIO84-00/MIO168-00).
Temperature | __int32 | temperature
Temperature.

Example how to create this action:

   IODeviceType    SourceType      = dioDeviceTypeMIO;
   const wchar_t*  ID              = L"ID";
   __int32         Temperature     = 1;

   HGscAction anAction;
   anAction = GscAct_CreateTemperature(SourceType, ID, Temperature);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   IODeviceType    SourceType;
   const wchar_t*  ID;
   __int32         Temperature;

   if (! GscAct_DecodeTemperature(anAction, SourceType, ID, Temperature))
   {
     // error handling
   }


GSC actions: Watchdog activate

Watchdog activate
[Digital contacts]

Collaboration diagram for Watchdog activate:

Activate watchdog.

Activate watchdog.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateWatchdogActivate();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeWatchdogActivate(anAction))
   {
     // error handling
   }


GSC actions: Watchdog deactivate

Watchdog deactivate
[Digital contacts]

Collaboration diagram for Watchdog deactivate:

Deactivate watchdog.

Deactivate watchdog.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateWatchdogDeactivate();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeWatchdogDeactivate(anAction))
   {
     // error handling
   }


GSC actions: Watchdog trigger

Watchdog trigger
[Digital contacts]

Collaboration diagram for Watchdog trigger:

Trigger watchdog.

Trigger watchdog.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateWatchdogTrigger();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeWatchdogTrigger(anAction))
   {
     // error handling
   }


GSC actions: Imex

Modules

Imex
[Actions]

Collaboration diagram for Imex:

Detailed Description

Image export.

Modules

Imex capacity file auto deleted

Imex capacity warning: file auto deleted.

Imex capacity out of disk space.

Imex capacity warning: out of disk space.

Imex capacity warning

Imex capacity warning: capacity warning.

Imex export event image

Imex export event image.

Imex export image from DB

Imex export image from DB.

Imex export image from live stream

Imex export image from live stream.


GSC actions: Imex capacity file auto deleted

Imex capacity file auto deleted
[Imex]

Collaboration diagram for Imex capacity file auto deleted:

Imex capacity warning: file auto deleted.

Imex capacity warning: file auto deleted.

Parameters

Name | Type | Description
Warning | ABCapacityWarning | warning
Warning.
Destination | TResourceID | destination
Destination.
TotalCapacity | __int64 | total capacity
Total capacity.
FreeCapacity | __int64 | free capacity
Free capacity.
AllocatedByImageFile | __int64 | allocated by image file
Allocated by image file.
PercentFree | __int32 | percent free
Percent free.
PercentAllocated | __int32 | percent allocated
Percent allocated.
PercentAllocatedByImageFile | __int32 | percent allocated by image file
Percent allocated by image file.
TotalFileSize | __int64 | total file size
Total file size.
NumberOfFiles | __int32 | number of files
Number of files.

Example how to create this action:

   ABCapacityWarning Warning         = abwOk;
   TResourceID     Destination     = {0, L"", 0};
   __int64         TotalCapacity   = 1;
   __int64         FreeCapacity    = 1;
   __int64         AllocatedByImageFile = 1;
   __int32         PercentFree     = 1;
   __int32         PercentAllocated = 1;
   __int32         PercentAllocatedByImageFile = 1;
   __int64         TotalFileSize   = 1;
   __int32         NumberOfFiles   = 1;

   HGscAction anAction;
   anAction = GscAct_CreateImexCapacityFileAutoDeleted(Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByImageFile, PercentFree, PercentAllocated, PercentAllocatedByImageFile, TotalFileSize, NumberOfFiles);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   ABCapacityWarning Warning;
   TResourceID     Destination;
   __int64         TotalCapacity;
   __int64         FreeCapacity;
   __int64         AllocatedByImageFile;
   __int32         PercentFree;
   __int32         PercentAllocated;
   __int32         PercentAllocatedByImageFile;
   __int64         TotalFileSize;
   __int32         NumberOfFiles;

   if (! GscAct_DecodeImexCapacityFileAutoDeleted(anAction, Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByImageFile, PercentFree, PercentAllocated, PercentAllocatedByImageFile, TotalFileSize, NumberOfFiles))
   {
     // error handling
   }


GSC actions: Imex capacity out of disk space.

Imex capacity out of disk space.
[Imex]

Collaboration diagram for Imex capacity out of disk space.:

Imex capacity warning: out of disk space.

Imex capacity warning: out of disk space.

Parameters

Name | Type | Description
Warning | ABCapacityWarning | warning
Warning.
Destination | TResourceID | destination
Destination.
TotalCapacity | __int64 | total capacity
Total capacity.
FreeCapacity | __int64 | free capacity
Free capacity.
AllocatedByImageFile | __int64 | allocated by image file
Allocated by image file.
PercentFree | __int32 | percent free
Percent free.
PercentAllocated | __int32 | percent allocated
Percent allocated.
PercentAllocatedByImageFile | __int32 | percent allocated by image file
Percent allocated by image file.

Example how to create this action:

   ABCapacityWarning Warning         = abwOk;
   TResourceID     Destination     = {0, L"", 0};
   __int64         TotalCapacity   = 1;
   __int64         FreeCapacity    = 1;
   __int64         AllocatedByImageFile = 1;
   __int32         PercentFree     = 1;
   __int32         PercentAllocated = 1;
   __int32         PercentAllocatedByImageFile = 1;

   HGscAction anAction;
   anAction = GscAct_CreateImexCapacityOutOfDiskSpace(Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByImageFile, PercentFree, PercentAllocated, PercentAllocatedByImageFile);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   ABCapacityWarning Warning;
   TResourceID     Destination;
   __int64         TotalCapacity;
   __int64         FreeCapacity;
   __int64         AllocatedByImageFile;
   __int32         PercentFree;
   __int32         PercentAllocated;
   __int32         PercentAllocatedByImageFile;

   if (! GscAct_DecodeImexCapacityOutOfDiskSpace(anAction, Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByImageFile, PercentFree, PercentAllocated, PercentAllocatedByImageFile))
   {
     // error handling
   }


GSC actions: Imex capacity warning

Imex capacity warning
[Imex]

Collaboration diagram for Imex capacity warning:

Imex capacity warning: capacity warning.

Imex capacity warning: capacity warning.

Parameters

Name | Type | Description
Warning | ABCapacityWarning | warning
Warning.
Destination | TResourceID | destination
Destination.
TotalCapacity | __int64 | total capacity
Total capacity.
FreeCapacity | __int64 | free capacity
Free capacity.
AllocatedByImageFile | __int64 | allocated by image file
Allocated by image file.
PercentFree | __int32 | percent free
Percent free.
PercentAllocated | __int32 | percent allocated
Percent allocated.
PercentAllocatedByImageFile | __int32 | percent allocated by image file
Percent allocated by image file.

Example how to create this action:

   ABCapacityWarning Warning         = abwOk;
   TResourceID     Destination     = {0, L"", 0};
   __int64         TotalCapacity   = 1;
   __int64         FreeCapacity    = 1;
   __int64         AllocatedByImageFile = 1;
   __int32         PercentFree     = 1;
   __int32         PercentAllocated = 1;
   __int32         PercentAllocatedByImageFile = 1;

   HGscAction anAction;
   anAction = GscAct_CreateImexCapacityWarning(Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByImageFile, PercentFree, PercentAllocated, PercentAllocatedByImageFile);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   ABCapacityWarning Warning;
   TResourceID     Destination;
   __int64         TotalCapacity;
   __int64         FreeCapacity;
   __int64         AllocatedByImageFile;
   __int32         PercentFree;
   __int32         PercentAllocated;
   __int32         PercentAllocatedByImageFile;

   if (! GscAct_DecodeImexCapacityWarning(anAction, Warning, Destination, TotalCapacity, FreeCapacity, AllocatedByImageFile, PercentFree, PercentAllocated, PercentAllocatedByImageFile))
   {
     // error handling
   }


GSC actions: Imex export event image

Imex export event image
[Imex]

Collaboration diagram for Imex export event image:

Imex export event image.

Imex export event image.

Parameters

Name | Type | Description
EventID | __int64 | instance ID
Instance ID of the event.
TypeID | TEventTypeID | event type
Type of the event.
Destination | TResourceID | destination
optional | Destination.
FilePath | widestring | file name
optional | File name.

Example how to create this action:

   __int64         EventID         = 1;
   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateImexExportEventImage(EventID, TypeID, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         EventID;
   TEventTypeID    TypeID;
   const TResourceID* Destination;
   const wchar_t*  FilePath;

   if (! GscAct_DecodeImexExportEventImage(anAction, EventID, TypeID, Destination, FilePath))
   {
     // error handling
   }


GSC actions: Imex export image from DB

Imex export image from DB
[Imex]

Collaboration diagram for Imex export image from DB:

Imex export image from DB.

Imex export image from DB.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
Destination | TResourceID | destination
optional | Destination.
FilePath | widestring | file name
optional | File name.
PictureTime | TGLibDateTime | picture time
optional | Picture time.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateImexExportImageFromDB(Channel, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const TResourceID* Destination;
   const wchar_t*  FilePath;
   const TGLibDateTime* PictureTime;

   if (! GscAct_DecodeImexExportImageFromDB(anAction, Channel, Destination, FilePath, PictureTime))
   {
     // error handling
   }


GSC actions: Imex export image from live stream

Imex export image from live stream
[Imex]

Collaboration diagram for Imex export image from live stream:

Imex export image from live stream.

Imex export image from live stream.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
Destination | TResourceID | destination
optional | Destination.
FilePath | widestring | file name
optional | File name.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateImexExportImageFromLiveStream(Channel, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const TResourceID* Destination;
   const wchar_t*  FilePath;

   if (! GscAct_DecodeImexExportImageFromLiveStream(anAction, Channel, Destination, FilePath))
   {
     // error handling
   }


GSC actions: LPS

Modules

LPS
[Actions]

Collaboration diagram for LPS:

Detailed Description

LPS messages.

Modules

LPS position data

LPS position data.

LPS query position

Send position query for a Tag to LPS server.


GSC actions: LPS position data

LPS position data
[LPS]

Collaboration diagram for LPS position data:

LPS position data.

LPS position data.

Parameters

Name | Type | Description
TagID | __int32 | tag ID
Tag ID.
ScannerID | widestring | scanner ID
optional | Scanner ID or IP address.
X | __int64 | X coordinate
X coordinate of cartesian coordinates.
Y | __int64 | Y coordinate
Y coordinate of cartesian coordinates.
Z | __int64 | Z coordinate
optional | Z coordinate of cartesian coordinates.
Latitude | double | latitude
optional | Latitude of geographic coordinates.
Longitude | double | longitude
optional | Longitude of geographic coordinates.
AreaID | __int32 | area ID
Area ID.
CellID | __int32 | cell ID
optional | Cell ID.
Status | PlcLpsStatus | status
Status.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
Data | widestring | data
optional | Data.
AreaName | widestring | area name
optional | Area Name.

Example how to create this action:

   __int32         TagID           = 1;
   __int64         X               = 1;
   __int64         Y               = 1;
   __int32         AreaID          = 1;
   PlcLpsStatus    Status          = lstPositionOK;

   HGscAction anAction;
   anAction = GscAct_CreateLPSPositionData(TagID, NULL, X, Y, NULL, NULL, NULL, AreaID, NULL, Status, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         TagID;
   const wchar_t*  ScannerID;
   __int64         X;
   __int64         Y;
   const __int64*  Z;
   const double*   Latitude;
   const double*   Longitude;
   __int32         AreaID;
   const __int32*  CellID;
   PlcLpsStatus    Status;
   const TGLibDateTime* TimeStamp;
   const wchar_t*  Data;
   const wchar_t*  AreaName;

   if (! GscAct_DecodeLPSPositionData(anAction, TagID, ScannerID, X, Y, Z, Latitude, Longitude, AreaID, CellID, Status, TimeStamp, Data, AreaName))
   {
     // error handling
   }


GSC actions: LPS query position

LPS query position
[LPS]

Collaboration diagram for LPS query position:

Send position query for a Tag to LPS server.

Send position query for a Tag to LPS server.

Parameters

Name | Type | Description
TagID | __int32 | tag ID
Tag ID.
ScannerID | widestring | scanner ID
optional | Scanner ID or IP address.
Data | widestring | data
optional | Data.

Example how to create this action:

   __int32         TagID           = 1;

   HGscAction anAction;
   anAction = GscAct_CreateLPSQueryPosition(TagID, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         TagID;
   const wchar_t*  ScannerID;
   const wchar_t*  Data;

   if (! GscAct_DecodeLPSQueryPosition(anAction, TagID, ScannerID, Data))
   {
     // error handling
   }


GSC actions: Lenel

Modules

Lenel
[Actions]

Collaboration diagram for Lenel:

Detailed Description

Lenel.

Modules

Lenel access event

Lenel OnGuard access event.

Lenel fire event

Lenel OnGuard fire event.

Lenel intercom event

Lenel OnGuard intercom event.

Lenel raw data

Lenel OnGuard raw data.

Lenel refresh names

Lenel OnGuard refresh names.

Lenel security event

Lenel OnGuard security event.

Lenel video event

Lenel OnGuard video event.


GSC actions: Lenel access event

Lenel access event
[Lenel]

Collaboration diagram for Lenel access event:

Lenel OnGuard access event.

Lenel OnGuard access event.

Parameters

Name | Type | Description
ID | LenelEventID | ID
optional | The ID that uniquely identifies the type of this event.
Panel | widestring | panel
optional | The name of the panel where this event originated.
Device | widestring | device
optional | The name of the device where this event originated.
SecondaryDevice | __int32 | secondary device
optional | The ID of the secondary device where this event originated.
CardNumber | __int64 | card number
optional | The badge ID for the card that was read, if available.
AccessResult | LenelAccessResult | access result
optional | The level of access that was granted that resulted from reading the card.
Type | LenelEventType | type
optional | Event type i.e., duress, system, etc.
SubType | __int32 | subtype
optional | Event sub-type i.e., granted, door forced open, etc.
Description | widestring | description
A human readable, brief description of this event.
SerialNumber | __int32 | serial number
optional | A number that uniquely identifies the instance of the event for a particular panel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
AreaEnteredID | __int32 | area entered
optional | The ID of the area that was entered, if any.
AreaExitedID | __int32 | area exited
optional | The ID of the area that was exited, if any.
AssetID | widestring | asset ID
optional | The ID of the asset related to this event, if any.
CardholderEntered | bool | cardholder entered
optional | Whether entry was made by the cardholder.
Duress | bool | duress
optional | Indicates whether this card access indicates an under duress/emergency state.
ElevatorFloor | __int32 | elevator floor
optional | The elevator floor on which the access event was generated, if any.
FacilityCode | __int32 | facility code
optional | The facility code for the card that was read, if available.
IsReadableCard | bool | readable card
optional | Whether the card could be read.
IssueCode | __int32 | issue code
optional | The issue code for the card that was read, if available.
CommServerHostName | widestring | server host
optional | Host name of the Communication server through which the event arrived.
EventText | widestring | event text
optional | Text associated with event

Example how to create this action:

   const wchar_t*  Description     = L"description";

   HGscAction anAction;
   anAction = GscAct_CreateLenelAccessEvent(NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, Description, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const LenelEventID* ID;
   const wchar_t*  Panel;
   const wchar_t*  Device;
   const __int32*  SecondaryDevice;
   const __int64*  CardNumber;
   const LenelAccessResult* AccessResult;
   const LenelEventType* Type;
   const __int32*  SubType;
   const wchar_t*  Description;
   const __int32*  SerialNumber;
   const TGLibDateTime* TimeStamp;
   const __int32*  AreaEnteredID;
   const __int32*  AreaExitedID;
   const wchar_t*  AssetID;
   const bool*     CardholderEntered;
   const bool*     Duress;
   const __int32*  ElevatorFloor;
   const __int32*  FacilityCode;
   const bool*     IsReadableCard;
   const __int32*  IssueCode;
   const wchar_t*  CommServerHostName;
   const wchar_t*  EventText;

   if (! GscAct_DecodeLenelAccessEvent(anAction, ID, Panel, Device, SecondaryDevice, CardNumber, AccessResult, Type, SubType, Description, SerialNumber, TimeStamp, AreaEnteredID, AreaExitedID, AssetID, CardholderEntered, Duress, ElevatorFloor, FacilityCode, IsReadableCard, IssueCode, CommServerHostName, EventText))
   {
     // error handling
   }


GSC actions: Lenel fire event

Lenel fire event
[Lenel]

Collaboration diagram for Lenel fire event:

Lenel OnGuard fire event.

Lenel OnGuard fire event.

Parameters

Name | Type | Description
ID | LenelEventID | ID
optional | The ID that uniquely identifies the type of this event.
Panel | widestring | panel
optional | The name of the panel where this event originated.
Device | widestring | device
optional | The name of the device where this event originated.
SecondaryDevice | __int32 | secondary device
optional | The ID of the secondary device where this event originated.
TroubleCode | __int32 | trouble code
optional | A trouble code associated with the fire event.
Type | LenelEventType | type
optional | Event type i.e., duress, system, etc.
SubType | __int32 | subtype
optional | Event sub-type i.e., granted, door forced open, etc.
Description | widestring | description
A human readable, brief description of this event.
SerialNumber | __int32 | serial number
optional | A number that uniquely identifies the instance of the event for a particular panel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
CommServerHostName | widestring | server host
optional | Host name of the Communication server through which the event arrived.
EventText | widestring | event text
optional | Text associated with event

Example how to create this action:

   const wchar_t*  Description     = L"description";

   HGscAction anAction;
   anAction = GscAct_CreateLenelFireEvent(NULL, NULL, NULL, NULL, NULL, NULL, NULL, Description, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const LenelEventID* ID;
   const wchar_t*  Panel;
   const wchar_t*  Device;
   const __int32*  SecondaryDevice;
   const __int32*  TroubleCode;
   const LenelEventType* Type;
   const __int32*  SubType;
   const wchar_t*  Description;
   const __int32*  SerialNumber;
   const TGLibDateTime* TimeStamp;
   const wchar_t*  CommServerHostName;
   const wchar_t*  EventText;

   if (! GscAct_DecodeLenelFireEvent(anAction, ID, Panel, Device, SecondaryDevice, TroubleCode, Type, SubType, Description, SerialNumber, TimeStamp, CommServerHostName, EventText))
   {
     // error handling
   }


GSC actions: Lenel intercom event

Lenel intercom event
[Lenel]

Collaboration diagram for Lenel intercom event:

Lenel OnGuard intercom event.

Lenel OnGuard intercom event.

Parameters

Name | Type | Description
ID | LenelEventID | ID
optional | The ID that uniquely identifies the type of this event.
Panel | widestring | panel
optional | The name of the panel where this event originated.
Device | widestring | device
optional | The name of the device where this event originated.
SecondaryDevice | __int32 | secondary device
optional | The ID of the secondary device where this event originated.
IntercomData | __int32 | intercom data
optional | Additional data for the intercom event that occurred.
LineNumber | __int32 | line number
optional | The line number involved in the intercom event.
Type | LenelEventType | type
optional | Event type i.e., duress, system, etc.
SubType | __int32 | subtype
optional | Event sub-type i.e., granted, door forced open, etc.
Description | widestring | description
A human readable, brief description of this event.
SerialNumber | __int32 | serial number
optional | A number that uniquely identifies the instance of the event for a particular panel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
CommServerHostName | widestring | server host
optional | Host name of the Communication server through which the event arrived.
EventText | widestring | event text
optional | Text associated with event

Example how to create this action:

   const wchar_t*  Description     = L"description";

   HGscAction anAction;
   anAction = GscAct_CreateLenelIntercomEvent(NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, Description, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const LenelEventID* ID;
   const wchar_t*  Panel;
   const wchar_t*  Device;
   const __int32*  SecondaryDevice;
   const __int32*  IntercomData;
   const __int32*  LineNumber;
   const LenelEventType* Type;
   const __int32*  SubType;
   const wchar_t*  Description;
   const __int32*  SerialNumber;
   const TGLibDateTime* TimeStamp;
   const wchar_t*  CommServerHostName;
   const wchar_t*  EventText;

   if (! GscAct_DecodeLenelIntercomEvent(anAction, ID, Panel, Device, SecondaryDevice, IntercomData, LineNumber, Type, SubType, Description, SerialNumber, TimeStamp, CommServerHostName, EventText))
   {
     // error handling
   }


GSC actions: Lenel raw data

Lenel raw data
[Lenel]

Collaboration diagram for Lenel raw data:

Lenel OnGuard raw data.

Lenel OnGuard raw data.

Parameters

Name | Type | Description
TimeStamp | TGLibDateTime | time stamp
Time stamp.
LenelData | widestring | data
Lenel OnGuard data.

Example how to create this action:

   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  LenelData       = L"data";

   HGscAction anAction;
   anAction = GscAct_CreateLenelRawData(TimeStamp, LenelData);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TGLibDateTime   TimeStamp;
   const wchar_t*  LenelData;

   if (! GscAct_DecodeLenelRawData(anAction, TimeStamp, LenelData))
   {
     // error handling
   }


GSC actions: Lenel refresh names

Lenel refresh names
[Lenel]

Collaboration diagram for Lenel refresh names:

Lenel OnGuard refresh names.

Lenel OnGuard refresh names.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateLenelRefreshNames();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeLenelRefreshNames(anAction))
   {
     // error handling
   }


GSC actions: Lenel security event

Lenel security event
[Lenel]

Collaboration diagram for Lenel security event:

Lenel OnGuard security event.

Lenel OnGuard security event.

Parameters

Name | Type | Description
ID | LenelEventID | ID
optional | The ID that uniquely identifies the type of this event.
Panel | widestring | panel
optional | The name of the panel where this event originated.
Device | widestring | device
optional | The name of the device where this event originated.
SecondaryDevice | __int32 | secondary device
optional | The ID of the secondary device where this event originated.
Type | LenelEventType | type
optional | Event type i.e., duress, system, etc.
SubType | __int32 | subtype
optional | Event sub-type i.e., granted, door forced open, etc.
Description | widestring | description
A human readable, brief description of this event.
SerialNumber | __int32 | serial number
optional | A number that uniquely identifies the instance of the event for a particular panel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
CommServerHostName | widestring | server host
optional | Host name of the Communication server through which the event arrived.
EventText | widestring | event text
optional | Text associated with event

Example how to create this action:

   const wchar_t*  Description     = L"description";

   HGscAction anAction;
   anAction = GscAct_CreateLenelSecurityEvent(NULL, NULL, NULL, NULL, NULL, NULL, Description, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const LenelEventID* ID;
   const wchar_t*  Panel;
   const wchar_t*  Device;
   const __int32*  SecondaryDevice;
   const LenelEventType* Type;
   const __int32*  SubType;
   const wchar_t*  Description;
   const __int32*  SerialNumber;
   const TGLibDateTime* TimeStamp;
   const wchar_t*  CommServerHostName;
   const wchar_t*  EventText;

   if (! GscAct_DecodeLenelSecurityEvent(anAction, ID, Panel, Device, SecondaryDevice, Type, SubType, Description, SerialNumber, TimeStamp, CommServerHostName, EventText))
   {
     // error handling
   }


GSC actions: Lenel video event

Lenel video event
[Lenel]

Collaboration diagram for Lenel video event:

Lenel OnGuard video event.

Lenel OnGuard video event.

Parameters

Name | Type | Description
ID | LenelEventID | ID
optional | The ID that uniquely identifies the type of this event.
Panel | widestring | panel
optional | The name of the panel where this event originated.
Device | widestring | device
optional | The name of the device where this event originated.
SecondaryDevice | __int32 | secondary device
optional | The ID of the secondary device where this event originated.
Channel | __int32 | channel
optional | The physical channel the camera is connected to that is creating this event.
Type | LenelEventType | type
optional | Event type i.e., duress, system, etc.
SubType | __int32 | subtype
optional | Event sub-type i.e., granted, door forced open, etc.
Description | widestring | description
A human readable, brief description of this event.
SerialNumber | __int32 | serial number
optional | A number that uniquely identifies the instance of the event for a particular panel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
StartTime | TGLibDateTime | start stamp
optional | The time the video event started
EndTime | TGLibDateTime | end time
optional | The time the video event ended.
CommServerHostName | widestring | server host
optional | Host name of the Communication server through which the event arrived.
EventText | widestring | event text
optional | Text associated with event

Example how to create this action:

   const wchar_t*  Description     = L"description";

   HGscAction anAction;
   anAction = GscAct_CreateLenelVideoEvent(NULL, NULL, NULL, NULL, NULL, NULL, NULL, Description, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const LenelEventID* ID;
   const wchar_t*  Panel;
   const wchar_t*  Device;
   const __int32*  SecondaryDevice;
   const __int32*  Channel;
   const LenelEventType* Type;
   const __int32*  SubType;
   const wchar_t*  Description;
   const __int32*  SerialNumber;
   const TGLibDateTime* TimeStamp;
   const TGLibDateTime* StartTime;
   const TGLibDateTime* EndTime;
   const wchar_t*  CommServerHostName;
   const wchar_t*  EventText;

   if (! GscAct_DecodeLenelVideoEvent(anAction, ID, Panel, Device, SecondaryDevice, Channel, Type, SubType, Description, SerialNumber, TimeStamp, StartTime, EndTime, CommServerHostName, EventText))
   {
     // error handling
   }


GSC actions: POS

Modules

POS
[Actions]

Collaboration diagram for POS:

Detailed Description

POS (point of sale).

Modules

Barcode data

Barcode data.

Filling pump status

Filling pump status.

Interface raw answer

Interface raw answer.

Interface raw data

Interface raw data.

POS data

POS data.

POS status

POS status.

Terminal article data

Terminal article data.

Terminal payment data

Terminal payment data.


GSC actions: Barcode data

Barcode data
[POS]

Collaboration diagram for Barcode data:

Barcode data.

Barcode data.

Parameters

Name | Type | Description
ReaderName | widestring | scanner
Scanner name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Barcode | widestring | code
Barcode.

Example how to create this action:

   const wchar_t*  ReaderName      = L"scanner";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  Barcode         = L"code";

   HGscAction anAction;
   anAction = GscAct_CreateBarcodeData(ReaderName, TimeStamp, Barcode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ReaderName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  Barcode;

   if (! GscAct_DecodeBarcodeData(anAction, ReaderName, TimeStamp, Barcode))
   {
     // error handling
   }


GSC actions: Filling pump status

Filling pump status
[POS]

Collaboration diagram for Filling pump status:

Filling pump status.

Filling pump status.

Parameters

Name | Type | Description
TerminalName | widestring | terminal
Terminal name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
PumpNo | __int32 | pump no
Pump no.
Status | PlcPumpStatus | status
Status.
Amount | double | amount
optional | Amount.
Price | double | price
optional | Price.
Details | widestring | details
optional | Details.

Example how to create this action:

   const wchar_t*  TerminalName    = L"terminal";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   __int32         PumpNo          = 1;
   PlcPumpStatus   Status          = pumStarted;

   HGscAction anAction;
   anAction = GscAct_CreateFillingPumpStatus(TerminalName, TimeStamp, PumpNo, Status, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  TerminalName;
   TGLibDateTime   TimeStamp;
   __int32         PumpNo;
   PlcPumpStatus   Status;
   const double*   Amount;
   const double*   Price;
   const wchar_t*  Details;

   if (! GscAct_DecodeFillingPumpStatus(anAction, TerminalName, TimeStamp, PumpNo, Status, Amount, Price, Details))
   {
     // error handling
   }


GSC actions: Interface raw answer

Interface raw answer
[POS]

Collaboration diagram for Interface raw answer:

Interface raw answer.

Interface raw answer.

Parameters

Name | Type | Description
InterfaceName | widestring | interface
Interface name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Data | widestring | answer
Interface answer.

Example how to create this action:

   const wchar_t*  InterfaceName   = L"interface";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  Data            = L"answer";

   HGscAction anAction;
   anAction = GscAct_CreateInterfaceRawAnswer(InterfaceName, TimeStamp, Data);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  Data;

   if (! GscAct_DecodeInterfaceRawAnswer(anAction, InterfaceName, TimeStamp, Data))
   {
     // error handling
   }


GSC actions: Interface raw data

Interface raw data
[POS]

Collaboration diagram for Interface raw data:

Interface raw data.

Interface raw data.

Parameters

Name | Type | Description
InterfaceName | widestring | interface
Interface name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Data | widestring | data
Interface data.

Example how to create this action:

   const wchar_t*  InterfaceName   = L"interface";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  Data            = L"data";

   HGscAction anAction;
   anAction = GscAct_CreateInterfaceRawData(InterfaceName, TimeStamp, Data);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  Data;

   if (! GscAct_DecodeInterfaceRawData(anAction, InterfaceName, TimeStamp, Data))
   {
     // error handling
   }


GSC actions: POS data

POS data
[POS]

Collaboration diagram for POS data:

POS data.

POS data.

Parameters

Name | Type | Description
POSName | widestring | POS
POS name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Article | widestring | article
optional | Article description.
Price | double | price
optional | Price.
Units | __int32 | units
optional | Number of units.
PricePerUnit | double | price per unit
optional | Price per unit.
Line1 | widestring | line 1
optional | Line 1.
Line2 | widestring | line 2
optional | Line 2.
Line3 | widestring | line 3
optional | Line 3.
Line4 | widestring | line 4
optional | Line 4.
Line5 | widestring | line 5
optional | Line 5.

Example how to create this action:

   const wchar_t*  POSName         = L"POS";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreatePOSData(POSName, TimeStamp, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  POSName;
   TGLibDateTime   TimeStamp;
   const wchar_t*  Article;
   const double*   Price;
   const __int32*  Units;
   const double*   PricePerUnit;
   const wchar_t*  Line1;
   const wchar_t*  Line2;
   const wchar_t*  Line3;
   const wchar_t*  Line4;
   const wchar_t*  Line5;

   if (! GscAct_DecodePOSData(anAction, POSName, TimeStamp, Article, Price, Units, PricePerUnit, Line1, Line2, Line3, Line4, Line5))
   {
     // error handling
   }


GSC actions: POS status

POS status
[POS]

Collaboration diagram for POS status:

POS status.

POS status.

Parameters

Name | Type | Description
POSName | widestring | POS
POS name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Status | PlcPOSStatus | status
Status.
Details | widestring | details
optional | Details.

Example how to create this action:

   const wchar_t*  POSName         = L"POS";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   PlcPOSStatus    Status          = posStarted;

   HGscAction anAction;
   anAction = GscAct_CreatePOSStatus(POSName, TimeStamp, Status, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  POSName;
   TGLibDateTime   TimeStamp;
   PlcPOSStatus    Status;
   const wchar_t*  Details;

   if (! GscAct_DecodePOSStatus(anAction, POSName, TimeStamp, Status, Details))
   {
     // error handling
   }


GSC actions: Terminal article data

Terminal article data
[POS]

Collaboration diagram for Terminal article data:

Terminal article data.

Terminal article data.

Parameters

Name | Type | Description
TerminalName | widestring | terminal
Terminal name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
CashierStation | __int32 | cashier station
Cashier station.
PumpNo | __int32 | pump no
optional | Pump no.
AlarmStatus | bool | alarm
Alarm status.
Amount | double | amount
optional | Amount.
Price | double | price
optional | Price.
Details | widestring | details
optional | Details.

Example how to create this action:

   const wchar_t*  TerminalName    = L"terminal";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   __int32         CashierStation  = 1;
   bool            AlarmStatus     = false;

   HGscAction anAction;
   anAction = GscAct_CreateTerminalArticleData(TerminalName, TimeStamp, CashierStation, NULL, AlarmStatus, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  TerminalName;
   TGLibDateTime   TimeStamp;
   __int32         CashierStation;
   const __int32*  PumpNo;
   bool            AlarmStatus;
   const double*   Amount;
   const double*   Price;
   const wchar_t*  Details;

   if (! GscAct_DecodeTerminalArticleData(anAction, TerminalName, TimeStamp, CashierStation, PumpNo, AlarmStatus, Amount, Price, Details))
   {
     // error handling
   }


GSC actions: Terminal payment data

Terminal payment data
[POS]

Collaboration diagram for Terminal payment data:

Terminal payment data.

Terminal payment data.

Parameters

Name | Type | Description
TerminalName | widestring | terminal
Terminal name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
CashierStation | __int32 | cashier station
Cashier station.
PumpNo | __int32 | pump no
optional | Pump no.
AlarmStatus | bool | alarm
Alarm status.
Amount | double | amount
optional | Amount.
Price | double | price
optional | Price.
Details | widestring | details
optional | Details.

Example how to create this action:

   const wchar_t*  TerminalName    = L"terminal";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   __int32         CashierStation  = 1;
   bool            AlarmStatus     = false;

   HGscAction anAction;
   anAction = GscAct_CreateTerminalPaymentData(TerminalName, TimeStamp, CashierStation, NULL, AlarmStatus, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  TerminalName;
   TGLibDateTime   TimeStamp;
   __int32         CashierStation;
   const __int32*  PumpNo;
   bool            AlarmStatus;
   const double*   Amount;
   const double*   Price;
   const wchar_t*  Details;

   if (! GscAct_DecodeTerminalPaymentData(anAction, TerminalName, TimeStamp, CashierStation, PumpNo, AlarmStatus, Amount, Price, Details))
   {
     // error handling
   }


GSC actions: Perimeter protection

Modules

Perimeter protection
[Actions]

Collaboration diagram for Perimeter protection:

Detailed Description

Perimeter protection.

Modules

PP device alarm

Perimeter protection device alarm.

PP device input

Perimeter protection device input.

PP device offline

Perimeter protection device offline.

PP device online

Perimeter protection device online.

PP interface offline

Perimeter protection interface offline.

PP interface online

Perimeter protection interface online.

PP query interface

Perimeter protection query interface.

PP set device output

Perimeter protection set device output.

PP subcell alarm

Perimeter protection subcell alarm.

PP zone alarm

Perimeter protection zone alarm.


GSC actions: PP device alarm

PP device alarm
[Perimeter protection]

Collaboration diagram for PP device alarm:

Perimeter protection device alarm.

Perimeter protection device alarm.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.
DeviceAddress | __int32 | device address
Device address.
Sensor | PPSensorKind | sensor
Sensor.
State | PPAlarmState | state
State.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";
   __int32         DeviceAddress   = 1;
   PPSensorKind    Sensor          = pskCableAFault;
   PPAlarmState    State           = pasNormal;

   HGscAction anAction;
   anAction = GscAct_CreatePPDeviceAlarm(InterfaceID, DeviceAddress, Sensor, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;
   __int32         DeviceAddress;
   PPSensorKind    Sensor;
   PPAlarmState    State;

   if (! GscAct_DecodePPDeviceAlarm(anAction, InterfaceID, DeviceAddress, Sensor, State))
   {
     // error handling
   }


GSC actions: PP device input

PP device input
[Perimeter protection]

Collaboration diagram for PP device input:

Perimeter protection device input.

Perimeter protection device input.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.
DeviceAddress | __int32 | device address
Device address.
Input | __int32 | input
Input.
State | PPAlarmState | state
State.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";
   __int32         DeviceAddress   = 1;
   __int32         Input           = 1;
   PPAlarmState    State           = pasNormal;

   HGscAction anAction;
   anAction = GscAct_CreatePPDeviceInput(InterfaceID, DeviceAddress, Input, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;
   __int32         DeviceAddress;
   __int32         Input;
   PPAlarmState    State;

   if (! GscAct_DecodePPDeviceInput(anAction, InterfaceID, DeviceAddress, Input, State))
   {
     // error handling
   }


GSC actions: PP device offline

PP device offline
[Perimeter protection]

Collaboration diagram for PP device offline:

Perimeter protection device offline.

Perimeter protection device offline.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.
DeviceAddress | __int32 | device address
Device address.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";
   __int32         DeviceAddress   = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePPDeviceOffline(InterfaceID, DeviceAddress);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;
   __int32         DeviceAddress;

   if (! GscAct_DecodePPDeviceOffline(anAction, InterfaceID, DeviceAddress))
   {
     // error handling
   }


GSC actions: PP device online

PP device online
[Perimeter protection]

Collaboration diagram for PP device online:

Perimeter protection device online.

Perimeter protection device online.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.
DeviceAddress | __int32 | device address
Device address.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";
   __int32         DeviceAddress   = 1;

   HGscAction anAction;
   anAction = GscAct_CreatePPDeviceOnline(InterfaceID, DeviceAddress);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;
   __int32         DeviceAddress;

   if (! GscAct_DecodePPDeviceOnline(anAction, InterfaceID, DeviceAddress))
   {
     // error handling
   }


GSC actions: PP interface offline

PP interface offline
[Perimeter protection]

Collaboration diagram for PP interface offline:

Perimeter protection interface offline.

Perimeter protection interface offline.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";

   HGscAction anAction;
   anAction = GscAct_CreatePPInterfaceOffline(InterfaceID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;

   if (! GscAct_DecodePPInterfaceOffline(anAction, InterfaceID))
   {
     // error handling
   }


GSC actions: PP interface online

PP interface online
[Perimeter protection]

Collaboration diagram for PP interface online:

Perimeter protection interface online.

Perimeter protection interface online.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";

   HGscAction anAction;
   anAction = GscAct_CreatePPInterfaceOnline(InterfaceID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;

   if (! GscAct_DecodePPInterfaceOnline(anAction, InterfaceID))
   {
     // error handling
   }


GSC actions: PP query interface

PP query interface
[Perimeter protection]

Collaboration diagram for PP query interface:

Perimeter protection query interface.

Perimeter protection query interface.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";

   HGscAction anAction;
   anAction = GscAct_CreatePPQueryInterface(InterfaceID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;

   if (! GscAct_DecodePPQueryInterface(anAction, InterfaceID))
   {
     // error handling
   }


GSC actions: PP set device output

PP set device output
[Perimeter protection]

Collaboration diagram for PP set device output:

Perimeter protection set device output.

Perimeter protection set device output.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.
DeviceAddress | __int32 | device address
Device address.
Output | __int32 | output
Output.
State | PPAlarmState | state
State.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";
   __int32         DeviceAddress   = 1;
   __int32         Output          = 1;
   PPAlarmState    State           = pasNormal;

   HGscAction anAction;
   anAction = GscAct_CreatePPSetDeviceOutput(InterfaceID, DeviceAddress, Output, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;
   __int32         DeviceAddress;
   __int32         Output;
   PPAlarmState    State;

   if (! GscAct_DecodePPSetDeviceOutput(anAction, InterfaceID, DeviceAddress, Output, State))
   {
     // error handling
   }


GSC actions: PP subcell alarm

PP subcell alarm
[Perimeter protection]

Collaboration diagram for PP subcell alarm:

Perimeter protection subcell alarm.

Perimeter protection subcell alarm.

Parameters

Name | Type | Description
InterfaceID | widestring | interface id
Interface ID.
DeviceAddress | __int32 | device address
Device address.
Cable | PPCableKind | cable
Cable.
Subcell | __int32 | subcell
Subcell.
State | PPAlarmState | state
State.

Example how to create this action:

   const wchar_t*  InterfaceID     = L"interface id";
   __int32         DeviceAddress   = 1;
   PPCableKind     Cable           = pckCableA;
   __int32         Subcell         = 1;
   PPAlarmState    State           = pasNormal;

   HGscAction anAction;
   anAction = GscAct_CreatePPSubcellAlarm(InterfaceID, DeviceAddress, Cable, Subcell, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceID;
   __int32         DeviceAddress;
   PPCableKind     Cable;
   __int32         Subcell;
   PPAlarmState    State;

   if (! GscAct_DecodePPSubcellAlarm(anAction, InterfaceID, DeviceAddress, Cable, Subcell, State))
   {
     // error handling
   }


GSC actions: PP zone alarm

PP zone alarm
[Perimeter protection]

Collaboration diagram for PP zone alarm:

Perimeter protection zone alarm.

Perimeter protection zone alarm.

Parameters

Name | Type | Description
ZoneID | widestring | zone id
Zone ID.
InterfaceID | widestring | interface id
Interface ID.
DeviceAddress | __int32 | device address
Device address.
Cable | PPCableKind | cable
optional | Cable.
Subcell | __int32 | subcell
optional | Subcell.
State | PPAlarmState | state
State.

Example how to create this action:

   const wchar_t*  ZoneID          = L"zone id";
   const wchar_t*  InterfaceID     = L"interface id";
   __int32         DeviceAddress   = 1;
   PPAlarmState    State           = pasNormal;

   HGscAction anAction;
   anAction = GscAct_CreatePPZoneAlarm(ZoneID, InterfaceID, DeviceAddress, NULL, NULL, State);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  ZoneID;
   const wchar_t*  InterfaceID;
   __int32         DeviceAddress;
   const PPCableKind* Cable;
   const __int32*  Subcell;
   PPAlarmState    State;

   if (! GscAct_DecodePPZoneAlarm(anAction, ZoneID, InterfaceID, DeviceAddress, Cable, Subcell, State))
   {
     // error handling
   }


GSC actions: Remote export

Modules

Remote export
[Actions]

Collaboration diagram for Remote export:

Detailed Description

Remote export.

Modules

Cancel export

Cancel export.

Export finished

Export finished.

Export progress

Export progress.

Initialize remote export

Initialize remote export.

Set export marker

Set export marker.

Start remote export

Start remote export.

Start scene store

Start scene store.


GSC actions: Cancel export

Cancel export
[Remote export]

Collaboration diagram for Cancel export:

Cancel export.

Cancel export.

Parameters

Name | Type | Description
ExportID | GUID | export GUID
Export GUID.
AbortFlag | PlcExportAbort | abort flag
Abort flag.

Example how to create this action:

   GUID            ExportID        = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   PlcExportAbort  AbortFlag       = exaUserAbort;

   HGscAction anAction;
   anAction = GscAct_CreateCancelExport(ExportID, AbortFlag);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            ExportID;
   PlcExportAbort  AbortFlag;

   if (! GscAct_DecodeCancelExport(anAction, ExportID, AbortFlag))
   {
     // error handling
   }


GSC actions: Export finished

Export finished
[Remote export]

Collaboration diagram for Export finished:

Export finished.

Export finished.

Parameters

Name | Type | Description
ExportID | GUID | export GUID
Export GUID.
Success | PlcExportSuccess | success
Success.

Example how to create this action:

   GUID            ExportID        = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   PlcExportSuccess Success         = exsSuccess;

   HGscAction anAction;
   anAction = GscAct_CreateExportFinished(ExportID, Success);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            ExportID;
   PlcExportSuccess Success;

   if (! GscAct_DecodeExportFinished(anAction, ExportID, Success))
   {
     // error handling
   }


GSC actions: Export progress

Export progress
[Remote export]

Collaboration diagram for Export progress:

Export progress.

Export progress.

Parameters

Name | Type | Description
ExportID | GUID | export GUID
Export GUID.
Progress | __int32 | progress
Progress.

Example how to create this action:

   GUID            ExportID        = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   __int32         Progress        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateExportProgress(ExportID, Progress);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            ExportID;
   __int32         Progress;

   if (! GscAct_DecodeExportProgress(anAction, ExportID, Progress))
   {
     // error handling
   }


GSC actions: Initialize remote export

Initialize remote export
[Remote export]

Collaboration diagram for Initialize remote export:

Initialize remote export.

Initialize remote export.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Device | GUID | device GUID
Pilot device GUID.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   GUID            Device          = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};

   HGscAction anAction;
   anAction = GscAct_CreateInitializeRemoteExport(Viewer, Device);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   GUID            Device;

   if (! GscAct_DecodeInitializeRemoteExport(anAction, Viewer, Device))
   {
     // error handling
   }


GSC actions: Set export marker

Set export marker
[Remote export]

Collaboration diagram for Set export marker:

Set export marker.

Set export marker.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Marker | PlcExportMarker | marker
Marker kind.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   PlcExportMarker Marker          = exmSelectionBegin;

   HGscAction anAction;
   anAction = GscAct_CreateSetExportMarker(Viewer, Marker);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   PlcExportMarker Marker;

   if (! GscAct_DecodeSetExportMarker(anAction, Viewer, Marker))
   {
     // error handling
   }


GSC actions: Start remote export

Start remote export
[Remote export]

Collaboration diagram for Start remote export:

Start remote export.

Start remote export.

Parameters

Name | Type | Description
ExportID | GUID | export GUID
Export GUID.
Device | GUID | device GUID
Pilot device GUID.
BackupFormat | PlcBackupFormat | format
Backup format.
Channel | TMediaChannelID | channel
Channel.
SelectionBegin | TGLibDateTime | start time
Start time.
SelectionEnd | TGLibDateTime | end time
End time.
JobID | widestring | job ID
Job ID.

Example how to create this action:

   GUID            ExportID        = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   GUID            Device          = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   PlcBackupFormat BackupFormat    = ebfDefault;
   TMediaChannelID Channel         = {0, L"", 0};
   TGLibDateTime   SelectionBegin  = TGLibDateTime::Now();
   TGLibDateTime   SelectionEnd    = TGLibDateTime::Now();
   const wchar_t*  JobID           = L"job ID";

   HGscAction anAction;
   anAction = GscAct_CreateStartRemoteExport(ExportID, Device, BackupFormat, Channel, SelectionBegin, SelectionEnd, JobID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            ExportID;
   GUID            Device;
   PlcBackupFormat BackupFormat;
   TMediaChannelID Channel;
   TGLibDateTime   SelectionBegin;
   TGLibDateTime   SelectionEnd;
   const wchar_t*  JobID;

   if (! GscAct_DecodeStartRemoteExport(anAction, ExportID, Device, BackupFormat, Channel, SelectionBegin, SelectionEnd, JobID))
   {
     // error handling
   }


GSC actions: Start scene store

Start scene store
[Remote export]

Collaboration diagram for Start scene store:

Start scene store.

Start scene store.

Parameters

Name | Type | Description
SceneStoreID | GUID | scene store GUID
Scene store GUID.
CutList | widestring | cut-list
Cut-list.
PreHistoryLength | __int64 | pre-history length
Pre-history length.
RecordingLength | __int64 | recording length
Recording length.

Example how to create this action:

   GUID            SceneStoreID    = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   const wchar_t*  CutList         = L"cut-list";
   __int64         PreHistoryLength = 1;
   __int64         RecordingLength = 1;

   HGscAction anAction;
   anAction = GscAct_CreateStartSceneStore(SceneStoreID, CutList, PreHistoryLength, RecordingLength);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            SceneStoreID;
   const wchar_t*  CutList;
   __int64         PreHistoryLength;
   __int64         RecordingLength;

   if (! GscAct_DecodeStartSceneStore(anAction, SceneStoreID, CutList, PreHistoryLength, RecordingLength))
   {
     // error handling
   }


GSC actions: SKIDATA

Modules

SKIDATA
[Actions]

Collaboration diagram for SKIDATA:

Detailed Description

SKIDATA messages.

Modules

SKIDATA control

SKIDATA control information.

SKIDATA device event

SKIDATA device event.

SKIDATA entry

SKIDATA entry.

SKIDATA exit

SKIDATA exit.

SKIDATA transaction

SKIDATA transaction.


GSC actions: SKIDATA control

SKIDATA control
[SKIDATA]

Collaboration diagram for SKIDATA control:

SKIDATA control information.

SKIDATA control information.

Parameters

Name | Type | Description
InterfaceName | widestring | interface
Interface name.
Data | PlcSkidataControl | state
Interface state.

Example how to create this action:

   const wchar_t*  InterfaceName   = L"interface";
   PlcSkidataControl Data            = sdcConnectionOk;

   HGscAction anAction;
   anAction = GscAct_CreateSkidataControl(InterfaceName, Data);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceName;
   PlcSkidataControl Data;

   if (! GscAct_DecodeSkidataControl(anAction, InterfaceName, Data))
   {
     // error handling
   }


GSC actions: SKIDATA device event

SKIDATA device event
[SKIDATA]

Collaboration diagram for SKIDATA device event:

SKIDATA device event.

SKIDATA device event.

Parameters

Name | Type | Description
InterfaceName | widestring | interface
Interface name.
DeviceID | __int32 | device
Device ID.
EventCode | __int32 | event code
Event code.

Example how to create this action:

   const wchar_t*  InterfaceName   = L"interface";
   __int32         DeviceID        = 1;
   __int32         EventCode       = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSkidataDeviceEvent(InterfaceName, DeviceID, EventCode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceName;
   __int32         DeviceID;
   __int32         EventCode;

   if (! GscAct_DecodeSkidataDeviceEvent(anAction, InterfaceName, DeviceID, EventCode))
   {
     // error handling
   }


GSC actions: SKIDATA entry

SKIDATA entry
[SKIDATA]

Collaboration diagram for SKIDATA entry:

SKIDATA entry.

SKIDATA entry.

Parameters

Name | Type | Description
InterfaceName | widestring | interface
Interface name.
MessageCode | PlcSkidataMsgCodeEntry | message
Message code.
TranscactionID | widestring | transaction
Transcaction ID.
CarParkNo | __int32 | car park
Car park no.
DeviceID | __int32 | device
Device ID.

Example how to create this action:

   const wchar_t*  InterfaceName   = L"interface";
   PlcSkidataMsgCodeEntry MessageCode     = sdenTicket;
   const wchar_t*  TranscactionID  = L"transaction";
   __int32         CarParkNo       = 1;
   __int32         DeviceID        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSkidataEntry(InterfaceName, MessageCode, TranscactionID, CarParkNo, DeviceID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceName;
   PlcSkidataMsgCodeEntry MessageCode;
   const wchar_t*  TranscactionID;
   __int32         CarParkNo;
   __int32         DeviceID;

   if (! GscAct_DecodeSkidataEntry(anAction, InterfaceName, MessageCode, TranscactionID, CarParkNo, DeviceID))
   {
     // error handling
   }


GSC actions: SKIDATA exit

SKIDATA exit
[SKIDATA]

Collaboration diagram for SKIDATA exit:

SKIDATA exit.

SKIDATA exit.

Parameters

Name | Type | Description
InterfaceName | widestring | interface
Interface name.
MessageCode | PlcSkidataMsgCodeExit | message
Message code.
TranscactionID | widestring | transaction
Transcaction ID.
CarParkNo | __int32 | car park
Car park no.
DeviceID | __int32 | device
Device ID.

Example how to create this action:

   const wchar_t*  InterfaceName   = L"interface";
   PlcSkidataMsgCodeExit MessageCode     = sdexTicket;
   const wchar_t*  TranscactionID  = L"transaction";
   __int32         CarParkNo       = 1;
   __int32         DeviceID        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSkidataExit(InterfaceName, MessageCode, TranscactionID, CarParkNo, DeviceID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceName;
   PlcSkidataMsgCodeExit MessageCode;
   const wchar_t*  TranscactionID;
   __int32         CarParkNo;
   __int32         DeviceID;

   if (! GscAct_DecodeSkidataExit(anAction, InterfaceName, MessageCode, TranscactionID, CarParkNo, DeviceID))
   {
     // error handling
   }


GSC actions: SKIDATA transaction

SKIDATA transaction
[SKIDATA]

Collaboration diagram for SKIDATA transaction:

SKIDATA transaction.

SKIDATA transaction.

Parameters

Name | Type | Description
InterfaceName | widestring | interface
Interface name.
MessageCode | PlcSkidataMsgCodeTransaction | message
Message code.
TranscactionID | widestring | transaction
Transcaction ID.
CarParkNo | __int32 | car park
Car park no.
DeviceID | __int32 | device
Device ID.

Example how to create this action:

   const wchar_t*  InterfaceName   = L"interface";
   PlcSkidataMsgCodeTransaction MessageCode     = sdtrParking;
   const wchar_t*  TranscactionID  = L"transaction";
   __int32         CarParkNo       = 1;
   __int32         DeviceID        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSkidataTransaction(InterfaceName, MessageCode, TranscactionID, CarParkNo, DeviceID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  InterfaceName;
   PlcSkidataMsgCodeTransaction MessageCode;
   const wchar_t*  TranscactionID;
   __int32         CarParkNo;
   __int32         DeviceID;

   if (! GscAct_DecodeSkidataTransaction(anAction, InterfaceName, MessageCode, TranscactionID, CarParkNo, DeviceID))
   {
     // error handling
   }


GSC actions: Supply chain security

Modules

Supply chain security
[Actions]

Collaboration diagram for Supply chain security:

Detailed Description

Supply chain security.

Modules

GSCS vehicle access denied

GSCS vehicle access denied.

GSCS vehicle access expired

GSCS vehicle access expired.

GSCS vehicle access granted

GSCS vehicle access granted.

GSCS vehicle access pending

GSCS vehicle access pending.

Log NPR recognition

Log NPR recognition.

Log barcode data

Logistic barcode data.

Log barcode data LPS

Logistic barcode and LPS data.


GSC actions: GSCS vehicle access denied

GSCS vehicle access denied
[Supply chain security]

Collaboration diagram for GSCS vehicle access denied:

GSCS vehicle access denied.

GSCS vehicle access denied.

Parameters

Name | Type | Description
SequenceID | __int32 | sequence ID
The sequence ID.
PlateNo | widestring | plate no.
Recognized plate no.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
CompanyCategory | widestring | company category
optional | Company category.
CompanyName | widestring | company name
optional | Company name.
Reason | widestring | reason
optional | Reason.
TrafficLane | widestring | traffic lane
optional | Traffic lane.
Channel | TMediaChannelID | channel
optional | Channel.
Direction | TrafficDirection | direction
optional | Direction.

Example how to create this action:

   __int32         SequenceID      = 1;
   const wchar_t*  PlateNo         = L"plate no.";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateGSCSVehicleAccessDenied(SequenceID, PlateNo, TimeStamp, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         SequenceID;
   const wchar_t*  PlateNo;
   TGLibDateTime   TimeStamp;
   const wchar_t*  CompanyCategory;
   const wchar_t*  CompanyName;
   const wchar_t*  Reason;
   const wchar_t*  TrafficLane;
   const TMediaChannelID* Channel;
   const TrafficDirection* Direction;

   if (! GscAct_DecodeGSCSVehicleAccessDenied(anAction, SequenceID, PlateNo, TimeStamp, CompanyCategory, CompanyName, Reason, TrafficLane, Channel, Direction))
   {
     // error handling
   }


GSC actions: GSCS vehicle access expired

GSCS vehicle access expired
[Supply chain security]

Collaboration diagram for GSCS vehicle access expired:

GSCS vehicle access expired.

GSCS vehicle access expired.

Parameters

Name | Type | Description
SequenceID | __int32 | sequence ID
The sequence ID.
PlateNo | widestring | plate no.
Recognized plate no.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ExpiringTime | TGLibDateTime | expiring time
Expiring time.
CompanyCategory | widestring | company category
optional | Company category.
CompanyName | widestring | company name
optional | Company name.
Reason | widestring | reason
optional | Reason.
TrafficLane | widestring | traffic lane
optional | Traffic lane.
Channel | TMediaChannelID | channel
optional | Channel.
Direction | TrafficDirection | direction
optional | Direction.

Example how to create this action:

   __int32         SequenceID      = 1;
   const wchar_t*  PlateNo         = L"plate no.";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   TGLibDateTime   ExpiringTime    = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateGSCSVehicleAccessExpired(SequenceID, PlateNo, TimeStamp, ExpiringTime, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         SequenceID;
   const wchar_t*  PlateNo;
   TGLibDateTime   TimeStamp;
   TGLibDateTime   ExpiringTime;
   const wchar_t*  CompanyCategory;
   const wchar_t*  CompanyName;
   const wchar_t*  Reason;
   const wchar_t*  TrafficLane;
   const TMediaChannelID* Channel;
   const TrafficDirection* Direction;

   if (! GscAct_DecodeGSCSVehicleAccessExpired(anAction, SequenceID, PlateNo, TimeStamp, ExpiringTime, CompanyCategory, CompanyName, Reason, TrafficLane, Channel, Direction))
   {
     // error handling
   }


GSC actions: GSCS vehicle access granted

GSCS vehicle access granted
[Supply chain security]

Collaboration diagram for GSCS vehicle access granted:

GSCS vehicle access granted.

GSCS vehicle access granted.

Parameters

Name | Type | Description
SequenceID | __int32 | sequence ID
The sequence ID.
PlateNo | widestring | plate no.
Recognized plate no.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
CompanyCategory | widestring | company category
optional | Company category.
CompanyName | widestring | company name
optional | Company name.
Reason | widestring | reason
optional | Reason.
TrafficLane | widestring | traffic lane
optional | Traffic lane.
Channel | TMediaChannelID | channel
optional | Channel.
Direction | TrafficDirection | direction
optional | Direction.

Example how to create this action:

   __int32         SequenceID      = 1;
   const wchar_t*  PlateNo         = L"plate no.";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateGSCSVehicleAccessGranted(SequenceID, PlateNo, TimeStamp, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         SequenceID;
   const wchar_t*  PlateNo;
   TGLibDateTime   TimeStamp;
   const wchar_t*  CompanyCategory;
   const wchar_t*  CompanyName;
   const wchar_t*  Reason;
   const wchar_t*  TrafficLane;
   const TMediaChannelID* Channel;
   const TrafficDirection* Direction;

   if (! GscAct_DecodeGSCSVehicleAccessGranted(anAction, SequenceID, PlateNo, TimeStamp, CompanyCategory, CompanyName, Reason, TrafficLane, Channel, Direction))
   {
     // error handling
   }


GSC actions: GSCS vehicle access pending

GSCS vehicle access pending
[Supply chain security]

Collaboration diagram for GSCS vehicle access pending:

GSCS vehicle access pending.

GSCS vehicle access pending.

Parameters

Name | Type | Description
SequenceID | __int32 | sequence ID
The sequence ID.
PlateNo | widestring | plate no.
Recognized plate no.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
CompanyCategory | widestring | company category
optional | Company category.
CompanyName | widestring | company name
optional | Company name.
Reason | widestring | reason
optional | Reason.
TrafficLane | widestring | traffic lane
optional | Traffic lane.
Channel | TMediaChannelID | channel
optional | Channel.
Direction | TrafficDirection | direction
optional | Direction.

Example how to create this action:

   __int32         SequenceID      = 1;
   const wchar_t*  PlateNo         = L"plate no.";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateGSCSVehicleAccessPending(SequenceID, PlateNo, TimeStamp, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         SequenceID;
   const wchar_t*  PlateNo;
   TGLibDateTime   TimeStamp;
   const wchar_t*  CompanyCategory;
   const wchar_t*  CompanyName;
   const wchar_t*  Reason;
   const wchar_t*  TrafficLane;
   const TMediaChannelID* Channel;
   const TrafficDirection* Direction;

   if (! GscAct_DecodeGSCSVehicleAccessPending(anAction, SequenceID, PlateNo, TimeStamp, CompanyCategory, CompanyName, Reason, TrafficLane, Channel, Direction))
   {
     // error handling
   }


GSC actions: Log NPR recognition

Log NPR recognition
[Supply chain security]

Collaboration diagram for Log NPR recognition:

Log NPR recognition.

Log NPR recognition.

Parameters

Name | Type | Description
PlateNo | widestring | plate no.
Recognized plate no.
Hash | __int64 | hash value
optional | Hash value.
Country | widestring | country
optional | Country.
Channel | TMediaChannelID | channel
optional | Channel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
Restriction | PlcNPRRestriction | restriction
optional | Restriction of recognized number.
Category | widestring | category
optional | Category of recognized number.

Example how to create this action:

   const wchar_t*  PlateNo         = L"plate no.";

   HGscAction anAction;
   anAction = GscAct_CreateLogNPRRecognition(PlateNo, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  PlateNo;
   const __int64*  Hash;
   const wchar_t*  Country;
   const TMediaChannelID* Channel;
   const TGLibDateTime* TimeStamp;
   const PlcNPRRestriction* Restriction;
   const wchar_t*  Category;

   if (! GscAct_DecodeLogNPRRecognition(anAction, PlateNo, Hash, Country, Channel, TimeStamp, Restriction, Category))
   {
     // error handling
   }


GSC actions: Log barcode data

Log barcode data
[Supply chain security]

Collaboration diagram for Log barcode data:

Logistic barcode data.

Logistic barcode data.

Parameters

Name | Type | Description
Barcode | widestring | barcode
Barcode.
Hash | __int64 | hash value
optional | Hash value.
Scanner | widestring | scanner name
optional | Scanner name or IP address.
AreaID | __int64 | area number
optional | Area number.
AreaName | widestring | area name
optional | Area name.
Channel | TMediaChannelID | channel
optional | Channel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
Order | widestring | order number
optional | Order number.
Shipment | widestring | shipment number
optional | Shipment number.
Item | widestring | item number
optional | Item number.

Example how to create this action:

   const wchar_t*  Barcode         = L"barcode";

   HGscAction anAction;
   anAction = GscAct_CreateLogBarcodeData(Barcode, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  Barcode;
   const __int64*  Hash;
   const wchar_t*  Scanner;
   const __int64*  AreaID;
   const wchar_t*  AreaName;
   const TMediaChannelID* Channel;
   const TGLibDateTime* TimeStamp;
   const wchar_t*  Order;
   const wchar_t*  Shipment;
   const wchar_t*  Item;

   if (! GscAct_DecodeLogBarcodeData(anAction, Barcode, Hash, Scanner, AreaID, AreaName, Channel, TimeStamp, Order, Shipment, Item))
   {
     // error handling
   }


GSC actions: Log barcode data LPS

Log barcode data LPS
[Supply chain security]

Collaboration diagram for Log barcode data LPS:

Logistic barcode and LPS data.

Logistic barcode and LPS data.

Parameters

Name | Type | Description
Barcode | widestring | barcode
Barcode.
Hash | __int64 | hash value
optional | Hash value.
Scanner | widestring | scanner name
optional | Scanner name or IP address.
AreaID | __int64 | area number
optional | Area number.
AreaName | widestring | area name
optional | Area name.
Channel | TMediaChannelID | channel
optional | Channel.
TimeStamp | TGLibDateTime | time stamp
optional | Time stamp.
X | double | X coordinate
optional | X coordinate.
Y | double | Y coordinate
optional | Y coordinate.
Z | double | Z coordinate
optional | Z coordinate.
LpsTagID | __int32 | LPS tag ID
optional | LPS tag ID.
LpsStatus | PlcLpsStatus | LPS status
optional | LPS status.
LpsCellID | __int32 | LPS cell ID
optional | LPS cell ID.
LpsAreaID | __int32 | LPS area ID
optional | LPS area ID.
UserParam | __int32 | user param
optional | User param.
Order | widestring | order number
optional | Order number.
Shipment | widestring | shipment number
optional | Shipment number.
Item | widestring | item number
optional | Item number.

Example how to create this action:

   const wchar_t*  Barcode         = L"barcode";

   HGscAction anAction;
   anAction = GscAct_CreateLogBarcodeDataLPS(Barcode, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  Barcode;
   const __int64*  Hash;
   const wchar_t*  Scanner;
   const __int64*  AreaID;
   const wchar_t*  AreaName;
   const TMediaChannelID* Channel;
   const TGLibDateTime* TimeStamp;
   const double*   X;
   const double*   Y;
   const double*   Z;
   const __int32*  LpsTagID;
   const PlcLpsStatus* LpsStatus;
   const __int32*  LpsCellID;
   const __int32*  LpsAreaID;
   const __int32*  UserParam;
   const wchar_t*  Order;
   const wchar_t*  Shipment;
   const wchar_t*  Item;

   if (! GscAct_DecodeLogBarcodeDataLPS(anAction, Barcode, Hash, Scanner, AreaID, AreaName, Channel, TimeStamp, X, Y, Z, LpsTagID, LpsStatus, LpsCellID, LpsAreaID, UserParam, Order, Shipment, Item))
   {
     // error handling
   }


GSC actions: System actions

Modules

System actions
[Actions]

Collaboration diagram for System actions:

Detailed Description

All actions describing system behaviour.

Modules

Blocking filter activate

Blocking filter activate.

Blocking filter deactivate

Blocking filter deactivate.

Custom action

This action has no side effects and can be used for customer purposes.

Database recording info per ring

Database recording info per ring.

Database recording info total

Database recording info total.

Database started

This action will be fired at the database start-up.

Event recording changed

Event recording settings are changed.

Event started

Event has started.

Event stopped

Event has stopped.

FRC notification

FRC notification.

GEMOS alarm

GEMOS alarm notification.

IP switch operation

IP switch operation.

Kill all events

Kill all active events.

Kill event

Kill event.

Kill event by instance

Kill event by instance ID.

Live check

This action will be fired every 10 seconds and is intended for use as live check.

Redundant power failure

This action is notified if a failure of the redundant power supply is detected.

Redundant power ok

This action is notified if a failure of the redundant power supply is removed.

SMRP viewer cleared

SMRP viewer cleared.

SMRP viewer connected

SMRP viewer connected to the camera.

SMTP mail

This action will send a user defined email if GSCMail is connected.

Set clock

Set clock.

Set watchdog

Set watchdog.

Setup changed

Setup changed.

Setup upload progress

Setup upload progress.

Start event

Start event.

Stop all events

Stop all active events.

Stop event

Stop event.

Stop event by instance

Stop event by instance ID.

System error

Notify system error.

System info

Notify system information.

System settings changed

Setup of the system and/or the current time range changed.

System started

This action will be fired only once at the system start-up.

System terminating

This action will be fired when the system is going to be shut down.

System warning

Notify system warning.

Transfer binary buffer

Transfer binary buffer.

Transfer binary channel buffer

Transfer binary channel buffer.

User login

This action will be fired when the user has connected to the system.

User login failed

This action will be fired when the user has tried to connect to the system but was rejected.

User logout

This action will be fired when the user has disconnected from the system.


GSC actions: Blocking filter activate

Blocking filter activate
[System actions]

Collaboration diagram for Blocking filter activate:

Blocking filter activate.

Blocking filter activate.

Parameters

Name | Type | Description
Filter | widestring | filter
Blocking filter.

Example how to create this action:

   const wchar_t*  Filter          = L"filter";

   HGscAction anAction;
   anAction = GscAct_CreateBlockingFilterActivate(Filter);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  Filter;

   if (! GscAct_DecodeBlockingFilterActivate(anAction, Filter))
   {
     // error handling
   }


GSC actions: Blocking filter deactivate

Blocking filter deactivate
[System actions]

Collaboration diagram for Blocking filter deactivate:

Blocking filter deactivate.

Blocking filter deactivate.

Parameters

Name | Type | Description
Filter | widestring | filter
Blocking filter.

Example how to create this action:

   const wchar_t*  Filter          = L"filter";

   HGscAction anAction;
   anAction = GscAct_CreateBlockingFilterDeactivate(Filter);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  Filter;

   if (! GscAct_DecodeBlockingFilterDeactivate(anAction, Filter))
   {
     // error handling
   }


GSC actions: Custom action

Custom action
[System actions]

Collaboration diagram for Custom action:

This action has no side effects and can be used for customer purposes.

This action has no side effects and can be used for customer purposes.

Parameters

Name | Type | Description
Int | __int64 | INT parameter
Numeric parameter.
String | widestring | STRING parameter
Literal parameter.

Example how to create this action:

   __int64         Int             = 1;
   const wchar_t*  String          = L"STRING parameter";

   HGscAction anAction;
   anAction = GscAct_CreateCustomAction(Int, String);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         Int;
   const wchar_t*  String;

   if (! GscAct_DecodeCustomAction(anAction, Int, String))
   {
     // error handling
   }


GSC actions: Database recording info per ring

Database recording info per ring
[System actions]

Collaboration diagram for Database recording info per ring:

Database recording info per ring.

Database recording info per ring.

Parameters

Name | Type | Description
DatabaseRing | PlcDatabaseRing | database ring
Database ring.
NoVideoRecording | bool | no video recording
Video is recording or not.
NoAudioRecording | bool | no audio recording
Audio is recording or not.
NoRecordingAtAll | bool | no recording
Video and/or audio is recording or not.
VideoSamplesPerSecond | double | video samples/s
Video samples per second.
VideoMBPerSecond | double | video samples MB/s
Video MB per second.
AudioSamplesPerSecond | double | audio samples/s
Audio samples per second.
AudioMBPerSecond | double | audio samples MB/s
Audio MB per second.
WriteWaitTimesPercent | double | write wait %
Write waiting times in percent.
RingCapacity | __int64 | ring capacity
Ring capacity.
OldestItem | TGLibDateTime | oldest item
Time stamp of the oldest item.
RecordingDepth | double | recording depth
optional | Recording depth in hours.
EstimatedRequiredCapacity | __int64 | estimated required capacity
optional | Estimated required capacity.

Example how to create this action:

   PlcDatabaseRing DatabaseRing    = dbrRing1;
   bool            NoVideoRecording = false;
   bool            NoAudioRecording = false;
   bool            NoRecordingAtAll = false;
   double          VideoSamplesPerSecond = 0.0;
   double          VideoMBPerSecond = 0.0;
   double          AudioSamplesPerSecond = 0.0;
   double          AudioMBPerSecond = 0.0;
   double          WriteWaitTimesPercent = 0.0;
   __int64         RingCapacity    = 1;
   TGLibDateTime   OldestItem      = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateDatabaseRecordingInfoRing(DatabaseRing, NoVideoRecording, NoAudioRecording, NoRecordingAtAll, VideoSamplesPerSecond, VideoMBPerSecond, AudioSamplesPerSecond, AudioMBPerSecond, WriteWaitTimesPercent, RingCapacity, OldestItem, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   PlcDatabaseRing DatabaseRing;
   bool            NoVideoRecording;
   bool            NoAudioRecording;
   bool            NoRecordingAtAll;
   double          VideoSamplesPerSecond;
   double          VideoMBPerSecond;
   double          AudioSamplesPerSecond;
   double          AudioMBPerSecond;
   double          WriteWaitTimesPercent;
   __int64         RingCapacity;
   TGLibDateTime   OldestItem;
   const double*   RecordingDepth;
   const __int64*  EstimatedRequiredCapacity;

   if (! GscAct_DecodeDatabaseRecordingInfoRing(anAction, DatabaseRing, NoVideoRecording, NoAudioRecording, NoRecordingAtAll, VideoSamplesPerSecond, VideoMBPerSecond, AudioSamplesPerSecond, AudioMBPerSecond, WriteWaitTimesPercent, RingCapacity, OldestItem, RecordingDepth, EstimatedRequiredCapacity))
   {
     // error handling
   }


GSC actions: Database recording info total

Database recording info total
[System actions]

Collaboration diagram for Database recording info total:

Database recording info total.

Database recording info total.

Parameters

Name | Type | Description
NoVideoRecording | bool | no video recording
Video is recording or not.
NoAudioRecording | bool | no audio recording
Audio is recording or not.
NoRecordingAtAll | bool | no recording
Video and/or audio is recording or not.
VideoSamplesPerSecond | double | video samples/s
Video samples per second.
VideoMBPerSecond | double | video samples MB/s
Video MB per second.
AudioSamplesPerSecond | double | audio samples/s
Audio samples per second.
AudioMBPerSecond | double | audio samples MB/s
Audio MB per second.
WriteWaitTimesPercent | double | write wait %
Write waiting times in percent.
TotalCapacity | __int64 | total capacity
Total capacity.
FreeCapacity | __int64 | free capacity
Free capacity.
AllocatedCapacity | __int64 | allocated capacity
Allocated capacity.
OldestItem | TGLibDateTime | oldest item
optional | Time stamp of the oldest item.
RecordingDepth | double | recording depth
optional | Recording depth in hours.
EstimatedRequiredCapacity | __int64 | estimated required capacity
optional | Estimated required capacity.
RequiredCapacityFactor | double | required capacity factor
optional | Required capacity factor.
RequiredCapacityAvailable | bool | required capacity available
optional | Required capacity available.

Example how to create this action:

   bool            NoVideoRecording = false;
   bool            NoAudioRecording = false;
   bool            NoRecordingAtAll = false;
   double          VideoSamplesPerSecond = 0.0;
   double          VideoMBPerSecond = 0.0;
   double          AudioSamplesPerSecond = 0.0;
   double          AudioMBPerSecond = 0.0;
   double          WriteWaitTimesPercent = 0.0;
   __int64         TotalCapacity   = 1;
   __int64         FreeCapacity    = 1;
   __int64         AllocatedCapacity = 1;

   HGscAction anAction;
   anAction = GscAct_CreateDatabaseRecordingInfoTotal(NoVideoRecording, NoAudioRecording, NoRecordingAtAll, VideoSamplesPerSecond, VideoMBPerSecond, AudioSamplesPerSecond, AudioMBPerSecond, WriteWaitTimesPercent, TotalCapacity, FreeCapacity, AllocatedCapacity, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   bool            NoVideoRecording;
   bool            NoAudioRecording;
   bool            NoRecordingAtAll;
   double          VideoSamplesPerSecond;
   double          VideoMBPerSecond;
   double          AudioSamplesPerSecond;
   double          AudioMBPerSecond;
   double          WriteWaitTimesPercent;
   __int64         TotalCapacity;
   __int64         FreeCapacity;
   __int64         AllocatedCapacity;
   const TGLibDateTime* OldestItem;
   const double*   RecordingDepth;
   const __int64*  EstimatedRequiredCapacity;
   const double*   RequiredCapacityFactor;
   const bool*     RequiredCapacityAvailable;

   if (! GscAct_DecodeDatabaseRecordingInfoTotal(anAction, NoVideoRecording, NoAudioRecording, NoRecordingAtAll, VideoSamplesPerSecond, VideoMBPerSecond, AudioSamplesPerSecond, AudioMBPerSecond, WriteWaitTimesPercent, TotalCapacity, FreeCapacity, AllocatedCapacity, OldestItem, RecordingDepth, EstimatedRequiredCapacity, RequiredCapacityFactor, RequiredCapacityAvailable))
   {
     // error handling
   }


GSC actions: Database started

Database started
[System actions]

Collaboration diagram for Database started:

This action will be fired at the database start-up.

This action will be fired at the database start-up.

Parameters

Name | Type | Description
Status | PlcDatabaseStatus | status
Database status message.
TotalSize | __int64 | total size
Database total size.

Example how to create this action:

   PlcDatabaseStatus Status          = dbsEmpty;
   __int64         TotalSize       = 1;

   HGscAction anAction;
   anAction = GscAct_CreateDatabaseStarted(Status, TotalSize);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   PlcDatabaseStatus Status;
   __int64         TotalSize;

   if (! GscAct_DecodeDatabaseStarted(anAction, Status, TotalSize))
   {
     // error handling
   }


GSC actions: Event recording changed

Event recording changed
[System actions]

Collaboration diagram for Event recording changed:

Event recording settings are changed.

Event recording settings are changed.

Parameters

Name | Type | Description
EventID | __int64 | instance ID
Instance ID of the event.
TypeID | TEventTypeID | event type
Type of the event.

Example how to create this action:

   __int64         EventID         = 1;
   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateEventRecordingChanged(EventID, TypeID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         EventID;
   TEventTypeID    TypeID;

   if (! GscAct_DecodeEventRecordingChanged(anAction, EventID, TypeID))
   {
     // error handling
   }


GSC actions: Event started

Event started
[System actions]

Collaboration diagram for Event started:

Event has started.

Event has started.

Parameters

Name | Type | Description
EventID | __int64 | instance ID
Instance ID of the event.
TypeID | TEventTypeID | event type
Type of the event.
ForeignKey | __int64 | foreign key
optional | Optional foreign key used to start the alarm.

Example how to create this action:

   __int64         EventID         = 1;
   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateEventStartedEx(EventID, TypeID, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         EventID;
   TEventTypeID    TypeID;
   const __int64*  ForeignKey;

   if (! GscAct_DecodeEventStartedEx(anAction, EventID, TypeID, ForeignKey))
   {
     // error handling
   }


GSC actions: Event stopped

Event stopped
[System actions]

Collaboration diagram for Event stopped:

Event has stopped.

Event has stopped.

Parameters

Name | Type | Description
EventID | __int64 | instance ID
Instance ID of the event.
TypeID | TEventTypeID | event type
Type of the event.

Example how to create this action:

   __int64         EventID         = 1;
   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateEventStopped(EventID, TypeID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         EventID;
   TEventTypeID    TypeID;

   if (! GscAct_DecodeEventStopped(anAction, EventID, TypeID))
   {
     // error handling
   }


GSC actions: FRC notification

FRC notification
[System actions]

Collaboration diagram for FRC notification:

FRC notification.

FRC notification.

Parameters

Name | Type | Description
Notification | PlcFRCNotification | notification
Notification reason.
Param | __int32 | param
optional | Additional parameter.
Description | widestring | description
optional | Optional notification text.
XMLInfo | string | additional info
optional | Optional additional info (usually as XML string).

Example how to create this action:

   PlcFRCNotification Notification    = frnDataOverwritten;

   HGscAction anAction;
   anAction = GscAct_CreateFRCNotification(Notification, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   PlcFRCNotification Notification;
   const __int32*  Param;
   const wchar_t*  Description;
   const char*     XMLInfo;

   if (! GscAct_DecodeFRCNotification(anAction, Notification, Param, Description, XMLInfo))
   {
     // error handling
   }


GSC actions: GEMOS alarm

GEMOS alarm
[System actions]

Collaboration diagram for GEMOS alarm:

GEMOS alarm notification.

GEMOS alarm notification.

Parameters

Name | Type | Description
GEMOSkey | __int64 | GEMOS key
GEMOS alarm key.
GEMOSint | __int32 | GEMOS int
GEMOS alarm integer parameter.
GEMOSstr | widestring | GEMOS str
GEMOS alarm string parameter.

Example how to create this action:

   __int64         GEMOSkey        = 1;
   __int32         GEMOSint        = 1;
   const wchar_t*  GEMOSstr        = L"GEMOS str";

   HGscAction anAction;
   anAction = GscAct_CreateGEMOSalarm(GEMOSkey, GEMOSint, GEMOSstr);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         GEMOSkey;
   __int32         GEMOSint;
   const wchar_t*  GEMOSstr;

   if (! GscAct_DecodeGEMOSalarm(anAction, GEMOSkey, GEMOSint, GEMOSstr))
   {
     // error handling
   }


GSC actions: IP switch operation

IP switch operation
[System actions]

Collaboration diagram for IP switch operation:

IP switch operation.

IP switch operation.

Parameters

Name | Type | Description
Operation | IPSwitchOps | operation
Operation.
Port | widestring | port no
Port no, IP address, MAC address.
Param | __int32 | parameter
optional | Optional parameter.

Example how to create this action:

   IPSwitchOps     Operation       = ipoPOEOn;
   const wchar_t*  Port            = L"port no";

   HGscAction anAction;
   anAction = GscAct_CreateIPSwitchOperation(Operation, Port, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   IPSwitchOps     Operation;
   const wchar_t*  Port;
   const __int32*  Param;

   if (! GscAct_DecodeIPSwitchOperation(anAction, Operation, Port, Param))
   {
     // error handling
   }


GSC actions: Kill all events

Kill all events
[System actions]

Collaboration diagram for Kill all events:

Kill all active events.

Kill all active events.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateKillAllEvents();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeKillAllEvents(anAction))
   {
     // error handling
   }


GSC actions: Kill event

Kill event
[System actions]

Collaboration diagram for Kill event:

Kill event.

Kill event.

Parameters

Name | Type | Description
TypeID | TEventTypeID | event type
Type of the event.

Example how to create this action:

   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateKillEvent(TypeID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TEventTypeID    TypeID;

   if (! GscAct_DecodeKillEvent(anAction, TypeID))
   {
     // error handling
   }


GSC actions: Kill event by instance

Kill event by instance
[System actions]

Collaboration diagram for Kill event by instance:

Kill event by instance ID.

Kill event by instance ID.

Parameters

Name | Type | Description
EventID | __int64 | instance ID
Instance ID of the event.

Example how to create this action:

   __int64         EventID         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateKillEventByID(EventID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         EventID;

   if (! GscAct_DecodeKillEventByID(anAction, EventID))
   {
     // error handling
   }


GSC actions: Live check

Live check
[System actions]

Collaboration diagram for Live check:

This action will be fired every 10 seconds and is intended for use as live check.

This action will be fired every 10 seconds and is intended for use as live check.

Parameters

Name | Type | Description
Counter | __int64 | counter
This is the number of already fired live check actions.
Date | TGLibDateTime | time stamp
Current server time.

Example how to create this action:

   __int64         Counter         = 1;
   TGLibDateTime   Date            = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateLiveCheck(Counter, Date);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         Counter;
   TGLibDateTime   Date;

   if (! GscAct_DecodeLiveCheck(anAction, Counter, Date))
   {
     // error handling
   }


GSC actions: Redundant power failure

Redundant power failure
[System actions]

Collaboration diagram for Redundant power failure:

This action is notified if a failure of the redundant power supply is detected.

This action is notified if a failure of the redundant power supply is detected.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateRedundantPowerFailure();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeRedundantPowerFailure(anAction))
   {
     // error handling
   }


GSC actions: Redundant power ok

Redundant power ok
[System actions]

Collaboration diagram for Redundant power ok:

This action is notified if a failure of the redundant power supply is removed.

This action is notified if a failure of the redundant power supply is removed.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateRedundantPowerOk();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeRedundantPowerOk(anAction))
   {
     // error handling
   }


GSC actions: SMRP viewer cleared

SMRP viewer cleared
[System actions]

Collaboration diagram for SMRP viewer cleared:

SMRP viewer cleared.

SMRP viewer cleared.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateSMRPViewerCleared();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeSMRPViewerCleared(anAction))
   {
     // error handling
   }


GSC actions: SMRP viewer connected

SMRP viewer connected
[System actions]

Collaboration diagram for SMRP viewer connected:

SMRP viewer connected to the camera.

SMRP viewer connected to the camera.

Parameters

Name | Type | Description
Server | widestring | server
Server name.
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   const wchar_t*  Server          = L"server";
   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateSMRPViewerConnected(Server, Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  Server;
   TMediaChannelID Channel;

   if (! GscAct_DecodeSMRPViewerConnected(anAction, Server, Channel))
   {
     // error handling
   }


GSC actions: SMTP mail

SMTP mail
[System actions]

Collaboration diagram for SMTP mail:

This action will send a user defined email if GSCMail is connected.

This action will send a user defined email if GSCMail is connected

Parameters

Name | Type | Description
Subject | widestring | subject
Mail subject.
To | widestring | to
Mail recipients.
Cc | widestring | cc
Carbon copy recipients.
Body | widestring | body
Mail body.
Channel | TMediaChannelID | channel
optional | Channel.

Example how to create this action:

   const wchar_t*  Subject         = L"subject";
   const wchar_t*  To              = L"to";
   const wchar_t*  Cc              = L"cc";
   const wchar_t*  Body            = L"body";

   HGscAction anAction;
   anAction = GscAct_CreateSMTPMailSend(Subject, To, Cc, Body, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  Subject;
   const wchar_t*  To;
   const wchar_t*  Cc;
   const wchar_t*  Body;
   const TMediaChannelID* Channel;

   if (! GscAct_DecodeSMTPMailSend(anAction, Subject, To, Cc, Body, Channel))
   {
     // error handling
   }


GSC actions: Set clock

Set clock
[System actions]

Collaboration diagram for Set clock:

Set clock.

Set clock.

Parameters

Name | Type | Description
Date | TGLibDateTime | current time
Current time.

Example how to create this action:

   TGLibDateTime   Date            = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateSetClock(Date);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TGLibDateTime   Date;

   if (! GscAct_DecodeSetClock(anAction, Date))
   {
     // error handling
   }


GSC actions: Set watchdog

Set watchdog
[System actions]

Collaboration diagram for Set watchdog:

Set watchdog.

Set watchdog.

Parameters

Name | Type | Description
Timeout | __int32 | timeout
Timeout in seconds, before the watchdog must be retriggered and before the hardware watchdog will set the hardware contact.

Example how to create this action:

   __int32         Timeout         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateSetWatchdog(Timeout);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         Timeout;

   if (! GscAct_DecodeSetWatchdog(anAction, Timeout))
   {
     // error handling
   }


GSC actions: Setup changed

Setup changed
[System actions]

Collaboration diagram for Setup changed:

Setup changed.

Setup changed.

Parameters

Name | Type | Description
User | widestring | user name
Name of the user who modified the setup.
Host | widestring | remote host
Host from where the connection was done.
Date | TGLibDateTime | current time
Current time.
ResourceKind | PlcResourceKind | resource kind
Modified resource kind.
ResourceID | TEventTypeID | resource ID
Modified resource ID.
ChangeKind | PlcResourceChangeKind | change kind
Change kind.
Details | widestring | details
optional | Details of the modification.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   const wchar_t*  User            = L"user name";
   const wchar_t*  Host            = L"remote host";
   TGLibDateTime   Date            = TGLibDateTime::Now();
   PlcResourceKind ResourceKind    = prkNotSpecified;
   TEventTypeID    ResourceID      = {0, L"", 0};
   PlcResourceChangeKind ChangeKind      = rckAdded;

   HGscAction anAction;
   anAction = GscAct_CreateSetupChanged(User, Host, Date, ResourceKind, ResourceID, ChangeKind, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  User;
   const wchar_t*  Host;
   TGLibDateTime   Date;
   PlcResourceKind ResourceKind;
   TEventTypeID    ResourceID;
   PlcResourceChangeKind ChangeKind;
   const wchar_t*  Details;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeSetupChanged(anAction, User, Host, Date, ResourceKind, ResourceID, ChangeKind, Details, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: Setup upload progress

Setup upload progress
[System actions]

Collaboration diagram for Setup upload progress:

Setup upload progress.

Setup upload progress.

Parameters

Name | Type | Description
User1 | widestring | first user
optional | Name of the user who modified the setup.
User2 | widestring | second user
optional | Name of the second user by four eyes authentication.
Host | widestring | remote host
optional | Host from where the connection was done.
Progress | __int32 | progress %
Progress in percent.
Date | TGLibDateTime | current time
Current stage time.

Example how to create this action:

   __int32         Progress        = 1;
   TGLibDateTime   Date            = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateSetupUploadProgress(NULL, NULL, NULL, Progress, Date);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  User1;
   const wchar_t*  User2;
   const wchar_t*  Host;
   __int32         Progress;
   TGLibDateTime   Date;

   if (! GscAct_DecodeSetupUploadProgress(anAction, User1, User2, Host, Progress, Date))
   {
     // error handling
   }


GSC actions: Start event

Start event
[System actions]

Collaboration diagram for Start event:

Start event.

Start event.

Parameters

Name | Type | Description
TypeID | TEventTypeID | event type
Type of the event.
ForeignKey | __int64 | foreign key
optional | Optional foreign key used to store with alarm.

Example how to create this action:

   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateStartEventEx(TypeID, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TEventTypeID    TypeID;
   const __int64*  ForeignKey;

   if (! GscAct_DecodeStartEventEx(anAction, TypeID, ForeignKey))
   {
     // error handling
   }


GSC actions: Stop all events

Stop all events
[System actions]

Collaboration diagram for Stop all events:

Stop all active events.

Stop all active events.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateStopAllEvents();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeStopAllEvents(anAction))
   {
     // error handling
   }


GSC actions: Stop event

Stop event
[System actions]

Collaboration diagram for Stop event:

Stop event.

Stop event.

Parameters

Name | Type | Description
TypeID | TEventTypeID | event type
Type of the event.

Example how to create this action:

   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateStopEvent(TypeID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TEventTypeID    TypeID;

   if (! GscAct_DecodeStopEvent(anAction, TypeID))
   {
     // error handling
   }


GSC actions: Stop event by instance

Stop event by instance
[System actions]

Collaboration diagram for Stop event by instance:

Stop event by instance ID.

Stop event by instance ID.

Parameters

Name | Type | Description
EventID | __int64 | instance ID
Instance ID of the event.

Example how to create this action:

   __int64         EventID         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateStopEventByID(EventID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int64         EventID;

   if (! GscAct_DecodeStopEventByID(anAction, EventID))
   {
     // error handling
   }


GSC actions: System error

System error
[System actions]

Collaboration diagram for System error:

Notify system error.

Notify system error.

Parameters

Name | Type | Description
Source | PlcMessageSource | source subsystem
Source of the message.
Message | PlcMessageCode | message code
Kind of the message.
WindowsError | __int32 | Windows error code
optional | Optional Windows error code.
Description | widestring | description
optional | Optional description of the message.
XMLInfo | string | additional info
optional | Optional additional info (usually as XML string).

Example how to create this action:

   PlcMessageSource Source          = pmsServer;
   PlcMessageCode  Message         = pmcInternalError;

   HGscAction anAction;
   anAction = GscAct_CreateSystemError(Source, Message, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   PlcMessageSource Source;
   PlcMessageCode  Message;
   const __int32*  WindowsError;
   const wchar_t*  Description;
   const char*     XMLInfo;

   if (! GscAct_DecodeSystemError(anAction, Source, Message, WindowsError, Description, XMLInfo))
   {
     // error handling
   }


GSC actions: System info

System info
[System actions]

Collaboration diagram for System info:

Notify system information.

Notify system information.

Parameters

Name | Type | Description
Source | PlcMessageSource | source subsystem
Source of the message.
Message | PlcMessageCode | message code
Kind of the message.
Description | widestring | description
optional | Optional description of the message.
XMLInfo | string | additional info
optional | Optional additional info (usually as XML string).

Example how to create this action:

   PlcMessageSource Source          = pmsServer;
   PlcMessageCode  Message         = pmcInternalError;

   HGscAction anAction;
   anAction = GscAct_CreateSystemInfo(Source, Message, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   PlcMessageSource Source;
   PlcMessageCode  Message;
   const wchar_t*  Description;
   const char*     XMLInfo;

   if (! GscAct_DecodeSystemInfo(anAction, Source, Message, Description, XMLInfo))
   {
     // error handling
   }


GSC actions: System settings changed

System settings changed
[System actions]

Collaboration diagram for System settings changed:

Setup of the system and/or the current time range changed.

Setup of the system and/or the current time range changed.

Parameters

Name | Type | Description
SetupChanged | bool | setup changed
System setup has changed.
User1 | widestring | first user
optional | Name of the user who modified the setup.
User2 | widestring | second user
optional | Name of the second user by four eyes authentication.
Host | widestring | remote host
optional | Host from where the connection was done.
TimeRangeChanged | bool | time range changed
Time range has changed.
TimeRange | TResourceID | current time range
optional | Currently active time range.
LicenceChanged | bool | licence changed
Licence has changed.
Date | TGLibDateTime | change time
Time of the system settings changed.

Example how to create this action:

   bool            SetupChanged    = false;
   bool            TimeRangeChanged = false;
   bool            LicenceChanged  = false;
   TGLibDateTime   Date            = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateSystemSettingsChanged(SetupChanged, NULL, NULL, NULL, TimeRangeChanged, NULL, LicenceChanged, Date);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   bool            SetupChanged;
   const wchar_t*  User1;
   const wchar_t*  User2;
   const wchar_t*  Host;
   bool            TimeRangeChanged;
   const TResourceID* TimeRange;
   bool            LicenceChanged;
   TGLibDateTime   Date;

   if (! GscAct_DecodeSystemSettingsChanged(anAction, SetupChanged, User1, User2, Host, TimeRangeChanged, TimeRange, LicenceChanged, Date))
   {
     // error handling
   }


GSC actions: System started

System started
[System actions]

Collaboration diagram for System started:

This action will be fired only once at the system start-up.

This action will be fired only once at the system start-up.

Parameters

Name | Type | Description
Date | TGLibDateTime | start time
Time of the system start-up.

Example how to create this action:

   TGLibDateTime   Date            = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateSystemStarted(Date);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TGLibDateTime   Date;

   if (! GscAct_DecodeSystemStarted(anAction, Date))
   {
     // error handling
   }


GSC actions: System terminating

System terminating
[System actions]

Collaboration diagram for System terminating:

This action will be fired when the system is going to be shut down.

This action will be fired when the system is going to be shut down.

Parameters

Name | Type | Description
Date | TGLibDateTime | stop time
Time of the system shutdown.
WindowsShutdown | bool | Windows shutdown
Indicates whether the system shutdown is done due to the windows shutdown.

Example how to create this action:

   TGLibDateTime   Date            = TGLibDateTime::Now();
   bool            WindowsShutdown = false;

   HGscAction anAction;
   anAction = GscAct_CreateSystemTerminating(Date, WindowsShutdown);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TGLibDateTime   Date;
   bool            WindowsShutdown;

   if (! GscAct_DecodeSystemTerminating(anAction, Date, WindowsShutdown))
   {
     // error handling
   }


GSC actions: System warning

System warning
[System actions]

Collaboration diagram for System warning:

Notify system warning.

Notify system warning.

Parameters

Name | Type | Description
Source | PlcMessageSource | source subsystem
Source of the message.
Message | PlcMessageCode | message code
Kind of the message.
WindowsError | __int32 | Windows error code
optional | Optional Windows error code.
Description | widestring | description
optional | Optional description of the message.
XMLInfo | string | additional info
optional | Optional additional info (usually as XML string).

Example how to create this action:

   PlcMessageSource Source          = pmsServer;
   PlcMessageCode  Message         = pmcInternalError;

   HGscAction anAction;
   anAction = GscAct_CreateSystemWarning(Source, Message, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   PlcMessageSource Source;
   PlcMessageCode  Message;
   const __int32*  WindowsError;
   const wchar_t*  Description;
   const char*     XMLInfo;

   if (! GscAct_DecodeSystemWarning(anAction, Source, Message, WindowsError, Description, XMLInfo))
   {
     // error handling
   }


GSC actions: Transfer binary buffer

Transfer binary buffer
[System actions]

Collaboration diagram for Transfer binary buffer:

Transfer binary buffer.

Transfer binary buffer.

Parameters

Name | Type | Description
InternalHandle | GUID | internal handle
Internal handle.
Parameter | widestring | parameter
Parameter.

Example how to create this action:

   GUID            InternalHandle  = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   const wchar_t*  Parameter       = L"parameter";

   HGscAction anAction;
   anAction = GscAct_CreateTransferBinaryBuffer(InternalHandle, Parameter);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   GUID            InternalHandle;
   const wchar_t*  Parameter;

   if (! GscAct_DecodeTransferBinaryBuffer(anAction, InternalHandle, Parameter))
   {
     // error handling
   }


GSC actions: Transfer binary channel buffer

Transfer binary channel buffer
[System actions]

Collaboration diagram for Transfer binary channel buffer:

Transfer binary channel buffer.

Transfer binary channel buffer.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
InternalHandle | GUID | internal handle
Internal handle.
Parameter | widestring | parameter
Parameter.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   GUID            InternalHandle  = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   const wchar_t*  Parameter       = L"parameter";

   HGscAction anAction;
   anAction = GscAct_CreateTransferBinaryChannelBuffer(Channel, InternalHandle, Parameter);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   GUID            InternalHandle;
   const wchar_t*  Parameter;

   if (! GscAct_DecodeTransferBinaryChannelBuffer(anAction, Channel, InternalHandle, Parameter))
   {
     // error handling
   }


GSC actions: User login

User login
[System actions]

Collaboration diagram for User login:

This action will be fired when the user has connected to the system.

This action will be fired when the user has connected to the system.

Parameters

Name | Type | Description
User1 | widestring | first user
Name of the user connected to the system.
User2 | widestring | second user
optional | Name of the second user by four eyes authentication.
Host | widestring | remote host
Host from where the connection is done.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   const wchar_t*  User1           = L"first user";
   const wchar_t*  Host            = L"remote host";

   HGscAction anAction;
   anAction = GscAct_CreateUserLogin(User1, NULL, Host, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  User1;
   const wchar_t*  User2;
   const wchar_t*  Host;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeUserLogin(anAction, User1, User2, Host, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: User login failed

User login failed
[System actions]

Collaboration diagram for User login failed:

This action will be fired when the user has tried to connect to the system but was rejected.

This action will be fired when the user has tried to connect to the system but was rejected.

Parameters

Name | Type | Description
User1 | widestring | first user
Name of the user who tried to connect to the system.
User2 | widestring | second user
optional | Name of the second user by four eyes authentication.
Host | widestring | remote host
Host from where the connection is done.
RejectReason | UserLoginFailureCode | reject reason
Reason of the rejection.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   const wchar_t*  User1           = L"first user";
   const wchar_t*  Host            = L"remote host";
   UserLoginFailureCode RejectReason    = ulfUser1NotFound;

   HGscAction anAction;
   anAction = GscAct_CreateUserLoginFailed(User1, NULL, Host, RejectReason, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  User1;
   const wchar_t*  User2;
   const wchar_t*  Host;
   UserLoginFailureCode RejectReason;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeUserLoginFailed(anAction, User1, User2, Host, RejectReason, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: User logout

User logout
[System actions]

Collaboration diagram for User logout:

This action will be fired when the user has disconnected from the system.

This action will be fired when the user has disconnected from the system.

Parameters

Name | Type | Description
User1 | widestring | first user
Name of the user disconnected from the system.
User2 | widestring | second user
optional | Name of the second user by four eyes authentication.
Host | widestring | remote host
Host from where the connection was done.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   const wchar_t*  User1           = L"first user";
   const wchar_t*  Host            = L"remote host";

   HGscAction anAction;
   anAction = GscAct_CreateUserLogout(User1, NULL, Host, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  User1;
   const wchar_t*  User2;
   const wchar_t*  Host;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeUserLogout(anAction, User1, User2, Host, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: Video control

Modules

Video control
[Actions]

Collaboration diagram for Video control:

Detailed Description

All actions to control the video streams, also all notifications about the state change of the video streams.

Modules

Activate external process

Activate external process.

CPA measurement

CPA measurement.

Change AD parameter set

This action changes the current AD parameter set of the video channel.

Change CPA parameter set

This action changes the current CPA parameter set of the video channel.

Change GTectVMX parameter set

This action changes the current GTectVMX parameter set of the video channel.

Change OBTRACK parameter set

This action changes the current OBTRACK parameter set of the video channel.

Change VMD parameter set

This action changes the current VMD parameter set of the video channel.

Change camera profile

This action changes the current camera profile of the hardware module.

Channel error

Notify channel error.

Channel info

Notify channel information.

Channel live check

This action notifies that the channel is alive.

Channel warning

Notify channel warning.

Enable client VCA

Enable client VCA.

G-Tect analytics live check

This action will be fired periodically to ensure that analytics client is still running.

G-Tect scene alarm

This action will be fired when G-Tect Video content analysis detects a scene alarm.

G-Tect scene alarm finished

This action will be fired when G-Tect Video content analysis scene alarm is finished.

G-Tect/Dual sensor alarm

This action will be fired when G-Tect/Dual sensor detects an alarm.

G-Tect/Dual sensor alarm finished

This action will be fired when the alarm is finished.

G-Tect/VMX alarm

This action will be fired when G-Tect/VMX Video content analysis detects an alarm.

G-Tect/VMX alarm finished

This action will be fired when the alarm is finished.

IAS settings changed

IAS settings changed.

IP camera failover notification

IP camera failover notification.

IP camera failover restore

IP camera failover restore.

IP camera raw command

This action sends a special command to the IP camera.

Make CPA reference image

Make CPA reference image.

Media channel setup

Media channel setup info.

NPR raw data

NPR raw data.

NPR recognition

NPR recognition.

OBTRACK channel counter

OBTRACK channel counter.

OBTRACK channel counter threshold

OBTRACK channel counter threshold.

OBTRACK channel set counter

OBTRACK channel set counter.

OBTRACK frame raw data

OBTRACK frame raw data.

OBTRACK group counter

OBTRACK group counter.

OBTRACK group counter threshold

OBTRACK group counter threshold.

OBTRACK group set counter

OBTRACK group set counter.

OBTRACK object raw data

OBTRACK object raw data.

OBTRACK tunnel alarm

OBTRACK tunnel alarm notification.

Sensor alarm finished

This action will be fired when the alarm is finished.

Sensor inhibit alarm finished

This action will be fired when the inhibit alarm is finished.

Sensor inhibit video alarm

This action will be fired when the motion in inhibit area is detected.

Sensor video alarm

This action will be fired when video alarm is detected.

Set system time

Set system time.

Set test picture mode

Enable or disable test picture generator.

VCA set armed

Send this action to notify VCA to be armed or disarmed.

VCA status answer

This action will be sent in response to VCA status request.

VCA status request

Send this action to request status of VCA.

Video contrast detected

This action will be fired when the contrast is detected in the video signal.

Video contrast failed

This action will be fired when the contrast is lost in the video signal.

Video set image brightness

Video set image brightness.

Video set image contrast

Video set image contrast.

Video set image saturation

Video set image saturation.

Video source has changed

This action indicates the changes on the video input source.

Video sync detected

This action will be fired when the sync is detected in the video signal.

Video sync failed

This action will be fired when the sync is lost in the video signal.


GSC actions: Activate external process

Activate external process
[Video control]

Collaboration diagram for Activate external process:

Activate external process.

Activate external process.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ExternalSystem | VideoSensorKind | external system
External system to activate.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   VideoSensorKind ExternalSystem  = vskAD;

   HGscAction anAction;
   anAction = GscAct_CreateActivateExternalProcess(Channel, TimeStamp, ExternalSystem);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TGLibDateTime   TimeStamp;
   VideoSensorKind ExternalSystem;

   if (! GscAct_DecodeActivateExternalProcess(anAction, Channel, TimeStamp, ExternalSystem))
   {
     // error handling
   }


GSC actions: CPA measurement

CPA measurement
[Video control]

Collaboration diagram for CPA measurement:

CPA measurement.

CPA measurement.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
Correlation | __int32 | correlation
Correlation factor.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   __int32         Correlation     = 1;

   HGscAction anAction;
   anAction = GscAct_CreateCPAMeasurement(Channel, Correlation);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   __int32         Correlation;

   if (! GscAct_DecodeCPAMeasurement(anAction, Channel, Correlation))
   {
     // error handling
   }


GSC actions: Change AD parameter set

Change AD parameter set
[Video control]

Collaboration diagram for Change AD parameter set:

This action changes the current AD parameter set of the video channel.

This action changes the current AD parameter set of the video channel.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
ParameterSet | TResourceID | AD parameter set
The name of the new AD parameter set.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TResourceID     ParameterSet    = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateChangeADParameterSet(Channel, ParameterSet);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TResourceID     ParameterSet;

   if (! GscAct_DecodeChangeADParameterSet(anAction, Channel, ParameterSet))
   {
     // error handling
   }


GSC actions: Change CPA parameter set

Change CPA parameter set
[Video control]

Collaboration diagram for Change CPA parameter set:

This action changes the current CPA parameter set of the video channel.

This action changes the current CPA parameter set of the video channel.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
ParameterSet | TResourceID | CPA parameter set
The name of the new CPA parameter set.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TResourceID     ParameterSet    = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateChangeCPAParameterSet(Channel, ParameterSet);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TResourceID     ParameterSet;

   if (! GscAct_DecodeChangeCPAParameterSet(anAction, Channel, ParameterSet))
   {
     // error handling
   }


GSC actions: Change GTectVMX parameter set

Change GTectVMX parameter set
[Video control]

Collaboration diagram for Change GTectVMX parameter set:

This action changes the current GTectVMX parameter set of the video channel.

This action changes the current GTectVMX parameter set of the video channel.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
ParameterSet | TResourceID | GTect parameter set
The name of the new GTect parameter set.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TResourceID     ParameterSet    = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateChangeGTectParameterSet(Channel, ParameterSet);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TResourceID     ParameterSet;

   if (! GscAct_DecodeChangeGTectParameterSet(anAction, Channel, ParameterSet))
   {
     // error handling
   }


GSC actions: Change OBTRACK parameter set

Change OBTRACK parameter set
[Video control]

Collaboration diagram for Change OBTRACK parameter set:

This action changes the current OBTRACK parameter set of the video channel.

This action changes the current OBTRACK parameter set of the video channel.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
ParameterSet | TResourceID | OBTRACK parameter set
The name of the new OBTRACK parameter set.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TResourceID     ParameterSet    = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateChangeObtrackParameterSet(Channel, ParameterSet);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TResourceID     ParameterSet;

   if (! GscAct_DecodeChangeObtrackParameterSet(anAction, Channel, ParameterSet))
   {
     // error handling
   }


GSC actions: Change VMD parameter set

Change VMD parameter set
[Video control]

Collaboration diagram for Change VMD parameter set:

This action changes the current VMD parameter set of the video channel.

This action changes the current VMD parameter set of the video channel.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
ParameterSet | TResourceID | VMD parameter set
The name of the new VMD parameter set.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TResourceID     ParameterSet    = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateChangeVMDParameterSet(Channel, ParameterSet);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TResourceID     ParameterSet;

   if (! GscAct_DecodeChangeVMDParameterSet(anAction, Channel, ParameterSet))
   {
     // error handling
   }


GSC actions: Change camera profile

Change camera profile
[Video control]

Collaboration diagram for Change camera profile:

This action changes the current camera profile of the hardware module.

This action changes the current camera profile of the hardware module.

Parameters

Name | Type | Description
HardwareModule | TResourceID | hardware
Hardware module.
CameraProfile | TResourceID | profile
The name of the camera profile.

Example how to create this action:

   TResourceID     HardwareModule  = {0, L"", 0};
   TResourceID     CameraProfile   = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateChangeCameraProfile(HardwareModule, CameraProfile);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TResourceID     HardwareModule;
   TResourceID     CameraProfile;

   if (! GscAct_DecodeChangeCameraProfile(anAction, HardwareModule, CameraProfile))
   {
     // error handling
   }


GSC actions: Channel error

Channel error
[Video control]

Collaboration diagram for Channel error:

Notify channel error.

Notify channel error.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
optional | Sensor type.
Source | PlcMessageSource | source subsystem
Source of the message.
Message | PlcMessageCode | message code
Kind of the message.
WindowsError | __int32 | Windows error code
optional | Optional Windows error code.
Description | widestring | description
optional | Optional description of the message.
XMLInfo | string | additional info
optional | Optional additional info (usually as XML string).

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   PlcMessageSource Source          = pmsServer;
   PlcMessageCode  Message         = pmcInternalError;

   HGscAction anAction;
   anAction = GscAct_CreateChannelError(Channel, NULL, Source, Message, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const VideoSensorKind* SensorType;
   PlcMessageSource Source;
   PlcMessageCode  Message;
   const __int32*  WindowsError;
   const wchar_t*  Description;
   const char*     XMLInfo;

   if (! GscAct_DecodeChannelError(anAction, Channel, SensorType, Source, Message, WindowsError, Description, XMLInfo))
   {
     // error handling
   }


GSC actions: Channel info

Channel info
[Video control]

Collaboration diagram for Channel info:

Notify channel information.

Notify channel information.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
optional | Sensor type.
Source | PlcMessageSource | source subsystem
Source of the message.
Message | PlcMessageCode | message code
Kind of the message.
Description | widestring | description
optional | Optional description of the message.
XMLInfo | string | additional info
optional | Optional additional info (usually as XML string).

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   PlcMessageSource Source          = pmsServer;
   PlcMessageCode  Message         = pmcInternalError;

   HGscAction anAction;
   anAction = GscAct_CreateChannelInfo(Channel, NULL, Source, Message, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const VideoSensorKind* SensorType;
   PlcMessageSource Source;
   PlcMessageCode  Message;
   const wchar_t*  Description;
   const char*     XMLInfo;

   if (! GscAct_DecodeChannelInfo(anAction, Channel, SensorType, Source, Message, Description, XMLInfo))
   {
     // error handling
   }


GSC actions: Channel live check

Channel live check
[Video control]

Collaboration diagram for Channel live check:

This action notifies that the channel is alive.

This action notifies that the channel is alive.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.
TimeStamp | TGLibDateTime | time stamp
Time stamp.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateChannelLiveCheck(Channel, SensorType, TimeStamp);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   TGLibDateTime   TimeStamp;

   if (! GscAct_DecodeChannelLiveCheck(anAction, Channel, SensorType, TimeStamp))
   {
     // error handling
   }


GSC actions: Channel warning

Channel warning
[Video control]

Collaboration diagram for Channel warning:

Notify channel warning.

Notify channel warning.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
optional | Sensor type.
Source | PlcMessageSource | source subsystem
Source of the message.
Message | PlcMessageCode | message code
Kind of the message.
WindowsError | __int32 | Windows error code
optional | Optional Windows error code.
Description | widestring | description
optional | Optional description of the message.
XMLInfo | string | additional info
optional | Optional additional info (usually as XML string).

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   PlcMessageSource Source          = pmsServer;
   PlcMessageCode  Message         = pmcInternalError;

   HGscAction anAction;
   anAction = GscAct_CreateChannelWarning(Channel, NULL, Source, Message, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const VideoSensorKind* SensorType;
   PlcMessageSource Source;
   PlcMessageCode  Message;
   const __int32*  WindowsError;
   const wchar_t*  Description;
   const char*     XMLInfo;

   if (! GscAct_DecodeChannelWarning(anAction, Channel, SensorType, Source, Message, WindowsError, Description, XMLInfo))
   {
     // error handling
   }


GSC actions: Enable client VCA

Enable client VCA
[Video control]

Collaboration diagram for Enable client VCA:

Enable client VCA.

Enable client VCA

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
ClientVCAType | GTectClientVCAType | VCA Type
VCA Type
Enabled | bool | enabled
Enabled

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   GTectClientVCAType ClientVCAType   = gvtClientPrivacyMasking;
   bool            Enabled         = false;

   HGscAction anAction;
   anAction = GscAct_CreateSetClientVCA(Channel, ClientVCAType, Enabled);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   GTectClientVCAType ClientVCAType;
   bool            Enabled;

   if (! GscAct_DecodeSetClientVCA(anAction, Channel, ClientVCAType, Enabled))
   {
     // error handling
   }


GSC actions: G-Tect analytics live check

G-Tect analytics live check
[Video control]

Collaboration diagram for G-Tect analytics live check:

This action will be fired periodically to ensure that analytics client is still running.

This action will be fired periodically to ensure that analytics client is still running.

Example how to create this action:

   HGscAction anAction;
   anAction = GscAct_CreateGTectAnalyticsLiveCheck();

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   if (! GscAct_DecodeGTectAnalyticsLiveCheck(anAction))
   {
     // error handling
   }


GSC actions: G-Tect scene alarm

G-Tect scene alarm
[Video control]

Collaboration diagram for G-Tect scene alarm:

This action will be fired when G-Tect Video content analysis detects a scene alarm.

This action will be fired when G-Tect Video content analysis detects a scene alarm.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
AlarmReason | GTectSceneAlarmReason | alarm reason
Alarm reason.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   GTectSceneAlarmReason AlarmReason     = garViewFieldObservation;

   HGscAction anAction;
   anAction = GscAct_CreateGTectSceneAlarm(Channel, AlarmReason);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   GTectSceneAlarmReason AlarmReason;

   if (! GscAct_DecodeGTectSceneAlarm(anAction, Channel, AlarmReason))
   {
     // error handling
   }


GSC actions: G-Tect scene alarm finished

G-Tect scene alarm finished
[Video control]

Collaboration diagram for G-Tect scene alarm finished:

This action will be fired when G-Tect Video content analysis scene alarm is finished.

This action will be fired when G-Tect Video content analysis scene alarm is finished.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
AlarmReason | GTectSceneAlarmReason | alarm reason
Alarm reason.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   GTectSceneAlarmReason AlarmReason     = garViewFieldObservation;

   HGscAction anAction;
   anAction = GscAct_CreateGTectSceneAlarmFinished(Channel, AlarmReason);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   GTectSceneAlarmReason AlarmReason;

   if (! GscAct_DecodeGTectSceneAlarmFinished(anAction, Channel, AlarmReason))
   {
     // error handling
   }


GSC actions: G-Tect/Dual sensor alarm

G-Tect/Dual sensor alarm
[Video control]

Collaboration diagram for G-Tect/Dual sensor alarm:

This action will be fired when G-Tect/Dual sensor detects an alarm.

This action will be fired when G-Tect/Dual sensor detects an alarm.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SterileZoneNumber | __int32 | sterile zone number
optional | Sterile Zone Number
VirtualFenceNumber | __int32 | virtual fence number
optional | Virtual Fence Number.
VMDGroup | VMDGroup | VMD alarm group
optional | VMD alarm group.
VMDZone | __int32 | VMD zone
optional | VMD zone nr.
VMDCycle | VMDCycle | VMD cycle
optional | VMD measure cycle.
AlarmArea | TPlcRect | alarm area
optional | Alarm area.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateGTectDualSensorAlarm(Channel, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const __int32*  SterileZoneNumber;
   const __int32*  VirtualFenceNumber;
   const VMDGroup* VMDGroup;
   const __int32*  VMDZone;
   const VMDCycle* VMDCycle;
   const TPlcRect* AlarmArea;

   if (! GscAct_DecodeGTectDualSensorAlarm(anAction, Channel, SterileZoneNumber, VirtualFenceNumber, VMDGroup, VMDZone, VMDCycle, AlarmArea))
   {
     // error handling
   }


GSC actions: G-Tect/Dual sensor alarm finished

G-Tect/Dual sensor alarm finished
[Video control]

Collaboration diagram for G-Tect/Dual sensor alarm finished:

This action will be fired when the alarm is finished.

This action will be fired when the alarm is finished.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateGTectDualSensorAlarmFinished(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeGTectDualSensorAlarmFinished(anAction, Channel))
   {
     // error handling
   }


GSC actions: G-Tect/VMX alarm

G-Tect/VMX alarm
[Video control]

Collaboration diagram for G-Tect/VMX alarm:

This action will be fired when G-Tect/VMX Video content analysis detects an alarm.

This action will be fired when G-Tect/VMX Video content analysis detects an alarm.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SterileZoneNumber | __int32 | sterile zone number
optional | Sterile Zone Number
VirtualFenceNumber | __int32 | virtual fence number
optional | Virtual Fence Number.
AlarmGroup | __int32 | group zones or fences
optional | Used to group different Zones or fences to the same level.
TrackID | __int32 | internal track ID
optional | Internal Track ID.
AlarmArea | TPlcRect | alarm area
optional | Alarm area.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateGTectVMXAlarm(Channel, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   const __int32*  SterileZoneNumber;
   const __int32*  VirtualFenceNumber;
   const __int32*  AlarmGroup;
   const __int32*  TrackID;
   const TPlcRect* AlarmArea;

   if (! GscAct_DecodeGTectVMXAlarm(anAction, Channel, SterileZoneNumber, VirtualFenceNumber, AlarmGroup, TrackID, AlarmArea))
   {
     // error handling
   }


GSC actions: G-Tect/VMX alarm finished

G-Tect/VMX alarm finished
[Video control]

Collaboration diagram for G-Tect/VMX alarm finished:

This action will be fired when the alarm is finished.

This action will be fired when the alarm is finished.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateGTectVMXAlarmFinished(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeGTectVMXAlarmFinished(anAction, Channel))
   {
     // error handling
   }


GSC actions: IAS settings changed

IAS settings changed
[Video control]

Collaboration diagram for IAS settings changed:

IAS settings changed.

IAS settings changed.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;

   HGscAction anAction;
   anAction = GscAct_CreateIASSettingsChanged(Channel, SensorType);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;

   if (! GscAct_DecodeIASSettingsChanged(anAction, Channel, SensorType))
   {
     // error handling
   }


GSC actions: IP camera failover notification

IP camera failover notification
[Video control]

Collaboration diagram for IP camera failover notification:

IP camera failover notification.

IP camera failover notification.

Parameters

Name | Type | Description
PrimaryServer | widestring | primary server
The name of the primary server.
SecondaryServer | widestring | secondary server
The name of the secondary server.
PrimaryChannel | TMediaChannelID | primary channel
Primary channel.
SecondaryChannel | TMediaChannelID | secondary channel
Secondary channel.
CameraParameters | widestring | camera parameters
optional | Optional camera parameters.

Example how to create this action:

   const wchar_t*  PrimaryServer   = L"primary server";
   const wchar_t*  SecondaryServer = L"secondary server";
   TMediaChannelID PrimaryChannel  = {0, L"", 0};
   TMediaChannelID SecondaryChannel = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateIPCamFailoverNotification(PrimaryServer, SecondaryServer, PrimaryChannel, SecondaryChannel, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  PrimaryServer;
   const wchar_t*  SecondaryServer;
   TMediaChannelID PrimaryChannel;
   TMediaChannelID SecondaryChannel;
   const wchar_t*  CameraParameters;

   if (! GscAct_DecodeIPCamFailoverNotification(anAction, PrimaryServer, SecondaryServer, PrimaryChannel, SecondaryChannel, CameraParameters))
   {
     // error handling
   }


GSC actions: IP camera failover restore

IP camera failover restore
[Video control]

Collaboration diagram for IP camera failover restore:

IP camera failover restore.

IP camera failover restore.

Parameters

Name | Type | Description
PrimaryServer | widestring | primary server
The name of the primary server.
SecondaryServer | widestring | secondary server
The name of the secondary server.
PrimaryChannel | TMediaChannelID | primary channel
Primary channel.
SecondaryChannel | TMediaChannelID | secondary channel
Secondary channel.
CameraParameters | widestring | camera parameters
optional | Optional camera parameters.

Example how to create this action:

   const wchar_t*  PrimaryServer   = L"primary server";
   const wchar_t*  SecondaryServer = L"secondary server";
   TMediaChannelID PrimaryChannel  = {0, L"", 0};
   TMediaChannelID SecondaryChannel = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateIPCamFailoverRestore(PrimaryServer, SecondaryServer, PrimaryChannel, SecondaryChannel, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  PrimaryServer;
   const wchar_t*  SecondaryServer;
   TMediaChannelID PrimaryChannel;
   TMediaChannelID SecondaryChannel;
   const wchar_t*  CameraParameters;

   if (! GscAct_DecodeIPCamFailoverRestore(anAction, PrimaryServer, SecondaryServer, PrimaryChannel, SecondaryChannel, CameraParameters))
   {
     // error handling
   }


GSC actions: IP camera raw command

IP camera raw command
[Video control]

Collaboration diagram for IP camera raw command:

This action sends a special command to the IP camera.

This action sends a special command to the IP camera.

Parameters

Name | Type | Description
URL | widestring | url
Complete command URL (like http://192.168.0.165:80/set?daynight=night).
User | widestring | user
optional | User name to authenticate by the camera (optional).
Password | widestring | password
optional | Password to authenticate by the camera (optional).
POST | widestring | post
optional | POST parameters (optional, separate lines with \r\n).

Example how to create this action:

   const wchar_t*  URL             = L"url";

   HGscAction anAction;
   anAction = GscAct_CreateIPCameraRawCommand(URL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  URL;
   const wchar_t*  User;
   const wchar_t*  Password;
   const wchar_t*  POST;

   if (! GscAct_DecodeIPCameraRawCommand(anAction, URL, User, Password, POST))
   {
     // error handling
   }


GSC actions: Make CPA reference image

Make CPA reference image
[Video control]

Collaboration diagram for Make CPA reference image:

Make CPA reference image.

Make CPA reference image.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateMakeCPAReferenceImage(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeMakeCPAReferenceImage(anAction, Channel))
   {
     // error handling
   }


GSC actions: Media channel setup

Media channel setup
[Video control]

Collaboration diagram for Media channel setup:

Media channel setup info.

Media channel setup info.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Parameter | widestring | parameter
Parameter.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  Parameter       = L"parameter";

   HGscAction anAction;
   anAction = GscAct_CreateMediaChannelSetupInfo(Channel, TimeStamp, Parameter);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TGLibDateTime   TimeStamp;
   const wchar_t*  Parameter;

   if (! GscAct_DecodeMediaChannelSetupInfo(anAction, Channel, TimeStamp, Parameter))
   {
     // error handling
   }


GSC actions: NPR raw data

NPR raw data
[Video control]

Collaboration diagram for NPR raw data:

NPR raw data.

NPR raw data.

Parameters

Name | Type | Description
PlateNo | widestring | plate no.
Recognized plate no.
Country | widestring | country
Country.
Channel | TMediaChannelID | channel
Channel.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ZoneRect | TPlcRect | zone rect
Zone rectangle.
Weight | __int32 | weight
Weight of recognition.
ZoneState | __int32 | zone state
Zone state.
ZonePlace | __int32 | zone status
Zone status.
Speed | __int32 | speed
Speed in km/h
Direction | __int32 | direction
Direction of the motion.
ZoneIndex | __int32 | zone index
Zone index.
CurBest | bool | best
Current recognition is best.
PlateWidth | __int32 | plate width
Plate width.
PlateHeight | __int32 | plate height
Plate height.
PlateAngle | __int32 | plate angle
Plate angle.
SymHeight | __int32 | symbol height
Symbol height.
Type | widestring | type
Number type.

Example how to create this action:

   const wchar_t*  PlateNo         = L"plate no.";
   const wchar_t*  Country         = L"country";
   TMediaChannelID Channel         = {0, L"", 0};
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   TPlcRect        ZoneRect        = {0, 0, 0, 0};
   __int32         Weight          = 1;
   __int32         ZoneState       = 1;
   __int32         ZonePlace       = 1;
   __int32         Speed           = 1;
   __int32         Direction       = 1;
   __int32         ZoneIndex       = 1;
   bool            CurBest         = false;
   __int32         PlateWidth      = 1;
   __int32         PlateHeight     = 1;
   __int32         PlateAngle      = 1;
   __int32         SymHeight       = 1;
   const wchar_t*  Type            = L"type";

   HGscAction anAction;
   anAction = GscAct_CreateNPRRawData(PlateNo, Country, Channel, TimeStamp, ZoneRect, Weight, ZoneState, ZonePlace, Speed, Direction, ZoneIndex, CurBest, PlateWidth, PlateHeight, PlateAngle, SymHeight, Type);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  PlateNo;
   const wchar_t*  Country;
   TMediaChannelID Channel;
   TGLibDateTime   TimeStamp;
   TPlcRect        ZoneRect;
   __int32         Weight;
   __int32         ZoneState;
   __int32         ZonePlace;
   __int32         Speed;
   __int32         Direction;
   __int32         ZoneIndex;
   bool            CurBest;
   __int32         PlateWidth;
   __int32         PlateHeight;
   __int32         PlateAngle;
   __int32         SymHeight;
   const wchar_t*  Type;

   if (! GscAct_DecodeNPRRawData(anAction, PlateNo, Country, Channel, TimeStamp, ZoneRect, Weight, ZoneState, ZonePlace, Speed, Direction, ZoneIndex, CurBest, PlateWidth, PlateHeight, PlateAngle, SymHeight, Type))
   {
     // error handling
   }


GSC actions: NPR recognition

NPR recognition
[Video control]

Collaboration diagram for NPR recognition:

NPR recognition.

NPR recognition.

Parameters

Name | Type | Description
PlateNo | widestring | plate no.
Recognized plate no.
Country | widestring | country
Country.
Channel | TMediaChannelID | channel
Channel.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ZoneRect | TPlcRect | zone rect
Zone rectangle.
Restriction | PlcNPRRestriction | restriction
Restriction of recognized number.
Category | widestring | category
Category of recognized number.
Speed | __int32 | speed
Speed in km/h
Direction | __int32 | direction
Direction of the motion.
ZoneIndex | __int32 | zone index
Zone index.
Type | widestring | type
Number type.
Weight | __int32 | weight
Weight of recognition.

Example how to create this action:

   const wchar_t*  PlateNo         = L"plate no.";
   const wchar_t*  Country         = L"country";
   TMediaChannelID Channel         = {0, L"", 0};
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   TPlcRect        ZoneRect        = {0, 0, 0, 0};
   PlcNPRRestriction Restriction     = nrrUnspecified;
   const wchar_t*  Category        = L"category";
   __int32         Speed           = 1;
   __int32         Direction       = 1;
   __int32         ZoneIndex       = 1;
   const wchar_t*  Type            = L"type";
   __int32         Weight          = 1;

   HGscAction anAction;
   anAction = GscAct_CreateNPRRecognition(PlateNo, Country, Channel, TimeStamp, ZoneRect, Restriction, Category, Speed, Direction, ZoneIndex, Type, Weight);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  PlateNo;
   const wchar_t*  Country;
   TMediaChannelID Channel;
   TGLibDateTime   TimeStamp;
   TPlcRect        ZoneRect;
   PlcNPRRestriction Restriction;
   const wchar_t*  Category;
   __int32         Speed;
   __int32         Direction;
   __int32         ZoneIndex;
   const wchar_t*  Type;
   __int32         Weight;

   if (! GscAct_DecodeNPRRecognition(anAction, PlateNo, Country, Channel, TimeStamp, ZoneRect, Restriction, Category, Speed, Direction, ZoneIndex, Type, Weight))
   {
     // error handling
   }


GSC actions: OBTRACK channel counter

OBTRACK channel counter
[Video control]

Collaboration diagram for OBTRACK channel counter:

OBTRACK channel counter.

OBTRACK channel counter.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
CounterType | PlcObtrackCounterType | counter type
Counter type.
CounterValue | __int64 | counter value
Counter value.
ObjectDirection | __int32 | object direction
Object direction.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ResetTimeStamp | TGLibDateTime | reset time stamp
optional | Reset time stamp.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   PlcObtrackCounterType CounterType     = octIncoming;
   __int64         CounterValue    = 1;
   __int32         ObjectDirection = 1;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateObtrackChannelCounter(Channel, CounterType, CounterValue, ObjectDirection, TimeStamp, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   PlcObtrackCounterType CounterType;
   __int64         CounterValue;
   __int32         ObjectDirection;
   TGLibDateTime   TimeStamp;
   const TGLibDateTime* ResetTimeStamp;

   if (! GscAct_DecodeObtrackChannelCounter(anAction, Channel, CounterType, CounterValue, ObjectDirection, TimeStamp, ResetTimeStamp))
   {
     // error handling
   }


GSC actions: OBTRACK channel counter threshold

OBTRACK channel counter threshold
[Video control]

Collaboration diagram for OBTRACK channel counter threshold:

OBTRACK channel counter threshold.

OBTRACK channel counter threshold.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
CounterType | PlcObtrackCounterType | counter type
Counter type.
CounterValue | __int64 | counter value
Counter value.
ExceedingDirection | PlcObtrackExceedingDirection | exceeding direction
Exceeding direction.
TimeStamp | TGLibDateTime | time stamp
Time stamp.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   PlcObtrackCounterType CounterType     = octIncoming;
   __int64         CounterValue    = 1;
   PlcObtrackExceedingDirection ExceedingDirection = oedExceed;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateObtrackChannelCounterThreshold(Channel, CounterType, CounterValue, ExceedingDirection, TimeStamp);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   PlcObtrackCounterType CounterType;
   __int64         CounterValue;
   PlcObtrackExceedingDirection ExceedingDirection;
   TGLibDateTime   TimeStamp;

   if (! GscAct_DecodeObtrackChannelCounterThreshold(anAction, Channel, CounterType, CounterValue, ExceedingDirection, TimeStamp))
   {
     // error handling
   }


GSC actions: OBTRACK channel set counter

OBTRACK channel set counter
[Video control]

Collaboration diagram for OBTRACK channel set counter:

OBTRACK channel set counter.

OBTRACK channel set counter.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
CounterType | PlcObtrackCounterType | counter type
Counter type.
CounterValue | __int64 | counter value
Counter value.
TimeStamp | TGLibDateTime | time stamp
Time stamp.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   PlcObtrackCounterType CounterType     = octIncoming;
   __int64         CounterValue    = 1;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateObtrackChannelSetCounter(Channel, CounterType, CounterValue, TimeStamp);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   PlcObtrackCounterType CounterType;
   __int64         CounterValue;
   TGLibDateTime   TimeStamp;

   if (! GscAct_DecodeObtrackChannelSetCounter(anAction, Channel, CounterType, CounterValue, TimeStamp))
   {
     // error handling
   }


GSC actions: OBTRACK frame raw data

OBTRACK frame raw data
[Video control]

Collaboration diagram for OBTRACK frame raw data:

OBTRACK frame raw data.

OBTRACK frame raw data.

Parameters

Name | Type | Description
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Channel | TMediaChannelID | channel
Channel.
Brightness | __int32 | brightness
Brightness.
Contrast | __int32 | contrast
Contrast.

Example how to create this action:

   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   TMediaChannelID Channel         = {0, L"", 0};
   __int32         Brightness      = 1;
   __int32         Contrast        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateObtrackFrameRawData(TimeStamp, Channel, Brightness, Contrast);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TGLibDateTime   TimeStamp;
   TMediaChannelID Channel;
   __int32         Brightness;
   __int32         Contrast;

   if (! GscAct_DecodeObtrackFrameRawData(anAction, TimeStamp, Channel, Brightness, Contrast))
   {
     // error handling
   }


GSC actions: OBTRACK group counter

OBTRACK group counter
[Video control]

Collaboration diagram for OBTRACK group counter:

OBTRACK group counter.

OBTRACK group counter.

Parameters

Name | Type | Description
GroupId | __int32 | group ID
Group ID.
CounterType | PlcObtrackCounterType | counter type
Counter type.
CounterValue | __int64 | counter value
Counter value.
ObjectDirection | __int32 | object direction
Object direction.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ResetTimeStamp | TGLibDateTime | reset time stamp
optional | Reset time stamp.
GroupName | widestring | group name
optional | Group name.

Example how to create this action:

   __int32         GroupId         = 1;
   PlcObtrackCounterType CounterType     = octIncoming;
   __int64         CounterValue    = 1;
   __int32         ObjectDirection = 1;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateObtrackGroupCounter(GroupId, CounterType, CounterValue, ObjectDirection, TimeStamp, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         GroupId;
   PlcObtrackCounterType CounterType;
   __int64         CounterValue;
   __int32         ObjectDirection;
   TGLibDateTime   TimeStamp;
   const TGLibDateTime* ResetTimeStamp;
   const wchar_t*  GroupName;

   if (! GscAct_DecodeObtrackGroupCounter(anAction, GroupId, CounterType, CounterValue, ObjectDirection, TimeStamp, ResetTimeStamp, GroupName))
   {
     // error handling
   }


GSC actions: OBTRACK group counter threshold

OBTRACK group counter threshold
[Video control]

Collaboration diagram for OBTRACK group counter threshold:

OBTRACK group counter threshold.

OBTRACK group counter threshold.

Parameters

Name | Type | Description
GroupId | __int32 | group ID
Group ID.
CounterType | PlcObtrackCounterType | counter type
Counter type.
CounterValue | __int64 | counter value
Counter value.
ExceedingDirection | PlcObtrackExceedingDirection | exceeding direction
Exceeding direction.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
GroupName | widestring | group name
optional | Group name.

Example how to create this action:

   __int32         GroupId         = 1;
   PlcObtrackCounterType CounterType     = octIncoming;
   __int64         CounterValue    = 1;
   PlcObtrackExceedingDirection ExceedingDirection = oedExceed;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateObtrackGroupCounterThreshold(GroupId, CounterType, CounterValue, ExceedingDirection, TimeStamp, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         GroupId;
   PlcObtrackCounterType CounterType;
   __int64         CounterValue;
   PlcObtrackExceedingDirection ExceedingDirection;
   TGLibDateTime   TimeStamp;
   const wchar_t*  GroupName;

   if (! GscAct_DecodeObtrackGroupCounterThreshold(anAction, GroupId, CounterType, CounterValue, ExceedingDirection, TimeStamp, GroupName))
   {
     // error handling
   }


GSC actions: OBTRACK group set counter

OBTRACK group set counter
[Video control]

Collaboration diagram for OBTRACK group set counter:

OBTRACK group set counter.

OBTRACK group set counter.

Parameters

Name | Type | Description
GroupId | __int32 | group ID
Group ID.
CounterType | PlcObtrackCounterType | counter type
Counter type.
CounterValue | __int64 | counter value
Counter value.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
GroupName | widestring | group name
optional | Group name.

Example how to create this action:

   __int32         GroupId         = 1;
   PlcObtrackCounterType CounterType     = octIncoming;
   __int64         CounterValue    = 1;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateObtrackGroupSetCounter(GroupId, CounterType, CounterValue, TimeStamp, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   __int32         GroupId;
   PlcObtrackCounterType CounterType;
   __int64         CounterValue;
   TGLibDateTime   TimeStamp;
   const wchar_t*  GroupName;

   if (! GscAct_DecodeObtrackGroupSetCounter(anAction, GroupId, CounterType, CounterValue, TimeStamp, GroupName))
   {
     // error handling
   }


GSC actions: OBTRACK object raw data

OBTRACK object raw data
[Video control]

Collaboration diagram for OBTRACK object raw data:

OBTRACK object raw data.

OBTRACK object raw data.

Parameters

Name | Type | Description
TimeStamp | TGLibDateTime | time stamp
Time stamp.
Channel | TMediaChannelID | channel
Channel.
Area | __int32 | area no
Area no.
ObjectID | __int32 | object ID
Object ID.
ObjectStatus | PlcObtrackObjectStatus | object status
Object status.
ObjectClass | PlcObtrackObjectClass | object class
Object class.
Confidence | __int32 | confidence
optional | Confidence.
Position | TPlcRect | position
optional | Position.
Speed | double | speed
optional | Speed.
Duration | __int32 | duration
optional | Duration.
Direction | __int32 | direction
optional | Direction.
Size | double | object size
optional | Object size.
ObjectWidth | double | object width
optional | Object width in meters.
ObjectHeight | double | object height
optional | Object height in meters.
ProcessSize | PlcObtrackProcessSize | process size
optional | Process size.
GscNetName | string | GSC net name
optional | GeViScope network name.

Example how to create this action:

   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   TMediaChannelID Channel         = {0, L"", 0};
   __int32         Area            = 1;
   __int32         ObjectID        = 1;
   PlcObtrackObjectStatus ObjectStatus    = oosStarting;
   PlcObtrackObjectClass ObjectClass     = oocPerson;

   HGscAction anAction;
   anAction = GscAct_CreateObtrackObjectRawData(TimeStamp, Channel, Area, ObjectID, ObjectStatus, ObjectClass, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TGLibDateTime   TimeStamp;
   TMediaChannelID Channel;
   __int32         Area;
   __int32         ObjectID;
   PlcObtrackObjectStatus ObjectStatus;
   PlcObtrackObjectClass ObjectClass;
   const __int32*  Confidence;
   const TPlcRect* Position;
   const double*   Speed;
   const __int32*  Duration;
   const __int32*  Direction;
   const double*   Size;
   const double*   ObjectWidth;
   const double*   ObjectHeight;
   const PlcObtrackProcessSize* ProcessSize;
   const char*     GscNetName;

   if (! GscAct_DecodeObtrackObjectRawData(anAction, TimeStamp, Channel, Area, ObjectID, ObjectStatus, ObjectClass, Confidence, Position, Speed, Duration, Direction, Size, ObjectWidth, ObjectHeight, ProcessSize, GscNetName))
   {
     // error handling
   }


GSC actions: OBTRACK tunnel alarm

OBTRACK tunnel alarm
[Video control]

Collaboration diagram for OBTRACK tunnel alarm:

OBTRACK tunnel alarm notification.

OBTRACK tunnel alarm notification.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
AlarmReason | PlcTunnelAlarmReason | alarm reason
Alarm reason.
ObjectID | __int32 | object ID
Object ID.
AlarmAreaID | __int32 | alarm area ID
Alarm area ID.
ObjectArea | TPlcRect | object area
optional | Object area.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   PlcTunnelAlarmReason AlarmReason     = tarPerson;
   __int32         ObjectID        = 1;
   __int32         AlarmAreaID     = 1;

   HGscAction anAction;
   anAction = GscAct_CreateObtrackTunnelAlarm(Channel, TimeStamp, AlarmReason, ObjectID, AlarmAreaID, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   TGLibDateTime   TimeStamp;
   PlcTunnelAlarmReason AlarmReason;
   __int32         ObjectID;
   __int32         AlarmAreaID;
   const TPlcRect* ObjectArea;

   if (! GscAct_DecodeObtrackTunnelAlarm(anAction, Channel, TimeStamp, AlarmReason, ObjectID, AlarmAreaID, ObjectArea))
   {
     // error handling
   }


GSC actions: Sensor alarm finished

Sensor alarm finished
[Video control]

Collaboration diagram for Sensor alarm finished:

This action will be fired when the alarm is finished.

This action will be fired when the alarm is finished.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;

   HGscAction anAction;
   anAction = GscAct_CreateSensorAlarmFinished(Channel, SensorType);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;

   if (! GscAct_DecodeSensorAlarmFinished(anAction, Channel, SensorType))
   {
     // error handling
   }


GSC actions: Sensor inhibit alarm finished

Sensor inhibit alarm finished
[Video control]

Collaboration diagram for Sensor inhibit alarm finished:

This action will be fired when the inhibit alarm is finished.

This action will be fired when the inhibit alarm is finished.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;

   HGscAction anAction;
   anAction = GscAct_CreateSensorInhibitAlarmFinished(Channel, SensorType);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;

   if (! GscAct_DecodeSensorInhibitAlarmFinished(anAction, Channel, SensorType))
   {
     // error handling
   }


GSC actions: Sensor inhibit video alarm

Sensor inhibit video alarm
[Video control]

Collaboration diagram for Sensor inhibit video alarm:

This action will be fired when the motion in inhibit area is detected.

This action will be fired when the motion in inhibit area is detected.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.
ADArea | ADArea | AD alarm area
optional | AD alarm area.
ADCell | __int32 | AD cell
optional | AD cell nr.
VMDGroup | VMDGroup | VMD alarm group
optional | VMD alarm group.
VMDZone | __int32 | VMD zone
optional | VMD zone nr.
VMDCycle | VMDCycle | VMD cycle
optional | VMD measure cycle.
AlarmArea | TPlcRect | alarm area
optional | Alarm area.
ObjectClass | PlcObtrackObjectClass | object class
optional | OBTRACK object class.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;

   HGscAction anAction;
   anAction = GscAct_CreateSensorInhibitVideoAlarmEx(Channel, SensorType, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   const ADArea*   ADArea;
   const __int32*  ADCell;
   const VMDGroup* VMDGroup;
   const __int32*  VMDZone;
   const VMDCycle* VMDCycle;
   const TPlcRect* AlarmArea;
   const PlcObtrackObjectClass* ObjectClass;

   if (! GscAct_DecodeSensorInhibitVideoAlarmEx(anAction, Channel, SensorType, ADArea, ADCell, VMDGroup, VMDZone, VMDCycle, AlarmArea, ObjectClass))
   {
     // error handling
   }


GSC actions: Sensor video alarm

Sensor video alarm
[Video control]

Collaboration diagram for Sensor video alarm:

This action will be fired when video alarm is detected.

This action will be fired when video alarm is detected.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.
ADArea | ADArea | AD alarm area
optional | AD alarm area.
ADCell | __int32 | AD cell
optional | AD cell nr.
VMDGroup | VMDGroup | VMD alarm group
optional | VMD alarm group.
VMDZone | __int32 | VMD zone
optional | VMD zone nr.
VMDCycle | VMDCycle | VMD cycle
optional | VMD measure cycle.
AlarmArea | TPlcRect | alarm area
optional | Alarm area.
ObjectClass | PlcObtrackObjectClass | object class
optional | OBTRACK object class.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;

   HGscAction anAction;
   anAction = GscAct_CreateSensorVideoAlarmEx(Channel, SensorType, NULL, NULL, NULL, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   const ADArea*   ADArea;
   const __int32*  ADCell;
   const VMDGroup* VMDGroup;
   const __int32*  VMDZone;
   const VMDCycle* VMDCycle;
   const TPlcRect* AlarmArea;
   const PlcObtrackObjectClass* ObjectClass;

   if (! GscAct_DecodeSensorVideoAlarmEx(anAction, Channel, SensorType, ADArea, ADCell, VMDGroup, VMDZone, VMDCycle, AlarmArea, ObjectClass))
   {
     // error handling
   }


GSC actions: Set system time

Set system time
[Video control]

Collaboration diagram for Set system time:

Set system time.

Set system time.

Parameters

Name | Type | Description
TimeStamp | TGLibDateTime | time stamp
Time stamp.

Example how to create this action:

   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateSetSystemTime(TimeStamp);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TGLibDateTime   TimeStamp;

   if (! GscAct_DecodeSetSystemTime(anAction, TimeStamp))
   {
     // error handling
   }


GSC actions: Set test picture mode

Set test picture mode
[Video control]

Collaboration diagram for Set test picture mode:

Enable or disable test picture generator.

Enable or disable test picture generator.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
Mode | bool | enable
Enable or disable test picture generator.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   bool            Mode            = false;

   HGscAction anAction;
   anAction = GscAct_CreateSetTestPictureMode(Channel, Mode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   bool            Mode;

   if (! GscAct_DecodeSetTestPictureMode(anAction, Channel, Mode))
   {
     // error handling
   }


GSC actions: VCA set armed

VCA set armed
[Video control]

Collaboration diagram for VCA set armed:

Send this action to notify VCA to be armed or disarmed.

Send this action to notify VCA to be armed or disarmed.

Parameters

Name | Type | Description
Channel | TMediaChannelID | Channel
Channel.
SensorType | VideoSensorKind | Sensor type
Sensor type.
Armed | bool | Armed (true) or disarmed (false)
Armed (true) or disarmed (false)

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;
   bool            Armed           = false;

   HGscAction anAction;
   anAction = GscAct_CreateVCASetArmed(Channel, SensorType, Armed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   bool            Armed;

   if (! GscAct_DecodeVCASetArmed(anAction, Channel, SensorType, Armed))
   {
     // error handling
   }


GSC actions: VCA status answer

VCA status answer
[Video control]

Collaboration diagram for VCA status answer:

This action will be sent in response to VCA status request.

This action will be sent in response to VCA status request.

Parameters

Name | Type | Description
Channel | TMediaChannelID | Channel
Channel.
SensorType | VideoSensorKind | Sensor type
Sensor type.
Armed | bool | Armed (true) or disarmed (false)
Armed (true) or disarmed (false)

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;
   bool            Armed           = false;

   HGscAction anAction;
   anAction = GscAct_CreateVCAStatusAnswer(Channel, SensorType, Armed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   bool            Armed;

   if (! GscAct_DecodeVCAStatusAnswer(anAction, Channel, SensorType, Armed))
   {
     // error handling
   }


GSC actions: VCA status request

VCA status request
[Video control]

Collaboration diagram for VCA status request:

Send this action to request status of VCA.

As response VCA will send VCA status answer.

Send this action to request status of VCA. As response VCA will send VCA status answer.

Parameters

Name | Type | Description
Channel | TMediaChannelID | Channel
Channel.
SensorType | VideoSensorKind | Sensor type
Sensor type.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;

   HGscAction anAction;
   anAction = GscAct_CreateVCAStatusRequest(Channel, SensorType);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;

   if (! GscAct_DecodeVCAStatusRequest(anAction, Channel, SensorType))
   {
     // error handling
   }


GSC actions: Video contrast detected

Video contrast detected
[Video control]

Collaboration diagram for Video contrast detected:

This action will be fired when the contrast is detected in the video signal.

This action will be fired when the contrast is detected in the video signal.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateVideoContrastDetected(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeVideoContrastDetected(anAction, Channel))
   {
     // error handling
   }


GSC actions: Video contrast failed

Video contrast failed
[Video control]

Collaboration diagram for Video contrast failed:

This action will be fired when the contrast is lost in the video signal.

This action will be fired when the contrast is lost in the video signal.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateVideoContrastFailed(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeVideoContrastFailed(anAction, Channel))
   {
     // error handling
   }


GSC actions: Video set image brightness

Video set image brightness
[Video control]

Collaboration diagram for Video set image brightness:

Video set image brightness.

Video set image brightness.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.
Brightness | __int32 | brightness
Brightness.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;
   __int32         Brightness      = 1;

   HGscAction anAction;
   anAction = GscAct_CreateVideoSetImageBrightness(Channel, SensorType, Brightness);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   __int32         Brightness;

   if (! GscAct_DecodeVideoSetImageBrightness(anAction, Channel, SensorType, Brightness))
   {
     // error handling
   }


GSC actions: Video set image contrast

Video set image contrast
[Video control]

Collaboration diagram for Video set image contrast:

Video set image contrast.

Video set image contrast.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.
Contrast | __int32 | contrast
Contrast.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;
   __int32         Contrast        = 1;

   HGscAction anAction;
   anAction = GscAct_CreateVideoSetImageContrast(Channel, SensorType, Contrast);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   __int32         Contrast;

   if (! GscAct_DecodeVideoSetImageContrast(anAction, Channel, SensorType, Contrast))
   {
     // error handling
   }


GSC actions: Video set image saturation

Video set image saturation
[Video control]

Collaboration diagram for Video set image saturation:

Video set image saturation.

Video set image saturation.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SensorType | VideoSensorKind | sensor type
Sensor type.
Saturation | __int32 | saturation
Saturation.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSensorKind SensorType      = vskAD;
   __int32         Saturation      = 1;

   HGscAction anAction;
   anAction = GscAct_CreateVideoSetImageSaturation(Channel, SensorType, Saturation);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSensorKind SensorType;
   __int32         Saturation;

   if (! GscAct_DecodeVideoSetImageSaturation(anAction, Channel, SensorType, Saturation))
   {
     // error handling
   }


GSC actions: Video source has changed

Video source has changed
[Video control]

Collaboration diagram for Video source has changed:

This action indicates the changes on the video input source.

This action indicates the changes on the video input source.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.
SignalNorm | VideoSignalNorm | signal norm
New signal norm.
SignalType | VideoSignalType | signal type
New signal type.
InterlaceType | VideoInterlaceType | interlace type
New interlace type.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};
   VideoSignalNorm SignalNorm      = vsnEIA;
   VideoSignalType SignalType      = vstBAS;
   VideoInterlaceType InterlaceType   = vsdInterlaced;

   HGscAction anAction;
   anAction = GscAct_CreateVideoSourceChanged(Channel, SignalNorm, SignalType, InterlaceType);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;
   VideoSignalNorm SignalNorm;
   VideoSignalType SignalType;
   VideoInterlaceType InterlaceType;

   if (! GscAct_DecodeVideoSourceChanged(anAction, Channel, SignalNorm, SignalType, InterlaceType))
   {
     // error handling
   }


GSC actions: Video sync detected

Video sync detected
[Video control]

Collaboration diagram for Video sync detected:

This action will be fired when the sync is detected in the video signal.

This action will be fired when the sync is detected in the video signal.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateVideoSyncDetected(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeVideoSyncDetected(anAction, Channel))
   {
     // error handling
   }


GSC actions: Video sync failed

Video sync failed
[Video control]

Collaboration diagram for Video sync failed:

This action will be fired when the sync is lost in the video signal.

This action will be fired when the sync is lost in the video signal.

Parameters

Name | Type | Description
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateVideoSyncFailed(Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Channel;

   if (! GscAct_DecodeVideoSyncFailed(anAction, Channel))
   {
     // error handling
   }


GSC actions: Viewer actions

Modules

Viewer actions
[Actions]

Collaboration diagram for Viewer actions:

Detailed Description

All actions for viewer customizing.

Modules

VC alarm queue confirm

Confirm alarm from the queue on the viewer client.

VC alarm queue confirm by instance

Confirm alarm from the queue on the viewer client.

VC alarm queue confirm by type

Confirm alarm of specific type from the queue on the viewer client.

VC alarm queue remove

Remove alarm from the queue on the viewer client.

VC alarm queue remove by instance

Remove alarm from the queue on the viewer client.

VC alarm queue remove by type

Remove alarm of specific type from the queue on the viewer client.

VC alarm queue select

Select alarm from the queue on the viewer client.

VC alarm queue select by instance

Select alarm from the queue on the viewer client.

VC alarm queue select by type

Select alarm of specific type from the queue on the viewer client.

VC change scene by name

Viewer client change scene by name.

VC clear scene by name

Viewer client clear scene by name.

VC full mode

Viewer client full mode.

VC set audio level

Viewer client set audio level.

VC show viewer text

Viewer client show viewer text.

VC stretch mode

Viewer client stretch mode.

Viewer change scene

Viewer change scene.

Viewer change sync audio/video

Viewer change sync audio/video.

Viewer clear

Clear viewer.

Viewer clear scene

Viewer clear scene.

Viewer clear text output

Clear text output in the given viewer.

Viewer connect

Connect camera to the viewer.

Viewer connect live

Connect live camera to the viewer.

Viewer export picture

Viewer export picture.

Viewer jump by time

Viewer jump by time.

Viewer maximize

Viewer maximize.

Viewer play from time

Viewer play from time.

Viewer print picture

Viewer print picture.

Viewer select

Select viewer.

Viewer set play mode

Set play mode of the viewer.

Viewer show alarm by instance

Show alarm in viewer using alarm instance ID.

Viewer show alarm by key

Show alarm in viewer using alarm foreign key.

Viewer show alarm by type

Show alarm in viewer using alarm type and optional foreign key.

Viewer text output

Display free string in the given viewer.


GSC actions: VC alarm queue confirm

VC alarm queue confirm
[Viewer actions]

Collaboration diagram for VC alarm queue confirm:

Confirm alarm from the queue on the viewer client.

Confirm alarm from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
SelectionMode | PlcViewerAlarmQueueSelection | selection mode
Selection mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   PlcViewerAlarmQueueSelection SelectionMode   = aqsFirst;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueConfirm(Viewer, SelectionMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   PlcViewerAlarmQueueSelection SelectionMode;

   if (! GscAct_DecodeVCAlarmQueueConfirm(anAction, Viewer, SelectionMode))
   {
     // error handling
   }


GSC actions: VC alarm queue confirm by instance

VC alarm queue confirm by instance
[Viewer actions]

Collaboration diagram for VC alarm queue confirm by instance:

Confirm alarm from the queue on the viewer client.

Confirm alarm from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
AlarmID | __int64 | instance ID
Instance ID of the alarm.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   __int64         AlarmID         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueConfirmByInstance(Viewer, AlarmID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   __int64         AlarmID;

   if (! GscAct_DecodeVCAlarmQueueConfirmByInstance(anAction, Viewer, AlarmID))
   {
     // error handling
   }


GSC actions: VC alarm queue confirm by type

VC alarm queue confirm by type
[Viewer actions]

Collaboration diagram for VC alarm queue confirm by type:

Confirm alarm of specific type from the queue on the viewer client.

Confirm alarm of specific type from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
TypeID | TEventTypeID | event type
Type of the event.
SelectionMode | PlcViewerAlarmQueueSelection | selection mode
Selection mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TEventTypeID    TypeID          = {0, L"", 0};
   PlcViewerAlarmQueueSelection SelectionMode   = aqsFirst;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueConfirmByType(Viewer, TypeID, SelectionMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TEventTypeID    TypeID;
   PlcViewerAlarmQueueSelection SelectionMode;

   if (! GscAct_DecodeVCAlarmQueueConfirmByType(anAction, Viewer, TypeID, SelectionMode))
   {
     // error handling
   }


GSC actions: VC alarm queue remove

VC alarm queue remove
[Viewer actions]

Collaboration diagram for VC alarm queue remove:

Remove alarm from the queue on the viewer client.

Remove alarm from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
SelectionMode | PlcViewerAlarmQueueSelection | selection mode
Selection mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   PlcViewerAlarmQueueSelection SelectionMode   = aqsFirst;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueRemove(Viewer, SelectionMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   PlcViewerAlarmQueueSelection SelectionMode;

   if (! GscAct_DecodeVCAlarmQueueRemove(anAction, Viewer, SelectionMode))
   {
     // error handling
   }


GSC actions: VC alarm queue remove by instance

VC alarm queue remove by instance
[Viewer actions]

Collaboration diagram for VC alarm queue remove by instance:

Remove alarm from the queue on the viewer client.

Remove alarm from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
AlarmID | __int64 | instance ID
Instance ID of the alarm.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   __int64         AlarmID         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueRemoveByInstance(Viewer, AlarmID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   __int64         AlarmID;

   if (! GscAct_DecodeVCAlarmQueueRemoveByInstance(anAction, Viewer, AlarmID))
   {
     // error handling
   }


GSC actions: VC alarm queue remove by type

VC alarm queue remove by type
[Viewer actions]

Collaboration diagram for VC alarm queue remove by type:

Remove alarm of specific type from the queue on the viewer client.

Remove alarm of specific type from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
TypeID | TEventTypeID | event type
Type of the event.
SelectionMode | PlcViewerAlarmQueueSelection | selection mode
Selection mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TEventTypeID    TypeID          = {0, L"", 0};
   PlcViewerAlarmQueueSelection SelectionMode   = aqsFirst;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueRemoveByType(Viewer, TypeID, SelectionMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TEventTypeID    TypeID;
   PlcViewerAlarmQueueSelection SelectionMode;

   if (! GscAct_DecodeVCAlarmQueueRemoveByType(anAction, Viewer, TypeID, SelectionMode))
   {
     // error handling
   }


GSC actions: VC alarm queue select

VC alarm queue select
[Viewer actions]

Collaboration diagram for VC alarm queue select:

Select alarm from the queue on the viewer client.

Select alarm from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
SelectionMode | PlcViewerAlarmQueueSelection | selection mode
Selection mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   PlcViewerAlarmQueueSelection SelectionMode   = aqsFirst;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueSelect(Viewer, SelectionMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   PlcViewerAlarmQueueSelection SelectionMode;

   if (! GscAct_DecodeVCAlarmQueueSelect(anAction, Viewer, SelectionMode))
   {
     // error handling
   }


GSC actions: VC alarm queue select by instance

VC alarm queue select by instance
[Viewer actions]

Collaboration diagram for VC alarm queue select by instance:

Select alarm from the queue on the viewer client.

Select alarm from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
AlarmID | __int64 | instance ID
Instance ID of the alarm.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   __int64         AlarmID         = 1;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueSelectByInstance(Viewer, AlarmID);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   __int64         AlarmID;

   if (! GscAct_DecodeVCAlarmQueueSelectByInstance(anAction, Viewer, AlarmID))
   {
     // error handling
   }


GSC actions: VC alarm queue select by type

VC alarm queue select by type
[Viewer actions]

Collaboration diagram for VC alarm queue select by type:

Select alarm of specific type from the queue on the viewer client.

Select alarm of specific type from the queue on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
TypeID | TEventTypeID | event type
Type of the event.
SelectionMode | PlcViewerAlarmQueueSelection | selection mode
Selection mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TEventTypeID    TypeID          = {0, L"", 0};
   PlcViewerAlarmQueueSelection SelectionMode   = aqsFirst;

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueSelectByType(Viewer, TypeID, SelectionMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TEventTypeID    TypeID;
   PlcViewerAlarmQueueSelection SelectionMode;

   if (! GscAct_DecodeVCAlarmQueueSelectByType(anAction, Viewer, TypeID, SelectionMode))
   {
     // error handling
   }


GSC actions: VC change scene by name

VC change scene by name
[Viewer actions]

Collaboration diagram for VC change scene by name:

Viewer client change scene by name.

Viewer client change scene by name.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Scene | widestring | scene
Scene name.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   const wchar_t*  Scene           = L"scene";

   HGscAction anAction;
   anAction = GscAct_CreateVCChangeSceneByName(Viewer, Scene);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   const wchar_t*  Scene;

   if (! GscAct_DecodeVCChangeSceneByName(anAction, Viewer, Scene))
   {
     // error handling
   }


GSC actions: VC clear scene by name

VC clear scene by name
[Viewer actions]

Collaboration diagram for VC clear scene by name:

Viewer client clear scene by name.

Viewer client clear scene by name.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Scene | widestring | scene
Scene name.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   const wchar_t*  Scene           = L"scene";

   HGscAction anAction;
   anAction = GscAct_CreateVCClearSceneByName(Viewer, Scene);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   const wchar_t*  Scene;

   if (! GscAct_DecodeVCClearSceneByName(anAction, Viewer, Scene))
   {
     // error handling
   }


GSC actions: VC full mode

VC full mode
[Viewer actions]

Collaboration diagram for VC full mode:

Viewer client full mode.

Viewer client full mode.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
FullMode | bool | full mode
Switch viewer client in full mode.
SensitiveAreaEnabled | bool | sensitive area enabled
Sensitive area enabled.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   bool            FullMode        = false;
   bool            SensitiveAreaEnabled = false;

   HGscAction anAction;
   anAction = GscAct_CreateVCFullMode(Viewer, FullMode, SensitiveAreaEnabled);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   bool            FullMode;
   bool            SensitiveAreaEnabled;

   if (! GscAct_DecodeVCFullMode(anAction, Viewer, FullMode, SensitiveAreaEnabled))
   {
     // error handling
   }


GSC actions: VC set audio level

VC set audio level
[Viewer actions]

Collaboration diagram for VC set audio level:

Viewer client set audio level.

Viewer client set audio level.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
AudioLevel | __int32 | audio level
Audio level in range 0 (audio off) till 100 (max. volume).

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   __int32         AudioLevel      = 1;

   HGscAction anAction;
   anAction = GscAct_CreateVCSetAudioLevel(Viewer, AudioLevel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   __int32         AudioLevel;

   if (! GscAct_DecodeVCSetAudioLevel(anAction, Viewer, AudioLevel))
   {
     // error handling
   }


GSC actions: VC show viewer text

VC show viewer text
[Viewer actions]

Collaboration diagram for VC show viewer text:

Viewer client show viewer text.

Viewer client show viewer text.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
ShowText | bool | show text
Show text in viewer client.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   bool            ShowText        = false;

   HGscAction anAction;
   anAction = GscAct_CreateVCShowViewerText(Viewer, ShowText);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   bool            ShowText;

   if (! GscAct_DecodeVCShowViewerText(anAction, Viewer, ShowText))
   {
     // error handling
   }


GSC actions: VC stretch mode

VC stretch mode
[Viewer actions]

Collaboration diagram for VC stretch mode:

Viewer client stretch mode.

Viewer client stretch mode.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
StretchMode | bool | stretch mode
Switch viewer client in stretch mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   bool            StretchMode     = false;

   HGscAction anAction;
   anAction = GscAct_CreateVCStretchMode(Viewer, StretchMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   bool            StretchMode;

   if (! GscAct_DecodeVCStretchMode(anAction, Viewer, StretchMode))
   {
     // error handling
   }


GSC actions: Viewer change scene

Viewer change scene
[Viewer actions]

Collaboration diagram for Viewer change scene:

Viewer change scene.

Viewer change scene.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerChangeScene(Viewer);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;

   if (! GscAct_DecodeViewerChangeScene(anAction, Viewer))
   {
     // error handling
   }


GSC actions: Viewer change sync audio/video

Viewer change sync audio/video
[Viewer actions]

Collaboration diagram for Viewer change sync audio/video:

Viewer change sync audio/video.

Viewer change sync audio/video.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
EnableSync | bool | enable sync
Enable audio/video sync.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   bool            EnableSync      = false;

   HGscAction anAction;
   anAction = GscAct_CreateViewerSyncAudioAndVideo(Viewer, EnableSync);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   bool            EnableSync;

   if (! GscAct_DecodeViewerSyncAudioAndVideo(anAction, Viewer, EnableSync))
   {
     // error handling
   }


GSC actions: Viewer clear

Viewer clear
[Viewer actions]

Collaboration diagram for Viewer clear:

Clear viewer.

Clear viewer.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerClear(Viewer);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;

   if (! GscAct_DecodeViewerClear(anAction, Viewer))
   {
     // error handling
   }


GSC actions: Viewer clear scene

Viewer clear scene
[Viewer actions]

Collaboration diagram for Viewer clear scene:

Viewer clear scene.

Viewer clear scene.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerClearScene(Viewer);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;

   if (! GscAct_DecodeViewerClearScene(anAction, Viewer))
   {
     // error handling
   }


GSC actions: Viewer clear text output

Viewer clear text output
[Viewer actions]

Collaboration diagram for Viewer clear text output:

Clear text output in the given viewer.

Clear text output in the given viewer.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerClearTextOutput(Viewer);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;

   if (! GscAct_DecodeViewerClearTextOutput(anAction, Viewer))
   {
     // error handling
   }


GSC actions: Viewer connect

Viewer connect
[Viewer actions]

Collaboration diagram for Viewer connect:

Connect camera to the viewer.

Connect camera to the viewer.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Channel | TMediaChannelID | channel
Channel.
PlayMode | PlcViewerPlayMode | play mode
Viewer play mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TMediaChannelID Channel         = {0, L"", 0};
   PlcViewerPlayMode PlayMode        = vpmUnknownMode;

   HGscAction anAction;
   anAction = GscAct_CreateViewerConnect(Viewer, Channel, PlayMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TMediaChannelID Channel;
   PlcViewerPlayMode PlayMode;

   if (! GscAct_DecodeViewerConnect(anAction, Viewer, Channel, PlayMode))
   {
     // error handling
   }


GSC actions: Viewer connect live

Viewer connect live
[Viewer actions]

Collaboration diagram for Viewer connect live:

Connect live camera to the viewer.

Connect live camera to the viewer.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Channel | TMediaChannelID | channel
Channel.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TMediaChannelID Channel         = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerConnectLive(Viewer, Channel);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TMediaChannelID Channel;

   if (! GscAct_DecodeViewerConnectLive(anAction, Viewer, Channel))
   {
     // error handling
   }


GSC actions: Viewer export picture

Viewer export picture
[Viewer actions]

Collaboration diagram for Viewer export picture:

Viewer export picture.

Viewer export picture.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
FilePath | widestring | file path
File path (local or UNC). GSCView default path is used if left empty.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   const wchar_t*  FilePath        = L"file path";

   HGscAction anAction;
   anAction = GscAct_CreateViewerExportPicture(Viewer, FilePath);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   const wchar_t*  FilePath;

   if (! GscAct_DecodeViewerExportPicture(anAction, Viewer, FilePath))
   {
     // error handling
   }


GSC actions: Viewer jump by time

Viewer jump by time
[Viewer actions]

Collaboration diagram for Viewer jump by time:

Viewer jump by time.

Viewer jump by time.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Channel | TMediaChannelID | channel
Channel.
PlayMode | PlcViewerPlayMode | play mode
Viewer play mode.
TimeInSec | __int32 | time in sec
Time to jump in seconds. Use negative values to jump in past.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TMediaChannelID Channel         = {0, L"", 0};
   PlcViewerPlayMode PlayMode        = vpmUnknownMode;
   __int32         TimeInSec       = 1;

   HGscAction anAction;
   anAction = GscAct_CreateViewerJumpByTime(Viewer, Channel, PlayMode, TimeInSec);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TMediaChannelID Channel;
   PlcViewerPlayMode PlayMode;
   __int32         TimeInSec;

   if (! GscAct_DecodeViewerJumpByTime(anAction, Viewer, Channel, PlayMode, TimeInSec))
   {
     // error handling
   }


GSC actions: Viewer maximize

Viewer maximize
[Viewer actions]

Collaboration diagram for Viewer maximize:

Viewer maximize.

Viewer maximize.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Maximize | bool | maximize
Maximize.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   bool            Maximize        = false;

   HGscAction anAction;
   anAction = GscAct_CreateViewerMaximize(Viewer, Maximize);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   bool            Maximize;

   if (! GscAct_DecodeViewerMaximize(anAction, Viewer, Maximize))
   {
     // error handling
   }


GSC actions: Viewer play from time

Viewer play from time
[Viewer actions]

Collaboration diagram for Viewer play from time:

Viewer play from time.

Viewer play from time.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Channel | TMediaChannelID | channel
Channel.
PlayMode | PlcViewerPlayMode | play mode
Viewer play mode.
Time | TGLibDateTime | time
Time to play from.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TMediaChannelID Channel         = {0, L"", 0};
   PlcViewerPlayMode PlayMode        = vpmUnknownMode;
   TGLibDateTime   Time            = TGLibDateTime::Now();

   HGscAction anAction;
   anAction = GscAct_CreateViewerPlayFromTime(Viewer, Channel, PlayMode, Time);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TMediaChannelID Channel;
   PlcViewerPlayMode PlayMode;
   TGLibDateTime   Time;

   if (! GscAct_DecodeViewerPlayFromTime(anAction, Viewer, Channel, PlayMode, Time))
   {
     // error handling
   }


GSC actions: Viewer print picture

Viewer print picture
[Viewer actions]

Collaboration diagram for Viewer print picture:

Viewer print picture.

Viewer print picture.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerPrintPicture(Viewer);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;

   if (! GscAct_DecodeViewerPrintPicture(anAction, Viewer))
   {
     // error handling
   }


GSC actions: Viewer select

Viewer select
[Viewer actions]

Collaboration diagram for Viewer select:

Select viewer.

Select viewer.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerSelect(Viewer);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;

   if (! GscAct_DecodeViewerSelect(anAction, Viewer))
   {
     // error handling
   }


GSC actions: Viewer set play mode

Viewer set play mode
[Viewer actions]

Collaboration diagram for Viewer set play mode:

Set play mode of the viewer.

Set play mode of the viewer.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
PlayMode | PlcViewerPlayMode | play mode
Viewer play mode.
PlaySpeed | __int32 | play speed
Optional play speed parameter.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   PlcViewerPlayMode PlayMode        = vpmUnknownMode;
   __int32         PlaySpeed       = 1;

   HGscAction anAction;
   anAction = GscAct_CreateViewerSetPlayMode(Viewer, PlayMode, PlaySpeed);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   PlcViewerPlayMode PlayMode;
   __int32         PlaySpeed;

   if (! GscAct_DecodeViewerSetPlayMode(anAction, Viewer, PlayMode, PlaySpeed))
   {
     // error handling
   }


GSC actions: Viewer show alarm by instance

Viewer show alarm by instance
[Viewer actions]

Collaboration diagram for Viewer show alarm by instance:

Show alarm in viewer using alarm instance ID.

Show alarm in viewer using alarm instance ID.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
AlarmID | __int64 | instance ID
Instance ID of the alarm.
PlayMode | PlcViewerAlarmPlayMode | play mode
Viewer alarm's play mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   __int64         AlarmID         = 1;
   PlcViewerAlarmPlayMode PlayMode        = apmDefault;

   HGscAction anAction;
   anAction = GscAct_CreateViewerShowAlarmByInstance(Viewer, AlarmID, PlayMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   __int64         AlarmID;
   PlcViewerAlarmPlayMode PlayMode;

   if (! GscAct_DecodeViewerShowAlarmByInstance(anAction, Viewer, AlarmID, PlayMode))
   {
     // error handling
   }


GSC actions: Viewer show alarm by key

Viewer show alarm by key
[Viewer actions]

Collaboration diagram for Viewer show alarm by key:

Show alarm in viewer using alarm foreign key.

Show alarm in viewer using alarm foreign key.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
ForeignKey | __int64 | foreign key
Foreign key used to start the alarm.
PlayMode | PlcViewerAlarmPlayMode | play mode
Viewer alarm's play mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   __int64         ForeignKey      = 1;
   PlcViewerAlarmPlayMode PlayMode        = apmDefault;

   HGscAction anAction;
   anAction = GscAct_CreateViewerShowAlarmByKey(Viewer, ForeignKey, PlayMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   __int64         ForeignKey;
   PlcViewerAlarmPlayMode PlayMode;

   if (! GscAct_DecodeViewerShowAlarmByKey(anAction, Viewer, ForeignKey, PlayMode))
   {
     // error handling
   }


GSC actions: Viewer show alarm by type

Viewer show alarm by type
[Viewer actions]

Collaboration diagram for Viewer show alarm by type:

Show alarm in viewer using alarm type and optional foreign key.

Show alarm in viewer using alarm type and optional foreign key.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
TypeID | TEventTypeID | alarm type
Type of the alarm.
ForeignKey | __int64 | foreign key
optional | Foreign key used to start the alarm.
PlayMode | PlcViewerAlarmPlayMode | play mode
Viewer alarm's play mode.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TEventTypeID    TypeID          = {0, L"", 0};
   PlcViewerAlarmPlayMode PlayMode        = apmDefault;

   HGscAction anAction;
   anAction = GscAct_CreateViewerShowAlarmByType(Viewer, TypeID, NULL, PlayMode);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TEventTypeID    TypeID;
   const __int64*  ForeignKey;
   PlcViewerAlarmPlayMode PlayMode;

   if (! GscAct_DecodeViewerShowAlarmByType(anAction, Viewer, TypeID, ForeignKey, PlayMode))
   {
     // error handling
   }


GSC actions: Viewer text output

Viewer text output
[Viewer actions]

Collaboration diagram for Viewer text output:

Display free string in the given viewer.

Display free string in the given viewer.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Text | widestring | text string
Text string to display.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   const wchar_t*  Text            = L"text string";

   HGscAction anAction;
   anAction = GscAct_CreateViewerTextOutput(Viewer, Text);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   const wchar_t*  Text;

   if (! GscAct_DecodeViewerTextOutput(anAction, Viewer, Text))
   {
     // error handling
   }


GSC actions: Viewer notifications

Modules

Viewer notifications
[Actions]

Collaboration diagram for Viewer notifications:

Detailed Description

All viewer notifications.

Modules

Image export notification

Notification on export or print of channel images.

Scene store modification

Scene store modification.

VC alarm queue notification

Alarm queue notification on the viewer client.

VC scene changed

Viewer client scene changed.

Viewer cleared

Viewer cleared.

Viewer connected

Viewer connected to the camera.

Viewer play mode changed

Viewer play mode changed.

Viewer selection changed

Viewer selection was changed.


GSC actions: Image export notification

Image export notification
[Viewer notifications]

Collaboration diagram for Image export notification:

Notification on export or print of channel images.

Notification on export or print of channel images.

Parameters

Name | Type | Description
User | widestring | user
Name of the user connected to the system.
Destination | widestring | destination
Destination.
DestinationType | PlcImageExportType | destination type
Destination type.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
TimeEnd | TGLibDateTime | end time
optional | End time.
Channels | widestring | channels
Channels.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   const wchar_t*  User            = L"user";
   const wchar_t*  Destination     = L"destination";
   PlcImageExportType DestinationType = ietSingleImage;
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   const wchar_t*  Channels        = L"channels";

   HGscAction anAction;
   anAction = GscAct_CreateImageExportNotification(User, Destination, DestinationType, TimeStamp, NULL, Channels, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   const wchar_t*  User;
   const wchar_t*  Destination;
   PlcImageExportType DestinationType;
   TGLibDateTime   TimeStamp;
   const TGLibDateTime* TimeEnd;
   const wchar_t*  Channels;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeImageExportNotification(anAction, User, Destination, DestinationType, TimeStamp, TimeEnd, Channels, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: Scene store modification

Scene store modification
[Viewer notifications]

Collaboration diagram for Scene store modification:

Scene store modification.

Scene store modification.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
SceneStoreID | GUID | scene store GUID
Scene store GUID.
SceneStoreName | widestring | scene store name
Scene store name.
TimeStamp | TGLibDateTime | time stamp
Time stamp.
ModificationType | PlcSceneStoreModificationType | modification type
Modification type.
User | widestring | user
Name of the user.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   GUID            SceneStoreID    = {0, 0, 0, {0, 0, 0, 0, 0, 0, 0, 0}};
   const wchar_t*  SceneStoreName  = L"scene store name";
   TGLibDateTime   TimeStamp       = TGLibDateTime::Now();
   PlcSceneStoreModificationType ModificationType = smtCreate;
   const wchar_t*  User            = L"user";

   HGscAction anAction;
   anAction = GscAct_CreateSceneStoreModification(Viewer, SceneStoreID, SceneStoreName, TimeStamp, ModificationType, User, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   GUID            SceneStoreID;
   const wchar_t*  SceneStoreName;
   TGLibDateTime   TimeStamp;
   PlcSceneStoreModificationType ModificationType;
   const wchar_t*  User;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeSceneStoreModification(anAction, Viewer, SceneStoreID, SceneStoreName, TimeStamp, ModificationType, User, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: VC alarm queue notification

VC alarm queue notification
[Viewer notifications]

Collaboration diagram for VC alarm queue notification:

Alarm queue notification on the viewer client.

Alarm queue notification on the viewer client.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Notification | PlcViewerAlarmState | notification
Alarm state notification.
AlarmID | __int64 | instance ID
Instance ID of the alarm.
TypeID | TEventTypeID | event type
Type of the event.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   PlcViewerAlarmState Notification    = vasNewAlarm;
   __int64         AlarmID         = 1;
   TEventTypeID    TypeID          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateVCAlarmQueueNotification(Viewer, Notification, AlarmID, TypeID, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   PlcViewerAlarmState Notification;
   __int64         AlarmID;
   TEventTypeID    TypeID;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeVCAlarmQueueNotification(anAction, Viewer, Notification, AlarmID, TypeID, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: VC scene changed

VC scene changed
[Viewer notifications]

Collaboration diagram for VC scene changed:

Viewer client scene changed.

Viewer client scene changed.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Scene | widestring | scene
Scene name.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   const wchar_t*  Scene           = L"scene";

   HGscAction anAction;
   anAction = GscAct_CreateVCSceneChanged(Viewer, Scene);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   const wchar_t*  Scene;

   if (! GscAct_DecodeVCSceneChanged(anAction, Viewer, Scene))
   {
     // error handling
   }


GSC actions: Viewer cleared

Viewer cleared
[Viewer notifications]

Collaboration diagram for Viewer cleared:

Viewer cleared.

Viewer cleared.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};

   HGscAction anAction;
   anAction = GscAct_CreateViewerCleared(Viewer, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeViewerCleared(anAction, Viewer, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: Viewer connected

Viewer connected
[Viewer notifications]

Collaboration diagram for Viewer connected:

Viewer connected to the camera.

Viewer connected to the camera.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Channel | TMediaChannelID | channel
Channel.
PlayMode | PlcViewerPlayMode | play mode
Viewer play mode.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TMediaChannelID Channel         = {0, L"", 0};
   PlcViewerPlayMode PlayMode        = vpmUnknownMode;

   HGscAction anAction;
   anAction = GscAct_CreateViewerConnected(Viewer, Channel, PlayMode, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TMediaChannelID Channel;
   PlcViewerPlayMode PlayMode;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeViewerConnected(anAction, Viewer, Channel, PlayMode, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: Viewer play mode changed

Viewer play mode changed
[Viewer notifications]

Collaboration diagram for Viewer play mode changed:

Viewer play mode changed.

Viewer play mode changed.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Channel | TMediaChannelID | channel
Channel.
PlayMode | PlcViewerPlayMode | play mode
Viewer play mode.
ChannelTime | TGLibDateTime | channel time
optional | Channel time.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TMediaChannelID Channel         = {0, L"", 0};
   PlcViewerPlayMode PlayMode        = vpmUnknownMode;

   HGscAction anAction;
   anAction = GscAct_CreateViewerPlayModeChanged(Viewer, Channel, PlayMode, NULL, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TMediaChannelID Channel;
   PlcViewerPlayMode PlayMode;
   const TGLibDateTime* ChannelTime;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeViewerPlayModeChanged(anAction, Viewer, Channel, PlayMode, ChannelTime, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: Viewer selection changed

Viewer selection changed
[Viewer notifications]

Collaboration diagram for Viewer selection changed:

Viewer selection was changed.

Viewer selection was changed.

Parameters

Name | Type | Description
Viewer | TMediaChannelID | viewer
Global viewer or viewer client no.
Channel | TMediaChannelID | channel
Channel.
PlayMode | PlcViewerPlayMode | play mode
Viewer play mode.
ClientHost | widestring | client host
optional | Host from where the connection is done.
ClientType | PlcClientType | client type
optional | Client type.
ClientAccount | widestring | client account
optional | User account from where the connection is done.

Example how to create this action:

   TMediaChannelID Viewer          = {0, L"", 0};
   TMediaChannelID Channel         = {0, L"", 0};
   PlcViewerPlayMode PlayMode        = vpmUnknownMode;

   HGscAction anAction;
   anAction = GscAct_CreateViewerSelectionChanged(Viewer, Channel, PlayMode, NULL, NULL, NULL);

   if (anAction == NULL)
   {
     // error handling
   }

Example how to decode this action:

   TMediaChannelID Viewer;
   TMediaChannelID Channel;
   PlcViewerPlayMode PlayMode;
   const wchar_t*  ClientHost;
   const PlcClientType* ClientType;
   const wchar_t*  ClientAccount;

   if (! GscAct_DecodeViewerSelectionChanged(anAction, Viewer, Channel, PlayMode, ClientHost, ClientType, ClientAccount))
   {
     // error handling
   }


GSC actions: Messages / actions

Modules

Messages / actions

Collaboration diagram for Messages / actions:

Detailed Description

Messages are base for PLC in GeViScope system.

There are two different kinds of messages: actions and match actions.

Actions are used

  • to inform server or client that something has happen, like a new user has logged in
  • to execute commands, like close contact.

Match actions represent test conditions and can be used as action templates. One can use function CGscMatchAction::Matches to test whether some action satisfies the test condition or not. Match actions are widely used on the server side to implement behavioral rules, but can be also used on the client side to adjust local behavior.

GscDBI provides only the transport layer for message communication between server and client. Messages should be converted to its binary representation to be send to the server over GscDBI, server notifications should be converted back to the corresponding control structures. This can be done with functions CGscMessage::StoreToBinBuffer and CGscMessage::CreateFromBinBuffer.

For every message there exists a control object on the DLL side. You don't have a direct pointer to this object or direct access to its member fields and functions. You are working with handles. These message handles should be closed if they are not needed anymore, you get memory leaks otherwise.

There are two possible ways to access message members:

  • using low level functional interface
  • using class wrapper interface

Functional interface can be found here:

  • Message functions
  • Action functions
  • Match action functions

Class wrapper interface is the preferred way. It consists of three classes - CGscMessage, CGscAction, and CGscMatchAction which restore object oriented view to the messages. You can use these proxy objects like any other heap allocated objects: create functions return a pointer to the proxy object, you can access its interface functions directly and should free it using delete operator:

 const wchar_t* actionText = L"CameraLightOn(1)";

 // create object
 CGscAction* anAction =
   CGscAction::CreateFromTextBuffer(actionText, wcslen(actionText));

 if (anAction)
 {
   wchar_t buffer[256];
   anAction->StoreToTextBuffer(buffer, 256, true); // access member function
   delete anAction;                                // free used memory
 }

Modules

Message classes

Here one can find a list of available class wrapper.

Message functions

Low level API functions to work with messages.

Action functions

Low level API functions to work with actions.

Match action functions

Low level API functions to work with match actions.

Output operators

Simplify input / output operation with messages.


GSC actions: Message classes

Classes | Typedefs

Message classes
[Messages / actions]

Collaboration diagram for Message classes:

Detailed Description

Here one can find a list of available class wrapper.

Wrapper classes over all but general functions.

Data types.

Classes

class | CGscMessage
GeViScope message. More...
class | CGscAction
GeViScope action. More...
class | CGscMatchAction
GeViScope match action. More...

Typedefs

typedef CGscMessage * | HGscMessage
typedef const CGscMessage * | ConstHGscMessage
typedef CGscAction * | HGscAction
typedef const CGscAction * | ConstHGscAction
typedef CGscMatchAction * | HGscMatchAction
typedef const CGscMatchAction * | ConstHGscMatchAction

Typedef Documentation

typedef CGscMessage* HGscMessage

Definition at line 62 of file GscActions.h.

typedef const CGscMessage* ConstHGscMessage

Definition at line 65 of file GscActions.h.

typedef CGscAction* HGscAction

Definition at line 66 of file GscActions.h.

typedef const CGscAction* ConstHGscAction

Definition at line 67 of file GscActions.h.

typedef CGscMatchAction* HGscMatchAction

Definition at line 68 of file GscActions.h.

typedef const CGscMatchAction* ConstHGscMatchAction

Definition at line 69 of file GscActions.h.


GSC actions: Message functions

Defines | Functions

Message functions
[Messages / actions]

Collaboration diagram for Message functions:

Detailed Description

Low level API functions to work with messages.

// end of group GscPlcEvents

General functions for all messages

Defines

#define | GscAct_CreateFromTextBuffer GscAct_CreateFromTextBufferA
#define | GscAct_StoreToTextBuffer GscAct_StoreToTextBufferA

Functions

GSCACTDLLCALL bool __stdcall | GscAct_CloseHandle (HGscMessage aMessage)
Close message handle.
GSCACTDLLCALL bool __stdcall | GscAct_DuplicateHandle (HGscMessage aMessage)
Duplicate message handle.
GSCACTDLLCALL bool __stdcall | GscAct_CloneHandle (ConstHGscMessage aMessage, HGscMessage &ClonedMessage)
Clone message handle.
GSCACTDLLCALL bool __stdcall | GscAct_GetReferenceCounter (ConstHGscMessage aMessage, int &RefCounter)
Get reference counter.
GSCACTDLLCALL bool __stdcall | GscAct_GetMessageClass (ConstHGscMessage aMessage, GscMessageClass &aClass)
Get class of the message.
GSCACTDLLCALL bool __stdcall | GscAct_GetInternalIndex (ConstHGscMessage aMessage, int &InternalIndex)
Get internal index of the message.
GSCACTDLLCALL bool __stdcall | GscAct_GetInternalData (ConstHGscMessage aMessage, void *&InternalData)
Get internal data.
GSCACTDLLCALL bool __stdcall | GscAct_SetInternalData (HGscMessage aMessage, void *InternalData)
Set internal data.
GSCACTDLLCALL bool __stdcall | GscAct_GetMessageFlags (ConstHGscMessage aMessage, unsigned __int32 &Flags)
Get flags of the message.
GSCACTDLLCALL bool __stdcall | GscAct_SetMessageFlags (HGscMessage aMessage, unsigned __int32 Flags)
Set flags of the message.
GSCACTDLLCALL bool __stdcall | GscAct_Equal (ConstHGscMessage aMessage1, ConstHGscMessage aMessage2, bool &Result)
Compare messages.
GSCACTDLLCALL HGscMessage __stdcall | GscAct_CreateFromBinBuffer (const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass, unsigned int *ReadBytes)
Create message from different buffers.
GSCACTDLLCALL HGscMessage __stdcall | GscAct_CreateFromTextBufferA (const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass, bool UseUTF8Encoding, unsigned int *ReadChars)
Create message from ANSI text buffer.
GSCACTDLLCALL HGscMessage __stdcall | GscAct_CreateFromTextBufferW (const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass, bool UseUTF8Encoding, unsigned int *ReadChars)
Create message from UNICODE text buffer.
GSCACTDLLCALL bool __stdcall | GscAct_StoreToBinBuffer (ConstHGscMessage aMessage, void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten)
Write message to the binary buffer.
GSCACTDLLCALL bool __stdcall | GscAct_StoreToTextBufferA (ConstHGscMessage aMessage, char *Buffer, unsigned int BufferSize, bool OutputAsPlainText, bool UseUTF8Encoding, unsigned int *CharsWritten)
Write message to the text buffer as ANSI string.
GSCACTDLLCALL bool __stdcall | GscAct_StoreToTextBufferW (ConstHGscMessage aMessage, wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText, bool UseUTF8Encoding, unsigned int *CharsWritten)
Write message to the text buffer as UNICODE string.

Define Documentation

#define GscAct_CreateFromTextBuffer GscAct_CreateFromTextBufferA

Definition at line 694 of file GscActions.h.

#define GscAct_StoreToTextBuffer GscAct_StoreToTextBufferA

Definition at line 770 of file GscActions.h.

Function Documentation

GSCACTDLLCALL bool __stdcall GscAct_CloseHandle ( HGscMessage aMessage )

Close message handle.

If the reference counter is 0, free used memory.

Parameters:
[in] aMessage handle to message.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_DuplicateHandle ( HGscMessage aMessage )

Duplicate message handle.

Increase the reference counter.

Parameters:
[in] aMessage handle to message.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_CloneHandle | ( | ConstHGscMessage | aMessage,
 |  | HGscMessage & | ClonedMessage
 | ) |  |

Clone message handle.

Create a new object with the same content.

Parameters:
[in] | aMessage | Handle to message.
[out] | ClonedMessage | Clone of the message.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetReferenceCounter | ( | ConstHGscMessage | aMessage,
 |  | int & | RefCounter
 | ) |  |

Get reference counter.

Parameters:
[in] | aMessage | Handle to message.
[out] | RefCounter | Field to store reference counter.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetMessageClass | ( | ConstHGscMessage | aMessage,
 |  | GscMessageClass & | aClass
 | ) |  |

Get class of the message.

Parameters:
[in] | aMessage | Handle to message.
[out] | aClass | Field to store message class.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetInternalIndex | ( | ConstHGscMessage | aMessage,
 |  | int & | InternalIndex
 | ) |  |

Get internal index of the message.

Parameters:
[in] | aMessage | Handle to message.
[out] | InternalIndex | Field to store the internal index.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetInternalData | ( | ConstHGscMessage | aMessage,
 |  | void *& | InternalData
 | ) |  |

Get internal data.

You can use this field as temporary storage for user specific data.

Parameters:
[in] | aMessage | Handle to message.
[out] | InternalData | Field to store the internal data.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetInternalData | ( | HGscMessage | aMessage,
 |  | void * | InternalData
 | ) |  |

Set internal data.

You can use this field as temporary storage for user specific data.

Parameters:
[in] | aMessage | Handle to message.
[in] | InternalData | Field with the internal data.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetMessageFlags | ( | ConstHGscMessage | aMessage,
 |  | unsigned __int32 & | Flags
 | ) |  |

Get flags of the message.

Parameters:
[in] | aMessage | Handle to message.
[out] | Flags | Field to store flags
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetMessageFlags | ( | HGscMessage | aMessage,
 |  | unsigned __int32 | Flags
 | ) |  |

Set flags of the message.

Parameters:
[in] | aMessage | Handle to message.
[in] | Flags | Field with new flags
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_Equal | ( | ConstHGscMessage | aMessage1,
 |  | ConstHGscMessage | aMessage2,
 |  | bool & | Result
 | ) |  |

Compare messages.

Parameters:
[in] | aMessage1 | Handle to first message.
[in] | aMessage2 | Handle to second message.
[out] | Result | Field to store the internal data.
Returns:
true if succeeds, false otherwise.
Attention:
Result of comparision is stored in Result field, NOT in return value!
GSCACTDLLCALL HGscMessage __stdcall GscAct_CreateFromBinBuffer | ( | const void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass,
 |  | unsigned int * | ReadBytes
 | ) |  |

Create message from different buffers.

Create message from binary buffer.

Parameters:
[in] | Buffer | Pointer to buffer with binary representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[out] | ReadBytes | Points to the variable where the number of read bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
GSCACTDLLCALL HGscMessage __stdcall GscAct_CreateFromTextBufferA | ( | const char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass,
 |  | bool | UseUTF8Encoding,
 |  | unsigned int * | ReadChars
 | ) |  |

Create message from ANSI text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding ANSI to UNICODE.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.
GSCACTDLLCALL HGscMessage __stdcall GscAct_CreateFromTextBufferW | ( | const wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass,
 |  | bool | UseUTF8Encoding,
 |  | unsigned int * | ReadChars
 | ) |  |

Create message from UNICODE text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding UNICODE to ANSI.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.
GSCACTDLLCALL bool __stdcall GscAct_StoreToBinBuffer | ( | ConstHGscMessage | aMessage,
 |  | void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | unsigned int * | BytesWritten
 | ) |  |

Write message to the binary buffer.

Parameters:
[in] | aMessage | Handle to message.
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[out] | BytesWritten | Points to the variable where the number of written bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
GSCACTDLLCALL bool __stdcall GscAct_StoreToTextBufferA | ( | ConstHGscMessage | aMessage,
 |  | char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText,
 |  | bool | UseUTF8Encoding,
 |  | unsigned int * | CharsWritten
 | ) |  |

Write message to the text buffer as ANSI string.

Parameters:
[in] | aMessage | Handle to message.
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode UNICODE to ANSI.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!
GSCACTDLLCALL bool __stdcall GscAct_StoreToTextBufferW | ( | ConstHGscMessage | aMessage,
 |  | wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText,
 |  | bool | UseUTF8Encoding,
 |  | unsigned int * | CharsWritten
 | ) |  |

Write message to the text buffer as UNICODE string.

Parameters:
[in] | aMessage | Handle to message.
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode ANSI to UNICODE.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!


GSC actions: Action functions

Defines | Functions

Action functions
[Messages / actions]

Collaboration diagram for Action functions:

Detailed Description

Low level API functions to work with actions.

General information about actions.

Defines

#define | GscAct_GetActionName GscAct_GetActionNameA
#define | GscAct_GetActionPlainName GscAct_GetActionPlainNameA

Functions

GSCACTDLLCALL bool __stdcall | GscAct_GetActionClass (ConstHGscAction anAction, GscActionClass &ActionClass)
Get class of the action.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionCode (ConstHGscAction anAction, GscActionCode &ActionCode)
Get code of the action.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionNameA (ConstHGscAction anAction, const char *&ActionName)
Get action name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionNameW (ConstHGscAction anAction, const wchar_t *&ActionName)
Get action name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionPlainNameA (ConstHGscAction anAction, const char *&ActionName)
Get action plain name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionPlainNameW (ConstHGscAction anAction, const wchar_t *&ActionName)
Get action plain name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscAct_GetVideoInput (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Special information about some specific IDs used in the action.
GSCACTDLLCALL bool __stdcall | GscAct_GetVideoOutput (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Get used video output.
GSCACTDLLCALL bool __stdcall | GscAct_GetInputContact (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Get used input contact.
GSCACTDLLCALL bool __stdcall | GscAct_GetOutputContact (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Get used output contact.
GSCACTDLLCALL bool __stdcall | GscAct_GetForeignKey (ConstHGscAction anAction, const __int64 *&Key)
Get used foreign key.
GSCACTDLLCALL bool __stdcall | GscAct_GetGenericInt32Parameter (ConstHGscAction anAction, __int32 &aParam)
Get used generic 32-bit integer parameter.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGenericAction (const TPlcMediaChannelID *aVideoInput, const TPlcMediaChannelID *aVideoOutput, const TPlcMediaChannelID *anInputContact, const TPlcMediaChannelID *anOutputContact, __int32 aParam)
Create generic action generic action has only infos about some resources, nothing else it is intended to use only in GeViSoft / GeviScope interface.
GSCACTDLLCALL bool __stdcall | GscAct_UpdateActionInfo (HGscAction anAction, void *anObject, const TPlcUpdateActionInfoCallback &Callback, bool &UpdateOk)
Update action info.
GSCACTDLLCALL bool __stdcall | GscAct_UpdateWindowsClientInfo (HGscAction anAction, const wchar_t *localHostName, const PlcClientType localClientType, const wchar_t *localUserName)
Update windows client info.
GSCACTDLLCALL bool __stdcall | GscAct_GetWindowsClientInfo (HGscAction anAction, const wchar_t *&localHostName, const PlcClientType *&localClientType, const wchar_t *&localUserName)
GSCACTDLLCALL bool __stdcall | GscAct_SetProperty (HGscAction anAction, const wchar_t *Key, const wchar_t *Value)
Set action property.
GSCACTDLLCALL bool __stdcall | GscAct_GetProperty (HGscAction anAction, const wchar_t *Key, const wchar_t *&Value)
Get action property.
GSCACTDLLCALL bool __stdcall | GscAct_GetProperties (HGscAction anAction, const wchar_t *&Properties)
Get action properties.

Define Documentation

#define GscAct_GetActionName GscAct_GetActionNameA

Definition at line 840 of file GscActions.h.

#define GscAct_GetActionPlainName GscAct_GetActionPlainNameA

Definition at line 841 of file GscActions.h.

Function Documentation

GSCACTDLLCALL bool __stdcall GscAct_GetActionClass | ( | ConstHGscAction | anAction,
 |  | GscActionClass & | ActionClass
 | ) |  |

Get class of the action.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionClass | Field to store action class.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetActionCode | ( | ConstHGscAction | anAction,
 |  | GscActionCode & | ActionCode
 | ) |  |

Get code of the action.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionCode | Field to store action code.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetActionNameA | ( | ConstHGscAction | anAction,
 |  | const char *& | ActionName
 | ) |  |

Get action name as ANSI string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetActionNameW | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | ActionName
 | ) |  |

Get action name as UNICODE string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetActionPlainNameA | ( | ConstHGscAction | anAction,
 |  | const char *& | ActionName
 | ) |  |

Get action plain name as ANSI string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to plain action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetActionPlainNameW | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | ActionName
 | ) |  |

Get action plain name as UNICODE string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to plain action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetVideoInput | ( | ConstHGscAction | anAction,
 |  | const TPlcMediaChannelID *& | ID
 | ) |  |

Special information about some specific IDs used in the action.

Get used video input.

Parameters:
[in] | anAction | Handle to action.
[out] | ID | Field to store ID.
Returns:
true if succeeds, false otherwise.
Attention:
If the field is not available, the return value is true and ID gets NULL.
GSCACTDLLCALL bool __stdcall GscAct_GetVideoOutput | ( | ConstHGscAction | anAction,
 |  | const TPlcMediaChannelID *& | ID
 | ) |  |

Get used video output.

Parameters:
[in] | anAction | Handle to action.
[out] | ID | Field to store ID.
Returns:
true if succeeds, false otherwise.
Attention:
If the field is not available, the return value is true and ID gets NULL.
GSCACTDLLCALL bool __stdcall GscAct_GetInputContact | ( | ConstHGscAction | anAction,
 |  | const TPlcMediaChannelID *& | ID
 | ) |  |

Get used input contact.

Parameters:
[in] | anAction | Handle to action.
[out] | ID | Field to store ID.
Returns:
true if succeeds, false otherwise.
Attention:
If the field is not available, the return value is true and ID gets NULL.
GSCACTDLLCALL bool __stdcall GscAct_GetOutputContact | ( | ConstHGscAction | anAction,
 |  | const TPlcMediaChannelID *& | ID
 | ) |  |

Get used output contact.

Parameters:
[in] | anAction | Handle to action.
[out] | ID | Field to store ID.
Returns:
true if succeeds, false otherwise.
Attention:
If the field is not available, the return value is true and ID gets NULL.
GSCACTDLLCALL bool __stdcall GscAct_GetForeignKey | ( | ConstHGscAction | anAction,
 |  | const __int64 *& | Key
 | ) |  |

Get used foreign key.

Parameters:
[in] | anAction | Handle to action.
[out] | Key | Field to store the foreign key.
Returns:
true if succeeds, false otherwise.
Attention:
If the field is not available, the return value is true and Key gets NULL.
GSCACTDLLCALL bool __stdcall GscAct_GetGenericInt32Parameter | ( | ConstHGscAction | anAction,
 |  | __int32 & | aParam
 | ) |  |

Get used generic 32-bit integer parameter.

Parameters:
[in] | anAction | Handle to action.
[out] | aParam | Field to store the paarameter.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGenericAction | ( | const TPlcMediaChannelID * | aVideoInput,
 |  | const TPlcMediaChannelID * | aVideoOutput,
 |  | const TPlcMediaChannelID * | anInputContact,
 |  | const TPlcMediaChannelID * | anOutputContact,
 |  | __int32 | aParam
 | ) |  |

Create generic action generic action has only infos about some resources, nothing else it is intended to use only in GeViSoft / GeviScope interface.

Parameters:
[in] | aVideoInput | Video input resource
[in] | aVideoOutput | Video output resource
[in] | anInputContact | Input contact resource
[in] | anOutputContact | Output contact resource
[in] | aParam | 32-bit integer parameter
Returns:
Handle to created message or NULL if the function fails.
GSCACTDLLCALL bool __stdcall GscAct_UpdateActionInfo | ( | HGscAction | anAction,
 |  | void * | anObject,
 |  | const TPlcUpdateActionInfoCallback & | Callback,
 |  | bool & | UpdateOk
 | ) |  |

Update action info.

Parameters:
[in] | anAction | Handle to action.
[in] | anObject | Proxy object to pass to callback.
[in] | Callback | Callback functions.
[out] | UpdateOk | Update successfull or not.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_UpdateWindowsClientInfo | ( | HGscAction | anAction,
 |  | const wchar_t * | localHostName,
 |  | const PlcClientType | localClientType,
 |  | const wchar_t * | localUserName
 | ) |  |

Update windows client info.

Parameters:
[in] | anAction | Handle to action.
[in] | localHostName | Local Windows host name
[in] | localClientType | Local client type
[in] | localUserName | Local Windows user name
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetWindowsClientInfo | ( | HGscAction | anAction,
 |  | const wchar_t *& | localHostName,
 |  | const PlcClientType *& | localClientType,
 |  | const wchar_t *& | localUserName
 | ) |  |
GSCACTDLLCALL bool __stdcall GscAct_SetProperty | ( | HGscAction | anAction,
 |  | const wchar_t * | Key,
 |  | const wchar_t * | Value
 | ) |  |

Set action property.

Parameters:
[in] | anAction | Handle to action.
[in] | Key | Property key.
[in] | Value | Property value.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetProperty | ( | HGscAction | anAction,
 |  | const wchar_t * | Key,
 |  | const wchar_t *& | Value
 | ) |  |

Get action property.

Parameters:
[in] | anAction | Handle to action.
[in] | Key | Property key.
[out] | Value | Property value.
Returns:
true if succeeds, false otherwise.
Attention:
If the property does not exist, the return value is true and Value gets NULL.
GSCACTDLLCALL bool __stdcall GscAct_GetProperties | ( | HGscAction | anAction,
 |  | const wchar_t *& | Properties
 | ) |  |

Get action properties.

Parameters:
[in] | anAction | Handle to action.
[out] | Properties | Properties.
Returns:
true if succeeds, false otherwise.


GSC actions: Match action functions

Defines | Functions

Match action functions
[Messages / actions]

Collaboration diagram for Match action functions:

Detailed Description

Low level API functions to work with match actions.

Defines

#define | GscMatchAct_GetActionName GscMatchAct_GetActionNameA
#define | GscMatchAct_GetActionPlainName GscMatchAct_GetActionPlainNameA
#define | GscMatchAct_GetDescription GscMatchAct_GetDescriptionA
#define | GscMatchAct_SetDescription GscMatchAct_SetDescriptionA
#define | GscMatchAct_GetComment GscMatchAct_GetCommentA
#define | GscMatchAct_SetComment GscMatchAct_SetCommentA

Functions

GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionClass (ConstHGscMatchAction anAction, GscActionClass &ActionClass)
Get class of the action.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionCode (ConstHGscMatchAction anAction, GscActionCode &ActionCode)
Get code of the action.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionNameA (ConstHGscMatchAction anAction, const char *&ActionName)
Get action name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionNameW (ConstHGscMatchAction anAction, const wchar_t *&ActionName)
Get action name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionPlainNameA (ConstHGscMatchAction anAction, const char *&ActionName)
Get action plain name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionPlainNameW (ConstHGscMatchAction anAction, const wchar_t *&ActionName)
Get action plain name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_HasDescription (ConstHGscMatchAction anAction, bool &Description)
Check description of the match action.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetDescriptionA (ConstHGscMatchAction anAction, const char *&Description)
Get description of the match action as ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetDescriptionW (ConstHGscMatchAction anAction, const wchar_t *&Description)
Get description of the match action as UNICODE string.
bool | GscMatchAct_GetCommentA (ConstHGscMatchAction anAction, const char *&Description)
Alias to GscMatchAct_GetDescriptionA.
bool | GscMatchAct_GetCommentW (ConstHGscMatchAction anAction, const wchar_t *&Description)
Alias to GscMatchAct_GetDescriptionW.
GSCACTDLLCALL bool __stdcall | GscMatchAct_SetDescriptionA (HGscMatchAction anAction, const char *Description)
Set description of the match action from ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_SetDescriptionW (HGscMatchAction anAction, const wchar_t *Description)
Set description of the match action from UNICODE string.
bool | GscMatchAct_SetCommentA (HGscMatchAction anAction, const char *Description)
Alias to GscMatchAct_SetDescriptionA.
bool | GscMatchAct_SetCommentW (HGscMatchAction anAction, const wchar_t *Description)
Alias to GscMatchAct_SetDescriptionW.
GSCACTDLLCALL bool __stdcall | GscMatchAct_Matches (ConstHGscMatchAction aMatchAction, ConstHGscAction anAction, bool &Result)
Working with match actions.
GSCACTDLLCALL bool __stdcall | GscMatchAct_CreateActionFromTemplate (ConstHGscMatchAction aMatchAction, ConstHGscAction aTemplate, HGscAction &Result)
Create action from the match action and provided action as template.
GSCACTDLLCALL bool __stdcall | GscAct_CreateMatchActionFromTemplate (ConstHGscAction anAction, HGscMatchAction &Result)
Create match action from the action.

Define Documentation

#define GscMatchAct_GetActionName GscMatchAct_GetActionNameA

Definition at line 1141 of file GscActions.h.

#define GscMatchAct_GetActionPlainName GscMatchAct_GetActionPlainNameA

Definition at line 1142 of file GscActions.h.

#define GscMatchAct_GetDescription GscMatchAct_GetDescriptionA

Definition at line 1143 of file GscActions.h.

#define GscMatchAct_SetDescription GscMatchAct_SetDescriptionA

Definition at line 1144 of file GscActions.h.

#define GscMatchAct_GetComment GscMatchAct_GetCommentA

Definition at line 1145 of file GscActions.h.

#define GscMatchAct_SetComment GscMatchAct_SetCommentA

Definition at line 1146 of file GscActions.h.

Function Documentation

GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionClass | ( | ConstHGscMatchAction | anAction,
 |  | GscActionClass & | ActionClass
 | ) |  |

Get class of the action.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionClass | Field to store action class.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionCode | ( | ConstHGscMatchAction | anAction,
 |  | GscActionCode & | ActionCode
 | ) |  |

Get code of the action.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionCode | Field to store action code.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionNameA | ( | ConstHGscMatchAction | anAction,
 |  | const char *& | ActionName
 | ) |  |

Get action name as ANSI string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionNameW | ( | ConstHGscMatchAction | anAction,
 |  | const wchar_t *& | ActionName
 | ) |  |

Get action name as UNICODE string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionPlainNameA | ( | ConstHGscMatchAction | anAction,
 |  | const char *& | ActionName
 | ) |  |

Get action plain name as ANSI string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to plain action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionPlainNameW | ( | ConstHGscMatchAction | anAction,
 |  | const wchar_t *& | ActionName
 | ) |  |

Get action plain name as UNICODE string.

Parameters:
[in] | anAction | Handle to action.
[out] | ActionName | Field to store reference to plain action name.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_HasDescription | ( | ConstHGscMatchAction | anAction,
 |  | bool & | Description
 | ) |  |

Check description of the match action.

Parameters:
[in] | anAction | Handle to action.
[out] | Description | Field to store the result.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetDescriptionA | ( | ConstHGscMatchAction | anAction,
 |  | const char *& | Description
 | ) |  |

Get description of the match action as ANSI string.

Parameters:
[in] | anAction | Handle to action.
[out] | Description | Field to store the result.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetDescriptionW | ( | ConstHGscMatchAction | anAction,
 |  | const wchar_t *& | Description
 | ) |  |

Get description of the match action as UNICODE string.

Parameters:
[in] | anAction | Handle to action.
[out] | Description | Field to store the result.
Returns:
true if succeeds, false otherwise.
bool GscMatchAct_GetCommentA | ( | ConstHGscMatchAction | anAction,
 |  | const char *& | Description |
 | ) |  |  | [inline]

Alias to GscMatchAct_GetDescriptionA.

Definition at line 1084 of file GscActions.h.

bool GscMatchAct_GetCommentW | ( | ConstHGscMatchAction | anAction,
 |  | const wchar_t *& | Description |
 | ) |  |  | [inline]

Alias to GscMatchAct_GetDescriptionW.

Definition at line 1092 of file GscActions.h.

GSCACTDLLCALL bool __stdcall GscMatchAct_SetDescriptionA | ( | HGscMatchAction | anAction,
 |  | const char * | Description
 | ) |  |

Set description of the match action from ANSI string.

Parameters:
[in] | anAction | Handle to action.
[in] | Description | User provided comment.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_SetDescriptionW | ( | HGscMatchAction | anAction,
 |  | const wchar_t * | Description
 | ) |  |

Set description of the match action from UNICODE string.

Parameters:
[in] | anAction | Handle to action.
[in] | Description | User provided comment.
Returns:
true if succeeds, false otherwise.
bool GscMatchAct_SetCommentA | ( | HGscMatchAction | anAction,
 |  | const char * | Description |
 | ) |  |  | [inline]

Alias to GscMatchAct_SetDescriptionA.

Definition at line 1118 of file GscActions.h.

bool GscMatchAct_SetCommentW | ( | HGscMatchAction | anAction,
 |  | const wchar_t * | Description |
 | ) |  |  | [inline]

Alias to GscMatchAct_SetDescriptionW.

Definition at line 1126 of file GscActions.h.

GSCACTDLLCALL bool __stdcall GscMatchAct_Matches | ( | ConstHGscMatchAction | aMatchAction,
 |  | ConstHGscAction | anAction,
 |  | bool & | Result
 | ) |  |

Working with match actions.

Matches action.

Parameters:
[in] | aMatchAction | Handle to match action.
[in] | anAction | Handle to action.
[out] | Result | Field to store the result.
Returns:
true if succeeds, false otherwise.
Attention:
Result of test is stored in Result field, NOT in return value!
GSCACTDLLCALL bool __stdcall GscMatchAct_CreateActionFromTemplate | ( | ConstHGscMatchAction | aMatchAction,
 |  | ConstHGscAction | aTemplate,
 |  | HGscAction & | Result
 | ) |  |

Create action from the match action and provided action as template.

Parameters:
[in] | aMatchAction | Handle to match action.
[in] | aTemplate | Action to use as template to take available fields from.
[out] | Result | Field to store the result.
Returns:
true if succeeds, false otherwise.
Attention:
aTemplate can be NULL if you don't use it.
GSCACTDLLCALL bool __stdcall GscAct_CreateMatchActionFromTemplate | ( | ConstHGscAction | anAction,
 |  | HGscMatchAction & | Result
 | ) |  |

Create match action from the action.

Parameters:
[in] | anAction | Handle to match action.
[out] | Result | Field to store the result.
Returns:
true if succeeds, false otherwise.


GSC actions: Output operators

Output operators
[Messages / actions]

Collaboration diagram for Output operators:

Simplify input / output operation with messages.

Add unit "GscActionsOutput.cpp" to your project and include following lines in your code:

   #include "GscActionsOutput.h"
   using namespace GscPLC;


GSC actions: Create / decode functions

Modules

Create / decode functions

Collaboration diagram for Create / decode functions:

Detailed Description

This module describes functions used to create and decode specific actions.

   #include "GscActions.h"
   using namespace GscPLC;

Functions to create actions have following syntax: prefix GscAct_Create followed by the name of the action. List of parameters can be found in the function description or the action reference.

In general, parameters passed to the function using by-value semantics. This rule has three exceptions:

  • Parameter is of structural type like TGLibDateTime. In this case we pass parameters by const reference.
  • Parameter is of type that is larger than 32-bit like __int64. In this case we pass parameters by const reference.
  • Parameter is optional. In this case functions expect pointer to const object. NULL is a valid value in this case.
    Please note that strings are passed as const char* (resp. const wchar_t* for UNICODE) in both cases.

Example how to create an action:

   HGscAction anAction;

   anAction = GscAct_CreateUserLogin(L"sysadmin", NULL, L"localhost");
   if (anAction == NULL)
   {
     // error handling
   }

Functions to decode actions have following syntax: prefix GscAct_Decode followed by the name of the action. First parameter is the const handle of the action to decode followed by action's parameters. List of parameters can be found in the function description or the action reference.

In general, parameters passed to the function using reference semantics. This rule has the following exception:

  • Parameter is optional. In this case functions expect the reference to the pointer to const object. The return value in this parameter can be NULL.
    Please note that strings are passed as const char*& (resp. const wchar_t*& for UNICODE) in both cases.

Example how to decode an action:

   const wchar_t* firstUser;
   const wchar_t* secondUser;
   const wchar_t* host;

   if (! GscAct_DecodeUserLogin(anAction, firstUser, secondUser, host))
   {
     // error handling
   }

Modules

Functions to create GSC actions

This module describes functions used to create specific actions.

Functions to decode GSC actions

This module describes functions used to decode specific actions.


GSC actions: Functions to create GSC actions

Functions

Functions to create GSC actions
[Create / decode functions]

Collaboration diagram for Functions to create GSC actions:

Detailed Description

This module describes functions used to create specific actions.

Create functions.

   #include "GscActions.h"
   using namespace GscPLC;

These functions have following syntax: prefix GscAct_Create followed by the name of the action. List of parameters can be found in the function description or the action reference.

In general, parameters passed to the function using by-value semantics. This rule has three exceptions:

  • Parameter is of structural type like TGLibDateTime. In this case we pass parameters by const reference.
  • Parameter is of type that is larger than 32-bit like __int64. In this case we pass parameters by const reference.
  • Parameter is optional. In this case functions expect pointer to const object. NULL is a valid value in this case.
    Please note that strings are passed as const char* (resp. const wchar_t* for UNICODE) in both cases.

Example how to create an action:

   HGscAction anAction;

   anAction = GscAct_CreateUserLogin(L"sysadmin", NULL, L"localhost");
   if (anAction == NULL)
   {
     // error handling
   }

Functions

GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateABCConnect (const wchar_t *aAddress)
Create action 'ABC connect'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateABCDisconnect ()
Create action 'ABC disconnect'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateABCPlayFile (const __int64 &aFileID, const wchar_t *aFileName, const bool aAutoRepeat)
Create action 'ABC play file'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAbortAllAutoBackups ()
Create action 'Abort all auto backups'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAbortAutoBackup (const TPlcResourceID &aSchedule)
Create action 'Abort auto backup'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSAccessDenied (const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp, const __int32 *aReason)
Create action 'ACS access denied'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSAccessGranted (const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp)
Create action 'ACS access granted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSRawAnswer (const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData)
Create action 'ACS raw answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSRawData (const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData)
Create action 'ACS raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateActivateExternalProcess (const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const VideoSensorKind aExternalSystem)
Create action 'Activate external process'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateATMRawAnswer (const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData)
Create action 'ATM raw answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateATMRawData (const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData)
Create action 'ATM raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateATMTransaction (const wchar_t *aATMName, const bool aNewTransaction, const __int32 aPhotostep, const __int32 *aATMNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const __int64 *aTAN1, const __int64 *aTAN2, const TGLibDateTime *aTimeStamp1, const TGLibDateTime *aTimeStamp2, const double *aAmount, const wchar_t *aCurrency)
Create action 'ATM transaction'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupCapacityMonitoringCapacityWarning (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf)
Create action 'Auto backup capacity warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupCapacityMonitoringFileAutoDeleted (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf, const __int64 &aFileSize, const wchar_t *aFileName)
Create action 'Auto backup capacity file auto deleted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupCapacityMonitoringOutOfDiskSpace (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf)
Create action 'Auto backup capacity out of disk space'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupFileDone (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Auto backup file done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupFileProgress (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Auto backup file progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupFileStarted (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName)
Create action 'Auto backup file started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupOperationDone (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TGLibDateTime &aOperationStopTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 *aOperationErrorCode)
Create action 'Auto backup operation done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupOperationStarted (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit)
Create action 'Auto backup operation started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupScheduleDone (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const TGLibDateTime &aStopTime, const __int32 aOperationCount, const bool aTimerStart)
Create action 'Auto backup schedule done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupScheduleStarted (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart)
Create action 'Auto backup schedule started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoFocusOff (const TPlcMediaChannelID &aCamera)
Create action 'Auto focus off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoFocusOn (const TPlcMediaChannelID &aCamera)
Create action 'Auto focus on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBackupEvent (const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID &aDestination, const __int64 *aStartHintID, const __int64 *aStopHintID, const wchar_t *aSubfolder)
Create action 'Backup event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBarcodeData (const wchar_t *aReaderName, const TGLibDateTime &aTimeStamp, const wchar_t *aBarcode)
Create action 'Barcode data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBlockingFilterActivate (const wchar_t *aFilter)
Create action 'Blocking filter activate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBlockingFilterDeactivate (const wchar_t *aFilter)
Create action 'Blocking filter deactivate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraApplyProfile (const TPlcMediaChannelID &aCamera, const wchar_t *aProfile)
Create action 'Camera apply profile'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraBacklightCompensationMode (const TPlcMediaChannelID &aCamera, const PlcBacklightMode aMode)
Create action 'Camera backlight compensation mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraClearPrePosText (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Camera clear preset text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraDayNightMode (const TPlcMediaChannelID &aCamera, const PlcDayNightMode aMode)
Create action 'Camera day/night mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraLightOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera light off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraLightOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera light on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraManualIrisOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera manual iris off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraManualIrisOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera manual iris on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraPumpOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera pump off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraPumpOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera pump on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraRAWOutput (const TPlcMediaChannelID &aCamera, const char *aOutput)
Create action 'Camera RAW output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSelectCharMode (const TPlcMediaChannelID &aCamera, const __int32 aMode)
Create action 'Camera select char mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSetPrePosText (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Camera set preset text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncUOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func U off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncUOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func U on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncVOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func V off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncVOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func V on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncXOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func X off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncXOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func X on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncYOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func Y off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncYOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func Y on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraStopAll (const TPlcMediaChannelID &aCamera)
Create action 'Camera stop all'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTextOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera text off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTextOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera text on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTourStart (const TPlcMediaChannelID &aCamera, const __int32 aTourID, const char *aTourName)
Create action 'Camera tour start'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTourStop (const TPlcMediaChannelID &aCamera)
Create action 'Camera tour stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraVersionOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera version off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraVersionOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera version on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraWashOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera wash-wipe off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraWashOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera wash-wipe on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCancelExport (const GUID &aExportID, const PlcExportAbort aAbortFlag)
Create action 'Cancel export'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCaseClosed ()
Create action 'Case has been closed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCaseOpened ()
Create action 'Case has been opened'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeADParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change AD parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeCameraProfile (const TPlcResourceID &aHardwareModule, const TPlcResourceID &aCameraProfile)
Create action 'Change camera profile'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeCPAParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change CPA parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeGTectParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change GTectVMX parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeObtrackParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change OBTRACK parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeVMDParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change VMD parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelError (const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'Channel error'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelInfo (const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'Channel info'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelLiveCheck (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const TGLibDateTime &aTimeStamp)
Create action 'Channel live check'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelWarning (const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'Channel warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCPAMeasurement (const TPlcMediaChannelID &aChannel, const __int32 aCorrelation)
Create action 'CPA measurement'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCustomAction (const __int64 &aInt, const wchar_t *aString)
Create action 'Custom action'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDatabaseRecordingInfoRing (const PlcDatabaseRing aDatabaseRing, const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aRingCapacity, const TGLibDateTime &aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity)
Create action 'Database recording info per ring'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDatabaseRecordingInfoTotal (const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedCapacity, const TGLibDateTime *aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity, const double *aRequiredCapacityFactor, const bool *aRequiredCapacityAvailable)
Create action 'Database recording info total'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDatabaseStarted (const PlcDatabaseStatus aStatus, const __int64 &aTotalSize)
Create action 'Database started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDefaultPosCallUp (const TPlcMediaChannelID &aCamera)
Create action 'Move to default position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDefaultPosClear (const TPlcMediaChannelID &aCamera)
Create action 'Clear default position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDefaultPosSave (const TPlcMediaChannelID &aCamera)
Create action 'Save default position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceFound (const char *aType, const char *aName, const char *aSerial)
Create action 'Device found'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceNewFirmware (const char *aType, const char *aName, const char *aSerial, const char *aFirmware)
Create action 'New firmware received'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDevicePluginError (const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginError aErrorClass, const __int32 *aErrorCode, const char *aDescription)
Create action 'Device plugin error'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDevicePluginState (const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginState aState, const __int32 *aInternalState, const char *aDescription)
Create action 'Device plugin state'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceReattached (const char *aType, const char *aName, const char *aSerial)
Create action 'Device reattached'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceRemoved (const char *aType, const char *aName, const char *aSerial)
Create action 'Device removed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDigitalInput (const TPlcMediaChannelID &aContact, const DigitalInputState aState)
Create action 'Digital input'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupDone (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const __int32 *aOperationErrorCode)
Create action 'Event backup done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupFileDone (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Event backup file done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupFileProgress (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Event backup file progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupFileStarted (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName)
Create action 'Event backup file started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupStarted (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime)
Create action 'Event backup started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventRecordingChanged (const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
Create action 'Event recording changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventStartedEx (const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey)
Create action 'Event started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventStopped (const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
Create action 'Event stopped'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateExportFinished (const GUID &aExportID, const PlcExportSuccess aSuccess)
Create action 'Export finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateExportProgress (const GUID &aExportID, const __int32 aProgress)
Create action 'Export progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFastSpeedOff (const TPlcMediaChannelID &aCamera)
Create action 'Fast speed off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFastSpeedOn (const TPlcMediaChannelID &aCamera)
Create action 'Fast speed on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFillingPumpStatus (const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aPumpNo, const PlcPumpStatus aStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
Create action 'Filling pump status'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFocusFar (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Focus far'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFocusNear (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Focus near'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFocusStop (const TPlcMediaChannelID &aCamera)
Create action 'Focus stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFRCNotification (const PlcFRCNotification aNotification, const __int32 *aParam, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'FRC notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGEMOSalarm (const __int64 &aGEMOSkey, const __int32 aGEMOSint, const wchar_t *aGEMOSstr)
Create action 'GEMOS alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessDenied (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access denied'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessExpired (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const TGLibDateTime &aExpiringTime, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access expired'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessGranted (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access granted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessPending (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access pending'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectAnalyticsLiveCheck ()
Create action 'G-Tect analytics live check'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectDualSensorAlarm (const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea)
Create action 'G-Tect/Dual sensor alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectDualSensorAlarmFinished (const TPlcMediaChannelID &aChannel)
Create action 'G-Tect/Dual sensor alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectSceneAlarm (const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason)
Create action 'G-Tect scene alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectSceneAlarmFinished (const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason)
Create action 'G-Tect scene alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectVMXAlarm (const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const __int32 *aAlarmGroup, const __int32 *aTrackID, const TPlcRect *aAlarmArea)
Create action 'G-Tect/VMX alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectVMXAlarmFinished (const TPlcMediaChannelID &aChannel)
Create action 'G-Tect/VMX alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIASSettingsChanged (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'IAS settings changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImageExportNotification (const wchar_t *aUser, const wchar_t *aDestination, const PlcImageExportType aDestinationType, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aTimeEnd, const wchar_t *aChannels, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Image export notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexCapacityFileAutoDeleted (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile, const __int64 &aTotalFileSize, const __int32 aNumberOfFiles)
Create action 'Imex capacity file auto deleted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexCapacityOutOfDiskSpace (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile)
Create action 'Imex capacity out of disk space.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexCapacityWarning (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile)
Create action 'Imex capacity warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexExportEventImage (const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID *aDestination, const wchar_t *aFilePath)
Create action 'Imex export event image'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexExportImageFromDB (const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath, const TGLibDateTime *aPictureTime)
Create action 'Imex export image from DB'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexExportImageFromLiveStream (const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath)
Create action 'Imex export image from live stream'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateInitializeRemoteExport (const TPlcMediaChannelID &aViewer, const GUID &aDevice)
Create action 'Initialize remote export'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateInterfaceRawAnswer (const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData)
Create action 'Interface raw answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateInterfaceRawData (const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData)
Create action 'Interface raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43ResetMainboard ()
Create action 'IOI43 reset mainboard'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43Temperature (const wchar_t *aID, const __int32 aTemperature)
Create action 'IOI43 temperature notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43WDActivate ()
Create action 'IOI43 watchdog activate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43WDDeactivate ()
Create action 'IOI43 watchdog deactivate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43WDTrigger ()
Create action 'IOI43 watchdog trigger'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPCameraRawCommand (const wchar_t *aURL, const wchar_t *aUser, const wchar_t *aPassword, const wchar_t *aPOST)
Create action 'IP camera raw command'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPCamFailoverNotification (const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters)
Create action 'IP camera failover notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPCamFailoverRestore (const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters)
Create action 'IP camera failover restore'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPSwitchOperation (const IPSwitchOps aOperation, const wchar_t *aPort, const __int32 *aParam)
Create action 'IP switch operation'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIrisClose (const TPlcMediaChannelID &aCamera)
Create action 'Iris close'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIrisOpen (const TPlcMediaChannelID &aCamera)
Create action 'Iris open'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIrisStop (const TPlcMediaChannelID &aCamera)
Create action 'Iris stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKeyPressed (const SystemKey aKey)
Create action 'Key pressed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKeyReleased (const SystemKey aKey)
Create action 'Key released'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKillAllEvents ()
Create action 'Kill all events'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKillEvent (const TPlcEventTypeID &aTypeID)
Create action 'Kill event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKillEventByID (const __int64 &aEventID)
Create action 'Kill event by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelAccessEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int64 *aCardNumber, const LenelAccessResult *aAccessResult, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const __int32 *aAreaEnteredID, const __int32 *aAreaExitedID, const wchar_t *aAssetID, const bool *aCardholderEntered, const bool *aDuress, const __int32 *aElevatorFloor, const __int32 *aFacilityCode, const bool *aIsReadableCard, const __int32 *aIssueCode, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel access event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelFireEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aTroubleCode, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel fire event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelIntercomEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aIntercomData, const __int32 *aLineNumber, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel intercom event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelRawData (const TGLibDateTime &aTimeStamp, const wchar_t *aLenelData)
Create action 'Lenel raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelRefreshNames ()
Create action 'Lenel refresh names'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelSecurityEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel security event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelVideoEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aChannel, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const TGLibDateTime *aStartTime, const TGLibDateTime *aEndTime, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel video event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLiveCheck (const __int64 &aCounter, const TGLibDateTime &aDate)
Create action 'Live check'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLogBarcodeData (const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem)
Create action 'Log barcode data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLogBarcodeDataLPS (const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const double *aX, const double *aY, const double *aZ, const __int32 *aLpsTagID, const PlcLpsStatus *aLpsStatus, const __int32 *aLpsCellID, const __int32 *aLpsAreaID, const __int32 *aUserParam, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem)
Create action 'Log barcode data LPS'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLogNPRRecognition (const wchar_t *aPlateNo, const __int64 *aHash, const wchar_t *aCountry, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const PlcNPRRestriction *aRestriction, const wchar_t *aCategory)
Create action 'Log NPR recognition'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLPSPositionData (const __int32 aTagID, const wchar_t *aScannerID, const __int64 &aX, const __int64 &aY, const __int64 *aZ, const double *aLatitude, const double *aLongitude, const __int32 aAreaID, const __int32 *aCellID, const PlcLpsStatus aStatus, const TGLibDateTime *aTimeStamp, const wchar_t *aData, const wchar_t *aAreaName)
Create action 'LPS position data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLPSQueryPosition (const __int32 aTagID, const wchar_t *aScannerID, const wchar_t *aData)
Create action 'LPS query position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMakeCPAReferenceImage (const TPlcMediaChannelID &aChannel)
Create action 'Make CPA reference image'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMediaChannelSetupInfo (const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const wchar_t *aParameter)
Create action 'Media channel setup'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMoveToAbsolutePosition (const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta)
Create action 'Move to absolute position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMoveToBySpeed (const TPlcMediaChannelID &aCamera, const double &aSpeedAlpha, const double &aSpeedBeta)
Create action 'Move by speed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMoveToRelativePosition (const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta)
Create action 'Move to relative position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateNPRRawData (const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const __int32 aWeight, const __int32 aZoneState, const __int32 aZonePlace, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const bool aCurBest, const __int32 aPlateWidth, const __int32 aPlateHeight, const __int32 aPlateAngle, const __int32 aSymHeight, const wchar_t *aType)
Create action 'NPR raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateNPRRecognition (const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const PlcNPRRestriction aRestriction, const wchar_t *aCategory, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const wchar_t *aType, const __int32 aWeight)
Create action 'NPR recognition'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackChannelCounter (const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp)
Create action 'OBTRACK channel counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackChannelCounterThreshold (const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp)
Create action 'OBTRACK channel counter threshold'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackChannelSetCounter (const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp)
Create action 'OBTRACK channel set counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackFrameRawData (const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aBrightness, const __int32 aContrast)
Create action 'OBTRACK frame raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackGroupCounter (const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp, const wchar_t *aGroupName)
Create action 'OBTRACK group counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackGroupCounterThreshold (const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName)
Create action 'OBTRACK group counter threshold'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackGroupSetCounter (const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName)
Create action 'OBTRACK group set counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackObjectRawData (const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aArea, const __int32 aObjectID, const PlcObtrackObjectStatus aObjectStatus, const PlcObtrackObjectClass aObjectClass, const __int32 *aConfidence, const TPlcRect *aPosition, const double *aSpeed, const __int32 *aDuration, const __int32 *aDirection, const double *aSize, const double *aObjectWidth, const double *aObjectHeight, const PlcObtrackProcessSize *aProcessSize, const char *aGscNetName)
Create action 'OBTRACK object raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackTunnelAlarm (const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const PlcTunnelAlarmReason aAlarmReason, const __int32 aObjectID, const __int32 aAlarmAreaID, const TPlcRect *aObjectArea)
Create action 'OBTRACK tunnel alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanAuto (const TPlcMediaChannelID &aCamera, const __int32 aModus)
Create action 'Pan auto'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanLeft (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Pan left'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanRight (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Pan right'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanStop (const TPlcMediaChannelID &aCamera)
Create action 'Pan stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePOSData (const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const wchar_t *aArticle, const double *aPrice, const __int32 *aUnits, const double *aPricePerUnit, const wchar_t *aLine1, const wchar_t *aLine2, const wchar_t *aLine3, const wchar_t *aLine4, const wchar_t *aLine5)
Create action 'POS data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePOSStatus (const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const PlcPOSStatus aStatus, const wchar_t *aDetails)
Create action 'POS status'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceAlarm (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPSensorKind aSensor, const PPAlarmState aState)
Create action 'PP device alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceInput (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aInput, const PPAlarmState aState)
Create action 'PP device input'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceOffline (const wchar_t *aInterfaceID, const __int32 aDeviceAddress)
Create action 'PP device offline'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceOnline (const wchar_t *aInterfaceID, const __int32 aDeviceAddress)
Create action 'PP device online'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPInterfaceOffline (const wchar_t *aInterfaceID)
Create action 'PP interface offline'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPInterfaceOnline (const wchar_t *aInterfaceID)
Create action 'PP interface online'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPQueryInterface (const wchar_t *aInterfaceID)
Create action 'PP query interface'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPSetDeviceOutput (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aOutput, const PPAlarmState aState)
Create action 'PP set device output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPSubcellAlarm (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind aCable, const __int32 aSubcell, const PPAlarmState aState)
Create action 'PP subcell alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPZoneAlarm (const wchar_t *aZoneID, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind *aCable, const __int32 *aSubcell, const PPAlarmState aState)
Create action 'PP zone alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePrePosCallUp (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Move to preset position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePrePosClear (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Clear preset position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePrePosSave (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Save preset position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateRedundantPowerFailure ()
Create action 'Redundant power failure'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateRedundantPowerOk ()
Create action 'Redundant power ok'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateResetMainboard ()
Create action 'Reset mainboard'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagClose (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques)
Create action 'Safebag close'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagData (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques)
Create action 'Safebag data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagOpen (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID)
Create action 'Safebag open'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagPassingOfRiskData (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
Create action 'Safebag passing of risk data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagPassingOfRiskStart (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
Create action 'Safebag passing of risk start'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagPassingOfRiskStop (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
Create action 'Safebag passing of risk stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSceneStoreModification (const TPlcMediaChannelID &aViewer, const GUID &aSceneStoreID, const wchar_t *aSceneStoreName, const TGLibDateTime &aTimeStamp, const PlcSceneStoreModificationType aModificationType, const wchar_t *aUser, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Scene store modification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorAlarmFinished (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'Sensor alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorAudioAlarm (const TPlcMediaChannelID &aChannel)
Create action 'Sensor audio alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorInhibitAlarmFinished (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'Sensor inhibit alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorInhibitVideoAlarmEx (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass)
Create action 'Sensor inhibit video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorVideoAlarmEx (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass)
Create action 'Sensor video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetCameraText (const TPlcMediaChannelID &aCamera, const char *aText)
Create action 'Set camera text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetClientVCA (const TPlcMediaChannelID &aChannel, const GTectClientVCAType aClientVCAType, const bool aEnabled)
Create action 'Enable client VCA'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetClock (const TGLibDateTime &aDate)
Create action 'Set clock'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetDigitalOutput (const TPlcMediaChannelID &aContact, const DigitalOutputState aState)
Create action 'Set digital output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetExportMarker (const TPlcMediaChannelID &aViewer, const PlcExportMarker aMarker)
Create action 'Set export marker'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetLED (const SystemLED aLED, const DigitalOutputState aState)
Create action 'Set system LED'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetLEDBlink (const SystemLED aLED, const __int32 aLedTimeOnMs, const __int32 aLedTimeOffMs)
Create action 'Set system LED to blink'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetSystemTime (const TGLibDateTime &aTimeStamp)
Create action 'Set system time'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetTestPictureMode (const TPlcMediaChannelID &aChannel, const bool aMode)
Create action 'Set test picture mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetupChanged (const wchar_t *aUser, const wchar_t *aHost, const TGLibDateTime &aDate, const PlcResourceKind aResourceKind, const TPlcEventTypeID &aResourceID, const PlcResourceChangeKind aChangeKind, const wchar_t *aDetails, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Setup changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetupUploadProgress (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const __int32 aProgress, const TGLibDateTime &aDate)
Create action 'Setup upload progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetWatchdog (const __int32 aTimeout)
Create action 'Set watchdog'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataControl (const wchar_t *aInterfaceName, const PlcSkidataControl aData)
Create action 'SKIDATA control'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataDeviceEvent (const wchar_t *aInterfaceName, const __int32 aDeviceID, const __int32 aEventCode)
Create action 'SKIDATA device event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataEntry (const wchar_t *aInterfaceName, const PlcSkidataMsgCodeEntry aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
Create action 'SKIDATA entry'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataExit (const wchar_t *aInterfaceName, const PlcSkidataMsgCodeExit aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
Create action 'SKIDATA exit'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataTransaction (const wchar_t *aInterfaceName, const PlcSkidataMsgCodeTransaction aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
Create action 'SKIDATA transaction'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSMRPViewerCleared ()
Create action 'SMRP viewer cleared'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSMRPViewerConnected (const wchar_t *aServer, const TPlcMediaChannelID &aChannel)
Create action 'SMRP viewer connected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSMTPMailSend (const wchar_t *aSubject, const wchar_t *aTo, const wchar_t *aCc, const wchar_t *aBody, const TPlcMediaChannelID *aChannel)
Create action 'SMTP mail'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartAutoBackup (const TPlcResourceID &aSchedule)
Create action 'Start auto backup'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartEventEx (const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey)
Create action 'Start event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartRemoteExport (const GUID &aExportID, const GUID &aDevice, const PlcBackupFormat aBackupFormat, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aSelectionBegin, const TGLibDateTime &aSelectionEnd, const wchar_t *aJobID)
Create action 'Start remote export'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartSceneStore (const GUID &aSceneStoreID, const wchar_t *aCutList, const __int64 &aPreHistoryLength, const __int64 &aRecordingLength)
Create action 'Start scene store'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStopAllEvents ()
Create action 'Stop all events'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStopEvent (const TPlcEventTypeID &aTypeID)
Create action 'Stop event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStopEventByID (const __int64 &aEventID)
Create action 'Stop event by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemError (const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'System error'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemInfo (const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'System info'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemSettingsChanged (const bool aSetupChanged, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const bool aTimeRangeChanged, const TPlcResourceID *aTimeRange, const bool aLicenceChanged, const TGLibDateTime &aDate)
Create action 'System settings changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemStarted (const TGLibDateTime &aDate)
Create action 'System started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemTerminating (const TGLibDateTime &aDate, const bool aWindowsShutdown)
Create action 'System terminating'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemWarning (const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'System warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTemperature (const IODeviceType aSourceType, const wchar_t *aID, const __int32 aTemperature)
Create action 'Temperature notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTerminalArticleData (const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
Create action 'Terminal article data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTerminalPaymentData (const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
Create action 'Terminal payment data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTiltDown (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Tilt down'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTiltStop (const TPlcMediaChannelID &aCamera)
Create action 'Tilt stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTiltUp (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Tilt up'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTransferBinaryBuffer (const GUID &aInternalHandle, const wchar_t *aParameter)
Create action 'Transfer binary buffer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTransferBinaryChannelBuffer (const TPlcMediaChannelID &aChannel, const GUID &aInternalHandle, const wchar_t *aParameter)
Create action 'Transfer binary channel buffer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateUserLogin (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'User login'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateUserLoginFailed (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const UserLoginFailureCode aRejectReason, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'User login failed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateUserLogout (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'User logout'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueConfirm (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue confirm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueConfirmByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
Create action 'VC alarm queue confirm by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueConfirmByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue confirm by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueNotification (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmState aNotification, const __int64 &aAlarmID, const TPlcEventTypeID &aTypeID, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'VC alarm queue notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueRemove (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue remove'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueRemoveByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
Create action 'VC alarm queue remove by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueRemoveByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue remove by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueSelect (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue select'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueSelectByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
Create action 'VC alarm queue select by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueSelectByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue select by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCASetArmed (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed)
Create action 'VCA set armed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAStatusAnswer (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed)
Create action 'VCA status answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAStatusRequest (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'VCA status request'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCChangeSceneByName (const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
Create action 'VC change scene by name'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCClearSceneByName (const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
Create action 'VC clear scene by name'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCFullMode (const TPlcMediaChannelID &aViewer, const bool aFullMode, const bool aSensitiveAreaEnabled)
Create action 'VC full mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCSceneChanged (const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
Create action 'VC scene changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCSetAudioLevel (const TPlcMediaChannelID &aViewer, const __int32 aAudioLevel)
Create action 'VC set audio level'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCShowViewerText (const TPlcMediaChannelID &aViewer, const bool aShowText)
Create action 'VC show viewer text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCStretchMode (const TPlcMediaChannelID &aViewer, const bool aStretchMode)
Create action 'VC stretch mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoContrastDetected (const TPlcMediaChannelID &aChannel)
Create action 'Video contrast detected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoContrastFailed (const TPlcMediaChannelID &aChannel)
Create action 'Video contrast failed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSetImageBrightness (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aBrightness)
Create action 'Video set image brightness'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSetImageContrast (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aContrast)
Create action 'Video set image contrast'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSetImageSaturation (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aSaturation)
Create action 'Video set image saturation'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSourceChanged (const TPlcMediaChannelID &aChannel, const VideoSignalNorm aSignalNorm, const VideoSignalType aSignalType, const VideoInterlaceType aInterlaceType)
Create action 'Video source has changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSyncDetected (const TPlcMediaChannelID &aChannel)
Create action 'Video sync detected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSyncFailed (const TPlcMediaChannelID &aChannel)
Create action 'Video sync failed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerChangeScene (const TPlcMediaChannelID &aViewer)
Create action 'Viewer change scene'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerClear (const TPlcMediaChannelID &aViewer)
Create action 'Viewer clear'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerCleared (const TPlcMediaChannelID &aViewer, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer cleared'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerClearScene (const TPlcMediaChannelID &aViewer)
Create action 'Viewer clear scene'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerClearTextOutput (const TPlcMediaChannelID &aViewer)
Create action 'Viewer clear text output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerConnect (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode)
Create action 'Viewer connect'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerConnected (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer connected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerConnectLive (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel)
Create action 'Viewer connect live'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerExportPicture (const TPlcMediaChannelID &aViewer, const wchar_t *aFilePath)
Create action 'Viewer export picture'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerJumpByTime (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const __int32 aTimeInSec)
Create action 'Viewer jump by time'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerMaximize (const TPlcMediaChannelID &aViewer, const bool aMaximize)
Create action 'Viewer maximize'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerPlayFromTime (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime &aTime)
Create action 'Viewer play from time'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerPlayModeChanged (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime *aChannelTime, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer play mode changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerPrintPicture (const TPlcMediaChannelID &aViewer)
Create action 'Viewer print picture'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSelect (const TPlcMediaChannelID &aViewer)
Create action 'Viewer select'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSelectionChanged (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer selection changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSetPlayMode (const TPlcMediaChannelID &aViewer, const PlcViewerPlayMode aPlayMode, const __int32 aPlaySpeed)
Create action 'Viewer set play mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerShowAlarmByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID, const PlcViewerAlarmPlayMode aPlayMode)
Create action 'Viewer show alarm by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerShowAlarmByKey (const TPlcMediaChannelID &aViewer, const __int64 &aForeignKey, const PlcViewerAlarmPlayMode aPlayMode)
Create action 'Viewer show alarm by key'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerShowAlarmByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey, const PlcViewerAlarmPlayMode aPlayMode)
Create action 'Viewer show alarm by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSyncAudioAndVideo (const TPlcMediaChannelID &aViewer, const bool aEnableSync)
Create action 'Viewer change sync audio/video'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerTextOutput (const TPlcMediaChannelID &aViewer, const wchar_t *aText)
Create action 'Viewer text output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateWatchdogActivate ()
Create action 'Watchdog activate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateWatchdogDeactivate ()
Create action 'Watchdog deactivate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateWatchdogTrigger ()
Create action 'Watchdog trigger'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateZoomIn (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Zoom in'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateZoomOut (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Zoom out'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateZoomStop (const TPlcMediaChannelID &aCamera)
Create action 'Zoom stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventStarted (const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
Deprecated functions.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorInhibitVideoAlarm (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone)
Create action 'Sensor inhibit video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorVideoAlarm (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone)
Create action 'Sensor video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartEvent (const TPlcEventTypeID &aTypeID)
Create action 'Start event'.

Function Documentation

GSCACTDLLCALL HGscAction __stdcall GscAct_CreateABCConnect ( const wchar_t * aAddress )

Create action 'ABC connect'.

Connect audio back channel.

Parameters:
[in] aAddress Address of the remote server.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateABCDisconnect ( )

Create action 'ABC disconnect'.

Disconnect audio back channel.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateABCPlayFile | ( | const __int64 & | aFileID,
 |  | const wchar_t * | aFileName,
 |  | const bool | aAutoRepeat
 | ) |  |

Create action 'ABC play file'.

Play file on audio back channel.

Parameters:
[in] | aFileID | File ID.
[in] | aFileName | Name of the file.
[in] | aAutoRepeat | Repeat file automatically
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAbortAllAutoBackups ( )

Create action 'Abort all auto backups'.

Abort all auto backups.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAbortAutoBackup ( const TPlcResourceID & aSchedule )

Create action 'Abort auto backup'.

Abort auto backup.

Parameters:
[in] aSchedule Schedule.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateACSAccessDenied | ( | const wchar_t * | aACSName,
 |  | const __int32 * | aACSNo,
 |  | const __int64 * | aAccount,
 |  | const __int64 * | aBancCode,
 |  | const wchar_t * | aCardNo,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const __int32 * | aReason
 | ) |  |

Create action 'ACS access denied'.

ACS access denied.

Parameters:
[in] | aACSName | ACS name.
[in] | aACSNo | ACS no.
[in] | aAccount | Account no.
[in] | aBancCode | Bank code.
[in] | aCardNo | Card no.
[in] | aTimeStamp | Time stamp.
[in] | aReason | Reason.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp. aReason.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateACSAccessGranted | ( | const wchar_t * | aACSName,
 |  | const __int32 * | aACSNo,
 |  | const __int64 * | aAccount,
 |  | const __int64 * | aBancCode,
 |  | const wchar_t * | aCardNo,
 |  | const TGLibDateTime * | aTimeStamp
 | ) |  |

Create action 'ACS access granted'.

ACS access granted.

Parameters:
[in] | aACSName | ACS name.
[in] | aACSNo | ACS no.
[in] | aAccount | Account no.
[in] | aBancCode | Bank code.
[in] | aCardNo | Card no.
[in] | aTimeStamp | Time stamp.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateACSRawAnswer | ( | const wchar_t * | aACSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aACSData
 | ) |  |

Create action 'ACS raw answer'.

ACS raw answer.

Parameters:
[in] | aACSName | ACS name.
[in] | aTimeStamp | Time stamp.
[in] | aACSData | ACS answer.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateACSRawData | ( | const wchar_t * | aACSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aACSData
 | ) |  |

Create action 'ACS raw data'.

ACS raw data.

Parameters:
[in] | aACSName | ACS name.
[in] | aTimeStamp | Time stamp.
[in] | aACSData | ACS data.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateActivateExternalProcess | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const VideoSensorKind | aExternalSystem
 | ) |  |

Create action 'Activate external process'.

Activate external process.

Parameters:
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aExternalSystem | External system to activate.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateATMRawAnswer | ( | const wchar_t * | aATMName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aATMData
 | ) |  |

Create action 'ATM raw answer'.

ATM raw answer.

Parameters:
[in] | aATMName | ATM name.
[in] | aTimeStamp | Time stamp.
[in] | aATMData | ATM answer.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateATMRawData | ( | const wchar_t * | aATMName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aATMData
 | ) |  |

Create action 'ATM raw data'.

ATM raw data.

Parameters:
[in] | aATMName | ATM name.
[in] | aTimeStamp | Time stamp.
[in] | aATMData | ATM data.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateATMTransaction | ( | const wchar_t * | aATMName,
 |  | const bool | aNewTransaction,
 |  | const __int32 | aPhotostep,
 |  | const __int32 * | aATMNo,
 |  | const __int64 * | aAccount,
 |  | const __int64 * | aBancCode,
 |  | const wchar_t * | aCardNo,
 |  | const __int64 * | aTAN1,
 |  | const __int64 * | aTAN2,
 |  | const TGLibDateTime * | aTimeStamp1,
 |  | const TGLibDateTime * | aTimeStamp2,
 |  | const double * | aAmount,
 |  | const wchar_t * | aCurrency
 | ) |  |

Create action 'ATM transaction'.

ATM transaction.

Parameters:
[in] | aATMName | ATM name.
[in] | aNewTransaction | New transaction.
[in] | aPhotostep | Photostep.
[in] | aATMNo | ATM no.
[in] | aAccount | Account no.
[in] | aBancCode | Bank code.
[in] | aCardNo | Card no.
[in] | aTAN1 | TAN 1.
[in] | aTAN2 | TAN 2.
[in] | aTimeStamp1 | Time stamp 1.
[in] | aTimeStamp2 | Time stamp 2.
[in] | aAmount | Amount.
[in] | aCurrency | Currency.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aATMNo. aAccount. aBancCode. aCardNo. aTAN1. aTAN2. aTimeStamp1. aTimeStamp2. aAmount. aCurrency.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupCapacityMonitoringCapacityWarning | ( | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByGbf,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByGbf
 | ) |  |

Create action 'Auto backup capacity warning'.

Auto backup capacity monitoring: capacity warning.

Parameters:
[in] | aWarning | Warning.
[in] | aDestination | Destination.
[in] | aTotalCapacity | Total capacity.
[in] | aFreeCapacity | Free capacity.
[in] | aAllocatedByGbf | Allocated by GBF.
[in] | aPercentFree | Percent free.
[in] | aPercentAllocated | Percent allocated.
[in] | aPercentAllocatedByGbf | Percent allocated by GBF.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupCapacityMonitoringFileAutoDeleted | ( | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByGbf,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByGbf,
 |  | const __int64 & | aFileSize,
 |  | const wchar_t * | aFileName
 | ) |  |

Create action 'Auto backup capacity file auto deleted'.

Auto backup capacity monitoring: file auto deleted.

Parameters:
[in] | aWarning | Warning.
[in] | aDestination | Destination.
[in] | aTotalCapacity | Total capacity.
[in] | aFreeCapacity | Free capacity.
[in] | aAllocatedByGbf | Allocated by GBF.
[in] | aPercentFree | Percent free.
[in] | aPercentAllocated | Percent allocated.
[in] | aPercentAllocatedByGbf | Percent allocated by GBF.
[in] | aFileSize | File size.
[in] | aFileName | File name.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupCapacityMonitoringOutOfDiskSpace | ( | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByGbf,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByGbf
 | ) |  |

Create action 'Auto backup capacity out of disk space'.

Auto backup capacity monitoring: out of disk space.

Parameters:
[in] | aWarning | Warning.
[in] | aDestination | Destination.
[in] | aTotalCapacity | Total capacity.
[in] | aFreeCapacity | Free capacity.
[in] | aAllocatedByGbf | Allocated by GBF.
[in] | aPercentFree | Percent free.
[in] | aPercentAllocated | Percent allocated.
[in] | aPercentAllocatedByGbf | Percent allocated by GBF.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupFileDone | ( | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize
 | ) |  |

Create action 'Auto backup file done'.

Auto backup progress notification: file done.

Parameters:
[in] | aSchedule | Schedule.
[in] | aStartTime | Start time, empty during event backup.
[in] | aEffectiveStartTime | Effective schedule start time.
[in] | aOperationCount | Operation count.
[in] | aTimerStart | Timer start.
[in] | aOperationIndex | Operation index.
[in] | aOperationStartTime | Operation start time.
[in] | aSource | Source.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aFileIndex | File index.
[in] | aFileName | File name.
[in] | aFileSize | File size.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartTime.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupFileProgress | ( | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize
 | ) |  |

Create action 'Auto backup file progress'.

Auto backup progress notification: file progress.

Parameters:
[in] | aSchedule | Schedule.
[in] | aStartTime | Start time, empty during event backup.
[in] | aEffectiveStartTime | Effective schedule start time.
[in] | aOperationCount | Operation count.
[in] | aTimerStart | Timer start.
[in] | aOperationIndex | Operation index.
[in] | aOperationStartTime | Operation start time.
[in] | aSource | Source.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aFileIndex | File index.
[in] | aFileName | File name.
[in] | aFileSize | File size.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartTime.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupFileStarted | ( | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName
 | ) |  |

Create action 'Auto backup file started'.

Auto backup progress notification: file started.

Parameters:
[in] | aSchedule | Schedule.
[in] | aStartTime | Start time, empty during event backup.
[in] | aEffectiveStartTime | Effective schedule start time.
[in] | aOperationCount | Operation count.
[in] | aTimerStart | Timer start.
[in] | aOperationIndex | Operation index.
[in] | aOperationStartTime | Operation start time.
[in] | aSource | Source.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aFileIndex | File index.
[in] | aFileName | File name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartTime.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupOperationDone | ( | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TGLibDateTime & | aOperationStopTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 * | aOperationErrorCode
 | ) |  |

Create action 'Auto backup operation done'.

Auto backup progress notification: operation done.

Parameters:
[in] | aSchedule | Schedule.
[in] | aStartTime | Start time, empty during event backup.
[in] | aEffectiveStartTime | Effective schedule start time.
[in] | aOperationCount | Operation count.
[in] | aTimerStart | Timer start.
[in] | aOperationIndex | Operation index.
[in] | aOperationStartTime | Operation start time.
[in] | aOperationStopTime | Operation stop time.
[in] | aSource | Source.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aOperationErrorCode | Operation error code.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartTime. aOperationErrorCode.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupOperationStarted | ( | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit
 | ) |  |

Create action 'Auto backup operation started'.

Auto backup progress notification: operation started.

Parameters:
[in] | aSchedule | Schedule.
[in] | aStartTime | Start time, empty during event backup.
[in] | aEffectiveStartTime | Effective schedule start time.
[in] | aOperationCount | Operation count.
[in] | aTimerStart | Timer start.
[in] | aOperationIndex | Operation index.
[in] | aOperationStartTime | Operation start time.
[in] | aSource | Source.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartTime.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupScheduleDone | ( | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart
 | ) |  |

Create action 'Auto backup schedule done'.

Auto backup progress notification: schedule done.

Parameters:
[in] | aSchedule | Schedule.
[in] | aStartTime | Start time, empty during event backup.
[in] | aEffectiveStartTime | Effective schedule start time.
[in] | aStopTime | Schedule stop time.
[in] | aOperationCount | Operation count.
[in] | aTimerStart | Timer start.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartTime.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoBackupScheduleStarted | ( | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart
 | ) |  |

Create action 'Auto backup schedule started'.

Auto backup progress notification: schedule started.

Parameters:
[in] | aSchedule | Schedule.
[in] | aStartTime | Start time, empty during event backup.
[in] | aEffectiveStartTime | Effective schedule start time.
[in] | aOperationCount | Operation count.
[in] | aTimerStart | Timer start.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartTime.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoFocusOff ( const TPlcMediaChannelID & aCamera )

Create action 'Auto focus off'.

Disable auto focus of the camera.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateAutoFocusOn ( const TPlcMediaChannelID & aCamera )

Create action 'Auto focus on'.

Enable auto focus of the camera.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateBackupEvent | ( | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 * | aStartHintID,
 |  | const __int64 * | aStopHintID,
 |  | const wchar_t * | aSubfolder
 | ) |  |

Create action 'Backup event'.

Backup event.

Parameters:
[in] | aEventID | Instance ID of the event.
[in] | aTypeID | Type of the event.
[in] | aDestination | Destination.
[in] | aStartHintID | Optional start hint ID.
[in] | aStopHintID | Optional stop hint ID.
[in] | aSubfolder | Sub folder to backup event.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aStartHintID. aStopHintID. aSubfolder.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateBarcodeData | ( | const wchar_t * | aReaderName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aBarcode
 | ) |  |

Create action 'Barcode data'.

Barcode data.

Parameters:
[in] | aReaderName | Scanner name.
[in] | aTimeStamp | Time stamp.
[in] | aBarcode | Barcode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateBlockingFilterActivate ( const wchar_t * aFilter )

Create action 'Blocking filter activate'.

Blocking filter activate.

Parameters:
[in] aFilter Blocking filter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateBlockingFilterDeactivate ( const wchar_t * aFilter )

Create action 'Blocking filter deactivate'.

Blocking filter deactivate.

Parameters:
[in] aFilter Blocking filter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraApplyProfile | ( | const TPlcMediaChannelID & | aCamera,
 |  | const wchar_t * | aProfile
 | ) |  |

Create action 'Camera apply profile'.

Apply a predefined profile settings to the camera.

Parameters:
[in] | aCamera | PTZ head.
[in] | aProfile | Profile name.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraBacklightCompensationMode | ( | const TPlcMediaChannelID & | aCamera,
 |  | const PlcBacklightMode | aMode
 | ) |  |

Create action 'Camera backlight compensation mode'.

Change backlight compensation mode of the camera.

Parameters:
[in] | aCamera | PTZ head.
[in] | aMode | Backlight compensation mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraClearPrePosText | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition
 | ) |  |

Create action 'Camera clear preset text'.

Clear camera text for preset position.

Parameters:
[in] | aCamera | PTZ head.
[in] | aPosition | Preset position.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraDayNightMode | ( | const TPlcMediaChannelID & | aCamera,
 |  | const PlcDayNightMode | aMode
 | ) |  |

Create action 'Camera day/night mode'.

Change day/night mode of the camera.

Parameters:
[in] | aCamera | PTZ head.
[in] | aMode | Day/night mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraLightOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera light off'.

Turn camera light off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraLightOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera light on'.

Turn camera light on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraManualIrisOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera manual iris off'.

Disable manual iris of the camera.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraManualIrisOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera manual iris on'.

Enable manual iris of the camera.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera off'.

Turn camera off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera on'.

Turn camera on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraPumpOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera pump off'.

Turn camera pump off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraPumpOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera pump on'.

Turn camera pump on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraRAWOutput | ( | const TPlcMediaChannelID & | aCamera,
 |  | const char * | aOutput
 | ) |  |

Create action 'Camera RAW output'.

Output unformatted command to the camera.

Parameters:
[in] | aCamera | PTZ head.
[in] | aOutput | RAW command to output.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSelectCharMode | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aMode
 | ) |  |

Create action 'Camera select char mode'.

Select camera character mode.

Parameters:
[in] | aCamera | PTZ head.
[in] | aMode | Character mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSetPrePosText | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition
 | ) |  |

Create action 'Camera set preset text'.

Set camera text for preset position.

Parameters:
[in] | aCamera | PTZ head.
[in] | aPosition | Preset position.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncUOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func U off'.

Turn camera special function U off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncUOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func U on'.

Turn camera special function U on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncVOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func V off'.

Turn camera special function V off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncVOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func V on'.

Turn camera special function V on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncXOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func X off'.

Turn camera special function X off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncXOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func X on'.

Turn camera special function X on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncYOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func Y off'.

Turn camera special function Y off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraSpecFuncYOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera spec func Y on'.

Turn camera special function Y on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraStopAll ( const TPlcMediaChannelID & aCamera )

Create action 'Camera stop all'.

Camera stop all.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraTextOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera text off'.

Disable camera text.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraTextOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera text on'.

Enable camera text.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraTourStart | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aTourID,
 |  | const char * | aTourName
 | ) |  |

Create action 'Camera tour start'.

Start camera tour.

Parameters:
[in] | aCamera | PTZ head.
[in] | aTourID | Tour ID.
[in] | aTourName | Tour name.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraTourStop ( const TPlcMediaChannelID & aCamera )

Create action 'Camera tour stop'.

Stop camera tour.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraVersionOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera version off'.

Hide camera version string.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraVersionOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera version on'.

Show camera version string.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraWashOff ( const TPlcMediaChannelID & aCamera )

Create action 'Camera wash-wipe off'.

Turn camera wash-wipe off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCameraWashOn ( const TPlcMediaChannelID & aCamera )

Create action 'Camera wash-wipe on'.

Turn camera wash-wipe on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCancelExport | ( | const GUID & | aExportID,
 |  | const PlcExportAbort | aAbortFlag
 | ) |  |

Create action 'Cancel export'.

Cancel export.

Parameters:
[in] | aExportID | Export GUID.
[in] | aAbortFlag | Abort flag.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCaseClosed ( )

Create action 'Case has been closed'.

Case has been closed.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCaseOpened ( )

Create action 'Case has been opened'.

Case has been opened.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChangeADParameterSet | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet
 | ) |  |

Create action 'Change AD parameter set'.

This action changes the current AD parameter set of the video channel.

Parameters:
[in] | aChannel | Channel.
[in] | aParameterSet | The name of the new AD parameter set.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChangeCameraProfile | ( | const TPlcResourceID & | aHardwareModule,
 |  | const TPlcResourceID & | aCameraProfile
 | ) |  |

Create action 'Change camera profile'.

This action changes the current camera profile of the hardware module.

Parameters:
[in] | aHardwareModule | Hardware module.
[in] | aCameraProfile | The name of the camera profile.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChangeCPAParameterSet | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet
 | ) |  |

Create action 'Change CPA parameter set'.

This action changes the current CPA parameter set of the video channel.

Parameters:
[in] | aChannel | Channel.
[in] | aParameterSet | The name of the new CPA parameter set.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChangeGTectParameterSet | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet
 | ) |  |

Create action 'Change GTectVMX parameter set'.

This action changes the current GTectVMX parameter set of the video channel.

Parameters:
[in] | aChannel | Channel.
[in] | aParameterSet | The name of the new GTect parameter set.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChangeObtrackParameterSet | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet
 | ) |  |

Create action 'Change OBTRACK parameter set'.

This action changes the current OBTRACK parameter set of the video channel.

Parameters:
[in] | aChannel | Channel.
[in] | aParameterSet | The name of the new OBTRACK parameter set.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChangeVMDParameterSet | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet
 | ) |  |

Create action 'Change VMD parameter set'.

This action changes the current VMD parameter set of the video channel.

Parameters:
[in] | aChannel | Channel.
[in] | aParameterSet | The name of the new VMD parameter set.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChannelError | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind * | aSensorType,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo
 | ) |  |

Create action 'Channel error'.

Notify channel error.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aSource | Source of the message.
[in] | aMessage | Kind of the message.
[in] | aWindowsError | Optional Windows error code.
[in] | aDescription | Optional description of the message.
[in] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aSensorType. aWindowsError. aDescription. aXMLInfo.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChannelInfo | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind * | aSensorType,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo
 | ) |  |

Create action 'Channel info'.

Notify channel information.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aSource | Source of the message.
[in] | aMessage | Kind of the message.
[in] | aDescription | Optional description of the message.
[in] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aSensorType. aDescription. aXMLInfo.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChannelLiveCheck | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const TGLibDateTime & | aTimeStamp
 | ) |  |

Create action 'Channel live check'.

This action notifies that the channel is alive.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aTimeStamp | Time stamp.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateChannelWarning | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind * | aSensorType,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo
 | ) |  |

Create action 'Channel warning'.

Notify channel warning.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aSource | Source of the message.
[in] | aMessage | Kind of the message.
[in] | aWindowsError | Optional Windows error code.
[in] | aDescription | Optional description of the message.
[in] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aSensorType. aWindowsError. aDescription. aXMLInfo.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCPAMeasurement | ( | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 | aCorrelation
 | ) |  |

Create action 'CPA measurement'.

CPA measurement.

Parameters:
[in] | aChannel | Channel.
[in] | aCorrelation | Correlation factor.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateCustomAction | ( | const __int64 & | aInt,
 |  | const wchar_t * | aString
 | ) |  |

Create action 'Custom action'.

This action has no side effects and can be used for customer purposes.

Parameters:
[in] | aInt | Numeric parameter.
[in] | aString | Literal parameter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDatabaseRecordingInfoRing | ( | const PlcDatabaseRing | aDatabaseRing,
 |  | const bool | aNoVideoRecording,
 |  | const bool | aNoAudioRecording,
 |  | const bool | aNoRecordingAtAll,
 |  | const double & | aVideoSamplesPerSecond,
 |  | const double & | aVideoMBPerSecond,
 |  | const double & | aAudioSamplesPerSecond,
 |  | const double & | aAudioMBPerSecond,
 |  | const double & | aWriteWaitTimesPercent,
 |  | const __int64 & | aRingCapacity,
 |  | const TGLibDateTime & | aOldestItem,
 |  | const double * | aRecordingDepth,
 |  | const __int64 * | aEstimatedRequiredCapacity
 | ) |  |

Create action 'Database recording info per ring'.

Database recording info per ring.

Parameters:
[in] | aDatabaseRing | Database ring.
[in] | aNoVideoRecording | Video is recording or not.
[in] | aNoAudioRecording | Audio is recording or not.
[in] | aNoRecordingAtAll | Video and/or audio is recording or not.
[in] | aVideoSamplesPerSecond | Video samples per second.
[in] | aVideoMBPerSecond | Video MB per second.
[in] | aAudioSamplesPerSecond | Audio samples per second.
[in] | aAudioMBPerSecond | Audio MB per second.
[in] | aWriteWaitTimesPercent | Write waiting times in percent.
[in] | aRingCapacity | Ring capacity.
[in] | aOldestItem | Time stamp of the oldest item.
[in] | aRecordingDepth | Recording depth in hours.
[in] | aEstimatedRequiredCapacity | Estimated required capacity.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aRecordingDepth. aEstimatedRequiredCapacity.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDatabaseRecordingInfoTotal | ( | const bool | aNoVideoRecording,
 |  | const bool | aNoAudioRecording,
 |  | const bool | aNoRecordingAtAll,
 |  | const double & | aVideoSamplesPerSecond,
 |  | const double & | aVideoMBPerSecond,
 |  | const double & | aAudioSamplesPerSecond,
 |  | const double & | aAudioMBPerSecond,
 |  | const double & | aWriteWaitTimesPercent,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedCapacity,
 |  | const TGLibDateTime * | aOldestItem,
 |  | const double * | aRecordingDepth,
 |  | const __int64 * | aEstimatedRequiredCapacity,
 |  | const double * | aRequiredCapacityFactor,
 |  | const bool * | aRequiredCapacityAvailable
 | ) |  |

Create action 'Database recording info total'.

Database recording info total.

Parameters:
[in] | aNoVideoRecording | Video is recording or not.
[in] | aNoAudioRecording | Audio is recording or not.
[in] | aNoRecordingAtAll | Video and/or audio is recording or not.
[in] | aVideoSamplesPerSecond | Video samples per second.
[in] | aVideoMBPerSecond | Video MB per second.
[in] | aAudioSamplesPerSecond | Audio samples per second.
[in] | aAudioMBPerSecond | Audio MB per second.
[in] | aWriteWaitTimesPercent | Write waiting times in percent.
[in] | aTotalCapacity | Total capacity.
[in] | aFreeCapacity | Free capacity.
[in] | aAllocatedCapacity | Allocated capacity.
[in] | aOldestItem | Time stamp of the oldest item.
[in] | aRecordingDepth | Recording depth in hours.
[in] | aEstimatedRequiredCapacity | Estimated required capacity.
[in] | aRequiredCapacityFactor | Required capacity factor.
[in] | aRequiredCapacityAvailable | Required capacity available.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aOldestItem. aRecordingDepth. aEstimatedRequiredCapacity. aRequiredCapacityFactor. aRequiredCapacityAvailable.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDatabaseStarted | ( | const PlcDatabaseStatus | aStatus,
 |  | const __int64 & | aTotalSize
 | ) |  |

Create action 'Database started'.

This action will be fired at the database start-up.

Parameters:
[in] | aStatus | Database status message.
[in] | aTotalSize | Database total size.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDefaultPosCallUp ( const TPlcMediaChannelID & aCamera )

Create action 'Move to default position'.

Move camera to default position.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDefaultPosClear ( const TPlcMediaChannelID & aCamera )

Create action 'Clear default position'.

Clear camera default position.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDefaultPosSave ( const TPlcMediaChannelID & aCamera )

Create action 'Save default position'.

Save current camera position as default position.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDeviceFound | ( | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial
 | ) |  |

Create action 'Device found'.

This action will be fired when the USB or NET device is connected to the system. It is also fired at start-up for all detected devices.

Parameters:
[in] | aType | Type of the device.
[in] | aName | Device name if assigned in setup, empty otherwise.
[in] | aSerial | Serial ID of the device.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDeviceNewFirmware | ( | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial,
 |  | const char * | aFirmware
 | ) |  |

Create action 'New firmware received'.

This action will be fired when the USB or NET device has got the new firmware.

Parameters:
[in] | aType | Type of the device.
[in] | aName | Device name if assigned in setup, empty otherwise.
[in] | aSerial | Serial ID of the device.
[in] | aFirmware | Serial ID of the firmware.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDevicePluginError | ( | const TPlcMediaChannelID & | aChannel,
 |  | const char * | aType,
 |  | const char * | aSubType,
 |  | const char * | aName,
 |  | const char * | aSerial,
 |  | const PlcPluginError | aErrorClass,
 |  | const __int32 * | aErrorCode,
 |  | const char * | aDescription
 | ) |  |

Create action 'Device plugin error'.

This action notifies device plugin error.

Parameters:
[in] | aChannel | Channel.
[in] | aType | Type of the device.
[in] | aSubType | Subtype of the device.
[in] | aName | Device name.
[in] | aSerial | Serial ID of the device.
[in] | aErrorClass | Error class of the error occured.
[in] | aErrorCode | Plugin type specific error code.
[in] | aDescription | Error description.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aSubType. aErrorCode. aDescription.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDevicePluginState | ( | const TPlcMediaChannelID & | aChannel,
 |  | const char * | aType,
 |  | const char * | aSubType,
 |  | const char * | aName,
 |  | const char * | aSerial,
 |  | const PlcPluginState | aState,
 |  | const __int32 * | aInternalState,
 |  | const char * | aDescription
 | ) |  |

Create action 'Device plugin state'.

This action notifies device plugin state.

Parameters:
[in] | aChannel | Channel.
[in] | aType | Type of the device.
[in] | aSubType | Subtype of the device.
[in] | aName | Device name.
[in] | aSerial | Serial ID of the device.
[in] | aState | New plugin device state.
[in] | aInternalState | Plugin device specific state.
[in] | aDescription | State description.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aSubType. aInternalState. aDescription.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDeviceReattached | ( | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial
 | ) |  |

Create action 'Device reattached'.

This action will be fired when the USB or NET device is reattached to the system.

Parameters:
[in] | aType | Type of the device.
[in] | aName | Device name if assigned in setup, empty otherwise.
[in] | aSerial | Serial ID of the device.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDeviceRemoved | ( | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial
 | ) |  |

Create action 'Device removed'.

This action will be fired when the USB or NET device is disconnected from the system. It is also fired at the start-up for all parameterized but not present devices.

Parameters:
[in] | aType | Type of the device.
[in] | aName | Device name if assigned in setup, empty otherwise.
[in] | aSerial | Serial ID of the device.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateDigitalInput | ( | const TPlcMediaChannelID & | aContact,
 |  | const DigitalInputState | aState
 | ) |  |

Create action 'Digital input'.

This action will be fired when the state of the digital input has changed.

Parameters:
[in] | aContact | Contact.
[in] | aState | New state.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventBackupDone | ( | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const __int32 * | aOperationErrorCode
 | ) |  |

Create action 'Event backup done'.

Event backup progress notification: backup done.

Parameters:
[in] | aJobID | Backup job ID.
[in] | aEventTypeID | Type of the event.
[in] | aEventID | Instance ID of the event.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aStartTime | Backup start time.
[in] | aStopTime | Backup stop time.
[in] | aOperationErrorCode | Operation error code.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aOperationErrorCode.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventBackupFileDone | ( | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize
 | ) |  |

Create action 'Event backup file done'.

Event backup progress notification: file done.

Parameters:
[in] | aJobID | Backup job ID.
[in] | aEventTypeID | Type of the event.
[in] | aEventID | Instance ID of the event.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aStartTime | Effective backup start time.
[in] | aFileIndex | File index.
[in] | aFileName | File name.
[in] | aFileSize | File size.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventBackupFileProgress | ( | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize
 | ) |  |

Create action 'Event backup file progress'.

Event backup progress notification: file progress.

Parameters:
[in] | aJobID | Backup job ID.
[in] | aEventTypeID | Type of the event.
[in] | aEventID | Instance ID of the event.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aStartTime | Effective backup start time.
[in] | aFileIndex | File index.
[in] | aFileName | File name.
[in] | aFileSize | File size.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventBackupFileStarted | ( | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName
 | ) |  |

Create action 'Event backup file started'.

Event backup progress notification: file started.

Parameters:
[in] | aJobID | Backup job ID.
[in] | aEventTypeID | Type of the event.
[in] | aEventID | Instance ID of the event.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aStartTime | Effective backup start time.
[in] | aFileIndex | File index.
[in] | aFileName | File name.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventBackupStarted | ( | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime
 | ) |  |

Create action 'Event backup started'.

Event backup progress notification: backup started.

Parameters:
[in] | aJobID | Backup job ID.
[in] | aEventTypeID | Type of the event.
[in] | aEventID | Instance ID of the event.
[in] | aDestination | Destination.
[in] | aFileSizeLimit | File size limit.
[in] | aBandWidthLimit | Band width limit.
[in] | aStartTime | Backup start time.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventRecordingChanged | ( | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID
 | ) |  |

Create action 'Event recording changed'.

Event recording settings are changed.

Parameters:
[in] | aEventID | Instance ID of the event.
[in] | aTypeID | Type of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventStartedEx | ( | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const __int64 * | aForeignKey
 | ) |  |

Create action 'Event started'.

Event has started.

Parameters:
[in] | aEventID | Instance ID of the event.
[in] | aTypeID | Type of the event.
[in] | aForeignKey | Optional foreign key used to start the alarm.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aForeignKey.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventStopped | ( | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID
 | ) |  |

Create action 'Event stopped'.

Event has stopped.

Parameters:
[in] | aEventID | Instance ID of the event.
[in] | aTypeID | Type of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateExportFinished | ( | const GUID & | aExportID,
 |  | const PlcExportSuccess | aSuccess
 | ) |  |

Create action 'Export finished'.

Export finished.

Parameters:
[in] | aExportID | Export GUID.
[in] | aSuccess | Success.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateExportProgress | ( | const GUID & | aExportID,
 |  | const __int32 | aProgress
 | ) |  |

Create action 'Export progress'.

Export progress.

Parameters:
[in] | aExportID | Export GUID.
[in] | aProgress | Progress.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateFastSpeedOff ( const TPlcMediaChannelID & aCamera )

Create action 'Fast speed off'.

Turn camera fast speed off.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateFastSpeedOn ( const TPlcMediaChannelID & aCamera )

Create action 'Fast speed on'.

Turn camera fast speed on.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateFillingPumpStatus | ( | const wchar_t * | aTerminalName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const __int32 | aPumpNo,
 |  | const PlcPumpStatus | aStatus,
 |  | const double * | aAmount,
 |  | const double * | aPrice,
 |  | const wchar_t * | aDetails
 | ) |  |

Create action 'Filling pump status'.

Filling pump status.

Parameters:
[in] | aTerminalName | Terminal name.
[in] | aTimeStamp | Time stamp.
[in] | aPumpNo | Pump no.
[in] | aStatus | Status.
[in] | aAmount | Amount.
[in] | aPrice | Price.
[in] | aDetails | Details.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aAmount. aPrice. aDetails.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateFocusFar | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Focus far'.

Focus camera far.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Focus speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateFocusNear | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Focus near'.

Focus camera near.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Focus speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateFocusStop ( const TPlcMediaChannelID & aCamera )

Create action 'Focus stop'.

Stop camera focus.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateFRCNotification | ( | const PlcFRCNotification | aNotification,
 |  | const __int32 * | aParam,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo
 | ) |  |

Create action 'FRC notification'.

FRC notification.

Parameters:
[in] | aNotification | Notification reason.
[in] | aParam | Additional parameter.
[in] | aDescription | Optional notification text.
[in] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aParam. aDescription. aXMLInfo.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGEMOSalarm | ( | const __int64 & | aGEMOSkey,
 |  | const __int32 | aGEMOSint,
 |  | const wchar_t * | aGEMOSstr
 | ) |  |

Create action 'GEMOS alarm'.

GEMOS alarm notification.

Parameters:
[in] | aGEMOSkey | GEMOS alarm key.
[in] | aGEMOSint | GEMOS alarm integer parameter.
[in] | aGEMOSstr | GEMOS alarm string parameter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGSCSVehicleAccessDenied | ( | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection
 | ) |  |

Create action 'GSCS vehicle access denied'.

GSCS vehicle access denied.

Parameters:
[in] | aSequenceID | The sequence ID.
[in] | aPlateNo | Recognized plate no.
[in] | aTimeStamp | Time stamp.
[in] | aCompanyCategory | Company category.
[in] | aCompanyName | Company name.
[in] | aReason | Reason.
[in] | aTrafficLane | Traffic lane.
[in] | aChannel | Channel.
[in] | aDirection | Direction.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGSCSVehicleAccessExpired | ( | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime & | aExpiringTime,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection
 | ) |  |

Create action 'GSCS vehicle access expired'.

GSCS vehicle access expired.

Parameters:
[in] | aSequenceID | The sequence ID.
[in] | aPlateNo | Recognized plate no.
[in] | aTimeStamp | Time stamp.
[in] | aExpiringTime | Expiring time.
[in] | aCompanyCategory | Company category.
[in] | aCompanyName | Company name.
[in] | aReason | Reason.
[in] | aTrafficLane | Traffic lane.
[in] | aChannel | Channel.
[in] | aDirection | Direction.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGSCSVehicleAccessGranted | ( | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection
 | ) |  |

Create action 'GSCS vehicle access granted'.

GSCS vehicle access granted.

Parameters:
[in] | aSequenceID | The sequence ID.
[in] | aPlateNo | Recognized plate no.
[in] | aTimeStamp | Time stamp.
[in] | aCompanyCategory | Company category.
[in] | aCompanyName | Company name.
[in] | aReason | Reason.
[in] | aTrafficLane | Traffic lane.
[in] | aChannel | Channel.
[in] | aDirection | Direction.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGSCSVehicleAccessPending | ( | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection
 | ) |  |

Create action 'GSCS vehicle access pending'.

GSCS vehicle access pending.

Parameters:
[in] | aSequenceID | The sequence ID.
[in] | aPlateNo | Recognized plate no.
[in] | aTimeStamp | Time stamp.
[in] | aCompanyCategory | Company category.
[in] | aCompanyName | Company name.
[in] | aReason | Reason.
[in] | aTrafficLane | Traffic lane.
[in] | aChannel | Channel.
[in] | aDirection | Direction.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGTectAnalyticsLiveCheck ( )

Create action 'G-Tect analytics live check'.

This action will be fired periodically to ensure that analytics client is still running.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGTectDualSensorAlarm | ( | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 * | aSterileZoneNumber,
 |  | const __int32 * | aVirtualFenceNumber,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone,
 |  | const VMDCycle * | aVMDCycle,
 |  | const TPlcRect * | aAlarmArea
 | ) |  |

Create action 'G-Tect/Dual sensor alarm'.

This action will be fired when G-Tect/Dual sensor detects an alarm.

Parameters:
[in] | aChannel | Channel.
[in] | aSterileZoneNumber | Sterile Zone Number
[in] | aVirtualFenceNumber | Virtual Fence Number.
[in] | aVMDGroup | VMD alarm group.
[in] | aVMDZone | VMD zone nr.
[in] | aVMDCycle | VMD measure cycle.
[in] | aAlarmArea | Alarm area.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aSterileZoneNumber. aVirtualFenceNumber. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGTectDualSensorAlarmFinished ( const TPlcMediaChannelID & aChannel )

Create action 'G-Tect/Dual sensor alarm finished'.

This action will be fired when the alarm is finished.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGTectSceneAlarm | ( | const TPlcMediaChannelID & | aChannel,
 |  | const GTectSceneAlarmReason | aAlarmReason
 | ) |  |

Create action 'G-Tect scene alarm'.

This action will be fired when G-Tect Video content analysis detects a scene alarm.

Parameters:
[in] | aChannel | Channel.
[in] | aAlarmReason | Alarm reason.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGTectSceneAlarmFinished | ( | const TPlcMediaChannelID & | aChannel,
 |  | const GTectSceneAlarmReason | aAlarmReason
 | ) |  |

Create action 'G-Tect scene alarm finished'.

This action will be fired when G-Tect Video content analysis scene alarm is finished.

Parameters:
[in] | aChannel | Channel.
[in] | aAlarmReason | Alarm reason.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGTectVMXAlarm | ( | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 * | aSterileZoneNumber,
 |  | const __int32 * | aVirtualFenceNumber,
 |  | const __int32 * | aAlarmGroup,
 |  | const __int32 * | aTrackID,
 |  | const TPlcRect * | aAlarmArea
 | ) |  |

Create action 'G-Tect/VMX alarm'.

This action will be fired when G-Tect/VMX Video content analysis detects an alarm.

Parameters:
[in] | aChannel | Channel.
[in] | aSterileZoneNumber | Sterile Zone Number
[in] | aVirtualFenceNumber | Virtual Fence Number.
[in] | aAlarmGroup | Used to group different Zones or fences to the same level.
[in] | aTrackID | Internal Track ID.
[in] | aAlarmArea | Alarm area.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aSterileZoneNumber. aVirtualFenceNumber. aAlarmGroup. aTrackID. aAlarmArea.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGTectVMXAlarmFinished ( const TPlcMediaChannelID & aChannel )

Create action 'G-Tect/VMX alarm finished'.

This action will be fired when the alarm is finished.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIASSettingsChanged | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType
 | ) |  |

Create action 'IAS settings changed'.

IAS settings changed.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateImageExportNotification | ( | const wchar_t * | aUser,
 |  | const wchar_t * | aDestination,
 |  | const PlcImageExportType | aDestinationType,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime * | aTimeEnd,
 |  | const wchar_t * | aChannels,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'Image export notification'.

Notification on export or print of channel images.

Parameters:
[in] | aUser | Name of the user connected to the system.
[in] | aDestination | Destination.
[in] | aDestinationType | Destination type.
[in] | aTimeStamp | Time stamp.
[in] | aTimeEnd | End time.
[in] | aChannels | Channels.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aTimeEnd. aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateImexCapacityFileAutoDeleted | ( | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByImageFile,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByImageFile,
 |  | const __int64 & | aTotalFileSize,
 |  | const __int32 | aNumberOfFiles
 | ) |  |

Create action 'Imex capacity file auto deleted'.

Imex capacity warning: file auto deleted.

Parameters:
[in] | aWarning | Warning.
[in] | aDestination | Destination.
[in] | aTotalCapacity | Total capacity.
[in] | aFreeCapacity | Free capacity.
[in] | aAllocatedByImageFile | Allocated by image file.
[in] | aPercentFree | Percent free.
[in] | aPercentAllocated | Percent allocated.
[in] | aPercentAllocatedByImageFile | Percent allocated by image file.
[in] | aTotalFileSize | Total file size.
[in] | aNumberOfFiles | Number of files.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateImexCapacityOutOfDiskSpace | ( | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByImageFile,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByImageFile
 | ) |  |

Create action 'Imex capacity out of disk space.

'. Imex capacity warning: out of disk space.

Parameters:
[in] | aWarning | Warning.
[in] | aDestination | Destination.
[in] | aTotalCapacity | Total capacity.
[in] | aFreeCapacity | Free capacity.
[in] | aAllocatedByImageFile | Allocated by image file.
[in] | aPercentFree | Percent free.
[in] | aPercentAllocated | Percent allocated.
[in] | aPercentAllocatedByImageFile | Percent allocated by image file.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateImexCapacityWarning | ( | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByImageFile,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByImageFile
 | ) |  |

Create action 'Imex capacity warning'.

Imex capacity warning: capacity warning.

Parameters:
[in] | aWarning | Warning.
[in] | aDestination | Destination.
[in] | aTotalCapacity | Total capacity.
[in] | aFreeCapacity | Free capacity.
[in] | aAllocatedByImageFile | Allocated by image file.
[in] | aPercentFree | Percent free.
[in] | aPercentAllocated | Percent allocated.
[in] | aPercentAllocatedByImageFile | Percent allocated by image file.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateImexExportEventImage | ( | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const TPlcResourceID * | aDestination,
 |  | const wchar_t * | aFilePath
 | ) |  |

Create action 'Imex export event image'.

Imex export event image.

Parameters:
[in] | aEventID | Instance ID of the event.
[in] | aTypeID | Type of the event.
[in] | aDestination | Destination.
[in] | aFilePath | File name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDestination. aFilePath.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateImexExportImageFromDB | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID * | aDestination,
 |  | const wchar_t * | aFilePath,
 |  | const TGLibDateTime * | aPictureTime
 | ) |  |

Create action 'Imex export image from DB'.

Imex export image from DB.

Parameters:
[in] | aChannel | Channel.
[in] | aDestination | Destination.
[in] | aFilePath | File name.
[in] | aPictureTime | Picture time.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDestination. aFilePath. aPictureTime.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateImexExportImageFromLiveStream | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID * | aDestination,
 |  | const wchar_t * | aFilePath
 | ) |  |

Create action 'Imex export image from live stream'.

Imex export image from live stream.

Parameters:
[in] | aChannel | Channel.
[in] | aDestination | Destination.
[in] | aFilePath | File name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDestination. aFilePath.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateInitializeRemoteExport | ( | const TPlcMediaChannelID & | aViewer,
 |  | const GUID & | aDevice
 | ) |  |

Create action 'Initialize remote export'.

Initialize remote export.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aDevice | Pilot device GUID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateInterfaceRawAnswer | ( | const wchar_t * | aInterfaceName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aData
 | ) |  |

Create action 'Interface raw answer'.

Interface raw answer.

Parameters:
[in] | aInterfaceName | Interface name.
[in] | aTimeStamp | Time stamp.
[in] | aData | Interface answer.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateInterfaceRawData | ( | const wchar_t * | aInterfaceName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aData
 | ) |  |

Create action 'Interface raw data'.

Interface raw data.

Parameters:
[in] | aInterfaceName | Interface name.
[in] | aTimeStamp | Time stamp.
[in] | aData | Interface data.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIOI43ResetMainboard ( )

Create action 'IOI43 reset mainboard'.

Reset mainboard using IOI43a/ab USB Alarm-I/O.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIOI43Temperature | ( | const wchar_t * | aID,
 |  | const __int32 | aTemperature
 | ) |  |

Create action 'IOI43 temperature notification'.

Temperature notification from IOI43a/ab USB Alarm-I/O.

Parameters:
[in] | aID | ID of the IOI43 module (like IOI43-00).
[in] | aTemperature | Temperature.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIOI43WDActivate ( )

Create action 'IOI43 watchdog activate'.

Activate watchdog on IOI43a/ab USB Alarm-I/O.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIOI43WDDeactivate ( )

Create action 'IOI43 watchdog deactivate'.

Deactivate watchdog on IOI43a/ab USB Alarm-I/O.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIOI43WDTrigger ( )

Create action 'IOI43 watchdog trigger'.

Trigger watchdog on IOI43a/ab USB Alarm-I/O.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIPCameraRawCommand | ( | const wchar_t * | aURL,
 |  | const wchar_t * | aUser,
 |  | const wchar_t * | aPassword,
 |  | const wchar_t * | aPOST
 | ) |  |

Create action 'IP camera raw command'.

This action sends a special command to the IP camera.

Parameters:
[in] | aURL | Complete command URL (like http://192.168.0.165:80/set?daynight=night).
[in] | aUser | User name to authenticate by the camera (optional).
[in] | aPassword | Password to authenticate by the camera (optional).
[in] | aPOST | POST parameters (optional, separate lines with \r\n).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aUser. aPassword. aPOST.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIPCamFailoverNotification | ( | const wchar_t * | aPrimaryServer,
 |  | const wchar_t * | aSecondaryServer,
 |  | const TPlcMediaChannelID & | aPrimaryChannel,
 |  | const TPlcMediaChannelID & | aSecondaryChannel,
 |  | const wchar_t * | aCameraParameters
 | ) |  |

Create action 'IP camera failover notification'.

IP camera failover notification.

Parameters:
[in] | aPrimaryServer | The name of the primary server.
[in] | aSecondaryServer | The name of the secondary server.
[in] | aPrimaryChannel | Primary channel.
[in] | aSecondaryChannel | Secondary channel.
[in] | aCameraParameters | Optional camera parameters.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aCameraParameters.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIPCamFailoverRestore | ( | const wchar_t * | aPrimaryServer,
 |  | const wchar_t * | aSecondaryServer,
 |  | const TPlcMediaChannelID & | aPrimaryChannel,
 |  | const TPlcMediaChannelID & | aSecondaryChannel,
 |  | const wchar_t * | aCameraParameters
 | ) |  |

Create action 'IP camera failover restore'.

IP camera failover restore.

Parameters:
[in] | aPrimaryServer | The name of the primary server.
[in] | aSecondaryServer | The name of the secondary server.
[in] | aPrimaryChannel | Primary channel.
[in] | aSecondaryChannel | Secondary channel.
[in] | aCameraParameters | Optional camera parameters.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aCameraParameters.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIPSwitchOperation | ( | const IPSwitchOps | aOperation,
 |  | const wchar_t * | aPort,
 |  | const __int32 * | aParam
 | ) |  |

Create action 'IP switch operation'.

IP switch operation.

Parameters:
[in] | aOperation | Operation.
[in] | aPort | Port no, IP address, MAC address.
[in] | aParam | Optional parameter.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aParam.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIrisClose ( const TPlcMediaChannelID & aCamera )

Create action 'Iris close'.

Close camera iris.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIrisOpen ( const TPlcMediaChannelID & aCamera )

Create action 'Iris open'.

Open camera iris.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateIrisStop ( const TPlcMediaChannelID & aCamera )

Create action 'Iris stop'.

Stop camera iris.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateKeyPressed ( const SystemKey aKey )

Create action 'Key pressed'.

This action is notified if one of the GEVISCOPE system keys is pressed.

Parameters:
[in] aKey System key.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateKeyReleased ( const SystemKey aKey )

Create action 'Key released'.

This action is notified if one of the GEVISCOPE system keys is released.

Parameters:
[in] aKey System key.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateKillAllEvents ( )

Create action 'Kill all events'.

Kill all active events.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateKillEvent ( const TPlcEventTypeID & aTypeID )

Create action 'Kill event'.

Kill event.

Parameters:
[in] aTypeID Type of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateKillEventByID ( const __int64 & aEventID )

Create action 'Kill event by instance'.

Kill event by instance ID.

Parameters:
[in] aEventID Instance ID of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLenelAccessEvent | ( | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int64 * | aCardNumber,
 |  | const LenelAccessResult * | aAccessResult,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const __int32 * | aAreaEnteredID,
 |  | const __int32 * | aAreaExitedID,
 |  | const wchar_t * | aAssetID,
 |  | const bool * | aCardholderEntered,
 |  | const bool * | aDuress,
 |  | const __int32 * | aElevatorFloor,
 |  | const __int32 * | aFacilityCode,
 |  | const bool * | aIsReadableCard,
 |  | const __int32 * | aIssueCode,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText
 | ) |  |

Create action 'Lenel access event'.

Lenel OnGuard access event.

Parameters:
[in] | aID | The ID that uniquely identifies the type of this event.
[in] | aPanel | The name of the panel where this event originated.
[in] | aDevice | The name of the device where this event originated.
[in] | aSecondaryDevice | The ID of the secondary device where this event originated.
[in] | aCardNumber | The badge ID for the card that was read, if available.
[in] | aAccessResult | The level of access that was granted that resulted from reading the card.
[in] | aType | Event type i.e., duress, system, etc.
[in] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[in] | aDescription | A human readable, brief description of this event.
[in] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[in] | aTimeStamp | Time stamp.
[in] | aAreaEnteredID | The ID of the area that was entered, if any.
[in] | aAreaExitedID | The ID of the area that was exited, if any.
[in] | aAssetID | The ID of the asset related to this event, if any.
[in] | aCardholderEntered | Whether entry was made by the cardholder.
[in] | aDuress | Indicates whether this card access indicates an under duress/emergency state.
[in] | aElevatorFloor | The elevator floor on which the access event was generated, if any.
[in] | aFacilityCode | The facility code for the card that was read, if available.
[in] | aIsReadableCard | Whether the card could be read.
[in] | aIssueCode | The issue code for the card that was read, if available.
[in] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[in] | aEventText | Text associated with event
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aCardNumber. aAccessResult. aType. aSubType. aSerialNumber. aTimeStamp. aAreaEnteredID. aAreaExitedID. aAssetID. aCardholderEntered. aDuress. aElevatorFloor. aFacilityCode. aIsReadableCard. aIssueCode. aCommServerHostName. aEventText.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLenelFireEvent | ( | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int32 * | aTroubleCode,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText
 | ) |  |

Create action 'Lenel fire event'.

Lenel OnGuard fire event.

Parameters:
[in] | aID | The ID that uniquely identifies the type of this event.
[in] | aPanel | The name of the panel where this event originated.
[in] | aDevice | The name of the device where this event originated.
[in] | aSecondaryDevice | The ID of the secondary device where this event originated.
[in] | aTroubleCode | A trouble code associated with the fire event.
[in] | aType | Event type i.e., duress, system, etc.
[in] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[in] | aDescription | A human readable, brief description of this event.
[in] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[in] | aTimeStamp | Time stamp.
[in] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[in] | aEventText | Text associated with event
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aTroubleCode. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLenelIntercomEvent | ( | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int32 * | aIntercomData,
 |  | const __int32 * | aLineNumber,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText
 | ) |  |

Create action 'Lenel intercom event'.

Lenel OnGuard intercom event.

Parameters:
[in] | aID | The ID that uniquely identifies the type of this event.
[in] | aPanel | The name of the panel where this event originated.
[in] | aDevice | The name of the device where this event originated.
[in] | aSecondaryDevice | The ID of the secondary device where this event originated.
[in] | aIntercomData | Additional data for the intercom event that occurred.
[in] | aLineNumber | The line number involved in the intercom event.
[in] | aType | Event type i.e., duress, system, etc.
[in] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[in] | aDescription | A human readable, brief description of this event.
[in] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[in] | aTimeStamp | Time stamp.
[in] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[in] | aEventText | Text associated with event
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aIntercomData. aLineNumber. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLenelRawData | ( | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aLenelData
 | ) |  |

Create action 'Lenel raw data'.

Lenel OnGuard raw data.

Parameters:
[in] | aTimeStamp | Time stamp.
[in] | aLenelData | Lenel OnGuard data.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLenelRefreshNames ( )

Create action 'Lenel refresh names'.

Lenel OnGuard refresh names.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLenelSecurityEvent | ( | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText
 | ) |  |

Create action 'Lenel security event'.

Lenel OnGuard security event.

Parameters:
[in] | aID | The ID that uniquely identifies the type of this event.
[in] | aPanel | The name of the panel where this event originated.
[in] | aDevice | The name of the device where this event originated.
[in] | aSecondaryDevice | The ID of the secondary device where this event originated.
[in] | aType | Event type i.e., duress, system, etc.
[in] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[in] | aDescription | A human readable, brief description of this event.
[in] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[in] | aTimeStamp | Time stamp.
[in] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[in] | aEventText | Text associated with event
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLenelVideoEvent | ( | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int32 * | aChannel,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime * | aEndTime,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText
 | ) |  |

Create action 'Lenel video event'.

Lenel OnGuard video event.

Parameters:
[in] | aID | The ID that uniquely identifies the type of this event.
[in] | aPanel | The name of the panel where this event originated.
[in] | aDevice | The name of the device where this event originated.
[in] | aSecondaryDevice | The ID of the secondary device where this event originated.
[in] | aChannel | The physical channel the camera is connected to that is creating this event.
[in] | aType | Event type i.e., duress, system, etc.
[in] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[in] | aDescription | A human readable, brief description of this event.
[in] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[in] | aTimeStamp | Time stamp.
[in] | aStartTime | The time the video event started
[in] | aEndTime | The time the video event ended.
[in] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[in] | aEventText | Text associated with event
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aChannel. aType. aSubType. aSerialNumber. aTimeStamp. aStartTime. aEndTime. aCommServerHostName. aEventText.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLiveCheck | ( | const __int64 & | aCounter,
 |  | const TGLibDateTime & | aDate
 | ) |  |

Create action 'Live check'.

This action will be fired every 10 seconds and is intended for use as live check.

Parameters:
[in] | aCounter | This is the number of already fired live check actions.
[in] | aDate | Current server time.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLogBarcodeData | ( | const wchar_t * | aBarcode,
 |  | const __int64 * | aHash,
 |  | const wchar_t * | aScanner,
 |  | const __int64 * | aAreaID,
 |  | const wchar_t * | aAreaName,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aOrder,
 |  | const wchar_t * | aShipment,
 |  | const wchar_t * | aItem
 | ) |  |

Create action 'Log barcode data'.

Logistic barcode data.

Parameters:
[in] | aBarcode | Barcode.
[in] | aHash | Hash value.
[in] | aScanner | Scanner name or IP address.
[in] | aAreaID | Area number.
[in] | aAreaName | Area name.
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aOrder | Order number.
[in] | aShipment | Shipment number.
[in] | aItem | Item number.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aOrder. aShipment. aItem.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLogBarcodeDataLPS | ( | const wchar_t * | aBarcode,
 |  | const __int64 * | aHash,
 |  | const wchar_t * | aScanner,
 |  | const __int64 * | aAreaID,
 |  | const wchar_t * | aAreaName,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const double * | aX,
 |  | const double * | aY,
 |  | const double * | aZ,
 |  | const __int32 * | aLpsTagID,
 |  | const PlcLpsStatus * | aLpsStatus,
 |  | const __int32 * | aLpsCellID,
 |  | const __int32 * | aLpsAreaID,
 |  | const __int32 * | aUserParam,
 |  | const wchar_t * | aOrder,
 |  | const wchar_t * | aShipment,
 |  | const wchar_t * | aItem
 | ) |  |

Create action 'Log barcode data LPS'.

Logistic barcode and LPS data.

Parameters:
[in] | aBarcode | Barcode.
[in] | aHash | Hash value.
[in] | aScanner | Scanner name or IP address.
[in] | aAreaID | Area number.
[in] | aAreaName | Area name.
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aX | X coordinate.
[in] | aY | Y coordinate.
[in] | aZ | Z coordinate.
[in] | aLpsTagID | LPS tag ID.
[in] | aLpsStatus | LPS status.
[in] | aLpsCellID | LPS cell ID.
[in] | aLpsAreaID | LPS area ID.
[in] | aUserParam | User param.
[in] | aOrder | Order number.
[in] | aShipment | Shipment number.
[in] | aItem | Item number.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aX. aY. aZ. aLpsTagID. aLpsStatus. aLpsCellID. aLpsAreaID. aUserParam. aOrder. aShipment. aItem.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLogNPRRecognition | ( | const wchar_t * | aPlateNo,
 |  | const __int64 * | aHash,
 |  | const wchar_t * | aCountry,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const PlcNPRRestriction * | aRestriction,
 |  | const wchar_t * | aCategory
 | ) |  |

Create action 'Log NPR recognition'.

Log NPR recognition.

Parameters:
[in] | aPlateNo | Recognized plate no.
[in] | aHash | Hash value.
[in] | aCountry | Country.
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aRestriction | Restriction of recognized number.
[in] | aCategory | Category of recognized number.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aHash. aCountry. aChannel. aTimeStamp. aRestriction. aCategory.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLPSPositionData | ( | const __int32 | aTagID,
 |  | const wchar_t * | aScannerID,
 |  | const __int64 & | aX,
 |  | const __int64 & | aY,
 |  | const __int64 * | aZ,
 |  | const double * | aLatitude,
 |  | const double * | aLongitude,
 |  | const __int32 | aAreaID,
 |  | const __int32 * | aCellID,
 |  | const PlcLpsStatus | aStatus,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aData,
 |  | const wchar_t * | aAreaName
 | ) |  |

Create action 'LPS position data'.

LPS position data.

Parameters:
[in] | aTagID | Tag ID.
[in] | aScannerID | Scanner ID or IP address.
[in] | aX | X coordinate of cartesian coordinates.
[in] | aY | Y coordinate of cartesian coordinates.
[in] | aZ | Z coordinate of cartesian coordinates.
[in] | aLatitude | Latitude of geographic coordinates.
[in] | aLongitude | Longitude of geographic coordinates.
[in] | aAreaID | Area ID.
[in] | aCellID | Cell ID.
[in] | aStatus | Status.
[in] | aTimeStamp | Time stamp.
[in] | aData | Data.
[in] | aAreaName | Area Name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aScannerID. aZ. aLatitude. aLongitude. aCellID. aTimeStamp. aData. aAreaName.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateLPSQueryPosition | ( | const __int32 | aTagID,
 |  | const wchar_t * | aScannerID,
 |  | const wchar_t * | aData
 | ) |  |

Create action 'LPS query position'.

Send position query for a Tag to LPS server.

Parameters:
[in] | aTagID | Tag ID.
[in] | aScannerID | Scanner ID or IP address.
[in] | aData | Data.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aScannerID. aData.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateMakeCPAReferenceImage ( const TPlcMediaChannelID & aChannel )

Create action 'Make CPA reference image'.

Make CPA reference image.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateMediaChannelSetupInfo | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aParameter
 | ) |  |

Create action 'Media channel setup'.

Media channel setup info.

Parameters:
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aParameter | Parameter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateMoveToAbsolutePosition | ( | const TPlcMediaChannelID & | aCamera,
 |  | const double & | aAlpha,
 |  | const double & | aBeta,
 |  | const double & | aSpeedAlpha,
 |  | const double & | aSpeedBeta
 | ) |  |

Create action 'Move to absolute position'.

Move camera to absolute position.

Parameters:
[in] | aCamera | PTZ head.
[in] | aAlpha | Alpha angle (-180°/+180°).
[in] | aBeta | Beta angle (-90°/+90°).
[in] | aSpeedAlpha | Speed in alpha direction (0/100 %).
[in] | aSpeedBeta | Speed in beta direction (0/100 %).
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateMoveToBySpeed | ( | const TPlcMediaChannelID & | aCamera,
 |  | const double & | aSpeedAlpha,
 |  | const double & | aSpeedBeta
 | ) |  |

Create action 'Move by speed'.

Move camera by speed.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeedAlpha | Speed in alpha (pan) direction (0/100 %).
[in] | aSpeedBeta | Speed in beta (tilt) direction (0/100 %).
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateMoveToRelativePosition | ( | const TPlcMediaChannelID & | aCamera,
 |  | const double & | aAlpha,
 |  | const double & | aBeta,
 |  | const double & | aSpeedAlpha,
 |  | const double & | aSpeedBeta
 | ) |  |

Create action 'Move to relative position'.

Move camera to relative position.

Parameters:
[in] | aCamera | PTZ head.
[in] | aAlpha | Alpha angle (-180°/+180°).
[in] | aBeta | Beta angle (-90°/+90°).
[in] | aSpeedAlpha | Speed in alpha direction (0/100 %).
[in] | aSpeedBeta | Speed in beta direction (0/100 %).
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateNPRRawData | ( | const wchar_t * | aPlateNo,
 |  | const wchar_t * | aCountry,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcRect & | aZoneRect,
 |  | const __int32 | aWeight,
 |  | const __int32 | aZoneState,
 |  | const __int32 | aZonePlace,
 |  | const __int32 | aSpeed,
 |  | const __int32 | aDirection,
 |  | const __int32 | aZoneIndex,
 |  | const bool | aCurBest,
 |  | const __int32 | aPlateWidth,
 |  | const __int32 | aPlateHeight,
 |  | const __int32 | aPlateAngle,
 |  | const __int32 | aSymHeight,
 |  | const wchar_t * | aType
 | ) |  |

Create action 'NPR raw data'.

NPR raw data.

Parameters:
[in] | aPlateNo | Recognized plate no.
[in] | aCountry | Country.
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aZoneRect | Zone rectangle.
[in] | aWeight | Weight of recognition.
[in] | aZoneState | Zone state.
[in] | aZonePlace | Zone status.
[in] | aSpeed | Speed in km/h
[in] | aDirection | Direction of the motion.
[in] | aZoneIndex | Zone index.
[in] | aCurBest | Current recognition is best.
[in] | aPlateWidth | Plate width.
[in] | aPlateHeight | Plate height.
[in] | aPlateAngle | Plate angle.
[in] | aSymHeight | Symbol height.
[in] | aType | Number type.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateNPRRecognition | ( | const wchar_t * | aPlateNo,
 |  | const wchar_t * | aCountry,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcRect & | aZoneRect,
 |  | const PlcNPRRestriction | aRestriction,
 |  | const wchar_t * | aCategory,
 |  | const __int32 | aSpeed,
 |  | const __int32 | aDirection,
 |  | const __int32 | aZoneIndex,
 |  | const wchar_t * | aType,
 |  | const __int32 | aWeight
 | ) |  |

Create action 'NPR recognition'.

NPR recognition.

Parameters:
[in] | aPlateNo | Recognized plate no.
[in] | aCountry | Country.
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aZoneRect | Zone rectangle.
[in] | aRestriction | Restriction of recognized number.
[in] | aCategory | Category of recognized number.
[in] | aSpeed | Speed in km/h
[in] | aDirection | Direction of the motion.
[in] | aZoneIndex | Zone index.
[in] | aType | Number type.
[in] | aWeight | Weight of recognition.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackChannelCounter | ( | const TPlcMediaChannelID & | aChannel,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const __int32 | aObjectDirection,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime * | aResetTimeStamp
 | ) |  |

Create action 'OBTRACK channel counter'.

OBTRACK channel counter.

Parameters:
[in] | aChannel | Channel.
[in] | aCounterType | Counter type.
[in] | aCounterValue | Counter value.
[in] | aObjectDirection | Object direction.
[in] | aTimeStamp | Time stamp.
[in] | aResetTimeStamp | Reset time stamp.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aResetTimeStamp.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackChannelCounterThreshold | ( | const TPlcMediaChannelID & | aChannel,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const PlcObtrackExceedingDirection | aExceedingDirection,
 |  | const TGLibDateTime & | aTimeStamp
 | ) |  |

Create action 'OBTRACK channel counter threshold'.

OBTRACK channel counter threshold.

Parameters:
[in] | aChannel | Channel.
[in] | aCounterType | Counter type.
[in] | aCounterValue | Counter value.
[in] | aExceedingDirection | Exceeding direction.
[in] | aTimeStamp | Time stamp.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackChannelSetCounter | ( | const TPlcMediaChannelID & | aChannel,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const TGLibDateTime & | aTimeStamp
 | ) |  |

Create action 'OBTRACK channel set counter'.

OBTRACK channel set counter.

Parameters:
[in] | aChannel | Channel.
[in] | aCounterType | Counter type.
[in] | aCounterValue | Counter value.
[in] | aTimeStamp | Time stamp.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackFrameRawData | ( | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 | aBrightness,
 |  | const __int32 | aContrast
 | ) |  |

Create action 'OBTRACK frame raw data'.

OBTRACK frame raw data.

Parameters:
[in] | aTimeStamp | Time stamp.
[in] | aChannel | Channel.
[in] | aBrightness | Brightness.
[in] | aContrast | Contrast.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackGroupCounter | ( | const __int32 | aGroupId,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const __int32 | aObjectDirection,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime * | aResetTimeStamp,
 |  | const wchar_t * | aGroupName
 | ) |  |

Create action 'OBTRACK group counter'.

OBTRACK group counter.

Parameters:
[in] | aGroupId | Group ID.
[in] | aCounterType | Counter type.
[in] | aCounterValue | Counter value.
[in] | aObjectDirection | Object direction.
[in] | aTimeStamp | Time stamp.
[in] | aResetTimeStamp | Reset time stamp.
[in] | aGroupName | Group name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aResetTimeStamp. aGroupName.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackGroupCounterThreshold | ( | const __int32 | aGroupId,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const PlcObtrackExceedingDirection | aExceedingDirection,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aGroupName
 | ) |  |

Create action 'OBTRACK group counter threshold'.

OBTRACK group counter threshold.

Parameters:
[in] | aGroupId | Group ID.
[in] | aCounterType | Counter type.
[in] | aCounterValue | Counter value.
[in] | aExceedingDirection | Exceeding direction.
[in] | aTimeStamp | Time stamp.
[in] | aGroupName | Group name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aGroupName.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackGroupSetCounter | ( | const __int32 | aGroupId,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aGroupName
 | ) |  |

Create action 'OBTRACK group set counter'.

OBTRACK group set counter.

Parameters:
[in] | aGroupId | Group ID.
[in] | aCounterType | Counter type.
[in] | aCounterValue | Counter value.
[in] | aTimeStamp | Time stamp.
[in] | aGroupName | Group name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aGroupName.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackObjectRawData | ( | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 | aArea,
 |  | const __int32 | aObjectID,
 |  | const PlcObtrackObjectStatus | aObjectStatus,
 |  | const PlcObtrackObjectClass | aObjectClass,
 |  | const __int32 * | aConfidence,
 |  | const TPlcRect * | aPosition,
 |  | const double * | aSpeed,
 |  | const __int32 * | aDuration,
 |  | const __int32 * | aDirection,
 |  | const double * | aSize,
 |  | const double * | aObjectWidth,
 |  | const double * | aObjectHeight,
 |  | const PlcObtrackProcessSize * | aProcessSize,
 |  | const char * | aGscNetName
 | ) |  |

Create action 'OBTRACK object raw data'.

OBTRACK object raw data.

Parameters:
[in] | aTimeStamp | Time stamp.
[in] | aChannel | Channel.
[in] | aArea | Area no.
[in] | aObjectID | Object ID.
[in] | aObjectStatus | Object status.
[in] | aObjectClass | Object class.
[in] | aConfidence | Confidence.
[in] | aPosition | Position.
[in] | aSpeed | Speed.
[in] | aDuration | Duration.
[in] | aDirection | Direction.
[in] | aSize | Object size.
[in] | aObjectWidth | Object width in meters.
[in] | aObjectHeight | Object height in meters.
[in] | aProcessSize | Process size.
[in] | aGscNetName | GeViScope network name.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aConfidence. aPosition. aSpeed. aDuration. aDirection. aSize. aObjectWidth. aObjectHeight. aProcessSize. aGscNetName.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateObtrackTunnelAlarm | ( | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const PlcTunnelAlarmReason | aAlarmReason,
 |  | const __int32 | aObjectID,
 |  | const __int32 | aAlarmAreaID,
 |  | const TPlcRect * | aObjectArea
 | ) |  |

Create action 'OBTRACK tunnel alarm'.

OBTRACK tunnel alarm notification.

Parameters:
[in] | aChannel | Channel.
[in] | aTimeStamp | Time stamp.
[in] | aAlarmReason | Alarm reason.
[in] | aObjectID | Object ID.
[in] | aAlarmAreaID | Alarm area ID.
[in] | aObjectArea | Object area.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aObjectArea.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePanAuto | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aModus
 | ) |  |

Create action 'Pan auto'.

Turn auto pan of the camera.

Parameters:
[in] | aCamera | PTZ head.
[in] | aModus | Pan modus.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePanLeft | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Pan left'.

Pan camera to the left.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Pan speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePanRight | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Pan right'.

Pan camera to the right.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Pan speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePanStop ( const TPlcMediaChannelID & aCamera )

Create action 'Pan stop'.

Stop pan movement.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePOSData | ( | const wchar_t * | aPOSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aArticle,
 |  | const double * | aPrice,
 |  | const __int32 * | aUnits,
 |  | const double * | aPricePerUnit,
 |  | const wchar_t * | aLine1,
 |  | const wchar_t * | aLine2,
 |  | const wchar_t * | aLine3,
 |  | const wchar_t * | aLine4,
 |  | const wchar_t * | aLine5
 | ) |  |

Create action 'POS data'.

POS data.

Parameters:
[in] | aPOSName | POS name.
[in] | aTimeStamp | Time stamp.
[in] | aArticle | Article description.
[in] | aPrice | Price.
[in] | aUnits | Number of units.
[in] | aPricePerUnit | Price per unit.
[in] | aLine1 | Line 1.
[in] | aLine2 | Line 2.
[in] | aLine3 | Line 3.
[in] | aLine4 | Line 4.
[in] | aLine5 | Line 5.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aArticle. aPrice. aUnits. aPricePerUnit. aLine1. aLine2. aLine3. aLine4. aLine5.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePOSStatus | ( | const wchar_t * | aPOSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const PlcPOSStatus | aStatus,
 |  | const wchar_t * | aDetails
 | ) |  |

Create action 'POS status'.

POS status.

Parameters:
[in] | aPOSName | POS name.
[in] | aTimeStamp | Time stamp.
[in] | aStatus | Status.
[in] | aDetails | Details.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDetails.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPDeviceAlarm | ( | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const PPSensorKind | aSensor,
 |  | const PPAlarmState | aState
 | ) |  |

Create action 'PP device alarm'.

Perimeter protection device alarm.

Parameters:
[in] | aInterfaceID | Interface ID.
[in] | aDeviceAddress | Device address.
[in] | aSensor | Sensor.
[in] | aState | State.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPDeviceInput | ( | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const __int32 | aInput,
 |  | const PPAlarmState | aState
 | ) |  |

Create action 'PP device input'.

Perimeter protection device input.

Parameters:
[in] | aInterfaceID | Interface ID.
[in] | aDeviceAddress | Device address.
[in] | aInput | Input.
[in] | aState | State.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPDeviceOffline | ( | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress
 | ) |  |

Create action 'PP device offline'.

Perimeter protection device offline.

Parameters:
[in] | aInterfaceID | Interface ID.
[in] | aDeviceAddress | Device address.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPDeviceOnline | ( | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress
 | ) |  |

Create action 'PP device online'.

Perimeter protection device online.

Parameters:
[in] | aInterfaceID | Interface ID.
[in] | aDeviceAddress | Device address.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPInterfaceOffline ( const wchar_t * aInterfaceID )

Create action 'PP interface offline'.

Perimeter protection interface offline.

Parameters:
[in] aInterfaceID Interface ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPInterfaceOnline ( const wchar_t * aInterfaceID )

Create action 'PP interface online'.

Perimeter protection interface online.

Parameters:
[in] aInterfaceID Interface ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPQueryInterface ( const wchar_t * aInterfaceID )

Create action 'PP query interface'.

Perimeter protection query interface.

Parameters:
[in] aInterfaceID Interface ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPSetDeviceOutput | ( | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const __int32 | aOutput,
 |  | const PPAlarmState | aState
 | ) |  |

Create action 'PP set device output'.

Perimeter protection set device output.

Parameters:
[in] | aInterfaceID | Interface ID.
[in] | aDeviceAddress | Device address.
[in] | aOutput | Output.
[in] | aState | State.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPSubcellAlarm | ( | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const PPCableKind | aCable,
 |  | const __int32 | aSubcell,
 |  | const PPAlarmState | aState
 | ) |  |

Create action 'PP subcell alarm'.

Perimeter protection subcell alarm.

Parameters:
[in] | aInterfaceID | Interface ID.
[in] | aDeviceAddress | Device address.
[in] | aCable | Cable.
[in] | aSubcell | Subcell.
[in] | aState | State.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePPZoneAlarm | ( | const wchar_t * | aZoneID,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const PPCableKind * | aCable,
 |  | const __int32 * | aSubcell,
 |  | const PPAlarmState | aState
 | ) |  |

Create action 'PP zone alarm'.

Perimeter protection zone alarm.

Parameters:
[in] | aZoneID | Zone ID.
[in] | aInterfaceID | Interface ID.
[in] | aDeviceAddress | Device address.
[in] | aCable | Cable.
[in] | aSubcell | Subcell.
[in] | aState | State.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aCable. aSubcell.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePrePosCallUp | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition
 | ) |  |

Create action 'Move to preset position'.

Move camera to preset position.

Parameters:
[in] | aCamera | PTZ head.
[in] | aPosition | Preset position.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePrePosClear | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition
 | ) |  |

Create action 'Clear preset position'.

Clear camera preset position.

Parameters:
[in] | aCamera | PTZ head.
[in] | aPosition | Preset position.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreatePrePosSave | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition
 | ) |  |

Create action 'Save preset position'.

Save current camera position as preset position.

Parameters:
[in] | aCamera | PTZ head.
[in] | aPosition | Preset position.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateRedundantPowerFailure ( )

Create action 'Redundant power failure'.

This action is notified if a failure of the redundant power supply is detected.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateRedundantPowerOk ( )

Create action 'Redundant power ok'.

This action is notified if a failure of the redundant power supply is removed.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateResetMainboard ( )

Create action 'Reset mainboard'.

Reset mainboard using IO device.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSafebagClose | ( | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const double * | aDebit,
 |  | const double * | aTotal,
 |  | const double * | aDifference,
 |  | const bool * | aHasDifference,
 |  | const wchar_t * | aNotes,
 |  | const wchar_t * | aCoins,
 |  | const wchar_t * | aCheques
 | ) |  |

Create action 'Safebag close'.

Safebag close.

Parameters:
[in] | aWorkingPlace | Working place no.
[in] | aStartTime | Start time stamp.
[in] | aStopTime | Stop time stamp.
[in] | aSafebagNo | Safebag no.
[in] | aSafebagInfo | Additional info about safebag.
[in] | aStepID | Processing step ID.
[in] | aDebit | Debit.
[in] | aTotal | Total.
[in] | aDifference | Difference between debit and total.
[in] | aHasDifference | Difference between debit and total is not zero.
[in] | aNotes | Notes.
[in] | aCoins | Coins.
[in] | aCheques | Cheques.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSafebagData | ( | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const double * | aDebit,
 |  | const double * | aTotal,
 |  | const double * | aDifference,
 |  | const bool * | aHasDifference,
 |  | const wchar_t * | aNotes,
 |  | const wchar_t * | aCoins,
 |  | const wchar_t * | aCheques
 | ) |  |

Create action 'Safebag data'.

Safebag data.

Parameters:
[in] | aWorkingPlace | Working place no.
[in] | aStartTime | Start time stamp.
[in] | aSafebagNo | Safebag no.
[in] | aSafebagInfo | Additional info about safebag.
[in] | aStepID | Processing step ID.
[in] | aDebit | Debit.
[in] | aTotal | Total.
[in] | aDifference | Difference between debit and total.
[in] | aHasDifference | Difference between debit and total is not zero.
[in] | aNotes | Notes.
[in] | aCoins | Coins.
[in] | aCheques | Cheques.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSafebagOpen | ( | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID
 | ) |  |

Create action 'Safebag open'.

Safebag open.

Parameters:
[in] | aWorkingPlace | Working place no.
[in] | aStartTime | Start time stamp.
[in] | aSafebagNo | Safebag no.
[in] | aSafebagInfo | Additional info about safebag.
[in] | aStepID | Processing step ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSafebagPassingOfRiskData | ( | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const __int32 | aUserID1,
 |  | const __int32 | aUserID2,
 |  | const __int32 * | aTourNumber,
 |  | const wchar_t * | aTargetWorkingPlace,
 |  | const wchar_t * | aPassingOfRiskType
 | ) |  |

Create action 'Safebag passing of risk data'.

Safebag passing of risk data.

Parameters:
[in] | aWorkingPlace | Working place no.
[in] | aStartTime | Start time stamp.
[in] | aSafebagNo | Safebag no.
[in] | aSafebagInfo | Additional info about safebag.
[in] | aStepID | Processing step ID.
[in] | aUserID1 | User who gives the safebag.
[in] | aUserID2 | User who takes the safebag.
[in] | aTourNumber | Optional tour no.
[in] | aTargetWorkingPlace | Target working place.
[in] | aPassingOfRiskType | Passing of risk type.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aTourNumber. aTargetWorkingPlace. aPassingOfRiskType.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSafebagPassingOfRiskStart | ( | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const __int32 | aUserID1,
 |  | const __int32 | aUserID2,
 |  | const __int32 * | aTourNumber,
 |  | const wchar_t * | aTargetWorkingPlace,
 |  | const wchar_t * | aPassingOfRiskType
 | ) |  |

Create action 'Safebag passing of risk start'.

Safebag passing of risk start.

Parameters:
[in] | aWorkingPlace | Working place no.
[in] | aStartTime | Start time stamp.
[in] | aSafebagNo | Safebag no.
[in] | aSafebagInfo | Additional info about safebag.
[in] | aStepID | Processing step ID.
[in] | aUserID1 | User who gives the safebag.
[in] | aUserID2 | User who takes the safebag.
[in] | aTourNumber | Optional tour no.
[in] | aTargetWorkingPlace | Target working place.
[in] | aPassingOfRiskType | Passing of risk type.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aTourNumber. aTargetWorkingPlace. aPassingOfRiskType.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSafebagPassingOfRiskStop | ( | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const __int32 | aUserID1,
 |  | const __int32 | aUserID2,
 |  | const __int32 * | aTourNumber,
 |  | const wchar_t * | aTargetWorkingPlace,
 |  | const wchar_t * | aPassingOfRiskType
 | ) |  |

Create action 'Safebag passing of risk stop'.

Safebag passing of risk stop.

Parameters:
[in] | aWorkingPlace | Working place no.
[in] | aStartTime | Start time stamp.
[in] | aStopTime | Stop time stamp.
[in] | aSafebagNo | Safebag no.
[in] | aSafebagInfo | Additional info about safebag.
[in] | aStepID | Processing step ID.
[in] | aUserID1 | User who gives the safebag.
[in] | aUserID2 | User who takes the safebag.
[in] | aTourNumber | Optional tour no.
[in] | aTargetWorkingPlace | Target working place.
[in] | aPassingOfRiskType | Passing of risk type.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aTourNumber. aTargetWorkingPlace. aPassingOfRiskType.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSceneStoreModification | ( | const TPlcMediaChannelID & | aViewer,
 |  | const GUID & | aSceneStoreID,
 |  | const wchar_t * | aSceneStoreName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const PlcSceneStoreModificationType | aModificationType,
 |  | const wchar_t * | aUser,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'Scene store modification'.

Scene store modification.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aSceneStoreID | Scene store GUID.
[in] | aSceneStoreName | Scene store name.
[in] | aTimeStamp | Time stamp.
[in] | aModificationType | Modification type.
[in] | aUser | Name of the user.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSensorAlarmFinished | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType
 | ) |  |

Create action 'Sensor alarm finished'.

This action will be fired when the alarm is finished.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSensorAudioAlarm ( const TPlcMediaChannelID & aChannel )

Create action 'Sensor audio alarm'.

Audio alarm detected.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSensorInhibitAlarmFinished | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType
 | ) |  |

Create action 'Sensor inhibit alarm finished'.

This action will be fired when the inhibit alarm is finished.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSensorInhibitVideoAlarmEx | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const ADArea * | aADArea,
 |  | const __int32 * | aADCell,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone,
 |  | const VMDCycle * | aVMDCycle,
 |  | const TPlcRect * | aAlarmArea,
 |  | const PlcObtrackObjectClass * | aObjectClass
 | ) |  |

Create action 'Sensor inhibit video alarm'.

This action will be fired when the motion in inhibit area is detected.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aADArea | AD alarm area.
[in] | aADCell | AD cell nr.
[in] | aVMDGroup | VMD alarm group.
[in] | aVMDZone | VMD zone nr.
[in] | aVMDCycle | VMD measure cycle.
[in] | aAlarmArea | Alarm area.
[in] | aObjectClass | OBTRACK object class.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSensorVideoAlarmEx | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const ADArea * | aADArea,
 |  | const __int32 * | aADCell,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone,
 |  | const VMDCycle * | aVMDCycle,
 |  | const TPlcRect * | aAlarmArea,
 |  | const PlcObtrackObjectClass * | aObjectClass
 | ) |  |

Create action 'Sensor video alarm'.

This action will be fired when video alarm is detected.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aADArea | AD alarm area.
[in] | aADCell | AD cell nr.
[in] | aVMDGroup | VMD alarm group.
[in] | aVMDZone | VMD zone nr.
[in] | aVMDCycle | VMD measure cycle.
[in] | aAlarmArea | Alarm area.
[in] | aObjectClass | OBTRACK object class.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetCameraText | ( | const TPlcMediaChannelID & | aCamera,
 |  | const char * | aText
 | ) |  |

Create action 'Set camera text'.

Set camera text.

Parameters:
[in] | aCamera | PTZ head.
[in] | aText | Text to superimpose.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetClientVCA | ( | const TPlcMediaChannelID & | aChannel,
 |  | const GTectClientVCAType | aClientVCAType,
 |  | const bool | aEnabled
 | ) |  |

Create action 'Enable client VCA'.

Enable client VCA

Parameters:
[in] | aChannel | Channel.
[in] | aClientVCAType | VCA Type
[in] | aEnabled | Enabled
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetClock ( const TGLibDateTime & aDate )

Create action 'Set clock'.

Set clock.

Parameters:
[in] aDate Current time.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetDigitalOutput | ( | const TPlcMediaChannelID & | aContact,
 |  | const DigitalOutputState | aState
 | ) |  |

Create action 'Set digital output'.

This action is used to modify the state of the digital output and to notify this change.

Parameters:
[in] | aContact | Contact.
[in] | aState | New state.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetExportMarker | ( | const TPlcMediaChannelID & | aViewer,
 |  | const PlcExportMarker | aMarker
 | ) |  |

Create action 'Set export marker'.

Set export marker.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aMarker | Marker kind.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetLED | ( | const SystemLED | aLED,
 |  | const DigitalOutputState | aState
 | ) |  |

Create action 'Set system LED'.

This action is used to turn the system LEDs on or off.

Parameters:
[in] | aLED | System LED.
[in] | aState | New state.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetLEDBlink | ( | const SystemLED | aLED,
 |  | const __int32 | aLedTimeOnMs,
 |  | const __int32 | aLedTimeOffMs
 | ) |  |

Create action 'Set system LED to blink'.

This action is used to blink the system LEDs.

Parameters:
[in] | aLED | System LED.
[in] | aLedTimeOnMs | Time in milliseconds when the LED will be switched on.
[in] | aLedTimeOffMs | Time in milliseconds when the LED will be switched off.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetSystemTime ( const TGLibDateTime & aTimeStamp )

Create action 'Set system time'.

Set system time.

Parameters:
[in] aTimeStamp Time stamp.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetTestPictureMode | ( | const TPlcMediaChannelID & | aChannel,
 |  | const bool | aMode
 | ) |  |

Create action 'Set test picture mode'.

Enable or disable test picture generator.

Parameters:
[in] | aChannel | Channel.
[in] | aMode | Enable or disable test picture generator.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetupChanged | ( | const wchar_t * | aUser,
 |  | const wchar_t * | aHost,
 |  | const TGLibDateTime & | aDate,
 |  | const PlcResourceKind | aResourceKind,
 |  | const TPlcEventTypeID & | aResourceID,
 |  | const PlcResourceChangeKind | aChangeKind,
 |  | const wchar_t * | aDetails,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'Setup changed'.

Setup changed.

Parameters:
[in] | aUser | Name of the user who modified the setup.
[in] | aHost | Host from where the connection was done.
[in] | aDate | Current time.
[in] | aResourceKind | Modified resource kind.
[in] | aResourceID | Modified resource ID.
[in] | aChangeKind | Change kind.
[in] | aDetails | Details of the modification.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDetails. aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetupUploadProgress | ( | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const __int32 | aProgress,
 |  | const TGLibDateTime & | aDate
 | ) |  |

Create action 'Setup upload progress'.

Setup upload progress.

Parameters:
[in] | aUser1 | Name of the user who modified the setup.
[in] | aUser2 | Name of the second user by four eyes authentication.
[in] | aHost | Host from where the connection was done.
[in] | aProgress | Progress in percent.
[in] | aDate | Current stage time.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aUser1. aUser2. aHost.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSetWatchdog ( const __int32 aTimeout )

Create action 'Set watchdog'.

Set watchdog.

Parameters:
[in] aTimeout Timeout in seconds, before the watchdog must be retriggered and before the hardware watchdog will set the hardware contact.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSkidataControl | ( | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataControl | aData
 | ) |  |

Create action 'SKIDATA control'.

SKIDATA control information.

Parameters:
[in] | aInterfaceName | Interface name.
[in] | aData | Interface state.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSkidataDeviceEvent | ( | const wchar_t * | aInterfaceName,
 |  | const __int32 | aDeviceID,
 |  | const __int32 | aEventCode
 | ) |  |

Create action 'SKIDATA device event'.

SKIDATA device event.

Parameters:
[in] | aInterfaceName | Interface name.
[in] | aDeviceID | Device ID.
[in] | aEventCode | Event code.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSkidataEntry | ( | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataMsgCodeEntry | aMessageCode,
 |  | const wchar_t * | aTranscactionID,
 |  | const __int32 | aCarParkNo,
 |  | const __int32 | aDeviceID
 | ) |  |

Create action 'SKIDATA entry'.

SKIDATA entry.

Parameters:
[in] | aInterfaceName | Interface name.
[in] | aMessageCode | Message code.
[in] | aTranscactionID | Transcaction ID.
[in] | aCarParkNo | Car park no.
[in] | aDeviceID | Device ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSkidataExit | ( | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataMsgCodeExit | aMessageCode,
 |  | const wchar_t * | aTranscactionID,
 |  | const __int32 | aCarParkNo,
 |  | const __int32 | aDeviceID
 | ) |  |

Create action 'SKIDATA exit'.

SKIDATA exit.

Parameters:
[in] | aInterfaceName | Interface name.
[in] | aMessageCode | Message code.
[in] | aTranscactionID | Transcaction ID.
[in] | aCarParkNo | Car park no.
[in] | aDeviceID | Device ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSkidataTransaction | ( | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataMsgCodeTransaction | aMessageCode,
 |  | const wchar_t * | aTranscactionID,
 |  | const __int32 | aCarParkNo,
 |  | const __int32 | aDeviceID
 | ) |  |

Create action 'SKIDATA transaction'.

SKIDATA transaction.

Parameters:
[in] | aInterfaceName | Interface name.
[in] | aMessageCode | Message code.
[in] | aTranscactionID | Transcaction ID.
[in] | aCarParkNo | Car park no.
[in] | aDeviceID | Device ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSMRPViewerCleared ( )

Create action 'SMRP viewer cleared'.

SMRP viewer cleared.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSMRPViewerConnected | ( | const wchar_t * | aServer,
 |  | const TPlcMediaChannelID & | aChannel
 | ) |  |

Create action 'SMRP viewer connected'.

SMRP viewer connected to the camera.

Parameters:
[in] | aServer | Server name.
[in] | aChannel | Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSMTPMailSend | ( | const wchar_t * | aSubject,
 |  | const wchar_t * | aTo,
 |  | const wchar_t * | aCc,
 |  | const wchar_t * | aBody,
 |  | const TPlcMediaChannelID * | aChannel
 | ) |  |

Create action 'SMTP mail'.

This action will send a user defined email if GSCMail is connected

Parameters:
[in] | aSubject | Mail subject.
[in] | aTo | Mail recipients.
[in] | aCc | Carbon copy recipients.
[in] | aBody | Mail body.
[in] | aChannel | Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aChannel.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStartAutoBackup ( const TPlcResourceID & aSchedule )

Create action 'Start auto backup'.

Start auto backup.

Parameters:
[in] aSchedule Schedule.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStartEventEx | ( | const TPlcEventTypeID & | aTypeID,
 |  | const __int64 * | aForeignKey
 | ) |  |

Create action 'Start event'.

Start event.

Parameters:
[in] | aTypeID | Type of the event.
[in] | aForeignKey | Optional foreign key used to store with alarm.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aForeignKey.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStartRemoteExport | ( | const GUID & | aExportID,
 |  | const GUID & | aDevice,
 |  | const PlcBackupFormat | aBackupFormat,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aSelectionBegin,
 |  | const TGLibDateTime & | aSelectionEnd,
 |  | const wchar_t * | aJobID
 | ) |  |

Create action 'Start remote export'.

Start remote export.

Parameters:
[in] | aExportID | Export GUID.
[in] | aDevice | Pilot device GUID.
[in] | aBackupFormat | Backup format.
[in] | aChannel | Channel.
[in] | aSelectionBegin | Start time.
[in] | aSelectionEnd | End time.
[in] | aJobID | Job ID.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStartSceneStore | ( | const GUID & | aSceneStoreID,
 |  | const wchar_t * | aCutList,
 |  | const __int64 & | aPreHistoryLength,
 |  | const __int64 & | aRecordingLength
 | ) |  |

Create action 'Start scene store'.

Start scene store.

Parameters:
[in] | aSceneStoreID | Scene store GUID.
[in] | aCutList | Cut-list.
[in] | aPreHistoryLength | Pre-history length.
[in] | aRecordingLength | Recording length.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStopAllEvents ( )

Create action 'Stop all events'.

Stop all active events.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStopEvent ( const TPlcEventTypeID & aTypeID )

Create action 'Stop event'.

Stop event.

Parameters:
[in] aTypeID Type of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStopEventByID ( const __int64 & aEventID )

Create action 'Stop event by instance'.

Stop event by instance ID.

Parameters:
[in] aEventID Instance ID of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSystemError | ( | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo
 | ) |  |

Create action 'System error'.

Notify system error.

Parameters:
[in] | aSource | Source of the message.
[in] | aMessage | Kind of the message.
[in] | aWindowsError | Optional Windows error code.
[in] | aDescription | Optional description of the message.
[in] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aWindowsError. aDescription. aXMLInfo.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSystemInfo | ( | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo
 | ) |  |

Create action 'System info'.

Notify system information.

Parameters:
[in] | aSource | Source of the message.
[in] | aMessage | Kind of the message.
[in] | aDescription | Optional description of the message.
[in] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aDescription. aXMLInfo.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSystemSettingsChanged | ( | const bool | aSetupChanged,
 |  | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const bool | aTimeRangeChanged,
 |  | const TPlcResourceID * | aTimeRange,
 |  | const bool | aLicenceChanged,
 |  | const TGLibDateTime & | aDate
 | ) |  |

Create action 'System settings changed'.

Setup of the system and/or the current time range changed.

Parameters:
[in] | aSetupChanged | System setup has changed.
[in] | aUser1 | Name of the user who modified the setup.
[in] | aUser2 | Name of the second user by four eyes authentication.
[in] | aHost | Host from where the connection was done.
[in] | aTimeRangeChanged | Time range has changed.
[in] | aTimeRange | Currently active time range.
[in] | aLicenceChanged | Licence has changed.
[in] | aDate | Time of the system settings changed.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aUser1. aUser2. aHost. aTimeRange.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSystemStarted ( const TGLibDateTime & aDate )

Create action 'System started'.

This action will be fired only once at the system start-up.

Parameters:
[in] aDate Time of the system start-up.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSystemTerminating | ( | const TGLibDateTime & | aDate,
 |  | const bool | aWindowsShutdown
 | ) |  |

Create action 'System terminating'.

This action will be fired when the system is going to be shut down.

Parameters:
[in] | aDate | Time of the system shutdown.
[in] | aWindowsShutdown | Indicates whether the system shutdown is done due to the windows shutdown.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSystemWarning | ( | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo
 | ) |  |

Create action 'System warning'.

Notify system warning.

Parameters:
[in] | aSource | Source of the message.
[in] | aMessage | Kind of the message.
[in] | aWindowsError | Optional Windows error code.
[in] | aDescription | Optional description of the message.
[in] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aWindowsError. aDescription. aXMLInfo.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTemperature | ( | const IODeviceType | aSourceType,
 |  | const wchar_t * | aID,
 |  | const __int32 | aTemperature
 | ) |  |

Create action 'Temperature notification'.

Temperature notification from a/ab USB Alarm-I/O.

Parameters:
[in] | aSourceType | Type of the device, which has fired the action.
[in] | aID | ID of the IO module (like IOI43-00/MIO84-00/MIO168-00).
[in] | aTemperature | Temperature.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTerminalArticleData | ( | const wchar_t * | aTerminalName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const __int32 | aCashierStation,
 |  | const __int32 * | aPumpNo,
 |  | const bool | aAlarmStatus,
 |  | const double * | aAmount,
 |  | const double * | aPrice,
 |  | const wchar_t * | aDetails
 | ) |  |

Create action 'Terminal article data'.

Terminal article data.

Parameters:
[in] | aTerminalName | Terminal name.
[in] | aTimeStamp | Time stamp.
[in] | aCashierStation | Cashier station.
[in] | aPumpNo | Pump no.
[in] | aAlarmStatus | Alarm status.
[in] | aAmount | Amount.
[in] | aPrice | Price.
[in] | aDetails | Details.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aPumpNo. aAmount. aPrice. aDetails.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTerminalPaymentData | ( | const wchar_t * | aTerminalName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const __int32 | aCashierStation,
 |  | const __int32 * | aPumpNo,
 |  | const bool | aAlarmStatus,
 |  | const double * | aAmount,
 |  | const double * | aPrice,
 |  | const wchar_t * | aDetails
 | ) |  |

Create action 'Terminal payment data'.

Terminal payment data.

Parameters:
[in] | aTerminalName | Terminal name.
[in] | aTimeStamp | Time stamp.
[in] | aCashierStation | Cashier station.
[in] | aPumpNo | Pump no.
[in] | aAlarmStatus | Alarm status.
[in] | aAmount | Amount.
[in] | aPrice | Price.
[in] | aDetails | Details.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aPumpNo. aAmount. aPrice. aDetails.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTiltDown | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Tilt down'.

Tilt camera down.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Tilt speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTiltStop ( const TPlcMediaChannelID & aCamera )

Create action 'Tilt stop'.

Stop tilt movement.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTiltUp | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Tilt up'.

Tilt camera up.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Tilt speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTransferBinaryBuffer | ( | const GUID & | aInternalHandle,
 |  | const wchar_t * | aParameter
 | ) |  |

Create action 'Transfer binary buffer'.

Transfer binary buffer.

Parameters:
[in] | aInternalHandle | Internal handle.
[in] | aParameter | Parameter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateTransferBinaryChannelBuffer | ( | const TPlcMediaChannelID & | aChannel,
 |  | const GUID & | aInternalHandle,
 |  | const wchar_t * | aParameter
 | ) |  |

Create action 'Transfer binary channel buffer'.

Transfer binary channel buffer.

Parameters:
[in] | aChannel | Channel.
[in] | aInternalHandle | Internal handle.
[in] | aParameter | Parameter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateUserLogin | ( | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'User login'.

This action will be fired when the user has connected to the system.

Parameters:
[in] | aUser1 | Name of the user connected to the system.
[in] | aUser2 | Name of the second user by four eyes authentication.
[in] | aHost | Host from where the connection is done.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aUser2. aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateUserLoginFailed | ( | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const UserLoginFailureCode | aRejectReason,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'User login failed'.

This action will be fired when the user has tried to connect to the system but was rejected.

Parameters:
[in] | aUser1 | Name of the user who tried to connect to the system.
[in] | aUser2 | Name of the second user by four eyes authentication.
[in] | aHost | Host from where the connection is done.
[in] | aRejectReason | Reason of the rejection.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aUser2. aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateUserLogout | ( | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'User logout'.

This action will be fired when the user has disconnected from the system.

Parameters:
[in] | aUser1 | Name of the user disconnected from the system.
[in] | aUser2 | Name of the second user by four eyes authentication.
[in] | aHost | Host from where the connection was done.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aUser2. aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueConfirm | ( | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode
 | ) |  |

Create action 'VC alarm queue confirm'.

Confirm alarm from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aSelectionMode | Selection mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueConfirmByInstance | ( | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID
 | ) |  |

Create action 'VC alarm queue confirm by instance'.

Confirm alarm from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aAlarmID | Instance ID of the alarm.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueConfirmByType | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode
 | ) |  |

Create action 'VC alarm queue confirm by type'.

Confirm alarm of specific type from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aTypeID | Type of the event.
[in] | aSelectionMode | Selection mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueNotification | ( | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmState | aNotification,
 |  | const __int64 & | aAlarmID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'VC alarm queue notification'.

Alarm queue notification on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aNotification | Alarm state notification.
[in] | aAlarmID | Instance ID of the alarm.
[in] | aTypeID | Type of the event.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueRemove | ( | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode
 | ) |  |

Create action 'VC alarm queue remove'.

Remove alarm from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aSelectionMode | Selection mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueRemoveByInstance | ( | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID
 | ) |  |

Create action 'VC alarm queue remove by instance'.

Remove alarm from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aAlarmID | Instance ID of the alarm.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueRemoveByType | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode
 | ) |  |

Create action 'VC alarm queue remove by type'.

Remove alarm of specific type from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aTypeID | Type of the event.
[in] | aSelectionMode | Selection mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueSelect | ( | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode
 | ) |  |

Create action 'VC alarm queue select'.

Select alarm from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aSelectionMode | Selection mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueSelectByInstance | ( | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID
 | ) |  |

Create action 'VC alarm queue select by instance'.

Select alarm from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aAlarmID | Instance ID of the alarm.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAlarmQueueSelectByType | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode
 | ) |  |

Create action 'VC alarm queue select by type'.

Select alarm of specific type from the queue on the viewer client.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aTypeID | Type of the event.
[in] | aSelectionMode | Selection mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCASetArmed | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const bool | aArmed
 | ) |  |

Create action 'VCA set armed'.

Send this action to notify VCA to be armed or disarmed.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aArmed | Armed (true) or disarmed (false)
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAStatusAnswer | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const bool | aArmed
 | ) |  |

Create action 'VCA status answer'.

This action will be sent in response to VCA status request.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aArmed | Armed (true) or disarmed (false)
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCAStatusRequest | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType
 | ) |  |

Create action 'VCA status request'.

Send this action to request status of VCA. As response VCA will send VCA status answer.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCChangeSceneByName | ( | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aScene
 | ) |  |

Create action 'VC change scene by name'.

Viewer client change scene by name.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aScene | Scene name.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCClearSceneByName | ( | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aScene
 | ) |  |

Create action 'VC clear scene by name'.

Viewer client clear scene by name.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aScene | Scene name.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCFullMode | ( | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aFullMode,
 |  | const bool | aSensitiveAreaEnabled
 | ) |  |

Create action 'VC full mode'.

Viewer client full mode.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aFullMode | Switch viewer client in full mode.
[in] | aSensitiveAreaEnabled | Sensitive area enabled.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCSceneChanged | ( | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aScene
 | ) |  |

Create action 'VC scene changed'.

Viewer client scene changed.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aScene | Scene name.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCSetAudioLevel | ( | const TPlcMediaChannelID & | aViewer,
 |  | const __int32 | aAudioLevel
 | ) |  |

Create action 'VC set audio level'.

Viewer client set audio level.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aAudioLevel | Audio level in range 0 (audio off) till 100 (max. volume).
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCShowViewerText | ( | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aShowText
 | ) |  |

Create action 'VC show viewer text'.

Viewer client show viewer text.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aShowText | Show text in viewer client.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVCStretchMode | ( | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aStretchMode
 | ) |  |

Create action 'VC stretch mode'.

Viewer client stretch mode.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aStretchMode | Switch viewer client in stretch mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoContrastDetected ( const TPlcMediaChannelID & aChannel )

Create action 'Video contrast detected'.

This action will be fired when the contrast is detected in the video signal.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoContrastFailed ( const TPlcMediaChannelID & aChannel )

Create action 'Video contrast failed'.

This action will be fired when the contrast is lost in the video signal.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoSetImageBrightness | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const __int32 | aBrightness
 | ) |  |

Create action 'Video set image brightness'.

Video set image brightness.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aBrightness | Brightness.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoSetImageContrast | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const __int32 | aContrast
 | ) |  |

Create action 'Video set image contrast'.

Video set image contrast.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aContrast | Contrast.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoSetImageSaturation | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const __int32 | aSaturation
 | ) |  |

Create action 'Video set image saturation'.

Video set image saturation.

Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aSaturation | Saturation.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoSourceChanged | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSignalNorm | aSignalNorm,
 |  | const VideoSignalType | aSignalType,
 |  | const VideoInterlaceType | aInterlaceType
 | ) |  |

Create action 'Video source has changed'.

This action indicates the changes on the video input source.

Parameters:
[in] | aChannel | Channel.
[in] | aSignalNorm | New signal norm.
[in] | aSignalType | New signal type.
[in] | aInterlaceType | New interlace type.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoSyncDetected ( const TPlcMediaChannelID & aChannel )

Create action 'Video sync detected'.

This action will be fired when the sync is detected in the video signal.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateVideoSyncFailed ( const TPlcMediaChannelID & aChannel )

Create action 'Video sync failed'.

This action will be fired when the sync is lost in the video signal.

Parameters:
[in] aChannel Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerChangeScene ( const TPlcMediaChannelID & aViewer )

Create action 'Viewer change scene'.

Viewer change scene.

Parameters:
[in] aViewer Global viewer or viewer client no.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerClear ( const TPlcMediaChannelID & aViewer )

Create action 'Viewer clear'.

Clear viewer.

Parameters:
[in] aViewer Global viewer or viewer client no.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerCleared | ( | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'Viewer cleared'.

Viewer cleared.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerClearScene ( const TPlcMediaChannelID & aViewer )

Create action 'Viewer clear scene'.

Viewer clear scene.

Parameters:
[in] aViewer Global viewer or viewer client no.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerClearTextOutput ( const TPlcMediaChannelID & aViewer )

Create action 'Viewer clear text output'.

Clear text output in the given viewer.

Parameters:
[in] aViewer Global viewer or viewer client no.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerConnect | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode
 | ) |  |

Create action 'Viewer connect'.

Connect camera to the viewer.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aChannel | Channel.
[in] | aPlayMode | Viewer play mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerConnected | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'Viewer connected'.

Viewer connected to the camera.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aChannel | Channel.
[in] | aPlayMode | Viewer play mode.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerConnectLive | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel
 | ) |  |

Create action 'Viewer connect live'.

Connect live camera to the viewer.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aChannel | Channel.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerExportPicture | ( | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aFilePath
 | ) |  |

Create action 'Viewer export picture'.

Viewer export picture.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aFilePath | File path (local or UNC). GSCView default path is used if left empty.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerJumpByTime | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const __int32 | aTimeInSec
 | ) |  |

Create action 'Viewer jump by time'.

Viewer jump by time.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aChannel | Channel.
[in] | aPlayMode | Viewer play mode.
[in] | aTimeInSec | Time to jump in seconds. Use negative values to jump in past.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerMaximize | ( | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aMaximize
 | ) |  |

Create action 'Viewer maximize'.

Viewer maximize.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aMaximize | Maximize.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerPlayFromTime | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const TGLibDateTime & | aTime
 | ) |  |

Create action 'Viewer play from time'.

Viewer play from time.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aChannel | Channel.
[in] | aPlayMode | Viewer play mode.
[in] | aTime | Time to play from.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerPlayModeChanged | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const TGLibDateTime * | aChannelTime,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'Viewer play mode changed'.

Viewer play mode changed.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aChannel | Channel.
[in] | aPlayMode | Viewer play mode.
[in] | aChannelTime | Channel time.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aChannelTime. aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerPrintPicture ( const TPlcMediaChannelID & aViewer )

Create action 'Viewer print picture'.

Viewer print picture.

Parameters:
[in] aViewer Global viewer or viewer client no.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerSelect ( const TPlcMediaChannelID & aViewer )

Create action 'Viewer select'.

Select viewer.

Parameters:
[in] aViewer Global viewer or viewer client no.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerSelectionChanged | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount
 | ) |  |

Create action 'Viewer selection changed'.

Viewer selection was changed.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aChannel | Channel.
[in] | aPlayMode | Viewer play mode.
[in] | aClientHost | Host from where the connection is done.
[in] | aClientType | Client type.
[in] | aClientAccount | User account from where the connection is done.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerSetPlayMode | ( | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const __int32 | aPlaySpeed
 | ) |  |

Create action 'Viewer set play mode'.

Set play mode of the viewer.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aPlayMode | Viewer play mode.
[in] | aPlaySpeed | Optional play speed parameter.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerShowAlarmByInstance | ( | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID,
 |  | const PlcViewerAlarmPlayMode | aPlayMode
 | ) |  |

Create action 'Viewer show alarm by instance'.

Show alarm in viewer using alarm instance ID.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aAlarmID | Instance ID of the alarm.
[in] | aPlayMode | Viewer alarm's play mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerShowAlarmByKey | ( | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aForeignKey,
 |  | const PlcViewerAlarmPlayMode | aPlayMode
 | ) |  |

Create action 'Viewer show alarm by key'.

Show alarm in viewer using alarm foreign key.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aForeignKey | Foreign key used to start the alarm.
[in] | aPlayMode | Viewer alarm's play mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerShowAlarmByType | ( | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const __int64 * | aForeignKey,
 |  | const PlcViewerAlarmPlayMode | aPlayMode
 | ) |  |

Create action 'Viewer show alarm by type'.

Show alarm in viewer using alarm type and optional foreign key.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aTypeID | Type of the alarm.
[in] | aForeignKey | Foreign key used to start the alarm.
[in] | aPlayMode | Viewer alarm's play mode.
Returns:
handle to action if the function succeeds or NULL if it fails.
Attention:
Following parameters are optional: aForeignKey.
You can provide NULL pointer if you not use these fields.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerSyncAudioAndVideo | ( | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aEnableSync
 | ) |  |

Create action 'Viewer change sync audio/video'.

Viewer change sync audio/video.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aEnableSync | Enable audio/video sync.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateViewerTextOutput | ( | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aText
 | ) |  |

Create action 'Viewer text output'.

Display free string in the given viewer.

Parameters:
[in] | aViewer | Global viewer or viewer client no.
[in] | aText | Text string to display.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateWatchdogActivate ( )

Create action 'Watchdog activate'.

Activate watchdog.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateWatchdogDeactivate ( )

Create action 'Watchdog deactivate'.

Deactivate watchdog.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateWatchdogTrigger ( )

Create action 'Watchdog trigger'.

Trigger watchdog.

Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateZoomIn | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Zoom in'.

Zoom camera in.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Zoom speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateZoomOut | ( | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed
 | ) |  |

Create action 'Zoom out'.

Zoom camera out.

Parameters:
[in] | aCamera | PTZ head.
[in] | aSpeed | Zoom speed.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateZoomStop ( const TPlcMediaChannelID & aCamera )

Create action 'Zoom stop'.

Stop camera zoom.

Parameters:
[in] aCamera PTZ head.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateEventStarted | ( | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID
 | ) |  |

Deprecated functions.

Create action 'Event started'. Event has started.

This action is deprecated, use GscAct_CreateEventStartedEx instead.
Parameters:
[in] | aEventID | Instance ID of the event.
[in] | aTypeID | Type of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSensorInhibitVideoAlarm | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const ADArea * | aADArea,
 |  | const __int32 * | aADCell,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone
 | ) |  |

Create action 'Sensor inhibit video alarm'.

This action will be fired when the motion in inhibit area is detected.

This action is deprecated, use GscAct_CreateSensorInhibitVideoAlarmEx instead.
Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aADArea | AD alarm area.
[in] | aADCell | AD cell nr.
[in] | aVMDGroup | VMD alarm group.
[in] | aVMDZone | VMD zone nr.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateSensorVideoAlarm | ( | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const ADArea * | aADArea,
 |  | const __int32 * | aADCell,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone
 | ) |  |

Create action 'Sensor video alarm'.

This action will be fired when video alarm is detected.

This action is deprecated, use GscAct_CreateSensorVideoAlarmEx instead.
Parameters:
[in] | aChannel | Channel.
[in] | aSensorType | Sensor type.
[in] | aADArea | AD alarm area.
[in] | aADCell | AD cell nr.
[in] | aVMDGroup | VMD alarm group.
[in] | aVMDZone | VMD zone nr.
Returns:
handle to action if the function succeeds or NULL if it fails.
GSCACTDLLCALL HGscAction __stdcall GscAct_CreateStartEvent ( const TPlcEventTypeID & aTypeID )

Create action 'Start event'.

Start event.

This action is deprecated, use GscAct_CreateStartEventEx instead.
Parameters:
[in] aTypeID Type of the event.
Returns:
handle to action if the function succeeds or NULL if it fails.


GSC actions: Functions to decode GSC actions

Functions

Functions to decode GSC actions
[Create / decode functions]

Collaboration diagram for Functions to decode GSC actions:

Detailed Description

This module describes functions used to decode specific actions.

Decode functions.

   #include "GscActions.h"
   using namespace GscPLC;

These functions have following syntax: prefix GscAct_Decode followed by the name of the action. First parameter is the const handle of the action to decode followed by action's parameters. List of parameters can be found in the function description or the action reference.

In general, parameters passed to the function using reference semantics. This rule has the following exception:

  • Parameter is optional. In this case functions expect the reference to the pointer to const object. The return value in this parameter can be NULL.
    Please note that strings are passed as const char*& (resp. const wchar_t*& for UNICODE) in both cases.

Example how to decode an action:

   const wchar_t* firstUser;
   const wchar_t* secondUser;
   const wchar_t* host;

   if (! GscAct_DecodeUserLogin(anAction, firstUser, secondUser, host))
   {
     // error handling
   }

Functions

GSCACTDLLCALL bool __stdcall | GscAct_DecodeABCConnect (ConstHGscAction anAction, const wchar_t *&aAddress)
Decode action 'ABC connect'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeABCDisconnect (ConstHGscAction anAction)
Decode action 'ABC disconnect'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeABCPlayFile (ConstHGscAction anAction, __int64 &aFileID, const wchar_t *&aFileName, bool &aAutoRepeat)
Decode action 'ABC play file'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAbortAllAutoBackups (ConstHGscAction anAction)
Decode action 'Abort all auto backups'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAbortAutoBackup (ConstHGscAction anAction, TPlcResourceID &aSchedule)
Decode action 'Abort auto backup'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSAccessDenied (ConstHGscAction anAction, const wchar_t *&aACSName, const __int32 *&aACSNo, const __int64 *&aAccount, const __int64 *&aBancCode, const wchar_t *&aCardNo, const TGLibDateTime *&aTimeStamp, const __int32 *&aReason)
Decode action 'ACS access denied'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSAccessGranted (ConstHGscAction anAction, const wchar_t *&aACSName, const __int32 *&aACSNo, const __int64 *&aAccount, const __int64 *&aBancCode, const wchar_t *&aCardNo, const TGLibDateTime *&aTimeStamp)
Decode action 'ACS access granted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSRawAnswer (ConstHGscAction anAction, const wchar_t *&aACSName, TGLibDateTime &aTimeStamp, const wchar_t *&aACSData)
Decode action 'ACS raw answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSRawData (ConstHGscAction anAction, const wchar_t *&aACSName, TGLibDateTime &aTimeStamp, const wchar_t *&aACSData)
Decode action 'ACS raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeActivateExternalProcess (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, VideoSensorKind &aExternalSystem)
Decode action 'Activate external process'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeATMRawAnswer (ConstHGscAction anAction, const wchar_t *&aATMName, TGLibDateTime &aTimeStamp, const wchar_t *&aATMData)
Decode action 'ATM raw answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeATMRawData (ConstHGscAction anAction, const wchar_t *&aATMName, TGLibDateTime &aTimeStamp, const wchar_t *&aATMData)
Decode action 'ATM raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeATMTransaction (ConstHGscAction anAction, const wchar_t *&aATMName, bool &aNewTransaction, __int32 &aPhotostep, const __int32 *&aATMNo, const __int64 *&aAccount, const __int64 *&aBancCode, const wchar_t *&aCardNo, const __int64 *&aTAN1, const __int64 *&aTAN2, const TGLibDateTime *&aTimeStamp1, const TGLibDateTime *&aTimeStamp2, const double *&aAmount, const wchar_t *&aCurrency)
Decode action 'ATM transaction'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupCapacityMonitoringCapacityWarning (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByGbf, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByGbf)
Decode action 'Auto backup capacity warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupCapacityMonitoringFileAutoDeleted (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByGbf, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByGbf, __int64 &aFileSize, const wchar_t *&aFileName)
Decode action 'Auto backup capacity file auto deleted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupCapacityMonitoringOutOfDiskSpace (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByGbf, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByGbf)
Decode action 'Auto backup capacity out of disk space'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupFileDone (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Auto backup file done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupFileProgress (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Auto backup file progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupFileStarted (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, __int32 &aFileIndex, const wchar_t *&aFileName)
Decode action 'Auto backup file started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupOperationDone (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TGLibDateTime &aOperationStopTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, const __int32 *&aOperationErrorCode)
Decode action 'Auto backup operation done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupOperationStarted (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit)
Decode action 'Auto backup operation started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupScheduleDone (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, TGLibDateTime &aStopTime, __int32 &aOperationCount, bool &aTimerStart)
Decode action 'Auto backup schedule done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupScheduleStarted (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart)
Decode action 'Auto backup schedule started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoFocusOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Auto focus off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoFocusOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Auto focus on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBackupEvent (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID, TPlcResourceID &aDestination, const __int64 *&aStartHintID, const __int64 *&aStopHintID, const wchar_t *&aSubfolder)
Decode action 'Backup event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBarcodeData (ConstHGscAction anAction, const wchar_t *&aReaderName, TGLibDateTime &aTimeStamp, const wchar_t *&aBarcode)
Decode action 'Barcode data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBlockingFilterActivate (ConstHGscAction anAction, const wchar_t *&aFilter)
Decode action 'Blocking filter activate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBlockingFilterDeactivate (ConstHGscAction anAction, const wchar_t *&aFilter)
Decode action 'Blocking filter deactivate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraApplyProfile (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, const wchar_t *&aProfile)
Decode action 'Camera apply profile'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraBacklightCompensationMode (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, PlcBacklightMode &aMode)
Decode action 'Camera backlight compensation mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraClearPrePosText (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Camera clear preset text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraDayNightMode (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, PlcDayNightMode &aMode)
Decode action 'Camera day/night mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraLightOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera light off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraLightOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera light on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraManualIrisOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera manual iris off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraManualIrisOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera manual iris on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraPumpOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera pump off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraPumpOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera pump on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraRAWOutput (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, const char *&aOutput)
Decode action 'Camera RAW output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSelectCharMode (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aMode)
Decode action 'Camera select char mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSetPrePosText (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Camera set preset text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncUOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func U off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncUOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func U on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncVOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func V off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncVOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func V on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncXOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func X off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncXOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func X on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncYOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func Y off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncYOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func Y on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraStopAll (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera stop all'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTextOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera text off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTextOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera text on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTourStart (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aTourID, const char *&aTourName)
Decode action 'Camera tour start'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTourStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera tour stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraVersionOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera version off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraVersionOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera version on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraWashOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera wash-wipe off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraWashOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera wash-wipe on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCancelExport (ConstHGscAction anAction, GUID &aExportID, PlcExportAbort &aAbortFlag)
Decode action 'Cancel export'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCaseClosed (ConstHGscAction anAction)
Decode action 'Case has been closed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCaseOpened (ConstHGscAction anAction)
Decode action 'Case has been opened'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeADParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change AD parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeCameraProfile (ConstHGscAction anAction, TPlcResourceID &aHardwareModule, TPlcResourceID &aCameraProfile)
Decode action 'Change camera profile'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeCPAParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change CPA parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeGTectParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change GTectVMX parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeObtrackParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change OBTRACK parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeVMDParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change VMD parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelError (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const VideoSensorKind *&aSensorType, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'Channel error'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelInfo (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const VideoSensorKind *&aSensorType, PlcMessageSource &aSource, PlcMessageCode &aMessage, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'Channel info'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelLiveCheck (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, TGLibDateTime &aTimeStamp)
Decode action 'Channel live check'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelWarning (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const VideoSensorKind *&aSensorType, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'Channel warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCPAMeasurement (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, __int32 &aCorrelation)
Decode action 'CPA measurement'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCustomAction (ConstHGscAction anAction, __int64 &aInt, const wchar_t *&aString)
Decode action 'Custom action'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDatabaseRecordingInfoRing (ConstHGscAction anAction, PlcDatabaseRing &aDatabaseRing, bool &aNoVideoRecording, bool &aNoAudioRecording, bool &aNoRecordingAtAll, double &aVideoSamplesPerSecond, double &aVideoMBPerSecond, double &aAudioSamplesPerSecond, double &aAudioMBPerSecond, double &aWriteWaitTimesPercent, __int64 &aRingCapacity, TGLibDateTime &aOldestItem, const double *&aRecordingDepth, const __int64 *&aEstimatedRequiredCapacity)
Decode action 'Database recording info per ring'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDatabaseRecordingInfoTotal (ConstHGscAction anAction, bool &aNoVideoRecording, bool &aNoAudioRecording, bool &aNoRecordingAtAll, double &aVideoSamplesPerSecond, double &aVideoMBPerSecond, double &aAudioSamplesPerSecond, double &aAudioMBPerSecond, double &aWriteWaitTimesPercent, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedCapacity, const TGLibDateTime *&aOldestItem, const double *&aRecordingDepth, const __int64 *&aEstimatedRequiredCapacity, const double *&aRequiredCapacityFactor, const bool *&aRequiredCapacityAvailable)
Decode action 'Database recording info total'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDatabaseStarted (ConstHGscAction anAction, PlcDatabaseStatus &aStatus, __int64 &aTotalSize)
Decode action 'Database started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDefaultPosCallUp (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Move to default position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDefaultPosClear (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Clear default position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDefaultPosSave (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Save default position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceFound (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial)
Decode action 'Device found'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceNewFirmware (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial, const char *&aFirmware)
Decode action 'New firmware received'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDevicePluginError (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const char *&aType, const char *&aSubType, const char *&aName, const char *&aSerial, PlcPluginError &aErrorClass, const __int32 *&aErrorCode, const char *&aDescription)
Decode action 'Device plugin error'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDevicePluginState (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const char *&aType, const char *&aSubType, const char *&aName, const char *&aSerial, PlcPluginState &aState, const __int32 *&aInternalState, const char *&aDescription)
Decode action 'Device plugin state'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceReattached (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial)
Decode action 'Device reattached'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceRemoved (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial)
Decode action 'Device removed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDigitalInput (ConstHGscAction anAction, TPlcMediaChannelID &aContact, DigitalInputState &aState)
Decode action 'Digital input'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupDone (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, TGLibDateTime &aStopTime, const __int32 *&aOperationErrorCode)
Decode action 'Event backup done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupFileDone (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Event backup file done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupFileProgress (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Event backup file progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupFileStarted (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, __int32 &aFileIndex, const wchar_t *&aFileName)
Decode action 'Event backup file started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupStarted (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime)
Decode action 'Event backup started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventRecordingChanged (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID)
Decode action 'Event recording changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventStartedEx (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID, const __int64 *&aForeignKey)
Decode action 'Event started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventStopped (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID)
Decode action 'Event stopped'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeExportFinished (ConstHGscAction anAction, GUID &aExportID, PlcExportSuccess &aSuccess)
Decode action 'Export finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeExportProgress (ConstHGscAction anAction, GUID &aExportID, __int32 &aProgress)
Decode action 'Export progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFastSpeedOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Fast speed off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFastSpeedOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Fast speed on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFillingPumpStatus (ConstHGscAction anAction, const wchar_t *&aTerminalName, TGLibDateTime &aTimeStamp, __int32 &aPumpNo, PlcPumpStatus &aStatus, const double *&aAmount, const double *&aPrice, const wchar_t *&aDetails)
Decode action 'Filling pump status'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFocusFar (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Focus far'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFocusNear (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Focus near'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFocusStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Focus stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFRCNotification (ConstHGscAction anAction, PlcFRCNotification &aNotification, const __int32 *&aParam, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'FRC notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGEMOSalarm (ConstHGscAction anAction, __int64 &aGEMOSkey, __int32 &aGEMOSint, const wchar_t *&aGEMOSstr)
Decode action 'GEMOS alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessDenied (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access denied'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessExpired (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, TGLibDateTime &aExpiringTime, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access expired'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessGranted (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access granted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessPending (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access pending'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectAnalyticsLiveCheck (ConstHGscAction anAction)
Decode action 'G-Tect analytics live check'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectDualSensorAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const __int32 *&aSterileZoneNumber, const __int32 *&aVirtualFenceNumber, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone, const VMDCycle *&aVMDCycle, const TPlcRect *&aAlarmArea)
Decode action 'G-Tect/Dual sensor alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectDualSensorAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'G-Tect/Dual sensor alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectSceneAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GTectSceneAlarmReason &aAlarmReason)
Decode action 'G-Tect scene alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectSceneAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GTectSceneAlarmReason &aAlarmReason)
Decode action 'G-Tect scene alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectVMXAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const __int32 *&aSterileZoneNumber, const __int32 *&aVirtualFenceNumber, const __int32 *&aAlarmGroup, const __int32 *&aTrackID, const TPlcRect *&aAlarmArea)
Decode action 'G-Tect/VMX alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectVMXAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'G-Tect/VMX alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIASSettingsChanged (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'IAS settings changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImageExportNotification (ConstHGscAction anAction, const wchar_t *&aUser, const wchar_t *&aDestination, PlcImageExportType &aDestinationType, TGLibDateTime &aTimeStamp, const TGLibDateTime *&aTimeEnd, const wchar_t *&aChannels, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Image export notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexCapacityFileAutoDeleted (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByImageFile, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByImageFile, __int64 &aTotalFileSize, __int32 &aNumberOfFiles)
Decode action 'Imex capacity file auto deleted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexCapacityOutOfDiskSpace (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByImageFile, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByImageFile)
Decode action 'Imex capacity out of disk space.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexCapacityWarning (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByImageFile, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByImageFile)
Decode action 'Imex capacity warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexExportEventImage (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID, const TPlcResourceID *&aDestination, const wchar_t *&aFilePath)
Decode action 'Imex export event image'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexExportImageFromDB (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const TPlcResourceID *&aDestination, const wchar_t *&aFilePath, const TGLibDateTime *&aPictureTime)
Decode action 'Imex export image from DB'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexExportImageFromLiveStream (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const TPlcResourceID *&aDestination, const wchar_t *&aFilePath)
Decode action 'Imex export image from live stream'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeInitializeRemoteExport (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, GUID &aDevice)
Decode action 'Initialize remote export'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeInterfaceRawAnswer (ConstHGscAction anAction, const wchar_t *&aInterfaceName, TGLibDateTime &aTimeStamp, const wchar_t *&aData)
Decode action 'Interface raw answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeInterfaceRawData (ConstHGscAction anAction, const wchar_t *&aInterfaceName, TGLibDateTime &aTimeStamp, const wchar_t *&aData)
Decode action 'Interface raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43ResetMainboard (ConstHGscAction anAction)
Decode action 'IOI43 reset mainboard'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43Temperature (ConstHGscAction anAction, const wchar_t *&aID, __int32 &aTemperature)
Decode action 'IOI43 temperature notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43WDActivate (ConstHGscAction anAction)
Decode action 'IOI43 watchdog activate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43WDDeactivate (ConstHGscAction anAction)
Decode action 'IOI43 watchdog deactivate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43WDTrigger (ConstHGscAction anAction)
Decode action 'IOI43 watchdog trigger'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPCameraRawCommand (ConstHGscAction anAction, const wchar_t *&aURL, const wchar_t *&aUser, const wchar_t *&aPassword, const wchar_t *&aPOST)
Decode action 'IP camera raw command'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPCamFailoverNotification (ConstHGscAction anAction, const wchar_t *&aPrimaryServer, const wchar_t *&aSecondaryServer, TPlcMediaChannelID &aPrimaryChannel, TPlcMediaChannelID &aSecondaryChannel, const wchar_t *&aCameraParameters)
Decode action 'IP camera failover notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPCamFailoverRestore (ConstHGscAction anAction, const wchar_t *&aPrimaryServer, const wchar_t *&aSecondaryServer, TPlcMediaChannelID &aPrimaryChannel, TPlcMediaChannelID &aSecondaryChannel, const wchar_t *&aCameraParameters)
Decode action 'IP camera failover restore'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPSwitchOperation (ConstHGscAction anAction, IPSwitchOps &aOperation, const wchar_t *&aPort, const __int32 *&aParam)
Decode action 'IP switch operation'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIrisClose (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Iris close'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIrisOpen (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Iris open'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIrisStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Iris stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKeyPressed (ConstHGscAction anAction, SystemKey &aKey)
Decode action 'Key pressed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKeyReleased (ConstHGscAction anAction, SystemKey &aKey)
Decode action 'Key released'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKillAllEvents (ConstHGscAction anAction)
Decode action 'Kill all events'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKillEvent (ConstHGscAction anAction, TPlcEventTypeID &aTypeID)
Decode action 'Kill event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKillEventByID (ConstHGscAction anAction, __int64 &aEventID)
Decode action 'Kill event by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelAccessEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int64 *&aCardNumber, const LenelAccessResult *&aAccessResult, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const __int32 *&aAreaEnteredID, const __int32 *&aAreaExitedID, const wchar_t *&aAssetID, const bool *&aCardholderEntered, const bool *&aDuress, const __int32 *&aElevatorFloor, const __int32 *&aFacilityCode, const bool *&aIsReadableCard, const __int32 *&aIssueCode, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel access event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelFireEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int32 *&aTroubleCode, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel fire event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelIntercomEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int32 *&aIntercomData, const __int32 *&aLineNumber, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel intercom event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelRawData (ConstHGscAction anAction, TGLibDateTime &aTimeStamp, const wchar_t *&aLenelData)
Decode action 'Lenel raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelRefreshNames (ConstHGscAction anAction)
Decode action 'Lenel refresh names'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelSecurityEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel security event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelVideoEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int32 *&aChannel, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const TGLibDateTime *&aStartTime, const TGLibDateTime *&aEndTime, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel video event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLiveCheck (ConstHGscAction anAction, __int64 &aCounter, TGLibDateTime &aDate)
Decode action 'Live check'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLogBarcodeData (ConstHGscAction anAction, const wchar_t *&aBarcode, const __int64 *&aHash, const wchar_t *&aScanner, const __int64 *&aAreaID, const wchar_t *&aAreaName, const TPlcMediaChannelID *&aChannel, const TGLibDateTime *&aTimeStamp, const wchar_t *&aOrder, const wchar_t *&aShipment, const wchar_t *&aItem)
Decode action 'Log barcode data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLogBarcodeDataLPS (ConstHGscAction anAction, const wchar_t *&aBarcode, const __int64 *&aHash, const wchar_t *&aScanner, const __int64 *&aAreaID, const wchar_t *&aAreaName, const TPlcMediaChannelID *&aChannel, const TGLibDateTime *&aTimeStamp, const double *&aX, const double *&aY, const double *&aZ, const __int32 *&aLpsTagID, const PlcLpsStatus *&aLpsStatus, const __int32 *&aLpsCellID, const __int32 *&aLpsAreaID, const __int32 *&aUserParam, const wchar_t *&aOrder, const wchar_t *&aShipment, const wchar_t *&aItem)
Decode action 'Log barcode data LPS'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLogNPRRecognition (ConstHGscAction anAction, const wchar_t *&aPlateNo, const __int64 *&aHash, const wchar_t *&aCountry, const TPlcMediaChannelID *&aChannel, const TGLibDateTime *&aTimeStamp, const PlcNPRRestriction *&aRestriction, const wchar_t *&aCategory)
Decode action 'Log NPR recognition'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLPSPositionData (ConstHGscAction anAction, __int32 &aTagID, const wchar_t *&aScannerID, __int64 &aX, __int64 &aY, const __int64 *&aZ, const double *&aLatitude, const double *&aLongitude, __int32 &aAreaID, const __int32 *&aCellID, PlcLpsStatus &aStatus, const TGLibDateTime *&aTimeStamp, const wchar_t *&aData, const wchar_t *&aAreaName)
Decode action 'LPS position data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLPSQueryPosition (ConstHGscAction anAction, __int32 &aTagID, const wchar_t *&aScannerID, const wchar_t *&aData)
Decode action 'LPS query position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMakeCPAReferenceImage (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Make CPA reference image'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMediaChannelSetupInfo (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, const wchar_t *&aParameter)
Decode action 'Media channel setup'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMoveToAbsolutePosition (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, double &aAlpha, double &aBeta, double &aSpeedAlpha, double &aSpeedBeta)
Decode action 'Move to absolute position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMoveToBySpeed (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, double &aSpeedAlpha, double &aSpeedBeta)
Decode action 'Move by speed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMoveToRelativePosition (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, double &aAlpha, double &aBeta, double &aSpeedAlpha, double &aSpeedBeta)
Decode action 'Move to relative position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeNPRRawData (ConstHGscAction anAction, const wchar_t *&aPlateNo, const wchar_t *&aCountry, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, TPlcRect &aZoneRect, __int32 &aWeight, __int32 &aZoneState, __int32 &aZonePlace, __int32 &aSpeed, __int32 &aDirection, __int32 &aZoneIndex, bool &aCurBest, __int32 &aPlateWidth, __int32 &aPlateHeight, __int32 &aPlateAngle, __int32 &aSymHeight, const wchar_t *&aType)
Decode action 'NPR raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeNPRRecognition (ConstHGscAction anAction, const wchar_t *&aPlateNo, const wchar_t *&aCountry, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, TPlcRect &aZoneRect, PlcNPRRestriction &aRestriction, const wchar_t *&aCategory, __int32 &aSpeed, __int32 &aDirection, __int32 &aZoneIndex, const wchar_t *&aType, __int32 &aWeight)
Decode action 'NPR recognition'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackChannelCounter (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, __int32 &aObjectDirection, TGLibDateTime &aTimeStamp, const TGLibDateTime *&aResetTimeStamp)
Decode action 'OBTRACK channel counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackChannelCounterThreshold (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, PlcObtrackExceedingDirection &aExceedingDirection, TGLibDateTime &aTimeStamp)
Decode action 'OBTRACK channel counter threshold'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackChannelSetCounter (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, TGLibDateTime &aTimeStamp)
Decode action 'OBTRACK channel set counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackFrameRawData (ConstHGscAction anAction, TGLibDateTime &aTimeStamp, TPlcMediaChannelID &aChannel, __int32 &aBrightness, __int32 &aContrast)
Decode action 'OBTRACK frame raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackGroupCounter (ConstHGscAction anAction, __int32 &aGroupId, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, __int32 &aObjectDirection, TGLibDateTime &aTimeStamp, const TGLibDateTime *&aResetTimeStamp, const wchar_t *&aGroupName)
Decode action 'OBTRACK group counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackGroupCounterThreshold (ConstHGscAction anAction, __int32 &aGroupId, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, PlcObtrackExceedingDirection &aExceedingDirection, TGLibDateTime &aTimeStamp, const wchar_t *&aGroupName)
Decode action 'OBTRACK group counter threshold'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackGroupSetCounter (ConstHGscAction anAction, __int32 &aGroupId, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, TGLibDateTime &aTimeStamp, const wchar_t *&aGroupName)
Decode action 'OBTRACK group set counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackObjectRawData (ConstHGscAction anAction, TGLibDateTime &aTimeStamp, TPlcMediaChannelID &aChannel, __int32 &aArea, __int32 &aObjectID, PlcObtrackObjectStatus &aObjectStatus, PlcObtrackObjectClass &aObjectClass, const __int32 *&aConfidence, const TPlcRect *&aPosition, const double *&aSpeed, const __int32 *&aDuration, const __int32 *&aDirection, const double *&aSize, const double *&aObjectWidth, const double *&aObjectHeight, const PlcObtrackProcessSize *&aProcessSize, const char *&aGscNetName)
Decode action 'OBTRACK object raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackTunnelAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, PlcTunnelAlarmReason &aAlarmReason, __int32 &aObjectID, __int32 &aAlarmAreaID, const TPlcRect *&aObjectArea)
Decode action 'OBTRACK tunnel alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanAuto (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aModus)
Decode action 'Pan auto'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanLeft (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Pan left'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanRight (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Pan right'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Pan stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePOSData (ConstHGscAction anAction, const wchar_t *&aPOSName, TGLibDateTime &aTimeStamp, const wchar_t *&aArticle, const double *&aPrice, const __int32 *&aUnits, const double *&aPricePerUnit, const wchar_t *&aLine1, const wchar_t *&aLine2, const wchar_t *&aLine3, const wchar_t *&aLine4, const wchar_t *&aLine5)
Decode action 'POS data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePOSStatus (ConstHGscAction anAction, const wchar_t *&aPOSName, TGLibDateTime &aTimeStamp, PlcPOSStatus &aStatus, const wchar_t *&aDetails)
Decode action 'POS status'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceAlarm (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, PPSensorKind &aSensor, PPAlarmState &aState)
Decode action 'PP device alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceInput (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, __int32 &aInput, PPAlarmState &aState)
Decode action 'PP device input'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceOffline (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress)
Decode action 'PP device offline'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceOnline (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress)
Decode action 'PP device online'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPInterfaceOffline (ConstHGscAction anAction, const wchar_t *&aInterfaceID)
Decode action 'PP interface offline'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPInterfaceOnline (ConstHGscAction anAction, const wchar_t *&aInterfaceID)
Decode action 'PP interface online'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPQueryInterface (ConstHGscAction anAction, const wchar_t *&aInterfaceID)
Decode action 'PP query interface'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPSetDeviceOutput (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, __int32 &aOutput, PPAlarmState &aState)
Decode action 'PP set device output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPSubcellAlarm (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, PPCableKind &aCable, __int32 &aSubcell, PPAlarmState &aState)
Decode action 'PP subcell alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPZoneAlarm (ConstHGscAction anAction, const wchar_t *&aZoneID, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, const PPCableKind *&aCable, const __int32 *&aSubcell, PPAlarmState &aState)
Decode action 'PP zone alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePrePosCallUp (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Move to preset position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePrePosClear (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Clear preset position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePrePosSave (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Save preset position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeRedundantPowerFailure (ConstHGscAction anAction)
Decode action 'Redundant power failure'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeRedundantPowerOk (ConstHGscAction anAction)
Decode action 'Redundant power ok'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeResetMainboard (ConstHGscAction anAction)
Decode action 'Reset mainboard'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagClose (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, TGLibDateTime &aStopTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, const double *&aDebit, const double *&aTotal, const double *&aDifference, const bool *&aHasDifference, const wchar_t *&aNotes, const wchar_t *&aCoins, const wchar_t *&aCheques)
Decode action 'Safebag close'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagData (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, const double *&aDebit, const double *&aTotal, const double *&aDifference, const bool *&aHasDifference, const wchar_t *&aNotes, const wchar_t *&aCoins, const wchar_t *&aCheques)
Decode action 'Safebag data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagOpen (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID)
Decode action 'Safebag open'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagPassingOfRiskData (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, __int32 &aUserID1, __int32 &aUserID2, const __int32 *&aTourNumber, const wchar_t *&aTargetWorkingPlace, const wchar_t *&aPassingOfRiskType)
Decode action 'Safebag passing of risk data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagPassingOfRiskStart (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, __int32 &aUserID1, __int32 &aUserID2, const __int32 *&aTourNumber, const wchar_t *&aTargetWorkingPlace, const wchar_t *&aPassingOfRiskType)
Decode action 'Safebag passing of risk start'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagPassingOfRiskStop (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, TGLibDateTime &aStopTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, __int32 &aUserID1, __int32 &aUserID2, const __int32 *&aTourNumber, const wchar_t *&aTargetWorkingPlace, const wchar_t *&aPassingOfRiskType)
Decode action 'Safebag passing of risk stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSceneStoreModification (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, GUID &aSceneStoreID, const wchar_t *&aSceneStoreName, TGLibDateTime &aTimeStamp, PlcSceneStoreModificationType &aModificationType, const wchar_t *&aUser, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Scene store modification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'Sensor alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorAudioAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Sensor audio alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorInhibitAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'Sensor inhibit alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorInhibitVideoAlarmEx (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone, const VMDCycle *&aVMDCycle, const TPlcRect *&aAlarmArea, const PlcObtrackObjectClass *&aObjectClass)
Decode action 'Sensor inhibit video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorVideoAlarmEx (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone, const VMDCycle *&aVMDCycle, const TPlcRect *&aAlarmArea, const PlcObtrackObjectClass *&aObjectClass)
Decode action 'Sensor video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetCameraText (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, const char *&aText)
Decode action 'Set camera text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetClientVCA (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GTectClientVCAType &aClientVCAType, bool &aEnabled)
Decode action 'Enable client VCA'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetClock (ConstHGscAction anAction, TGLibDateTime &aDate)
Decode action 'Set clock'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetDigitalOutput (ConstHGscAction anAction, TPlcMediaChannelID &aContact, DigitalOutputState &aState)
Decode action 'Set digital output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetExportMarker (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcExportMarker &aMarker)
Decode action 'Set export marker'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetLED (ConstHGscAction anAction, SystemLED &aLED, DigitalOutputState &aState)
Decode action 'Set system LED'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetLEDBlink (ConstHGscAction anAction, SystemLED &aLED, __int32 &aLedTimeOnMs, __int32 &aLedTimeOffMs)
Decode action 'Set system LED to blink'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetSystemTime (ConstHGscAction anAction, TGLibDateTime &aTimeStamp)
Decode action 'Set system time'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetTestPictureMode (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, bool &aMode)
Decode action 'Set test picture mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetupChanged (ConstHGscAction anAction, const wchar_t *&aUser, const wchar_t *&aHost, TGLibDateTime &aDate, PlcResourceKind &aResourceKind, TPlcEventTypeID &aResourceID, PlcResourceChangeKind &aChangeKind, const wchar_t *&aDetails, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Setup changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetupUploadProgress (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, __int32 &aProgress, TGLibDateTime &aDate)
Decode action 'Setup upload progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetWatchdog (ConstHGscAction anAction, __int32 &aTimeout)
Decode action 'Set watchdog'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataControl (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataControl &aData)
Decode action 'SKIDATA control'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataDeviceEvent (ConstHGscAction anAction, const wchar_t *&aInterfaceName, __int32 &aDeviceID, __int32 &aEventCode)
Decode action 'SKIDATA device event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataEntry (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataMsgCodeEntry &aMessageCode, const wchar_t *&aTranscactionID, __int32 &aCarParkNo, __int32 &aDeviceID)
Decode action 'SKIDATA entry'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataExit (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataMsgCodeExit &aMessageCode, const wchar_t *&aTranscactionID, __int32 &aCarParkNo, __int32 &aDeviceID)
Decode action 'SKIDATA exit'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataTransaction (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataMsgCodeTransaction &aMessageCode, const wchar_t *&aTranscactionID, __int32 &aCarParkNo, __int32 &aDeviceID)
Decode action 'SKIDATA transaction'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSMRPViewerCleared (ConstHGscAction anAction)
Decode action 'SMRP viewer cleared'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSMRPViewerConnected (ConstHGscAction anAction, const wchar_t *&aServer, TPlcMediaChannelID &aChannel)
Decode action 'SMRP viewer connected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSMTPMailSend (ConstHGscAction anAction, const wchar_t *&aSubject, const wchar_t *&aTo, const wchar_t *&aCc, const wchar_t *&aBody, const TPlcMediaChannelID *&aChannel)
Decode action 'SMTP mail'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartAutoBackup (ConstHGscAction anAction, TPlcResourceID &aSchedule)
Decode action 'Start auto backup'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartEventEx (ConstHGscAction anAction, TPlcEventTypeID &aTypeID, const __int64 *&aForeignKey)
Decode action 'Start event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartRemoteExport (ConstHGscAction anAction, GUID &aExportID, GUID &aDevice, PlcBackupFormat &aBackupFormat, TPlcMediaChannelID &aChannel, TGLibDateTime &aSelectionBegin, TGLibDateTime &aSelectionEnd, const wchar_t *&aJobID)
Decode action 'Start remote export'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartSceneStore (ConstHGscAction anAction, GUID &aSceneStoreID, const wchar_t *&aCutList, __int64 &aPreHistoryLength, __int64 &aRecordingLength)
Decode action 'Start scene store'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStopAllEvents (ConstHGscAction anAction)
Decode action 'Stop all events'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStopEvent (ConstHGscAction anAction, TPlcEventTypeID &aTypeID)
Decode action 'Stop event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStopEventByID (ConstHGscAction anAction, __int64 &aEventID)
Decode action 'Stop event by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemError (ConstHGscAction anAction, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'System error'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemInfo (ConstHGscAction anAction, PlcMessageSource &aSource, PlcMessageCode &aMessage, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'System info'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemSettingsChanged (ConstHGscAction anAction, bool &aSetupChanged, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, bool &aTimeRangeChanged, const TPlcResourceID *&aTimeRange, bool &aLicenceChanged, TGLibDateTime &aDate)
Decode action 'System settings changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemStarted (ConstHGscAction anAction, TGLibDateTime &aDate)
Decode action 'System started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemTerminating (ConstHGscAction anAction, TGLibDateTime &aDate, bool &aWindowsShutdown)
Decode action 'System terminating'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemWarning (ConstHGscAction anAction, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'System warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTemperature (ConstHGscAction anAction, IODeviceType &aSourceType, const wchar_t *&aID, __int32 &aTemperature)
Decode action 'Temperature notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTerminalArticleData (ConstHGscAction anAction, const wchar_t *&aTerminalName, TGLibDateTime &aTimeStamp, __int32 &aCashierStation, const __int32 *&aPumpNo, bool &aAlarmStatus, const double *&aAmount, const double *&aPrice, const wchar_t *&aDetails)
Decode action 'Terminal article data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTerminalPaymentData (ConstHGscAction anAction, const wchar_t *&aTerminalName, TGLibDateTime &aTimeStamp, __int32 &aCashierStation, const __int32 *&aPumpNo, bool &aAlarmStatus, const double *&aAmount, const double *&aPrice, const wchar_t *&aDetails)
Decode action 'Terminal payment data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTiltDown (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Tilt down'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTiltStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Tilt stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTiltUp (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Tilt up'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTransferBinaryBuffer (ConstHGscAction anAction, GUID &aInternalHandle, const wchar_t *&aParameter)
Decode action 'Transfer binary buffer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTransferBinaryChannelBuffer (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GUID &aInternalHandle, const wchar_t *&aParameter)
Decode action 'Transfer binary channel buffer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeUserLogin (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'User login'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeUserLoginFailed (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, UserLoginFailureCode &aRejectReason, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'User login failed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeUserLogout (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'User logout'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueConfirm (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue confirm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueConfirmByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID)
Decode action 'VC alarm queue confirm by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueConfirmByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue confirm by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueNotification (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmState &aNotification, __int64 &aAlarmID, TPlcEventTypeID &aTypeID, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'VC alarm queue notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueRemove (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue remove'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueRemoveByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID)
Decode action 'VC alarm queue remove by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueRemoveByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue remove by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueSelect (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue select'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueSelectByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID)
Decode action 'VC alarm queue select by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueSelectByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue select by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCASetArmed (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, bool &aArmed)
Decode action 'VCA set armed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAStatusAnswer (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, bool &aArmed)
Decode action 'VCA status answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAStatusRequest (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'VCA status request'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCChangeSceneByName (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aScene)
Decode action 'VC change scene by name'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCClearSceneByName (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aScene)
Decode action 'VC clear scene by name'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCFullMode (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aFullMode, bool &aSensitiveAreaEnabled)
Decode action 'VC full mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCSceneChanged (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aScene)
Decode action 'VC scene changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCSetAudioLevel (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int32 &aAudioLevel)
Decode action 'VC set audio level'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCShowViewerText (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aShowText)
Decode action 'VC show viewer text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCStretchMode (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aStretchMode)
Decode action 'VC stretch mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoContrastDetected (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video contrast detected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoContrastFailed (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video contrast failed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSetImageBrightness (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, __int32 &aBrightness)
Decode action 'Video set image brightness'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSetImageContrast (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, __int32 &aContrast)
Decode action 'Video set image contrast'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSetImageSaturation (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, __int32 &aSaturation)
Decode action 'Video set image saturation'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSourceChanged (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSignalNorm &aSignalNorm, VideoSignalType &aSignalType, VideoInterlaceType &aInterlaceType)
Decode action 'Video source has changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSyncDetected (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video sync detected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSyncFailed (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video sync failed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerChangeScene (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer change scene'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerClear (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer clear'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerCleared (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer cleared'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerClearScene (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer clear scene'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerClearTextOutput (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer clear text output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerConnect (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode)
Decode action 'Viewer connect'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerConnected (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer connected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerConnectLive (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel)
Decode action 'Viewer connect live'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerExportPicture (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aFilePath)
Decode action 'Viewer export picture'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerJumpByTime (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, __int32 &aTimeInSec)
Decode action 'Viewer jump by time'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerMaximize (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aMaximize)
Decode action 'Viewer maximize'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerPlayFromTime (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, TGLibDateTime &aTime)
Decode action 'Viewer play from time'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerPlayModeChanged (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, const TGLibDateTime *&aChannelTime, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer play mode changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerPrintPicture (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer print picture'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSelect (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer select'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSelectionChanged (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer selection changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSetPlayMode (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerPlayMode &aPlayMode, __int32 &aPlaySpeed)
Decode action 'Viewer set play mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerShowAlarmByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID, PlcViewerAlarmPlayMode &aPlayMode)
Decode action 'Viewer show alarm by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerShowAlarmByKey (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aForeignKey, PlcViewerAlarmPlayMode &aPlayMode)
Decode action 'Viewer show alarm by key'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerShowAlarmByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, const __int64 *&aForeignKey, PlcViewerAlarmPlayMode &aPlayMode)
Decode action 'Viewer show alarm by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSyncAudioAndVideo (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aEnableSync)
Decode action 'Viewer change sync audio/video'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerTextOutput (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aText)
Decode action 'Viewer text output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeWatchdogActivate (ConstHGscAction anAction)
Decode action 'Watchdog activate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeWatchdogDeactivate (ConstHGscAction anAction)
Decode action 'Watchdog deactivate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeWatchdogTrigger (ConstHGscAction anAction)
Decode action 'Watchdog trigger'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeZoomIn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Zoom in'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeZoomOut (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Zoom out'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeZoomStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Zoom stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventStarted (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID)
Deprecated functions.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorInhibitVideoAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone)
Decode action 'Sensor inhibit video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorVideoAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone)
Decode action 'Sensor video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartEvent (ConstHGscAction anAction, TPlcEventTypeID &aTypeID)
Decode action 'Start event'.

Function Documentation

GSCACTDLLCALL bool __stdcall GscAct_DecodeABCConnect | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aAddress
 | ) |  |

Decode action 'ABC connect'.

Connect audio back channel.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aAddress | Address of the remote server.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeABCDisconnect ( ConstHGscAction anAction )

Decode action 'ABC disconnect'.

Disconnect audio back channel.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeABCPlayFile | ( | ConstHGscAction | anAction,
 |  | __int64 & | aFileID,
 |  | const wchar_t *& | aFileName,
 |  | bool & | aAutoRepeat
 | ) |  |

Decode action 'ABC play file'.

Play file on audio back channel.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aFileID | File ID.
[out] | aFileName | Name of the file.
[out] | aAutoRepeat | Repeat file automatically
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAbortAllAutoBackups ( ConstHGscAction anAction )

Decode action 'Abort all auto backups'.

Abort all auto backups.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAbortAutoBackup | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule
 | ) |  |

Decode action 'Abort auto backup'.

Abort auto backup.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeACSAccessDenied | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aACSName,
 |  | const __int32 *& | aACSNo,
 |  | const __int64 *& | aAccount,
 |  | const __int64 *& | aBancCode,
 |  | const wchar_t *& | aCardNo,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const __int32 *& | aReason
 | ) |  |

Decode action 'ACS access denied'.

ACS access denied.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aACSName | ACS name.
[out] | aACSNo | ACS no.
[out] | aAccount | Account no.
[out] | aBancCode | Bank code.
[out] | aCardNo | Card no.
[out] | aTimeStamp | Time stamp.
[out] | aReason | Reason.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp. aReason.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeACSAccessGranted | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aACSName,
 |  | const __int32 *& | aACSNo,
 |  | const __int64 *& | aAccount,
 |  | const __int64 *& | aBancCode,
 |  | const wchar_t *& | aCardNo,
 |  | const TGLibDateTime *& | aTimeStamp
 | ) |  |

Decode action 'ACS access granted'.

ACS access granted.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aACSName | ACS name.
[out] | aACSNo | ACS no.
[out] | aAccount | Account no.
[out] | aBancCode | Bank code.
[out] | aCardNo | Card no.
[out] | aTimeStamp | Time stamp.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeACSRawAnswer | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aACSName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aACSData
 | ) |  |

Decode action 'ACS raw answer'.

ACS raw answer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aACSName | ACS name.
[out] | aTimeStamp | Time stamp.
[out] | aACSData | ACS answer.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeACSRawData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aACSName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aACSData
 | ) |  |

Decode action 'ACS raw data'.

ACS raw data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aACSName | ACS name.
[out] | aTimeStamp | Time stamp.
[out] | aACSData | ACS data.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeActivateExternalProcess | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TGLibDateTime & | aTimeStamp,
 |  | VideoSensorKind & | aExternalSystem
 | ) |  |

Decode action 'Activate external process'.

Activate external process.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aExternalSystem | External system to activate.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeATMRawAnswer | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aATMName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aATMData
 | ) |  |

Decode action 'ATM raw answer'.

ATM raw answer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aATMName | ATM name.
[out] | aTimeStamp | Time stamp.
[out] | aATMData | ATM answer.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeATMRawData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aATMName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aATMData
 | ) |  |

Decode action 'ATM raw data'.

ATM raw data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aATMName | ATM name.
[out] | aTimeStamp | Time stamp.
[out] | aATMData | ATM data.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeATMTransaction | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aATMName,
 |  | bool & | aNewTransaction,
 |  | __int32 & | aPhotostep,
 |  | const __int32 *& | aATMNo,
 |  | const __int64 *& | aAccount,
 |  | const __int64 *& | aBancCode,
 |  | const wchar_t *& | aCardNo,
 |  | const __int64 *& | aTAN1,
 |  | const __int64 *& | aTAN2,
 |  | const TGLibDateTime *& | aTimeStamp1,
 |  | const TGLibDateTime *& | aTimeStamp2,
 |  | const double *& | aAmount,
 |  | const wchar_t *& | aCurrency
 | ) |  |

Decode action 'ATM transaction'.

ATM transaction.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aATMName | ATM name.
[out] | aNewTransaction | New transaction.
[out] | aPhotostep | Photostep.
[out] | aATMNo | ATM no.
[out] | aAccount | Account no.
[out] | aBancCode | Bank code.
[out] | aCardNo | Card no.
[out] | aTAN1 | TAN 1.
[out] | aTAN2 | TAN 2.
[out] | aTimeStamp1 | Time stamp 1.
[out] | aTimeStamp2 | Time stamp 2.
[out] | aAmount | Amount.
[out] | aCurrency | Currency.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aATMNo. aAccount. aBancCode. aCardNo. aTAN1. aTAN2. aTimeStamp1. aTimeStamp2. aAmount. aCurrency.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupCapacityMonitoringCapacityWarning | ( | ConstHGscAction | anAction,
 |  | ABCapacityWarning & | aWarning,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aTotalCapacity,
 |  | __int64 & | aFreeCapacity,
 |  | __int64 & | aAllocatedByGbf,
 |  | __int32 & | aPercentFree,
 |  | __int32 & | aPercentAllocated,
 |  | __int32 & | aPercentAllocatedByGbf
 | ) |  |

Decode action 'Auto backup capacity warning'.

Auto backup capacity monitoring: capacity warning.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWarning | Warning.
[out] | aDestination | Destination.
[out] | aTotalCapacity | Total capacity.
[out] | aFreeCapacity | Free capacity.
[out] | aAllocatedByGbf | Allocated by GBF.
[out] | aPercentFree | Percent free.
[out] | aPercentAllocated | Percent allocated.
[out] | aPercentAllocatedByGbf | Percent allocated by GBF.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupCapacityMonitoringFileAutoDeleted | ( | ConstHGscAction | anAction,
 |  | ABCapacityWarning & | aWarning,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aTotalCapacity,
 |  | __int64 & | aFreeCapacity,
 |  | __int64 & | aAllocatedByGbf,
 |  | __int32 & | aPercentFree,
 |  | __int32 & | aPercentAllocated,
 |  | __int32 & | aPercentAllocatedByGbf,
 |  | __int64 & | aFileSize,
 |  | const wchar_t *& | aFileName
 | ) |  |

Decode action 'Auto backup capacity file auto deleted'.

Auto backup capacity monitoring: file auto deleted.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWarning | Warning.
[out] | aDestination | Destination.
[out] | aTotalCapacity | Total capacity.
[out] | aFreeCapacity | Free capacity.
[out] | aAllocatedByGbf | Allocated by GBF.
[out] | aPercentFree | Percent free.
[out] | aPercentAllocated | Percent allocated.
[out] | aPercentAllocatedByGbf | Percent allocated by GBF.
[out] | aFileSize | File size.
[out] | aFileName | File name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupCapacityMonitoringOutOfDiskSpace | ( | ConstHGscAction | anAction,
 |  | ABCapacityWarning & | aWarning,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aTotalCapacity,
 |  | __int64 & | aFreeCapacity,
 |  | __int64 & | aAllocatedByGbf,
 |  | __int32 & | aPercentFree,
 |  | __int32 & | aPercentAllocated,
 |  | __int32 & | aPercentAllocatedByGbf
 | ) |  |

Decode action 'Auto backup capacity out of disk space'.

Auto backup capacity monitoring: out of disk space.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWarning | Warning.
[out] | aDestination | Destination.
[out] | aTotalCapacity | Total capacity.
[out] | aFreeCapacity | Free capacity.
[out] | aAllocatedByGbf | Allocated by GBF.
[out] | aPercentFree | Percent free.
[out] | aPercentAllocated | Percent allocated.
[out] | aPercentAllocatedByGbf | Percent allocated by GBF.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupFileDone | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime *& | aStartTime,
 |  | TGLibDateTime & | aEffectiveStartTime,
 |  | __int32 & | aOperationCount,
 |  | bool & | aTimerStart,
 |  | __int32 & | aOperationIndex,
 |  | TGLibDateTime & | aOperationStartTime,
 |  | TPlcResourceID & | aSource,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | __int32 & | aFileIndex,
 |  | const wchar_t *& | aFileName,
 |  | __int64 & | aFileSize
 | ) |  |

Decode action 'Auto backup file done'.

Auto backup progress notification: file done.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
[out] | aStartTime | Start time, empty during event backup.
[out] | aEffectiveStartTime | Effective schedule start time.
[out] | aOperationCount | Operation count.
[out] | aTimerStart | Timer start.
[out] | aOperationIndex | Operation index.
[out] | aOperationStartTime | Operation start time.
[out] | aSource | Source.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aFileIndex | File index.
[out] | aFileName | File name.
[out] | aFileSize | File size.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartTime.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupFileProgress | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime *& | aStartTime,
 |  | TGLibDateTime & | aEffectiveStartTime,
 |  | __int32 & | aOperationCount,
 |  | bool & | aTimerStart,
 |  | __int32 & | aOperationIndex,
 |  | TGLibDateTime & | aOperationStartTime,
 |  | TPlcResourceID & | aSource,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | __int32 & | aFileIndex,
 |  | const wchar_t *& | aFileName,
 |  | __int64 & | aFileSize
 | ) |  |

Decode action 'Auto backup file progress'.

Auto backup progress notification: file progress.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
[out] | aStartTime | Start time, empty during event backup.
[out] | aEffectiveStartTime | Effective schedule start time.
[out] | aOperationCount | Operation count.
[out] | aTimerStart | Timer start.
[out] | aOperationIndex | Operation index.
[out] | aOperationStartTime | Operation start time.
[out] | aSource | Source.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aFileIndex | File index.
[out] | aFileName | File name.
[out] | aFileSize | File size.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartTime.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupFileStarted | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime *& | aStartTime,
 |  | TGLibDateTime & | aEffectiveStartTime,
 |  | __int32 & | aOperationCount,
 |  | bool & | aTimerStart,
 |  | __int32 & | aOperationIndex,
 |  | TGLibDateTime & | aOperationStartTime,
 |  | TPlcResourceID & | aSource,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | __int32 & | aFileIndex,
 |  | const wchar_t *& | aFileName
 | ) |  |

Decode action 'Auto backup file started'.

Auto backup progress notification: file started.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
[out] | aStartTime | Start time, empty during event backup.
[out] | aEffectiveStartTime | Effective schedule start time.
[out] | aOperationCount | Operation count.
[out] | aTimerStart | Timer start.
[out] | aOperationIndex | Operation index.
[out] | aOperationStartTime | Operation start time.
[out] | aSource | Source.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aFileIndex | File index.
[out] | aFileName | File name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartTime.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupOperationDone | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime *& | aStartTime,
 |  | TGLibDateTime & | aEffectiveStartTime,
 |  | __int32 & | aOperationCount,
 |  | bool & | aTimerStart,
 |  | __int32 & | aOperationIndex,
 |  | TGLibDateTime & | aOperationStartTime,
 |  | TGLibDateTime & | aOperationStopTime,
 |  | TPlcResourceID & | aSource,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | const __int32 *& | aOperationErrorCode
 | ) |  |

Decode action 'Auto backup operation done'.

Auto backup progress notification: operation done.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
[out] | aStartTime | Start time, empty during event backup.
[out] | aEffectiveStartTime | Effective schedule start time.
[out] | aOperationCount | Operation count.
[out] | aTimerStart | Timer start.
[out] | aOperationIndex | Operation index.
[out] | aOperationStartTime | Operation start time.
[out] | aOperationStopTime | Operation stop time.
[out] | aSource | Source.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aOperationErrorCode | Operation error code.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartTime. aOperationErrorCode.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupOperationStarted | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime *& | aStartTime,
 |  | TGLibDateTime & | aEffectiveStartTime,
 |  | __int32 & | aOperationCount,
 |  | bool & | aTimerStart,
 |  | __int32 & | aOperationIndex,
 |  | TGLibDateTime & | aOperationStartTime,
 |  | TPlcResourceID & | aSource,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit
 | ) |  |

Decode action 'Auto backup operation started'.

Auto backup progress notification: operation started.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
[out] | aStartTime | Start time, empty during event backup.
[out] | aEffectiveStartTime | Effective schedule start time.
[out] | aOperationCount | Operation count.
[out] | aTimerStart | Timer start.
[out] | aOperationIndex | Operation index.
[out] | aOperationStartTime | Operation start time.
[out] | aSource | Source.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartTime.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupScheduleDone | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime *& | aStartTime,
 |  | TGLibDateTime & | aEffectiveStartTime,
 |  | TGLibDateTime & | aStopTime,
 |  | __int32 & | aOperationCount,
 |  | bool & | aTimerStart
 | ) |  |

Decode action 'Auto backup schedule done'.

Auto backup progress notification: schedule done.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
[out] | aStartTime | Start time, empty during event backup.
[out] | aEffectiveStartTime | Effective schedule start time.
[out] | aStopTime | Schedule stop time.
[out] | aOperationCount | Operation count.
[out] | aTimerStart | Timer start.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartTime.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoBackupScheduleStarted | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime *& | aStartTime,
 |  | TGLibDateTime & | aEffectiveStartTime,
 |  | __int32 & | aOperationCount,
 |  | bool & | aTimerStart
 | ) |  |

Decode action 'Auto backup schedule started'.

Auto backup progress notification: schedule started.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
[out] | aStartTime | Start time, empty during event backup.
[out] | aEffectiveStartTime | Effective schedule start time.
[out] | aOperationCount | Operation count.
[out] | aTimerStart | Timer start.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartTime.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoFocusOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Auto focus off'.

Disable auto focus of the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeAutoFocusOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Auto focus on'.

Enable auto focus of the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeBackupEvent | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID,
 |  | TPlcEventTypeID & | aTypeID,
 |  | TPlcResourceID & | aDestination,
 |  | const __int64 *& | aStartHintID,
 |  | const __int64 *& | aStopHintID,
 |  | const wchar_t *& | aSubfolder
 | ) |  |

Decode action 'Backup event'.

Backup event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
[out] | aTypeID | Type of the event.
[out] | aDestination | Destination.
[out] | aStartHintID | Optional start hint ID.
[out] | aStopHintID | Optional stop hint ID.
[out] | aSubfolder | Sub folder to backup event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aStartHintID. aStopHintID. aSubfolder.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeBarcodeData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aReaderName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aBarcode
 | ) |  |

Decode action 'Barcode data'.

Barcode data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aReaderName | Scanner name.
[out] | aTimeStamp | Time stamp.
[out] | aBarcode | Barcode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeBlockingFilterActivate | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aFilter
 | ) |  |

Decode action 'Blocking filter activate'.

Blocking filter activate.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aFilter | Blocking filter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeBlockingFilterDeactivate | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aFilter
 | ) |  |

Decode action 'Blocking filter deactivate'.

Blocking filter deactivate.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aFilter | Blocking filter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraApplyProfile | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | const wchar_t *& | aProfile
 | ) |  |

Decode action 'Camera apply profile'.

Apply a predefined profile settings to the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aProfile | Profile name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraBacklightCompensationMode | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | PlcBacklightMode & | aMode
 | ) |  |

Decode action 'Camera backlight compensation mode'.

Change backlight compensation mode of the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aMode | Backlight compensation mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraClearPrePosText | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aPosition
 | ) |  |

Decode action 'Camera clear preset text'.

Clear camera text for preset position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aPosition | Preset position.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraDayNightMode | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | PlcDayNightMode & | aMode
 | ) |  |

Decode action 'Camera day/night mode'.

Change day/night mode of the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aMode | Day/night mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraLightOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera light off'.

Turn camera light off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraLightOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera light on'.

Turn camera light on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraManualIrisOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera manual iris off'.

Disable manual iris of the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraManualIrisOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera manual iris on'.

Enable manual iris of the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera off'.

Turn camera off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera on'.

Turn camera on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraPumpOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera pump off'.

Turn camera pump off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraPumpOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera pump on'.

Turn camera pump on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraRAWOutput | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | const char *& | aOutput
 | ) |  |

Decode action 'Camera RAW output'.

Output unformatted command to the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aOutput | RAW command to output.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSelectCharMode | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aMode
 | ) |  |

Decode action 'Camera select char mode'.

Select camera character mode.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aMode | Character mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSetPrePosText | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aPosition
 | ) |  |

Decode action 'Camera set preset text'.

Set camera text for preset position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aPosition | Preset position.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncUOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func U off'.

Turn camera special function U off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncUOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func U on'.

Turn camera special function U on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncVOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func V off'.

Turn camera special function V off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncVOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func V on'.

Turn camera special function V on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncXOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func X off'.

Turn camera special function X off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncXOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func X on'.

Turn camera special function X on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncYOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func Y off'.

Turn camera special function Y off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraSpecFuncYOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera spec func Y on'.

Turn camera special function Y on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraStopAll | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera stop all'.

Camera stop all.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraTextOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera text off'.

Disable camera text.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraTextOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera text on'.

Enable camera text.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraTourStart | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aTourID,
 |  | const char *& | aTourName
 | ) |  |

Decode action 'Camera tour start'.

Start camera tour.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aTourID | Tour ID.
[out] | aTourName | Tour name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraTourStop | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera tour stop'.

Stop camera tour.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraVersionOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera version off'.

Hide camera version string.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraVersionOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera version on'.

Show camera version string.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraWashOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera wash-wipe off'.

Turn camera wash-wipe off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCameraWashOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Camera wash-wipe on'.

Turn camera wash-wipe on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCancelExport | ( | ConstHGscAction | anAction,
 |  | GUID & | aExportID,
 |  | PlcExportAbort & | aAbortFlag
 | ) |  |

Decode action 'Cancel export'.

Cancel export.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aExportID | Export GUID.
[out] | aAbortFlag | Abort flag.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCaseClosed ( ConstHGscAction anAction )

Decode action 'Case has been closed'.

Case has been closed.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCaseOpened ( ConstHGscAction anAction )

Decode action 'Case has been opened'.

Case has been opened.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChangeADParameterSet | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TPlcResourceID & | aParameterSet
 | ) |  |

Decode action 'Change AD parameter set'.

This action changes the current AD parameter set of the video channel.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aParameterSet | The name of the new AD parameter set.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChangeCameraProfile | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aHardwareModule,
 |  | TPlcResourceID & | aCameraProfile
 | ) |  |

Decode action 'Change camera profile'.

This action changes the current camera profile of the hardware module.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aHardwareModule | Hardware module.
[out] | aCameraProfile | The name of the camera profile.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChangeCPAParameterSet | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TPlcResourceID & | aParameterSet
 | ) |  |

Decode action 'Change CPA parameter set'.

This action changes the current CPA parameter set of the video channel.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aParameterSet | The name of the new CPA parameter set.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChangeGTectParameterSet | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TPlcResourceID & | aParameterSet
 | ) |  |

Decode action 'Change GTectVMX parameter set'.

This action changes the current GTectVMX parameter set of the video channel.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aParameterSet | The name of the new GTect parameter set.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChangeObtrackParameterSet | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TPlcResourceID & | aParameterSet
 | ) |  |

Decode action 'Change OBTRACK parameter set'.

This action changes the current OBTRACK parameter set of the video channel.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aParameterSet | The name of the new OBTRACK parameter set.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChangeVMDParameterSet | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TPlcResourceID & | aParameterSet
 | ) |  |

Decode action 'Change VMD parameter set'.

This action changes the current VMD parameter set of the video channel.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aParameterSet | The name of the new VMD parameter set.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChannelError | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind *& | aSensorType,
 |  | PlcMessageSource & | aSource,
 |  | PlcMessageCode & | aMessage,
 |  | const __int32 *& | aWindowsError,
 |  | const wchar_t *& | aDescription,
 |  | const char *& | aXMLInfo
 | ) |  |

Decode action 'Channel error'.

Notify channel error.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aSource | Source of the message.
[out] | aMessage | Kind of the message.
[out] | aWindowsError | Optional Windows error code.
[out] | aDescription | Optional description of the message.
[out] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aSensorType. aWindowsError. aDescription. aXMLInfo.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChannelInfo | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind *& | aSensorType,
 |  | PlcMessageSource & | aSource,
 |  | PlcMessageCode & | aMessage,
 |  | const wchar_t *& | aDescription,
 |  | const char *& | aXMLInfo
 | ) |  |

Decode action 'Channel info'.

Notify channel information.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aSource | Source of the message.
[out] | aMessage | Kind of the message.
[out] | aDescription | Optional description of the message.
[out] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aSensorType. aDescription. aXMLInfo.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChannelLiveCheck | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | TGLibDateTime & | aTimeStamp
 | ) |  |

Decode action 'Channel live check'.

This action notifies that the channel is alive.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aTimeStamp | Time stamp.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeChannelWarning | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind *& | aSensorType,
 |  | PlcMessageSource & | aSource,
 |  | PlcMessageCode & | aMessage,
 |  | const __int32 *& | aWindowsError,
 |  | const wchar_t *& | aDescription,
 |  | const char *& | aXMLInfo
 | ) |  |

Decode action 'Channel warning'.

Notify channel warning.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aSource | Source of the message.
[out] | aMessage | Kind of the message.
[out] | aWindowsError | Optional Windows error code.
[out] | aDescription | Optional description of the message.
[out] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aSensorType. aWindowsError. aDescription. aXMLInfo.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCPAMeasurement | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | __int32 & | aCorrelation
 | ) |  |

Decode action 'CPA measurement'.

CPA measurement.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aCorrelation | Correlation factor.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeCustomAction | ( | ConstHGscAction | anAction,
 |  | __int64 & | aInt,
 |  | const wchar_t *& | aString
 | ) |  |

Decode action 'Custom action'.

This action has no side effects and can be used for customer purposes.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInt | Numeric parameter.
[out] | aString | Literal parameter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDatabaseRecordingInfoRing | ( | ConstHGscAction | anAction,
 |  | PlcDatabaseRing & | aDatabaseRing,
 |  | bool & | aNoVideoRecording,
 |  | bool & | aNoAudioRecording,
 |  | bool & | aNoRecordingAtAll,
 |  | double & | aVideoSamplesPerSecond,
 |  | double & | aVideoMBPerSecond,
 |  | double & | aAudioSamplesPerSecond,
 |  | double & | aAudioMBPerSecond,
 |  | double & | aWriteWaitTimesPercent,
 |  | __int64 & | aRingCapacity,
 |  | TGLibDateTime & | aOldestItem,
 |  | const double *& | aRecordingDepth,
 |  | const __int64 *& | aEstimatedRequiredCapacity
 | ) |  |

Decode action 'Database recording info per ring'.

Database recording info per ring.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aDatabaseRing | Database ring.
[out] | aNoVideoRecording | Video is recording or not.
[out] | aNoAudioRecording | Audio is recording or not.
[out] | aNoRecordingAtAll | Video and/or audio is recording or not.
[out] | aVideoSamplesPerSecond | Video samples per second.
[out] | aVideoMBPerSecond | Video MB per second.
[out] | aAudioSamplesPerSecond | Audio samples per second.
[out] | aAudioMBPerSecond | Audio MB per second.
[out] | aWriteWaitTimesPercent | Write waiting times in percent.
[out] | aRingCapacity | Ring capacity.
[out] | aOldestItem | Time stamp of the oldest item.
[out] | aRecordingDepth | Recording depth in hours.
[out] | aEstimatedRequiredCapacity | Estimated required capacity.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aRecordingDepth. aEstimatedRequiredCapacity.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDatabaseRecordingInfoTotal | ( | ConstHGscAction | anAction,
 |  | bool & | aNoVideoRecording,
 |  | bool & | aNoAudioRecording,
 |  | bool & | aNoRecordingAtAll,
 |  | double & | aVideoSamplesPerSecond,
 |  | double & | aVideoMBPerSecond,
 |  | double & | aAudioSamplesPerSecond,
 |  | double & | aAudioMBPerSecond,
 |  | double & | aWriteWaitTimesPercent,
 |  | __int64 & | aTotalCapacity,
 |  | __int64 & | aFreeCapacity,
 |  | __int64 & | aAllocatedCapacity,
 |  | const TGLibDateTime *& | aOldestItem,
 |  | const double *& | aRecordingDepth,
 |  | const __int64 *& | aEstimatedRequiredCapacity,
 |  | const double *& | aRequiredCapacityFactor,
 |  | const bool *& | aRequiredCapacityAvailable
 | ) |  |

Decode action 'Database recording info total'.

Database recording info total.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aNoVideoRecording | Video is recording or not.
[out] | aNoAudioRecording | Audio is recording or not.
[out] | aNoRecordingAtAll | Video and/or audio is recording or not.
[out] | aVideoSamplesPerSecond | Video samples per second.
[out] | aVideoMBPerSecond | Video MB per second.
[out] | aAudioSamplesPerSecond | Audio samples per second.
[out] | aAudioMBPerSecond | Audio MB per second.
[out] | aWriteWaitTimesPercent | Write waiting times in percent.
[out] | aTotalCapacity | Total capacity.
[out] | aFreeCapacity | Free capacity.
[out] | aAllocatedCapacity | Allocated capacity.
[out] | aOldestItem | Time stamp of the oldest item.
[out] | aRecordingDepth | Recording depth in hours.
[out] | aEstimatedRequiredCapacity | Estimated required capacity.
[out] | aRequiredCapacityFactor | Required capacity factor.
[out] | aRequiredCapacityAvailable | Required capacity available.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aOldestItem. aRecordingDepth. aEstimatedRequiredCapacity. aRequiredCapacityFactor. aRequiredCapacityAvailable.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDatabaseStarted | ( | ConstHGscAction | anAction,
 |  | PlcDatabaseStatus & | aStatus,
 |  | __int64 & | aTotalSize
 | ) |  |

Decode action 'Database started'.

This action will be fired at the database start-up.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aStatus | Database status message.
[out] | aTotalSize | Database total size.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDefaultPosCallUp | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Move to default position'.

Move camera to default position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDefaultPosClear | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Clear default position'.

Clear camera default position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDefaultPosSave | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Save default position'.

Save current camera position as default position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDeviceFound | ( | ConstHGscAction | anAction,
 |  | const char *& | aType,
 |  | const char *& | aName,
 |  | const char *& | aSerial
 | ) |  |

Decode action 'Device found'.

This action will be fired when the USB or NET device is connected to the system. It is also fired at start-up for all detected devices.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aType | Type of the device.
[out] | aName | Device name if assigned in setup, empty otherwise.
[out] | aSerial | Serial ID of the device.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDeviceNewFirmware | ( | ConstHGscAction | anAction,
 |  | const char *& | aType,
 |  | const char *& | aName,
 |  | const char *& | aSerial,
 |  | const char *& | aFirmware
 | ) |  |

Decode action 'New firmware received'.

This action will be fired when the USB or NET device has got the new firmware.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aType | Type of the device.
[out] | aName | Device name if assigned in setup, empty otherwise.
[out] | aSerial | Serial ID of the device.
[out] | aFirmware | Serial ID of the firmware.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDevicePluginError | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const char *& | aType,
 |  | const char *& | aSubType,
 |  | const char *& | aName,
 |  | const char *& | aSerial,
 |  | PlcPluginError & | aErrorClass,
 |  | const __int32 *& | aErrorCode,
 |  | const char *& | aDescription
 | ) |  |

Decode action 'Device plugin error'.

This action notifies device plugin error.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aType | Type of the device.
[out] | aSubType | Subtype of the device.
[out] | aName | Device name.
[out] | aSerial | Serial ID of the device.
[out] | aErrorClass | Error class of the error occured.
[out] | aErrorCode | Plugin type specific error code.
[out] | aDescription | Error description.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aSubType. aErrorCode. aDescription.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDevicePluginState | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const char *& | aType,
 |  | const char *& | aSubType,
 |  | const char *& | aName,
 |  | const char *& | aSerial,
 |  | PlcPluginState & | aState,
 |  | const __int32 *& | aInternalState,
 |  | const char *& | aDescription
 | ) |  |

Decode action 'Device plugin state'.

This action notifies device plugin state.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aType | Type of the device.
[out] | aSubType | Subtype of the device.
[out] | aName | Device name.
[out] | aSerial | Serial ID of the device.
[out] | aState | New plugin device state.
[out] | aInternalState | Plugin device specific state.
[out] | aDescription | State description.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aSubType. aInternalState. aDescription.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDeviceReattached | ( | ConstHGscAction | anAction,
 |  | const char *& | aType,
 |  | const char *& | aName,
 |  | const char *& | aSerial
 | ) |  |

Decode action 'Device reattached'.

This action will be fired when the USB or NET device is reattached to the system.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aType | Type of the device.
[out] | aName | Device name if assigned in setup, empty otherwise.
[out] | aSerial | Serial ID of the device.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDeviceRemoved | ( | ConstHGscAction | anAction,
 |  | const char *& | aType,
 |  | const char *& | aName,
 |  | const char *& | aSerial
 | ) |  |

Decode action 'Device removed'.

This action will be fired when the USB or NET device is disconnected from the system. It is also fired at the start-up for all parameterized but not present devices.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aType | Type of the device.
[out] | aName | Device name if assigned in setup, empty otherwise.
[out] | aSerial | Serial ID of the device.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeDigitalInput | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aContact,
 |  | DigitalInputState & | aState
 | ) |  |

Decode action 'Digital input'.

This action will be fired when the state of the digital input has changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aContact | Contact.
[out] | aState | New state.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventBackupDone | ( | ConstHGscAction | anAction,
 |  | GUID & | aJobID,
 |  | TPlcEventTypeID & | aEventTypeID,
 |  | __int64 & | aEventID,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | TGLibDateTime & | aStartTime,
 |  | TGLibDateTime & | aStopTime,
 |  | const __int32 *& | aOperationErrorCode
 | ) |  |

Decode action 'Event backup done'.

Event backup progress notification: backup done.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aJobID | Backup job ID.
[out] | aEventTypeID | Type of the event.
[out] | aEventID | Instance ID of the event.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aStartTime | Backup start time.
[out] | aStopTime | Backup stop time.
[out] | aOperationErrorCode | Operation error code.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aOperationErrorCode.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventBackupFileDone | ( | ConstHGscAction | anAction,
 |  | GUID & | aJobID,
 |  | TPlcEventTypeID & | aEventTypeID,
 |  | __int64 & | aEventID,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | TGLibDateTime & | aStartTime,
 |  | __int32 & | aFileIndex,
 |  | const wchar_t *& | aFileName,
 |  | __int64 & | aFileSize
 | ) |  |

Decode action 'Event backup file done'.

Event backup progress notification: file done.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aJobID | Backup job ID.
[out] | aEventTypeID | Type of the event.
[out] | aEventID | Instance ID of the event.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aStartTime | Effective backup start time.
[out] | aFileIndex | File index.
[out] | aFileName | File name.
[out] | aFileSize | File size.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventBackupFileProgress | ( | ConstHGscAction | anAction,
 |  | GUID & | aJobID,
 |  | TPlcEventTypeID & | aEventTypeID,
 |  | __int64 & | aEventID,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | TGLibDateTime & | aStartTime,
 |  | __int32 & | aFileIndex,
 |  | const wchar_t *& | aFileName,
 |  | __int64 & | aFileSize
 | ) |  |

Decode action 'Event backup file progress'.

Event backup progress notification: file progress.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aJobID | Backup job ID.
[out] | aEventTypeID | Type of the event.
[out] | aEventID | Instance ID of the event.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aStartTime | Effective backup start time.
[out] | aFileIndex | File index.
[out] | aFileName | File name.
[out] | aFileSize | File size.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventBackupFileStarted | ( | ConstHGscAction | anAction,
 |  | GUID & | aJobID,
 |  | TPlcEventTypeID & | aEventTypeID,
 |  | __int64 & | aEventID,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | TGLibDateTime & | aStartTime,
 |  | __int32 & | aFileIndex,
 |  | const wchar_t *& | aFileName
 | ) |  |

Decode action 'Event backup file started'.

Event backup progress notification: file started.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aJobID | Backup job ID.
[out] | aEventTypeID | Type of the event.
[out] | aEventID | Instance ID of the event.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aStartTime | Effective backup start time.
[out] | aFileIndex | File index.
[out] | aFileName | File name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventBackupStarted | ( | ConstHGscAction | anAction,
 |  | GUID & | aJobID,
 |  | TPlcEventTypeID & | aEventTypeID,
 |  | __int64 & | aEventID,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aFileSizeLimit,
 |  | __int64 & | aBandWidthLimit,
 |  | TGLibDateTime & | aStartTime
 | ) |  |

Decode action 'Event backup started'.

Event backup progress notification: backup started.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aJobID | Backup job ID.
[out] | aEventTypeID | Type of the event.
[out] | aEventID | Instance ID of the event.
[out] | aDestination | Destination.
[out] | aFileSizeLimit | File size limit.
[out] | aBandWidthLimit | Band width limit.
[out] | aStartTime | Backup start time.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventRecordingChanged | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID,
 |  | TPlcEventTypeID & | aTypeID
 | ) |  |

Decode action 'Event recording changed'.

Event recording settings are changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
[out] | aTypeID | Type of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventStartedEx | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID,
 |  | TPlcEventTypeID & | aTypeID,
 |  | const __int64 *& | aForeignKey
 | ) |  |

Decode action 'Event started'.

Event has started.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
[out] | aTypeID | Type of the event.
[out] | aForeignKey | Optional foreign key used to start the alarm.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aForeignKey.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventStopped | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID,
 |  | TPlcEventTypeID & | aTypeID
 | ) |  |

Decode action 'Event stopped'.

Event has stopped.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
[out] | aTypeID | Type of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeExportFinished | ( | ConstHGscAction | anAction,
 |  | GUID & | aExportID,
 |  | PlcExportSuccess & | aSuccess
 | ) |  |

Decode action 'Export finished'.

Export finished.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aExportID | Export GUID.
[out] | aSuccess | Success.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeExportProgress | ( | ConstHGscAction | anAction,
 |  | GUID & | aExportID,
 |  | __int32 & | aProgress
 | ) |  |

Decode action 'Export progress'.

Export progress.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aExportID | Export GUID.
[out] | aProgress | Progress.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeFastSpeedOff | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Fast speed off'.

Turn camera fast speed off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeFastSpeedOn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Fast speed on'.

Turn camera fast speed on.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeFillingPumpStatus | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aTerminalName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | __int32 & | aPumpNo,
 |  | PlcPumpStatus & | aStatus,
 |  | const double *& | aAmount,
 |  | const double *& | aPrice,
 |  | const wchar_t *& | aDetails
 | ) |  |

Decode action 'Filling pump status'.

Filling pump status.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTerminalName | Terminal name.
[out] | aTimeStamp | Time stamp.
[out] | aPumpNo | Pump no.
[out] | aStatus | Status.
[out] | aAmount | Amount.
[out] | aPrice | Price.
[out] | aDetails | Details.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aAmount. aPrice. aDetails.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeFocusFar | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Focus far'.

Focus camera far.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Focus speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeFocusNear | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Focus near'.

Focus camera near.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Focus speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeFocusStop | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Focus stop'.

Stop camera focus.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeFRCNotification | ( | ConstHGscAction | anAction,
 |  | PlcFRCNotification & | aNotification,
 |  | const __int32 *& | aParam,
 |  | const wchar_t *& | aDescription,
 |  | const char *& | aXMLInfo
 | ) |  |

Decode action 'FRC notification'.

FRC notification.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aNotification | Notification reason.
[out] | aParam | Additional parameter.
[out] | aDescription | Optional notification text.
[out] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aParam. aDescription. aXMLInfo.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGEMOSalarm | ( | ConstHGscAction | anAction,
 |  | __int64 & | aGEMOSkey,
 |  | __int32 & | aGEMOSint,
 |  | const wchar_t *& | aGEMOSstr
 | ) |  |

Decode action 'GEMOS alarm'.

GEMOS alarm notification.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aGEMOSkey | GEMOS alarm key.
[out] | aGEMOSint | GEMOS alarm integer parameter.
[out] | aGEMOSstr | GEMOS alarm string parameter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGSCSVehicleAccessDenied | ( | ConstHGscAction | anAction,
 |  | __int32 & | aSequenceID,
 |  | const wchar_t *& | aPlateNo,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aCompanyCategory,
 |  | const wchar_t *& | aCompanyName,
 |  | const wchar_t *& | aReason,
 |  | const wchar_t *& | aTrafficLane,
 |  | const TPlcMediaChannelID *& | aChannel,
 |  | const TrafficDirection *& | aDirection
 | ) |  |

Decode action 'GSCS vehicle access denied'.

GSCS vehicle access denied.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSequenceID | The sequence ID.
[out] | aPlateNo | Recognized plate no.
[out] | aTimeStamp | Time stamp.
[out] | aCompanyCategory | Company category.
[out] | aCompanyName | Company name.
[out] | aReason | Reason.
[out] | aTrafficLane | Traffic lane.
[out] | aChannel | Channel.
[out] | aDirection | Direction.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGSCSVehicleAccessExpired | ( | ConstHGscAction | anAction,
 |  | __int32 & | aSequenceID,
 |  | const wchar_t *& | aPlateNo,
 |  | TGLibDateTime & | aTimeStamp,
 |  | TGLibDateTime & | aExpiringTime,
 |  | const wchar_t *& | aCompanyCategory,
 |  | const wchar_t *& | aCompanyName,
 |  | const wchar_t *& | aReason,
 |  | const wchar_t *& | aTrafficLane,
 |  | const TPlcMediaChannelID *& | aChannel,
 |  | const TrafficDirection *& | aDirection
 | ) |  |

Decode action 'GSCS vehicle access expired'.

GSCS vehicle access expired.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSequenceID | The sequence ID.
[out] | aPlateNo | Recognized plate no.
[out] | aTimeStamp | Time stamp.
[out] | aExpiringTime | Expiring time.
[out] | aCompanyCategory | Company category.
[out] | aCompanyName | Company name.
[out] | aReason | Reason.
[out] | aTrafficLane | Traffic lane.
[out] | aChannel | Channel.
[out] | aDirection | Direction.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGSCSVehicleAccessGranted | ( | ConstHGscAction | anAction,
 |  | __int32 & | aSequenceID,
 |  | const wchar_t *& | aPlateNo,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aCompanyCategory,
 |  | const wchar_t *& | aCompanyName,
 |  | const wchar_t *& | aReason,
 |  | const wchar_t *& | aTrafficLane,
 |  | const TPlcMediaChannelID *& | aChannel,
 |  | const TrafficDirection *& | aDirection
 | ) |  |

Decode action 'GSCS vehicle access granted'.

GSCS vehicle access granted.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSequenceID | The sequence ID.
[out] | aPlateNo | Recognized plate no.
[out] | aTimeStamp | Time stamp.
[out] | aCompanyCategory | Company category.
[out] | aCompanyName | Company name.
[out] | aReason | Reason.
[out] | aTrafficLane | Traffic lane.
[out] | aChannel | Channel.
[out] | aDirection | Direction.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGSCSVehicleAccessPending | ( | ConstHGscAction | anAction,
 |  | __int32 & | aSequenceID,
 |  | const wchar_t *& | aPlateNo,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aCompanyCategory,
 |  | const wchar_t *& | aCompanyName,
 |  | const wchar_t *& | aReason,
 |  | const wchar_t *& | aTrafficLane,
 |  | const TPlcMediaChannelID *& | aChannel,
 |  | const TrafficDirection *& | aDirection
 | ) |  |

Decode action 'GSCS vehicle access pending'.

GSCS vehicle access pending.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSequenceID | The sequence ID.
[out] | aPlateNo | Recognized plate no.
[out] | aTimeStamp | Time stamp.
[out] | aCompanyCategory | Company category.
[out] | aCompanyName | Company name.
[out] | aReason | Reason.
[out] | aTrafficLane | Traffic lane.
[out] | aChannel | Channel.
[out] | aDirection | Direction.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGTectAnalyticsLiveCheck ( ConstHGscAction anAction )

Decode action 'G-Tect analytics live check'.

This action will be fired periodically to ensure that analytics client is still running.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGTectDualSensorAlarm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const __int32 *& | aSterileZoneNumber,
 |  | const __int32 *& | aVirtualFenceNumber,
 |  | const VMDGroup *& | aVMDGroup,
 |  | const __int32 *& | aVMDZone,
 |  | const VMDCycle *& | aVMDCycle,
 |  | const TPlcRect *& | aAlarmArea
 | ) |  |

Decode action 'G-Tect/Dual sensor alarm'.

This action will be fired when G-Tect/Dual sensor detects an alarm.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSterileZoneNumber | Sterile Zone Number
[out] | aVirtualFenceNumber | Virtual Fence Number.
[out] | aVMDGroup | VMD alarm group.
[out] | aVMDZone | VMD zone nr.
[out] | aVMDCycle | VMD measure cycle.
[out] | aAlarmArea | Alarm area.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aSterileZoneNumber. aVirtualFenceNumber. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGTectDualSensorAlarmFinished | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'G-Tect/Dual sensor alarm finished'.

This action will be fired when the alarm is finished.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGTectSceneAlarm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | GTectSceneAlarmReason & | aAlarmReason
 | ) |  |

Decode action 'G-Tect scene alarm'.

This action will be fired when G-Tect Video content analysis detects a scene alarm.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aAlarmReason | Alarm reason.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGTectSceneAlarmFinished | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | GTectSceneAlarmReason & | aAlarmReason
 | ) |  |

Decode action 'G-Tect scene alarm finished'.

This action will be fired when G-Tect Video content analysis scene alarm is finished.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aAlarmReason | Alarm reason.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGTectVMXAlarm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const __int32 *& | aSterileZoneNumber,
 |  | const __int32 *& | aVirtualFenceNumber,
 |  | const __int32 *& | aAlarmGroup,
 |  | const __int32 *& | aTrackID,
 |  | const TPlcRect *& | aAlarmArea
 | ) |  |

Decode action 'G-Tect/VMX alarm'.

This action will be fired when G-Tect/VMX Video content analysis detects an alarm.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSterileZoneNumber | Sterile Zone Number
[out] | aVirtualFenceNumber | Virtual Fence Number.
[out] | aAlarmGroup | Used to group different Zones or fences to the same level.
[out] | aTrackID | Internal Track ID.
[out] | aAlarmArea | Alarm area.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aSterileZoneNumber. aVirtualFenceNumber. aAlarmGroup. aTrackID. aAlarmArea.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeGTectVMXAlarmFinished | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'G-Tect/VMX alarm finished'.

This action will be fired when the alarm is finished.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIASSettingsChanged | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType
 | ) |  |

Decode action 'IAS settings changed'.

IAS settings changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeImageExportNotification | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aUser,
 |  | const wchar_t *& | aDestination,
 |  | PlcImageExportType & | aDestinationType,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime *& | aTimeEnd,
 |  | const wchar_t *& | aChannels,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'Image export notification'.

Notification on export or print of channel images.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aUser | Name of the user connected to the system.
[out] | aDestination | Destination.
[out] | aDestinationType | Destination type.
[out] | aTimeStamp | Time stamp.
[out] | aTimeEnd | End time.
[out] | aChannels | Channels.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aTimeEnd. aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeImexCapacityFileAutoDeleted | ( | ConstHGscAction | anAction,
 |  | ABCapacityWarning & | aWarning,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aTotalCapacity,
 |  | __int64 & | aFreeCapacity,
 |  | __int64 & | aAllocatedByImageFile,
 |  | __int32 & | aPercentFree,
 |  | __int32 & | aPercentAllocated,
 |  | __int32 & | aPercentAllocatedByImageFile,
 |  | __int64 & | aTotalFileSize,
 |  | __int32 & | aNumberOfFiles
 | ) |  |

Decode action 'Imex capacity file auto deleted'.

Imex capacity warning: file auto deleted.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWarning | Warning.
[out] | aDestination | Destination.
[out] | aTotalCapacity | Total capacity.
[out] | aFreeCapacity | Free capacity.
[out] | aAllocatedByImageFile | Allocated by image file.
[out] | aPercentFree | Percent free.
[out] | aPercentAllocated | Percent allocated.
[out] | aPercentAllocatedByImageFile | Percent allocated by image file.
[out] | aTotalFileSize | Total file size.
[out] | aNumberOfFiles | Number of files.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeImexCapacityOutOfDiskSpace | ( | ConstHGscAction | anAction,
 |  | ABCapacityWarning & | aWarning,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aTotalCapacity,
 |  | __int64 & | aFreeCapacity,
 |  | __int64 & | aAllocatedByImageFile,
 |  | __int32 & | aPercentFree,
 |  | __int32 & | aPercentAllocated,
 |  | __int32 & | aPercentAllocatedByImageFile
 | ) |  |

Decode action 'Imex capacity out of disk space.

'. Imex capacity warning: out of disk space.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWarning | Warning.
[out] | aDestination | Destination.
[out] | aTotalCapacity | Total capacity.
[out] | aFreeCapacity | Free capacity.
[out] | aAllocatedByImageFile | Allocated by image file.
[out] | aPercentFree | Percent free.
[out] | aPercentAllocated | Percent allocated.
[out] | aPercentAllocatedByImageFile | Percent allocated by image file.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeImexCapacityWarning | ( | ConstHGscAction | anAction,
 |  | ABCapacityWarning & | aWarning,
 |  | TPlcResourceID & | aDestination,
 |  | __int64 & | aTotalCapacity,
 |  | __int64 & | aFreeCapacity,
 |  | __int64 & | aAllocatedByImageFile,
 |  | __int32 & | aPercentFree,
 |  | __int32 & | aPercentAllocated,
 |  | __int32 & | aPercentAllocatedByImageFile
 | ) |  |

Decode action 'Imex capacity warning'.

Imex capacity warning: capacity warning.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWarning | Warning.
[out] | aDestination | Destination.
[out] | aTotalCapacity | Total capacity.
[out] | aFreeCapacity | Free capacity.
[out] | aAllocatedByImageFile | Allocated by image file.
[out] | aPercentFree | Percent free.
[out] | aPercentAllocated | Percent allocated.
[out] | aPercentAllocatedByImageFile | Percent allocated by image file.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeImexExportEventImage | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID,
 |  | TPlcEventTypeID & | aTypeID,
 |  | const TPlcResourceID *& | aDestination,
 |  | const wchar_t *& | aFilePath
 | ) |  |

Decode action 'Imex export event image'.

Imex export event image.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
[out] | aTypeID | Type of the event.
[out] | aDestination | Destination.
[out] | aFilePath | File name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDestination. aFilePath.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeImexExportImageFromDB | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID *& | aDestination,
 |  | const wchar_t *& | aFilePath,
 |  | const TGLibDateTime *& | aPictureTime
 | ) |  |

Decode action 'Imex export image from DB'.

Imex export image from DB.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aDestination | Destination.
[out] | aFilePath | File name.
[out] | aPictureTime | Picture time.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDestination. aFilePath. aPictureTime.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeImexExportImageFromLiveStream | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID *& | aDestination,
 |  | const wchar_t *& | aFilePath
 | ) |  |

Decode action 'Imex export image from live stream'.

Imex export image from live stream.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aDestination | Destination.
[out] | aFilePath | File name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDestination. aFilePath.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeInitializeRemoteExport | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | GUID & | aDevice
 | ) |  |

Decode action 'Initialize remote export'.

Initialize remote export.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aDevice | Pilot device GUID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeInterfaceRawAnswer | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aData
 | ) |  |

Decode action 'Interface raw answer'.

Interface raw answer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceName | Interface name.
[out] | aTimeStamp | Time stamp.
[out] | aData | Interface answer.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeInterfaceRawData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aData
 | ) |  |

Decode action 'Interface raw data'.

Interface raw data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceName | Interface name.
[out] | aTimeStamp | Time stamp.
[out] | aData | Interface data.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIOI43ResetMainboard ( ConstHGscAction anAction )

Decode action 'IOI43 reset mainboard'.

Reset mainboard using IOI43a/ab USB Alarm-I/O.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIOI43Temperature | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aID,
 |  | __int32 & | aTemperature
 | ) |  |

Decode action 'IOI43 temperature notification'.

Temperature notification from IOI43a/ab USB Alarm-I/O.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aID | ID of the IOI43 module (like IOI43-00).
[out] | aTemperature | Temperature.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIOI43WDActivate ( ConstHGscAction anAction )

Decode action 'IOI43 watchdog activate'.

Activate watchdog on IOI43a/ab USB Alarm-I/O.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIOI43WDDeactivate ( ConstHGscAction anAction )

Decode action 'IOI43 watchdog deactivate'.

Deactivate watchdog on IOI43a/ab USB Alarm-I/O.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIOI43WDTrigger ( ConstHGscAction anAction )

Decode action 'IOI43 watchdog trigger'.

Trigger watchdog on IOI43a/ab USB Alarm-I/O.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIPCameraRawCommand | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aURL,
 |  | const wchar_t *& | aUser,
 |  | const wchar_t *& | aPassword,
 |  | const wchar_t *& | aPOST
 | ) |  |

Decode action 'IP camera raw command'.

This action sends a special command to the IP camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aURL | Complete command URL (like http://192.168.0.165:80/set?daynight=night).
[out] | aUser | User name to authenticate by the camera (optional).
[out] | aPassword | Password to authenticate by the camera (optional).
[out] | aPOST | POST parameters (optional, separate lines with \r\n).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aUser. aPassword. aPOST.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIPCamFailoverNotification | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aPrimaryServer,
 |  | const wchar_t *& | aSecondaryServer,
 |  | TPlcMediaChannelID & | aPrimaryChannel,
 |  | TPlcMediaChannelID & | aSecondaryChannel,
 |  | const wchar_t *& | aCameraParameters
 | ) |  |

Decode action 'IP camera failover notification'.

IP camera failover notification.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aPrimaryServer | The name of the primary server.
[out] | aSecondaryServer | The name of the secondary server.
[out] | aPrimaryChannel | Primary channel.
[out] | aSecondaryChannel | Secondary channel.
[out] | aCameraParameters | Optional camera parameters.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aCameraParameters.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIPCamFailoverRestore | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aPrimaryServer,
 |  | const wchar_t *& | aSecondaryServer,
 |  | TPlcMediaChannelID & | aPrimaryChannel,
 |  | TPlcMediaChannelID & | aSecondaryChannel,
 |  | const wchar_t *& | aCameraParameters
 | ) |  |

Decode action 'IP camera failover restore'.

IP camera failover restore.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aPrimaryServer | The name of the primary server.
[out] | aSecondaryServer | The name of the secondary server.
[out] | aPrimaryChannel | Primary channel.
[out] | aSecondaryChannel | Secondary channel.
[out] | aCameraParameters | Optional camera parameters.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aCameraParameters.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIPSwitchOperation | ( | ConstHGscAction | anAction,
 |  | IPSwitchOps & | aOperation,
 |  | const wchar_t *& | aPort,
 |  | const __int32 *& | aParam
 | ) |  |

Decode action 'IP switch operation'.

IP switch operation.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aOperation | Operation.
[out] | aPort | Port no, IP address, MAC address.
[out] | aParam | Optional parameter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aParam.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIrisClose | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Iris close'.

Close camera iris.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIrisOpen | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Iris open'.

Open camera iris.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeIrisStop | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Iris stop'.

Stop camera iris.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeKeyPressed | ( | ConstHGscAction | anAction,
 |  | SystemKey & | aKey
 | ) |  |

Decode action 'Key pressed'.

This action is notified if one of the GEVISCOPE system keys is pressed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aKey | System key.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeKeyReleased | ( | ConstHGscAction | anAction,
 |  | SystemKey & | aKey
 | ) |  |

Decode action 'Key released'.

This action is notified if one of the GEVISCOPE system keys is released.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aKey | System key.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeKillAllEvents ( ConstHGscAction anAction )

Decode action 'Kill all events'.

Kill all active events.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeKillEvent | ( | ConstHGscAction | anAction,
 |  | TPlcEventTypeID & | aTypeID
 | ) |  |

Decode action 'Kill event'.

Kill event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTypeID | Type of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeKillEventByID | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID
 | ) |  |

Decode action 'Kill event by instance'.

Kill event by instance ID.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLenelAccessEvent | ( | ConstHGscAction | anAction,
 |  | const LenelEventID *& | aID,
 |  | const wchar_t *& | aPanel,
 |  | const wchar_t *& | aDevice,
 |  | const __int32 *& | aSecondaryDevice,
 |  | const __int64 *& | aCardNumber,
 |  | const LenelAccessResult *& | aAccessResult,
 |  | const LenelEventType *& | aType,
 |  | const __int32 *& | aSubType,
 |  | const wchar_t *& | aDescription,
 |  | const __int32 *& | aSerialNumber,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const __int32 *& | aAreaEnteredID,
 |  | const __int32 *& | aAreaExitedID,
 |  | const wchar_t *& | aAssetID,
 |  | const bool *& | aCardholderEntered,
 |  | const bool *& | aDuress,
 |  | const __int32 *& | aElevatorFloor,
 |  | const __int32 *& | aFacilityCode,
 |  | const bool *& | aIsReadableCard,
 |  | const __int32 *& | aIssueCode,
 |  | const wchar_t *& | aCommServerHostName,
 |  | const wchar_t *& | aEventText
 | ) |  |

Decode action 'Lenel access event'.

Lenel OnGuard access event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aID | The ID that uniquely identifies the type of this event.
[out] | aPanel | The name of the panel where this event originated.
[out] | aDevice | The name of the device where this event originated.
[out] | aSecondaryDevice | The ID of the secondary device where this event originated.
[out] | aCardNumber | The badge ID for the card that was read, if available.
[out] | aAccessResult | The level of access that was granted that resulted from reading the card.
[out] | aType | Event type i.e., duress, system, etc.
[out] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[out] | aDescription | A human readable, brief description of this event.
[out] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[out] | aTimeStamp | Time stamp.
[out] | aAreaEnteredID | The ID of the area that was entered, if any.
[out] | aAreaExitedID | The ID of the area that was exited, if any.
[out] | aAssetID | The ID of the asset related to this event, if any.
[out] | aCardholderEntered | Whether entry was made by the cardholder.
[out] | aDuress | Indicates whether this card access indicates an under duress/emergency state.
[out] | aElevatorFloor | The elevator floor on which the access event was generated, if any.
[out] | aFacilityCode | The facility code for the card that was read, if available.
[out] | aIsReadableCard | Whether the card could be read.
[out] | aIssueCode | The issue code for the card that was read, if available.
[out] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[out] | aEventText | Text associated with event
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aCardNumber. aAccessResult. aType. aSubType. aSerialNumber. aTimeStamp. aAreaEnteredID. aAreaExitedID. aAssetID. aCardholderEntered. aDuress. aElevatorFloor. aFacilityCode. aIsReadableCard. aIssueCode. aCommServerHostName. aEventText.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLenelFireEvent | ( | ConstHGscAction | anAction,
 |  | const LenelEventID *& | aID,
 |  | const wchar_t *& | aPanel,
 |  | const wchar_t *& | aDevice,
 |  | const __int32 *& | aSecondaryDevice,
 |  | const __int32 *& | aTroubleCode,
 |  | const LenelEventType *& | aType,
 |  | const __int32 *& | aSubType,
 |  | const wchar_t *& | aDescription,
 |  | const __int32 *& | aSerialNumber,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const wchar_t *& | aCommServerHostName,
 |  | const wchar_t *& | aEventText
 | ) |  |

Decode action 'Lenel fire event'.

Lenel OnGuard fire event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aID | The ID that uniquely identifies the type of this event.
[out] | aPanel | The name of the panel where this event originated.
[out] | aDevice | The name of the device where this event originated.
[out] | aSecondaryDevice | The ID of the secondary device where this event originated.
[out] | aTroubleCode | A trouble code associated with the fire event.
[out] | aType | Event type i.e., duress, system, etc.
[out] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[out] | aDescription | A human readable, brief description of this event.
[out] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[out] | aTimeStamp | Time stamp.
[out] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[out] | aEventText | Text associated with event
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aTroubleCode. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLenelIntercomEvent | ( | ConstHGscAction | anAction,
 |  | const LenelEventID *& | aID,
 |  | const wchar_t *& | aPanel,
 |  | const wchar_t *& | aDevice,
 |  | const __int32 *& | aSecondaryDevice,
 |  | const __int32 *& | aIntercomData,
 |  | const __int32 *& | aLineNumber,
 |  | const LenelEventType *& | aType,
 |  | const __int32 *& | aSubType,
 |  | const wchar_t *& | aDescription,
 |  | const __int32 *& | aSerialNumber,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const wchar_t *& | aCommServerHostName,
 |  | const wchar_t *& | aEventText
 | ) |  |

Decode action 'Lenel intercom event'.

Lenel OnGuard intercom event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aID | The ID that uniquely identifies the type of this event.
[out] | aPanel | The name of the panel where this event originated.
[out] | aDevice | The name of the device where this event originated.
[out] | aSecondaryDevice | The ID of the secondary device where this event originated.
[out] | aIntercomData | Additional data for the intercom event that occurred.
[out] | aLineNumber | The line number involved in the intercom event.
[out] | aType | Event type i.e., duress, system, etc.
[out] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[out] | aDescription | A human readable, brief description of this event.
[out] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[out] | aTimeStamp | Time stamp.
[out] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[out] | aEventText | Text associated with event
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aIntercomData. aLineNumber. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLenelRawData | ( | ConstHGscAction | anAction,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aLenelData
 | ) |  |

Decode action 'Lenel raw data'.

Lenel OnGuard raw data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTimeStamp | Time stamp.
[out] | aLenelData | Lenel OnGuard data.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLenelRefreshNames ( ConstHGscAction anAction )

Decode action 'Lenel refresh names'.

Lenel OnGuard refresh names.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLenelSecurityEvent | ( | ConstHGscAction | anAction,
 |  | const LenelEventID *& | aID,
 |  | const wchar_t *& | aPanel,
 |  | const wchar_t *& | aDevice,
 |  | const __int32 *& | aSecondaryDevice,
 |  | const LenelEventType *& | aType,
 |  | const __int32 *& | aSubType,
 |  | const wchar_t *& | aDescription,
 |  | const __int32 *& | aSerialNumber,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const wchar_t *& | aCommServerHostName,
 |  | const wchar_t *& | aEventText
 | ) |  |

Decode action 'Lenel security event'.

Lenel OnGuard security event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aID | The ID that uniquely identifies the type of this event.
[out] | aPanel | The name of the panel where this event originated.
[out] | aDevice | The name of the device where this event originated.
[out] | aSecondaryDevice | The ID of the secondary device where this event originated.
[out] | aType | Event type i.e., duress, system, etc.
[out] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[out] | aDescription | A human readable, brief description of this event.
[out] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[out] | aTimeStamp | Time stamp.
[out] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[out] | aEventText | Text associated with event
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLenelVideoEvent | ( | ConstHGscAction | anAction,
 |  | const LenelEventID *& | aID,
 |  | const wchar_t *& | aPanel,
 |  | const wchar_t *& | aDevice,
 |  | const __int32 *& | aSecondaryDevice,
 |  | const __int32 *& | aChannel,
 |  | const LenelEventType *& | aType,
 |  | const __int32 *& | aSubType,
 |  | const wchar_t *& | aDescription,
 |  | const __int32 *& | aSerialNumber,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const TGLibDateTime *& | aStartTime,
 |  | const TGLibDateTime *& | aEndTime,
 |  | const wchar_t *& | aCommServerHostName,
 |  | const wchar_t *& | aEventText
 | ) |  |

Decode action 'Lenel video event'.

Lenel OnGuard video event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aID | The ID that uniquely identifies the type of this event.
[out] | aPanel | The name of the panel where this event originated.
[out] | aDevice | The name of the device where this event originated.
[out] | aSecondaryDevice | The ID of the secondary device where this event originated.
[out] | aChannel | The physical channel the camera is connected to that is creating this event.
[out] | aType | Event type i.e., duress, system, etc.
[out] | aSubType | Event sub-type i.e., granted, door forced open, etc.
[out] | aDescription | A human readable, brief description of this event.
[out] | aSerialNumber | A number that uniquely identifies the instance of the event for a particular panel.
[out] | aTimeStamp | Time stamp.
[out] | aStartTime | The time the video event started
[out] | aEndTime | The time the video event ended.
[out] | aCommServerHostName | Host name of the Communication server through which the event arrived.
[out] | aEventText | Text associated with event
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aID. aPanel. aDevice. aSecondaryDevice. aChannel. aType. aSubType. aSerialNumber. aTimeStamp. aStartTime. aEndTime. aCommServerHostName. aEventText.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLiveCheck | ( | ConstHGscAction | anAction,
 |  | __int64 & | aCounter,
 |  | TGLibDateTime & | aDate
 | ) |  |

Decode action 'Live check'.

This action will be fired every 10 seconds and is intended for use as live check.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCounter | This is the number of already fired live check actions.
[out] | aDate | Current server time.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLogBarcodeData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aBarcode,
 |  | const __int64 *& | aHash,
 |  | const wchar_t *& | aScanner,
 |  | const __int64 *& | aAreaID,
 |  | const wchar_t *& | aAreaName,
 |  | const TPlcMediaChannelID *& | aChannel,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const wchar_t *& | aOrder,
 |  | const wchar_t *& | aShipment,
 |  | const wchar_t *& | aItem
 | ) |  |

Decode action 'Log barcode data'.

Logistic barcode data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aBarcode | Barcode.
[out] | aHash | Hash value.
[out] | aScanner | Scanner name or IP address.
[out] | aAreaID | Area number.
[out] | aAreaName | Area name.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aOrder | Order number.
[out] | aShipment | Shipment number.
[out] | aItem | Item number.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aOrder. aShipment. aItem.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLogBarcodeDataLPS | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aBarcode,
 |  | const __int64 *& | aHash,
 |  | const wchar_t *& | aScanner,
 |  | const __int64 *& | aAreaID,
 |  | const wchar_t *& | aAreaName,
 |  | const TPlcMediaChannelID *& | aChannel,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const double *& | aX,
 |  | const double *& | aY,
 |  | const double *& | aZ,
 |  | const __int32 *& | aLpsTagID,
 |  | const PlcLpsStatus *& | aLpsStatus,
 |  | const __int32 *& | aLpsCellID,
 |  | const __int32 *& | aLpsAreaID,
 |  | const __int32 *& | aUserParam,
 |  | const wchar_t *& | aOrder,
 |  | const wchar_t *& | aShipment,
 |  | const wchar_t *& | aItem
 | ) |  |

Decode action 'Log barcode data LPS'.

Logistic barcode and LPS data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aBarcode | Barcode.
[out] | aHash | Hash value.
[out] | aScanner | Scanner name or IP address.
[out] | aAreaID | Area number.
[out] | aAreaName | Area name.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aX | X coordinate.
[out] | aY | Y coordinate.
[out] | aZ | Z coordinate.
[out] | aLpsTagID | LPS tag ID.
[out] | aLpsStatus | LPS status.
[out] | aLpsCellID | LPS cell ID.
[out] | aLpsAreaID | LPS area ID.
[out] | aUserParam | User param.
[out] | aOrder | Order number.
[out] | aShipment | Shipment number.
[out] | aItem | Item number.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aX. aY. aZ. aLpsTagID. aLpsStatus. aLpsCellID. aLpsAreaID. aUserParam. aOrder. aShipment. aItem.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLogNPRRecognition | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aPlateNo,
 |  | const __int64 *& | aHash,
 |  | const wchar_t *& | aCountry,
 |  | const TPlcMediaChannelID *& | aChannel,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const PlcNPRRestriction *& | aRestriction,
 |  | const wchar_t *& | aCategory
 | ) |  |

Decode action 'Log NPR recognition'.

Log NPR recognition.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aPlateNo | Recognized plate no.
[out] | aHash | Hash value.
[out] | aCountry | Country.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aRestriction | Restriction of recognized number.
[out] | aCategory | Category of recognized number.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aHash. aCountry. aChannel. aTimeStamp. aRestriction. aCategory.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLPSPositionData | ( | ConstHGscAction | anAction,
 |  | __int32 & | aTagID,
 |  | const wchar_t *& | aScannerID,
 |  | __int64 & | aX,
 |  | __int64 & | aY,
 |  | const __int64 *& | aZ,
 |  | const double *& | aLatitude,
 |  | const double *& | aLongitude,
 |  | __int32 & | aAreaID,
 |  | const __int32 *& | aCellID,
 |  | PlcLpsStatus & | aStatus,
 |  | const TGLibDateTime *& | aTimeStamp,
 |  | const wchar_t *& | aData,
 |  | const wchar_t *& | aAreaName
 | ) |  |

Decode action 'LPS position data'.

LPS position data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTagID | Tag ID.
[out] | aScannerID | Scanner ID or IP address.
[out] | aX | X coordinate of cartesian coordinates.
[out] | aY | Y coordinate of cartesian coordinates.
[out] | aZ | Z coordinate of cartesian coordinates.
[out] | aLatitude | Latitude of geographic coordinates.
[out] | aLongitude | Longitude of geographic coordinates.
[out] | aAreaID | Area ID.
[out] | aCellID | Cell ID.
[out] | aStatus | Status.
[out] | aTimeStamp | Time stamp.
[out] | aData | Data.
[out] | aAreaName | Area Name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aScannerID. aZ. aLatitude. aLongitude. aCellID. aTimeStamp. aData. aAreaName.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeLPSQueryPosition | ( | ConstHGscAction | anAction,
 |  | __int32 & | aTagID,
 |  | const wchar_t *& | aScannerID,
 |  | const wchar_t *& | aData
 | ) |  |

Decode action 'LPS query position'.

Send position query for a Tag to LPS server.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTagID | Tag ID.
[out] | aScannerID | Scanner ID or IP address.
[out] | aData | Data.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aScannerID. aData.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeMakeCPAReferenceImage | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'Make CPA reference image'.

Make CPA reference image.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeMediaChannelSetupInfo | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aParameter
 | ) |  |

Decode action 'Media channel setup'.

Media channel setup info.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aParameter | Parameter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeMoveToAbsolutePosition | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | double & | aAlpha,
 |  | double & | aBeta,
 |  | double & | aSpeedAlpha,
 |  | double & | aSpeedBeta
 | ) |  |

Decode action 'Move to absolute position'.

Move camera to absolute position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aAlpha | Alpha angle (-180°/+180°).
[out] | aBeta | Beta angle (-90°/+90°).
[out] | aSpeedAlpha | Speed in alpha direction (0/100 %).
[out] | aSpeedBeta | Speed in beta direction (0/100 %).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeMoveToBySpeed | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | double & | aSpeedAlpha,
 |  | double & | aSpeedBeta
 | ) |  |

Decode action 'Move by speed'.

Move camera by speed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeedAlpha | Speed in alpha (pan) direction (0/100 %).
[out] | aSpeedBeta | Speed in beta (tilt) direction (0/100 %).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeMoveToRelativePosition | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | double & | aAlpha,
 |  | double & | aBeta,
 |  | double & | aSpeedAlpha,
 |  | double & | aSpeedBeta
 | ) |  |

Decode action 'Move to relative position'.

Move camera to relative position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aAlpha | Alpha angle (-180°/+180°).
[out] | aBeta | Beta angle (-90°/+90°).
[out] | aSpeedAlpha | Speed in alpha direction (0/100 %).
[out] | aSpeedBeta | Speed in beta direction (0/100 %).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeNPRRawData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aPlateNo,
 |  | const wchar_t *& | aCountry,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TGLibDateTime & | aTimeStamp,
 |  | TPlcRect & | aZoneRect,
 |  | __int32 & | aWeight,
 |  | __int32 & | aZoneState,
 |  | __int32 & | aZonePlace,
 |  | __int32 & | aSpeed,
 |  | __int32 & | aDirection,
 |  | __int32 & | aZoneIndex,
 |  | bool & | aCurBest,
 |  | __int32 & | aPlateWidth,
 |  | __int32 & | aPlateHeight,
 |  | __int32 & | aPlateAngle,
 |  | __int32 & | aSymHeight,
 |  | const wchar_t *& | aType
 | ) |  |

Decode action 'NPR raw data'.

NPR raw data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aPlateNo | Recognized plate no.
[out] | aCountry | Country.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aZoneRect | Zone rectangle.
[out] | aWeight | Weight of recognition.
[out] | aZoneState | Zone state.
[out] | aZonePlace | Zone status.
[out] | aSpeed | Speed in km/h
[out] | aDirection | Direction of the motion.
[out] | aZoneIndex | Zone index.
[out] | aCurBest | Current recognition is best.
[out] | aPlateWidth | Plate width.
[out] | aPlateHeight | Plate height.
[out] | aPlateAngle | Plate angle.
[out] | aSymHeight | Symbol height.
[out] | aType | Number type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeNPRRecognition | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aPlateNo,
 |  | const wchar_t *& | aCountry,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TGLibDateTime & | aTimeStamp,
 |  | TPlcRect & | aZoneRect,
 |  | PlcNPRRestriction & | aRestriction,
 |  | const wchar_t *& | aCategory,
 |  | __int32 & | aSpeed,
 |  | __int32 & | aDirection,
 |  | __int32 & | aZoneIndex,
 |  | const wchar_t *& | aType,
 |  | __int32 & | aWeight
 | ) |  |

Decode action 'NPR recognition'.

NPR recognition.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aPlateNo | Recognized plate no.
[out] | aCountry | Country.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aZoneRect | Zone rectangle.
[out] | aRestriction | Restriction of recognized number.
[out] | aCategory | Category of recognized number.
[out] | aSpeed | Speed in km/h
[out] | aDirection | Direction of the motion.
[out] | aZoneIndex | Zone index.
[out] | aType | Number type.
[out] | aWeight | Weight of recognition.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackChannelCounter | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcObtrackCounterType & | aCounterType,
 |  | __int64 & | aCounterValue,
 |  | __int32 & | aObjectDirection,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime *& | aResetTimeStamp
 | ) |  |

Decode action 'OBTRACK channel counter'.

OBTRACK channel counter.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aCounterType | Counter type.
[out] | aCounterValue | Counter value.
[out] | aObjectDirection | Object direction.
[out] | aTimeStamp | Time stamp.
[out] | aResetTimeStamp | Reset time stamp.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aResetTimeStamp.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackChannelCounterThreshold | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcObtrackCounterType & | aCounterType,
 |  | __int64 & | aCounterValue,
 |  | PlcObtrackExceedingDirection & | aExceedingDirection,
 |  | TGLibDateTime & | aTimeStamp
 | ) |  |

Decode action 'OBTRACK channel counter threshold'.

OBTRACK channel counter threshold.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aCounterType | Counter type.
[out] | aCounterValue | Counter value.
[out] | aExceedingDirection | Exceeding direction.
[out] | aTimeStamp | Time stamp.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackChannelSetCounter | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcObtrackCounterType & | aCounterType,
 |  | __int64 & | aCounterValue,
 |  | TGLibDateTime & | aTimeStamp
 | ) |  |

Decode action 'OBTRACK channel set counter'.

OBTRACK channel set counter.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aCounterType | Counter type.
[out] | aCounterValue | Counter value.
[out] | aTimeStamp | Time stamp.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackFrameRawData | ( | ConstHGscAction | anAction,
 |  | TGLibDateTime & | aTimeStamp,
 |  | TPlcMediaChannelID & | aChannel,
 |  | __int32 & | aBrightness,
 |  | __int32 & | aContrast
 | ) |  |

Decode action 'OBTRACK frame raw data'.

OBTRACK frame raw data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTimeStamp | Time stamp.
[out] | aChannel | Channel.
[out] | aBrightness | Brightness.
[out] | aContrast | Contrast.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackGroupCounter | ( | ConstHGscAction | anAction,
 |  | __int32 & | aGroupId,
 |  | PlcObtrackCounterType & | aCounterType,
 |  | __int64 & | aCounterValue,
 |  | __int32 & | aObjectDirection,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime *& | aResetTimeStamp,
 |  | const wchar_t *& | aGroupName
 | ) |  |

Decode action 'OBTRACK group counter'.

OBTRACK group counter.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aGroupId | Group ID.
[out] | aCounterType | Counter type.
[out] | aCounterValue | Counter value.
[out] | aObjectDirection | Object direction.
[out] | aTimeStamp | Time stamp.
[out] | aResetTimeStamp | Reset time stamp.
[out] | aGroupName | Group name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aResetTimeStamp. aGroupName.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackGroupCounterThreshold | ( | ConstHGscAction | anAction,
 |  | __int32 & | aGroupId,
 |  | PlcObtrackCounterType & | aCounterType,
 |  | __int64 & | aCounterValue,
 |  | PlcObtrackExceedingDirection & | aExceedingDirection,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aGroupName
 | ) |  |

Decode action 'OBTRACK group counter threshold'.

OBTRACK group counter threshold.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aGroupId | Group ID.
[out] | aCounterType | Counter type.
[out] | aCounterValue | Counter value.
[out] | aExceedingDirection | Exceeding direction.
[out] | aTimeStamp | Time stamp.
[out] | aGroupName | Group name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aGroupName.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackGroupSetCounter | ( | ConstHGscAction | anAction,
 |  | __int32 & | aGroupId,
 |  | PlcObtrackCounterType & | aCounterType,
 |  | __int64 & | aCounterValue,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aGroupName
 | ) |  |

Decode action 'OBTRACK group set counter'.

OBTRACK group set counter.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aGroupId | Group ID.
[out] | aCounterType | Counter type.
[out] | aCounterValue | Counter value.
[out] | aTimeStamp | Time stamp.
[out] | aGroupName | Group name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aGroupName.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackObjectRawData | ( | ConstHGscAction | anAction,
 |  | TGLibDateTime & | aTimeStamp,
 |  | TPlcMediaChannelID & | aChannel,
 |  | __int32 & | aArea,
 |  | __int32 & | aObjectID,
 |  | PlcObtrackObjectStatus & | aObjectStatus,
 |  | PlcObtrackObjectClass & | aObjectClass,
 |  | const __int32 *& | aConfidence,
 |  | const TPlcRect *& | aPosition,
 |  | const double *& | aSpeed,
 |  | const __int32 *& | aDuration,
 |  | const __int32 *& | aDirection,
 |  | const double *& | aSize,
 |  | const double *& | aObjectWidth,
 |  | const double *& | aObjectHeight,
 |  | const PlcObtrackProcessSize *& | aProcessSize,
 |  | const char *& | aGscNetName
 | ) |  |

Decode action 'OBTRACK object raw data'.

OBTRACK object raw data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTimeStamp | Time stamp.
[out] | aChannel | Channel.
[out] | aArea | Area no.
[out] | aObjectID | Object ID.
[out] | aObjectStatus | Object status.
[out] | aObjectClass | Object class.
[out] | aConfidence | Confidence.
[out] | aPosition | Position.
[out] | aSpeed | Speed.
[out] | aDuration | Duration.
[out] | aDirection | Direction.
[out] | aSize | Object size.
[out] | aObjectWidth | Object width in meters.
[out] | aObjectHeight | Object height in meters.
[out] | aProcessSize | Process size.
[out] | aGscNetName | GeViScope network name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aConfidence. aPosition. aSpeed. aDuration. aDirection. aSize. aObjectWidth. aObjectHeight. aProcessSize. aGscNetName.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeObtrackTunnelAlarm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TGLibDateTime & | aTimeStamp,
 |  | PlcTunnelAlarmReason & | aAlarmReason,
 |  | __int32 & | aObjectID,
 |  | __int32 & | aAlarmAreaID,
 |  | const TPlcRect *& | aObjectArea
 | ) |  |

Decode action 'OBTRACK tunnel alarm'.

OBTRACK tunnel alarm notification.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aTimeStamp | Time stamp.
[out] | aAlarmReason | Alarm reason.
[out] | aObjectID | Object ID.
[out] | aAlarmAreaID | Alarm area ID.
[out] | aObjectArea | Object area.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aObjectArea.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodePanAuto | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aModus
 | ) |  |

Decode action 'Pan auto'.

Turn auto pan of the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aModus | Pan modus.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePanLeft | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Pan left'.

Pan camera to the left.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Pan speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePanRight | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Pan right'.

Pan camera to the right.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Pan speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePanStop | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Pan stop'.

Stop pan movement.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePOSData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aPOSName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | const wchar_t *& | aArticle,
 |  | const double *& | aPrice,
 |  | const __int32 *& | aUnits,
 |  | const double *& | aPricePerUnit,
 |  | const wchar_t *& | aLine1,
 |  | const wchar_t *& | aLine2,
 |  | const wchar_t *& | aLine3,
 |  | const wchar_t *& | aLine4,
 |  | const wchar_t *& | aLine5
 | ) |  |

Decode action 'POS data'.

POS data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aPOSName | POS name.
[out] | aTimeStamp | Time stamp.
[out] | aArticle | Article description.
[out] | aPrice | Price.
[out] | aUnits | Number of units.
[out] | aPricePerUnit | Price per unit.
[out] | aLine1 | Line 1.
[out] | aLine2 | Line 2.
[out] | aLine3 | Line 3.
[out] | aLine4 | Line 4.
[out] | aLine5 | Line 5.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aArticle. aPrice. aUnits. aPricePerUnit. aLine1. aLine2. aLine3. aLine4. aLine5.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodePOSStatus | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aPOSName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | PlcPOSStatus & | aStatus,
 |  | const wchar_t *& | aDetails
 | ) |  |

Decode action 'POS status'.

POS status.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aPOSName | POS name.
[out] | aTimeStamp | Time stamp.
[out] | aStatus | Status.
[out] | aDetails | Details.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDetails.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPDeviceAlarm | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID,
 |  | __int32 & | aDeviceAddress,
 |  | PPSensorKind & | aSensor,
 |  | PPAlarmState & | aState
 | ) |  |

Decode action 'PP device alarm'.

Perimeter protection device alarm.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
[out] | aDeviceAddress | Device address.
[out] | aSensor | Sensor.
[out] | aState | State.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPDeviceInput | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID,
 |  | __int32 & | aDeviceAddress,
 |  | __int32 & | aInput,
 |  | PPAlarmState & | aState
 | ) |  |

Decode action 'PP device input'.

Perimeter protection device input.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
[out] | aDeviceAddress | Device address.
[out] | aInput | Input.
[out] | aState | State.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPDeviceOffline | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID,
 |  | __int32 & | aDeviceAddress
 | ) |  |

Decode action 'PP device offline'.

Perimeter protection device offline.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
[out] | aDeviceAddress | Device address.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPDeviceOnline | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID,
 |  | __int32 & | aDeviceAddress
 | ) |  |

Decode action 'PP device online'.

Perimeter protection device online.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
[out] | aDeviceAddress | Device address.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPInterfaceOffline | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID
 | ) |  |

Decode action 'PP interface offline'.

Perimeter protection interface offline.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPInterfaceOnline | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID
 | ) |  |

Decode action 'PP interface online'.

Perimeter protection interface online.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPQueryInterface | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID
 | ) |  |

Decode action 'PP query interface'.

Perimeter protection query interface.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPSetDeviceOutput | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID,
 |  | __int32 & | aDeviceAddress,
 |  | __int32 & | aOutput,
 |  | PPAlarmState & | aState
 | ) |  |

Decode action 'PP set device output'.

Perimeter protection set device output.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
[out] | aDeviceAddress | Device address.
[out] | aOutput | Output.
[out] | aState | State.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPSubcellAlarm | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceID,
 |  | __int32 & | aDeviceAddress,
 |  | PPCableKind & | aCable,
 |  | __int32 & | aSubcell,
 |  | PPAlarmState & | aState
 | ) |  |

Decode action 'PP subcell alarm'.

Perimeter protection subcell alarm.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceID | Interface ID.
[out] | aDeviceAddress | Device address.
[out] | aCable | Cable.
[out] | aSubcell | Subcell.
[out] | aState | State.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePPZoneAlarm | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aZoneID,
 |  | const wchar_t *& | aInterfaceID,
 |  | __int32 & | aDeviceAddress,
 |  | const PPCableKind *& | aCable,
 |  | const __int32 *& | aSubcell,
 |  | PPAlarmState & | aState
 | ) |  |

Decode action 'PP zone alarm'.

Perimeter protection zone alarm.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aZoneID | Zone ID.
[out] | aInterfaceID | Interface ID.
[out] | aDeviceAddress | Device address.
[out] | aCable | Cable.
[out] | aSubcell | Subcell.
[out] | aState | State.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aCable. aSubcell.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodePrePosCallUp | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aPosition
 | ) |  |

Decode action 'Move to preset position'.

Move camera to preset position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aPosition | Preset position.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePrePosClear | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aPosition
 | ) |  |

Decode action 'Clear preset position'.

Clear camera preset position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aPosition | Preset position.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodePrePosSave | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aPosition
 | ) |  |

Decode action 'Save preset position'.

Save current camera position as preset position.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aPosition | Preset position.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeRedundantPowerFailure ( ConstHGscAction anAction )

Decode action 'Redundant power failure'.

This action is notified if a failure of the redundant power supply is detected.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeRedundantPowerOk ( ConstHGscAction anAction )

Decode action 'Redundant power ok'.

This action is notified if a failure of the redundant power supply is removed.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeResetMainboard ( ConstHGscAction anAction )

Decode action 'Reset mainboard'.

Reset mainboard using IO device.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSafebagClose | ( | ConstHGscAction | anAction,
 |  | __int32 & | aWorkingPlace,
 |  | TGLibDateTime & | aStartTime,
 |  | TGLibDateTime & | aStopTime,
 |  | const wchar_t *& | aSafebagNo,
 |  | const wchar_t *& | aSafebagInfo,
 |  | SafebagStep & | aStepID,
 |  | const double *& | aDebit,
 |  | const double *& | aTotal,
 |  | const double *& | aDifference,
 |  | const bool *& | aHasDifference,
 |  | const wchar_t *& | aNotes,
 |  | const wchar_t *& | aCoins,
 |  | const wchar_t *& | aCheques
 | ) |  |

Decode action 'Safebag close'.

Safebag close.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWorkingPlace | Working place no.
[out] | aStartTime | Start time stamp.
[out] | aStopTime | Stop time stamp.
[out] | aSafebagNo | Safebag no.
[out] | aSafebagInfo | Additional info about safebag.
[out] | aStepID | Processing step ID.
[out] | aDebit | Debit.
[out] | aTotal | Total.
[out] | aDifference | Difference between debit and total.
[out] | aHasDifference | Difference between debit and total is not zero.
[out] | aNotes | Notes.
[out] | aCoins | Coins.
[out] | aCheques | Cheques.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSafebagData | ( | ConstHGscAction | anAction,
 |  | __int32 & | aWorkingPlace,
 |  | TGLibDateTime & | aStartTime,
 |  | const wchar_t *& | aSafebagNo,
 |  | const wchar_t *& | aSafebagInfo,
 |  | SafebagStep & | aStepID,
 |  | const double *& | aDebit,
 |  | const double *& | aTotal,
 |  | const double *& | aDifference,
 |  | const bool *& | aHasDifference,
 |  | const wchar_t *& | aNotes,
 |  | const wchar_t *& | aCoins,
 |  | const wchar_t *& | aCheques
 | ) |  |

Decode action 'Safebag data'.

Safebag data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWorkingPlace | Working place no.
[out] | aStartTime | Start time stamp.
[out] | aSafebagNo | Safebag no.
[out] | aSafebagInfo | Additional info about safebag.
[out] | aStepID | Processing step ID.
[out] | aDebit | Debit.
[out] | aTotal | Total.
[out] | aDifference | Difference between debit and total.
[out] | aHasDifference | Difference between debit and total is not zero.
[out] | aNotes | Notes.
[out] | aCoins | Coins.
[out] | aCheques | Cheques.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSafebagOpen | ( | ConstHGscAction | anAction,
 |  | __int32 & | aWorkingPlace,
 |  | TGLibDateTime & | aStartTime,
 |  | const wchar_t *& | aSafebagNo,
 |  | const wchar_t *& | aSafebagInfo,
 |  | SafebagStep & | aStepID
 | ) |  |

Decode action 'Safebag open'.

Safebag open.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWorkingPlace | Working place no.
[out] | aStartTime | Start time stamp.
[out] | aSafebagNo | Safebag no.
[out] | aSafebagInfo | Additional info about safebag.
[out] | aStepID | Processing step ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSafebagPassingOfRiskData | ( | ConstHGscAction | anAction,
 |  | __int32 & | aWorkingPlace,
 |  | TGLibDateTime & | aStartTime,
 |  | const wchar_t *& | aSafebagNo,
 |  | const wchar_t *& | aSafebagInfo,
 |  | SafebagStep & | aStepID,
 |  | __int32 & | aUserID1,
 |  | __int32 & | aUserID2,
 |  | const __int32 *& | aTourNumber,
 |  | const wchar_t *& | aTargetWorkingPlace,
 |  | const wchar_t *& | aPassingOfRiskType
 | ) |  |

Decode action 'Safebag passing of risk data'.

Safebag passing of risk data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWorkingPlace | Working place no.
[out] | aStartTime | Start time stamp.
[out] | aSafebagNo | Safebag no.
[out] | aSafebagInfo | Additional info about safebag.
[out] | aStepID | Processing step ID.
[out] | aUserID1 | User who gives the safebag.
[out] | aUserID2 | User who takes the safebag.
[out] | aTourNumber | Optional tour no.
[out] | aTargetWorkingPlace | Target working place.
[out] | aPassingOfRiskType | Passing of risk type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aTourNumber. aTargetWorkingPlace. aPassingOfRiskType.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSafebagPassingOfRiskStart | ( | ConstHGscAction | anAction,
 |  | __int32 & | aWorkingPlace,
 |  | TGLibDateTime & | aStartTime,
 |  | const wchar_t *& | aSafebagNo,
 |  | const wchar_t *& | aSafebagInfo,
 |  | SafebagStep & | aStepID,
 |  | __int32 & | aUserID1,
 |  | __int32 & | aUserID2,
 |  | const __int32 *& | aTourNumber,
 |  | const wchar_t *& | aTargetWorkingPlace,
 |  | const wchar_t *& | aPassingOfRiskType
 | ) |  |

Decode action 'Safebag passing of risk start'.

Safebag passing of risk start.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWorkingPlace | Working place no.
[out] | aStartTime | Start time stamp.
[out] | aSafebagNo | Safebag no.
[out] | aSafebagInfo | Additional info about safebag.
[out] | aStepID | Processing step ID.
[out] | aUserID1 | User who gives the safebag.
[out] | aUserID2 | User who takes the safebag.
[out] | aTourNumber | Optional tour no.
[out] | aTargetWorkingPlace | Target working place.
[out] | aPassingOfRiskType | Passing of risk type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aTourNumber. aTargetWorkingPlace. aPassingOfRiskType.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSafebagPassingOfRiskStop | ( | ConstHGscAction | anAction,
 |  | __int32 & | aWorkingPlace,
 |  | TGLibDateTime & | aStartTime,
 |  | TGLibDateTime & | aStopTime,
 |  | const wchar_t *& | aSafebagNo,
 |  | const wchar_t *& | aSafebagInfo,
 |  | SafebagStep & | aStepID,
 |  | __int32 & | aUserID1,
 |  | __int32 & | aUserID2,
 |  | const __int32 *& | aTourNumber,
 |  | const wchar_t *& | aTargetWorkingPlace,
 |  | const wchar_t *& | aPassingOfRiskType
 | ) |  |

Decode action 'Safebag passing of risk stop'.

Safebag passing of risk stop.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aWorkingPlace | Working place no.
[out] | aStartTime | Start time stamp.
[out] | aStopTime | Stop time stamp.
[out] | aSafebagNo | Safebag no.
[out] | aSafebagInfo | Additional info about safebag.
[out] | aStepID | Processing step ID.
[out] | aUserID1 | User who gives the safebag.
[out] | aUserID2 | User who takes the safebag.
[out] | aTourNumber | Optional tour no.
[out] | aTargetWorkingPlace | Target working place.
[out] | aPassingOfRiskType | Passing of risk type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aTourNumber. aTargetWorkingPlace. aPassingOfRiskType.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSceneStoreModification | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | GUID & | aSceneStoreID,
 |  | const wchar_t *& | aSceneStoreName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | PlcSceneStoreModificationType & | aModificationType,
 |  | const wchar_t *& | aUser,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'Scene store modification'.

Scene store modification.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aSceneStoreID | Scene store GUID.
[out] | aSceneStoreName | Scene store name.
[out] | aTimeStamp | Time stamp.
[out] | aModificationType | Modification type.
[out] | aUser | Name of the user.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSensorAlarmFinished | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType
 | ) |  |

Decode action 'Sensor alarm finished'.

This action will be fired when the alarm is finished.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSensorAudioAlarm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'Sensor audio alarm'.

Audio alarm detected.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSensorInhibitAlarmFinished | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType
 | ) |  |

Decode action 'Sensor inhibit alarm finished'.

This action will be fired when the inhibit alarm is finished.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSensorInhibitVideoAlarmEx | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | const ADArea *& | aADArea,
 |  | const __int32 *& | aADCell,
 |  | const VMDGroup *& | aVMDGroup,
 |  | const __int32 *& | aVMDZone,
 |  | const VMDCycle *& | aVMDCycle,
 |  | const TPlcRect *& | aAlarmArea,
 |  | const PlcObtrackObjectClass *& | aObjectClass
 | ) |  |

Decode action 'Sensor inhibit video alarm'.

This action will be fired when the motion in inhibit area is detected.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aADArea | AD alarm area.
[out] | aADCell | AD cell nr.
[out] | aVMDGroup | VMD alarm group.
[out] | aVMDZone | VMD zone nr.
[out] | aVMDCycle | VMD measure cycle.
[out] | aAlarmArea | Alarm area.
[out] | aObjectClass | OBTRACK object class.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSensorVideoAlarmEx | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | const ADArea *& | aADArea,
 |  | const __int32 *& | aADCell,
 |  | const VMDGroup *& | aVMDGroup,
 |  | const __int32 *& | aVMDZone,
 |  | const VMDCycle *& | aVMDCycle,
 |  | const TPlcRect *& | aAlarmArea,
 |  | const PlcObtrackObjectClass *& | aObjectClass
 | ) |  |

Decode action 'Sensor video alarm'.

This action will be fired when video alarm is detected.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aADArea | AD alarm area.
[out] | aADCell | AD cell nr.
[out] | aVMDGroup | VMD alarm group.
[out] | aVMDZone | VMD zone nr.
[out] | aVMDCycle | VMD measure cycle.
[out] | aAlarmArea | Alarm area.
[out] | aObjectClass | OBTRACK object class.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetCameraText | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | const char *& | aText
 | ) |  |

Decode action 'Set camera text'.

Set camera text.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aText | Text to superimpose.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetClientVCA | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | GTectClientVCAType & | aClientVCAType,
 |  | bool & | aEnabled
 | ) |  |

Decode action 'Enable client VCA'.

Enable client VCA

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aClientVCAType | VCA Type
[out] | aEnabled | Enabled
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetClock | ( | ConstHGscAction | anAction,
 |  | TGLibDateTime & | aDate
 | ) |  |

Decode action 'Set clock'.

Set clock.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aDate | Current time.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetDigitalOutput | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aContact,
 |  | DigitalOutputState & | aState
 | ) |  |

Decode action 'Set digital output'.

This action is used to modify the state of the digital output and to notify this change.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aContact | Contact.
[out] | aState | New state.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetExportMarker | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | PlcExportMarker & | aMarker
 | ) |  |

Decode action 'Set export marker'.

Set export marker.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aMarker | Marker kind.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetLED | ( | ConstHGscAction | anAction,
 |  | SystemLED & | aLED,
 |  | DigitalOutputState & | aState
 | ) |  |

Decode action 'Set system LED'.

This action is used to turn the system LEDs on or off.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aLED | System LED.
[out] | aState | New state.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetLEDBlink | ( | ConstHGscAction | anAction,
 |  | SystemLED & | aLED,
 |  | __int32 & | aLedTimeOnMs,
 |  | __int32 & | aLedTimeOffMs
 | ) |  |

Decode action 'Set system LED to blink'.

This action is used to blink the system LEDs.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aLED | System LED.
[out] | aLedTimeOnMs | Time in milliseconds when the LED will be switched on.
[out] | aLedTimeOffMs | Time in milliseconds when the LED will be switched off.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetSystemTime | ( | ConstHGscAction | anAction,
 |  | TGLibDateTime & | aTimeStamp
 | ) |  |

Decode action 'Set system time'.

Set system time.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTimeStamp | Time stamp.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetTestPictureMode | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | bool & | aMode
 | ) |  |

Decode action 'Set test picture mode'.

Enable or disable test picture generator.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aMode | Enable or disable test picture generator.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetupChanged | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aUser,
 |  | const wchar_t *& | aHost,
 |  | TGLibDateTime & | aDate,
 |  | PlcResourceKind & | aResourceKind,
 |  | TPlcEventTypeID & | aResourceID,
 |  | PlcResourceChangeKind & | aChangeKind,
 |  | const wchar_t *& | aDetails,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'Setup changed'.

Setup changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aUser | Name of the user who modified the setup.
[out] | aHost | Host from where the connection was done.
[out] | aDate | Current time.
[out] | aResourceKind | Modified resource kind.
[out] | aResourceID | Modified resource ID.
[out] | aChangeKind | Change kind.
[out] | aDetails | Details of the modification.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDetails. aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetupUploadProgress | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aUser1,
 |  | const wchar_t *& | aUser2,
 |  | const wchar_t *& | aHost,
 |  | __int32 & | aProgress,
 |  | TGLibDateTime & | aDate
 | ) |  |

Decode action 'Setup upload progress'.

Setup upload progress.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aUser1 | Name of the user who modified the setup.
[out] | aUser2 | Name of the second user by four eyes authentication.
[out] | aHost | Host from where the connection was done.
[out] | aProgress | Progress in percent.
[out] | aDate | Current stage time.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aUser1. aUser2. aHost.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSetWatchdog | ( | ConstHGscAction | anAction,
 |  | __int32 & | aTimeout
 | ) |  |

Decode action 'Set watchdog'.

Set watchdog.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTimeout | Timeout in seconds, before the watchdog must be retriggered and before the hardware watchdog will set the hardware contact.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSkidataControl | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceName,
 |  | PlcSkidataControl & | aData
 | ) |  |

Decode action 'SKIDATA control'.

SKIDATA control information.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceName | Interface name.
[out] | aData | Interface state.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSkidataDeviceEvent | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceName,
 |  | __int32 & | aDeviceID,
 |  | __int32 & | aEventCode
 | ) |  |

Decode action 'SKIDATA device event'.

SKIDATA device event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceName | Interface name.
[out] | aDeviceID | Device ID.
[out] | aEventCode | Event code.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSkidataEntry | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceName,
 |  | PlcSkidataMsgCodeEntry & | aMessageCode,
 |  | const wchar_t *& | aTranscactionID,
 |  | __int32 & | aCarParkNo,
 |  | __int32 & | aDeviceID
 | ) |  |

Decode action 'SKIDATA entry'.

SKIDATA entry.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceName | Interface name.
[out] | aMessageCode | Message code.
[out] | aTranscactionID | Transcaction ID.
[out] | aCarParkNo | Car park no.
[out] | aDeviceID | Device ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSkidataExit | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceName,
 |  | PlcSkidataMsgCodeExit & | aMessageCode,
 |  | const wchar_t *& | aTranscactionID,
 |  | __int32 & | aCarParkNo,
 |  | __int32 & | aDeviceID
 | ) |  |

Decode action 'SKIDATA exit'.

SKIDATA exit.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceName | Interface name.
[out] | aMessageCode | Message code.
[out] | aTranscactionID | Transcaction ID.
[out] | aCarParkNo | Car park no.
[out] | aDeviceID | Device ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSkidataTransaction | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aInterfaceName,
 |  | PlcSkidataMsgCodeTransaction & | aMessageCode,
 |  | const wchar_t *& | aTranscactionID,
 |  | __int32 & | aCarParkNo,
 |  | __int32 & | aDeviceID
 | ) |  |

Decode action 'SKIDATA transaction'.

SKIDATA transaction.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInterfaceName | Interface name.
[out] | aMessageCode | Message code.
[out] | aTranscactionID | Transcaction ID.
[out] | aCarParkNo | Car park no.
[out] | aDeviceID | Device ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSMRPViewerCleared ( ConstHGscAction anAction )

Decode action 'SMRP viewer cleared'.

SMRP viewer cleared.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSMRPViewerConnected | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aServer,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'SMRP viewer connected'.

SMRP viewer connected to the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aServer | Server name.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSMTPMailSend | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aSubject,
 |  | const wchar_t *& | aTo,
 |  | const wchar_t *& | aCc,
 |  | const wchar_t *& | aBody,
 |  | const TPlcMediaChannelID *& | aChannel
 | ) |  |

Decode action 'SMTP mail'.

This action will send a user defined email if GSCMail is connected

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSubject | Mail subject.
[out] | aTo | Mail recipients.
[out] | aCc | Carbon copy recipients.
[out] | aBody | Mail body.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aChannel.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStartAutoBackup | ( | ConstHGscAction | anAction,
 |  | TPlcResourceID & | aSchedule
 | ) |  |

Decode action 'Start auto backup'.

Start auto backup.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSchedule | Schedule.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStartEventEx | ( | ConstHGscAction | anAction,
 |  | TPlcEventTypeID & | aTypeID,
 |  | const __int64 *& | aForeignKey
 | ) |  |

Decode action 'Start event'.

Start event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTypeID | Type of the event.
[out] | aForeignKey | Optional foreign key used to store with alarm.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aForeignKey.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStartRemoteExport | ( | ConstHGscAction | anAction,
 |  | GUID & | aExportID,
 |  | GUID & | aDevice,
 |  | PlcBackupFormat & | aBackupFormat,
 |  | TPlcMediaChannelID & | aChannel,
 |  | TGLibDateTime & | aSelectionBegin,
 |  | TGLibDateTime & | aSelectionEnd,
 |  | const wchar_t *& | aJobID
 | ) |  |

Decode action 'Start remote export'.

Start remote export.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aExportID | Export GUID.
[out] | aDevice | Pilot device GUID.
[out] | aBackupFormat | Backup format.
[out] | aChannel | Channel.
[out] | aSelectionBegin | Start time.
[out] | aSelectionEnd | End time.
[out] | aJobID | Job ID.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStartSceneStore | ( | ConstHGscAction | anAction,
 |  | GUID & | aSceneStoreID,
 |  | const wchar_t *& | aCutList,
 |  | __int64 & | aPreHistoryLength,
 |  | __int64 & | aRecordingLength
 | ) |  |

Decode action 'Start scene store'.

Start scene store.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSceneStoreID | Scene store GUID.
[out] | aCutList | Cut-list.
[out] | aPreHistoryLength | Pre-history length.
[out] | aRecordingLength | Recording length.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStopAllEvents ( ConstHGscAction anAction )

Decode action 'Stop all events'.

Stop all active events.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStopEvent | ( | ConstHGscAction | anAction,
 |  | TPlcEventTypeID & | aTypeID
 | ) |  |

Decode action 'Stop event'.

Stop event.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTypeID | Type of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStopEventByID | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID
 | ) |  |

Decode action 'Stop event by instance'.

Stop event by instance ID.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSystemError | ( | ConstHGscAction | anAction,
 |  | PlcMessageSource & | aSource,
 |  | PlcMessageCode & | aMessage,
 |  | const __int32 *& | aWindowsError,
 |  | const wchar_t *& | aDescription,
 |  | const char *& | aXMLInfo
 | ) |  |

Decode action 'System error'.

Notify system error.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSource | Source of the message.
[out] | aMessage | Kind of the message.
[out] | aWindowsError | Optional Windows error code.
[out] | aDescription | Optional description of the message.
[out] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aWindowsError. aDescription. aXMLInfo.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSystemInfo | ( | ConstHGscAction | anAction,
 |  | PlcMessageSource & | aSource,
 |  | PlcMessageCode & | aMessage,
 |  | const wchar_t *& | aDescription,
 |  | const char *& | aXMLInfo
 | ) |  |

Decode action 'System info'.

Notify system information.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSource | Source of the message.
[out] | aMessage | Kind of the message.
[out] | aDescription | Optional description of the message.
[out] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aDescription. aXMLInfo.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSystemSettingsChanged | ( | ConstHGscAction | anAction,
 |  | bool & | aSetupChanged,
 |  | const wchar_t *& | aUser1,
 |  | const wchar_t *& | aUser2,
 |  | const wchar_t *& | aHost,
 |  | bool & | aTimeRangeChanged,
 |  | const TPlcResourceID *& | aTimeRange,
 |  | bool & | aLicenceChanged,
 |  | TGLibDateTime & | aDate
 | ) |  |

Decode action 'System settings changed'.

Setup of the system and/or the current time range changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSetupChanged | System setup has changed.
[out] | aUser1 | Name of the user who modified the setup.
[out] | aUser2 | Name of the second user by four eyes authentication.
[out] | aHost | Host from where the connection was done.
[out] | aTimeRangeChanged | Time range has changed.
[out] | aTimeRange | Currently active time range.
[out] | aLicenceChanged | Licence has changed.
[out] | aDate | Time of the system settings changed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aUser1. aUser2. aHost. aTimeRange.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSystemStarted | ( | ConstHGscAction | anAction,
 |  | TGLibDateTime & | aDate
 | ) |  |

Decode action 'System started'.

This action will be fired only once at the system start-up.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aDate | Time of the system start-up.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSystemTerminating | ( | ConstHGscAction | anAction,
 |  | TGLibDateTime & | aDate,
 |  | bool & | aWindowsShutdown
 | ) |  |

Decode action 'System terminating'.

This action will be fired when the system is going to be shut down.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aDate | Time of the system shutdown.
[out] | aWindowsShutdown | Indicates whether the system shutdown is done due to the windows shutdown.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSystemWarning | ( | ConstHGscAction | anAction,
 |  | PlcMessageSource & | aSource,
 |  | PlcMessageCode & | aMessage,
 |  | const __int32 *& | aWindowsError,
 |  | const wchar_t *& | aDescription,
 |  | const char *& | aXMLInfo
 | ) |  |

Decode action 'System warning'.

Notify system warning.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSource | Source of the message.
[out] | aMessage | Kind of the message.
[out] | aWindowsError | Optional Windows error code.
[out] | aDescription | Optional description of the message.
[out] | aXMLInfo | Optional additional info (usually as XML string).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aWindowsError. aDescription. aXMLInfo.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTemperature | ( | ConstHGscAction | anAction,
 |  | IODeviceType & | aSourceType,
 |  | const wchar_t *& | aID,
 |  | __int32 & | aTemperature
 | ) |  |

Decode action 'Temperature notification'.

Temperature notification from a/ab USB Alarm-I/O.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aSourceType | Type of the device, which has fired the action.
[out] | aID | ID of the IO module (like IOI43-00/MIO84-00/MIO168-00).
[out] | aTemperature | Temperature.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTerminalArticleData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aTerminalName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | __int32 & | aCashierStation,
 |  | const __int32 *& | aPumpNo,
 |  | bool & | aAlarmStatus,
 |  | const double *& | aAmount,
 |  | const double *& | aPrice,
 |  | const wchar_t *& | aDetails
 | ) |  |

Decode action 'Terminal article data'.

Terminal article data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTerminalName | Terminal name.
[out] | aTimeStamp | Time stamp.
[out] | aCashierStation | Cashier station.
[out] | aPumpNo | Pump no.
[out] | aAlarmStatus | Alarm status.
[out] | aAmount | Amount.
[out] | aPrice | Price.
[out] | aDetails | Details.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aPumpNo. aAmount. aPrice. aDetails.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTerminalPaymentData | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aTerminalName,
 |  | TGLibDateTime & | aTimeStamp,
 |  | __int32 & | aCashierStation,
 |  | const __int32 *& | aPumpNo,
 |  | bool & | aAlarmStatus,
 |  | const double *& | aAmount,
 |  | const double *& | aPrice,
 |  | const wchar_t *& | aDetails
 | ) |  |

Decode action 'Terminal payment data'.

Terminal payment data.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTerminalName | Terminal name.
[out] | aTimeStamp | Time stamp.
[out] | aCashierStation | Cashier station.
[out] | aPumpNo | Pump no.
[out] | aAlarmStatus | Alarm status.
[out] | aAmount | Amount.
[out] | aPrice | Price.
[out] | aDetails | Details.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aPumpNo. aAmount. aPrice. aDetails.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTiltDown | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Tilt down'.

Tilt camera down.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Tilt speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTiltStop | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Tilt stop'.

Stop tilt movement.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTiltUp | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Tilt up'.

Tilt camera up.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Tilt speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTransferBinaryBuffer | ( | ConstHGscAction | anAction,
 |  | GUID & | aInternalHandle,
 |  | const wchar_t *& | aParameter
 | ) |  |

Decode action 'Transfer binary buffer'.

Transfer binary buffer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aInternalHandle | Internal handle.
[out] | aParameter | Parameter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeTransferBinaryChannelBuffer | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | GUID & | aInternalHandle,
 |  | const wchar_t *& | aParameter
 | ) |  |

Decode action 'Transfer binary channel buffer'.

Transfer binary channel buffer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aInternalHandle | Internal handle.
[out] | aParameter | Parameter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeUserLogin | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aUser1,
 |  | const wchar_t *& | aUser2,
 |  | const wchar_t *& | aHost,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'User login'.

This action will be fired when the user has connected to the system.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aUser1 | Name of the user connected to the system.
[out] | aUser2 | Name of the second user by four eyes authentication.
[out] | aHost | Host from where the connection is done.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aUser2. aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeUserLoginFailed | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aUser1,
 |  | const wchar_t *& | aUser2,
 |  | const wchar_t *& | aHost,
 |  | UserLoginFailureCode & | aRejectReason,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'User login failed'.

This action will be fired when the user has tried to connect to the system but was rejected.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aUser1 | Name of the user who tried to connect to the system.
[out] | aUser2 | Name of the second user by four eyes authentication.
[out] | aHost | Host from where the connection is done.
[out] | aRejectReason | Reason of the rejection.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aUser2. aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeUserLogout | ( | ConstHGscAction | anAction,
 |  | const wchar_t *& | aUser1,
 |  | const wchar_t *& | aUser2,
 |  | const wchar_t *& | aHost,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'User logout'.

This action will be fired when the user has disconnected from the system.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aUser1 | Name of the user disconnected from the system.
[out] | aUser2 | Name of the second user by four eyes authentication.
[out] | aHost | Host from where the connection was done.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aUser2. aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueConfirm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | PlcViewerAlarmQueueSelection & | aSelectionMode
 | ) |  |

Decode action 'VC alarm queue confirm'.

Confirm alarm from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aSelectionMode | Selection mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueConfirmByInstance | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | __int64 & | aAlarmID
 | ) |  |

Decode action 'VC alarm queue confirm by instance'.

Confirm alarm from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aAlarmID | Instance ID of the alarm.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueConfirmByType | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcEventTypeID & | aTypeID,
 |  | PlcViewerAlarmQueueSelection & | aSelectionMode
 | ) |  |

Decode action 'VC alarm queue confirm by type'.

Confirm alarm of specific type from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aTypeID | Type of the event.
[out] | aSelectionMode | Selection mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueNotification | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | PlcViewerAlarmState & | aNotification,
 |  | __int64 & | aAlarmID,
 |  | TPlcEventTypeID & | aTypeID,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'VC alarm queue notification'.

Alarm queue notification on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aNotification | Alarm state notification.
[out] | aAlarmID | Instance ID of the alarm.
[out] | aTypeID | Type of the event.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueRemove | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | PlcViewerAlarmQueueSelection & | aSelectionMode
 | ) |  |

Decode action 'VC alarm queue remove'.

Remove alarm from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aSelectionMode | Selection mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueRemoveByInstance | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | __int64 & | aAlarmID
 | ) |  |

Decode action 'VC alarm queue remove by instance'.

Remove alarm from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aAlarmID | Instance ID of the alarm.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueRemoveByType | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcEventTypeID & | aTypeID,
 |  | PlcViewerAlarmQueueSelection & | aSelectionMode
 | ) |  |

Decode action 'VC alarm queue remove by type'.

Remove alarm of specific type from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aTypeID | Type of the event.
[out] | aSelectionMode | Selection mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueSelect | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | PlcViewerAlarmQueueSelection & | aSelectionMode
 | ) |  |

Decode action 'VC alarm queue select'.

Select alarm from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aSelectionMode | Selection mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueSelectByInstance | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | __int64 & | aAlarmID
 | ) |  |

Decode action 'VC alarm queue select by instance'.

Select alarm from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aAlarmID | Instance ID of the alarm.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAlarmQueueSelectByType | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcEventTypeID & | aTypeID,
 |  | PlcViewerAlarmQueueSelection & | aSelectionMode
 | ) |  |

Decode action 'VC alarm queue select by type'.

Select alarm of specific type from the queue on the viewer client.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aTypeID | Type of the event.
[out] | aSelectionMode | Selection mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCASetArmed | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | bool & | aArmed
 | ) |  |

Decode action 'VCA set armed'.

Send this action to notify VCA to be armed or disarmed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aArmed | Armed (true) or disarmed (false)
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAStatusAnswer | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | bool & | aArmed
 | ) |  |

Decode action 'VCA status answer'.

This action will be sent in response to VCA status request.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aArmed | Armed (true) or disarmed (false)
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCAStatusRequest | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType
 | ) |  |

Decode action 'VCA status request'.

Send this action to request status of VCA. As response VCA will send VCA status answer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCChangeSceneByName | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | const wchar_t *& | aScene
 | ) |  |

Decode action 'VC change scene by name'.

Viewer client change scene by name.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aScene | Scene name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCClearSceneByName | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | const wchar_t *& | aScene
 | ) |  |

Decode action 'VC clear scene by name'.

Viewer client clear scene by name.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aScene | Scene name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCFullMode | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | bool & | aFullMode,
 |  | bool & | aSensitiveAreaEnabled
 | ) |  |

Decode action 'VC full mode'.

Viewer client full mode.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aFullMode | Switch viewer client in full mode.
[out] | aSensitiveAreaEnabled | Sensitive area enabled.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCSceneChanged | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | const wchar_t *& | aScene
 | ) |  |

Decode action 'VC scene changed'.

Viewer client scene changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aScene | Scene name.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCSetAudioLevel | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | __int32 & | aAudioLevel
 | ) |  |

Decode action 'VC set audio level'.

Viewer client set audio level.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aAudioLevel | Audio level in range 0 (audio off) till 100 (max. volume).
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCShowViewerText | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | bool & | aShowText
 | ) |  |

Decode action 'VC show viewer text'.

Viewer client show viewer text.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aShowText | Show text in viewer client.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVCStretchMode | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | bool & | aStretchMode
 | ) |  |

Decode action 'VC stretch mode'.

Viewer client stretch mode.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aStretchMode | Switch viewer client in stretch mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoContrastDetected | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'Video contrast detected'.

This action will be fired when the contrast is detected in the video signal.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoContrastFailed | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'Video contrast failed'.

This action will be fired when the contrast is lost in the video signal.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoSetImageBrightness | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | __int32 & | aBrightness
 | ) |  |

Decode action 'Video set image brightness'.

Video set image brightness.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aBrightness | Brightness.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoSetImageContrast | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | __int32 & | aContrast
 | ) |  |

Decode action 'Video set image contrast'.

Video set image contrast.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aContrast | Contrast.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoSetImageSaturation | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | __int32 & | aSaturation
 | ) |  |

Decode action 'Video set image saturation'.

Video set image saturation.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aSaturation | Saturation.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoSourceChanged | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSignalNorm & | aSignalNorm,
 |  | VideoSignalType & | aSignalType,
 |  | VideoInterlaceType & | aInterlaceType
 | ) |  |

Decode action 'Video source has changed'.

This action indicates the changes on the video input source.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSignalNorm | New signal norm.
[out] | aSignalType | New signal type.
[out] | aInterlaceType | New interlace type.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoSyncDetected | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'Video sync detected'.

This action will be fired when the sync is detected in the video signal.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeVideoSyncFailed | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'Video sync failed'.

This action will be fired when the sync is lost in the video signal.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerChangeScene | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer
 | ) |  |

Decode action 'Viewer change scene'.

Viewer change scene.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerClear | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer
 | ) |  |

Decode action 'Viewer clear'.

Clear viewer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerCleared | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'Viewer cleared'.

Viewer cleared.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerClearScene | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer
 | ) |  |

Decode action 'Viewer clear scene'.

Viewer clear scene.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerClearTextOutput | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer
 | ) |  |

Decode action 'Viewer clear text output'.

Clear text output in the given viewer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerConnect | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcViewerPlayMode & | aPlayMode
 | ) |  |

Decode action 'Viewer connect'.

Connect camera to the viewer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aChannel | Channel.
[out] | aPlayMode | Viewer play mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerConnected | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcViewerPlayMode & | aPlayMode,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'Viewer connected'.

Viewer connected to the camera.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aChannel | Channel.
[out] | aPlayMode | Viewer play mode.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerConnectLive | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcMediaChannelID & | aChannel
 | ) |  |

Decode action 'Viewer connect live'.

Connect live camera to the viewer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aChannel | Channel.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerExportPicture | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | const wchar_t *& | aFilePath
 | ) |  |

Decode action 'Viewer export picture'.

Viewer export picture.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aFilePath | File path (local or UNC). GSCView default path is used if left empty.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerJumpByTime | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcViewerPlayMode & | aPlayMode,
 |  | __int32 & | aTimeInSec
 | ) |  |

Decode action 'Viewer jump by time'.

Viewer jump by time.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aChannel | Channel.
[out] | aPlayMode | Viewer play mode.
[out] | aTimeInSec | Time to jump in seconds. Use negative values to jump in past.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerMaximize | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | bool & | aMaximize
 | ) |  |

Decode action 'Viewer maximize'.

Viewer maximize.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aMaximize | Maximize.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerPlayFromTime | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcViewerPlayMode & | aPlayMode,
 |  | TGLibDateTime & | aTime
 | ) |  |

Decode action 'Viewer play from time'.

Viewer play from time.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aChannel | Channel.
[out] | aPlayMode | Viewer play mode.
[out] | aTime | Time to play from.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerPlayModeChanged | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcViewerPlayMode & | aPlayMode,
 |  | const TGLibDateTime *& | aChannelTime,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'Viewer play mode changed'.

Viewer play mode changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aChannel | Channel.
[out] | aPlayMode | Viewer play mode.
[out] | aChannelTime | Channel time.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aChannelTime. aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerPrintPicture | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer
 | ) |  |

Decode action 'Viewer print picture'.

Viewer print picture.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerSelect | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer
 | ) |  |

Decode action 'Viewer select'.

Select viewer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerSelectionChanged | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcMediaChannelID & | aChannel,
 |  | PlcViewerPlayMode & | aPlayMode,
 |  | const wchar_t *& | aClientHost,
 |  | const PlcClientType *& | aClientType,
 |  | const wchar_t *& | aClientAccount
 | ) |  |

Decode action 'Viewer selection changed'.

Viewer selection was changed.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aChannel | Channel.
[out] | aPlayMode | Viewer play mode.
[out] | aClientHost | Host from where the connection is done.
[out] | aClientType | Client type.
[out] | aClientAccount | User account from where the connection is done.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aClientHost. aClientType. aClientAccount.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerSetPlayMode | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | PlcViewerPlayMode & | aPlayMode,
 |  | __int32 & | aPlaySpeed
 | ) |  |

Decode action 'Viewer set play mode'.

Set play mode of the viewer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aPlayMode | Viewer play mode.
[out] | aPlaySpeed | Optional play speed parameter.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerShowAlarmByInstance | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | __int64 & | aAlarmID,
 |  | PlcViewerAlarmPlayMode & | aPlayMode
 | ) |  |

Decode action 'Viewer show alarm by instance'.

Show alarm in viewer using alarm instance ID.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aAlarmID | Instance ID of the alarm.
[out] | aPlayMode | Viewer alarm's play mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerShowAlarmByKey | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | __int64 & | aForeignKey,
 |  | PlcViewerAlarmPlayMode & | aPlayMode
 | ) |  |

Decode action 'Viewer show alarm by key'.

Show alarm in viewer using alarm foreign key.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aForeignKey | Foreign key used to start the alarm.
[out] | aPlayMode | Viewer alarm's play mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerShowAlarmByType | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | TPlcEventTypeID & | aTypeID,
 |  | const __int64 *& | aForeignKey,
 |  | PlcViewerAlarmPlayMode & | aPlayMode
 | ) |  |

Decode action 'Viewer show alarm by type'.

Show alarm in viewer using alarm type and optional foreign key.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aTypeID | Type of the alarm.
[out] | aForeignKey | Foreign key used to start the alarm.
[out] | aPlayMode | Viewer alarm's play mode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
Warning:
Following parameters are optional: aForeignKey.
Values returned in these fields can be NULL pointers.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerSyncAudioAndVideo | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | bool & | aEnableSync
 | ) |  |

Decode action 'Viewer change sync audio/video'.

Viewer change sync audio/video.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aEnableSync | Enable audio/video sync.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeViewerTextOutput | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aViewer,
 |  | const wchar_t *& | aText
 | ) |  |

Decode action 'Viewer text output'.

Display free string in the given viewer.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aViewer | Global viewer or viewer client no.
[out] | aText | Text string to display.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeWatchdogActivate ( ConstHGscAction anAction )

Decode action 'Watchdog activate'.

Activate watchdog.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeWatchdogDeactivate ( ConstHGscAction anAction )

Decode action 'Watchdog deactivate'.

Deactivate watchdog.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeWatchdogTrigger ( ConstHGscAction anAction )

Decode action 'Watchdog trigger'.

Trigger watchdog.

Parameters:
[in] anAction Handle to action to decode.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeZoomIn | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Zoom in'.

Zoom camera in.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Zoom speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeZoomOut | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera,
 |  | __int32 & | aSpeed
 | ) |  |

Decode action 'Zoom out'.

Zoom camera out.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
[out] | aSpeed | Zoom speed.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeZoomStop | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aCamera
 | ) |  |

Decode action 'Zoom stop'.

Stop camera zoom.

Parameters:
[in] | anAction | Handle to action to decode.
[out] | aCamera | PTZ head.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeEventStarted | ( | ConstHGscAction | anAction,
 |  | __int64 & | aEventID,
 |  | TPlcEventTypeID & | aTypeID
 | ) |  |

Deprecated functions.

Decode action 'Event started'. Event has started.

This action is deprecated, use GscAct_DecodeEventStartedEx instead.
Parameters:
[in] | anAction | Handle to action to decode.
[out] | aEventID | Instance ID of the event.
[out] | aTypeID | Type of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSensorInhibitVideoAlarm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | const ADArea *& | aADArea,
 |  | const __int32 *& | aADCell,
 |  | const VMDGroup *& | aVMDGroup,
 |  | const __int32 *& | aVMDZone
 | ) |  |

Decode action 'Sensor inhibit video alarm'.

This action will be fired when the motion in inhibit area is detected.

This action is deprecated, use GscAct_DecodeSensorInhibitVideoAlarmEx instead.
Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aADArea | AD alarm area.
[out] | aADCell | AD cell nr.
[out] | aVMDGroup | VMD alarm group.
[out] | aVMDZone | VMD zone nr.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeSensorVideoAlarm | ( | ConstHGscAction | anAction,
 |  | TPlcMediaChannelID & | aChannel,
 |  | VideoSensorKind & | aSensorType,
 |  | const ADArea *& | aADArea,
 |  | const __int32 *& | aADCell,
 |  | const VMDGroup *& | aVMDGroup,
 |  | const __int32 *& | aVMDZone
 | ) |  |

Decode action 'Sensor video alarm'.

This action will be fired when video alarm is detected.

This action is deprecated, use GscAct_DecodeSensorVideoAlarmEx instead.
Parameters:
[in] | anAction | Handle to action to decode.
[out] | aChannel | Channel.
[out] | aSensorType | Sensor type.
[out] | aADArea | AD alarm area.
[out] | aADCell | AD cell nr.
[out] | aVMDGroup | VMD alarm group.
[out] | aVMDZone | VMD zone nr.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.
GSCACTDLLCALL bool __stdcall GscAct_DecodeStartEvent | ( | ConstHGscAction | anAction,
 |  | TPlcEventTypeID & | aTypeID
 | ) |  |

Decode action 'Start event'.

Start event.

This action is deprecated, use GscAct_DecodeStartEventEx instead.
Parameters:
[in] | anAction | Handle to action to decode.
[out] | aTypeID | Type of the event.
Returns:
true if the function succeeds, false otherwise. To get extended error information, call GscAct_GetLastError.


GSC actions: Enumeration

Modules

Enumeration

Collaboration diagram for Enumeration:

Detailed Description

Basic functions to enumerate action's info.

All structures supported by GscActions.dll can be enumerated by by the client, i.e. you can get information about all action classes, actions or used enumeration values. This information contains the following:

  • numeric values like action code or action class.
  • internal names as ANSI and UNICODE strings (e.g. "UserLogin").
  • translated (or plain) names as ANSI, UTF8-encoded, and UNICODE strings (e.g. "User login").
    Use it to present information to the user in readable form.
  • long description also as ANSI, UTF8-encoded, and UNICODE strings (e.g. "This action will be fired when the user has connected to the system.").
    Use it as hint to explain user what it is good for.

In this section we describe the low level functional interface.

Attention:
Translated names are available only if GscActionsDlgs.dll is used! In this case you can also use the collection of classes to simplify the process of enumeration. This information can be found in section Enumeration classes.

Modules

Basic enumeration

// end of group GscPlcEvents

Enumerate action classes

Enumerate functions for action classes.

Enumerate actions

Enumerate functions for actions.

Enumerate action parameters

Enumerate functions for action parameters.

Enumerate enum values

Enumerate functions for enum values.

Access by name

Access by name.


GSC actions: Basic enumeration

Classes | Functions | Variables

Basic enumeration
[Enumeration]

Collaboration diagram for Basic enumeration:

Detailed Description

// end of group GscPlcEvents

Basic types for enumerations

Classes

struct | TGscActionClassInfo
action class info More...
struct | TGscActionClassPlainInfo
action class plain info More...
struct | TGscActionInfo
action info More...
struct | TGscActionPlainInfo
action plain info More...
struct | TGscParameterInfo
parameter info More...
struct | TGscParameterPlainInfo
parameter plain info More...
struct | TGscEnumInfo
enum value info More...
struct | TGscEnumPlainInfo
enum value plain info More...

Functions

bool | IsGscEnumType (GscParameterType ParameterType)
Check the parameter type is an enumerable type.

Variables

const unsigned __int32 | PLC_DISABLE_ON_MATCH = 1
setup visibility mask
const unsigned __int32 | PLC_DISABLE_MATCH_BY = 2
setup visibility mask

Function Documentation

bool IsGscEnumType ( GscParameterType ParameterType ) [inline]

Check the parameter type is an enumerable type.

These types have text representation for values.

Parameters:
[in] ParameterType enumeration value of parameter type.
Returns:
true for enumeration type and false otherwise.

Definition at line 1768 of file GscActionsTypes.h.

Variable Documentation

const unsigned __int32 PLC_DISABLE_ON_MATCH = 1

setup visibility mask

Definition at line 1861 of file GscActionsTypes.h.

const unsigned __int32 PLC_DISABLE_MATCH_BY = 2

setup visibility mask

Definition at line 1863 of file GscActionsTypes.h.


GSC actions: Enumerate action classes

Functions

Enumerate action classes
[Enumeration]

Collaboration diagram for Enumerate action classes:

Detailed Description

Enumerate functions for action classes.

Functions

GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfActionClasses ()
Get number of action classes.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateActionClasses (TGscActionClassPlainInfo List[], unsigned int Count)
Get the list of action classes.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionClassInfo (TGscActionClassPlainInfo &Info, GscActionClass ActionClass)
Get the action class info.
GSCACTDLLCALL bool __stdcall | GscAct_SetActionClassPlainInfo (const TGscActionClassPlainInfo &Info)
Set the plain part of action class info.

Function Documentation

GSCACTDLLCALL unsigned int __stdcall GscAct_GetNumberOfActionClasses ( )

Get number of action classes.

Returns:
number of action classes
GSCACTDLLCALL unsigned int __stdcall GscAct_EnumerateActionClasses | ( | TGscActionClassPlainInfo | List[],
 |  | unsigned int | Count
 | ) |  |

Get the list of action classes.

Required place can be queried with GscAct_GetNumberOfActionClasses.

Parameters:
[out] | List | Retrieves infos. Should be allocated by client.
[in] | Count | Size of the List in elements.
Returns:
number of copied elements.
GSCACTDLLCALL bool __stdcall GscAct_GetActionClassInfo | ( | TGscActionClassPlainInfo & | Info,
 |  | GscActionClass | ActionClass
 | ) |  |

Get the action class info.

Parameters:
[out] | Info | Reference to info structure.
[in] | ActionClass | Which class is requested.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetActionClassPlainInfo ( const TGscActionClassPlainInfo & Info )

Set the plain part of action class info.

Only ActionClass, PlainNameW, and DescriptionW fields of the struct are used.

Parameters:
[in] Info Const reference to info structure.
Returns:
true if succeeds, false otherwise.


GSC actions: Enumerate actions

Functions

Enumerate actions
[Enumeration]

Collaboration diagram for Enumerate actions:

Detailed Description

Enumerate functions for actions.

Functions

GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfActions ()
Get number of actions.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateActions (TGscActionPlainInfo List[], unsigned int Count)
Get the list of actions.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionInfo (TGscActionPlainInfo &Info, GscActionCode ActionCode)
Get the action info.
GSCACTDLLCALL bool __stdcall | GscAct_SetActionPlainInfo (const TGscActionPlainInfo &Info)
Set the plain part of action info.

Function Documentation

GSCACTDLLCALL unsigned int __stdcall GscAct_GetNumberOfActions ( )

Get number of actions.

Returns:
number of actions
GSCACTDLLCALL unsigned int __stdcall GscAct_EnumerateActions | ( | TGscActionPlainInfo | List[],
 |  | unsigned int | Count
 | ) |  |

Get the list of actions.

Required place can be queried with GscAct_GetNumberOfActions.

Parameters:
[out] | List | Retrieves infos. Should be allocated by client.
[in] | Count | Size of the List in elements.
Returns:
number of copied elements.
GSCACTDLLCALL bool __stdcall GscAct_GetActionInfo | ( | TGscActionPlainInfo & | Info,
 |  | GscActionCode | ActionCode
 | ) |  |

Get the action info.

Parameters:
[out] | Info | Reference to info structure.
[in] | ActionCode | Which action is requested.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetActionPlainInfo ( const TGscActionPlainInfo & Info )

Set the plain part of action info.

Only ActionCode, PlainNameW, and DescriptionW fields of the struct are used.

Parameters:
[in] Info Const reference to info structure.
Returns:
true if succeeds, false otherwise.


GSC actions: Enumerate action parameters

Functions

Enumerate action parameters
[Enumeration]

Collaboration diagram for Enumerate action parameters:

Detailed Description

Enumerate functions for action parameters.

Functions

GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfActionParameters (GscActionCode ActionCode)
Get the number of parameters of the given action.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateActionParameters (TGscParameterPlainInfo List[], unsigned int Count, GscActionCode ActionCode)
Get the list of parameters.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionParameterInfo (TGscParameterPlainInfo &Info, GscActionCode ActionCode, unsigned int Index)
Get the parameter info.
GSCACTDLLCALL bool __stdcall | GscAct_SetActionParameterPlainInfo (const TGscParameterPlainInfo &Info, GscActionCode ActionCode, unsigned int Index)
Set the plain part of parameter info.
GSCACTDLLCALL bool __stdcall | GscAct_GetMatchActionDescriptionInfo (TGscParameterPlainInfo &Info)
Get the info about match action description.
GSCACTDLLCALL bool __stdcall | GscAct_SetMatchActionDescriptionPlainInfo (const TGscParameterPlainInfo &Info)
Set the plain part of match action description info.

Function Documentation

GSCACTDLLCALL unsigned int __stdcall GscAct_GetNumberOfActionParameters ( GscActionCode ActionCode )

Get the number of parameters of the given action.

Parameters:
[in] ActionCode Which action is requested.
Returns:
number of parameters of the given action. This value is the same as in the field NumberOfParameters in the action info.
GSCACTDLLCALL unsigned int __stdcall GscAct_EnumerateActionParameters | ( | TGscParameterPlainInfo | List[],
 |  | unsigned int | Count,
 |  | GscActionCode | ActionCode
 | ) |  |

Get the list of parameters.

Required place can be queried with GscAct_GetNumberOfActionParameters (ActionCode).

Parameters:
[out] | List | Retrieves infos. Should be allocated by client.
[in] | Count | Size of the List in elements.
[in] | ActionCode | Which action is requested.
Returns:
number of copied elements.
GSCACTDLLCALL bool __stdcall GscAct_GetActionParameterInfo | ( | TGscParameterPlainInfo & | Info,
 |  | GscActionCode | ActionCode,
 |  | unsigned int | Index
 | ) |  |

Get the parameter info.

Returns the Index-th parameter of the action provided by ActionCode.

Parameters:
[out] | Info | Reference to info structure.
[in] | ActionCode | Which action is requested.
[in] | Index | Index of parameter.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetActionParameterPlainInfo | ( | const TGscParameterPlainInfo & | Info,
 |  | GscActionCode | ActionCode,
 |  | unsigned int | Index
 | ) |  |

Set the plain part of parameter info.

Index-th parameter of the action provided by ActionCode is used. Only PlainNameW and DescriptionW fields of the struct are used.

Parameters:
[in] | Info | Reference to info structure.
[in] | ActionCode | Which action is requested.
[in] | Index | Index of parameter.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetMatchActionDescriptionInfo ( TGscParameterPlainInfo & Info )

Get the info about match action description.

Parameters:
[out] Info Reference to info structure.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetMatchActionDescriptionPlainInfo ( const TGscParameterPlainInfo & Info )

Set the plain part of match action description info.

Only PlainNameW and DescriptionW fields of the struct are used.

Parameters:
[in] Info Reference to info structure.
Returns:
true if succeeds, false otherwise.


GSC actions: Enumerate enum values

Functions

Enumerate enum values
[Enumeration]

Collaboration diagram for Enumerate enum values:

Detailed Description

Enumerate functions for enum values.

Functions

GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfEnumValues (GscParameterType EnumType)
Get the number of available values for enum type.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateEnumValues (TGscEnumPlainInfo List[], unsigned int Count, GscParameterType EnumType)
Get the list of enum values.
GSCACTDLLCALL bool __stdcall | GscAct_GetEnumValueInfo (TGscEnumPlainInfo &Info, GscParameterType EnumType, __int32 Value)
Get the enum info.
GSCACTDLLCALL bool __stdcall | GscAct_SetEnumValuePlainInfo (const TGscEnumPlainInfo &Info)
Set the plain part of the enum info.

Function Documentation

GSCACTDLLCALL unsigned int __stdcall GscAct_GetNumberOfEnumValues ( GscParameterType EnumType )

Get the number of available values for enum type.

Parameters:
[in] EnumType Which type is queried. Pass pt_Unknown to get the list of enum values for all enum types.
Returns:
number of elements.
GSCACTDLLCALL unsigned int __stdcall GscAct_EnumerateEnumValues | ( | TGscEnumPlainInfo | List[],
 |  | unsigned int | Count,
 |  | GscParameterType | EnumType
 | ) |  |

Get the list of enum values.

Required place can be queried with GscAct_GetNumberOfEnumValues (EnumType).

Parameters:
[out] | List | Retrieves infos. Should be allocated by client.
[in] | Count | Size of the List in elements.
[in] | EnumType | Which type is queried. Pass pt_Unknown to get the list of enum values for all enum types.
Returns:
number of copied elements.
GSCACTDLLCALL bool __stdcall GscAct_GetEnumValueInfo | ( | TGscEnumPlainInfo & | Info,
 |  | GscParameterType | EnumType,
 |  | __int32 | Value
 | ) |  |

Get the enum info.

Parameters:
[out] | Info | Reference to info structure.
[in] | EnumType | Which type is queried.
[in] | Value | Numeric value.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetEnumValuePlainInfo ( const TGscEnumPlainInfo & Info )

Set the plain part of the enum info.

Only PlainNameW and DescriptionW fields of the struct are used.

Parameters:
[in] Info Reference to info structure.
Returns:
true if succeeds, false otherwise.


GSC actions: Access by name

Defines | Functions

Access by name
[Enumeration]

Collaboration diagram for Access by name:

Detailed Description

Access by name.

Defines

#define | GscAct_GetActionClassByName GscAct_GetActionClassByNameA
#define | GscAct_GetActionCodeByName GscAct_GetActionCodeByNameA

Functions

GSCACTDLLCALL GscActionClass
__stdcall 		GscAct_GetActionClassByNameA (const char *Name)
Get action class by name.
GSCACTDLLCALL GscActionClass
__stdcall 		GscAct_GetActionClassByNameW (const wchar_t *Name)
Get action class by name.
GSCACTDLLCALL GscActionCode
__stdcall 		GscAct_GetActionCodeByNameA (const char *Name)
Get action code by name.
GSCACTDLLCALL GscActionCode
__stdcall 		GscAct_GetActionCodeByNameW (const wchar_t *Name)
Get action code by name.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetInternalIndexByCode (GscActionCode Code)
Get internal index by action code.
GSCACTDLLCALL GscActionCode
__stdcall 		GscAct_GetActionCodeByIndex (unsigned int Index)
Get action code by internal index.
GSCACTDLLCALL bool __stdcall | GscAct_GetNativeTranslation (bool &IsNativeTranslation)
Get native translation.
GSCACTDLLCALL bool __stdcall | GscAct_SetNativeTranslation (bool IsNativeTranslation)
Set native translation.

Define Documentation

#define GscAct_GetActionClassByName GscAct_GetActionClassByNameA

Definition at line 369 of file GscActions.h.

#define GscAct_GetActionCodeByName GscAct_GetActionCodeByNameA

Definition at line 370 of file GscActions.h.

Function Documentation

GSCACTDLLCALL GscActionClass __stdcall GscAct_GetActionClassByNameA ( const char * Name )

Get action class by name.

Parameters:
[in] Name Name of the class as ANSI string.
Returns:
action class if succeeds, ak_Unknown otherwise.
GSCACTDLLCALL GscActionClass __stdcall GscAct_GetActionClassByNameW ( const wchar_t * Name )

Get action class by name.

Parameters:
[in] Name Name of the class as UNICODE string.
Returns:
action class if succeeds, ak_Unknown otherwise.
GSCACTDLLCALL GscActionCode __stdcall GscAct_GetActionCodeByNameA ( const char * Name )

Get action code by name.

Parameters:
[in] Name Name of the action as ANSI string.
Returns:
action code if succeeds, ac_Unknown otherwise.
GSCACTDLLCALL GscActionCode __stdcall GscAct_GetActionCodeByNameW ( const wchar_t * Name )

Get action code by name.

Parameters:
[in] Name Name of the action as UNICODE string.
Returns:
action code if succeeds, ac_Unknown otherwise.
GSCACTDLLCALL unsigned int __stdcall GscAct_GetInternalIndexByCode ( GscActionCode Code )

Get internal index by action code.

Parameters:
[in] Code Action code.
Returns:
internal index if succeeds, 0x7FFFFFFF otherwise.
GSCACTDLLCALL GscActionCode __stdcall GscAct_GetActionCodeByIndex ( unsigned int Index )

Get action code by internal index.

Parameters:
[in] Index Internal index.
Returns:
action code if succeeds, ac_Unknown otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetNativeTranslation ( bool & IsNativeTranslation )

Get native translation.

Parameters:
[out] IsNativeTranslation Translation flag, true -> native, false -> english.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetNativeTranslation ( bool IsNativeTranslation )

Set native translation.

Parameters:
[in] IsNativeTranslation Translation flag, true -> native, false -> english.
Returns:
true if succeeds, false otherwise.


GSC actions: Dispatcher

Modules

Dispatcher

Collaboration diagram for Dispatcher:

Detailed Description

Dispatcher classes.

TODO

Modules

Using virtual functions

This dispatcher class allows you to implement your own derived dispatcher by overriding virtual functions.


GSC actions: Using virtual functions

Classes

Using virtual functions
[Dispatcher]

Collaboration diagram for Using virtual functions:

Detailed Description

This dispatcher class allows you to implement your own derived dispatcher by overriding virtual functions.

TODO

Classes

class GscActionsDispatcher


GSC actions: GscActionsDlgs.dll

Modules

GscActionsDlgs.dll

Collaboration diagram for GscActionsDlgs.dll:

Detailed Description

GscActionsDlgs.dll.

This DLL is designed for the following purposes:

  • Add internationalisation support to GscActions.dll. To activate it you need only to load GscActionsDlgs.dll. The loader automatically initialize all translation tables.
  • Add means to create action selection dialogs. This includes also one predefined dialog which can be used by the client application directly.

Modules

General definitions
Working with buffers
Conversion functions
Dialog functions

Functions to present action selection dialog.

Enumeration classes

Simplify enumeration.

Sources of built-in dialog

Sources of built-in dialog.


GSC actions: General definitions

General definitions
[GscActionsDlgs.dll]

Collaboration diagram for General definitions:


GSC actions: Working with buffers

Working with buffers
[GscActionsDlgs.dll]

Collaboration diagram for Working with buffers:


GSC actions: Conversion functions

Conversion functions
[GscActionsDlgs.dll]

Collaboration diagram for Conversion functions:


GSC actions: Dialog functions

Dialog functions
[GscActionsDlgs.dll]

Collaboration diagram for Dialog functions:

Functions to present action selection dialog.


GSC actions: Enumeration classes

Enumeration classes
[GscActionsDlgs.dll]

Collaboration diagram for Enumeration classes:

Simplify enumeration.

Add unit "GscActionsDlgsClass.cpp" to your project and include following lines in your code:

   #include "GscActionsDlgsClass.h"
   using namespace GscPLC;

Look the sources of the built-in dialog as an example how these classes can be used.


GSC actions: Sources of built-in dialog

Modules

Sources of built-in dialog
[GscActionsDlgs.dll]

Collaboration diagram for Sources of built-in dialog:

Detailed Description

Sources of built-in dialog.

Here you can find the sources of the dialog built in the GscActionsDlgs.dll. You will need Borland C++ Builder and Tnt UNICODE Controls to compile them.

Modules

GscActionsDialog.dfm

DFM file for built-in dialog.

GscActionsDialog.h

H file for built-in dialog.

GscActionsDialog.cpp

CPP file for built-in dialog.


GSC actions: GscActionsDialog.dfm

GscActionsDialog.dfm
[Sources of built-in dialog]

Collaboration diagram for GscActionsDialog.dfm:

DFM file for built-in dialog.

object GscActionsDlg: TGscActionsDlg
  Left = 0
  Top = 0
  Caption = 'Select GeViScope action'
  ClientHeight = 466
  ClientWidth = 592
  Color = clBtnFace
  Constraints.MinHeight = 300
  Constraints.MinWidth = 300
  DefaultMonitor = dmPrimary
  Font.Charset = DEFAULT_CHARSET
  Font.Color = clWindowText
  Font.Height = -11
  Font.Name = 'Tahoma'
  Font.Style = []
  OldCreateOrder = False
  Position = poMainFormCenter
  OnActivate = FormActivate
  OnCreate = FormCreate
  DesignSize = (
    592
    466)
  PixelsPerInch = 96
  TextHeight = 13
  object Panel1: TPanel
    Left = 0
    Top = 0
    Width = 592
    Height = 429
    Anchors = [akLeft, akTop, akRight, akBottom]
    BevelOuter = bvNone
    TabOrder = 0
    object Splitter1: TSplitter
      Left = 200
      Top = 0
      Height = 429
      AutoSnap = False
      Beveled = True
      MinSize = 50
    end
    object Panel2: TPanel
      Left = 0
      Top = 0
      Width = 200
      Height = 429
      Align = alLeft
      BevelOuter = bvNone
      TabOrder = 0
      DesignSize = (
        200
        429)
      object GroupBox1: TGroupBox
        Left = 0
        Top = 0
        Width = 200
        Height = 49
        Anchors = [akLeft, akTop, akRight]
        Caption = 'Category:'
        TabOrder = 0
        DesignSize = (
          200
          49)
        object CbCategory: TComboBox
          Left = 2
          Top = 16
          Width = 196
          Height = 21
          Style = csDropDownList
          Anchors = [akLeft, akTop, akRight, akBottom]
          ItemHeight = 13
          Sorted = True
          TabOrder = 0
          OnSelect = CbCategorySelect
          Items.Strings = (
            'All actions')
        end
      end
      object GroupBox2: TGroupBox
        Left = 0
        Top = 48
        Width = 200
        Height = 381
        Anchors = [akLeft, akTop, akRight, akBottom]
        Caption = 'Action:'
        TabOrder = 1
        DesignSize = (
          200
          381)
        object LvActions: TListView
          Left = 2
          Top = 16
          Width = 196
          Height = 362
          Anchors = [akLeft, akTop, akRight, akBottom]
          Columns = <
            item
              AutoSize = True
              Caption = 'Action name'
            end>
          HideSelection = False
          ReadOnly = True
          RowSelect = True
          ShowColumnHeaders = False
          SortType = stText
          TabOrder = 0
          ViewStyle = vsReport
          OnSelectItem = LvActionsSelectItem
        end
      end
    end
    object Panel3: TPanel
      Left = 203
      Top = 0
      Width = 389
      Height = 429
      Align = alClient
      BevelOuter = bvNone
      Constraints.MinWidth = 50
      TabOrder = 1
      OnResize = Panel3Resize
      DesignSize = (
        389
        429)
      object GbParameterInfo: TGroupBox
        Left = 0
        Top = 300
        Width = 389
        Height = 65
        Anchors = [akLeft, akRight, akBottom]
        Caption = 'Parameter info'
        TabOrder = 1
        DesignSize = (
          389
          65)
        object LbParamDescription: TStaticText
          Left = 8
          Top = 16
          Width = 369
          Height = 41
          Anchors = [akLeft, akTop, akRight, akBottom]
          AutoSize = False
          TabOrder = 0
        end
      end
      object GbActionDescription: TGroupBox
        Left = 0
        Top = 364
        Width = 389
        Height = 65
        Anchors = [akLeft, akRight, akBottom]
        Caption = 'Action description'
        TabOrder = 2
        DesignSize = (
          389
          65)
        object LbDescription: TStaticText
          Left = 8
          Top = 16
          Width = 377
          Height = 41
          Anchors = [akLeft, akTop, akRight, akBottom]
          AutoSize = False
          TabOrder = 0
        end
      end
      object VlParameters: TValueListEditor
        Left = 0
        Top = 0
        Width = 389
        Height = 294
        Anchors = [akLeft, akTop, akRight, akBottom]
        Strings.Strings = (
          'Comment=')
        TabOrder = 0
        TitleCaptions.Strings = (
          'Parameter'
          'Value (leave empty for default)')
        OnEditButtonClick = VlParametersEditButtonClick
        OnGetPickList = VlParametersGetPickList
        OnSelectCell = VlParametersSelectCell
        OnValidate = VlParametersValidate
        ColWidths = (
          150
          233)
      end
      object TntPanel1: TPanel
        Left = 32
        Top = 64
        Width = 185
        Height = 201
        TabOrder = 3
        Visible = False
        DesignSize = (
          185
          201)
        object LbStrParameter: TLabel
          Left = 8
          Top = 44
          Width = 50
          Height = 13
          Anchors = [akLeft, akBottom]
          Caption = 'Parameter'
          Visible = False
        end
        object LbStrDefaultValue: TLabel
          Left = 8
          Top = 28
          Width = 150
          Height = 13
          Anchors = [akLeft, akBottom]
          Caption = 'Value (leave empty for default)'
          Visible = False
        end
        object LbStrIsNotValid: TLabel
          Left = 56
          Top = 64
          Width = 115
          Height = 13
          Caption = 'is not valid for this field.'
        end
        object LbStrValue: TLabel
          Left = 8
          Top = 64
          Width = 26
          Height = 13
          Caption = 'Value'
        end
        object LbStrString: TLabel
          Left = 8
          Top = 80
          Width = 118
          Height = 13
          Caption = '" is not allowed in strings'
        end
        object LbStrTGLibDateTime: TLabel
          Left = 8
          Top = 96
          Width = 266
          Height = 13
          Caption = 'Use following format "yyyy/mm/dd hh:mm:ss,uuu BIAS"'
        end
        object LbStrAllowedValues: TLabel
          Left = 8
          Top = 112
          Width = 140
          Height = 13
          Caption = 'Following values are allowed:'
        end
        object LbStrUseContext: TLabel
          Left = 8
          Top = 128
          Width = 176
          Height = 13
          Caption = 'Use context menu to present this list'
        end
        object LbStrCurrentTime: TLabel
          Left = 9
          Top = 144
          Width = 58
          Height = 13
          Caption = 'current time'
        end
        object LbStrNullGuid: TLabel
          Left = 9
          Top = 160
          Width = 44
          Height = 13
          Caption = 'null GUID'
        end
      end
    end
  end
  object BtnCancel: TButton
    Left = 513
    Top = 436
    Width = 75
    Height = 25
    Anchors = [akRight, akBottom]
    Cancel = True
    Caption = '&Cancel'
    ModalResult = 2
    TabOrder = 2
  end
  object BtnOK: TButton
    Left = 417
    Top = 436
    Width = 75
    Height = 25
    Anchors = [akRight, akBottom]
    Caption = '&OK'
    Default = True
    ModalResult = 1
    TabOrder = 1
    OnClick = BtnOKClick
  end
end


GSC actions: GscActionsDialog.h

GscActionsDialog.h
[Sources of built-in dialog]

Collaboration diagram for GscActionsDialog.h:

H file for built-in dialog.

//---------------------------------------------------------------------------

#ifndef GscActionsDialogH
#define GscActionsDialogH
//---------------------------------------------------------------------------
#include <Classes.hpp>
#include <Controls.hpp>
#include <StdCtrls.hpp>
#include <Forms.hpp>
#include <ExtCtrls.hpp>
#include <ComCtrls.hpp>
#include <Grids.hpp>
#include <Menus.hpp>
//---------------------------------------------------------------------------

#include "GscActionsDlgsClass.h"
#include <ValEdit.hpp>

class TGscActionsDlg : public TForm
{
__published:    // IDE-verwaltete Komponenten
        TPanel *Panel1;
        TSplitter *Splitter1;
        TPanel *Panel2;
        TGroupBox *GroupBox1;
        TComboBox *CbCategory;
        TGroupBox *GroupBox2;
        TListView *LvActions;
        TPanel *Panel3;
        TGroupBox *GbParameterInfo;
        TStaticText *LbParamDescription;
        TGroupBox *GbActionDescription;
        TStaticText *LbDescription;
        TButton *BtnOK;
        TButton *BtnCancel;
        TPanel *TntPanel1;
        TLabel *LbStrParameter;
        TLabel *LbStrDefaultValue;
        TLabel *LbStrIsNotValid;
        TLabel *LbStrValue;
        TLabel *LbStrString;
        TLabel *LbStrTGLibDateTime;
        TLabel *LbStrAllowedValues;
        TLabel *LbStrUseContext;
        TLabel *LbStrCurrentTime;
        TLabel *LbStrNullGuid;
  TValueListEditor *VlParameters;
        void __fastcall FormCreate(TObject *Sender);
        void __fastcall FormActivate(TObject *Sender);
        void __fastcall CbCategorySelect(TObject *Sender);
        void __fastcall LvActionsSelectItem(TObject *Sender,
          TListItem *Item, bool Selected);
        void __fastcall BtnOKClick(TObject *Sender);
        void __fastcall Panel3Resize(TObject *Sender);
  void __fastcall VlParametersSelectCell(TObject *Sender, int ACol,
          int ARow, bool &CanSelect);
  void __fastcall VlParametersEditButtonClick(TObject *Sender);
  void __fastcall VlParametersGetPickList(TObject *Sender, const UnicodeString KeyName,
          TStrings *Values);
  void __fastcall VlParametersValidate(TObject *Sender, int ACol, int ARow, const UnicodeString KeyName,
          const UnicodeString KeyValue);

private:        // Benutzer Deklarationen
        friend class GscPLC::CGscActionDialog;
        GscPLC::TPlcActionClassInfoList   ActionClasses;  // staic info
        GscPLC::TPlcActionInfoList        Actions;        // staic info
        GscPLC::TPlcEnumValuesInfo        EnumValues;     // staic info

        UnicodeString           ParameterInfoString; // used to build GB label
        UnicodeString           ActionInfoString;    // used to build GB label

        UnicodeString           Description;     // description for all actions
        GscPLC::TPlcActionInfo* CurrentAction;   // currently selected action
        bool                    firstResizeCall; // first time in resize

        void __fastcall SelectAction();
        void __fastcall ClearParameterList();
        void __fastcall PrepareParameterList();
        void __fastcall ValidateInput(int ARow, bool OnExit)
          throw(Exception, GscPLC::TPlcConversionException);

        void InitializeItemProp(const GscPLC::TPlcParameterVariant& Variant, Valedit::TItemProp *ItemProp);
        void InitializePickList(const GscPLC::TPlcParameterVariant& Variant, TStrings *Values);
        void InitializeItemProp(const GscPLC::TPlcParameterInfo& Parameter, Valedit::TItemProp *ItemProp)
        {
          InitializeItemProp(Parameter.Value, ItemProp);
        }
        void InitializePickList(const GscPLC::TPlcParameterInfo& Parameter, TStrings *Values)
        {
          InitializePickList(Parameter.Value, Values);
        }

public:         // Benutzer Deklarationen
        __fastcall TGscActionsDlg(TComponent* Owner);
        bool inDestroy;
};

namespace GscPLC
{
  class CGscActionDialog {
    private:
      TGscActionsDlg* Dlg;

    public:
      CGscActionDialog(HWND Parent);
      ~CGscActionDialog();
      HGscMatchAction ShowModal(ConstHGscMatchAction Template = 0);
  };
};
//---------------------------------------------------------------------------
extern PACKAGE TGscActionsDlg *GscActionsDlg;
//---------------------------------------------------------------------------
#endif


GSC actions: GscActionsDialog.cpp

GscActionsDialog.cpp
[Sources of built-in dialog]

Collaboration diagram for GscActionsDialog.cpp:

CPP file for built-in dialog.

//---------------------------------------------------------------------------
#include "Precompiled.h"
#pragma hdrstop
//---------------------------------------------------------------------------

#include "GscActionsDialog.h"

#include "GLib\Text\StringTransform.h"
//---------------------------------------------------------------------------
//#pragma package(smart_init)
#pragma resource "*.dfm"
// TGscActionsDlg *GscActionsDlg;

using namespace GscPLC;

#pragma warn -8057 // Parameter 'parameter' is never used

//---------------------------------------------------------------------------
//---------------------------------------------------------------------------
void TGscActionsDlg::InitializeItemProp(const TPlcParameterVariant& Variant, Valedit::TItemProp *ItemProp)
{
  ItemProp->EditStyle = IsGscEnumType(Variant.ParameterType) ? esPickList : esSimple;
}
void TGscActionsDlg::InitializePickList(const TPlcParameterVariant& Variant, TStrings *Values)
{
  Values->Clear();

  switch (Variant.ParameterType)
  {
    case pt_TGLibDateTime:
      Values->Add(TGLibDateTime::Now().SQLDateTimeStrWithBiasW().c_str());
      break;

    case pt_GUID:
      Values->Add(L"00000000-0000-0000-0000-000000000000");
      break;

    case pt_widestring:
    case pt_string:
      if (Variant.ParameterView == pv_UserName)
        Values->Add(L"Sysadmin");
      break;

    default:
      if (IsGscEnumType(Variant.ParameterType))
      {
        ///
        /// enumerate all parameters
        for (TPlcEnumValuesInfo::TValueMap::const_iterator
          it  = EnumValues.Values.begin();
          it != EnumValues.Values.end();
          ++it)
        {
          if (it->first.first == Variant.ParameterType)
          {
            Values->Add(it->second.Short.c_str());
          }
        }
      }
  }
}
//---------------------------------------------------------------------------
//---------------------------------------------------------------------------
__fastcall TGscActionsDlg::TGscActionsDlg(TComponent* Owner)
        : TForm(Owner)
{
  CurrentAction   = 0;
  firstResizeCall = true;
  inDestroy       = false;

  /// ActionClass, Actions, and EnumValues get the complete list of infos
  /// from the GscActions.DLL in theirs ctors

  /// The first entry "all actions" is already in the list
  for (TPlcActionClassInfoList::iterator it = ActionClasses.begin();
    it != ActionClasses.end(); ++it)
  {
    CbCategory->AddItem(it->Desc.Short.c_str(),
          reinterpret_cast<TObject*>(&*it));
  }
  CbCategory->ItemIndex = 0;
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::FormCreate(TObject *Sender)
{
  /// remember the string
  ParameterInfoString = GbParameterInfo->Caption;
  ActionInfoString    = GbActionDescription->Caption;
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::FormActivate(TObject *Sender)
{
  Panel3Resize(0);
  CbCategorySelect(CbCategory);

  /// setup second row - description
  VlParameters->Cells[0][1] = Actions.Comment.Desc.Short.c_str();
  VlParameters->Cells[1][1] = Description;
  VlParameters->Col         = 1;
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::CbCategorySelect(TObject *Sender)
{
  LvActions->Items->BeginUpdate();
  LvActions->Clear();

    if (CbCategory->ItemIndex < 0)
      CbCategory->ItemIndex = 0;

    ///
    /// get the class info, can be NULL if "all actions" selected
    TPlcActionClassInfo* Class = reinterpret_cast<TPlcActionClassInfo*>(
      CbCategory->Items->Objects[CbCategory->ItemIndex]);

    ///
    /// Scan all actions with appropriate action class
    for (TPlcActionInfoList::iterator it = Actions.begin();
      it != Actions.end(); ++it)
    {
      if (    (Class == 0)
           || (Class->Class == ak_Unknown)
           || (Class->Class == it->Class) )
      {
        LvActions->AddItem( it->Desc.Short.c_str(),
                            reinterpret_cast<TObject*>(&*it));
      }
    }

    ActiveControl = LvActions;

  LvActions->Items->EndUpdate();
  LvActions->Invalidate();
  SelectAction();
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::SelectAction()
{
  ClearParameterList();

  ///
  /// is the current action in the list?
  int Idx = 0;
  if (CurrentAction)
  {
    for (int i = 0; i < LvActions->Items->Count; ++i)
    {
      if (LvActions->Items->Item[i]->Data == CurrentAction)
      {
        Idx = i;
        break;
      }
    }
  }

  ///
  /// select it
  if (LvActions->Items->Count)
  {
    LvActions->Items->Item[Idx]->Selected = true;
    LvActions->Items->Item[Idx]->MakeVisible(false);

    CurrentAction =
      reinterpret_cast<TPlcActionInfo*>(LvActions->Items->Item[Idx]->Data);
  }
  else
  {
    CurrentAction = 0;
  }
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::ClearParameterList()
{
  if (inDestroy) return;

  while (VlParameters->RowCount > 2)
    VlParameters->DeleteRow(2);
  VlParameters->Row = 1;

  LbParamDescription->Caption  = UnicodeString(L"");
  LbDescription->Caption       = UnicodeString(L"");
  GbParameterInfo->Caption     = ParameterInfoString + L":";
  GbActionDescription->Caption = ActionInfoString    + L":";
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::PrepareParameterList()
{
  if (inDestroy) return;

  ClearParameterList();
  if (!CurrentAction) return;

  int Idx = 1;
  for (std::vector<TPlcParameterInfo>::iterator
    it = CurrentAction->Parameters.begin();
    it != CurrentAction->Parameters.end();
    ++it, ++Idx)
  {
    /// insert row
    VlParameters->InsertRow(
      it->Desc.Short.c_str(),
      it->Used ? it->Value.GetValue(&EnumValues).c_str() : L"",
      true);

    InitializeItemProp(*it, VlParameters->ItemProps[Idx]);
  }

  /// change captions of group boxes
  GbActionDescription->Caption = ActionInfoString                 + L" [" +
                                 CurrentAction->Desc.Name.c_str() + L"]:";
  LbDescription->Caption       = CurrentAction->Desc.Long.c_str();

  /// fix parameter info
  bool CanSelect;
  VlParametersSelectCell(0, 1, 1, CanSelect);
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::LvActionsSelectItem(TObject *Sender,
      TListItem *Item, bool Selected)
{
  if (inDestroy) return;

  ///
  /// Select the current
  CurrentAction = Selected ? reinterpret_cast<TPlcActionInfo*>(Item->Data) : 0;
  PrepareParameterList();
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::BtnOKClick(TObject *Sender)
{
  if (!CurrentAction)
    ModalResult = mrNone;
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::VlParametersSelectCell(TObject *Sender,
      int ACol, int ARow, bool &CanSelect)
{
  if (inDestroy) return;

  ///
  /// Validate input, but only!!! if something else selected
  /// otherwise there can be two exception: first on exit and second on reselect
  if (ACol && VlParameters->Col && CurrentAction && (VlParameters->Row > 0))
  {
    if ((ACol != VlParameters->Col) || (ARow != VlParameters->Row))
      ValidateInput(VlParameters->Row, false);
  }

  ///
  /// setup parameter infos

  if (ACol)
  {
    ///
    /// comment field or description
    TPlcParameterInfo& Info = ((ARow > 1) && CurrentAction) ?
      (CurrentAction->Parameters)[ARow - 2]                 :
      Actions.Comment;

    LbParamDescription->Caption = Info.Desc.Long.c_str();
    GbParameterInfo->Caption    = ParameterInfoString    + L" [" +
                                  Info.Desc.Name.c_str() + L"]:";
  }
  else
  {
    CanSelect = false;
  }
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::ValidateInput(int ARow, bool OnExit)
throw(Exception, GscPLC::TPlcConversionException)
{
  try
  {
    std::wstring Value(GLib::SafeStr(VlParameters->Cells[1][ARow].c_str()));

    if (ARow == 1)
    {
      size_t Quote = Value.find(L'"');
      if (Quote != Value.npos)
      {
        ///
        /// raise exception
        throw TPlcConversionException(pt_widestring, Value);
      }
      Description = UnicodeString(Value.c_str());
    }

    if (CurrentAction && (ARow > 1))
    {
      TPlcParameterInfo& Info = (CurrentAction->Parameters)[ARow - 2];

      ///
      /// set value
      if (Value.length() > 0)
      {
        Info.Value.SetValue(Value, &EnumValues);
        if (!OnExit)
        {
          VlParameters->Cells[1][ARow] =
            Info.Value.GetValue(&EnumValues).c_str();
        }
        Info.Used = true;
      }
      else
      {
        Info.Used = false;
      }
    }
  }
  catch(const TPlcConversionException& Excp)
  {
    UnicodeString Line = LbStrValue->Caption
                    + L" '" + Excp.ErrorLine.c_str() + L"' "
                    + LbStrIsNotValid->Caption
                    + L"\n\n";

    switch (Excp.ParameterType)
    {
      case pt_string:
      case pt_widestring:
        Line += LbStrString->Caption;
        break;
      case pt_TGLibDateTime:
        Line += LbStrTGLibDateTime->Caption;
        break;
    }

    if (Excp.AvailableValues.size())
    {
      Line += LbStrAllowedValues->Caption + L"\n";
      for (std::vector<std::wstring>::const_iterator
        it  = Excp.AvailableValues.begin();
        it != Excp.AvailableValues.end();
        ++it)
      {
        Line += (std::wstring(L"  ") + *it + L"\n").c_str();
      }

      Line += L"\n";
      Line += LbStrUseContext->Caption;
    }

    throw Exception(Line);
  }
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::Panel3Resize(TObject *Sender)
{
  if (!firstResizeCall)
  {
    double Ratio =
      (VlParameters->ColWidths[0] + VlParameters->ColWidths[1]) /
      double(VlParameters->ClientWidth);

    if (Ratio > 0.001)
      VlParameters->ColWidths[0] = VlParameters->ColWidths[0] / Ratio;

    VlParameters->ColWidths[1] =
      VlParameters->ClientWidth - VlParameters->ColWidths[0] - 1;
  }
  else
  {
    firstResizeCall = false;
  }
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::VlParametersEditButtonClick(TObject *Sender)
{
  Application->MessageBox(L"Not implemented yet!", L"Sorry");
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::VlParametersGetPickList(TObject *Sender, const UnicodeString KeyName,
          TStrings *Values)
{
  int ARow = -1;
  VlParameters->FindRow(KeyName, ARow);

  if (CurrentAction && (ARow > 1))
    InitializePickList((CurrentAction->Parameters)[ARow - 2], Values);
}
//---------------------------------------------------------------------------
void __fastcall TGscActionsDlg::VlParametersValidate(TObject *Sender, int ACol,
          int ARow, const UnicodeString KeyName, const UnicodeString KeyValue)
{
  if (CurrentAction && ACol && (ARow > 0))
  {
    TPlcParameterInfo& Info = ((ARow > 1) && CurrentAction) ?
      (CurrentAction->Parameters)[ARow - 2]                 :
      Actions.Comment;

    VlParameters->Strings->Strings[ARow - 1] = KeyName + L"=" + KeyValue;

    ///
    /// Validate input
    try
    {
      ValidateInput(ARow, true);
    }
    catch (...)
    {
      VlParameters->SetFocus();
      throw;
    }
  }
}

#pragma warn .8057 // Parameter 'parameter' is never used

//---------------------------------------------------------------------------
//---------------------------------------------------------------------------
//---------------------------------------------------------------------------
//---------------------------------------------------------------------------
namespace GscPLC {

CGscActionDialog::CGscActionDialog(HWND Parent)
{
  Application->Handle = Parent;
  Dlg = new TGscActionsDlg(Application);
}

CGscActionDialog::~CGscActionDialog()
{
  Dlg->inDestroy = true;
  delete Dlg;
}

HGscMatchAction CGscActionDialog::ShowModal(ConstHGscMatchAction Template)
{
  /// preselect action
  Dlg->CurrentAction = Dlg->Actions << Template;

  /// read its description
  if (Template)
    Dlg->Description = UnicodeString(Template->GetDescriptionW());

  if ((Dlg->ShowModal() == mrOk) && Dlg->CurrentAction)
  {
    /// set user comment
    Dlg->CurrentAction->Comment =
      std::wstring(GLib::SafeStr(Dlg->Description.c_str()));

    /// ...and create action
    HGscMatchAction Result;
    (*Dlg->CurrentAction) >> Result;

    return Result;
  }

  return 0;
}

}; // namespace
//---------------------------------------------------------------------------


GSC actions: GscPlcEvents

Classes | Typedefs | Functions

GscPlcEvents

Detailed Description

// end of group GscPlcAccessByNames

// end of group GscPlcBasicTypes

Event data

Basic types for event transformation

Classes

struct | TPlcActionEventDataRecord
Structure to access action fields as event data fields. More...

Typedefs

typedef void(__stdcall * | TPlcGetEventDataCallback )(void *Instance, int Index, const wchar_t *Name, const wchar_t *Value)
Get event data callback.

Functions

GSCACTDLLCALL bool __stdcall | GscAct_GetActionEventData (ConstHGscAction anAction, TPlcActionEventDataRecord &EventRecord, bool &DataComplete)
Get action event data.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionEventData (ConstHGscMatchAction anAction, TPlcActionEventDataRecord &EventRecord, bool &DataComplete)
Get match action event data.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionEventDescription (const TPlcActionEventDataRecord &EventRecord, void *Instance, TPlcGetEventDataCallback Callback, bool &DataComplete)
Get action event description lines.
GSCACTDLLCALL HGscAction __stdcall | GscAct_RestoreActionFromEventData (const TPlcActionEventDataRecord &EventRecord)
Restore actions from event data.
GSCACTDLLCALL HGscMatchAction
__stdcall 		GscMatchAct_RestoreActionFromEventData (const TPlcActionEventDataRecord &EventRecord)
Restore match action from event data.
GSCACTDLLCALL bool __stdcall | GscAct_GetEventDescriptionInfo (TGscActionPlainInfo &Info)
Enumerate event fields.
GSCACTDLLCALL bool __stdcall | GscAct_SetEventDescriptionPlainInfo (const TGscActionPlainInfo &Info)
Set the plain part of the event field info.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateEventFields (TGscParameterPlainInfo List[], unsigned int Count)
Get the list of parameters.
GSCACTDLLCALL bool __stdcall | GscAct_GetEventFieldInfo (TGscParameterPlainInfo &Info, unsigned int Index)
Get the parameter info.
GSCACTDLLCALL bool __stdcall | GscAct_SetEventFieldPlainInfo (const TGscParameterPlainInfo &Info, unsigned int Index)
Set the plain part of parameter info.

Typedef Documentation

typedef void(__stdcall * TPlcGetEventDataCallback)(void *Instance, int Index, const wchar_t *Name, const wchar_t *Value)

Get event data callback.

Instance - provided by the caller. Index - less than 0 - Name is action name Value is complete action description

  • otherwise - Name is plain name of i-th parameter Value is its value

Definition at line 415 of file GscActions.h.

Function Documentation

GSCACTDLLCALL bool __stdcall GscAct_GetActionEventData | ( | ConstHGscAction | anAction,
 |  | TPlcActionEventDataRecord & | EventRecord,
 |  | bool & | DataComplete
 | ) |  |

Get action event data.

Parameters:
[in] | anAction | Handle to action.
[out] | EventRecord | Record to store event data.
[out] | DataComplete | Flag whether all action data are stored
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionEventData | ( | ConstHGscMatchAction | anAction,
 |  | TPlcActionEventDataRecord & | EventRecord,
 |  | bool & | DataComplete
 | ) |  |

Get match action event data.

Parameters:
[in] | anAction | Handle to action.
[out] | EventRecord | Record to store event data.
[out] | DataComplete | Flag whether all action data are stored
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_GetActionEventDescription | ( | const TPlcActionEventDataRecord & | EventRecord,
 |  | void * | Instance,
 |  | TPlcGetEventDataCallback | Callback,
 |  | bool & | DataComplete
 | ) |  |

Get action event description lines.

Parameters:
[in] | EventRecord | Record with event data.
[in] | Instance | Instance to pass to callback.
[in] | Callback | Callback function to call for each pair of name/value.
[out] | DataComplete | Flag whether all action data are stored
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL HGscAction __stdcall GscAct_RestoreActionFromEventData ( const TPlcActionEventDataRecord & EventRecord )

Restore actions from event data.

Restore action from event data.

Parameters:
[in] EventRecord Record with event data.
Returns:
Handle to created action or NULL if the function fails.
GSCACTDLLCALL HGscMatchAction __stdcall GscMatchAct_RestoreActionFromEventData ( const TPlcActionEventDataRecord & EventRecord )

Restore match action from event data.

Parameters:
[in] EventRecord Record with event data.
Returns:
Handle to created action or NULL if the function fails.
GSCACTDLLCALL bool __stdcall GscAct_GetEventDescriptionInfo ( TGscActionPlainInfo & Info )

Enumerate event fields.

Get event field info.

Parameters:
[out] Info Reference to info structure.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetEventDescriptionPlainInfo ( const TGscActionPlainInfo & Info )

Set the plain part of the event field info.

Only PlainNameW and DescriptionW fields of the struct are used.

Parameters:
[in] Info Const reference to info structure.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL unsigned int __stdcall GscAct_EnumerateEventFields | ( | TGscParameterPlainInfo | List[],
 |  | unsigned int | Count
 | ) |  |

Get the list of parameters.

Parameters:
[out] | List | Retrieves infos. Should be allocated by client.
[in] | Count | Size of the List in elements.
Returns:
number of copied elements.
GSCACTDLLCALL bool __stdcall GscAct_GetEventFieldInfo | ( | TGscParameterPlainInfo & | Info,
 |  | unsigned int | Index
 | ) |  |

Get the parameter info.

Returns the Index-th parameter.

Parameters:
[out] | Info | Reference to info structure.
[in] | Index | Index of parameter.
Returns:
true if succeeds, false otherwise.
GSCACTDLLCALL bool __stdcall GscAct_SetEventFieldPlainInfo | ( | const TGscParameterPlainInfo & | Info,
 |  | unsigned int | Index
 | ) |  |

Set the plain part of parameter info.

Only PlainNameW and DescriptionW fields of the struct are used.

Parameters:
[in] | Info | Reference to info structure.
[in] | Index | Index of parameter.
Returns:
true if succeeds, false otherwise.


GSC actions: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
__int32 | 32-bit integer
__int64 | 64-bit integer
bool | Boolean value
CGscAction | GeViScope action
CGscMatchAction | GeViScope match action
CGscMessage | GeViScope message
double | 64-bit floating-point number
GscActionsDispatcher |
GUID | GUID value
TGLibDateTime | Date time value
TGscActionClassInfo | Action class info
TGscActionClassPlainInfo | Action class plain info
TGscActionInfo | Action info
TGscActionPlainInfo | Action plain info
TGscEnumInfo | Enum value info
TGscEnumPlainInfo | Enum value plain info
TGscParameterInfo | Parameter info
TGscParameterPlainInfo | Parameter plain info
TPlcActionEventDataRecord | Structure to access action fields as event data fields
TPlcEventTypeID | Event type
TPlcLastError | Structure which holds last error info
TPlcMediaChannelID | Media channel
TPlcRect | PLC rect
TPlcResourceID | Resource ID
TPlcUpdateActionInfoCallback | Update callback definition


GSC actions: __int32 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

__int32 Class Reference

Detailed Description

32-bit integer

Standard type

Definition at line 14 of file stl.txt.


GSC actions: __int64 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

__int64 Class Reference

Detailed Description

64-bit integer

Standard type

Definition at line 9 of file stl.txt.


GSC actions: bool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

bool Class Reference

Detailed Description

Boolean value.

Standard type

Definition at line 24 of file stl.txt.


GSC actions: CGscAction Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions

CGscAction Class Reference
[Message classes]

Detailed Description

GeViScope action.

 Static members:
   CGscAction*     CreateFromBinBuffer   - create action from the bin buffer
   CGscAction*     CreateFromTextBuffer  - create action from the text buffer
   CGscAction*     RestoreActionFromEventData - restore action from event data

 Public methods:
   void            operator delete       - delete operator
   HGscAction      CloneHandle           - create a clone of the action

   GscActionClass  GetActionClass        - access to action class
   GscActionCode   GetActionCode         - access to action code
   const TCHAR*    GetActionName         - access to action name
   const TCHAR*    GetActionPlainName    - access to translated action name
   HGscMatchAction CreateMatchActionFromTemplate
                                         - create a match action from the
                                           current action as template
   bool            GetActionEventData    - get action event data
   const TPlcMediaChannelID*
                   GetVideoInput         - access to video  input   field
                   GetVideoOutput        - access to video  output  field
                   GetInputContact       - access to input  contact field
                   GetOutputContact      - access to output contact field
   const __int64*  GetForeignKey         - access to foreign key    field

Definition at line 1552 of file GscActions.h.

#include <GscActions.h>

Inheritance diagram for CGscAction:
[legend]
Collaboration diagram for CGscAction:
[legend]

List of all members.

Get available fields

const TPlcMediaChannelID * | GetVideoInput () const
Get used video input.
const TPlcMediaChannelID * | GetVideoOutput () const
Get used video output.
const TPlcMediaChannelID * | GetInputContact () const
Get used input contact.
const TPlcMediaChannelID * | GetOutputContact () const
Get used output contact.
const __int64 * | GetForeignKey () const
Get used foreign key.
__int32 | GetGenericInt32Parameter () const
Get used generic 32-bit integer parameter.
bool | UpdateActionInfo (void *anObject, const TPlcUpdateActionInfoCallback &Callback)
Update action info.
bool | UpdateWindowsClientInfo (const wchar_t *localHostName, const PlcClientType localClientType, const wchar_t *localUserName)
Update windows client info.
bool | GetWindowsClientInfo (const wchar_t *&localHostName, const PlcClientType *&localClientType, const wchar_t *&localUserName)
Get used video input.
void | SetProperty (const wchar_t *Key, const wchar_t *Value)
Set action property.
const wchar_t * | GetProperty (const wchar_t *Key)
Get action property.
const wchar_t * | GetProperties ()
Get action properties.

Write Operations

bool | StoreToBinBuffer (void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten=0) const
Write message to the binary buffer.
bool | StoreToTextBuffer (char *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const
Write message to the text buffer as ANSI string.
bool | StoreToTextBuffer (wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const
Write message to the text buffer as UNICODE string.

Public Member Functions

void | operator delete (void *Ptr)
same as in CGscMessage
HGscAction | CloneHandle () const
Clone action.
GscActionClass | GetActionClass () const
Get action class.
GscActionCode | GetActionCode () const
Get action code.
const char * | GetActionNameA () const
Get action name.
const wchar_t * | GetActionNameW () const
Get action name.
const char * | GetActionPlainNameA () const
Get plain action name.
const wchar_t * | GetActionPlainNameW () const
Get plain action name.
HGscMatchAction | CreateMatchActionFromTemplate () const
Create match action from the current action.
bool | GetActionEventData (TPlcActionEventDataRecord &EventRecord, bool &DataComplete) const
Get action event data.
void | CloseHandle ()
Close message handle.
void | DuplicateHandle ()
Duplicate message handle.
GscMessageClass | GetMessageClass () const
Get message class.
int | GetReferenceCounter () const
Get reference counter.
int | GetInternalIndex () const
Get internal index.
void * | GetInternalData () const
Get internal data.
void | SetInternalData (void *Data)
Set internal data.
unsigned __int32 | GetMessageFlags () const
Get message flags.
void | SetMessageFlags (unsigned __int32 Flags)
Set message flags.
void | DisableResourceUpdate ()
Set DisableResourceUpdate flag.
void | DisableInternalInEventData ()
Set DisableInternalInEventData flag.
bool | EqualTo (ConstHGscMessage aMessage) const
Compare two messages.
bool | operator== (ConstHGscMessage aMessage) const
Compare two messages.
bool | operator!= (ConstHGscMessage aMessage) const
Compare two messages.

Static Public Member Functions

static CGscAction * | CreateFromBinBuffer (const void *Buffer, unsigned int BufferSize, unsigned int *ReadChars=0)
static members
static CGscAction * | CreateFromTextBuffer (const char *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from ANSI text buffer.
static CGscAction * | CreateFromTextBuffer (const wchar_t *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from UNICODE text buffer.
static CGscAction * | RestoreActionFromEventData (const TPlcActionEventDataRecord &EventRecord)
Restore action from event data.
static unsigned int | GetInternalIndexByCode (GscActionCode Code)
Get internal index by action code.
static GscActionCode | GetActionCodeByIndex (unsigned int Index)
Get action code by internal index.
static CGscMessage * | CreateFromBinBuffer (const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, unsigned int *ReadChars=0)
static members
static CGscMessage * | CreateFromTextBuffer (const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from text buffer.
static CGscMessage * | CreateFromTextBuffer (const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from UNICODE text buffer.

Member Function Documentation

static CGscAction* CGscAction::CreateFromBinBuffer | ( | const void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

static members

Create message from binary buffer.

Parameters:
[in] | Buffer | Pointer to buffer with binary representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[out] | ReadChars | Points to the variable where the number of read bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created action or NULL if the function fails.

Definition at line 1566 of file GscActions.h.

static CGscAction* CGscAction::CreateFromTextBuffer | ( | const char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

Create message from ANSI text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding ANSI to UNICODE.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created action or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1583 of file GscActions.h.

static CGscAction* CGscAction::CreateFromTextBuffer | ( | const wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

Create message from UNICODE text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding UNICODE to ANSI.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created action or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1601 of file GscActions.h.

static CGscAction* CGscAction::RestoreActionFromEventData ( const TPlcActionEventDataRecord & EventRecord ) [inline, static]

Restore action from event data.

Parameters:
[in] EventRecord Record with event data.
Returns:
Handle to created action or NULL if the function fails.

Definition at line 1614 of file GscActions.h.

static unsigned int CGscAction::GetInternalIndexByCode ( GscActionCode Code ) [inline, static]

Get internal index by action code.

Parameters:
[in] Code Action code.
Returns:
internal index if succeeds, 0x7FFFFFFF otherwise.

Definition at line 1624 of file GscActions.h.

static GscActionCode CGscAction::GetActionCodeByIndex ( unsigned int Index ) [inline, static]

Get action code by internal index.

Parameters:
[in] Index Internal index.
Returns:
action code if succeeds, ac_Unknown otherwise.

Definition at line 1633 of file GscActions.h.

void CGscAction::operator delete ( void * Ptr ) [inline]

same as in CGscMessage

delete operator. Delete action as usual object created with new.

Reimplemented from CGscMessage.

Definition at line 1650 of file GscActions.h.

HGscAction CGscAction::CloneHandle ( ) const [inline]

Clone action.

Returns:
a new action as a clone of the current one.

Reimplemented from CGscMessage.

Definition at line 1657 of file GscActions.h.

GscActionClass CGscAction::GetActionClass ( ) const [inline]

Get action class.

Returns:
class of the action.

Definition at line 1664 of file GscActions.h.

GscActionCode CGscAction::GetActionCode ( ) const [inline]

Get action code.

Returns:
code of the action.

Definition at line 1674 of file GscActions.h.

const char* CGscAction::GetActionNameA ( ) const [inline]

Get action name.

Returns:
Name of the action as ANSI string.

Definition at line 1684 of file GscActions.h.

const wchar_t* CGscAction::GetActionNameW ( ) const [inline]

Get action name.

Returns:
Name of the action as UNICODE string.

Definition at line 1694 of file GscActions.h.

const char* CGscAction::GetActionPlainNameA ( ) const [inline]

Get plain action name.

Returns:
Plain name of the action as ANSI string.

Definition at line 1716 of file GscActions.h.

const wchar_t* CGscAction::GetActionPlainNameW ( ) const [inline]

Get plain action name.

Returns:
Plain name of the action as UNICODE string.

Definition at line 1726 of file GscActions.h.

HGscMatchAction CGscAction::CreateMatchActionFromTemplate ( ) const [inline]

Create match action from the current action.

Returns:
Match action.

Definition at line 1747 of file GscActions.h.

bool CGscAction::GetActionEventData | ( | TPlcActionEventDataRecord & | EventRecord,
 |  | bool & | DataComplete |
 | ) |  |  | const [inline]

Get action event data.

Parameters:
[out] | EventRecord | Record to store event data.
[out] | DataComplete | Flag whether all action data are stored
Returns:
true if succeeds, false otherwise.

Definition at line 1760 of file GscActions.h.

const TPlcMediaChannelID* CGscAction::GetVideoInput ( ) const [inline]

Get used video input.

Returns:
Video input ID or NULL if not available.

Definition at line 1773 of file GscActions.h.

const TPlcMediaChannelID* CGscAction::GetVideoOutput ( ) const [inline]

Get used video output.

Returns:
Video output ID or NULL if not available.

Definition at line 1783 of file GscActions.h.

const TPlcMediaChannelID* CGscAction::GetInputContact ( ) const [inline]

Get used input contact.

Returns:
input contact ID or NULL if not available.

Definition at line 1793 of file GscActions.h.

const TPlcMediaChannelID* CGscAction::GetOutputContact ( ) const [inline]

Get used output contact.

Returns:
output contact ID or NULL if not available.

Definition at line 1803 of file GscActions.h.

const __int64* CGscAction::GetForeignKey ( ) const [inline]

Get used foreign key.

Returns:
foreign key or NULL if not available.

Definition at line 1813 of file GscActions.h.

__int32 CGscAction::GetGenericInt32Parameter ( ) const [inline]

Get used generic 32-bit integer parameter.

Returns:
generic 32-bit integer parameter.

Definition at line 1823 of file GscActions.h.

bool CGscAction::UpdateActionInfo | ( | void * | anObject,
 |  | const TPlcUpdateActionInfoCallback & | Callback |
 | ) |  |  | [inline]

Update action info.

Parameters:
[in] | anObject | Proxy object to pass to callback.
[in] | Callback | Callback functions.
Returns:
true if update successfull, false otherwise.

Definition at line 1836 of file GscActions.h.

bool CGscAction::UpdateWindowsClientInfo | ( | const wchar_t * | localHostName,
 |  | const PlcClientType | localClientType,
 |  | const wchar_t * | localUserName |
 | ) |  |  | [inline]

Update windows client info.

Parameters:
[in] | localHostName | Local Windows host name
[in] | localClientType | Local client type
[in] | localUserName | Local Windows user name
Returns:
true if succeeds, false otherwise.

Definition at line 1851 of file GscActions.h.

bool CGscAction::GetWindowsClientInfo | ( | const wchar_t *& | localHostName,
 |  | const PlcClientType *& | localClientType,
 |  | const wchar_t *& | localUserName |
 | ) |  |  | [inline]

Get used video input.

Returns:
Video input ID or NULL if not available.

Definition at line 1858 of file GscActions.h.

void CGscAction::SetProperty | ( | const wchar_t * | Key,
 |  | const wchar_t * | Value |
 | ) |  |  | [inline]

Set action property.

Parameters:
[in] | Key | Property key.
[in] | Value | Property value.

Definition at line 1870 of file GscActions.h.

const wchar_t* CGscAction::GetProperty ( const wchar_t * Key ) [inline]

Get action property.

Parameters:
[in] Key Property key.
Returns:
Property value

Definition at line 1879 of file GscActions.h.

const wchar_t* CGscAction::GetProperties ( ) [inline]

Get action properties.

Returns:
Properties.

Definition at line 1889 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromBinBuffer | ( | const void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static, inherited]

static members

Create message from binary buffer.

Parameters:
[in] | Buffer | Pointer to buffer with binary representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[out] | ReadChars | Points to the variable where the number of read bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.

Definition at line 1246 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromTextBuffer | ( | const char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static, inherited]

Create message from text buffer.

Create message from ANSI text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding ANSI to UNICODE.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1270 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromTextBuffer | ( | const wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static, inherited]

Create message from UNICODE text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding UNICODE to ANSI.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1292 of file GscActions.h.

bool CGscMessage::StoreToBinBuffer | ( | void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | unsigned int * | BytesWritten = 0 |
 | ) |  |  | const [inline, inherited]

Write message to the binary buffer.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[out] | BytesWritten | Points to the variable where the number of written bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.

Definition at line 1318 of file GscActions.h.

bool CGscMessage::StoreToTextBuffer | ( | char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText = false,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | CharsWritten = 0 |
 | ) |  |  | const [inline, inherited]

Write message to the text buffer as ANSI string.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode UNICODE to ANSI.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!

Definition at line 1340 of file GscActions.h.

bool CGscMessage::StoreToTextBuffer | ( | wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText = false,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | CharsWritten = 0 |
 | ) |  |  | const [inline, inherited]

Write message to the text buffer as UNICODE string.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode ANSI to UNICODE.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!

Definition at line 1364 of file GscActions.h.

void CGscMessage::CloseHandle ( ) [inline, inherited]

Close message handle.

Same as delete message.

Definition at line 1385 of file GscActions.h.

void CGscMessage::DuplicateHandle ( ) [inline, inherited]

Duplicate message handle.

Increase the internal reference to the message.

Definition at line 1392 of file GscActions.h.

GscMessageClass CGscMessage::GetMessageClass ( ) const [inline, inherited]

Get message class.

Returns:
class of the message.

Definition at line 1409 of file GscActions.h.

int CGscMessage::GetReferenceCounter ( ) const [inline, inherited]

Get reference counter.

Returns:
value of the internal reference counter.

Definition at line 1419 of file GscActions.h.

int CGscMessage::GetInternalIndex ( ) const [inline, inherited]

Get internal index.

Returns:
internal index.

Definition at line 1430 of file GscActions.h.

void* CGscMessage::GetInternalData ( ) const [inline, inherited]

Get internal data.

You can use this field as temporary storage for user specific data.

Returns:
internal data.

Definition at line 1443 of file GscActions.h.

void CGscMessage::SetInternalData ( void * Data ) [inline, inherited]

Set internal data.

You can use this field as temporary storage for user specific data.

Parameters:
[in] Data internal data.

Definition at line 1454 of file GscActions.h.

unsigned __int32 CGscMessage::GetMessageFlags ( ) const [inline, inherited]

Get message flags.

Returns:
message flags.

Definition at line 1462 of file GscActions.h.

void CGscMessage::SetMessageFlags ( unsigned __int32 Flags ) [inline, inherited]

Set message flags.

Parameters:
[in] Flags message flags.

Definition at line 1471 of file GscActions.h.

void CGscMessage::DisableResourceUpdate ( ) [inline, inherited]

Set DisableResourceUpdate flag.

Definition at line 1476 of file GscActions.h.

void CGscMessage::DisableInternalInEventData ( ) [inline, inherited]

Set DisableInternalInEventData flag.

Definition at line 1481 of file GscActions.h.

bool CGscMessage::EqualTo ( ConstHGscMessage aMessage ) const [inline, inherited]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1490 of file GscActions.h.

bool CGscMessage::operator== ( ConstHGscMessage aMessage ) const [inline, inherited]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1500 of file GscActions.h.

bool CGscMessage::operator!= ( ConstHGscMessage aMessage ) const [inline, inherited]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1511 of file GscActions.h.


GSC actions: CGscMatchAction Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions

CGscMatchAction Class Reference
[Message classes]

Detailed Description

GeViScope match action.

 Static members:
   CGscMatchAction*CreateFromBinBuffer   - create match action from the bin buffer
   CGscMatchAction*CreateFromTextBuffer  - create match action from the text buffer
   CGscMatchAction*RestoreActionFromEventData - restore match action from event data

 Public methods:
   void            operator delete       - delete operator
   HGscAction      CloneHandle           - create a clone of the match action

   GscActionClass  GetActionClass        - access to action class
   GscActionCode   GetActionCode         - access to action code
   const TCHAR*    GetActionName         - access to action name
   const TCHAR*    GetActionPlainName    - access to translated action name

   bool            HasDescription        - check user provided description (comment)
   const TCHAR*    GetDescription        - get user provided description (comment)
   const TCHAR*    GetComment
   void            SetDescription        - set user provided description (comment)
   void            SetComment

   bool            Matches               - check an action against match condition
   HGscAction      CreateActionFromTemplate
                                         - create the action from the
                                           current match action and another
                                           action as field template
   bool            GetActionEventData    - get action event data

Definition at line 1932 of file GscActions.h.

#include <GscActions.h>

Inheritance diagram for CGscMatchAction:
[legend]
Collaboration diagram for CGscMatchAction:
[legend]

List of all members.

Match specific functions

bool | Matches (ConstHGscAction anAction) const
Matches action.
HGscAction | CreateActionFromTemplate (ConstHGscAction anAction) const
Create action from the current match action and provided action as template.
bool | GetActionEventData (TPlcActionEventDataRecord &EventRecord, bool &DataComplete) const
Get action event data.

Write Operations

bool | StoreToBinBuffer (void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten=0) const
Write message to the binary buffer.
bool | StoreToTextBuffer (char *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const
Write message to the text buffer as ANSI string.
bool | StoreToTextBuffer (wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const
Write message to the text buffer as UNICODE string.

Public Member Functions

void | operator delete (void *Ptr)
same as in CGscMessage
HGscMatchAction | CloneHandle () const
Clone match action.
GscActionClass | GetActionClass () const
Get action class.
GscActionCode | GetActionCode () const
Get action code.
const char * | GetActionNameA () const
Get action name.
const wchar_t * | GetActionNameW () const
Get action name.
const char * | GetActionPlainNameA () const
Get plain action name.
const wchar_t * | GetActionPlainNameW () const
Get action name.
bool HasDescription ()
Check description of the match action.
const char * | GetDescriptionA () const
Get description of the match action.
const char * | GetCommentA () const
Get description of the match action.
const wchar_t * | GetDescriptionW () const
Get description of the match action.
const wchar_t * | GetCommentW () const
Get description of the match action.
void | SetDescription (const char *Description)
Set description of the match action.
void | SetDescription (const wchar_t *Description)
Set description of the match action.
void | SetComment (const char *Description)
Set description of the match action.
void | SetComment (const wchar_t *Description)
Set description of the match action.
void | CloseHandle ()
Close message handle.
void | DuplicateHandle ()
Duplicate message handle.
GscMessageClass | GetMessageClass () const
Get message class.
int | GetReferenceCounter () const
Get reference counter.
int | GetInternalIndex () const
Get internal index.
void * | GetInternalData () const
Get internal data.
void | SetInternalData (void *Data)
Set internal data.
unsigned __int32 | GetMessageFlags () const
Get message flags.
void | SetMessageFlags (unsigned __int32 Flags)
Set message flags.
void | DisableResourceUpdate ()
Set DisableResourceUpdate flag.
void | DisableInternalInEventData ()
Set DisableInternalInEventData flag.
bool | EqualTo (ConstHGscMessage aMessage) const
Compare two messages.
bool | operator== (ConstHGscMessage aMessage) const
Compare two messages.
bool | operator!= (ConstHGscMessage aMessage) const
Compare two messages.

Static Public Member Functions

static CGscMatchAction * | CreateFromBinBuffer (const void *Buffer, unsigned int BufferSize, unsigned int *ReadChars=0)
static members
static CGscMatchAction * | CreateFromTextBuffer (const char *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from ANSI text buffer.
static CGscMatchAction * | CreateFromTextBuffer (const wchar_t *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from UNICODE text buffer.
static CGscMatchAction * | RestoreActionFromEventData (const TPlcActionEventDataRecord &EventRecord)
Restore match action from event data.
static CGscMessage * | CreateFromBinBuffer (const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, unsigned int *ReadChars=0)
static members
static CGscMessage * | CreateFromTextBuffer (const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from text buffer.
static CGscMessage * | CreateFromTextBuffer (const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from UNICODE text buffer.

Member Function Documentation

static CGscMatchAction* CGscMatchAction::CreateFromBinBuffer | ( | const void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

static members

Create message from binary buffer.

Parameters:
[in] | Buffer | Pointer to buffer with binary representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[out] | ReadChars | Points to the variable where the number of read bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created match action or NULL if the function fails.

Definition at line 1946 of file GscActions.h.

static CGscMatchAction* CGscMatchAction::CreateFromTextBuffer | ( | const char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

Create message from ANSI text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding ANSI to UNICODE.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created action or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1963 of file GscActions.h.

static CGscMatchAction* CGscMatchAction::CreateFromTextBuffer | ( | const wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

Create message from UNICODE text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding UNICODE to ANSI.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created action or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1981 of file GscActions.h.

static CGscMatchAction* CGscMatchAction::RestoreActionFromEventData ( const TPlcActionEventDataRecord & EventRecord ) [inline, static]

Restore match action from event data.

Parameters:
[in] EventRecord Record with event data.
Returns:
Handle to created action or NULL if the function fails.

Definition at line 1994 of file GscActions.h.

void CGscMatchAction::operator delete ( void * Ptr ) [inline]

same as in CGscMessage

delete operator. Delete match action as usual object created with new.

Reimplemented from CGscMessage.

Definition at line 2012 of file GscActions.h.

HGscMatchAction CGscMatchAction::CloneHandle ( ) const [inline]

Clone match action.

Returns:
a new match action as a clone of the current one.

Reimplemented from CGscMessage.

Definition at line 2019 of file GscActions.h.

GscActionClass CGscMatchAction::GetActionClass ( ) const [inline]

Get action class.

Returns:
class of the match action.

Definition at line 2026 of file GscActions.h.

GscActionCode CGscMatchAction::GetActionCode ( ) const [inline]

Get action code.

Returns:
code of the match action.

Definition at line 2036 of file GscActions.h.

const char* CGscMatchAction::GetActionNameA ( ) const [inline]

Get action name.

Returns:
Name of the match action as ANSI string.

Definition at line 2046 of file GscActions.h.

const wchar_t* CGscMatchAction::GetActionNameW ( ) const [inline]

Get action name.

Returns:
Name of the match action as UNICODE string.

Definition at line 2056 of file GscActions.h.

const char* CGscMatchAction::GetActionPlainNameA ( ) const [inline]

Get plain action name.

Returns:
Plain name of the match action as ANSI string.

Definition at line 2077 of file GscActions.h.

const wchar_t* CGscMatchAction::GetActionPlainNameW ( ) const [inline]

Get action name.

Returns:
Plain name of the match action as UNICODE string.

Definition at line 2087 of file GscActions.h.

bool CGscMatchAction::HasDescription ( ) [inline]

Check description of the match action.

Returns:
true if the match action has user provided comment.

Definition at line 2108 of file GscActions.h.

const char* CGscMatchAction::GetDescriptionA ( ) const [inline]

Get description of the match action.

Returns:
Description of the match action as ANSI string.

Definition at line 2118 of file GscActions.h.

const char* CGscMatchAction::GetCommentA ( ) const [inline]

Get description of the match action.

Alias to GetDescriptionA.

Definition at line 2128 of file GscActions.h.

const wchar_t* CGscMatchAction::GetDescriptionW ( ) const [inline]

Get description of the match action.

Returns:
Description of the match action as UNICODE string.

Definition at line 2135 of file GscActions.h.

const wchar_t* CGscMatchAction::GetCommentW ( ) const [inline]

Get description of the match action.

Alias to GetDescriptionW.

Definition at line 2145 of file GscActions.h.

void CGscMatchAction::SetDescription ( const char * Description ) [inline]

Set description of the match action.

Parameters:
[in] Description User provided comment to the match action.

Definition at line 2169 of file GscActions.h.

void CGscMatchAction::SetDescription ( const wchar_t * Description ) [inline]

Set description of the match action.

Parameters:
[in] Description User provided comment to the match action.

Definition at line 2175 of file GscActions.h.

void CGscMatchAction::SetComment ( const char * Description ) [inline]

Set description of the match action.

Parameters:
[in] Description User provided comment to the match action.

Definition at line 2181 of file GscActions.h.

void CGscMatchAction::SetComment ( const wchar_t * Description ) [inline]

Set description of the match action.

Parameters:
[in] Description User provided comment to the match action.

Definition at line 2187 of file GscActions.h.

bool CGscMatchAction::Matches ( ConstHGscAction anAction ) const [inline]

Matches action.

Parameters:
[in] anAction Action to match against the current match action.
Returns:
true if the condition satisfied, false otherwise.

Definition at line 2200 of file GscActions.h.

HGscAction CGscMatchAction::CreateActionFromTemplate ( ConstHGscAction anAction ) const [inline]

Create action from the current match action and provided action as template.

Parameters:
[in] anAction Action to use as template to take available fields from.
Returns:
Handle to created action.
Attention:
anAction can be NULL if you don't use it.

Definition at line 2212 of file GscActions.h.

bool CGscMatchAction::GetActionEventData | ( | TPlcActionEventDataRecord & | EventRecord,
 |  | bool & | DataComplete |
 | ) |  |  | const [inline]

Get action event data.

Parameters:
[out] | EventRecord | Record to store event data.
[out] | DataComplete | Flag whether all action data are stored
Returns:
true if succeeds, false otherwise.

Definition at line 2225 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromBinBuffer | ( | const void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static, inherited]

static members

Create message from binary buffer.

Parameters:
[in] | Buffer | Pointer to buffer with binary representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[out] | ReadChars | Points to the variable where the number of read bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.

Definition at line 1246 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromTextBuffer | ( | const char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static, inherited]

Create message from text buffer.

Create message from ANSI text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding ANSI to UNICODE.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1270 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromTextBuffer | ( | const wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static, inherited]

Create message from UNICODE text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding UNICODE to ANSI.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1292 of file GscActions.h.

bool CGscMessage::StoreToBinBuffer | ( | void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | unsigned int * | BytesWritten = 0 |
 | ) |  |  | const [inline, inherited]

Write message to the binary buffer.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[out] | BytesWritten | Points to the variable where the number of written bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.

Definition at line 1318 of file GscActions.h.

bool CGscMessage::StoreToTextBuffer | ( | char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText = false,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | CharsWritten = 0 |
 | ) |  |  | const [inline, inherited]

Write message to the text buffer as ANSI string.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode UNICODE to ANSI.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!

Definition at line 1340 of file GscActions.h.

bool CGscMessage::StoreToTextBuffer | ( | wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText = false,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | CharsWritten = 0 |
 | ) |  |  | const [inline, inherited]

Write message to the text buffer as UNICODE string.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode ANSI to UNICODE.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!

Definition at line 1364 of file GscActions.h.

void CGscMessage::CloseHandle ( ) [inline, inherited]

Close message handle.

Same as delete message.

Definition at line 1385 of file GscActions.h.

void CGscMessage::DuplicateHandle ( ) [inline, inherited]

Duplicate message handle.

Increase the internal reference to the message.

Definition at line 1392 of file GscActions.h.

GscMessageClass CGscMessage::GetMessageClass ( ) const [inline, inherited]

Get message class.

Returns:
class of the message.

Definition at line 1409 of file GscActions.h.

int CGscMessage::GetReferenceCounter ( ) const [inline, inherited]

Get reference counter.

Returns:
value of the internal reference counter.

Definition at line 1419 of file GscActions.h.

int CGscMessage::GetInternalIndex ( ) const [inline, inherited]

Get internal index.

Returns:
internal index.

Definition at line 1430 of file GscActions.h.

void* CGscMessage::GetInternalData ( ) const [inline, inherited]

Get internal data.

You can use this field as temporary storage for user specific data.

Returns:
internal data.

Definition at line 1443 of file GscActions.h.

void CGscMessage::SetInternalData ( void * Data ) [inline, inherited]

Set internal data.

You can use this field as temporary storage for user specific data.

Parameters:
[in] Data internal data.

Definition at line 1454 of file GscActions.h.

unsigned __int32 CGscMessage::GetMessageFlags ( ) const [inline, inherited]

Get message flags.

Returns:
message flags.

Definition at line 1462 of file GscActions.h.

void CGscMessage::SetMessageFlags ( unsigned __int32 Flags ) [inline, inherited]

Set message flags.

Parameters:
[in] Flags message flags.

Definition at line 1471 of file GscActions.h.

void CGscMessage::DisableResourceUpdate ( ) [inline, inherited]

Set DisableResourceUpdate flag.

Definition at line 1476 of file GscActions.h.

void CGscMessage::DisableInternalInEventData ( ) [inline, inherited]

Set DisableInternalInEventData flag.

Definition at line 1481 of file GscActions.h.

bool CGscMessage::EqualTo ( ConstHGscMessage aMessage ) const [inline, inherited]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1490 of file GscActions.h.

bool CGscMessage::operator== ( ConstHGscMessage aMessage ) const [inline, inherited]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1500 of file GscActions.h.

bool CGscMessage::operator!= ( ConstHGscMessage aMessage ) const [inline, inherited]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1511 of file GscActions.h.


GSC actions: CGscMessage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions

CGscMessage Class Reference
[Message classes]

Detailed Description

GeViScope message.

 Static members:
   CGscMessage*    CreateFromBinBuffer   - create message from the bin buffer
   CGscMessage*    CreateFromTextBuffer  - create message from the text buffer

 Public methods:
   bool            StoreToBinBuffer      - store message to the bin buffer
   bool            StoreToTextBuffer     - store message to the text buffer

   void            operator delete       - delete operator
   void            CloseHandle           - close message handle
   void            DuplicateHandle       - duplicate message handle
   HGscMessage     CloneHandle           - create a clone of the message
   GscMessageClass GetMessageClass       - access to message class
   int             GetReferenceCounter   - access to reference counter
   int             GetInternalIndex      - access to the internal index
   void*           GetInternalData       - get internal data
   void            SetInternalData       - set internal data
   bool            EqualTo               - compare with another message

Definition at line 1223 of file GscActions.h.

#include <GscActions.h>

Inheritance diagram for CGscMessage:
[legend]

List of all members.

Write Operations

bool | StoreToBinBuffer (void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten=0) const
Write message to the binary buffer.
bool | StoreToTextBuffer (char *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const
Write message to the text buffer as ANSI string.
bool | StoreToTextBuffer (wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const
Write message to the text buffer as UNICODE string.

Public Member Functions

void | operator delete (void *Ptr)
delete operator.
void | CloseHandle ()
Close message handle.
void | DuplicateHandle ()
Duplicate message handle.
HGscMessage | CloneHandle () const
Clone message.
GscMessageClass | GetMessageClass () const
Get message class.
int | GetReferenceCounter () const
Get reference counter.
int | GetInternalIndex () const
Get internal index.
void * | GetInternalData () const
Get internal data.
void | SetInternalData (void *Data)
Set internal data.
unsigned __int32 | GetMessageFlags () const
Get message flags.
void | SetMessageFlags (unsigned __int32 Flags)
Set message flags.
void | DisableResourceUpdate ()
Set DisableResourceUpdate flag.
void | DisableInternalInEventData ()
Set DisableInternalInEventData flag.
bool | EqualTo (ConstHGscMessage aMessage) const
Compare two messages.
bool | operator== (ConstHGscMessage aMessage) const
Compare two messages.
bool | operator!= (ConstHGscMessage aMessage) const
Compare two messages.

Static Public Member Functions

static CGscMessage * | CreateFromBinBuffer (const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, unsigned int *ReadChars=0)
static members
static CGscMessage * | CreateFromTextBuffer (const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from text buffer.
static CGscMessage * | CreateFromTextBuffer (const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0)
Create message from UNICODE text buffer.

Member Function Documentation

static CGscMessage* CGscMessage::CreateFromBinBuffer | ( | const void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

static members

Create message from binary buffer.

Parameters:
[in] | Buffer | Pointer to buffer with binary representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[out] | ReadChars | Points to the variable where the number of read bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.

Definition at line 1246 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromTextBuffer | ( | const char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

Create message from text buffer.

Create message from ANSI text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding ANSI to UNICODE.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1270 of file GscActions.h.

static CGscMessage* CGscMessage::CreateFromTextBuffer | ( | const wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | GscMessageClass | ExpectedClass = mk_Unknown,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | ReadChars = 0 |
 | ) |  |  | [inline, static]

Create message from UNICODE text buffer.

Parameters:
[in] | Buffer | Pointer to buffer with text representation of message.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | ExpectedClass | Expected class of the message. Use mk_Unknown to read any message.
[in] | UseUTF8Encoding | Use UTF8 encoding for transcoding UNICODE to ANSI.
[out] | ReadChars | Points to the variable where the number of read chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
Handle to created message or NULL if the function fails.
Attention:
Buffer must be 0-terminated.

Definition at line 1292 of file GscActions.h.

bool CGscMessage::StoreToBinBuffer | ( | void * | Buffer,
 |  | unsigned int | BufferSize,
 |  | unsigned int * | BytesWritten = 0 |
 | ) |  |  | const [inline]

Write message to the binary buffer.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[out] | BytesWritten | Points to the variable where the number of written bytes is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.

Definition at line 1318 of file GscActions.h.

bool CGscMessage::StoreToTextBuffer | ( | char * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText = false,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | CharsWritten = 0 |
 | ) |  |  | const [inline]

Write message to the text buffer as ANSI string.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode UNICODE to ANSI.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!

Definition at line 1340 of file GscActions.h.

bool CGscMessage::StoreToTextBuffer | ( | wchar_t * | Buffer,
 |  | unsigned int | BufferSize,
 |  | bool | OutputAsPlainText = false,
 |  | bool | UseUTF8Encoding = false,
 |  | unsigned int * | CharsWritten = 0 |
 | ) |  |  | const [inline]

Write message to the text buffer as UNICODE string.

Parameters:
[in] | Buffer | Points to the buffer that receives the data.
[in] | BufferSize | Size of the buffer pointed by Buffer in chars.
[in] | OutputAsPlainText | Output as plain text.
[in] | UseUTF8Encoding | Use UTF8 encoding to transcode ANSI to UNICODE.
[out] | CharsWritten | Points to the variable where the number of written chars is returned. This parameter can be NULL if the caller does not need this information.
Returns:
true if the function succeeds, false otherwise.
Attention:
Buffer can be NULL if BufferSize is 0. Use it to query required size.
Warning:
The output produced as "plain text" CANNOT be converted back to the message!

Definition at line 1364 of file GscActions.h.

void CGscMessage::operator delete ( void * Ptr ) [inline]

delete operator.

Delete message as usual object created with new.

Reimplemented in CGscAction, and CGscMatchAction.

Definition at line 1378 of file GscActions.h.

void CGscMessage::CloseHandle ( ) [inline]

Close message handle.

Same as delete message.

Definition at line 1385 of file GscActions.h.

void CGscMessage::DuplicateHandle ( ) [inline]

Duplicate message handle.

Increase the internal reference to the message.

Definition at line 1392 of file GscActions.h.

HGscMessage CGscMessage::CloneHandle ( ) const [inline]

Clone message.

Returns:
a new message as a clone of this one.

Reimplemented in CGscAction, and CGscMatchAction.

Definition at line 1399 of file GscActions.h.

GscMessageClass CGscMessage::GetMessageClass ( ) const [inline]

Get message class.

Returns:
class of the message.

Definition at line 1409 of file GscActions.h.

int CGscMessage::GetReferenceCounter ( ) const [inline]

Get reference counter.

Returns:
value of the internal reference counter.

Definition at line 1419 of file GscActions.h.

int CGscMessage::GetInternalIndex ( ) const [inline]

Get internal index.

Returns:
internal index.

Definition at line 1430 of file GscActions.h.

void* CGscMessage::GetInternalData ( ) const [inline]

Get internal data.

You can use this field as temporary storage for user specific data.

Returns:
internal data.

Definition at line 1443 of file GscActions.h.

void CGscMessage::SetInternalData ( void * Data ) [inline]

Set internal data.

You can use this field as temporary storage for user specific data.

Parameters:
[in] Data internal data.

Definition at line 1454 of file GscActions.h.

unsigned __int32 CGscMessage::GetMessageFlags ( ) const [inline]

Get message flags.

Returns:
message flags.

Definition at line 1462 of file GscActions.h.

void CGscMessage::SetMessageFlags ( unsigned __int32 Flags ) [inline]

Set message flags.

Parameters:
[in] Flags message flags.

Definition at line 1471 of file GscActions.h.

void CGscMessage::DisableResourceUpdate ( ) [inline]

Set DisableResourceUpdate flag.

Definition at line 1476 of file GscActions.h.

void CGscMessage::DisableInternalInEventData ( ) [inline]

Set DisableInternalInEventData flag.

Definition at line 1481 of file GscActions.h.

bool CGscMessage::EqualTo ( ConstHGscMessage aMessage ) const [inline]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1490 of file GscActions.h.

bool CGscMessage::operator== ( ConstHGscMessage aMessage ) const [inline]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1500 of file GscActions.h.

bool CGscMessage::operator!= ( ConstHGscMessage aMessage ) const [inline]

Compare two messages.

Parameters:
[in] aMessage a message to compare with.
Returns:
Result of comparision.

Definition at line 1511 of file GscActions.h.


GSC actions: double Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

double Class Reference

Detailed Description

64-bit floating-point number

Standard type

Definition at line 19 of file stl.txt.


GSC actions: GscActionsDispatcher Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions

GscActionsDispatcher Class Reference
[Using virtual functions]

Detailed Description

Definition at line 27 of file GscActionsDispatcher.h.

#include <GscActionsDispatcher.h>

List of all members.

Public Member Functions

GscActionsDispatcher ()
virtual | ~GscActionsDispatcher ()
bool | Dispatch (HGscAction Action)

Protected Member Functions

virtual bool | OnUnregisteredMessage (HGscAction Action)
virtual bool | OnBlockingFilterActivate (HGscAction anAction, const wchar_t *aFilter)
System actions.
virtual bool | OnBlockingFilterDeactivate (HGscAction anAction, const wchar_t *aFilter)
virtual bool | OnCustomAction (HGscAction anAction, const __int64 &aInt, const wchar_t *aString)
virtual bool | OnDatabaseRecordingInfoRing (HGscAction anAction, const PlcDatabaseRing aDatabaseRing, const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aRingCapacity, const TGLibDateTime &aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity)
virtual bool | OnDatabaseRecordingInfoTotal (HGscAction anAction, const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedCapacity, const TGLibDateTime *aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity, const double *aRequiredCapacityFactor, const bool *aRequiredCapacityAvailable)
virtual bool | OnDatabaseStarted (HGscAction anAction, const PlcDatabaseStatus aStatus, const __int64 &aTotalSize)
virtual bool | OnEventRecordingChanged (HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
virtual bool | OnEventStarted (HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey)
virtual bool | OnEventStopped (HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
virtual bool | OnFRCNotification (HGscAction anAction, const PlcFRCNotification aNotification, const __int32 *aParam, const wchar_t *aDescription, const char *aXMLInfo)
virtual bool | OnGEMOSalarm (HGscAction anAction, const __int64 &aGEMOSkey, const __int32 aGEMOSint, const wchar_t *aGEMOSstr)
virtual bool | OnIPSwitchOperation (HGscAction anAction, const IPSwitchOps aOperation, const wchar_t *aPort, const __int32 *aParam)
virtual bool | OnKillAllEvents (HGscAction anAction)
virtual bool | OnKillEvent (HGscAction anAction, const TPlcEventTypeID &aTypeID)
virtual bool | OnKillEventByID (HGscAction anAction, const __int64 &aEventID)
virtual bool | OnLiveCheck (HGscAction anAction, const __int64 &aCounter, const TGLibDateTime &aDate)
virtual bool | OnRedundantPowerFailure (HGscAction anAction)
virtual bool | OnRedundantPowerOk (HGscAction anAction)
virtual bool | OnSetClock (HGscAction anAction, const TGLibDateTime &aDate)
virtual bool | OnSetupChanged (HGscAction anAction, const wchar_t *aUser, const wchar_t *aHost, const TGLibDateTime &aDate, const PlcResourceKind aResourceKind, const TPlcEventTypeID &aResourceID, const PlcResourceChangeKind aChangeKind, const wchar_t *aDetails, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnSetupUploadProgress (HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const __int32 aProgress, const TGLibDateTime &aDate)
virtual bool | OnSetWatchdog (HGscAction anAction, const __int32 aTimeout)
virtual bool | OnSMRPViewerCleared (HGscAction anAction)
virtual bool | OnSMRPViewerConnected (HGscAction anAction, const wchar_t *aServer, const TPlcMediaChannelID &aChannel)
virtual bool | OnSMTPMailSend (HGscAction anAction, const wchar_t *aSubject, const wchar_t *aTo, const wchar_t *aCc, const wchar_t *aBody, const TPlcMediaChannelID *aChannel)
virtual bool | OnStartEvent (HGscAction anAction, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey)
virtual bool | OnStopAllEvents (HGscAction anAction)
virtual bool | OnStopEvent (HGscAction anAction, const TPlcEventTypeID &aTypeID)
virtual bool | OnStopEventByID (HGscAction anAction, const __int64 &aEventID)
virtual bool | OnSystemError (HGscAction anAction, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
virtual bool | OnSystemInfo (HGscAction anAction, const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo)
virtual bool | OnSystemSettingsChanged (HGscAction anAction, const bool aSetupChanged, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const bool aTimeRangeChanged, const TPlcResourceID *aTimeRange, const bool aLicenceChanged, const TGLibDateTime &aDate)
virtual bool | OnSystemStarted (HGscAction anAction, const TGLibDateTime &aDate)
virtual bool | OnSystemTerminating (HGscAction anAction, const TGLibDateTime &aDate, const bool aWindowsShutdown)
virtual bool | OnSystemWarning (HGscAction anAction, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
virtual bool | OnTransferBinaryBuffer (HGscAction anAction, const GUID &aInternalHandle, const wchar_t *aParameter)
virtual bool | OnTransferBinaryChannelBuffer (HGscAction anAction, const TPlcMediaChannelID &aChannel, const GUID &aInternalHandle, const wchar_t *aParameter)
virtual bool | OnUserLogin (HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnUserLoginFailed (HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const UserLoginFailureCode aRejectReason, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnUserLogout (HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnActivateExternalProcess (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const VideoSensorKind aExternalSystem)
Video control.
virtual bool | OnChangeADParameterSet (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
virtual bool | OnChangeCameraProfile (HGscAction anAction, const TPlcResourceID &aHardwareModule, const TPlcResourceID &aCameraProfile)
virtual bool | OnChangeCPAParameterSet (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
virtual bool | OnChangeGTectParameterSet (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
virtual bool | OnChangeObtrackParameterSet (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
virtual bool | OnChangeVMDParameterSet (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
virtual bool | OnChannelError (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
virtual bool | OnChannelInfo (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo)
virtual bool | OnChannelLiveCheck (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const TGLibDateTime &aTimeStamp)
virtual bool | OnChannelWarning (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
virtual bool | OnCPAMeasurement (HGscAction anAction, const TPlcMediaChannelID &aChannel, const __int32 aCorrelation)
virtual bool | OnGTectAnalyticsLiveCheck (HGscAction anAction)
virtual bool | OnGTectDualSensorAlarm (HGscAction anAction, const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea)
virtual bool | OnGTectDualSensorAlarmFinished (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnGTectSceneAlarm (HGscAction anAction, const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason)
virtual bool | OnGTectSceneAlarmFinished (HGscAction anAction, const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason)
virtual bool | OnGTectVMXAlarm (HGscAction anAction, const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const __int32 *aAlarmGroup, const __int32 *aTrackID, const TPlcRect *aAlarmArea)
virtual bool | OnGTectVMXAlarmFinished (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnIASSettingsChanged (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
virtual bool | OnIPCameraRawCommand (HGscAction anAction, const wchar_t *aURL, const wchar_t *aUser, const wchar_t *aPassword, const wchar_t *aPOST)
virtual bool | OnIPCamFailoverNotification (HGscAction anAction, const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters)
virtual bool | OnIPCamFailoverRestore (HGscAction anAction, const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters)
virtual bool | OnMakeCPAReferenceImage (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnMediaChannelSetupInfo (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const wchar_t *aParameter)
virtual bool | OnNPRRawData (HGscAction anAction, const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const __int32 aWeight, const __int32 aZoneState, const __int32 aZonePlace, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const bool aCurBest, const __int32 aPlateWidth, const __int32 aPlateHeight, const __int32 aPlateAngle, const __int32 aSymHeight, const wchar_t *aType)
virtual bool | OnNPRRecognition (HGscAction anAction, const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const PlcNPRRestriction aRestriction, const wchar_t *aCategory, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const wchar_t *aType, const __int32 aWeight)
virtual bool | OnObtrackChannelCounter (HGscAction anAction, const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp)
virtual bool | OnObtrackChannelCounterThreshold (HGscAction anAction, const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp)
virtual bool | OnObtrackChannelSetCounter (HGscAction anAction, const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp)
virtual bool | OnObtrackFrameRawData (HGscAction anAction, const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aBrightness, const __int32 aContrast)
virtual bool | OnObtrackGroupCounter (HGscAction anAction, const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp, const wchar_t *aGroupName)
virtual bool | OnObtrackGroupCounterThreshold (HGscAction anAction, const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName)
virtual bool | OnObtrackGroupSetCounter (HGscAction anAction, const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName)
virtual bool | OnObtrackObjectRawData (HGscAction anAction, const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aArea, const __int32 aObjectID, const PlcObtrackObjectStatus aObjectStatus, const PlcObtrackObjectClass aObjectClass, const __int32 *aConfidence, const TPlcRect *aPosition, const double *aSpeed, const __int32 *aDuration, const __int32 *aDirection, const double *aSize, const double *aObjectWidth, const double *aObjectHeight, const PlcObtrackProcessSize *aProcessSize, const char *aGscNetName)
virtual bool | OnObtrackTunnelAlarm (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const PlcTunnelAlarmReason aAlarmReason, const __int32 aObjectID, const __int32 aAlarmAreaID, const TPlcRect *aObjectArea)
virtual bool | OnSensorAlarmFinished (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
virtual bool | OnSensorInhibitAlarmFinished (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
virtual bool | OnSensorInhibitVideoAlarm (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass)
virtual bool | OnSensorVideoAlarm (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass)
virtual bool | OnSetClientVCA (HGscAction anAction, const TPlcMediaChannelID &aChannel, const GTectClientVCAType aClientVCAType, const bool aEnabled)
virtual bool | OnSetSystemTime (HGscAction anAction, const TGLibDateTime &aTimeStamp)
virtual bool | OnSetTestPictureMode (HGscAction anAction, const TPlcMediaChannelID &aChannel, const bool aMode)
virtual bool | OnVCASetArmed (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed)
virtual bool | OnVCAStatusAnswer (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed)
virtual bool | OnVCAStatusRequest (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
virtual bool | OnVideoContrastDetected (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnVideoContrastFailed (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnVideoSetImageBrightness (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aBrightness)
virtual bool | OnVideoSetImageContrast (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aContrast)
virtual bool | OnVideoSetImageSaturation (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aSaturation)
virtual bool | OnVideoSourceChanged (HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSignalNorm aSignalNorm, const VideoSignalType aSignalType, const VideoInterlaceType aInterlaceType)
virtual bool | OnVideoSyncDetected (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnVideoSyncFailed (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnABCConnect (HGscAction anAction, const wchar_t *aAddress)
Audio control.
virtual bool | OnABCDisconnect (HGscAction anAction)
virtual bool | OnABCPlayFile (HGscAction anAction, const __int64 &aFileID, const wchar_t *aFileName, const bool aAutoRepeat)
virtual bool | OnSensorAudioAlarm (HGscAction anAction, const TPlcMediaChannelID &aChannel)
virtual bool | OnAutoFocusOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
Camera control.
virtual bool | OnAutoFocusOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraApplyProfile (HGscAction anAction, const TPlcMediaChannelID &aCamera, const wchar_t *aProfile)
virtual bool | OnCameraBacklightCompensationMode (HGscAction anAction, const TPlcMediaChannelID &aCamera, const PlcBacklightMode aMode)
virtual bool | OnCameraClearPrePosText (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition)
virtual bool | OnCameraDayNightMode (HGscAction anAction, const TPlcMediaChannelID &aCamera, const PlcDayNightMode aMode)
virtual bool | OnCameraLightOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraLightOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraManualIrisOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraManualIrisOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraPumpOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraPumpOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraRAWOutput (HGscAction anAction, const TPlcMediaChannelID &aCamera, const char *aOutput)
virtual bool | OnCameraSelectCharMode (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aMode)
virtual bool | OnCameraSetPrePosText (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition)
virtual bool | OnCameraSpecFuncUOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraSpecFuncUOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraSpecFuncVOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraSpecFuncVOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraSpecFuncXOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraSpecFuncXOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraSpecFuncYOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraSpecFuncYOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraStopAll (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraTextOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraTextOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraTourStart (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aTourID, const char *aTourName)
virtual bool | OnCameraTourStop (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraVersionOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraVersionOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraWashOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCameraWashOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnDefaultPosCallUp (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnDefaultPosClear (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnDefaultPosSave (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnFastSpeedOff (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnFastSpeedOn (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnFocusFar (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnFocusNear (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnFocusStop (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnIrisClose (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnIrisOpen (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnIrisStop (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnMoveToAbsolutePosition (HGscAction anAction, const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta)
virtual bool | OnMoveToBySpeed (HGscAction anAction, const TPlcMediaChannelID &aCamera, const double &aSpeedAlpha, const double &aSpeedBeta)
virtual bool | OnMoveToRelativePosition (HGscAction anAction, const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta)
virtual bool | OnPanAuto (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aModus)
virtual bool | OnPanLeft (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnPanRight (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnPanStop (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnPrePosCallUp (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition)
virtual bool | OnPrePosClear (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition)
virtual bool | OnPrePosSave (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition)
virtual bool | OnSetCameraText (HGscAction anAction, const TPlcMediaChannelID &aCamera, const char *aText)
virtual bool | OnTiltDown (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnTiltStop (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnTiltUp (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnZoomIn (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnZoomOut (HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
virtual bool | OnZoomStop (HGscAction anAction, const TPlcMediaChannelID &aCamera)
virtual bool | OnCaseClosed (HGscAction anAction)
Digital contacts.
virtual bool | OnCaseOpened (HGscAction anAction)
virtual bool | OnDigitalInput (HGscAction anAction, const TPlcMediaChannelID &aContact, const DigitalInputState aState)
virtual bool | OnIOI43ResetMainboard (HGscAction anAction)
virtual bool | OnIOI43Temperature (HGscAction anAction, const wchar_t *aID, const __int32 aTemperature)
virtual bool | OnIOI43WDActivate (HGscAction anAction)
virtual bool | OnIOI43WDDeactivate (HGscAction anAction)
virtual bool | OnIOI43WDTrigger (HGscAction anAction)
virtual bool | OnKeyPressed (HGscAction anAction, const SystemKey aKey)
virtual bool | OnKeyReleased (HGscAction anAction, const SystemKey aKey)
virtual bool | OnResetMainboard (HGscAction anAction)
virtual bool | OnSetDigitalOutput (HGscAction anAction, const TPlcMediaChannelID &aContact, const DigitalOutputState aState)
virtual bool | OnSetLED (HGscAction anAction, const SystemLED aLED, const DigitalOutputState aState)
virtual bool | OnSetLEDBlink (HGscAction anAction, const SystemLED aLED, const __int32 aLedTimeOnMs, const __int32 aLedTimeOffMs)
virtual bool | OnTemperature (HGscAction anAction, const IODeviceType aSourceType, const wchar_t *aID, const __int32 aTemperature)
virtual bool | OnWatchdogActivate (HGscAction anAction)
virtual bool | OnWatchdogDeactivate (HGscAction anAction)
virtual bool | OnWatchdogTrigger (HGscAction anAction)
virtual bool | OnDeviceFound (HGscAction anAction, const char *aType, const char *aName, const char *aSerial)
Device information.
virtual bool | OnDeviceNewFirmware (HGscAction anAction, const char *aType, const char *aName, const char *aSerial, const char *aFirmware)
virtual bool | OnDevicePluginError (HGscAction anAction, const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginError aErrorClass, const __int32 *aErrorCode, const char *aDescription)
virtual bool | OnDevicePluginState (HGscAction anAction, const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginState aState, const __int32 *aInternalState, const char *aDescription)
virtual bool | OnDeviceReattached (HGscAction anAction, const char *aType, const char *aName, const char *aSerial)
virtual bool | OnDeviceRemoved (HGscAction anAction, const char *aType, const char *aName, const char *aSerial)
virtual bool | OnACSAccessDenied (HGscAction anAction, const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp, const __int32 *aReason)
ATM/ACS.
virtual bool | OnACSAccessGranted (HGscAction anAction, const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp)
virtual bool | OnACSRawAnswer (HGscAction anAction, const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData)
virtual bool | OnACSRawData (HGscAction anAction, const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData)
virtual bool | OnATMRawAnswer (HGscAction anAction, const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData)
virtual bool | OnATMRawData (HGscAction anAction, const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData)
virtual bool | OnATMTransaction (HGscAction anAction, const wchar_t *aATMName, const bool aNewTransaction, const __int32 aPhotostep, const __int32 *aATMNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const __int64 *aTAN1, const __int64 *aTAN2, const TGLibDateTime *aTimeStamp1, const TGLibDateTime *aTimeStamp2, const double *aAmount, const wchar_t *aCurrency)
virtual bool | OnAbortAllAutoBackups (HGscAction anAction)
Backup actions.
virtual bool | OnAbortAutoBackup (HGscAction anAction, const TPlcResourceID &aSchedule)
virtual bool | OnAutoBackupCapacityMonitoringCapacityWarning (HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf)
virtual bool | OnAutoBackupCapacityMonitoringFileAutoDeleted (HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf, const __int64 &aFileSize, const wchar_t *aFileName)
virtual bool | OnAutoBackupCapacityMonitoringOutOfDiskSpace (HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf)
virtual bool | OnAutoBackupFileDone (HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
virtual bool | OnAutoBackupFileProgress (HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
virtual bool | OnAutoBackupFileStarted (HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName)
virtual bool | OnAutoBackupOperationDone (HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TGLibDateTime &aOperationStopTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 *aOperationErrorCode)
virtual bool | OnAutoBackupOperationStarted (HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit)
virtual bool | OnAutoBackupScheduleDone (HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const TGLibDateTime &aStopTime, const __int32 aOperationCount, const bool aTimerStart)
virtual bool | OnAutoBackupScheduleStarted (HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart)
virtual bool | OnBackupEvent (HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID &aDestination, const __int64 *aStartHintID, const __int64 *aStopHintID, const wchar_t *aSubfolder)
virtual bool | OnEventBackupDone (HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const __int32 *aOperationErrorCode)
virtual bool | OnEventBackupFileDone (HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
virtual bool | OnEventBackupFileProgress (HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
virtual bool | OnEventBackupFileStarted (HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName)
virtual bool | OnEventBackupStarted (HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime)
virtual bool | OnStartAutoBackup (HGscAction anAction, const TPlcResourceID &aSchedule)
virtual bool | OnSafebagClose (HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques)
Cash management actions.
virtual bool | OnSafebagData (HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques)
virtual bool | OnSafebagOpen (HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID)
virtual bool | OnSafebagPassingOfRiskData (HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
virtual bool | OnSafebagPassingOfRiskStart (HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
virtual bool | OnSafebagPassingOfRiskStop (HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
virtual bool | OnVCAlarmQueueConfirm (HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
Viewer actions.
virtual bool | OnVCAlarmQueueConfirmByInstance (HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
virtual bool | OnVCAlarmQueueConfirmByType (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
virtual bool | OnVCAlarmQueueRemove (HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
virtual bool | OnVCAlarmQueueRemoveByInstance (HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
virtual bool | OnVCAlarmQueueRemoveByType (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
virtual bool | OnVCAlarmQueueSelect (HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
virtual bool | OnVCAlarmQueueSelectByInstance (HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
virtual bool | OnVCAlarmQueueSelectByType (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
virtual bool | OnVCChangeSceneByName (HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
virtual bool | OnVCClearSceneByName (HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
virtual bool | OnVCFullMode (HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aFullMode, const bool aSensitiveAreaEnabled)
virtual bool | OnVCSetAudioLevel (HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int32 aAudioLevel)
virtual bool | OnVCShowViewerText (HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aShowText)
virtual bool | OnVCStretchMode (HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aStretchMode)
virtual bool | OnViewerChangeScene (HGscAction anAction, const TPlcMediaChannelID &aViewer)
virtual bool | OnViewerClear (HGscAction anAction, const TPlcMediaChannelID &aViewer)
virtual bool | OnViewerClearScene (HGscAction anAction, const TPlcMediaChannelID &aViewer)
virtual bool | OnViewerClearTextOutput (HGscAction anAction, const TPlcMediaChannelID &aViewer)
virtual bool | OnViewerConnect (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode)
virtual bool | OnViewerConnectLive (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel)
virtual bool | OnViewerExportPicture (HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aFilePath)
virtual bool | OnViewerJumpByTime (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const __int32 aTimeInSec)
virtual bool | OnViewerMaximize (HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aMaximize)
virtual bool | OnViewerPlayFromTime (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime &aTime)
virtual bool | OnViewerPrintPicture (HGscAction anAction, const TPlcMediaChannelID &aViewer)
virtual bool | OnViewerSelect (HGscAction anAction, const TPlcMediaChannelID &aViewer)
virtual bool | OnViewerSetPlayMode (HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerPlayMode aPlayMode, const __int32 aPlaySpeed)
virtual bool | OnViewerShowAlarmByInstance (HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID, const PlcViewerAlarmPlayMode aPlayMode)
virtual bool | OnViewerShowAlarmByKey (HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aForeignKey, const PlcViewerAlarmPlayMode aPlayMode)
virtual bool | OnViewerShowAlarmByType (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey, const PlcViewerAlarmPlayMode aPlayMode)
virtual bool | OnViewerSyncAudioAndVideo (HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aEnableSync)
virtual bool | OnViewerTextOutput (HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aText)
virtual bool | OnImageExportNotification (HGscAction anAction, const wchar_t *aUser, const wchar_t *aDestination, const PlcImageExportType aDestinationType, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aTimeEnd, const wchar_t *aChannels, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Viewer notifications.
virtual bool | OnSceneStoreModification (HGscAction anAction, const TPlcMediaChannelID &aViewer, const GUID &aSceneStoreID, const wchar_t *aSceneStoreName, const TGLibDateTime &aTimeStamp, const PlcSceneStoreModificationType aModificationType, const wchar_t *aUser, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnVCAlarmQueueNotification (HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmState aNotification, const __int64 &aAlarmID, const TPlcEventTypeID &aTypeID, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnVCSceneChanged (HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
virtual bool | OnViewerCleared (HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnViewerConnected (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnViewerPlayModeChanged (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime *aChannelTime, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnViewerSelectionChanged (HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
virtual bool | OnBarcodeData (HGscAction anAction, const wchar_t *aReaderName, const TGLibDateTime &aTimeStamp, const wchar_t *aBarcode)
POS.
virtual bool | OnFillingPumpStatus (HGscAction anAction, const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aPumpNo, const PlcPumpStatus aStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
virtual bool | OnInterfaceRawAnswer (HGscAction anAction, const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData)
virtual bool | OnInterfaceRawData (HGscAction anAction, const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData)
virtual bool | OnPOSData (HGscAction anAction, const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const wchar_t *aArticle, const double *aPrice, const __int32 *aUnits, const double *aPricePerUnit, const wchar_t *aLine1, const wchar_t *aLine2, const wchar_t *aLine3, const wchar_t *aLine4, const wchar_t *aLine5)
virtual bool | OnPOSStatus (HGscAction anAction, const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const PlcPOSStatus aStatus, const wchar_t *aDetails)
virtual bool | OnTerminalArticleData (HGscAction anAction, const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
virtual bool | OnTerminalPaymentData (HGscAction anAction, const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
virtual bool | OnCancelExport (HGscAction anAction, const GUID &aExportID, const PlcExportAbort aAbortFlag)
Remote export.
virtual bool | OnExportFinished (HGscAction anAction, const GUID &aExportID, const PlcExportSuccess aSuccess)
virtual bool | OnExportProgress (HGscAction anAction, const GUID &aExportID, const __int32 aProgress)
virtual bool | OnInitializeRemoteExport (HGscAction anAction, const TPlcMediaChannelID &aViewer, const GUID &aDevice)
virtual bool | OnSetExportMarker (HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcExportMarker aMarker)
virtual bool | OnStartRemoteExport (HGscAction anAction, const GUID &aExportID, const GUID &aDevice, const PlcBackupFormat aBackupFormat, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aSelectionBegin, const TGLibDateTime &aSelectionEnd, const wchar_t *aJobID)
virtual bool | OnStartSceneStore (HGscAction anAction, const GUID &aSceneStoreID, const wchar_t *aCutList, const __int64 &aPreHistoryLength, const __int64 &aRecordingLength)
virtual bool | OnSkidataControl (HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataControl aData)
SKIDATA.
virtual bool | OnSkidataDeviceEvent (HGscAction anAction, const wchar_t *aInterfaceName, const __int32 aDeviceID, const __int32 aEventCode)
virtual bool | OnSkidataEntry (HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataMsgCodeEntry aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
virtual bool | OnSkidataExit (HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataMsgCodeExit aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
virtual bool | OnSkidataTransaction (HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataMsgCodeTransaction aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
virtual bool | OnLPSPositionData (HGscAction anAction, const __int32 aTagID, const wchar_t *aScannerID, const __int64 &aX, const __int64 &aY, const __int64 *aZ, const double *aLatitude, const double *aLongitude, const __int32 aAreaID, const __int32 *aCellID, const PlcLpsStatus aStatus, const TGLibDateTime *aTimeStamp, const wchar_t *aData, const wchar_t *aAreaName)
LPS.
virtual bool | OnLPSQueryPosition (HGscAction anAction, const __int32 aTagID, const wchar_t *aScannerID, const wchar_t *aData)
virtual bool | OnGSCSVehicleAccessDenied (HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Supply chain security.
virtual bool | OnGSCSVehicleAccessExpired (HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const TGLibDateTime &aExpiringTime, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
virtual bool | OnGSCSVehicleAccessGranted (HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
virtual bool | OnGSCSVehicleAccessPending (HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
virtual bool | OnLogBarcodeData (HGscAction anAction, const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem)
virtual bool | OnLogBarcodeDataLPS (HGscAction anAction, const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const double *aX, const double *aY, const double *aZ, const __int32 *aLpsTagID, const PlcLpsStatus *aLpsStatus, const __int32 *aLpsCellID, const __int32 *aLpsAreaID, const __int32 *aUserParam, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem)
virtual bool | OnLogNPRRecognition (HGscAction anAction, const wchar_t *aPlateNo, const __int64 *aHash, const wchar_t *aCountry, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const PlcNPRRestriction *aRestriction, const wchar_t *aCategory)
virtual bool | OnLenelAccessEvent (HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int64 *aCardNumber, const LenelAccessResult *aAccessResult, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const __int32 *aAreaEnteredID, const __int32 *aAreaExitedID, const wchar_t *aAssetID, const bool *aCardholderEntered, const bool *aDuress, const __int32 *aElevatorFloor, const __int32 *aFacilityCode, const bool *aIsReadableCard, const __int32 *aIssueCode, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Lenel.
virtual bool | OnLenelFireEvent (HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aTroubleCode, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
virtual bool | OnLenelIntercomEvent (HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aIntercomData, const __int32 *aLineNumber, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
virtual bool | OnLenelRawData (HGscAction anAction, const TGLibDateTime &aTimeStamp, const wchar_t *aLenelData)
virtual bool | OnLenelRefreshNames (HGscAction anAction)
virtual bool | OnLenelSecurityEvent (HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
virtual bool | OnLenelVideoEvent (HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aChannel, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const TGLibDateTime *aStartTime, const TGLibDateTime *aEndTime, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
virtual bool | OnImexCapacityFileAutoDeleted (HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile, const __int64 &aTotalFileSize, const __int32 aNumberOfFiles)
Imex.
virtual bool | OnImexCapacityOutOfDiskSpace (HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile)
virtual bool | OnImexCapacityWarning (HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile)
virtual bool | OnImexExportEventImage (HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID *aDestination, const wchar_t *aFilePath)
virtual bool | OnImexExportImageFromDB (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath, const TGLibDateTime *aPictureTime)
virtual bool | OnImexExportImageFromLiveStream (HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath)
virtual bool | OnPPDeviceAlarm (HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPSensorKind aSensor, const PPAlarmState aState)
Perimeter protection.
virtual bool | OnPPDeviceInput (HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aInput, const PPAlarmState aState)
virtual bool | OnPPDeviceOffline (HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress)
virtual bool | OnPPDeviceOnline (HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress)
virtual bool | OnPPInterfaceOffline (HGscAction anAction, const wchar_t *aInterfaceID)
virtual bool | OnPPInterfaceOnline (HGscAction anAction, const wchar_t *aInterfaceID)
virtual bool | OnPPQueryInterface (HGscAction anAction, const wchar_t *aInterfaceID)
virtual bool | OnPPSetDeviceOutput (HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aOutput, const PPAlarmState aState)
virtual bool | OnPPSubcellAlarm (HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind aCable, const __int32 aSubcell, const PPAlarmState aState)
virtual bool | OnPPZoneAlarm (HGscAction anAction, const wchar_t *aZoneID, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind *aCable, const __int32 *aSubcell, const PPAlarmState aState)

Constructor & Destructor Documentation

GscActionsDispatcher::GscActionsDispatcher ( ) [inline]

Definition at line 29 of file GscActionsDispatcher.h.

virtual GscActionsDispatcher::~GscActionsDispatcher ( ) [inline, virtual]

Definition at line 30 of file GscActionsDispatcher.h.

Member Function Documentation

bool GscActionsDispatcher::Dispatch ( HGscAction Action )
virtual bool GscActionsDispatcher::OnUnregisteredMessage ( HGscAction Action ) [inline, protected, virtual]

Definition at line 36 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnBlockingFilterActivate | ( | HGscAction | anAction,
 |  | const wchar_t * | aFilter |
 | ) |  |  | [inline, protected, virtual]

System actions.

Definition at line 44 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnBlockingFilterDeactivate | ( | HGscAction | anAction,
 |  | const wchar_t * | aFilter |
 | ) |  |  | [inline, protected, virtual]

Definition at line 48 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCustomAction | ( | HGscAction | anAction,
 |  | const __int64 & | aInt,
 |  | const wchar_t * | aString |
 | ) |  |  | [inline, protected, virtual]

Definition at line 52 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDatabaseRecordingInfoRing | ( | HGscAction | anAction,
 |  | const PlcDatabaseRing | aDatabaseRing,
 |  | const bool | aNoVideoRecording,
 |  | const bool | aNoAudioRecording,
 |  | const bool | aNoRecordingAtAll,
 |  | const double & | aVideoSamplesPerSecond,
 |  | const double & | aVideoMBPerSecond,
 |  | const double & | aAudioSamplesPerSecond,
 |  | const double & | aAudioMBPerSecond,
 |  | const double & | aWriteWaitTimesPercent,
 |  | const __int64 & | aRingCapacity,
 |  | const TGLibDateTime & | aOldestItem,
 |  | const double * | aRecordingDepth,
 |  | const __int64 * | aEstimatedRequiredCapacity |
 | ) |  |  | [inline, protected, virtual]

Definition at line 57 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDatabaseRecordingInfoTotal | ( | HGscAction | anAction,
 |  | const bool | aNoVideoRecording,
 |  | const bool | aNoAudioRecording,
 |  | const bool | aNoRecordingAtAll,
 |  | const double & | aVideoSamplesPerSecond,
 |  | const double & | aVideoMBPerSecond,
 |  | const double & | aAudioSamplesPerSecond,
 |  | const double & | aAudioMBPerSecond,
 |  | const double & | aWriteWaitTimesPercent,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedCapacity,
 |  | const TGLibDateTime * | aOldestItem,
 |  | const double * | aRecordingDepth,
 |  | const __int64 * | aEstimatedRequiredCapacity,
 |  | const double * | aRequiredCapacityFactor,
 |  | const bool * | aRequiredCapacityAvailable |
 | ) |  |  | [inline, protected, virtual]

Definition at line 73 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDatabaseStarted | ( | HGscAction | anAction,
 |  | const PlcDatabaseStatus | aStatus,
 |  | const __int64 & | aTotalSize |
 | ) |  |  | [inline, protected, virtual]

Definition at line 92 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventRecordingChanged | ( | HGscAction | anAction,
 |  | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 97 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventStarted | ( | HGscAction | anAction,
 |  | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const __int64 * | aForeignKey |
 | ) |  |  | [inline, protected, virtual]

Definition at line 102 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventStopped | ( | HGscAction | anAction,
 |  | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 108 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnFRCNotification | ( | HGscAction | anAction,
 |  | const PlcFRCNotification | aNotification,
 |  | const __int32 * | aParam,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo |
 | ) |  |  | [inline, protected, virtual]

Definition at line 113 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGEMOSalarm | ( | HGscAction | anAction,
 |  | const __int64 & | aGEMOSkey,
 |  | const __int32 | aGEMOSint,
 |  | const wchar_t * | aGEMOSstr |
 | ) |  |  | [inline, protected, virtual]

Definition at line 120 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIPSwitchOperation | ( | HGscAction | anAction,
 |  | const IPSwitchOps | aOperation,
 |  | const wchar_t * | aPort,
 |  | const __int32 * | aParam |
 | ) |  |  | [inline, protected, virtual]

Definition at line 126 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnKillAllEvents ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 132 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnKillEvent | ( | HGscAction | anAction,
 |  | const TPlcEventTypeID & | aTypeID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 135 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnKillEventByID | ( | HGscAction | anAction,
 |  | const __int64 & | aEventID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 139 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLiveCheck | ( | HGscAction | anAction,
 |  | const __int64 & | aCounter,
 |  | const TGLibDateTime & | aDate |
 | ) |  |  | [inline, protected, virtual]

Definition at line 143 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnRedundantPowerFailure ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 148 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnRedundantPowerOk ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 151 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetClock | ( | HGscAction | anAction,
 |  | const TGLibDateTime & | aDate |
 | ) |  |  | [inline, protected, virtual]

Definition at line 154 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetupChanged | ( | HGscAction | anAction,
 |  | const wchar_t * | aUser,
 |  | const wchar_t * | aHost,
 |  | const TGLibDateTime & | aDate,
 |  | const PlcResourceKind | aResourceKind,
 |  | const TPlcEventTypeID & | aResourceID,
 |  | const PlcResourceChangeKind | aChangeKind,
 |  | const wchar_t * | aDetails,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 158 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetupUploadProgress | ( | HGscAction | anAction,
 |  | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const __int32 | aProgress,
 |  | const TGLibDateTime & | aDate |
 | ) |  |  | [inline, protected, virtual]

Definition at line 171 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetWatchdog | ( | HGscAction | anAction,
 |  | const __int32 | aTimeout |
 | ) |  |  | [inline, protected, virtual]

Definition at line 179 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSMRPViewerCleared ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 183 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSMRPViewerConnected | ( | HGscAction | anAction,
 |  | const wchar_t * | aServer,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 186 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSMTPMailSend | ( | HGscAction | anAction,
 |  | const wchar_t * | aSubject,
 |  | const wchar_t * | aTo,
 |  | const wchar_t * | aCc,
 |  | const wchar_t * | aBody,
 |  | const TPlcMediaChannelID * | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 191 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnStartEvent | ( | HGscAction | anAction,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const __int64 * | aForeignKey |
 | ) |  |  | [inline, protected, virtual]

Definition at line 199 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnStopAllEvents ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 204 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnStopEvent | ( | HGscAction | anAction,
 |  | const TPlcEventTypeID & | aTypeID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 207 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnStopEventByID | ( | HGscAction | anAction,
 |  | const __int64 & | aEventID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 211 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSystemError | ( | HGscAction | anAction,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo |
 | ) |  |  | [inline, protected, virtual]

Definition at line 215 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSystemInfo | ( | HGscAction | anAction,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo |
 | ) |  |  | [inline, protected, virtual]

Definition at line 223 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSystemSettingsChanged | ( | HGscAction | anAction,
 |  | const bool | aSetupChanged,
 |  | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const bool | aTimeRangeChanged,
 |  | const TPlcResourceID * | aTimeRange,
 |  | const bool | aLicenceChanged,
 |  | const TGLibDateTime & | aDate |
 | ) |  |  | [inline, protected, virtual]

Definition at line 230 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSystemStarted | ( | HGscAction | anAction,
 |  | const TGLibDateTime & | aDate |
 | ) |  |  | [inline, protected, virtual]

Definition at line 241 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSystemTerminating | ( | HGscAction | anAction,
 |  | const TGLibDateTime & | aDate,
 |  | const bool | aWindowsShutdown |
 | ) |  |  | [inline, protected, virtual]

Definition at line 245 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSystemWarning | ( | HGscAction | anAction,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo |
 | ) |  |  | [inline, protected, virtual]

Definition at line 250 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTransferBinaryBuffer | ( | HGscAction | anAction,
 |  | const GUID & | aInternalHandle,
 |  | const wchar_t * | aParameter |
 | ) |  |  | [inline, protected, virtual]

Definition at line 258 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTransferBinaryChannelBuffer | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const GUID & | aInternalHandle,
 |  | const wchar_t * | aParameter |
 | ) |  |  | [inline, protected, virtual]

Definition at line 263 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnUserLogin | ( | HGscAction | anAction,
 |  | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 269 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnUserLoginFailed | ( | HGscAction | anAction,
 |  | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const UserLoginFailureCode | aRejectReason,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 278 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnUserLogout | ( | HGscAction | anAction,
 |  | const wchar_t * | aUser1,
 |  | const wchar_t * | aUser2,
 |  | const wchar_t * | aHost,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 288 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnActivateExternalProcess | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const VideoSensorKind | aExternalSystem |
 | ) |  |  | [inline, protected, virtual]

Video control.

Definition at line 301 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChangeADParameterSet | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet |
 | ) |  |  | [inline, protected, virtual]

Definition at line 307 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChangeCameraProfile | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aHardwareModule,
 |  | const TPlcResourceID & | aCameraProfile |
 | ) |  |  | [inline, protected, virtual]

Definition at line 312 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChangeCPAParameterSet | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet |
 | ) |  |  | [inline, protected, virtual]

Definition at line 317 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChangeGTectParameterSet | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet |
 | ) |  |  | [inline, protected, virtual]

Definition at line 322 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChangeObtrackParameterSet | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet |
 | ) |  |  | [inline, protected, virtual]

Definition at line 327 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChangeVMDParameterSet | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID & | aParameterSet |
 | ) |  |  | [inline, protected, virtual]

Definition at line 332 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChannelError | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind * | aSensorType,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo |
 | ) |  |  | [inline, protected, virtual]

Definition at line 337 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChannelInfo | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind * | aSensorType,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo |
 | ) |  |  | [inline, protected, virtual]

Definition at line 347 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChannelLiveCheck | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const TGLibDateTime & | aTimeStamp |
 | ) |  |  | [inline, protected, virtual]

Definition at line 356 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnChannelWarning | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind * | aSensorType,
 |  | const PlcMessageSource | aSource,
 |  | const PlcMessageCode | aMessage,
 |  | const __int32 * | aWindowsError,
 |  | const wchar_t * | aDescription,
 |  | const char * | aXMLInfo |
 | ) |  |  | [inline, protected, virtual]

Definition at line 362 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCPAMeasurement | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 | aCorrelation |
 | ) |  |  | [inline, protected, virtual]

Definition at line 372 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGTectAnalyticsLiveCheck ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 377 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGTectDualSensorAlarm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 * | aSterileZoneNumber,
 |  | const __int32 * | aVirtualFenceNumber,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone,
 |  | const VMDCycle * | aVMDCycle,
 |  | const TPlcRect * | aAlarmArea |
 | ) |  |  | [inline, protected, virtual]

Definition at line 380 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGTectDualSensorAlarmFinished | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 390 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGTectSceneAlarm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const GTectSceneAlarmReason | aAlarmReason |
 | ) |  |  | [inline, protected, virtual]

Definition at line 394 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGTectSceneAlarmFinished | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const GTectSceneAlarmReason | aAlarmReason |
 | ) |  |  | [inline, protected, virtual]

Definition at line 399 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGTectVMXAlarm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 * | aSterileZoneNumber,
 |  | const __int32 * | aVirtualFenceNumber,
 |  | const __int32 * | aAlarmGroup,
 |  | const __int32 * | aTrackID,
 |  | const TPlcRect * | aAlarmArea |
 | ) |  |  | [inline, protected, virtual]

Definition at line 404 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGTectVMXAlarmFinished | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 413 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIASSettingsChanged | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 417 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIPCameraRawCommand | ( | HGscAction | anAction,
 |  | const wchar_t * | aURL,
 |  | const wchar_t * | aUser,
 |  | const wchar_t * | aPassword,
 |  | const wchar_t * | aPOST |
 | ) |  |  | [inline, protected, virtual]

Definition at line 422 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIPCamFailoverNotification | ( | HGscAction | anAction,
 |  | const wchar_t * | aPrimaryServer,
 |  | const wchar_t * | aSecondaryServer,
 |  | const TPlcMediaChannelID & | aPrimaryChannel,
 |  | const TPlcMediaChannelID & | aSecondaryChannel,
 |  | const wchar_t * | aCameraParameters |
 | ) |  |  | [inline, protected, virtual]

Definition at line 429 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIPCamFailoverRestore | ( | HGscAction | anAction,
 |  | const wchar_t * | aPrimaryServer,
 |  | const wchar_t * | aSecondaryServer,
 |  | const TPlcMediaChannelID & | aPrimaryChannel,
 |  | const TPlcMediaChannelID & | aSecondaryChannel,
 |  | const wchar_t * | aCameraParameters |
 | ) |  |  | [inline, protected, virtual]

Definition at line 437 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnMakeCPAReferenceImage | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 445 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnMediaChannelSetupInfo | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aParameter |
 | ) |  |  | [inline, protected, virtual]

Definition at line 449 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnNPRRawData | ( | HGscAction | anAction,
 |  | const wchar_t * | aPlateNo,
 |  | const wchar_t * | aCountry,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcRect & | aZoneRect,
 |  | const __int32 | aWeight,
 |  | const __int32 | aZoneState,
 |  | const __int32 | aZonePlace,
 |  | const __int32 | aSpeed,
 |  | const __int32 | aDirection,
 |  | const __int32 | aZoneIndex,
 |  | const bool | aCurBest,
 |  | const __int32 | aPlateWidth,
 |  | const __int32 | aPlateHeight,
 |  | const __int32 | aPlateAngle,
 |  | const __int32 | aSymHeight,
 |  | const wchar_t * | aType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 455 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnNPRRecognition | ( | HGscAction | anAction,
 |  | const wchar_t * | aPlateNo,
 |  | const wchar_t * | aCountry,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcRect & | aZoneRect,
 |  | const PlcNPRRestriction | aRestriction,
 |  | const wchar_t * | aCategory,
 |  | const __int32 | aSpeed,
 |  | const __int32 | aDirection,
 |  | const __int32 | aZoneIndex,
 |  | const wchar_t * | aType,
 |  | const __int32 | aWeight |
 | ) |  |  | [inline, protected, virtual]

Definition at line 475 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackChannelCounter | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const __int32 | aObjectDirection,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime * | aResetTimeStamp |
 | ) |  |  | [inline, protected, virtual]

Definition at line 490 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackChannelCounterThreshold | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const PlcObtrackExceedingDirection | aExceedingDirection,
 |  | const TGLibDateTime & | aTimeStamp |
 | ) |  |  | [inline, protected, virtual]

Definition at line 499 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackChannelSetCounter | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const TGLibDateTime & | aTimeStamp |
 | ) |  |  | [inline, protected, virtual]

Definition at line 507 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackFrameRawData | ( | HGscAction | anAction,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 | aBrightness,
 |  | const __int32 | aContrast |
 | ) |  |  | [inline, protected, virtual]

Definition at line 514 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackGroupCounter | ( | HGscAction | anAction,
 |  | const __int32 | aGroupId,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const __int32 | aObjectDirection,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime * | aResetTimeStamp,
 |  | const wchar_t * | aGroupName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 521 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackGroupCounterThreshold | ( | HGscAction | anAction,
 |  | const __int32 | aGroupId,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const PlcObtrackExceedingDirection | aExceedingDirection,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aGroupName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 531 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackGroupSetCounter | ( | HGscAction | anAction,
 |  | const __int32 | aGroupId,
 |  | const PlcObtrackCounterType | aCounterType,
 |  | const __int64 & | aCounterValue,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aGroupName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 540 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackObjectRawData | ( | HGscAction | anAction,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const __int32 | aArea,
 |  | const __int32 | aObjectID,
 |  | const PlcObtrackObjectStatus | aObjectStatus,
 |  | const PlcObtrackObjectClass | aObjectClass,
 |  | const __int32 * | aConfidence,
 |  | const TPlcRect * | aPosition,
 |  | const double * | aSpeed,
 |  | const __int32 * | aDuration,
 |  | const __int32 * | aDirection,
 |  | const double * | aSize,
 |  | const double * | aObjectWidth,
 |  | const double * | aObjectHeight,
 |  | const PlcObtrackProcessSize * | aProcessSize,
 |  | const char * | aGscNetName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 548 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnObtrackTunnelAlarm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const PlcTunnelAlarmReason | aAlarmReason,
 |  | const __int32 | aObjectID,
 |  | const __int32 | aAlarmAreaID,
 |  | const TPlcRect * | aObjectArea |
 | ) |  |  | [inline, protected, virtual]

Definition at line 567 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSensorAlarmFinished | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 576 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSensorInhibitAlarmFinished | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 581 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSensorInhibitVideoAlarm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const ADArea * | aADArea,
 |  | const __int32 * | aADCell,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone,
 |  | const VMDCycle * | aVMDCycle,
 |  | const TPlcRect * | aAlarmArea,
 |  | const PlcObtrackObjectClass * | aObjectClass |
 | ) |  |  | [inline, protected, virtual]

Definition at line 586 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSensorVideoAlarm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const ADArea * | aADArea,
 |  | const __int32 * | aADCell,
 |  | const VMDGroup * | aVMDGroup,
 |  | const __int32 * | aVMDZone,
 |  | const VMDCycle * | aVMDCycle,
 |  | const TPlcRect * | aAlarmArea,
 |  | const PlcObtrackObjectClass * | aObjectClass |
 | ) |  |  | [inline, protected, virtual]

Definition at line 598 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetClientVCA | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const GTectClientVCAType | aClientVCAType,
 |  | const bool | aEnabled |
 | ) |  |  | [inline, protected, virtual]

Definition at line 610 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetSystemTime | ( | HGscAction | anAction,
 |  | const TGLibDateTime & | aTimeStamp |
 | ) |  |  | [inline, protected, virtual]

Definition at line 616 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetTestPictureMode | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const bool | aMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 620 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCASetArmed | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const bool | aArmed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 625 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAStatusAnswer | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const bool | aArmed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 631 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAStatusRequest | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 637 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoContrastDetected | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 642 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoContrastFailed | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 646 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoSetImageBrightness | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const __int32 | aBrightness |
 | ) |  |  | [inline, protected, virtual]

Definition at line 650 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoSetImageContrast | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const __int32 | aContrast |
 | ) |  |  | [inline, protected, virtual]

Definition at line 656 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoSetImageSaturation | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSensorKind | aSensorType,
 |  | const __int32 | aSaturation |
 | ) |  |  | [inline, protected, virtual]

Definition at line 662 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoSourceChanged | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const VideoSignalNorm | aSignalNorm,
 |  | const VideoSignalType | aSignalType,
 |  | const VideoInterlaceType | aInterlaceType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 668 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoSyncDetected | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 675 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVideoSyncFailed | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 679 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnABCConnect | ( | HGscAction | anAction,
 |  | const wchar_t * | aAddress |
 | ) |  |  | [inline, protected, virtual]

Audio control.

Definition at line 687 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnABCDisconnect ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 691 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnABCPlayFile | ( | HGscAction | anAction,
 |  | const __int64 & | aFileID,
 |  | const wchar_t * | aFileName,
 |  | const bool | aAutoRepeat |
 | ) |  |  | [inline, protected, virtual]

Definition at line 694 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSensorAudioAlarm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 700 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoFocusOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Camera control.

Definition at line 708 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoFocusOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 712 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraApplyProfile | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const wchar_t * | aProfile |
 | ) |  |  | [inline, protected, virtual]

Definition at line 716 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraBacklightCompensationMode | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const PlcBacklightMode | aMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 721 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraClearPrePosText | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition |
 | ) |  |  | [inline, protected, virtual]

Definition at line 726 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraDayNightMode | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const PlcDayNightMode | aMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 731 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraLightOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 736 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraLightOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 740 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraManualIrisOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 744 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraManualIrisOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 748 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 752 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 756 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraPumpOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 760 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraPumpOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 764 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraRAWOutput | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const char * | aOutput |
 | ) |  |  | [inline, protected, virtual]

Definition at line 768 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSelectCharMode | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 773 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSetPrePosText | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition |
 | ) |  |  | [inline, protected, virtual]

Definition at line 778 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncUOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 783 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncUOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 787 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncVOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 791 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncVOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 795 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncXOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 799 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncXOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 803 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncYOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 807 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraSpecFuncYOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 811 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraStopAll | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 815 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraTextOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 819 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraTextOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 823 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraTourStart | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aTourID,
 |  | const char * | aTourName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 827 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraTourStop | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 833 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraVersionOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 837 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraVersionOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 841 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraWashOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 845 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCameraWashOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 849 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDefaultPosCallUp | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 853 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDefaultPosClear | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 857 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDefaultPosSave | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 861 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnFastSpeedOff | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 865 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnFastSpeedOn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 869 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnFocusFar | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 873 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnFocusNear | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 878 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnFocusStop | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 883 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIrisClose | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 887 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIrisOpen | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 891 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIrisStop | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 895 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnMoveToAbsolutePosition | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const double & | aAlpha,
 |  | const double & | aBeta,
 |  | const double & | aSpeedAlpha,
 |  | const double & | aSpeedBeta |
 | ) |  |  | [inline, protected, virtual]

Definition at line 899 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnMoveToBySpeed | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const double & | aSpeedAlpha,
 |  | const double & | aSpeedBeta |
 | ) |  |  | [inline, protected, virtual]

Definition at line 907 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnMoveToRelativePosition | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const double & | aAlpha,
 |  | const double & | aBeta,
 |  | const double & | aSpeedAlpha,
 |  | const double & | aSpeedBeta |
 | ) |  |  | [inline, protected, virtual]

Definition at line 913 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPanAuto | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aModus |
 | ) |  |  | [inline, protected, virtual]

Definition at line 921 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPanLeft | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 926 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPanRight | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 931 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPanStop | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 936 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPrePosCallUp | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition |
 | ) |  |  | [inline, protected, virtual]

Definition at line 940 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPrePosClear | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition |
 | ) |  |  | [inline, protected, virtual]

Definition at line 945 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPrePosSave | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aPosition |
 | ) |  |  | [inline, protected, virtual]

Definition at line 950 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetCameraText | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const char * | aText |
 | ) |  |  | [inline, protected, virtual]

Definition at line 955 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTiltDown | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 960 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTiltStop | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 965 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTiltUp | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 969 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnZoomIn | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 974 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnZoomOut | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera,
 |  | const __int32 | aSpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 979 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnZoomStop | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aCamera |
 | ) |  |  | [inline, protected, virtual]

Definition at line 984 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCaseClosed ( HGscAction anAction ) [inline, protected, virtual]

Digital contacts.

Definition at line 992 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCaseOpened ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 995 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDigitalInput | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aContact,
 |  | const DigitalInputState | aState |
 | ) |  |  | [inline, protected, virtual]

Definition at line 998 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIOI43ResetMainboard ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1003 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIOI43Temperature | ( | HGscAction | anAction,
 |  | const wchar_t * | aID,
 |  | const __int32 | aTemperature |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1006 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIOI43WDActivate ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1011 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIOI43WDDeactivate ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1014 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnIOI43WDTrigger ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1017 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnKeyPressed | ( | HGscAction | anAction,
 |  | const SystemKey | aKey |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1020 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnKeyReleased | ( | HGscAction | anAction,
 |  | const SystemKey | aKey |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1024 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnResetMainboard ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1028 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetDigitalOutput | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aContact,
 |  | const DigitalOutputState | aState |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1031 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetLED | ( | HGscAction | anAction,
 |  | const SystemLED | aLED,
 |  | const DigitalOutputState | aState |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1036 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetLEDBlink | ( | HGscAction | anAction,
 |  | const SystemLED | aLED,
 |  | const __int32 | aLedTimeOnMs,
 |  | const __int32 | aLedTimeOffMs |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1041 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTemperature | ( | HGscAction | anAction,
 |  | const IODeviceType | aSourceType,
 |  | const wchar_t * | aID,
 |  | const __int32 | aTemperature |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1047 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnWatchdogActivate ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1053 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnWatchdogDeactivate ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1056 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnWatchdogTrigger ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 1059 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDeviceFound | ( | HGscAction | anAction,
 |  | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial |
 | ) |  |  | [inline, protected, virtual]

Device information.

Definition at line 1066 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDeviceNewFirmware | ( | HGscAction | anAction,
 |  | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial,
 |  | const char * | aFirmware |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1072 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDevicePluginError | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const char * | aType,
 |  | const char * | aSubType,
 |  | const char * | aName,
 |  | const char * | aSerial,
 |  | const PlcPluginError | aErrorClass,
 |  | const __int32 * | aErrorCode,
 |  | const char * | aDescription |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1079 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDevicePluginState | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const char * | aType,
 |  | const char * | aSubType,
 |  | const char * | aName,
 |  | const char * | aSerial,
 |  | const PlcPluginState | aState,
 |  | const __int32 * | aInternalState,
 |  | const char * | aDescription |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1090 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDeviceReattached | ( | HGscAction | anAction,
 |  | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1101 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnDeviceRemoved | ( | HGscAction | anAction,
 |  | const char * | aType,
 |  | const char * | aName,
 |  | const char * | aSerial |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1107 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnACSAccessDenied | ( | HGscAction | anAction,
 |  | const wchar_t * | aACSName,
 |  | const __int32 * | aACSNo,
 |  | const __int64 * | aAccount,
 |  | const __int64 * | aBancCode,
 |  | const wchar_t * | aCardNo,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const __int32 * | aReason |
 | ) |  |  | [inline, protected, virtual]

ATM/ACS.

Definition at line 1117 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnACSAccessGranted | ( | HGscAction | anAction,
 |  | const wchar_t * | aACSName,
 |  | const __int32 * | aACSNo,
 |  | const __int64 * | aAccount,
 |  | const __int64 * | aBancCode,
 |  | const wchar_t * | aCardNo,
 |  | const TGLibDateTime * | aTimeStamp |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1127 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnACSRawAnswer | ( | HGscAction | anAction,
 |  | const wchar_t * | aACSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aACSData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1136 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnACSRawData | ( | HGscAction | anAction,
 |  | const wchar_t * | aACSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aACSData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1142 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnATMRawAnswer | ( | HGscAction | anAction,
 |  | const wchar_t * | aATMName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aATMData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1148 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnATMRawData | ( | HGscAction | anAction,
 |  | const wchar_t * | aATMName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aATMData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1154 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnATMTransaction | ( | HGscAction | anAction,
 |  | const wchar_t * | aATMName,
 |  | const bool | aNewTransaction,
 |  | const __int32 | aPhotostep,
 |  | const __int32 * | aATMNo,
 |  | const __int64 * | aAccount,
 |  | const __int64 * | aBancCode,
 |  | const wchar_t * | aCardNo,
 |  | const __int64 * | aTAN1,
 |  | const __int64 * | aTAN2,
 |  | const TGLibDateTime * | aTimeStamp1,
 |  | const TGLibDateTime * | aTimeStamp2,
 |  | const double * | aAmount,
 |  | const wchar_t * | aCurrency |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1160 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAbortAllAutoBackups ( HGscAction anAction ) [inline, protected, virtual]

Backup actions.

Definition at line 1180 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAbortAutoBackup | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1183 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupCapacityMonitoringCapacityWarning | ( | HGscAction | anAction,
 |  | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByGbf,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByGbf |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1187 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupCapacityMonitoringFileAutoDeleted | ( | HGscAction | anAction,
 |  | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByGbf,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByGbf,
 |  | const __int64 & | aFileSize,
 |  | const wchar_t * | aFileName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1198 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupCapacityMonitoringOutOfDiskSpace | ( | HGscAction | anAction,
 |  | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByGbf,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByGbf |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1211 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupFileDone | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1222 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupFileProgress | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1239 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupFileStarted | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1256 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupOperationDone | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TGLibDateTime & | aOperationStopTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const __int32 * | aOperationErrorCode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1272 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupOperationStarted | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart,
 |  | const __int32 | aOperationIndex,
 |  | const TGLibDateTime & | aOperationStartTime,
 |  | const TPlcResourceID & | aSource,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1288 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupScheduleDone | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1302 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnAutoBackupScheduleStarted | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime & | aEffectiveStartTime,
 |  | const __int32 | aOperationCount,
 |  | const bool | aTimerStart |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1311 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnBackupEvent | ( | HGscAction | anAction,
 |  | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 * | aStartHintID,
 |  | const __int64 * | aStopHintID,
 |  | const wchar_t * | aSubfolder |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1319 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventBackupDone | ( | HGscAction | anAction,
 |  | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const __int32 * | aOperationErrorCode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1328 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventBackupFileDone | ( | HGscAction | anAction,
 |  | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1340 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventBackupFileProgress | ( | HGscAction | anAction,
 |  | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName,
 |  | const __int64 & | aFileSize |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1353 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventBackupFileStarted | ( | HGscAction | anAction,
 |  | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime,
 |  | const __int32 | aFileIndex,
 |  | const wchar_t * | aFileName |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1366 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnEventBackupStarted | ( | HGscAction | anAction,
 |  | const GUID & | aJobID,
 |  | const TPlcEventTypeID & | aEventTypeID,
 |  | const __int64 & | aEventID,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aFileSizeLimit,
 |  | const __int64 & | aBandWidthLimit,
 |  | const TGLibDateTime & | aStartTime |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1378 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnStartAutoBackup | ( | HGscAction | anAction,
 |  | const TPlcResourceID & | aSchedule |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1388 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSafebagClose | ( | HGscAction | anAction,
 |  | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const double * | aDebit,
 |  | const double * | aTotal,
 |  | const double * | aDifference,
 |  | const bool * | aHasDifference,
 |  | const wchar_t * | aNotes,
 |  | const wchar_t * | aCoins,
 |  | const wchar_t * | aCheques |
 | ) |  |  | [inline, protected, virtual]

Cash management actions.

Definition at line 1396 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSafebagData | ( | HGscAction | anAction,
 |  | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const double * | aDebit,
 |  | const double * | aTotal,
 |  | const double * | aDifference,
 |  | const bool * | aHasDifference,
 |  | const wchar_t * | aNotes,
 |  | const wchar_t * | aCoins,
 |  | const wchar_t * | aCheques |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1412 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSafebagOpen | ( | HGscAction | anAction,
 |  | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1427 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSafebagPassingOfRiskData | ( | HGscAction | anAction,
 |  | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const __int32 | aUserID1,
 |  | const __int32 | aUserID2,
 |  | const __int32 * | aTourNumber,
 |  | const wchar_t * | aTargetWorkingPlace,
 |  | const wchar_t * | aPassingOfRiskType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1435 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSafebagPassingOfRiskStart | ( | HGscAction | anAction,
 |  | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const __int32 | aUserID1,
 |  | const __int32 | aUserID2,
 |  | const __int32 * | aTourNumber,
 |  | const wchar_t * | aTargetWorkingPlace,
 |  | const wchar_t * | aPassingOfRiskType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1448 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSafebagPassingOfRiskStop | ( | HGscAction | anAction,
 |  | const __int32 | aWorkingPlace,
 |  | const TGLibDateTime & | aStartTime,
 |  | const TGLibDateTime & | aStopTime,
 |  | const wchar_t * | aSafebagNo,
 |  | const wchar_t * | aSafebagInfo,
 |  | const SafebagStep | aStepID,
 |  | const __int32 | aUserID1,
 |  | const __int32 | aUserID2,
 |  | const __int32 * | aTourNumber,
 |  | const wchar_t * | aTargetWorkingPlace,
 |  | const wchar_t * | aPassingOfRiskType |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1461 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueConfirm | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode |
 | ) |  |  | [inline, protected, virtual]

Viewer actions.

Definition at line 1479 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueConfirmByInstance | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1484 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueConfirmByType | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1489 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueRemove | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1495 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueRemoveByInstance | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1500 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueRemoveByType | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1505 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueSelect | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1511 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueSelectByInstance | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1516 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueSelectByType | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const PlcViewerAlarmQueueSelection | aSelectionMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1521 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCChangeSceneByName | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aScene |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1527 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCClearSceneByName | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aScene |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1532 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCFullMode | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aFullMode,
 |  | const bool | aSensitiveAreaEnabled |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1537 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCSetAudioLevel | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const __int32 | aAudioLevel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1543 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCShowViewerText | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aShowText |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1548 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCStretchMode | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aStretchMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1553 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerChangeScene | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1558 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerClear | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1562 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerClearScene | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1566 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerClearTextOutput | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1570 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerConnect | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1574 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerConnectLive | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1580 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerExportPicture | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aFilePath |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1585 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerJumpByTime | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const __int32 | aTimeInSec |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1590 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerMaximize | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aMaximize |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1597 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerPlayFromTime | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const TGLibDateTime & | aTime |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1602 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerPrintPicture | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1609 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerSelect | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1613 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerSetPlayMode | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const __int32 | aPlaySpeed |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1617 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerShowAlarmByInstance | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aAlarmID,
 |  | const PlcViewerAlarmPlayMode | aPlayMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1623 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerShowAlarmByKey | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const __int64 & | aForeignKey,
 |  | const PlcViewerAlarmPlayMode | aPlayMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1629 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerShowAlarmByType | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const __int64 * | aForeignKey,
 |  | const PlcViewerAlarmPlayMode | aPlayMode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1635 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerSyncAudioAndVideo | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const bool | aEnableSync |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1642 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerTextOutput | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aText |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1647 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnImageExportNotification | ( | HGscAction | anAction,
 |  | const wchar_t * | aUser,
 |  | const wchar_t * | aDestination,
 |  | const PlcImageExportType | aDestinationType,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime * | aTimeEnd,
 |  | const wchar_t * | aChannels,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Viewer notifications.

Definition at line 1656 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSceneStoreModification | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const GUID & | aSceneStoreID,
 |  | const wchar_t * | aSceneStoreName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const PlcSceneStoreModificationType | aModificationType,
 |  | const wchar_t * | aUser,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1668 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCAlarmQueueNotification | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const PlcViewerAlarmState | aNotification,
 |  | const __int64 & | aAlarmID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1680 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnVCSceneChanged | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aScene |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1690 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerCleared | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1695 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerConnected | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1702 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerPlayModeChanged | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const TGLibDateTime * | aChannelTime,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1711 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnViewerSelectionChanged | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const PlcViewerPlayMode | aPlayMode,
 |  | const wchar_t * | aClientHost,
 |  | const PlcClientType * | aClientType,
 |  | const wchar_t * | aClientAccount |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1721 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnBarcodeData | ( | HGscAction | anAction,
 |  | const wchar_t * | aReaderName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aBarcode |
 | ) |  |  | [inline, protected, virtual]

POS.

Definition at line 1734 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnFillingPumpStatus | ( | HGscAction | anAction,
 |  | const wchar_t * | aTerminalName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const __int32 | aPumpNo,
 |  | const PlcPumpStatus | aStatus,
 |  | const double * | aAmount,
 |  | const double * | aPrice,
 |  | const wchar_t * | aDetails |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1740 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnInterfaceRawAnswer | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1750 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnInterfaceRawData | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1756 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPOSData | ( | HGscAction | anAction,
 |  | const wchar_t * | aPOSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aArticle,
 |  | const double * | aPrice,
 |  | const __int32 * | aUnits,
 |  | const double * | aPricePerUnit,
 |  | const wchar_t * | aLine1,
 |  | const wchar_t * | aLine2,
 |  | const wchar_t * | aLine3,
 |  | const wchar_t * | aLine4,
 |  | const wchar_t * | aLine5 |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1762 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPOSStatus | ( | HGscAction | anAction,
 |  | const wchar_t * | aPOSName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const PlcPOSStatus | aStatus,
 |  | const wchar_t * | aDetails |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1776 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTerminalArticleData | ( | HGscAction | anAction,
 |  | const wchar_t * | aTerminalName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const __int32 | aCashierStation,
 |  | const __int32 * | aPumpNo,
 |  | const bool | aAlarmStatus,
 |  | const double * | aAmount,
 |  | const double * | aPrice,
 |  | const wchar_t * | aDetails |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1783 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnTerminalPaymentData | ( | HGscAction | anAction,
 |  | const wchar_t * | aTerminalName,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const __int32 | aCashierStation,
 |  | const __int32 * | aPumpNo,
 |  | const bool | aAlarmStatus,
 |  | const double * | aAmount,
 |  | const double * | aPrice,
 |  | const wchar_t * | aDetails |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1794 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnCancelExport | ( | HGscAction | anAction,
 |  | const GUID & | aExportID,
 |  | const PlcExportAbort | aAbortFlag |
 | ) |  |  | [inline, protected, virtual]

Remote export.

Definition at line 1809 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnExportFinished | ( | HGscAction | anAction,
 |  | const GUID & | aExportID,
 |  | const PlcExportSuccess | aSuccess |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1814 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnExportProgress | ( | HGscAction | anAction,
 |  | const GUID & | aExportID,
 |  | const __int32 | aProgress |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1819 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnInitializeRemoteExport | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const GUID & | aDevice |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1824 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSetExportMarker | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aViewer,
 |  | const PlcExportMarker | aMarker |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1829 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnStartRemoteExport | ( | HGscAction | anAction,
 |  | const GUID & | aExportID,
 |  | const GUID & | aDevice,
 |  | const PlcBackupFormat | aBackupFormat,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TGLibDateTime & | aSelectionBegin,
 |  | const TGLibDateTime & | aSelectionEnd,
 |  | const wchar_t * | aJobID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1834 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnStartSceneStore | ( | HGscAction | anAction,
 |  | const GUID & | aSceneStoreID,
 |  | const wchar_t * | aCutList,
 |  | const __int64 & | aPreHistoryLength,
 |  | const __int64 & | aRecordingLength |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1844 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSkidataControl | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataControl | aData |
 | ) |  |  | [inline, protected, virtual]

SKIDATA.

Definition at line 1855 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSkidataDeviceEvent | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceName,
 |  | const __int32 | aDeviceID,
 |  | const __int32 | aEventCode |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1860 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSkidataEntry | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataMsgCodeEntry | aMessageCode,
 |  | const wchar_t * | aTranscactionID,
 |  | const __int32 | aCarParkNo,
 |  | const __int32 | aDeviceID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1866 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSkidataExit | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataMsgCodeExit | aMessageCode,
 |  | const wchar_t * | aTranscactionID,
 |  | const __int32 | aCarParkNo,
 |  | const __int32 | aDeviceID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1874 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnSkidataTransaction | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceName,
 |  | const PlcSkidataMsgCodeTransaction | aMessageCode,
 |  | const wchar_t * | aTranscactionID,
 |  | const __int32 | aCarParkNo,
 |  | const __int32 | aDeviceID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1882 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLPSPositionData | ( | HGscAction | anAction,
 |  | const __int32 | aTagID,
 |  | const wchar_t * | aScannerID,
 |  | const __int64 & | aX,
 |  | const __int64 & | aY,
 |  | const __int64 * | aZ,
 |  | const double * | aLatitude,
 |  | const double * | aLongitude,
 |  | const __int32 | aAreaID,
 |  | const __int32 * | aCellID,
 |  | const PlcLpsStatus | aStatus,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aData,
 |  | const wchar_t * | aAreaName |
 | ) |  |  | [inline, protected, virtual]

LPS.

Definition at line 1894 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLPSQueryPosition | ( | HGscAction | anAction,
 |  | const __int32 | aTagID,
 |  | const wchar_t * | aScannerID,
 |  | const wchar_t * | aData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1910 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGSCSVehicleAccessDenied | ( | HGscAction | anAction,
 |  | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection |
 | ) |  |  | [inline, protected, virtual]

Supply chain security.

Definition at line 1920 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGSCSVehicleAccessExpired | ( | HGscAction | anAction,
 |  | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const TGLibDateTime & | aExpiringTime,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1932 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGSCSVehicleAccessGranted | ( | HGscAction | anAction,
 |  | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1945 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnGSCSVehicleAccessPending | ( | HGscAction | anAction,
 |  | const __int32 | aSequenceID,
 |  | const wchar_t * | aPlateNo,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aCompanyCategory,
 |  | const wchar_t * | aCompanyName,
 |  | const wchar_t * | aReason,
 |  | const wchar_t * | aTrafficLane,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TrafficDirection * | aDirection |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1957 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLogBarcodeData | ( | HGscAction | anAction,
 |  | const wchar_t * | aBarcode,
 |  | const __int64 * | aHash,
 |  | const wchar_t * | aScanner,
 |  | const __int64 * | aAreaID,
 |  | const wchar_t * | aAreaName,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aOrder,
 |  | const wchar_t * | aShipment,
 |  | const wchar_t * | aItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1969 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLogBarcodeDataLPS | ( | HGscAction | anAction,
 |  | const wchar_t * | aBarcode,
 |  | const __int64 * | aHash,
 |  | const wchar_t * | aScanner,
 |  | const __int64 * | aAreaID,
 |  | const wchar_t * | aAreaName,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const double * | aX,
 |  | const double * | aY,
 |  | const double * | aZ,
 |  | const __int32 * | aLpsTagID,
 |  | const PlcLpsStatus * | aLpsStatus,
 |  | const __int32 * | aLpsCellID,
 |  | const __int32 * | aLpsAreaID,
 |  | const __int32 * | aUserParam,
 |  | const wchar_t * | aOrder,
 |  | const wchar_t * | aShipment,
 |  | const wchar_t * | aItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 1982 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLogNPRRecognition | ( | HGscAction | anAction,
 |  | const wchar_t * | aPlateNo,
 |  | const __int64 * | aHash,
 |  | const wchar_t * | aCountry,
 |  | const TPlcMediaChannelID * | aChannel,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const PlcNPRRestriction * | aRestriction,
 |  | const wchar_t * | aCategory |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2003 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLenelAccessEvent | ( | HGscAction | anAction,
 |  | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int64 * | aCardNumber,
 |  | const LenelAccessResult * | aAccessResult,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const __int32 * | aAreaEnteredID,
 |  | const __int32 * | aAreaExitedID,
 |  | const wchar_t * | aAssetID,
 |  | const bool * | aCardholderEntered,
 |  | const bool * | aDuress,
 |  | const __int32 * | aElevatorFloor,
 |  | const __int32 * | aFacilityCode,
 |  | const bool * | aIsReadableCard,
 |  | const __int32 * | aIssueCode,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText |
 | ) |  |  | [inline, protected, virtual]

Lenel.

Definition at line 2017 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLenelFireEvent | ( | HGscAction | anAction,
 |  | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int32 * | aTroubleCode,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2042 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLenelIntercomEvent | ( | HGscAction | anAction,
 |  | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int32 * | aIntercomData,
 |  | const __int32 * | aLineNumber,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2057 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLenelRawData | ( | HGscAction | anAction,
 |  | const TGLibDateTime & | aTimeStamp,
 |  | const wchar_t * | aLenelData |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2073 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLenelRefreshNames ( HGscAction anAction ) [inline, protected, virtual]

Definition at line 2078 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLenelSecurityEvent | ( | HGscAction | anAction,
 |  | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2081 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnLenelVideoEvent | ( | HGscAction | anAction,
 |  | const LenelEventID * | aID,
 |  | const wchar_t * | aPanel,
 |  | const wchar_t * | aDevice,
 |  | const __int32 * | aSecondaryDevice,
 |  | const __int32 * | aChannel,
 |  | const LenelEventType * | aType,
 |  | const __int32 * | aSubType,
 |  | const wchar_t * | aDescription,
 |  | const __int32 * | aSerialNumber,
 |  | const TGLibDateTime * | aTimeStamp,
 |  | const TGLibDateTime * | aStartTime,
 |  | const TGLibDateTime * | aEndTime,
 |  | const wchar_t * | aCommServerHostName,
 |  | const wchar_t * | aEventText |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2095 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnImexCapacityFileAutoDeleted | ( | HGscAction | anAction,
 |  | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByImageFile,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByImageFile,
 |  | const __int64 & | aTotalFileSize,
 |  | const __int32 | aNumberOfFiles |
 | ) |  |  | [inline, protected, virtual]

Imex.

Definition at line 2116 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnImexCapacityOutOfDiskSpace | ( | HGscAction | anAction,
 |  | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByImageFile,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByImageFile |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2129 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnImexCapacityWarning | ( | HGscAction | anAction,
 |  | const ABCapacityWarning | aWarning,
 |  | const TPlcResourceID & | aDestination,
 |  | const __int64 & | aTotalCapacity,
 |  | const __int64 & | aFreeCapacity,
 |  | const __int64 & | aAllocatedByImageFile,
 |  | const __int32 | aPercentFree,
 |  | const __int32 | aPercentAllocated,
 |  | const __int32 | aPercentAllocatedByImageFile |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2140 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnImexExportEventImage | ( | HGscAction | anAction,
 |  | const __int64 & | aEventID,
 |  | const TPlcEventTypeID & | aTypeID,
 |  | const TPlcResourceID * | aDestination,
 |  | const wchar_t * | aFilePath |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2151 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnImexExportImageFromDB | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID * | aDestination,
 |  | const wchar_t * | aFilePath,
 |  | const TGLibDateTime * | aPictureTime |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2158 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnImexExportImageFromLiveStream | ( | HGscAction | anAction,
 |  | const TPlcMediaChannelID & | aChannel,
 |  | const TPlcResourceID * | aDestination,
 |  | const wchar_t * | aFilePath |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2165 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPDeviceAlarm | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const PPSensorKind | aSensor,
 |  | const PPAlarmState | aState |
 | ) |  |  | [inline, protected, virtual]

Perimeter protection.

Definition at line 2175 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPDeviceInput | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const __int32 | aInput,
 |  | const PPAlarmState | aState |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2182 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPDeviceOffline | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2189 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPDeviceOnline | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2194 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPInterfaceOffline | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2199 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPInterfaceOnline | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2203 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPQueryInterface | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2207 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPSetDeviceOutput | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const __int32 | aOutput,
 |  | const PPAlarmState | aState |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2211 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPSubcellAlarm | ( | HGscAction | anAction,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const PPCableKind | aCable,
 |  | const __int32 | aSubcell,
 |  | const PPAlarmState | aState |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2218 of file GscActionsDispatcher.h.

virtual bool GscActionsDispatcher::OnPPZoneAlarm | ( | HGscAction | anAction,
 |  | const wchar_t * | aZoneID,
 |  | const wchar_t * | aInterfaceID,
 |  | const __int32 | aDeviceAddress,
 |  | const PPCableKind * | aCable,
 |  | const __int32 * | aSubcell,
 |  | const PPAlarmState | aState |
 | ) |  |  | [inline, protected, virtual]

Definition at line 2226 of file GscActionsDispatcher.h.


GSC actions: GUID Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

GUID Class Reference

Detailed Description

GUID value.

Standard type

Definition at line 29 of file stl.txt.


GSC actions: TGLibDateTime Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGLibDateTime Class Reference

Detailed Description

Date time value.

See GscDBI definition for more details.

Definition at line 34 of file stl.txt.

Collaboration diagram for TGLibDateTime:
[legend]

List of all members.


GSC actions: TGscActionClassInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TGscActionClassInfo Struct Reference
[Basic enumeration]

Detailed Description

action class info

Definition at line 1838 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscActionClassInfo:
[legend]

List of all members.

Public Attributes

GscActionClass ActionClass
action class
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string
size_t | Reserved
reserved, set to 0

Member Data Documentation

GscActionClass TGscActionClassInfo::ActionClass

action class

Definition at line 1840 of file GscActionsTypes.h.

const char* TGscActionClassInfo::NameA

internal name as ANSI string

Definition at line 1844 of file GscActionsTypes.h.

const wchar_t* TGscActionClassInfo::NameW

internal name as UNICODE string

Definition at line 1845 of file GscActionsTypes.h.

size_t TGscActionClassInfo::Reserved

reserved, set to 0

Definition at line 1846 of file GscActionsTypes.h.


GSC actions: TGscActionClassPlainInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TGscActionClassPlainInfo Struct Reference
[Basic enumeration]

Detailed Description

action class plain info

Definition at line 1850 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscActionClassPlainInfo:
[legend]
Collaboration diagram for TGscActionClassPlainInfo:
[legend]

List of all members.

Public Attributes

const char * | PlainNameA
plain name as ANSI string
const char * | PlainNameU
plain name as ANSI string using UTF8 encoding
const wchar_t * | PlainNameW
plain name as UNICODE string
const char * | DescriptionA
description as ANSI string
const char * | DescriptionU
description as ANSI string using UTF8 encoding
const wchar_t * | DescriptionW
description as UNICODE string
GscActionClass ActionClass
action class
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string
size_t | Reserved
reserved, set to 0

Member Data Documentation

const char* TGscActionClassPlainInfo::PlainNameA

plain name as ANSI string

Definition at line 1852 of file GscActionsTypes.h.

const char* TGscActionClassPlainInfo::PlainNameU

plain name as ANSI string using UTF8 encoding

Definition at line 1853 of file GscActionsTypes.h.

const wchar_t* TGscActionClassPlainInfo::PlainNameW

plain name as UNICODE string

Definition at line 1854 of file GscActionsTypes.h.

const char* TGscActionClassPlainInfo::DescriptionA

description as ANSI string

Definition at line 1855 of file GscActionsTypes.h.

const char* TGscActionClassPlainInfo::DescriptionU

description as ANSI string using UTF8 encoding

Definition at line 1856 of file GscActionsTypes.h.

const wchar_t* TGscActionClassPlainInfo::DescriptionW

description as UNICODE string

Definition at line 1857 of file GscActionsTypes.h.

GscActionClass TGscActionClassInfo::ActionClass [inherited]

action class

Definition at line 1840 of file GscActionsTypes.h.

const char* TGscActionClassInfo::NameA [inherited]

internal name as ANSI string

Definition at line 1844 of file GscActionsTypes.h.

const wchar_t* TGscActionClassInfo::NameW [inherited]

internal name as UNICODE string

Definition at line 1845 of file GscActionsTypes.h.

size_t TGscActionClassInfo::Reserved [inherited]

reserved, set to 0

Definition at line 1846 of file GscActionsTypes.h.


GSC actions: TGscActionInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TGscActionInfo Struct Reference
[Basic enumeration]

Detailed Description

action info

Definition at line 1866 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscActionInfo:
[legend]
Collaboration diagram for TGscActionInfo:
[legend]

List of all members.

Public Member Functions

bool | DisableOnMatch () const
bool | DisableMatchBy () const

Public Attributes

GscActionClass ActionClass
action class
GscActionCode ActionCode
action code
unsigned __int32 | ActionSetupMask
setup visibility mask
unsigned __int32 | NumberOfParameters
number of parameters
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string

Member Function Documentation

bool TGscActionInfo::DisableOnMatch ( ) const [inline]

Definition at line 1875 of file GscActionsTypes.h.

bool TGscActionInfo::DisableMatchBy ( ) const [inline]

Definition at line 1876 of file GscActionsTypes.h.

Member Data Documentation

GscActionClass TGscActionInfo::ActionClass

action class

Definition at line 1868 of file GscActionsTypes.h.

GscActionCode TGscActionInfo::ActionCode

action code

Definition at line 1869 of file GscActionsTypes.h.

unsigned __int32 TGscActionInfo::ActionSetupMask

setup visibility mask

Definition at line 1870 of file GscActionsTypes.h.

unsigned __int32 TGscActionInfo::NumberOfParameters

number of parameters

Definition at line 1871 of file GscActionsTypes.h.

const char* TGscActionInfo::NameA

internal name as ANSI string

Definition at line 1872 of file GscActionsTypes.h.

const wchar_t* TGscActionInfo::NameW

internal name as UNICODE string

Definition at line 1873 of file GscActionsTypes.h.


GSC actions: TGscActionPlainInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TGscActionPlainInfo Struct Reference
[Basic enumeration]

Detailed Description

action plain info

Definition at line 1880 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscActionPlainInfo:
[legend]
Collaboration diagram for TGscActionPlainInfo:
[legend]

List of all members.

Public Member Functions

bool | DisableOnMatch () const
bool | DisableMatchBy () const

Public Attributes

const char * | PlainNameA
plain name as ANSI string
const char * | PlainNameU
plain name as ANSI string using UTF8 encoding
const wchar_t * | PlainNameW
plain name as UNICODE string
const char * | DescriptionA
description as ANSI string
const char * | DescriptionU
description as ANSI string using UTF8 encoding
const wchar_t * | DescriptionW
description as UNICODE string
GscActionClass ActionClass
action class
GscActionCode ActionCode
action code
unsigned __int32 | ActionSetupMask
setup visibility mask
unsigned __int32 | NumberOfParameters
number of parameters
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string

Member Function Documentation

bool TGscActionInfo::DisableOnMatch ( ) const [inline, inherited]

Definition at line 1875 of file GscActionsTypes.h.

bool TGscActionInfo::DisableMatchBy ( ) const [inline, inherited]

Definition at line 1876 of file GscActionsTypes.h.

Member Data Documentation

const char* TGscActionPlainInfo::PlainNameA

plain name as ANSI string

Definition at line 1882 of file GscActionsTypes.h.

const char* TGscActionPlainInfo::PlainNameU

plain name as ANSI string using UTF8 encoding

Definition at line 1883 of file GscActionsTypes.h.

const wchar_t* TGscActionPlainInfo::PlainNameW

plain name as UNICODE string

Definition at line 1884 of file GscActionsTypes.h.

const char* TGscActionPlainInfo::DescriptionA

description as ANSI string

Definition at line 1885 of file GscActionsTypes.h.

const char* TGscActionPlainInfo::DescriptionU

description as ANSI string using UTF8 encoding

Definition at line 1886 of file GscActionsTypes.h.

const wchar_t* TGscActionPlainInfo::DescriptionW

description as UNICODE string

Definition at line 1887 of file GscActionsTypes.h.

GscActionClass TGscActionInfo::ActionClass [inherited]

action class

Definition at line 1868 of file GscActionsTypes.h.

GscActionCode TGscActionInfo::ActionCode [inherited]

action code

Definition at line 1869 of file GscActionsTypes.h.

unsigned __int32 TGscActionInfo::ActionSetupMask [inherited]

setup visibility mask

Definition at line 1870 of file GscActionsTypes.h.

unsigned __int32 TGscActionInfo::NumberOfParameters [inherited]

number of parameters

Definition at line 1871 of file GscActionsTypes.h.

const char* TGscActionInfo::NameA [inherited]

internal name as ANSI string

Definition at line 1872 of file GscActionsTypes.h.

const wchar_t* TGscActionInfo::NameW [inherited]

internal name as UNICODE string

Definition at line 1873 of file GscActionsTypes.h.


GSC actions: TGscEnumInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TGscEnumInfo Struct Reference
[Basic enumeration]

Detailed Description

enum value info

Definition at line 1916 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscEnumInfo:
[legend]
Collaboration diagram for TGscEnumInfo:
[legend]

List of all members.

Public Attributes

GscParameterType EnumType
enum type
__int32 EnumValue
enum value
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string

Member Data Documentation

GscParameterType TGscEnumInfo::EnumType

enum type

Definition at line 1918 of file GscActionsTypes.h.

__int32 TGscEnumInfo::EnumValue

enum value

Definition at line 1919 of file GscActionsTypes.h.

const char* TGscEnumInfo::NameA

internal name as ANSI string

Definition at line 1920 of file GscActionsTypes.h.

const wchar_t* TGscEnumInfo::NameW

internal name as UNICODE string

Definition at line 1921 of file GscActionsTypes.h.


GSC actions: TGscEnumPlainInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TGscEnumPlainInfo Struct Reference
[Basic enumeration]

Detailed Description

enum value plain info

Definition at line 1925 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscEnumPlainInfo:
[legend]
Collaboration diagram for TGscEnumPlainInfo:
[legend]

List of all members.

Public Attributes

const char * | PlainNameA
plain name as ANSI string
const char * | PlainNameU
plain name as ANSI string using UTF8 encoding
const wchar_t * | PlainNameW
plain name as UNICODE string
size_t | Reserved
reserved, set to 0
GscParameterType EnumType
enum type
__int32 EnumValue
enum value
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string

Member Data Documentation

const char* TGscEnumPlainInfo::PlainNameA

plain name as ANSI string

Definition at line 1927 of file GscActionsTypes.h.

const char* TGscEnumPlainInfo::PlainNameU

plain name as ANSI string using UTF8 encoding

Definition at line 1928 of file GscActionsTypes.h.

const wchar_t* TGscEnumPlainInfo::PlainNameW

plain name as UNICODE string

Definition at line 1929 of file GscActionsTypes.h.

size_t TGscEnumPlainInfo::Reserved

reserved, set to 0

Definition at line 1930 of file GscActionsTypes.h.

GscParameterType TGscEnumInfo::EnumType [inherited]

enum type

Definition at line 1918 of file GscActionsTypes.h.

__int32 TGscEnumInfo::EnumValue [inherited]

enum value

Definition at line 1919 of file GscActionsTypes.h.

const char* TGscEnumInfo::NameA [inherited]

internal name as ANSI string

Definition at line 1920 of file GscActionsTypes.h.

const wchar_t* TGscEnumInfo::NameW [inherited]

internal name as UNICODE string

Definition at line 1921 of file GscActionsTypes.h.


GSC actions: TGscParameterInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TGscParameterInfo Struct Reference
[Basic enumeration]

Detailed Description

parameter info

Definition at line 1891 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscParameterInfo:
[legend]
Collaboration diagram for TGscParameterInfo:
[legend]

List of all members.

Public Member Functions

bool | DisableOnMatch () const
bool | DisableMatchBy () const

Public Attributes

GscParameterType ParameterType
parameter type
GscParameterView ParameterView
parameter view (role)
unsigned __int32 | ParameterSetupMask
setup visibility mask
unsigned __int32 | Reserved
reserved, set to 0
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string

Member Function Documentation

bool TGscParameterInfo::DisableOnMatch ( ) const [inline]

Definition at line 1900 of file GscActionsTypes.h.

bool TGscParameterInfo::DisableMatchBy ( ) const [inline]

Definition at line 1901 of file GscActionsTypes.h.

Member Data Documentation

GscParameterType TGscParameterInfo::ParameterType

parameter type

Definition at line 1893 of file GscActionsTypes.h.

GscParameterView TGscParameterInfo::ParameterView

parameter view (role)

Definition at line 1894 of file GscActionsTypes.h.

unsigned __int32 TGscParameterInfo::ParameterSetupMask

setup visibility mask

Definition at line 1895 of file GscActionsTypes.h.

unsigned __int32 TGscParameterInfo::Reserved

reserved, set to 0

Definition at line 1896 of file GscActionsTypes.h.

const char* TGscParameterInfo::NameA

internal name as ANSI string

Definition at line 1897 of file GscActionsTypes.h.

const wchar_t* TGscParameterInfo::NameW

internal name as UNICODE string

Definition at line 1898 of file GscActionsTypes.h.


GSC actions: TGscParameterPlainInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TGscParameterPlainInfo Struct Reference
[Basic enumeration]

Detailed Description

parameter plain info

Definition at line 1905 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Inheritance diagram for TGscParameterPlainInfo:
[legend]
Collaboration diagram for TGscParameterPlainInfo:
[legend]

List of all members.

Public Member Functions

bool | DisableOnMatch () const
bool | DisableMatchBy () const

Public Attributes

const char * | PlainNameA
plain name as ANSI string
const char * | PlainNameU
plain name as ANSI string using UTF8 encoding
const wchar_t * | PlainNameW
plain name as UNICODE string
const char * | DescriptionA
description as ANSI string
const char * | DescriptionU
description as ANSI string using UTF8 encoding
const wchar_t * | DescriptionW
description as UNICODE string
GscParameterType ParameterType
parameter type
GscParameterView ParameterView
parameter view (role)
unsigned __int32 | ParameterSetupMask
setup visibility mask
unsigned __int32 | Reserved
reserved, set to 0
const char * | NameA
internal name as ANSI string
const wchar_t * | NameW
internal name as UNICODE string

Member Function Documentation

bool TGscParameterInfo::DisableOnMatch ( ) const [inline, inherited]

Definition at line 1900 of file GscActionsTypes.h.

bool TGscParameterInfo::DisableMatchBy ( ) const [inline, inherited]

Definition at line 1901 of file GscActionsTypes.h.

Member Data Documentation

const char* TGscParameterPlainInfo::PlainNameA

plain name as ANSI string

Definition at line 1907 of file GscActionsTypes.h.

const char* TGscParameterPlainInfo::PlainNameU

plain name as ANSI string using UTF8 encoding

Definition at line 1908 of file GscActionsTypes.h.

const wchar_t* TGscParameterPlainInfo::PlainNameW

plain name as UNICODE string

Definition at line 1909 of file GscActionsTypes.h.

const char* TGscParameterPlainInfo::DescriptionA

description as ANSI string

Definition at line 1910 of file GscActionsTypes.h.

const char* TGscParameterPlainInfo::DescriptionU

description as ANSI string using UTF8 encoding

Definition at line 1911 of file GscActionsTypes.h.

const wchar_t* TGscParameterPlainInfo::DescriptionW

description as UNICODE string

Definition at line 1912 of file GscActionsTypes.h.

GscParameterType TGscParameterInfo::ParameterType [inherited]

parameter type

Definition at line 1893 of file GscActionsTypes.h.

GscParameterView TGscParameterInfo::ParameterView [inherited]

parameter view (role)

Definition at line 1894 of file GscActionsTypes.h.

unsigned __int32 TGscParameterInfo::ParameterSetupMask [inherited]

setup visibility mask

Definition at line 1895 of file GscActionsTypes.h.

unsigned __int32 TGscParameterInfo::Reserved [inherited]

reserved, set to 0

Definition at line 1896 of file GscActionsTypes.h.

const char* TGscParameterInfo::NameA [inherited]

internal name as ANSI string

Definition at line 1897 of file GscActionsTypes.h.

const wchar_t* TGscParameterInfo::NameW [inherited]

internal name as UNICODE string

Definition at line 1898 of file GscActionsTypes.h.


GSC actions: TPlcActionEventDataRecord Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TPlcActionEventDataRecord Struct Reference
[GscPlcEvents]

Detailed Description

Structure to access action fields as event data fields.

Definition at line 1678 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Collaboration diagram for TPlcActionEventDataRecord:
[legend]

List of all members.

Public Member Functions

TPlcActionEventDataRecord ()
void | Clear ()

Public Attributes

unsigned __int32 | StructSize
size of the structure
unsigned __int32 | EventDataKind
data kind
__int64 EventDataID
primary key of the entry
__int64 EventID
primary key of the corresponding event
GLib::TGLibDateTime | EventDataTime
entry time stamp
const __int32 * | EventInt32_A
int32 field A
const __int32 * | EventInt32_B
int32 field B
const __int32 * | EventInt32_C
int32 field C
const __int32 * | EventInt32_D
int32 field D
const __int64 * | EventInt64_A
int64 field A
const __int64 * | EventInt64_B
int64 field B
const __int64 * | EventInt64_C
int64 field C
const __int64 * | EventInt64_D
int64 field D
const double * | EventDouble_A
float field A
const double * | EventDouble_B
float field B
const GLib::TGLibDateTime * | EventTime_A
date time field A
const GLib::TGLibDateTime * | EventTime_B
date time field B
size_t | EventString_A_Size
size of the string
const wchar_t * | EventString_A
text field A
size_t | EventString_B_Size
size of the string
const wchar_t * | EventString_B
text field B
size_t | EventDataSize
size of the BLOB
const void * | EventData
BLOB.

Constructor & Destructor Documentation

TPlcActionEventDataRecord::TPlcActionEventDataRecord ( ) [inline]

Definition at line 1712 of file GscActionsTypes.h.

Member Function Documentation

void TPlcActionEventDataRecord::Clear ( ) [inline]

Definition at line 1717 of file GscActionsTypes.h.

Member Data Documentation

unsigned __int32 TPlcActionEventDataRecord::StructSize

size of the structure

Definition at line 1680 of file GscActionsTypes.h.

unsigned __int32 TPlcActionEventDataRecord::EventDataKind

data kind

Definition at line 1681 of file GscActionsTypes.h.

__int64 TPlcActionEventDataRecord::EventDataID

primary key of the entry

Definition at line 1683 of file GscActionsTypes.h.

__int64 TPlcActionEventDataRecord::EventID

primary key of the corresponding event

Definition at line 1684 of file GscActionsTypes.h.

GLib::TGLibDateTime TPlcActionEventDataRecord::EventDataTime

entry time stamp

Definition at line 1685 of file GscActionsTypes.h.

const __int32* TPlcActionEventDataRecord::EventInt32_A

int32 field A

Definition at line 1687 of file GscActionsTypes.h.

const __int32* TPlcActionEventDataRecord::EventInt32_B

int32 field B

Definition at line 1688 of file GscActionsTypes.h.

const __int32* TPlcActionEventDataRecord::EventInt32_C

int32 field C

Definition at line 1689 of file GscActionsTypes.h.

const __int32* TPlcActionEventDataRecord::EventInt32_D

int32 field D

Definition at line 1690 of file GscActionsTypes.h.

const __int64* TPlcActionEventDataRecord::EventInt64_A

int64 field A

Definition at line 1692 of file GscActionsTypes.h.

const __int64* TPlcActionEventDataRecord::EventInt64_B

int64 field B

Definition at line 1693 of file GscActionsTypes.h.

const __int64* TPlcActionEventDataRecord::EventInt64_C

int64 field C

Definition at line 1694 of file GscActionsTypes.h.

const __int64* TPlcActionEventDataRecord::EventInt64_D

int64 field D

Definition at line 1695 of file GscActionsTypes.h.

const double* TPlcActionEventDataRecord::EventDouble_A

float field A

Definition at line 1697 of file GscActionsTypes.h.

const double* TPlcActionEventDataRecord::EventDouble_B

float field B

Definition at line 1698 of file GscActionsTypes.h.

const GLib::TGLibDateTime* TPlcActionEventDataRecord::EventTime_A

date time field A

Definition at line 1700 of file GscActionsTypes.h.

const GLib::TGLibDateTime* TPlcActionEventDataRecord::EventTime_B

date time field B

Definition at line 1701 of file GscActionsTypes.h.

size_t TPlcActionEventDataRecord::EventString_A_Size

size of the string

Definition at line 1703 of file GscActionsTypes.h.

const wchar_t* TPlcActionEventDataRecord::EventString_A

text field A

Definition at line 1704 of file GscActionsTypes.h.

size_t TPlcActionEventDataRecord::EventString_B_Size

size of the string

Definition at line 1706 of file GscActionsTypes.h.

const wchar_t* TPlcActionEventDataRecord::EventString_B

text field B

Definition at line 1707 of file GscActionsTypes.h.

size_t TPlcActionEventDataRecord::EventDataSize

size of the BLOB

Definition at line 1709 of file GscActionsTypes.h.

const void* TPlcActionEventDataRecord::EventData

BLOB.

Definition at line 1710 of file GscActionsTypes.h.


GSC actions: TPlcEventTypeID Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TPlcEventTypeID Struct Reference
[Basic types]

Detailed Description

Event type.

Definition at line 1563 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Collaboration diagram for TPlcEventTypeID:
[legend]

List of all members.

Public Member Functions

TPlcEventTypeID ()
TPlcEventTypeID (const __int64 &anEventTypeID, const wchar_t *anEventName)

Public Attributes

__int64 EventTypeID
event type ID
const wchar_t * | EventName
event name
size_t | Reserved
reserved, set to 0

Constructor & Destructor Documentation

TPlcEventTypeID::TPlcEventTypeID ( ) [inline]

Definition at line 1569 of file GscActionsTypes.h.

TPlcEventTypeID::TPlcEventTypeID | ( | const __int64 & | anEventTypeID,
 |  | const wchar_t * | anEventName |
 | ) |  |  | [inline]

Definition at line 1572 of file GscActionsTypes.h.

Member Data Documentation

__int64 TPlcEventTypeID::EventTypeID

event type ID

Definition at line 1565 of file GscActionsTypes.h.

const wchar_t* TPlcEventTypeID::EventName

event name

Definition at line 1566 of file GscActionsTypes.h.

size_t TPlcEventTypeID::Reserved

reserved, set to 0

Definition at line 1567 of file GscActionsTypes.h.


GSC actions: TPlcLastError Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TPlcLastError Struct Reference
[Error handling]

Detailed Description

Structure which holds last error info.

Definition at line 116 of file GscActions.h.

#include <GscActions.h>

List of all members.

Public Attributes

int | ErrorClass
error class
unsigned int | ErrorCode
error code
const char * | ClassName
name of the exception class
const char * | ErrorMessageA
error message as ANSI string
const wchar_t * | ErrorMessageW
error message as UNICODE string
const char * | XMLInfo
optional description as XML string

Member Data Documentation

int TPlcLastError::ErrorClass

error class

Definition at line 118 of file GscActions.h.

unsigned int TPlcLastError::ErrorCode

error code

Definition at line 119 of file GscActions.h.

const char* TPlcLastError::ClassName

name of the exception class

Definition at line 120 of file GscActions.h.

const char* TPlcLastError::ErrorMessageA

error message as ANSI string

Definition at line 121 of file GscActions.h.

const wchar_t* TPlcLastError::ErrorMessageW

error message as UNICODE string

Definition at line 122 of file GscActions.h.

const char* TPlcLastError::XMLInfo

optional description as XML string

Definition at line 123 of file GscActions.h.


GSC actions: TPlcMediaChannelID Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TPlcMediaChannelID Struct Reference
[Basic types]

Detailed Description

Media channel.

Definition at line 1528 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Collaboration diagram for TPlcMediaChannelID:
[legend]

List of all members.

Public Member Functions

TPlcMediaChannelID ()
TPlcMediaChannelID (__int32 aGlobalNo)
TPlcMediaChannelID (const __int64 &aChannelID, const wchar_t *aChannelName, __int32 aGlobalNo)

Public Attributes

__int64 ChannelID
media channel ID
const wchar_t * ChannelName
media channel name
__int32 GlobalNo
assigned global No

Constructor & Destructor Documentation

TPlcMediaChannelID::TPlcMediaChannelID ( ) [inline]

Definition at line 1537 of file GscActionsTypes.h.

TPlcMediaChannelID::TPlcMediaChannelID ( __int32 aGlobalNo ) [inline]

Definition at line 1540 of file GscActionsTypes.h.

TPlcMediaChannelID::TPlcMediaChannelID | ( | const __int64 & | aChannelID,
 |  | const wchar_t * | aChannelName,
 |  | __int32 | aGlobalNo |
 | ) |  |  | [inline]

Definition at line 1549 of file GscActionsTypes.h.

Member Data Documentation

__int64 TPlcMediaChannelID::ChannelID

media channel ID

Definition at line 1530 of file GscActionsTypes.h.

const wchar_t* TPlcMediaChannelID::ChannelName

media channel name

Definition at line 1531 of file GscActionsTypes.h.

__int32 TPlcMediaChannelID::GlobalNo

assigned global No

Definition at line 1532 of file GscActionsTypes.h.


GSC actions: TPlcRect Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TPlcRect Struct Reference
[Basic types]

Detailed Description

PLC rect.

Definition at line 1603 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

List of all members.

Public Member Functions

TPlcRect (__int16 aTop=0, __int16 aLeft=0, __int16 aBottom=0, __int16 aRight=0)
bool | operator== (const TPlcRect &Other) const
bool | operator!= (const TPlcRect &Other) const

Public Attributes

__int16 | Top
top
__int16 | Left
left
__int16 | Bottom
bottom
__int16 | Right
right

Constructor & Destructor Documentation

TPlcRect::TPlcRect | ( | __int16 | aTop = 0,
 |  | __int16 | aLeft = 0,
 |  | __int16 | aBottom = 0,
 |  | __int16 | aRight = 0 |
 | ) |  |  | [inline]

Definition at line 1610 of file GscActionsTypes.h.

Member Function Documentation

bool TPlcRect::operator== ( const TPlcRect & Other ) const [inline]

Definition at line 1618 of file GscActionsTypes.h.

bool TPlcRect::operator!= ( const TPlcRect & Other ) const [inline]

Definition at line 1625 of file GscActionsTypes.h.

Member Data Documentation

__int16 TPlcRect::Top

top

Definition at line 1605 of file GscActionsTypes.h.

__int16 TPlcRect::Left

left

Definition at line 1606 of file GscActionsTypes.h.

__int16 TPlcRect::Bottom

bottom

Definition at line 1607 of file GscActionsTypes.h.

__int16 TPlcRect::Right

right

Definition at line 1608 of file GscActionsTypes.h.


GSC actions: TPlcResourceID Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

TPlcResourceID Struct Reference
[Basic types]

Detailed Description

Resource ID.

Definition at line 1583 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Collaboration diagram for TPlcResourceID:
[legend]

List of all members.

Public Member Functions

TPlcResourceID ()
TPlcResourceID (const GUID &aResourceID, const wchar_t *aResourceName)

Public Attributes

GUID ResourceID
resource ID
const wchar_t * | ResourceName
resource name
size_t | Reserved
reserved, set to 0

Constructor & Destructor Documentation

TPlcResourceID::TPlcResourceID ( ) [inline]

Definition at line 1589 of file GscActionsTypes.h.

TPlcResourceID::TPlcResourceID | ( | const GUID & | aResourceID,
 |  | const wchar_t * | aResourceName |
 | ) |  |  | [inline]

Definition at line 1592 of file GscActionsTypes.h.

Member Data Documentation

GUID TPlcResourceID::ResourceID

resource ID

Definition at line 1585 of file GscActionsTypes.h.

const wchar_t* TPlcResourceID::ResourceName

resource name

Definition at line 1586 of file GscActionsTypes.h.

size_t TPlcResourceID::Reserved

reserved, set to 0

Definition at line 1587 of file GscActionsTypes.h.


GSC actions: TPlcUpdateActionInfoCallback Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TPlcUpdateActionInfoCallback Struct Reference
[Basic types]

Detailed Description

update callback definition

Definition at line 1649 of file GscActionsTypes.h.

#include <GscActionsTypes.h>

Collaboration diagram for TPlcUpdateActionInfoCallback:
[legend]

List of all members.

Public Attributes

unsigned __int32 Version
struct version
TUpdateMediaChannelID UpdateVideoInput
update video input
TUpdateMediaChannelID UpdateVideoOutput
update video output
TUpdateMediaChannelID UpdateInputContact
update input contact
TUpdateMediaChannelID UpdateOutputContact
update output contact
TUpdateEventTypeID UpdateEventType
update event type
TUpdateResourceID UpdateResource
update resources like time range, AB schedule, AB destination
TUpdateResChannelID UpdateParameterSet
update resources like AD / VMD / CPA / OBTRACK parameter sets

Member Data Documentation

unsigned __int32 TPlcUpdateActionInfoCallback::Version

struct version

Definition at line 1651 of file GscActionsTypes.h.

TUpdateMediaChannelID TPlcUpdateActionInfoCallback::UpdateVideoInput

update video input

Definition at line 1655 of file GscActionsTypes.h.

TUpdateMediaChannelID TPlcUpdateActionInfoCallback::UpdateVideoOutput

update video output

Definition at line 1656 of file GscActionsTypes.h.

TUpdateMediaChannelID TPlcUpdateActionInfoCallback::UpdateInputContact

update input contact

Definition at line 1657 of file GscActionsTypes.h.

TUpdateMediaChannelID TPlcUpdateActionInfoCallback::UpdateOutputContact

update output contact

Definition at line 1658 of file GscActionsTypes.h.

TUpdateEventTypeID TPlcUpdateActionInfoCallback::UpdateEventType

update event type

Definition at line 1659 of file GscActionsTypes.h.

TUpdateResourceID TPlcUpdateActionInfoCallback::UpdateResource

update resources like time range, AB schedule, AB destination

Definition at line 1660 of file GscActionsTypes.h.

TUpdateResChannelID TPlcUpdateActionInfoCallback::UpdateParameterSet

update resources like AD / VMD / CPA / OBTRACK parameter sets

Definition at line 1661 of file GscActionsTypes.h.


GSC actions: Hierarchical Index

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • __int32
  • __int64
  • bool
  • CGscMessage
    • CGscAction
    • CGscMatchAction
  • double
  • GscActionsDispatcher
  • GUID
  • TGLibDateTime
  • TGscActionClassInfo
    • TGscActionClassPlainInfo
  • TGscActionInfo
    • TGscActionPlainInfo
  • TGscEnumInfo
    • TGscEnumPlainInfo
  • TGscParameterInfo
    • TGscParameterPlainInfo
  • TPlcActionEventDataRecord
  • TPlcEventTypeID
  • TPlcLastError
  • TPlcMediaChannelID
  • TPlcRect
  • TPlcResourceID
  • TPlcUpdateActionInfoCallback


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActionClass : TGscActionClassInfo , TGscActionInfo
  • ActionCode : TGscActionInfo
  • ActionSetupMask : TGscActionInfo


GSC actions: Namespace Index

  • Namespace List

Namespace List

Here is a list of all namespaces with brief descriptions:
GscPLC PLC namespace


GSC actions: GscPLC Namespace Reference

  • Namespace List

GscPLC Namespace Reference

Detailed Description

PLC namespace.

All interface functions and classes of GscActions.DLL and GscActionsDlgs.DLL belong to this namespace.


GSC actions: File Index

  • File List
  • File Members

File List

Here is a list of all files with brief descriptions:
GscActions.h [code] | Interface unit for GscActions.DLL
GscActionsDispatcher.h [code] | This dispatcher class allows you to implement your own derived dispatcher by overriding virtual functions
GscActionsTypes.h [code] | Types used by GscActions and GscActionsDlgs DLLs


GSC actions: GscActions.h File Reference

  • File List
  • File Members
Classes | Defines | Typedefs | Functions | Variables

GscActions.h File Reference

Detailed Description

Interface unit for GscActions.DLL.

Copyright (c) 2004 - 2010 Geutebrueck GmbH. All rights reserved.

This file is part of the GEVISCOPE SDK.

This software is provided "as is" without express or implied warranty, and with no claim as to its suitability for any purpose.

Definition in file GscActions.h.

#include "GscActionsTypes.h"
#include "GLibDateTime.h"
Include dependency graph for GscActions.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | TPlcLastError
Structure which holds last error info. More...
class | CGscMessage
GeViScope message. More...
class | CGscAction
GeViScope action. More...
class | CGscMatchAction
GeViScope match action. More...

Defines

#define | GSCACTDLLCALL __declspec(dllimport)
export style declaration.
#define | GscAct_GetActionClassByName GscAct_GetActionClassByNameA
#define | GscAct_GetActionCodeByName GscAct_GetActionCodeByNameA
#define | GscAct_CreateFromTextBuffer GscAct_CreateFromTextBufferA
#define | GscAct_StoreToTextBuffer GscAct_StoreToTextBufferA
#define | GscAct_GetActionName GscAct_GetActionNameA
#define | GscAct_GetActionPlainName GscAct_GetActionPlainNameA
#define | GscMatchAct_GetActionName GscMatchAct_GetActionNameA
#define | GscMatchAct_GetActionPlainName GscMatchAct_GetActionPlainNameA
#define | GscMatchAct_GetDescription GscMatchAct_GetDescriptionA
#define | GscMatchAct_SetDescription GscMatchAct_SetDescriptionA
#define | GscMatchAct_GetComment GscMatchAct_GetCommentA
#define | GscMatchAct_SetComment GscMatchAct_SetCommentA

Typedefs

typedef CGscMessage * | HGscMessage
typedef const CGscMessage * | ConstHGscMessage
typedef CGscAction * | HGscAction
typedef const CGscAction * | ConstHGscAction
typedef CGscMatchAction * | HGscMatchAction
typedef const CGscMatchAction * | ConstHGscMatchAction
typedef void(__stdcall * | TPlcGetEventDataCallback )(void *Instance, int Index, const wchar_t *Name, const wchar_t *Value)
Get event data callback.

Functions

GSCACTDLLCALL int __stdcall | GscAct_InterfaceVersion ()
Get the interface version number of the used GscActions.dll.
GSCACTDLLCALL const char *__stdcall | GscAct_InterfaceDate ()
Get the interface release date of the used GscActions.dll.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfOpenHandles ()
Get the number of open action/message handles.
GSCACTDLLCALL bool __stdcall | GscAct_GetLastError (TPlcLastError &LastError)
Get information about the last occured error in the current thread.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfActionClasses ()
Get number of action classes.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateActionClasses (TGscActionClassPlainInfo List[], unsigned int Count)
Get the list of action classes.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionClassInfo (TGscActionClassPlainInfo &Info, GscActionClass ActionClass)
Get the action class info.
GSCACTDLLCALL bool __stdcall | GscAct_SetActionClassPlainInfo (const TGscActionClassPlainInfo &Info)
Set the plain part of action class info.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfActions ()
Get number of actions.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateActions (TGscActionPlainInfo List[], unsigned int Count)
Get the list of actions.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionInfo (TGscActionPlainInfo &Info, GscActionCode ActionCode)
Get the action info.
GSCACTDLLCALL bool __stdcall | GscAct_SetActionPlainInfo (const TGscActionPlainInfo &Info)
Set the plain part of action info.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfActionParameters (GscActionCode ActionCode)
Get the number of parameters of the given action.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateActionParameters (TGscParameterPlainInfo List[], unsigned int Count, GscActionCode ActionCode)
Get the list of parameters.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionParameterInfo (TGscParameterPlainInfo &Info, GscActionCode ActionCode, unsigned int Index)
Get the parameter info.
GSCACTDLLCALL bool __stdcall | GscAct_SetActionParameterPlainInfo (const TGscParameterPlainInfo &Info, GscActionCode ActionCode, unsigned int Index)
Set the plain part of parameter info.
GSCACTDLLCALL bool __stdcall | GscAct_GetMatchActionDescriptionInfo (TGscParameterPlainInfo &Info)
Get the info about match action description.
GSCACTDLLCALL bool __stdcall | GscAct_SetMatchActionDescriptionPlainInfo (const TGscParameterPlainInfo &Info)
Set the plain part of match action description info.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetNumberOfEnumValues (GscParameterType EnumType)
Get the number of available values for enum type.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateEnumValues (TGscEnumPlainInfo List[], unsigned int Count, GscParameterType EnumType)
Get the list of enum values.
GSCACTDLLCALL bool __stdcall | GscAct_GetEnumValueInfo (TGscEnumPlainInfo &Info, GscParameterType EnumType, __int32 Value)
Get the enum info.
GSCACTDLLCALL bool __stdcall | GscAct_SetEnumValuePlainInfo (const TGscEnumPlainInfo &Info)
Set the plain part of the enum info.
GSCACTDLLCALL GscActionClass
__stdcall 		GscAct_GetActionClassByNameA (const char *Name)
Get action class by name.
GSCACTDLLCALL GscActionClass
__stdcall 		GscAct_GetActionClassByNameW (const wchar_t *Name)
Get action class by name.
GSCACTDLLCALL GscActionCode
__stdcall 		GscAct_GetActionCodeByNameA (const char *Name)
Get action code by name.
GSCACTDLLCALL GscActionCode
__stdcall 		GscAct_GetActionCodeByNameW (const wchar_t *Name)
Get action code by name.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_GetInternalIndexByCode (GscActionCode Code)
Get internal index by action code.
GSCACTDLLCALL GscActionCode
__stdcall 		GscAct_GetActionCodeByIndex (unsigned int Index)
Get action code by internal index.
GSCACTDLLCALL bool __stdcall | GscAct_GetNativeTranslation (bool &IsNativeTranslation)
Get native translation.
GSCACTDLLCALL bool __stdcall | GscAct_SetNativeTranslation (bool IsNativeTranslation)
Set native translation.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionEventData (ConstHGscAction anAction, TPlcActionEventDataRecord &EventRecord, bool &DataComplete)
Get action event data.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionEventData (ConstHGscMatchAction anAction, TPlcActionEventDataRecord &EventRecord, bool &DataComplete)
Get match action event data.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionEventDescription (const TPlcActionEventDataRecord &EventRecord, void *Instance, TPlcGetEventDataCallback Callback, bool &DataComplete)
Get action event description lines.
GSCACTDLLCALL HGscAction __stdcall | GscAct_RestoreActionFromEventData (const TPlcActionEventDataRecord &EventRecord)
Restore actions from event data.
GSCACTDLLCALL HGscMatchAction
__stdcall 		GscMatchAct_RestoreActionFromEventData (const TPlcActionEventDataRecord &EventRecord)
Restore match action from event data.
GSCACTDLLCALL bool __stdcall | GscAct_GetEventDescriptionInfo (TGscActionPlainInfo &Info)
Enumerate event fields.
GSCACTDLLCALL bool __stdcall | GscAct_SetEventDescriptionPlainInfo (const TGscActionPlainInfo &Info)
Set the plain part of the event field info.
GSCACTDLLCALL unsigned int
__stdcall 		GscAct_EnumerateEventFields (TGscParameterPlainInfo List[], unsigned int Count)
Get the list of parameters.
GSCACTDLLCALL bool __stdcall | GscAct_GetEventFieldInfo (TGscParameterPlainInfo &Info, unsigned int Index)
Get the parameter info.
GSCACTDLLCALL bool __stdcall | GscAct_SetEventFieldPlainInfo (const TGscParameterPlainInfo &Info, unsigned int Index)
Set the plain part of parameter info.
GSCACTDLLCALL bool __stdcall | GscAct_CloseHandle (HGscMessage aMessage)
Close message handle.
GSCACTDLLCALL bool __stdcall | GscAct_DuplicateHandle (HGscMessage aMessage)
Duplicate message handle.
GSCACTDLLCALL bool __stdcall | GscAct_CloneHandle (ConstHGscMessage aMessage, HGscMessage &ClonedMessage)
Clone message handle.
GSCACTDLLCALL bool __stdcall | GscAct_GetReferenceCounter (ConstHGscMessage aMessage, int &RefCounter)
Get reference counter.
GSCACTDLLCALL bool __stdcall | GscAct_GetMessageClass (ConstHGscMessage aMessage, GscMessageClass &aClass)
Get class of the message.
GSCACTDLLCALL bool __stdcall | GscAct_GetInternalIndex (ConstHGscMessage aMessage, int &InternalIndex)
Get internal index of the message.
GSCACTDLLCALL bool __stdcall | GscAct_GetInternalData (ConstHGscMessage aMessage, void *&InternalData)
Get internal data.
GSCACTDLLCALL bool __stdcall | GscAct_SetInternalData (HGscMessage aMessage, void *InternalData)
Set internal data.
GSCACTDLLCALL bool __stdcall | GscAct_GetMessageFlags (ConstHGscMessage aMessage, unsigned __int32 &Flags)
Get flags of the message.
GSCACTDLLCALL bool __stdcall | GscAct_SetMessageFlags (HGscMessage aMessage, unsigned __int32 Flags)
Set flags of the message.
GSCACTDLLCALL bool __stdcall | GscAct_Equal (ConstHGscMessage aMessage1, ConstHGscMessage aMessage2, bool &Result)
Compare messages.
GSCACTDLLCALL HGscMessage __stdcall | GscAct_CreateFromBinBuffer (const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass, unsigned int *ReadBytes)
Create message from different buffers.
GSCACTDLLCALL HGscMessage __stdcall | GscAct_CreateFromTextBufferA (const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass, bool UseUTF8Encoding, unsigned int *ReadChars)
Create message from ANSI text buffer.
GSCACTDLLCALL HGscMessage __stdcall | GscAct_CreateFromTextBufferW (const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass, bool UseUTF8Encoding, unsigned int *ReadChars)
Create message from UNICODE text buffer.
GSCACTDLLCALL bool __stdcall | GscAct_StoreToBinBuffer (ConstHGscMessage aMessage, void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten)
Write message to the binary buffer.
GSCACTDLLCALL bool __stdcall | GscAct_StoreToTextBufferA (ConstHGscMessage aMessage, char *Buffer, unsigned int BufferSize, bool OutputAsPlainText, bool UseUTF8Encoding, unsigned int *CharsWritten)
Write message to the text buffer as ANSI string.
GSCACTDLLCALL bool __stdcall | GscAct_StoreToTextBufferW (ConstHGscMessage aMessage, wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText, bool UseUTF8Encoding, unsigned int *CharsWritten)
Write message to the text buffer as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionClass (ConstHGscAction anAction, GscActionClass &ActionClass)
Get class of the action.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionCode (ConstHGscAction anAction, GscActionCode &ActionCode)
Get code of the action.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionNameA (ConstHGscAction anAction, const char *&ActionName)
Get action name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionNameW (ConstHGscAction anAction, const wchar_t *&ActionName)
Get action name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionPlainNameA (ConstHGscAction anAction, const char *&ActionName)
Get action plain name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscAct_GetActionPlainNameW (ConstHGscAction anAction, const wchar_t *&ActionName)
Get action plain name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscAct_GetVideoInput (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Special information about some specific IDs used in the action.
GSCACTDLLCALL bool __stdcall | GscAct_GetVideoOutput (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Get used video output.
GSCACTDLLCALL bool __stdcall | GscAct_GetInputContact (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Get used input contact.
GSCACTDLLCALL bool __stdcall | GscAct_GetOutputContact (ConstHGscAction anAction, const TPlcMediaChannelID *&ID)
Get used output contact.
GSCACTDLLCALL bool __stdcall | GscAct_GetForeignKey (ConstHGscAction anAction, const __int64 *&Key)
Get used foreign key.
GSCACTDLLCALL bool __stdcall | GscAct_GetGenericInt32Parameter (ConstHGscAction anAction, __int32 &aParam)
Get used generic 32-bit integer parameter.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGenericAction (const TPlcMediaChannelID *aVideoInput, const TPlcMediaChannelID *aVideoOutput, const TPlcMediaChannelID *anInputContact, const TPlcMediaChannelID *anOutputContact, __int32 aParam)
Create generic action generic action has only infos about some resources, nothing else it is intended to use only in GeViSoft / GeviScope interface.
GSCACTDLLCALL bool __stdcall | GscAct_UpdateActionInfo (HGscAction anAction, void *anObject, const TPlcUpdateActionInfoCallback &Callback, bool &UpdateOk)
Update action info.
GSCACTDLLCALL bool __stdcall | GscAct_UpdateWindowsClientInfo (HGscAction anAction, const wchar_t *localHostName, const PlcClientType localClientType, const wchar_t *localUserName)
Update windows client info.
GSCACTDLLCALL bool __stdcall | GscAct_GetWindowsClientInfo (HGscAction anAction, const wchar_t *&localHostName, const PlcClientType *&localClientType, const wchar_t *&localUserName)
GSCACTDLLCALL bool __stdcall | GscAct_SetProperty (HGscAction anAction, const wchar_t *Key, const wchar_t *Value)
Set action property.
GSCACTDLLCALL bool __stdcall | GscAct_GetProperty (HGscAction anAction, const wchar_t *Key, const wchar_t *&Value)
Get action property.
GSCACTDLLCALL bool __stdcall | GscAct_GetProperties (HGscAction anAction, const wchar_t *&Properties)
Get action properties.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionClass (ConstHGscMatchAction anAction, GscActionClass &ActionClass)
Get class of the action.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionCode (ConstHGscMatchAction anAction, GscActionCode &ActionCode)
Get code of the action.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionNameA (ConstHGscMatchAction anAction, const char *&ActionName)
Get action name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionNameW (ConstHGscMatchAction anAction, const wchar_t *&ActionName)
Get action name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionPlainNameA (ConstHGscMatchAction anAction, const char *&ActionName)
Get action plain name as ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetActionPlainNameW (ConstHGscMatchAction anAction, const wchar_t *&ActionName)
Get action plain name as UNICODE string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_HasDescription (ConstHGscMatchAction anAction, bool &Description)
Check description of the match action.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetDescriptionA (ConstHGscMatchAction anAction, const char *&Description)
Get description of the match action as ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_GetDescriptionW (ConstHGscMatchAction anAction, const wchar_t *&Description)
Get description of the match action as UNICODE string.
bool | GscMatchAct_GetCommentA (ConstHGscMatchAction anAction, const char *&Description)
Alias to GscMatchAct_GetDescriptionA.
bool | GscMatchAct_GetCommentW (ConstHGscMatchAction anAction, const wchar_t *&Description)
Alias to GscMatchAct_GetDescriptionW.
GSCACTDLLCALL bool __stdcall | GscMatchAct_SetDescriptionA (HGscMatchAction anAction, const char *Description)
Set description of the match action from ANSI string.
GSCACTDLLCALL bool __stdcall | GscMatchAct_SetDescriptionW (HGscMatchAction anAction, const wchar_t *Description)
Set description of the match action from UNICODE string.
bool | GscMatchAct_SetCommentA (HGscMatchAction anAction, const char *Description)
Alias to GscMatchAct_SetDescriptionA.
bool | GscMatchAct_SetCommentW (HGscMatchAction anAction, const wchar_t *Description)
Alias to GscMatchAct_SetDescriptionW.
GSCACTDLLCALL bool __stdcall | GscMatchAct_Matches (ConstHGscMatchAction aMatchAction, ConstHGscAction anAction, bool &Result)
Working with match actions.
GSCACTDLLCALL bool __stdcall | GscMatchAct_CreateActionFromTemplate (ConstHGscMatchAction aMatchAction, ConstHGscAction aTemplate, HGscAction &Result)
Create action from the match action and provided action as template.
GSCACTDLLCALL bool __stdcall | GscAct_CreateMatchActionFromTemplate (ConstHGscAction anAction, HGscMatchAction &Result)
Create match action from the action.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateABCConnect (const wchar_t *aAddress)
Create action 'ABC connect'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateABCDisconnect ()
Create action 'ABC disconnect'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateABCPlayFile (const __int64 &aFileID, const wchar_t *aFileName, const bool aAutoRepeat)
Create action 'ABC play file'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAbortAllAutoBackups ()
Create action 'Abort all auto backups'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAbortAutoBackup (const TPlcResourceID &aSchedule)
Create action 'Abort auto backup'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSAccessDenied (const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp, const __int32 *aReason)
Create action 'ACS access denied'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSAccessGranted (const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp)
Create action 'ACS access granted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSRawAnswer (const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData)
Create action 'ACS raw answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateACSRawData (const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData)
Create action 'ACS raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateActivateExternalProcess (const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const VideoSensorKind aExternalSystem)
Create action 'Activate external process'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateATMRawAnswer (const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData)
Create action 'ATM raw answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateATMRawData (const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData)
Create action 'ATM raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateATMTransaction (const wchar_t *aATMName, const bool aNewTransaction, const __int32 aPhotostep, const __int32 *aATMNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const __int64 *aTAN1, const __int64 *aTAN2, const TGLibDateTime *aTimeStamp1, const TGLibDateTime *aTimeStamp2, const double *aAmount, const wchar_t *aCurrency)
Create action 'ATM transaction'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupCapacityMonitoringCapacityWarning (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf)
Create action 'Auto backup capacity warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupCapacityMonitoringFileAutoDeleted (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf, const __int64 &aFileSize, const wchar_t *aFileName)
Create action 'Auto backup capacity file auto deleted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupCapacityMonitoringOutOfDiskSpace (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf)
Create action 'Auto backup capacity out of disk space'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupFileDone (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Auto backup file done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupFileProgress (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Auto backup file progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupFileStarted (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName)
Create action 'Auto backup file started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupOperationDone (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TGLibDateTime &aOperationStopTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 *aOperationErrorCode)
Create action 'Auto backup operation done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupOperationStarted (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit)
Create action 'Auto backup operation started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupScheduleDone (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const TGLibDateTime &aStopTime, const __int32 aOperationCount, const bool aTimerStart)
Create action 'Auto backup schedule done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoBackupScheduleStarted (const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart)
Create action 'Auto backup schedule started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoFocusOff (const TPlcMediaChannelID &aCamera)
Create action 'Auto focus off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateAutoFocusOn (const TPlcMediaChannelID &aCamera)
Create action 'Auto focus on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBackupEvent (const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID &aDestination, const __int64 *aStartHintID, const __int64 *aStopHintID, const wchar_t *aSubfolder)
Create action 'Backup event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBarcodeData (const wchar_t *aReaderName, const TGLibDateTime &aTimeStamp, const wchar_t *aBarcode)
Create action 'Barcode data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBlockingFilterActivate (const wchar_t *aFilter)
Create action 'Blocking filter activate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateBlockingFilterDeactivate (const wchar_t *aFilter)
Create action 'Blocking filter deactivate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraApplyProfile (const TPlcMediaChannelID &aCamera, const wchar_t *aProfile)
Create action 'Camera apply profile'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraBacklightCompensationMode (const TPlcMediaChannelID &aCamera, const PlcBacklightMode aMode)
Create action 'Camera backlight compensation mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraClearPrePosText (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Camera clear preset text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraDayNightMode (const TPlcMediaChannelID &aCamera, const PlcDayNightMode aMode)
Create action 'Camera day/night mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraLightOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera light off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraLightOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera light on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraManualIrisOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera manual iris off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraManualIrisOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera manual iris on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraPumpOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera pump off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraPumpOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera pump on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraRAWOutput (const TPlcMediaChannelID &aCamera, const char *aOutput)
Create action 'Camera RAW output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSelectCharMode (const TPlcMediaChannelID &aCamera, const __int32 aMode)
Create action 'Camera select char mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSetPrePosText (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Camera set preset text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncUOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func U off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncUOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func U on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncVOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func V off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncVOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func V on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncXOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func X off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncXOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func X on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncYOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func Y off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraSpecFuncYOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera spec func Y on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraStopAll (const TPlcMediaChannelID &aCamera)
Create action 'Camera stop all'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTextOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera text off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTextOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera text on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTourStart (const TPlcMediaChannelID &aCamera, const __int32 aTourID, const char *aTourName)
Create action 'Camera tour start'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraTourStop (const TPlcMediaChannelID &aCamera)
Create action 'Camera tour stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraVersionOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera version off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraVersionOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera version on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraWashOff (const TPlcMediaChannelID &aCamera)
Create action 'Camera wash-wipe off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCameraWashOn (const TPlcMediaChannelID &aCamera)
Create action 'Camera wash-wipe on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCancelExport (const GUID &aExportID, const PlcExportAbort aAbortFlag)
Create action 'Cancel export'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCaseClosed ()
Create action 'Case has been closed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCaseOpened ()
Create action 'Case has been opened'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeADParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change AD parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeCameraProfile (const TPlcResourceID &aHardwareModule, const TPlcResourceID &aCameraProfile)
Create action 'Change camera profile'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeCPAParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change CPA parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeGTectParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change GTectVMX parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeObtrackParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change OBTRACK parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChangeVMDParameterSet (const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet)
Create action 'Change VMD parameter set'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelError (const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'Channel error'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelInfo (const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'Channel info'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelLiveCheck (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const TGLibDateTime &aTimeStamp)
Create action 'Channel live check'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateChannelWarning (const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'Channel warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCPAMeasurement (const TPlcMediaChannelID &aChannel, const __int32 aCorrelation)
Create action 'CPA measurement'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateCustomAction (const __int64 &aInt, const wchar_t *aString)
Create action 'Custom action'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDatabaseRecordingInfoRing (const PlcDatabaseRing aDatabaseRing, const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aRingCapacity, const TGLibDateTime &aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity)
Create action 'Database recording info per ring'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDatabaseRecordingInfoTotal (const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedCapacity, const TGLibDateTime *aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity, const double *aRequiredCapacityFactor, const bool *aRequiredCapacityAvailable)
Create action 'Database recording info total'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDatabaseStarted (const PlcDatabaseStatus aStatus, const __int64 &aTotalSize)
Create action 'Database started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDefaultPosCallUp (const TPlcMediaChannelID &aCamera)
Create action 'Move to default position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDefaultPosClear (const TPlcMediaChannelID &aCamera)
Create action 'Clear default position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDefaultPosSave (const TPlcMediaChannelID &aCamera)
Create action 'Save default position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceFound (const char *aType, const char *aName, const char *aSerial)
Create action 'Device found'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceNewFirmware (const char *aType, const char *aName, const char *aSerial, const char *aFirmware)
Create action 'New firmware received'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDevicePluginError (const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginError aErrorClass, const __int32 *aErrorCode, const char *aDescription)
Create action 'Device plugin error'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDevicePluginState (const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginState aState, const __int32 *aInternalState, const char *aDescription)
Create action 'Device plugin state'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceReattached (const char *aType, const char *aName, const char *aSerial)
Create action 'Device reattached'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDeviceRemoved (const char *aType, const char *aName, const char *aSerial)
Create action 'Device removed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateDigitalInput (const TPlcMediaChannelID &aContact, const DigitalInputState aState)
Create action 'Digital input'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupDone (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const __int32 *aOperationErrorCode)
Create action 'Event backup done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupFileDone (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Event backup file done'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupFileProgress (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize)
Create action 'Event backup file progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupFileStarted (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName)
Create action 'Event backup file started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventBackupStarted (const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime)
Create action 'Event backup started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventRecordingChanged (const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
Create action 'Event recording changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventStartedEx (const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey)
Create action 'Event started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventStopped (const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
Create action 'Event stopped'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateExportFinished (const GUID &aExportID, const PlcExportSuccess aSuccess)
Create action 'Export finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateExportProgress (const GUID &aExportID, const __int32 aProgress)
Create action 'Export progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFastSpeedOff (const TPlcMediaChannelID &aCamera)
Create action 'Fast speed off'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFastSpeedOn (const TPlcMediaChannelID &aCamera)
Create action 'Fast speed on'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFillingPumpStatus (const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aPumpNo, const PlcPumpStatus aStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
Create action 'Filling pump status'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFocusFar (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Focus far'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFocusNear (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Focus near'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFocusStop (const TPlcMediaChannelID &aCamera)
Create action 'Focus stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateFRCNotification (const PlcFRCNotification aNotification, const __int32 *aParam, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'FRC notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGEMOSalarm (const __int64 &aGEMOSkey, const __int32 aGEMOSint, const wchar_t *aGEMOSstr)
Create action 'GEMOS alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessDenied (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access denied'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessExpired (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const TGLibDateTime &aExpiringTime, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access expired'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessGranted (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access granted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGSCSVehicleAccessPending (const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection)
Create action 'GSCS vehicle access pending'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectAnalyticsLiveCheck ()
Create action 'G-Tect analytics live check'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectDualSensorAlarm (const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea)
Create action 'G-Tect/Dual sensor alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectDualSensorAlarmFinished (const TPlcMediaChannelID &aChannel)
Create action 'G-Tect/Dual sensor alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectSceneAlarm (const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason)
Create action 'G-Tect scene alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectSceneAlarmFinished (const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason)
Create action 'G-Tect scene alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectVMXAlarm (const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const __int32 *aAlarmGroup, const __int32 *aTrackID, const TPlcRect *aAlarmArea)
Create action 'G-Tect/VMX alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateGTectVMXAlarmFinished (const TPlcMediaChannelID &aChannel)
Create action 'G-Tect/VMX alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIASSettingsChanged (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'IAS settings changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImageExportNotification (const wchar_t *aUser, const wchar_t *aDestination, const PlcImageExportType aDestinationType, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aTimeEnd, const wchar_t *aChannels, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Image export notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexCapacityFileAutoDeleted (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile, const __int64 &aTotalFileSize, const __int32 aNumberOfFiles)
Create action 'Imex capacity file auto deleted'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexCapacityOutOfDiskSpace (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile)
Create action 'Imex capacity out of disk space.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexCapacityWarning (const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile)
Create action 'Imex capacity warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexExportEventImage (const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID *aDestination, const wchar_t *aFilePath)
Create action 'Imex export event image'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexExportImageFromDB (const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath, const TGLibDateTime *aPictureTime)
Create action 'Imex export image from DB'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateImexExportImageFromLiveStream (const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath)
Create action 'Imex export image from live stream'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateInitializeRemoteExport (const TPlcMediaChannelID &aViewer, const GUID &aDevice)
Create action 'Initialize remote export'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateInterfaceRawAnswer (const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData)
Create action 'Interface raw answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateInterfaceRawData (const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData)
Create action 'Interface raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43ResetMainboard ()
Create action 'IOI43 reset mainboard'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43Temperature (const wchar_t *aID, const __int32 aTemperature)
Create action 'IOI43 temperature notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43WDActivate ()
Create action 'IOI43 watchdog activate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43WDDeactivate ()
Create action 'IOI43 watchdog deactivate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIOI43WDTrigger ()
Create action 'IOI43 watchdog trigger'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPCameraRawCommand (const wchar_t *aURL, const wchar_t *aUser, const wchar_t *aPassword, const wchar_t *aPOST)
Create action 'IP camera raw command'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPCamFailoverNotification (const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters)
Create action 'IP camera failover notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPCamFailoverRestore (const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters)
Create action 'IP camera failover restore'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIPSwitchOperation (const IPSwitchOps aOperation, const wchar_t *aPort, const __int32 *aParam)
Create action 'IP switch operation'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIrisClose (const TPlcMediaChannelID &aCamera)
Create action 'Iris close'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIrisOpen (const TPlcMediaChannelID &aCamera)
Create action 'Iris open'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateIrisStop (const TPlcMediaChannelID &aCamera)
Create action 'Iris stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKeyPressed (const SystemKey aKey)
Create action 'Key pressed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKeyReleased (const SystemKey aKey)
Create action 'Key released'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKillAllEvents ()
Create action 'Kill all events'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKillEvent (const TPlcEventTypeID &aTypeID)
Create action 'Kill event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateKillEventByID (const __int64 &aEventID)
Create action 'Kill event by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelAccessEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int64 *aCardNumber, const LenelAccessResult *aAccessResult, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const __int32 *aAreaEnteredID, const __int32 *aAreaExitedID, const wchar_t *aAssetID, const bool *aCardholderEntered, const bool *aDuress, const __int32 *aElevatorFloor, const __int32 *aFacilityCode, const bool *aIsReadableCard, const __int32 *aIssueCode, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel access event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelFireEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aTroubleCode, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel fire event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelIntercomEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aIntercomData, const __int32 *aLineNumber, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel intercom event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelRawData (const TGLibDateTime &aTimeStamp, const wchar_t *aLenelData)
Create action 'Lenel raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelRefreshNames ()
Create action 'Lenel refresh names'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelSecurityEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel security event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLenelVideoEvent (const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aChannel, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const TGLibDateTime *aStartTime, const TGLibDateTime *aEndTime, const wchar_t *aCommServerHostName, const wchar_t *aEventText)
Create action 'Lenel video event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLiveCheck (const __int64 &aCounter, const TGLibDateTime &aDate)
Create action 'Live check'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLogBarcodeData (const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem)
Create action 'Log barcode data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLogBarcodeDataLPS (const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const double *aX, const double *aY, const double *aZ, const __int32 *aLpsTagID, const PlcLpsStatus *aLpsStatus, const __int32 *aLpsCellID, const __int32 *aLpsAreaID, const __int32 *aUserParam, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem)
Create action 'Log barcode data LPS'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLogNPRRecognition (const wchar_t *aPlateNo, const __int64 *aHash, const wchar_t *aCountry, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const PlcNPRRestriction *aRestriction, const wchar_t *aCategory)
Create action 'Log NPR recognition'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLPSPositionData (const __int32 aTagID, const wchar_t *aScannerID, const __int64 &aX, const __int64 &aY, const __int64 *aZ, const double *aLatitude, const double *aLongitude, const __int32 aAreaID, const __int32 *aCellID, const PlcLpsStatus aStatus, const TGLibDateTime *aTimeStamp, const wchar_t *aData, const wchar_t *aAreaName)
Create action 'LPS position data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateLPSQueryPosition (const __int32 aTagID, const wchar_t *aScannerID, const wchar_t *aData)
Create action 'LPS query position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMakeCPAReferenceImage (const TPlcMediaChannelID &aChannel)
Create action 'Make CPA reference image'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMediaChannelSetupInfo (const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const wchar_t *aParameter)
Create action 'Media channel setup'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMoveToAbsolutePosition (const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta)
Create action 'Move to absolute position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMoveToBySpeed (const TPlcMediaChannelID &aCamera, const double &aSpeedAlpha, const double &aSpeedBeta)
Create action 'Move by speed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateMoveToRelativePosition (const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta)
Create action 'Move to relative position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateNPRRawData (const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const __int32 aWeight, const __int32 aZoneState, const __int32 aZonePlace, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const bool aCurBest, const __int32 aPlateWidth, const __int32 aPlateHeight, const __int32 aPlateAngle, const __int32 aSymHeight, const wchar_t *aType)
Create action 'NPR raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateNPRRecognition (const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const PlcNPRRestriction aRestriction, const wchar_t *aCategory, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const wchar_t *aType, const __int32 aWeight)
Create action 'NPR recognition'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackChannelCounter (const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp)
Create action 'OBTRACK channel counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackChannelCounterThreshold (const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp)
Create action 'OBTRACK channel counter threshold'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackChannelSetCounter (const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp)
Create action 'OBTRACK channel set counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackFrameRawData (const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aBrightness, const __int32 aContrast)
Create action 'OBTRACK frame raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackGroupCounter (const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp, const wchar_t *aGroupName)
Create action 'OBTRACK group counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackGroupCounterThreshold (const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName)
Create action 'OBTRACK group counter threshold'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackGroupSetCounter (const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName)
Create action 'OBTRACK group set counter'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackObjectRawData (const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aArea, const __int32 aObjectID, const PlcObtrackObjectStatus aObjectStatus, const PlcObtrackObjectClass aObjectClass, const __int32 *aConfidence, const TPlcRect *aPosition, const double *aSpeed, const __int32 *aDuration, const __int32 *aDirection, const double *aSize, const double *aObjectWidth, const double *aObjectHeight, const PlcObtrackProcessSize *aProcessSize, const char *aGscNetName)
Create action 'OBTRACK object raw data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateObtrackTunnelAlarm (const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const PlcTunnelAlarmReason aAlarmReason, const __int32 aObjectID, const __int32 aAlarmAreaID, const TPlcRect *aObjectArea)
Create action 'OBTRACK tunnel alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanAuto (const TPlcMediaChannelID &aCamera, const __int32 aModus)
Create action 'Pan auto'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanLeft (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Pan left'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanRight (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Pan right'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePanStop (const TPlcMediaChannelID &aCamera)
Create action 'Pan stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePOSData (const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const wchar_t *aArticle, const double *aPrice, const __int32 *aUnits, const double *aPricePerUnit, const wchar_t *aLine1, const wchar_t *aLine2, const wchar_t *aLine3, const wchar_t *aLine4, const wchar_t *aLine5)
Create action 'POS data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePOSStatus (const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const PlcPOSStatus aStatus, const wchar_t *aDetails)
Create action 'POS status'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceAlarm (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPSensorKind aSensor, const PPAlarmState aState)
Create action 'PP device alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceInput (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aInput, const PPAlarmState aState)
Create action 'PP device input'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceOffline (const wchar_t *aInterfaceID, const __int32 aDeviceAddress)
Create action 'PP device offline'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPDeviceOnline (const wchar_t *aInterfaceID, const __int32 aDeviceAddress)
Create action 'PP device online'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPInterfaceOffline (const wchar_t *aInterfaceID)
Create action 'PP interface offline'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPInterfaceOnline (const wchar_t *aInterfaceID)
Create action 'PP interface online'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPQueryInterface (const wchar_t *aInterfaceID)
Create action 'PP query interface'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPSetDeviceOutput (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aOutput, const PPAlarmState aState)
Create action 'PP set device output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPSubcellAlarm (const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind aCable, const __int32 aSubcell, const PPAlarmState aState)
Create action 'PP subcell alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePPZoneAlarm (const wchar_t *aZoneID, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind *aCable, const __int32 *aSubcell, const PPAlarmState aState)
Create action 'PP zone alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePrePosCallUp (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Move to preset position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePrePosClear (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Clear preset position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreatePrePosSave (const TPlcMediaChannelID &aCamera, const __int32 aPosition)
Create action 'Save preset position'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateRedundantPowerFailure ()
Create action 'Redundant power failure'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateRedundantPowerOk ()
Create action 'Redundant power ok'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateResetMainboard ()
Create action 'Reset mainboard'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagClose (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques)
Create action 'Safebag close'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagData (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques)
Create action 'Safebag data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagOpen (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID)
Create action 'Safebag open'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagPassingOfRiskData (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
Create action 'Safebag passing of risk data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagPassingOfRiskStart (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
Create action 'Safebag passing of risk start'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSafebagPassingOfRiskStop (const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType)
Create action 'Safebag passing of risk stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSceneStoreModification (const TPlcMediaChannelID &aViewer, const GUID &aSceneStoreID, const wchar_t *aSceneStoreName, const TGLibDateTime &aTimeStamp, const PlcSceneStoreModificationType aModificationType, const wchar_t *aUser, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Scene store modification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorAlarmFinished (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'Sensor alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorAudioAlarm (const TPlcMediaChannelID &aChannel)
Create action 'Sensor audio alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorInhibitAlarmFinished (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'Sensor inhibit alarm finished'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorInhibitVideoAlarmEx (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass)
Create action 'Sensor inhibit video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorVideoAlarmEx (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass)
Create action 'Sensor video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetCameraText (const TPlcMediaChannelID &aCamera, const char *aText)
Create action 'Set camera text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetClientVCA (const TPlcMediaChannelID &aChannel, const GTectClientVCAType aClientVCAType, const bool aEnabled)
Create action 'Enable client VCA'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetClock (const TGLibDateTime &aDate)
Create action 'Set clock'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetDigitalOutput (const TPlcMediaChannelID &aContact, const DigitalOutputState aState)
Create action 'Set digital output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetExportMarker (const TPlcMediaChannelID &aViewer, const PlcExportMarker aMarker)
Create action 'Set export marker'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetLED (const SystemLED aLED, const DigitalOutputState aState)
Create action 'Set system LED'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetLEDBlink (const SystemLED aLED, const __int32 aLedTimeOnMs, const __int32 aLedTimeOffMs)
Create action 'Set system LED to blink'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetSystemTime (const TGLibDateTime &aTimeStamp)
Create action 'Set system time'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetTestPictureMode (const TPlcMediaChannelID &aChannel, const bool aMode)
Create action 'Set test picture mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetupChanged (const wchar_t *aUser, const wchar_t *aHost, const TGLibDateTime &aDate, const PlcResourceKind aResourceKind, const TPlcEventTypeID &aResourceID, const PlcResourceChangeKind aChangeKind, const wchar_t *aDetails, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Setup changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetupUploadProgress (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const __int32 aProgress, const TGLibDateTime &aDate)
Create action 'Setup upload progress'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSetWatchdog (const __int32 aTimeout)
Create action 'Set watchdog'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataControl (const wchar_t *aInterfaceName, const PlcSkidataControl aData)
Create action 'SKIDATA control'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataDeviceEvent (const wchar_t *aInterfaceName, const __int32 aDeviceID, const __int32 aEventCode)
Create action 'SKIDATA device event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataEntry (const wchar_t *aInterfaceName, const PlcSkidataMsgCodeEntry aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
Create action 'SKIDATA entry'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataExit (const wchar_t *aInterfaceName, const PlcSkidataMsgCodeExit aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
Create action 'SKIDATA exit'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSkidataTransaction (const wchar_t *aInterfaceName, const PlcSkidataMsgCodeTransaction aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID)
Create action 'SKIDATA transaction'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSMRPViewerCleared ()
Create action 'SMRP viewer cleared'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSMRPViewerConnected (const wchar_t *aServer, const TPlcMediaChannelID &aChannel)
Create action 'SMRP viewer connected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSMTPMailSend (const wchar_t *aSubject, const wchar_t *aTo, const wchar_t *aCc, const wchar_t *aBody, const TPlcMediaChannelID *aChannel)
Create action 'SMTP mail'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartAutoBackup (const TPlcResourceID &aSchedule)
Create action 'Start auto backup'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartEventEx (const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey)
Create action 'Start event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartRemoteExport (const GUID &aExportID, const GUID &aDevice, const PlcBackupFormat aBackupFormat, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aSelectionBegin, const TGLibDateTime &aSelectionEnd, const wchar_t *aJobID)
Create action 'Start remote export'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartSceneStore (const GUID &aSceneStoreID, const wchar_t *aCutList, const __int64 &aPreHistoryLength, const __int64 &aRecordingLength)
Create action 'Start scene store'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStopAllEvents ()
Create action 'Stop all events'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStopEvent (const TPlcEventTypeID &aTypeID)
Create action 'Stop event'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStopEventByID (const __int64 &aEventID)
Create action 'Stop event by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemError (const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'System error'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemInfo (const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'System info'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemSettingsChanged (const bool aSetupChanged, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const bool aTimeRangeChanged, const TPlcResourceID *aTimeRange, const bool aLicenceChanged, const TGLibDateTime &aDate)
Create action 'System settings changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemStarted (const TGLibDateTime &aDate)
Create action 'System started'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemTerminating (const TGLibDateTime &aDate, const bool aWindowsShutdown)
Create action 'System terminating'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSystemWarning (const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo)
Create action 'System warning'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTemperature (const IODeviceType aSourceType, const wchar_t *aID, const __int32 aTemperature)
Create action 'Temperature notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTerminalArticleData (const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
Create action 'Terminal article data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTerminalPaymentData (const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails)
Create action 'Terminal payment data'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTiltDown (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Tilt down'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTiltStop (const TPlcMediaChannelID &aCamera)
Create action 'Tilt stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTiltUp (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Tilt up'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTransferBinaryBuffer (const GUID &aInternalHandle, const wchar_t *aParameter)
Create action 'Transfer binary buffer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateTransferBinaryChannelBuffer (const TPlcMediaChannelID &aChannel, const GUID &aInternalHandle, const wchar_t *aParameter)
Create action 'Transfer binary channel buffer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateUserLogin (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'User login'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateUserLoginFailed (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const UserLoginFailureCode aRejectReason, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'User login failed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateUserLogout (const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'User logout'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueConfirm (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue confirm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueConfirmByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
Create action 'VC alarm queue confirm by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueConfirmByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue confirm by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueNotification (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmState aNotification, const __int64 &aAlarmID, const TPlcEventTypeID &aTypeID, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'VC alarm queue notification'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueRemove (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue remove'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueRemoveByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
Create action 'VC alarm queue remove by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueRemoveByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue remove by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueSelect (const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue select'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueSelectByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID)
Create action 'VC alarm queue select by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAlarmQueueSelectByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode)
Create action 'VC alarm queue select by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCASetArmed (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed)
Create action 'VCA set armed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAStatusAnswer (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed)
Create action 'VCA status answer'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCAStatusRequest (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType)
Create action 'VCA status request'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCChangeSceneByName (const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
Create action 'VC change scene by name'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCClearSceneByName (const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
Create action 'VC clear scene by name'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCFullMode (const TPlcMediaChannelID &aViewer, const bool aFullMode, const bool aSensitiveAreaEnabled)
Create action 'VC full mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCSceneChanged (const TPlcMediaChannelID &aViewer, const wchar_t *aScene)
Create action 'VC scene changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCSetAudioLevel (const TPlcMediaChannelID &aViewer, const __int32 aAudioLevel)
Create action 'VC set audio level'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCShowViewerText (const TPlcMediaChannelID &aViewer, const bool aShowText)
Create action 'VC show viewer text'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVCStretchMode (const TPlcMediaChannelID &aViewer, const bool aStretchMode)
Create action 'VC stretch mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoContrastDetected (const TPlcMediaChannelID &aChannel)
Create action 'Video contrast detected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoContrastFailed (const TPlcMediaChannelID &aChannel)
Create action 'Video contrast failed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSetImageBrightness (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aBrightness)
Create action 'Video set image brightness'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSetImageContrast (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aContrast)
Create action 'Video set image contrast'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSetImageSaturation (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aSaturation)
Create action 'Video set image saturation'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSourceChanged (const TPlcMediaChannelID &aChannel, const VideoSignalNorm aSignalNorm, const VideoSignalType aSignalType, const VideoInterlaceType aInterlaceType)
Create action 'Video source has changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSyncDetected (const TPlcMediaChannelID &aChannel)
Create action 'Video sync detected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateVideoSyncFailed (const TPlcMediaChannelID &aChannel)
Create action 'Video sync failed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerChangeScene (const TPlcMediaChannelID &aViewer)
Create action 'Viewer change scene'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerClear (const TPlcMediaChannelID &aViewer)
Create action 'Viewer clear'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerCleared (const TPlcMediaChannelID &aViewer, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer cleared'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerClearScene (const TPlcMediaChannelID &aViewer)
Create action 'Viewer clear scene'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerClearTextOutput (const TPlcMediaChannelID &aViewer)
Create action 'Viewer clear text output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerConnect (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode)
Create action 'Viewer connect'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerConnected (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer connected'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerConnectLive (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel)
Create action 'Viewer connect live'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerExportPicture (const TPlcMediaChannelID &aViewer, const wchar_t *aFilePath)
Create action 'Viewer export picture'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerJumpByTime (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const __int32 aTimeInSec)
Create action 'Viewer jump by time'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerMaximize (const TPlcMediaChannelID &aViewer, const bool aMaximize)
Create action 'Viewer maximize'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerPlayFromTime (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime &aTime)
Create action 'Viewer play from time'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerPlayModeChanged (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime *aChannelTime, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer play mode changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerPrintPicture (const TPlcMediaChannelID &aViewer)
Create action 'Viewer print picture'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSelect (const TPlcMediaChannelID &aViewer)
Create action 'Viewer select'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSelectionChanged (const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount)
Create action 'Viewer selection changed'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSetPlayMode (const TPlcMediaChannelID &aViewer, const PlcViewerPlayMode aPlayMode, const __int32 aPlaySpeed)
Create action 'Viewer set play mode'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerShowAlarmByInstance (const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID, const PlcViewerAlarmPlayMode aPlayMode)
Create action 'Viewer show alarm by instance'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerShowAlarmByKey (const TPlcMediaChannelID &aViewer, const __int64 &aForeignKey, const PlcViewerAlarmPlayMode aPlayMode)
Create action 'Viewer show alarm by key'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerShowAlarmByType (const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey, const PlcViewerAlarmPlayMode aPlayMode)
Create action 'Viewer show alarm by type'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerSyncAudioAndVideo (const TPlcMediaChannelID &aViewer, const bool aEnableSync)
Create action 'Viewer change sync audio/video'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateViewerTextOutput (const TPlcMediaChannelID &aViewer, const wchar_t *aText)
Create action 'Viewer text output'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateWatchdogActivate ()
Create action 'Watchdog activate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateWatchdogDeactivate ()
Create action 'Watchdog deactivate'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateWatchdogTrigger ()
Create action 'Watchdog trigger'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateZoomIn (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Zoom in'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateZoomOut (const TPlcMediaChannelID &aCamera, const __int32 aSpeed)
Create action 'Zoom out'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateZoomStop (const TPlcMediaChannelID &aCamera)
Create action 'Zoom stop'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateEventStarted (const __int64 &aEventID, const TPlcEventTypeID &aTypeID)
Deprecated functions.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorInhibitVideoAlarm (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone)
Create action 'Sensor inhibit video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateSensorVideoAlarm (const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone)
Create action 'Sensor video alarm'.
GSCACTDLLCALL HGscAction __stdcall | GscAct_CreateStartEvent (const TPlcEventTypeID &aTypeID)
Create action 'Start event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeABCConnect (ConstHGscAction anAction, const wchar_t *&aAddress)
Decode action 'ABC connect'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeABCDisconnect (ConstHGscAction anAction)
Decode action 'ABC disconnect'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeABCPlayFile (ConstHGscAction anAction, __int64 &aFileID, const wchar_t *&aFileName, bool &aAutoRepeat)
Decode action 'ABC play file'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAbortAllAutoBackups (ConstHGscAction anAction)
Decode action 'Abort all auto backups'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAbortAutoBackup (ConstHGscAction anAction, TPlcResourceID &aSchedule)
Decode action 'Abort auto backup'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSAccessDenied (ConstHGscAction anAction, const wchar_t *&aACSName, const __int32 *&aACSNo, const __int64 *&aAccount, const __int64 *&aBancCode, const wchar_t *&aCardNo, const TGLibDateTime *&aTimeStamp, const __int32 *&aReason)
Decode action 'ACS access denied'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSAccessGranted (ConstHGscAction anAction, const wchar_t *&aACSName, const __int32 *&aACSNo, const __int64 *&aAccount, const __int64 *&aBancCode, const wchar_t *&aCardNo, const TGLibDateTime *&aTimeStamp)
Decode action 'ACS access granted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSRawAnswer (ConstHGscAction anAction, const wchar_t *&aACSName, TGLibDateTime &aTimeStamp, const wchar_t *&aACSData)
Decode action 'ACS raw answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeACSRawData (ConstHGscAction anAction, const wchar_t *&aACSName, TGLibDateTime &aTimeStamp, const wchar_t *&aACSData)
Decode action 'ACS raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeActivateExternalProcess (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, VideoSensorKind &aExternalSystem)
Decode action 'Activate external process'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeATMRawAnswer (ConstHGscAction anAction, const wchar_t *&aATMName, TGLibDateTime &aTimeStamp, const wchar_t *&aATMData)
Decode action 'ATM raw answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeATMRawData (ConstHGscAction anAction, const wchar_t *&aATMName, TGLibDateTime &aTimeStamp, const wchar_t *&aATMData)
Decode action 'ATM raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeATMTransaction (ConstHGscAction anAction, const wchar_t *&aATMName, bool &aNewTransaction, __int32 &aPhotostep, const __int32 *&aATMNo, const __int64 *&aAccount, const __int64 *&aBancCode, const wchar_t *&aCardNo, const __int64 *&aTAN1, const __int64 *&aTAN2, const TGLibDateTime *&aTimeStamp1, const TGLibDateTime *&aTimeStamp2, const double *&aAmount, const wchar_t *&aCurrency)
Decode action 'ATM transaction'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupCapacityMonitoringCapacityWarning (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByGbf, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByGbf)
Decode action 'Auto backup capacity warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupCapacityMonitoringFileAutoDeleted (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByGbf, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByGbf, __int64 &aFileSize, const wchar_t *&aFileName)
Decode action 'Auto backup capacity file auto deleted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupCapacityMonitoringOutOfDiskSpace (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByGbf, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByGbf)
Decode action 'Auto backup capacity out of disk space'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupFileDone (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Auto backup file done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupFileProgress (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Auto backup file progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupFileStarted (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, __int32 &aFileIndex, const wchar_t *&aFileName)
Decode action 'Auto backup file started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupOperationDone (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TGLibDateTime &aOperationStopTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, const __int32 *&aOperationErrorCode)
Decode action 'Auto backup operation done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupOperationStarted (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart, __int32 &aOperationIndex, TGLibDateTime &aOperationStartTime, TPlcResourceID &aSource, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit)
Decode action 'Auto backup operation started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupScheduleDone (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, TGLibDateTime &aStopTime, __int32 &aOperationCount, bool &aTimerStart)
Decode action 'Auto backup schedule done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoBackupScheduleStarted (ConstHGscAction anAction, TPlcResourceID &aSchedule, const TGLibDateTime *&aStartTime, TGLibDateTime &aEffectiveStartTime, __int32 &aOperationCount, bool &aTimerStart)
Decode action 'Auto backup schedule started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoFocusOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Auto focus off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeAutoFocusOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Auto focus on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBackupEvent (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID, TPlcResourceID &aDestination, const __int64 *&aStartHintID, const __int64 *&aStopHintID, const wchar_t *&aSubfolder)
Decode action 'Backup event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBarcodeData (ConstHGscAction anAction, const wchar_t *&aReaderName, TGLibDateTime &aTimeStamp, const wchar_t *&aBarcode)
Decode action 'Barcode data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBlockingFilterActivate (ConstHGscAction anAction, const wchar_t *&aFilter)
Decode action 'Blocking filter activate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeBlockingFilterDeactivate (ConstHGscAction anAction, const wchar_t *&aFilter)
Decode action 'Blocking filter deactivate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraApplyProfile (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, const wchar_t *&aProfile)
Decode action 'Camera apply profile'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraBacklightCompensationMode (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, PlcBacklightMode &aMode)
Decode action 'Camera backlight compensation mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraClearPrePosText (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Camera clear preset text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraDayNightMode (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, PlcDayNightMode &aMode)
Decode action 'Camera day/night mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraLightOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera light off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraLightOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera light on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraManualIrisOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera manual iris off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraManualIrisOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera manual iris on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraPumpOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera pump off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraPumpOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera pump on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraRAWOutput (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, const char *&aOutput)
Decode action 'Camera RAW output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSelectCharMode (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aMode)
Decode action 'Camera select char mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSetPrePosText (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Camera set preset text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncUOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func U off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncUOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func U on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncVOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func V off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncVOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func V on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncXOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func X off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncXOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func X on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncYOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func Y off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraSpecFuncYOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera spec func Y on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraStopAll (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera stop all'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTextOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera text off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTextOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera text on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTourStart (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aTourID, const char *&aTourName)
Decode action 'Camera tour start'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraTourStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera tour stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraVersionOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera version off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraVersionOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera version on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraWashOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera wash-wipe off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCameraWashOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Camera wash-wipe on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCancelExport (ConstHGscAction anAction, GUID &aExportID, PlcExportAbort &aAbortFlag)
Decode action 'Cancel export'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCaseClosed (ConstHGscAction anAction)
Decode action 'Case has been closed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCaseOpened (ConstHGscAction anAction)
Decode action 'Case has been opened'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeADParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change AD parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeCameraProfile (ConstHGscAction anAction, TPlcResourceID &aHardwareModule, TPlcResourceID &aCameraProfile)
Decode action 'Change camera profile'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeCPAParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change CPA parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeGTectParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change GTectVMX parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeObtrackParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change OBTRACK parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChangeVMDParameterSet (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TPlcResourceID &aParameterSet)
Decode action 'Change VMD parameter set'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelError (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const VideoSensorKind *&aSensorType, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'Channel error'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelInfo (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const VideoSensorKind *&aSensorType, PlcMessageSource &aSource, PlcMessageCode &aMessage, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'Channel info'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelLiveCheck (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, TGLibDateTime &aTimeStamp)
Decode action 'Channel live check'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeChannelWarning (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const VideoSensorKind *&aSensorType, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'Channel warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCPAMeasurement (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, __int32 &aCorrelation)
Decode action 'CPA measurement'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeCustomAction (ConstHGscAction anAction, __int64 &aInt, const wchar_t *&aString)
Decode action 'Custom action'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDatabaseRecordingInfoRing (ConstHGscAction anAction, PlcDatabaseRing &aDatabaseRing, bool &aNoVideoRecording, bool &aNoAudioRecording, bool &aNoRecordingAtAll, double &aVideoSamplesPerSecond, double &aVideoMBPerSecond, double &aAudioSamplesPerSecond, double &aAudioMBPerSecond, double &aWriteWaitTimesPercent, __int64 &aRingCapacity, TGLibDateTime &aOldestItem, const double *&aRecordingDepth, const __int64 *&aEstimatedRequiredCapacity)
Decode action 'Database recording info per ring'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDatabaseRecordingInfoTotal (ConstHGscAction anAction, bool &aNoVideoRecording, bool &aNoAudioRecording, bool &aNoRecordingAtAll, double &aVideoSamplesPerSecond, double &aVideoMBPerSecond, double &aAudioSamplesPerSecond, double &aAudioMBPerSecond, double &aWriteWaitTimesPercent, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedCapacity, const TGLibDateTime *&aOldestItem, const double *&aRecordingDepth, const __int64 *&aEstimatedRequiredCapacity, const double *&aRequiredCapacityFactor, const bool *&aRequiredCapacityAvailable)
Decode action 'Database recording info total'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDatabaseStarted (ConstHGscAction anAction, PlcDatabaseStatus &aStatus, __int64 &aTotalSize)
Decode action 'Database started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDefaultPosCallUp (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Move to default position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDefaultPosClear (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Clear default position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDefaultPosSave (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Save default position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceFound (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial)
Decode action 'Device found'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceNewFirmware (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial, const char *&aFirmware)
Decode action 'New firmware received'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDevicePluginError (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const char *&aType, const char *&aSubType, const char *&aName, const char *&aSerial, PlcPluginError &aErrorClass, const __int32 *&aErrorCode, const char *&aDescription)
Decode action 'Device plugin error'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDevicePluginState (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const char *&aType, const char *&aSubType, const char *&aName, const char *&aSerial, PlcPluginState &aState, const __int32 *&aInternalState, const char *&aDescription)
Decode action 'Device plugin state'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceReattached (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial)
Decode action 'Device reattached'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDeviceRemoved (ConstHGscAction anAction, const char *&aType, const char *&aName, const char *&aSerial)
Decode action 'Device removed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeDigitalInput (ConstHGscAction anAction, TPlcMediaChannelID &aContact, DigitalInputState &aState)
Decode action 'Digital input'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupDone (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, TGLibDateTime &aStopTime, const __int32 *&aOperationErrorCode)
Decode action 'Event backup done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupFileDone (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Event backup file done'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupFileProgress (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, __int32 &aFileIndex, const wchar_t *&aFileName, __int64 &aFileSize)
Decode action 'Event backup file progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupFileStarted (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime, __int32 &aFileIndex, const wchar_t *&aFileName)
Decode action 'Event backup file started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventBackupStarted (ConstHGscAction anAction, GUID &aJobID, TPlcEventTypeID &aEventTypeID, __int64 &aEventID, TPlcResourceID &aDestination, __int64 &aFileSizeLimit, __int64 &aBandWidthLimit, TGLibDateTime &aStartTime)
Decode action 'Event backup started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventRecordingChanged (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID)
Decode action 'Event recording changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventStartedEx (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID, const __int64 *&aForeignKey)
Decode action 'Event started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventStopped (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID)
Decode action 'Event stopped'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeExportFinished (ConstHGscAction anAction, GUID &aExportID, PlcExportSuccess &aSuccess)
Decode action 'Export finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeExportProgress (ConstHGscAction anAction, GUID &aExportID, __int32 &aProgress)
Decode action 'Export progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFastSpeedOff (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Fast speed off'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFastSpeedOn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Fast speed on'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFillingPumpStatus (ConstHGscAction anAction, const wchar_t *&aTerminalName, TGLibDateTime &aTimeStamp, __int32 &aPumpNo, PlcPumpStatus &aStatus, const double *&aAmount, const double *&aPrice, const wchar_t *&aDetails)
Decode action 'Filling pump status'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFocusFar (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Focus far'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFocusNear (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Focus near'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFocusStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Focus stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeFRCNotification (ConstHGscAction anAction, PlcFRCNotification &aNotification, const __int32 *&aParam, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'FRC notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGEMOSalarm (ConstHGscAction anAction, __int64 &aGEMOSkey, __int32 &aGEMOSint, const wchar_t *&aGEMOSstr)
Decode action 'GEMOS alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessDenied (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access denied'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessExpired (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, TGLibDateTime &aExpiringTime, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access expired'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessGranted (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access granted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGSCSVehicleAccessPending (ConstHGscAction anAction, __int32 &aSequenceID, const wchar_t *&aPlateNo, TGLibDateTime &aTimeStamp, const wchar_t *&aCompanyCategory, const wchar_t *&aCompanyName, const wchar_t *&aReason, const wchar_t *&aTrafficLane, const TPlcMediaChannelID *&aChannel, const TrafficDirection *&aDirection)
Decode action 'GSCS vehicle access pending'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectAnalyticsLiveCheck (ConstHGscAction anAction)
Decode action 'G-Tect analytics live check'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectDualSensorAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const __int32 *&aSterileZoneNumber, const __int32 *&aVirtualFenceNumber, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone, const VMDCycle *&aVMDCycle, const TPlcRect *&aAlarmArea)
Decode action 'G-Tect/Dual sensor alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectDualSensorAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'G-Tect/Dual sensor alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectSceneAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GTectSceneAlarmReason &aAlarmReason)
Decode action 'G-Tect scene alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectSceneAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GTectSceneAlarmReason &aAlarmReason)
Decode action 'G-Tect scene alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectVMXAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const __int32 *&aSterileZoneNumber, const __int32 *&aVirtualFenceNumber, const __int32 *&aAlarmGroup, const __int32 *&aTrackID, const TPlcRect *&aAlarmArea)
Decode action 'G-Tect/VMX alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeGTectVMXAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'G-Tect/VMX alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIASSettingsChanged (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'IAS settings changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImageExportNotification (ConstHGscAction anAction, const wchar_t *&aUser, const wchar_t *&aDestination, PlcImageExportType &aDestinationType, TGLibDateTime &aTimeStamp, const TGLibDateTime *&aTimeEnd, const wchar_t *&aChannels, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Image export notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexCapacityFileAutoDeleted (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByImageFile, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByImageFile, __int64 &aTotalFileSize, __int32 &aNumberOfFiles)
Decode action 'Imex capacity file auto deleted'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexCapacityOutOfDiskSpace (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByImageFile, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByImageFile)
Decode action 'Imex capacity out of disk space.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexCapacityWarning (ConstHGscAction anAction, ABCapacityWarning &aWarning, TPlcResourceID &aDestination, __int64 &aTotalCapacity, __int64 &aFreeCapacity, __int64 &aAllocatedByImageFile, __int32 &aPercentFree, __int32 &aPercentAllocated, __int32 &aPercentAllocatedByImageFile)
Decode action 'Imex capacity warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexExportEventImage (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID, const TPlcResourceID *&aDestination, const wchar_t *&aFilePath)
Decode action 'Imex export event image'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexExportImageFromDB (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const TPlcResourceID *&aDestination, const wchar_t *&aFilePath, const TGLibDateTime *&aPictureTime)
Decode action 'Imex export image from DB'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeImexExportImageFromLiveStream (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, const TPlcResourceID *&aDestination, const wchar_t *&aFilePath)
Decode action 'Imex export image from live stream'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeInitializeRemoteExport (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, GUID &aDevice)
Decode action 'Initialize remote export'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeInterfaceRawAnswer (ConstHGscAction anAction, const wchar_t *&aInterfaceName, TGLibDateTime &aTimeStamp, const wchar_t *&aData)
Decode action 'Interface raw answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeInterfaceRawData (ConstHGscAction anAction, const wchar_t *&aInterfaceName, TGLibDateTime &aTimeStamp, const wchar_t *&aData)
Decode action 'Interface raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43ResetMainboard (ConstHGscAction anAction)
Decode action 'IOI43 reset mainboard'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43Temperature (ConstHGscAction anAction, const wchar_t *&aID, __int32 &aTemperature)
Decode action 'IOI43 temperature notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43WDActivate (ConstHGscAction anAction)
Decode action 'IOI43 watchdog activate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43WDDeactivate (ConstHGscAction anAction)
Decode action 'IOI43 watchdog deactivate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIOI43WDTrigger (ConstHGscAction anAction)
Decode action 'IOI43 watchdog trigger'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPCameraRawCommand (ConstHGscAction anAction, const wchar_t *&aURL, const wchar_t *&aUser, const wchar_t *&aPassword, const wchar_t *&aPOST)
Decode action 'IP camera raw command'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPCamFailoverNotification (ConstHGscAction anAction, const wchar_t *&aPrimaryServer, const wchar_t *&aSecondaryServer, TPlcMediaChannelID &aPrimaryChannel, TPlcMediaChannelID &aSecondaryChannel, const wchar_t *&aCameraParameters)
Decode action 'IP camera failover notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPCamFailoverRestore (ConstHGscAction anAction, const wchar_t *&aPrimaryServer, const wchar_t *&aSecondaryServer, TPlcMediaChannelID &aPrimaryChannel, TPlcMediaChannelID &aSecondaryChannel, const wchar_t *&aCameraParameters)
Decode action 'IP camera failover restore'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIPSwitchOperation (ConstHGscAction anAction, IPSwitchOps &aOperation, const wchar_t *&aPort, const __int32 *&aParam)
Decode action 'IP switch operation'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIrisClose (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Iris close'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIrisOpen (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Iris open'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeIrisStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Iris stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKeyPressed (ConstHGscAction anAction, SystemKey &aKey)
Decode action 'Key pressed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKeyReleased (ConstHGscAction anAction, SystemKey &aKey)
Decode action 'Key released'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKillAllEvents (ConstHGscAction anAction)
Decode action 'Kill all events'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKillEvent (ConstHGscAction anAction, TPlcEventTypeID &aTypeID)
Decode action 'Kill event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeKillEventByID (ConstHGscAction anAction, __int64 &aEventID)
Decode action 'Kill event by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelAccessEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int64 *&aCardNumber, const LenelAccessResult *&aAccessResult, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const __int32 *&aAreaEnteredID, const __int32 *&aAreaExitedID, const wchar_t *&aAssetID, const bool *&aCardholderEntered, const bool *&aDuress, const __int32 *&aElevatorFloor, const __int32 *&aFacilityCode, const bool *&aIsReadableCard, const __int32 *&aIssueCode, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel access event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelFireEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int32 *&aTroubleCode, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel fire event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelIntercomEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int32 *&aIntercomData, const __int32 *&aLineNumber, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel intercom event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelRawData (ConstHGscAction anAction, TGLibDateTime &aTimeStamp, const wchar_t *&aLenelData)
Decode action 'Lenel raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelRefreshNames (ConstHGscAction anAction)
Decode action 'Lenel refresh names'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelSecurityEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel security event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLenelVideoEvent (ConstHGscAction anAction, const LenelEventID *&aID, const wchar_t *&aPanel, const wchar_t *&aDevice, const __int32 *&aSecondaryDevice, const __int32 *&aChannel, const LenelEventType *&aType, const __int32 *&aSubType, const wchar_t *&aDescription, const __int32 *&aSerialNumber, const TGLibDateTime *&aTimeStamp, const TGLibDateTime *&aStartTime, const TGLibDateTime *&aEndTime, const wchar_t *&aCommServerHostName, const wchar_t *&aEventText)
Decode action 'Lenel video event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLiveCheck (ConstHGscAction anAction, __int64 &aCounter, TGLibDateTime &aDate)
Decode action 'Live check'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLogBarcodeData (ConstHGscAction anAction, const wchar_t *&aBarcode, const __int64 *&aHash, const wchar_t *&aScanner, const __int64 *&aAreaID, const wchar_t *&aAreaName, const TPlcMediaChannelID *&aChannel, const TGLibDateTime *&aTimeStamp, const wchar_t *&aOrder, const wchar_t *&aShipment, const wchar_t *&aItem)
Decode action 'Log barcode data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLogBarcodeDataLPS (ConstHGscAction anAction, const wchar_t *&aBarcode, const __int64 *&aHash, const wchar_t *&aScanner, const __int64 *&aAreaID, const wchar_t *&aAreaName, const TPlcMediaChannelID *&aChannel, const TGLibDateTime *&aTimeStamp, const double *&aX, const double *&aY, const double *&aZ, const __int32 *&aLpsTagID, const PlcLpsStatus *&aLpsStatus, const __int32 *&aLpsCellID, const __int32 *&aLpsAreaID, const __int32 *&aUserParam, const wchar_t *&aOrder, const wchar_t *&aShipment, const wchar_t *&aItem)
Decode action 'Log barcode data LPS'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLogNPRRecognition (ConstHGscAction anAction, const wchar_t *&aPlateNo, const __int64 *&aHash, const wchar_t *&aCountry, const TPlcMediaChannelID *&aChannel, const TGLibDateTime *&aTimeStamp, const PlcNPRRestriction *&aRestriction, const wchar_t *&aCategory)
Decode action 'Log NPR recognition'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLPSPositionData (ConstHGscAction anAction, __int32 &aTagID, const wchar_t *&aScannerID, __int64 &aX, __int64 &aY, const __int64 *&aZ, const double *&aLatitude, const double *&aLongitude, __int32 &aAreaID, const __int32 *&aCellID, PlcLpsStatus &aStatus, const TGLibDateTime *&aTimeStamp, const wchar_t *&aData, const wchar_t *&aAreaName)
Decode action 'LPS position data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeLPSQueryPosition (ConstHGscAction anAction, __int32 &aTagID, const wchar_t *&aScannerID, const wchar_t *&aData)
Decode action 'LPS query position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMakeCPAReferenceImage (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Make CPA reference image'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMediaChannelSetupInfo (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, const wchar_t *&aParameter)
Decode action 'Media channel setup'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMoveToAbsolutePosition (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, double &aAlpha, double &aBeta, double &aSpeedAlpha, double &aSpeedBeta)
Decode action 'Move to absolute position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMoveToBySpeed (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, double &aSpeedAlpha, double &aSpeedBeta)
Decode action 'Move by speed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeMoveToRelativePosition (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, double &aAlpha, double &aBeta, double &aSpeedAlpha, double &aSpeedBeta)
Decode action 'Move to relative position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeNPRRawData (ConstHGscAction anAction, const wchar_t *&aPlateNo, const wchar_t *&aCountry, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, TPlcRect &aZoneRect, __int32 &aWeight, __int32 &aZoneState, __int32 &aZonePlace, __int32 &aSpeed, __int32 &aDirection, __int32 &aZoneIndex, bool &aCurBest, __int32 &aPlateWidth, __int32 &aPlateHeight, __int32 &aPlateAngle, __int32 &aSymHeight, const wchar_t *&aType)
Decode action 'NPR raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeNPRRecognition (ConstHGscAction anAction, const wchar_t *&aPlateNo, const wchar_t *&aCountry, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, TPlcRect &aZoneRect, PlcNPRRestriction &aRestriction, const wchar_t *&aCategory, __int32 &aSpeed, __int32 &aDirection, __int32 &aZoneIndex, const wchar_t *&aType, __int32 &aWeight)
Decode action 'NPR recognition'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackChannelCounter (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, __int32 &aObjectDirection, TGLibDateTime &aTimeStamp, const TGLibDateTime *&aResetTimeStamp)
Decode action 'OBTRACK channel counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackChannelCounterThreshold (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, PlcObtrackExceedingDirection &aExceedingDirection, TGLibDateTime &aTimeStamp)
Decode action 'OBTRACK channel counter threshold'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackChannelSetCounter (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, TGLibDateTime &aTimeStamp)
Decode action 'OBTRACK channel set counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackFrameRawData (ConstHGscAction anAction, TGLibDateTime &aTimeStamp, TPlcMediaChannelID &aChannel, __int32 &aBrightness, __int32 &aContrast)
Decode action 'OBTRACK frame raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackGroupCounter (ConstHGscAction anAction, __int32 &aGroupId, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, __int32 &aObjectDirection, TGLibDateTime &aTimeStamp, const TGLibDateTime *&aResetTimeStamp, const wchar_t *&aGroupName)
Decode action 'OBTRACK group counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackGroupCounterThreshold (ConstHGscAction anAction, __int32 &aGroupId, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, PlcObtrackExceedingDirection &aExceedingDirection, TGLibDateTime &aTimeStamp, const wchar_t *&aGroupName)
Decode action 'OBTRACK group counter threshold'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackGroupSetCounter (ConstHGscAction anAction, __int32 &aGroupId, PlcObtrackCounterType &aCounterType, __int64 &aCounterValue, TGLibDateTime &aTimeStamp, const wchar_t *&aGroupName)
Decode action 'OBTRACK group set counter'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackObjectRawData (ConstHGscAction anAction, TGLibDateTime &aTimeStamp, TPlcMediaChannelID &aChannel, __int32 &aArea, __int32 &aObjectID, PlcObtrackObjectStatus &aObjectStatus, PlcObtrackObjectClass &aObjectClass, const __int32 *&aConfidence, const TPlcRect *&aPosition, const double *&aSpeed, const __int32 *&aDuration, const __int32 *&aDirection, const double *&aSize, const double *&aObjectWidth, const double *&aObjectHeight, const PlcObtrackProcessSize *&aProcessSize, const char *&aGscNetName)
Decode action 'OBTRACK object raw data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeObtrackTunnelAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, TGLibDateTime &aTimeStamp, PlcTunnelAlarmReason &aAlarmReason, __int32 &aObjectID, __int32 &aAlarmAreaID, const TPlcRect *&aObjectArea)
Decode action 'OBTRACK tunnel alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanAuto (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aModus)
Decode action 'Pan auto'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanLeft (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Pan left'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanRight (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Pan right'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePanStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Pan stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePOSData (ConstHGscAction anAction, const wchar_t *&aPOSName, TGLibDateTime &aTimeStamp, const wchar_t *&aArticle, const double *&aPrice, const __int32 *&aUnits, const double *&aPricePerUnit, const wchar_t *&aLine1, const wchar_t *&aLine2, const wchar_t *&aLine3, const wchar_t *&aLine4, const wchar_t *&aLine5)
Decode action 'POS data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePOSStatus (ConstHGscAction anAction, const wchar_t *&aPOSName, TGLibDateTime &aTimeStamp, PlcPOSStatus &aStatus, const wchar_t *&aDetails)
Decode action 'POS status'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceAlarm (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, PPSensorKind &aSensor, PPAlarmState &aState)
Decode action 'PP device alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceInput (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, __int32 &aInput, PPAlarmState &aState)
Decode action 'PP device input'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceOffline (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress)
Decode action 'PP device offline'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPDeviceOnline (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress)
Decode action 'PP device online'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPInterfaceOffline (ConstHGscAction anAction, const wchar_t *&aInterfaceID)
Decode action 'PP interface offline'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPInterfaceOnline (ConstHGscAction anAction, const wchar_t *&aInterfaceID)
Decode action 'PP interface online'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPQueryInterface (ConstHGscAction anAction, const wchar_t *&aInterfaceID)
Decode action 'PP query interface'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPSetDeviceOutput (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, __int32 &aOutput, PPAlarmState &aState)
Decode action 'PP set device output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPSubcellAlarm (ConstHGscAction anAction, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, PPCableKind &aCable, __int32 &aSubcell, PPAlarmState &aState)
Decode action 'PP subcell alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePPZoneAlarm (ConstHGscAction anAction, const wchar_t *&aZoneID, const wchar_t *&aInterfaceID, __int32 &aDeviceAddress, const PPCableKind *&aCable, const __int32 *&aSubcell, PPAlarmState &aState)
Decode action 'PP zone alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePrePosCallUp (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Move to preset position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePrePosClear (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Clear preset position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodePrePosSave (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aPosition)
Decode action 'Save preset position'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeRedundantPowerFailure (ConstHGscAction anAction)
Decode action 'Redundant power failure'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeRedundantPowerOk (ConstHGscAction anAction)
Decode action 'Redundant power ok'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeResetMainboard (ConstHGscAction anAction)
Decode action 'Reset mainboard'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagClose (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, TGLibDateTime &aStopTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, const double *&aDebit, const double *&aTotal, const double *&aDifference, const bool *&aHasDifference, const wchar_t *&aNotes, const wchar_t *&aCoins, const wchar_t *&aCheques)
Decode action 'Safebag close'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagData (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, const double *&aDebit, const double *&aTotal, const double *&aDifference, const bool *&aHasDifference, const wchar_t *&aNotes, const wchar_t *&aCoins, const wchar_t *&aCheques)
Decode action 'Safebag data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagOpen (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID)
Decode action 'Safebag open'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagPassingOfRiskData (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, __int32 &aUserID1, __int32 &aUserID2, const __int32 *&aTourNumber, const wchar_t *&aTargetWorkingPlace, const wchar_t *&aPassingOfRiskType)
Decode action 'Safebag passing of risk data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagPassingOfRiskStart (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, __int32 &aUserID1, __int32 &aUserID2, const __int32 *&aTourNumber, const wchar_t *&aTargetWorkingPlace, const wchar_t *&aPassingOfRiskType)
Decode action 'Safebag passing of risk start'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSafebagPassingOfRiskStop (ConstHGscAction anAction, __int32 &aWorkingPlace, TGLibDateTime &aStartTime, TGLibDateTime &aStopTime, const wchar_t *&aSafebagNo, const wchar_t *&aSafebagInfo, SafebagStep &aStepID, __int32 &aUserID1, __int32 &aUserID2, const __int32 *&aTourNumber, const wchar_t *&aTargetWorkingPlace, const wchar_t *&aPassingOfRiskType)
Decode action 'Safebag passing of risk stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSceneStoreModification (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, GUID &aSceneStoreID, const wchar_t *&aSceneStoreName, TGLibDateTime &aTimeStamp, PlcSceneStoreModificationType &aModificationType, const wchar_t *&aUser, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Scene store modification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'Sensor alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorAudioAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Sensor audio alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorInhibitAlarmFinished (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'Sensor inhibit alarm finished'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorInhibitVideoAlarmEx (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone, const VMDCycle *&aVMDCycle, const TPlcRect *&aAlarmArea, const PlcObtrackObjectClass *&aObjectClass)
Decode action 'Sensor inhibit video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorVideoAlarmEx (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone, const VMDCycle *&aVMDCycle, const TPlcRect *&aAlarmArea, const PlcObtrackObjectClass *&aObjectClass)
Decode action 'Sensor video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetCameraText (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, const char *&aText)
Decode action 'Set camera text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetClientVCA (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GTectClientVCAType &aClientVCAType, bool &aEnabled)
Decode action 'Enable client VCA'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetClock (ConstHGscAction anAction, TGLibDateTime &aDate)
Decode action 'Set clock'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetDigitalOutput (ConstHGscAction anAction, TPlcMediaChannelID &aContact, DigitalOutputState &aState)
Decode action 'Set digital output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetExportMarker (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcExportMarker &aMarker)
Decode action 'Set export marker'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetLED (ConstHGscAction anAction, SystemLED &aLED, DigitalOutputState &aState)
Decode action 'Set system LED'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetLEDBlink (ConstHGscAction anAction, SystemLED &aLED, __int32 &aLedTimeOnMs, __int32 &aLedTimeOffMs)
Decode action 'Set system LED to blink'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetSystemTime (ConstHGscAction anAction, TGLibDateTime &aTimeStamp)
Decode action 'Set system time'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetTestPictureMode (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, bool &aMode)
Decode action 'Set test picture mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetupChanged (ConstHGscAction anAction, const wchar_t *&aUser, const wchar_t *&aHost, TGLibDateTime &aDate, PlcResourceKind &aResourceKind, TPlcEventTypeID &aResourceID, PlcResourceChangeKind &aChangeKind, const wchar_t *&aDetails, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Setup changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetupUploadProgress (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, __int32 &aProgress, TGLibDateTime &aDate)
Decode action 'Setup upload progress'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSetWatchdog (ConstHGscAction anAction, __int32 &aTimeout)
Decode action 'Set watchdog'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataControl (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataControl &aData)
Decode action 'SKIDATA control'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataDeviceEvent (ConstHGscAction anAction, const wchar_t *&aInterfaceName, __int32 &aDeviceID, __int32 &aEventCode)
Decode action 'SKIDATA device event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataEntry (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataMsgCodeEntry &aMessageCode, const wchar_t *&aTranscactionID, __int32 &aCarParkNo, __int32 &aDeviceID)
Decode action 'SKIDATA entry'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataExit (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataMsgCodeExit &aMessageCode, const wchar_t *&aTranscactionID, __int32 &aCarParkNo, __int32 &aDeviceID)
Decode action 'SKIDATA exit'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSkidataTransaction (ConstHGscAction anAction, const wchar_t *&aInterfaceName, PlcSkidataMsgCodeTransaction &aMessageCode, const wchar_t *&aTranscactionID, __int32 &aCarParkNo, __int32 &aDeviceID)
Decode action 'SKIDATA transaction'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSMRPViewerCleared (ConstHGscAction anAction)
Decode action 'SMRP viewer cleared'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSMRPViewerConnected (ConstHGscAction anAction, const wchar_t *&aServer, TPlcMediaChannelID &aChannel)
Decode action 'SMRP viewer connected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSMTPMailSend (ConstHGscAction anAction, const wchar_t *&aSubject, const wchar_t *&aTo, const wchar_t *&aCc, const wchar_t *&aBody, const TPlcMediaChannelID *&aChannel)
Decode action 'SMTP mail'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartAutoBackup (ConstHGscAction anAction, TPlcResourceID &aSchedule)
Decode action 'Start auto backup'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartEventEx (ConstHGscAction anAction, TPlcEventTypeID &aTypeID, const __int64 *&aForeignKey)
Decode action 'Start event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartRemoteExport (ConstHGscAction anAction, GUID &aExportID, GUID &aDevice, PlcBackupFormat &aBackupFormat, TPlcMediaChannelID &aChannel, TGLibDateTime &aSelectionBegin, TGLibDateTime &aSelectionEnd, const wchar_t *&aJobID)
Decode action 'Start remote export'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartSceneStore (ConstHGscAction anAction, GUID &aSceneStoreID, const wchar_t *&aCutList, __int64 &aPreHistoryLength, __int64 &aRecordingLength)
Decode action 'Start scene store'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStopAllEvents (ConstHGscAction anAction)
Decode action 'Stop all events'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStopEvent (ConstHGscAction anAction, TPlcEventTypeID &aTypeID)
Decode action 'Stop event'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStopEventByID (ConstHGscAction anAction, __int64 &aEventID)
Decode action 'Stop event by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemError (ConstHGscAction anAction, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'System error'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemInfo (ConstHGscAction anAction, PlcMessageSource &aSource, PlcMessageCode &aMessage, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'System info'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemSettingsChanged (ConstHGscAction anAction, bool &aSetupChanged, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, bool &aTimeRangeChanged, const TPlcResourceID *&aTimeRange, bool &aLicenceChanged, TGLibDateTime &aDate)
Decode action 'System settings changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemStarted (ConstHGscAction anAction, TGLibDateTime &aDate)
Decode action 'System started'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemTerminating (ConstHGscAction anAction, TGLibDateTime &aDate, bool &aWindowsShutdown)
Decode action 'System terminating'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSystemWarning (ConstHGscAction anAction, PlcMessageSource &aSource, PlcMessageCode &aMessage, const __int32 *&aWindowsError, const wchar_t *&aDescription, const char *&aXMLInfo)
Decode action 'System warning'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTemperature (ConstHGscAction anAction, IODeviceType &aSourceType, const wchar_t *&aID, __int32 &aTemperature)
Decode action 'Temperature notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTerminalArticleData (ConstHGscAction anAction, const wchar_t *&aTerminalName, TGLibDateTime &aTimeStamp, __int32 &aCashierStation, const __int32 *&aPumpNo, bool &aAlarmStatus, const double *&aAmount, const double *&aPrice, const wchar_t *&aDetails)
Decode action 'Terminal article data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTerminalPaymentData (ConstHGscAction anAction, const wchar_t *&aTerminalName, TGLibDateTime &aTimeStamp, __int32 &aCashierStation, const __int32 *&aPumpNo, bool &aAlarmStatus, const double *&aAmount, const double *&aPrice, const wchar_t *&aDetails)
Decode action 'Terminal payment data'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTiltDown (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Tilt down'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTiltStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Tilt stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTiltUp (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Tilt up'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTransferBinaryBuffer (ConstHGscAction anAction, GUID &aInternalHandle, const wchar_t *&aParameter)
Decode action 'Transfer binary buffer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeTransferBinaryChannelBuffer (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, GUID &aInternalHandle, const wchar_t *&aParameter)
Decode action 'Transfer binary channel buffer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeUserLogin (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'User login'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeUserLoginFailed (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, UserLoginFailureCode &aRejectReason, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'User login failed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeUserLogout (ConstHGscAction anAction, const wchar_t *&aUser1, const wchar_t *&aUser2, const wchar_t *&aHost, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'User logout'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueConfirm (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue confirm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueConfirmByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID)
Decode action 'VC alarm queue confirm by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueConfirmByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue confirm by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueNotification (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmState &aNotification, __int64 &aAlarmID, TPlcEventTypeID &aTypeID, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'VC alarm queue notification'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueRemove (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue remove'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueRemoveByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID)
Decode action 'VC alarm queue remove by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueRemoveByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue remove by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueSelect (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue select'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueSelectByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID)
Decode action 'VC alarm queue select by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAlarmQueueSelectByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, PlcViewerAlarmQueueSelection &aSelectionMode)
Decode action 'VC alarm queue select by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCASetArmed (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, bool &aArmed)
Decode action 'VCA set armed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAStatusAnswer (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, bool &aArmed)
Decode action 'VCA status answer'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCAStatusRequest (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType)
Decode action 'VCA status request'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCChangeSceneByName (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aScene)
Decode action 'VC change scene by name'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCClearSceneByName (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aScene)
Decode action 'VC clear scene by name'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCFullMode (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aFullMode, bool &aSensitiveAreaEnabled)
Decode action 'VC full mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCSceneChanged (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aScene)
Decode action 'VC scene changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCSetAudioLevel (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int32 &aAudioLevel)
Decode action 'VC set audio level'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCShowViewerText (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aShowText)
Decode action 'VC show viewer text'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVCStretchMode (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aStretchMode)
Decode action 'VC stretch mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoContrastDetected (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video contrast detected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoContrastFailed (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video contrast failed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSetImageBrightness (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, __int32 &aBrightness)
Decode action 'Video set image brightness'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSetImageContrast (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, __int32 &aContrast)
Decode action 'Video set image contrast'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSetImageSaturation (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, __int32 &aSaturation)
Decode action 'Video set image saturation'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSourceChanged (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSignalNorm &aSignalNorm, VideoSignalType &aSignalType, VideoInterlaceType &aInterlaceType)
Decode action 'Video source has changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSyncDetected (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video sync detected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeVideoSyncFailed (ConstHGscAction anAction, TPlcMediaChannelID &aChannel)
Decode action 'Video sync failed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerChangeScene (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer change scene'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerClear (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer clear'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerCleared (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer cleared'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerClearScene (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer clear scene'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerClearTextOutput (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer clear text output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerConnect (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode)
Decode action 'Viewer connect'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerConnected (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer connected'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerConnectLive (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel)
Decode action 'Viewer connect live'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerExportPicture (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aFilePath)
Decode action 'Viewer export picture'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerJumpByTime (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, __int32 &aTimeInSec)
Decode action 'Viewer jump by time'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerMaximize (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aMaximize)
Decode action 'Viewer maximize'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerPlayFromTime (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, TGLibDateTime &aTime)
Decode action 'Viewer play from time'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerPlayModeChanged (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, const TGLibDateTime *&aChannelTime, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer play mode changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerPrintPicture (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer print picture'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSelect (ConstHGscAction anAction, TPlcMediaChannelID &aViewer)
Decode action 'Viewer select'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSelectionChanged (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcMediaChannelID &aChannel, PlcViewerPlayMode &aPlayMode, const wchar_t *&aClientHost, const PlcClientType *&aClientType, const wchar_t *&aClientAccount)
Decode action 'Viewer selection changed'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSetPlayMode (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, PlcViewerPlayMode &aPlayMode, __int32 &aPlaySpeed)
Decode action 'Viewer set play mode'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerShowAlarmByInstance (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aAlarmID, PlcViewerAlarmPlayMode &aPlayMode)
Decode action 'Viewer show alarm by instance'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerShowAlarmByKey (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, __int64 &aForeignKey, PlcViewerAlarmPlayMode &aPlayMode)
Decode action 'Viewer show alarm by key'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerShowAlarmByType (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, TPlcEventTypeID &aTypeID, const __int64 *&aForeignKey, PlcViewerAlarmPlayMode &aPlayMode)
Decode action 'Viewer show alarm by type'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerSyncAudioAndVideo (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, bool &aEnableSync)
Decode action 'Viewer change sync audio/video'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeViewerTextOutput (ConstHGscAction anAction, TPlcMediaChannelID &aViewer, const wchar_t *&aText)
Decode action 'Viewer text output'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeWatchdogActivate (ConstHGscAction anAction)
Decode action 'Watchdog activate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeWatchdogDeactivate (ConstHGscAction anAction)
Decode action 'Watchdog deactivate'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeWatchdogTrigger (ConstHGscAction anAction)
Decode action 'Watchdog trigger'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeZoomIn (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Zoom in'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeZoomOut (ConstHGscAction anAction, TPlcMediaChannelID &aCamera, __int32 &aSpeed)
Decode action 'Zoom out'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeZoomStop (ConstHGscAction anAction, TPlcMediaChannelID &aCamera)
Decode action 'Zoom stop'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeEventStarted (ConstHGscAction anAction, __int64 &aEventID, TPlcEventTypeID &aTypeID)
Deprecated functions.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorInhibitVideoAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone)
Decode action 'Sensor inhibit video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeSensorVideoAlarm (ConstHGscAction anAction, TPlcMediaChannelID &aChannel, VideoSensorKind &aSensorType, const ADArea *&aADArea, const __int32 *&aADCell, const VMDGroup *&aVMDGroup, const __int32 *&aVMDZone)
Decode action 'Sensor video alarm'.
GSCACTDLLCALL bool __stdcall | GscAct_DecodeStartEvent (ConstHGscAction anAction, TPlcEventTypeID &aTypeID)
Decode action 'Start event'.

Variables

const char | GscActionsDll [] = "GscActions.DLL"
DLL name.
const int | GscActionAPIVersion = 95
API version.
const char | GscActionAPIDate [] = "05.09.2013"
API release date.

Define Documentation

#define GSCACTDLLCALL __declspec(dllimport)

export style declaration.

__stdcall is used as call convention.

Definition at line 23 of file GscActions.h.


GSC actions: GscActionsDispatcher.h File Reference

  • File List
  • File Members
Classes

GscActionsDispatcher.h File Reference

Detailed Description

This dispatcher class allows you to implement your own derived dispatcher by overriding virtual functions.

Copyright (c) 2004 - 2010 Geutebrueck GmbH. All rights reserved.

This file is part of the GEVISCOPE SDK.

This software is provided "as is" without express or implied warranty, and with no claim as to its suitability for any purpose.

Definition in file GscActionsDispatcher.h.

#include "GscActions.h"
Include dependency graph for GscActionsDispatcher.h:

Go to the source code of this file.

Classes

class GscActionsDispatcher


GSC actions: GscActionsTypes.h File Reference

  • File List
  • File Members
Classes | Typedefs | Enumerations | Functions | Variables

GscActionsTypes.h File Reference

Detailed Description

Types used by GscActions and GscActionsDlgs DLLs.

Copyright (c) 2004 - 2010 Geutebrueck GmbH. All rights reserved.

This file is part of the GEVISCOPE SDK.

This software is provided "as is" without express or implied warranty, and with no claim as to its suitability for any purpose.

Definition in file GscActionsTypes.h.

#include "GLibDateTime.h"
Include dependency graph for GscActionsTypes.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | TPlcMediaChannelID
Media channel. More...
struct | TPlcEventTypeID
Event type. More...
struct | TPlcResourceID
Resource ID. More...
struct | TPlcRect
PLC rect. More...
struct | TPlcUpdateActionInfoCallback
update callback definition More...
struct | TPlcActionEventDataRecord
Structure to access action fields as event data fields. More...
struct | TGscActionClassInfo
action class info More...
struct | TGscActionClassPlainInfo
action class plain info More...
struct | TGscActionInfo
action info More...
struct | TGscActionPlainInfo
action plain info More...
struct | TGscParameterInfo
parameter info More...
struct | TGscParameterPlainInfo
parameter plain info More...
struct | TGscEnumInfo
enum value info More...
struct | TGscEnumPlainInfo
enum value plain info More...

Typedefs

typedef enum TPlcDigitalInputState | DigitalInputState
State of the digital input contact.
typedef enum TPlcDigitalOutputState | DigitalOutputState
State of the digital output contact.
typedef enum TPlcVideoSignalNorm | VideoSignalNorm
Norm of the video input signal.
typedef enum TPlcVideoSignalType | VideoSignalType
Type of the video input signal.
typedef enum TPlcVideoInterlaceType | VideoInterlaceType
Interlace kind of the video input signal.
typedef enum TPlcADArea | ADArea
Activity detection area.
typedef enum TPlcVMDGroup | VMDGroup
VMD group.
typedef enum TPlcSystemLED | SystemLED
System LED.
typedef enum TPlcVideoSensorKind | VideoSensorKind
Video sensor type.
typedef enum
TPlcUserLoginFailureCode 		UserLoginFailureCode
User login failure code.
typedef enum TPlcPlcMessageSource | PlcMessageSource
Source of the message.
typedef enum TPlcPlcMessageCode | PlcMessageCode
Code of the message.
typedef enum
TPlcPlcViewerAlarmQueueSelection 		PlcViewerAlarmQueueSelection
Viewer alarm queue selection mode.
typedef enum TPlcABCapacityWarning | ABCapacityWarning
Auto backup capacity monitoring warning.
typedef enum
TPlcPlcObtrackObjectStatus 		PlcObtrackObjectStatus
OBTRACK object status.
typedef enum
TPlcPlcObtrackObjectClass 		PlcObtrackObjectClass
OBTRACK object class.
typedef enum TPlcPlcDatabaseStatus | PlcDatabaseStatus
Database status.
typedef enum
TPlcPlcObtrackProcessSize 		PlcObtrackProcessSize
OBTRACK process size.
typedef enum TPlcSystemKey | SystemKey
GEVISCOPE system key.
typedef enum TPlcVMDCycle | VMDCycle
VMD measure cycle.
typedef enum TPlcSafebagStep | SafebagStep
Safebag step.
typedef enum
TPlcPlcObtrackCounterType 		PlcObtrackCounterType
OBTRACK counter type.
typedef enum
TPlcPlcObtrackExceedingDirection 		PlcObtrackExceedingDirection
OBTRACK exceeding direction.
typedef enum
TPlcPlcTunnelAlarmReason 		PlcTunnelAlarmReason
Tunnel alarm reason.
typedef enum TPlcPlcViewerPlayMode | PlcViewerPlayMode
Viewer play mode.
typedef enum
TPlcPlcViewerAlarmPlayMode 		PlcViewerAlarmPlayMode
Viewer alarm play mode.
typedef enum
TPlcPlcViewerAlarmState 		PlcViewerAlarmState
Viewer alarm state notification.
typedef enum TPlcPlcImageExportType | PlcImageExportType
Image export type.
typedef enum TPlcPlcDatabaseRing | PlcDatabaseRing
Database ring.
typedef enum TPlcPlcPluginError | PlcPluginError
Plugin error code.
typedef enum TPlcPlcClientType | PlcClientType
Client type.
typedef enum TPlcPlcFRCNotification | PlcFRCNotification
FRC notification.
typedef enum TPlcPlcResourceKind | PlcResourceKind
PLC resource kind.
typedef enum
TPlcPlcResourceChangeKind 		PlcResourceChangeKind
PLC resource change kind.
typedef enum TPlcPlcPOSStatus | PlcPOSStatus
PLC POS status.
typedef enum TPlcPlcNPRRestriction | PlcNPRRestriction
PLC POS status.
typedef enum
TPlcPlcSpecialConstants 		PlcSpecialConstants
Special constants.
typedef enum TPlcPlcPluginState | PlcPluginState
Plugin state.
typedef enum TPlcPlcPumpStatus | PlcPumpStatus
PLC pump status.
typedef enum TPlcPlcDayNightMode | PlcDayNightMode
Day/night mode.
typedef enum TPlcPlcBacklightMode | PlcBacklightMode
Backlight compensation mode.
typedef enum TPlcPlcSkidataControl | PlcSkidataControl
SKIDATA control message.
typedef enum
TPlcPlcSkidataMsgCodeEntry 		PlcSkidataMsgCodeEntry
SKIDATA message entry.
typedef enum
TPlcPlcSkidataMsgCodeExit 		PlcSkidataMsgCodeExit
SKIDATA message exit.
typedef enum
TPlcPlcSkidataMsgCodeTransaction 		PlcSkidataMsgCodeTransaction
SKIDATA message transaction.
typedef enum TPlcPlcExportMarker | PlcExportMarker
Export marker.
typedef enum TPlcPlcBackupFormat | PlcBackupFormat
Backup format.
typedef enum TPlcPlcExportSuccess | PlcExportSuccess
Export success state.
typedef enum TPlcPlcExportAbort | PlcExportAbort
Export abort flag.
typedef enum TPlcPlcLpsStatus | PlcLpsStatus
Position query status.
typedef enum
TPlcPlcSceneStoreModificationType 		PlcSceneStoreModificationType
Scene store modification type.
typedef enum
TPlcGTectSceneAlarmReason 		GTectSceneAlarmReason
G-Tect alarm reason.
typedef enum TPlcGTectClientVCAType | GTectClientVCAType
G-Tect client VCA type.
typedef enum TPlcLenelAccessResult | LenelAccessResult
Lenel access result.
typedef enum TPlcLenelEventType | LenelEventType
Lenel event type.
typedef enum TPlcLenelEventID | LenelEventID
Lenel event ID.
typedef enum TPlcIODeviceType | IODeviceType
Specifies the type of the io device.
typedef enum TPlcTrafficDirection | TrafficDirection
Traffic direction.
typedef enum TPlcPPAlarmState | PPAlarmState
PP alarm state.
typedef enum TPlcPPCableKind | PPCableKind
PP cable kind.
typedef enum TPlcPPSensorKind | PPSensorKind
PP sensor kind.
typedef enum TPlcIPSwitchOps | IPSwitchOps
IP switch operation.
typedef TPlcResourceID | TPlcTimeRangeID
compatibility definitions
typedef bool(__stdcall * | TUpdateMediaChannelID )(void *Object, TPlcMediaChannelID &Info)
update media channel callback
typedef bool(__stdcall * | TUpdateEventTypeID )(void *Object, TPlcEventTypeID &Info)
update event type callback
typedef bool(__stdcall * | TUpdateResourceID )(void *Object, GscParameterView ParameterView, TPlcResourceID &Info)
update resource ID callback
typedef bool(__stdcall * | TUpdateResChannelID )(void *Object, GscParameterView ParameterView, TPlcResourceID &Info, __int64 &Channel)
update resource ID and channel callback

Enumerations

enum | GscMessageClass { mk_Action = 1, mk_MatchAction = 2, mk_Unknown = 0x7fffffff }

Available message classes.

More...
enum GscActionClass {
ak_System = 0, ak_Video = 1, ak_Audio = 2, ak_CameraControl = 3,
ak_DigitalContacts = 4, ak_Device = 5, ak_ATM = 6, ak_Backup = 7,
ak_CashManagement = 8, ak_Viewer = 9, ak_ViewerNotification = 10, ak_POS = 11,
ak_RemoteExport = 12, ak_SkiData = 13, ak_LPS = 14, ak_Logistic = 15,
ak_Lenel = 16, ak_Imex = 17, ak_PP = 18, ak_Unknown = 0x7fffffff
}

Available action classes.

More...
enum GscActionCode {
ac_SystemStarted = 1, ac_SystemTerminating = 2, ac_UserLogin = 3, ac_UserLoginFailed = 4,
ac_UserLogout = 5, ac_SystemSettingsChanged = 6, ac_LiveCheck = 7, ac_CustomAction = 8,
ac_DatabaseStarted = 9, ac_DeviceFound = 10, ac_DeviceRemoved = 11, ac_DeviceNewFirmware = 12,
ac_DeviceReattached = 13, ac_DevicePluginError = 14, ac_DevicePluginState = 15, ac_SetupUploadProgress = 16,
ac_SetupChanged = 17, ac_FRCNotification = 19, ac_SensorAudioAlarm = 20, ac_ABCConnect = 21,
ac_ABCDisconnect = 22, ac_ABCPlayFile = 23, ac_SetClock = 25, ac_DigitalInput = 30,
ac_SetDigitalOutput = 31, ac_SetLED = 32, ac_SetLEDBlink = 33, ac_KeyPressed = 35,
ac_KeyReleased = 36, ac_RedundantPowerFailure = 37, ac_RedundantPowerOk = 38, ac_VideoSyncDetected = 40,
ac_VideoSyncFailed = 41, ac_ChangeADParameterSet = 42, ac_ChangeVMDParameterSet = 43, ac_ChangeCPAParameterSet = 44,
ac_VideoSourceChanged = 45, ac_VideoContrastDetected = 46, ac_VideoContrastFailed = 47, ac_MakeCPAReferenceImage = 48,
ac_IASSettingsChanged = 49, ac_SystemInfo = 50, ac_SystemWarning = 51, ac_SystemError = 52,
ac_SetWatchdog = 53, ac_StartEvent = 54, ac_StopEvent = 55, ac_StopEventByID = 56,
ac_EventStarted = 59, ac_EventStopped = 60, ac_EventRecordingChanged = 61, ac_StopAllEvents = 62,
ac_KillEvent = 63, ac_KillEventByID = 64, ac_KillAllEvents = 65, ac_BlockingFilterActivate = 68,
ac_BlockingFilterDeactivate = 69, ac_CPAMeasurement = 70, ac_SetTestPictureMode = 72, ac_ChannelLiveCheck = 74,
ac_IPCameraRawCommand = 75, ac_SensorVideoAlarm = 80, ac_SensorInhibitVideoAlarm = 81, ac_SensorAlarmFinished = 84,
ac_SensorInhibitAlarmFinished = 85, ac_ChangeObtrackParameterSet = 90, ac_ObtrackFrameRawData = 91, ac_ObtrackObjectRawData = 92,
ac_ObtrackChannelCounter = 94, ac_ObtrackGroupCounter = 95, ac_ObtrackChannelCounterThreshold = 96, ac_ObtrackGroupCounterThreshold = 97,
ac_ObtrackChannelSetCounter = 98, ac_ObtrackGroupSetCounter = 99, ac_PanRight = 101, ac_PanLeft = 102,
ac_PanStop = 103, ac_TiltUp = 104, ac_TiltDown = 105, ac_TiltStop = 106,
ac_ZoomIn = 107, ac_ZoomOut = 108, ac_ZoomStop = 109, ac_FocusNear = 110,
ac_FocusFar = 111, ac_FocusStop = 112, ac_IrisOpen = 113, ac_IrisClose = 114,
ac_IrisStop = 115, ac_PrePosCallUp = 116, ac_DefaultPosCallUp = 117, ac_CameraTourStart = 118,
ac_CameraTourStop = 119, ac_CameraLightOn = 120, ac_CameraLightOff = 121, ac_CameraOn = 122,
ac_CameraOff = 123, ac_CameraPumpOn = 124, ac_CameraPumpOff = 125, ac_FastSpeedOn = 126,
ac_FastSpeedOff = 127, ac_CameraWashOn = 128, ac_CameraWashOff = 129, ac_CameraSpecFuncUOn = 130,
ac_CameraSpecFuncUOff = 131, ac_CameraSpecFuncVOn = 132, ac_CameraSpecFuncVOff = 133, ac_CameraSpecFuncXOn = 134,
ac_CameraSpecFuncXOff = 135, ac_CameraSpecFuncYOn = 136, ac_CameraSpecFuncYOff = 137, ac_CameraStopAll = 138,
ac_PrePosSave = 139, ac_DefaultPosSave = 140, ac_PrePosClear = 141, ac_DefaultPosClear = 142,
ac_SetCameraText = 143, ac_CameraSelectCharMode = 144, ac_CameraClearPrePosText = 145, ac_CameraSetPrePosText = 146,
ac_CameraRAWOutput = 147, ac_CameraVersionOn = 148, ac_CameraVersionOff = 149, ac_PanAuto = 150,
ac_AutoFocusOn = 151, ac_AutoFocusOff = 152, ac_CameraManualIrisOn = 153, ac_CameraManualIrisOff = 154,
ac_CameraTextOn = 155, ac_CameraTextOff = 156, ac_CameraDayNightMode = 157, ac_CameraBacklightCompensationMode = 158,
ac_CameraApplyProfile = 159, ac_MoveToAbsolutePosition = 160, ac_MoveToRelativePosition = 161, ac_MoveToBySpeed = 162,
ac_ChannelInfo = 180, ac_ChannelWarning = 181, ac_ChannelError = 182, ac_IPSwitchOperation = 190,
ac_ViewerConnectLive = 200, ac_ViewerConnect = 201, ac_ViewerClear = 202, ac_ViewerConnected = 203,
ac_ViewerCleared = 204, ac_ViewerPlayModeChanged = 205, ac_ViewerChangeScene = 206, ac_VCChangeSceneByName = 207,
ac_ViewerClearScene = 208, ac_VCClearSceneByName = 209, ac_ViewerShowAlarmByInstance = 210, ac_ViewerShowAlarmByKey = 211,
ac_ViewerShowAlarmByType = 212, ac_VCSceneChanged = 213, ac_ViewerJumpByTime = 215, ac_ViewerPlayFromTime = 216,
ac_ViewerSetPlayMode = 217, ac_ViewerSyncAudioAndVideo = 220, ac_VCSetAudioLevel = 221, ac_ViewerMaximize = 222,
ac_ViewerExportPicture = 223, ac_ViewerPrintPicture = 224, ac_ImageExportNotification = 225, ac_ViewerSelect = 230,
ac_VCShowViewerText = 231, ac_VCFullMode = 232, ac_VCStretchMode = 233, ac_ViewerTextOutput = 240,
ac_ViewerClearTextOutput = 241, ac_ViewerSelectionChanged = 242, ac_SceneStoreModification = 243, ac_VCAlarmQueueSelect = 250,
ac_VCAlarmQueueSelectByType = 251, ac_VCAlarmQueueConfirm = 252, ac_VCAlarmQueueConfirmByType = 253, ac_VCAlarmQueueRemove = 254,
ac_VCAlarmQueueRemoveByType = 255, ac_VCAlarmQueueSelectByInstance = 256, ac_VCAlarmQueueConfirmByInstance = 257, ac_VCAlarmQueueRemoveByInstance = 258,
ac_VCAlarmQueueNotification = 259, ac_DatabaseRecordingInfoTotal = 260, ac_DatabaseRecordingInfoRing = 263, ac_AutoBackupCapacityMonitoringOutOfDiskSpace = 270,
ac_AutoBackupCapacityMonitoringCapacityWarning = 272, ac_AutoBackupCapacityMonitoringFileAutoDeleted = 274, ac_StartAutoBackup = 280, ac_BackupEvent = 281,
ac_AutoBackupScheduleStarted = 282, ac_AutoBackupScheduleDone = 284, ac_AutoBackupOperationStarted = 286, ac_AutoBackupOperationDone = 288,
ac_AutoBackupFileStarted = 290, ac_AutoBackupFileProgress = 292, ac_AutoBackupFileDone = 294, ac_AbortAutoBackup = 298,
ac_AbortAllAutoBackups = 299, ac_GEMOSalarm = 300, ac_ObtrackTunnelAlarm = 301, ac_SMTPMailSend = 303,
ac_EventBackupStarted = 310, ac_EventBackupDone = 312, ac_EventBackupFileStarted = 314, ac_EventBackupFileProgress = 316,
ac_EventBackupFileDone = 318, ac_ChangeCameraProfile = 330, ac_SMRPViewerConnected = 340, ac_SMRPViewerCleared = 341,
ac_ATMRawData = 350, ac_ATMRawAnswer = 351, ac_ATMTransaction = 352, ac_ACSRawData = 354,
ac_ACSRawAnswer = 355, ac_ACSAccessGranted = 356, ac_ACSAccessDenied = 357, ac_InterfaceRawData = 358,
ac_InterfaceRawAnswer = 359, ac_POSStatus = 360, ac_POSData = 361, ac_TerminalArticleData = 363,
ac_TerminalPaymentData = 364, ac_BarcodeData = 365, ac_FillingPumpStatus = 366, ac_ActivateExternalProcess = 370,
ac_NPRRawData = 371, ac_NPRRecognition = 375, ac_TransferBinaryBuffer = 380, ac_TransferBinaryChannelBuffer = 381,
ac_SetSystemTime = 385, ac_VideoSetImageContrast = 390, ac_VideoSetImageBrightness = 391, ac_VideoSetImageSaturation = 392,
ac_MediaChannelSetupInfo = 395, ac_SafebagOpen = 400, ac_SafebagData = 402, ac_SafebagClose = 405,
ac_SafebagPassingOfRiskStart = 407, ac_SafebagPassingOfRiskData = 410, ac_SafebagPassingOfRiskStop = 413, ac_IOI43WDActivate = 420,
ac_IOI43WDDeactivate = 421, ac_IOI43WDTrigger = 422, ac_IOI43ResetMainboard = 423, ac_IOI43Temperature = 424,
ac_SkidataControl = 430, ac_SkidataEntry = 431, ac_SkidataExit = 432, ac_SkidataTransaction = 433,
ac_SkidataDeviceEvent = 434, ac_WatchdogActivate = 440, ac_WatchdogDeactivate = 441, ac_WatchdogTrigger = 442,
ac_Temperature = 443, ac_ResetMainboard = 444, ac_CaseOpened = 445, ac_CaseClosed = 446,
ac_SetExportMarker = 450, ac_InitializeRemoteExport = 451, ac_StartRemoteExport = 452, ac_ExportProgress = 454,
ac_ExportFinished = 455, ac_CancelExport = 456, ac_StartSceneStore = 457, ac_LPSPositionData = 460,
ac_LPSQueryPosition = 463, ac_LogBarcodeData = 465, ac_LogBarcodeDataLPS = 467, ac_LogNPRRecognition = 469,
ac_GSCSVehicleAccessDenied = 480, ac_GSCSVehicleAccessGranted = 482, ac_GSCSVehicleAccessExpired = 484, ac_GSCSVehicleAccessPending = 486,
ac_LenelSecurityEvent = 500, ac_LenelAccessEvent = 502, ac_LenelIntercomEvent = 506, ac_LenelVideoEvent = 508,
ac_LenelFireEvent = 510, ac_LenelRawData = 512, ac_LenelRefreshNames = 514, ac_GTectVMXAlarm = 520,
ac_GTectVMXAlarmFinished = 522, ac_GTectDualSensorAlarm = 524, ac_GTectDualSensorAlarmFinished = 526, ac_GTectSceneAlarm = 528,
ac_GTectSceneAlarmFinished = 530, ac_GTectAnalyticsLiveCheck = 532, ac_ChangeGTectParameterSet = 534, ac_SetClientVCA = 536,
ac_VCASetArmed = 537, ac_VCAStatusRequest = 538, ac_VCAStatusAnswer = 539, ac_IPCamFailoverNotification = 540,
ac_IPCamFailoverRestore = 541, ac_ImexCapacityWarning = 550, ac_ImexCapacityOutOfDiskSpace = 552, ac_ImexCapacityFileAutoDeleted = 554,
ac_ImexExportImageFromDB = 560, ac_ImexExportEventImage = 562, ac_ImexExportImageFromLiveStream = 564, ac_PPSubcellAlarm = 580,
ac_PPDeviceAlarm = 581, ac_PPZoneAlarm = 582, ac_PPDeviceInput = 583, ac_PPSetDeviceOutput = 584,
ac_PPQueryInterface = 585, ac_PPInterfaceOnline = 586, ac_PPInterfaceOffline = 587, ac_PPDeviceOnline = 588,
ac_PPDeviceOffline = 589, ac_Unknown = 0x7fffffff
}

Available action codes.

More...
enum | TPlcDigitalInputState { disLow = 0, disMiddle = 1, disHigh = 2, disUnknown = 0x7fffffff }

State of the digital input contact.

More...
enum | TPlcDigitalOutputState { dosOpen = 0, dosClose = 1, dosToggle = 2, dosUnknown = 0x7fffffff }

State of the digital output contact.

More...
enum | TPlcVideoSignalNorm { vsnEIA = 0, vsnCCIR = 1, vsnUnknown = 0x7fffffff }

Norm of the video input signal.

More...
enum | TPlcVideoSignalType { vstBAS = 0, vstFBAS = 1, vstUnknown = 0x7fffffff }

Type of the video input signal.

More...
enum | TPlcVideoInterlaceType { vsdInterlaced = 0, vsdNonInterlaced = 1, vsdUnknown = 0x7fffffff }

Interlace kind of the video input signal.

More...
enum TPlcADArea {
adgArea1 = 0, adgArea2 = 1, adgArea3 = 2, adgArea4 = 3,
adgUnknown = 0x7fffffff
}

Activity detection area.

More...
enum TPlcVMDGroup {
vmgGroup1 = 0, vmgGroup2 = 1, vmgGroup3 = 2, vmgGroup4 = 3,
vmgUnknown = 0x7fffffff
}

VMD group.

More...
enum TPlcSystemLED {
ledError = 0, ledRecord = 1, ledGreen = 2, ledYellow = 3,
ledIOI43a1 = 9, ledIOI43a2 = 10, ledIOI43a3 = 11, ledIOI43a4 = 12,
ledUnknown = 0x7fffffff
}

System LED.

More...
enum TPlcVideoSensorKind {
vskAD = 0, vskVMD = 1, vskCPA = 2, vskIPAD = 3,
vskOBTRACK = 4, vskDUAL = 5, vskNPR = 6, vskFR = 7,
vskVAMissing = 8, vskCPAExt = 9, vskGTectVMX = 10, vskUnknown = 0x7fffffff
}

Video sensor type.

More...
enum TPlcUserLoginFailureCode {
ulfUser1NotFound = 1, ulfUser1InvalPwd = 2, ulfUser2NotFound = 3, ulfUser2InvalPwd = 4,
ulfMissingSecondUser = 5, ulfUser2NotAdmitted = 6, ulfNoLicense = 7, ulfTooManyClients = 8,
ulfUnknown = 0x7fffffff
}

User login failure code.

More...
enum TPlcPlcMessageSource {
pmsServer = 0, pmsSetup = 1, pmsDBE = 2, pmsMediaAPI = 3,
pmsMediaPlugin = 4, pmsPLC = 5, pmsAutoBackup = 6, pmsDongle = 7,
pmsFRC = 8, pmsATM = 9, pmsSensor = 10, pmsPOS = 11,
pmsACS = 12, pmsIOI43 = 13, pmsInterface = 14, pmsTranscoder = 15,
pmsLenel = 16, pmsLogistic = 17, pmsLPS = 18, pmsSCS = 19,
pmsVAM = 20, pmsMIO = 21, pmsPP = 22, pmsUnknown = 0x7fffffff
}

Source of the message.

More...
enum TPlcPlcMessageCode {
pmcInternalError = 0, pmcOutOfResources = 1, pmcUnlicensed = 2, pmcConnectionLost = 3,
pmcUnknownError = 4, pmcDemoModeExpired = 5, pmcDatabaseFileMissing = 10, pmcFileAccessError = 11,
pmcFLTMInefficient = 12, pmcDBECouldNotFreeAnyPage = 13, pmcDongleFound = 20, pmcDongleMissing = 21,
pmcDongleWrong = 22, pmcDongleInsufficient = 23, pmcFirmwareUploadFailed = 30, pmcWatchdogReset = 31,
pmcHttpError = 35, pmcHostRestrictions = 36, pmcInsufficientFrameRate = 40, pmcTranscoderOverload = 41,
pmcNoControlForLongTime = 50, pmcBehaviouralRuleTooDeep = 51, pmcCannotOpenPort = 61, pmcCannotEnumeratePorts = 62,
pmcCannotSetFilter = 63, pmcDataOverflow = 64, pmcInsufficientData = 65, pmcIODeviceFound = 70,
pmcIODeviceLost = 71, pmcIODeviceNotFound = 72, pmcIOTemperatureBelow = 73, pmcIOTemperatureAbove = 74,
pmcIODriverNotInstalled = 75, pmcIOCannotEnumerate = 76, pmcIOCannotOpen = 77, pmcIODuplcatedAddress = 78,
pmcIOUnusedDevice = 79, pmcUnknown = 0x7fffffff
}

Code of the message.

More...
enum TPlcPlcViewerAlarmQueueSelection {
aqsFirst = 0, aqsLast = 1, aqsNext = 2, aqsPrevious = 3,
aqsUnknown = 0x7fffffff
}

Viewer alarm queue selection mode.

More...
enum TPlcABCapacityWarning {
abwOk = 0, abwFreeCapacityBelowLimit = 1, abwAllocatedCapacityAboveLimit = 2, abwBoth = 3,
abwUnknown = 0x7fffffff
}

Auto backup capacity monitoring warning.

More...
enum TPlcPlcObtrackObjectStatus {
oosStarting = 0, oosStationary = 1, oosLeaving = 2, oosUndefined = 3,
oosDeleted = 4, oosUnknown = 0x7fffffff
}

OBTRACK object status.

More...
enum | TPlcPlcObtrackObjectClass { oocPerson = 0, oocCar = 1, oocUndefined = 2, oocUnknown = 0x7fffffff }

OBTRACK object class.

More...
enum | TPlcPlcDatabaseStatus { dbsEmpty = 0, dbsReady = 1, dbsFileAdded = 2, dbsUnknown = 0x7fffffff }

Database status.

More...
enum | TPlcPlcObtrackProcessSize { opsCIF = 0, opsFourCIF = 1, opsTakeWhatYouGet = 2, opsUnknown = 0x7fffffff }

OBTRACK process size.

More...
enum TPlcSystemKey {
keyDisplay1 = 0, keyDisplay2 = 1, keyDisplay3 = 2, keyDisplay4 = 3,
keyReporter1 = 256, keyUnknown = 0x7fffffff
}

GEVISCOPE system key.

More...
enum TPlcVMDCycle {
vmc40ms = 0, vmc160ms = 1, vmc640ms = 2, vmc2_5s = 3,
vmc10s = 4, vmcUnknown = 0x7fffffff
}

VMD measure cycle.

More...
enum | TPlcSafebagStep { sbsOpen = 0, sbsUnknown = 0x7fffffff }

Safebag step.

More...
enum | TPlcPlcObtrackCounterType { octIncoming = 0, octOutcoming = 1, octCommon = 2, octUnknown = 0x7fffffff }

OBTRACK counter type.

More...
enum | TPlcPlcObtrackExceedingDirection { oedExceed = 0, oedFallBelow = 1, oedUnknown = 0x7fffffff }

OBTRACK exceeding direction.

More...
enum | TPlcPlcTunnelAlarmReason { tarPerson = 0, tarPark = 1, tarWrongDirection = 2, tarUnknown = 0x7fffffff }

Tunnel alarm reason.

More...
enum TPlcPlcViewerPlayMode {
vpmUnknownMode = 0, vpmPlayStop = 1, vpmPlayForward = 2, vpmPlayBackward = 3,
vpmPlayFastForward = 4, vpmPlayFastBackward = 5, vpmPlayStepForward = 6, vpmPlayStepBackward = 7,
vpmPlayBOD = 8, vpmPlayEOD = 9, vpmPlayQuasiLive = 10, vpmPlayStream = 11,
vpmPlayNextEvent = 12, vpmPlayPrevEvent = 13, vpmPeekLivePicture = 14, vpmPlayNextMOS = 17,
vpmPlayPrevMOS = 18, vpmUnknown = 0x7fffffff
}

Viewer play mode.

More...
enum TPlcPlcViewerAlarmPlayMode {
apmDefault = 0, apmLiveReplay = 1, apmReplayEventPictures = 2, apmContinuousEventReplayInALoop = 3,
apmShowFirstAlarmPictureOnly = 4, apmUnknown = 0x7fffffff
}

Viewer alarm play mode.

More...
enum TPlcPlcViewerAlarmState {
vasNewAlarm = 0, vasPresented = 1, vasStacked = 2, vasConfirmed = 3,
vasRemoved = 4, vasLastConfirmed = 5, vasLastRemoved = 6, vasListConfirmed = 7,
vasListEmpty = 8, vasUnknown = 0x7fffffff
}

Viewer alarm state notification.

More...
enum TPlcPlcImageExportType {
ietSingleImage = 0, ietBackupFile = 1, ietVideoFile = 2, ietClipboard = 3,
ietPrinter = 4, ietUnknown = 0x7fffffff
}

Image export type.

More...
enum TPlcPlcDatabaseRing {
dbrRing1 = 0, dbrRing2 = 1, dbrRing3 = 2, dbrRing4 = 3,
dbrRing5 = 4, dbrRing6 = 5, dbrRing7 = 6, dbrRing8 = 7,
dbrUnknown = 0x7fffffff
}

Database ring.

More...
enum TPlcPlcPluginError {
ppeInternalError = 1, ppeOutOfResources = 2, ppeUnlicensed = 3, ppeConnectionLost = 4,
ppeUnknownError = 5, ppeUnknown = 0x7fffffff
}

Plugin error code.

More...
enum TPlcPlcClientType {
pctInvalid = 0, pctGscView = 1, pctGscSetup = 2, pctGscRegEdit = 3,
pctGscWeb = 4, pctDefault = 5, pctGscSupplyChain = 6, pctUnknown = 0x7fffffff
}

Client type.

More...
enum TPlcPlcFRCNotification {
frnDataOverwritten = 0, frnBufferActivated = 1, frnReconcileStarted = 2, frnReconcileProgress = 3,
frnReconcileAborted = 4, frnReconcileFinished = 5, frnUnknown = 0x7fffffff
}

FRC notification.

More...
enum TPlcPlcResourceKind {
prkNotSpecified = 0, prkVideoInput = 1, prkPTZHead = 2, prkDigitalInput = 3,
prkDigitalOutput = 4, prkUser = 5, prkTimeRange = 6, prkVCUserOptions = 7,
prkVCAllProfiles = 8, prkUnknown = 0x7fffffff
}

PLC resource kind.

More...
enum | TPlcPlcResourceChangeKind { rckAdded = 0, rckRemoved = 1, rckModified = 2, rckUnknown = 0x7fffffff }

PLC resource change kind.

More...
enum | TPlcPlcPOSStatus { posStarted = 0, posCleared = 1, posStopped = 2, posUnknown = 0x7fffffff }

PLC POS status.

More...
enum | TPlcPlcNPRRestriction { nrrUnspecified = 0, nrrBlackListed = 1, nrrWhiteListed = 2, nrrUnknown = 0x7fffffff }

PLC POS status.

More...
enum | TPlcPlcSpecialConstants { pscRestOfTime = 0, pscUnknown = 0x7fffffff }

Special constants.

More...
enum | TPlcPlcPluginState { ppsInternalState = 0, ppsConnected = 1, ppsDisconnected = 2, ppsUnknown = 0x7fffffff }

Plugin state.

More...
enum TPlcPlcPumpStatus {
pumStarted = 0, pumStopped = 1, pumCleared = 2, pumAmount = 3,
pumUnknown = 0x7fffffff
}

PLC pump status.

More...
enum | TPlcPlcDayNightMode { pdnDay = 0, pdnNight = 1, pdnAuto = 2, pdnUnknown = 0x7fffffff }

Day/night mode.

More...
enum | TPlcPlcBacklightMode { pbmOff = 0, pbmOn = 1, pbmUnknown = 0x7fffffff }

Backlight compensation mode.

More...
enum TPlcPlcSkidataControl {
sdcConnectionOk = 1, sdcConnectionFailed = 2, sdcDisconnected = 3, sdcConnectionLost = 4,
sdcUnknown = 0x7fffffff
}

SKIDATA control message.

More...
enum TPlcPlcSkidataMsgCodeEntry {
sdenTicket = 1, sdenCreditCard = 2, sdenElectronicPurse = 3, sdenExternalCard = 4,
sdenUnknown = 0x7fffffff
}

SKIDATA message entry.

More...
enum TPlcPlcSkidataMsgCodeExit {
sdexTicket = 1, sdexCreditCard = 2, sdexElectronicPurse = 3, sdexExternalCard = 4,
sdexUnknown = 0x7fffffff
}

SKIDATA message exit.

More...
enum TPlcPlcSkidataMsgCodeTransaction {
sdtrParking = 1, sdtrSale = 2, sdtrOther = 3, sdtrCash = 4,
sdtrCheck = 5, sdtrCreditCard = 6, sdtrInvoice = 7, sdtrValueCard = 8,
sdtrValidation = 9, sdtrToken = 10, sdtrElectronicPurse = 11, sdtrIsoDiscount = 12,
sdtrUnknown = 0x7fffffff
}

SKIDATA message transaction.

More...
enum | TPlcPlcExportMarker { exmSelectionBegin = 0, exmSelectionEnd = 1, exmUnknown = 0x7fffffff }

Export marker.

More...
enum | TPlcPlcBackupFormat { ebfDefault = 0, ebfGBF = 1, ebfMPEG2 = 2, ebfUnknown = 0x7fffffff }

Backup format.

More...
enum TPlcPlcExportSuccess {
exsSuccess = 0, exsFailed = 1, exsAborted = 2, exsLowDiscSpace = 3,
exsNoUserRights = 4, exsQueueSizeReached = 5, exsConnectionError = 6, exsUnknown = 0x7fffffff
}

Export success state.

More...
enum TPlcPlcExportAbort {
exaUserAbort = 0, exaLowDiscSpace = 1, exaNoUserRights = 2, exaError = 3,
exaUnknown = 0x7fffffff
}

Export abort flag.

More...
enum TPlcPlcLpsStatus {
lstPositionOK = 0, lstUnknownArea = 1, lstLastPosition = 2, lstInvalidID = 3,
lstError = 4, lstUnknown = 0x7fffffff
}

Position query status.

More...
enum TPlcPlcSceneStoreModificationType {
smtCreate = 0, smtOpen = 1, smtDisplay = 2, smtClose = 3,
smtDelete = 4, smtUnknown = 0x7fffffff
}

Scene store modification type.

More...
enum | TPlcGTectSceneAlarmReason { garViewFieldObservation = 0, garContrast = 1, garUnknown = 0x7fffffff }

G-Tect alarm reason.

More...
enum | TPlcGTectClientVCAType { gvtClientPrivacyMasking = 0, gvtMotionPrivacy = 1, gvtUnknown = 0x7fffffff }

G-Tect client VCA type.

More...
enum TPlcLenelAccessResult {
larOther = 0, larlUnknown = 1, larGranted = 2, larDenied = 3,
larNotApplicable = 4, larUnknown = 0x7fffffff
}

Lenel access result.

More...
enum TPlcLenelEventType {
letAccessGranted = 0, letAccessDenied = 1, letDuress = 2, letAreaAPB = 3,
letSystem = 4, letAsset = 5, letHostMessages = 6, letFireSeven = 7,
letFireEight = 8, letFireNine = 9, letIntercom = 10, letVideo = 11,
letTransmitter = 12, letBiometric = 18, letTrouble = 19, letDigitize = 20,
letBurglary = 21, letTemperature = 22, letGas = 23, letRelaySounder = 24,
letMedical = 25, letWater = 26, letC900 = 27, letOpenClose = 28,
letMuster = 29, letGeneric = 30, letPointofSale = 31, letPortableProgrammer = 32,
letUnknown = 0x7fffffff
}

Lenel event type.

More...
enum TPlcLenelEventID {
leiAccessGranted = 1, leiAccessGrantedonFacilityCode = 2, leiAccessGrantedNoEntryMade = 3, leiAccessGrantedonFacilityCodeNoEntryMade = 4,
leiInvalidCardFormat = 6, leiDeniedCountExceeded = 7, leiDeniedPINOnlyRequest = 8, leiInvalidFacilityCode = 9,
leiInvalidBadge = 10, leiInvalidIssueCode = 11, leiInvalidPINNumber = 12, leiInvalidAccessLevel = 13,
leiInactiveBadge = 14, leiDeniedReaderExcluded = 15, leiDeniedNoCommandAuthority = 16, leiDeniedUnMaskActiveZonesinGroup = 17,
leiUseLimitExceeded = 18, leiAccessGrantedUnderDuress = 20, leiAccessDeniedUnderDuress = 21, leiAccessGrantedUnderDuressNoEntryMade = 22,
leiAntiPassbackViolation = 23, leiAreaLimitExceeded = 24, leiTimeoutExceededNoSecondCard = 25, leiAreaClosed = 26,
leiAccessGrantedAntiPassbackUsed = 27, leiAccessGrantedAntiPassbackNotUsed = 28, leiAntiPassbackInvalidExitReader = 29, leiAntiPassbackInvalidEntryReader = 30,
leiNotConfigured = 33, leiAlarmCanceled = 34, leiAlarmActive = 35, leiDoorForcedOpen = 41,
leiDoorForcedOpenCanceled = 42, leiDoorHeldOpen = 43, leiDoorHeldOpenCanceled = 44, leiReaderInputTamper = 47,
leiReaderInputTamperCanceled = 48, leiDoorContactTamper = 49, leiDoorContactTamperCanceled = 50, leiCabinetTamper = 51,
leiCanceledCabinetTamper = 52, leiPowerFailure = 53, leiCanceledPowerFailure = 54, leiRelayContactActivated = 86,
leiRelayContactDeactivated = 87, leiCommunicationsLost = 109, leiCommunicationsRestored = 110, leiLocalIOExecutedFunctionList = 111,
leiFireAlarmIn = 220, leiFireAlarmOut = 221, leiFireAlarmAcknowledge = 222, leiFireAlarmBlockAcknowledge = 223,
leiCalltoaBusySubscriber = 760, leiCalltoaPrivateSubscriber = 761, leiCalltoanOpenSubscriber = 762, leiCallDisconnected = 763,
leiIntercomFunction = 764, leiTroubleIn = 765, leiTroubleOut = 766, leiTroubleAcknowledge = 767,
leiDeniedLowBattery = 801, leiReaderModeFacilityCode = 802, leiReaderModeCardOnly = 803, leiReaderModeFirstCardUnlock = 804,
leiReaderModeUnlocked = 805, leiReaderModeLocked = 806, leiBiometricMismatch = 812, leiInputMasked = 831,
leiInputUnmasked = 832, leiDoorForcedOpenMasked = 833, leiDoorForcedOpenUnmasked = 834, leiDoorHeldOpenMasked = 835,
leiDoorHeldOpenUnmasked = 836, leiReaderModePinorCard = 837, leiReaderModeCardandPin = 838, leiAcceptedBiometricScore = 839,
leiRejectedBiometricScore = 840, leiNoBiometricTemplateData = 841, leiPanelOptionsMismatch = 842, leiAccessGrantedReaderUnlocked = 843,
leiAccessDeniedReaderLocked = 844, leiMaxCardholdersReached = 845, leiMaxAssetsReached = 846, leiAccessGrantedGenral = 847,
leiAccessDeniedGeneral = 848, leiAccessDeniedDoorSecured = 849, leiAccessDeniedInterlock = 850, leiAccessDeniedPassback = 851,
leiAccessDeniedUnauthorizedArmingState = 852, leiAccessDeniedUnauthorizedEntryLevel = 853, leiAccessDeniedUnauthorizedTime = 854, leiSchedulerActionFailed = 1502,
leiSchedulerActionExecuted = 1503, leiGuardTourActionFailed = 1504, leiGuardTourActionExecuted = 1505, leiGlobalLinkageActionFailed = 1506,
leiGlobalLinkageActionExecuted = 1507, leiDeniedNoHostApproval = 1508, leiDeniedUnauthorizedAssets = 1509, leiFirstCardUnlockModeEnabled = 1542,
leiFirstCardUnlockModeDisabled = 1543, leiExtendedHeldOpenModeEnabled = 1544, leiExtendedHeldOpenModeDisabled = 1545, leiCipherModeEnabled = 1546,
leiCipherModeDisabled = 1547, leiBiometricVerifyModeEnabled = 1548, leiBiometricVerifyModeDisabled = 1549, leiAccessDeniedNoBiometricTemplate = 1550,
leiAccessDeniedBiometricReaderOffline = 1551, leiExtendedHeldCommandDenied = 1552, leiExtendedHeldCommandSetFromReader = 1553, leiIncomingCall = 1554,
leiTroubleReport = 1555, leiTestReport = 1556, leiAcknowledgmentActionExecuted = 1785, leiAcknowledgmentActionFailed = 1786,
leiAlarmMonitoringActionGroupExecuted = 1787, leiAlarmMonitoringActionGroupFailed = 1788, leiSmartCardAuthenticationFailed = 1789, leiRinging = 1794,
leiCallFailed = 1795, leiHold = 1796, leiRetrieved = 1797, leiInitiated = 1798,
leiGenericEvent = 1799, leiInputAlarmed = 1808, leiInputNormal = 1809, leiInputLowLow = 1810,
leiInputLow = 1811, leiInputHigh = 1812, leiInputHighHigh = 1813, leiDoorOpen = 1887,
leiDoorClose = 1888, leiCommunicationsWithHostLost = 1889, leiCommunicationsWithHostRestored = 1890, leiCallEnded = 1891,
leiCallEstablished = 1892, leiUnansweredCall = 1893, leiCallTransferred = 1894, leiCallConferenced = 1895,
leiAccessDeniedEscortTimeoutExpired = 1896, leiCallQueued = 1910, leiAccessDeniedAreaOccupied = 1911, leiAccessDeniedNoOccupantApproval = 1912,
leiDeniedBadgeNotinPanel = 1914, leiIntercomExchangeFailure = 1915, leiIntrusionCommandDenied = 1920, leiIntrusionCommandAccepted = 1921,
leiAlarmMaskGroupArmed = 1922, leiAlarmMaskGroupDisarmed = 1923, leiAlarmMaskGroupForceArmed = 1924, leiAlarmMaskGroupMaskCountIncremented = 1925,
leiAlarmMaskGroupMaskCountDecremented = 1926, leiAlarmMaskGroupArmingFailureActivePoints = 1927, leiAccessDeniedAreaEmpty = 1928, leiElevatorTerminalModeDefaultFloororUserEntryofDestinationFloor = 1936,
leiUnknownElevatorTerminal = 1937, leiOpenDoorCommandIssuedDoorUsed = 1938, leiOpenDoorCommandIssuedDoorNotUsed = 1939, leiRequesttoExitDoorUsed = 1940,
leiRequesttoExitDoorNotUsed = 1941, leiElevatorTerminalModeDefaultFloor = 1943, leiElevatorTerminalModeAccesstoAuthorizedFloors = 1944, leiElevatorTerminalModeUserEntryofDestinationFloor = 1945,
leiReaderOffline = 1968, leiReaderOfflineRestored = 1969, leiUnknownUserCommand = 1978, leiAccessDeniedAssetRequired = 1984,
leiAccessDeniedSpecial = 2289, leiUnknown = 0x7fffffff
}

Lenel event ID.

More...
enum | TPlcIODeviceType { dioDeviceTypeMIO = 0, dioDeviceTypeIOI43 = 1, dioUnknown = 0x7fffffff }

Specifies the type of the io device.

More...
enum | TPlcTrafficDirection { tfdIn = 0, tfdOut = 1, tfdUnspecified = 2, tfdUnknown = 0x7fffffff }

Traffic direction.

More...
enum | TPlcPPAlarmState { pasNormal = 0, pasAlarm = 1, pasUnknown = 0x7fffffff }

PP alarm state.

More...
enum | TPlcPPCableKind { pckCableA = 0, pckCableB = 1, pckUnknown = 0x7fffffff }

PP cable kind.

More...
enum TPlcPPSensorKind {
pskCableAFault = 0, pskCableBFault = 1, pskTamper = 2, pskTrap = 3,
pskSensor = 4, pskPath = 5, pskAux = 6, pskService = 7,
pskUnknown = 0x7fffffff
}

PP sensor kind.

More...
enum TPlcIPSwitchOps {
ipoPOEOn = 0, ipoPOEOff = 1, ipoPOEReset = 2, ipoPOEDelayedReset = 3,
ipoUnknown = 0x7fffffff
}

IP switch operation.

More...
enum GscParameterType {
pt___int32 = 0, pt___int64 = 1, pt_TGLibDateTime = 2, pt_string = 3,
pt_widestring = 4, pt_bool = 5, pt_GUID = 6, pt_TEventTypeID = 7,
pt_TMediaChannelID = 8, pt_TResourceID = 9, pt_DigitalInputState = 10, pt_DigitalOutputState = 11,
pt_VideoSignalNorm = 12, pt_VideoSignalType = 13, pt_VideoInterlaceType = 14, pt_ADArea = 15,
pt_VMDGroup = 16, pt_SystemLED = 17, pt_VideoSensorKind = 18, pt_UserLoginFailureCode = 20,
pt_PlcMessageSource = 21, pt_PlcMessageCode = 24, pt_PlcViewerAlarmQueueSelection = 28, pt_ABCapacityWarning = 29,
pt_PlcObtrackObjectStatus = 30, pt_PlcObtrackObjectClass = 31, pt_PlcDatabaseStatus = 32, pt_PlcObtrackProcessSize = 33,
pt_SystemKey = 34, pt_VMDCycle = 35, pt_SafebagStep = 36, pt_PlcObtrackCounterType = 37,
pt_PlcObtrackExceedingDirection = 38, pt_PlcTunnelAlarmReason = 39, pt_PlcViewerPlayMode = 40, pt_PlcViewerAlarmPlayMode = 43,
pt_PlcViewerAlarmState = 45, pt_PlcImageExportType = 47, pt_PlcDatabaseRing = 48, pt_PlcPluginError = 49,
pt_PlcClientType = 50, pt_PlcFRCNotification = 52, pt_PlcResourceKind = 54, pt_PlcResourceChangeKind = 56,
pt_PlcPOSStatus = 58, pt_PlcNPRRestriction = 59, pt_PlcSpecialConstants = 60, pt_PlcPluginState = 61,
pt_PlcPumpStatus = 62, pt_PlcDayNightMode = 63, pt_PlcBacklightMode = 64, pt_PlcSkidataControl = 65,
pt_PlcSkidataMsgCodeEntry = 66, pt_PlcSkidataMsgCodeExit = 68, pt_PlcSkidataMsgCodeTransaction = 70, pt_PlcExportMarker = 72,
pt_PlcBackupFormat = 73, pt_PlcExportSuccess = 74, pt_PlcExportAbort = 75, pt_PlcLpsStatus = 77,
pt_PlcSceneStoreModificationType = 78, pt_GTectSceneAlarmReason = 79, pt_GTectClientVCAType = 80, pt_LenelAccessResult = 95,
pt_LenelEventType = 96, pt_LenelEventID = 99, pt_IODeviceType = 90, pt_TrafficDirection = 81,
pt_PPAlarmState = 82, pt_PPCableKind = 83, pt_PPSensorKind = 84, pt_IPSwitchOps = 85,
pt_double = 100, pt_TPlcRect = 101, pt_Unknown = 0x7fffffff
}

Available parameter types.

More...
enum GscParameterView {
pv_Default = 0, pv_UserName = 1, pv_DeviceType = 2, pv_DeviceName = 3,
pv_VideoInput = 4, pv_VideoOutput = 5, pv_InputContact = 6, pv_OutputContact = 7,
pv_PTZHead = 8, pv_TimeRange = 9, pv_Event = 10, pv_AudioInput = 11,
pv_AudioOutput = 12, pv_ADParameterSet = 13, pv_VMDParameterSet = 14, pv_WindowsError = 15,
pv_DeviceSubType = 16, pv_ForeignKey = 17, pv_CPAParameterSet = 18, pv_ObtrackParameterSet = 19,
pv_ABDestination = 20, pv_ABSchedule = 21, pv_HardwareModule = 22, pv_CameraProfile = 23,
pv_GTectParameterSet = 24, pv_ImexDestination = 25, pv_Unknown = 0x7FFFFFFF
}

Available parameter views.

More...

Functions

bool | IsGscEnumType (GscParameterType ParameterType)
Check the parameter type is an enumerable type.

Variables

const unsigned __int32 | FlagDisableResourceUpdate = 0x00000001
Disable resource update callback.
const unsigned __int32 | FlagDisableInternalInEventData = 0x00000002
Disable storing internal data in event data struct.
const unsigned __int32 | TPlcUpdateActionInfoCallbackVersion = 1
update callback definition version
const unsigned __int32 | PLC_DISABLE_ON_MATCH = 1
setup visibility mask
const unsigned __int32 | PLC_DISABLE_MATCH_BY = 2
setup visibility mask


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- a -

  • ABCapacityWarning : GscActionsTypes.h
  • abwAllocatedCapacityAboveLimit : GscActionsTypes.h
  • abwBoth : GscActionsTypes.h
  • abwFreeCapacityBelowLimit : GscActionsTypes.h
  • abwOk : GscActionsTypes.h
  • abwUnknown : GscActionsTypes.h
  • ac_ABCConnect : GscActionsTypes.h
  • ac_ABCDisconnect : GscActionsTypes.h
  • ac_ABCPlayFile : GscActionsTypes.h
  • ac_AbortAllAutoBackups : GscActionsTypes.h
  • ac_AbortAutoBackup : GscActionsTypes.h
  • ac_ACSAccessDenied : GscActionsTypes.h
  • ac_ACSAccessGranted : GscActionsTypes.h
  • ac_ACSRawAnswer : GscActionsTypes.h
  • ac_ACSRawData : GscActionsTypes.h
  • ac_ActivateExternalProcess : GscActionsTypes.h
  • ac_ATMRawAnswer : GscActionsTypes.h
  • ac_ATMRawData : GscActionsTypes.h
  • ac_ATMTransaction : GscActionsTypes.h
  • ac_AutoBackupCapacityMonitoringCapacityWarning : GscActionsTypes.h
  • ac_AutoBackupCapacityMonitoringFileAutoDeleted : GscActionsTypes.h
  • ac_AutoBackupCapacityMonitoringOutOfDiskSpace : GscActionsTypes.h
  • ac_AutoBackupFileDone : GscActionsTypes.h
  • ac_AutoBackupFileProgress : GscActionsTypes.h
  • ac_AutoBackupFileStarted : GscActionsTypes.h
  • ac_AutoBackupOperationDone : GscActionsTypes.h
  • ac_AutoBackupOperationStarted : GscActionsTypes.h
  • ac_AutoBackupScheduleDone : GscActionsTypes.h
  • ac_AutoBackupScheduleStarted : GscActionsTypes.h
  • ac_AutoFocusOff : GscActionsTypes.h
  • ac_AutoFocusOn : GscActionsTypes.h
  • ac_BackupEvent : GscActionsTypes.h
  • ac_BarcodeData : GscActionsTypes.h
  • ac_BlockingFilterActivate : GscActionsTypes.h
  • ac_BlockingFilterDeactivate : GscActionsTypes.h
  • ac_CameraApplyProfile : GscActionsTypes.h
  • ac_CameraBacklightCompensationMode : GscActionsTypes.h
  • ac_CameraClearPrePosText : GscActionsTypes.h
  • ac_CameraDayNightMode : GscActionsTypes.h
  • ac_CameraLightOff : GscActionsTypes.h
  • ac_CameraLightOn : GscActionsTypes.h
  • ac_CameraManualIrisOff : GscActionsTypes.h
  • ac_CameraManualIrisOn : GscActionsTypes.h
  • ac_CameraOff : GscActionsTypes.h
  • ac_CameraOn : GscActionsTypes.h
  • ac_CameraPumpOff : GscActionsTypes.h
  • ac_CameraPumpOn : GscActionsTypes.h
  • ac_CameraRAWOutput : GscActionsTypes.h
  • ac_CameraSelectCharMode : GscActionsTypes.h
  • ac_CameraSetPrePosText : GscActionsTypes.h
  • ac_CameraSpecFuncUOff : GscActionsTypes.h
  • ac_CameraSpecFuncUOn : GscActionsTypes.h
  • ac_CameraSpecFuncVOff : GscActionsTypes.h
  • ac_CameraSpecFuncVOn : GscActionsTypes.h
  • ac_CameraSpecFuncXOff : GscActionsTypes.h
  • ac_CameraSpecFuncXOn : GscActionsTypes.h
  • ac_CameraSpecFuncYOff : GscActionsTypes.h
  • ac_CameraSpecFuncYOn : GscActionsTypes.h
  • ac_CameraStopAll : GscActionsTypes.h
  • ac_CameraTextOff : GscActionsTypes.h
  • ac_CameraTextOn : GscActionsTypes.h
  • ac_CameraTourStart : GscActionsTypes.h
  • ac_CameraTourStop : GscActionsTypes.h
  • ac_CameraVersionOff : GscActionsTypes.h
  • ac_CameraVersionOn : GscActionsTypes.h
  • ac_CameraWashOff : GscActionsTypes.h
  • ac_CameraWashOn : GscActionsTypes.h
  • ac_CancelExport : GscActionsTypes.h
  • ac_CaseClosed : GscActionsTypes.h
  • ac_CaseOpened : GscActionsTypes.h
  • ac_ChangeADParameterSet : GscActionsTypes.h
  • ac_ChangeCameraProfile : GscActionsTypes.h
  • ac_ChangeCPAParameterSet : GscActionsTypes.h
  • ac_ChangeGTectParameterSet : GscActionsTypes.h
  • ac_ChangeObtrackParameterSet : GscActionsTypes.h
  • ac_ChangeVMDParameterSet : GscActionsTypes.h
  • ac_ChannelError : GscActionsTypes.h
  • ac_ChannelInfo : GscActionsTypes.h
  • ac_ChannelLiveCheck : GscActionsTypes.h
  • ac_ChannelWarning : GscActionsTypes.h
  • ac_CPAMeasurement : GscActionsTypes.h
  • ac_CustomAction : GscActionsTypes.h
  • ac_DatabaseRecordingInfoRing : GscActionsTypes.h
  • ac_DatabaseRecordingInfoTotal : GscActionsTypes.h
  • ac_DatabaseStarted : GscActionsTypes.h
  • ac_DefaultPosCallUp : GscActionsTypes.h
  • ac_DefaultPosClear : GscActionsTypes.h
  • ac_DefaultPosSave : GscActionsTypes.h
  • ac_DeviceFound : GscActionsTypes.h
  • ac_DeviceNewFirmware : GscActionsTypes.h
  • ac_DevicePluginError : GscActionsTypes.h
  • ac_DevicePluginState : GscActionsTypes.h
  • ac_DeviceReattached : GscActionsTypes.h
  • ac_DeviceRemoved : GscActionsTypes.h
  • ac_DigitalInput : GscActionsTypes.h
  • ac_EventBackupDone : GscActionsTypes.h
  • ac_EventBackupFileDone : GscActionsTypes.h
  • ac_EventBackupFileProgress : GscActionsTypes.h
  • ac_EventBackupFileStarted : GscActionsTypes.h
  • ac_EventBackupStarted : GscActionsTypes.h
  • ac_EventRecordingChanged : GscActionsTypes.h
  • ac_EventStarted : GscActionsTypes.h
  • ac_EventStopped : GscActionsTypes.h
  • ac_ExportFinished : GscActionsTypes.h
  • ac_ExportProgress : GscActionsTypes.h
  • ac_FastSpeedOff : GscActionsTypes.h
  • ac_FastSpeedOn : GscActionsTypes.h
  • ac_FillingPumpStatus : GscActionsTypes.h
  • ac_FocusFar : GscActionsTypes.h
  • ac_FocusNear : GscActionsTypes.h
  • ac_FocusStop : GscActionsTypes.h
  • ac_FRCNotification : GscActionsTypes.h
  • ac_GEMOSalarm : GscActionsTypes.h
  • ac_GSCSVehicleAccessDenied : GscActionsTypes.h
  • ac_GSCSVehicleAccessExpired : GscActionsTypes.h
  • ac_GSCSVehicleAccessGranted : GscActionsTypes.h
  • ac_GSCSVehicleAccessPending : GscActionsTypes.h
  • ac_GTectAnalyticsLiveCheck : GscActionsTypes.h
  • ac_GTectDualSensorAlarm : GscActionsTypes.h
  • ac_GTectDualSensorAlarmFinished : GscActionsTypes.h
  • ac_GTectSceneAlarm : GscActionsTypes.h
  • ac_GTectSceneAlarmFinished : GscActionsTypes.h
  • ac_GTectVMXAlarm : GscActionsTypes.h
  • ac_GTectVMXAlarmFinished : GscActionsTypes.h
  • ac_IASSettingsChanged : GscActionsTypes.h
  • ac_ImageExportNotification : GscActionsTypes.h
  • ac_ImexCapacityFileAutoDeleted : GscActionsTypes.h
  • ac_ImexCapacityOutOfDiskSpace : GscActionsTypes.h
  • ac_ImexCapacityWarning : GscActionsTypes.h
  • ac_ImexExportEventImage : GscActionsTypes.h
  • ac_ImexExportImageFromDB : GscActionsTypes.h
  • ac_ImexExportImageFromLiveStream : GscActionsTypes.h
  • ac_InitializeRemoteExport : GscActionsTypes.h
  • ac_InterfaceRawAnswer : GscActionsTypes.h
  • ac_InterfaceRawData : GscActionsTypes.h
  • ac_IOI43ResetMainboard : GscActionsTypes.h
  • ac_IOI43Temperature : GscActionsTypes.h
  • ac_IOI43WDActivate : GscActionsTypes.h
  • ac_IOI43WDDeactivate : GscActionsTypes.h
  • ac_IOI43WDTrigger : GscActionsTypes.h
  • ac_IPCameraRawCommand : GscActionsTypes.h
  • ac_IPCamFailoverNotification : GscActionsTypes.h
  • ac_IPCamFailoverRestore : GscActionsTypes.h
  • ac_IPSwitchOperation : GscActionsTypes.h
  • ac_IrisClose : GscActionsTypes.h
  • ac_IrisOpen : GscActionsTypes.h
  • ac_IrisStop : GscActionsTypes.h
  • ac_KeyPressed : GscActionsTypes.h
  • ac_KeyReleased : GscActionsTypes.h
  • ac_KillAllEvents : GscActionsTypes.h
  • ac_KillEvent : GscActionsTypes.h
  • ac_KillEventByID : GscActionsTypes.h
  • ac_LenelAccessEvent : GscActionsTypes.h
  • ac_LenelFireEvent : GscActionsTypes.h
  • ac_LenelIntercomEvent : GscActionsTypes.h
  • ac_LenelRawData : GscActionsTypes.h
  • ac_LenelRefreshNames : GscActionsTypes.h
  • ac_LenelSecurityEvent : GscActionsTypes.h
  • ac_LenelVideoEvent : GscActionsTypes.h
  • ac_LiveCheck : GscActionsTypes.h
  • ac_LogBarcodeData : GscActionsTypes.h
  • ac_LogBarcodeDataLPS : GscActionsTypes.h
  • ac_LogNPRRecognition : GscActionsTypes.h
  • ac_LPSPositionData : GscActionsTypes.h
  • ac_LPSQueryPosition : GscActionsTypes.h
  • ac_MakeCPAReferenceImage : GscActionsTypes.h
  • ac_MediaChannelSetupInfo : GscActionsTypes.h
  • ac_MoveToAbsolutePosition : GscActionsTypes.h
  • ac_MoveToBySpeed : GscActionsTypes.h
  • ac_MoveToRelativePosition : GscActionsTypes.h
  • ac_NPRRawData : GscActionsTypes.h
  • ac_NPRRecognition : GscActionsTypes.h
  • ac_ObtrackChannelCounter : GscActionsTypes.h
  • ac_ObtrackChannelCounterThreshold : GscActionsTypes.h
  • ac_ObtrackChannelSetCounter : GscActionsTypes.h
  • ac_ObtrackFrameRawData : GscActionsTypes.h
  • ac_ObtrackGroupCounter : GscActionsTypes.h
  • ac_ObtrackGroupCounterThreshold : GscActionsTypes.h
  • ac_ObtrackGroupSetCounter : GscActionsTypes.h
  • ac_ObtrackObjectRawData : GscActionsTypes.h
  • ac_ObtrackTunnelAlarm : GscActionsTypes.h
  • ac_PanAuto : GscActionsTypes.h
  • ac_PanLeft : GscActionsTypes.h
  • ac_PanRight : GscActionsTypes.h
  • ac_PanStop : GscActionsTypes.h
  • ac_POSData : GscActionsTypes.h
  • ac_POSStatus : GscActionsTypes.h
  • ac_PPDeviceAlarm : GscActionsTypes.h
  • ac_PPDeviceInput : GscActionsTypes.h
  • ac_PPDeviceOffline : GscActionsTypes.h
  • ac_PPDeviceOnline : GscActionsTypes.h
  • ac_PPInterfaceOffline : GscActionsTypes.h
  • ac_PPInterfaceOnline : GscActionsTypes.h
  • ac_PPQueryInterface : GscActionsTypes.h
  • ac_PPSetDeviceOutput : GscActionsTypes.h
  • ac_PPSubcellAlarm : GscActionsTypes.h
  • ac_PPZoneAlarm : GscActionsTypes.h
  • ac_PrePosCallUp : GscActionsTypes.h
  • ac_PrePosClear : GscActionsTypes.h
  • ac_PrePosSave : GscActionsTypes.h
  • ac_RedundantPowerFailure : GscActionsTypes.h
  • ac_RedundantPowerOk : GscActionsTypes.h
  • ac_ResetMainboard : GscActionsTypes.h
  • ac_SafebagClose : GscActionsTypes.h
  • ac_SafebagData : GscActionsTypes.h
  • ac_SafebagOpen : GscActionsTypes.h
  • ac_SafebagPassingOfRiskData : GscActionsTypes.h
  • ac_SafebagPassingOfRiskStart : GscActionsTypes.h
  • ac_SafebagPassingOfRiskStop : GscActionsTypes.h
  • ac_SceneStoreModification : GscActionsTypes.h
  • ac_SensorAlarmFinished : GscActionsTypes.h
  • ac_SensorAudioAlarm : GscActionsTypes.h
  • ac_SensorInhibitAlarmFinished : GscActionsTypes.h
  • ac_SensorInhibitVideoAlarm : GscActionsTypes.h
  • ac_SensorVideoAlarm : GscActionsTypes.h
  • ac_SetCameraText : GscActionsTypes.h
  • ac_SetClientVCA : GscActionsTypes.h
  • ac_SetClock : GscActionsTypes.h
  • ac_SetDigitalOutput : GscActionsTypes.h
  • ac_SetExportMarker : GscActionsTypes.h
  • ac_SetLED : GscActionsTypes.h
  • ac_SetLEDBlink : GscActionsTypes.h
  • ac_SetSystemTime : GscActionsTypes.h
  • ac_SetTestPictureMode : GscActionsTypes.h
  • ac_SetupChanged : GscActionsTypes.h
  • ac_SetupUploadProgress : GscActionsTypes.h
  • ac_SetWatchdog : GscActionsTypes.h
  • ac_SkidataControl : GscActionsTypes.h
  • ac_SkidataDeviceEvent : GscActionsTypes.h
  • ac_SkidataEntry : GscActionsTypes.h
  • ac_SkidataExit : GscActionsTypes.h
  • ac_SkidataTransaction : GscActionsTypes.h
  • ac_SMRPViewerCleared : GscActionsTypes.h
  • ac_SMRPViewerConnected : GscActionsTypes.h
  • ac_SMTPMailSend : GscActionsTypes.h
  • ac_StartAutoBackup : GscActionsTypes.h
  • ac_StartEvent : GscActionsTypes.h
  • ac_StartRemoteExport : GscActionsTypes.h
  • ac_StartSceneStore : GscActionsTypes.h
  • ac_StopAllEvents : GscActionsTypes.h
  • ac_StopEvent : GscActionsTypes.h
  • ac_StopEventByID : GscActionsTypes.h
  • ac_SystemError : GscActionsTypes.h
  • ac_SystemInfo : GscActionsTypes.h
  • ac_SystemSettingsChanged : GscActionsTypes.h
  • ac_SystemStarted : GscActionsTypes.h
  • ac_SystemTerminating : GscActionsTypes.h
  • ac_SystemWarning : GscActionsTypes.h
  • ac_Temperature : GscActionsTypes.h
  • ac_TerminalArticleData : GscActionsTypes.h
  • ac_TerminalPaymentData : GscActionsTypes.h
  • ac_TiltDown : GscActionsTypes.h
  • ac_TiltStop : GscActionsTypes.h
  • ac_TiltUp : GscActionsTypes.h
  • ac_TransferBinaryBuffer : GscActionsTypes.h
  • ac_TransferBinaryChannelBuffer : GscActionsTypes.h
  • ac_Unknown : GscActionsTypes.h
  • ac_UserLogin : GscActionsTypes.h
  • ac_UserLoginFailed : GscActionsTypes.h
  • ac_UserLogout : GscActionsTypes.h
  • ac_VCAlarmQueueConfirm : GscActionsTypes.h
  • ac_VCAlarmQueueConfirmByInstance : GscActionsTypes.h
  • ac_VCAlarmQueueConfirmByType : GscActionsTypes.h
  • ac_VCAlarmQueueNotification : GscActionsTypes.h
  • ac_VCAlarmQueueRemove : GscActionsTypes.h
  • ac_VCAlarmQueueRemoveByInstance : GscActionsTypes.h
  • ac_VCAlarmQueueRemoveByType : GscActionsTypes.h
  • ac_VCAlarmQueueSelect : GscActionsTypes.h
  • ac_VCAlarmQueueSelectByInstance : GscActionsTypes.h
  • ac_VCAlarmQueueSelectByType : GscActionsTypes.h
  • ac_VCASetArmed : GscActionsTypes.h
  • ac_VCAStatusAnswer : GscActionsTypes.h
  • ac_VCAStatusRequest : GscActionsTypes.h
  • ac_VCChangeSceneByName : GscActionsTypes.h
  • ac_VCClearSceneByName : GscActionsTypes.h
  • ac_VCFullMode : GscActionsTypes.h
  • ac_VCSceneChanged : GscActionsTypes.h
  • ac_VCSetAudioLevel : GscActionsTypes.h
  • ac_VCShowViewerText : GscActionsTypes.h
  • ac_VCStretchMode : GscActionsTypes.h
  • ac_VideoContrastDetected : GscActionsTypes.h
  • ac_VideoContrastFailed : GscActionsTypes.h
  • ac_VideoSetImageBrightness : GscActionsTypes.h
  • ac_VideoSetImageContrast : GscActionsTypes.h
  • ac_VideoSetImageSaturation : GscActionsTypes.h
  • ac_VideoSourceChanged : GscActionsTypes.h
  • ac_VideoSyncDetected : GscActionsTypes.h
  • ac_VideoSyncFailed : GscActionsTypes.h
  • ac_ViewerChangeScene : GscActionsTypes.h
  • ac_ViewerClear : GscActionsTypes.h
  • ac_ViewerCleared : GscActionsTypes.h
  • ac_ViewerClearScene : GscActionsTypes.h
  • ac_ViewerClearTextOutput : GscActionsTypes.h
  • ac_ViewerConnect : GscActionsTypes.h
  • ac_ViewerConnected : GscActionsTypes.h
  • ac_ViewerConnectLive : GscActionsTypes.h
  • ac_ViewerExportPicture : GscActionsTypes.h
  • ac_ViewerJumpByTime : GscActionsTypes.h
  • ac_ViewerMaximize : GscActionsTypes.h
  • ac_ViewerPlayFromTime : GscActionsTypes.h
  • ac_ViewerPlayModeChanged : GscActionsTypes.h
  • ac_ViewerPrintPicture : GscActionsTypes.h
  • ac_ViewerSelect : GscActionsTypes.h
  • ac_ViewerSelectionChanged : GscActionsTypes.h
  • ac_ViewerSetPlayMode : GscActionsTypes.h
  • ac_ViewerShowAlarmByInstance : GscActionsTypes.h
  • ac_ViewerShowAlarmByKey : GscActionsTypes.h
  • ac_ViewerShowAlarmByType : GscActionsTypes.h
  • ac_ViewerSyncAudioAndVideo : GscActionsTypes.h
  • ac_ViewerTextOutput : GscActionsTypes.h
  • ac_WatchdogActivate : GscActionsTypes.h
  • ac_WatchdogDeactivate : GscActionsTypes.h
  • ac_WatchdogTrigger : GscActionsTypes.h
  • ac_ZoomIn : GscActionsTypes.h
  • ac_ZoomOut : GscActionsTypes.h
  • ac_ZoomStop : GscActionsTypes.h
  • ADArea : GscActionsTypes.h
  • adgArea1 : GscActionsTypes.h
  • adgArea2 : GscActionsTypes.h
  • adgArea3 : GscActionsTypes.h
  • adgArea4 : GscActionsTypes.h
  • adgUnknown : GscActionsTypes.h
  • ak_ATM : GscActionsTypes.h
  • ak_Audio : GscActionsTypes.h
  • ak_Backup : GscActionsTypes.h
  • ak_CameraControl : GscActionsTypes.h
  • ak_CashManagement : GscActionsTypes.h
  • ak_Device : GscActionsTypes.h
  • ak_DigitalContacts : GscActionsTypes.h
  • ak_Imex : GscActionsTypes.h
  • ak_Lenel : GscActionsTypes.h
  • ak_Logistic : GscActionsTypes.h
  • ak_LPS : GscActionsTypes.h
  • ak_POS : GscActionsTypes.h
  • ak_PP : GscActionsTypes.h
  • ak_RemoteExport : GscActionsTypes.h
  • ak_SkiData : GscActionsTypes.h
  • ak_System : GscActionsTypes.h
  • ak_Unknown : GscActionsTypes.h
  • ak_Video : GscActionsTypes.h
  • ak_Viewer : GscActionsTypes.h
  • ak_ViewerNotification : GscActionsTypes.h
  • apmContinuousEventReplayInALoop : GscActionsTypes.h
  • apmDefault : GscActionsTypes.h
  • apmLiveReplay : GscActionsTypes.h
  • apmReplayEventPictures : GscActionsTypes.h
  • apmShowFirstAlarmPictureOnly : GscActionsTypes.h
  • apmUnknown : GscActionsTypes.h
  • aqsFirst : GscActionsTypes.h
  • aqsLast : GscActionsTypes.h
  • aqsNext : GscActionsTypes.h
  • aqsPrevious : GscActionsTypes.h
  • aqsUnknown : GscActionsTypes.h


GSC actions: GscActions.h Source File

  • File List
  • File Members

GscActions.h

Go to the documentation of this file.
00001
00002 ///
00003 ///  @file   GscActions.h
00004 ///  @brief  Interface unit for GscActions.DLL.
00005 ///
00006 ///  Copyright (c) 2004 - 2010 Geutebrueck GmbH.  All rights reserved.
00007 ///
00008 ///  This file is part of the GEVISCOPE SDK.
00009 ///
00010 ///  This software is provided "as is" without express or implied warranty,
00011 ///  and with no claim as to its suitability for any purpose.
00012 ///
00013
00014 #ifndef GscActionsH
00015 #define GscActionsH
00016
00017 ///
00018 /// export style declaration.
00019 /// __stdcall is used as call convention.
00020 #ifdef __GscActionsDLL
00021 #define GSCACTDLLCALL __declspec(dllexport)
00022 #else
00023 #define GSCACTDLLCALL __declspec(dllimport)
00024 #endif
00025
00026 #include "GscActionsTypes.h"
00027 #include "GLibDateTime.h"
00028
00029 #ifdef __cplusplus
00030 extern "C"
00031 {
00032 namespace GscPLC
00033 {
00034   using namespace GLib;
00035 #endif
00036
00037 /////////////////////////////////////////////////////////
00038 /// Important constants
00039 /////////////////////////////////////////////////////////
00040
00041 /// \addtogroup GscPlcGeneralDefinition
00042 /// \{
00043
00044 /// DLL name.
00045 const char GscActionsDll[]     = "GscActions.DLL";
00046 /// API version.
00047 const int  GscActionAPIVersion = 95;
00048 /// API release date.
00049 const char GscActionAPIDate[]  = "05.09.2013";
00050
00051 /// \} // end of group GscPlcGeneralDefinition
00052
00053 ////////////////////////////////////////////////////////////////////////////
00054 /// Data types
00055 ////////////////////////////////////////////////////////////////////////////
00056
00057 /// \addtogroup GscPlcClassWrapper
00058 /// \{
00059
00060 class CGscMessage;
00061 class CGscAction;
00062 class CGscMatchAction;
00063
00064 typedef CGscMessage*           HGscMessage;
00065 typedef const CGscMessage*     ConstHGscMessage;
00066 typedef CGscAction*            HGscAction;
00067 typedef const CGscAction*      ConstHGscAction;
00068 typedef CGscMatchAction*       HGscMatchAction;
00069 typedef const CGscMatchAction* ConstHGscMatchAction;
00070
00071 /// \} // end of group GscPlcClassWrapper
00072
00073 /////////////////////////////////////////////////////////
00074 ///
00075 /// imported functions
00076 ///
00077 /////////////////////////////////////////////////////////
00078
00079 /////////////////////////////////////////////////////////
00080 /// General functions
00081 /////////////////////////////////////////////////////////
00082
00083 /// \addtogroup GscPlcGeneralDefinition
00084 /// \{
00085
00086 /// Get the interface version number of the used GscActions.dll.
00087 /// Should be checked against the \ref GscActionAPIVersion
00088 /// to ensure one works with a compatible DLL.
00089 ///
00090 /// @return interface version number
00091 GSCACTDLLCALL int            __stdcall GscAct_InterfaceVersion();
00092
00093 /// Get the interface release date of the used GscActions.dll.
00094 ///
00095 /// @return interface release date
00096 GSCACTDLLCALL const char*    __stdcall GscAct_InterfaceDate();
00097
00098 /// Get the number of open action/message handles.
00099 /// Use this function to detect memory leaks.
00100 ///
00101 /// @return number of open action/message handles.
00102 GSCACTDLLCALL unsigned int   __stdcall GscAct_GetNumberOfOpenHandles();
00103
00104 /// \} // end of group GscPlcGeneralDefinition
00105
00106 /////////////////////////////////////////////////////////
00107 /// Error handling
00108 /////////////////////////////////////////////////////////
00109
00110 /// \addtogroup GscPlcErrorHandling
00111 /// \{
00112
00113 #pragma pack(push, 4)
00114 ///
00115 /// Structure which holds last error info.
00116 struct TPlcLastError
00117 {
00118   int             ErrorClass;       ///< error class
00119   unsigned int    ErrorCode;        ///< error code
00120   const char*     ClassName;        ///< name of the exception class
00121   const char*     ErrorMessageA;    ///< error message as ANSI string
00122   const wchar_t*  ErrorMessageW;    ///< error message as UNICODE string
00123   const char*     XMLInfo;          ///< optional description as XML string
00124 };
00125 #pragma pack(pop)
00126
00127 /// Get information about the last occured error in the current thread.
00128 /// Should be called when any of the other API functions returns false.
00129 ///
00130 /// @param  [out] LastError Reference to structure where to store the information.
00131 /// @return \c true if last error info is available and \c false otherwise.
00132 GSCACTDLLCALL bool           __stdcall GscAct_GetLastError(TPlcLastError& LastError);
00133
00134 /// \} // end of group GscPlcErrorHandling
00135
00136 /////////////////////////////////////////////////////////
00137 /// Enumerate functions for action classes
00138 /////////////////////////////////////////////////////////
00139
00140 /// \addtogroup GscPlcEnumerateActionClasses
00141 /// \{
00142
00143 /// Get number of action classes
00144 /// @return number of action classes
00145 GSCACTDLLCALL unsigned int   __stdcall GscAct_GetNumberOfActionClasses();
00146
00147 /// Get the list of action classes.
00148 /// Required place can be queried with \ref GscAct_GetNumberOfActionClasses.
00149 ///
00150 /// @param [out] List  Retrieves infos. Should be allocated by client.
00151 /// @param [in]  Count Size of the List in elements.
00152 /// @return number of copied elements.
00153 GSCACTDLLCALL unsigned int   __stdcall GscAct_EnumerateActionClasses(
00154                    TGscActionClassPlainInfo List[],
00155                    unsigned int             Count);
00156
00157 /// Get the action class info.
00158 ///
00159 /// @param [out] Info        Reference to info structure.
00160 /// @param [in]  ActionClass Which class is requested.
00161 /// @return \c true if succeeds, \c false otherwise.
00162 GSCACTDLLCALL bool           __stdcall GscAct_GetActionClassInfo(
00163                    TGscActionClassPlainInfo& Info,
00164                    GscActionClass            ActionClass);
00165
00166 /// Set the plain part of action class info.
00167 /// Only \c ActionClass, \c PlainNameW, and \c DescriptionW fields of the struct are used.
00168 ///
00169 /// @param [in]  Info        Const reference to info structure.
00170 /// @return \c true if succeeds, \c false otherwise.
00171 GSCACTDLLCALL bool           __stdcall GscAct_SetActionClassPlainInfo(
00172                    const TGscActionClassPlainInfo& Info);
00173
00174 /// \} // end of group GscPlcEnumerateActionClasses
00175
00176 /////////////////////////////////////////////////////////
00177 /// Enumerate functions for actions
00178 /////////////////////////////////////////////////////////
00179
00180 /// \addtogroup GscPlcEnumerateActions
00181 /// \{
00182
00183 /// Get number of actions
00184 /// @return number of actions
00185 GSCACTDLLCALL unsigned int   __stdcall GscAct_GetNumberOfActions();
00186
00187 /// Get the list of actions.
00188 /// Required place can be queried with \ref GscAct_GetNumberOfActions.
00189 ///
00190 /// @param [out] List  Retrieves infos. Should be allocated by client.
00191 /// @param [in]  Count Size of the List in elements.
00192 /// @return number of copied elements.
00193 GSCACTDLLCALL unsigned int   __stdcall GscAct_EnumerateActions(
00194                    TGscActionPlainInfo List[],
00195                    unsigned int        Count);
00196
00197 /// Get the action info.
00198 ///
00199 /// @param [out] Info        Reference to info structure.
00200 /// @param [in]  ActionCode  Which action is requested.
00201 /// @return \c true if succeeds, \c false otherwise.
00202 GSCACTDLLCALL bool           __stdcall GscAct_GetActionInfo(
00203                    TGscActionPlainInfo& Info,
00204                    GscActionCode        ActionCode);
00205
00206 /// Set the plain part of action info.
00207 /// Only \c ActionCode, \c PlainNameW, and \c DescriptionW fields of the struct are used.
00208 ///
00209 /// @param [in]  Info        Const reference to info structure.
00210 /// @return \c true if succeeds, \c false otherwise.
00211 GSCACTDLLCALL bool           __stdcall GscAct_SetActionPlainInfo(
00212                    const TGscActionPlainInfo& Info);
00213
00214 /// \} // end of group GscPlcEnumerateActions
00215
00216 /////////////////////////////////////////////////////////
00217 /// Enumerate functions for action parameters
00218 /////////////////////////////////////////////////////////
00219
00220 /// \addtogroup GscPlcEnumerateParameters
00221 /// \{
00222
00223 /// Get the number of parameters of the given action.
00224 ///
00225 /// @param [in]  ActionCode  Which action is requested.
00226 /// @return number of parameters of the given action.
00227 ///         This value is the same as in the field \c NumberOfParameters in the action info.
00228 GSCACTDLLCALL unsigned int   __stdcall GscAct_GetNumberOfActionParameters(
00229                    GscActionCode ActionCode);
00230
00231 /// Get the list of parameters.
00232 /// Required place can be queried with \ref GscAct_GetNumberOfActionParameters (\c ActionCode).
00233 ///
00234 /// @param [out] List        Retrieves infos. Should be allocated by client.
00235 /// @param [in]  Count       Size of the List in elements.
00236 /// @param [in]  ActionCode  Which action is requested.
00237 /// @return number of copied elements.
00238 GSCACTDLLCALL unsigned int   __stdcall GscAct_EnumerateActionParameters(
00239                    TGscParameterPlainInfo List[],
00240                    unsigned int           Count,
00241                    GscActionCode          ActionCode);
00242
00243 /// Get the parameter info.
00244 /// Returns the Index-th parameter of the action provided by ActionCode.
00245 ///
00246 /// @param [out] Info        Reference to info structure.
00247 /// @param [in]  ActionCode  Which action is requested.
00248 /// @param [in]  Index       Index of parameter.
00249 /// @return \c true if succeeds, \c false otherwise.
00250 GSCACTDLLCALL bool           __stdcall GscAct_GetActionParameterInfo(
00251                    TGscParameterPlainInfo& Info,
00252                    GscActionCode           ActionCode,
00253                    unsigned int            Index);
00254
00255 /// Set the plain part of parameter info.
00256 /// Index-th parameter of the action provided by ActionCode is used.
00257 /// Only \c PlainNameW and \c DescriptionW fields of the struct are used.
00258 ///
00259 /// @param [in]  Info        Reference to info structure.
00260 /// @param [in]  ActionCode  Which action is requested.
00261 /// @param [in]  Index       Index of parameter.
00262 /// @return \c true if succeeds, \c false otherwise.
00263 GSCACTDLLCALL bool           __stdcall GscAct_SetActionParameterPlainInfo(
00264                    const TGscParameterPlainInfo& Info,
00265                    GscActionCode                 ActionCode,
00266                    unsigned int                  Index);
00267
00268 /// Get the info about match action description.
00269 ///
00270 /// @param [out] Info        Reference to info structure.
00271 /// @return \c true if succeeds, \c false otherwise.
00272 GSCACTDLLCALL bool           __stdcall GscAct_GetMatchActionDescriptionInfo(
00273                    TGscParameterPlainInfo& Info);
00274
00275 /// Set the plain part of match action description info.
00276 /// Only \c PlainNameW and \c DescriptionW fields of the struct are used.
00277 ///
00278 /// @param [in]  Info        Reference to info structure.
00279 /// @return \c true if succeeds, \c false otherwise.
00280 GSCACTDLLCALL bool           __stdcall GscAct_SetMatchActionDescriptionPlainInfo(
00281                    const TGscParameterPlainInfo& Info);
00282
00283 /// \} // end of group GscPlcEnumerateParameters
00284
00285 /////////////////////////////////////////////////////////
00286 /// Enumerate functions for enum values
00287 /////////////////////////////////////////////////////////
00288
00289 /// \addtogroup GscPlcEnumerateEnumValues
00290 /// \{
00291
00292 /// Get the number of available values for enum type.
00293 ///
00294 /// @param [in]  EnumType  Which type is queried. Pass \c pt_Unknown
00295 ///                        to get the list of enum values for all enum types.
00296 /// @return number of elements.
00297 GSCACTDLLCALL unsigned int   __stdcall GscAct_GetNumberOfEnumValues(
00298                    GscParameterType EnumType);
00299
00300 /// Get the list of enum values.
00301 /// Required place can be queried with \ref GscAct_GetNumberOfEnumValues (\c EnumType).
00302 ///
00303 /// @param [out] List        Retrieves infos. Should be allocated by client.
00304 /// @param [in]  Count       Size of the List in elements.
00305 /// @param [in]  EnumType    Which type is queried. Pass \c pt_Unknown
00306 ///                          to get the list of enum values for all enum types.
00307 /// @return number of copied elements.
00308 GSCACTDLLCALL unsigned int   __stdcall GscAct_EnumerateEnumValues(
00309                    TGscEnumPlainInfo List[],
00310                    unsigned int      Count,
00311                    GscParameterType  EnumType);
00312
00313 /// Get the enum info.
00314 ///
00315 /// @param [out] Info        Reference to info structure.
00316 /// @param [in]  EnumType    Which type is queried.
00317 /// @param [in]  Value       Numeric value.
00318 /// @return \c true if succeeds, \c false otherwise.
00319 GSCACTDLLCALL bool           __stdcall GscAct_GetEnumValueInfo(
00320                    TGscEnumPlainInfo& Info,
00321                    GscParameterType   EnumType,
00322                    __int32            Value);
00323
00324 /// Set the plain part of the enum info.
00325 /// Only \c PlainNameW and \c DescriptionW fields of the struct are used.
00326 ///
00327 /// @param [in]  Info        Reference to info structure.
00328 /// @return \c true if succeeds, \c false otherwise.
00329 GSCACTDLLCALL bool           __stdcall GscAct_SetEnumValuePlainInfo(
00330                    const TGscEnumPlainInfo& Info);
00331
00332 /// \} // end of group GscPlcEnumerateEnumValues
00333
00334 /////////////////////////////////////////////////////////
00335 /// Access by name
00336 /////////////////////////////////////////////////////////
00337
00338 /// \addtogroup GscPlcAccessByNames
00339 /// \{
00340
00341 /// Get action class by name.
00342 ///
00343 /// @param [in] Name Name of the class as ANSI string.
00344 /// @return action class if succeeds, \c ak_Unknown otherwise.
00345 GSCACTDLLCALL GscActionClass __stdcall GscAct_GetActionClassByNameA(const char*    Name);
00346
00347 /// Get action class by name.
00348 ///
00349 /// @param [in] Name Name of the class as UNICODE string.
00350 /// @return action class if succeeds, \c ak_Unknown otherwise.
00351 GSCACTDLLCALL GscActionClass __stdcall GscAct_GetActionClassByNameW(const wchar_t* Name);
00352
00353 /// Get action code by name.
00354 ///
00355 /// @param [in] Name Name of the action as ANSI string.
00356 /// @return action code if succeeds, \c ac_Unknown otherwise.
00357 GSCACTDLLCALL GscActionCode  __stdcall GscAct_GetActionCodeByNameA(const char*     Name);
00358
00359 /// Get action code by name.
00360 ///
00361 /// @param [in] Name Name of the action as UNICODE string.
00362 /// @return action code if succeeds, \c ac_Unknown otherwise.
00363 GSCACTDLLCALL GscActionCode  __stdcall GscAct_GetActionCodeByNameW(const wchar_t*  Name);
00364
00365 #if defined(UNICODE) || defined(_UNICODE)
00366 #define GscAct_GetActionClassByName    GscAct_GetActionClassByNameW
00367 #define GscAct_GetActionCodeByName     GscAct_GetActionCodeByNameW
00368 #else
00369 #define GscAct_GetActionClassByName    GscAct_GetActionClassByNameA
00370 #define GscAct_GetActionCodeByName     GscAct_GetActionCodeByNameA
00371 #endif
00372
00373 /// Get internal index by action code
00374 ///
00375 /// @param [in] Code   Action code.
00376 /// @return internal index if succeeds, \c 0x7FFFFFFF otherwise.
00377 GSCACTDLLCALL unsigned int  __stdcall GscAct_GetInternalIndexByCode(GscActionCode Code);
00378
00379 /// Get action code by internal index.
00380 ///
00381 /// @param [in] Index  Internal index.
00382 /// @return action code if succeeds, \c ac_Unknown otherwise.
00383 GSCACTDLLCALL GscActionCode __stdcall GscAct_GetActionCodeByIndex(unsigned int Index);
00384
00385 /// Get native translation.
00386 ///
00387 /// @param [out] IsNativeTranslation  Translation flag, \c true -> native, \c false -> english.
00388 /// @return \c true if succeeds, \c false otherwise.
00389 GSCACTDLLCALL bool __stdcall GscAct_GetNativeTranslation(bool& IsNativeTranslation);
00390
00391 /// Set native translation.
00392 ///
00393 /// @param [in] IsNativeTranslation  Translation flag, \c true -> native, \c false -> english.
00394 /// @return \c true if succeeds, \c false otherwise.
00395 GSCACTDLLCALL bool __stdcall GscAct_SetNativeTranslation(bool IsNativeTranslation);
00396
00397 ///
00398 /// \} // end of group GscPlcAccessByNames
00399
00400 /////////////////////////////////////////////////////////
00401 /// Event data
00402 /////////////////////////////////////////////////////////
00403
00404 /// \addtogroup GscPlcEvents
00405 /// \{
00406
00407 ///
00408 /// Get event data callback.
00409 ///
00410 /// Instance - provided by the caller.
00411 /// Index    - less than 0 - Name is action name
00412 ///                          Value is complete action description
00413 ///          - otherwise   - Name is plain name of i-th parameter
00414 ///                          Value is its value
00415 typedef void (__stdcall *TPlcGetEventDataCallback)(void* Instance, int Index, const wchar_t* Name, const wchar_t* Value);
00416
00417 /// Get action event data.
00418 ///
00419 /// @param [in]  anAction      Handle to action.
00420 /// @param [out] EventRecord   Record to store event data.
00421 /// @param [out] DataComplete  Flag whether all action data are stored
00422 /// @return \c true if succeeds, \c false otherwise.
00423 GSCACTDLLCALL bool __stdcall GscAct_GetActionEventData(
00424                    ConstHGscAction                  anAction,
00425                    TPlcActionEventDataRecord&       EventRecord,
00426                    bool&                            DataComplete);
00427
00428 /// Get match action event data.
00429 ///
00430 /// @param [in]  anAction      Handle to action.
00431 /// @param [out] EventRecord   Record to store event data.
00432 /// @param [out] DataComplete  Flag whether all action data are stored
00433 /// @return \c true if succeeds, \c false otherwise.
00434 GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionEventData(
00435                    ConstHGscMatchAction             anAction,
00436                    TPlcActionEventDataRecord&       EventRecord,
00437                    bool&                            DataComplete);
00438
00439 /// Get action event description lines.
00440 ///
00441 /// @param [in]  EventRecord   Record with event data.
00442 /// @param [in]  Instance      Instance to pass to callback.
00443 /// @param [in]  Callback      Callback function to call for each pair of name/value.
00444 /// @param [out] DataComplete  Flag whether all action data are stored
00445 /// @return \c true if succeeds, \c false otherwise.
00446 GSCACTDLLCALL bool __stdcall GscAct_GetActionEventDescription(
00447                    const TPlcActionEventDataRecord& EventRecord,
00448                    void*                            Instance,
00449                    TPlcGetEventDataCallback         Callback,
00450                    bool&                            DataComplete);
00451
00452 /////////////////////////////////////////////////////////
00453 /// Restore actions from event data
00454 /////////////////////////////////////////////////////////
00455
00456 /// Restore action from event data.
00457 ///
00458 /// @param [in]  EventRecord   Record with event data.
00459 /// @return Handle to created action or \c NULL if the function fails.
00460 GSCACTDLLCALL HGscAction __stdcall GscAct_RestoreActionFromEventData(
00461                    const TPlcActionEventDataRecord& EventRecord);
00462
00463 /// Restore match action from event data.
00464 ///
00465 /// @param [in]  EventRecord   Record with event data.
00466 /// @return Handle to created action or \c NULL if the function fails.
00467 GSCACTDLLCALL HGscMatchAction __stdcall GscMatchAct_RestoreActionFromEventData(
00468                    const TPlcActionEventDataRecord& EventRecord);
00469
00470 /////////////////////////////////////////////////////////
00471 /// Enumerate event fields
00472 /////////////////////////////////////////////////////////
00473
00474 /// Get event field info.
00475 ///
00476 /// @param [out] Info        Reference to info structure.
00477 /// @return \c true if succeeds, \c false otherwise.
00478 GSCACTDLLCALL bool           __stdcall GscAct_GetEventDescriptionInfo(
00479                    TGscActionPlainInfo& Info);
00480
00481 /// Set the plain part of the event field info.
00482 /// Only \c PlainNameW and \c DescriptionW fields of the struct are used.
00483 ///
00484 /// @param [in]  Info        Const reference to info structure.
00485 /// @return \c true if succeeds, \c false otherwise.
00486 GSCACTDLLCALL bool           __stdcall GscAct_SetEventDescriptionPlainInfo(
00487                    const TGscActionPlainInfo& Info);
00488
00489 /// Get the list of parameters.
00490 ///
00491 /// @param [out] List        Retrieves infos. Should be allocated by client.
00492 /// @param [in]  Count       Size of the List in elements.
00493 /// @return number of copied elements.
00494 GSCACTDLLCALL unsigned int   __stdcall GscAct_EnumerateEventFields(
00495                    TGscParameterPlainInfo List[],
00496                    unsigned int           Count);
00497
00498 /// Get the parameter info.
00499 /// Returns the Index-th parameter.
00500 ///
00501 /// @param [out] Info        Reference to info structure.
00502 /// @param [in]  Index       Index of parameter.
00503 /// @return \c true if succeeds, \c false otherwise.
00504 GSCACTDLLCALL bool           __stdcall GscAct_GetEventFieldInfo(
00505                    TGscParameterPlainInfo& Info,
00506                    unsigned int            Index);
00507
00508 /// Set the plain part of parameter info.
00509 /// Only \c PlainNameW and \c DescriptionW fields of the struct are used.
00510 ///
00511 /// @param [in]  Info        Reference to info structure.
00512 /// @param [in]  Index       Index of parameter.
00513 /// @return \c true if succeeds, \c false otherwise.
00514 GSCACTDLLCALL bool           __stdcall GscAct_SetEventFieldPlainInfo(
00515                    const TGscParameterPlainInfo& Info,
00516                    unsigned int                  Index);
00517
00518 ///
00519 /// \} // end of group GscPlcEvents
00520
00521 /////////////////////////////////////////////////////////
00522 /// General functions for all messages
00523 /////////////////////////////////////////////////////////
00524
00525 /// \addtogroup GscPlcMessageFunctions
00526 /// \{
00527
00528 /// Close message handle.
00529 /// If the reference counter is 0, free used memory.
00530 ///
00531 /// @param [in] aMessage handle to message.
00532 /// @return \c true if succeeds, \c false otherwise.
00533 GSCACTDLLCALL bool __stdcall GscAct_CloseHandle(
00534                    HGscMessage       aMessage);
00535
00536 /// Duplicate message handle.
00537 /// Increase the reference counter.
00538 ///
00539 /// @param [in] aMessage handle to message.
00540 /// @return \c true if succeeds, \c false otherwise.
00541 GSCACTDLLCALL bool __stdcall GscAct_DuplicateHandle(
00542                     HGscMessage      aMessage);
00543
00544 /// Clone message handle.
00545 /// Create a new object with the same content.
00546 ///
00547 /// @param [in]  aMessage      Handle to message.
00548 /// @param [out] ClonedMessage Clone of the message.
00549 /// @return \c true if succeeds, \c false otherwise.
00550 GSCACTDLLCALL bool __stdcall GscAct_CloneHandle(
00551                     ConstHGscMessage aMessage,
00552                     HGscMessage&     ClonedMessage);
00553
00554 /// Get reference counter.
00555 ///
00556 /// @param [in]  aMessage      Handle to message.
00557 /// @param [out] RefCounter    Field to store reference counter.
00558 /// @return \c true if succeeds, \c false otherwise.
00559 GSCACTDLLCALL bool __stdcall GscAct_GetReferenceCounter(
00560                     ConstHGscMessage aMessage,
00561                     int&             RefCounter);
00562
00563 /// Get class of the message.
00564 ///
00565 /// @param [in]  aMessage      Handle to message.
00566 /// @param [out] aClass        Field to store message class.
00567 /// @return \c true if succeeds, \c false otherwise.
00568 GSCACTDLLCALL bool __stdcall GscAct_GetMessageClass(
00569                     ConstHGscMessage aMessage,
00570                     GscMessageClass& aClass);
00571
00572 /// Get internal index of the message.
00573 ///
00574 /// @param [in]  aMessage      Handle to message.
00575 /// @param [out] InternalIndex Field to store the internal index.
00576 /// @return \c true if succeeds, \c false otherwise.
00577 GSCACTDLLCALL bool __stdcall GscAct_GetInternalIndex(
00578                     ConstHGscMessage aMessage,
00579                     int&             InternalIndex);
00580
00581 /// Get internal data.
00582 /// You can use this field as temporary storage for user specific data.
00583 ///
00584 /// @param [in]  aMessage      Handle to message.
00585 /// @param [out] InternalData  Field to store the internal data.
00586 /// @return \c true if succeeds, \c false otherwise.
00587 GSCACTDLLCALL bool __stdcall GscAct_GetInternalData(
00588                     ConstHGscMessage aMessage,
00589                     void*&           InternalData);
00590
00591 /// Set internal data.
00592 /// You can use this field as temporary storage for user specific data.
00593 ///
00594 /// @param [in]  aMessage      Handle to message.
00595 /// @param [in]  InternalData  Field with the internal data.
00596 /// @return \c true if succeeds, \c false otherwise.
00597 GSCACTDLLCALL bool __stdcall GscAct_SetInternalData(
00598                     HGscMessage      aMessage,
00599                     void*            InternalData);
00600
00601 /// Get flags of the message
00602 ///
00603 /// @param [in]  aMessage      Handle to message.
00604 /// @param [out] Flags         Field to store flags
00605 /// @return \c true if succeeds, \c false otherwise.
00606 GSCACTDLLCALL bool __stdcall GscAct_GetMessageFlags(
00607                     ConstHGscMessage aMessage,
00608                     unsigned __int32& Flags);
00609
00610 /// Set flags of the message
00611 ///
00612 /// @param [in]  aMessage      Handle to message.
00613 /// @param [in]  Flags         Field with new flags
00614 /// @return \c true if succeeds, \c false otherwise.
00615 GSCACTDLLCALL bool __stdcall GscAct_SetMessageFlags(
00616                     HGscMessage      aMessage,
00617                     unsigned __int32 Flags);
00618
00619 /// Compare messages.
00620 ///
00621 /// @param [in]  aMessage1     Handle to first message.
00622 /// @param [in]  aMessage2     Handle to second message.
00623 /// @param [out] Result        Field to store the internal data.
00624 /// @return \c true if succeeds, \c false otherwise.
00625 ///
00626 /// @attention Result of comparision is stored in \c Result field,
00627 ///            NOT in return value!
00628 GSCACTDLLCALL bool __stdcall GscAct_Equal(
00629                     ConstHGscMessage aMessage1,
00630                     ConstHGscMessage aMessage2,
00631                     bool& Result);
00632
00633 /////////////////////////////////////////////////////////
00634 /// Create message from different buffers
00635 /////////////////////////////////////////////////////////
00636
00637 /// Create message from binary buffer.
00638 ///
00639 /// @param [in]  Buffer        Pointer to buffer with binary representation of message.
00640 /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
00641 /// @param [in]  ExpectedClass Expected class of the message.
00642 ///                            Use \c mk_Unknown to read any message.
00643 /// @param [out] ReadBytes     Points to the variable where the number of read bytes
00644 ///                            is returned. This parameter can be \c NULL if
00645 ///                            the caller does not need this information.
00646 /// @return Handle to created message or \c NULL if the function fails.
00647 GSCACTDLLCALL HGscMessage __stdcall GscAct_CreateFromBinBuffer(
00648                     const void*      Buffer,
00649                     unsigned int     BufferSize,
00650                     GscMessageClass  ExpectedClass,
00651                     unsigned int*    ReadBytes);
00652
00653 /// Create message from ANSI text buffer.
00654 ///
00655 /// @param [in]  Buffer        Pointer to buffer with text representation of message.
00656 /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
00657 /// @param [in]  ExpectedClass Expected class of the message.
00658 ///                            Use \c mk_Unknown to read any message.
00659 /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding ANSI to UNICODE.
00660 /// @param [out] ReadChars     Points to the variable where the number of read chars
00661 ///                            is returned. This parameter can be \c NULL if
00662 ///                            the caller does not need this information.
00663 /// @return Handle to created message or \c NULL if the function fails.
00664 /// @attention Buffer must be 0-terminated.
00665 GSCACTDLLCALL HGscMessage __stdcall GscAct_CreateFromTextBufferA(
00666                     const char*      Buffer,
00667                     unsigned int     BufferSize,
00668                     GscMessageClass  ExpectedClass,
00669                     bool             UseUTF8Encoding,
00670                     unsigned int*    ReadChars);
00671
00672 /// Create message from UNICODE text buffer.
00673 ///
00674 /// @param [in]  Buffer        Pointer to buffer with text representation of message.
00675 /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
00676 /// @param [in]  ExpectedClass Expected class of the message.
00677 ///                            Use \c mk_Unknown to read any message.
00678 /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding UNICODE to ANSI.
00679 /// @param [out] ReadChars     Points to the variable where the number of read chars
00680 ///                            is returned. This parameter can be \c NULL if
00681 ///                            the caller does not need this information.
00682 /// @return Handle to created message or \c NULL if the function fails.
00683 /// @attention Buffer must be 0-terminated.
00684 GSCACTDLLCALL HGscMessage __stdcall GscAct_CreateFromTextBufferW(
00685                     const wchar_t*   Buffer,
00686                     unsigned int     BufferSize,
00687                     GscMessageClass  ExpectedClass,
00688                     bool             UseUTF8Encoding,
00689                     unsigned int*    ReadChars);
00690
00691 #if defined(UNICODE) || defined(_UNICODE)
00692 #define GscAct_CreateFromTextBuffer    GscAct_CreateFromTextBufferW
00693 #else
00694 #define GscAct_CreateFromTextBuffer    GscAct_CreateFromTextBufferA
00695 #endif
00696
00697 /////////////////////////////////////////////////////////
00698 // Store message to the buffer
00699 /////////////////////////////////////////////////////////
00700
00701 /// Write message to the binary buffer.
00702 ///
00703 /// @param [in]  aMessage      Handle to message.
00704 /// @param [in]  Buffer        Points to the buffer that receives the data.
00705 /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
00706 /// @param [out] BytesWritten  Points to the variable where the number of written bytes
00707 ///                            is returned. This parameter can be \c NULL if
00708 ///                            the caller does not need this information.
00709 /// @return \c true if the function succeeds, \c false otherwise.
00710 ///
00711 /// @attention Buffer can be \c NULL if BufferSize is \c 0. Use it to
00712 ///            query required size.
00713 GSCACTDLLCALL bool __stdcall GscAct_StoreToBinBuffer(
00714                     ConstHGscMessage aMessage,
00715                     void*            Buffer,
00716                     unsigned int     BufferSize,
00717                     unsigned int*    BytesWritten);
00718
00719 /// Write message to the text buffer as ANSI string.
00720 ///
00721 /// @param [in]  aMessage      Handle to message.
00722 /// @param [in]  Buffer        Points to the buffer that receives the data.
00723 /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
00724 /// @param [in]  OutputAsPlainText   Output as plain text.
00725 /// @param [in]  UseUTF8Encoding     Use UTF8 encoding to transcode UNICODE to ANSI.
00726 /// @param [out] CharsWritten  Points to the variable where the number of written chars
00727 ///                            is returned. This parameter can be \c NULL if
00728 ///                            the caller does not need this information.
00729 /// @return \c true if the function succeeds, \c false otherwise.
00730 ///
00731 /// @attention Buffer can be \c NULL if BufferSize is \c 0. Use it to
00732 ///            query required size.
00733 /// @warning   The output produced as "plain text" CANNOT be converted
00734 ///            back to the message!
00735 GSCACTDLLCALL bool __stdcall GscAct_StoreToTextBufferA(
00736                     ConstHGscMessage aMessage,
00737                     char*            Buffer,
00738                     unsigned int     BufferSize,
00739                     bool             OutputAsPlainText,
00740                     bool             UseUTF8Encoding,
00741                     unsigned int*    CharsWritten);
00742
00743 /// Write message to the text buffer as UNICODE string.
00744 ///
00745 /// @param [in]  aMessage      Handle to message.
00746 /// @param [in]  Buffer        Points to the buffer that receives the data.
00747 /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
00748 /// @param [in]  OutputAsPlainText   Output as plain text.
00749 /// @param [in]  UseUTF8Encoding     Use UTF8 encoding to transcode ANSI to UNICODE.
00750 /// @param [out] CharsWritten  Points to the variable where the number of written chars
00751 ///                            is returned. This parameter can be \c NULL if
00752 ///                            the caller does not need this information.
00753 /// @return \c true if the function succeeds, \c false otherwise.
00754 ///
00755 /// @attention Buffer can be \c NULL if BufferSize is \c 0. Use it to
00756 ///            query required size.
00757 /// @warning   The output produced as "plain text" CANNOT be converted
00758 ///            back to the message!
00759 GSCACTDLLCALL bool __stdcall GscAct_StoreToTextBufferW(
00760                     ConstHGscMessage aMessage,
00761                     wchar_t*         Buffer,
00762                     unsigned int     BufferSize,
00763                     bool             OutputAsPlainText,
00764                     bool             UseUTF8Encoding,
00765                     unsigned int*    CharsWritten);
00766
00767 #if defined(UNICODE) || defined(_UNICODE)
00768 #define GscAct_StoreToTextBuffer       GscAct_StoreToTextBufferW
00769 #else
00770 #define GscAct_StoreToTextBuffer       GscAct_StoreToTextBufferA
00771 #endif
00772
00773 /// \} // end of group GscPlcMessageFunctions
00774
00775 /////////////////////////////////////////////////////////
00776 /// General information about actions
00777 /////////////////////////////////////////////////////////
00778
00779 /// \addtogroup GscPlcActionFunctions
00780 /// \{
00781
00782 /// Get class of the action.
00783 ///
00784 /// @param [in]  anAction      Handle to action.
00785 /// @param [out] ActionClass   Field to store action class.
00786 /// @return \c true if succeeds, \c false otherwise.
00787 GSCACTDLLCALL bool __stdcall GscAct_GetActionClass(
00788                     ConstHGscAction  anAction,
00789                     GscActionClass&  ActionClass);
00790
00791 /// Get code of the action.
00792 ///
00793 /// @param [in]  anAction      Handle to action.
00794 /// @param [out] ActionCode    Field to store action code.
00795 /// @return \c true if succeeds, \c false otherwise.
00796 GSCACTDLLCALL bool __stdcall GscAct_GetActionCode(
00797                     ConstHGscAction  anAction,
00798                     GscActionCode&   ActionCode);
00799
00800 /// Get action name as ANSI string.
00801 ///
00802 /// @param [in]  anAction      Handle to action.
00803 /// @param [out] ActionName    Field to store reference to action name.
00804 /// @return \c true if succeeds, \c false otherwise.
00805 GSCACTDLLCALL bool __stdcall GscAct_GetActionNameA(
00806                     ConstHGscAction  anAction,
00807                     const char*&     ActionName);
00808
00809 /// Get action name as UNICODE string.
00810 ///
00811 /// @param [in]  anAction      Handle to action.
00812 /// @param [out] ActionName    Field to store reference to action name.
00813 /// @return \c true if succeeds, \c false otherwise.
00814 GSCACTDLLCALL bool __stdcall GscAct_GetActionNameW(
00815                     ConstHGscAction  anAction,
00816                     const wchar_t*&  ActionName);
00817
00818 /// Get action plain name as ANSI string.
00819 ///
00820 /// @param [in]  anAction      Handle to action.
00821 /// @param [out] ActionName    Field to store reference to plain action name.
00822 /// @return \c true if succeeds, \c false otherwise.
00823 GSCACTDLLCALL bool __stdcall GscAct_GetActionPlainNameA(
00824                     ConstHGscAction  anAction,
00825                     const char*&     ActionName);
00826
00827 /// Get action plain name as UNICODE string.
00828 ///
00829 /// @param [in]  anAction      Handle to action.
00830 /// @param [out] ActionName    Field to store reference to plain action name.
00831 /// @return \c true if succeeds, \c false otherwise.
00832 GSCACTDLLCALL bool __stdcall GscAct_GetActionPlainNameW(
00833                     ConstHGscAction  anAction,
00834                     const wchar_t*&  ActionName);
00835
00836 #if defined(UNICODE) || defined(_UNICODE)
00837 #define GscAct_GetActionName           GscAct_GetActionNameW
00838 #define GscAct_GetActionPlainName      GscAct_GetActionPlainNameW
00839 #else
00840 #define GscAct_GetActionName           GscAct_GetActionNameA
00841 #define GscAct_GetActionPlainName      GscAct_GetActionPlainNameA
00842 #endif
00843
00844 /////////////////////////////////////////////////////////
00845 /// Special information about some specific IDs used in the action
00846 /////////////////////////////////////////////////////////
00847
00848 /// Get used video input.
00849 ///
00850 /// @param [in]  anAction      Handle to action.
00851 /// @param [out] ID            Field to store ID.
00852 /// @return \c true if succeeds, \c false otherwise.
00853 /// @attention If the field is not available, the return value is \c true
00854 ///            and \c ID gets \c NULL.
00855 GSCACTDLLCALL bool __stdcall GscAct_GetVideoInput(
00856                     ConstHGscAction            anAction,
00857                     const TPlcMediaChannelID*& ID);
00858
00859 /// Get used video output.
00860 ///
00861 /// @param [in]  anAction      Handle to action.
00862 /// @param [out] ID            Field to store ID.
00863 /// @return \c true if succeeds, \c false otherwise.
00864 /// @attention If the field is not available, the return value is \c true
00865 ///            and \c ID gets \c NULL.
00866 GSCACTDLLCALL bool __stdcall GscAct_GetVideoOutput(
00867                     ConstHGscAction            anAction,
00868                     const TPlcMediaChannelID*& ID);
00869
00870 /// Get used input contact.
00871 ///
00872 /// @param [in]  anAction      Handle to action.
00873 /// @param [out] ID            Field to store ID.
00874 /// @return \c true if succeeds, \c false otherwise.
00875 /// @attention If the field is not available, the return value is \c true
00876 ///            and \c ID gets \c NULL.
00877 GSCACTDLLCALL bool __stdcall GscAct_GetInputContact(
00878                     ConstHGscAction            anAction,
00879                     const TPlcMediaChannelID*& ID);
00880
00881 /// Get used output contact.
00882 ///
00883 /// @param [in]  anAction      Handle to action.
00884 /// @param [out] ID            Field to store ID.
00885 /// @return \c true if succeeds, \c false otherwise.
00886 /// @attention If the field is not available, the return value is \c true
00887 ///            and \c ID gets \c NULL.
00888 GSCACTDLLCALL bool __stdcall GscAct_GetOutputContact(
00889                     ConstHGscAction            anAction,
00890                     const TPlcMediaChannelID*& ID);
00891
00892 /// Get used foreign key.
00893 ///
00894 /// @param [in]  anAction      Handle to action.
00895 /// @param [out] Key           Field to store the foreign key.
00896 /// @return \c true if succeeds, \c false otherwise.
00897 /// @attention If the field is not available, the return value is \c true
00898 ///            and \c Key gets \c NULL.
00899 GSCACTDLLCALL bool __stdcall GscAct_GetForeignKey(
00900                     ConstHGscAction            anAction,
00901                     const __int64*&            Key);
00902
00903 /// Get used generic 32-bit integer parameter.
00904 ///
00905 /// @param [in]  anAction      Handle to action.
00906 /// @param [out] aParam        Field to store the paarameter.
00907 /// @return \c true if succeeds, \c false otherwise.
00908 GSCACTDLLCALL bool __stdcall GscAct_GetGenericInt32Parameter(
00909                     ConstHGscAction            anAction,
00910                     __int32&                   aParam);
00911
00912 /// Create generic action
00913 /// generic action has only infos about some resources, nothing else
00914 /// it is intended to use only in GeViSoft / GeviScope interface
00915 ///
00916 /// @param [in]  aVideoInput     Video input resource
00917 /// @param [in]  aVideoOutput    Video output resource
00918 /// @param [in]  anInputContact  Input contact resource
00919 /// @param [in]  anOutputContact Output contact resource
00920 /// @param [in]  aParam          32-bit integer parameter
00921 /// @return Handle to created message or \c NULL if the function fails.
00922 GSCACTDLLCALL HGscAction __stdcall GscAct_CreateGenericAction(
00923                     const TPlcMediaChannelID* aVideoInput,
00924                     const TPlcMediaChannelID* aVideoOutput,
00925                     const TPlcMediaChannelID* anInputContact,
00926                     const TPlcMediaChannelID* anOutputContact,
00927                     __int32                   aParam);
00928
00929 /// Update action info.
00930 ///
00931 /// @param [in]  anAction      Handle to action.
00932 /// @param [in]  anObject      Proxy object to pass to callback.
00933 /// @param [in]  Callback      Callback functions.
00934 /// @param [out] UpdateOk      Update successfull or not.
00935 /// @return \c true if succeeds, \c false otherwise.
00936 GSCACTDLLCALL bool __stdcall GscAct_UpdateActionInfo(
00937                     HGscAction                          anAction,
00938                     void*                               anObject,
00939                     const TPlcUpdateActionInfoCallback& Callback,
00940                     bool&                               UpdateOk);
00941
00942 /// Update windows client info.
00943 ///
00944 /// @param [in]  anAction        Handle to action.
00945 /// @param [in]  localHostName   Local Windows host name
00946 /// @param [in]  localClientType Local client type
00947 /// @param [in]  localUserName   Local Windows user name
00948 /// @return \c true if succeeds, \c false otherwise.
00949 GSCACTDLLCALL bool __stdcall GscAct_UpdateWindowsClientInfo(
00950                     HGscAction                          anAction,
00951                     const wchar_t*                      localHostName,
00952                     const PlcClientType                 localClientType,
00953                     const wchar_t*                      localUserName);
00954 GSCACTDLLCALL bool __stdcall GscAct_GetWindowsClientInfo(
00955                     HGscAction                          anAction,
00956                     const wchar_t*&                     localHostName,
00957                     const PlcClientType*&               localClientType,
00958                     const wchar_t*&                     localUserName);
00959
00960 /// Set action property
00961 ///
00962 /// @param [in]  anAction      Handle to action.
00963 /// @param [in]  Key           Property key.
00964 /// @param [in]  Value         Property value.
00965 /// @return \c true if succeeds, \c false otherwise.
00966 GSCACTDLLCALL bool __stdcall GscAct_SetProperty(
00967                     HGscAction       anAction,
00968                     const wchar_t*   Key,
00969                     const wchar_t*   Value);
00970
00971 /// Get action property
00972 ///
00973 /// @param [in]  anAction      Handle to action.
00974 /// @param [in]  Key           Property key.
00975 /// @param [out] Value         Property value.
00976 /// @return \c true if succeeds, \c false otherwise.
00977 /// @attention If the property does not exist, the return value is \c true
00978 ///            and \c Value gets \c NULL.
00979 GSCACTDLLCALL bool __stdcall GscAct_GetProperty(
00980                     HGscAction       anAction,
00981                     const wchar_t*   Key,
00982                     const wchar_t*&  Value);
00983
00984 /// Get action properties
00985 ///
00986 /// @param [in]  anAction      Handle to action.
00987 /// @param [out] Properties    Properties.
00988 /// @return \c true if succeeds, \c false otherwise.
00989 GSCACTDLLCALL bool __stdcall GscAct_GetProperties(
00990                     HGscAction       anAction,
00991                     const wchar_t*&  Properties);
00992
00993 /// \} // end of group GscPlcActionFunctions
00994
00995 /////////////////////////////////////////////////////////
00996 // General information about match actions
00997 /////////////////////////////////////////////////////////
00998
00999 /// \addtogroup GscPlcMatchActionFunctions
01000 /// \{
01001
01002 /// Get class of the action.
01003 ///
01004 /// @param [in]  anAction      Handle to action.
01005 /// @param [out] ActionClass   Field to store action class.
01006 /// @return \c true if succeeds, \c false otherwise.
01007 GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionClass(
01008                     ConstHGscMatchAction  anAction,
01009                     GscActionClass&       ActionClass);
01010
01011 /// Get code of the action.
01012 ///
01013 /// @param [in]  anAction      Handle to action.
01014 /// @param [out] ActionCode    Field to store action code.
01015 /// @return \c true if succeeds, \c false otherwise.
01016 GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionCode(
01017                     ConstHGscMatchAction  anAction,
01018                     GscActionCode&        ActionCode);
01019
01020 /// Get action name as ANSI string.
01021 ///
01022 /// @param [in]  anAction      Handle to action.
01023 /// @param [out] ActionName    Field to store reference to action name.
01024 /// @return \c true if succeeds, \c false otherwise.
01025 GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionNameA(
01026                     ConstHGscMatchAction  anAction,
01027                     const char*&          ActionName);
01028
01029 /// Get action name as UNICODE string.
01030 ///
01031 /// @param [in]  anAction      Handle to action.
01032 /// @param [out] ActionName    Field to store reference to action name.
01033 /// @return \c true if succeeds, \c false otherwise.
01034 GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionNameW(
01035                     ConstHGscMatchAction  anAction,
01036                     const wchar_t*&       ActionName);
01037
01038 /// Get action plain name as ANSI string.
01039 ///
01040 /// @param [in]  anAction      Handle to action.
01041 /// @param [out] ActionName    Field to store reference to plain action name.
01042 /// @return \c true if succeeds, \c false otherwise.
01043 GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionPlainNameA(
01044                     ConstHGscMatchAction  anAction,
01045                     const char*&          ActionName);
01046
01047 /// Get action plain name as UNICODE string.
01048 ///
01049 /// @param [in]  anAction      Handle to action.
01050 /// @param [out] ActionName    Field to store reference to plain action name.
01051 /// @return \c true if succeeds, \c false otherwise.
01052 GSCACTDLLCALL bool __stdcall GscMatchAct_GetActionPlainNameW(
01053                     ConstHGscMatchAction  anAction,
01054                     const wchar_t*&       ActionName);
01055
01056 /// Check description of the match action.
01057 ///
01058 /// @param [in]  anAction      Handle to action.
01059 /// @param [out] Description   Field to store the result.
01060 /// @return \c true if succeeds, \c false otherwise.
01061 GSCACTDLLCALL bool __stdcall GscMatchAct_HasDescription(
01062                     ConstHGscMatchAction  anAction,
01063                     bool&                 Description);
01064
01065 /// Get description of the match action as ANSI string.
01066 ///
01067 /// @param [in]  anAction      Handle to action.
01068 /// @param [out] Description   Field to store the result.
01069 /// @return \c true if succeeds, \c false otherwise.
01070 GSCACTDLLCALL bool __stdcall GscMatchAct_GetDescriptionA(
01071                     ConstHGscMatchAction  anAction,
01072                     const char*&          Description);
01073
01074 /// Get description of the match action as UNICODE string.
01075 ///
01076 /// @param [in]  anAction      Handle to action.
01077 /// @param [out] Description   Field to store the result.
01078 /// @return \c true if succeeds, \c false otherwise.
01079 GSCACTDLLCALL bool __stdcall GscMatchAct_GetDescriptionW(
01080                     ConstHGscMatchAction  anAction,
01081                     const wchar_t*&       Description);
01082
01083 /// Alias to \ref GscMatchAct_GetDescriptionA.
01084 inline bool GscMatchAct_GetCommentA(
01085                     ConstHGscMatchAction  anAction,
01086                     const char*&          Description)
01087 {
01088   return GscMatchAct_GetDescriptionA(anAction, Description);
01089 }
01090
01091 /// Alias to \ref GscMatchAct_GetDescriptionW.
01092 inline bool GscMatchAct_GetCommentW(
01093                     ConstHGscMatchAction  anAction,
01094                     const wchar_t*&       Description)
01095 {
01096   return GscMatchAct_GetDescriptionW(anAction, Description);
01097 }
01098
01099 /// Set description of the match action from ANSI string.
01100 ///
01101 /// @param [in]  anAction      Handle to action.
01102 /// @param [in]  Description   User provided comment.
01103 /// @return \c true if succeeds, \c false otherwise.
01104 GSCACTDLLCALL bool __stdcall GscMatchAct_SetDescriptionA(
01105                     HGscMatchAction       anAction,
01106                     const char*           Description);
01107
01108 /// Set description of the match action from UNICODE string.
01109 ///
01110 /// @param [in]  anAction      Handle to action.
01111 /// @param [in]  Description   User provided comment.
01112 /// @return \c true if succeeds, \c false otherwise.
01113 GSCACTDLLCALL bool __stdcall GscMatchAct_SetDescriptionW(
01114                     HGscMatchAction       anAction,
01115                     const wchar_t*        Description);
01116
01117 /// Alias to \ref GscMatchAct_SetDescriptionA.
01118 inline bool GscMatchAct_SetCommentA(
01119                     HGscMatchAction       anAction,
01120                     const char*           Description)
01121 {
01122   return GscMatchAct_SetDescriptionA(anAction, Description);
01123 }
01124
01125 /// Alias to \ref GscMatchAct_SetDescriptionW.
01126 inline bool GscMatchAct_SetCommentW(
01127                     HGscMatchAction       anAction,
01128                     const wchar_t*        Description)
01129 {
01130   return GscMatchAct_SetDescriptionW(anAction, Description);
01131 }
01132
01133 #if defined(UNICODE) || defined(_UNICODE)
01134 #define GscMatchAct_GetActionName      GscMatchAct_GetActionNameW
01135 #define GscMatchAct_GetActionPlainName GscMatchAct_GetActionPlainNameW
01136 #define GscMatchAct_GetDescription     GscMatchAct_GetDescriptionW
01137 #define GscMatchAct_SetDescription     GscMatchAct_SetDescriptionW
01138 #define GscMatchAct_GetComment         GscMatchAct_GetCommentW
01139 #define GscMatchAct_SetComment         GscMatchAct_SetCommentW
01140 #else
01141 #define GscMatchAct_GetActionName      GscMatchAct_GetActionNameA
01142 #define GscMatchAct_GetActionPlainName GscMatchAct_GetActionPlainNameA
01143 #define GscMatchAct_GetDescription     GscMatchAct_GetDescriptionA
01144 #define GscMatchAct_SetDescription     GscMatchAct_SetDescriptionA
01145 #define GscMatchAct_GetComment         GscMatchAct_GetCommentA
01146 #define GscMatchAct_SetComment         GscMatchAct_SetCommentA
01147 #endif
01148
01149 /////////////////////////////////////////////////////////
01150 /// Working with match actions
01151 /////////////////////////////////////////////////////////
01152
01153 /// Matches action.
01154 ///
01155 /// @param [in]  aMatchAction  Handle to match action.
01156 /// @param [in]  anAction      Handle to action.
01157 /// @param [out] Result        Field to store the result.
01158 /// @return \c true if succeeds, \c false otherwise.
01159 /// @attention Result of test is stored in \c Result field,
01160 ///            NOT in return value!
01161 GSCACTDLLCALL bool __stdcall GscMatchAct_Matches(
01162                     ConstHGscMatchAction  aMatchAction,
01163                     ConstHGscAction       anAction,
01164                     bool&                 Result);
01165
01166 /// Create action from the match action and provided action as template.
01167 ///
01168 /// @param [in]  aMatchAction  Handle to match action.
01169 /// @param [in]  aTemplate     Action to use as template to take available fields from.
01170 /// @param [out] Result        Field to store the result.
01171 /// @return \c true if succeeds, \c false otherwise.
01172 /// @attention \c aTemplate can be \c NULL if you don't use it.
01173 GSCACTDLLCALL bool __stdcall GscMatchAct_CreateActionFromTemplate(
01174                     ConstHGscMatchAction  aMatchAction,
01175                     ConstHGscAction       aTemplate,
01176                     HGscAction&           Result);
01177
01178 /// Create match action from the action.
01179 ///
01180 /// @param [in]  anAction      Handle to match action.
01181 /// @param [out] Result        Field to store the result.
01182 /// @return \c true if succeeds, \c false otherwise.
01183 GSCACTDLLCALL bool __stdcall GscAct_CreateMatchActionFromTemplate(
01184                     ConstHGscAction       anAction,
01185                     HGscMatchAction&      Result);
01186
01187 /// \} // end of group GscPlcMatchActionFunctions
01188
01189 /////////////////////////////////////////////////////////
01190 /// Wrapper classes over all but general functions
01191 /////////////////////////////////////////////////////////
01192
01193 /// \addtogroup GscPlcClassWrapper Message classes
01194 /// \{
01195
01196 #ifndef __GscActionsDLL
01197
01198 /////////////////////////////////////////////////////////
01199 /// GeViScope message
01200 /// \nosubgrouping
01201 ///
01202 /// \code
01203 /// Static members:
01204 ///   CGscMessage*    CreateFromBinBuffer   - create message from the bin buffer
01205 ///   CGscMessage*    CreateFromTextBuffer  - create message from the text buffer
01206 ///
01207 /// Public methods:
01208 ///   bool            StoreToBinBuffer      - store message to the bin buffer
01209 ///   bool            StoreToTextBuffer     - store message to the text buffer
01210 ///
01211 ///   void            operator delete       - delete operator
01212 ///   void            CloseHandle           - close message handle
01213 ///   void            DuplicateHandle       - duplicate message handle
01214 ///   HGscMessage     CloneHandle           - create a clone of the message
01215 ///   GscMessageClass GetMessageClass       - access to message class
01216 ///   int             GetReferenceCounter   - access to reference counter
01217 ///   int             GetInternalIndex      - access to the internal index
01218 ///   void*           GetInternalData       - get internal data
01219 ///   void            SetInternalData       - set internal data
01220 ///   bool            EqualTo               - compare with another message
01221 /// \endcode
01222 ///
01223 class CGscMessage {
01224   private:
01225     ///
01226     /// forbidden default constructors and assignment
01227     CGscMessage();
01228     CGscMessage(const CGscMessage&);
01229     CGscMessage& operator=(const CGscMessage&);
01230
01231   public:
01232     ///
01233     /// static members
01234
01235     /////////////////////////////////////////////////////////
01236
01237     /// Create message from binary buffer.
01238     /// @param [in]  Buffer        Pointer to buffer with binary representation of message.
01239     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
01240     /// @param [in]  ExpectedClass Expected class of the message.
01241     ///                            Use \c mk_Unknown to read any message.
01242     /// @param [out] ReadChars     Points to the variable where the number of read bytes
01243     ///                            is returned. This parameter can be \c NULL if
01244     ///                            the caller does not need this information.
01245     /// @return Handle to created message or \c NULL if the function fails.
01246     static CGscMessage* CreateFromBinBuffer(
01247                     const void*      Buffer,
01248                     unsigned int     BufferSize,
01249                     GscMessageClass  ExpectedClass   = mk_Unknown,
01250                     unsigned int*    ReadChars       = 0)
01251     {
01252       return GscAct_CreateFromBinBuffer(
01253                     Buffer, BufferSize, ExpectedClass, ReadChars);
01254     }
01255
01256     /////////////////////////////////////////////////////////
01257     /// Create message from text buffer.
01258
01259     /// Create message from ANSI text buffer.
01260     /// @param [in]  Buffer        Pointer to buffer with text representation of message.
01261     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
01262     /// @param [in]  ExpectedClass Expected class of the message.
01263     ///                            Use \c mk_Unknown to read any message.
01264     /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding ANSI to UNICODE.
01265     /// @param [out] ReadChars     Points to the variable where the number of read chars
01266     ///                            is returned. This parameter can be \c NULL if
01267     ///                            the caller does not need this information.
01268     /// @return Handle to created message or \c NULL if the function fails.
01269     /// @attention Buffer must be 0-terminated.
01270     static CGscMessage* CreateFromTextBuffer(
01271                     const char*      Buffer,
01272                     unsigned int     BufferSize,
01273                     GscMessageClass  ExpectedClass   = mk_Unknown,
01274                     bool             UseUTF8Encoding = false,
01275                     unsigned int*    ReadChars       = 0)
01276     {
01277       return GscAct_CreateFromTextBufferA(
01278                     Buffer, BufferSize, ExpectedClass, UseUTF8Encoding, ReadChars);
01279     }
01280
01281     /// Create message from UNICODE text buffer.
01282     /// @param [in]  Buffer        Pointer to buffer with text representation of message.
01283     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
01284     /// @param [in]  ExpectedClass Expected class of the message.
01285     ///                            Use \c mk_Unknown to read any message.
01286     /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding UNICODE to ANSI.
01287     /// @param [out] ReadChars     Points to the variable where the number of read chars
01288     ///                            is returned. This parameter can be \c NULL if
01289     ///                            the caller does not need this information.
01290     /// @return Handle to created message or \c NULL if the function fails.
01291     /// @attention Buffer must be 0-terminated.
01292     static CGscMessage* CreateFromTextBuffer(
01293                     const wchar_t*   Buffer,
01294                     unsigned int     BufferSize,
01295                     GscMessageClass  ExpectedClass   = mk_Unknown,
01296                     bool             UseUTF8Encoding = false,
01297                     unsigned int*    ReadChars       = 0)
01298     {
01299       return GscAct_CreateFromTextBufferW(
01300                     Buffer, BufferSize, ExpectedClass, UseUTF8Encoding, ReadChars);
01301     }
01302
01303     /////////////////////////////////////////////////////////
01304     /// @name Write Operations
01305
01306     /// \{
01307
01308     /// Write message to the binary buffer.
01309     /// @param [in]  Buffer        Points to the buffer that receives the data.
01310     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
01311     /// @param [out] BytesWritten  Points to the variable where the number of written bytes
01312     ///                            is returned. This parameter can be \c NULL if
01313     ///                            the caller does not need this information.
01314     /// @return \c true if the function succeeds, \c false otherwise.
01315     ///
01316     /// @attention Buffer can be \c NULL if BufferSize is \c 0. Use it to
01317     ///            query required size.
01318     bool StoreToBinBuffer(
01319                     void*            Buffer,
01320                     unsigned int     BufferSize,
01321                     unsigned int*    BytesWritten    = 0) const
01322     {
01323       return GscAct_StoreToBinBuffer(this, Buffer, BufferSize, BytesWritten);
01324     }
01325
01326     /// Write message to the text buffer as ANSI string.
01327     /// @param [in]  Buffer        Points to the buffer that receives the data.
01328     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
01329     /// @param [in]  OutputAsPlainText   Output as plain text.
01330     /// @param [in]  UseUTF8Encoding     Use UTF8 encoding to transcode UNICODE to ANSI.
01331     /// @param [out] CharsWritten  Points to the variable where the number of written chars
01332     ///                            is returned. This parameter can be \c NULL if
01333     ///                            the caller does not need this information.
01334     /// @return \c true if the function succeeds, \c false otherwise.
01335     ///
01336     /// @attention Buffer can be \c NULL if BufferSize is \c 0. Use it to
01337     ///            query required size.
01338     /// @warning   The output produced as "plain text" CANNOT be converted
01339     ///            back to the message!
01340     bool StoreToTextBuffer(
01341                     char*            Buffer,
01342                     unsigned int     BufferSize,
01343                     bool             OutputAsPlainText = false,
01344                     bool             UseUTF8Encoding   = false,
01345                     unsigned int*    CharsWritten      = 0) const
01346     {
01347       return GscAct_StoreToTextBufferA(this, Buffer, BufferSize, OutputAsPlainText, UseUTF8Encoding, CharsWritten);
01348     }
01349
01350     /// Write message to the text buffer as UNICODE string.
01351     /// @param [in]  Buffer        Points to the buffer that receives the data.
01352     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
01353     /// @param [in]  OutputAsPlainText   Output as plain text.
01354     /// @param [in]  UseUTF8Encoding     Use UTF8 encoding to transcode ANSI to UNICODE.
01355     /// @param [out] CharsWritten  Points to the variable where the number of written chars
01356     ///                            is returned. This parameter can be \c NULL if
01357     ///                            the caller does not need this information.
01358     /// @return \c true if the function succeeds, \c false otherwise.
01359     ///
01360     /// @attention Buffer can be \c NULL if BufferSize is \c 0. Use it to
01361     ///            query required size.
01362     /// @warning   The output produced as "plain text" CANNOT be converted
01363     ///            back to the message!
01364     bool StoreToTextBuffer(
01365                     wchar_t*         Buffer,
01366                     unsigned int     BufferSize,
01367                     bool             OutputAsPlainText = false,
01368                     bool             UseUTF8Encoding   = false,
01369                     unsigned int*    CharsWritten      = 0) const
01370     {
01371       return GscAct_StoreToTextBufferW(this, Buffer, BufferSize, OutputAsPlainText, UseUTF8Encoding, CharsWritten);
01372     }
01373     /// \}
01374
01375   public:
01376     /// delete operator.
01377     /// Delete message as usual object created with \c new.
01378     void operator delete (void* Ptr)
01379     {
01380       GscAct_CloseHandle(static_cast<HGscMessage>(Ptr));
01381     }
01382
01383     /// Close message handle.
01384     /// Same as \c delete message.
01385     void CloseHandle()
01386     {
01387       GscAct_CloseHandle(this);
01388     }
01389
01390     /// Duplicate message handle.
01391     /// Increase the internal reference to the message.
01392     void DuplicateHandle()
01393     {
01394       GscAct_DuplicateHandle(this);
01395     }
01396
01397     /// Clone message.
01398     /// @return a new message as a clone of this one.
01399     HGscMessage CloneHandle() const
01400     {
01401       HGscMessage Clone;
01402       if (GscAct_CloneHandle(this, Clone))
01403         return Clone;
01404       return 0;
01405     }
01406
01407     /// Get message class.
01408     /// @return class of the message.
01409     GscMessageClass GetMessageClass() const
01410     {
01411       GscMessageClass Class;
01412       if (GscAct_GetMessageClass(this, Class))
01413         return Class;
01414       return mk_Unknown;
01415     }
01416
01417     /// Get reference counter.
01418     /// @return value of the internal reference counter.
01419     int GetReferenceCounter() const
01420     {
01421       int RefCounter;
01422       if (GscAct_GetReferenceCounter(this, RefCounter))
01423         return RefCounter;
01424       return -1;
01425     }
01426
01427
01428     /// Get internal index.
01429     /// @return   internal index.
01430     int GetInternalIndex() const
01431     {
01432       int Index;
01433       if (GscAct_GetInternalIndex(this, Index))
01434         return Index;
01435       return -1;
01436     }
01437
01438
01439     /// Get internal data.
01440     /// You can use this field as temporary storage for
01441     /// user specific data.
01442     /// @return   internal data.
01443     void* GetInternalData() const
01444     {
01445       void* Data;
01446       if (GscAct_GetInternalData(this, Data))
01447         return Data;
01448       return 0;
01449     }
01450     /// Set internal data.
01451     /// You can use this field as temporary storage for
01452     /// user specific data.
01453     /// @param [in] Data  internal data.
01454     void SetInternalData(void* Data)
01455     {
01456       GscAct_SetInternalData(this, Data);
01457     }
01458
01459
01460     /// Get message flags.
01461     /// @return   message flags.
01462     unsigned __int32 GetMessageFlags() const
01463     {
01464       unsigned __int32 Flags;
01465       if (GscAct_GetMessageFlags(this, Flags))
01466         return Flags;
01467       return 0;
01468     }
01469     /// Set message flags.
01470     /// @param [in] Flags message flags.
01471     void SetMessageFlags(unsigned __int32 Flags)
01472     {
01473       GscAct_SetMessageFlags(this, Flags);
01474     }
01475     /// Set DisableResourceUpdate flag.
01476     void DisableResourceUpdate()
01477     {
01478       SetMessageFlags(FlagDisableResourceUpdate);
01479     }
01480     /// Set DisableInternalInEventData flag.
01481     void DisableInternalInEventData()
01482     {
01483       SetMessageFlags(FlagDisableInternalInEventData);
01484     }
01485
01486
01487     /// Compare two messages.
01488     /// @param [in] aMessage   a message to compare with.
01489     /// @return     Result of comparision.
01490     bool EqualTo(ConstHGscMessage aMessage) const
01491     {
01492       bool Result;
01493       if (GscAct_Equal(this, aMessage, Result))
01494         return Result;
01495       return false;
01496     }
01497     /// Compare two messages.
01498     /// @param [in] aMessage   a message to compare with.
01499     /// @return     Result of comparision.
01500     bool operator==(ConstHGscMessage aMessage) const
01501     {
01502       // return EqualTo(aMessage);
01503       bool Result;
01504       if (GscAct_Equal(this, aMessage, Result))
01505         return Result;
01506       return false;
01507     }
01508     /// Compare two messages.
01509     /// @param [in] aMessage   a message to compare with.
01510     /// @return     Result of comparision.
01511     bool operator!=(ConstHGscMessage aMessage) const
01512     {
01513       // return ! EqualTo(aMessage);
01514       bool Result;
01515       if (GscAct_Equal(this, aMessage, Result))
01516         return ! Result;
01517       return false;
01518     }
01519 };
01520
01521
01522 /////////////////////////////////////////////////////////
01523 /// GeViScope action
01524 /// \nosubgrouping
01525 ///
01526 /// \code
01527 /// Static members:
01528 ///   CGscAction*     CreateFromBinBuffer   - create action from the bin buffer
01529 ///   CGscAction*     CreateFromTextBuffer  - create action from the text buffer
01530 ///   CGscAction*     RestoreActionFromEventData - restore action from event data
01531 ///
01532 /// Public methods:
01533 ///   void            operator delete       - delete operator
01534 ///   HGscAction      CloneHandle           - create a clone of the action
01535 ///
01536 ///   GscActionClass  GetActionClass        - access to action class
01537 ///   GscActionCode   GetActionCode         - access to action code
01538 ///   const TCHAR*    GetActionName         - access to action name
01539 ///   const TCHAR*    GetActionPlainName    - access to translated action name
01540 ///   HGscMatchAction CreateMatchActionFromTemplate
01541 ///                                         - create a match action from the
01542 ///                                           current action as template
01543 ///   bool            GetActionEventData    - get action event data
01544 ///   const TPlcMediaChannelID*
01545 ///                   GetVideoInput         - access to video  input   field
01546 ///                   GetVideoOutput        - access to video  output  field
01547 ///                   GetInputContact       - access to input  contact field
01548 ///                   GetOutputContact      - access to output contact field
01549 ///   const __int64*  GetForeignKey         - access to foreign key    field
01550 /// \endcode
01551 ///
01552 class CGscAction: public CGscMessage {
01553   public:
01554     ///
01555     /// static members
01556
01557     /////////////////////////////////////////////////////////
01558
01559     /// Create message from binary buffer.
01560     /// @param [in]  Buffer        Pointer to buffer with binary representation of message.
01561     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
01562     /// @param [out] ReadChars     Points to the variable where the number of read bytes
01563     ///                            is returned. This parameter can be \c NULL if
01564     ///                            the caller does not need this information.
01565     /// @return Handle to created action or \c NULL if the function fails.
01566     static CGscAction* CreateFromBinBuffer(
01567                     const void*      Buffer,
01568                     unsigned int     BufferSize,
01569                     unsigned int*    ReadChars       = 0)
01570     {
01571       return static_cast<HGscAction>(CGscMessage::CreateFromBinBuffer(Buffer, BufferSize, mk_Action, ReadChars));
01572     }
01573
01574     /// Create message from ANSI text buffer.
01575     /// @param [in]  Buffer        Pointer to buffer with text representation of message.
01576     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
01577     /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding ANSI to UNICODE.
01578     /// @param [out] ReadChars     Points to the variable where the number of read chars
01579     ///                            is returned. This parameter can be \c NULL if
01580     ///                            the caller does not need this information.
01581     /// @return Handle to created action or \c NULL if the function fails.
01582     /// @attention Buffer must be 0-terminated.
01583     static CGscAction* CreateFromTextBuffer(
01584                     const char*      Buffer,
01585                     unsigned int     BufferSize,
01586                     bool             UseUTF8Encoding = false,
01587                     unsigned int*    ReadChars       = 0)
01588     {
01589       return static_cast<HGscAction>(CGscMessage::CreateFromTextBuffer(Buffer, BufferSize, mk_Action, UseUTF8Encoding, ReadChars));
01590     }
01591
01592     /// Create message from UNICODE text buffer.
01593     /// @param [in]  Buffer        Pointer to buffer with text representation of message.
01594     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
01595     /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding UNICODE to ANSI.
01596     /// @param [out] ReadChars     Points to the variable where the number of read chars
01597     ///                            is returned. This parameter can be \c NULL if
01598     ///                            the caller does not need this information.
01599     /// @return Handle to created action or \c NULL if the function fails.
01600     /// @attention Buffer must be 0-terminated.
01601     static CGscAction* CreateFromTextBuffer(
01602                     const wchar_t*   Buffer,
01603                     unsigned int     BufferSize,
01604                     bool             UseUTF8Encoding = false,
01605                     unsigned int*    ReadChars       = 0)
01606     {
01607       return static_cast<HGscAction>(CGscMessage::CreateFromTextBuffer(Buffer, BufferSize, mk_Action, UseUTF8Encoding, ReadChars));
01608     }
01609
01610     /// Restore action from event data.
01611     ///
01612     /// @param [in]  EventRecord   Record with event data.
01613     /// @return Handle to created action or \c NULL if the function fails.
01614     static CGscAction* RestoreActionFromEventData(
01615                     const TPlcActionEventDataRecord& EventRecord)
01616     {
01617       return GscAct_RestoreActionFromEventData(EventRecord);
01618     }
01619
01620     /// Get internal index by action code
01621     ///
01622     /// @param [in] Code   Action code.
01623     /// @return internal index if succeeds, \c 0x7FFFFFFF otherwise.
01624     static unsigned int GetInternalIndexByCode(GscActionCode Code)
01625     {
01626       return GscAct_GetInternalIndexByCode(Code);
01627     }
01628
01629     /// Get action code by internal index.
01630     ///
01631     /// @param [in] Index  Internal index.
01632     /// @return action code if succeeds, \c ac_Unknown otherwise.
01633     static GscActionCode GetActionCodeByIndex(unsigned int Index)
01634     {
01635       return GscAct_GetActionCodeByIndex(Index);
01636     }
01637
01638     /////////////////////////////////////////////////////////
01639     /// @name Write Operations
01640
01641     /// \{
01642
01643     /// same as in CGscMessage
01644
01645     /// \}
01646
01647   public:
01648     /// delete operator.
01649     /// Delete action as usual object created with \c new.
01650     void operator delete (void* Ptr)
01651     {
01652       GscAct_CloseHandle(static_cast<HGscAction>(Ptr));
01653     }
01654
01655     /// Clone action.
01656     /// @return a new action as a clone of the current one.
01657     HGscAction CloneHandle() const
01658     {
01659       return static_cast<HGscAction>(CGscMessage::CloneHandle());
01660     }
01661
01662     /// Get action class.
01663     /// @return class of the action.
01664     GscActionClass GetActionClass() const
01665     {
01666       GscActionClass ActionClass;
01667       if (GscAct_GetActionClass(this, ActionClass))
01668         return ActionClass;
01669       return ak_Unknown;
01670     }
01671
01672     /// Get action code.
01673     /// @return code of the action.
01674     GscActionCode GetActionCode() const
01675     {
01676       GscActionCode ActionCode;
01677       if (GscAct_GetActionCode(this, ActionCode))
01678         return ActionCode;
01679       return ac_Unknown;
01680     }
01681
01682     /// Get action name.
01683     /// @return Name of the action as ANSI string.
01684     const char* GetActionNameA() const
01685     {
01686       const char* ActionName;
01687       if (GscAct_GetActionNameA(this, ActionName))
01688         return ActionName;
01689       return 0;
01690     }
01691
01692     /// Get action name.
01693     /// @return Name of the action as UNICODE string.
01694     const wchar_t* GetActionNameW() const
01695     {
01696       const wchar_t* ActionName;
01697       if (GscAct_GetActionNameW(this, ActionName))
01698         return ActionName;
01699       return 0;
01700     }
01701 #ifdef _TCHAR_DEFINED
01702     /// Get action name.
01703     /// @return Name of the action.
01704     const TCHAR* GetActionName() const
01705     {
01706       const TCHAR* ActionName;
01707       if (GscAct_GetActionName(this, ActionName))
01708         return ActionName;
01709       return 0;
01710     }
01711 #endif
01712
01713
01714     /// Get plain action name.
01715     /// @return Plain name of the action as ANSI string.
01716     const char* GetActionPlainNameA() const
01717     {
01718       const char* ActionName;
01719       if (GscAct_GetActionPlainNameA(this, ActionName))
01720         return ActionName;
01721       return 0;
01722     }
01723
01724     /// Get plain action name.
01725     /// @return Plain name of the action as UNICODE string.
01726     const wchar_t* GetActionPlainNameW() const
01727     {
01728       const wchar_t* ActionName;
01729       if (GscAct_GetActionPlainNameW(this, ActionName))
01730         return ActionName;
01731       return 0;
01732     }
01733 #ifdef _TCHAR_DEFINED
01734     /// Get plain action name.
01735     /// @return Plain name of the action.
01736     const TCHAR* GetActionPlainName() const
01737     {
01738       const TCHAR* ActionName;
01739       if (GscAct_GetActionPlainName(this, ActionName))
01740         return ActionName;
01741       return 0;
01742     }
01743 #endif
01744
01745     /// Create match action from the current action.
01746     /// @return Match action.
01747     HGscMatchAction CreateMatchActionFromTemplate() const
01748     {
01749       HGscMatchAction Result;
01750       if (GscAct_CreateMatchActionFromTemplate(this, Result))
01751         return Result;
01752       return 0;
01753     }
01754
01755     /// Get action event data.
01756     ///
01757     /// @param [out] EventRecord   Record to store event data.
01758     /// @param [out] DataComplete  Flag whether all action data are stored
01759     /// @return \c true if succeeds, \c false otherwise.
01760     bool GetActionEventData(TPlcActionEventDataRecord& EventRecord,
01761                             bool&                      DataComplete) const
01762     {
01763       return GscAct_GetActionEventData(this, EventRecord, DataComplete);
01764     }
01765
01766     /////////////////////////////////////////////////////////
01767     /// @name Get available fields
01768
01769     /// \{
01770
01771     /// Get used video input.
01772     /// @return Video input ID or \c NULL if not available.
01773     const TPlcMediaChannelID* GetVideoInput() const
01774     {
01775       const TPlcMediaChannelID* Result;
01776       if (GscAct_GetVideoInput(this, Result))
01777         return Result;
01778       return 0;
01779     }
01780
01781     /// Get used video output.
01782     /// @return Video output ID or \c NULL if not available.
01783     const TPlcMediaChannelID* GetVideoOutput() const
01784     {
01785       const TPlcMediaChannelID* Result;
01786       if (GscAct_GetVideoOutput(this, Result))
01787         return Result;
01788       return 0;
01789     }
01790
01791     /// Get used input contact.
01792     /// @return input contact ID or \c NULL if not available.
01793     const TPlcMediaChannelID* GetInputContact() const
01794     {
01795       const TPlcMediaChannelID* Result;
01796       if (GscAct_GetInputContact(this, Result))
01797         return Result;
01798       return 0;
01799     }
01800
01801     /// Get used output contact.
01802     /// @return output contact ID or \c NULL if not available.
01803     const TPlcMediaChannelID* GetOutputContact() const
01804     {
01805       const TPlcMediaChannelID* Result;
01806       if (GscAct_GetOutputContact(this, Result))
01807         return Result;
01808       return 0;
01809     }
01810
01811     /// Get used foreign key.
01812     /// @return foreign key or \c NULL if not available.
01813     const __int64* GetForeignKey() const
01814     {
01815       const __int64* Result;
01816       if (GscAct_GetForeignKey(this, Result))
01817         return Result;
01818       return 0;
01819     }
01820
01821     /// Get used generic 32-bit integer parameter.
01822     /// @return generic 32-bit integer parameter.
01823     __int32 GetGenericInt32Parameter() const
01824     {
01825       __int32 Result;
01826       if (GscAct_GetGenericInt32Parameter(this, Result))
01827         return Result;
01828       return 0;
01829     }
01830
01831     /// Update action info.
01832     ///
01833     /// @param [in]  anObject      Proxy object to pass to callback.
01834     /// @param [in]  Callback      Callback functions.
01835     /// @return \c true if update successfull, \c false otherwise.
01836     bool UpdateActionInfo(void* anObject,
01837                           const TPlcUpdateActionInfoCallback& Callback)
01838     {
01839       bool UpdateOk;
01840       if (GscAct_UpdateActionInfo(this, anObject, Callback, UpdateOk))
01841         return UpdateOk;
01842       return false;
01843     }
01844
01845     /// Update windows client info.
01846     ///
01847     /// @param [in]  localHostName   Local Windows host name
01848     /// @param [in]  localClientType Local client type
01849     /// @param [in]  localUserName   Local Windows user name
01850     /// @return \c true if succeeds, \c false otherwise.
01851     bool UpdateWindowsClientInfo(
01852                     const wchar_t*                      localHostName,
01853                     const PlcClientType                 localClientType,
01854                     const wchar_t*                      localUserName)
01855     {
01856       return GscAct_UpdateWindowsClientInfo(this, localHostName, localClientType, localUserName);
01857     }
01858     bool GetWindowsClientInfo(
01859                     const wchar_t*&                     localHostName,
01860                     const PlcClientType*&               localClientType,
01861                     const wchar_t*&                     localUserName)
01862     {
01863       return GscAct_GetWindowsClientInfo(this, localHostName, localClientType, localUserName);
01864     }
01865
01866     /// Set action property
01867     ///
01868     /// @param [in]  Key           Property key.
01869     /// @param [in]  Value         Property value.
01870     void SetProperty(const wchar_t* Key, const wchar_t*   Value)
01871     {
01872       GscAct_SetProperty(this, Key, Value);
01873     }
01874
01875     /// Get action property
01876     ///
01877     /// @param [in]  Key           Property key.
01878     /// @return Property value
01879     const wchar_t* GetProperty(const wchar_t* Key)
01880     {
01881       const wchar_t* Value = L"";
01882       GscAct_GetProperty(this, Key, Value);
01883       return Value;
01884     }
01885
01886     /// Get action properties
01887     ///
01888     /// @return Properties.
01889     const wchar_t* GetProperties()
01890     {
01891       const wchar_t* Properties = L"";
01892       GscAct_GetProperties(this, Properties);
01893       return Properties;
01894     }
01895
01896     /// \}
01897 };
01898
01899 /////////////////////////////////////////////////////////
01900 /// GeViScope match action
01901 /// \nosubgrouping
01902 ///
01903 /// \code
01904 /// Static members:
01905 ///   CGscMatchAction*CreateFromBinBuffer   - create match action from the bin buffer
01906 ///   CGscMatchAction*CreateFromTextBuffer  - create match action from the text buffer
01907 ///   CGscMatchAction*RestoreActionFromEventData - restore match action from event data
01908 ///
01909 /// Public methods:
01910 ///   void            operator delete       - delete operator
01911 ///   HGscAction      CloneHandle           - create a clone of the match action
01912 ///
01913 ///   GscActionClass  GetActionClass        - access to action class
01914 ///   GscActionCode   GetActionCode         - access to action code
01915 ///   const TCHAR*    GetActionName         - access to action name
01916 ///   const TCHAR*    GetActionPlainName    - access to translated action name
01917 ///
01918 ///   bool            HasDescription        - check user provided description (comment)
01919 ///   const TCHAR*    GetDescription        - get user provided description (comment)
01920 ///   const TCHAR*    GetComment
01921 ///   void            SetDescription        - set user provided description (comment)
01922 ///   void            SetComment
01923 ///
01924 ///   bool            Matches               - check an action against match condition
01925 ///   HGscAction      CreateActionFromTemplate
01926 ///                                         - create the action from the
01927 ///                                           current match action and another
01928 ///                                           action as field template
01929 ///   bool            GetActionEventData    - get action event data
01930 /// \endcode
01931 ///
01932 class CGscMatchAction: public CGscMessage {
01933   public:
01934     ///
01935     /// static members
01936
01937     /////////////////////////////////////////////////////////
01938
01939     /// Create message from binary buffer.
01940     /// @param [in]  Buffer        Pointer to buffer with binary representation of message.
01941     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer.
01942     /// @param [out] ReadChars     Points to the variable where the number of read bytes
01943     ///                            is returned. This parameter can be \c NULL if
01944     ///                            the caller does not need this information.
01945     /// @return Handle to created match action or \c NULL if the function fails.
01946     static CGscMatchAction* CreateFromBinBuffer(
01947                     const void*      Buffer,
01948                     unsigned int     BufferSize,
01949                     unsigned int*    ReadChars       = 0)
01950     {
01951       return static_cast<HGscMatchAction>(CGscMessage::CreateFromBinBuffer(Buffer, BufferSize, mk_MatchAction, ReadChars));
01952     }
01953
01954     /// Create message from ANSI text buffer.
01955     /// @param [in]  Buffer        Pointer to buffer with text representation of message.
01956     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
01957     /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding ANSI to UNICODE.
01958     /// @param [out] ReadChars     Points to the variable where the number of read chars
01959     ///                            is returned. This parameter can be \c NULL if
01960     ///                            the caller does not need this information.
01961     /// @return Handle to created action or \c NULL if the function fails.
01962     /// @attention Buffer must be 0-terminated.
01963     static CGscMatchAction* CreateFromTextBuffer(
01964                     const char*      Buffer,
01965                     unsigned int     BufferSize,
01966                     bool             UseUTF8Encoding = false,
01967                     unsigned int*    ReadChars       = 0)
01968     {
01969       return static_cast<HGscMatchAction>(CGscMessage::CreateFromTextBuffer(Buffer, BufferSize, mk_MatchAction, UseUTF8Encoding, ReadChars));
01970     }
01971
01972     /// Create message from UNICODE text buffer.
01973     /// @param [in]  Buffer        Pointer to buffer with text representation of message.
01974     /// @param [in]  BufferSize    Size of the buffer pointed by Buffer in chars.
01975     /// @param [in]  UseUTF8Encoding Use UTF8 encoding for transcoding UNICODE to ANSI.
01976     /// @param [out] ReadChars     Points to the variable where the number of read chars
01977     ///                            is returned. This parameter can be \c NULL if
01978     ///                            the caller does not need this information.
01979     /// @return Handle to created action or \c NULL if the function fails.
01980     /// @attention Buffer must be 0-terminated.
01981     static CGscMatchAction* CreateFromTextBuffer(
01982                     const wchar_t*   Buffer,
01983                     unsigned int     BufferSize,
01984                     bool             UseUTF8Encoding = false,
01985                     unsigned int*    ReadChars       = 0)
01986     {
01987       return static_cast<HGscMatchAction>(CGscMessage::CreateFromTextBuffer(Buffer, BufferSize, mk_MatchAction, UseUTF8Encoding, ReadChars));
01988     }
01989
01990     /// Restore match action from event data.
01991     ///
01992     /// @param [in]  EventRecord   Record with event data.
01993     /// @return Handle to created action or \c NULL if the function fails.
01994     static CGscMatchAction* RestoreActionFromEventData(
01995                     const TPlcActionEventDataRecord& EventRecord)
01996     {
01997       return GscMatchAct_RestoreActionFromEventData(EventRecord);
01998     }
01999
02000     /////////////////////////////////////////////////////////
02001     /// @name Write Operations
02002
02003     /// \{
02004
02005     /// same as in CGscMessage
02006
02007     /// \}
02008
02009   public:
02010     /// delete operator.
02011     /// Delete match action as usual object created with \c new.
02012     void operator delete (void* Ptr)
02013     {
02014       GscAct_CloseHandle(static_cast<HGscMatchAction>(Ptr));
02015     }
02016
02017     /// Clone match action.
02018     /// @return a new match action as a clone of the current one.
02019     HGscMatchAction CloneHandle() const
02020     {
02021       return static_cast<HGscMatchAction>(CGscMessage::CloneHandle());
02022     }
02023
02024     /// Get action class.
02025     /// @return class of the match action.
02026     GscActionClass GetActionClass() const
02027     {
02028       GscActionClass ActionClass;
02029       if (GscMatchAct_GetActionClass(this, ActionClass))
02030         return ActionClass;
02031       return ak_Unknown;
02032     }
02033
02034     /// Get action code.
02035     /// @return code of the match action.
02036     GscActionCode GetActionCode() const
02037     {
02038       GscActionCode ActionCode;
02039       if (GscMatchAct_GetActionCode(this, ActionCode))
02040         return ActionCode;
02041       return ac_Unknown;
02042     }
02043
02044     /// Get action name.
02045     /// @return Name of the match action as ANSI string.
02046     const char* GetActionNameA() const
02047     {
02048       const char* ActionName;
02049       if (GscMatchAct_GetActionNameA(this, ActionName))
02050         return ActionName;
02051       return 0;
02052     }
02053
02054     /// Get action name.
02055     /// @return Name of the match action as UNICODE string.
02056     const wchar_t* GetActionNameW() const
02057     {
02058       const wchar_t* ActionName;
02059       if (GscMatchAct_GetActionNameW(this, ActionName))
02060         return ActionName;
02061       return 0;
02062     }
02063 #ifdef _TCHAR_DEFINED
02064     /// Get action name.
02065     /// @return Name of the match action as ANSI string.
02066     const TCHAR* GetActionName() const
02067     {
02068       const TCHAR* ActionName;
02069       if (GscMatchAct_GetActionName(this, ActionName))
02070         return ActionName;
02071       return 0;
02072     }
02073 #endif
02074
02075     /// Get plain action name.
02076     /// @return Plain name of the match action as ANSI string.
02077     const char* GetActionPlainNameA() const
02078     {
02079       const char* ActionName;
02080       if (GscMatchAct_GetActionPlainNameA(this, ActionName))
02081         return ActionName;
02082       return 0;
02083     }
02084
02085     /// Get action name.
02086     /// @return Plain name of the match action as UNICODE string.
02087     const wchar_t* GetActionPlainNameW() const
02088     {
02089       const wchar_t* ActionName;
02090       if (GscMatchAct_GetActionPlainNameW(this, ActionName))
02091         return ActionName;
02092       return 0;
02093     }
02094 #ifdef _TCHAR_DEFINED
02095     /// Get plain action name.
02096     /// @return Plain name of the match action as ANSI string.
02097     const TCHAR* GetActionPlainName() const
02098     {
02099       const TCHAR* ActionName;
02100       if (GscMatchAct_GetActionPlainName(this, ActionName))
02101         return ActionName;
02102       return 0;
02103     }
02104 #endif
02105
02106     /// Check description of the match action.
02107     /// @return \c true if the match action has user provided comment.
02108     bool HasDescription()
02109     {
02110       bool Description;
02111       if (GscMatchAct_HasDescription(this, Description))
02112         return Description;
02113       return false;
02114     }
02115
02116     /// Get description of the match action.
02117     /// @return Description of the match action as ANSI string.
02118     const char* GetDescriptionA() const
02119     {
02120       const char* Description;
02121       if (GscMatchAct_GetDescriptionA(this, Description))
02122         return Description;
02123       return 0;
02124     }
02125
02126     /// Get description of the match action.
02127     /// Alias to \ref GetDescriptionA.
02128     const char* GetCommentA() const
02129     {
02130       return GetDescriptionA();
02131     }
02132
02133     /// Get description of the match action.
02134     /// @return Description of the match action as UNICODE string.
02135     const wchar_t* GetDescriptionW() const
02136     {
02137       const wchar_t* Description;
02138       if (GscMatchAct_GetDescriptionW(this, Description))
02139         return Description;
02140       return 0;
02141     }
02142
02143     /// Get description of the match action.
02144     /// Alias to \ref GetDescriptionW.
02145     const wchar_t* GetCommentW() const
02146     {
02147       return GetDescriptionW();
02148     }
02149 #ifdef _TCHAR_DEFINED
02150     /// Get description of the match action.
02151     /// @return Description of the match action.
02152     const TCHAR* GetDescription() const
02153     {
02154       const TCHAR* Description;
02155       if (GscMatchAct_GetDescription(this, Description))
02156         return Description;
02157       return 0;
02158     }
02159     /// Get description of the match action.
02160     /// Alias to \ref GetDescription.
02161     const TCHAR* GetComment() const
02162     {
02163       return GetDescription();
02164     }
02165 #endif
02166
02167     /// Set description of the match action.
02168     /// @param [in] Description User provided comment to the match action.
02169     void SetDescription(const char* Description)
02170     {
02171       GscMatchAct_SetDescriptionA(this, Description);
02172     }
02173     /// Set description of the match action.
02174     /// @param [in] Description User provided comment to the match action.
02175     void SetDescription(const wchar_t* Description)
02176     {
02177       GscMatchAct_SetDescriptionW(this, Description);
02178     }
02179     /// Set description of the match action.
02180     /// @param [in] Description User provided comment to the match action.
02181     void SetComment(const char* Description)
02182     {
02183       SetDescription(Description);
02184     }
02185     /// Set description of the match action.
02186     /// @param [in] Description User provided comment to the match action.
02187     void SetComment(const wchar_t* Description)
02188     {
02189       SetDescription(Description);
02190     }
02191
02192     /////////////////////////////////////////////////////////
02193     /// @name Match specific functions
02194
02195     /// \{
02196
02197     /// Matches action.
02198     /// @param [in] anAction Action to match against the current match action.
02199     /// @return \c true if the condition satisfied, \c false otherwise.
02200     bool Matches(ConstHGscAction anAction) const
02201     {
02202       bool Result;
02203       if (GscMatchAct_Matches(this, anAction, Result))
02204         return Result;
02205       return false;
02206     }
02207
02208     /// Create action from the current match action and provided action as template.
02209     /// @param [in] anAction Action to use as template to take available fields from.
02210     /// @return Handle to created action.
02211     /// @attention anAction can be \c NULL if you don't use it.
02212     HGscAction CreateActionFromTemplate(ConstHGscAction anAction) const
02213     {
02214       HGscAction Result;
02215       if (GscMatchAct_CreateActionFromTemplate(this, anAction, Result))
02216         return Result;
02217       return 0;
02218     }
02219
02220     /// Get action event data.
02221     ///
02222     /// @param [out] EventRecord   Record to store event data.
02223     /// @param [out] DataComplete  Flag whether all action data are stored
02224     /// @return \c true if succeeds, \c false otherwise.
02225     bool GetActionEventData(TPlcActionEventDataRecord& EventRecord,
02226                             bool&                      DataComplete) const
02227     {
02228       return GscMatchAct_GetActionEventData(this, EventRecord, DataComplete);
02229     }
02230
02231     /// \}
02232 };
02233 #endif // __GscActionsDLL
02234
02235 /// \} end of group GscPlcClassWrapper
02236
02237 /////////////////////////////////////////////////////////
02238 /// Create functions
02239 /////////////////////////////////////////////////////////
02240
02241 /// \addtogroup GscPlcCreate
02242 /// \{
02243
02244 /// Create action 'ABC connect'.
02245 /// Connect audio back channel.
02246 /// @param  [in]  aAddress     Address of the remote server.
02247 /// @return handle to action if the function succeeds or \c NULL if it fails.
02248 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateABCConnect(
02249   const wchar_t* aAddress);
02250
02251 /// Create action 'ABC disconnect'.
02252 /// Disconnect audio back channel.
02253 /// @return handle to action if the function succeeds or \c NULL if it fails.
02254 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateABCDisconnect();
02255
02256 /// Create action 'ABC play file'.
02257 /// Play file on audio back channel.
02258 /// @param  [in]  aFileID      File ID.
02259 /// @param  [in]  aFileName    Name of the file.
02260 /// @param  [in]  aAutoRepeat  Repeat file automatically
02261 /// @return handle to action if the function succeeds or \c NULL if it fails.
02262 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateABCPlayFile(
02263   const __int64& aFileID,
02264   const wchar_t* aFileName,
02265   const bool aAutoRepeat);
02266
02267 /// Create action 'Abort all auto backups'.
02268 /// Abort all auto backups.
02269 /// @return handle to action if the function succeeds or \c NULL if it fails.
02270 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAbortAllAutoBackups();
02271
02272 /// Create action 'Abort auto backup'.
02273 /// Abort auto backup.
02274 /// @param  [in]  aSchedule    Schedule.
02275 /// @return handle to action if the function succeeds or \c NULL if it fails.
02276 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAbortAutoBackup(
02277   const TPlcResourceID& aSchedule);
02278
02279 /// Create action 'ACS access denied'.
02280 /// ACS access denied.
02281 /// @param  [in]  aACSName     ACS name.
02282 /// @param  [in]  aACSNo       ACS no.
02283 /// @param  [in]  aAccount     Account no.
02284 /// @param  [in]  aBancCode    Bank code.
02285 /// @param  [in]  aCardNo      Card no.
02286 /// @param  [in]  aTimeStamp   Time stamp.
02287 /// @param  [in]  aReason      Reason.
02288 /// @return handle to action if the function succeeds or \c NULL if it fails.
02289 ///
02290 /// @attention Following parameters are optional:  aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp. aReason. \par
02291 ///            You can provide \c NULL pointer if you not use these fields.
02292 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateACSAccessDenied(
02293   const wchar_t* aACSName,
02294   const __int32* aACSNo,
02295   const __int64* aAccount,
02296   const __int64* aBancCode,
02297   const wchar_t* aCardNo,
02298   const TGLibDateTime* aTimeStamp,
02299   const __int32* aReason);
02300
02301 /// Create action 'ACS access granted'.
02302 /// ACS access granted.
02303 /// @param  [in]  aACSName     ACS name.
02304 /// @param  [in]  aACSNo       ACS no.
02305 /// @param  [in]  aAccount     Account no.
02306 /// @param  [in]  aBancCode    Bank code.
02307 /// @param  [in]  aCardNo      Card no.
02308 /// @param  [in]  aTimeStamp   Time stamp.
02309 /// @return handle to action if the function succeeds or \c NULL if it fails.
02310 ///
02311 /// @attention Following parameters are optional:  aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp. \par
02312 ///            You can provide \c NULL pointer if you not use these fields.
02313 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateACSAccessGranted(
02314   const wchar_t* aACSName,
02315   const __int32* aACSNo,
02316   const __int64* aAccount,
02317   const __int64* aBancCode,
02318   const wchar_t* aCardNo,
02319   const TGLibDateTime* aTimeStamp);
02320
02321 /// Create action 'ACS raw answer'.
02322 /// ACS raw answer.
02323 /// @param  [in]  aACSName     ACS name.
02324 /// @param  [in]  aTimeStamp   Time stamp.
02325 /// @param  [in]  aACSData     ACS answer.
02326 /// @return handle to action if the function succeeds or \c NULL if it fails.
02327 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateACSRawAnswer(
02328   const wchar_t* aACSName,
02329   const TGLibDateTime& aTimeStamp,
02330   const wchar_t* aACSData);
02331
02332 /// Create action 'ACS raw data'.
02333 /// ACS raw data.
02334 /// @param  [in]  aACSName     ACS name.
02335 /// @param  [in]  aTimeStamp   Time stamp.
02336 /// @param  [in]  aACSData     ACS data.
02337 /// @return handle to action if the function succeeds or \c NULL if it fails.
02338 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateACSRawData(
02339   const wchar_t* aACSName,
02340   const TGLibDateTime& aTimeStamp,
02341   const wchar_t* aACSData);
02342
02343 /// Create action 'Activate external process'.
02344 /// Activate external process.
02345 /// @param  [in]  aChannel     Channel.
02346 /// @param  [in]  aTimeStamp   Time stamp.
02347 /// @param  [in]  aExternalSystem External system to activate.
02348 /// @return handle to action if the function succeeds or \c NULL if it fails.
02349 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateActivateExternalProcess(
02350   const TPlcMediaChannelID& aChannel,
02351   const TGLibDateTime& aTimeStamp,
02352   const VideoSensorKind aExternalSystem);
02353
02354 /// Create action 'ATM raw answer'.
02355 /// ATM raw answer.
02356 /// @param  [in]  aATMName     ATM name.
02357 /// @param  [in]  aTimeStamp   Time stamp.
02358 /// @param  [in]  aATMData     ATM answer.
02359 /// @return handle to action if the function succeeds or \c NULL if it fails.
02360 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateATMRawAnswer(
02361   const wchar_t* aATMName,
02362   const TGLibDateTime& aTimeStamp,
02363   const wchar_t* aATMData);
02364
02365 /// Create action 'ATM raw data'.
02366 /// ATM raw data.
02367 /// @param  [in]  aATMName     ATM name.
02368 /// @param  [in]  aTimeStamp   Time stamp.
02369 /// @param  [in]  aATMData     ATM data.
02370 /// @return handle to action if the function succeeds or \c NULL if it fails.
02371 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateATMRawData(
02372   const wchar_t* aATMName,
02373   const TGLibDateTime& aTimeStamp,
02374   const wchar_t* aATMData);
02375
02376 /// Create action 'ATM transaction'.
02377 /// ATM transaction.
02378 /// @param  [in]  aATMName     ATM name.
02379 /// @param  [in]  aNewTransaction New transaction.
02380 /// @param  [in]  aPhotostep   Photostep.
02381 /// @param  [in]  aATMNo       ATM no.
02382 /// @param  [in]  aAccount     Account no.
02383 /// @param  [in]  aBancCode    Bank code.
02384 /// @param  [in]  aCardNo      Card no.
02385 /// @param  [in]  aTAN1        TAN 1.
02386 /// @param  [in]  aTAN2        TAN 2.
02387 /// @param  [in]  aTimeStamp1  Time stamp 1.
02388 /// @param  [in]  aTimeStamp2  Time stamp 2.
02389 /// @param  [in]  aAmount      Amount.
02390 /// @param  [in]  aCurrency    Currency.
02391 /// @return handle to action if the function succeeds or \c NULL if it fails.
02392 ///
02393 /// @attention Following parameters are optional:  aATMNo. aAccount. aBancCode. aCardNo. aTAN1. aTAN2. aTimeStamp1. aTimeStamp2. aAmount. aCurrency. \par
02394 ///            You can provide \c NULL pointer if you not use these fields.
02395 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateATMTransaction(
02396   const wchar_t* aATMName,
02397   const bool aNewTransaction,
02398   const __int32 aPhotostep,
02399   const __int32* aATMNo,
02400   const __int64* aAccount,
02401   const __int64* aBancCode,
02402   const wchar_t* aCardNo,
02403   const __int64* aTAN1,
02404   const __int64* aTAN2,
02405   const TGLibDateTime* aTimeStamp1,
02406   const TGLibDateTime* aTimeStamp2,
02407   const double* aAmount,
02408   const wchar_t* aCurrency);
02409
02410 /// Create action 'Auto backup capacity warning'.
02411 /// Auto backup capacity monitoring: capacity warning.
02412 /// @param  [in]  aWarning     Warning.
02413 /// @param  [in]  aDestination Destination.
02414 /// @param  [in]  aTotalCapacity Total capacity.
02415 /// @param  [in]  aFreeCapacity Free capacity.
02416 /// @param  [in]  aAllocatedByGbf Allocated by GBF.
02417 /// @param  [in]  aPercentFree Percent free.
02418 /// @param  [in]  aPercentAllocated Percent allocated.
02419 /// @param  [in]  aPercentAllocatedByGbf Percent allocated by GBF.
02420 /// @return handle to action if the function succeeds or \c NULL if it fails.
02421 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupCapacityMonitoringCapacityWarning(
02422   const ABCapacityWarning aWarning,
02423   const TPlcResourceID& aDestination,
02424   const __int64& aTotalCapacity,
02425   const __int64& aFreeCapacity,
02426   const __int64& aAllocatedByGbf,
02427   const __int32 aPercentFree,
02428   const __int32 aPercentAllocated,
02429   const __int32 aPercentAllocatedByGbf);
02430
02431 /// Create action 'Auto backup capacity file auto deleted'.
02432 /// Auto backup capacity monitoring: file auto deleted.
02433 /// @param  [in]  aWarning     Warning.
02434 /// @param  [in]  aDestination Destination.
02435 /// @param  [in]  aTotalCapacity Total capacity.
02436 /// @param  [in]  aFreeCapacity Free capacity.
02437 /// @param  [in]  aAllocatedByGbf Allocated by GBF.
02438 /// @param  [in]  aPercentFree Percent free.
02439 /// @param  [in]  aPercentAllocated Percent allocated.
02440 /// @param  [in]  aPercentAllocatedByGbf Percent allocated by GBF.
02441 /// @param  [in]  aFileSize    File size.
02442 /// @param  [in]  aFileName    File name.
02443 /// @return handle to action if the function succeeds or \c NULL if it fails.
02444 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupCapacityMonitoringFileAutoDeleted(
02445   const ABCapacityWarning aWarning,
02446   const TPlcResourceID& aDestination,
02447   const __int64& aTotalCapacity,
02448   const __int64& aFreeCapacity,
02449   const __int64& aAllocatedByGbf,
02450   const __int32 aPercentFree,
02451   const __int32 aPercentAllocated,
02452   const __int32 aPercentAllocatedByGbf,
02453   const __int64& aFileSize,
02454   const wchar_t* aFileName);
02455
02456 /// Create action 'Auto backup capacity out of disk space'.
02457 /// Auto backup capacity monitoring: out of disk space.
02458 /// @param  [in]  aWarning     Warning.
02459 /// @param  [in]  aDestination Destination.
02460 /// @param  [in]  aTotalCapacity Total capacity.
02461 /// @param  [in]  aFreeCapacity Free capacity.
02462 /// @param  [in]  aAllocatedByGbf Allocated by GBF.
02463 /// @param  [in]  aPercentFree Percent free.
02464 /// @param  [in]  aPercentAllocated Percent allocated.
02465 /// @param  [in]  aPercentAllocatedByGbf Percent allocated by GBF.
02466 /// @return handle to action if the function succeeds or \c NULL if it fails.
02467 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupCapacityMonitoringOutOfDiskSpace(
02468   const ABCapacityWarning aWarning,
02469   const TPlcResourceID& aDestination,
02470   const __int64& aTotalCapacity,
02471   const __int64& aFreeCapacity,
02472   const __int64& aAllocatedByGbf,
02473   const __int32 aPercentFree,
02474   const __int32 aPercentAllocated,
02475   const __int32 aPercentAllocatedByGbf);
02476
02477 /// Create action 'Auto backup file done'.
02478 /// Auto backup progress notification: file done.
02479 /// @param  [in]  aSchedule    Schedule.
02480 /// @param  [in]  aStartTime   Start time, empty during event backup.
02481 /// @param  [in]  aEffectiveStartTime Effective schedule start time.
02482 /// @param  [in]  aOperationCount Operation count.
02483 /// @param  [in]  aTimerStart  Timer start.
02484 /// @param  [in]  aOperationIndex Operation index.
02485 /// @param  [in]  aOperationStartTime Operation start time.
02486 /// @param  [in]  aSource      Source.
02487 /// @param  [in]  aDestination Destination.
02488 /// @param  [in]  aFileSizeLimit File size limit.
02489 /// @param  [in]  aBandWidthLimit Band width limit.
02490 /// @param  [in]  aFileIndex   File index.
02491 /// @param  [in]  aFileName    File name.
02492 /// @param  [in]  aFileSize    File size.
02493 /// @return handle to action if the function succeeds or \c NULL if it fails.
02494 ///
02495 /// @attention Following parameters are optional:  aStartTime. \par
02496 ///            You can provide \c NULL pointer if you not use these fields.
02497 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupFileDone(
02498   const TPlcResourceID& aSchedule,
02499   const TGLibDateTime* aStartTime,
02500   const TGLibDateTime& aEffectiveStartTime,
02501   const __int32 aOperationCount,
02502   const bool aTimerStart,
02503   const __int32 aOperationIndex,
02504   const TGLibDateTime& aOperationStartTime,
02505   const TPlcResourceID& aSource,
02506   const TPlcResourceID& aDestination,
02507   const __int64& aFileSizeLimit,
02508   const __int64& aBandWidthLimit,
02509   const __int32 aFileIndex,
02510   const wchar_t* aFileName,
02511   const __int64& aFileSize);
02512
02513 /// Create action 'Auto backup file progress'.
02514 /// Auto backup progress notification: file progress.
02515 /// @param  [in]  aSchedule    Schedule.
02516 /// @param  [in]  aStartTime   Start time, empty during event backup.
02517 /// @param  [in]  aEffectiveStartTime Effective schedule start time.
02518 /// @param  [in]  aOperationCount Operation count.
02519 /// @param  [in]  aTimerStart  Timer start.
02520 /// @param  [in]  aOperationIndex Operation index.
02521 /// @param  [in]  aOperationStartTime Operation start time.
02522 /// @param  [in]  aSource      Source.
02523 /// @param  [in]  aDestination Destination.
02524 /// @param  [in]  aFileSizeLimit File size limit.
02525 /// @param  [in]  aBandWidthLimit Band width limit.
02526 /// @param  [in]  aFileIndex   File index.
02527 /// @param  [in]  aFileName    File name.
02528 /// @param  [in]  aFileSize    File size.
02529 /// @return handle to action if the function succeeds or \c NULL if it fails.
02530 ///
02531 /// @attention Following parameters are optional:  aStartTime. \par
02532 ///            You can provide \c NULL pointer if you not use these fields.
02533 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupFileProgress(
02534   const TPlcResourceID& aSchedule,
02535   const TGLibDateTime* aStartTime,
02536   const TGLibDateTime& aEffectiveStartTime,
02537   const __int32 aOperationCount,
02538   const bool aTimerStart,
02539   const __int32 aOperationIndex,
02540   const TGLibDateTime& aOperationStartTime,
02541   const TPlcResourceID& aSource,
02542   const TPlcResourceID& aDestination,
02543   const __int64& aFileSizeLimit,
02544   const __int64& aBandWidthLimit,
02545   const __int32 aFileIndex,
02546   const wchar_t* aFileName,
02547   const __int64& aFileSize);
02548
02549 /// Create action 'Auto backup file started'.
02550 /// Auto backup progress notification: file started.
02551 /// @param  [in]  aSchedule    Schedule.
02552 /// @param  [in]  aStartTime   Start time, empty during event backup.
02553 /// @param  [in]  aEffectiveStartTime Effective schedule start time.
02554 /// @param  [in]  aOperationCount Operation count.
02555 /// @param  [in]  aTimerStart  Timer start.
02556 /// @param  [in]  aOperationIndex Operation index.
02557 /// @param  [in]  aOperationStartTime Operation start time.
02558 /// @param  [in]  aSource      Source.
02559 /// @param  [in]  aDestination Destination.
02560 /// @param  [in]  aFileSizeLimit File size limit.
02561 /// @param  [in]  aBandWidthLimit Band width limit.
02562 /// @param  [in]  aFileIndex   File index.
02563 /// @param  [in]  aFileName    File name.
02564 /// @return handle to action if the function succeeds or \c NULL if it fails.
02565 ///
02566 /// @attention Following parameters are optional:  aStartTime. \par
02567 ///            You can provide \c NULL pointer if you not use these fields.
02568 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupFileStarted(
02569   const TPlcResourceID& aSchedule,
02570   const TGLibDateTime* aStartTime,
02571   const TGLibDateTime& aEffectiveStartTime,
02572   const __int32 aOperationCount,
02573   const bool aTimerStart,
02574   const __int32 aOperationIndex,
02575   const TGLibDateTime& aOperationStartTime,
02576   const TPlcResourceID& aSource,
02577   const TPlcResourceID& aDestination,
02578   const __int64& aFileSizeLimit,
02579   const __int64& aBandWidthLimit,
02580   const __int32 aFileIndex,
02581   const wchar_t* aFileName);
02582
02583 /// Create action 'Auto backup operation done'.
02584 /// Auto backup progress notification: operation done.
02585 /// @param  [in]  aSchedule    Schedule.
02586 /// @param  [in]  aStartTime   Start time, empty during event backup.
02587 /// @param  [in]  aEffectiveStartTime Effective schedule start time.
02588 /// @param  [in]  aOperationCount Operation count.
02589 /// @param  [in]  aTimerStart  Timer start.
02590 /// @param  [in]  aOperationIndex Operation index.
02591 /// @param  [in]  aOperationStartTime Operation start time.
02592 /// @param  [in]  aOperationStopTime Operation stop time.
02593 /// @param  [in]  aSource      Source.
02594 /// @param  [in]  aDestination Destination.
02595 /// @param  [in]  aFileSizeLimit File size limit.
02596 /// @param  [in]  aBandWidthLimit Band width limit.
02597 /// @param  [in]  aOperationErrorCode Operation error code.
02598 /// @return handle to action if the function succeeds or \c NULL if it fails.
02599 ///
02600 /// @attention Following parameters are optional:  aStartTime. aOperationErrorCode. \par
02601 ///            You can provide \c NULL pointer if you not use these fields.
02602 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupOperationDone(
02603   const TPlcResourceID& aSchedule,
02604   const TGLibDateTime* aStartTime,
02605   const TGLibDateTime& aEffectiveStartTime,
02606   const __int32 aOperationCount,
02607   const bool aTimerStart,
02608   const __int32 aOperationIndex,
02609   const TGLibDateTime& aOperationStartTime,
02610   const TGLibDateTime& aOperationStopTime,
02611   const TPlcResourceID& aSource,
02612   const TPlcResourceID& aDestination,
02613   const __int64& aFileSizeLimit,
02614   const __int64& aBandWidthLimit,
02615   const __int32* aOperationErrorCode);
02616
02617 /// Create action 'Auto backup operation started'.
02618 /// Auto backup progress notification: operation started.
02619 /// @param  [in]  aSchedule    Schedule.
02620 /// @param  [in]  aStartTime   Start time, empty during event backup.
02621 /// @param  [in]  aEffectiveStartTime Effective schedule start time.
02622 /// @param  [in]  aOperationCount Operation count.
02623 /// @param  [in]  aTimerStart  Timer start.
02624 /// @param  [in]  aOperationIndex Operation index.
02625 /// @param  [in]  aOperationStartTime Operation start time.
02626 /// @param  [in]  aSource      Source.
02627 /// @param  [in]  aDestination Destination.
02628 /// @param  [in]  aFileSizeLimit File size limit.
02629 /// @param  [in]  aBandWidthLimit Band width limit.
02630 /// @return handle to action if the function succeeds or \c NULL if it fails.
02631 ///
02632 /// @attention Following parameters are optional:  aStartTime. \par
02633 ///            You can provide \c NULL pointer if you not use these fields.
02634 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupOperationStarted(
02635   const TPlcResourceID& aSchedule,
02636   const TGLibDateTime* aStartTime,
02637   const TGLibDateTime& aEffectiveStartTime,
02638   const __int32 aOperationCount,
02639   const bool aTimerStart,
02640   const __int32 aOperationIndex,
02641   const TGLibDateTime& aOperationStartTime,
02642   const TPlcResourceID& aSource,
02643   const TPlcResourceID& aDestination,
02644   const __int64& aFileSizeLimit,
02645   const __int64& aBandWidthLimit);
02646
02647 /// Create action 'Auto backup schedule done'.
02648 /// Auto backup progress notification: schedule done.
02649 /// @param  [in]  aSchedule    Schedule.
02650 /// @param  [in]  aStartTime   Start time, empty during event backup.
02651 /// @param  [in]  aEffectiveStartTime Effective schedule start time.
02652 /// @param  [in]  aStopTime    Schedule stop time.
02653 /// @param  [in]  aOperationCount Operation count.
02654 /// @param  [in]  aTimerStart  Timer start.
02655 /// @return handle to action if the function succeeds or \c NULL if it fails.
02656 ///
02657 /// @attention Following parameters are optional:  aStartTime. \par
02658 ///            You can provide \c NULL pointer if you not use these fields.
02659 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupScheduleDone(
02660   const TPlcResourceID& aSchedule,
02661   const TGLibDateTime* aStartTime,
02662   const TGLibDateTime& aEffectiveStartTime,
02663   const TGLibDateTime& aStopTime,
02664   const __int32 aOperationCount,
02665   const bool aTimerStart);
02666
02667 /// Create action 'Auto backup schedule started'.
02668 /// Auto backup progress notification: schedule started.
02669 /// @param  [in]  aSchedule    Schedule.
02670 /// @param  [in]  aStartTime   Start time, empty during event backup.
02671 /// @param  [in]  aEffectiveStartTime Effective schedule start time.
02672 /// @param  [in]  aOperationCount Operation count.
02673 /// @param  [in]  aTimerStart  Timer start.
02674 /// @return handle to action if the function succeeds or \c NULL if it fails.
02675 ///
02676 /// @attention Following parameters are optional:  aStartTime. \par
02677 ///            You can provide \c NULL pointer if you not use these fields.
02678 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoBackupScheduleStarted(
02679   const TPlcResourceID& aSchedule,
02680   const TGLibDateTime* aStartTime,
02681   const TGLibDateTime& aEffectiveStartTime,
02682   const __int32 aOperationCount,
02683   const bool aTimerStart);
02684
02685 /// Create action 'Auto focus off'.
02686 /// Disable auto focus of the camera.
02687 /// @param  [in]  aCamera      PTZ head.
02688 /// @return handle to action if the function succeeds or \c NULL if it fails.
02689 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoFocusOff(
02690   const TPlcMediaChannelID& aCamera);
02691
02692 /// Create action 'Auto focus on'.
02693 /// Enable auto focus of the camera.
02694 /// @param  [in]  aCamera      PTZ head.
02695 /// @return handle to action if the function succeeds or \c NULL if it fails.
02696 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateAutoFocusOn(
02697   const TPlcMediaChannelID& aCamera);
02698
02699 /// Create action 'Backup event'.
02700 /// Backup event.
02701 /// @param  [in]  aEventID     Instance ID of the event.
02702 /// @param  [in]  aTypeID      Type of the event.
02703 /// @param  [in]  aDestination Destination.
02704 /// @param  [in]  aStartHintID Optional start hint ID.
02705 /// @param  [in]  aStopHintID  Optional stop hint ID.
02706 /// @param  [in]  aSubfolder   Sub folder to backup event.
02707 /// @return handle to action if the function succeeds or \c NULL if it fails.
02708 ///
02709 /// @attention Following parameters are optional:  aStartHintID. aStopHintID. aSubfolder. \par
02710 ///            You can provide \c NULL pointer if you not use these fields.
02711 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateBackupEvent(
02712   const __int64& aEventID,
02713   const TPlcEventTypeID& aTypeID,
02714   const TPlcResourceID& aDestination,
02715   const __int64* aStartHintID,
02716   const __int64* aStopHintID,
02717   const wchar_t* aSubfolder);
02718
02719 /// Create action 'Barcode data'.
02720 /// Barcode data.
02721 /// @param  [in]  aReaderName  Scanner name.
02722 /// @param  [in]  aTimeStamp   Time stamp.
02723 /// @param  [in]  aBarcode     Barcode.
02724 /// @return handle to action if the function succeeds or \c NULL if it fails.
02725 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateBarcodeData(
02726   const wchar_t* aReaderName,
02727   const TGLibDateTime& aTimeStamp,
02728   const wchar_t* aBarcode);
02729
02730 /// Create action 'Blocking filter activate'.
02731 /// Blocking filter activate.
02732 /// @param  [in]  aFilter      Blocking filter.
02733 /// @return handle to action if the function succeeds or \c NULL if it fails.
02734 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateBlockingFilterActivate(
02735   const wchar_t* aFilter);
02736
02737 /// Create action 'Blocking filter deactivate'.
02738 /// Blocking filter deactivate.
02739 /// @param  [in]  aFilter      Blocking filter.
02740 /// @return handle to action if the function succeeds or \c NULL if it fails.
02741 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateBlockingFilterDeactivate(
02742   const wchar_t* aFilter);
02743
02744 /// Create action 'Camera apply profile'.
02745 /// Apply a predefined profile settings to the camera.
02746 /// @param  [in]  aCamera      PTZ head.
02747 /// @param  [in]  aProfile     Profile name.
02748 /// @return handle to action if the function succeeds or \c NULL if it fails.
02749 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraApplyProfile(
02750   const TPlcMediaChannelID& aCamera,
02751   const wchar_t* aProfile);
02752
02753 /// Create action 'Camera backlight compensation mode'.
02754 /// Change backlight compensation mode of the camera.
02755 /// @param  [in]  aCamera      PTZ head.
02756 /// @param  [in]  aMode        Backlight compensation mode.
02757 /// @return handle to action if the function succeeds or \c NULL if it fails.
02758 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraBacklightCompensationMode(
02759   const TPlcMediaChannelID& aCamera,
02760   const PlcBacklightMode aMode);
02761
02762 /// Create action 'Camera clear preset text'.
02763 /// Clear camera text for preset position.
02764 /// @param  [in]  aCamera      PTZ head.
02765 /// @param  [in]  aPosition    Preset position.
02766 /// @return handle to action if the function succeeds or \c NULL if it fails.
02767 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraClearPrePosText(
02768   const TPlcMediaChannelID& aCamera,
02769   const __int32 aPosition);
02770
02771 /// Create action 'Camera day/night mode'.
02772 /// Change day/night mode of the camera.
02773 /// @param  [in]  aCamera      PTZ head.
02774 /// @param  [in]  aMode        Day/night mode.
02775 /// @return handle to action if the function succeeds or \c NULL if it fails.
02776 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraDayNightMode(
02777   const TPlcMediaChannelID& aCamera,
02778   const PlcDayNightMode aMode);
02779
02780 /// Create action 'Camera light off'.
02781 /// Turn camera light off.
02782 /// @param  [in]  aCamera      PTZ head.
02783 /// @return handle to action if the function succeeds or \c NULL if it fails.
02784 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraLightOff(
02785   const TPlcMediaChannelID& aCamera);
02786
02787 /// Create action 'Camera light on'.
02788 /// Turn camera light on.
02789 /// @param  [in]  aCamera      PTZ head.
02790 /// @return handle to action if the function succeeds or \c NULL if it fails.
02791 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraLightOn(
02792   const TPlcMediaChannelID& aCamera);
02793
02794 /// Create action 'Camera manual iris off'.
02795 /// Disable manual iris of the camera.
02796 /// @param  [in]  aCamera      PTZ head.
02797 /// @return handle to action if the function succeeds or \c NULL if it fails.
02798 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraManualIrisOff(
02799   const TPlcMediaChannelID& aCamera);
02800
02801 /// Create action 'Camera manual iris on'.
02802 /// Enable manual iris of the camera.
02803 /// @param  [in]  aCamera      PTZ head.
02804 /// @return handle to action if the function succeeds or \c NULL if it fails.
02805 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraManualIrisOn(
02806   const TPlcMediaChannelID& aCamera);
02807
02808 /// Create action 'Camera off'.
02809 /// Turn camera off.
02810 /// @param  [in]  aCamera      PTZ head.
02811 /// @return handle to action if the function succeeds or \c NULL if it fails.
02812 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraOff(
02813   const TPlcMediaChannelID& aCamera);
02814
02815 /// Create action 'Camera on'.
02816 /// Turn camera on.
02817 /// @param  [in]  aCamera      PTZ head.
02818 /// @return handle to action if the function succeeds or \c NULL if it fails.
02819 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraOn(
02820   const TPlcMediaChannelID& aCamera);
02821
02822 /// Create action 'Camera pump off'.
02823 /// Turn camera pump off.
02824 /// @param  [in]  aCamera      PTZ head.
02825 /// @return handle to action if the function succeeds or \c NULL if it fails.
02826 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraPumpOff(
02827   const TPlcMediaChannelID& aCamera);
02828
02829 /// Create action 'Camera pump on'.
02830 /// Turn camera pump on.
02831 /// @param  [in]  aCamera      PTZ head.
02832 /// @return handle to action if the function succeeds or \c NULL if it fails.
02833 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraPumpOn(
02834   const TPlcMediaChannelID& aCamera);
02835
02836 /// Create action 'Camera RAW output'.
02837 /// Output unformatted command to the camera.
02838 /// @param  [in]  aCamera      PTZ head.
02839 /// @param  [in]  aOutput      RAW command to output.
02840 /// @return handle to action if the function succeeds or \c NULL if it fails.
02841 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraRAWOutput(
02842   const TPlcMediaChannelID& aCamera,
02843   const char* aOutput);
02844
02845 /// Create action 'Camera select char mode'.
02846 /// Select camera character mode.
02847 /// @param  [in]  aCamera      PTZ head.
02848 /// @param  [in]  aMode        Character mode.
02849 /// @return handle to action if the function succeeds or \c NULL if it fails.
02850 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSelectCharMode(
02851   const TPlcMediaChannelID& aCamera,
02852   const __int32 aMode);
02853
02854 /// Create action 'Camera set preset text'.
02855 /// Set camera text for preset position.
02856 /// @param  [in]  aCamera      PTZ head.
02857 /// @param  [in]  aPosition    Preset position.
02858 /// @return handle to action if the function succeeds or \c NULL if it fails.
02859 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSetPrePosText(
02860   const TPlcMediaChannelID& aCamera,
02861   const __int32 aPosition);
02862
02863 /// Create action 'Camera spec func U off'.
02864 /// Turn camera special function U off.
02865 /// @param  [in]  aCamera      PTZ head.
02866 /// @return handle to action if the function succeeds or \c NULL if it fails.
02867 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncUOff(
02868   const TPlcMediaChannelID& aCamera);
02869
02870 /// Create action 'Camera spec func U on'.
02871 /// Turn camera special function U on.
02872 /// @param  [in]  aCamera      PTZ head.
02873 /// @return handle to action if the function succeeds or \c NULL if it fails.
02874 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncUOn(
02875   const TPlcMediaChannelID& aCamera);
02876
02877 /// Create action 'Camera spec func V off'.
02878 /// Turn camera special function V off.
02879 /// @param  [in]  aCamera      PTZ head.
02880 /// @return handle to action if the function succeeds or \c NULL if it fails.
02881 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncVOff(
02882   const TPlcMediaChannelID& aCamera);
02883
02884 /// Create action 'Camera spec func V on'.
02885 /// Turn camera special function V on.
02886 /// @param  [in]  aCamera      PTZ head.
02887 /// @return handle to action if the function succeeds or \c NULL if it fails.
02888 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncVOn(
02889   const TPlcMediaChannelID& aCamera);
02890
02891 /// Create action 'Camera spec func X off'.
02892 /// Turn camera special function X off.
02893 /// @param  [in]  aCamera      PTZ head.
02894 /// @return handle to action if the function succeeds or \c NULL if it fails.
02895 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncXOff(
02896   const TPlcMediaChannelID& aCamera);
02897
02898 /// Create action 'Camera spec func X on'.
02899 /// Turn camera special function X on.
02900 /// @param  [in]  aCamera      PTZ head.
02901 /// @return handle to action if the function succeeds or \c NULL if it fails.
02902 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncXOn(
02903   const TPlcMediaChannelID& aCamera);
02904
02905 /// Create action 'Camera spec func Y off'.
02906 /// Turn camera special function Y off.
02907 /// @param  [in]  aCamera      PTZ head.
02908 /// @return handle to action if the function succeeds or \c NULL if it fails.
02909 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncYOff(
02910   const TPlcMediaChannelID& aCamera);
02911
02912 /// Create action 'Camera spec func Y on'.
02913 /// Turn camera special function Y on.
02914 /// @param  [in]  aCamera      PTZ head.
02915 /// @return handle to action if the function succeeds or \c NULL if it fails.
02916 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraSpecFuncYOn(
02917   const TPlcMediaChannelID& aCamera);
02918
02919 /// Create action 'Camera stop all'.
02920 /// Camera stop all.
02921 /// @param  [in]  aCamera      PTZ head.
02922 /// @return handle to action if the function succeeds or \c NULL if it fails.
02923 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraStopAll(
02924   const TPlcMediaChannelID& aCamera);
02925
02926 /// Create action 'Camera text off'.
02927 /// Disable camera text.
02928 /// @param  [in]  aCamera      PTZ head.
02929 /// @return handle to action if the function succeeds or \c NULL if it fails.
02930 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraTextOff(
02931   const TPlcMediaChannelID& aCamera);
02932
02933 /// Create action 'Camera text on'.
02934 /// Enable camera text.
02935 /// @param  [in]  aCamera      PTZ head.
02936 /// @return handle to action if the function succeeds or \c NULL if it fails.
02937 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraTextOn(
02938   const TPlcMediaChannelID& aCamera);
02939
02940 /// Create action 'Camera tour start'.
02941 /// Start camera tour.
02942 /// @param  [in]  aCamera      PTZ head.
02943 /// @param  [in]  aTourID      Tour ID.
02944 /// @param  [in]  aTourName    Tour name.
02945 /// @return handle to action if the function succeeds or \c NULL if it fails.
02946 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraTourStart(
02947   const TPlcMediaChannelID& aCamera,
02948   const __int32 aTourID,
02949   const char* aTourName);
02950
02951 /// Create action 'Camera tour stop'.
02952 /// Stop camera tour.
02953 /// @param  [in]  aCamera      PTZ head.
02954 /// @return handle to action if the function succeeds or \c NULL if it fails.
02955 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraTourStop(
02956   const TPlcMediaChannelID& aCamera);
02957
02958 /// Create action 'Camera version off'.
02959 /// Hide camera version string.
02960 /// @param  [in]  aCamera      PTZ head.
02961 /// @return handle to action if the function succeeds or \c NULL if it fails.
02962 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraVersionOff(
02963   const TPlcMediaChannelID& aCamera);
02964
02965 /// Create action 'Camera version on'.
02966 /// Show camera version string.
02967 /// @param  [in]  aCamera      PTZ head.
02968 /// @return handle to action if the function succeeds or \c NULL if it fails.
02969 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraVersionOn(
02970   const TPlcMediaChannelID& aCamera);
02971
02972 /// Create action 'Camera wash-wipe off'.
02973 /// Turn camera wash-wipe off.
02974 /// @param  [in]  aCamera      PTZ head.
02975 /// @return handle to action if the function succeeds or \c NULL if it fails.
02976 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraWashOff(
02977   const TPlcMediaChannelID& aCamera);
02978
02979 /// Create action 'Camera wash-wipe on'.
02980 /// Turn camera wash-wipe on.
02981 /// @param  [in]  aCamera      PTZ head.
02982 /// @return handle to action if the function succeeds or \c NULL if it fails.
02983 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCameraWashOn(
02984   const TPlcMediaChannelID& aCamera);
02985
02986 /// Create action 'Cancel export'.
02987 /// Cancel export.
02988 /// @param  [in]  aExportID    Export GUID.
02989 /// @param  [in]  aAbortFlag   Abort flag.
02990 /// @return handle to action if the function succeeds or \c NULL if it fails.
02991 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCancelExport(
02992   const GUID& aExportID,
02993   const PlcExportAbort aAbortFlag);
02994
02995 /// Create action 'Case has been closed'.
02996 /// Case has been closed.
02997 /// @return handle to action if the function succeeds or \c NULL if it fails.
02998 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCaseClosed();
02999
03000 /// Create action 'Case has been opened'.
03001 /// Case has been opened.
03002 /// @return handle to action if the function succeeds or \c NULL if it fails.
03003 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCaseOpened();
03004
03005 /// Create action 'Change AD parameter set'.
03006 /// This action changes the current AD parameter set of the video channel.
03007 /// @param  [in]  aChannel     Channel.
03008 /// @param  [in]  aParameterSet The name of the new AD parameter set.
03009 /// @return handle to action if the function succeeds or \c NULL if it fails.
03010 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChangeADParameterSet(
03011   const TPlcMediaChannelID& aChannel,
03012   const TPlcResourceID& aParameterSet);
03013
03014 /// Create action 'Change camera profile'.
03015 /// This action changes the current camera profile of the hardware module.
03016 /// @param  [in]  aHardwareModule Hardware module.
03017 /// @param  [in]  aCameraProfile The name of the camera profile.
03018 /// @return handle to action if the function succeeds or \c NULL if it fails.
03019 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChangeCameraProfile(
03020   const TPlcResourceID& aHardwareModule,
03021   const TPlcResourceID& aCameraProfile);
03022
03023 /// Create action 'Change CPA parameter set'.
03024 /// This action changes the current CPA parameter set of the video channel.
03025 /// @param  [in]  aChannel     Channel.
03026 /// @param  [in]  aParameterSet The name of the new CPA parameter set.
03027 /// @return handle to action if the function succeeds or \c NULL if it fails.
03028 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChangeCPAParameterSet(
03029   const TPlcMediaChannelID& aChannel,
03030   const TPlcResourceID& aParameterSet);
03031
03032 /// Create action 'Change GTectVMX parameter set'.
03033 /// This action changes the current GTectVMX parameter set of the video channel.
03034 /// @param  [in]  aChannel     Channel.
03035 /// @param  [in]  aParameterSet The name of the new GTect parameter set.
03036 /// @return handle to action if the function succeeds or \c NULL if it fails.
03037 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChangeGTectParameterSet(
03038   const TPlcMediaChannelID& aChannel,
03039   const TPlcResourceID& aParameterSet);
03040
03041 /// Create action 'Change OBTRACK parameter set'.
03042 /// This action changes the current OBTRACK parameter set of the video channel.
03043 /// @param  [in]  aChannel     Channel.
03044 /// @param  [in]  aParameterSet The name of the new OBTRACK parameter set.
03045 /// @return handle to action if the function succeeds or \c NULL if it fails.
03046 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChangeObtrackParameterSet(
03047   const TPlcMediaChannelID& aChannel,
03048   const TPlcResourceID& aParameterSet);
03049
03050 /// Create action 'Change VMD parameter set'.
03051 /// This action changes the current VMD parameter set of the video channel.
03052 /// @param  [in]  aChannel     Channel.
03053 /// @param  [in]  aParameterSet The name of the new VMD parameter set.
03054 /// @return handle to action if the function succeeds or \c NULL if it fails.
03055 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChangeVMDParameterSet(
03056   const TPlcMediaChannelID& aChannel,
03057   const TPlcResourceID& aParameterSet);
03058
03059 /// Create action 'Channel error'.
03060 /// Notify channel error.
03061 /// @param  [in]  aChannel     Channel.
03062 /// @param  [in]  aSensorType  Sensor type.
03063 /// @param  [in]  aSource      Source of the message.
03064 /// @param  [in]  aMessage     Kind of the message.
03065 /// @param  [in]  aWindowsError Optional Windows error code.
03066 /// @param  [in]  aDescription Optional description of the message.
03067 /// @param  [in]  aXMLInfo     Optional additional info (usually as XML string).
03068 /// @return handle to action if the function succeeds or \c NULL if it fails.
03069 ///
03070 /// @attention Following parameters are optional:  aSensorType. aWindowsError. aDescription. aXMLInfo. \par
03071 ///            You can provide \c NULL pointer if you not use these fields.
03072 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChannelError(
03073   const TPlcMediaChannelID& aChannel,
03074   const VideoSensorKind* aSensorType,
03075   const PlcMessageSource aSource,
03076   const PlcMessageCode aMessage,
03077   const __int32* aWindowsError,
03078   const wchar_t* aDescription,
03079   const char* aXMLInfo);
03080
03081 /// Create action 'Channel info'.
03082 /// Notify channel information.
03083 /// @param  [in]  aChannel     Channel.
03084 /// @param  [in]  aSensorType  Sensor type.
03085 /// @param  [in]  aSource      Source of the message.
03086 /// @param  [in]  aMessage     Kind of the message.
03087 /// @param  [in]  aDescription Optional description of the message.
03088 /// @param  [in]  aXMLInfo     Optional additional info (usually as XML string).
03089 /// @return handle to action if the function succeeds or \c NULL if it fails.
03090 ///
03091 /// @attention Following parameters are optional:  aSensorType. aDescription. aXMLInfo. \par
03092 ///            You can provide \c NULL pointer if you not use these fields.
03093 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChannelInfo(
03094   const TPlcMediaChannelID& aChannel,
03095   const VideoSensorKind* aSensorType,
03096   const PlcMessageSource aSource,
03097   const PlcMessageCode aMessage,
03098   const wchar_t* aDescription,
03099   const char* aXMLInfo);
03100
03101 /// Create action 'Channel live check'.
03102 /// This action notifies that the channel is alive.
03103 /// @param  [in]  aChannel     Channel.
03104 /// @param  [in]  aSensorType  Sensor type.
03105 /// @param  [in]  aTimeStamp   Time stamp.
03106 /// @return handle to action if the function succeeds or \c NULL if it fails.
03107 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChannelLiveCheck(
03108   const TPlcMediaChannelID& aChannel,
03109   const VideoSensorKind aSensorType,
03110   const TGLibDateTime& aTimeStamp);
03111
03112 /// Create action 'Channel warning'.
03113 /// Notify channel warning.
03114 /// @param  [in]  aChannel     Channel.
03115 /// @param  [in]  aSensorType  Sensor type.
03116 /// @param  [in]  aSource      Source of the message.
03117 /// @param  [in]  aMessage     Kind of the message.
03118 /// @param  [in]  aWindowsError Optional Windows error code.
03119 /// @param  [in]  aDescription Optional description of the message.
03120 /// @param  [in]  aXMLInfo     Optional additional info (usually as XML string).
03121 /// @return handle to action if the function succeeds or \c NULL if it fails.
03122 ///
03123 /// @attention Following parameters are optional:  aSensorType. aWindowsError. aDescription. aXMLInfo. \par
03124 ///            You can provide \c NULL pointer if you not use these fields.
03125 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateChannelWarning(
03126   const TPlcMediaChannelID& aChannel,
03127   const VideoSensorKind* aSensorType,
03128   const PlcMessageSource aSource,
03129   const PlcMessageCode aMessage,
03130   const __int32* aWindowsError,
03131   const wchar_t* aDescription,
03132   const char* aXMLInfo);
03133
03134 /// Create action 'CPA measurement'.
03135 /// CPA measurement.
03136 /// @param  [in]  aChannel     Channel.
03137 /// @param  [in]  aCorrelation Correlation factor.
03138 /// @return handle to action if the function succeeds or \c NULL if it fails.
03139 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCPAMeasurement(
03140   const TPlcMediaChannelID& aChannel,
03141   const __int32 aCorrelation);
03142
03143 /// Create action 'Custom action'.
03144 /// This action has no side effects and can be used for customer purposes.
03145 /// @param  [in]  aInt         Numeric parameter.
03146 /// @param  [in]  aString      Literal parameter.
03147 /// @return handle to action if the function succeeds or \c NULL if it fails.
03148 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateCustomAction(
03149   const __int64& aInt,
03150   const wchar_t* aString);
03151
03152 /// Create action 'Database recording info per ring'.
03153 /// Database recording info per ring.
03154 /// @param  [in]  aDatabaseRing Database ring.
03155 /// @param  [in]  aNoVideoRecording Video is recording or not.
03156 /// @param  [in]  aNoAudioRecording Audio is recording or not.
03157 /// @param  [in]  aNoRecordingAtAll Video and/or audio is recording or not.
03158 /// @param  [in]  aVideoSamplesPerSecond Video samples per second.
03159 /// @param  [in]  aVideoMBPerSecond Video MB per second.
03160 /// @param  [in]  aAudioSamplesPerSecond Audio samples per second.
03161 /// @param  [in]  aAudioMBPerSecond Audio MB per second.
03162 /// @param  [in]  aWriteWaitTimesPercent Write waiting times in percent.
03163 /// @param  [in]  aRingCapacity Ring capacity.
03164 /// @param  [in]  aOldestItem  Time stamp of the oldest item.
03165 /// @param  [in]  aRecordingDepth Recording depth in hours.
03166 /// @param  [in]  aEstimatedRequiredCapacity Estimated required capacity.
03167 /// @return handle to action if the function succeeds or \c NULL if it fails.
03168 ///
03169 /// @attention Following parameters are optional:  aRecordingDepth. aEstimatedRequiredCapacity. \par
03170 ///            You can provide \c NULL pointer if you not use these fields.
03171 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDatabaseRecordingInfoRing(
03172   const PlcDatabaseRing aDatabaseRing,
03173   const bool aNoVideoRecording,
03174   const bool aNoAudioRecording,
03175   const bool aNoRecordingAtAll,
03176   const double& aVideoSamplesPerSecond,
03177   const double& aVideoMBPerSecond,
03178   const double& aAudioSamplesPerSecond,
03179   const double& aAudioMBPerSecond,
03180   const double& aWriteWaitTimesPercent,
03181   const __int64& aRingCapacity,
03182   const TGLibDateTime& aOldestItem,
03183   const double* aRecordingDepth,
03184   const __int64* aEstimatedRequiredCapacity);
03185
03186 /// Create action 'Database recording info total'.
03187 /// Database recording info total.
03188 /// @param  [in]  aNoVideoRecording Video is recording or not.
03189 /// @param  [in]  aNoAudioRecording Audio is recording or not.
03190 /// @param  [in]  aNoRecordingAtAll Video and/or audio is recording or not.
03191 /// @param  [in]  aVideoSamplesPerSecond Video samples per second.
03192 /// @param  [in]  aVideoMBPerSecond Video MB per second.
03193 /// @param  [in]  aAudioSamplesPerSecond Audio samples per second.
03194 /// @param  [in]  aAudioMBPerSecond Audio MB per second.
03195 /// @param  [in]  aWriteWaitTimesPercent Write waiting times in percent.
03196 /// @param  [in]  aTotalCapacity Total capacity.
03197 /// @param  [in]  aFreeCapacity Free capacity.
03198 /// @param  [in]  aAllocatedCapacity Allocated capacity.
03199 /// @param  [in]  aOldestItem  Time stamp of the oldest item.
03200 /// @param  [in]  aRecordingDepth Recording depth in hours.
03201 /// @param  [in]  aEstimatedRequiredCapacity Estimated required capacity.
03202 /// @param  [in]  aRequiredCapacityFactor Required capacity factor.
03203 /// @param  [in]  aRequiredCapacityAvailable Required capacity available.
03204 /// @return handle to action if the function succeeds or \c NULL if it fails.
03205 ///
03206 /// @attention Following parameters are optional:  aOldestItem. aRecordingDepth. aEstimatedRequiredCapacity. aRequiredCapacityFactor. aRequiredCapacityAvailable. \par
03207 ///            You can provide \c NULL pointer if you not use these fields.
03208 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDatabaseRecordingInfoTotal(
03209   const bool aNoVideoRecording,
03210   const bool aNoAudioRecording,
03211   const bool aNoRecordingAtAll,
03212   const double& aVideoSamplesPerSecond,
03213   const double& aVideoMBPerSecond,
03214   const double& aAudioSamplesPerSecond,
03215   const double& aAudioMBPerSecond,
03216   const double& aWriteWaitTimesPercent,
03217   const __int64& aTotalCapacity,
03218   const __int64& aFreeCapacity,
03219   const __int64& aAllocatedCapacity,
03220   const TGLibDateTime* aOldestItem,
03221   const double* aRecordingDepth,
03222   const __int64* aEstimatedRequiredCapacity,
03223   const double* aRequiredCapacityFactor,
03224   const bool* aRequiredCapacityAvailable);
03225
03226 /// Create action 'Database started'.
03227 /// This action will be fired at the database start-up.
03228 /// @param  [in]  aStatus      Database status message.
03229 /// @param  [in]  aTotalSize   Database total size.
03230 /// @return handle to action if the function succeeds or \c NULL if it fails.
03231 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDatabaseStarted(
03232   const PlcDatabaseStatus aStatus,
03233   const __int64& aTotalSize);
03234
03235 /// Create action 'Move to default position'.
03236 /// Move camera to default position.
03237 /// @param  [in]  aCamera      PTZ head.
03238 /// @return handle to action if the function succeeds or \c NULL if it fails.
03239 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDefaultPosCallUp(
03240   const TPlcMediaChannelID& aCamera);
03241
03242 /// Create action 'Clear default position'.
03243 /// Clear camera default position.
03244 /// @param  [in]  aCamera      PTZ head.
03245 /// @return handle to action if the function succeeds or \c NULL if it fails.
03246 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDefaultPosClear(
03247   const TPlcMediaChannelID& aCamera);
03248
03249 /// Create action 'Save default position'.
03250 /// Save current camera position as default position.
03251 /// @param  [in]  aCamera      PTZ head.
03252 /// @return handle to action if the function succeeds or \c NULL if it fails.
03253 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDefaultPosSave(
03254   const TPlcMediaChannelID& aCamera);
03255
03256 /// Create action 'Device found'.
03257 /// This action will be fired when the USB or NET device is connected to the system. It is also fired at start-up for all detected devices.
03258 /// @param  [in]  aType        Type of the device.
03259 /// @param  [in]  aName        Device name if assigned in setup, empty otherwise.
03260 /// @param  [in]  aSerial      Serial ID of the device.
03261 /// @return handle to action if the function succeeds or \c NULL if it fails.
03262 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDeviceFound(
03263   const char* aType,
03264   const char* aName,
03265   const char* aSerial);
03266
03267 /// Create action 'New firmware received'.
03268 /// This action will be fired when the USB or NET device has got the new firmware.
03269 /// @param  [in]  aType        Type of the device.
03270 /// @param  [in]  aName        Device name if assigned in setup, empty otherwise.
03271 /// @param  [in]  aSerial      Serial ID of the device.
03272 /// @param  [in]  aFirmware    Serial ID of the firmware.
03273 /// @return handle to action if the function succeeds or \c NULL if it fails.
03274 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDeviceNewFirmware(
03275   const char* aType,
03276   const char* aName,
03277   const char* aSerial,
03278   const char* aFirmware);
03279
03280 /// Create action 'Device plugin error'.
03281 /// This action notifies device plugin error.
03282 /// @param  [in]  aChannel     Channel.
03283 /// @param  [in]  aType        Type of the device.
03284 /// @param  [in]  aSubType     Subtype of the device.
03285 /// @param  [in]  aName        Device name.
03286 /// @param  [in]  aSerial      Serial ID of the device.
03287 /// @param  [in]  aErrorClass  Error class of the error occured.
03288 /// @param  [in]  aErrorCode   Plugin type specific error code.
03289 /// @param  [in]  aDescription Error description.
03290 /// @return handle to action if the function succeeds or \c NULL if it fails.
03291 ///
03292 /// @attention Following parameters are optional:  aSubType. aErrorCode. aDescription. \par
03293 ///            You can provide \c NULL pointer if you not use these fields.
03294 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDevicePluginError(
03295   const TPlcMediaChannelID& aChannel,
03296   const char* aType,
03297   const char* aSubType,
03298   const char* aName,
03299   const char* aSerial,
03300   const PlcPluginError aErrorClass,
03301   const __int32* aErrorCode,
03302   const char* aDescription);
03303
03304 /// Create action 'Device plugin state'.
03305 /// This action notifies device plugin state.
03306 /// @param  [in]  aChannel     Channel.
03307 /// @param  [in]  aType        Type of the device.
03308 /// @param  [in]  aSubType     Subtype of the device.
03309 /// @param  [in]  aName        Device name.
03310 /// @param  [in]  aSerial      Serial ID of the device.
03311 /// @param  [in]  aState       New plugin device state.
03312 /// @param  [in]  aInternalState Plugin device specific state.
03313 /// @param  [in]  aDescription State description.
03314 /// @return handle to action if the function succeeds or \c NULL if it fails.
03315 ///
03316 /// @attention Following parameters are optional:  aSubType. aInternalState. aDescription. \par
03317 ///            You can provide \c NULL pointer if you not use these fields.
03318 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDevicePluginState(
03319   const TPlcMediaChannelID& aChannel,
03320   const char* aType,
03321   const char* aSubType,
03322   const char* aName,
03323   const char* aSerial,
03324   const PlcPluginState aState,
03325   const __int32* aInternalState,
03326   const char* aDescription);
03327
03328 /// Create action 'Device reattached'.
03329 /// This action will be fired when the USB or NET device is reattached to the system.
03330 /// @param  [in]  aType        Type of the device.
03331 /// @param  [in]  aName        Device name if assigned in setup, empty otherwise.
03332 /// @param  [in]  aSerial      Serial ID of the device.
03333 /// @return handle to action if the function succeeds or \c NULL if it fails.
03334 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDeviceReattached(
03335   const char* aType,
03336   const char* aName,
03337   const char* aSerial);
03338
03339 /// Create action 'Device removed'.
03340 /// This action will be fired when the USB or NET device is disconnected from the system. It is also fired at the start-up for all parameterized but not present devices.
03341 /// @param  [in]  aType        Type of the device.
03342 /// @param  [in]  aName        Device name if assigned in setup, empty otherwise.
03343 /// @param  [in]  aSerial      Serial ID of the device.
03344 /// @return handle to action if the function succeeds or \c NULL if it fails.
03345 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDeviceRemoved(
03346   const char* aType,
03347   const char* aName,
03348   const char* aSerial);
03349
03350 /// Create action 'Digital input'.
03351 /// This action will be fired when the state of the digital input has changed.
03352 /// @param  [in]  aContact     Contact.
03353 /// @param  [in]  aState       New state.
03354 /// @return handle to action if the function succeeds or \c NULL if it fails.
03355 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateDigitalInput(
03356   const TPlcMediaChannelID& aContact,
03357   const DigitalInputState aState);
03358
03359 /// Create action 'Event backup done'.
03360 /// Event backup progress notification: backup done.
03361 /// @param  [in]  aJobID       Backup job ID.
03362 /// @param  [in]  aEventTypeID Type of the event.
03363 /// @param  [in]  aEventID     Instance ID of the event.
03364 /// @param  [in]  aDestination Destination.
03365 /// @param  [in]  aFileSizeLimit File size limit.
03366 /// @param  [in]  aBandWidthLimit Band width limit.
03367 /// @param  [in]  aStartTime   Backup start time.
03368 /// @param  [in]  aStopTime    Backup stop time.
03369 /// @param  [in]  aOperationErrorCode Operation error code.
03370 /// @return handle to action if the function succeeds or \c NULL if it fails.
03371 ///
03372 /// @attention Following parameters are optional:  aOperationErrorCode. \par
03373 ///            You can provide \c NULL pointer if you not use these fields.
03374 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventBackupDone(
03375   const GUID& aJobID,
03376   const TPlcEventTypeID& aEventTypeID,
03377   const __int64& aEventID,
03378   const TPlcResourceID& aDestination,
03379   const __int64& aFileSizeLimit,
03380   const __int64& aBandWidthLimit,
03381   const TGLibDateTime& aStartTime,
03382   const TGLibDateTime& aStopTime,
03383   const __int32* aOperationErrorCode);
03384
03385 /// Create action 'Event backup file done'.
03386 /// Event backup progress notification: file done.
03387 /// @param  [in]  aJobID       Backup job ID.
03388 /// @param  [in]  aEventTypeID Type of the event.
03389 /// @param  [in]  aEventID     Instance ID of the event.
03390 /// @param  [in]  aDestination Destination.
03391 /// @param  [in]  aFileSizeLimit File size limit.
03392 /// @param  [in]  aBandWidthLimit Band width limit.
03393 /// @param  [in]  aStartTime   Effective backup start time.
03394 /// @param  [in]  aFileIndex   File index.
03395 /// @param  [in]  aFileName    File name.
03396 /// @param  [in]  aFileSize    File size.
03397 /// @return handle to action if the function succeeds or \c NULL if it fails.
03398 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventBackupFileDone(
03399   const GUID& aJobID,
03400   const TPlcEventTypeID& aEventTypeID,
03401   const __int64& aEventID,
03402   const TPlcResourceID& aDestination,
03403   const __int64& aFileSizeLimit,
03404   const __int64& aBandWidthLimit,
03405   const TGLibDateTime& aStartTime,
03406   const __int32 aFileIndex,
03407   const wchar_t* aFileName,
03408   const __int64& aFileSize);
03409
03410 /// Create action 'Event backup file progress'.
03411 /// Event backup progress notification: file progress.
03412 /// @param  [in]  aJobID       Backup job ID.
03413 /// @param  [in]  aEventTypeID Type of the event.
03414 /// @param  [in]  aEventID     Instance ID of the event.
03415 /// @param  [in]  aDestination Destination.
03416 /// @param  [in]  aFileSizeLimit File size limit.
03417 /// @param  [in]  aBandWidthLimit Band width limit.
03418 /// @param  [in]  aStartTime   Effective backup start time.
03419 /// @param  [in]  aFileIndex   File index.
03420 /// @param  [in]  aFileName    File name.
03421 /// @param  [in]  aFileSize    File size.
03422 /// @return handle to action if the function succeeds or \c NULL if it fails.
03423 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventBackupFileProgress(
03424   const GUID& aJobID,
03425   const TPlcEventTypeID& aEventTypeID,
03426   const __int64& aEventID,
03427   const TPlcResourceID& aDestination,
03428   const __int64& aFileSizeLimit,
03429   const __int64& aBandWidthLimit,
03430   const TGLibDateTime& aStartTime,
03431   const __int32 aFileIndex,
03432   const wchar_t* aFileName,
03433   const __int64& aFileSize);
03434
03435 /// Create action 'Event backup file started'.
03436 /// Event backup progress notification: file started.
03437 /// @param  [in]  aJobID       Backup job ID.
03438 /// @param  [in]  aEventTypeID Type of the event.
03439 /// @param  [in]  aEventID     Instance ID of the event.
03440 /// @param  [in]  aDestination Destination.
03441 /// @param  [in]  aFileSizeLimit File size limit.
03442 /// @param  [in]  aBandWidthLimit Band width limit.
03443 /// @param  [in]  aStartTime   Effective backup start time.
03444 /// @param  [in]  aFileIndex   File index.
03445 /// @param  [in]  aFileName    File name.
03446 /// @return handle to action if the function succeeds or \c NULL if it fails.
03447 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventBackupFileStarted(
03448   const GUID& aJobID,
03449   const TPlcEventTypeID& aEventTypeID,
03450   const __int64& aEventID,
03451   const TPlcResourceID& aDestination,
03452   const __int64& aFileSizeLimit,
03453   const __int64& aBandWidthLimit,
03454   const TGLibDateTime& aStartTime,
03455   const __int32 aFileIndex,
03456   const wchar_t* aFileName);
03457
03458 /// Create action 'Event backup started'.
03459 /// Event backup progress notification: backup started.
03460 /// @param  [in]  aJobID       Backup job ID.
03461 /// @param  [in]  aEventTypeID Type of the event.
03462 /// @param  [in]  aEventID     Instance ID of the event.
03463 /// @param  [in]  aDestination Destination.
03464 /// @param  [in]  aFileSizeLimit File size limit.
03465 /// @param  [in]  aBandWidthLimit Band width limit.
03466 /// @param  [in]  aStartTime   Backup start time.
03467 /// @return handle to action if the function succeeds or \c NULL if it fails.
03468 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventBackupStarted(
03469   const GUID& aJobID,
03470   const TPlcEventTypeID& aEventTypeID,
03471   const __int64& aEventID,
03472   const TPlcResourceID& aDestination,
03473   const __int64& aFileSizeLimit,
03474   const __int64& aBandWidthLimit,
03475   const TGLibDateTime& aStartTime);
03476
03477 /// Create action 'Event recording changed'.
03478 /// Event recording settings are changed.
03479 /// @param  [in]  aEventID     Instance ID of the event.
03480 /// @param  [in]  aTypeID      Type of the event.
03481 /// @return handle to action if the function succeeds or \c NULL if it fails.
03482 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventRecordingChanged(
03483   const __int64& aEventID,
03484   const TPlcEventTypeID& aTypeID);
03485
03486 /// Create action 'Event started'.
03487 /// Event has started.
03488 /// @param  [in]  aEventID     Instance ID of the event.
03489 /// @param  [in]  aTypeID      Type of the event.
03490 /// @param  [in]  aForeignKey  Optional foreign key used to start the alarm.
03491 /// @return handle to action if the function succeeds or \c NULL if it fails.
03492 ///
03493 /// @attention Following parameters are optional:  aForeignKey. \par
03494 ///            You can provide \c NULL pointer if you not use these fields.
03495 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventStartedEx(
03496   const __int64& aEventID,
03497   const TPlcEventTypeID& aTypeID,
03498   const __int64* aForeignKey);
03499
03500 /// Create action 'Event stopped'.
03501 /// Event has stopped.
03502 /// @param  [in]  aEventID     Instance ID of the event.
03503 /// @param  [in]  aTypeID      Type of the event.
03504 /// @return handle to action if the function succeeds or \c NULL if it fails.
03505 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventStopped(
03506   const __int64& aEventID,
03507   const TPlcEventTypeID& aTypeID);
03508
03509 /// Create action 'Export finished'.
03510 /// Export finished.
03511 /// @param  [in]  aExportID    Export GUID.
03512 /// @param  [in]  aSuccess     Success.
03513 /// @return handle to action if the function succeeds or \c NULL if it fails.
03514 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateExportFinished(
03515   const GUID& aExportID,
03516   const PlcExportSuccess aSuccess);
03517
03518 /// Create action 'Export progress'.
03519 /// Export progress.
03520 /// @param  [in]  aExportID    Export GUID.
03521 /// @param  [in]  aProgress    Progress.
03522 /// @return handle to action if the function succeeds or \c NULL if it fails.
03523 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateExportProgress(
03524   const GUID& aExportID,
03525   const __int32 aProgress);
03526
03527 /// Create action 'Fast speed off'.
03528 /// Turn camera fast speed off.
03529 /// @param  [in]  aCamera      PTZ head.
03530 /// @return handle to action if the function succeeds or \c NULL if it fails.
03531 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateFastSpeedOff(
03532   const TPlcMediaChannelID& aCamera);
03533
03534 /// Create action 'Fast speed on'.
03535 /// Turn camera fast speed on.
03536 /// @param  [in]  aCamera      PTZ head.
03537 /// @return handle to action if the function succeeds or \c NULL if it fails.
03538 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateFastSpeedOn(
03539   const TPlcMediaChannelID& aCamera);
03540
03541 /// Create action 'Filling pump status'.
03542 /// Filling pump status.
03543 /// @param  [in]  aTerminalName Terminal name.
03544 /// @param  [in]  aTimeStamp   Time stamp.
03545 /// @param  [in]  aPumpNo      Pump no.
03546 /// @param  [in]  aStatus      Status.
03547 /// @param  [in]  aAmount      Amount.
03548 /// @param  [in]  aPrice       Price.
03549 /// @param  [in]  aDetails     Details.
03550 /// @return handle to action if the function succeeds or \c NULL if it fails.
03551 ///
03552 /// @attention Following parameters are optional:  aAmount. aPrice. aDetails. \par
03553 ///            You can provide \c NULL pointer if you not use these fields.
03554 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateFillingPumpStatus(
03555   const wchar_t* aTerminalName,
03556   const TGLibDateTime& aTimeStamp,
03557   const __int32 aPumpNo,
03558   const PlcPumpStatus aStatus,
03559   const double* aAmount,
03560   const double* aPrice,
03561   const wchar_t* aDetails);
03562
03563 /// Create action 'Focus far'.
03564 /// Focus camera far.
03565 /// @param  [in]  aCamera      PTZ head.
03566 /// @param  [in]  aSpeed       Focus speed.
03567 /// @return handle to action if the function succeeds or \c NULL if it fails.
03568 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateFocusFar(
03569   const TPlcMediaChannelID& aCamera,
03570   const __int32 aSpeed);
03571
03572 /// Create action 'Focus near'.
03573 /// Focus camera near.
03574 /// @param  [in]  aCamera      PTZ head.
03575 /// @param  [in]  aSpeed       Focus speed.
03576 /// @return handle to action if the function succeeds or \c NULL if it fails.
03577 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateFocusNear(
03578   const TPlcMediaChannelID& aCamera,
03579   const __int32 aSpeed);
03580
03581 /// Create action 'Focus stop'.
03582 /// Stop camera focus.
03583 /// @param  [in]  aCamera      PTZ head.
03584 /// @return handle to action if the function succeeds or \c NULL if it fails.
03585 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateFocusStop(
03586   const TPlcMediaChannelID& aCamera);
03587
03588 /// Create action 'FRC notification'.
03589 /// FRC notification.
03590 /// @param  [in]  aNotification Notification reason.
03591 /// @param  [in]  aParam       Additional parameter.
03592 /// @param  [in]  aDescription Optional notification text.
03593 /// @param  [in]  aXMLInfo     Optional additional info (usually as XML string).
03594 /// @return handle to action if the function succeeds or \c NULL if it fails.
03595 ///
03596 /// @attention Following parameters are optional:  aParam. aDescription. aXMLInfo. \par
03597 ///            You can provide \c NULL pointer if you not use these fields.
03598 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateFRCNotification(
03599   const PlcFRCNotification aNotification,
03600   const __int32* aParam,
03601   const wchar_t* aDescription,
03602   const char* aXMLInfo);
03603
03604 /// Create action 'GEMOS alarm'.
03605 /// GEMOS alarm notification.
03606 /// @param  [in]  aGEMOSkey    GEMOS alarm key.
03607 /// @param  [in]  aGEMOSint    GEMOS alarm integer parameter.
03608 /// @param  [in]  aGEMOSstr    GEMOS alarm string parameter.
03609 /// @return handle to action if the function succeeds or \c NULL if it fails.
03610 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGEMOSalarm(
03611   const __int64& aGEMOSkey,
03612   const __int32 aGEMOSint,
03613   const wchar_t* aGEMOSstr);
03614
03615 /// Create action 'GSCS vehicle access denied'.
03616 /// GSCS vehicle access denied.
03617 /// @param  [in]  aSequenceID  The sequence ID.
03618 /// @param  [in]  aPlateNo     Recognized plate no.
03619 /// @param  [in]  aTimeStamp   Time stamp.
03620 /// @param  [in]  aCompanyCategory Company category.
03621 /// @param  [in]  aCompanyName Company name.
03622 /// @param  [in]  aReason      Reason.
03623 /// @param  [in]  aTrafficLane Traffic lane.
03624 /// @param  [in]  aChannel     Channel.
03625 /// @param  [in]  aDirection   Direction.
03626 /// @return handle to action if the function succeeds or \c NULL if it fails.
03627 ///
03628 /// @attention Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
03629 ///            You can provide \c NULL pointer if you not use these fields.
03630 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGSCSVehicleAccessDenied(
03631   const __int32 aSequenceID,
03632   const wchar_t* aPlateNo,
03633   const TGLibDateTime& aTimeStamp,
03634   const wchar_t* aCompanyCategory,
03635   const wchar_t* aCompanyName,
03636   const wchar_t* aReason,
03637   const wchar_t* aTrafficLane,
03638   const TPlcMediaChannelID* aChannel,
03639   const TrafficDirection* aDirection);
03640
03641 /// Create action 'GSCS vehicle access expired'.
03642 /// GSCS vehicle access expired.
03643 /// @param  [in]  aSequenceID  The sequence ID.
03644 /// @param  [in]  aPlateNo     Recognized plate no.
03645 /// @param  [in]  aTimeStamp   Time stamp.
03646 /// @param  [in]  aExpiringTime Expiring time.
03647 /// @param  [in]  aCompanyCategory Company category.
03648 /// @param  [in]  aCompanyName Company name.
03649 /// @param  [in]  aReason      Reason.
03650 /// @param  [in]  aTrafficLane Traffic lane.
03651 /// @param  [in]  aChannel     Channel.
03652 /// @param  [in]  aDirection   Direction.
03653 /// @return handle to action if the function succeeds or \c NULL if it fails.
03654 ///
03655 /// @attention Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
03656 ///            You can provide \c NULL pointer if you not use these fields.
03657 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGSCSVehicleAccessExpired(
03658   const __int32 aSequenceID,
03659   const wchar_t* aPlateNo,
03660   const TGLibDateTime& aTimeStamp,
03661   const TGLibDateTime& aExpiringTime,
03662   const wchar_t* aCompanyCategory,
03663   const wchar_t* aCompanyName,
03664   const wchar_t* aReason,
03665   const wchar_t* aTrafficLane,
03666   const TPlcMediaChannelID* aChannel,
03667   const TrafficDirection* aDirection);
03668
03669 /// Create action 'GSCS vehicle access granted'.
03670 /// GSCS vehicle access granted.
03671 /// @param  [in]  aSequenceID  The sequence ID.
03672 /// @param  [in]  aPlateNo     Recognized plate no.
03673 /// @param  [in]  aTimeStamp   Time stamp.
03674 /// @param  [in]  aCompanyCategory Company category.
03675 /// @param  [in]  aCompanyName Company name.
03676 /// @param  [in]  aReason      Reason.
03677 /// @param  [in]  aTrafficLane Traffic lane.
03678 /// @param  [in]  aChannel     Channel.
03679 /// @param  [in]  aDirection   Direction.
03680 /// @return handle to action if the function succeeds or \c NULL if it fails.
03681 ///
03682 /// @attention Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
03683 ///            You can provide \c NULL pointer if you not use these fields.
03684 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGSCSVehicleAccessGranted(
03685   const __int32 aSequenceID,
03686   const wchar_t* aPlateNo,
03687   const TGLibDateTime& aTimeStamp,
03688   const wchar_t* aCompanyCategory,
03689   const wchar_t* aCompanyName,
03690   const wchar_t* aReason,
03691   const wchar_t* aTrafficLane,
03692   const TPlcMediaChannelID* aChannel,
03693   const TrafficDirection* aDirection);
03694
03695 /// Create action 'GSCS vehicle access pending'.
03696 /// GSCS vehicle access pending.
03697 /// @param  [in]  aSequenceID  The sequence ID.
03698 /// @param  [in]  aPlateNo     Recognized plate no.
03699 /// @param  [in]  aTimeStamp   Time stamp.
03700 /// @param  [in]  aCompanyCategory Company category.
03701 /// @param  [in]  aCompanyName Company name.
03702 /// @param  [in]  aReason      Reason.
03703 /// @param  [in]  aTrafficLane Traffic lane.
03704 /// @param  [in]  aChannel     Channel.
03705 /// @param  [in]  aDirection   Direction.
03706 /// @return handle to action if the function succeeds or \c NULL if it fails.
03707 ///
03708 /// @attention Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
03709 ///            You can provide \c NULL pointer if you not use these fields.
03710 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGSCSVehicleAccessPending(
03711   const __int32 aSequenceID,
03712   const wchar_t* aPlateNo,
03713   const TGLibDateTime& aTimeStamp,
03714   const wchar_t* aCompanyCategory,
03715   const wchar_t* aCompanyName,
03716   const wchar_t* aReason,
03717   const wchar_t* aTrafficLane,
03718   const TPlcMediaChannelID* aChannel,
03719   const TrafficDirection* aDirection);
03720
03721 /// Create action 'G-Tect analytics live check'.
03722 /// This action will be fired periodically to ensure that analytics client is still running.
03723 /// @return handle to action if the function succeeds or \c NULL if it fails.
03724 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGTectAnalyticsLiveCheck();
03725
03726 /// Create action 'G-Tect/Dual sensor alarm'.
03727 /// This action will be fired when G-Tect/Dual sensor detects an alarm.
03728 /// @param  [in]  aChannel     Channel.
03729 /// @param  [in]  aSterileZoneNumber Sterile Zone Number
03730 /// @param  [in]  aVirtualFenceNumber Virtual Fence Number.
03731 /// @param  [in]  aVMDGroup    VMD alarm group.
03732 /// @param  [in]  aVMDZone     VMD zone nr.
03733 /// @param  [in]  aVMDCycle    VMD measure cycle.
03734 /// @param  [in]  aAlarmArea   Alarm area.
03735 /// @return handle to action if the function succeeds or \c NULL if it fails.
03736 ///
03737 /// @attention Following parameters are optional:  aSterileZoneNumber. aVirtualFenceNumber. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. \par
03738 ///            You can provide \c NULL pointer if you not use these fields.
03739 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGTectDualSensorAlarm(
03740   const TPlcMediaChannelID& aChannel,
03741   const __int32* aSterileZoneNumber,
03742   const __int32* aVirtualFenceNumber,
03743   const VMDGroup* aVMDGroup,
03744   const __int32* aVMDZone,
03745   const VMDCycle* aVMDCycle,
03746   const TPlcRect* aAlarmArea);
03747
03748 /// Create action 'G-Tect/Dual sensor alarm finished'.
03749 /// This action will be fired when the alarm is finished.
03750 /// @param  [in]  aChannel     Channel.
03751 /// @return handle to action if the function succeeds or \c NULL if it fails.
03752 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGTectDualSensorAlarmFinished(
03753   const TPlcMediaChannelID& aChannel);
03754
03755 /// Create action 'G-Tect scene alarm'.
03756 /// This action will be fired when G-Tect Video content analysis detects a scene alarm.
03757 /// @param  [in]  aChannel     Channel.
03758 /// @param  [in]  aAlarmReason Alarm reason.
03759 /// @return handle to action if the function succeeds or \c NULL if it fails.
03760 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGTectSceneAlarm(
03761   const TPlcMediaChannelID& aChannel,
03762   const GTectSceneAlarmReason aAlarmReason);
03763
03764 /// Create action 'G-Tect scene alarm finished'.
03765 /// This action will be fired when G-Tect Video content analysis scene alarm is finished.
03766 /// @param  [in]  aChannel     Channel.
03767 /// @param  [in]  aAlarmReason Alarm reason.
03768 /// @return handle to action if the function succeeds or \c NULL if it fails.
03769 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGTectSceneAlarmFinished(
03770   const TPlcMediaChannelID& aChannel,
03771   const GTectSceneAlarmReason aAlarmReason);
03772
03773 /// Create action 'G-Tect/VMX alarm'.
03774 /// This action will be fired when G-Tect/VMX Video content analysis detects an alarm.
03775 /// @param  [in]  aChannel     Channel.
03776 /// @param  [in]  aSterileZoneNumber Sterile Zone Number
03777 /// @param  [in]  aVirtualFenceNumber Virtual Fence Number.
03778 /// @param  [in]  aAlarmGroup  Used to group different Zones or fences to the same level.
03779 /// @param  [in]  aTrackID     Internal Track ID.
03780 /// @param  [in]  aAlarmArea   Alarm area.
03781 /// @return handle to action if the function succeeds or \c NULL if it fails.
03782 ///
03783 /// @attention Following parameters are optional:  aSterileZoneNumber. aVirtualFenceNumber. aAlarmGroup. aTrackID. aAlarmArea. \par
03784 ///            You can provide \c NULL pointer if you not use these fields.
03785 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGTectVMXAlarm(
03786   const TPlcMediaChannelID& aChannel,
03787   const __int32* aSterileZoneNumber,
03788   const __int32* aVirtualFenceNumber,
03789   const __int32* aAlarmGroup,
03790   const __int32* aTrackID,
03791   const TPlcRect* aAlarmArea);
03792
03793 /// Create action 'G-Tect/VMX alarm finished'.
03794 /// This action will be fired when the alarm is finished.
03795 /// @param  [in]  aChannel     Channel.
03796 /// @return handle to action if the function succeeds or \c NULL if it fails.
03797 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateGTectVMXAlarmFinished(
03798   const TPlcMediaChannelID& aChannel);
03799
03800 /// Create action 'IAS settings changed'.
03801 /// IAS settings changed.
03802 /// @param  [in]  aChannel     Channel.
03803 /// @param  [in]  aSensorType  Sensor type.
03804 /// @return handle to action if the function succeeds or \c NULL if it fails.
03805 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIASSettingsChanged(
03806   const TPlcMediaChannelID& aChannel,
03807   const VideoSensorKind aSensorType);
03808
03809 /// Create action 'Image export notification'.
03810 /// Notification on export or print of channel images.
03811 /// @param  [in]  aUser        Name of the user connected to the system.
03812 /// @param  [in]  aDestination Destination.
03813 /// @param  [in]  aDestinationType Destination type.
03814 /// @param  [in]  aTimeStamp   Time stamp.
03815 /// @param  [in]  aTimeEnd     End time.
03816 /// @param  [in]  aChannels    Channels.
03817 /// @param  [in]  aClientHost  Host from where the connection is done.
03818 /// @param  [in]  aClientType  Client type.
03819 /// @param  [in]  aClientAccount User account from where the connection is done.
03820 /// @return handle to action if the function succeeds or \c NULL if it fails.
03821 ///
03822 /// @attention Following parameters are optional:  aTimeEnd. aClientHost. aClientType. aClientAccount. \par
03823 ///            You can provide \c NULL pointer if you not use these fields.
03824 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateImageExportNotification(
03825   const wchar_t* aUser,
03826   const wchar_t* aDestination,
03827   const PlcImageExportType aDestinationType,
03828   const TGLibDateTime& aTimeStamp,
03829   const TGLibDateTime* aTimeEnd,
03830   const wchar_t* aChannels,
03831   const wchar_t* aClientHost,
03832   const PlcClientType* aClientType,
03833   const wchar_t* aClientAccount);
03834
03835 /// Create action 'Imex capacity file auto deleted'.
03836 /// Imex capacity warning: file auto deleted.
03837 /// @param  [in]  aWarning     Warning.
03838 /// @param  [in]  aDestination Destination.
03839 /// @param  [in]  aTotalCapacity Total capacity.
03840 /// @param  [in]  aFreeCapacity Free capacity.
03841 /// @param  [in]  aAllocatedByImageFile Allocated by image file.
03842 /// @param  [in]  aPercentFree Percent free.
03843 /// @param  [in]  aPercentAllocated Percent allocated.
03844 /// @param  [in]  aPercentAllocatedByImageFile Percent allocated by image file.
03845 /// @param  [in]  aTotalFileSize Total file size.
03846 /// @param  [in]  aNumberOfFiles Number of files.
03847 /// @return handle to action if the function succeeds or \c NULL if it fails.
03848 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateImexCapacityFileAutoDeleted(
03849   const ABCapacityWarning aWarning,
03850   const TPlcResourceID& aDestination,
03851   const __int64& aTotalCapacity,
03852   const __int64& aFreeCapacity,
03853   const __int64& aAllocatedByImageFile,
03854   const __int32 aPercentFree,
03855   const __int32 aPercentAllocated,
03856   const __int32 aPercentAllocatedByImageFile,
03857   const __int64& aTotalFileSize,
03858   const __int32 aNumberOfFiles);
03859
03860 /// Create action 'Imex capacity out of disk space.'.
03861 /// Imex capacity warning: out of disk space.
03862 /// @param  [in]  aWarning     Warning.
03863 /// @param  [in]  aDestination Destination.
03864 /// @param  [in]  aTotalCapacity Total capacity.
03865 /// @param  [in]  aFreeCapacity Free capacity.
03866 /// @param  [in]  aAllocatedByImageFile Allocated by image file.
03867 /// @param  [in]  aPercentFree Percent free.
03868 /// @param  [in]  aPercentAllocated Percent allocated.
03869 /// @param  [in]  aPercentAllocatedByImageFile Percent allocated by image file.
03870 /// @return handle to action if the function succeeds or \c NULL if it fails.
03871 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateImexCapacityOutOfDiskSpace(
03872   const ABCapacityWarning aWarning,
03873   const TPlcResourceID& aDestination,
03874   const __int64& aTotalCapacity,
03875   const __int64& aFreeCapacity,
03876   const __int64& aAllocatedByImageFile,
03877   const __int32 aPercentFree,
03878   const __int32 aPercentAllocated,
03879   const __int32 aPercentAllocatedByImageFile);
03880
03881 /// Create action 'Imex capacity warning'.
03882 /// Imex capacity warning: capacity warning.
03883 /// @param  [in]  aWarning     Warning.
03884 /// @param  [in]  aDestination Destination.
03885 /// @param  [in]  aTotalCapacity Total capacity.
03886 /// @param  [in]  aFreeCapacity Free capacity.
03887 /// @param  [in]  aAllocatedByImageFile Allocated by image file.
03888 /// @param  [in]  aPercentFree Percent free.
03889 /// @param  [in]  aPercentAllocated Percent allocated.
03890 /// @param  [in]  aPercentAllocatedByImageFile Percent allocated by image file.
03891 /// @return handle to action if the function succeeds or \c NULL if it fails.
03892 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateImexCapacityWarning(
03893   const ABCapacityWarning aWarning,
03894   const TPlcResourceID& aDestination,
03895   const __int64& aTotalCapacity,
03896   const __int64& aFreeCapacity,
03897   const __int64& aAllocatedByImageFile,
03898   const __int32 aPercentFree,
03899   const __int32 aPercentAllocated,
03900   const __int32 aPercentAllocatedByImageFile);
03901
03902 /// Create action 'Imex export event image'.
03903 /// Imex export event image.
03904 /// @param  [in]  aEventID     Instance ID of the event.
03905 /// @param  [in]  aTypeID      Type of the event.
03906 /// @param  [in]  aDestination Destination.
03907 /// @param  [in]  aFilePath    File name.
03908 /// @return handle to action if the function succeeds or \c NULL if it fails.
03909 ///
03910 /// @attention Following parameters are optional:  aDestination. aFilePath. \par
03911 ///            You can provide \c NULL pointer if you not use these fields.
03912 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateImexExportEventImage(
03913   const __int64& aEventID,
03914   const TPlcEventTypeID& aTypeID,
03915   const TPlcResourceID* aDestination,
03916   const wchar_t* aFilePath);
03917
03918 /// Create action 'Imex export image from DB'.
03919 /// Imex export image from DB.
03920 /// @param  [in]  aChannel     Channel.
03921 /// @param  [in]  aDestination Destination.
03922 /// @param  [in]  aFilePath    File name.
03923 /// @param  [in]  aPictureTime Picture time.
03924 /// @return handle to action if the function succeeds or \c NULL if it fails.
03925 ///
03926 /// @attention Following parameters are optional:  aDestination. aFilePath. aPictureTime. \par
03927 ///            You can provide \c NULL pointer if you not use these fields.
03928 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateImexExportImageFromDB(
03929   const TPlcMediaChannelID& aChannel,
03930   const TPlcResourceID* aDestination,
03931   const wchar_t* aFilePath,
03932   const TGLibDateTime* aPictureTime);
03933
03934 /// Create action 'Imex export image from live stream'.
03935 /// Imex export image from live stream.
03936 /// @param  [in]  aChannel     Channel.
03937 /// @param  [in]  aDestination Destination.
03938 /// @param  [in]  aFilePath    File name.
03939 /// @return handle to action if the function succeeds or \c NULL if it fails.
03940 ///
03941 /// @attention Following parameters are optional:  aDestination. aFilePath. \par
03942 ///            You can provide \c NULL pointer if you not use these fields.
03943 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateImexExportImageFromLiveStream(
03944   const TPlcMediaChannelID& aChannel,
03945   const TPlcResourceID* aDestination,
03946   const wchar_t* aFilePath);
03947
03948 /// Create action 'Initialize remote export'.
03949 /// Initialize remote export.
03950 /// @param  [in]  aViewer      Global viewer or viewer client no.
03951 /// @param  [in]  aDevice      Pilot device GUID.
03952 /// @return handle to action if the function succeeds or \c NULL if it fails.
03953 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateInitializeRemoteExport(
03954   const TPlcMediaChannelID& aViewer,
03955   const GUID& aDevice);
03956
03957 /// Create action 'Interface raw answer'.
03958 /// Interface raw answer.
03959 /// @param  [in]  aInterfaceName Interface name.
03960 /// @param  [in]  aTimeStamp   Time stamp.
03961 /// @param  [in]  aData        Interface answer.
03962 /// @return handle to action if the function succeeds or \c NULL if it fails.
03963 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateInterfaceRawAnswer(
03964   const wchar_t* aInterfaceName,
03965   const TGLibDateTime& aTimeStamp,
03966   const wchar_t* aData);
03967
03968 /// Create action 'Interface raw data'.
03969 /// Interface raw data.
03970 /// @param  [in]  aInterfaceName Interface name.
03971 /// @param  [in]  aTimeStamp   Time stamp.
03972 /// @param  [in]  aData        Interface data.
03973 /// @return handle to action if the function succeeds or \c NULL if it fails.
03974 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateInterfaceRawData(
03975   const wchar_t* aInterfaceName,
03976   const TGLibDateTime& aTimeStamp,
03977   const wchar_t* aData);
03978
03979 /// Create action 'IOI43 reset mainboard'.
03980 /// Reset mainboard using IOI43a/ab USB Alarm-I/O.
03981 /// @return handle to action if the function succeeds or \c NULL if it fails.
03982 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIOI43ResetMainboard();
03983
03984 /// Create action 'IOI43 temperature notification'.
03985 /// Temperature notification from IOI43a/ab USB Alarm-I/O.
03986 /// @param  [in]  aID          ID of the IOI43 module (like IOI43-00).
03987 /// @param  [in]  aTemperature Temperature.
03988 /// @return handle to action if the function succeeds or \c NULL if it fails.
03989 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIOI43Temperature(
03990   const wchar_t* aID,
03991   const __int32 aTemperature);
03992
03993 /// Create action 'IOI43 watchdog activate'.
03994 /// Activate watchdog on IOI43a/ab USB Alarm-I/O.
03995 /// @return handle to action if the function succeeds or \c NULL if it fails.
03996 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIOI43WDActivate();
03997
03998 /// Create action 'IOI43 watchdog deactivate'.
03999 /// Deactivate watchdog on IOI43a/ab USB Alarm-I/O.
04000 /// @return handle to action if the function succeeds or \c NULL if it fails.
04001 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIOI43WDDeactivate();
04002
04003 /// Create action 'IOI43 watchdog trigger'.
04004 /// Trigger watchdog on IOI43a/ab USB Alarm-I/O.
04005 /// @return handle to action if the function succeeds or \c NULL if it fails.
04006 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIOI43WDTrigger();
04007
04008 /// Create action 'IP camera raw command'.
04009 /// This action sends a special command to the IP camera.
04010 /// @param  [in]  aURL         Complete command URL (like http://192.168.0.165:80/set?daynight=night).
04011 /// @param  [in]  aUser        User name to authenticate by the camera (optional).
04012 /// @param  [in]  aPassword    Password to authenticate by the camera (optional).
04013 /// @param  [in]  aPOST        POST parameters (optional, separate lines with \\r\\n).
04014 /// @return handle to action if the function succeeds or \c NULL if it fails.
04015 ///
04016 /// @attention Following parameters are optional:  aUser. aPassword. aPOST. \par
04017 ///            You can provide \c NULL pointer if you not use these fields.
04018 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIPCameraRawCommand(
04019   const wchar_t* aURL,
04020   const wchar_t* aUser,
04021   const wchar_t* aPassword,
04022   const wchar_t* aPOST);
04023
04024 /// Create action 'IP camera failover notification'.
04025 /// IP camera failover notification.
04026 /// @param  [in]  aPrimaryServer The name of the primary server.
04027 /// @param  [in]  aSecondaryServer The name of the secondary server.
04028 /// @param  [in]  aPrimaryChannel Primary channel.
04029 /// @param  [in]  aSecondaryChannel Secondary channel.
04030 /// @param  [in]  aCameraParameters Optional camera parameters.
04031 /// @return handle to action if the function succeeds or \c NULL if it fails.
04032 ///
04033 /// @attention Following parameters are optional:  aCameraParameters. \par
04034 ///            You can provide \c NULL pointer if you not use these fields.
04035 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIPCamFailoverNotification(
04036   const wchar_t* aPrimaryServer,
04037   const wchar_t* aSecondaryServer,
04038   const TPlcMediaChannelID& aPrimaryChannel,
04039   const TPlcMediaChannelID& aSecondaryChannel,
04040   const wchar_t* aCameraParameters);
04041
04042 /// Create action 'IP camera failover restore'.
04043 /// IP camera failover restore.
04044 /// @param  [in]  aPrimaryServer The name of the primary server.
04045 /// @param  [in]  aSecondaryServer The name of the secondary server.
04046 /// @param  [in]  aPrimaryChannel Primary channel.
04047 /// @param  [in]  aSecondaryChannel Secondary channel.
04048 /// @param  [in]  aCameraParameters Optional camera parameters.
04049 /// @return handle to action if the function succeeds or \c NULL if it fails.
04050 ///
04051 /// @attention Following parameters are optional:  aCameraParameters. \par
04052 ///            You can provide \c NULL pointer if you not use these fields.
04053 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIPCamFailoverRestore(
04054   const wchar_t* aPrimaryServer,
04055   const wchar_t* aSecondaryServer,
04056   const TPlcMediaChannelID& aPrimaryChannel,
04057   const TPlcMediaChannelID& aSecondaryChannel,
04058   const wchar_t* aCameraParameters);
04059
04060 /// Create action 'IP switch operation'.
04061 /// IP switch operation.
04062 /// @param  [in]  aOperation   Operation.
04063 /// @param  [in]  aPort        Port no, IP address, MAC address.
04064 /// @param  [in]  aParam       Optional parameter.
04065 /// @return handle to action if the function succeeds or \c NULL if it fails.
04066 ///
04067 /// @attention Following parameters are optional:  aParam. \par
04068 ///            You can provide \c NULL pointer if you not use these fields.
04069 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIPSwitchOperation(
04070   const IPSwitchOps aOperation,
04071   const wchar_t* aPort,
04072   const __int32* aParam);
04073
04074 /// Create action 'Iris close'.
04075 /// Close camera iris.
04076 /// @param  [in]  aCamera      PTZ head.
04077 /// @return handle to action if the function succeeds or \c NULL if it fails.
04078 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIrisClose(
04079   const TPlcMediaChannelID& aCamera);
04080
04081 /// Create action 'Iris open'.
04082 /// Open camera iris.
04083 /// @param  [in]  aCamera      PTZ head.
04084 /// @return handle to action if the function succeeds or \c NULL if it fails.
04085 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIrisOpen(
04086   const TPlcMediaChannelID& aCamera);
04087
04088 /// Create action 'Iris stop'.
04089 /// Stop camera iris.
04090 /// @param  [in]  aCamera      PTZ head.
04091 /// @return handle to action if the function succeeds or \c NULL if it fails.
04092 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateIrisStop(
04093   const TPlcMediaChannelID& aCamera);
04094
04095 /// Create action 'Key pressed'.
04096 /// This action is notified if one of the GEVISCOPE system keys is pressed.
04097 /// @param  [in]  aKey         System key.
04098 /// @return handle to action if the function succeeds or \c NULL if it fails.
04099 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateKeyPressed(
04100   const SystemKey aKey);
04101
04102 /// Create action 'Key released'.
04103 /// This action is notified if one of the GEVISCOPE system keys is released.
04104 /// @param  [in]  aKey         System key.
04105 /// @return handle to action if the function succeeds or \c NULL if it fails.
04106 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateKeyReleased(
04107   const SystemKey aKey);
04108
04109 /// Create action 'Kill all events'.
04110 /// Kill all active events.
04111 /// @return handle to action if the function succeeds or \c NULL if it fails.
04112 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateKillAllEvents();
04113
04114 /// Create action 'Kill event'.
04115 /// Kill event.
04116 /// @param  [in]  aTypeID      Type of the event.
04117 /// @return handle to action if the function succeeds or \c NULL if it fails.
04118 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateKillEvent(
04119   const TPlcEventTypeID& aTypeID);
04120
04121 /// Create action 'Kill event by instance'.
04122 /// Kill event by instance ID.
04123 /// @param  [in]  aEventID     Instance ID of the event.
04124 /// @return handle to action if the function succeeds or \c NULL if it fails.
04125 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateKillEventByID(
04126   const __int64& aEventID);
04127
04128 /// Create action 'Lenel access event'.
04129 /// Lenel OnGuard access event.
04130 /// @param  [in]  aID          The ID that uniquely identifies the type of this event.
04131 /// @param  [in]  aPanel       The name of the panel where this event originated.
04132 /// @param  [in]  aDevice      The name of the device where this event originated.
04133 /// @param  [in]  aSecondaryDevice The ID of the secondary device where this event originated.
04134 /// @param  [in]  aCardNumber  The badge ID for the card that was read, if available.
04135 /// @param  [in]  aAccessResult The level of access that was granted that resulted from reading the card.
04136 /// @param  [in]  aType        Event type i.e., duress, system, etc.
04137 /// @param  [in]  aSubType     Event sub-type i.e., granted, door forced open, etc.
04138 /// @param  [in]  aDescription A human readable, brief description of this event.
04139 /// @param  [in]  aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
04140 /// @param  [in]  aTimeStamp   Time stamp.
04141 /// @param  [in]  aAreaEnteredID The ID of the area that was entered, if any.
04142 /// @param  [in]  aAreaExitedID The ID of the area that was exited, if any.
04143 /// @param  [in]  aAssetID     The ID of the asset related to this event, if any.
04144 /// @param  [in]  aCardholderEntered Whether entry was made by the cardholder.
04145 /// @param  [in]  aDuress      Indicates whether this card access indicates an under duress/emergency state.
04146 /// @param  [in]  aElevatorFloor The elevator floor on which the access event was generated, if any.
04147 /// @param  [in]  aFacilityCode The facility code for the card that was read, if available.
04148 /// @param  [in]  aIsReadableCard Whether the card could be read.
04149 /// @param  [in]  aIssueCode   The issue code for the card that was read, if available.
04150 /// @param  [in]  aCommServerHostName Host name of the Communication server through which the event arrived.
04151 /// @param  [in]  aEventText   Text associated with event
04152 /// @return handle to action if the function succeeds or \c NULL if it fails.
04153 ///
04154 /// @attention Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aCardNumber. aAccessResult. aType. aSubType. aSerialNumber. aTimeStamp. aAreaEnteredID. aAreaExitedID. aAssetID. aCardholderEntered. aDuress. aElevatorFloor. aFacilityCode. aIsReadableCard. aIssueCode. aCommServerHostName. aEventText. \par
04155 ///            You can provide \c NULL pointer if you not use these fields.
04156 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLenelAccessEvent(
04157   const LenelEventID* aID,
04158   const wchar_t* aPanel,
04159   const wchar_t* aDevice,
04160   const __int32* aSecondaryDevice,
04161   const __int64* aCardNumber,
04162   const LenelAccessResult* aAccessResult,
04163   const LenelEventType* aType,
04164   const __int32* aSubType,
04165   const wchar_t* aDescription,
04166   const __int32* aSerialNumber,
04167   const TGLibDateTime* aTimeStamp,
04168   const __int32* aAreaEnteredID,
04169   const __int32* aAreaExitedID,
04170   const wchar_t* aAssetID,
04171   const bool* aCardholderEntered,
04172   const bool* aDuress,
04173   const __int32* aElevatorFloor,
04174   const __int32* aFacilityCode,
04175   const bool* aIsReadableCard,
04176   const __int32* aIssueCode,
04177   const wchar_t* aCommServerHostName,
04178   const wchar_t* aEventText);
04179
04180 /// Create action 'Lenel fire event'.
04181 /// Lenel OnGuard fire event.
04182 /// @param  [in]  aID          The ID that uniquely identifies the type of this event.
04183 /// @param  [in]  aPanel       The name of the panel where this event originated.
04184 /// @param  [in]  aDevice      The name of the device where this event originated.
04185 /// @param  [in]  aSecondaryDevice The ID of the secondary device where this event originated.
04186 /// @param  [in]  aTroubleCode A trouble code associated with the fire event.
04187 /// @param  [in]  aType        Event type i.e., duress, system, etc.
04188 /// @param  [in]  aSubType     Event sub-type i.e., granted, door forced open, etc.
04189 /// @param  [in]  aDescription A human readable, brief description of this event.
04190 /// @param  [in]  aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
04191 /// @param  [in]  aTimeStamp   Time stamp.
04192 /// @param  [in]  aCommServerHostName Host name of the Communication server through which the event arrived.
04193 /// @param  [in]  aEventText   Text associated with event
04194 /// @return handle to action if the function succeeds or \c NULL if it fails.
04195 ///
04196 /// @attention Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aTroubleCode. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText. \par
04197 ///            You can provide \c NULL pointer if you not use these fields.
04198 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLenelFireEvent(
04199   const LenelEventID* aID,
04200   const wchar_t* aPanel,
04201   const wchar_t* aDevice,
04202   const __int32* aSecondaryDevice,
04203   const __int32* aTroubleCode,
04204   const LenelEventType* aType,
04205   const __int32* aSubType,
04206   const wchar_t* aDescription,
04207   const __int32* aSerialNumber,
04208   const TGLibDateTime* aTimeStamp,
04209   const wchar_t* aCommServerHostName,
04210   const wchar_t* aEventText);
04211
04212 /// Create action 'Lenel intercom event'.
04213 /// Lenel OnGuard intercom event.
04214 /// @param  [in]  aID          The ID that uniquely identifies the type of this event.
04215 /// @param  [in]  aPanel       The name of the panel where this event originated.
04216 /// @param  [in]  aDevice      The name of the device where this event originated.
04217 /// @param  [in]  aSecondaryDevice The ID of the secondary device where this event originated.
04218 /// @param  [in]  aIntercomData Additional data for the intercom event that occurred.
04219 /// @param  [in]  aLineNumber  The line number involved in the intercom event.
04220 /// @param  [in]  aType        Event type i.e., duress, system, etc.
04221 /// @param  [in]  aSubType     Event sub-type i.e., granted, door forced open, etc.
04222 /// @param  [in]  aDescription A human readable, brief description of this event.
04223 /// @param  [in]  aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
04224 /// @param  [in]  aTimeStamp   Time stamp.
04225 /// @param  [in]  aCommServerHostName Host name of the Communication server through which the event arrived.
04226 /// @param  [in]  aEventText   Text associated with event
04227 /// @return handle to action if the function succeeds or \c NULL if it fails.
04228 ///
04229 /// @attention Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aIntercomData. aLineNumber. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText. \par
04230 ///            You can provide \c NULL pointer if you not use these fields.
04231 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLenelIntercomEvent(
04232   const LenelEventID* aID,
04233   const wchar_t* aPanel,
04234   const wchar_t* aDevice,
04235   const __int32* aSecondaryDevice,
04236   const __int32* aIntercomData,
04237   const __int32* aLineNumber,
04238   const LenelEventType* aType,
04239   const __int32* aSubType,
04240   const wchar_t* aDescription,
04241   const __int32* aSerialNumber,
04242   const TGLibDateTime* aTimeStamp,
04243   const wchar_t* aCommServerHostName,
04244   const wchar_t* aEventText);
04245
04246 /// Create action 'Lenel raw data'.
04247 /// Lenel OnGuard raw data.
04248 /// @param  [in]  aTimeStamp   Time stamp.
04249 /// @param  [in]  aLenelData   Lenel OnGuard data.
04250 /// @return handle to action if the function succeeds or \c NULL if it fails.
04251 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLenelRawData(
04252   const TGLibDateTime& aTimeStamp,
04253   const wchar_t* aLenelData);
04254
04255 /// Create action 'Lenel refresh names'.
04256 /// Lenel OnGuard refresh names.
04257 /// @return handle to action if the function succeeds or \c NULL if it fails.
04258 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLenelRefreshNames();
04259
04260 /// Create action 'Lenel security event'.
04261 /// Lenel OnGuard security event.
04262 /// @param  [in]  aID          The ID that uniquely identifies the type of this event.
04263 /// @param  [in]  aPanel       The name of the panel where this event originated.
04264 /// @param  [in]  aDevice      The name of the device where this event originated.
04265 /// @param  [in]  aSecondaryDevice The ID of the secondary device where this event originated.
04266 /// @param  [in]  aType        Event type i.e., duress, system, etc.
04267 /// @param  [in]  aSubType     Event sub-type i.e., granted, door forced open, etc.
04268 /// @param  [in]  aDescription A human readable, brief description of this event.
04269 /// @param  [in]  aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
04270 /// @param  [in]  aTimeStamp   Time stamp.
04271 /// @param  [in]  aCommServerHostName Host name of the Communication server through which the event arrived.
04272 /// @param  [in]  aEventText   Text associated with event
04273 /// @return handle to action if the function succeeds or \c NULL if it fails.
04274 ///
04275 /// @attention Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText. \par
04276 ///            You can provide \c NULL pointer if you not use these fields.
04277 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLenelSecurityEvent(
04278   const LenelEventID* aID,
04279   const wchar_t* aPanel,
04280   const wchar_t* aDevice,
04281   const __int32* aSecondaryDevice,
04282   const LenelEventType* aType,
04283   const __int32* aSubType,
04284   const wchar_t* aDescription,
04285   const __int32* aSerialNumber,
04286   const TGLibDateTime* aTimeStamp,
04287   const wchar_t* aCommServerHostName,
04288   const wchar_t* aEventText);
04289
04290 /// Create action 'Lenel video event'.
04291 /// Lenel OnGuard video event.
04292 /// @param  [in]  aID          The ID that uniquely identifies the type of this event.
04293 /// @param  [in]  aPanel       The name of the panel where this event originated.
04294 /// @param  [in]  aDevice      The name of the device where this event originated.
04295 /// @param  [in]  aSecondaryDevice The ID of the secondary device where this event originated.
04296 /// @param  [in]  aChannel     The physical channel the camera is connected to that is creating this event.
04297 /// @param  [in]  aType        Event type i.e., duress, system, etc.
04298 /// @param  [in]  aSubType     Event sub-type i.e., granted, door forced open, etc.
04299 /// @param  [in]  aDescription A human readable, brief description of this event.
04300 /// @param  [in]  aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
04301 /// @param  [in]  aTimeStamp   Time stamp.
04302 /// @param  [in]  aStartTime   The time the video event started
04303 /// @param  [in]  aEndTime     The time the video event ended.
04304 /// @param  [in]  aCommServerHostName Host name of the Communication server through which the event arrived.
04305 /// @param  [in]  aEventText   Text associated with event
04306 /// @return handle to action if the function succeeds or \c NULL if it fails.
04307 ///
04308 /// @attention Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aChannel. aType. aSubType. aSerialNumber. aTimeStamp. aStartTime. aEndTime. aCommServerHostName. aEventText. \par
04309 ///            You can provide \c NULL pointer if you not use these fields.
04310 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLenelVideoEvent(
04311   const LenelEventID* aID,
04312   const wchar_t* aPanel,
04313   const wchar_t* aDevice,
04314   const __int32* aSecondaryDevice,
04315   const __int32* aChannel,
04316   const LenelEventType* aType,
04317   const __int32* aSubType,
04318   const wchar_t* aDescription,
04319   const __int32* aSerialNumber,
04320   const TGLibDateTime* aTimeStamp,
04321   const TGLibDateTime* aStartTime,
04322   const TGLibDateTime* aEndTime,
04323   const wchar_t* aCommServerHostName,
04324   const wchar_t* aEventText);
04325
04326 /// Create action 'Live check'.
04327 /// This action will be fired every 10 seconds and is intended for use as live check.
04328 /// @param  [in]  aCounter     This is the number of already fired live check actions.
04329 /// @param  [in]  aDate        Current server time.
04330 /// @return handle to action if the function succeeds or \c NULL if it fails.
04331 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLiveCheck(
04332   const __int64& aCounter,
04333   const TGLibDateTime& aDate);
04334
04335 /// Create action 'Log barcode data'.
04336 /// Logistic barcode data.
04337 /// @param  [in]  aBarcode     Barcode.
04338 /// @param  [in]  aHash        Hash value.
04339 /// @param  [in]  aScanner     Scanner name or IP address.
04340 /// @param  [in]  aAreaID      Area number.
04341 /// @param  [in]  aAreaName    Area name.
04342 /// @param  [in]  aChannel     Channel.
04343 /// @param  [in]  aTimeStamp   Time stamp.
04344 /// @param  [in]  aOrder       Order number.
04345 /// @param  [in]  aShipment    Shipment number.
04346 /// @param  [in]  aItem        Item number.
04347 /// @return handle to action if the function succeeds or \c NULL if it fails.
04348 ///
04349 /// @attention Following parameters are optional:  aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aOrder. aShipment. aItem. \par
04350 ///            You can provide \c NULL pointer if you not use these fields.
04351 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLogBarcodeData(
04352   const wchar_t* aBarcode,
04353   const __int64* aHash,
04354   const wchar_t* aScanner,
04355   const __int64* aAreaID,
04356   const wchar_t* aAreaName,
04357   const TPlcMediaChannelID* aChannel,
04358   const TGLibDateTime* aTimeStamp,
04359   const wchar_t* aOrder,
04360   const wchar_t* aShipment,
04361   const wchar_t* aItem);
04362
04363 /// Create action 'Log barcode data LPS'.
04364 /// Logistic barcode and LPS data.
04365 /// @param  [in]  aBarcode     Barcode.
04366 /// @param  [in]  aHash        Hash value.
04367 /// @param  [in]  aScanner     Scanner name or IP address.
04368 /// @param  [in]  aAreaID      Area number.
04369 /// @param  [in]  aAreaName    Area name.
04370 /// @param  [in]  aChannel     Channel.
04371 /// @param  [in]  aTimeStamp   Time stamp.
04372 /// @param  [in]  aX           X coordinate.
04373 /// @param  [in]  aY           Y coordinate.
04374 /// @param  [in]  aZ           Z coordinate.
04375 /// @param  [in]  aLpsTagID    LPS tag ID.
04376 /// @param  [in]  aLpsStatus   LPS status.
04377 /// @param  [in]  aLpsCellID   LPS cell ID.
04378 /// @param  [in]  aLpsAreaID   LPS area ID.
04379 /// @param  [in]  aUserParam   User param.
04380 /// @param  [in]  aOrder       Order number.
04381 /// @param  [in]  aShipment    Shipment number.
04382 /// @param  [in]  aItem        Item number.
04383 /// @return handle to action if the function succeeds or \c NULL if it fails.
04384 ///
04385 /// @attention Following parameters are optional:  aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aX. aY. aZ. aLpsTagID. aLpsStatus. aLpsCellID. aLpsAreaID. aUserParam. aOrder. aShipment. aItem. \par
04386 ///            You can provide \c NULL pointer if you not use these fields.
04387 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLogBarcodeDataLPS(
04388   const wchar_t* aBarcode,
04389   const __int64* aHash,
04390   const wchar_t* aScanner,
04391   const __int64* aAreaID,
04392   const wchar_t* aAreaName,
04393   const TPlcMediaChannelID* aChannel,
04394   const TGLibDateTime* aTimeStamp,
04395   const double* aX,
04396   const double* aY,
04397   const double* aZ,
04398   const __int32* aLpsTagID,
04399   const PlcLpsStatus* aLpsStatus,
04400   const __int32* aLpsCellID,
04401   const __int32* aLpsAreaID,
04402   const __int32* aUserParam,
04403   const wchar_t* aOrder,
04404   const wchar_t* aShipment,
04405   const wchar_t* aItem);
04406
04407 /// Create action 'Log NPR recognition'.
04408 /// Log NPR recognition.
04409 /// @param  [in]  aPlateNo     Recognized plate no.
04410 /// @param  [in]  aHash        Hash value.
04411 /// @param  [in]  aCountry     Country.
04412 /// @param  [in]  aChannel     Channel.
04413 /// @param  [in]  aTimeStamp   Time stamp.
04414 /// @param  [in]  aRestriction Restriction of recognized number.
04415 /// @param  [in]  aCategory    Category of recognized number.
04416 /// @return handle to action if the function succeeds or \c NULL if it fails.
04417 ///
04418 /// @attention Following parameters are optional:  aHash. aCountry. aChannel. aTimeStamp. aRestriction. aCategory. \par
04419 ///            You can provide \c NULL pointer if you not use these fields.
04420 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLogNPRRecognition(
04421   const wchar_t* aPlateNo,
04422   const __int64* aHash,
04423   const wchar_t* aCountry,
04424   const TPlcMediaChannelID* aChannel,
04425   const TGLibDateTime* aTimeStamp,
04426   const PlcNPRRestriction* aRestriction,
04427   const wchar_t* aCategory);
04428
04429 /// Create action 'LPS position data'.
04430 /// LPS position data.
04431 /// @param  [in]  aTagID       Tag ID.
04432 /// @param  [in]  aScannerID   Scanner ID or IP address.
04433 /// @param  [in]  aX           X coordinate of cartesian coordinates.
04434 /// @param  [in]  aY           Y coordinate of cartesian coordinates.
04435 /// @param  [in]  aZ           Z coordinate of cartesian coordinates.
04436 /// @param  [in]  aLatitude    Latitude of geographic coordinates.
04437 /// @param  [in]  aLongitude   Longitude of geographic coordinates.
04438 /// @param  [in]  aAreaID      Area ID.
04439 /// @param  [in]  aCellID      Cell ID.
04440 /// @param  [in]  aStatus      Status.
04441 /// @param  [in]  aTimeStamp   Time stamp.
04442 /// @param  [in]  aData        Data.
04443 /// @param  [in]  aAreaName    Area Name.
04444 /// @return handle to action if the function succeeds or \c NULL if it fails.
04445 ///
04446 /// @attention Following parameters are optional:  aScannerID. aZ. aLatitude. aLongitude. aCellID. aTimeStamp. aData. aAreaName. \par
04447 ///            You can provide \c NULL pointer if you not use these fields.
04448 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLPSPositionData(
04449   const __int32 aTagID,
04450   const wchar_t* aScannerID,
04451   const __int64& aX,
04452   const __int64& aY,
04453   const __int64* aZ,
04454   const double* aLatitude,
04455   const double* aLongitude,
04456   const __int32 aAreaID,
04457   const __int32* aCellID,
04458   const PlcLpsStatus aStatus,
04459   const TGLibDateTime* aTimeStamp,
04460   const wchar_t* aData,
04461   const wchar_t* aAreaName);
04462
04463 /// Create action 'LPS query position'.
04464 /// Send position query for a Tag to LPS server.
04465 /// @param  [in]  aTagID       Tag ID.
04466 /// @param  [in]  aScannerID   Scanner ID or IP address.
04467 /// @param  [in]  aData        Data.
04468 /// @return handle to action if the function succeeds or \c NULL if it fails.
04469 ///
04470 /// @attention Following parameters are optional:  aScannerID. aData. \par
04471 ///            You can provide \c NULL pointer if you not use these fields.
04472 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateLPSQueryPosition(
04473   const __int32 aTagID,
04474   const wchar_t* aScannerID,
04475   const wchar_t* aData);
04476
04477 /// Create action 'Make CPA reference image'.
04478 /// Make CPA reference image.
04479 /// @param  [in]  aChannel     Channel.
04480 /// @return handle to action if the function succeeds or \c NULL if it fails.
04481 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateMakeCPAReferenceImage(
04482   const TPlcMediaChannelID& aChannel);
04483
04484 /// Create action 'Media channel setup'.
04485 /// Media channel setup info.
04486 /// @param  [in]  aChannel     Channel.
04487 /// @param  [in]  aTimeStamp   Time stamp.
04488 /// @param  [in]  aParameter   Parameter.
04489 /// @return handle to action if the function succeeds or \c NULL if it fails.
04490 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateMediaChannelSetupInfo(
04491   const TPlcMediaChannelID& aChannel,
04492   const TGLibDateTime& aTimeStamp,
04493   const wchar_t* aParameter);
04494
04495 /// Create action 'Move to absolute position'.
04496 /// Move camera to absolute position.
04497 /// @param  [in]  aCamera      PTZ head.
04498 /// @param  [in]  aAlpha       Alpha angle (-180°/+180°).
04499 /// @param  [in]  aBeta        Beta angle (-90°/+90°).
04500 /// @param  [in]  aSpeedAlpha  Speed in alpha direction (0/100 %).
04501 /// @param  [in]  aSpeedBeta   Speed in beta direction (0/100 %).
04502 /// @return handle to action if the function succeeds or \c NULL if it fails.
04503 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateMoveToAbsolutePosition(
04504   const TPlcMediaChannelID& aCamera,
04505   const double& aAlpha,
04506   const double& aBeta,
04507   const double& aSpeedAlpha,
04508   const double& aSpeedBeta);
04509
04510 /// Create action 'Move by speed'.
04511 /// Move camera by speed.
04512 /// @param  [in]  aCamera      PTZ head.
04513 /// @param  [in]  aSpeedAlpha  Speed in alpha (pan) direction (0/100 %).
04514 /// @param  [in]  aSpeedBeta   Speed in beta (tilt) direction (0/100 %).
04515 /// @return handle to action if the function succeeds or \c NULL if it fails.
04516 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateMoveToBySpeed(
04517   const TPlcMediaChannelID& aCamera,
04518   const double& aSpeedAlpha,
04519   const double& aSpeedBeta);
04520
04521 /// Create action 'Move to relative position'.
04522 /// Move camera to relative position.
04523 /// @param  [in]  aCamera      PTZ head.
04524 /// @param  [in]  aAlpha       Alpha angle (-180°/+180°).
04525 /// @param  [in]  aBeta        Beta angle (-90°/+90°).
04526 /// @param  [in]  aSpeedAlpha  Speed in alpha direction (0/100 %).
04527 /// @param  [in]  aSpeedBeta   Speed in beta direction (0/100 %).
04528 /// @return handle to action if the function succeeds or \c NULL if it fails.
04529 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateMoveToRelativePosition(
04530   const TPlcMediaChannelID& aCamera,
04531   const double& aAlpha,
04532   const double& aBeta,
04533   const double& aSpeedAlpha,
04534   const double& aSpeedBeta);
04535
04536 /// Create action 'NPR raw data'.
04537 /// NPR raw data.
04538 /// @param  [in]  aPlateNo     Recognized plate no.
04539 /// @param  [in]  aCountry     Country.
04540 /// @param  [in]  aChannel     Channel.
04541 /// @param  [in]  aTimeStamp   Time stamp.
04542 /// @param  [in]  aZoneRect    Zone rectangle.
04543 /// @param  [in]  aWeight      Weight of recognition.
04544 /// @param  [in]  aZoneState   Zone state.
04545 /// @param  [in]  aZonePlace   Zone status.
04546 /// @param  [in]  aSpeed       Speed in km/h
04547 /// @param  [in]  aDirection   Direction of the motion.
04548 /// @param  [in]  aZoneIndex   Zone index.
04549 /// @param  [in]  aCurBest     Current recognition is best.
04550 /// @param  [in]  aPlateWidth  Plate width.
04551 /// @param  [in]  aPlateHeight Plate height.
04552 /// @param  [in]  aPlateAngle  Plate angle.
04553 /// @param  [in]  aSymHeight   Symbol height.
04554 /// @param  [in]  aType        Number type.
04555 /// @return handle to action if the function succeeds or \c NULL if it fails.
04556 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateNPRRawData(
04557   const wchar_t* aPlateNo,
04558   const wchar_t* aCountry,
04559   const TPlcMediaChannelID& aChannel,
04560   const TGLibDateTime& aTimeStamp,
04561   const TPlcRect& aZoneRect,
04562   const __int32 aWeight,
04563   const __int32 aZoneState,
04564   const __int32 aZonePlace,
04565   const __int32 aSpeed,
04566   const __int32 aDirection,
04567   const __int32 aZoneIndex,
04568   const bool aCurBest,
04569   const __int32 aPlateWidth,
04570   const __int32 aPlateHeight,
04571   const __int32 aPlateAngle,
04572   const __int32 aSymHeight,
04573   const wchar_t* aType);
04574
04575 /// Create action 'NPR recognition'.
04576 /// NPR recognition.
04577 /// @param  [in]  aPlateNo     Recognized plate no.
04578 /// @param  [in]  aCountry     Country.
04579 /// @param  [in]  aChannel     Channel.
04580 /// @param  [in]  aTimeStamp   Time stamp.
04581 /// @param  [in]  aZoneRect    Zone rectangle.
04582 /// @param  [in]  aRestriction Restriction of recognized number.
04583 /// @param  [in]  aCategory    Category of recognized number.
04584 /// @param  [in]  aSpeed       Speed in km/h
04585 /// @param  [in]  aDirection   Direction of the motion.
04586 /// @param  [in]  aZoneIndex   Zone index.
04587 /// @param  [in]  aType        Number type.
04588 /// @param  [in]  aWeight      Weight of recognition.
04589 /// @return handle to action if the function succeeds or \c NULL if it fails.
04590 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateNPRRecognition(
04591   const wchar_t* aPlateNo,
04592   const wchar_t* aCountry,
04593   const TPlcMediaChannelID& aChannel,
04594   const TGLibDateTime& aTimeStamp,
04595   const TPlcRect& aZoneRect,
04596   const PlcNPRRestriction aRestriction,
04597   const wchar_t* aCategory,
04598   const __int32 aSpeed,
04599   const __int32 aDirection,
04600   const __int32 aZoneIndex,
04601   const wchar_t* aType,
04602   const __int32 aWeight);
04603
04604 /// Create action 'OBTRACK channel counter'.
04605 /// OBTRACK channel counter.
04606 /// @param  [in]  aChannel     Channel.
04607 /// @param  [in]  aCounterType Counter type.
04608 /// @param  [in]  aCounterValue Counter value.
04609 /// @param  [in]  aObjectDirection Object direction.
04610 /// @param  [in]  aTimeStamp   Time stamp.
04611 /// @param  [in]  aResetTimeStamp Reset time stamp.
04612 /// @return handle to action if the function succeeds or \c NULL if it fails.
04613 ///
04614 /// @attention Following parameters are optional:  aResetTimeStamp. \par
04615 ///            You can provide \c NULL pointer if you not use these fields.
04616 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackChannelCounter(
04617   const TPlcMediaChannelID& aChannel,
04618   const PlcObtrackCounterType aCounterType,
04619   const __int64& aCounterValue,
04620   const __int32 aObjectDirection,
04621   const TGLibDateTime& aTimeStamp,
04622   const TGLibDateTime* aResetTimeStamp);
04623
04624 /// Create action 'OBTRACK channel counter threshold'.
04625 /// OBTRACK channel counter threshold.
04626 /// @param  [in]  aChannel     Channel.
04627 /// @param  [in]  aCounterType Counter type.
04628 /// @param  [in]  aCounterValue Counter value.
04629 /// @param  [in]  aExceedingDirection Exceeding direction.
04630 /// @param  [in]  aTimeStamp   Time stamp.
04631 /// @return handle to action if the function succeeds or \c NULL if it fails.
04632 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackChannelCounterThreshold(
04633   const TPlcMediaChannelID& aChannel,
04634   const PlcObtrackCounterType aCounterType,
04635   const __int64& aCounterValue,
04636   const PlcObtrackExceedingDirection aExceedingDirection,
04637   const TGLibDateTime& aTimeStamp);
04638
04639 /// Create action 'OBTRACK channel set counter'.
04640 /// OBTRACK channel set counter.
04641 /// @param  [in]  aChannel     Channel.
04642 /// @param  [in]  aCounterType Counter type.
04643 /// @param  [in]  aCounterValue Counter value.
04644 /// @param  [in]  aTimeStamp   Time stamp.
04645 /// @return handle to action if the function succeeds or \c NULL if it fails.
04646 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackChannelSetCounter(
04647   const TPlcMediaChannelID& aChannel,
04648   const PlcObtrackCounterType aCounterType,
04649   const __int64& aCounterValue,
04650   const TGLibDateTime& aTimeStamp);
04651
04652 /// Create action 'OBTRACK frame raw data'.
04653 /// OBTRACK frame raw data.
04654 /// @param  [in]  aTimeStamp   Time stamp.
04655 /// @param  [in]  aChannel     Channel.
04656 /// @param  [in]  aBrightness  Brightness.
04657 /// @param  [in]  aContrast    Contrast.
04658 /// @return handle to action if the function succeeds or \c NULL if it fails.
04659 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackFrameRawData(
04660   const TGLibDateTime& aTimeStamp,
04661   const TPlcMediaChannelID& aChannel,
04662   const __int32 aBrightness,
04663   const __int32 aContrast);
04664
04665 /// Create action 'OBTRACK group counter'.
04666 /// OBTRACK group counter.
04667 /// @param  [in]  aGroupId     Group ID.
04668 /// @param  [in]  aCounterType Counter type.
04669 /// @param  [in]  aCounterValue Counter value.
04670 /// @param  [in]  aObjectDirection Object direction.
04671 /// @param  [in]  aTimeStamp   Time stamp.
04672 /// @param  [in]  aResetTimeStamp Reset time stamp.
04673 /// @param  [in]  aGroupName   Group name.
04674 /// @return handle to action if the function succeeds or \c NULL if it fails.
04675 ///
04676 /// @attention Following parameters are optional:  aResetTimeStamp. aGroupName. \par
04677 ///            You can provide \c NULL pointer if you not use these fields.
04678 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackGroupCounter(
04679   const __int32 aGroupId,
04680   const PlcObtrackCounterType aCounterType,
04681   const __int64& aCounterValue,
04682   const __int32 aObjectDirection,
04683   const TGLibDateTime& aTimeStamp,
04684   const TGLibDateTime* aResetTimeStamp,
04685   const wchar_t* aGroupName);
04686
04687 /// Create action 'OBTRACK group counter threshold'.
04688 /// OBTRACK group counter threshold.
04689 /// @param  [in]  aGroupId     Group ID.
04690 /// @param  [in]  aCounterType Counter type.
04691 /// @param  [in]  aCounterValue Counter value.
04692 /// @param  [in]  aExceedingDirection Exceeding direction.
04693 /// @param  [in]  aTimeStamp   Time stamp.
04694 /// @param  [in]  aGroupName   Group name.
04695 /// @return handle to action if the function succeeds or \c NULL if it fails.
04696 ///
04697 /// @attention Following parameters are optional:  aGroupName. \par
04698 ///            You can provide \c NULL pointer if you not use these fields.
04699 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackGroupCounterThreshold(
04700   const __int32 aGroupId,
04701   const PlcObtrackCounterType aCounterType,
04702   const __int64& aCounterValue,
04703   const PlcObtrackExceedingDirection aExceedingDirection,
04704   const TGLibDateTime& aTimeStamp,
04705   const wchar_t* aGroupName);
04706
04707 /// Create action 'OBTRACK group set counter'.
04708 /// OBTRACK group set counter.
04709 /// @param  [in]  aGroupId     Group ID.
04710 /// @param  [in]  aCounterType Counter type.
04711 /// @param  [in]  aCounterValue Counter value.
04712 /// @param  [in]  aTimeStamp   Time stamp.
04713 /// @param  [in]  aGroupName   Group name.
04714 /// @return handle to action if the function succeeds or \c NULL if it fails.
04715 ///
04716 /// @attention Following parameters are optional:  aGroupName. \par
04717 ///            You can provide \c NULL pointer if you not use these fields.
04718 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackGroupSetCounter(
04719   const __int32 aGroupId,
04720   const PlcObtrackCounterType aCounterType,
04721   const __int64& aCounterValue,
04722   const TGLibDateTime& aTimeStamp,
04723   const wchar_t* aGroupName);
04724
04725 /// Create action 'OBTRACK object raw data'.
04726 /// OBTRACK object raw data.
04727 /// @param  [in]  aTimeStamp   Time stamp.
04728 /// @param  [in]  aChannel     Channel.
04729 /// @param  [in]  aArea        Area no.
04730 /// @param  [in]  aObjectID    Object ID.
04731 /// @param  [in]  aObjectStatus Object status.
04732 /// @param  [in]  aObjectClass Object class.
04733 /// @param  [in]  aConfidence  Confidence.
04734 /// @param  [in]  aPosition    Position.
04735 /// @param  [in]  aSpeed       Speed.
04736 /// @param  [in]  aDuration    Duration.
04737 /// @param  [in]  aDirection   Direction.
04738 /// @param  [in]  aSize        Object size.
04739 /// @param  [in]  aObjectWidth Object width in meters.
04740 /// @param  [in]  aObjectHeight Object height in meters.
04741 /// @param  [in]  aProcessSize Process size.
04742 /// @param  [in]  aGscNetName  GeViScope network name.
04743 /// @return handle to action if the function succeeds or \c NULL if it fails.
04744 ///
04745 /// @attention Following parameters are optional:  aConfidence. aPosition. aSpeed. aDuration. aDirection. aSize. aObjectWidth. aObjectHeight. aProcessSize. aGscNetName. \par
04746 ///            You can provide \c NULL pointer if you not use these fields.
04747 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackObjectRawData(
04748   const TGLibDateTime& aTimeStamp,
04749   const TPlcMediaChannelID& aChannel,
04750   const __int32 aArea,
04751   const __int32 aObjectID,
04752   const PlcObtrackObjectStatus aObjectStatus,
04753   const PlcObtrackObjectClass aObjectClass,
04754   const __int32* aConfidence,
04755   const TPlcRect* aPosition,
04756   const double* aSpeed,
04757   const __int32* aDuration,
04758   const __int32* aDirection,
04759   const double* aSize,
04760   const double* aObjectWidth,
04761   const double* aObjectHeight,
04762   const PlcObtrackProcessSize* aProcessSize,
04763   const char* aGscNetName);
04764
04765 /// Create action 'OBTRACK tunnel alarm'.
04766 /// OBTRACK tunnel alarm notification.
04767 /// @param  [in]  aChannel     Channel.
04768 /// @param  [in]  aTimeStamp   Time stamp.
04769 /// @param  [in]  aAlarmReason Alarm reason.
04770 /// @param  [in]  aObjectID    Object ID.
04771 /// @param  [in]  aAlarmAreaID Alarm area ID.
04772 /// @param  [in]  aObjectArea  Object area.
04773 /// @return handle to action if the function succeeds or \c NULL if it fails.
04774 ///
04775 /// @attention Following parameters are optional:  aObjectArea. \par
04776 ///            You can provide \c NULL pointer if you not use these fields.
04777 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateObtrackTunnelAlarm(
04778   const TPlcMediaChannelID& aChannel,
04779   const TGLibDateTime& aTimeStamp,
04780   const PlcTunnelAlarmReason aAlarmReason,
04781   const __int32 aObjectID,
04782   const __int32 aAlarmAreaID,
04783   const TPlcRect* aObjectArea);
04784
04785 /// Create action 'Pan auto'.
04786 /// Turn auto pan of the camera.
04787 /// @param  [in]  aCamera      PTZ head.
04788 /// @param  [in]  aModus       Pan modus.
04789 /// @return handle to action if the function succeeds or \c NULL if it fails.
04790 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePanAuto(
04791   const TPlcMediaChannelID& aCamera,
04792   const __int32 aModus);
04793
04794 /// Create action 'Pan left'.
04795 /// Pan camera to the left.
04796 /// @param  [in]  aCamera      PTZ head.
04797 /// @param  [in]  aSpeed       Pan speed.
04798 /// @return handle to action if the function succeeds or \c NULL if it fails.
04799 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePanLeft(
04800   const TPlcMediaChannelID& aCamera,
04801   const __int32 aSpeed);
04802
04803 /// Create action 'Pan right'.
04804 /// Pan camera to the right.
04805 /// @param  [in]  aCamera      PTZ head.
04806 /// @param  [in]  aSpeed       Pan speed.
04807 /// @return handle to action if the function succeeds or \c NULL if it fails.
04808 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePanRight(
04809   const TPlcMediaChannelID& aCamera,
04810   const __int32 aSpeed);
04811
04812 /// Create action 'Pan stop'.
04813 /// Stop pan movement.
04814 /// @param  [in]  aCamera      PTZ head.
04815 /// @return handle to action if the function succeeds or \c NULL if it fails.
04816 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePanStop(
04817   const TPlcMediaChannelID& aCamera);
04818
04819 /// Create action 'POS data'.
04820 /// POS data.
04821 /// @param  [in]  aPOSName     POS name.
04822 /// @param  [in]  aTimeStamp   Time stamp.
04823 /// @param  [in]  aArticle     Article description.
04824 /// @param  [in]  aPrice       Price.
04825 /// @param  [in]  aUnits       Number of units.
04826 /// @param  [in]  aPricePerUnit Price per unit.
04827 /// @param  [in]  aLine1       Line 1.
04828 /// @param  [in]  aLine2       Line 2.
04829 /// @param  [in]  aLine3       Line 3.
04830 /// @param  [in]  aLine4       Line 4.
04831 /// @param  [in]  aLine5       Line 5.
04832 /// @return handle to action if the function succeeds or \c NULL if it fails.
04833 ///
04834 /// @attention Following parameters are optional:  aArticle. aPrice. aUnits. aPricePerUnit. aLine1. aLine2. aLine3. aLine4. aLine5. \par
04835 ///            You can provide \c NULL pointer if you not use these fields.
04836 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePOSData(
04837   const wchar_t* aPOSName,
04838   const TGLibDateTime& aTimeStamp,
04839   const wchar_t* aArticle,
04840   const double* aPrice,
04841   const __int32* aUnits,
04842   const double* aPricePerUnit,
04843   const wchar_t* aLine1,
04844   const wchar_t* aLine2,
04845   const wchar_t* aLine3,
04846   const wchar_t* aLine4,
04847   const wchar_t* aLine5);
04848
04849 /// Create action 'POS status'.
04850 /// POS status.
04851 /// @param  [in]  aPOSName     POS name.
04852 /// @param  [in]  aTimeStamp   Time stamp.
04853 /// @param  [in]  aStatus      Status.
04854 /// @param  [in]  aDetails     Details.
04855 /// @return handle to action if the function succeeds or \c NULL if it fails.
04856 ///
04857 /// @attention Following parameters are optional:  aDetails. \par
04858 ///            You can provide \c NULL pointer if you not use these fields.
04859 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePOSStatus(
04860   const wchar_t* aPOSName,
04861   const TGLibDateTime& aTimeStamp,
04862   const PlcPOSStatus aStatus,
04863   const wchar_t* aDetails);
04864
04865 /// Create action 'PP device alarm'.
04866 /// Perimeter protection device alarm.
04867 /// @param  [in]  aInterfaceID Interface ID.
04868 /// @param  [in]  aDeviceAddress Device address.
04869 /// @param  [in]  aSensor      Sensor.
04870 /// @param  [in]  aState       State.
04871 /// @return handle to action if the function succeeds or \c NULL if it fails.
04872 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPDeviceAlarm(
04873   const wchar_t* aInterfaceID,
04874   const __int32 aDeviceAddress,
04875   const PPSensorKind aSensor,
04876   const PPAlarmState aState);
04877
04878 /// Create action 'PP device input'.
04879 /// Perimeter protection device input.
04880 /// @param  [in]  aInterfaceID Interface ID.
04881 /// @param  [in]  aDeviceAddress Device address.
04882 /// @param  [in]  aInput       Input.
04883 /// @param  [in]  aState       State.
04884 /// @return handle to action if the function succeeds or \c NULL if it fails.
04885 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPDeviceInput(
04886   const wchar_t* aInterfaceID,
04887   const __int32 aDeviceAddress,
04888   const __int32 aInput,
04889   const PPAlarmState aState);
04890
04891 /// Create action 'PP device offline'.
04892 /// Perimeter protection device offline.
04893 /// @param  [in]  aInterfaceID Interface ID.
04894 /// @param  [in]  aDeviceAddress Device address.
04895 /// @return handle to action if the function succeeds or \c NULL if it fails.
04896 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPDeviceOffline(
04897   const wchar_t* aInterfaceID,
04898   const __int32 aDeviceAddress);
04899
04900 /// Create action 'PP device online'.
04901 /// Perimeter protection device online.
04902 /// @param  [in]  aInterfaceID Interface ID.
04903 /// @param  [in]  aDeviceAddress Device address.
04904 /// @return handle to action if the function succeeds or \c NULL if it fails.
04905 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPDeviceOnline(
04906   const wchar_t* aInterfaceID,
04907   const __int32 aDeviceAddress);
04908
04909 /// Create action 'PP interface offline'.
04910 /// Perimeter protection interface offline.
04911 /// @param  [in]  aInterfaceID Interface ID.
04912 /// @return handle to action if the function succeeds or \c NULL if it fails.
04913 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPInterfaceOffline(
04914   const wchar_t* aInterfaceID);
04915
04916 /// Create action 'PP interface online'.
04917 /// Perimeter protection interface online.
04918 /// @param  [in]  aInterfaceID Interface ID.
04919 /// @return handle to action if the function succeeds or \c NULL if it fails.
04920 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPInterfaceOnline(
04921   const wchar_t* aInterfaceID);
04922
04923 /// Create action 'PP query interface'.
04924 /// Perimeter protection query interface.
04925 /// @param  [in]  aInterfaceID Interface ID.
04926 /// @return handle to action if the function succeeds or \c NULL if it fails.
04927 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPQueryInterface(
04928   const wchar_t* aInterfaceID);
04929
04930 /// Create action 'PP set device output'.
04931 /// Perimeter protection set device output.
04932 /// @param  [in]  aInterfaceID Interface ID.
04933 /// @param  [in]  aDeviceAddress Device address.
04934 /// @param  [in]  aOutput      Output.
04935 /// @param  [in]  aState       State.
04936 /// @return handle to action if the function succeeds or \c NULL if it fails.
04937 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPSetDeviceOutput(
04938   const wchar_t* aInterfaceID,
04939   const __int32 aDeviceAddress,
04940   const __int32 aOutput,
04941   const PPAlarmState aState);
04942
04943 /// Create action 'PP subcell alarm'.
04944 /// Perimeter protection subcell alarm.
04945 /// @param  [in]  aInterfaceID Interface ID.
04946 /// @param  [in]  aDeviceAddress Device address.
04947 /// @param  [in]  aCable       Cable.
04948 /// @param  [in]  aSubcell     Subcell.
04949 /// @param  [in]  aState       State.
04950 /// @return handle to action if the function succeeds or \c NULL if it fails.
04951 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPSubcellAlarm(
04952   const wchar_t* aInterfaceID,
04953   const __int32 aDeviceAddress,
04954   const PPCableKind aCable,
04955   const __int32 aSubcell,
04956   const PPAlarmState aState);
04957
04958 /// Create action 'PP zone alarm'.
04959 /// Perimeter protection zone alarm.
04960 /// @param  [in]  aZoneID      Zone ID.
04961 /// @param  [in]  aInterfaceID Interface ID.
04962 /// @param  [in]  aDeviceAddress Device address.
04963 /// @param  [in]  aCable       Cable.
04964 /// @param  [in]  aSubcell     Subcell.
04965 /// @param  [in]  aState       State.
04966 /// @return handle to action if the function succeeds or \c NULL if it fails.
04967 ///
04968 /// @attention Following parameters are optional:  aCable. aSubcell. \par
04969 ///            You can provide \c NULL pointer if you not use these fields.
04970 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePPZoneAlarm(
04971   const wchar_t* aZoneID,
04972   const wchar_t* aInterfaceID,
04973   const __int32 aDeviceAddress,
04974   const PPCableKind* aCable,
04975   const __int32* aSubcell,
04976   const PPAlarmState aState);
04977
04978 /// Create action 'Move to preset position'.
04979 /// Move camera to preset position.
04980 /// @param  [in]  aCamera      PTZ head.
04981 /// @param  [in]  aPosition    Preset position.
04982 /// @return handle to action if the function succeeds or \c NULL if it fails.
04983 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePrePosCallUp(
04984   const TPlcMediaChannelID& aCamera,
04985   const __int32 aPosition);
04986
04987 /// Create action 'Clear preset position'.
04988 /// Clear camera preset position.
04989 /// @param  [in]  aCamera      PTZ head.
04990 /// @param  [in]  aPosition    Preset position.
04991 /// @return handle to action if the function succeeds or \c NULL if it fails.
04992 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePrePosClear(
04993   const TPlcMediaChannelID& aCamera,
04994   const __int32 aPosition);
04995
04996 /// Create action 'Save preset position'.
04997 /// Save current camera position as preset position.
04998 /// @param  [in]  aCamera      PTZ head.
04999 /// @param  [in]  aPosition    Preset position.
05000 /// @return handle to action if the function succeeds or \c NULL if it fails.
05001 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreatePrePosSave(
05002   const TPlcMediaChannelID& aCamera,
05003   const __int32 aPosition);
05004
05005 /// Create action 'Redundant power failure'.
05006 /// This action is notified if a failure of the redundant power supply is detected.
05007 /// @return handle to action if the function succeeds or \c NULL if it fails.
05008 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateRedundantPowerFailure();
05009
05010 /// Create action 'Redundant power ok'.
05011 /// This action is notified if a failure of the redundant power supply is removed.
05012 /// @return handle to action if the function succeeds or \c NULL if it fails.
05013 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateRedundantPowerOk();
05014
05015 /// Create action 'Reset mainboard'.
05016 /// Reset mainboard using IO device.
05017 /// @return handle to action if the function succeeds or \c NULL if it fails.
05018 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateResetMainboard();
05019
05020 /// Create action 'Safebag close'.
05021 /// Safebag close.
05022 /// @param  [in]  aWorkingPlace Working place no.
05023 /// @param  [in]  aStartTime   Start time stamp.
05024 /// @param  [in]  aStopTime    Stop time stamp.
05025 /// @param  [in]  aSafebagNo   Safebag no.
05026 /// @param  [in]  aSafebagInfo Additional info about safebag.
05027 /// @param  [in]  aStepID      Processing step ID.
05028 /// @param  [in]  aDebit       Debit.
05029 /// @param  [in]  aTotal       Total.
05030 /// @param  [in]  aDifference  Difference between debit and total.
05031 /// @param  [in]  aHasDifference Difference between debit and total is not zero.
05032 /// @param  [in]  aNotes       Notes.
05033 /// @param  [in]  aCoins       Coins.
05034 /// @param  [in]  aCheques     Cheques.
05035 /// @return handle to action if the function succeeds or \c NULL if it fails.
05036 ///
05037 /// @attention Following parameters are optional:  aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques. \par
05038 ///            You can provide \c NULL pointer if you not use these fields.
05039 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSafebagClose(
05040   const __int32 aWorkingPlace,
05041   const TGLibDateTime& aStartTime,
05042   const TGLibDateTime& aStopTime,
05043   const wchar_t* aSafebagNo,
05044   const wchar_t* aSafebagInfo,
05045   const SafebagStep aStepID,
05046   const double* aDebit,
05047   const double* aTotal,
05048   const double* aDifference,
05049   const bool* aHasDifference,
05050   const wchar_t* aNotes,
05051   const wchar_t* aCoins,
05052   const wchar_t* aCheques);
05053
05054 /// Create action 'Safebag data'.
05055 /// Safebag data.
05056 /// @param  [in]  aWorkingPlace Working place no.
05057 /// @param  [in]  aStartTime   Start time stamp.
05058 /// @param  [in]  aSafebagNo   Safebag no.
05059 /// @param  [in]  aSafebagInfo Additional info about safebag.
05060 /// @param  [in]  aStepID      Processing step ID.
05061 /// @param  [in]  aDebit       Debit.
05062 /// @param  [in]  aTotal       Total.
05063 /// @param  [in]  aDifference  Difference between debit and total.
05064 /// @param  [in]  aHasDifference Difference between debit and total is not zero.
05065 /// @param  [in]  aNotes       Notes.
05066 /// @param  [in]  aCoins       Coins.
05067 /// @param  [in]  aCheques     Cheques.
05068 /// @return handle to action if the function succeeds or \c NULL if it fails.
05069 ///
05070 /// @attention Following parameters are optional:  aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques. \par
05071 ///            You can provide \c NULL pointer if you not use these fields.
05072 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSafebagData(
05073   const __int32 aWorkingPlace,
05074   const TGLibDateTime& aStartTime,
05075   const wchar_t* aSafebagNo,
05076   const wchar_t* aSafebagInfo,
05077   const SafebagStep aStepID,
05078   const double* aDebit,
05079   const double* aTotal,
05080   const double* aDifference,
05081   const bool* aHasDifference,
05082   const wchar_t* aNotes,
05083   const wchar_t* aCoins,
05084   const wchar_t* aCheques);
05085
05086 /// Create action 'Safebag open'.
05087 /// Safebag open.
05088 /// @param  [in]  aWorkingPlace Working place no.
05089 /// @param  [in]  aStartTime   Start time stamp.
05090 /// @param  [in]  aSafebagNo   Safebag no.
05091 /// @param  [in]  aSafebagInfo Additional info about safebag.
05092 /// @param  [in]  aStepID      Processing step ID.
05093 /// @return handle to action if the function succeeds or \c NULL if it fails.
05094 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSafebagOpen(
05095   const __int32 aWorkingPlace,
05096   const TGLibDateTime& aStartTime,
05097   const wchar_t* aSafebagNo,
05098   const wchar_t* aSafebagInfo,
05099   const SafebagStep aStepID);
05100
05101 /// Create action 'Safebag passing of risk data'.
05102 /// Safebag passing of risk data.
05103 /// @param  [in]  aWorkingPlace Working place no.
05104 /// @param  [in]  aStartTime   Start time stamp.
05105 /// @param  [in]  aSafebagNo   Safebag no.
05106 /// @param  [in]  aSafebagInfo Additional info about safebag.
05107 /// @param  [in]  aStepID      Processing step ID.
05108 /// @param  [in]  aUserID1     User who gives the safebag.
05109 /// @param  [in]  aUserID2     User who takes the safebag.
05110 /// @param  [in]  aTourNumber  Optional tour no.
05111 /// @param  [in]  aTargetWorkingPlace Target working place.
05112 /// @param  [in]  aPassingOfRiskType Passing of risk type.
05113 /// @return handle to action if the function succeeds or \c NULL if it fails.
05114 ///
05115 /// @attention Following parameters are optional:  aTourNumber. aTargetWorkingPlace. aPassingOfRiskType. \par
05116 ///            You can provide \c NULL pointer if you not use these fields.
05117 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSafebagPassingOfRiskData(
05118   const __int32 aWorkingPlace,
05119   const TGLibDateTime& aStartTime,
05120   const wchar_t* aSafebagNo,
05121   const wchar_t* aSafebagInfo,
05122   const SafebagStep aStepID,
05123   const __int32 aUserID1,
05124   const __int32 aUserID2,
05125   const __int32* aTourNumber,
05126   const wchar_t* aTargetWorkingPlace,
05127   const wchar_t* aPassingOfRiskType);
05128
05129 /// Create action 'Safebag passing of risk start'.
05130 /// Safebag passing of risk start.
05131 /// @param  [in]  aWorkingPlace Working place no.
05132 /// @param  [in]  aStartTime   Start time stamp.
05133 /// @param  [in]  aSafebagNo   Safebag no.
05134 /// @param  [in]  aSafebagInfo Additional info about safebag.
05135 /// @param  [in]  aStepID      Processing step ID.
05136 /// @param  [in]  aUserID1     User who gives the safebag.
05137 /// @param  [in]  aUserID2     User who takes the safebag.
05138 /// @param  [in]  aTourNumber  Optional tour no.
05139 /// @param  [in]  aTargetWorkingPlace Target working place.
05140 /// @param  [in]  aPassingOfRiskType Passing of risk type.
05141 /// @return handle to action if the function succeeds or \c NULL if it fails.
05142 ///
05143 /// @attention Following parameters are optional:  aTourNumber. aTargetWorkingPlace. aPassingOfRiskType. \par
05144 ///            You can provide \c NULL pointer if you not use these fields.
05145 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSafebagPassingOfRiskStart(
05146   const __int32 aWorkingPlace,
05147   const TGLibDateTime& aStartTime,
05148   const wchar_t* aSafebagNo,
05149   const wchar_t* aSafebagInfo,
05150   const SafebagStep aStepID,
05151   const __int32 aUserID1,
05152   const __int32 aUserID2,
05153   const __int32* aTourNumber,
05154   const wchar_t* aTargetWorkingPlace,
05155   const wchar_t* aPassingOfRiskType);
05156
05157 /// Create action 'Safebag passing of risk stop'.
05158 /// Safebag passing of risk stop.
05159 /// @param  [in]  aWorkingPlace Working place no.
05160 /// @param  [in]  aStartTime   Start time stamp.
05161 /// @param  [in]  aStopTime    Stop time stamp.
05162 /// @param  [in]  aSafebagNo   Safebag no.
05163 /// @param  [in]  aSafebagInfo Additional info about safebag.
05164 /// @param  [in]  aStepID      Processing step ID.
05165 /// @param  [in]  aUserID1     User who gives the safebag.
05166 /// @param  [in]  aUserID2     User who takes the safebag.
05167 /// @param  [in]  aTourNumber  Optional tour no.
05168 /// @param  [in]  aTargetWorkingPlace Target working place.
05169 /// @param  [in]  aPassingOfRiskType Passing of risk type.
05170 /// @return handle to action if the function succeeds or \c NULL if it fails.
05171 ///
05172 /// @attention Following parameters are optional:  aTourNumber. aTargetWorkingPlace. aPassingOfRiskType. \par
05173 ///            You can provide \c NULL pointer if you not use these fields.
05174 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSafebagPassingOfRiskStop(
05175   const __int32 aWorkingPlace,
05176   const TGLibDateTime& aStartTime,
05177   const TGLibDateTime& aStopTime,
05178   const wchar_t* aSafebagNo,
05179   const wchar_t* aSafebagInfo,
05180   const SafebagStep aStepID,
05181   const __int32 aUserID1,
05182   const __int32 aUserID2,
05183   const __int32* aTourNumber,
05184   const wchar_t* aTargetWorkingPlace,
05185   const wchar_t* aPassingOfRiskType);
05186
05187 /// Create action 'Scene store modification'.
05188 /// Scene store modification.
05189 /// @param  [in]  aViewer      Global viewer or viewer client no.
05190 /// @param  [in]  aSceneStoreID Scene store GUID.
05191 /// @param  [in]  aSceneStoreName Scene store name.
05192 /// @param  [in]  aTimeStamp   Time stamp.
05193 /// @param  [in]  aModificationType Modification type.
05194 /// @param  [in]  aUser        Name of the user.
05195 /// @param  [in]  aClientHost  Host from where the connection is done.
05196 /// @param  [in]  aClientType  Client type.
05197 /// @param  [in]  aClientAccount User account from where the connection is done.
05198 /// @return handle to action if the function succeeds or \c NULL if it fails.
05199 ///
05200 /// @attention Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
05201 ///            You can provide \c NULL pointer if you not use these fields.
05202 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSceneStoreModification(
05203   const TPlcMediaChannelID& aViewer,
05204   const GUID& aSceneStoreID,
05205   const wchar_t* aSceneStoreName,
05206   const TGLibDateTime& aTimeStamp,
05207   const PlcSceneStoreModificationType aModificationType,
05208   const wchar_t* aUser,
05209   const wchar_t* aClientHost,
05210   const PlcClientType* aClientType,
05211   const wchar_t* aClientAccount);
05212
05213 /// Create action 'Sensor alarm finished'.
05214 /// This action will be fired when the alarm is finished.
05215 /// @param  [in]  aChannel     Channel.
05216 /// @param  [in]  aSensorType  Sensor type.
05217 /// @return handle to action if the function succeeds or \c NULL if it fails.
05218 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSensorAlarmFinished(
05219   const TPlcMediaChannelID& aChannel,
05220   const VideoSensorKind aSensorType);
05221
05222 /// Create action 'Sensor audio alarm'.
05223 /// Audio alarm detected.
05224 /// @param  [in]  aChannel     Channel.
05225 /// @return handle to action if the function succeeds or \c NULL if it fails.
05226 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSensorAudioAlarm(
05227   const TPlcMediaChannelID& aChannel);
05228
05229 /// Create action 'Sensor inhibit alarm finished'.
05230 /// This action will be fired when the inhibit alarm is finished.
05231 /// @param  [in]  aChannel     Channel.
05232 /// @param  [in]  aSensorType  Sensor type.
05233 /// @return handle to action if the function succeeds or \c NULL if it fails.
05234 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSensorInhibitAlarmFinished(
05235   const TPlcMediaChannelID& aChannel,
05236   const VideoSensorKind aSensorType);
05237
05238 /// Create action 'Sensor inhibit video alarm'.
05239 /// This action will be fired when the motion in inhibit area is detected.
05240 /// @param  [in]  aChannel     Channel.
05241 /// @param  [in]  aSensorType  Sensor type.
05242 /// @param  [in]  aADArea      AD alarm area.
05243 /// @param  [in]  aADCell      AD cell nr.
05244 /// @param  [in]  aVMDGroup    VMD alarm group.
05245 /// @param  [in]  aVMDZone     VMD zone nr.
05246 /// @param  [in]  aVMDCycle    VMD measure cycle.
05247 /// @param  [in]  aAlarmArea   Alarm area.
05248 /// @param  [in]  aObjectClass OBTRACK object class.
05249 /// @return handle to action if the function succeeds or \c NULL if it fails.
05250 ///
05251 /// @attention Following parameters are optional:  aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass. \par
05252 ///            You can provide \c NULL pointer if you not use these fields.
05253 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSensorInhibitVideoAlarmEx(
05254   const TPlcMediaChannelID& aChannel,
05255   const VideoSensorKind aSensorType,
05256   const ADArea* aADArea,
05257   const __int32* aADCell,
05258   const VMDGroup* aVMDGroup,
05259   const __int32* aVMDZone,
05260   const VMDCycle* aVMDCycle,
05261   const TPlcRect* aAlarmArea,
05262   const PlcObtrackObjectClass* aObjectClass);
05263
05264 /// Create action 'Sensor video alarm'.
05265 /// This action will be fired when video alarm is detected.
05266 /// @param  [in]  aChannel     Channel.
05267 /// @param  [in]  aSensorType  Sensor type.
05268 /// @param  [in]  aADArea      AD alarm area.
05269 /// @param  [in]  aADCell      AD cell nr.
05270 /// @param  [in]  aVMDGroup    VMD alarm group.
05271 /// @param  [in]  aVMDZone     VMD zone nr.
05272 /// @param  [in]  aVMDCycle    VMD measure cycle.
05273 /// @param  [in]  aAlarmArea   Alarm area.
05274 /// @param  [in]  aObjectClass OBTRACK object class.
05275 /// @return handle to action if the function succeeds or \c NULL if it fails.
05276 ///
05277 /// @attention Following parameters are optional:  aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass. \par
05278 ///            You can provide \c NULL pointer if you not use these fields.
05279 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSensorVideoAlarmEx(
05280   const TPlcMediaChannelID& aChannel,
05281   const VideoSensorKind aSensorType,
05282   const ADArea* aADArea,
05283   const __int32* aADCell,
05284   const VMDGroup* aVMDGroup,
05285   const __int32* aVMDZone,
05286   const VMDCycle* aVMDCycle,
05287   const TPlcRect* aAlarmArea,
05288   const PlcObtrackObjectClass* aObjectClass);
05289
05290 /// Create action 'Set camera text'.
05291 /// Set camera text.
05292 /// @param  [in]  aCamera      PTZ head.
05293 /// @param  [in]  aText        Text to superimpose.
05294 /// @return handle to action if the function succeeds or \c NULL if it fails.
05295 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetCameraText(
05296   const TPlcMediaChannelID& aCamera,
05297   const char* aText);
05298
05299 /// Create action 'Enable client VCA'.
05300 /// Enable client VCA
05301 /// @param  [in]  aChannel     Channel.
05302 /// @param  [in]  aClientVCAType VCA Type
05303 /// @param  [in]  aEnabled     Enabled
05304 /// @return handle to action if the function succeeds or \c NULL if it fails.
05305 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetClientVCA(
05306   const TPlcMediaChannelID& aChannel,
05307   const GTectClientVCAType aClientVCAType,
05308   const bool aEnabled);
05309
05310 /// Create action 'Set clock'.
05311 /// Set clock.
05312 /// @param  [in]  aDate        Current time.
05313 /// @return handle to action if the function succeeds or \c NULL if it fails.
05314 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetClock(
05315   const TGLibDateTime& aDate);
05316
05317 /// Create action 'Set digital output'.
05318 /// This action is used to modify the state of the digital output and to notify this change.
05319 /// @param  [in]  aContact     Contact.
05320 /// @param  [in]  aState       New state.
05321 /// @return handle to action if the function succeeds or \c NULL if it fails.
05322 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetDigitalOutput(
05323   const TPlcMediaChannelID& aContact,
05324   const DigitalOutputState aState);
05325
05326 /// Create action 'Set export marker'.
05327 /// Set export marker.
05328 /// @param  [in]  aViewer      Global viewer or viewer client no.
05329 /// @param  [in]  aMarker      Marker kind.
05330 /// @return handle to action if the function succeeds or \c NULL if it fails.
05331 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetExportMarker(
05332   const TPlcMediaChannelID& aViewer,
05333   const PlcExportMarker aMarker);
05334
05335 /// Create action 'Set system LED'.
05336 /// This action is used to turn the system LEDs on or off.
05337 /// @param  [in]  aLED         System LED.
05338 /// @param  [in]  aState       New state.
05339 /// @return handle to action if the function succeeds or \c NULL if it fails.
05340 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetLED(
05341   const SystemLED aLED,
05342   const DigitalOutputState aState);
05343
05344 /// Create action 'Set system LED to blink'.
05345 /// This action is used to blink the system LEDs.
05346 /// @param  [in]  aLED         System LED.
05347 /// @param  [in]  aLedTimeOnMs Time in milliseconds when the LED will be switched on.
05348 /// @param  [in]  aLedTimeOffMs Time in milliseconds when the LED will be switched off.
05349 /// @return handle to action if the function succeeds or \c NULL if it fails.
05350 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetLEDBlink(
05351   const SystemLED aLED,
05352   const __int32 aLedTimeOnMs,
05353   const __int32 aLedTimeOffMs);
05354
05355 /// Create action 'Set system time'.
05356 /// Set system time.
05357 /// @param  [in]  aTimeStamp   Time stamp.
05358 /// @return handle to action if the function succeeds or \c NULL if it fails.
05359 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetSystemTime(
05360   const TGLibDateTime& aTimeStamp);
05361
05362 /// Create action 'Set test picture mode'.
05363 /// Enable or disable test picture generator.
05364 /// @param  [in]  aChannel     Channel.
05365 /// @param  [in]  aMode        Enable or disable test picture generator.
05366 /// @return handle to action if the function succeeds or \c NULL if it fails.
05367 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetTestPictureMode(
05368   const TPlcMediaChannelID& aChannel,
05369   const bool aMode);
05370
05371 /// Create action 'Setup changed'.
05372 /// Setup changed.
05373 /// @param  [in]  aUser        Name of the user who modified the setup.
05374 /// @param  [in]  aHost        Host from where the connection was done.
05375 /// @param  [in]  aDate        Current time.
05376 /// @param  [in]  aResourceKind Modified resource kind.
05377 /// @param  [in]  aResourceID  Modified resource ID.
05378 /// @param  [in]  aChangeKind  Change kind.
05379 /// @param  [in]  aDetails     Details of the modification.
05380 /// @param  [in]  aClientHost  Host from where the connection is done.
05381 /// @param  [in]  aClientType  Client type.
05382 /// @param  [in]  aClientAccount User account from where the connection is done.
05383 /// @return handle to action if the function succeeds or \c NULL if it fails.
05384 ///
05385 /// @attention Following parameters are optional:  aDetails. aClientHost. aClientType. aClientAccount. \par
05386 ///            You can provide \c NULL pointer if you not use these fields.
05387 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetupChanged(
05388   const wchar_t* aUser,
05389   const wchar_t* aHost,
05390   const TGLibDateTime& aDate,
05391   const PlcResourceKind aResourceKind,
05392   const TPlcEventTypeID& aResourceID,
05393   const PlcResourceChangeKind aChangeKind,
05394   const wchar_t* aDetails,
05395   const wchar_t* aClientHost,
05396   const PlcClientType* aClientType,
05397   const wchar_t* aClientAccount);
05398
05399 /// Create action 'Setup upload progress'.
05400 /// Setup upload progress.
05401 /// @param  [in]  aUser1       Name of the user who modified the setup.
05402 /// @param  [in]  aUser2       Name of the second user by four eyes authentication.
05403 /// @param  [in]  aHost        Host from where the connection was done.
05404 /// @param  [in]  aProgress    Progress in percent.
05405 /// @param  [in]  aDate        Current stage time.
05406 /// @return handle to action if the function succeeds or \c NULL if it fails.
05407 ///
05408 /// @attention Following parameters are optional:  aUser1. aUser2. aHost. \par
05409 ///            You can provide \c NULL pointer if you not use these fields.
05410 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetupUploadProgress(
05411   const wchar_t* aUser1,
05412   const wchar_t* aUser2,
05413   const wchar_t* aHost,
05414   const __int32 aProgress,
05415   const TGLibDateTime& aDate);
05416
05417 /// Create action 'Set watchdog'.
05418 /// Set watchdog.
05419 /// @param  [in]  aTimeout     Timeout in seconds, before the watchdog must be retriggered and before the hardware watchdog will set the hardware contact.
05420 /// @return handle to action if the function succeeds or \c NULL if it fails.
05421 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSetWatchdog(
05422   const __int32 aTimeout);
05423
05424 /// Create action 'SKIDATA control'.
05425 /// SKIDATA control information.
05426 /// @param  [in]  aInterfaceName Interface name.
05427 /// @param  [in]  aData        Interface state.
05428 /// @return handle to action if the function succeeds or \c NULL if it fails.
05429 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSkidataControl(
05430   const wchar_t* aInterfaceName,
05431   const PlcSkidataControl aData);
05432
05433 /// Create action 'SKIDATA device event'.
05434 /// SKIDATA device event.
05435 /// @param  [in]  aInterfaceName Interface name.
05436 /// @param  [in]  aDeviceID    Device ID.
05437 /// @param  [in]  aEventCode   Event code.
05438 /// @return handle to action if the function succeeds or \c NULL if it fails.
05439 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSkidataDeviceEvent(
05440   const wchar_t* aInterfaceName,
05441   const __int32 aDeviceID,
05442   const __int32 aEventCode);
05443
05444 /// Create action 'SKIDATA entry'.
05445 /// SKIDATA entry.
05446 /// @param  [in]  aInterfaceName Interface name.
05447 /// @param  [in]  aMessageCode Message code.
05448 /// @param  [in]  aTranscactionID Transcaction ID.
05449 /// @param  [in]  aCarParkNo   Car park no.
05450 /// @param  [in]  aDeviceID    Device ID.
05451 /// @return handle to action if the function succeeds or \c NULL if it fails.
05452 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSkidataEntry(
05453   const wchar_t* aInterfaceName,
05454   const PlcSkidataMsgCodeEntry aMessageCode,
05455   const wchar_t* aTranscactionID,
05456   const __int32 aCarParkNo,
05457   const __int32 aDeviceID);
05458
05459 /// Create action 'SKIDATA exit'.
05460 /// SKIDATA exit.
05461 /// @param  [in]  aInterfaceName Interface name.
05462 /// @param  [in]  aMessageCode Message code.
05463 /// @param  [in]  aTranscactionID Transcaction ID.
05464 /// @param  [in]  aCarParkNo   Car park no.
05465 /// @param  [in]  aDeviceID    Device ID.
05466 /// @return handle to action if the function succeeds or \c NULL if it fails.
05467 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSkidataExit(
05468   const wchar_t* aInterfaceName,
05469   const PlcSkidataMsgCodeExit aMessageCode,
05470   const wchar_t* aTranscactionID,
05471   const __int32 aCarParkNo,
05472   const __int32 aDeviceID);
05473
05474 /// Create action 'SKIDATA transaction'.
05475 /// SKIDATA transaction.
05476 /// @param  [in]  aInterfaceName Interface name.
05477 /// @param  [in]  aMessageCode Message code.
05478 /// @param  [in]  aTranscactionID Transcaction ID.
05479 /// @param  [in]  aCarParkNo   Car park no.
05480 /// @param  [in]  aDeviceID    Device ID.
05481 /// @return handle to action if the function succeeds or \c NULL if it fails.
05482 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSkidataTransaction(
05483   const wchar_t* aInterfaceName,
05484   const PlcSkidataMsgCodeTransaction aMessageCode,
05485   const wchar_t* aTranscactionID,
05486   const __int32 aCarParkNo,
05487   const __int32 aDeviceID);
05488
05489 /// Create action 'SMRP viewer cleared'.
05490 /// SMRP viewer cleared.
05491 /// @return handle to action if the function succeeds or \c NULL if it fails.
05492 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSMRPViewerCleared();
05493
05494 /// Create action 'SMRP viewer connected'.
05495 /// SMRP viewer connected to the camera.
05496 /// @param  [in]  aServer      Server name.
05497 /// @param  [in]  aChannel     Channel.
05498 /// @return handle to action if the function succeeds or \c NULL if it fails.
05499 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSMRPViewerConnected(
05500   const wchar_t* aServer,
05501   const TPlcMediaChannelID& aChannel);
05502
05503 /// Create action 'SMTP mail'.
05504 /// This action will send a user defined email if GSCMail is connected
05505 /// @param  [in]  aSubject     Mail subject.
05506 /// @param  [in]  aTo          Mail recipients.
05507 /// @param  [in]  aCc          Carbon copy recipients.
05508 /// @param  [in]  aBody        Mail body.
05509 /// @param  [in]  aChannel     Channel.
05510 /// @return handle to action if the function succeeds or \c NULL if it fails.
05511 ///
05512 /// @attention Following parameters are optional:  aChannel. \par
05513 ///            You can provide \c NULL pointer if you not use these fields.
05514 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSMTPMailSend(
05515   const wchar_t* aSubject,
05516   const wchar_t* aTo,
05517   const wchar_t* aCc,
05518   const wchar_t* aBody,
05519   const TPlcMediaChannelID* aChannel);
05520
05521 /// Create action 'Start auto backup'.
05522 /// Start auto backup.
05523 /// @param  [in]  aSchedule    Schedule.
05524 /// @return handle to action if the function succeeds or \c NULL if it fails.
05525 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStartAutoBackup(
05526   const TPlcResourceID& aSchedule);
05527
05528 /// Create action 'Start event'.
05529 /// Start event.
05530 /// @param  [in]  aTypeID      Type of the event.
05531 /// @param  [in]  aForeignKey  Optional foreign key used to store with alarm.
05532 /// @return handle to action if the function succeeds or \c NULL if it fails.
05533 ///
05534 /// @attention Following parameters are optional:  aForeignKey. \par
05535 ///            You can provide \c NULL pointer if you not use these fields.
05536 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStartEventEx(
05537   const TPlcEventTypeID& aTypeID,
05538   const __int64* aForeignKey);
05539
05540 /// Create action 'Start remote export'.
05541 /// Start remote export.
05542 /// @param  [in]  aExportID    Export GUID.
05543 /// @param  [in]  aDevice      Pilot device GUID.
05544 /// @param  [in]  aBackupFormat Backup format.
05545 /// @param  [in]  aChannel     Channel.
05546 /// @param  [in]  aSelectionBegin Start time.
05547 /// @param  [in]  aSelectionEnd End time.
05548 /// @param  [in]  aJobID       Job ID.
05549 /// @return handle to action if the function succeeds or \c NULL if it fails.
05550 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStartRemoteExport(
05551   const GUID& aExportID,
05552   const GUID& aDevice,
05553   const PlcBackupFormat aBackupFormat,
05554   const TPlcMediaChannelID& aChannel,
05555   const TGLibDateTime& aSelectionBegin,
05556   const TGLibDateTime& aSelectionEnd,
05557   const wchar_t* aJobID);
05558
05559 /// Create action 'Start scene store'.
05560 /// Start scene store.
05561 /// @param  [in]  aSceneStoreID Scene store GUID.
05562 /// @param  [in]  aCutList     Cut-list.
05563 /// @param  [in]  aPreHistoryLength Pre-history length.
05564 /// @param  [in]  aRecordingLength Recording length.
05565 /// @return handle to action if the function succeeds or \c NULL if it fails.
05566 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStartSceneStore(
05567   const GUID& aSceneStoreID,
05568   const wchar_t* aCutList,
05569   const __int64& aPreHistoryLength,
05570   const __int64& aRecordingLength);
05571
05572 /// Create action 'Stop all events'.
05573 /// Stop all active events.
05574 /// @return handle to action if the function succeeds or \c NULL if it fails.
05575 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStopAllEvents();
05576
05577 /// Create action 'Stop event'.
05578 /// Stop event.
05579 /// @param  [in]  aTypeID      Type of the event.
05580 /// @return handle to action if the function succeeds or \c NULL if it fails.
05581 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStopEvent(
05582   const TPlcEventTypeID& aTypeID);
05583
05584 /// Create action 'Stop event by instance'.
05585 /// Stop event by instance ID.
05586 /// @param  [in]  aEventID     Instance ID of the event.
05587 /// @return handle to action if the function succeeds or \c NULL if it fails.
05588 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStopEventByID(
05589   const __int64& aEventID);
05590
05591 /// Create action 'System error'.
05592 /// Notify system error.
05593 /// @param  [in]  aSource      Source of the message.
05594 /// @param  [in]  aMessage     Kind of the message.
05595 /// @param  [in]  aWindowsError Optional Windows error code.
05596 /// @param  [in]  aDescription Optional description of the message.
05597 /// @param  [in]  aXMLInfo     Optional additional info (usually as XML string).
05598 /// @return handle to action if the function succeeds or \c NULL if it fails.
05599 ///
05600 /// @attention Following parameters are optional:  aWindowsError. aDescription. aXMLInfo. \par
05601 ///            You can provide \c NULL pointer if you not use these fields.
05602 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSystemError(
05603   const PlcMessageSource aSource,
05604   const PlcMessageCode aMessage,
05605   const __int32* aWindowsError,
05606   const wchar_t* aDescription,
05607   const char* aXMLInfo);
05608
05609 /// Create action 'System info'.
05610 /// Notify system information.
05611 /// @param  [in]  aSource      Source of the message.
05612 /// @param  [in]  aMessage     Kind of the message.
05613 /// @param  [in]  aDescription Optional description of the message.
05614 /// @param  [in]  aXMLInfo     Optional additional info (usually as XML string).
05615 /// @return handle to action if the function succeeds or \c NULL if it fails.
05616 ///
05617 /// @attention Following parameters are optional:  aDescription. aXMLInfo. \par
05618 ///            You can provide \c NULL pointer if you not use these fields.
05619 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSystemInfo(
05620   const PlcMessageSource aSource,
05621   const PlcMessageCode aMessage,
05622   const wchar_t* aDescription,
05623   const char* aXMLInfo);
05624
05625 /// Create action 'System settings changed'.
05626 /// Setup of the system and/or the current time range changed.
05627 /// @param  [in]  aSetupChanged System setup has changed.
05628 /// @param  [in]  aUser1       Name of the user who modified the setup.
05629 /// @param  [in]  aUser2       Name of the second user by four eyes authentication.
05630 /// @param  [in]  aHost        Host from where the connection was done.
05631 /// @param  [in]  aTimeRangeChanged Time range has changed.
05632 /// @param  [in]  aTimeRange   Currently active time range.
05633 /// @param  [in]  aLicenceChanged Licence has changed.
05634 /// @param  [in]  aDate        Time of the system settings changed.
05635 /// @return handle to action if the function succeeds or \c NULL if it fails.
05636 ///
05637 /// @attention Following parameters are optional:  aUser1. aUser2. aHost. aTimeRange. \par
05638 ///            You can provide \c NULL pointer if you not use these fields.
05639 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSystemSettingsChanged(
05640   const bool aSetupChanged,
05641   const wchar_t* aUser1,
05642   const wchar_t* aUser2,
05643   const wchar_t* aHost,
05644   const bool aTimeRangeChanged,
05645   const TPlcResourceID* aTimeRange,
05646   const bool aLicenceChanged,
05647   const TGLibDateTime& aDate);
05648
05649 /// Create action 'System started'.
05650 /// This action will be fired only once at the system start-up.
05651 /// @param  [in]  aDate        Time of the system start-up.
05652 /// @return handle to action if the function succeeds or \c NULL if it fails.
05653 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSystemStarted(
05654   const TGLibDateTime& aDate);
05655
05656 /// Create action 'System terminating'.
05657 /// This action will be fired when the system is going to be shut down.
05658 /// @param  [in]  aDate        Time of the system shutdown.
05659 /// @param  [in]  aWindowsShutdown Indicates whether the system shutdown is done due to the windows shutdown.
05660 /// @return handle to action if the function succeeds or \c NULL if it fails.
05661 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSystemTerminating(
05662   const TGLibDateTime& aDate,
05663   const bool aWindowsShutdown);
05664
05665 /// Create action 'System warning'.
05666 /// Notify system warning.
05667 /// @param  [in]  aSource      Source of the message.
05668 /// @param  [in]  aMessage     Kind of the message.
05669 /// @param  [in]  aWindowsError Optional Windows error code.
05670 /// @param  [in]  aDescription Optional description of the message.
05671 /// @param  [in]  aXMLInfo     Optional additional info (usually as XML string).
05672 /// @return handle to action if the function succeeds or \c NULL if it fails.
05673 ///
05674 /// @attention Following parameters are optional:  aWindowsError. aDescription. aXMLInfo. \par
05675 ///            You can provide \c NULL pointer if you not use these fields.
05676 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSystemWarning(
05677   const PlcMessageSource aSource,
05678   const PlcMessageCode aMessage,
05679   const __int32* aWindowsError,
05680   const wchar_t* aDescription,
05681   const char* aXMLInfo);
05682
05683 /// Create action 'Temperature notification'.
05684 /// Temperature notification from a/ab USB Alarm-I/O.
05685 /// @param  [in]  aSourceType  Type of the device, which has fired the action.
05686 /// @param  [in]  aID          ID of the IO module (like IOI43-00/MIO84-00/MIO168-00).
05687 /// @param  [in]  aTemperature Temperature.
05688 /// @return handle to action if the function succeeds or \c NULL if it fails.
05689 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTemperature(
05690   const IODeviceType aSourceType,
05691   const wchar_t* aID,
05692   const __int32 aTemperature);
05693
05694 /// Create action 'Terminal article data'.
05695 /// Terminal article data.
05696 /// @param  [in]  aTerminalName Terminal name.
05697 /// @param  [in]  aTimeStamp   Time stamp.
05698 /// @param  [in]  aCashierStation Cashier station.
05699 /// @param  [in]  aPumpNo      Pump no.
05700 /// @param  [in]  aAlarmStatus Alarm status.
05701 /// @param  [in]  aAmount      Amount.
05702 /// @param  [in]  aPrice       Price.
05703 /// @param  [in]  aDetails     Details.
05704 /// @return handle to action if the function succeeds or \c NULL if it fails.
05705 ///
05706 /// @attention Following parameters are optional:  aPumpNo. aAmount. aPrice. aDetails. \par
05707 ///            You can provide \c NULL pointer if you not use these fields.
05708 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTerminalArticleData(
05709   const wchar_t* aTerminalName,
05710   const TGLibDateTime& aTimeStamp,
05711   const __int32 aCashierStation,
05712   const __int32* aPumpNo,
05713   const bool aAlarmStatus,
05714   const double* aAmount,
05715   const double* aPrice,
05716   const wchar_t* aDetails);
05717
05718 /// Create action 'Terminal payment data'.
05719 /// Terminal payment data.
05720 /// @param  [in]  aTerminalName Terminal name.
05721 /// @param  [in]  aTimeStamp   Time stamp.
05722 /// @param  [in]  aCashierStation Cashier station.
05723 /// @param  [in]  aPumpNo      Pump no.
05724 /// @param  [in]  aAlarmStatus Alarm status.
05725 /// @param  [in]  aAmount      Amount.
05726 /// @param  [in]  aPrice       Price.
05727 /// @param  [in]  aDetails     Details.
05728 /// @return handle to action if the function succeeds or \c NULL if it fails.
05729 ///
05730 /// @attention Following parameters are optional:  aPumpNo. aAmount. aPrice. aDetails. \par
05731 ///            You can provide \c NULL pointer if you not use these fields.
05732 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTerminalPaymentData(
05733   const wchar_t* aTerminalName,
05734   const TGLibDateTime& aTimeStamp,
05735   const __int32 aCashierStation,
05736   const __int32* aPumpNo,
05737   const bool aAlarmStatus,
05738   const double* aAmount,
05739   const double* aPrice,
05740   const wchar_t* aDetails);
05741
05742 /// Create action 'Tilt down'.
05743 /// Tilt camera down.
05744 /// @param  [in]  aCamera      PTZ head.
05745 /// @param  [in]  aSpeed       Tilt speed.
05746 /// @return handle to action if the function succeeds or \c NULL if it fails.
05747 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTiltDown(
05748   const TPlcMediaChannelID& aCamera,
05749   const __int32 aSpeed);
05750
05751 /// Create action 'Tilt stop'.
05752 /// Stop tilt movement.
05753 /// @param  [in]  aCamera      PTZ head.
05754 /// @return handle to action if the function succeeds or \c NULL if it fails.
05755 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTiltStop(
05756   const TPlcMediaChannelID& aCamera);
05757
05758 /// Create action 'Tilt up'.
05759 /// Tilt camera up.
05760 /// @param  [in]  aCamera      PTZ head.
05761 /// @param  [in]  aSpeed       Tilt speed.
05762 /// @return handle to action if the function succeeds or \c NULL if it fails.
05763 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTiltUp(
05764   const TPlcMediaChannelID& aCamera,
05765   const __int32 aSpeed);
05766
05767 /// Create action 'Transfer binary buffer'.
05768 /// Transfer binary buffer.
05769 /// @param  [in]  aInternalHandle Internal handle.
05770 /// @param  [in]  aParameter   Parameter.
05771 /// @return handle to action if the function succeeds or \c NULL if it fails.
05772 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTransferBinaryBuffer(
05773   const GUID& aInternalHandle,
05774   const wchar_t* aParameter);
05775
05776 /// Create action 'Transfer binary channel buffer'.
05777 /// Transfer binary channel buffer.
05778 /// @param  [in]  aChannel     Channel.
05779 /// @param  [in]  aInternalHandle Internal handle.
05780 /// @param  [in]  aParameter   Parameter.
05781 /// @return handle to action if the function succeeds or \c NULL if it fails.
05782 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateTransferBinaryChannelBuffer(
05783   const TPlcMediaChannelID& aChannel,
05784   const GUID& aInternalHandle,
05785   const wchar_t* aParameter);
05786
05787 /// Create action 'User login'.
05788 /// This action will be fired when the user has connected to the system.
05789 /// @param  [in]  aUser1       Name of the user connected to the system.
05790 /// @param  [in]  aUser2       Name of the second user by four eyes authentication.
05791 /// @param  [in]  aHost        Host from where the connection is done.
05792 /// @param  [in]  aClientHost  Host from where the connection is done.
05793 /// @param  [in]  aClientType  Client type.
05794 /// @param  [in]  aClientAccount User account from where the connection is done.
05795 /// @return handle to action if the function succeeds or \c NULL if it fails.
05796 ///
05797 /// @attention Following parameters are optional:  aUser2. aClientHost. aClientType. aClientAccount. \par
05798 ///            You can provide \c NULL pointer if you not use these fields.
05799 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateUserLogin(
05800   const wchar_t* aUser1,
05801   const wchar_t* aUser2,
05802   const wchar_t* aHost,
05803   const wchar_t* aClientHost,
05804   const PlcClientType* aClientType,
05805   const wchar_t* aClientAccount);
05806
05807 /// Create action 'User login failed'.
05808 /// This action will be fired when the user has tried to connect to the system but was rejected.
05809 /// @param  [in]  aUser1       Name of the user who tried to connect to the system.
05810 /// @param  [in]  aUser2       Name of the second user by four eyes authentication.
05811 /// @param  [in]  aHost        Host from where the connection is done.
05812 /// @param  [in]  aRejectReason Reason of the rejection.
05813 /// @param  [in]  aClientHost  Host from where the connection is done.
05814 /// @param  [in]  aClientType  Client type.
05815 /// @param  [in]  aClientAccount User account from where the connection is done.
05816 /// @return handle to action if the function succeeds or \c NULL if it fails.
05817 ///
05818 /// @attention Following parameters are optional:  aUser2. aClientHost. aClientType. aClientAccount. \par
05819 ///            You can provide \c NULL pointer if you not use these fields.
05820 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateUserLoginFailed(
05821   const wchar_t* aUser1,
05822   const wchar_t* aUser2,
05823   const wchar_t* aHost,
05824   const UserLoginFailureCode aRejectReason,
05825   const wchar_t* aClientHost,
05826   const PlcClientType* aClientType,
05827   const wchar_t* aClientAccount);
05828
05829 /// Create action 'User logout'.
05830 /// This action will be fired when the user has disconnected from the system.
05831 /// @param  [in]  aUser1       Name of the user disconnected from the system.
05832 /// @param  [in]  aUser2       Name of the second user by four eyes authentication.
05833 /// @param  [in]  aHost        Host from where the connection was done.
05834 /// @param  [in]  aClientHost  Host from where the connection is done.
05835 /// @param  [in]  aClientType  Client type.
05836 /// @param  [in]  aClientAccount User account from where the connection is done.
05837 /// @return handle to action if the function succeeds or \c NULL if it fails.
05838 ///
05839 /// @attention Following parameters are optional:  aUser2. aClientHost. aClientType. aClientAccount. \par
05840 ///            You can provide \c NULL pointer if you not use these fields.
05841 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateUserLogout(
05842   const wchar_t* aUser1,
05843   const wchar_t* aUser2,
05844   const wchar_t* aHost,
05845   const wchar_t* aClientHost,
05846   const PlcClientType* aClientType,
05847   const wchar_t* aClientAccount);
05848
05849 /// Create action 'VC alarm queue confirm'.
05850 /// Confirm alarm from the queue on the viewer client.
05851 /// @param  [in]  aViewer      Global viewer or viewer client no.
05852 /// @param  [in]  aSelectionMode Selection mode.
05853 /// @return handle to action if the function succeeds or \c NULL if it fails.
05854 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueConfirm(
05855   const TPlcMediaChannelID& aViewer,
05856   const PlcViewerAlarmQueueSelection aSelectionMode);
05857
05858 /// Create action 'VC alarm queue confirm by instance'.
05859 /// Confirm alarm from the queue on the viewer client.
05860 /// @param  [in]  aViewer      Global viewer or viewer client no.
05861 /// @param  [in]  aAlarmID     Instance ID of the alarm.
05862 /// @return handle to action if the function succeeds or \c NULL if it fails.
05863 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueConfirmByInstance(
05864   const TPlcMediaChannelID& aViewer,
05865   const __int64& aAlarmID);
05866
05867 /// Create action 'VC alarm queue confirm by type'.
05868 /// Confirm alarm of specific type from the queue on the viewer client.
05869 /// @param  [in]  aViewer      Global viewer or viewer client no.
05870 /// @param  [in]  aTypeID      Type of the event.
05871 /// @param  [in]  aSelectionMode Selection mode.
05872 /// @return handle to action if the function succeeds or \c NULL if it fails.
05873 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueConfirmByType(
05874   const TPlcMediaChannelID& aViewer,
05875   const TPlcEventTypeID& aTypeID,
05876   const PlcViewerAlarmQueueSelection aSelectionMode);
05877
05878 /// Create action 'VC alarm queue notification'.
05879 /// Alarm queue notification on the viewer client.
05880 /// @param  [in]  aViewer      Global viewer or viewer client no.
05881 /// @param  [in]  aNotification Alarm state notification.
05882 /// @param  [in]  aAlarmID     Instance ID of the alarm.
05883 /// @param  [in]  aTypeID      Type of the event.
05884 /// @param  [in]  aClientHost  Host from where the connection is done.
05885 /// @param  [in]  aClientType  Client type.
05886 /// @param  [in]  aClientAccount User account from where the connection is done.
05887 /// @return handle to action if the function succeeds or \c NULL if it fails.
05888 ///
05889 /// @attention Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
05890 ///            You can provide \c NULL pointer if you not use these fields.
05891 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueNotification(
05892   const TPlcMediaChannelID& aViewer,
05893   const PlcViewerAlarmState aNotification,
05894   const __int64& aAlarmID,
05895   const TPlcEventTypeID& aTypeID,
05896   const wchar_t* aClientHost,
05897   const PlcClientType* aClientType,
05898   const wchar_t* aClientAccount);
05899
05900 /// Create action 'VC alarm queue remove'.
05901 /// Remove alarm from the queue on the viewer client.
05902 /// @param  [in]  aViewer      Global viewer or viewer client no.
05903 /// @param  [in]  aSelectionMode Selection mode.
05904 /// @return handle to action if the function succeeds or \c NULL if it fails.
05905 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueRemove(
05906   const TPlcMediaChannelID& aViewer,
05907   const PlcViewerAlarmQueueSelection aSelectionMode);
05908
05909 /// Create action 'VC alarm queue remove by instance'.
05910 /// Remove alarm from the queue on the viewer client.
05911 /// @param  [in]  aViewer      Global viewer or viewer client no.
05912 /// @param  [in]  aAlarmID     Instance ID of the alarm.
05913 /// @return handle to action if the function succeeds or \c NULL if it fails.
05914 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueRemoveByInstance(
05915   const TPlcMediaChannelID& aViewer,
05916   const __int64& aAlarmID);
05917
05918 /// Create action 'VC alarm queue remove by type'.
05919 /// Remove alarm of specific type from the queue on the viewer client.
05920 /// @param  [in]  aViewer      Global viewer or viewer client no.
05921 /// @param  [in]  aTypeID      Type of the event.
05922 /// @param  [in]  aSelectionMode Selection mode.
05923 /// @return handle to action if the function succeeds or \c NULL if it fails.
05924 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueRemoveByType(
05925   const TPlcMediaChannelID& aViewer,
05926   const TPlcEventTypeID& aTypeID,
05927   const PlcViewerAlarmQueueSelection aSelectionMode);
05928
05929 /// Create action 'VC alarm queue select'.
05930 /// Select alarm from the queue on the viewer client.
05931 /// @param  [in]  aViewer      Global viewer or viewer client no.
05932 /// @param  [in]  aSelectionMode Selection mode.
05933 /// @return handle to action if the function succeeds or \c NULL if it fails.
05934 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueSelect(
05935   const TPlcMediaChannelID& aViewer,
05936   const PlcViewerAlarmQueueSelection aSelectionMode);
05937
05938 /// Create action 'VC alarm queue select by instance'.
05939 /// Select alarm from the queue on the viewer client.
05940 /// @param  [in]  aViewer      Global viewer or viewer client no.
05941 /// @param  [in]  aAlarmID     Instance ID of the alarm.
05942 /// @return handle to action if the function succeeds or \c NULL if it fails.
05943 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueSelectByInstance(
05944   const TPlcMediaChannelID& aViewer,
05945   const __int64& aAlarmID);
05946
05947 /// Create action 'VC alarm queue select by type'.
05948 /// Select alarm of specific type from the queue on the viewer client.
05949 /// @param  [in]  aViewer      Global viewer or viewer client no.
05950 /// @param  [in]  aTypeID      Type of the event.
05951 /// @param  [in]  aSelectionMode Selection mode.
05952 /// @return handle to action if the function succeeds or \c NULL if it fails.
05953 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAlarmQueueSelectByType(
05954   const TPlcMediaChannelID& aViewer,
05955   const TPlcEventTypeID& aTypeID,
05956   const PlcViewerAlarmQueueSelection aSelectionMode);
05957
05958 /// Create action 'VCA set armed'.
05959 /// Send this action to notify VCA to be armed or disarmed.
05960 /// @param  [in]  aChannel     Channel.
05961 /// @param  [in]  aSensorType  Sensor type.
05962 /// @param  [in]  aArmed       Armed (true) or disarmed (false)
05963 /// @return handle to action if the function succeeds or \c NULL if it fails.
05964 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCASetArmed(
05965   const TPlcMediaChannelID& aChannel,
05966   const VideoSensorKind aSensorType,
05967   const bool aArmed);
05968
05969 /// Create action 'VCA status answer'.
05970 /// This action will be sent in response to VCA status request.
05971 /// @param  [in]  aChannel     Channel.
05972 /// @param  [in]  aSensorType  Sensor type.
05973 /// @param  [in]  aArmed       Armed (true) or disarmed (false)
05974 /// @return handle to action if the function succeeds or \c NULL if it fails.
05975 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAStatusAnswer(
05976   const TPlcMediaChannelID& aChannel,
05977   const VideoSensorKind aSensorType,
05978   const bool aArmed);
05979
05980 /// Create action 'VCA status request'.
05981 /// Send this action to request status of VCA. As response VCA will send VCA status answer.
05982 /// @param  [in]  aChannel     Channel.
05983 /// @param  [in]  aSensorType  Sensor type.
05984 /// @return handle to action if the function succeeds or \c NULL if it fails.
05985 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCAStatusRequest(
05986   const TPlcMediaChannelID& aChannel,
05987   const VideoSensorKind aSensorType);
05988
05989 /// Create action 'VC change scene by name'.
05990 /// Viewer client change scene by name.
05991 /// @param  [in]  aViewer      Global viewer or viewer client no.
05992 /// @param  [in]  aScene       Scene name.
05993 /// @return handle to action if the function succeeds or \c NULL if it fails.
05994 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCChangeSceneByName(
05995   const TPlcMediaChannelID& aViewer,
05996   const wchar_t* aScene);
05997
05998 /// Create action 'VC clear scene by name'.
05999 /// Viewer client clear scene by name.
06000 /// @param  [in]  aViewer      Global viewer or viewer client no.
06001 /// @param  [in]  aScene       Scene name.
06002 /// @return handle to action if the function succeeds or \c NULL if it fails.
06003 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCClearSceneByName(
06004   const TPlcMediaChannelID& aViewer,
06005   const wchar_t* aScene);
06006
06007 /// Create action 'VC full mode'.
06008 /// Viewer client full mode.
06009 /// @param  [in]  aViewer      Global viewer or viewer client no.
06010 /// @param  [in]  aFullMode    Switch viewer client in full mode.
06011 /// @param  [in]  aSensitiveAreaEnabled Sensitive area enabled.
06012 /// @return handle to action if the function succeeds or \c NULL if it fails.
06013 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCFullMode(
06014   const TPlcMediaChannelID& aViewer,
06015   const bool aFullMode,
06016   const bool aSensitiveAreaEnabled);
06017
06018 /// Create action 'VC scene changed'.
06019 /// Viewer client scene changed.
06020 /// @param  [in]  aViewer      Global viewer or viewer client no.
06021 /// @param  [in]  aScene       Scene name.
06022 /// @return handle to action if the function succeeds or \c NULL if it fails.
06023 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCSceneChanged(
06024   const TPlcMediaChannelID& aViewer,
06025   const wchar_t* aScene);
06026
06027 /// Create action 'VC set audio level'.
06028 /// Viewer client set audio level.
06029 /// @param  [in]  aViewer      Global viewer or viewer client no.
06030 /// @param  [in]  aAudioLevel  Audio level in range 0 (audio off) till 100 (max. volume).
06031 /// @return handle to action if the function succeeds or \c NULL if it fails.
06032 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCSetAudioLevel(
06033   const TPlcMediaChannelID& aViewer,
06034   const __int32 aAudioLevel);
06035
06036 /// Create action 'VC show viewer text'.
06037 /// Viewer client show viewer text.
06038 /// @param  [in]  aViewer      Global viewer or viewer client no.
06039 /// @param  [in]  aShowText    Show text in viewer client.
06040 /// @return handle to action if the function succeeds or \c NULL if it fails.
06041 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCShowViewerText(
06042   const TPlcMediaChannelID& aViewer,
06043   const bool aShowText);
06044
06045 /// Create action 'VC stretch mode'.
06046 /// Viewer client stretch mode.
06047 /// @param  [in]  aViewer      Global viewer or viewer client no.
06048 /// @param  [in]  aStretchMode Switch viewer client in stretch mode.
06049 /// @return handle to action if the function succeeds or \c NULL if it fails.
06050 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVCStretchMode(
06051   const TPlcMediaChannelID& aViewer,
06052   const bool aStretchMode);
06053
06054 /// Create action 'Video contrast detected'.
06055 /// This action will be fired when the contrast is detected in the video signal.
06056 /// @param  [in]  aChannel     Channel.
06057 /// @return handle to action if the function succeeds or \c NULL if it fails.
06058 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoContrastDetected(
06059   const TPlcMediaChannelID& aChannel);
06060
06061 /// Create action 'Video contrast failed'.
06062 /// This action will be fired when the contrast is lost in the video signal.
06063 /// @param  [in]  aChannel     Channel.
06064 /// @return handle to action if the function succeeds or \c NULL if it fails.
06065 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoContrastFailed(
06066   const TPlcMediaChannelID& aChannel);
06067
06068 /// Create action 'Video set image brightness'.
06069 /// Video set image brightness.
06070 /// @param  [in]  aChannel     Channel.
06071 /// @param  [in]  aSensorType  Sensor type.
06072 /// @param  [in]  aBrightness  Brightness.
06073 /// @return handle to action if the function succeeds or \c NULL if it fails.
06074 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoSetImageBrightness(
06075   const TPlcMediaChannelID& aChannel,
06076   const VideoSensorKind aSensorType,
06077   const __int32 aBrightness);
06078
06079 /// Create action 'Video set image contrast'.
06080 /// Video set image contrast.
06081 /// @param  [in]  aChannel     Channel.
06082 /// @param  [in]  aSensorType  Sensor type.
06083 /// @param  [in]  aContrast    Contrast.
06084 /// @return handle to action if the function succeeds or \c NULL if it fails.
06085 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoSetImageContrast(
06086   const TPlcMediaChannelID& aChannel,
06087   const VideoSensorKind aSensorType,
06088   const __int32 aContrast);
06089
06090 /// Create action 'Video set image saturation'.
06091 /// Video set image saturation.
06092 /// @param  [in]  aChannel     Channel.
06093 /// @param  [in]  aSensorType  Sensor type.
06094 /// @param  [in]  aSaturation  Saturation.
06095 /// @return handle to action if the function succeeds or \c NULL if it fails.
06096 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoSetImageSaturation(
06097   const TPlcMediaChannelID& aChannel,
06098   const VideoSensorKind aSensorType,
06099   const __int32 aSaturation);
06100
06101 /// Create action 'Video source has changed'.
06102 /// This action indicates the changes on the video input source.
06103 /// @param  [in]  aChannel     Channel.
06104 /// @param  [in]  aSignalNorm  New signal norm.
06105 /// @param  [in]  aSignalType  New signal type.
06106 /// @param  [in]  aInterlaceType New interlace type.
06107 /// @return handle to action if the function succeeds or \c NULL if it fails.
06108 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoSourceChanged(
06109   const TPlcMediaChannelID& aChannel,
06110   const VideoSignalNorm aSignalNorm,
06111   const VideoSignalType aSignalType,
06112   const VideoInterlaceType aInterlaceType);
06113
06114 /// Create action 'Video sync detected'.
06115 /// This action will be fired when the sync is detected in the video signal.
06116 /// @param  [in]  aChannel     Channel.
06117 /// @return handle to action if the function succeeds or \c NULL if it fails.
06118 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoSyncDetected(
06119   const TPlcMediaChannelID& aChannel);
06120
06121 /// Create action 'Video sync failed'.
06122 /// This action will be fired when the sync is lost in the video signal.
06123 /// @param  [in]  aChannel     Channel.
06124 /// @return handle to action if the function succeeds or \c NULL if it fails.
06125 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateVideoSyncFailed(
06126   const TPlcMediaChannelID& aChannel);
06127
06128 /// Create action 'Viewer change scene'.
06129 /// Viewer change scene.
06130 /// @param  [in]  aViewer      Global viewer or viewer client no.
06131 /// @return handle to action if the function succeeds or \c NULL if it fails.
06132 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerChangeScene(
06133   const TPlcMediaChannelID& aViewer);
06134
06135 /// Create action 'Viewer clear'.
06136 /// Clear viewer.
06137 /// @param  [in]  aViewer      Global viewer or viewer client no.
06138 /// @return handle to action if the function succeeds or \c NULL if it fails.
06139 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerClear(
06140   const TPlcMediaChannelID& aViewer);
06141
06142 /// Create action 'Viewer cleared'.
06143 /// Viewer cleared.
06144 /// @param  [in]  aViewer      Global viewer or viewer client no.
06145 /// @param  [in]  aClientHost  Host from where the connection is done.
06146 /// @param  [in]  aClientType  Client type.
06147 /// @param  [in]  aClientAccount User account from where the connection is done.
06148 /// @return handle to action if the function succeeds or \c NULL if it fails.
06149 ///
06150 /// @attention Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
06151 ///            You can provide \c NULL pointer if you not use these fields.
06152 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerCleared(
06153   const TPlcMediaChannelID& aViewer,
06154   const wchar_t* aClientHost,
06155   const PlcClientType* aClientType,
06156   const wchar_t* aClientAccount);
06157
06158 /// Create action 'Viewer clear scene'.
06159 /// Viewer clear scene.
06160 /// @param  [in]  aViewer      Global viewer or viewer client no.
06161 /// @return handle to action if the function succeeds or \c NULL if it fails.
06162 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerClearScene(
06163   const TPlcMediaChannelID& aViewer);
06164
06165 /// Create action 'Viewer clear text output'.
06166 /// Clear text output in the given viewer.
06167 /// @param  [in]  aViewer      Global viewer or viewer client no.
06168 /// @return handle to action if the function succeeds or \c NULL if it fails.
06169 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerClearTextOutput(
06170   const TPlcMediaChannelID& aViewer);
06171
06172 /// Create action 'Viewer connect'.
06173 /// Connect camera to the viewer.
06174 /// @param  [in]  aViewer      Global viewer or viewer client no.
06175 /// @param  [in]  aChannel     Channel.
06176 /// @param  [in]  aPlayMode    Viewer play mode.
06177 /// @return handle to action if the function succeeds or \c NULL if it fails.
06178 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerConnect(
06179   const TPlcMediaChannelID& aViewer,
06180   const TPlcMediaChannelID& aChannel,
06181   const PlcViewerPlayMode aPlayMode);
06182
06183 /// Create action 'Viewer connected'.
06184 /// Viewer connected to the camera.
06185 /// @param  [in]  aViewer      Global viewer or viewer client no.
06186 /// @param  [in]  aChannel     Channel.
06187 /// @param  [in]  aPlayMode    Viewer play mode.
06188 /// @param  [in]  aClientHost  Host from where the connection is done.
06189 /// @param  [in]  aClientType  Client type.
06190 /// @param  [in]  aClientAccount User account from where the connection is done.
06191 /// @return handle to action if the function succeeds or \c NULL if it fails.
06192 ///
06193 /// @attention Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
06194 ///            You can provide \c NULL pointer if you not use these fields.
06195 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerConnected(
06196   const TPlcMediaChannelID& aViewer,
06197   const TPlcMediaChannelID& aChannel,
06198   const PlcViewerPlayMode aPlayMode,
06199   const wchar_t* aClientHost,
06200   const PlcClientType* aClientType,
06201   const wchar_t* aClientAccount);
06202
06203 /// Create action 'Viewer connect live'.
06204 /// Connect live camera to the viewer.
06205 /// @param  [in]  aViewer      Global viewer or viewer client no.
06206 /// @param  [in]  aChannel     Channel.
06207 /// @return handle to action if the function succeeds or \c NULL if it fails.
06208 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerConnectLive(
06209   const TPlcMediaChannelID& aViewer,
06210   const TPlcMediaChannelID& aChannel);
06211
06212 /// Create action 'Viewer export picture'.
06213 /// Viewer export picture.
06214 /// @param  [in]  aViewer      Global viewer or viewer client no.
06215 /// @param  [in]  aFilePath    File path (local or UNC). GSCView default path is used if left empty.
06216 /// @return handle to action if the function succeeds or \c NULL if it fails.
06217 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerExportPicture(
06218   const TPlcMediaChannelID& aViewer,
06219   const wchar_t* aFilePath);
06220
06221 /// Create action 'Viewer jump by time'.
06222 /// Viewer jump by time.
06223 /// @param  [in]  aViewer      Global viewer or viewer client no.
06224 /// @param  [in]  aChannel     Channel.
06225 /// @param  [in]  aPlayMode    Viewer play mode.
06226 /// @param  [in]  aTimeInSec   Time to jump in seconds. Use negative values to jump in past.
06227 /// @return handle to action if the function succeeds or \c NULL if it fails.
06228 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerJumpByTime(
06229   const TPlcMediaChannelID& aViewer,
06230   const TPlcMediaChannelID& aChannel,
06231   const PlcViewerPlayMode aPlayMode,
06232   const __int32 aTimeInSec);
06233
06234 /// Create action 'Viewer maximize'.
06235 /// Viewer maximize.
06236 /// @param  [in]  aViewer      Global viewer or viewer client no.
06237 /// @param  [in]  aMaximize    Maximize.
06238 /// @return handle to action if the function succeeds or \c NULL if it fails.
06239 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerMaximize(
06240   const TPlcMediaChannelID& aViewer,
06241   const bool aMaximize);
06242
06243 /// Create action 'Viewer play from time'.
06244 /// Viewer play from time.
06245 /// @param  [in]  aViewer      Global viewer or viewer client no.
06246 /// @param  [in]  aChannel     Channel.
06247 /// @param  [in]  aPlayMode    Viewer play mode.
06248 /// @param  [in]  aTime        Time to play from.
06249 /// @return handle to action if the function succeeds or \c NULL if it fails.
06250 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerPlayFromTime(
06251   const TPlcMediaChannelID& aViewer,
06252   const TPlcMediaChannelID& aChannel,
06253   const PlcViewerPlayMode aPlayMode,
06254   const TGLibDateTime& aTime);
06255
06256 /// Create action 'Viewer play mode changed'.
06257 /// Viewer play mode changed.
06258 /// @param  [in]  aViewer      Global viewer or viewer client no.
06259 /// @param  [in]  aChannel     Channel.
06260 /// @param  [in]  aPlayMode    Viewer play mode.
06261 /// @param  [in]  aChannelTime Channel time.
06262 /// @param  [in]  aClientHost  Host from where the connection is done.
06263 /// @param  [in]  aClientType  Client type.
06264 /// @param  [in]  aClientAccount User account from where the connection is done.
06265 /// @return handle to action if the function succeeds or \c NULL if it fails.
06266 ///
06267 /// @attention Following parameters are optional:  aChannelTime. aClientHost. aClientType. aClientAccount. \par
06268 ///            You can provide \c NULL pointer if you not use these fields.
06269 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerPlayModeChanged(
06270   const TPlcMediaChannelID& aViewer,
06271   const TPlcMediaChannelID& aChannel,
06272   const PlcViewerPlayMode aPlayMode,
06273   const TGLibDateTime* aChannelTime,
06274   const wchar_t* aClientHost,
06275   const PlcClientType* aClientType,
06276   const wchar_t* aClientAccount);
06277
06278 /// Create action 'Viewer print picture'.
06279 /// Viewer print picture.
06280 /// @param  [in]  aViewer      Global viewer or viewer client no.
06281 /// @return handle to action if the function succeeds or \c NULL if it fails.
06282 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerPrintPicture(
06283   const TPlcMediaChannelID& aViewer);
06284
06285 /// Create action 'Viewer select'.
06286 /// Select viewer.
06287 /// @param  [in]  aViewer      Global viewer or viewer client no.
06288 /// @return handle to action if the function succeeds or \c NULL if it fails.
06289 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerSelect(
06290   const TPlcMediaChannelID& aViewer);
06291
06292 /// Create action 'Viewer selection changed'.
06293 /// Viewer selection was changed.
06294 /// @param  [in]  aViewer      Global viewer or viewer client no.
06295 /// @param  [in]  aChannel     Channel.
06296 /// @param  [in]  aPlayMode    Viewer play mode.
06297 /// @param  [in]  aClientHost  Host from where the connection is done.
06298 /// @param  [in]  aClientType  Client type.
06299 /// @param  [in]  aClientAccount User account from where the connection is done.
06300 /// @return handle to action if the function succeeds or \c NULL if it fails.
06301 ///
06302 /// @attention Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
06303 ///            You can provide \c NULL pointer if you not use these fields.
06304 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerSelectionChanged(
06305   const TPlcMediaChannelID& aViewer,
06306   const TPlcMediaChannelID& aChannel,
06307   const PlcViewerPlayMode aPlayMode,
06308   const wchar_t* aClientHost,
06309   const PlcClientType* aClientType,
06310   const wchar_t* aClientAccount);
06311
06312 /// Create action 'Viewer set play mode'.
06313 /// Set play mode of the viewer.
06314 /// @param  [in]  aViewer      Global viewer or viewer client no.
06315 /// @param  [in]  aPlayMode    Viewer play mode.
06316 /// @param  [in]  aPlaySpeed   Optional play speed parameter.
06317 /// @return handle to action if the function succeeds or \c NULL if it fails.
06318 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerSetPlayMode(
06319   const TPlcMediaChannelID& aViewer,
06320   const PlcViewerPlayMode aPlayMode,
06321   const __int32 aPlaySpeed);
06322
06323 /// Create action 'Viewer show alarm by instance'.
06324 /// Show alarm in viewer using alarm instance ID.
06325 /// @param  [in]  aViewer      Global viewer or viewer client no.
06326 /// @param  [in]  aAlarmID     Instance ID of the alarm.
06327 /// @param  [in]  aPlayMode    Viewer alarm's play mode.
06328 /// @return handle to action if the function succeeds or \c NULL if it fails.
06329 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerShowAlarmByInstance(
06330   const TPlcMediaChannelID& aViewer,
06331   const __int64& aAlarmID,
06332   const PlcViewerAlarmPlayMode aPlayMode);
06333
06334 /// Create action 'Viewer show alarm by key'.
06335 /// Show alarm in viewer using alarm foreign key.
06336 /// @param  [in]  aViewer      Global viewer or viewer client no.
06337 /// @param  [in]  aForeignKey  Foreign key used to start the alarm.
06338 /// @param  [in]  aPlayMode    Viewer alarm's play mode.
06339 /// @return handle to action if the function succeeds or \c NULL if it fails.
06340 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerShowAlarmByKey(
06341   const TPlcMediaChannelID& aViewer,
06342   const __int64& aForeignKey,
06343   const PlcViewerAlarmPlayMode aPlayMode);
06344
06345 /// Create action 'Viewer show alarm by type'.
06346 /// Show alarm in viewer using alarm type and optional foreign key.
06347 /// @param  [in]  aViewer      Global viewer or viewer client no.
06348 /// @param  [in]  aTypeID      Type of the alarm.
06349 /// @param  [in]  aForeignKey  Foreign key used to start the alarm.
06350 /// @param  [in]  aPlayMode    Viewer alarm's play mode.
06351 /// @return handle to action if the function succeeds or \c NULL if it fails.
06352 ///
06353 /// @attention Following parameters are optional:  aForeignKey. \par
06354 ///            You can provide \c NULL pointer if you not use these fields.
06355 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerShowAlarmByType(
06356   const TPlcMediaChannelID& aViewer,
06357   const TPlcEventTypeID& aTypeID,
06358   const __int64* aForeignKey,
06359   const PlcViewerAlarmPlayMode aPlayMode);
06360
06361 /// Create action 'Viewer change sync audio/video'.
06362 /// Viewer change sync audio/video.
06363 /// @param  [in]  aViewer      Global viewer or viewer client no.
06364 /// @param  [in]  aEnableSync  Enable audio/video sync.
06365 /// @return handle to action if the function succeeds or \c NULL if it fails.
06366 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerSyncAudioAndVideo(
06367   const TPlcMediaChannelID& aViewer,
06368   const bool aEnableSync);
06369
06370 /// Create action 'Viewer text output'.
06371 /// Display free string in the given viewer.
06372 /// @param  [in]  aViewer      Global viewer or viewer client no.
06373 /// @param  [in]  aText        Text string to display.
06374 /// @return handle to action if the function succeeds or \c NULL if it fails.
06375 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateViewerTextOutput(
06376   const TPlcMediaChannelID& aViewer,
06377   const wchar_t* aText);
06378
06379 /// Create action 'Watchdog activate'.
06380 /// Activate watchdog.
06381 /// @return handle to action if the function succeeds or \c NULL if it fails.
06382 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateWatchdogActivate();
06383
06384 /// Create action 'Watchdog deactivate'.
06385 /// Deactivate watchdog.
06386 /// @return handle to action if the function succeeds or \c NULL if it fails.
06387 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateWatchdogDeactivate();
06388
06389 /// Create action 'Watchdog trigger'.
06390 /// Trigger watchdog.
06391 /// @return handle to action if the function succeeds or \c NULL if it fails.
06392 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateWatchdogTrigger();
06393
06394 /// Create action 'Zoom in'.
06395 /// Zoom camera in.
06396 /// @param  [in]  aCamera      PTZ head.
06397 /// @param  [in]  aSpeed       Zoom speed.
06398 /// @return handle to action if the function succeeds or \c NULL if it fails.
06399 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateZoomIn(
06400   const TPlcMediaChannelID& aCamera,
06401   const __int32 aSpeed);
06402
06403 /// Create action 'Zoom out'.
06404 /// Zoom camera out.
06405 /// @param  [in]  aCamera      PTZ head.
06406 /// @param  [in]  aSpeed       Zoom speed.
06407 /// @return handle to action if the function succeeds or \c NULL if it fails.
06408 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateZoomOut(
06409   const TPlcMediaChannelID& aCamera,
06410   const __int32 aSpeed);
06411
06412 /// Create action 'Zoom stop'.
06413 /// Stop camera zoom.
06414 /// @param  [in]  aCamera      PTZ head.
06415 /// @return handle to action if the function succeeds or \c NULL if it fails.
06416 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateZoomStop(
06417   const TPlcMediaChannelID& aCamera);
06418
06419 ///
06420 /// Deprecated functions
06421
06422 /// Create action 'Event started'.
06423 /// Event has started.\par
06424 /// This action is deprecated,
06425 /// use \ref GscAct_CreateEventStartedEx instead.
06426 ///
06427 /// @param  [in]  aEventID     Instance ID of the event.
06428 /// @param  [in]  aTypeID      Type of the event.
06429 /// @return handle to action if the function succeeds or \c NULL if it fails.
06430 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateEventStarted(
06431   const __int64& aEventID,
06432   const TPlcEventTypeID& aTypeID);
06433
06434 /// Create action 'Sensor inhibit video alarm'.
06435 /// This action will be fired when the motion in inhibit area is detected.\par
06436 /// This action is deprecated,
06437 /// use \ref GscAct_CreateSensorInhibitVideoAlarmEx instead.
06438 ///
06439 /// @param  [in]  aChannel     Channel.
06440 /// @param  [in]  aSensorType  Sensor type.
06441 /// @param  [in]  aADArea      AD alarm area.
06442 /// @param  [in]  aADCell      AD cell nr.
06443 /// @param  [in]  aVMDGroup    VMD alarm group.
06444 /// @param  [in]  aVMDZone     VMD zone nr.
06445 /// @return handle to action if the function succeeds or \c NULL if it fails.
06446 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSensorInhibitVideoAlarm(
06447   const TPlcMediaChannelID& aChannel,
06448   const VideoSensorKind aSensorType,
06449   const ADArea* aADArea,
06450   const __int32* aADCell,
06451   const VMDGroup* aVMDGroup,
06452   const __int32* aVMDZone);
06453
06454 /// Create action 'Sensor video alarm'.
06455 /// This action will be fired when video alarm is detected.\par
06456 /// This action is deprecated,
06457 /// use \ref GscAct_CreateSensorVideoAlarmEx instead.
06458 ///
06459 /// @param  [in]  aChannel     Channel.
06460 /// @param  [in]  aSensorType  Sensor type.
06461 /// @param  [in]  aADArea      AD alarm area.
06462 /// @param  [in]  aADCell      AD cell nr.
06463 /// @param  [in]  aVMDGroup    VMD alarm group.
06464 /// @param  [in]  aVMDZone     VMD zone nr.
06465 /// @return handle to action if the function succeeds or \c NULL if it fails.
06466 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateSensorVideoAlarm(
06467   const TPlcMediaChannelID& aChannel,
06468   const VideoSensorKind aSensorType,
06469   const ADArea* aADArea,
06470   const __int32* aADCell,
06471   const VMDGroup* aVMDGroup,
06472   const __int32* aVMDZone);
06473
06474 /// Create action 'Start event'.
06475 /// Start event.\par
06476 /// This action is deprecated,
06477 /// use \ref GscAct_CreateStartEventEx instead.
06478 ///
06479 /// @param  [in]  aTypeID      Type of the event.
06480 /// @return handle to action if the function succeeds or \c NULL if it fails.
06481 GSCACTDLLCALL HGscAction  __stdcall GscAct_CreateStartEvent(
06482   const TPlcEventTypeID& aTypeID);
06483
06484 /// \} end of group GscPlcCreate
06485
06486 /////////////////////////////////////////////////////////
06487 /// Decode functions
06488 /////////////////////////////////////////////////////////
06489
06490 /// \addtogroup GscPlcDecode
06491 /// \{
06492
06493 /// Decode action 'ABC connect'.
06494 /// Connect audio back channel.
06495 /// @param  [in]  anAction     Handle to action to decode.
06496 /// @param  [out] aAddress     Address of the remote server.
06497 /// @return \c true if the function succeeds, \c false otherwise.
06498 ///         To get extended error information, call \ref GscAct_GetLastError.
06499 GSCACTDLLCALL bool        __stdcall GscAct_DecodeABCConnect(
06500   ConstHGscAction anAction,
06501   const wchar_t*& aAddress);
06502
06503 /// Decode action 'ABC disconnect'.
06504 /// Disconnect audio back channel.
06505 /// @param  [in]  anAction     Handle to action to decode.
06506 /// @return \c true if the function succeeds, \c false otherwise.
06507 ///         To get extended error information, call \ref GscAct_GetLastError.
06508 GSCACTDLLCALL bool        __stdcall GscAct_DecodeABCDisconnect(
06509   ConstHGscAction anAction);
06510
06511 /// Decode action 'ABC play file'.
06512 /// Play file on audio back channel.
06513 /// @param  [in]  anAction     Handle to action to decode.
06514 /// @param  [out] aFileID      File ID.
06515 /// @param  [out] aFileName    Name of the file.
06516 /// @param  [out] aAutoRepeat  Repeat file automatically
06517 /// @return \c true if the function succeeds, \c false otherwise.
06518 ///         To get extended error information, call \ref GscAct_GetLastError.
06519 GSCACTDLLCALL bool        __stdcall GscAct_DecodeABCPlayFile(
06520   ConstHGscAction anAction,
06521   __int64& aFileID,
06522   const wchar_t*& aFileName,
06523   bool& aAutoRepeat);
06524
06525 /// Decode action 'Abort all auto backups'.
06526 /// Abort all auto backups.
06527 /// @param  [in]  anAction     Handle to action to decode.
06528 /// @return \c true if the function succeeds, \c false otherwise.
06529 ///         To get extended error information, call \ref GscAct_GetLastError.
06530 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAbortAllAutoBackups(
06531   ConstHGscAction anAction);
06532
06533 /// Decode action 'Abort auto backup'.
06534 /// Abort auto backup.
06535 /// @param  [in]  anAction     Handle to action to decode.
06536 /// @param  [out] aSchedule    Schedule.
06537 /// @return \c true if the function succeeds, \c false otherwise.
06538 ///         To get extended error information, call \ref GscAct_GetLastError.
06539 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAbortAutoBackup(
06540   ConstHGscAction anAction,
06541   TPlcResourceID& aSchedule);
06542
06543 /// Decode action 'ACS access denied'.
06544 /// ACS access denied.
06545 /// @param  [in]  anAction     Handle to action to decode.
06546 /// @param  [out] aACSName     ACS name.
06547 /// @param  [out] aACSNo       ACS no.
06548 /// @param  [out] aAccount     Account no.
06549 /// @param  [out] aBancCode    Bank code.
06550 /// @param  [out] aCardNo      Card no.
06551 /// @param  [out] aTimeStamp   Time stamp.
06552 /// @param  [out] aReason      Reason.
06553 /// @return \c true if the function succeeds, \c false otherwise.
06554 ///         To get extended error information, call \ref GscAct_GetLastError.
06555 ///
06556 /// @warning   Following parameters are optional:  aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp. aReason. \par
06557 ///            Values returned in these fields can be \c NULL pointers.
06558 GSCACTDLLCALL bool        __stdcall GscAct_DecodeACSAccessDenied(
06559   ConstHGscAction anAction,
06560   const wchar_t*& aACSName,
06561   const __int32*& aACSNo,
06562   const __int64*& aAccount,
06563   const __int64*& aBancCode,
06564   const wchar_t*& aCardNo,
06565   const TGLibDateTime*& aTimeStamp,
06566   const __int32*& aReason);
06567
06568 /// Decode action 'ACS access granted'.
06569 /// ACS access granted.
06570 /// @param  [in]  anAction     Handle to action to decode.
06571 /// @param  [out] aACSName     ACS name.
06572 /// @param  [out] aACSNo       ACS no.
06573 /// @param  [out] aAccount     Account no.
06574 /// @param  [out] aBancCode    Bank code.
06575 /// @param  [out] aCardNo      Card no.
06576 /// @param  [out] aTimeStamp   Time stamp.
06577 /// @return \c true if the function succeeds, \c false otherwise.
06578 ///         To get extended error information, call \ref GscAct_GetLastError.
06579 ///
06580 /// @warning   Following parameters are optional:  aACSNo. aAccount. aBancCode. aCardNo. aTimeStamp. \par
06581 ///            Values returned in these fields can be \c NULL pointers.
06582 GSCACTDLLCALL bool        __stdcall GscAct_DecodeACSAccessGranted(
06583   ConstHGscAction anAction,
06584   const wchar_t*& aACSName,
06585   const __int32*& aACSNo,
06586   const __int64*& aAccount,
06587   const __int64*& aBancCode,
06588   const wchar_t*& aCardNo,
06589   const TGLibDateTime*& aTimeStamp);
06590
06591 /// Decode action 'ACS raw answer'.
06592 /// ACS raw answer.
06593 /// @param  [in]  anAction     Handle to action to decode.
06594 /// @param  [out] aACSName     ACS name.
06595 /// @param  [out] aTimeStamp   Time stamp.
06596 /// @param  [out] aACSData     ACS answer.
06597 /// @return \c true if the function succeeds, \c false otherwise.
06598 ///         To get extended error information, call \ref GscAct_GetLastError.
06599 GSCACTDLLCALL bool        __stdcall GscAct_DecodeACSRawAnswer(
06600   ConstHGscAction anAction,
06601   const wchar_t*& aACSName,
06602   TGLibDateTime& aTimeStamp,
06603   const wchar_t*& aACSData);
06604
06605 /// Decode action 'ACS raw data'.
06606 /// ACS raw data.
06607 /// @param  [in]  anAction     Handle to action to decode.
06608 /// @param  [out] aACSName     ACS name.
06609 /// @param  [out] aTimeStamp   Time stamp.
06610 /// @param  [out] aACSData     ACS data.
06611 /// @return \c true if the function succeeds, \c false otherwise.
06612 ///         To get extended error information, call \ref GscAct_GetLastError.
06613 GSCACTDLLCALL bool        __stdcall GscAct_DecodeACSRawData(
06614   ConstHGscAction anAction,
06615   const wchar_t*& aACSName,
06616   TGLibDateTime& aTimeStamp,
06617   const wchar_t*& aACSData);
06618
06619 /// Decode action 'Activate external process'.
06620 /// Activate external process.
06621 /// @param  [in]  anAction     Handle to action to decode.
06622 /// @param  [out] aChannel     Channel.
06623 /// @param  [out] aTimeStamp   Time stamp.
06624 /// @param  [out] aExternalSystem External system to activate.
06625 /// @return \c true if the function succeeds, \c false otherwise.
06626 ///         To get extended error information, call \ref GscAct_GetLastError.
06627 GSCACTDLLCALL bool        __stdcall GscAct_DecodeActivateExternalProcess(
06628   ConstHGscAction anAction,
06629   TPlcMediaChannelID& aChannel,
06630   TGLibDateTime& aTimeStamp,
06631   VideoSensorKind& aExternalSystem);
06632
06633 /// Decode action 'ATM raw answer'.
06634 /// ATM raw answer.
06635 /// @param  [in]  anAction     Handle to action to decode.
06636 /// @param  [out] aATMName     ATM name.
06637 /// @param  [out] aTimeStamp   Time stamp.
06638 /// @param  [out] aATMData     ATM answer.
06639 /// @return \c true if the function succeeds, \c false otherwise.
06640 ///         To get extended error information, call \ref GscAct_GetLastError.
06641 GSCACTDLLCALL bool        __stdcall GscAct_DecodeATMRawAnswer(
06642   ConstHGscAction anAction,
06643   const wchar_t*& aATMName,
06644   TGLibDateTime& aTimeStamp,
06645   const wchar_t*& aATMData);
06646
06647 /// Decode action 'ATM raw data'.
06648 /// ATM raw data.
06649 /// @param  [in]  anAction     Handle to action to decode.
06650 /// @param  [out] aATMName     ATM name.
06651 /// @param  [out] aTimeStamp   Time stamp.
06652 /// @param  [out] aATMData     ATM data.
06653 /// @return \c true if the function succeeds, \c false otherwise.
06654 ///         To get extended error information, call \ref GscAct_GetLastError.
06655 GSCACTDLLCALL bool        __stdcall GscAct_DecodeATMRawData(
06656   ConstHGscAction anAction,
06657   const wchar_t*& aATMName,
06658   TGLibDateTime& aTimeStamp,
06659   const wchar_t*& aATMData);
06660
06661 /// Decode action 'ATM transaction'.
06662 /// ATM transaction.
06663 /// @param  [in]  anAction     Handle to action to decode.
06664 /// @param  [out] aATMName     ATM name.
06665 /// @param  [out] aNewTransaction New transaction.
06666 /// @param  [out] aPhotostep   Photostep.
06667 /// @param  [out] aATMNo       ATM no.
06668 /// @param  [out] aAccount     Account no.
06669 /// @param  [out] aBancCode    Bank code.
06670 /// @param  [out] aCardNo      Card no.
06671 /// @param  [out] aTAN1        TAN 1.
06672 /// @param  [out] aTAN2        TAN 2.
06673 /// @param  [out] aTimeStamp1  Time stamp 1.
06674 /// @param  [out] aTimeStamp2  Time stamp 2.
06675 /// @param  [out] aAmount      Amount.
06676 /// @param  [out] aCurrency    Currency.
06677 /// @return \c true if the function succeeds, \c false otherwise.
06678 ///         To get extended error information, call \ref GscAct_GetLastError.
06679 ///
06680 /// @warning   Following parameters are optional:  aATMNo. aAccount. aBancCode. aCardNo. aTAN1. aTAN2. aTimeStamp1. aTimeStamp2. aAmount. aCurrency. \par
06681 ///            Values returned in these fields can be \c NULL pointers.
06682 GSCACTDLLCALL bool        __stdcall GscAct_DecodeATMTransaction(
06683   ConstHGscAction anAction,
06684   const wchar_t*& aATMName,
06685   bool& aNewTransaction,
06686   __int32& aPhotostep,
06687   const __int32*& aATMNo,
06688   const __int64*& aAccount,
06689   const __int64*& aBancCode,
06690   const wchar_t*& aCardNo,
06691   const __int64*& aTAN1,
06692   const __int64*& aTAN2,
06693   const TGLibDateTime*& aTimeStamp1,
06694   const TGLibDateTime*& aTimeStamp2,
06695   const double*& aAmount,
06696   const wchar_t*& aCurrency);
06697
06698 /// Decode action 'Auto backup capacity warning'.
06699 /// Auto backup capacity monitoring: capacity warning.
06700 /// @param  [in]  anAction     Handle to action to decode.
06701 /// @param  [out] aWarning     Warning.
06702 /// @param  [out] aDestination Destination.
06703 /// @param  [out] aTotalCapacity Total capacity.
06704 /// @param  [out] aFreeCapacity Free capacity.
06705 /// @param  [out] aAllocatedByGbf Allocated by GBF.
06706 /// @param  [out] aPercentFree Percent free.
06707 /// @param  [out] aPercentAllocated Percent allocated.
06708 /// @param  [out] aPercentAllocatedByGbf Percent allocated by GBF.
06709 /// @return \c true if the function succeeds, \c false otherwise.
06710 ///         To get extended error information, call \ref GscAct_GetLastError.
06711 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupCapacityMonitoringCapacityWarning(
06712   ConstHGscAction anAction,
06713   ABCapacityWarning& aWarning,
06714   TPlcResourceID& aDestination,
06715   __int64& aTotalCapacity,
06716   __int64& aFreeCapacity,
06717   __int64& aAllocatedByGbf,
06718   __int32& aPercentFree,
06719   __int32& aPercentAllocated,
06720   __int32& aPercentAllocatedByGbf);
06721
06722 /// Decode action 'Auto backup capacity file auto deleted'.
06723 /// Auto backup capacity monitoring: file auto deleted.
06724 /// @param  [in]  anAction     Handle to action to decode.
06725 /// @param  [out] aWarning     Warning.
06726 /// @param  [out] aDestination Destination.
06727 /// @param  [out] aTotalCapacity Total capacity.
06728 /// @param  [out] aFreeCapacity Free capacity.
06729 /// @param  [out] aAllocatedByGbf Allocated by GBF.
06730 /// @param  [out] aPercentFree Percent free.
06731 /// @param  [out] aPercentAllocated Percent allocated.
06732 /// @param  [out] aPercentAllocatedByGbf Percent allocated by GBF.
06733 /// @param  [out] aFileSize    File size.
06734 /// @param  [out] aFileName    File name.
06735 /// @return \c true if the function succeeds, \c false otherwise.
06736 ///         To get extended error information, call \ref GscAct_GetLastError.
06737 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupCapacityMonitoringFileAutoDeleted(
06738   ConstHGscAction anAction,
06739   ABCapacityWarning& aWarning,
06740   TPlcResourceID& aDestination,
06741   __int64& aTotalCapacity,
06742   __int64& aFreeCapacity,
06743   __int64& aAllocatedByGbf,
06744   __int32& aPercentFree,
06745   __int32& aPercentAllocated,
06746   __int32& aPercentAllocatedByGbf,
06747   __int64& aFileSize,
06748   const wchar_t*& aFileName);
06749
06750 /// Decode action 'Auto backup capacity out of disk space'.
06751 /// Auto backup capacity monitoring: out of disk space.
06752 /// @param  [in]  anAction     Handle to action to decode.
06753 /// @param  [out] aWarning     Warning.
06754 /// @param  [out] aDestination Destination.
06755 /// @param  [out] aTotalCapacity Total capacity.
06756 /// @param  [out] aFreeCapacity Free capacity.
06757 /// @param  [out] aAllocatedByGbf Allocated by GBF.
06758 /// @param  [out] aPercentFree Percent free.
06759 /// @param  [out] aPercentAllocated Percent allocated.
06760 /// @param  [out] aPercentAllocatedByGbf Percent allocated by GBF.
06761 /// @return \c true if the function succeeds, \c false otherwise.
06762 ///         To get extended error information, call \ref GscAct_GetLastError.
06763 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupCapacityMonitoringOutOfDiskSpace(
06764   ConstHGscAction anAction,
06765   ABCapacityWarning& aWarning,
06766   TPlcResourceID& aDestination,
06767   __int64& aTotalCapacity,
06768   __int64& aFreeCapacity,
06769   __int64& aAllocatedByGbf,
06770   __int32& aPercentFree,
06771   __int32& aPercentAllocated,
06772   __int32& aPercentAllocatedByGbf);
06773
06774 /// Decode action 'Auto backup file done'.
06775 /// Auto backup progress notification: file done.
06776 /// @param  [in]  anAction     Handle to action to decode.
06777 /// @param  [out] aSchedule    Schedule.
06778 /// @param  [out] aStartTime   Start time, empty during event backup.
06779 /// @param  [out] aEffectiveStartTime Effective schedule start time.
06780 /// @param  [out] aOperationCount Operation count.
06781 /// @param  [out] aTimerStart  Timer start.
06782 /// @param  [out] aOperationIndex Operation index.
06783 /// @param  [out] aOperationStartTime Operation start time.
06784 /// @param  [out] aSource      Source.
06785 /// @param  [out] aDestination Destination.
06786 /// @param  [out] aFileSizeLimit File size limit.
06787 /// @param  [out] aBandWidthLimit Band width limit.
06788 /// @param  [out] aFileIndex   File index.
06789 /// @param  [out] aFileName    File name.
06790 /// @param  [out] aFileSize    File size.
06791 /// @return \c true if the function succeeds, \c false otherwise.
06792 ///         To get extended error information, call \ref GscAct_GetLastError.
06793 ///
06794 /// @warning   Following parameters are optional:  aStartTime. \par
06795 ///            Values returned in these fields can be \c NULL pointers.
06796 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupFileDone(
06797   ConstHGscAction anAction,
06798   TPlcResourceID& aSchedule,
06799   const TGLibDateTime*& aStartTime,
06800   TGLibDateTime& aEffectiveStartTime,
06801   __int32& aOperationCount,
06802   bool& aTimerStart,
06803   __int32& aOperationIndex,
06804   TGLibDateTime& aOperationStartTime,
06805   TPlcResourceID& aSource,
06806   TPlcResourceID& aDestination,
06807   __int64& aFileSizeLimit,
06808   __int64& aBandWidthLimit,
06809   __int32& aFileIndex,
06810   const wchar_t*& aFileName,
06811   __int64& aFileSize);
06812
06813 /// Decode action 'Auto backup file progress'.
06814 /// Auto backup progress notification: file progress.
06815 /// @param  [in]  anAction     Handle to action to decode.
06816 /// @param  [out] aSchedule    Schedule.
06817 /// @param  [out] aStartTime   Start time, empty during event backup.
06818 /// @param  [out] aEffectiveStartTime Effective schedule start time.
06819 /// @param  [out] aOperationCount Operation count.
06820 /// @param  [out] aTimerStart  Timer start.
06821 /// @param  [out] aOperationIndex Operation index.
06822 /// @param  [out] aOperationStartTime Operation start time.
06823 /// @param  [out] aSource      Source.
06824 /// @param  [out] aDestination Destination.
06825 /// @param  [out] aFileSizeLimit File size limit.
06826 /// @param  [out] aBandWidthLimit Band width limit.
06827 /// @param  [out] aFileIndex   File index.
06828 /// @param  [out] aFileName    File name.
06829 /// @param  [out] aFileSize    File size.
06830 /// @return \c true if the function succeeds, \c false otherwise.
06831 ///         To get extended error information, call \ref GscAct_GetLastError.
06832 ///
06833 /// @warning   Following parameters are optional:  aStartTime. \par
06834 ///            Values returned in these fields can be \c NULL pointers.
06835 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupFileProgress(
06836   ConstHGscAction anAction,
06837   TPlcResourceID& aSchedule,
06838   const TGLibDateTime*& aStartTime,
06839   TGLibDateTime& aEffectiveStartTime,
06840   __int32& aOperationCount,
06841   bool& aTimerStart,
06842   __int32& aOperationIndex,
06843   TGLibDateTime& aOperationStartTime,
06844   TPlcResourceID& aSource,
06845   TPlcResourceID& aDestination,
06846   __int64& aFileSizeLimit,
06847   __int64& aBandWidthLimit,
06848   __int32& aFileIndex,
06849   const wchar_t*& aFileName,
06850   __int64& aFileSize);
06851
06852 /// Decode action 'Auto backup file started'.
06853 /// Auto backup progress notification: file started.
06854 /// @param  [in]  anAction     Handle to action to decode.
06855 /// @param  [out] aSchedule    Schedule.
06856 /// @param  [out] aStartTime   Start time, empty during event backup.
06857 /// @param  [out] aEffectiveStartTime Effective schedule start time.
06858 /// @param  [out] aOperationCount Operation count.
06859 /// @param  [out] aTimerStart  Timer start.
06860 /// @param  [out] aOperationIndex Operation index.
06861 /// @param  [out] aOperationStartTime Operation start time.
06862 /// @param  [out] aSource      Source.
06863 /// @param  [out] aDestination Destination.
06864 /// @param  [out] aFileSizeLimit File size limit.
06865 /// @param  [out] aBandWidthLimit Band width limit.
06866 /// @param  [out] aFileIndex   File index.
06867 /// @param  [out] aFileName    File name.
06868 /// @return \c true if the function succeeds, \c false otherwise.
06869 ///         To get extended error information, call \ref GscAct_GetLastError.
06870 ///
06871 /// @warning   Following parameters are optional:  aStartTime. \par
06872 ///            Values returned in these fields can be \c NULL pointers.
06873 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupFileStarted(
06874   ConstHGscAction anAction,
06875   TPlcResourceID& aSchedule,
06876   const TGLibDateTime*& aStartTime,
06877   TGLibDateTime& aEffectiveStartTime,
06878   __int32& aOperationCount,
06879   bool& aTimerStart,
06880   __int32& aOperationIndex,
06881   TGLibDateTime& aOperationStartTime,
06882   TPlcResourceID& aSource,
06883   TPlcResourceID& aDestination,
06884   __int64& aFileSizeLimit,
06885   __int64& aBandWidthLimit,
06886   __int32& aFileIndex,
06887   const wchar_t*& aFileName);
06888
06889 /// Decode action 'Auto backup operation done'.
06890 /// Auto backup progress notification: operation done.
06891 /// @param  [in]  anAction     Handle to action to decode.
06892 /// @param  [out] aSchedule    Schedule.
06893 /// @param  [out] aStartTime   Start time, empty during event backup.
06894 /// @param  [out] aEffectiveStartTime Effective schedule start time.
06895 /// @param  [out] aOperationCount Operation count.
06896 /// @param  [out] aTimerStart  Timer start.
06897 /// @param  [out] aOperationIndex Operation index.
06898 /// @param  [out] aOperationStartTime Operation start time.
06899 /// @param  [out] aOperationStopTime Operation stop time.
06900 /// @param  [out] aSource      Source.
06901 /// @param  [out] aDestination Destination.
06902 /// @param  [out] aFileSizeLimit File size limit.
06903 /// @param  [out] aBandWidthLimit Band width limit.
06904 /// @param  [out] aOperationErrorCode Operation error code.
06905 /// @return \c true if the function succeeds, \c false otherwise.
06906 ///         To get extended error information, call \ref GscAct_GetLastError.
06907 ///
06908 /// @warning   Following parameters are optional:  aStartTime. aOperationErrorCode. \par
06909 ///            Values returned in these fields can be \c NULL pointers.
06910 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupOperationDone(
06911   ConstHGscAction anAction,
06912   TPlcResourceID& aSchedule,
06913   const TGLibDateTime*& aStartTime,
06914   TGLibDateTime& aEffectiveStartTime,
06915   __int32& aOperationCount,
06916   bool& aTimerStart,
06917   __int32& aOperationIndex,
06918   TGLibDateTime& aOperationStartTime,
06919   TGLibDateTime& aOperationStopTime,
06920   TPlcResourceID& aSource,
06921   TPlcResourceID& aDestination,
06922   __int64& aFileSizeLimit,
06923   __int64& aBandWidthLimit,
06924   const __int32*& aOperationErrorCode);
06925
06926 /// Decode action 'Auto backup operation started'.
06927 /// Auto backup progress notification: operation started.
06928 /// @param  [in]  anAction     Handle to action to decode.
06929 /// @param  [out] aSchedule    Schedule.
06930 /// @param  [out] aStartTime   Start time, empty during event backup.
06931 /// @param  [out] aEffectiveStartTime Effective schedule start time.
06932 /// @param  [out] aOperationCount Operation count.
06933 /// @param  [out] aTimerStart  Timer start.
06934 /// @param  [out] aOperationIndex Operation index.
06935 /// @param  [out] aOperationStartTime Operation start time.
06936 /// @param  [out] aSource      Source.
06937 /// @param  [out] aDestination Destination.
06938 /// @param  [out] aFileSizeLimit File size limit.
06939 /// @param  [out] aBandWidthLimit Band width limit.
06940 /// @return \c true if the function succeeds, \c false otherwise.
06941 ///         To get extended error information, call \ref GscAct_GetLastError.
06942 ///
06943 /// @warning   Following parameters are optional:  aStartTime. \par
06944 ///            Values returned in these fields can be \c NULL pointers.
06945 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupOperationStarted(
06946   ConstHGscAction anAction,
06947   TPlcResourceID& aSchedule,
06948   const TGLibDateTime*& aStartTime,
06949   TGLibDateTime& aEffectiveStartTime,
06950   __int32& aOperationCount,
06951   bool& aTimerStart,
06952   __int32& aOperationIndex,
06953   TGLibDateTime& aOperationStartTime,
06954   TPlcResourceID& aSource,
06955   TPlcResourceID& aDestination,
06956   __int64& aFileSizeLimit,
06957   __int64& aBandWidthLimit);
06958
06959 /// Decode action 'Auto backup schedule done'.
06960 /// Auto backup progress notification: schedule done.
06961 /// @param  [in]  anAction     Handle to action to decode.
06962 /// @param  [out] aSchedule    Schedule.
06963 /// @param  [out] aStartTime   Start time, empty during event backup.
06964 /// @param  [out] aEffectiveStartTime Effective schedule start time.
06965 /// @param  [out] aStopTime    Schedule stop time.
06966 /// @param  [out] aOperationCount Operation count.
06967 /// @param  [out] aTimerStart  Timer start.
06968 /// @return \c true if the function succeeds, \c false otherwise.
06969 ///         To get extended error information, call \ref GscAct_GetLastError.
06970 ///
06971 /// @warning   Following parameters are optional:  aStartTime. \par
06972 ///            Values returned in these fields can be \c NULL pointers.
06973 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupScheduleDone(
06974   ConstHGscAction anAction,
06975   TPlcResourceID& aSchedule,
06976   const TGLibDateTime*& aStartTime,
06977   TGLibDateTime& aEffectiveStartTime,
06978   TGLibDateTime& aStopTime,
06979   __int32& aOperationCount,
06980   bool& aTimerStart);
06981
06982 /// Decode action 'Auto backup schedule started'.
06983 /// Auto backup progress notification: schedule started.
06984 /// @param  [in]  anAction     Handle to action to decode.
06985 /// @param  [out] aSchedule    Schedule.
06986 /// @param  [out] aStartTime   Start time, empty during event backup.
06987 /// @param  [out] aEffectiveStartTime Effective schedule start time.
06988 /// @param  [out] aOperationCount Operation count.
06989 /// @param  [out] aTimerStart  Timer start.
06990 /// @return \c true if the function succeeds, \c false otherwise.
06991 ///         To get extended error information, call \ref GscAct_GetLastError.
06992 ///
06993 /// @warning   Following parameters are optional:  aStartTime. \par
06994 ///            Values returned in these fields can be \c NULL pointers.
06995 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoBackupScheduleStarted(
06996   ConstHGscAction anAction,
06997   TPlcResourceID& aSchedule,
06998   const TGLibDateTime*& aStartTime,
06999   TGLibDateTime& aEffectiveStartTime,
07000   __int32& aOperationCount,
07001   bool& aTimerStart);
07002
07003 /// Decode action 'Auto focus off'.
07004 /// Disable auto focus of the camera.
07005 /// @param  [in]  anAction     Handle to action to decode.
07006 /// @param  [out] aCamera      PTZ head.
07007 /// @return \c true if the function succeeds, \c false otherwise.
07008 ///         To get extended error information, call \ref GscAct_GetLastError.
07009 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoFocusOff(
07010   ConstHGscAction anAction,
07011   TPlcMediaChannelID& aCamera);
07012
07013 /// Decode action 'Auto focus on'.
07014 /// Enable auto focus of the camera.
07015 /// @param  [in]  anAction     Handle to action to decode.
07016 /// @param  [out] aCamera      PTZ head.
07017 /// @return \c true if the function succeeds, \c false otherwise.
07018 ///         To get extended error information, call \ref GscAct_GetLastError.
07019 GSCACTDLLCALL bool        __stdcall GscAct_DecodeAutoFocusOn(
07020   ConstHGscAction anAction,
07021   TPlcMediaChannelID& aCamera);
07022
07023 /// Decode action 'Backup event'.
07024 /// Backup event.
07025 /// @param  [in]  anAction     Handle to action to decode.
07026 /// @param  [out] aEventID     Instance ID of the event.
07027 /// @param  [out] aTypeID      Type of the event.
07028 /// @param  [out] aDestination Destination.
07029 /// @param  [out] aStartHintID Optional start hint ID.
07030 /// @param  [out] aStopHintID  Optional stop hint ID.
07031 /// @param  [out] aSubfolder   Sub folder to backup event.
07032 /// @return \c true if the function succeeds, \c false otherwise.
07033 ///         To get extended error information, call \ref GscAct_GetLastError.
07034 ///
07035 /// @warning   Following parameters are optional:  aStartHintID. aStopHintID. aSubfolder. \par
07036 ///            Values returned in these fields can be \c NULL pointers.
07037 GSCACTDLLCALL bool        __stdcall GscAct_DecodeBackupEvent(
07038   ConstHGscAction anAction,
07039   __int64& aEventID,
07040   TPlcEventTypeID& aTypeID,
07041   TPlcResourceID& aDestination,
07042   const __int64*& aStartHintID,
07043   const __int64*& aStopHintID,
07044   const wchar_t*& aSubfolder);
07045
07046 /// Decode action 'Barcode data'.
07047 /// Barcode data.
07048 /// @param  [in]  anAction     Handle to action to decode.
07049 /// @param  [out] aReaderName  Scanner name.
07050 /// @param  [out] aTimeStamp   Time stamp.
07051 /// @param  [out] aBarcode     Barcode.
07052 /// @return \c true if the function succeeds, \c false otherwise.
07053 ///         To get extended error information, call \ref GscAct_GetLastError.
07054 GSCACTDLLCALL bool        __stdcall GscAct_DecodeBarcodeData(
07055   ConstHGscAction anAction,
07056   const wchar_t*& aReaderName,
07057   TGLibDateTime& aTimeStamp,
07058   const wchar_t*& aBarcode);
07059
07060 /// Decode action 'Blocking filter activate'.
07061 /// Blocking filter activate.
07062 /// @param  [in]  anAction     Handle to action to decode.
07063 /// @param  [out] aFilter      Blocking filter.
07064 /// @return \c true if the function succeeds, \c false otherwise.
07065 ///         To get extended error information, call \ref GscAct_GetLastError.
07066 GSCACTDLLCALL bool        __stdcall GscAct_DecodeBlockingFilterActivate(
07067   ConstHGscAction anAction,
07068   const wchar_t*& aFilter);
07069
07070 /// Decode action 'Blocking filter deactivate'.
07071 /// Blocking filter deactivate.
07072 /// @param  [in]  anAction     Handle to action to decode.
07073 /// @param  [out] aFilter      Blocking filter.
07074 /// @return \c true if the function succeeds, \c false otherwise.
07075 ///         To get extended error information, call \ref GscAct_GetLastError.
07076 GSCACTDLLCALL bool        __stdcall GscAct_DecodeBlockingFilterDeactivate(
07077   ConstHGscAction anAction,
07078   const wchar_t*& aFilter);
07079
07080 /// Decode action 'Camera apply profile'.
07081 /// Apply a predefined profile settings to the camera.
07082 /// @param  [in]  anAction     Handle to action to decode.
07083 /// @param  [out] aCamera      PTZ head.
07084 /// @param  [out] aProfile     Profile name.
07085 /// @return \c true if the function succeeds, \c false otherwise.
07086 ///         To get extended error information, call \ref GscAct_GetLastError.
07087 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraApplyProfile(
07088   ConstHGscAction anAction,
07089   TPlcMediaChannelID& aCamera,
07090   const wchar_t*& aProfile);
07091
07092 /// Decode action 'Camera backlight compensation mode'.
07093 /// Change backlight compensation mode of the camera.
07094 /// @param  [in]  anAction     Handle to action to decode.
07095 /// @param  [out] aCamera      PTZ head.
07096 /// @param  [out] aMode        Backlight compensation mode.
07097 /// @return \c true if the function succeeds, \c false otherwise.
07098 ///         To get extended error information, call \ref GscAct_GetLastError.
07099 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraBacklightCompensationMode(
07100   ConstHGscAction anAction,
07101   TPlcMediaChannelID& aCamera,
07102   PlcBacklightMode& aMode);
07103
07104 /// Decode action 'Camera clear preset text'.
07105 /// Clear camera text for preset position.
07106 /// @param  [in]  anAction     Handle to action to decode.
07107 /// @param  [out] aCamera      PTZ head.
07108 /// @param  [out] aPosition    Preset position.
07109 /// @return \c true if the function succeeds, \c false otherwise.
07110 ///         To get extended error information, call \ref GscAct_GetLastError.
07111 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraClearPrePosText(
07112   ConstHGscAction anAction,
07113   TPlcMediaChannelID& aCamera,
07114   __int32& aPosition);
07115
07116 /// Decode action 'Camera day/night mode'.
07117 /// Change day/night mode of the camera.
07118 /// @param  [in]  anAction     Handle to action to decode.
07119 /// @param  [out] aCamera      PTZ head.
07120 /// @param  [out] aMode        Day/night mode.
07121 /// @return \c true if the function succeeds, \c false otherwise.
07122 ///         To get extended error information, call \ref GscAct_GetLastError.
07123 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraDayNightMode(
07124   ConstHGscAction anAction,
07125   TPlcMediaChannelID& aCamera,
07126   PlcDayNightMode& aMode);
07127
07128 /// Decode action 'Camera light off'.
07129 /// Turn camera light off.
07130 /// @param  [in]  anAction     Handle to action to decode.
07131 /// @param  [out] aCamera      PTZ head.
07132 /// @return \c true if the function succeeds, \c false otherwise.
07133 ///         To get extended error information, call \ref GscAct_GetLastError.
07134 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraLightOff(
07135   ConstHGscAction anAction,
07136   TPlcMediaChannelID& aCamera);
07137
07138 /// Decode action 'Camera light on'.
07139 /// Turn camera light on.
07140 /// @param  [in]  anAction     Handle to action to decode.
07141 /// @param  [out] aCamera      PTZ head.
07142 /// @return \c true if the function succeeds, \c false otherwise.
07143 ///         To get extended error information, call \ref GscAct_GetLastError.
07144 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraLightOn(
07145   ConstHGscAction anAction,
07146   TPlcMediaChannelID& aCamera);
07147
07148 /// Decode action 'Camera manual iris off'.
07149 /// Disable manual iris of the camera.
07150 /// @param  [in]  anAction     Handle to action to decode.
07151 /// @param  [out] aCamera      PTZ head.
07152 /// @return \c true if the function succeeds, \c false otherwise.
07153 ///         To get extended error information, call \ref GscAct_GetLastError.
07154 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraManualIrisOff(
07155   ConstHGscAction anAction,
07156   TPlcMediaChannelID& aCamera);
07157
07158 /// Decode action 'Camera manual iris on'.
07159 /// Enable manual iris of the camera.
07160 /// @param  [in]  anAction     Handle to action to decode.
07161 /// @param  [out] aCamera      PTZ head.
07162 /// @return \c true if the function succeeds, \c false otherwise.
07163 ///         To get extended error information, call \ref GscAct_GetLastError.
07164 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraManualIrisOn(
07165   ConstHGscAction anAction,
07166   TPlcMediaChannelID& aCamera);
07167
07168 /// Decode action 'Camera off'.
07169 /// Turn camera off.
07170 /// @param  [in]  anAction     Handle to action to decode.
07171 /// @param  [out] aCamera      PTZ head.
07172 /// @return \c true if the function succeeds, \c false otherwise.
07173 ///         To get extended error information, call \ref GscAct_GetLastError.
07174 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraOff(
07175   ConstHGscAction anAction,
07176   TPlcMediaChannelID& aCamera);
07177
07178 /// Decode action 'Camera on'.
07179 /// Turn camera on.
07180 /// @param  [in]  anAction     Handle to action to decode.
07181 /// @param  [out] aCamera      PTZ head.
07182 /// @return \c true if the function succeeds, \c false otherwise.
07183 ///         To get extended error information, call \ref GscAct_GetLastError.
07184 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraOn(
07185   ConstHGscAction anAction,
07186   TPlcMediaChannelID& aCamera);
07187
07188 /// Decode action 'Camera pump off'.
07189 /// Turn camera pump off.
07190 /// @param  [in]  anAction     Handle to action to decode.
07191 /// @param  [out] aCamera      PTZ head.
07192 /// @return \c true if the function succeeds, \c false otherwise.
07193 ///         To get extended error information, call \ref GscAct_GetLastError.
07194 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraPumpOff(
07195   ConstHGscAction anAction,
07196   TPlcMediaChannelID& aCamera);
07197
07198 /// Decode action 'Camera pump on'.
07199 /// Turn camera pump on.
07200 /// @param  [in]  anAction     Handle to action to decode.
07201 /// @param  [out] aCamera      PTZ head.
07202 /// @return \c true if the function succeeds, \c false otherwise.
07203 ///         To get extended error information, call \ref GscAct_GetLastError.
07204 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraPumpOn(
07205   ConstHGscAction anAction,
07206   TPlcMediaChannelID& aCamera);
07207
07208 /// Decode action 'Camera RAW output'.
07209 /// Output unformatted command to the camera.
07210 /// @param  [in]  anAction     Handle to action to decode.
07211 /// @param  [out] aCamera      PTZ head.
07212 /// @param  [out] aOutput      RAW command to output.
07213 /// @return \c true if the function succeeds, \c false otherwise.
07214 ///         To get extended error information, call \ref GscAct_GetLastError.
07215 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraRAWOutput(
07216   ConstHGscAction anAction,
07217   TPlcMediaChannelID& aCamera,
07218   const char*& aOutput);
07219
07220 /// Decode action 'Camera select char mode'.
07221 /// Select camera character mode.
07222 /// @param  [in]  anAction     Handle to action to decode.
07223 /// @param  [out] aCamera      PTZ head.
07224 /// @param  [out] aMode        Character mode.
07225 /// @return \c true if the function succeeds, \c false otherwise.
07226 ///         To get extended error information, call \ref GscAct_GetLastError.
07227 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSelectCharMode(
07228   ConstHGscAction anAction,
07229   TPlcMediaChannelID& aCamera,
07230   __int32& aMode);
07231
07232 /// Decode action 'Camera set preset text'.
07233 /// Set camera text for preset position.
07234 /// @param  [in]  anAction     Handle to action to decode.
07235 /// @param  [out] aCamera      PTZ head.
07236 /// @param  [out] aPosition    Preset position.
07237 /// @return \c true if the function succeeds, \c false otherwise.
07238 ///         To get extended error information, call \ref GscAct_GetLastError.
07239 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSetPrePosText(
07240   ConstHGscAction anAction,
07241   TPlcMediaChannelID& aCamera,
07242   __int32& aPosition);
07243
07244 /// Decode action 'Camera spec func U off'.
07245 /// Turn camera special function U off.
07246 /// @param  [in]  anAction     Handle to action to decode.
07247 /// @param  [out] aCamera      PTZ head.
07248 /// @return \c true if the function succeeds, \c false otherwise.
07249 ///         To get extended error information, call \ref GscAct_GetLastError.
07250 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncUOff(
07251   ConstHGscAction anAction,
07252   TPlcMediaChannelID& aCamera);
07253
07254 /// Decode action 'Camera spec func U on'.
07255 /// Turn camera special function U on.
07256 /// @param  [in]  anAction     Handle to action to decode.
07257 /// @param  [out] aCamera      PTZ head.
07258 /// @return \c true if the function succeeds, \c false otherwise.
07259 ///         To get extended error information, call \ref GscAct_GetLastError.
07260 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncUOn(
07261   ConstHGscAction anAction,
07262   TPlcMediaChannelID& aCamera);
07263
07264 /// Decode action 'Camera spec func V off'.
07265 /// Turn camera special function V off.
07266 /// @param  [in]  anAction     Handle to action to decode.
07267 /// @param  [out] aCamera      PTZ head.
07268 /// @return \c true if the function succeeds, \c false otherwise.
07269 ///         To get extended error information, call \ref GscAct_GetLastError.
07270 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncVOff(
07271   ConstHGscAction anAction,
07272   TPlcMediaChannelID& aCamera);
07273
07274 /// Decode action 'Camera spec func V on'.
07275 /// Turn camera special function V on.
07276 /// @param  [in]  anAction     Handle to action to decode.
07277 /// @param  [out] aCamera      PTZ head.
07278 /// @return \c true if the function succeeds, \c false otherwise.
07279 ///         To get extended error information, call \ref GscAct_GetLastError.
07280 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncVOn(
07281   ConstHGscAction anAction,
07282   TPlcMediaChannelID& aCamera);
07283
07284 /// Decode action 'Camera spec func X off'.
07285 /// Turn camera special function X off.
07286 /// @param  [in]  anAction     Handle to action to decode.
07287 /// @param  [out] aCamera      PTZ head.
07288 /// @return \c true if the function succeeds, \c false otherwise.
07289 ///         To get extended error information, call \ref GscAct_GetLastError.
07290 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncXOff(
07291   ConstHGscAction anAction,
07292   TPlcMediaChannelID& aCamera);
07293
07294 /// Decode action 'Camera spec func X on'.
07295 /// Turn camera special function X on.
07296 /// @param  [in]  anAction     Handle to action to decode.
07297 /// @param  [out] aCamera      PTZ head.
07298 /// @return \c true if the function succeeds, \c false otherwise.
07299 ///         To get extended error information, call \ref GscAct_GetLastError.
07300 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncXOn(
07301   ConstHGscAction anAction,
07302   TPlcMediaChannelID& aCamera);
07303
07304 /// Decode action 'Camera spec func Y off'.
07305 /// Turn camera special function Y off.
07306 /// @param  [in]  anAction     Handle to action to decode.
07307 /// @param  [out] aCamera      PTZ head.
07308 /// @return \c true if the function succeeds, \c false otherwise.
07309 ///         To get extended error information, call \ref GscAct_GetLastError.
07310 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncYOff(
07311   ConstHGscAction anAction,
07312   TPlcMediaChannelID& aCamera);
07313
07314 /// Decode action 'Camera spec func Y on'.
07315 /// Turn camera special function Y on.
07316 /// @param  [in]  anAction     Handle to action to decode.
07317 /// @param  [out] aCamera      PTZ head.
07318 /// @return \c true if the function succeeds, \c false otherwise.
07319 ///         To get extended error information, call \ref GscAct_GetLastError.
07320 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraSpecFuncYOn(
07321   ConstHGscAction anAction,
07322   TPlcMediaChannelID& aCamera);
07323
07324 /// Decode action 'Camera stop all'.
07325 /// Camera stop all.
07326 /// @param  [in]  anAction     Handle to action to decode.
07327 /// @param  [out] aCamera      PTZ head.
07328 /// @return \c true if the function succeeds, \c false otherwise.
07329 ///         To get extended error information, call \ref GscAct_GetLastError.
07330 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraStopAll(
07331   ConstHGscAction anAction,
07332   TPlcMediaChannelID& aCamera);
07333
07334 /// Decode action 'Camera text off'.
07335 /// Disable camera text.
07336 /// @param  [in]  anAction     Handle to action to decode.
07337 /// @param  [out] aCamera      PTZ head.
07338 /// @return \c true if the function succeeds, \c false otherwise.
07339 ///         To get extended error information, call \ref GscAct_GetLastError.
07340 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraTextOff(
07341   ConstHGscAction anAction,
07342   TPlcMediaChannelID& aCamera);
07343
07344 /// Decode action 'Camera text on'.
07345 /// Enable camera text.
07346 /// @param  [in]  anAction     Handle to action to decode.
07347 /// @param  [out] aCamera      PTZ head.
07348 /// @return \c true if the function succeeds, \c false otherwise.
07349 ///         To get extended error information, call \ref GscAct_GetLastError.
07350 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraTextOn(
07351   ConstHGscAction anAction,
07352   TPlcMediaChannelID& aCamera);
07353
07354 /// Decode action 'Camera tour start'.
07355 /// Start camera tour.
07356 /// @param  [in]  anAction     Handle to action to decode.
07357 /// @param  [out] aCamera      PTZ head.
07358 /// @param  [out] aTourID      Tour ID.
07359 /// @param  [out] aTourName    Tour name.
07360 /// @return \c true if the function succeeds, \c false otherwise.
07361 ///         To get extended error information, call \ref GscAct_GetLastError.
07362 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraTourStart(
07363   ConstHGscAction anAction,
07364   TPlcMediaChannelID& aCamera,
07365   __int32& aTourID,
07366   const char*& aTourName);
07367
07368 /// Decode action 'Camera tour stop'.
07369 /// Stop camera tour.
07370 /// @param  [in]  anAction     Handle to action to decode.
07371 /// @param  [out] aCamera      PTZ head.
07372 /// @return \c true if the function succeeds, \c false otherwise.
07373 ///         To get extended error information, call \ref GscAct_GetLastError.
07374 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraTourStop(
07375   ConstHGscAction anAction,
07376   TPlcMediaChannelID& aCamera);
07377
07378 /// Decode action 'Camera version off'.
07379 /// Hide camera version string.
07380 /// @param  [in]  anAction     Handle to action to decode.
07381 /// @param  [out] aCamera      PTZ head.
07382 /// @return \c true if the function succeeds, \c false otherwise.
07383 ///         To get extended error information, call \ref GscAct_GetLastError.
07384 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraVersionOff(
07385   ConstHGscAction anAction,
07386   TPlcMediaChannelID& aCamera);
07387
07388 /// Decode action 'Camera version on'.
07389 /// Show camera version string.
07390 /// @param  [in]  anAction     Handle to action to decode.
07391 /// @param  [out] aCamera      PTZ head.
07392 /// @return \c true if the function succeeds, \c false otherwise.
07393 ///         To get extended error information, call \ref GscAct_GetLastError.
07394 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraVersionOn(
07395   ConstHGscAction anAction,
07396   TPlcMediaChannelID& aCamera);
07397
07398 /// Decode action 'Camera wash-wipe off'.
07399 /// Turn camera wash-wipe off.
07400 /// @param  [in]  anAction     Handle to action to decode.
07401 /// @param  [out] aCamera      PTZ head.
07402 /// @return \c true if the function succeeds, \c false otherwise.
07403 ///         To get extended error information, call \ref GscAct_GetLastError.
07404 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraWashOff(
07405   ConstHGscAction anAction,
07406   TPlcMediaChannelID& aCamera);
07407
07408 /// Decode action 'Camera wash-wipe on'.
07409 /// Turn camera wash-wipe on.
07410 /// @param  [in]  anAction     Handle to action to decode.
07411 /// @param  [out] aCamera      PTZ head.
07412 /// @return \c true if the function succeeds, \c false otherwise.
07413 ///         To get extended error information, call \ref GscAct_GetLastError.
07414 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCameraWashOn(
07415   ConstHGscAction anAction,
07416   TPlcMediaChannelID& aCamera);
07417
07418 /// Decode action 'Cancel export'.
07419 /// Cancel export.
07420 /// @param  [in]  anAction     Handle to action to decode.
07421 /// @param  [out] aExportID    Export GUID.
07422 /// @param  [out] aAbortFlag   Abort flag.
07423 /// @return \c true if the function succeeds, \c false otherwise.
07424 ///         To get extended error information, call \ref GscAct_GetLastError.
07425 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCancelExport(
07426   ConstHGscAction anAction,
07427   GUID& aExportID,
07428   PlcExportAbort& aAbortFlag);
07429
07430 /// Decode action 'Case has been closed'.
07431 /// Case has been closed.
07432 /// @param  [in]  anAction     Handle to action to decode.
07433 /// @return \c true if the function succeeds, \c false otherwise.
07434 ///         To get extended error information, call \ref GscAct_GetLastError.
07435 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCaseClosed(
07436   ConstHGscAction anAction);
07437
07438 /// Decode action 'Case has been opened'.
07439 /// Case has been opened.
07440 /// @param  [in]  anAction     Handle to action to decode.
07441 /// @return \c true if the function succeeds, \c false otherwise.
07442 ///         To get extended error information, call \ref GscAct_GetLastError.
07443 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCaseOpened(
07444   ConstHGscAction anAction);
07445
07446 /// Decode action 'Change AD parameter set'.
07447 /// This action changes the current AD parameter set of the video channel.
07448 /// @param  [in]  anAction     Handle to action to decode.
07449 /// @param  [out] aChannel     Channel.
07450 /// @param  [out] aParameterSet The name of the new AD parameter set.
07451 /// @return \c true if the function succeeds, \c false otherwise.
07452 ///         To get extended error information, call \ref GscAct_GetLastError.
07453 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChangeADParameterSet(
07454   ConstHGscAction anAction,
07455   TPlcMediaChannelID& aChannel,
07456   TPlcResourceID& aParameterSet);
07457
07458 /// Decode action 'Change camera profile'.
07459 /// This action changes the current camera profile of the hardware module.
07460 /// @param  [in]  anAction     Handle to action to decode.
07461 /// @param  [out] aHardwareModule Hardware module.
07462 /// @param  [out] aCameraProfile The name of the camera profile.
07463 /// @return \c true if the function succeeds, \c false otherwise.
07464 ///         To get extended error information, call \ref GscAct_GetLastError.
07465 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChangeCameraProfile(
07466   ConstHGscAction anAction,
07467   TPlcResourceID& aHardwareModule,
07468   TPlcResourceID& aCameraProfile);
07469
07470 /// Decode action 'Change CPA parameter set'.
07471 /// This action changes the current CPA parameter set of the video channel.
07472 /// @param  [in]  anAction     Handle to action to decode.
07473 /// @param  [out] aChannel     Channel.
07474 /// @param  [out] aParameterSet The name of the new CPA parameter set.
07475 /// @return \c true if the function succeeds, \c false otherwise.
07476 ///         To get extended error information, call \ref GscAct_GetLastError.
07477 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChangeCPAParameterSet(
07478   ConstHGscAction anAction,
07479   TPlcMediaChannelID& aChannel,
07480   TPlcResourceID& aParameterSet);
07481
07482 /// Decode action 'Change GTectVMX parameter set'.
07483 /// This action changes the current GTectVMX parameter set of the video channel.
07484 /// @param  [in]  anAction     Handle to action to decode.
07485 /// @param  [out] aChannel     Channel.
07486 /// @param  [out] aParameterSet The name of the new GTect parameter set.
07487 /// @return \c true if the function succeeds, \c false otherwise.
07488 ///         To get extended error information, call \ref GscAct_GetLastError.
07489 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChangeGTectParameterSet(
07490   ConstHGscAction anAction,
07491   TPlcMediaChannelID& aChannel,
07492   TPlcResourceID& aParameterSet);
07493
07494 /// Decode action 'Change OBTRACK parameter set'.
07495 /// This action changes the current OBTRACK parameter set of the video channel.
07496 /// @param  [in]  anAction     Handle to action to decode.
07497 /// @param  [out] aChannel     Channel.
07498 /// @param  [out] aParameterSet The name of the new OBTRACK parameter set.
07499 /// @return \c true if the function succeeds, \c false otherwise.
07500 ///         To get extended error information, call \ref GscAct_GetLastError.
07501 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChangeObtrackParameterSet(
07502   ConstHGscAction anAction,
07503   TPlcMediaChannelID& aChannel,
07504   TPlcResourceID& aParameterSet);
07505
07506 /// Decode action 'Change VMD parameter set'.
07507 /// This action changes the current VMD parameter set of the video channel.
07508 /// @param  [in]  anAction     Handle to action to decode.
07509 /// @param  [out] aChannel     Channel.
07510 /// @param  [out] aParameterSet The name of the new VMD parameter set.
07511 /// @return \c true if the function succeeds, \c false otherwise.
07512 ///         To get extended error information, call \ref GscAct_GetLastError.
07513 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChangeVMDParameterSet(
07514   ConstHGscAction anAction,
07515   TPlcMediaChannelID& aChannel,
07516   TPlcResourceID& aParameterSet);
07517
07518 /// Decode action 'Channel error'.
07519 /// Notify channel error.
07520 /// @param  [in]  anAction     Handle to action to decode.
07521 /// @param  [out] aChannel     Channel.
07522 /// @param  [out] aSensorType  Sensor type.
07523 /// @param  [out] aSource      Source of the message.
07524 /// @param  [out] aMessage     Kind of the message.
07525 /// @param  [out] aWindowsError Optional Windows error code.
07526 /// @param  [out] aDescription Optional description of the message.
07527 /// @param  [out] aXMLInfo     Optional additional info (usually as XML string).
07528 /// @return \c true if the function succeeds, \c false otherwise.
07529 ///         To get extended error information, call \ref GscAct_GetLastError.
07530 ///
07531 /// @warning   Following parameters are optional:  aSensorType. aWindowsError. aDescription. aXMLInfo. \par
07532 ///            Values returned in these fields can be \c NULL pointers.
07533 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChannelError(
07534   ConstHGscAction anAction,
07535   TPlcMediaChannelID& aChannel,
07536   const VideoSensorKind*& aSensorType,
07537   PlcMessageSource& aSource,
07538   PlcMessageCode& aMessage,
07539   const __int32*& aWindowsError,
07540   const wchar_t*& aDescription,
07541   const char*& aXMLInfo);
07542
07543 /// Decode action 'Channel info'.
07544 /// Notify channel information.
07545 /// @param  [in]  anAction     Handle to action to decode.
07546 /// @param  [out] aChannel     Channel.
07547 /// @param  [out] aSensorType  Sensor type.
07548 /// @param  [out] aSource      Source of the message.
07549 /// @param  [out] aMessage     Kind of the message.
07550 /// @param  [out] aDescription Optional description of the message.
07551 /// @param  [out] aXMLInfo     Optional additional info (usually as XML string).
07552 /// @return \c true if the function succeeds, \c false otherwise.
07553 ///         To get extended error information, call \ref GscAct_GetLastError.
07554 ///
07555 /// @warning   Following parameters are optional:  aSensorType. aDescription. aXMLInfo. \par
07556 ///            Values returned in these fields can be \c NULL pointers.
07557 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChannelInfo(
07558   ConstHGscAction anAction,
07559   TPlcMediaChannelID& aChannel,
07560   const VideoSensorKind*& aSensorType,
07561   PlcMessageSource& aSource,
07562   PlcMessageCode& aMessage,
07563   const wchar_t*& aDescription,
07564   const char*& aXMLInfo);
07565
07566 /// Decode action 'Channel live check'.
07567 /// This action notifies that the channel is alive.
07568 /// @param  [in]  anAction     Handle to action to decode.
07569 /// @param  [out] aChannel     Channel.
07570 /// @param  [out] aSensorType  Sensor type.
07571 /// @param  [out] aTimeStamp   Time stamp.
07572 /// @return \c true if the function succeeds, \c false otherwise.
07573 ///         To get extended error information, call \ref GscAct_GetLastError.
07574 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChannelLiveCheck(
07575   ConstHGscAction anAction,
07576   TPlcMediaChannelID& aChannel,
07577   VideoSensorKind& aSensorType,
07578   TGLibDateTime& aTimeStamp);
07579
07580 /// Decode action 'Channel warning'.
07581 /// Notify channel warning.
07582 /// @param  [in]  anAction     Handle to action to decode.
07583 /// @param  [out] aChannel     Channel.
07584 /// @param  [out] aSensorType  Sensor type.
07585 /// @param  [out] aSource      Source of the message.
07586 /// @param  [out] aMessage     Kind of the message.
07587 /// @param  [out] aWindowsError Optional Windows error code.
07588 /// @param  [out] aDescription Optional description of the message.
07589 /// @param  [out] aXMLInfo     Optional additional info (usually as XML string).
07590 /// @return \c true if the function succeeds, \c false otherwise.
07591 ///         To get extended error information, call \ref GscAct_GetLastError.
07592 ///
07593 /// @warning   Following parameters are optional:  aSensorType. aWindowsError. aDescription. aXMLInfo. \par
07594 ///            Values returned in these fields can be \c NULL pointers.
07595 GSCACTDLLCALL bool        __stdcall GscAct_DecodeChannelWarning(
07596   ConstHGscAction anAction,
07597   TPlcMediaChannelID& aChannel,
07598   const VideoSensorKind*& aSensorType,
07599   PlcMessageSource& aSource,
07600   PlcMessageCode& aMessage,
07601   const __int32*& aWindowsError,
07602   const wchar_t*& aDescription,
07603   const char*& aXMLInfo);
07604
07605 /// Decode action 'CPA measurement'.
07606 /// CPA measurement.
07607 /// @param  [in]  anAction     Handle to action to decode.
07608 /// @param  [out] aChannel     Channel.
07609 /// @param  [out] aCorrelation Correlation factor.
07610 /// @return \c true if the function succeeds, \c false otherwise.
07611 ///         To get extended error information, call \ref GscAct_GetLastError.
07612 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCPAMeasurement(
07613   ConstHGscAction anAction,
07614   TPlcMediaChannelID& aChannel,
07615   __int32& aCorrelation);
07616
07617 /// Decode action 'Custom action'.
07618 /// This action has no side effects and can be used for customer purposes.
07619 /// @param  [in]  anAction     Handle to action to decode.
07620 /// @param  [out] aInt         Numeric parameter.
07621 /// @param  [out] aString      Literal parameter.
07622 /// @return \c true if the function succeeds, \c false otherwise.
07623 ///         To get extended error information, call \ref GscAct_GetLastError.
07624 GSCACTDLLCALL bool        __stdcall GscAct_DecodeCustomAction(
07625   ConstHGscAction anAction,
07626   __int64& aInt,
07627   const wchar_t*& aString);
07628
07629 /// Decode action 'Database recording info per ring'.
07630 /// Database recording info per ring.
07631 /// @param  [in]  anAction     Handle to action to decode.
07632 /// @param  [out] aDatabaseRing Database ring.
07633 /// @param  [out] aNoVideoRecording Video is recording or not.
07634 /// @param  [out] aNoAudioRecording Audio is recording or not.
07635 /// @param  [out] aNoRecordingAtAll Video and/or audio is recording or not.
07636 /// @param  [out] aVideoSamplesPerSecond Video samples per second.
07637 /// @param  [out] aVideoMBPerSecond Video MB per second.
07638 /// @param  [out] aAudioSamplesPerSecond Audio samples per second.
07639 /// @param  [out] aAudioMBPerSecond Audio MB per second.
07640 /// @param  [out] aWriteWaitTimesPercent Write waiting times in percent.
07641 /// @param  [out] aRingCapacity Ring capacity.
07642 /// @param  [out] aOldestItem  Time stamp of the oldest item.
07643 /// @param  [out] aRecordingDepth Recording depth in hours.
07644 /// @param  [out] aEstimatedRequiredCapacity Estimated required capacity.
07645 /// @return \c true if the function succeeds, \c false otherwise.
07646 ///         To get extended error information, call \ref GscAct_GetLastError.
07647 ///
07648 /// @warning   Following parameters are optional:  aRecordingDepth. aEstimatedRequiredCapacity. \par
07649 ///            Values returned in these fields can be \c NULL pointers.
07650 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDatabaseRecordingInfoRing(
07651   ConstHGscAction anAction,
07652   PlcDatabaseRing& aDatabaseRing,
07653   bool& aNoVideoRecording,
07654   bool& aNoAudioRecording,
07655   bool& aNoRecordingAtAll,
07656   double& aVideoSamplesPerSecond,
07657   double& aVideoMBPerSecond,
07658   double& aAudioSamplesPerSecond,
07659   double& aAudioMBPerSecond,
07660   double& aWriteWaitTimesPercent,
07661   __int64& aRingCapacity,
07662   TGLibDateTime& aOldestItem,
07663   const double*& aRecordingDepth,
07664   const __int64*& aEstimatedRequiredCapacity);
07665
07666 /// Decode action 'Database recording info total'.
07667 /// Database recording info total.
07668 /// @param  [in]  anAction     Handle to action to decode.
07669 /// @param  [out] aNoVideoRecording Video is recording or not.
07670 /// @param  [out] aNoAudioRecording Audio is recording or not.
07671 /// @param  [out] aNoRecordingAtAll Video and/or audio is recording or not.
07672 /// @param  [out] aVideoSamplesPerSecond Video samples per second.
07673 /// @param  [out] aVideoMBPerSecond Video MB per second.
07674 /// @param  [out] aAudioSamplesPerSecond Audio samples per second.
07675 /// @param  [out] aAudioMBPerSecond Audio MB per second.
07676 /// @param  [out] aWriteWaitTimesPercent Write waiting times in percent.
07677 /// @param  [out] aTotalCapacity Total capacity.
07678 /// @param  [out] aFreeCapacity Free capacity.
07679 /// @param  [out] aAllocatedCapacity Allocated capacity.
07680 /// @param  [out] aOldestItem  Time stamp of the oldest item.
07681 /// @param  [out] aRecordingDepth Recording depth in hours.
07682 /// @param  [out] aEstimatedRequiredCapacity Estimated required capacity.
07683 /// @param  [out] aRequiredCapacityFactor Required capacity factor.
07684 /// @param  [out] aRequiredCapacityAvailable Required capacity available.
07685 /// @return \c true if the function succeeds, \c false otherwise.
07686 ///         To get extended error information, call \ref GscAct_GetLastError.
07687 ///
07688 /// @warning   Following parameters are optional:  aOldestItem. aRecordingDepth. aEstimatedRequiredCapacity. aRequiredCapacityFactor. aRequiredCapacityAvailable. \par
07689 ///            Values returned in these fields can be \c NULL pointers.
07690 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDatabaseRecordingInfoTotal(
07691   ConstHGscAction anAction,
07692   bool& aNoVideoRecording,
07693   bool& aNoAudioRecording,
07694   bool& aNoRecordingAtAll,
07695   double& aVideoSamplesPerSecond,
07696   double& aVideoMBPerSecond,
07697   double& aAudioSamplesPerSecond,
07698   double& aAudioMBPerSecond,
07699   double& aWriteWaitTimesPercent,
07700   __int64& aTotalCapacity,
07701   __int64& aFreeCapacity,
07702   __int64& aAllocatedCapacity,
07703   const TGLibDateTime*& aOldestItem,
07704   const double*& aRecordingDepth,
07705   const __int64*& aEstimatedRequiredCapacity,
07706   const double*& aRequiredCapacityFactor,
07707   const bool*& aRequiredCapacityAvailable);
07708
07709 /// Decode action 'Database started'.
07710 /// This action will be fired at the database start-up.
07711 /// @param  [in]  anAction     Handle to action to decode.
07712 /// @param  [out] aStatus      Database status message.
07713 /// @param  [out] aTotalSize   Database total size.
07714 /// @return \c true if the function succeeds, \c false otherwise.
07715 ///         To get extended error information, call \ref GscAct_GetLastError.
07716 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDatabaseStarted(
07717   ConstHGscAction anAction,
07718   PlcDatabaseStatus& aStatus,
07719   __int64& aTotalSize);
07720
07721 /// Decode action 'Move to default position'.
07722 /// Move camera to default position.
07723 /// @param  [in]  anAction     Handle to action to decode.
07724 /// @param  [out] aCamera      PTZ head.
07725 /// @return \c true if the function succeeds, \c false otherwise.
07726 ///         To get extended error information, call \ref GscAct_GetLastError.
07727 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDefaultPosCallUp(
07728   ConstHGscAction anAction,
07729   TPlcMediaChannelID& aCamera);
07730
07731 /// Decode action 'Clear default position'.
07732 /// Clear camera default position.
07733 /// @param  [in]  anAction     Handle to action to decode.
07734 /// @param  [out] aCamera      PTZ head.
07735 /// @return \c true if the function succeeds, \c false otherwise.
07736 ///         To get extended error information, call \ref GscAct_GetLastError.
07737 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDefaultPosClear(
07738   ConstHGscAction anAction,
07739   TPlcMediaChannelID& aCamera);
07740
07741 /// Decode action 'Save default position'.
07742 /// Save current camera position as default position.
07743 /// @param  [in]  anAction     Handle to action to decode.
07744 /// @param  [out] aCamera      PTZ head.
07745 /// @return \c true if the function succeeds, \c false otherwise.
07746 ///         To get extended error information, call \ref GscAct_GetLastError.
07747 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDefaultPosSave(
07748   ConstHGscAction anAction,
07749   TPlcMediaChannelID& aCamera);
07750
07751 /// Decode action 'Device found'.
07752 /// This action will be fired when the USB or NET device is connected to the system. It is also fired at start-up for all detected devices.
07753 /// @param  [in]  anAction     Handle to action to decode.
07754 /// @param  [out] aType        Type of the device.
07755 /// @param  [out] aName        Device name if assigned in setup, empty otherwise.
07756 /// @param  [out] aSerial      Serial ID of the device.
07757 /// @return \c true if the function succeeds, \c false otherwise.
07758 ///         To get extended error information, call \ref GscAct_GetLastError.
07759 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDeviceFound(
07760   ConstHGscAction anAction,
07761   const char*& aType,
07762   const char*& aName,
07763   const char*& aSerial);
07764
07765 /// Decode action 'New firmware received'.
07766 /// This action will be fired when the USB or NET device has got the new firmware.
07767 /// @param  [in]  anAction     Handle to action to decode.
07768 /// @param  [out] aType        Type of the device.
07769 /// @param  [out] aName        Device name if assigned in setup, empty otherwise.
07770 /// @param  [out] aSerial      Serial ID of the device.
07771 /// @param  [out] aFirmware    Serial ID of the firmware.
07772 /// @return \c true if the function succeeds, \c false otherwise.
07773 ///         To get extended error information, call \ref GscAct_GetLastError.
07774 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDeviceNewFirmware(
07775   ConstHGscAction anAction,
07776   const char*& aType,
07777   const char*& aName,
07778   const char*& aSerial,
07779   const char*& aFirmware);
07780
07781 /// Decode action 'Device plugin error'.
07782 /// This action notifies device plugin error.
07783 /// @param  [in]  anAction     Handle to action to decode.
07784 /// @param  [out] aChannel     Channel.
07785 /// @param  [out] aType        Type of the device.
07786 /// @param  [out] aSubType     Subtype of the device.
07787 /// @param  [out] aName        Device name.
07788 /// @param  [out] aSerial      Serial ID of the device.
07789 /// @param  [out] aErrorClass  Error class of the error occured.
07790 /// @param  [out] aErrorCode   Plugin type specific error code.
07791 /// @param  [out] aDescription Error description.
07792 /// @return \c true if the function succeeds, \c false otherwise.
07793 ///         To get extended error information, call \ref GscAct_GetLastError.
07794 ///
07795 /// @warning   Following parameters are optional:  aSubType. aErrorCode. aDescription. \par
07796 ///            Values returned in these fields can be \c NULL pointers.
07797 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDevicePluginError(
07798   ConstHGscAction anAction,
07799   TPlcMediaChannelID& aChannel,
07800   const char*& aType,
07801   const char*& aSubType,
07802   const char*& aName,
07803   const char*& aSerial,
07804   PlcPluginError& aErrorClass,
07805   const __int32*& aErrorCode,
07806   const char*& aDescription);
07807
07808 /// Decode action 'Device plugin state'.
07809 /// This action notifies device plugin state.
07810 /// @param  [in]  anAction     Handle to action to decode.
07811 /// @param  [out] aChannel     Channel.
07812 /// @param  [out] aType        Type of the device.
07813 /// @param  [out] aSubType     Subtype of the device.
07814 /// @param  [out] aName        Device name.
07815 /// @param  [out] aSerial      Serial ID of the device.
07816 /// @param  [out] aState       New plugin device state.
07817 /// @param  [out] aInternalState Plugin device specific state.
07818 /// @param  [out] aDescription State description.
07819 /// @return \c true if the function succeeds, \c false otherwise.
07820 ///         To get extended error information, call \ref GscAct_GetLastError.
07821 ///
07822 /// @warning   Following parameters are optional:  aSubType. aInternalState. aDescription. \par
07823 ///            Values returned in these fields can be \c NULL pointers.
07824 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDevicePluginState(
07825   ConstHGscAction anAction,
07826   TPlcMediaChannelID& aChannel,
07827   const char*& aType,
07828   const char*& aSubType,
07829   const char*& aName,
07830   const char*& aSerial,
07831   PlcPluginState& aState,
07832   const __int32*& aInternalState,
07833   const char*& aDescription);
07834
07835 /// Decode action 'Device reattached'.
07836 /// This action will be fired when the USB or NET device is reattached to the system.
07837 /// @param  [in]  anAction     Handle to action to decode.
07838 /// @param  [out] aType        Type of the device.
07839 /// @param  [out] aName        Device name if assigned in setup, empty otherwise.
07840 /// @param  [out] aSerial      Serial ID of the device.
07841 /// @return \c true if the function succeeds, \c false otherwise.
07842 ///         To get extended error information, call \ref GscAct_GetLastError.
07843 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDeviceReattached(
07844   ConstHGscAction anAction,
07845   const char*& aType,
07846   const char*& aName,
07847   const char*& aSerial);
07848
07849 /// Decode action 'Device removed'.
07850 /// This action will be fired when the USB or NET device is disconnected from the system. It is also fired at the start-up for all parameterized but not present devices.
07851 /// @param  [in]  anAction     Handle to action to decode.
07852 /// @param  [out] aType        Type of the device.
07853 /// @param  [out] aName        Device name if assigned in setup, empty otherwise.
07854 /// @param  [out] aSerial      Serial ID of the device.
07855 /// @return \c true if the function succeeds, \c false otherwise.
07856 ///         To get extended error information, call \ref GscAct_GetLastError.
07857 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDeviceRemoved(
07858   ConstHGscAction anAction,
07859   const char*& aType,
07860   const char*& aName,
07861   const char*& aSerial);
07862
07863 /// Decode action 'Digital input'.
07864 /// This action will be fired when the state of the digital input has changed.
07865 /// @param  [in]  anAction     Handle to action to decode.
07866 /// @param  [out] aContact     Contact.
07867 /// @param  [out] aState       New state.
07868 /// @return \c true if the function succeeds, \c false otherwise.
07869 ///         To get extended error information, call \ref GscAct_GetLastError.
07870 GSCACTDLLCALL bool        __stdcall GscAct_DecodeDigitalInput(
07871   ConstHGscAction anAction,
07872   TPlcMediaChannelID& aContact,
07873   DigitalInputState& aState);
07874
07875 /// Decode action 'Event backup done'.
07876 /// Event backup progress notification: backup done.
07877 /// @param  [in]  anAction     Handle to action to decode.
07878 /// @param  [out] aJobID       Backup job ID.
07879 /// @param  [out] aEventTypeID Type of the event.
07880 /// @param  [out] aEventID     Instance ID of the event.
07881 /// @param  [out] aDestination Destination.
07882 /// @param  [out] aFileSizeLimit File size limit.
07883 /// @param  [out] aBandWidthLimit Band width limit.
07884 /// @param  [out] aStartTime   Backup start time.
07885 /// @param  [out] aStopTime    Backup stop time.
07886 /// @param  [out] aOperationErrorCode Operation error code.
07887 /// @return \c true if the function succeeds, \c false otherwise.
07888 ///         To get extended error information, call \ref GscAct_GetLastError.
07889 ///
07890 /// @warning   Following parameters are optional:  aOperationErrorCode. \par
07891 ///            Values returned in these fields can be \c NULL pointers.
07892 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventBackupDone(
07893   ConstHGscAction anAction,
07894   GUID& aJobID,
07895   TPlcEventTypeID& aEventTypeID,
07896   __int64& aEventID,
07897   TPlcResourceID& aDestination,
07898   __int64& aFileSizeLimit,
07899   __int64& aBandWidthLimit,
07900   TGLibDateTime& aStartTime,
07901   TGLibDateTime& aStopTime,
07902   const __int32*& aOperationErrorCode);
07903
07904 /// Decode action 'Event backup file done'.
07905 /// Event backup progress notification: file done.
07906 /// @param  [in]  anAction     Handle to action to decode.
07907 /// @param  [out] aJobID       Backup job ID.
07908 /// @param  [out] aEventTypeID Type of the event.
07909 /// @param  [out] aEventID     Instance ID of the event.
07910 /// @param  [out] aDestination Destination.
07911 /// @param  [out] aFileSizeLimit File size limit.
07912 /// @param  [out] aBandWidthLimit Band width limit.
07913 /// @param  [out] aStartTime   Effective backup start time.
07914 /// @param  [out] aFileIndex   File index.
07915 /// @param  [out] aFileName    File name.
07916 /// @param  [out] aFileSize    File size.
07917 /// @return \c true if the function succeeds, \c false otherwise.
07918 ///         To get extended error information, call \ref GscAct_GetLastError.
07919 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventBackupFileDone(
07920   ConstHGscAction anAction,
07921   GUID& aJobID,
07922   TPlcEventTypeID& aEventTypeID,
07923   __int64& aEventID,
07924   TPlcResourceID& aDestination,
07925   __int64& aFileSizeLimit,
07926   __int64& aBandWidthLimit,
07927   TGLibDateTime& aStartTime,
07928   __int32& aFileIndex,
07929   const wchar_t*& aFileName,
07930   __int64& aFileSize);
07931
07932 /// Decode action 'Event backup file progress'.
07933 /// Event backup progress notification: file progress.
07934 /// @param  [in]  anAction     Handle to action to decode.
07935 /// @param  [out] aJobID       Backup job ID.
07936 /// @param  [out] aEventTypeID Type of the event.
07937 /// @param  [out] aEventID     Instance ID of the event.
07938 /// @param  [out] aDestination Destination.
07939 /// @param  [out] aFileSizeLimit File size limit.
07940 /// @param  [out] aBandWidthLimit Band width limit.
07941 /// @param  [out] aStartTime   Effective backup start time.
07942 /// @param  [out] aFileIndex   File index.
07943 /// @param  [out] aFileName    File name.
07944 /// @param  [out] aFileSize    File size.
07945 /// @return \c true if the function succeeds, \c false otherwise.
07946 ///         To get extended error information, call \ref GscAct_GetLastError.
07947 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventBackupFileProgress(
07948   ConstHGscAction anAction,
07949   GUID& aJobID,
07950   TPlcEventTypeID& aEventTypeID,
07951   __int64& aEventID,
07952   TPlcResourceID& aDestination,
07953   __int64& aFileSizeLimit,
07954   __int64& aBandWidthLimit,
07955   TGLibDateTime& aStartTime,
07956   __int32& aFileIndex,
07957   const wchar_t*& aFileName,
07958   __int64& aFileSize);
07959
07960 /// Decode action 'Event backup file started'.
07961 /// Event backup progress notification: file started.
07962 /// @param  [in]  anAction     Handle to action to decode.
07963 /// @param  [out] aJobID       Backup job ID.
07964 /// @param  [out] aEventTypeID Type of the event.
07965 /// @param  [out] aEventID     Instance ID of the event.
07966 /// @param  [out] aDestination Destination.
07967 /// @param  [out] aFileSizeLimit File size limit.
07968 /// @param  [out] aBandWidthLimit Band width limit.
07969 /// @param  [out] aStartTime   Effective backup start time.
07970 /// @param  [out] aFileIndex   File index.
07971 /// @param  [out] aFileName    File name.
07972 /// @return \c true if the function succeeds, \c false otherwise.
07973 ///         To get extended error information, call \ref GscAct_GetLastError.
07974 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventBackupFileStarted(
07975   ConstHGscAction anAction,
07976   GUID& aJobID,
07977   TPlcEventTypeID& aEventTypeID,
07978   __int64& aEventID,
07979   TPlcResourceID& aDestination,
07980   __int64& aFileSizeLimit,
07981   __int64& aBandWidthLimit,
07982   TGLibDateTime& aStartTime,
07983   __int32& aFileIndex,
07984   const wchar_t*& aFileName);
07985
07986 /// Decode action 'Event backup started'.
07987 /// Event backup progress notification: backup started.
07988 /// @param  [in]  anAction     Handle to action to decode.
07989 /// @param  [out] aJobID       Backup job ID.
07990 /// @param  [out] aEventTypeID Type of the event.
07991 /// @param  [out] aEventID     Instance ID of the event.
07992 /// @param  [out] aDestination Destination.
07993 /// @param  [out] aFileSizeLimit File size limit.
07994 /// @param  [out] aBandWidthLimit Band width limit.
07995 /// @param  [out] aStartTime   Backup start time.
07996 /// @return \c true if the function succeeds, \c false otherwise.
07997 ///         To get extended error information, call \ref GscAct_GetLastError.
07998 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventBackupStarted(
07999   ConstHGscAction anAction,
08000   GUID& aJobID,
08001   TPlcEventTypeID& aEventTypeID,
08002   __int64& aEventID,
08003   TPlcResourceID& aDestination,
08004   __int64& aFileSizeLimit,
08005   __int64& aBandWidthLimit,
08006   TGLibDateTime& aStartTime);
08007
08008 /// Decode action 'Event recording changed'.
08009 /// Event recording settings are changed.
08010 /// @param  [in]  anAction     Handle to action to decode.
08011 /// @param  [out] aEventID     Instance ID of the event.
08012 /// @param  [out] aTypeID      Type of the event.
08013 /// @return \c true if the function succeeds, \c false otherwise.
08014 ///         To get extended error information, call \ref GscAct_GetLastError.
08015 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventRecordingChanged(
08016   ConstHGscAction anAction,
08017   __int64& aEventID,
08018   TPlcEventTypeID& aTypeID);
08019
08020 /// Decode action 'Event started'.
08021 /// Event has started.
08022 /// @param  [in]  anAction     Handle to action to decode.
08023 /// @param  [out] aEventID     Instance ID of the event.
08024 /// @param  [out] aTypeID      Type of the event.
08025 /// @param  [out] aForeignKey  Optional foreign key used to start the alarm.
08026 /// @return \c true if the function succeeds, \c false otherwise.
08027 ///         To get extended error information, call \ref GscAct_GetLastError.
08028 ///
08029 /// @warning   Following parameters are optional:  aForeignKey. \par
08030 ///            Values returned in these fields can be \c NULL pointers.
08031 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventStartedEx(
08032   ConstHGscAction anAction,
08033   __int64& aEventID,
08034   TPlcEventTypeID& aTypeID,
08035   const __int64*& aForeignKey);
08036
08037 /// Decode action 'Event stopped'.
08038 /// Event has stopped.
08039 /// @param  [in]  anAction     Handle to action to decode.
08040 /// @param  [out] aEventID     Instance ID of the event.
08041 /// @param  [out] aTypeID      Type of the event.
08042 /// @return \c true if the function succeeds, \c false otherwise.
08043 ///         To get extended error information, call \ref GscAct_GetLastError.
08044 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventStopped(
08045   ConstHGscAction anAction,
08046   __int64& aEventID,
08047   TPlcEventTypeID& aTypeID);
08048
08049 /// Decode action 'Export finished'.
08050 /// Export finished.
08051 /// @param  [in]  anAction     Handle to action to decode.
08052 /// @param  [out] aExportID    Export GUID.
08053 /// @param  [out] aSuccess     Success.
08054 /// @return \c true if the function succeeds, \c false otherwise.
08055 ///         To get extended error information, call \ref GscAct_GetLastError.
08056 GSCACTDLLCALL bool        __stdcall GscAct_DecodeExportFinished(
08057   ConstHGscAction anAction,
08058   GUID& aExportID,
08059   PlcExportSuccess& aSuccess);
08060
08061 /// Decode action 'Export progress'.
08062 /// Export progress.
08063 /// @param  [in]  anAction     Handle to action to decode.
08064 /// @param  [out] aExportID    Export GUID.
08065 /// @param  [out] aProgress    Progress.
08066 /// @return \c true if the function succeeds, \c false otherwise.
08067 ///         To get extended error information, call \ref GscAct_GetLastError.
08068 GSCACTDLLCALL bool        __stdcall GscAct_DecodeExportProgress(
08069   ConstHGscAction anAction,
08070   GUID& aExportID,
08071   __int32& aProgress);
08072
08073 /// Decode action 'Fast speed off'.
08074 /// Turn camera fast speed off.
08075 /// @param  [in]  anAction     Handle to action to decode.
08076 /// @param  [out] aCamera      PTZ head.
08077 /// @return \c true if the function succeeds, \c false otherwise.
08078 ///         To get extended error information, call \ref GscAct_GetLastError.
08079 GSCACTDLLCALL bool        __stdcall GscAct_DecodeFastSpeedOff(
08080   ConstHGscAction anAction,
08081   TPlcMediaChannelID& aCamera);
08082
08083 /// Decode action 'Fast speed on'.
08084 /// Turn camera fast speed on.
08085 /// @param  [in]  anAction     Handle to action to decode.
08086 /// @param  [out] aCamera      PTZ head.
08087 /// @return \c true if the function succeeds, \c false otherwise.
08088 ///         To get extended error information, call \ref GscAct_GetLastError.
08089 GSCACTDLLCALL bool        __stdcall GscAct_DecodeFastSpeedOn(
08090   ConstHGscAction anAction,
08091   TPlcMediaChannelID& aCamera);
08092
08093 /// Decode action 'Filling pump status'.
08094 /// Filling pump status.
08095 /// @param  [in]  anAction     Handle to action to decode.
08096 /// @param  [out] aTerminalName Terminal name.
08097 /// @param  [out] aTimeStamp   Time stamp.
08098 /// @param  [out] aPumpNo      Pump no.
08099 /// @param  [out] aStatus      Status.
08100 /// @param  [out] aAmount      Amount.
08101 /// @param  [out] aPrice       Price.
08102 /// @param  [out] aDetails     Details.
08103 /// @return \c true if the function succeeds, \c false otherwise.
08104 ///         To get extended error information, call \ref GscAct_GetLastError.
08105 ///
08106 /// @warning   Following parameters are optional:  aAmount. aPrice. aDetails. \par
08107 ///            Values returned in these fields can be \c NULL pointers.
08108 GSCACTDLLCALL bool        __stdcall GscAct_DecodeFillingPumpStatus(
08109   ConstHGscAction anAction,
08110   const wchar_t*& aTerminalName,
08111   TGLibDateTime& aTimeStamp,
08112   __int32& aPumpNo,
08113   PlcPumpStatus& aStatus,
08114   const double*& aAmount,
08115   const double*& aPrice,
08116   const wchar_t*& aDetails);
08117
08118 /// Decode action 'Focus far'.
08119 /// Focus camera far.
08120 /// @param  [in]  anAction     Handle to action to decode.
08121 /// @param  [out] aCamera      PTZ head.
08122 /// @param  [out] aSpeed       Focus speed.
08123 /// @return \c true if the function succeeds, \c false otherwise.
08124 ///         To get extended error information, call \ref GscAct_GetLastError.
08125 GSCACTDLLCALL bool        __stdcall GscAct_DecodeFocusFar(
08126   ConstHGscAction anAction,
08127   TPlcMediaChannelID& aCamera,
08128   __int32& aSpeed);
08129
08130 /// Decode action 'Focus near'.
08131 /// Focus camera near.
08132 /// @param  [in]  anAction     Handle to action to decode.
08133 /// @param  [out] aCamera      PTZ head.
08134 /// @param  [out] aSpeed       Focus speed.
08135 /// @return \c true if the function succeeds, \c false otherwise.
08136 ///         To get extended error information, call \ref GscAct_GetLastError.
08137 GSCACTDLLCALL bool        __stdcall GscAct_DecodeFocusNear(
08138   ConstHGscAction anAction,
08139   TPlcMediaChannelID& aCamera,
08140   __int32& aSpeed);
08141
08142 /// Decode action 'Focus stop'.
08143 /// Stop camera focus.
08144 /// @param  [in]  anAction     Handle to action to decode.
08145 /// @param  [out] aCamera      PTZ head.
08146 /// @return \c true if the function succeeds, \c false otherwise.
08147 ///         To get extended error information, call \ref GscAct_GetLastError.
08148 GSCACTDLLCALL bool        __stdcall GscAct_DecodeFocusStop(
08149   ConstHGscAction anAction,
08150   TPlcMediaChannelID& aCamera);
08151
08152 /// Decode action 'FRC notification'.
08153 /// FRC notification.
08154 /// @param  [in]  anAction     Handle to action to decode.
08155 /// @param  [out] aNotification Notification reason.
08156 /// @param  [out] aParam       Additional parameter.
08157 /// @param  [out] aDescription Optional notification text.
08158 /// @param  [out] aXMLInfo     Optional additional info (usually as XML string).
08159 /// @return \c true if the function succeeds, \c false otherwise.
08160 ///         To get extended error information, call \ref GscAct_GetLastError.
08161 ///
08162 /// @warning   Following parameters are optional:  aParam. aDescription. aXMLInfo. \par
08163 ///            Values returned in these fields can be \c NULL pointers.
08164 GSCACTDLLCALL bool        __stdcall GscAct_DecodeFRCNotification(
08165   ConstHGscAction anAction,
08166   PlcFRCNotification& aNotification,
08167   const __int32*& aParam,
08168   const wchar_t*& aDescription,
08169   const char*& aXMLInfo);
08170
08171 /// Decode action 'GEMOS alarm'.
08172 /// GEMOS alarm notification.
08173 /// @param  [in]  anAction     Handle to action to decode.
08174 /// @param  [out] aGEMOSkey    GEMOS alarm key.
08175 /// @param  [out] aGEMOSint    GEMOS alarm integer parameter.
08176 /// @param  [out] aGEMOSstr    GEMOS alarm string parameter.
08177 /// @return \c true if the function succeeds, \c false otherwise.
08178 ///         To get extended error information, call \ref GscAct_GetLastError.
08179 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGEMOSalarm(
08180   ConstHGscAction anAction,
08181   __int64& aGEMOSkey,
08182   __int32& aGEMOSint,
08183   const wchar_t*& aGEMOSstr);
08184
08185 /// Decode action 'GSCS vehicle access denied'.
08186 /// GSCS vehicle access denied.
08187 /// @param  [in]  anAction     Handle to action to decode.
08188 /// @param  [out] aSequenceID  The sequence ID.
08189 /// @param  [out] aPlateNo     Recognized plate no.
08190 /// @param  [out] aTimeStamp   Time stamp.
08191 /// @param  [out] aCompanyCategory Company category.
08192 /// @param  [out] aCompanyName Company name.
08193 /// @param  [out] aReason      Reason.
08194 /// @param  [out] aTrafficLane Traffic lane.
08195 /// @param  [out] aChannel     Channel.
08196 /// @param  [out] aDirection   Direction.
08197 /// @return \c true if the function succeeds, \c false otherwise.
08198 ///         To get extended error information, call \ref GscAct_GetLastError.
08199 ///
08200 /// @warning   Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
08201 ///            Values returned in these fields can be \c NULL pointers.
08202 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGSCSVehicleAccessDenied(
08203   ConstHGscAction anAction,
08204   __int32& aSequenceID,
08205   const wchar_t*& aPlateNo,
08206   TGLibDateTime& aTimeStamp,
08207   const wchar_t*& aCompanyCategory,
08208   const wchar_t*& aCompanyName,
08209   const wchar_t*& aReason,
08210   const wchar_t*& aTrafficLane,
08211   const TPlcMediaChannelID*& aChannel,
08212   const TrafficDirection*& aDirection);
08213
08214 /// Decode action 'GSCS vehicle access expired'.
08215 /// GSCS vehicle access expired.
08216 /// @param  [in]  anAction     Handle to action to decode.
08217 /// @param  [out] aSequenceID  The sequence ID.
08218 /// @param  [out] aPlateNo     Recognized plate no.
08219 /// @param  [out] aTimeStamp   Time stamp.
08220 /// @param  [out] aExpiringTime Expiring time.
08221 /// @param  [out] aCompanyCategory Company category.
08222 /// @param  [out] aCompanyName Company name.
08223 /// @param  [out] aReason      Reason.
08224 /// @param  [out] aTrafficLane Traffic lane.
08225 /// @param  [out] aChannel     Channel.
08226 /// @param  [out] aDirection   Direction.
08227 /// @return \c true if the function succeeds, \c false otherwise.
08228 ///         To get extended error information, call \ref GscAct_GetLastError.
08229 ///
08230 /// @warning   Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
08231 ///            Values returned in these fields can be \c NULL pointers.
08232 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGSCSVehicleAccessExpired(
08233   ConstHGscAction anAction,
08234   __int32& aSequenceID,
08235   const wchar_t*& aPlateNo,
08236   TGLibDateTime& aTimeStamp,
08237   TGLibDateTime& aExpiringTime,
08238   const wchar_t*& aCompanyCategory,
08239   const wchar_t*& aCompanyName,
08240   const wchar_t*& aReason,
08241   const wchar_t*& aTrafficLane,
08242   const TPlcMediaChannelID*& aChannel,
08243   const TrafficDirection*& aDirection);
08244
08245 /// Decode action 'GSCS vehicle access granted'.
08246 /// GSCS vehicle access granted.
08247 /// @param  [in]  anAction     Handle to action to decode.
08248 /// @param  [out] aSequenceID  The sequence ID.
08249 /// @param  [out] aPlateNo     Recognized plate no.
08250 /// @param  [out] aTimeStamp   Time stamp.
08251 /// @param  [out] aCompanyCategory Company category.
08252 /// @param  [out] aCompanyName Company name.
08253 /// @param  [out] aReason      Reason.
08254 /// @param  [out] aTrafficLane Traffic lane.
08255 /// @param  [out] aChannel     Channel.
08256 /// @param  [out] aDirection   Direction.
08257 /// @return \c true if the function succeeds, \c false otherwise.
08258 ///         To get extended error information, call \ref GscAct_GetLastError.
08259 ///
08260 /// @warning   Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
08261 ///            Values returned in these fields can be \c NULL pointers.
08262 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGSCSVehicleAccessGranted(
08263   ConstHGscAction anAction,
08264   __int32& aSequenceID,
08265   const wchar_t*& aPlateNo,
08266   TGLibDateTime& aTimeStamp,
08267   const wchar_t*& aCompanyCategory,
08268   const wchar_t*& aCompanyName,
08269   const wchar_t*& aReason,
08270   const wchar_t*& aTrafficLane,
08271   const TPlcMediaChannelID*& aChannel,
08272   const TrafficDirection*& aDirection);
08273
08274 /// Decode action 'GSCS vehicle access pending'.
08275 /// GSCS vehicle access pending.
08276 /// @param  [in]  anAction     Handle to action to decode.
08277 /// @param  [out] aSequenceID  The sequence ID.
08278 /// @param  [out] aPlateNo     Recognized plate no.
08279 /// @param  [out] aTimeStamp   Time stamp.
08280 /// @param  [out] aCompanyCategory Company category.
08281 /// @param  [out] aCompanyName Company name.
08282 /// @param  [out] aReason      Reason.
08283 /// @param  [out] aTrafficLane Traffic lane.
08284 /// @param  [out] aChannel     Channel.
08285 /// @param  [out] aDirection   Direction.
08286 /// @return \c true if the function succeeds, \c false otherwise.
08287 ///         To get extended error information, call \ref GscAct_GetLastError.
08288 ///
08289 /// @warning   Following parameters are optional:  aCompanyCategory. aCompanyName. aReason. aTrafficLane. aChannel. aDirection. \par
08290 ///            Values returned in these fields can be \c NULL pointers.
08291 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGSCSVehicleAccessPending(
08292   ConstHGscAction anAction,
08293   __int32& aSequenceID,
08294   const wchar_t*& aPlateNo,
08295   TGLibDateTime& aTimeStamp,
08296   const wchar_t*& aCompanyCategory,
08297   const wchar_t*& aCompanyName,
08298   const wchar_t*& aReason,
08299   const wchar_t*& aTrafficLane,
08300   const TPlcMediaChannelID*& aChannel,
08301   const TrafficDirection*& aDirection);
08302
08303 /// Decode action 'G-Tect analytics live check'.
08304 /// This action will be fired periodically to ensure that analytics client is still running.
08305 /// @param  [in]  anAction     Handle to action to decode.
08306 /// @return \c true if the function succeeds, \c false otherwise.
08307 ///         To get extended error information, call \ref GscAct_GetLastError.
08308 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGTectAnalyticsLiveCheck(
08309   ConstHGscAction anAction);
08310
08311 /// Decode action 'G-Tect/Dual sensor alarm'.
08312 /// This action will be fired when G-Tect/Dual sensor detects an alarm.
08313 /// @param  [in]  anAction     Handle to action to decode.
08314 /// @param  [out] aChannel     Channel.
08315 /// @param  [out] aSterileZoneNumber Sterile Zone Number
08316 /// @param  [out] aVirtualFenceNumber Virtual Fence Number.
08317 /// @param  [out] aVMDGroup    VMD alarm group.
08318 /// @param  [out] aVMDZone     VMD zone nr.
08319 /// @param  [out] aVMDCycle    VMD measure cycle.
08320 /// @param  [out] aAlarmArea   Alarm area.
08321 /// @return \c true if the function succeeds, \c false otherwise.
08322 ///         To get extended error information, call \ref GscAct_GetLastError.
08323 ///
08324 /// @warning   Following parameters are optional:  aSterileZoneNumber. aVirtualFenceNumber. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. \par
08325 ///            Values returned in these fields can be \c NULL pointers.
08326 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGTectDualSensorAlarm(
08327   ConstHGscAction anAction,
08328   TPlcMediaChannelID& aChannel,
08329   const __int32*& aSterileZoneNumber,
08330   const __int32*& aVirtualFenceNumber,
08331   const VMDGroup*& aVMDGroup,
08332   const __int32*& aVMDZone,
08333   const VMDCycle*& aVMDCycle,
08334   const TPlcRect*& aAlarmArea);
08335
08336 /// Decode action 'G-Tect/Dual sensor alarm finished'.
08337 /// This action will be fired when the alarm is finished.
08338 /// @param  [in]  anAction     Handle to action to decode.
08339 /// @param  [out] aChannel     Channel.
08340 /// @return \c true if the function succeeds, \c false otherwise.
08341 ///         To get extended error information, call \ref GscAct_GetLastError.
08342 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGTectDualSensorAlarmFinished(
08343   ConstHGscAction anAction,
08344   TPlcMediaChannelID& aChannel);
08345
08346 /// Decode action 'G-Tect scene alarm'.
08347 /// This action will be fired when G-Tect Video content analysis detects a scene alarm.
08348 /// @param  [in]  anAction     Handle to action to decode.
08349 /// @param  [out] aChannel     Channel.
08350 /// @param  [out] aAlarmReason Alarm reason.
08351 /// @return \c true if the function succeeds, \c false otherwise.
08352 ///         To get extended error information, call \ref GscAct_GetLastError.
08353 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGTectSceneAlarm(
08354   ConstHGscAction anAction,
08355   TPlcMediaChannelID& aChannel,
08356   GTectSceneAlarmReason& aAlarmReason);
08357
08358 /// Decode action 'G-Tect scene alarm finished'.
08359 /// This action will be fired when G-Tect Video content analysis scene alarm is finished.
08360 /// @param  [in]  anAction     Handle to action to decode.
08361 /// @param  [out] aChannel     Channel.
08362 /// @param  [out] aAlarmReason Alarm reason.
08363 /// @return \c true if the function succeeds, \c false otherwise.
08364 ///         To get extended error information, call \ref GscAct_GetLastError.
08365 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGTectSceneAlarmFinished(
08366   ConstHGscAction anAction,
08367   TPlcMediaChannelID& aChannel,
08368   GTectSceneAlarmReason& aAlarmReason);
08369
08370 /// Decode action 'G-Tect/VMX alarm'.
08371 /// This action will be fired when G-Tect/VMX Video content analysis detects an alarm.
08372 /// @param  [in]  anAction     Handle to action to decode.
08373 /// @param  [out] aChannel     Channel.
08374 /// @param  [out] aSterileZoneNumber Sterile Zone Number
08375 /// @param  [out] aVirtualFenceNumber Virtual Fence Number.
08376 /// @param  [out] aAlarmGroup  Used to group different Zones or fences to the same level.
08377 /// @param  [out] aTrackID     Internal Track ID.
08378 /// @param  [out] aAlarmArea   Alarm area.
08379 /// @return \c true if the function succeeds, \c false otherwise.
08380 ///         To get extended error information, call \ref GscAct_GetLastError.
08381 ///
08382 /// @warning   Following parameters are optional:  aSterileZoneNumber. aVirtualFenceNumber. aAlarmGroup. aTrackID. aAlarmArea. \par
08383 ///            Values returned in these fields can be \c NULL pointers.
08384 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGTectVMXAlarm(
08385   ConstHGscAction anAction,
08386   TPlcMediaChannelID& aChannel,
08387   const __int32*& aSterileZoneNumber,
08388   const __int32*& aVirtualFenceNumber,
08389   const __int32*& aAlarmGroup,
08390   const __int32*& aTrackID,
08391   const TPlcRect*& aAlarmArea);
08392
08393 /// Decode action 'G-Tect/VMX alarm finished'.
08394 /// This action will be fired when the alarm is finished.
08395 /// @param  [in]  anAction     Handle to action to decode.
08396 /// @param  [out] aChannel     Channel.
08397 /// @return \c true if the function succeeds, \c false otherwise.
08398 ///         To get extended error information, call \ref GscAct_GetLastError.
08399 GSCACTDLLCALL bool        __stdcall GscAct_DecodeGTectVMXAlarmFinished(
08400   ConstHGscAction anAction,
08401   TPlcMediaChannelID& aChannel);
08402
08403 /// Decode action 'IAS settings changed'.
08404 /// IAS settings changed.
08405 /// @param  [in]  anAction     Handle to action to decode.
08406 /// @param  [out] aChannel     Channel.
08407 /// @param  [out] aSensorType  Sensor type.
08408 /// @return \c true if the function succeeds, \c false otherwise.
08409 ///         To get extended error information, call \ref GscAct_GetLastError.
08410 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIASSettingsChanged(
08411   ConstHGscAction anAction,
08412   TPlcMediaChannelID& aChannel,
08413   VideoSensorKind& aSensorType);
08414
08415 /// Decode action 'Image export notification'.
08416 /// Notification on export or print of channel images.
08417 /// @param  [in]  anAction     Handle to action to decode.
08418 /// @param  [out] aUser        Name of the user connected to the system.
08419 /// @param  [out] aDestination Destination.
08420 /// @param  [out] aDestinationType Destination type.
08421 /// @param  [out] aTimeStamp   Time stamp.
08422 /// @param  [out] aTimeEnd     End time.
08423 /// @param  [out] aChannels    Channels.
08424 /// @param  [out] aClientHost  Host from where the connection is done.
08425 /// @param  [out] aClientType  Client type.
08426 /// @param  [out] aClientAccount User account from where the connection is done.
08427 /// @return \c true if the function succeeds, \c false otherwise.
08428 ///         To get extended error information, call \ref GscAct_GetLastError.
08429 ///
08430 /// @warning   Following parameters are optional:  aTimeEnd. aClientHost. aClientType. aClientAccount. \par
08431 ///            Values returned in these fields can be \c NULL pointers.
08432 GSCACTDLLCALL bool        __stdcall GscAct_DecodeImageExportNotification(
08433   ConstHGscAction anAction,
08434   const wchar_t*& aUser,
08435   const wchar_t*& aDestination,
08436   PlcImageExportType& aDestinationType,
08437   TGLibDateTime& aTimeStamp,
08438   const TGLibDateTime*& aTimeEnd,
08439   const wchar_t*& aChannels,
08440   const wchar_t*& aClientHost,
08441   const PlcClientType*& aClientType,
08442   const wchar_t*& aClientAccount);
08443
08444 /// Decode action 'Imex capacity file auto deleted'.
08445 /// Imex capacity warning: file auto deleted.
08446 /// @param  [in]  anAction     Handle to action to decode.
08447 /// @param  [out] aWarning     Warning.
08448 /// @param  [out] aDestination Destination.
08449 /// @param  [out] aTotalCapacity Total capacity.
08450 /// @param  [out] aFreeCapacity Free capacity.
08451 /// @param  [out] aAllocatedByImageFile Allocated by image file.
08452 /// @param  [out] aPercentFree Percent free.
08453 /// @param  [out] aPercentAllocated Percent allocated.
08454 /// @param  [out] aPercentAllocatedByImageFile Percent allocated by image file.
08455 /// @param  [out] aTotalFileSize Total file size.
08456 /// @param  [out] aNumberOfFiles Number of files.
08457 /// @return \c true if the function succeeds, \c false otherwise.
08458 ///         To get extended error information, call \ref GscAct_GetLastError.
08459 GSCACTDLLCALL bool        __stdcall GscAct_DecodeImexCapacityFileAutoDeleted(
08460   ConstHGscAction anAction,
08461   ABCapacityWarning& aWarning,
08462   TPlcResourceID& aDestination,
08463   __int64& aTotalCapacity,
08464   __int64& aFreeCapacity,
08465   __int64& aAllocatedByImageFile,
08466   __int32& aPercentFree,
08467   __int32& aPercentAllocated,
08468   __int32& aPercentAllocatedByImageFile,
08469   __int64& aTotalFileSize,
08470   __int32& aNumberOfFiles);
08471
08472 /// Decode action 'Imex capacity out of disk space.'.
08473 /// Imex capacity warning: out of disk space.
08474 /// @param  [in]  anAction     Handle to action to decode.
08475 /// @param  [out] aWarning     Warning.
08476 /// @param  [out] aDestination Destination.
08477 /// @param  [out] aTotalCapacity Total capacity.
08478 /// @param  [out] aFreeCapacity Free capacity.
08479 /// @param  [out] aAllocatedByImageFile Allocated by image file.
08480 /// @param  [out] aPercentFree Percent free.
08481 /// @param  [out] aPercentAllocated Percent allocated.
08482 /// @param  [out] aPercentAllocatedByImageFile Percent allocated by image file.
08483 /// @return \c true if the function succeeds, \c false otherwise.
08484 ///         To get extended error information, call \ref GscAct_GetLastError.
08485 GSCACTDLLCALL bool        __stdcall GscAct_DecodeImexCapacityOutOfDiskSpace(
08486   ConstHGscAction anAction,
08487   ABCapacityWarning& aWarning,
08488   TPlcResourceID& aDestination,
08489   __int64& aTotalCapacity,
08490   __int64& aFreeCapacity,
08491   __int64& aAllocatedByImageFile,
08492   __int32& aPercentFree,
08493   __int32& aPercentAllocated,
08494   __int32& aPercentAllocatedByImageFile);
08495
08496 /// Decode action 'Imex capacity warning'.
08497 /// Imex capacity warning: capacity warning.
08498 /// @param  [in]  anAction     Handle to action to decode.
08499 /// @param  [out] aWarning     Warning.
08500 /// @param  [out] aDestination Destination.
08501 /// @param  [out] aTotalCapacity Total capacity.
08502 /// @param  [out] aFreeCapacity Free capacity.
08503 /// @param  [out] aAllocatedByImageFile Allocated by image file.
08504 /// @param  [out] aPercentFree Percent free.
08505 /// @param  [out] aPercentAllocated Percent allocated.
08506 /// @param  [out] aPercentAllocatedByImageFile Percent allocated by image file.
08507 /// @return \c true if the function succeeds, \c false otherwise.
08508 ///         To get extended error information, call \ref GscAct_GetLastError.
08509 GSCACTDLLCALL bool        __stdcall GscAct_DecodeImexCapacityWarning(
08510   ConstHGscAction anAction,
08511   ABCapacityWarning& aWarning,
08512   TPlcResourceID& aDestination,
08513   __int64& aTotalCapacity,
08514   __int64& aFreeCapacity,
08515   __int64& aAllocatedByImageFile,
08516   __int32& aPercentFree,
08517   __int32& aPercentAllocated,
08518   __int32& aPercentAllocatedByImageFile);
08519
08520 /// Decode action 'Imex export event image'.
08521 /// Imex export event image.
08522 /// @param  [in]  anAction     Handle to action to decode.
08523 /// @param  [out] aEventID     Instance ID of the event.
08524 /// @param  [out] aTypeID      Type of the event.
08525 /// @param  [out] aDestination Destination.
08526 /// @param  [out] aFilePath    File name.
08527 /// @return \c true if the function succeeds, \c false otherwise.
08528 ///         To get extended error information, call \ref GscAct_GetLastError.
08529 ///
08530 /// @warning   Following parameters are optional:  aDestination. aFilePath. \par
08531 ///            Values returned in these fields can be \c NULL pointers.
08532 GSCACTDLLCALL bool        __stdcall GscAct_DecodeImexExportEventImage(
08533   ConstHGscAction anAction,
08534   __int64& aEventID,
08535   TPlcEventTypeID& aTypeID,
08536   const TPlcResourceID*& aDestination,
08537   const wchar_t*& aFilePath);
08538
08539 /// Decode action 'Imex export image from DB'.
08540 /// Imex export image from DB.
08541 /// @param  [in]  anAction     Handle to action to decode.
08542 /// @param  [out] aChannel     Channel.
08543 /// @param  [out] aDestination Destination.
08544 /// @param  [out] aFilePath    File name.
08545 /// @param  [out] aPictureTime Picture time.
08546 /// @return \c true if the function succeeds, \c false otherwise.
08547 ///         To get extended error information, call \ref GscAct_GetLastError.
08548 ///
08549 /// @warning   Following parameters are optional:  aDestination. aFilePath. aPictureTime. \par
08550 ///            Values returned in these fields can be \c NULL pointers.
08551 GSCACTDLLCALL bool        __stdcall GscAct_DecodeImexExportImageFromDB(
08552   ConstHGscAction anAction,
08553   TPlcMediaChannelID& aChannel,
08554   const TPlcResourceID*& aDestination,
08555   const wchar_t*& aFilePath,
08556   const TGLibDateTime*& aPictureTime);
08557
08558 /// Decode action 'Imex export image from live stream'.
08559 /// Imex export image from live stream.
08560 /// @param  [in]  anAction     Handle to action to decode.
08561 /// @param  [out] aChannel     Channel.
08562 /// @param  [out] aDestination Destination.
08563 /// @param  [out] aFilePath    File name.
08564 /// @return \c true if the function succeeds, \c false otherwise.
08565 ///         To get extended error information, call \ref GscAct_GetLastError.
08566 ///
08567 /// @warning   Following parameters are optional:  aDestination. aFilePath. \par
08568 ///            Values returned in these fields can be \c NULL pointers.
08569 GSCACTDLLCALL bool        __stdcall GscAct_DecodeImexExportImageFromLiveStream(
08570   ConstHGscAction anAction,
08571   TPlcMediaChannelID& aChannel,
08572   const TPlcResourceID*& aDestination,
08573   const wchar_t*& aFilePath);
08574
08575 /// Decode action 'Initialize remote export'.
08576 /// Initialize remote export.
08577 /// @param  [in]  anAction     Handle to action to decode.
08578 /// @param  [out] aViewer      Global viewer or viewer client no.
08579 /// @param  [out] aDevice      Pilot device GUID.
08580 /// @return \c true if the function succeeds, \c false otherwise.
08581 ///         To get extended error information, call \ref GscAct_GetLastError.
08582 GSCACTDLLCALL bool        __stdcall GscAct_DecodeInitializeRemoteExport(
08583   ConstHGscAction anAction,
08584   TPlcMediaChannelID& aViewer,
08585   GUID& aDevice);
08586
08587 /// Decode action 'Interface raw answer'.
08588 /// Interface raw answer.
08589 /// @param  [in]  anAction     Handle to action to decode.
08590 /// @param  [out] aInterfaceName Interface name.
08591 /// @param  [out] aTimeStamp   Time stamp.
08592 /// @param  [out] aData        Interface answer.
08593 /// @return \c true if the function succeeds, \c false otherwise.
08594 ///         To get extended error information, call \ref GscAct_GetLastError.
08595 GSCACTDLLCALL bool        __stdcall GscAct_DecodeInterfaceRawAnswer(
08596   ConstHGscAction anAction,
08597   const wchar_t*& aInterfaceName,
08598   TGLibDateTime& aTimeStamp,
08599   const wchar_t*& aData);
08600
08601 /// Decode action 'Interface raw data'.
08602 /// Interface raw data.
08603 /// @param  [in]  anAction     Handle to action to decode.
08604 /// @param  [out] aInterfaceName Interface name.
08605 /// @param  [out] aTimeStamp   Time stamp.
08606 /// @param  [out] aData        Interface data.
08607 /// @return \c true if the function succeeds, \c false otherwise.
08608 ///         To get extended error information, call \ref GscAct_GetLastError.
08609 GSCACTDLLCALL bool        __stdcall GscAct_DecodeInterfaceRawData(
08610   ConstHGscAction anAction,
08611   const wchar_t*& aInterfaceName,
08612   TGLibDateTime& aTimeStamp,
08613   const wchar_t*& aData);
08614
08615 /// Decode action 'IOI43 reset mainboard'.
08616 /// Reset mainboard using IOI43a/ab USB Alarm-I/O.
08617 /// @param  [in]  anAction     Handle to action to decode.
08618 /// @return \c true if the function succeeds, \c false otherwise.
08619 ///         To get extended error information, call \ref GscAct_GetLastError.
08620 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIOI43ResetMainboard(
08621   ConstHGscAction anAction);
08622
08623 /// Decode action 'IOI43 temperature notification'.
08624 /// Temperature notification from IOI43a/ab USB Alarm-I/O.
08625 /// @param  [in]  anAction     Handle to action to decode.
08626 /// @param  [out] aID          ID of the IOI43 module (like IOI43-00).
08627 /// @param  [out] aTemperature Temperature.
08628 /// @return \c true if the function succeeds, \c false otherwise.
08629 ///         To get extended error information, call \ref GscAct_GetLastError.
08630 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIOI43Temperature(
08631   ConstHGscAction anAction,
08632   const wchar_t*& aID,
08633   __int32& aTemperature);
08634
08635 /// Decode action 'IOI43 watchdog activate'.
08636 /// Activate watchdog on IOI43a/ab USB Alarm-I/O.
08637 /// @param  [in]  anAction     Handle to action to decode.
08638 /// @return \c true if the function succeeds, \c false otherwise.
08639 ///         To get extended error information, call \ref GscAct_GetLastError.
08640 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIOI43WDActivate(
08641   ConstHGscAction anAction);
08642
08643 /// Decode action 'IOI43 watchdog deactivate'.
08644 /// Deactivate watchdog on IOI43a/ab USB Alarm-I/O.
08645 /// @param  [in]  anAction     Handle to action to decode.
08646 /// @return \c true if the function succeeds, \c false otherwise.
08647 ///         To get extended error information, call \ref GscAct_GetLastError.
08648 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIOI43WDDeactivate(
08649   ConstHGscAction anAction);
08650
08651 /// Decode action 'IOI43 watchdog trigger'.
08652 /// Trigger watchdog on IOI43a/ab USB Alarm-I/O.
08653 /// @param  [in]  anAction     Handle to action to decode.
08654 /// @return \c true if the function succeeds, \c false otherwise.
08655 ///         To get extended error information, call \ref GscAct_GetLastError.
08656 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIOI43WDTrigger(
08657   ConstHGscAction anAction);
08658
08659 /// Decode action 'IP camera raw command'.
08660 /// This action sends a special command to the IP camera.
08661 /// @param  [in]  anAction     Handle to action to decode.
08662 /// @param  [out] aURL         Complete command URL (like http://192.168.0.165:80/set?daynight=night).
08663 /// @param  [out] aUser        User name to authenticate by the camera (optional).
08664 /// @param  [out] aPassword    Password to authenticate by the camera (optional).
08665 /// @param  [out] aPOST        POST parameters (optional, separate lines with \\r\\n).
08666 /// @return \c true if the function succeeds, \c false otherwise.
08667 ///         To get extended error information, call \ref GscAct_GetLastError.
08668 ///
08669 /// @warning   Following parameters are optional:  aUser. aPassword. aPOST. \par
08670 ///            Values returned in these fields can be \c NULL pointers.
08671 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIPCameraRawCommand(
08672   ConstHGscAction anAction,
08673   const wchar_t*& aURL,
08674   const wchar_t*& aUser,
08675   const wchar_t*& aPassword,
08676   const wchar_t*& aPOST);
08677
08678 /// Decode action 'IP camera failover notification'.
08679 /// IP camera failover notification.
08680 /// @param  [in]  anAction     Handle to action to decode.
08681 /// @param  [out] aPrimaryServer The name of the primary server.
08682 /// @param  [out] aSecondaryServer The name of the secondary server.
08683 /// @param  [out] aPrimaryChannel Primary channel.
08684 /// @param  [out] aSecondaryChannel Secondary channel.
08685 /// @param  [out] aCameraParameters Optional camera parameters.
08686 /// @return \c true if the function succeeds, \c false otherwise.
08687 ///         To get extended error information, call \ref GscAct_GetLastError.
08688 ///
08689 /// @warning   Following parameters are optional:  aCameraParameters. \par
08690 ///            Values returned in these fields can be \c NULL pointers.
08691 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIPCamFailoverNotification(
08692   ConstHGscAction anAction,
08693   const wchar_t*& aPrimaryServer,
08694   const wchar_t*& aSecondaryServer,
08695   TPlcMediaChannelID& aPrimaryChannel,
08696   TPlcMediaChannelID& aSecondaryChannel,
08697   const wchar_t*& aCameraParameters);
08698
08699 /// Decode action 'IP camera failover restore'.
08700 /// IP camera failover restore.
08701 /// @param  [in]  anAction     Handle to action to decode.
08702 /// @param  [out] aPrimaryServer The name of the primary server.
08703 /// @param  [out] aSecondaryServer The name of the secondary server.
08704 /// @param  [out] aPrimaryChannel Primary channel.
08705 /// @param  [out] aSecondaryChannel Secondary channel.
08706 /// @param  [out] aCameraParameters Optional camera parameters.
08707 /// @return \c true if the function succeeds, \c false otherwise.
08708 ///         To get extended error information, call \ref GscAct_GetLastError.
08709 ///
08710 /// @warning   Following parameters are optional:  aCameraParameters. \par
08711 ///            Values returned in these fields can be \c NULL pointers.
08712 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIPCamFailoverRestore(
08713   ConstHGscAction anAction,
08714   const wchar_t*& aPrimaryServer,
08715   const wchar_t*& aSecondaryServer,
08716   TPlcMediaChannelID& aPrimaryChannel,
08717   TPlcMediaChannelID& aSecondaryChannel,
08718   const wchar_t*& aCameraParameters);
08719
08720 /// Decode action 'IP switch operation'.
08721 /// IP switch operation.
08722 /// @param  [in]  anAction     Handle to action to decode.
08723 /// @param  [out] aOperation   Operation.
08724 /// @param  [out] aPort        Port no, IP address, MAC address.
08725 /// @param  [out] aParam       Optional parameter.
08726 /// @return \c true if the function succeeds, \c false otherwise.
08727 ///         To get extended error information, call \ref GscAct_GetLastError.
08728 ///
08729 /// @warning   Following parameters are optional:  aParam. \par
08730 ///            Values returned in these fields can be \c NULL pointers.
08731 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIPSwitchOperation(
08732   ConstHGscAction anAction,
08733   IPSwitchOps& aOperation,
08734   const wchar_t*& aPort,
08735   const __int32*& aParam);
08736
08737 /// Decode action 'Iris close'.
08738 /// Close camera iris.
08739 /// @param  [in]  anAction     Handle to action to decode.
08740 /// @param  [out] aCamera      PTZ head.
08741 /// @return \c true if the function succeeds, \c false otherwise.
08742 ///         To get extended error information, call \ref GscAct_GetLastError.
08743 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIrisClose(
08744   ConstHGscAction anAction,
08745   TPlcMediaChannelID& aCamera);
08746
08747 /// Decode action 'Iris open'.
08748 /// Open camera iris.
08749 /// @param  [in]  anAction     Handle to action to decode.
08750 /// @param  [out] aCamera      PTZ head.
08751 /// @return \c true if the function succeeds, \c false otherwise.
08752 ///         To get extended error information, call \ref GscAct_GetLastError.
08753 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIrisOpen(
08754   ConstHGscAction anAction,
08755   TPlcMediaChannelID& aCamera);
08756
08757 /// Decode action 'Iris stop'.
08758 /// Stop camera iris.
08759 /// @param  [in]  anAction     Handle to action to decode.
08760 /// @param  [out] aCamera      PTZ head.
08761 /// @return \c true if the function succeeds, \c false otherwise.
08762 ///         To get extended error information, call \ref GscAct_GetLastError.
08763 GSCACTDLLCALL bool        __stdcall GscAct_DecodeIrisStop(
08764   ConstHGscAction anAction,
08765   TPlcMediaChannelID& aCamera);
08766
08767 /// Decode action 'Key pressed'.
08768 /// This action is notified if one of the GEVISCOPE system keys is pressed.
08769 /// @param  [in]  anAction     Handle to action to decode.
08770 /// @param  [out] aKey         System key.
08771 /// @return \c true if the function succeeds, \c false otherwise.
08772 ///         To get extended error information, call \ref GscAct_GetLastError.
08773 GSCACTDLLCALL bool        __stdcall GscAct_DecodeKeyPressed(
08774   ConstHGscAction anAction,
08775   SystemKey& aKey);
08776
08777 /// Decode action 'Key released'.
08778 /// This action is notified if one of the GEVISCOPE system keys is released.
08779 /// @param  [in]  anAction     Handle to action to decode.
08780 /// @param  [out] aKey         System key.
08781 /// @return \c true if the function succeeds, \c false otherwise.
08782 ///         To get extended error information, call \ref GscAct_GetLastError.
08783 GSCACTDLLCALL bool        __stdcall GscAct_DecodeKeyReleased(
08784   ConstHGscAction anAction,
08785   SystemKey& aKey);
08786
08787 /// Decode action 'Kill all events'.
08788 /// Kill all active events.
08789 /// @param  [in]  anAction     Handle to action to decode.
08790 /// @return \c true if the function succeeds, \c false otherwise.
08791 ///         To get extended error information, call \ref GscAct_GetLastError.
08792 GSCACTDLLCALL bool        __stdcall GscAct_DecodeKillAllEvents(
08793   ConstHGscAction anAction);
08794
08795 /// Decode action 'Kill event'.
08796 /// Kill event.
08797 /// @param  [in]  anAction     Handle to action to decode.
08798 /// @param  [out] aTypeID      Type of the event.
08799 /// @return \c true if the function succeeds, \c false otherwise.
08800 ///         To get extended error information, call \ref GscAct_GetLastError.
08801 GSCACTDLLCALL bool        __stdcall GscAct_DecodeKillEvent(
08802   ConstHGscAction anAction,
08803   TPlcEventTypeID& aTypeID);
08804
08805 /// Decode action 'Kill event by instance'.
08806 /// Kill event by instance ID.
08807 /// @param  [in]  anAction     Handle to action to decode.
08808 /// @param  [out] aEventID     Instance ID of the event.
08809 /// @return \c true if the function succeeds, \c false otherwise.
08810 ///         To get extended error information, call \ref GscAct_GetLastError.
08811 GSCACTDLLCALL bool        __stdcall GscAct_DecodeKillEventByID(
08812   ConstHGscAction anAction,
08813   __int64& aEventID);
08814
08815 /// Decode action 'Lenel access event'.
08816 /// Lenel OnGuard access event.
08817 /// @param  [in]  anAction     Handle to action to decode.
08818 /// @param  [out] aID          The ID that uniquely identifies the type of this event.
08819 /// @param  [out] aPanel       The name of the panel where this event originated.
08820 /// @param  [out] aDevice      The name of the device where this event originated.
08821 /// @param  [out] aSecondaryDevice The ID of the secondary device where this event originated.
08822 /// @param  [out] aCardNumber  The badge ID for the card that was read, if available.
08823 /// @param  [out] aAccessResult The level of access that was granted that resulted from reading the card.
08824 /// @param  [out] aType        Event type i.e., duress, system, etc.
08825 /// @param  [out] aSubType     Event sub-type i.e., granted, door forced open, etc.
08826 /// @param  [out] aDescription A human readable, brief description of this event.
08827 /// @param  [out] aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
08828 /// @param  [out] aTimeStamp   Time stamp.
08829 /// @param  [out] aAreaEnteredID The ID of the area that was entered, if any.
08830 /// @param  [out] aAreaExitedID The ID of the area that was exited, if any.
08831 /// @param  [out] aAssetID     The ID of the asset related to this event, if any.
08832 /// @param  [out] aCardholderEntered Whether entry was made by the cardholder.
08833 /// @param  [out] aDuress      Indicates whether this card access indicates an under duress/emergency state.
08834 /// @param  [out] aElevatorFloor The elevator floor on which the access event was generated, if any.
08835 /// @param  [out] aFacilityCode The facility code for the card that was read, if available.
08836 /// @param  [out] aIsReadableCard Whether the card could be read.
08837 /// @param  [out] aIssueCode   The issue code for the card that was read, if available.
08838 /// @param  [out] aCommServerHostName Host name of the Communication server through which the event arrived.
08839 /// @param  [out] aEventText   Text associated with event
08840 /// @return \c true if the function succeeds, \c false otherwise.
08841 ///         To get extended error information, call \ref GscAct_GetLastError.
08842 ///
08843 /// @warning   Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aCardNumber. aAccessResult. aType. aSubType. aSerialNumber. aTimeStamp. aAreaEnteredID. aAreaExitedID. aAssetID. aCardholderEntered. aDuress. aElevatorFloor. aFacilityCode. aIsReadableCard. aIssueCode. aCommServerHostName. aEventText. \par
08844 ///            Values returned in these fields can be \c NULL pointers.
08845 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLenelAccessEvent(
08846   ConstHGscAction anAction,
08847   const LenelEventID*& aID,
08848   const wchar_t*& aPanel,
08849   const wchar_t*& aDevice,
08850   const __int32*& aSecondaryDevice,
08851   const __int64*& aCardNumber,
08852   const LenelAccessResult*& aAccessResult,
08853   const LenelEventType*& aType,
08854   const __int32*& aSubType,
08855   const wchar_t*& aDescription,
08856   const __int32*& aSerialNumber,
08857   const TGLibDateTime*& aTimeStamp,
08858   const __int32*& aAreaEnteredID,
08859   const __int32*& aAreaExitedID,
08860   const wchar_t*& aAssetID,
08861   const bool*& aCardholderEntered,
08862   const bool*& aDuress,
08863   const __int32*& aElevatorFloor,
08864   const __int32*& aFacilityCode,
08865   const bool*& aIsReadableCard,
08866   const __int32*& aIssueCode,
08867   const wchar_t*& aCommServerHostName,
08868   const wchar_t*& aEventText);
08869
08870 /// Decode action 'Lenel fire event'.
08871 /// Lenel OnGuard fire event.
08872 /// @param  [in]  anAction     Handle to action to decode.
08873 /// @param  [out] aID          The ID that uniquely identifies the type of this event.
08874 /// @param  [out] aPanel       The name of the panel where this event originated.
08875 /// @param  [out] aDevice      The name of the device where this event originated.
08876 /// @param  [out] aSecondaryDevice The ID of the secondary device where this event originated.
08877 /// @param  [out] aTroubleCode A trouble code associated with the fire event.
08878 /// @param  [out] aType        Event type i.e., duress, system, etc.
08879 /// @param  [out] aSubType     Event sub-type i.e., granted, door forced open, etc.
08880 /// @param  [out] aDescription A human readable, brief description of this event.
08881 /// @param  [out] aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
08882 /// @param  [out] aTimeStamp   Time stamp.
08883 /// @param  [out] aCommServerHostName Host name of the Communication server through which the event arrived.
08884 /// @param  [out] aEventText   Text associated with event
08885 /// @return \c true if the function succeeds, \c false otherwise.
08886 ///         To get extended error information, call \ref GscAct_GetLastError.
08887 ///
08888 /// @warning   Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aTroubleCode. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText. \par
08889 ///            Values returned in these fields can be \c NULL pointers.
08890 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLenelFireEvent(
08891   ConstHGscAction anAction,
08892   const LenelEventID*& aID,
08893   const wchar_t*& aPanel,
08894   const wchar_t*& aDevice,
08895   const __int32*& aSecondaryDevice,
08896   const __int32*& aTroubleCode,
08897   const LenelEventType*& aType,
08898   const __int32*& aSubType,
08899   const wchar_t*& aDescription,
08900   const __int32*& aSerialNumber,
08901   const TGLibDateTime*& aTimeStamp,
08902   const wchar_t*& aCommServerHostName,
08903   const wchar_t*& aEventText);
08904
08905 /// Decode action 'Lenel intercom event'.
08906 /// Lenel OnGuard intercom event.
08907 /// @param  [in]  anAction     Handle to action to decode.
08908 /// @param  [out] aID          The ID that uniquely identifies the type of this event.
08909 /// @param  [out] aPanel       The name of the panel where this event originated.
08910 /// @param  [out] aDevice      The name of the device where this event originated.
08911 /// @param  [out] aSecondaryDevice The ID of the secondary device where this event originated.
08912 /// @param  [out] aIntercomData Additional data for the intercom event that occurred.
08913 /// @param  [out] aLineNumber  The line number involved in the intercom event.
08914 /// @param  [out] aType        Event type i.e., duress, system, etc.
08915 /// @param  [out] aSubType     Event sub-type i.e., granted, door forced open, etc.
08916 /// @param  [out] aDescription A human readable, brief description of this event.
08917 /// @param  [out] aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
08918 /// @param  [out] aTimeStamp   Time stamp.
08919 /// @param  [out] aCommServerHostName Host name of the Communication server through which the event arrived.
08920 /// @param  [out] aEventText   Text associated with event
08921 /// @return \c true if the function succeeds, \c false otherwise.
08922 ///         To get extended error information, call \ref GscAct_GetLastError.
08923 ///
08924 /// @warning   Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aIntercomData. aLineNumber. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText. \par
08925 ///            Values returned in these fields can be \c NULL pointers.
08926 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLenelIntercomEvent(
08927   ConstHGscAction anAction,
08928   const LenelEventID*& aID,
08929   const wchar_t*& aPanel,
08930   const wchar_t*& aDevice,
08931   const __int32*& aSecondaryDevice,
08932   const __int32*& aIntercomData,
08933   const __int32*& aLineNumber,
08934   const LenelEventType*& aType,
08935   const __int32*& aSubType,
08936   const wchar_t*& aDescription,
08937   const __int32*& aSerialNumber,
08938   const TGLibDateTime*& aTimeStamp,
08939   const wchar_t*& aCommServerHostName,
08940   const wchar_t*& aEventText);
08941
08942 /// Decode action 'Lenel raw data'.
08943 /// Lenel OnGuard raw data.
08944 /// @param  [in]  anAction     Handle to action to decode.
08945 /// @param  [out] aTimeStamp   Time stamp.
08946 /// @param  [out] aLenelData   Lenel OnGuard data.
08947 /// @return \c true if the function succeeds, \c false otherwise.
08948 ///         To get extended error information, call \ref GscAct_GetLastError.
08949 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLenelRawData(
08950   ConstHGscAction anAction,
08951   TGLibDateTime& aTimeStamp,
08952   const wchar_t*& aLenelData);
08953
08954 /// Decode action 'Lenel refresh names'.
08955 /// Lenel OnGuard refresh names.
08956 /// @param  [in]  anAction     Handle to action to decode.
08957 /// @return \c true if the function succeeds, \c false otherwise.
08958 ///         To get extended error information, call \ref GscAct_GetLastError.
08959 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLenelRefreshNames(
08960   ConstHGscAction anAction);
08961
08962 /// Decode action 'Lenel security event'.
08963 /// Lenel OnGuard security event.
08964 /// @param  [in]  anAction     Handle to action to decode.
08965 /// @param  [out] aID          The ID that uniquely identifies the type of this event.
08966 /// @param  [out] aPanel       The name of the panel where this event originated.
08967 /// @param  [out] aDevice      The name of the device where this event originated.
08968 /// @param  [out] aSecondaryDevice The ID of the secondary device where this event originated.
08969 /// @param  [out] aType        Event type i.e., duress, system, etc.
08970 /// @param  [out] aSubType     Event sub-type i.e., granted, door forced open, etc.
08971 /// @param  [out] aDescription A human readable, brief description of this event.
08972 /// @param  [out] aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
08973 /// @param  [out] aTimeStamp   Time stamp.
08974 /// @param  [out] aCommServerHostName Host name of the Communication server through which the event arrived.
08975 /// @param  [out] aEventText   Text associated with event
08976 /// @return \c true if the function succeeds, \c false otherwise.
08977 ///         To get extended error information, call \ref GscAct_GetLastError.
08978 ///
08979 /// @warning   Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aType. aSubType. aSerialNumber. aTimeStamp. aCommServerHostName. aEventText. \par
08980 ///            Values returned in these fields can be \c NULL pointers.
08981 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLenelSecurityEvent(
08982   ConstHGscAction anAction,
08983   const LenelEventID*& aID,
08984   const wchar_t*& aPanel,
08985   const wchar_t*& aDevice,
08986   const __int32*& aSecondaryDevice,
08987   const LenelEventType*& aType,
08988   const __int32*& aSubType,
08989   const wchar_t*& aDescription,
08990   const __int32*& aSerialNumber,
08991   const TGLibDateTime*& aTimeStamp,
08992   const wchar_t*& aCommServerHostName,
08993   const wchar_t*& aEventText);
08994
08995 /// Decode action 'Lenel video event'.
08996 /// Lenel OnGuard video event.
08997 /// @param  [in]  anAction     Handle to action to decode.
08998 /// @param  [out] aID          The ID that uniquely identifies the type of this event.
08999 /// @param  [out] aPanel       The name of the panel where this event originated.
09000 /// @param  [out] aDevice      The name of the device where this event originated.
09001 /// @param  [out] aSecondaryDevice The ID of the secondary device where this event originated.
09002 /// @param  [out] aChannel     The physical channel the camera is connected to that is creating this event.
09003 /// @param  [out] aType        Event type i.e., duress, system, etc.
09004 /// @param  [out] aSubType     Event sub-type i.e., granted, door forced open, etc.
09005 /// @param  [out] aDescription A human readable, brief description of this event.
09006 /// @param  [out] aSerialNumber A number that uniquely identifies the instance of the event for a particular panel.
09007 /// @param  [out] aTimeStamp   Time stamp.
09008 /// @param  [out] aStartTime   The time the video event started
09009 /// @param  [out] aEndTime     The time the video event ended.
09010 /// @param  [out] aCommServerHostName Host name of the Communication server through which the event arrived.
09011 /// @param  [out] aEventText   Text associated with event
09012 /// @return \c true if the function succeeds, \c false otherwise.
09013 ///         To get extended error information, call \ref GscAct_GetLastError.
09014 ///
09015 /// @warning   Following parameters are optional:  aID. aPanel. aDevice. aSecondaryDevice. aChannel. aType. aSubType. aSerialNumber. aTimeStamp. aStartTime. aEndTime. aCommServerHostName. aEventText. \par
09016 ///            Values returned in these fields can be \c NULL pointers.
09017 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLenelVideoEvent(
09018   ConstHGscAction anAction,
09019   const LenelEventID*& aID,
09020   const wchar_t*& aPanel,
09021   const wchar_t*& aDevice,
09022   const __int32*& aSecondaryDevice,
09023   const __int32*& aChannel,
09024   const LenelEventType*& aType,
09025   const __int32*& aSubType,
09026   const wchar_t*& aDescription,
09027   const __int32*& aSerialNumber,
09028   const TGLibDateTime*& aTimeStamp,
09029   const TGLibDateTime*& aStartTime,
09030   const TGLibDateTime*& aEndTime,
09031   const wchar_t*& aCommServerHostName,
09032   const wchar_t*& aEventText);
09033
09034 /// Decode action 'Live check'.
09035 /// This action will be fired every 10 seconds and is intended for use as live check.
09036 /// @param  [in]  anAction     Handle to action to decode.
09037 /// @param  [out] aCounter     This is the number of already fired live check actions.
09038 /// @param  [out] aDate        Current server time.
09039 /// @return \c true if the function succeeds, \c false otherwise.
09040 ///         To get extended error information, call \ref GscAct_GetLastError.
09041 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLiveCheck(
09042   ConstHGscAction anAction,
09043   __int64& aCounter,
09044   TGLibDateTime& aDate);
09045
09046 /// Decode action 'Log barcode data'.
09047 /// Logistic barcode data.
09048 /// @param  [in]  anAction     Handle to action to decode.
09049 /// @param  [out] aBarcode     Barcode.
09050 /// @param  [out] aHash        Hash value.
09051 /// @param  [out] aScanner     Scanner name or IP address.
09052 /// @param  [out] aAreaID      Area number.
09053 /// @param  [out] aAreaName    Area name.
09054 /// @param  [out] aChannel     Channel.
09055 /// @param  [out] aTimeStamp   Time stamp.
09056 /// @param  [out] aOrder       Order number.
09057 /// @param  [out] aShipment    Shipment number.
09058 /// @param  [out] aItem        Item number.
09059 /// @return \c true if the function succeeds, \c false otherwise.
09060 ///         To get extended error information, call \ref GscAct_GetLastError.
09061 ///
09062 /// @warning   Following parameters are optional:  aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aOrder. aShipment. aItem. \par
09063 ///            Values returned in these fields can be \c NULL pointers.
09064 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLogBarcodeData(
09065   ConstHGscAction anAction,
09066   const wchar_t*& aBarcode,
09067   const __int64*& aHash,
09068   const wchar_t*& aScanner,
09069   const __int64*& aAreaID,
09070   const wchar_t*& aAreaName,
09071   const TPlcMediaChannelID*& aChannel,
09072   const TGLibDateTime*& aTimeStamp,
09073   const wchar_t*& aOrder,
09074   const wchar_t*& aShipment,
09075   const wchar_t*& aItem);
09076
09077 /// Decode action 'Log barcode data LPS'.
09078 /// Logistic barcode and LPS data.
09079 /// @param  [in]  anAction     Handle to action to decode.
09080 /// @param  [out] aBarcode     Barcode.
09081 /// @param  [out] aHash        Hash value.
09082 /// @param  [out] aScanner     Scanner name or IP address.
09083 /// @param  [out] aAreaID      Area number.
09084 /// @param  [out] aAreaName    Area name.
09085 /// @param  [out] aChannel     Channel.
09086 /// @param  [out] aTimeStamp   Time stamp.
09087 /// @param  [out] aX           X coordinate.
09088 /// @param  [out] aY           Y coordinate.
09089 /// @param  [out] aZ           Z coordinate.
09090 /// @param  [out] aLpsTagID    LPS tag ID.
09091 /// @param  [out] aLpsStatus   LPS status.
09092 /// @param  [out] aLpsCellID   LPS cell ID.
09093 /// @param  [out] aLpsAreaID   LPS area ID.
09094 /// @param  [out] aUserParam   User param.
09095 /// @param  [out] aOrder       Order number.
09096 /// @param  [out] aShipment    Shipment number.
09097 /// @param  [out] aItem        Item number.
09098 /// @return \c true if the function succeeds, \c false otherwise.
09099 ///         To get extended error information, call \ref GscAct_GetLastError.
09100 ///
09101 /// @warning   Following parameters are optional:  aHash. aScanner. aAreaID. aAreaName. aChannel. aTimeStamp. aX. aY. aZ. aLpsTagID. aLpsStatus. aLpsCellID. aLpsAreaID. aUserParam. aOrder. aShipment. aItem. \par
09102 ///            Values returned in these fields can be \c NULL pointers.
09103 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLogBarcodeDataLPS(
09104   ConstHGscAction anAction,
09105   const wchar_t*& aBarcode,
09106   const __int64*& aHash,
09107   const wchar_t*& aScanner,
09108   const __int64*& aAreaID,
09109   const wchar_t*& aAreaName,
09110   const TPlcMediaChannelID*& aChannel,
09111   const TGLibDateTime*& aTimeStamp,
09112   const double*& aX,
09113   const double*& aY,
09114   const double*& aZ,
09115   const __int32*& aLpsTagID,
09116   const PlcLpsStatus*& aLpsStatus,
09117   const __int32*& aLpsCellID,
09118   const __int32*& aLpsAreaID,
09119   const __int32*& aUserParam,
09120   const wchar_t*& aOrder,
09121   const wchar_t*& aShipment,
09122   const wchar_t*& aItem);
09123
09124 /// Decode action 'Log NPR recognition'.
09125 /// Log NPR recognition.
09126 /// @param  [in]  anAction     Handle to action to decode.
09127 /// @param  [out] aPlateNo     Recognized plate no.
09128 /// @param  [out] aHash        Hash value.
09129 /// @param  [out] aCountry     Country.
09130 /// @param  [out] aChannel     Channel.
09131 /// @param  [out] aTimeStamp   Time stamp.
09132 /// @param  [out] aRestriction Restriction of recognized number.
09133 /// @param  [out] aCategory    Category of recognized number.
09134 /// @return \c true if the function succeeds, \c false otherwise.
09135 ///         To get extended error information, call \ref GscAct_GetLastError.
09136 ///
09137 /// @warning   Following parameters are optional:  aHash. aCountry. aChannel. aTimeStamp. aRestriction. aCategory. \par
09138 ///            Values returned in these fields can be \c NULL pointers.
09139 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLogNPRRecognition(
09140   ConstHGscAction anAction,
09141   const wchar_t*& aPlateNo,
09142   const __int64*& aHash,
09143   const wchar_t*& aCountry,
09144   const TPlcMediaChannelID*& aChannel,
09145   const TGLibDateTime*& aTimeStamp,
09146   const PlcNPRRestriction*& aRestriction,
09147   const wchar_t*& aCategory);
09148
09149 /// Decode action 'LPS position data'.
09150 /// LPS position data.
09151 /// @param  [in]  anAction     Handle to action to decode.
09152 /// @param  [out] aTagID       Tag ID.
09153 /// @param  [out] aScannerID   Scanner ID or IP address.
09154 /// @param  [out] aX           X coordinate of cartesian coordinates.
09155 /// @param  [out] aY           Y coordinate of cartesian coordinates.
09156 /// @param  [out] aZ           Z coordinate of cartesian coordinates.
09157 /// @param  [out] aLatitude    Latitude of geographic coordinates.
09158 /// @param  [out] aLongitude   Longitude of geographic coordinates.
09159 /// @param  [out] aAreaID      Area ID.
09160 /// @param  [out] aCellID      Cell ID.
09161 /// @param  [out] aStatus      Status.
09162 /// @param  [out] aTimeStamp   Time stamp.
09163 /// @param  [out] aData        Data.
09164 /// @param  [out] aAreaName    Area Name.
09165 /// @return \c true if the function succeeds, \c false otherwise.
09166 ///         To get extended error information, call \ref GscAct_GetLastError.
09167 ///
09168 /// @warning   Following parameters are optional:  aScannerID. aZ. aLatitude. aLongitude. aCellID. aTimeStamp. aData. aAreaName. \par
09169 ///            Values returned in these fields can be \c NULL pointers.
09170 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLPSPositionData(
09171   ConstHGscAction anAction,
09172   __int32& aTagID,
09173   const wchar_t*& aScannerID,
09174   __int64& aX,
09175   __int64& aY,
09176   const __int64*& aZ,
09177   const double*& aLatitude,
09178   const double*& aLongitude,
09179   __int32& aAreaID,
09180   const __int32*& aCellID,
09181   PlcLpsStatus& aStatus,
09182   const TGLibDateTime*& aTimeStamp,
09183   const wchar_t*& aData,
09184   const wchar_t*& aAreaName);
09185
09186 /// Decode action 'LPS query position'.
09187 /// Send position query for a Tag to LPS server.
09188 /// @param  [in]  anAction     Handle to action to decode.
09189 /// @param  [out] aTagID       Tag ID.
09190 /// @param  [out] aScannerID   Scanner ID or IP address.
09191 /// @param  [out] aData        Data.
09192 /// @return \c true if the function succeeds, \c false otherwise.
09193 ///         To get extended error information, call \ref GscAct_GetLastError.
09194 ///
09195 /// @warning   Following parameters are optional:  aScannerID. aData. \par
09196 ///            Values returned in these fields can be \c NULL pointers.
09197 GSCACTDLLCALL bool        __stdcall GscAct_DecodeLPSQueryPosition(
09198   ConstHGscAction anAction,
09199   __int32& aTagID,
09200   const wchar_t*& aScannerID,
09201   const wchar_t*& aData);
09202
09203 /// Decode action 'Make CPA reference image'.
09204 /// Make CPA reference image.
09205 /// @param  [in]  anAction     Handle to action to decode.
09206 /// @param  [out] aChannel     Channel.
09207 /// @return \c true if the function succeeds, \c false otherwise.
09208 ///         To get extended error information, call \ref GscAct_GetLastError.
09209 GSCACTDLLCALL bool        __stdcall GscAct_DecodeMakeCPAReferenceImage(
09210   ConstHGscAction anAction,
09211   TPlcMediaChannelID& aChannel);
09212
09213 /// Decode action 'Media channel setup'.
09214 /// Media channel setup info.
09215 /// @param  [in]  anAction     Handle to action to decode.
09216 /// @param  [out] aChannel     Channel.
09217 /// @param  [out] aTimeStamp   Time stamp.
09218 /// @param  [out] aParameter   Parameter.
09219 /// @return \c true if the function succeeds, \c false otherwise.
09220 ///         To get extended error information, call \ref GscAct_GetLastError.
09221 GSCACTDLLCALL bool        __stdcall GscAct_DecodeMediaChannelSetupInfo(
09222   ConstHGscAction anAction,
09223   TPlcMediaChannelID& aChannel,
09224   TGLibDateTime& aTimeStamp,
09225   const wchar_t*& aParameter);
09226
09227 /// Decode action 'Move to absolute position'.
09228 /// Move camera to absolute position.
09229 /// @param  [in]  anAction     Handle to action to decode.
09230 /// @param  [out] aCamera      PTZ head.
09231 /// @param  [out] aAlpha       Alpha angle (-180°/+180°).
09232 /// @param  [out] aBeta        Beta angle (-90°/+90°).
09233 /// @param  [out] aSpeedAlpha  Speed in alpha direction (0/100 %).
09234 /// @param  [out] aSpeedBeta   Speed in beta direction (0/100 %).
09235 /// @return \c true if the function succeeds, \c false otherwise.
09236 ///         To get extended error information, call \ref GscAct_GetLastError.
09237 GSCACTDLLCALL bool        __stdcall GscAct_DecodeMoveToAbsolutePosition(
09238   ConstHGscAction anAction,
09239   TPlcMediaChannelID& aCamera,
09240   double& aAlpha,
09241   double& aBeta,
09242   double& aSpeedAlpha,
09243   double& aSpeedBeta);
09244
09245 /// Decode action 'Move by speed'.
09246 /// Move camera by speed.
09247 /// @param  [in]  anAction     Handle to action to decode.
09248 /// @param  [out] aCamera      PTZ head.
09249 /// @param  [out] aSpeedAlpha  Speed in alpha (pan) direction (0/100 %).
09250 /// @param  [out] aSpeedBeta   Speed in beta (tilt) direction (0/100 %).
09251 /// @return \c true if the function succeeds, \c false otherwise.
09252 ///         To get extended error information, call \ref GscAct_GetLastError.
09253 GSCACTDLLCALL bool        __stdcall GscAct_DecodeMoveToBySpeed(
09254   ConstHGscAction anAction,
09255   TPlcMediaChannelID& aCamera,
09256   double& aSpeedAlpha,
09257   double& aSpeedBeta);
09258
09259 /// Decode action 'Move to relative position'.
09260 /// Move camera to relative position.
09261 /// @param  [in]  anAction     Handle to action to decode.
09262 /// @param  [out] aCamera      PTZ head.
09263 /// @param  [out] aAlpha       Alpha angle (-180°/+180°).
09264 /// @param  [out] aBeta        Beta angle (-90°/+90°).
09265 /// @param  [out] aSpeedAlpha  Speed in alpha direction (0/100 %).
09266 /// @param  [out] aSpeedBeta   Speed in beta direction (0/100 %).
09267 /// @return \c true if the function succeeds, \c false otherwise.
09268 ///         To get extended error information, call \ref GscAct_GetLastError.
09269 GSCACTDLLCALL bool        __stdcall GscAct_DecodeMoveToRelativePosition(
09270   ConstHGscAction anAction,
09271   TPlcMediaChannelID& aCamera,
09272   double& aAlpha,
09273   double& aBeta,
09274   double& aSpeedAlpha,
09275   double& aSpeedBeta);
09276
09277 /// Decode action 'NPR raw data'.
09278 /// NPR raw data.
09279 /// @param  [in]  anAction     Handle to action to decode.
09280 /// @param  [out] aPlateNo     Recognized plate no.
09281 /// @param  [out] aCountry     Country.
09282 /// @param  [out] aChannel     Channel.
09283 /// @param  [out] aTimeStamp   Time stamp.
09284 /// @param  [out] aZoneRect    Zone rectangle.
09285 /// @param  [out] aWeight      Weight of recognition.
09286 /// @param  [out] aZoneState   Zone state.
09287 /// @param  [out] aZonePlace   Zone status.
09288 /// @param  [out] aSpeed       Speed in km/h
09289 /// @param  [out] aDirection   Direction of the motion.
09290 /// @param  [out] aZoneIndex   Zone index.
09291 /// @param  [out] aCurBest     Current recognition is best.
09292 /// @param  [out] aPlateWidth  Plate width.
09293 /// @param  [out] aPlateHeight Plate height.
09294 /// @param  [out] aPlateAngle  Plate angle.
09295 /// @param  [out] aSymHeight   Symbol height.
09296 /// @param  [out] aType        Number type.
09297 /// @return \c true if the function succeeds, \c false otherwise.
09298 ///         To get extended error information, call \ref GscAct_GetLastError.
09299 GSCACTDLLCALL bool        __stdcall GscAct_DecodeNPRRawData(
09300   ConstHGscAction anAction,
09301   const wchar_t*& aPlateNo,
09302   const wchar_t*& aCountry,
09303   TPlcMediaChannelID& aChannel,
09304   TGLibDateTime& aTimeStamp,
09305   TPlcRect& aZoneRect,
09306   __int32& aWeight,
09307   __int32& aZoneState,
09308   __int32& aZonePlace,
09309   __int32& aSpeed,
09310   __int32& aDirection,
09311   __int32& aZoneIndex,
09312   bool& aCurBest,
09313   __int32& aPlateWidth,
09314   __int32& aPlateHeight,
09315   __int32& aPlateAngle,
09316   __int32& aSymHeight,
09317   const wchar_t*& aType);
09318
09319 /// Decode action 'NPR recognition'.
09320 /// NPR recognition.
09321 /// @param  [in]  anAction     Handle to action to decode.
09322 /// @param  [out] aPlateNo     Recognized plate no.
09323 /// @param  [out] aCountry     Country.
09324 /// @param  [out] aChannel     Channel.
09325 /// @param  [out] aTimeStamp   Time stamp.
09326 /// @param  [out] aZoneRect    Zone rectangle.
09327 /// @param  [out] aRestriction Restriction of recognized number.
09328 /// @param  [out] aCategory    Category of recognized number.
09329 /// @param  [out] aSpeed       Speed in km/h
09330 /// @param  [out] aDirection   Direction of the motion.
09331 /// @param  [out] aZoneIndex   Zone index.
09332 /// @param  [out] aType        Number type.
09333 /// @param  [out] aWeight      Weight of recognition.
09334 /// @return \c true if the function succeeds, \c false otherwise.
09335 ///         To get extended error information, call \ref GscAct_GetLastError.
09336 GSCACTDLLCALL bool        __stdcall GscAct_DecodeNPRRecognition(
09337   ConstHGscAction anAction,
09338   const wchar_t*& aPlateNo,
09339   const wchar_t*& aCountry,
09340   TPlcMediaChannelID& aChannel,
09341   TGLibDateTime& aTimeStamp,
09342   TPlcRect& aZoneRect,
09343   PlcNPRRestriction& aRestriction,
09344   const wchar_t*& aCategory,
09345   __int32& aSpeed,
09346   __int32& aDirection,
09347   __int32& aZoneIndex,
09348   const wchar_t*& aType,
09349   __int32& aWeight);
09350
09351 /// Decode action 'OBTRACK channel counter'.
09352 /// OBTRACK channel counter.
09353 /// @param  [in]  anAction     Handle to action to decode.
09354 /// @param  [out] aChannel     Channel.
09355 /// @param  [out] aCounterType Counter type.
09356 /// @param  [out] aCounterValue Counter value.
09357 /// @param  [out] aObjectDirection Object direction.
09358 /// @param  [out] aTimeStamp   Time stamp.
09359 /// @param  [out] aResetTimeStamp Reset time stamp.
09360 /// @return \c true if the function succeeds, \c false otherwise.
09361 ///         To get extended error information, call \ref GscAct_GetLastError.
09362 ///
09363 /// @warning   Following parameters are optional:  aResetTimeStamp. \par
09364 ///            Values returned in these fields can be \c NULL pointers.
09365 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackChannelCounter(
09366   ConstHGscAction anAction,
09367   TPlcMediaChannelID& aChannel,
09368   PlcObtrackCounterType& aCounterType,
09369   __int64& aCounterValue,
09370   __int32& aObjectDirection,
09371   TGLibDateTime& aTimeStamp,
09372   const TGLibDateTime*& aResetTimeStamp);
09373
09374 /// Decode action 'OBTRACK channel counter threshold'.
09375 /// OBTRACK channel counter threshold.
09376 /// @param  [in]  anAction     Handle to action to decode.
09377 /// @param  [out] aChannel     Channel.
09378 /// @param  [out] aCounterType Counter type.
09379 /// @param  [out] aCounterValue Counter value.
09380 /// @param  [out] aExceedingDirection Exceeding direction.
09381 /// @param  [out] aTimeStamp   Time stamp.
09382 /// @return \c true if the function succeeds, \c false otherwise.
09383 ///         To get extended error information, call \ref GscAct_GetLastError.
09384 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackChannelCounterThreshold(
09385   ConstHGscAction anAction,
09386   TPlcMediaChannelID& aChannel,
09387   PlcObtrackCounterType& aCounterType,
09388   __int64& aCounterValue,
09389   PlcObtrackExceedingDirection& aExceedingDirection,
09390   TGLibDateTime& aTimeStamp);
09391
09392 /// Decode action 'OBTRACK channel set counter'.
09393 /// OBTRACK channel set counter.
09394 /// @param  [in]  anAction     Handle to action to decode.
09395 /// @param  [out] aChannel     Channel.
09396 /// @param  [out] aCounterType Counter type.
09397 /// @param  [out] aCounterValue Counter value.
09398 /// @param  [out] aTimeStamp   Time stamp.
09399 /// @return \c true if the function succeeds, \c false otherwise.
09400 ///         To get extended error information, call \ref GscAct_GetLastError.
09401 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackChannelSetCounter(
09402   ConstHGscAction anAction,
09403   TPlcMediaChannelID& aChannel,
09404   PlcObtrackCounterType& aCounterType,
09405   __int64& aCounterValue,
09406   TGLibDateTime& aTimeStamp);
09407
09408 /// Decode action 'OBTRACK frame raw data'.
09409 /// OBTRACK frame raw data.
09410 /// @param  [in]  anAction     Handle to action to decode.
09411 /// @param  [out] aTimeStamp   Time stamp.
09412 /// @param  [out] aChannel     Channel.
09413 /// @param  [out] aBrightness  Brightness.
09414 /// @param  [out] aContrast    Contrast.
09415 /// @return \c true if the function succeeds, \c false otherwise.
09416 ///         To get extended error information, call \ref GscAct_GetLastError.
09417 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackFrameRawData(
09418   ConstHGscAction anAction,
09419   TGLibDateTime& aTimeStamp,
09420   TPlcMediaChannelID& aChannel,
09421   __int32& aBrightness,
09422   __int32& aContrast);
09423
09424 /// Decode action 'OBTRACK group counter'.
09425 /// OBTRACK group counter.
09426 /// @param  [in]  anAction     Handle to action to decode.
09427 /// @param  [out] aGroupId     Group ID.
09428 /// @param  [out] aCounterType Counter type.
09429 /// @param  [out] aCounterValue Counter value.
09430 /// @param  [out] aObjectDirection Object direction.
09431 /// @param  [out] aTimeStamp   Time stamp.
09432 /// @param  [out] aResetTimeStamp Reset time stamp.
09433 /// @param  [out] aGroupName   Group name.
09434 /// @return \c true if the function succeeds, \c false otherwise.
09435 ///         To get extended error information, call \ref GscAct_GetLastError.
09436 ///
09437 /// @warning   Following parameters are optional:  aResetTimeStamp. aGroupName. \par
09438 ///            Values returned in these fields can be \c NULL pointers.
09439 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackGroupCounter(
09440   ConstHGscAction anAction,
09441   __int32& aGroupId,
09442   PlcObtrackCounterType& aCounterType,
09443   __int64& aCounterValue,
09444   __int32& aObjectDirection,
09445   TGLibDateTime& aTimeStamp,
09446   const TGLibDateTime*& aResetTimeStamp,
09447   const wchar_t*& aGroupName);
09448
09449 /// Decode action 'OBTRACK group counter threshold'.
09450 /// OBTRACK group counter threshold.
09451 /// @param  [in]  anAction     Handle to action to decode.
09452 /// @param  [out] aGroupId     Group ID.
09453 /// @param  [out] aCounterType Counter type.
09454 /// @param  [out] aCounterValue Counter value.
09455 /// @param  [out] aExceedingDirection Exceeding direction.
09456 /// @param  [out] aTimeStamp   Time stamp.
09457 /// @param  [out] aGroupName   Group name.
09458 /// @return \c true if the function succeeds, \c false otherwise.
09459 ///         To get extended error information, call \ref GscAct_GetLastError.
09460 ///
09461 /// @warning   Following parameters are optional:  aGroupName. \par
09462 ///            Values returned in these fields can be \c NULL pointers.
09463 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackGroupCounterThreshold(
09464   ConstHGscAction anAction,
09465   __int32& aGroupId,
09466   PlcObtrackCounterType& aCounterType,
09467   __int64& aCounterValue,
09468   PlcObtrackExceedingDirection& aExceedingDirection,
09469   TGLibDateTime& aTimeStamp,
09470   const wchar_t*& aGroupName);
09471
09472 /// Decode action 'OBTRACK group set counter'.
09473 /// OBTRACK group set counter.
09474 /// @param  [in]  anAction     Handle to action to decode.
09475 /// @param  [out] aGroupId     Group ID.
09476 /// @param  [out] aCounterType Counter type.
09477 /// @param  [out] aCounterValue Counter value.
09478 /// @param  [out] aTimeStamp   Time stamp.
09479 /// @param  [out] aGroupName   Group name.
09480 /// @return \c true if the function succeeds, \c false otherwise.
09481 ///         To get extended error information, call \ref GscAct_GetLastError.
09482 ///
09483 /// @warning   Following parameters are optional:  aGroupName. \par
09484 ///            Values returned in these fields can be \c NULL pointers.
09485 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackGroupSetCounter(
09486   ConstHGscAction anAction,
09487   __int32& aGroupId,
09488   PlcObtrackCounterType& aCounterType,
09489   __int64& aCounterValue,
09490   TGLibDateTime& aTimeStamp,
09491   const wchar_t*& aGroupName);
09492
09493 /// Decode action 'OBTRACK object raw data'.
09494 /// OBTRACK object raw data.
09495 /// @param  [in]  anAction     Handle to action to decode.
09496 /// @param  [out] aTimeStamp   Time stamp.
09497 /// @param  [out] aChannel     Channel.
09498 /// @param  [out] aArea        Area no.
09499 /// @param  [out] aObjectID    Object ID.
09500 /// @param  [out] aObjectStatus Object status.
09501 /// @param  [out] aObjectClass Object class.
09502 /// @param  [out] aConfidence  Confidence.
09503 /// @param  [out] aPosition    Position.
09504 /// @param  [out] aSpeed       Speed.
09505 /// @param  [out] aDuration    Duration.
09506 /// @param  [out] aDirection   Direction.
09507 /// @param  [out] aSize        Object size.
09508 /// @param  [out] aObjectWidth Object width in meters.
09509 /// @param  [out] aObjectHeight Object height in meters.
09510 /// @param  [out] aProcessSize Process size.
09511 /// @param  [out] aGscNetName  GeViScope network name.
09512 /// @return \c true if the function succeeds, \c false otherwise.
09513 ///         To get extended error information, call \ref GscAct_GetLastError.
09514 ///
09515 /// @warning   Following parameters are optional:  aConfidence. aPosition. aSpeed. aDuration. aDirection. aSize. aObjectWidth. aObjectHeight. aProcessSize. aGscNetName. \par
09516 ///            Values returned in these fields can be \c NULL pointers.
09517 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackObjectRawData(
09518   ConstHGscAction anAction,
09519   TGLibDateTime& aTimeStamp,
09520   TPlcMediaChannelID& aChannel,
09521   __int32& aArea,
09522   __int32& aObjectID,
09523   PlcObtrackObjectStatus& aObjectStatus,
09524   PlcObtrackObjectClass& aObjectClass,
09525   const __int32*& aConfidence,
09526   const TPlcRect*& aPosition,
09527   const double*& aSpeed,
09528   const __int32*& aDuration,
09529   const __int32*& aDirection,
09530   const double*& aSize,
09531   const double*& aObjectWidth,
09532   const double*& aObjectHeight,
09533   const PlcObtrackProcessSize*& aProcessSize,
09534   const char*& aGscNetName);
09535
09536 /// Decode action 'OBTRACK tunnel alarm'.
09537 /// OBTRACK tunnel alarm notification.
09538 /// @param  [in]  anAction     Handle to action to decode.
09539 /// @param  [out] aChannel     Channel.
09540 /// @param  [out] aTimeStamp   Time stamp.
09541 /// @param  [out] aAlarmReason Alarm reason.
09542 /// @param  [out] aObjectID    Object ID.
09543 /// @param  [out] aAlarmAreaID Alarm area ID.
09544 /// @param  [out] aObjectArea  Object area.
09545 /// @return \c true if the function succeeds, \c false otherwise.
09546 ///         To get extended error information, call \ref GscAct_GetLastError.
09547 ///
09548 /// @warning   Following parameters are optional:  aObjectArea. \par
09549 ///            Values returned in these fields can be \c NULL pointers.
09550 GSCACTDLLCALL bool        __stdcall GscAct_DecodeObtrackTunnelAlarm(
09551   ConstHGscAction anAction,
09552   TPlcMediaChannelID& aChannel,
09553   TGLibDateTime& aTimeStamp,
09554   PlcTunnelAlarmReason& aAlarmReason,
09555   __int32& aObjectID,
09556   __int32& aAlarmAreaID,
09557   const TPlcRect*& aObjectArea);
09558
09559 /// Decode action 'Pan auto'.
09560 /// Turn auto pan of the camera.
09561 /// @param  [in]  anAction     Handle to action to decode.
09562 /// @param  [out] aCamera      PTZ head.
09563 /// @param  [out] aModus       Pan modus.
09564 /// @return \c true if the function succeeds, \c false otherwise.
09565 ///         To get extended error information, call \ref GscAct_GetLastError.
09566 GSCACTDLLCALL bool        __stdcall GscAct_DecodePanAuto(
09567   ConstHGscAction anAction,
09568   TPlcMediaChannelID& aCamera,
09569   __int32& aModus);
09570
09571 /// Decode action 'Pan left'.
09572 /// Pan camera to the left.
09573 /// @param  [in]  anAction     Handle to action to decode.
09574 /// @param  [out] aCamera      PTZ head.
09575 /// @param  [out] aSpeed       Pan speed.
09576 /// @return \c true if the function succeeds, \c false otherwise.
09577 ///         To get extended error information, call \ref GscAct_GetLastError.
09578 GSCACTDLLCALL bool        __stdcall GscAct_DecodePanLeft(
09579   ConstHGscAction anAction,
09580   TPlcMediaChannelID& aCamera,
09581   __int32& aSpeed);
09582
09583 /// Decode action 'Pan right'.
09584 /// Pan camera to the right.
09585 /// @param  [in]  anAction     Handle to action to decode.
09586 /// @param  [out] aCamera      PTZ head.
09587 /// @param  [out] aSpeed       Pan speed.
09588 /// @return \c true if the function succeeds, \c false otherwise.
09589 ///         To get extended error information, call \ref GscAct_GetLastError.
09590 GSCACTDLLCALL bool        __stdcall GscAct_DecodePanRight(
09591   ConstHGscAction anAction,
09592   TPlcMediaChannelID& aCamera,
09593   __int32& aSpeed);
09594
09595 /// Decode action 'Pan stop'.
09596 /// Stop pan movement.
09597 /// @param  [in]  anAction     Handle to action to decode.
09598 /// @param  [out] aCamera      PTZ head.
09599 /// @return \c true if the function succeeds, \c false otherwise.
09600 ///         To get extended error information, call \ref GscAct_GetLastError.
09601 GSCACTDLLCALL bool        __stdcall GscAct_DecodePanStop(
09602   ConstHGscAction anAction,
09603   TPlcMediaChannelID& aCamera);
09604
09605 /// Decode action 'POS data'.
09606 /// POS data.
09607 /// @param  [in]  anAction     Handle to action to decode.
09608 /// @param  [out] aPOSName     POS name.
09609 /// @param  [out] aTimeStamp   Time stamp.
09610 /// @param  [out] aArticle     Article description.
09611 /// @param  [out] aPrice       Price.
09612 /// @param  [out] aUnits       Number of units.
09613 /// @param  [out] aPricePerUnit Price per unit.
09614 /// @param  [out] aLine1       Line 1.
09615 /// @param  [out] aLine2       Line 2.
09616 /// @param  [out] aLine3       Line 3.
09617 /// @param  [out] aLine4       Line 4.
09618 /// @param  [out] aLine5       Line 5.
09619 /// @return \c true if the function succeeds, \c false otherwise.
09620 ///         To get extended error information, call \ref GscAct_GetLastError.
09621 ///
09622 /// @warning   Following parameters are optional:  aArticle. aPrice. aUnits. aPricePerUnit. aLine1. aLine2. aLine3. aLine4. aLine5. \par
09623 ///            Values returned in these fields can be \c NULL pointers.
09624 GSCACTDLLCALL bool        __stdcall GscAct_DecodePOSData(
09625   ConstHGscAction anAction,
09626   const wchar_t*& aPOSName,
09627   TGLibDateTime& aTimeStamp,
09628   const wchar_t*& aArticle,
09629   const double*& aPrice,
09630   const __int32*& aUnits,
09631   const double*& aPricePerUnit,
09632   const wchar_t*& aLine1,
09633   const wchar_t*& aLine2,
09634   const wchar_t*& aLine3,
09635   const wchar_t*& aLine4,
09636   const wchar_t*& aLine5);
09637
09638 /// Decode action 'POS status'.
09639 /// POS status.
09640 /// @param  [in]  anAction     Handle to action to decode.
09641 /// @param  [out] aPOSName     POS name.
09642 /// @param  [out] aTimeStamp   Time stamp.
09643 /// @param  [out] aStatus      Status.
09644 /// @param  [out] aDetails     Details.
09645 /// @return \c true if the function succeeds, \c false otherwise.
09646 ///         To get extended error information, call \ref GscAct_GetLastError.
09647 ///
09648 /// @warning   Following parameters are optional:  aDetails. \par
09649 ///            Values returned in these fields can be \c NULL pointers.
09650 GSCACTDLLCALL bool        __stdcall GscAct_DecodePOSStatus(
09651   ConstHGscAction anAction,
09652   const wchar_t*& aPOSName,
09653   TGLibDateTime& aTimeStamp,
09654   PlcPOSStatus& aStatus,
09655   const wchar_t*& aDetails);
09656
09657 /// Decode action 'PP device alarm'.
09658 /// Perimeter protection device alarm.
09659 /// @param  [in]  anAction     Handle to action to decode.
09660 /// @param  [out] aInterfaceID Interface ID.
09661 /// @param  [out] aDeviceAddress Device address.
09662 /// @param  [out] aSensor      Sensor.
09663 /// @param  [out] aState       State.
09664 /// @return \c true if the function succeeds, \c false otherwise.
09665 ///         To get extended error information, call \ref GscAct_GetLastError.
09666 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPDeviceAlarm(
09667   ConstHGscAction anAction,
09668   const wchar_t*& aInterfaceID,
09669   __int32& aDeviceAddress,
09670   PPSensorKind& aSensor,
09671   PPAlarmState& aState);
09672
09673 /// Decode action 'PP device input'.
09674 /// Perimeter protection device input.
09675 /// @param  [in]  anAction     Handle to action to decode.
09676 /// @param  [out] aInterfaceID Interface ID.
09677 /// @param  [out] aDeviceAddress Device address.
09678 /// @param  [out] aInput       Input.
09679 /// @param  [out] aState       State.
09680 /// @return \c true if the function succeeds, \c false otherwise.
09681 ///         To get extended error information, call \ref GscAct_GetLastError.
09682 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPDeviceInput(
09683   ConstHGscAction anAction,
09684   const wchar_t*& aInterfaceID,
09685   __int32& aDeviceAddress,
09686   __int32& aInput,
09687   PPAlarmState& aState);
09688
09689 /// Decode action 'PP device offline'.
09690 /// Perimeter protection device offline.
09691 /// @param  [in]  anAction     Handle to action to decode.
09692 /// @param  [out] aInterfaceID Interface ID.
09693 /// @param  [out] aDeviceAddress Device address.
09694 /// @return \c true if the function succeeds, \c false otherwise.
09695 ///         To get extended error information, call \ref GscAct_GetLastError.
09696 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPDeviceOffline(
09697   ConstHGscAction anAction,
09698   const wchar_t*& aInterfaceID,
09699   __int32& aDeviceAddress);
09700
09701 /// Decode action 'PP device online'.
09702 /// Perimeter protection device online.
09703 /// @param  [in]  anAction     Handle to action to decode.
09704 /// @param  [out] aInterfaceID Interface ID.
09705 /// @param  [out] aDeviceAddress Device address.
09706 /// @return \c true if the function succeeds, \c false otherwise.
09707 ///         To get extended error information, call \ref GscAct_GetLastError.
09708 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPDeviceOnline(
09709   ConstHGscAction anAction,
09710   const wchar_t*& aInterfaceID,
09711   __int32& aDeviceAddress);
09712
09713 /// Decode action 'PP interface offline'.
09714 /// Perimeter protection interface offline.
09715 /// @param  [in]  anAction     Handle to action to decode.
09716 /// @param  [out] aInterfaceID Interface ID.
09717 /// @return \c true if the function succeeds, \c false otherwise.
09718 ///         To get extended error information, call \ref GscAct_GetLastError.
09719 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPInterfaceOffline(
09720   ConstHGscAction anAction,
09721   const wchar_t*& aInterfaceID);
09722
09723 /// Decode action 'PP interface online'.
09724 /// Perimeter protection interface online.
09725 /// @param  [in]  anAction     Handle to action to decode.
09726 /// @param  [out] aInterfaceID Interface ID.
09727 /// @return \c true if the function succeeds, \c false otherwise.
09728 ///         To get extended error information, call \ref GscAct_GetLastError.
09729 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPInterfaceOnline(
09730   ConstHGscAction anAction,
09731   const wchar_t*& aInterfaceID);
09732
09733 /// Decode action 'PP query interface'.
09734 /// Perimeter protection query interface.
09735 /// @param  [in]  anAction     Handle to action to decode.
09736 /// @param  [out] aInterfaceID Interface ID.
09737 /// @return \c true if the function succeeds, \c false otherwise.
09738 ///         To get extended error information, call \ref GscAct_GetLastError.
09739 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPQueryInterface(
09740   ConstHGscAction anAction,
09741   const wchar_t*& aInterfaceID);
09742
09743 /// Decode action 'PP set device output'.
09744 /// Perimeter protection set device output.
09745 /// @param  [in]  anAction     Handle to action to decode.
09746 /// @param  [out] aInterfaceID Interface ID.
09747 /// @param  [out] aDeviceAddress Device address.
09748 /// @param  [out] aOutput      Output.
09749 /// @param  [out] aState       State.
09750 /// @return \c true if the function succeeds, \c false otherwise.
09751 ///         To get extended error information, call \ref GscAct_GetLastError.
09752 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPSetDeviceOutput(
09753   ConstHGscAction anAction,
09754   const wchar_t*& aInterfaceID,
09755   __int32& aDeviceAddress,
09756   __int32& aOutput,
09757   PPAlarmState& aState);
09758
09759 /// Decode action 'PP subcell alarm'.
09760 /// Perimeter protection subcell alarm.
09761 /// @param  [in]  anAction     Handle to action to decode.
09762 /// @param  [out] aInterfaceID Interface ID.
09763 /// @param  [out] aDeviceAddress Device address.
09764 /// @param  [out] aCable       Cable.
09765 /// @param  [out] aSubcell     Subcell.
09766 /// @param  [out] aState       State.
09767 /// @return \c true if the function succeeds, \c false otherwise.
09768 ///         To get extended error information, call \ref GscAct_GetLastError.
09769 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPSubcellAlarm(
09770   ConstHGscAction anAction,
09771   const wchar_t*& aInterfaceID,
09772   __int32& aDeviceAddress,
09773   PPCableKind& aCable,
09774   __int32& aSubcell,
09775   PPAlarmState& aState);
09776
09777 /// Decode action 'PP zone alarm'.
09778 /// Perimeter protection zone alarm.
09779 /// @param  [in]  anAction     Handle to action to decode.
09780 /// @param  [out] aZoneID      Zone ID.
09781 /// @param  [out] aInterfaceID Interface ID.
09782 /// @param  [out] aDeviceAddress Device address.
09783 /// @param  [out] aCable       Cable.
09784 /// @param  [out] aSubcell     Subcell.
09785 /// @param  [out] aState       State.
09786 /// @return \c true if the function succeeds, \c false otherwise.
09787 ///         To get extended error information, call \ref GscAct_GetLastError.
09788 ///
09789 /// @warning   Following parameters are optional:  aCable. aSubcell. \par
09790 ///            Values returned in these fields can be \c NULL pointers.
09791 GSCACTDLLCALL bool        __stdcall GscAct_DecodePPZoneAlarm(
09792   ConstHGscAction anAction,
09793   const wchar_t*& aZoneID,
09794   const wchar_t*& aInterfaceID,
09795   __int32& aDeviceAddress,
09796   const PPCableKind*& aCable,
09797   const __int32*& aSubcell,
09798   PPAlarmState& aState);
09799
09800 /// Decode action 'Move to preset position'.
09801 /// Move camera to preset position.
09802 /// @param  [in]  anAction     Handle to action to decode.
09803 /// @param  [out] aCamera      PTZ head.
09804 /// @param  [out] aPosition    Preset position.
09805 /// @return \c true if the function succeeds, \c false otherwise.
09806 ///         To get extended error information, call \ref GscAct_GetLastError.
09807 GSCACTDLLCALL bool        __stdcall GscAct_DecodePrePosCallUp(
09808   ConstHGscAction anAction,
09809   TPlcMediaChannelID& aCamera,
09810   __int32& aPosition);
09811
09812 /// Decode action 'Clear preset position'.
09813 /// Clear camera preset position.
09814 /// @param  [in]  anAction     Handle to action to decode.
09815 /// @param  [out] aCamera      PTZ head.
09816 /// @param  [out] aPosition    Preset position.
09817 /// @return \c true if the function succeeds, \c false otherwise.
09818 ///         To get extended error information, call \ref GscAct_GetLastError.
09819 GSCACTDLLCALL bool        __stdcall GscAct_DecodePrePosClear(
09820   ConstHGscAction anAction,
09821   TPlcMediaChannelID& aCamera,
09822   __int32& aPosition);
09823
09824 /// Decode action 'Save preset position'.
09825 /// Save current camera position as preset position.
09826 /// @param  [in]  anAction     Handle to action to decode.
09827 /// @param  [out] aCamera      PTZ head.
09828 /// @param  [out] aPosition    Preset position.
09829 /// @return \c true if the function succeeds, \c false otherwise.
09830 ///         To get extended error information, call \ref GscAct_GetLastError.
09831 GSCACTDLLCALL bool        __stdcall GscAct_DecodePrePosSave(
09832   ConstHGscAction anAction,
09833   TPlcMediaChannelID& aCamera,
09834   __int32& aPosition);
09835
09836 /// Decode action 'Redundant power failure'.
09837 /// This action is notified if a failure of the redundant power supply is detected.
09838 /// @param  [in]  anAction     Handle to action to decode.
09839 /// @return \c true if the function succeeds, \c false otherwise.
09840 ///         To get extended error information, call \ref GscAct_GetLastError.
09841 GSCACTDLLCALL bool        __stdcall GscAct_DecodeRedundantPowerFailure(
09842   ConstHGscAction anAction);
09843
09844 /// Decode action 'Redundant power ok'.
09845 /// This action is notified if a failure of the redundant power supply is removed.
09846 /// @param  [in]  anAction     Handle to action to decode.
09847 /// @return \c true if the function succeeds, \c false otherwise.
09848 ///         To get extended error information, call \ref GscAct_GetLastError.
09849 GSCACTDLLCALL bool        __stdcall GscAct_DecodeRedundantPowerOk(
09850   ConstHGscAction anAction);
09851
09852 /// Decode action 'Reset mainboard'.
09853 /// Reset mainboard using IO device.
09854 /// @param  [in]  anAction     Handle to action to decode.
09855 /// @return \c true if the function succeeds, \c false otherwise.
09856 ///         To get extended error information, call \ref GscAct_GetLastError.
09857 GSCACTDLLCALL bool        __stdcall GscAct_DecodeResetMainboard(
09858   ConstHGscAction anAction);
09859
09860 /// Decode action 'Safebag close'.
09861 /// Safebag close.
09862 /// @param  [in]  anAction     Handle to action to decode.
09863 /// @param  [out] aWorkingPlace Working place no.
09864 /// @param  [out] aStartTime   Start time stamp.
09865 /// @param  [out] aStopTime    Stop time stamp.
09866 /// @param  [out] aSafebagNo   Safebag no.
09867 /// @param  [out] aSafebagInfo Additional info about safebag.
09868 /// @param  [out] aStepID      Processing step ID.
09869 /// @param  [out] aDebit       Debit.
09870 /// @param  [out] aTotal       Total.
09871 /// @param  [out] aDifference  Difference between debit and total.
09872 /// @param  [out] aHasDifference Difference between debit and total is not zero.
09873 /// @param  [out] aNotes       Notes.
09874 /// @param  [out] aCoins       Coins.
09875 /// @param  [out] aCheques     Cheques.
09876 /// @return \c true if the function succeeds, \c false otherwise.
09877 ///         To get extended error information, call \ref GscAct_GetLastError.
09878 ///
09879 /// @warning   Following parameters are optional:  aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques. \par
09880 ///            Values returned in these fields can be \c NULL pointers.
09881 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSafebagClose(
09882   ConstHGscAction anAction,
09883   __int32& aWorkingPlace,
09884   TGLibDateTime& aStartTime,
09885   TGLibDateTime& aStopTime,
09886   const wchar_t*& aSafebagNo,
09887   const wchar_t*& aSafebagInfo,
09888   SafebagStep& aStepID,
09889   const double*& aDebit,
09890   const double*& aTotal,
09891   const double*& aDifference,
09892   const bool*& aHasDifference,
09893   const wchar_t*& aNotes,
09894   const wchar_t*& aCoins,
09895   const wchar_t*& aCheques);
09896
09897 /// Decode action 'Safebag data'.
09898 /// Safebag data.
09899 /// @param  [in]  anAction     Handle to action to decode.
09900 /// @param  [out] aWorkingPlace Working place no.
09901 /// @param  [out] aStartTime   Start time stamp.
09902 /// @param  [out] aSafebagNo   Safebag no.
09903 /// @param  [out] aSafebagInfo Additional info about safebag.
09904 /// @param  [out] aStepID      Processing step ID.
09905 /// @param  [out] aDebit       Debit.
09906 /// @param  [out] aTotal       Total.
09907 /// @param  [out] aDifference  Difference between debit and total.
09908 /// @param  [out] aHasDifference Difference between debit and total is not zero.
09909 /// @param  [out] aNotes       Notes.
09910 /// @param  [out] aCoins       Coins.
09911 /// @param  [out] aCheques     Cheques.
09912 /// @return \c true if the function succeeds, \c false otherwise.
09913 ///         To get extended error information, call \ref GscAct_GetLastError.
09914 ///
09915 /// @warning   Following parameters are optional:  aDebit. aTotal. aDifference. aHasDifference. aNotes. aCoins. aCheques. \par
09916 ///            Values returned in these fields can be \c NULL pointers.
09917 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSafebagData(
09918   ConstHGscAction anAction,
09919   __int32& aWorkingPlace,
09920   TGLibDateTime& aStartTime,
09921   const wchar_t*& aSafebagNo,
09922   const wchar_t*& aSafebagInfo,
09923   SafebagStep& aStepID,
09924   const double*& aDebit,
09925   const double*& aTotal,
09926   const double*& aDifference,
09927   const bool*& aHasDifference,
09928   const wchar_t*& aNotes,
09929   const wchar_t*& aCoins,
09930   const wchar_t*& aCheques);
09931
09932 /// Decode action 'Safebag open'.
09933 /// Safebag open.
09934 /// @param  [in]  anAction     Handle to action to decode.
09935 /// @param  [out] aWorkingPlace Working place no.
09936 /// @param  [out] aStartTime   Start time stamp.
09937 /// @param  [out] aSafebagNo   Safebag no.
09938 /// @param  [out] aSafebagInfo Additional info about safebag.
09939 /// @param  [out] aStepID      Processing step ID.
09940 /// @return \c true if the function succeeds, \c false otherwise.
09941 ///         To get extended error information, call \ref GscAct_GetLastError.
09942 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSafebagOpen(
09943   ConstHGscAction anAction,
09944   __int32& aWorkingPlace,
09945   TGLibDateTime& aStartTime,
09946   const wchar_t*& aSafebagNo,
09947   const wchar_t*& aSafebagInfo,
09948   SafebagStep& aStepID);
09949
09950 /// Decode action 'Safebag passing of risk data'.
09951 /// Safebag passing of risk data.
09952 /// @param  [in]  anAction     Handle to action to decode.
09953 /// @param  [out] aWorkingPlace Working place no.
09954 /// @param  [out] aStartTime   Start time stamp.
09955 /// @param  [out] aSafebagNo   Safebag no.
09956 /// @param  [out] aSafebagInfo Additional info about safebag.
09957 /// @param  [out] aStepID      Processing step ID.
09958 /// @param  [out] aUserID1     User who gives the safebag.
09959 /// @param  [out] aUserID2     User who takes the safebag.
09960 /// @param  [out] aTourNumber  Optional tour no.
09961 /// @param  [out] aTargetWorkingPlace Target working place.
09962 /// @param  [out] aPassingOfRiskType Passing of risk type.
09963 /// @return \c true if the function succeeds, \c false otherwise.
09964 ///         To get extended error information, call \ref GscAct_GetLastError.
09965 ///
09966 /// @warning   Following parameters are optional:  aTourNumber. aTargetWorkingPlace. aPassingOfRiskType. \par
09967 ///            Values returned in these fields can be \c NULL pointers.
09968 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSafebagPassingOfRiskData(
09969   ConstHGscAction anAction,
09970   __int32& aWorkingPlace,
09971   TGLibDateTime& aStartTime,
09972   const wchar_t*& aSafebagNo,
09973   const wchar_t*& aSafebagInfo,
09974   SafebagStep& aStepID,
09975   __int32& aUserID1,
09976   __int32& aUserID2,
09977   const __int32*& aTourNumber,
09978   const wchar_t*& aTargetWorkingPlace,
09979   const wchar_t*& aPassingOfRiskType);
09980
09981 /// Decode action 'Safebag passing of risk start'.
09982 /// Safebag passing of risk start.
09983 /// @param  [in]  anAction     Handle to action to decode.
09984 /// @param  [out] aWorkingPlace Working place no.
09985 /// @param  [out] aStartTime   Start time stamp.
09986 /// @param  [out] aSafebagNo   Safebag no.
09987 /// @param  [out] aSafebagInfo Additional info about safebag.
09988 /// @param  [out] aStepID      Processing step ID.
09989 /// @param  [out] aUserID1     User who gives the safebag.
09990 /// @param  [out] aUserID2     User who takes the safebag.
09991 /// @param  [out] aTourNumber  Optional tour no.
09992 /// @param  [out] aTargetWorkingPlace Target working place.
09993 /// @param  [out] aPassingOfRiskType Passing of risk type.
09994 /// @return \c true if the function succeeds, \c false otherwise.
09995 ///         To get extended error information, call \ref GscAct_GetLastError.
09996 ///
09997 /// @warning   Following parameters are optional:  aTourNumber. aTargetWorkingPlace. aPassingOfRiskType. \par
09998 ///            Values returned in these fields can be \c NULL pointers.
09999 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSafebagPassingOfRiskStart(
10000   ConstHGscAction anAction,
10001   __int32& aWorkingPlace,
10002   TGLibDateTime& aStartTime,
10003   const wchar_t*& aSafebagNo,
10004   const wchar_t*& aSafebagInfo,
10005   SafebagStep& aStepID,
10006   __int32& aUserID1,
10007   __int32& aUserID2,
10008   const __int32*& aTourNumber,
10009   const wchar_t*& aTargetWorkingPlace,
10010   const wchar_t*& aPassingOfRiskType);
10011
10012 /// Decode action 'Safebag passing of risk stop'.
10013 /// Safebag passing of risk stop.
10014 /// @param  [in]  anAction     Handle to action to decode.
10015 /// @param  [out] aWorkingPlace Working place no.
10016 /// @param  [out] aStartTime   Start time stamp.
10017 /// @param  [out] aStopTime    Stop time stamp.
10018 /// @param  [out] aSafebagNo   Safebag no.
10019 /// @param  [out] aSafebagInfo Additional info about safebag.
10020 /// @param  [out] aStepID      Processing step ID.
10021 /// @param  [out] aUserID1     User who gives the safebag.
10022 /// @param  [out] aUserID2     User who takes the safebag.
10023 /// @param  [out] aTourNumber  Optional tour no.
10024 /// @param  [out] aTargetWorkingPlace Target working place.
10025 /// @param  [out] aPassingOfRiskType Passing of risk type.
10026 /// @return \c true if the function succeeds, \c false otherwise.
10027 ///         To get extended error information, call \ref GscAct_GetLastError.
10028 ///
10029 /// @warning   Following parameters are optional:  aTourNumber. aTargetWorkingPlace. aPassingOfRiskType. \par
10030 ///            Values returned in these fields can be \c NULL pointers.
10031 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSafebagPassingOfRiskStop(
10032   ConstHGscAction anAction,
10033   __int32& aWorkingPlace,
10034   TGLibDateTime& aStartTime,
10035   TGLibDateTime& aStopTime,
10036   const wchar_t*& aSafebagNo,
10037   const wchar_t*& aSafebagInfo,
10038   SafebagStep& aStepID,
10039   __int32& aUserID1,
10040   __int32& aUserID2,
10041   const __int32*& aTourNumber,
10042   const wchar_t*& aTargetWorkingPlace,
10043   const wchar_t*& aPassingOfRiskType);
10044
10045 /// Decode action 'Scene store modification'.
10046 /// Scene store modification.
10047 /// @param  [in]  anAction     Handle to action to decode.
10048 /// @param  [out] aViewer      Global viewer or viewer client no.
10049 /// @param  [out] aSceneStoreID Scene store GUID.
10050 /// @param  [out] aSceneStoreName Scene store name.
10051 /// @param  [out] aTimeStamp   Time stamp.
10052 /// @param  [out] aModificationType Modification type.
10053 /// @param  [out] aUser        Name of the user.
10054 /// @param  [out] aClientHost  Host from where the connection is done.
10055 /// @param  [out] aClientType  Client type.
10056 /// @param  [out] aClientAccount User account from where the connection is done.
10057 /// @return \c true if the function succeeds, \c false otherwise.
10058 ///         To get extended error information, call \ref GscAct_GetLastError.
10059 ///
10060 /// @warning   Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
10061 ///            Values returned in these fields can be \c NULL pointers.
10062 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSceneStoreModification(
10063   ConstHGscAction anAction,
10064   TPlcMediaChannelID& aViewer,
10065   GUID& aSceneStoreID,
10066   const wchar_t*& aSceneStoreName,
10067   TGLibDateTime& aTimeStamp,
10068   PlcSceneStoreModificationType& aModificationType,
10069   const wchar_t*& aUser,
10070   const wchar_t*& aClientHost,
10071   const PlcClientType*& aClientType,
10072   const wchar_t*& aClientAccount);
10073
10074 /// Decode action 'Sensor alarm finished'.
10075 /// This action will be fired when the alarm is finished.
10076 /// @param  [in]  anAction     Handle to action to decode.
10077 /// @param  [out] aChannel     Channel.
10078 /// @param  [out] aSensorType  Sensor type.
10079 /// @return \c true if the function succeeds, \c false otherwise.
10080 ///         To get extended error information, call \ref GscAct_GetLastError.
10081 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSensorAlarmFinished(
10082   ConstHGscAction anAction,
10083   TPlcMediaChannelID& aChannel,
10084   VideoSensorKind& aSensorType);
10085
10086 /// Decode action 'Sensor audio alarm'.
10087 /// Audio alarm detected.
10088 /// @param  [in]  anAction     Handle to action to decode.
10089 /// @param  [out] aChannel     Channel.
10090 /// @return \c true if the function succeeds, \c false otherwise.
10091 ///         To get extended error information, call \ref GscAct_GetLastError.
10092 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSensorAudioAlarm(
10093   ConstHGscAction anAction,
10094   TPlcMediaChannelID& aChannel);
10095
10096 /// Decode action 'Sensor inhibit alarm finished'.
10097 /// This action will be fired when the inhibit alarm is finished.
10098 /// @param  [in]  anAction     Handle to action to decode.
10099 /// @param  [out] aChannel     Channel.
10100 /// @param  [out] aSensorType  Sensor type.
10101 /// @return \c true if the function succeeds, \c false otherwise.
10102 ///         To get extended error information, call \ref GscAct_GetLastError.
10103 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSensorInhibitAlarmFinished(
10104   ConstHGscAction anAction,
10105   TPlcMediaChannelID& aChannel,
10106   VideoSensorKind& aSensorType);
10107
10108 /// Decode action 'Sensor inhibit video alarm'.
10109 /// This action will be fired when the motion in inhibit area is detected.
10110 /// @param  [in]  anAction     Handle to action to decode.
10111 /// @param  [out] aChannel     Channel.
10112 /// @param  [out] aSensorType  Sensor type.
10113 /// @param  [out] aADArea      AD alarm area.
10114 /// @param  [out] aADCell      AD cell nr.
10115 /// @param  [out] aVMDGroup    VMD alarm group.
10116 /// @param  [out] aVMDZone     VMD zone nr.
10117 /// @param  [out] aVMDCycle    VMD measure cycle.
10118 /// @param  [out] aAlarmArea   Alarm area.
10119 /// @param  [out] aObjectClass OBTRACK object class.
10120 /// @return \c true if the function succeeds, \c false otherwise.
10121 ///         To get extended error information, call \ref GscAct_GetLastError.
10122 ///
10123 /// @warning   Following parameters are optional:  aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass. \par
10124 ///            Values returned in these fields can be \c NULL pointers.
10125 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSensorInhibitVideoAlarmEx(
10126   ConstHGscAction anAction,
10127   TPlcMediaChannelID& aChannel,
10128   VideoSensorKind& aSensorType,
10129   const ADArea*& aADArea,
10130   const __int32*& aADCell,
10131   const VMDGroup*& aVMDGroup,
10132   const __int32*& aVMDZone,
10133   const VMDCycle*& aVMDCycle,
10134   const TPlcRect*& aAlarmArea,
10135   const PlcObtrackObjectClass*& aObjectClass);
10136
10137 /// Decode action 'Sensor video alarm'.
10138 /// This action will be fired when video alarm is detected.
10139 /// @param  [in]  anAction     Handle to action to decode.
10140 /// @param  [out] aChannel     Channel.
10141 /// @param  [out] aSensorType  Sensor type.
10142 /// @param  [out] aADArea      AD alarm area.
10143 /// @param  [out] aADCell      AD cell nr.
10144 /// @param  [out] aVMDGroup    VMD alarm group.
10145 /// @param  [out] aVMDZone     VMD zone nr.
10146 /// @param  [out] aVMDCycle    VMD measure cycle.
10147 /// @param  [out] aAlarmArea   Alarm area.
10148 /// @param  [out] aObjectClass OBTRACK object class.
10149 /// @return \c true if the function succeeds, \c false otherwise.
10150 ///         To get extended error information, call \ref GscAct_GetLastError.
10151 ///
10152 /// @warning   Following parameters are optional:  aADArea. aADCell. aVMDGroup. aVMDZone. aVMDCycle. aAlarmArea. aObjectClass. \par
10153 ///            Values returned in these fields can be \c NULL pointers.
10154 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSensorVideoAlarmEx(
10155   ConstHGscAction anAction,
10156   TPlcMediaChannelID& aChannel,
10157   VideoSensorKind& aSensorType,
10158   const ADArea*& aADArea,
10159   const __int32*& aADCell,
10160   const VMDGroup*& aVMDGroup,
10161   const __int32*& aVMDZone,
10162   const VMDCycle*& aVMDCycle,
10163   const TPlcRect*& aAlarmArea,
10164   const PlcObtrackObjectClass*& aObjectClass);
10165
10166 /// Decode action 'Set camera text'.
10167 /// Set camera text.
10168 /// @param  [in]  anAction     Handle to action to decode.
10169 /// @param  [out] aCamera      PTZ head.
10170 /// @param  [out] aText        Text to superimpose.
10171 /// @return \c true if the function succeeds, \c false otherwise.
10172 ///         To get extended error information, call \ref GscAct_GetLastError.
10173 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetCameraText(
10174   ConstHGscAction anAction,
10175   TPlcMediaChannelID& aCamera,
10176   const char*& aText);
10177
10178 /// Decode action 'Enable client VCA'.
10179 /// Enable client VCA
10180 /// @param  [in]  anAction     Handle to action to decode.
10181 /// @param  [out] aChannel     Channel.
10182 /// @param  [out] aClientVCAType VCA Type
10183 /// @param  [out] aEnabled     Enabled
10184 /// @return \c true if the function succeeds, \c false otherwise.
10185 ///         To get extended error information, call \ref GscAct_GetLastError.
10186 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetClientVCA(
10187   ConstHGscAction anAction,
10188   TPlcMediaChannelID& aChannel,
10189   GTectClientVCAType& aClientVCAType,
10190   bool& aEnabled);
10191
10192 /// Decode action 'Set clock'.
10193 /// Set clock.
10194 /// @param  [in]  anAction     Handle to action to decode.
10195 /// @param  [out] aDate        Current time.
10196 /// @return \c true if the function succeeds, \c false otherwise.
10197 ///         To get extended error information, call \ref GscAct_GetLastError.
10198 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetClock(
10199   ConstHGscAction anAction,
10200   TGLibDateTime& aDate);
10201
10202 /// Decode action 'Set digital output'.
10203 /// This action is used to modify the state of the digital output and to notify this change.
10204 /// @param  [in]  anAction     Handle to action to decode.
10205 /// @param  [out] aContact     Contact.
10206 /// @param  [out] aState       New state.
10207 /// @return \c true if the function succeeds, \c false otherwise.
10208 ///         To get extended error information, call \ref GscAct_GetLastError.
10209 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetDigitalOutput(
10210   ConstHGscAction anAction,
10211   TPlcMediaChannelID& aContact,
10212   DigitalOutputState& aState);
10213
10214 /// Decode action 'Set export marker'.
10215 /// Set export marker.
10216 /// @param  [in]  anAction     Handle to action to decode.
10217 /// @param  [out] aViewer      Global viewer or viewer client no.
10218 /// @param  [out] aMarker      Marker kind.
10219 /// @return \c true if the function succeeds, \c false otherwise.
10220 ///         To get extended error information, call \ref GscAct_GetLastError.
10221 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetExportMarker(
10222   ConstHGscAction anAction,
10223   TPlcMediaChannelID& aViewer,
10224   PlcExportMarker& aMarker);
10225
10226 /// Decode action 'Set system LED'.
10227 /// This action is used to turn the system LEDs on or off.
10228 /// @param  [in]  anAction     Handle to action to decode.
10229 /// @param  [out] aLED         System LED.
10230 /// @param  [out] aState       New state.
10231 /// @return \c true if the function succeeds, \c false otherwise.
10232 ///         To get extended error information, call \ref GscAct_GetLastError.
10233 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetLED(
10234   ConstHGscAction anAction,
10235   SystemLED& aLED,
10236   DigitalOutputState& aState);
10237
10238 /// Decode action 'Set system LED to blink'.
10239 /// This action is used to blink the system LEDs.
10240 /// @param  [in]  anAction     Handle to action to decode.
10241 /// @param  [out] aLED         System LED.
10242 /// @param  [out] aLedTimeOnMs Time in milliseconds when the LED will be switched on.
10243 /// @param  [out] aLedTimeOffMs Time in milliseconds when the LED will be switched off.
10244 /// @return \c true if the function succeeds, \c false otherwise.
10245 ///         To get extended error information, call \ref GscAct_GetLastError.
10246 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetLEDBlink(
10247   ConstHGscAction anAction,
10248   SystemLED& aLED,
10249   __int32& aLedTimeOnMs,
10250   __int32& aLedTimeOffMs);
10251
10252 /// Decode action 'Set system time'.
10253 /// Set system time.
10254 /// @param  [in]  anAction     Handle to action to decode.
10255 /// @param  [out] aTimeStamp   Time stamp.
10256 /// @return \c true if the function succeeds, \c false otherwise.
10257 ///         To get extended error information, call \ref GscAct_GetLastError.
10258 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetSystemTime(
10259   ConstHGscAction anAction,
10260   TGLibDateTime& aTimeStamp);
10261
10262 /// Decode action 'Set test picture mode'.
10263 /// Enable or disable test picture generator.
10264 /// @param  [in]  anAction     Handle to action to decode.
10265 /// @param  [out] aChannel     Channel.
10266 /// @param  [out] aMode        Enable or disable test picture generator.
10267 /// @return \c true if the function succeeds, \c false otherwise.
10268 ///         To get extended error information, call \ref GscAct_GetLastError.
10269 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetTestPictureMode(
10270   ConstHGscAction anAction,
10271   TPlcMediaChannelID& aChannel,
10272   bool& aMode);
10273
10274 /// Decode action 'Setup changed'.
10275 /// Setup changed.
10276 /// @param  [in]  anAction     Handle to action to decode.
10277 /// @param  [out] aUser        Name of the user who modified the setup.
10278 /// @param  [out] aHost        Host from where the connection was done.
10279 /// @param  [out] aDate        Current time.
10280 /// @param  [out] aResourceKind Modified resource kind.
10281 /// @param  [out] aResourceID  Modified resource ID.
10282 /// @param  [out] aChangeKind  Change kind.
10283 /// @param  [out] aDetails     Details of the modification.
10284 /// @param  [out] aClientHost  Host from where the connection is done.
10285 /// @param  [out] aClientType  Client type.
10286 /// @param  [out] aClientAccount User account from where the connection is done.
10287 /// @return \c true if the function succeeds, \c false otherwise.
10288 ///         To get extended error information, call \ref GscAct_GetLastError.
10289 ///
10290 /// @warning   Following parameters are optional:  aDetails. aClientHost. aClientType. aClientAccount. \par
10291 ///            Values returned in these fields can be \c NULL pointers.
10292 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetupChanged(
10293   ConstHGscAction anAction,
10294   const wchar_t*& aUser,
10295   const wchar_t*& aHost,
10296   TGLibDateTime& aDate,
10297   PlcResourceKind& aResourceKind,
10298   TPlcEventTypeID& aResourceID,
10299   PlcResourceChangeKind& aChangeKind,
10300   const wchar_t*& aDetails,
10301   const wchar_t*& aClientHost,
10302   const PlcClientType*& aClientType,
10303   const wchar_t*& aClientAccount);
10304
10305 /// Decode action 'Setup upload progress'.
10306 /// Setup upload progress.
10307 /// @param  [in]  anAction     Handle to action to decode.
10308 /// @param  [out] aUser1       Name of the user who modified the setup.
10309 /// @param  [out] aUser2       Name of the second user by four eyes authentication.
10310 /// @param  [out] aHost        Host from where the connection was done.
10311 /// @param  [out] aProgress    Progress in percent.
10312 /// @param  [out] aDate        Current stage time.
10313 /// @return \c true if the function succeeds, \c false otherwise.
10314 ///         To get extended error information, call \ref GscAct_GetLastError.
10315 ///
10316 /// @warning   Following parameters are optional:  aUser1. aUser2. aHost. \par
10317 ///            Values returned in these fields can be \c NULL pointers.
10318 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetupUploadProgress(
10319   ConstHGscAction anAction,
10320   const wchar_t*& aUser1,
10321   const wchar_t*& aUser2,
10322   const wchar_t*& aHost,
10323   __int32& aProgress,
10324   TGLibDateTime& aDate);
10325
10326 /// Decode action 'Set watchdog'.
10327 /// Set watchdog.
10328 /// @param  [in]  anAction     Handle to action to decode.
10329 /// @param  [out] aTimeout     Timeout in seconds, before the watchdog must be retriggered and before the hardware watchdog will set the hardware contact.
10330 /// @return \c true if the function succeeds, \c false otherwise.
10331 ///         To get extended error information, call \ref GscAct_GetLastError.
10332 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSetWatchdog(
10333   ConstHGscAction anAction,
10334   __int32& aTimeout);
10335
10336 /// Decode action 'SKIDATA control'.
10337 /// SKIDATA control information.
10338 /// @param  [in]  anAction     Handle to action to decode.
10339 /// @param  [out] aInterfaceName Interface name.
10340 /// @param  [out] aData        Interface state.
10341 /// @return \c true if the function succeeds, \c false otherwise.
10342 ///         To get extended error information, call \ref GscAct_GetLastError.
10343 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSkidataControl(
10344   ConstHGscAction anAction,
10345   const wchar_t*& aInterfaceName,
10346   PlcSkidataControl& aData);
10347
10348 /// Decode action 'SKIDATA device event'.
10349 /// SKIDATA device event.
10350 /// @param  [in]  anAction     Handle to action to decode.
10351 /// @param  [out] aInterfaceName Interface name.
10352 /// @param  [out] aDeviceID    Device ID.
10353 /// @param  [out] aEventCode   Event code.
10354 /// @return \c true if the function succeeds, \c false otherwise.
10355 ///         To get extended error information, call \ref GscAct_GetLastError.
10356 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSkidataDeviceEvent(
10357   ConstHGscAction anAction,
10358   const wchar_t*& aInterfaceName,
10359   __int32& aDeviceID,
10360   __int32& aEventCode);
10361
10362 /// Decode action 'SKIDATA entry'.
10363 /// SKIDATA entry.
10364 /// @param  [in]  anAction     Handle to action to decode.
10365 /// @param  [out] aInterfaceName Interface name.
10366 /// @param  [out] aMessageCode Message code.
10367 /// @param  [out] aTranscactionID Transcaction ID.
10368 /// @param  [out] aCarParkNo   Car park no.
10369 /// @param  [out] aDeviceID    Device ID.
10370 /// @return \c true if the function succeeds, \c false otherwise.
10371 ///         To get extended error information, call \ref GscAct_GetLastError.
10372 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSkidataEntry(
10373   ConstHGscAction anAction,
10374   const wchar_t*& aInterfaceName,
10375   PlcSkidataMsgCodeEntry& aMessageCode,
10376   const wchar_t*& aTranscactionID,
10377   __int32& aCarParkNo,
10378   __int32& aDeviceID);
10379
10380 /// Decode action 'SKIDATA exit'.
10381 /// SKIDATA exit.
10382 /// @param  [in]  anAction     Handle to action to decode.
10383 /// @param  [out] aInterfaceName Interface name.
10384 /// @param  [out] aMessageCode Message code.
10385 /// @param  [out] aTranscactionID Transcaction ID.
10386 /// @param  [out] aCarParkNo   Car park no.
10387 /// @param  [out] aDeviceID    Device ID.
10388 /// @return \c true if the function succeeds, \c false otherwise.
10389 ///         To get extended error information, call \ref GscAct_GetLastError.
10390 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSkidataExit(
10391   ConstHGscAction anAction,
10392   const wchar_t*& aInterfaceName,
10393   PlcSkidataMsgCodeExit& aMessageCode,
10394   const wchar_t*& aTranscactionID,
10395   __int32& aCarParkNo,
10396   __int32& aDeviceID);
10397
10398 /// Decode action 'SKIDATA transaction'.
10399 /// SKIDATA transaction.
10400 /// @param  [in]  anAction     Handle to action to decode.
10401 /// @param  [out] aInterfaceName Interface name.
10402 /// @param  [out] aMessageCode Message code.
10403 /// @param  [out] aTranscactionID Transcaction ID.
10404 /// @param  [out] aCarParkNo   Car park no.
10405 /// @param  [out] aDeviceID    Device ID.
10406 /// @return \c true if the function succeeds, \c false otherwise.
10407 ///         To get extended error information, call \ref GscAct_GetLastError.
10408 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSkidataTransaction(
10409   ConstHGscAction anAction,
10410   const wchar_t*& aInterfaceName,
10411   PlcSkidataMsgCodeTransaction& aMessageCode,
10412   const wchar_t*& aTranscactionID,
10413   __int32& aCarParkNo,
10414   __int32& aDeviceID);
10415
10416 /// Decode action 'SMRP viewer cleared'.
10417 /// SMRP viewer cleared.
10418 /// @param  [in]  anAction     Handle to action to decode.
10419 /// @return \c true if the function succeeds, \c false otherwise.
10420 ///         To get extended error information, call \ref GscAct_GetLastError.
10421 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSMRPViewerCleared(
10422   ConstHGscAction anAction);
10423
10424 /// Decode action 'SMRP viewer connected'.
10425 /// SMRP viewer connected to the camera.
10426 /// @param  [in]  anAction     Handle to action to decode.
10427 /// @param  [out] aServer      Server name.
10428 /// @param  [out] aChannel     Channel.
10429 /// @return \c true if the function succeeds, \c false otherwise.
10430 ///         To get extended error information, call \ref GscAct_GetLastError.
10431 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSMRPViewerConnected(
10432   ConstHGscAction anAction,
10433   const wchar_t*& aServer,
10434   TPlcMediaChannelID& aChannel);
10435
10436 /// Decode action 'SMTP mail'.
10437 /// This action will send a user defined email if GSCMail is connected
10438 /// @param  [in]  anAction     Handle to action to decode.
10439 /// @param  [out] aSubject     Mail subject.
10440 /// @param  [out] aTo          Mail recipients.
10441 /// @param  [out] aCc          Carbon copy recipients.
10442 /// @param  [out] aBody        Mail body.
10443 /// @param  [out] aChannel     Channel.
10444 /// @return \c true if the function succeeds, \c false otherwise.
10445 ///         To get extended error information, call \ref GscAct_GetLastError.
10446 ///
10447 /// @warning   Following parameters are optional:  aChannel. \par
10448 ///            Values returned in these fields can be \c NULL pointers.
10449 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSMTPMailSend(
10450   ConstHGscAction anAction,
10451   const wchar_t*& aSubject,
10452   const wchar_t*& aTo,
10453   const wchar_t*& aCc,
10454   const wchar_t*& aBody,
10455   const TPlcMediaChannelID*& aChannel);
10456
10457 /// Decode action 'Start auto backup'.
10458 /// Start auto backup.
10459 /// @param  [in]  anAction     Handle to action to decode.
10460 /// @param  [out] aSchedule    Schedule.
10461 /// @return \c true if the function succeeds, \c false otherwise.
10462 ///         To get extended error information, call \ref GscAct_GetLastError.
10463 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStartAutoBackup(
10464   ConstHGscAction anAction,
10465   TPlcResourceID& aSchedule);
10466
10467 /// Decode action 'Start event'.
10468 /// Start event.
10469 /// @param  [in]  anAction     Handle to action to decode.
10470 /// @param  [out] aTypeID      Type of the event.
10471 /// @param  [out] aForeignKey  Optional foreign key used to store with alarm.
10472 /// @return \c true if the function succeeds, \c false otherwise.
10473 ///         To get extended error information, call \ref GscAct_GetLastError.
10474 ///
10475 /// @warning   Following parameters are optional:  aForeignKey. \par
10476 ///            Values returned in these fields can be \c NULL pointers.
10477 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStartEventEx(
10478   ConstHGscAction anAction,
10479   TPlcEventTypeID& aTypeID,
10480   const __int64*& aForeignKey);
10481
10482 /// Decode action 'Start remote export'.
10483 /// Start remote export.
10484 /// @param  [in]  anAction     Handle to action to decode.
10485 /// @param  [out] aExportID    Export GUID.
10486 /// @param  [out] aDevice      Pilot device GUID.
10487 /// @param  [out] aBackupFormat Backup format.
10488 /// @param  [out] aChannel     Channel.
10489 /// @param  [out] aSelectionBegin Start time.
10490 /// @param  [out] aSelectionEnd End time.
10491 /// @param  [out] aJobID       Job ID.
10492 /// @return \c true if the function succeeds, \c false otherwise.
10493 ///         To get extended error information, call \ref GscAct_GetLastError.
10494 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStartRemoteExport(
10495   ConstHGscAction anAction,
10496   GUID& aExportID,
10497   GUID& aDevice,
10498   PlcBackupFormat& aBackupFormat,
10499   TPlcMediaChannelID& aChannel,
10500   TGLibDateTime& aSelectionBegin,
10501   TGLibDateTime& aSelectionEnd,
10502   const wchar_t*& aJobID);
10503
10504 /// Decode action 'Start scene store'.
10505 /// Start scene store.
10506 /// @param  [in]  anAction     Handle to action to decode.
10507 /// @param  [out] aSceneStoreID Scene store GUID.
10508 /// @param  [out] aCutList     Cut-list.
10509 /// @param  [out] aPreHistoryLength Pre-history length.
10510 /// @param  [out] aRecordingLength Recording length.
10511 /// @return \c true if the function succeeds, \c false otherwise.
10512 ///         To get extended error information, call \ref GscAct_GetLastError.
10513 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStartSceneStore(
10514   ConstHGscAction anAction,
10515   GUID& aSceneStoreID,
10516   const wchar_t*& aCutList,
10517   __int64& aPreHistoryLength,
10518   __int64& aRecordingLength);
10519
10520 /// Decode action 'Stop all events'.
10521 /// Stop all active events.
10522 /// @param  [in]  anAction     Handle to action to decode.
10523 /// @return \c true if the function succeeds, \c false otherwise.
10524 ///         To get extended error information, call \ref GscAct_GetLastError.
10525 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStopAllEvents(
10526   ConstHGscAction anAction);
10527
10528 /// Decode action 'Stop event'.
10529 /// Stop event.
10530 /// @param  [in]  anAction     Handle to action to decode.
10531 /// @param  [out] aTypeID      Type of the event.
10532 /// @return \c true if the function succeeds, \c false otherwise.
10533 ///         To get extended error information, call \ref GscAct_GetLastError.
10534 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStopEvent(
10535   ConstHGscAction anAction,
10536   TPlcEventTypeID& aTypeID);
10537
10538 /// Decode action 'Stop event by instance'.
10539 /// Stop event by instance ID.
10540 /// @param  [in]  anAction     Handle to action to decode.
10541 /// @param  [out] aEventID     Instance ID of the event.
10542 /// @return \c true if the function succeeds, \c false otherwise.
10543 ///         To get extended error information, call \ref GscAct_GetLastError.
10544 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStopEventByID(
10545   ConstHGscAction anAction,
10546   __int64& aEventID);
10547
10548 /// Decode action 'System error'.
10549 /// Notify system error.
10550 /// @param  [in]  anAction     Handle to action to decode.
10551 /// @param  [out] aSource      Source of the message.
10552 /// @param  [out] aMessage     Kind of the message.
10553 /// @param  [out] aWindowsError Optional Windows error code.
10554 /// @param  [out] aDescription Optional description of the message.
10555 /// @param  [out] aXMLInfo     Optional additional info (usually as XML string).
10556 /// @return \c true if the function succeeds, \c false otherwise.
10557 ///         To get extended error information, call \ref GscAct_GetLastError.
10558 ///
10559 /// @warning   Following parameters are optional:  aWindowsError. aDescription. aXMLInfo. \par
10560 ///            Values returned in these fields can be \c NULL pointers.
10561 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSystemError(
10562   ConstHGscAction anAction,
10563   PlcMessageSource& aSource,
10564   PlcMessageCode& aMessage,
10565   const __int32*& aWindowsError,
10566   const wchar_t*& aDescription,
10567   const char*& aXMLInfo);
10568
10569 /// Decode action 'System info'.
10570 /// Notify system information.
10571 /// @param  [in]  anAction     Handle to action to decode.
10572 /// @param  [out] aSource      Source of the message.
10573 /// @param  [out] aMessage     Kind of the message.
10574 /// @param  [out] aDescription Optional description of the message.
10575 /// @param  [out] aXMLInfo     Optional additional info (usually as XML string).
10576 /// @return \c true if the function succeeds, \c false otherwise.
10577 ///         To get extended error information, call \ref GscAct_GetLastError.
10578 ///
10579 /// @warning   Following parameters are optional:  aDescription. aXMLInfo. \par
10580 ///            Values returned in these fields can be \c NULL pointers.
10581 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSystemInfo(
10582   ConstHGscAction anAction,
10583   PlcMessageSource& aSource,
10584   PlcMessageCode& aMessage,
10585   const wchar_t*& aDescription,
10586   const char*& aXMLInfo);
10587
10588 /// Decode action 'System settings changed'.
10589 /// Setup of the system and/or the current time range changed.
10590 /// @param  [in]  anAction     Handle to action to decode.
10591 /// @param  [out] aSetupChanged System setup has changed.
10592 /// @param  [out] aUser1       Name of the user who modified the setup.
10593 /// @param  [out] aUser2       Name of the second user by four eyes authentication.
10594 /// @param  [out] aHost        Host from where the connection was done.
10595 /// @param  [out] aTimeRangeChanged Time range has changed.
10596 /// @param  [out] aTimeRange   Currently active time range.
10597 /// @param  [out] aLicenceChanged Licence has changed.
10598 /// @param  [out] aDate        Time of the system settings changed.
10599 /// @return \c true if the function succeeds, \c false otherwise.
10600 ///         To get extended error information, call \ref GscAct_GetLastError.
10601 ///
10602 /// @warning   Following parameters are optional:  aUser1. aUser2. aHost. aTimeRange. \par
10603 ///            Values returned in these fields can be \c NULL pointers.
10604 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSystemSettingsChanged(
10605   ConstHGscAction anAction,
10606   bool& aSetupChanged,
10607   const wchar_t*& aUser1,
10608   const wchar_t*& aUser2,
10609   const wchar_t*& aHost,
10610   bool& aTimeRangeChanged,
10611   const TPlcResourceID*& aTimeRange,
10612   bool& aLicenceChanged,
10613   TGLibDateTime& aDate);
10614
10615 /// Decode action 'System started'.
10616 /// This action will be fired only once at the system start-up.
10617 /// @param  [in]  anAction     Handle to action to decode.
10618 /// @param  [out] aDate        Time of the system start-up.
10619 /// @return \c true if the function succeeds, \c false otherwise.
10620 ///         To get extended error information, call \ref GscAct_GetLastError.
10621 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSystemStarted(
10622   ConstHGscAction anAction,
10623   TGLibDateTime& aDate);
10624
10625 /// Decode action 'System terminating'.
10626 /// This action will be fired when the system is going to be shut down.
10627 /// @param  [in]  anAction     Handle to action to decode.
10628 /// @param  [out] aDate        Time of the system shutdown.
10629 /// @param  [out] aWindowsShutdown Indicates whether the system shutdown is done due to the windows shutdown.
10630 /// @return \c true if the function succeeds, \c false otherwise.
10631 ///         To get extended error information, call \ref GscAct_GetLastError.
10632 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSystemTerminating(
10633   ConstHGscAction anAction,
10634   TGLibDateTime& aDate,
10635   bool& aWindowsShutdown);
10636
10637 /// Decode action 'System warning'.
10638 /// Notify system warning.
10639 /// @param  [in]  anAction     Handle to action to decode.
10640 /// @param  [out] aSource      Source of the message.
10641 /// @param  [out] aMessage     Kind of the message.
10642 /// @param  [out] aWindowsError Optional Windows error code.
10643 /// @param  [out] aDescription Optional description of the message.
10644 /// @param  [out] aXMLInfo     Optional additional info (usually as XML string).
10645 /// @return \c true if the function succeeds, \c false otherwise.
10646 ///         To get extended error information, call \ref GscAct_GetLastError.
10647 ///
10648 /// @warning   Following parameters are optional:  aWindowsError. aDescription. aXMLInfo. \par
10649 ///            Values returned in these fields can be \c NULL pointers.
10650 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSystemWarning(
10651   ConstHGscAction anAction,
10652   PlcMessageSource& aSource,
10653   PlcMessageCode& aMessage,
10654   const __int32*& aWindowsError,
10655   const wchar_t*& aDescription,
10656   const char*& aXMLInfo);
10657
10658 /// Decode action 'Temperature notification'.
10659 /// Temperature notification from a/ab USB Alarm-I/O.
10660 /// @param  [in]  anAction     Handle to action to decode.
10661 /// @param  [out] aSourceType  Type of the device, which has fired the action.
10662 /// @param  [out] aID          ID of the IO module (like IOI43-00/MIO84-00/MIO168-00).
10663 /// @param  [out] aTemperature Temperature.
10664 /// @return \c true if the function succeeds, \c false otherwise.
10665 ///         To get extended error information, call \ref GscAct_GetLastError.
10666 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTemperature(
10667   ConstHGscAction anAction,
10668   IODeviceType& aSourceType,
10669   const wchar_t*& aID,
10670   __int32& aTemperature);
10671
10672 /// Decode action 'Terminal article data'.
10673 /// Terminal article data.
10674 /// @param  [in]  anAction     Handle to action to decode.
10675 /// @param  [out] aTerminalName Terminal name.
10676 /// @param  [out] aTimeStamp   Time stamp.
10677 /// @param  [out] aCashierStation Cashier station.
10678 /// @param  [out] aPumpNo      Pump no.
10679 /// @param  [out] aAlarmStatus Alarm status.
10680 /// @param  [out] aAmount      Amount.
10681 /// @param  [out] aPrice       Price.
10682 /// @param  [out] aDetails     Details.
10683 /// @return \c true if the function succeeds, \c false otherwise.
10684 ///         To get extended error information, call \ref GscAct_GetLastError.
10685 ///
10686 /// @warning   Following parameters are optional:  aPumpNo. aAmount. aPrice. aDetails. \par
10687 ///            Values returned in these fields can be \c NULL pointers.
10688 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTerminalArticleData(
10689   ConstHGscAction anAction,
10690   const wchar_t*& aTerminalName,
10691   TGLibDateTime& aTimeStamp,
10692   __int32& aCashierStation,
10693   const __int32*& aPumpNo,
10694   bool& aAlarmStatus,
10695   const double*& aAmount,
10696   const double*& aPrice,
10697   const wchar_t*& aDetails);
10698
10699 /// Decode action 'Terminal payment data'.
10700 /// Terminal payment data.
10701 /// @param  [in]  anAction     Handle to action to decode.
10702 /// @param  [out] aTerminalName Terminal name.
10703 /// @param  [out] aTimeStamp   Time stamp.
10704 /// @param  [out] aCashierStation Cashier station.
10705 /// @param  [out] aPumpNo      Pump no.
10706 /// @param  [out] aAlarmStatus Alarm status.
10707 /// @param  [out] aAmount      Amount.
10708 /// @param  [out] aPrice       Price.
10709 /// @param  [out] aDetails     Details.
10710 /// @return \c true if the function succeeds, \c false otherwise.
10711 ///         To get extended error information, call \ref GscAct_GetLastError.
10712 ///
10713 /// @warning   Following parameters are optional:  aPumpNo. aAmount. aPrice. aDetails. \par
10714 ///            Values returned in these fields can be \c NULL pointers.
10715 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTerminalPaymentData(
10716   ConstHGscAction anAction,
10717   const wchar_t*& aTerminalName,
10718   TGLibDateTime& aTimeStamp,
10719   __int32& aCashierStation,
10720   const __int32*& aPumpNo,
10721   bool& aAlarmStatus,
10722   const double*& aAmount,
10723   const double*& aPrice,
10724   const wchar_t*& aDetails);
10725
10726 /// Decode action 'Tilt down'.
10727 /// Tilt camera down.
10728 /// @param  [in]  anAction     Handle to action to decode.
10729 /// @param  [out] aCamera      PTZ head.
10730 /// @param  [out] aSpeed       Tilt speed.
10731 /// @return \c true if the function succeeds, \c false otherwise.
10732 ///         To get extended error information, call \ref GscAct_GetLastError.
10733 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTiltDown(
10734   ConstHGscAction anAction,
10735   TPlcMediaChannelID& aCamera,
10736   __int32& aSpeed);
10737
10738 /// Decode action 'Tilt stop'.
10739 /// Stop tilt movement.
10740 /// @param  [in]  anAction     Handle to action to decode.
10741 /// @param  [out] aCamera      PTZ head.
10742 /// @return \c true if the function succeeds, \c false otherwise.
10743 ///         To get extended error information, call \ref GscAct_GetLastError.
10744 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTiltStop(
10745   ConstHGscAction anAction,
10746   TPlcMediaChannelID& aCamera);
10747
10748 /// Decode action 'Tilt up'.
10749 /// Tilt camera up.
10750 /// @param  [in]  anAction     Handle to action to decode.
10751 /// @param  [out] aCamera      PTZ head.
10752 /// @param  [out] aSpeed       Tilt speed.
10753 /// @return \c true if the function succeeds, \c false otherwise.
10754 ///         To get extended error information, call \ref GscAct_GetLastError.
10755 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTiltUp(
10756   ConstHGscAction anAction,
10757   TPlcMediaChannelID& aCamera,
10758   __int32& aSpeed);
10759
10760 /// Decode action 'Transfer binary buffer'.
10761 /// Transfer binary buffer.
10762 /// @param  [in]  anAction     Handle to action to decode.
10763 /// @param  [out] aInternalHandle Internal handle.
10764 /// @param  [out] aParameter   Parameter.
10765 /// @return \c true if the function succeeds, \c false otherwise.
10766 ///         To get extended error information, call \ref GscAct_GetLastError.
10767 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTransferBinaryBuffer(
10768   ConstHGscAction anAction,
10769   GUID& aInternalHandle,
10770   const wchar_t*& aParameter);
10771
10772 /// Decode action 'Transfer binary channel buffer'.
10773 /// Transfer binary channel buffer.
10774 /// @param  [in]  anAction     Handle to action to decode.
10775 /// @param  [out] aChannel     Channel.
10776 /// @param  [out] aInternalHandle Internal handle.
10777 /// @param  [out] aParameter   Parameter.
10778 /// @return \c true if the function succeeds, \c false otherwise.
10779 ///         To get extended error information, call \ref GscAct_GetLastError.
10780 GSCACTDLLCALL bool        __stdcall GscAct_DecodeTransferBinaryChannelBuffer(
10781   ConstHGscAction anAction,
10782   TPlcMediaChannelID& aChannel,
10783   GUID& aInternalHandle,
10784   const wchar_t*& aParameter);
10785
10786 /// Decode action 'User login'.
10787 /// This action will be fired when the user has connected to the system.
10788 /// @param  [in]  anAction     Handle to action to decode.
10789 /// @param  [out] aUser1       Name of the user connected to the system.
10790 /// @param  [out] aUser2       Name of the second user by four eyes authentication.
10791 /// @param  [out] aHost        Host from where the connection is done.
10792 /// @param  [out] aClientHost  Host from where the connection is done.
10793 /// @param  [out] aClientType  Client type.
10794 /// @param  [out] aClientAccount User account from where the connection is done.
10795 /// @return \c true if the function succeeds, \c false otherwise.
10796 ///         To get extended error information, call \ref GscAct_GetLastError.
10797 ///
10798 /// @warning   Following parameters are optional:  aUser2. aClientHost. aClientType. aClientAccount. \par
10799 ///            Values returned in these fields can be \c NULL pointers.
10800 GSCACTDLLCALL bool        __stdcall GscAct_DecodeUserLogin(
10801   ConstHGscAction anAction,
10802   const wchar_t*& aUser1,
10803   const wchar_t*& aUser2,
10804   const wchar_t*& aHost,
10805   const wchar_t*& aClientHost,
10806   const PlcClientType*& aClientType,
10807   const wchar_t*& aClientAccount);
10808
10809 /// Decode action 'User login failed'.
10810 /// This action will be fired when the user has tried to connect to the system but was rejected.
10811 /// @param  [in]  anAction     Handle to action to decode.
10812 /// @param  [out] aUser1       Name of the user who tried to connect to the system.
10813 /// @param  [out] aUser2       Name of the second user by four eyes authentication.
10814 /// @param  [out] aHost        Host from where the connection is done.
10815 /// @param  [out] aRejectReason Reason of the rejection.
10816 /// @param  [out] aClientHost  Host from where the connection is done.
10817 /// @param  [out] aClientType  Client type.
10818 /// @param  [out] aClientAccount User account from where the connection is done.
10819 /// @return \c true if the function succeeds, \c false otherwise.
10820 ///         To get extended error information, call \ref GscAct_GetLastError.
10821 ///
10822 /// @warning   Following parameters are optional:  aUser2. aClientHost. aClientType. aClientAccount. \par
10823 ///            Values returned in these fields can be \c NULL pointers.
10824 GSCACTDLLCALL bool        __stdcall GscAct_DecodeUserLoginFailed(
10825   ConstHGscAction anAction,
10826   const wchar_t*& aUser1,
10827   const wchar_t*& aUser2,
10828   const wchar_t*& aHost,
10829   UserLoginFailureCode& aRejectReason,
10830   const wchar_t*& aClientHost,
10831   const PlcClientType*& aClientType,
10832   const wchar_t*& aClientAccount);
10833
10834 /// Decode action 'User logout'.
10835 /// This action will be fired when the user has disconnected from the system.
10836 /// @param  [in]  anAction     Handle to action to decode.
10837 /// @param  [out] aUser1       Name of the user disconnected from the system.
10838 /// @param  [out] aUser2       Name of the second user by four eyes authentication.
10839 /// @param  [out] aHost        Host from where the connection was done.
10840 /// @param  [out] aClientHost  Host from where the connection is done.
10841 /// @param  [out] aClientType  Client type.
10842 /// @param  [out] aClientAccount User account from where the connection is done.
10843 /// @return \c true if the function succeeds, \c false otherwise.
10844 ///         To get extended error information, call \ref GscAct_GetLastError.
10845 ///
10846 /// @warning   Following parameters are optional:  aUser2. aClientHost. aClientType. aClientAccount. \par
10847 ///            Values returned in these fields can be \c NULL pointers.
10848 GSCACTDLLCALL bool        __stdcall GscAct_DecodeUserLogout(
10849   ConstHGscAction anAction,
10850   const wchar_t*& aUser1,
10851   const wchar_t*& aUser2,
10852   const wchar_t*& aHost,
10853   const wchar_t*& aClientHost,
10854   const PlcClientType*& aClientType,
10855   const wchar_t*& aClientAccount);
10856
10857 /// Decode action 'VC alarm queue confirm'.
10858 /// Confirm alarm from the queue on the viewer client.
10859 /// @param  [in]  anAction     Handle to action to decode.
10860 /// @param  [out] aViewer      Global viewer or viewer client no.
10861 /// @param  [out] aSelectionMode Selection mode.
10862 /// @return \c true if the function succeeds, \c false otherwise.
10863 ///         To get extended error information, call \ref GscAct_GetLastError.
10864 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueConfirm(
10865   ConstHGscAction anAction,
10866   TPlcMediaChannelID& aViewer,
10867   PlcViewerAlarmQueueSelection& aSelectionMode);
10868
10869 /// Decode action 'VC alarm queue confirm by instance'.
10870 /// Confirm alarm from the queue on the viewer client.
10871 /// @param  [in]  anAction     Handle to action to decode.
10872 /// @param  [out] aViewer      Global viewer or viewer client no.
10873 /// @param  [out] aAlarmID     Instance ID of the alarm.
10874 /// @return \c true if the function succeeds, \c false otherwise.
10875 ///         To get extended error information, call \ref GscAct_GetLastError.
10876 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueConfirmByInstance(
10877   ConstHGscAction anAction,
10878   TPlcMediaChannelID& aViewer,
10879   __int64& aAlarmID);
10880
10881 /// Decode action 'VC alarm queue confirm by type'.
10882 /// Confirm alarm of specific type from the queue on the viewer client.
10883 /// @param  [in]  anAction     Handle to action to decode.
10884 /// @param  [out] aViewer      Global viewer or viewer client no.
10885 /// @param  [out] aTypeID      Type of the event.
10886 /// @param  [out] aSelectionMode Selection mode.
10887 /// @return \c true if the function succeeds, \c false otherwise.
10888 ///         To get extended error information, call \ref GscAct_GetLastError.
10889 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueConfirmByType(
10890   ConstHGscAction anAction,
10891   TPlcMediaChannelID& aViewer,
10892   TPlcEventTypeID& aTypeID,
10893   PlcViewerAlarmQueueSelection& aSelectionMode);
10894
10895 /// Decode action 'VC alarm queue notification'.
10896 /// Alarm queue notification on the viewer client.
10897 /// @param  [in]  anAction     Handle to action to decode.
10898 /// @param  [out] aViewer      Global viewer or viewer client no.
10899 /// @param  [out] aNotification Alarm state notification.
10900 /// @param  [out] aAlarmID     Instance ID of the alarm.
10901 /// @param  [out] aTypeID      Type of the event.
10902 /// @param  [out] aClientHost  Host from where the connection is done.
10903 /// @param  [out] aClientType  Client type.
10904 /// @param  [out] aClientAccount User account from where the connection is done.
10905 /// @return \c true if the function succeeds, \c false otherwise.
10906 ///         To get extended error information, call \ref GscAct_GetLastError.
10907 ///
10908 /// @warning   Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
10909 ///            Values returned in these fields can be \c NULL pointers.
10910 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueNotification(
10911   ConstHGscAction anAction,
10912   TPlcMediaChannelID& aViewer,
10913   PlcViewerAlarmState& aNotification,
10914   __int64& aAlarmID,
10915   TPlcEventTypeID& aTypeID,
10916   const wchar_t*& aClientHost,
10917   const PlcClientType*& aClientType,
10918   const wchar_t*& aClientAccount);
10919
10920 /// Decode action 'VC alarm queue remove'.
10921 /// Remove alarm from the queue on the viewer client.
10922 /// @param  [in]  anAction     Handle to action to decode.
10923 /// @param  [out] aViewer      Global viewer or viewer client no.
10924 /// @param  [out] aSelectionMode Selection mode.
10925 /// @return \c true if the function succeeds, \c false otherwise.
10926 ///         To get extended error information, call \ref GscAct_GetLastError.
10927 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueRemove(
10928   ConstHGscAction anAction,
10929   TPlcMediaChannelID& aViewer,
10930   PlcViewerAlarmQueueSelection& aSelectionMode);
10931
10932 /// Decode action 'VC alarm queue remove by instance'.
10933 /// Remove alarm from the queue on the viewer client.
10934 /// @param  [in]  anAction     Handle to action to decode.
10935 /// @param  [out] aViewer      Global viewer or viewer client no.
10936 /// @param  [out] aAlarmID     Instance ID of the alarm.
10937 /// @return \c true if the function succeeds, \c false otherwise.
10938 ///         To get extended error information, call \ref GscAct_GetLastError.
10939 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueRemoveByInstance(
10940   ConstHGscAction anAction,
10941   TPlcMediaChannelID& aViewer,
10942   __int64& aAlarmID);
10943
10944 /// Decode action 'VC alarm queue remove by type'.
10945 /// Remove alarm of specific type from the queue on the viewer client.
10946 /// @param  [in]  anAction     Handle to action to decode.
10947 /// @param  [out] aViewer      Global viewer or viewer client no.
10948 /// @param  [out] aTypeID      Type of the event.
10949 /// @param  [out] aSelectionMode Selection mode.
10950 /// @return \c true if the function succeeds, \c false otherwise.
10951 ///         To get extended error information, call \ref GscAct_GetLastError.
10952 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueRemoveByType(
10953   ConstHGscAction anAction,
10954   TPlcMediaChannelID& aViewer,
10955   TPlcEventTypeID& aTypeID,
10956   PlcViewerAlarmQueueSelection& aSelectionMode);
10957
10958 /// Decode action 'VC alarm queue select'.
10959 /// Select alarm from the queue on the viewer client.
10960 /// @param  [in]  anAction     Handle to action to decode.
10961 /// @param  [out] aViewer      Global viewer or viewer client no.
10962 /// @param  [out] aSelectionMode Selection mode.
10963 /// @return \c true if the function succeeds, \c false otherwise.
10964 ///         To get extended error information, call \ref GscAct_GetLastError.
10965 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueSelect(
10966   ConstHGscAction anAction,
10967   TPlcMediaChannelID& aViewer,
10968   PlcViewerAlarmQueueSelection& aSelectionMode);
10969
10970 /// Decode action 'VC alarm queue select by instance'.
10971 /// Select alarm from the queue on the viewer client.
10972 /// @param  [in]  anAction     Handle to action to decode.
10973 /// @param  [out] aViewer      Global viewer or viewer client no.
10974 /// @param  [out] aAlarmID     Instance ID of the alarm.
10975 /// @return \c true if the function succeeds, \c false otherwise.
10976 ///         To get extended error information, call \ref GscAct_GetLastError.
10977 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueSelectByInstance(
10978   ConstHGscAction anAction,
10979   TPlcMediaChannelID& aViewer,
10980   __int64& aAlarmID);
10981
10982 /// Decode action 'VC alarm queue select by type'.
10983 /// Select alarm of specific type from the queue on the viewer client.
10984 /// @param  [in]  anAction     Handle to action to decode.
10985 /// @param  [out] aViewer      Global viewer or viewer client no.
10986 /// @param  [out] aTypeID      Type of the event.
10987 /// @param  [out] aSelectionMode Selection mode.
10988 /// @return \c true if the function succeeds, \c false otherwise.
10989 ///         To get extended error information, call \ref GscAct_GetLastError.
10990 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAlarmQueueSelectByType(
10991   ConstHGscAction anAction,
10992   TPlcMediaChannelID& aViewer,
10993   TPlcEventTypeID& aTypeID,
10994   PlcViewerAlarmQueueSelection& aSelectionMode);
10995
10996 /// Decode action 'VCA set armed'.
10997 /// Send this action to notify VCA to be armed or disarmed.
10998 /// @param  [in]  anAction     Handle to action to decode.
10999 /// @param  [out] aChannel     Channel.
11000 /// @param  [out] aSensorType  Sensor type.
11001 /// @param  [out] aArmed       Armed (true) or disarmed (false)
11002 /// @return \c true if the function succeeds, \c false otherwise.
11003 ///         To get extended error information, call \ref GscAct_GetLastError.
11004 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCASetArmed(
11005   ConstHGscAction anAction,
11006   TPlcMediaChannelID& aChannel,
11007   VideoSensorKind& aSensorType,
11008   bool& aArmed);
11009
11010 /// Decode action 'VCA status answer'.
11011 /// This action will be sent in response to VCA status request.
11012 /// @param  [in]  anAction     Handle to action to decode.
11013 /// @param  [out] aChannel     Channel.
11014 /// @param  [out] aSensorType  Sensor type.
11015 /// @param  [out] aArmed       Armed (true) or disarmed (false)
11016 /// @return \c true if the function succeeds, \c false otherwise.
11017 ///         To get extended error information, call \ref GscAct_GetLastError.
11018 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAStatusAnswer(
11019   ConstHGscAction anAction,
11020   TPlcMediaChannelID& aChannel,
11021   VideoSensorKind& aSensorType,
11022   bool& aArmed);
11023
11024 /// Decode action 'VCA status request'.
11025 /// Send this action to request status of VCA. As response VCA will send VCA status answer.
11026 /// @param  [in]  anAction     Handle to action to decode.
11027 /// @param  [out] aChannel     Channel.
11028 /// @param  [out] aSensorType  Sensor type.
11029 /// @return \c true if the function succeeds, \c false otherwise.
11030 ///         To get extended error information, call \ref GscAct_GetLastError.
11031 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCAStatusRequest(
11032   ConstHGscAction anAction,
11033   TPlcMediaChannelID& aChannel,
11034   VideoSensorKind& aSensorType);
11035
11036 /// Decode action 'VC change scene by name'.
11037 /// Viewer client change scene by name.
11038 /// @param  [in]  anAction     Handle to action to decode.
11039 /// @param  [out] aViewer      Global viewer or viewer client no.
11040 /// @param  [out] aScene       Scene name.
11041 /// @return \c true if the function succeeds, \c false otherwise.
11042 ///         To get extended error information, call \ref GscAct_GetLastError.
11043 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCChangeSceneByName(
11044   ConstHGscAction anAction,
11045   TPlcMediaChannelID& aViewer,
11046   const wchar_t*& aScene);
11047
11048 /// Decode action 'VC clear scene by name'.
11049 /// Viewer client clear scene by name.
11050 /// @param  [in]  anAction     Handle to action to decode.
11051 /// @param  [out] aViewer      Global viewer or viewer client no.
11052 /// @param  [out] aScene       Scene name.
11053 /// @return \c true if the function succeeds, \c false otherwise.
11054 ///         To get extended error information, call \ref GscAct_GetLastError.
11055 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCClearSceneByName(
11056   ConstHGscAction anAction,
11057   TPlcMediaChannelID& aViewer,
11058   const wchar_t*& aScene);
11059
11060 /// Decode action 'VC full mode'.
11061 /// Viewer client full mode.
11062 /// @param  [in]  anAction     Handle to action to decode.
11063 /// @param  [out] aViewer      Global viewer or viewer client no.
11064 /// @param  [out] aFullMode    Switch viewer client in full mode.
11065 /// @param  [out] aSensitiveAreaEnabled Sensitive area enabled.
11066 /// @return \c true if the function succeeds, \c false otherwise.
11067 ///         To get extended error information, call \ref GscAct_GetLastError.
11068 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCFullMode(
11069   ConstHGscAction anAction,
11070   TPlcMediaChannelID& aViewer,
11071   bool& aFullMode,
11072   bool& aSensitiveAreaEnabled);
11073
11074 /// Decode action 'VC scene changed'.
11075 /// Viewer client scene changed.
11076 /// @param  [in]  anAction     Handle to action to decode.
11077 /// @param  [out] aViewer      Global viewer or viewer client no.
11078 /// @param  [out] aScene       Scene name.
11079 /// @return \c true if the function succeeds, \c false otherwise.
11080 ///         To get extended error information, call \ref GscAct_GetLastError.
11081 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCSceneChanged(
11082   ConstHGscAction anAction,
11083   TPlcMediaChannelID& aViewer,
11084   const wchar_t*& aScene);
11085
11086 /// Decode action 'VC set audio level'.
11087 /// Viewer client set audio level.
11088 /// @param  [in]  anAction     Handle to action to decode.
11089 /// @param  [out] aViewer      Global viewer or viewer client no.
11090 /// @param  [out] aAudioLevel  Audio level in range 0 (audio off) till 100 (max. volume).
11091 /// @return \c true if the function succeeds, \c false otherwise.
11092 ///         To get extended error information, call \ref GscAct_GetLastError.
11093 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCSetAudioLevel(
11094   ConstHGscAction anAction,
11095   TPlcMediaChannelID& aViewer,
11096   __int32& aAudioLevel);
11097
11098 /// Decode action 'VC show viewer text'.
11099 /// Viewer client show viewer text.
11100 /// @param  [in]  anAction     Handle to action to decode.
11101 /// @param  [out] aViewer      Global viewer or viewer client no.
11102 /// @param  [out] aShowText    Show text in viewer client.
11103 /// @return \c true if the function succeeds, \c false otherwise.
11104 ///         To get extended error information, call \ref GscAct_GetLastError.
11105 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCShowViewerText(
11106   ConstHGscAction anAction,
11107   TPlcMediaChannelID& aViewer,
11108   bool& aShowText);
11109
11110 /// Decode action 'VC stretch mode'.
11111 /// Viewer client stretch mode.
11112 /// @param  [in]  anAction     Handle to action to decode.
11113 /// @param  [out] aViewer      Global viewer or viewer client no.
11114 /// @param  [out] aStretchMode Switch viewer client in stretch mode.
11115 /// @return \c true if the function succeeds, \c false otherwise.
11116 ///         To get extended error information, call \ref GscAct_GetLastError.
11117 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVCStretchMode(
11118   ConstHGscAction anAction,
11119   TPlcMediaChannelID& aViewer,
11120   bool& aStretchMode);
11121
11122 /// Decode action 'Video contrast detected'.
11123 /// This action will be fired when the contrast is detected in the video signal.
11124 /// @param  [in]  anAction     Handle to action to decode.
11125 /// @param  [out] aChannel     Channel.
11126 /// @return \c true if the function succeeds, \c false otherwise.
11127 ///         To get extended error information, call \ref GscAct_GetLastError.
11128 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoContrastDetected(
11129   ConstHGscAction anAction,
11130   TPlcMediaChannelID& aChannel);
11131
11132 /// Decode action 'Video contrast failed'.
11133 /// This action will be fired when the contrast is lost in the video signal.
11134 /// @param  [in]  anAction     Handle to action to decode.
11135 /// @param  [out] aChannel     Channel.
11136 /// @return \c true if the function succeeds, \c false otherwise.
11137 ///         To get extended error information, call \ref GscAct_GetLastError.
11138 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoContrastFailed(
11139   ConstHGscAction anAction,
11140   TPlcMediaChannelID& aChannel);
11141
11142 /// Decode action 'Video set image brightness'.
11143 /// Video set image brightness.
11144 /// @param  [in]  anAction     Handle to action to decode.
11145 /// @param  [out] aChannel     Channel.
11146 /// @param  [out] aSensorType  Sensor type.
11147 /// @param  [out] aBrightness  Brightness.
11148 /// @return \c true if the function succeeds, \c false otherwise.
11149 ///         To get extended error information, call \ref GscAct_GetLastError.
11150 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoSetImageBrightness(
11151   ConstHGscAction anAction,
11152   TPlcMediaChannelID& aChannel,
11153   VideoSensorKind& aSensorType,
11154   __int32& aBrightness);
11155
11156 /// Decode action 'Video set image contrast'.
11157 /// Video set image contrast.
11158 /// @param  [in]  anAction     Handle to action to decode.
11159 /// @param  [out] aChannel     Channel.
11160 /// @param  [out] aSensorType  Sensor type.
11161 /// @param  [out] aContrast    Contrast.
11162 /// @return \c true if the function succeeds, \c false otherwise.
11163 ///         To get extended error information, call \ref GscAct_GetLastError.
11164 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoSetImageContrast(
11165   ConstHGscAction anAction,
11166   TPlcMediaChannelID& aChannel,
11167   VideoSensorKind& aSensorType,
11168   __int32& aContrast);
11169
11170 /// Decode action 'Video set image saturation'.
11171 /// Video set image saturation.
11172 /// @param  [in]  anAction     Handle to action to decode.
11173 /// @param  [out] aChannel     Channel.
11174 /// @param  [out] aSensorType  Sensor type.
11175 /// @param  [out] aSaturation  Saturation.
11176 /// @return \c true if the function succeeds, \c false otherwise.
11177 ///         To get extended error information, call \ref GscAct_GetLastError.
11178 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoSetImageSaturation(
11179   ConstHGscAction anAction,
11180   TPlcMediaChannelID& aChannel,
11181   VideoSensorKind& aSensorType,
11182   __int32& aSaturation);
11183
11184 /// Decode action 'Video source has changed'.
11185 /// This action indicates the changes on the video input source.
11186 /// @param  [in]  anAction     Handle to action to decode.
11187 /// @param  [out] aChannel     Channel.
11188 /// @param  [out] aSignalNorm  New signal norm.
11189 /// @param  [out] aSignalType  New signal type.
11190 /// @param  [out] aInterlaceType New interlace type.
11191 /// @return \c true if the function succeeds, \c false otherwise.
11192 ///         To get extended error information, call \ref GscAct_GetLastError.
11193 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoSourceChanged(
11194   ConstHGscAction anAction,
11195   TPlcMediaChannelID& aChannel,
11196   VideoSignalNorm& aSignalNorm,
11197   VideoSignalType& aSignalType,
11198   VideoInterlaceType& aInterlaceType);
11199
11200 /// Decode action 'Video sync detected'.
11201 /// This action will be fired when the sync is detected in the video signal.
11202 /// @param  [in]  anAction     Handle to action to decode.
11203 /// @param  [out] aChannel     Channel.
11204 /// @return \c true if the function succeeds, \c false otherwise.
11205 ///         To get extended error information, call \ref GscAct_GetLastError.
11206 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoSyncDetected(
11207   ConstHGscAction anAction,
11208   TPlcMediaChannelID& aChannel);
11209
11210 /// Decode action 'Video sync failed'.
11211 /// This action will be fired when the sync is lost in the video signal.
11212 /// @param  [in]  anAction     Handle to action to decode.
11213 /// @param  [out] aChannel     Channel.
11214 /// @return \c true if the function succeeds, \c false otherwise.
11215 ///         To get extended error information, call \ref GscAct_GetLastError.
11216 GSCACTDLLCALL bool        __stdcall GscAct_DecodeVideoSyncFailed(
11217   ConstHGscAction anAction,
11218   TPlcMediaChannelID& aChannel);
11219
11220 /// Decode action 'Viewer change scene'.
11221 /// Viewer change scene.
11222 /// @param  [in]  anAction     Handle to action to decode.
11223 /// @param  [out] aViewer      Global viewer or viewer client no.
11224 /// @return \c true if the function succeeds, \c false otherwise.
11225 ///         To get extended error information, call \ref GscAct_GetLastError.
11226 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerChangeScene(
11227   ConstHGscAction anAction,
11228   TPlcMediaChannelID& aViewer);
11229
11230 /// Decode action 'Viewer clear'.
11231 /// Clear viewer.
11232 /// @param  [in]  anAction     Handle to action to decode.
11233 /// @param  [out] aViewer      Global viewer or viewer client no.
11234 /// @return \c true if the function succeeds, \c false otherwise.
11235 ///         To get extended error information, call \ref GscAct_GetLastError.
11236 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerClear(
11237   ConstHGscAction anAction,
11238   TPlcMediaChannelID& aViewer);
11239
11240 /// Decode action 'Viewer cleared'.
11241 /// Viewer cleared.
11242 /// @param  [in]  anAction     Handle to action to decode.
11243 /// @param  [out] aViewer      Global viewer or viewer client no.
11244 /// @param  [out] aClientHost  Host from where the connection is done.
11245 /// @param  [out] aClientType  Client type.
11246 /// @param  [out] aClientAccount User account from where the connection is done.
11247 /// @return \c true if the function succeeds, \c false otherwise.
11248 ///         To get extended error information, call \ref GscAct_GetLastError.
11249 ///
11250 /// @warning   Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
11251 ///            Values returned in these fields can be \c NULL pointers.
11252 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerCleared(
11253   ConstHGscAction anAction,
11254   TPlcMediaChannelID& aViewer,
11255   const wchar_t*& aClientHost,
11256   const PlcClientType*& aClientType,
11257   const wchar_t*& aClientAccount);
11258
11259 /// Decode action 'Viewer clear scene'.
11260 /// Viewer clear scene.
11261 /// @param  [in]  anAction     Handle to action to decode.
11262 /// @param  [out] aViewer      Global viewer or viewer client no.
11263 /// @return \c true if the function succeeds, \c false otherwise.
11264 ///         To get extended error information, call \ref GscAct_GetLastError.
11265 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerClearScene(
11266   ConstHGscAction anAction,
11267   TPlcMediaChannelID& aViewer);
11268
11269 /// Decode action 'Viewer clear text output'.
11270 /// Clear text output in the given viewer.
11271 /// @param  [in]  anAction     Handle to action to decode.
11272 /// @param  [out] aViewer      Global viewer or viewer client no.
11273 /// @return \c true if the function succeeds, \c false otherwise.
11274 ///         To get extended error information, call \ref GscAct_GetLastError.
11275 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerClearTextOutput(
11276   ConstHGscAction anAction,
11277   TPlcMediaChannelID& aViewer);
11278
11279 /// Decode action 'Viewer connect'.
11280 /// Connect camera to the viewer.
11281 /// @param  [in]  anAction     Handle to action to decode.
11282 /// @param  [out] aViewer      Global viewer or viewer client no.
11283 /// @param  [out] aChannel     Channel.
11284 /// @param  [out] aPlayMode    Viewer play mode.
11285 /// @return \c true if the function succeeds, \c false otherwise.
11286 ///         To get extended error information, call \ref GscAct_GetLastError.
11287 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerConnect(
11288   ConstHGscAction anAction,
11289   TPlcMediaChannelID& aViewer,
11290   TPlcMediaChannelID& aChannel,
11291   PlcViewerPlayMode& aPlayMode);
11292
11293 /// Decode action 'Viewer connected'.
11294 /// Viewer connected to the camera.
11295 /// @param  [in]  anAction     Handle to action to decode.
11296 /// @param  [out] aViewer      Global viewer or viewer client no.
11297 /// @param  [out] aChannel     Channel.
11298 /// @param  [out] aPlayMode    Viewer play mode.
11299 /// @param  [out] aClientHost  Host from where the connection is done.
11300 /// @param  [out] aClientType  Client type.
11301 /// @param  [out] aClientAccount User account from where the connection is done.
11302 /// @return \c true if the function succeeds, \c false otherwise.
11303 ///         To get extended error information, call \ref GscAct_GetLastError.
11304 ///
11305 /// @warning   Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
11306 ///            Values returned in these fields can be \c NULL pointers.
11307 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerConnected(
11308   ConstHGscAction anAction,
11309   TPlcMediaChannelID& aViewer,
11310   TPlcMediaChannelID& aChannel,
11311   PlcViewerPlayMode& aPlayMode,
11312   const wchar_t*& aClientHost,
11313   const PlcClientType*& aClientType,
11314   const wchar_t*& aClientAccount);
11315
11316 /// Decode action 'Viewer connect live'.
11317 /// Connect live camera to the viewer.
11318 /// @param  [in]  anAction     Handle to action to decode.
11319 /// @param  [out] aViewer      Global viewer or viewer client no.
11320 /// @param  [out] aChannel     Channel.
11321 /// @return \c true if the function succeeds, \c false otherwise.
11322 ///         To get extended error information, call \ref GscAct_GetLastError.
11323 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerConnectLive(
11324   ConstHGscAction anAction,
11325   TPlcMediaChannelID& aViewer,
11326   TPlcMediaChannelID& aChannel);
11327
11328 /// Decode action 'Viewer export picture'.
11329 /// Viewer export picture.
11330 /// @param  [in]  anAction     Handle to action to decode.
11331 /// @param  [out] aViewer      Global viewer or viewer client no.
11332 /// @param  [out] aFilePath    File path (local or UNC). GSCView default path is used if left empty.
11333 /// @return \c true if the function succeeds, \c false otherwise.
11334 ///         To get extended error information, call \ref GscAct_GetLastError.
11335 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerExportPicture(
11336   ConstHGscAction anAction,
11337   TPlcMediaChannelID& aViewer,
11338   const wchar_t*& aFilePath);
11339
11340 /// Decode action 'Viewer jump by time'.
11341 /// Viewer jump by time.
11342 /// @param  [in]  anAction     Handle to action to decode.
11343 /// @param  [out] aViewer      Global viewer or viewer client no.
11344 /// @param  [out] aChannel     Channel.
11345 /// @param  [out] aPlayMode    Viewer play mode.
11346 /// @param  [out] aTimeInSec   Time to jump in seconds. Use negative values to jump in past.
11347 /// @return \c true if the function succeeds, \c false otherwise.
11348 ///         To get extended error information, call \ref GscAct_GetLastError.
11349 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerJumpByTime(
11350   ConstHGscAction anAction,
11351   TPlcMediaChannelID& aViewer,
11352   TPlcMediaChannelID& aChannel,
11353   PlcViewerPlayMode& aPlayMode,
11354   __int32& aTimeInSec);
11355
11356 /// Decode action 'Viewer maximize'.
11357 /// Viewer maximize.
11358 /// @param  [in]  anAction     Handle to action to decode.
11359 /// @param  [out] aViewer      Global viewer or viewer client no.
11360 /// @param  [out] aMaximize    Maximize.
11361 /// @return \c true if the function succeeds, \c false otherwise.
11362 ///         To get extended error information, call \ref GscAct_GetLastError.
11363 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerMaximize(
11364   ConstHGscAction anAction,
11365   TPlcMediaChannelID& aViewer,
11366   bool& aMaximize);
11367
11368 /// Decode action 'Viewer play from time'.
11369 /// Viewer play from time.
11370 /// @param  [in]  anAction     Handle to action to decode.
11371 /// @param  [out] aViewer      Global viewer or viewer client no.
11372 /// @param  [out] aChannel     Channel.
11373 /// @param  [out] aPlayMode    Viewer play mode.
11374 /// @param  [out] aTime        Time to play from.
11375 /// @return \c true if the function succeeds, \c false otherwise.
11376 ///         To get extended error information, call \ref GscAct_GetLastError.
11377 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerPlayFromTime(
11378   ConstHGscAction anAction,
11379   TPlcMediaChannelID& aViewer,
11380   TPlcMediaChannelID& aChannel,
11381   PlcViewerPlayMode& aPlayMode,
11382   TGLibDateTime& aTime);
11383
11384 /// Decode action 'Viewer play mode changed'.
11385 /// Viewer play mode changed.
11386 /// @param  [in]  anAction     Handle to action to decode.
11387 /// @param  [out] aViewer      Global viewer or viewer client no.
11388 /// @param  [out] aChannel     Channel.
11389 /// @param  [out] aPlayMode    Viewer play mode.
11390 /// @param  [out] aChannelTime Channel time.
11391 /// @param  [out] aClientHost  Host from where the connection is done.
11392 /// @param  [out] aClientType  Client type.
11393 /// @param  [out] aClientAccount User account from where the connection is done.
11394 /// @return \c true if the function succeeds, \c false otherwise.
11395 ///         To get extended error information, call \ref GscAct_GetLastError.
11396 ///
11397 /// @warning   Following parameters are optional:  aChannelTime. aClientHost. aClientType. aClientAccount. \par
11398 ///            Values returned in these fields can be \c NULL pointers.
11399 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerPlayModeChanged(
11400   ConstHGscAction anAction,
11401   TPlcMediaChannelID& aViewer,
11402   TPlcMediaChannelID& aChannel,
11403   PlcViewerPlayMode& aPlayMode,
11404   const TGLibDateTime*& aChannelTime,
11405   const wchar_t*& aClientHost,
11406   const PlcClientType*& aClientType,
11407   const wchar_t*& aClientAccount);
11408
11409 /// Decode action 'Viewer print picture'.
11410 /// Viewer print picture.
11411 /// @param  [in]  anAction     Handle to action to decode.
11412 /// @param  [out] aViewer      Global viewer or viewer client no.
11413 /// @return \c true if the function succeeds, \c false otherwise.
11414 ///         To get extended error information, call \ref GscAct_GetLastError.
11415 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerPrintPicture(
11416   ConstHGscAction anAction,
11417   TPlcMediaChannelID& aViewer);
11418
11419 /// Decode action 'Viewer select'.
11420 /// Select viewer.
11421 /// @param  [in]  anAction     Handle to action to decode.
11422 /// @param  [out] aViewer      Global viewer or viewer client no.
11423 /// @return \c true if the function succeeds, \c false otherwise.
11424 ///         To get extended error information, call \ref GscAct_GetLastError.
11425 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerSelect(
11426   ConstHGscAction anAction,
11427   TPlcMediaChannelID& aViewer);
11428
11429 /// Decode action 'Viewer selection changed'.
11430 /// Viewer selection was changed.
11431 /// @param  [in]  anAction     Handle to action to decode.
11432 /// @param  [out] aViewer      Global viewer or viewer client no.
11433 /// @param  [out] aChannel     Channel.
11434 /// @param  [out] aPlayMode    Viewer play mode.
11435 /// @param  [out] aClientHost  Host from where the connection is done.
11436 /// @param  [out] aClientType  Client type.
11437 /// @param  [out] aClientAccount User account from where the connection is done.
11438 /// @return \c true if the function succeeds, \c false otherwise.
11439 ///         To get extended error information, call \ref GscAct_GetLastError.
11440 ///
11441 /// @warning   Following parameters are optional:  aClientHost. aClientType. aClientAccount. \par
11442 ///            Values returned in these fields can be \c NULL pointers.
11443 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerSelectionChanged(
11444   ConstHGscAction anAction,
11445   TPlcMediaChannelID& aViewer,
11446   TPlcMediaChannelID& aChannel,
11447   PlcViewerPlayMode& aPlayMode,
11448   const wchar_t*& aClientHost,
11449   const PlcClientType*& aClientType,
11450   const wchar_t*& aClientAccount);
11451
11452 /// Decode action 'Viewer set play mode'.
11453 /// Set play mode of the viewer.
11454 /// @param  [in]  anAction     Handle to action to decode.
11455 /// @param  [out] aViewer      Global viewer or viewer client no.
11456 /// @param  [out] aPlayMode    Viewer play mode.
11457 /// @param  [out] aPlaySpeed   Optional play speed parameter.
11458 /// @return \c true if the function succeeds, \c false otherwise.
11459 ///         To get extended error information, call \ref GscAct_GetLastError.
11460 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerSetPlayMode(
11461   ConstHGscAction anAction,
11462   TPlcMediaChannelID& aViewer,
11463   PlcViewerPlayMode& aPlayMode,
11464   __int32& aPlaySpeed);
11465
11466 /// Decode action 'Viewer show alarm by instance'.
11467 /// Show alarm in viewer using alarm instance ID.
11468 /// @param  [in]  anAction     Handle to action to decode.
11469 /// @param  [out] aViewer      Global viewer or viewer client no.
11470 /// @param  [out] aAlarmID     Instance ID of the alarm.
11471 /// @param  [out] aPlayMode    Viewer alarm's play mode.
11472 /// @return \c true if the function succeeds, \c false otherwise.
11473 ///         To get extended error information, call \ref GscAct_GetLastError.
11474 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerShowAlarmByInstance(
11475   ConstHGscAction anAction,
11476   TPlcMediaChannelID& aViewer,
11477   __int64& aAlarmID,
11478   PlcViewerAlarmPlayMode& aPlayMode);
11479
11480 /// Decode action 'Viewer show alarm by key'.
11481 /// Show alarm in viewer using alarm foreign key.
11482 /// @param  [in]  anAction     Handle to action to decode.
11483 /// @param  [out] aViewer      Global viewer or viewer client no.
11484 /// @param  [out] aForeignKey  Foreign key used to start the alarm.
11485 /// @param  [out] aPlayMode    Viewer alarm's play mode.
11486 /// @return \c true if the function succeeds, \c false otherwise.
11487 ///         To get extended error information, call \ref GscAct_GetLastError.
11488 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerShowAlarmByKey(
11489   ConstHGscAction anAction,
11490   TPlcMediaChannelID& aViewer,
11491   __int64& aForeignKey,
11492   PlcViewerAlarmPlayMode& aPlayMode);
11493
11494 /// Decode action 'Viewer show alarm by type'.
11495 /// Show alarm in viewer using alarm type and optional foreign key.
11496 /// @param  [in]  anAction     Handle to action to decode.
11497 /// @param  [out] aViewer      Global viewer or viewer client no.
11498 /// @param  [out] aTypeID      Type of the alarm.
11499 /// @param  [out] aForeignKey  Foreign key used to start the alarm.
11500 /// @param  [out] aPlayMode    Viewer alarm's play mode.
11501 /// @return \c true if the function succeeds, \c false otherwise.
11502 ///         To get extended error information, call \ref GscAct_GetLastError.
11503 ///
11504 /// @warning   Following parameters are optional:  aForeignKey. \par
11505 ///            Values returned in these fields can be \c NULL pointers.
11506 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerShowAlarmByType(
11507   ConstHGscAction anAction,
11508   TPlcMediaChannelID& aViewer,
11509   TPlcEventTypeID& aTypeID,
11510   const __int64*& aForeignKey,
11511   PlcViewerAlarmPlayMode& aPlayMode);
11512
11513 /// Decode action 'Viewer change sync audio/video'.
11514 /// Viewer change sync audio/video.
11515 /// @param  [in]  anAction     Handle to action to decode.
11516 /// @param  [out] aViewer      Global viewer or viewer client no.
11517 /// @param  [out] aEnableSync  Enable audio/video sync.
11518 /// @return \c true if the function succeeds, \c false otherwise.
11519 ///         To get extended error information, call \ref GscAct_GetLastError.
11520 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerSyncAudioAndVideo(
11521   ConstHGscAction anAction,
11522   TPlcMediaChannelID& aViewer,
11523   bool& aEnableSync);
11524
11525 /// Decode action 'Viewer text output'.
11526 /// Display free string in the given viewer.
11527 /// @param  [in]  anAction     Handle to action to decode.
11528 /// @param  [out] aViewer      Global viewer or viewer client no.
11529 /// @param  [out] aText        Text string to display.
11530 /// @return \c true if the function succeeds, \c false otherwise.
11531 ///         To get extended error information, call \ref GscAct_GetLastError.
11532 GSCACTDLLCALL bool        __stdcall GscAct_DecodeViewerTextOutput(
11533   ConstHGscAction anAction,
11534   TPlcMediaChannelID& aViewer,
11535   const wchar_t*& aText);
11536
11537 /// Decode action 'Watchdog activate'.
11538 /// Activate watchdog.
11539 /// @param  [in]  anAction     Handle to action to decode.
11540 /// @return \c true if the function succeeds, \c false otherwise.
11541 ///         To get extended error information, call \ref GscAct_GetLastError.
11542 GSCACTDLLCALL bool        __stdcall GscAct_DecodeWatchdogActivate(
11543   ConstHGscAction anAction);
11544
11545 /// Decode action 'Watchdog deactivate'.
11546 /// Deactivate watchdog.
11547 /// @param  [in]  anAction     Handle to action to decode.
11548 /// @return \c true if the function succeeds, \c false otherwise.
11549 ///         To get extended error information, call \ref GscAct_GetLastError.
11550 GSCACTDLLCALL bool        __stdcall GscAct_DecodeWatchdogDeactivate(
11551   ConstHGscAction anAction);
11552
11553 /// Decode action 'Watchdog trigger'.
11554 /// Trigger watchdog.
11555 /// @param  [in]  anAction     Handle to action to decode.
11556 /// @return \c true if the function succeeds, \c false otherwise.
11557 ///         To get extended error information, call \ref GscAct_GetLastError.
11558 GSCACTDLLCALL bool        __stdcall GscAct_DecodeWatchdogTrigger(
11559   ConstHGscAction anAction);
11560
11561 /// Decode action 'Zoom in'.
11562 /// Zoom camera in.
11563 /// @param  [in]  anAction     Handle to action to decode.
11564 /// @param  [out] aCamera      PTZ head.
11565 /// @param  [out] aSpeed       Zoom speed.
11566 /// @return \c true if the function succeeds, \c false otherwise.
11567 ///         To get extended error information, call \ref GscAct_GetLastError.
11568 GSCACTDLLCALL bool        __stdcall GscAct_DecodeZoomIn(
11569   ConstHGscAction anAction,
11570   TPlcMediaChannelID& aCamera,
11571   __int32& aSpeed);
11572
11573 /// Decode action 'Zoom out'.
11574 /// Zoom camera out.
11575 /// @param  [in]  anAction     Handle to action to decode.
11576 /// @param  [out] aCamera      PTZ head.
11577 /// @param  [out] aSpeed       Zoom speed.
11578 /// @return \c true if the function succeeds, \c false otherwise.
11579 ///         To get extended error information, call \ref GscAct_GetLastError.
11580 GSCACTDLLCALL bool        __stdcall GscAct_DecodeZoomOut(
11581   ConstHGscAction anAction,
11582   TPlcMediaChannelID& aCamera,
11583   __int32& aSpeed);
11584
11585 /// Decode action 'Zoom stop'.
11586 /// Stop camera zoom.
11587 /// @param  [in]  anAction     Handle to action to decode.
11588 /// @param  [out] aCamera      PTZ head.
11589 /// @return \c true if the function succeeds, \c false otherwise.
11590 ///         To get extended error information, call \ref GscAct_GetLastError.
11591 GSCACTDLLCALL bool        __stdcall GscAct_DecodeZoomStop(
11592   ConstHGscAction anAction,
11593   TPlcMediaChannelID& aCamera);
11594
11595 ///
11596 /// Deprecated functions
11597
11598 /// Decode action 'Event started'.
11599 /// Event has started.\par
11600 /// This action is deprecated,
11601 /// use \ref GscAct_DecodeEventStartedEx instead.
11602 /// @param  [in]  anAction     Handle to action to decode.
11603 /// @param  [out] aEventID     Instance ID of the event.
11604 /// @param  [out] aTypeID      Type of the event.
11605 /// @return \c true if the function succeeds, \c false otherwise.
11606 ///         To get extended error information, call \ref GscAct_GetLastError.
11607 GSCACTDLLCALL bool        __stdcall GscAct_DecodeEventStarted(
11608   ConstHGscAction anAction,
11609   __int64& aEventID,
11610   TPlcEventTypeID& aTypeID);
11611
11612 /// Decode action 'Sensor inhibit video alarm'.
11613 /// This action will be fired when the motion in inhibit area is detected.\par
11614 /// This action is deprecated,
11615 /// use \ref GscAct_DecodeSensorInhibitVideoAlarmEx instead.
11616 /// @param  [in]  anAction     Handle to action to decode.
11617 /// @param  [out] aChannel     Channel.
11618 /// @param  [out] aSensorType  Sensor type.
11619 /// @param  [out] aADArea      AD alarm area.
11620 /// @param  [out] aADCell      AD cell nr.
11621 /// @param  [out] aVMDGroup    VMD alarm group.
11622 /// @param  [out] aVMDZone     VMD zone nr.
11623 /// @return \c true if the function succeeds, \c false otherwise.
11624 ///         To get extended error information, call \ref GscAct_GetLastError.
11625 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSensorInhibitVideoAlarm(
11626   ConstHGscAction anAction,
11627   TPlcMediaChannelID& aChannel,
11628   VideoSensorKind& aSensorType,
11629   const ADArea*& aADArea,
11630   const __int32*& aADCell,
11631   const VMDGroup*& aVMDGroup,
11632   const __int32*& aVMDZone);
11633
11634 /// Decode action 'Sensor video alarm'.
11635 /// This action will be fired when video alarm is detected.\par
11636 /// This action is deprecated,
11637 /// use \ref GscAct_DecodeSensorVideoAlarmEx instead.
11638 /// @param  [in]  anAction     Handle to action to decode.
11639 /// @param  [out] aChannel     Channel.
11640 /// @param  [out] aSensorType  Sensor type.
11641 /// @param  [out] aADArea      AD alarm area.
11642 /// @param  [out] aADCell      AD cell nr.
11643 /// @param  [out] aVMDGroup    VMD alarm group.
11644 /// @param  [out] aVMDZone     VMD zone nr.
11645 /// @return \c true if the function succeeds, \c false otherwise.
11646 ///         To get extended error information, call \ref GscAct_GetLastError.
11647 GSCACTDLLCALL bool        __stdcall GscAct_DecodeSensorVideoAlarm(
11648   ConstHGscAction anAction,
11649   TPlcMediaChannelID& aChannel,
11650   VideoSensorKind& aSensorType,
11651   const ADArea*& aADArea,
11652   const __int32*& aADCell,
11653   const VMDGroup*& aVMDGroup,
11654   const __int32*& aVMDZone);
11655
11656 /// Decode action 'Start event'.
11657 /// Start event.\par
11658 /// This action is deprecated,
11659 /// use \ref GscAct_DecodeStartEventEx instead.
11660 /// @param  [in]  anAction     Handle to action to decode.
11661 /// @param  [out] aTypeID      Type of the event.
11662 /// @return \c true if the function succeeds, \c false otherwise.
11663 ///         To get extended error information, call \ref GscAct_GetLastError.
11664 GSCACTDLLCALL bool        __stdcall GscAct_DecodeStartEvent(
11665   ConstHGscAction anAction,
11666   TPlcEventTypeID& aTypeID);
11667
11668 /// \} end of group GscPlcDecode
11669
11670 /////////////////////////////////////////////////////////
11671 /// Deprecated functions
11672 /////////////////////////////////////////////////////////
11673
11674 #ifndef __BORLANDC__
11675   #pragma deprecated(GscAct_CreateSensorVideoAlarm)
11676   #pragma deprecated(GscAct_DecodeSensorVideoAlarm)
11677   #pragma deprecated(GscAct_CreateSensorInhibitVideoAlarm)
11678   #pragma deprecated(GscAct_DecodeSensorInhibitVideoAlarm)
11679   #pragma deprecated(GscAct_CreateStartEvent)
11680   #pragma deprecated(GscAct_DecodeStartEvent)
11681   #pragma deprecated(GscAct_CreateEventStarted)
11682   #pragma deprecated(GscAct_DecodeEventStarted)
11683 #else
11684   #pragma obsolete GscAct_CreateSensorVideoAlarm
11685   #pragma obsolete GscAct_DecodeSensorVideoAlarm
11686   #pragma obsolete GscAct_CreateSensorInhibitVideoAlarm
11687   #pragma obsolete GscAct_DecodeSensorInhibitVideoAlarm
11688   #pragma obsolete GscAct_CreateStartEvent
11689   #pragma obsolete GscAct_DecodeStartEvent
11690   #pragma obsolete GscAct_CreateEventStarted
11691   #pragma obsolete GscAct_DecodeEventStarted
11692 #endif
11693
11694 #ifdef __cplusplus
11695 }; // namespace
11696 }; // __cplusplus
11697 #endif
11698
11699 #endif


GSC actions: GscActionsDispatcher.h Source File

  • File List
  • File Members

GscActionsDispatcher.h

Go to the documentation of this file.
00001
00002 ///
00003 ///  @file   GscActionsDispatcher.h
00004 ///  @brief  This dispatcher class allows you to implement your own derived dispatcher by overriding virtual functions.
00005 ///
00006 ///  Copyright (c) 2004 - 2010 Geutebrueck GmbH.  All rights reserved.
00007 ///
00008 ///  This file is part of the GEVISCOPE SDK.
00009 ///
00010 ///  This software is provided "as is" without express or implied warranty,
00011 ///  and with no claim as to its suitability for any purpose.
00012 ///
00013
00014 #ifndef GscActionsDispatcherH
00015 #define GscActionsDispatcherH
00016
00017 #include "GscActions.h"
00018
00019 #ifdef __cplusplus
00020 namespace GscPLC
00021 {
00022 #endif
00023
00024 /// \addtogroup GscPlcDispatcherVirtual
00025 /// \{
00026
00027 class GscActionsDispatcher {
00028   public:
00029     GscActionsDispatcher() {}
00030     virtual ~GscActionsDispatcher() {}
00031
00032   public:
00033     bool Dispatch(HGscAction Action);
00034
00035   protected:
00036     virtual bool OnUnregisteredMessage(HGscAction Action)
00037     { return false; }
00038
00039
00040 //////////////////////////////////////////////////////////////////////////
00041 /// System actions
00042 ///
00043
00044 virtual bool OnBlockingFilterActivate(HGscAction anAction,
00045   const wchar_t* aFilter)
00046 { return false; }
00047
00048 virtual bool OnBlockingFilterDeactivate(HGscAction anAction,
00049   const wchar_t* aFilter)
00050 { return false; }
00051
00052 virtual bool OnCustomAction(HGscAction anAction,
00053   const __int64& aInt,
00054   const wchar_t* aString)
00055 { return false; }
00056
00057 virtual bool OnDatabaseRecordingInfoRing(HGscAction anAction,
00058   const PlcDatabaseRing aDatabaseRing,
00059   const bool aNoVideoRecording,
00060   const bool aNoAudioRecording,
00061   const bool aNoRecordingAtAll,
00062   const double& aVideoSamplesPerSecond,
00063   const double& aVideoMBPerSecond,
00064   const double& aAudioSamplesPerSecond,
00065   const double& aAudioMBPerSecond,
00066   const double& aWriteWaitTimesPercent,
00067   const __int64& aRingCapacity,
00068   const TGLibDateTime& aOldestItem,
00069   const double* aRecordingDepth,
00070   const __int64* aEstimatedRequiredCapacity)
00071 { return false; }
00072
00073 virtual bool OnDatabaseRecordingInfoTotal(HGscAction anAction,
00074   const bool aNoVideoRecording,
00075   const bool aNoAudioRecording,
00076   const bool aNoRecordingAtAll,
00077   const double& aVideoSamplesPerSecond,
00078   const double& aVideoMBPerSecond,
00079   const double& aAudioSamplesPerSecond,
00080   const double& aAudioMBPerSecond,
00081   const double& aWriteWaitTimesPercent,
00082   const __int64& aTotalCapacity,
00083   const __int64& aFreeCapacity,
00084   const __int64& aAllocatedCapacity,
00085   const TGLibDateTime* aOldestItem,
00086   const double* aRecordingDepth,
00087   const __int64* aEstimatedRequiredCapacity,
00088   const double* aRequiredCapacityFactor,
00089   const bool* aRequiredCapacityAvailable)
00090 { return false; }
00091
00092 virtual bool OnDatabaseStarted(HGscAction anAction,
00093   const PlcDatabaseStatus aStatus,
00094   const __int64& aTotalSize)
00095 { return false; }
00096
00097 virtual bool OnEventRecordingChanged(HGscAction anAction,
00098   const __int64& aEventID,
00099   const TPlcEventTypeID& aTypeID)
00100 { return false; }
00101
00102 virtual bool OnEventStarted(HGscAction anAction,
00103   const __int64& aEventID,
00104   const TPlcEventTypeID& aTypeID,
00105   const __int64* aForeignKey)
00106 { return false; }
00107
00108 virtual bool OnEventStopped(HGscAction anAction,
00109   const __int64& aEventID,
00110   const TPlcEventTypeID& aTypeID)
00111 { return false; }
00112
00113 virtual bool OnFRCNotification(HGscAction anAction,
00114   const PlcFRCNotification aNotification,
00115   const __int32* aParam,
00116   const wchar_t* aDescription,
00117   const char* aXMLInfo)
00118 { return false; }
00119
00120 virtual bool OnGEMOSalarm(HGscAction anAction,
00121   const __int64& aGEMOSkey,
00122   const __int32 aGEMOSint,
00123   const wchar_t* aGEMOSstr)
00124 { return false; }
00125
00126 virtual bool OnIPSwitchOperation(HGscAction anAction,
00127   const IPSwitchOps aOperation,
00128   const wchar_t* aPort,
00129   const __int32* aParam)
00130 { return false; }
00131
00132 virtual bool OnKillAllEvents(HGscAction anAction)
00133 { return false; }
00134
00135 virtual bool OnKillEvent(HGscAction anAction,
00136   const TPlcEventTypeID& aTypeID)
00137 { return false; }
00138
00139 virtual bool OnKillEventByID(HGscAction anAction,
00140   const __int64& aEventID)
00141 { return false; }
00142
00143 virtual bool OnLiveCheck(HGscAction anAction,
00144   const __int64& aCounter,
00145   const TGLibDateTime& aDate)
00146 { return false; }
00147
00148 virtual bool OnRedundantPowerFailure(HGscAction anAction)
00149 { return false; }
00150
00151 virtual bool OnRedundantPowerOk(HGscAction anAction)
00152 { return false; }
00153
00154 virtual bool OnSetClock(HGscAction anAction,
00155   const TGLibDateTime& aDate)
00156 { return false; }
00157
00158 virtual bool OnSetupChanged(HGscAction anAction,
00159   const wchar_t* aUser,
00160   const wchar_t* aHost,
00161   const TGLibDateTime& aDate,
00162   const PlcResourceKind aResourceKind,
00163   const TPlcEventTypeID& aResourceID,
00164   const PlcResourceChangeKind aChangeKind,
00165   const wchar_t* aDetails,
00166   const wchar_t* aClientHost,
00167   const PlcClientType* aClientType,
00168   const wchar_t* aClientAccount)
00169 { return false; }
00170
00171 virtual bool OnSetupUploadProgress(HGscAction anAction,
00172   const wchar_t* aUser1,
00173   const wchar_t* aUser2,
00174   const wchar_t* aHost,
00175   const __int32 aProgress,
00176   const TGLibDateTime& aDate)
00177 { return false; }
00178
00179 virtual bool OnSetWatchdog(HGscAction anAction,
00180   const __int32 aTimeout)
00181 { return false; }
00182
00183 virtual bool OnSMRPViewerCleared(HGscAction anAction)
00184 { return false; }
00185
00186 virtual bool OnSMRPViewerConnected(HGscAction anAction,
00187   const wchar_t* aServer,
00188   const TPlcMediaChannelID& aChannel)
00189 { return false; }
00190
00191 virtual bool OnSMTPMailSend(HGscAction anAction,
00192   const wchar_t* aSubject,
00193   const wchar_t* aTo,
00194   const wchar_t* aCc,
00195   const wchar_t* aBody,
00196   const TPlcMediaChannelID* aChannel)
00197 { return false; }
00198
00199 virtual bool OnStartEvent(HGscAction anAction,
00200   const TPlcEventTypeID& aTypeID,
00201   const __int64* aForeignKey)
00202 { return false; }
00203
00204 virtual bool OnStopAllEvents(HGscAction anAction)
00205 { return false; }
00206
00207 virtual bool OnStopEvent(HGscAction anAction,
00208   const TPlcEventTypeID& aTypeID)
00209 { return false; }
00210
00211 virtual bool OnStopEventByID(HGscAction anAction,
00212   const __int64& aEventID)
00213 { return false; }
00214
00215 virtual bool OnSystemError(HGscAction anAction,
00216   const PlcMessageSource aSource,
00217   const PlcMessageCode aMessage,
00218   const __int32* aWindowsError,
00219   const wchar_t* aDescription,
00220   const char* aXMLInfo)
00221 { return false; }
00222
00223 virtual bool OnSystemInfo(HGscAction anAction,
00224   const PlcMessageSource aSource,
00225   const PlcMessageCode aMessage,
00226   const wchar_t* aDescription,
00227   const char* aXMLInfo)
00228 { return false; }
00229
00230 virtual bool OnSystemSettingsChanged(HGscAction anAction,
00231   const bool aSetupChanged,
00232   const wchar_t* aUser1,
00233   const wchar_t* aUser2,
00234   const wchar_t* aHost,
00235   const bool aTimeRangeChanged,
00236   const TPlcResourceID* aTimeRange,
00237   const bool aLicenceChanged,
00238   const TGLibDateTime& aDate)
00239 { return false; }
00240
00241 virtual bool OnSystemStarted(HGscAction anAction,
00242   const TGLibDateTime& aDate)
00243 { return false; }
00244
00245 virtual bool OnSystemTerminating(HGscAction anAction,
00246   const TGLibDateTime& aDate,
00247   const bool aWindowsShutdown)
00248 { return false; }
00249
00250 virtual bool OnSystemWarning(HGscAction anAction,
00251   const PlcMessageSource aSource,
00252   const PlcMessageCode aMessage,
00253   const __int32* aWindowsError,
00254   const wchar_t* aDescription,
00255   const char* aXMLInfo)
00256 { return false; }
00257
00258 virtual bool OnTransferBinaryBuffer(HGscAction anAction,
00259   const GUID& aInternalHandle,
00260   const wchar_t* aParameter)
00261 { return false; }
00262
00263 virtual bool OnTransferBinaryChannelBuffer(HGscAction anAction,
00264   const TPlcMediaChannelID& aChannel,
00265   const GUID& aInternalHandle,
00266   const wchar_t* aParameter)
00267 { return false; }
00268
00269 virtual bool OnUserLogin(HGscAction anAction,
00270   const wchar_t* aUser1,
00271   const wchar_t* aUser2,
00272   const wchar_t* aHost,
00273   const wchar_t* aClientHost,
00274   const PlcClientType* aClientType,
00275   const wchar_t* aClientAccount)
00276 { return false; }
00277
00278 virtual bool OnUserLoginFailed(HGscAction anAction,
00279   const wchar_t* aUser1,
00280   const wchar_t* aUser2,
00281   const wchar_t* aHost,
00282   const UserLoginFailureCode aRejectReason,
00283   const wchar_t* aClientHost,
00284   const PlcClientType* aClientType,
00285   const wchar_t* aClientAccount)
00286 { return false; }
00287
00288 virtual bool OnUserLogout(HGscAction anAction,
00289   const wchar_t* aUser1,
00290   const wchar_t* aUser2,
00291   const wchar_t* aHost,
00292   const wchar_t* aClientHost,
00293   const PlcClientType* aClientType,
00294   const wchar_t* aClientAccount)
00295 { return false; }
00296
00297 //////////////////////////////////////////////////////////////////////////
00298 /// Video control
00299 ///
00300
00301 virtual bool OnActivateExternalProcess(HGscAction anAction,
00302   const TPlcMediaChannelID& aChannel,
00303   const TGLibDateTime& aTimeStamp,
00304   const VideoSensorKind aExternalSystem)
00305 { return false; }
00306
00307 virtual bool OnChangeADParameterSet(HGscAction anAction,
00308   const TPlcMediaChannelID& aChannel,
00309   const TPlcResourceID& aParameterSet)
00310 { return false; }
00311
00312 virtual bool OnChangeCameraProfile(HGscAction anAction,
00313   const TPlcResourceID& aHardwareModule,
00314   const TPlcResourceID& aCameraProfile)
00315 { return false; }
00316
00317 virtual bool OnChangeCPAParameterSet(HGscAction anAction,
00318   const TPlcMediaChannelID& aChannel,
00319   const TPlcResourceID& aParameterSet)
00320 { return false; }
00321
00322 virtual bool OnChangeGTectParameterSet(HGscAction anAction,
00323   const TPlcMediaChannelID& aChannel,
00324   const TPlcResourceID& aParameterSet)
00325 { return false; }
00326
00327 virtual bool OnChangeObtrackParameterSet(HGscAction anAction,
00328   const TPlcMediaChannelID& aChannel,
00329   const TPlcResourceID& aParameterSet)
00330 { return false; }
00331
00332 virtual bool OnChangeVMDParameterSet(HGscAction anAction,
00333   const TPlcMediaChannelID& aChannel,
00334   const TPlcResourceID& aParameterSet)
00335 { return false; }
00336
00337 virtual bool OnChannelError(HGscAction anAction,
00338   const TPlcMediaChannelID& aChannel,
00339   const VideoSensorKind* aSensorType,
00340   const PlcMessageSource aSource,
00341   const PlcMessageCode aMessage,
00342   const __int32* aWindowsError,
00343   const wchar_t* aDescription,
00344   const char* aXMLInfo)
00345 { return false; }
00346
00347 virtual bool OnChannelInfo(HGscAction anAction,
00348   const TPlcMediaChannelID& aChannel,
00349   const VideoSensorKind* aSensorType,
00350   const PlcMessageSource aSource,
00351   const PlcMessageCode aMessage,
00352   const wchar_t* aDescription,
00353   const char* aXMLInfo)
00354 { return false; }
00355
00356 virtual bool OnChannelLiveCheck(HGscAction anAction,
00357   const TPlcMediaChannelID& aChannel,
00358   const VideoSensorKind aSensorType,
00359   const TGLibDateTime& aTimeStamp)
00360 { return false; }
00361
00362 virtual bool OnChannelWarning(HGscAction anAction,
00363   const TPlcMediaChannelID& aChannel,
00364   const VideoSensorKind* aSensorType,
00365   const PlcMessageSource aSource,
00366   const PlcMessageCode aMessage,
00367   const __int32* aWindowsError,
00368   const wchar_t* aDescription,
00369   const char* aXMLInfo)
00370 { return false; }
00371
00372 virtual bool OnCPAMeasurement(HGscAction anAction,
00373   const TPlcMediaChannelID& aChannel,
00374   const __int32 aCorrelation)
00375 { return false; }
00376
00377 virtual bool OnGTectAnalyticsLiveCheck(HGscAction anAction)
00378 { return false; }
00379
00380 virtual bool OnGTectDualSensorAlarm(HGscAction anAction,
00381   const TPlcMediaChannelID& aChannel,
00382   const __int32* aSterileZoneNumber,
00383   const __int32* aVirtualFenceNumber,
00384   const VMDGroup* aVMDGroup,
00385   const __int32* aVMDZone,
00386   const VMDCycle* aVMDCycle,
00387   const TPlcRect* aAlarmArea)
00388 { return false; }
00389
00390 virtual bool OnGTectDualSensorAlarmFinished(HGscAction anAction,
00391   const TPlcMediaChannelID& aChannel)
00392 { return false; }
00393
00394 virtual bool OnGTectSceneAlarm(HGscAction anAction,
00395   const TPlcMediaChannelID& aChannel,
00396   const GTectSceneAlarmReason aAlarmReason)
00397 { return false; }
00398
00399 virtual bool OnGTectSceneAlarmFinished(HGscAction anAction,
00400   const TPlcMediaChannelID& aChannel,
00401   const GTectSceneAlarmReason aAlarmReason)
00402 { return false; }
00403
00404 virtual bool OnGTectVMXAlarm(HGscAction anAction,
00405   const TPlcMediaChannelID& aChannel,
00406   const __int32* aSterileZoneNumber,
00407   const __int32* aVirtualFenceNumber,
00408   const __int32* aAlarmGroup,
00409   const __int32* aTrackID,
00410   const TPlcRect* aAlarmArea)
00411 { return false; }
00412
00413 virtual bool OnGTectVMXAlarmFinished(HGscAction anAction,
00414   const TPlcMediaChannelID& aChannel)
00415 { return false; }
00416
00417 virtual bool OnIASSettingsChanged(HGscAction anAction,
00418   const TPlcMediaChannelID& aChannel,
00419   const VideoSensorKind aSensorType)
00420 { return false; }
00421
00422 virtual bool OnIPCameraRawCommand(HGscAction anAction,
00423   const wchar_t* aURL,
00424   const wchar_t* aUser,
00425   const wchar_t* aPassword,
00426   const wchar_t* aPOST)
00427 { return false; }
00428
00429 virtual bool OnIPCamFailoverNotification(HGscAction anAction,
00430   const wchar_t* aPrimaryServer,
00431   const wchar_t* aSecondaryServer,
00432   const TPlcMediaChannelID& aPrimaryChannel,
00433   const TPlcMediaChannelID& aSecondaryChannel,
00434   const wchar_t* aCameraParameters)
00435 { return false; }
00436
00437 virtual bool OnIPCamFailoverRestore(HGscAction anAction,
00438   const wchar_t* aPrimaryServer,
00439   const wchar_t* aSecondaryServer,
00440   const TPlcMediaChannelID& aPrimaryChannel,
00441   const TPlcMediaChannelID& aSecondaryChannel,
00442   const wchar_t* aCameraParameters)
00443 { return false; }
00444
00445 virtual bool OnMakeCPAReferenceImage(HGscAction anAction,
00446   const TPlcMediaChannelID& aChannel)
00447 { return false; }
00448
00449 virtual bool OnMediaChannelSetupInfo(HGscAction anAction,
00450   const TPlcMediaChannelID& aChannel,
00451   const TGLibDateTime& aTimeStamp,
00452   const wchar_t* aParameter)
00453 { return false; }
00454
00455 virtual bool OnNPRRawData(HGscAction anAction,
00456   const wchar_t* aPlateNo,
00457   const wchar_t* aCountry,
00458   const TPlcMediaChannelID& aChannel,
00459   const TGLibDateTime& aTimeStamp,
00460   const TPlcRect& aZoneRect,
00461   const __int32 aWeight,
00462   const __int32 aZoneState,
00463   const __int32 aZonePlace,
00464   const __int32 aSpeed,
00465   const __int32 aDirection,
00466   const __int32 aZoneIndex,
00467   const bool aCurBest,
00468   const __int32 aPlateWidth,
00469   const __int32 aPlateHeight,
00470   const __int32 aPlateAngle,
00471   const __int32 aSymHeight,
00472   const wchar_t* aType)
00473 { return false; }
00474
00475 virtual bool OnNPRRecognition(HGscAction anAction,
00476   const wchar_t* aPlateNo,
00477   const wchar_t* aCountry,
00478   const TPlcMediaChannelID& aChannel,
00479   const TGLibDateTime& aTimeStamp,
00480   const TPlcRect& aZoneRect,
00481   const PlcNPRRestriction aRestriction,
00482   const wchar_t* aCategory,
00483   const __int32 aSpeed,
00484   const __int32 aDirection,
00485   const __int32 aZoneIndex,
00486   const wchar_t* aType,
00487   const __int32 aWeight)
00488 { return false; }
00489
00490 virtual bool OnObtrackChannelCounter(HGscAction anAction,
00491   const TPlcMediaChannelID& aChannel,
00492   const PlcObtrackCounterType aCounterType,
00493   const __int64& aCounterValue,
00494   const __int32 aObjectDirection,
00495   const TGLibDateTime& aTimeStamp,
00496   const TGLibDateTime* aResetTimeStamp)
00497 { return false; }
00498
00499 virtual bool OnObtrackChannelCounterThreshold(HGscAction anAction,
00500   const TPlcMediaChannelID& aChannel,
00501   const PlcObtrackCounterType aCounterType,
00502   const __int64& aCounterValue,
00503   const PlcObtrackExceedingDirection aExceedingDirection,
00504   const TGLibDateTime& aTimeStamp)
00505 { return false; }
00506
00507 virtual bool OnObtrackChannelSetCounter(HGscAction anAction,
00508   const TPlcMediaChannelID& aChannel,
00509   const PlcObtrackCounterType aCounterType,
00510   const __int64& aCounterValue,
00511   const TGLibDateTime& aTimeStamp)
00512 { return false; }
00513
00514 virtual bool OnObtrackFrameRawData(HGscAction anAction,
00515   const TGLibDateTime& aTimeStamp,
00516   const TPlcMediaChannelID& aChannel,
00517   const __int32 aBrightness,
00518   const __int32 aContrast)
00519 { return false; }
00520
00521 virtual bool OnObtrackGroupCounter(HGscAction anAction,
00522   const __int32 aGroupId,
00523   const PlcObtrackCounterType aCounterType,
00524   const __int64& aCounterValue,
00525   const __int32 aObjectDirection,
00526   const TGLibDateTime& aTimeStamp,
00527   const TGLibDateTime* aResetTimeStamp,
00528   const wchar_t* aGroupName)
00529 { return false; }
00530
00531 virtual bool OnObtrackGroupCounterThreshold(HGscAction anAction,
00532   const __int32 aGroupId,
00533   const PlcObtrackCounterType aCounterType,
00534   const __int64& aCounterValue,
00535   const PlcObtrackExceedingDirection aExceedingDirection,
00536   const TGLibDateTime& aTimeStamp,
00537   const wchar_t* aGroupName)
00538 { return false; }
00539
00540 virtual bool OnObtrackGroupSetCounter(HGscAction anAction,
00541   const __int32 aGroupId,
00542   const PlcObtrackCounterType aCounterType,
00543   const __int64& aCounterValue,
00544   const TGLibDateTime& aTimeStamp,
00545   const wchar_t* aGroupName)
00546 { return false; }
00547
00548 virtual bool OnObtrackObjectRawData(HGscAction anAction,
00549   const TGLibDateTime& aTimeStamp,
00550   const TPlcMediaChannelID& aChannel,
00551   const __int32 aArea,
00552   const __int32 aObjectID,
00553   const PlcObtrackObjectStatus aObjectStatus,
00554   const PlcObtrackObjectClass aObjectClass,
00555   const __int32* aConfidence,
00556   const TPlcRect* aPosition,
00557   const double* aSpeed,
00558   const __int32* aDuration,
00559   const __int32* aDirection,
00560   const double* aSize,
00561   const double* aObjectWidth,
00562   const double* aObjectHeight,
00563   const PlcObtrackProcessSize* aProcessSize,
00564   const char* aGscNetName)
00565 { return false; }
00566
00567 virtual bool OnObtrackTunnelAlarm(HGscAction anAction,
00568   const TPlcMediaChannelID& aChannel,
00569   const TGLibDateTime& aTimeStamp,
00570   const PlcTunnelAlarmReason aAlarmReason,
00571   const __int32 aObjectID,
00572   const __int32 aAlarmAreaID,
00573   const TPlcRect* aObjectArea)
00574 { return false; }
00575
00576 virtual bool OnSensorAlarmFinished(HGscAction anAction,
00577   const TPlcMediaChannelID& aChannel,
00578   const VideoSensorKind aSensorType)
00579 { return false; }
00580
00581 virtual bool OnSensorInhibitAlarmFinished(HGscAction anAction,
00582   const TPlcMediaChannelID& aChannel,
00583   const VideoSensorKind aSensorType)
00584 { return false; }
00585
00586 virtual bool OnSensorInhibitVideoAlarm(HGscAction anAction,
00587   const TPlcMediaChannelID& aChannel,
00588   const VideoSensorKind aSensorType,
00589   const ADArea* aADArea,
00590   const __int32* aADCell,
00591   const VMDGroup* aVMDGroup,
00592   const __int32* aVMDZone,
00593   const VMDCycle* aVMDCycle,
00594   const TPlcRect* aAlarmArea,
00595   const PlcObtrackObjectClass* aObjectClass)
00596 { return false; }
00597
00598 virtual bool OnSensorVideoAlarm(HGscAction anAction,
00599   const TPlcMediaChannelID& aChannel,
00600   const VideoSensorKind aSensorType,
00601   const ADArea* aADArea,
00602   const __int32* aADCell,
00603   const VMDGroup* aVMDGroup,
00604   const __int32* aVMDZone,
00605   const VMDCycle* aVMDCycle,
00606   const TPlcRect* aAlarmArea,
00607   const PlcObtrackObjectClass* aObjectClass)
00608 { return false; }
00609
00610 virtual bool OnSetClientVCA(HGscAction anAction,
00611   const TPlcMediaChannelID& aChannel,
00612   const GTectClientVCAType aClientVCAType,
00613   const bool aEnabled)
00614 { return false; }
00615
00616 virtual bool OnSetSystemTime(HGscAction anAction,
00617   const TGLibDateTime& aTimeStamp)
00618 { return false; }
00619
00620 virtual bool OnSetTestPictureMode(HGscAction anAction,
00621   const TPlcMediaChannelID& aChannel,
00622   const bool aMode)
00623 { return false; }
00624
00625 virtual bool OnVCASetArmed(HGscAction anAction,
00626   const TPlcMediaChannelID& aChannel,
00627   const VideoSensorKind aSensorType,
00628   const bool aArmed)
00629 { return false; }
00630
00631 virtual bool OnVCAStatusAnswer(HGscAction anAction,
00632   const TPlcMediaChannelID& aChannel,
00633   const VideoSensorKind aSensorType,
00634   const bool aArmed)
00635 { return false; }
00636
00637 virtual bool OnVCAStatusRequest(HGscAction anAction,
00638   const TPlcMediaChannelID& aChannel,
00639   const VideoSensorKind aSensorType)
00640 { return false; }
00641
00642 virtual bool OnVideoContrastDetected(HGscAction anAction,
00643   const TPlcMediaChannelID& aChannel)
00644 { return false; }
00645
00646 virtual bool OnVideoContrastFailed(HGscAction anAction,
00647   const TPlcMediaChannelID& aChannel)
00648 { return false; }
00649
00650 virtual bool OnVideoSetImageBrightness(HGscAction anAction,
00651   const TPlcMediaChannelID& aChannel,
00652   const VideoSensorKind aSensorType,
00653   const __int32 aBrightness)
00654 { return false; }
00655
00656 virtual bool OnVideoSetImageContrast(HGscAction anAction,
00657   const TPlcMediaChannelID& aChannel,
00658   const VideoSensorKind aSensorType,
00659   const __int32 aContrast)
00660 { return false; }
00661
00662 virtual bool OnVideoSetImageSaturation(HGscAction anAction,
00663   const TPlcMediaChannelID& aChannel,
00664   const VideoSensorKind aSensorType,
00665   const __int32 aSaturation)
00666 { return false; }
00667
00668 virtual bool OnVideoSourceChanged(HGscAction anAction,
00669   const TPlcMediaChannelID& aChannel,
00670   const VideoSignalNorm aSignalNorm,
00671   const VideoSignalType aSignalType,
00672   const VideoInterlaceType aInterlaceType)
00673 { return false; }
00674
00675 virtual bool OnVideoSyncDetected(HGscAction anAction,
00676   const TPlcMediaChannelID& aChannel)
00677 { return false; }
00678
00679 virtual bool OnVideoSyncFailed(HGscAction anAction,
00680   const TPlcMediaChannelID& aChannel)
00681 { return false; }
00682
00683 //////////////////////////////////////////////////////////////////////////
00684 /// Audio control
00685 ///
00686
00687 virtual bool OnABCConnect(HGscAction anAction,
00688   const wchar_t* aAddress)
00689 { return false; }
00690
00691 virtual bool OnABCDisconnect(HGscAction anAction)
00692 { return false; }
00693
00694 virtual bool OnABCPlayFile(HGscAction anAction,
00695   const __int64& aFileID,
00696   const wchar_t* aFileName,
00697   const bool aAutoRepeat)
00698 { return false; }
00699
00700 virtual bool OnSensorAudioAlarm(HGscAction anAction,
00701   const TPlcMediaChannelID& aChannel)
00702 { return false; }
00703
00704 //////////////////////////////////////////////////////////////////////////
00705 /// Camera control
00706 ///
00707
00708 virtual bool OnAutoFocusOff(HGscAction anAction,
00709   const TPlcMediaChannelID& aCamera)
00710 { return false; }
00711
00712 virtual bool OnAutoFocusOn(HGscAction anAction,
00713   const TPlcMediaChannelID& aCamera)
00714 { return false; }
00715
00716 virtual bool OnCameraApplyProfile(HGscAction anAction,
00717   const TPlcMediaChannelID& aCamera,
00718   const wchar_t* aProfile)
00719 { return false; }
00720
00721 virtual bool OnCameraBacklightCompensationMode(HGscAction anAction,
00722   const TPlcMediaChannelID& aCamera,
00723   const PlcBacklightMode aMode)
00724 { return false; }
00725
00726 virtual bool OnCameraClearPrePosText(HGscAction anAction,
00727   const TPlcMediaChannelID& aCamera,
00728   const __int32 aPosition)
00729 { return false; }
00730
00731 virtual bool OnCameraDayNightMode(HGscAction anAction,
00732   const TPlcMediaChannelID& aCamera,
00733   const PlcDayNightMode aMode)
00734 { return false; }
00735
00736 virtual bool OnCameraLightOff(HGscAction anAction,
00737   const TPlcMediaChannelID& aCamera)
00738 { return false; }
00739
00740 virtual bool OnCameraLightOn(HGscAction anAction,
00741   const TPlcMediaChannelID& aCamera)
00742 { return false; }
00743
00744 virtual bool OnCameraManualIrisOff(HGscAction anAction,
00745   const TPlcMediaChannelID& aCamera)
00746 { return false; }
00747
00748 virtual bool OnCameraManualIrisOn(HGscAction anAction,
00749   const TPlcMediaChannelID& aCamera)
00750 { return false; }
00751
00752 virtual bool OnCameraOff(HGscAction anAction,
00753   const TPlcMediaChannelID& aCamera)
00754 { return false; }
00755
00756 virtual bool OnCameraOn(HGscAction anAction,
00757   const TPlcMediaChannelID& aCamera)
00758 { return false; }
00759
00760 virtual bool OnCameraPumpOff(HGscAction anAction,
00761   const TPlcMediaChannelID& aCamera)
00762 { return false; }
00763
00764 virtual bool OnCameraPumpOn(HGscAction anAction,
00765   const TPlcMediaChannelID& aCamera)
00766 { return false; }
00767
00768 virtual bool OnCameraRAWOutput(HGscAction anAction,
00769   const TPlcMediaChannelID& aCamera,
00770   const char* aOutput)
00771 { return false; }
00772
00773 virtual bool OnCameraSelectCharMode(HGscAction anAction,
00774   const TPlcMediaChannelID& aCamera,
00775   const __int32 aMode)
00776 { return false; }
00777
00778 virtual bool OnCameraSetPrePosText(HGscAction anAction,
00779   const TPlcMediaChannelID& aCamera,
00780   const __int32 aPosition)
00781 { return false; }
00782
00783 virtual bool OnCameraSpecFuncUOff(HGscAction anAction,
00784   const TPlcMediaChannelID& aCamera)
00785 { return false; }
00786
00787 virtual bool OnCameraSpecFuncUOn(HGscAction anAction,
00788   const TPlcMediaChannelID& aCamera)
00789 { return false; }
00790
00791 virtual bool OnCameraSpecFuncVOff(HGscAction anAction,
00792   const TPlcMediaChannelID& aCamera)
00793 { return false; }
00794
00795 virtual bool OnCameraSpecFuncVOn(HGscAction anAction,
00796   const TPlcMediaChannelID& aCamera)
00797 { return false; }
00798
00799 virtual bool OnCameraSpecFuncXOff(HGscAction anAction,
00800   const TPlcMediaChannelID& aCamera)
00801 { return false; }
00802
00803 virtual bool OnCameraSpecFuncXOn(HGscAction anAction,
00804   const TPlcMediaChannelID& aCamera)
00805 { return false; }
00806
00807 virtual bool OnCameraSpecFuncYOff(HGscAction anAction,
00808   const TPlcMediaChannelID& aCamera)
00809 { return false; }
00810
00811 virtual bool OnCameraSpecFuncYOn(HGscAction anAction,
00812   const TPlcMediaChannelID& aCamera)
00813 { return false; }
00814
00815 virtual bool OnCameraStopAll(HGscAction anAction,
00816   const TPlcMediaChannelID& aCamera)
00817 { return false; }
00818
00819 virtual bool OnCameraTextOff(HGscAction anAction,
00820   const TPlcMediaChannelID& aCamera)
00821 { return false; }
00822
00823 virtual bool OnCameraTextOn(HGscAction anAction,
00824   const TPlcMediaChannelID& aCamera)
00825 { return false; }
00826
00827 virtual bool OnCameraTourStart(HGscAction anAction,
00828   const TPlcMediaChannelID& aCamera,
00829   const __int32 aTourID,
00830   const char* aTourName)
00831 { return false; }
00832
00833 virtual bool OnCameraTourStop(HGscAction anAction,
00834   const TPlcMediaChannelID& aCamera)
00835 { return false; }
00836
00837 virtual bool OnCameraVersionOff(HGscAction anAction,
00838   const TPlcMediaChannelID& aCamera)
00839 { return false; }
00840
00841 virtual bool OnCameraVersionOn(HGscAction anAction,
00842   const TPlcMediaChannelID& aCamera)
00843 { return false; }
00844
00845 virtual bool OnCameraWashOff(HGscAction anAction,
00846   const TPlcMediaChannelID& aCamera)
00847 { return false; }
00848
00849 virtual bool OnCameraWashOn(HGscAction anAction,
00850   const TPlcMediaChannelID& aCamera)
00851 { return false; }
00852
00853 virtual bool OnDefaultPosCallUp(HGscAction anAction,
00854   const TPlcMediaChannelID& aCamera)
00855 { return false; }
00856
00857 virtual bool OnDefaultPosClear(HGscAction anAction,
00858   const TPlcMediaChannelID& aCamera)
00859 { return false; }
00860
00861 virtual bool OnDefaultPosSave(HGscAction anAction,
00862   const TPlcMediaChannelID& aCamera)
00863 { return false; }
00864
00865 virtual bool OnFastSpeedOff(HGscAction anAction,
00866   const TPlcMediaChannelID& aCamera)
00867 { return false; }
00868
00869 virtual bool OnFastSpeedOn(HGscAction anAction,
00870   const TPlcMediaChannelID& aCamera)
00871 { return false; }
00872
00873 virtual bool OnFocusFar(HGscAction anAction,
00874   const TPlcMediaChannelID& aCamera,
00875   const __int32 aSpeed)
00876 { return false; }
00877
00878 virtual bool OnFocusNear(HGscAction anAction,
00879   const TPlcMediaChannelID& aCamera,
00880   const __int32 aSpeed)
00881 { return false; }
00882
00883 virtual bool OnFocusStop(HGscAction anAction,
00884   const TPlcMediaChannelID& aCamera)
00885 { return false; }
00886
00887 virtual bool OnIrisClose(HGscAction anAction,
00888   const TPlcMediaChannelID& aCamera)
00889 { return false; }
00890
00891 virtual bool OnIrisOpen(HGscAction anAction,
00892   const TPlcMediaChannelID& aCamera)
00893 { return false; }
00894
00895 virtual bool OnIrisStop(HGscAction anAction,
00896   const TPlcMediaChannelID& aCamera)
00897 { return false; }
00898
00899 virtual bool OnMoveToAbsolutePosition(HGscAction anAction,
00900   const TPlcMediaChannelID& aCamera,
00901   const double& aAlpha,
00902   const double& aBeta,
00903   const double& aSpeedAlpha,
00904   const double& aSpeedBeta)
00905 { return false; }
00906
00907 virtual bool OnMoveToBySpeed(HGscAction anAction,
00908   const TPlcMediaChannelID& aCamera,
00909   const double& aSpeedAlpha,
00910   const double& aSpeedBeta)
00911 { return false; }
00912
00913 virtual bool OnMoveToRelativePosition(HGscAction anAction,
00914   const TPlcMediaChannelID& aCamera,
00915   const double& aAlpha,
00916   const double& aBeta,
00917   const double& aSpeedAlpha,
00918   const double& aSpeedBeta)
00919 { return false; }
00920
00921 virtual bool OnPanAuto(HGscAction anAction,
00922   const TPlcMediaChannelID& aCamera,
00923   const __int32 aModus)
00924 { return false; }
00925
00926 virtual bool OnPanLeft(HGscAction anAction,
00927   const TPlcMediaChannelID& aCamera,
00928   const __int32 aSpeed)
00929 { return false; }
00930
00931 virtual bool OnPanRight(HGscAction anAction,
00932   const TPlcMediaChannelID& aCamera,
00933   const __int32 aSpeed)
00934 { return false; }
00935
00936 virtual bool OnPanStop(HGscAction anAction,
00937   const TPlcMediaChannelID& aCamera)
00938 { return false; }
00939
00940 virtual bool OnPrePosCallUp(HGscAction anAction,
00941   const TPlcMediaChannelID& aCamera,
00942   const __int32 aPosition)
00943 { return false; }
00944
00945 virtual bool OnPrePosClear(HGscAction anAction,
00946   const TPlcMediaChannelID& aCamera,
00947   const __int32 aPosition)
00948 { return false; }
00949
00950 virtual bool OnPrePosSave(HGscAction anAction,
00951   const TPlcMediaChannelID& aCamera,
00952   const __int32 aPosition)
00953 { return false; }
00954
00955 virtual bool OnSetCameraText(HGscAction anAction,
00956   const TPlcMediaChannelID& aCamera,
00957   const char* aText)
00958 { return false; }
00959
00960 virtual bool OnTiltDown(HGscAction anAction,
00961   const TPlcMediaChannelID& aCamera,
00962   const __int32 aSpeed)
00963 { return false; }
00964
00965 virtual bool OnTiltStop(HGscAction anAction,
00966   const TPlcMediaChannelID& aCamera)
00967 { return false; }
00968
00969 virtual bool OnTiltUp(HGscAction anAction,
00970   const TPlcMediaChannelID& aCamera,
00971   const __int32 aSpeed)
00972 { return false; }
00973
00974 virtual bool OnZoomIn(HGscAction anAction,
00975   const TPlcMediaChannelID& aCamera,
00976   const __int32 aSpeed)
00977 { return false; }
00978
00979 virtual bool OnZoomOut(HGscAction anAction,
00980   const TPlcMediaChannelID& aCamera,
00981   const __int32 aSpeed)
00982 { return false; }
00983
00984 virtual bool OnZoomStop(HGscAction anAction,
00985   const TPlcMediaChannelID& aCamera)
00986 { return false; }
00987
00988 //////////////////////////////////////////////////////////////////////////
00989 /// Digital contacts
00990 ///
00991
00992 virtual bool OnCaseClosed(HGscAction anAction)
00993 { return false; }
00994
00995 virtual bool OnCaseOpened(HGscAction anAction)
00996 { return false; }
00997
00998 virtual bool OnDigitalInput(HGscAction anAction,
00999   const TPlcMediaChannelID& aContact,
01000   const DigitalInputState aState)
01001 { return false; }
01002
01003 virtual bool OnIOI43ResetMainboard(HGscAction anAction)
01004 { return false; }
01005
01006 virtual bool OnIOI43Temperature(HGscAction anAction,
01007   const wchar_t* aID,
01008   const __int32 aTemperature)
01009 { return false; }
01010
01011 virtual bool OnIOI43WDActivate(HGscAction anAction)
01012 { return false; }
01013
01014 virtual bool OnIOI43WDDeactivate(HGscAction anAction)
01015 { return false; }
01016
01017 virtual bool OnIOI43WDTrigger(HGscAction anAction)
01018 { return false; }
01019
01020 virtual bool OnKeyPressed(HGscAction anAction,
01021   const SystemKey aKey)
01022 { return false; }
01023
01024 virtual bool OnKeyReleased(HGscAction anAction,
01025   const SystemKey aKey)
01026 { return false; }
01027
01028 virtual bool OnResetMainboard(HGscAction anAction)
01029 { return false; }
01030
01031 virtual bool OnSetDigitalOutput(HGscAction anAction,
01032   const TPlcMediaChannelID& aContact,
01033   const DigitalOutputState aState)
01034 { return false; }
01035
01036 virtual bool OnSetLED(HGscAction anAction,
01037   const SystemLED aLED,
01038   const DigitalOutputState aState)
01039 { return false; }
01040
01041 virtual bool OnSetLEDBlink(HGscAction anAction,
01042   const SystemLED aLED,
01043   const __int32 aLedTimeOnMs,
01044   const __int32 aLedTimeOffMs)
01045 { return false; }
01046
01047 virtual bool OnTemperature(HGscAction anAction,
01048   const IODeviceType aSourceType,
01049   const wchar_t* aID,
01050   const __int32 aTemperature)
01051 { return false; }
01052
01053 virtual bool OnWatchdogActivate(HGscAction anAction)
01054 { return false; }
01055
01056 virtual bool OnWatchdogDeactivate(HGscAction anAction)
01057 { return false; }
01058
01059 virtual bool OnWatchdogTrigger(HGscAction anAction)
01060 { return false; }
01061
01062 //////////////////////////////////////////////////////////////////////////
01063 /// Device information
01064 ///
01065
01066 virtual bool OnDeviceFound(HGscAction anAction,
01067   const char* aType,
01068   const char* aName,
01069   const char* aSerial)
01070 { return false; }
01071
01072 virtual bool OnDeviceNewFirmware(HGscAction anAction,
01073   const char* aType,
01074   const char* aName,
01075   const char* aSerial,
01076   const char* aFirmware)
01077 { return false; }
01078
01079 virtual bool OnDevicePluginError(HGscAction anAction,
01080   const TPlcMediaChannelID& aChannel,
01081   const char* aType,
01082   const char* aSubType,
01083   const char* aName,
01084   const char* aSerial,
01085   const PlcPluginError aErrorClass,
01086   const __int32* aErrorCode,
01087   const char* aDescription)
01088 { return false; }
01089
01090 virtual bool OnDevicePluginState(HGscAction anAction,
01091   const TPlcMediaChannelID& aChannel,
01092   const char* aType,
01093   const char* aSubType,
01094   const char* aName,
01095   const char* aSerial,
01096   const PlcPluginState aState,
01097   const __int32* aInternalState,
01098   const char* aDescription)
01099 { return false; }
01100
01101 virtual bool OnDeviceReattached(HGscAction anAction,
01102   const char* aType,
01103   const char* aName,
01104   const char* aSerial)
01105 { return false; }
01106
01107 virtual bool OnDeviceRemoved(HGscAction anAction,
01108   const char* aType,
01109   const char* aName,
01110   const char* aSerial)
01111 { return false; }
01112
01113 //////////////////////////////////////////////////////////////////////////
01114 /// ATM/ACS
01115 ///
01116
01117 virtual bool OnACSAccessDenied(HGscAction anAction,
01118   const wchar_t* aACSName,
01119   const __int32* aACSNo,
01120   const __int64* aAccount,
01121   const __int64* aBancCode,
01122   const wchar_t* aCardNo,
01123   const TGLibDateTime* aTimeStamp,
01124   const __int32* aReason)
01125 { return false; }
01126
01127 virtual bool OnACSAccessGranted(HGscAction anAction,
01128   const wchar_t* aACSName,
01129   const __int32* aACSNo,
01130   const __int64* aAccount,
01131   const __int64* aBancCode,
01132   const wchar_t* aCardNo,
01133   const TGLibDateTime* aTimeStamp)
01134 { return false; }
01135
01136 virtual bool OnACSRawAnswer(HGscAction anAction,
01137   const wchar_t* aACSName,
01138   const TGLibDateTime& aTimeStamp,
01139   const wchar_t* aACSData)
01140 { return false; }
01141
01142 virtual bool OnACSRawData(HGscAction anAction,
01143   const wchar_t* aACSName,
01144   const TGLibDateTime& aTimeStamp,
01145   const wchar_t* aACSData)
01146 { return false; }
01147
01148 virtual bool OnATMRawAnswer(HGscAction anAction,
01149   const wchar_t* aATMName,
01150   const TGLibDateTime& aTimeStamp,
01151   const wchar_t* aATMData)
01152 { return false; }
01153
01154 virtual bool OnATMRawData(HGscAction anAction,
01155   const wchar_t* aATMName,
01156   const TGLibDateTime& aTimeStamp,
01157   const wchar_t* aATMData)
01158 { return false; }
01159
01160 virtual bool OnATMTransaction(HGscAction anAction,
01161   const wchar_t* aATMName,
01162   const bool aNewTransaction,
01163   const __int32 aPhotostep,
01164   const __int32* aATMNo,
01165   const __int64* aAccount,
01166   const __int64* aBancCode,
01167   const wchar_t* aCardNo,
01168   const __int64* aTAN1,
01169   const __int64* aTAN2,
01170   const TGLibDateTime* aTimeStamp1,
01171   const TGLibDateTime* aTimeStamp2,
01172   const double* aAmount,
01173   const wchar_t* aCurrency)
01174 { return false; }
01175
01176 //////////////////////////////////////////////////////////////////////////
01177 /// Backup actions
01178 ///
01179
01180 virtual bool OnAbortAllAutoBackups(HGscAction anAction)
01181 { return false; }
01182
01183 virtual bool OnAbortAutoBackup(HGscAction anAction,
01184   const TPlcResourceID& aSchedule)
01185 { return false; }
01186
01187 virtual bool OnAutoBackupCapacityMonitoringCapacityWarning(HGscAction anAction,
01188   const ABCapacityWarning aWarning,
01189   const TPlcResourceID& aDestination,
01190   const __int64& aTotalCapacity,
01191   const __int64& aFreeCapacity,
01192   const __int64& aAllocatedByGbf,
01193   const __int32 aPercentFree,
01194   const __int32 aPercentAllocated,
01195   const __int32 aPercentAllocatedByGbf)
01196 { return false; }
01197
01198 virtual bool OnAutoBackupCapacityMonitoringFileAutoDeleted(HGscAction anAction,
01199   const ABCapacityWarning aWarning,
01200   const TPlcResourceID& aDestination,
01201   const __int64& aTotalCapacity,
01202   const __int64& aFreeCapacity,
01203   const __int64& aAllocatedByGbf,
01204   const __int32 aPercentFree,
01205   const __int32 aPercentAllocated,
01206   const __int32 aPercentAllocatedByGbf,
01207   const __int64& aFileSize,
01208   const wchar_t* aFileName)
01209 { return false; }
01210
01211 virtual bool OnAutoBackupCapacityMonitoringOutOfDiskSpace(HGscAction anAction,
01212   const ABCapacityWarning aWarning,
01213   const TPlcResourceID& aDestination,
01214   const __int64& aTotalCapacity,
01215   const __int64& aFreeCapacity,
01216   const __int64& aAllocatedByGbf,
01217   const __int32 aPercentFree,
01218   const __int32 aPercentAllocated,
01219   const __int32 aPercentAllocatedByGbf)
01220 { return false; }
01221
01222 virtual bool OnAutoBackupFileDone(HGscAction anAction,
01223   const TPlcResourceID& aSchedule,
01224   const TGLibDateTime* aStartTime,
01225   const TGLibDateTime& aEffectiveStartTime,
01226   const __int32 aOperationCount,
01227   const bool aTimerStart,
01228   const __int32 aOperationIndex,
01229   const TGLibDateTime& aOperationStartTime,
01230   const TPlcResourceID& aSource,
01231   const TPlcResourceID& aDestination,
01232   const __int64& aFileSizeLimit,
01233   const __int64& aBandWidthLimit,
01234   const __int32 aFileIndex,
01235   const wchar_t* aFileName,
01236   const __int64& aFileSize)
01237 { return false; }
01238
01239 virtual bool OnAutoBackupFileProgress(HGscAction anAction,
01240   const TPlcResourceID& aSchedule,
01241   const TGLibDateTime* aStartTime,
01242   const TGLibDateTime& aEffectiveStartTime,
01243   const __int32 aOperationCount,
01244   const bool aTimerStart,
01245   const __int32 aOperationIndex,
01246   const TGLibDateTime& aOperationStartTime,
01247   const TPlcResourceID& aSource,
01248   const TPlcResourceID& aDestination,
01249   const __int64& aFileSizeLimit,
01250   const __int64& aBandWidthLimit,
01251   const __int32 aFileIndex,
01252   const wchar_t* aFileName,
01253   const __int64& aFileSize)
01254 { return false; }
01255
01256 virtual bool OnAutoBackupFileStarted(HGscAction anAction,
01257   const TPlcResourceID& aSchedule,
01258   const TGLibDateTime* aStartTime,
01259   const TGLibDateTime& aEffectiveStartTime,
01260   const __int32 aOperationCount,
01261   const bool aTimerStart,
01262   const __int32 aOperationIndex,
01263   const TGLibDateTime& aOperationStartTime,
01264   const TPlcResourceID& aSource,
01265   const TPlcResourceID& aDestination,
01266   const __int64& aFileSizeLimit,
01267   const __int64& aBandWidthLimit,
01268   const __int32 aFileIndex,
01269   const wchar_t* aFileName)
01270 { return false; }
01271
01272 virtual bool OnAutoBackupOperationDone(HGscAction anAction,
01273   const TPlcResourceID& aSchedule,
01274   const TGLibDateTime* aStartTime,
01275   const TGLibDateTime& aEffectiveStartTime,
01276   const __int32 aOperationCount,
01277   const bool aTimerStart,
01278   const __int32 aOperationIndex,
01279   const TGLibDateTime& aOperationStartTime,
01280   const TGLibDateTime& aOperationStopTime,
01281   const TPlcResourceID& aSource,
01282   const TPlcResourceID& aDestination,
01283   const __int64& aFileSizeLimit,
01284   const __int64& aBandWidthLimit,
01285   const __int32* aOperationErrorCode)
01286 { return false; }
01287
01288 virtual bool OnAutoBackupOperationStarted(HGscAction anAction,
01289   const TPlcResourceID& aSchedule,
01290   const TGLibDateTime* aStartTime,
01291   const TGLibDateTime& aEffectiveStartTime,
01292   const __int32 aOperationCount,
01293   const bool aTimerStart,
01294   const __int32 aOperationIndex,
01295   const TGLibDateTime& aOperationStartTime,
01296   const TPlcResourceID& aSource,
01297   const TPlcResourceID& aDestination,
01298   const __int64& aFileSizeLimit,
01299   const __int64& aBandWidthLimit)
01300 { return false; }
01301
01302 virtual bool OnAutoBackupScheduleDone(HGscAction anAction,
01303   const TPlcResourceID& aSchedule,
01304   const TGLibDateTime* aStartTime,
01305   const TGLibDateTime& aEffectiveStartTime,
01306   const TGLibDateTime& aStopTime,
01307   const __int32 aOperationCount,
01308   const bool aTimerStart)
01309 { return false; }
01310
01311 virtual bool OnAutoBackupScheduleStarted(HGscAction anAction,
01312   const TPlcResourceID& aSchedule,
01313   const TGLibDateTime* aStartTime,
01314   const TGLibDateTime& aEffectiveStartTime,
01315   const __int32 aOperationCount,
01316   const bool aTimerStart)
01317 { return false; }
01318
01319 virtual bool OnBackupEvent(HGscAction anAction,
01320   const __int64& aEventID,
01321   const TPlcEventTypeID& aTypeID,
01322   const TPlcResourceID& aDestination,
01323   const __int64* aStartHintID,
01324   const __int64* aStopHintID,
01325   const wchar_t* aSubfolder)
01326 { return false; }
01327
01328 virtual bool OnEventBackupDone(HGscAction anAction,
01329   const GUID& aJobID,
01330   const TPlcEventTypeID& aEventTypeID,
01331   const __int64& aEventID,
01332   const TPlcResourceID& aDestination,
01333   const __int64& aFileSizeLimit,
01334   const __int64& aBandWidthLimit,
01335   const TGLibDateTime& aStartTime,
01336   const TGLibDateTime& aStopTime,
01337   const __int32* aOperationErrorCode)
01338 { return false; }
01339
01340 virtual bool OnEventBackupFileDone(HGscAction anAction,
01341   const GUID& aJobID,
01342   const TPlcEventTypeID& aEventTypeID,
01343   const __int64& aEventID,
01344   const TPlcResourceID& aDestination,
01345   const __int64& aFileSizeLimit,
01346   const __int64& aBandWidthLimit,
01347   const TGLibDateTime& aStartTime,
01348   const __int32 aFileIndex,
01349   const wchar_t* aFileName,
01350   const __int64& aFileSize)
01351 { return false; }
01352
01353 virtual bool OnEventBackupFileProgress(HGscAction anAction,
01354   const GUID& aJobID,
01355   const TPlcEventTypeID& aEventTypeID,
01356   const __int64& aEventID,
01357   const TPlcResourceID& aDestination,
01358   const __int64& aFileSizeLimit,
01359   const __int64& aBandWidthLimit,
01360   const TGLibDateTime& aStartTime,
01361   const __int32 aFileIndex,
01362   const wchar_t* aFileName,
01363   const __int64& aFileSize)
01364 { return false; }
01365
01366 virtual bool OnEventBackupFileStarted(HGscAction anAction,
01367   const GUID& aJobID,
01368   const TPlcEventTypeID& aEventTypeID,
01369   const __int64& aEventID,
01370   const TPlcResourceID& aDestination,
01371   const __int64& aFileSizeLimit,
01372   const __int64& aBandWidthLimit,
01373   const TGLibDateTime& aStartTime,
01374   const __int32 aFileIndex,
01375   const wchar_t* aFileName)
01376 { return false; }
01377
01378 virtual bool OnEventBackupStarted(HGscAction anAction,
01379   const GUID& aJobID,
01380   const TPlcEventTypeID& aEventTypeID,
01381   const __int64& aEventID,
01382   const TPlcResourceID& aDestination,
01383   const __int64& aFileSizeLimit,
01384   const __int64& aBandWidthLimit,
01385   const TGLibDateTime& aStartTime)
01386 { return false; }
01387
01388 virtual bool OnStartAutoBackup(HGscAction anAction,
01389   const TPlcResourceID& aSchedule)
01390 { return false; }
01391
01392 //////////////////////////////////////////////////////////////////////////
01393 /// Cash management actions
01394 ///
01395
01396 virtual bool OnSafebagClose(HGscAction anAction,
01397   const __int32 aWorkingPlace,
01398   const TGLibDateTime& aStartTime,
01399   const TGLibDateTime& aStopTime,
01400   const wchar_t* aSafebagNo,
01401   const wchar_t* aSafebagInfo,
01402   const SafebagStep aStepID,
01403   const double* aDebit,
01404   const double* aTotal,
01405   const double* aDifference,
01406   const bool* aHasDifference,
01407   const wchar_t* aNotes,
01408   const wchar_t* aCoins,
01409   const wchar_t* aCheques)
01410 { return false; }
01411
01412 virtual bool OnSafebagData(HGscAction anAction,
01413   const __int32 aWorkingPlace,
01414   const TGLibDateTime& aStartTime,
01415   const wchar_t* aSafebagNo,
01416   const wchar_t* aSafebagInfo,
01417   const SafebagStep aStepID,
01418   const double* aDebit,
01419   const double* aTotal,
01420   const double* aDifference,
01421   const bool* aHasDifference,
01422   const wchar_t* aNotes,
01423   const wchar_t* aCoins,
01424   const wchar_t* aCheques)
01425 { return false; }
01426
01427 virtual bool OnSafebagOpen(HGscAction anAction,
01428   const __int32 aWorkingPlace,
01429   const TGLibDateTime& aStartTime,
01430   const wchar_t* aSafebagNo,
01431   const wchar_t* aSafebagInfo,
01432   const SafebagStep aStepID)
01433 { return false; }
01434
01435 virtual bool OnSafebagPassingOfRiskData(HGscAction anAction,
01436   const __int32 aWorkingPlace,
01437   const TGLibDateTime& aStartTime,
01438   const wchar_t* aSafebagNo,
01439   const wchar_t* aSafebagInfo,
01440   const SafebagStep aStepID,
01441   const __int32 aUserID1,
01442   const __int32 aUserID2,
01443   const __int32* aTourNumber,
01444   const wchar_t* aTargetWorkingPlace,
01445   const wchar_t* aPassingOfRiskType)
01446 { return false; }
01447
01448 virtual bool OnSafebagPassingOfRiskStart(HGscAction anAction,
01449   const __int32 aWorkingPlace,
01450   const TGLibDateTime& aStartTime,
01451   const wchar_t* aSafebagNo,
01452   const wchar_t* aSafebagInfo,
01453   const SafebagStep aStepID,
01454   const __int32 aUserID1,
01455   const __int32 aUserID2,
01456   const __int32* aTourNumber,
01457   const wchar_t* aTargetWorkingPlace,
01458   const wchar_t* aPassingOfRiskType)
01459 { return false; }
01460
01461 virtual bool OnSafebagPassingOfRiskStop(HGscAction anAction,
01462   const __int32 aWorkingPlace,
01463   const TGLibDateTime& aStartTime,
01464   const TGLibDateTime& aStopTime,
01465   const wchar_t* aSafebagNo,
01466   const wchar_t* aSafebagInfo,
01467   const SafebagStep aStepID,
01468   const __int32 aUserID1,
01469   const __int32 aUserID2,
01470   const __int32* aTourNumber,
01471   const wchar_t* aTargetWorkingPlace,
01472   const wchar_t* aPassingOfRiskType)
01473 { return false; }
01474
01475 //////////////////////////////////////////////////////////////////////////
01476 /// Viewer actions
01477 ///
01478
01479 virtual bool OnVCAlarmQueueConfirm(HGscAction anAction,
01480   const TPlcMediaChannelID& aViewer,
01481   const PlcViewerAlarmQueueSelection aSelectionMode)
01482 { return false; }
01483
01484 virtual bool OnVCAlarmQueueConfirmByInstance(HGscAction anAction,
01485   const TPlcMediaChannelID& aViewer,
01486   const __int64& aAlarmID)
01487 { return false; }
01488
01489 virtual bool OnVCAlarmQueueConfirmByType(HGscAction anAction,
01490   const TPlcMediaChannelID& aViewer,
01491   const TPlcEventTypeID& aTypeID,
01492   const PlcViewerAlarmQueueSelection aSelectionMode)
01493 { return false; }
01494
01495 virtual bool OnVCAlarmQueueRemove(HGscAction anAction,
01496   const TPlcMediaChannelID& aViewer,
01497   const PlcViewerAlarmQueueSelection aSelectionMode)
01498 { return false; }
01499
01500 virtual bool OnVCAlarmQueueRemoveByInstance(HGscAction anAction,
01501   const TPlcMediaChannelID& aViewer,
01502   const __int64& aAlarmID)
01503 { return false; }
01504
01505 virtual bool OnVCAlarmQueueRemoveByType(HGscAction anAction,
01506   const TPlcMediaChannelID& aViewer,
01507   const TPlcEventTypeID& aTypeID,
01508   const PlcViewerAlarmQueueSelection aSelectionMode)
01509 { return false; }
01510
01511 virtual bool OnVCAlarmQueueSelect(HGscAction anAction,
01512   const TPlcMediaChannelID& aViewer,
01513   const PlcViewerAlarmQueueSelection aSelectionMode)
01514 { return false; }
01515
01516 virtual bool OnVCAlarmQueueSelectByInstance(HGscAction anAction,
01517   const TPlcMediaChannelID& aViewer,
01518   const __int64& aAlarmID)
01519 { return false; }
01520
01521 virtual bool OnVCAlarmQueueSelectByType(HGscAction anAction,
01522   const TPlcMediaChannelID& aViewer,
01523   const TPlcEventTypeID& aTypeID,
01524   const PlcViewerAlarmQueueSelection aSelectionMode)
01525 { return false; }
01526
01527 virtual bool OnVCChangeSceneByName(HGscAction anAction,
01528   const TPlcMediaChannelID& aViewer,
01529   const wchar_t* aScene)
01530 { return false; }
01531
01532 virtual bool OnVCClearSceneByName(HGscAction anAction,
01533   const TPlcMediaChannelID& aViewer,
01534   const wchar_t* aScene)
01535 { return false; }
01536
01537 virtual bool OnVCFullMode(HGscAction anAction,
01538   const TPlcMediaChannelID& aViewer,
01539   const bool aFullMode,
01540   const bool aSensitiveAreaEnabled)
01541 { return false; }
01542
01543 virtual bool OnVCSetAudioLevel(HGscAction anAction,
01544   const TPlcMediaChannelID& aViewer,
01545   const __int32 aAudioLevel)
01546 { return false; }
01547
01548 virtual bool OnVCShowViewerText(HGscAction anAction,
01549   const TPlcMediaChannelID& aViewer,
01550   const bool aShowText)
01551 { return false; }
01552
01553 virtual bool OnVCStretchMode(HGscAction anAction,
01554   const TPlcMediaChannelID& aViewer,
01555   const bool aStretchMode)
01556 { return false; }
01557
01558 virtual bool OnViewerChangeScene(HGscAction anAction,
01559   const TPlcMediaChannelID& aViewer)
01560 { return false; }
01561
01562 virtual bool OnViewerClear(HGscAction anAction,
01563   const TPlcMediaChannelID& aViewer)
01564 { return false; }
01565
01566 virtual bool OnViewerClearScene(HGscAction anAction,
01567   const TPlcMediaChannelID& aViewer)
01568 { return false; }
01569
01570 virtual bool OnViewerClearTextOutput(HGscAction anAction,
01571   const TPlcMediaChannelID& aViewer)
01572 { return false; }
01573
01574 virtual bool OnViewerConnect(HGscAction anAction,
01575   const TPlcMediaChannelID& aViewer,
01576   const TPlcMediaChannelID& aChannel,
01577   const PlcViewerPlayMode aPlayMode)
01578 { return false; }
01579
01580 virtual bool OnViewerConnectLive(HGscAction anAction,
01581   const TPlcMediaChannelID& aViewer,
01582   const TPlcMediaChannelID& aChannel)
01583 { return false; }
01584
01585 virtual bool OnViewerExportPicture(HGscAction anAction,
01586   const TPlcMediaChannelID& aViewer,
01587   const wchar_t* aFilePath)
01588 { return false; }
01589
01590 virtual bool OnViewerJumpByTime(HGscAction anAction,
01591   const TPlcMediaChannelID& aViewer,
01592   const TPlcMediaChannelID& aChannel,
01593   const PlcViewerPlayMode aPlayMode,
01594   const __int32 aTimeInSec)
01595 { return false; }
01596
01597 virtual bool OnViewerMaximize(HGscAction anAction,
01598   const TPlcMediaChannelID& aViewer,
01599   const bool aMaximize)
01600 { return false; }
01601
01602 virtual bool OnViewerPlayFromTime(HGscAction anAction,
01603   const TPlcMediaChannelID& aViewer,
01604   const TPlcMediaChannelID& aChannel,
01605   const PlcViewerPlayMode aPlayMode,
01606   const TGLibDateTime& aTime)
01607 { return false; }
01608
01609 virtual bool OnViewerPrintPicture(HGscAction anAction,
01610   const TPlcMediaChannelID& aViewer)
01611 { return false; }
01612
01613 virtual bool OnViewerSelect(HGscAction anAction,
01614   const TPlcMediaChannelID& aViewer)
01615 { return false; }
01616
01617 virtual bool OnViewerSetPlayMode(HGscAction anAction,
01618   const TPlcMediaChannelID& aViewer,
01619   const PlcViewerPlayMode aPlayMode,
01620   const __int32 aPlaySpeed)
01621 { return false; }
01622
01623 virtual bool OnViewerShowAlarmByInstance(HGscAction anAction,
01624   const TPlcMediaChannelID& aViewer,
01625   const __int64& aAlarmID,
01626   const PlcViewerAlarmPlayMode aPlayMode)
01627 { return false; }
01628
01629 virtual bool OnViewerShowAlarmByKey(HGscAction anAction,
01630   const TPlcMediaChannelID& aViewer,
01631   const __int64& aForeignKey,
01632   const PlcViewerAlarmPlayMode aPlayMode)
01633 { return false; }
01634
01635 virtual bool OnViewerShowAlarmByType(HGscAction anAction,
01636   const TPlcMediaChannelID& aViewer,
01637   const TPlcEventTypeID& aTypeID,
01638   const __int64* aForeignKey,
01639   const PlcViewerAlarmPlayMode aPlayMode)
01640 { return false; }
01641
01642 virtual bool OnViewerSyncAudioAndVideo(HGscAction anAction,
01643   const TPlcMediaChannelID& aViewer,
01644   const bool aEnableSync)
01645 { return false; }
01646
01647 virtual bool OnViewerTextOutput(HGscAction anAction,
01648   const TPlcMediaChannelID& aViewer,
01649   const wchar_t* aText)
01650 { return false; }
01651
01652 //////////////////////////////////////////////////////////////////////////
01653 /// Viewer notifications
01654 ///
01655
01656 virtual bool OnImageExportNotification(HGscAction anAction,
01657   const wchar_t* aUser,
01658   const wchar_t* aDestination,
01659   const PlcImageExportType aDestinationType,
01660   const TGLibDateTime& aTimeStamp,
01661   const TGLibDateTime* aTimeEnd,
01662   const wchar_t* aChannels,
01663   const wchar_t* aClientHost,
01664   const PlcClientType* aClientType,
01665   const wchar_t* aClientAccount)
01666 { return false; }
01667
01668 virtual bool OnSceneStoreModification(HGscAction anAction,
01669   const TPlcMediaChannelID& aViewer,
01670   const GUID& aSceneStoreID,
01671   const wchar_t* aSceneStoreName,
01672   const TGLibDateTime& aTimeStamp,
01673   const PlcSceneStoreModificationType aModificationType,
01674   const wchar_t* aUser,
01675   const wchar_t* aClientHost,
01676   const PlcClientType* aClientType,
01677   const wchar_t* aClientAccount)
01678 { return false; }
01679
01680 virtual bool OnVCAlarmQueueNotification(HGscAction anAction,
01681   const TPlcMediaChannelID& aViewer,
01682   const PlcViewerAlarmState aNotification,
01683   const __int64& aAlarmID,
01684   const TPlcEventTypeID& aTypeID,
01685   const wchar_t* aClientHost,
01686   const PlcClientType* aClientType,
01687   const wchar_t* aClientAccount)
01688 { return false; }
01689
01690 virtual bool OnVCSceneChanged(HGscAction anAction,
01691   const TPlcMediaChannelID& aViewer,
01692   const wchar_t* aScene)
01693 { return false; }
01694
01695 virtual bool OnViewerCleared(HGscAction anAction,
01696   const TPlcMediaChannelID& aViewer,
01697   const wchar_t* aClientHost,
01698   const PlcClientType* aClientType,
01699   const wchar_t* aClientAccount)
01700 { return false; }
01701
01702 virtual bool OnViewerConnected(HGscAction anAction,
01703   const TPlcMediaChannelID& aViewer,
01704   const TPlcMediaChannelID& aChannel,
01705   const PlcViewerPlayMode aPlayMode,
01706   const wchar_t* aClientHost,
01707   const PlcClientType* aClientType,
01708   const wchar_t* aClientAccount)
01709 { return false; }
01710
01711 virtual bool OnViewerPlayModeChanged(HGscAction anAction,
01712   const TPlcMediaChannelID& aViewer,
01713   const TPlcMediaChannelID& aChannel,
01714   const PlcViewerPlayMode aPlayMode,
01715   const TGLibDateTime* aChannelTime,
01716   const wchar_t* aClientHost,
01717   const PlcClientType* aClientType,
01718   const wchar_t* aClientAccount)
01719 { return false; }
01720
01721 virtual bool OnViewerSelectionChanged(HGscAction anAction,
01722   const TPlcMediaChannelID& aViewer,
01723   const TPlcMediaChannelID& aChannel,
01724   const PlcViewerPlayMode aPlayMode,
01725   const wchar_t* aClientHost,
01726   const PlcClientType* aClientType,
01727   const wchar_t* aClientAccount)
01728 { return false; }
01729
01730 //////////////////////////////////////////////////////////////////////////
01731 /// POS
01732 ///
01733
01734 virtual bool OnBarcodeData(HGscAction anAction,
01735   const wchar_t* aReaderName,
01736   const TGLibDateTime& aTimeStamp,
01737   const wchar_t* aBarcode)
01738 { return false; }
01739
01740 virtual bool OnFillingPumpStatus(HGscAction anAction,
01741   const wchar_t* aTerminalName,
01742   const TGLibDateTime& aTimeStamp,
01743   const __int32 aPumpNo,
01744   const PlcPumpStatus aStatus,
01745   const double* aAmount,
01746   const double* aPrice,
01747   const wchar_t* aDetails)
01748 { return false; }
01749
01750 virtual bool OnInterfaceRawAnswer(HGscAction anAction,
01751   const wchar_t* aInterfaceName,
01752   const TGLibDateTime& aTimeStamp,
01753   const wchar_t* aData)
01754 { return false; }
01755
01756 virtual bool OnInterfaceRawData(HGscAction anAction,
01757   const wchar_t* aInterfaceName,
01758   const TGLibDateTime& aTimeStamp,
01759   const wchar_t* aData)
01760 { return false; }
01761
01762 virtual bool OnPOSData(HGscAction anAction,
01763   const wchar_t* aPOSName,
01764   const TGLibDateTime& aTimeStamp,
01765   const wchar_t* aArticle,
01766   const double* aPrice,
01767   const __int32* aUnits,
01768   const double* aPricePerUnit,
01769   const wchar_t* aLine1,
01770   const wchar_t* aLine2,
01771   const wchar_t* aLine3,
01772   const wchar_t* aLine4,
01773   const wchar_t* aLine5)
01774 { return false; }
01775
01776 virtual bool OnPOSStatus(HGscAction anAction,
01777   const wchar_t* aPOSName,
01778   const TGLibDateTime& aTimeStamp,
01779   const PlcPOSStatus aStatus,
01780   const wchar_t* aDetails)
01781 { return false; }
01782
01783 virtual bool OnTerminalArticleData(HGscAction anAction,
01784   const wchar_t* aTerminalName,
01785   const TGLibDateTime& aTimeStamp,
01786   const __int32 aCashierStation,
01787   const __int32* aPumpNo,
01788   const bool aAlarmStatus,
01789   const double* aAmount,
01790   const double* aPrice,
01791   const wchar_t* aDetails)
01792 { return false; }
01793
01794 virtual bool OnTerminalPaymentData(HGscAction anAction,
01795   const wchar_t* aTerminalName,
01796   const TGLibDateTime& aTimeStamp,
01797   const __int32 aCashierStation,
01798   const __int32* aPumpNo,
01799   const bool aAlarmStatus,
01800   const double* aAmount,
01801   const double* aPrice,
01802   const wchar_t* aDetails)
01803 { return false; }
01804
01805 //////////////////////////////////////////////////////////////////////////
01806 /// Remote export
01807 ///
01808
01809 virtual bool OnCancelExport(HGscAction anAction,
01810   const GUID& aExportID,
01811   const PlcExportAbort aAbortFlag)
01812 { return false; }
01813
01814 virtual bool OnExportFinished(HGscAction anAction,
01815   const GUID& aExportID,
01816   const PlcExportSuccess aSuccess)
01817 { return false; }
01818
01819 virtual bool OnExportProgress(HGscAction anAction,
01820   const GUID& aExportID,
01821   const __int32 aProgress)
01822 { return false; }
01823
01824 virtual bool OnInitializeRemoteExport(HGscAction anAction,
01825   const TPlcMediaChannelID& aViewer,
01826   const GUID& aDevice)
01827 { return false; }
01828
01829 virtual bool OnSetExportMarker(HGscAction anAction,
01830   const TPlcMediaChannelID& aViewer,
01831   const PlcExportMarker aMarker)
01832 { return false; }
01833
01834 virtual bool OnStartRemoteExport(HGscAction anAction,
01835   const GUID& aExportID,
01836   const GUID& aDevice,
01837   const PlcBackupFormat aBackupFormat,
01838   const TPlcMediaChannelID& aChannel,
01839   const TGLibDateTime& aSelectionBegin,
01840   const TGLibDateTime& aSelectionEnd,
01841   const wchar_t* aJobID)
01842 { return false; }
01843
01844 virtual bool OnStartSceneStore(HGscAction anAction,
01845   const GUID& aSceneStoreID,
01846   const wchar_t* aCutList,
01847   const __int64& aPreHistoryLength,
01848   const __int64& aRecordingLength)
01849 { return false; }
01850
01851 //////////////////////////////////////////////////////////////////////////
01852 /// SKIDATA
01853 ///
01854
01855 virtual bool OnSkidataControl(HGscAction anAction,
01856   const wchar_t* aInterfaceName,
01857   const PlcSkidataControl aData)
01858 { return false; }
01859
01860 virtual bool OnSkidataDeviceEvent(HGscAction anAction,
01861   const wchar_t* aInterfaceName,
01862   const __int32 aDeviceID,
01863   const __int32 aEventCode)
01864 { return false; }
01865
01866 virtual bool OnSkidataEntry(HGscAction anAction,
01867   const wchar_t* aInterfaceName,
01868   const PlcSkidataMsgCodeEntry aMessageCode,
01869   const wchar_t* aTranscactionID,
01870   const __int32 aCarParkNo,
01871   const __int32 aDeviceID)
01872 { return false; }
01873
01874 virtual bool OnSkidataExit(HGscAction anAction,
01875   const wchar_t* aInterfaceName,
01876   const PlcSkidataMsgCodeExit aMessageCode,
01877   const wchar_t* aTranscactionID,
01878   const __int32 aCarParkNo,
01879   const __int32 aDeviceID)
01880 { return false; }
01881
01882 virtual bool OnSkidataTransaction(HGscAction anAction,
01883   const wchar_t* aInterfaceName,
01884   const PlcSkidataMsgCodeTransaction aMessageCode,
01885   const wchar_t* aTranscactionID,
01886   const __int32 aCarParkNo,
01887   const __int32 aDeviceID)
01888 { return false; }
01889
01890 //////////////////////////////////////////////////////////////////////////
01891 /// LPS
01892 ///
01893
01894 virtual bool OnLPSPositionData(HGscAction anAction,
01895   const __int32 aTagID,
01896   const wchar_t* aScannerID,
01897   const __int64& aX,
01898   const __int64& aY,
01899   const __int64* aZ,
01900   const double* aLatitude,
01901   const double* aLongitude,
01902   const __int32 aAreaID,
01903   const __int32* aCellID,
01904   const PlcLpsStatus aStatus,
01905   const TGLibDateTime* aTimeStamp,
01906   const wchar_t* aData,
01907   const wchar_t* aAreaName)
01908 { return false; }
01909
01910 virtual bool OnLPSQueryPosition(HGscAction anAction,
01911   const __int32 aTagID,
01912   const wchar_t* aScannerID,
01913   const wchar_t* aData)
01914 { return false; }
01915
01916 //////////////////////////////////////////////////////////////////////////
01917 /// Supply chain security
01918 ///
01919
01920 virtual bool OnGSCSVehicleAccessDenied(HGscAction anAction,
01921   const __int32 aSequenceID,
01922   const wchar_t* aPlateNo,
01923   const TGLibDateTime& aTimeStamp,
01924   const wchar_t* aCompanyCategory,
01925   const wchar_t* aCompanyName,
01926   const wchar_t* aReason,
01927   const wchar_t* aTrafficLane,
01928   const TPlcMediaChannelID* aChannel,
01929   const TrafficDirection* aDirection)
01930 { return false; }
01931
01932 virtual bool OnGSCSVehicleAccessExpired(HGscAction anAction,
01933   const __int32 aSequenceID,
01934   const wchar_t* aPlateNo,
01935   const TGLibDateTime& aTimeStamp,
01936   const TGLibDateTime& aExpiringTime,
01937   const wchar_t* aCompanyCategory,
01938   const wchar_t* aCompanyName,
01939   const wchar_t* aReason,
01940   const wchar_t* aTrafficLane,
01941   const TPlcMediaChannelID* aChannel,
01942   const TrafficDirection* aDirection)
01943 { return false; }
01944
01945 virtual bool OnGSCSVehicleAccessGranted(HGscAction anAction,
01946   const __int32 aSequenceID,
01947   const wchar_t* aPlateNo,
01948   const TGLibDateTime& aTimeStamp,
01949   const wchar_t* aCompanyCategory,
01950   const wchar_t* aCompanyName,
01951   const wchar_t* aReason,
01952   const wchar_t* aTrafficLane,
01953   const TPlcMediaChannelID* aChannel,
01954   const TrafficDirection* aDirection)
01955 { return false; }
01956
01957 virtual bool OnGSCSVehicleAccessPending(HGscAction anAction,
01958   const __int32 aSequenceID,
01959   const wchar_t* aPlateNo,
01960   const TGLibDateTime& aTimeStamp,
01961   const wchar_t* aCompanyCategory,
01962   const wchar_t* aCompanyName,
01963   const wchar_t* aReason,
01964   const wchar_t* aTrafficLane,
01965   const TPlcMediaChannelID* aChannel,
01966   const TrafficDirection* aDirection)
01967 { return false; }
01968
01969 virtual bool OnLogBarcodeData(HGscAction anAction,
01970   const wchar_t* aBarcode,
01971   const __int64* aHash,
01972   const wchar_t* aScanner,
01973   const __int64* aAreaID,
01974   const wchar_t* aAreaName,
01975   const TPlcMediaChannelID* aChannel,
01976   const TGLibDateTime* aTimeStamp,
01977   const wchar_t* aOrder,
01978   const wchar_t* aShipment,
01979   const wchar_t* aItem)
01980 { return false; }
01981
01982 virtual bool OnLogBarcodeDataLPS(HGscAction anAction,
01983   const wchar_t* aBarcode,
01984   const __int64* aHash,
01985   const wchar_t* aScanner,
01986   const __int64* aAreaID,
01987   const wchar_t* aAreaName,
01988   const TPlcMediaChannelID* aChannel,
01989   const TGLibDateTime* aTimeStamp,
01990   const double* aX,
01991   const double* aY,
01992   const double* aZ,
01993   const __int32* aLpsTagID,
01994   const PlcLpsStatus* aLpsStatus,
01995   const __int32* aLpsCellID,
01996   const __int32* aLpsAreaID,
01997   const __int32* aUserParam,
01998   const wchar_t* aOrder,
01999   const wchar_t* aShipment,
02000   const wchar_t* aItem)
02001 { return false; }
02002
02003 virtual bool OnLogNPRRecognition(HGscAction anAction,
02004   const wchar_t* aPlateNo,
02005   const __int64* aHash,
02006   const wchar_t* aCountry,
02007   const TPlcMediaChannelID* aChannel,
02008   const TGLibDateTime* aTimeStamp,
02009   const PlcNPRRestriction* aRestriction,
02010   const wchar_t* aCategory)
02011 { return false; }
02012
02013 //////////////////////////////////////////////////////////////////////////
02014 /// Lenel
02015 ///
02016
02017 virtual bool OnLenelAccessEvent(HGscAction anAction,
02018   const LenelEventID* aID,
02019   const wchar_t* aPanel,
02020   const wchar_t* aDevice,
02021   const __int32* aSecondaryDevice,
02022   const __int64* aCardNumber,
02023   const LenelAccessResult* aAccessResult,
02024   const LenelEventType* aType,
02025   const __int32* aSubType,
02026   const wchar_t* aDescription,
02027   const __int32* aSerialNumber,
02028   const TGLibDateTime* aTimeStamp,
02029   const __int32* aAreaEnteredID,
02030   const __int32* aAreaExitedID,
02031   const wchar_t* aAssetID,
02032   const bool* aCardholderEntered,
02033   const bool* aDuress,
02034   const __int32* aElevatorFloor,
02035   const __int32* aFacilityCode,
02036   const bool* aIsReadableCard,
02037   const __int32* aIssueCode,
02038   const wchar_t* aCommServerHostName,
02039   const wchar_t* aEventText)
02040 { return false; }
02041
02042 virtual bool OnLenelFireEvent(HGscAction anAction,
02043   const LenelEventID* aID,
02044   const wchar_t* aPanel,
02045   const wchar_t* aDevice,
02046   const __int32* aSecondaryDevice,
02047   const __int32* aTroubleCode,
02048   const LenelEventType* aType,
02049   const __int32* aSubType,
02050   const wchar_t* aDescription,
02051   const __int32* aSerialNumber,
02052   const TGLibDateTime* aTimeStamp,
02053   const wchar_t* aCommServerHostName,
02054   const wchar_t* aEventText)
02055 { return false; }
02056
02057 virtual bool OnLenelIntercomEvent(HGscAction anAction,
02058   const LenelEventID* aID,
02059   const wchar_t* aPanel,
02060   const wchar_t* aDevice,
02061   const __int32* aSecondaryDevice,
02062   const __int32* aIntercomData,
02063   const __int32* aLineNumber,
02064   const LenelEventType* aType,
02065   const __int32* aSubType,
02066   const wchar_t* aDescription,
02067   const __int32* aSerialNumber,
02068   const TGLibDateTime* aTimeStamp,
02069   const wchar_t* aCommServerHostName,
02070   const wchar_t* aEventText)
02071 { return false; }
02072
02073 virtual bool OnLenelRawData(HGscAction anAction,
02074   const TGLibDateTime& aTimeStamp,
02075   const wchar_t* aLenelData)
02076 { return false; }
02077
02078 virtual bool OnLenelRefreshNames(HGscAction anAction)
02079 { return false; }
02080
02081 virtual bool OnLenelSecurityEvent(HGscAction anAction,
02082   const LenelEventID* aID,
02083   const wchar_t* aPanel,
02084   const wchar_t* aDevice,
02085   const __int32* aSecondaryDevice,
02086   const LenelEventType* aType,
02087   const __int32* aSubType,
02088   const wchar_t* aDescription,
02089   const __int32* aSerialNumber,
02090   const TGLibDateTime* aTimeStamp,
02091   const wchar_t* aCommServerHostName,
02092   const wchar_t* aEventText)
02093 { return false; }
02094
02095 virtual bool OnLenelVideoEvent(HGscAction anAction,
02096   const LenelEventID* aID,
02097   const wchar_t* aPanel,
02098   const wchar_t* aDevice,
02099   const __int32* aSecondaryDevice,
02100   const __int32* aChannel,
02101   const LenelEventType* aType,
02102   const __int32* aSubType,
02103   const wchar_t* aDescription,
02104   const __int32* aSerialNumber,
02105   const TGLibDateTime* aTimeStamp,
02106   const TGLibDateTime* aStartTime,
02107   const TGLibDateTime* aEndTime,
02108   const wchar_t* aCommServerHostName,
02109   const wchar_t* aEventText)
02110 { return false; }
02111
02112 //////////////////////////////////////////////////////////////////////////
02113 /// Imex
02114 ///
02115
02116 virtual bool OnImexCapacityFileAutoDeleted(HGscAction anAction,
02117   const ABCapacityWarning aWarning,
02118   const TPlcResourceID& aDestination,
02119   const __int64& aTotalCapacity,
02120   const __int64& aFreeCapacity,
02121   const __int64& aAllocatedByImageFile,
02122   const __int32 aPercentFree,
02123   const __int32 aPercentAllocated,
02124   const __int32 aPercentAllocatedByImageFile,
02125   const __int64& aTotalFileSize,
02126   const __int32 aNumberOfFiles)
02127 { return false; }
02128
02129 virtual bool OnImexCapacityOutOfDiskSpace(HGscAction anAction,
02130   const ABCapacityWarning aWarning,
02131   const TPlcResourceID& aDestination,
02132   const __int64& aTotalCapacity,
02133   const __int64& aFreeCapacity,
02134   const __int64& aAllocatedByImageFile,
02135   const __int32 aPercentFree,
02136   const __int32 aPercentAllocated,
02137   const __int32 aPercentAllocatedByImageFile)
02138 { return false; }
02139
02140 virtual bool OnImexCapacityWarning(HGscAction anAction,
02141   const ABCapacityWarning aWarning,
02142   const TPlcResourceID& aDestination,
02143   const __int64& aTotalCapacity,
02144   const __int64& aFreeCapacity,
02145   const __int64& aAllocatedByImageFile,
02146   const __int32 aPercentFree,
02147   const __int32 aPercentAllocated,
02148   const __int32 aPercentAllocatedByImageFile)
02149 { return false; }
02150
02151 virtual bool OnImexExportEventImage(HGscAction anAction,
02152   const __int64& aEventID,
02153   const TPlcEventTypeID& aTypeID,
02154   const TPlcResourceID* aDestination,
02155   const wchar_t* aFilePath)
02156 { return false; }
02157
02158 virtual bool OnImexExportImageFromDB(HGscAction anAction,
02159   const TPlcMediaChannelID& aChannel,
02160   const TPlcResourceID* aDestination,
02161   const wchar_t* aFilePath,
02162   const TGLibDateTime* aPictureTime)
02163 { return false; }
02164
02165 virtual bool OnImexExportImageFromLiveStream(HGscAction anAction,
02166   const TPlcMediaChannelID& aChannel,
02167   const TPlcResourceID* aDestination,
02168   const wchar_t* aFilePath)
02169 { return false; }
02170
02171 //////////////////////////////////////////////////////////////////////////
02172 /// Perimeter protection
02173 ///
02174
02175 virtual bool OnPPDeviceAlarm(HGscAction anAction,
02176   const wchar_t* aInterfaceID,
02177   const __int32 aDeviceAddress,
02178   const PPSensorKind aSensor,
02179   const PPAlarmState aState)
02180 { return false; }
02181
02182 virtual bool OnPPDeviceInput(HGscAction anAction,
02183   const wchar_t* aInterfaceID,
02184   const __int32 aDeviceAddress,
02185   const __int32 aInput,
02186   const PPAlarmState aState)
02187 { return false; }
02188
02189 virtual bool OnPPDeviceOffline(HGscAction anAction,
02190   const wchar_t* aInterfaceID,
02191   const __int32 aDeviceAddress)
02192 { return false; }
02193
02194 virtual bool OnPPDeviceOnline(HGscAction anAction,
02195   const wchar_t* aInterfaceID,
02196   const __int32 aDeviceAddress)
02197 { return false; }
02198
02199 virtual bool OnPPInterfaceOffline(HGscAction anAction,
02200   const wchar_t* aInterfaceID)
02201 { return false; }
02202
02203 virtual bool OnPPInterfaceOnline(HGscAction anAction,
02204   const wchar_t* aInterfaceID)
02205 { return false; }
02206
02207 virtual bool OnPPQueryInterface(HGscAction anAction,
02208   const wchar_t* aInterfaceID)
02209 { return false; }
02210
02211 virtual bool OnPPSetDeviceOutput(HGscAction anAction,
02212   const wchar_t* aInterfaceID,
02213   const __int32 aDeviceAddress,
02214   const __int32 aOutput,
02215   const PPAlarmState aState)
02216 { return false; }
02217
02218 virtual bool OnPPSubcellAlarm(HGscAction anAction,
02219   const wchar_t* aInterfaceID,
02220   const __int32 aDeviceAddress,
02221   const PPCableKind aCable,
02222   const __int32 aSubcell,
02223   const PPAlarmState aState)
02224 { return false; }
02225
02226 virtual bool OnPPZoneAlarm(HGscAction anAction,
02227   const wchar_t* aZoneID,
02228   const wchar_t* aInterfaceID,
02229   const __int32 aDeviceAddress,
02230   const PPCableKind* aCable,
02231   const __int32* aSubcell,
02232   const PPAlarmState aState)
02233 { return false; }
02234
02235 };
02236
02237 /// \}
02238
02239 #ifdef __cplusplus
02240 };
02241 #endif
02242
02243 #endif


GSC actions: GscActionsTypes.h Source File

  • File List
  • File Members

GscActionsTypes.h

Go to the documentation of this file.
00001
00002 ///
00003 ///  @file   GscActionsTypes.h
00004 ///  @brief  Types used by GscActions and GscActionsDlgs DLLs.
00005 ///
00006 ///  Copyright (c) 2004 - 2010 Geutebrueck GmbH.  All rights reserved.
00007 ///
00008 ///  This file is part of the GEVISCOPE SDK.
00009 ///
00010 ///  This software is provided "as is" without express or implied warranty,
00011 ///  and with no claim as to its suitability for any purpose.
00012 ///
00013
00014 #ifndef GscActionsTypesH
00015 #define GscActionsTypesH
00016
00017 #include "GLibDateTime.h"
00018
00019 #ifdef __cplusplus
00020 namespace GscPLC
00021 {
00022   using namespace GLib;
00023 #endif
00024
00025   /////////////////////////////////////////////////////////
00026   /// Basic types and definitions
00027   /////////////////////////////////////////////////////////
00028
00029   /// \addtogroup GscPlcBasicTypes
00030   /// \{
00031
00032   /// Disable resource update callback
00033   const unsigned __int32 FlagDisableResourceUpdate       = 0x00000001;
00034
00035   /// Disable storing internal data in event data struct
00036   const unsigned __int32 FlagDisableInternalInEventData  = 0x00000002;
00037
00038   ///
00039   /// Available message classes
00040
00041   enum GscMessageClass
00042   {
00043     mk_Action              = 1,          ///< action
00044     mk_MatchAction         = 2,          ///< match action
00045     mk_Unknown             = 0x7fffffff
00046   };
00047
00048   ///
00049   /// Available action classes
00050
00051   enum GscActionClass
00052   {
00053     ak_System              = 0,          ///< System actions
00054     ak_Video               = 1,          ///< Video control
00055     ak_Audio               = 2,          ///< Audio control
00056     ak_CameraControl       = 3,          ///< Camera control
00057     ak_DigitalContacts     = 4,          ///< Digital contacts
00058     ak_Device              = 5,          ///< Device information
00059     ak_ATM                 = 6,          ///< ATM/ACS
00060     ak_Backup              = 7,          ///< Backup actions
00061     ak_CashManagement      = 8,          ///< Cash management actions
00062     ak_Viewer              = 9,          ///< Viewer actions
00063     ak_ViewerNotification  = 10,          ///< Viewer notifications
00064     ak_POS                 = 11,          ///< POS
00065     ak_RemoteExport        = 12,          ///< Remote export
00066     ak_SkiData             = 13,          ///< SKIDATA
00067     ak_LPS                 = 14,          ///< LPS
00068     ak_Logistic            = 15,          ///< Supply chain security
00069     ak_Lenel               = 16,          ///< Lenel
00070     ak_Imex                = 17,          ///< Imex
00071     ak_PP                  = 18,          ///< Perimeter protection
00072     ak_Unknown             = 0x7fffffff
00073   };
00074
00075   ///
00076   /// Available action codes
00077
00078   enum GscActionCode
00079   {
00080     ac_SystemStarted       = 1,          ///< System started
00081     ac_SystemTerminating   = 2,          ///< System terminating
00082     ac_UserLogin           = 3,          ///< User login
00083     ac_UserLoginFailed     = 4,          ///< User login failed
00084     ac_UserLogout          = 5,          ///< User logout
00085     ac_SystemSettingsChanged = 6,        ///< System settings changed
00086     ac_LiveCheck           = 7,          ///< Live check
00087     ac_CustomAction        = 8,          ///< Custom action
00088     ac_DatabaseStarted     = 9,          ///< Database started
00089     ac_DeviceFound         = 10,         ///< Device found
00090     ac_DeviceRemoved       = 11,         ///< Device removed
00091     ac_DeviceNewFirmware   = 12,         ///< New firmware received
00092     ac_DeviceReattached    = 13,         ///< Device reattached
00093     ac_DevicePluginError   = 14,         ///< Device plugin error
00094     ac_DevicePluginState   = 15,         ///< Device plugin state
00095     ac_SetupUploadProgress = 16,         ///< Setup upload progress
00096     ac_SetupChanged        = 17,         ///< Setup changed
00097     ac_FRCNotification     = 19,         ///< FRC notification
00098     ac_SensorAudioAlarm    = 20,         ///< Sensor audio alarm
00099     ac_ABCConnect          = 21,         ///< ABC connect
00100     ac_ABCDisconnect       = 22,         ///< ABC disconnect
00101     ac_ABCPlayFile         = 23,         ///< ABC play file
00102     ac_SetClock            = 25,         ///< Set clock
00103     ac_DigitalInput        = 30,         ///< Digital input
00104     ac_SetDigitalOutput    = 31,         ///< Set digital output
00105     ac_SetLED              = 32,         ///< Set system LED
00106     ac_SetLEDBlink         = 33,         ///< Set system LED to blink
00107     ac_KeyPressed          = 35,         ///< Key pressed
00108     ac_KeyReleased         = 36,         ///< Key released
00109     ac_RedundantPowerFailure = 37,       ///< Redundant power failure
00110     ac_RedundantPowerOk    = 38,         ///< Redundant power ok
00111     ac_VideoSyncDetected   = 40,         ///< Video sync detected
00112     ac_VideoSyncFailed     = 41,         ///< Video sync failed
00113     ac_ChangeADParameterSet = 42,        ///< Change AD parameter set
00114     ac_ChangeVMDParameterSet = 43,       ///< Change VMD parameter set
00115     ac_ChangeCPAParameterSet = 44,       ///< Change CPA parameter set
00116     ac_VideoSourceChanged  = 45,         ///< Video source has changed
00117     ac_VideoContrastDetected = 46,       ///< Video contrast detected
00118     ac_VideoContrastFailed = 47,         ///< Video contrast failed
00119     ac_MakeCPAReferenceImage = 48,       ///< Make CPA reference image
00120     ac_IASSettingsChanged  = 49,         ///< IAS settings changed
00121     ac_SystemInfo          = 50,         ///< System info
00122     ac_SystemWarning       = 51,         ///< System warning
00123     ac_SystemError         = 52,         ///< System error
00124     ac_SetWatchdog         = 53,         ///< Set watchdog
00125     ac_StartEvent          = 54,         ///< Start event
00126     ac_StopEvent           = 55,         ///< Stop event
00127     ac_StopEventByID       = 56,         ///< Stop event by instance
00128     ac_EventStarted        = 59,         ///< Event started
00129     ac_EventStopped        = 60,         ///< Event stopped
00130     ac_EventRecordingChanged = 61,       ///< Event recording changed
00131     ac_StopAllEvents       = 62,         ///< Stop all events
00132     ac_KillEvent           = 63,         ///< Kill event
00133     ac_KillEventByID       = 64,         ///< Kill event by instance
00134     ac_KillAllEvents       = 65,         ///< Kill all events
00135     ac_BlockingFilterActivate = 68,      ///< Blocking filter activate
00136     ac_BlockingFilterDeactivate = 69,    ///< Blocking filter deactivate
00137     ac_CPAMeasurement      = 70,         ///< CPA measurement
00138     ac_SetTestPictureMode  = 72,         ///< Set test picture mode
00139     ac_ChannelLiveCheck    = 74,         ///< Channel live check
00140     ac_IPCameraRawCommand  = 75,         ///< IP camera raw command
00141     ac_SensorVideoAlarm    = 80,         ///< Sensor video alarm
00142     ac_SensorInhibitVideoAlarm = 81,     ///< Sensor inhibit video alarm
00143     ac_SensorAlarmFinished = 84,         ///< Sensor alarm finished
00144     ac_SensorInhibitAlarmFinished = 85,  ///< Sensor inhibit alarm finished
00145     ac_ChangeObtrackParameterSet = 90,   ///< Change OBTRACK parameter set
00146     ac_ObtrackFrameRawData = 91,         ///< OBTRACK frame raw data
00147     ac_ObtrackObjectRawData = 92,        ///< OBTRACK object raw data
00148     ac_ObtrackChannelCounter = 94,       ///< OBTRACK channel counter
00149     ac_ObtrackGroupCounter = 95,         ///< OBTRACK group counter
00150     ac_ObtrackChannelCounterThreshold = 96, ///< OBTRACK channel counter threshold
00151     ac_ObtrackGroupCounterThreshold = 97, ///< OBTRACK group counter threshold
00152     ac_ObtrackChannelSetCounter = 98,    ///< OBTRACK channel set counter
00153     ac_ObtrackGroupSetCounter = 99,      ///< OBTRACK group set counter
00154     ac_PanRight            = 101,        ///< Pan right
00155     ac_PanLeft             = 102,        ///< Pan left
00156     ac_PanStop             = 103,        ///< Pan stop
00157     ac_TiltUp              = 104,        ///< Tilt up
00158     ac_TiltDown            = 105,        ///< Tilt down
00159     ac_TiltStop            = 106,        ///< Tilt stop
00160     ac_ZoomIn              = 107,        ///< Zoom in
00161     ac_ZoomOut             = 108,        ///< Zoom out
00162     ac_ZoomStop            = 109,        ///< Zoom stop
00163     ac_FocusNear           = 110,        ///< Focus near
00164     ac_FocusFar            = 111,        ///< Focus far
00165     ac_FocusStop           = 112,        ///< Focus stop
00166     ac_IrisOpen            = 113,        ///< Iris open
00167     ac_IrisClose           = 114,        ///< Iris close
00168     ac_IrisStop            = 115,        ///< Iris stop
00169     ac_PrePosCallUp        = 116,        ///< Move to preset position
00170     ac_DefaultPosCallUp    = 117,        ///< Move to default position
00171     ac_CameraTourStart     = 118,        ///< Camera tour start
00172     ac_CameraTourStop      = 119,        ///< Camera tour stop
00173     ac_CameraLightOn       = 120,        ///< Camera light on
00174     ac_CameraLightOff      = 121,        ///< Camera light off
00175     ac_CameraOn            = 122,        ///< Camera on
00176     ac_CameraOff           = 123,        ///< Camera off
00177     ac_CameraPumpOn        = 124,        ///< Camera pump on
00178     ac_CameraPumpOff       = 125,        ///< Camera pump off
00179     ac_FastSpeedOn         = 126,        ///< Fast speed on
00180     ac_FastSpeedOff        = 127,        ///< Fast speed off
00181     ac_CameraWashOn        = 128,        ///< Camera wash-wipe on
00182     ac_CameraWashOff       = 129,        ///< Camera wash-wipe off
00183     ac_CameraSpecFuncUOn   = 130,        ///< Camera spec func U on
00184     ac_CameraSpecFuncUOff  = 131,        ///< Camera spec func U off
00185     ac_CameraSpecFuncVOn   = 132,        ///< Camera spec func V on
00186     ac_CameraSpecFuncVOff  = 133,        ///< Camera spec func V off
00187     ac_CameraSpecFuncXOn   = 134,        ///< Camera spec func X on
00188     ac_CameraSpecFuncXOff  = 135,        ///< Camera spec func X off
00189     ac_CameraSpecFuncYOn   = 136,        ///< Camera spec func Y on
00190     ac_CameraSpecFuncYOff  = 137,        ///< Camera spec func Y off
00191     ac_CameraStopAll       = 138,        ///< Camera stop all
00192     ac_PrePosSave          = 139,        ///< Save preset position
00193     ac_DefaultPosSave      = 140,        ///< Save default position
00194     ac_PrePosClear         = 141,        ///< Clear preset position
00195     ac_DefaultPosClear     = 142,        ///< Clear default position
00196     ac_SetCameraText       = 143,        ///< Set camera text
00197     ac_CameraSelectCharMode = 144,       ///< Camera select char mode
00198     ac_CameraClearPrePosText = 145,      ///< Camera clear preset text
00199     ac_CameraSetPrePosText = 146,        ///< Camera set preset text
00200     ac_CameraRAWOutput     = 147,        ///< Camera RAW output
00201     ac_CameraVersionOn     = 148,        ///< Camera version on
00202     ac_CameraVersionOff    = 149,        ///< Camera version off
00203     ac_PanAuto             = 150,        ///< Pan auto
00204     ac_AutoFocusOn         = 151,        ///< Auto focus on
00205     ac_AutoFocusOff        = 152,        ///< Auto focus off
00206     ac_CameraManualIrisOn  = 153,        ///< Camera manual iris on
00207     ac_CameraManualIrisOff = 154,        ///< Camera manual iris off
00208     ac_CameraTextOn        = 155,        ///< Camera text on
00209     ac_CameraTextOff       = 156,        ///< Camera text off
00210     ac_CameraDayNightMode  = 157,        ///< Camera day/night mode
00211     ac_CameraBacklightCompensationMode = 158, ///< Camera backlight compensation mode
00212     ac_CameraApplyProfile  = 159,        ///< Camera apply profile
00213     ac_MoveToAbsolutePosition = 160,     ///< Move to absolute position
00214     ac_MoveToRelativePosition = 161,     ///< Move to relative position
00215     ac_MoveToBySpeed       = 162,        ///< Move by speed
00216     ac_ChannelInfo         = 180,        ///< Channel info
00217     ac_ChannelWarning      = 181,        ///< Channel warning
00218     ac_ChannelError        = 182,        ///< Channel error
00219     ac_IPSwitchOperation   = 190,        ///< IP switch operation
00220     ac_ViewerConnectLive   = 200,        ///< Viewer connect live
00221     ac_ViewerConnect       = 201,        ///< Viewer connect
00222     ac_ViewerClear         = 202,        ///< Viewer clear
00223     ac_ViewerConnected     = 203,        ///< Viewer connected
00224     ac_ViewerCleared       = 204,        ///< Viewer cleared
00225     ac_ViewerPlayModeChanged = 205,      ///< Viewer play mode changed
00226     ac_ViewerChangeScene   = 206,        ///< Viewer change scene
00227     ac_VCChangeSceneByName = 207,        ///< VC change scene by name
00228     ac_ViewerClearScene    = 208,        ///< Viewer clear scene
00229     ac_VCClearSceneByName  = 209,        ///< VC clear scene by name
00230     ac_ViewerShowAlarmByInstance = 210,  ///< Viewer show alarm by instance
00231     ac_ViewerShowAlarmByKey = 211,       ///< Viewer show alarm by key
00232     ac_ViewerShowAlarmByType = 212,      ///< Viewer show alarm by type
00233     ac_VCSceneChanged      = 213,        ///< VC scene changed
00234     ac_ViewerJumpByTime    = 215,        ///< Viewer jump by time
00235     ac_ViewerPlayFromTime  = 216,        ///< Viewer play from time
00236     ac_ViewerSetPlayMode   = 217,        ///< Viewer set play mode
00237     ac_ViewerSyncAudioAndVideo = 220,    ///< Viewer change sync audio/video
00238     ac_VCSetAudioLevel     = 221,        ///< VC set audio level
00239     ac_ViewerMaximize      = 222,        ///< Viewer maximize
00240     ac_ViewerExportPicture = 223,        ///< Viewer export picture
00241     ac_ViewerPrintPicture  = 224,        ///< Viewer print picture
00242     ac_ImageExportNotification = 225,    ///< Image export notification
00243     ac_ViewerSelect        = 230,        ///< Viewer select
00244     ac_VCShowViewerText    = 231,        ///< VC show viewer text
00245     ac_VCFullMode          = 232,        ///< VC full mode
00246     ac_VCStretchMode       = 233,        ///< VC stretch mode
00247     ac_ViewerTextOutput    = 240,        ///< Viewer text output
00248     ac_ViewerClearTextOutput = 241,      ///< Viewer clear text output
00249     ac_ViewerSelectionChanged = 242,     ///< Viewer selection changed
00250     ac_SceneStoreModification = 243,     ///< Scene store modification
00251     ac_VCAlarmQueueSelect  = 250,        ///< VC alarm queue select
00252     ac_VCAlarmQueueSelectByType = 251,   ///< VC alarm queue select by type
00253     ac_VCAlarmQueueConfirm = 252,        ///< VC alarm queue confirm
00254     ac_VCAlarmQueueConfirmByType = 253,  ///< VC alarm queue confirm by type
00255     ac_VCAlarmQueueRemove  = 254,        ///< VC alarm queue remove
00256     ac_VCAlarmQueueRemoveByType = 255,   ///< VC alarm queue remove by type
00257     ac_VCAlarmQueueSelectByInstance = 256, ///< VC alarm queue select by instance
00258     ac_VCAlarmQueueConfirmByInstance = 257, ///< VC alarm queue confirm by instance
00259     ac_VCAlarmQueueRemoveByInstance = 258, ///< VC alarm queue remove by instance
00260     ac_VCAlarmQueueNotification = 259,   ///< VC alarm queue notification
00261     ac_DatabaseRecordingInfoTotal = 260, ///< Database recording info total
00262     ac_DatabaseRecordingInfoRing = 263,  ///< Database recording info per ring
00263     ac_AutoBackupCapacityMonitoringOutOfDiskSpace = 270, ///< Auto backup capacity out of disk space
00264     ac_AutoBackupCapacityMonitoringCapacityWarning = 272, ///< Auto backup capacity warning
00265     ac_AutoBackupCapacityMonitoringFileAutoDeleted = 274, ///< Auto backup capacity file auto deleted
00266     ac_StartAutoBackup     = 280,        ///< Start auto backup
00267     ac_BackupEvent         = 281,        ///< Backup event
00268     ac_AutoBackupScheduleStarted = 282,  ///< Auto backup schedule started
00269     ac_AutoBackupScheduleDone = 284,     ///< Auto backup schedule done
00270     ac_AutoBackupOperationStarted = 286, ///< Auto backup operation started
00271     ac_AutoBackupOperationDone = 288,    ///< Auto backup operation done
00272     ac_AutoBackupFileStarted = 290,      ///< Auto backup file started
00273     ac_AutoBackupFileProgress = 292,     ///< Auto backup file progress
00274     ac_AutoBackupFileDone  = 294,        ///< Auto backup file done
00275     ac_AbortAutoBackup     = 298,        ///< Abort auto backup
00276     ac_AbortAllAutoBackups = 299,        ///< Abort all auto backups
00277     ac_GEMOSalarm          = 300,        ///< GEMOS alarm
00278     ac_ObtrackTunnelAlarm  = 301,        ///< OBTRACK tunnel alarm
00279     ac_SMTPMailSend        = 303,        ///< SMTP mail
00280     ac_EventBackupStarted  = 310,        ///< Event backup started
00281     ac_EventBackupDone     = 312,        ///< Event backup done
00282     ac_EventBackupFileStarted = 314,     ///< Event backup file started
00283     ac_EventBackupFileProgress = 316,    ///< Event backup file progress
00284     ac_EventBackupFileDone = 318,        ///< Event backup file done
00285     ac_ChangeCameraProfile = 330,        ///< Change camera profile
00286     ac_SMRPViewerConnected = 340,        ///< SMRP viewer connected
00287     ac_SMRPViewerCleared   = 341,        ///< SMRP viewer cleared
00288     ac_ATMRawData          = 350,        ///< ATM raw data
00289     ac_ATMRawAnswer        = 351,        ///< ATM raw answer
00290     ac_ATMTransaction      = 352,        ///< ATM transaction
00291     ac_ACSRawData          = 354,        ///< ACS raw data
00292     ac_ACSRawAnswer        = 355,        ///< ACS raw answer
00293     ac_ACSAccessGranted    = 356,        ///< ACS access granted
00294     ac_ACSAccessDenied     = 357,        ///< ACS access denied
00295     ac_InterfaceRawData    = 358,        ///< Interface raw data
00296     ac_InterfaceRawAnswer  = 359,        ///< Interface raw answer
00297     ac_POSStatus           = 360,        ///< POS status
00298     ac_POSData             = 361,        ///< POS data
00299     ac_TerminalArticleData = 363,        ///< Terminal article data
00300     ac_TerminalPaymentData = 364,        ///< Terminal payment data
00301     ac_BarcodeData         = 365,        ///< Barcode data
00302     ac_FillingPumpStatus   = 366,        ///< Filling pump status
00303     ac_ActivateExternalProcess = 370,    ///< Activate external process
00304     ac_NPRRawData          = 371,        ///< NPR raw data
00305     ac_NPRRecognition      = 375,        ///< NPR recognition
00306     ac_TransferBinaryBuffer = 380,       ///< Transfer binary buffer
00307     ac_TransferBinaryChannelBuffer = 381, ///< Transfer binary channel buffer
00308     ac_SetSystemTime       = 385,        ///< Set system time
00309     ac_VideoSetImageContrast = 390,      ///< Video set image contrast
00310     ac_VideoSetImageBrightness = 391,    ///< Video set image brightness
00311     ac_VideoSetImageSaturation = 392,    ///< Video set image saturation
00312     ac_MediaChannelSetupInfo = 395,      ///< Media channel setup
00313     ac_SafebagOpen         = 400,        ///< Safebag open
00314     ac_SafebagData         = 402,        ///< Safebag data
00315     ac_SafebagClose        = 405,        ///< Safebag close
00316     ac_SafebagPassingOfRiskStart = 407,  ///< Safebag passing of risk start
00317     ac_SafebagPassingOfRiskData = 410,   ///< Safebag passing of risk data
00318     ac_SafebagPassingOfRiskStop = 413,   ///< Safebag passing of risk stop
00319     ac_IOI43WDActivate     = 420,        ///< IOI43 watchdog activate
00320     ac_IOI43WDDeactivate   = 421,        ///< IOI43 watchdog deactivate
00321     ac_IOI43WDTrigger      = 422,        ///< IOI43 watchdog trigger
00322     ac_IOI43ResetMainboard = 423,        ///< IOI43 reset mainboard
00323     ac_IOI43Temperature    = 424,        ///< IOI43 temperature notification
00324     ac_SkidataControl      = 430,        ///< SKIDATA control
00325     ac_SkidataEntry        = 431,        ///< SKIDATA entry
00326     ac_SkidataExit         = 432,        ///< SKIDATA exit
00327     ac_SkidataTransaction  = 433,        ///< SKIDATA transaction
00328     ac_SkidataDeviceEvent  = 434,        ///< SKIDATA device event
00329     ac_WatchdogActivate    = 440,        ///< Watchdog activate
00330     ac_WatchdogDeactivate  = 441,        ///< Watchdog deactivate
00331     ac_WatchdogTrigger     = 442,        ///< Watchdog trigger
00332     ac_Temperature         = 443,        ///< Temperature notification
00333     ac_ResetMainboard      = 444,        ///< Reset mainboard
00334     ac_CaseOpened          = 445,        ///< Case has been opened
00335     ac_CaseClosed          = 446,        ///< Case has been closed
00336     ac_SetExportMarker     = 450,        ///< Set export marker
00337     ac_InitializeRemoteExport = 451,     ///< Initialize remote export
00338     ac_StartRemoteExport   = 452,        ///< Start remote export
00339     ac_ExportProgress      = 454,        ///< Export progress
00340     ac_ExportFinished      = 455,        ///< Export finished
00341     ac_CancelExport        = 456,        ///< Cancel export
00342     ac_StartSceneStore     = 457,        ///< Start scene store
00343     ac_LPSPositionData     = 460,        ///< LPS position data
00344     ac_LPSQueryPosition    = 463,        ///< LPS query position
00345     ac_LogBarcodeData      = 465,        ///< Log barcode data
00346     ac_LogBarcodeDataLPS   = 467,        ///< Log barcode data LPS
00347     ac_LogNPRRecognition   = 469,        ///< Log NPR recognition
00348     ac_GSCSVehicleAccessDenied = 480,    ///< GSCS vehicle access denied
00349     ac_GSCSVehicleAccessGranted = 482,   ///< GSCS vehicle access granted
00350     ac_GSCSVehicleAccessExpired = 484,   ///< GSCS vehicle access expired
00351     ac_GSCSVehicleAccessPending = 486,   ///< GSCS vehicle access pending
00352     ac_LenelSecurityEvent  = 500,        ///< Lenel security event
00353     ac_LenelAccessEvent    = 502,        ///< Lenel access event
00354     ac_LenelIntercomEvent  = 506,        ///< Lenel intercom event
00355     ac_LenelVideoEvent     = 508,        ///< Lenel video event
00356     ac_LenelFireEvent      = 510,        ///< Lenel fire event
00357     ac_LenelRawData        = 512,        ///< Lenel raw data
00358     ac_LenelRefreshNames   = 514,        ///< Lenel refresh names
00359     ac_GTectVMXAlarm       = 520,        ///< G-Tect/VMX alarm
00360     ac_GTectVMXAlarmFinished = 522,      ///< G-Tect/VMX alarm finished
00361     ac_GTectDualSensorAlarm = 524,       ///< G-Tect/Dual sensor alarm
00362     ac_GTectDualSensorAlarmFinished = 526, ///< G-Tect/Dual sensor alarm finished
00363     ac_GTectSceneAlarm     = 528,        ///< G-Tect scene alarm
00364     ac_GTectSceneAlarmFinished = 530,    ///< G-Tect scene alarm finished
00365     ac_GTectAnalyticsLiveCheck = 532,    ///< G-Tect analytics live check
00366     ac_ChangeGTectParameterSet = 534,    ///< Change GTectVMX parameter set
00367     ac_SetClientVCA        = 536,        ///< Enable client VCA
00368     ac_VCASetArmed         = 537,        ///< VCA set armed
00369     ac_VCAStatusRequest    = 538,        ///< VCA status request
00370     ac_VCAStatusAnswer     = 539,        ///< VCA status answer
00371     ac_IPCamFailoverNotification = 540,  ///< IP camera failover notification
00372     ac_IPCamFailoverRestore = 541,       ///< IP camera failover restore
00373     ac_ImexCapacityWarning = 550,        ///< Imex capacity warning
00374     ac_ImexCapacityOutOfDiskSpace = 552, ///< Imex capacity out of disk space.
00375     ac_ImexCapacityFileAutoDeleted = 554, ///< Imex capacity file auto deleted
00376     ac_ImexExportImageFromDB = 560,      ///< Imex export image from DB
00377     ac_ImexExportEventImage = 562,       ///< Imex export event image
00378     ac_ImexExportImageFromLiveStream = 564, ///< Imex export image from live stream
00379     ac_PPSubcellAlarm      = 580,        ///< PP subcell alarm
00380     ac_PPDeviceAlarm       = 581,        ///< PP device alarm
00381     ac_PPZoneAlarm         = 582,        ///< PP zone alarm
00382     ac_PPDeviceInput       = 583,        ///< PP device input
00383     ac_PPSetDeviceOutput   = 584,        ///< PP set device output
00384     ac_PPQueryInterface    = 585,        ///< PP query interface
00385     ac_PPInterfaceOnline   = 586,        ///< PP interface online
00386     ac_PPInterfaceOffline  = 587,        ///< PP interface offline
00387     ac_PPDeviceOnline      = 588,        ///< PP device online
00388     ac_PPDeviceOffline     = 589,        ///< PP device offline
00389     ac_Unknown             = 0x7fffffff
00390   };
00391
00392
00393   ///
00394   /// State of the digital input contact.
00395
00396   typedef enum TPlcDigitalInputState
00397   {
00398     disLow                 = 0,          ///< low
00399     disMiddle              = 1,          ///< terminated
00400     disHigh                = 2,          ///< high
00401     disUnknown             = 0x7fffffff
00402   } DigitalInputState;
00403
00404   ///
00405   /// State of the digital output contact.
00406
00407   typedef enum TPlcDigitalOutputState
00408   {
00409     dosOpen                = 0,          ///< open
00410     dosClose               = 1,          ///< close
00411     dosToggle              = 2,          ///< toggle
00412     dosUnknown             = 0x7fffffff
00413   } DigitalOutputState;
00414
00415   ///
00416   /// Norm of the video input signal.
00417
00418   typedef enum TPlcVideoSignalNorm
00419   {
00420     vsnEIA                 = 0,          ///< EIA
00421     vsnCCIR                = 1,          ///< CCIR
00422     vsnUnknown             = 0x7fffffff
00423   } VideoSignalNorm;
00424
00425   ///
00426   /// Type of the video input signal.
00427
00428   typedef enum TPlcVideoSignalType
00429   {
00430     vstBAS                 = 0,          ///< BAS
00431     vstFBAS                = 1,          ///< FBAS
00432     vstUnknown             = 0x7fffffff
00433   } VideoSignalType;
00434
00435   ///
00436   /// Interlace kind of the video input signal.
00437
00438   typedef enum TPlcVideoInterlaceType
00439   {
00440     vsdInterlaced          = 0,          ///< interlaced
00441     vsdNonInterlaced       = 1,          ///< non-interlaced
00442     vsdUnknown             = 0x7fffffff
00443   } VideoInterlaceType;
00444
00445   ///
00446   /// Activity detection area.
00447
00448   typedef enum TPlcADArea
00449   {
00450     adgArea1               = 0,          ///< area 1
00451     adgArea2               = 1,          ///< area 2
00452     adgArea3               = 2,          ///< area 3
00453     adgArea4               = 3,          ///< area 4
00454     adgUnknown             = 0x7fffffff
00455   } ADArea;
00456
00457   ///
00458   /// VMD group.
00459
00460   typedef enum TPlcVMDGroup
00461   {
00462     vmgGroup1              = 0,          ///< group 1
00463     vmgGroup2              = 1,          ///< group 2
00464     vmgGroup3              = 2,          ///< group 3
00465     vmgGroup4              = 3,          ///< group 4
00466     vmgUnknown             = 0x7fffffff
00467   } VMDGroup;
00468
00469   ///
00470   /// System LED.
00471
00472   typedef enum TPlcSystemLED
00473   {
00474     ledError               = 0,          ///< error LED
00475     ledRecord              = 1,          ///< record LED
00476     ledGreen               = 2,          ///< green LED
00477     ledYellow              = 3,          ///< yellow LED
00478     ledIOI43a1             = 9,          ///< IOI43a LED 1
00479     ledIOI43a2             = 10,          ///< IOI43a LED 2
00480     ledIOI43a3             = 11,          ///< IOI43a LED 3
00481     ledIOI43a4             = 12,          ///< IOI43a LED 4
00482     ledUnknown             = 0x7fffffff
00483   } SystemLED;
00484
00485   ///
00486   /// Video sensor type.
00487
00488   typedef enum TPlcVideoSensorKind
00489   {
00490     vskAD                  = 0,          ///< AD
00491     vskVMD                 = 1,          ///< VMD
00492     vskCPA                 = 2,          ///< CPA
00493     vskIPAD                = 3,          ///< IP-AD
00494     vskOBTRACK             = 4,          ///< OBTRACK
00495     vskDUAL                = 5,          ///< DUAL
00496     vskNPR                 = 6,          ///< NPR
00497     vskFR                  = 7,          ///< FR
00498     vskVAMissing           = 8,          ///< VA-Missing
00499     vskCPAExt              = 9,          ///< CPA extern
00500     vskGTectVMX            = 10,          ///< G-Tect/VMX
00501     vskUnknown             = 0x7fffffff
00502   } VideoSensorKind;
00503
00504   ///
00505   /// User login failure code.
00506
00507   typedef enum TPlcUserLoginFailureCode
00508   {
00509     ulfUser1NotFound       = 1,          ///< unknown first user
00510     ulfUser1InvalPwd       = 2,          ///< invalid first user
00511     ulfUser2NotFound       = 3,          ///< unknown second user
00512     ulfUser2InvalPwd       = 4,          ///< invalid second user
00513     ulfMissingSecondUser   = 5,          ///< second user required
00514     ulfUser2NotAdmitted    = 6,          ///< second user is not admitted
00515     ulfNoLicense           = 7,          ///< no licence available
00516     ulfTooManyClients      = 8,          ///< licence limits reached
00517     ulfUnknown             = 0x7fffffff
00518   } UserLoginFailureCode;
00519
00520   ///
00521   /// Source of the message.
00522
00523   typedef enum TPlcPlcMessageSource
00524   {
00525     pmsServer              = 0,          ///< server
00526     pmsSetup               = 1,          ///< setup
00527     pmsDBE                 = 2,          ///< DBE
00528     pmsMediaAPI            = 3,          ///< media API
00529     pmsMediaPlugin         = 4,          ///< media plugin
00530     pmsPLC                 = 5,          ///< PLC
00531     pmsAutoBackup          = 6,          ///< auto backup
00532     pmsDongle              = 7,          ///< dongle
00533     pmsFRC                 = 8,          ///< FRC
00534     pmsATM                 = 9,          ///< ATM
00535     pmsSensor              = 10,          ///< sensor
00536     pmsPOS                 = 11,          ///< POS
00537     pmsACS                 = 12,          ///< ACS
00538     pmsIOI43               = 13,          ///< IOI43
00539     pmsInterface           = 14,          ///< interface
00540     pmsTranscoder          = 15,          ///< transcoder
00541     pmsLenel               = 16,          ///< LENEL
00542     pmsLogistic            = 17,          ///< logistic
00543     pmsLPS                 = 18,          ///< LPS
00544     pmsSCS                 = 19,          ///< Supply Chain Security
00545     pmsVAM                 = 20,          ///< Vehicle Access Manager
00546     pmsMIO                 = 21,          ///< MIO
00547     pmsPP                  = 22,          ///< perimeter protection
00548     pmsUnknown             = 0x7fffffff
00549   } PlcMessageSource;
00550
00551   ///
00552   /// Code of the message.
00553
00554   typedef enum TPlcPlcMessageCode
00555   {
00556     pmcInternalError       = 0,          ///< internal error
00557     pmcOutOfResources      = 1,          ///< out of resources
00558     pmcUnlicensed          = 2,          ///< unlicensed
00559     pmcConnectionLost      = 3,          ///< connection lost
00560     pmcUnknownError        = 4,          ///< unknown error
00561     pmcDemoModeExpired     = 5,          ///< demo mode expired
00562     pmcDatabaseFileMissing = 10,          ///< database file missing
00563     pmcFileAccessError     = 11,          ///< file access error
00564     pmcFLTMInefficient     = 12,          ///< FLTM inefficient
00565     pmcDBECouldNotFreeAnyPage = 13,          ///< DBE could not free any page
00566     pmcDongleFound         = 20,          ///< dongle found
00567     pmcDongleMissing       = 21,          ///< dongle missing
00568     pmcDongleWrong         = 22,          ///< wrong dongle connected
00569     pmcDongleInsufficient  = 23,          ///< insufficient licences
00570     pmcFirmwareUploadFailed = 30,          ///< firmware upload failed
00571     pmcWatchdogReset       = 31,          ///< watchdog reset detected
00572     pmcHttpError           = 35,          ///< HTTP error
00573     pmcHostRestrictions    = 36,          ///< not a white-listed host
00574     pmcInsufficientFrameRate = 40,          ///< not enough images for analysis
00575     pmcTranscoderOverload  = 41,          ///< transcoder is overloaded
00576     pmcNoControlForLongTime = 50,          ///< had no control for long time
00577     pmcBehaviouralRuleTooDeep = 51,          ///< behavioural rule iteration too deep
00578     pmcCannotOpenPort      = 61,          ///< cannot open port
00579     pmcCannotEnumeratePorts = 62,          ///< cannot enumerate ports
00580     pmcCannotSetFilter     = 63,          ///< cannot set filter
00581     pmcDataOverflow        = 64,          ///< data overflow
00582     pmcInsufficientData    = 65,          ///< insufficient data
00583     pmcIODeviceFound       = 70,          ///< device found
00584     pmcIODeviceLost        = 71,          ///< device lost
00585     pmcIODeviceNotFound    = 72,          ///< device not found
00586     pmcIOTemperatureBelow  = 73,          ///< temperature below threshold
00587     pmcIOTemperatureAbove  = 74,          ///< temperature above threshold
00588     pmcIODriverNotInstalled = 75,          ///< driver is not installed
00589     pmcIOCannotEnumerate   = 76,          ///< cannot enumerate hardware
00590     pmcIOCannotOpen        = 77,          ///< cannot open device
00591     pmcIODuplcatedAddress  = 78,          ///< device with duplicated address switch
00592     pmcIOUnusedDevice      = 79,          ///< unused device
00593     pmcUnknown             = 0x7fffffff
00594   } PlcMessageCode;
00595
00596   ///
00597   /// Viewer alarm queue selection mode.
00598
00599   typedef enum TPlcPlcViewerAlarmQueueSelection
00600   {
00601     aqsFirst               = 0,          ///< first
00602     aqsLast                = 1,          ///< last
00603     aqsNext                = 2,          ///< next
00604     aqsPrevious            = 3,          ///< previous
00605     aqsUnknown             = 0x7fffffff
00606   } PlcViewerAlarmQueueSelection;
00607
00608   ///
00609   /// Auto backup capacity monitoring warning.
00610
00611   typedef enum TPlcABCapacityWarning
00612   {
00613     abwOk                  = 0,          ///< no warnings
00614     abwFreeCapacityBelowLimit = 1,          ///< free capacity below limit
00615     abwAllocatedCapacityAboveLimit = 2,          ///< allocated capacity above limit
00616     abwBoth                = 3,          ///< free capacity below and allocated capacity above limit
00617     abwUnknown             = 0x7fffffff
00618   } ABCapacityWarning;
00619
00620   ///
00621   /// OBTRACK object status.
00622
00623   typedef enum TPlcPlcObtrackObjectStatus
00624   {
00625     oosStarting            = 0,          ///< starting
00626     oosStationary          = 1,          ///< stationary
00627     oosLeaving             = 2,          ///< leaving
00628     oosUndefined           = 3,          ///< undefined
00629     oosDeleted             = 4,          ///< deleted
00630     oosUnknown             = 0x7fffffff
00631   } PlcObtrackObjectStatus;
00632
00633   ///
00634   /// OBTRACK object class.
00635
00636   typedef enum TPlcPlcObtrackObjectClass
00637   {
00638     oocPerson              = 0,          ///< person
00639     oocCar                 = 1,          ///< car
00640     oocUndefined           = 2,          ///< unknown object
00641     oocUnknown             = 0x7fffffff
00642   } PlcObtrackObjectClass;
00643
00644   ///
00645   /// Database status.
00646
00647   typedef enum TPlcPlcDatabaseStatus
00648   {
00649     dbsEmpty               = 0,          ///< empty
00650     dbsReady               = 1,          ///< ready
00651     dbsFileAdded           = 2,          ///< file added
00652     dbsUnknown             = 0x7fffffff
00653   } PlcDatabaseStatus;
00654
00655   ///
00656   /// OBTRACK process size.
00657
00658   typedef enum TPlcPlcObtrackProcessSize
00659   {
00660     opsCIF                 = 0,          ///< CIF
00661     opsFourCIF             = 1,          ///< 4CIF
00662     opsTakeWhatYouGet      = 2,          ///< ANY
00663     opsUnknown             = 0x7fffffff
00664   } PlcObtrackProcessSize;
00665
00666   ///
00667   /// GEVISCOPE system key.
00668
00669   typedef enum TPlcSystemKey
00670   {
00671     keyDisplay1            = 0,          ///< GSC display 1
00672     keyDisplay2            = 1,          ///< GSC display 2
00673     keyDisplay3            = 2,          ///< GSC display 3
00674     keyDisplay4            = 3,          ///< GSC display 4
00675     keyReporter1           = 256,          ///< reporter 1
00676     keyUnknown             = 0x7fffffff
00677   } SystemKey;
00678
00679   ///
00680   /// VMD measure cycle.
00681
00682   typedef enum TPlcVMDCycle
00683   {
00684     vmc40ms                = 0,          ///< 40 ms
00685     vmc160ms               = 1,          ///< 160 ms
00686     vmc640ms               = 2,          ///< 640 ms
00687     vmc2_5s                = 3,          ///< 2.5 s
00688     vmc10s                 = 4,          ///< 10 s
00689     vmcUnknown             = 0x7fffffff
00690   } VMDCycle;
00691
00692   ///
00693   /// Safebag step.
00694
00695   typedef enum TPlcSafebagStep
00696   {
00697     sbsOpen                = 0,          ///< open
00698     sbsUnknown             = 0x7fffffff
00699   } SafebagStep;
00700
00701   ///
00702   /// OBTRACK counter type.
00703
00704   typedef enum TPlcPlcObtrackCounterType
00705   {
00706     octIncoming            = 0,          ///< incoming
00707     octOutcoming           = 1,          ///< outcoming
00708     octCommon              = 2,          ///< common
00709     octUnknown             = 0x7fffffff
00710   } PlcObtrackCounterType;
00711
00712   ///
00713   /// OBTRACK exceeding direction.
00714
00715   typedef enum TPlcPlcObtrackExceedingDirection
00716   {
00717     oedExceed              = 0,          ///< exceed
00718     oedFallBelow           = 1,          ///< fall below
00719     oedUnknown             = 0x7fffffff
00720   } PlcObtrackExceedingDirection;
00721
00722   ///
00723   /// Tunnel alarm reason.
00724
00725   typedef enum TPlcPlcTunnelAlarmReason
00726   {
00727     tarPerson              = 0,          ///< person
00728     tarPark                = 1,          ///< park
00729     tarWrongDirection      = 2,          ///< wrong direction
00730     tarUnknown             = 0x7fffffff
00731   } PlcTunnelAlarmReason;
00732
00733   ///
00734   /// Viewer play mode.
00735
00736   typedef enum TPlcPlcViewerPlayMode
00737   {
00738     vpmUnknownMode         = 0,          ///< unknown
00739     vpmPlayStop            = 1,          ///< play stop
00740     vpmPlayForward         = 2,          ///< play forward
00741     vpmPlayBackward        = 3,          ///< play backward
00742     vpmPlayFastForward     = 4,          ///< fast forward
00743     vpmPlayFastBackward    = 5,          ///< fast backward
00744     vpmPlayStepForward     = 6,          ///< step forward
00745     vpmPlayStepBackward    = 7,          ///< step backward
00746     vpmPlayBOD             = 8,          ///< play BOD
00747     vpmPlayEOD             = 9,          ///< play EOD
00748     vpmPlayQuasiLive       = 10,          ///< quasi live
00749     vpmPlayStream          = 11,          ///< live
00750     vpmPlayNextEvent       = 12,          ///< next event
00751     vpmPlayPrevEvent       = 13,          ///< prev event
00752     vpmPeekLivePicture     = 14,          ///< peek live picture
00753     vpmPlayNextMOS         = 17,          ///< next detected motion
00754     vpmPlayPrevMOS         = 18,          ///< prev detected motion
00755     vpmUnknown             = 0x7fffffff
00756   } PlcViewerPlayMode;
00757
00758   ///
00759   /// Viewer alarm play mode.
00760
00761   typedef enum TPlcPlcViewerAlarmPlayMode
00762   {
00763     apmDefault             = 0,          ///< show alarm using default settings
00764     apmLiveReplay          = 1,          ///< live replay
00765     apmReplayEventPictures = 2,          ///< replay event pictures
00766     apmContinuousEventReplayInALoop = 3,          ///< continuous event replay
00767     apmShowFirstAlarmPictureOnly = 4,          ///< show first alarm picture only
00768     apmUnknown             = 0x7fffffff
00769   } PlcViewerAlarmPlayMode;
00770
00771   ///
00772   /// Viewer alarm state notification.
00773
00774   typedef enum TPlcPlcViewerAlarmState
00775   {
00776     vasNewAlarm            = 0,          ///< new alarm
00777     vasPresented           = 1,          ///< presented
00778     vasStacked             = 2,          ///< stacked
00779     vasConfirmed           = 3,          ///< confirmed
00780     vasRemoved             = 4,          ///< removed
00781     vasLastConfirmed       = 5,          ///< last confirmed
00782     vasLastRemoved         = 6,          ///< last removed
00783     vasListConfirmed       = 7,          ///< list confirmed
00784     vasListEmpty           = 8,          ///< list empty
00785     vasUnknown             = 0x7fffffff
00786   } PlcViewerAlarmState;
00787
00788   ///
00789   /// Image export type.
00790
00791   typedef enum TPlcPlcImageExportType
00792   {
00793     ietSingleImage         = 0,          ///< single image
00794     ietBackupFile          = 1,          ///< backup file
00795     ietVideoFile           = 2,          ///< video file
00796     ietClipboard           = 3,          ///< clipboard
00797     ietPrinter             = 4,          ///< printer
00798     ietUnknown             = 0x7fffffff
00799   } PlcImageExportType;
00800
00801   ///
00802   /// Database ring.
00803
00804   typedef enum TPlcPlcDatabaseRing
00805   {
00806     dbrRing1               = 0,          ///< ring 1
00807     dbrRing2               = 1,          ///< ring 2
00808     dbrRing3               = 2,          ///< ring 3
00809     dbrRing4               = 3,          ///< ring 4
00810     dbrRing5               = 4,          ///< ring 5
00811     dbrRing6               = 5,          ///< ring 6
00812     dbrRing7               = 6,          ///< ring 7
00813     dbrRing8               = 7,          ///< ring 8
00814     dbrUnknown             = 0x7fffffff
00815   } PlcDatabaseRing;
00816
00817   ///
00818   /// Plugin error code.
00819
00820   typedef enum TPlcPlcPluginError
00821   {
00822     ppeInternalError       = 1,          ///< internal error
00823     ppeOutOfResources      = 2,          ///< out of resources
00824     ppeUnlicensed          = 3,          ///< unlicensed
00825     ppeConnectionLost      = 4,          ///< connection lost
00826     ppeUnknownError        = 5,          ///< unknown error
00827     ppeUnknown             = 0x7fffffff
00828   } PlcPluginError;
00829
00830   ///
00831   /// Client type.
00832
00833   typedef enum TPlcPlcClientType
00834   {
00835     pctInvalid             = 0,          ///< invalid
00836     pctGscView             = 1,          ///< GSCView
00837     pctGscSetup            = 2,          ///< GSCSetup
00838     pctGscRegEdit          = 3,          ///< GSCRegEdit
00839     pctGscWeb              = 4,          ///< GSCWeb
00840     pctDefault             = 5,          ///< default
00841     pctGscSupplyChain      = 6,          ///< GSCSupplyChain
00842     pctUnknown             = 0x7fffffff
00843   } PlcClientType;
00844
00845   ///
00846   /// FRC notification.
00847
00848   typedef enum TPlcPlcFRCNotification
00849   {
00850     frnDataOverwritten     = 0,          ///< data overwritten
00851     frnBufferActivated     = 1,          ///< buffer recording activated
00852     frnReconcileStarted    = 2,          ///< reconcile operation started
00853     frnReconcileProgress   = 3,          ///< reconcile progress
00854     frnReconcileAborted    = 4,          ///< reconcile aborted
00855     frnReconcileFinished   = 5,          ///< reconcile finished
00856     frnUnknown             = 0x7fffffff
00857   } PlcFRCNotification;
00858
00859   ///
00860   /// PLC resource kind.
00861
00862   typedef enum TPlcPlcResourceKind
00863   {
00864     prkNotSpecified        = 0,          ///< unknown
00865     prkVideoInput          = 1,          ///< video input
00866     prkPTZHead             = 2,          ///< PTZ head
00867     prkDigitalInput        = 3,          ///< digital input
00868     prkDigitalOutput       = 4,          ///< digital output
00869     prkUser                = 5,          ///< user
00870     prkTimeRange           = 6,          ///< time range
00871     prkVCUserOptions       = 7,          ///< VC user options
00872     prkVCAllProfiles       = 8,          ///< VC all profiles
00873     prkUnknown             = 0x7fffffff
00874   } PlcResourceKind;
00875
00876   ///
00877   /// PLC resource change kind.
00878
00879   typedef enum TPlcPlcResourceChangeKind
00880   {
00881     rckAdded               = 0,          ///< added
00882     rckRemoved             = 1,          ///< removed
00883     rckModified            = 2,          ///< modified
00884     rckUnknown             = 0x7fffffff
00885   } PlcResourceChangeKind;
00886
00887   ///
00888   /// PLC POS status.
00889
00890   typedef enum TPlcPlcPOSStatus
00891   {
00892     posStarted             = 0,          ///< started
00893     posCleared             = 1,          ///< cleared
00894     posStopped             = 2,          ///< stopped
00895     posUnknown             = 0x7fffffff
00896   } PlcPOSStatus;
00897
00898   ///
00899   /// PLC POS status.
00900
00901   typedef enum TPlcPlcNPRRestriction
00902   {
00903     nrrUnspecified         = 0,          ///< unspecified
00904     nrrBlackListed         = 1,          ///< black-listed
00905     nrrWhiteListed         = 2,          ///< white-listed
00906     nrrUnknown             = 0x7fffffff
00907   } PlcNPRRestriction;
00908
00909   ///
00910   /// Special constants.
00911
00912   typedef enum TPlcPlcSpecialConstants
00913   {
00914     pscRestOfTime          = 0,          ///< rest of time
00915     pscUnknown             = 0x7fffffff
00916   } PlcSpecialConstants;
00917
00918   ///
00919   /// Plugin state.
00920
00921   typedef enum TPlcPlcPluginState
00922   {
00923     ppsInternalState       = 0,          ///< internal state
00924     ppsConnected           = 1,          ///< connected
00925     ppsDisconnected        = 2,          ///< disconnected
00926     ppsUnknown             = 0x7fffffff
00927   } PlcPluginState;
00928
00929   ///
00930   /// PLC pump status.
00931
00932   typedef enum TPlcPlcPumpStatus
00933   {
00934     pumStarted             = 0,          ///< filling started
00935     pumStopped             = 1,          ///< filling stopped
00936     pumCleared             = 2,          ///< pump released
00937     pumAmount              = 3,          ///< amount message
00938     pumUnknown             = 0x7fffffff
00939   } PlcPumpStatus;
00940
00941   ///
00942   /// Day/night mode.
00943
00944   typedef enum TPlcPlcDayNightMode
00945   {
00946     pdnDay                 = 0,          ///< day
00947     pdnNight               = 1,          ///< night
00948     pdnAuto                = 2,          ///< auto
00949     pdnUnknown             = 0x7fffffff
00950   } PlcDayNightMode;
00951
00952   ///
00953   /// Backlight compensation mode.
00954
00955   typedef enum TPlcPlcBacklightMode
00956   {
00957     pbmOff                 = 0,          ///< off
00958     pbmOn                  = 1,          ///< on
00959     pbmUnknown             = 0x7fffffff
00960   } PlcBacklightMode;
00961
00962   ///
00963   /// SKIDATA control message.
00964
00965   typedef enum TPlcPlcSkidataControl
00966   {
00967     sdcConnectionOk        = 1,          ///< connection ok
00968     sdcConnectionFailed    = 2,          ///< connection attempt failed
00969     sdcDisconnected        = 3,          ///< disconnected
00970     sdcConnectionLost      = 4,          ///< connection lost
00971     sdcUnknown             = 0x7fffffff
00972   } PlcSkidataControl;
00973
00974   ///
00975   /// SKIDATA message entry.
00976
00977   typedef enum TPlcPlcSkidataMsgCodeEntry
00978   {
00979     sdenTicket              = 1,          ///< SKIDATA ticket
00980     sdenCreditCard          = 2,          ///< credit card
00981     sdenElectronicPurse     = 3,          ///< el. purse card
00982     sdenExternalCard        = 4,          ///< external card
00983     sdenUnknown             = 0x7fffffff
00984   } PlcSkidataMsgCodeEntry;
00985
00986   ///
00987   /// SKIDATA message exit.
00988
00989   typedef enum TPlcPlcSkidataMsgCodeExit
00990   {
00991     sdexTicket              = 1,          ///< SKIDATA ticket
00992     sdexCreditCard          = 2,          ///< credit card
00993     sdexElectronicPurse     = 3,          ///< el. purse card
00994     sdexExternalCard        = 4,          ///< external card
00995     sdexUnknown             = 0x7fffffff
00996   } PlcSkidataMsgCodeExit;
00997
00998   ///
00999   /// SKIDATA message transaction.
01000
01001   typedef enum TPlcPlcSkidataMsgCodeTransaction
01002   {
01003     sdtrParking             = 1,          ///< parking payment
01004     sdtrSale                = 2,          ///< sale payment
01005     sdtrOther               = 3,          ///< other payment
01006     sdtrCash                = 4,          ///< cash payment
01007     sdtrCheck               = 5,          ///< cheque payment
01008     sdtrCreditCard          = 6,          ///< credit card payment
01009     sdtrInvoice             = 7,          ///< invoice payment
01010     sdtrValueCard           = 8,          ///< value card payment
01011     sdtrValidation          = 9,          ///< validation payment
01012     sdtrToken               = 10,          ///< token payment
01013     sdtrElectronicPurse     = 11,          ///< electronic purse payment
01014     sdtrIsoDiscount         = 12,          ///< ISO discount payment
01015     sdtrUnknown             = 0x7fffffff
01016   } PlcSkidataMsgCodeTransaction;
01017
01018   ///
01019   /// Export marker.
01020
01021   typedef enum TPlcPlcExportMarker
01022   {
01023     exmSelectionBegin      = 0,          ///< selection begin
01024     exmSelectionEnd        = 1,          ///< selection end
01025     exmUnknown             = 0x7fffffff
01026   } PlcExportMarker;
01027
01028   ///
01029   /// Backup format.
01030
01031   typedef enum TPlcPlcBackupFormat
01032   {
01033     ebfDefault             = 0,          ///< default
01034     ebfGBF                 = 1,          ///< GBF
01035     ebfMPEG2               = 2,          ///< MPEG2
01036     ebfUnknown             = 0x7fffffff
01037   } PlcBackupFormat;
01038
01039   ///
01040   /// Export success state.
01041
01042   typedef enum TPlcPlcExportSuccess
01043   {
01044     exsSuccess             = 0,          ///< success
01045     exsFailed              = 1,          ///< failed
01046     exsAborted             = 2,          ///< aborted
01047     exsLowDiscSpace        = 3,          ///< low disc space
01048     exsNoUserRights        = 4,          ///< no user rights
01049     exsQueueSizeReached    = 5,          ///< queue size reached
01050     exsConnectionError     = 6,          ///< connection error
01051     exsUnknown             = 0x7fffffff
01052   } PlcExportSuccess;
01053
01054   ///
01055   /// Export abort flag.
01056
01057   typedef enum TPlcPlcExportAbort
01058   {
01059     exaUserAbort           = 0,          ///< user abort
01060     exaLowDiscSpace        = 1,          ///< low disc space
01061     exaNoUserRights        = 2,          ///< no user rights
01062     exaError               = 3,          ///< error
01063     exaUnknown             = 0x7fffffff
01064   } PlcExportAbort;
01065
01066   ///
01067   /// Position query status.
01068
01069   typedef enum TPlcPlcLpsStatus
01070   {
01071     lstPositionOK          = 0,          ///< tag and position is valid
01072     lstUnknownArea         = 1,          ///< tag is valid but position is not known
01073     lstLastPosition        = 2,          ///< tag is valid but position is last known position
01074     lstInvalidID           = 3,          ///< tag is invalid
01075     lstError               = 4,          ///< system error or server not connected
01076     lstUnknown             = 0x7fffffff
01077   } PlcLpsStatus;
01078
01079   ///
01080   /// Scene store modification type.
01081
01082   typedef enum TPlcPlcSceneStoreModificationType
01083   {
01084     smtCreate              = 0,          ///< create
01085     smtOpen                = 1,          ///< open
01086     smtDisplay             = 2,          ///< display
01087     smtClose               = 3,          ///< close
01088     smtDelete              = 4,          ///< delete
01089     smtUnknown             = 0x7fffffff
01090   } PlcSceneStoreModificationType;
01091
01092   ///
01093   /// G-Tect alarm reason.
01094
01095   typedef enum TPlcGTectSceneAlarmReason
01096   {
01097     garViewFieldObservation = 0,          ///< view field observation
01098     garContrast            = 1,          ///< contrast
01099     garUnknown             = 0x7fffffff
01100   } GTectSceneAlarmReason;
01101
01102   ///
01103   /// G-Tect client VCA type
01104
01105   typedef enum TPlcGTectClientVCAType
01106   {
01107     gvtClientPrivacyMasking = 0,          ///< client privacy masking
01108     gvtMotionPrivacy       = 1,          ///< motion privacy
01109     gvtUnknown             = 0x7fffffff
01110   } GTectClientVCAType;
01111
01112   ///
01113   /// Lenel access result.
01114
01115   typedef enum TPlcLenelAccessResult
01116   {
01117     larOther               = 0,          ///< access other
01118     larlUnknown            = 1,          ///< access unknown
01119     larGranted             = 2,          ///< access granted
01120     larDenied              = 3,          ///< access denied
01121     larNotApplicable       = 4,          ///< not applicable
01122     larUnknown             = 0x7fffffff
01123   } LenelAccessResult;
01124
01125   ///
01126   /// Lenel event type.
01127
01128   typedef enum TPlcLenelEventType
01129   {
01130     letAccessGranted       = 0,          ///< access granted
01131     letAccessDenied        = 1,          ///< access denied
01132     letDuress              = 2,          ///< duress
01133     letAreaAPB             = 3,          ///< area APB
01134     letSystem              = 4,          ///< system
01135     letAsset               = 5,          ///< asset
01136     letHostMessages        = 6,          ///< host messages
01137     letFireSeven           = 7,          ///< Fire
01138     letFireEight           = 8,          ///< Fire
01139     letFireNine            = 9,          ///< Fire
01140     letIntercom            = 10,          ///< intercom
01141     letVideo               = 11,          ///< video
01142     letTransmitter         = 12,          ///< transmitter
01143     letBiometric           = 18,          ///< biometric
01144     letTrouble             = 19,          ///< trouble
01145     letDigitize            = 20,          ///< digitize
01146     letBurglary            = 21,          ///< burglary
01147     letTemperature         = 22,          ///< temperature
01148     letGas                 = 23,          ///< gas
01149     letRelaySounder        = 24,          ///< relay/sounder
01150     letMedical             = 25,          ///< medical
01151     letWater               = 26,          ///< water
01152     letC900                = 27,          ///< C900
01153     letOpenClose           = 28,          ///< open/close
01154     letMuster              = 29,          ///< muster
01155     letGeneric             = 30,          ///< generic
01156     letPointofSale         = 31,          ///< point of sale
01157     letPortableProgrammer  = 32,          ///< portable programmer
01158     letUnknown             = 0x7fffffff
01159   } LenelEventType;
01160
01161   ///
01162   /// Lenel event ID.
01163
01164   typedef enum TPlcLenelEventID
01165   {
01166     leiAccessGranted       = 1,          ///< access granted
01167     leiAccessGrantedonFacilityCode = 2,          ///< access granted on facility code
01168     leiAccessGrantedNoEntryMade = 3,          ///< access granted no entry made
01169     leiAccessGrantedonFacilityCodeNoEntryMade = 4,          ///< access granted on facility code, no entry made
01170     leiInvalidCardFormat   = 6,          ///< invalid card format
01171     leiDeniedCountExceeded = 7,          ///< denied count exceeded
01172     leiDeniedPINOnlyRequest = 8,          ///< denied, pin only request
01173     leiInvalidFacilityCode = 9,          ///< invalid facility code
01174     leiInvalidBadge        = 10,          ///< invalid badge
01175     leiInvalidIssueCode    = 11,          ///< invalid issue code
01176     leiInvalidPINNumber    = 12,          ///< invalid pin number
01177     leiInvalidAccessLevel  = 13,          ///< invalid access level
01178     leiInactiveBadge       = 14,          ///< inactive badge
01179     leiDeniedReaderExcluded = 15,          ///< denied, reader excluded
01180     leiDeniedNoCommandAuthority = 16,          ///< denied, no command authority
01181     leiDeniedUnMaskActiveZonesinGroup = 17,          ///< denied unmask - active zones in group
01182     leiUseLimitExceeded    = 18,          ///< use limit exceeded
01183     leiAccessGrantedUnderDuress = 20,          ///< access granted under duress
01184     leiAccessDeniedUnderDuress = 21,          ///< access denied under duress
01185     leiAccessGrantedUnderDuressNoEntryMade = 22,          ///< access granted under duress - no entry made
01186     leiAntiPassbackViolation = 23,          ///< anti-passback violation
01187     leiAreaLimitExceeded   = 24,          ///< area limit exceeded
01188     leiTimeoutExceededNoSecondCard = 25,          ///< timeout exceeded - no second card
01189     leiAreaClosed          = 26,          ///< area closed
01190     leiAccessGrantedAntiPassbackUsed = 27,          ///< access granted - anti-passback used
01191     leiAccessGrantedAntiPassbackNotUsed = 28,          ///< access granted - anti-passback not used
01192     leiAntiPassbackInvalidExitReader = 29,          ///< anti-passback invalid exit reader
01193     leiAntiPassbackInvalidEntryReader = 30,          ///< anti-passback invalid entry reader
01194     leiNotConfigured       = 33,          ///< not configured
01195     leiAlarmCanceled       = 34,          ///< alarm canceled
01196     leiAlarmActive         = 35,          ///< alarm active
01197     leiDoorForcedOpen      = 41,          ///< door forced open
01198     leiDoorForcedOpenCanceled = 42,          ///< door forced open canceled
01199     leiDoorHeldOpen        = 43,          ///< door held open
01200     leiDoorHeldOpenCanceled = 44,          ///< door held open canceled
01201     leiReaderInputTamper   = 47,          ///< reader input tamper
01202     leiReaderInputTamperCanceled = 48,          ///< reader input tamper canceled
01203     leiDoorContactTamper   = 49,          ///< door contact tamper
01204     leiDoorContactTamperCanceled = 50,          ///< door contact tamper canceled
01205     leiCabinetTamper       = 51,          ///< cabinet tamper
01206     leiCanceledCabinetTamper = 52,          ///< canceled cabinet tamper
01207     leiPowerFailure        = 53,          ///< power failure
01208     leiCanceledPowerFailure = 54,          ///< canceled power failure
01209     leiRelayContactActivated = 86,          ///< relay contact activated
01210     leiRelayContactDeactivated = 87,          ///< relay contact deactivated
01211     leiCommunicationsLost  = 109,          ///< communications lost
01212     leiCommunicationsRestored = 110,          ///< communications restored
01213     leiLocalIOExecutedFunctionList = 111,          ///< local i/o executed function list
01214     leiFireAlarmIn         = 220,          ///< fire alarm in
01215     leiFireAlarmOut        = 221,          ///< fire alarm out
01216     leiFireAlarmAcknowledge = 222,          ///< fire alarm acknowledge
01217     leiFireAlarmBlockAcknowledge = 223,          ///< fire alarm block acknowledge
01218     leiCalltoaBusySubscriber = 760,          ///< call to a busy subscriber
01219     leiCalltoaPrivateSubscriber = 761,          ///< call to a private subscriber
01220     leiCalltoanOpenSubscriber = 762,          ///< call to an open subscriber
01221     leiCallDisconnected    = 763,          ///< call disconnected
01222     leiIntercomFunction    = 764,          ///< intercom function
01223     leiTroubleIn           = 765,          ///< trouble in
01224     leiTroubleOut          = 766,          ///< trouble out
01225     leiTroubleAcknowledge  = 767,          ///< trouble acknowledge
01226     leiDeniedLowBattery    = 801,          ///< denied low battery
01227     leiReaderModeFacilityCode = 802,          ///< reader mode facility code
01228     leiReaderModeCardOnly  = 803,          ///< reader mode card only
01229     leiReaderModeFirstCardUnlock = 804,          ///< reader mode first card unlock
01230     leiReaderModeUnlocked  = 805,          ///< reader mode unlocked
01231     leiReaderModeLocked    = 806,          ///< reader mode locked
01232     leiBiometricMismatch   = 812,          ///< biometric mismatch
01233     leiInputMasked         = 831,          ///< input masked
01234     leiInputUnmasked       = 832,          ///< input unmasked
01235     leiDoorForcedOpenMasked = 833,          ///< door forced open masked
01236     leiDoorForcedOpenUnmasked = 834,          ///< door forced open unmasked
01237     leiDoorHeldOpenMasked  = 835,          ///< door held open masked
01238     leiDoorHeldOpenUnmasked = 836,          ///< door held open unmasked
01239     leiReaderModePinorCard = 837,          ///< reader mode pin or card
01240     leiReaderModeCardandPin = 838,          ///< reader mode card and pin
01241     leiAcceptedBiometricScore = 839,          ///< accepted biometric score
01242     leiRejectedBiometricScore = 840,          ///< rejected biometric score
01243     leiNoBiometricTemplateData = 841,          ///< no biometric template data
01244     leiPanelOptionsMismatch = 842,          ///< panel options mismatch
01245     leiAccessGrantedReaderUnlocked = 843,          ///< access granted: reader unlocked
01246     leiAccessDeniedReaderLocked = 844,          ///< access denied: reader locked
01247     leiMaxCardholdersReached = 845,          ///< max cardholders reached
01248     leiMaxAssetsReached    = 846,          ///< max assets reached
01249     leiAccessGrantedGenral = 847,          ///< access granted
01250     leiAccessDeniedGeneral = 848,          ///< access denied
01251     leiAccessDeniedDoorSecured = 849,          ///< access denied door secured
01252     leiAccessDeniedInterlock = 850,          ///< access denied interlock
01253     leiAccessDeniedPassback = 851,          ///< access denied passback
01254     leiAccessDeniedUnauthorizedArmingState = 852,          ///< access denied unauthorized arming state
01255     leiAccessDeniedUnauthorizedEntryLevel = 853,          ///< access denied unauthorized entry level
01256     leiAccessDeniedUnauthorizedTime = 854,          ///< access denied unauthorized time
01257     leiSchedulerActionFailed = 1502,          ///< scheduler action failed
01258     leiSchedulerActionExecuted = 1503,          ///< scheduler action executed
01259     leiGuardTourActionFailed = 1504,          ///< guard tour action failed
01260     leiGuardTourActionExecuted = 1505,          ///< guard tour action executed
01261     leiGlobalLinkageActionFailed = 1506,          ///< global linkage action failed
01262     leiGlobalLinkageActionExecuted = 1507,          ///< global linkage action executed
01263     leiDeniedNoHostApproval = 1508,          ///< denied - no host approval
01264     leiDeniedUnauthorizedAssets = 1509,          ///< denied - unauthorized assets
01265     leiFirstCardUnlockModeEnabled = 1542,          ///< first card unlock mode enabled
01266     leiFirstCardUnlockModeDisabled = 1543,          ///< first card unlock mode disabled
01267     leiExtendedHeldOpenModeEnabled = 1544,          ///< extended held open mode enabled
01268     leiExtendedHeldOpenModeDisabled = 1545,          ///< extended held open mode disabled
01269     leiCipherModeEnabled   = 1546,          ///< cipher mode enabled
01270     leiCipherModeDisabled  = 1547,          ///< cipher mode disabled
01271     leiBiometricVerifyModeEnabled = 1548,          ///< biometric verify mode enabled
01272     leiBiometricVerifyModeDisabled = 1549,          ///< biometric verify mode disabled
01273     leiAccessDeniedNoBiometricTemplate = 1550,          ///< access denied: no biometric template
01274     leiAccessDeniedBiometricReaderOffline = 1551,          ///< access denied: biometric reader offline
01275     leiExtendedHeldCommandDenied = 1552,          ///< extended held command denied
01276     leiExtendedHeldCommandSetFromReader = 1553,          ///< extended held command set from reader
01277     leiIncomingCall        = 1554,          ///< incoming call
01278     leiTroubleReport       = 1555,          ///< trouble report
01279     leiTestReport          = 1556,          ///< test report
01280     leiAcknowledgmentActionExecuted = 1785,          ///< acknowledgment action executed
01281     leiAcknowledgmentActionFailed = 1786,          ///< acknowledgment action failed
01282     leiAlarmMonitoringActionGroupExecuted = 1787,          ///< alarm monitoring action group executed
01283     leiAlarmMonitoringActionGroupFailed = 1788,          ///< alarm monitoring action group failed
01284     leiSmartCardAuthenticationFailed = 1789,          ///< smart card authentication failed
01285     leiRinging             = 1794,          ///< ringing
01286     leiCallFailed          = 1795,          ///< call failed
01287     leiHold                = 1796,          ///< hold
01288     leiRetrieved           = 1797,          ///< retrieved
01289     leiInitiated           = 1798,          ///< initiated
01290     leiGenericEvent        = 1799,          ///< generic event
01291     leiInputAlarmed        = 1808,          ///< input alarmed
01292     leiInputNormal         = 1809,          ///< input normal
01293     leiInputLowLow         = 1810,          ///< input low low
01294     leiInputLow            = 1811,          ///< input low
01295     leiInputHigh           = 1812,          ///< input high
01296     leiInputHighHigh       = 1813,          ///< input high high
01297     leiDoorOpen            = 1887,          ///< door open
01298     leiDoorClose           = 1888,          ///< door close
01299     leiCommunicationsWithHostLost = 1889,          ///< communications with host lost
01300     leiCommunicationsWithHostRestored = 1890,          ///< communications with host restored
01301     leiCallEnded           = 1891,          ///< call ended
01302     leiCallEstablished     = 1892,          ///< call established
01303     leiUnansweredCall      = 1893,          ///< unanswered call
01304     leiCallTransferred     = 1894,          ///< call transferred
01305     leiCallConferenced     = 1895,          ///< call conferenced
01306     leiAccessDeniedEscortTimeoutExpired = 1896,          ///< access denied: escort timeout expired
01307     leiCallQueued          = 1910,          ///< call queued
01308     leiAccessDeniedAreaOccupied = 1911,          ///< access denied: area occupied
01309     leiAccessDeniedNoOccupantApproval = 1912,          ///< access denied: no occupant approval
01310     leiDeniedBadgeNotinPanel = 1914,          ///< denied, badge not in panel
01311     leiIntercomExchangeFailure = 1915,          ///< intercom exchange failure
01312     leiIntrusionCommandDenied = 1920,          ///< intrusion command denied
01313     leiIntrusionCommandAccepted = 1921,          ///< intrusion command accepted
01314     leiAlarmMaskGroupArmed = 1922,          ///< alarm mask group armed
01315     leiAlarmMaskGroupDisarmed = 1923,          ///< alarm mask group disarmed
01316     leiAlarmMaskGroupForceArmed = 1924,          ///< alarm mask group force armed
01317     leiAlarmMaskGroupMaskCountIncremented = 1925,          ///< alarm mask group mask count incremented
01318     leiAlarmMaskGroupMaskCountDecremented = 1926,          ///< alarm mask group mask count decremented
01319     leiAlarmMaskGroupArmingFailureActivePoints = 1927,          ///< alarm mask group arming failure, active points
01320     leiAccessDeniedAreaEmpty = 1928,          ///< access denied: area empty
01321     leiElevatorTerminalModeDefaultFloororUserEntryofDestinationFloor = 1936,          ///< elevator terminal mode default floor or user entry of destination floor
01322     leiUnknownElevatorTerminal = 1937,          ///< unknown elevator terminal
01323     leiOpenDoorCommandIssuedDoorUsed = 1938,          ///< open door command issued - door used
01324     leiOpenDoorCommandIssuedDoorNotUsed = 1939,          ///< open door command issued - door not used
01325     leiRequesttoExitDoorUsed = 1940,          ///< request to exit - door used
01326     leiRequesttoExitDoorNotUsed = 1941,          ///< request to exit - door not used
01327     leiElevatorTerminalModeDefaultFloor = 1943,          ///< elevator terminal mode default floor
01328     leiElevatorTerminalModeAccesstoAuthorizedFloors = 1944,          ///< elevator terminal mode access to authorized floors
01329     leiElevatorTerminalModeUserEntryofDestinationFloor = 1945,          ///< elevator terminal mode user entry of destination floor
01330     leiReaderOffline       = 1968,          ///< reader offline
01331     leiReaderOfflineRestored = 1969,          ///< reader offline restored
01332     leiUnknownUserCommand  = 1978,          ///< unknown user command
01333     leiAccessDeniedAssetRequired = 1984,          ///< access denied: asset required
01334     leiAccessDeniedSpecial = 2289,          ///< access denied
01335     leiUnknown             = 0x7fffffff
01336   } LenelEventID;
01337
01338   ///
01339   /// Specifies the type of the io device.
01340
01341   typedef enum TPlcIODeviceType
01342   {
01343     dioDeviceTypeMIO       = 0,          ///< MIO84
01344     dioDeviceTypeIOI43     = 1,          ///< IOI43
01345     dioUnknown             = 0x7fffffff
01346   } IODeviceType;
01347
01348   ///
01349   /// Traffic direction.
01350
01351   typedef enum TPlcTrafficDirection
01352   {
01353     tfdIn                  = 0,          ///< in
01354     tfdOut                 = 1,          ///< out
01355     tfdUnspecified         = 2,          ///< unknown
01356     tfdUnknown             = 0x7fffffff
01357   } TrafficDirection;
01358
01359   ///
01360   /// PP alarm state.
01361
01362   typedef enum TPlcPPAlarmState
01363   {
01364     pasNormal              = 0,          ///< normal
01365     pasAlarm               = 1,          ///< alarm
01366     pasUnknown             = 0x7fffffff
01367   } PPAlarmState;
01368
01369   ///
01370   /// PP cable kind.
01371
01372   typedef enum TPlcPPCableKind
01373   {
01374     pckCableA              = 0,          ///< cable A
01375     pckCableB              = 1,          ///< cable B
01376     pckUnknown             = 0x7fffffff
01377   } PPCableKind;
01378
01379   ///
01380   /// PP sensor kind.
01381
01382   typedef enum TPlcPPSensorKind
01383   {
01384     pskCableAFault         = 0,          ///< cable A fault
01385     pskCableBFault         = 1,          ///< cable B fault
01386     pskTamper              = 2,          ///< tamper
01387     pskTrap                = 3,          ///< trap
01388     pskSensor              = 4,          ///< sensor
01389     pskPath                = 5,          ///< path
01390     pskAux                 = 6,          ///< aux
01391     pskService             = 7,          ///< service
01392     pskUnknown             = 0x7fffffff
01393   } PPSensorKind;
01394
01395   ///
01396   /// IP switch operation.
01397
01398   typedef enum TPlcIPSwitchOps
01399   {
01400     ipoPOEOn               = 0,          ///< PoE on
01401     ipoPOEOff              = 1,          ///< PoE off
01402     ipoPOEReset            = 2,          ///< PoE reset
01403     ipoPOEDelayedReset     = 3,          ///< PoE delayed reset
01404     ipoUnknown             = 0x7fffffff
01405   } IPSwitchOps;
01406
01407
01408   ///
01409   /// Available parameter types
01410
01411   enum GscParameterType
01412   {
01413     pt___int32             = 0,          ///< 32 bit integer values
01414     pt___int64             = 1,          ///< 64 bit integer values
01415     pt_TGLibDateTime       = 2,          ///< date / time values
01416     pt_string              = 3,          ///< ANSI strings (0-terminated)
01417     pt_widestring          = 4,          ///< UNICODE strings (0-terminated)
01418     pt_bool                = 5,          ///< boolean values
01419     pt_GUID                = 6,          ///< GUID values
01420     pt_TEventTypeID        = 7,          ///< event type struct
01421     pt_TMediaChannelID     = 8,          ///< media channel struct
01422     pt_TResourceID         = 9,          ///< resource ID struct
01423     pt_DigitalInputState   = 10,         ///< State of the digital input contact.
01424     pt_DigitalOutputState  = 11,         ///< State of the digital output contact.
01425     pt_VideoSignalNorm     = 12,         ///< Norm of the video input signal.
01426     pt_VideoSignalType     = 13,         ///< Type of the video input signal.
01427     pt_VideoInterlaceType  = 14,         ///< Interlace kind of the video input signal.
01428     pt_ADArea              = 15,         ///< Activity detection area.
01429     pt_VMDGroup            = 16,         ///< VMD group.
01430     pt_SystemLED           = 17,         ///< System LED.
01431     pt_VideoSensorKind     = 18,         ///< Video sensor type.
01432     pt_UserLoginFailureCode = 20,         ///< User login failure code.
01433     pt_PlcMessageSource    = 21,         ///< Source of the message.
01434     pt_PlcMessageCode      = 24,         ///< Code of the message.
01435     pt_PlcViewerAlarmQueueSelection = 28,         ///< Viewer alarm queue selection mode.
01436     pt_ABCapacityWarning   = 29,         ///< Auto backup capacity monitoring warning.
01437     pt_PlcObtrackObjectStatus = 30,         ///< OBTRACK object status.
01438     pt_PlcObtrackObjectClass = 31,         ///< OBTRACK object class.
01439     pt_PlcDatabaseStatus   = 32,         ///< Database status.
01440     pt_PlcObtrackProcessSize = 33,         ///< OBTRACK process size.
01441     pt_SystemKey           = 34,         ///< GEVISCOPE system key.
01442     pt_VMDCycle            = 35,         ///< VMD measure cycle.
01443     pt_SafebagStep         = 36,         ///< Safebag step.
01444     pt_PlcObtrackCounterType = 37,         ///< OBTRACK counter type.
01445     pt_PlcObtrackExceedingDirection = 38,         ///< OBTRACK exceeding direction.
01446     pt_PlcTunnelAlarmReason = 39,         ///< Tunnel alarm reason.
01447     pt_PlcViewerPlayMode   = 40,         ///< Viewer play mode.
01448     pt_PlcViewerAlarmPlayMode = 43,         ///< Viewer alarm play mode.
01449     pt_PlcViewerAlarmState = 45,         ///< Viewer alarm state notification.
01450     pt_PlcImageExportType  = 47,         ///< Image export type.
01451     pt_PlcDatabaseRing     = 48,         ///< Database ring.
01452     pt_PlcPluginError      = 49,         ///< Plugin error code.
01453     pt_PlcClientType       = 50,         ///< Client type.
01454     pt_PlcFRCNotification  = 52,         ///< FRC notification.
01455     pt_PlcResourceKind     = 54,         ///< PLC resource kind.
01456     pt_PlcResourceChangeKind = 56,         ///< PLC resource change kind.
01457     pt_PlcPOSStatus        = 58,         ///< PLC POS status.
01458     pt_PlcNPRRestriction   = 59,         ///< PLC POS status.
01459     pt_PlcSpecialConstants = 60,         ///< Special constants.
01460     pt_PlcPluginState      = 61,         ///< Plugin state.
01461     pt_PlcPumpStatus       = 62,         ///< PLC pump status.
01462     pt_PlcDayNightMode     = 63,         ///< Day/night mode.
01463     pt_PlcBacklightMode    = 64,         ///< Backlight compensation mode.
01464     pt_PlcSkidataControl   = 65,         ///< SKIDATA control message.
01465     pt_PlcSkidataMsgCodeEntry = 66,         ///< SKIDATA message entry.
01466     pt_PlcSkidataMsgCodeExit = 68,         ///< SKIDATA message exit.
01467     pt_PlcSkidataMsgCodeTransaction = 70,         ///< SKIDATA message transaction.
01468     pt_PlcExportMarker     = 72,         ///< Export marker.
01469     pt_PlcBackupFormat     = 73,         ///< Backup format.
01470     pt_PlcExportSuccess    = 74,         ///< Export success state.
01471     pt_PlcExportAbort      = 75,         ///< Export abort flag.
01472     pt_PlcLpsStatus        = 77,         ///< Position query status.
01473     pt_PlcSceneStoreModificationType = 78,         ///< Scene store modification type.
01474     pt_GTectSceneAlarmReason = 79,         ///< G-Tect alarm reason.
01475     pt_GTectClientVCAType  = 80,         ///< G-Tect client VCA type
01476     pt_LenelAccessResult   = 95,         ///< Lenel access result.
01477     pt_LenelEventType      = 96,         ///< Lenel event type.
01478     pt_LenelEventID        = 99,         ///< Lenel event ID.
01479     pt_IODeviceType        = 90,         ///< Specifies the type of the io device.
01480     pt_TrafficDirection    = 81,         ///< Traffic direction.
01481     pt_PPAlarmState        = 82,         ///< PP alarm state.
01482     pt_PPCableKind         = 83,         ///< PP cable kind.
01483     pt_PPSensorKind        = 84,         ///< PP sensor kind.
01484     pt_IPSwitchOps         = 85,         ///< IP switch operation.
01485     pt_double              = 100,        ///< double value
01486     pt_TPlcRect            = 101,        ///< PLC rect value
01487     pt_Unknown             = 0x7fffffff
01488   };
01489
01490   ///
01491   /// Available parameter views
01492
01493   enum GscParameterView
01494   {
01495     pv_Default             = 0,          ///< default view
01496     pv_UserName            = 1,          ///< parameter represents user name
01497     pv_DeviceType          = 2,          ///< parameter represents device type
01498     pv_DeviceName          = 3,          ///< parameter represents device name
01499     pv_VideoInput          = 4,          ///< parameter represents video input channel
01500     pv_VideoOutput         = 5,          ///< parameter represents video output channel
01501     pv_InputContact        = 6,          ///< parameter represents input contact
01502     pv_OutputContact       = 7,          ///< parameter represents output contact
01503     pv_PTZHead             = 8,          ///< parameter represents PTZ head
01504     pv_TimeRange           = 9,          ///< parameter represents time range
01505     pv_Event               = 10,         ///< parameter represents event type
01506     pv_AudioInput          = 11,         ///< parameter represents audio input channel
01507     pv_AudioOutput         = 12,         ///< parameter represents audio output channel
01508     pv_ADParameterSet      = 13,         ///< parameter represents AD parameter set
01509     pv_VMDParameterSet     = 14,         ///< parameter represents VMD parameter set
01510     pv_WindowsError        = 15,         ///< parameter represents Windows error code
01511     pv_DeviceSubType       = 16,         ///< parameter represents device sub type
01512     pv_ForeignKey          = 17,         ///< parameter represents foreign key
01513     pv_CPAParameterSet     = 18,         ///< parameter represents CPA parameter set
01514     pv_ObtrackParameterSet = 19,         ///< parameter represents OBTRACK parameter set
01515     pv_ABDestination       = 20,         ///< parameter represents auto backup destination
01516     pv_ABSchedule          = 21,         ///< parameter represents auto backup schedule
01517     pv_HardwareModule      = 22,         ///< parameter represents hardware module
01518     pv_CameraProfile       = 23,         ///< parameter represents camera profile
01519     pv_GTectParameterSet   = 24,         ///< parameter represents G-Tect parameter set
01520     pv_ImexDestination     = 25,         ///< parameter represents image export destination
01521     pv_Unknown             = 0x7FFFFFFF
01522   };
01523
01524 #pragma pack (push, 8)
01525   ///
01526   /// Media channel
01527
01528   struct TPlcMediaChannelID
01529   {
01530     __int64          ChannelID;          ///< media channel ID
01531     const wchar_t*   ChannelName;        ///< media channel name
01532     __int32          GlobalNo;           ///< assigned global No
01533 #ifdef _WIN64
01534     unsigned __int32 Reserved;           ///< alignment for 64bit
01535 #endif
01536
01537     TPlcMediaChannelID()
01538     {
01539     }
01540     TPlcMediaChannelID(__int32 aGlobalNo)
01541     {
01542       ChannelID   = 0;
01543       ChannelName = L"";
01544       GlobalNo    = aGlobalNo;
01545 #ifdef _WIN64
01546       Reserved    = 0;
01547 #endif
01548     }
01549     TPlcMediaChannelID(const __int64& aChannelID, const wchar_t* aChannelName, __int32 aGlobalNo)
01550     {
01551       ChannelID   = aChannelID;
01552       ChannelName = aChannelName;
01553       GlobalNo    = aGlobalNo;
01554 #ifdef _WIN64
01555       Reserved    = 0;
01556 #endif
01557     }
01558   };
01559
01560   ///
01561   /// Event type
01562
01563   struct TPlcEventTypeID
01564   {
01565     __int64          EventTypeID;        ///< event type ID
01566     const wchar_t*   EventName;          ///< event name
01567     size_t           Reserved;           ///< reserved, set to 0
01568
01569     TPlcEventTypeID()
01570     {
01571     }
01572     TPlcEventTypeID(const __int64& anEventTypeID, const wchar_t* anEventName)
01573     {
01574       EventTypeID = anEventTypeID;
01575       EventName   = anEventName;
01576       Reserved    = 0;
01577     }
01578   };
01579
01580   ///
01581   /// Resource ID
01582
01583   struct TPlcResourceID
01584   {
01585     GUID             ResourceID;         ///< resource ID
01586     const wchar_t*   ResourceName;       ///< resource name
01587     size_t           Reserved;           ///< reserved, set to 0
01588
01589     TPlcResourceID()
01590     {
01591     }
01592     TPlcResourceID(const GUID& aResourceID, const wchar_t* aResourceName)
01593     {
01594       ResourceID    = aResourceID;
01595       ResourceName  = aResourceName;
01596       Reserved      = 0;
01597     }
01598   };
01599
01600   ///
01601   /// PLC rect
01602
01603   struct TPlcRect
01604   {
01605     __int16          Top;                ///< top
01606     __int16          Left;               ///< left
01607     __int16          Bottom;             ///< bottom
01608     __int16          Right;              ///< right
01609
01610     TPlcRect(__int16 aTop = 0, __int16 aLeft = 0, __int16 aBottom = 0, __int16 aRight = 0)
01611     {
01612       Top    = aTop;
01613       Left   = aLeft;
01614       Bottom = aBottom;
01615       Right  = aRight;
01616     }
01617
01618     bool operator==(const TPlcRect& Other) const
01619     {
01620       return  (Top    == Other.Top)    &&
01621               (Left   == Other.Left)   &&
01622               (Bottom == Other.Bottom) &&
01623               (Right  == Other.Right);
01624     }
01625     bool operator!=(const TPlcRect& Other) const
01626     {
01627       return ! operator==(Other);
01628     }
01629   };
01630 #pragma pack (pop)
01631
01632   /// compatibility definitions
01633   typedef TPlcResourceID TPlcTimeRangeID;
01634
01635   /// update media channel callback
01636   typedef bool (__stdcall *TUpdateMediaChannelID)(void* Object, TPlcMediaChannelID& Info);
01637   /// update event type callback
01638   typedef bool (__stdcall *TUpdateEventTypeID)(void* Object,    TPlcEventTypeID& Info);
01639   /// update resource ID callback
01640   typedef bool (__stdcall *TUpdateResourceID)(void* Object,     GscParameterView ParameterView, TPlcResourceID& Info);
01641   /// update resource ID and channel callback
01642   typedef bool (__stdcall *TUpdateResChannelID)(void* Object,   GscParameterView ParameterView, TPlcResourceID& Info, __int64& Channel);
01643
01644 #pragma pack(push, 4)
01645   /// update callback definition version
01646   const unsigned __int32 TPlcUpdateActionInfoCallbackVersion = 1;
01647
01648   /// update callback definition
01649   struct TPlcUpdateActionInfoCallback
01650   {
01651     unsigned __int32       Version;                  ///< struct version
01652 #ifdef _WIN64
01653     unsigned __int32       Reserved;                 ///< alignment for 64bit
01654 #endif
01655     TUpdateMediaChannelID  UpdateVideoInput;         ///< update video input
01656     TUpdateMediaChannelID  UpdateVideoOutput;        ///< update video output
01657     TUpdateMediaChannelID  UpdateInputContact;       ///< update input contact
01658     TUpdateMediaChannelID  UpdateOutputContact;      ///< update output contact
01659     TUpdateEventTypeID     UpdateEventType;          ///< update event type
01660     TUpdateResourceID      UpdateResource;           ///< update resources like time range, AB schedule, AB destination
01661     TUpdateResChannelID    UpdateParameterSet;       ///< update resources like AD / VMD / CPA / OBTRACK parameter sets
01662   };
01663 #pragma pack (pop)
01664
01665   ///
01666   /// \} // end of group GscPlcBasicTypes
01667
01668   /////////////////////////////////////////////////////////
01669   /// Basic types for event transformation
01670   /////////////////////////////////////////////////////////
01671
01672   /// \addtogroup GscPlcEvents
01673   /// \{
01674
01675 #pragma pack (push, 8)
01676   ///
01677   /// Structure to access action fields as event data fields
01678   struct TPlcActionEventDataRecord
01679   {
01680     unsigned __int32    StructSize;      ///< size of the structure
01681     unsigned __int32    EventDataKind;   ///< data kind
01682
01683     __int64             EventDataID;     ///< primary key of the entry
01684     __int64             EventID;         ///< primary key of the corresponding event
01685     GLib::TGLibDateTime EventDataTime;   ///< entry time stamp
01686
01687     const __int32*      EventInt32_A;    ///< int32 field A
01688     const __int32*      EventInt32_B;    ///< int32 field B
01689     const __int32*      EventInt32_C;    ///< int32 field C
01690     const __int32*      EventInt32_D;    ///< int32 field D
01691
01692     const __int64*      EventInt64_A;    ///< int64 field A
01693     const __int64*      EventInt64_B;    ///< int64 field B
01694     const __int64*      EventInt64_C;    ///< int64 field C
01695     const __int64*      EventInt64_D;    ///< int64 field D
01696
01697     const double*       EventDouble_A;   ///< float field A
01698     const double*       EventDouble_B;   ///< float field B
01699
01700     const GLib::TGLibDateTime* EventTime_A;     ///< date time field A
01701     const GLib::TGLibDateTime* EventTime_B;     ///< date time field B
01702
01703     size_t              EventString_A_Size;     ///< size of the string
01704     const wchar_t*      EventString_A;          ///< text field A
01705
01706     size_t              EventString_B_Size;     ///< size of the string
01707     const wchar_t*      EventString_B;          ///< text field B
01708
01709     size_t              EventDataSize;          ///< size of the BLOB
01710     const void*         EventData;              ///< BLOB
01711
01712     TPlcActionEventDataRecord()
01713     {
01714       StructSize = sizeof(TPlcActionEventDataRecord);
01715     }
01716
01717     void Clear()
01718     {
01719       EventDataKind = 0;
01720
01721       EventDataID   =
01722       EventID       = 0;
01723
01724       EventInt32_A =
01725       EventInt32_B =
01726       EventInt32_C =
01727       EventInt32_D = 0;
01728
01729       EventInt64_A =
01730       EventInt64_B =
01731       EventInt64_C =
01732       EventInt64_D = 0;
01733
01734       EventDouble_A =
01735       EventDouble_B = 0;
01736
01737       EventTime_A =
01738       EventTime_B = 0;
01739
01740       EventString_A_Size =
01741       EventString_B_Size = 0;
01742
01743       EventString_A =
01744       EventString_B = 0;
01745
01746       EventDataSize = 0;
01747       EventData     = 0;
01748     }
01749   };
01750 #pragma pack (pop)
01751
01752   ///
01753   /// \} // end of group GscPlcEvents
01754
01755   /////////////////////////////////////////////////////////
01756   /// Basic types for enumerations
01757   /////////////////////////////////////////////////////////
01758
01759   /// \addtogroup GscPlcBasicEnumeration
01760   /// \{
01761
01762   ///
01763   /// Check the parameter type is an enumerable type.
01764   /// These types have text representation for values.
01765   ///
01766   /// @param [in] ParameterType enumeration value of parameter type.
01767   /// @return     \c true for enumeration type and \c false otherwise.
01768   inline bool IsGscEnumType(GscParameterType ParameterType)
01769   {
01770     if (ParameterType == pt_bool)                return true;
01771     if (ParameterType == pt_DigitalInputState)   return true;
01772     if (ParameterType == pt_DigitalOutputState)  return true;
01773     if (ParameterType == pt_VideoSignalNorm)     return true;
01774     if (ParameterType == pt_VideoSignalType)     return true;
01775     if (ParameterType == pt_VideoInterlaceType)  return true;
01776     if (ParameterType == pt_ADArea)              return true;
01777     if (ParameterType == pt_VMDGroup)            return true;
01778     if (ParameterType == pt_SystemLED)           return true;
01779     if (ParameterType == pt_VideoSensorKind)     return true;
01780     if (ParameterType == pt_UserLoginFailureCode) return true;
01781     if (ParameterType == pt_PlcMessageSource)    return true;
01782     if (ParameterType == pt_PlcMessageCode)      return true;
01783     if (ParameterType == pt_PlcViewerAlarmQueueSelection) return true;
01784     if (ParameterType == pt_ABCapacityWarning)   return true;
01785     if (ParameterType == pt_PlcObtrackObjectStatus) return true;
01786     if (ParameterType == pt_PlcObtrackObjectClass) return true;
01787     if (ParameterType == pt_PlcDatabaseStatus)   return true;
01788     if (ParameterType == pt_PlcObtrackProcessSize) return true;
01789     if (ParameterType == pt_SystemKey)           return true;
01790     if (ParameterType == pt_VMDCycle)            return true;
01791     if (ParameterType == pt_SafebagStep)         return true;
01792     if (ParameterType == pt_PlcObtrackCounterType) return true;
01793     if (ParameterType == pt_PlcObtrackExceedingDirection) return true;
01794     if (ParameterType == pt_PlcTunnelAlarmReason) return true;
01795     if (ParameterType == pt_PlcViewerPlayMode)   return true;
01796     if (ParameterType == pt_PlcViewerAlarmPlayMode) return true;
01797     if (ParameterType == pt_PlcViewerAlarmState) return true;
01798     if (ParameterType == pt_PlcImageExportType)  return true;
01799     if (ParameterType == pt_PlcDatabaseRing)     return true;
01800     if (ParameterType == pt_PlcPluginError)      return true;
01801     if (ParameterType == pt_PlcClientType)       return true;
01802     if (ParameterType == pt_PlcFRCNotification)  return true;
01803     if (ParameterType == pt_PlcResourceKind)     return true;
01804     if (ParameterType == pt_PlcResourceChangeKind) return true;
01805     if (ParameterType == pt_PlcPOSStatus)        return true;
01806     if (ParameterType == pt_PlcNPRRestriction)   return true;
01807     if (ParameterType == pt_PlcSpecialConstants) return true;
01808     if (ParameterType == pt_PlcPluginState)      return true;
01809     if (ParameterType == pt_PlcPumpStatus)       return true;
01810     if (ParameterType == pt_PlcDayNightMode)     return true;
01811     if (ParameterType == pt_PlcBacklightMode)    return true;
01812     if (ParameterType == pt_PlcSkidataControl)   return true;
01813     if (ParameterType == pt_PlcSkidataMsgCodeEntry) return true;
01814     if (ParameterType == pt_PlcSkidataMsgCodeExit) return true;
01815     if (ParameterType == pt_PlcSkidataMsgCodeTransaction) return true;
01816     if (ParameterType == pt_PlcExportMarker)     return true;
01817     if (ParameterType == pt_PlcBackupFormat)     return true;
01818     if (ParameterType == pt_PlcExportSuccess)    return true;
01819     if (ParameterType == pt_PlcExportAbort)      return true;
01820     if (ParameterType == pt_PlcLpsStatus)        return true;
01821     if (ParameterType == pt_PlcSceneStoreModificationType) return true;
01822     if (ParameterType == pt_GTectSceneAlarmReason) return true;
01823     if (ParameterType == pt_GTectClientVCAType)  return true;
01824     if (ParameterType == pt_LenelAccessResult)   return true;
01825     if (ParameterType == pt_LenelEventType)      return true;
01826     if (ParameterType == pt_LenelEventID)        return true;
01827     if (ParameterType == pt_IODeviceType)        return true;
01828     if (ParameterType == pt_TrafficDirection)    return true;
01829     if (ParameterType == pt_PPAlarmState)        return true;
01830     if (ParameterType == pt_PPCableKind)         return true;
01831     if (ParameterType == pt_PPSensorKind)        return true;
01832     if (ParameterType == pt_IPSwitchOps)         return true;
01833     return false;
01834   }
01835
01836 #pragma pack (push, 4)
01837   /// action class info
01838   struct TGscActionClassInfo
01839   {
01840     GscActionClass     ActionClass;      ///< action class
01841 #ifdef _WIN64
01842     unsigned __int32   Reserved0;        ///< alignment for 64bit
01843 #endif
01844     const char*        NameA;            ///< internal name as ANSI string
01845     const wchar_t*     NameW;            ///< internal name as UNICODE string
01846     size_t             Reserved;         ///< reserved, set to 0
01847   };
01848
01849   /// action class plain info
01850   struct TGscActionClassPlainInfo: public TGscActionClassInfo
01851   {
01852     const char*        PlainNameA;       ///< plain name as ANSI string
01853     const char*        PlainNameU;       ///< plain name as ANSI string using UTF8 encoding
01854     const wchar_t*     PlainNameW;       ///< plain name as UNICODE string
01855     const char*        DescriptionA;     ///< description as ANSI string
01856     const char*        DescriptionU;     ///< description as ANSI string using UTF8 encoding
01857     const wchar_t*     DescriptionW;     ///< description as UNICODE string
01858   };
01859
01860   /// setup visibility mask
01861   const unsigned __int32 PLC_DISABLE_ON_MATCH = 1;
01862   /// setup visibility mask
01863   const unsigned __int32 PLC_DISABLE_MATCH_BY = 2;
01864
01865   /// action info
01866   struct TGscActionInfo
01867   {
01868     GscActionClass     ActionClass;      ///< action class
01869     GscActionCode      ActionCode;       ///< action code
01870     unsigned __int32   ActionSetupMask;  ///< setup visibility mask
01871     unsigned __int32   NumberOfParameters;  ///< number of parameters
01872     const char*        NameA;            ///< internal name as ANSI string
01873     const wchar_t*     NameW;            ///< internal name as UNICODE string
01874
01875     bool DisableOnMatch() const { return (ActionSetupMask & PLC_DISABLE_ON_MATCH) != 0; }
01876     bool DisableMatchBy() const { return (ActionSetupMask & PLC_DISABLE_MATCH_BY) != 0; }
01877   };
01878
01879   /// action plain info
01880   struct TGscActionPlainInfo: public TGscActionInfo
01881   {
01882     const char*        PlainNameA;       ///< plain name as ANSI string
01883     const char*        PlainNameU;       ///< plain name as ANSI string using UTF8 encoding
01884     const wchar_t*     PlainNameW;       ///< plain name as UNICODE string
01885     const char*        DescriptionA;     ///< description as ANSI string
01886     const char*        DescriptionU;     ///< description as ANSI string using UTF8 encoding
01887     const wchar_t*     DescriptionW;     ///< description as UNICODE string
01888   };
01889
01890   /// parameter info
01891   struct TGscParameterInfo
01892   {
01893     GscParameterType   ParameterType;    ///< parameter type
01894     GscParameterView   ParameterView;    ///< parameter view (role)
01895     unsigned __int32   ParameterSetupMask;  ///< setup visibility mask
01896     unsigned __int32   Reserved;            ///< reserved, set to 0
01897     const char*        NameA;            ///< internal name as ANSI string
01898     const wchar_t*     NameW;            ///< internal name as UNICODE string
01899
01900     bool DisableOnMatch() const { return (ParameterSetupMask & PLC_DISABLE_ON_MATCH) != 0; }
01901     bool DisableMatchBy() const { return (ParameterSetupMask & PLC_DISABLE_MATCH_BY) != 0; }
01902   };
01903
01904   /// parameter plain info
01905   struct TGscParameterPlainInfo: public TGscParameterInfo
01906   {
01907     const char*        PlainNameA;       ///< plain name as ANSI string
01908     const char*        PlainNameU;       ///< plain name as ANSI string using UTF8 encoding
01909     const wchar_t*     PlainNameW;       ///< plain name as UNICODE string
01910     const char*        DescriptionA;     ///< description as ANSI string
01911     const char*        DescriptionU;     ///< description as ANSI string using UTF8 encoding
01912     const wchar_t*     DescriptionW;     ///< description as UNICODE string
01913   };
01914
01915   /// enum value info
01916   struct TGscEnumInfo
01917   {
01918     GscParameterType   EnumType;         ///< enum type
01919     __int32            EnumValue;        ///< enum value
01920     const char*        NameA;            ///< internal name as ANSI string
01921     const wchar_t*     NameW;            ///< internal name as UNICODE string
01922   };
01923
01924   /// enum value plain info
01925   struct TGscEnumPlainInfo: public TGscEnumInfo
01926   {
01927     const char*        PlainNameA;       ///< plain name as ANSI string
01928     const char*        PlainNameU;       ///< plain name as ANSI string using UTF8 encoding
01929     const wchar_t*     PlainNameW;       ///< plain name as UNICODE string
01930     size_t             Reserved;         ///< reserved, set to 0
01931   };
01932 #pragma pack (pop)
01933
01934   ///
01935   /// \} // end of group GscPlcBasicEnumeration
01936
01937 #ifdef __cplusplus
01938 };
01939 #endif
01940
01941 #endif


GSC actions: actions.txt File Reference

  • File List
  • File Members

actions.txt File Reference

Detailed Description

Action documentation.

Definition in file actions.txt.


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CGscAction Member List

This is the complete list of members for CGscAction, including all inherited members.
CloneHandle() const | CGscAction | [inline]
CloseHandle() | CGscMessage | [inline]
CreateFromBinBuffer(const void *Buffer, unsigned int BufferSize, unsigned int *ReadChars=0) | CGscAction | [inline, static]
CGscMessage::CreateFromBinBuffer(const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
CreateFromTextBuffer(const char *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscAction | [inline, static]
CreateFromTextBuffer(const wchar_t *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscAction | [inline, static]
CGscMessage::CreateFromTextBuffer(const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
CGscMessage::CreateFromTextBuffer(const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
CreateMatchActionFromTemplate() const | CGscAction | [inline]
DisableInternalInEventData() | CGscMessage | [inline]
DisableResourceUpdate() | CGscMessage | [inline]
DuplicateHandle() | CGscMessage | [inline]
EqualTo(ConstHGscMessage aMessage) const | CGscMessage | [inline]
GetActionClass() const | CGscAction | [inline]
GetActionCode() const | CGscAction | [inline]
GetActionCodeByIndex(unsigned int Index) | CGscAction | [inline, static]
GetActionEventData(TPlcActionEventDataRecord &EventRecord, bool &DataComplete) const | CGscAction | [inline]
GetActionNameA() const | CGscAction | [inline]
GetActionNameW() const | CGscAction | [inline]
GetActionPlainNameA() const | CGscAction | [inline]
GetActionPlainNameW() const | CGscAction | [inline]
GetForeignKey() const | CGscAction | [inline]
GetGenericInt32Parameter() const | CGscAction | [inline]
GetInputContact() const | CGscAction | [inline]
GetInternalData() const | CGscMessage | [inline]
GetInternalIndex() const | CGscMessage | [inline]
GetInternalIndexByCode(GscActionCode Code) | CGscAction | [inline, static]
GetMessageClass() const | CGscMessage | [inline]
GetMessageFlags() const | CGscMessage | [inline]
GetOutputContact() const | CGscAction | [inline]
GetProperties() | CGscAction | [inline]
GetProperty(const wchar_t *Key) | CGscAction | [inline]
GetReferenceCounter() const | CGscMessage | [inline]
GetVideoInput() const | CGscAction | [inline]
GetVideoOutput() const | CGscAction | [inline]
GetWindowsClientInfo(const wchar_t *&localHostName, const PlcClientType *&localClientType, const wchar_t *&localUserName) | CGscAction | [inline]
operator delete(void *Ptr) | CGscAction | [inline]
operator!=(ConstHGscMessage aMessage) const | CGscMessage | [inline]
operator==(ConstHGscMessage aMessage) const | CGscMessage | [inline]
RestoreActionFromEventData(const TPlcActionEventDataRecord &EventRecord) | CGscAction | [inline, static]
SetInternalData(void *Data) | CGscMessage | [inline]
SetMessageFlags(unsigned __int32 Flags) | CGscMessage | [inline]
SetProperty(const wchar_t *Key, const wchar_t *Value) | CGscAction | [inline]
StoreToBinBuffer(void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten=0) const | CGscMessage | [inline]
StoreToTextBuffer(char *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const | CGscMessage | [inline]
StoreToTextBuffer(wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const | CGscMessage | [inline]
UpdateActionInfo(void *anObject, const TPlcUpdateActionInfoCallback &Callback) | CGscAction | [inline]
UpdateWindowsClientInfo(const wchar_t *localHostName, const PlcClientType localClientType, const wchar_t *localUserName) | CGscAction | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CGscMatchAction Member List

This is the complete list of members for CGscMatchAction, including all inherited members.
CloneHandle() const | CGscMatchAction | [inline]
CloseHandle() | CGscMessage | [inline]
CreateActionFromTemplate(ConstHGscAction anAction) const | CGscMatchAction | [inline]
CreateFromBinBuffer(const void *Buffer, unsigned int BufferSize, unsigned int *ReadChars=0) | CGscMatchAction | [inline, static]
CGscMessage::CreateFromBinBuffer(const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
CreateFromTextBuffer(const char *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMatchAction | [inline, static]
CreateFromTextBuffer(const wchar_t *Buffer, unsigned int BufferSize, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMatchAction | [inline, static]
CGscMessage::CreateFromTextBuffer(const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
CGscMessage::CreateFromTextBuffer(const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
DisableInternalInEventData() | CGscMessage | [inline]
DisableResourceUpdate() | CGscMessage | [inline]
DuplicateHandle() | CGscMessage | [inline]
EqualTo(ConstHGscMessage aMessage) const | CGscMessage | [inline]
GetActionClass() const | CGscMatchAction | [inline]
GetActionCode() const | CGscMatchAction | [inline]
GetActionEventData(TPlcActionEventDataRecord &EventRecord, bool &DataComplete) const | CGscMatchAction | [inline]
GetActionNameA() const | CGscMatchAction | [inline]
GetActionNameW() const | CGscMatchAction | [inline]
GetActionPlainNameA() const | CGscMatchAction | [inline]
GetActionPlainNameW() const | CGscMatchAction | [inline]
GetCommentA() const | CGscMatchAction | [inline]
GetCommentW() const | CGscMatchAction | [inline]
GetDescriptionA() const | CGscMatchAction | [inline]
GetDescriptionW() const | CGscMatchAction | [inline]
GetInternalData() const | CGscMessage | [inline]
GetInternalIndex() const | CGscMessage | [inline]
GetMessageClass() const | CGscMessage | [inline]
GetMessageFlags() const | CGscMessage | [inline]
GetReferenceCounter() const | CGscMessage | [inline]
HasDescription() | CGscMatchAction | [inline]
Matches(ConstHGscAction anAction) const | CGscMatchAction | [inline]
operator delete(void *Ptr) | CGscMatchAction | [inline]
operator!=(ConstHGscMessage aMessage) const | CGscMessage | [inline]
operator==(ConstHGscMessage aMessage) const | CGscMessage | [inline]
RestoreActionFromEventData(const TPlcActionEventDataRecord &EventRecord) | CGscMatchAction | [inline, static]
SetComment(const char *Description) | CGscMatchAction | [inline]
SetComment(const wchar_t *Description) | CGscMatchAction | [inline]
SetDescription(const char *Description) | CGscMatchAction | [inline]
SetDescription(const wchar_t *Description) | CGscMatchAction | [inline]
SetInternalData(void *Data) | CGscMessage | [inline]
SetMessageFlags(unsigned __int32 Flags) | CGscMessage | [inline]
StoreToBinBuffer(void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten=0) const | CGscMessage | [inline]
StoreToTextBuffer(char *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const | CGscMessage | [inline]
StoreToTextBuffer(wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const | CGscMessage | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CGscMessage Member List

This is the complete list of members for CGscMessage, including all inherited members.
CloneHandle() const | CGscMessage | [inline]
CloseHandle() | CGscMessage | [inline]
CreateFromBinBuffer(const void *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
CreateFromTextBuffer(const char *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
CreateFromTextBuffer(const wchar_t *Buffer, unsigned int BufferSize, GscMessageClass ExpectedClass=mk_Unknown, bool UseUTF8Encoding=false, unsigned int *ReadChars=0) | CGscMessage | [inline, static]
DisableInternalInEventData() | CGscMessage | [inline]
DisableResourceUpdate() | CGscMessage | [inline]
DuplicateHandle() | CGscMessage | [inline]
EqualTo(ConstHGscMessage aMessage) const | CGscMessage | [inline]
GetInternalData() const | CGscMessage | [inline]
GetInternalIndex() const | CGscMessage | [inline]
GetMessageClass() const | CGscMessage | [inline]
GetMessageFlags() const | CGscMessage | [inline]
GetReferenceCounter() const | CGscMessage | [inline]
operator delete(void *Ptr) | CGscMessage | [inline]
operator!=(ConstHGscMessage aMessage) const | CGscMessage | [inline]
operator==(ConstHGscMessage aMessage) const | CGscMessage | [inline]
SetInternalData(void *Data) | CGscMessage | [inline]
SetMessageFlags(unsigned __int32 Flags) | CGscMessage | [inline]
StoreToBinBuffer(void *Buffer, unsigned int BufferSize, unsigned int *BytesWritten=0) const | CGscMessage | [inline]
StoreToTextBuffer(char *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const | CGscMessage | [inline]
StoreToTextBuffer(wchar_t *Buffer, unsigned int BufferSize, bool OutputAsPlainText=false, bool UseUTF8Encoding=false, unsigned int *CharsWritten=0) const | CGscMessage | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

GscActionsDispatcher Member List

This is the complete list of members for GscActionsDispatcher, including all inherited members.
Dispatch(HGscAction Action) | GscActionsDispatcher |
GscActionsDispatcher() | GscActionsDispatcher | [inline]
OnABCConnect(HGscAction anAction, const wchar_t *aAddress) | GscActionsDispatcher | [inline, protected, virtual]
OnABCDisconnect(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnABCPlayFile(HGscAction anAction, const __int64 &aFileID, const wchar_t *aFileName, const bool aAutoRepeat) | GscActionsDispatcher | [inline, protected, virtual]
OnAbortAllAutoBackups(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnAbortAutoBackup(HGscAction anAction, const TPlcResourceID &aSchedule) | GscActionsDispatcher | [inline, protected, virtual]
OnACSAccessDenied(HGscAction anAction, const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp, const __int32 *aReason) | GscActionsDispatcher | [inline, protected, virtual]
OnACSAccessGranted(HGscAction anAction, const wchar_t *aACSName, const __int32 *aACSNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const TGLibDateTime *aTimeStamp) | GscActionsDispatcher | [inline, protected, virtual]
OnACSRawAnswer(HGscAction anAction, const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData) | GscActionsDispatcher | [inline, protected, virtual]
OnACSRawData(HGscAction anAction, const wchar_t *aACSName, const TGLibDateTime &aTimeStamp, const wchar_t *aACSData) | GscActionsDispatcher | [inline, protected, virtual]
OnActivateExternalProcess(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const VideoSensorKind aExternalSystem) | GscActionsDispatcher | [inline, protected, virtual]
OnATMRawAnswer(HGscAction anAction, const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData) | GscActionsDispatcher | [inline, protected, virtual]
OnATMRawData(HGscAction anAction, const wchar_t *aATMName, const TGLibDateTime &aTimeStamp, const wchar_t *aATMData) | GscActionsDispatcher | [inline, protected, virtual]
OnATMTransaction(HGscAction anAction, const wchar_t *aATMName, const bool aNewTransaction, const __int32 aPhotostep, const __int32 *aATMNo, const __int64 *aAccount, const __int64 *aBancCode, const wchar_t *aCardNo, const __int64 *aTAN1, const __int64 *aTAN2, const TGLibDateTime *aTimeStamp1, const TGLibDateTime *aTimeStamp2, const double *aAmount, const wchar_t *aCurrency) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupCapacityMonitoringCapacityWarning(HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupCapacityMonitoringFileAutoDeleted(HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf, const __int64 &aFileSize, const wchar_t *aFileName) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupCapacityMonitoringOutOfDiskSpace(HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByGbf, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByGbf) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupFileDone(HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupFileProgress(HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupFileStarted(HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 aFileIndex, const wchar_t *aFileName) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupOperationDone(HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TGLibDateTime &aOperationStopTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const __int32 *aOperationErrorCode) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupOperationStarted(HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart, const __int32 aOperationIndex, const TGLibDateTime &aOperationStartTime, const TPlcResourceID &aSource, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupScheduleDone(HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const TGLibDateTime &aStopTime, const __int32 aOperationCount, const bool aTimerStart) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoBackupScheduleStarted(HGscAction anAction, const TPlcResourceID &aSchedule, const TGLibDateTime *aStartTime, const TGLibDateTime &aEffectiveStartTime, const __int32 aOperationCount, const bool aTimerStart) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoFocusOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnAutoFocusOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnBackupEvent(HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID &aDestination, const __int64 *aStartHintID, const __int64 *aStopHintID, const wchar_t *aSubfolder) | GscActionsDispatcher | [inline, protected, virtual]
OnBarcodeData(HGscAction anAction, const wchar_t *aReaderName, const TGLibDateTime &aTimeStamp, const wchar_t *aBarcode) | GscActionsDispatcher | [inline, protected, virtual]
OnBlockingFilterActivate(HGscAction anAction, const wchar_t *aFilter) | GscActionsDispatcher | [inline, protected, virtual]
OnBlockingFilterDeactivate(HGscAction anAction, const wchar_t *aFilter) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraApplyProfile(HGscAction anAction, const TPlcMediaChannelID &aCamera, const wchar_t *aProfile) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraBacklightCompensationMode(HGscAction anAction, const TPlcMediaChannelID &aCamera, const PlcBacklightMode aMode) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraClearPrePosText(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraDayNightMode(HGscAction anAction, const TPlcMediaChannelID &aCamera, const PlcDayNightMode aMode) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraLightOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraLightOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraManualIrisOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraManualIrisOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraPumpOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraPumpOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraRAWOutput(HGscAction anAction, const TPlcMediaChannelID &aCamera, const char *aOutput) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSelectCharMode(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aMode) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSetPrePosText(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncUOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncUOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncVOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncVOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncXOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncXOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncYOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraSpecFuncYOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraStopAll(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraTextOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraTextOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraTourStart(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aTourID, const char *aTourName) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraTourStop(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraVersionOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraVersionOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraWashOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCameraWashOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnCancelExport(HGscAction anAction, const GUID &aExportID, const PlcExportAbort aAbortFlag) | GscActionsDispatcher | [inline, protected, virtual]
OnCaseClosed(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnCaseOpened(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnChangeADParameterSet(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet) | GscActionsDispatcher | [inline, protected, virtual]
OnChangeCameraProfile(HGscAction anAction, const TPlcResourceID &aHardwareModule, const TPlcResourceID &aCameraProfile) | GscActionsDispatcher | [inline, protected, virtual]
OnChangeCPAParameterSet(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet) | GscActionsDispatcher | [inline, protected, virtual]
OnChangeGTectParameterSet(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet) | GscActionsDispatcher | [inline, protected, virtual]
OnChangeObtrackParameterSet(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet) | GscActionsDispatcher | [inline, protected, virtual]
OnChangeVMDParameterSet(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID &aParameterSet) | GscActionsDispatcher | [inline, protected, virtual]
OnChannelError(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo) | GscActionsDispatcher | [inline, protected, virtual]
OnChannelInfo(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo) | GscActionsDispatcher | [inline, protected, virtual]
OnChannelLiveCheck(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const TGLibDateTime &aTimeStamp) | GscActionsDispatcher | [inline, protected, virtual]
OnChannelWarning(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind *aSensorType, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo) | GscActionsDispatcher | [inline, protected, virtual]
OnCPAMeasurement(HGscAction anAction, const TPlcMediaChannelID &aChannel, const __int32 aCorrelation) | GscActionsDispatcher | [inline, protected, virtual]
OnCustomAction(HGscAction anAction, const __int64 &aInt, const wchar_t *aString) | GscActionsDispatcher | [inline, protected, virtual]
OnDatabaseRecordingInfoRing(HGscAction anAction, const PlcDatabaseRing aDatabaseRing, const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aRingCapacity, const TGLibDateTime &aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity) | GscActionsDispatcher | [inline, protected, virtual]
OnDatabaseRecordingInfoTotal(HGscAction anAction, const bool aNoVideoRecording, const bool aNoAudioRecording, const bool aNoRecordingAtAll, const double &aVideoSamplesPerSecond, const double &aVideoMBPerSecond, const double &aAudioSamplesPerSecond, const double &aAudioMBPerSecond, const double &aWriteWaitTimesPercent, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedCapacity, const TGLibDateTime *aOldestItem, const double *aRecordingDepth, const __int64 *aEstimatedRequiredCapacity, const double *aRequiredCapacityFactor, const bool *aRequiredCapacityAvailable) | GscActionsDispatcher | [inline, protected, virtual]
OnDatabaseStarted(HGscAction anAction, const PlcDatabaseStatus aStatus, const __int64 &aTotalSize) | GscActionsDispatcher | [inline, protected, virtual]
OnDefaultPosCallUp(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnDefaultPosClear(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnDefaultPosSave(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnDeviceFound(HGscAction anAction, const char *aType, const char *aName, const char *aSerial) | GscActionsDispatcher | [inline, protected, virtual]
OnDeviceNewFirmware(HGscAction anAction, const char *aType, const char *aName, const char *aSerial, const char *aFirmware) | GscActionsDispatcher | [inline, protected, virtual]
OnDevicePluginError(HGscAction anAction, const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginError aErrorClass, const __int32 *aErrorCode, const char *aDescription) | GscActionsDispatcher | [inline, protected, virtual]
OnDevicePluginState(HGscAction anAction, const TPlcMediaChannelID &aChannel, const char *aType, const char *aSubType, const char *aName, const char *aSerial, const PlcPluginState aState, const __int32 *aInternalState, const char *aDescription) | GscActionsDispatcher | [inline, protected, virtual]
OnDeviceReattached(HGscAction anAction, const char *aType, const char *aName, const char *aSerial) | GscActionsDispatcher | [inline, protected, virtual]
OnDeviceRemoved(HGscAction anAction, const char *aType, const char *aName, const char *aSerial) | GscActionsDispatcher | [inline, protected, virtual]
OnDigitalInput(HGscAction anAction, const TPlcMediaChannelID &aContact, const DigitalInputState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnEventBackupDone(HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const __int32 *aOperationErrorCode) | GscActionsDispatcher | [inline, protected, virtual]
OnEventBackupFileDone(HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize) | GscActionsDispatcher | [inline, protected, virtual]
OnEventBackupFileProgress(HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName, const __int64 &aFileSize) | GscActionsDispatcher | [inline, protected, virtual]
OnEventBackupFileStarted(HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime, const __int32 aFileIndex, const wchar_t *aFileName) | GscActionsDispatcher | [inline, protected, virtual]
OnEventBackupStarted(HGscAction anAction, const GUID &aJobID, const TPlcEventTypeID &aEventTypeID, const __int64 &aEventID, const TPlcResourceID &aDestination, const __int64 &aFileSizeLimit, const __int64 &aBandWidthLimit, const TGLibDateTime &aStartTime) | GscActionsDispatcher | [inline, protected, virtual]
OnEventRecordingChanged(HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID) | GscActionsDispatcher | [inline, protected, virtual]
OnEventStarted(HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey) | GscActionsDispatcher | [inline, protected, virtual]
OnEventStopped(HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID) | GscActionsDispatcher | [inline, protected, virtual]
OnExportFinished(HGscAction anAction, const GUID &aExportID, const PlcExportSuccess aSuccess) | GscActionsDispatcher | [inline, protected, virtual]
OnExportProgress(HGscAction anAction, const GUID &aExportID, const __int32 aProgress) | GscActionsDispatcher | [inline, protected, virtual]
OnFastSpeedOff(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnFastSpeedOn(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnFillingPumpStatus(HGscAction anAction, const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aPumpNo, const PlcPumpStatus aStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails) | GscActionsDispatcher | [inline, protected, virtual]
OnFocusFar(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnFocusNear(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnFocusStop(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnFRCNotification(HGscAction anAction, const PlcFRCNotification aNotification, const __int32 *aParam, const wchar_t *aDescription, const char *aXMLInfo) | GscActionsDispatcher | [inline, protected, virtual]
OnGEMOSalarm(HGscAction anAction, const __int64 &aGEMOSkey, const __int32 aGEMOSint, const wchar_t *aGEMOSstr) | GscActionsDispatcher | [inline, protected, virtual]
OnGSCSVehicleAccessDenied(HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection) | GscActionsDispatcher | [inline, protected, virtual]
OnGSCSVehicleAccessExpired(HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const TGLibDateTime &aExpiringTime, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection) | GscActionsDispatcher | [inline, protected, virtual]
OnGSCSVehicleAccessGranted(HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection) | GscActionsDispatcher | [inline, protected, virtual]
OnGSCSVehicleAccessPending(HGscAction anAction, const __int32 aSequenceID, const wchar_t *aPlateNo, const TGLibDateTime &aTimeStamp, const wchar_t *aCompanyCategory, const wchar_t *aCompanyName, const wchar_t *aReason, const wchar_t *aTrafficLane, const TPlcMediaChannelID *aChannel, const TrafficDirection *aDirection) | GscActionsDispatcher | [inline, protected, virtual]
OnGTectAnalyticsLiveCheck(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnGTectDualSensorAlarm(HGscAction anAction, const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea) | GscActionsDispatcher | [inline, protected, virtual]
OnGTectDualSensorAlarmFinished(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnGTectSceneAlarm(HGscAction anAction, const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason) | GscActionsDispatcher | [inline, protected, virtual]
OnGTectSceneAlarmFinished(HGscAction anAction, const TPlcMediaChannelID &aChannel, const GTectSceneAlarmReason aAlarmReason) | GscActionsDispatcher | [inline, protected, virtual]
OnGTectVMXAlarm(HGscAction anAction, const TPlcMediaChannelID &aChannel, const __int32 *aSterileZoneNumber, const __int32 *aVirtualFenceNumber, const __int32 *aAlarmGroup, const __int32 *aTrackID, const TPlcRect *aAlarmArea) | GscActionsDispatcher | [inline, protected, virtual]
OnGTectVMXAlarmFinished(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnIASSettingsChanged(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType) | GscActionsDispatcher | [inline, protected, virtual]
OnImageExportNotification(HGscAction anAction, const wchar_t *aUser, const wchar_t *aDestination, const PlcImageExportType aDestinationType, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aTimeEnd, const wchar_t *aChannels, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnImexCapacityFileAutoDeleted(HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile, const __int64 &aTotalFileSize, const __int32 aNumberOfFiles) | GscActionsDispatcher | [inline, protected, virtual]
OnImexCapacityOutOfDiskSpace(HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile) | GscActionsDispatcher | [inline, protected, virtual]
OnImexCapacityWarning(HGscAction anAction, const ABCapacityWarning aWarning, const TPlcResourceID &aDestination, const __int64 &aTotalCapacity, const __int64 &aFreeCapacity, const __int64 &aAllocatedByImageFile, const __int32 aPercentFree, const __int32 aPercentAllocated, const __int32 aPercentAllocatedByImageFile) | GscActionsDispatcher | [inline, protected, virtual]
OnImexExportEventImage(HGscAction anAction, const __int64 &aEventID, const TPlcEventTypeID &aTypeID, const TPlcResourceID *aDestination, const wchar_t *aFilePath) | GscActionsDispatcher | [inline, protected, virtual]
OnImexExportImageFromDB(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath, const TGLibDateTime *aPictureTime) | GscActionsDispatcher | [inline, protected, virtual]
OnImexExportImageFromLiveStream(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TPlcResourceID *aDestination, const wchar_t *aFilePath) | GscActionsDispatcher | [inline, protected, virtual]
OnInitializeRemoteExport(HGscAction anAction, const TPlcMediaChannelID &aViewer, const GUID &aDevice) | GscActionsDispatcher | [inline, protected, virtual]
OnInterfaceRawAnswer(HGscAction anAction, const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData) | GscActionsDispatcher | [inline, protected, virtual]
OnInterfaceRawData(HGscAction anAction, const wchar_t *aInterfaceName, const TGLibDateTime &aTimeStamp, const wchar_t *aData) | GscActionsDispatcher | [inline, protected, virtual]
OnIOI43ResetMainboard(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnIOI43Temperature(HGscAction anAction, const wchar_t *aID, const __int32 aTemperature) | GscActionsDispatcher | [inline, protected, virtual]
OnIOI43WDActivate(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnIOI43WDDeactivate(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnIOI43WDTrigger(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnIPCameraRawCommand(HGscAction anAction, const wchar_t *aURL, const wchar_t *aUser, const wchar_t *aPassword, const wchar_t *aPOST) | GscActionsDispatcher | [inline, protected, virtual]
OnIPCamFailoverNotification(HGscAction anAction, const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters) | GscActionsDispatcher | [inline, protected, virtual]
OnIPCamFailoverRestore(HGscAction anAction, const wchar_t *aPrimaryServer, const wchar_t *aSecondaryServer, const TPlcMediaChannelID &aPrimaryChannel, const TPlcMediaChannelID &aSecondaryChannel, const wchar_t *aCameraParameters) | GscActionsDispatcher | [inline, protected, virtual]
OnIPSwitchOperation(HGscAction anAction, const IPSwitchOps aOperation, const wchar_t *aPort, const __int32 *aParam) | GscActionsDispatcher | [inline, protected, virtual]
OnIrisClose(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnIrisOpen(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnIrisStop(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnKeyPressed(HGscAction anAction, const SystemKey aKey) | GscActionsDispatcher | [inline, protected, virtual]
OnKeyReleased(HGscAction anAction, const SystemKey aKey) | GscActionsDispatcher | [inline, protected, virtual]
OnKillAllEvents(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnKillEvent(HGscAction anAction, const TPlcEventTypeID &aTypeID) | GscActionsDispatcher | [inline, protected, virtual]
OnKillEventByID(HGscAction anAction, const __int64 &aEventID) | GscActionsDispatcher | [inline, protected, virtual]
OnLenelAccessEvent(HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int64 *aCardNumber, const LenelAccessResult *aAccessResult, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const __int32 *aAreaEnteredID, const __int32 *aAreaExitedID, const wchar_t *aAssetID, const bool *aCardholderEntered, const bool *aDuress, const __int32 *aElevatorFloor, const __int32 *aFacilityCode, const bool *aIsReadableCard, const __int32 *aIssueCode, const wchar_t *aCommServerHostName, const wchar_t *aEventText) | GscActionsDispatcher | [inline, protected, virtual]
OnLenelFireEvent(HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aTroubleCode, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText) | GscActionsDispatcher | [inline, protected, virtual]
OnLenelIntercomEvent(HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aIntercomData, const __int32 *aLineNumber, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText) | GscActionsDispatcher | [inline, protected, virtual]
OnLenelRawData(HGscAction anAction, const TGLibDateTime &aTimeStamp, const wchar_t *aLenelData) | GscActionsDispatcher | [inline, protected, virtual]
OnLenelRefreshNames(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnLenelSecurityEvent(HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const wchar_t *aCommServerHostName, const wchar_t *aEventText) | GscActionsDispatcher | [inline, protected, virtual]
OnLenelVideoEvent(HGscAction anAction, const LenelEventID *aID, const wchar_t *aPanel, const wchar_t *aDevice, const __int32 *aSecondaryDevice, const __int32 *aChannel, const LenelEventType *aType, const __int32 *aSubType, const wchar_t *aDescription, const __int32 *aSerialNumber, const TGLibDateTime *aTimeStamp, const TGLibDateTime *aStartTime, const TGLibDateTime *aEndTime, const wchar_t *aCommServerHostName, const wchar_t *aEventText) | GscActionsDispatcher | [inline, protected, virtual]
OnLiveCheck(HGscAction anAction, const __int64 &aCounter, const TGLibDateTime &aDate) | GscActionsDispatcher | [inline, protected, virtual]
OnLogBarcodeData(HGscAction anAction, const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem) | GscActionsDispatcher | [inline, protected, virtual]
OnLogBarcodeDataLPS(HGscAction anAction, const wchar_t *aBarcode, const __int64 *aHash, const wchar_t *aScanner, const __int64 *aAreaID, const wchar_t *aAreaName, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const double *aX, const double *aY, const double *aZ, const __int32 *aLpsTagID, const PlcLpsStatus *aLpsStatus, const __int32 *aLpsCellID, const __int32 *aLpsAreaID, const __int32 *aUserParam, const wchar_t *aOrder, const wchar_t *aShipment, const wchar_t *aItem) | GscActionsDispatcher | [inline, protected, virtual]
OnLogNPRRecognition(HGscAction anAction, const wchar_t *aPlateNo, const __int64 *aHash, const wchar_t *aCountry, const TPlcMediaChannelID *aChannel, const TGLibDateTime *aTimeStamp, const PlcNPRRestriction *aRestriction, const wchar_t *aCategory) | GscActionsDispatcher | [inline, protected, virtual]
OnLPSPositionData(HGscAction anAction, const __int32 aTagID, const wchar_t *aScannerID, const __int64 &aX, const __int64 &aY, const __int64 *aZ, const double *aLatitude, const double *aLongitude, const __int32 aAreaID, const __int32 *aCellID, const PlcLpsStatus aStatus, const TGLibDateTime *aTimeStamp, const wchar_t *aData, const wchar_t *aAreaName) | GscActionsDispatcher | [inline, protected, virtual]
OnLPSQueryPosition(HGscAction anAction, const __int32 aTagID, const wchar_t *aScannerID, const wchar_t *aData) | GscActionsDispatcher | [inline, protected, virtual]
OnMakeCPAReferenceImage(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnMediaChannelSetupInfo(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const wchar_t *aParameter) | GscActionsDispatcher | [inline, protected, virtual]
OnMoveToAbsolutePosition(HGscAction anAction, const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta) | GscActionsDispatcher | [inline, protected, virtual]
OnMoveToBySpeed(HGscAction anAction, const TPlcMediaChannelID &aCamera, const double &aSpeedAlpha, const double &aSpeedBeta) | GscActionsDispatcher | [inline, protected, virtual]
OnMoveToRelativePosition(HGscAction anAction, const TPlcMediaChannelID &aCamera, const double &aAlpha, const double &aBeta, const double &aSpeedAlpha, const double &aSpeedBeta) | GscActionsDispatcher | [inline, protected, virtual]
OnNPRRawData(HGscAction anAction, const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const __int32 aWeight, const __int32 aZoneState, const __int32 aZonePlace, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const bool aCurBest, const __int32 aPlateWidth, const __int32 aPlateHeight, const __int32 aPlateAngle, const __int32 aSymHeight, const wchar_t *aType) | GscActionsDispatcher | [inline, protected, virtual]
OnNPRRecognition(HGscAction anAction, const wchar_t *aPlateNo, const wchar_t *aCountry, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const TPlcRect &aZoneRect, const PlcNPRRestriction aRestriction, const wchar_t *aCategory, const __int32 aSpeed, const __int32 aDirection, const __int32 aZoneIndex, const wchar_t *aType, const __int32 aWeight) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackChannelCounter(HGscAction anAction, const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackChannelCounterThreshold(HGscAction anAction, const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackChannelSetCounter(HGscAction anAction, const TPlcMediaChannelID &aChannel, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackFrameRawData(HGscAction anAction, const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aBrightness, const __int32 aContrast) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackGroupCounter(HGscAction anAction, const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const __int32 aObjectDirection, const TGLibDateTime &aTimeStamp, const TGLibDateTime *aResetTimeStamp, const wchar_t *aGroupName) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackGroupCounterThreshold(HGscAction anAction, const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const PlcObtrackExceedingDirection aExceedingDirection, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackGroupSetCounter(HGscAction anAction, const __int32 aGroupId, const PlcObtrackCounterType aCounterType, const __int64 &aCounterValue, const TGLibDateTime &aTimeStamp, const wchar_t *aGroupName) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackObjectRawData(HGscAction anAction, const TGLibDateTime &aTimeStamp, const TPlcMediaChannelID &aChannel, const __int32 aArea, const __int32 aObjectID, const PlcObtrackObjectStatus aObjectStatus, const PlcObtrackObjectClass aObjectClass, const __int32 *aConfidence, const TPlcRect *aPosition, const double *aSpeed, const __int32 *aDuration, const __int32 *aDirection, const double *aSize, const double *aObjectWidth, const double *aObjectHeight, const PlcObtrackProcessSize *aProcessSize, const char *aGscNetName) | GscActionsDispatcher | [inline, protected, virtual]
OnObtrackTunnelAlarm(HGscAction anAction, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aTimeStamp, const PlcTunnelAlarmReason aAlarmReason, const __int32 aObjectID, const __int32 aAlarmAreaID, const TPlcRect *aObjectArea) | GscActionsDispatcher | [inline, protected, virtual]
OnPanAuto(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aModus) | GscActionsDispatcher | [inline, protected, virtual]
OnPanLeft(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnPanRight(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnPanStop(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnPOSData(HGscAction anAction, const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const wchar_t *aArticle, const double *aPrice, const __int32 *aUnits, const double *aPricePerUnit, const wchar_t *aLine1, const wchar_t *aLine2, const wchar_t *aLine3, const wchar_t *aLine4, const wchar_t *aLine5) | GscActionsDispatcher | [inline, protected, virtual]
OnPOSStatus(HGscAction anAction, const wchar_t *aPOSName, const TGLibDateTime &aTimeStamp, const PlcPOSStatus aStatus, const wchar_t *aDetails) | GscActionsDispatcher | [inline, protected, virtual]
OnPPDeviceAlarm(HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPSensorKind aSensor, const PPAlarmState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnPPDeviceInput(HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aInput, const PPAlarmState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnPPDeviceOffline(HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress) | GscActionsDispatcher | [inline, protected, virtual]
OnPPDeviceOnline(HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress) | GscActionsDispatcher | [inline, protected, virtual]
OnPPInterfaceOffline(HGscAction anAction, const wchar_t *aInterfaceID) | GscActionsDispatcher | [inline, protected, virtual]
OnPPInterfaceOnline(HGscAction anAction, const wchar_t *aInterfaceID) | GscActionsDispatcher | [inline, protected, virtual]
OnPPQueryInterface(HGscAction anAction, const wchar_t *aInterfaceID) | GscActionsDispatcher | [inline, protected, virtual]
OnPPSetDeviceOutput(HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const __int32 aOutput, const PPAlarmState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnPPSubcellAlarm(HGscAction anAction, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind aCable, const __int32 aSubcell, const PPAlarmState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnPPZoneAlarm(HGscAction anAction, const wchar_t *aZoneID, const wchar_t *aInterfaceID, const __int32 aDeviceAddress, const PPCableKind *aCable, const __int32 *aSubcell, const PPAlarmState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnPrePosCallUp(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition) | GscActionsDispatcher | [inline, protected, virtual]
OnPrePosClear(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition) | GscActionsDispatcher | [inline, protected, virtual]
OnPrePosSave(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aPosition) | GscActionsDispatcher | [inline, protected, virtual]
OnRedundantPowerFailure(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnRedundantPowerOk(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnResetMainboard(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnSafebagClose(HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques) | GscActionsDispatcher | [inline, protected, virtual]
OnSafebagData(HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const double *aDebit, const double *aTotal, const double *aDifference, const bool *aHasDifference, const wchar_t *aNotes, const wchar_t *aCoins, const wchar_t *aCheques) | GscActionsDispatcher | [inline, protected, virtual]
OnSafebagOpen(HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID) | GscActionsDispatcher | [inline, protected, virtual]
OnSafebagPassingOfRiskData(HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType) | GscActionsDispatcher | [inline, protected, virtual]
OnSafebagPassingOfRiskStart(HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType) | GscActionsDispatcher | [inline, protected, virtual]
OnSafebagPassingOfRiskStop(HGscAction anAction, const __int32 aWorkingPlace, const TGLibDateTime &aStartTime, const TGLibDateTime &aStopTime, const wchar_t *aSafebagNo, const wchar_t *aSafebagInfo, const SafebagStep aStepID, const __int32 aUserID1, const __int32 aUserID2, const __int32 *aTourNumber, const wchar_t *aTargetWorkingPlace, const wchar_t *aPassingOfRiskType) | GscActionsDispatcher | [inline, protected, virtual]
OnSceneStoreModification(HGscAction anAction, const TPlcMediaChannelID &aViewer, const GUID &aSceneStoreID, const wchar_t *aSceneStoreName, const TGLibDateTime &aTimeStamp, const PlcSceneStoreModificationType aModificationType, const wchar_t *aUser, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnSensorAlarmFinished(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType) | GscActionsDispatcher | [inline, protected, virtual]
OnSensorAudioAlarm(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnSensorInhibitAlarmFinished(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType) | GscActionsDispatcher | [inline, protected, virtual]
OnSensorInhibitVideoAlarm(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass) | GscActionsDispatcher | [inline, protected, virtual]
OnSensorVideoAlarm(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const ADArea *aADArea, const __int32 *aADCell, const VMDGroup *aVMDGroup, const __int32 *aVMDZone, const VMDCycle *aVMDCycle, const TPlcRect *aAlarmArea, const PlcObtrackObjectClass *aObjectClass) | GscActionsDispatcher | [inline, protected, virtual]
OnSetCameraText(HGscAction anAction, const TPlcMediaChannelID &aCamera, const char *aText) | GscActionsDispatcher | [inline, protected, virtual]
OnSetClientVCA(HGscAction anAction, const TPlcMediaChannelID &aChannel, const GTectClientVCAType aClientVCAType, const bool aEnabled) | GscActionsDispatcher | [inline, protected, virtual]
OnSetClock(HGscAction anAction, const TGLibDateTime &aDate) | GscActionsDispatcher | [inline, protected, virtual]
OnSetDigitalOutput(HGscAction anAction, const TPlcMediaChannelID &aContact, const DigitalOutputState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnSetExportMarker(HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcExportMarker aMarker) | GscActionsDispatcher | [inline, protected, virtual]
OnSetLED(HGscAction anAction, const SystemLED aLED, const DigitalOutputState aState) | GscActionsDispatcher | [inline, protected, virtual]
OnSetLEDBlink(HGscAction anAction, const SystemLED aLED, const __int32 aLedTimeOnMs, const __int32 aLedTimeOffMs) | GscActionsDispatcher | [inline, protected, virtual]
OnSetSystemTime(HGscAction anAction, const TGLibDateTime &aTimeStamp) | GscActionsDispatcher | [inline, protected, virtual]
OnSetTestPictureMode(HGscAction anAction, const TPlcMediaChannelID &aChannel, const bool aMode) | GscActionsDispatcher | [inline, protected, virtual]
OnSetupChanged(HGscAction anAction, const wchar_t *aUser, const wchar_t *aHost, const TGLibDateTime &aDate, const PlcResourceKind aResourceKind, const TPlcEventTypeID &aResourceID, const PlcResourceChangeKind aChangeKind, const wchar_t *aDetails, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnSetupUploadProgress(HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const __int32 aProgress, const TGLibDateTime &aDate) | GscActionsDispatcher | [inline, protected, virtual]
OnSetWatchdog(HGscAction anAction, const __int32 aTimeout) | GscActionsDispatcher | [inline, protected, virtual]
OnSkidataControl(HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataControl aData) | GscActionsDispatcher | [inline, protected, virtual]
OnSkidataDeviceEvent(HGscAction anAction, const wchar_t *aInterfaceName, const __int32 aDeviceID, const __int32 aEventCode) | GscActionsDispatcher | [inline, protected, virtual]
OnSkidataEntry(HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataMsgCodeEntry aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID) | GscActionsDispatcher | [inline, protected, virtual]
OnSkidataExit(HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataMsgCodeExit aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID) | GscActionsDispatcher | [inline, protected, virtual]
OnSkidataTransaction(HGscAction anAction, const wchar_t *aInterfaceName, const PlcSkidataMsgCodeTransaction aMessageCode, const wchar_t *aTranscactionID, const __int32 aCarParkNo, const __int32 aDeviceID) | GscActionsDispatcher | [inline, protected, virtual]
OnSMRPViewerCleared(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnSMRPViewerConnected(HGscAction anAction, const wchar_t *aServer, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnSMTPMailSend(HGscAction anAction, const wchar_t *aSubject, const wchar_t *aTo, const wchar_t *aCc, const wchar_t *aBody, const TPlcMediaChannelID *aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnStartAutoBackup(HGscAction anAction, const TPlcResourceID &aSchedule) | GscActionsDispatcher | [inline, protected, virtual]
OnStartEvent(HGscAction anAction, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey) | GscActionsDispatcher | [inline, protected, virtual]
OnStartRemoteExport(HGscAction anAction, const GUID &aExportID, const GUID &aDevice, const PlcBackupFormat aBackupFormat, const TPlcMediaChannelID &aChannel, const TGLibDateTime &aSelectionBegin, const TGLibDateTime &aSelectionEnd, const wchar_t *aJobID) | GscActionsDispatcher | [inline, protected, virtual]
OnStartSceneStore(HGscAction anAction, const GUID &aSceneStoreID, const wchar_t *aCutList, const __int64 &aPreHistoryLength, const __int64 &aRecordingLength) | GscActionsDispatcher | [inline, protected, virtual]
OnStopAllEvents(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnStopEvent(HGscAction anAction, const TPlcEventTypeID &aTypeID) | GscActionsDispatcher | [inline, protected, virtual]
OnStopEventByID(HGscAction anAction, const __int64 &aEventID) | GscActionsDispatcher | [inline, protected, virtual]
OnSystemError(HGscAction anAction, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo) | GscActionsDispatcher | [inline, protected, virtual]
OnSystemInfo(HGscAction anAction, const PlcMessageSource aSource, const PlcMessageCode aMessage, const wchar_t *aDescription, const char *aXMLInfo) | GscActionsDispatcher | [inline, protected, virtual]
OnSystemSettingsChanged(HGscAction anAction, const bool aSetupChanged, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const bool aTimeRangeChanged, const TPlcResourceID *aTimeRange, const bool aLicenceChanged, const TGLibDateTime &aDate) | GscActionsDispatcher | [inline, protected, virtual]
OnSystemStarted(HGscAction anAction, const TGLibDateTime &aDate) | GscActionsDispatcher | [inline, protected, virtual]
OnSystemTerminating(HGscAction anAction, const TGLibDateTime &aDate, const bool aWindowsShutdown) | GscActionsDispatcher | [inline, protected, virtual]
OnSystemWarning(HGscAction anAction, const PlcMessageSource aSource, const PlcMessageCode aMessage, const __int32 *aWindowsError, const wchar_t *aDescription, const char *aXMLInfo) | GscActionsDispatcher | [inline, protected, virtual]
OnTemperature(HGscAction anAction, const IODeviceType aSourceType, const wchar_t *aID, const __int32 aTemperature) | GscActionsDispatcher | [inline, protected, virtual]
OnTerminalArticleData(HGscAction anAction, const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails) | GscActionsDispatcher | [inline, protected, virtual]
OnTerminalPaymentData(HGscAction anAction, const wchar_t *aTerminalName, const TGLibDateTime &aTimeStamp, const __int32 aCashierStation, const __int32 *aPumpNo, const bool aAlarmStatus, const double *aAmount, const double *aPrice, const wchar_t *aDetails) | GscActionsDispatcher | [inline, protected, virtual]
OnTiltDown(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnTiltStop(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
OnTiltUp(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnTransferBinaryBuffer(HGscAction anAction, const GUID &aInternalHandle, const wchar_t *aParameter) | GscActionsDispatcher | [inline, protected, virtual]
OnTransferBinaryChannelBuffer(HGscAction anAction, const TPlcMediaChannelID &aChannel, const GUID &aInternalHandle, const wchar_t *aParameter) | GscActionsDispatcher | [inline, protected, virtual]
OnUnregisteredMessage(HGscAction Action) | GscActionsDispatcher | [inline, protected, virtual]
OnUserLogin(HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnUserLoginFailed(HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const UserLoginFailureCode aRejectReason, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnUserLogout(HGscAction anAction, const wchar_t *aUser1, const wchar_t *aUser2, const wchar_t *aHost, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueConfirm(HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueConfirmByInstance(HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueConfirmByType(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueNotification(HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmState aNotification, const __int64 &aAlarmID, const TPlcEventTypeID &aTypeID, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueRemove(HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueRemoveByInstance(HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueRemoveByType(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueSelect(HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerAlarmQueueSelection aSelectionMode) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueSelectByInstance(HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAlarmQueueSelectByType(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const PlcViewerAlarmQueueSelection aSelectionMode) | GscActionsDispatcher | [inline, protected, virtual]
OnVCASetArmed(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAStatusAnswer(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const bool aArmed) | GscActionsDispatcher | [inline, protected, virtual]
OnVCAStatusRequest(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType) | GscActionsDispatcher | [inline, protected, virtual]
OnVCChangeSceneByName(HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aScene) | GscActionsDispatcher | [inline, protected, virtual]
OnVCClearSceneByName(HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aScene) | GscActionsDispatcher | [inline, protected, virtual]
OnVCFullMode(HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aFullMode, const bool aSensitiveAreaEnabled) | GscActionsDispatcher | [inline, protected, virtual]
OnVCSceneChanged(HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aScene) | GscActionsDispatcher | [inline, protected, virtual]
OnVCSetAudioLevel(HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int32 aAudioLevel) | GscActionsDispatcher | [inline, protected, virtual]
OnVCShowViewerText(HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aShowText) | GscActionsDispatcher | [inline, protected, virtual]
OnVCStretchMode(HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aStretchMode) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoContrastDetected(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoContrastFailed(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoSetImageBrightness(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aBrightness) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoSetImageContrast(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aContrast) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoSetImageSaturation(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSensorKind aSensorType, const __int32 aSaturation) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoSourceChanged(HGscAction anAction, const TPlcMediaChannelID &aChannel, const VideoSignalNorm aSignalNorm, const VideoSignalType aSignalType, const VideoInterlaceType aInterlaceType) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoSyncDetected(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnVideoSyncFailed(HGscAction anAction, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerChangeScene(HGscAction anAction, const TPlcMediaChannelID &aViewer) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerClear(HGscAction anAction, const TPlcMediaChannelID &aViewer) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerCleared(HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerClearScene(HGscAction anAction, const TPlcMediaChannelID &aViewer) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerClearTextOutput(HGscAction anAction, const TPlcMediaChannelID &aViewer) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerConnect(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerConnected(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerConnectLive(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerExportPicture(HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aFilePath) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerJumpByTime(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const __int32 aTimeInSec) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerMaximize(HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aMaximize) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerPlayFromTime(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime &aTime) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerPlayModeChanged(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const TGLibDateTime *aChannelTime, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerPrintPicture(HGscAction anAction, const TPlcMediaChannelID &aViewer) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerSelect(HGscAction anAction, const TPlcMediaChannelID &aViewer) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerSelectionChanged(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcMediaChannelID &aChannel, const PlcViewerPlayMode aPlayMode, const wchar_t *aClientHost, const PlcClientType *aClientType, const wchar_t *aClientAccount) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerSetPlayMode(HGscAction anAction, const TPlcMediaChannelID &aViewer, const PlcViewerPlayMode aPlayMode, const __int32 aPlaySpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerShowAlarmByInstance(HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aAlarmID, const PlcViewerAlarmPlayMode aPlayMode) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerShowAlarmByKey(HGscAction anAction, const TPlcMediaChannelID &aViewer, const __int64 &aForeignKey, const PlcViewerAlarmPlayMode aPlayMode) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerShowAlarmByType(HGscAction anAction, const TPlcMediaChannelID &aViewer, const TPlcEventTypeID &aTypeID, const __int64 *aForeignKey, const PlcViewerAlarmPlayMode aPlayMode) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerSyncAudioAndVideo(HGscAction anAction, const TPlcMediaChannelID &aViewer, const bool aEnableSync) | GscActionsDispatcher | [inline, protected, virtual]
OnViewerTextOutput(HGscAction anAction, const TPlcMediaChannelID &aViewer, const wchar_t *aText) | GscActionsDispatcher | [inline, protected, virtual]
OnWatchdogActivate(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnWatchdogDeactivate(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnWatchdogTrigger(HGscAction anAction) | GscActionsDispatcher | [inline, protected, virtual]
OnZoomIn(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnZoomOut(HGscAction anAction, const TPlcMediaChannelID &aCamera, const __int32 aSpeed) | GscActionsDispatcher | [inline, protected, virtual]
OnZoomStop(HGscAction anAction, const TPlcMediaChannelID &aCamera) | GscActionsDispatcher | [inline, protected, virtual]
~GscActionsDispatcher() | GscActionsDispatcher | [inline, virtual]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGLibDateTime Member List

This is the complete list of members for TGLibDateTime, including all inherited members.


GSC actions: Alphabetical List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Class Index

B | C | D | G | T | _
B
double TGscActionClassInfo TGscParameterInfo TPlcRect
bool
G
TGscActionClassPlainInfo TGscParameterPlainInfo TPlcResourceID
C
GscActionsDispatcher TGscActionInfo TPlcActionEventDataRecord TPlcUpdateActionInfoCallback
CGscAction GUID TGscActionPlainInfo TPlcEventTypeID
_
CGscMatchAction
T
TGscEnumInfo TPlcLastError __int32
CGscMessage TGLibDateTime TGscEnumPlainInfo TPlcMediaChannelID __int64
D
B | C | D | G | T | _


GSC actions: doxy.txt File Reference

  • File List
  • File Members
Namespaces

doxy.txt File Reference

Detailed Description

Internal definitions for Doxygen.

Definition in file doxy.txt.

Namespaces

namespace GscPLC

PLC namespace.


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Left : TPlcRect


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • Matches() : CGscMatchAction


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • NameA : TGscActionClassInfo , TGscActionInfo , TGscEnumInfo , TGscParameterInfo
  • NameW : TGscActionInfo , TGscActionClassInfo , TGscEnumInfo , TGscParameterInfo
  • NumberOfParameters : TGscActionInfo


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • OnABCConnect() : GscActionsDispatcher
  • OnABCDisconnect() : GscActionsDispatcher
  • OnABCPlayFile() : GscActionsDispatcher
  • OnAbortAllAutoBackups() : GscActionsDispatcher
  • OnAbortAutoBackup() : GscActionsDispatcher
  • OnACSAccessDenied() : GscActionsDispatcher
  • OnACSAccessGranted() : GscActionsDispatcher
  • OnACSRawAnswer() : GscActionsDispatcher
  • OnACSRawData() : GscActionsDispatcher
  • OnActivateExternalProcess() : GscActionsDispatcher
  • OnATMRawAnswer() : GscActionsDispatcher
  • OnATMRawData() : GscActionsDispatcher
  • OnATMTransaction() : GscActionsDispatcher
  • OnAutoBackupCapacityMonitoringCapacityWarning() : GscActionsDispatcher
  • OnAutoBackupCapacityMonitoringFileAutoDeleted() : GscActionsDispatcher
  • OnAutoBackupCapacityMonitoringOutOfDiskSpace() : GscActionsDispatcher
  • OnAutoBackupFileDone() : GscActionsDispatcher
  • OnAutoBackupFileProgress() : GscActionsDispatcher
  • OnAutoBackupFileStarted() : GscActionsDispatcher
  • OnAutoBackupOperationDone() : GscActionsDispatcher
  • OnAutoBackupOperationStarted() : GscActionsDispatcher
  • OnAutoBackupScheduleDone() : GscActionsDispatcher
  • OnAutoBackupScheduleStarted() : GscActionsDispatcher
  • OnAutoFocusOff() : GscActionsDispatcher
  • OnAutoFocusOn() : GscActionsDispatcher
  • OnBackupEvent() : GscActionsDispatcher
  • OnBarcodeData() : GscActionsDispatcher
  • OnBlockingFilterActivate() : GscActionsDispatcher
  • OnBlockingFilterDeactivate() : GscActionsDispatcher
  • OnCameraApplyProfile() : GscActionsDispatcher
  • OnCameraBacklightCompensationMode() : GscActionsDispatcher
  • OnCameraClearPrePosText() : GscActionsDispatcher
  • OnCameraDayNightMode() : GscActionsDispatcher
  • OnCameraLightOff() : GscActionsDispatcher
  • OnCameraLightOn() : GscActionsDispatcher
  • OnCameraManualIrisOff() : GscActionsDispatcher
  • OnCameraManualIrisOn() : GscActionsDispatcher
  • OnCameraOff() : GscActionsDispatcher
  • OnCameraOn() : GscActionsDispatcher
  • OnCameraPumpOff() : GscActionsDispatcher
  • OnCameraPumpOn() : GscActionsDispatcher
  • OnCameraRAWOutput() : GscActionsDispatcher
  • OnCameraSelectCharMode() : GscActionsDispatcher
  • OnCameraSetPrePosText() : GscActionsDispatcher
  • OnCameraSpecFuncUOff() : GscActionsDispatcher
  • OnCameraSpecFuncUOn() : GscActionsDispatcher
  • OnCameraSpecFuncVOff() : GscActionsDispatcher
  • OnCameraSpecFuncVOn() : GscActionsDispatcher
  • OnCameraSpecFuncXOff() : GscActionsDispatcher
  • OnCameraSpecFuncXOn() : GscActionsDispatcher
  • OnCameraSpecFuncYOff() : GscActionsDispatcher
  • OnCameraSpecFuncYOn() : GscActionsDispatcher
  • OnCameraStopAll() : GscActionsDispatcher
  • OnCameraTextOff() : GscActionsDispatcher
  • OnCameraTextOn() : GscActionsDispatcher
  • OnCameraTourStart() : GscActionsDispatcher
  • OnCameraTourStop() : GscActionsDispatcher
  • OnCameraVersionOff() : GscActionsDispatcher
  • OnCameraVersionOn() : GscActionsDispatcher
  • OnCameraWashOff() : GscActionsDispatcher
  • OnCameraWashOn() : GscActionsDispatcher
  • OnCancelExport() : GscActionsDispatcher
  • OnCaseClosed() : GscActionsDispatcher
  • OnCaseOpened() : GscActionsDispatcher
  • OnChangeADParameterSet() : GscActionsDispatcher
  • OnChangeCameraProfile() : GscActionsDispatcher
  • OnChangeCPAParameterSet() : GscActionsDispatcher
  • OnChangeGTectParameterSet() : GscActionsDispatcher
  • OnChangeObtrackParameterSet() : GscActionsDispatcher
  • OnChangeVMDParameterSet() : GscActionsDispatcher
  • OnChannelError() : GscActionsDispatcher
  • OnChannelInfo() : GscActionsDispatcher
  • OnChannelLiveCheck() : GscActionsDispatcher
  • OnChannelWarning() : GscActionsDispatcher
  • OnCPAMeasurement() : GscActionsDispatcher
  • OnCustomAction() : GscActionsDispatcher
  • OnDatabaseRecordingInfoRing() : GscActionsDispatcher
  • OnDatabaseRecordingInfoTotal() : GscActionsDispatcher
  • OnDatabaseStarted() : GscActionsDispatcher
  • OnDefaultPosCallUp() : GscActionsDispatcher
  • OnDefaultPosClear() : GscActionsDispatcher
  • OnDefaultPosSave() : GscActionsDispatcher
  • OnDeviceFound() : GscActionsDispatcher
  • OnDeviceNewFirmware() : GscActionsDispatcher
  • OnDevicePluginError() : GscActionsDispatcher
  • OnDevicePluginState() : GscActionsDispatcher
  • OnDeviceReattached() : GscActionsDispatcher
  • OnDeviceRemoved() : GscActionsDispatcher
  • OnDigitalInput() : GscActionsDispatcher
  • OnEventBackupDone() : GscActionsDispatcher
  • OnEventBackupFileDone() : GscActionsDispatcher
  • OnEventBackupFileProgress() : GscActionsDispatcher
  • OnEventBackupFileStarted() : GscActionsDispatcher
  • OnEventBackupStarted() : GscActionsDispatcher
  • OnEventRecordingChanged() : GscActionsDispatcher
  • OnEventStarted() : GscActionsDispatcher
  • OnEventStopped() : GscActionsDispatcher
  • OnExportFinished() : GscActionsDispatcher
  • OnExportProgress() : GscActionsDispatcher
  • OnFastSpeedOff() : GscActionsDispatcher
  • OnFastSpeedOn() : GscActionsDispatcher
  • OnFillingPumpStatus() : GscActionsDispatcher
  • OnFocusFar() : GscActionsDispatcher
  • OnFocusNear() : GscActionsDispatcher
  • OnFocusStop() : GscActionsDispatcher
  • OnFRCNotification() : GscActionsDispatcher
  • OnGEMOSalarm() : GscActionsDispatcher
  • OnGSCSVehicleAccessDenied() : GscActionsDispatcher
  • OnGSCSVehicleAccessExpired() : GscActionsDispatcher
  • OnGSCSVehicleAccessGranted() : GscActionsDispatcher
  • OnGSCSVehicleAccessPending() : GscActionsDispatcher
  • OnGTectAnalyticsLiveCheck() : GscActionsDispatcher
  • OnGTectDualSensorAlarm() : GscActionsDispatcher
  • OnGTectDualSensorAlarmFinished() : GscActionsDispatcher
  • OnGTectSceneAlarm() : GscActionsDispatcher
  • OnGTectSceneAlarmFinished() : GscActionsDispatcher
  • OnGTectVMXAlarm() : GscActionsDispatcher
  • OnGTectVMXAlarmFinished() : GscActionsDispatcher
  • OnIASSettingsChanged() : GscActionsDispatcher
  • OnImageExportNotification() : GscActionsDispatcher
  • OnImexCapacityFileAutoDeleted() : GscActionsDispatcher
  • OnImexCapacityOutOfDiskSpace() : GscActionsDispatcher
  • OnImexCapacityWarning() : GscActionsDispatcher
  • OnImexExportEventImage() : GscActionsDispatcher
  • OnImexExportImageFromDB() : GscActionsDispatcher
  • OnImexExportImageFromLiveStream() : GscActionsDispatcher
  • OnInitializeRemoteExport() : GscActionsDispatcher
  • OnInterfaceRawAnswer() : GscActionsDispatcher
  • OnInterfaceRawData() : GscActionsDispatcher
  • OnIOI43ResetMainboard() : GscActionsDispatcher
  • OnIOI43Temperature() : GscActionsDispatcher
  • OnIOI43WDActivate() : GscActionsDispatcher
  • OnIOI43WDDeactivate() : GscActionsDispatcher
  • OnIOI43WDTrigger() : GscActionsDispatcher
  • OnIPCameraRawCommand() : GscActionsDispatcher
  • OnIPCamFailoverNotification() : GscActionsDispatcher
  • OnIPCamFailoverRestore() : GscActionsDispatcher
  • OnIPSwitchOperation() : GscActionsDispatcher
  • OnIrisClose() : GscActionsDispatcher
  • OnIrisOpen() : GscActionsDispatcher
  • OnIrisStop() : GscActionsDispatcher
  • OnKeyPressed() : GscActionsDispatcher
  • OnKeyReleased() : GscActionsDispatcher
  • OnKillAllEvents() : GscActionsDispatcher
  • OnKillEvent() : GscActionsDispatcher
  • OnKillEventByID() : GscActionsDispatcher
  • OnLenelAccessEvent() : GscActionsDispatcher
  • OnLenelFireEvent() : GscActionsDispatcher
  • OnLenelIntercomEvent() : GscActionsDispatcher
  • OnLenelRawData() : GscActionsDispatcher
  • OnLenelRefreshNames() : GscActionsDispatcher
  • OnLenelSecurityEvent() : GscActionsDispatcher
  • OnLenelVideoEvent() : GscActionsDispatcher
  • OnLiveCheck() : GscActionsDispatcher
  • OnLogBarcodeData() : GscActionsDispatcher
  • OnLogBarcodeDataLPS() : GscActionsDispatcher
  • OnLogNPRRecognition() : GscActionsDispatcher
  • OnLPSPositionData() : GscActionsDispatcher
  • OnLPSQueryPosition() : GscActionsDispatcher
  • OnMakeCPAReferenceImage() : GscActionsDispatcher
  • OnMediaChannelSetupInfo() : GscActionsDispatcher
  • OnMoveToAbsolutePosition() : GscActionsDispatcher
  • OnMoveToBySpeed() : GscActionsDispatcher
  • OnMoveToRelativePosition() : GscActionsDispatcher
  • OnNPRRawData() : GscActionsDispatcher
  • OnNPRRecognition() : GscActionsDispatcher
  • OnObtrackChannelCounter() : GscActionsDispatcher
  • OnObtrackChannelCounterThreshold() : GscActionsDispatcher
  • OnObtrackChannelSetCounter() : GscActionsDispatcher
  • OnObtrackFrameRawData() : GscActionsDispatcher
  • OnObtrackGroupCounter() : GscActionsDispatcher
  • OnObtrackGroupCounterThreshold() : GscActionsDispatcher
  • OnObtrackGroupSetCounter() : GscActionsDispatcher
  • OnObtrackObjectRawData() : GscActionsDispatcher
  • OnObtrackTunnelAlarm() : GscActionsDispatcher
  • OnPanAuto() : GscActionsDispatcher
  • OnPanLeft() : GscActionsDispatcher
  • OnPanRight() : GscActionsDispatcher
  • OnPanStop() : GscActionsDispatcher
  • OnPOSData() : GscActionsDispatcher
  • OnPOSStatus() : GscActionsDispatcher
  • OnPPDeviceAlarm() : GscActionsDispatcher
  • OnPPDeviceInput() : GscActionsDispatcher
  • OnPPDeviceOffline() : GscActionsDispatcher
  • OnPPDeviceOnline() : GscActionsDispatcher
  • OnPPInterfaceOffline() : GscActionsDispatcher
  • OnPPInterfaceOnline() : GscActionsDispatcher
  • OnPPQueryInterface() : GscActionsDispatcher
  • OnPPSetDeviceOutput() : GscActionsDispatcher
  • OnPPSubcellAlarm() : GscActionsDispatcher
  • OnPPZoneAlarm() : GscActionsDispatcher
  • OnPrePosCallUp() : GscActionsDispatcher
  • OnPrePosClear() : GscActionsDispatcher
  • OnPrePosSave() : GscActionsDispatcher
  • OnRedundantPowerFailure() : GscActionsDispatcher
  • OnRedundantPowerOk() : GscActionsDispatcher
  • OnResetMainboard() : GscActionsDispatcher
  • OnSafebagClose() : GscActionsDispatcher
  • OnSafebagData() : GscActionsDispatcher
  • OnSafebagOpen() : GscActionsDispatcher
  • OnSafebagPassingOfRiskData() : GscActionsDispatcher
  • OnSafebagPassingOfRiskStart() : GscActionsDispatcher
  • OnSafebagPassingOfRiskStop() : GscActionsDispatcher
  • OnSceneStoreModification() : GscActionsDispatcher
  • OnSensorAlarmFinished() : GscActionsDispatcher
  • OnSensorAudioAlarm() : GscActionsDispatcher
  • OnSensorInhibitAlarmFinished() : GscActionsDispatcher
  • OnSensorInhibitVideoAlarm() : GscActionsDispatcher
  • OnSensorVideoAlarm() : GscActionsDispatcher
  • OnSetCameraText() : GscActionsDispatcher
  • OnSetClientVCA() : GscActionsDispatcher
  • OnSetClock() : GscActionsDispatcher
  • OnSetDigitalOutput() : GscActionsDispatcher
  • OnSetExportMarker() : GscActionsDispatcher
  • OnSetLED() : GscActionsDispatcher
  • OnSetLEDBlink() : GscActionsDispatcher
  • OnSetSystemTime() : GscActionsDispatcher
  • OnSetTestPictureMode() : GscActionsDispatcher
  • OnSetupChanged() : GscActionsDispatcher
  • OnSetupUploadProgress() : GscActionsDispatcher
  • OnSetWatchdog() : GscActionsDispatcher
  • OnSkidataControl() : GscActionsDispatcher
  • OnSkidataDeviceEvent() : GscActionsDispatcher
  • OnSkidataEntry() : GscActionsDispatcher
  • OnSkidataExit() : GscActionsDispatcher
  • OnSkidataTransaction() : GscActionsDispatcher
  • OnSMRPViewerCleared() : GscActionsDispatcher
  • OnSMRPViewerConnected() : GscActionsDispatcher
  • OnSMTPMailSend() : GscActionsDispatcher
  • OnStartAutoBackup() : GscActionsDispatcher
  • OnStartEvent() : GscActionsDispatcher
  • OnStartRemoteExport() : GscActionsDispatcher
  • OnStartSceneStore() : GscActionsDispatcher
  • OnStopAllEvents() : GscActionsDispatcher
  • OnStopEvent() : GscActionsDispatcher
  • OnStopEventByID() : GscActionsDispatcher
  • OnSystemError() : GscActionsDispatcher
  • OnSystemInfo() : GscActionsDispatcher
  • OnSystemSettingsChanged() : GscActionsDispatcher
  • OnSystemStarted() : GscActionsDispatcher
  • OnSystemTerminating() : GscActionsDispatcher
  • OnSystemWarning() : GscActionsDispatcher
  • OnTemperature() : GscActionsDispatcher
  • OnTerminalArticleData() : GscActionsDispatcher
  • OnTerminalPaymentData() : GscActionsDispatcher
  • OnTiltDown() : GscActionsDispatcher
  • OnTiltStop() : GscActionsDispatcher
  • OnTiltUp() : GscActionsDispatcher
  • OnTransferBinaryBuffer() : GscActionsDispatcher
  • OnTransferBinaryChannelBuffer() : GscActionsDispatcher
  • OnUnregisteredMessage() : GscActionsDispatcher
  • OnUserLogin() : GscActionsDispatcher
  • OnUserLoginFailed() : GscActionsDispatcher
  • OnUserLogout() : GscActionsDispatcher
  • OnVCAlarmQueueConfirm() : GscActionsDispatcher
  • OnVCAlarmQueueConfirmByInstance() : GscActionsDispatcher
  • OnVCAlarmQueueConfirmByType() : GscActionsDispatcher
  • OnVCAlarmQueueNotification() : GscActionsDispatcher
  • OnVCAlarmQueueRemove() : GscActionsDispatcher
  • OnVCAlarmQueueRemoveByInstance() : GscActionsDispatcher
  • OnVCAlarmQueueRemoveByType() : GscActionsDispatcher
  • OnVCAlarmQueueSelect() : GscActionsDispatcher
  • OnVCAlarmQueueSelectByInstance() : GscActionsDispatcher
  • OnVCAlarmQueueSelectByType() : GscActionsDispatcher
  • OnVCASetArmed() : GscActionsDispatcher
  • OnVCAStatusAnswer() : GscActionsDispatcher
  • OnVCAStatusRequest() : GscActionsDispatcher
  • OnVCChangeSceneByName() : GscActionsDispatcher
  • OnVCClearSceneByName() : GscActionsDispatcher
  • OnVCFullMode() : GscActionsDispatcher
  • OnVCSceneChanged() : GscActionsDispatcher
  • OnVCSetAudioLevel() : GscActionsDispatcher
  • OnVCShowViewerText() : GscActionsDispatcher
  • OnVCStretchMode() : GscActionsDispatcher
  • OnVideoContrastDetected() : GscActionsDispatcher
  • OnVideoContrastFailed() : GscActionsDispatcher
  • OnVideoSetImageBrightness() : GscActionsDispatcher
  • OnVideoSetImageContrast() : GscActionsDispatcher
  • OnVideoSetImageSaturation() : GscActionsDispatcher
  • OnVideoSourceChanged() : GscActionsDispatcher
  • OnVideoSyncDetected() : GscActionsDispatcher
  • OnVideoSyncFailed() : GscActionsDispatcher
  • OnViewerChangeScene() : GscActionsDispatcher
  • OnViewerClear() : GscActionsDispatcher
  • OnViewerCleared() : GscActionsDispatcher
  • OnViewerClearScene() : GscActionsDispatcher
  • OnViewerClearTextOutput() : GscActionsDispatcher
  • OnViewerConnect() : GscActionsDispatcher
  • OnViewerConnected() : GscActionsDispatcher
  • OnViewerConnectLive() : GscActionsDispatcher
  • OnViewerExportPicture() : GscActionsDispatcher
  • OnViewerJumpByTime() : GscActionsDispatcher
  • OnViewerMaximize() : GscActionsDispatcher
  • OnViewerPlayFromTime() : GscActionsDispatcher
  • OnViewerPlayModeChanged() : GscActionsDispatcher
  • OnViewerPrintPicture() : GscActionsDispatcher
  • OnViewerSelect() : GscActionsDispatcher
  • OnViewerSelectionChanged() : GscActionsDispatcher
  • OnViewerSetPlayMode() : GscActionsDispatcher
  • OnViewerShowAlarmByInstance() : GscActionsDispatcher
  • OnViewerShowAlarmByKey() : GscActionsDispatcher
  • OnViewerShowAlarmByType() : GscActionsDispatcher
  • OnViewerSyncAudioAndVideo() : GscActionsDispatcher
  • OnViewerTextOutput() : GscActionsDispatcher
  • OnWatchdogActivate() : GscActionsDispatcher
  • OnWatchdogDeactivate() : GscActionsDispatcher
  • OnWatchdogTrigger() : GscActionsDispatcher
  • OnZoomIn() : GscActionsDispatcher
  • OnZoomOut() : GscActionsDispatcher
  • OnZoomStop() : GscActionsDispatcher
  • operator delete() : CGscMatchAction , CGscAction , CGscMessage
  • operator!=() : CGscMessage , TPlcRect
  • operator==() : CGscMessage , TPlcRect


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~GscActionsDispatcher() : GscActionsDispatcher


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • Bottom : TPlcRect


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : TPlcMediaChannelID
  • ChannelName : TPlcMediaChannelID
  • ClassName : TPlcLastError
  • Clear() : TPlcActionEventDataRecord
  • CloneHandle() : CGscMessage , CGscAction , CGscMatchAction
  • CloseHandle() : CGscMessage
  • CreateActionFromTemplate() : CGscMatchAction
  • CreateFromBinBuffer() : CGscMessage , CGscAction , CGscMatchAction
  • CreateFromTextBuffer() : CGscAction , CGscMatchAction , CGscMessage
  • CreateMatchActionFromTemplate() : CGscAction


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • DescriptionA : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo
  • DescriptionU : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo
  • DescriptionW : TGscActionPlainInfo , TGscParameterPlainInfo , TGscActionClassPlainInfo
  • DisableInternalInEventData() : CGscMessage
  • DisableMatchBy() : TGscActionInfo , TGscParameterInfo
  • DisableOnMatch() : TGscParameterInfo , TGscActionInfo
  • DisableResourceUpdate() : CGscMessage
  • Dispatch() : GscActionsDispatcher
  • DuplicateHandle() : CGscMessage


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • EnumType : TGscEnumInfo
  • EnumValue : TGscEnumInfo
  • EqualTo() : CGscMessage
  • ErrorClass : TPlcLastError
  • ErrorCode : TPlcLastError
  • ErrorMessageA : TPlcLastError
  • ErrorMessageW : TPlcLastError
  • EventData : TPlcActionEventDataRecord
  • EventDataID : TPlcActionEventDataRecord
  • EventDataKind : TPlcActionEventDataRecord
  • EventDataSize : TPlcActionEventDataRecord
  • EventDataTime : TPlcActionEventDataRecord
  • EventDouble_A : TPlcActionEventDataRecord
  • EventDouble_B : TPlcActionEventDataRecord
  • EventID : TPlcActionEventDataRecord
  • EventInt32_A : TPlcActionEventDataRecord
  • EventInt32_B : TPlcActionEventDataRecord
  • EventInt32_C : TPlcActionEventDataRecord
  • EventInt32_D : TPlcActionEventDataRecord
  • EventInt64_A : TPlcActionEventDataRecord
  • EventInt64_B : TPlcActionEventDataRecord
  • EventInt64_C : TPlcActionEventDataRecord
  • EventInt64_D : TPlcActionEventDataRecord
  • EventName : TPlcEventTypeID
  • EventString_A : TPlcActionEventDataRecord
  • EventString_A_Size : TPlcActionEventDataRecord
  • EventString_B : TPlcActionEventDataRecord
  • EventString_B_Size : TPlcActionEventDataRecord
  • EventTime_A : TPlcActionEventDataRecord
  • EventTime_B : TPlcActionEventDataRecord
  • EventTypeID : TPlcEventTypeID


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetActionClass() : CGscAction , CGscMatchAction
  • GetActionCode() : CGscMatchAction , CGscAction
  • GetActionCodeByIndex() : CGscAction
  • GetActionEventData() : CGscAction , CGscMatchAction
  • GetActionNameA() : CGscAction , CGscMatchAction
  • GetActionNameW() : CGscAction , CGscMatchAction
  • GetActionPlainNameA() : CGscAction , CGscMatchAction
  • GetActionPlainNameW() : CGscAction , CGscMatchAction
  • GetCommentA() : CGscMatchAction
  • GetCommentW() : CGscMatchAction
  • GetDescriptionA() : CGscMatchAction
  • GetDescriptionW() : CGscMatchAction
  • GetForeignKey() : CGscAction
  • GetGenericInt32Parameter() : CGscAction
  • GetInputContact() : CGscAction
  • GetInternalData() : CGscMessage
  • GetInternalIndex() : CGscMessage
  • GetInternalIndexByCode() : CGscAction
  • GetMessageClass() : CGscMessage
  • GetMessageFlags() : CGscMessage
  • GetOutputContact() : CGscAction
  • GetProperties() : CGscAction
  • GetProperty() : CGscAction
  • GetReferenceCounter() : CGscMessage
  • GetVideoInput() : CGscAction
  • GetVideoOutput() : CGscAction
  • GetWindowsClientInfo() : CGscAction
  • GlobalNo : TPlcMediaChannelID
  • GscActionsDispatcher() : GscActionsDispatcher


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • HasDescription() : CGscMatchAction


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • ParameterSetupMask : TGscParameterInfo
  • ParameterType : TGscParameterInfo
  • ParameterView : TGscParameterInfo
  • PlainNameA : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo , TGscEnumPlainInfo
  • PlainNameU : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo , TGscEnumPlainInfo
  • PlainNameW : TGscEnumPlainInfo , TGscActionClassPlainInfo , TGscParameterPlainInfo , TGscActionPlainInfo


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • Reserved : TPlcEventTypeID , TPlcResourceID , TGscParameterInfo , TGscEnumPlainInfo , TGscActionClassInfo
  • ResourceID : TPlcResourceID
  • ResourceName : TPlcResourceID
  • RestoreActionFromEventData() : CGscAction , CGscMatchAction
  • Right : TPlcRect


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SetComment() : CGscMatchAction
  • SetDescription() : CGscMatchAction
  • SetInternalData() : CGscMessage
  • SetMessageFlags() : CGscMessage
  • SetProperty() : CGscAction
  • StoreToBinBuffer() : CGscMessage
  • StoreToTextBuffer() : CGscMessage
  • StructSize : TPlcActionEventDataRecord


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Top : TPlcRect
  • TPlcActionEventDataRecord() : TPlcActionEventDataRecord
  • TPlcEventTypeID() : TPlcEventTypeID
  • TPlcMediaChannelID() : TPlcMediaChannelID
  • TPlcRect() : TPlcRect
  • TPlcResourceID() : TPlcResourceID


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateActionInfo() : CGscAction
  • UpdateEventType : TPlcUpdateActionInfoCallback
  • UpdateInputContact : TPlcUpdateActionInfoCallback
  • UpdateOutputContact : TPlcUpdateActionInfoCallback
  • UpdateParameterSet : TPlcUpdateActionInfoCallback
  • UpdateResource : TPlcUpdateActionInfoCallback
  • UpdateVideoInput : TPlcUpdateActionInfoCallback
  • UpdateVideoOutput : TPlcUpdateActionInfoCallback
  • UpdateWindowsClientInfo() : CGscAction


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • Version : TPlcUpdateActionInfoCallback


GSC actions: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • XMLInfo : TPlcLastError


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- c -

  • Clear() : TPlcActionEventDataRecord
  • CloneHandle() : CGscMessage , CGscMatchAction , CGscAction
  • CloseHandle() : CGscMessage
  • CreateActionFromTemplate() : CGscMatchAction
  • CreateFromBinBuffer() : CGscAction , CGscMatchAction , CGscMessage
  • CreateFromTextBuffer() : CGscMessage , CGscAction , CGscMatchAction , CGscMessage , CGscAction
  • CreateMatchActionFromTemplate() : CGscAction


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- m -

  • Matches() : CGscMatchAction


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- o -

  • OnABCConnect() : GscActionsDispatcher
  • OnABCDisconnect() : GscActionsDispatcher
  • OnABCPlayFile() : GscActionsDispatcher
  • OnAbortAllAutoBackups() : GscActionsDispatcher
  • OnAbortAutoBackup() : GscActionsDispatcher
  • OnACSAccessDenied() : GscActionsDispatcher
  • OnACSAccessGranted() : GscActionsDispatcher
  • OnACSRawAnswer() : GscActionsDispatcher
  • OnACSRawData() : GscActionsDispatcher
  • OnActivateExternalProcess() : GscActionsDispatcher
  • OnATMRawAnswer() : GscActionsDispatcher
  • OnATMRawData() : GscActionsDispatcher
  • OnATMTransaction() : GscActionsDispatcher
  • OnAutoBackupCapacityMonitoringCapacityWarning() : GscActionsDispatcher
  • OnAutoBackupCapacityMonitoringFileAutoDeleted() : GscActionsDispatcher
  • OnAutoBackupCapacityMonitoringOutOfDiskSpace() : GscActionsDispatcher
  • OnAutoBackupFileDone() : GscActionsDispatcher
  • OnAutoBackupFileProgress() : GscActionsDispatcher
  • OnAutoBackupFileStarted() : GscActionsDispatcher
  • OnAutoBackupOperationDone() : GscActionsDispatcher
  • OnAutoBackupOperationStarted() : GscActionsDispatcher
  • OnAutoBackupScheduleDone() : GscActionsDispatcher
  • OnAutoBackupScheduleStarted() : GscActionsDispatcher
  • OnAutoFocusOff() : GscActionsDispatcher
  • OnAutoFocusOn() : GscActionsDispatcher
  • OnBackupEvent() : GscActionsDispatcher
  • OnBarcodeData() : GscActionsDispatcher
  • OnBlockingFilterActivate() : GscActionsDispatcher
  • OnBlockingFilterDeactivate() : GscActionsDispatcher
  • OnCameraApplyProfile() : GscActionsDispatcher
  • OnCameraBacklightCompensationMode() : GscActionsDispatcher
  • OnCameraClearPrePosText() : GscActionsDispatcher
  • OnCameraDayNightMode() : GscActionsDispatcher
  • OnCameraLightOff() : GscActionsDispatcher
  • OnCameraLightOn() : GscActionsDispatcher
  • OnCameraManualIrisOff() : GscActionsDispatcher
  • OnCameraManualIrisOn() : GscActionsDispatcher
  • OnCameraOff() : GscActionsDispatcher
  • OnCameraOn() : GscActionsDispatcher
  • OnCameraPumpOff() : GscActionsDispatcher
  • OnCameraPumpOn() : GscActionsDispatcher
  • OnCameraRAWOutput() : GscActionsDispatcher
  • OnCameraSelectCharMode() : GscActionsDispatcher
  • OnCameraSetPrePosText() : GscActionsDispatcher
  • OnCameraSpecFuncUOff() : GscActionsDispatcher
  • OnCameraSpecFuncUOn() : GscActionsDispatcher
  • OnCameraSpecFuncVOff() : GscActionsDispatcher
  • OnCameraSpecFuncVOn() : GscActionsDispatcher
  • OnCameraSpecFuncXOff() : GscActionsDispatcher
  • OnCameraSpecFuncXOn() : GscActionsDispatcher
  • OnCameraSpecFuncYOff() : GscActionsDispatcher
  • OnCameraSpecFuncYOn() : GscActionsDispatcher
  • OnCameraStopAll() : GscActionsDispatcher
  • OnCameraTextOff() : GscActionsDispatcher
  • OnCameraTextOn() : GscActionsDispatcher
  • OnCameraTourStart() : GscActionsDispatcher
  • OnCameraTourStop() : GscActionsDispatcher
  • OnCameraVersionOff() : GscActionsDispatcher
  • OnCameraVersionOn() : GscActionsDispatcher
  • OnCameraWashOff() : GscActionsDispatcher
  • OnCameraWashOn() : GscActionsDispatcher
  • OnCancelExport() : GscActionsDispatcher
  • OnCaseClosed() : GscActionsDispatcher
  • OnCaseOpened() : GscActionsDispatcher
  • OnChangeADParameterSet() : GscActionsDispatcher
  • OnChangeCameraProfile() : GscActionsDispatcher
  • OnChangeCPAParameterSet() : GscActionsDispatcher
  • OnChangeGTectParameterSet() : GscActionsDispatcher
  • OnChangeObtrackParameterSet() : GscActionsDispatcher
  • OnChangeVMDParameterSet() : GscActionsDispatcher
  • OnChannelError() : GscActionsDispatcher
  • OnChannelInfo() : GscActionsDispatcher
  • OnChannelLiveCheck() : GscActionsDispatcher
  • OnChannelWarning() : GscActionsDispatcher
  • OnCPAMeasurement() : GscActionsDispatcher
  • OnCustomAction() : GscActionsDispatcher
  • OnDatabaseRecordingInfoRing() : GscActionsDispatcher
  • OnDatabaseRecordingInfoTotal() : GscActionsDispatcher
  • OnDatabaseStarted() : GscActionsDispatcher
  • OnDefaultPosCallUp() : GscActionsDispatcher
  • OnDefaultPosClear() : GscActionsDispatcher
  • OnDefaultPosSave() : GscActionsDispatcher
  • OnDeviceFound() : GscActionsDispatcher
  • OnDeviceNewFirmware() : GscActionsDispatcher
  • OnDevicePluginError() : GscActionsDispatcher
  • OnDevicePluginState() : GscActionsDispatcher
  • OnDeviceReattached() : GscActionsDispatcher
  • OnDeviceRemoved() : GscActionsDispatcher
  • OnDigitalInput() : GscActionsDispatcher
  • OnEventBackupDone() : GscActionsDispatcher
  • OnEventBackupFileDone() : GscActionsDispatcher
  • OnEventBackupFileProgress() : GscActionsDispatcher
  • OnEventBackupFileStarted() : GscActionsDispatcher
  • OnEventBackupStarted() : GscActionsDispatcher
  • OnEventRecordingChanged() : GscActionsDispatcher
  • OnEventStarted() : GscActionsDispatcher
  • OnEventStopped() : GscActionsDispatcher
  • OnExportFinished() : GscActionsDispatcher
  • OnExportProgress() : GscActionsDispatcher
  • OnFastSpeedOff() : GscActionsDispatcher
  • OnFastSpeedOn() : GscActionsDispatcher
  • OnFillingPumpStatus() : GscActionsDispatcher
  • OnFocusFar() : GscActionsDispatcher
  • OnFocusNear() : GscActionsDispatcher
  • OnFocusStop() : GscActionsDispatcher
  • OnFRCNotification() : GscActionsDispatcher
  • OnGEMOSalarm() : GscActionsDispatcher
  • OnGSCSVehicleAccessDenied() : GscActionsDispatcher
  • OnGSCSVehicleAccessExpired() : GscActionsDispatcher
  • OnGSCSVehicleAccessGranted() : GscActionsDispatcher
  • OnGSCSVehicleAccessPending() : GscActionsDispatcher
  • OnGTectAnalyticsLiveCheck() : GscActionsDispatcher
  • OnGTectDualSensorAlarm() : GscActionsDispatcher
  • OnGTectDualSensorAlarmFinished() : GscActionsDispatcher
  • OnGTectSceneAlarm() : GscActionsDispatcher
  • OnGTectSceneAlarmFinished() : GscActionsDispatcher
  • OnGTectVMXAlarm() : GscActionsDispatcher
  • OnGTectVMXAlarmFinished() : GscActionsDispatcher
  • OnIASSettingsChanged() : GscActionsDispatcher
  • OnImageExportNotification() : GscActionsDispatcher
  • OnImexCapacityFileAutoDeleted() : GscActionsDispatcher
  • OnImexCapacityOutOfDiskSpace() : GscActionsDispatcher
  • OnImexCapacityWarning() : GscActionsDispatcher
  • OnImexExportEventImage() : GscActionsDispatcher
  • OnImexExportImageFromDB() : GscActionsDispatcher
  • OnImexExportImageFromLiveStream() : GscActionsDispatcher
  • OnInitializeRemoteExport() : GscActionsDispatcher
  • OnInterfaceRawAnswer() : GscActionsDispatcher
  • OnInterfaceRawData() : GscActionsDispatcher
  • OnIOI43ResetMainboard() : GscActionsDispatcher
  • OnIOI43Temperature() : GscActionsDispatcher
  • OnIOI43WDActivate() : GscActionsDispatcher
  • OnIOI43WDDeactivate() : GscActionsDispatcher
  • OnIOI43WDTrigger() : GscActionsDispatcher
  • OnIPCameraRawCommand() : GscActionsDispatcher
  • OnIPCamFailoverNotification() : GscActionsDispatcher
  • OnIPCamFailoverRestore() : GscActionsDispatcher
  • OnIPSwitchOperation() : GscActionsDispatcher
  • OnIrisClose() : GscActionsDispatcher
  • OnIrisOpen() : GscActionsDispatcher
  • OnIrisStop() : GscActionsDispatcher
  • OnKeyPressed() : GscActionsDispatcher
  • OnKeyReleased() : GscActionsDispatcher
  • OnKillAllEvents() : GscActionsDispatcher
  • OnKillEvent() : GscActionsDispatcher
  • OnKillEventByID() : GscActionsDispatcher
  • OnLenelAccessEvent() : GscActionsDispatcher
  • OnLenelFireEvent() : GscActionsDispatcher
  • OnLenelIntercomEvent() : GscActionsDispatcher
  • OnLenelRawData() : GscActionsDispatcher
  • OnLenelRefreshNames() : GscActionsDispatcher
  • OnLenelSecurityEvent() : GscActionsDispatcher
  • OnLenelVideoEvent() : GscActionsDispatcher
  • OnLiveCheck() : GscActionsDispatcher
  • OnLogBarcodeData() : GscActionsDispatcher
  • OnLogBarcodeDataLPS() : GscActionsDispatcher
  • OnLogNPRRecognition() : GscActionsDispatcher
  • OnLPSPositionData() : GscActionsDispatcher
  • OnLPSQueryPosition() : GscActionsDispatcher
  • OnMakeCPAReferenceImage() : GscActionsDispatcher
  • OnMediaChannelSetupInfo() : GscActionsDispatcher
  • OnMoveToAbsolutePosition() : GscActionsDispatcher
  • OnMoveToBySpeed() : GscActionsDispatcher
  • OnMoveToRelativePosition() : GscActionsDispatcher
  • OnNPRRawData() : GscActionsDispatcher
  • OnNPRRecognition() : GscActionsDispatcher
  • OnObtrackChannelCounter() : GscActionsDispatcher
  • OnObtrackChannelCounterThreshold() : GscActionsDispatcher
  • OnObtrackChannelSetCounter() : GscActionsDispatcher
  • OnObtrackFrameRawData() : GscActionsDispatcher
  • OnObtrackGroupCounter() : GscActionsDispatcher
  • OnObtrackGroupCounterThreshold() : GscActionsDispatcher
  • OnObtrackGroupSetCounter() : GscActionsDispatcher
  • OnObtrackObjectRawData() : GscActionsDispatcher
  • OnObtrackTunnelAlarm() : GscActionsDispatcher
  • OnPanAuto() : GscActionsDispatcher
  • OnPanLeft() : GscActionsDispatcher
  • OnPanRight() : GscActionsDispatcher
  • OnPanStop() : GscActionsDispatcher
  • OnPOSData() : GscActionsDispatcher
  • OnPOSStatus() : GscActionsDispatcher
  • OnPPDeviceAlarm() : GscActionsDispatcher
  • OnPPDeviceInput() : GscActionsDispatcher
  • OnPPDeviceOffline() : GscActionsDispatcher
  • OnPPDeviceOnline() : GscActionsDispatcher
  • OnPPInterfaceOffline() : GscActionsDispatcher
  • OnPPInterfaceOnline() : GscActionsDispatcher
  • OnPPQueryInterface() : GscActionsDispatcher
  • OnPPSetDeviceOutput() : GscActionsDispatcher
  • OnPPSubcellAlarm() : GscActionsDispatcher
  • OnPPZoneAlarm() : GscActionsDispatcher
  • OnPrePosCallUp() : GscActionsDispatcher
  • OnPrePosClear() : GscActionsDispatcher
  • OnPrePosSave() : GscActionsDispatcher
  • OnRedundantPowerFailure() : GscActionsDispatcher
  • OnRedundantPowerOk() : GscActionsDispatcher
  • OnResetMainboard() : GscActionsDispatcher
  • OnSafebagClose() : GscActionsDispatcher
  • OnSafebagData() : GscActionsDispatcher
  • OnSafebagOpen() : GscActionsDispatcher
  • OnSafebagPassingOfRiskData() : GscActionsDispatcher
  • OnSafebagPassingOfRiskStart() : GscActionsDispatcher
  • OnSafebagPassingOfRiskStop() : GscActionsDispatcher
  • OnSceneStoreModification() : GscActionsDispatcher
  • OnSensorAlarmFinished() : GscActionsDispatcher
  • OnSensorAudioAlarm() : GscActionsDispatcher
  • OnSensorInhibitAlarmFinished() : GscActionsDispatcher
  • OnSensorInhibitVideoAlarm() : GscActionsDispatcher
  • OnSensorVideoAlarm() : GscActionsDispatcher
  • OnSetCameraText() : GscActionsDispatcher
  • OnSetClientVCA() : GscActionsDispatcher
  • OnSetClock() : GscActionsDispatcher
  • OnSetDigitalOutput() : GscActionsDispatcher
  • OnSetExportMarker() : GscActionsDispatcher
  • OnSetLED() : GscActionsDispatcher
  • OnSetLEDBlink() : GscActionsDispatcher
  • OnSetSystemTime() : GscActionsDispatcher
  • OnSetTestPictureMode() : GscActionsDispatcher
  • OnSetupChanged() : GscActionsDispatcher
  • OnSetupUploadProgress() : GscActionsDispatcher
  • OnSetWatchdog() : GscActionsDispatcher
  • OnSkidataControl() : GscActionsDispatcher
  • OnSkidataDeviceEvent() : GscActionsDispatcher
  • OnSkidataEntry() : GscActionsDispatcher
  • OnSkidataExit() : GscActionsDispatcher
  • OnSkidataTransaction() : GscActionsDispatcher
  • OnSMRPViewerCleared() : GscActionsDispatcher
  • OnSMRPViewerConnected() : GscActionsDispatcher
  • OnSMTPMailSend() : GscActionsDispatcher
  • OnStartAutoBackup() : GscActionsDispatcher
  • OnStartEvent() : GscActionsDispatcher
  • OnStartRemoteExport() : GscActionsDispatcher
  • OnStartSceneStore() : GscActionsDispatcher
  • OnStopAllEvents() : GscActionsDispatcher
  • OnStopEvent() : GscActionsDispatcher
  • OnStopEventByID() : GscActionsDispatcher
  • OnSystemError() : GscActionsDispatcher
  • OnSystemInfo() : GscActionsDispatcher
  • OnSystemSettingsChanged() : GscActionsDispatcher
  • OnSystemStarted() : GscActionsDispatcher
  • OnSystemTerminating() : GscActionsDispatcher
  • OnSystemWarning() : GscActionsDispatcher
  • OnTemperature() : GscActionsDispatcher
  • OnTerminalArticleData() : GscActionsDispatcher
  • OnTerminalPaymentData() : GscActionsDispatcher
  • OnTiltDown() : GscActionsDispatcher
  • OnTiltStop() : GscActionsDispatcher
  • OnTiltUp() : GscActionsDispatcher
  • OnTransferBinaryBuffer() : GscActionsDispatcher
  • OnTransferBinaryChannelBuffer() : GscActionsDispatcher
  • OnUnregisteredMessage() : GscActionsDispatcher
  • OnUserLogin() : GscActionsDispatcher
  • OnUserLoginFailed() : GscActionsDispatcher
  • OnUserLogout() : GscActionsDispatcher
  • OnVCAlarmQueueConfirm() : GscActionsDispatcher
  • OnVCAlarmQueueConfirmByInstance() : GscActionsDispatcher
  • OnVCAlarmQueueConfirmByType() : GscActionsDispatcher
  • OnVCAlarmQueueNotification() : GscActionsDispatcher
  • OnVCAlarmQueueRemove() : GscActionsDispatcher
  • OnVCAlarmQueueRemoveByInstance() : GscActionsDispatcher
  • OnVCAlarmQueueRemoveByType() : GscActionsDispatcher
  • OnVCAlarmQueueSelect() : GscActionsDispatcher
  • OnVCAlarmQueueSelectByInstance() : GscActionsDispatcher
  • OnVCAlarmQueueSelectByType() : GscActionsDispatcher
  • OnVCASetArmed() : GscActionsDispatcher
  • OnVCAStatusAnswer() : GscActionsDispatcher
  • OnVCAStatusRequest() : GscActionsDispatcher
  • OnVCChangeSceneByName() : GscActionsDispatcher
  • OnVCClearSceneByName() : GscActionsDispatcher
  • OnVCFullMode() : GscActionsDispatcher
  • OnVCSceneChanged() : GscActionsDispatcher
  • OnVCSetAudioLevel() : GscActionsDispatcher
  • OnVCShowViewerText() : GscActionsDispatcher
  • OnVCStretchMode() : GscActionsDispatcher
  • OnVideoContrastDetected() : GscActionsDispatcher
  • OnVideoContrastFailed() : GscActionsDispatcher
  • OnVideoSetImageBrightness() : GscActionsDispatcher
  • OnVideoSetImageContrast() : GscActionsDispatcher
  • OnVideoSetImageSaturation() : GscActionsDispatcher
  • OnVideoSourceChanged() : GscActionsDispatcher
  • OnVideoSyncDetected() : GscActionsDispatcher
  • OnVideoSyncFailed() : GscActionsDispatcher
  • OnViewerChangeScene() : GscActionsDispatcher
  • OnViewerClear() : GscActionsDispatcher
  • OnViewerCleared() : GscActionsDispatcher
  • OnViewerClearScene() : GscActionsDispatcher
  • OnViewerClearTextOutput() : GscActionsDispatcher
  • OnViewerConnect() : GscActionsDispatcher
  • OnViewerConnected() : GscActionsDispatcher
  • OnViewerConnectLive() : GscActionsDispatcher
  • OnViewerExportPicture() : GscActionsDispatcher
  • OnViewerJumpByTime() : GscActionsDispatcher
  • OnViewerMaximize() : GscActionsDispatcher
  • OnViewerPlayFromTime() : GscActionsDispatcher
  • OnViewerPlayModeChanged() : GscActionsDispatcher
  • OnViewerPrintPicture() : GscActionsDispatcher
  • OnViewerSelect() : GscActionsDispatcher
  • OnViewerSelectionChanged() : GscActionsDispatcher
  • OnViewerSetPlayMode() : GscActionsDispatcher
  • OnViewerShowAlarmByInstance() : GscActionsDispatcher
  • OnViewerShowAlarmByKey() : GscActionsDispatcher
  • OnViewerShowAlarmByType() : GscActionsDispatcher
  • OnViewerSyncAudioAndVideo() : GscActionsDispatcher
  • OnViewerTextOutput() : GscActionsDispatcher
  • OnWatchdogActivate() : GscActionsDispatcher
  • OnWatchdogDeactivate() : GscActionsDispatcher
  • OnWatchdogTrigger() : GscActionsDispatcher
  • OnZoomIn() : GscActionsDispatcher
  • OnZoomOut() : GscActionsDispatcher
  • OnZoomStop() : GscActionsDispatcher
  • operator delete() : CGscMatchAction , CGscAction , CGscMessage
  • operator!=() : CGscMessage , TPlcRect
  • operator==() : CGscMessage , TPlcRect


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- ~ -

  • ~GscActionsDispatcher() : GscActionsDispatcher


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- d -

  • DisableInternalInEventData() : CGscMessage
  • DisableMatchBy() : TGscActionInfo , TGscParameterInfo
  • DisableOnMatch() : TGscActionInfo , TGscParameterInfo
  • DisableResourceUpdate() : CGscMessage
  • Dispatch() : GscActionsDispatcher
  • DuplicateHandle() : CGscMessage


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- e -

  • EqualTo() : CGscMessage


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- g -

  • GetActionClass() : CGscAction , CGscMatchAction
  • GetActionCode() : CGscMatchAction , CGscAction
  • GetActionCodeByIndex() : CGscAction
  • GetActionEventData() : CGscAction , CGscMatchAction
  • GetActionNameA() : CGscAction , CGscMatchAction
  • GetActionNameW() : CGscAction , CGscMatchAction
  • GetActionPlainNameA() : CGscAction , CGscMatchAction
  • GetActionPlainNameW() : CGscAction , CGscMatchAction
  • GetCommentA() : CGscMatchAction
  • GetCommentW() : CGscMatchAction
  • GetDescriptionA() : CGscMatchAction
  • GetDescriptionW() : CGscMatchAction
  • GetForeignKey() : CGscAction
  • GetGenericInt32Parameter() : CGscAction
  • GetInputContact() : CGscAction
  • GetInternalData() : CGscMessage
  • GetInternalIndex() : CGscMessage
  • GetInternalIndexByCode() : CGscAction
  • GetMessageClass() : CGscMessage
  • GetMessageFlags() : CGscMessage
  • GetOutputContact() : CGscAction
  • GetProperties() : CGscAction
  • GetProperty() : CGscAction
  • GetReferenceCounter() : CGscMessage
  • GetVideoInput() : CGscAction
  • GetVideoOutput() : CGscAction
  • GetWindowsClientInfo() : CGscAction
  • GscActionsDispatcher() : GscActionsDispatcher


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- h -

  • HasDescription() : CGscMatchAction


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- r -

  • RestoreActionFromEventData() : CGscAction , CGscMatchAction


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- s -

  • SetComment() : CGscMatchAction
  • SetDescription() : CGscMatchAction
  • SetInternalData() : CGscMessage
  • SetMessageFlags() : CGscMessage
  • SetProperty() : CGscAction
  • StoreToBinBuffer() : CGscMessage
  • StoreToTextBuffer() : CGscMessage


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- t -

  • TPlcActionEventDataRecord() : TPlcActionEventDataRecord
  • TPlcEventTypeID() : TPlcEventTypeID
  • TPlcMediaChannelID() : TPlcMediaChannelID
  • TPlcRect() : TPlcRect
  • TPlcResourceID() : TPlcResourceID


GSC actions: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • g
  • h
  • m
  • o
  • r
  • s
  • t
  • u
  • ~

- u -

  • UpdateActionInfo() : CGscAction
  • UpdateWindowsClientInfo() : CGscAction


GSC actions: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • l
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- a -

  • ActionClass : TGscActionClassInfo , TGscActionInfo
  • ActionCode : TGscActionInfo
  • ActionSetupMask : TGscActionInfo

- b -

  • Bottom : TPlcRect

- c -

  • ChannelID : TPlcMediaChannelID
  • ChannelName : TPlcMediaChannelID
  • ClassName : TPlcLastError

- d -

  • DescriptionA : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo
  • DescriptionU : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo
  • DescriptionW : TGscParameterPlainInfo , TGscActionClassPlainInfo , TGscActionPlainInfo

- e -

  • EnumType : TGscEnumInfo
  • EnumValue : TGscEnumInfo
  • ErrorClass : TPlcLastError
  • ErrorCode : TPlcLastError
  • ErrorMessageA : TPlcLastError
  • ErrorMessageW : TPlcLastError
  • EventData : TPlcActionEventDataRecord
  • EventDataID : TPlcActionEventDataRecord
  • EventDataKind : TPlcActionEventDataRecord
  • EventDataSize : TPlcActionEventDataRecord
  • EventDataTime : TPlcActionEventDataRecord
  • EventDouble_A : TPlcActionEventDataRecord
  • EventDouble_B : TPlcActionEventDataRecord
  • EventID : TPlcActionEventDataRecord
  • EventInt32_A : TPlcActionEventDataRecord
  • EventInt32_B : TPlcActionEventDataRecord
  • EventInt32_C : TPlcActionEventDataRecord
  • EventInt32_D : TPlcActionEventDataRecord
  • EventInt64_A : TPlcActionEventDataRecord
  • EventInt64_B : TPlcActionEventDataRecord
  • EventInt64_C : TPlcActionEventDataRecord
  • EventInt64_D : TPlcActionEventDataRecord
  • EventName : TPlcEventTypeID
  • EventString_A : TPlcActionEventDataRecord
  • EventString_A_Size : TPlcActionEventDataRecord
  • EventString_B : TPlcActionEventDataRecord
  • EventString_B_Size : TPlcActionEventDataRecord
  • EventTime_A : TPlcActionEventDataRecord
  • EventTime_B : TPlcActionEventDataRecord
  • EventTypeID : TPlcEventTypeID

- g -

  • GlobalNo : TPlcMediaChannelID

- l -

  • Left : TPlcRect

- n -

  • NameA : TGscActionClassInfo , TGscActionInfo , TGscEnumInfo , TGscParameterInfo
  • NameW : TGscActionInfo , TGscActionClassInfo , TGscEnumInfo , TGscParameterInfo
  • NumberOfParameters : TGscActionInfo

- p -

  • ParameterSetupMask : TGscParameterInfo
  • ParameterType : TGscParameterInfo
  • ParameterView : TGscParameterInfo
  • PlainNameA : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo , TGscEnumPlainInfo
  • PlainNameU : TGscActionClassPlainInfo , TGscActionPlainInfo , TGscParameterPlainInfo , TGscEnumPlainInfo
  • PlainNameW : TGscEnumPlainInfo , TGscActionClassPlainInfo , TGscParameterPlainInfo , TGscActionPlainInfo

- r -

  • Reserved : TPlcEventTypeID , TPlcResourceID , TGscParameterInfo , TGscEnumPlainInfo , TGscActionClassInfo
  • ResourceID : TPlcResourceID
  • ResourceName : TPlcResourceID
  • Right : TPlcRect

- s -

  • StructSize : TPlcActionEventDataRecord

- t -

  • Top : TPlcRect

- u -

  • UpdateEventType : TPlcUpdateActionInfoCallback
  • UpdateInputContact : TPlcUpdateActionInfoCallback
  • UpdateOutputContact : TPlcUpdateActionInfoCallback
  • UpdateParameterSet : TPlcUpdateActionInfoCallback
  • UpdateResource : TPlcUpdateActionInfoCallback
  • UpdateVideoInput : TPlcUpdateActionInfoCallback
  • UpdateVideoOutput : TPlcUpdateActionInfoCallback

- v -

  • Version : TPlcUpdateActionInfoCallback

- x -

  • XMLInfo : TPlcLastError


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- k -

  • keyDisplay1 : GscActionsTypes.h
  • keyDisplay2 : GscActionsTypes.h
  • keyDisplay3 : GscActionsTypes.h
  • keyDisplay4 : GscActionsTypes.h
  • keyReporter1 : GscActionsTypes.h
  • keyUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- l -

  • larDenied : GscActionsTypes.h
  • larGranted : GscActionsTypes.h
  • larlUnknown : GscActionsTypes.h
  • larNotApplicable : GscActionsTypes.h
  • larOther : GscActionsTypes.h
  • larUnknown : GscActionsTypes.h
  • ledError : GscActionsTypes.h
  • ledGreen : GscActionsTypes.h
  • ledIOI43a1 : GscActionsTypes.h
  • ledIOI43a2 : GscActionsTypes.h
  • ledIOI43a3 : GscActionsTypes.h
  • ledIOI43a4 : GscActionsTypes.h
  • ledRecord : GscActionsTypes.h
  • ledUnknown : GscActionsTypes.h
  • ledYellow : GscActionsTypes.h
  • leiAcceptedBiometricScore : GscActionsTypes.h
  • leiAccessDeniedAreaEmpty : GscActionsTypes.h
  • leiAccessDeniedAreaOccupied : GscActionsTypes.h
  • leiAccessDeniedAssetRequired : GscActionsTypes.h
  • leiAccessDeniedBiometricReaderOffline : GscActionsTypes.h
  • leiAccessDeniedDoorSecured : GscActionsTypes.h
  • leiAccessDeniedEscortTimeoutExpired : GscActionsTypes.h
  • leiAccessDeniedGeneral : GscActionsTypes.h
  • leiAccessDeniedInterlock : GscActionsTypes.h
  • leiAccessDeniedNoBiometricTemplate : GscActionsTypes.h
  • leiAccessDeniedNoOccupantApproval : GscActionsTypes.h
  • leiAccessDeniedPassback : GscActionsTypes.h
  • leiAccessDeniedReaderLocked : GscActionsTypes.h
  • leiAccessDeniedSpecial : GscActionsTypes.h
  • leiAccessDeniedUnauthorizedArmingState : GscActionsTypes.h
  • leiAccessDeniedUnauthorizedEntryLevel : GscActionsTypes.h
  • leiAccessDeniedUnauthorizedTime : GscActionsTypes.h
  • leiAccessDeniedUnderDuress : GscActionsTypes.h
  • leiAccessGranted : GscActionsTypes.h
  • leiAccessGrantedAntiPassbackNotUsed : GscActionsTypes.h
  • leiAccessGrantedAntiPassbackUsed : GscActionsTypes.h
  • leiAccessGrantedGenral : GscActionsTypes.h
  • leiAccessGrantedNoEntryMade : GscActionsTypes.h
  • leiAccessGrantedonFacilityCode : GscActionsTypes.h
  • leiAccessGrantedonFacilityCodeNoEntryMade : GscActionsTypes.h
  • leiAccessGrantedReaderUnlocked : GscActionsTypes.h
  • leiAccessGrantedUnderDuress : GscActionsTypes.h
  • leiAccessGrantedUnderDuressNoEntryMade : GscActionsTypes.h
  • leiAcknowledgmentActionExecuted : GscActionsTypes.h
  • leiAcknowledgmentActionFailed : GscActionsTypes.h
  • leiAlarmActive : GscActionsTypes.h
  • leiAlarmCanceled : GscActionsTypes.h
  • leiAlarmMaskGroupArmed : GscActionsTypes.h
  • leiAlarmMaskGroupArmingFailureActivePoints : GscActionsTypes.h
  • leiAlarmMaskGroupDisarmed : GscActionsTypes.h
  • leiAlarmMaskGroupForceArmed : GscActionsTypes.h
  • leiAlarmMaskGroupMaskCountDecremented : GscActionsTypes.h
  • leiAlarmMaskGroupMaskCountIncremented : GscActionsTypes.h
  • leiAlarmMonitoringActionGroupExecuted : GscActionsTypes.h
  • leiAlarmMonitoringActionGroupFailed : GscActionsTypes.h
  • leiAntiPassbackInvalidEntryReader : GscActionsTypes.h
  • leiAntiPassbackInvalidExitReader : GscActionsTypes.h
  • leiAntiPassbackViolation : GscActionsTypes.h
  • leiAreaClosed : GscActionsTypes.h
  • leiAreaLimitExceeded : GscActionsTypes.h
  • leiBiometricMismatch : GscActionsTypes.h
  • leiBiometricVerifyModeDisabled : GscActionsTypes.h
  • leiBiometricVerifyModeEnabled : GscActionsTypes.h
  • leiCabinetTamper : GscActionsTypes.h
  • leiCallConferenced : GscActionsTypes.h
  • leiCallDisconnected : GscActionsTypes.h
  • leiCallEnded : GscActionsTypes.h
  • leiCallEstablished : GscActionsTypes.h
  • leiCallFailed : GscActionsTypes.h
  • leiCallQueued : GscActionsTypes.h
  • leiCalltoaBusySubscriber : GscActionsTypes.h
  • leiCalltoanOpenSubscriber : GscActionsTypes.h
  • leiCalltoaPrivateSubscriber : GscActionsTypes.h
  • leiCallTransferred : GscActionsTypes.h
  • leiCanceledCabinetTamper : GscActionsTypes.h
  • leiCanceledPowerFailure : GscActionsTypes.h
  • leiCipherModeDisabled : GscActionsTypes.h
  • leiCipherModeEnabled : GscActionsTypes.h
  • leiCommunicationsLost : GscActionsTypes.h
  • leiCommunicationsRestored : GscActionsTypes.h
  • leiCommunicationsWithHostLost : GscActionsTypes.h
  • leiCommunicationsWithHostRestored : GscActionsTypes.h
  • leiDeniedBadgeNotinPanel : GscActionsTypes.h
  • leiDeniedCountExceeded : GscActionsTypes.h
  • leiDeniedLowBattery : GscActionsTypes.h
  • leiDeniedNoCommandAuthority : GscActionsTypes.h
  • leiDeniedNoHostApproval : GscActionsTypes.h
  • leiDeniedPINOnlyRequest : GscActionsTypes.h
  • leiDeniedReaderExcluded : GscActionsTypes.h
  • leiDeniedUnauthorizedAssets : GscActionsTypes.h
  • leiDeniedUnMaskActiveZonesinGroup : GscActionsTypes.h
  • leiDoorClose : GscActionsTypes.h
  • leiDoorContactTamper : GscActionsTypes.h
  • leiDoorContactTamperCanceled : GscActionsTypes.h
  • leiDoorForcedOpen : GscActionsTypes.h
  • leiDoorForcedOpenCanceled : GscActionsTypes.h
  • leiDoorForcedOpenMasked : GscActionsTypes.h
  • leiDoorForcedOpenUnmasked : GscActionsTypes.h
  • leiDoorHeldOpen : GscActionsTypes.h
  • leiDoorHeldOpenCanceled : GscActionsTypes.h
  • leiDoorHeldOpenMasked : GscActionsTypes.h
  • leiDoorHeldOpenUnmasked : GscActionsTypes.h
  • leiDoorOpen : GscActionsTypes.h
  • leiElevatorTerminalModeAccesstoAuthorizedFloors : GscActionsTypes.h
  • leiElevatorTerminalModeDefaultFloor : GscActionsTypes.h
  • leiElevatorTerminalModeDefaultFloororUserEntryofDestinationFloor : GscActionsTypes.h
  • leiElevatorTerminalModeUserEntryofDestinationFloor : GscActionsTypes.h
  • leiExtendedHeldCommandDenied : GscActionsTypes.h
  • leiExtendedHeldCommandSetFromReader : GscActionsTypes.h
  • leiExtendedHeldOpenModeDisabled : GscActionsTypes.h
  • leiExtendedHeldOpenModeEnabled : GscActionsTypes.h
  • leiFireAlarmAcknowledge : GscActionsTypes.h
  • leiFireAlarmBlockAcknowledge : GscActionsTypes.h
  • leiFireAlarmIn : GscActionsTypes.h
  • leiFireAlarmOut : GscActionsTypes.h
  • leiFirstCardUnlockModeDisabled : GscActionsTypes.h
  • leiFirstCardUnlockModeEnabled : GscActionsTypes.h
  • leiGenericEvent : GscActionsTypes.h
  • leiGlobalLinkageActionExecuted : GscActionsTypes.h
  • leiGlobalLinkageActionFailed : GscActionsTypes.h
  • leiGuardTourActionExecuted : GscActionsTypes.h
  • leiGuardTourActionFailed : GscActionsTypes.h
  • leiHold : GscActionsTypes.h
  • leiInactiveBadge : GscActionsTypes.h
  • leiIncomingCall : GscActionsTypes.h
  • leiInitiated : GscActionsTypes.h
  • leiInputAlarmed : GscActionsTypes.h
  • leiInputHigh : GscActionsTypes.h
  • leiInputHighHigh : GscActionsTypes.h
  • leiInputLow : GscActionsTypes.h
  • leiInputLowLow : GscActionsTypes.h
  • leiInputMasked : GscActionsTypes.h
  • leiInputNormal : GscActionsTypes.h
  • leiInputUnmasked : GscActionsTypes.h
  • leiIntercomExchangeFailure : GscActionsTypes.h
  • leiIntercomFunction : GscActionsTypes.h
  • leiIntrusionCommandAccepted : GscActionsTypes.h
  • leiIntrusionCommandDenied : GscActionsTypes.h
  • leiInvalidAccessLevel : GscActionsTypes.h
  • leiInvalidBadge : GscActionsTypes.h
  • leiInvalidCardFormat : GscActionsTypes.h
  • leiInvalidFacilityCode : GscActionsTypes.h
  • leiInvalidIssueCode : GscActionsTypes.h
  • leiInvalidPINNumber : GscActionsTypes.h
  • leiLocalIOExecutedFunctionList : GscActionsTypes.h
  • leiMaxAssetsReached : GscActionsTypes.h
  • leiMaxCardholdersReached : GscActionsTypes.h
  • leiNoBiometricTemplateData : GscActionsTypes.h
  • leiNotConfigured : GscActionsTypes.h
  • leiOpenDoorCommandIssuedDoorNotUsed : GscActionsTypes.h
  • leiOpenDoorCommandIssuedDoorUsed : GscActionsTypes.h
  • leiPanelOptionsMismatch : GscActionsTypes.h
  • leiPowerFailure : GscActionsTypes.h
  • leiReaderInputTamper : GscActionsTypes.h
  • leiReaderInputTamperCanceled : GscActionsTypes.h
  • leiReaderModeCardandPin : GscActionsTypes.h
  • leiReaderModeCardOnly : GscActionsTypes.h
  • leiReaderModeFacilityCode : GscActionsTypes.h
  • leiReaderModeFirstCardUnlock : GscActionsTypes.h
  • leiReaderModeLocked : GscActionsTypes.h
  • leiReaderModePinorCard : GscActionsTypes.h
  • leiReaderModeUnlocked : GscActionsTypes.h
  • leiReaderOffline : GscActionsTypes.h
  • leiReaderOfflineRestored : GscActionsTypes.h
  • leiRejectedBiometricScore : GscActionsTypes.h
  • leiRelayContactActivated : GscActionsTypes.h
  • leiRelayContactDeactivated : GscActionsTypes.h
  • leiRequesttoExitDoorNotUsed : GscActionsTypes.h
  • leiRequesttoExitDoorUsed : GscActionsTypes.h
  • leiRetrieved : GscActionsTypes.h
  • leiRinging : GscActionsTypes.h
  • leiSchedulerActionExecuted : GscActionsTypes.h
  • leiSchedulerActionFailed : GscActionsTypes.h
  • leiSmartCardAuthenticationFailed : GscActionsTypes.h
  • leiTestReport : GscActionsTypes.h
  • leiTimeoutExceededNoSecondCard : GscActionsTypes.h
  • leiTroubleAcknowledge : GscActionsTypes.h
  • leiTroubleIn : GscActionsTypes.h
  • leiTroubleOut : GscActionsTypes.h
  • leiTroubleReport : GscActionsTypes.h
  • leiUnansweredCall : GscActionsTypes.h
  • leiUnknown : GscActionsTypes.h
  • leiUnknownElevatorTerminal : GscActionsTypes.h
  • leiUnknownUserCommand : GscActionsTypes.h
  • leiUseLimitExceeded : GscActionsTypes.h
  • LenelAccessResult : GscActionsTypes.h
  • LenelEventID : GscActionsTypes.h
  • LenelEventType : GscActionsTypes.h
  • letAccessDenied : GscActionsTypes.h
  • letAccessGranted : GscActionsTypes.h
  • letAreaAPB : GscActionsTypes.h
  • letAsset : GscActionsTypes.h
  • letBiometric : GscActionsTypes.h
  • letBurglary : GscActionsTypes.h
  • letC900 : GscActionsTypes.h
  • letDigitize : GscActionsTypes.h
  • letDuress : GscActionsTypes.h
  • letFireEight : GscActionsTypes.h
  • letFireNine : GscActionsTypes.h
  • letFireSeven : GscActionsTypes.h
  • letGas : GscActionsTypes.h
  • letGeneric : GscActionsTypes.h
  • letHostMessages : GscActionsTypes.h
  • letIntercom : GscActionsTypes.h
  • letMedical : GscActionsTypes.h
  • letMuster : GscActionsTypes.h
  • letOpenClose : GscActionsTypes.h
  • letPointofSale : GscActionsTypes.h
  • letPortableProgrammer : GscActionsTypes.h
  • letRelaySounder : GscActionsTypes.h
  • letSystem : GscActionsTypes.h
  • letTemperature : GscActionsTypes.h
  • letTransmitter : GscActionsTypes.h
  • letTrouble : GscActionsTypes.h
  • letUnknown : GscActionsTypes.h
  • letVideo : GscActionsTypes.h
  • letWater : GscActionsTypes.h
  • lstError : GscActionsTypes.h
  • lstInvalidID : GscActionsTypes.h
  • lstLastPosition : GscActionsTypes.h
  • lstPositionOK : GscActionsTypes.h
  • lstUnknown : GscActionsTypes.h
  • lstUnknownArea : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- m -

  • mk_Action : GscActionsTypes.h
  • mk_MatchAction : GscActionsTypes.h
  • mk_Unknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- n -

  • nrrBlackListed : GscActionsTypes.h
  • nrrUnknown : GscActionsTypes.h
  • nrrUnspecified : GscActionsTypes.h
  • nrrWhiteListed : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- o -

  • octCommon : GscActionsTypes.h
  • octIncoming : GscActionsTypes.h
  • octOutcoming : GscActionsTypes.h
  • octUnknown : GscActionsTypes.h
  • oedExceed : GscActionsTypes.h
  • oedFallBelow : GscActionsTypes.h
  • oedUnknown : GscActionsTypes.h
  • oocCar : GscActionsTypes.h
  • oocPerson : GscActionsTypes.h
  • oocUndefined : GscActionsTypes.h
  • oocUnknown : GscActionsTypes.h
  • oosDeleted : GscActionsTypes.h
  • oosLeaving : GscActionsTypes.h
  • oosStarting : GscActionsTypes.h
  • oosStationary : GscActionsTypes.h
  • oosUndefined : GscActionsTypes.h
  • oosUnknown : GscActionsTypes.h
  • opsCIF : GscActionsTypes.h
  • opsFourCIF : GscActionsTypes.h
  • opsTakeWhatYouGet : GscActionsTypes.h
  • opsUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- c -

  • ConstHGscAction : GscActions.h
  • ConstHGscMatchAction : GscActions.h
  • ConstHGscMessage : GscActions.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- d -

  • dbrRing1 : GscActionsTypes.h
  • dbrRing2 : GscActionsTypes.h
  • dbrRing3 : GscActionsTypes.h
  • dbrRing4 : GscActionsTypes.h
  • dbrRing5 : GscActionsTypes.h
  • dbrRing6 : GscActionsTypes.h
  • dbrRing7 : GscActionsTypes.h
  • dbrRing8 : GscActionsTypes.h
  • dbrUnknown : GscActionsTypes.h
  • dbsEmpty : GscActionsTypes.h
  • dbsFileAdded : GscActionsTypes.h
  • dbsReady : GscActionsTypes.h
  • dbsUnknown : GscActionsTypes.h
  • DigitalInputState : GscActionsTypes.h
  • DigitalOutputState : GscActionsTypes.h
  • dioDeviceTypeIOI43 : GscActionsTypes.h
  • dioDeviceTypeMIO : GscActionsTypes.h
  • dioUnknown : GscActionsTypes.h
  • disHigh : GscActionsTypes.h
  • disLow : GscActionsTypes.h
  • disMiddle : GscActionsTypes.h
  • disUnknown : GscActionsTypes.h
  • dosClose : GscActionsTypes.h
  • dosOpen : GscActionsTypes.h
  • dosToggle : GscActionsTypes.h
  • dosUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- e -

  • ebfDefault : GscActionsTypes.h
  • ebfGBF : GscActionsTypes.h
  • ebfMPEG2 : GscActionsTypes.h
  • ebfUnknown : GscActionsTypes.h
  • exaError : GscActionsTypes.h
  • exaLowDiscSpace : GscActionsTypes.h
  • exaNoUserRights : GscActionsTypes.h
  • exaUnknown : GscActionsTypes.h
  • exaUserAbort : GscActionsTypes.h
  • exmSelectionBegin : GscActionsTypes.h
  • exmSelectionEnd : GscActionsTypes.h
  • exmUnknown : GscActionsTypes.h
  • exsAborted : GscActionsTypes.h
  • exsConnectionError : GscActionsTypes.h
  • exsFailed : GscActionsTypes.h
  • exsLowDiscSpace : GscActionsTypes.h
  • exsNoUserRights : GscActionsTypes.h
  • exsQueueSizeReached : GscActionsTypes.h
  • exsSuccess : GscActionsTypes.h
  • exsUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- f -

  • FlagDisableInternalInEventData : GscActionsTypes.h
  • FlagDisableResourceUpdate : GscActionsTypes.h
  • frnBufferActivated : GscActionsTypes.h
  • frnDataOverwritten : GscActionsTypes.h
  • frnReconcileAborted : GscActionsTypes.h
  • frnReconcileFinished : GscActionsTypes.h
  • frnReconcileProgress : GscActionsTypes.h
  • frnReconcileStarted : GscActionsTypes.h
  • frnUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- g -

  • garContrast : GscActionsTypes.h
  • garUnknown : GscActionsTypes.h
  • garViewFieldObservation : GscActionsTypes.h
  • GscAct_CloneHandle() : GscActions.h
  • GscAct_CloseHandle() : GscActions.h
  • GscAct_CreateABCConnect() : GscActions.h
  • GscAct_CreateABCDisconnect() : GscActions.h
  • GscAct_CreateABCPlayFile() : GscActions.h
  • GscAct_CreateAbortAllAutoBackups() : GscActions.h
  • GscAct_CreateAbortAutoBackup() : GscActions.h
  • GscAct_CreateACSAccessDenied() : GscActions.h
  • GscAct_CreateACSAccessGranted() : GscActions.h
  • GscAct_CreateACSRawAnswer() : GscActions.h
  • GscAct_CreateACSRawData() : GscActions.h
  • GscAct_CreateActivateExternalProcess() : GscActions.h
  • GscAct_CreateATMRawAnswer() : GscActions.h
  • GscAct_CreateATMRawData() : GscActions.h
  • GscAct_CreateATMTransaction() : GscActions.h
  • GscAct_CreateAutoBackupCapacityMonitoringCapacityWarning() : GscActions.h
  • GscAct_CreateAutoBackupCapacityMonitoringFileAutoDeleted() : GscActions.h
  • GscAct_CreateAutoBackupCapacityMonitoringOutOfDiskSpace() : GscActions.h
  • GscAct_CreateAutoBackupFileDone() : GscActions.h
  • GscAct_CreateAutoBackupFileProgress() : GscActions.h
  • GscAct_CreateAutoBackupFileStarted() : GscActions.h
  • GscAct_CreateAutoBackupOperationDone() : GscActions.h
  • GscAct_CreateAutoBackupOperationStarted() : GscActions.h
  • GscAct_CreateAutoBackupScheduleDone() : GscActions.h
  • GscAct_CreateAutoBackupScheduleStarted() : GscActions.h
  • GscAct_CreateAutoFocusOff() : GscActions.h
  • GscAct_CreateAutoFocusOn() : GscActions.h
  • GscAct_CreateBackupEvent() : GscActions.h
  • GscAct_CreateBarcodeData() : GscActions.h
  • GscAct_CreateBlockingFilterActivate() : GscActions.h
  • GscAct_CreateBlockingFilterDeactivate() : GscActions.h
  • GscAct_CreateCameraApplyProfile() : GscActions.h
  • GscAct_CreateCameraBacklightCompensationMode() : GscActions.h
  • GscAct_CreateCameraClearPrePosText() : GscActions.h
  • GscAct_CreateCameraDayNightMode() : GscActions.h
  • GscAct_CreateCameraLightOff() : GscActions.h
  • GscAct_CreateCameraLightOn() : GscActions.h
  • GscAct_CreateCameraManualIrisOff() : GscActions.h
  • GscAct_CreateCameraManualIrisOn() : GscActions.h
  • GscAct_CreateCameraOff() : GscActions.h
  • GscAct_CreateCameraOn() : GscActions.h
  • GscAct_CreateCameraPumpOff() : GscActions.h
  • GscAct_CreateCameraPumpOn() : GscActions.h
  • GscAct_CreateCameraRAWOutput() : GscActions.h
  • GscAct_CreateCameraSelectCharMode() : GscActions.h
  • GscAct_CreateCameraSetPrePosText() : GscActions.h
  • GscAct_CreateCameraSpecFuncUOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncUOn() : GscActions.h
  • GscAct_CreateCameraSpecFuncVOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncVOn() : GscActions.h
  • GscAct_CreateCameraSpecFuncXOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncXOn() : GscActions.h
  • GscAct_CreateCameraSpecFuncYOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncYOn() : GscActions.h
  • GscAct_CreateCameraStopAll() : GscActions.h
  • GscAct_CreateCameraTextOff() : GscActions.h
  • GscAct_CreateCameraTextOn() : GscActions.h
  • GscAct_CreateCameraTourStart() : GscActions.h
  • GscAct_CreateCameraTourStop() : GscActions.h
  • GscAct_CreateCameraVersionOff() : GscActions.h
  • GscAct_CreateCameraVersionOn() : GscActions.h
  • GscAct_CreateCameraWashOff() : GscActions.h
  • GscAct_CreateCameraWashOn() : GscActions.h
  • GscAct_CreateCancelExport() : GscActions.h
  • GscAct_CreateCaseClosed() : GscActions.h
  • GscAct_CreateCaseOpened() : GscActions.h
  • GscAct_CreateChangeADParameterSet() : GscActions.h
  • GscAct_CreateChangeCameraProfile() : GscActions.h
  • GscAct_CreateChangeCPAParameterSet() : GscActions.h
  • GscAct_CreateChangeGTectParameterSet() : GscActions.h
  • GscAct_CreateChangeObtrackParameterSet() : GscActions.h
  • GscAct_CreateChangeVMDParameterSet() : GscActions.h
  • GscAct_CreateChannelError() : GscActions.h
  • GscAct_CreateChannelInfo() : GscActions.h
  • GscAct_CreateChannelLiveCheck() : GscActions.h
  • GscAct_CreateChannelWarning() : GscActions.h
  • GscAct_CreateCPAMeasurement() : GscActions.h
  • GscAct_CreateCustomAction() : GscActions.h
  • GscAct_CreateDatabaseRecordingInfoRing() : GscActions.h
  • GscAct_CreateDatabaseRecordingInfoTotal() : GscActions.h
  • GscAct_CreateDatabaseStarted() : GscActions.h
  • GscAct_CreateDefaultPosCallUp() : GscActions.h
  • GscAct_CreateDefaultPosClear() : GscActions.h
  • GscAct_CreateDefaultPosSave() : GscActions.h
  • GscAct_CreateDeviceFound() : GscActions.h
  • GscAct_CreateDeviceNewFirmware() : GscActions.h
  • GscAct_CreateDevicePluginError() : GscActions.h
  • GscAct_CreateDevicePluginState() : GscActions.h
  • GscAct_CreateDeviceReattached() : GscActions.h
  • GscAct_CreateDeviceRemoved() : GscActions.h
  • GscAct_CreateDigitalInput() : GscActions.h
  • GscAct_CreateEventBackupDone() : GscActions.h
  • GscAct_CreateEventBackupFileDone() : GscActions.h
  • GscAct_CreateEventBackupFileProgress() : GscActions.h
  • GscAct_CreateEventBackupFileStarted() : GscActions.h
  • GscAct_CreateEventBackupStarted() : GscActions.h
  • GscAct_CreateEventRecordingChanged() : GscActions.h
  • GscAct_CreateEventStarted() : GscActions.h
  • GscAct_CreateEventStartedEx() : GscActions.h
  • GscAct_CreateEventStopped() : GscActions.h
  • GscAct_CreateExportFinished() : GscActions.h
  • GscAct_CreateExportProgress() : GscActions.h
  • GscAct_CreateFastSpeedOff() : GscActions.h
  • GscAct_CreateFastSpeedOn() : GscActions.h
  • GscAct_CreateFillingPumpStatus() : GscActions.h
  • GscAct_CreateFocusFar() : GscActions.h
  • GscAct_CreateFocusNear() : GscActions.h
  • GscAct_CreateFocusStop() : GscActions.h
  • GscAct_CreateFRCNotification() : GscActions.h
  • GscAct_CreateFromBinBuffer() : GscActions.h
  • GscAct_CreateFromTextBuffer : GscActions.h
  • GscAct_CreateFromTextBufferA() : GscActions.h
  • GscAct_CreateFromTextBufferW() : GscActions.h
  • GscAct_CreateGEMOSalarm() : GscActions.h
  • GscAct_CreateGenericAction() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessDenied() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessExpired() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessGranted() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessPending() : GscActions.h
  • GscAct_CreateGTectAnalyticsLiveCheck() : GscActions.h
  • GscAct_CreateGTectDualSensorAlarm() : GscActions.h
  • GscAct_CreateGTectDualSensorAlarmFinished() : GscActions.h
  • GscAct_CreateGTectSceneAlarm() : GscActions.h
  • GscAct_CreateGTectSceneAlarmFinished() : GscActions.h
  • GscAct_CreateGTectVMXAlarm() : GscActions.h
  • GscAct_CreateGTectVMXAlarmFinished() : GscActions.h
  • GscAct_CreateIASSettingsChanged() : GscActions.h
  • GscAct_CreateImageExportNotification() : GscActions.h
  • GscAct_CreateImexCapacityFileAutoDeleted() : GscActions.h
  • GscAct_CreateImexCapacityOutOfDiskSpace() : GscActions.h
  • GscAct_CreateImexCapacityWarning() : GscActions.h
  • GscAct_CreateImexExportEventImage() : GscActions.h
  • GscAct_CreateImexExportImageFromDB() : GscActions.h
  • GscAct_CreateImexExportImageFromLiveStream() : GscActions.h
  • GscAct_CreateInitializeRemoteExport() : GscActions.h
  • GscAct_CreateInterfaceRawAnswer() : GscActions.h
  • GscAct_CreateInterfaceRawData() : GscActions.h
  • GscAct_CreateIOI43ResetMainboard() : GscActions.h
  • GscAct_CreateIOI43Temperature() : GscActions.h
  • GscAct_CreateIOI43WDActivate() : GscActions.h
  • GscAct_CreateIOI43WDDeactivate() : GscActions.h
  • GscAct_CreateIOI43WDTrigger() : GscActions.h
  • GscAct_CreateIPCameraRawCommand() : GscActions.h
  • GscAct_CreateIPCamFailoverNotification() : GscActions.h
  • GscAct_CreateIPCamFailoverRestore() : GscActions.h
  • GscAct_CreateIPSwitchOperation() : GscActions.h
  • GscAct_CreateIrisClose() : GscActions.h
  • GscAct_CreateIrisOpen() : GscActions.h
  • GscAct_CreateIrisStop() : GscActions.h
  • GscAct_CreateKeyPressed() : GscActions.h
  • GscAct_CreateKeyReleased() : GscActions.h
  • GscAct_CreateKillAllEvents() : GscActions.h
  • GscAct_CreateKillEvent() : GscActions.h
  • GscAct_CreateKillEventByID() : GscActions.h
  • GscAct_CreateLenelAccessEvent() : GscActions.h
  • GscAct_CreateLenelFireEvent() : GscActions.h
  • GscAct_CreateLenelIntercomEvent() : GscActions.h
  • GscAct_CreateLenelRawData() : GscActions.h
  • GscAct_CreateLenelRefreshNames() : GscActions.h
  • GscAct_CreateLenelSecurityEvent() : GscActions.h
  • GscAct_CreateLenelVideoEvent() : GscActions.h
  • GscAct_CreateLiveCheck() : GscActions.h
  • GscAct_CreateLogBarcodeData() : GscActions.h
  • GscAct_CreateLogBarcodeDataLPS() : GscActions.h
  • GscAct_CreateLogNPRRecognition() : GscActions.h
  • GscAct_CreateLPSPositionData() : GscActions.h
  • GscAct_CreateLPSQueryPosition() : GscActions.h
  • GscAct_CreateMakeCPAReferenceImage() : GscActions.h
  • GscAct_CreateMatchActionFromTemplate() : GscActions.h
  • GscAct_CreateMediaChannelSetupInfo() : GscActions.h
  • GscAct_CreateMoveToAbsolutePosition() : GscActions.h
  • GscAct_CreateMoveToBySpeed() : GscActions.h
  • GscAct_CreateMoveToRelativePosition() : GscActions.h
  • GscAct_CreateNPRRawData() : GscActions.h
  • GscAct_CreateNPRRecognition() : GscActions.h
  • GscAct_CreateObtrackChannelCounter() : GscActions.h
  • GscAct_CreateObtrackChannelCounterThreshold() : GscActions.h
  • GscAct_CreateObtrackChannelSetCounter() : GscActions.h
  • GscAct_CreateObtrackFrameRawData() : GscActions.h
  • GscAct_CreateObtrackGroupCounter() : GscActions.h
  • GscAct_CreateObtrackGroupCounterThreshold() : GscActions.h
  • GscAct_CreateObtrackGroupSetCounter() : GscActions.h
  • GscAct_CreateObtrackObjectRawData() : GscActions.h
  • GscAct_CreateObtrackTunnelAlarm() : GscActions.h
  • GscAct_CreatePanAuto() : GscActions.h
  • GscAct_CreatePanLeft() : GscActions.h
  • GscAct_CreatePanRight() : GscActions.h
  • GscAct_CreatePanStop() : GscActions.h
  • GscAct_CreatePOSData() : GscActions.h
  • GscAct_CreatePOSStatus() : GscActions.h
  • GscAct_CreatePPDeviceAlarm() : GscActions.h
  • GscAct_CreatePPDeviceInput() : GscActions.h
  • GscAct_CreatePPDeviceOffline() : GscActions.h
  • GscAct_CreatePPDeviceOnline() : GscActions.h
  • GscAct_CreatePPInterfaceOffline() : GscActions.h
  • GscAct_CreatePPInterfaceOnline() : GscActions.h
  • GscAct_CreatePPQueryInterface() : GscActions.h
  • GscAct_CreatePPSetDeviceOutput() : GscActions.h
  • GscAct_CreatePPSubcellAlarm() : GscActions.h
  • GscAct_CreatePPZoneAlarm() : GscActions.h
  • GscAct_CreatePrePosCallUp() : GscActions.h
  • GscAct_CreatePrePosClear() : GscActions.h
  • GscAct_CreatePrePosSave() : GscActions.h
  • GscAct_CreateRedundantPowerFailure() : GscActions.h
  • GscAct_CreateRedundantPowerOk() : GscActions.h
  • GscAct_CreateResetMainboard() : GscActions.h
  • GscAct_CreateSafebagClose() : GscActions.h
  • GscAct_CreateSafebagData() : GscActions.h
  • GscAct_CreateSafebagOpen() : GscActions.h
  • GscAct_CreateSafebagPassingOfRiskData() : GscActions.h
  • GscAct_CreateSafebagPassingOfRiskStart() : GscActions.h
  • GscAct_CreateSafebagPassingOfRiskStop() : GscActions.h
  • GscAct_CreateSceneStoreModification() : GscActions.h
  • GscAct_CreateSensorAlarmFinished() : GscActions.h
  • GscAct_CreateSensorAudioAlarm() : GscActions.h
  • GscAct_CreateSensorInhibitAlarmFinished() : GscActions.h
  • GscAct_CreateSensorInhibitVideoAlarm() : GscActions.h
  • GscAct_CreateSensorInhibitVideoAlarmEx() : GscActions.h
  • GscAct_CreateSensorVideoAlarm() : GscActions.h
  • GscAct_CreateSensorVideoAlarmEx() : GscActions.h
  • GscAct_CreateSetCameraText() : GscActions.h
  • GscAct_CreateSetClientVCA() : GscActions.h
  • GscAct_CreateSetClock() : GscActions.h
  • GscAct_CreateSetDigitalOutput() : GscActions.h
  • GscAct_CreateSetExportMarker() : GscActions.h
  • GscAct_CreateSetLED() : GscActions.h
  • GscAct_CreateSetLEDBlink() : GscActions.h
  • GscAct_CreateSetSystemTime() : GscActions.h
  • GscAct_CreateSetTestPictureMode() : GscActions.h
  • GscAct_CreateSetupChanged() : GscActions.h
  • GscAct_CreateSetupUploadProgress() : GscActions.h
  • GscAct_CreateSetWatchdog() : GscActions.h
  • GscAct_CreateSkidataControl() : GscActions.h
  • GscAct_CreateSkidataDeviceEvent() : GscActions.h
  • GscAct_CreateSkidataEntry() : GscActions.h
  • GscAct_CreateSkidataExit() : GscActions.h
  • GscAct_CreateSkidataTransaction() : GscActions.h
  • GscAct_CreateSMRPViewerCleared() : GscActions.h
  • GscAct_CreateSMRPViewerConnected() : GscActions.h
  • GscAct_CreateSMTPMailSend() : GscActions.h
  • GscAct_CreateStartAutoBackup() : GscActions.h
  • GscAct_CreateStartEvent() : GscActions.h
  • GscAct_CreateStartEventEx() : GscActions.h
  • GscAct_CreateStartRemoteExport() : GscActions.h
  • GscAct_CreateStartSceneStore() : GscActions.h
  • GscAct_CreateStopAllEvents() : GscActions.h
  • GscAct_CreateStopEvent() : GscActions.h
  • GscAct_CreateStopEventByID() : GscActions.h
  • GscAct_CreateSystemError() : GscActions.h
  • GscAct_CreateSystemInfo() : GscActions.h
  • GscAct_CreateSystemSettingsChanged() : GscActions.h
  • GscAct_CreateSystemStarted() : GscActions.h
  • GscAct_CreateSystemTerminating() : GscActions.h
  • GscAct_CreateSystemWarning() : GscActions.h
  • GscAct_CreateTemperature() : GscActions.h
  • GscAct_CreateTerminalArticleData() : GscActions.h
  • GscAct_CreateTerminalPaymentData() : GscActions.h
  • GscAct_CreateTiltDown() : GscActions.h
  • GscAct_CreateTiltStop() : GscActions.h
  • GscAct_CreateTiltUp() : GscActions.h
  • GscAct_CreateTransferBinaryBuffer() : GscActions.h
  • GscAct_CreateTransferBinaryChannelBuffer() : GscActions.h
  • GscAct_CreateUserLogin() : GscActions.h
  • GscAct_CreateUserLoginFailed() : GscActions.h
  • GscAct_CreateUserLogout() : GscActions.h
  • GscAct_CreateVCAlarmQueueConfirm() : GscActions.h
  • GscAct_CreateVCAlarmQueueConfirmByInstance() : GscActions.h
  • GscAct_CreateVCAlarmQueueConfirmByType() : GscActions.h
  • GscAct_CreateVCAlarmQueueNotification() : GscActions.h
  • GscAct_CreateVCAlarmQueueRemove() : GscActions.h
  • GscAct_CreateVCAlarmQueueRemoveByInstance() : GscActions.h
  • GscAct_CreateVCAlarmQueueRemoveByType() : GscActions.h
  • GscAct_CreateVCAlarmQueueSelect() : GscActions.h
  • GscAct_CreateVCAlarmQueueSelectByInstance() : GscActions.h
  • GscAct_CreateVCAlarmQueueSelectByType() : GscActions.h
  • GscAct_CreateVCASetArmed() : GscActions.h
  • GscAct_CreateVCAStatusAnswer() : GscActions.h
  • GscAct_CreateVCAStatusRequest() : GscActions.h
  • GscAct_CreateVCChangeSceneByName() : GscActions.h
  • GscAct_CreateVCClearSceneByName() : GscActions.h
  • GscAct_CreateVCFullMode() : GscActions.h
  • GscAct_CreateVCSceneChanged() : GscActions.h
  • GscAct_CreateVCSetAudioLevel() : GscActions.h
  • GscAct_CreateVCShowViewerText() : GscActions.h
  • GscAct_CreateVCStretchMode() : GscActions.h
  • GscAct_CreateVideoContrastDetected() : GscActions.h
  • GscAct_CreateVideoContrastFailed() : GscActions.h
  • GscAct_CreateVideoSetImageBrightness() : GscActions.h
  • GscAct_CreateVideoSetImageContrast() : GscActions.h
  • GscAct_CreateVideoSetImageSaturation() : GscActions.h
  • GscAct_CreateVideoSourceChanged() : GscActions.h
  • GscAct_CreateVideoSyncDetected() : GscActions.h
  • GscAct_CreateVideoSyncFailed() : GscActions.h
  • GscAct_CreateViewerChangeScene() : GscActions.h
  • GscAct_CreateViewerClear() : GscActions.h
  • GscAct_CreateViewerCleared() : GscActions.h
  • GscAct_CreateViewerClearScene() : GscActions.h
  • GscAct_CreateViewerClearTextOutput() : GscActions.h
  • GscAct_CreateViewerConnect() : GscActions.h
  • GscAct_CreateViewerConnected() : GscActions.h
  • GscAct_CreateViewerConnectLive() : GscActions.h
  • GscAct_CreateViewerExportPicture() : GscActions.h
  • GscAct_CreateViewerJumpByTime() : GscActions.h
  • GscAct_CreateViewerMaximize() : GscActions.h
  • GscAct_CreateViewerPlayFromTime() : GscActions.h
  • GscAct_CreateViewerPlayModeChanged() : GscActions.h
  • GscAct_CreateViewerPrintPicture() : GscActions.h
  • GscAct_CreateViewerSelect() : GscActions.h
  • GscAct_CreateViewerSelectionChanged() : GscActions.h
  • GscAct_CreateViewerSetPlayMode() : GscActions.h
  • GscAct_CreateViewerShowAlarmByInstance() : GscActions.h
  • GscAct_CreateViewerShowAlarmByKey() : GscActions.h
  • GscAct_CreateViewerShowAlarmByType() : GscActions.h
  • GscAct_CreateViewerSyncAudioAndVideo() : GscActions.h
  • GscAct_CreateViewerTextOutput() : GscActions.h
  • GscAct_CreateWatchdogActivate() : GscActions.h
  • GscAct_CreateWatchdogDeactivate() : GscActions.h
  • GscAct_CreateWatchdogTrigger() : GscActions.h
  • GscAct_CreateZoomIn() : GscActions.h
  • GscAct_CreateZoomOut() : GscActions.h
  • GscAct_CreateZoomStop() : GscActions.h
  • GscAct_DecodeABCConnect() : GscActions.h
  • GscAct_DecodeABCDisconnect() : GscActions.h
  • GscAct_DecodeABCPlayFile() : GscActions.h
  • GscAct_DecodeAbortAllAutoBackups() : GscActions.h
  • GscAct_DecodeAbortAutoBackup() : GscActions.h
  • GscAct_DecodeACSAccessDenied() : GscActions.h
  • GscAct_DecodeACSAccessGranted() : GscActions.h
  • GscAct_DecodeACSRawAnswer() : GscActions.h
  • GscAct_DecodeACSRawData() : GscActions.h
  • GscAct_DecodeActivateExternalProcess() : GscActions.h
  • GscAct_DecodeATMRawAnswer() : GscActions.h
  • GscAct_DecodeATMRawData() : GscActions.h
  • GscAct_DecodeATMTransaction() : GscActions.h
  • GscAct_DecodeAutoBackupCapacityMonitoringCapacityWarning() : GscActions.h
  • GscAct_DecodeAutoBackupCapacityMonitoringFileAutoDeleted() : GscActions.h
  • GscAct_DecodeAutoBackupCapacityMonitoringOutOfDiskSpace() : GscActions.h
  • GscAct_DecodeAutoBackupFileDone() : GscActions.h
  • GscAct_DecodeAutoBackupFileProgress() : GscActions.h
  • GscAct_DecodeAutoBackupFileStarted() : GscActions.h
  • GscAct_DecodeAutoBackupOperationDone() : GscActions.h
  • GscAct_DecodeAutoBackupOperationStarted() : GscActions.h
  • GscAct_DecodeAutoBackupScheduleDone() : GscActions.h
  • GscAct_DecodeAutoBackupScheduleStarted() : GscActions.h
  • GscAct_DecodeAutoFocusOff() : GscActions.h
  • GscAct_DecodeAutoFocusOn() : GscActions.h
  • GscAct_DecodeBackupEvent() : GscActions.h
  • GscAct_DecodeBarcodeData() : GscActions.h
  • GscAct_DecodeBlockingFilterActivate() : GscActions.h
  • GscAct_DecodeBlockingFilterDeactivate() : GscActions.h
  • GscAct_DecodeCameraApplyProfile() : GscActions.h
  • GscAct_DecodeCameraBacklightCompensationMode() : GscActions.h
  • GscAct_DecodeCameraClearPrePosText() : GscActions.h
  • GscAct_DecodeCameraDayNightMode() : GscActions.h
  • GscAct_DecodeCameraLightOff() : GscActions.h
  • GscAct_DecodeCameraLightOn() : GscActions.h
  • GscAct_DecodeCameraManualIrisOff() : GscActions.h
  • GscAct_DecodeCameraManualIrisOn() : GscActions.h
  • GscAct_DecodeCameraOff() : GscActions.h
  • GscAct_DecodeCameraOn() : GscActions.h
  • GscAct_DecodeCameraPumpOff() : GscActions.h
  • GscAct_DecodeCameraPumpOn() : GscActions.h
  • GscAct_DecodeCameraRAWOutput() : GscActions.h
  • GscAct_DecodeCameraSelectCharMode() : GscActions.h
  • GscAct_DecodeCameraSetPrePosText() : GscActions.h
  • GscAct_DecodeCameraSpecFuncUOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncUOn() : GscActions.h
  • GscAct_DecodeCameraSpecFuncVOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncVOn() : GscActions.h
  • GscAct_DecodeCameraSpecFuncXOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncXOn() : GscActions.h
  • GscAct_DecodeCameraSpecFuncYOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncYOn() : GscActions.h
  • GscAct_DecodeCameraStopAll() : GscActions.h
  • GscAct_DecodeCameraTextOff() : GscActions.h
  • GscAct_DecodeCameraTextOn() : GscActions.h
  • GscAct_DecodeCameraTourStart() : GscActions.h
  • GscAct_DecodeCameraTourStop() : GscActions.h
  • GscAct_DecodeCameraVersionOff() : GscActions.h
  • GscAct_DecodeCameraVersionOn() : GscActions.h
  • GscAct_DecodeCameraWashOff() : GscActions.h
  • GscAct_DecodeCameraWashOn() : GscActions.h
  • GscAct_DecodeCancelExport() : GscActions.h
  • GscAct_DecodeCaseClosed() : GscActions.h
  • GscAct_DecodeCaseOpened() : GscActions.h
  • GscAct_DecodeChangeADParameterSet() : GscActions.h
  • GscAct_DecodeChangeCameraProfile() : GscActions.h
  • GscAct_DecodeChangeCPAParameterSet() : GscActions.h
  • GscAct_DecodeChangeGTectParameterSet() : GscActions.h
  • GscAct_DecodeChangeObtrackParameterSet() : GscActions.h
  • GscAct_DecodeChangeVMDParameterSet() : GscActions.h
  • GscAct_DecodeChannelError() : GscActions.h
  • GscAct_DecodeChannelInfo() : GscActions.h
  • GscAct_DecodeChannelLiveCheck() : GscActions.h
  • GscAct_DecodeChannelWarning() : GscActions.h
  • GscAct_DecodeCPAMeasurement() : GscActions.h
  • GscAct_DecodeCustomAction() : GscActions.h
  • GscAct_DecodeDatabaseRecordingInfoRing() : GscActions.h
  • GscAct_DecodeDatabaseRecordingInfoTotal() : GscActions.h
  • GscAct_DecodeDatabaseStarted() : GscActions.h
  • GscAct_DecodeDefaultPosCallUp() : GscActions.h
  • GscAct_DecodeDefaultPosClear() : GscActions.h
  • GscAct_DecodeDefaultPosSave() : GscActions.h
  • GscAct_DecodeDeviceFound() : GscActions.h
  • GscAct_DecodeDeviceNewFirmware() : GscActions.h
  • GscAct_DecodeDevicePluginError() : GscActions.h
  • GscAct_DecodeDevicePluginState() : GscActions.h
  • GscAct_DecodeDeviceReattached() : GscActions.h
  • GscAct_DecodeDeviceRemoved() : GscActions.h
  • GscAct_DecodeDigitalInput() : GscActions.h
  • GscAct_DecodeEventBackupDone() : GscActions.h
  • GscAct_DecodeEventBackupFileDone() : GscActions.h
  • GscAct_DecodeEventBackupFileProgress() : GscActions.h
  • GscAct_DecodeEventBackupFileStarted() : GscActions.h
  • GscAct_DecodeEventBackupStarted() : GscActions.h
  • GscAct_DecodeEventRecordingChanged() : GscActions.h
  • GscAct_DecodeEventStarted() : GscActions.h
  • GscAct_DecodeEventStartedEx() : GscActions.h
  • GscAct_DecodeEventStopped() : GscActions.h
  • GscAct_DecodeExportFinished() : GscActions.h
  • GscAct_DecodeExportProgress() : GscActions.h
  • GscAct_DecodeFastSpeedOff() : GscActions.h
  • GscAct_DecodeFastSpeedOn() : GscActions.h
  • GscAct_DecodeFillingPumpStatus() : GscActions.h
  • GscAct_DecodeFocusFar() : GscActions.h
  • GscAct_DecodeFocusNear() : GscActions.h
  • GscAct_DecodeFocusStop() : GscActions.h
  • GscAct_DecodeFRCNotification() : GscActions.h
  • GscAct_DecodeGEMOSalarm() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessDenied() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessExpired() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessGranted() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessPending() : GscActions.h
  • GscAct_DecodeGTectAnalyticsLiveCheck() : GscActions.h
  • GscAct_DecodeGTectDualSensorAlarm() : GscActions.h
  • GscAct_DecodeGTectDualSensorAlarmFinished() : GscActions.h
  • GscAct_DecodeGTectSceneAlarm() : GscActions.h
  • GscAct_DecodeGTectSceneAlarmFinished() : GscActions.h
  • GscAct_DecodeGTectVMXAlarm() : GscActions.h
  • GscAct_DecodeGTectVMXAlarmFinished() : GscActions.h
  • GscAct_DecodeIASSettingsChanged() : GscActions.h
  • GscAct_DecodeImageExportNotification() : GscActions.h
  • GscAct_DecodeImexCapacityFileAutoDeleted() : GscActions.h
  • GscAct_DecodeImexCapacityOutOfDiskSpace() : GscActions.h
  • GscAct_DecodeImexCapacityWarning() : GscActions.h
  • GscAct_DecodeImexExportEventImage() : GscActions.h
  • GscAct_DecodeImexExportImageFromDB() : GscActions.h
  • GscAct_DecodeImexExportImageFromLiveStream() : GscActions.h
  • GscAct_DecodeInitializeRemoteExport() : GscActions.h
  • GscAct_DecodeInterfaceRawAnswer() : GscActions.h
  • GscAct_DecodeInterfaceRawData() : GscActions.h
  • GscAct_DecodeIOI43ResetMainboard() : GscActions.h
  • GscAct_DecodeIOI43Temperature() : GscActions.h
  • GscAct_DecodeIOI43WDActivate() : GscActions.h
  • GscAct_DecodeIOI43WDDeactivate() : GscActions.h
  • GscAct_DecodeIOI43WDTrigger() : GscActions.h
  • GscAct_DecodeIPCameraRawCommand() : GscActions.h
  • GscAct_DecodeIPCamFailoverNotification() : GscActions.h
  • GscAct_DecodeIPCamFailoverRestore() : GscActions.h
  • GscAct_DecodeIPSwitchOperation() : GscActions.h
  • GscAct_DecodeIrisClose() : GscActions.h
  • GscAct_DecodeIrisOpen() : GscActions.h
  • GscAct_DecodeIrisStop() : GscActions.h
  • GscAct_DecodeKeyPressed() : GscActions.h
  • GscAct_DecodeKeyReleased() : GscActions.h
  • GscAct_DecodeKillAllEvents() : GscActions.h
  • GscAct_DecodeKillEvent() : GscActions.h
  • GscAct_DecodeKillEventByID() : GscActions.h
  • GscAct_DecodeLenelAccessEvent() : GscActions.h
  • GscAct_DecodeLenelFireEvent() : GscActions.h
  • GscAct_DecodeLenelIntercomEvent() : GscActions.h
  • GscAct_DecodeLenelRawData() : GscActions.h
  • GscAct_DecodeLenelRefreshNames() : GscActions.h
  • GscAct_DecodeLenelSecurityEvent() : GscActions.h
  • GscAct_DecodeLenelVideoEvent() : GscActions.h
  • GscAct_DecodeLiveCheck() : GscActions.h
  • GscAct_DecodeLogBarcodeData() : GscActions.h
  • GscAct_DecodeLogBarcodeDataLPS() : GscActions.h
  • GscAct_DecodeLogNPRRecognition() : GscActions.h
  • GscAct_DecodeLPSPositionData() : GscActions.h
  • GscAct_DecodeLPSQueryPosition() : GscActions.h
  • GscAct_DecodeMakeCPAReferenceImage() : GscActions.h
  • GscAct_DecodeMediaChannelSetupInfo() : GscActions.h
  • GscAct_DecodeMoveToAbsolutePosition() : GscActions.h
  • GscAct_DecodeMoveToBySpeed() : GscActions.h
  • GscAct_DecodeMoveToRelativePosition() : GscActions.h
  • GscAct_DecodeNPRRawData() : GscActions.h
  • GscAct_DecodeNPRRecognition() : GscActions.h
  • GscAct_DecodeObtrackChannelCounter() : GscActions.h
  • GscAct_DecodeObtrackChannelCounterThreshold() : GscActions.h
  • GscAct_DecodeObtrackChannelSetCounter() : GscActions.h
  • GscAct_DecodeObtrackFrameRawData() : GscActions.h
  • GscAct_DecodeObtrackGroupCounter() : GscActions.h
  • GscAct_DecodeObtrackGroupCounterThreshold() : GscActions.h
  • GscAct_DecodeObtrackGroupSetCounter() : GscActions.h
  • GscAct_DecodeObtrackObjectRawData() : GscActions.h
  • GscAct_DecodeObtrackTunnelAlarm() : GscActions.h
  • GscAct_DecodePanAuto() : GscActions.h
  • GscAct_DecodePanLeft() : GscActions.h
  • GscAct_DecodePanRight() : GscActions.h
  • GscAct_DecodePanStop() : GscActions.h
  • GscAct_DecodePOSData() : GscActions.h
  • GscAct_DecodePOSStatus() : GscActions.h
  • GscAct_DecodePPDeviceAlarm() : GscActions.h
  • GscAct_DecodePPDeviceInput() : GscActions.h
  • GscAct_DecodePPDeviceOffline() : GscActions.h
  • GscAct_DecodePPDeviceOnline() : GscActions.h
  • GscAct_DecodePPInterfaceOffline() : GscActions.h
  • GscAct_DecodePPInterfaceOnline() : GscActions.h
  • GscAct_DecodePPQueryInterface() : GscActions.h
  • GscAct_DecodePPSetDeviceOutput() : GscActions.h
  • GscAct_DecodePPSubcellAlarm() : GscActions.h
  • GscAct_DecodePPZoneAlarm() : GscActions.h
  • GscAct_DecodePrePosCallUp() : GscActions.h
  • GscAct_DecodePrePosClear() : GscActions.h
  • GscAct_DecodePrePosSave() : GscActions.h
  • GscAct_DecodeRedundantPowerFailure() : GscActions.h
  • GscAct_DecodeRedundantPowerOk() : GscActions.h
  • GscAct_DecodeResetMainboard() : GscActions.h
  • GscAct_DecodeSafebagClose() : GscActions.h
  • GscAct_DecodeSafebagData() : GscActions.h
  • GscAct_DecodeSafebagOpen() : GscActions.h
  • GscAct_DecodeSafebagPassingOfRiskData() : GscActions.h
  • GscAct_DecodeSafebagPassingOfRiskStart() : GscActions.h
  • GscAct_DecodeSafebagPassingOfRiskStop() : GscActions.h
  • GscAct_DecodeSceneStoreModification() : GscActions.h
  • GscAct_DecodeSensorAlarmFinished() : GscActions.h
  • GscAct_DecodeSensorAudioAlarm() : GscActions.h
  • GscAct_DecodeSensorInhibitAlarmFinished() : GscActions.h
  • GscAct_DecodeSensorInhibitVideoAlarm() : GscActions.h
  • GscAct_DecodeSensorInhibitVideoAlarmEx() : GscActions.h
  • GscAct_DecodeSensorVideoAlarm() : GscActions.h
  • GscAct_DecodeSensorVideoAlarmEx() : GscActions.h
  • GscAct_DecodeSetCameraText() : GscActions.h
  • GscAct_DecodeSetClientVCA() : GscActions.h
  • GscAct_DecodeSetClock() : GscActions.h
  • GscAct_DecodeSetDigitalOutput() : GscActions.h
  • GscAct_DecodeSetExportMarker() : GscActions.h
  • GscAct_DecodeSetLED() : GscActions.h
  • GscAct_DecodeSetLEDBlink() : GscActions.h
  • GscAct_DecodeSetSystemTime() : GscActions.h
  • GscAct_DecodeSetTestPictureMode() : GscActions.h
  • GscAct_DecodeSetupChanged() : GscActions.h
  • GscAct_DecodeSetupUploadProgress() : GscActions.h
  • GscAct_DecodeSetWatchdog() : GscActions.h
  • GscAct_DecodeSkidataControl() : GscActions.h
  • GscAct_DecodeSkidataDeviceEvent() : GscActions.h
  • GscAct_DecodeSkidataEntry() : GscActions.h
  • GscAct_DecodeSkidataExit() : GscActions.h
  • GscAct_DecodeSkidataTransaction() : GscActions.h
  • GscAct_DecodeSMRPViewerCleared() : GscActions.h
  • GscAct_DecodeSMRPViewerConnected() : GscActions.h
  • GscAct_DecodeSMTPMailSend() : GscActions.h
  • GscAct_DecodeStartAutoBackup() : GscActions.h
  • GscAct_DecodeStartEvent() : GscActions.h
  • GscAct_DecodeStartEventEx() : GscActions.h
  • GscAct_DecodeStartRemoteExport() : GscActions.h
  • GscAct_DecodeStartSceneStore() : GscActions.h
  • GscAct_DecodeStopAllEvents() : GscActions.h
  • GscAct_DecodeStopEvent() : GscActions.h
  • GscAct_DecodeStopEventByID() : GscActions.h
  • GscAct_DecodeSystemError() : GscActions.h
  • GscAct_DecodeSystemInfo() : GscActions.h
  • GscAct_DecodeSystemSettingsChanged() : GscActions.h
  • GscAct_DecodeSystemStarted() : GscActions.h
  • GscAct_DecodeSystemTerminating() : GscActions.h
  • GscAct_DecodeSystemWarning() : GscActions.h
  • GscAct_DecodeTemperature() : GscActions.h
  • GscAct_DecodeTerminalArticleData() : GscActions.h
  • GscAct_DecodeTerminalPaymentData() : GscActions.h
  • GscAct_DecodeTiltDown() : GscActions.h
  • GscAct_DecodeTiltStop() : GscActions.h
  • GscAct_DecodeTiltUp() : GscActions.h
  • GscAct_DecodeTransferBinaryBuffer() : GscActions.h
  • GscAct_DecodeTransferBinaryChannelBuffer() : GscActions.h
  • GscAct_DecodeUserLogin() : GscActions.h
  • GscAct_DecodeUserLoginFailed() : GscActions.h
  • GscAct_DecodeUserLogout() : GscActions.h
  • GscAct_DecodeVCAlarmQueueConfirm() : GscActions.h
  • GscAct_DecodeVCAlarmQueueConfirmByInstance() : GscActions.h
  • GscAct_DecodeVCAlarmQueueConfirmByType() : GscActions.h
  • GscAct_DecodeVCAlarmQueueNotification() : GscActions.h
  • GscAct_DecodeVCAlarmQueueRemove() : GscActions.h
  • GscAct_DecodeVCAlarmQueueRemoveByInstance() : GscActions.h
  • GscAct_DecodeVCAlarmQueueRemoveByType() : GscActions.h
  • GscAct_DecodeVCAlarmQueueSelect() : GscActions.h
  • GscAct_DecodeVCAlarmQueueSelectByInstance() : GscActions.h
  • GscAct_DecodeVCAlarmQueueSelectByType() : GscActions.h
  • GscAct_DecodeVCASetArmed() : GscActions.h
  • GscAct_DecodeVCAStatusAnswer() : GscActions.h
  • GscAct_DecodeVCAStatusRequest() : GscActions.h
  • GscAct_DecodeVCChangeSceneByName() : GscActions.h
  • GscAct_DecodeVCClearSceneByName() : GscActions.h
  • GscAct_DecodeVCFullMode() : GscActions.h
  • GscAct_DecodeVCSceneChanged() : GscActions.h
  • GscAct_DecodeVCSetAudioLevel() : GscActions.h
  • GscAct_DecodeVCShowViewerText() : GscActions.h
  • GscAct_DecodeVCStretchMode() : GscActions.h
  • GscAct_DecodeVideoContrastDetected() : GscActions.h
  • GscAct_DecodeVideoContrastFailed() : GscActions.h
  • GscAct_DecodeVideoSetImageBrightness() : GscActions.h
  • GscAct_DecodeVideoSetImageContrast() : GscActions.h
  • GscAct_DecodeVideoSetImageSaturation() : GscActions.h
  • GscAct_DecodeVideoSourceChanged() : GscActions.h
  • GscAct_DecodeVideoSyncDetected() : GscActions.h
  • GscAct_DecodeVideoSyncFailed() : GscActions.h
  • GscAct_DecodeViewerChangeScene() : GscActions.h
  • GscAct_DecodeViewerClear() : GscActions.h
  • GscAct_DecodeViewerCleared() : GscActions.h
  • GscAct_DecodeViewerClearScene() : GscActions.h
  • GscAct_DecodeViewerClearTextOutput() : GscActions.h
  • GscAct_DecodeViewerConnect() : GscActions.h
  • GscAct_DecodeViewerConnected() : GscActions.h
  • GscAct_DecodeViewerConnectLive() : GscActions.h
  • GscAct_DecodeViewerExportPicture() : GscActions.h
  • GscAct_DecodeViewerJumpByTime() : GscActions.h
  • GscAct_DecodeViewerMaximize() : GscActions.h
  • GscAct_DecodeViewerPlayFromTime() : GscActions.h
  • GscAct_DecodeViewerPlayModeChanged() : GscActions.h
  • GscAct_DecodeViewerPrintPicture() : GscActions.h
  • GscAct_DecodeViewerSelect() : GscActions.h
  • GscAct_DecodeViewerSelectionChanged() : GscActions.h
  • GscAct_DecodeViewerSetPlayMode() : GscActions.h
  • GscAct_DecodeViewerShowAlarmByInstance() : GscActions.h
  • GscAct_DecodeViewerShowAlarmByKey() : GscActions.h
  • GscAct_DecodeViewerShowAlarmByType() : GscActions.h
  • GscAct_DecodeViewerSyncAudioAndVideo() : GscActions.h
  • GscAct_DecodeViewerTextOutput() : GscActions.h
  • GscAct_DecodeWatchdogActivate() : GscActions.h
  • GscAct_DecodeWatchdogDeactivate() : GscActions.h
  • GscAct_DecodeWatchdogTrigger() : GscActions.h
  • GscAct_DecodeZoomIn() : GscActions.h
  • GscAct_DecodeZoomOut() : GscActions.h
  • GscAct_DecodeZoomStop() : GscActions.h
  • GscAct_DuplicateHandle() : GscActions.h
  • GscAct_EnumerateActionClasses() : GscActions.h
  • GscAct_EnumerateActionParameters() : GscActions.h
  • GscAct_EnumerateActions() : GscActions.h
  • GscAct_EnumerateEnumValues() : GscActions.h
  • GscAct_EnumerateEventFields() : GscActions.h
  • GscAct_Equal() : GscActions.h
  • GscAct_GetActionClass() : GscActions.h
  • GscAct_GetActionClassByName : GscActions.h
  • GscAct_GetActionClassByNameA() : GscActions.h
  • GscAct_GetActionClassByNameW() : GscActions.h
  • GscAct_GetActionClassInfo() : GscActions.h
  • GscAct_GetActionCode() : GscActions.h
  • GscAct_GetActionCodeByIndex() : GscActions.h
  • GscAct_GetActionCodeByName : GscActions.h
  • GscAct_GetActionCodeByNameA() : GscActions.h
  • GscAct_GetActionCodeByNameW() : GscActions.h
  • GscAct_GetActionEventData() : GscActions.h
  • GscAct_GetActionEventDescription() : GscActions.h
  • GscAct_GetActionInfo() : GscActions.h
  • GscAct_GetActionName : GscActions.h
  • GscAct_GetActionNameA() : GscActions.h
  • GscAct_GetActionNameW() : GscActions.h
  • GscAct_GetActionParameterInfo() : GscActions.h
  • GscAct_GetActionPlainName : GscActions.h
  • GscAct_GetActionPlainNameA() : GscActions.h
  • GscAct_GetActionPlainNameW() : GscActions.h
  • GscAct_GetEnumValueInfo() : GscActions.h
  • GscAct_GetEventDescriptionInfo() : GscActions.h
  • GscAct_GetEventFieldInfo() : GscActions.h
  • GscAct_GetForeignKey() : GscActions.h
  • GscAct_GetGenericInt32Parameter() : GscActions.h
  • GscAct_GetInputContact() : GscActions.h
  • GscAct_GetInternalData() : GscActions.h
  • GscAct_GetInternalIndex() : GscActions.h
  • GscAct_GetInternalIndexByCode() : GscActions.h
  • GscAct_GetLastError() : GscActions.h
  • GscAct_GetMatchActionDescriptionInfo() : GscActions.h
  • GscAct_GetMessageClass() : GscActions.h
  • GscAct_GetMessageFlags() : GscActions.h
  • GscAct_GetNativeTranslation() : GscActions.h
  • GscAct_GetNumberOfActionClasses() : GscActions.h
  • GscAct_GetNumberOfActionParameters() : GscActions.h
  • GscAct_GetNumberOfActions() : GscActions.h
  • GscAct_GetNumberOfEnumValues() : GscActions.h
  • GscAct_GetNumberOfOpenHandles() : GscActions.h
  • GscAct_GetOutputContact() : GscActions.h
  • GscAct_GetProperties() : GscActions.h
  • GscAct_GetProperty() : GscActions.h
  • GscAct_GetReferenceCounter() : GscActions.h
  • GscAct_GetVideoInput() : GscActions.h
  • GscAct_GetVideoOutput() : GscActions.h
  • GscAct_GetWindowsClientInfo() : GscActions.h
  • GscAct_InterfaceDate() : GscActions.h
  • GscAct_InterfaceVersion() : GscActions.h
  • GscAct_RestoreActionFromEventData() : GscActions.h
  • GscAct_SetActionClassPlainInfo() : GscActions.h
  • GscAct_SetActionParameterPlainInfo() : GscActions.h
  • GscAct_SetActionPlainInfo() : GscActions.h
  • GscAct_SetEnumValuePlainInfo() : GscActions.h
  • GscAct_SetEventDescriptionPlainInfo() : GscActions.h
  • GscAct_SetEventFieldPlainInfo() : GscActions.h
  • GscAct_SetInternalData() : GscActions.h
  • GscAct_SetMatchActionDescriptionPlainInfo() : GscActions.h
  • GscAct_SetMessageFlags() : GscActions.h
  • GscAct_SetNativeTranslation() : GscActions.h
  • GscAct_SetProperty() : GscActions.h
  • GscAct_StoreToBinBuffer() : GscActions.h
  • GscAct_StoreToTextBuffer : GscActions.h
  • GscAct_StoreToTextBufferA() : GscActions.h
  • GscAct_StoreToTextBufferW() : GscActions.h
  • GscAct_UpdateActionInfo() : GscActions.h
  • GscAct_UpdateWindowsClientInfo() : GscActions.h
  • GSCACTDLLCALL : GscActions.h
  • GscActionAPIDate : GscActions.h
  • GscActionAPIVersion : GscActions.h
  • GscActionClass : GscActionsTypes.h
  • GscActionCode : GscActionsTypes.h
  • GscActionsDll : GscActions.h
  • GscMatchAct_CreateActionFromTemplate() : GscActions.h
  • GscMatchAct_GetActionClass() : GscActions.h
  • GscMatchAct_GetActionCode() : GscActions.h
  • GscMatchAct_GetActionEventData() : GscActions.h
  • GscMatchAct_GetActionName : GscActions.h
  • GscMatchAct_GetActionNameA() : GscActions.h
  • GscMatchAct_GetActionNameW() : GscActions.h
  • GscMatchAct_GetActionPlainName : GscActions.h
  • GscMatchAct_GetActionPlainNameA() : GscActions.h
  • GscMatchAct_GetActionPlainNameW() : GscActions.h
  • GscMatchAct_GetComment : GscActions.h
  • GscMatchAct_GetCommentA() : GscActions.h
  • GscMatchAct_GetCommentW() : GscActions.h
  • GscMatchAct_GetDescription : GscActions.h
  • GscMatchAct_GetDescriptionA() : GscActions.h
  • GscMatchAct_GetDescriptionW() : GscActions.h
  • GscMatchAct_HasDescription() : GscActions.h
  • GscMatchAct_Matches() : GscActions.h
  • GscMatchAct_RestoreActionFromEventData() : GscActions.h
  • GscMatchAct_SetComment : GscActions.h
  • GscMatchAct_SetCommentA() : GscActions.h
  • GscMatchAct_SetCommentW() : GscActions.h
  • GscMatchAct_SetDescription : GscActions.h
  • GscMatchAct_SetDescriptionA() : GscActions.h
  • GscMatchAct_SetDescriptionW() : GscActions.h
  • GscMessageClass : GscActionsTypes.h
  • GscParameterType : GscActionsTypes.h
  • GscParameterView : GscActionsTypes.h
  • GTectClientVCAType : GscActionsTypes.h
  • GTectSceneAlarmReason : GscActionsTypes.h
  • gvtClientPrivacyMasking : GscActionsTypes.h
  • gvtMotionPrivacy : GscActionsTypes.h
  • gvtUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- h -

  • HGscAction : GscActions.h
  • HGscMatchAction : GscActions.h
  • HGscMessage : GscActions.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- i -

  • ietBackupFile : GscActionsTypes.h
  • ietClipboard : GscActionsTypes.h
  • ietPrinter : GscActionsTypes.h
  • ietSingleImage : GscActionsTypes.h
  • ietUnknown : GscActionsTypes.h
  • ietVideoFile : GscActionsTypes.h
  • IODeviceType : GscActionsTypes.h
  • ipoPOEDelayedReset : GscActionsTypes.h
  • ipoPOEOff : GscActionsTypes.h
  • ipoPOEOn : GscActionsTypes.h
  • ipoPOEReset : GscActionsTypes.h
  • ipoUnknown : GscActionsTypes.h
  • IPSwitchOps : GscActionsTypes.h
  • IsGscEnumType() : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- p -

  • pasAlarm : GscActionsTypes.h
  • pasNormal : GscActionsTypes.h
  • pasUnknown : GscActionsTypes.h
  • pbmOff : GscActionsTypes.h
  • pbmOn : GscActionsTypes.h
  • pbmUnknown : GscActionsTypes.h
  • pckCableA : GscActionsTypes.h
  • pckCableB : GscActionsTypes.h
  • pckUnknown : GscActionsTypes.h
  • pctDefault : GscActionsTypes.h
  • pctGscRegEdit : GscActionsTypes.h
  • pctGscSetup : GscActionsTypes.h
  • pctGscSupplyChain : GscActionsTypes.h
  • pctGscView : GscActionsTypes.h
  • pctGscWeb : GscActionsTypes.h
  • pctInvalid : GscActionsTypes.h
  • pctUnknown : GscActionsTypes.h
  • pdnAuto : GscActionsTypes.h
  • pdnDay : GscActionsTypes.h
  • pdnNight : GscActionsTypes.h
  • pdnUnknown : GscActionsTypes.h
  • PLC_DISABLE_MATCH_BY : GscActionsTypes.h
  • PLC_DISABLE_ON_MATCH : GscActionsTypes.h
  • PlcBacklightMode : GscActionsTypes.h
  • PlcBackupFormat : GscActionsTypes.h
  • PlcClientType : GscActionsTypes.h
  • PlcDatabaseRing : GscActionsTypes.h
  • PlcDatabaseStatus : GscActionsTypes.h
  • PlcDayNightMode : GscActionsTypes.h
  • PlcExportAbort : GscActionsTypes.h
  • PlcExportMarker : GscActionsTypes.h
  • PlcExportSuccess : GscActionsTypes.h
  • PlcFRCNotification : GscActionsTypes.h
  • PlcImageExportType : GscActionsTypes.h
  • PlcLpsStatus : GscActionsTypes.h
  • PlcMessageCode : GscActionsTypes.h
  • PlcMessageSource : GscActionsTypes.h
  • PlcNPRRestriction : GscActionsTypes.h
  • PlcObtrackCounterType : GscActionsTypes.h
  • PlcObtrackExceedingDirection : GscActionsTypes.h
  • PlcObtrackObjectClass : GscActionsTypes.h
  • PlcObtrackObjectStatus : GscActionsTypes.h
  • PlcObtrackProcessSize : GscActionsTypes.h
  • PlcPluginError : GscActionsTypes.h
  • PlcPluginState : GscActionsTypes.h
  • PlcPOSStatus : GscActionsTypes.h
  • PlcPumpStatus : GscActionsTypes.h
  • PlcResourceChangeKind : GscActionsTypes.h
  • PlcResourceKind : GscActionsTypes.h
  • PlcSceneStoreModificationType : GscActionsTypes.h
  • PlcSkidataControl : GscActionsTypes.h
  • PlcSkidataMsgCodeEntry : GscActionsTypes.h
  • PlcSkidataMsgCodeExit : GscActionsTypes.h
  • PlcSkidataMsgCodeTransaction : GscActionsTypes.h
  • PlcSpecialConstants : GscActionsTypes.h
  • PlcTunnelAlarmReason : GscActionsTypes.h
  • PlcViewerAlarmPlayMode : GscActionsTypes.h
  • PlcViewerAlarmQueueSelection : GscActionsTypes.h
  • PlcViewerAlarmState : GscActionsTypes.h
  • PlcViewerPlayMode : GscActionsTypes.h
  • pmcBehaviouralRuleTooDeep : GscActionsTypes.h
  • pmcCannotEnumeratePorts : GscActionsTypes.h
  • pmcCannotOpenPort : GscActionsTypes.h
  • pmcCannotSetFilter : GscActionsTypes.h
  • pmcConnectionLost : GscActionsTypes.h
  • pmcDatabaseFileMissing : GscActionsTypes.h
  • pmcDataOverflow : GscActionsTypes.h
  • pmcDBECouldNotFreeAnyPage : GscActionsTypes.h
  • pmcDemoModeExpired : GscActionsTypes.h
  • pmcDongleFound : GscActionsTypes.h
  • pmcDongleInsufficient : GscActionsTypes.h
  • pmcDongleMissing : GscActionsTypes.h
  • pmcDongleWrong : GscActionsTypes.h
  • pmcFileAccessError : GscActionsTypes.h
  • pmcFirmwareUploadFailed : GscActionsTypes.h
  • pmcFLTMInefficient : GscActionsTypes.h
  • pmcHostRestrictions : GscActionsTypes.h
  • pmcHttpError : GscActionsTypes.h
  • pmcInsufficientData : GscActionsTypes.h
  • pmcInsufficientFrameRate : GscActionsTypes.h
  • pmcInternalError : GscActionsTypes.h
  • pmcIOCannotEnumerate : GscActionsTypes.h
  • pmcIOCannotOpen : GscActionsTypes.h
  • pmcIODeviceFound : GscActionsTypes.h
  • pmcIODeviceLost : GscActionsTypes.h
  • pmcIODeviceNotFound : GscActionsTypes.h
  • pmcIODriverNotInstalled : GscActionsTypes.h
  • pmcIODuplcatedAddress : GscActionsTypes.h
  • pmcIOTemperatureAbove : GscActionsTypes.h
  • pmcIOTemperatureBelow : GscActionsTypes.h
  • pmcIOUnusedDevice : GscActionsTypes.h
  • pmcNoControlForLongTime : GscActionsTypes.h
  • pmcOutOfResources : GscActionsTypes.h
  • pmcTranscoderOverload : GscActionsTypes.h
  • pmcUnknown : GscActionsTypes.h
  • pmcUnknownError : GscActionsTypes.h
  • pmcUnlicensed : GscActionsTypes.h
  • pmcWatchdogReset : GscActionsTypes.h
  • pmsACS : GscActionsTypes.h
  • pmsATM : GscActionsTypes.h
  • pmsAutoBackup : GscActionsTypes.h
  • pmsDBE : GscActionsTypes.h
  • pmsDongle : GscActionsTypes.h
  • pmsFRC : GscActionsTypes.h
  • pmsInterface : GscActionsTypes.h
  • pmsIOI43 : GscActionsTypes.h
  • pmsLenel : GscActionsTypes.h
  • pmsLogistic : GscActionsTypes.h
  • pmsLPS : GscActionsTypes.h
  • pmsMediaAPI : GscActionsTypes.h
  • pmsMediaPlugin : GscActionsTypes.h
  • pmsMIO : GscActionsTypes.h
  • pmsPLC : GscActionsTypes.h
  • pmsPOS : GscActionsTypes.h
  • pmsPP : GscActionsTypes.h
  • pmsSCS : GscActionsTypes.h
  • pmsSensor : GscActionsTypes.h
  • pmsServer : GscActionsTypes.h
  • pmsSetup : GscActionsTypes.h
  • pmsTranscoder : GscActionsTypes.h
  • pmsUnknown : GscActionsTypes.h
  • pmsVAM : GscActionsTypes.h
  • posCleared : GscActionsTypes.h
  • posStarted : GscActionsTypes.h
  • posStopped : GscActionsTypes.h
  • posUnknown : GscActionsTypes.h
  • PPAlarmState : GscActionsTypes.h
  • PPCableKind : GscActionsTypes.h
  • ppeConnectionLost : GscActionsTypes.h
  • ppeInternalError : GscActionsTypes.h
  • ppeOutOfResources : GscActionsTypes.h
  • ppeUnknown : GscActionsTypes.h
  • ppeUnknownError : GscActionsTypes.h
  • ppeUnlicensed : GscActionsTypes.h
  • ppsConnected : GscActionsTypes.h
  • ppsDisconnected : GscActionsTypes.h
  • PPSensorKind : GscActionsTypes.h
  • ppsInternalState : GscActionsTypes.h
  • ppsUnknown : GscActionsTypes.h
  • prkDigitalInput : GscActionsTypes.h
  • prkDigitalOutput : GscActionsTypes.h
  • prkNotSpecified : GscActionsTypes.h
  • prkPTZHead : GscActionsTypes.h
  • prkTimeRange : GscActionsTypes.h
  • prkUnknown : GscActionsTypes.h
  • prkUser : GscActionsTypes.h
  • prkVCAllProfiles : GscActionsTypes.h
  • prkVCUserOptions : GscActionsTypes.h
  • prkVideoInput : GscActionsTypes.h
  • pscRestOfTime : GscActionsTypes.h
  • pscUnknown : GscActionsTypes.h
  • pskAux : GscActionsTypes.h
  • pskCableAFault : GscActionsTypes.h
  • pskCableBFault : GscActionsTypes.h
  • pskPath : GscActionsTypes.h
  • pskSensor : GscActionsTypes.h
  • pskService : GscActionsTypes.h
  • pskTamper : GscActionsTypes.h
  • pskTrap : GscActionsTypes.h
  • pskUnknown : GscActionsTypes.h
  • pt___int32 : GscActionsTypes.h
  • pt___int64 : GscActionsTypes.h
  • pt_ABCapacityWarning : GscActionsTypes.h
  • pt_ADArea : GscActionsTypes.h
  • pt_bool : GscActionsTypes.h
  • pt_DigitalInputState : GscActionsTypes.h
  • pt_DigitalOutputState : GscActionsTypes.h
  • pt_double : GscActionsTypes.h
  • pt_GTectClientVCAType : GscActionsTypes.h
  • pt_GTectSceneAlarmReason : GscActionsTypes.h
  • pt_GUID : GscActionsTypes.h
  • pt_IODeviceType : GscActionsTypes.h
  • pt_IPSwitchOps : GscActionsTypes.h
  • pt_LenelAccessResult : GscActionsTypes.h
  • pt_LenelEventID : GscActionsTypes.h
  • pt_LenelEventType : GscActionsTypes.h
  • pt_PlcBacklightMode : GscActionsTypes.h
  • pt_PlcBackupFormat : GscActionsTypes.h
  • pt_PlcClientType : GscActionsTypes.h
  • pt_PlcDatabaseRing : GscActionsTypes.h
  • pt_PlcDatabaseStatus : GscActionsTypes.h
  • pt_PlcDayNightMode : GscActionsTypes.h
  • pt_PlcExportAbort : GscActionsTypes.h
  • pt_PlcExportMarker : GscActionsTypes.h
  • pt_PlcExportSuccess : GscActionsTypes.h
  • pt_PlcFRCNotification : GscActionsTypes.h
  • pt_PlcImageExportType : GscActionsTypes.h
  • pt_PlcLpsStatus : GscActionsTypes.h
  • pt_PlcMessageCode : GscActionsTypes.h
  • pt_PlcMessageSource : GscActionsTypes.h
  • pt_PlcNPRRestriction : GscActionsTypes.h
  • pt_PlcObtrackCounterType : GscActionsTypes.h
  • pt_PlcObtrackExceedingDirection : GscActionsTypes.h
  • pt_PlcObtrackObjectClass : GscActionsTypes.h
  • pt_PlcObtrackObjectStatus : GscActionsTypes.h
  • pt_PlcObtrackProcessSize : GscActionsTypes.h
  • pt_PlcPluginError : GscActionsTypes.h
  • pt_PlcPluginState : GscActionsTypes.h
  • pt_PlcPOSStatus : GscActionsTypes.h
  • pt_PlcPumpStatus : GscActionsTypes.h
  • pt_PlcResourceChangeKind : GscActionsTypes.h
  • pt_PlcResourceKind : GscActionsTypes.h
  • pt_PlcSceneStoreModificationType : GscActionsTypes.h
  • pt_PlcSkidataControl : GscActionsTypes.h
  • pt_PlcSkidataMsgCodeEntry : GscActionsTypes.h
  • pt_PlcSkidataMsgCodeExit : GscActionsTypes.h
  • pt_PlcSkidataMsgCodeTransaction : GscActionsTypes.h
  • pt_PlcSpecialConstants : GscActionsTypes.h
  • pt_PlcTunnelAlarmReason : GscActionsTypes.h
  • pt_PlcViewerAlarmPlayMode : GscActionsTypes.h
  • pt_PlcViewerAlarmQueueSelection : GscActionsTypes.h
  • pt_PlcViewerAlarmState : GscActionsTypes.h
  • pt_PlcViewerPlayMode : GscActionsTypes.h
  • pt_PPAlarmState : GscActionsTypes.h
  • pt_PPCableKind : GscActionsTypes.h
  • pt_PPSensorKind : GscActionsTypes.h
  • pt_SafebagStep : GscActionsTypes.h
  • pt_string : GscActionsTypes.h
  • pt_SystemKey : GscActionsTypes.h
  • pt_SystemLED : GscActionsTypes.h
  • pt_TEventTypeID : GscActionsTypes.h
  • pt_TGLibDateTime : GscActionsTypes.h
  • pt_TMediaChannelID : GscActionsTypes.h
  • pt_TPlcRect : GscActionsTypes.h
  • pt_TrafficDirection : GscActionsTypes.h
  • pt_TResourceID : GscActionsTypes.h
  • pt_Unknown : GscActionsTypes.h
  • pt_UserLoginFailureCode : GscActionsTypes.h
  • pt_VideoInterlaceType : GscActionsTypes.h
  • pt_VideoSensorKind : GscActionsTypes.h
  • pt_VideoSignalNorm : GscActionsTypes.h
  • pt_VideoSignalType : GscActionsTypes.h
  • pt_VMDCycle : GscActionsTypes.h
  • pt_VMDGroup : GscActionsTypes.h
  • pt_widestring : GscActionsTypes.h
  • pumAmount : GscActionsTypes.h
  • pumCleared : GscActionsTypes.h
  • pumStarted : GscActionsTypes.h
  • pumStopped : GscActionsTypes.h
  • pumUnknown : GscActionsTypes.h
  • pv_ABDestination : GscActionsTypes.h
  • pv_ABSchedule : GscActionsTypes.h
  • pv_ADParameterSet : GscActionsTypes.h
  • pv_AudioInput : GscActionsTypes.h
  • pv_AudioOutput : GscActionsTypes.h
  • pv_CameraProfile : GscActionsTypes.h
  • pv_CPAParameterSet : GscActionsTypes.h
  • pv_Default : GscActionsTypes.h
  • pv_DeviceName : GscActionsTypes.h
  • pv_DeviceSubType : GscActionsTypes.h
  • pv_DeviceType : GscActionsTypes.h
  • pv_Event : GscActionsTypes.h
  • pv_ForeignKey : GscActionsTypes.h
  • pv_GTectParameterSet : GscActionsTypes.h
  • pv_HardwareModule : GscActionsTypes.h
  • pv_ImexDestination : GscActionsTypes.h
  • pv_InputContact : GscActionsTypes.h
  • pv_ObtrackParameterSet : GscActionsTypes.h
  • pv_OutputContact : GscActionsTypes.h
  • pv_PTZHead : GscActionsTypes.h
  • pv_TimeRange : GscActionsTypes.h
  • pv_Unknown : GscActionsTypes.h
  • pv_UserName : GscActionsTypes.h
  • pv_VideoInput : GscActionsTypes.h
  • pv_VideoOutput : GscActionsTypes.h
  • pv_VMDParameterSet : GscActionsTypes.h
  • pv_WindowsError : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- r -

  • rckAdded : GscActionsTypes.h
  • rckModified : GscActionsTypes.h
  • rckRemoved : GscActionsTypes.h
  • rckUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- s -

  • SafebagStep : GscActionsTypes.h
  • sbsOpen : GscActionsTypes.h
  • sbsUnknown : GscActionsTypes.h
  • sdcConnectionFailed : GscActionsTypes.h
  • sdcConnectionLost : GscActionsTypes.h
  • sdcConnectionOk : GscActionsTypes.h
  • sdcDisconnected : GscActionsTypes.h
  • sdcUnknown : GscActionsTypes.h
  • sdenCreditCard : GscActionsTypes.h
  • sdenElectronicPurse : GscActionsTypes.h
  • sdenExternalCard : GscActionsTypes.h
  • sdenTicket : GscActionsTypes.h
  • sdenUnknown : GscActionsTypes.h
  • sdexCreditCard : GscActionsTypes.h
  • sdexElectronicPurse : GscActionsTypes.h
  • sdexExternalCard : GscActionsTypes.h
  • sdexTicket : GscActionsTypes.h
  • sdexUnknown : GscActionsTypes.h
  • sdtrCash : GscActionsTypes.h
  • sdtrCheck : GscActionsTypes.h
  • sdtrCreditCard : GscActionsTypes.h
  • sdtrElectronicPurse : GscActionsTypes.h
  • sdtrInvoice : GscActionsTypes.h
  • sdtrIsoDiscount : GscActionsTypes.h
  • sdtrOther : GscActionsTypes.h
  • sdtrParking : GscActionsTypes.h
  • sdtrSale : GscActionsTypes.h
  • sdtrToken : GscActionsTypes.h
  • sdtrUnknown : GscActionsTypes.h
  • sdtrValidation : GscActionsTypes.h
  • sdtrValueCard : GscActionsTypes.h
  • smtClose : GscActionsTypes.h
  • smtCreate : GscActionsTypes.h
  • smtDelete : GscActionsTypes.h
  • smtDisplay : GscActionsTypes.h
  • smtOpen : GscActionsTypes.h
  • smtUnknown : GscActionsTypes.h
  • string : stl.txt
  • SystemKey : GscActionsTypes.h
  • SystemLED : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- t -

  • TADParameterSetID : stl.txt
  • tarPark : GscActionsTypes.h
  • tarPerson : GscActionsTypes.h
  • tarUnknown : GscActionsTypes.h
  • tarWrongDirection : GscActionsTypes.h
  • TEventTypeID : stl.txt
  • tfdIn : GscActionsTypes.h
  • tfdOut : GscActionsTypes.h
  • tfdUnknown : GscActionsTypes.h
  • tfdUnspecified : GscActionsTypes.h
  • TMediaChannelID : stl.txt
  • TPlcABCapacityWarning : GscActionsTypes.h
  • TPlcADArea : GscActionsTypes.h
  • TPlcDigitalInputState : GscActionsTypes.h
  • TPlcDigitalOutputState : GscActionsTypes.h
  • TPlcGetEventDataCallback : GscActions.h
  • TPlcGTectClientVCAType : GscActionsTypes.h
  • TPlcGTectSceneAlarmReason : GscActionsTypes.h
  • TPlcIODeviceType : GscActionsTypes.h
  • TPlcIPSwitchOps : GscActionsTypes.h
  • TPlcLenelAccessResult : GscActionsTypes.h
  • TPlcLenelEventID : GscActionsTypes.h
  • TPlcLenelEventType : GscActionsTypes.h
  • TPlcPlcBacklightMode : GscActionsTypes.h
  • TPlcPlcBackupFormat : GscActionsTypes.h
  • TPlcPlcClientType : GscActionsTypes.h
  • TPlcPlcDatabaseRing : GscActionsTypes.h
  • TPlcPlcDatabaseStatus : GscActionsTypes.h
  • TPlcPlcDayNightMode : GscActionsTypes.h
  • TPlcPlcExportAbort : GscActionsTypes.h
  • TPlcPlcExportMarker : GscActionsTypes.h
  • TPlcPlcExportSuccess : GscActionsTypes.h
  • TPlcPlcFRCNotification : GscActionsTypes.h
  • TPlcPlcImageExportType : GscActionsTypes.h
  • TPlcPlcLpsStatus : GscActionsTypes.h
  • TPlcPlcMessageCode : GscActionsTypes.h
  • TPlcPlcMessageSource : GscActionsTypes.h
  • TPlcPlcNPRRestriction : GscActionsTypes.h
  • TPlcPlcObtrackCounterType : GscActionsTypes.h
  • TPlcPlcObtrackExceedingDirection : GscActionsTypes.h
  • TPlcPlcObtrackObjectClass : GscActionsTypes.h
  • TPlcPlcObtrackObjectStatus : GscActionsTypes.h
  • TPlcPlcObtrackProcessSize : GscActionsTypes.h
  • TPlcPlcPluginError : GscActionsTypes.h
  • TPlcPlcPluginState : GscActionsTypes.h
  • TPlcPlcPOSStatus : GscActionsTypes.h
  • TPlcPlcPumpStatus : GscActionsTypes.h
  • TPlcPlcResourceChangeKind : GscActionsTypes.h
  • TPlcPlcResourceKind : GscActionsTypes.h
  • TPlcPlcSceneStoreModificationType : GscActionsTypes.h
  • TPlcPlcSkidataControl : GscActionsTypes.h
  • TPlcPlcSkidataMsgCodeEntry : GscActionsTypes.h
  • TPlcPlcSkidataMsgCodeExit : GscActionsTypes.h
  • TPlcPlcSkidataMsgCodeTransaction : GscActionsTypes.h
  • TPlcPlcSpecialConstants : GscActionsTypes.h
  • TPlcPlcTunnelAlarmReason : GscActionsTypes.h
  • TPlcPlcViewerAlarmPlayMode : GscActionsTypes.h
  • TPlcPlcViewerAlarmQueueSelection : GscActionsTypes.h
  • TPlcPlcViewerAlarmState : GscActionsTypes.h
  • TPlcPlcViewerPlayMode : GscActionsTypes.h
  • TPlcPPAlarmState : GscActionsTypes.h
  • TPlcPPCableKind : GscActionsTypes.h
  • TPlcPPSensorKind : GscActionsTypes.h
  • TPlcSafebagStep : GscActionsTypes.h
  • TPlcSystemKey : GscActionsTypes.h
  • TPlcSystemLED : GscActionsTypes.h
  • TPlcTimeRangeID : GscActionsTypes.h
  • TPlcTrafficDirection : GscActionsTypes.h
  • TPlcUpdateActionInfoCallbackVersion : GscActionsTypes.h
  • TPlcUserLoginFailureCode : GscActionsTypes.h
  • TPlcVideoInterlaceType : GscActionsTypes.h
  • TPlcVideoSensorKind : GscActionsTypes.h
  • TPlcVideoSignalNorm : GscActionsTypes.h
  • TPlcVideoSignalType : GscActionsTypes.h
  • TPlcVMDCycle : GscActionsTypes.h
  • TPlcVMDGroup : GscActionsTypes.h
  • TrafficDirection : GscActionsTypes.h
  • TResourceID : stl.txt
  • TTimeRangeID : stl.txt
  • TUpdateEventTypeID : GscActionsTypes.h
  • TUpdateMediaChannelID : GscActionsTypes.h
  • TUpdateResChannelID : GscActionsTypes.h
  • TUpdateResourceID : GscActionsTypes.h
  • TVMDParameterSetID : stl.txt


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- u -

  • ulfMissingSecondUser : GscActionsTypes.h
  • ulfNoLicense : GscActionsTypes.h
  • ulfTooManyClients : GscActionsTypes.h
  • ulfUnknown : GscActionsTypes.h
  • ulfUser1InvalPwd : GscActionsTypes.h
  • ulfUser1NotFound : GscActionsTypes.h
  • ulfUser2InvalPwd : GscActionsTypes.h
  • ulfUser2NotAdmitted : GscActionsTypes.h
  • ulfUser2NotFound : GscActionsTypes.h
  • UserLoginFailureCode : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- v -

  • vasConfirmed : GscActionsTypes.h
  • vasLastConfirmed : GscActionsTypes.h
  • vasLastRemoved : GscActionsTypes.h
  • vasListConfirmed : GscActionsTypes.h
  • vasListEmpty : GscActionsTypes.h
  • vasNewAlarm : GscActionsTypes.h
  • vasPresented : GscActionsTypes.h
  • vasRemoved : GscActionsTypes.h
  • vasStacked : GscActionsTypes.h
  • vasUnknown : GscActionsTypes.h
  • VideoInterlaceType : GscActionsTypes.h
  • VideoSensorKind : GscActionsTypes.h
  • VideoSignalNorm : GscActionsTypes.h
  • VideoSignalType : GscActionsTypes.h
  • vmc10s : GscActionsTypes.h
  • vmc160ms : GscActionsTypes.h
  • vmc2_5s : GscActionsTypes.h
  • vmc40ms : GscActionsTypes.h
  • vmc640ms : GscActionsTypes.h
  • vmcUnknown : GscActionsTypes.h
  • VMDCycle : GscActionsTypes.h
  • VMDGroup : GscActionsTypes.h
  • vmgGroup1 : GscActionsTypes.h
  • vmgGroup2 : GscActionsTypes.h
  • vmgGroup3 : GscActionsTypes.h
  • vmgGroup4 : GscActionsTypes.h
  • vmgUnknown : GscActionsTypes.h
  • vpmPeekLivePicture : GscActionsTypes.h
  • vpmPlayBackward : GscActionsTypes.h
  • vpmPlayBOD : GscActionsTypes.h
  • vpmPlayEOD : GscActionsTypes.h
  • vpmPlayFastBackward : GscActionsTypes.h
  • vpmPlayFastForward : GscActionsTypes.h
  • vpmPlayForward : GscActionsTypes.h
  • vpmPlayNextEvent : GscActionsTypes.h
  • vpmPlayNextMOS : GscActionsTypes.h
  • vpmPlayPrevEvent : GscActionsTypes.h
  • vpmPlayPrevMOS : GscActionsTypes.h
  • vpmPlayQuasiLive : GscActionsTypes.h
  • vpmPlayStepBackward : GscActionsTypes.h
  • vpmPlayStepForward : GscActionsTypes.h
  • vpmPlayStop : GscActionsTypes.h
  • vpmPlayStream : GscActionsTypes.h
  • vpmUnknown : GscActionsTypes.h
  • vpmUnknownMode : GscActionsTypes.h
  • vsdInterlaced : GscActionsTypes.h
  • vsdNonInterlaced : GscActionsTypes.h
  • vsdUnknown : GscActionsTypes.h
  • vskAD : GscActionsTypes.h
  • vskCPA : GscActionsTypes.h
  • vskCPAExt : GscActionsTypes.h
  • vskDUAL : GscActionsTypes.h
  • vskFR : GscActionsTypes.h
  • vskGTectVMX : GscActionsTypes.h
  • vskIPAD : GscActionsTypes.h
  • vskNPR : GscActionsTypes.h
  • vskOBTRACK : GscActionsTypes.h
  • vskUnknown : GscActionsTypes.h
  • vskVAMissing : GscActionsTypes.h
  • vskVMD : GscActionsTypes.h
  • vsnCCIR : GscActionsTypes.h
  • vsnEIA : GscActionsTypes.h
  • vsnUnknown : GscActionsTypes.h
  • vstBAS : GscActionsTypes.h
  • vstFBAS : GscActionsTypes.h
  • vstUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all file members with links to the files they belong to:

- w -

  • widestring : stl.txt


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • GscAct_CreateFromTextBuffer : GscActions.h
  • GscAct_GetActionClassByName : GscActions.h
  • GscAct_GetActionCodeByName : GscActions.h
  • GscAct_GetActionName : GscActions.h
  • GscAct_GetActionPlainName : GscActions.h
  • GscAct_StoreToTextBuffer : GscActions.h
  • GSCACTDLLCALL : GscActions.h
  • GscMatchAct_GetActionName : GscActions.h
  • GscMatchAct_GetActionPlainName : GscActions.h
  • GscMatchAct_GetComment : GscActions.h
  • GscMatchAct_GetDescription : GscActions.h
  • GscMatchAct_SetComment : GscActions.h
  • GscMatchAct_SetDescription : GscActions.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • g
  • t

- g -

  • GscActionClass : GscActionsTypes.h
  • GscActionCode : GscActionsTypes.h
  • GscMessageClass : GscActionsTypes.h
  • GscParameterType : GscActionsTypes.h
  • GscParameterView : GscActionsTypes.h

- t -

  • TPlcABCapacityWarning : GscActionsTypes.h
  • TPlcADArea : GscActionsTypes.h
  • TPlcDigitalInputState : GscActionsTypes.h
  • TPlcDigitalOutputState : GscActionsTypes.h
  • TPlcGTectClientVCAType : GscActionsTypes.h
  • TPlcGTectSceneAlarmReason : GscActionsTypes.h
  • TPlcIODeviceType : GscActionsTypes.h
  • TPlcIPSwitchOps : GscActionsTypes.h
  • TPlcLenelAccessResult : GscActionsTypes.h
  • TPlcLenelEventID : GscActionsTypes.h
  • TPlcLenelEventType : GscActionsTypes.h
  • TPlcPlcBacklightMode : GscActionsTypes.h
  • TPlcPlcBackupFormat : GscActionsTypes.h
  • TPlcPlcClientType : GscActionsTypes.h
  • TPlcPlcDatabaseRing : GscActionsTypes.h
  • TPlcPlcDatabaseStatus : GscActionsTypes.h
  • TPlcPlcDayNightMode : GscActionsTypes.h
  • TPlcPlcExportAbort : GscActionsTypes.h
  • TPlcPlcExportMarker : GscActionsTypes.h
  • TPlcPlcExportSuccess : GscActionsTypes.h
  • TPlcPlcFRCNotification : GscActionsTypes.h
  • TPlcPlcImageExportType : GscActionsTypes.h
  • TPlcPlcLpsStatus : GscActionsTypes.h
  • TPlcPlcMessageCode : GscActionsTypes.h
  • TPlcPlcMessageSource : GscActionsTypes.h
  • TPlcPlcNPRRestriction : GscActionsTypes.h
  • TPlcPlcObtrackCounterType : GscActionsTypes.h
  • TPlcPlcObtrackExceedingDirection : GscActionsTypes.h
  • TPlcPlcObtrackObjectClass : GscActionsTypes.h
  • TPlcPlcObtrackObjectStatus : GscActionsTypes.h
  • TPlcPlcObtrackProcessSize : GscActionsTypes.h
  • TPlcPlcPluginError : GscActionsTypes.h
  • TPlcPlcPluginState : GscActionsTypes.h
  • TPlcPlcPOSStatus : GscActionsTypes.h
  • TPlcPlcPumpStatus : GscActionsTypes.h
  • TPlcPlcResourceChangeKind : GscActionsTypes.h
  • TPlcPlcResourceKind : GscActionsTypes.h
  • TPlcPlcSceneStoreModificationType : GscActionsTypes.h
  • TPlcPlcSkidataControl : GscActionsTypes.h
  • TPlcPlcSkidataMsgCodeEntry : GscActionsTypes.h
  • TPlcPlcSkidataMsgCodeExit : GscActionsTypes.h
  • TPlcPlcSkidataMsgCodeTransaction : GscActionsTypes.h
  • TPlcPlcSpecialConstants : GscActionsTypes.h
  • TPlcPlcTunnelAlarmReason : GscActionsTypes.h
  • TPlcPlcViewerAlarmPlayMode : GscActionsTypes.h
  • TPlcPlcViewerAlarmQueueSelection : GscActionsTypes.h
  • TPlcPlcViewerAlarmState : GscActionsTypes.h
  • TPlcPlcViewerPlayMode : GscActionsTypes.h
  • TPlcPPAlarmState : GscActionsTypes.h
  • TPlcPPCableKind : GscActionsTypes.h
  • TPlcPPSensorKind : GscActionsTypes.h
  • TPlcSafebagStep : GscActionsTypes.h
  • TPlcSystemKey : GscActionsTypes.h
  • TPlcSystemLED : GscActionsTypes.h
  • TPlcTrafficDirection : GscActionsTypes.h
  • TPlcUserLoginFailureCode : GscActionsTypes.h
  • TPlcVideoInterlaceType : GscActionsTypes.h
  • TPlcVideoSensorKind : GscActionsTypes.h
  • TPlcVideoSignalNorm : GscActionsTypes.h
  • TPlcVideoSignalType : GscActionsTypes.h
  • TPlcVMDCycle : GscActionsTypes.h
  • TPlcVMDGroup : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- a -

  • abwAllocatedCapacityAboveLimit : GscActionsTypes.h
  • abwBoth : GscActionsTypes.h
  • abwFreeCapacityBelowLimit : GscActionsTypes.h
  • abwOk : GscActionsTypes.h
  • abwUnknown : GscActionsTypes.h
  • ac_ABCConnect : GscActionsTypes.h
  • ac_ABCDisconnect : GscActionsTypes.h
  • ac_ABCPlayFile : GscActionsTypes.h
  • ac_AbortAllAutoBackups : GscActionsTypes.h
  • ac_AbortAutoBackup : GscActionsTypes.h
  • ac_ACSAccessDenied : GscActionsTypes.h
  • ac_ACSAccessGranted : GscActionsTypes.h
  • ac_ACSRawAnswer : GscActionsTypes.h
  • ac_ACSRawData : GscActionsTypes.h
  • ac_ActivateExternalProcess : GscActionsTypes.h
  • ac_ATMRawAnswer : GscActionsTypes.h
  • ac_ATMRawData : GscActionsTypes.h
  • ac_ATMTransaction : GscActionsTypes.h
  • ac_AutoBackupCapacityMonitoringCapacityWarning : GscActionsTypes.h
  • ac_AutoBackupCapacityMonitoringFileAutoDeleted : GscActionsTypes.h
  • ac_AutoBackupCapacityMonitoringOutOfDiskSpace : GscActionsTypes.h
  • ac_AutoBackupFileDone : GscActionsTypes.h
  • ac_AutoBackupFileProgress : GscActionsTypes.h
  • ac_AutoBackupFileStarted : GscActionsTypes.h
  • ac_AutoBackupOperationDone : GscActionsTypes.h
  • ac_AutoBackupOperationStarted : GscActionsTypes.h
  • ac_AutoBackupScheduleDone : GscActionsTypes.h
  • ac_AutoBackupScheduleStarted : GscActionsTypes.h
  • ac_AutoFocusOff : GscActionsTypes.h
  • ac_AutoFocusOn : GscActionsTypes.h
  • ac_BackupEvent : GscActionsTypes.h
  • ac_BarcodeData : GscActionsTypes.h
  • ac_BlockingFilterActivate : GscActionsTypes.h
  • ac_BlockingFilterDeactivate : GscActionsTypes.h
  • ac_CameraApplyProfile : GscActionsTypes.h
  • ac_CameraBacklightCompensationMode : GscActionsTypes.h
  • ac_CameraClearPrePosText : GscActionsTypes.h
  • ac_CameraDayNightMode : GscActionsTypes.h
  • ac_CameraLightOff : GscActionsTypes.h
  • ac_CameraLightOn : GscActionsTypes.h
  • ac_CameraManualIrisOff : GscActionsTypes.h
  • ac_CameraManualIrisOn : GscActionsTypes.h
  • ac_CameraOff : GscActionsTypes.h
  • ac_CameraOn : GscActionsTypes.h
  • ac_CameraPumpOff : GscActionsTypes.h
  • ac_CameraPumpOn : GscActionsTypes.h
  • ac_CameraRAWOutput : GscActionsTypes.h
  • ac_CameraSelectCharMode : GscActionsTypes.h
  • ac_CameraSetPrePosText : GscActionsTypes.h
  • ac_CameraSpecFuncUOff : GscActionsTypes.h
  • ac_CameraSpecFuncUOn : GscActionsTypes.h
  • ac_CameraSpecFuncVOff : GscActionsTypes.h
  • ac_CameraSpecFuncVOn : GscActionsTypes.h
  • ac_CameraSpecFuncXOff : GscActionsTypes.h
  • ac_CameraSpecFuncXOn : GscActionsTypes.h
  • ac_CameraSpecFuncYOff : GscActionsTypes.h
  • ac_CameraSpecFuncYOn : GscActionsTypes.h
  • ac_CameraStopAll : GscActionsTypes.h
  • ac_CameraTextOff : GscActionsTypes.h
  • ac_CameraTextOn : GscActionsTypes.h
  • ac_CameraTourStart : GscActionsTypes.h
  • ac_CameraTourStop : GscActionsTypes.h
  • ac_CameraVersionOff : GscActionsTypes.h
  • ac_CameraVersionOn : GscActionsTypes.h
  • ac_CameraWashOff : GscActionsTypes.h
  • ac_CameraWashOn : GscActionsTypes.h
  • ac_CancelExport : GscActionsTypes.h
  • ac_CaseClosed : GscActionsTypes.h
  • ac_CaseOpened : GscActionsTypes.h
  • ac_ChangeADParameterSet : GscActionsTypes.h
  • ac_ChangeCameraProfile : GscActionsTypes.h
  • ac_ChangeCPAParameterSet : GscActionsTypes.h
  • ac_ChangeGTectParameterSet : GscActionsTypes.h
  • ac_ChangeObtrackParameterSet : GscActionsTypes.h
  • ac_ChangeVMDParameterSet : GscActionsTypes.h
  • ac_ChannelError : GscActionsTypes.h
  • ac_ChannelInfo : GscActionsTypes.h
  • ac_ChannelLiveCheck : GscActionsTypes.h
  • ac_ChannelWarning : GscActionsTypes.h
  • ac_CPAMeasurement : GscActionsTypes.h
  • ac_CustomAction : GscActionsTypes.h
  • ac_DatabaseRecordingInfoRing : GscActionsTypes.h
  • ac_DatabaseRecordingInfoTotal : GscActionsTypes.h
  • ac_DatabaseStarted : GscActionsTypes.h
  • ac_DefaultPosCallUp : GscActionsTypes.h
  • ac_DefaultPosClear : GscActionsTypes.h
  • ac_DefaultPosSave : GscActionsTypes.h
  • ac_DeviceFound : GscActionsTypes.h
  • ac_DeviceNewFirmware : GscActionsTypes.h
  • ac_DevicePluginError : GscActionsTypes.h
  • ac_DevicePluginState : GscActionsTypes.h
  • ac_DeviceReattached : GscActionsTypes.h
  • ac_DeviceRemoved : GscActionsTypes.h
  • ac_DigitalInput : GscActionsTypes.h
  • ac_EventBackupDone : GscActionsTypes.h
  • ac_EventBackupFileDone : GscActionsTypes.h
  • ac_EventBackupFileProgress : GscActionsTypes.h
  • ac_EventBackupFileStarted : GscActionsTypes.h
  • ac_EventBackupStarted : GscActionsTypes.h
  • ac_EventRecordingChanged : GscActionsTypes.h
  • ac_EventStarted : GscActionsTypes.h
  • ac_EventStopped : GscActionsTypes.h
  • ac_ExportFinished : GscActionsTypes.h
  • ac_ExportProgress : GscActionsTypes.h
  • ac_FastSpeedOff : GscActionsTypes.h
  • ac_FastSpeedOn : GscActionsTypes.h
  • ac_FillingPumpStatus : GscActionsTypes.h
  • ac_FocusFar : GscActionsTypes.h
  • ac_FocusNear : GscActionsTypes.h
  • ac_FocusStop : GscActionsTypes.h
  • ac_FRCNotification : GscActionsTypes.h
  • ac_GEMOSalarm : GscActionsTypes.h
  • ac_GSCSVehicleAccessDenied : GscActionsTypes.h
  • ac_GSCSVehicleAccessExpired : GscActionsTypes.h
  • ac_GSCSVehicleAccessGranted : GscActionsTypes.h
  • ac_GSCSVehicleAccessPending : GscActionsTypes.h
  • ac_GTectAnalyticsLiveCheck : GscActionsTypes.h
  • ac_GTectDualSensorAlarm : GscActionsTypes.h
  • ac_GTectDualSensorAlarmFinished : GscActionsTypes.h
  • ac_GTectSceneAlarm : GscActionsTypes.h
  • ac_GTectSceneAlarmFinished : GscActionsTypes.h
  • ac_GTectVMXAlarm : GscActionsTypes.h
  • ac_GTectVMXAlarmFinished : GscActionsTypes.h
  • ac_IASSettingsChanged : GscActionsTypes.h
  • ac_ImageExportNotification : GscActionsTypes.h
  • ac_ImexCapacityFileAutoDeleted : GscActionsTypes.h
  • ac_ImexCapacityOutOfDiskSpace : GscActionsTypes.h
  • ac_ImexCapacityWarning : GscActionsTypes.h
  • ac_ImexExportEventImage : GscActionsTypes.h
  • ac_ImexExportImageFromDB : GscActionsTypes.h
  • ac_ImexExportImageFromLiveStream : GscActionsTypes.h
  • ac_InitializeRemoteExport : GscActionsTypes.h
  • ac_InterfaceRawAnswer : GscActionsTypes.h
  • ac_InterfaceRawData : GscActionsTypes.h
  • ac_IOI43ResetMainboard : GscActionsTypes.h
  • ac_IOI43Temperature : GscActionsTypes.h
  • ac_IOI43WDActivate : GscActionsTypes.h
  • ac_IOI43WDDeactivate : GscActionsTypes.h
  • ac_IOI43WDTrigger : GscActionsTypes.h
  • ac_IPCameraRawCommand : GscActionsTypes.h
  • ac_IPCamFailoverNotification : GscActionsTypes.h
  • ac_IPCamFailoverRestore : GscActionsTypes.h
  • ac_IPSwitchOperation : GscActionsTypes.h
  • ac_IrisClose : GscActionsTypes.h
  • ac_IrisOpen : GscActionsTypes.h
  • ac_IrisStop : GscActionsTypes.h
  • ac_KeyPressed : GscActionsTypes.h
  • ac_KeyReleased : GscActionsTypes.h
  • ac_KillAllEvents : GscActionsTypes.h
  • ac_KillEvent : GscActionsTypes.h
  • ac_KillEventByID : GscActionsTypes.h
  • ac_LenelAccessEvent : GscActionsTypes.h
  • ac_LenelFireEvent : GscActionsTypes.h
  • ac_LenelIntercomEvent : GscActionsTypes.h
  • ac_LenelRawData : GscActionsTypes.h
  • ac_LenelRefreshNames : GscActionsTypes.h
  • ac_LenelSecurityEvent : GscActionsTypes.h
  • ac_LenelVideoEvent : GscActionsTypes.h
  • ac_LiveCheck : GscActionsTypes.h
  • ac_LogBarcodeData : GscActionsTypes.h
  • ac_LogBarcodeDataLPS : GscActionsTypes.h
  • ac_LogNPRRecognition : GscActionsTypes.h
  • ac_LPSPositionData : GscActionsTypes.h
  • ac_LPSQueryPosition : GscActionsTypes.h
  • ac_MakeCPAReferenceImage : GscActionsTypes.h
  • ac_MediaChannelSetupInfo : GscActionsTypes.h
  • ac_MoveToAbsolutePosition : GscActionsTypes.h
  • ac_MoveToBySpeed : GscActionsTypes.h
  • ac_MoveToRelativePosition : GscActionsTypes.h
  • ac_NPRRawData : GscActionsTypes.h
  • ac_NPRRecognition : GscActionsTypes.h
  • ac_ObtrackChannelCounter : GscActionsTypes.h
  • ac_ObtrackChannelCounterThreshold : GscActionsTypes.h
  • ac_ObtrackChannelSetCounter : GscActionsTypes.h
  • ac_ObtrackFrameRawData : GscActionsTypes.h
  • ac_ObtrackGroupCounter : GscActionsTypes.h
  • ac_ObtrackGroupCounterThreshold : GscActionsTypes.h
  • ac_ObtrackGroupSetCounter : GscActionsTypes.h
  • ac_ObtrackObjectRawData : GscActionsTypes.h
  • ac_ObtrackTunnelAlarm : GscActionsTypes.h
  • ac_PanAuto : GscActionsTypes.h
  • ac_PanLeft : GscActionsTypes.h
  • ac_PanRight : GscActionsTypes.h
  • ac_PanStop : GscActionsTypes.h
  • ac_POSData : GscActionsTypes.h
  • ac_POSStatus : GscActionsTypes.h
  • ac_PPDeviceAlarm : GscActionsTypes.h
  • ac_PPDeviceInput : GscActionsTypes.h
  • ac_PPDeviceOffline : GscActionsTypes.h
  • ac_PPDeviceOnline : GscActionsTypes.h
  • ac_PPInterfaceOffline : GscActionsTypes.h
  • ac_PPInterfaceOnline : GscActionsTypes.h
  • ac_PPQueryInterface : GscActionsTypes.h
  • ac_PPSetDeviceOutput : GscActionsTypes.h
  • ac_PPSubcellAlarm : GscActionsTypes.h
  • ac_PPZoneAlarm : GscActionsTypes.h
  • ac_PrePosCallUp : GscActionsTypes.h
  • ac_PrePosClear : GscActionsTypes.h
  • ac_PrePosSave : GscActionsTypes.h
  • ac_RedundantPowerFailure : GscActionsTypes.h
  • ac_RedundantPowerOk : GscActionsTypes.h
  • ac_ResetMainboard : GscActionsTypes.h
  • ac_SafebagClose : GscActionsTypes.h
  • ac_SafebagData : GscActionsTypes.h
  • ac_SafebagOpen : GscActionsTypes.h
  • ac_SafebagPassingOfRiskData : GscActionsTypes.h
  • ac_SafebagPassingOfRiskStart : GscActionsTypes.h
  • ac_SafebagPassingOfRiskStop : GscActionsTypes.h
  • ac_SceneStoreModification : GscActionsTypes.h
  • ac_SensorAlarmFinished : GscActionsTypes.h
  • ac_SensorAudioAlarm : GscActionsTypes.h
  • ac_SensorInhibitAlarmFinished : GscActionsTypes.h
  • ac_SensorInhibitVideoAlarm : GscActionsTypes.h
  • ac_SensorVideoAlarm : GscActionsTypes.h
  • ac_SetCameraText : GscActionsTypes.h
  • ac_SetClientVCA : GscActionsTypes.h
  • ac_SetClock : GscActionsTypes.h
  • ac_SetDigitalOutput : GscActionsTypes.h
  • ac_SetExportMarker : GscActionsTypes.h
  • ac_SetLED : GscActionsTypes.h
  • ac_SetLEDBlink : GscActionsTypes.h
  • ac_SetSystemTime : GscActionsTypes.h
  • ac_SetTestPictureMode : GscActionsTypes.h
  • ac_SetupChanged : GscActionsTypes.h
  • ac_SetupUploadProgress : GscActionsTypes.h
  • ac_SetWatchdog : GscActionsTypes.h
  • ac_SkidataControl : GscActionsTypes.h
  • ac_SkidataDeviceEvent : GscActionsTypes.h
  • ac_SkidataEntry : GscActionsTypes.h
  • ac_SkidataExit : GscActionsTypes.h
  • ac_SkidataTransaction : GscActionsTypes.h
  • ac_SMRPViewerCleared : GscActionsTypes.h
  • ac_SMRPViewerConnected : GscActionsTypes.h
  • ac_SMTPMailSend : GscActionsTypes.h
  • ac_StartAutoBackup : GscActionsTypes.h
  • ac_StartEvent : GscActionsTypes.h
  • ac_StartRemoteExport : GscActionsTypes.h
  • ac_StartSceneStore : GscActionsTypes.h
  • ac_StopAllEvents : GscActionsTypes.h
  • ac_StopEvent : GscActionsTypes.h
  • ac_StopEventByID : GscActionsTypes.h
  • ac_SystemError : GscActionsTypes.h
  • ac_SystemInfo : GscActionsTypes.h
  • ac_SystemSettingsChanged : GscActionsTypes.h
  • ac_SystemStarted : GscActionsTypes.h
  • ac_SystemTerminating : GscActionsTypes.h
  • ac_SystemWarning : GscActionsTypes.h
  • ac_Temperature : GscActionsTypes.h
  • ac_TerminalArticleData : GscActionsTypes.h
  • ac_TerminalPaymentData : GscActionsTypes.h
  • ac_TiltDown : GscActionsTypes.h
  • ac_TiltStop : GscActionsTypes.h
  • ac_TiltUp : GscActionsTypes.h
  • ac_TransferBinaryBuffer : GscActionsTypes.h
  • ac_TransferBinaryChannelBuffer : GscActionsTypes.h
  • ac_Unknown : GscActionsTypes.h
  • ac_UserLogin : GscActionsTypes.h
  • ac_UserLoginFailed : GscActionsTypes.h
  • ac_UserLogout : GscActionsTypes.h
  • ac_VCAlarmQueueConfirm : GscActionsTypes.h
  • ac_VCAlarmQueueConfirmByInstance : GscActionsTypes.h
  • ac_VCAlarmQueueConfirmByType : GscActionsTypes.h
  • ac_VCAlarmQueueNotification : GscActionsTypes.h
  • ac_VCAlarmQueueRemove : GscActionsTypes.h
  • ac_VCAlarmQueueRemoveByInstance : GscActionsTypes.h
  • ac_VCAlarmQueueRemoveByType : GscActionsTypes.h
  • ac_VCAlarmQueueSelect : GscActionsTypes.h
  • ac_VCAlarmQueueSelectByInstance : GscActionsTypes.h
  • ac_VCAlarmQueueSelectByType : GscActionsTypes.h
  • ac_VCASetArmed : GscActionsTypes.h
  • ac_VCAStatusAnswer : GscActionsTypes.h
  • ac_VCAStatusRequest : GscActionsTypes.h
  • ac_VCChangeSceneByName : GscActionsTypes.h
  • ac_VCClearSceneByName : GscActionsTypes.h
  • ac_VCFullMode : GscActionsTypes.h
  • ac_VCSceneChanged : GscActionsTypes.h
  • ac_VCSetAudioLevel : GscActionsTypes.h
  • ac_VCShowViewerText : GscActionsTypes.h
  • ac_VCStretchMode : GscActionsTypes.h
  • ac_VideoContrastDetected : GscActionsTypes.h
  • ac_VideoContrastFailed : GscActionsTypes.h
  • ac_VideoSetImageBrightness : GscActionsTypes.h
  • ac_VideoSetImageContrast : GscActionsTypes.h
  • ac_VideoSetImageSaturation : GscActionsTypes.h
  • ac_VideoSourceChanged : GscActionsTypes.h
  • ac_VideoSyncDetected : GscActionsTypes.h
  • ac_VideoSyncFailed : GscActionsTypes.h
  • ac_ViewerChangeScene : GscActionsTypes.h
  • ac_ViewerClear : GscActionsTypes.h
  • ac_ViewerCleared : GscActionsTypes.h
  • ac_ViewerClearScene : GscActionsTypes.h
  • ac_ViewerClearTextOutput : GscActionsTypes.h
  • ac_ViewerConnect : GscActionsTypes.h
  • ac_ViewerConnected : GscActionsTypes.h
  • ac_ViewerConnectLive : GscActionsTypes.h
  • ac_ViewerExportPicture : GscActionsTypes.h
  • ac_ViewerJumpByTime : GscActionsTypes.h
  • ac_ViewerMaximize : GscActionsTypes.h
  • ac_ViewerPlayFromTime : GscActionsTypes.h
  • ac_ViewerPlayModeChanged : GscActionsTypes.h
  • ac_ViewerPrintPicture : GscActionsTypes.h
  • ac_ViewerSelect : GscActionsTypes.h
  • ac_ViewerSelectionChanged : GscActionsTypes.h
  • ac_ViewerSetPlayMode : GscActionsTypes.h
  • ac_ViewerShowAlarmByInstance : GscActionsTypes.h
  • ac_ViewerShowAlarmByKey : GscActionsTypes.h
  • ac_ViewerShowAlarmByType : GscActionsTypes.h
  • ac_ViewerSyncAudioAndVideo : GscActionsTypes.h
  • ac_ViewerTextOutput : GscActionsTypes.h
  • ac_WatchdogActivate : GscActionsTypes.h
  • ac_WatchdogDeactivate : GscActionsTypes.h
  • ac_WatchdogTrigger : GscActionsTypes.h
  • ac_ZoomIn : GscActionsTypes.h
  • ac_ZoomOut : GscActionsTypes.h
  • ac_ZoomStop : GscActionsTypes.h
  • adgArea1 : GscActionsTypes.h
  • adgArea2 : GscActionsTypes.h
  • adgArea3 : GscActionsTypes.h
  • adgArea4 : GscActionsTypes.h
  • adgUnknown : GscActionsTypes.h
  • ak_ATM : GscActionsTypes.h
  • ak_Audio : GscActionsTypes.h
  • ak_Backup : GscActionsTypes.h
  • ak_CameraControl : GscActionsTypes.h
  • ak_CashManagement : GscActionsTypes.h
  • ak_Device : GscActionsTypes.h
  • ak_DigitalContacts : GscActionsTypes.h
  • ak_Imex : GscActionsTypes.h
  • ak_Lenel : GscActionsTypes.h
  • ak_Logistic : GscActionsTypes.h
  • ak_LPS : GscActionsTypes.h
  • ak_POS : GscActionsTypes.h
  • ak_PP : GscActionsTypes.h
  • ak_RemoteExport : GscActionsTypes.h
  • ak_SkiData : GscActionsTypes.h
  • ak_System : GscActionsTypes.h
  • ak_Unknown : GscActionsTypes.h
  • ak_Video : GscActionsTypes.h
  • ak_Viewer : GscActionsTypes.h
  • ak_ViewerNotification : GscActionsTypes.h
  • apmContinuousEventReplayInALoop : GscActionsTypes.h
  • apmDefault : GscActionsTypes.h
  • apmLiveReplay : GscActionsTypes.h
  • apmReplayEventPictures : GscActionsTypes.h
  • apmShowFirstAlarmPictureOnly : GscActionsTypes.h
  • apmUnknown : GscActionsTypes.h
  • aqsFirst : GscActionsTypes.h
  • aqsLast : GscActionsTypes.h
  • aqsNext : GscActionsTypes.h
  • aqsPrevious : GscActionsTypes.h
  • aqsUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- k -

  • keyDisplay1 : GscActionsTypes.h
  • keyDisplay2 : GscActionsTypes.h
  • keyDisplay3 : GscActionsTypes.h
  • keyDisplay4 : GscActionsTypes.h
  • keyReporter1 : GscActionsTypes.h
  • keyUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- l -

  • larDenied : GscActionsTypes.h
  • larGranted : GscActionsTypes.h
  • larlUnknown : GscActionsTypes.h
  • larNotApplicable : GscActionsTypes.h
  • larOther : GscActionsTypes.h
  • larUnknown : GscActionsTypes.h
  • ledError : GscActionsTypes.h
  • ledGreen : GscActionsTypes.h
  • ledIOI43a1 : GscActionsTypes.h
  • ledIOI43a2 : GscActionsTypes.h
  • ledIOI43a3 : GscActionsTypes.h
  • ledIOI43a4 : GscActionsTypes.h
  • ledRecord : GscActionsTypes.h
  • ledUnknown : GscActionsTypes.h
  • ledYellow : GscActionsTypes.h
  • leiAcceptedBiometricScore : GscActionsTypes.h
  • leiAccessDeniedAreaEmpty : GscActionsTypes.h
  • leiAccessDeniedAreaOccupied : GscActionsTypes.h
  • leiAccessDeniedAssetRequired : GscActionsTypes.h
  • leiAccessDeniedBiometricReaderOffline : GscActionsTypes.h
  • leiAccessDeniedDoorSecured : GscActionsTypes.h
  • leiAccessDeniedEscortTimeoutExpired : GscActionsTypes.h
  • leiAccessDeniedGeneral : GscActionsTypes.h
  • leiAccessDeniedInterlock : GscActionsTypes.h
  • leiAccessDeniedNoBiometricTemplate : GscActionsTypes.h
  • leiAccessDeniedNoOccupantApproval : GscActionsTypes.h
  • leiAccessDeniedPassback : GscActionsTypes.h
  • leiAccessDeniedReaderLocked : GscActionsTypes.h
  • leiAccessDeniedSpecial : GscActionsTypes.h
  • leiAccessDeniedUnauthorizedArmingState : GscActionsTypes.h
  • leiAccessDeniedUnauthorizedEntryLevel : GscActionsTypes.h
  • leiAccessDeniedUnauthorizedTime : GscActionsTypes.h
  • leiAccessDeniedUnderDuress : GscActionsTypes.h
  • leiAccessGranted : GscActionsTypes.h
  • leiAccessGrantedAntiPassbackNotUsed : GscActionsTypes.h
  • leiAccessGrantedAntiPassbackUsed : GscActionsTypes.h
  • leiAccessGrantedGenral : GscActionsTypes.h
  • leiAccessGrantedNoEntryMade : GscActionsTypes.h
  • leiAccessGrantedonFacilityCode : GscActionsTypes.h
  • leiAccessGrantedonFacilityCodeNoEntryMade : GscActionsTypes.h
  • leiAccessGrantedReaderUnlocked : GscActionsTypes.h
  • leiAccessGrantedUnderDuress : GscActionsTypes.h
  • leiAccessGrantedUnderDuressNoEntryMade : GscActionsTypes.h
  • leiAcknowledgmentActionExecuted : GscActionsTypes.h
  • leiAcknowledgmentActionFailed : GscActionsTypes.h
  • leiAlarmActive : GscActionsTypes.h
  • leiAlarmCanceled : GscActionsTypes.h
  • leiAlarmMaskGroupArmed : GscActionsTypes.h
  • leiAlarmMaskGroupArmingFailureActivePoints : GscActionsTypes.h
  • leiAlarmMaskGroupDisarmed : GscActionsTypes.h
  • leiAlarmMaskGroupForceArmed : GscActionsTypes.h
  • leiAlarmMaskGroupMaskCountDecremented : GscActionsTypes.h
  • leiAlarmMaskGroupMaskCountIncremented : GscActionsTypes.h
  • leiAlarmMonitoringActionGroupExecuted : GscActionsTypes.h
  • leiAlarmMonitoringActionGroupFailed : GscActionsTypes.h
  • leiAntiPassbackInvalidEntryReader : GscActionsTypes.h
  • leiAntiPassbackInvalidExitReader : GscActionsTypes.h
  • leiAntiPassbackViolation : GscActionsTypes.h
  • leiAreaClosed : GscActionsTypes.h
  • leiAreaLimitExceeded : GscActionsTypes.h
  • leiBiometricMismatch : GscActionsTypes.h
  • leiBiometricVerifyModeDisabled : GscActionsTypes.h
  • leiBiometricVerifyModeEnabled : GscActionsTypes.h
  • leiCabinetTamper : GscActionsTypes.h
  • leiCallConferenced : GscActionsTypes.h
  • leiCallDisconnected : GscActionsTypes.h
  • leiCallEnded : GscActionsTypes.h
  • leiCallEstablished : GscActionsTypes.h
  • leiCallFailed : GscActionsTypes.h
  • leiCallQueued : GscActionsTypes.h
  • leiCalltoaBusySubscriber : GscActionsTypes.h
  • leiCalltoanOpenSubscriber : GscActionsTypes.h
  • leiCalltoaPrivateSubscriber : GscActionsTypes.h
  • leiCallTransferred : GscActionsTypes.h
  • leiCanceledCabinetTamper : GscActionsTypes.h
  • leiCanceledPowerFailure : GscActionsTypes.h
  • leiCipherModeDisabled : GscActionsTypes.h
  • leiCipherModeEnabled : GscActionsTypes.h
  • leiCommunicationsLost : GscActionsTypes.h
  • leiCommunicationsRestored : GscActionsTypes.h
  • leiCommunicationsWithHostLost : GscActionsTypes.h
  • leiCommunicationsWithHostRestored : GscActionsTypes.h
  • leiDeniedBadgeNotinPanel : GscActionsTypes.h
  • leiDeniedCountExceeded : GscActionsTypes.h
  • leiDeniedLowBattery : GscActionsTypes.h
  • leiDeniedNoCommandAuthority : GscActionsTypes.h
  • leiDeniedNoHostApproval : GscActionsTypes.h
  • leiDeniedPINOnlyRequest : GscActionsTypes.h
  • leiDeniedReaderExcluded : GscActionsTypes.h
  • leiDeniedUnauthorizedAssets : GscActionsTypes.h
  • leiDeniedUnMaskActiveZonesinGroup : GscActionsTypes.h
  • leiDoorClose : GscActionsTypes.h
  • leiDoorContactTamper : GscActionsTypes.h
  • leiDoorContactTamperCanceled : GscActionsTypes.h
  • leiDoorForcedOpen : GscActionsTypes.h
  • leiDoorForcedOpenCanceled : GscActionsTypes.h
  • leiDoorForcedOpenMasked : GscActionsTypes.h
  • leiDoorForcedOpenUnmasked : GscActionsTypes.h
  • leiDoorHeldOpen : GscActionsTypes.h
  • leiDoorHeldOpenCanceled : GscActionsTypes.h
  • leiDoorHeldOpenMasked : GscActionsTypes.h
  • leiDoorHeldOpenUnmasked : GscActionsTypes.h
  • leiDoorOpen : GscActionsTypes.h
  • leiElevatorTerminalModeAccesstoAuthorizedFloors : GscActionsTypes.h
  • leiElevatorTerminalModeDefaultFloor : GscActionsTypes.h
  • leiElevatorTerminalModeDefaultFloororUserEntryofDestinationFloor : GscActionsTypes.h
  • leiElevatorTerminalModeUserEntryofDestinationFloor : GscActionsTypes.h
  • leiExtendedHeldCommandDenied : GscActionsTypes.h
  • leiExtendedHeldCommandSetFromReader : GscActionsTypes.h
  • leiExtendedHeldOpenModeDisabled : GscActionsTypes.h
  • leiExtendedHeldOpenModeEnabled : GscActionsTypes.h
  • leiFireAlarmAcknowledge : GscActionsTypes.h
  • leiFireAlarmBlockAcknowledge : GscActionsTypes.h
  • leiFireAlarmIn : GscActionsTypes.h
  • leiFireAlarmOut : GscActionsTypes.h
  • leiFirstCardUnlockModeDisabled : GscActionsTypes.h
  • leiFirstCardUnlockModeEnabled : GscActionsTypes.h
  • leiGenericEvent : GscActionsTypes.h
  • leiGlobalLinkageActionExecuted : GscActionsTypes.h
  • leiGlobalLinkageActionFailed : GscActionsTypes.h
  • leiGuardTourActionExecuted : GscActionsTypes.h
  • leiGuardTourActionFailed : GscActionsTypes.h
  • leiHold : GscActionsTypes.h
  • leiInactiveBadge : GscActionsTypes.h
  • leiIncomingCall : GscActionsTypes.h
  • leiInitiated : GscActionsTypes.h
  • leiInputAlarmed : GscActionsTypes.h
  • leiInputHigh : GscActionsTypes.h
  • leiInputHighHigh : GscActionsTypes.h
  • leiInputLow : GscActionsTypes.h
  • leiInputLowLow : GscActionsTypes.h
  • leiInputMasked : GscActionsTypes.h
  • leiInputNormal : GscActionsTypes.h
  • leiInputUnmasked : GscActionsTypes.h
  • leiIntercomExchangeFailure : GscActionsTypes.h
  • leiIntercomFunction : GscActionsTypes.h
  • leiIntrusionCommandAccepted : GscActionsTypes.h
  • leiIntrusionCommandDenied : GscActionsTypes.h
  • leiInvalidAccessLevel : GscActionsTypes.h
  • leiInvalidBadge : GscActionsTypes.h
  • leiInvalidCardFormat : GscActionsTypes.h
  • leiInvalidFacilityCode : GscActionsTypes.h
  • leiInvalidIssueCode : GscActionsTypes.h
  • leiInvalidPINNumber : GscActionsTypes.h
  • leiLocalIOExecutedFunctionList : GscActionsTypes.h
  • leiMaxAssetsReached : GscActionsTypes.h
  • leiMaxCardholdersReached : GscActionsTypes.h
  • leiNoBiometricTemplateData : GscActionsTypes.h
  • leiNotConfigured : GscActionsTypes.h
  • leiOpenDoorCommandIssuedDoorNotUsed : GscActionsTypes.h
  • leiOpenDoorCommandIssuedDoorUsed : GscActionsTypes.h
  • leiPanelOptionsMismatch : GscActionsTypes.h
  • leiPowerFailure : GscActionsTypes.h
  • leiReaderInputTamper : GscActionsTypes.h
  • leiReaderInputTamperCanceled : GscActionsTypes.h
  • leiReaderModeCardandPin : GscActionsTypes.h
  • leiReaderModeCardOnly : GscActionsTypes.h
  • leiReaderModeFacilityCode : GscActionsTypes.h
  • leiReaderModeFirstCardUnlock : GscActionsTypes.h
  • leiReaderModeLocked : GscActionsTypes.h
  • leiReaderModePinorCard : GscActionsTypes.h
  • leiReaderModeUnlocked : GscActionsTypes.h
  • leiReaderOffline : GscActionsTypes.h
  • leiReaderOfflineRestored : GscActionsTypes.h
  • leiRejectedBiometricScore : GscActionsTypes.h
  • leiRelayContactActivated : GscActionsTypes.h
  • leiRelayContactDeactivated : GscActionsTypes.h
  • leiRequesttoExitDoorNotUsed : GscActionsTypes.h
  • leiRequesttoExitDoorUsed : GscActionsTypes.h
  • leiRetrieved : GscActionsTypes.h
  • leiRinging : GscActionsTypes.h
  • leiSchedulerActionExecuted : GscActionsTypes.h
  • leiSchedulerActionFailed : GscActionsTypes.h
  • leiSmartCardAuthenticationFailed : GscActionsTypes.h
  • leiTestReport : GscActionsTypes.h
  • leiTimeoutExceededNoSecondCard : GscActionsTypes.h
  • leiTroubleAcknowledge : GscActionsTypes.h
  • leiTroubleIn : GscActionsTypes.h
  • leiTroubleOut : GscActionsTypes.h
  • leiTroubleReport : GscActionsTypes.h
  • leiUnansweredCall : GscActionsTypes.h
  • leiUnknown : GscActionsTypes.h
  • leiUnknownElevatorTerminal : GscActionsTypes.h
  • leiUnknownUserCommand : GscActionsTypes.h
  • leiUseLimitExceeded : GscActionsTypes.h
  • letAccessDenied : GscActionsTypes.h
  • letAccessGranted : GscActionsTypes.h
  • letAreaAPB : GscActionsTypes.h
  • letAsset : GscActionsTypes.h
  • letBiometric : GscActionsTypes.h
  • letBurglary : GscActionsTypes.h
  • letC900 : GscActionsTypes.h
  • letDigitize : GscActionsTypes.h
  • letDuress : GscActionsTypes.h
  • letFireEight : GscActionsTypes.h
  • letFireNine : GscActionsTypes.h
  • letFireSeven : GscActionsTypes.h
  • letGas : GscActionsTypes.h
  • letGeneric : GscActionsTypes.h
  • letHostMessages : GscActionsTypes.h
  • letIntercom : GscActionsTypes.h
  • letMedical : GscActionsTypes.h
  • letMuster : GscActionsTypes.h
  • letOpenClose : GscActionsTypes.h
  • letPointofSale : GscActionsTypes.h
  • letPortableProgrammer : GscActionsTypes.h
  • letRelaySounder : GscActionsTypes.h
  • letSystem : GscActionsTypes.h
  • letTemperature : GscActionsTypes.h
  • letTransmitter : GscActionsTypes.h
  • letTrouble : GscActionsTypes.h
  • letUnknown : GscActionsTypes.h
  • letVideo : GscActionsTypes.h
  • letWater : GscActionsTypes.h
  • lstError : GscActionsTypes.h
  • lstInvalidID : GscActionsTypes.h
  • lstLastPosition : GscActionsTypes.h
  • lstPositionOK : GscActionsTypes.h
  • lstUnknown : GscActionsTypes.h
  • lstUnknownArea : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- m -

  • mk_Action : GscActionsTypes.h
  • mk_MatchAction : GscActionsTypes.h
  • mk_Unknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- n -

  • nrrBlackListed : GscActionsTypes.h
  • nrrUnknown : GscActionsTypes.h
  • nrrUnspecified : GscActionsTypes.h
  • nrrWhiteListed : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- o -

  • octCommon : GscActionsTypes.h
  • octIncoming : GscActionsTypes.h
  • octOutcoming : GscActionsTypes.h
  • octUnknown : GscActionsTypes.h
  • oedExceed : GscActionsTypes.h
  • oedFallBelow : GscActionsTypes.h
  • oedUnknown : GscActionsTypes.h
  • oocCar : GscActionsTypes.h
  • oocPerson : GscActionsTypes.h
  • oocUndefined : GscActionsTypes.h
  • oocUnknown : GscActionsTypes.h
  • oosDeleted : GscActionsTypes.h
  • oosLeaving : GscActionsTypes.h
  • oosStarting : GscActionsTypes.h
  • oosStationary : GscActionsTypes.h
  • oosUndefined : GscActionsTypes.h
  • oosUnknown : GscActionsTypes.h
  • opsCIF : GscActionsTypes.h
  • opsFourCIF : GscActionsTypes.h
  • opsTakeWhatYouGet : GscActionsTypes.h
  • opsUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- d -

  • dbrRing1 : GscActionsTypes.h
  • dbrRing2 : GscActionsTypes.h
  • dbrRing3 : GscActionsTypes.h
  • dbrRing4 : GscActionsTypes.h
  • dbrRing5 : GscActionsTypes.h
  • dbrRing6 : GscActionsTypes.h
  • dbrRing7 : GscActionsTypes.h
  • dbrRing8 : GscActionsTypes.h
  • dbrUnknown : GscActionsTypes.h
  • dbsEmpty : GscActionsTypes.h
  • dbsFileAdded : GscActionsTypes.h
  • dbsReady : GscActionsTypes.h
  • dbsUnknown : GscActionsTypes.h
  • dioDeviceTypeIOI43 : GscActionsTypes.h
  • dioDeviceTypeMIO : GscActionsTypes.h
  • dioUnknown : GscActionsTypes.h
  • disHigh : GscActionsTypes.h
  • disLow : GscActionsTypes.h
  • disMiddle : GscActionsTypes.h
  • disUnknown : GscActionsTypes.h
  • dosClose : GscActionsTypes.h
  • dosOpen : GscActionsTypes.h
  • dosToggle : GscActionsTypes.h
  • dosUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- e -

  • ebfDefault : GscActionsTypes.h
  • ebfGBF : GscActionsTypes.h
  • ebfMPEG2 : GscActionsTypes.h
  • ebfUnknown : GscActionsTypes.h
  • exaError : GscActionsTypes.h
  • exaLowDiscSpace : GscActionsTypes.h
  • exaNoUserRights : GscActionsTypes.h
  • exaUnknown : GscActionsTypes.h
  • exaUserAbort : GscActionsTypes.h
  • exmSelectionBegin : GscActionsTypes.h
  • exmSelectionEnd : GscActionsTypes.h
  • exmUnknown : GscActionsTypes.h
  • exsAborted : GscActionsTypes.h
  • exsConnectionError : GscActionsTypes.h
  • exsFailed : GscActionsTypes.h
  • exsLowDiscSpace : GscActionsTypes.h
  • exsNoUserRights : GscActionsTypes.h
  • exsQueueSizeReached : GscActionsTypes.h
  • exsSuccess : GscActionsTypes.h
  • exsUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- f -

  • frnBufferActivated : GscActionsTypes.h
  • frnDataOverwritten : GscActionsTypes.h
  • frnReconcileAborted : GscActionsTypes.h
  • frnReconcileFinished : GscActionsTypes.h
  • frnReconcileProgress : GscActionsTypes.h
  • frnReconcileStarted : GscActionsTypes.h
  • frnUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- g -

  • garContrast : GscActionsTypes.h
  • garUnknown : GscActionsTypes.h
  • garViewFieldObservation : GscActionsTypes.h
  • gvtClientPrivacyMasking : GscActionsTypes.h
  • gvtMotionPrivacy : GscActionsTypes.h
  • gvtUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- i -

  • ietBackupFile : GscActionsTypes.h
  • ietClipboard : GscActionsTypes.h
  • ietPrinter : GscActionsTypes.h
  • ietSingleImage : GscActionsTypes.h
  • ietUnknown : GscActionsTypes.h
  • ietVideoFile : GscActionsTypes.h
  • ipoPOEDelayedReset : GscActionsTypes.h
  • ipoPOEOff : GscActionsTypes.h
  • ipoPOEOn : GscActionsTypes.h
  • ipoPOEReset : GscActionsTypes.h
  • ipoUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- p -

  • pasAlarm : GscActionsTypes.h
  • pasNormal : GscActionsTypes.h
  • pasUnknown : GscActionsTypes.h
  • pbmOff : GscActionsTypes.h
  • pbmOn : GscActionsTypes.h
  • pbmUnknown : GscActionsTypes.h
  • pckCableA : GscActionsTypes.h
  • pckCableB : GscActionsTypes.h
  • pckUnknown : GscActionsTypes.h
  • pctDefault : GscActionsTypes.h
  • pctGscRegEdit : GscActionsTypes.h
  • pctGscSetup : GscActionsTypes.h
  • pctGscSupplyChain : GscActionsTypes.h
  • pctGscView : GscActionsTypes.h
  • pctGscWeb : GscActionsTypes.h
  • pctInvalid : GscActionsTypes.h
  • pctUnknown : GscActionsTypes.h
  • pdnAuto : GscActionsTypes.h
  • pdnDay : GscActionsTypes.h
  • pdnNight : GscActionsTypes.h
  • pdnUnknown : GscActionsTypes.h
  • pmcBehaviouralRuleTooDeep : GscActionsTypes.h
  • pmcCannotEnumeratePorts : GscActionsTypes.h
  • pmcCannotOpenPort : GscActionsTypes.h
  • pmcCannotSetFilter : GscActionsTypes.h
  • pmcConnectionLost : GscActionsTypes.h
  • pmcDatabaseFileMissing : GscActionsTypes.h
  • pmcDataOverflow : GscActionsTypes.h
  • pmcDBECouldNotFreeAnyPage : GscActionsTypes.h
  • pmcDemoModeExpired : GscActionsTypes.h
  • pmcDongleFound : GscActionsTypes.h
  • pmcDongleInsufficient : GscActionsTypes.h
  • pmcDongleMissing : GscActionsTypes.h
  • pmcDongleWrong : GscActionsTypes.h
  • pmcFileAccessError : GscActionsTypes.h
  • pmcFirmwareUploadFailed : GscActionsTypes.h
  • pmcFLTMInefficient : GscActionsTypes.h
  • pmcHostRestrictions : GscActionsTypes.h
  • pmcHttpError : GscActionsTypes.h
  • pmcInsufficientData : GscActionsTypes.h
  • pmcInsufficientFrameRate : GscActionsTypes.h
  • pmcInternalError : GscActionsTypes.h
  • pmcIOCannotEnumerate : GscActionsTypes.h
  • pmcIOCannotOpen : GscActionsTypes.h
  • pmcIODeviceFound : GscActionsTypes.h
  • pmcIODeviceLost : GscActionsTypes.h
  • pmcIODeviceNotFound : GscActionsTypes.h
  • pmcIODriverNotInstalled : GscActionsTypes.h
  • pmcIODuplcatedAddress : GscActionsTypes.h
  • pmcIOTemperatureAbove : GscActionsTypes.h
  • pmcIOTemperatureBelow : GscActionsTypes.h
  • pmcIOUnusedDevice : GscActionsTypes.h
  • pmcNoControlForLongTime : GscActionsTypes.h
  • pmcOutOfResources : GscActionsTypes.h
  • pmcTranscoderOverload : GscActionsTypes.h
  • pmcUnknown : GscActionsTypes.h
  • pmcUnknownError : GscActionsTypes.h
  • pmcUnlicensed : GscActionsTypes.h
  • pmcWatchdogReset : GscActionsTypes.h
  • pmsACS : GscActionsTypes.h
  • pmsATM : GscActionsTypes.h
  • pmsAutoBackup : GscActionsTypes.h
  • pmsDBE : GscActionsTypes.h
  • pmsDongle : GscActionsTypes.h
  • pmsFRC : GscActionsTypes.h
  • pmsInterface : GscActionsTypes.h
  • pmsIOI43 : GscActionsTypes.h
  • pmsLenel : GscActionsTypes.h
  • pmsLogistic : GscActionsTypes.h
  • pmsLPS : GscActionsTypes.h
  • pmsMediaAPI : GscActionsTypes.h
  • pmsMediaPlugin : GscActionsTypes.h
  • pmsMIO : GscActionsTypes.h
  • pmsPLC : GscActionsTypes.h
  • pmsPOS : GscActionsTypes.h
  • pmsPP : GscActionsTypes.h
  • pmsSCS : GscActionsTypes.h
  • pmsSensor : GscActionsTypes.h
  • pmsServer : GscActionsTypes.h
  • pmsSetup : GscActionsTypes.h
  • pmsTranscoder : GscActionsTypes.h
  • pmsUnknown : GscActionsTypes.h
  • pmsVAM : GscActionsTypes.h
  • posCleared : GscActionsTypes.h
  • posStarted : GscActionsTypes.h
  • posStopped : GscActionsTypes.h
  • posUnknown : GscActionsTypes.h
  • ppeConnectionLost : GscActionsTypes.h
  • ppeInternalError : GscActionsTypes.h
  • ppeOutOfResources : GscActionsTypes.h
  • ppeUnknown : GscActionsTypes.h
  • ppeUnknownError : GscActionsTypes.h
  • ppeUnlicensed : GscActionsTypes.h
  • ppsConnected : GscActionsTypes.h
  • ppsDisconnected : GscActionsTypes.h
  • ppsInternalState : GscActionsTypes.h
  • ppsUnknown : GscActionsTypes.h
  • prkDigitalInput : GscActionsTypes.h
  • prkDigitalOutput : GscActionsTypes.h
  • prkNotSpecified : GscActionsTypes.h
  • prkPTZHead : GscActionsTypes.h
  • prkTimeRange : GscActionsTypes.h
  • prkUnknown : GscActionsTypes.h
  • prkUser : GscActionsTypes.h
  • prkVCAllProfiles : GscActionsTypes.h
  • prkVCUserOptions : GscActionsTypes.h
  • prkVideoInput : GscActionsTypes.h
  • pscRestOfTime : GscActionsTypes.h
  • pscUnknown : GscActionsTypes.h
  • pskAux : GscActionsTypes.h
  • pskCableAFault : GscActionsTypes.h
  • pskCableBFault : GscActionsTypes.h
  • pskPath : GscActionsTypes.h
  • pskSensor : GscActionsTypes.h
  • pskService : GscActionsTypes.h
  • pskTamper : GscActionsTypes.h
  • pskTrap : GscActionsTypes.h
  • pskUnknown : GscActionsTypes.h
  • pt___int32 : GscActionsTypes.h
  • pt___int64 : GscActionsTypes.h
  • pt_ABCapacityWarning : GscActionsTypes.h
  • pt_ADArea : GscActionsTypes.h
  • pt_bool : GscActionsTypes.h
  • pt_DigitalInputState : GscActionsTypes.h
  • pt_DigitalOutputState : GscActionsTypes.h
  • pt_double : GscActionsTypes.h
  • pt_GTectClientVCAType : GscActionsTypes.h
  • pt_GTectSceneAlarmReason : GscActionsTypes.h
  • pt_GUID : GscActionsTypes.h
  • pt_IODeviceType : GscActionsTypes.h
  • pt_IPSwitchOps : GscActionsTypes.h
  • pt_LenelAccessResult : GscActionsTypes.h
  • pt_LenelEventID : GscActionsTypes.h
  • pt_LenelEventType : GscActionsTypes.h
  • pt_PlcBacklightMode : GscActionsTypes.h
  • pt_PlcBackupFormat : GscActionsTypes.h
  • pt_PlcClientType : GscActionsTypes.h
  • pt_PlcDatabaseRing : GscActionsTypes.h
  • pt_PlcDatabaseStatus : GscActionsTypes.h
  • pt_PlcDayNightMode : GscActionsTypes.h
  • pt_PlcExportAbort : GscActionsTypes.h
  • pt_PlcExportMarker : GscActionsTypes.h
  • pt_PlcExportSuccess : GscActionsTypes.h
  • pt_PlcFRCNotification : GscActionsTypes.h
  • pt_PlcImageExportType : GscActionsTypes.h
  • pt_PlcLpsStatus : GscActionsTypes.h
  • pt_PlcMessageCode : GscActionsTypes.h
  • pt_PlcMessageSource : GscActionsTypes.h
  • pt_PlcNPRRestriction : GscActionsTypes.h
  • pt_PlcObtrackCounterType : GscActionsTypes.h
  • pt_PlcObtrackExceedingDirection : GscActionsTypes.h
  • pt_PlcObtrackObjectClass : GscActionsTypes.h
  • pt_PlcObtrackObjectStatus : GscActionsTypes.h
  • pt_PlcObtrackProcessSize : GscActionsTypes.h
  • pt_PlcPluginError : GscActionsTypes.h
  • pt_PlcPluginState : GscActionsTypes.h
  • pt_PlcPOSStatus : GscActionsTypes.h
  • pt_PlcPumpStatus : GscActionsTypes.h
  • pt_PlcResourceChangeKind : GscActionsTypes.h
  • pt_PlcResourceKind : GscActionsTypes.h
  • pt_PlcSceneStoreModificationType : GscActionsTypes.h
  • pt_PlcSkidataControl : GscActionsTypes.h
  • pt_PlcSkidataMsgCodeEntry : GscActionsTypes.h
  • pt_PlcSkidataMsgCodeExit : GscActionsTypes.h
  • pt_PlcSkidataMsgCodeTransaction : GscActionsTypes.h
  • pt_PlcSpecialConstants : GscActionsTypes.h
  • pt_PlcTunnelAlarmReason : GscActionsTypes.h
  • pt_PlcViewerAlarmPlayMode : GscActionsTypes.h
  • pt_PlcViewerAlarmQueueSelection : GscActionsTypes.h
  • pt_PlcViewerAlarmState : GscActionsTypes.h
  • pt_PlcViewerPlayMode : GscActionsTypes.h
  • pt_PPAlarmState : GscActionsTypes.h
  • pt_PPCableKind : GscActionsTypes.h
  • pt_PPSensorKind : GscActionsTypes.h
  • pt_SafebagStep : GscActionsTypes.h
  • pt_string : GscActionsTypes.h
  • pt_SystemKey : GscActionsTypes.h
  • pt_SystemLED : GscActionsTypes.h
  • pt_TEventTypeID : GscActionsTypes.h
  • pt_TGLibDateTime : GscActionsTypes.h
  • pt_TMediaChannelID : GscActionsTypes.h
  • pt_TPlcRect : GscActionsTypes.h
  • pt_TrafficDirection : GscActionsTypes.h
  • pt_TResourceID : GscActionsTypes.h
  • pt_Unknown : GscActionsTypes.h
  • pt_UserLoginFailureCode : GscActionsTypes.h
  • pt_VideoInterlaceType : GscActionsTypes.h
  • pt_VideoSensorKind : GscActionsTypes.h
  • pt_VideoSignalNorm : GscActionsTypes.h
  • pt_VideoSignalType : GscActionsTypes.h
  • pt_VMDCycle : GscActionsTypes.h
  • pt_VMDGroup : GscActionsTypes.h
  • pt_widestring : GscActionsTypes.h
  • pumAmount : GscActionsTypes.h
  • pumCleared : GscActionsTypes.h
  • pumStarted : GscActionsTypes.h
  • pumStopped : GscActionsTypes.h
  • pumUnknown : GscActionsTypes.h
  • pv_ABDestination : GscActionsTypes.h
  • pv_ABSchedule : GscActionsTypes.h
  • pv_ADParameterSet : GscActionsTypes.h
  • pv_AudioInput : GscActionsTypes.h
  • pv_AudioOutput : GscActionsTypes.h
  • pv_CameraProfile : GscActionsTypes.h
  • pv_CPAParameterSet : GscActionsTypes.h
  • pv_Default : GscActionsTypes.h
  • pv_DeviceName : GscActionsTypes.h
  • pv_DeviceSubType : GscActionsTypes.h
  • pv_DeviceType : GscActionsTypes.h
  • pv_Event : GscActionsTypes.h
  • pv_ForeignKey : GscActionsTypes.h
  • pv_GTectParameterSet : GscActionsTypes.h
  • pv_HardwareModule : GscActionsTypes.h
  • pv_ImexDestination : GscActionsTypes.h
  • pv_InputContact : GscActionsTypes.h
  • pv_ObtrackParameterSet : GscActionsTypes.h
  • pv_OutputContact : GscActionsTypes.h
  • pv_PTZHead : GscActionsTypes.h
  • pv_TimeRange : GscActionsTypes.h
  • pv_Unknown : GscActionsTypes.h
  • pv_UserName : GscActionsTypes.h
  • pv_VideoInput : GscActionsTypes.h
  • pv_VideoOutput : GscActionsTypes.h
  • pv_VMDParameterSet : GscActionsTypes.h
  • pv_WindowsError : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- r -

  • rckAdded : GscActionsTypes.h
  • rckModified : GscActionsTypes.h
  • rckRemoved : GscActionsTypes.h
  • rckUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- s -

  • sbsOpen : GscActionsTypes.h
  • sbsUnknown : GscActionsTypes.h
  • sdcConnectionFailed : GscActionsTypes.h
  • sdcConnectionLost : GscActionsTypes.h
  • sdcConnectionOk : GscActionsTypes.h
  • sdcDisconnected : GscActionsTypes.h
  • sdcUnknown : GscActionsTypes.h
  • sdenCreditCard : GscActionsTypes.h
  • sdenElectronicPurse : GscActionsTypes.h
  • sdenExternalCard : GscActionsTypes.h
  • sdenTicket : GscActionsTypes.h
  • sdenUnknown : GscActionsTypes.h
  • sdexCreditCard : GscActionsTypes.h
  • sdexElectronicPurse : GscActionsTypes.h
  • sdexExternalCard : GscActionsTypes.h
  • sdexTicket : GscActionsTypes.h
  • sdexUnknown : GscActionsTypes.h
  • sdtrCash : GscActionsTypes.h
  • sdtrCheck : GscActionsTypes.h
  • sdtrCreditCard : GscActionsTypes.h
  • sdtrElectronicPurse : GscActionsTypes.h
  • sdtrInvoice : GscActionsTypes.h
  • sdtrIsoDiscount : GscActionsTypes.h
  • sdtrOther : GscActionsTypes.h
  • sdtrParking : GscActionsTypes.h
  • sdtrSale : GscActionsTypes.h
  • sdtrToken : GscActionsTypes.h
  • sdtrUnknown : GscActionsTypes.h
  • sdtrValidation : GscActionsTypes.h
  • sdtrValueCard : GscActionsTypes.h
  • smtClose : GscActionsTypes.h
  • smtCreate : GscActionsTypes.h
  • smtDelete : GscActionsTypes.h
  • smtDisplay : GscActionsTypes.h
  • smtOpen : GscActionsTypes.h
  • smtUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- t -

  • tarPark : GscActionsTypes.h
  • tarPerson : GscActionsTypes.h
  • tarUnknown : GscActionsTypes.h
  • tarWrongDirection : GscActionsTypes.h
  • tfdIn : GscActionsTypes.h
  • tfdOut : GscActionsTypes.h
  • tfdUnknown : GscActionsTypes.h
  • tfdUnspecified : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- u -

  • ulfMissingSecondUser : GscActionsTypes.h
  • ulfNoLicense : GscActionsTypes.h
  • ulfTooManyClients : GscActionsTypes.h
  • ulfUnknown : GscActionsTypes.h
  • ulfUser1InvalPwd : GscActionsTypes.h
  • ulfUser1NotFound : GscActionsTypes.h
  • ulfUser2InvalPwd : GscActionsTypes.h
  • ulfUser2NotAdmitted : GscActionsTypes.h
  • ulfUser2NotFound : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- v -

  • vasConfirmed : GscActionsTypes.h
  • vasLastConfirmed : GscActionsTypes.h
  • vasLastRemoved : GscActionsTypes.h
  • vasListConfirmed : GscActionsTypes.h
  • vasListEmpty : GscActionsTypes.h
  • vasNewAlarm : GscActionsTypes.h
  • vasPresented : GscActionsTypes.h
  • vasRemoved : GscActionsTypes.h
  • vasStacked : GscActionsTypes.h
  • vasUnknown : GscActionsTypes.h
  • vmc10s : GscActionsTypes.h
  • vmc160ms : GscActionsTypes.h
  • vmc2_5s : GscActionsTypes.h
  • vmc40ms : GscActionsTypes.h
  • vmc640ms : GscActionsTypes.h
  • vmcUnknown : GscActionsTypes.h
  • vmgGroup1 : GscActionsTypes.h
  • vmgGroup2 : GscActionsTypes.h
  • vmgGroup3 : GscActionsTypes.h
  • vmgGroup4 : GscActionsTypes.h
  • vmgUnknown : GscActionsTypes.h
  • vpmPeekLivePicture : GscActionsTypes.h
  • vpmPlayBackward : GscActionsTypes.h
  • vpmPlayBOD : GscActionsTypes.h
  • vpmPlayEOD : GscActionsTypes.h
  • vpmPlayFastBackward : GscActionsTypes.h
  • vpmPlayFastForward : GscActionsTypes.h
  • vpmPlayForward : GscActionsTypes.h
  • vpmPlayNextEvent : GscActionsTypes.h
  • vpmPlayNextMOS : GscActionsTypes.h
  • vpmPlayPrevEvent : GscActionsTypes.h
  • vpmPlayPrevMOS : GscActionsTypes.h
  • vpmPlayQuasiLive : GscActionsTypes.h
  • vpmPlayStepBackward : GscActionsTypes.h
  • vpmPlayStepForward : GscActionsTypes.h
  • vpmPlayStop : GscActionsTypes.h
  • vpmPlayStream : GscActionsTypes.h
  • vpmUnknown : GscActionsTypes.h
  • vpmUnknownMode : GscActionsTypes.h
  • vsdInterlaced : GscActionsTypes.h
  • vsdNonInterlaced : GscActionsTypes.h
  • vsdUnknown : GscActionsTypes.h
  • vskAD : GscActionsTypes.h
  • vskCPA : GscActionsTypes.h
  • vskCPAExt : GscActionsTypes.h
  • vskDUAL : GscActionsTypes.h
  • vskFR : GscActionsTypes.h
  • vskGTectVMX : GscActionsTypes.h
  • vskIPAD : GscActionsTypes.h
  • vskNPR : GscActionsTypes.h
  • vskOBTRACK : GscActionsTypes.h
  • vskUnknown : GscActionsTypes.h
  • vskVAMissing : GscActionsTypes.h
  • vskVMD : GscActionsTypes.h
  • vsnCCIR : GscActionsTypes.h
  • vsnEIA : GscActionsTypes.h
  • vsnUnknown : GscActionsTypes.h
  • vstBAS : GscActionsTypes.h
  • vstFBAS : GscActionsTypes.h
  • vstUnknown : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • g
  • i

- g -

  • GscAct_CloneHandle() : GscActions.h
  • GscAct_CloseHandle() : GscActions.h
  • GscAct_CreateABCConnect() : GscActions.h
  • GscAct_CreateABCDisconnect() : GscActions.h
  • GscAct_CreateABCPlayFile() : GscActions.h
  • GscAct_CreateAbortAllAutoBackups() : GscActions.h
  • GscAct_CreateAbortAutoBackup() : GscActions.h
  • GscAct_CreateACSAccessDenied() : GscActions.h
  • GscAct_CreateACSAccessGranted() : GscActions.h
  • GscAct_CreateACSRawAnswer() : GscActions.h
  • GscAct_CreateACSRawData() : GscActions.h
  • GscAct_CreateActivateExternalProcess() : GscActions.h
  • GscAct_CreateATMRawAnswer() : GscActions.h
  • GscAct_CreateATMRawData() : GscActions.h
  • GscAct_CreateATMTransaction() : GscActions.h
  • GscAct_CreateAutoBackupCapacityMonitoringCapacityWarning() : GscActions.h
  • GscAct_CreateAutoBackupCapacityMonitoringFileAutoDeleted() : GscActions.h
  • GscAct_CreateAutoBackupCapacityMonitoringOutOfDiskSpace() : GscActions.h
  • GscAct_CreateAutoBackupFileDone() : GscActions.h
  • GscAct_CreateAutoBackupFileProgress() : GscActions.h
  • GscAct_CreateAutoBackupFileStarted() : GscActions.h
  • GscAct_CreateAutoBackupOperationDone() : GscActions.h
  • GscAct_CreateAutoBackupOperationStarted() : GscActions.h
  • GscAct_CreateAutoBackupScheduleDone() : GscActions.h
  • GscAct_CreateAutoBackupScheduleStarted() : GscActions.h
  • GscAct_CreateAutoFocusOff() : GscActions.h
  • GscAct_CreateAutoFocusOn() : GscActions.h
  • GscAct_CreateBackupEvent() : GscActions.h
  • GscAct_CreateBarcodeData() : GscActions.h
  • GscAct_CreateBlockingFilterActivate() : GscActions.h
  • GscAct_CreateBlockingFilterDeactivate() : GscActions.h
  • GscAct_CreateCameraApplyProfile() : GscActions.h
  • GscAct_CreateCameraBacklightCompensationMode() : GscActions.h
  • GscAct_CreateCameraClearPrePosText() : GscActions.h
  • GscAct_CreateCameraDayNightMode() : GscActions.h
  • GscAct_CreateCameraLightOff() : GscActions.h
  • GscAct_CreateCameraLightOn() : GscActions.h
  • GscAct_CreateCameraManualIrisOff() : GscActions.h
  • GscAct_CreateCameraManualIrisOn() : GscActions.h
  • GscAct_CreateCameraOff() : GscActions.h
  • GscAct_CreateCameraOn() : GscActions.h
  • GscAct_CreateCameraPumpOff() : GscActions.h
  • GscAct_CreateCameraPumpOn() : GscActions.h
  • GscAct_CreateCameraRAWOutput() : GscActions.h
  • GscAct_CreateCameraSelectCharMode() : GscActions.h
  • GscAct_CreateCameraSetPrePosText() : GscActions.h
  • GscAct_CreateCameraSpecFuncUOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncUOn() : GscActions.h
  • GscAct_CreateCameraSpecFuncVOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncVOn() : GscActions.h
  • GscAct_CreateCameraSpecFuncXOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncXOn() : GscActions.h
  • GscAct_CreateCameraSpecFuncYOff() : GscActions.h
  • GscAct_CreateCameraSpecFuncYOn() : GscActions.h
  • GscAct_CreateCameraStopAll() : GscActions.h
  • GscAct_CreateCameraTextOff() : GscActions.h
  • GscAct_CreateCameraTextOn() : GscActions.h
  • GscAct_CreateCameraTourStart() : GscActions.h
  • GscAct_CreateCameraTourStop() : GscActions.h
  • GscAct_CreateCameraVersionOff() : GscActions.h
  • GscAct_CreateCameraVersionOn() : GscActions.h
  • GscAct_CreateCameraWashOff() : GscActions.h
  • GscAct_CreateCameraWashOn() : GscActions.h
  • GscAct_CreateCancelExport() : GscActions.h
  • GscAct_CreateCaseClosed() : GscActions.h
  • GscAct_CreateCaseOpened() : GscActions.h
  • GscAct_CreateChangeADParameterSet() : GscActions.h
  • GscAct_CreateChangeCameraProfile() : GscActions.h
  • GscAct_CreateChangeCPAParameterSet() : GscActions.h
  • GscAct_CreateChangeGTectParameterSet() : GscActions.h
  • GscAct_CreateChangeObtrackParameterSet() : GscActions.h
  • GscAct_CreateChangeVMDParameterSet() : GscActions.h
  • GscAct_CreateChannelError() : GscActions.h
  • GscAct_CreateChannelInfo() : GscActions.h
  • GscAct_CreateChannelLiveCheck() : GscActions.h
  • GscAct_CreateChannelWarning() : GscActions.h
  • GscAct_CreateCPAMeasurement() : GscActions.h
  • GscAct_CreateCustomAction() : GscActions.h
  • GscAct_CreateDatabaseRecordingInfoRing() : GscActions.h
  • GscAct_CreateDatabaseRecordingInfoTotal() : GscActions.h
  • GscAct_CreateDatabaseStarted() : GscActions.h
  • GscAct_CreateDefaultPosCallUp() : GscActions.h
  • GscAct_CreateDefaultPosClear() : GscActions.h
  • GscAct_CreateDefaultPosSave() : GscActions.h
  • GscAct_CreateDeviceFound() : GscActions.h
  • GscAct_CreateDeviceNewFirmware() : GscActions.h
  • GscAct_CreateDevicePluginError() : GscActions.h
  • GscAct_CreateDevicePluginState() : GscActions.h
  • GscAct_CreateDeviceReattached() : GscActions.h
  • GscAct_CreateDeviceRemoved() : GscActions.h
  • GscAct_CreateDigitalInput() : GscActions.h
  • GscAct_CreateEventBackupDone() : GscActions.h
  • GscAct_CreateEventBackupFileDone() : GscActions.h
  • GscAct_CreateEventBackupFileProgress() : GscActions.h
  • GscAct_CreateEventBackupFileStarted() : GscActions.h
  • GscAct_CreateEventBackupStarted() : GscActions.h
  • GscAct_CreateEventRecordingChanged() : GscActions.h
  • GscAct_CreateEventStarted() : GscActions.h
  • GscAct_CreateEventStartedEx() : GscActions.h
  • GscAct_CreateEventStopped() : GscActions.h
  • GscAct_CreateExportFinished() : GscActions.h
  • GscAct_CreateExportProgress() : GscActions.h
  • GscAct_CreateFastSpeedOff() : GscActions.h
  • GscAct_CreateFastSpeedOn() : GscActions.h
  • GscAct_CreateFillingPumpStatus() : GscActions.h
  • GscAct_CreateFocusFar() : GscActions.h
  • GscAct_CreateFocusNear() : GscActions.h
  • GscAct_CreateFocusStop() : GscActions.h
  • GscAct_CreateFRCNotification() : GscActions.h
  • GscAct_CreateFromBinBuffer() : GscActions.h
  • GscAct_CreateFromTextBufferA() : GscActions.h
  • GscAct_CreateFromTextBufferW() : GscActions.h
  • GscAct_CreateGEMOSalarm() : GscActions.h
  • GscAct_CreateGenericAction() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessDenied() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessExpired() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessGranted() : GscActions.h
  • GscAct_CreateGSCSVehicleAccessPending() : GscActions.h
  • GscAct_CreateGTectAnalyticsLiveCheck() : GscActions.h
  • GscAct_CreateGTectDualSensorAlarm() : GscActions.h
  • GscAct_CreateGTectDualSensorAlarmFinished() : GscActions.h
  • GscAct_CreateGTectSceneAlarm() : GscActions.h
  • GscAct_CreateGTectSceneAlarmFinished() : GscActions.h
  • GscAct_CreateGTectVMXAlarm() : GscActions.h
  • GscAct_CreateGTectVMXAlarmFinished() : GscActions.h
  • GscAct_CreateIASSettingsChanged() : GscActions.h
  • GscAct_CreateImageExportNotification() : GscActions.h
  • GscAct_CreateImexCapacityFileAutoDeleted() : GscActions.h
  • GscAct_CreateImexCapacityOutOfDiskSpace() : GscActions.h
  • GscAct_CreateImexCapacityWarning() : GscActions.h
  • GscAct_CreateImexExportEventImage() : GscActions.h
  • GscAct_CreateImexExportImageFromDB() : GscActions.h
  • GscAct_CreateImexExportImageFromLiveStream() : GscActions.h
  • GscAct_CreateInitializeRemoteExport() : GscActions.h
  • GscAct_CreateInterfaceRawAnswer() : GscActions.h
  • GscAct_CreateInterfaceRawData() : GscActions.h
  • GscAct_CreateIOI43ResetMainboard() : GscActions.h
  • GscAct_CreateIOI43Temperature() : GscActions.h
  • GscAct_CreateIOI43WDActivate() : GscActions.h
  • GscAct_CreateIOI43WDDeactivate() : GscActions.h
  • GscAct_CreateIOI43WDTrigger() : GscActions.h
  • GscAct_CreateIPCameraRawCommand() : GscActions.h
  • GscAct_CreateIPCamFailoverNotification() : GscActions.h
  • GscAct_CreateIPCamFailoverRestore() : GscActions.h
  • GscAct_CreateIPSwitchOperation() : GscActions.h
  • GscAct_CreateIrisClose() : GscActions.h
  • GscAct_CreateIrisOpen() : GscActions.h
  • GscAct_CreateIrisStop() : GscActions.h
  • GscAct_CreateKeyPressed() : GscActions.h
  • GscAct_CreateKeyReleased() : GscActions.h
  • GscAct_CreateKillAllEvents() : GscActions.h
  • GscAct_CreateKillEvent() : GscActions.h
  • GscAct_CreateKillEventByID() : GscActions.h
  • GscAct_CreateLenelAccessEvent() : GscActions.h
  • GscAct_CreateLenelFireEvent() : GscActions.h
  • GscAct_CreateLenelIntercomEvent() : GscActions.h
  • GscAct_CreateLenelRawData() : GscActions.h
  • GscAct_CreateLenelRefreshNames() : GscActions.h
  • GscAct_CreateLenelSecurityEvent() : GscActions.h
  • GscAct_CreateLenelVideoEvent() : GscActions.h
  • GscAct_CreateLiveCheck() : GscActions.h
  • GscAct_CreateLogBarcodeData() : GscActions.h
  • GscAct_CreateLogBarcodeDataLPS() : GscActions.h
  • GscAct_CreateLogNPRRecognition() : GscActions.h
  • GscAct_CreateLPSPositionData() : GscActions.h
  • GscAct_CreateLPSQueryPosition() : GscActions.h
  • GscAct_CreateMakeCPAReferenceImage() : GscActions.h
  • GscAct_CreateMatchActionFromTemplate() : GscActions.h
  • GscAct_CreateMediaChannelSetupInfo() : GscActions.h
  • GscAct_CreateMoveToAbsolutePosition() : GscActions.h
  • GscAct_CreateMoveToBySpeed() : GscActions.h
  • GscAct_CreateMoveToRelativePosition() : GscActions.h
  • GscAct_CreateNPRRawData() : GscActions.h
  • GscAct_CreateNPRRecognition() : GscActions.h
  • GscAct_CreateObtrackChannelCounter() : GscActions.h
  • GscAct_CreateObtrackChannelCounterThreshold() : GscActions.h
  • GscAct_CreateObtrackChannelSetCounter() : GscActions.h
  • GscAct_CreateObtrackFrameRawData() : GscActions.h
  • GscAct_CreateObtrackGroupCounter() : GscActions.h
  • GscAct_CreateObtrackGroupCounterThreshold() : GscActions.h
  • GscAct_CreateObtrackGroupSetCounter() : GscActions.h
  • GscAct_CreateObtrackObjectRawData() : GscActions.h
  • GscAct_CreateObtrackTunnelAlarm() : GscActions.h
  • GscAct_CreatePanAuto() : GscActions.h
  • GscAct_CreatePanLeft() : GscActions.h
  • GscAct_CreatePanRight() : GscActions.h
  • GscAct_CreatePanStop() : GscActions.h
  • GscAct_CreatePOSData() : GscActions.h
  • GscAct_CreatePOSStatus() : GscActions.h
  • GscAct_CreatePPDeviceAlarm() : GscActions.h
  • GscAct_CreatePPDeviceInput() : GscActions.h
  • GscAct_CreatePPDeviceOffline() : GscActions.h
  • GscAct_CreatePPDeviceOnline() : GscActions.h
  • GscAct_CreatePPInterfaceOffline() : GscActions.h
  • GscAct_CreatePPInterfaceOnline() : GscActions.h
  • GscAct_CreatePPQueryInterface() : GscActions.h
  • GscAct_CreatePPSetDeviceOutput() : GscActions.h
  • GscAct_CreatePPSubcellAlarm() : GscActions.h
  • GscAct_CreatePPZoneAlarm() : GscActions.h
  • GscAct_CreatePrePosCallUp() : GscActions.h
  • GscAct_CreatePrePosClear() : GscActions.h
  • GscAct_CreatePrePosSave() : GscActions.h
  • GscAct_CreateRedundantPowerFailure() : GscActions.h
  • GscAct_CreateRedundantPowerOk() : GscActions.h
  • GscAct_CreateResetMainboard() : GscActions.h
  • GscAct_CreateSafebagClose() : GscActions.h
  • GscAct_CreateSafebagData() : GscActions.h
  • GscAct_CreateSafebagOpen() : GscActions.h
  • GscAct_CreateSafebagPassingOfRiskData() : GscActions.h
  • GscAct_CreateSafebagPassingOfRiskStart() : GscActions.h
  • GscAct_CreateSafebagPassingOfRiskStop() : GscActions.h
  • GscAct_CreateSceneStoreModification() : GscActions.h
  • GscAct_CreateSensorAlarmFinished() : GscActions.h
  • GscAct_CreateSensorAudioAlarm() : GscActions.h
  • GscAct_CreateSensorInhibitAlarmFinished() : GscActions.h
  • GscAct_CreateSensorInhibitVideoAlarm() : GscActions.h
  • GscAct_CreateSensorInhibitVideoAlarmEx() : GscActions.h
  • GscAct_CreateSensorVideoAlarm() : GscActions.h
  • GscAct_CreateSensorVideoAlarmEx() : GscActions.h
  • GscAct_CreateSetCameraText() : GscActions.h
  • GscAct_CreateSetClientVCA() : GscActions.h
  • GscAct_CreateSetClock() : GscActions.h
  • GscAct_CreateSetDigitalOutput() : GscActions.h
  • GscAct_CreateSetExportMarker() : GscActions.h
  • GscAct_CreateSetLED() : GscActions.h
  • GscAct_CreateSetLEDBlink() : GscActions.h
  • GscAct_CreateSetSystemTime() : GscActions.h
  • GscAct_CreateSetTestPictureMode() : GscActions.h
  • GscAct_CreateSetupChanged() : GscActions.h
  • GscAct_CreateSetupUploadProgress() : GscActions.h
  • GscAct_CreateSetWatchdog() : GscActions.h
  • GscAct_CreateSkidataControl() : GscActions.h
  • GscAct_CreateSkidataDeviceEvent() : GscActions.h
  • GscAct_CreateSkidataEntry() : GscActions.h
  • GscAct_CreateSkidataExit() : GscActions.h
  • GscAct_CreateSkidataTransaction() : GscActions.h
  • GscAct_CreateSMRPViewerCleared() : GscActions.h
  • GscAct_CreateSMRPViewerConnected() : GscActions.h
  • GscAct_CreateSMTPMailSend() : GscActions.h
  • GscAct_CreateStartAutoBackup() : GscActions.h
  • GscAct_CreateStartEvent() : GscActions.h
  • GscAct_CreateStartEventEx() : GscActions.h
  • GscAct_CreateStartRemoteExport() : GscActions.h
  • GscAct_CreateStartSceneStore() : GscActions.h
  • GscAct_CreateStopAllEvents() : GscActions.h
  • GscAct_CreateStopEvent() : GscActions.h
  • GscAct_CreateStopEventByID() : GscActions.h
  • GscAct_CreateSystemError() : GscActions.h
  • GscAct_CreateSystemInfo() : GscActions.h
  • GscAct_CreateSystemSettingsChanged() : GscActions.h
  • GscAct_CreateSystemStarted() : GscActions.h
  • GscAct_CreateSystemTerminating() : GscActions.h
  • GscAct_CreateSystemWarning() : GscActions.h
  • GscAct_CreateTemperature() : GscActions.h
  • GscAct_CreateTerminalArticleData() : GscActions.h
  • GscAct_CreateTerminalPaymentData() : GscActions.h
  • GscAct_CreateTiltDown() : GscActions.h
  • GscAct_CreateTiltStop() : GscActions.h
  • GscAct_CreateTiltUp() : GscActions.h
  • GscAct_CreateTransferBinaryBuffer() : GscActions.h
  • GscAct_CreateTransferBinaryChannelBuffer() : GscActions.h
  • GscAct_CreateUserLogin() : GscActions.h
  • GscAct_CreateUserLoginFailed() : GscActions.h
  • GscAct_CreateUserLogout() : GscActions.h
  • GscAct_CreateVCAlarmQueueConfirm() : GscActions.h
  • GscAct_CreateVCAlarmQueueConfirmByInstance() : GscActions.h
  • GscAct_CreateVCAlarmQueueConfirmByType() : GscActions.h
  • GscAct_CreateVCAlarmQueueNotification() : GscActions.h
  • GscAct_CreateVCAlarmQueueRemove() : GscActions.h
  • GscAct_CreateVCAlarmQueueRemoveByInstance() : GscActions.h
  • GscAct_CreateVCAlarmQueueRemoveByType() : GscActions.h
  • GscAct_CreateVCAlarmQueueSelect() : GscActions.h
  • GscAct_CreateVCAlarmQueueSelectByInstance() : GscActions.h
  • GscAct_CreateVCAlarmQueueSelectByType() : GscActions.h
  • GscAct_CreateVCASetArmed() : GscActions.h
  • GscAct_CreateVCAStatusAnswer() : GscActions.h
  • GscAct_CreateVCAStatusRequest() : GscActions.h
  • GscAct_CreateVCChangeSceneByName() : GscActions.h
  • GscAct_CreateVCClearSceneByName() : GscActions.h
  • GscAct_CreateVCFullMode() : GscActions.h
  • GscAct_CreateVCSceneChanged() : GscActions.h
  • GscAct_CreateVCSetAudioLevel() : GscActions.h
  • GscAct_CreateVCShowViewerText() : GscActions.h
  • GscAct_CreateVCStretchMode() : GscActions.h
  • GscAct_CreateVideoContrastDetected() : GscActions.h
  • GscAct_CreateVideoContrastFailed() : GscActions.h
  • GscAct_CreateVideoSetImageBrightness() : GscActions.h
  • GscAct_CreateVideoSetImageContrast() : GscActions.h
  • GscAct_CreateVideoSetImageSaturation() : GscActions.h
  • GscAct_CreateVideoSourceChanged() : GscActions.h
  • GscAct_CreateVideoSyncDetected() : GscActions.h
  • GscAct_CreateVideoSyncFailed() : GscActions.h
  • GscAct_CreateViewerChangeScene() : GscActions.h
  • GscAct_CreateViewerClear() : GscActions.h
  • GscAct_CreateViewerCleared() : GscActions.h
  • GscAct_CreateViewerClearScene() : GscActions.h
  • GscAct_CreateViewerClearTextOutput() : GscActions.h
  • GscAct_CreateViewerConnect() : GscActions.h
  • GscAct_CreateViewerConnected() : GscActions.h
  • GscAct_CreateViewerConnectLive() : GscActions.h
  • GscAct_CreateViewerExportPicture() : GscActions.h
  • GscAct_CreateViewerJumpByTime() : GscActions.h
  • GscAct_CreateViewerMaximize() : GscActions.h
  • GscAct_CreateViewerPlayFromTime() : GscActions.h
  • GscAct_CreateViewerPlayModeChanged() : GscActions.h
  • GscAct_CreateViewerPrintPicture() : GscActions.h
  • GscAct_CreateViewerSelect() : GscActions.h
  • GscAct_CreateViewerSelectionChanged() : GscActions.h
  • GscAct_CreateViewerSetPlayMode() : GscActions.h
  • GscAct_CreateViewerShowAlarmByInstance() : GscActions.h
  • GscAct_CreateViewerShowAlarmByKey() : GscActions.h
  • GscAct_CreateViewerShowAlarmByType() : GscActions.h
  • GscAct_CreateViewerSyncAudioAndVideo() : GscActions.h
  • GscAct_CreateViewerTextOutput() : GscActions.h
  • GscAct_CreateWatchdogActivate() : GscActions.h
  • GscAct_CreateWatchdogDeactivate() : GscActions.h
  • GscAct_CreateWatchdogTrigger() : GscActions.h
  • GscAct_CreateZoomIn() : GscActions.h
  • GscAct_CreateZoomOut() : GscActions.h
  • GscAct_CreateZoomStop() : GscActions.h
  • GscAct_DecodeABCConnect() : GscActions.h
  • GscAct_DecodeABCDisconnect() : GscActions.h
  • GscAct_DecodeABCPlayFile() : GscActions.h
  • GscAct_DecodeAbortAllAutoBackups() : GscActions.h
  • GscAct_DecodeAbortAutoBackup() : GscActions.h
  • GscAct_DecodeACSAccessDenied() : GscActions.h
  • GscAct_DecodeACSAccessGranted() : GscActions.h
  • GscAct_DecodeACSRawAnswer() : GscActions.h
  • GscAct_DecodeACSRawData() : GscActions.h
  • GscAct_DecodeActivateExternalProcess() : GscActions.h
  • GscAct_DecodeATMRawAnswer() : GscActions.h
  • GscAct_DecodeATMRawData() : GscActions.h
  • GscAct_DecodeATMTransaction() : GscActions.h
  • GscAct_DecodeAutoBackupCapacityMonitoringCapacityWarning() : GscActions.h
  • GscAct_DecodeAutoBackupCapacityMonitoringFileAutoDeleted() : GscActions.h
  • GscAct_DecodeAutoBackupCapacityMonitoringOutOfDiskSpace() : GscActions.h
  • GscAct_DecodeAutoBackupFileDone() : GscActions.h
  • GscAct_DecodeAutoBackupFileProgress() : GscActions.h
  • GscAct_DecodeAutoBackupFileStarted() : GscActions.h
  • GscAct_DecodeAutoBackupOperationDone() : GscActions.h
  • GscAct_DecodeAutoBackupOperationStarted() : GscActions.h
  • GscAct_DecodeAutoBackupScheduleDone() : GscActions.h
  • GscAct_DecodeAutoBackupScheduleStarted() : GscActions.h
  • GscAct_DecodeAutoFocusOff() : GscActions.h
  • GscAct_DecodeAutoFocusOn() : GscActions.h
  • GscAct_DecodeBackupEvent() : GscActions.h
  • GscAct_DecodeBarcodeData() : GscActions.h
  • GscAct_DecodeBlockingFilterActivate() : GscActions.h
  • GscAct_DecodeBlockingFilterDeactivate() : GscActions.h
  • GscAct_DecodeCameraApplyProfile() : GscActions.h
  • GscAct_DecodeCameraBacklightCompensationMode() : GscActions.h
  • GscAct_DecodeCameraClearPrePosText() : GscActions.h
  • GscAct_DecodeCameraDayNightMode() : GscActions.h
  • GscAct_DecodeCameraLightOff() : GscActions.h
  • GscAct_DecodeCameraLightOn() : GscActions.h
  • GscAct_DecodeCameraManualIrisOff() : GscActions.h
  • GscAct_DecodeCameraManualIrisOn() : GscActions.h
  • GscAct_DecodeCameraOff() : GscActions.h
  • GscAct_DecodeCameraOn() : GscActions.h
  • GscAct_DecodeCameraPumpOff() : GscActions.h
  • GscAct_DecodeCameraPumpOn() : GscActions.h
  • GscAct_DecodeCameraRAWOutput() : GscActions.h
  • GscAct_DecodeCameraSelectCharMode() : GscActions.h
  • GscAct_DecodeCameraSetPrePosText() : GscActions.h
  • GscAct_DecodeCameraSpecFuncUOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncUOn() : GscActions.h
  • GscAct_DecodeCameraSpecFuncVOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncVOn() : GscActions.h
  • GscAct_DecodeCameraSpecFuncXOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncXOn() : GscActions.h
  • GscAct_DecodeCameraSpecFuncYOff() : GscActions.h
  • GscAct_DecodeCameraSpecFuncYOn() : GscActions.h
  • GscAct_DecodeCameraStopAll() : GscActions.h
  • GscAct_DecodeCameraTextOff() : GscActions.h
  • GscAct_DecodeCameraTextOn() : GscActions.h
  • GscAct_DecodeCameraTourStart() : GscActions.h
  • GscAct_DecodeCameraTourStop() : GscActions.h
  • GscAct_DecodeCameraVersionOff() : GscActions.h
  • GscAct_DecodeCameraVersionOn() : GscActions.h
  • GscAct_DecodeCameraWashOff() : GscActions.h
  • GscAct_DecodeCameraWashOn() : GscActions.h
  • GscAct_DecodeCancelExport() : GscActions.h
  • GscAct_DecodeCaseClosed() : GscActions.h
  • GscAct_DecodeCaseOpened() : GscActions.h
  • GscAct_DecodeChangeADParameterSet() : GscActions.h
  • GscAct_DecodeChangeCameraProfile() : GscActions.h
  • GscAct_DecodeChangeCPAParameterSet() : GscActions.h
  • GscAct_DecodeChangeGTectParameterSet() : GscActions.h
  • GscAct_DecodeChangeObtrackParameterSet() : GscActions.h
  • GscAct_DecodeChangeVMDParameterSet() : GscActions.h
  • GscAct_DecodeChannelError() : GscActions.h
  • GscAct_DecodeChannelInfo() : GscActions.h
  • GscAct_DecodeChannelLiveCheck() : GscActions.h
  • GscAct_DecodeChannelWarning() : GscActions.h
  • GscAct_DecodeCPAMeasurement() : GscActions.h
  • GscAct_DecodeCustomAction() : GscActions.h
  • GscAct_DecodeDatabaseRecordingInfoRing() : GscActions.h
  • GscAct_DecodeDatabaseRecordingInfoTotal() : GscActions.h
  • GscAct_DecodeDatabaseStarted() : GscActions.h
  • GscAct_DecodeDefaultPosCallUp() : GscActions.h
  • GscAct_DecodeDefaultPosClear() : GscActions.h
  • GscAct_DecodeDefaultPosSave() : GscActions.h
  • GscAct_DecodeDeviceFound() : GscActions.h
  • GscAct_DecodeDeviceNewFirmware() : GscActions.h
  • GscAct_DecodeDevicePluginError() : GscActions.h
  • GscAct_DecodeDevicePluginState() : GscActions.h
  • GscAct_DecodeDeviceReattached() : GscActions.h
  • GscAct_DecodeDeviceRemoved() : GscActions.h
  • GscAct_DecodeDigitalInput() : GscActions.h
  • GscAct_DecodeEventBackupDone() : GscActions.h
  • GscAct_DecodeEventBackupFileDone() : GscActions.h
  • GscAct_DecodeEventBackupFileProgress() : GscActions.h
  • GscAct_DecodeEventBackupFileStarted() : GscActions.h
  • GscAct_DecodeEventBackupStarted() : GscActions.h
  • GscAct_DecodeEventRecordingChanged() : GscActions.h
  • GscAct_DecodeEventStarted() : GscActions.h
  • GscAct_DecodeEventStartedEx() : GscActions.h
  • GscAct_DecodeEventStopped() : GscActions.h
  • GscAct_DecodeExportFinished() : GscActions.h
  • GscAct_DecodeExportProgress() : GscActions.h
  • GscAct_DecodeFastSpeedOff() : GscActions.h
  • GscAct_DecodeFastSpeedOn() : GscActions.h
  • GscAct_DecodeFillingPumpStatus() : GscActions.h
  • GscAct_DecodeFocusFar() : GscActions.h
  • GscAct_DecodeFocusNear() : GscActions.h
  • GscAct_DecodeFocusStop() : GscActions.h
  • GscAct_DecodeFRCNotification() : GscActions.h
  • GscAct_DecodeGEMOSalarm() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessDenied() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessExpired() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessGranted() : GscActions.h
  • GscAct_DecodeGSCSVehicleAccessPending() : GscActions.h
  • GscAct_DecodeGTectAnalyticsLiveCheck() : GscActions.h
  • GscAct_DecodeGTectDualSensorAlarm() : GscActions.h
  • GscAct_DecodeGTectDualSensorAlarmFinished() : GscActions.h
  • GscAct_DecodeGTectSceneAlarm() : GscActions.h
  • GscAct_DecodeGTectSceneAlarmFinished() : GscActions.h
  • GscAct_DecodeGTectVMXAlarm() : GscActions.h
  • GscAct_DecodeGTectVMXAlarmFinished() : GscActions.h
  • GscAct_DecodeIASSettingsChanged() : GscActions.h
  • GscAct_DecodeImageExportNotification() : GscActions.h
  • GscAct_DecodeImexCapacityFileAutoDeleted() : GscActions.h
  • GscAct_DecodeImexCapacityOutOfDiskSpace() : GscActions.h
  • GscAct_DecodeImexCapacityWarning() : GscActions.h
  • GscAct_DecodeImexExportEventImage() : GscActions.h
  • GscAct_DecodeImexExportImageFromDB() : GscActions.h
  • GscAct_DecodeImexExportImageFromLiveStream() : GscActions.h
  • GscAct_DecodeInitializeRemoteExport() : GscActions.h
  • GscAct_DecodeInterfaceRawAnswer() : GscActions.h
  • GscAct_DecodeInterfaceRawData() : GscActions.h
  • GscAct_DecodeIOI43ResetMainboard() : GscActions.h
  • GscAct_DecodeIOI43Temperature() : GscActions.h
  • GscAct_DecodeIOI43WDActivate() : GscActions.h
  • GscAct_DecodeIOI43WDDeactivate() : GscActions.h
  • GscAct_DecodeIOI43WDTrigger() : GscActions.h
  • GscAct_DecodeIPCameraRawCommand() : GscActions.h
  • GscAct_DecodeIPCamFailoverNotification() : GscActions.h
  • GscAct_DecodeIPCamFailoverRestore() : GscActions.h
  • GscAct_DecodeIPSwitchOperation() : GscActions.h
  • GscAct_DecodeIrisClose() : GscActions.h
  • GscAct_DecodeIrisOpen() : GscActions.h
  • GscAct_DecodeIrisStop() : GscActions.h
  • GscAct_DecodeKeyPressed() : GscActions.h
  • GscAct_DecodeKeyReleased() : GscActions.h
  • GscAct_DecodeKillAllEvents() : GscActions.h
  • GscAct_DecodeKillEvent() : GscActions.h
  • GscAct_DecodeKillEventByID() : GscActions.h
  • GscAct_DecodeLenelAccessEvent() : GscActions.h
  • GscAct_DecodeLenelFireEvent() : GscActions.h
  • GscAct_DecodeLenelIntercomEvent() : GscActions.h
  • GscAct_DecodeLenelRawData() : GscActions.h
  • GscAct_DecodeLenelRefreshNames() : GscActions.h
  • GscAct_DecodeLenelSecurityEvent() : GscActions.h
  • GscAct_DecodeLenelVideoEvent() : GscActions.h
  • GscAct_DecodeLiveCheck() : GscActions.h
  • GscAct_DecodeLogBarcodeData() : GscActions.h
  • GscAct_DecodeLogBarcodeDataLPS() : GscActions.h
  • GscAct_DecodeLogNPRRecognition() : GscActions.h
  • GscAct_DecodeLPSPositionData() : GscActions.h
  • GscAct_DecodeLPSQueryPosition() : GscActions.h
  • GscAct_DecodeMakeCPAReferenceImage() : GscActions.h
  • GscAct_DecodeMediaChannelSetupInfo() : GscActions.h
  • GscAct_DecodeMoveToAbsolutePosition() : GscActions.h
  • GscAct_DecodeMoveToBySpeed() : GscActions.h
  • GscAct_DecodeMoveToRelativePosition() : GscActions.h
  • GscAct_DecodeNPRRawData() : GscActions.h
  • GscAct_DecodeNPRRecognition() : GscActions.h
  • GscAct_DecodeObtrackChannelCounter() : GscActions.h
  • GscAct_DecodeObtrackChannelCounterThreshold() : GscActions.h
  • GscAct_DecodeObtrackChannelSetCounter() : GscActions.h
  • GscAct_DecodeObtrackFrameRawData() : GscActions.h
  • GscAct_DecodeObtrackGroupCounter() : GscActions.h
  • GscAct_DecodeObtrackGroupCounterThreshold() : GscActions.h
  • GscAct_DecodeObtrackGroupSetCounter() : GscActions.h
  • GscAct_DecodeObtrackObjectRawData() : GscActions.h
  • GscAct_DecodeObtrackTunnelAlarm() : GscActions.h
  • GscAct_DecodePanAuto() : GscActions.h
  • GscAct_DecodePanLeft() : GscActions.h
  • GscAct_DecodePanRight() : GscActions.h
  • GscAct_DecodePanStop() : GscActions.h
  • GscAct_DecodePOSData() : GscActions.h
  • GscAct_DecodePOSStatus() : GscActions.h
  • GscAct_DecodePPDeviceAlarm() : GscActions.h
  • GscAct_DecodePPDeviceInput() : GscActions.h
  • GscAct_DecodePPDeviceOffline() : GscActions.h
  • GscAct_DecodePPDeviceOnline() : GscActions.h
  • GscAct_DecodePPInterfaceOffline() : GscActions.h
  • GscAct_DecodePPInterfaceOnline() : GscActions.h
  • GscAct_DecodePPQueryInterface() : GscActions.h
  • GscAct_DecodePPSetDeviceOutput() : GscActions.h
  • GscAct_DecodePPSubcellAlarm() : GscActions.h
  • GscAct_DecodePPZoneAlarm() : GscActions.h
  • GscAct_DecodePrePosCallUp() : GscActions.h
  • GscAct_DecodePrePosClear() : GscActions.h
  • GscAct_DecodePrePosSave() : GscActions.h
  • GscAct_DecodeRedundantPowerFailure() : GscActions.h
  • GscAct_DecodeRedundantPowerOk() : GscActions.h
  • GscAct_DecodeResetMainboard() : GscActions.h
  • GscAct_DecodeSafebagClose() : GscActions.h
  • GscAct_DecodeSafebagData() : GscActions.h
  • GscAct_DecodeSafebagOpen() : GscActions.h
  • GscAct_DecodeSafebagPassingOfRiskData() : GscActions.h
  • GscAct_DecodeSafebagPassingOfRiskStart() : GscActions.h
  • GscAct_DecodeSafebagPassingOfRiskStop() : GscActions.h
  • GscAct_DecodeSceneStoreModification() : GscActions.h
  • GscAct_DecodeSensorAlarmFinished() : GscActions.h
  • GscAct_DecodeSensorAudioAlarm() : GscActions.h
  • GscAct_DecodeSensorInhibitAlarmFinished() : GscActions.h
  • GscAct_DecodeSensorInhibitVideoAlarm() : GscActions.h
  • GscAct_DecodeSensorInhibitVideoAlarmEx() : GscActions.h
  • GscAct_DecodeSensorVideoAlarm() : GscActions.h
  • GscAct_DecodeSensorVideoAlarmEx() : GscActions.h
  • GscAct_DecodeSetCameraText() : GscActions.h
  • GscAct_DecodeSetClientVCA() : GscActions.h
  • GscAct_DecodeSetClock() : GscActions.h
  • GscAct_DecodeSetDigitalOutput() : GscActions.h
  • GscAct_DecodeSetExportMarker() : GscActions.h
  • GscAct_DecodeSetLED() : GscActions.h
  • GscAct_DecodeSetLEDBlink() : GscActions.h
  • GscAct_DecodeSetSystemTime() : GscActions.h
  • GscAct_DecodeSetTestPictureMode() : GscActions.h
  • GscAct_DecodeSetupChanged() : GscActions.h
  • GscAct_DecodeSetupUploadProgress() : GscActions.h
  • GscAct_DecodeSetWatchdog() : GscActions.h
  • GscAct_DecodeSkidataControl() : GscActions.h
  • GscAct_DecodeSkidataDeviceEvent() : GscActions.h
  • GscAct_DecodeSkidataEntry() : GscActions.h
  • GscAct_DecodeSkidataExit() : GscActions.h
  • GscAct_DecodeSkidataTransaction() : GscActions.h
  • GscAct_DecodeSMRPViewerCleared() : GscActions.h
  • GscAct_DecodeSMRPViewerConnected() : GscActions.h
  • GscAct_DecodeSMTPMailSend() : GscActions.h
  • GscAct_DecodeStartAutoBackup() : GscActions.h
  • GscAct_DecodeStartEvent() : GscActions.h
  • GscAct_DecodeStartEventEx() : GscActions.h
  • GscAct_DecodeStartRemoteExport() : GscActions.h
  • GscAct_DecodeStartSceneStore() : GscActions.h
  • GscAct_DecodeStopAllEvents() : GscActions.h
  • GscAct_DecodeStopEvent() : GscActions.h
  • GscAct_DecodeStopEventByID() : GscActions.h
  • GscAct_DecodeSystemError() : GscActions.h
  • GscAct_DecodeSystemInfo() : GscActions.h
  • GscAct_DecodeSystemSettingsChanged() : GscActions.h
  • GscAct_DecodeSystemStarted() : GscActions.h
  • GscAct_DecodeSystemTerminating() : GscActions.h
  • GscAct_DecodeSystemWarning() : GscActions.h
  • GscAct_DecodeTemperature() : GscActions.h
  • GscAct_DecodeTerminalArticleData() : GscActions.h
  • GscAct_DecodeTerminalPaymentData() : GscActions.h
  • GscAct_DecodeTiltDown() : GscActions.h
  • GscAct_DecodeTiltStop() : GscActions.h
  • GscAct_DecodeTiltUp() : GscActions.h
  • GscAct_DecodeTransferBinaryBuffer() : GscActions.h
  • GscAct_DecodeTransferBinaryChannelBuffer() : GscActions.h
  • GscAct_DecodeUserLogin() : GscActions.h
  • GscAct_DecodeUserLoginFailed() : GscActions.h
  • GscAct_DecodeUserLogout() : GscActions.h
  • GscAct_DecodeVCAlarmQueueConfirm() : GscActions.h
  • GscAct_DecodeVCAlarmQueueConfirmByInstance() : GscActions.h
  • GscAct_DecodeVCAlarmQueueConfirmByType() : GscActions.h
  • GscAct_DecodeVCAlarmQueueNotification() : GscActions.h
  • GscAct_DecodeVCAlarmQueueRemove() : GscActions.h
  • GscAct_DecodeVCAlarmQueueRemoveByInstance() : GscActions.h
  • GscAct_DecodeVCAlarmQueueRemoveByType() : GscActions.h
  • GscAct_DecodeVCAlarmQueueSelect() : GscActions.h
  • GscAct_DecodeVCAlarmQueueSelectByInstance() : GscActions.h
  • GscAct_DecodeVCAlarmQueueSelectByType() : GscActions.h
  • GscAct_DecodeVCASetArmed() : GscActions.h
  • GscAct_DecodeVCAStatusAnswer() : GscActions.h
  • GscAct_DecodeVCAStatusRequest() : GscActions.h
  • GscAct_DecodeVCChangeSceneByName() : GscActions.h
  • GscAct_DecodeVCClearSceneByName() : GscActions.h
  • GscAct_DecodeVCFullMode() : GscActions.h
  • GscAct_DecodeVCSceneChanged() : GscActions.h
  • GscAct_DecodeVCSetAudioLevel() : GscActions.h
  • GscAct_DecodeVCShowViewerText() : GscActions.h
  • GscAct_DecodeVCStretchMode() : GscActions.h
  • GscAct_DecodeVideoContrastDetected() : GscActions.h
  • GscAct_DecodeVideoContrastFailed() : GscActions.h
  • GscAct_DecodeVideoSetImageBrightness() : GscActions.h
  • GscAct_DecodeVideoSetImageContrast() : GscActions.h
  • GscAct_DecodeVideoSetImageSaturation() : GscActions.h
  • GscAct_DecodeVideoSourceChanged() : GscActions.h
  • GscAct_DecodeVideoSyncDetected() : GscActions.h
  • GscAct_DecodeVideoSyncFailed() : GscActions.h
  • GscAct_DecodeViewerChangeScene() : GscActions.h
  • GscAct_DecodeViewerClear() : GscActions.h
  • GscAct_DecodeViewerCleared() : GscActions.h
  • GscAct_DecodeViewerClearScene() : GscActions.h
  • GscAct_DecodeViewerClearTextOutput() : GscActions.h
  • GscAct_DecodeViewerConnect() : GscActions.h
  • GscAct_DecodeViewerConnected() : GscActions.h
  • GscAct_DecodeViewerConnectLive() : GscActions.h
  • GscAct_DecodeViewerExportPicture() : GscActions.h
  • GscAct_DecodeViewerJumpByTime() : GscActions.h
  • GscAct_DecodeViewerMaximize() : GscActions.h
  • GscAct_DecodeViewerPlayFromTime() : GscActions.h
  • GscAct_DecodeViewerPlayModeChanged() : GscActions.h
  • GscAct_DecodeViewerPrintPicture() : GscActions.h
  • GscAct_DecodeViewerSelect() : GscActions.h
  • GscAct_DecodeViewerSelectionChanged() : GscActions.h
  • GscAct_DecodeViewerSetPlayMode() : GscActions.h
  • GscAct_DecodeViewerShowAlarmByInstance() : GscActions.h
  • GscAct_DecodeViewerShowAlarmByKey() : GscActions.h
  • GscAct_DecodeViewerShowAlarmByType() : GscActions.h
  • GscAct_DecodeViewerSyncAudioAndVideo() : GscActions.h
  • GscAct_DecodeViewerTextOutput() : GscActions.h
  • GscAct_DecodeWatchdogActivate() : GscActions.h
  • GscAct_DecodeWatchdogDeactivate() : GscActions.h
  • GscAct_DecodeWatchdogTrigger() : GscActions.h
  • GscAct_DecodeZoomIn() : GscActions.h
  • GscAct_DecodeZoomOut() : GscActions.h
  • GscAct_DecodeZoomStop() : GscActions.h
  • GscAct_DuplicateHandle() : GscActions.h
  • GscAct_EnumerateActionClasses() : GscActions.h
  • GscAct_EnumerateActionParameters() : GscActions.h
  • GscAct_EnumerateActions() : GscActions.h
  • GscAct_EnumerateEnumValues() : GscActions.h
  • GscAct_EnumerateEventFields() : GscActions.h
  • GscAct_Equal() : GscActions.h
  • GscAct_GetActionClass() : GscActions.h
  • GscAct_GetActionClassByNameA() : GscActions.h
  • GscAct_GetActionClassByNameW() : GscActions.h
  • GscAct_GetActionClassInfo() : GscActions.h
  • GscAct_GetActionCode() : GscActions.h
  • GscAct_GetActionCodeByIndex() : GscActions.h
  • GscAct_GetActionCodeByNameA() : GscActions.h
  • GscAct_GetActionCodeByNameW() : GscActions.h
  • GscAct_GetActionEventData() : GscActions.h
  • GscAct_GetActionEventDescription() : GscActions.h
  • GscAct_GetActionInfo() : GscActions.h
  • GscAct_GetActionNameA() : GscActions.h
  • GscAct_GetActionNameW() : GscActions.h
  • GscAct_GetActionParameterInfo() : GscActions.h
  • GscAct_GetActionPlainNameA() : GscActions.h
  • GscAct_GetActionPlainNameW() : GscActions.h
  • GscAct_GetEnumValueInfo() : GscActions.h
  • GscAct_GetEventDescriptionInfo() : GscActions.h
  • GscAct_GetEventFieldInfo() : GscActions.h
  • GscAct_GetForeignKey() : GscActions.h
  • GscAct_GetGenericInt32Parameter() : GscActions.h
  • GscAct_GetInputContact() : GscActions.h
  • GscAct_GetInternalData() : GscActions.h
  • GscAct_GetInternalIndex() : GscActions.h
  • GscAct_GetInternalIndexByCode() : GscActions.h
  • GscAct_GetLastError() : GscActions.h
  • GscAct_GetMatchActionDescriptionInfo() : GscActions.h
  • GscAct_GetMessageClass() : GscActions.h
  • GscAct_GetMessageFlags() : GscActions.h
  • GscAct_GetNativeTranslation() : GscActions.h
  • GscAct_GetNumberOfActionClasses() : GscActions.h
  • GscAct_GetNumberOfActionParameters() : GscActions.h
  • GscAct_GetNumberOfActions() : GscActions.h
  • GscAct_GetNumberOfEnumValues() : GscActions.h
  • GscAct_GetNumberOfOpenHandles() : GscActions.h
  • GscAct_GetOutputContact() : GscActions.h
  • GscAct_GetProperties() : GscActions.h
  • GscAct_GetProperty() : GscActions.h
  • GscAct_GetReferenceCounter() : GscActions.h
  • GscAct_GetVideoInput() : GscActions.h
  • GscAct_GetVideoOutput() : GscActions.h
  • GscAct_GetWindowsClientInfo() : GscActions.h
  • GscAct_InterfaceDate() : GscActions.h
  • GscAct_InterfaceVersion() : GscActions.h
  • GscAct_RestoreActionFromEventData() : GscActions.h
  • GscAct_SetActionClassPlainInfo() : GscActions.h
  • GscAct_SetActionParameterPlainInfo() : GscActions.h
  • GscAct_SetActionPlainInfo() : GscActions.h
  • GscAct_SetEnumValuePlainInfo() : GscActions.h
  • GscAct_SetEventDescriptionPlainInfo() : GscActions.h
  • GscAct_SetEventFieldPlainInfo() : GscActions.h
  • GscAct_SetInternalData() : GscActions.h
  • GscAct_SetMatchActionDescriptionPlainInfo() : GscActions.h
  • GscAct_SetMessageFlags() : GscActions.h
  • GscAct_SetNativeTranslation() : GscActions.h
  • GscAct_SetProperty() : GscActions.h
  • GscAct_StoreToBinBuffer() : GscActions.h
  • GscAct_StoreToTextBufferA() : GscActions.h
  • GscAct_StoreToTextBufferW() : GscActions.h
  • GscAct_UpdateActionInfo() : GscActions.h
  • GscAct_UpdateWindowsClientInfo() : GscActions.h
  • GscMatchAct_CreateActionFromTemplate() : GscActions.h
  • GscMatchAct_GetActionClass() : GscActions.h
  • GscMatchAct_GetActionCode() : GscActions.h
  • GscMatchAct_GetActionEventData() : GscActions.h
  • GscMatchAct_GetActionNameA() : GscActions.h
  • GscMatchAct_GetActionNameW() : GscActions.h
  • GscMatchAct_GetActionPlainNameA() : GscActions.h
  • GscMatchAct_GetActionPlainNameW() : GscActions.h
  • GscMatchAct_GetCommentA() : GscActions.h
  • GscMatchAct_GetCommentW() : GscActions.h
  • GscMatchAct_GetDescriptionA() : GscActions.h
  • GscMatchAct_GetDescriptionW() : GscActions.h
  • GscMatchAct_HasDescription() : GscActions.h
  • GscMatchAct_Matches() : GscActions.h
  • GscMatchAct_RestoreActionFromEventData() : GscActions.h
  • GscMatchAct_SetCommentA() : GscActions.h
  • GscMatchAct_SetCommentW() : GscActions.h
  • GscMatchAct_SetDescriptionA() : GscActions.h
  • GscMatchAct_SetDescriptionW() : GscActions.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • g
  • i

- i -

  • IsGscEnumType() : GscActionsTypes.h


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • g
  • h
  • i
  • l
  • p
  • s
  • t
  • u
  • v
  • w

- a -

  • ABCapacityWarning : GscActionsTypes.h
  • ADArea : GscActionsTypes.h

- c -

  • ConstHGscAction : GscActions.h
  • ConstHGscMatchAction : GscActions.h
  • ConstHGscMessage : GscActions.h

- d -

  • DigitalInputState : GscActionsTypes.h
  • DigitalOutputState : GscActionsTypes.h

- g -

  • GTectClientVCAType : GscActionsTypes.h
  • GTectSceneAlarmReason : GscActionsTypes.h

- h -

  • HGscAction : GscActions.h
  • HGscMatchAction : GscActions.h
  • HGscMessage : GscActions.h

- i -

  • IODeviceType : GscActionsTypes.h
  • IPSwitchOps : GscActionsTypes.h

- l -

  • LenelAccessResult : GscActionsTypes.h
  • LenelEventID : GscActionsTypes.h
  • LenelEventType : GscActionsTypes.h

- p -

  • PlcBacklightMode : GscActionsTypes.h
  • PlcBackupFormat : GscActionsTypes.h
  • PlcClientType : GscActionsTypes.h
  • PlcDatabaseRing : GscActionsTypes.h
  • PlcDatabaseStatus : GscActionsTypes.h
  • PlcDayNightMode : GscActionsTypes.h
  • PlcExportAbort : GscActionsTypes.h
  • PlcExportMarker : GscActionsTypes.h
  • PlcExportSuccess : GscActionsTypes.h
  • PlcFRCNotification : GscActionsTypes.h
  • PlcImageExportType : GscActionsTypes.h
  • PlcLpsStatus : GscActionsTypes.h
  • PlcMessageCode : GscActionsTypes.h
  • PlcMessageSource : GscActionsTypes.h
  • PlcNPRRestriction : GscActionsTypes.h
  • PlcObtrackCounterType : GscActionsTypes.h
  • PlcObtrackExceedingDirection : GscActionsTypes.h
  • PlcObtrackObjectClass : GscActionsTypes.h
  • PlcObtrackObjectStatus : GscActionsTypes.h
  • PlcObtrackProcessSize : GscActionsTypes.h
  • PlcPluginError : GscActionsTypes.h
  • PlcPluginState : GscActionsTypes.h
  • PlcPOSStatus : GscActionsTypes.h
  • PlcPumpStatus : GscActionsTypes.h
  • PlcResourceChangeKind : GscActionsTypes.h
  • PlcResourceKind : GscActionsTypes.h
  • PlcSceneStoreModificationType : GscActionsTypes.h
  • PlcSkidataControl : GscActionsTypes.h
  • PlcSkidataMsgCodeEntry : GscActionsTypes.h
  • PlcSkidataMsgCodeExit : GscActionsTypes.h
  • PlcSkidataMsgCodeTransaction : GscActionsTypes.h
  • PlcSpecialConstants : GscActionsTypes.h
  • PlcTunnelAlarmReason : GscActionsTypes.h
  • PlcViewerAlarmPlayMode : GscActionsTypes.h
  • PlcViewerAlarmQueueSelection : GscActionsTypes.h
  • PlcViewerAlarmState : GscActionsTypes.h
  • PlcViewerPlayMode : GscActionsTypes.h
  • PPAlarmState : GscActionsTypes.h
  • PPCableKind : GscActionsTypes.h
  • PPSensorKind : GscActionsTypes.h

- s -

  • SafebagStep : GscActionsTypes.h
  • string : stl.txt
  • SystemKey : GscActionsTypes.h
  • SystemLED : GscActionsTypes.h

- t -

  • TADParameterSetID : stl.txt
  • TEventTypeID : stl.txt
  • TMediaChannelID : stl.txt
  • TPlcGetEventDataCallback : GscActions.h
  • TPlcTimeRangeID : GscActionsTypes.h
  • TrafficDirection : GscActionsTypes.h
  • TResourceID : stl.txt
  • TTimeRangeID : stl.txt
  • TUpdateEventTypeID : GscActionsTypes.h
  • TUpdateMediaChannelID : GscActionsTypes.h
  • TUpdateResChannelID : GscActionsTypes.h
  • TUpdateResourceID : GscActionsTypes.h
  • TVMDParameterSetID : stl.txt

- u -

  • UserLoginFailureCode : GscActionsTypes.h

- v -

  • VideoInterlaceType : GscActionsTypes.h
  • VideoSensorKind : GscActionsTypes.h
  • VideoSignalNorm : GscActionsTypes.h
  • VideoSignalType : GscActionsTypes.h
  • VMDCycle : GscActionsTypes.h
  • VMDGroup : GscActionsTypes.h

- w -

  • widestring : stl.txt


GSC actions: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • FlagDisableInternalInEventData : GscActionsTypes.h
  • FlagDisableResourceUpdate : GscActionsTypes.h
  • GscActionAPIDate : GscActions.h
  • GscActionAPIVersion : GscActions.h
  • GscActionsDll : GscActions.h
  • PLC_DISABLE_MATCH_BY : GscActionsTypes.h
  • PLC_DISABLE_ON_MATCH : GscActionsTypes.h
  • TPlcUpdateActionInfoCallbackVersion : GscActionsTypes.h


GSC actions: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


GSC actions: stl.txt File Reference

  • File List
  • File Members
Classes | Typedefs

stl.txt File Reference

Detailed Description

Pass selected STL declarations to doxygen.

Definition in file stl.txt.

Classes

class | __int64
64-bit integer More...
class | __int32
32-bit integer More...
class | double
64-bit floating-point number More...
class | bool
Boolean value. More...
class | GUID
GUID value. More...
class | TGLibDateTime
Date time value. More...

Typedefs

typedef TPlcMediaChannelID | TMediaChannelID
typedef TPlcEventTypeID | TEventTypeID
typedef TPlcResourceID | TResourceID
typedef TPlcResourceID | TTimeRangeID
typedef TPlcResourceID | TADParameterSetID
typedef TPlcResourceID | TVMDParameterSetID
typedef const char * | string
typedef const wchar_t * | widestring

Typedef Documentation

typedef TPlcMediaChannelID TMediaChannelID

Definition at line 39 of file stl.txt.

typedef TPlcEventTypeID TEventTypeID

Definition at line 40 of file stl.txt.

typedef TPlcResourceID TResourceID

Definition at line 41 of file stl.txt.

typedef TPlcResourceID TTimeRangeID

Definition at line 42 of file stl.txt.

typedef TPlcResourceID TADParameterSetID

Definition at line 43 of file stl.txt.

typedef TPlcResourceID TVMDParameterSetID

Definition at line 44 of file stl.txt.

typedef const char* string

Definition at line 45 of file stl.txt.

typedef const wchar_t* widestring

Definition at line 46 of file stl.txt.


GSC actions: GscActionsDlgs.h Source File

  • File List
  • File Members

Standard C++ Library

The Standard C++ Library is a large and comprehensive collection of classes and functions for fine-grained, low-level programming. It is NOT a part of GeViScope SDK. Please consult documentation of your development environment on how to use it.


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscActionClassInfo Member List

This is the complete list of members for TGscActionClassInfo, including all inherited members.
ActionClass | TGscActionClassInfo
NameA | TGscActionClassInfo
NameW | TGscActionClassInfo
Reserved | TGscActionClassInfo


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscActionClassPlainInfo Member List

This is the complete list of members for TGscActionClassPlainInfo, including all inherited members.
ActionClass | TGscActionClassInfo
DescriptionA | TGscActionClassPlainInfo
DescriptionU | TGscActionClassPlainInfo
DescriptionW | TGscActionClassPlainInfo
NameA | TGscActionClassInfo
NameW | TGscActionClassInfo
PlainNameA | TGscActionClassPlainInfo
PlainNameU | TGscActionClassPlainInfo
PlainNameW | TGscActionClassPlainInfo
Reserved | TGscActionClassInfo


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscActionInfo Member List

This is the complete list of members for TGscActionInfo, including all inherited members.
ActionClass | TGscActionInfo |
ActionCode | TGscActionInfo |
ActionSetupMask | TGscActionInfo |
DisableMatchBy() const | TGscActionInfo | [inline]
DisableOnMatch() const | TGscActionInfo | [inline]
NameA | TGscActionInfo |
NameW | TGscActionInfo |
NumberOfParameters | TGscActionInfo |


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscActionPlainInfo Member List

This is the complete list of members for TGscActionPlainInfo, including all inherited members.
ActionClass | TGscActionInfo |
ActionCode | TGscActionInfo |
ActionSetupMask | TGscActionInfo |
DescriptionA | TGscActionPlainInfo |
DescriptionU | TGscActionPlainInfo |
DescriptionW | TGscActionPlainInfo |
DisableMatchBy() const | TGscActionInfo | [inline]
DisableOnMatch() const | TGscActionInfo | [inline]
NameA | TGscActionInfo |
NameW | TGscActionInfo |
NumberOfParameters | TGscActionInfo |
PlainNameA | TGscActionPlainInfo |
PlainNameU | TGscActionPlainInfo |
PlainNameW | TGscActionPlainInfo |


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscEnumInfo Member List

This is the complete list of members for TGscEnumInfo, including all inherited members.
EnumType | TGscEnumInfo
EnumValue | TGscEnumInfo
NameA | TGscEnumInfo
NameW | TGscEnumInfo


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscEnumPlainInfo Member List

This is the complete list of members for TGscEnumPlainInfo, including all inherited members.
EnumType | TGscEnumInfo
EnumValue | TGscEnumInfo
NameA | TGscEnumInfo
NameW | TGscEnumInfo
PlainNameA | TGscEnumPlainInfo
PlainNameU | TGscEnumPlainInfo
PlainNameW | TGscEnumPlainInfo
Reserved | TGscEnumPlainInfo


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscParameterInfo Member List

This is the complete list of members for TGscParameterInfo, including all inherited members.
DisableMatchBy() const | TGscParameterInfo | [inline]
DisableOnMatch() const | TGscParameterInfo | [inline]
NameA | TGscParameterInfo |
NameW | TGscParameterInfo |
ParameterSetupMask | TGscParameterInfo |
ParameterType | TGscParameterInfo |
ParameterView | TGscParameterInfo |
Reserved | TGscParameterInfo |


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGscParameterPlainInfo Member List

This is the complete list of members for TGscParameterPlainInfo, including all inherited members.
DescriptionA | TGscParameterPlainInfo |
DescriptionU | TGscParameterPlainInfo |
DescriptionW | TGscParameterPlainInfo |
DisableMatchBy() const | TGscParameterInfo | [inline]
DisableOnMatch() const | TGscParameterInfo | [inline]
NameA | TGscParameterInfo |
NameW | TGscParameterInfo |
ParameterSetupMask | TGscParameterInfo |
ParameterType | TGscParameterInfo |
ParameterView | TGscParameterInfo |
PlainNameA | TGscParameterPlainInfo |
PlainNameU | TGscParameterPlainInfo |
PlainNameW | TGscParameterPlainInfo |
Reserved | TGscParameterInfo |


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TPlcActionEventDataRecord Member List

This is the complete list of members for TPlcActionEventDataRecord, including all inherited members.
Clear() | TPlcActionEventDataRecord | [inline]
EventData | TPlcActionEventDataRecord |
EventDataID | TPlcActionEventDataRecord |
EventDataKind | TPlcActionEventDataRecord |
EventDataSize | TPlcActionEventDataRecord |
EventDataTime | TPlcActionEventDataRecord |
EventDouble_A | TPlcActionEventDataRecord |
EventDouble_B | TPlcActionEventDataRecord |
EventID | TPlcActionEventDataRecord |
EventInt32_A | TPlcActionEventDataRecord |
EventInt32_B | TPlcActionEventDataRecord |
EventInt32_C | TPlcActionEventDataRecord |
EventInt32_D | TPlcActionEventDataRecord |
EventInt64_A | TPlcActionEventDataRecord |
EventInt64_B | TPlcActionEventDataRecord |
EventInt64_C | TPlcActionEventDataRecord |
EventInt64_D | TPlcActionEventDataRecord |
EventString_A | TPlcActionEventDataRecord |
EventString_A_Size | TPlcActionEventDataRecord |
EventString_B | TPlcActionEventDataRecord |
EventString_B_Size | TPlcActionEventDataRecord |
EventTime_A | TPlcActionEventDataRecord |
EventTime_B | TPlcActionEventDataRecord |
StructSize | TPlcActionEventDataRecord |
TPlcActionEventDataRecord() | TPlcActionEventDataRecord | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TPlcEventTypeID Member List

This is the complete list of members for TPlcEventTypeID, including all inherited members.
EventName | TPlcEventTypeID |
EventTypeID | TPlcEventTypeID |
Reserved | TPlcEventTypeID |
TPlcEventTypeID() | TPlcEventTypeID | [inline]
TPlcEventTypeID(const __int64 &anEventTypeID, const wchar_t *anEventName) | TPlcEventTypeID | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TPlcLastError Member List

This is the complete list of members for TPlcLastError, including all inherited members.
ClassName | TPlcLastError
ErrorClass | TPlcLastError
ErrorCode | TPlcLastError
ErrorMessageA | TPlcLastError
ErrorMessageW | TPlcLastError
XMLInfo | TPlcLastError


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TPlcMediaChannelID Member List

This is the complete list of members for TPlcMediaChannelID, including all inherited members.
ChannelID | TPlcMediaChannelID |
ChannelName | TPlcMediaChannelID |
GlobalNo | TPlcMediaChannelID |
TPlcMediaChannelID() | TPlcMediaChannelID | [inline]
TPlcMediaChannelID(__int32 aGlobalNo) | TPlcMediaChannelID | [inline]
TPlcMediaChannelID(const __int64 &aChannelID, const wchar_t *aChannelName, __int32 aGlobalNo) | TPlcMediaChannelID | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TPlcRect Member List

This is the complete list of members for TPlcRect, including all inherited members.
Bottom | TPlcRect |
Left | TPlcRect |
operator!=(const TPlcRect &Other) const | TPlcRect | [inline]
operator==(const TPlcRect &Other) const | TPlcRect | [inline]
Right | TPlcRect |
Top | TPlcRect |
TPlcRect(__int16 aTop=0, __int16 aLeft=0, __int16 aBottom=0, __int16 aRight=0) | TPlcRect | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TPlcResourceID Member List

This is the complete list of members for TPlcResourceID, including all inherited members.
Reserved | TPlcResourceID |
ResourceID | TPlcResourceID |
ResourceName | TPlcResourceID |
TPlcResourceID() | TPlcResourceID | [inline]
TPlcResourceID(const GUID &aResourceID, const wchar_t *aResourceName) | TPlcResourceID | [inline]


GSC actions: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TPlcUpdateActionInfoCallback Member List

This is the complete list of members for TPlcUpdateActionInfoCallback, including all inherited members.
UpdateEventType | TPlcUpdateActionInfoCallback
UpdateInputContact | TPlcUpdateActionInfoCallback
UpdateOutputContact | TPlcUpdateActionInfoCallback
UpdateParameterSet | TPlcUpdateActionInfoCallback
UpdateResource | TPlcUpdateActionInfoCallback
UpdateVideoInput | TPlcUpdateActionInfoCallback
UpdateVideoOutput | TPlcUpdateActionInfoCallback
Version | TPlcUpdateActionInfoCallback